Introduction

The following controls are contained in the MindFusion Pack for WinForms:

MindFusion.Charting

MindFusion.Charting is a multi-functional graphics component that draws different types of charts.

MindFusion.Diagramming

MindFusion.Diagramming can be used to display various types of diagrams and charts, in many different formats.

MindFusion.Reporting

MindFusion.Reporting can be used to design, display and print various types of reports and charts.

MindFusion.Scheduling

MindFusion.Scheduling can be used to present calendars and timetables to users and let them edit the schedule information interactively.

© 2009 MindFusion


Programming Interface Overview

© 2009 MindFusion


MindFusion.Charting Overview

© 2009 MindFusion


Basic Chart Types

With MindFusion.Charting, you can create four types of charts:

  • Line/area/scatter/bubble charts
  • Bar/cylinder charts
  • Pie/doughnut charts
  • Radar/polar charts

You can create each of them either programmatically or by dragging the appropriate chart control onto your application with the mouse in Windows Windows Forms.

You must first load the appropriate DLL - MindFusion.Charting.WinForms.dllMindFusion.Charting.WinForms.dll. It creates 4 icons in the Toolbox pane - for bar, line/area, pie/doughnut and radar/polar charts.

Programmatically four different classes - BarChart class, LineChart class, PieChart class and RadarChart class implement the creation of chart objects. There is an AxisSettings class, which holds the settings for the chart axis. The Chart class holds the properties shared by all charts while AxesChart has only the properties used by charts with axes.

Change the type of the chart with the BarChart.BarType, LineChart.LineType, PieChart.PieType and RadarChart.RadarType properties. When using MindFusion.Charting programmatically, specify the chart type in the constructor. It can be changed later through the respective property.

See Also

Creating Bar Charts
Creating Line Charts
Creating Area Charts
Creating Scatter Charts
Creating Pie Charts
Creating Radar Charts
Creating Bubble Charts


Setting the Chart's Data

Charts that use the Cartesian coordinate system use two basic properties for setting the data - XData and YData. A third data property is also available - Y2Data and it is used by the second Y-axis. Those properties are of type IList and hold other lists with the data. The member lists can be different in count. The count of graphics in vertical charts depends on the YData property; the count of graphics in horizontal charts depends on XData.

In bubble charts, the Y2Data property is used as a third data array, which determines the radius of the bubble. In such cases, the second Y axis is not drawn. When no Y2Data is specified, the bubble radius is calculated based on the YData values.

Pie, bar and radar charts use a single property called Data (See PieChart.Data, BarChart.Data, RadarChart.Data).

Data in line chars can be either numbers or DateTime values. The rest of the charts support only numbers. Data of any format is acceptable as long as it can be converted to numbers or DateTime values using the standard .NET DoubleConverter and DateTimeConverter classes. Negative values for all charts that use the Cartesian coordinate system are supported.

In bar charts of type Groups2D/Groups3D, each group is drawn with data from the subsequent array in the Data property and each data series forms one group. When the BarType is Clustered2D / Clustered3D, each cluster is built with the numbers placed at the same positions in each array in the Data property.

Pie charts cannot have more than one graphics. If you need to draw several pies, add several instances of the PieChart control to your application.

MindFusion.Charting supports database binding. Check DataMember DataMember and DataSource DataSource properties for further details. Read the BarChart Members, PieChart Members, LineChart Members and RadarChart Members for more information about the properties for the specific chart type, which can be bound to database fields.

See Also

Using DateTime Values
Axes of the Chart
Adding Summary Values
Retrieving Chart Data from a Database


Customizing the Axis Appearance

The appearance settings of all chart axes are set with the properties of the AxisSettings class. They can be accessed directly through the chart's XAxisSettings, YAxisSettings and Y2AxisSettings properties.

Each axis can have a title and explanation labels. The title is set with TitleLabel and is drawn with TitleLabelBrush and TitleLabelFont. Its position and alignment is set with TitleLabelPosition and TitleLabelAlignment. The type of explanation labels depends on LabelType. They are drawn with LabelBrush and LabelFont. Labels are drawn by default at the chart axis. If you want them outside the plot area, set LabelAtTheAxis to false.

Chart axes can be drawn with division markers for better visualisation. The property is called DivMarkerLength.

Chart numbers can be cancelled when too big. The DivisionCoef property specifies the divisor. The unit of measure is set with DivisionLabel.

The format of numbers at the axis is specified with the NumberFormat property. The numerical scale can be regulated with the MinValue, MaxValue and AxisDelta properties.

Labels at the X-axis can be drawn with a rotation angle as specified with the RotationAngle property.

The zero number is not drawn explicitly. Use DrawZero to specify whether the zero is drawn or not.

The inner scale in radar charts is calculated based on the MinValue, MaxValue and Span. The number format is set with InnerLabelFormat.

See Also

Axes of the Chart
Setting the Chart's Labels
Setting the Chart's Data


Setting the Chart's Labels

All chart types support custom text for labels. For those charts that support coordinate axes, custom labels are set with XLabels, YLabels and Y2Labels. The LabelType property of the XAxisSettings, YAxisSettings or Y2AxisSettings object should be set to CustomText.

Line charts support DateTime values as data. In this case, the DataFormat should be set to DateTime and the format of the labels is set with AxisSettings.DateTimeFormat. Use CustomDateTime format to set the format manually. The auto scale can be regulated with AxisSettings.StartDateTime, AxisSettings.EndDateTime and TimeSpan properties.

Bar charts can have labels at the top of the bar and/or inside bars. See the InnerLabelType and TopLabelType properties for more details. Custom inner and top labels are set with the InnerLabels and TopLabels properties. Clusters and groups of bars can have one label at each cluster / group. These labels are set with ClusterLabels.

In pie charts, the pie labels can be drawn inside or outside pie segments. The InnerLabelType and OuterLabelType properties specify the type of labels to be drawn. The different label types are members of the LabelType enumeration. The length of pointers to the labels drawn outside pie pieces is set with PointerLength. The InnerLabelPosition determines the location of inner labels.

In radar charts, the type of labels drawn at the inner axis is specified with InnerAxisLabelType. The type of labels drawn at the outer axis is set with OuterAxisLabelType. Custom labels are specified with InnerAxisLabels and OuterAxisLabels. Use OuterLabels to set labels drawn in the middle of outer axis segments.

Labels can be drawn with a border around the text. The Border enumeration contains the types of border that can be used. The following properties set the label's border according to the chart type:

  • BarChart: InnerLabelBackground, InnerLabelBorder, InnerLabelMargin, InnerLabelOutline,
    TopLabelBackground, TopLabelBorder, TopLabelMargin, TopLabelOutline
  • LineChart: LabelBorder, LabelBorderBackground, LabelBorderMargin, LabelBorderOutline
  • PieChart: InnerLabelBackground, InnerLabelBorder, InnerLabelBorderMargin, InnerLabelOutline, OuterLabelBackground, OuterLabelBorder, OuterLabelBorderMargin, OuterLabelOutline
  • RadarChart: OuterAxisLabelBackground, OuterAxisLabelBorder, OuterAxisLabelMargin, OuterAxisLabelOutline, OuterLabelBackground, OuterLabelBorder, OuterLabelMargin, OuterLabelOutline

The chart labels can be retrieved directly from a database. Check the DataSource and DataMember properties for more information. Check the DataSource and DataMember properties for more information. See the data bound properties in the LineChart Members, PieChart Members, BarChart Members and RadarChart.Members lists.

See Also

Chart parts


Adding Summary Values

MindFusion.Charting supports four summary types - average, sum, minimum and maximum. All of them are members of the Summary enumeration. Choose the summary you need and add it to the SummaryValues list.

Summary values are drawn differently in the different chart types:

  • In line charts they are lines
  • In scatter charts they are shapes
  • In area charts they are polygons
  • In bar charts they are either part of each bar (in stacked bars) or a separate bar in a group / cluster of bars
  • Pie / doughnut charts do not have summaries
  • Radar / polar charts do not have summaries

The summary operations are performed on all values from all graphics.

Custom summary values together with their text description are added with the AddCustomSummary method.

There is no limit for the number of summary values you can add to a chart.


Setting the Chart's Colors

MindFusion.Charting gives you absolute freedom to set the colours of the charts you draw. The brushes and pens used by the control are of type MindFudion.Drawing.Brush or MindFusion.Drawing.Pen classes. They are equivalent to the .NET brushes and pens but are automatically disposed, which guarantees that GDI+ resources shall not get exhausted. All MindFusion's pen and brush classes are documented in details.

The ChartBrushes property holds the brushes, used for drawing the chart. The pens for all types of charts are set with ChartPens.

If you have set summary operations, use the SummaryBrushes property to specify the brushes for drawing summary parts of the chart. In line charts, the SummaryPens property is available.

The shapes of scatter charts are drawn with brushes from the ShapeBrushes property. ShapePens specify the outlining of the shapes. The shapes in radar charts are drawn with pens and brushes from the RadarChart.ShapePens and RadarChart.ShapeBrushes properties.

If the brushes / pens are less than the brushes / pens needed for drawing all parts of the chart, the control cycles through them. In case you want a single-coloured chart, set the MultiColored property to false.

Chart labels are drawn with the LabelBrush property. If MultiColoredLabels is set to true, the labels are drawn with the Brush for the chart graphics they refer to.

The pen, used for drawing the chart's axes is the AxisPen. The shadow in 3D axes charts is drawn with AxisShadowBrush.

The background of the chart is drawn with the BackgroundBrush property. The plot area (the area between the axes) in charts that use the Cartesian coordinate system is drawn with ChartBackgroundBrush.

In radar chart, the background of the chart can be drawn in sections, coloured with SectionBrushes or in segments with brushes from SegmentBrushes. The background colour of 3D radar/polar charts is set with Background3D.

The layout style and position of the image is set with BkgrImagePos. Use ChartImage to set an image as background for the area between the chart axes.The layout style and position of the image is set with BkgrImagePos. Use ChartImage to set an image as background for the area between the chart axes.


Title and Subtitle

MindFusion.Charting supports both title and subtitle labels for all chart types - they are set with TitleText and SubTitleText. The title label is drawn with TitleBrush and TitleFont. The subtitle label - with SubTitleFont and SubTitleBrush.

The subtitle is drawn always under the title. Both texts can be broken in several lines if you insert the symbol for new line "\n". If the title (subtitle) is wider than the chart graphics, the width of the chart is increased automatically.

Both the title and subtitle can be omitted.

Title labels can be set by using the TitleLabel, TitleLabelAlignment, TitleLabelBrush, TitleLabelFont, TitleLabelOffset, TitleLabelOrientation, TitleLabelPosition properties.

The TitleOffset and SubTitleOffset properties specify the distance between the title, the subtitle and the rest of the chart.


Position and Size of the Chart

You can get the estimated size of the chart with the CalculateSize method.

Note

If you call CalculateSize before all chart's characteristics are set, you might get invalid size. When you call CalculateSize before you have set the graphics object, the control creates a temp graphics object with GraphicsUnit.Pixel.

Margins around the chart are set with the ChartMargins property. Use it to specify the space that you want to have around your chart in all four directions - left, top, right and bottom.

You can manually set the margins of the plot area in charts with axes with the PlotAreaMargins property. For pie charts, the margins around the pie chart are specified with PieMargins.

The size of the chart is determined automatically by the size of the chart control. When the chart's original size is not equal to the size of the control there are four different ways it can get resized - centred, stretched, fit or scrolled. You can set the type you want with the ResizeType property. The size of the chart is determined automatically by the size of the chart control. When the chart's original size is not equal to the size of the control there are four different ways it can get resized - centred, stretched, fit or scrolled. You can set the type you want with the ResizeType property.

When you want to place a chart in a bigger graphics object, you can set its position programmatically with the TopLeftPosition property. The position of the chart does not change its size. In MindFusion.Charting, this property is replaced by the Location property of all .NET controls.

See Also

ResizeType Enumeration
UpdateChart Method ResizeType Enumeration
UpdateChart Method
ChartSize Property
DrawChart Method
TopLeftPosition
InnerAxisPosition
RadarChart.RadiusLength
PieChart.RadiusLength


Legend

Every chart can have a legend. Labels for the legend are set with the LegendLabels property. They are drawn with the LegendBrush. The LegendFont property specifies the font for the labels. When LegendWordWrap is set to true and a legend label needs to be broken in multiple lines, words are kept whole.

The legend can be drawn with grid separating the legend labels - in rows, columns or both. The property is called LegendGridType.

You can control the width of the legend's bounding rectangle with the LegendWidth property. The count of columns in the legend is set by the LegendColumns property. The position and alignment of the legend is set with LegendPosition and LegendAlignment.

The LegendBorder and LegendBorderMargin properties specify the border of the legend and the margin around the legend border. The background of the legend, when drawn with border, is set with LegendBackgroundBrush. The border is drawn with LegendPen.

See Also

MindFusion.Charting Tutorials: Legend of the Chart
Grid


Grid

All types of charts that have axes can draw a grid. The type of the grid is specified with GridType which is of type GridType Enumeration. When the GridType is set to GridType.Chess, the width is set with GridWidth. In the other grid types, except, GridType.Custom, the grid width is determined by the position of the scales at the chart axes.

The grid can be drawn with stripes: MindFusion.Charting supports different brushes for the odd and even stripes - GridBrush and AltGridBrush. The grid lines are drawn with GridPen. The outlining of the grid's rectangle is drawn with GridOutlinePen.

Setting GridType to GridType.Custom gives you complete control over the appearance of the grid. Use HorGridPoints and VertGridPoints properties to set the position of grid lines. The stripes are filled with brushes taken subsequently from the HorGridBrushes and VertGridBrushes properties. The grid stripes are drawn with pens from the HorGridPens and VertGridPens properties.

Custom grids can have labels at the grid sections on all chart axes. The labels are set with XGridLabels, YGridLabels and Y2GridLabels. The labels are drawn with XGridLabelBrushes, YGridLabelBrushes and Y2GridLabelBrushes.

If GridLabelsAtLines is true, the labels are drawn at grid lines. Otherwise, they are drawn at the middle of grid segments. When drawn at grid segments, grid labels can have a pointer which length is set with GridLabelPointer.

See Also

Tutorials: Grid
Legend


Retrieving Chart Data from a Database

With MindFusion.Charting you can retrieve database fields and set them as data for the chart labels and numerical values. You can bind the database fields directly to the properties, which the control provides. Please, refer to Chart Members, AxesChart Members, BarChart Members, PieChart Members, RadarChart Members and LineChart Members lists for more information exactly which these properties are. You will recognize them by the suffix "field(s)" added to the name of the property.

When using MindFusion.Charting programmatically you can do data binding manually, so no special properties are needed and therefore provided in order to set data from a database to the chart properties.

When you start binding database fields to chart properties the first thing to do is provide a valid DataSource DataSource object. If it is of type DataSet, specify the name of the table with the data you need in the DataMember DataMember property. When you have finished with all this, then you can start assigning database fields to the chart's properties. Use DataSourceDataSource when you make databinding programmatically at run time.

The subtopics show step by step how you can bind database controls from Microsoft VisualStudio 2008 or VisualStudio 2005 development environments to MindFusion.Charting database properties.

See Also

Using VisualStudio 2005
Using VisualStudio 2008


Using VisualStudio 2008

Create a database connection

  • In the Server Explorer, right-click the Data Connections node and choose Add Connection.
  • Select the data source (for example, Microsoft Access Database File), and click Continue.
  • In the Add Connection dialog box, click Browse and select the database file name (for example 'Sales.mdb'), test the connection and press OK. The selected database appears in the Server Explorer, under the Data Connections node.

Add data source

  • On the Visual Studio Data menu, select Add New Data Source. This will display the Data Source Configuration Wizard, which will automate the process of adding a new data source to your application.
  • Select Database, then click Next.
  • Click the New Connection button to create a new database connection. If you have already created the database connection (as shown above through the Server Explorer), click Next.
  • Save the connection string to the application configuration file. Click Next.
  • Choose the database objects
    Expand the Tables node, select the Table that you want to use, and then click Finish. The DataSet is added to your project and the selected table appears in the Data Sources window.
  • On the Data menu, select Show Data Sources. The DataSet is displayed in the Data Sources window.

  • To preview the added data source, right-click the DataSet, and select Preview Data.
  • Rebuild the project

Create a database connection

  • In the Server Explorer, right-click the Data Connections node and choose Add Connection.
  • Select the data source (for example, Microsoft Access Database File), and click Continue.
  • In the Add Connection dialog box, click Browse and select the database file name (for example 'Sales.mdb'), test the connection and press OK. The selected database appears in the Server Explorer, under the Data Connections node.

Add data source

  • On the Visual Studio Data menu, select Add New Data Source. This will display the Data Source Configuration Wizard, which will automate the process of adding a new data source to your application.
  • Select Database, then click Next.
  • Click the New Connection button to create a new database connection. If you have already created the database connection (as shown above through the Server Explorer), click Next.
  • Save the connection string to the application configuration file. Click Next.
  • Choose the database objects
    Expand the Tables node, select the Table that you want to use, and then click Finish. The DataSet is added to your project and the selected table appears in the Data Sources window.
  • On the Data menu, select Show Data Sources. The DataSet is displayed in the Data Sources window.
  • To preview the added data source, right-click the DataSet, and select Preview Data.

    • Rebuild the project

Bind MindFusion.Charting properties

  • In design view, in the 'Data' properties group in the Properties' browser for MindFusion.Charting, first set the DataSource to your DataSet object from the drop-down list.
  • Set the DataMember to the desired database table from the drop-down list.
  • Search for the chart properties (ending with 'field(s)') and bind them to the respective columns from the drop-down list.

Read the data at run time

Add the following lines of code in your application, a good place is behind InitalizeComponent():

C#

myDataAdapter.Fill(myDataSet);
myChart.DataBind();
myChart.UpdateChart();


Using VisualStudio 2005

Practical Tips: How To Connect MindFusion.Charting's Database Properties to a Database in VisualStudio 2005?

Create a database connection

  • Right-click the Servers pane and choose Add Connection.
  • Choose the data source and database names, test the connection and press OK.

Create a DataAdapter

  • In design view, choose the appropriate data adapter control from the toolbox - OleDbDataAdapter, OdbcDataAdapter, and so on. You can add more database controls if you right-click the Toolbox pane and select Choose Items.
  • Follow the steps of the DataAdapter wizard to choose the appropriate database tables and columns that you'll need.

Create a DataSet

  • Right-click at the icon of the DataAdapter you have created in the previous steps.
  • Choose Generate DataSet.

Bind MindFusion.Charting properties

  • In design view, in the 'Data' properties group in the Properties' browser for MindFusion.Charting, first set DataSource to your DataSet object from the drop-down list.
  • Set DataMember to the desired database table from the drop-down list.
  • Search for the chart properties (ending with 'field(s)') and bind them to the respective columns from the drop-down list.

Read the data at run time

Add the following lines of code in your application, a good place is behind InitalizeComponent():

C#

myDataAdapter.Fill(myDataSet);
myChart.DataBind();
myChart.UpdateChart();

Create a database connection

  • Right-click the Servers pane and choose Add Connection.
  • Choose the data source and database names, test the connection and press OK.

Create a DataAdapter

  • In design view, choose the appropriate data adapter control from the toolbox - OleDbDataAdapter, OdbcDataAdapter, and so on. You can add more database controls if you right-click the Toolbox pane and select Choose Items.
  • Follow the steps of the DataAdapter wizard to choose the appropriate database tables and columns that you'll need.

Create a DataSet

  • Right-click at the icon of the DataAdapter you have created in the previous steps.
  • Choose Generate DataSet.

Bind MindFusion.Charting properties

  • In design view, in the 'Data' properties group in the Properties' browser for MindFusion.Charting, first set DataSource to your DataSet object from the drop-down list.
  • Set DataMember to the desired database table from the drop-down list.
  • Search for the chart properties (ending with 'field(s)') and bind them to the respective columns from the drop-down list.

Read the data at run time

Add the following lines of code in your application, a good place is behind InitalizeComponent():

C#

myDataAdapter.Fill(myDataSet);
myChart.DataBind();
myChart.UpdateChart();

See Also

Using VisualStudio 2008


Using VisualStudio 2003

Practical Tip: How to create a database connection using Visual Studio 2003?

Note

Versions of MindFusion.Charting 3.2 and higher do not support design-time data binding in Visual Studio.NET 2003.

In order to use any data from a database you should first make a connection to the database (1), select the data you need (2) and transform the data in such format that it can be used in WindowsWindows applications (3). Here is how to do this in Visual Studio.NET 2003:

1. Make connection to the database

  • Select the Data tab in the Toolbox pane in design mode in Visual Studio.NET.
  • Select the type of connection you want - OleDbConnection or SqlConnection and drag the tab chosen onto the form. The Connection control appears in the bottom of the design window.
  • In the properties palette of the connection choose ConnectionString and select New from the drop down combo box.
  • Follow the steps of the connection wizard in order to create connection to the database you want.

2. Select the data you need

  • With the DataConnection already done, drag OleDbDataAdapter or SqlDataAdapter from the Data tab in the Toolbox pane. While the control is being dragged a DataAdapter wizard starts.
  • Follow the wizard in order to create a database query and select the necessary fields and tables from the database.

3. Transform the data in a way it can be used in a Windowswindows application

  • With DataAdapter ready choose Create DataSet from the hyperlinks in the bottom of the DataAdapter properties browser.
  • The newly created DataSet appears next to the connection and adapter controls. Now select it in the property browser of the chart as value of the DataSource Property. Also select a table as value of DataMember. Fill the other data-related properties with the names of the columns which you wish the chart control to read automatically.
  • Now the DataAdapter should be filled with the data from the DataSet. Add the following code anywhere in your project, a form_load event handler is a good choice:

C#

OleDbDataAdapter1.Fill( dataSet1 );
chart1.DataBind();

Notes:

  • Connection refers to the created SqlConnection or OleDbConnection object;
  • DataAdapter refers to the created SqlDataAdapter or OldDbDataAdapter;
  • chart1 refers to the instance of the Chart - derived class created - line, area, bar, radar;
  • dataSet1 refers to the newly created instance of the DataSet class;
  • OleDbDataAdapter1 refers to the newly created instance of the OleDbDataAdapter class. The same code counts when you use SqlDataAdapter.

See Also

Using VisualStudio 2005


Printing of Charts

You can print your charts by using the ChartPrinter class.

How to Print a Chart?
  • Create the desired chart by dragging the appropriate chart control from the Toolbox pane.
  • Create a ChartPrinter object.
  • Drag the ChartPrinter icon to the form's working area or
  • Instantiate the ChartPrinter object directly in your code:

C#

private void btnPrint_Click(object sender, System.EventArgs e)
{
ChartPrinter chartPrinter = new ChartPrinter();
chartPrinter.Chart = myChart;
.....
}

  • To print the chart document, call Print() on the ChartPrinter object. Before that, set any ChartPrinter properties as desired.

C#

private void btnPrint_Click(object sender, System.EventArgs e)
{
.....
chartPrinter.Landscape = false;
chartPrinter.Print();
}

  • To perform PrintPreview of the chart, use the PrintPreviewDialog control:

C#

private void btnPrintPreview_Click(object sender, System.EventArgs e)
{
PrintPreviewDialog previewDialog = new PrintPreviewDialog();
chartPrinter.Landscape = false;
previewDialog.Document = chartPrinter;
previewDialog.ShowDialog();
}


Hit Testing

You can do hit testing on chart types with the HitTest method. It returns an object of type ChartElement that holds all specific data for the hitted object. If no element is hitted, the result is null.

HitTest return value must be converted according to the elements of the chart that is being tested for example:

  • for bar charts this is Bar
  • for line charts this is Line
  • for scatter charts it is Scatter
  • for bubble charts this is Bubble
  • for radar charts this is RadarPiece
  • for pie charts this is PiePiece

To avoid casting the result from HitTest, you can use the chart specific functions for testing HitTestLine, HitTestBar, HitTestBubble, HitTestScatter, HitTestRadar, HitTestPie. For a line chart with scatter shapes, HitTestLine will return null if a scatter is hitted and HitTestScatter will return null if line is hitted. The same counts for radar charts with scatters.

How to perform hit testing?

The following steps describe how a radar chart with scatter shapes is tested if clicked-on by the user:

  • Add an event handler for the MouseDown event through the Property Browser for the chart.

C#

private void radarChart1_MouseDown(object sender, System.Windows.Forms.MouseEventArgs e)
{
}

  • Check if the clicked point is inside a Scatter or RadarPiece.

C#

//get the result from the hit testing
ChartElement result = radarChart1.HitTest( e.X, e.Y );
if ( result != null )
{
}

  • Cast the result to get the ChartElement.

C#

if ( result != null )
{
//check to see if radar piece or scatter is hitted
if ( result is MindFusion.Charting.RadarPiece )
{
MindFusion.Charting.RadarPiece piece = result as MindFusion.Charting.RadarPiece;
}
else if ( result is MindFusion.Charting.Scatter )
{
MindFusion.Charting.Scatter scatter = result as MindFusion.Charting.Scatter;
}
}

  • Do some action according to the element being hit.

C#

doSomething( piece.Index, piece.Value );

You can do hit testing on chart types with the HitTest method. It returns an object of type ChartElement that holds all specific data for the hitted object. If no element is hitted, the result is null.

HitTest return value must be converted according to the elements of the chart that is being tested for example:

  • for bar charts this is Bar
  • for line charts this is Line
  • for scatter charts it is Scatter
  • for bubble charts this is Bubble
  • for radar charts this is RadarPiece
  • for pie charts this is PiePiece

To avoid casting the result from HitTest, you can use the chart specific functions for testing HitTestLine, HitTestBar, HitTestBubble, HitTestScatter, HitTestRadar, HitTestPie. For a line chart with scatter shapes, HitTestLine will return null if a scatter is hitted and HitTestScatter will return null if line is hitted. The same counts for radar charts with scatters.

How to perform hit testing?
The following steps describe how a radar chart with scatter shapes is tested if clicked-on by the user:

  • Add an event handler for the MouseDown event through the Property Browser for the chart.

C#

private void radarChart1_MouseDown(object sender, System.Windows.Forms.MouseEventArgs e)
{
}

  • Check if the clicked point is inside a Scatter or RadarPiece.

C#

//get the result from the hit testing
ChartElement result = radarChart1.HitTest( e.X, e.Y );
if ( result != null )
{
}

  • Cast the result to get the ChartElement.

C#

if ( result != null )
{
//check to see if radar piece or scatter is hitted
if ( result is MindFusion.Charting.RadarPiece )
{
MindFusion.Charting.RadarPiece piece = result as MindFusion.Charting.RadarPiece;
}
else if ( result is MindFusion.Charting.Scatter )
{
MindFusion.Charting.Scatter scatter = result as MindFusion.Charting.Scatter;
}
}

  • Do some action according to the element being hit.

C#

doSomething( piece.Index, piece.Value );


Using DateTime Values

MindFusion.Charting supports DateTime values as data for all its chart types. You can add the DateTime values the same way as you add numbers. You can also use any other data, for example, strings as long as it can be parsed to valid DateTime values.

Data cannot be mixed - for any of the XData, YData or Y2Data properties, you can use either numbers or DateTime values.

Labels at the axis are drawn as DateTime values if you set the DateTimeFormat property to any of the date / time formats - ShortDate, LongDate and so on.

The following sample creates a line chart with 4 DateTime points.

  • Add 4 DateTime values to the XData list

VB

'Create the DateTime data
Dim d1 = New DateTime(2008, 2, 12)
Dim d2 = New DateTime(2008, 2, 17)
Dim d3 = New DateTime(2008, 2, 4)
Dim d4 = New DateTime(2008, 2, 10)

'Create an array with the data
Dim dateTime = New ArrayList(6)
dateTime.Add(d1)
dateTime.Add(d2)
dateTime.Add(d3)
dateTime.Add(d4)

'Add the DateTime array
Me.LineChart1.XData.Clear()
Me.LineChart1.XData.Add(dateTime)

'Update the chart iwth the new data
Me.LineChart1.UpdateChart()

  • Set XAxisSettings.StartDateTime to Fabruary, 1st 2008

  • Set the YAxisSettings.EndDateTime property to February, 20th 2008

VB

Me.LineChart1.XAxisSettings.EndDateTime = New Date(2008, 2, 20, 0, 0, 0, 0)

  • Set the XAxisSettings.TimeSpan to 3 days

VB

Me.LineChart1.XAxisSettings.TimeSpan = System.TimeSpan.Parse("3.00:00:00")

  • Set the format of data for the X-axis to CustomDateTime and set the DateTimeFormat

VB

Me.LineChart1.XAxisSettings.DataFormat = MindFusion.Charting.DataFormat.CustomDateTime
Me.LineChart1.XAxisSettings.DateTimeFormat = "dd-M"

  • Use the ChartPens, ShapePens and ShapeSizes properties to adjust the colors for the pen and the size of the shapes
  • Set the BackgroundBrush

Here is the final chart:

See Also

DataFormat Enumeration
DateTimeFormat Enumeration
NumberFormat Enumeration


MindFusion.Diagramming Overview

The next few chapters give you an overview of all features, grouped by functionality. Hyperlinks refer to the detailed description of methods and properties of each class.


Document-View Architecture

MindFusion.Diagramming implements the Model-View-Controller (MVC) architectural pattern in its new version 5. The MVC design pattern as applied to MindFusion.Diagramming separates the diagram data (model) from its representation to the user (view) and controlling it by the user (controller).

According to the MVC design pattern, MindFusion.Diagramming Version 5 provides two new classes instead of the FlowChart class, namely Diagram and DiagramView.

The Diagram class represents the diagram data model and provides operations to process the data. It exposes properties and methods for adding new diagram elements, finding and accessing existing elements, or removing them.

The DiagramView class presents the relevant data from the Diagram class by drawing on the screen using .NET GDI+. When the diagram is changed, the view automatically redraws the affected part of the image to reflect the changes. Multiple views can display the same diagram, set by their Diagram property. Each view can have a different zoom level and scroll position.

The DiagramView class also integrates the Controller part of the MVC, represented mostly by the view's Behavior property. That property specifies how GUI actions to manipulate the data should be interpreted.


Diagram Structure

The following topics are contained within this topic:

Standard Item Types
Information about the standard MindFusion.Diagramming item types, such as ShapeNode, TableNode and DiagramLink.

Custom Item Types
Information on how to implement and use custom item types.

Creating and Deleting Items
Information on how to create and delete items both interactively and programmaticaly.

Accessing Items
Information about how to access the diagram items, how to get the selected items and how to find particular items in the diagram according to a specifiec criteria.

Hosting .NET Controls in Nodes
Information on how to host .NET controls in MindFusion.Diagramming diagrams through ControlNode objects.

Attaching and Grouping Items
Information about the use of the Group class in order to create hierarchies of dependent objects in MindFusion.Diagramming.

Collapsing and Expanding Tree Branches
Information on how to enable expanding diagram nodes.


Standard Item Types

Diagram elements in MindFusion.Diagramming are represented by ShapeNode, TableNode, ControlNode and DiagramLink instances. Combined and linked together, they can form complex data structures such as process or entity-relationship diagrams, class hierarchies, networks and graphs. Each of their rich features can be customized through numerous methods and properties. MindFusion.Diagramming also offers intuitive user interface for drawing and editing diagram items interactively.

Shape Nodes

Shape nodes can represent geometric shapes, flowchart elements, icons in network diagrams, and so on. They can display both graphics and text in different fonts, sizes and colors. There are 87 predefined node shapes (you can preview them here) and apart from them, MindFusion.Diagramming offers an easy way to define custom shapes. Shape nodes can be rotated, either interactively using the round selection handle drawn above them, or programmatically using the RotationAngle property. ShapeNode appearance can be customized further using several types of custom painting. The first type gives you full control over the painting. With the second one your painting code is performed additionally to the basic painting. The third one performs standard drawing of nodes and custom drawing of their shadows.

Table Nodes

Tables can be used to represent table schemas in database diagrams or classes in class-hierarchies. A table contains cells arranged in a grid, and every cell can display text and/or image. Cells can span several rows and columns as set in the RowSpan and ColumnSpan properties. Cells, columns and rows can be customized in various ways - there are properties available for setting their extents, style, image and text alignment. Tables' dimensions can be programmatically changed; inserting, appending or deleting rows and columns can be done in a very comprehensive, intuitive way whenever you might need it. Tables can also display background images and graphics. The file formats supported are BMP, GIF, JPEG, ICO and WMF (the same applies for shape nodes).

Control Hosts

A ControlNode can host any .NET control - instance of System.Windows.Forms.Control-derived class. The hosted control might be any of the standard .NET types such as DataGrid or Button; custom controls are also supported. A ControlNode can be connected with links to any other nodes - control hosts, shapes or tables.

Container Nodes

A ContainerNode can contain other diagram nodes. When a container is moved, the contained nodes move too. Containers can be folded to hide the contained nodes, and unfolded back to show them again. Nodes inside a container can be linked to nodes both inside and outside of it. When a container is folded, the links connected to contained nodes point to the container outlines. Containers can be nested one within another to unlimited depth.

Links

Links are used to represent various types of connections and relations in diagrams. MindFusion.Diagramming offers three basic link types:
  • polyline links composed of straight-line segments;
  • curved links composed of Bézier-spline segments;
  • links composed of horizontal and vertical segments, alternating their orientation so that every segment is orthogonal to its neighbor.

A link can be connected to a node at each of the link's ends. It is also possible to have unconnected links - having one or both of their ends not connected to nodes. Some customizable link's properties are: arrowheads, style, color, text, pen width and style, modification behavior and number of segments.


Custom Item Types

You can create your own item types by deriving the DiagramNode and DiagramLink classes or their successors such as TableNode, ContainerNode and so on. This lets you add custom data fields to the diagram items, and implement custom visualization and interaction functionality. For an example, take a look at the IconNodes sample project that comes with MindFusion.Diagramming. The IconNodes main features are outlined in the Using Custom Item Types Tutorial.

Serialization

If you add custom fields to your item class, you will probably want their values saved when saving diagram files, and restored when loading files. To enable this, override the SaveTo and LoadFrom methods of the DiagramItem class, which let you use BinaryWriter and BinaryReader objects to implement binary serialization. For XML serialization, you must implement the SaveToXml and LoadFromXml methods.

Clipboard operations

You must implement the Clone method in order to enable CopyToClipboard and PasteFromClipboard to work with your custom item type, If Clone is not implemented, you will get an instance of the base class created for the pasted item, and this could lead to an exception when the base class deserialization code tries to load the item state from a data stream created by the derived class. If your class has any custom fields, it must also implement the SaveTo and LoadFrom methods for proper serialization.

Rendering

If you need to provide custom rendering for your items, override the Draw and DrawShadow methods. They receive as an argument an object that implements the IGraphics interface, which provides methods for drawing vector graphics, text and images. MindFusion.Diagramming provides GdiGraphics, PdfGraphics and SvgGraphics implementations of that interface, which are used respectively when drawing on the screen, exporting to PDF and to SVG. That lets you use the same code regardless of where the item should draw itself.

User interaction

To let the user draw items from a custom class, set the Behavior property of the diagram view to Custom, and set the CustomNodeType or CustomLinkType property to the Type object that corresponds to your class. If you need to change how items handle user interaction while they are being initially created, implement the StartCreate, UpdateCreate and CompleteCreate methods. In order to change how items respond to user interaction while they are being modified, implement the StartModify, UpdateModify and CompleteModify methods.


Creating and Deleting Items

Creating Items Programmatically

In order to add a new node or link to a diagram, create an instance of the item class via the new operator and add it to the diagram's Nodes or Links collection. This works the same way for adding both items from your custom class or ones from the MindFusion.Diagramming predefined types.

There are several shortcut methods provided for creating instances of the predefined node and link types. The methods are members of the diagram's Factory object:

  • The CreateShapeNode method creates a ShapeNode at the specified position.
  • The CreateTableNode method creates a TableNode at a specified position. Tables have a method that connects them with other tables called AddRelation.
  • The CreateContainerNode method creates a ContainerNode at the specified position.
  • There are several overloads of the CreateDiagramLink method that allow connecting two nodes of the same type or of different types.

Drawing New Items

Users can draw diagram elements with the mouse. The Behavior property specifies what type of elements should be created when a user starts drawing. When a user starts drawing, an item is created and an initialization event is raised to let you customize the item appearance before showing it on the screen. The initialization events include ones such as InitializeNode, InitializeLink, and so on. While items are being drawn, the control raises validation events such as NodeCreating to let you validate the operation and prevent creating items at a specific location. When the user releases the mouse button, the item is added to the collection that contains items from the same type (for example Nodes) and an event is raised, for example NodeCreated.

Deleting Items

Call the Remove method of the Nodes or Links collection to delete an item from the diagram. The ClearAll method clears diagram contents by deleting all items. A shortcut for removing a link between two tables is provided by the BreakRelation method.


Accessing Items

One of the most common tasks when using the component is iterating over all items in the diagram document or navigating through the connections between items - from a node to the incoming or outgoing links, or from a link to its origin and destination nodes. To enumerate items of a diagram use the Items, Links or Nodes collections. The nodes that a link connects are referenced by the link's Destination and Origin properties. To access the links that are connected to a node, use its IncomingLinks and OutgoingLinks collections. The first collection contains references to all links pointing to the node, the second - to the links that start from it. Links can connect to rows of a table; to find such links use table's Rows collection and the IncomingLinks and OutgoingLinks collections. A shortcut for accessing the other end of a relation in entity-relationship diagrams is provided by the RelatedOneToMany and RelatedManyToOne properties of the Row class.

Selected Items

If only one item is selected, it is considered the active item and can be accessed with the ActiveItem property. The type of this property is DiagramItem; you can get the actual type of the selected item through .NET reflection. Multiple items can be selected when clicking or dragging with the CTRL key pressed at the same time. Multiple selection is represented by the Selection property of the Diagram class. The Selection object provides collections to access the selected Links and Nodes.

Finding Items

You can search for diagram items by their tag using the FindLink and FindNode methods. Tag objects are compared by calling the Equals method of the System.Object class. Thus if the tags are of value type, they are compared by value (that is bitwise equality). If they are of reference type their Equals method is used. If there are more items with the same tag, the first one will be returned. If no item with the specified tag exists, a null reference (Nothing in Visual Basic) will be returned. Groups can also be searched by tag using FindGroup.


Hosting .NET Controls in Nodes

A ControlNode instance can host any .NET control derived from System.Windows.Forms.Control. This allows you to use ready-made controls to display or edit the entities represented in your application's diagrams. The controls hosted in MindFusion.Diagramming nodes might be interactive and with embedded user interface. For example you might utilize calendars, grids, rich-text controls or html-pages as entity editors or viewers. You might also create your own custom control and integrate it seamlessly with MindFusion.Diagramming; as a result you can get as advanced entity-relationship diagram editor as your application needs.

Creating Controls Interactively

To allow end-users to draw ControlNode objects with the mouse, set Behavior to either DrawControls or LinkControls. The type of controls to be created in the host nodes is specified via the DefaultControlType property of DiagramView. If the following code executes, each node drawn by users would host a DataGrid instance, and nodes could be connected by drawing links between them:

C#

// Draw datagrid nodes and allow connecting them with links
diagramView.Behavior = Behavior.LinkControls;

// Default type of hosted controls is DataGrid
diagramView.DefaultControlType = typeof(DataGrid);

// Mouse clicks on hosted controls are processed by MindFusion.Diagramming
diagramView.ControlMouseAction = ControlMouseAction.IgnoreControl;

Visual Basic

' Draw datagrid nodes and allow connecting them with links
diagramView.Behavior = Behavior.LinkControls

' Default type of hosted controls is DataGrid
diagramView.DefaultControlType = GetType(DataGrid)

' Mouse clicks on hosted controls are processed by MindFusion.Diagramming
diagramView.ControlMouseAction = ControlMouseAction.IgnoreControl

Creating a ControlNode Programmatically

To create a ControlNode programmatically, add an instance of the class to the diagram's Nodes collection and set its Control property to an instance of a Control-derived class. A hosted control can be replaced with another one by assigning to Control again.

Consequences

Hosted controls are like any other child controls in a form, which leads to the following consequences:
  • they participate in the form's tab order;
  • they paint themselves in their own windows and are always drawn above other diagram items, independently of ZIndex;
  • they paint themselves in their own windows and MindFusion.Diagramming cannot always invoke their painting code, for example when printing or rendering preview/overview windows. Handle the PaintControl in situations where controls are not rendered properly;


Attaching and Grouping Items

MindFusion.Diagramming allows attaching a node to another diagram element, establishing a subordinate - master relationship between the two items. The easiest way to attach nodes is to call the AttachTo method. When a master element is moved or resized, any subordinated node follows it, so that the initial distance between the two items stays constant. This happens both when a user moves the master item around, and when the item position is changed using a method or a property.

Possible Uses

  • Attach a Transparent shape node to another item and set its Text, so that the shape node acts as an additional label assigned to the main item.
  • Attach a shape node to another item and set the node's Image, so it acts as an additional icon displayed inside or near the main item.
  • Attach a shape node or a table to another item and handle the NodeClicked or similar events to perform some action on the main item. This makes the subordinated node act as a button or another type of UI element attached to the main item. For more complex UI requirements, use an attached ControlNode and handle the events raised by the control it hosts.
  • In all previous cases, the Locked property can be set for attached nodes, which are used only as decorations embellishing the main item. That prevents users from selecting, modifying or drawing links to the subordinates.
  • Attach child elements in a tree branch to the branch root, so that when a user moves a tree node, the node's children moves simultaneously with it. Modifying an item in such hierarchical group makes the modification pervade through all dependant subordinated items.

Hierarchical Grouping

A unit of attached items is represented by an instance of the Group class. To create a group, instantiate a Group object and add it to the diagram's Groups collection, or call the CreateGroup method passing the master object as argument. Attach items to the group using the various Group methods. The AttachTo method of nodes is a shortcut to creating a group and attaching an item to it.

Every member of a group can be the master item of another group, that is, an item can be subordinate in one group and meanwhile be another group's master. MindFusion.Diagramming doesn't impose any limits to the depth and width of group hierarchies built that way. However, it is not possible to put an item as a subordinate in more than one groups because the hierarchy relations would become ambiguous.

Unions

It is possible to create such groups, that if any item in the hierarchy is modified, all other items are updated too. This can be done by putting the items in circular chain of dependencies - that is, item1 is attached to item2, item2 to item3 ... itemN to item1. If any of these items is modified, the change will propagate through the chain until it reaches its originator.

Attaching Items to a Group

Links cannot be attached to groups but can be master items of groups. If a group's master item is a link, nodes can be attached to the control points or segments of the link. See the AttachToLinkPoint and AttachToLinkSegment methods for details. If the master item is a node, other nodes can be attached to any of its corners, or to an area specified as percent of master-node's bounding rectangle. Check AttachToCorner and AttachProportional for details. A shortcut to creating Group instance and calling the appropriate AttachTo* methods is provided by the AttachTo method of the DiagramNode class.

Accessing Group Items

Group members can be accessed using the MainItem property and the AttachedNodes collection. To get the groups in which an item participates, use its MasterGroup and SubordinateGroup properties.

Destroying Groups

If a user deletes the master item of a group, the group is destroyed automatically and the GroupDestroyed event is raised. If AutoDeleteItems is enabled, subordinated items in the group are deleted too. If AutoDeleteItems is disabled, subordinated items are just detached from their master and remain intact. Groups can be destroyed programmatically by removing them from the diagram's Groups collection.


Collapsing and Expanding Tree Branches

If a diagram represents a tree structure, the tree branch starting from a node can be collapsed or expanded again in order to hide or display hierarchy details. Use the nodes' Collapse and Expand methods to do this programmatically. To determine whether a subtree is expanded or collapsed, check its root's Expanded property.

Displaying Expand/Collapse Button

If the Expandable property of a node is set to true, there is a [±] button displayed beside the node to allow users to collapse or expand the tree branch starting there. The button location can be customized through the diagram's ExpandButtonPosition property. By default, pressing that button calls automatically the Collapse and Expand methods and raises the TreeExpanded or TreeCollapsed events.

Defining Tree Direction

A node can be connected to other nodes through outgoing and incoming links. Setting the ExpandOnIncoming property specifies which items connected to a node will be regarded as its descendants. If ExpandOnIncoming is false (default value) then each node will be regarded as a parent of its outgoing links and the items attached to them. If ExpandOnIncoming is set to true, the node's incoming links define its children. So that property specifies the direction of parent-children relationship between diagram items and respectively the overall direction in which collapsing / expanding is done.

Expanding a Branch Recursively

Use the RecursiveExpand property to specify whether the whole tree branch starting from a node will be shown when expanding, or only the first level of descendants. A related property is the Expandable property of the Group class, which specifies whether expanding and collapsing propagate through group members.

HtmlBuilder Support

The HtmlBuilder class can generate map areas for the [±] buttons displayed beside Expandable nodes. To enable that, assign an URL to the ExpandBtnHyperLink property. That URL can contain some format specifiers which are automatically replaced with the values of nodes' Tag or ZIndex properties. That lets you identify on the server side the node whose [±] button is clicked.

Custom Expand/Collapse Functionality

The ExpandButtonAction property lets you override the standard functionality of the [±] button. Set this property to RaiseEvents and handle the ExpandButtonClicked event if you need to implement your own expand/collapse logic.


User Interaction

The following topics are contained within this topic:

Controlling User Interaction
Information on how to control user interactions with the control through diagram behavior, node constraints and event handling.

Handling Events
Information about some more notable events in MindFusion.Diagramming

Single and Multiple Selection
Provides information on how to select items, how to modify the selection appearance and behavior and how to access the items that are already selected.

Clipboard Operations
Information on how to use the Windows clipboard with MindFusion.Diagramming.

Scrolling and Zooming
Controlling scrolling and zooming in diagram views.

Tool-Tips
Information on how to enable tooltips for individual items and for the entire diagram.

In-place Editing the Contents of Items
Information about in-place editing of ShapeNodes, TableNode.Cells and DiagramLinks.


Controlling User Interaction with MindFusion.Diagramming

There are several ways to control user actions on the diagram as a whole, or on individual items in the diagram.

Disabling Interaction

By setting the Enabled property of DiagramView to false you can make the diagram contents non-modifiable at all. Thus it will function as nothing more than a static image you can use to present some data to the user. The diagram can still be modified programmatically though.

Specify How User's Actions are Interpreted

The Behavior property provides several predefined sets of rules specifying how user input with the mouse/keyboard is interpreted. If Behavior is set to LinkShapes, mouse dragging started from an unoccupied point of the document is processed as a ShapeNode creation request and dragging over a node creates a link. Note that such behavior leads to some extra work when creating overlaying nodes - users need to draw the second node on an empty area and move it over the first one afterwards. If you want to avoid that you should use the DrawShapes behavior. If LinkTables is set, dragging the mouse over an empty area creates a table and dragging over a table creates a link. Behavior options also include DrawLinks, DrawTables and Modify.

Setting Diagram Bounds

Document size can be get or set with the Bounds property. By default users are able to move items outside the diagram bounds. To prevent this, enable the RestrictItemsToBounds property. It provides three options to restrict item positions. They might not be restricted at all. The most restrictive option is to keep items entirely inside the document area. Another option allows items to be partially outside the document area but having at least a small visible part inside.

Item Constraints

Constraints upon how users are allowed to modify a node are set through the Constraints and EnabledHandles properties. The former can be used to constrain the move direction, node size and aspect ratio. The latter enables or disables specific manipulation handles of a node. That allows making the node non-moveable, non-resizable, or resizable only horizontally/vertically.

Items can be locked via the Locked properties. Locked items are excluded from selection and users cannot select, move or modify them.

Control How Links Connect to Nodes

The AllowIncomingLinks property of the DiagramNode class lets you specify whether incoming links can be drawn to a node. The AllowOutgoingLinks property lets you do that for outgoing links.

Anchor points define where link's ends should be placed when a user attaches a link to a node. A pattern of anchor points can be assigned to a node by setting the node's AnchorPattern. The SnapToAnchor property specifies whether link ends are aligned to anchor points when creating or modifying links.

Once a link is created, a user can still move its end points to different positions, unless LinkEndsMovable is set to false. This can also be controlled on a per-link basis by using the AllowMoveEnd and AllowMoveStart properties. You can dynamically validate moving of links' end points using the LinkModifying event.

The AllowSelfLoops property enables or disables drawing of reflexive links. They are allowed by default, but can be disabled if you consider them meaningless for the application. AllowLinksRepeat controls if two nodes can be connected more than once in the same direction.

In-place Text Editing

The text of nodes and tables can be edited in-place by double-clicking the respective items. To enable the feature set the AllowInplaceEdit property to true. For tables, both captions and cells can be edited in this way. Handle the CellTextEditing event to enable/disable in-place editing per cell. Depending on the type of item being edited, one of these events can be fired when editing completes: NodeTextEdited, CellTextEdited. In-place editing mode is exited when users click outside the text entry control. Pressing ENTER or ESC exits inplace-edit mode if respectively InplaceEditAcceptOnEnter and InplaceEditCancelOnEsc are enabled.

Validation Events

When users try to create, delete or select an item, one of the following events is raised. To ban the action, set corresponding event bool argument to false:

Event | Description
NodeCreating | Raised while a user draws a new node.
LinkCreating | Raised while a user draws a new link.
NodeSelecting | Raised when the user is trying to select a node.
LinkSelecting | Raised when the user is trying to select a link.
NodeDeleting | Raised when the user is trying to delete a node.
LinkDeleting | Raised when the user is trying to delete a link.
NodeModifying | Raised while a user modifies an existing node.
LinkModifying | Raised while a user modifies an existing link.

For more events that can be fired by user's actions, please, consult the Events section of the documentation.

Miscellaneous

  • Setting the SelectAfterCreate property to true automatically selects each newly created item, so users can immediately modify it.
  • The ModifierKeyActions property allows assigning different functions to the CTRL, ALT and SHIFT keys.


Handling Events

Most events are raised only in response to users actions. If you need to execute the same code after user actions and API calls, move the common code to a method and invoke the method both in the respective event handler and after the API method or property setter call. A notable exception is the *Deleted set of events, which are also raised when items are deleted programmatically, because in some circumstances deleting an item could delete other items related to it.

When a user starts drawing a new item with the mouse, the control raises an initialization event to let you set the appearance properties of the item. That is, for a node, the control raises InitializeNode.

While the user is holding down the mouse button and drawing, a validation event is raised to let you cancel the item creation (for example, NodeCreating). If the action is not cancelled, a creation event is raised to let your application know about the new item (for example, NodeCreated). There are events raised when users modify items, for example, NodeModifying and NodeModified. Call the CancelDrag method to cancel the item modification or creation from the *Modifying or *Creating events raised for nodes or links.

Note

In order to repaint the screen quickly while modifying items or drawing new ones, MindFusion.Diagramming caches the representation of all items not affected by the modification in an off-screen bitmap. When the mouse is moved, the cache bitmap is blitted to the screen and only the item being modified is redrawn. If an application changes the appearance properties of items in the cache while handling a mouse movement related event, the changes won't be visualized correctly on the screen until the mouse button is released and drawing completes. Use the RecreateCacheImage method to recreate the cache bitmap, so that the changes in item's appearance are immediately visualized.

When a user presses the DEL key, there is a validation event raised to let you confirm that an item should be deleted (for example, NodeDeleting), and if not cancelled, there is an item-deleted event raised (for example, NodeDeleted).

There are many other events related to various activities a user could carry out on the diagram. The full set of events can be found here:
Diagram Events
DiagramView Events


Single and Multiple Selection

Selecting and Modifying Items

In order to move or modify a diagram element, users drag its adjustment handles. Adjustment handles appear around an item when it is selected. Each handle can be dragged to perform specific transformation on the item. The appearance and behavior of modification handles can be altered via the HandlesStyle property. Depending on the value assigned to ModificationStart, those handles can also appear automatically when the mouse pointer hovers over an item.

Active Item

If only one diagram item is selected, it is considered the 'active' item. One of the items in a multiple selection is also regarded as active; it is usually the one selected last. The active item has white modification handles drawn around it, while other items in multiple selection have gray handles. The active item is probably the one users are most interested in while editing a diagram, and your program can update its state and user-interface according to that. Access to the active item is provided via the ActiveItem property of the Diagram class.

Multiple Selection

Selection of diagram items in MindFusion.Diagramming is represented by an instance of the Selection class. This class provides methods to programmatically select or deselect items and properties that specify how the selection looks and behaves. A property of the Diagram class, also called Selection, exposes the items selected within the current document. Multiple items can be selected, thus moved at the same time. To programmatically add items to or remove them from the multiple selection invoke one of the AddItem, Toggle and RemoveItem methods. The Clear method deselected all items and the Change method selects a single item, deselecting all others. Setting AllowMultipleSelection to false disables multiple selection.

Drawing a Selection Rectangle

To select multiple items, users must draw a selection rectangle with the left mouse button while holding down the CTRL key. The MiddleButtonActions and RightButtonActions properties let you enable drawing the selection rectangle using the middle or right mouse button.

Appearance

The visual style of multiple selection is defined via the Style property of the Selection class. For example, selection might be painted as a dashed rectangle or a semi-transparent filled rectangle. Colors of the selection rectangle can be changed by setting the selection's Pen and Brush properties. Another property related to selection visualization is the diagram's SelectionOnTop, which specifies whether selected items should be painted according to their z-order position or they should be painted on top of the non-selected items.

Enumerating Items

The Selection class exposes the selected items as .NET collections. The Items collection references all selected items, getting them as DiagramItem instances. The Nodes and Links collections keep references to the selected items of specific classes. Alternatively you might enumerate all items in the diagram and check their Selected property.

Automatic Selection

Setting the SelectAfterCreate property to true automatically selects each newly created item, so users can modify it immediately.


Clipboard Operations

A single diagram item or a selection of items can be copied or cut to the Windows clipboard. This is done programmatically using the CopyToClipboard and CutToClipboard methods. To paste the clipboard contents into the current diagram call PasteFromClipboard.

MindFusion.Diagramming does not provide keyboard interface to clipboard operations. You might assign the standard CTRL+C, CTRL+X and CTRL+V shortcuts to menu items and handle them by calling the respective methods.


Scrolling and Zooming

By default MindFusion.Diagramming scrollbars are visible. That can be changed by enabling or disabling the ShowScrollbars property. When the scrollbars are visible, the position and size of their thumbs as well as the scrolling page size are automatically updated, depending on the document size, zoom factor and scroll position.

Automatic Scrolling

The AutoScroll property controls automatic scrolling. When a user drags an adjustment handle outside MindFusion.Diagramming visual area while manipulating an item, if automatic scrolling is enabled the control will scroll its view towards the mouse position.

Diagram Size

The diagram size is set through the Bounds property. Its value is a RectangleF instance that specifies the origin of the diagram coordinate system and the diagram size. If the ShowScrollbars property is set to true, than the scrollbars are automatically updated - size, position and scrolling page size.

Programmatic Scrolling

To scroll the document contents programmatically you can use ScrollTo method or ScrollX and ScrollY properties, which give you the scroll position in case you need it.

Scrolling Tables

Table rows can be scrolled too. If the Scrollable property is set to true, an up/down scroll button is displayed in the table's caption area. By means of this button users can scroll the rows of the table. Scrolling can also be done programmatically using the CurrentScrollRow property.

Zooming

Zooming is controlled by ZoomFactor property, ZoomIn and ZoomOut methods. The zoom factor is expressed in percents, 100% meaning no zoom. Higher than 100% makes the diagram items look closer and bigger on the screen - zooming in. Less than 100% makes items look further and smaller on screen - zooming out. The ZoomIn method increases zoom factor by 10%. Respectively the ZoomOut method decreases zoom factor again by 10%. To zoom and scroll the view to fit the diagram contents to the control's client area, call ZoomToFit. To zoom and scroll the view so it fits a specified rectangular document area to the control's client area, call ZoomToRect.

Panning

The diagram view can be panned by holding ALT while dragging the mouse with the left button down. Another modifier key can be used for panning by setting ModifierKeyActions. The MiddleButtonActions and RightButtonActions properties let you use the middle or right mouse button to start panning. MindFusion.Diagramming displays the PanCursor while panning.


Tool-Tips

Tool-tips are short text messages displayed when the mouse pointer hovers over a diagram item for a while. To enable tool-tips, set the ShowToolTips property to true. The delay before a tool-tip appears is set via the ToolTipDelay property. Use the ToolTipControl property to get access to the System.Windows.Forms.ToolTip control used by MindFusion.Diagramming.

Tool-tips can be defined for each diagram element and for the whole document. If the mouse pointer stands still and it points to an item, then the ToolTip of the item is displayed. The ToolTip of the diagram appears if there is no item under the cursor or if there is an item but there isn't any tool-tip text defined for it. The anchor points assigned to nodes also provide a ToolTip property.

Tool-tip's text is also used as a value of the ALT attribute of image map areas corresponding to items; see HtmlBuilder for more information.


In-place Editing the Contents of Items

Standard in-place editing

To activate the standard in-place editing of the text of MindFusion.Diagramming objects, set the AllowInplaceEdit property to true. AllowInplaceEdit allows in-place editing the content of a diagram element by double-clicking it. In-place editing mode can be accepted and exited by clicking anywhere outside the text-field.

If you want to change the way of accepting / rejecting changes, the following DiagramView properties allow using the ENTER and ESC keys to perform that: InplaceEditAcceptOnEnter and InplaceEditCancelOnEsc. When InplaceEditAcceptOnEnter is set to true, pressing the ENTER key causes accepting changes and exiting in-place editing mode. If InplaceEditAcceptOnEnter is set to false, pressing ENTER inserts a new line in the text while in in-place editing mode. If InplaceEditCancelOnEsc is set to true, pressing the ESC key performs rejecting changes and exiting in-place editing mode.

In-place editing can be applied to the following properties: ShapeNode.Text, DiagramLink.Text, TableNode.Cell.Text, TableNode.Caption and ContainerNode.Caption. For tables, both captions and cells can be edited in this way.

If you want to enable/disable in-place editing of a specific table's cell, handle the CellTextEditing event. To enable/disable in-place editing of nodes, handle the NodeTextEditing event. For a DiagramLink object, the LinkTextEditing event is raised while in-place editing. These validation events let you prevent users from editing the text in the particular object if it is necessary.

When in-place editing of a node is completed, the NodeTextEdited event is raised. For a table's cell, handle the CellTextEdited event. LinkTextEdited event is raised when in-place editing of a DiagramLink object completes.

By default, MindFusion.Diagramming creates a TextBox control to let users edit item's text. The EnterInplaceEditMode event allows customizing the properties of that control, or attaching event handlers to it. InplaceEditFont specifies the font of the in-place edited text box. Actually, InplaceEditFont is assigned to the Font property of that text box.

When leaving in-place editing mode, the LeaveInplaceEditMode event is raised. This event is raised in all cases of closing the in-place editing control, for example, when the user accepts or cancels the changes made to an item's text, or when the EndEdit method is called.

To enter in-place editing mode programmatically and let users edit an item's text inline, call the BeginEdit method of DiagramView. The EndEdit method exits in-place editing mode.

In-place editing of custom items

The InplaceEditable interface allows implementing the standard in-place editing for custom defined items. By means of the methods of this interface, you can specify the position of the in-place editing textbox control and copy the entered text to a property of the edited item.

GetEditRect returns the destination rectangle of the in-place editing box. GetTextToEdit represents the initial contents of the in-place editing box. SetEditedText sets the edited text to the object after completing the in-place editing.

Using custom editor controls

Handle the CreateEditControl event to create a custom in-place editor control. This event is raised if AllowInplaceEdit is enabled and the user double-clicks an item, or when the application invokes the BeginEdit method of DiagramView. When the event is raised, set its EditControl argument to an instance of your custom editor class. You can use any Windows Forms control as editor instead of the default TextBox. It is your responsibility to set the editor control size and position. For an example, take a look at the InteractiveTable sample project.

When the user exits in-place editing mode by clicking outside the editor, MindFusion.Diagramming raises the DestroyEditControl event. Handle it to transfer the values entered into the editor to the respective properties of the edited item, and finally destroy or hide the editor control.


Placement and Layout

The following topics are contained within this topic:

Items Placement - Position, Size and Z-order
Information on how to modify the position, size and z-order of diagram items, both interactively and programmatically.

Alignment Grid
Information about the alignment grid.

Lanes Grid
Introduces the lanes grid - a grid that can be used in Swimlane diagrams or Gantt charts.

Laying Out Diagrams Automatically
Provides information about the automatic layouts available in MindFusion.Diagramming. These include the TreeLayout, SpringLayout and GridLayout.

Link Routing
Information about the automatic link routing.

Anchor Points and Patterns
Information on how to use anchor patterns and how to create custom anchor patterns.


Items Placement - Position, Size and Z-order

Measure Unit

The MeasureUnit property specifies the unit of measure for all location and size-related values assigned to MindFusion.Diagramming properties or passed as arguments to its methods.

Location and Size of Nodes

Use the Bounds property to get or change the location and size of a node. To move a node without changing its size, call the Move method. To change only the size of a node, invoke the Resize method. ResizeToFitImage and ResizeToFitImage methods set nodes' sizes to fit that of their pictures.

Links Control Points

Links have two or more control points, depending on their Style and SegmentCount. You can get access to the control points via link's ControlPoints collection. You must call UpdateFromPoints after moving control points of a link; that's needed in order to repaint the link and update its internal state variables. The Bounds property is read-only. It returns the smallest rectangle that bounds all link points.

Link Dynamics

The Dynamic property of a link can be enabled to make the link automatically recalculate its end point positions if the nodes connected to the link are moved or resized; the end points are moved in such a way that the link points to the centers of the connected nodes. A related property is SnapToNodeBorder, which can be enabled to make the link end points align to the border of their origin or destination nodes while a user move the link ends.

RetainForm is useful for links that have more than two control points. If the nodes that a link connects are moved around, usually only the segments at the ends of that link are updated, so that they stay connected to their respective nodes. In that case all intermediate control points stay where they are. However, if RetainForm is enabled, all control points will move simultaneously in a way they preserve their relative position one to another, and thus preserving the overall form of the link.

Links have an AutoRoute property that enables or disables automatic routing of a link. Routed links avoid nodes by finding the shortest path between their origin and destination that does not cross any other nodes. The link routing algorithm can be tuned via the properties exposed by RoutingOptions.

Interactive Moving or Resizing

End-users of your application can move or resize the diagram elements. They do this by selecting an item and dragging any of its adjustment handles, a point inside its interior, any of its sides or a selection frame. The HandlesStyle property of nodes controls how interaction can be performed. Additionally it defines the representation of selected items on screen. EnabledHandles lets you disable specific manipulations users are allowed to perform on a node, for example resizing the item horizontally or moving it. If an item is modified interactively, the NodeModified or LinkModified event is raised, depending on the item's type.

Controlling the Z-order

The Z-order defines how items are ordered on the Z-axis - so that one looks above or below another. Members of the DiagramItem class give you full control over the Z-order. To move an item one level up or down, invoke the ZLevelUp or ZLevelDown methods. To move an item to the bottom of the Z-order call its ZBottom method. To move the item in front of all others, call its ZTop method. You can use the ZIndex property to get or set the index of an item within the Z-order array.


Alignment Grid

MindFusion.Diagramming provides an alignment grid to help users place the diagram items more precisely. To activate the grid, set the AlignToGrid property to true. If the grid is active while an item is being created or modified, the item's control-points are aligned to the nearest grid points. The distance between adjacent grid points is set by the GridSizeX and GridSizeY properties. The GridOffsetX and GridOffsetY properties allow specifying the horizontal and vertical offset of the first point in the alignment grid.

Items created or modified by a user are automatically aligned to the grid. However, if items are placed in the diagram programmatically, their coordinates are set to the specified positions without aligning. In such cases use AlignPointToGrid if items must be placed exactly at grid points.

The grid can be either visible or invisible, depending on whether the ShowGrid value is true or false. If visible, the grid is painted as a matrix of points or as series of crossing lines, as specified by the GridStyle property. GridColor defines the color with which the alignment points or lines are painted.


Lanes Grid

The classes from the MindFusion.Diagramming.Lanes namespace let you develop process maps and lane diagrams, useful in business process planning and reporting. Processes consist of consecutive operations accomplished by people involved, technical installations, means of contact, and flow of information. The MindFusion.Diagramming lane grid features allow indicating and arranging related diagram items in complicated processes and systems, that is, Swim lane diagrams (known as Rummler-Brache diagram), Gantt Charts (planning and scheduling of projects). A lane in the grid can visually contain nodes, links, shapes or images, that represent tasks fulfilled in specified periods of time by people, companies or departments.

The MindFusion.Diagramming.Lanes namespace provides the Grid, Header, HeaderCollection and Style classes, the ICell interface and the ResizeType enumeration. These types expose additional properties and methods that let you define your own grids as required by your application logic. Grids can include varying number of lanes, divided into child rows and columns whose intersections form cells. The cells color and style can be customized too.

Use the EnableLanes property of the Diagram class to display lanes in your application. The LaneGrid lets you setup the rows and columns in the grid by defining horizontal and vertical lanes, where each lane can be titled by its own header and/or subheadings. The grid can be resized by setting the ColumnCount and RowCount properties or by adding headers to the ColumnHeaders and RowHeaders collections. A column or row can be divided into child elements by adding to the SubHeaders collection of a Header, which lets you form a complex hierarchy of unlimited depth. The intersection of rows and columns can be either a simple cell for bottommost elements in the hierarchy, or a group of cells for parent rows and columns. Cells or cell groups can be accessed via the grid class Item property, that lets you index cells either by their integer positions, or by their Header objects.

If the AllowResizeHeaders property of the Grid class is enabled, users can resize the grid columns and rows as desired. The LaneColumnResizeCursor and LaneRowResizeCursor properties get or set the mouse cursor shown when resizing the lane column header or the lane row header. The CellBoundsChanged event is raised when a cell is resized. An application can handle this event in order to rearrange or resize nodes so that they stay within a specific column or row of the grid.

The position of the grid and grid headers within the diagram is defined via TopMargin and LeftMargin, which specify the grid offset relative to Bounds. HookHeaders enables lane headers to be anchored to the left or right side of the control's visible area. The sizes of headers at different levels in the lane hierarchy can be set in a single operation by the RowHeadersWidths and ColumnHeadersHeights properties.

The appearance of the lanes grid can be customized further via the AlignCells property, which specifies whether cells are aligned to each other, the HeadersOnTop poperty, which specifies whether headers should appear on top of the Z-order, and the TopLeftAreaStyle specifying the appearance of the grid's top-left corner.

The Grid class provides many miscellaneous methods that can be used to find grid elements, for determining their bounds and for hit-testing: FindColumn, FindRow, GetCellBounds, GetCellColumn, GetCellFromPoint, GetCellRow, GetColumn, GetRow, GetRowIndex, GetColumnHeaderBounds, GetColumnIndex, GetHeaderBounds, GetRowHeaderBounds, GetHeaderFromPoint.

The headers in the lanes grid can be customized by using the following properties of the Header class:

Property Name | Description
Height | Gets or sets the height of the header and the related row in the grid.
ResizeType | Gets or sets the resize type of the header.
RotateTitle | Gets or sets a value indicating whether rotating of the header caption at 90 degree is enabled.
Style | Gets or sets the style of the header.
SubHeaders | Gets a collection with the subheaders of the header.
Title | Gets or sets the header caption.
TitleColor | Gets or sets the color of the header caption.
TitleFont | Gets or sets the font of the header caption.
TitleFormat | Gets or sets the alignment format of the header.
Width | Gets or sets the width of the header and the related column in the grid.


Laying Out Diagrams Automatically

Applications that process hierarchical or more complex entity-relationship data might need to present that data to end-users in an aesthetical and visually appealing manner. Such applications would store their data as graph of connected nodes possibly having additional information attached to them. However, position and size coordinates of nodes might be unnecessary and/or unavailable. MindFusion.Diagramming provides a way to automatically arrange the nodes of a diagram, applying attractive layouts on the overall structure of the diagram. To utilize that functionality, an application can create a diagram by assigning generic coordinates to its nodes, instantiating a layout object and invoking the layout's Arrange method.

The Arrange methods can be prevented from changing positions of individual items by setting the IgnoreLayout property of those items to true.

Tree Layout

If application's data is structured hierarchically, it is appropriate to apply tree layout on it. To do this, create a TreeLayout object and call its Arrange method. Members of TreeLayout control many aspects of the layout process. The type of layout can be directional or radial. You can choose how much space to leave between tree levels and between nodes on the same level. For directional layouts the style of links in the arranged tree can be set to straight, orthogonal or curved. Global tree direction and alignment can be customized too. In VB.NET and C#, tree layout might be applied like this:

C#

using MindFusion.Diagramming;
using MindFusion.Diagramming.Layout;

...

private void button1_Click(object sender, EventArgs e)
{
TreeLayout tl = new TreeLayout();
tl.Type = TreeLayoutType.Cascading;
tl.Direction = TreeLayoutDirections.LeftToRight;
tl.LinkStyle = TreeLayoutLinkType.Cascading2;
tl.LevelDistance = 10;
tl.Arrange(diagram);
}

Visual Basic

Imports MindFusion.Diagramming
Imports MindFusion.Diagramming.Layout

...

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim tl As New TreeLayout()
tl.Type = TreeLayoutType.Cascading
tl.Direction = TreeLayoutDirections.LeftToRight
tl.LinkStyle = TreeLayoutLinkType.Cascading2
tl.LevelDistance = 10
tl.Arrange(diagram)

End Sub

Spring-Embedder Graph Layout

Spring-Embedder is force-directed layout algorithm. It simulates a physical system in which nodes repulse each other, and the links between them act as confining springs. Graphs processed by Spring-Embedder have their nodes distributed uniformly across the diagram area. The algorithm can be applied on a graph by creating a SpringLayout object and calling its Arrange method. Members of SpringLayout allow you to set the desired distance between graph nodes and the number of iteration steps to use while calculating node positions. You can also specify to minimize link crossings. If you select that option, the algorithm would produce better result with more iteration steps. However, it needs more time to complete if more steps are specified. In VB.NET and C#, Spring-Embedder layout might be applied like this:

C#

using MindFusion.Diagramming;
using MindFusion.Diagramming.Layout;

...

private void button1_Click(object sender, EventArgs e)
{
SpringLayout sl = new SpringLayout();
sl.IterationCount = 500;
sl.NodeDistance = 30;
sl.Arrange(diagram);
}

Visual Basic

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim sl As New SpringLayout()
sl.IterationCount = 500
sl.NodeDistance = 30
sl.Arrange(diagram)

End Sub

Layered Graph Layout

The LayeredLayout algorithm arranges diagram nodes in layers according to several criteria, most important of which are: connected nodes must be placed close together; links must flow in one direction if possible; links must cross as few layers as possible; links must not cross other links. To apply the layout to a diagram, create a LayeredLayout instance, set its members and invoke the Arrange method. In C# and VB.NET, layered layout can be applied like this:

C#

using MindFusion.Diagramming;
using MindFusion.Diagramming.Layout;

...

private void btnArrange_Click(object sender, System.EventArgs e)
{
LayeredLayout ll = new LayeredLayout();
ll.Orientation = MindFusion.Diagramming.Layout.Orientation.Horizontal;
ll.SplitLayers = true;
ll.LayerDistance = 35;
ll.Arrange(diagram);
}

Visual Basic

Imports MindFusion.Diagramming
Imports MindFusion.Diagramming.Layout

...

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim ll = New LayeredLayout()
ll.Orientation = MindFusion.Diagramming.Layout.Orientation.Horizontal
ll.SplitLayers = True
ll.LayerDistance = 35
ll.Arrange(Diagram)

End Sub

Grid Graph Layout

The GridLayout algorithm arranges diagram nodes in a grid, keeping connected nodes close together. The algorithm strives to achieve a small number of link crossings. It is based on an iterative process whose initial steps shuffle the grid nodes randomly. That can lead to very different results each time the algorithm is run.

To apply the layout to a diagram, create a GridLayout instance, set its members and invoke the Arrange method. Grid layout might be applied like this:

C#

using MindFusion.Diagramming;
using MindFusion.Diagramming.Layout;

...

private void button1_Click(object sender, EventArgs e)
{
GridLayout gl = new GridLayout();
gl.GridSize = 75;
gl.Arrange(diagram);
}

Visual Basic

Imports MindFusion.Diagramming
Imports MindFusion.Diagramming.Layout

...

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim gl As New GridLayout()
gl.GridSize = 75
gl.Arrange(diagram)

End Sub

Simulated Annealing Graph Layout

The AnnealLayout class implements the Simulated Annealing graph layout algorithm. Simulated Annealing is a general-purpose optimization method used to solve large-scale combinatorial problems by simulating the process of heating and cooling of metal to achieve freedom from defects. Finding a nice arrangement of a graph is a combinatorial problem that can be reduced to assigning costs to graph configurations and finding the minimum cost configuration. AnnealLayout assigns costs to graph configurations by evaluating different aesthetic criteria such as distance between nodes, length of links and the number of link crossings. Thus the best configuration found will have good aesthetic properties.

Workflow Graph Layout

The FlowLayout algorithm can be used to lay out flowcharts, workflow and process diagrams. It works by applying a customizable set of rules for local positioning of connected nodes relatively to each other. On a larger scale, the algorithm keeps groups of nodes separate and prevents links between the groups from crossing nodes. The FlowLayout and ProcessLayout examples included in the MindFusion.Diagramming package demonstrate two sample sets of layout rules.

Orthogonal Graph Layout

The OrthogonalLayout class implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings. This algorithm was designed for planar graphs where the nodes have at most four incident links, and produces best results with such graphs as input. It can arrange any arbitrary graph as well, by adding some dummy nodes and links to planarize the graph and reduce its vertex degree, and removing them after the layout. However this might lead to using larger area than necessary, due to the space occupied by dummy elements.

Circular Graph Layout

CircularLayout distributes nodes evenly on the circumference of a circle at positions that result in as few link crossing as possible. Set its Radius property to specify the size of the layout circle. Use SiftingRounds to set the number of fine-tuning crossing-reduction iterations.

Orthogonal Router

OrthogonalRouter is a secondary layout algorithm that can be used to arrange links after an initial node arrangement has already been applied. The orthogonal layout is useful when there are much more links than nodes in a graph. The algorithm strives to achieve the following criteria, while preserving as much of the initial node configuration as possible.

  • links must not overlap;
  • only vertical and horizontal routing lines are used;
  • graph routing is performed with respect to the specified main layout direction;
  • links crossings are minimized;
  • bends are minimized;


Link Routing

Routed links avoid nodes marked as Obstacles by finding the shortest path between their origin and destination that does not cross any other nodes.

Automatic or Explicit Routing

The RouteAllLinks method can be invoked to explicitly rearrange links in a way they do not cross nodes. In addition, links have an AutoRoute property that enables or disables automatic routing of a link; that property is initialized from the diagram's RouteLinks member. The TriggerRerouting member of the RoutingOptions class specifies when links should be rerouted automatically.

Tuning the Routing Algorithm

The RoutingOptions class allows customizing various aspects of the routing algorithm. That algorithm evaluates possible paths aiming to find one that has a minimal cost. The values of LengthCost, TurnCost, CrossingCost and NodeVicinityCost are added to the total cost of a route and have a great influence over the shape of the chosen path. The StartOrientation and EndOrientation properties specify the orientation of the first and last segments of routed links.


Anchor Points and Patterns

Anchor Points

For each node you can define one or more points to which links should dock when connecting to that node. Such points are represented by instances of the AnchorPoint class. The position of an anchor point relative to node's bounding rectangle is specified via the X and Y properties. Their values are expressed as percent of the node's width and height to accommodate for moving and resizing. The final location of an anchor point is determined by this simple calculation:

C#

return new PointF(
nodeRect.X + nodeRect.Width * X / 100,
nodeRect.Y + nodeRect.Height * Y / 100);

Visual Basic

Return New PointF( _
nodeRect.X + nodeRect.Width * X / 100, _
nodeRect.Y + nodeRect.Height * Y / 100)

You can control whether an anchor point accepts incoming or outgoing links or both. That is done via the AllowIncoming and AllowOutgoing properties. When a link is drawn, its ends are aligned to the nearest anchors allowing docking of the respective end type. Another way to control whether links can be connected to an anchor point is to handle the ValidateAnchorPoint event.

Anchor Patterns

An AnchorPattern instance defines a set of anchor points to be used together. When creating an anchor pattern, pass to its constructor an array of AnchorPoint objects. The AnchorPattern class exposes several predefined patterns as static properties. An existing pattern can be assigned as a single entity to the AnchorPattern property of nodes. The following example creates a pattern of four anchor points:

C#

apat1 = new AnchorPattern(new AnchorPoint[] {
new AnchorPoint(50, 0, true, true),
new AnchorPoint(100, 50, true, true),
new AnchorPoint(50, 100, true, true),
new AnchorPoint(0, 50, true, true)});

Visual Basic

apat1 = new AnchorPattern(new AnchorPoint() { _
new AnchorPoint(50, 0, true, true), _
new AnchorPoint(100, 50, true, true), _
new AnchorPoint(50, 100, true, true), _
new AnchorPoint(0, 50, true, true) })

The points are located at the middles of bounding rectangle sides of nodes to which the pattern is assigned. All four points accept both incoming and outgoing links.

Anchor Patterns and Tables

A distinct anchor pattern can be assigned to every row of a table. When a link is connected to a row, the respective end of the link is aligned to the nearest AnchorPoint assigned to that row. If a row does not have associated anchor points of the appropriate type (incoming/outgoing), the link will be connected to the nearest row that has such anchors defined. If none of the rows of a table has an associated anchor pattern, links are connected to the middle of the left or right side of the pointed row.

Anchor Points and User Interaction

By default, a link is attached to an anchor point only when the link is created. Afterwards, the user can move the link end to any part of the node. To ensure that links always stay attached to an anchor point even after subsequent modifications done by the user, set the SnapToAnchor property to CreateOrModify. You can prevent the user from attaching specific links to specific anchor points by handling the ValidateAnchorPoint event.

Setting Anchor Point Programmatically

You can connect a link to a specific anchor point by setting the link's OriginAnchor and DestinationAnchor properties to the index of the point in the respective node's AnchorPattern. The ReassignAnchorPoints method of DiagramLink automatically chooses anchor points of the origin and destination nodes that are close to each other, so that the link takes a shorter path between the nodes. The ReassignAnchorPoints method of DiagramNode sets the anchor point of each link connected to the node so that links are evenly distributed among the available anchor points.


Undo and Redo

The following topics are contained within this topic:

Overview
Introduces to the MindFusion.Diagramming undo system.

Actions and Commands
Previews the available actions on a diagram and their associated undo/redo commands.

Undo Manager
Introduces the UndoManager class.

Command History
Information about the command history where all previously executed commands are stored.

Undo or Redo of Property Changes
Information on how to undo/redo changes in diagram item properties.

Composite Commands
Demonstrates how to encapsulate a set of commands as a single command that can be undone as an atomic operation.

Subclassing the Command Class
Information on how to create custom commands.


Overview

Interactive actions, carried out by users, and programmatic commands that change the structure of a diagram are recorded in a history queue. While action records are still in that queue, the actions can be undone or redone. The queue has a fixed length - if it gets full, recording a new action makes the oldest one drop from the queue.

Undo is disabled by default. To enable it, set the UndoEnabled property to true. To undo or redo an action, call the Undo or Redo methods of UndoManager. MindFusion.Diagramming does not provide keyboard shortcuts for undo/redo. Your application must have its own menu items and/or keyboard accelerators to provide the necessary user interface, and invoke the respective methods in response to UI events.

MindFusion.Diagramming automatically saves the following types of actions for later undo/redo:

  • adding an item to the diagram
  • removing an item from the diagram
  • moving or resizing items
  • creating a group
  • destroying a group
  • expanding or collapsing trees
  • scrolling table rows
  • adding or removing tables' rows

Changes to property values are not saved automatically in the history. If your application must be able to undo/redo property changes, use the ChangeItemCmd command. ChangeItemCmd allows recording several property changes as an atomic undoable action.

In some cases you may need to create your own types of actions or commands. For example, suppose you need to implement undo/redo for changes made to the Tag property of items or changes to controls embedded in ControlNode items. However, MindFusion.Diagramming is not able to detect such changes, so it cannot undo them. To enable undo/redo you would have to create a subclass of Command and implement its Execute, Undo and Redo methods.


Actions and Commands

Undoable interactive actions and programmatic commands that can be carried out by MindFusion.Diagramming are represented by Command subclasses. The Command class provides the necessary interface to Execute, Undo or Redo actions. In some cases you will have to implement these methods in derived classes, but you must not call them directly. Use the Undo or Redo methods of the UndoManager to undo or redo a command. The UndoManager methods call the respective Command methods and in addition update the state of the command history and the Diagram.

The following MindFusion.Diagramming classes are derived from Command:

Command | Description
AddItemCmd | Adds a new item to the diagram.
RemoveItemCmd | Removes an item from the diagram.
AddGroupCmd | Creates a new hierarchical group.
RemoveGroupCmd | Destroys a group.
GroupAttachCmd | Attaches an item to a group.
GroupDetachCmd | Detaches an item from a group.
ModifyItemCmd | Moves or resizes an item.
RedimTableCmd | Change number of table's columns or rows.
ExpandItemCmd | Expands or collapses a tree of items.
ScrollTableCmd | Scrolls table's rows.
ExpandHeaderRowCmd | Expands or collapses tables sections.
ChangeItemCmd | Handles undo/redo of item property changes.
CompositeCmd | Allows several actions to be undo and redone at the same time.

Instances of most of these classes are created implicitly by MindFusion.Diagramming in response to users' actions or method calls. You might need to explicitly instantiate only ChangeItemCmd - to undo or redo property changes - and CompositeCmd - to present several actions as single undoable operation.

The data of your application might be tightly integrated in MindFusion.Diagramming diagrams, for example via Tag objects or .NET controls embedded in ControlNode items. In these cases MindFusion.Diagramming cannot detect, undo or redo changes to your data. To enable undo of such changes, you must inherit the Command class and implement your versions of the Execute, Undo and Redo methods. To record your own action in the undo/redo history, call the ExecuteCommand method of the Diagram class.


Undo Manager

The undo manager acts as a mediator between commands, the diagram and the command history. It is represented by the UndoManager class, whose only instance can be accessed through the Diagram's UndoManager property.

By default undo functionality is disabled - commands are executed, but are not recorded in history for later undo or redo. To enable undo, set UndoEnabled to true. You might need to disable undo before executing actions you don't want end-users to undo, for example creating special start/end nodes. Another situation in which you might want to disable undo is when creating programmatically a lot of new diagram items - say hundreds or thousands. MindFusion.Diagramming creates an undo record for each item creation; if the Capacity of the command history is smaller than the number of items created, most of the records will drop from the history queue while adding new ones. That would waste processing power and memory for creating undo records that won't be used.

As an alternative, you can create a composite record by calling StartComposite. All subsequent create-item actions are saved in the composite. The composite is saved in the undo history as a single record that allows undo or redo of all constituent actions as a single operation. StartComposite creates and returns a CompositeCmd instance, which is marked as active composite in the undo manager. While there is an active composite, all actions that are carried out are added to it. Call the Execute method of the active composite to stop recording subcommands in it and save it in the history as atomic undoable operation.

Use the Undo and Redo methods of the undo manager to undo or redo actions. Do not call the respective methods of the Command class - they are called internally by the undo manager, and in addition the current command history position is updated and the diagram view is repainted.


Command History

The undo/redo history is represented by a CommandHistory instance. That instance is created by the UndoManager and can be accessed by its History property.

The undo manager adds commands to the history after executing them. If the history queue is full, the oldest command records are removed when new ones are added. Use the Capacity property of CommandHistory to specify how many action records to keep in the queue.

The history has a current-command pointer indicating which are the next commands to undo or redo. If a command is undone, the current pointer in the history queue is moved back and allows undoing even older actions. If the current pointer is not at the last record, any newer commands can be redone again. Each time an action is undone or redone, respectively an ActionUndone or ActionRedone event is fired.

To query which are the next commands to be undone or redone, use the NextUndo and NextRedo read-only properties. They return the Command instances contained in the queue which are referred by the current position pointer. If no further undo or redo is possible, the properties return null (Nothing in Visual Basic). You might use them to indicate to end-users which are the next commands to undo/redo.

C#

if (diagram.UndoManager.History.NextUndo == null)
{
// Everything has been undone
miUndo.Enabled = false;
miUndo.Text = "Undo";
}
else
{
if (diagram.UndoManager.History.NextUndo is AddItemCmd)
{
// The next action to undo is item-creation
miUndo.Enabled = true;
miUndo.Text = "Undo Create";
}
}

Visual Basic

If Diagram.UndoManager.History.NextUndo Is Nothing Then

' Everything has been undone
miUndo.Enabled = False
miUndo.Text = "Undo"

Else

If TypeOf Diagram.UndoManager.History.NextUndo Is AddItemCmd Then

' The next action to undo is item-creation
miUndo.Enabled = True
miUndo.Text = "Undo Create"

End If

End If

To ban end-users from undoing last commands, clear the command history by invoking the Clear method. It is possible to filter some commands so they are not recorded in the history by handling the ActionRecording event.


Undo or Redo of Property Changes

Changes to item properties are not recorded automatically for later undo. To enable undo of property changes, you must explicitly create a ChangeItemCmd instance and add it to the history queue.

The ChangeItemCmd constructor requires a reference to an item as argument and saves the item's initial state to be restored by later Undo. Call the Execute method after one or more assignments to item's properties. Execute records the final state of the item to be restored by later Redo. This allows changes to several properties of an item to be saved within a single record, which can be undone or redone as a single operation:

C#

// Save item state
ChangeItemCmd propChange = new ChangeItemCmd(diagram.Nodes[0], "Change");

// Change properties
ShapeNode shape = (ShapeNode)diagram.Nodes[0];
shape.Text = "new text";
shape.Brush = new SolidBrush(Color.Blue);
shape.Shape = Shape.FromId("Ellipse");

// Add to history
propChange.Execute();

Visual Basic

' Save item state
Dim propChange = New ChangeItemCmd(Diagram.Nodes(0), "Change")

' Change properties
Dim shape As ShapeNode = Diagram.Nodes(0)
shape.Text = "new text"
shape.Brush = New SolidBrush(Color.Blue)
shape.Shape = MindFusion.Diagramming.Shape.FromId("Ellipse")

' Add to history
propChange.Execute()

You might need to treat changes to several items as an atomic operation. To do so, create a CompositeCmd instance and add the ChangeItemCmd commands to the composite by calling the AddSubCmd method:

C#

if (diagram.Selection.Nodes.Count == 0)
return;

// Make all changes seem like a single operation by
// putting them in composite Command
CompositeCmd composite = new CompositeCmd(
diagram, "Change selection");

foreach (DiagramNode node in diagram.Selection.Nodes)
{
ShapeNode shape = node as ShapeNode;
if (shape == null)
continue;

// Save item state
ChangeItemCmd propChange = new ChangeItemCmd(shape, "Change");

// Change properties
shape.Text = "new text";
shape.Brush = new SolidBrush(Color.Blue);

// Add to the composite
composite.AddSubCmd(propChange);
}

// Store final state of all contained commands
composite.Execute();

Visual Basic

If diagram.Selection.Nodes.Count = 0 Then
Return
End If

' Make all changes seem like a single operation by
' putting them in composite Command
Dim composite As CompositeCmd = New CompositeCmd( _
diagram, "Change selection")

Dim node As DiagramNode
For Each node In diagram.Selection.Nodes

Dim shape As ShapeNode = CType(node, ShapeNode)
If Not shape Is Nothing Then

' Save item state
Dim propChange As ChangeItemCmd = New ChangeItemCmd(shape, "Change")

' Change properties
shape.Text = "new text"
shape.Brush = New SolidBrush(Color.Blue)

' Add to the composite
composite.AddSubCmd(propChange)

End If

Next

' Store final state of all contained commands
composite.Execute()


Composite Commands

Sometimes you might prefer having a set of actions undo and redo as a single atomic operation. MindFusion.Diagramming provides the CompositeCmd class to help you with that. CompositeCmd objects act as containers of other Command-derived objects. When Undo or Redo are invoked on a composite command, all its subcommands are respectively undone or redone.

To add a command to the composite call the AddSubCmd method. Call Execute to execute all subcommands contained in the composite. Subcommands are executed or redone in the same order in which they were added to the container, and are undone in the opposite order.

Often MindFusion.Diagramming implicitly generates Command objects in response to users actions or method calls, and automatically records them in the history queue. You do not have direct access to those commands and cannot add them to a composite by AddSubCmd. To enable creating composites in such cases, the undo manager provides the notion of active composite. Active composite is created by calling the StartComposite function of UndoManager. Each action executed after that is made part of the composite, instead of adding it directly to the command history. Invoking the Execute method of the current composite completes it and saves it in the history queue.

C#

// Implicitly created undo records will be saved here
CompositeCmd composite = diagram.UndoManager.StartComposite("Create group");

// Call methods that create undo records
ShapeNode node1 = diagram.Factory.CreateShapeNode(0, 0, 30, 30);
ShapeNode node2 = diagram.Factory.CreateShapeNode (0, 0, 15, 15);
Group g = diagram.Factory.CreateGroup(node1);
g.AttachToCorner(node2, 0);

// This goes to the active composite too
ChangeItemCmd change = new ChangeItemCmd(node2, "");
node2.Locked = true;
change.Execute();

// Save the active composite in history
composite.Execute();

Visual Basic

' Implicitly created undo records will be saved here
Dim composite As CompositeCmd = Diagram.UndoManager.StartComposite("Create group")

' Call methods that create undo records
Dim node1 As ShapeNode = Diagram.Factory.CreateShapeNode(0, 0, 30, 30)
Dim node2 As ShapeNode = Diagram.Factory.CreateShapeNode(0, 0, 15, 15)
Dim g As Group = Diagram.Factory.CreateGroup(node1)
g.AttachToCorner(node2, 0)

' This goes to the active composite too
Dim change As New ChangeItemCmd(node2, "")
node2.Locked = True
change.Execute()

' Save the active composite in history
composite.Execute()


Subclassing the Command Class

MindFusion.Diagramming diagrams can be just a part of the data model of your application, which might already have undo/redo functions implemented for its native data. To integrate MindFusion.Diagramming undo functionality into the application's undo mechanism, use the ActionRecorded event. When the event is fired, add a corresponding wrapper-record to your application's history from the event handler. The wrapper could just call Undo and Redo methods of the UndoManager. In such situations make sure the MindFusion.Diagramming's history Capacity is at least as big as your application's.

Another possibility is to reuse MindFusion.Diagramming's undo functionality by subclassing Command and creating classes responsible for changes in your application's data. When a change occurs outside the diagram, it can still be recorded by calling the Diagram's ExecuteCommand method and integrated into MindFusion.Diagramming's command history.

A simpler scenario when you might have to subclass Command is using complex objects as tags or embedding controls in ControlNode instances. Actions that change these objects or controls cannot be detected and handled automatically by MindFusion.Diagramming. To integrate such an action into the diagram's undo history, you must create a Command instance that knows how to carry out, undo or redo the action.

Command subclasses must implement Execute, Undo and Redo methods. Actions represented by your subclass must be carried out by executing the ExecuteCommand method of Diagram. ExecuteCommand invokes Execute on the command passed as argument, which is then added to the history queue and whose Undo and Redo methods can be called multiple times later by the undo manager. Usually you can implement Redo as a call to Execute, but if the latter is time consuming, its result state can be saved in an instance member and restored by Redo.

Do not call the Undo and Redo methods of your class directly, just implement them and they will be invoked by UndoManager's Undo or Redo methods when necessary.

The example below shows a simple implementation of Command methods:

C#

public class PersonTag
{
public string Name;
public string Address;

// And so on
...
}

public class AddressChangeCmd : Command
{
public AddressChangeCmd(PersonTag p, string address) :
base("Address change")
{
this.p = p;
this.oldAddress = p.Address;
this.newAddress = address;
}

public override void Execute(bool undoEnabled)
{
p.Address = newAddress;
}

public override void Undo()
{
p.Address = oldAddress;
}

public override void Redo()
{
// Undo manager is enabled if Redo is called
// so pass true for the undoEnabled argument
Execute(true);
}

private PersonTag p;
private string oldAddress;
private string newAddress;
}

...

// Somewhere in later code
PersonTag tag = (PersonTag)diagram. ActiveItem.Tag;
AddressChangeCmd cc = new AddressChangeCmd(tag, "far far away");
diagram.ExecuteCommand(cc);

Visual Basic

Public Class PersonTag

Public Name As String
Public Address As String

' And so on
...

End Class

Public Class AddressChangeCmd
Inherits Command

Public Sub New(ByVal p As PersonTag, ByVal address As String)

MyBase.New("Address change")

Me.p = p
Me.oldAddress = p.Address
Me.newAddress = address

End Sub

Protected Overrides Sub Execute(ByVal undoEnabled As Boolean)

p.Address = newAddress

End Sub

Protected Overrides Sub Undo()

p.Address = oldAddress

End Sub

Protected Overrides Sub Redo()

' Undo manager is enabled if Redo is called
' so pass true for the undoEnabled argument
Execute(True)

End Sub

Private p As PersonTag
Private oldAddress As String
Private newAddress As String

End Class

...

' Somewhere in later code
Dim tag As PersonTag = CType(diagram.ActiveItem.Tag, PersonTag)
Dim cc As AddressChangeCmd = New AddressChangeCmd(tag, "far far away")
diagram.ExecuteCommand(cc)


Diagram Serialization and Output

The following topics are contained within this topic:

Serialization of Diagrams
Information on how to serialize and deserialize MindFusion.Diagramming diagrams to binary and XML files.

Printing and Print Preview
Information about how to setup, preview and print diagrams.

Exporting the Diagram
How to export diagrams to Image files, Pdf, Svg, Dxf and Visio formats.


Serialization of MindFusion.Diagramming Diagrams

Saving and Loading Diagrams

MindFusion.Diagramming diagrams can be serialized in byte sequences wrapped by .NET streams. Such streams may represent files, memory buffers, communication pipes, TCP sockets, and so on. In serialized form a diagram might be saved in a database record too. To save the current diagram into a stream, call the SaveToStream method, and respectively to load a diagram from a stream call LoadFromStream. Two shortcut methods are provided for work with files. SaveToFile creates a disk file and a stream that wraps it and invokes SaveToStream. LoadFromFile opens a read-stream on a disk file and invokes LoadFromStream.

Saving Attached Data

All objects referenced by the diagram, such as images and fonts, are serialized together with the diagram elements. The Tag objects that are associated with diagram elements are also saved if they are of value data type, if they are marked as [Serializable] or if their class implements the ISerializable interface. If a tag is not serializable it won't be saved by the Save* methods.

XML Serialization

It is possible to save a diagram as an XML document. To do that, call the SaveToXml method of the Diagram class. To deserialize a diagram back from its XML representation, call the LoadFromXml method.

Exporting Images

You can create a static image representing the current diagram using the CreateImage method. The method returns an instance of the System.Drawing.Bitmap class. The Bitmap class provides ways to save the image as a Jpeg, Gif or Bmp file, as shown in the following example:

C#

private void btnExport_Click(object sender, System.EventArgs e)
{
Bitmap bmp = diagram.CreateImage();
bmp.Save(@"E:\export.jpg", System.Drawing.Imaging.ImageFormat.Jpeg);
}

Visual Basic

Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click

Dim bmp As Bitmap = diagram.CreateImage()
bmp.Save("E:\export.jpg", System.Drawing.Imaging.ImageFormat.Jpeg)

End Sub


Exporting the Diagram

Exporting Images

You can create a static image representing the current diagram using the CreateImage method. The method returns an instance of the System.Drawing.Bitmap class. The following example shows how to export a diagram to a Png image file in response to pressing a button, using the SaveFileDialog control where the location is selected and the name of the image file is entered:

C#

private void btnPngExport_Click(object sender, System.EventArgs e)
{
saveFileDialog.DefaultExt = "png";
saveFileDialog.Filter = "PNG files|*.png";
if (saveFileDialog.ShowDialog() == DialogResult.OK)
{
Image image = diagram1.CreateImage();
image.Save(saveFileDialog.FileName);
image.Dispose();
}
}

Visual Basic

Private Sub btnPngExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPngExport.Click
saveFileDialog.DefaultExt = "png"
saveFileDialog.Filter = "PNG files|*.png"
If saveFileDialog1.ShowDialog() = DialogResult.OK Then

Dim image As Image = diagram1.CreateImage()
image.Save(saveFileDialog1.FileName)
image.Dispose()
End If
End Sub

The MindFusion.Diagramming.Export Namespace contains classes for exporting to Dxf, Pdf, Svg and Visio formats.

Exporting to DXF files

Add a reference to the MindFusion.Diagramming.Export.Dxf.dll to your project. Create a DxfExporter instance and call its Export method, specifying a Diagram object and a file path as arguments. Raster images can be used in DXF by referencing external image files. To export the images displayed in diagram elements, enable the ExportImages property. If your application supports the multiple-line text DXF entity - MTEXT, use the ExportTextAsMultiline property. The following example shows how to create a DxfExporter instance and export a diagram by performing the Export method passing the Diagram object and the file name entered in a SaveFileDialog.

C#

MindFusion.Diagramming.Export.DxfExporter dxfExp = new MindFusion.Diagramming.Export.DxfExporter();
dxfExp.Export(diagramView1.Diagram, saveFileDialog.FileName);

Exporting to Pdf files

Add references to the MindFusion.Diagramming.Export.Pdf.dll and MindFusion.Pdf.dll assemblies to your project. Create a PdfExporter instance and call its Export method. Margins specifies the page margins for all pages in the document. If you need to set the page size and orientation, use the PageSize, and PageOrientation properties. The AutoScale property allows scaling the diagram to fit in one or more PDF pages. If invisible items should be displayed in the PDF, enable the InvisibleItems property. The following example shows how to export a diagram to a Pdf file in response to pressing a button event and using the SaveFileDialog control where the location is selected and the name of the Pdf file is entered:

C#

private void button1_Click(object sender, EventArgs e)
{
saveFileDialog.DefaultExt = "pdf";
saveFileDialog.Filter = "PDF files|*.pdf";
if (saveFileDialog.ShowDialog() == DialogResult.OK)
{
MindFusion.Diagramming.Export.PdfExporter pdfExp = new MindFusion.Diagramming.Export.PdfExporter();
pdfExp.Export(diagramView1.Diagram, saveFileDialog.FileName);
}
}

Visual Basic

Private Sub button1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles button1.Click
saveFileDialog.DefaultExt = "pdf"
saveFileDialog.Filter = "PDF files|*.pdf"
If saveFileDialog.ShowDialog() = DialogResult.OK Then
pdfExp.Export(diagramView1.Diagram, saveFileDialog.FileName)
End If
End Sub
Dim pdfExp As New MindFusion.Diagramming.Export.PdfExporter

Exporting to Svg files

Add references to the MindFusion.Diagramming.Export.Svg.dll and MindFusion.Svg.dll assemblies to your project. Create an SvgExporter instance and call its Export method, passing a Diagram object and the full path to the .svg file as parameters. To export images displayed by diagram items to external files, enable the ExternalImages property.

C#

MindFusion.Diagramming.Export.SvgExporter svgExp = new MindFusion.Diagramming.Export.SvgExporter();
svgExp.ExternalImages = false;
svgExp.Export(diagramView.Diagram, saveFileDialog.FileName);

Visual Basic

dim svgExp as MindFusion.Diagramming.Export.SvgExporter = _
new MindFusion.Diagramming.Export.SvgExporter()
svgExp.ExternalImages = False
svgExp.Export(diagramView1.Diagram, saveFileDialog.FileName)

Exporting to Visio files

Add a reference to the MindFusion.Diagramming.Export.Visio.dll to your project. The MindFusion.Diagramming ShapeNode objects are mapped to their closest Visio counterparts and TableNode objects are exported as groups of Visio shapes. MindFusion.Diagramming DiagramLink instances are exported as Visio connectors of a similar style. In addition, most of the attributes of diagram items such as text, text formatting, fill and line colors and styles are preserved.
The exporter object requires the VisioExport.vxt file to be present in the application's directory. This file contains an XML template data used by the component to generate Visio documents.
Create a new instance of the VisioExporter class. Call the Export method passing a Diagram object and the full path to the exported Visio .vdx file as parameters. The Visio page dimension and items size measure unit is set to the diagram's MeasureUnit.
To create Visio groups from the MindFusion.Diagramming groups, enable the CreateVisioGroups property. If a shape node that contains an image should be exported as a Visio group of a shape, picture and text objects, use the ExportImagesAsGroups property set to true by default. ExportInvisibleItems allows exporting of invisible items. If MindFusion.Diagramming TableNode objects should be exported as groups of Visio rectangular shapes, enable the ExportTablesAsGroups property.

The following example shows how to export a diagram to a Visio file in response to choosing a File > Export to > Visio menu item and using the SaveFileDialog control where the location is selected and the name of the Visio file is entered:

C#

private void _menuItemExportVisio_Click(object sender, System.EventArgs e)
{
SaveFileDialog dlg = new SaveFileDialog();

dlg.Filter = "Visio files (*.vdx)|*.vdx|All files|*.*||";

if (dlg.ShowDialog(this) == DialogResult.OK)
{
VisioExporter export = new VisioExporter();
export.Export(_diagram, dlg.FileName);
}
}


Printing and Print Preview

Print or Preview a Diagram

Call the Print method to print the current diagram. PrintPreview displays the standard .NET print-preview window. PrintPreviewEx displays an extended preview form that provides buttons for choosing page orientation and for scaling the print output.

Settings for Printing

The PrintOptions class exposes the available settings for printing and print preview. The visualization properties in that class are used both for printing and for preview. That allows achieving uniform output on the printed pages and on the display. An instance of this structure is accessible via the diagram's PrintOptions property.

Customizing the Extended Print Preview Window

The preview window displayed by PrintPreviewEx can have its UI elements customized via the PreviewOptions class. Members of that class allow assigning images to the preview toolbar buttons and changing the tooltip and menu texts to allow localization of the user interface. The appearance settings for the diagram displayed in the preview window are still set through PrintOptions.

Size of a Printed Diagram

If BackgroundImage is set and EnableBackgroundImage is enabled, the size of a printed diagram is defined solely by the Bounds property. If the actual diagram items occupy only a small portion of the document, there might be some pages printed that do not display any items but just a part of the background image. To avoid that, call ResizeToFitItems before printing.

If no background image is used, MindFusion.Diagramming prints only the part of a document containing all items that are both Visible and Printable. That avoids printing blank pages.

Print Scaling

The Scale property allows printing a diagram in larger or smaller proportions than the actual ones. ScaleToPage automatically calculates Scale so that the whole diagram fits in a single printed page.


Appearance

The following topics are contained within this topic:

Brush and Pen Classes
Introduces the MindFusion wrappers of the standard GDI+ pens and brushes.

Modifying Appearance
General options affecting the appearance of a MindFusion.Diagramming diagram.

Customizing the Appearance of Items
Information about how to modify various aspects of the appearance of individual diagram items.

User Defined Node Shapes and Custom Drawing
Information on how to define arbitrary node shapes as well as how to use custom-drawing.

Text Attributes and Formatting
Provides information on how to customize the text of diagram items and lists all possible formatting tags.


Brush and Pen Classes

MindFusion.Diagramming defines proxy classes to wrap the functionality of standard .NET brushes and pens and expose them as properties of diagram elements. Those classes, located in the MindFusion.Drawing namespace, have the same names as their System.Drawing counterparts. There are five brush classes that inherit the abstract class Brush, namely HatchBrush, LinearGradientBrush, PathGradientBrush, SolidBrush and TextureBrush. There's also a Pen class - proxy for the .NET Pen.

There are two reasons to use proxy classes instead the original GDI classes. First, the GDI resources are limited and would be exhausted by keeping a GDI pen and brush attached all the time to each diagram element; by using proxies the GDI pen and brush are created only at the time of drawing, and immediately disposed after that. Second, the GDI Pen and Brush classes don't support serialization; the proxy-classes implement the required interfaces instead.

Otherwise the proxy classes expose the same properties as their GDI counterparts. You might set default pen and brush properties like this:

C#

diagram.ShapeBrush = new MindFusion.Drawing.LinearGradientBrush(
Color.Yellow, Color.BurlyWood, 20);

MindFusion.Drawing.Brush penBrush = new MindFusion.Drawing.LinearGradientBrush(
Color.Bisque, Color.Blue, 0);
diagram.ShapePen = new MindFusion.Drawing.Pen(penBrush);

Visual Basic

Diagram.ShapeBrush = New MindFusion.Drawing.LinearGradientBrush( _
Color.Yellow, Color.BurlyWood, 20)

Dim penBrush As MindFusion.Drawing.Brush = New MindFusion.Drawing.LinearGradientBrush( _
Color.Bisque, Color.Blue, 0)
Diagram.ShapePen = New MindFusion.Drawing.Pen(penBrush)

After that piece of code is executed, every new shape node created will have gradient brush and pen.

Instances of those classes can be assigned to the Pen and Brush properties of each diagram element.


Modifying MindFusion.Diagramming Appearance

You can customize most of the diagram visualization effects.

Background

The Diagram background area can be filled using a solid brush, gradient, texture or color patterns, by setting the BackBrush property. Background theme can also be an image set by the BackgroundImage property. The image can be any from the supported by the .NET System.Drawing.Image file formats - metafiles, icons, bitmaps, jpegs or gifs. Background image can be centered, aligned to a corner of the control or document, tiled or stretched to cover the drawing area - depending on the BackgroundImageAlign property value. It is possible to paint the area outside Bounds using a distinct brush by setting the ExteriorBrush property.

Smoothing

The SmoothingMode property enables or disables antialiasing of lines and curves rendered in the diagram view. The TextRenderingHint property enables or disables smoothing of text.

Shadows

By default all diagram items have shadows drawn under them. If ShadowsStyle is set to OneLevel, the item shadows are drawn at the lowest Z-level under all items, which makes them look as on single Z-level. If it is set to ZOrder each shadow is drawn immediately under its corresponding item, possibly covering parts of other items, which gives more 3D-like look to the diagram. If the style is set to OneLevel no shadows are drawn. The shadows offset from items is specified by the ShadowOffsetX and ShadowOffsetY properties or the SetShadowOffset method. Shadow colors are painted as set by ShadowColor property value.

Selection

The color of selection handles drawn around the active item can be set with the ActiveItemHandlesColor property. Items in multiple selection have their handles drawn in the color specified by the SelectedItemHandlesColor property. Disabled manipulation handles are painted in DisabledHandlesColor when ShowDisabledHandles is enabled (see EnabledHandles). The Style property of the Selection class controls the way multiple selection is displayed.

Mouse Cursors

Different mouse cursor icons can be set to give context-sensitive feedback to users, prompting them if creation/modification of an item is possible. The following properties specify what cursors are displayed at different situations: PointerCursor, MoveCursor, DisallowCursor, DrawLinkCursor, AllowLinkCursor, DisallowLinkCursor, HorizontalResizeCursor, VerticalResizeCursor, DiagonalResizeCursor, CounterDiagonalResizeCursor. MindFusion.Diagramming displays the PanCursor while panning the diagram view. Set the CurrentCursor if you need to change the cursor from a mouse movement related event handler.

Grid Settings

An alignment grid is drawn if the ShowGrid is set to true. The GridColor property specifies the color of grid points.


Customizing the Appearance of Items

For every MindFusion.Diagramming item, different visual styles and properties can be set as described in the following paragraphs.

Pen Width and Style

The borders of nodes and the lines of links are drawn using a pen whose color, width and style can be customized through the Pen property.

Color of Diagram Elements

The color of link segments can be set using the Pen property. Brush specifies how closed arrowhead shapes are filled. TextColor is used for rendering link's text. Nodes have three properties for colors: the color of node borders is specified through the Pen property; the interior of a node is filled using Brush; TextColor specifies the color for rendering text. Tables have a special property for their caption color - CaptionColor.

Text

Diagram items can have attached text, displayed inside / over them.

Text of shape nodes is set using their Text property and the text format and alignment style is specified using TextFormat. The text of shape nodes can be laid out and rendered inside a polygonal outline; that depends on the value of PolygonalTextLayout. To make a node big enough to display its text without clipping, call ResizeToFitText.

Links have their text drawn horizontally above their middle segment or rotated as specified via TextStyle; the string to display can be set using the Text property.

Tables have caption text specified via Caption; table cells expose Text property and their text can be formatted via TextFormat.

All diagram items expose Font property, specifying the name, style and size of the font of item's text. The color of item's text is set in its corresponding TextColor property.

Images

Shape nodes and tables can display images inside them. Use ShapeNode.Image and TableNode.Image properties to load images into the respective items. A node can be made the same size as the image it contains by calling ResizeToFitImage.

Images can be positioned in different ways: they can be tiled, stretched or aligned to the containing nodes' centers or sides. Use ShapeNode.ImageAlign and TableNode.ImageAlign to specify how images are placed within the corresponding nodes. An image shown inside a node is clipped in accordance with the shape of that node.

Table cells can have Image and ImageAlign assigned too. For example that might be used to display an icon for the key field of a database table.

Shadow Offset

The shadow of each diagram item can be painted with a distinct color, as specified via the item's ShadowColor property. Shadow offsets from their items can be set individually via the ShadowOffsetX and ShadowOffsetY properties. Set those to zero to hide item's shadow.

DiagramLink-specific Properties

The shape and orientation of link segments is specified by the Style property; the number of segments is specified by the SegmentCount property. The form and size of the arrowhead shape is set using the HeadShape and HeadShapeSize properties. Shapes displayed at the origin of links are defined by BaseShape and BaseShapeSize. Shapes can be displayed at middles of segments, helping to follow the path of long links. They are defined by the IntermediateShape and IntermediateShapeSize properties. The lines of arrowhead shapes are painted using the HeadPen pen. Custom painting code may be invoked for a link, as set in CustomDraw.

Rounded Links

Links comprising straight segments, that is, ones whose Style is set to Polyline or Cascading, can use arcs to join their adjacent segments. To enable that feature, set RoundedLinks to true. Use RoundedLinksRadius to set the radius of the joining arcs.

Link Crossings

Intersection points where links cross their paths can be rendered as arcs or breaks, as specified via LinkCrossings. It depends on the Z-order, which links jump over the others, or which links appear cut by the others. If LinkCrossings is set to Arcs, links with higher ZIndex jump over those with lower ZIndex. If set to Cut, links at lower Z position are cut by links at higher Z. Radius of arcs and breaks can be set through the CrossingRadius property.

ShapeNode-specific Properties

The shape of a node is defined using its Shape property. Shape templates can be applied to a shape node with an orientation of 0/90/180/270 degrees as specified via the ShapeOrientation property. Your own drawing code may be invoked for a node, depending on the value of CustomDraw. Shape nodes can be marked as Transparent, having only their text or images rendered.

TableNode-specific Properties

The outline of a table can be either a rectangle or rounded rectangle, as specified via the Style property. The borders of table cells can be rendered in different ways, depending on the value of CellFrameStyle. The table caption area is painted using the CaptionBackBrush brush. Custom painting can be performed on a table and its cells as set in the CustomDraw and CellCustomDraw properties.


User Defined Node Shapes and Custom Drawing

The appearance of MindFusion.Diagramming items can be customized in several additional ways, as described below.

Shape Templates

The Shape class provides the means for defining complex node shapes, made of straight lines, arcs and Bézier curves. A shape template must always contain an outline to be used for hit testing, clipping and finding intersections with other items. Optionally, shapes can contain decoration elements and text region definitions. Decorations are visual elements that do not take part in hit testing and clipping. Text regions are the parts of shapes in which node's text is laid out and rendered. MindFusion.Diagramming provides a set of 87 predefined shape templates, which can be accessed through the Shapes collection or FromId method of the Shape class. Each predefined shape has a string identifier assigned to it. Use the FromId method to find a shape with the specified id. A shape template can be assigned to the Shape member of shape nodes.

Shape Libraries

The ShapeDesigner tool included in the MindFusion.Diagramming suite lets you draw custom shapes and store them in shape libraries. A library file can be loaded into your application using the ShapeLibrary class. The definitions loaded from a shape library are automatically added to the Shapes collection and can be accessed through the FromId method, just as the predefined shapes.

Custom Painting

Another way to customize item's appearance is implemented by raising an event each time an item is painted, giving you the option to attach your own drawing code to the MindFusion.Diagramming's rendering engine. Use the corresponding CustomDraw property of items to enable that feature in your application.

MindFusion.Diagramming provides several options for custom drawing. If you choose Additional drawing style, your drawing code will be executed after the standard item drawing code is executed and Image is rendered, but before the text is rendered. Furthermore, the Graphics object you receive to draw on has a clipping region applied that corresponds to a node's shape. If using Full drawing mode, none of the standard MindFusion.Diagramming drawing code is executed - just yours. The ShadowOnly mode performs standard painting of items, but leaves the drawing of shadows to your code.

Place your own drawing code in a handler of the DrawNode, DrawCell and DrawLink events. These events are fired for each custom-drawn item that needs repainting.

Combining Custom Shapes with Custom Drawing

Finally, you could combine user-defined shapes with the Additional custom-painting style. Thus, you can get custom shapes enabled for a node and your custom painting code executing with the node shape used as clipping region. You might clear the clipping region, but be careful - if you draw outside node's bounding rectangle the view may not update correctly.


Text Attributes and Formatting

Text in Shape Nodes

A ShapeNode node can display Text within its outlines. Text position and alignment depend on the value of TextFormat. The text is painted with the color set in TextColor. Even more useful layout and formatting attributes can be enabled via PolygonalTextLayout and EnableStyledText.

Layout Text in Arbitrary Shapes

ShapeNode instances can have various shapes, as specified via their Shape and ShapeOrientation properties. To layout text inside non-rectangular shapes, enable PolygonalTextLayout. If enabled, MindFusion.Diagramming uses a formatting algorithm that fits exactly each line of text within the width of a line inside a polygonal shape. If a shape node has curved outlines, the formatting algorithm approximates them the poly-lines.

Text Wrapping

If there isn't enough space available to fit a whole line of text, MindFusion.Diagramming wraps the text to a new line when it reaches the edge of the node. You can specify that the text should be wrapped only at word boundaries by setting the Trimming member of TextFormat to StringTrimming.Word. The default is to split words into multiple parts if there is not enough space to fit a whole word.

If you prefer to use your own line-breaks, you can disable the automatic text wrapping by enabling the NoWrap flag in the FormatFlags member of TextFormat. If automatic wrapping is disabled and there isn't enough space to fit the whole line, the text is clipped at the node boundaries.

Text in Tables

A TableNode can display text in its caption area and inside each cell. Text in the Caption is painted with TextColor and is aligned as specified via CaptionFormat. Text in cells is painted in their own TextColor and is aligned according to their own TextFormat. Even more useful formatting attributes can be enabled via EnableStyledText property.

Styled Text

The ShapeNode.EnableStyledText property of shape nodes and the TableNode.EnableStyledText property of tables enables or disables styled text rendering. Styled text can have various attributes applied to the characters it contains. The attributes are specified using HTML-like formatting tags embedded in the raw text. Shape nodes can display styled text only if PolygonalTextLayout is enabled. Use the DrawStyledText method to display styled text in custom-drawn items.

The following table lists the currently supported style tags:

Tag | Description
<i>text</i> | Indicates italic text.
<b>text</b> | Indicates bold text.
<u>text</u> | Indicates underlined text.
<sub>text</sub> | Indicates subscript.
<sup>text</sup> | Indicates superscript.
<color=#RRGGBB>text</color> | Changes the color of the text. The red green and blue color channels are specified as two-digit hexadecimal numbers.

When styled text is enabled, you must use &lt;, &gt; and &amp; to display respectively the <, > and & symbols.

Links' Text

The Text of a DiagramLink is painted with the color specified in TextColor and is positioned as set in TextStyle.

Fonts

All items provide a Font property that allows getting or setting the font used for rendering their text. Always set the font's Unit property to World to get correct zooming of items' text and proper formatting and layout.


Initial Values of Item Properties

Each new item, created either by the user or programmatically, is initialized with some kind of default property values.

If you create items by using the new operator and adding them the diagram's Nodes or Links collection, you can initialize the items by passing a Diagram reference to the respective constructor, or by passing another item to the copy constructor. In the former case, item properties are initialized from the default-property values defined in Diagram. In the latter case, properties are copied from the prototype item.

When users draw new items, the items are initialized from the Diagram properties, but you can change the default values by handling the InitializeNode and InitializeLink events.

Items created via the diagram's Factory object are always initialized from the default-property values defined in Diagram.

Below are listed item properties and the corresponding constants or Diagram properties through which they are initialized:

DiagramItem Property | Initialized With
Brush | ShapeBrush TableBrush LinkBrush
Font | Font
Locked | false
Pen | ShapePen TablePen LinkPen
Selected | SelectAfterCreate
ShadowOffsetX | ShadowOffsetX
ShadowOffsetY | ShadowOffsetY
Tag | null
ToolTip | (empty string)
Visible | true

ShapeNode Property | Initialized With
CustomDraw | ShapeCustomDraw
EnabledHandles | AdjustmentHandles.All
Expandable | NodesExpandable
HandlesStyle | ShapeHandlesStyle
Image | null
ImageAlign | ImageAlign.Fit
Text | ShapeText
TextColor | TextColor
TextFormat | TextFormat
Transparent | false

ContainerNode Property | Initialized With
AutoShrink | false
Caption | ContainerCaption
CaptionColor | Black
CaptionFormat | TextFormat
CaptionHeight | ContainerCaptionHeight
Foldable | ContainersFoldable
Folded | false
HighlightPen | ContainerHighlightPen
Margin | ContainerMargin
MinimumSize | ContainerMinimumSize

TableNode Property | Initialized With
Caption | TableCaption
CaptionColor | Color.FromArgb(0, 0, 0)
CaptionFormat | Centered horizontal and vertical alignment
CellCustomDraw | CellCustomDraw
CellFrameStyle | CellFrameStyle
ColumnWidth | TableColumnWidth
CustomDraw | TableCustomDraw
HandlesStyle | TableHandlesStyle
Image | null
ImageAlign | ImageAlign.Fit
ConnectionStyle | TableConnectionStyle
RowHeight | TableRowHeight
Scrollable | TablesScrollable
Style | TableStyle
TextColor | TextColor

DiagramLink Property | Initialized With
BaseShape | LinkBaseShape
BaseShapeSize | LinkBaseShapeSize
HeadShape | LinkHeadShape
HeadShapeSize | LinkHeadShapeSize
AutoRoute | RouteLinks
CascadeOrientation | LinkCascadeOrientation
CustomDraw | LinkCustomDraw
Dynamic | DynamicLinks
HeadPen | LinkPen
IntermediateShape | LinkIntermediateShape
IntermediateShapeSize | LinkIntermediateShapeSize
RetainForm | LinksRetainForm
SegmentCount | LinkSegments
Style | LinkStyle
Text | LinkText
TextColor | TextColor
TextStyle | LinkTextStyle


Display Graphs in 3D

The DiagramView3D control allows displaying diagrams in 3D. It could be used to display graphs with associated 3D spatial data, such as structural formulas of chemical compounds, or to display dense graphs that otherwise would look too cluttered in 2D.

The CameraPosition property specifies the position of the camera in 3D space. To specify the camera's pitch, roll and yaw angles, set the CameraRotation property. PointCameraTo lets you direct the camera to a specified point. The ViewerDistance property specifies the distance of the viewer from the camera.

After changing the camera position or direction, or after changing the location of graph nodes, call the ResetProjection method. It calculates the new projection coordinates of nodes and updates the view.

The following mouse and keyboard actions allow moving the camera around the 3D scene:

  • Mouse drag: Moves the camera across the plane perpendicular to direction of the camera.
  • CTRL+mouse drag: Rotate the camera by changing the pitch and yaw angles.
  • Mouse wheel: Causes moving the camera forwards or backwards.
  • CTRL+mouse wheel: Rolls the camera around the Z-axis.

Set the EnableOrbitingCamera property to true to enable using the CTRL key to move the camera in an orbit around a node.

DiagramView3D uses the following coordinate system:

The X axis is horizontal and points to the right.
The Y axis is vertical and points upwards.
The Z axis specifies depth and its values grow with distance.

Look at the SpringLayout solution in the Samples folder that demonstrates how to apply a 3D SpringLayout algorithm and display a 3D view of the diagram.


Miscellaneous

Associate Custom Data with Items

Every diagram item can be associated with a user-defined value from any data type. Use the Tag property of the DiagramItem class to associate your data with an item. If the associated data is of a value type or of type that is serializable (marked as [Serializable] and implementing the ISerializable interface), then it is saved and loaded together with the diagram items when the MindFusion.Diagramming diagrams are saved or loaded.

Informative Properties and Methods

  • The Intersects method of the DiagramNode class determines whether nodes intersect.
  • The Length method of the DiagramLink class returns the total length of a link.
  • The IsTrialVersion property returns true in trial versions of MindFusion.Diagramming; it returns false in retail licensed versions.


MindFusion.Reporting Overview

The next few chapters will give you an overview of the majority of the MindFusion.Reporting features, grouped by functionality. Hyperlinks refer to the detailed description of methods and properties of each class.


Report Designer

MindFusion.Reporting provides rich design-time support in order to facilitate the creation and modification of reports. The MindFusion.Reporting report designer integrates seamlessly in the MS Visual Studio environment. The designer is very intuitive because its behavior closely resembles the built-in Windows Forms editor of MS Visual Studio. Below you can see a sample report opened in MS Visual Studio using the MindFusion.Reporting designer:

The report designer is automatically activated when you open a source code file containing a MindFusion.Reporting report, that is, when you double-click the file or select the 'View Designer' command from its context menu. The report designer provides means for editing the layout of a report visually. The following sections describe the major features of the MindFusion.Reporting in more details.

Creating report items

Items in the designer can be created in the same way as they are created in a Windows Forms designer - by dragging them from the toolbox and dropping them onto the report designer surface. Alternatively you can double-click on an item in order to create an object of the appropriate type in the currently active report. The report items in the toolbox can be found under the 'MindFusion.Reporting' category, which becomes visible when you activate a report designer. You can also drag common Windows control to the report, which will create a ControlWrapper report item for this control.

Note

The Document Outline window of MS Visual Studio can help you to see the report items in a report. To open the Document Outline window, choose the 'View -> Other Windows -> Document Outline' command from the menu.

For more information about the individual items that can participate in a report, see Report Items.

The report structure

Each report consists of one or more design pages. These pages provide a way to design logically independent parts of complex reports separately. For example, you can have one page for the title of the report and general report information and another for the report's actual contents. You can place all the report elements on a single page and use PageBreak items to denote page breaks but with more complex reports this single page may get rather big and hard to manipulate. Splitting the report into several logical pages can improve the design-time experience in such cases.

Item containment

Each report page can contain an arbitrary number of report items. Certain report items (such as DataRange) can have items on their own, including other containers. This forms a hierarchy of report items, the root of the hierarchy being the report itself.

In order to place a new item in a specific container, drag the item from the MS Visual Studio toolbox and drop it within the container of interest. You can perform the same technique with existing items - simply drag them over the container.

Headers and footers

Report pages can contain headers and footers. The headers and footers contain items that are displayed on each individual instance of the page in the final report layout. For example, a common scenario would be to place a label displaying the current page number in the page footer.

By default, the pages do not have header and footer. In order to create one, right-click on the page surface in the designer and select either the 'Header' or 'Footer' command from the context menu. Make sure you click on an unoccupied section of the page. Otherwise the context menu will contain only the commands specific to the clicked element. The following image displays how the context menu of a report page should look like:

Once the header or footer is created, it becomes visible in the designer and is positioned either above or below the page contents area. The following image illustrates a designer of a page with header and footer, both outlined with a red contour:

You can expand or collapse various page sections by clicking the [image] and [image] buttons in the section's header respectively. Collapsing a section does not affect the way it is rendered in the final report layout. It only affects the design-time appearance of the page.

As with other elements in the report, you can resize page sections by selecting them and dragging the resize handles that appear at the selection border. Page sections can only be resized to the bottom and right. Alternatively you can resize page sections by dragging their headers with the mouse.

Headers and footers for data ranges

DataRange objects can have their own headers and footers, similar to those of the page. The header and footer of a data range are displayed in the beginning and the end of each occurrence of this data range in the final report layout. For example, if a data range is split across two pages, its header and footer will be displayed once on both pages. The header and footer of a data range are usually used to display column header texts.

In order to create a header/footer for a data range, right-click on the data range's surface in the designer and select the 'Header'/'Footer' command from the context menu. Unlike to page, the header and footer of a data range do not have headers and can be resized in any direction.

Designer toolbar

The toolbar is displayed at the top of the report designer. The majority of the commands in the toolbar affect only the behavior of the designer and rarely have impact on the way the report output at run-time.

The following commands are present in the designer toolbar:

Command | Description
Zoom Out | Reduces the size of the report designer. The minimum zoom factor is 100% thus this option can only be used to reverse the effect of the Zoom In command.
Zoom Factor | Displays the current zoom factor. You can type in any zoom factor in the 100-1600% range.
Zoom In | Increases the size of the report designer. The maximum zoom factor is 1600%.
Previous Page | Moves to the previous page in the report.
Current Page | Displays the current page. You can type in a page number to go directly to that page.
Next page | Moves to the next page in the report.
Add Page | Adds a new page at the end of the report.
Delete Page | Deletes the current page. A report should always have at least one page, so, if this is the last page in the report, the deletion will fail.
Toggle Grid | Shows or hides the report designer grid.
Toggle Grid Snap | Turns grid snapping on and off.
Toggle Ordering | Shows or hides the ordering of report items on the current page.

In addition to the default toolbar, the report designer takes advantage of the layout capabilities built in MS Visual Studio. These features can be accessed either through the 'Format' menu or through the 'Layout' toolbar. The toolbar can be displayed by right-clicking on any other MS Visual Studio toolbar and selecting 'Layout' from the context menu.

Designer toolbox

While the report designer is active a new group of elements (called 'MindFusion.Reporting') is visible in the MS Visual Studio Toolbox. It contains all report items available to use in a report.

More detailed information about individual report items can be found in Report Items.


Report Items

The following items are available to use in the MindFusion.Reporting reports. The majority of the report items share two common properties: Location and Size - specifying the position of the element relative to its parent element, and its size respectively.

Page

The page is the most fundamental element of a MindFusion.Reporting report. Pages in the report are represented by objects of the Page class. Each report can contain an arbitrary number of pages. The page itself can contain an arbitrary number of other report elements, such as labels and data ranges. When the report is processed by a call to its Run method, the pages can be split if the target space is insufficient to hold the processed page contents.

Properties

The most notable page properties are Background, Border and PageOrientation. The first two define the background and border of the page. The latter is used to specify the page orientation. If PageOrientation is set to Unspecified, the actual orientation of the page is determined by the defaultPageOrientation parameter passed to the Layout method of the Report class.

Header and footer

Each page can optionally contain a header and/or a footer. Headers are displayed on top of the page, while footers are displayed at the bottom. If a page is split during report processing, its header and footer are displayed for each occurrence of the page in the final layout. You can assign a header and/or a footer to a page either through the report designer (see Report Designer) or through code. The latter requires you to assign a PageSection object to the Header or Footer property of the Page respectively. The following code illustrates this:

C#

// Create the header
PageSection header = new PageSection();

// Perform initialization of the header here, by adding various report items
// to it, for example

// Set the header to a page
page.Header = header;

VB.NET

' Create the header
Dim header As New PageSection()

' Perform initialization of the header here, by adding various report items
' to it, for example

' Set the header to a page
page.Header = header

There are various properties, such as Border, Background and Visible, which affect the visualization of the header and footer in the final layout.

Label

The label elements display text within a report. Labels are represented by the Label class. The text displayed by the label can be either static, a value from a data source or a value calculated by an expression. Additionally, the text can contain various formatting specifiers, such as <b>, <i> and so on. The text displayed by a label is specified through its Text property.

Data-bound labels

Data-bound labels can be created only within DataRange objects. The data source of the label is specified by the DataSource property of its containing DataRange object. The name of the data field that the label is bound to is specified through the DataField property. When DataField is set, the Text property of the label is ignored and the displayed text is determined by the value of the related field in the data source.

Expressions

Labels can display texts more complex than static and data field values. You can include the so-called expressions within the text of the label. When the text is processed, the expressions within it are evaluated and the expressions are replaced with the result of the evaluation.

To embed expressions in the label text enclose the expressions in square brackets. For example, the following label text is valid and it will display the string "Date: " followed by the system's date at the time of evaluation. Note, that the expression in the example is highlighted in bold.

Expression

Date: [Now()]

The result of the evaluation of the above text will be something similar to "Date: 12/10/2008 2:23:38 PM".

It is possible to specify formatting to the value of the expression. To do so, add an '@' symbol after the expression but before the closing ']' then add the string representing the formatting specifier enclosed in quotes. The following example extends the previous one by adding formatting to the resulting date. Note, that the formatting specifier in the example is highlighted in bold.

Expression

Date: [Now()@"d"]

The result of the evaluation will now be similar to the following: "Date: 12/10/2008".

For more information about the expressions in MindFusion.Reporting in general, visit Expressions. For more information on how to use expressions in label texts, check Using Expressions in Label Texts.

Properties

Besides the Text and the DataField properties, labels expose several other properties that can be used to further customize the appearance of the label text. The Alignment, LineAlignment, Padding, Color and Font control how the text of the label is displayed and the position within the label's bounds.

DataRange

The data range elements provide a way to perform data-binding in MindFusion.Reporting reports. The data ranges are represented by the DataRange class. For extensive information about how to data-bind using data ranges can be found in the Binding Reports to a Data Source topic.

Properties

DataRange objects expose some common visualization properties, such as Background and Border. There are two additional properties - AlternatingBackground and AlternatingBorder, both of which default to null (Nothing in Visual Basic). When these properties are assigned values different from null, they are used as the background and border of every second occurrence of this data range in the final layout. In other words, Background and Border are used for the odd occurrences of a data range, while AlternatingBackground and AlternatingBorder are used for the even ones.

The AllowSplit property, when set to false, prevents the data range from splitting to more than one page when the report is processed. The ArrangeByX property specifies whether to lay out data range instances horizontally first, then vertically. If ArrangeByX is set to false (the default), the instances of the data range are always arranged vertically regardless of whether there is space along the x-axis. The Repeat property is used with disconnected data ranges to specify the number of occurrences of these data ranges in the final layout.

Picture

The picture elements enable you to add static images to a report. Pictures are represented by the Picture class. Similarly to labels, pictures can be data-bound if they are positioned within a data-bound DataRange element. To bind a picture to a field in the data source, use its DataField property.

Properties

To assign a static image to a picture, use the Image property. The border and background of the image can be specified through the Border and Background properties respectively. You can rotate the image at arbitrary degrees through the RotationAngle property. The alignment of the displayed image is controlled through the ImageAlign property.

Canvas

The canvas elements can be used in order to perform custom rendering within a report. The canvas elements are represented by the Canvas class. In order to perform drawing within the canvas, you need to handle its RenderContents event. The DrawCanvasEventArgs argument passed to the handler of this event contains an IGraphics object, which can be used to perform the necessary drawing.

Data-bound canvases

You can data-bind canvases in the same way you can bind labels and pictures - by placing them within a data-bound DataRange and setting the appropriate value to its DataField property. The value acquired through the data-binding is supplied to the RenderContents event handler through the DataValue property of the event argument.

Charts

MindFusion.Reporting provides four chart types that can be used in reports. They are represented by the BarChart, LineChart, PieChart and RadarChart classes. Each of these classes provides a set of properties that lets you customize the chart's appearance. For further information, read the topics of the respective classes. For more information on how to use charts in reports, visit Charts in Reports.

Page Break

The page break elements are a special kind of report elements represented by the PageBreak class. Page breaks do not appear in the final layout of the report. When a page break is encountered during layout, it forces (as its name suggests) a new page to be created and the layout to continue on this new page. Page breaks should not be placed in containers other than pages or they may cause unpredictable results.

Properties

The only notable property of a PageBreak object is its position within its containing element specified by the Location property.

Line

The line elements enable you to add straight colored lines to a report. Lines are represented by the Line class.

Properties

The Line objects expose two properties that define the position of the line relative to its containing element - StartPoint and EndPoint. The appearance of the line can be modified through the Color, DashStyle and Width properties.

Ellipse

The Ellipse elements are similar to the line - they enable you to add a static shape, an ellipse to a report.

Properties

To modify the appearance of the ellipse, use the Color, DashStyle and Width properties.


Binding Reports to a Data Source

There are several ways to create data-bound contents in a MindFusion.Reporting report. The majority of the data-binding mechanisms involve the use of one or more DataRange objects. It is also possible to create data-bound Chart objects outside of data ranges.

Note

The sections below assume you are already acquainted with the process of adding data sources to a .NET application. For a step-by-step tutorial on how to do this, refer to Tutorial 1: Getting Started.

Using DataRange objects

In order to perform data-binding you have to create a DataRange object and add it to the report. Then assign the appropriate data source to the DataSource property of the data range and the name of the respective data member (usually table or view) to its DataMember property. You can do this either from the property grid in the report designer or directly via code.

In the following example a data range is bound to the Employees table in an existing data set:

C#

this.dataRange1.DataSource = this.nwindDataSet1;
this.dataRange1.DataMember = "Employees";

Visual Basic

Me.dataRange1.DataSource = Me.nwindDataSet1
Me.dataRange1.DataMember = "Employees"

The above code assumes that dataRange1 identifies the existing DataRange object and nwindDataSet1 - an existing .NET DataSet object.

Once the data range is bound to a data source, you can associate the report items contained in that data range with individual fields in the bound data member by assigning the name of the field to the item's DataField property. In the example, if we assume that we have a label label1 within the data range, we can associate this label with the 'FirstName' field in the Employees table by assigning 'FirstName' to the label's DataField property:

C#

this.label1.DataField = "FirstName";

Visual Basic

Me.label1.DataField = "FirstName"

When running the report, the data range will be multiplied as many times as there are records in the Employees table. The label1 in each occurrence of the data range will contain the 'FirstName' of the employee from the corresponding record.

Note

Currently, it is not possible to create data-bound DataRange objects within headers and footers.

For a step-by-step example on how to create data-bound reports using data ranges, see Tutorial 2: Binding to a Data Source.

Master detail relation

MindFusion.Reporting supports master detail relation through data range composition. You need to create a data range, bound to one of the data members. Then you need to create another data range as a child of the first one, bound to the data member related to the first one. Finally, you have to specify the name of the relation as a value to the MasterDetailRelation property of the inner data range. The following code illustrates this:

C#

this.innerRange.DataSource = this.nwindDataSet1;
this.innerRange.DataMember = "Products";
this.innerRange.MasterDetailRelation = "CategoriesProducts";

this.outerRange.DataSource = this.nwindDataSet1;
this.outerRange.DataMember = "Categories";
this.outerRange.Items.Add(this.innerRange);

Visual Basic

Me.innerRange.DataSource = this.nwindDataSet1
Me.innerRange.DataMember = "Products"
Me.innerRange.MasterDetailRelation = "CategoriesProducts"

Me.outerRange.DataSource = Me.nwindDataSet1
Me.outerRange.DataMember = "Categories"
Me.outerRange.Items.Add(Me.innerRange)

The code makes many assumptions including the correctness of the DataRange objects referenced by innerRange and outerRange and the availability of the 'Categories' and 'Products' data members within the specified data set.

Data range composition can be achieved very easily through the Report Designer by dragging the inner data range to the outer one.

Automation

It is possible to create data-bound DataRange objects automatically within the Report Designer. This automatic creation involves setting up the DataSource and DataMember properties of the data range automatically as well as adding one or more labels representing individual data fields to the new data range. It is also possible to create a header, containing static label texts with the names of the individual columns.

To create a data-bound DataRange object right-click anywhere on the page surface in the report designer and select the 'Create DataRange from Adapter...' command from the context menu. This command displays a dialog box with the table adapters currently available in the report. In order for this to work, you have to have created at least one data adapter in the report from which to create the new data range. The following image shows how this dialog box looks like:

You need to select the fields you want to be present in the data range and whether the data range should have a header or not. The labels representing the selected fields are evenly distributed along the width of the newly created data range.

For a step-by-step example on how to use this automation option, visit Tutorial 1: Getting Started.

Data-binding Chart objects

There is one type of MindFusion.Reporting elements that can be data-bound without the need to place them in a data-bound DataRange object, namely, the classes deriving from Chart - BarChart, LineChart, PieChart and RadarChart. For more information about those elements and how you can use them in reports, check Charts in Reports.

As with data ranges, you can bind Chart objects by using their DataSource and DataMember to specify the data source and member respectively. Then you need to assign the field to bind to through the appropriate property. If you want to data-bind a BarChart object, you should assign the name of the data field to its DataFields property. If you want to bind a PieChart, you should assign to its DataField property. To bind a LineChart, use its XDataFields and YDataFields properties. Finally, to bind a RadarChart, use its DataFields property.

For example, the following code binds the BarChart object referenced by the variable barChart1 to the field "UnitPrice" in a table "Products" of a data source identified by a .NET DataSet referenced by the variable dataSet1:

C#

this.barChart1.DataFields = "UnitPrice";
this.barChart1.DataMember = "Products";
this.barChart1.DataSource = this.dataSet1;

Visual Basic

Me.barChart1.DataFields = "UnitPrice"
Me.barChart1.DataMember = "Products"
Me.barChart1.DataSource = Me.dataSet1

The Chart objects provide other properties that can be data-bound. For example, the XLabelsFields property of the BarChart class can be set to the name of the field to supply the texts of the labels across the x-axis. In order for this binding to work, you also have to set the LabelType property of the XAxisSettings property of the BarChart class to CustomText. Here is how you can do this in code:

C#

this.barChart1.XLabelsFields = "ProductName";
this.barChart1.XAxisSettings.LabelType = MindFusion.Charting.AxisLabelType.CustomText;

Visual Basic

this.barChart1.XLabelsFields = "ProductName"
this.barChart1.XAxisSettings.LabelType = MindFusion.Charting.AxisLabelType.CustomText


Charts in Reports

MindFusion.Reporting provides several report items that can be used to visualize information as a chart. The following table lists the available charting elements along with a short description and their corresponding icon in the Visual Studio Toolbox:

Name | Description
BarChart | Displays 2D and 3D bar charts.
LineChart | Displays line, area, scatter and bubble charts as well as different combinations of them.
PieChart | Displays both 2D and 3D pie and doughnut charts.
RadarChart | Displays 2D and 3D radar and polar charts.

To add a chart element to the report in the Designer, simply drag its icon from the Visual Studio Toolbox and drop onto the page surface. To bind the chart to a data source, you have to use the properties provided by that particular chart type. For example, to bind a BarChart object, you have to use its DataSource, DataMember and DataFields properties. For more information on how to data-bind chart elements, check Binding Reports to a Data Source. For a step-by-step tutorial on how to use charts in reports, visit Tutorial 4: Using Charts in Reports.


Displaying Reports on a Windows Form

In order to display a MindFusion.Reporting report on a form, you need to use an instance of the ReportViewer class. The ReportViewer class is contained in the MindFusion.Reporting.WinForms.dll assembly.

To add an instance of the ReportViewer class to your project, open the Windows form where you want to place the viewer and customize the Visual Studio Toolbox by adding the MindFusion.Reporting.WinForms.dll assembly. Then either drag and drop or double-click on the ReportViewer icon ( [image]) in the Toolbox. This will create a new instance of the ReportViewer class and place it on the current form.

Note

You can display the Visual Studio Toolbox through the View -> Toolbox command from the main menu.

Once the ReportViewer object is created, you can associate it with an existing report through its Report property. You need to ensure that the report is processed by a call to its Run method before the viewer is actually displayed.

The following code illustrates how to create a report and associate it with an existing viewer. The example assumes that reportViewer1 is a variable identifying an existing viewer.

C#

Report report = new Report();
report.Run();
reportViewer1.Report = report;

Visual Basic

Dim report As New Report()
report.Run()
reportViewer1.Report = report

The report associated with the viewer in the above example is empty and therefore only a single empty page will be displayed.

For a step-by-step demonstration on how to use the ReportViewer class, refer to Tutorial 1: Getting Started.


Report Serialization and Output

© 2009 MindFusion


Exporting

Currently MindFusion.Reporting reports support exporting to PDF and HTML formats.

Exporting to PDF files

Add references to the MindFusion.Reporting.Pdf.dll and MindFusion.Pdf.dll assemblies to your project. Create a PdfExporter instance and call its Export method, passing a reference to the report to be exported and a string specifying the output file name. Margins specifies the page margins for all pages in the document. If you need to set the page size and orientation, use the PageSize, and PageOrientation properties.

The following example shows how to export a report to a PDF file. The example assumes that pdfPath is a variable containing the name of the file to export to and report is a variable identifying the Report to export.

C#

MindFusion.Reporting.Export.PdfExporter pdfExporter =
new MindFusion.Reporting.Export.PdfExporter();
pdfExporter.Export(report, pdfPath);

Visual Basic

Dim pdfExporter As New MindFusion.Reporting.Export.PdfExporter()
pdfExporter.Export(report, pdfPath)

Exporting to HTML files

Add reference to the MindFusion.Reporting.Html.dll assembly to your project. Create an HtmlExporter instance and call one of its Export method overloads.

If there are images in the report, set EmbedImages to true to embed the images in the HTML as text. If this property is set to false, the images will be copied to the directory specified by the ImageFolder property. This property can also specify a directory relative to the output directory of the exported HTML file.

Note

Not all browsers can handle embedded images. Make sure the target browser supports them when using the EmbedImages property.

The following example demonstrates the use of the HtmlExporter class. The example assumes that pdfPath is a variable containing the name of the file to export to and report is a variable identifying the Report to export.

C#

MindFusion.Reporting.Export.HtmlExporter htmlExporter =
new MindFusion.Reporting.Export.HtmlExporter();
htmlExporter.Export(report, htmlPath);

Visual Basic

Dim htmlExporter As New MindFusion.Reporting.Export.HtmlExporter()
htmlExporter.Export(report, htmlPath)

The HtmlExporter class provides a second overload of the Export method, which exports the report to a .NET StringBuilder rather than a file. This is useful when you want to embed the report in a custom page, for example, within a scrollable DIV tag.


Printing and Print Previewing

Printing

To print the report, you need an instance of the ReportPrinter class. Assign the report to be printed to the Report property of the ReportPrinter object then call its Print method. Make sure that the attached report has been previously processed by a call to its Run method.

The following example demonstrates the use of the ReportPrinter class. The example assumes that report1 is a variable identifying a valid Report instance and that the Run method of this instance has already been invoked.

C#

ReportPrinter printer = new ReportPrinter();
printer.Report = report1;
printer.Print();

Visual Basic
Dim printer As New ReportPrinter()
printer.Report = report1
printer.Print()

Previewing

To preview the report, create a ReportPrinter object and assign the report to its Report property in a way similar to the one specified above. Instead of calling the Print method however, create an instance of the .NET PrintPreviewDialog class, assign the previously created ReportPrinter object to its Document property and call its Show or ShowDialog method.

The following example demonstrates how to preview an existing report. The example makes the same assumptions as the one above.

C#

ReportPrinter printer = new ReportPrinter();
printer.Report = report1;

PrintePreviewDialog previewDialog = new PrintePreviewDialog();
previewDialog.Document = printer;
previewDialog.ShowDialog();

Visual Basic
Dim printer As New ReportPrinter()
printer.Report = report1

Dim previewDialog As New PrintePreviewDialog()
previewDialog.Document = printer
previewDialog.ShowDialog()

Using the extended Print Preview form

MindFusion.Reporting supplies a custom print preview form. This form contains better looking toolbar icons but its functionality is similar to the standard PrintPreviewDialog. The extended preview form is exposed by the PrintPreviewForm class, found in the MindFusion.Reporting.WinForms.dll. The extended form is used the same way as the standard .NET PrintPreviewDialog - you assign the ReportPrinter object to its Document property and call either Show or ShowDialog methods.

The following image shows the extended preview form displaying a report:

The extended preview form can be customized through the options argument supplied to its overloaded constructor. This argument is of type PreviewOptions and provide several properties that allow you to customize various aspect of the form, such as the tooltips of the toolbar buttons.


MindFusion WinForms Programmer's Guide

Expressions

© 2009 MindFusion


Overview

Expressions in MindFusion.Reporting are conceptually very similar to expressions in various programming languages, such as C# and Visual Basic. An expression is a text fragment that can be evaluated to a single value or object. Expressions can contain a literal value, a function invocation, an operator and its operands, or a field name.

Expressions can use operators that in turn use other expressions as parameters, or function calls whose parameters are in turn other method calls, so expressions can range from simple to very complex.

Literals

The simplest type of expression is a literal. A literal is a constant value written directly in the expression. For example 5 and "Hello World" in the example below are both literals.

Expression

"Hello World"
5

The first line in the example is an expression containing a single literal - the string "Hello World". The second line is another expression containing the number 5. Both of these expressions evaluate to their contained literals.

Literals in MindFusion.Reporting can be numbers, strings and colors. The string literals should be enclosed in quotes. The color literals have the format #RRGGBB, where RR, GG and BB are the hexidecimal representations of the red, green and blue channels of the color.

Table fields

You can include names of table fields in an expression. The available fields to choose from depend on the context in which the expression is evaluated. For example, if you include an expression in a Label's text, the fields that can be referenced within the expression are only those contained in the data table bound to the DataRange object, containing the label. If the label is not contained in a data range, or the data range is not data-bound, no fields will be available for use in the expression.

The following example shows an expression,which concatenates two data fields of type string - FirstName and LastName:

Expression

FirstName + " " + LastName

For more information on how to use expressions in labels check Using Expressions in Label Texts.

Invoking Functions

The following example demonstrates another type of expression, called function invocation. The function in the example is Len with a single string argument.

Expression

Len("Hello World")

A function invocation requires the name of the function, followed by parenthesis and any function parameters. The function invocation evaluates to the return value of the function. In the above example, the invocation will evaluate to the number of characters in the string specified as argument, that is, 11.

Each function expects arguments of specific type. Passing an argument of type that does not match the type the function expects will either result in false evaluation or a run-time error. Additionally, the number of arguments passed to the function should match the number of arguments expected.

There are numerous predefined functions that can be called within an expression. A complete list with all available functions, see Function Reference.

Operators

An operator is a symbol that takes one or more expressions, called operands, as input and returns a value. Operators that take one operand, such as the unary minus operator (-) are called unary operators. Operators that take two operands, such as arithmetic operators (+, -, *, /) are called binary operators. In MindFusion.Reporting there are no tertiary operators.

The following example illustrates an expression that is the sum of two numbers (operands).

Expression

2 + 3

The operand of an operator can be any valid expression that evaluates to a value of the same type as the one expected by the operator. For example, the following expression applies operators to the result of a function invocation, then passes the result as an argument to another function.

Expression

Sqrt(Pow(SideA, 2) + Pow(SideB, 2))

The example evaluates the hypotenuse of a right triangle with sides identified by the fields SideA and SideB respectively.

The following table describes the operators available in MindFusion.Reporting in more details:

Operator | Description
+ | Addition. The addition operator can work on both number and string operands, including mixing between both.
- | Subtraction or Unary minus. Can be applied on numeric operands.
! | Logical negation. Unary operator that can be applied only on boolean operands.
*, / | Multiplication and Division. Can be applied to any numeric operands.
% | Modulo. Can be applied on integer operands and returns the reminder of the division between them.
<, >, <=, >= | Comparison operators. Can be used on numeric operands.
==, <> | Equality operators. Can be used on numeric and string operands.
&&, || | Logical AND and OR operators. Can be applied on boolean operands.
&, ^, | | Bitwise operators (OR, XOR and OR). Can be applied on integer operands.

Operator precedence

The operators encountered in an expression are evaluated according to their precedence. Operators with higher priority are evaluated before operators with lower priority. For example, the following example will evaluate to 14, because the multiplication will be evaluated first.

Expression

2 + 3 * 4

You can change operator precedence by using parenthesis. Changing the order of the operators in the above example, so that the addition is evaluated first, can be done like this:

Expression

(2 + 3) * 4

The following table lists the operators in order of precedence:

Unary | - (unary), !
Arithmetic - Multiplicative | *, /, %
Arithmetic - Additive | +, - (binary)
Relational | <, >, <=, >=
Equality | ==, <>
Logical, in order of precedence | &, ^, |
Conditional, in order of precedence | &&, ||


Function Reference

The following table lists the functions available for use in MindFusion.Reporting expressions:

Name | Description
Abs | Returns the absolute value of a specified number.
Acos | Returns the angle whose cosine is the specified number.
Asc | Returns the ANSI character code corresponding to the first letter in a string.
Asin | Returns the angle whose sine is the specified number.
Atn | Returns the angle whose tangent is the specified number.
CBool | Converts the value, specified as an argument, to a value of type Boolean.
CDate | Converts the value, specified as an argument, to a value of type Date.
CDbl | Converts the value, specified as an argument, to a value of type Double.
Chr | Returns the character associated with the specified ANSI character code.
CInt | Converts the value, specified as an argument, to a value of type Integer.
CLong | Converts the value, specified as an argument, to a value of type Long.
Cos | Returns the cosine of an angle.
CStr | Converts the value, specified as an argument, to a value of type String.
CSng | Returns the cosine of the specified angle.
DateAdd | Returns a date to which a specified time interval has been added.
DatePart | Returns the specified part of a given date.
Day | Returns a whole number between 1 and 31, inclusive, representing the day of the month.
DateDiff | Returns the number of intervals between two dates.
DateSerial | Returns a value of type Date for a specified year, month, and day.
E | Represents the natural logarithmic base, specified by the constant, e.
Exp | Returns e raised to the specified power.
Hour | Returns a whole number between 0 and 23, inclusive, representing the hour of the day.
IIf | Returns one of two parts, depending on the evaluation of an expression.
InStr | Returns the position of the first occurrence of one string within another.
InStrRev | Returns the position of an occurrence of one string within another, from the end of string.
Int | Returns the integer portion of a number.
IsDate | Returns a Boolean value indicating whether an expression can be converted to a date.
IsNull | Returns a Boolean value that indicates whether an expression contains no valid data (Null).
IsNumeric | Returns a Boolean value indicating whether an expression can be evaluated as a number.
LCase | Returns a string that has been converted to lowercase.
Left | Returns a specified number of characters from the left side of a string.
Len | Returns the number of characters in a string.
Log | Returns the logarithm of a specified number.
LTrim | Returns a copy of a string without leading spaces.
Mid | Returns a specified number of characters from a string.
Minute | Returns a whole number between 0 and 59, inclusive, representing the minute of the hour.
Month | Returns a whole number between 1 and 12, inclusive, representing the month of the year.
Now | Returns the current date and time according to the setting of your computer's system date and time.
PageCount | Returns the number of pages.
PageCurrent | Returns the number of the current page.
PI | Represents the ratio of the circumference of a circle to its diameter.
Pow | Returns a specified number raised to the specified power.
RangeItemCount | Returns the count of the items in the current DataRange.
RangeItemCurrent | Returns a number that is the index of the current instance of the DataRange.
Replace | Returns a string in which a specified substring has been replaced with another substring a specified number of times.
Right | Returns a specified number of characters from the right side of a string.
Rnd | Returns a random number.
Round | Returns the number nearest the specified value.
RTrim | Returns a copy of a string without trailing spaces.
Second | Returns a whole number between 0 and 59, inclusive, representing the second of the minute.
Sgn | Returns a value indicating the sign of a number.
Sin | Returns the sine of the specified angle.
Space | Returns a string consisting of the specified number of spaces.
Sqr | Returns the square root of a number.
Sqrt | Returns the square root of a number.
Str | Returns a string representation of a number.
StrComp | Returns a value indicating the result of a string comparison.
String | Returns a repeating character string of the length specified.
StrReverse | Returns a string in which the character order of a specified string is reversed.
Today | Returns a DateTime value containing the current date according to your system.
Tan | Returns the tangent of the specified angle.


Abs

Returns the absolute value of the specified number.

Syntax

double Abs (
double value
)

Parameters

Return Value

The absolute value of the specified number. If the specified value is not a number, 0 is returned.

Remarks

The absolute value of a number is its unsigned magnitude. For example, Abs(-1) and Abs(1) both return 1.

See Also

Sgn Function


Acos

Returns the angle whose cosine is the specified number.

Syntax

double Acos (
double value
)

Parameters

Return Value

The angle whose cosine is the specified number.

See Also

Asin Function
Atn Function


Asc

Returns the ANSI character code corresponding to the first letter in the specified string.

Syntax

string Asc (
string value
)

Parameters

Remarks

If value contains no characters, a run-time error occurs.

See Also

Chr Function


Asin

Returns the angle whose sine is the specified number.

Syntax

double Asin (
double value
)

Parameters

value <= 1.

Remarks

A positive return value represents a counterclockwise angle from the x-axis; a negative return value represents a clockwise angle.

See Also

Acos Function
Atn Function


Atn

Returns the arctangent of the specified number.

Syntax

double Atn (
double value
)

Parameters

Remarks

The Atn function takes the ratio of two sides of a right triangle (number) and returns the corresponding angle in radians. The ratio is the length of the side opposite the angle divided by the length of the side adjacent to the angle. The range of the result is -pi/2 to pi/2 radians.

See Also

Cos Function
Sin Function
Tan Function


CBool

Converts the value, specified as an argument, to a value of boolean type.

Syntax

bool CBool (
object value
)

Parameters

Return Value

true, if the specified value can be evaluated as a boolean and evaluates to true; otherwise, false.

Remarks

If value is a boolean, value is returned. If value is a number, true is returned if the number is non-zero, otherwise - false. If value is a string, true is returned if the string is "true" and false if the string is "false", no case-sensitive.

See Also

CDate Function
CDbl Function
CInt Function
CLong Function
CSng Function
CStr Function


CDate

Converts the value, specified as an argument, to a value of date type.

Syntax

DateTime CDate (
object value
)

Parameters

Return Value

A DateTime value.

Remarks

Use the IsDate function to determine if value can be converted to a date. CDate recognizes date literals and time literals as well as some numbers that fall within the range of acceptable dates.

CDate recognizes date formats according to the locale setting of your system. The correct order of day, month, and year may not be determined if it is provided in a format other than one of the recognized date settings. In addition, a long date format is not recognized if it also contains the day-of-the-week string.

See Also

DateAdd Function
DatePart Function


CDbl

Converts the value, specified as an argument, to a value of type double.

Syntax

double CDbl (
object value
)

Parameters

Return Value

Returns the specified argument converted to double, or 0, if the argument cannot be converted.

Remarks

If value is a number of any kind, it is converted to double. If value is a string, it is parsed as a double and the result is returned. If none of the above applies, 0 is returned.

See Also

CBool Function
CDate Function
CInt Function
CSng Function
CStr Function


Chr

Returns the character associated with the specified ANSI character code.

Syntax

string Chr (
int c
)

Parameters

Remarks

Numbers from 0 to 31 are the same as standard, nonprintable ASCII codes.

See Also

Asc Function


CInt

Converts the value, specified as an argument, to a value of type int.

Syntax

int CInt (
object value
)

Parameters

Return Value

Returns the specified argument converted to int, or 0, if the argument cannot be converted.

Remarks

If value is a number of any kind, it is converted to int. If value is a string, it is parsed as an integer and the result is returned. If none of the above applies, 0 is returned.

See Also

CBool Function
CDate Function
CDbl Function
CSng Function
CStr Function


CLong

Converts the value, specified as an argument, to a value of type long.

Syntax

long CLong (
object value
)

Parameters

Return Value

Returns the specified argument converted to long, or 0, if the argument cannot be converted.

Remarks

If value is a number of any kind, it is converted to long. If value is a string, it is parsed as a long and the result is returned. If none of the above applies, 0 is returned.

See Also

CBool Function
CDate Function
CDbl Function
CInt Function
CStr Function


Cos

Returns the cosine of the specified angle.

Syntax

double Cos (
double value
)

Parameters

Remarks

The Cos function takes an angle and returns the ratio of two sides of a right triangle. The ratio is the length of the side adjacent to the angle divided by the length of the hypotenuse. The result lies in the range -1 to 1, inclusive.

See Also

Sin Function
Tan Function


CSng

Converts the value, specified as an argument, to a value of type float.

Syntax

float CSng (
object value
)

Parameters

Return Value

Returns the specified argument converted to float, or 0, if the argument cannot be converted.

Remarks

If value is a number of any kind, it is converted to float. If value is a string, it is parsed as a float and the result is returned. If none of the above applies, 0 is returned.

See Also

CBool Function
CDate Function
CInt Function
CLong Function
CStr Function


CStr

Converts the value, specified as an argument, to a string value.

Syntax

string CStr (
object value
)

Parameters

Remarks

The data in value determines what is returned according to the following table:

Parameter Type | Return Value
Boolean | A string containing "true" or "false".
Date | A string containing a date in the short-date format of your system.
Null | A zero-length string ("").
Empty | A zero-length string ("").
Other numeric | A string containing the number.

See Also

CBool Function
CDate Function
CInt Function
CLong Function
CSng Function
Str Function


DateAdd

Returns a date to which a specified time interval has been added.

Syntax

DateTime DateAdd (
string type,
double count,
DateTime date
)

Parameters

DateTime value to which the units are added.

Settings

The type parameter can have one of the following values:

Parameter Value | Description
y | The value of count represents the number of years to add or subtract from date.
m | The value of count represents the number of months to add or subtract from date.
d | The value of count represents the number of days to add or subtract from date.
h | The value of count represents the number of hours to add or subtract from date.
n | The value of count represents the number of minutes to add or subtract from date.
s | The value of count represents the number of seconds to add or subtract from date.

Remarks

You can use the DateAdd function to add or subtract a specified time interval from a date.

See Also

DateDiff Function
DatePart Function


DateDiff

Returns the number of intervals between two dates.

Syntax

long DateDiff (
string part,
DateTime a,
DateTime b
)

Parameters

a and b. See Remarks section for values.
DateTime value.
DateTime value.

Remarks

The part parameter can have one of the following values:

Parameter Value | Description
y | The returned value specifies the difference between a and b, expressed in years.
m | The returned value specifies the difference between a and b, expressed in months.
d | The returned value specifies the difference between a and b, expressed in days.
h | The returned value specifies the difference between a and b, expressed in hours.
n | The returned value specifies the difference between a and b, expressed in minutes.
s | The returned value specifies the difference between a and b, expressed in seconds.

You can use the DateDiff function to determine how many specified time intervals exist between two dates. For example, use DateDiff to calculate the number of days between two dates.

If a refers to a later point in time than b, the DateDiff function returns a negative number.

When comparing December 31 to January 1 of the immediately succeeding year, DateDiff for Year ("y") returns 1 even though only a day has elapsed.

See Also

DateAdd Function
DatePart Function


DatePart

Returns the specified component of the specified date.

Syntax

int DatePart (
string part,
DateTime date
)

Parameters

DateTime value you want to evaluate.

Remarks

The part parameter can have the following values:

Parameter Value | Description
y | Returns the year component of date.
m | Returns the month component of date.
d | Returns the day component of date.
h | Returns the hour component of date.
n | Returns the minute component of date.
s | Returns the second component of date.

You can use the DatePart function to obtain a specific component of a date. For example, you can use DatePart to obtain the month of a particular date.

See Also

DateAdd Function
DateDiff Function
Month Function
Day Function
Hour Functinon
Minute Function
Second Function


DateSerial

Returns a value of type DateTime for a specified year, month, and day.

Syntax

DateTime DateSerial (
int year,
int month,
int day
)

Parameters

Remarks

To specify a date, such as December 31, 1991, the range of numbers for each DateSerial parameter should be in the accepted range for the unit; that is, 1-31 for days and 1-12 for months. However, you can also specify relative dates for each parameter using any numeric expression that represents some number of days, months, or years before or after a certain date.

When any parameter exceeds the accepted range for that parameter, it increments to the next larger unit as appropriate. For example, if you specify 35 days, it is evaluated as one month and some number of days, depending on where in the year it is applied. However, if the date specified by the three parameters, either directly or by expression, falls outside the acceptable range of dates, an error occurs.

See Also

Day Function
Month Function
Now Function


Day

Returns an integer number between 1 and 31, inclusive, representing the day of the month component of the specified date.

Syntax

int Day (
DateTime date
)

Parameters

DateTime value.

See Also

Hour Function
Minute Function
Month Function
Now Function
Second Function


E

Represents the natural logarithmic base, specified by the constant, e.

Syntax

double E ()

Return Value

The return value is the constant 2.71828.

See Also

Exp Function
Log Function


Exp

Returns e (the base of natural logarithms) raised to the specified power.

Syntax

double Exp (
double value
)

Parameters

Return Value

The number e raised to the power value.

Remarks

The Exp function complements the action of the Log function and is sometimes referred to as the antilogarithm.

See Also

Sqr Function


Hour

Returns a whole number between 0 and 23, inclusive, representing the hour of the day component of the specified date.

Syntax

double Hour (
DateTime date
)

Parameters

DateTime value.

See Also

Day Function
Minute Function
Month Function
Now Function
Second Function


IIf

Returns one of two objects, depending on the evaluation of an expression.

Syntax

object IIf (
bool condition,
object a,
object b
)

Parameters

condition evaluates to true.
condition evaluates to false.

Return Value

Returns a if condition evaluates to true; otherwise, returns b.

Example

The following example demonstrates how you can use IIf to find the smaller of two numbers:

IIf(5 < 3, 5, 3)

Although the result of the above calculation is obvious, this may not always be the case. Here is the same example applied to fields from a database:

IIf(Field1 < Field2, Field1, Field2)


InStr

Returns the position of the first occurrence of one string within another.

Syntax

int InStr (
string a,
string b
)

Parameters

Return Value

The InStr function returns the following values:

Parameter | Return Value
a is zero-length | -1
a is null | -1
b is zero-length | -1
b is null | -1
b is not found | -1
b is found within a | The position at which match is found.

See Also

InStrRev Function


InStrRev

Returns the position of the first occurrence of one string within another, starting from the end of string.

Syntax

int InStrRev (
string a,
string b
)

Parameters

Return Value

InStrRev returns the following values:

Parameter | Return Value
a is zero-length | -1
a is null | -1
b is zero-length | -1
b is null | -1
b is not found | -1
b is found within a | The position at which match is found.

See Also

InStr Function


Int

Returns the integer portion of a number.

Syntax

int Int (
double value
)

Parameters

Return Value

The largest integer less than or equal to value.

See Also

CInt Function
Round Function


IsDate

Returns a boolean value indicating whether the specified expression can be converted to a date.

Syntax

bool IsDate (
object value
)

Parameters

Return Value

true, if value is a date or can be converted to a valid date; otherwise, false.

Remarks

A value is recognized as a date if it is a date, it is a string that contains a valid representation of a date, or it is a number. In the last case, the number will be interpreted as the number of ticks.

See Also

CDate Function
IsNull Function
IsNumeric Function


IsNull

Returns a boolean value that indicates whether the specified expression contains no valid data (null).

Syntax

bool IsNull (
object value
)

Parameters

Return Value

true, if value is null, that is, it contains no valid data; otherwise, false.

See Also

IsDate Function
IsNumeric Function


IsNumeric

Returns a boolean value indicating whether the specified expression can be evaluated to a number.

Syntax

bool IsNumeric (
object value
)

Parameters

Return Value

true, if the specified expression is recognized as a number; otherwise, false.

See Also

IsDate Function
IsNull Function


LCase

Returns the specified string converted to lowercase.

Syntax

string LCase (
string value
)

Parameters

Remarks

Only uppercase letters are converted to lowercase; all lowercase letters and non-letter characters remain unchanged.

See Also

Str Function


Left

Returns the specified number of characters from the left side of the specified string.

Syntax

string Left (
string a,
int length
)

Parameters

a is null, null is returned.
a, the entire string is returned.

Remarks

To determine the number of characters in a, use the Len function.

See Also

Right Function
Len Function
Mid Function


Len

Returns the number of characters in the specified string.

Syntax

int Len (
string value
)

Parameters

value is null, the function returns zero.

See Also

InStr Function


Log

Returns the natural (base e) logarithm of the specified number.

Syntax

double Log (
double value
)

Parameters

Remarks

The natural logarithm is the logarithm to the base e. The constant e is approximately 2.718282.

See Also

Exp Function


LTrim

Returns a copy of the specified string without leading white spaces.

Syntax

string LTrim (
string value
)

Parameters

value is null, null is returned.

Remarks

Use RTrim to return a string without its trailing white spaces.

See Also

Left Function
Right Function
RTrim Function


Mid

Returns a specified number of characters from a string.

Syntax

string Mid (
string value,
int pos,
int length
)

Parameters

value is null, null is returned.
value of the substing to be returned. If pos is greater than the number of characters in value, the function returns an empty string ("").
length characters in the string, all characters from pos to the end of the string are returned.

Remarks

To determine the number of characters in a string, use the Len function.

See Also

Left Function
Right Function
Len Function


Minute

Returns an integer number between 0 and 59, inclusive, representing the minute of the hour component of the specified date.

Syntax

int Minute (
DateTime date
)

Parameters

DateTime value.

Remarks

Alternatively, you can obtain the minute of the hour by calling DatePart.

See Also

Day Function
Hour Function
Now Function
Second Function


Month

Returns a integer number between 1 and 12, inclusive, representing the month of the year component of the specified date.

Syntax

int Month (
DateTime date
)

Parameters

DateTime value.

Remarks

Alternatively, you can obtain the month of the year by calling DatePart.

See Also

Day Function
Now Function


Now

Returns the current date and time according to the setting of your computer's system date and time.

Syntax

DateTime Now ()

Remarks

To access the system date, use the Today property.

See Also

Day Function
Hour Function
Minute Function
Month Function
Second Function


PageCount

Returns the total number of pages within the current report.

Syntax

int PageCount ()

Remarks

PageCount is only usable in expressions related to report items. For example, PageCount is usable in expressions embedded in the Text of a Label. When evaluated it returns the total number of pages in the final report layout.

See Also

Using Expressions in Label Texts
PageCurrent Function
RangeItemCurrent Function
RangeItemCount Function


PageCurrent

Returns the number of the current page.

Syntax

int PageCurrent ()

Remarks

PageCurrent is only usable in expressions related to report items. For example, PageCurrent is usable in expressions embedded in the Text of a Label. When evaluated it returns the index of the page in the final report layout to which the associated report item belongs to.

See Also

Using Expressions in Label Texts
PageCount Function
RangeItemCount Function
RangeItemCurrent Function


PI

Returns the constant value of p.

Syntax

double PI ()

Remarks

The numeric constant p is the ratio of the circumference of a circle to its diameter.

Return Value

The return value is the constant 3.14159.

See Also

Pow Function


Pow

Returns the specified number raised to the specified power.

Syntax

double Pow (
double a,
double b
)

Parameters

Return Value

The number x raised to the power y.

See Also

Sqr Function


RangeItemCount

Returns the total number of instances of the current DataRange.

Syntax

int RangeItemCount ()

Remarks

RangeItemCount is only usable in expressions related to report items, which are containted in DataRange containers. For example, RangeItemCount is usable in expressions embedded in the Text of a Label, but only when this label is contained in a DataRange. When evaluated it returns the total number of instances of the related DataRange.

See Also

Using Expressions in Label Texts
RangeItemCurrent Function
PageCount Function
PageCurrent Function


RangeItemCurrent

Returns the index of the current instance of the current DataRange.

Syntax

int RangeItemCurrent ()

Remarks

RangeItemCurrent is only usable in expressions related to report items, which are containted in DataRange containers. For example, RangeItemCurrent is usable in expressions embedded in the Text of a Label, but only when this label is contained in a DataRange. When evaluated it returns the total number of instances of the related DataRange.

See Also

Using Expressions in Label Texts
RangeItemCount Function
PageCount Function
PageCurrent Function


Replace

Returns a string in which a specified substring has been replaced with another substring a specified number of times.

Syntax

string Replace (
string value,
string oldValue,
string newValue
)

Parameters

oldValue.

Return Value

A string equivalent to value but with all instances of oldValue replaced with newValue. If any of the specified parameters is null, null is returned.

See Also

Left Function
RTrim Function


Right

Returns the specified number of characters from the right side of the specified string.

Syntax

string Right (
string a,
int length
)

Parameters

a is null, null is returned.
a, the entire string is returned.

Remarks

To determine the number of characters in a, use the Len function.

See Also

Len Function
Left Function
Mid Function


Rnd

Returns a random number.

Syntax

double Rnd (
int type
)

Parameters

Return Value

The return value depends on the type parameter. The following table describes the behavior of the function depending on the value of the value of type:

Parameter Value | Description
Less than zero | The same number every time, using type as the seed.
Greater than zero | The next random number in the sequence.
Equal to zero | The most recently generated number.

Remarks

The Rnd function returns a value less than 1, but greater than or equal to zero. The value of type determines how Rnd generates a random number as outlined in the above table.


Round

Returns the specified value rounded to the specified precision.

Syntax

double Round (
double value,
int digits
)

Parameters

Return Value

Returns the number nearest to value with precision equal to digits. If value is halfway between two numbers, one of which is even and the other odd, then the even number is returned. If the precision of value is less than digits, then value is returned unchanged.

Remarks

The digits parameter specifies the number of significant fractional digits in the return value and ranges from 0 to 28. If digits is zero, then a whole number is returned.

This kind of rounding is sometimes called rounding to nearest, or banker's rounding. If digits is zero, this kind of rounding is sometimes called rounding toward zero.

See Also

Left Function
RTrim Function


RTrim

Returns a copy of the specified string without trailing white spaces.

Syntax

string RTrim (
string value
)

Parameters

value is null, null is returned.

Remarks

Use LTrim to return a string without its leading white spaces.

See Also

Left Function
Right Function
LTrim Function


Second

Returns an integer value between 0 and 59, inclusive, representing the second of the minute component of the specified date.

Syntax

int Second (
DateTime date
)

Parameters

DateTime value.

Remarks

Alternatively, you can obtain the second of the hour by calling DatePart.

See Also

Day Function
Hour Function
Minute Function
Now Property


Sgn

Indicates the sign of a number.

Syntax

double Sgn (
double value
)

Parameters

Return Value

The function has the following possible return values:

Parameter Value | Return Value
Greater than zero | 1
Equal to zero | 0
Less than zero | -1

If value cannot be evaluated to a number or is null, the function returns 0.

Remarks

The sign of the value parameter determines the return value of the Sgn function.

See Also

Abs Function
Str Function


Sin

Returns the sine of the specified angle.

Syntax

double Sin (
double value
)

Parameters

Remarks

This function takes an angle and returns the ratio of two sides of a right triangle. The ratio is the length of the side opposite the angle divided by the length of the hypotenuse. The result lies in the range -1 to 1, inclusive.

See Also

Asin Function
Cos Function
Tan Function


Space

Returns a string consisting of the specified number of spaces.

Syntax

string Space (
int count
)

Parameters

Remarks

The Space function is useful for formatting output and clearing data in fixed-length strings.

See Also

Replace Function


Sqr

Returns square root of the specified number.

Syntax

double Sqr (
double value
)

Parameters

Remarks

If value is negative, the return value is NaN.

See Also

Log Function


Sqrt

Returns the square root of the specified number.

Syntax

double Sqrt (
double value
)

Parameters

Remarks

If value is negative, the return value is NaN.


Str

Returns a string representation of the specified number.

Syntax

string Str (
double value
)

Parameters

<value

Remarks

Str converts the specified number to a string using the current regional settings. If you want to perform a more sophisticated formatting of a number or use a different culture, you have to use the formatting capabilities provided when embedding an expression. For more information, see Using Expressions in Label Texts.

See Also

String Function
Len Function


StrComp

Returns a value indicating the result of a comparison of the specified strings.

Syntax

int StrComp (
string a,
string b
)

Parameters

Return Value

The StrComp function has the following return values.

Parameters | Return Value
String a sorts ahead of string b | -1
String a is equal to string b | 0
String a sorts after string b | 1

Remarks

The strings are compared by alphanumeric sort values beginning with the first character.

See Also

InStr Function


String

Returns a string consisting of the specified character repeating the specified number of times.

Syntax

string String (
int count,
int c
)

Parameters

c in the resulting string.

See Also

Space Function
Str Function


StrReverse

Returns a string in which the character order of the specified string is reversed.

Syntax

string StrReverse (
string value
)

Parameters

Remarks

The value argument is the string whose characters are to be reversed. If value is a zero-length string (""), a zero-length string is returned. If value is null, null is returned.

See Also

StrComp Function


Tan

Returns the tangent of the specified angle.

double Tan (
double value
)

Parameters

<value

Remarks

Tan takes an angle and returns the ratio of two sides of a right triangle. The ratio is the length of the side opposite the angle divided by the length of the side adjacent to the angle.

See Also

Atn Function
Cos Function
Sin Function


Today

Returns a DateTime value containing the current system date.

Syntax

DateTime Today ()

Remarks

The DateTime data type includes time components. When returning the system date, Today sets all of these to 0, so the returned value represents midnight (00:00:00).

To access the day of a date, use the Day property.

See Also

Now Function
DatePart Function
DateSerial Function
DateAdd Function


Using Expressions in Label Texts

You can embed expressions within the text of Label elements by enclosing the expression in square brackets. The following example shows the text of a label with a function call expression embedded within it:

Example

The date and time now is: [Now()]

The expression will be evaluated when the report, containing the label is processed by a call to its Run method. Once the expression is evaluated, its string representation is inserted at its place in the text. In the above example, when the label is displayed, the result will be similar to the following: "The date and time now is: 12/15/2000 1:05:11 PM".

Formatting

By default the result from the evaluation of an embedded expression is formatted to a string through a call to its ToString method. It is also possible to apply custom formatting as illustrated by the following example:

Example

The date and time now is: [Now() @ "d"]

The above example will format the date receieved as a result of the expression evaluation using short date format. The result will be similar to the following: "The date and time now is: 12/15/2000".

Generally, you can apply any string, which would be a valid format string for the ToString method of the expression evaluation result. The following example illustrates how you can apply formatting to an expression, which evaluates to a number. The example assumes that Price is a field of type double in the data source related to the current context.

Example

Cost: [Price @ "$#,##0.00"]

Specifying culture

When applying formatting to an expression, the current culture is used by default. The following example will produce text similar to "16 Jan" when evaluated on machines with regional settings set to en-US or similar:

Example

[Now() @ "dd MMM"]

Evaluating the example is dependent on the current culture however and may yield unexpected results if the current culture is not the one we expect. To force explicitly specify the culture, use the following syntax:

Example

[Now() @ "dd MMM" : "en-US"]

This will force the expression to always be evaluated with the specified culture regardless of the current regional settings.


MindFusion.Scheduling Overview

The MindFusion.Scheduling API is divided in two major parts, implemented in different .NET namespaces. The schedule data is represented by instances of the Schedule class and the helper Appointment, Task, Location, Contact and Resource classes, implemented in the MindFusion.Scheduling namespace. The calendar views are implemented by the Calendar class in the MindFusion.Scheduling.WinForms namespace.


The Schedule

The Schedule class represents the data displayed by MindFusion.Scheduling calendar views. The schedule contains a collection of schedule items defined by the Item abstract class and implemented by the Appointment class. Appointment objects contain references to instances of the miscellaneous Task, Location, Contact and Resource classes, which are also contained in the respective collection members of the Schedule class.

If your application has to process other types of schedule data items, create a class for each item type and inherit it from Item or Appointment. All methods and properties defined in Item are abstract, so if a class inherits from it, that class must implement all members of the Item class. On the other hand, if a class derives from Appointment, it can just add its own distinct properties and override the SaveTo and LoadFrom methods to implement serialization of the new members of the class. Custom schedule item classes must be registered for serialization via the RegisterItemClass method of the Schedule. See Creating Custom Appointment Classes tutorial for more information on how to create custom item classes.


Schedule Items

Events scheduled to occur at an appointed time are represented in MindFusion.Scheduling by the abstract class Item. Item comprises the information that should be defined for all schedule events. For example, the StartTime and EndTime properties specify the time and duration of an event. The Recurrence property lets you create recurrent events that occur repeatedly following some recurrence pattern. There are several descriptive properties that define additional information about an item, such as Priority, HeaderText and DescriptionText. The class also defines methods that support serialization in binary format and XML.

It is possible to associate resources with scheduled events via the Resources, Contacts, Location and Task properties of Item. These properties contain objects from the Resource, Contact, Location and Task classes respectively.

The appearance of items when viewed in the Calendar can be set via the Style property. It lets you define the color, alignment and style of various elements of the item visualization, such as frame lines, fill, header and description texts, icon images, and so on.

The abstract class Item is derived by the concrete class Appointment, which can be readily used in your applications. You could also define your own event class, which derives either from Appointment or Item. In order to integrate your custom class into the calendar API and user interface, you must do the following:

  • Provide parameterless constructor to let users create items of the custom class interactively;
  • Override the SaveTo / LoadFrom methods if you have any additional data fields in your custom class and register the class for serialization using the Schedule.RegisterItemClass method;
  • Override CopyOccurrence to support recurrence of the custom item. Also ensure you call MarkException on the associated recurrence whenever a custom property of the new item changes.

Tutorial 4: Creating Custom Appointment Classes demonstrates in details how to implement custom items.


Recurrence

Schedule items can recur in time, following a specific recurrence pattern. For example an event could be set to occur each Monday, on the third day of each month, and so on. Assign a Recurrence object to item's Recurrence property to specify the time period, pattern, and other properties for the repetition of that item in time.

Once a recurrent item is added to the Schedule of a Calendar instance, the calendar creates multiple occurrences of the item in the time period being visualized. Occasionally you will get references to these occurrences passed as arguments to the calendar events or returned by the calendar methods. Occurrences are instances of the same class as of the item that was set recurrent, however their RecurrenceState property is set to Occurrence. If a user moves a recurrent event's occurrence in the calendar, thus changing its start or end time, or changes the occurrence text, an exception is created. Exceptions are item instances whose RecurrenceState is set to Exception.

Note

Recurrence is not automatically supported in user classes derived from Item or Appointment. To see how to implement custom classes, which support recurrence, see Tutorial 4: Creating Custom Appointment Classes.


Resources

MindFusion.Scheduling lets you associate resources with scheduled events via the Resources, Contacts, Location and Task properties of Item objects. These properties contain objects from the Resource, Contact, Location and Task classes respectively. If you need to assign a resource to schedule items, you must also add the resource to the appropriate collection in the Schedule class, namely Resources, Contacts, Locations or Tasks.

The timetable, week range and resource views let you display distinct rows or columns for selected resources and to group items by their associated resources. To enable that, add the resources of interest to the appropriate resource collection of the Calendar object (that is, Resources, Contacts, Locations and Tasks respectively) and set the Calendar.GroupType property to the appropriate value.

The class Resource is the base class of Contact, Location and Task. It defines an Id property, which must be unique among all resources in the schedule, and a pair of SaveTo and LoadFrom methods, which implement serialization.

You can define custom resources by deriving from Resource or from any of the Resource-derived classes. Custom resources are added to the schedule by adding them to the Calendar.Schedule.Resources collection. In order to enable serialization of custom resources, you have to provide a parameterless constructor and override the SaveTo / LoadFrom methods in the custom resource class. In addition you must register that class by calling Schedule.RegisterResourceClass before any deserialization code takes place.


Serializing the Schedule

The SaveTo and LoadFrom methods of the Schedule class let you save and load complete schedules to/from binary streams and files or XML documents. The SaveToString and LoadFromString methods let you encode or decode a schedule into/from an ASCII string, which could be used to store the whole schedule in a database table field or as a part of a larger file.

The serialization methods of the Schedule work by invoking the SaveTo and LoadFrom methods of the Item and Resource classes or the classes derived from them. If you define your own Item or Resource-derived classes, you must override the SaveTo and LoadFrom methods and register the classes for serialization by calling the RegisterItemClass and RegisterResourceClass methods of the Schedule.


Calendar and Timetable Views

The Calendar class implements several types of views that can be enabled by setting the calendar's CurrentView property. These views provide different outlooks over the schedule data and allow for different user interaction behavior. By changing the views from more general ones to more specialized ones, your application can implement drilling down through the schedule data. At this time MindFusion.Scheduling supports the following views:

  • The Month Range View displays a range of months or years.
  • The Single Month View displays a single month and lets the user scroll to the previous or next month.
  • The Week Range View displays a grid in which the days of a week occupy a single row.
  • The List View displays a list of cells where each cell represents an arbitrary time interval, such as second, minute, hour, and so on.
  • The Timetable View displays the allotment of resources to distinct hours of a day; the columns of this view can be grouped by location, task, contact or resource.
  • The Resource View displays the distribution of resources over a period of time.


Month Range View

The Month Range view displays an arbitrary long sequence of months arranged in rows and columns. Each month represents a grid of day cells, each of which displays the day number and the schedule events set to occur on its respective date. The months in the view can be scrolled back or forth in time by an arbitrary interval using the navigation buttons in the view header.

In order to enable the Month Range view, set the CurrentView property of the Calendar class to MonthRange. Use the MonthRangeSettings and the MonthSettings properties of the Calendar class to adjust the appearance of the view. Use the DayStyles, DayOfWeekStyles and MonthStyles collections of the Calendar class to specify individual styles for particular cells or ranges of cells. The ItemSettings property affects how schedule items will be displayed.


Single Month View

This Single Month view displays a single month and lets the user scroll to the previous or next month or the previous or next year by using the navigation buttons optionally displayed in the view header. The month represents a grid of day cells, which display the day number and the schedule events set to occur on the specific date.

In order to enable the Single Month view, set the CurrentView property of the Calendar class to SingleMonth. Use the MonthSettings property of the Calendar class to set the appearance of the view. The Style property of the associated DaySettings object specifies a common appearance style to be used for all cells in the view. Use the DayStyles, DayOfWeekStyles and MonthStyles collections of the Calendar class to specify individual styles for particular cells or range of cells. The ItemSettings property affects how schedule items will be displayed.


Week Range View

This Week Range view displays a range of weeks. Each week occupies a whole row or column whose cells represent days. The day cells display the day name or number according to the GeneralFormat, FirstDayOfMonthFormat and FirstDayOfYearFormat properties of the associated DaySettings, and the schedule items set to occur on the corresponding date.

In order to enable the Week Range view, set the CurrentView property of the Calendar class to WeekRange. Use the WeekRangeSettings property of the Calendar class to adjust the appearance of the view. Use the DayStyles and DayOfWeekStyles collections of the Calendar class to specify individual styles for specific cells. The ItemSettings property lets you specify how schedule items should be displayed.


List View

Set the CurrentView property of the Calendar class to List to select the list view. This view displays several rows or columns where each row or column represents a single second, minute, hour, day, week, month or year. The day cells display the represented time in a user-specified format to the GeneralFormat, FirstDayOfMonthFormat and FirstDayOfYearFormat properties of the associated CellSettings, and the schedule items set to occur on the corresponding date.

Use the ListViewSettings property of the of the Calendar class to set the appearance of the list view. The Style property of the associated CellSettings specifies a common appearance style to be used for all cells in the view. Use DayStyles and DayOfWeekStyles to specify a higher priority style for specific cells. The ItemSettings property lets you specify how schedule items should be displayed.


Timetable View

Set the CurrentView property of the Calendar class to Timetable to select the timetable view. This view displays the allotment of resources to distinct hours of a day; the columns in this view represent dates, tasks, locations, contacts or resources. The columns can be grouped by location, task, contact or resource. Each row represents an hour or a custom time interval. The cells in the view display information about the schedule items allocated to the task, contact, location or resource for the specific time interval.

Use the TimetableSettings property of the Calendar class to set the appearance of the timetable view. The Style property specifies a common appearance style for all cells in the view, while the WorkTimeCellStyle property defines the style of cells in the work time interval. The ItemSettings property lets you specify how schedule items should be displayed.


Resource View

Set the CurrentView property of the Calendar class to ResourceView to select the resource view. This view displays the distribution of items over a period of time for a particular contacts, locations, tasks or resources. The view displays a single row for each individual contact, location, task or resource and up to three timelines. In order to view associated items in this view, the GroupType property of the Calendar must be set to GroupByContacts, GroupByLocations, GroupByTasks or GroupByResources.

Use the ResourceViewSettings property of the Calendar class to set the appearance of the resource view. The Style property specifies a common appearance style for all cells in the view. The ItemSettings property lets you specify how schedule items should be displayed.


Grouping

Views that can be grouped: Timetable / Week Range / List.
Views that should to be grouped: Resource.
The other views do not support grouping.

In order to enable grouping the following steps should be done:

  • The resources should be created and added to the appropriate collection in the schedule: Calendar.Schedule.Contacts for contacts, Calendar.Schedule.Locations for locations, Calendar.Schedule.Tasks for tasks and Calendar.Schedule.Resources for general and custom resources.
  • The selected resources by which to group should be added to the appropriate collection in the control: Calendar.Contacts for contacts, and so on. The selected resources are a subset of all resources defined in the schedule.
  • The Calendar.GroupType should be set to the appropriate value, for example GroupType.GroupByContacts to group by contacts.

The following code illustrates how to enable grouping by contacts:

C#

// Define two contacts to group by
Contact c1 = new Contact();
c1.FirstName = "John";

Contact c2 = new Contact();
c2.FirstName = "Jack";

// Add the contacts to the schedule
calendar.Schedule.Contacts.Add(c1);
calendar.Schedule.Contacts.Add(c2);

// Select these contacts for grouping by adding them to
// the appropriate Calendar collection
calendar.Contacts.Add(c1);
calendar.Contacts.Add(c2);

// Enable grouping by contacts
calendar.GroupType = GroupType.GroupByContacts;

Visual Basic

' Define two contacts to group by
Dim c1 As New Contact()
c1.FirstName = "John"

Dim c2 As New Contact()
c2.FirstName = "Jack"

' Add the contacts to the schedule
calendar.Schedule.Contacts.Add(c1)
calendar.Schedule.Contacts.Add(c2)

' Select these contacts for grouping by adding them to
' the appropriate Calendar collection
calendar.Contacts.Add(c1)
calendar.Contacts.Add(c2)

' Enable grouping by contacts
calendar.GroupType = GroupType.GroupByContacts

The text displayed in the header of the corresponding resource depends on the type of the resource and is as follows:

  • A string formatted according to Calendar.ContactNameFormat for contacts.
  • The Resource.Name for general and custom resources, and locations.
  • The Task.Subject for tasks.

Grouping and Appearance

  • In resource view a single row is dedicated to each individual resource. The row has a header, displaying the text for that resource and contains all items, associated with that resource for the specified time interval. The row can be additionally subdivided to lanes depending on the ResourceViewSettings.ViewStyle.
  • In timetable view each column (or row in a horizontal view) that represents a day is additionally subdivided to the number of grouped resources. For example if there are 3 resources selected to group by, each day column in the view is subdivided to 3 columns. The sub-columns represent individual resources and contain only the items specific for them. The sub-columns have headers containing the resource text. The header of the day column is displayed above the headers of its underlying resource columns.
  • The week range view displays a separate view for grouped resources. For example if there are two resources, two views are displayed alongside, each of which contains the items associated with its corresponding resource.


Customizing Appearance

The following topics are contained within this topic:

Styles and Themes
Information about the visualization styles and themes available in MindFusion.Scheduling.

Customizing the Appearance of Views
Information on how to modify the appearance of various MindFusion.Scheduling views.

Customizing the Appearance of Items
Information on how to modify the appearance of items in MindFusion.Scheduling.

Tooltips
General information about the tooltips in MindFusion.Scheduling.


Styles and Themes

A Style is a set of appearance attributes, such as colors, brushes and images that can be applied to schedule items or calendar view cells as an integral entity. Styles support cascading propagation of attributes up through the visualization hierarchy. Attributes defined in more specific styles override the attributes defined in more general styles. If a style leaves some attribute values undefined, the ones specified in a more general style or in the current theme are used. For example, the Item.Style property cascades to ItemSettings.Style, which cascades to the corresponding property in the current theme. If a property in Item.Style is defined, it will be used. Otherwise the style system will take the value of this property from ItemSettings.Style. If the property is not present there too, the value will be taken from the current theme.

The following values are used as an "not defined" marker for the style attributes, that is, when a style use them for some property, the value of the same property defined higher in the style hierarchy will be used instead:

  • Enumerations: <EnumName>.Unspecified
  • Numbers: -1 (or -2 for Style.ImageIndex where -1 indicates that there is no image associated with the style)
  • Strings: null (Nothing in Visual Basic)
  • Other reference types: null (Nothing in Visual Basic)

Themes are complete sets of styles and attributes that can be applied to the calendar and its views. The themes contain values for all properties in the MonthSettings, TimetableSettings, ListViewSettings, and so on, defining the appearance of the various calendar views. MindFusion.Scheduling comes with several predefined themes: Standard, Windows2003, Silver, Lila and Vista. Use the Calendar.ApplyTheme method to apply a specific theme.

You can create custom themes by deriving from Theme. For more information on how to do this see Custom Themes.


MindFusion.Scheduling Themes

The following table illustrates how various views would look like when particular appearance Theme is applied to them.

 | Standard | Windows2003 | Lila | Silver | Vista
List View |  |  |  |  |
Week Range |  |  |  |  |
Month Range |  |  |  |  |
Timetable |  |  |  |  |
Resource View |  |  |  |  |


Custom Themes

Since version 4.2 MindFusion.Scheduling enables the creation of user-defined themes. The Theme class is now abstract and can be inherited. In order to create a custom theme, you have to define a new class derived from Theme and implement all abstract properties.

In order to work properly, all properties of the theme must be explicitly initialized. The theme properties cannot have undefined values. For example a property of type State cannot have Unspecified value. This ensues from the fact that the theme is the last layer in the appearance hierarchy and the mechanism to propagate a request further in the hierarchy when a theme property is undefined will fail. This requirement makes custom theme creation really tedious to be done manually. In order to automate this process, you can use the MindFusion Theme Editor, a small application installed with MindFusion.Scheduling. To learn more about the editor, please refer to Theme Editor.

The following sample code illustrates what is the usual structure of a custom theme class:

C#

public class MyTheme : MindFusion.Scheduling.WinForms.Theme
{
public MyTheme()
{
this._controlAppearance = ControlAppearance.System;
this._listViewSettings = base.CreateListViewSettings();
this._itemSettings = base.CreateItemSettings();
// Instantiate the rest of the fields

// Initialize all objects
}

public override ControlAppearance ControlAppearance
{
get { return this._controlAppearance; }
}

public override ListViewSettings ListViewSettings
{
get { return this._listViewSettings; }
}

public override ItemSettings ItemSettings
{
get { return this._itemSettings; }
}

// Override all other theme properties and return
// the corresponding objects

private ControlAppearance _controlAppearance;
private ListViewSettings _listViewSettings;
private ItemSettings _itemSettings;
// Declare all other necessary fields
}

Visual Basic

Public Class MyTheme
Inherits MindFusion.Scheduling.WinForms.Theme

Public Sub New()

Me._controlAppearance = ControlAppearance.System
Me._listViewSettings = MyBase.CreateListViewSettings()
Me._itemSettings = MyBase.CreateItemSettings()
' Instantiate the rest of the fields

' Initialize all objects

End Sub

Public Overrides ReadOnly Property ControlAppearance() As ControlAppearance

Get
Return Me._controlAppearance
End Get

End Property

Public Overrides ReadOnly Property ListViewSettings() As ListViewSettings

Get
Return Me._listViewSettings
End Get

End Property

Public Overrides ReadOnly Property ItemSettings() As ItemSettings

Get
Return Me._itemSettings
End Get

End Property

' Override all other theme properties and return
' the corresponding objects

Private _controlAppearance As ControlAppearance
Private _listViewSettings As ListViewSettings
Private _itemSettings As ItemSettings
' Declare all other necessary fields

End Class

All objects that cannot be instantiated directly, such as MonthSettings and ControlStyle can be created by calling various protected methods of the base Theme class. For example, in order to create a MonthSettings object, you need to invoke Theme.CreateMonthSettings.


Customizing the Appearance of Views

The appearance of individual calendar views depends on the settings corresponding to them. For example the appearance of the list view is controlled by the Calendar.ListViewSettings property, while the appearance of the timetable view is controlled by the Calendar.TimetableSettings property, and so on. The month range view is an exception to this rule since it depends on both Calendar.MonthSettings and Calendar.MonthRangeSettings properties.

The settings object defines styles for various elements of the view. Most settings contain properties, which let you change the size and number of elements (such as columns, rows, headers, and so on) contained in the view. There are usually properties that control the padding and margin of various elements and properties that define the format of the text displayed in the view.

Most view elements can be custom-drawn by setting the appropriate flag in the CustomDraw property of the Calendar and handling the Draw event. Draw event handler receives argument, which specifies which element is being drawn, its coordinates and style. Use the methods of the .NET Graphics object argument to render your custom visualization.


Customizing the Appearance of Items

There are several ways to customize the appearance of items in MindFusion.Scheduling.

You can customize the general appearance of items in a schedule, by setting various properties in Calendar.ItemSettings. This would affect the appearance of all items in the current schedule. To customize the appearance of individual item, adjust its Style, SelectedStyle, PointedStyle and PointedSelectedStyle properties. The particular style that will be used when the item is rendered depends on the state of the item. Style is used when the item is neither selected nor the mouse hovers over it. SelectedStyle is used when the item is selected and the mouse is not over it. PointedStyle is used when the mouse is over a non-selected item and, finally, PointedSelectedStyle is used when the item is selected and the mouse is over it at the same time. PointedStyle and PointedSelectedStyle are only used if ItemSettings.UseExtendedStyles is set to Enabled. Extended styles are disabled by default. The item styles support the cascading paradigm described in Styles and Themes. The most general item styles are defined in the current theme. They cannot be changed by any means except by changing the theme itself. The styles defined in Calendar.ItemSettings are of higher priority and any of their properties that are explicitly specified will be used prior those from the theme. The styles defined in individual items are of highest priority and will always be used first, when present.

The following illustration shows how item appearance is affected by the item settings and style.

The image shows how to customize item appearance in a single month, month range, day range and week range views. The grayed out properties either does not have effect or does not have noticeable effect on the items in these views.

The next image illustrates how settings affect the appearance of items in a timetable view.

You can use custom drawing to perform additional drawing on an item by setting the Calendar.CustomDraw property to CalendarItem, TimetableItem or ResourceViewItem and handling the Draw event.

If you want to completely draw the items in your code, you can use a custom viewer. The item viewers are associated with an item on a class level, so if you want to use your own viewer, you should create a new custom item class. Tutorial 5: Custom Item Viewers and Editors illustrates how to implement custom item viewer. Keep in mind that items using custom viewers are not rendered by the control and their appearance is dependent entirely on the viewer.


Tooltips

Tooltips are displayed for items and for the column headers in the timetable view. Tooltips are only displayed if the Calendar.ShowToolTips property is set to true. The item tooltip is formatted according to Calendar.ItemTooltipFormat property. Item tooltips can be additionally customized by handling the ItemTooltipDisplaying event. The column header tooltip displays the text contents of the column header and can be customized by handling the TooltipDisplaying event.


Optimizing Performance

The following tips might help you improve the performance of your application:

Item Shadows

Disable fading item shadows through the ItemSettings.ShadowStyle property. Fading shadows require substantial amount of processing power in order to be calculated and might incur significant loss of performance if you have even medium amount of items in your application.

Optimization

Since version 4.2.1 you can enable item rendering optimization through the use of the Calendar.EnableOptimization property. When this property is enabled, items' visual appearance is cached in an off-screen buffer. When the item needs to be rendered on-screen, the item's contents are retrieved from the back buffer. The back buffer is updated when the item's contents or bounding rectangle are changed. The contents of the back-buffer can also be updated through the use of the Item.OnVisualsChanged method.

Note

Item optimization yields best results when you perform some kind of heavy custom drawing on the items.

Extended Styles

Disable the use of the extended item styles (ItemSettings.UseExtendedStyles). If these styles are enabled, the items' appearance is invalidated each time the mouse hovers over or leaves an item.

Timetable Collisions

If you don't need collision detection in a Timetable view, you can disable it by setting TimetableSettings.EnableCollisions to Disabled.

Default Item Rendering

If you perform full custom drawing of items, or for some other reason you don't need default item rendering, you can disable it through ItemSettings.EnableDefaultRendering.


Theme Editor

Introduction

The theme editor is a stand-alone application that comes with MindFusion.Scheduling, which enables you to create your own MindFusion.Scheduling themes without writing a single line of code. To learn more about how to create custom themes in general, see Custom Themes. For a practical example on how to use the theme editor, refer to Tutorial 8: Creating Custom Themes.

Note

The Theme Editor is found in the folder where you have installed MindFusion.Scheduling (usually 'c:\Program Files\MindFusion\MindFusion.Scheduling for WinForms'). You can also access it from the Windows' start menu.

Adding themes

When the application is initially started, it contains an empty theme package. You can add new themes to the package and rename and delete existing themes from the Themes menu. Once a new theme is added, its name appears in the list on the left side. In order to edit existing themes, double-click on their names in the list, select them in the list and press F2 or select them and press Theme -> Edit menu item.

Note

The names of the new themes must be unique within the package and also they must be valid identifiers. The reason for this is that the name of each theme is used as a name of its corresponding class.

Editing themes

When the theme is being edited, a new form appears in the right part of the application. You can modify the properties of the theme from the property grid on the left side of this new form the same way you would modify the properties of the Calendar control in the Visual Studio design environment. You can observe the results of your modifications in the preview window available in the right side of the theme form. Below the preview window there is a text box, containing the source code of the current theme. You can copy the source code at any given time and paste it in your application. The other way to use the theme(s) is to compile the package in a separate dll file.

Settings

The following options are available for each package:

  • CodeProviderType - specifies the programming language to use when generating the theme source code. The available options are C# and VB.NET.
  • Namespace - specifies the namespace containing the generated theme class.
  • OutputFile - contains the fully qualified path of the compiled dll file. This property is mandatory for successful compilation.
  • CommonReference - specifies the fully qualified path to the MindFusion.Common.dll. This property is mandatory for successful compilation.
  • PlannerReference - specifies the fully qualified path to the MindFusion.Scheduling.dll. This property is mandatory for successful compilation.

All settings can be accessed via Options -> Settings menu.

Compilation

To compile the theme package in an external dll file, select Options -> Compile menu. The result of the compilation is specified by the OutputFile property in the package settings (see Settings section above). The dll file contains a single class for each theme in the package. The name of each class is the same as the name of its corresponding theme. All classes are placed in a namespace as specified by the Namespace property in the package settings (see Settings section above).

Note

In order to use the themes from the compiled dll file in your application, you have to copy this file in the directory containing the referenced MindFusion.Common.dll and MindFusion.Scheduling.dll files. Then you need to add a reference to the theme dll to your project, instantiate an object of a particular theme class and assign this object to the Calendar.CustomTheme property. You can alternatively add the custom themes to the Toolbox in the Visual Studio environment and assign them to the Calendar control at design-time. For more information on how to do this refer to Tutorial 8: Creating Custom Themes.

Important note

It is required to recompile all theme libraries when the MindFusion.Scheduling.dll or MindFusion.Common.dll files change. This usually happens when you upgrade to a new version of MindFusion.Scheduling. For more information on how to automate the process of rebuilding your theme libraries, refer to the next point.

Compiling from Command Line

The theme editor supports compilation from command line. This feature is considered unofficial and should be used with caution. The command line utility does not produce any error messages nor does it display any information in the command line window. The only way to determine the success of the theme editor when invoked from a command line is the availability of the output library file. However, this utility can be useful if you want to automate the build of your custom theme libraries. Here is the syntax of the theme editor command line utility:

Command line syntax

ThemeEditor.exe t:themeFile [o:outputLibrary] [cr:commonRef] [pr:plannerRef] [t:themeFile [o:outputFile] ...]

The following table describes the input arguments:

Argument | Description
t:themeFile | Specifies the binary theme file, which should be comiled.
o:outputFile | Specifies the name of the output dll file. Note: This argument is optional. If it is not specified, the output file name is obtained from the theme file settings. If there is neither output file name specified as argument nor in the theme file settings, the compilation will fail. However, if this argument is specified, it will override the one available in the theme file settings.
cr:commonRef | Specifies the path to the MindFusion.Common.dll file required to compile a custom theme. Note: This argument is optional. If it is not specified, the reference file name is obtained from the theme file settings. If there is neither reference file name specified as argument nor in the theme file settings, the compilation will fail. However, if this argument is specified, it will override the one available in the theme file settings.
cr:plannerRef | Specifies the path of the MindFusion.Scheduling.dll file required to compile a custom theme. Note: This argument is optional. If it is not specified, the reference file name is obtained from the theme file settings. If there is neither reference file name specified as argument nor in the theme file settings, the compilation will fail. However, if this argument is specified, it will override the one available in the theme file settings.

The following example demonstrates how to use the command line utility in order to compile a custom theme. All the paths given in this example are figurative.

Command line

ThemeEditor.exe "t:d:\projects\myapp\mythemes.theme"

The above sample assumes that all required settings (output and reference files) are available in the theme file being compiled. The following example specifies those settings explicitly. In this case the settings in the theme file are ignored, even if available.

Command line

ThemeEditor.exe "t:d:\projects\myapp\mythemes.theme" "o:d:\projects\myapp\mytheme.dll" "cr:d:\projects\myapp\MindFusion.Common.dll" "pr:d:\projects\myapp\MindFusion.Scheduling.dll"

Persistence

Since themes cannot be restored from the dll file or from their source code, you have to save the theme package in a file in order to be able to make future modifications to the themes contained within it. To save the package, simply select File -> Save from the application menu. To load a previously saved package, select File -> Load from the menu.


Tutorials

© 2009 MindFusion


MindFusion.Charting Tutorials

These tutorials will help you learn how to install MindFusion.Charting, and how to begin using the MindFusion.Charting control to create and customize different types of charts.


Getting Started

Getting Started will show you how to begin using MindFusion.Charting

  • How to include the MindFusion.Charting control in the Visual Studio Toolbox
  • How to add the MindFusion.Charting control to your Visual Studio project
  • How to add MindFusion.Charting references to a Visual Studio project


Customizing the Visual Studio Toolbox

Add the MindFusion.Charting Control to the Visual Studio Toolbox

Note

Delete any control's icons from previous versions by right-clicking on the icon and choosing Delete from the context menu.

  • To add a tab in the Visual Studio Toolbox, right-click within the toolbox, and choose Add tab from context menu. An empty field appears where you can type 'MindFusion.Charting'.

  • Right-click on the new toolbox tab where you want to add the MindFusion.Charting control.
    In Visual Studio 2005 or Visual Studio 2008, select Choose Items. The 'Choose Toolbox Items' dialog box appears.
  • Click on the .NET Framework Components tab.
  • Select the Browse button.
  • Go to the MindFusion.Charting Installation folder, for instance VS2005 (.NET 2.0).

Note

If you select MindFusion.Charting.dll and click the Open button, the following message appears:
"There are no components in 'Folder…\MindFusion.Charting.dll' that can be placed on the toolbox." MindFusion.Charting.dll is the drawing engine of the control and does not contain any components that can be placed at the Visual Studio Toolbox.

  • Select MindFusion.Charting.WebForms.dllMindFusion.Charting.WinForms.dll, and click Open. Click OK.
  • The MindFusion.Charting icons appear in the new tab.


Adding MindFusion.Charting to a Project

Create a Visual Studio .NET Project

  • On the File menu, click New and choose Project.
  • Select the Project type and template you want; for example, for a Visual C# Project, select the Windows Forms ApplicationWindows Forms Application template, and then click OK. The following icons appear in the Toolbox:

If some MindFusion.Charting icons from previous versions are located in the Toolbox, right-click every icon and select Delete.

Note

The icons must have been added previously to the Toolbox. Read Customizing the Visual Studio Toolbox for tips how to add the icons.

  • Drag the icon of the desired chart - an instance of the corresponding control is created: for bar charts, for example, this is a BarChart object.
  • MindFusion.Charting adds automatically references to the MindFusion.Charting.dll and MindFusion.Common.dll that it uses. If you see some fields in the Property browser grey or the Project does not compile, the references to the *.dll-s might be missing. Please, check this and add them manually. For more information, see Adding References to a Project.


Adding References to a Project

MindFusion.Charting requires MindFusion.Charting.dll and MindFusion.Common.dll to operate. You can place the component on a form and set the appearance properties at design time. Your project must also reference MindFusion.Charting.WinForms.dllMindFusion.Charting.WinForms.dll.

MindFusion.Charting adds the appropriate references automatically, when you drag and drop a chart icon on the form at design time. If you get a compilation error or some of the chart properties are grey, a reference to some of the *.dll-s might be missing.

Follow the next quick guide to add the references to your project:

  • On the Visual Studio Project main menu, select Add Reference (or right-click the project in the Solution Explorer or the References node of the project, and choose Add Reference). The Add Reference dialog box appears.
  • Click the Browse button. Select MindFusion.Charting.dll and click OK. The reference is added to the project.
  • Then, select MindFusion.Charting.WinForms.dllMindFusion.Charting.WinForms.dll, and click OK.
  • Select MindFusion.Common.dll, click OK.

The references will be displayed in the Solution Explorer under the References node of the project.


Default Values

© 2009 MindFusion


Default Values of LineChart Properties

LineChart properties are initialized with the following values:

Property name | Default value
ChartBrushes | Empty
Curve | False
Depth3D | 20
DistBtwSeries | 10f
GridType | None
GridWidth | 0
Horizontal | False
LabelBorder | Border.None
LabelBorderBackground | a light blue SolidBrush
LabelBorderMargin | 3f
LabelBorderOutline | a black pen
LabelOffset | 5f
LabelFont | Times New Roman, 12pt
LegendAlignment | Begin
LegendBrush | solid, black
LegendColumns | 0
LegendFont | Times New Roman, 10pt
LegendGridType | None
LegendPosition | Right
LegendWordWrap | False
LineType | Line,Scatter
MultiColoredShapes | False
MaxBubbleRadius | 30
LegendWidth | NaN
MinBubbleRadius | 10
Offset | 0
PlotAreaMargins | 0,0,0,0
LabelAlignment | Far
Labels | Empty
LabelType | Empty
ShapeBrushes | Empty list
ShapePens | Empty
Shapes | Empty list
ShapeSizes | Empty
SortOrder | None
SortSeriesBy | Nothing
Stacked | False
SummaryBrushes | Empty
SummaryPens | Empty
SummaryShapeBrushes | Empty
SummaryShapePens | Empty
SummaryShapes | Empty
SummaryShapeSizes | Empty
XData | 100,20,80.5,53.33
XGridLabelsOrientation | InRow
XLabels | Empty
Y2ScatterLabels | Empty
Y2ShapeBrushes | Empty
Y2ShapePens | Empty
Y2Shapes | Empty
Y2ShapeSizes | Empty
YData | 45,64,18.2,33.03
YGridLabelsOrientation | InRow


Default Values of BarChart Properties

BarChart properties are initialized with the following values:

Property name | Default value
BarSeriesLayout | InRow
BarType | Single3D
BarWidth | 30f
ClusterLabels | Empty
Cylinder | False
CylinderTension | 30
Data | Empty
DistBtwBars | 20
Depth3D | 20
InnerLabelAlignment | Center
InnerLabelBackground | a light blue SolidBrush
InnerLabelBorder | Border.None
InnerLabelFormat | Fixed_point
InnerLabelMargin | 3f
InnerLabelOutline | a black pen, width 1
InnerLabels | Empty
InnerLabelType | Empty
TopLabelBackground | a light blue SolidBrush
TopLabelBorder | Border.None
TopLabelFormat | Fixed_point
TopLabelMargin | 3f
TopLabelOffset | 5f
TopLabelOutline | a black pen, width 1
TopLabelRotAngle | 0
TopLabels | Empty
TopLabelType | Empty


Default Values of PieChart Properties

PieChart properties are initialized with the following values:

Property name | Default value
LabelSuffix | Empty string ("")
LabelPrefix | Empty string ("")
Data | 100,60,90.5,73.33,12.8
DivisionCoef | NaN
DivisionLabel | Empty string ("")
DoughnutThickness | 50
InnerLabelBackground | a light blue SolidBrush
InnerLabelBorder | Border.None
InnerLabelBorderMargin | 5f
InnerLabelFormat | NumberFormat.Fixed_point
InnerLabelOutline | a black pen
InnerLabelPosition | 50
InnerLabels | Empty list
InnerLabelType | Empty
DataFormat | Fixed_point
OuterLabels | Empty list
OuterLabelType | Empty
OutlinePen | black, width 1
Pie3DTension | 30
Pie3DThickness | 20
PieceOutIndex | -1
PieceOutPercent | 30
PieMargins | -1
PieType | Pie3D
PointerLength | 10f
RadiusLength | 100f
StartAngle | 0


Default Values of RadarChart Properties

RadarChart properties are initialized with the following values:

Property name | Default value
InnerAxisLabels | Empty list
InnerAxisLabelType | AutoScale
InnerAxisPen | a black pen
InnerAxisPosition | Bottom
InnerLabelFormat | NumberFormat.Fixed_point
LabelPrefix | Empty
LabelSuffix | Empty
LegendAlignment | Begin
LegendColumns | 0
LegendGridType | None
LegendPosition | Right
LegendWordWrap | False
LegendWidth | 100
MaxValue | 100
MinValue | 0
MultiColored | True
MultiColoredLabels | False
OuterAxisLabelBackground | a light blue SolidBrush
OuterAxisLabelBorder | Border.None
OuterAxisLabelMargin | 5f
OuterAxisLabelOutline | a black pen, width 1
OuterAxisLabels | Empty list
OuterAxisLabelType | CustomText
OuterAxisPen | a black pen
OuterLabelBackground | a light blue SolidBrush
OuterLabelBorder | Border.None
OuterLabelFormat | Fixed_point_0Digits
OuterLabelMargin | 5f
OuterLabelOutline | a black pen, width 1
OuterLabels | Empty list
RadarStyle | Lines
RadarType | Radar2D
RadiusLength | 120
SectionPoints | Empty
SegmentBrushes | Empty list
ShapeBrushes | Empty list
Shapes | Empty list
SortSeriesBy | MaxValue
Span | 20
SpiderWeb | False


Default Values of XAxisSettings Properties

The XAxisSettings properties are initialized with the following values:

Property name | Default value
AxisDelta | NaN
AxisLength | 0
DataFormat | Auto
DateTimeFormat | FullDateTime
DivisionCoef | NaN
DivMarkerLength | 0
LabelAlignment | StringAlignment.Far
LabelAtTheAxis | True
LabelBrush | a black SolidBrush
LabelOffset | 5f
LabelPrefix | an empty string
LabelSpan | 5f
LabelSuffix | an empty string
LabelType | AutoScale
MaxValue | NaN
MinValue | NaN
NumberFormat | Fixed_point
RotationAngle | 0
StartDateTime | DateTime.MinValue
TimeSpan | Zero
TitleLabelOrientation | LabelOrientation.InRow


Default Values of YAxisSettings Properties

The YAxisSettings properties are initialized with the following values:

Property name | Default value
AxisDelta | NaN
TitleLabelFont | Times New Roman, 8pt
LabelType | AxisLabelType.Empty
AxisLength | 0
DateTimeFormat | FullDateTime
DivisionCoef | NaN
DivMarkerLength | 0
NumberFormat | Fixed_point
TitleLabelOrientation | InRow
TitleLabelPosition | Position.Left
LabelAtTheAxis | True
LabelSpan | 5
MaxValue | NaN
MinValue | NaN
DataFormat | Auto


Default Values of Y2AxisSettings Properties

The default values for the Y2AxisSettings properties are the same as those for YAxisSettings. The TitleLabelPosition property has the following default value:

Property name | Default value
TitleLabelPosition | Position.Right


Collection Editors

MindFusion.Charting provides several collection-editor dialog boxes for creating and editing individual members of a collection. The dialog box is displayed when you click the button in the property field for a collection.


Using the BrushCollection Editor

The BrushCollection editor allows design-time editing of collections of brushes. It is used by the following properties:

  • ChartBrushes
  • SummaryBrushes
  • ShapeBrushes
  • Y2ChartBrushes
  • Y2ShapeBrushes
  • SummaryShapeBrushes
  • HorGridBrushes
  • VertGridBrushes
  • SectionBrushes
  • SegmentBrushes

How to use the BrushCollection editor?

  • The BrushCollection editor appears automatically when you want to edit any property of type BrushCollection at design time.

  • To add a brush, click the Add tab. On the left side you can choose the type of brush you want. On the right side you can edit the properties of the brush, according to its type.
  • When you have finished editing the brushes, press the Close button at the top right corner of the editor. The brushes appear as strings in the Property browser, the chart is updated with the new brushes.

See Also

Using the Color Collection Editor


Using the Color Collection Editor

The ColorCollection Editor can be accessed from the BrushCollection Editor if the color is of Gradient type.

How to use the ColorCollection editor?

  • Click to edit any property of type BrushCollection and the BrushCollection editor appears automatically. Add a new brush and set its type to Gradient from the left property pane.

  • Click the three points button for choosing LinearColors. The Color Collection Editor appears:

  • Select a color member in the Members pane by clicking the Up or Down arrow button.
  • Select a color value for the selected color member.
  • Click the Add button to add a new color.
  • Click OK to close the ColorCollection Editor.

See Also

Using the Shape Collection Editor
Using the PenCollection Editor


Using the Double Collection Editor

The DoubleCollection Editor enables design-time editing of double lists. It is used for setting the following properties:

  • LineChart: HorGridPoints, VertGridPoints
  • Scatter chart: ShapeSizes, SummaryShapeSizes, Y2ShapeSizes
  • PieChart: Data
  • RadarChart: SectionPoints, ShapeSizes

The DoubleCollection Editor appears when you are using the Properties window and click the field next to the chosen property on the right.

How to use the Double Collection Editor?

  • Click to edit any of the property of type DoubleCollection in the Property browser.

For example, for the PieChart, click the Data property values field, delete some old value, and add a new value for the data as desired.

Note 1

Use comma as delimiter of the DoubleCollection values.

Note 2

Use a point for the decimal separator.

  • Click in the Form area. The chart is displayed according to the entered Data property values.

See Also

Using the SeriesCollection Editor


Using the LabelsCollection Editor

The LabelsCollection Editor enables design - time editing of collections of lists with labels. The properties that use the LabelsCollection editor are:

  • XLabels
  • YLabels
  • Y2Labels
  • InnerLabels
  • TopLabels
  • Labels

How to use the LabelsCollection editor?

  • Click to edit any of the relevant properties, the LabelsCollection editor appears automatically.
  • Add as many lists as you want with the Add button. Remove unwanted lists by selecting them and presssing Remove.

  • Add the labels for each list as strings, seperate them with commas.
  • When all labels are set click OK. The labels appear as strings in the Property browser. The chart is updated with the new labels.

Note

Labels set with the LabelsCollection require the LabelType property to be set to CustomText for example:

  • for XLabels, XAxisSettings.LabelType must be AxisLabelType.CustomText
  • for YLabels, YAxisSettings.LabelType must be AxisLabelType.CustomText
  • for Y2Labels, Y2AxisSettings.LabelType must be AxisLabelType.CustomText
  • for InnerLabels, InnerLabelType must be set to LabelType.CustomText
  • for TopLabels, TopLabelType must be set to LabelType.CustomText
  • for bubbles Labels, LabelType must be set to LabelType.CustomText

See Also

Using the Double Collection Editor


Using the PenCollection Editor

With the PenCollection Editor you can edit collections of pens at design time. It is used for setting the following properties:

  • ChartPens
  • Y2ChartPens
  • SummaryPens
  • VertGridPens
  • HorGridPens
  • ShapePens
  • SummaryShapePens
  • AltAxesPens
  • Showing the editor

If you click to edit any property of type PenCollection, the PenCollection Editor appears automatically:

  • To add a pen, select the Add tab. On the right, you can see and edit the properties of the pen:

  • When you have finished adding and customizing the pens, click the Close button at the top right corner. The pens appear as strings in the Property editor, the chart is updated with the new pens.

See Also

 Using the String Collection Editor


Using the SeriesCollection Editor

The SeriesCollection Editor enables design-time editing of lists that hold other lists with data. It is used for setting the following properties:

  • XData
  • YData
  • Y2Data
  • RadarChart.Data
  • BarChart.Data

How to use the SeriesCollection editor?

  • Click to edit any of the data properties in the Property browser and the SeriesCollection editor appears automatically:

  • Use the Add button to add as many lists with data as necessary. Use Remove to remove any unwanted data lists.
  • Add the numbers for the lists, separate them by commas. Do not use comma as a delimiter inside any number - it will be considered as separate values.
  • When ready with the data, click the Close tab at the top right corner of the SeriesCollection editor. The data appears as a string in the Property browser. The chart is updated with the new data.

See Also

Using the LabelsCollection Editor


Using the Shape Collection Editor

The Shape Collection Editor allows design - time editing for collections of shapes. It is used for defining the LineChat.Shapes and RadarChart.Shapes property.

The Shape Collection Editor appears when you are using the Properties browser.

How to use the Shape Collection Editor?

  • To edit the Shapes property in the Property browser, click the three points button.

The Shape Collection Editor appears.

  • To add a shape, select the Add button. The Circle shape appears by default. Change the Circle shape by clicking on the right of the Circle field and choosing another shape.

See Also

Using the SeriesCollection Editor
Using the BrushCollection Editor


Using the String Collection Editor

The String Collection Editor enables design-time editing of string lists. It is used for setting the following properties:

  • BarChart: TopLabels, InnerLabels, ClusterLabels, LegendLabels;
  • LineChart: LegendLabels, XGridLabels, XLabels, YGridLabels, YLabels;
  • PieChart: InnerLabels, OuterLabels, LegendLabels;
  • AxesChart: XGridLabels, Y2GridLabels, YGridLabels, YLabels, Y2Labels;
  • RadarChart: InnerAxisLabels, OuterAxisLabels, OuterLabels;

The String Collection Editor appears when you are using the Properties window and click the field next to the chosen property on the right.

How to use the String Collection Editor?

  • Click to edit any of the relevant properties in the Property browser

For the PieChart, click the InnerLabels property values field, and delete some old value, and add a new value for the inner label as desired.

Note

Use comma as delimiter of the string values.

  • Click in the Form area. The labels are displayed on the chart.

See Also

Using the Shape Collection Editor


Creating charts

© 2009 MindFusion


Creating Area Charts

Create a 3D area chart

  • Set the LineType to Area3D.
  • Set GridType to HorScale.
  • Set XData and YData, XAxisSettings and YAxisSettings as described in Creating Line Charts.
  • Click in the Form. The area chart is displayed as shown below:


Creating Bar Charts

  • Create a new BarChart by dragging the BarChart control at the top.
  • Set the BarType to Clustered3D and BarSeriesLayout to BarSeriesLayout.InColumn. That will draw cluster bars in columns.

Adding Data

  • Add the Data for the chart using the SeriesCollection editor. The sample uses 4 data arrays with three members each. The data is: 18,28,39;10,15,22;6,9,14;2,5,9
  • Sort the data by setting the SortOrder to Ascending.

Setting labels

  • Set the TopLabelType to LabelType.Data to show the number of each bar as top label.
  • Set the LabelType property of the XAxisSettings object to AxisLabelType.Cu [image] stomText to show custom labels at the X-axis.
  • Add the X-labels as values for the ClusterLabels property. Write them separated by comma: "1st quarter, 2nd quarter, 3rd quarter, 4th quarter".
  • Set the LabelType property of the YAxisSettings object to AxisLabelType.AutoScale.
  • Set the format of the scale divisions for the Y-axis to Fixed_point_0Digits using the NumberFormat property of the YAxisSettings object.
  • Set YAxisSettings.DrawZero to true to show the zero label.
  • Set the font for the labels on both axes with LabelFont. The zero label uses the same format as the labels Fixed_point_0Digits.
  • Add the title for the Y-axis: Write "in thousands" as TitleLabel in the YAxisSettings object.
  • Set the orientation of the axis label for the Y-axis with YAxisSettings.TitleLabelOrientation. The sample uses TopToBottom.
  • Set the font for the axis label at the Y-axis to Verdana, 12pt.
  • Add labels for the legend - write "avg. 28.33,avg. 15.66,avg. 9.66,avg. 5.66 " in the LegendLabels field in the property browser.
  • Set the LegendWidth to 500 so that all labels could fit in.
  • Place the legend at the "Top" with LegendPosition. Align it with LegendAlignment to Center.
  • Choose the font for the legend labels - "Verdana, 9pt."

Adding title

  • Add the title of the chart with TitleText. Write in the property field "Sales for Year 2006".
  • Choose font for the title with TitleFont - "Verdana, 14pt."

Setting brushes

  • Add four brushes to the ChartBrushes property.
  • Choose background for the plot area with ChartBackgroundBrush. Use the same brush for the background of the legend.
  • Set the brush for the 3D axes with AxisShadowBrush.
  • Set the background of the whole chart with BackgroundBrush.

See Also

Creating Line Charts
Creating Radar Charts
Creating Scatter Charts


Creating Bubble Charts

  • Drag a new instance of the Line control and set its LineType to Bubble3D.
  • Choose a background for the chart with the BackgroundBrush property. In our sample we use a Gradient Brush, choose Light Yellow Start color and Pink End color.
  • Specify the depth of the 3D axis with Depth3D, for example 20.
  • Set a grid for the chart - set the GridType to Crossed, choose GridWidth, for example 10 and specify the GridPen, for example choose Dot Style. Set GridBrush to Beige.
  • Set ChartBackgroundBrush to Light blue.

Adding data

  • Add XData values by using the SeriesCollection Editor
    Click the XData property in the Properties window.
    The SeriesCollection Editor appears. Add the following XData values in one series: 15,26,35,50,65. In this way, both graphics will have the same X values.
  • Add YData values for two series
    Click the YData property in the Properties window.
    The SeriesCollection Editor appears. Add the following YData values in two series: Serie0: 25, 44, 18, 33, 52; Serie1: 15,33,20,40,60

Note

For a bubble chart to be drawn, the count of members in both XData and YData lists must be equal. If the count of lists in XData is not equal to the count of lists in YData, the control completes the list with less values automatically.

AxisSettings

  • Set the following XAxisSettings properties
    • Set LabelType of the X-axis to CustomText.
    • Enter 'Sector' in the TitleLabel field for the X axis.
    • Enter 'Education,Energy,Health,Justice,Public' in the XLabels property field by using the LabelsCollection Editor.
    • Set TitleLabelFont to Verdana, bold, size 14.
    • Set TitleLabelOrientation to InRow, TitleLabelPosition to Bottom. AxisLength to 500, TitleLabelOffset to 15.

  • Set the YAxisSettings properties
      • Enter 'Budget (mio USD)' in the TitleLabel field of the Y axis.
      • Set LabelType to AutoScale.
      • Set TitleLabelFont to Verdana, bold, size 14.
      • Set TitleLabelOrientation to BottomToTop.
      • Set DivMarkerAlignment to Far, DivMarkerLength to 10.
      • Set LabelOffset to 5, LabelSpan to 5.
      • Set DataFormat to Number.
      • Set NumberFormat to Fixed_point_0Digits.

Brushes

Specify the brushes for the bubble series with ChartBrushes and the BrushCollection Editor, for example Gradient brushes for two series: Brush0: from white to light blue color, Brush1: from white to olive color.

Title

Fill in "Development 2008/2009" as value for the TitleText property. Set TitleFont to Verdana, bold, size 16.

Bubble radius

Set MaxBubbleRadius to 40, MinBubbleRadius = 20.

Legend

Enter the LegendLabels, for example: '2008, 2009', set the LegendPosition to Right, LegendFont to Verdana, size 12pt.

Click in the Form. The bubble chart is displayed as shown below:


Creating Line Charts

A. Create a new Visual Studio Project

  • Open Visual Studio.
  • On the File menu, select New, and then choose Project.
  • Select the desired project type from the list of installed templates.
  • Type the name of your project, and click OK.

B. Create a line chart object

  • Click on the LineChart icon in the Toolbox, and drag it to the form's working area. This creates a new line chart object.
  • Click on the selection handles and expand the area of the control as desired.

C. Set the properties of the LineChart object

  • Select the newly created LineChart object by clicking in the area within the form.
  • Set the LineType to Line3D.

Note

To display properly the 3D line chart, set the Depth3D property to a value greater than zero, for example to 30.

  • Enter 'Products' in the TitleText property field, choose bold Verdana TitleFont, size 16pt.
  • Set the ChartPens property by using the PenCollection Editor.
    Choose blue Pen0 and green Pen1, Width = 3.

  • Set the ChartBrushes property to light blue and light green colors by using the PenCollection Editor.
  • Set GridType to HorScale, choose Light Gray GridBrush and GridPen of Dot Style.
  • Set AltGridBrush to Gradient Style, from white start color to pink end color.

Note

To draw the chart by using of curves, set the Curve property to true.

D. Set data for the line chart

Add XData and YData values for two series.

  • Click the XData property in the Properties window.
  • The SeriesCollection Editor appears. Add the XData values in one series. In this way, both line graphics will have the same X values.

  • Add YData values in two series

Note

For a line chart to be drawn, the count of members in both XData and YData lists must be equal. If the count of lists in XData is not equal to the count of lists in YData, the control cycles through them. If the count of numbers in lists at matching positions in XData and YData are not equal, the control completes the list with less values automatically.

E. Set the XAxisSettings and YAxisSettings properties

  • Set LabelType of the XAxis to CustomText.
  • Enter 'Months' in the TitleLabel field for the X axis, and enter 'Sales' in the TitleLabel field of the Y axis.
  • Set LabelType of the YAxis to AutoScale.
  • Set TitleLabelFont to Verdana, bold, and 14pt size.
  • Set DataFormat to Fixed_point_0Digits.

F. Set the labels of the line chart

  • Select the XLabels property. The LabelsCollection Editor appears.
  • Enter the XLabels values: 'Jan,Feb,Mar,Apr,May,Jun,Jul,Aug,Sep,Oct'

  • Set LabelFont to Verdana, size 14.
  • Set YAxisSettings.DrawZero to true to show the zero label.

Click in the Form area. The line chart is displayed according to the specified properties values as shown below.

Note

To draw the chart as Area3D, set LineType to Area3D.


Creating Pie Charts

  • Create a new PieChart by dragging the PieChart control at the top.
  • Set the PieType property to Doughnut3D.
  • Set StartAngle to 270.
  • Fill in the following Data values for the PieChart: 100, 60, 20, 73, 12, 50, 6
  • Choose 7 ChartBrushes of different colors by using the BrushCollection Editor.
  • To specify the index of a detached pie piece, set the PieceOutIndex property, for example to 4. The property specifies the 0-based index of the detached piece. In this case, the fifth pie piece will be detached.
  • Set PieceOutPercent to 40 to determine the distance at which the detached pie piece is drawn from the center of the doughnut.
  • Set OuterLabelType to Percents.
  • Set LabelFont to Verdana, size 12 pt.
  • Set NumberFormat to Fixed_point_0Digits.
  • Enter InnerLabels: A,B,C,D,E,F,G; set the InnerLabelPosition to 80, and InnerLabelType to CustomText.

Click in the Form area. The doughnut chart is displayed.


Creating Radar Charts

A. Create a radar chart with lines

  • Drag the radar chart icon to create a new chart
  • Set the RadarType to Radar3D
  • Set the RadarStyle to Lines
  • Set a brush for the 3D background with Background3D property.

Adding data

  • Add data for two series with the SeriesCollection Editor:
    Series0: 39.88,72.47,58.48,81.65,62.17,69.07
    Series1: 25.13,87.31,38.09,96.22,19.87,42.11
  • Set the scale divisions for the inner axis. Set MinValue to 0, MaxValue to 120 and Span to 30.

Setting labels of the inner axis

  • Set the label type of the inner axis with InnerAxisLabelType to
    AxisLabelType.AutoScale. This will draw the scale divisions as axis labels.
  • Choose format of the inner labels with InnerLabelFormat. In the sample, it is set to NumberFormat.Fixed_point_0Digits.
  • Choose position for the inner axis with InnerAxisPosition. In the sample, Position.Top is chosen.

Brushes and pens

  • Set two brushes for filling the radar polygons with the BrushCollection editor and the ChartBrushes property.
  • Add two pens for drawing the radar polygons with the PenCollection editor and ChartPens.

Tip

Pens that are a bit darker than the respective brush make nice outlining.

  • Add a grey brush for drawing the biggest radar circle through OuterAxisPen.
  • Set the pen for the inner axis with InnerAxisPen.
  • Add the same pen to the AltAxesPens property using the PenCollection editor.
  • Choose a brush for the background of the control with BackgroundBrush.

Setting labels of radar segments

  • Add the labels for the radar segments with OuterLabels. Write there "2001, 2002, 2003, 2004, 2005, 2006".
  • Set LabelFont to Arial, 9.75 pt.

Title and subtitle

  • Write "Sales" as TitleText.
  • Set TitleFont to Arial, 14 pt., style=bold.
  • Write "for six consecutive years" as SubTitleText.
  • Set the SubTitleFont to "Arial, 12 pt., style=bold"

B. Create a spider web radar chart with lines, point shapes and segments

To create a spider web radar chart with lines, point shapes and segments replace steps 2, 3, 4 and 10 with the following steps:

  • Set RadarType to Radar2D.
  • Set the RadarStyle to Lines with Points, for example write "Lines,Points". Set SpiderWeb to true.
  • Add the brushes for the segments with the SegmentBrushes property using the BrushCollection Editor.
  • Copy the ChartBrushes to ShapeBrushes. Clear ChartBrushes so that the radar polygons will not be filled. Add the same pens in ChartPens and ShapePens.

Tip

You can make the shape pens a bit thinner.

  • Write the sizes of the shapes in ShapeSizes: "15,15"
  • By default, shapes are drawn as rhombuses. You can set new shapes using the Shapes property. Copy the following code after InitializeComponent, in the constructor:

VB.NET

Me.RadarChart1.Shapes.Clear()
Me.RadarChart1.Shapes.Add(MindFusion.Charting.Shape.Circle)
Me.RadarChart1.Shapes.Add(MindFusion.Charting.Shape.Square)
Me.RadarChart1.UpdateChart()

C#

this.radarChart1.Shapes.Clear();
this.radarChart1.Shapes.Add(MindFusion.Charting.Shape.Circle);
this.radarChart1.Shapes.Add(MindFusion.Charting.Shape.Square);
this.radarChart1.UpdateChart();

C. Create a radar chart with arcs and sections

To create a radar chart with sections and arcs, replace steps 2, 3 and 4 from point A with the following steps:

  • Set the RadarType to Radar2D
  • Set the RadarStyle to Arcs.
  • Add the brushes for the sections with the BrushCollection Editor to the SectionBrushes property. In the sample two brushes are used.
  • Add the positions, at which the arcs are drawn to SectionPoints - "0, 25, 50, 75, 100". This creates 4 equally placed along the radius arcs.

Note

The quotation marks ("") around values of data and label properties are not needed when writing them in the Property designer.


Creating Scatter Charts

  • Drag a new instance of the Line chart control and set its LineType property to Scatter.

C#

this.lineChart1.LineType = MindFusion.Charting.LineTypes.Scatter;

VB.NET

Me.LineChart1.LineType = MindFusion.Charting.LineTypes.Scatter

  • Set the chart background with the BackgroundBrush property.
  • Set the background of the plot area with ChartBackgroundBrush.
  • Use AxisPen to specify the pen for the axes - in this sample it is a grey one, width 2.
  • Create a grid: set the GridType to HorScale , and then choose a GridBrush and AltGridBrush. Set the GridPen to a dashed one.

C#

this.lineChart1.GridType = MindFusion.Charting.GridType.HorScale;

VB.NET

Me.LineChart1.GridType = MindFusion.Charting.GridType.HorScale

  • Set the title label - enter 'Scatter Chart' in the TitleText property field. Use TitleFont and TitleBrush to set the font and color of the title.

C#

this.lineChart1.TitleText = "Scatter Chart";

VB.NET

Me.LineChart1.TitleText = "Scatter chart"

  • Specify Verdana, 10 pt. font for the labels with LabelFont.
  • Specify the data for the chart - enter 1,3,5,7,9 in the XData property using the SeriesCollection editor.

C#

this.lineChart1.XData = new MindFusion.Charting.SeriesCollection("1,3,5,7,9");

VB.NET

Me.LineChart1.XData = New MindFusion.Charting.SeriesCollection("1,3,5,7,9")

  • Enter two series of data in the YData property: Serie0: 30,44,18,33 and Serie1: 10,20,35,22 by using the SeriesCollection Editor.

C#

this.lineChart1.YData = new MindFusion.Charting.SeriesCollection("30,44,18,33;10,20,35,22");

VB.NET

Me.LineChart1.YData = New MindFusion.Charting.SeriesCollection("30,44,18,33;10,20,35,22")

  • Set the following properties of the X-axis with the XAxisSettings object:

    • Set the label type to ChartData with AxisLabelType.
    • Specify the length of the axis - enter 400 in the AxisLength field.
    • Set the MinValue to 0, the MaxValue to 8 and the AxisDelta to 1. This divides the axis in 8 intervals and the scatter shapes fill nicely into the plot area.
    • Set the NumberFormat of the labels to Fixed_point_0Digits .

  • Set the appearance options for the Y-axis with the YAxisSettings property:

    • Set AxisLabelType to AutoScale
    • Set DivMarkerAlignment to Far to draw the scale divisions out of the plot area towards the labels
    • Set the length of the scale divisions to 5, that is DivMarkerLength = 5

  • Set the YAxisSettings.DrawZero property to true to show the zero label at the Y-axis.
  • Specify the type of Shape-s that you want for the scatter chart. Add the chosen values to the Shapes property, clear any already added Shape objects beforehand. Update the chart with the newly set options. Write the following lines of code in the constructor of the Form, which contains the chart control, after InitializeComponent:

C#

this.lineChart1.Shapes.Clear();
this.lineChart1.Shapes.Add(MindFusion.Charting.Shape.Rhombus);
this.lineChart1.Shapes.Add(MindFusion.Charting.Shape.Circle);
this.lineChart1.UpdateChart();

VB.NET

Me.LineChart1.Shapes.Clear()
Me.LineChart1.Shapes.Add(MindFusion.Charting.Shape.Rhombus)
Me.LineChart1.Shapes.Add(MindFusion.Charting.Shape.Circle)
Me.LineChart1.UpdateChart()

    • Choose the brushes for the scatter shapes. Use ShapeBrushes and add two brushes for both YData series by using the BrushCollection Editor:

  • Use the ShapePens property to specify the pens that draw the outlining of the scatter Shapes. Add and edit the pens with the PenCollection Editor.
  • Set the size of the scatter shapes using ShapeSizes. Enter the desired values, for example 20 and 30, separated by commas in the Property Designer of Visual Studio, for example write "20,30".
  • The Scatter chart will be updated with the described settings:


Chart parts

© 2009 MindFusion


Bar Charts

Bar charts are instances of the BarChart class.

Type of the Bars

The type of the bar chart depends on the BarType property. Multiple-series charts can be drawn in groups or clusters as set by BarSeriesLayout. The bars can also be drawn as Cylinders.

Bars

The width of bars is set with BarWidth. Space between bars in a single series or in a cluster / group is set with DistBtwBars. The offset among clusters / groups - in rows or columns is set with DistBtwSeries. If the length of the axis at which the bars are drawn is set, it is considered first and all other width / space settings might not be taken into account.

Data

Data is set with Data and can be numbers or in any other format that can be parsed to numbers. Data is a single-dimensional list that can hold either numbers or values of any other type that can be converted to numbers. If you add values to the Y2Data property, a second Y-axis will be drawn.

Data lists can be sorted using the SortSeriesBy property. Values inside the lists are sorted with SortOrder.

Labels

Bar charts can show labels at all axes, as well at the top and inside of bars. The type of the labels drawn is set with the XAxisSettings.LabelType, YAxisSettings.LabelType, Y2AxisSettings.LabelType, TopLabelType and InnerLabelType properties. If any label type is CustomText, use the respective property to set the labels - XLabels, YLabels, Y2Labels, TopLabels or InnerLabels. You can edit them at design time with the LabelsCollection Editor.

See Also

Pie Charts
Line Charts
Creating Bar Charts
Creating Line Charts


Line Charts

The LineChart class is used for creating of line, area, scatter and bubble charts as well different combinations of them.

Use the LineType property to specify the type of the chart. Choose the chart type at design time in the Visual Studio Properties window:

If you want to combine several LineType values, write them manually and seperate them with commas.

Plot area

The plot area is the inner rectangular area used to plot the chart graphics. It is bounded by the axes.

Set the apperance of the chart's plot area with the ChartBackgroundBrush property. In this example, we have set the ChartBackgroundBrush to RosyBrown color.

There are several ways you can position the chart graphics in the chart control - see the ResizeType property.There are several ways you can position the chart graphics in the chart control - see the ResizeType property.

The PlotAreaMargins property allows changing the margins of the plot area relatively to the chart elements outside it.

Title

The title text is specified by the TitleText property in all chart types. The chart title is drawn with font and brush set by the TitleFont and TitleBrush properties.

Subtitle

The subtitle text is specified by the SubTitleText property in all chart types. The chart title is drawn with font and brush set by the SubTitleFont and SubTitleBrush properties.

Legend

The Legend is specified by the following properties: LegendAlignment, LegendBackgroundBrush, LegendBrush, LegendColumns, LegendFont, LegendGridType, LegendLabels, LegendOffset, LegendPen, LegendPosition, LegendWordWrap, LegendWidth. The Legend section in this chapter illustrates more precisely the legend's parts.

Chart data

Line chatrs support unlimited number of data series. The data is set with the XData, YData and Y2Data properties. The numbers can be edited at design time with the SeriesCollection Editor. The SortSeriesBy property specifies how charts with more than one data series are arranged. SortOrder specifies different options for sorting numbers in data series.

Bubble size

For bubble charts the size of the bubbles is calculated based on the MaxBubbleRadius and MinBubbleRadius.

Summaries

Summaries are displayed when the SummaryValues property is not an empty list. They are drawn as new series with the same LineType as the data series.

Bubble chart

See Also

Creating Line Charts


Pie Charts

Use the PieType property to specify the type of the pie chart:

Pie / doughnut charts consist of pie pieces. They can have one or all of their pieces detached (PieceOutIndex).

Size and Shape

The size of the pie chart depends on the length of its radius, which is set with RadiusLength. If the chart is 3D its thickness and tension (flatness) can be regulated with Pie3DThickness and Pie3DTension.

Title and Subtitle

Title and subtitle are added with the TitleText and SubTitleText properties. They are drawn in TitleFont and SubTitleFont and with TitleBrush and SubTitleBrush.

Data

The data for the pie is specified with the Data property, which is a single-dimensional array that can hold numbers, DateTime values or any other data that can be converted to numbers or DateTime values.

Labels

Each pie can have text outside and inside its segments (pieces). The type of text drawn is specified the OuterLabelType and InnerLabelType. If the *LabelType is CustomText, the labels are set through OuterLabels and InnerLabels.

The labels can be drawn with a prefix and a suffix - see the LabelSuffix and LabelPrefix properties.

Outer labels can be drawn with pointers from the middle of the piece to the label. The length of the pointer is specified with PointerLength.


Radar Charts (Polar Charts)

A. Radar Charts

Axes

  • Inner axes

The count of elements in each Data series determines the count of the chart axes. They are drawn as equally distributed radiuses around the chart circle. In MindFusion.Charting they are called inner axes.

The position of the primary inner axis is determined with the InnerAxisPosition. The labels of this axis can also be custom texts, which are specified with InnerAxisLabels. If the labels are numbers, they are formatted with InnerLabelFormat. Use InnerAxisLabelType to specify the type of the inner labels.

  • Outer axis

As a second axis, radar / polar charts have the circumference of the radar circle, which is named by MindFusion.Charting's outer axis.

In radar charts, this axis is used only for showing labels. Radar charts can have more than one outer axis. The pens of the alternative outer axes are set with AltAxesPens.

In polar charts, the outer axes holds information about the angles of the data points. They are specified with the Angles property.

Inner and outer axes are drawn at a RadarChart as shown below:

The data for the radar chart is set with Data and, for polar charts, Angles.

Data series

Data series are entered in the Data property. ChartBrushes and ChartPens are used to paint the series circles (polygons). The number of ChartBrushes and ChartPens corresponds to the number of data series.

Titles and Labels

The TitleText contains the chart title. TitleBrush and TitleFont are used to display the title. The SubTitleText holds the text for a subtitle.

OuterLabels specify the labels, drawn at the outer segments of radar charts.

LabelBrush and LabelFont specify the brush and font for drawing of all the chart labels.

At the following RadarChart drawn as SpiderWeb chart, data series, title and labels are presented:

Chart parts depending on RadarStyle

  • Lines

Both charts shown in the pictures are drawn with Lines RadarStyle.

  • Arcs

Arcs are used to present data series. OuterLabels desribe the criteria of the RadarChart. SegmentBrushes show the background segments of the chart if RadarType is Radar2D.

  • Points

Points are defined through the following properties: Shapes, ShapeBrushes, ShapePens, ShapeSizes.

B. Polar charts

In Polar charts, Data and Angles are used to display the chart.


Axes of the Chart

How to specify the appearance of chart's axes

This topic is for all charts that use the Cartesian coordinate system - bar, line, area, scatter, bubble and so on.

Axes

The axes are by default two - the X and Y. Y2 is drawn only if Y2Data is not empty. All axes can have both positive and negative parts.

The axis always contains the 0 number though it might not be drawn if DrawZero is set to false. The zero label uses the same appearance settings as the other chart labels. In axes that display DateTime values, the zero label is the StartDateTime property, if set, or the automatically calculated start value.

Appearance settings

You can customize the axes by using the XAxisSettings, YAxisSettings and Y2AxisSettings properties.

The AxisSettings object can be edited at design time:

Axis Labels as CustomText

If the LabelType is set to CustomText, the labels are entered in the XLabels, YLabels or Y2Labels properties fields using the LabelsCollection Editor:

C#

this.lineChart1.XLabels = new MindFusion.Charting.LabelsCollection("Jan,Feb,Mar,Apr,Mai,Jun,Jul,Aug,Sep,Oct");

3D charts

In 3d charts, the axes are drawn as polygons - the width of the polygon depends on Depth3D. The color of the axes might be changed with AxisShadowBrush:

C#

this.lineChart1.LineType = MindFusion.Charting.LineTypes.Line3D;
this.lineChart1.Depth3D = 40F;

See Also

Creating Bar Charts
Creating Line Charts
Creating Radar Charts


Legend of the Chart

The Legend is specified by the following properties: LegendAlignment, LegendBackgroundBrush, LegendBorder, LegendBorderMargin, LegendBrush, LegendColumns, LegendFont, LegendGridType, LegendLabels, LegendOffset, LegendPen, LegendPosition, LegendWordWrap.

Legend grids do not use brushes and are drawn with the LegendPen.

C# code

this.lineChart1.LabelType = MindFusion.Charting.LabelType.Data;
this.lineChart1.ChartBrushes = new MindFusion.Drawing.BrushCollection("l:90;#FFFFFFFF;#FF0000FF;0;0;0;0;,l:90;#FFFFFFFF;#FFFF8000;0;0;0;0;");
this.lineChart1.ChartPens = new MindFusion.Drawing.PenCollection("n:0/#FF0CB00C/3/0/0//0/0/10/,n:0/#FFFF4500/2/0/0//0/0/10/");
this.lineChart1.GridBrush = new MindFusion.Drawing.SolidBrush("#FFB0C4DE");
this.lineChart1.GridLabelPointer = 0F;
this.lineChart1.GridType = MindFusion.Charting.GridType.Custom;
this.lineChart1.HorGridBrushes = new MindFusion.Drawing.BrushCollection("l:360;#FFC0FFFF;#FF80FFFF;0;0;0;0;,l:360;#FFC0FFC0;#FFFFFF80;0;0;0;0;,l:360;#FFFF" +
"FFC0;#FFFFFF80;0;0;0;0;,l:360;#FFFFE4B5;#FFF0E68C;0;0;0;0;,l:360;#FFFFC080;#FFFF" +
"C080;0;0;0;0;");
this.lineChart1.HorGridPoints = new MindFusion.Charting.DoubleCollection("20,40,60,80");
this.lineChart1.LabelFont = new System.Drawing.Font("Verdana", 12F, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, ((byte)(0)));
this.lineChart1.LegendAlignment = MindFusion.Charting.Alignment.Center;
this.lineChart1.LegendBackgroundBrush = new MindFusion.Drawing.SolidBrush("#FFFFF0F5");
this.lineChart1.LegendBrush = new MindFusion.Drawing.SolidBrush("#FF00008B");
this.lineChart1.LegendColumns = 2;
this.lineChart1.LegendFont = new System.Drawing.Font("Verdana", 9.75F, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, ((byte)(0)));
this.lineChart1.LegendGridType = MindFusion.Charting.GridType.VertScale;
this.lineChart1.LegendLabels = new MindFusion.Charting.StringCollection("Min.Temp.,Max.Temp.");
this.lineChart1.LegendPosition = MindFusion.Charting.Position.Bottom;
this.lineChart1.LegendWordWrap = true;
this.lineChart1.LineType = MindFusion.Charting.LineTypes.Bubble;
this.lineChart1.MinBubbleRadius = 20F;
this.lineChart1.LegendWidth = 100F;

Legend within the Plot area

You can place the legend inside the plot area. Set the LegendOffset property to a negative value as desired.

C#

this.lineChart1.LegendOffset = -150F;


Grid

The type of the grid is specified by the GridType property that receives a value of the GridType Enumeration. GridBrush and AltGridBrush specify the brushes. The grid is drawn with GridPen.

In the topic Creating Line Charts, a chart is drawn whereby GridType is set to HorScale, GridBrush is Light Gray and GridPen is of Dot Style.

Note

RadarCharts and PieCharts have no grid.

  • GridType is HorScale

When the grid is horizontal, vertical or crossed, its width is calculated automatically - it is the distance between scale divisions at the X and / or Y axis.

  • GridType is Chess

The distance between vertical and horizontal lines of the grid of Chess type is set by GridWidth.

  • GridType is Crossed

Crossed grids have both horizontal and vertical lines. The grid width is determined by the position of the scales at the chart axes.

  • GridType is Custom

Custom grid is achieved with the following properties: HorGridPoints and/or VertGridPoints, HorGridBrushes and VertGridBrushes, HorGridPens and VertGridPens.

Custom grid labels at the grid sections on both X and Y axes can be set using XGridLabels and YGridLabels. Pointers can be drawn from the section to its labels. The length of the pointer is set with GridLabelPointer.


MindFusion.Diagramming Tutorials

The following tutorials will show you how to create simple applications based on MindFusion.Diagramming. You will learn to create diagrams to display in Windows Forms in Visual C# or Visual Basic Projects. We use Microsoft Visual Studio 2005, so the commands and screenshots you see throughout the tutorial steps might be different if you are using another Visual Studio version.


Setting up your project to use MindFusion.Diagramming

To create a new project of type 'Windows application' follow the steps below:

  • Select File -> New -> Project from the Visual Studio menu.
  • In the dialog that appears, select Visual C# Project (or Visual Basic project) type from the list on the left.
  • Choose Windows Application from the list of installed templates.
  • Type in the name of your project, for instance FlowChartApplication1, and click OK.


Customize the Visual Studio Toolbox

Follow the steps shown in Setting up your project to use MindFusion.Diagramming in order to create a new Windows Application.

Add the MindFusion.Diagramming control to the Toolbox

Before using the MindFusion.Diagramming control, you must add it to the Toolbox pane.

  • Select View -> Toolbox from the menu to display the Toolbox.
  • Select the appropriate category to place the control and right-click on it (or right-click anywhere in the Toolbox pane). From the context menu, select 'Choose Items'.
  • You may also use Tools -> Choose Toolbox items to add the MindFusion.Diagramming control to the Toolbox.
  • In the 'Choose Toolbox items' dialog, select the '.NET Framework Components' tab, click the 'Browse' button.
  • Navigate to the MindFusion.Diagramming installation folder.
  • Navigate to the subfolder for the particular .NET version.
  • The assembly files are usually found in the c:\Program Files\MindFusion\MindFusion.Diagramming for WinForms\Assemblies for .NET XX\ folder or in the folder where you have installed the product.
  • Select MindFusion.Diagramming.dll, this is the assembly file that contains the Diagram component; click the 'Open' button.
  • Select MindFusion.Diagramming.WinForms.dll, the assembly file that contains the DiagramView component; click the 'Open' button.
  • Once the dlls are added to the list of components, click OK. A Diagram item and a DiagramView item should appear in the selected category in the toolbox.

  • To add the Overview control, click 'Browse', and select MindFusion.Diagramming.WinForms.Overview.dll.

  • To add the Ruler control, click 'Browse', and select MindFusion.Diagramming.WinForms.Ruler.dll.

  • To add the ShapeToolBar control, click 'Browse', and select MindFusion.Diagramming.WinForms.ShapeToolBar.dll.

  • To add the ShapeListBox control, click 'Browse', and select MindFusion.Diagramming.WinForms.ShapeListBox.dll.

  • Click OK to close the 'Choose Toolbox items' dialog.

You can create a MindFusion.Diagramming tab, and add the component assembly files into this tab. All the MindFusion.Diagramming icons will be displayed in the Visual Studio Toolbox as shown below:


Create a Diagram and a DiagramView

This tutorial shows you how to create a Diagram and a DiagramView object on a form.

  • Click Project -> Add Windows Form, choose 'Windows Form' template in the "Add New Item" dialog box, fill in the name and click the 'Add' button.
  • Click Project -> Add Reference to add references to MindFusion.Common.dll, MindFusion.Diagramming.dll and MindFusion.Diagramming.WinForms.dll to your project.
  • Click on the DiagramView icon in the Toolbox, and drag it to the form's working area. This creates a DiagramView instance, and in addition adds a new Diagram object that appears in the Designer area under the Windows Form:

  • If you have skipped step 2 and Visual Studio keeps older versions of the MindFusion.Diagramming assemblies in its cache folder, you will get an error when trying to add a DiagramView object or when trying to build the project. In such a case, make sure the three assemblies listed in step 2 are correctly referenced under the References branch of Solution Explorer.
  • Click on the selection handles of the new DiagramView object and expand the area of the control as desired.
  • Verify that the Diagram property of the DiagramView is correctly set to the Diagram object.

C#

this.diagramView1.Diagram = this.diagram1;

While the DiagramView object is selected, open the property browser and set the view's Diagram property to the Diagram object you have created in step 3. If that object is not visible in the Diagram property drop-down list, close your form and open it again to force Visual Studio to repopulate the drop-down list.

  • MindFusion.Diagramming supports multiple views over the same diagram. You can drop additional DiagramView objects and set their Diagram property to a shared Diagram object if you desire so.


Common MindFusion.Diagramming properties and methods

This tutorial demonstrates how to setup the properties of the MindFusion.Diagramming components.

Start from the Create a Diagram and a DiagramView tutorial.

  • Select the newly created DiagramView object by clicking in the area within the form.
  • Select View -> Properties Window menu item. A list of the available properties appears grouped in categories on the right on the Microsoft Visual Studio window.
  • Select the Diagram or DiagramView object whose properties should be shown in the Properties window:

The respective properties are displayed in the Properties pane.

  • To show the properties in alphabetical order, click the Alphabetical icon. To show the properties categorized, click the Categorized icon.

The Diagram component has the following property categories: Appearance, Behavior, Defaults, Grid, Routing. The Defaults category shows the default values for the properties of new diagram items drawn by the user. Try to set some properties there on your own.

DiagramView has the following property categories: Appearance, Behavior, Inplace text editing, Layout, Data, Mouse cursors, Printing, Tooltips. The Behavior category contains the important Behavior property which specifies the behavior when the user draws with the mouse; assign a value to this property. The Data category contains the Diagram property, which you can use to assign a Diagram object to be displayed in this view.


Setting up the DiagramView properties

Start from the Create a Diagram and a DiagramView tutorial.

  • Select the newly created DiagramView object by clicking in the area within the form.
  • Select View -> Properties Window menu item. A list of the available properties appears grouped in categories on the right on the Microsoft Visual Studio window.
  • Choose the DiagramView object properties to be shown in the Properties window of Visual Studio.

The DiagramView properties are displayed in the Properties pane.

  • To show the properties in alphabetical order, click the Alphabetical icon. To show the properties categorized, click the Categorized icon.

DiagramView properties categories: Appearance, Behavior, Inplace text editing, Layout, Misc, Mouse cursors, Printing, Tooltips. The Misc category contains the important Behavior property and the Diagram subcategory where the Diagram properties values are accessible from.

  • Choose or enter properties values in the Properties pane.

For example, enter a value for the Name property. The Name of the control can be found under the Design category in the property grid. The default name of the DiagramView control is 'diagramView1'. You can change it. The code will be automatically generated by Visual Studio.

Note

The Name property defines the name of the variable you will use to access the DiagramView instance from code.

  • Execute the Windows application directly. You can draw flowcharts according to the chosen properties values.

DiagramView Behavior property

The Behavior property of the DiagramView class defines how MindFusion.Diagramming should interpret mouse actions performed by users of your application.

In the Behavior property field, select one of the following actions: Modify, DrawShapes, DrawLinks, LinkShapes, LinkTables, DrawTables, DrawControls, LinkControls, DoNothing, Custom, DrawContainers, or LinkContainers.

The default value LinkShapes allows drawing of shape nodes and connect them with links. If you choose the LinkTables value, you can draw tables and relations. The Modify value enables only modification of existing items.

How to select a Behavior mode for the DiagramView object

  • Select the newly created DiagramView object by clicking within the Windows form area.
  • Choose a value for the Behavior property in the Visual Studio Properties pane.

The default value is LinkShapes. In this mode, nodes and links can be created in the canvas area, so flowchart diagrams can be drawn. Selecting, moving, modifying and deleting of diagram items is possible by default.

The DrawLinks behavior allows drawing only DiagramLink objects between existing nodes, or if the AllowUnconnectedLinks property is enabled, links can be drawn without connecting them to nodes.
Table-related diagrams created when using LinkTables or DrawTables use TableNode objects.
ControlNode objects can be created interactively when using the DrawControls or LinkControls values.

ContainerNode objects can be created by using the DrawContainers and LinkContainer values.

DiagramView Appearance properties

  • Set the following DiagramView properties: SmoothingMode, BackColor, and ShowScrollbars.
  • Set the BackColor property to a desired color.
  • Set SmoothingMode to AntiAlias.

Zooming and scrolling

  • Set DiagramView.ShowScrollbars to true to enable showing the scrollbar.
  • To customize the scrollbars, use AutoScroll, ScrollX, ScrollY properties. Automatic scrolling is enabled by setting the DiagramView AutoScroll property.
  • The HScrollBar property gets the horizontal scrollbar of the view.
  • The VScrollBar property gets the vertical scrollbar of the view.
  • The ZoomFactor property specifies the zoom factor used to scale up or down the diagram.

Selecting and modifying items

The ModificationStart property specifies how users can modify diagram items. Set it to AutoHandles to enable modification of items without having to select them first.


Setting up the Diagram properties

Start from the Create a Diagram and a DiagramView tutorial.

  • Select the newly created Diagram object in the Windows Forms Designer.
  • Select View -> Properties Window menu item. A list of the available properties appears grouped in categories on the right on the Microsoft Visual Studio window.
  • Choose the Diagram object properties to be shown in the Properties window of Visual Studio.

The respective properties are displayed in the Properties pane.

  • To show the properties in alphabetical order, click the Alphabetical icon. To show the properties categorized, click the Categorized icon.

Diagram properties categories: Appearance, Behavior, Defaults, Grid, Routing. The Defaults category contains properties that specify the default values for newly created diagram items.

Appearance Diagram properties

You can customize the appearance of your diagram; for instance, set the following Diagram properties: ActiveItemHandlesColor, EnableShadowEffects, ShadowsStyle, LinkCrossings, BackBrush, BackgroundImage, Font, RoundedLinks, ShowGrid and so on. You can choose a picture in the BackgroundImage property field to be shown as background in your MindFusion.Diagramming Windows form application, and set the position of the background image by using BackgroundImageAlign.

You can customize the appearance of new shape nodes, links and tables.

  • To customize the appearance of new links, you can set the following Diagram properties: LinkBaseShape, LinkBaseShapeSize, LinkBrush, LinkCrossings, LinkHeadShape, LinkPen, LinksSnapToBorders, LinkStyle and so on.
  • To customize the appearance of new shapes, you can set the following Diagram properties: ShapeBrush, ShapePen, ShapeHandlesStyle, ShapeText and so on.
  • To customize the appearance of new tables, you can set the following Diagram properties: TableBrush, TableCaption, TableColumnCount, TablePen, TableRowCount, TableStyle and so on.

Selecting and modifying items

  • If Diagram.SelectAfterCreate is set to true, every newly created item will be automatically selected.
  • Use the Selection property of the Diagram class to get the items currently selected.
  • Customize selection handles by using the following Diagram properties: LinkHandlesStyle, ShapeHandlesStyle, and TableHandlesStyle.
  • Use the SelectedItemHandlesColor property to specify the color of the adjustment handles of selected items.
  • To specify the color of the adjustment handles of the active item, set the ActiveItemHandlesColor Property to the desired color.
  • The Diagram.SelectionOnTop property indicates whether selected items should be painted on top of other items.

Changing the MeasureUnit property

Many properties in the MindFusion.Diagramming API are based on the MeasureUnit setting, for example AdjustmentHandlesSize, LinkBaseShapeSize, LinkHeadShapeSize, GridSizeX, GridSizeY, GridOffsetX, GridOffsetY, RoundedLinksRadius, RoundRectFactor and so on. The default measure unit in MindFusion.Diagramming is Millimeter.

Note

Changing the measure unit resets RoutingOptions to default values.

Example:

  • Set the Diagram.MeasureUnit to Millimeter. GridSizeX and GridSizeY are 4 millimeters each.
  • Set ShowGrid to true. Set GridStyle to Lines.
  • Run the application. Draw a diagram node.

  • Change the MeasureUnit to Inch.

You must change yourself the values of the properties based on the selected MeasureUnit. Now, to have the same grid size, fill in 0.157 in both GridSizeX and GridSizeY properties fields (recalculate the size into the new measure unit: 1/2.54*4 = 0.157). The values of GridSizeX and GridSizeY are 0.157 inches now.


Storing MindFusion.Diagramming diagrams

Start from the 'Create a Diagram and a DiagramView tutorial.

To store diagrams, use the following methods: SaveToFile, SaveToStream, SaveToXml, SaveToString.

To load diagrams, use the following methods: LoadFromFile, LoadFromStream, LoadFromXml, and LoadFromString.

  • Using SaveToFile and LoadFromFile

Diagram.SaveToFile method saves the binary contents of a diagram to the specified file. The file contents can be loaded later using the LoadFromFile method.

The following example shows how to save/load a diagram to/from a file:

  • Create the File, Edit, and Tools main menu items by using the MenuStrip component.
  • To the File menu, add the following menu items: Load, Save;

C#

/// Required designer variables
private MainMenu _mainMenu;
private MenuItem _menuItemFile;
private MenuItem _menuItemLoad;
private MenuItem _menuItemSave;
private OpenFileDialog _openFileDialog;
private SaveFileDialog _saveFileDialog;
private Diagram diagram;
private DiagramView diagramView;

#region Windows Form Designer generated code

private void InitializeComponent()
{
System.Resources.ResourceManager resources = new System.Resources.ResourceManager(typeof(MainForm));
this._mainMenu = new System.Windows.Forms.MainMenu();
this._menuItemFile = new System.Windows.Forms.MenuItem();
this._menuItemNew = new System.Windows.Forms.MenuItem();
this._menuItemOpen = new System.Windows.Forms.MenuItem();
this._menuItemSave = new System.Windows.Forms.MenuItem();
this.diagramView = new MindFusion.Diagramming.WinForms.DiagramView();
this.diagram = new MindFusion.Diagramming.Diagram();

Visual Basic

Private Sub InitializeComponent()
Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(MainForm))
Me._mainMenu = New System.Windows.Forms.MainMenu
Me._menuItemFile = New System.Windows.Forms.MenuItem
Me._menuItemNew = New System.Windows.Forms.MenuItem
Me._menuItemLoad = New System.Windows.Forms.MenuItem
Me._menuItemSave = New System.Windows.Forms.MenuItem
Me._saveFileDialog = New System.Windows.Forms.SaveFileDialog

  • Add functionality to the Save menu item by using the Click event in the Properties window:
    Click the File -> Save menu item; click the Events icon in the Properties window on the right. In the Click field, type in 'OnFileSave', press Enter.
  • Add a shortcut key to the Save menu item at design time:
    Select the menu item within the Menu Designer. In the Properties window, set the Shortcut property to one of the values offered in the drop-down list, in this case CTRL+S.

C#

// _menuItemSave
//
this._menuItemSave.Index = 2;
this._menuItemSave.Shortcut = System.Windows.Forms.Shortcut.CtrlS;
this._menuItemSave.Text = "&Save...";
this._menuItemSave.Click += new System.EventHandler(this.OnFileSave);

Visual Basic

'_menuItemSave
'
Me._menuItemSave.Index = 2
Me._menuItemSave.Shortcut = System.Windows.Forms.Shortcut.CtrlS
Me._menuItemSave.Text = "&Save..."

  • Specify a SaveFileDialog object to create a new file

C#

// _saveFileDialog
//
this._saveFileDialog.DefaultExt = "fcs";
this._saveFileDialog.FileName = "Flowchart";
this._saveFileDialog.Filter = "FlowCharter documents|*.fcs|All files|*.*";
this._saveFileDialog.Title = "Save document";

Visual Basic

'_saveFileDialog
'
Me._saveFileDialog.DefaultExt = "fcs"
Me._saveFileDialog.FileName = "Flowchart"
Me._saveFileDialog.Filter = "FlowCharter documents|*.fcs|All files|*.*"
Me._saveFileDialog.Title = "Save document"

  • Define the 'OnFileSave' method. Call the SaveFileDialog box using the ShowDialog method, and save the diagram to the file with the specified FileName.

C#

private void OnFileSave(object sender, EventArgs e)
{
if (_saveFileDialog.ShowDialog(this) == DialogResult.OK)
{
diagram.SaveToFile(_saveFileDialog.FileName, true);
}
}

Visual Basic

Private Sub _menuItemSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles _menuItemSave.Click
If _saveFileDialog.ShowDialog(Me) = DialogResult.OK Then
_doc.SaveToFile(_saveFileDialog.FileName, True)
End If
End Sub

  • Add functionality to the Load menu item by using the Click event in the Properties window.
    Click the File -> Load menu item; click the Events icon in the Properties window on the right. In the Click field, type in 'OnFileLoad', press Enter.
    Add a shortcut key to the Load menu item at design time or programmatically.

C#

// _menuItemLoad
//
this._menuItemLoad.Index = 1;
this._menuItemLoad.Shortcut = System.Windows.Forms.Shortcut.CtrlO;
this._menuItemLoad.Text = "&Open...";
this._menuItemLoad.Click += new System.EventHandler(this.OnFileLoad);

Visual Basic

'_menuItemLoad
'
Me._menuItemLoad.Index = 1
Me._menuItemLoad.Shortcut = System.Windows.Forms.Shortcut.CtrlO
Me._menuItemLoad.Text = "&Open..."

  • Define the 'OnFileLoad' method. Call the OpenFileDialog box using the ShowDialog method, and load the diagram from the file with the specified FileName. Add a message box if loading the file is failed.

C#

private void OnFileLoad(object sender, EventArgs e)
{
if (_openFileDialog.ShowDialog(this) == DialogResult.OK)
{
try
{
diagram.LoadFromFile(_openFileDialog.FileName);
}
catch
{
MessageBox.Show(this, "Failed to open document!");
}
}
}

Visual Basic

Private Sub _menuItemLoad_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles _menuItemOpen.Click
If _openFileDialog.ShowDialog(Me) = DialogResult.OK Then
Try
_doc.LoadFromFile(_openFileDialog.FileName)
Catch
MessageBox.Show(Me, "Failed to open document!")
End Try
End If
End Sub

For a complete sample that implements SaveToFile and LoadFromFile, see the FlowCharter sample in the installation folder.

  • SaveToStream and LoadFromStream

Diagram.SaveToStream method saves the binary contents of the diagram to the specified .NET stream.

You can save an array of Diagram objects into a single file as shown below.

C#

FileStream fs = new FileStream(@"C:\test.dg", FileMode.Create);
fs.WriteByte((byte)pages.Length);
foreach (Diagram page in pages)
page.SaveToStream(fs);

Use LoadFromStream to load the Diagram objects.

  • SaveToXml and LoadFromXml

Diagram.SaveToXml method saves the diagram to an XML document.

To save a diagram to a XML document, add the code for SaveToXML:

C#

private void OnXmlSave(object sender, EventArgs e)
{
if (_saveFileDialog.ShowDialog(this) == DialogResult.OK)
{
diagram.SaveToXML(_saveFileDialog.FileName);
}
}

To load a diagram from a XML document, use LoadFromXml:

C#

private void OnXmlLoad(object sender, EventArgs e)
{
if (_openFileDialog.ShowDialog(this) == DialogResult.OK)
{
try
{
diagram.LoadFromXml(_openFileDialog.FileName);
}
catch
{
MessageBox.Show(this, "Failed to open document!");
}
}
}

Note

Make sure the Form.cs contains the following code line:
using System.Xml;

  • SaveToString and LoadFromString

Diagram.SaveToString method encodes the diagram contents into an ASCII string.

For a complete sample that implements SaveToString and LoadFromString, see the Genealogy sample in the installation folder.

To save the chart in a database field, use SaveToString as shown below:

C#

// save the whole chart
dbChartAdapter.InsertCommand.Parameters.Clear();
dbChartAdapter.InsertCommand.Parameters.Add("FlowChart", diagram.SaveToString(SaveToStringFormat.Base64, true));
dbChartAdapter.InsertCommand.ExecuteNonQuery();

To load the chart, use LoadFromString as shown below:

C#

// read the chart
diagram.LoadFromString(chartSet.FlowChart[0]["FlowChart"] as string);


Printing MindFusion.Diagramming diagrams

The DiagramView.Print method prints the diagram to the default printer.

The DiagramView.PrintPreview method displays the standard .NET print preview form.

For a complete sample that implements Print and PrintPreview, see the FlowCharter sample in the installation folder.

  • Specify the PrintOptions for PrintPreview

C#

private void OnPrintPreview(object sender, EventArgs e)
{
diagramView.PrintOptions.DocumentName = "Flowchart";
diagramView.PrintOptions.EnableImages = false;
diagramView.PrintOptions.EnableInterior = true;
diagramView.PrintOptions.EnableShadows = true;
diagramView.PrintOptions.Scale = 100;
diagramView.PrintPreview();
}

Visual Basic

Private Sub _menuItemPreview_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles _menuItemPreview.Click
_view.PrintOptions.DocumentName = "Flowchart"
_view.PrintOptions.EnableImages = False
_view.PrintOptions.EnableInterior = True
_view.PrintOptions.EnableShadows = True
_view.PrintOptions.Scale = 100
_view.PrintPreview()
End Sub

  • Specify the PrintOptions for Print

The first Print method displays the standard Windows print dialog, allowing users to select a printer and choose which portions of the document to print.

C#

private void OnPrint(object sender, EventArgs e)
{
diagramView.PrintOptions.DocumentName = "Flowchart";
diagramView.PrintOptions.EnableImages = false;
diagramView.PrintOptions.EnableInterior = true;
diagramView.PrintOptions.EnableShadows = true;
diagramView.PrintOptions.Scale = 100;
diagramView.Print();
}

Visual Basic

Private Sub _menuItemPrint_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles _menuItemPrint.Click
_view.PrintOptions.DocumentName = "Flowchart"
_view.PrintOptions.EnableImages = False
_view.PrintOptions.EnableInterior = True
_view.PrintOptions.EnableShadows = True
_view.PrintOptions.Scale = 100
_view.Print()
End Sub

The second overloaded Print method does not display print dialog, but uses the options specified through the doc argument. The DefaultPageSettings property of PrintDocument allows setting page size and orientation. The PrinterSettings property allows choosing the device to print the diagram.

  • Specify DefaultPageSettings.Landscape orientation for PrintDocument and call the Print method:

C#

PrintDocument pdoc = new PrintDocument();
pdoc.DefaultPageSetting.Landscape = true;
diagramView.Print(pdoc)


Using ShapeNode objects

© 2009 MindFusion


Tutorial 1: Your first FlowChart diagram

This tutorial demonstrates how to create a MindFusion.Diagramming application with Behavior set to LinkShapes.

Start from the 'Create a Diagram and a DiagramView' tutorial.

1. Set the Diagram Properties

  • Set LinkStyle to Polyline; fill in 'Link' in the LinkText property field.
  • Set LinkBrush to the desired color, choose Yellow.
  • Set LinkHeadShape to PointerArrow.
  • Set the ShapeBrush to the desired color, YellowGreen, and fill in 'Node' in the ShapeText field.

Tip

Use the Visual Studio Property windows to select the desired properties values. You could also assign the property values through source code, for example, from the handler of the Form.Load event. To generate a Form.Load event handler:

  • Right-click the Form.cs in the Solution Explorer
  • Choose View Designer
  • Double-click the Form title bar in the Windows Form Designer

2. Set the DiagramView Properties

  • Select the DiagramView object on the Windows Form. Click the left mouse button within the area of the DiagramView component in the Form window;
  • In the DiagramView Properties window, choose LinkShapes in the Behavior property field;

Note

Make sure the Enabled property of the DiagramView object is set to true (it is the default value). This is necessary to make the component interactive, to be capable to create or modify diagram elements.

  • Enable anti-aliasing for the diagram view. Set the SmoothingMode property to HighQuality. SmoothingMode possible values: Invalid, Default, HighSpeed, HighQuality, None, AntiAlias.

Note

At this time only HighQuality and AntiAlias smooth the graphic elements in the diagram view.

3. Enable the Diagram property of the DiagramView object

To enable the Diagram property of the DiagramView object in order to display the diagram by this view, two approaches are available. In the Form.Designer.cs, write the code:

C#

this.diagramView1.Diagram = this.diagram1;

In the DiagramView Properties window, fill in the name of the Diagram instance in the Diagram property field, in this case 'diagram1':

The code will be automatically generated from the Visual Studio:

this.diagramView1.Diagram = this.diagram1;

4. Execute the Windows Form application

Click CTRL+F5 (or click the [image] icon). The Windows Form area appears. The diagram drawing application is generated automatically from Microsoft Visual Studio. Now, you can draw nodes and links in the Windows Form.

To draw the first node, click the left mouse button within the Form area, drag the mouse to draw a node, and release the left mouse button to finish drawing the node. The node is drawn by using the default property values shown under the Default category for the Diagram object. You can change the default properties before executing the application.

Draw the second node in the same way.

To draw a link between two nodes, place the mouse over the first node. If the mouse pointer appears as a right hand image (in this case, AllowLinkCursor is set to Hand, see Properties pane), click the left mouse button, move the mouse to the next node and release the left mouse button. The link appears between the nodes.

Draw several nodes and/or links to create your diagram as desired.

Note

To delete a node or link, click the node/link to select it, and press the DEL key.

5. Look at the source code generated automatically

Most of the code for this application is generated automatically by Microsoft Visual Studio. It is the simplest application for drawing a MindFusion.Diagramming diagram.

To view the program code, click the Form.cs tab in the Windows Form Designer of Microsoft Visual Studio (or double-click the Form1 title bar). The Code Editor appears.

The C# code in Form.cs

using System;
using System.ComponentModel;
using System.Drawing;
using System.Windows.Forms;

using MindFusion.Diagramming;
using MindFusion.Diagramming.WinForms;
using MindFusion.Drawing;

namespace FlowChartApplication1
{
public partial class Form1 : Form
{
public Form1()
{
InitializeComponent();
}

private void Form1_Load(object sender, EventArgs e)
{
}
}
}

In the Form1.Designer.cs, double-click the following framed code message (or click the plus sign on the left):

The following Windows Form Designer generated code is shown inside the Form1 class in the Flowchart namespace:

Windows Form Designer generated code

#region Windows Form Designer generated code
/// <summary>
/// Required method for Designer support - do not modify
/// the contents of this method with the code editor.
/// </summary>
private void InitializeComponent()
{
System.ComponentModel.ComponentResourceManager resources = new System.ComponentModel.ComponentResourceManager(typeof(Form1));
this.diagramView1 = new MindFusion.Diagramming.WinForms.DiagramView();
this.diagram1 = new MindFusion.Diagramming.Diagram();
this.SuspendLayout();
//
// diagramView1
//
this.diagramView1.Behavior = MindFusion.Diagramming.Behavior.LinkShapes;
this.diagramView1.ControlHandlesStyle = MindFusion.Diagramming.HandlesStyle.HatchHandles;
this.diagramView1.ControlMouseAction = MindFusion.Diagramming.ControlMouseAction.SelectNode;
this.diagramView1.Diagram = this.diagram1;
this.diagramView1.InplaceEditFont = new System.Drawing.Font("Microsoft Sans Serif", 8.25F, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, ((byte)(0)));
this.diagramView1.Location = new System.Drawing.Point(12, 12);
this.diagramView1.MiddleButtonActions = MindFusion.Diagramming.MouseButtonActions.None;
this.diagramView1.ModificationStart = MindFusion.Diagramming.ModificationStart.SelectedOnly;
this.diagramView1.Name = "diagramView1";
this.diagramView1.PrintOptions.RenderTarget = MindFusion.Diagramming.RenderTarget.Printer;
this.diagramView1.PrintOptions.TargetView = null;
this.diagramView1.RightButtonActions = MindFusion.Diagramming.MouseButtonActions.Cancel;
this.diagramView1.Size = new System.Drawing.Size(268, 242);
this.diagramView1.TabIndex = 0;
this.diagramView1.Text = "diagramView1";
//
// diagram1
//
this.diagram1.BackgroundImageAlign = MindFusion.Drawing.ImageAlign.TopLeft;
this.diagram1.Bounds = ((System.Drawing.RectangleF)(resources.GetObject("diagram1.Bounds")));
this.diagram1.ContainerMargin = 10F;
this.diagram1.ContainerMinimumSize = new System.Drawing.SizeF(50F, 40F);
this.diagram1.Font = new System.Drawing.Font("Microsoft Sans Serif", 2.9F, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.World);
this.diagram1.Interaction = null;
//
// Form1
//
this.AutoScaleDimensions = new System.Drawing.SizeF(6F, 13F);
this.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font;
this.ClientSize = new System.Drawing.Size(323, 266);
this.Controls.Add(this.diagramView1);
this.Name = "Form1";
this.Text = "Form1";
this.Load += new System.EventHandler(this.Form1_Load);
this.ResumeLayout(false);
}

Afterwards, the following code lines about the FlowChart control are generated

private MindFusion.Diagramming.WinForms.DiagramView diagramView1;
private MindFusion.Diagramming.Diagram diagram1;

By using this simple program, you can draw several nodes and links in your diagram, whereby all nodes and links have the same properties values set at design time. The properties not shown in the Properties pane are assigned the default values.

Make sure the Form.cs contains the following code lines:

C#

using MindFusion.Diagramming;
using MindFusion.Diagramming.WinForms;
using MindFusion.Drawing;

Enable the Diagram property of the DiagramView object in order to display the diagram by this view:

C#

this.diagramView1.Diagram = this.diagram1;


Tutorial 2: Changing the default shape

This tutorial will show you how to change the default shape of nodes.

ShapeNode objects can be drawn as various geometric shapes, as set through their Shape property. The DefaultShape property specifies what shape should be assigned to new nodes, and it is set to RoundRect by default.

Start from the 'Create a Diagram and a DiagramView' tutorial.

  • Set DefaultShape to Rectangle.

To change the node shape, write the following code in the Form1.cs after InitializeComponent:

public Form1()
{
InitializeComponent();
this.diagram1.DefaultShape = Shapes.Rectangle;
}

DefaultShape of the shape node is set to Rectangle:

There are 87 predefined shapes exposed as static members of the Shapes class. The Shape property can be set to one of the predefined shapes: RoundRect, Rectangle, Ellipse, Process, Procedure, Delay and much more. In addition, the Shape class lets you create custom shapes.

  • Set DefaultShape to Delay.

Code

this.diagram1.DefaultShape = Shapes.Delay;
this.diagram1.ShapeText = "Delay";

Note

The node has the shape of a D-like symbol used to denote delay in process diagrams.


Tutorial 3: Editing the text of nodes

Start from the 'Create a Diagram and a DiagramView' tutorial.

  • Set the AllowInplaceEdit property of DiagramView to true. Then, you can edit the text content of a node (or a table's cell) by double-clicking the node. To exit the field after entering the text, click anywhere outside the text-field.
  • To let users accept the edited text by pressing ENTER, set InplaceEditAcceptOnEnter to true.
  • Double-click within the node, an input field appears in the node:

  • Enter the text, and then click outside the text-field. If InplaceEditAcceptOnEnter is set to true, press ENTER to accept inserting/editing of texts. If InplaceEditCancelOnEsc is set to true, press ESC to cancel inserting/changing of the text.

  • Example

Draw the shape nodes and type in the text as shown in the picture:

C# Code

// diagramView1
this.diagramView1.AllowInplaceEdit = true;
this.diagramView1.InplaceEditAcceptOnEnter = true;
this.diagramView1.InplaceEditFont = new System.Drawing.Font("Microsoft Sans Serif", 8.25F, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, ((byte)(0)));

  • Change the font of the text in the edit box

To change the font of the inplace-edit text box, choose a font in the InplaceEditFont property field.
Set the TextColor property of the Diagram object in the Properties pane to change the appearance color of the text.

See also tutorial about
Text in-place editing of container nodes.
Text in-place editing of diagram links.


Tutorial 4: Creating ShapeNode objects programmatically

Start from the 'Create a Diagram and a DiagramView' tutorial.

1. Create a new ShapeNode.

Call the CreateShapeNode method through the Factory property of the Diagram class. To create a ShapeNode object, use this code (specifying the desired size and position):

C#

ShapeNode b = diagram.Factory.CreateShapeNode(10, 10, 40, 20);

Set the Text property of the new ShapeNode object:

C#

b.Text = "This is a node";

Set the TextColor and Font of the new ShapeNode object

C#

b.TextColor = Color.Red;
b.Font = new Font("Times New Roman", 6, GraphicsUnit.World);

Run the ShapeNode application. The Form area appears. Click in the Form area. The following shape is drawn:

Form.cs (C#)

using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Windows.Forms;

using MindFusion.Diagramming;
using MindFusion.Drawing;
using MindFusion.Diagramming.WinForms;

namespace ShapeNodesChart
{
public partial class Form1 : Form
{
public Form1()
{
InitializeComponent();
}

private void Form1_Load(object sender, EventArgs e)
{
this.diagram1.DefaultShape = Shapes.Rectangle;
}

private void diagram_Clicked(object sender, DiagramEventArgs e)
{
ShapeNode b = diagram1.Factory.CreateShapeNode(10, 10, 40, 20);
b.Text = "This is a node";
b.TextColor = Color.Red;
b.Font = new Font("Times New Roman", 6, GraphicsUnit.World);
}

private void textBox1_TextChanged(object sender, EventArgs e)
{
}
}
}

Form.Designer.cs (C#)

namespace ShapeNodesChart
{
partial class Form1
{
/// <summary>
/// Required designer variable.
/// </summary>
private System.ComponentModel.IContainer components = null;

/// <summary>
/// Clean up any resources being used.
/// </summary>
/// <param name="disposing">true if managed resources should be disposed; otherwise, false.</param>
protected override void Dispose(bool disposing)
{
if (disposing && (components != null))
{
components.Dispose();
}
base.Dispose(disposing);
}

#region Windows Form Designer generated code

/// <summary>
/// Required method for Designer support - do not modify
/// the contents of this method with the code editor.
/// </summary>
private void InitializeComponent()
{
System.ComponentModel.ComponentResourceManager resources = new System.ComponentModel.ComponentResourceManager(typeof(Form1));
this.diagram1 = new MindFusion.Diagramming.Diagram();
this.diagramView1 = new MindFusion.Diagramming.WinForms.DiagramView();
this.textBox1 = new System.Windows.Forms.TextBox();
this.SuspendLayout();
//
// diagram1
//
this.diagram1.ActiveItemHandlesColor = System.Drawing.Color.Red;
this.diagram1.BackBrush = new MindFusion.Drawing.SolidBrush("#FF8FBC8B");
this.diagram1.Bounds = ((System.Drawing.RectangleF)(resources.GetObject("diagram1.Bounds")));
this.diagram1.Font = new System.Drawing.Font("Microsoft Sans Serif", 2.9F, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.World);
this.diagram1.Interaction = null;
this.diagram1.ShapeBrush = new MindFusion.Drawing.SolidBrush("#FFFFFF00");
this.diagram1.Clicked += new MindFusion.Diagramming.DiagramEventHandler(this.diagram_Clicked);
//
// diagramView1
//
this.diagramView1.BackColor = System.Drawing.SystemColors.ButtonFace;
this.diagramView1.BackgroundImageLayout = System.Windows.Forms.ImageLayout.Center;
this.diagramView1.Behavior = MindFusion.Diagramming.Behavior.LinkShapes;
this.diagramView1.ControlHandlesStyle = MindFusion.Diagramming.HandlesStyle.HatchHandles;
this.diagramView1.ControlMouseAction = MindFusion.Diagramming.ControlMouseAction.SelectNode;
this.diagramView1.Diagram = this.diagram1;
this.diagramView1.InplaceEditFont = new System.Drawing.Font("Microsoft Sans Serif", 8.25F, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, ((byte)(0)));
this.diagramView1.Location = new System.Drawing.Point(12, 12);
this.diagramView1.MiddleButtonActions = MindFusion.Diagramming.MouseButtonActions.None;
this.diagramView1.ModificationStart = MindFusion.Diagramming.ModificationStart.SelectedOnly;
this.diagramView1.Name = "diagramView1";
this.diagramView1.PrintOptions.HyperLinkStyle = MindFusion.Diagramming.HyperLinkStyle.Text;
this.diagramView1.PrintOptions.HyperLinkTarget = "_self";
this.diagramView1.PrintOptions.RenderTarget = MindFusion.Diagramming.RenderTarget.Printer;
this.diagramView1.PrintOptions.TargetView = null;
this.diagramView1.PrintOptions.VisibleRect = ((System.Drawing.RectangleF)(resources.GetObject("diagramView1.PrintOptions.VisibleRect")));
this.diagramView1.RightButtonActions = MindFusion.Diagramming.MouseButtonActions.Cancel;
this.diagramView1.Size = new System.Drawing.Size(420, 304);
this.diagramView1.TabIndex = 0;
this.diagramView1.Text = "diagramView1";
//
// textBox1
//
this.textBox1.BackColor = System.Drawing.SystemColors.GradientActiveCaption;
this.textBox1.Location = new System.Drawing.Point(57, 23);
this.textBox1.Name = "textBox1";
this.textBox1.Size = new System.Drawing.Size(188, 20);
this.textBox1.TabIndex = 1;
this.textBox1.Text = "Click below to create a node";
this.textBox1.TextChanged += new System.EventHandler(this.textBox1_TextChanged);
//
// Form1
//
this.AutoScaleDimensions = new System.Drawing.SizeF(6F, 13F);
this.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font;
this.BackColor = System.Drawing.SystemColors.Desktop;
this.ClientSize = new System.Drawing.Size(432, 316);
this.Controls.Add(this.textBox1);
this.Controls.Add(this.diagramView1);
this.Name = "Form1";
this.Text = "Form1";
this.Load += new System.EventHandler(this.Form1_Load);
this.ResumeLayout(false);
this.PerformLayout();
}

#endregion

private MindFusion.Diagramming.Diagram diagram1;
private MindFusion.Diagramming.WinForms.DiagramView diagramView1;
private System.Windows.Forms.TextBox textBox1;
}
}

2. Create a custom ShapeNode.

Call the CreateShapeNode method. Set the Shape property of the new ShapeNode object, use one of the predefined shapes.

C#

ShapeNode b = diagram.Factory.CreateShapeNode(10, 10, 40, 20);
b.Shape = Shape.FromId("File");

Set the Text property of the new ShapeNode object:

C#

b.Text = "This is a file";

Set the TextColor and Font of the new ShapeNode object:

C#

b.TextColor = Color.Red;
b.Font = new Font("Times New Roman", 6, GraphicsUnit.World);

Run the ShapeNode application. The Form area appears. Click in the Form area. The following shape is drawn:

3. Add an Image to the ShapeNode object.

Add the code as shown below, and place the image file in the "bin\debug" folder of the solution directory. This is the default folder where the image will be searched if the path to the file is not specified.
Specify a Text, TextColor and Font for the new ShapeNode object.

C#

private void diagram_Clicked(object sender, DiagramEventArgs e)
{
ShapeNode b = diagram1.Factory.CreateShapeNode(10, 10, 40, 20);
b.Text = "This is an image";
b.TextColor = Color.Black;
b.Font = new Font("Times New Roman", 4, GraphicsUnit.World);
b.Image = Image.FromFile("Birds.jpg");
}

Run the ShapeNode application. The Form area appears. Click in the Form area. The shape node is drawn and the picture is displayed as shown below:

To align the image as desired, specify the ImageAlign property, for example set it to Stretch.

C#

b.ImageAlign = ImageAlign.Stretch;

Run the ShapeNode application. Click in the Form area. The shape node is drawn and the image is shown stretched in the shape node.

To make the shape node transparent, set the Transparent property to true. Set ImageAlign to Fit.

C#

b.Transparent = true;
b.ImageAlign = ImageAlign.Fit;

Run the ShapeNode application. Click in the Form area. The shape node is drawn transparent, and only the picture is visible as shown below:


Tutorial 5: Create a hierarchy chart

Start from the 'Create a Diagram and a DiagramView' tutorial.

Let's create a chart similar to the one below:

  • Select the Diagram and DiagramView controls on the Windows Form. Choose the appropriate properties values as described in the next steps.
  • Set Behavior property of the DiagramView object to LinkShapes.
  • Set default node shape to Ellipse.

Code:

this.diagram1.DefaultShape = Shapes.Ellipse;

  • Set NodesExpandable to true.

Code

this.diagram1.NodesExpandable = true;

In this case, a small square button with a minus or plus sign in it appears on the right of the drawn node in the chart. If a node has successors, and you click on the plus sign near the node, the tree expands, the successors are shown, and the plus sign changes into a minus sign. If you click then the minus sign near the same node, the successors disappear, and the minus sign is transformed into a plus sign.

  • Set ExpandButtonAction to ExpandTreeBranch.
  • Set ExpandButtonPosition to OuterRight. In this case, the plus/minus button appears outer on the right near the node.
  • Set the SmoothingMode property to HighQuality.

C#

this.diagramView1.SmoothingMode = System.Drawing.Drawing2D.SmoothingMode.HighQuality;

  • Execute the application: Click Ctrl+F5 (or click the [image] icon). The Form area appears.
  • Draw nodes and links in the Windows Form as shown above.


Tutorial 6: Other Flowchart diagrams

Start from the 'Create a Diagram and a DiagramView' tutorial.

Draw the following charts by setting the MindFusion.Diagramming properties interactively at design time. The DiagramView.Behavior property is set to LinkShapes in the Properties pane.

Chart 1

1. Set node shape to Ellipse.

Code

this.diagram1.DefaultShape = Shapes.Ellipse;

2. Set NodesExpandable to false.

3. Set LinkHeadShape to None.

4. Set AllowInplaceEdit to true.

Chart 2

1. Set node shape to Rectangle.

Code

this.diagram1.DefaultShape = Shapes.Rectangle;

2. Set AllowUnconnectedLinks to true, LinkHeadShape to None, LinkBaseShape to None.

3. Set LinkStyle to Cascading. Set LinkCascadeOrientation to Vertical.

4. Set LinkCrossings to Cut.

Chart 3

1. Set Behavior to LinkShapes.

2. Set default node shape to Ellipse.

C#

this.diagram1.DefaultShape = Shapes.Ellipse;

Chart 4

Set LinkHeadShape and LinkBaseShape to Triangle.

Chart 5

Each item (node) is connected to many other items (nodes). Set LinkHeadShape to Arrow, set LinkCrossings to Cut, AllowSplitLinks to false, LinkStyle to Polyline, LinkSegments to 1, RoundedLinks to false, RouteLinks to false, LinkBaseShape to None, DefaultShape to Rectangle, NodesExpandable to false, EnableShadowEffects to true.

Symmetric graph

Set DefaultShape to Ellipse, LinkHeadShape to None.

Actor chart

Set DefaultShape to Rectangle, LinkHeadShape to Triangle, LinkBaseShape to Triangle, LinkEndsMovable to false, AllowUnconnectedLinks to true, AllowLinksRepeat to true. Run the chart application. Draw the nodes and links as shown below, and fill in the respective text in the nodes.


Tutorial 7: Custom shape nodes

This tutorial demonstrates how to perform custom drawing of shape nodes.

By using the Shape class, you can design any shape composed of lines, arcs and Bezier-curves.

Start from the 'Create a Diagram and a DiagramView' tutorial.

1. Set the following Diagram properties:

Property name | Property value
ShapeCustomDraw | None
LinkCustomDraw | None
LinkSegments | 3
LinkStyle | Cascading
LinkHeadShape | DoubleArrow

2. Set the following DiagramView properties:

Property name | Property value
Behavior | Custom or LinkShapes
ModificationStart | SelectedOnly

3. To draw a custom shape node, add the following lines in your code within the Form_Load event:

C#

this.diagram1.DefaultShape = new Shape(
new ElementTemplate[] {
new LineTemplate(0, 0, 100, 0),
new LineTemplate(100, 0, 100, 50),
new LineTemplate(100, 50, 50, 50),
new LineTemplate(50, 50, 50, 100),
new LineTemplate(50, 100, 0, 100),
new LineTemplate(0, 100, 0, 50)
},
FillMode.Winding, "Custom");

4. Insert the following using statement:

C#

using System.Drawing.Drawing2D;

5. Run the application. On the form, draw a diagram as shown below or as desired:


Using DiagramLink objects

© 2009 MindFusion


Tutorial 1: The DrawLinks behavior

This sample demonstrates how to draw a flowchart diagram with behavior DrawLinks.

Start from the 'Create a Diagram and a DiagramView' tutorial.

Set the Behavior property of DiagramView to DrawLinks and the AllowUnconnectedLinks property of Diagram to true.

Code

this.diagramView1.Behavior = MindFusion.Diagramming.Behavior.DrawLinks;
this.diagram1.AllowUnconnectedLinks = true;

These values let you draw unconnected links.

Example 1

You can draw the following by setting LinkStyle to Polyline.

1. Set the LinkHeadShape to Triangle, and specify the LinkHeadShapeSize as needed in the Properties window.

C#

this.diagram1.LinkHeadShape = MindFusion.Diagramming.ArrowHead.Triangle;

2. Choose Polyline for LinkStyle.

3. Set the SmoothingMode property to HighQuality.

C#

this.diagramView1.SmoothingMode = System.Drawing.Drawing2D.SmoothingMode.HighQuality;

4. Set AllowUnconnectedLinks to true.

C#

this.diagram1.AllowUnconnectedLinks = true;

5. Set AllowSplitLinks to true.

C#

this.diagram1.AllowSplitLinks = true;

6. Insert new link segments interactively by clicking and dragging a point of a link's segment.

For Polyline links, additional segments can created by dragging the middle of a segment, splitting it into two parts.

Example 2

You can draw the following by setting LinkStyle to Cascading .

1. Set LinkStyle to Cascading, LinkCascadeOrientation to Auto.

2. Set LinkCrossings to Straight, set LinkEndsMovable to true.

3. Set LinkHeadShape to Triangle, LinkHeadShapeSize to 2, LinkSegments to 4.

4. Set AllowUnconnectedLinks to true.

C#

this.diagram1.AllowUnconnectedLinks = true;

5. Set AllowSplitLinks to true.

C#

this.diagram1.AllowSplitLinks = true;

For Cascading links, two segments are inserted keeping intact the alternating pattern of horizontal and vertical segments, each orthogonal to its neighbors.

Execute the application. Draw in the Windows Form the chart shown above.

Example 3

You can draw the following by setting LinkStyle to Bezier.

1. Set LinkStyle to Bezier.

2. Set LinkHeadShape to Triangle.

Note

Bezier-style links cannot be split in the current version.

3. Execute the application. Draw in the Windows Form the chart shown above.

Example 4

In the Properties pane, set LinkHeadShape to DoubleArrow, LinkSegments to 3, LinkStyle to Cascading.The code is generated automatically. Run the application. Draw an arrow diagram on the form:


Tutorial 2: Drawing diagram links

Start from the 'Create a Diagram and a DiagramView' tutorial.

LinkBaseShape and LinkHeadShape

LinkBaseShape specifies the shape displayed at the base of the links, and LinkHeadShape specifies the shape of the link head.

Set LinkBaseShape and LinkHeadShape to the same value such as Triangle or Arrow by choosing from the selection box items.

Code

this.diagramView1.Behavior = MindFusion.Diagramming.Behavior.LinkShapes;
this.diagram1.LinkBrush = new MindFusion.Drawing.SolidBrush("#FFFFC0CB");
this.diagram1.LinkBaseShape = MindFusion.Diagramming.ArrowHead.Triangle;
this.diagram1.LinkHeadShape = MindFusion.Diagramming.ArrowHead.Triangle;
this.diagram1.DefaultShape = Shapes.Actor;

Bezier Links

The LinkStyle property is set to Polyline by default. You can change it to Bezier in order to draw Bezier links.

  • Set the LinkStyle property to Bezier.
  • Type in 'Bezier' in the LinkText property field.
  • Set the LinkTextStyle property to OverLongestSegment.

C#

this.diagram1.LinkStyle = MindFusion.Diagramming.LinkStyle.Bezier;
this.diagram1.LinkText = "Bezier";
this.diagram1.LinkTextStyle = MindFusion.Diagramming.LinkTextStyle.OverLongestSegment;

  • Set the RoundedLinks property to true.

C#

this.diagram1.RoundedLinks = true;

  • Draw two nodes and a link. The link appears as a straight line at first.

  • Click the left mouse button on the link to make the selection handles visible. Click on every selection handle, and move the mouse as desired. The straight line changes to a Bezier curve. You can adjust the curve by clicking the selection points and moving the mouse.

  • To draw links without a base shape, set LinkBaseShape to None in the Properties pane.

Cascading Links

You can change the LinkStyle property to Cascading in order to draw cascading links.

  • Set the LinkStyle property to Cascading. Type in 'Cascading' in the LinkText property field.
  • Use the LinkCascadeOrientation property to specify the orientation of the first segment of the cascading link. By default, LinkCascadeOrientation is set to Auto. In this case, choose Vertical.

C#

this.diagram1.LinkCascadeOrientation = MindFusion.Diagramming.Orientation.Vertical;
this.diagram1.LinkStyle = MindFusion.Diagramming.LinkStyle.Cascading;

  • Set the AllowSplitLinks property to true. This way, you can add or remove link segments interactively.

To insert a new link segment, click and drag point from the middle of the vertical link's segment.

Change the LinkTextStyle

  • In the Properties window, choose the LinkTextStyle property value from: Center, Rotate, OverLongestSegment, and Follow.
  • Set the BackBrush property of the Diagram class to a DarkSea solid color. Set ShapeBrush and LinkBrush to Yellow, ActiveItemHandlesColor to Red.

C#

this.diagram1.BackBrush = new MindFusion.Drawing.SolidBrush("#FF8FBC8B");
this.diagram1.ShapeBrush = new MindFusion.Drawing.SolidBrush("#FFFFFF00");
this.diagram1.LinkBrush = new MindFusion.Drawing.SolidBrush("#FFFFFF00");
this.diagram1.ActiveItemHandlesColor = System.Drawing.Color.Red;

  • Change the DefaultShape to Rectangle.

C#

this.diagram1.DefaultShape = Shapes.Rectangle;

  • Set LinkTextStyle to Center. Fill in '3' in the LinkSegments property field.

The link above consists of three segments, the description text of the link is placed over the middle segment horizontally.

Move one selection handle upwards. The link text is positioned across the central link segment as shown in the picture below:

  • Set LinkTextStyle to Rotate.

The description text of the link is rotated and appears over the longest link segment.

Move one of the selection handles to make the left segment the longest one. The link text is placed now over the left segment as it is the longest segment.

C#

this.diagram1.LinkSegments = ((short)(3));
this.diagram1.LinkText = "This link text description is rotated ";
this.diagram1.LinkTextStyle = MindFusion.Diagramming.LinkTextStyle.Rotate;

  • Set LinkTextStyle to OverLongestSegment.

The link is defined to consist of 3 segments, and the LinkTextStyle property is defined to place the description text over the longest segment.

  • Set LinkTextStyle to Follow and LinkStyle to Polyline.

The link label text follows the line of the link.

C#

this.diagram1.LinkTextStyle = MindFusion.Diagramming.LinkTextStyle.Follow;
this.diagram1.LinkSegments = ((short)(3));
this.diagram1.LinkText = "This LinkTextStyle is set to Follow ";

In both pictures below, the link is of Polyline style and is composed of 3 segments:

  • Set LinkStyle to Bezier, LinkSegments to 2.

In both pictures above, the description text of the link follows the bezier curve of the link.

See also tutorial about
 In-place text editing of diagram links
Dynamic links
Link routing


Tutorial 3: Dynamic Links

Start from the 'Create a Diagram and a DiagramView' tutorial.

If DynamicLinks is enabled, links will update their end points positions while moving the source or target node, adjusting it in a way that makes the end segment point to the center of the respective node. The end segments of dynamic links keep pointing to the centers of connected nodes.

C#

this.diagram1.DynamicLinks = true;

  • Draw a diagram as shown below:

A dynamic polyline link is drawn before moving the selected node.

  • Move the selected node upward:

The link end point is moving along the node border, and the segment keeps pointing to the center of the node.


Tutorial 4: Link routing

MindFusion.Diagramming provides automatic link routing. This feature allows links to avoid nodes considered as obstacles whereby the shortest path between source and target is found, and the link doesn't cross any other nodes.

Start from the 'Create a Diagram and a DiagramView' tutorial.

1. Set the following properties:

  • Set the Behavior property of DiagramView to LinkShapes.
  • Set SmoothingMode to HighQuality.
  • Set LinkHeadShape to PointerArrow.
  • Set LinkBrush to Brown, LinkStyle to Polyline.
  • Set LinkSegments to 1, ShapeBrush to Violet.

2. Set RouteLinks to true.

3. Execute the application. The DiagramView canvas area appears. Draw three nodes and a link as shown in the picture below.

The link doesn't cross the node located between the source and the target node. The link finds automatically the shortest path between the nodes.

4. Draw another node over the third selection handle point of the link.

The link is moved automatically because it should not cross a node:

RoutingOptions properties

The RoutingOptions properties of the Diagram class allow tuning the link routing algorithm.

In the Properties pane, click the plus sign on the left of the property to expand the options.
The following routing options are provided: Anchoring, CrossingCost, DontOptimizeLongRoutes, EndOrientation, GridSize, LengthCost, NodeVicinityCost, NodeVicinitySize, RouteHeuristics, SmartPolylineEnds, StartOrientation, TriggerRerouting, TurnCost.

Note

The size-related members of RoutingOptions are based on the MeasureUnit setting. Default value of MeasureUnit is Millimeter.

Read more about the properties of the RoutingOptions class.

For the purposes of this tutorial set these properties to the values specified in the following table:

Property | Value
Anchoring | Reassign
CrossingCost | 10
GridSize | (default)
LengthCost | 10
NodeVicinityCost | 20
TurnCost | 20

Set LinkStyle to Cascading, RouteLinks to true, LinkSegments to 3 and LinksSnapToBorders to true.

Execute the application and draw a diagram as shown below.

Draw a routing chart

We want to draw the following chart:

1. Set the following properties in the Properties window:

Property name | Property value
Behavior | LinkShapes
LinksSnapToBorders | true
LinkStyle | Polyline
LinkSegments | 1
SnapToAnchor | OnCreateOrModify

2. Set DefaultShape of the Diagram object to Rectangle:

C#

this.diagram1.DefaultShape = Shapes.Rectangle;

3. Additionally, set DynamicLinks to true, InplaceEditAcceptOnEnter to true and SmoothingMode to HighQuality.

4. Execute the application. Draw the nodes Nr. 1, 2, 3, 4, 5, and two nodes without number as obstacles:

5. Draw the following links: from 1 to 2, from 2 to 3, from 3 to 4, from 4 to 5, and from 5 to 1. The links do not cross the nodes located between the source and the target node.

6. Select the obstacle node as shown in the picture:

7. Change routing of links by moving a node. Click the left mouse button on the cross and move the node rightwards. The routing of the link from node 4 to node 5 is changed automatically.


Tutorial 5: Text in-place editing of diagram links

  • Start from the 'Create a Diagram and a DiagramView' tutorial.
  • Set AllowInplaceEdit to True.
  • Double-click the text of the DiagramLink object, and edit the text. An editing box appears where you can enter or edit a text.

  • Click in the Form area outside the in-place edit area to accept the text changes.

See also tutorial about
 Inserting text in nodes
Text in-place editing of container nodes
Dynamic links
Link routing


Using TableNode objects

© 2009 MindFusion


Tutorial 1: Using TableNodes

1. Start from the 'Create a Diagram and a DiagramView' tutorial.

2. Set the DiagramView Behavior property to LinkTables.

C#

this.diagramView.Behavior = MindFusion.Diagramming.Behavior.LinkTables;

The LinkTables behavior value allows creating entity-relationship diagrams. Drawing over an empty document area creates a TableNode instance. Drawing started over a node creates a DiagramLink.

Make sure the Form.cs contains the following code lines:

C#

using MindFusion.Diagramming;
using MindFusion.Diagramming.WinForms;
using MindFusion.Drawing;

3. Run the test application.

Click on the [image] icon to execute the program. The form appears. Now, you can draw tables and links in the diagram view area.

4. Draw tables in the Windows Form

  • To draw the first table, click the left mouse button on the canvas area, drag the mouse and release the mouse to finish drawing the table.
  • Draw the second table.
  • Draw a relation (link) between two tables.

5. Set TableNode properties

The following table lists the default property values for newly created tables:

Property name | Default value
TableRowCount | 4
TableColumnCount | 2
LinkSegments | 1
LinkStyle | Polyline

You can set the following Diagram Properties for drawing tables: TableStyle, TableBrush, TablePen, TableCaption, TableCaptionHeight, TableColumnCount, TableRowCount, TableRowHeight, TablesScrollable, TableConnectionStyle, TableHandlesStyle (accessible in the Properties pane too). Tables can also display a background image for the whole table or for the individual cells.

Cells, columns and rows can be customized in various ways - there are properties available for setting their extents, style, image, and text alignment. The structure of a table can be dynamically changed by adding and deleting rows and columns. This can be done with the AddColumn and AddRow methods as well with the InsertColumn, InsertRow and RedimTable methods. DeleteRow and DeleteColumn methods delete existing rows / columns.

6. Resizing and moving of TableNode objects

To move a table, click the table to select it. A cross cursor appears when the mouse is over the table title bar, click and move the table as desired.

To resize a table, click the table to select it, and drag a table corner to change the table size as desired.

The ResizeToFitText method resizes all columns and rows so that each table cell fits its text on a single line without clipping it. ResizeToFitImage makes a table exactly the same size as the image it contains.


Tutorial 2: Create a database design tool

This tutorial follows the DBDesign sample application, which shows how to create tables and table cells programmatically in response to menu commands.

Create a menu with main menu items File, Table, Exit for drawing tables at runtime.

Start from the 'Create a Diagram and a DiagramView' tutorial.

  • Add menu items to the Windows Form

In the Toolbox, double-click the MenuStrip component, a menu is added to the form.

Add the menu items File, Table, Exit. Type in the names of the menu items in the fields where the text 'Type Here' is displayed in gray color.

To the File menu, add the following menu items: New, Load, Save.

To the Table menu, add the following menu items: Create table, Rename table, Delete table.

In the Properties window, ensure that the Menu property is set to the menu you have just created (mainMenu1 in Visual C#, unless you have given it a unique name).

  • Add functionality to the 'File' menu items

2.1. File > New menu item

In the miNew_Click event handler, add the code that should be executed in response to a click of the File > New menu item. The diagram.ClearAll method is called to remove all items from the diagram. The private generateSQL method is executed to refresh the SQL definition.

C#

private void miNew_Click(object sender, EventArgs e)
{
diagram.ClearAll();
generateSQL();
}

2.2. File > Load menu item

In the miLoad_Click event handler, add the code that should be executed in response to a click of the File > Load menu item. The ShowDialog method shows the OpenFileDialog, the LoadFromFile method loads the file with the specified FileName.
The private generateSQL method is executed to refresh the SQL definition.

C#

private void miLoad_Click(object sender, EventArgs e)
{
if (openDlg.ShowDialog(this) == DialogResult.OK)
{
try
{
diagram.LoadFromFile(openDlg.FileName);
generateSQL();
}
catch (Exception ex)
{
MessageBox.Show(ex.Message);
}
}
}

2.3. File > Save menu item

In the miSave_Click event handler, add the code that should be executed in response to a click of the File > Save menu item. The ShowDialog method shows the SaveFileDialog box, the SaveToFile method is called to save the file with the specified FileName.

C#

private void miSave_Click(object sender, EventArgs e)
{
if (saveDlg.ShowDialog(this) == DialogResult.OK)
diagram.SaveToFile(saveDlg.FileName, true);
}

2.4. File > Import schema menu item

In the miImport_Click event handler, add the code that should be executed in response to a click of the 'File' > 'Import schema' menu item. The ShowDialog method shows a new Windows Form called 'ConnectForm' to enter the connection string that includes the data source name, and other parameters needed to establish the initial connection to a database.

C#

private void miImport_Click(object sender, EventArgs e)
{
ConnectForm cf = new ConnectForm();
cf.tbConnect.Text =
"Provider=SQLOLEDB;Data Source=SHTAIGATA\\VSDOTNET;Initial Catalog=Media;Integrated Security=SSPI;";

if (cf.ShowDialog() != DialogResult.OK)
return;

try
{
OleDbConnection cn = new OleDbConnection();
DataTable schemaTable;

// connect using specified connection string
cn.ConnectionString = cf.tbConnect.Text;
cn.Open();

...

An OleDbConnection object is initialized. The ConnectionString property of the OleDbConnection object is used to to open a data source. The Open method is called to open a connection to a data source.
The Schema information about tables is retrieved. The GetOleDbSchemaTable method returns schema information from the data source as indicated.

  • Add functionality to the 'Table' menu items

3.1. 'Table' > 'Create table' menu item

Click the Table -> Create table menu item.
Enter 'miCreate' in the MenuItem Name field in the Properties pane on the right. Click the Events icon. In the Click field type in 'miCreate_Click', press ENTER.

The following code is generated automatically:

C#(DBDesignForm.cs)

// miCreate
//
this.miCreate.Index = 0;
this.miCreate.Text = "Create table";
this.miCreate.Click += new System.EventHandler(this.miCreate_Click);

In the miCreate_Click event handler body, add the code that should be executed in response to a click of the 'Create table' menu item. Use the CreateTableNode method to create a new TableNode instance.

C#(DBDesignForm.cs)

private void miCreate_Click(object sender, EventArgs e)
{
// create a new table with the specified extent
TableNode tbl = diagram.Factory.CreateTableNode(
15 + tableCount * 3, 15 + tableCount * 4, 50, 60);
tbl.Caption = "Table" + tableCount;

// the first column will be resized together with the table
tbl.Columns[0].ColumnStyle = ColumnStyle.AutoWidth;

generateSQL();
tableCount++;
}

The private 'generateSQL' method defined in DBDesignForm.cs. It enumerates all tables in the current diagram, enumerates all rows of a table, and gets the text of the cells in the current row.

C#

private void generateSQL()
{
text.Text = "";

// enumerate all tables in the current diagram
foreach (TableNode table in diagram.Nodes)
{
text.Text += "CREATE TABLE " + table.Caption + "\r\n(";

// enumerate all rows of a table
for (int r = 0; r < table.RowCount; ++r)
{
// get text of cells in current row
text.Text += "\t" + table[0, r].Text + " " + table[1, r].Text;
if (r < table.RowCount - 1)
text.Text += ",\r\n";
}
text.Text += "\r\n);\r\n\r\n";
}
}

Moving and resizing the table

Point the mouse over the table title bar, a cross cursor appears, press the mouse button down and you can move the table in the canvas area as desired.

Move the mouse over a table border line (top, bottom, left, right), a double-headed arrow appears. You can resize the table by dragging the border into the desired direction.

3.2. 'Table' > 'Rename table' menu item

In the miRename_Click event handler, add the code that should be executed in response to a click of the 'Rename table' menu item. If the selected object is a table, the private renameTable method is called. The renameTable method initializes a RenameForm, shows this RenameForm by performing the ShowDialog method, and assigns a new table name to the table.Caption.
See below the code of the private renameTable method. This method is called from the context menu too.

C#

private void miRename_Click(object sender, EventArgs e)
{
if (diagram.ActiveItem == null)
return;

// check if the selected object is a table
TableNode table = diagram.ActiveItem as TableNode;
if (table != null)
renameTable(table);
}

3.3. 'Table' > 'Delete table' menu item

In the miDelete_Click event handler, add the code that should be executed in response to a click of the 'Delete table' menu item. If the selected object is a table, the Diagram.Nodes.Remove method is called, and then generateSQL is executed.

C#

private void miDelete_Click(object sender, EventArgs e)
{
if (diagram.ActiveItem == null)
return;

// check if the selected object is a table
TableNode table = diagram.ActiveItem as TableNode;
if (table != null)
{
diagram.Nodes.Remove(table);
generateSQL();
}
}

  • Add a context menu to the Windows Form

Add a context menu to the Windows Form at design time by double-clicking the ContextMenu component.

Associate the context menu with the form. Add the Add row and Rename table menu items.

C#

#region Windows Form Designer generated code

this.cmTable = new System.Windows.Forms.ContextMenu();
...

// cmTable
//
this.cmTable.MenuItems.AddRange(new System.Windows.Forms.MenuItem[] {
this.miTableRename,
this.miTableAddRow});

4.1. Define the 'Add row' menu item from the context menu

Place the mouse pointer inside the table node area, and click the right mouse button. A context menu appears, select the Add row item.

Create a new form with the following layout. Name the form AddRowForm.

Add functionality to the 'Add row' menu item.

In the miTableAddRow_Click event handler, add the code that should be executed in response to a click of the 'Add row' menu item. The addRow method is called.

C#

private void miTableAddRow_Click(object sender, EventArgs e)
{
addRow(tblClicked);
}

The addRow method performs the following:
The ShowDialog method shows the AddRowForm. The table row is added by using the AddRow method.

C#

private void addRow(TableNode table)
{
AddRowForm form = new AddRowForm();

if (form.ShowDialog(this) == DialogResult.OK)
{
// this adds a row and returns the index of the new row
int lastRow = table.AddRow();

// use the cell indexer to access cells by their column and row
table[0, lastRow].Text = form.fieldName.Text;
table[1, lastRow].Text = form.fieldType.Text;

// refresh SQL definition
generateSQL();
}
}

4.2. Define the 'Rename table' menu item from the context menu

Create a new form with the following layout. Name the form RenameForm.

Add functionality to the 'Rename table' menu item.

In the miTableRename_Click event handler, add the code that should be executed in response to a click of the 'Rename table' menu item. The renameTable method is called.

C#

private void miTableRename_Click(object sender, EventArgs e)
{
renameTable(tblClicked);
}

The renameTable method performs the following:
The ShowDialog method shows the RenameForm. The table is renamed by assigning the entered table name text to the table.Caption.

C#

private void renameTable(TableNode table)
{
RenameForm form = new RenameForm();

if (form.ShowDialog(this) == DialogResult.OK)
{
table.Caption = form.tblName.Text;
generateSQL();
}
}

  • Creating a context menu for editing a table row

  • Creating a context menu for editing a table row

  • Creating a context menu for editing a table row

  • Creating a context menu for editing a table row

Add a 'cmRow' context menu for editing of table rows.

C#

private ContextMenu cmRow;

Associate it with the form. Add the 'Rename table', 'Add row', 'Edit row', and 'Delete row' menu items.

C#

#region Windows Form Designer generated code

this.cmRow = new System.Windows.Forms.ContextMenu();

// cmRow
//
this.cmRow.MenuItems.AddRange(new System.Windows.Forms.MenuItem[] {
this.miRowRenameTable,
this.miRowAdd,
this.miRowEdit,
this.miRowDelete});

If you click a row, this context menu appears:

5.1. Create EditRowForm

Create a new form with the following layout. Name the form EditRowForm.

5.2. Add functionality to the 'Edit row' menu item.

The private 'editRow' method gets the text of cells on this row, shows this EditRowForm by using the ShowDialog method, and sets the text of cells on this row. The 'generateSQL' method is performed at the end.

C#

private void editRow(TableNode table, int row)
{
EditRowForm form = new EditRowForm();

// get the text of cells on this row
form.fieldName.Text = table[0, row].Text;
form.fieldType.Text = table[1, row].Text;

if (form.ShowDialog(this) == DialogResult.OK)
{
// set the text of cells on this row
table[0, row].Text = form.fieldName.Text;
table[1, row].Text = form.fieldType.Text;

// refresh SQL definition
generateSQL();
}
}

6. Try to create your own database schema: create tables, add fields to them, set the field names and types and so on. Here is a sample database schema:


Tutorial 3: Collapsible table sections

Start from the 'Create a Diagram and a DiagramView' tutorial.

Each table row can be designated as a section header. Each header row defines a table section that includes the non-header rows beneath it. Such sections can be collapsed to hide the rows that they contain, and expanded back. If a row section is expanded, its header-row and non-header rows are visible. If the section is collapsed, only the header row is visible. Changing the section visibility state is performed by pressing the plus/minus button on the left of the header rows.

Example:

Define two header rows in a table as shown below (both header rows are initially expanded):

By pressing the minus button on the left of the 'Account data' header row, the 'Account data' section rows will be hidden. Only the header row 'Account data' is displayed whereby a plus sign is displayed instead of the minus sign next to the header row of the table section.

C#

private void diagram1_NodeCreated(object sender, NodeEventArgs e)
{
TableNode table = e.Node as TableNode;

table.Caption = "Bank accounts";
table.OffsetHeaderRows = true;

// Sets the number of columns and rows
table.RedimTable(1, 5);

// To span 1 column
table[0, 0].ColumnSpan = 1;

// Header text
table[0, 0].Text = "Client data";

// The first row is a section header
table.Rows[0].Header = true;
table[0, 1].Text = "Client number";
table[0, 2].ColumnSpan = 2;
table[0, 2].Text = "Account data";

// The third row is a section header
table.Rows[2].Header = true;
table[0, 3].Text = "IBAN";
table[0, 4].Text = "Maturity";
}

Perform the following steps to customize header rows as shown in the pictures above:

1. Set Behavior to LinkTables or DrawTables:

C#

this.diagramView1.Behavior = MindFusion.Diagramming.Behavior.LinkTables;

2. Set TableStyle to RoundedRectangle:

C#

this.diagram1.TableStyle = MindFusion.Diagramming.TableStyle.RoundedRectangle;

3. Set TablesScrollable to true.

C#

this.diagram1.TablesScrollable = true;

4. In the diagram_NodeCreated event, define the table as TableNode:

C#

TableNode table = e.Node as TableNode;

5. Set the number of columns and rows through the RedimTable method to 1 and 5 respectively.

C#

table.RedimTable (1, 5);

6. Set the OffsetHeaderRows property table to true to define the offset for the +/- buttons.

C#

table.OffsetHeaderRows = true;

7. Set the table Caption as desired, for example to "Bank accounts".

C#

table.Caption = "Bank accounts";

8. Set ColumnSpan to span 1 column within the first row section:

C#

table[0, 0].ColumnSpan = 1;

9. Define the first row text:

C#

table[0, 0].Text = "Client data";

10. Specify the first row as a Header:

C#

table.Rows[0].Header = true;

11. Specify the second header row (span 2 rows, define rows texts, third row is a header):

C#

table[0, 2].RowSpan = 2;
table[0, 2].Text = "Account data";

// The third row is a section header
table.Rows[2].Header = true;
table[0, 3].Text = "IBAN";
table[0, 4].Text = "Maturity";

12. Run the table application. Draw a table on the Windows Form. It appears as specified.


Tutorial 4: Create spanning cells

Start from the 'Create a Diagram and a DiagramView' tutorial.

Table cells can span several rows and columns as defined by the RowSpan and ColumnSpan properties. Every spanning cell can display text and/or image, which will fill the entire spanned area. Spanning cells in tables can be used when you need a larger cell to display an image or some text description.

  • Set Behavior to LinkTables or DrawTables.

C#

this.diagramView1.Behavior = MindFusion.Diagramming.Behavior.LinkTables;

  • In the diagram_NodeCreated event, define the table attributes:

C#

private void diagram_NodeCreated(object sender, NodeEventArgs e)
{
TableNode table = e.Node as TableNode;
table.RedimTable(1, 5);
table.Caption = "Spanning cells";
table[0, 0].ColumnSpan = 1;
table[0, 0].RowSpan = 4;
}

  • Set the number of columns and rows through the RedimTable method to 1 and 5 respectively.

C#

table.RedimTable(1, 5);

  • Span 1 columns and 4 rows from the first cell.

C#

table[0, 0].ColumnSpan = 1;
table[0, 0].RowSpan = 4;

  • Define the image alignment in a specified table cell by ImageAlign property.

C#

table[0, 0].ImageAlign = ImageAlign.Center;

  • Set TableConnectionStyle to Table .

C#

this.diagram1.TableConnectionStyle = MindFusion.Diagramming.TableConnectionStyle.Table;

Increase the TableCaptionHeight and the TableColumnWidth of the table.

  • Set TableConnectionStyle to Table.

C#

this.diagram1.TableCaptionHeight = 8F;
this.diagram1.TableColumnWidth = 40F;

  • Instead of increasing the TableColumnWidth, set ColumnStyle of the first column to AutoWidth.

C#

// set the first column to resize with the table
table.Columns[0].ColumnStyle = ColumnStyle.AutoWidth;

Note

Add the following using statement:

using ColumnStyle = MindFusion.Diagramming.ColumnStyle;

  • To open the OpenFileDialog box in responce to a right-click event, select an image and place it in the TableNode spanned cell, write the following code:

C#

private void diagram_CellClicked(object sender, CellEventArgs e)
{
TableNode table = e.Table;
if (table != null)
{
if (e.MouseButton == MouseButton.Right)
{
// Pick image
OpenFileDialog dlg = new OpenFileDialog();

dlg.Filter = "Images|*.jpg; *.bmp; *.png; *.gif|All files|*.*";
dlg.Title = "Select image";

if (dlg.ShowDialog(this) == DialogResult.OK)
{
Image image;
try
{
image = Image.FromFile(dlg.FileName);
}
catch
{
MessageBox.Show("Failed to load image.");
return;
}
e.Table[0, 0].Image = image;
e.Table[0, 0].ImageAlign = ImageAlign.Stretch;
}
}
}
}

  • Execute the application. Draw a table in the Windows Form. Right-click the table cells area, the ShowDialog method displays the OpenFileDialog box. Select the desired image to show it in the spanned cell of the TableNode object.

  • To enter text in a cell, double-click the left mouse button within the cell, and type in the text.

If ColumnStyle is set to AutoWidth, the user can resize the spanned cell as desired:


Tutorial 5: Creating TableNode objects programmatically

Start from the 'Create a Diagram and a DiagramView' tutorial.

Create a new TableNode in responce to click events

Make sure your source code file contains the following lines of code:

C#

using MindFusion.Diagramming;
using MindFusion.Diagramming.WinForms;
using MindFusion.Drawing;

1. Call the CreateTableNode method through the Factory property of the Diagram class. To create a rectangle TableNode object, write the code:

C#

private void diagram_Clicked(object sender, DiagramEventArgs e)
{
TableNode t = diagram.Factory.CreateTableNode(e.MousePosition, new SizeF(45, 40));
}

Specify the size parameters as desired.

2. Set the Behavior property of the DiagramView class to LinkTables or DrawTables in the Properties window. In the TableNodes namespace, the respective C# code is created automatically:

C#

this.diagramView1.Behavior = MindFusion.Diagramming.Behavior.LinkTables;

Run the application. Click in the Form area to create a TableNode object. The table node is drawn as shown below:

Add a Create table menu

Add a main menu 'Create table' for drawing tables at runtime.

1. In the Toolbox, double-click the MenuStrip component, a menu is added to the form.

2. Add the Create table menu item. Type in the names of the menu items in the fields where the text 'Type Here' is displayed in grey.

3. Add the menu items: HeaderRows and Spanned table. If HeaderRows is clicked, a TableNode object that has a header row is created. If Spanned table is selected, a TableNode object that has spanning cells is created.

4. In the Properties window, ensure that the MainMenuStrip property of the Form is set to the menu you have just created (menuStrip1 in Visual C#, unless you have given it a different name).

Create a TableNode object with HeaderRows

1. Add functionality to the HeaderRows menu item by using the Click event. In the Visual Studio Form Designer, click the Create table -> HeaderRows menu item; click the Events icon in the Properties window.

In the Click field, type in 'header_table', and press ENTER. The following code is generated in the Form1.Designer.cs:

C#

// headerRowsToolStripMenuItem
//
this.headerRowsToolStripMenuItem.Name = "headerRowsToolStripMenuItem";
this.headerRowsToolStripMenuItem.Size = new System.Drawing.Size(171, 22);
this.headerRowsToolStripMenuItem.Text = "HeaderRows";
this.headerRowsToolStripMenuItem.Click += new System.EventHandler(this.header_table);

In the Form1.cs, the Click event handler code is generated for the HeaderRows menu item:

C#

private void header_table(object sender, EventArgs e)
{
}

2. In the event handler body, add the code that should be executed in response to a click of the HeaderRows menu item.

C#

private void header_table(object sender, EventArgs e)
{
TableNode t = diagram1.Factory.CreateTableNode(10, 10, 45, 40);
t.Caption = "Clients";

// Sets the number of columns and rows
t.RedimTable(2, 5);
t.OffsetHeaderRows = true;

// The first row is a section header
t.Rows[0].Header = true;

// Header text
t[0, 0].Text = "Client data";
t[0, 1].Text = "Client number";
t[0, 2].Text = "Forename";
t[0, 3].Text = "Surname";
t[0, 4].Text = "Address";
}

3. Specify a Text property value for the table cells.

C#

t[0, 0].Text = "Client data";
t[0, 1].Text = "Client number";
t[0, 2].Text = "Forename";

4. Define a Caption of the new TableNode object.

C#

t.Caption = "Clients"

5. Set the Scrollable property to true.

C#

t.Scrollable = true;

6. Specify the first row as a Header.

C#

t.Rows[0].Header = true;

7. Set the OffsetHeaderRows property table to true to define the offset for the +/- buttons.

C#

t.OffsetHeaderRows = true;

8. Run the application. Select the HeaderRows menu item. A new TableNode object is drawn where the first row is a header row as shown below:

The header row is expanded in the picture above. Click the minus sign on the left of the 'Client data' header row. The header row will be collapsed, and only the header row is visible. See the next picture:

Create a TableNode object with spanning cells

1. In the Visual Studio Form Designer, select the Create table -> Spanned table menu item; click the Events icon in the Properties window. In the Click field, type in 'spanned_table', and press ENTER. The following code is generated:

C#

// spannedTableToolStripMenuItem
//
this.spannedTableToolStripMenuItem.Name = "spannedTableToolStripMenuItem";
this.spannedTableToolStripMenuItem.Size = new System.Drawing.Size(171, 22);
this.spannedTableToolStripMenuItem.Text = "Spanned table";
this.spannedTableToolStripMenuItem.Click += new System.EventHandler(this.spanned_table);

In the Form1.cs, in the TableNodes namespace, the Click event code is generated for the Spanned table menu item:

C#

private void spanned_table(object sender, EventArgs e)
{
}

2. In the event handler, add the code that should be executed in response to a click of the Spanned table menu item.

C#

private void spanned_table(object sender, EventArgs e)
{
TableNode t = diagram1.Factory.CreateTableNode(10, 10, 45, 40);
t.Caption = "Name";
t.Scrollable = true;

// Sets the number of columns and rows
t.RedimTable(2, 5);

// Span 1 column and 4 rows from the first cell
t[0, 0].ColumnSpan = 1;
t[0, 0].RowSpan = 4;
}

3. Span 1 column and 4 rows from the first cell by using the ColumnSpan and RowSpan properties.

C#

table[0, 0].ColumnSpan = 1;
table[0, 0].RowSpan = 4;

4. Run the application. Select the Spanned table menu item. A new TableNode object is drawn where a spanning cell is displayed as shown below:

5. Specify a Text to be displayed in the spanning cell.

C#

t[0, 0].Text = "Photo";
t[0, 0].TextColor = Color.Red;

6. Place an image in the spanning cell by using the Image property.

C#

t[0, 0].Image = Image.FromFile("rose.jpg");

Save the chosen image file in the bin\debug solution folder, otherwise specify the path to the image file.

7. Run the application. Select the Spanned table menu item. A new TableNode object is drawn where an image is displayed in the spanning table cell as shown below:

8. Specify the ImageAlign property, for example choose Stretch.

C#

t[0, 0].ImageAlign = ImageAlign.Stretch;


Using ControlNode objects

The ControlNode class lets you host Windows Forms controls inside your diagrams.

1. Start from the 'Create a Diagram and a DiagramView' tutorial.

2. Set the Behavior property to DrawControls.

To draw control nodes, set the Behavior property of the DiagramView class to DrawControls or LinkControls, then users are allowed to draw control host nodes interactively.

3. Run the ControlNodes application.

Click on the [image] icon to execute the program. The Form area appears. The diagram application is generated automatically from Microsoft Visual Studio. Now, you can draw control nodes in the Windows Form.

The following code is automatically generated by the Visual Studio designer:

C#

#region Windows Form Designer generated code
/// <summary>
/// Required method for Designer support - do not modify
/// the contents of this method with the code editor.
/// </summary>
private void InitializeComponent()
{
System.ComponentModel.ComponentResourceManager resources = new System.ComponentModel.ComponentResourceManager(typeof(Form1));
this.diagram1 = new MindFusion.Diagramming.Diagram();
this.diagramView1 = new MindFusion.Diagramming.WinForms.DiagramView();
this.SuspendLayout();
//
// diagram1
//
this.diagram1.BackgroundImageAlign = MindFusion.Drawing.ImageAlign.TopLeft;
this.diagram1.Bounds = ((System.Drawing.RectangleF)(resources.GetObject("diagram1.Bounds")));
this.diagram1.ContainerMargin = 10F;
this.diagram1.ContainerMinimumSize = new System.Drawing.SizeF(50F, 40F);
this.diagram1.Font = new System.Drawing.Font("Microsoft Sans Serif", 2.9F, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.World);
this.diagram1.Interaction = null;
//
// diagramView1
//
this.diagramView1.Behavior = MindFusion.Diagramming.Behavior.DrawControls;
this.diagramView1.ControlHandlesStyle = MindFusion.Diagramming.HandlesStyle.HatchHandles;
this.diagramView1.ControlMouseAction = MindFusion.Diagramming.ControlMouseAction.SelectNode;
this.diagramView1.InplaceEditFont = new System.Drawing.Font("Microsoft Sans Serif", 8.25F, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, ((byte)(0)));
this.diagramView1.Location = new System.Drawing.Point(12, -2);
this.diagramView1.MiddleButtonActions = MindFusion.Diagramming.MouseButtonActions.None;
this.diagramView1.ModificationStart = MindFusion.Diagramming.ModificationStart.SelectedOnly;
this.diagramView1.Name = "diagramView1";
this.diagramView1.PrintOptions.RenderTarget = MindFusion.Diagramming.RenderTarget.Printer;
this.diagramView1.PrintOptions.TargetView = null;
this.diagramView1.RightButtonActions = MindFusion.Diagramming.MouseButtonActions.Cancel;
this.diagramView1.Size = new System.Drawing.Size(256, 256);
this.diagramView1.TabIndex = 0;
this.diagramView1.Text = "diagramView1";
//
// Form1
//
this.AutoScaleDimensions = new System.Drawing.SizeF(6F, 13F);
this.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font;
this.ClientSize = new System.Drawing.Size(472, 339);
this.Controls.Add(this.diagramView1);
this.Name = "Form1";
this.Text = "Form1";
this.Load += new System.EventHandler(this.Form1_Load);
this.ResumeLayout(false);
}

#endregion

4. Draw control host nodes in the Form area. By default, MindFusion.Diagramming creates Button controls.

5. Set the ControlHandlesStyle property.

The style of the selection handles of the control host nodes can be set via the ControlHandlesStyle property that can be set to one of the following values: Invisible, SquareHandles, DashFrame, HatchFrame, HatchHandles, HatchHandles2, HatchHandles3, MoveOnly, EasyMove, SquareHandles2, Custom, or InvisibleMove.

6. Deleting of control host nodes.

Select a control host item by clicking it. Press the DEL key.


Tutorial 1: Setting the type of hosted controls

Start from the 'Create a Diagram and a DiagramView' tutorial.

The type of controls to be created in the host nodes is specified via the DefaultControlType property of the DiagramView class.

1. To place a .NET Button control in newly created ControlNode objects, use the following code:

C#

this.diagramView1.DefaultControlType = typeof(System.Windows.Forms.Button);

2. Initialize the values of the hosted control in response to the NodeCreated event. Set text and color for the Button control as desired.

C#

private void diagram_NodeCreated(object sender, NodeEventArgs e)
{
ControlNode controlNode = e.Node as ControlNode;
if (e.Node is ControlNode)
{
Type type = controlNode.Control.GetType();
if (type == typeof(Button))
{
Button btn = (Button)controlNode.Control;
btn.Text = "Button";
btn.ForeColor = Color.Blue;
btn.BackColor = Color.LavenderBlush;
}
}
}

Run the application. Draw a control node on the form.

3. To place a .NET DataGrid control in newly created ControlNode objects, use the following code:

C#

this.diagramView1.DefaultControlType = typeof(System.Windows.Forms.DataGrid);

Execute the application. Draw nodes and links. A data grid is created in each ControlNode automatically.

4. To place a .NET MonthCalendar control in newly created ControlNode objects, use the following code:

// C#

this.diagramView1.DefaultControlType = typeof(MonthCalendar);

Execute the code. A control host form appears where a MonthCalendar control is hosted:


Tutorial 2: Linking ControlNode objects

Start from the 'Create a Diagram and a DiagramView' tutorial.

1. Set the Behavior property.

Select LinkControls for the Behavior property in the Properties pane. This value of the Behavior property allows connecting the nodes with links. The following code in C# is generated in the Form1.cs automatically from the Microsoft Visual Studio:

C#:

this.diagramView1.Behavior = MindFusion.Diagramming.WinForms.Behavior.LinkControls;

2. Set ControlMouseAction to SelectNode. Execute the program and draw the control host nodes as in the picture:

To draw the link between the nodes, point the mouse cursor near the border of the source node, and move the mouse to the target node.

3. Set the ControlMouseAction to IgnoreControl. Now drawing of links is possible from anywhere within the control.

The following code is generated in the Form1.Designer.cs:

C#

this.diagramView1.ControlMouseAction = MindFusion.Diagramming.ControlMouseAction.IgnoreControl;

4. Execute the application. Draw nodes and links as shown below:


Tutorial 3: Drawing expandable ControlNodes

Start from the 'Create a Diagram and a DiagramView' tutorial.

1. Set NodesExpandable to true.

2. Set ControlMouseAction to IgnoreControl.

3. Set Behavior to LinkControls.

Note

IgnoreControl works only with controls which do not capture the mouse.

4. Execute the application. Draw nodes and links as shown below:

5. Click the [-] button of the root node and the child nodes will hide.


Tutorial 4: Creating ControlNode objects programmatically

Make sure your source code file contains the following lines of code:

C#

using MindFusion.Diagramming;
using MindFusion.Diagramming.WinForms;
using MindFusion.Drawing;

1. Start from the 'Create a Diagram and a DiagramView' tutorial. Create a new project called ControlNodes.

2. To draw Control nodes, set the Behavior property of the DiagramView class to DrawControls or LinkControls.
C#

this.diagramView1.Behavior = MindFusion.Diagramming.Behavior.DrawControls;

3. Add two ControlNode instances to the diagram. Add the following source code in Form.cs:

C#

private void Form1_Load(object sender, EventArgs e)
{
this.diagramView1.SuspendLayout();
for (int i = 0; i < 2; ++i)
{
ControlNode host = new ControlNode(diagramView1);
host.Bounds = new RectangleF((i % 10) * 20, (i / 10) * 20, 20, 30);
diagram1.Nodes.Add(host);
}
this.diagramView1.ResumeLayout();
}

Important note

Enclose the calls to Nodes.Add between SuspendLayout and ResumeLayout. This ensures that the OnLayout method is executed only once.

4. Run the application. Two ControlNode instances will be automatically created as specified in the code above:

To place a TextBox control in the newly created ControlNode objects:

1. Specify DefaultControlType of DiagramView to define the type of .NET controls to be hosted in ControlNode objects..

2. Set DefaultControlType to TextBox.

C#

this.diagramView1.DefaultControlType = typeof(TextBox);

3. Run the application. Two ControlNode objects are created where a TextBox control is hosted.

Double-click the TextBox ControlNode and type in the text as desired.

To place a Button control in the newly created ControlNode objects:

1. Set DefaultControlType to a Button control.

C#

this.diagramView1.DefaultControlType = typeof(Button);

2. Run the application. Two ControlNode objects are created where a Button control is hosted.

3. Add text and color to the ControlNode buttons.

C#

Button ctrl1 = (Button)host.Control;
ctrl1.Text = "Button";
ctrl1.ForeColor = Color.Red;
ctrl1.BackColor = Color.LightGray;

4. Look at the source code for the ControlNodes application:

Form.cs (C#)

using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Windows.Forms;

using MindFusion.Diagramming;
using MindFusion.Drawing;
using MindFusion.Diagramming.WinForms;

namespace ControlNodes
{
public partial class Form1 : Form
{
public Form1()
{
InitializeComponent();
this.diagramView1.DefaultControlType = typeof(Button);
}

private void Form1_Load(object sender, EventArgs e)
{
this.diagramView1.SuspendLayout();

for (int i = 0; i < 2; ++i)
{
// First control node
if (i == 0)
{
ControlNode host1 = new ControlNode(diagramView1);
host1.Bounds = new RectangleF(5, 10, 20, 30);
diagram1.Nodes.Add(host1);
Button ctrl1 = (Button)host1.Control;
ctrl1.Text = "Button1";
ctrl1.BackColor = Color.LightGreen;
}

// Second control node
if (i == 1)
{
ControlNode host2 = new ControlNode(diagramView1);
host2.Bounds = new RectangleF(30, 10, 20, 30);
diagram1.Nodes.Add(host2);
Button ctrl2 = (Button)host2.Control;
ctrl2.Text = "Button2";
ctrl2.BackColor = Color.LightSkyBlue;
}
}

this.diagramView1.ResumeLayout();
}
}
}


Using ContainerNode objects

© 2009 MindFusion


Tutorial 1: Creating ContainerNode diagrams

Start from the 'Create a Diagram and a DiagramView' tutorial.

  • Set the Behavior property of the DiagramView class to DrawContainers.
  • Set ContainersFoldable to true. A foldable container can be folded and unfolded by clicking the up/down arrow displayed in the caption area.
  • Execute the code and draw the control host nodes as shown in the picture:

  • Select the little container and move it into the bigger container node. Click the arrow in the caption area of the inner container, this container is folded. Move the exterior container, the inner container is moved too.

  • Set the Behavior property of the DiagramView class to LinkContainers. Execute the code and draw the control host nodes and links as shown in the picture:


Tutorial 2: Creating ContainerNode objects programmatically

1. Start from the 'Create a Diagram and a DiagramView' tutorial. Create a new project called ContainerNodes. Set up your project. See the provided ContainerNodes tutorial sample.

Make sure your source code file contains the following lines of code:

C#

using MindFusion.Diagramming;
using MindFusion.Diagramming.WinForms;
using MindFusion.Drawing;

2. Set the Behavior property of the DiagramView class to DrawContainers.

C#

this.diagramView1.Behavior = MindFusion.Diagramming.Behavior.DrawContainers;

3. Create a new ContainerNode.

Call the CreateContainerNode method through the Factory property of the Diagram class. To create a rectangle ContainerNode object, write the code (specifying the desired location and size):

C#

ContainerNode c = diagram1.Factory.CreateContainerNode(10, 10, 40, 20);

4. Set the properties of the new ContainerNode object

  • Set the Caption property of the new ContainerNode object:

C#

c.Caption = "Container";

  • Set CaptionColor, CaptionHeight and Font of the ContainerNode object.

C#

c.CaptionColor = Color.Violet;
c.CaptionHeight = 5;
b.Font = new Font("Times New Roman", 4, GraphicsUnit.World);

  • Set the Foldable property to true.

C#

c.Foldable = true;

  • Set the AutoShrink property to true.

C#

c.AutoShrink = true;

5. Run the ContainerNode application. The Form area appears. Click in the Form area. The following container node is drawn:

6. Click the up/down arrow displayed in the caption area. The container node will be folded:

C#

private void diagram_Clicked(object sender, DiagramEventArgs e)
{
// Create a container node
ContainerNode c = diagram1.Factory.CreateContainerNode(5, 10, 90, 40);
c.Font = new Font("Times New Roman", 5, GraphicsUnit.World);
c.Caption = "Container";
c.CaptionColor = Color.Violet;
c.CaptionHeight = 5;
c.Foldable = true;
c.AutoShrink = true;
}

7. Create ShapeNode objects. Add three shape nodes. In the FormContainer.cs, type in the code for creating shape nodes:

C#

// First shape node
ShapeNode b1 = diagram1.Factory.CreateShapeNode(5, 52, 20, 30);
b1.Shape = Shape.FromId("Database");
b1.Text = "Database";

// Second shape node
ShapeNode b2 = diagram1.Factory.CreateShapeNode(30, 52, 20, 30);
b2.Shape = Shape.FromId("Arrow6");
b2.Text = "Save to";

// Third shape node
ShapeNode b3 = diagram1.Factory.CreateShapeNode(60, 52, 20, 30);
b3.Shape = Shape.FromId("File");
b3.Text = "File";

Three shape nodes will be created in the Form area.

8. Add the created shape nodes to the container node. In the FormContainer.cs, type in the following code:

C#

// Shape nodes are added to the container
c.Add(b1);
c.Add(b2);
c.Add(b3);

Run the application. The ContainerNode object is created, three shape nodes are drawn and added to the container node as shown in the picture below:

Select the container. Moving the container will pe performed together with the shape nodes added to.

C#

using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Windows.Forms;

using MindFusion.Diagramming;
using MindFusion.Drawing;
using MindFusion.Diagramming.WinForms;

namespace ContainerNodes
{
public partial class Form1 : Form
{
public Form1()
{
InitializeComponent();
}

private void Form1_Load(object sender, EventArgs e)
{
}

private void diagram_Clicked(object sender, DiagramEventArgs e)
{
// Create a container node
ContainerNode c = diagram1.Factory.CreateContainerNode(5, 10, 90, 40);
c.Font = new Font("Times New Roman", 5, GraphicsUnit.World);
c.Caption = "Container";
c.CaptionColor = Color.Violet;
c.CaptionHeight = 5;
c.Foldable = true;
c.AutoShrink = true;

// First shape node
ShapeNode b1 = diagram1.Factory.CreateShapeNode(5, 52, 20, 30);
b1.Shape = Shape.FromId("Database");
b1.Text = "Database";

// Second shape node
ShapeNode b2 = diagram1.Factory.CreateShapeNode(30, 52, 20, 30);
b2.Shape = Shape.FromId("Arrow6");
b2.Text = "Save to";

// Third shape node
ShapeNode b3 = diagram1.Factory.CreateShapeNode(60, 52, 20, 30);
b3.Shape = Shape.FromId("File");
b3.Text = "File";

// shape nodes are added to the container
c.Add(b1);
c.Add(b2);
c.Add(b3);
}
}
}


Tutorial 3: Text in-place editing of container nodes

Start from the 'Create a Diagram and a DiagramView' tutorial.

  • Set the Behavior property of the DiagramView class to DrawContainers.
  • Set AllowInplaceEdit to True.

C#

this.diagramView1.AllowInplaceEdit = true;

  • Execute the code and draw control host nodes.
  • Double-click the text of the ContainerNode object, and edit the text.

Click in the Form area outside the ContainerNode object to accept the text changes.

See also tutorial about
Text in-place editing of diagram links
Inserting text in shape nodes


Using Custom Item Types

Start from the 'Create a Diagram and a DiagramView' tutorial.

To apply Custom Item Types, follow the steps:

Step 1: Define a custom node class

Step 2: Define a static constructor

Step 3: Define a public constructor

Step 4: Override the Draw method

Step 5: Override the DrawShadow method

Step 6: Define custom properties

Step 7: Enable serialization

Step 8: Implement serialization

Step 9: Enable interactive drawing

Step 10: Add custom nodes to click events


Step 1: Define a custom node class

Define the custom node class (the name IconNode is used in this tutorial) by deriving from DiagramNode.

C#

public class IconNode : DiagramNode
{
}

Visual Basic

Public Class IconNode
Inherits DiagramNode

End Class


Step 2: Define a static constructor

Define a static constructor to initialize static members of the class.

C#

static IconNode()
{
defaultIcon = new Bitmap(48, 48);

Graphics graphics = Graphics.FromImage(defaultIcon);
Font font = new Font("Arial", 48, FontStyle.Bold, GraphicsUnit.Pixel);

graphics.FillRectangle(Brushes.Transparent, 0, 0, 48, 48);
graphics.DrawString("?", font, Brushes.Black, 0, 0);

font.Dispose();
graphics.Dispose();
}

Visual Basic

Shared Sub New()

defaultIcon = New Bitmap(48, 48)

Dim graphics As Graphics = graphics.FromImage(defaultIcon)
Dim font As Font = New Font("Arial", 48, FontStyle.Bold, GraphicsUnit.Pixel)

graphics.FillRectangle(Brushes.Transparent, 0, 0, 48, 48)
graphics.DrawString("?", font, Brushes.Black, 0, 0)

font.Dispose()
graphics.Dispose()

End Sub


Step 3: Define a public constructor

Define a constructor to initialize the instance members.

C#

public IconNode(Diagram diagram) : base(diagram)
{
icon = defaultIcon;
label = "Label";

format = new StringFormat();
format.Alignment = StringAlignment.Center;
format.LineAlignment = StringAlignment.Center;

Bounds = new RectangleF(Bounds.Location, CalculateSize());
}

Visual Basic

Sub New(ByVal diagram As Diagram)

MyBase.New(diagram)

fIcon = defaultIcon
fLabel = "Label"

format = New StringFormat
format.Alignment = StringAlignment.Center
format.LineAlignment = StringAlignment.Center

Bounds = New RectangleF(Bounds.Location, CalculateSize())

End Sub


Step 4: Override the Draw method

Override the Draw method of the base class to implement your own drawing logic.

C#

public override void Draw(IGraphics graphics, RenderOptions options)
{
Rectangle iconSizePixels = new Rectangle(
0, 0, icon.Width, icon.Height);
RectangleF imageSize = MindFusion.Utilities.DeviceToDoc(
graphics, iconSizePixels);

// Draw the icon at the top-middle
graphics.DrawImage(icon,
Bounds.X + Bounds.Width / 2 - imageSize.Width / 2, Bounds.Y);

// Draw the label at the bottom
RectangleF labelBounds = RectangleF.FromLTRB(
Bounds.X, Bounds.Y + imageSize.Height,
Bounds.Right, Bounds.Bottom);

graphics.DrawString(label,
Font, Brushes.Black, labelBounds, format);
}

Visual Basic

Public Overrides Sub Draw(ByVal graphics As IGraphics, ByVal options As RenderOptions)

Dim iconSizePixels As Rectangle = New Rectangle( _
0, 0, fIcon.Width, fIcon.Height)
Dim imageSize As RectangleF = MindFusion.Utilities.DeviceToDoc( _
graphics, iconSizePixels)

' Draw the icon at the top-middle
graphics.DrawImage(fIcon, _
Bounds.X + Bounds.Width / 2 - imageSize.Width / 2, Bounds.Y)

' Draw the label at the bottom
Dim labelBounds As RectangleF = RectangleF.FromLTRB( _
Bounds.X, Bounds.Y + imageSize.Height, _
Bounds.Right, Bounds.Bottom)

graphics.DrawString(fLabel, _
Font, Brushes.Black, labelBounds, format)

End Sub


Step 5: Override the DrawShadow method

Override the DrawShadow method of the base class to implement custom drawing of shadows.

C#

public override void DrawShadow(IGraphics graphics, RenderOptions options)
{
}

Visual Basic

Public Overrides Sub DrawShadow(ByVal graphics As IGraphics, ByVal options as RenderOptions)

End Sub


Step 6: Define custom properties

Define custom properties. For example IconNode defines properties that specify the icon image and label.

C#

public Image Icon
{
get { return icon; }
set
{
icon = value;
Bounds = new RectangleF(Bounds.Location, CalculateSize());
}
}

public string Label
{
get { return label; }
set
{
label = value;
Bounds = new RectangleF(Bounds.Location, CalculateSize());
}
}

Visual Basic

Public Property Icon() As Image

Get
Return fIcon
End Get

Set(ByVal Value As Image)

fIcon = Value
Bounds = New RectangleF(Bounds.Location, CalculateSize())

End Set

End Property

Public Property Label() As String

Get
Return fLabel
End Get

Set(ByVal Value As String)

fLabel = Value
Bounds = New RectangleF(Bounds.Location, CalculateSize())

End Set

End Property


Step 7: Enable serialization

In order to enable serialization of custom item types, call the RegisterItemClass method. For example, to enable serialization of IconNode objects, add the following code in your form constructor.

C#

// Enable serialization of IconNode instances
Diagram.RegisterItemClass(typeof(IconNode), "IconNode", 1);

Visual Basic

' Enable serialization of IconNode instances
Diagram.RegisterItemClass(GetType(IconNode), "IconNode", 1)


Step 8: Implement serialization

Implement serialization of custom class members.

C#

protected override void SaveTo(
System.IO.BinaryWriter writer, PersistContext ctx)
{
base.SaveTo(writer, ctx);

// Save the label using the standard .NET BinaryWriter
writer.Write(label);

// Save the image using the MindFusion.Diagramming built-in image saving code,
// which stores the contents of shared images only once.
ctx.SaveImage(icon);
}

protected override void LoadFrom(
System.IO.BinaryReader reader, PersistContext ctx)
{
base.LoadFrom(reader, ctx);

label = reader.ReadString();
icon = ctx.LoadImage();
}

Visual Basic

Protected Overrides Sub SaveTo( _
ByVal writer As System.IO.BinaryWriter, ByVal ctx As PersistContext)

MyBase.SaveTo(writer, ctx)
' Save the label using the standard .NET BinaryWriter
writer.Write(fLabel)

' Save the image using the MindFusion.Diagramming built-in image saving code,
' which stores the contents of shared images only once.
ctx.SaveImage(fIcon)

End Sub

Protected Overrides Sub LoadFrom( _
ByVal reader As System.IO.BinaryReader, ByVal ctx As PersistContext)

MyBase.LoadFrom(reader, ctx)

fLabel = reader.ReadString()
fIcon = ctx.LoadImage()

End Sub


Step 9: Enable interactive drawing

To enable interactive drawing of IconNode objects, add the following code after the InitializeComponent call:

C#

// Let users draw IconNode objects
diagramView.CustomNodeType = typeof(IconNode);
diagramView.Behavior = Behavior.Custom;

Visual Basic

' Let users draw IconNode objects
diagramView.CustomNodeType = GetType(IconNode)
diagramView.Behavior = Behavior.Custom

Setting CustomNodeType and Behavior as shown above specifies that IconNode instances should be created when users draw on the diagram canvas.


Step 10: Add custom nodes to click events

Add custom nodes programmatically in response to click events.

C#

private void diagram_Clicked(object sender, DiagramEventArgs e)
{
IconNode iconNode = new IconNode(diagram);
diagram.Nodes.Add(iconNode);

iconNode.Move(e.MousePosition.X, e.MousePosition.Y);
}

Visual Basic

Private Sub diagram_Clicked(ByVal sender As Object, ByVal e As DiagramEventArgs) Handles diagram.Clicked

Dim iconNode As IconNode = New IconNode(diagram)
diagram.Nodes.Add(iconNode)

iconNode.Move(e.MousePosition.X, e.MousePosition.Y)

End Sub


Adjustment handles of nodes and links

Start from the 'Create a Diagram and a DiagramView' tutorial.

Set the ModificationStart property to AutoHandles

The AutoHandles setting means that selection handles appear even if you only point the mouse over an item without clicking it. If you click an item, the selection handles will be visible even if the mouse is located over another item.

  • Click the Diagram object in the Windows Form Designer.
  • Set ActiveItemHandlesColor to Red.
  • Set SelectedItemHandlesColor to Gray.
  • Set SelectAfterCreate to true.
  • Draw two nodes and a link.
  • Click the link. The selection handles of the link appear red.
  • Position the mouse pointer over the first node without clicking; faded selection handles appear on the first node while the mouse pointer is over the node. At the same time, the selection handles on the link continue to be displayed.

C#

this.diagramView1.ModificationStart = MindFusion.Diagramming.ModificationStart.AutoHandles;

Set the ModificationStart property to SelectedOnly

This determines that an item should be selected in order to be moved or resized. Only the selection handles of the item appear that you have clicked on.
  • Set the selection handles size: type in '2' in the Diagram.AdjustmentHandlesSize field.
  • Set Diagram.ShapeBrush to Orange color, and Diagram.LinkHeadShape to Triangle.
  • Fill in 'Link' in the LinkText field, set LinkTextStyle to Center, and fill in '10' in the LinkHeadShapeSize field.


Style of adjustment handles

Start from the 'Create a Diagram and a DiagramView' tutorial.

Usually the selection handle at the center of a node can be used to move the node around. To set the default value for the HandlesStyle property of newly created shape nodes, use ShapeHandlesStyle property of the Diagram class.

  • Set ShapeHandlesStyle to SquareHandles

  • Set ShapeHandlesStyle to EasyMove. The cross selection handle appears by pointing the cursor anywhere in the node area, except the center.

To set the default value for the HandlesStyle property of newly created links, use LinkHandlesStyle property of the Diagram class.

  • Set LinkHandlesStyle to DashFrame

  • Set LinkEndsMovable to true

Select the link, move the cursor over a link selection handle until a cross appears as shown in the picture. Click the left mouse button on the cross, and move the link.

Learn more about Additional handle styles.


Modifying nodes and links

Four handles at the corners allow resizing the node by moving the two sides adjacent to the corresponding direction. Handles placed at the center of the four sides resize in horizontal or vertical directions only.

ShapeHandlesStyle is set to SquareHandles.

ShapeHandlesStyle is EasyMove.

Note

Open the 'Mouse cursors' category in the DiagramView Properties window. You can change the appearance of cursor pointers.

Set DiagramView.AllowLinkCursor to Arrow.

Resizing a node can cause modification of the connecting links too. To move the link, click the left mouse button on the cross, and move the link (see picture below).

The cross is transformed into arrow shape showing that the link is moving (see picture below).

LinkStyle is Polyline. Read about Drawing of Dynamic links.


Additional handle styles

The shape handles style can be chosen from the following styles values: SquareHandles, DashFrame, HatchFrame, HatchHandles, HatchHandles2, HatchHandles3, EasyMove, MoveOnly, Invisible, InvisibleMove, SquareHandles2, and Custom.You may choose the property value as needed for your application.

The next pictures and code show some of these property values:

  • Set ShapeHandlesStyle to SquareHandles, LinkHeadShape to Arrow.

  • Set LinkHandlesStyle to SquareHandles, LinkSegments to 2, LinkStyle to Polyline.

  • Set ShapeHandlesStyle to DashFrame, LinkHeadShape to BowArrow.

Code

this.diagram1.ShapeHandlesStyle = MindFusion.Diagramming.HandlesStyle.DashFrame;
this.diagram1.LinkHeadShape = MindFusion.Diagramming.ArrowHead.BowArrow;

  • Set ShapeHandlesStyle to HatchFrame.

Code

this.diagram1.ShapeHandlesStyle = MindFusion.Diagramming.HandlesStyle.HatchFrame;

  • Set ShapeHandlesStyle to MoveOnly, LinkHeadShape to Quill.

Node size cannot be modified if MoveOnly is chosen, node can only be moved. Best used with ModificationStart set to AutoHandles.

Code

this.diagram1.ShapeHandlesStyle = MindFusion.Diagramming.HandlesStyle.MoveOnly;
this.diagram1.LinkHeadShape = MindFusion.Diagramming.ArrowHead.Quill;
this.diagram1.LinkText = "Link";
this.diagram1.ShapeText = "MoveOnly";

  • Set ShapeHandlesStyle to EasyMove, LinkHeadShape to Pentagon.

Any point inside a node enables moving it easy, except a small area in the center that allows creating links. Best used when ModificationStart is set to AutoHandles.

Code

this.diagram1.LinkHeadShape = MindFusion.Diagramming.ArrowHead.Pentagon;
this.diagram1.ShapeHandlesStyle = MindFusion.Diagramming.HandlesStyle.EasyMove;

  • Set ShapeHandlesStyle is InvisibleMove.

If you click within the node, no selection handles appear. But a double cross is visible in the whole area of the selected node. You can move the node, but not resize it.

Code

this.diagram1.ShapeHandlesStyle = MindFusion.Diagramming.HandlesStyle.InvisibleMove;
this.diagram1.ShapeText = "InvisibleMove";


MindFusion.Reporting Tutorials

The following tutorials will show you how to create and design MindFusion.Reporting reports. The reports are applicable for both Visual Studio 2005 and Visual Studio 2008.

Tutorial 1: Getting Started
This tutorial will help you create a very simple data-bound report from scratch.

Tutorial 2: Binding to a Data Source
This tutorial will demonstrate how to create and bind DataRange objects manually and how to create master-detail relationship between data-ranges representing related tables.

Tutorial 3: Customizing Your Report
This tutorial illustrates how to adjust various settings of a report in order to customize its appearance.

Tutorial 4: Using Charts in Reports
This tutorial extends Tutorial 1 by adding a bar chart to the report.

Tutorial 5: Adding a RadarChart to a Report


Tutorial 1: Getting Started

This tutorial will help you create a very simple data-bound report from scratch. The following steps are explained in more details below:

  • Creating a new project
  • Adding a MindFusion report to the project
  • Adding a data source to the project
  • Adding the data source to the MindFusion report
  • Creating a data-bound DataRange
  • Creating a report viewer
  • Running the application

Creating a new project

From MS Visual Studio select the File -> New -> Project menu command in order to create a new project.

In the dialog box that appears, select the project language and type. Select the desired programming language, then pick the 'Windows' category and select 'Windows Application' from the list to the right. Type the name and the location of the project in the text boxes at the bottom of the dialog, then click 'OK'. This tutorial uses 'myapp' as a name of the project.

Adding a MindFusion report to the project

From the 'Project' menu within MS Visual Studio select the 'Add New Item...' command.

The 'Add New Item' dialog box is displayed with the list of all item templates registered within MS Visual Studio. Select the 'MindFusion Report' item in the list, then type the name of the report class file in the text box at the bottom of the dialog ('myreport' for the purposes of this tutorial) and click 'Add'.

A class file representing the new report is created and added to the current project. A designer for the report is automatically opened in the environment.

Adding a data source to the project

Select the 'Add New Data Source...' command from the 'Data' menu in MS Visual Studio. This will display the 'Data Source Configuration Wizard', which will automate the process of adding a new data source to your application.

Follow the instructions in the wizard that appears in order to create a new data source. On the first step of the wizard select the type of the data source ('Database' in this particular sample), then click 'Next'.

In the next step of the wizard, set up the database connection.

- Click on the 'New Connection' button and enter the information required to describe the connection in the 'Add Connection' dialog box that appears. This tutorial uses the nwind.mdb file supplied with the project installation as its data source. For this purpose, select 'Microsoft Access Database File (OLE DB)' as a data adapter and enter the path to the nwind.mdb file as a database file name.

- Click 'OK' to close the 'Add Connection' dialog box, then click 'Next' to move to the next step of the wizard. The MS Visual Studio will ask you whether you want to copy the mdb file to your project directory and modify the connection string to reflect this. Select 'Yes'.

Note

After saving the connection string, a new app.config file is added to your project, and it appears in the Solution Explorer.

On the following step save the connection under the default name 'nwindConnectionString', then click 'Next'.

Select the database objects you want to import in the project.

Expand the 'Tables' node and select the 'Products' table by placing a check in the box to its left. Type the name of the imported dataset in the text box at the bottom of the dialog (this tutorial uses the default - nwindDataSet), then click 'Finish'.

Adding the data source to the MindFusion report

Either rebuild or close and reopen the project. This is necessary in order to display the newly imported data objects in the MS Visual Studio toolbox.

A new category has appeared in the toolbox. It is named after your project (in this particular case - 'myapp Components'). There are two items in this category - nwindDataSet and ProductsTableAdapter representing the data set and the data adapter for the Products table respectively.

Note

If the toolbox is not visible, you can display it through the 'Toolbox' command in the View menu or by using the respective shortcut key combination (CTRL+ALT+X by default).

Now that the data items are visible in the toolbox, double-click on each of them in order to create an object of the corresponding type within the report. Alternatively, you can drag the items from the toolbox and drop them onto the report design surface. The newly created data objects appear in the list at the very bottom of the report designer.

Creating a data-bound DataRange

Right-click on the report design surface and select the 'Create DataRange from Adapter...' command from the context menu.

In the 'Select Data Source' dialog box that appears, place a check on those fields from the Products table you want to have displayed by the report. The tutorial uses ProductID, ProductName, QuantityPerUnit, UnitPrice and UnitsInStock.

Select the 'Generate Header' option at the bottom of the dialog box in order to generate a header for the DataRange and click 'OK'.

A new DataRange appears in the report. The DataRange contains five labels bound to the selected fields. The labels are evenly distributed along the width of its parent DataRange. The DataRange also includes a header containing labels with the static names of the displayed fields.

The DataRange is already bound to the Products table. However, the table adapter needs to be filled with information from the database. Unfortunately this cannot be performed in the designer. Instead, we have to manually modify the source code of the report.

Right-click on the report and select the 'View Code' command from the context menu.

Locate the constructor of the report within the source code and add the following line of code right after the call to InitializeComponent (note, that the newly added code is outlined in bold):

C#

public myreport()
{
InitializeComponent();

// Fill the data adapter from the dataset
productsTableAdapter1.Fill(nwindDataSet1.Products);
}

Visual Basic

Public Sub New()

InitializeComponent()

' Fill the data adapter from the dataset
productsTableAdapter1.Fill(nwindDataSet1.Products)

End Sub

The report is ready to use. Close it and return back to the main application form designer.

Creating a report viewer

Ensure that the designer of the main application form is currently active in the MS Visual Studio. Right-click on the toolbox and select the 'Choose Items...' command from the context menu.

This will bring up the 'Choose Toolbox Items' dialog box. The '.NET Framework Components' should be initially active.

Click on the 'Browse...' button and navigate to the MindFusion.Reporting.WinForms.dll file located in the MindFusion.Reporting installation folder. Select the file and click 'Open'.

This will add the ReportPrinter and ReportViewer components to the list. They should be initially selected, so simply confirm the import by clicking 'OK'.

The two components should now appear in the toolbox. Double-click on (or drag and drop) the ReportViewer component to add it to the form.

While the newly added ReportViewer component is selected on the form, open the 'Properties' window and modify the value of its Dock property from None to Fill, as illustrated below:

Note

You can display the 'Properties' window through the 'Properties Window' command in the view menu or by using the respective shortcut key combination (ALT+ENTER by default).

Now that we have a report viewer and a ready report class, all we need to do is create an instance of the report and select this instance in the viewer. We have to do this manually in the code of the form class. Right-click on the form designer and select the 'View Code' command from the context menu.

Locate the form's constructor within the source code and add the following lines of code right after the call to InitializeComponent (note, that the newly added code is outlined in bold):

C#

public Form1()
{
InitializeComponent();

// Create and run the report
myreport report = new myreport();
report.Run();

// Select the report in the viewer
reportViewer1.Report = report;
}

Visual Basic

Public Sub New()

InitializeComponent()

' Create and run the report
Dim report As New myreport()
report.Run()

' Select the report in the viewer
reportViewer1.Report = report
}

Running the application

The application is ready. Compile and run to see the result. After expanding the main application form, it should look similar to the following:

Click the 'Print' button in the viewer's toolbar to print the report.


Tutorial 2: Binding to a Data Source

This tutorial will demonstrate how to create and bind DataRange objects manually and how to create master-detail relationship between data-ranges representing related tables. The following steps are explained in more details below:

  • Prerequisites
  • Adding a new data adapter
  • Creating DataRange objects manually
  • Setting MasterDetail relationship
  • Running the application

Prerequisites

This tutorial continues from where Tutorial 1: Getting Started has ended. It is therefore assumed that we have an existing application with a single data-bound report in it and a form with a set up ReportViewer that displays an instance of this report.

Adding a new data adapter

Now that we have an existing data set and an adapter for the 'Products' table, we will expand this data source by creating an adapter for the 'Categories' table.

To do this, go to the 'Data Sources' window, select the 'nwindDataSet' and click the 'Configure DataSet with Wizard' button from the 'Data Sources' window toolbar. This will bring up the 'Data Source Configuration Wizard' that we used in Tutorial 1 in order to setup the data source initially.

Note

To open the 'Data Sources' window, select the Data -> Show Data Sources menu command.

Expand the 'Tables' node and select the 'Categories' table by placing a check in the box to its left. Click 'Finish' to create a new table adapter for the selected table.

Rebuild the project to force the new table adapter to appear in the Visual Studio Toolbox. Add an instance of the CategoriesTableAdapter to the report by double-clicking on the adapter name.

Creating DataRange objects manually

In the previous tutorial we demonstrated how to create DataRange objects from an adapter automatically. To create a DataRange manually, drag it from the Toolbox and drop it onto the page surface. From the 'Properties' window set its Location to "0mm, 30mm" (this is temporary to prevent the data range from overlapping the previously created one) and its Size to "100%, 40mm".

Select the page and set its ContentSize to "180, 74" to ensure that the new DataRange will be visible in the designer.

To bind the new data range to the 'Categories' table, set its DataSource property to nwindDataSet1 and its DataMember property to "Categories". The new DataRange is now positioned and data-bound.

To add a label to the data range, simply drag the label from the Toolbox and make sure to drop the label onto the data range surface within the Designer. To ensure that the label is placed within the data range, select the label once it is positioned and press the ESCAPE key. This should select the label's parent, which in this case should be the newly created data range. Set the Location of the new label to "2mm, 2mm", its Size to "50%, 6mm" and its DataField to "CategoryName".

Add a Picture element to the data range. Set its Location to "60%, 2mm", its Size to "38%, 36mm" and its DataField to "Picture".

The report containing the two data ranges should now look similar to the following (the newly created data range is outlined in red):

Setting MasterDetail relationship

In order to create master detail relationships between the two data range elements, we have to embed them into one another. To do this, select the first data range object in the Designer and drag it onto the second one.

Note

To drag a data range, click on the [image] icon located at the top left corner of the data range when it is selected.

Adjust the position of the dragged data range. Set its Location to "2mm, 20mm" and its Size to "50%, 8mm". Finally move the containing data range at the beginning of the report, by settings its Location to "0mm, 0mm". The following image illustrates the result:

Now we have to setup the MasterDetailRelation property of the internal (embedded) data range. The name of the relation can be obtained from the data set designer.

To open the data set designer, navigate to the nwindDataSet.xsd file in the 'Solution Explorer', right-click on it and select the 'View Designer' command from the context menu. A database relationship diagram will be displayed. Select the relation connecting the 'Products' and 'Categories' tables in the diagram and open the 'Properties' window. The Name property contains the value ("CategoriesProducts" in our case) that should be set to the MasterDetailRelation property of the embedded data range.

Go back to the Report Designer, select the internal data range (the one bound to the 'Products' table) and set its MasterDetailRelation property to "CategoriesProducts".

Finally modify the report's constructor like this (the new lines are outlined in bold):

C#

public myreport()
{
InitializeComponent();

// Fill the data adapter from the dataset
productsTableAdapter1.Fill(nwindDataSet1.Products);
categoriesTableAdapter1.Fill(nwindDataSet1.Categories);
}

Visual Basic

Public Sub New()

InitializeComponent()

' Fill the data adapter from the dataset
productsTableAdapter1.Fill(nwindDataSet1.Products)
categoriesTableAdapter1.Fill(nwindDataSet1.Categories)

End Sub

Running the application

The main application form should remain unchanged from Tutorial 1. Running the application will yield a result similar to the one illustrated by the following image:


Tutorial 3: Customizing Your Report

This tutorial illustrates how to adjust various settings of a report in order to customize its appearance. The following steps are explained in more details below:

  • Prerequisites
  • Adding report header and footer
  • Customizing background colors
  • Customizing borders
  • Customizing fonts
  • Additional customizations

Prerequisites

This tutorial continues from where Tutorial 2: Binding to a Data Source has ended. It is therefore assumed that the reader is acquainted with Tutorial 1 and Tutorial 2 before reading further.

Adding report header and footer

You can add header and/or footer to a report page by right-clicking on the page surface in the Designer and selecting respectively the 'Header' or 'Footer' command from the context menu that appears. Selecting the same command again will remove the header and/or footer from the report. Removing a header or footer clears all the report elements contained within them.

For the purposes of this tutorial, lets add a footer to the report. Report elements are added to the footer in the same way they are added to a page - by dragging them from the Visual Studio Toolbox and dropping them onto the header/footer surface in the Designer.

Create a new Label within the footer and set its Location to "0mm, 0mm", its Size to "100%, 10mm" and its Alignment to "Center".

Set the Text property to "[PageCurrent()] of [PageCount()]". The specified text contains the so-called Expressions. The expressions found within the text are evaluated when the report is processed and the result of the evaluation is used in the final label text. To learn more about expressions, see Overview. To learn how to use expressions in label texts, see Using Expressions in Label Texts.

Finally, set the height of the of the footer itself to "10mm" so that it is exactly as big as the label it contains.

The report designer will now look similar to the image below. The newly created footer and its label are outlined with red.

If you run the application now, you will notice a small text at the bottom of each page specifying the current page and the total number of pages in the report.

Customizing background colors

Many report elements allow their background color to be changed. The page header/footer and the page itself allow this too. In this tutorial we will set the background of the footer, created in the previous step, to Gainsboro. To do this, select the footer in the Designer, navigate to its Background property in the Property grid, click the drop-down arrow to the right and select the 'Solid' brush from the drop-down brush editor that appears. The following image illustrates this:

Now we will customize the background of the alternating rows of the internal data range. To do this, select the data range, navigate to its AlternatingBackground property in the Property grid and set it to PaleGoldenrod solid brush the same way we set the brush of the footer above.

Finally, select the header of the internal data range and change its brush to a LightSteelBlue solid brush.

Running the application will yield the following result:

Customizing borders

Many report elements allow their border to be customized. In this tutorial we will set the border of the outer data range. To do this, select the data range and navigate to its Border property in the Property grid. The value of this property cannot be set directly. Click on the '...' button to the right of the property value in order to invoke the Format Border dialog box.

In the Format Border dialog box setup the line properties to the right, then click on the buttons corresponding to the various border sides to the left. Set Style to "Solid", Color to "160, 168, 176", Width to "0.0" and Alignment to "Center", then click on each of the four buttons to the left, to indicate that the border will have all four sides. Click 'OK' to confirm. The following image shows the Format Border dialog box:

Note

The Format Border dialog box can be alternatively displayed by clicking on the "Design Border..." command in an element's context menu.

Customizing fonts

You can customize the font of individual labels or of the entire report. Changing the font of the report will automatically change the font of all labels on that report whose font has not been explicitly changed. In this tutorial we will change the font of the report to ensure that all texts fit in their corresponding elements. Select the report (by clicking outside of the page in the Designer for example), navigate to its Font property in the Property grid and set its value to "Arial, 8pt".

Additional customizations

Running the report now reveals some minor flaws that we might want to get fixed. For example, the instances of the outer data range appear to be adjoined to each other because of the border we applied to the data range earlier. To insert some spacing between adjacent instances, set the Bottom component of the Margin property of the outer data range to, say, "5".

We may further improve the report by preventing the data range instances to split accross pages. In order to do this, set the AllowSplit property of the outer data range to false.

Running the application now and setting the viewer to display two pages at once will result in the following:


Tutorial 4: Using Charts in Reports

This tutorial extends Tutorial 1: Getting Started by adding a bar chart to the report. The following steps are illustrated in more details:

  • Prerequisites
  • Adding a bar chart to the report
  • Data-binding the chart
  • Binding to a custom query

Prerequisites

As mentioned above this tutorial extends Tutorial 1. Therefore it is expected that the reader has finished with Tutorial 1 before reading further.

Adding a bar chart to the report

The BarChart is another type of report element, just like Label and Picture. The simplest way to create one is to drag it from the Visual Studio Toolbox and drop it onto the page surface in the Designer.

Once the chart is added to the report, we have to position and resize the chart. This particular chart will hold quite a few bars, so we will stretch it along the width of the first page of the report. Set the Location of the chart to "0mm, 0mm" and its Size to "100%, 60mm". Set the ContentSize property of the current page to "180, 90" so that the whole chart is visible in the Designer. Adjust the Location of the existing data range so that it does not overlap with the newly added chart. Set it to "0mm, 70mm".

Here is how the Designer will look like after these modifications:

Data-binding the chart

To data-bind the chart, set its DataSource property to nwindDataSet1 (a variable referencing an instance of the data set we added to the report in Tutorial 1), set DataMember to "Products" and DataFields to "UnitPrice".

Now we can bind even more chart properties to this data source. For example, to display the names of the products along the x-axis, set the XLabelsFields property to "ProductName" and the LabelType property of XAxisSettings to CustomText. To display the actual prices of the products on top of each bar in the chart, set the TopLabelsFields property to "UnitPrice" and TopLabelType to CustomText.

Running the application will have the following result:

Binding to a custom query

As is observed from the illustration above, the chart bars are very small due to the large amount of products displayed. One way to partially resolve this problem is to set the PageOrientation property of the page to Landscape. This way the chart will span a larger area and the size of its bars will increase. Another way is to filter the data displayed on the chart with some criteria. To do this we need to create a custom query and a new data adapter in our data set.

Navigate to the nwindDataSet.xsd file in the Solution Explorer window and double-click on it to open the data sat diagram in the environment. Right-click on an empty area in the diagram designer and select the 'Add -> TableAdapter...' command from the context menu.

A new table adapter is created in the data set and the TableAdapter Configuration Wizard is displayed. Ensure that the appropriate connection is selected in the combo box and click 'Next'. On the 'Choose a Command Type' step leave 'Use SQL statements' as selected and click 'Next'. The 'Enter a SQL Statement' step appears.

We have to enter the text of our SQL query in the next step. There are several ways to improve the query creation experience, but we will use a ready-made query text that selects only the products with price less than 20 and sorts them in ascending order.

SQL

SELECT ProductName, UnitPrice
FROM Products
WHERE (UnitPrice < 20)
ORDER BY UnitPrice

Click the 'Advanced Options...' and uncheck the 'Generate Insert, Update and Delete statements' check box. Click 'OK' to close the 'Advanced Options' dialog box, then click 'Finish'. The table adapter representing our query is now properly initialized and appears on the diagram.

Select the data table representing the newly created query and press F2 to rename it. Replace "Products1" with "CheapProducts" then press ENTER. The name of the corresponding adapter is changed to "CheapProductsTableAdapter" automatically. Save the data set and close it. Recompile the project.

Now get back to the Report Designer. The data adapter representing the new query is now visible in the Toolbox under the 'Tutorial4 Components' tab. Double-click on it in order to create a new instance of the adapter and add it to the report.

Select the BarChart in the report, navigate to its DataMember property in the Properties window and set its value to "CheapProducts". Since the fields of our query have the same name as those in the original 'Products' table, there is nothing more that needs to be changed.

Finally, go back to the report's constructor and add the following line of code (outlined in bold):

C#

public myreport()
{
InitializeComponent();

// Fill the data adapter from the dataset
productsTableAdapter1.Fill(nwindDataSet1.Products);
cheapProductsTableAdapter1.Fill(nwindDataSet1.CheapProducts);
}

Visual Basic

Public Sub New()

InitializeComponent()

' Fill the data adapter from the dataset
productsTableAdapter1.Fill(nwindDataSet1.Products)
cheapProductsTableAdapter1.Fill(nwindDataSet1.CheapProducts)

End Sub

Running the application will now display the filtered list of products as illustrated below:


Tutorial 5: Adding a RadarChart to a Report

This tutorial demonstrates how to use RadarChart elements in a report. The following steps are described in more details below:

  • Prerequisites
  • Creating and setting up a radar chart
  • Binding the chart to a data source
  • Creating a report viewer
  • Running the application

Prerequisites

The tutorial does not have any special prerequisites. However it is assumed that the reader is acquainted with the creation of MindFusion.Reporting applications. For more details on this, check Tutorial 1. Also, the process of adding the data source and binding the chart to it is briefly described. For information on how to perform data-binding in reports, refer to Tutorial 2.

Creating and setting up a radar chart

Create a new application ('Tutorial5') and add a single MindFusion.Reporting report to it. Name the report 'RadarChartReport'. Open the report in the Visual Studio Designer and drag and drop a RadarChart element from the Toolbox to the report surface. This will create a new instance of the RadarChart class and add it to the report.

Select the RadarChart element within the designer and open the 'Properties' window. Set the following properties, in no particular order:

  • Set Location to "2mm, 2mm".
  • Set Size to "80mm, 80mm".
  • Set RadarType to Radar3D.
  • Set RadarStyle to Lines.
  • Set SpiderWeb to true.
  • Set Background3D to an Orange color.

Modify the chart's title settings as follows:

  • Set TitleText to "Sales".
  • Set TitleFont to "Arial, 12pt, style=Bold".
  • Set SubTitleText to "Product sales for 1995".
  • Set SubTitleFont to "Arial, 10pt".

To modify the brush and pen of the area drawn by the radar chart, navigate to the ChartBrushes property in the Properties window, select it and click on the '...' button at its right. The 'BrushCollection Editor' dialog appears. Click on the 'Add' button in the toolbar to create a new brush. Select the brush in the property grid below and click the drop-down arrow. In the brush editor click 'Solid' and enter LightSteelBlue for a value of color. The following image illustrates this:

The area pen is specified in a similar manner, only this time edit the ChartPens property. Add a single pen with DarkSlateBlue color, as shown below:

Resize the report page by setting its ContentSize to "180, 100".

Binding the chart to a data source

Add the 'Category Sales for 1995' view from the nwind.mdb database to the project. Extensive information on how to add data sources to a project can be found in both Tutorial 1 and Tutorial 2.

After rebuilding the project a new category will be visible in the Toolbox - 'Tutorial5 Components'. This new category contains two items - nwindDataSet and Category_Sales_for_1995TableAdapter. While the designer is active, double-click on any of these items in order to instantiate them. The nwindDataSet1 and category_Sales_for_1995TableAdapter1 are created and added to the report and can now be observed at the bottom side of the report designer.

To bind the radar chart to the newly created data source, set its DataSource to nwindDataSet1 and its DataMember to "Category Sales for 1995". Set the DataField property to the appropriate field in the data table, in this case - "CategorySales".

Set OuterAxisLabelType to CustomText and OuterAxisLabelsField to "CategoryName".

Finally, go to the source code of our report and modify its constructor as following:

C#

public RadarChartReport()
{
InitializeComponent();

category_Sales_for_1995TableAdapter1.Fill(nwindDataSet1.Category_Sales_for_1995);
}

Visual Basic

Public Sub New()

InitializeComponent()

category_Sales_for_1995TableAdapter1.Fill(nwindDataSet1.Category_Sales_for_1995)

End Sub

Creating a report viewer

For more information on how to create a ReportViewer, refer to Tutorial 1. Leave the default name of the newly created viewer - reportViewer1. Create an instance of our report and select it within the report viewer.

C#

public Form1()
{
InitializeComponent();

// Create and run the report
RadarChartReport report = new RadarChartReport();
report.Run();

// Select the report in the viewer
reportViewer1.Report = report;
}

Visual Basic

Public Sub New()

InitializeComponent()

' Create and run the report
Dim report As New RadarChartReport()
report.Run()

' Select the report in the viewer
reportViewer1.Report = report

End Sub

Running the application

The following image illustrates the result when running the application:


MindFusion.Scheduling Tutorials

Tutorial 1: Getting Started
This tutorial demonstrates how to quickly utilize MindFusion.Scheduling in an application.

Tutorial 2: Creating Recurrent Items
This tutorial shows how to create recurring items programmatically in MindFusion.Scheduling.

Tutorial 3: Using the Standard Forms
This tutorial shows how to use the standard appointment editing dialogs provided with MindFusion.Scheduling.

Tutorial 4: Creating Custom Appointment Classes
This tutorial demonstrates how to create custom appointment class, by deriving from Appointment. The custom class is also made serializable and supports recurrence.

Tutorial 5: Custom Item Viewers and Editors
This tutorial demonstrates how to add custom viewers and editors to items in MindFusion.Scheduling.

Tutorial 6: Creating and Printing Reports
This tutorial demonstrates how to setup and preview an event report in MindFusion.Scheduling.

Tutorial 7: Exchanging Data with Microsoft Outlook
This tutorial demonstrates how to import and export MindFusion.Scheduling event information from/to MS Outlook.

Tutorial 8: Creating Custom Themes
This tutorial demonstrates how to create custom themes for MindFusion.Scheduling using the MindFusion Theme Editor and how to integrate your custom themes in an application.

Tutorial 9: Binding to a Data Source
This tutorial shows how to serialize and deserialize schedules to and from a database with MindFusion.Scheduling.


Tutorial 1: Getting Started

This tutorial will show you how to create a simple day schedule application based on MindFusion.Scheduling.

1. Create a new Windows Forms application project

Select File -> New -> Project from the Visual Studio menu. In the dialog that appears, select Visual C# Projects from the list on the left, then Windows Application from the list on the right. Type in the name of your project (the tutorial uses Tutorial1) and click 'OK'.

2. Add the Calendar control to the form

Before using the Calendar control, you must add it to the toolbox. Display the toolbox by selecting View -> Toolbox from the menu. Then select the appropriate category for the control and right-click on it. From the context menu choose 'Add/Remove Items...'. In the "Customize toolbox" dialog click the 'Browse...' button and navigate to the control assembly file - MindFusion.Scheduling.dll. This file is usually found in the 'c:\Program Files\MindFusion\MindFusion.Scheduling for WinForms' folder or in the folder where you have installed the product. Once the dll is added to the list of components, click 'OK'. A Calendar item should appear in the selected category in the toolbox. Click on this item and drag it to the form's working area. This creates a new MindFusion.Scheduling Calendar control on the form.

3. Setting the control's properties

Select the newly created control and click View -> Properties Window from the menu. In the Properties window change the name of the control to 'calendar' and set Dock to Fill.

Change CurrentView to Timetable. The timetable view displays rows of cells corresponding to the time of the day, and the cells in each column correspond to a specific date.

Expand the TimetableSettings property and set ShowDayHeader to Enabled. TimetableSettings contains settings used with the timetable view. There are corresponding settings objects available for each of the view types.

4. Adding more days to the Timetable

Initially the timetable displays only one day - usually the day when the control was added to the form. To change the set of displayed days, you must add a few lines of code. For that purpose, double-click on the form's title bar in the designer area. This switches to source code view and automatically creates an event handler for the form's Load event (named Form1_Load). Add the next lines to the body of the event handler.

C#

calendar.BeginInit();
calendar.TimetableSettings.Dates.Clear();

for (int i = 0; i < 5; i++)
{
calendar.TimetableSettings.Dates.Add(
DateTime.Today + new TimeSpan(i, 0, 0, 0));
}

calendar.EndInit();

Visual Basic

calendar.BeginInit()
calendar.TimetableSettings.Dates.Clear()

Dim i as Integer
for i = 0 to 4

calendar.TimetableSettings.Dates.Add(
DateTime.Today.Add(new TimeSpan(i, 0, 0, 0)));

Next i

calendar.EndInit()

The code above adds 5 days to the timetable view, starting from today.

The first and last methods called above are used together to enclose code, which contains series of modifications to the calendar. BeginInit disables the internal update logic of the control, while EndInit resumes the control's normal behavior and updates its internal state to reflect all changes made since the call to BeginInit.

You can also set VisibleColumns to more than 1 to ensure more than one column is visible initially.

5. Build and run

Compile and run the application. If you have set VisibleColumns to 3, the result should look like the image shown below.


Tutorial 2: Creating Recurrent Items

This tutorial shows how to programmatically create recurring items using MindFusion's MindFusion.Scheduling.

1. Create and initialize a new Windows Forms application project

Follow steps 1 through 3 from the previous tutorial.

Set CurrentView to WeekRange, Date to Jan 1, 2006 and EndDate to Mar 1, 2006, respectively.

2. Create an appointment

Create a new appointment in the handler of the form's Load event. To create the appointment, add the following lines of code to the body of the event handler.

Note

Be sure to include both MindFusion.Scheduling and MindFusion.Scheduling.WinForms namespace via the using keyword in the beginning of the file.

C#

Appointment app = new Appointment();
app.HeaderText = "Meet George";
app.DescriptionText = "This is a sample appointment";
app.StartTime = new DateTime(2006, 1, 10, 14, 0, 0);
app.EndTime = new DateTime(2006, 1, 10, 16, 30, 0);

calendar.Schedule.Items.Add(app);

Visual Basic

Dim app As New Appointment()
app.HeaderText = "Meet George"
app.DescriptionText = "This is a sample appointment"
app.StartTime = new DateTime(2006, 1, 10, 14, 0, 0)
app.EndTime = new DateTime(2006, 1, 10, 16, 30, 0)

calendar.Schedule.Items.Add(app)

The code above creates a new appointment on 10th of January, 2006, starting at 2:00 PM and ending at 4:30 PM.

3. Create the recurrence

Now that the appointment is added to the schedule, create a Recurrence object that defines how the appointment recurs. The following code creates and initializes a new Recurrence object and associates it with the item. Append these lines to the form's Load event handler.

C#

Recurrence rec = new Recurrence();
rec.Pattern = RecurrencePattern.Weekly;
rec.DaysOfWeek = DaysOfWeek.Monday | DaysOfWeek.Wednesday;
rec.Weeks = 2;
rec.StartDate = new DateTime(2006, 1, 10);
rec.RecurrenceEnd = RecurrenceEnd.Never;

app.Recurrence = rec;

Visual Basic

Dim rec As New Recurrence()
rec.Pattern = RecurrencePattern.Weekly
rec.DaysOfWeek = DaysOfWeek.Monday + DaysOfWeek.Wednesday
rec.Weeks = 2
rec.StartDate = new DateTime(2006, 1, 10)
rec.RecurrenceEnd = RecurrenceEnd.Never

app.Recurrence = rec

This fragment creates a new recurrence object that continues infinitely and repeats the appointment on Monday and Wednesday every two weeks.

4. Build and run

Compile and run the application. The image below depicts what the application output would look like.


Tutorial 3: Using the Standard Forms

This tutorial shows how to use the standard MindFusion.Scheduling dialogs to edit appointments in the calendar. This tutorial extends the application created in the previous tutorial so if you haven't done it already, complete Tutorial 2: Creating Recurrent Items first.

1. Add a reference to the dialogs assembly

In order to use the stock forms that come with MindFusion.Scheduling, you must first add a reference to the assembly that contains them. To do so, open the Solution Explorer by selecting View -> Solution Explorer from the Visual Studio menu, then right-click on the 'References' item and select 'Add Reference' from the context menu. In the dialog that appears, navigate to the StandardForms.dll file and click 'OK'. The file is usually located in the 'c:\Program Files\MindFusion\MindFusion.Scheduling for WinForms' folder or in the folder where you have installed the product.

2. Handling the ItemClick event

The appointment form is usually displayed in response to double-clicking the appointment, so we will handle the ItemClick event of the Calendar control. Switch to design view, select the control and in the Properties window click the 'Events' button located in the toolbar near the top of the window. Navigate to the ItemClick event in the event list and double-click it. That automatically creates an event handler for the event (with default name calendar_ItemClick) and places the input cursor at its beginning.

3. Display the form

To display the form add the following code to the body of the event handler just created.

Note

Be sure to include both MindFusion.Scheduling and MindFusion.Scheduling.WinForms namespace via the using keyword in the beginning of the file.

C#

// Display the form only if left mouse button is double-clicked
if (e.Button != MouseButtons.Left || e.Clicks != 2)
return;

calendar.ResetDrag();

// Create the form
AppointmentForm form = new AppointmentForm(calendar.Schedule);
form.Text = e.Item.HeaderText;
form.SetAppointment(e.Item as Appointment);

// Display the form to the user
DialogResult result = form.ShowDialog(this);

if (result == DialogResult.Abort)
{
// 'Abort' is returned when the user clicks the 'Delete' button.
// It is up to us to delete the item from the schedule.
if (e.Item.RecurrenceState == RecurrenceState.Occurrence ||
e.Item.RecurrenceState == RecurrenceState.Exception)
e.Item.Recurrence.MarkException(e.Item, true);
else
calendar.Schedule.Items.Remove(e.Item);
}

// Invalidate the control
calendar.Invalidate();

Visual Basic

' Display the form only if left mouse button is double-clicked
If e.Button <> MouseButtons.Left Or e.Clicks <> 2 Then
Return
End If

calendar.ResetDrag()

' Create the form
Dim form As New AppointmentForm(calendar.Schedule)
form.Text = e.Item.HeaderText
form.SetAppointment(e.Item as Appointment)

' Display the form to the user
Dim result As DialogResult = form.ShowDialog(this)

If result = DialogResult.Abort Then

' 'Abort' is returned when the user clicks the 'Delete' button.
' It is up to us to delete the item from the schedule.
If e.Item.RecurrenceState = RecurrenceState.Occurrence Or _
e.Item.RecurrenceState = RecurrenceState.Exception Then
e.Item.Recurrence.MarkException(e.Item, True)
Else
calendar.Schedule.Items.Remove(e.Item)
End If

End If

' Invalidate the control
calendar.Invalidate()

The form automatically updates the edited item with all modifications made by the user, except when the user clicks the 'Delete' button. In this situation the form doesn't do anything except that it returns DialogResult.Abort. It is a responsibility of the developer to remove the item from the schedule.

If the item is not a recurring one, we can simply remove it from the Items collection. If the item is a recurring item, then it is not within the collection and an attempt to remove it will result in exception. To mark a recurring item as deleted we invoke MarkException on the corresponding Recurrence object, passing to it a reference to the item as the first argument and true as the second argument.

4. Build and run

Compile and run the application. Create an appointment by typing and then double-click it to display the appointment dialog.


Tutorial 4: Creating Custom Appointment Classes

This tutorial shows how to create a custom schedule item class. For simplicity, the sample demonstrates that by inheriting a class from Appointment.

1. Create and initialize a new Windows Forms application project

Follow steps 1 through 3 from Tutorial 1: Getting Started.

2. Create new class for the custom item

Select Project -> Add Class... from the menu, type the name of the custom item class in the dialog that appears (for example MyApp) and click 'OK'. Include the MindFusion.Scheduling namespace at the beginning of the file.

C#

using MindFusion.Scheduling;

Visual Basic

Imports MindFusion.Scheduling

The custom class will support a new property of type Boolean (called Kept) that will indicate whether the appointment has been kept or cancelled. The implementation of the property is trivial. Simply add a private field of type Boolean and make the property getter setter to return the field and to set the field respectively. The following sample code illustrates this:

C#

public class MyApp : Appointment
{
public MyApp()
{
_kept = true;
}

public bool Kept
{
get { return _kept; }
set { _kept = value; }
}

private bool _kept;
}

Visual Basic

Class MyApp
Inherits Appointment

Public Sub New()

_kept = True

End Sub

Public Property Kept() As Boolean

Get
Return _kept
End Get

Set(ByVal Value As Boolean)
_kept = Value
End Set

End Property

Private _kept As Boolean

End Class

Note

You must provide constructor that takes no argument with your custom item class. MindFusion.Scheduling creates item class instances using reflection and an exception will be thrown if there isn't such constructor available.

3. Set the custom item as default

By default the Calendar control instantiates items of type Appointment when the user creates items interactively (by typing). To make the calendar create items of the new class, we need to add the following line of code in the form's Load event handler.

C#

calendar.InteractiveItemType = typeof(MyApp);

Visual Basic

calendar.InteractiveItemType = GetType(MyApp)

Now all items created by the user at runtime will be instances of MyApp.

4. Test

To test whether the calendar actually creates MyApp instances, add an event handler to the control's ItemClick event. Add the following as a body of the event handler:

C#

if (e.Item is MyApp)
{
calendar.ResetDrag();
MessageBox.Show("This is our item.");
}

Visual Basic

If TypeOf e.Item Is MyApp Then

calendar.ResetDrag()
MessageBox.Show("This is our item.")

End If

Clicking on an item now should display the message box.

5. Serialization

Serialization of custom items requires additional efforts. Attempts to save a schedule containing items of type MyApp will result in an InvalidOperationException exception. In order to support serialization, we have to register MyApp with the schedule. For this purpose, add the following line of code somewhere in the form's Load event handler:

C#

Schedule.RegisterItemClass(typeof(MyApp), "myapp", 1);

Visual Basic

Schedule.RegisterItemClass(GetType(MyApp), "myapp", 1)

Now the exception won't be thrown, but we still need to override the SaveTo and LoadFrom methods of the Appointment class in order to serialize the custom property Kept. The code below illustrates how this is done for the SaveTo and LoadFrom overloads that serialize item's contents in binary streams.

C#

public override void SaveTo(System.IO.BinaryWriter writer, BinarySerializationContext context)
{
base.SaveTo(writer, context);
context.WriteBool(writer, _kept);
}

public override void LoadFrom(System.IO.BinaryReader reader, BinarySerializationContext context)
{
base.LoadFrom(reader, context);
_kept = context.ReadBool(reader);
}

Visual Basic

Public Overloads Overrides Sub SaveTo(ByVal writer As System.IO.BinaryWriter, ByVal context As BinarySerializationContext)

MyBase.SaveTo(writer, context)
context.WriteBool(writer, context)

End Sub

Public Overloads Overrides Sub LoadFrom(ByVal reader As System.IO.BinaryReader, ByVal context As SerializationContext)

MyBase.LoadFrom(reader, context)
_kept = context.ReadBool(reader)

End Sub

A code that implements serialization of items in XML format would look similar to the above, but it will override the other SaveTo and LoadFrom method overloads.

6. Recurrence

Recurrence of items from a custom class is not handled wholly automatically. Let's take a closer look at how recurrence works in MindFusion.Scheduling. When a recurrence pattern is associated with an existing item, the item is said to become the master of the recurrence. Every time the occurrences of a master item must be displayed in a given time range, they are generated by instantiating new objects of the same type as that of the master. This is necessary in order to support infinite recurrences, where the generation of all recurrence instances is not possible. When the occurrences are generated, their properties are copied from the master item. This is done automatically for the built-in item properties, but not for those added by a derived item class. In order to copy the custom properties from the master item to a particular occurrence, you need to override the CopyOccurrence method. The following code sample shows how to do this.

C#

protected override void CopyOccurrence(Item master)
{
base.CopyOccurrence(master);
_kept = (master as MyApp).Kept;
}

Visual Basic

Protected Overloads Overrides Sub CopyOccurrence(ByVal master As Item)

MyBase.CopyOccurrence(master)
_kept = CType(master, MyApp).Kept

End Sub

In addition, it is recommended to mark an item from a recurrent series as an exception when the value of a custom property changes. Otherwise, the change will be lost the next time the instance is generated.

C#

//...
public bool Kept
{
get { return _kept; }
set
{
_kept = value;

if (Recurrence != null)
Recurrence.MarkException(this, false);
}
}
//...

Visual Basic

' ...
Public Property Kept() As Boolean

Get
Return _kept
End Get

Set(ByVal Value As Boolean)

_kept = Value

If Not Recurrence Is Nothing Then
Recurrence.MarkException(Me, False)
End If

End Set

End Property
' ...

7. Interactive cloning

Interactive item cloning has been introduced in version 4.0. The users can clone items by holding down a particular key (the SHIFT key by default). To enable your custom items for interactive cloning, you have to override the Clone method, create a new object from your custom type and duplicate the fields of the prototype item. If you do not override the Clone method, MindFusion.Scheduling will still create copies of the item, but they will be of type Appointment instead of the custom item type. Here is a sample implementation of the Clone method.

C#

//...
public override object Clone()
{
MyApp clone = new MyApp();

// The following code replicates the code used in
// the Appointment's Clone method
clone.AllDayEvent = this.AllDayEvent;
clone.DescriptionText = this.DescriptionText;
clone.EndTime = this.EndTime;
clone.HeaderText = this.HeaderText;
clone.Location = this.Location;
clone.Locked = this.Locked;
clone.Priority = this.Priority;
clone.Reminder = this.Reminder;
clone.SelectedStyle = this.SelectedStyle.Clone() as Style;
clone.StartTime = this.StartTime;
clone.Style = this.Style.Clone() as Style;
clone.Tag = this.Tag;
clone.Task = this.Task;
clone.Visible = this.Visible;

foreach (Resource resource in this.Resources)
clone.Resources.Add(resource);

foreach (Contact contact in this.Contacts)
clone.Contacts.Add(contact);

// Now copy the custom fields
clone.Kept = this.Kept;

return clone;
}
//...

Visual Basic

'...
Public Overloads Overrides Function Clone() As Object

Dim aClone As New MyApp

' The following code replicates the code used in
' the Appointment's Clone method
aClone.AllDayEvent = Me.AllDayEvent
aClone.DescriptionText = Me.DescriptionText
aClone.EndTime = Me.EndTime
aClone.HeaderText = Me.HeaderText
aClone.Location = Me.Location
aClone.Locked = Me.Locked
aClone.Priority = Me.Priority
aClone.Reminder = Me.Reminder
aClone.SelectedStyle = CType(Me.SelectedStyle.Clone(), Style)
aClone.StartTime = Me.StartTime
aClone.Style = CType(Me.Style.Clone(), Style)
aClone.Tag = Me.Tag
aClone.Task = Me.Task
aClone.Visible = Me.Visible

Dim resource As Resource
For Each resource In Me.Resources
aClone.Resources.Add(resource)
Next resource

Dim contact As Contact
For Each contact In Me.Contacts
aClone.Contacts.Add(contact)
Next contact

' Now copy the custom fields
aClone.Kept = Me.Kept

Return aClone

End Function
'...


Tutorial 5: Custom Item Viewers and Editors

This tutorial demonstrates how to add custom viewers and editors to schedule items in MindFusion.Scheduling. The tutorial extends Tutorial 4: Creating Custom Appointment Classes and if you have not done so already, complete that one first.

1. Define custom item class

Custom items and viewers in MindFusion.Scheduling are associated with items on class level (that is, the viewers and the editors are associated with the item's class, and not to distinct item). For that reason, if you want to use custom viewers or editors you need to implement new item class. We will use the class MyApp that we created in the previous tutorial step.

2. Create the viewer

Custom viewers implement the IItemViewer interface. This interface exposes a single method - Draw, which is called each time an item must be repainted. A sample implementation of a custom item viewer is shown below. Make sure you include System.Drawing, MindFusion.Scheduling and MindFusion.Scheduling.WinForms namespaces.

C#

public class MyAppViewer : IItemViewer
{
public virtual void Draw(ItemDrawContext context)
{
Rectangle b = context.Bounds;
Graphics g = context.Graphics;
Style s = context.Style;
Brush headerBrush = new SolidBrush(s.HeaderTextColor);
Pen strokePen = new Pen(Color.Red, 2);
MyApp item = context.Item as MyApp;

// If the item is selected, draw a faint background
if (context.Calendar.ItemSelection.Contains(item))
g.FillRectangle(Brushes.PaleGoldenrod, b);

// Draw the item's text
g.DrawString(context.Item.HeaderText, context.Style.HeaderFont,
headerBrush, new RectangleF(b.Left, b.Top, b.Width, b.Height));

// Stroke the text if the appointment is not kept
if (!item.Kept)
{
int width = (int)Math.Ceiling(
g.MeasureString(context.Item.HeaderText, context.Style.HeaderFont, b.Width).Width);
g.DrawLine(strokePen,
b.Left, b.Top + b.Height / 2,
b.Left + width, b.Top + b.Height / 2);
}

strokePen.Dispose();
headerBrush.Dispose();
}
}

Visual Basic

Public Class MyAppViewer
Implements IItemViewer

Public Sub Draw(ByVal context As ItemDrawContext) Implements IItemViewer.Draw

Dim b As Rectangle = context.Bounds
Dim g As Graphics = context.Graphics
Dim s As Style = context.Style
Dim headerBrush As Brush = New SolidBrush(s.HeaderTextColor)
Dim strokePen As Pen = New Pen(Color.Red, 2)
Dim item As MyApp = CType(context.Item, MyApp)

' If the item is selected, draw a faint background
If context.Calendar.ItemSelection.Contains(item) Then
g.FillRectangle(Brushes.PaleGoldenrod, b)
End If

' Draw the item's text
g.DrawString(context.Item.HeaderText, context.Style.HeaderFont, _
headerBrush, new RectangleF(b.Left, b.Top, b.Width, b.Height))

' Stroke the text if the appointment is not kept
If Not item.Kept Then

Dim width As Integer = CType(Math.Ceiling( _
g.MeasureString(context.Item.HeaderText, context.Style.HeaderFont, b.Width).Width), Integer)
g.DrawLine(strokePen, _
b.Left, b.Top + CInt(b.Height / 2), _
b.Left + width, b.Top + CInt(b.Height / 2))

End If

strokePen.Dispose()
headerBrush.Dispose()

End Sub

End Class

Since we will associate MyAppViewer only with the MyApp item custom class, we may safely assume, that the item provided with the context parameter is of type MyApp.

The viewer simply draws the item's header text in the item's bounding rectangle. If the item is selected, its background is drawn with a faint yellow color. If the appointment is not kept (that is, Kept is set to false) the viewer strikes the text with a thick red line.

3. Associate the viewer with the custom item class

The association of a custom viewer with a particular item class is done via the ItemViewerAttribute class. The following sample demonstrates how to use it.

C#

[ItemViewer(typeof(MyAppViewer))]
public class MyApp : Appointment
{
//...

Visual Basic

<ItemViewer(GetType(MyAppViewer))> _
Class MyApp
Inherits Appointment
'...

Now all MyApp instances will be drawn using MyAppViewer.

4. Create the editor

We will define a custom editor, capable of changing not only the item's header text but the item's Kept property as well. The easiest way to define a custom editor is by deriving from UserControl. To create a new UserControl, click the Project -> Add User Control menu, type in the name of the custom editor class (for example MyAppEditor) and click 'OK'. The environment opens the designer of the new control where you can arrange its child controls.

Drag a new TextBox in the control's area (the Toolbox is displayed via View -> Toolbox menu command). Select the TextBox and change the Text property to an empty string and the name to headerText. Position the TextBox at the top of the user control, and expand it to span from left to (right - 16). Then set its anchor to 'Top, Left, Right' and its BorderStyle to None. Finally make the height of the user control equal to the height of the TextBox. So far the control should look similar to this:

Now drag in a CheckBox from the toolbox and position it on the right of the edit box. Change the name of the ChekBox to kept and its Anchor to 'Top, Right'. The final layout of the control should look like this:

Right-click in the designer area and select 'View Code'. The first thing to do is to make sure that the newly created class implements the IItemEditor interface. The following line of code illustrates this.

Note

Don't forget to include both MindFusion.Scheduling and MindFusion.Scheduling.WinForms namespaces.

C#

public class MyAppEditor : System.Windows.Forms.UserControl, IItemEditor
{
//...

Visual Basic

Public Class MyAppEditor
Inherits System.Windows.Forms.UserControl
Implements IItemEditor
'...

The IItemEditor interface exposes 2 methods and a single property.

The method StartEdit is invoked by the Calendar control when the user initiates in-place editing of an item (usually by single-clicking on the item). By the time the method is invoked, the control is instantiated, properly positioned and displayed. This is the place to put code that initializes child controls with the properties of the edited item. The following code shows sample implementation of this method.

C#

public void StartEdit(ItemEditContext context)
{
MyApp item = context.Item as MyApp;

headerText.Text = item.HeaderText;
kept.Checked = item.Kept;

headerText.Focus();
headerText.Select(headerText.Text.Length, 0);
}

Visual Basic

Public Sub StartEdit(ByVal context As ItemEditContext) Implements IItemEditor.StartEdit

Dim item As MyApp = CType(context.Item, MyApp)

headerText.Text = item.HeaderText
kept.Checked = item.Kept

headerText.Focus()
headerText.Select(headerText.Text.Length, 0)

End Sub

As with the viewer, we can safely assume that the item, passed with the method argument is of type MyApp. The first two lines initialize the child controls of the editor with the values of the particular item. The next lines set the focus to the header text and position the input cursor at the end of the text.

The method EndEdit is invoked by the Calendar control when the editor is about to be closed. The second parameter specifies whether the changes are to be accepted or not. EndEdit can also be invoked by the custom editor (for example in response to a button click). In this case however you need to keep a copy of the ItemEditContext to pass to it. Below is given a sample implementation of EndEdit.

C#

public void EndEdit(ItemEditContext context, bool accept)
{
if (accept)
{
context.Accept();

MyApp item = context.Item as MyApp;

item.HeaderText = headerText.Text;
item.Kept = kept.Checked;
}
else
{
context.Cancel();
}
}

Visual Basic

Public Sub EndEdit(ByVal context As ItemEditContext, ByVal accept As Boolean)

If (accept) Then

context.Accept()

Dim item As MyApp = CType(context.Item, MyApp)

item.HeaderText = headerText.Text
item.Kept = kept.Checked

Else

context.Cancel()

End If

End Sub

As you can see above, it is necessary to invoke Accept or Cancel on the context object, depending on whether the operation has been accepted or not. This notifies the Calendar control of the result of the editing operation as well as causes the editor object to be removed and destroyed.

Finally, the implementation of the Text property simply returns the contents of the TextBox.

C#

public new string Text
{
get { return headerText.Text; }
}

Visual Basic

Public Shadows ReadOnly Property Text() As String

Get
Return headerText.Text
End Get

End Property

We use the keyword new because this property hides the UserControl.Text property.

5. Associate the editor with the custom item class

The association of a custom editor with a particular item class is done via the ItemEditorAttribute class. The following sample demonstrates how to use it.

C#

[ItemEditor(typeof(MyAppEditor))]
public class MyApp : Appointment
{
//...

Visual Basic

<ItemEditor(GetType(MyAppEditor))> _
Class MyApp
Inherits Appointment
'...

Now all MyApp instances will be edited using MyAppEditor.

6. Test

Make sure the default item in the calendar is MyApp by specifying typeof(MyApp) (or GetType(MyApp) in Visual Basic) for the calendar's InteractiveItemType property. Set the CurrentView to WeekRange. Then build and run the application. Here is a screenshot of what the application output should look like after creating several items.


Tutorial 6: Creating and Printing Reports

This tutorial demonstrates how to setup and preview an event report in MindFusion.Scheduling.

1. Create the report

To create a report, simply instantiate from the Report class.

C#

Report report = new Report();

Visual Basic

Dim report As new Report()

2. Setting-up the report columns

Report columns are created by calling the CreateColumn method on the report object. Once created the column's properties can be customized as needed, then the columns are added to the report by calling the Add method of the ReportColumnCollection returned by the Columns property. The following code illustrates how to create three columns containing the header text, the start date and the end date of items respectively and how to add them to the report created in step 1.

C#

ReportColumn column = null;

// Create the first column
column = report.CreateColumn();
column.Property = "HeaderText";
column.Width = 100;
report.Columns.Add(column);

// Create the second column
column = report.CreateColumn();
column.Property = "StartTime";
column.Width = 50;
report.Columns.Add(column);

// Create the third column
column = report.CreateColumn();
column.Property = "EndTime";
column.Width = 50;
report.Columns.Add(column);

Visual Basic

Dim column As ReportColumn = Nothing

' Create the first column
column = report.CreateColumn()
column.Property = "HeaderText"
column.Width = 100
report.Columns.Add(column)

' Create the second column
column = report.CreateColumn()
column.Property = "StartTime"
column.Width = 50
report.Columns.Add(column)

' Create the third column
column = report.CreateColumn()
column.Property = "EndTime"
column.Width = 50
report.Columns.Add(column)

We make the first column twice as wide as the other columns.

3. Associate the report with a schedule

It is very important to associate the report with the schedule, which would provide the items for the report. If the report does not have an assigned schedule by the time its Preview or Print methods are invoked, the invocation would raise an exception. You associate a schedule with the report by assigning the schedule instance to the Schedule property of the report. The code below assumes that the variable schedule identifies a valid Schedule instance.

C#

report.Schedule = schedule;

Visual Basic

report.Schedule = schedule

4. Setup report options

You can customize various aspects of the report by modifying the properties of the ReportOptions object, accessed through the Report.Options property. In this particular case we will make the width of the columns in the report to resize to automatically fill the width of one page.

C#

report.Options.AbsoluteColumnWidth = false;

Visual Basic

report.Options.AbsoluteColumnWidth = False

5. Print / Preview the report

The report is printed or previewed by calling the Print or Preview methods respectively. Both methods accept two .NET DateTime instances, which specify the time range of the items included in the report. If you do NOT have infinite recurrences in the report it is safe to specify DateTime.MinValue and DateTime.MaxValue for those parameters to ensure that all items will get included in the report.

C#

report.Preview(DateTime.MinValue, DateTime.MaxValue);

Visual Basic

report.Preview(DateTime.MinValue, DateTime.MaxValue)

Here is how our report would look like.


Tutorial 7: Exchanging Data with Microsoft Outlook

This tutorial demonstrates how to import and export MindFusion.Scheduling event information from/to MS Outlook.

1. Create and initialize a new Windows Forms application project

Follow steps 1 through 3 from Tutorial 1: Getting Started.

Set CurrentView to WeekRange, Date to Jan 1, 2006 and EndDate to Mar 1, 2006, respectively.

2. Add a reference to the Outlook library

Go to the 'Solution Explorer' window. You can show this window by selecting View -> Solution Explorer from the menu. Find the 'References' node in the tree view displayed in the 'Solution Explorer', right-click on it with the mouse and select 'Add Reference...' from the context menu that appears. In the "Add reference" dialog click the 'Browse...' button and navigate to the Outlook Import/Export library - MindFusion.Scheduling.Outlook.dll. This file is usually found in the 'c:\Program Files\MindFusion\MindFusion.Scheduling for WinForms' folder or in the folder where you have installed the product. Click the 'OK' button to add the assembly reference to your project.

3. Add a reference to the Outlook library

Include the MindFusion.Scheduling and MindFusion.Scheduling.Outlook namespaces in the beginning of the file. These namespaces contain all schedule classes along with the OutlookImporter and OutlookExporter classes, which provide Outlook Export/Import capabilities.

C#

using MindFusion.Scheduling;
using MindFusion.Scheduling.Outlook;

Visual Basic

Imports MindFusion.Scheduling
Imports MindFusion.Scheduling.Outlook

4. Add import and export buttons to the form

Add two buttons to the form, named _btnImport and _btnExport accordingly. Set the texts of the buttons to 'Import' and 'Export' respectively. Create a Click event handler for each of those buttons by double-clicking on the buttons in the design environment.

The body of the event handler of the 'Import' button should look like this:

C#

private void _btnImport_Click(object sender, System.EventArgs e)
{
OutlookImporter importer = new OutlookImporter(calendar.Schedule);
importer.ImportItems();
}

Visual Basic

Private Sub _btnImport_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles _btnImport.Click

Dim importer As New OutlookImporter(calendar.Schedule)
importer.ImportItems()

End Sub

The code above creates a new instance of the OutlookImporter class, passing to the constructor a reference to the Schedule object, which will be the target of the importing operation. Then it calls the ImportItems method of the OutlookImporter class in order to import all items from Outlook to the specified schedule. More complicated scenarios are possible. For example you can filter certain items during the importing process by attaching a handler to the ItemImporting event of the OutlookImporter class.

The body of the event handler of the 'Export' button will look similarly.

C#

private void _btnExport_Click(object sender, System.EventArgs e)
{
OutlookExporter exporter = new OutlookExporter(calendar.Schedule);
exporter.ExportItems();
}

Visual Basic

Private Sub _btnExport_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles _btnExport.Click

Dim exporter As New OutlookExporter(calendar.Schedule)
exporter.ExportItems()

End Sub

5. Build and run

Compile and run the application. Click the 'Import' button to import all items from Outlook into out application. Click the 'Export' button to export all items from the application to Outlook.


Tutorial 8: Creating Custom Themes

This tutorial demonstrates how to create custom themes for MindFusion.Scheduling using the MindFusion Theme Editor and how to integrate your custom themes into an application.

1. Create a new theme using the Theme Editor

Start the Theme Editor. The Theme Editor (ThemeEditor.exe) is usually found in the directory where you have installed MindFusion.Scheduling. It can also be accessed from the Windows' Start menu. For more information on how to use the editor, please refer to the Theme Editor topic in this documentation.

Add a new theme using the Theme -> New menu. Enter a valid C# identifier for the theme name because it will be used as a name of the theme class when the source code of the theme is generated. Once you accept the theme name, the theme is created and placed in the Themes list on the left. Double-click on the theme name to open a form where you can edit various theme properties. By default, the new theme is based on the Standard predefined theme and is using the SingleMonth view for a preview.

You can now setup various appearance properties in the property grid on the left, as you would have done if you were working with a MindFusion.Scheduling control in an application. For the purposes of this tutorial we will set the following properties:

1. Navigate to MonthSettings.ShowDayOfWeek property in the property grid and change its value to Disabled. This will cause the days of the week to be hidden.

2. Navigate to HeaderBrush property of the MonthSettings.Style and click on the drop down arrow next to its value in the property grid to display the drop-down editor. Select LinearGradientBrush and choose 270 for the brush angle and "180, 220, 180" and "60, 120, 60" for both colors respectively. This will fill the header of the control in the SingleMonth view with a green linear brush.

3. In the MonthSettings.Style set BorderBottomColor, BorderLeftColor, BorderRightColor and BorderTopColor to DarkGreen, and BorderBottomWidth, BorderLeftWidth, BorderRightWidth and BorderTopWidth to 1. This will draw a thin dark green line around the entire control.

4. Finally set Brush property MonthSettings.Style to a solid brush with color "238, 255, 238".

Our new custom theme is now ready. You can optionally save the theme via the File -> Save menu if you intend to make some changes in the future.

There are two ways to integrate the theme into your application now. You can copy the theme's source code and paste it directly into your application or you can compile the theme in an external dll file and reference this dll file in your project. In the next step we will examine the second technique since it requires a bit more efforts.

Note

The theme created above is also available in the Tutorial8.theme file. This file is located in the Tutorial8 project folder.

2. Compile the theme

Before compilation, you have to specify the name of the output dll file as well as references to the MindFusion.Scheduling.dll and MindFusion.Common.dll, both of which are used during compilation. To do so, select Options -> Settings from the editor menu. You can optionally select a code provider (either C# of VB.NET) and a namespace for your theme class.

Compile the theme using Options -> Compile or by pressing F7.

Note

It is recommended that you copy the dll file containing the theme to the folder containing the referenced MindFusion.Scheduling.dll and MindFusion.Common.dll files. Otherwise, there will be problems later when using the theme in an end-user application.

3. Create a sample application

Create a new application in the Visual Studio and add a Calendar control to its main form as described in steps 1 and 2 in Tutorial 1: Getting Started.

4. Use the custom theme

In order to use the custom theme in the design environment of the Visual Studio, you have to add the theme to the toolbox. This is done using the standard method of adding components to the toolbox, that is, right-click on the toolbox, select "Customize toolbox", and then navigate to the theme's dll file. Once the theme is added to the toolbox, you can double-click on it while editing the application's form or click on it and drag it to the form. This will create a new instance of the theme on this form.

To associate this instance with the Calendar control, select the control on the form and go to the Properties window (The properties window is accessed through the View -> Properties Window menu). Navigate to the CustomTheme property in the property grid and click on the drop-down arrow displayed next to the property value. Select your custom theme in the drop-down list, which appears (Note: Sometimes the name of your custom theme might not be visible in this list right away. In this case simply close the form and reopen it again.).

Now your custom theme is applied to the control. You should see the green header, background and frame visible in the design environment.

5. Build and run

Compile and run the application. Here is what it should look like:


Tutorial 9: Binding to a Data Source

This tutorial will show you how to integrate database serialization in your project.

1. Create and initialize a new Windows Forms application project

Follow steps 1 through 3 from Tutorial 1: Getting Started.

Set CurrentView to WeekRange, Date to Jan 1, 2006 and EndDate to Mar 1, 2006, respectively.

2. Add the data source

Select Data -> Add New Data Source from the Visual Studio menu. This will display the Data Source Configuration Wizard, which will automate the process of adding a new data source to your application.

In the dialog that appears, select 'Database', then click 'Next'.

On the following step click the 'New Connection' button. Since we will use the Planner.mdb file for a database, select 'Microsoft Access Database File' for the type of the data source. Locate the mdb file (which is usually available in the main installation folder) and click 'OK'.

When you click 'Next' to go to the next step of the wizard will ask you whether to copy the database file to the output directory of your project each time it is build. Confirm. Save the connection string in the configuration file of your application in the next step and continue.

Then you need to select the database objects you would like to be included in your data set. Mark all tables. Finally, enter the name of the data set and click 'Finish'.

3. Rebuild the project

In order to use the data adapters created by the wizard in the previous step you need to rebuild your project. At this time the project should compile without errors. When the project is compiled, a new component category will appear in the Visual Studio Toolbox. The category is named after your project (that is, 'Tutorial9 Components' in this particular case) and contains the automatically created data set as well as data adapter wrappers for all selected tables.

4. Bind MindFusion.Scheduling to the data source

Select the Calendar control on the form and go to the Properties window. Locate the DataSource property under the Data category and click the down arrow, which appears next to the property value. In the drop-down window expand 'Other Data Sources'. The data set we created in step 2 should appear under 'Project Data Sources'. Click on it to select it as a data source. This will automatically create an instance of the data set on the form and will bind this instance to the Calendar control through a new BindingSource object.

To associate the tables from the data set with the appropriate data collections in the Calendar control, set the values of the data member properties to the name of their corresponding table. For example, the ContactsDataMember property should be set to "Contacts", and so on. Once all data members are set, continue to the next step.

Navigate back to the 'Tutorial9 Components' section in the toolbox and create one instance of each table adapter, by dragging the adapter from the toolbox to the form.

5. Perform serialization

Add two buttons on the form named 'Save' and 'Load' accordingly. Create an event handler for each of the buttons by double-clicking on them. In the event handler of the 'Save' button add the following code.

C#

calendar1.SaveToDataSource(
reminderTableAdapter1,
styleTableAdapter1,
customBrushesTableAdapter1,
contactTableAdapter1,
locationTableAdapter1,
resourceTableAdapter1,
taskTableAdapter1,
itemTableAdapter1,
itemContactsTableAdapter1,
itemResourcesTableAdapter1,
recurrenceTableAdapter1,
recurrenceExceptionTableAdapter1,
recurrenceExceptionsTableAdapter1);

Visual Basic

calendar1.SaveToDataSource( _
reminderTableAdapter1, _
styleTableAdapter1, _
customBrushesTableAdapter1, _
contactTableAdapter1, _
locationTableAdapter1, _
resourceTableAdapter1, _
taskTableAdapter1, _
itemTableAdapter1, _
itemContactsTableAdapter1, _
itemResourcesTableAdapter1, _
recurrenceTableAdapter1, _
recurrenceExceptionTableAdapter1, _
recurrenceExceptionsTableAdapter1)

The code above assumes that all objects created on the form so far use their default names. If you have changed the name of an object, you have to update the event handler code to reflect this.

The contents of the 'Load' button will look like this:

C#

calendar1.Schedule.Clear();
plannerDataSet.Clear();

reminderTableAdapter1.Fill(plannerDataSet.Reminder);
styleTableAdapter1.Fill(plannerDataSet.Style);
customBrushesTableAdapter1.Fill(plannerDataSet.CustomBrushes);
contactTableAdapter1.Fill(plannerDataSet.Contact);
locationTableAdapter1.Fill(plannerDataSet.Location);
resourceTableAdapter1.Fill(plannerDataSet.Resource);
taskTableAdapter1.Fill(plannerDataSet.Task);
itemTableAdapter1.Fill(plannerDataSet.Item);
itemContactsTableAdapter1.Fill(plannerDataSet.ItemContacts);
itemResourcesTableAdapter1.Fill(plannerDataSet.ItemResources);
recurrenceTableAdapter1.Fill(plannerDataSet.Recurrence);
recurrenceExceptionTableAdapter1.Fill(plannerDataSet.RecurrenceException);
recurrenceExceptionsTableAdapter1.Fill(plannerDataSet.RecurrenceExceptions);

calendar1.LoadFromDataSource();

Visual Basic

calendar1.Schedule.Clear()
plannerDataSet.Clear()

reminderTableAdapter1.Fill(plannerDataSet.Reminder)
styleTableAdapter1.Fill(plannerDataSet.Style)
customBrushesTableAdapter1.Fill(plannerDataSet.CustomBrushes)
contactTableAdapter1.Fill(plannerDataSet.Contact)
locationTableAdapter1.Fill(plannerDataSet.Location)
resourceTableAdapter1.Fill(plannerDataSet.Resource)
taskTableAdapter1.Fill(plannerDataSet.Task)
itemTableAdapter1.Fill(plannerDataSet.Item)
itemContactsTableAdapter1.Fill(plannerDataSet.ItemContacts)
itemResourcesTableAdapter1.Fill(plannerDataSet.ItemResources)
recurrenceTableAdapter1.Fill(plannerDataSet.Recurrence)
recurrenceExceptionTableAdapter1.Fill(plannerDataSet.RecurrenceException)
recurrenceExceptionsTableAdapter1.Fill(plannerDataSet.RecurrenceExceptions)

calendar1.LoadFromDataSource()

6. Build and run

Compile and run the application. Try saving and loading schedules by clicking on the two buttons.


Reference

© 2009 MindFusion


MindFusion Namespace
Enumerations

Enumerations

Enumeration | Description
Alignment | Specifies the alignment of contents relative to the layout rectangle.


MindFusion.Alignment Enumeration

Alignment Enumeration
See Also

Specifies the alignment of contents relative to the layout rectangle.

Namespace: MindFusion
Assembly: MindFusion.Scheduling

Syntax

C#

public enum Alignment
Visual Basic

Public Enumeration Alignment

Members

Member name | Description
Far | The contents are aligned far from the origin of the layout rectangle. In a left-to-right layout, the far position is right. In a right-to-left layout, the far position is left.
Near | The contents are aligned near the layout rectangle. In a left-to-right layout, the near position is left. In a right-to-left layout, the near position is right.
None | The contents are unavailable.
Unspecified | Unspecified.

See Also

MindFusion Namespace


MindFusion.Charting Namespace
Classes Delegates Enumerations

Classes

Class | Description
AxesChart | A base class for all charts that use the rectangular coordinate system.
AxisSettings | A class for specifying the settings of chart axes.
Bar | Represents a bar in a bar chart.
BarChart | A class for drawing bar charts.
Bubble | Represents a bubble in bubble charts.
Chart | Base class for all chart types - bars, pies, areas, lines, or radars.
ChartElement | Base class for all chart elements - Bar, Line, Scatter, Bubble, PiePiece and RadarPiece.
DoubleCollection | Represents a strongly typed collection of double numbers.
FunctionArgs | A class specified for setting the arguments of chart functions.
LabelsCollection | Represents a strongly typed collection of StringCollection objects.
Line | A class that represents line objects in line charts.
LineChart | A class specified for drawing line, area, bubble and scatter charts.
Margins | Class for setting the space around chart elements.
PieChart | A class specified for drawing pie charts.
PiePiece | A class that represents pie piece objects in pie charts.
RadarChart | A class used to draw radar charts.
RadarPiece | A class that represents radar piece objects in radar charts.
Scatter | A class that represents scatter objects in scatter charts.
SeriesCollection | Represents a list with DoubleCollection-s for specifying the data in multi-series charts.
ShapeCollection | Represents a strongly typed collection of shapes.
ShapeConverter | Provides an EnumConverter to convert Shape objects to and from various other representations.
StringCollection | Represents a collection with string labels.

Delegates

Delegate | Description
CalculateFunctionDelegate | Invokes a custom function that calculates the values for the chart.
PathOperator | Calls a method that draws or hit tests the path specified.

Enumerations

Enumeration | Description
Alignment | Specifies alignment styles for labels at the chart axis.
AxisLabelType | Specifies the type of labels drawn at chart axis.
BarSeriesLayout | Specifies the layout of bars in series.
BarType | Specifies the different types of bar charts that can be drawn.
Border | Specifies the type of border drawn around chart objects.
DataFormat | Specifies the type of data values.
DateTimeFormat | Specifies formats for DateTime values.
GridType | Specifies the type of the grid.
LabelOrientation | Specifies different text orientation styles for chart labels.
LabelType | Specifies the type of labels drawn at chart elements.
LineTypes | Specifies the different types of line/area/scatter/bubble charts that can be drawn.
NumberFormat | Specifies formats for numerical values.
PieType | Specifies the possible type of pie chart that can be drawn.
Position | Specifies the position of different chart elements.
RadarStyle | Specifies the drawing styles for a radar chart.
RadarType | Specifies the different types of radar charts that can be drawn.
Shape | Specifies the type of shapes that can be drawn at chart data points.
SortOrder | Specifies different options for sorting numbers in data series.
SortSeriesBy | Specifies how charts with more than one data series are arranged.
Summary | Specifies type of summary operations that can be performed over the chart values.


MindFusion.Charting.Alignment Enumeration

Alignment Enumeration

Specifies alignment styles for labels at the chart axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum Alignment
Visual Basic

Public Enumeration Alignment

Members

Member name | Description
Begin | The label is drawn at the beginning of the axis.
Center | The label is drawn in the center of the axis.
End | The label is drawn at the end of the axis.

Remarks

Labels that use the Alignment enumeration are:

  • Division and axis labels. Their position is specified with the AxisSettings object for the axis they refer to. The property is called AxisSettings.TitleLabelAlignment.
  • The chart legend. Legend is drawn when LegendLabels is not an empty list. The location of the legend is set with LegendPosition. LegendAlignment specifies the alignment of the legend.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.AxesChart Class

AxesChart Class
Remarks See Also

A base class for all charts that use the rectangular coordinate system.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public abstract class AxesChart : Chart
Visual Basic

Public MustInherit Class AxesChart
Inherits Chart

Remarks

AxesChart inherits properties and methods from its base class Chart.

Chart axes can be drawn with a shadow, which length is set with the Depth3D property. Use AxisShadowBrush to set the brush for the axis shadow. AxisPen specifies the pen for the chart axes.

Every axes chart can be drawn with a grid. You can choose among several grid types by using the GridType property. If the grid is Crossed, its density is set with GridWidth. The stripes of the grid are filled with GridBrush and AltGridBrush. The grid is drawn with the GridPen.

Custom grid points are set with HorGridPoints and VertGridPoints. They are drawn with HorGridPens and VertGridPens. Stripes in custom grids are filled with HorGridBrushes and VertGridBrushes.

Custom grids can have grid labels. They are set wtih XGridLabels, YGridLabels and Y2GridLabels. The orientation of the labels at the X-axis is set with XGridLabelsOrientation. If you want pointers to the grid labels, use GridLabelPointer.

The summary graphics or parts of graphics are drawn with SummaryBrushes and SummaryPens. AddCustomSummary method adds a custom summary value to the list of summaries. Graphics, which data is bound to the Y2-axis are drawn with the Y2ChartBrushes and Y2ChartPens.

The AxisSettings class holds the settings for the chart axes - chart label, length, type of axis labels, label prefix and suffix, data formatting and so on. The properties for each chart axis are called XAxisSettings, YAxisSettings and Y2AxisSettings.

The chart data is set with XData and YData. Use Y2Data if you want to draw graphics for the second Y-axis, parallel to the first one. Data can be either numbers or DateTime values or any other format that can safely be converted to numbers / DateTime values using the standard .NET type converters.

Charts can be drawn with an Offset from the start of the coordinate system.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Chart
MindFusion.Charting.AxesChart

See Also

AxesChart Members
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart Members

AxesChart Members
Constructors Properties Methods

A base class for all charts that use the rectangular coordinate system.

The following tables list the members exposed by the AxesChart type.

Protected Constructors

Name | Description
AxesChart | Creates a new instance of the AxesChart class.

Public Properties

Name | Description
AltGridBrush | Gets or sets the alternative brush for drawing the chart's grid.
AxisPen | Gets or sets the pen, which is used to draw the chart axes.
AxisShadowBrush | Gets or sets the brush, which is used when drawing the shadow of the chart axes.
ChartBackgroundBrush | Gets or sets the brush for the plot area.
Depth3D | Gets or sets the shadow depth for 3D charts.
DistBtwSeries | Gets or sets the distance among chart series.
GridBrush | Gets or sets the brush for filling odd grid stripes.
GridLabelOffset | Gets or sets the offset of grid labels.
GridLabelPointer | Gets or sets the length of the pointer to the grid labels.
GridLabelsAtLines | Gets or sets the position of grid labels.
GridOutlinePen | Gets or sets the pen for the grid border.
GridPen | Specifies the pen for drawing the chart grid.
GridType | Gets or sets the type of the chart grid.
GridWidth | Gets or sets the distance between adjacent grid points in chess grids.
HorGridBrushes | Gets or sets the brushes for drawing horizontal grid stripes in custom grids.
HorGridPens | Gets or sets the pens for drawing horizontal grid stripes in custom grids.
HorGridPoints | Gets or sets the positions of horizontal lines in custom grids.
Horizontal | Gets or sets the orientation of the chart.
Offset | Gets or sets the offset from the zero point to the beginning of the chart graphics.
PlotAreaMargins | Gets or sets the margins of the plot area.
SummaryBrushes | Gets or sets the brushes that are used for drawing summary parts in charts.
SummaryPens | Gets or sets the pens for drawing summary parts.
SummaryValues | Gets or sets the summary operations performed on chart data.
VertGridBrushes | Gets or sets the brushes for filling vertical stripes in custom grids.
VertGridPens | Gets or sets the pens for drawing vertical grid lines in custom grids.
VertGridPoints | Gets or sets the positions of vertical lines in custom grids.
XAxisSettings | Gets or sets the appearance settings for the X-axis.
XGridLabelBrushes | Gets or sets the brushes for drawing labels at the X-axis in custom grids.
XGridLabels | Gets or sets the labels drawn at the X-axis in custom grids.
XGridLabelsOrientation | Gets or sets the orientation of labels drawn at the X-axis in custom grids.
XLabels | Gets or sets custom labels drawn at the X-axis.
Y2AxisSettings | Gets os sets the appearance settings for the Y2-axis.
Y2ChartBrushes | Gets or sets the brushes for drawing Y2-bound chart graphics.
Y2ChartPens | Gets or sets the pens for drawing Y2 - bound chart graphics.
Y2Data | Gets or sets the data for Y2-bound graphics or the radiuses for bubbles in bubble charts.
Y2GridLabelBrushes | Gets or sets the brushes for drawing labels at the Y2-axis in custom grids.
Y2GridLabels | Gets or sets the labels drawn at the Y2-axis in custom grids.
Y2GridLabelsOrientation | Gets or sets the orientation of grid labels at the Y2-axis in custom grids.
Y2Labels | Gets or sets custom labels for the second Y-axis.
YAxisSettings | Gets or set the appearance settings for the Y-axis.
YGridLabelBrushes | Gets or sets the brushes for drawing custom grid labels at the Y-axis.
YGridLabels | Gets or sets custom grid labels at the Y-axis.
YGridLabelsOrientation | Gets or sets the orientation of grid labels drawn at the Y-axis.
YLabels | Gets or sets the labels drawn at the Y-axis.

Public Methods

Name | Description
AddCustomSummary | Overloaded. Adds a value to the list of summary values that are drawn in the chart.
ClearData | Clears all data and labels.
ClearDataBoundLists | Clears all IList properties that support data binding.
Clone | Creates an exact copy of the current AxesChart object.
DrawChart | Draws parts of the chart common for all charts with axes.

Protected Methods

Name | Description
ClearChartSpecificData | Clears data that is specific for bar or line charts.

See Also

AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart Constructor

AxesChart Constructor

Creates a new instance of the AxesChart class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

protected AxesChart ()
Visual Basic

Protected Sub New ()

See Also

AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart Methods

AxesChart Methods

Public Methods

Name | Description
AddCustomSummary | Overloaded. Adds a value to the list of summary values that are drawn in the chart.
ClearData | Clears all data and labels.
ClearDataBoundLists | Clears all IList properties that support data binding.
Clone | Creates an exact copy of the current AxesChart object.
DrawChart | Draws parts of the chart common for all charts with axes.

Protected Methods

Name | Description
ClearChartSpecificData | Clears data that is specific for bar or line charts.

See Also

AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.AddCustomSummary Method

AxesChart.AddCustomSummary Method

Adds a value to the list of summary values that are drawn in the chart.

Overload List

Name | Description
AxesChart.AddCustomSummary (Double, String) | Adds a value to the list of summary values that are drawn in the chart.
AxesChart.AddCustomSummary (Int32, String) | Adds a value to the list of summary values that are drawn in the chart.
AxesChart.AddCustomSummary (Int64, String) | Adds a value to the list of summary values that are drawn in the chart.
AxesChart.AddCustomSummary (Single, String) | Adds a value to the list of summary values that are drawn in the chart.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.AddCustomSummary Method (Double, String)

AxesChart.AddCustomSummary Method (Double, String)
See Also

Adds a value to the list of summary values that are drawn in the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void AddCustomSummary (
double summaryValue,
string summaryText
)
Visual Basic

Public Sub AddCustomSummary ( _
summaryValue As Double, _
summaryText As String _
)

Parameters

summaryValue
A double value for the summary.
summaryText
String that describes the summary value.

Remarks

The method is used to add a summary value that is not any of the Summary enumeration members. The description is drawn when the LabelType for this axis is set to AxisLabelType.CustomText. If axis labels show DateTime values or DataFormat.Number, the format of the summary value is set by DateTimeFormat or NumberFormat.

See Also

AddCustomSummary Method Overload List
AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.AddCustomSummary Method (Int32, String)

AxesChart.AddCustomSummary Method (Int32, String)
See Also

Adds a value to the list of summary values that are drawn in the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void AddCustomSummary (
int summaryValue,
string summaryText
)
Visual Basic

Public Sub AddCustomSummary ( _
summaryValue As Integer, _
summaryText As String _
)

Parameters

summaryValue
an integer value for the summary.
summaryText
String that describes the summary value.

Remarks

The method is used to add a summary value that is not any of the Summary enumeration members. The description is drawn when the LabelType for this axis is set to AxisLabelType.CustomText. If axis labels show DateTime values or Numbers, the format of the summary value is set by DateTimeFormat or NumberFormat.

See Also

AddCustomSummary Method Overload List
AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.AddCustomSummary Method (Int64, String)

AxesChart.AddCustomSummary Method (Int64, String)
See Also

Adds a value to the list of summary values that are drawn in the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void AddCustomSummary (
long summaryValue,
string summaryText
)
Visual Basic

Public Sub AddCustomSummary ( _
summaryValue As Long, _
summaryText As String _
)

Parameters

summaryValue
The numerical value for the summary.
summaryText
String that describes the summary value.

Remarks

The method is used to add a summary value that is not any of the Summary enumeration members. The description is drawn when the LabelType for this axis is set to AxisLabelType.CustomText. If axis labels show DateTime values or Numbers the format of the summary value is set by DateTimeFormat or NumberFormat.

See Also

AddCustomSummary Method Overload List
AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.AddCustomSummary Method (Single, String)

AxesChart.AddCustomSummary Method (Single, String)
See Also

Adds a value to the list of summary values that are drawn in the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void AddCustomSummary (
float summaryValue,
string summaryText
)
Visual Basic

Public Sub AddCustomSummary ( _
summaryValue As Single, _
summaryText As String _
)

Parameters

summaryValue
The numerical value for the summary.
summaryText
String that describes the summary value.

Remarks

The method is used to add a summary value that is not any of the Summary enumeration members. The description is drawn when the LabelType for this axis is set to AxisLabelType.CustomText. If axis labels show DateTime values or Numbers, the format of the summary value is set by DateTimeFormat or NumberFormat.

See Also

AddCustomSummary Method Overload List
AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.ClearChartSpecificData Method

AxesChart.ClearChartSpecificData Method

Clears data that is specific for bar or line charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

protected virtual void ClearChartSpecificData ()
Visual Basic

Protected Overridable Sub ClearChartSpecificData ()

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.ClearData Method

AxesChart.ClearData Method

Clears all data and labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override void ClearData ()
Visual Basic

Public Overrides Sub ClearData ()

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.ClearDataBoundLists Method

AxesChart.ClearDataBoundLists Method

Clears all IList properties that support data binding.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override void ClearDataBoundLists ()
Visual Basic

Public Overrides Sub ClearDataBoundLists ()

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.Clone Method

AxesChart.Clone Method

Creates an exact copy of the current AxesChart object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

The cloned AxesChart.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.DrawChart Method

AxesChart.DrawChart Method

Draws parts of the chart common for all charts with axes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override void DrawChart ()
Visual Basic

Public Overrides Sub DrawChart ()

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart Properties

AxesChart Properties

Public Properties

Name | Description
AltGridBrush | Gets or sets the alternative brush for drawing the chart's grid.
AxisPen | Gets or sets the pen, which is used to draw the chart axes.
AxisShadowBrush | Gets or sets the brush, which is used when drawing the shadow of the chart axes.
ChartBackgroundBrush | Gets or sets the brush for the plot area.
Depth3D | Gets or sets the shadow depth for 3D charts.
DistBtwSeries | Gets or sets the distance among chart series.
GridBrush | Gets or sets the brush for filling odd grid stripes.
GridLabelOffset | Gets or sets the offset of grid labels.
GridLabelPointer | Gets or sets the length of the pointer to the grid labels.
GridLabelsAtLines | Gets or sets the position of grid labels.
GridOutlinePen | Gets or sets the pen for the grid border.
GridPen | Specifies the pen for drawing the chart grid.
GridType | Gets or sets the type of the chart grid.
GridWidth | Gets or sets the distance between adjacent grid points in chess grids.
HorGridBrushes | Gets or sets the brushes for drawing horizontal grid stripes in custom grids.
HorGridPens | Gets or sets the pens for drawing horizontal grid stripes in custom grids.
HorGridPoints | Gets or sets the positions of horizontal lines in custom grids.
Horizontal | Gets or sets the orientation of the chart.
Offset | Gets or sets the offset from the zero point to the beginning of the chart graphics.
PlotAreaMargins | Gets or sets the margins of the plot area.
SummaryBrushes | Gets or sets the brushes that are used for drawing summary parts in charts.
SummaryPens | Gets or sets the pens for drawing summary parts.
SummaryValues | Gets or sets the summary operations performed on chart data.
VertGridBrushes | Gets or sets the brushes for filling vertical stripes in custom grids.
VertGridPens | Gets or sets the pens for drawing vertical grid lines in custom grids.
VertGridPoints | Gets or sets the positions of vertical lines in custom grids.
XAxisSettings | Gets or sets the appearance settings for the X-axis.
XGridLabelBrushes | Gets or sets the brushes for drawing labels at the X-axis in custom grids.
XGridLabels | Gets or sets the labels drawn at the X-axis in custom grids.
XGridLabelsOrientation | Gets or sets the orientation of labels drawn at the X-axis in custom grids.
XLabels | Gets or sets custom labels drawn at the X-axis.
Y2AxisSettings | Gets os sets the appearance settings for the Y2-axis.
Y2ChartBrushes | Gets or sets the brushes for drawing Y2-bound chart graphics.
Y2ChartPens | Gets or sets the pens for drawing Y2 - bound chart graphics.
Y2Data | Gets or sets the data for Y2-bound graphics or the radiuses for bubbles in bubble charts.
Y2GridLabelBrushes | Gets or sets the brushes for drawing labels at the Y2-axis in custom grids.
Y2GridLabels | Gets or sets the labels drawn at the Y2-axis in custom grids.
Y2GridLabelsOrientation | Gets or sets the orientation of grid labels at the Y2-axis in custom grids.
Y2Labels | Gets or sets custom labels for the second Y-axis.
YAxisSettings | Gets or set the appearance settings for the Y-axis.
YGridLabelBrushes | Gets or sets the brushes for drawing custom grid labels at the Y-axis.
YGridLabels | Gets or sets custom grid labels at the Y-axis.
YGridLabelsOrientation | Gets or sets the orientation of grid labels drawn at the Y-axis.
YLabels | Gets or sets the labels drawn at the Y-axis.

See Also

AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.AltGridBrush Property

AxesChart.AltGridBrush Property

Gets or sets the alternative brush for drawing the chart's grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush AltGridBrush { get; set; }
Visual Basic

Public Property AltGridBrush As Brush

Property Value

A MindFusion.Drawing.Brush object that represents the alternative grid brush.

Remarks

AltGridBrush is used for filling the even grid stripes when the GridType is not GridType.None or GridType.Custom. The odd grid stripes are filled with GridBrush. The grid stripes are drawn with the GridPen.

When the GridType is GridType.Custom the grid stripes are painted with HorGridBrushes and VertGridBrushes.

Default value for the AltGridBrush is null (no brush).

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.AxisPen Property

AxesChart.AxisPen Property

Gets or sets the pen, which is used to draw the chart axes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen AxisPen { get; set; }
Visual Basic

Public Property AxisPen As Pen

Property Value

A value of type the MindFusion.Drawing.Pen class.

Remarks

The property is used for drawing all chart axes. If the chart is of 3D type the axis shadow is drawn with AxisShadowBrush. If no AxisShadowBrush is specified, a shadow brush a little darker than the AxisPen is created.

Default value of the AxisPen property is black pen with width 1.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.AxisShadowBrush Property

AxesChart.AxisShadowBrush Property

Gets or sets the brush, which is used when drawing the shadow of the chart axes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush AxisShadowBrush { get; set; }
Visual Basic

Public Property AxisShadowBrush As Brush

Property Value

An object of type MindFusion.Drawing.Brush class.

Remarks

The property specifies the brush for drawing axes shadows in 3D charts.

Axes are drawn with shadows when the type of the chart (LineType, BarType) is set to a 3D chart and Depth3D is greater than 0. If the chart has multiple series, its shadow is drawn larger so that all series could fit in.

Default value for the AxisShadowBrush property is a semitransparent SolidBrush with alpha value 100 and color equal to the color of the AxisPen.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
BarSeriesLayout
ChartBackgroundBrush


MindFusion.Charting.AxesChart.ChartBackgroundBrush Property

AxesChart.ChartBackgroundBrush Property

Gets or sets the brush for the plot area.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush ChartBackgroundBrush { get; set; }
Visual Basic

Public Property ChartBackgroundBrush As Brush

Property Value

An instance of MindFusion.Drawing.Brush class.

Remarks

The property is used for drawing the area of the chart background that lies between the chart axes. If the ChartBackgroundBrush is not set, the BackgroundBrush is used for drawing the whole chart background.

Value for the property can be any brush that is derived from MindFusion.Drawing.Brush - SolidBrush, LinearGradientBrush, PathGradientBrush and so on.

Default value for the ChartBackgroundBrush property is null, that is, the plot area is drawn with the BackgroundBrush.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.Depth3D Property

AxesChart.Depth3D Property

Gets or sets the shadow depth for 3D charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float Depth3D { get; set; }
Visual Basic

Public Property Depth3D As Single

Property Value

A float value.

Remarks

The property is used only by 3D charts. If the chart draws more than one series, the Depth3D property is multiplied by the count of the series. Stacked bar charts make an exception since their series are drawn as sections in a single bar.

Default value for the Depth3D property is 20f.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.DistBtwSeries Property

AxesChart.DistBtwSeries Property

Gets or sets the distance among chart series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float DistBtwSeries { get; set; }
Visual Basic

Public Property DistBtwSeries As Single

Property Value

A float value.

Remarks

The property specifies the distance among separate graphics in multi-series 3D charts. Default value for the DistBtwSeries property is 10f.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.GridBrush Property

AxesChart.GridBrush Property

Gets or sets the brush for filling odd grid stripes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush GridBrush { get; set; }
Visual Basic

Public Property GridBrush As Brush

Property Value

A MindFusion.Drawing.Brush object that represents the grid brush.

Remarks

GridBrush is used for filling the odd grid stripes when the GridType is not GridType.None or GridType.Custom. The even grid stripes are filled with AltGridBrush. The grid stripes are drawn with the GridPen.

Grid stripes in custom grids are painted with HorGridBrushes and VertGridBrushes.

Default value for the GridBrush is null (no brush).

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
GridWidth


MindFusion.Charting.AxesChart.GridLabelOffset Property

AxesChart.GridLabelOffset Property

Gets or sets the offset of grid labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float GridLabelOffset { get; set; }
Visual Basic

Public Property GridLabelOffset As Single

Property Value

A float number.

Remarks

The property specifies the offset of custom grid labels to the nearest chart object - the grid bracket (if GridLabelPointer is greater than zero), the axis labels (if LabelType is not Empty) or the axis. The property sets the offset for labels at all axes - X, Y and Y2 (if present).

The property is used only with custom grids, for example, the GridType is set to Custom. Grid labels are set with XGridLabels, YGridLabels and Y2GridLabels.

Default value for the GridLabelOffset property is 5f.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
GridOutlinePen


MindFusion.Charting.AxesChart.GridLabelPointer Property

AxesChart.GridLabelPointer Property

Gets or sets the length of the pointer to the grid labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float GridLabelPointer { get; set; }
Visual Basic

Public Property GridLabelPointer As Single

Property Value

A float value that specifies the length.

Remarks

The property specifies the length of the grid label pointer for grid labels at all chart axes - X, Y and Y2 (if present). Pointers are not drawn when the labels are located at grid lines if GridLabelsAtLines is true.

Grid labels are drawn only in charts which GridType is set to GridType.Custom. The labels are set with XGridLabels, YGridLabels and Y2GridLabels.

Default value for the GridLabelPointer property is 5f.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
Chart Parts: Grid


MindFusion.Charting.AxesChart.GridLabelsAtLines Property

AxesChart.GridLabelsAtLines Property

Gets or sets the position of grid labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool GridLabelsAtLines { get; set; }
Visual Basic

Public Property GridLabelsAtLines As Boolean

Property Value

true if labels are drawn at grid lines; otherwise false.

Remarks

The property specifies where custom grid labels are drawn - in the middle of the grid segment or at the grid line they refer to. If the labels are drawn at grid lines no pointing bracket is drawn.

The property is used only when the GridType is GridType.Custom. Custom grid labels are set with XGridLabels, YGridLabels and Y2GridLabels.

Default value for the GridLabelsAtLines property is false.

See Also

XGridLabelBrushes
YGridLabelBrushes
Y2GridLabelBrushes
HorGridPoints
VertGridPoints
AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.GridOutlinePen Property

AxesChart.GridOutlinePen Property

Gets or sets the pen for the grid border.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen GridOutlinePen { get; set; }
Visual Basic

Public Property GridOutlinePen As Pen

Property Value

An object of type MindFusion.Drawing.Pen.

Remarks

The pen draws the border around the grid. It can be null and in this case, no outlining is drawn.

Default value for the GridOutlinePen property is a black pen, width 1.

See Also

GridType
AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.GridPen Property

AxesChart.GridPen Property

Specifies the pen for drawing the chart grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen GridPen { get; set; }
Visual Basic

Public Property GridPen As Pen

Property Value

An object of type MindFusion.Drawing.Pen.

Remarks

The GridPen is used for drawing the chart grid when the GridType is not GridType.None or GridType.Custom. The grid stripes are painted with GridBrush and AltGridBrush. You can have a grid that has only stripes and no lines are drawn. In this case, set GridPen to null.

The border of the grid is drawn with GridOutlinePen.

Default value for the GridPen is null, that is, no grid is drawn.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.GridType Property

AxesChart.GridType Property

Gets or sets the type of the chart grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public GridType GridType { get; set; }
Visual Basic

Public Property GridType As GridType

Property Value

One of the GridType Enumeration members.

Remarks

Grid can be drawn at all charts with axes. When the grid is of type GridType.Chess its width is set by GridWidth.

When the grid is custom, the positions of grid lines are specified with HorGridPoints and VertGridPoints. For other grid types, except GridType.None, the width is calculated automatically based on the scale of the axes.

Default value for the GridType property is GridType.None.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.GridWidth Property

AxesChart.GridWidth Property

Gets or sets the distance between adjacent grid points in chess grids.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float GridWidth { get; set; }
Visual Basic

Public Property GridWidth As Single

Property Value

A float value.

Remarks

The property is considered only for GridType.Chess. Default value for the GridWidth property is 0.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
GridType Enumeration
GridBrush


MindFusion.Charting.AxesChart.HorGridBrushes Property

AxesChart.HorGridBrushes Property

Gets or sets the brushes for drawing horizontal grid stripes in custom grids.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection HorGridBrushes { get; set; }
Visual Basic

Public Property HorGridBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

The GridType should be set to GridType.Custom and HorGridPoints should not be empty. If the brushes are less than the grid stripes to be filled, they are used in a cycle.

Default value for the HorGridBrushes property is an empty BrushCollection, in this case no stripes are drawn.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
HorGridPens


MindFusion.Charting.AxesChart.HorGridPens Property

AxesChart.HorGridPens Property

Gets or sets the pens for drawing horizontal grid stripes in custom grids.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PenCollection HorGridPens { get; set; }
Visual Basic

Public Property HorGridPens As PenCollection

Property Value

An object of type MindFusion.Drawing.PenCollection.

Remarks

The GridType should be set to GridType.Custom and HorGridPoints should not be empty. If the count of the pens is less than the count of the stripes, they are used in a cycle.

Default value for the HorGridPens is an empty PenCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
HorGridBrushes


MindFusion.Charting.AxesChart.HorGridPoints Property

AxesChart.HorGridPoints Property

Gets or sets the positions of horizontal lines in custom grids.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList HorGridPoints { get; set; }
Visual Basic

Public Property HorGridPoints As IList

Property Value

An object of type .NET IList.

Remarks

HorGridPoints is used when GridType is set to GridType.Custom. The values should range from 0 to 100 with 0 coinciding with the start of the Y-axis and 100 - with its end.

The stripes are drawn with HorGridPens and are filled with HorGridBrushes. You can leave the property empty if you do not need horizontal grid lines.

Default value for the HorGridPoints property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.Horizontal Property

AxesChart.Horizontal Property

Gets or sets the orientation of the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool Horizontal { get; set; }
Visual Basic

Public Property Horizontal As Boolean

Property Value

true if the chart is horizontal; otherwise false.

Remarks

In horizontal bar charts, the Data property specifies values for the X-axis. In vertical bar charts, the Data property specifies values for the Y-axis.

Line charts use data from both XData and YData lists, no matter their orientation. Summary operations are performed on XData for horizontal charts and YData for vertical ones. Bubble charts have no orientation.

Default value for the Horizontal property is false.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
LineChart Class
BarChart Class


MindFusion.Charting.AxesChart.Offset Property

AxesChart.Offset Property

Gets or sets the offset from the zero point to the beginning of the chart graphics.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float Offset { get; set; }
Visual Basic

Public Property Offset As Single

Property Value

A float value.

Remarks

Vertical charts with positive values are shifted rightwards, with offset at the X-axis. If the chart has only negative X-values, it is shifted leftwards. Horizontal charts with positive values are shifted upwards, with offset at the Y-axis. If the chart has only negative Y-values, it is shifted downwards.

The orientation of the chart is set with the Horizontal property.

Default value for the Offset property is 0 (no offset).

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
Data
Horizontal


MindFusion.Charting.AxesChart.PlotAreaMargins Property

AxesChart.PlotAreaMargins Property

Gets or sets the margins of the plot area.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Margins PlotAreaMargins { get; set; }
Visual Basic

Public Property PlotAreaMargins As Margins

Property Value

An instance of Margins class.

Remarks

Use the property to set custom values for the space at any of the plot area sides.

Default value for the PlotAreaMargins property is Margins(0,0,0,0).

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.SummaryBrushes Property

AxesChart.SummaryBrushes Property

Gets or sets the brushes that are used for drawing summary parts in charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection SummaryBrushes { get; set; }
Visual Basic

Public Property SummaryBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

SummaryBrushes are used for filling summary parts in all types of charts that use axes. The summary graphics depend on the type of the chart - in bar charts they are bars, in area charts - areas and so on. If SummaryBrushes are not set, the control creates brushes from the SummaryPen-s, if any.

Summaries are drawn when the SummaryValues property is not an empty list.

Default value for the SummaryBrushes property is an empty BrushCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
BarChart Class
PieChart Class


MindFusion.Charting.AxesChart.SummaryPens Property

AxesChart.SummaryPens Property

Gets or sets the pens for drawing summary parts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PenCollection SummaryPens { get; set; }
Visual Basic

Public Property SummaryPens As PenCollection

Property Value

An object of type MindFusion.Drawing.PenCollection.

Remarks

SummaryPens are used for drawing summary parts in all charts that use axes. The summary graphics depends on the chart type - in line charts it is a line, in bar charts - bar and so on. If SummaryPens are not set, the control uses SummaryBrushes, if any, to create pens from them.

Use SummaryValues to add Summary-s to the chart.

Default value for the SummaryPens property is an empty PenCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
Summary Enumeration


MindFusion.Charting.AxesChart.SummaryValues Property

AxesChart.SummaryValues Property

Gets or sets the summary operations performed on chart data.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList SummaryValues { get; set; }
Visual Basic

Public Property SummaryValues As IList

Property Value

An object of type System.Collection.IList that holds the summaries.

Remarks

SummaryValues enables you to add aggregate operations like min, max, average and so on to the chart values. Use for that the members of the Summary enumeration. You can specify your own summary values with the AddCustomSummary method.

Summary graphics follow the shape of the chart they refer to. In line charts, they are lines, in bar charts - bars, and so on. They are drawn with SummaryPens and SummaryBrushes. The labels for summary charts are the same type as those of the chart's axes.

Summary operations are performed on XData for horizontal line charts and on YData for vertical ones. In bar charts always Data is used.

Default value for the SummaryValues property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
Summary Enumeration


MindFusion.Charting.AxesChart.VertGridBrushes Property

AxesChart.VertGridBrushes Property

Gets or sets the brushes for filling vertical stripes in custom grids.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection VertGridBrushes { get; set; }
Visual Basic

Public Property VertGridBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

Vertical stripes and lines in custom grids are drawn when the VertGridPoints property is not an empty list. The grid lines are drawn with VertGridPens. The GridType should be set to GridType.Custom.

The respective properties for drawing horizontal grid stripes are HorGridPoints, HorGridPens and HorGridBrushes.

Default value for the VertGridBrushes property is an empty BrushCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
HorGridPens


MindFusion.Charting.AxesChart.VertGridPens Property

AxesChart.VertGridPens Property

Gets or sets the pens for drawing vertical grid lines in custom grids.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PenCollection VertGridPens { get; set; }
Visual Basic

Public Property VertGridPens As PenCollection

Property Value

An object of type MindFusion.Drawing.PenCollection.

Remarks

The property specifies the pens for drawing vertical grid lines in custom grids. In this case the grid stripes are filled with brushes from the VertGridBrushes property. The position of the grid lines is specified with VertGridPoints.

Custom grids can have labels at the X-axis. The labels are set with XGridLabels property.

When the GridType is not GridType.Custom, the grid is drawn with the GridPen and the grid stripes are filled with GridBrush and AltGridBrush.

Default value for the VertGridPens property is an empty PenCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
HorGridPens


MindFusion.Charting.AxesChart.VertGridPoints Property

AxesChart.VertGridPoints Property

Gets or sets the positions of vertical lines in custom grids.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList VertGridPoints { get; set; }
Visual Basic

Public Property VertGridPoints As IList

Property Value

An object of type .NET IList.

Remarks

Add to the VertGridPoints property numbers between 0 and 100. Zero coincides with the start of the X-axis and 100 - with its end. Use VertGridPens and VertGridBrushes to specify the pens and brushes for filing the grid stripes. The GridType should be set to GridType.Custom.

The respective properties for drawing horizontal grid stripes are HorGridPoints, HorGridPens and HorGridBrushes.

Default value for the VertGridBrushes property is an empty BrushCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
HorGridPoints


MindFusion.Charting.AxesChart.XAxisSettings Property

AxesChart.XAxisSettings Property

Gets or sets the appearance settings for the X-axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public AxisSettings XAxisSettings { get; set; }
Visual Basic

Public Property XAxisSettings As AxisSettings

Property Value

An object of type AxisSettings class.

Remarks

The property specifies all appearance characteristics of the X-axis: labels, fonts, data format, minimum and maximum value as well the intervals among them, label suffix and prefix, division coefficient and division label and so on.

For more information about the axis properties and their default values, please check the AxisSettings class.

Default value for the XAxisSettings property is a new AxisSettings object. You can access it directly through the XAxisSettings property.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.XGridLabelBrushes Property

AxesChart.XGridLabelBrushes Property

Gets or sets the brushes for drawing labels at the X-axis in custom grids.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection XGridLabelBrushes { get; set; }
Visual Basic

Public Property XGridLabelBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

Use XGridLabels to set custom labels in grids with vertical stripes. The GridType should be set to GridType.Custom. The position of the labels depends on the VertGridPoints and GridLabelsAtLines properties.

If the brushes are less than the grid labels, the control cycles through them.

Default value for the XGridLabelBrushes property is an empty BrushCollection.

See Also

XGridLabels
VertGridPoints
AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.XGridLabels Property

AxesChart.XGridLabels Property

Gets or sets the labels drawn at the X-axis in custom grids.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList XGridLabels { get; set; }
Visual Basic

Public Property XGridLabels As IList

Property Value

An object of type .NET IList.

Remarks

The labels are drawn with XGridLabelBrushes. The GridType should be set to GridType.Custom. Use VertGridPoints to specify the position of the XGridLabels at the X-axis. GridLabelsAtLines specifies whether the labels are drawn at grid lines or in the middle of the grid segment.

The orientation of the grid labels is set with XGridLabelsOrientation.

Default value for the XGridLabels property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
YGridLabels


MindFusion.Charting.AxesChart.XGridLabelsOrientation Property

AxesChart.XGridLabelsOrientation Property

Gets or sets the orientation of labels drawn at the X-axis in custom grids.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LabelOrientation XGridLabelsOrientation { get; set; }
Visual Basic

Public Property XGridLabelsOrientation As LabelOrientation

Property Value

One of the LabelOrientation Enumeration values.

Remarks

The property specifies the orientation of grid labels drawn at the X-axis when the GridType is GridType.Custom. Grid labels are specified with the XGridLabels property. Their position depends on the VertGridPoints and GridLabelsAtLines properties.

Default value for XGridLabelsOrientation property is LabelOrientation.InRow.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.XLabels Property

AxesChart.XLabels Property

Gets or sets custom labels drawn at the X-axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList XLabels { get; set; }
Visual Basic

Public Property XLabels As IList

Property Value

An object of type .NET IList that holds other lists with the labels.

Remarks

The labels are drawn when XAxisSettings.LabelType is set to AxisLabelType.CustomText. If the labels are not set as strings, the control converts them automatically.

In multi-series charts, the labels are drawn in rows. The space among the rows depends on LabelSpan. LabelOffset specifies the offset of the labels to the chart axis.

The labels can be drawn rotated if RotationAngle is greater than zero. LabelBrush sets the brush for the labels. If MultiColoredLabels is true, the labels are drawn with the ChartBrushes.

If the labels are less than the data, the control adds empty strings. If they are more, the excess labels are omitted.

Default value for the XLabels property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.Y2AxisSettings Property

AxesChart.Y2AxisSettings Property

Gets os sets the appearance settings for the Y2-axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public AxisSettings Y2AxisSettings { get; set; }
Visual Basic

Public Property Y2AxisSettings As AxisSettings

Property Value

An instance of the AxisSettings class.

Remarks

The property specifies all appearance characteristics of the Y2-axis: labels, fonts, data format, minimum and maximum value as well the intervals among them, label suffix and prefix, division coefficient and division label and so on. For more information about the axis properties and their default values, please check the AxisSettings class.

Y2Axis is drawn only when Y2Data is not an empty list. It is drawn parallel to the Y-axis, at the end of the X-axis.

Default value for the Y2AxisSettings property is a new AxisSettings object, which properties are set to their default values.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.Y2ChartBrushes Property

AxesChart.Y2ChartBrushes Property

Gets or sets the brushes for drawing Y2-bound chart graphics.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection Y2ChartBrushes { get; set; }
Visual Basic

Public Property Y2ChartBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

Y2 chart graphics are drawn only when the Y2Data property is not empty. Use Y2ChartPens to set the pens. If the brushes are less than the data series, the control cycles through them.

Default value for the Y2ChartBrushes property is an empty BrushCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.Y2ChartPens Property

AxesChart.Y2ChartPens Property

Gets or sets the pens for drawing Y2 - bound chart graphics.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PenCollection Y2ChartPens { get; set; }
Visual Basic

Public Property Y2ChartPens As PenCollection

Property Value

An object of type MindFusion.Drawing.PenCollection.

Remarks

Y2 chart graphics are drawn only when the Y2Data property is not an empty list. The brushes are set with Y2ChartBrushes. If the pens are less than the data series, the control cycles through them.

Default value for the Y2ChartPens property is an empty PenCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.Y2Data Property

AxesChart.Y2Data Property

Gets or sets the data for Y2-bound graphics or the radiuses for bubbles in bubble charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList Y2Data { get; set; }
Visual Basic

Public Property Y2Data As IList

Property Value

An instance of type .NET IList that holds other lists with the numbers.

Remarks

Data can be either numbers or DateTime values. They can be set in any format - integer, float, string as long as it can safely be converted to double-s or DateTime values using the standard .NET DoubleConverter and DateTimeConveter classes. The appearance options for the Y2-axis are set with Y2AxisSettings.

In bubble charts, the property is used to calculate the bubbles' radii.

Default value for the Y2Data property is an empty IList object.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.Y2GridLabelBrushes Property

AxesChart.Y2GridLabelBrushes Property

Gets or sets the brushes for drawing labels at the Y2-axis in custom grids.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection Y2GridLabelBrushes { get; set; }
Visual Basic

Public Property Y2GridLabelBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

Grid labels are drawn when the GridType is GridType.Custom and HorGridPoints and Y2Data are not empty. The labels are set wtih Y2GridLabels. They are drawn either at the grid lines or in the middle of the grid segments - use GridLabelsAtLines to set this.

If the brushes are less than the grid labels, the control cycles through them. If no brushes are set, the Y2AxisSettings.LabelBrush is used.

Default value for the Y2GridLabelBrushes property is an empty BrushCollection.

See Also

Y2Data
Y2GridLabels
HorGridPoints
AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.Y2GridLabels Property

AxesChart.Y2GridLabels Property

Gets or sets the labels drawn at the Y2-axis in custom grids.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList Y2GridLabels { get; set; }
Visual Basic

Public Property Y2GridLabels As IList

Property Value

A value of type .NET IList.

Remarks

Y2GridLabels are drawn when the GridType is GridType.Custom, the HorGridPoints and Y2Data properties are not empty lists. The labels are drawn at grid lines or in the middle of the grid segments as stated by the GridLabelsAtLines property.

When the brushes are less than the labels, they are used in cycle. If no brushes are set, Y2AxisSettings.LabelBrush is used instead.

Default value of Y2GridLabels is an empty IList.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.Y2GridLabelsOrientation Property

AxesChart.Y2GridLabelsOrientation Property

Gets or sets the orientation of grid labels at the Y2-axis in custom grids.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LabelOrientation Y2GridLabelsOrientation { get; set; }
Visual Basic

Public Property Y2GridLabelsOrientation As LabelOrientation

Property Value

One of the LabelOrientation Enumeration values.

Remarks

Grid labels at the Y2-axis are drawn when the GridType is GridType.Custom, HorGridPoints and Y2Data are not empty lists. The labels are set with Y2GridLabels. Their position depends on the value of the GridLabelsAtLines property.

Default value of Y2GridLabelsOrientation is LabelOrientation.InRow.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.Y2Labels Property

AxesChart.Y2Labels Property

Gets or sets custom labels for the second Y-axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList Y2Labels { get; set; }
Visual Basic

Public Property Y2Labels As IList

Property Value

An instance of type .NET IList that holds other lists with the labels.

Remarks

Custom labels are drawn when the Y2AxisSettings.AxiLabelsType property is set to AxisLabelType.CustomText. Second Y-axis is drawn when the Y2Data property is not an empty list.

When there are more than one series of Y2Data, the labels are drawn in column. The distance between the columns is set with Y2AxisSettings.LabelSpan. The offset of the first label column to the Y2-axis is set with Y2AxisSettings.LabelOffset.

The labels can be of any data type - numbers, strings and so on. The control converts automatically the data into strings. The labels are drawn with the LabelBrush; the font is set with LabelFont.

Default value for the Y2Labels property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.YAxisSettings Property

AxesChart.YAxisSettings Property

Gets or set the appearance settings for the Y-axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public AxisSettings YAxisSettings { get; set; }
Visual Basic

Public Property YAxisSettings As AxisSettings

Property Value

An instance of the AxisSettings class.

Remarks

The property specifies all appearance characteristics of the Y-axis: number format, distance between labels and their rotation angle, minimum and maximum axis value, label suffix and prefix, date and time values, division coefficient and so on.

For information about the axis properties and their default values, please check the AxisSettings class.

Default value for the YAxisSettings property is a new AxisSettings object. You can access it directly through the YAxisSettings property.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.YGridLabelBrushes Property

AxesChart.YGridLabelBrushes Property

Gets or sets the brushes for drawing custom grid labels at the Y-axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection YGridLabelBrushes { get; set; }
Visual Basic

Public Property YGridLabelBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

The property specifies the brushes for drawing custom grid labels at the Y-axis. If the BrushCollection is empty, YAxisSettings.LabelBrush is used for drawing the grid labels. The property is used only when the GridType is set to GridType.Custom and HorGridPoints is not an empty list. The labels are set with YGridLabels.

If the brushes are less than the grid labels, the control uses them in a cycle.

Default value for the YGridLabelBrushes property is an empty BrushCollection.

See Also

HorGridPoints
HorGridBrushes
VertGridPoints
AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxesChart.YGridLabels Property

AxesChart.YGridLabels Property

Gets or sets custom grid labels at the Y-axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList YGridLabels { get; set; }
Visual Basic

Public Property YGridLabels As IList

Property Value

An object of type .NET IList.

Remarks

Custom grid labels are drawn when the GridType is set to GridType.Custom. They can be drawn at grid lines or in the middle of grid segments - it depends on the GridLabelsAtLines property. The position of the grid lines is specified with the HorGridPoints property. The orientation of the grid labels is set with YGridLabelsOrientation.

The labels can be drawn with pointers as specified by the GridLabelPointer property.

Default value for the YGridLabels property is an empty IList.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
GridType Enumeration
XGridLabels
XLabels


MindFusion.Charting.AxesChart.YGridLabelsOrientation Property

AxesChart.YGridLabelsOrientation Property

Gets or sets the orientation of grid labels drawn at the Y-axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LabelOrientation YGridLabelsOrientation { get; set; }
Visual Basic

Public Property YGridLabelsOrientation As LabelOrientation

Property Value

One of the LabelOrientation Enumeration values.

Remarks

Custom grid labels are drawn at the Y-axis when the GridType is set to GridType.Custom. The position of the grid labels is set with HorGridPoints. The labels are specified with YGridLabels.

Labels can be drawn with a pointer from the middle of the grid section they refer to, to the label. Use GridLabelPointer to specify the length of the pointer.

Default value for YGridLabelsOrientation is LabelOrientation.InRow.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace
GridType Enumeration


MindFusion.Charting.AxesChart.YLabels Property

AxesChart.YLabels Property

Gets or sets the labels drawn at the Y-axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList YLabels { get; set; }
Visual Basic

Public Property YLabels As IList

Property Value

An instance of type .NET IList that holds other lists with the labels.

Remarks

The property is a list that holds other lists with the labels. Custom labels are drawn at the Y-axis when the LabelType property of the YAxisSettings object is set to CustomText. The labels can be of any format, the control always converts them to strings.

The labels are drawn in a column, which offset to the Y-axis is set with LabelOffset. When labels for multiple series are drawn, each series has its own column. The space among them is set with LabelsSpan.

Each labels column can be drawn in the color of the chart graphics it refers to by setting the MultiColoredLabels property to true. If the count of labels for a given series is less than the count of data values the control fills the missing label members with empty strings.

Default value for the YLabels property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisLabelType Enumeration

AxisLabelType Enumeration

Specifies the type of labels drawn at chart axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum AxisLabelType
Visual Basic

Public Enumeration AxisLabelType

Members

Member name | Description
AutoScale | The labels represent the numerical auto scale for this axis.
ChartData | The labels are the data values for this axis.
CustomText | Labels for this axis are set by the user.
Empty | No labels are drawn at this axis.

Remarks

This enumeration is used by charts that have axes - bar, line, area, scatter, bubble, radar, polar and so on.

When the label type is AxisLabelType.AutoScale, the scale is calculated automatically so that all chart values fit in. It is possible to set manually the divisions of the axis. In charts that use the Cartesian coordinate system, this is done through the AxisSettings.MinValue, AxisSettings.MaxValue and AxisSettings.AxisDelta properties. In radar / polar charts, the MinValue, MaxValue and Span properties are used.

If DateTime values are used as data, the properties for setting the auto scale are StartDateTime, EndDateTime and TimeSpan.

When too big numbers are drawn, they can be cancelled. The division coefficient and label are set with the DivisionCoef and DivisionLabel properties.

If the label type is CustomText, the labels are set with XLabels, YLabels and Y2Labels. For radar / polar charts custom labels are set with InnerAxisLabels and OuterAxisLabels.

If the axis is without any labels, its length must be specified with AxisSettings.AxisLength. Otherwise, it might appear too short. The inner axis length in radar charts is the radius. It is set with RadiusLength.

The label type is set with AxisSettings.LabelType. In radar charts, the InnerAxisLabelType and OuterAxisLabelType properties are used.

See Also

MindFusion.Charting Namespace
XAxisSettings
Y2AxisSettings
YAxisSettings
LabelType Enumeration


MindFusion.Charting.AxisSettings Class

AxisSettings Class
Remarks See Also

A class for specifying the settings of chart axes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public class AxisSettings : ICloneable
Visual Basic

Public Class AxisSettings
Implements ICloneable

Remarks

Members of the AxisSettings class specify the appearance of the axes in charts that use the Cartesian coordinate system. LabelType sets the type of labels drawn at the axis. The alignment of the labels is specified with LabelAlignment. The space between the labels and the axis is set with LabelOffset.

Labels can be drawn with text before and after the number - use LabelPrefix and LabelSuffix to set it.

The format of axis labels depends on DataFormat. When it is set to Numbers, the format is set by NumberFormat; when set to DateTime, the format is set by DateTimeFormat. Use StartDateTime and EndDateTime to specify the begin and end date. The interval between them is set through TimeSpan.

If the axis shows numbers, you can manually set the scale. The start and end numbers are specified with MinValue and MaxValue. The intervals between them are set with AxisDelta.

The zero label is not drawn by default. Set DrawZero to true if you want to show it.

Labels at horizontal axes can be drawn with a rotation angle. This is specified with the RotationAngle property.

Large data numbers can be cancelled with a custom-set coefficient. The DivisionCoef and DivisionLabel properties specify how numbers are cancelled and the label that will show the unit of measure.

Use AxisLength to specify the length of the axis. Title for the axis data is set with TitleLabel. It is drawn with the TitleLabelFont. The alignment of the title label is specified with TitleLabelAlignment. Its position is set with TitleLabelPosition. Use TitleLabelOffset to specify the distance between the axis label and the other axis labels or the axis (if no other labels are drawn).

The orientation of the axis labels is set with LabelOrientation.

Inheritance Hierarchy

System.Object
MindFusion.Charting.AxisSettings

See Also

AxisSettings Members
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings Members

AxisSettings Members
Constructors Properties Methods

A class for specifying the settings of chart axes.

The following tables list the members exposed by the AxisSettings type.

Public Constructors

Name | Description
AxisSettings | Creates a new instance of the AxisSettings class.

Public Properties

Name | Description
AxisDelta | Specifies the interval between labels at the chart axis.
AxisLength | Gets or sets the length of the chart axis.
CustomDateTimeFormat | Gets or sets custom DateTime format.
DataFormat | Gets or sets the format of data.
DateTimeFormat | Gets or sets the format of DateTime data.
DivisionCoef | Gets or sets the division coefficient for numerical values.
DivisionLabel | Gets or sets the unit of measure when numbers are cancelled.
DivMarkerAlignment | Gets or sets the alignment of division markers at the chart axis.
DivMarkerLength | Gets or sets the length of the division marker.
DrawZero | Gets or sets whether the zero label is drawn.
EndDateTime | Gets or sets the value of the last DateTime interval at the axis.
LabelAlignment | Gets or sets the alignment of labels at the chart axis.
LabelAtTheAxis | Gets or sets whether labels are drawn at the axis or outside the plot area.
LabelBrush | Gets or sets the brush for the axis labels.
LabelFont | Gets or sets the font for the axis labels.
LabelOffset | Gets or sets the offset of the axis labels to the axis they refer to.
LabelPrefix | Gets or sets the prefix drawn with each label.
LabelSpan | Gets or sets the distance among rows/columns of labels.
LabelSuffix | Gets or sets the suffix drawn with each label.
LabelType | Gets or sets the type of labels at the chart axis.
MaxValue | Specifies the maximum data value.
MinValue | Specifies the minimum data value.
NumberFormat | Gets or sets the format of numbers.
RotationAngle | Specifies the rotation angle of labels when the axis is horizontal.
StartDateTime | Specifies the start DateTime value.
TimeSpan | A TimeSpan object that specifies the interval among DateTime values at the axis.
TitleLabel | Gets or sets the title of the chart axes.
TitleLabelAlignment | Gets or set the alignment of the TitleLabel.
TitleLabelBrush | Gets or sets the Brush for drawing the TitleLabel.
TitleLabelFont | Gets or sets the font for the TitleLabel.
TitleLabelOffset | Gets or sets the offset of the TitleLabel to the start of the chart axis.
TitleLabelOrientation | Gets or sets the orientation of the TitleLabel.
TitleLabelPosition | Gets or sets the position of the TitleLabel.

Public Methods

Name | Description
Clone | Creates an exact copy of the current object.

See Also

AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings Constructor

AxisSettings Constructor

Creates a new instance of the AxisSettings class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public AxisSettings ()
Visual Basic

Public Sub New ()

Remarks

LineCharts and BarCharts have properties of type AxisSettings, which you can access directly in order to customize the appearance of the axes in your chart. The AxisSettings object is automatically created every time you create a new chart, so you do not need to initialize it manually.

See Also

AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings Methods

AxisSettings Methods

Public Methods

Name | Description
Clone | Creates an exact copy of the current object.

See Also

AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.Clone Method

AxisSettings.Clone Method

Creates an exact copy of the current object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

The copied AxisSettings object.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings Properties

AxisSettings Properties

Public Properties

Name | Description
AxisDelta | Specifies the interval between labels at the chart axis.
AxisLength | Gets or sets the length of the chart axis.
CustomDateTimeFormat | Gets or sets custom DateTime format.
DataFormat | Gets or sets the format of data.
DateTimeFormat | Gets or sets the format of DateTime data.
DivisionCoef | Gets or sets the division coefficient for numerical values.
DivisionLabel | Gets or sets the unit of measure when numbers are cancelled.
DivMarkerAlignment | Gets or sets the alignment of division markers at the chart axis.
DivMarkerLength | Gets or sets the length of the division marker.
DrawZero | Gets or sets whether the zero label is drawn.
EndDateTime | Gets or sets the value of the last DateTime interval at the axis.
LabelAlignment | Gets or sets the alignment of labels at the chart axis.
LabelAtTheAxis | Gets or sets whether labels are drawn at the axis or outside the plot area.
LabelBrush | Gets or sets the brush for the axis labels.
LabelFont | Gets or sets the font for the axis labels.
LabelOffset | Gets or sets the offset of the axis labels to the axis they refer to.
LabelPrefix | Gets or sets the prefix drawn with each label.
LabelSpan | Gets or sets the distance among rows/columns of labels.
LabelSuffix | Gets or sets the suffix drawn with each label.
LabelType | Gets or sets the type of labels at the chart axis.
MaxValue | Specifies the maximum data value.
MinValue | Specifies the minimum data value.
NumberFormat | Gets or sets the format of numbers.
RotationAngle | Specifies the rotation angle of labels when the axis is horizontal.
StartDateTime | Specifies the start DateTime value.
TimeSpan | A TimeSpan object that specifies the interval among DateTime values at the axis.
TitleLabel | Gets or sets the title of the chart axes.
TitleLabelAlignment | Gets or set the alignment of the TitleLabel.
TitleLabelBrush | Gets or sets the Brush for drawing the TitleLabel.
TitleLabelFont | Gets or sets the font for the TitleLabel.
TitleLabelOffset | Gets or sets the offset of the TitleLabel to the start of the chart axis.
TitleLabelOrientation | Gets or sets the orientation of the TitleLabel.
TitleLabelPosition | Gets or sets the position of the TitleLabel.

See Also

AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.AxisDelta Property

AxisSettings.AxisDelta Property

Specifies the interval between labels at the chart axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double AxisDelta { get; set; }
Visual Basic

Public Property AxisDelta As Double

Property Value

A double number that represents the interval.

Remarks

The property specifies the interval between scale divisions at the chart axis. The control uses this property together with MinValue and MaxValue to calculate the auto scale.

The numbers at the axis are formatted with the DataFormat property. If it is set to show DateTime values, the scale divisions must be specified with StartDateTime, EndDateTime and TimeSpan.

Default value for the AxisDelta property is Double.NaN, that is, the interval is calculated automatically.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.AxisLength Property

AxisSettings.AxisLength Property

Gets or sets the length of the chart axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float AxisLength { get; set; }
Visual Basic

Public Property AxisLength As Single

Property Value

A float value, which represents the length, in pixels.

Remarks

The property enables you to control the length of the chart axis. When the control automatically calculates the axis length it might get too short or too long according to the data and the labels. The AxisLength property allows fixing it at a suitable length.

When the length of the axis is a constant value, some labels might overlap because of insufficient space.

In bar charts, if the AxisLength is set, the bar width and distance between bars are recalculated so that all bars could fit in. This annuls all previously set BarWidth and DistBtwBars.

Default value for the AxisLength property is 0, which means the control automatically calculates the length of the axis.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.CustomDateTimeFormat Property

AxisSettings.CustomDateTimeFormat Property

Gets or sets custom DateTime format.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string CustomDateTimeFormat { get; set; }
Visual Basic

Public Property CustomDateTimeFormat As String

Property Value

A string. Default value is an empty string ("").

Remarks

The property is used for formatting DateTime values as axis labels. Set the DateTimeFormat property to DateTimeFormat.CustomDateTime and chart data must be DateTime values.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.DataFormat Property

AxisSettings.DataFormat Property

Gets or sets the format of data.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public DataFormat DataFormat { get; set; }
Visual Basic

Public Property DataFormat As DataFormat

Property Value

One of the DataFormat enumeration values. Default value is DataFormat.Auto.

Remarks

Use the property to specify whether your data is DateTime values or numbers. When the property is set to Auto, the control tries to convert all data to DateTime objects using the standard .NET DateTimeConverter. If any of the data values fails to be converted, the data is treated as numbers.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.DateTimeFormat Property

AxisSettings.DateTimeFormat Property

Gets or sets the format of DateTime data.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public DateTimeFormat DateTimeFormat { get; set; }
Visual Basic

Public Property DateTimeFormat As DateTimeFormat

Property Value

One of the DateTimeFormat enumeration values. Default is DateTimeFormat.FullDateTime.

Remarks

When DateTime values are used as chart data, the DataFormat must be set to DataFormat.DateTime. If DateTimeFormat is CustomDateTime, set the format through CustomDateTimeFormat.

With DateTime values, the axis scale can be set manually with the StartDateTime, EndDateTime and TimeSpan properties.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.DivisionCoef Property

AxisSettings.DivisionCoef Property

Gets or sets the division coefficient for numerical values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double DivisionCoef { get; set; }
Visual Basic

Public Property DivisionCoef As Double

Property Value

A double value that represents the division coefficient. Default is Double.NaN.

Remarks

DivisionCoef enables you to cancel big numbers with a custom-set divisor. The unit of measure is set with the DivisionLabel property. It is drawn besides the TitleLabel, if present.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.DivisionLabel Property

AxisSettings.DivisionLabel Property

Gets or sets the unit of measure when numbers are cancelled.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string DivisionLabel { get; set; }
Visual Basic

Public Property DivisionLabel As String

Property Value

A string. Default value is an empty string ("").

Remarks

Numbers are cancelled with the DivisionCoef. The value of DivisionLabel is not considered if DivisionCoef is not specified or the labels are not numbers but DateTime values. The DivisionLabel is drawn besides the TitleLabel and uses the same alignment, position and orientation.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.DivMarkerAlignment Property

AxisSettings.DivMarkerAlignment Property

Gets or sets the alignment of division markers at the chart axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public StringAlignment DivMarkerAlignment { get; set; }
Visual Basic

Public Property DivMarkerAlignment As StringAlignment

Property Value

One of the .NET StringAlignment Enumeration values.

Remarks

Division markers are drawn when the DivMarkerLength property is set to a value greater than 0.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.DivMarkerLength Property

AxisSettings.DivMarkerLength Property

Gets or sets the length of the division marker.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float DivMarkerLength { get; set; }
Visual Basic

Public Property DivMarkerLength As Single

Property Value

A float value. Default is 0f.

Remarks

Division markers are small lines that are drawn at scale divisions at the axis. They are drawn when the LabelType is set to AxisLabelType.AutoScale. Use DivMarkerAlignment to specify the alignment of the division markers.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.DrawZero Property

AxisSettings.DrawZero Property

Gets or sets whether the zero label is drawn.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool DrawZero { get; set; }
Visual Basic

Public Property DrawZero As Boolean

Property Value

true if the zero label is drawn; otherwise false. Default is false.

Remarks

The appearance settings for the zero label are the same as those of the other axes labels.

The zero label in axes that show DateTime values is not the number 0 but the StartDateTime, if set, or its automatically calculated value.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.EndDateTime Property

AxisSettings.EndDateTime Property

Gets or sets the value of the last DateTime interval at the axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public DateTime EndDateTime { get; set; }
Visual Basic

Public Property EndDateTime As DateTime

Property Value

A value of type .NET DateTime structure. Default is DateTime.MinValue.

Remarks

The property is considered only when the DataFormat is set to DataFormat is set to DateTime. The smallest DateTime value is set with StartDateTime. The intervals among them are calculated through the TimeSpan property.

StartDateTime, EndDateTime and TimeSpan properties specify the auto scale for data given as DateTime values. If they are not set, the control calculates them automatically.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.LabelAlignment Property

AxisSettings.LabelAlignment Property

Gets or sets the alignment of labels at the chart axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public StringAlignment LabelAlignment { get; set; }
Visual Basic

Public Property LabelAlignment As StringAlignment

Property Value

One of the .NET StringAlignment Enumeration values.

Remarks

When LabelAlignment is set to StringAlignment.Far the labels are drawn to the outside of the chart's plot area. When it is set to StringAlignment.Near the labels are drawn to the inside of the plot area.

It is not necessary that the labels are drawn always at the chart axis they refer to. They can also be drawn outside the plot area. Use the LabelAtTheAxis property to specify that.

Default value for the LabelAlignment property is StringAlignment.Far.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.LabelAtTheAxis Property

AxisSettings.LabelAtTheAxis Property

Gets or sets whether labels are drawn at the axis or outside the plot area.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool LabelAtTheAxis { get; set; }
Visual Basic

Public Property LabelAtTheAxis As Boolean

Property Value

A bool value. Default is true.

Remarks

The property is useful in charts that use both negative and positive values. It helps avoid drawing of labels in the center of the chart, over the graphics.

When LabelAtTheAxis is true, axis labels are drawn at the chart axis. When set to false, they are drawn outside the plot area.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.LabelBrush Property

AxisSettings.LabelBrush Property

Gets or sets the brush for the axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush LabelBrush { get; set; }
Visual Basic

Public Property LabelBrush As Brush

Property Value

An instance of type MindFusion.Drawing.Brush. Default is a black SolidBrush.

Remarks

When the MultiColoredLabels property is set to true, the axis labels are drawn with ChartBrushes. The title of the axis is drawn with TitleLabelBrush.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.LabelFont Property

AxisSettings.LabelFont Property

Gets or sets the font for the axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Font LabelFont { get; set; }
Visual Basic

Public Property LabelFont As Font

Property Value

An object of type .NET Font class.

Remarks

This property does not set the font for the axis title label. It is set with TitleLabelFont.

See Also

XAxisSettings
YAxisSettings
Y2AxisSettings
AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.LabelOffset Property

AxisSettings.LabelOffset Property

Gets or sets the offset of the axis labels to the axis they refer to.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float LabelOffset { get; set; }
Visual Basic

Public Property LabelOffset As Single

Property Value

A float value. Default is 5f.

Remarks

The property specifies the distance between the first row or column of labels and the chart axis. The offset among rows or columns of labels in multi-series charts is set with LabelSpan.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.LabelPrefix Property

AxisSettings.LabelPrefix Property

Gets or sets the prefix drawn with each label.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string LabelPrefix { get; set; }
Visual Basic

Public Property LabelPrefix As String

Property Value

A string value that represents the label prefix.

Remarks

The property specifies a prefix drawn before each label at the axis. It doesn't depend on the type of the labels and their format. The prefix is the same for all labels.

There are no limits for the length or type of the prefix, so you can use it to set any text you wish to appear before the label, for example USD, $, MB and so on.

Default value for the LabelPrefix property is an empty string ("").

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.LabelSpan Property

AxisSettings.LabelSpan Property

Gets or sets the distance among rows/columns of labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float LabelSpan { get; set; }
Visual Basic

Public Property LabelSpan As Single

Property Value

A float value. Default is 5f.

Remarks

The property is used only when more than row or column of labels is drawn. When there are SummaryValues, the property is also used for the distance between them and the rest of the labels.

The distance between the axis labels and the axis is set with LabelOffset.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.LabelSuffix Property

AxisSettings.LabelSuffix Property

Gets or sets the suffix drawn with each label.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string LabelSuffix { get; set; }
Visual Basic

Public Property LabelSuffix As String

Property Value

A string that represents the label suffix.

Remarks

The property specifies a suffix drawn behind each label. There is no limit for the length of the string that represents the label suffix. The suffix is the same for all labels and does not depend on their type.

Besides the suffix, labels can also have a prefix - LabelPrefix.

Default value for the LabelSuffix property is an empty string.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.LabelType Property

AxisSettings.LabelType Property

Gets or sets the type of labels at the chart axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public AxisLabelType LabelType { get; set; }
Visual Basic

Public Property LabelType As AxisLabelType

Property Value

One of the AxisLabelType Enumeration values.

Remarks

The property specifies the type of labels drawn at the chart axis. Custom labels are set with XLabels, YLabels or Y2Labels.

DataFormat specifies whether labels refer to numbers or DateTime values. The format of the labels is set by NumberFormat for numerical data and DateTimeFormat for DateTime values. Custom DateTime format is set with CustomDateTimeFormat .

Labels in multi-series charts can be drawn in several rows / columns. The space between them is set with LabelSpan. They can also be drawn in color matching the color of the series they refer to. Use MultiColoredLabels to set this.

Default value for the LabelType property is AxisLabelType.Empty.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.MaxValue Property

AxisSettings.MaxValue Property

Specifies the maximum data value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double MaxValue { get; set; }
Visual Basic

Public Property MaxValue As Double

Property Value

A double value that represents the maximum number.

Remarks

The property specifies the maximum double value, which any member at the chart axis can have. The data for the chart axes is set with the XData, YData or Y2Data properties.

When a number is bigger than the MaxValue it is dropped out of the data array it belongs to. The number at the relevant position in the other data arrays is dropped out also to ensure correct drawing of the chart data.

If the maximum number is smaller than zero the axis is still drawn till the start of the coordinate system but the numbers bigger than MaxValue are eliminated.

The MinValue and MaxValue can be used to set the start and end number of the axis numerical scale more precisely. AxisDelta sets the value of the intervals between them.

Default value for the MaxValue property is Double.NaN, that is, the maximum value is calculated automatically.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.MinValue Property

AxisSettings.MinValue Property

Specifies the minimum data value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double MinValue { get; set; }
Visual Basic

Public Property MinValue As Double

Property Value

A double value that represents the minimum number.

Remarks

The property specifies the minimum double value, which any member at the chart axis can have. The data for the chart axes is set with the XData, YData or Y2Data properties.

When a number is smaller than the MinValue it is dropped out of the data array it belongs to. The number at the relevant position in the other data arrays is dropped out also to ensure correct drawing of the chart data.

If the minimum number is bigger than zero the axis is still drawn from the beginning of the coordinate system but the numbers smaller than MinValue are eliminated.

The MinValue and MaxValue can be used to set more precisely the start and end numbers of the axis numerical scale. AxisDelta sets the value of the intervals between them.

Default value for the MinValue property is Double.NaN, that is, no minimum value is considered.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.NumberFormat Property

AxisSettings.NumberFormat Property

Gets or sets the format of numbers.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public NumberFormat NumberFormat { get; set; }
Visual Basic

Public Property NumberFormat As NumberFormat

Property Value

One of the NumberFormat enumeration values. Default value is NumberFormat.Fixed_point.

Remarks

Use the property to specify the format of labels drawn when data values are numbers. DataFormat should be set to Number. The LabelType should be set to AutoScale or ChartData.

The axis scale can be set manually with the MinValue, MaxValue and AxisDelta properties.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.RotationAngle Property

AxisSettings.RotationAngle Property

Specifies the rotation angle of labels when the axis is horizontal.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float RotationAngle { get; set; }
Visual Basic

Public Property RotationAngle As Single

Property Value

A float value that represents the rotation angle.

Remarks

The property sets the rotation angle for labels, drawn when the axis is horizontal. Labels drawn at vertical chart axes are not rotated.

The rotation angle is between 0 and 90. 0 indicates that the text is drawn horizontally and 90 - the text is drawn vertically.

The labels type is set with LabelType property.

Default value for the RotationAngle property is 0, that is, the labels are not rotated.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.StartDateTime Property

AxisSettings.StartDateTime Property

Specifies the start DateTime value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public DateTime StartDateTime { get; set; }
Visual Basic

Public Property StartDateTime As DateTime

Property Value

A value of type .NET DateTime structure.

Remarks

The StartDateTime property specifies the smallest DateTime value at the axis. The biggest one is set with EndDateTime. The size of the intervals between them is set with TimeSpan.

Set the DataFormat property to DateTime. Use DateTimeFormat to set the particular DateTime format.

Default value for the StartDateTime property is DateTime.MinValue.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.TimeSpan Property

AxisSettings.TimeSpan Property

A TimeSpan object that specifies the interval among DateTime values at the axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public TimeSpan TimeSpan { get; set; }
Visual Basic

Public Property TimeSpan As TimeSpan

Property Value

An object of type .NET TimeSpan structure.

Remarks

Use the TimeSpan property to set the interval between DateTime labels drawn at the axis. The smallest and biggest DateTime values are set with StartDateTime and EndDateTime.

DateTime labels are drawn when the DataFormat is set to DateTime. Use DateTimeFormat to set the particular label.

Default value for the TimeSpan property is TimeSpan.Zero.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.TitleLabel Property

AxisSettings.TitleLabel Property

Gets or sets the title of the chart axes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string TitleLabel { get; set; }
Visual Basic

Public Property TitleLabel As String

Property Value

A string that represents the label.

Remarks

The title label can be drawn in several lines using the "\n" symbol. It is drawn with TitleLabelFont.

The position, orientation and alignment of the TitleLabel are set with TitleLabelPosition, TitleLabelOrientation and TitleLabelAlignment.

The TitleLabel is drawn always after the labels for the axis, which means that their alignment is considered for it too (see LabelAlignment).

Default value for the TitleLabel property is an empty string.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.TitleLabelAlignment Property

AxisSettings.TitleLabelAlignment Property

Gets or set the alignment of the TitleLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Alignment TitleLabelAlignment { get; set; }
Visual Basic

Public Property TitleLabelAlignment As Alignment

Property Value

One of the Alignment Enumeration values.

Remarks

The TitleLabel can also have a position and orientation as set by TitleLabelOrientation and TitleLabelPosition. The alignment, orientation and position of the TitleLabel are also considered for the DivisionLabel.

Default value for the TitleLabelAlignment property is Alignment.Center.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.TitleLabelBrush Property

AxisSettings.TitleLabelBrush Property

Gets or sets the Brush for drawing the TitleLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush TitleLabelBrush { get; set; }
Visual Basic

Public Property TitleLabelBrush As Brush

Property Value

An instance of type MindFusion.Drawing.Brush class.

Remarks

TitleLabelBrush is also used for drawing the DivisionLabel.

Default value for the TitleLabelBrush property is a black SolidBrush.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.TitleLabelFont Property

AxisSettings.TitleLabelFont Property

Gets or sets the font for the TitleLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Font TitleLabelFont { get; set; }
Visual Basic

Public Property TitleLabelFont As Font

Property Value

A value of type System.Drawing.Font.

Remarks

Default value for the TitleLabelFont property is Times New Roman, 8 pt.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisSettings.TitleLabelOffset Property

AxisSettings.TitleLabelOffset Property

Gets or sets the offset of the TitleLabel to the start of the chart axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float TitleLabelOffset { get; set; }
Visual Basic

Public Property TitleLabelOffset As Single

Property Value

A float value. Default is 5f.

Remarks

The property specifies the space between the TitleLabel and the axis it refers to. If other labels are drawn at the axis, the property specifies the offset between the TitleLabel and the last row or column of axis labels.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace
TitleLabelOrientation
TitleLabelAlignment
TitleLabelPosition


MindFusion.Charting.AxisSettings.TitleLabelOrientation Property

AxisSettings.TitleLabelOrientation Property

Gets or sets the orientation of the TitleLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LabelOrientation TitleLabelOrientation { get; set; }
Visual Basic

Public Property TitleLabelOrientation As LabelOrientation

Property Value

One of the LabelOrientation Enumeration values.

Remarks

TitleLabelOrientation, together with TitleLabelAlignment and TitleLabelPosition specify the exact location of the TitleLabel. These settings are also considered for the DivisionLabel.

Default value for the LabelOrientation property is LabelOrientation.InRow.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace
TitleLabel


MindFusion.Charting.AxisSettings.TitleLabelPosition Property

AxisSettings.TitleLabelPosition Property

Gets or sets the position of the TitleLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Position TitleLabelPosition { get; set; }
Visual Basic

Public Property TitleLabelPosition As Position

Property Value

One of the Position Enumeration values.

Remarks

Not all Position values are valid for the labels at a given axis. Labels at the X-axis can be placed either at the top or bottom of the axis. Labels at Y and Y2-axis can be placed either to the left or right of the axis. Invalid values are ignored.

TitleLabelPosition together with TitleLabelAlignment and TitleLabelOrientation specify the exact location of the TitleLabel. These settings are also considered for the DivisionLabel.

The default value for the TitleLabelPosition property depends on the axis. It is Position.Bottom in the XAxisSettings object, Position.Left in the YAxisSettings object and Position.Right in the Y2AxisSettings object.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Charting Namespace


MindFusion.Charting.Bar Class

Bar Class
Remarks See Also

Represents a bar in a bar chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public sealed class Bar : ChartElement
Visual Basic

Public NotInheritable Class Bar
Inherits ChartElement

Remarks

Each bar in a bar chart is an instance of the Bar class. If by hit-testing the user clicks on a bar, the Bar object that represents the bar is returned. Members of the Bar class are read-only. Use the respective members of the BarChart class to set the data for the chart.

Inheritance Hierarchy

System.Object
MindFusion.Charting.ChartElement
MindFusion.Charting.Bar

See Also

HitTest
HitTestBar
Bar Members
MindFusion.Charting Namespace


MindFusion.Charting.Bar Members

Bar Members
Constructors Properties Methods

Represents a bar in a bar chart.

The following tables list the members exposed by the Bar type.

Public Constructors

Name | Description
Bar | Initializes a new instance of the Bar class.

Public Properties

Name | Description
Brush | Gets the brush for this Bar.
Height | Gets the height of this Bar.
InnerLabel | Gets the inner label of the bar.
TopLabel | Gets the top label of the bar.
Value | Gets the value this bar represents.
Width | Gets the width of this Bar.
XLabel | Gets the label drawn at the X-axis for this bar.
YLabel | Gets the label drawn for this bar at the Y-axis.

Public Methods

Name | Description
CompareTo | Compares a bar to another one.

See Also

Bar Class
MindFusion.Charting Namespace


MindFusion.Charting.Bar Constructor

Bar Constructor

Initializes a new instance of the Bar class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Bar ()
Visual Basic

Public Sub New ()

See Also

Bar Class
MindFusion.Charting Namespace


MindFusion.Charting.Bar Methods

Bar Methods

Public Methods

Name | Description
CompareTo | Compares a bar to another one.

See Also

Bar Class
MindFusion.Charting Namespace


MindFusion.Charting.Bar.CompareTo Method

Bar.CompareTo Method

Compares a bar to another one.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public virtual int CompareTo (
Object obj
)
Visual Basic

Public Overridable Function CompareTo ( _
obj As Object _
) As Integer

Parameters

obj
The bar to compare to.

Return Value

0 if equal, 1 if this Bar is bigger, otherwise -1;

See Also

Bar Members
Bar Class
MindFusion.Charting Namespace


MindFusion.Charting.Bar Properties

Bar Properties

Public Properties

Name | Description
Brush | Gets the brush for this Bar.
Height | Gets the height of this Bar.
InnerLabel | Gets the inner label of the bar.
TopLabel | Gets the top label of the bar.
Value | Gets the value this bar represents.
Width | Gets the width of this Bar.
XLabel | Gets the label drawn at the X-axis for this bar.
YLabel | Gets the label drawn for this bar at the Y-axis.

See Also

Bar Class
MindFusion.Charting Namespace


MindFusion.Charting.Bar.Brush Property

Bar.Brush Property

Gets the brush for this Bar.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush Brush { get; }
Visual Basic

Public ReadOnly Property Brush As Brush

Property Value

An instance of MindFusion.Drawing.Brush class.

Remarks

The property gets the brush, which is used for painting this bar. The brushes for bar charts are set with ChartBrushes. If MultiColored is set to true, all bars in bar series are drawn with different brushes, otherwise only one brush is used.

When ChartBrushes is an empty list, a default blue gradient brush is used.

See Also

Bar Members
Bar Class
MindFusion.Charting Namespace


MindFusion.Charting.Bar.Height Property

Bar.Height Property

Gets the height of this Bar.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float Height { get; }
Visual Basic

Public ReadOnly Property Height As Single

Property Value

A float value.

Remarks

Gets the height of the bar, in pixels. The height of the bar depends on its Value and the maximum number at the axis at which the bars are plotted - X-axis for horizontal charts and Y-axis for vertical ones. The height also depends on AxisLength.

See Also

Bar Members
Bar Class
MindFusion.Charting Namespace


MindFusion.Charting.Bar.InnerLabel Property

Bar.InnerLabel Property

Gets the inner label of the bar.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string InnerLabel { get; }
Visual Basic

Public ReadOnly Property InnerLabel As String

Property Value

A string value that represents the inner label.

Remarks

The property returns the text that is drawn inside the bar. The type of the text depends on the value of the InnerLabelType property. Custom text is set with InnerLabels.

See Also

Bar Members
Bar Class
MindFusion.Charting Namespace


MindFusion.Charting.Bar.TopLabel Property

Bar.TopLabel Property

Gets the top label of the bar.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string TopLabel { get; }
Visual Basic

Public ReadOnly Property TopLabel As String

Property Value

A string value that represents the top label.

Remarks

The property gets the text drawn at the top of chart bars. The type of the text depends on the value of the TopLabelType property. Custom text is set with TopLabels. Labels at vertical bars can be rotated if you set TopLabelRotAngle to a value greater than zero.

See Also

Bar Members
Bar Class
MindFusion.Charting Namespace


MindFusion.Charting.Bar.Value Property

Bar.Value Property

Gets the value this bar represents.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double Value { get; }
Visual Basic

Public ReadOnly Property Value As Double

Property Value

A double number that represents the value of the bar.

Remarks

The property gets the value of the bar as set with the Data property. No number formatting is applied.

See Also

Bar Members
Bar Class
MindFusion.Charting Namespace


MindFusion.Charting.Bar.Width Property

Bar.Width Property

Gets the width of this Bar.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float Width { get; }
Visual Basic

Public ReadOnly Property Width As Single

Property Value

A float value.

Remarks

The property specifies the width of the bar. It can be set with BarWidth or calculated automatically. If the value is calculated, it depends on the AxisLength, the count of the bars and the values of the DistBtwBars and DistBtwSeries properties, if set.

See Also

BarType
XAxisSettings
YAxisSettings
Bar Members
Bar Class
MindFusion.Charting Namespace


MindFusion.Charting.Bar.XLabel Property

Bar.XLabel Property

Gets the label drawn at the X-axis for this bar.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string XLabel { get; }
Visual Basic

Public ReadOnly Property XLabel As String

Property Value

A string value that represents the label at the X-axis.

Remarks

The property gets the label drawn for this bar at the X-axis. Its value depends on the LabelType property of XAxisSettings. Custom labels are set with XLabels.

See Also

Bar Members
Bar Class
MindFusion.Charting Namespace


MindFusion.Charting.Bar.YLabel Property

Bar.YLabel Property

Gets the label drawn for this bar at the Y-axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string YLabel { get; }
Visual Basic

Public ReadOnly Property YLabel As String

Property Value

A string value that represents the label.

Remarks

The text of the YLabel depends on the value of the YAxisSettings.LabelType property. Custom labels are specified with YLabels.

See Also

Bar Members
Bar Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart Class

BarChart Class
Remarks See Also

A class for drawing bar charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public class BarChart : AxesChart
Visual Basic

Public Class BarChart
Inherits AxesChart

Remarks

BarChart inherits properties and methods from its base class AxesChart.

The class is used for drawing all types of bar charts - flat (2D charts) as well with 3D visual effect. The different bar types are listed as members of the BarType Enumeration. You can set the type of the bar chart with the BarType property. The Cylinder property enables you to draw the data as cylinders instead of bars.

The data for the bar chart is set with Data, which is used for calculating the height of the bars. The data can be numbers, or in any other format that can be parsed to numbers.

The orientation of the chart is set with the Horizontal property. The layout of bars in multiple series is set with BarSeriesLayout.

You can change the offset between the first bar and the beginning of the axis Offset. The distance between the bars - both horizontal and vertical - can be specified with DistBtwBars. BarWidth regulates the thickness of bars. Distance between bar series is specified with DistBtwSeries.

Bars can have labels inside and / or at the top. The type of the labels is set with InnerLabelType and TopLabelType. Custom labels are specified with InnerLabels and TopLabels. The position of the inner label inside the bar is set with InnerLabelAlignment.

Top labels can be rotated and drawn with offset from the edge of the bars as specified by the TopLabelRotAngle and TopLabelOffset properties. Use ClusterLabels if you want to draw a label at each cluster or group of bars.

The bar chart can be drawn with a grid, which type is set with the GridType property. The width of crossed grids is set with GridWidth. The grid can be drawn with stripes. The brushes for them are specified with GridBrush and AltGridBrush. Custom-set grid points are also possible.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Chart
MindFusion.Charting.AxesChart
MindFusion.Charting.BarChart

See Also

BarChart Members
MindFusion.Charting Namespace


MindFusion.Charting.BarChart Members

BarChart Members
Constructors Properties Methods

A class for drawing bar charts.

The following tables list the members exposed by the BarChart type.

Public Constructors

Name | Description
BarChart | Creates a new instance of the BarChart class.

Public Properties

Name | Description
BarSeriesLayout | Gets or sets the layout of bars in multi-series charts.
BarType | Gets or sets the type of the bar chart to be drawn.
BarWidth | Gets or sets the thickness of chart bars.
ClusterLabels | Gets or sets custom labels for clustered bar charts.
Cylinder | Gets or sets whether bars are drawn as cylinders.
CylinderTension | Gets or sets the tension of chart cylinders.
Data | Gets or sets the numerical data used for calculating the height of chart bars.
DistBtwBars | Gets or sets the distance between bars in a bar chart.
InnerLabelAlignment | Gets or sets the alignment of labels inside bars.
InnerLabelBackground | Gets or sets the Brush for filling the border rectangle of inner labels.
InnerLabelBorder | Gets or sets the Border drawn around inner labels.
InnerLabelFormat | Gets or sets the format of inner labels.
InnerLabelMargin | Gets or sets the margin around the inner label and its border.
InnerLabelOutline | Gets or sets the Pen for drawing the outline of the border rectangle for inner labels.
InnerLabels | Gets or sets the labels drawn inside bars.
InnerLabelType | Gets or sets the type of labels drawn inside chart bars.
TopLabelBackground | Gets or sets the Brush for filling the border rectangle of top labels.
TopLabelBorder | Gets or sets the Border drawn around top labels.
TopLabelFormat | Gets or sets the format of top labels.
TopLabelMargin | Gets or sets the margin around the top label when drawn with border.
TopLabelOffset | Gets or sets the offset of the top label to the edge of the bar.
TopLabelOutline | Gets or sets the Pen that draws the label border of top labels.
TopLabelRotAngle | Gets or sets the rotation angle of labels at the top of vertical chart bars.
TopLabels | Gets or sets custom labels drawn at the top of chart bars.
TopLabelType | Gets or sets the type of labels drawn at the top of chart bars.

Public Methods

Name | Description
ClearData | Clears any data from the chart.
Clone | Creates an exact copy of the current BarChart object.
HitTest | Returns the bar at the specified position.
HitTestBar | Returns the bar at the specified position.

Protected Methods

Name | Description
ClearChartSpecificData | Clears the bar specific data.
CreateChart | Creates a new BarChart object.

See Also

BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart Constructor

BarChart Constructor

Creates a new instance of the BarChart class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BarChart (
BarType type
)
Visual Basic

Public Sub BarChart ( _
type As BarType _
)

Parameters

type
One of the BarType Enumeration values.

Remarks

This method is the BarChart constructor and creates a new instance of the BarChart class. Its only parameter indicates the type of the bar chart. For more details about the types of bar charts that can be created, please refer to the BarType enumeration. The layout of bars in multi - series charts is set with BarSeriesLayout.

See Also

BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart Methods

BarChart Methods

Public Methods

Name | Description
ClearData | Clears any data from the chart.
Clone | Creates an exact copy of the current BarChart object.
HitTest | Returns the bar at the specified position.
HitTestBar | Returns the bar at the specified position.

Protected Methods

Name | Description
ClearChartSpecificData | Clears the bar specific data.
CreateChart | Creates a new BarChart object.

See Also

BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.ClearChartSpecificData Method

BarChart.ClearChartSpecificData Method

Clears the bar specific data.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

protected virtual void ClearChartSpecificData ()
Visual Basic

Protected Overridable Sub ClearChartSpecificData ()

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.ClearData Method

BarChart.ClearData Method

Clears any data from the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override void ClearData ()
Visual Basic

Public Overrides Sub ClearData ()

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.Clone Method

BarChart.Clone Method

Creates an exact copy of the current BarChart object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

The cloned bar chart.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.CreateChart Method

BarChart.CreateChart Method

Creates a new BarChart object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

protected virtual Chart CreateChart ()
Visual Basic

Protected Overridable Function CreateChart () As Chart

Return Value

The new bar chart.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.HitTest Method

BarChart.HitTest Method

Returns the bar at the specified position.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override ChartElement HitTest (
int x,
int y
)
Visual Basic

Public Overrides Function HitTest ( _
x As Integer, _
y As Integer _
) As ChartElement

Parameters

x
the X - coordinate of the mouse
y
the Y - coordinate of the mouse

Return Value

The hitted bar or null.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.HitTestBar Method

BarChart.HitTestBar Method

Returns the bar at the specified position.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Bar HitTestBar (
int x,
int y
)
Visual Basic

Public Function HitTestBar ( _
x As Integer, _
y As Integer _
) As Bar

Parameters

x
the X - coordinate of the mouse
y
the Y - coordinate of the mouse

Return Value

The Bar that includes the point specified by x and y; null if no Bar is found.

Remarks

Use this method when hit - testing to find the Bar, at which the user clicks. The result can be null, so always check.

See Also

HitTest
BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart Properties

BarChart Properties

Public Properties

Name | Description
BarSeriesLayout | Gets or sets the layout of bars in multi-series charts.
BarType | Gets or sets the type of the bar chart to be drawn.
BarWidth | Gets or sets the thickness of chart bars.
ClusterLabels | Gets or sets custom labels for clustered bar charts.
Cylinder | Gets or sets whether bars are drawn as cylinders.
CylinderTension | Gets or sets the tension of chart cylinders.
Data | Gets or sets the numerical data used for calculating the height of chart bars.
DistBtwBars | Gets or sets the distance between bars in a bar chart.
InnerLabelAlignment | Gets or sets the alignment of labels inside bars.
InnerLabelBackground | Gets or sets the Brush for filling the border rectangle of inner labels.
InnerLabelBorder | Gets or sets the Border drawn around inner labels.
InnerLabelFormat | Gets or sets the format of inner labels.
InnerLabelMargin | Gets or sets the margin around the inner label and its border.
InnerLabelOutline | Gets or sets the Pen for drawing the outline of the border rectangle for inner labels.
InnerLabels | Gets or sets the labels drawn inside bars.
InnerLabelType | Gets or sets the type of labels drawn inside chart bars.
TopLabelBackground | Gets or sets the Brush for filling the border rectangle of top labels.
TopLabelBorder | Gets or sets the Border drawn around top labels.
TopLabelFormat | Gets or sets the format of top labels.
TopLabelMargin | Gets or sets the margin around the top label when drawn with border.
TopLabelOffset | Gets or sets the offset of the top label to the edge of the bar.
TopLabelOutline | Gets or sets the Pen that draws the label border of top labels.
TopLabelRotAngle | Gets or sets the rotation angle of labels at the top of vertical chart bars.
TopLabels | Gets or sets custom labels drawn at the top of chart bars.
TopLabelType | Gets or sets the type of labels drawn at the top of chart bars.

See Also

BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.BarSeriesLayout Property

BarChart.BarSeriesLayout Property

Gets or sets the layout of bars in multi-series charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BarSeriesLayout BarSeriesLayout { get; set; }
Visual Basic

Public Property BarSeriesLayout As BarSeriesLayout

Property Value

One of the BarSeriesLayout Enumeration values.

Remarks

The property specifies the layout of bars in multi-series charts. Multi - series charts are drawn when BarType is set to Clustered2D/3D or Groups2D/3D. Data for the bar series is set with Data.

Default value of the BarSeriesLayout property is BarSeriesLayout.InRow.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.BarType Property

BarChart.BarType Property

Gets or sets the type of the bar chart to be drawn.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BarType BarType { get; set; }
Visual Basic

Public Property BarType As BarType

Property Value

One of the BarType Enumeration values.

Remarks

The layout of bars in multi-series charts is set with BarSeriesLayout. Multi-series charts are drawn when BarType is set to BarType.Groups or BarType.Clustered.

Check the BarType enumeration members for additional information what types of bars can be created. Find detailed information how data for the bar chart is specified in the Data property.

Default value for the BarType property is BarType.Single3D.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.BarWidth Property

BarChart.BarWidth Property

Gets or sets the thickness of chart bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float BarWidth { get; set; }
Visual Basic

Public Property BarWidth As Single

Property Value

A float value that specifies the thickness.

Remarks

The property specifies how thick/thin the chart bars are. The distance between the bars is set with DistBtwBars. If the bars are drawn in a group / cluster, the distance between the groups is set with DistBtwSeries.

If the distance between bars, bar width and distance between bar series (if any) are not set, they are calculated automatically according to the length of the axis, at which the bars are drawn.

Default value for the BarWidth property is 20f.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.ClusterLabels Property

BarChart.ClusterLabels Property

Gets or sets custom labels for clustered bar charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList ClusterLabels { get; set; }
Visual Basic

Public Property ClusterLabels As IList

Property Value

An object of type .NET IList that holds the labels.

Remarks

The property specifies custom labels for each bar cluster or data group. If the labels are less than the clusters, MindFusion.Charting adds empty strings. ClusterLabels are drawn when the label type for the axis at which the bars are drawn is AxisLabelType.CustomText.

Only one label is drawn at each bar cluster / data group. If the LabelType is AxisLabelType.CustomText and the ClusterLabels property is empty, MindFusion.Charting takes the labels from the XLabels or YLabels properties according to the chart's orientation. In this case, each bar has a label.

Cluster labels are considered only when the BarType is Clustered2D, Clustered3D, Groups2D or Groups3D.

Default value for the ClusterLabels property is an empty array.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace
AxesChart.XAxisSettings
AxesChart.YAxisSettings


MindFusion.Charting.BarChart.Cylinder Property

BarChart.Cylinder Property

Gets or sets whether bars are drawn as cylinders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool Cylinder { get; set; }
Visual Basic

Public Property Cylinder As Boolean

Property Value

A bool value, true if the bars are drawn as cylinders, otherwise false.

Remarks

Instances of the BarChart class can draw data not only as bars but also cylinders. The tension of the cylinders is specified with CylinderTension. All other chart settings remain the same as for bar charts.

Default value for the Cylinder property is false.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.CylinderTension Property

BarChart.CylinderTension Property

Gets or sets the tension of chart cylinders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int CylinderTension { get; set; }
Visual Basic

Public Property CylinderTension As Integer

Property Value

An int value that specifies the tension of the cylinder. The bigger the value, the flatter the cylinder. Values range from 0 to 100.

Remarks

Instances of the BarChart class can draw data not only as bars but also as cylinders. Cylinders are drawn when the Cylinder property is set to true. All other settings for the chart remain the same as for bar charts.

Default value for the CylinderTension property is 30.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.Data Property

BarChart.Data Property

Gets or sets the numerical data used for calculating the height of chart bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList Data { get; set; }
Visual Basic

Public Property Data As IList

Property Value

An object of type .NET IList class that holds other lists with numbers.

Remarks

Add lists with data to the property or assign to it a list that holds the data lists. The data can be numbers, or in any other format that can be parsed to numbers.

Each bar cluster is formed from data at the same position in the Data series. This means that the data for the first cluster will be taken from the elements at first position in the Data lists; the data for the second cluster - from the elements at second position in the Data lists and so on. The count of bars in the cluster is determined by the count of lists in the Data property. The count of the clusters is determined by the count of numbers in the longest list in Data.

Groups2D and Groups3D bar charts represent bars in a group. The data for each group is taken from the respective Data list. Thus, data for the first group is taken from all the numbers in the first list in the Data property. The count of values in the list determines the count of bars in the group. The count of lists in the Data property determines the count of the groups.

If the chart has summaries, the values are added as bars to each bar group. Summaries are added to the SummaryValues property.

Default value for the Data property is an empty list.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.DistBtwBars Property

BarChart.DistBtwBars Property

Gets or sets the distance between bars in a bar chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float DistBtwBars { get; set; }
Visual Basic

Public Property DistBtwBars As Single

Property Value

A float value that specifies the distance.

Remarks

The property specifies the distance between bars - alone or in a group. The width of the bars is set with BarWidth. If the bars are drawn in clusters or groups, DistBtwSeries specifies the distance between the groups. The layout of the bars in groups is set with BarSeriesLayout.

If the bar width and the distance between the bars and bar groups/clusters is not set, the control calculates them automatically, according to the length of the axis, at which the bars are drawn. If it is also not set, the bars are drawn with width 20 and distance between them 10.

Default value for the DistBtwBars property is 10.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.InnerLabelAlignment Property

BarChart.InnerLabelAlignment Property

Gets or sets the alignment of labels inside bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public StringAlignment InnerLabelAlignment { get; set; }
Visual Basic

Public Property InnerLabelAlignment As StringAlignment

Property Value

One of the .NET StringAlignment Enumeration values.

Remarks

The property specifies how labels inside bars are aligned. The StringAlignment.Near value indicates the label is aligned to the bottom of the bar. StringAlignment.Far aligns the label to the top of the bar, while with StringAlignment.Center the label is drawn in the center of the bar.

In order to draw labels inside bars, the InnerLabelType property should not be set to LabelType.Empty. Custom labels are set with the InnerLabels property.

Bars can also have labels at the top. Their type is set with TopLabelType.

Default value for the InnerLabelAlignment property is StringAlignment.Center.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.InnerLabelBackground Property

BarChart.InnerLabelBackground Property

Gets or sets the Brush for filling the border rectangle of inner labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush InnerLabelBackground { get; set; }
Visual Basic

Public Property InnerLabelBackground As Brush

Property Value

An instance of MindFusion.Drawing.Brush class. Default is a light blue SolidBrush.

Remarks

InnerLabelBorder specifies the border drawn around inner labels. The border rectangle is drawn with InnerLabelOutline. The space between the inner label and its border is set with InnerLabelMargin.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.InnerLabelBorder Property

BarChart.InnerLabelBorder Property

Gets or sets the Border drawn around inner labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Border InnerLabelBorder { get; set; }
Visual Basic

Public Property InnerLabelBorder As Border

Property Value

One of the Border Enumeration values. Default is Border.None.

Remarks

The border rectangle is drawn with InnerLabelOutline and filled with InnerLabelBackground. The space between the inner label and its border is set with InnerLabelMargin.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace
TopLabelBorder


MindFusion.Charting.BarChart.InnerLabelFormat Property

BarChart.InnerLabelFormat Property

Gets or sets the format of inner labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public NumberFormat InnerLabelFormat { get; set; }
Visual Basic

Public Property InnerLabelFormat As NumberFormat

Property Value

One of the NumberFormat enumeration members. Default is NumberFormat.Fixed_point.

Remarks

Use the property to specify how numbers drawn inside bars as labels are formatted. InnerLabelFormat is not considered if InnerLabelType is Empty or CustomText.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.InnerLabelMargin Property

BarChart.InnerLabelMargin Property

Gets or sets the margin around the inner label and its border.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float InnerLabelMargin { get; set; }
Visual Basic

Public Property InnerLabelMargin As Single

Property Value

A float value. Default is 5f.

Remarks

InnerLabelBorder specifies the Border drawn around bar inner labels. The border rectangle is drawn with InnerLabelOutline and filled with InnerLabelBackground.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.InnerLabelOutline Property

BarChart.InnerLabelOutline Property

Gets or sets the Pen for drawing the outline of the border rectangle for inner labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen InnerLabelOutline { get; set; }
Visual Basic

Public Property InnerLabelOutline As Pen

Property Value

An instance of type MindFusion.Drawing.Pen class. Default is a black Pen, width 1.

Remarks

Use InnerLabelBorder to specify the Border for bar inner labels. The label rectangle is filled with InnerLabelBackground. The space between the inner label and its border is set with InnerLabelMargin.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.InnerLabels Property

BarChart.InnerLabels Property

Gets or sets the labels drawn inside bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList InnerLabels { get; set; }
Visual Basic

Public Property InnerLabels As IList

Property Value

An object of type .NET IList that holds lists with the inner labels.

Remarks

The property specifies the labels drawn inside chart bars when the inner label type is set to LabelType.CustomText. Add lists with the labels to the InnerLabels array. The control converts automatically any data to strings.

The data, specified with InnerLabels, is drawn only if the InnerLabelType property is LabelType.CustomText. InnerLabelAlignment sets the alignment of labels inside the bars. If the labels are less than the number of bars the control fills the missing positions with empty strings.

Bars can also have labels at the top. They are set with TopLabelType and TopLabels.

Default value for the InnerLabels property is an empty list.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.InnerLabelType Property

BarChart.InnerLabelType Property

Gets or sets the type of labels drawn inside chart bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LabelType InnerLabelType { get; set; }
Visual Basic

Public Property InnerLabelType As LabelType

Property Value

One of the LabelType Enumeration values.

Remarks

The property specifies what type of labels are drawn inside chart bars. The formatting of the labels is the same as the formatting of the axis, at which the bars are drawn. For formatting and appearance options of the axis, please check the AxisSettings class.

If InnerLabelType is set to LabelType.CustomText, the inner labels are set with InnerLabels. The position of the label in the bar is set with the InnerLabelAlignment property.

Bars can also have labels at the top. They are set with TopLabelType and TopLabels.

Default value for the InnerLabelType property is LabelType.Empty, that is, no labels are drawn.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.TopLabelBackground Property

BarChart.TopLabelBackground Property

Gets or sets the Brush for filling the border rectangle of top labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush TopLabelBackground { get; set; }
Visual Basic

Public Property TopLabelBackground As Brush

Property Value

An instance of MindFusion.Drawing.Brush class. Default is a light blue SolidBrush.

Remarks

Use TopLabelBorder to set the type of Border drawn around top labels in bars. It is drawn with TopLabelOutline. The space between the top label and its border is set with TopLabelMargin.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.TopLabelBorder Property

BarChart.TopLabelBorder Property

Gets or sets the Border drawn around top labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Border TopLabelBorder { get; set; }
Visual Basic

Public Property TopLabelBorder As Border

Property Value

One of the Border Enumeration values. Default value is Border.None.

Remarks

The border rectangle is drawn with TopLabelOutline and filled with TopLabelBackground. The space between the label and its border is set with TopLabelMargin.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace
InnerLabelBorder


MindFusion.Charting.BarChart.TopLabelFormat Property

BarChart.TopLabelFormat Property

Gets or sets the format of top labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public NumberFormat TopLabelFormat { get; set; }
Visual Basic

Public Property TopLabelFormat As NumberFormat

Property Value

One of the NumberFormat enumeration values. Default value is NumberFormat.Fixed_point.

Remarks

The property specifies the format of numbers drawn as labels at the top of chart bars. It is not considered if TopLabelType is LabelType.Empty or LabelType.CustomText.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.TopLabelMargin Property

BarChart.TopLabelMargin Property

Gets or sets the margin around the top label when drawn with border.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float TopLabelMargin { get; set; }
Visual Basic

Public Property TopLabelMargin As Single

Property Value

A float value. Default is 5f.

Remarks

Use TopLabelBorder to specify the Border draw around top labels. The border rectangle is drawn with TopLabelOutline and filled with TopLabelBackground.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.TopLabelOffset Property

BarChart.TopLabelOffset Property

Gets or sets the offset of the top label to the edge of the bar.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float TopLabelOffset { get; set; }
Visual Basic

Public Property TopLabelOffset As Single

Property Value

A float value that specifies the offset.

Remarks

The property specifies at what distance labels at chart bars are drawn measured from the edge of the bar top. The offset is preserved no matter what the value of the TopLabelRotAngle is. Top labels are drawn when the TopLabelType property is not LabelType.Empty. Custom top labels are set with TopLabels.

Bars can also have inner labels. They are set with InnerLabelType and InnerLabels.

Default value for the TopLabelOffset property is 5f.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.TopLabelOutline Property

BarChart.TopLabelOutline Property

Gets or sets the Pen that draws the label border of top labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen TopLabelOutline { get; set; }
Visual Basic

Public Property TopLabelOutline As Pen

Property Value

An instance of type MindFusion.Drawing.Pen class. Default is a black Pen, width 1.

Remarks

Use TopLabelBorder to specify the border drawn around top labels. The border rectangle is filled with TopLabelBackground. The space between the top label and its border is set with TopLabelMargin.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.TopLabelRotAngle Property

BarChart.TopLabelRotAngle Property

Gets or sets the rotation angle of labels at the top of vertical chart bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float TopLabelRotAngle { get; set; }
Visual Basic

Public Property TopLabelRotAngle As Single

Property Value

A float value that specifies the angle, in degrees.

Remarks

The property specifies the angle of rotation for labels at the top of the bars. When the TopLabelRotAngle property is set to 90, the labels are drawn vertically. If the TopLabelRotAngle is 0, the labels are drawn without any rotation, that is horizontally. Values between 0 and 90 rotate the text between absolutely vertical and absolutely horizontal.

The property is useful only for vertical bars. The top labels of horizontal bars are always drawn horizontally.

The type of top labels is set with the TopLabelType property. Custom top labels are specified with the TopLabels property.

Bars can also have inner labels. They are set with InnerLabelType and InnerLabels.

Default value for the TopLabelRotAngle property is 0.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.TopLabels Property

BarChart.TopLabels Property

Gets or sets custom labels drawn at the top of chart bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList TopLabels { get; set; }
Visual Basic

Public Property TopLabels As IList

Property Value

An .NET IList that holds other arrays with the labels.

Remarks

The property specifies the labels drawn at the top of chart bars when the top label type is set to LabelType.CustomText. Data to be drawn can be added directly to the TopLabels array. The control converts automatically any data to strings.

If the labels are less than the number of bars the control fills the missing positions with empty strings.

Bars can also have inner labels. They are set with InnerLabelType and InnerLabels.

Default value for the TopLabels property is an empty array object.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarChart.TopLabelType Property

BarChart.TopLabelType Property

Gets or sets the type of labels drawn at the top of chart bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LabelType TopLabelType { get; set; }
Visual Basic

Public Property TopLabelType As LabelType

Property Value

One of the LabelType Enumeration values.

Remarks

The property specifies what labels are drawn at the top of chart bars. For appearance, format and style settings, please check the AxisSettings class. The style settings for vertical bars are regulated by XAxisSettings, the style settings for horizontal bars - by YAxisSettings.

The custom text for the top labels is set with the TopLabels property.

Bars can also have inner labels. They are set with InnerLabelType and InnerLabels.

Default value for the TopLabelType property is LabelType.Empty, in this case, no labels are drawn.

See Also

BarChart Members
BarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.BarSeriesLayout Enumeration

BarSeriesLayout Enumeration

Specifies the layout of bars in series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum BarSeriesLayout
Visual Basic

Public Enumeration BarSeriesLayout

Members

Member name | Description
InColumn | Bar series are drawn one behind the other, in columns.
InRow | Bar series are drawn next to each other, in a row.
Stacked | Bars in series are drawn stacked.

Remarks

The Enumeration represents the different layouts of bars in multi-series charts. The type of the bar chart depends on the BarType property.

See Also

MindFusion.Charting Namespace
BarSeriesLayout property


MindFusion.Charting.BarType Enumeration

BarType Enumeration

Specifies the different types of bar charts that can be drawn.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum BarType
Visual Basic

Public Enumeration BarType

Members

Member name | Description
Clustered2D | Clusters of 2D bars. Data for each bar in the cluster is taken from elements at the same position in the lists of the Data property.
Clustered3D | Clusters of 3D bars. Data for each bar in the cluster is taken from elements at the same position in the lists of the Data property.
Groups2D | Groups of 2D bars. Data for each bar in the group is taken from the respective list in the Data property.
Groups3D | Groups of 3D bars. Data for each bar in the group is taken from the respective list in the Data property.
Single2D | A single 2D (flat) bar is drawn for each data value.
Single3D | A single 3D bar is drawn for each data value.

Remarks

The Enumeration represents the different types of bars that can be drawn. The property for setting the bar type is called BarType.

Use Depth3D to set the depth for 3D charts. Set Cylinder to true to draw the bars as cylinders. Bars can also be drawn horizontal if Horizontal is set to true. The space among bars depends on BarWidth, DistBtwBars and DistBtwSeries.

The layout of bars in muti-series charts is specified with the BarSeriesLayout enumeration and the BarSeriesLayout property.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.Border Enumeration

Border Enumeration

Specifies the type of border drawn around chart objects.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum Border
Visual Basic

Public Enumeration Border

Members

Member name | Description
Circle | The border is drawn as a circle.
None | No border is drawn.
Rectangle | The border is drawn as a rectangle.
RoundedRect | The border is drawn as a rounded rectangle.

Remarks

Properties that use the Border enumeration include:

  • LineChart.LabelBorder
  • BarChart.InnerLabelBorder, BarChart.TopLabelBorder
  • PieChart.InnerLabelBorder, PieChart.OuterLabelBorder
  • RadarChart.OuterLabelBorder, RadarChart.OuterAxisLabelBorder
  • LegendBorder

See Also

MindFusion.Charting Namespace
LegendBorder
LabelBorder
BarChart.InnerLabelBorder
BarChart.TopLabelBorder
PieChart.InnerLabelBorder
PieChart.OuterLabelBorder
RadarChart.OuterLabelBorder


MindFusion.Charting.Bubble Class

Bubble Class
Remarks See Also

Represents a bubble in bubble charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public sealed class Bubble : ChartElement
Visual Basic

Public NotInheritable Class Bubble
Inherits ChartElement

Remarks

Each bubble in a bubble chart is an instance of the Bubble class. When the user clicks on a bubble in hit-testing, the Bubble object that contains the hitted mouse point is returned.

The members of the Bubble class are read-only. Use the respective bubble properties of the LineChart class to set them.

Inheritance Hierarchy

System.Object
MindFusion.Charting.ChartElement
MindFusion.Charting.Bubble

See Also

Bubble Members
MindFusion.Charting Namespace


MindFusion.Charting.Bubble Members

Bubble Members
Constructors Properties

Represents a bubble in bubble charts.

The following tables list the members exposed by the Bubble type.

Public Constructors

Name | Description
Bubble | Initializes a new instance of the Bubble class.

Public Properties

Name | Description
Label | Gets the label drawn at this bubble.
Value | Gets the value that this bubble represents.

See Also

Bubble Class
MindFusion.Charting Namespace


MindFusion.Charting.Bubble Constructor

Bubble Constructor

Initializes a new instance of the Bubble class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Bubble ()
Visual Basic

Public Sub New ()

See Also

Bubble Class
MindFusion.Charting Namespace


MindFusion.Charting.Bubble Properties

Bubble Properties

Public Properties

Name | Description
Label | Gets the label drawn at this bubble.
Value | Gets the value that this bubble represents.

See Also

Bubble Class
MindFusion.Charting Namespace


MindFusion.Charting.Bubble.Label Property

Bubble.Label Property

Gets the label drawn at this bubble.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string Label { get; }
Visual Basic

Public ReadOnly Property Label As String

Property Value

A string value that represents the label.

Remarks

The text of the bubble depends on LabelType. Custom labels are set with Labels.

See Also

Bubble Members
Bubble Class
MindFusion.Charting Namespace


MindFusion.Charting.Bubble.Value Property

Bubble.Value Property

Gets the value that this bubble represents.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double Value { get; }
Visual Basic

Public ReadOnly Property Value As Double

Property Value

A double number that represents the value of the bubble.

Remarks

The value of the property depends on the number in Y2Data or YData for this bubble. No formatting is applied.

See Also

Bubble Members
Bubble Class
MindFusion.Charting Namespace


MindFusion.Charting.CalculateFunctionDelegate Delegate

CalculateFunctionDelegate Delegate

Invokes a custom function that calculates the values for the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public delegate float CalculateFunctionDelegate (
float xValue,
FunctionArgs e
)
Visual Basic

Public Delegate Function CalculateFunctionDelegate ( _
xValue As Single, _
e As FunctionArgs _
) As Single

Parameters

xValue
the argument of the function, which is computed.
e

Argument of type FunctionArgs. It provides data for the event and has following members:

Member Name

Description

float StartValue

Specifies the beginning of the numerical interval in which the function is calculated.

float EndValue

Specifies the closing value of the numerical interval in which the function is calculated.

double FunctionDelta

Specifies the interval with which function values are calculated.

Return Value

Remarks

The delegate enables custom functions to be computed and drawn rather than settings numbers with XData and YData. The delegate's function argument specifies the numerical interval, in which the function is computed. In order to raise the CalculateFunction event, provide a method that calculates the value of a float argument and returns float result. Then, assign the method to an instance of the CalculateFunctionDelegate delegate.

Example

The following example:

  • Creates a line chart
  • Sets the chart data with a delegate, which calculates the sine function in the interval [-3, 3];

C#

/// <summary>
/// The sine function.
/// </summary>
public float CalculateFunction(float xVal, MindFusion.Charting.FunctionArgs e)
{
return (float)Math.Sin((double)xVal);
}

// ...

// Create the chart
MindFusion.Charting.LineChart chart = new MindFusion.Charting.LineChart(MindFusion.Charting.LineTypes.Line);

// Add the delegate
chart.CalculateFunction = new MindFusion.Charting.CalculateFunctionDelegate(CalculateFunction);

// Set the interval of calculation
chart.FunctionArguments = new MindFusion.Charting.FunctionArgs(-3, 3);

See Also

MindFusion.Charting Namespace


MindFusion.Charting.Chart Class

Chart Class
Remarks See Also

Base class for all chart types - bars, pies, areas, lines, or radars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public abstract class Chart : ICloneable
Visual Basic

Public MustInherit Class Chart Implements ICloneable

Remarks

This class is the base class for all chart types - bar, pie, lines and radar and all their modifications - scatter, cylinder, polar and so on. It provides methods, properties and events for supplying data for drawing the chart and setting different chart customization options.

Each chart type has its own properties for setting the data. The chart series are drawn in the order the data for them is set. If you want to sort the series relatively to each other, use the SortSeriesBy property. SortOrder sorts the numbers in each series. Use ClearData to remove all data and labels from the chart.

ChartBrushes sets the brushes used for drawing all chart types. ChartPens property defines the pens, used for drawing the charts.

The font and brush for the chart labels are specified with the LabelFont and LabelBrush properties.

All charts can have a title and a subtitle. They are set with TitleText and SubTitleText. TitleFont, TitleBrush, SubTitleFont and SubTitleBrush properties specify the font and brush for the title and the subtitle. The TextRenderingHint property sets the quality of rendering for the chart texts.

The chart background is painted with the BackgroundBrush property.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Chart

See Also

Chart Members
MindFusion.Charting Namespace


MindFusion.Charting.Chart Members

Chart Members
Constructors Properties Methods

Base class for all chart types - bars, pies, areas, lines, or radars.

The following tables list the members exposed by the Chart type.

Protected Constructors

Name | Description
Chart | Creates a new instance of the Chart class.

Public Properties

Name | Description
BackgroundBrush | Specifies the brush for the chart background.
ChartBrushes | Specifies the brushes used to draw the charts.
ChartGraphics | Specifies the Graphics object that is used to draw the chart.
ChartMargins | Gets or sets the margins of the chart.
ChartPens | Specifies the pens for the charts.
ChartSize | Specifies the size of the chart's bounding rectangle.
LabelBrush | Specifies the brush that is used for drawing chart labels.
LabelFont | Specifies the font for drawing the chart labels.
LegendAlignment | Gets or sets the alignment of the legend.
LegendBackgroundBrush | Gets or sets the legend background brush.
LegendBorder | Gets or sets the Border of the legend.
LegendBorderMargin | Gets or sets the margin around the LegendBorder.
LegendBrush | Gets or sets the brush for the legend's bounding rectangle.
LegendColumns | Gets or sets the count of columns in the chart legend.
LegendFont | Gets or sets the font for the chart legend.
LegendGridType | Gets or sets the type of the legend grid.
LegendLabels | Gets or sets the labels for the legend.
LegendOffset | Gets or sets the offset of the chart legend.
LegendPen | Gets or sets the pen for the legend's bounding rectangle.
LegendPosition | Gets or sets the position of the chart legend.
LegendWidth | Gets or sets the width of the legend's rectangle.
LegendWordWrap | Gets or sets whether the words of the legend labels are wrapped.
MultiColored | Specifies whether the chart is drawn in one color or in different colors.
MultiColoredLabels | Specifies whether labels at the chart axes are drawn in different colors.
SortOrder | Specifies the sort order of numbers in chart series.
SortSeriesBy | Specifies the sort order of data series.
SubTitleBrush | Specifies the brush that is used for drawing the chart subtitle.
SubTitleFont | Specifies the font, which is used to draw the chart subtitle.
SubTitleOffset | Gets or sets the offset of the SubTitleText.
SubTitleText | Specifies the text for the chart subtitle.
TextRenderingHint | Specifies the quality, with which text is rendered.
TitleBrush | Specifies the brush that is used to draw the chart title.
TitleFont | Specifies the font, which is used to draw the chart title.
TitleOffset | Gets or sets the offset of the TitleText.
TitleText | Specifies the text for the chart title.
TopLeftPosition | Specifies the position of the chart in the graphics object.

Public Methods

Name | Description
CalculateSize | Calculates the size of the chart.
ClearData | Removes all labels and numerical data from the chart.
ClearDataBoundLists | Clears all IList properties that support data binding.
Clone | Creates an exact copy of the current Chart object.
DrawChart | Draws the chart in the object assigned to the Graphics property.
HitTest | Checks whether a point with the particular coordinates is contained inside a chart element.

Protected Methods

Name | Description
CreateChart | Creates a new Chart object.
IsDateTime | Checks if a list contains DateTime values.

See Also

Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart Constructor

Chart Constructor

Creates a new instance of the Chart class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

protected Chart ()
Visual Basic

Protected Sub New ()

See Also

Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart Methods

Chart Methods

Public Methods

Name | Description
CalculateSize | Calculates the size of the chart.
ClearData | Removes all labels and numerical data from the chart.
ClearDataBoundLists | Clears all IList properties that support data binding.
Clone | Creates an exact copy of the current Chart object.
DrawChart | Draws the chart in the object assigned to the Graphics property.
HitTest | Checks whether a point with the particular coordinates is contained inside a chart element.

Protected Methods

Name | Description
CreateChart | Creates a new Chart object.
IsDateTime | Checks if a list contains DateTime values.

See Also

Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.CalculateSize Method

Chart.CalculateSize Method

Calculates the size of the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public virtual SizeF CalculateSize ()
Visual Basic

Public Overridable Function CalculateSize () As SizeF

Return Value

An object of type .NET SizeF structure that represents the chart size.

Remarks

The method is overridden by all chart classes. It calculates the size, in points, of the chart's bounding rectangle. If it is called before all chart settings are finished, it might return a wrong result.

If you have set the chart to be drawn at a position in the chart's bounding rectangle different that (0, 0), the size of the chart shall remain unchanged, for example, a chart with size 200 x 300 does not turn to 220 x 320 chart if the TopLeftPosition property is set to (20, 20).

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.ClearData Method

Chart.ClearData Method

Removes all labels and numerical data from the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public virtual void ClearData ()
Visual Basic

Public Overridable Sub ClearData ()

Remarks

The method removes any data that has been set to the chart. If the LabelType of a chart axis is AxisLabelType.AutoScale, the scale labels remain. Labels of any other type are cleared.

Data is removed from the XData, YData, Y2Data, Data, XLabels, YLabels and Y2Labels properties. The inner and top labels of bar charts are also removed; the labels for radar charts are removed too. The proportions of the chart are left - the length of the axis, the radius and so on.

If the chart has a legend, the LegendLabels are also cleared. Any title, subtitle, brushes and pens are left.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace
BarChart.InnerLabels
BarChart.TopLabels
PieChart.InnerLabels
PieChart.OuterLabels
RadarChart.InnerAxisLabels
RadarChart.OuterAxisLabels
RadarChart.OuterLabels


MindFusion.Charting.Chart.ClearDataBoundLists Method

Chart.ClearDataBoundLists Method

Clears all IList properties that support data binding.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public virtual void ClearDataBoundLists ()
Visual Basic

Public Overridable Sub ClearDataBoundLists ()

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.Clone Method

Chart.Clone Method

Creates an exact copy of the current Chart object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

The new chart object.

Remarks

The method creates an exact copy of the current chart - all appearance settings and data is copied. It is overridden by all chart classes - the returned object must be cast to the chart type that you clone.

All properties, labels and data are cloned. The method is available only when you use the chart object programmatically.

Example

C#

MindFusion.Charting.RadarChart myChart =
new MindFusion.Charting.RadarChart(RadarType.Radar2D);

// Chart settings follow
MindFusion.Charting.RadarChart clonedChart =
myChart.Clone() as MindFusion.Charting.RadarChart;

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.CreateChart Method

Chart.CreateChart Method

Creates a new Chart object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

protected abstract Chart CreateChart ()
Visual Basic

Protected MustOverride Function CreateChart () As Chart

Return Value

The new chart.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.DrawChart Method

Chart.DrawChart Method

Draws the chart in the object assigned to the Graphics property.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public virtual void DrawChart ()
Visual Basic

Public Overridable Sub DrawChart ()

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.HitTest Method

Chart.HitTest Method

Checks whether a point with the particular coordinates is contained inside a chart element.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public virtual ChartElement HitTest (
int x,
int y
)
Visual Basic

Public Overridable Function HitTest ( _
x As Integer, _
y As Integer _
) As ChartElement

Parameters

x
The X-coordinate of the point to check.
y

The Y-coordinate of the point to check.

Return Value

An object of type ChartElement that contains the point described by the two parameters of the function; null if no object is found.

Remarks

Call this method inside event handlers for user interaction with the mouse. The mouse coordinates are retrieved from the event data.

The Chart control overrides HitTest to return a specific chart element. Cast the result to Bar, Line, Scatter, Bubble, PiePiece or RadarPiece according to the chart type you are using. All HitTest methods may return null so always check.

See Also

HitTestBar
HitTestBubble
HitTestLine
HitTestPie
HitTestRadar
HitTestScatter
Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.IsDateTime Method

Chart.IsDateTime Method

Checks if a list contains DateTime values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

protected bool IsDateTime (
ArrayList dataArrays
)
Visual Basic

Protected Function IsDateTime ( _
dataArrays As ArrayList _
) As Boolean

Parameters

dataArrays
The list to check.

Return Value

True if the list contains DateTime values; otherwise false.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart Properties

Chart Properties

Public Properties

Name | Description
BackgroundBrush | Specifies the brush for the chart background.
ChartBrushes | Specifies the brushes used to draw the charts.
ChartGraphics | Specifies the Graphics object that is used to draw the chart.
ChartMargins | Gets or sets the margins of the chart.
ChartPens | Specifies the pens for the charts.
ChartSize | Specifies the size of the chart's bounding rectangle.
LabelBrush | Specifies the brush that is used for drawing chart labels.
LabelFont | Specifies the font for drawing the chart labels.
LegendAlignment | Gets or sets the alignment of the legend.
LegendBackgroundBrush | Gets or sets the legend background brush.
LegendBorder | Gets or sets the Border of the legend.
LegendBorderMargin | Gets or sets the margin around the LegendBorder.
LegendBrush | Gets or sets the brush for the legend's bounding rectangle.
LegendColumns | Gets or sets the count of columns in the chart legend.
LegendFont | Gets or sets the font for the chart legend.
LegendGridType | Gets or sets the type of the legend grid.
LegendLabels | Gets or sets the labels for the legend.
LegendOffset | Gets or sets the offset of the chart legend.
LegendPen | Gets or sets the pen for the legend's bounding rectangle.
LegendPosition | Gets or sets the position of the chart legend.
LegendWidth | Gets or sets the width of the legend's rectangle.
LegendWordWrap | Gets or sets whether the words of the legend labels are wrapped.
MultiColored | Specifies whether the chart is drawn in one color or in different colors.
MultiColoredLabels | Specifies whether labels at the chart axes are drawn in different colors.
SortOrder | Specifies the sort order of numbers in chart series.
SortSeriesBy | Specifies the sort order of data series.
SubTitleBrush | Specifies the brush that is used for drawing the chart subtitle.
SubTitleFont | Specifies the font, which is used to draw the chart subtitle.
SubTitleOffset | Gets or sets the offset of the SubTitleText.
SubTitleText | Specifies the text for the chart subtitle.
TextRenderingHint | Specifies the quality, with which text is rendered.
TitleBrush | Specifies the brush that is used to draw the chart title.
TitleFont | Specifies the font, which is used to draw the chart title.
TitleOffset | Gets or sets the offset of the TitleText.
TitleText | Specifies the text for the chart title.
TopLeftPosition | Specifies the position of the chart in the graphics object.

See Also

Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.BackgroundBrush Property

Chart.BackgroundBrush Property

Specifies the brush for the chart background.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush BackgroundBrush { get; set; }
Visual Basic

Public Property BackgroundBrush As Brush

Property Value

An object of the MindFusion.Drawing.Brush class.

Remarks

The property specifies the brush for the entire chart background. If the chart is drawn in a graphics, bigger than its size the background brush paints only the background of the chart bounding rectangle and not the whole graphics.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace
BkgrImagePos
ImagePos Enumeration


MindFusion.Charting.Chart.ChartBrushes Property

Chart.ChartBrushes Property

Specifies the brushes used to draw the charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection ChartBrushes { get; set; }
Visual Basic

Public Property ChartBrushes As BrushCollection

Property Value

A value of the .NET IList class filled with objects of type MindFusion.Drawing.BrushCollection class.

Remarks

The property is used for drawing of any type of chart. If the MultiColored property is set to true, the brushes are taken from the ChartBrushes list one after the other till all graphics or chart parts are drawn. If the brushes needed are more than the brushes specified, the control cycles through them as many times as necessary. Thus, in a bar chart, which is multicoloured and has 9 bars, but only 5 brushes are specified, the bars from 1 to 5 are filled with the 5 brushes specified, the 6th bar - with the first brush and so on. When the chart is not multi-colored, just the first brush is used for filling of all chart graphics or chart parts.

The ChartBrushes property also sets the colors of the small squares that are drawn in legends before each legend text. If the ChartPens are specified and the ChartBrushes is an empty list, then the control fills the ChartBrushes with solid brushes, which are the same color and count as the ChartPens. If the ChartBrushes are specified and the ChartPens is an empty list, then the chart pens are filled with Pen-s which are equal in count and color to the ChartBrushes and have default width 1.

You can fill the ChartBrushes list with all sorts of brushes, which are derived from the MindFusion.Drawing.Brush class - HatchBrush, SolidBrush and so on.

Default value for the ChartBrushes property is an empty IList.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace
MultiColored


MindFusion.Charting.Chart.ChartGraphics Property

Chart.ChartGraphics Property

Specifies the Graphics object that is used to draw the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IGraphics ChartGraphics { get; set; }
Visual Basic

Public Property ChartGraphics As IGraphics

Property Value

An instance of the IGraphics class.

Remarks

If you want to draw a chart programmatically, set a valid IGraphics object. This enables you not only to create and save charts in files but also to nest charts in Windows applications.

If no valid IGraphics object is set before DrawChart is called, the control shall not visibly draw any chart.

Default value for the ChartGraphics property is null.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace
ChartSize
CalculateSize method


MindFusion.Charting.Chart.ChartMargins Property

Chart.ChartMargins Property

Gets or sets the margins of the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Margins ChartMargins { get; set; }
Visual Basic

Public Property ChartMargins As Margins

Property Value

An instance of the Margins class. Default is Margins set to 10f at all four sides.

Remarks

Use the property to specify the space around the chart at all sides - left, top, right and bottom.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.ChartPens Property

Chart.ChartPens Property

Specifies the pens for the charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PenCollection ChartPens { get; set; }
Visual Basic

Public Property ChartPens As PenCollection

Property Value

A value of the .NET IList class that holds objects of type MindFusion.Drawing. PenCollection class.

Remarks

The control uses ChartPens to draw line charts, area charts with outlining as well pie and doughnut charts.

If both the ChartPens and ChartBrushes properties are empty, the control uses a default white-blue gradient brush and a black pen.

If the ChartBrushes are specified and the ChartPens is an empty list, then the control fills the ChartPens with pens which are the same count and color as the chart brushes and with default width 1. If the chart pens are specified, the control fills the chart brushes with solid brushes, which are the same color and count as the pens.

Default value of the ChartPens property is an empty array.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.ChartSize Property

Chart.ChartSize Property

Specifies the size of the chart's bounding rectangle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public SizeF ChartSize { get; }
Visual Basic

Public ReadOnly Property ChartSize As SizeF

Property Value

A value of type .NET SizeF structure.

Remarks

The property is read-only and specifies the size of the chart.

Note

If you access it before specifying all chart settings, the result might not be correct.

The property is meaningful when using the control programmatically. The size of the chart is calculated according to its data and customization options and cannot be changed. You can also use the CalculateSize method to calculate the dimensions of the chart's bounding rectangle.

The size of the chart does not change when the chart's TopLeftPosition property is changed.
Initial value for the ChartSize property is (0, 0).

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.LabelBrush Property

Chart.LabelBrush Property

Specifies the brush that is used for drawing chart labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush LabelBrush { get; set; }
Visual Basic

Public Property LabelBrush As Brush

Property Value

An object of the MindFusion.Drawing.Brush class.

Remarks

The property is used to draw the labels in all chart types. It is used for inner and top labels in bar charts, for scatter labels in line charts, inner and outer labels in pie charts and for the outer labels in radars. The labels are drawn with LabelFont.

Default value for the LabelBrush property is a black SolidBrush.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace
LabelFont


MindFusion.Charting.Chart.LabelFont Property

Chart.LabelFont Property

Specifies the font for drawing the chart labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Font LabelFont { get; set; }
Visual Basic

Public Property LabelFont As Font

Property Value

An object of the .NET Font class.

Remarks

The property specifies the font for the labels at both X and Y chart axes as well inside and outside pie pieces in pie charts.

LabelFont is also used for drawing the explanation label and the unit of measure at the chart axis, in case they are set.

Any text, drawn with the LabelFont uses the LabelBrush for the drawing.

Default value of the LabelFont property is Times New Roman, size 10.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace
MultiColoredLabels


MindFusion.Charting.Chart.LegendAlignment Property

Chart.LegendAlignment Property

Gets or sets the alignment of the legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Alignment LegendAlignment { get; set; }
Visual Basic

Public Property LegendAlignment As Alignment

Property Value

One of the Alignment Enumeration values.

Remarks

The LegendAlignment property specifies the alignment of the legend at the side of the chart that it is drawn at.

Chart legends are drawn when the LegendLabels property is not an empty array. The position of the chart legend is set with LegendPosition.

Default value for the LegendAlignment property is Alignment.Begin.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.LegendBackgroundBrush Property

Chart.LegendBackgroundBrush Property

Gets or sets the legend background brush.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush LegendBackgroundBrush { get; set; }
Visual Basic

Public Property LegendBackgroundBrush As Brush

Property Value

An object of type MindFusion.Drawing.Brush.

Remarks

The LegendBackgroundBrush object is used for drawing the background of the chart's legend. The legend bounding rectangle is drawn with LegendPen.

A chart is drawn with a legend when the LegendLabels property is not an empty array.

Default value for the LegendBackgroundBrush property is null.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.LegendBorder Property

Chart.LegendBorder Property

Gets or sets the Border of the legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Border LegendBorder { get; set; }
Visual Basic

Public Property LegendBorder As Border

Property Value

One of the Border Enumeration values. Default is Border.Rectangle.

Remarks

The border rectangle is drawn with LegendPen and filled with LegendBackgroundBrush. The space between the border and the LegendLabels is set with LegendBorderMargin.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.LegendBorderMargin Property

Chart.LegendBorderMargin Property

Gets or sets the margin around the LegendBorder.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float LegendBorderMargin { get; set; }
Visual Basic

Public Property LegendBorderMargin As Single

Property Value

A float value. Default is 10f.

Remarks

The type of the border is set with LegendBorder. The border rectangle is drawn with LegendPen and filled with LegendBackgroundBrush.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.LegendBrush Property

Chart.LegendBrush Property

Gets or sets the brush for the legend's bounding rectangle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush LegendBrush { get; set; }
Visual Basic

Public Property LegendBrush As Brush

Property Value

An object of type MindFusion.Drawing.Brush.

Remarks

The LegendBrush object is used for drawing the legend labels. Legend labels are set with the LegendLabels property. The count of columns in the legend is set with LegendColumns.
Default value for the LegendBrush property is a black SolidBrush.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.LegendColumns Property

Chart.LegendColumns Property

Gets or sets the count of columns in the chart legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int LegendColumns { get; set; }
Visual Basic

Public Property LegendColumns As Integer

Property Value

An int value that represents the count of columns. Default is 1.

Remarks

Legend is drawn when LegendLabels is not an empty list.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace
LegendLabels


MindFusion.Charting.Chart.LegendFont Property

Chart.LegendFont Property

Gets or sets the font for the chart legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Font LegendFont { get; set; }
Visual Basic

Public Property LegendFont As Font

Property Value

An object of type System.Drawing.Font.

Remarks

The property specifies the font for the legend labels. The height of the font sets the height of the squares before the legend labels. The labels are drawn with LegendBrush.

Legends are drawn when the LegendLabels property is not an empty array. The position of the legend and its alignment is specified with LegendPosition and LegendAlignment.

Default value for the LegendFont property is Times New Roman, 10.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.LegendGridType Property

Chart.LegendGridType Property

Gets or sets the type of the legend grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public GridType LegendGridType { get; set; }
Visual Basic

Public Property LegendGridType As GridType

Property Value

One of the GridType Enumeration members.

Remarks

Legends can be drawn with a grid. The grid can separate the rows, columns or both. Legends cannot have custom or chess grids.

The grid is drawn with the LegendPen. Legend is drawn when the LegendLabels property is not an empty list.

Default value for the LegendGridType property is GridType.None.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.LegendLabels Property

Chart.LegendLabels Property

Gets or sets the labels for the legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList LegendLabels { get; set; }
Visual Basic

Public Property LegendLabels As IList

Property Value

A list that contains the legend labels.

Remarks

Add the legend labels to the LegendLabels property or assign to it a list that holds the labels. If the labels are not strings, the control converts them automatically. Words can be kept whole if a label is drawn in multiple rows if you set LegendWordWrap to true.

The labels can be drawn in as many columns as set by LegendColumns properties. The labels are drawn with LegendBrush.

Default value for the LegendLabels property is an empty list.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.LegendOffset Property

Chart.LegendOffset Property

Gets or sets the offset of the chart legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float LegendOffset { get; set; }
Visual Basic

Public Property LegendOffset As Single

Property Value

A float value that specifies the offset.

Remarks

The offset of the legend is considered from the edge of the legend to the nearest chart object - the plot area, chart labels or the chart axes.

The position of the legend is set with LegendPosition. Alignment is specified with LegendAlignment. Legend is drawn when the LegendLabels is not an empty list.

Default value for the LegendOffset property is 15f.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.LegendPen Property

Chart.LegendPen Property

Gets or sets the pen for the legend's bounding rectangle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen LegendPen { get; set; }
Visual Basic

Public Property LegendPen As Pen

Property Value

An object of type MindFusion.Drawing.Pen.

Remarks

Legends can be drawn with an outlining. When the legend's bounding rectangle is drawn the pen is set with LegendPen. When the property is set to null, no legend's bounding rectangle is drawn.

The LegendPen is also used for drawing the legend grid. Legend grid is drawn when the LegendGridType property is not GridType.None. The columns of the legend labels can be set with LegendColumns.

Default value for the LegendPen property is a black pen, width 1.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.LegendPosition Property

Chart.LegendPosition Property

Gets or sets the position of the chart legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Position LegendPosition { get; set; }
Visual Basic

Public Property LegendPosition As Position

Property Value

One of the Position enumeration values.

Remarks

The property specifies the position of the chart legend at the chart's plot area. The alignment of the legend is set with LegendAlignment.

Legends are drawn when the LegendLabels property contains at least one list item with a label.

The labels can be drawn with an offset to the axes / plot area, at which it is drawn. Use LegendOffset to set the offset.

Default value for the LegendPosition property is Position.Right.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.LegendWidth Property

Chart.LegendWidth Property

Gets or sets the width of the legend's rectangle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float LegendWidth { get; set; }
Visual Basic

Public Property LegendWidth As Single

Property Value

A float value. Default is float.NaN.

Remarks

When LegendWidth is set to float.NaN the control calculates automatically the width of the legend so that all LegendLabels could fit in without being broken into several lines.

When the LegendWidth is custom-set, the legend value is considered to include the LegendBorderMargin, the space for the color indicators before each legend label and and so on. If space is not enough, LegendLabels are broken into several lines. Words are kept whole if LegendWordWrap is set to true.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.LegendWordWrap Property

Chart.LegendWordWrap Property

Gets or sets whether the words of the legend labels are wrapped.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool LegendWordWrap { get; set; }
Visual Basic

Public Property LegendWordWrap As Boolean

Property Value

A bool value that specifies whether legend words are wrapped.

Remarks

When the legend labels are too long they might be automatically broken into several lines. If LegendWordWrap is set to true, only whole words are drawn at each line. In this case, provide enough space for the words to be drawn in order to avoid overlapping of labels.

The property for setting the width of the legend is LegendWidth.

Default value for the LegendWordWrap property is false.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.MultiColored Property

Chart.MultiColored Property

Specifies whether the chart is drawn in one color or in different colors.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool MultiColored { get; set; }
Visual Basic

Public Property MultiColored As Boolean

Property Value

A bool value.

Remarks

The property specifies whether different parts of the chart are drawn with different colors, which means:

  • In bar charts, whether data bars are drawn in one color or in several colors;
  • For pie/doughnut charts, whether the pie pieces are drawn in same color or not;
  • For area/line/bubble charts, whether separate lines / areas / bubbles are drawn in one color or not;

When the property is set to false, the charts are drawn only with the first brush from the ChartBrushes list. Otherwise, all brushes are used in a continuous cycle if their number is less than the number of the chart parts they should draw.

Default value for the MultiColored property is true.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.MultiColoredLabels Property

Chart.MultiColoredLabels Property

Specifies whether labels at the chart axes are drawn in different colors.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool MultiColoredLabels { get; set; }
Visual Basic

Public Property MultiColoredLabels As Boolean

Property Value

A bool value.

Remarks

This property enables labels drawn at both chart axes to be drawn in same colors as the parts of the chart they refer to. This makes charts more readable.

When the property is true, the labels are drawn with brushes from the ChartBrushes property. When it is false, the labels are drawn with the LabelBrush.

Default value for the MultiColoredLabels property is false.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.SortOrder Property

Chart.SortOrder Property

Specifies the sort order of numbers in chart series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public SortOrder SortOrder { get; set; }
Visual Basic

Public Property SortOrder As SortOrder

Property Value

One of the SortOrder Enumeration values.

Remarks

This property specifies how the data in each series is sorted. The sorting is performed on all data lists.

For charts that use the Cartesian coordinate system the orientation is considered - XData is sorted in horizontal and YData in vertical ones. For charts without axes, PieChart.Data, BarChart.Data or RadarChart.Data is sorted.

Together with the data all label lists are rearranged in the same order as the sorted data.

SortOrder sorts the numbers in the data arrays. SortSeriesBy sorts the data lists.

Default value for the SortOrder property is SortOrder.None.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.SortSeriesBy Property

Chart.SortSeriesBy Property

Specifies the sort order of data series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public SortSeriesBy SortSeriesBy { get; set; }
Visual Basic

Public Property SortSeriesBy As SortSeriesBy

Property Value

One of the SortSeriesBy Enumeration values.

Remarks

This property specifies the sort order of data series relatively to each other.

When considered for charts that use the Cartesian coordinate system, the XData and YData properties are sorted. Sorting is performed on the YData for vertical charts and XData for horizontal ones. When it is considered for charts that use one data list, BarChart.Data, PieChart.Data or RadarChart.Data are considered.

Sorting is performed on the lists as complex objects and not on the numbers inside the lists. The property that sorts the data in the data lists is called SortOrder.

When the data lists consist of lists with members similar in count, it is better to sort them by their sum. Otherwise, it is better to use SortSeriesBy.MaxValue as sorting criterion.

When the data lists are sorted, the same sorting order is applied to all label lists for the chart.

Default value for the SortSeriesBy property is SortSeriesBy.Nothing.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.SubTitleBrush Property

Chart.SubTitleBrush Property

Specifies the brush that is used for drawing the chart subtitle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush SubTitleBrush { get; set; }
Visual Basic

Public Property SubTitleBrush As Brush

Property Value

An object of the MindFusion.Drawing.Brush class.

Remarks

This property is used when subtitle for the chart is drawn. The subtitle text is specifies with SubTitleText property and is drawn with the SubTitleFont property. The subtitle text can be broken in several lines with the new line ("\n") symbol.

Default value for the SubTitleBrush property is a black SolidBrush.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.SubTitleFont Property

Chart.SubTitleFont Property

Specifies the font, which is used to draw the chart subtitle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Font SubTitleFont { get; set; }
Visual Basic

Public Property SubTitleFont As Font

Property Value

A value of the .NET Font class.

Remarks

The property defines the font with which the chart's subtitle is drawn. The subtitle text is specified with the SubTitleText property. Leave it an empty string, if you do not want any subtitle to be drawn. The subtitle is drawn with the SubTitleBrush property. The subtitle is always drawn under the title (if any).

You can make the subtitle text in several lines by using the new line ("\n") symbol.

Default value for the SubTitleFont property is Times New Roman, size 14.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.SubTitleOffset Property

Chart.SubTitleOffset Property

Gets or sets the offset of the SubTitleText.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float SubTitleOffset { get; set; }
Visual Basic

Public Property SubTitleOffset As Single

Property Value

A float value. Default is 5f.

Remarks

The property specifies the space between the SubTitleText and the nearest chart object.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.SubTitleText Property

Chart.SubTitleText Property

Specifies the text for the chart subtitle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string SubTitleText { get; set; }
Visual Basic

Public Property SubTitleText As String

Property Value

A string value.

Remarks

The property specifies the text that is drawn as chart subtitle. If the SubTitleText is an empty string no subtitle is drawn. The subtitle is always drawn under the title (if any).

The subtitle is drawn with font and brush set respectively by the SubTitleFont and SubTitleBrush properties and is aligned in the center.

You can make the subtitle multi-lined if you insert the new line symbol ("\n") in the positions in the subtitle string, where you want new lines.

Default value of the SubTitleText property is an empty string.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.TextRenderingHint Property

Chart.TextRenderingHint Property

Specifies the quality, with which text is rendered.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public TextRenderingHint TextRenderingHint { get; set; }
Visual Basic

Public Property TextRenderingHint As TextRenderingHint

Property Value

A value of type System.DrawingText.TextRenderingHint.

Remarks

The property specifies the quality, with which chart texts are rendered. It is applied to all texts that are displayed at the chart - legend labels, title and subtitle, axis labels and so on.

The values of the TextRenderingHint enumeration range from System.Default, which means poor quality but fast performance to AntiAlias, which gives high quality but slow performance. Good choice for text displayed on screen is one of the ClearType values.

Please, check the System.Drawing.TextRenderingHint enumeration for more details about the different text rendering options.

Default value for the TextRenderingHint property is TextRenderingHint.System.Default.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.TitleBrush Property

Chart.TitleBrush Property

Specifies the brush that is used to draw the chart title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush TitleBrush { get; set; }
Visual Basic

Public Property TitleBrush As Brush

Property Value

A value of the MindFusion.Drawing.Brush class.

Remarks

This property is used when title for the chart is drawn. The title is set with TitleText and is drawn with TitleFont.

You can draw the title text in more than one line using the new line ("\n") symbol.

Default value for the TitleBrush property is a black SolidBrush.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.TitleFont Property

Chart.TitleFont Property

Specifies the font, which is used to draw the chart title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Font TitleFont { get; set; }
Visual Basic

Public Property TitleFont As Font

Property Value

A value of type .NET Font class.

Remarks

The property defines the font with which the chart's title is drawn. The title text is specified with the TitleText property. If it is an empty string, no title is drawn. The title is drawn with the TitleBrush property and is always above the subtitle.

You can make the title text in several lines by using the new line ("\n") symbol.

Default value for the TitleFont property is Times New Roman, size 16.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.TitleOffset Property

Chart.TitleOffset Property

Gets or sets the offset of the TitleText.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float TitleOffset { get; set; }
Visual Basic

Public Property TitleOffset As Single

Property Value

A float value. Default is 5f.

Remarks

TitleOffset specifies the space between the title label and the nearest chart object - the SubTitleText, if drawn or the chart graphics.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.TitleText Property

Chart.TitleText Property

Specifies the text for the chart title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string TitleText { get; set; }
Visual Basic

Public Property TitleText As String

Property Value

A string value.

Remarks

The property specifies the title for all chart types. If it is an empty string, no title is drawn.

The chart title is drawn with font and brush set respectively by the TitleFont and TitleBrush properties. The title is placed at the top of the chart and is aligned in the center. It is always drawn above the subtitle, if any.

You can draw the title in more than one line by inserting the new line ("\n") symbol in those positions in the text that you want to start at a new line. The control itself does not divide the title text but adjusts the width of the chart so that the title could fit in.

Default value of the TitleText property is an empty string.

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.Chart.TopLeftPosition Property

Chart.TopLeftPosition Property

Specifies the position of the chart in the graphics object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PointF TopLeftPosition { get; set; }
Visual Basic

Public Property TopLeftPosition As PointF

Property Value

An instance of the .NET PointF structure. Default value for the TopLeftPosition property is (0,0).

Remarks

The property enables you to draw a chart at a position different from the top left corner of the graphics object's bounding rectangle.

Note

The position of the chart does not change its size, when calculated by CalculateSize.

Provide larger graphics object if you are not going to position the chart in it at (0, 0).

See Also

Chart Members
Chart Class
MindFusion.Charting Namespace


MindFusion.Charting.ChartElement Class

ChartElement Class
Remarks See Also

Base class for all chart elements - Bar, Line, Scatter, Bubble, PiePiece and RadarPiece.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public abstract class ChartElement
Visual Basic

Public MustInherit Class ChartElement

Remarks

Objects of type ChartElement are returned by the HitTest method. The result must be converted according to the type of the chart that is hit-tested.

Conversion can be omitted if you use any of the chart - specific methods for hit-testing: HitTestBar, HitTestBubble, HitTestLine, HitTestPie and HitTestRadar, HitTestScatter. Both the chart - specific and the general method might return null, so always check.

Inheritance Hierarchy

System.Object
MindFusion.Charting.ChartElement

See Also

ChartElement Members
MindFusion.Charting Namespace


MindFusion.Charting.ChartElement Members

ChartElement Members
Constructors Properties

Base class for all chart elements - Bar, Line, Scatter, Bubble, PiePiece and RadarPiece.

The following tables list the members exposed by the ChartElement type.

Public Constructors

Name | Description
ChartElement | Creates a new instance of the ChartElement class.

Public Properties

Name | Description
Index | Gets the index of the chart element.

See Also

ChartElement Class
MindFusion.Charting Namespace


MindFusion.Charting.ChartElement Constructor

ChartElement Constructor

Creates a new instance of the ChartElement class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public ChartElement ()
Visual Basic

Public Sub New ()

See Also

ChartElement Class
MindFusion.Charting Namespace


MindFusion.Charting.ChartElement Properties

ChartElement Properties

Public Properties

Name | Description
Index | Gets the index of the chart element.

See Also

ChartElement Class
MindFusion.Charting Namespace


MindFusion.Charting.ChartElement.Index Property

ChartElement.Index Property

Gets the index of the chart element.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int Index { get; }
Visual Basic

Public ReadOnly Property Index As Integer

Property Value

An int value that specifies the index.

Remarks

The index of the element represents the place that the chart element has among all other chart elements. The index is calculated according to the position of the data value it represents among all other data values. This means:

  • For line charts, the Index represents the index of the Line series in the XData and YData properties.
  • For bar charts, the index of the Bar represents the position of the number, which is represented by this Bar in the Data list.
  • For scatter charts, the Index represents the position of the value, which this scatter represents in the YData or XData lists, depending on whether the chart is vertical or horizontal.
  • For bubble charts, the Index represents the index of the number, which is shown by this Bubble in the YData or Y2Data list if used.
  • For pie charts, the Index shows the position of the PiePiece in the chart.
  • For radar charts, the Index shows the position of the RadarPiece in the chart.

All ChartElement objects in a chart have unique indexes. The index remains unchanged even when sorting has been applied.

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting Namespace


MindFusion.Charting.DataFormat Enumeration

DataFormat Enumeration

Specifies the type of data values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum DataFormat
Visual Basic

Public Enumeration DataFormat

Members

Member name | Description
Auto | The format of the data is set automatically.
DateTime | Chart data is DateTime values.
Number | Chart data is numbers.

Remarks

Data in line charts can be either Number or DateTime values. Use AxisSettings.DataFormat to set the correct data format. When set to Auto, the control tries to convert all data to DateTime values. If a single conversion fails, the DataFormat is set to Number.

See Also

MindFusion.Charting Namespace
DateTimeFormat Enumeration
NumberFormat Enumeration
LineChart class
Setting the Chart's Data
Setting the Chart's Labels


MindFusion.Charting.DateTimeFormat Enumeration

DateTimeFormat Enumeration

Specifies formats for DateTime values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum DateTimeFormat
Visual Basic

Public Enumeration DateTimeFormat

Members

Member name | Description
CustomDateTime | Indicates that the number is formatted as a DateTime value according to a custom-set string.
FullDateTime | Indicates that the number is formatted as a DateTime value with a full date pattern.
LongDate | Indicates that the number is formatted as a DateTime value with a long date pattern.
LongTime | Indicates that the number is formatted as a DateTime value with a long time pattern.
MonthDateTime | Indicates that the number is formatted as a DateTime value with a month day pattern.
None | The DateTime value is not formatted.
ShortDate | Indicates that the number is formatted as a DateTime value with a short date pattern.
ShortTime | Indicates that the number is formatted as a DateTime value with a short time pattern.
YearDateTime | Indicates that the number is formatted as a DateTime value with a year month date pattern.

Remarks

The format of axis labels can be set by using the DateTimeFormat values if the DataFormat property is set to DateTime.

See Also

MindFusion.Charting Namespace
Using DateTime Values
DateTimeFormat Property


MindFusion.Charting.DoubleCollection Class

DoubleCollection Class

Represents a strongly typed collection of double numbers.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public class DoubleCollection : CollectionBase
Visual Basic

Public Class DoubleCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Charting.DoubleCollection

See Also

DoubleCollection Members
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection Members

DoubleCollection Members
Constructors Properties Methods

Represents a strongly typed collection of double numbers.

The following tables list the members exposed by the DoubleCollection type.

Public Constructors

Name | Description
DoubleCollection | Overloaded. Initializes a new instance of the DoubleCollection class.

Public Properties

Name | Description
Item | Gets or sets the double number, located at the specified position.

Public Methods

Name | Description
Add | Adds the specified double number to the collection.
Compare | Compares the contents of this collection with the contents of the specified list.
Contains | Checks whether the specified double number is contained in the collection.
GetValues | Returns an array containing the elements of this collection.
IndexOf | Returns the index of the first occurrence of the specified double number.
Insert | Inserts the specified double number at the specified position within the collection.
Remove | Removes the first occurrence of the specified double number from the collection.
RemoveAt | Removes the double number at the specified index.
ToString | CollectionBase.ToString override.

See Also

DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection Constructor

DoubleCollection Constructor

Initializes a new instance of the DoubleCollection class.

Overload List

Name | Description
DoubleCollection () | Initializes a new instance of the DoubleCollection class.
DoubleCollection (Double[]) | Initializes a new instance of the DoubleCollection class with the specified initial values.
DoubleCollection (ICollection) | Initializes a new instance of the DoubleCollection class with the specified initial values.
DoubleCollection (String) | Initializes a new instance of the DoubleCollection class.

See Also

DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection Constructor ()

DoubleCollection Constructor ()
See Also

Initializes a new instance of the DoubleCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public DoubleCollection ()
Visual Basic

Public Sub New ()

See Also

DoubleCollection Constructor Overload List
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection Constructor (Double[])

DoubleCollection Constructor (Double[])
See Also

Initializes a new instance of the DoubleCollection class with the specified initial values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public DoubleCollection (
double[] values
)
Visual Basic

Public New ( _
values() As Double _
)

Parameters

values

See Also

DoubleCollection Constructor Overload List
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection Constructor (ICollection)

DoubleCollection Constructor (ICollection)
See Also

Initializes a new instance of the DoubleCollection class with the specified initial values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public DoubleCollection (
ICollection values
)
Visual Basic

Public New ( _
values As ICollection _
)

Parameters

values
An instance of type .NET ICollection, which contains the initial labels for the collection.

See Also

DoubleCollection Constructor Overload List
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection Constructor (String)

DoubleCollection Constructor (String)
See Also

Initializes a new instance of the DoubleCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public DoubleCollection (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation

The string identifier of the DoubleCollection.

See Also

DoubleCollection Constructor Overload List
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection Methods

DoubleCollection Methods

Public Methods

Name | Description
Add | Adds the specified double number to the collection.
Compare | Compares the contents of this collection with the contents of the specified list.
Contains | Checks whether the specified double number is contained in the collection.
GetValues | Returns an array containing the elements of this collection.
IndexOf | Returns the index of the first occurrence of the specified double number.
Insert | Inserts the specified double number at the specified position within the collection.
Remove | Removes the first occurrence of the specified double number from the collection.
RemoveAt | Removes the double number at the specified index.
ToString | CollectionBase.ToString override.

See Also

DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection.Add Method

DoubleCollection.Add Method

Adds the specified double number to the collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int Add (
double value
)
Visual Basic

Public Function Add ( _
value As Double _
) As Integer

Parameters

value
The new double number to add.

Return Value

The position into which the new double value was added.

See Also

DoubleCollection Members
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection.Compare Method

DoubleCollection.Compare Method

Compares the contents of this collection with the contents of the specified list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool Compare (
IList values
)
Visual Basic

Public Function Compare ( _
values As IList _
) As Boolean

Parameters

values
An object of type .NET IList, which is compared to the current collection.

Return Value

true if the collections are equal; otherwise false.

See Also

DoubleCollection Members
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection.Contains Method

DoubleCollection.Contains Method

Checks whether the specified double number is contained in the collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool Contains (
double value
)
Visual Basic

Public Function Contains ( _
value As Double _
) As Boolean

Parameters

value
The double value to search for.

Return Value

true if value is contained within the collection; otherwise false.

See Also

DoubleCollection Members
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection.GetValues Method

DoubleCollection.GetValues Method

Returns an array containing the elements of this collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double[] GetValues ()
Visual Basic

Public Function GetValues () As Double()

Return Value

A double[] array with all values contained in the current DoubleCollection instance.

See Also

DoubleCollection Members
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection.IndexOf Method

DoubleCollection.IndexOf Method

Returns the index of the first occurrence of the specified double number.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int IndexOf (
double value
)
Visual Basic

Public Function IndexOf ( _
value As Double _
) As Integer

Parameters

value
The double value to search for.

Return Value

The index of the first occurrence of the double number; -1 if not found.

See Also

DoubleCollection Members
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection.Insert Method

DoubleCollection.Insert Method

Inserts the specified double number at the specified position within the collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void Insert (
int index,
double value
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
value As Double _
)

Parameters

index

The zero-based index at which value should be inserted.

value
The double value to insert.

Remarks

The collection's count is increased with 1. The items, which followed the inserted item, are moved backwards with one place. Their indexes are also updated.

See Also

DoubleCollection Members
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection.Remove Method

DoubleCollection.Remove Method

Removes the first occurrence of the specified double number from the collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void Remove (
double value
)
Visual Basic

Public Sub Remove ( _
value As Double _
)

Parameters

value

See Also

DoubleCollection Members
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection.RemoveAt Method

DoubleCollection.RemoveAt Method

Removes the double number at the specified index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public new void RemoveAt (
int index
)
Visual Basic

Public Shadows Sub RemoveAt ( _
index As Integer _
)

Parameters

index
The index at which the double number should be removed.

See Also

DoubleCollection Members
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection.ToString Method

DoubleCollection.ToString Method

CollectionBase.ToString override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

See Also

DoubleCollection Members
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection Properties

DoubleCollection Properties

Public Properties

Name | Description
Item | Gets or sets the double number, located at the specified position.

See Also

DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.DoubleCollection.Item Property

DoubleCollection.Item Property

Gets or sets the double number, located at the specified position.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Double

Parameters

index
The zero-based index of the element to get or set.

Property Value

The element at the specified index.

Remarks

This property provides the ability to access a specific element in the collection.

See Also

DoubleCollection Members
DoubleCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionArgs Class

FunctionArgs Class
Remarks See Also

A class specified for setting the arguments of chart functions.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public class FunctionArgs : EventArgs
Visual Basic

Public Class FunctionArgs
Inherits EventArgs

Remarks

The FunctionArgs class specifies the interval, in which delegate functions are calculated. The delegate function is used to create YData values as a result from calculations made on the data from the FunctionArgs object. The numerical interval is considered as XData.

Charts, created through the CalculateFunctionDelegate can only be line charts and their variations - scatter, bubble and so on. The count of numbers in an interval, even the smallest one, is impossible to be represented as a constant and this does not allow drawing of pie, radar and bar charts. When the data count is too big it is not advisable to set the LabelType property of the AxisSettings object for any of the chart axes to AxisLabelType.ChartData.

When labels for some of the chart axes are specified, the control calculates the function for as many values as labels are defined. The label style of the axis, where you want to draw the labels must be set to AxisLabelType.CustomText.

The two final values of the interval are specified with the StartValue and EndValue properties. The distance between numbers passed as function arguments is specified by FunctionDelta.

The numerical interval, in which the function is calculated is a closed one - it includes the start and end values.

Every FunctionArgs object can be assigned to the FunctionArguments property of a Chart object.

There are no limitations on the type of the delegate function - you can calculate whatever you want as long as it returns one float value.

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Charting.FunctionArgs

See Also

FunctionArgs Members
MindFusion.Charting Namespace


MindFusion.Charting.FunctionArgs Members

FunctionArgs Members
Constructors Properties

A class specified for setting the arguments of chart functions.

The following tables list the members exposed by the FunctionArgs type.

Public Constructors

Name | Description
FunctionArgs | Creates a new instance of the FunctionArgs class.

Public Properties

Name | Description
EndValue | Specifies the maximum value in the function interval.
FunctionDelta | Specifies the interval, through which function values are calculated.
StartValue | Specifies the minimal value in the function interval.

See Also

FunctionArgs Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionArgs Constructor

FunctionArgs Constructor

Creates a new instance of the FunctionArgs class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public FunctionArgs (
float sVal,
float eVal
)
Visual Basic

Public New ( _
sVal As Single, _
eVal As Single _
)

Parameters

sVal
The start value of the numerical interval;
eVal
The end value of the numerical interval;

Remarks

The arguments of the FunctionArgs constructor are two parameters, which indicate the smallest and biggest float numbers, for which the delegate function is calculated. The newly created FunctionArgs object must be assigned to the chart FunctionArguments property. The control calculates the chart data as a result from the delegate function with parameters the numbers from the specified FunctionArguments interval.

See Also

FunctionArgs Class
MindFusion.Charting Namespace
CalculateFunctionDelegate


MindFusion.Charting.FunctionArgs Properties

FunctionArgs Properties

Public Properties

Name | Description
EndValue | Specifies the maximum value in the function interval.
FunctionDelta | Specifies the interval, through which function values are calculated.
StartValue | Specifies the minimal value in the function interval.

See Also

FunctionArgs Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionArgs.EndValue Property

FunctionArgs.EndValue Property

Specifies the maximum value in the function interval.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float EndValue { get; }
Visual Basic

Public ReadOnly Property EndValue As Single

Property Value

A float value.

Remarks

The property indicates the maximum float value, for which the function is calculated. It is read-only, since the interval of the function arguments is set by the creation of the FunctionArgs object.

The property does not have a default value - it's value is set with the very creation of the FunctionArgs object.

See Also

FunctionArgs Members
FunctionArgs Class
MindFusion.Charting Namespace
StartValue
FunctionDelta
CalculateFunctionDelegate


MindFusion.Charting.FunctionArgs.FunctionDelta Property

FunctionArgs.FunctionDelta Property

Specifies the interval, through which function values are calculated.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double FunctionDelta { get; set; }
Visual Basic

Public Property FunctionDelta As Double

Property Value

A double value.

Remarks

The property specifies the difference between two adjacent intervals of calculation. Its value indicates how the interval built from the StartValue and EndValue properties is divided. Each interval division is identified as an argument to the function delegate and a function value for it is calculated. A smaller FunctionDelta value means more precise function calculation and smoother graphic.

Default value for the FunctionDelta property is 0.5.

See Also

FunctionArgs Members
FunctionArgs Class
MindFusion.Charting Namespace
CalculateFunctionDelegate


MindFusion.Charting.FunctionArgs.StartValue Property

FunctionArgs.StartValue Property

Specifies the minimal value in the function interval.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float StartValue { get; }
Visual Basic

Public ReadOnly Property StartValue As Single

Property Value

A float value.

Remarks

The property indicates the minimal float value, for which the function is calculated. It is read-only, since the interval of the function arguments is set by the creation of the FunctionArgs object.

The property does not have a default value - its value is set with the very creation of the FunctionArgs object.

See Also

FunctionArgs Members
FunctionArgs Class
MindFusion.Charting Namespace
EndValue
FunctionDelta
CalculateFunctionDelegate


MindFusion.Charting.GridType Enumeration

GridType Enumeration

Specifies the type of the grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum GridType
Visual Basic

Public Enumeration GridType

Members

Member name | Description
Chess | The grid consists of vertical and horizontal lines, which make squares. The distance between them is set by GridWidth.
Crossed | The grid consists of vertical and horizontal lines.
Custom | The position of the grid points, brushes and labels is specified by the user.
HorScale | The grid consists only of horizontal lines.
None | No grid is drawn.
VertScale | The grid consists only of vertical lines.

Remarks

The Enumeration specifies how chart grids are drawn. There are two objects that support grids: the plot area, in chart with axes and the legend background.

GridType.HorScale means that the positions of horizontal grid lines are determined by the scale divisions of the Y-axis. In GridType.VertScale the positions of vertical grid lines are determined by the scale divisions of the X-axis. Crossed grids have both horizontal and vertical lines.

Grids are drawn with the GridPen, which is by default null. The grid stripes can be filled with the GridBrush and AltGridBrush.

Custom grids can have horizontal and/or vertical lines as set with the user. They are painted with brushes and pens from HorGridBrushes, HorGridPens, VertGridBrushes and VertGridPens properties. The position of the grid lines is set with HorGridPoints and VertGridPoints.

When the chart is 3D, grid lines are drawn at the chart axes, if appropriate.

Legends do not have custom and crossed grids. Horizontal grids are drawn between label columns; vertical grids - between label rows. Crossed grids are a combination of both. Legend grids do not use brushes and are drawn with the LegendPen.

See Also

MindFusion.Charting Namespace
GridType
LegendGridType


MindFusion.Charting.LabelOrientation Enumeration

LabelOrientation Enumeration

Specifies different text orientation styles for chart labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum LabelOrientation
Visual Basic

Public Enumeration LabelOrientation

Members

Member name | Description
BottomToTop | The label is rotated 90 degrees counterclockwise.
InColumn | Label letters are drawn in a column, each letter under the previous one.
InRow | The label is drawn in a straight line.
TopToBottom | The label is rotated 90 degrees clockwise.

Remarks

Label orientation is considered for the TitleLabel, DivisionLabel and the grid labels.

The orientation of the TitleLabel is specified with AxisSettings.TitleLabelOrientation. The orientation of grid labels is specified with XGridLabelsOrientation, YGridLabelsOrientation and Y2GridLabelsOrientation.

See Also

MindFusion.Charting Namespace
XGridLabels
YGridLabels
Y2GridLabels


MindFusion.Charting.LabelsCollection Class

LabelsCollection Class

Represents a strongly typed collection of StringCollection objects.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public class LabelsCollection : CollectionBase, ICloneable
Visual Basic

Public Class LabelsCollection
Inherits CollectionBase
Implements ICloneable

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Charting.LabelsCollection

See Also

LabelsCollection Members
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection Members

LabelsCollection Members
Constructors Properties Methods

Represents a strongly typed collection of StringCollection objects.

The following tables list the members exposed by the LabelsCollection type.

Public Constructors

Name | Description
LabelsCollection | Overloaded.

Public Properties

Name | Description
Item | Gets or sets the double number, located at the specified position.

Public Methods

Name | Description
Add | Adds the specified StringCollection to the collection.
Clone | Creates an exact copy of this collection.
Compare | Compares the contents of this collection with the contents of the specified list.
Contains | Checks whether the specified StringCollection is contained in the collection.
GetValues | Returns an array containing the elements of this collection.
IndexOf | Returns the index of the first occurrence of the specified StringCollection.
Insert | Inserts the specified StringCollection at the specified position within the collection.
Remove | Removes the first occurrence of the specified StringCollection from the collection.
RemoveAt | Removes the StringCollection at the specified index.

See Also

LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection Constructor

LabelsCollection Constructor

Overload List

Name | Description
LabelsCollection () | Initializes a new instance of the LabelsCollection class.
LabelsCollection (IList) | Initializes a new instance of the LabelsCollection class.
LabelsCollection (String) | Initializes a new instance of the LabelsCollection class.
LabelsCollection (StringCollection[]) | Initializes a new instance of the LabelsCollection class with the specified initial values.

See Also

LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection Constructor ()

LabelsCollection Constructor ()
See Also

Initializes a new instance of the LabelsCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LabelsCollection ()
Visual Basic

Public Sub New ()

See Also

LabelsCollection Constructor Overload List
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection Constructor (IList)

LabelsCollection Constructor (IList)
See Also

Initializes a new instance of the LabelsCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LabelsCollection (
IList arrays
)
Visual Basic

Public New ( _
arrays As IList _
)

Parameters

arrays

See Also

LabelsCollection Constructor Overload List
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection Constructor (String)

LabelsCollection Constructor (String)
See Also

Initializes a new instance of the LabelsCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LabelsCollection (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation

See Also

LabelsCollection Constructor Overload List
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection Constructor (StringCollection[])

LabelsCollection Constructor (StringCollection[])
See Also

Initializes a new instance of the LabelsCollection class with the specified initial values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LabelsCollection (
StringCollection[] values
)
Visual Basic

Public New ( _
values() As StringCollection _
)

Parameters

values

See Also

LabelsCollection Constructor Overload List
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection Methods

LabelsCollection Methods

Public Methods

Name | Description
Add | Adds the specified StringCollection to the collection.
Clone | Creates an exact copy of this collection.
Compare | Compares the contents of this collection with the contents of the specified list.
Contains | Checks whether the specified StringCollection is contained in the collection.
GetValues | Returns an array containing the elements of this collection.
IndexOf | Returns the index of the first occurrence of the specified StringCollection.
Insert | Inserts the specified StringCollection at the specified position within the collection.
Remove | Removes the first occurrence of the specified StringCollection from the collection.
RemoveAt | Removes the StringCollection at the specified index.

See Also

LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection.Add Method

LabelsCollection.Add Method

Adds the specified StringCollection to the collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int Add (
StringCollection value
)
Visual Basic

Public Function Add ( _
value As StringCollection _
) As Integer

Parameters

value
The new label to add.

Return Value

The position into which the new StringCollection object was added.

See Also

LabelsCollection Members
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection.Clone Method

LabelsCollection.Clone Method

Creates an exact copy of this collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

See Also

LabelsCollection Members
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection.Compare Method

LabelsCollection.Compare Method

Compares the contents of this collection with the contents of the specified list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool Compare (
IList values
)
Visual Basic

Public Function Compare ( _
values As IList _
) As Boolean

Parameters

values
An object of type .NET IList, which is compared to the current collection.

Return Value

true if the collections are equal; otherwise false.

See Also

LabelsCollection Members
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection.Contains Method

LabelsCollection.Contains Method

Checks whether the specified StringCollection is contained in the collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool Contains (
StringCollection value
)
Visual Basic

Public Function Contains ( _
value As StringCollection _
) As Boolean

Parameters

value
The StringCollection to search for.

Return Value

true if value is contained within the collection; otherwise false.

See Also

LabelsCollection Members
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection.GetValues Method

LabelsCollection.GetValues Method

Returns an array containing the elements of this collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public StringCollection[] GetValues ()
Visual Basic

Public Function GetValues () As StringCollection()

Return Value

A StringCollection[] array with all values contained in the current LabelsCollection instance.

See Also

LabelsCollection Members
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection.IndexOf Method

LabelsCollection.IndexOf Method

Returns the index of the first occurrence of the specified StringCollection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int IndexOf (
StringCollection value
)
Visual Basic

Public Function IndexOf ( _
value As StringCollection _
) As Integer

Parameters

value
The StringCollection to search for.

Return Value

The index of the first occurrence of value; -1 if not found.

See Also

LabelsCollection Members
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection.Insert Method

LabelsCollection.Insert Method

Inserts the specified StringCollection at the specified position within the collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void Insert (
int index,
StringCollection value
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
value As StringCollection _
)

Parameters

index
value

See Also

LabelsCollection Members
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection.Remove Method

LabelsCollection.Remove Method

Removes the first occurrence of the specified StringCollection from the collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void Remove (
StringCollection value
)
Visual Basic

Public Sub Remove ( _
value As StringCollection _
)

Parameters

value

See Also

LabelsCollection Members
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection.RemoveAt Method

LabelsCollection.RemoveAt Method

Removes the StringCollection at the specified index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public new void RemoveAt (
int index
)
Visual Basic

Public Shadows Sub RemoveAt ( _
index As Integer _
)

Parameters

index
The index at which the StringCollection should be removed.

See Also

LabelsCollection Members
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection Properties

LabelsCollection Properties

Public Properties

Name | Description
Item | Gets or sets the double number, located at the specified position.

See Also

LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelsCollection.Item Property

LabelsCollection.Item Property

Gets or sets the double number, located at the specified position.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public StringCollection Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As StringCollection

Parameters

index
The zero-based index of the entry to get or set.

Property Value

The element at the specified index.

Remarks

This property provides the ability to access a specific element in the collection.

See Also

LabelsCollection Members
LabelsCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.LabelType Enumeration

LabelType Enumeration

Specifies the type of labels drawn at chart elements.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum LabelType
Visual Basic

Public Enumeration LabelType

Members

Member name | Description
CustomText | The text of chart labels is set by the user.
Data | The labels represent the data numerical values (for big numbers, number division can be used).
Empty | No labels are drawn.
Percents | Percentage value for numerical data is drawn.

Remarks

The enumeration represents the possible styles of labels. A LabelType object is required. It is not necessary to specify custom texts as string values - the control converts automatically any type of data into strings.

In bar charts:
The labels can be drawn inside and/or at the top of bars. The properties are InnerLabelType and TopLabelType. The appearance, style and format options of the labels are set with the XAxisSettings for vertical and YAxisSettings for horizontal charts. The labels that represent percentage data are calculated as the numerical data for each bar is divided by the sum of all data numbers. Custom labels are set with the InnerLabels and TopLabels properties.

By default, the bar inner and top labels are set to LabelType.Empty.

In pie charts:
Pies / doughnuts can have labels both inside and outside its pieces. The properties are InnerLabelType and OuterLabelType. If you choose to set custom labels, use the InnerLabels and OuterLabels properties. If the numerical data is too big, you can use DivisionCoef and DivisionLabel properties to cancel the chart data.

By default the pie inner and outer labels are set to LabelType.Empty.

In bubble charts:
The LabelType property enables you to choose the type of label drawn inside each bubble of a bubble chart. Labels specify the custom labels drawn at chart bubbles.

The LabelAlignment property specifies the alignment of the labels. They can be drawn inside, or above/below the bubble.

In radar charts:
Polar / radar charts have labels at the inner axis, the outer axis and in the center of the outer axis segments. The label type for the inner and outer axis is set with InnerAxisLabelType and OuterAxisLabelType. Custom labels are set with InnerAxisLabels and OuterAxisLabels.

See Also

MindFusion.Charting Namespace
AxisLabelType Enumeration


MindFusion.Charting.Line Class

Line Class
Remarks See Also

A class that represents line objects in line charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public sealed class Line : ChartElement
Visual Basic

Public NotInheritable Class Line
Inherits ChartElement

Remarks

MindFusion.Charting builds a Line object for each line / area graphics it draws in a line chart. If the chart is drawn with scatter shapes, they are represented separately by Scatter objects.

All properties of the Line class are read-only. You can set them through the LineChart class. When the user hits a line in hit-testing, the Line object that holds the hitted point is returned.

Inheritance Hierarchy

System.Object
MindFusion.Charting.ChartElement
MindFusion.Charting.Line

See Also

HitTest
HitTestLine
Line Members
MindFusion.Charting Namespace


MindFusion.Charting.Line Members

Line Members
Constructors Properties

A class that represents line objects in line charts.

The following tables list the members exposed by the Line type.

Public Constructors

Name | Description
Line | Initializes a new instance of the Line class.

Public Properties

Name | Description
MaxNum | Gets the biggest number this Line series contains.
Sum | Gets the sum of all data values in this line series.

See Also

Line Class
MindFusion.Charting Namespace


MindFusion.Charting.Line Constructor

Line Constructor

Initializes a new instance of the Line class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Line ()
Visual Basic

Public Sub New ()

See Also

Line Class
MindFusion.Charting Namespace


MindFusion.Charting.Line Properties

Line Properties

Public Properties

Name | Description
MaxNum | Gets the biggest number this Line series contains.
Sum | Gets the sum of all data values in this line series.

See Also

Line Class
MindFusion.Charting Namespace


MindFusion.Charting.Line.MaxNum Property

Line.MaxNum Property

Gets the biggest number this Line series contains.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double MaxNum { get; }
Visual Basic

Public ReadOnly Property MaxNum As Double

Property Value

A double number.

Remarks

The property returns the biggest YData value for this Line series in vertical charts. For horizontal charts the maximum number is taken from the respective XData list.

See Also

Line Members
Line Class
MindFusion.Charting Namespace


MindFusion.Charting.Line.Sum Property

Line.Sum Property

Gets the sum of all data values in this line series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double Sum { get; }
Visual Basic

Public ReadOnly Property Sum As Double

Property Value

A double number that represents the sum.

Remarks

The property returns the sum of all numbers this line displays. The numbers are taken from the respective YData array for vertical charts. For horizontal charts the array is taken from XData.

See Also

Line Members
Line Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart Class

LineChart Class
Remarks See Also

A class specified for drawing line, area, bubble and scatter charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public class LineChart : AxesChart
Visual Basic

Public Class LineChart
Inherits AxesChart

Remarks

LineChart inherits properties and methods from its base class AxesChart.

The class is used for creating line, area, scatter and bubble charts as well different combinations of them. The type of the chart is specified with LineType. The possible values are members of the LineTypes enumeration and allow bitwise combination.

The data for the chart is given with lists that contain numerical or DateTime values. The data can be any format that can safely be converted to numbers or DateTime values using the standard .NET type converters. The data is added to the XData / YData properties, which are of type IList. You can specify values for just one of the XData or YData properties.

Charts can have graphics bound to the second Y-axis. The data for them is set with Y2Data.

Scatter charts get the type of the scatter for each series from the Shapes property. The size of the scatters is set with ShapeSizes. The shapes are drawn with pens and brushes from ShapePens and ShapeBrushes.

The appearance and size options of point shapes for Y2-bound graphics are specified with Y2Shapes, Y2ShapeSizes and Y2ShapePens and Y2ShapeBrushes. The point shapes of summary graphics are customized with SummaryShapes, SummaryShapeSizes, SummaryShapePens and SummaryShapeBrushes.

When drawing area charts, it is possible that some areas, when drawn in the order their data is set, overlap too much. Use the SortSeriesBy property to change the order for drawing the charts.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Chart
MindFusion.Charting.AxesChart
MindFusion.Charting.LineChart

See Also

LineChart Members
MindFusion.Charting Namespace


MindFusion.Charting.LineChart Members

LineChart Members
Constructors Fields Properties Methods

A class specified for drawing line, area, bubble and scatter charts.

The following tables list the members exposed by the LineChart type.

Public Constructors

Name | Description
LineChart | Creates a new instance of the LineChart class.

Public Fields

Name | Description
CalculateFunction | Invokes a custom function that calculates the values for the chart.

Public Properties

Name | Description
Curve | Gets or sets whether lines in line charts are drawn like curves.
FunctionArguments | Gets or sets the FunctionArgs argument of the CalculateFunctionDelegate delegate.
LabelAlignment | Gets or sets the alignment of chart labels.
LabelBorder | Gets or sets the border of data labels.
LabelBorderBackground | Gets or sets the brush for the background of the LabelBorder.
LabelBorderMargin | Gets or sets the margin between the data label and its border.
LabelBorderOutline | Gets or sets the pen for drawing the LabelBorder.
LabelOffset | Gets or sets the offset of the data label.
Labels | Gets or sets custom labels drawn at chart data points.
LabelType | Gets or sets the type of chart labels.
LineType | Gets or set the type of the line chart.
MaxBubbleRadius | Gets or sets the radius length of the biggest bubble.
MinBubbleRadius | Gets or sets the radius length of the smallest bubble.
MultiColoredShapes | Gets or sets whether scatters in line charts are drawn in one color.
ShapeBrushes | Gets or sets the brushes, which are used for filling the point shapes in scatter charts.
ShapePens | Gets or sets the pens, which are used for outlining of point shapes in scatter charts.
Shapes | Gets or sets the shape of data points in scatter charts.
ShapeSizes | Gets or sets the size of point shapes drawn at scatter charts.
Stacked | Gets or sets whether multi series charts are drawn stacked.
SummaryShapeBrushes | Gets or sets the brushes for drawing of point shapes at summary scatter charts.
SummaryShapePens | Gets or sets the pens for drawing shapes at summary scatter chart.
SummaryShapes | Gets or sets the shapes drawn at summary scatter charts.
SummaryShapeSizes | Gets or sets the size of point shapes drawn at summary scatter charts.
XData | Gets or sets the numerical data, which is used for calculating the X - coordinates of line points.
Y2ScatterLabels | Gets or sets custom labels drawn at Y2 scatter shapes.
Y2ShapeBrushes | Gets or sets the brushes for drawing of point shapes at Y2 scatter charts.
Y2ShapePens | Gets or sets the pens for drawing of point shapes at Y2 scatter charts.
Y2Shapes | Gets or sets the style of point shapes drawn at Y2 scatter charts.
Y2ShapeSizes | Gets or sets the size of point shapes drawn at Y2 lines.
YData | Gets or sets the data, which is used to calculate the Y-coordinates of the chart points.

Public Methods

Name | Description
ClearData | Clears any data from the chart.
Clone | Creates an exact copy of the current LineChart object.
HitTest | Returns the line element at the specified position
HitTestBubble | Returns the Bubble at the specified x and y coordinates.
HitTestLine | Returns the Line at the position specified by x and y.
HitTestScatter | Returns the Scatter at the specified position.

Protected Methods

Name | Description
CreateChart | Creates a new LineChart object.

See Also

LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart Fields

LineChart Fields

Public Fields

Name | Description
CalculateFunction | Invokes a custom function that calculates the values for the chart.

See Also

LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.CalculateFunction Field

LineChart.CalculateFunction Field

Invokes a custom function that calculates the values for the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public CalculateFunctionDelegate CalculateFunction (float xValue, FunctionArgs e)
Visual Basic

Public CalculateFunction As CalculateFunctionDelegate (ByVal xValue As Single, ByVal e As FunctionArgs)

Example

The following example:

  • Creates a line chart
  • Sets the chart data with a delegate, which calculates the sine function in the interval [-3, 3];

C#

/// <summary>
/// The sine function.
/// </summary>
public float CalculateFunction(float xVal, MindFusion.Charting.FunctionArgs e)
{
return (float)Math.Sin((double)xVal);
}

// ...

// Create the chart
MindFusion.Charting.LineChart chart = new MindFusion.Charting.LineChart(MindFusion.Charting.LineTypes.Line);

// Add the delegate
chart.CalculateFunction = new MindFusion.Charting.CalculateFunctionDelegate(CalculateFunction);

// Set the interval of calculation
chart.FunctionArguments = new MindFusion.Charting.FunctionArgs(-3, 3);

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart Constructor

LineChart Constructor

Creates a new instance of the LineChart class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LineChart (
LineTypes chartType
)
Visual Basic

Public Sub LineChart ( _
chartType As LineTypes _
)

Parameters

chartType
One of the LineTypes enumeration values.

Remarks

The method creates a new instance of the LineChart class. It's only parameter indicates the type of the line chart. Members of the LineTypes enumeration allow bitwise combination, which increases the variety of charts that can be created.

The type of LineChart can be changed later on with the LineType property.

See Also

LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart Methods

LineChart Methods

Public Methods

Name | Description
ClearData | Clears any data from the chart.
Clone | Creates an exact copy of the current LineChart object.
HitTest | Returns the line element at the specified position
HitTestBubble | Returns the Bubble at the specified x and y coordinates.
HitTestLine | Returns the Line at the position specified by x and y.
HitTestScatter | Returns the Scatter at the specified position.

Protected Methods

Name | Description
CreateChart | Creates a new LineChart object.

See Also

LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.ClearData Method

LineChart.ClearData Method

Clears any data from the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override void ClearData ()
Visual Basic

Public Overrides Sub ClearData ()

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.Clone Method

LineChart.Clone Method

Creates an exact copy of the current LineChart object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

The cloned line chart.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.CreateChart Method

LineChart.CreateChart Method

Creates a new LineChart object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

protected virtual Chart CreateChart ()
Visual Basic

Protected Overridable Function CreateChart () As Chart

Return Value

The new line chart.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.HitTest Method

LineChart.HitTest Method

Returns the line element at the specified position

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override ChartElement HitTest (
int x,
int y
)
Visual Basic

Public Overrides Function HitTest ( _
x As Integer, _
y As Integer _
) As ChartElement

Parameters

x
the X - coordinate of the mouse
y
the Y - coordinate of the mouse

Return Value

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.HitTestBubble Method

LineChart.HitTestBubble Method

Returns the Bubble at the specified x and y coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Bubble HitTestBubble (
int x,
int y
)
Visual Basic

Public Function HitTestBubble ( _
x As Integer, _
y As Integer _
) As Bubble

Parameters

x
The X - coordinate of the mouse.
y

The Y - coordinate of the mouse.

Return Value

The Bubble at the position specified by x and y; null if no Bubble is found.

Remarks

Use the function when hit-testing bubble charts. The result can be null, so always check.

See Also

HitTest
LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.HitTestLine Method

LineChart.HitTestLine Method

Returns the Line at the position specified by x and y.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Line HitTestLine (
int x,
int y
)
Visual Basic

Public Function HitTestLine ( _
x As Integer, _
y As Integer _
) As Line

Parameters

x
The X - coordinate of the mouse.
y
The Y - coordinate of the mouse.

Return Value

The Line at the position specified by x and y; null if no Line is found.

Remarks

Use the method when hit-testing all types of line and/or area charts. If the chart is combined with scatter, the method will not return the scatter, when hitted. Instead you should use HitTestScatter or HitTest and cast the result.

HitTestLine returns the line that holds all points for a particular data series. You can recognize it through the Index or MaxNum properties. The result can be null, so always check.

See Also

HitTest
LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.HitTestScatter Method

LineChart.HitTestScatter Method

Returns the Scatter at the specified position.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Scatter HitTestScatter (
int x,
int y
)
Visual Basic

Public Function HitTestScatter ( _
x As Integer, _
y As Integer _
) As Scatter

Parameters

x
The X - coordinate of the mouse
y
The Y - coordinate of the mouse

Return Value

The Scatter at the position specified by x and y; null if no Scatter is clicked.

Remarks

Use this method when hit-testing scatter charts. The method returns only the hitted scatter. If the scatter chart is combined with any type of line or area chart, you should also use HitTestLine or HitTest and cast the result to Line or Scatter.

The result can be null, so always check.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart Properties

LineChart Properties

Public Properties

Name | Description
Curve | Gets or sets whether lines in line charts are drawn like curves.
FunctionArguments | Gets or sets the FunctionArgs argument of the CalculateFunctionDelegate delegate.
LabelAlignment | Gets or sets the alignment of chart labels.
LabelBorder | Gets or sets the border of data labels.
LabelBorderBackground | Gets or sets the brush for the background of the LabelBorder.
LabelBorderMargin | Gets or sets the margin between the data label and its border.
LabelBorderOutline | Gets or sets the pen for drawing the LabelBorder.
LabelOffset | Gets or sets the offset of the data label.
Labels | Gets or sets custom labels drawn at chart data points.
LabelType | Gets or sets the type of chart labels.
LineType | Gets or set the type of the line chart.
MaxBubbleRadius | Gets or sets the radius length of the biggest bubble.
MinBubbleRadius | Gets or sets the radius length of the smallest bubble.
MultiColoredShapes | Gets or sets whether scatters in line charts are drawn in one color.
ShapeBrushes | Gets or sets the brushes, which are used for filling the point shapes in scatter charts.
ShapePens | Gets or sets the pens, which are used for outlining of point shapes in scatter charts.
Shapes | Gets or sets the shape of data points in scatter charts.
ShapeSizes | Gets or sets the size of point shapes drawn at scatter charts.
Stacked | Gets or sets whether multi series charts are drawn stacked.
SummaryShapeBrushes | Gets or sets the brushes for drawing of point shapes at summary scatter charts.
SummaryShapePens | Gets or sets the pens for drawing shapes at summary scatter chart.
SummaryShapes | Gets or sets the shapes drawn at summary scatter charts.
SummaryShapeSizes | Gets or sets the size of point shapes drawn at summary scatter charts.
XData | Gets or sets the numerical data, which is used for calculating the X - coordinates of line points.
Y2ScatterLabels | Gets or sets custom labels drawn at Y2 scatter shapes.
Y2ShapeBrushes | Gets or sets the brushes for drawing of point shapes at Y2 scatter charts.
Y2ShapePens | Gets or sets the pens for drawing of point shapes at Y2 scatter charts.
Y2Shapes | Gets or sets the style of point shapes drawn at Y2 scatter charts.
Y2ShapeSizes | Gets or sets the size of point shapes drawn at Y2 lines.
YData | Gets or sets the data, which is used to calculate the Y-coordinates of the chart points.

See Also

LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.Curve Property

LineChart.Curve Property

Gets or sets whether lines in line charts are drawn like curves.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool Curve { get; set; }
Visual Basic

Public Property Curve As Boolean

Property Value

A bool value, which specifies whether lines are drawn as curves.

Remarks

The property allows line and area charts to be drawn as rounded curves instead of a combination of straight lines. The property can be applied to all 2D and 3D line/area charts. The type of the chart is set with LineType.

Default value for the Curve property is false.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.FunctionArguments Property

LineChart.FunctionArguments Property

Gets or sets the FunctionArgs argument of the CalculateFunctionDelegate delegate.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public FunctionArgs FunctionArguments { get; set; }
Visual Basic

Public Property FunctionArguments As FunctionArgs

Property Value

An instance of type FunctionArgs class.

Remarks

The property sets the interval, in which the float argument of the CalculateFunctionDelegate delegate is computed. The interval is specified by a start and end float value and is closed, that is it includes the two border values.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.LabelAlignment Property

LineChart.LabelAlignment Property

Gets or sets the alignment of chart labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public StringAlignment LabelAlignment { get; set; }
Visual Basic

Public Property LabelAlignment As StringAlignment

Property Value

One of .NET StringAlignment Enumeration values.

Remarks

The property specifies whether the label is drawn above, below or in the center of the line data point. Is is also used for scatters and bubbles. Labels are drawn when the LabelType property is not set to LabelType.Empty. Custom labels are set with Labels.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace
LabelBorder
LabelBorderBackground


MindFusion.Charting.LineChart.LabelBorder Property

LineChart.LabelBorder Property

Gets or sets the border of data labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Border LabelBorder { get; set; }
Visual Basic

Public Property LabelBorder As Border

Property Value

One of the Border Enumeration values.

Remarks

The border is drawn with LabelBorderOutline and painted with LabelBorderBackground. LabelBorderMargin sets the space between the label and its border.

Default value for the LabelBorder property is Border.None.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace
LabelAlignment
LabelBorderMargin
LabelBorderOutline


MindFusion.Charting.LineChart.LabelBorderBackground Property

LineChart.LabelBorderBackground Property

Gets or sets the brush for the background of the LabelBorder.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush LabelBorderBackground { get; set; }
Visual Basic

Public Property LabelBorderBackground As Brush

Property Value

An object of type MindFusion.Drawing.Brush class.

Remarks

Use LabelBorder to specify the type of the border. LabelBorderOutline specifies the pen for the border outline. LabelBorderMargin sets the space between the label and its border.

Default value for the LabelBorderBackground property is a light blue SolidBrush.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace
LabelBorder


MindFusion.Charting.LineChart.LabelBorderMargin Property

LineChart.LabelBorderMargin Property

Gets or sets the margin between the data label and its border.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float LabelBorderMargin { get; set; }
Visual Basic

Public Property LabelBorderMargin As Single

Property Value

A float value. Default is 5f.

Remarks

The property specifies the space between the LabelBorder and data labels drawn at line data points, scatters or bubbles. The border is drawn with LabelBorderOutline and filled with LabelBorderBackground.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace
LabelBorder


MindFusion.Charting.LineChart.LabelBorderOutline Property

LineChart.LabelBorderOutline Property

Gets or sets the pen for drawing the LabelBorder.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen LabelBorderOutline { get; set; }
Visual Basic

Public Property LabelBorderOutline As Pen

Property Value

An instance of MindFusion.Drawing.Pen class.

Remarks

Use LabelBorder to set the border for labels drawn at line data points, scatters or bubbles. The background of the border rectangle is filled with LabelBorderBackground.

Default value for the LabelBorderOutline property is a black Pen.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace
LabelBorder


MindFusion.Charting.LineChart.LabelOffset Property

LineChart.LabelOffset Property

Gets or sets the offset of the data label.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float LabelOffset { get; set; }
Visual Basic

Public Property LabelOffset As Single

Property Value

A float value. Default is 5f.

Remarks

LabelOffset specifies the space between the label and the data point, scatter or bubble it refers to. Use LabelType to set the type of labels drawn. LabelAlignment specifies how labels are aligned.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.Labels Property

LineChart.Labels Property

Gets or sets custom labels drawn at chart data points.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList Labels { get; set; }
Visual Basic

Public Property Labels As IList

Property Value

A list that holds other lists with the labels for each data series.

Remarks

The labels are drawn at line data points, scatters or bubbles depending on the chart type. They are drawn when the LabelType is set to LabelType.CustomText.

Default value for the Labels property is an empty IList object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace
LabelType


MindFusion.Charting.LineChart.LabelType Property

LineChart.LabelType Property

Gets or sets the type of chart labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LabelType LabelType { get; set; }
Visual Basic

Public Property LabelType As LabelType

Property Value

One of the LabelType Enumeration values.

Remarks

LabelType specifies the type of labels drawn at line data points, scatters or bubbles according to the type of the chart. Custom labels are set with Labels.

Default value for the LabelType property is LabelType.Empty.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.LineType Property

LineChart.LineType Property

Gets or set the type of the line chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LineTypes LineType { get; set; }
Visual Basic

Public Property LineType As LineTypes

Property Value

One of the LineTypes enumeration values.

Remarks

The members of the LineTypes enumeration allow bitwise combination, which increases the variety of charts that can be drawn.

When using MindFusion.Charting programmatically, the type of line chart is set in the constructor. It can later be changed with the LineType property.

Line charts can be drawn not only as a combination of straight lines but also as curves. This is set with Curve.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.MaxBubbleRadius Property

LineChart.MaxBubbleRadius Property

Gets or sets the radius length of the biggest bubble.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float MaxBubbleRadius { get; set; }
Visual Basic

Public Property MaxBubbleRadius As Single

Property Value

A float value that represents the radius length.

Remarks

The property sets the radius of the biggest bubble. The radius of the smallest bubble is specified with MinBubbleRadius. The length of the radiuses of all other bubbles are calculated based on their value compared to the value of the biggest and smallest bubble.

Use the Y2Data property to specify the values of the bubbles. If you do not need a third data array for the bubble chart, the size of the bubble is calculated based on its value in the YData list.

Default value for the MaxBubbleRadius property is 30.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.MinBubbleRadius Property

LineChart.MinBubbleRadius Property

Gets or sets the radius length of the smallest bubble.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float MinBubbleRadius { get; set; }
Visual Basic

Public Property MinBubbleRadius As Single

Property Value

A float value that represents the radius length.

Remarks

The property sets the radius of the smallest bubble. The radius of the biggest bubble is specified with MaxBubbleRadius. The length of the radiuses of all other bubbles are calculated based on their value compared to the value of the biggest and smallest bubble.

Use the Y2Data property to specify the values of the bubbles. If you do not need a third data array for the bubble chart, the size of the bubble is calculated based on its value in the YData list.

Default value for the MinBubbleRadius property is 10.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.MultiColoredShapes Property

LineChart.MultiColoredShapes Property

Gets or sets whether scatters in line charts are drawn in one color.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool MultiColoredShapes { get; set; }
Visual Basic

Public Property MultiColoredShapes As Boolean

Property Value

A bool value, which specifies if scatters are multicolored or not.

Remarks

Scatters are drawn when the LineType is set to LineTypes.Scatter. The type of scatters is specified with Shapes property. Line points for the Y2 axis and the summary graphics are set with Y2Shapes and SummaryShapes.

The scatters are drawn with pens and brushes from ShapePens and ShapeBrushes. The control can draw all the shapes using one brush or all the brushes in a cycle. If MultiColoredShapes is true, all scatters in a single series are drawn with all ShapeBrushes. Otherwise each series is drawn with the subsequent brush.

The pens and brushes for Y2 and summary scatters are set with Y2ShapePens, Y2ShapeBrushes and SummaryShapePens, SummaryShapeBrushes.

Default value for the MultiColoredShapes property is false.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace
Shape Enumeration


MindFusion.Charting.LineChart.ShapeBrushes Property

LineChart.ShapeBrushes Property

Gets or sets the brushes, which are used for filling the point shapes in scatter charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection ShapeBrushes { get; set; }
Visual Basic

Public Property ShapeBrushes As BrushCollection

Property Value

A BrushCollection object, which holds the brushes for scatter shapes.

Remarks

The property specifies the brushes used for filling shapes in scatter charts. The pens used for drawing the outlining of line point shapes are specified with the ShapePens property. In case no pens are set, the control uses a default black shape. In case no brushes are set, a default blue-white gradient brush is used.

If point shapes are not multi colored, the control takes for each line graphics a consequent chart from the ShapeBrushes array. When necessary, it repeats the brushes in a cycle. Whether a chart is drawn with multicolored point shapes depends on the value of the MultiColoredShapes property. When the line is with MultiColoredShapes, each point shape at it is drawn with different brush.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the ShapeBrushes property is an empty list.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace
Shape Enumeration
Shapes
ShapeSizes


MindFusion.Charting.LineChart.ShapePens Property

LineChart.ShapePens Property

Gets or sets the pens, which are used for outlining of point shapes in scatter charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PenCollection ShapePens { get; set; }
Visual Basic

Public Property ShapePens As PenCollection

Property Value

A Mindfusion.Drawing.PenCollection object, which holds the pens for the shapes.

Remarks

The property specifies the pens for drawing the outlining of shapes in scatter charts. The shapes are filled with ShapeBrushes.

In case no pens are set with the ShapePens property, the control uses a default black pen. If the ShapeBrushes are not set, the control uses a default blue gradient brush.

If the point shapes are multicolored, all pens are used for drawing of the shapes at a given line chart. If their count is smaller than the count of line data values, the control cycles through them.

If point shapes are not multi colored, the control takes for each line graphics a consequent pen from the ShapePens array. When necessary, it repeats the pens in a cycle.

Whether a chart is drawn with multicolored point shapes depends on the value of the MultiColoredShapes property. Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the ShapePens property is an empty list.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace
Shape Enumeration
Shapes
ShapeSizes


MindFusion.Charting.LineChart.Shapes Property

LineChart.Shapes Property

Gets or sets the shape of data points in scatter charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList Shapes { get; set; }
Visual Basic

Public Property Shapes As IList

Property Value

An IList with Shape members.

Remarks

The property specifies the shapes of scatter charts. Add a Shapes object for each scatter graphics. For summary lines and Y2-lines the properties are SummaryShapes and Y2Shapes.

Each point shape can have different size as indicated by the ShapeSizes property. The MultiColoredShapes property specifies whether point shapes are drawn in one color or in many colors.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the Shapes property is an empty IList.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.ShapeSizes Property

LineChart.ShapeSizes Property

Gets or sets the size of point shapes drawn at scatter charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList ShapeSizes { get; set; }
Visual Basic

Public Property ShapeSizes As IList

Property Value

An IList object with float values that specify the sizes.

Remarks

The property specifies the size of point shapes drawn in scatter charts. Add the values in the same order as you have added the Shape objects to the Shapes property.

The size of the point shapes indicates:

  • For circles - the diameter of the circle;
  • For rhombuses, triangles and squares - the length of the side;

For each point shape in the Shapes property, you can specify not only the size, but also the color with the ShapeBrushes, ShapePens and MultiColoredShapes properties.

Scatter charts are drawn when the LineType property se set to LineTypes.Scatter.

Default value for the ShapeSizes property is an empty IList.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.Stacked Property

LineChart.Stacked Property

Gets or sets whether multi series charts are drawn stacked.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool Stacked { get; set; }
Visual Basic

Public Property Stacked As Boolean

Property Value

A bool value, which specifies if the line chart is stacked.

Remarks

When 3D line charts have multiple series they are normally drawn one behind the other with distance between them set with DistBtwSeries. The graphics can also be drawn in a block, for example stacked. The property is not useful when the chart is 2D. There is no limitation as to the chart type - bubble, scatter, area, line and so on.

The charts are drawn in the same order as their data has been added to the XData, YData and Y2Data properties. You can set a different sort order with SortSeriesBy.

Default value for the Stacked property is false.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.SummaryShapeBrushes Property

LineChart.SummaryShapeBrushes Property

Gets or sets the brushes for drawing of point shapes at summary scatter charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection SummaryShapeBrushes { get; set; }
Visual Basic

Public Property SummaryShapeBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection that holds the brushes for the point shapes.

Remarks

The property specifies the brushes, with which point shapes at summary scatter charts are drawn. In order to draw summary lines, add the desired Summary value to the SummaryValues property. Custom summaries are added with the AddCustomSummary method.

The point shapes of summary lines are drawn with pens from the SummaryShapePens and filled with brushes from the SummaryShapeBrushes property. If they both are not set, the control uses a default black pen and a default blue gradient brush.

The size of the point shapes is set with SummaryShapeSizes.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the SummaryShapeBrushes property is an empty BrushCollection object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.SummaryShapePens Property

LineChart.SummaryShapePens Property

Gets or sets the pens for drawing shapes at summary scatter chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PenCollection SummaryShapePens { get; set; }
Visual Basic

Public Property SummaryShapePens As PenCollection

Property Value

An object of type MindFusion.Drawing.PenCollection.

Remarks

The property specifies the pens, with which point shapes at summary scatter charts are drawn. In order to draw summary lines, add the desired Summary value to the SummaryValues property. Custom summaries are added with the AddCustomSummary method.

The point shapes of summary lines are filled with brushes from the SummaryShapeBrushes property. If the SummaryShapeBrushes is an empty array, the control uses a default blue gradient brush. If the SummaryShapePens are an empty list, a default black pen is used.

The size of the summary point shapes is set with SummaryShapeSizes.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the SummaryShapePens property is an empty PenCollection object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.SummaryShapes Property

LineChart.SummaryShapes Property

Gets or sets the shapes drawn at summary scatter charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList SummaryShapes { get; set; }
Visual Basic

Public Property SummaryShapes As IList

Property Value

An IList with Shape objects.

Remarks

The property specifies the type of shapes, drawn at summary scatter charts. In order to draw summary lines, add the desired Summary value to the SummaryValues property. Custom summaries are added with the AddCustomSummary method. Add the Shape objects in the same order in which you add the Summary values.

The point shapes of summary lines are filled with brushes from the SummaryShapeBrushes property.

Their outlining is drawn with pens from the SummaryShapePens property.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the SummaryShapes property is an empty IList object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.SummaryShapeSizes Property

LineChart.SummaryShapeSizes Property

Gets or sets the size of point shapes drawn at summary scatter charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList SummaryShapeSizes { get; set; }
Visual Basic

Public Property SummaryShapeSizes As IList

Property Value

An IList with float values that specify the sizes.

Remarks

The property specifies the size of point shapes drawn at summary scatter charts. In order to draw summary lines, add the desired Summary value to the SummaryValues property. Custom summaries are added with the AddCustomSummary method. Add the Shape objects in the same order in which you add the Summary values.

Each float value in the SummaryShapeSizes array indicates:

  • For point shapes of type Shape.Circle - the radius of the point shape
  • For point shapes of type Shape.Triangle, Shape.Rhombus and Shape.Square - the side of the figure

The point shapes of summary lines are filled with brushes from the SummaryShapeBrushes property. Their outlining is drawn with pens from the SummaryShapePens property.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the SummaryShapeSizes property is an empty IList object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.XData Property

LineChart.XData Property

Gets or sets the numerical data, which is used for calculating the X - coordinates of line points.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList XData { get; set; }
Visual Basic

Public Property XData As IList

Property Value

An instance of type .NET IList that holds other lists with numbers.

Remarks

The property holds the data used for calculating the X-coordinates of chart points. The data can be numbers or DateTime values. There is no restriction as to the format of the data as long as it can safely be converted to numbers or DateTime values using the standard .NET DoubleConverter and DateTimeConverter classes.

If the XData list is empty, the control fills it with consequent integers starting from 0, 1, 2... up till the count of data in the respective YData series. In this case, the data is equally distributed along the X-axis.

There is no limit to the count of series XData can hold.

You can also set a function that calculates the result (y) values in a given numerical interval by means of the CalculateFunctionDelegate.

XData can be sorted in two ways - both the arrays can be sorted in comparison with each other and the numbers in each series can also be sorted. The properties for this are SortSeriesBy and SortOrder.

Default value for the XData property is an empty list.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace
DataFormat Enumeration
DateTimeFormat Enumeration
NumberFormat Enumeration


MindFusion.Charting.LineChart.Y2ScatterLabels Property

LineChart.Y2ScatterLabels Property

Gets or sets custom labels drawn at Y2 scatter shapes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList Y2ScatterLabels { get; set; }
Visual Basic

Public Property Y2ScatterLabels As IList

Property Value

A list that holds other lists with the labels for each Y2-scatter series.

Remarks

Use the property to set custom labels drawn at scatter charts bound to Y2. The LabelType must be set to CustomText to show the labels. LabelAlignment sets the alignment of the scatter labels.

Y2 charts are drawn when the Y2Data property is not an empty list. Scatter charts are drawn when LineType is set to LineTypes.Scatter.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.Y2ShapeBrushes Property

LineChart.Y2ShapeBrushes Property

Gets or sets the brushes for drawing of point shapes at Y2 scatter charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection Y2ShapeBrushes { get; set; }
Visual Basic

Public Property Y2ShapeBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection that holds the brushes for the scatter shapes.

Remarks

The property specifies the brushes, with which point shapes at scatter charts for Y2 are drawn. In order to draw graphics for the second Y-axis, add the desired data to the Y2Data property. The X-values of the lines are taken from the XData property.

The point shapes of Y2 lines are drawn with pens from the Y2ShapePens property. If the Y2ShapePens is an empty list, the control uses a default black pen. If the Y2ShapeBrushes is an empty list, a default blue gradient brush is used.

The size of the point shapes is set with Y2ShapeSizes.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the Y2ShapeBrushes property is an empty BrushCollection object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace
Shape Enumeration
Y2Shapes


MindFusion.Charting.LineChart.Y2ShapePens Property

LineChart.Y2ShapePens Property

Gets or sets the pens for drawing of point shapes at Y2 scatter charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PenCollection Y2ShapePens { get; set; }
Visual Basic

Public Property Y2ShapePens As PenCollection

Property Value

An object of type MindFusion.Drawing.PenCollection.

Remarks

The property specifies the pens, with which point shapes at scatter charts for Y2 are drawn. In order to draw lines for the second Y-axis, add the desired data to the Y2Data property. The X-values for the graphics are taken from the XData property.

The point shapes of summary lines are filled with brushes from the Y2ShapeBrushes property. If it is an empty list, a default white-blue gradient brush is used. If the ShapePens is an empty list, the control uses a black pen.

Their size of the point shapes is set with Y2ShapeSizes.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the Y2ShapePens property is an empty PenCollection object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.Y2Shapes Property

LineChart.Y2Shapes Property

Gets or sets the style of point shapes drawn at Y2 scatter charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList Y2Shapes { get; set; }
Visual Basic

Public Property Y2Shapes As IList

Property Value

An IList with Shape objects.

Remarks

The property specifies the style of point shapes, drawn at Y2-scatter charts. In order to draw lines for the second Y-axis, add the desired data to the Y2Data property. The X-values of the lines are taken from the XData property.

The point shapes of Y2 lines are filled with brushes from the Y2ShapeBrushes property. Their outlining is drawn with pens from the Y2ShapePens property.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the Y2Shapes property is an empty IList object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.Y2ShapeSizes Property

LineChart.Y2ShapeSizes Property

Gets or sets the size of point shapes drawn at Y2 lines.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList Y2ShapeSizes { get; set; }
Visual Basic

Public Property Y2ShapeSizes As IList

Property Value

An IList with float numbers.

Remarks

The property specifies the size of point shapes drawn at Y2 lines. In order to draw lines for the second Y-axis, add the desired data to the Y2Data property. The X-values of the lines are taken from the XData property. Each float value in the Y2ShapeSizes array indicates:

  • For point shapes of type Shape.Circle - the radius of the point shape
  • For point shapes of type Shape.Triangle, Shape.Rhombus and Shape.Square - the side of the figure

The point shapes of Y2lines are filled with brushes from the Y2ShapeBrushes property. Their outlining is drawn with pens from the Y2ShapePens property.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the Y2ShapeSizes property is an empty IList object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace


MindFusion.Charting.LineChart.YData Property

LineChart.YData Property

Gets or sets the data, which is used to calculate the Y-coordinates of the chart points.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList YData { get; set; }
Visual Basic

Public Property YData As IList

Property Value

An instance of type .NET IList that holds other lists with the numbers.

Remarks

The property holds the numbers, which are used to calculate the Y-coordinates of chart points. The data can be either numbers or DateTime values. Data can be in any format (for example strings) that can safely be converted to numbers or DateTime values using the standard .NET DoubleConverter and DateTimeConverter classes.

If the YData list is empty, the control automatically fills it with consequent numbers starting from 0,1,2,3... till the count of data in the respective XData series. In this case, the points are equally spread along the axes.

There is no limit to the count of data in YData - you can add as many series with as many numbers as you need.

You can also set a function that calculates the result (y) values in a given numerical interval with the CalculateFunctionDelegate.

YData can be sorted in two ways - both the lists can be sorted in comparison with each other and the numbers in each series can also be sorted. The properties for that are SortSeriesBy and SortOrder.

Default value for the YData property is an empty list.

See Also

LineChart Members
LineChart Class
MindFusion.Charting Namespace
DataFormat Enumeration
DateTimeFormat Enumeration
NumberFormat Enumeration


MindFusion.Charting.LineTypes Enumeration

LineTypes Enumeration

Specifies the different types of line/area/scatter/bubble charts that can be drawn.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum LineTypes
Visual Basic

Public Enumeration LineTypes

Members

Member name | Description
Area | The chart is drawn as area.
Area3D | The chart is drawn as area with 3D visual effect.
Bubble | The chart is drawn with bubbles. Each bubble has the coordinates of the respective XData and YData numbers. Its size is set by its Y2Data.
Bubble3D | The chart is drawn with bubbles that have 3D visual outlook. Each bubble has the coordinates of the respective XData and YData numbers. Its size is set by its Y2Data.
Line | The chart is drawn in the shape of a line.
Line3D | The chart is drawn as a line with 3D visual effect.
Scatter | The chart is drawn with shape markers at data points.

Remarks

The enumeration specifies the different types of line and respectively area charts that the control can draw. Its members allow bitwise combinations, which makes the variety of charts that can be drawn bigger.

Line charts can be drawn not only as a combination of straight lines but also as a curve. This is set with Curve property.

The property that manipulates the type of the LineChart set is called LineType. When using MindFusion.Charting programmatically, the initial type of the chart created is specified in the constructor.

If you want to draw more than one data graphics in a single line chart you should add the numerical data to the XData and/or YData properties. You can also draw a second Y axis and graphics, which data is bound to it. Use the Y2Data property for that. The Y2Data property stores bubbles radiuses if applied to bubble charts.

The sort sequence of the charts series data is set with the SortSeriesBy property.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.Margins Class

Margins Class
Remarks See Also

Class for setting the space around chart elements.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public sealed class Margins : ICloneable
Visual Basic

Public NotInheritable Class Margins
Implements ICloneable

Remarks

The Margins class is used to set the space around the whole chart. The property is ChartMargins. It is also used for setting the margins around the plot area in charts with axes. The property is PlotAreaMargins.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Margins

See Also

Margins Members
MindFusion.Charting Namespace
ChartMargins


MindFusion.Charting.Margins Members

Margins Members
Constructors Properties Methods

Class for setting the space around chart elements.

The following tables list the members exposed by the Margins type.

Public Constructors

Name | Description
Margins | Overloaded.

Public Properties

Name | Description
Bottom | Gets or sets the bottom margin.
Left | Gets or sets the left margin.
Right | Gets or sets the right margin.
Top | Gets or sets the top margin.

Public Methods

Name | Description
Clone | Creates an exact copy of the current Margins object.
IsEmpty | Checks if this Margins object still has its initial value of [-1, -1, -1, -1].

See Also

Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins Constructor

Margins Constructor

Overload List

Name | Description
Margins () | Creates an instance of the Margins class.
Margins (Single) | Creates a new instance of the Margins class.
Margins (Single, Single, Single, Single) | Creates a new instance of the Margins class.

See Also

Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins Constructor ()

Margins Constructor ()
See Also

Creates an instance of the Margins class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Margins ()
Visual Basic

Public Sub New ()

Remarks

The Top, Left, Right and Bottom properties are all set to -1.

See Also

Margins Constructor Overload List
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins Constructor (Single)

Margins Constructor (Single)
See Also

Creates a new instance of the Margins class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Margins (
float margin
)
Visual Basic

Public New ( _
margin As Single _
)

Parameters

margin
A margin that is applied to all four sides.

Remarks

The Top, Left, Bottom and Right properties are set to margin.

See Also

Margins Constructor Overload List
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins Constructor (Single, Single, Single, Single)

Margins Constructor (Single, Single, Single, Single)
See Also

Creates a new instance of the Margins class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Margins (
float left,
float top,
float right,
float bottom
)
Visual Basic

Public New ( _
left As Single, _
top As Single, _
right As Single, _
bottom As Single _
)

Parameters

left
The left margin.
top
The top margin.
right
The right margin.
bottom
The left margin.

See Also

Margins Constructor Overload List
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins Methods

Margins Methods

Public Methods

Name | Description
Clone | Creates an exact copy of the current Margins object.
IsEmpty | Checks if this Margins object still has its initial value of [-1, -1, -1, -1].

See Also

Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins.Clone Method

Margins.Clone Method

Creates an exact copy of the current Margins object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

The cloned Margins.

See Also

Margins Members
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins.IsEmpty Method

Margins.IsEmpty Method

Checks if this Margins object still has its initial value of [-1, -1, -1, -1].

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool IsEmpty ()
Visual Basic

Public Function IsEmpty () As Boolean

Return Value

false if any of the margins are set; otherwise true.

See Also

Margins Members
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins Properties

Margins Properties

Public Properties

Name | Description
Bottom | Gets or sets the bottom margin.
Left | Gets or sets the left margin.
Right | Gets or sets the right margin.
Top | Gets or sets the top margin.

See Also

Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins.Bottom Property

Margins.Bottom Property

Gets or sets the bottom margin.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float Bottom { get; set; }
Visual Basic

Public Property Bottom As Single

Property Value

A float value. Default is -1.

See Also

Margins Members
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins.Left Property

Margins.Left Property

Gets or sets the left margin.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float Left { get; set; }
Visual Basic

Public Property Left As Single

Property Value

A float value. Default is -1.

See Also

Margins Members
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins.Right Property

Margins.Right Property

Gets or sets the right margin.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float Right { get; set; }
Visual Basic

Public Property Right As Single

Property Value

A float value. Default is -1.

See Also

Margins Members
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins.Top Property

Margins.Top Property

Gets or sets the top margin.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float Top { get; set; }
Visual Basic

Public Property Top As Single

Property Value

A float value. Default is -1.

See Also

Margins Members
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.NumberFormat Enumeration

NumberFormat Enumeration

Specifies formats for numerical values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum NumberFormat
Visual Basic

Public Enumeration NumberFormat

Members

Member name | Description
Currency | Indicates that the number is formatted as a currency value with a currency symbol according to the current regional settings.
Fixed_point | Indicates that the number is formatted as a fixed point number.
Fixed_point_0Digits | Indicates that the number is formatted as a fixed point number with no digits after the decimal point.
Fixed_point_6Digits | Indicates that the number is formatted as a fixed point number with 6 digits after the decimal point.
General | Indicates that the number is formatted as a general number.
General_2Digits | Indicates that the number is formatted as a general format number with two digits.
General_7Digits | Indicates that the number is formatted as a general format number with seven digits.
None | Specifies that the number should not be formatted but drawn as it is.
Number | Indicates that the number will be formatted according to the current regional settings.
Number_4Digits | Indicates that the number is formatted as a general number with four digits after the decimal point.
Percent | Indicates that the number will be formatted as a percent.
Scientific | Indicates that the number will be formatted in scientific format according to the current regional settings.
Scientific_10Digits | Indicates that the number will be formatted in scientific format with ten digits after the decimal point according to the current regional settings.
Scientific_4Digits | Specifies that the number will be formatted in scientific format with four digits after the decimal point according to the current regional settings.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.PathOperator Delegate

PathOperator Delegate

Calls a method that draws or hit tests the path specified.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public delegate bool PathOperator (
GraphicsPath path,
Brush brush,
Pen pen
)
Visual Basic

Public Delegate Function PathOperator ( _
path As GraphicsPath, _
brush As Brush, _
pen As Pen _
) As Boolean

Parameters

path
brush
pen

Return Value

See Also

MindFusion.Charting Namespace


MindFusion.Charting.PieChart Class

PieChart Class
Remarks See Also

A class specified for drawing pie charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public class PieChart : Chart
Visual Basic

Public Class PieChart
Inherits Chart

Remarks

PieChart inherits properties and methods from its base class Chart.

Instances of the PieChart class are responsible for drawing both 2D and 3D pie and doughnut charts. The type of the chart is set with the PieType property and is an instance of the PieType enumeration.

Data for the pie is specified with the Data property. It is a single-dimensional list that can hold either numbers or values of any other type that can be converted to numbers.

Pie data can be cancelled if the numbers are too big. The DivisionCoef property specifies the division coefficient. The unit of measure is set with DivisionLabel.

Pies and doughnut charts can have one or all of its pieces detached. The index of the piece detached is specified with PieceOutIndex. Drawing of pie pieces can start from an angle, other than 0. Use the StartAngle property to specify it.

Each pie can have text outside and inside its segments (pieces). The type of text is specified with OuterLabelType and InnerLabelType.

Custom text, drawn inside or outside the pie pieces is set with InnerLabels and OuterLabels.

Each label, drawn inside / outside the pie pieces can be drawn with a label before or after it - use LabelSuffix and LabelPrefix to set it.

Labels drawn outside of pie segments are drawn with pointers from the middle of the piece to the label. The length of the pointer is specified with PointerLength.

The radius of the pie is set with RadiusLength.

If you want to set the tension (flatness) and thickness of 3D pie charts use Pie3DTension and Pie3DThickness.

In doughnut charts, you can use the DoughnutThickness property to specify the thickness of doughnuts.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Chart
MindFusion.Charting.PieChart

See Also

PieChart Members
MindFusion.Charting Namespace


MindFusion.Charting.PieChart Members

PieChart Members
Constructors Properties Methods

A class specified for drawing pie charts.

The following tables list the members exposed by the PieChart type.

Public Constructors

Name | Description
PieChart | Creates a new instance of the PieChart class.

Public Properties

Name | Description
Data | Specifies the numerical data used for calculating the segments of the pie.
DivisionCoef | Specifies the division coefficient for pie data.
DivisionLabel | Specifies the unit of measure for data in the pie chart.
DoughnutThickness | Gets or sets the thickness of the doughnut as to the radius.
InnerLabelBackground | Gets or sets the pen for filling the border rectangle of pie inner labels.
InnerLabelBorder | Gets or sets the border drawn around inner labels.
InnerLabelBorderMargin | Gets or sets the margin of the border of inner labels.
InnerLabelFormat | Gets or sets the number format for numerical inner labels.
InnerLabelOutline | Gets or sets the pen for drawing the border rectangle of inner labels.
InnerLabelPosition | Specifies the position of labels inside pie pieces.
InnerLabels | Specifies the text drawn inside each pie piece.
InnerLabelType | Specifies the type of labels to be drawn inside pie pieces.
LabelPrefix | Gets or sets a string prefix for labels inside/outside the pie's pieces.
LabelSuffix | Gets or sets a string suffix for labels inside/outside the pie's pieces.
OuterLabelBackground | Gets or sets the Brush for filling the border rectangle of pie outer labels.
OuterLabelBorder | Gets or sets the border drawn around outer labels.
OuterLabelBorderMargin | Gets or sets the margin for the border of outer labels.
OuterLabelFormat | Gets or sets the number format for numerical outer labels.
OuterLabelOutline | Gets or sets the pen for drawing the border rectangle of outer labels.
OuterLabels | Specifies the text drawn outside each pie piece.
OuterLabelType | Specifies the type of labels drawn outside pie pieces.
OutlinePen | Specifies the chart pen used for drawing the pie outlining.
Pie3DTension | Specifies the flatness of 3D pies.
Pie3DThickness | Specifies the height of 3D pies.
PieceOutIndex | Specifies the index of the detached pie piece.
PieceOutPercent | Specifies the distance at which the detached pie piece is drawn from the center of the pie/doughnut.
PieMargins | Specifies the margins for the pie chart.
PieType | Gets or sets the type of the pie chart to be drawn.
PointerLength | Gets or sets the length of the piece pointers.
RadiusLength | Specifies the radius length of the pie chart.
StartAngle | Gets or sets the start angle for drawing the pieces of the pie.

Public Methods

Name | Description
CalculateSize | Calculates the size of the chart and initalizes the variables used back to normal values.
ClearData | Removes all data and labels.
ClearDataBoundLists | Clears all IList properties that support data binding.
Clone | Creates an exact copy of the current PieChart object.
DrawChart | Draws the chart. First, prepares everything needed for drawing the chart.
HitTest | Returns the chart element at the specified position
HitTestPie | Returns the PiePiece at the specified position.

Protected Methods

Name | Description
CreateChart | Creates a new PieChart object.

See Also

PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart Constructor

PieChart Constructor

Creates a new instance of the PieChart class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PieChart (
PieType type
)
Visual Basic

Public Sub PieChart ( _
type As PieType _
)

Parameters

type
One of the PieType enumeration values.

Remarks

The type parameter indicates the type of the pie chart to be drawn. The charts created by the method can be pies and doughnuts with 2D or 3D visual effects. The type parameter is a member of the PieType enumeration. MindFusion.Charting also supports drawing of doughnut charts.

See Also

PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart Methods

PieChart Methods

Public Methods

Name | Description
CalculateSize | Calculates the size of the chart and initalizes the variables used back to normal values.
ClearData | Removes all data and labels.
ClearDataBoundLists | Clears all IList properties that support data binding.
Clone | Creates an exact copy of the current PieChart object.
DrawChart | Draws the chart. First, prepares everything needed for drawing the chart.
HitTest | Returns the chart element at the specified position
HitTestPie | Returns the PiePiece at the specified position.

Protected Methods

Name | Description
CreateChart | Creates a new PieChart object.

See Also

PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.CalculateSize Method

PieChart.CalculateSize Method

Calculates the size of the chart and initalizes the variables used back to normal values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override SizeF CalculateSize ()
Visual Basic

Public Overrides Function CalculateSize () As SizeF

Return Value

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.ClearData Method

PieChart.ClearData Method

Removes all data and labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override void ClearData ()
Visual Basic

Public Overrides Sub ClearData ()

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.ClearDataBoundLists Method

PieChart.ClearDataBoundLists Method

Clears all IList properties that support data binding.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override void ClearDataBoundLists ()
Visual Basic

Public Overrides Sub ClearDataBoundLists ()

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.Clone Method

PieChart.Clone Method

Creates an exact copy of the current PieChart object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

The cloned pie chart.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.CreateChart Method

PieChart.CreateChart Method

Creates a new PieChart object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

protected virtual Chart CreateChart ()
Visual Basic

Protected Overridable Function CreateChart () As Chart

Return Value

The new pie chart.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.DrawChart Method

PieChart.DrawChart Method

Draws the chart. First, prepares everything needed for drawing the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override void DrawChart ()
Visual Basic

Public Overrides Sub DrawChart ()

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.HitTest Method

PieChart.HitTest Method

Returns the chart element at the specified position

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override ChartElement HitTest (
int x,
int y
)
Visual Basic

Public Overrides Function HitTest ( _
x As Integer, _
y As Integer _
) As ChartElement

Parameters

x
the X - coordinate of the mouse
y
the Y - coordinate of the mouse

Return Value

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.HitTestPie Method

PieChart.HitTestPie Method

Returns the PiePiece at the specified position.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PiePiece HitTestPie (
int x,
int y
)
Visual Basic

Public Function HitTestPie ( _
x As Integer, _
y As Integer _
) As PiePiece

Parameters

x
the X - coordinate of the mouse
y
the Y - coordinate of the mouse

Return Value

The PiePiece found at the position specified by x and y; otherwise null.

Remarks

Use this method when hit-testing pie charts. The result can be null, so always check.

See Also

HitTest
PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart Properties

PieChart Properties

Public Properties

Name | Description
Data | Specifies the numerical data used for calculating the segments of the pie.
DivisionCoef | Specifies the division coefficient for pie data.
DivisionLabel | Specifies the unit of measure for data in the pie chart.
DoughnutThickness | Gets or sets the thickness of the doughnut as to the radius.
InnerLabelBackground | Gets or sets the pen for filling the border rectangle of pie inner labels.
InnerLabelBorder | Gets or sets the border drawn around inner labels.
InnerLabelBorderMargin | Gets or sets the margin of the border of inner labels.
InnerLabelFormat | Gets or sets the number format for numerical inner labels.
InnerLabelOutline | Gets or sets the pen for drawing the border rectangle of inner labels.
InnerLabelPosition | Specifies the position of labels inside pie pieces.
InnerLabels | Specifies the text drawn inside each pie piece.
InnerLabelType | Specifies the type of labels to be drawn inside pie pieces.
LabelPrefix | Gets or sets a string prefix for labels inside/outside the pie's pieces.
LabelSuffix | Gets or sets a string suffix for labels inside/outside the pie's pieces.
OuterLabelBackground | Gets or sets the Brush for filling the border rectangle of pie outer labels.
OuterLabelBorder | Gets or sets the border drawn around outer labels.
OuterLabelBorderMargin | Gets or sets the margin for the border of outer labels.
OuterLabelFormat | Gets or sets the number format for numerical outer labels.
OuterLabelOutline | Gets or sets the pen for drawing the border rectangle of outer labels.
OuterLabels | Specifies the text drawn outside each pie piece.
OuterLabelType | Specifies the type of labels drawn outside pie pieces.
OutlinePen | Specifies the chart pen used for drawing the pie outlining.
Pie3DTension | Specifies the flatness of 3D pies.
Pie3DThickness | Specifies the height of 3D pies.
PieceOutIndex | Specifies the index of the detached pie piece.
PieceOutPercent | Specifies the distance at which the detached pie piece is drawn from the center of the pie/doughnut.
PieMargins | Specifies the margins for the pie chart.
PieType | Gets or sets the type of the pie chart to be drawn.
PointerLength | Gets or sets the length of the piece pointers.
RadiusLength | Specifies the radius length of the pie chart.
StartAngle | Gets or sets the start angle for drawing the pieces of the pie.

See Also

PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.Data Property

PieChart.Data Property

Specifies the numerical data used for calculating the segments of the pie.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList Data { get; set; }
Visual Basic

Public Property Data As IList

Property Value

An object of type .NET IList class that holds a single array with numbers.

Remarks

The property holds the data for the pie. The values can be either numbers or of any other type that can be parsed to numbers. Add the values directly to the property or assign to it a list that holds the data.

The data numbers can be cancelled - use the DivisionCoef and DivisionLabel properties to specify the divisor and the label that indicates the units of measure.

Default value for the Data property is an empty list.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace
InnerLabels
OuterLabels


MindFusion.Charting.PieChart.DivisionCoef Property

PieChart.DivisionCoef Property

Specifies the division coefficient for pie data.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double DivisionCoef { get; set; }
Visual Basic

Public Property DivisionCoef As Double

Property Value

A double value that represents the coefficient.

Remarks

The property specifies the division coefficient, with which pie data is cancelled. Use DivisionLabel to set the unit of measure when pie data has been cancelled.

The DivisionCoef property is not considered if none of the InnerLabelType and OuterLabelType properties is set to LabelType.Data.

Default value for the DivisionCoef property is Double.NaN, that is the numbers are not divided.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.DivisionLabel Property

PieChart.DivisionLabel Property

Specifies the unit of measure for data in the pie chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string DivisionLabel { get; set; }
Visual Basic

Public Property DivisionLabel As String

Property Value

A string object that represents the unit of measure.

Remarks

The property is used to indicate the unit of measure when the pie data has been cancelled. It is considered only if the InnerLabelType or OuterLabelType for this pie is set to LabelType.Data.

The division coefficient is specified with the DivisionCoef property.

Default value for the DivisionLabel property is an empty string.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.DoughnutThickness Property

PieChart.DoughnutThickness Property

Gets or sets the thickness of the doughnut as to the radius.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int DoughnutThickness { get; set; }
Visual Basic

Public Property DoughnutThickness As Integer

Property Value

An int value. Default is 50.

Remarks

DoughnutThickness values range from 0 to 100. Values closer to 100 make the doughnut look more like a pie. Values close to 0 make it look more like a thin ring.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.InnerLabelBackground Property

PieChart.InnerLabelBackground Property

Gets or sets the pen for filling the border rectangle of pie inner labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush InnerLabelBackground { get; set; }
Visual Basic

Public Property InnerLabelBackground As Brush

Property Value

An object of type MindFusion.Drawing.Brush class.

Remarks

Use InnerLabelBorder to set the type of the border. The outline of the border rectangle is drawn with InnerLabelOutline. InnerLabelBorderMargin specifies the space between the label and the border.

Default value for the InnerLabelBackground property is a light blue SolidBrush.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace
OuterLabelBackground


MindFusion.Charting.PieChart.InnerLabelBorder Property

PieChart.InnerLabelBorder Property

Gets or sets the border drawn around inner labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Border InnerLabelBorder { get; set; }
Visual Basic

Public Property InnerLabelBorder As Border

Property Value

One of the Border Enumeration values. Default value is Border.None.

Remarks

The border rectangle is drawn with InnerLabelOutline and filled with InnerLabelBackground. The offset between the inner label and its border is set with InnerLabelBorderMargin.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace
OuterLabelBorder
InnerLabelBorderMargin


MindFusion.Charting.PieChart.InnerLabelBorderMargin Property

PieChart.InnerLabelBorderMargin Property

Gets or sets the margin of the border of inner labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float InnerLabelBorderMargin { get; set; }
Visual Basic

Public Property InnerLabelBorderMargin As Single

Property Value

A float value. Default is 5f.

Remarks

The property specifies the space between the inner label and its border. The border is set with InnerLabelBorder. The border rectangle is drawn with InnerLabelOutline and filled with InnerLabelBackground.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.InnerLabelFormat Property

PieChart.InnerLabelFormat Property

Gets or sets the number format for numerical inner labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public NumberFormat InnerLabelFormat { get; set; }
Visual Basic

Public Property InnerLabelFormat As NumberFormat

Property Value

One of the NumberFormat enumeration values. Default is NumberFormat.Fixed_point.

Remarks

The property specifies the format of labels inside pie pieces when the InnerLabelType is set to LabelType.Data or LabelType.Percents.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace
InnerLabels


MindFusion.Charting.PieChart.InnerLabelOutline Property

PieChart.InnerLabelOutline Property

Gets or sets the pen for drawing the border rectangle of inner labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen InnerLabelOutline { get; set; }
Visual Basic

Public Property InnerLabelOutline As Pen

Property Value

An instance of MindFusion.Drawing.Pen class.

Remarks

The border of inner labels is set with InnerLabelBorder. It is filled with InnerLabelBackground. Use InnerLabelBorderMargin to specify the space between the inner label and its border.

Default value for the InnerLabelOutline property is a black Pen.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.InnerLabelPosition Property

PieChart.InnerLabelPosition Property

Specifies the position of labels inside pie pieces.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int InnerLabelPosition { get; set; }
Visual Basic

Public Property InnerLabelPosition As Integer

Property Value

An int number.

Remarks

The property indicates the position of labels inside pie pieces as percent from the pie radius. Set the property to a value between 0 and 100. The smaller the value, the closer the label is drawn to the center of the chart. Numbers close to 100 indicate that the labels shall be drawn close to the edge of the pie.

The type of inner and outer labels is specified with InnerLabelType and OuterLabelType properties.

Default value for the InnerLabelPosition is 50 (labels are drawn in the middle of the pie radius).

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.InnerLabels Property

PieChart.InnerLabels Property

Specifies the text drawn inside each pie piece.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList InnerLabels { get; set; }
Visual Basic

Public Property InnerLabels As IList

Property Value

An instance of the .NET IList class, which is a single array with the labels.

Remarks

Use the property to specify the text drawn inside each pie piece, when you have set the InnerLabelType member to LabelType.CustomText.

The InnerLabelFormat property specifies the number format for numerical inner labels.

OuterLabels are set with the OuterLabels property and the OuterLabelType property.

Default value for the InnerLabels property is an empty array.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.InnerLabelType Property

PieChart.InnerLabelType Property

Specifies the type of labels to be drawn inside pie pieces.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LabelType InnerLabelType { get; set; }
Visual Basic

Public Property InnerLabelType As LabelType

Property Value

One of the LabelType enumeration values.

Remarks

The property enables you to choose the type of label drawn inside each segment of a pie chart. Use InnerLabels to specify custom labels.

Outer labels are specified with OuterLabelType and OuterLabels properties. The position of the inner labels in the piece is specified with InnerLabelPosition.

Default value for the InnerLabelType property is LabelType.Empty.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.LabelPrefix Property

PieChart.LabelPrefix Property

Gets or sets a string prefix for labels inside/outside the pie's pieces.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string LabelPrefix { get; set; }
Visual Basic

Public Property LabelPrefix As String

Property Value

A string value.

Remarks

Use the property to specify a prefix drawn before each label inside / outside pie pieces. Use LabelSuffix to set a suffix drawn behind each label.

The prefix and suffix are the same for all pie pieces. The label type is set with InnerLabelType and OuterLabelType. InnerLabels and OuterLabels specify custom labels.

Default value for LabelPrefix property is an empty string.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.LabelSuffix Property

PieChart.LabelSuffix Property

Gets or sets a string suffix for labels inside/outside the pie's pieces.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string LabelSuffix { get; set; }
Visual Basic

Public Property LabelSuffix As String

Property Value

A string value.

Remarks

The property specifies a suffix drawn behind each label inside / outside pie pieces. You can also set a prefix drawn before each label with LabelPrefix.

The prefix and suffix are the same for all pie pieces. The type of the inner and outer labels is set with InnerLabelType and OuterLabelType. Custom labels are set with InnerLabels and OuterLabels.

Default value for LabelSuffix property is an empty string.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.OuterLabelBackground Property

PieChart.OuterLabelBackground Property

Gets or sets the Brush for filling the border rectangle of pie outer labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush OuterLabelBackground { get; set; }
Visual Basic

Public Property OuterLabelBackground As Brush

Property Value

An object of type MindFusion.Drawing.Brush class.

Remarks

Use OuterLabelBorder to specify the Border drawn around outer labels. OuterLabelOutline specifies the pen for drawing the border rectangle. The space between the label and its border is specified with OuterLabelBorderMargin.

Default value for the OuterLabelBackground property is a light blue SolidBrush.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace
InnerLabelBackground


MindFusion.Charting.PieChart.OuterLabelBorder Property

PieChart.OuterLabelBorder Property

Gets or sets the border drawn around outer labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Border OuterLabelBorder { get; set; }
Visual Basic

Public Property OuterLabelBorder As Border

Property Value

One of the Border Enumeration values. Default value is Border.None.

Remarks

The border is drawn with pen specified with OuterLabelOutline and filled with OuterLabelBackground. Use OuterLabelBorderMargin to specify the space between the label and its border.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace
InnerLabelBorder


MindFusion.Charting.PieChart.OuterLabelBorderMargin Property

PieChart.OuterLabelBorderMargin Property

Gets or sets the margin for the border of outer labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float OuterLabelBorderMargin { get; set; }
Visual Basic

Public Property OuterLabelBorderMargin As Single

Property Value

A float value. Default is 5f.

Remarks

The property specifies the space between the outer label and its border.

Outer labels in pies are drawn with border set by OuterLabelBorder. The border rectangle is drawn with OuterLabelOutline and filled with OuterLabelBackground.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.OuterLabelFormat Property

PieChart.OuterLabelFormat Property

Gets or sets the number format for numerical outer labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public NumberFormat OuterLabelFormat { get; set; }
Visual Basic

Public Property OuterLabelFormat As NumberFormat

Property Value

One of the NumberFormat enumeration values. Default is NumberFormat.Fixed_point.

Remarks

The property specifies the format of labels drawn outside pie pieces when the OuterLabelType is set to LabelType.Data or LabelType.Percents.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.OuterLabelOutline Property

PieChart.OuterLabelOutline Property

Gets or sets the pen for drawing the border rectangle of outer labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen OuterLabelOutline { get; set; }
Visual Basic

Public Property OuterLabelOutline As Pen

Property Value

An instance of MindFusion.Drawing.Pen class. Default is a black Pen, width 1.

Remarks

Use OuterLabelBorder to specify the border around outer labels. The border rectangle is filled with OuterLabelBackground. Space between the outer label and its border is specified with OuterLabelBorderMargin.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.OuterLabels Property

PieChart.OuterLabels Property

Specifies the text drawn outside each pie piece.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList OuterLabels { get; set; }
Visual Basic

Public Property OuterLabels As IList

Property Value

An instance of the .NET IList class.

Remarks

Use the property to specify the labels, drawn outside each pie piece, when you have set the OuterLabelType property to LabelType.CustomText.

You can assign to OuterLabels the array that holds the labels or add them directly to the OuterLabels property.

Inner labels are specified with the InnerLabelType and InnerLabels properties.

Default value for the OuterLabels property is an empty array.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.OuterLabelType Property

PieChart.OuterLabelType Property

Specifies the type of labels drawn outside pie pieces.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public LabelType OuterLabelType { get; set; }
Visual Basic

Public Property OuterLabelType As LabelType

Property Value

One of the LabelType enumeration values.

Remarks

The property enables you to choose the type of label drawn outside each pie segment. Custom labels are specified with OuterLabels. Lines are drawn from the middle of each segment to its label. Use the PointerLength property to specify the length of this line.

Default value for the OuterLabelType property is LabelType.Empty.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.OutlinePen Property

PieChart.OutlinePen Property

Specifies the chart pen used for drawing the pie outlining.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen OutlinePen { get; set; }
Visual Basic

Public Property OutlinePen As Pen

Property Value

An object of type MindFusion.Drawing.Pen.

Remarks

The pie in a pie chart is drawn with a visible outlining, which makes the chart easier to understand. This property specifies the pen used for drawing the outlining not only for the whole pie but also between the separate pie pieces.

Default value for the OutlinePen property is a black Pen, width 1.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.Pie3DTension Property

PieChart.Pie3DTension Property

Specifies the flatness of 3D pies.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int Pie3DTension { get; set; }
Visual Basic

Public Property Pie3DTension As Integer

Property Value

An int value that specifies the flatness.

Remarks

The property specifies the flatness of pies, that are 3D. The bigger the Pie3DTension, the flatter the pie. The property value should be between 0 and 100.

Generally, thick pies look better with bigger 3D tension and thin pies with a small one. Check the Pie3DThickness property for more details.

Default value for the Pie3DTension is 25.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.Pie3DThickness Property

PieChart.Pie3DThickness Property

Specifies the height of 3D pies.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float Pie3DThickness { get; set; }
Visual Basic

Public Property Pie3DThickness As Single

Property Value

A float value that specifies the height.

Remarks

The property indicates how thick (tall) the 3D pie is. The flatness of a 3D pie is specified with Pie3DTension. Generally, a thick pie looks better with bigger 3D tension and a flat pie with a small one.

Default value for the Pie3DThickness is 20.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.PieceOutIndex Property

PieChart.PieceOutIndex Property

Specifies the index of the detached pie piece.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int PieceOutIndex { get; set; }
Visual Basic

Public Property PieceOutIndex As Integer

Property Value

An int value that specifies the zero-based index of the detached piece.

Remarks

The property specifies the 0-based index of the detached piece. You should set this property to the count of all pieces or more and all pie pieces will be drawn detached.

The PieceOutPercent property sets the distance, at which the detached pie / doughnut piece is drawn from the pie / doughnut center.

Default value for the PieceOutIndex property is -1, which means that no pie piece is detached.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.PieceOutPercent Property

PieChart.PieceOutPercent Property

Specifies the distance at which the detached pie piece is drawn from the center of the pie/doughnut.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float PieceOutPercent { get; set; }
Visual Basic

Public Property PieceOutPercent As Single

Property Value

An int value that specifies the distance, in percents from the pie's radius.

Remarks

The property specifies the distance, at which pie pieces are drawn from the centre of the pie. The distance is set as percent from the pie radius. Add a value between 0 and 100 to PieceOutPercent.

The PieceOutIndex specifies the 0-based index of the piece, which is detached (if any).

Default value for the PieceOutPercent property is 20.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.PieMargins Property

PieChart.PieMargins Property

Specifies the margins for the pie chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float PieMargins { get; set; }
Visual Basic

Public Property PieMargins As Single

Property Value

A float number that represents the margins.

Remarks

The property specifies the margins that are left at all four side of the pie chart. When the PieMargins property is set, the control does not calculate any space for the OuterLabels / InnerLabels. That is why the margins should be set in accordance with the length of the labels and the piece pointers.

The size of the legend (if any) is not included in the pie margins.

Default value for the PieMargins property is -1, which means that MindFusion.Charting calculates the margins automatically so that all labels could fit in.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.PieType Property

PieChart.PieType Property

Gets or sets the type of the pie chart to be drawn.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PieType PieType { get; set; }
Visual Basic

Public Property PieType As PieType

Property Value

One of the PieType enumeration values.

Remarks

The property specifies the type of the pie chart drawn. The type of the pie chart is set by its declaration in the constructor. When it is changed dynamically, it should be noted that some pie types need different settings than others.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.PointerLength Property

PieChart.PointerLength Property

Gets or sets the length of the piece pointers.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float PointerLength { get; set; }
Visual Basic

Public Property PointerLength As Single

Property Value

A float value that represents the length of the piece pointer.

Remarks

A pointer is drawn from the middle of the edge of a pie piece to the label outside it. Labels are drawn when the OuterLabelType of the pie is not set to LabelType.Empty.

The length of the piece pointer is included in the PieMargins property, if specified.

Default value for the PointerLength property is 10f.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace
OuterLabels


MindFusion.Charting.PieChart.RadiusLength Property

PieChart.RadiusLength Property

Specifies the radius length of the pie chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float RadiusLength { get; set; }
Visual Basic

Public Property RadiusLength As Single

Property Value

A float value.

Remarks

The property sets how big the pie is drawn.

When the chart is 3D, use Pie3DThickness and Pie3DTension to specify the thickness and tension of the pie.

Default value for the RadiusLength property is 100F.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PieChart.StartAngle Property

PieChart.StartAngle Property

Gets or sets the start angle for drawing the pieces of the pie.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float StartAngle { get; set; }
Visual Basic

Public Property StartAngle As Single

Property Value

A float value that represents the start angle.

Remarks

The property specifies the start angle for drawing the pieces of the pie. Possible values range from 0 to 360.

The data for the pie pieces is set with Data.

Default value for the StartAngle property is 0.

See Also

PieChart Members
PieChart Class
MindFusion.Charting Namespace


MindFusion.Charting.PiePiece Class

PiePiece Class
Remarks See Also

A class that represents pie piece objects in pie charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public sealed class PiePiece : ChartElement
Visual Basic

Public NotInheritable Class PiePiece
Inherits ChartElement

Remarks

Each pie piece in a pie chart is an instance of the PiePiece class. When the user clicks on a pie piece in hit-testing, the PiePiece object that contains the hitted mouse point is returned.

The members of the PiePiece class are read-only. Use the respective pie piece properties of the PieChart class to set them.

Inheritance Hierarchy

System.Object
MindFusion.Charting.ChartElement
MindFusion.Charting.PiePiece

See Also

PiePiece Members
MindFusion.Charting Namespace


MindFusion.Charting.PiePiece Members

PiePiece Members
Constructors Properties

A class that represents pie piece objects in pie charts.

The following tables list the members exposed by the PiePiece type.

Public Constructors

Name | Description
PiePiece | Initializes a new instance of the PiePiece class.

Public Properties

Name | Description
Angle | Gets the angle of the PiePiece.
InnerLabel | Gets the inner label drawn at this pie piece.
OuterLabel | Gets the label drawn outside the pie piece.
PieceOut | Gets whether this piece is detached.

See Also

PiePiece Class
MindFusion.Charting Namespace


MindFusion.Charting.PiePiece Constructor

PiePiece Constructor

Initializes a new instance of the PiePiece class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PiePiece ()
Visual Basic

Public Sub New ()

See Also

PiePiece Class
MindFusion.Charting Namespace


MindFusion.Charting.PiePiece Properties

PiePiece Properties

Public Properties

Name | Description
Angle | Gets the angle of the PiePiece.
InnerLabel | Gets the inner label drawn at this pie piece.
OuterLabel | Gets the label drawn outside the pie piece.
PieceOut | Gets whether this piece is detached.

See Also

PiePiece Class
MindFusion.Charting Namespace


MindFusion.Charting.PiePiece.Angle Property

PiePiece.Angle Property

Gets the angle of the PiePiece.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double Angle { get; }
Visual Basic

Public ReadOnly Property Angle As Double

Property Value

A double value that represents the angle of the piece.

Remarks

The angle is calculated based on the number that stands for this piece in the Data property of the pie chart.

See Also

PiePiece Members
PiePiece Class
MindFusion.Charting Namespace


MindFusion.Charting.PiePiece.InnerLabel Property

PiePiece.InnerLabel Property

Gets the inner label drawn at this pie piece.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string InnerLabel { get; }
Visual Basic

Public ReadOnly Property InnerLabel As String

Property Value

A string that represents the inner label.

Remarks

The label depends on the InnerLabelType for this pie chart. Custom labels are set with InnerLabels.

See Also

PiePiece Members
PiePiece Class
MindFusion.Charting Namespace


MindFusion.Charting.PiePiece.OuterLabel Property

PiePiece.OuterLabel Property

Gets the label drawn outside the pie piece.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string OuterLabel { get; }
Visual Basic

Public ReadOnly Property OuterLabel As String

Property Value

A string that represents the label.

Remarks

The outer label depends on the value of the OuterLabelType property. Custom labels are set with OuterLabels.

See Also

PiePiece Members
PiePiece Class
MindFusion.Charting Namespace


MindFusion.Charting.PiePiece.PieceOut Property

PiePiece.PieceOut Property

Gets whether this piece is detached.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool PieceOut { get; }
Visual Basic

Public ReadOnly Property PieceOut As Boolean

Property Value

A bool value.

Remarks

The piece is drawn detached when the value of PieceOut property is set to the index of the piece or to a value greater than the number of pie pieces. In this case, all pieces are drawn detached.

See Also

PiePiece Members
PiePiece Class
MindFusion.Charting Namespace


MindFusion.Charting.PieType Enumeration

PieType Enumeration

Specifies the possible type of pie chart that can be drawn.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum PieType
Visual Basic

Public Enumeration PieType

Members

Member name | Description
Doughnut2D | Specifies that the chart drawn is a 2D (plain) doughnut.
Doughnut3D | Specifies that the chart drawn is a doughnut with 3D visual effect.
Pie2D | Specifies that the chart drawn is a plain (2D) pie.
Pie3D | Specifies that the chart drawn is a pie with 3D visual effect.

Remarks

This Enumeration represents the different types of pies that can be drawn. The pie type is set in the constructor of the PieChart class and can later be manipulated with the PieType property.

The thickness and tension for the pie / doughnut is specified with he Pie3DThickness and Pie3DTension properties. If pie data is too big, you can cancel it with DivisionCoef and DivisionLabel properties.

See Also

MindFusion.Charting Namespace
PieChart Constructor


MindFusion.Charting.Position Enumeration

Position Enumeration

Specifies the position of different chart elements.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum Position
Visual Basic

Public Enumeration Position

Members

Member name | Description
Bottom | The item is placed to the bottom.
Left | The item is placed to the left.
Right | The item is placed to the right.
Top | The item is placed to the top.

Remarks

The enumeration specifies the position of chart items. Currently it is used by the:

  • TitleLabelPosition to specify the position of the axis label.
  • Chart legend with LegendPosition to specify its allocation as to the chart graphic.
  • The inner axis in radar charts with InnerAxisPosition to specify its position in the chart circle / polygon.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.RadarChart Class

RadarChart Class
Remarks See Also

A class used to draw radar charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public class RadarChart : Chart
Visual Basic

Public Class RadarChart
Inherits Chart

Remarks

RadarChart inherits properties and methods from its base class Chart.

MindFusion.Charting can draw both 2D and 3D radar and polar charts. The different radar types are listed as members of the RadarType Enumeration. 3D charts are drawn with a 3D-like background, which color is specified with the Background3D color.

The style of the radar / polar chart is set by the RadarStyle property. The property's values allow bitwise combination.

The brushes and pens that are used in radar charts are set with ChartBrushes and ChartPens. It is not necessary to set both. Use ShapeBrushes and ShapePens to set how data points are drawn.

Typically, a radar chart has as many outer axes as the count of data series. They are drawn as concentrical circles. The biggest one is the OuterAxis, the rest are alternative outer axes. Set SpiderWeb to true to draw the outer axes as polygons instead of circles. They are drawn with AltAxesPens. In polar charts, the outer axis holds information about the angles of the data points. They are specified with the Angles property.

The outer axis is drawn with the OuterAxisPen. Labels can be drawn at the intersection points of the outer axis with each inner axis. The type of those labels is set with OuterAxisLabelType. Labels might also be drawn in the middle of each segment - they are only custom text and are set with OuterLabels.

AxisLabelType.ChartData is not applied for specifying the OuterAxisLabelType property. AxisLabelType.AutoScale is used only in RadarChart objects.

Usually a radar chart will have as many inner axes as the count of elements in the longest Data series. The inner axes are drawn as radiuses. One of them is the primary InnerAxis and its position is set with InnerAxisPosition. The InnerAxis holds the scale divisions for the radar data. It starts from MinValue and ends with MaxValue. The Span property determines the count of the divisions.

The InnerAxis is drawn with the InnerAxisPen. Its labels depend on InnerAxisLabelType. Custom labels are set with InnerAxisLabels. If the labels are numbers, they are formatted with InnerLabelFormat.

The chart background can be drawn in sections or segments. Sections resemble concentric circumferences drawn with brushes from the SectionBrushes property. The positions of the sections are specified with SectionPoints.

Segments represent triangular-like areas within two inner axes. They are filled with brushes taken consecutively from the SegmentBrushes.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Chart
MindFusion.Charting.RadarChart

See Also

RadarChart Members
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart Members

RadarChart Members
Constructors Properties Methods

A class used to draw radar charts.

The following tables list the members exposed by the RadarChart type.

Public Constructors

Name | Description
RadarChart | Creates a new instance of the RadarChart class.

Public Properties

Name | Description
AltAxesCount | Gets or sets the count of alternative chart axes.
AltAxesPens | Specifies the collection of pens used for drawing the alternative axes.
Angles | Specifies the angles of data points in polar charts.
Background3D | Gets or sets whether the chart is drawn with 3D effect.
Data | Gets or sets the data for the chart series.
InnerAxisLabels | Gets or sets custom labels for the inner axis.
InnerAxisLabelType | Gets or sets the label type of the inner axis.
InnerAxisPen | Gets or sets the pen for drawing the inner axis.
InnerAxisPosition | Gets or sets the position of the inner axis.
InnerLabelFormat | Gets or sets the format for labels drawn at the inner axis.
LabelPrefix | Gets or sets the prefix for radar labels.
LabelSuffix | Gets or sets the suffix for labels at radar charts.
MaxValue | Gets or sets the end value at the inner axis.
MinValue | Gets or sets the start value of the inner axis.
OuterAxisLabelBackground | Gets or sets the brush that fills the border rectangle drawn around labels at the outer axis.
OuterAxisLabelBorder | Gets or sets the border drawn around outer axis labels.
OuterAxisLabelMargin | Gets or sets the space between the outer axis label and its border.
OuterAxisLabelOutline | Gets or sets the Pen that draws the border rectangle for outer axis labels.
OuterAxisLabels | Gets or sets custom labels drawn at the outer axis.
OuterAxisLabelType | Specifies the type of labels drawn at the outer axis.
OuterAxisPen | Specifies the pen for drawing the outer chart axis.
OuterLabelBackground | Gets or sets the Brush that fills the border rectangle of OuterLabels.
OuterLabelBorder | Gets or sets the border drawn around OuterLabels.
OuterLabelFormat | Gets or sets the format for labels drawn at the outer chart axis.
OuterLabelMargin | Gets or sets the space between the outer label and its border.
OuterLabelOutline | Gets or sets the Pen that draws the border rectangle for OuterLabels.
OuterLabels | Specifies the custom labels drawn at the chart segments of the outer axis.
RadarStyle | Gets or sets the style of the radar / polar chart to be drawn.
RadarType | Gets or sets the type of the radar chart to be drawn.
RadiusLength | Specifies the length of the chart radius.
SectionBrushes | Specifies the brushes for drawing the sections of the chart circle.
SectionPoints | Gets or sets the width and location of radar sections.
SegmentBrushes | Specifies the brushes for filling chart background segments.
ShapeBrushes | Specifies the brushes for filling data point shapes.
ShapePens | Specifies the pens for outlining the shapes drawn at data points.
Shapes | Specifies the shapes for data points.
ShapeSizes | Specifies the size of shapes drawn at data points.
Span | Specifies the numerical span of scale division at the inner axes.
SpiderWeb | Specifies whether the outer chart axes are drawn as circles or polygons.

Public Methods

Name | Description
ClearData | Clears any data from the chart.
ClearDataBoundLists | Clears all IList properties that support data binding.
Clone | Creates an exact copy of the current RadarChart object.
DrawChart | Calls preparatory and drawing methods according to the chart type, data and settings
HitTest | Returns the chart element at the specified position
HitTestRadar | Returns the RadarPiece at the specified location.

Protected Methods

Name | Description
CreateChart | Creates a new RadarChart object.

See Also

RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart Constructor

RadarChart Constructor

Creates a new instance of the RadarChart class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public RadarChart (
RadarType type
)
Visual Basic

Public Sub RadarChart ( _
type As RadarType _
)

Parameters

type
One of the RadarType enumeration values.

Remarks

This method is the RadarChart constructor and creates a new instance of the RadarChart class. Its only parameter indicates the type of the radar or polar chart. For more details about the types of radar charts that can be created, please refer to the RadarType enumeration.

The style of representing the chart data is set with the RadarStyle property and RadarStyle enumeration.

Default value for the RadarType property is RadarType.Radar2D.

See Also

RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart Methods

RadarChart Methods

Public Methods

Name | Description
ClearData | Clears any data from the chart.
ClearDataBoundLists | Clears all IList properties that support data binding.
Clone | Creates an exact copy of the current RadarChart object.
DrawChart | Calls preparatory and drawing methods according to the chart type, data and settings
HitTest | Returns the chart element at the specified position
HitTestRadar | Returns the RadarPiece at the specified location.

Protected Methods

Name | Description
CreateChart | Creates a new RadarChart object.

See Also

RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.ClearData Method

RadarChart.ClearData Method

Clears any data from the chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override void ClearData ()
Visual Basic

Public Overrides Sub ClearData ()

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.ClearDataBoundLists Method

RadarChart.ClearDataBoundLists Method

Clears all IList properties that support data binding.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override void ClearDataBoundLists ()
Visual Basic

Public Overrides Sub ClearDataBoundLists ()

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.Clone Method

RadarChart.Clone Method

Creates an exact copy of the current RadarChart object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

The cloned radar chart.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.CreateChart Method

RadarChart.CreateChart Method

Creates a new RadarChart object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

protected virtual Chart CreateChart ()
Visual Basic

Protected Overridable Function CreateChart () As Chart

Return Value

The new radar chart.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.DrawChart Method

RadarChart.DrawChart Method

Calls preparatory and drawing methods according to the chart type, data and settings

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override void DrawChart ()
Visual Basic

Public Overrides Sub DrawChart ()

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.HitTest Method

RadarChart.HitTest Method

Returns the chart element at the specified position

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override ChartElement HitTest (
int x,
int y
)
Visual Basic

Public Overrides Function HitTest ( _
x As Integer, _
y As Integer _
) As ChartElement

Parameters

x
the X - coordinate of the mouse
y
the Y - coordinate of the mouse

Return Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.HitTestRadar Method

RadarChart.HitTestRadar Method

Returns the RadarPiece at the specified location.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public RadarPiece HitTestRadar (
int x,
int y
)
Visual Basic

Public Function HitTestRadar ( _
x As Integer, _
y As Integer _
) As RadarPiece

Parameters

x
the X - coordinate of the mouse
y
the Y - coordinate of the mouse

Return Value

The RadarPiece that contains the point specified by x and y; null if none is found.

Remarks

Use the method when hit-testing radar charts. The result can be null, so always check.

See Also

HitTest
RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart Properties

RadarChart Properties

Public Properties

Name | Description
AltAxesCount | Gets or sets the count of alternative chart axes.
AltAxesPens | Specifies the collection of pens used for drawing the alternative axes.
Angles | Specifies the angles of data points in polar charts.
Background3D | Gets or sets whether the chart is drawn with 3D effect.
Data | Gets or sets the data for the chart series.
InnerAxisLabels | Gets or sets custom labels for the inner axis.
InnerAxisLabelType | Gets or sets the label type of the inner axis.
InnerAxisPen | Gets or sets the pen for drawing the inner axis.
InnerAxisPosition | Gets or sets the position of the inner axis.
InnerLabelFormat | Gets or sets the format for labels drawn at the inner axis.
LabelPrefix | Gets or sets the prefix for radar labels.
LabelSuffix | Gets or sets the suffix for labels at radar charts.
MaxValue | Gets or sets the end value at the inner axis.
MinValue | Gets or sets the start value of the inner axis.
OuterAxisLabelBackground | Gets or sets the brush that fills the border rectangle drawn around labels at the outer axis.
OuterAxisLabelBorder | Gets or sets the border drawn around outer axis labels.
OuterAxisLabelMargin | Gets or sets the space between the outer axis label and its border.
OuterAxisLabelOutline | Gets or sets the Pen that draws the border rectangle for outer axis labels.
OuterAxisLabels | Gets or sets custom labels drawn at the outer axis.
OuterAxisLabelType | Specifies the type of labels drawn at the outer axis.
OuterAxisPen | Specifies the pen for drawing the outer chart axis.
OuterLabelBackground | Gets or sets the Brush that fills the border rectangle of OuterLabels.
OuterLabelBorder | Gets or sets the border drawn around OuterLabels.
OuterLabelFormat | Gets or sets the format for labels drawn at the outer chart axis.
OuterLabelMargin | Gets or sets the space between the outer label and its border.
OuterLabelOutline | Gets or sets the Pen that draws the border rectangle for OuterLabels.
OuterLabels | Specifies the custom labels drawn at the chart segments of the outer axis.
RadarStyle | Gets or sets the style of the radar / polar chart to be drawn.
RadarType | Gets or sets the type of the radar chart to be drawn.
RadiusLength | Specifies the length of the chart radius.
SectionBrushes | Specifies the brushes for drawing the sections of the chart circle.
SectionPoints | Gets or sets the width and location of radar sections.
SegmentBrushes | Specifies the brushes for filling chart background segments.
ShapeBrushes | Specifies the brushes for filling data point shapes.
ShapePens | Specifies the pens for outlining the shapes drawn at data points.
Shapes | Specifies the shapes for data points.
ShapeSizes | Specifies the size of shapes drawn at data points.
Span | Specifies the numerical span of scale division at the inner axes.
SpiderWeb | Specifies whether the outer chart axes are drawn as circles or polygons.

See Also

RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.AltAxesCount Property

RadarChart.AltAxesCount Property

Gets or sets the count of alternative chart axes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int AltAxesCount { get; set; }
Visual Basic

Public Property AltAxesCount As Integer

Property Value

An int value that specifies the count of alternative axes.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.AltAxesPens Property

RadarChart.AltAxesPens Property

Specifies the collection of pens used for drawing the alternative axes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PenCollection AltAxesPens { get; set; }
Visual Basic

Public Property AltAxesPens As PenCollection

Property Value

An object of type MindFusion.Drawing.PenCollection. The default is an empty PenCollection.

Remarks

The property specifies the pens for drawing the alternative axes. The alternative axes are circumferences, which are concentric to the outer axes (the outlining) of the chart. If SpiderWeb is set to true, the axes are polygons.

The count of the alternative axes depends on the divisions of the inner axis. They are determined by the MinValue, MaxValue and the Span properties. If those are not set, the count is calculates based on the count of data series, added to the Data property.

No alternative axes are drawn if the AltAxesPens collection is empty. None of the alternative axes replace the outer axis, which is always drawn.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.Angles Property

RadarChart.Angles Property

Specifies the angles of data points in polar charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList Angles { get; set; }
Visual Basic

Public Property Angles As IList

Property Value

A value of type .NET IList.

Remarks

This property is used only in polar charts. In polar charts, the position of each data point is specified by the value of the point and an angle. The values are set with Data, the angles - with Angles.

The property contains lists with angles. The values must range from 0 to 360. If an angle is not in this range, it is transformed by deduction or addition of 360 as many times as necessary until it fits the interval.

In radar charts, data points are always positioned at equal angles on the inner axes. In polar charts, points can be distributed unevenly in the circle.

If a member in the Data array has no corresponding angle in the Angles array and Angles is not empty, the data point angle is considered to be 0.

If Angles are not specified and the chart type is Polar2D / Polar3D, the angles are calculated automatically as in radar charts.

Default value for the Angles property is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.Background3D Property

RadarChart.Background3D Property

Gets or sets whether the chart is drawn with 3D effect.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Color Background3D { get; set; }
Visual Basic

Public Property Background3D As Color

Property Value

A value of type .NET Color structure.

Remarks

The property specifies the color of the chart background if the RadarType is set to RadarType.Radar3D or RadarType.Polar3D.

When a 3D chart is drawn, the 3D effect is achieved by changing the color angles of the chart background. That's why no brushes are suitable for painting the background in these types of charts.

If the radar chart is 2D, you can specify different brushes and types of background. Please check the SectionBrushes, SectionPoints and SegmentBrushes properties for further details.

Default value for the Background3D property is Color.Grey.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.Data Property

RadarChart.Data Property

Gets or sets the data for the chart series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList Data { get; set; }
Visual Basic

Public Property Data As IList

Property Value

A value of type .NET IList.

Remarks

The property holds lists with data for each radar graphics. Data can be numbers or in any other format that can be parsed to numbers.

Data lists might vary in count. The count of the longest series determines the count of the inner axes. They are drawn as equally distributed radiuses.

The position of data points is calculated using the inner axis scale. The scale starts with MinValue ends with MaxValue and the length of the intervals depends on Span. If those properties are not set, the smallest and biggest Data numbers are taken as minimum and maximum scale values. The span is calculated automatically based on the count of lists in Data.

If the chart is polar, the position of the data points depends also on the value of the angle that corresponds to that point. The angles are set with Angles.

Default value for the Data property is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.InnerAxisLabels Property

RadarChart.InnerAxisLabels Property

Gets or sets custom labels for the inner axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList InnerAxisLabels { get; set; }
Visual Basic

Public Property InnerAxisLabels As IList

Property Value

A property of type .NET IList.

Remarks

The property specifies the custom labels for the inner axis. Inner labels are drawn at the scale divisions of the inner axes. The inner labels might not only be custom text, but also numbers. The InnerAxisLabelType property specifies the type of the labels.

Radar / polar charts can also have labels at radar segments and / or at the crossing points of the inner and outer axes. The type of labels is set with InnerAxisLabelType.

Default value for the InnerAxisLabels property is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.InnerAxisLabelType Property

RadarChart.InnerAxisLabelType Property

Gets or sets the label type of the inner axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public AxisLabelType InnerAxisLabelType { get; set; }
Visual Basic

Public Property InnerAxisLabelType As AxisLabelType

Property Value

One of the AxisLabelType Enumeration values.

Remarks

The property specifies the type of labels drawn at the inner chart axis. If the InnerAxisLabelType is set to AxisLabelType.CustomText, the labels are specified with InnerAxisLabels.

The format of the labels, when numbers, is set with InnerLabelFormat.

Radar / polar charts can also have labels at radar segments and / or at the crossing points of the inner and outer axes. The type of these labels is set with OuterAxisLabelType. Custom labels are set with OuterLabels and OuterAxisLabels.

Default value for the InnerAxisLabelType property is AxisLabelType.Empty.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.InnerAxisPen Property

RadarChart.InnerAxisPen Property

Gets or sets the pen for drawing the inner axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen InnerAxisPen { get; set; }
Visual Basic

Public Property InnerAxisPen As Pen

Property Value

An object of type MindFusion.Drawing.Pen.

Remarks

The property specifies the pen for drawing the inner axes of the chart. The inner axes coincide with some of the radiuses for the chart. The primary inner axes, the one that holds labels on it, is positioned as set with the InnerAxisPosition. The count of the inner axes depends on the count of elements in the longest list added to the Data property.

Only one of the inner axis has labels. The type of the labels is set with InnerAxisLabelType, custom labels are specified with InnerAxisLabels.

All inner axes are drawn with the same pen. In contrast, the outer axis is drawn with OuterAxisPen, while alternative axes, concentric to the outer one, are drawn with pens from the AltAxesPens property.

Default value for the InnerAxisPen property is a MindFusion.Drawing.Pen with black color and default width.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.InnerAxisPosition Property

RadarChart.InnerAxisPosition Property

Gets or sets the position of the inner axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Position InnerAxisPosition { get; set; }
Visual Basic

Public Property InnerAxisPosition As Position

Property Value

One of the Position Enumeration values.

Remarks

The property specifies the position of the primary inner chart axis. Each radar / polar chart can have many inner axes, which look like radiuses, equally distributed in the chart circle (polygon). The count of the inner axes depends on the count of the longest list added to the Data property.

All inner axes are drawn with the InnerAxisPen. Only one of them has labels on it and its position is specified with InnerAxisPosition.

The type of labels drawn at the inner axis is specified with InnerAxisLabelType. Custom labels are set with InnerAxisLabels.

Default value for the InnerAxisPosition property is Position.Bottom.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.InnerLabelFormat Property

RadarChart.InnerLabelFormat Property

Gets or sets the format for labels drawn at the inner axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public NumberFormat InnerLabelFormat { get; set; }
Visual Basic

Public Property InnerLabelFormat As NumberFormat

Property Value

One of the NumberFormat enumeration values.

Remarks

The property specifies the format of labels drawn at the inner axis. The InnerAxisLabelType property identifies the type of the labels at the inner axis. If the labels are custom text, use InnerAxisLabels to set them.

Inner labels are drawn at the scale division of the inner axis.

InnerAxisPosition sets the position of the inner axis. Radar charts might have many inner axes but only the one drawn at the InnerAxisPosition has labels.

Default value for the InnerLabelFormat property is NumberFormat.Fixed_point.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace
MinValue
MaxValue
Span


MindFusion.Charting.RadarChart.LabelPrefix Property

RadarChart.LabelPrefix Property

Gets or sets the prefix for radar labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string LabelPrefix { get; set; }
Visual Basic

Public Property LabelPrefix As String

Property Value

A string value.

Remarks

The property specifies a prefix drawn before each label at the inner and / or outer axis of radar charts. Prefix is not drawn when the axis has no labels or shows the auto scale.

There are no limitations as to the format or length of the prefix. You can use LabelPrefix to set unit of measure, currency mark or any other text related to your data.

Default value for the LabelPrefix property is an empty string.

See Also

InnerAxisLabelType
OuterAxisLabelType
RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.LabelSuffix Property

RadarChart.LabelSuffix Property

Gets or sets the suffix for labels at radar charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string LabelSuffix { get; set; }
Visual Basic

Public Property LabelSuffix As String

Property Value

A string.

Remarks

The property specifies a suffix drawn after each label at the inner and / or outer axis of radar charts. Suffix is not drawn when the axis has no labels or shows the auto scale.

There are no limitations as to the format or length of the suffix. You can use LabelSuffix to set unit of measure, currency mark or any other text related to your data.

Default value for the LabelSuffix property is an empty string.

See Also

InnerAxisLabelType
OuterAxisLabelType
RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.MaxValue Property

RadarChart.MaxValue Property

Gets or sets the end value at the inner axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double MaxValue { get; set; }
Visual Basic

Public Property MaxValue As Double

Property Value

A double value.

Remarks

The property specifies the end value for the inner axis. Together with MinValue and Span it is used for calculating the scale divisions of the inner axis. If max value is not set, the maximum number of all data series added to the Data property is considered.

The scale divisions can be drawn as labels at the inner axis, when the InnerAxisLabelType is set to AxisLabelType.AutoScale. The format of the numbers is set with InnerLabelFormat.

Default value for the MaxValue property is Double.NaN.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.MinValue Property

RadarChart.MinValue Property

Gets or sets the start value of the inner axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double MinValue { get; set; }
Visual Basic

Public Property MinValue As Double

Property Value

A double value.

Remarks

The property specifies the start value for the auto scale of the inner axis. Together with MaxValue and Span it is used for calculating the scale divisions of the inner axis. If MinValue is not set, the minimum number of all data series added to the Data property is considered.

The scale divisions can be drawn as labels at the inner axis, when the InnerAxisLabelType is set to AxisLabelType.AutoScale. The format of the numbers is set with InnerLabelFormat.

Default value for the MinValue property is Double.NaN.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.OuterAxisLabelBackground Property

RadarChart.OuterAxisLabelBackground Property

Gets or sets the brush that fills the border rectangle drawn around labels at the outer axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush OuterAxisLabelBackground { get; set; }
Visual Basic

Public Property OuterAxisLabelBackground As Brush

Property Value

An object of type MindFusion.Drawing.Brush class. Default is a light blue SolidBrush.

Remarks

OuterAxisLabelBorder specifies the border drawn around labels at the outer axis. The border rectangle is drawn with OuterAxisLabelOutline. The space between the label and its border is set with OuterAxisLabelMargin.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.OuterAxisLabelBorder Property

RadarChart.OuterAxisLabelBorder Property

Gets or sets the border drawn around outer axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Border OuterAxisLabelBorder { get; set; }
Visual Basic

Public Property OuterAxisLabelBorder As Border

Property Value

One of the Border Enumeration values. Default is Border.None.

Remarks

Border rectangles around labels at the outer axis are drawn with OuterAxisLabelOutline and filled with OuterAxisLabelBackground. The space between the label and its border is set with OuterAxisLabelMargin.

The type of labels drawn at the outer axis depends on OuterAxisLabelType.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace
OuterLabelBorder


MindFusion.Charting.RadarChart.OuterAxisLabelMargin Property

RadarChart.OuterAxisLabelMargin Property

Gets or sets the space between the outer axis label and its border.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float OuterAxisLabelMargin { get; set; }
Visual Basic

Public Property OuterAxisLabelMargin As Single

Property Value

A float value. Default is 5f.

Remarks

Use OuterAxisLabelBorder to specify the border type. The border rectangle is drawn with OuterAxisLabelOutline and filled with OuterAxisLabelBackground.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.OuterAxisLabelOutline Property

RadarChart.OuterAxisLabelOutline Property

Gets or sets the Pen that draws the border rectangle for outer axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen OuterAxisLabelOutline { get; set; }
Visual Basic

Public Property OuterAxisLabelOutline As Pen

Property Value

An object of type MindFusion.Drawing.Pen. Default is a black Pen, width 1.

Remarks

Use OuterAxisLabelBorder to specify the type of border drawn around labels at the outer axis. The border rectangle is filled with OuterAxisLabelBackground. The space between the label and its border is set with OuterAxisLabelMargin.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.OuterAxisLabels Property

RadarChart.OuterAxisLabels Property

Gets or sets custom labels drawn at the outer axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList OuterAxisLabels { get; set; }
Visual Basic

Public Property OuterAxisLabels As IList

Property Value

A .NET IList value that holds the labels.

Remarks

The property specifies the custom labels drawn at the outer axis.

In radar / polar charts, the outer axis is the bounding circumference (polygon) for the radar / polar. The outer axis is just one, the circles (polygons) drawn concentric to it are called alternative axes.

OuterAxisLabels specifies the labels drawn at the crossing points of the outer axis with the inner axes when the OuterAxisLabelType is set to AxisLabelType.CustomText. In polar carts the axis labels can also be the angles grades. Labels can also be drawn in the middle of the outer axis segments. They are only custom-set and are specified with OuterLabels.

The labels are drawn with LabelBrush.

Default value for the OuterAxisLabels property is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.OuterAxisLabelType Property

RadarChart.OuterAxisLabelType Property

Specifies the type of labels drawn at the outer axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public AxisLabelType OuterAxisLabelType { get; set; }
Visual Basic

Public Property OuterAxisLabelType As AxisLabelType

Property Value

One of the AxisLabelType Enumeration values.

Remarks

The property specifies the type of labels drawn at the outer chart axis. When it is set to AxisLabelType.CustomText, the labels are specified with OuterAxisLabels.

In radar / polar charts, the outer axis is the bounding circumference (polygon) for the radar / polar. The outer axis is just one, the circles (polygons) drawn concentric to it are called alternative axes.

Labels can also be drawn in the middle of the outer axis segments. They are only custom-set and are specified with OuterLabels.

AxisLabelType.ChartData is not applied for specifying the OuterAxisLabelType property. AxisLabelType.AutoScale is used only in RadarChart objects.

The labels are drawn with LabelBrush.

Default value for the OuterAxisLabelType property is AxisLabelType.Empty.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.OuterAxisPen Property

RadarChart.OuterAxisPen Property

Specifies the pen for drawing the outer chart axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen OuterAxisPen { get; set; }
Visual Basic

Public Property OuterAxisPen As Pen

Property Value

An object of type MindFusion.Drawing.Pen.

Remarks

The property specifies the pen for drawing the outer chart axis.

In radar / polar charts, the outer axis is the bounding circumference (polygon) for the radar / polar. The outer axis is just one, the circles (polygons) drawn concentric to it are called alternative axes. The shape of the outer axis - circle or polygon depends on the SpiderWeb property.

The outer axis can have two types of labels: in the middle of chart segments and / or at the crossing points with the inner axes. The properties for the labels are OuterAxisLabelType, OuterAxisLabels and OuterLabels.

Default value for the OuterAxisPen property is a Pen with black color and default width.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.OuterLabelBackground Property

RadarChart.OuterLabelBackground Property

Gets or sets the Brush that fills the border rectangle of OuterLabels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Brush OuterLabelBackground { get; set; }
Visual Basic

Public Property OuterLabelBackground As Brush

Property Value

An object of type MindFusion.Drawing.Brush class. Default is light blue SolidBrush.

Remarks

The border around OuterLabels is set with OuterLabelBorder. It is drawn with OuterLabelOutline. The space between the outer label and its border is set with OuterLabelMargin.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.OuterLabelBorder Property

RadarChart.OuterLabelBorder Property

Gets or sets the border drawn around OuterLabels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Border OuterLabelBorder { get; set; }
Visual Basic

Public Property OuterLabelBorder As Border

Property Value

One of the Border Enumeration values. Default is Border.None.

Remarks

The border rectangle of OuterLabels is drawn with OuterLabelOutline and filled with OuterLabelBackground. The space between the outer label and its border is set with OuterLabelMargin.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.OuterLabelFormat Property

RadarChart.OuterLabelFormat Property

Gets or sets the format for labels drawn at the outer chart axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public NumberFormat OuterLabelFormat { get; set; }
Visual Basic

Public Property OuterLabelFormat As NumberFormat

Property Value

One of the NumberFormat enumeration values.

Remarks

The property specifies how labels at the outer axis are formatted.

In polar charts, setting the value of the property to AxisLabelType.AutoScale draws the grads from 0 to 360. Radar charts do not use scale as outer axis.

The outer axis labels are drawn at the crossing points of the inner axes with the outer axis. Labels can also be drawn at the middle of the axes segments. Those labels are only custom text and are set with OuterLabels.

Default value for the OuterLabelFormat property is NumberFormat.Fixed_point.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace
OuterAxisLabels


MindFusion.Charting.RadarChart.OuterLabelMargin Property

RadarChart.OuterLabelMargin Property

Gets or sets the space between the outer label and its border.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float OuterLabelMargin { get; set; }
Visual Basic

Public Property OuterLabelMargin As Single

Property Value

A float value. Default is 5f.

Remarks

The border of OuterLabels is set with OuterLabelBorder. It is drawn with OuterLabelOutline and filled with OuterLabelBackground.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.OuterLabelOutline Property

RadarChart.OuterLabelOutline Property

Gets or sets the Pen that draws the border rectangle for OuterLabels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Pen OuterLabelOutline { get; set; }
Visual Basic

Public Property OuterLabelOutline As Pen

Property Value

An object of type MindFusion.Drawing.Pen. Default is a black Pen, width 1.

Remarks

Use OuterLabelBorder to specify the type of border drawn around OuterLabels. The border rectangle is filled with OuterLabelBackground. OuterLabelMargin specifies the space between the outer label and its border.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.OuterLabels Property

RadarChart.OuterLabels Property

Specifies the custom labels drawn at the chart segments of the outer axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList OuterLabels { get; set; }
Visual Basic

Public Property OuterLabels As IList

Property Value

A .NET IList property that holds the labels.

Remarks

Use the property to specify the labels, drawn at the outer segments of the radar charts. You can assign to OuterLabels the array that holds the labels or add them directly to the OuterLabels property.

In radar / polar charts, the outer axis is the bounding circumference (polygon) for the radar / polar. The outer axis is just one, the circles (polygons) drawn concentric to it are called alternative axes.

Labels can also be drawn at the crossing points of the outer axis and the inner axes. Their type is set with OuterAxisLabelType. Labels drawn at the inner axis are specified with InnerAXisLabelType and InnerAxisLabels properties.

Default value for the OuterLabels property is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.RadarStyle Property

RadarChart.RadarStyle Property

Gets or sets the style of the radar / polar chart to be drawn.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public RadarStyle RadarStyle { get; set; }
Visual Basic

Public Property RadarStyle As RadarStyle

Property Value

One of the RadarStyle enumeration values.

Remarks

RadarStyle property specifies the drawing style for both radar and polar charts. The RadarStyle enumeration members allow bitwise combination for more styles, for example, you can draw radar lines with shapes at data points.

The type of the chart is set with RadarType.

All charts are drawn with pens and brushes from the ChartPens and ChartBrushes property. The data for the chart is set with Data and, for polar charts, Angles.

Default value for the RadarStyle property is RadarStyle.Lines.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace
SpiderWeb


MindFusion.Charting.RadarChart.RadarType Property

RadarChart.RadarType Property

Gets or sets the type of the radar chart to be drawn.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public RadarType RadarType { get; set; }
Visual Basic

Public Property RadarType As RadarType

Property Value

One of the RadarType enumeration values.

Remarks

The property specifies whether the chart is radar or polar and if it is 2D or 3D. When using MindFusion.Charting programmatically, the initial RadarType is specified in the constructor.

The drawing style of the chart - lines, arcs and so on, is specified with RadarStyle.

All charts are drawn with pens and brushes from the ChartPens and ChartBrushes property. The data for the chart is set with Data and, for polar charts, Angles.

Default value for the RadarType property is RadarType.Radar2D.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace
SpiderWeb


MindFusion.Charting.RadarChart.RadiusLength Property

RadarChart.RadiusLength Property

Specifies the length of the chart radius.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public float RadiusLength { get; set; }
Visual Basic

Public Property RadiusLength As Single

Property Value

A float value that represents the radius.

Remarks

The property specifies the size of the radius of the chart. When the chart is 3D, the size remains intact, which the 3D look is achieved only graphically.

The property is valid also for charts that draw their outer axes as polygons. This is set when the SpiderWeb property is set to true.

Default value for the radius length is 100f.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.SectionBrushes Property

RadarChart.SectionBrushes Property

Specifies the brushes for drawing the sections of the chart circle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection SectionBrushes { get; set; }
Visual Basic

Public Property SectionBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

The property specifies the brushes for drawing background sections. The sections are circles (polygons) concentric to the outer axis. The outer axis is the chart bounding circumference (polygon).

The positions of the sections are calculated based on the SectionPoints property. Its values should range from 0 to 100.

When the brushes are less than the count of sections, MindFusion.Charting cycles through them again. The brushes follow the order of setting the section points - brushes for the bigger sections should be added last.

The sections are drawn as polygons when SpiderWeb is set to true.

Alternatively, the chart background can be drawn as differently colored segments. Use SegmentBrushes to specify the brushes for that.

Background is drawn when any of the SectionBrushes or SegmentBrushes is not an empty collection. If both are specified, the background is drawn in sections.

Default value for the SectionBrushes property is an empty BrushCollection.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.SectionPoints Property

RadarChart.SectionPoints Property

Gets or sets the width and location of radar sections.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList SectionPoints { get; set; }
Visual Basic

Public Property SectionPoints As IList

Property Value

A .NET IList value that holds the section positions. The values should range from 0 to 100.

Remarks

The property specifies the positions of chart background sections. The sections are circles (polygons) concentric to the outer axis. The outer axis is the chart bounding circumference (polygon).

The positions of the sections are calculated relatively to the length of the chart radius.

The sections are filled with brushes from the SectionBrushes property. When the brushes are less than the count of sections, MindFusion.Charting cycles through them again. The brushes follow the order of setting the section points - brushes for the bigger sections should be added last.

The sections are drawn as polygons when SpiderWeb is set to true.

Alternatively, the chart background can be drawn as differently colored segments. Use SegmentBrushes to specify the brushes for that.

Background is drawn when any of the SectionBrushes or SegmentBrushes is not an empty collection. If both are specified, the background is drawn in sections.

Default value for the SectionPoints property is an empty IList.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.SegmentBrushes Property

RadarChart.SegmentBrushes Property

Specifies the brushes for filling chart background segments.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection SegmentBrushes { get; set; }
Visual Basic

Public Property SegmentBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

The property specifies the brushes for drawing the segments of the chart circle. A segment is a rectangular-like area between two inner axes. The inner axes are radiuses, distributed equally inside the chart. They start from the InnerAxisPosition of the inner chart. The count of the inner axes, thus chart segments, depends on the count of elements in the longest list added to Data.

When the sections are more than the segment brushes, the control cycles again through the brushes.

The segments are triangles, when the chart outer axes are drawn as spider web, in this case SpiderWeb is set to true.

Default value for the SegmentBrushes property is an empty BrushCollection.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.ShapeBrushes Property

RadarChart.ShapeBrushes Property

Specifies the brushes for filling data point shapes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public BrushCollection ShapeBrushes { get; set; }
Visual Basic

Public Property ShapeBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

Use the property to specify the brushes for filling shapes, drawn at data points. Shapes are drawn when the RadarStyle property is set to RadarStyle.Points.

Each Data series can be drawn with different shapes, which have different width. Add the desired Shape member and size to the Shapes and ShapeSizes property - lists. The shapes are drawn with pens from ShapePens.

When the ShapeBrushes are less than the count of data series added to the Data property, MindFusion.Charting cycles through them.

Default value for the ShapeBrushes property is an empty BrushCollection.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.ShapePens Property

RadarChart.ShapePens Property

Specifies the pens for outlining the shapes drawn at data points.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public PenCollection ShapePens { get; set; }
Visual Basic

Public Property ShapePens As PenCollection

Property Value

An object of type MindFusion.Drawing.PenCollection.

Remarks

Use the property to specify the pens for outlining the shapes, drawn at data points. Shapes are drawn when the RadarStyle property is set to RadarStyle.Points.

Each Data series can be drawn with different shapes, which have different width. Add the desired Shape member and size to the Shapes and ShapeSizes property - lists. The shapes are filled with brushes from the ShapeBrushes property. When the ShapePens are less than the count of data series added to the Data property, MindFusion.Charting cycles through them.

Default value for the ShapePens property is an empty PenCollection.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.Shapes Property

RadarChart.Shapes Property

Specifies the shapes for data points.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList Shapes { get; set; }
Visual Basic

Public Property Shapes As IList

Property Value

A .NET IList with Shape Enumeration values that specify the shape type.

Remarks

Use the property to specify the shapes, drawn at data points. Shapes are drawn when the RadarStyle property is set to RadarStyle.Points.

Each Data series can be drawn with different shapes, which have different width. Add the desired Shape member and size to the Shapes and ShapeSizes lists.

The shapes are drawn with pens from ShapePens and are filled with brushes from ShapeBrushes.

Default value for the Shapes property is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.ShapeSizes Property

RadarChart.ShapeSizes Property

Specifies the size of shapes drawn at data points.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public IList ShapeSizes { get; set; }
Visual Basic

Public Property ShapeSizes As IList

Property Value

A .NET IList with float values that represent the sizes.

Remarks

Use the property to specify the size of shapes drawn at data points. Shapes are drawn when the RadarStyle property is set to RadarStyle.Points.

Each Data series can be drawn with different shapes, which have different width. Add the desired Shape member to the Shapes property.

The shapes are drawn with pens and brushes from ShapePens and ShapeBrushes properties.

When the numbers in ShapeSizes are less than the count of data series added to the Data property, MindFusion.Charting cycles through them.

Default value for the ShapeSizes property is an empty list. If no shape is set, the shapes are drawn with width 10.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.Span Property

RadarChart.Span Property

Specifies the numerical span of scale division at the inner axes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double Span { get; set; }
Visual Basic

Public Property Span As Double

Property Value

A double value.

Remarks

The property specifies the span between scale divisions at the inner chart axes. The start and end values of the inner axis scale are set with MinValue and MaxValue.

The inner axis is one of the chart radiuses. Its position is specified with InnerAxisPosition.

The chart has as many inner axes as the count of elements in the longest series added to Data is. Only the axis at InnerAxisPosition has labels.

When the InnerAxisLabelType is set to AxisLabelType.AutoScale, the scale divisions are drawn. They are formatted with InnerLabelFormat.

Default value for the Span property is Double.NaN.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarChart.SpiderWeb Property

RadarChart.SpiderWeb Property

Specifies whether the outer chart axes are drawn as circles or polygons.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool SpiderWeb { get; set; }
Visual Basic

Public Property SpiderWeb As Boolean

Property Value

A bool value.

Remarks

The property specifies the shape of the outer and alternative axes - circle or polygon. The outer axis is the chart bounding circle, where the chart graphics are located. When SpiderWeb is true, the outer axes are drawn as a polygon.

The outer axis is only one and is the biggest circle (polygon). It is drawn with OuterAxisPen. The circles (polygons) drawn concentric to the outer axis are called alternative axes and are drawn with AltAxesPens.

The count of the alternative axes depends on the scale divisions of the inner axis.

Default value for the SpiderWeb property is false.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPiece Class

RadarPiece Class
Remarks See Also

A class that represents radar piece objects in radar charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public sealed class RadarPiece : ChartElement
Visual Basic

Public NotInheritable Class RadarPiece
Inherits ChartElement

Remarks

Each radar piece in a radar chart is an instance of the RadarPiece class. When the user clicks on a radar piece in hit-testing, the RadarPiece object that contains the hitted mouse point is returned.

The members of the RadarPiece class are read-only. Use the respective radar piece properties of the RadarPiece class to set them.

Inheritance Hierarchy

System.Object
MindFusion.Charting.ChartElement
MindFusion.Charting.RadarPiece

See Also

RadarPiece Members
MindFusion.Charting Namespace


MindFusion.Charting.RadarPiece Members

RadarPiece Members
Constructors Properties

A class that represents radar piece objects in radar charts.

The following tables list the members exposed by the RadarPiece type.

Public Constructors

Name | Description
RadarPiece | Creates a new instance of the RadarPiece class.

Public Properties

Name | Description
AxisLabel | Gets the axis label drawn at this RadarPiece.
OuterLabel | Gets the outer label drawn at this RadarPiece.
Value | Gets the value that this RadarPiece represents.

See Also

RadarPiece Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPiece Constructor

RadarPiece Constructor

Creates a new instance of the RadarPiece class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public RadarPiece ()
Visual Basic

Public Sub New ()

See Also

RadarPiece Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPiece Properties

RadarPiece Properties

Public Properties

Name | Description
AxisLabel | Gets the axis label drawn at this RadarPiece.
OuterLabel | Gets the outer label drawn at this RadarPiece.
Value | Gets the value that this RadarPiece represents.

See Also

RadarPiece Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPiece.AxisLabel Property

RadarPiece.AxisLabel Property

Gets the axis label drawn at this RadarPiece.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string AxisLabel { get; }
Visual Basic

Public ReadOnly Property AxisLabel As String

Property Value

A string that represents the label.

Remarks

The label at the axis for each RadarPiece depends on the value of OuterAxisLabelType. Custom labels are set with OuterAxisLabels.

See Also

RadarPiece Members
RadarPiece Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPiece.OuterLabel Property

RadarPiece.OuterLabel Property

Gets the outer label drawn at this RadarPiece.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string OuterLabel { get; }
Visual Basic

Public ReadOnly Property OuterLabel As String

Property Value

A string that represents the outer label for this RadarPiece.

Remarks

Use OuterLabels to specifies the text drawn in the middle of each segment in radar charts.

See Also

RadarPiece Members
RadarPiece Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPiece.Value Property

RadarPiece.Value Property

Gets the value that this RadarPiece represents.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double Value { get; }
Visual Basic

Public ReadOnly Property Value As Double

Property Value

A double number.

Remarks

The property gets the value of the hitted piece. If the hitted point is covered by several radar charts, the topmost is returned.

See Also

RadarPiece Members
RadarPiece Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarStyle Enumeration

RadarStyle Enumeration

Specifies the drawing styles for a radar chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum RadarStyle
Visual Basic

Public Enumeration RadarStyle

Members

Member name | Description
Arcs | The chart is drawn with arcs that connect the data points.
Lines | The chart is drawn with lines that connect the data points.
Points | The chart is drawn with points that mark the position of each chart value.

Remarks

The Enumeration represents the different styles of radar charts that can be drawn with arcs, lines or points. The style of a radar chart is specified with the RadarStyle property. The members of the enumeration allow bitwise combination, for example you can draw lines with points.

The chart graphics is drawn with pens and brushes set with ChartPens and ChartBrushes. When shapes at data points are drawn their type is set with Shapes. The pens and brushes for them are specified with ShapePens and ShapeBrushes.

The type of the radar chart is set with the RadarType property and the RadarType enumeration.
By default the RadarStyle property is set to RadarStyle.Lines.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.RadarType Enumeration

RadarType Enumeration

Specifies the different types of radar charts that can be drawn.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum RadarType
Visual Basic

Public Enumeration RadarType

Members

Member name | Description
Polar2D | 2D polar chart. The position of each data point is specified by an angle and a numerical value.
Polar3D | 3D polar chart. Each data point is specified by an angle and a numerical value.
Radar2D | A 2D radar chart. The position of each data point is specified by a numerical value.
Radar3D | A 3D radar chart. The position of each data point is specified by a numerical value.

Remarks

The enumeration represents the different types of radar charts that can be drawn. The type of a radar chart is specified with the RadarType property. The drawing style of the chart is specified with RadarStyle.

Data for the chart is set with Data. The angles of data points in polar charts are specified with Angles.

MindFusion.Charting parses all data automatically. All data types are allowed - integers, doubles and so on.

3D charts are drawn by changing the light angle for the chart background. The color of the background is set with Background3D property. No background brushes are used.

The drawing style of a radar / polar chart is specified by the RadarStyle property.

Default value for the RadarType property is RadarType.Radar2D.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.Scatter Class

Scatter Class
Remarks See Also

A class that represents scatter objects in scatter charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public class Scatter : ChartElement
Visual Basic

Public Class Scatter
Inherits ChartElement

Remarks

Instances of the Scatter class are returned by the HitTestScatter and HitTest methods. If HitTest is used, the result should be cast to Scatter. Use the Label and Value properties to recognize the scatter being hit.

Inheritance Hierarchy

System.Object
MindFusion.Charting.ChartElement
MindFusion.Charting.Scatter

See Also

Scatter Members
MindFusion.Charting Namespace


MindFusion.Charting.Scatter Members

Scatter Members
Constructors Properties

A class that represents scatter objects in scatter charts.

The following tables list the members exposed by the Scatter type.

Public Constructors

Name | Description
Scatter | Initializes a new instance of the Scatter class.

Public Properties

Name | Description
Label | Gets the label drawn at this Scatter.
Value | Gets the value that this Scatter represents.

See Also

Scatter Class
MindFusion.Charting Namespace


MindFusion.Charting.Scatter Constructor

Scatter Constructor

Initializes a new instance of the Scatter class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Scatter ()
Visual Basic

Public Sub New ()

Remarks

All Scatter properties are initialized with its default values.

See Also

Scatter Class
MindFusion.Charting Namespace


MindFusion.Charting.Scatter Properties

Scatter Properties

Public Properties

Name | Description
Label | Gets the label drawn at this Scatter.
Value | Gets the value that this Scatter represents.

See Also

Scatter Class
MindFusion.Charting Namespace


MindFusion.Charting.Scatter.Label Property

Scatter.Label Property

Gets the label drawn at this Scatter.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string Label { get; }
Visual Basic

Public ReadOnly Property Label As String

Property Value

A string value that represents the label.

Remarks

The text of the Scatter depends on LabelType. Custom labels are set with Labels.

See Also

Scatter Members
Scatter Class
MindFusion.Charting Namespace


MindFusion.Charting.Scatter.Value Property

Scatter.Value Property

Gets the value that this Scatter represents.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public double Value { get; }
Visual Basic

Public ReadOnly Property Value As Double

Property Value

A double number that represents the value of the Scatter.

Remarks

The number corresponds to the number set for this Scatter through the XData property for horizontal charts or YData for vertical charts.

See Also

Scatter Members
Scatter Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection Class

SeriesCollection Class
Remarks See Also

Represents a list with DoubleCollection-s for specifying the data in multi-series charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public class SeriesCollection : CollectionBase, ICloneable
Visual Basic

Public Class SeriesCollection
Inherits CollectionBase
Implements ICloneable

Remarks

Objects of the SeriesCollection class are used for specifying the data in multi-series charts. They hold objects of type DoubleCollection that represent the numbers in a single series.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Charting.SeriesCollection

See Also

SeriesCollection Members
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection Members

SeriesCollection Members
Constructors Properties Methods

Represents a list with DoubleCollection-s for specifying the data in multi-series charts.

The following tables list the members exposed by the SeriesCollection type.

Public Constructors

Name | Description
SeriesCollection | Overloaded. Initializes a new instance of the SeriesCollection class.

Public Properties

Name | Description
Item | Gets or sets the element at the specified index.

Public Methods

Name | Description
Add | Adds a new DoubleCollection object to the collection.
Clone | Creates a copy of the current collection.
Compare | Compares the current SeriesCollection to another collection.
Contains | Checks whether a particular DoubleCollection object is contained within the current collection.
GetValues | Returns an array with all DoubleCollection objects in the collection.
IndexOf | Returns the index of the first occurrence of the specified DoubleCollection.
Insert | Inserts the specified DoubleCollection object in the specified position.
Remove | Removes the first occurrence of the specified DoubleCollection object.
RemoveAt | Removes the DoubleCollection object at the specified index.

See Also

SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection Constructor

SeriesCollection Constructor

Initializes a new instance of the SeriesCollection class.

Overload List

Name | Description
SeriesCollection () | Initializes a new instance of the SeriesCollection class.
SeriesCollection (DoubleCollection[]) | Initializes a new instance of the SeriesCollection class.
SeriesCollection (IList) | Initializes a new instance of the SeriesCollection class.
SeriesCollection (String) | Initializes a new instance of the SeriesCollection class.

See Also

SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection Constructor ()

SeriesCollection Constructor ()
See Also

Initializes a new instance of the SeriesCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public SeriesCollection ()
Visual Basic

Public Sub New ()

See Also

SeriesCollection Constructor Overload List
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection Constructor (DoubleCollection[])

SeriesCollection Constructor (DoubleCollection[])
See Also

Initializes a new instance of the SeriesCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public SeriesCollection (
DoubleCollection[] values
)
Visual Basic

Public Sub SeriesCollection ( _
values As DoubleCollection() _
)

Parameters

values
An array with the initial DoubleCollection objects for the collection.

See Also

SeriesCollection Constructor Overload List
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection Constructor (IList)

SeriesCollection Constructor (IList)
See Also

Initializes a new instance of the SeriesCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public SeriesCollection (
IList arrays
)
Visual Basic

Public New ( _
arrays As IList _
)

Parameters

arrays
A collection with the initial DoubleCollection objects of the collection.

See Also

SeriesCollection Constructor Overload List
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection Constructor (String)

SeriesCollection Constructor (String)
See Also

Initializes a new instance of the SeriesCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public SeriesCollection (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation
A string, which contains the numbers in all DoubleCollection objects in this collection.

See Also

SeriesCollection Constructor Overload List
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection Methods

SeriesCollection Methods

Public Methods

Name | Description
Add | Adds a new DoubleCollection object to the collection.
Clone | Creates a copy of the current collection.
Compare | Compares the current SeriesCollection to another collection.
Contains | Checks whether a particular DoubleCollection object is contained within the current collection.
GetValues | Returns an array with all DoubleCollection objects in the collection.
IndexOf | Returns the index of the first occurrence of the specified DoubleCollection.
Insert | Inserts the specified DoubleCollection object in the specified position.
Remove | Removes the first occurrence of the specified DoubleCollection object.
RemoveAt | Removes the DoubleCollection object at the specified index.

See Also

SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection.Add Method

SeriesCollection.Add Method

Adds a new DoubleCollection object to the collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int Add (
DoubleCollection value
)
Visual Basic

Public Function Add ( _
value As DoubleCollection _
) As Integer

Parameters

value
The DoubleCollection object to be added.

Return Value

The position into which the new DoubleCollection object was added.

See Also

SeriesCollection Members
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection.Clone Method

SeriesCollection.Clone Method

Creates a copy of the current collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

An object of type SeriesCollection, identical to the current collection.

See Also

SeriesCollection Members
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection.Compare Method

SeriesCollection.Compare Method

Compares the current SeriesCollection to another collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool Compare (
IList values
)
Visual Basic

Public Function Compare ( _
values As IList _
) As Boolean

Parameters

values
The collection to compare.

Return Value

true if values is identical to the current collection; otherwise false.

See Also

SeriesCollection Members
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection.Contains Method

SeriesCollection.Contains Method

Checks whether a particular DoubleCollection object is contained within the current collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool Contains (
DoubleCollection value
)
Visual Basic

Public Function Contains ( _
value As DoubleCollection _
) As Boolean

Parameters

value
The DoubleCollection to search for.

Return Value

true if value is contained within the collection; otherwise false.

See Also

SeriesCollection Members
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection.GetValues Method

SeriesCollection.GetValues Method

Returns an array with all DoubleCollection objects in the collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public DoubleCollection[] GetValues ()
Visual Basic

Public Function GetValues () As DoubleCollection()

Return Value

An array with all DoubleCollection objects in this collection.

See Also

SeriesCollection Members
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection.IndexOf Method

SeriesCollection.IndexOf Method

Returns the index of the first occurrence of the specified DoubleCollection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int IndexOf (
DoubleCollection value
)
Visual Basic

Public Function IndexOf ( _
value As DoubleCollection _
) As Integer

Parameters

value
The DoubleCollection to search for.

Return Value

The index of the first occurrence of the DoubleCollection; -1 if not found.

See Also

SeriesCollection Members
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection.Insert Method

SeriesCollection.Insert Method

Inserts the specified DoubleCollection object in the specified position.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void Insert (
int index,
DoubleCollection value
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
value As DoubleCollection _
)

Parameters

index

The zero-based index at which value should be inserted.

value

The DoubleCollection object to insert.

Remarks

The collection's count is increased with 1. The items, which followed the inserted item, are moved backwards with one place. Their indexes are also updated.

See Also

SeriesCollection Members
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection.Remove Method

SeriesCollection.Remove Method

Removes the first occurrence of the specified DoubleCollection object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void Remove (
DoubleCollection value
)
Visual Basic

Public Sub Remove ( _
value As DoubleCollection _
)

Parameters

value
The DoubleCollection object to remove.

Remarks

The collection's count is reduced with 1. The items, which followed the removed item, are moved forwards with one place. Their indexes are also updated.

See Also

SeriesCollection Members
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection.RemoveAt Method

SeriesCollection.RemoveAt Method

Removes the DoubleCollection object at the specified index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public new void RemoveAt (
int index
)
Visual Basic

Public Shadows Sub RemoveAt ( _
index As Integer _
)

Parameters

index
The zero-based index, at which the DoubleCollection object should be removed.

Remarks

The collection's count is reduced with 1. The items, which followed the removed item, are moved forwards with one place. Their indexes are also updated.

See Also

SeriesCollection Members
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection Properties

SeriesCollection Properties

Public Properties

Name | Description
Item | Gets or sets the element at the specified index.

See Also

SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesCollection.Item Property

SeriesCollection.Item Property

Gets or sets the element at the specified index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public DoubleCollection Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As DoubleCollection

Parameters

index
The zero-based index of the element to get or set.

Property Value

The element at the specified index.

Remarks

This property provides the ability to access a specific element in the collection.

See Also

SeriesCollection Members
SeriesCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.Shape Enumeration

Shape Enumeration

Specifies the type of shapes that can be drawn at chart data points.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum Shape
Visual Basic

Public Enumeration Shape

Members

Member name | Description
Circle | The shape is drawn as a circle.
Rhombus | The shape is drawn as a rhombus.
Square | The shape is drawn as a square.
Triangle | The shape is drawn as a triangle.

Remarks

The Enumeration specifies the type of geometrical figure drawn at data intersection points. Currently it is used in scatter and radar charts.

In line charts, the LineType should be set to LineTypes.Scatter. It can be combined with any other type of line chart. Multi-series line charts can have different point shapes for each line. See the Shapes property for more details. The point shapes for summary lines and Y2 graphics are set with SummaryShapes and Y2Shapes.

Shapes can be drawn at data points in radar/polar charts also. The RadarStyle property should be set to RadarStyle.Points. Each series can also have a different shape.

The shapes are drawn with pens and brushes as set with ShapePens and ShapeBrushes property. The size of each shape is given by the ShapeSizes property.

See Also

MindFusion.Charting Namespace
LineChart.ShapeBrushes
LineChart.ShapePens
LineChart.ShapeSizes
RadarChart.ShapeBrushes
RadarChart.ShapePens
RadarChart.ShapeSizes


MindFusion.Charting.ShapeCollection Class

ShapeCollection Class

Represents a strongly typed collection of shapes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public class ShapeCollection : CollectionBase, ICloneable
Visual Basic

Public Class ShapeCollection
Inherits CollectionBase
Implements ICloneable

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Charting.ShapeCollection

See Also

ShapeCollection Members
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection Members

ShapeCollection Members
Constructors Properties Methods

Represents a strongly typed collection of shapes.

The following tables list the members exposed by the ShapeCollection type.

Public Constructors

Name | Description
ShapeCollection | Overloaded. Initializes a new instance of the ShapeCollection class.

Public Properties

Name | Description
Item | Gets or sets the Shape object, located at the specified position.

Public Methods

Name | Description
Add | Adds the specified Shape object to the ShapeCollection.
Clone | Creates an exact copy of this ShapeCollection.
Contains | Checks whether the specified Shape is contained in the ShapeCollection.
GetValues | Returns an array containing the shapes of this ShapeCollection.
IndexOf | Returns the index of the first occurrence of the specified Shape object.
Insert | Inserts the specified Shape object at the specified position within the collection.
Remove | Removes the first occurrence of the specified Shape object from the collection.
RemoveAt | Removes the Shape object at the specified index.

See Also

ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection Constructor

ShapeCollection Constructor

Initializes a new instance of the ShapeCollection class.

Overload List

Name | Description
ShapeCollection () | Initializes a new instance of the ShapeCollection class.
ShapeCollection (ICollection) | Initializes a new instance of the ShapeCollection class with the specified initial values.
ShapeCollection (Shape[]) | Initializes a new instance of the ShapeCollection class with the specified initial values.
ShapeCollection (String) | Initializes a new instance of the ShapeCollection class.

See Also

ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection Constructor ()

ShapeCollection Constructor ()
See Also

Initializes a new instance of the ShapeCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public ShapeCollection ()
Visual Basic

Public Sub New ()

See Also

ShapeCollection Constructor Overload List
ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection Constructor (ICollection)

ShapeCollection Constructor (ICollection)
See Also

Initializes a new instance of the ShapeCollection class with the specified initial values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public ShapeCollection (
ICollection values
)
Visual Basic

Public New ( _
values As ICollection _
)

Parameters

values
A collection with the initial ShapeCollection objects of the collection.

See Also

ShapeCollection Constructor Overload List
ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection Constructor (Shape[])

ShapeCollection Constructor (Shape[])
See Also

Initializes a new instance of the ShapeCollection class with the specified initial values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public ShapeCollection (
Shape[] values
)
Visual Basic

Public New ( _
values() As Shape _
)

Parameters

values
An array with the initial ShapeCollection objects for the collection.

See Also

ShapeCollection Constructor Overload List
ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection Constructor (String)

ShapeCollection Constructor (String)
See Also

Initializes a new instance of the ShapeCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public ShapeCollection (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation
The string identifier of the new ShapeCollection.

See Also

ShapeCollection Constructor Overload List
ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection Methods

ShapeCollection Methods

Public Methods

Name | Description
Add | Adds the specified Shape object to the ShapeCollection.
Clone | Creates an exact copy of this ShapeCollection.
Contains | Checks whether the specified Shape is contained in the ShapeCollection.
GetValues | Returns an array containing the shapes of this ShapeCollection.
IndexOf | Returns the index of the first occurrence of the specified Shape object.
Insert | Inserts the specified Shape object at the specified position within the collection.
Remove | Removes the first occurrence of the specified Shape object from the collection.
RemoveAt | Removes the Shape object at the specified index.

See Also

ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection.Add Method

ShapeCollection.Add Method

Adds the specified Shape object to the ShapeCollection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int Add (
Shape value
)
Visual Basic

Public Function Add ( _
value As Shape _
) As Integer

Parameters

value
The Shape object to add to the ShapeCollection.

Return Value

The zero-based index within the collection of the newly added shape.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection.Clone Method

ShapeCollection.Clone Method

Creates an exact copy of this ShapeCollection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

An instance of the ShapeCollection class representing the newly created clone.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection.Contains Method

ShapeCollection.Contains Method

Checks whether the specified Shape is contained in the ShapeCollection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool Contains (
Shape value
)
Visual Basic

Public Function Contains ( _
value As Shape _
) As Boolean

Parameters

value
The Shape to search for.

Return Value

true if value is contained within the collection; otherwise false.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection.GetValues Method

ShapeCollection.GetValues Method

Returns an array containing the shapes of this ShapeCollection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Shape[] GetValues ()
Visual Basic

Public Function GetValues () As Shape()

Return Value

A Shape[] array with all shapes contained in the current ShapeCollection instance.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection.IndexOf Method

ShapeCollection.IndexOf Method

Returns the index of the first occurrence of the specified Shape object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int IndexOf (
Shape value
)
Visual Basic

Public Function IndexOf ( _
value As Shape _
) As Integer

Parameters

value
The Shape to search for.

Return Value

The index of the first occurrence of the shape in the ShapeCollection; -1 if not found.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection.Insert Method

ShapeCollection.Insert Method

Inserts the specified Shape object at the specified position within the collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void Insert (
int index,
Shape value
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
value As Shape _
)

Parameters

index
The zero-based index at which value should be inserted.
value
The Shape object to insert.

Remarks

The collection's count is increased with 1. The items, which followed the inserted item, are moved backwards with one place. Their indexes are also updated.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection.Remove Method

ShapeCollection.Remove Method

Removes the first occurrence of the specified Shape object from the collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void Remove (
Shape value
)
Visual Basic

Public Sub Remove ( _
value As Shape _
)

Parameters

value
The Shape object to remove from the ShapeCollection.

Remarks

The collection's count is reduced with 1. The items, which followed the removed item, are moved forwards with one place. Their indexes are also updated.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection.RemoveAt Method

ShapeCollection.RemoveAt Method

Removes the Shape object at the specified index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public new void RemoveAt (
int index
)
Visual Basic

Public Shadows Sub RemoveAt ( _
index As Integer _
)

Parameters

index
The zero-based index of the shape to remove.

Remarks

The collection's count is reduced with 1. The items, which followed the removed item, are moved forwards with one place. Their indexes are also updated.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection Properties

ShapeCollection Properties

Public Properties

Name | Description
Item | Gets or sets the Shape object, located at the specified position.

See Also

ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeCollection.Item Property

ShapeCollection.Item Property

Gets or sets the Shape object, located at the specified position.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public Shape Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Shape

Parameters

index
The zero-based index of the element to get or set.

Property Value

The element at the specified index.

Remarks

In C#, this property is the indexer of the collection.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeConverter Class

ShapeConverter Class

Provides an EnumConverter to convert Shape objects to and from various other representations.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public class ShapeConverter : EnumConverter
Visual Basic

Public Class ShapeConverter
Inherits EnumConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.EnumConverter
MindFusion.Charting.ShapeConverter

See Also

ShapeConverter Members
MindFusion.Charting Namespace


MindFusion.Charting.ShapeConverter Members

ShapeConverter Members
Constructors Methods

Provides an EnumConverter to convert Shape objects to and from various other representations.

The following tables list the members exposed by the ShapeConverter type.

Public Constructors

Name | Description
ShapeConverter | Initializes a new instance of the ShapeConverter class.

Public Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.
CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Converts the particular object to the type of this converter, using the specified context and culture information.
ConvertTo | Converts the particular value object to the specified type, using the specified context and culture information.

See Also

ShapeConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeConverter Constructor

ShapeConverter Constructor

Initializes a new instance of the ShapeConverter class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public ShapeConverter (
Type enumType
)
Visual Basic

Public New ( _
enumType As Type _
)

Parameters

enumType
An instance of the .NET Type class specifying the ShapeConverter class.

See Also

ShapeConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeConverter Methods

ShapeConverter Methods

Public Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.
CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Converts the particular object to the type of this converter, using the specified context and culture information.
ConvertTo | Converts the particular value object to the specified type, using the specified context and culture information.

See Also

ShapeConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeConverter.CanConvertFrom Method

ShapeConverter.CanConvertFrom Method

Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)
Visual Basic

Public Overrides Function CanConvertFrom ( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context
An ITypeDescriptorContext that provides a format context.
sourceType
A .NET Type that represents the type to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

Remarks

This method returns true only if sourceType is equal to typeof(string).

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeConverter.CanConvertTo Method

ShapeConverter.CanConvertTo Method

Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)
Visual Basic

Public Overrides Function CanConvertTo ( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
destinationType
A .NET Type that represents the type to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Remarks

This method returns true only if destinationType is equal to typeof(string).

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeConverter.ConvertFrom Method

ShapeConverter.ConvertFrom Method

Converts the particular object to the type of this converter, using the specified context and culture information.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)
Visual Basic

Public Overrides Function ConvertFrom ( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
culture
The .NET CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

An Object that represents the converted value.

Remarks

As implemented in this class, the method returns a Shape.

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.ShapeConverter.ConvertTo Method

ShapeConverter.ConvertTo Method

Converts the particular value object to the specified type, using the specified context and culture information.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)
Visual Basic

Public Overrides Function ConvertTo ( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
culture
A .NET CultureInfo object.
value
The Object to convert.
destinationType
The Type to convert the value parameter to.

Return Value

An Object that represents the converted value.

Remarks

As implemented by this class, the method returns a .NET InstanceDescriptor or string, according to destinationType.

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.SortOrder Enumeration

SortOrder Enumeration

Specifies different options for sorting numbers in data series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum SortOrder
Visual Basic

Public Enumeration SortOrder

Members

Member name | Description
Ascending | The numbers are sorted in ascending order.
Descending | The numbers are sorted in descending order.
None | The numbers are not sorted.

Remarks

The Enumeration specifies how individual numbers in the data series are sorted. The sorting is performed on each number compared to the other numbers in the same series. This sorting is different from SortSeriesBy, where the whole lists are sorted and compared to each other.

The sorting can be applied on all data properties - XData, YData and Data. When any of the data lists is rearranged, the labels lists are rearranged in the same order.

The property that sets / gets the sorting in the charts is called SortOrder.

See Also

MindFusion.Charting Namespace
XLabels
YLabels
Y2Labels
BarChart.Data
PieChart.Data
RadarChart.Data


MindFusion.Charting.SortSeriesBy Enumeration

SortSeriesBy Enumeration

Specifies how charts with more than one data series are arranged.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum SortSeriesBy
Visual Basic

Public Enumeration SortSeriesBy

Members

Member name | Description
MaxValue | The maximum value of the numbers in the chart data determines the order of drawing the series.
Nothing | No sorting of the chart series is made and the segments are drawn in such order as the lists with numerical data have been added to the XData / YData or Y2Data properties.
Sum | The sum of the numbers in each series list determines the order of drawing for this series.

Remarks

The enumeration specifies how series lists for charts are sorted. When charts are drawn it is possible that one segment covers partly or entirely another one. That is why it is useful to specify a method for arranging the parts so that a maximum part of each one is visible.

Sorting series by sum is useful when the series lists are equal in count. Otherwise, it is more reasonable to sort the series by their maximum value.

See Also

MindFusion.Charting Namespace
Chart.SortSeriesBy


MindFusion.Charting.StringCollection Class

StringCollection Class
Remarks See Also

Represents a collection with string labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public class StringCollection : CollectionBase
Visual Basic

Public Class StringCollection
Inherits CollectionBase

Remarks

Objects of the StringCollection class are used for specifying the labels in properties of type simple array, which members are strings. In properties fo type complex array, which members are simple arrays, they represent the label series, which are added to the LabelsCollection object.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Charting.StringCollection

See Also

StringCollection Members
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection Members

StringCollection Members
Constructors Properties Methods

Represents a collection with string labels.

The following tables list the members exposed by the StringCollection type.

Public Constructors

Name | Description
StringCollection | Overloaded. Initializes a new instance of the StringCollection class.

Public Properties

Name | Description
Item | Gets or sets the element at the specified index.

Public Methods

Name | Description
Add | Adds a new label to the StringCollection.
Compare | Compares a list to the current StringCollection.
Contains | Checks whether the StringCollection contains the specified label.
GetValues | Returns an array with all labels in the StringCollection.
IndexOf | Returns the index of the first occurrence of the specified label.
Insert | Inserts the specified label in the specified position.
Remove | Removes the first occurrence of the specified label.
RemoveAt | Removes the label at the specified index.
ToString | Returns a string representation of the collection.

See Also

StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection Constructor

StringCollection Constructor

Initializes a new instance of the StringCollection class.

Overload List

Name | Description
StringCollection () | Initializes a new instance of the StringCollection class.
StringCollection (ICollection) | Initializes a new instance of the StringCollection class.
StringCollection (String) | Initializes a new instance of the StringCollection class.
StringCollection (String[]) | Initializes a new instance of the StringCollection class.

See Also

StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection Constructor ()

StringCollection Constructor ()
See Also

Initializes a new instance of the StringCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public StringCollection ()
Visual Basic

Public Sub New ()

See Also

StringCollection Constructor Overload List
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection Constructor (ICollection)

StringCollection Constructor (ICollection)
See Also

Initializes a new instance of the StringCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public StringCollection (
ICollection values
)
Visual Basic

Public New ( _
values As ICollection _
)

Parameters

values
An instance of type .NET ICollection, which contains the initial labels for the collection.

See Also

StringCollection Constructor Overload List
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection Constructor (String)

StringCollection Constructor (String)
See Also

Initializes a new instance of the StringCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public StringCollection (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation
A string, which contains the labels for the collection, separated by commas (,).

See Also

StringCollection Constructor Overload List
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection Constructor (String[])

StringCollection Constructor (String[])
See Also

Initializes a new instance of the StringCollection class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public StringCollection (
string[] values
)
Visual Basic

Public New ( _
values() As String _
)

Parameters

values
An array with the initial labels of the collection.

See Also

StringCollection Constructor Overload List
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection Methods

StringCollection Methods

Public Methods

Name | Description
Add | Adds a new label to the StringCollection.
Compare | Compares a list to the current StringCollection.
Contains | Checks whether the StringCollection contains the specified label.
GetValues | Returns an array with all labels in the StringCollection.
IndexOf | Returns the index of the first occurrence of the specified label.
Insert | Inserts the specified label in the specified position.
Remove | Removes the first occurrence of the specified label.
RemoveAt | Removes the label at the specified index.
ToString | Returns a string representation of the collection.

See Also

StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection.Add Method

StringCollection.Add Method

Adds a new label to the StringCollection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int Add (
string value
)
Visual Basic

Public Function Add ( _
value As String _
) As Integer

Parameters

value
The new label to add.

Return Value

The position into which the new label was added.

See Also

StringCollection Members
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection.Compare Method

StringCollection.Compare Method

Compares a list to the current StringCollection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool Compare (
IList values
)
Visual Basic

Public Function Compare ( _
values As IList _
) As Boolean

Parameters

values
An object of type .NET IList, which is compared to the current collection.

Return Value

true if the collections are equal; otherwise false.

See Also

StringCollection Members
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection.Contains Method

StringCollection.Contains Method

Checks whether the StringCollection contains the specified label.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public bool Contains (
string value
)
Visual Basic

Public Function Contains ( _
value As String _
) As Boolean

Parameters

value
The label to check.

Return Value

true if value is contained within the collection; otherwise false.

See Also

StringCollection Members
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection.GetValues Method

StringCollection.GetValues Method

Returns an array with all labels in the StringCollection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string[] GetValues ()
Visual Basic

Public Function GetValues () As String()

Return Value

A string[] array with all labels contained in the current StringCollection instance.

See Also

StringCollection Members
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection.IndexOf Method

StringCollection.IndexOf Method

Returns the index of the first occurrence of the specified label.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public int IndexOf (
string value
)
Visual Basic

Public Function IndexOf ( _
value As String _
) As Integer

Parameters

value
the label to search for.

Return Value

The index of the first occurrence of value; -1 if not found.

See Also

StringCollection Members
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection.Insert Method

StringCollection.Insert Method

Inserts the specified label in the specified position.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void Insert (
int index,
string value
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
value As String _
)

Parameters

index
The zero-based index at which value should be inserted.
value
The label to insert.

Remarks

The collection's count is increased with 1. The items, which followed the inserted item, are moved backwards with one place. Their indexes are also updated.

See Also

StringCollection Members
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection.Remove Method

StringCollection.Remove Method

Removes the first occurrence of the specified label.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public void Remove (
string value
)
Visual Basic

Public Sub Remove ( _
value As String _
)

Parameters

value

The label to remove.

Remarks

The collection's count is reduced with 1. The items, which followed the removed item, are moved forwards with one place. Their indexes are also updated.

See Also

StringCollection Members
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection.RemoveAt Method

StringCollection.RemoveAt Method

Removes the label at the specified index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public new void RemoveAt (
int index
)
Visual Basic

Public Shadows Sub RemoveAt ( _
index As Integer _
)

Parameters

index
The zero-based index, at which the label should be removed.

Remarks

The collection's count is reduced with 1. The items, which followed the removed item, are moved forwards with one place. Their indexes are also updated.

See Also

StringCollection Members
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection.ToString Method

StringCollection.ToString Method

Returns a string representation of the collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string that represents the collection.

Remarks

The string represents the labels in the collection, separated by commas.

See Also

StringCollection Members
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection Properties

StringCollection Properties

Public Properties

Name | Description
Item | Gets or sets the element at the specified index.

See Also

StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.StringCollection.Item Property

StringCollection.Item Property

Gets or sets the element at the specified index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public string Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As String

Parameters

index
The zero-based index of the element to get or set.

Property Value

The element at the specified index.

Remarks

In C#, this property is the indexer of the collection.

See Also

StringCollection Members
StringCollection Class
MindFusion.Charting Namespace


MindFusion.Charting.Summary Enumeration

Summary Enumeration

Specifies type of summary operations that can be performed over the chart values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C#

public enum Summary
Visual Basic

Public Enumeration Summary

Members

Member name | Description
Average | The summary is calculated as the average value of all data values.
Max | The summary is calculated as the maximum value of all data values.
Min | The summary is calculated as the minimum value of all data values.
None | No summary is calculated.
Sum | The summary is calculated as the sum of all data values.

Remarks

The Enumeration represents the aggregate operations that could be performed over the chart data values. The operation is performed on all values, that means, for values given in more than one liat, the summary value is calculated on all of them.

The calculation is on the values of the X-axis for horizontal line charts and on values at the Y-axis for vertical ones. In bar charts, it is always performed on Data.

In order to specify summary operations for a given chart, you should add the chosen Summary members to the SummaryValues property. The chart parts for the summary values are drawn with pens and brushes set with the SummaryPens and SummaryBrushes properties.

The AddCustomSummary method enables you to add custom summaries.

See Also

MindFusion.Charting Namespace
Horizontal
XData
YData
Data


MindFusion.Charting.Design Namespace
Classes

Classes

Class | Description
DoubleCollectionConverter | Provides a type converter for DoubleCollection types.
LabelsCollectionConverter | Provides a type converter for LabelsCollection types.
LabelsCollectionEditor | Provides a user interface that can edit the LabelsCollection objects at design time.
LabelsCollectionForm | Provides a modal dialog box for editing the contents of a LabelsCollection using the LabelsCollectionEditor.
NoEditor | Provides a user interface that can edit collection objects at design time.
SeriesCollectionConverter | Provides a type converter for SeriesCollection types.
SeriesCollectionEditor | Design-time editor for SeriesCollection objects.
SeriesCollectionForm | Provides a modal dialog box for editing the contents of a SeriesCollection using the SeriesCollectionEditor.
ShapeCollectionConverter | Provides a type converter for ShapeCollection types.
ShapeCollectionEditor | Editor for editing Shape collections at design time.
ShapeCollectionForm | A form used to edit ShapeCollection objects at design-time.
StringCollectionConverter | Provides a type converter for StringCollection types.


MindFusion.Charting.Design.DoubleCollectionConverter Class

DoubleCollectionConverter Class
Remarks See Also

Provides a type converter for DoubleCollection types.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public class DoubleCollectionConverter : TypeConverter
Visual Basic

Public Class DoubleCollectionConverter
Inherits TypeConverter

Remarks

This class is for internal use only.

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Charting.Design.DoubleCollectionConverter

See Also

DoubleCollectionConverter Members
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.DoubleCollectionConverter Members

DoubleCollectionConverter Members
Constructors Methods

Provides a type converter for DoubleCollection types.

The following tables list the members exposed by the DoubleCollectionConverter type.

Public Constructors

Name | Description
DoubleCollectionConverter | Initializes a new instance of the DoubleCollectionConverter class.

Public Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.
CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Converts the particular object to the type of this converter, using the specified context and culture information.
ConvertTo | Converts the particular value object to the specified type, using the specified context and culture information.

See Also

DoubleCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.DoubleCollectionConverter Constructor

DoubleCollectionConverter Constructor

Initializes a new instance of the DoubleCollectionConverter class.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public DoubleCollectionConverter ()
Visual Basic

Public Sub New ()

Remarks

This is the default constructor and it initializes any fields to their default values.

See Also

DoubleCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.DoubleCollectionConverter Methods

DoubleCollectionConverter Methods

Public Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.
CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Converts the particular object to the type of this converter, using the specified context and culture information.
ConvertTo | Converts the particular value object to the specified type, using the specified context and culture information.

See Also

DoubleCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.DoubleCollectionConverter.CanConvertFrom Method

DoubleCollectionConverter.CanConvertFrom Method

Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type t
)
Visual Basic

Public Overrides Function CanConvertFrom ( _
context As ITypeDescriptorContext, _
t As Type _
) As Boolean

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
t

A .NET Type that represents the type to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

Remarks

As implemented in this class, this method returns true if t is type of string. Otherwise it returns false.

See Also

DoubleCollectionConverter Members
DoubleCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.DoubleCollectionConverter.CanConvertTo Method

DoubleCollectionConverter.CanConvertTo Method

Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destType
)
Visual Basic

Public Overrides Function CanConvertTo ( _
context As ITypeDescriptorContext, _
destType As Type _
) As Boolean

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
destType
A .NET Type that represents the type to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Remarks

As implemented in this class, the method returns true if destType is of type .NET InstanceDescriptor or string.

See Also

DoubleCollectionConverter Members
DoubleCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.DoubleCollectionConverter.ConvertFrom Method

DoubleCollectionConverter.ConvertFrom Method

Converts the particular object to the type of this converter, using the specified context and culture information.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo info,
Object value
)
Visual Basic

Public Overrides Function ConvertFrom ( _
context As ITypeDescriptorContext, _
info As CultureInfo, _
value As Object _
) As Object

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
info
The .NET CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

An Object that represents the converted value.

Remarks

As implemented in this class, the method returns a DoubleCollection.

See Also

DoubleCollectionConverter Members
DoubleCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.DoubleCollectionConverter.ConvertTo Method

DoubleCollectionConverter.ConvertTo Method

Converts the particular value object to the specified type, using the specified context and culture information.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo info,
Object value,
Type destType
)
Visual Basic

Public Overrides Function ConvertTo ( _
context As ITypeDescriptorContext, _
info As CultureInfo, _
value As Object, _
destType As Type _
) As Object

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
info
A .NET CultureInfo object.
value
The Object to convert.
destType
The Type to convert the value parameter to.

Return Value

An Object that represents the converted value.

Remarks

As implemented by this class, the method returns a .NET InstanceDescriptor or string, according to destType.

See Also

DoubleCollectionConverter Members
DoubleCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionConverter Class

LabelsCollectionConverter Class
Remarks See Also

Provides a type converter for LabelsCollection types.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public class LabelsCollectionConverter : ExpandableObjectConverter
Visual Basic

Public Class LabelsCollectionConverter
Inherits ExpandableObjectConverter

Remarks

This class is for internal use only.

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.ExpandableObjectConverter
MindFusion.Charting.Design.LabelsCollectionConverter

See Also

LabelsCollectionConverter Members
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionConverter Members

LabelsCollectionConverter Members
Constructors Methods

Provides a type converter for LabelsCollection types.

The following tables list the members exposed by the LabelsCollectionConverter type.

Public Constructors

Name | Description
LabelsCollectionConverter | Initializes a new instance of the LabelsCollectionConverter class.

Public Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.
CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Converts the particular object to the type of this converter, using the specified context and culture information.
ConvertTo | Converts the particular value object to the specified type, using the specified context and culture information.
GetProperties | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

See Also

LabelsCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionConverter Constructor

LabelsCollectionConverter Constructor

Initializes a new instance of the LabelsCollectionConverter class.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public LabelsCollectionConverter ()
Visual Basic

Public Sub New ()

Remarks

This is the default constructor and it initializes any fields to their default values.

See Also

LabelsCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionConverter Methods

LabelsCollectionConverter Methods

Public Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.
CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Converts the particular object to the type of this converter, using the specified context and culture information.
ConvertTo | Converts the particular value object to the specified type, using the specified context and culture information.
GetProperties | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

See Also

LabelsCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionConverter.CanConvertFrom Method

LabelsCollectionConverter.CanConvertFrom Method

Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type t
)
Visual Basic

Public Overrides Function CanConvertFrom ( _
context As ITypeDescriptorContext, _
t As Type _
) As Boolean

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
t
A .NET Type that represents the type to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

Remarks

As implemented in this class, this method returns true if t is of string type. Otherwise it returns false.

See Also

LabelsCollectionConverter Members
LabelsCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionConverter.CanConvertTo Method

LabelsCollectionConverter.CanConvertTo Method

Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destType
)
Visual Basic

Public Overrides Function CanConvertTo ( _
context As ITypeDescriptorContext, _
destType As Type _
) As Boolean

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
destType
A .NET Type that represents the type to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Remarks

As implemented in this class, the method returns true if destType is of type .NET InstanceDescriptor or string.

See Also

LabelsCollectionConverter Members
LabelsCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionConverter.ConvertFrom Method

LabelsCollectionConverter.ConvertFrom Method

Converts the particular object to the type of this converter, using the specified context and culture information.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo info,
Object value
)
Visual Basic

Public Overrides Function ConvertFrom ( _
context As ITypeDescriptorContext, _
info As CultureInfo, _
value As Object _
) As Object

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
info
The .NET CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

An Object that represents the converted value.

See Also

LabelsCollectionConverter Members
LabelsCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionConverter.ConvertTo Method

LabelsCollectionConverter.ConvertTo Method

Converts the particular value object to the specified type, using the specified context and culture information.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo info,
Object value,
Type destType
)
Visual Basic

Public Overrides Function ConvertTo ( _
context As ITypeDescriptorContext, _
info As CultureInfo, _
value As Object, _
destType As Type _
) As Object

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
info
A .NET CultureInfo object.
value
The Object to convert.
destType
The .NET Type to convert the value parameter to.

Return Value

An Object that represents the converted value.

Remarks

As implemented by this class, the method returns a .NET InstanceDescriptor or string, according to destType.

See Also

LabelsCollectionConverter Members
LabelsCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionConverter.GetProperties Method

LabelsCollectionConverter.GetProperties Method

Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override PropertyDescriptorCollection GetProperties (
ITypeDescriptorContext context,
Object value,
Attribute[] attributes
)
Visual Basic

Public Overrides Function GetProperties ( _
context As ITypeDescriptorContext, _
value As Object, _
attributes() As Attribute _
) As PropertyDescriptorCollection

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
value
An Object that specifies the type of array for which to get properties.
attributes
An array of type Attribute that is used as a filter.

Return Value

A PropertyDescriptorCollection with the properties that are exposed for this data type.

Remarks

As implemented in this class, this method returns a PropertyDescriptorCollection with the properties that are exposed for LabelsCollection.

See Also

LabelsCollectionConverter Members
LabelsCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionEditor Class

LabelsCollectionEditor Class
Remarks See Also

Provides a user interface that can edit the LabelsCollection objects at design time.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public class LabelsCollectionEditor : UITypeEditor
Visual Basic

Public Class LabelsCollectionEditor
Inherits UITypeEditor

Remarks

This class is for internal use only.

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
MindFusion.Charting.Design.LabelsCollectionEditor

See Also

LabelsCollectionEditor Members
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionEditor Members

LabelsCollectionEditor Members
Constructors Methods

Provides a user interface that can edit the LabelsCollection objects at design time.

The following tables list the members exposed by the LabelsCollectionEditor type.

Public Constructors

Name | Description
LabelsCollectionEditor | Initializes a new instance of the LabelsCollectionEditor class.

Public Methods

Name | Description
EditValue | Edits the value of the specified LabelsCollection using the specified service provider and context.
GetEditStyle | Gets the edit style used by the EditValue method.
GetPaintValueSupported | Indicates whether the specified context supports painting a representation of the LabelsCollection's value within the specified context.

See Also

LabelsCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionEditor Constructor

LabelsCollectionEditor Constructor

Initializes a new instance of the LabelsCollectionEditor class.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public LabelsCollectionEditor ()
Visual Basic

Public Sub New ()

See Also

LabelsCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionEditor Methods

LabelsCollectionEditor Methods

Public Methods

Name | Description
EditValue | Edits the value of the specified LabelsCollection using the specified service provider and context.
GetEditStyle | Gets the edit style used by the EditValue method.
GetPaintValueSupported | Indicates whether the specified context supports painting a representation of the LabelsCollection's value within the specified context.

See Also

LabelsCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionEditor.EditValue Method

LabelsCollectionEditor.EditValue Method

Edits the value of the specified LabelsCollection using the specified service provider and context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override Object EditValue (
ITypeDescriptorContext context,
IServiceProvider provider,
Object value
)
Visual Basic

Public Overrides Function EditValue ( _
context As ITypeDescriptorContext, _
provider As IServiceProvider, _
value As Object _
) As Object

Parameters

context
A .NET ITypeDescriptorContext that can be used to gain additional context information.
provider
A .NET service provider object through which editing services can be obtained.
value
The LabelsCollection to edit the value of.

Return Value

The new value of the LabelsCollection. If the value of the LabelsCollection has not changed, the method returns the same collection it was passed.

See Also

LabelsCollectionEditor Members
LabelsCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionEditor.GetEditStyle Method

LabelsCollectionEditor.GetEditStyle Method

Gets the edit style used by the EditValue method.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override UITypeEditorEditStyle GetEditStyle (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetEditStyle ( _
context As ITypeDescriptorContext _
) As UITypeEditorEditStyle

Parameters

context
A .NET ITypeDescriptorContext that can be used to gain additional context information.

Return Value

.NET UITypeEditorEditStyle enumeration value indicating the provided editing style. As implemented by this class, the return value is UITypeEditorEditStyle.Modal.

See Also

LabelsCollectionEditor Members
LabelsCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionEditor.GetPaintValueSupported Method

LabelsCollectionEditor.GetPaintValueSupported Method

Indicates whether the specified context supports painting a representation of the LabelsCollection's value within the specified context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override bool GetPaintValueSupported (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetPaintValueSupported ( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context
A .NET ITypeDescriptorContext that can be used to gain additional context information.

Return Value

true if .NET PaintValue method is implemented; otherwise, false. The return value, as implemented in this class, is always false.

See Also

LabelsCollectionEditor Members
LabelsCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionForm Class

LabelsCollectionForm Class
Remarks See Also

Provides a modal dialog box for editing the contents of a LabelsCollection using the LabelsCollectionEditor.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public class LabelsCollectionForm : Form
Visual Basic

Public Class LabelsCollectionForm
Inherits Form

Remarks

This class is for internal use only.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
MindFusion.Charting.Design.LabelsCollectionForm

See Also

LabelsCollectionForm Members
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionForm Members

LabelsCollectionForm Members
Constructors Properties Methods

Provides a modal dialog box for editing the contents of a LabelsCollection using the LabelsCollectionEditor.

The following tables list the members exposed by the LabelsCollectionForm type.

Public Constructors

Name | Description
LabelsCollectionForm | Initializes a new instance of the LabelsCollectionForm class.

Public Properties

Name | Description
Collection | Gets or sets the LabelsCollection to be edited in the LabelsCollectionForm.

Protected Methods

Name | Description
Dispose | Disposes the LabelsCollectionForm.

See Also

LabelsCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionForm Constructor

LabelsCollectionForm Constructor

Initializes a new instance of the LabelsCollectionForm class.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public LabelsCollectionForm ()
Visual Basic

Public Sub New ()

See Also

LabelsCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionForm Methods

LabelsCollectionForm Methods

Protected Methods

Name | Description
Dispose | Disposes the LabelsCollectionForm.

See Also

LabelsCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionForm.Dispose Method

LabelsCollectionForm.Dispose Method

Disposes the LabelsCollectionForm.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true, if the LabelsCollection form is in process of disposing; otherwise false.

See Also

LabelsCollectionForm Members
LabelsCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionForm Properties

LabelsCollectionForm Properties

Public Properties

Name | Description
Collection | Gets or sets the LabelsCollection to be edited in the LabelsCollectionForm.

See Also

LabelsCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.LabelsCollectionForm.Collection Property

LabelsCollectionForm.Collection Property

Gets or sets the LabelsCollection to be edited in the LabelsCollectionForm.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public LabelsCollection Collection { get; set; }
Visual Basic

Public Property Collection As LabelsCollection

Property Value

An object of type LabelsCollection to be edited.

See Also

LabelsCollectionForm Members
LabelsCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.NoEditor Class

NoEditor Class

Provides a user interface that can edit collection objects at design time.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public class NoEditor : UITypeEditor
Visual Basic

Public Class NoEditor
Inherits UITypeEditor

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
MindFusion.Charting.Design.NoEditor

See Also

NoEditor Members
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.NoEditor Members

NoEditor Members
Constructors Methods

Provides a user interface that can edit collection objects at design time.

The following tables list the members exposed by the NoEditor type.

Public Constructors

Name | Description
NoEditor | Initializes a new instance of the NoEditor class.

Public Methods

Name | Description
GetEditStyle | Gets the edit style for this editor.

See Also

NoEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.NoEditor Constructor

NoEditor Constructor

Initializes a new instance of the NoEditor class.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public NoEditor ()
Visual Basic

Public Sub New ()

See Also

NoEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.NoEditor Methods

NoEditor Methods

Public Methods

Name | Description
GetEditStyle | Gets the edit style for this editor.

See Also

NoEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.NoEditor.GetEditStyle Method

NoEditor.GetEditStyle Method

Gets the edit style for this editor.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override UITypeEditorEditStyle GetEditStyle (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetEditStyle ( _
context As ITypeDescriptorContext _
) As UITypeEditorEditStyle

Parameters

context
A .NET ITypeDescriptorContext that can be used to gain additional context information.

Return Value

NET UITypeEditorEditStyle enumeration value indicating the provided editing style. As implemented by this class, the return value is UITypeEditorEditStyle.None.

See Also

NoEditor Members
NoEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionConverter Class

SeriesCollectionConverter Class
Remarks See Also

Provides a type converter for SeriesCollection types.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public class SeriesCollectionConverter : ExpandableObjectConverter
Visual Basic

Public Class SeriesCollectionConverter
Inherits ExpandableObjectConverter

Remarks

This class is for internal use only.

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.ExpandableObjectConverter
MindFusion.Charting.Design.SeriesCollectionConverter

See Also

SeriesCollectionConverter Members
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionConverter Members

SeriesCollectionConverter Members
Constructors Methods

Provides a type converter for SeriesCollection types.

The following tables list the members exposed by the SeriesCollectionConverter type.

Public Constructors

Name | Description
SeriesCollectionConverter | Initializes a new instance of the SeriesCollectionConverter class.

Public Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.
CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Converts the particular object to the type of this converter, using the specified context and culture information.
ConvertTo | Converts the particular value object to the specified type, using the specified context and culture information.
GetProperties | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

See Also

SeriesCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionConverter Constructor

SeriesCollectionConverter Constructor

Initializes a new instance of the SeriesCollectionConverter class.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public SeriesCollectionConverter ()
Visual Basic

Public Sub New ()

Remarks

This is the default constructor and it initializes any fields to their default values.

See Also

SeriesCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionConverter Methods

SeriesCollectionConverter Methods

Public Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.
CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Converts the particular object to the type of this converter, using the specified context and culture information.
ConvertTo | Converts the particular value object to the specified type, using the specified context and culture information.
GetProperties | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

See Also

SeriesCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionConverter.CanConvertFrom Method

SeriesCollectionConverter.CanConvertFrom Method

Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type t
)
Visual Basic

Public Overrides Function CanConvertFrom ( _
context As ITypeDescriptorContext, _
t As Type _
) As Boolean

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
t
A .NET Type that represents the type to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

Remarks

As implemented in this class, this method returns true if t is type of string. Otherwise it returns false.

See Also

SeriesCollectionConverter Members
SeriesCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionConverter.CanConvertTo Method

SeriesCollectionConverter.CanConvertTo Method

Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destType
)
Visual Basic

Public Overrides Function CanConvertTo ( _
context As ITypeDescriptorContext, _
destType As Type _
) As Boolean

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
destType
A .NET Type that represents the type to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Remarks

As implemented in this class, the method returns true if destType is of type .NET InstanceDescriptor or string.

See Also

SeriesCollectionConverter Members
SeriesCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionConverter.ConvertFrom Method

SeriesCollectionConverter.ConvertFrom Method

Converts the particular object to the type of this converter, using the specified context and culture information.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo info,
Object value
)
Visual Basic

Public Overrides Function ConvertFrom ( _
context As ITypeDescriptorContext, _
info As CultureInfo, _
value As Object _
) As Object

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
info
The .NET CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

An Object that represents the converted value.

See Also

SeriesCollectionConverter Members
SeriesCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionConverter.ConvertTo Method

SeriesCollectionConverter.ConvertTo Method

Converts the particular value object to the specified type, using the specified context and culture information.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo info,
Object value,
Type destType
)
Visual Basic

Public Overrides Function ConvertTo ( _
context As ITypeDescriptorContext, _
info As CultureInfo, _
value As Object, _
destType As Type _
) As Object

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
info
A .NET CultureInfo object.
value
The Object to convert.
destType
The Type to convert the value parameter to.

Return Value

An Object that represents the converted value.

Remarks

As implemented by this class, the method returns a .NET InstanceDescriptor or string, according to destType.

See Also

SeriesCollectionConverter Members
SeriesCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionConverter.GetProperties Method

SeriesCollectionConverter.GetProperties Method

Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override PropertyDescriptorCollection GetProperties (
ITypeDescriptorContext context,
Object value,
Attribute[] attributes
)
Visual Basic

Public Overrides Function GetProperties ( _
context As ITypeDescriptorContext, _
value As Object, _
attributes() As Attribute _
) As PropertyDescriptorCollection

Parameters

context
An ITypeDescriptorContext that provides a format context.
value

An Object that specifies the type of array for which to get properties.

attributes
An array of type Attribute that is used as a filter.

Return Value

A PropertyDescriptorCollection with the properties that are exposed for this data type.

Remarks

As implemented in this class, this method returns a PropertyDescriptorCollection with the properties that are exposed for SeriesCollection.

See Also

SeriesCollectionConverter Members
SeriesCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionEditor Class

SeriesCollectionEditor Class
Remarks See Also

Design-time editor for SeriesCollection objects.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public class SeriesCollectionEditor : UITypeEditor
Visual Basic

Public Class SeriesCollectionEditor
Inherits UITypeEditor

Remarks

This class is for internal use only.

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
MindFusion.Charting.Design.SeriesCollectionEditor

See Also

SeriesCollectionEditor Members
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionEditor Members

SeriesCollectionEditor Members
Constructors Methods

Design-time editor for SeriesCollection objects.

The following tables list the members exposed by the SeriesCollectionEditor type.

Public Constructors

Name | Description
SeriesCollectionEditor |

Public Methods

Name | Description
EditValue | Edits the value of the specified SeriesCollection using the specified service provider and context.
GetEditStyle | Gets the edit style used by the EditValue method.
GetPaintValueSupported | Indicates whether the specified context supports painting a representation of the SeriesCollection's value within the specified context.

See Also

SeriesCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionEditor Constructor

SeriesCollectionEditor Constructor

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public SeriesCollectionEditor ()
Visual Basic

Public Sub New ()

See Also

SeriesCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionEditor Methods

SeriesCollectionEditor Methods

Public Methods

Name | Description
EditValue | Edits the value of the specified SeriesCollection using the specified service provider and context.
GetEditStyle | Gets the edit style used by the EditValue method.
GetPaintValueSupported | Indicates whether the specified context supports painting a representation of the SeriesCollection's value within the specified context.

See Also

SeriesCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionEditor.EditValue Method

SeriesCollectionEditor.EditValue Method

Edits the value of the specified SeriesCollection using the specified service provider and context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override Object EditValue (
ITypeDescriptorContext context,
IServiceProvider provider,
Object value
)
Visual Basic

Public Overrides Function EditValue ( _
context As ITypeDescriptorContext, _
provider As IServiceProvider, _
value As Object _
) As Object

Parameters

context

A .NET ITypeDescriptorContext that can be used to gain additional context information.

provider

A .NET service provider object through which editing services can be obtained.

value
The SeriesCollection to edit the value of.

Return Value

The new value of the SeriesCollection. If the value of the SeriesCollection has not changed, the method returns the same collection it was passed.

See Also

SeriesCollectionEditor Members
SeriesCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionEditor.GetEditStyle Method

SeriesCollectionEditor.GetEditStyle Method

Gets the edit style used by the EditValue method.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override UITypeEditorEditStyle GetEditStyle (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetEditStyle ( _
context As ITypeDescriptorContext _
) As UITypeEditorEditStyle

Parameters

context

A .NET ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A .NET UITypeEditorEditStyle enumeration value indicating the provided editing style. As implemented by this class, the return value is UITypeEditorEditStyle.Modal.

See Also

SeriesCollectionEditor Members
SeriesCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionEditor.GetPaintValueSupported Method

SeriesCollectionEditor.GetPaintValueSupported Method

Indicates whether the specified context supports painting a representation of the SeriesCollection's value within the specified context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override bool GetPaintValueSupported (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetPaintValueSupported ( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context

A .NET ITypeDescriptorContext that can be used to gain additional context information.

Return Value

true if .NET PaintValue method is implemented; otherwise, false. The return value, as implemented in this class, is always false.

See Also

SeriesCollectionEditor Members
SeriesCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionForm Class

SeriesCollectionForm Class
Remarks See Also

Provides a modal dialog box for editing the contents of a SeriesCollection using the SeriesCollectionEditor.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public class SeriesCollectionForm : Form
Visual Basic

Public Class SeriesCollectionForm
Inherits Form

Remarks

This class is for internal use only.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
MindFusion.Charting.Design.SeriesCollectionForm

See Also

SeriesCollectionForm Members
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionForm Members

SeriesCollectionForm Members
Constructors Properties Methods

Provides a modal dialog box for editing the contents of a SeriesCollection using the SeriesCollectionEditor.

The following tables list the members exposed by the SeriesCollectionForm type.

Public Constructors

Name | Description
SeriesCollectionForm | nitializes a new instance of the SeriesCollectionForm class.

Public Properties

Name | Description
Collection | Gets or sets the SeriesCollection to be edited in the SeriesCollectionForm.

Protected Methods

Name | Description
Dispose | Disposes the SeriesCollectionForm.

See Also

SeriesCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionForm Constructor

SeriesCollectionForm Constructor

nitializes a new instance of the SeriesCollectionForm class.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public SeriesCollectionForm ()
Visual Basic

Public Sub New ()

See Also

SeriesCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionForm Methods

SeriesCollectionForm Methods

Protected Methods

Name | Description
Dispose | Disposes the SeriesCollectionForm.

See Also

SeriesCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionForm.Dispose Method

SeriesCollectionForm.Dispose Method

Disposes the SeriesCollectionForm.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing

true, if the SeriesCollectionForm is in process of disposing; otherwise false.

See Also

SeriesCollectionForm Members
SeriesCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionForm Properties

SeriesCollectionForm Properties

Public Properties

Name | Description
Collection | Gets or sets the SeriesCollection to be edited in the SeriesCollectionForm.

See Also

SeriesCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.SeriesCollectionForm.Collection Property

SeriesCollectionForm.Collection Property

Gets or sets the SeriesCollection to be edited in the SeriesCollectionForm.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public SeriesCollection Collection { get; set; }
Visual Basic

Public Property Collection As SeriesCollection

Property Value

An object of type SeriesCollection to be edited.

See Also

SeriesCollectionForm Members
SeriesCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionConverter Class

ShapeCollectionConverter Class
Remarks See Also

Provides a type converter for ShapeCollection types.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public class ShapeCollectionConverter : ExpandableObjectConverter
Visual Basic

Public Class ShapeCollectionConverter
Inherits ExpandableObjectConverter

Remarks

This class is for internal use only.

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.ExpandableObjectConverter
MindFusion.Charting.Design.ShapeCollectionConverter

See Also

ShapeCollectionConverter Members
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionConverter Members

ShapeCollectionConverter Members
Constructors Methods

Provides a type converter for ShapeCollection types.

The following tables list the members exposed by the ShapeCollectionConverter type.

Public Constructors

Name | Description
ShapeCollectionConverter | Initializes a new instance of the ShapeCollectionConverter class.

Public Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.
CanConvertTo | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Converts the particular object to the type of this converter, using the specified context and culture information.
ConvertTo | Converts the particular value object to the specified type, using the specified context and culture information.
GetProperties | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

See Also

ShapeCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionConverter Constructor

ShapeCollectionConverter Constructor

Initializes a new instance of the ShapeCollectionConverter class.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public ShapeCollectionConverter ()
Visual Basic

Public Sub New ()

See Also

ShapeCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionConverter Methods

ShapeCollectionConverter Methods

Public Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.
CanConvertTo | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Converts the particular object to the type of this converter, using the specified context and culture information.
ConvertTo | Converts the particular value object to the specified type, using the specified context and culture information.
GetProperties | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

See Also

ShapeCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionConverter.CanConvertFrom Method

ShapeCollectionConverter.CanConvertFrom Method

Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type t
)
Visual Basic

Public Overrides Function CanConvertFrom ( _
context As ITypeDescriptorContext, _
t As Type _
) As Boolean

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
t
A .NET Type that represents the type to convert from.

Return Value

A .NET Type that represents the type to convert from.

See Also

ShapeCollectionConverter Members
ShapeCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionConverter.CanConvertTo Method

ShapeCollectionConverter.CanConvertTo Method

Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destType
)
Visual Basic

Public Overrides Function CanConvertTo ( _
context As ITypeDescriptorContext, _
destType As Type _
) As Boolean

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
destType
A .NET Type that represents the type to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Remarks

As implemented in this class, the method returns true if destType is of type .NET InstanceDescriptor or string.

See Also

ShapeCollectionConverter Members
ShapeCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionConverter.ConvertFrom Method

ShapeCollectionConverter.ConvertFrom Method

Converts the particular object to the type of this converter, using the specified context and culture information.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo info,
Object value
)
Visual Basic

Public Overrides Function ConvertFrom ( _
context As ITypeDescriptorContext, _
info As CultureInfo, _
value As Object _
) As Object

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
info
The .NET CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

An Object that represents the converted value.

See Also

ShapeCollectionConverter Members
ShapeCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionConverter.ConvertTo Method

ShapeCollectionConverter.ConvertTo Method

Converts the particular value object to the specified type, using the specified context and culture information.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo info,
Object value,
Type destType
)
Visual Basic

Public Overrides Function ConvertTo ( _
context As ITypeDescriptorContext, _
info As CultureInfo, _
value As Object, _
destType As Type _
) As Object

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
info
A .NET CultureInfo object.
value
The Object to convert.
destType
The Type to convert the value parameter to.

Return Value

An Object that represents the converted value.

Remarks

As implemented by this class, the method returns a .NET InstanceDescriptor or string, according to destType.

See Also

ShapeCollectionConverter Members
ShapeCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionConverter.GetProperties Method

ShapeCollectionConverter.GetProperties Method

Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override PropertyDescriptorCollection GetProperties (
ITypeDescriptorContext context,
Object value,
Attribute[] attributes
)
Visual Basic

Public Overrides Function GetProperties ( _
context As ITypeDescriptorContext, _
value As Object, _
attributes() As Attribute _
) As PropertyDescriptorCollection

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
value
An Object that specifies the type of array for which to get properties.
attributes
An array of type Attribute that is used as a filter.

Return Value

A PropertyDescriptorCollection with the properties that are exposed for this data type.

Remarks

As implemented in this class, this method returns a PropertyDescriptorCollection with the properties that are exposed for ShapeCollection.

See Also

ShapeCollectionConverter Members
ShapeCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionEditor Class

ShapeCollectionEditor Class

Editor for editing Shape collections at design time.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public class ShapeCollectionEditor : CollectionEditor
Visual Basic

Public Class ShapeCollectionEditor
Inherits CollectionEditor

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
System.ComponentModel.Design.CollectionEditor
MindFusion.Charting.Design.ShapeCollectionEditor

See Also

ShapeCollectionEditor Members
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionEditor Members

ShapeCollectionEditor Members
Constructors Methods

Editor for editing Shape collections at design time.

The following tables list the members exposed by the ShapeCollectionEditor type.

Public Constructors

Name | Description
ShapeCollectionEditor | Initializes a new instance of the ShapeCollectionEditor class using the ShapeCollection type.

Public Methods

Name | Description
EditValue | Edits the value of the specified ShapeCollection using the specified service provider and context.
GetEditStyle | Overloaded. Overridden. Gets the edit style used by the EditValue method.
GetPaintValueSupported | Overloaded. Indicates whether this editor supports painting a representation of the ShapeCollection's value within the specified context.
PaintValue | Overloaded. Paints a representation of the ShapeCollection's value using the specified PaintValueEventArgs.

Protected Methods

Name | Description
CanSelectMultipleInstances | Indicates whether multiple collection items can be selected at once.
CreateCollectionItemType | Gets the data type that this collection contains.

See Also

ShapeCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionEditor Constructor

ShapeCollectionEditor Constructor

Initializes a new instance of the ShapeCollectionEditor class using the ShapeCollection type.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public ShapeCollectionEditor (
Type type
)
Visual Basic

Public New ( _
type As Type _
)

Parameters

type
The type of the collection for this editor to edit.

See Also

ShapeCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionEditor Methods

ShapeCollectionEditor Methods

Public Methods

Name | Description
EditValue | Edits the value of the specified ShapeCollection using the specified service provider and context.
GetEditStyle | Overloaded. Overridden. Gets the edit style used by the EditValue method.
GetPaintValueSupported | Overloaded. Indicates whether this editor supports painting a representation of the ShapeCollection's value within the specified context.
PaintValue | Overloaded. Paints a representation of the ShapeCollection's value using the specified PaintValueEventArgs.

Protected Methods

Name | Description
CanSelectMultipleInstances | Indicates whether multiple collection items can be selected at once.
CreateCollectionItemType | Gets the data type that this collection contains.

See Also

ShapeCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionEditor.CanSelectMultipleInstances Method

ShapeCollectionEditor.CanSelectMultipleInstances Method

Indicates whether multiple collection items can be selected at once.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

protected virtual bool CanSelectMultipleInstances ()
Visual Basic

Protected Overridable Function CanSelectMultipleInstances () As Boolean

Return Value

true if the multiple collection members can be selected at the same time; otherwise, false. By default, this returns false.

Remarks

This method indicates whether multiple collection members can be selected within the collection editor dialog box.

See Also

ShapeCollectionEditor Members
ShapeCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionEditor.CreateCollectionItemType Method

ShapeCollectionEditor.CreateCollectionItemType Method

Gets the data type that this collection contains.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

protected virtual Type CreateCollectionItemType ()
Visual Basic

Protected Overridable Function CreateCollectionItemType () As Type

Return Value

The data type of the items in the collection, or an object equal typeof(Shape) can be located on the collection.

Remarks

The default implementation of this method returns the data type of the Item property of the collection, if it exists.

See Also

ShapeCollectionEditor Members
ShapeCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionEditor.EditValue Method

ShapeCollectionEditor.EditValue Method

Edits the value of the specified ShapeCollection using the specified service provider and context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override Object EditValue (
ITypeDescriptorContext context,
IServiceProvider provider,
Object value
)
Visual Basic

Public Overrides Function EditValue ( _
context As ITypeDescriptorContext, _
provider As IServiceProvider, _
value As Object _
) As Object

Parameters

context
An ITypeDescriptorContext that can be used to gain additional context information.
provider
A service provider object through which editing services can be obtained.
value
The object to edit the value of.

Return Value

The new value of the ShapeCollection. If the value of the ShapeCollection has not changed, this returns the same object it was passed.

See Also

ShapeCollectionEditor Members
ShapeCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionEditor.GetEditStyle Method

ShapeCollectionEditor.GetEditStyle Method

Overloaded. Overridden. Gets the edit style used by the EditValue method.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override UITypeEditorEditStyle GetEditStyle (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetEditStyle ( _
context As ITypeDescriptorContext _
) As UITypeEditorEditStyle

Parameters

context
A .NET ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A .NET UITypeEditorEditStyle enumeration value indicating the provided editing style. If the method is not supported in the specified context, this method will return UITypeEditorEditStyle.Modal.

See Also

ShapeCollectionEditor Members
ShapeCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionEditor.GetPaintValueSupported Method

ShapeCollectionEditor.GetPaintValueSupported Method

Overloaded. Indicates whether this editor supports painting a representation of the ShapeCollection's value within the specified context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override bool GetPaintValueSupported (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetPaintValueSupported ( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

true if PaintValue is implemented; otherwise, false.

See Also

ShapeCollectionEditor Members
ShapeCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionEditor.PaintValue Method

ShapeCollectionEditor.PaintValue Method

Overloaded. Paints a representation of the ShapeCollection's value using the specified PaintValueEventArgs.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override void PaintValue (
PaintValueEventArgs e
)
Visual Basic

Public Overrides Sub PaintValue ( _
e As PaintValueEventArgs _
)

Parameters

e
A PaintValueEventArgs that indicates what to paint and where to paint it.

Remarks

Editors should paint within the boundaries of the specified rectangle. This rectangle indicates the area of the Properties window to draw a representation of the value within.

See Also

ShapeCollectionEditor Members
ShapeCollectionEditor Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionForm Class

ShapeCollectionForm Class
Remarks See Also

A form used to edit ShapeCollection objects at design-time.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public class ShapeCollectionForm : Form
Visual Basic

Public Class ShapeCollectionForm
Inherits Form

Remarks

This class is for internal use only.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
MindFusion.Charting.Design.ShapeCollectionForm

See Also

ShapeCollectionForm Members
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionForm Members

ShapeCollectionForm Members
Constructors Properties Methods

A form used to edit ShapeCollection objects at design-time.

The following tables list the members exposed by the ShapeCollectionForm type.

Public Constructors

Name | Description
ShapeCollectionForm | Default constructor. Creates a new instance of the ShapeCollectionForm class.

Public Properties

Name | Description
Collection | Gets or sets the edited ShapeCollection object.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.

See Also

ShapeCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionForm Constructor

ShapeCollectionForm Constructor

Default constructor. Creates a new instance of the ShapeCollectionForm class.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public ShapeCollectionForm ()
Visual Basic

Public Sub New ()

See Also

ShapeCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionForm Methods

ShapeCollectionForm Methods

Protected Methods

Name | Description
Dispose | Clean up any resources being used.

See Also

ShapeCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionForm.Dispose Method

ShapeCollectionForm.Dispose Method

Clean up any resources being used.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true, if the ShapeCollectionForm is in process of disposing; otherwise false.

See Also

ShapeCollectionForm Members
ShapeCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionForm Properties

ShapeCollectionForm Properties

Public Properties

Name | Description
Collection | Gets or sets the edited ShapeCollection object.

See Also

ShapeCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.ShapeCollectionForm.Collection Property

ShapeCollectionForm.Collection Property

Gets or sets the edited ShapeCollection object.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public ShapeCollection Collection { get; set; }
Visual Basic

Public Property Collection As ShapeCollection

Property Value

An object of type ShapeCollection to be edited.

See Also

ShapeCollectionForm Members
ShapeCollectionForm Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.StringCollectionConverter Class

StringCollectionConverter Class
Remarks See Also

Provides a type converter for StringCollection types.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public class StringCollectionConverter : TypeConverter
Visual Basic

Public Class StringCollectionConverter
Inherits TypeConverter

Remarks

This class is for internal use only.

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Charting.Design.StringCollectionConverter

See Also

StringCollectionConverter Members
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.StringCollectionConverter Members

StringCollectionConverter Members
Constructors Methods

Provides a type converter for StringCollection types.

The following tables list the members exposed by the StringCollectionConverter type.

Public Constructors

Name | Description
StringCollectionConverter | Initializes a new instance of the StringCollectionConverter class.

Public Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.
CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Converts the particular object to the type of this converter, using the specified context and culture information.
ConvertTo | Converts the particular value object to the specified type, using the specified context and culture information.

See Also

StringCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.StringCollectionConverter Constructor

StringCollectionConverter Constructor

Initializes a new instance of the StringCollectionConverter class.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public StringCollectionConverter ()
Visual Basic

Public Sub New ()

Remarks

This is the default constructor and it initializes any fields to their default values.

See Also

StringCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.StringCollectionConverter Methods

StringCollectionConverter Methods

Public Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.
CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Converts the particular object to the type of this converter, using the specified context and culture information.
ConvertTo | Converts the particular value object to the specified type, using the specified context and culture information.

See Also

StringCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.StringCollectionConverter.CanConvertFrom Method

StringCollectionConverter.CanConvertFrom Method

Returns whether this converter can convert an object of the particular type to the type of this converter, using the specified context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type t
)
Visual Basic

Public Overrides Function CanConvertFrom ( _
context As ITypeDescriptorContext, _
t As Type _
) As Boolean

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
t
A .NET Type that represents the type to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

Remarks

As implemented in this class, this method returns true if t is type of string. Otherwise it returns false.

See Also

StringCollectionConverter Members
StringCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.StringCollectionConverter.CanConvertTo Method

StringCollectionConverter.CanConvertTo Method

Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destType
)
Visual Basic

Public Overrides Function CanConvertTo ( _
context As ITypeDescriptorContext, _
destType As Type _
) As Boolean

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
destType
A .NET Type that represents the type to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Remarks

As implemented in this class, the method returns true if destType is of type .NET InstanceDescriptor or string.

See Also

StringCollectionConverter Members
StringCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.StringCollectionConverter.ConvertFrom Method

StringCollectionConverter.ConvertFrom Method

Converts the particular object to the type of this converter, using the specified context and culture information.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo info,
Object value
)
Visual Basic

Public Overrides Function ConvertFrom ( _
context As ITypeDescriptorContext, _
info As CultureInfo, _
value As Object _
) As Object

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
info
The .NET CultureInfo to use as the current culture.
value
The Object to convert.

Return Value

An Object that represents the converted value.

See Also

StringCollectionConverter Members
StringCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.Design.StringCollectionConverter.ConvertTo Method

StringCollectionConverter.ConvertTo Method

Converts the particular value object to the specified type, using the specified context and culture information.

Namespace: MindFusion.Charting.Design
Assembly: MindFusion.Charting

Syntax

C#

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo info,
Object value,
Type destType
)
Visual Basic

Public Overrides Function ConvertTo ( _
context As ITypeDescriptorContext, _
info As CultureInfo, _
value As Object, _
destType As Type _
) As Object

Parameters

context
A .NET ITypeDescriptorContext that provides a format context.
info
A .NET CultureInfo object.
value
The Type to convert the value parameter to.
destType
An Object that represents the converted value.

Return Value

Remarks

As implemented by this class, the method returns a .NET InstanceDescriptor or string, according to destType.

See Also

StringCollectionConverter Members
StringCollectionConverter Class
MindFusion.Charting.Design Namespace


MindFusion.Charting.WinForms Namespace
Classes Enumerations

Classes

Class | Description
AxesChart | A base class for all charts that use the rectangular coordinate system.
BarChart | A class for drawing bar charts.
Chart | Base class for all chart types - bars, pies, areas, lines, or radars.
ChartPrinter | Defines a class for printing charts.
LineChart | A class specified for drawing line, area, bubble and scatter charts.
PieChart | A class specified for drawing pie charts.
RadarChart | A class used to draw radar charts.

Enumerations

Enumeration | Description
ImagePos | Specifies the position and alignment of the chart's background image.
ResizeType | Specifies how chart graphics fit into the chart control's bounding rectangle.


MindFusion.Charting.WinForms.AxesChart Class

AxesChart Class
Remarks See Also

A base class for all charts that use the rectangular coordinate system.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public abstract class AxesChart : Chart
Visual Basic

Public MustInherit Class AxesChart
Inherits Chart

Remarks

AxesChart inherits properties and methods from its base class Chart.

Chart axes can be drawn with a shadow, which length is set with the Depth3D property. Use AxisShadowBrush to set the brush for the axis shadow. AxisPen specifies the pen for the chart axes.

Every axes chart can be drawn with a grid. You can choose among several grid types by using the GridType property. If the grid is Crossed, its density is set with GridWidth. The stripes of the grid are filled with GridBrush and AltGridBrush. The grid is drawn with the GridPen.

Custom grid points are set with HorGridPoints and VertGridPoints. They are drawn with HorGridPens and VertGridPens. Stripes in custom grids are filled with HorGridBrushes and VertGridBrushes.

Custom grids can have grid labels. They are set wtih XGridLabels, YGridLabels and Y2GridLabels. The orientation of the labels at the X-axis is set with XGridLabelsOrientation. If you want pointers to the grid labels, use GridLabelPointer.

The summary graphics or parts of graphics are drawn with SummaryBrushes and SummaryPens. AddCustomSummary method adds a custom summary value to the list of summaries. Graphics, which data is bound to the Y2-axis are drawn with the Y2ChartBrushes and Y2ChartPens.

The AxisSettings class holds the settings for the chart axes - chart label, length, type of axis labels, label prefix and suffix, data formatting and so on. The properties for each chart axis are called XAxisSettings, YAxisSettings and Y2AxisSettings.

The chart data is set with XData and YData. Use Y2Data if you want to draw graphics for the second Y-axis, parallel to the first one. Data can be either numbers or DateTime values or any other format that can safely be converted to numbers / DateTime values using the standard .NET type converters.

Charts can be drawn with an Offset from the start of the coordinate system.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Charting.WinForms.Chart
MindFusion.Charting.WinForms.AxesChart

See Also

AxesChart Members
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart Members

AxesChart Members
Constructors Properties Methods

A base class for all charts that use the rectangular coordinate system.

The following tables list the members exposed by the AxesChart type.

Public Constructors

Name | Description
AxesChart | A base class for all charts that use the rectangular coordinate system.

Public Properties

Name | Description
AltGridBrush | Gets or sets the alternative brush for drawing the chart's grid.
AxisPen | Gets or sets the pen, which is used to draw the chart axes.
AxisShadowBrush | Gets or sets the brush, which is used when drawing the shadow of the chart axes.
ChartBackgroundBrush | Gets or sets the brush for the plot area.
Depth3D | Gets or sets the shadow depth for 3D charts.
DistBtwSeries | Gets or sets the distance among chart series.
GridBrush | Gets or sets the brush for filling odd grid stripes.
GridLabelOffset | Gets or sets the offset of grid labels.
GridLabelPointer | Gets or sets the length of the pointer to the grid labels.
GridLabelsAtLines | Gets or sets the position of grid labels.
GridOutlinePen | Gets or sets the pen for the grid border.
GridPen | Specifies the pen for drawing the chart grid.
GridType | Gets or sets the type of the chart grid.
GridWidth | Gets or sets the distance between adjacent grid points in chess grids.
HorGridBrushes | Gets or sets the brushes for drawing horizontal grid stripes in custom grids.
HorGridPens | Gets or sets the pens for drawing horizontal grid stripes in custom grids.
HorGridPoints | Gets or sets the positions of horizontal lines in custom grids.
Horizontal | Gets or sets the orientation of the chart.
Offset | Gets or sets the offset from the zero point to the beginning of the chart graphics.
PlotAreaMargins | Gets or sets the margins of the plot area.
SummaryBrushes | Gets or sets the brushes that are used for drawing summary parts in charts.
SummaryPens | Gets or sets the pens for drawing summary parts.
SummaryValues | Gets or sets the summary operations performed on chart data.
VertGridBrushes | Gets or sets the brushes for filling vertical stripes in custom grids.
VertGridPens | Gets or sets the pens for drawing vertical grid lines in custom grids.
VertGridPoints | Gets or sets the positions of vertical lines in custom grids.
XAxisSettings | Gets or sets the appearance settings for the X-axis.
XGridLabelBrushes | Gets or sets the brushes for drawing labels at the X-axis in custom grids.
XGridLabels | Gets or sets the labels drawn at the X-axis in custom grids.
XLabels | Gets or sets custom labels drawn at the X-axis.
XLabelsFields | Gets or sets the field of the data source used to populate the XLabels array.
Y2AxisSettings | Gets os sets the appearance settings for the Y2-axis.
Y2ChartBrushes | Gets or sets the brushes for drawing Y2-bound chart graphics.
Y2ChartPens | Gets or sets the pens for drawing Y2 - bound chart graphics.
Y2Data | Invokes a custom function that calculates the values for the chart.
Y2DataFields | Gets or sets the field in the data source when the data for the Y2-chart values is derived from a database.
Y2GridLabelBrushes | Gets or sets the brushes for drawing labels at the Y2-axis in custom grids.
Y2GridLabels | Gets or sets the labels drawn at the Y2-axis in custom grids.
Y2Labels | Gets or sets custom labels for the second Y-axis.
Y2LabelsFields | Gets or sets the field in the data source when the data for the Y2 - chart labels is derived from a database.
YAxisSettings | Gets or set the appearance settings for the Y-axis.
YGridLabelBrushes | Gets or sets the brushes for drawing custom grid labels at the Y-axis.
YGridLabels | Gets or sets custom grid labels at the Y-axis.
YLabels | Gets or sets the list of labels displayed along the Y axis.
YLabelsFields | Gets or sets the field of the data source used to populate the YLabels array.

Public Methods

Name | Description
AddCustomSummary | Overloaded. Adds a value to the list of summary values that are drawn in the chart.

See Also

AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart Constructor

AxesChart Constructor

A base class for all charts that use the rectangular coordinate system.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public AxesChart ()
Visual Basic

Public Sub New ()

See Also

AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart Methods

AxesChart Methods

Public Methods

Name | Description
AddCustomSummary | Overloaded. Adds a value to the list of summary values that are drawn in the chart.

See Also

AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.AddCustomSummary Method

AxesChart.AddCustomSummary Method

Adds a value to the list of summary values that are drawn in the chart.

Overload List

Name | Description
AxesChart.AddCustomSummary (Double, String) | Adds a value to the list of summary values that are drawn in the chart.
AxesChart.AddCustomSummary (Int32, String) | Adds a value to the list of summary values that are drawn in the chart.
AxesChart.AddCustomSummary (Int64, String) | Adds a value to the list of summary values that are drawn in the chart.
AxesChart.AddCustomSummary (Single, String) | Adds a value to the list of summary values that are drawn in the chart.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.AddCustomSummary Method (Double, String)

AxesChart.AddCustomSummary Method (Double, String)
See Also

Adds a value to the list of summary values that are drawn in the chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void AddCustomSummary (
double summaryValue,
string summaryText
)
Visual Basic

Public Sub AddCustomSummary ( _
summaryValue As Double, _
summaryText As String _
)

Parameters

summaryValue
A double number that represents the summary value.
summaryText
A string that specifies description for summaryValue.

Remarks

The method is used to add a summary value that is not any of the Summary enumeration members. The description is drawn when the LabelType for this axis is set to AxisLabelType.CustomText. If axis labels show DateTime values or DataFormat.Number, the format of the summary value is set by DateTimeFormat or NumberFormat.

See Also

AddCustomSummary Method Overload List
AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.AddCustomSummary Method (Int32, String)

AxesChart.AddCustomSummary Method (Int32, String)
See Also

Adds a value to the list of summary values that are drawn in the chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void AddCustomSummary (
int summaryValue,
string summaryText
)
Visual Basic

Public Sub AddCustomSummary ( _
summaryValue As Integer, _
summaryText As String _
)

Parameters

summaryValue
An int value that represents the summary.
summaryText
A string that represents description for summaryValue.

See Also

AddCustomSummary Method Overload List
AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.AddCustomSummary Method (Int64, String)

AxesChart.AddCustomSummary Method (Int64, String)
See Also

Adds a value to the list of summary values that are drawn in the chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void AddCustomSummary (
long summaryValue,
string summaryText
)
Visual Basic

Public Sub AddCustomSummary ( _
summaryValue As Long, _
summaryText As String _
)

Parameters

summaryValue
An int value that represents the summary.
summaryText
A string that specifies the description of summaryValue.

Remarks

The method is used to add a summary value that is not any of the Summary enumeration members. The description is drawn when the LabelType for this axis is set to AxisLabelType.CustomText. If axis labels show DateTime values or Numbers the format of the summary value is set by DateTimeFormat or NumberFormat.

See Also

AddCustomSummary Method Overload List
AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.AddCustomSummary Method (Single, String)

AxesChart.AddCustomSummary Method (Single, String)
See Also

Adds a value to the list of summary values that are drawn in the chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void AddCustomSummary (
float summaryValue,
string summaryText
)
Visual Basic

Public Sub AddCustomSummary ( _
summaryValue As Single, _
summaryText As String _
)

Parameters

summaryValue
A float value that represents the summary.
summaryText
A string that specifies the description of summaryValue.

Remarks

Adds a value to the list of summary values that are drawn in the chart.

See Also

AddCustomSummary Method Overload List
AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart Properties

AxesChart Properties

Public Properties

Name | Description
AltGridBrush | Gets or sets the alternative brush for drawing the chart's grid.
AxisPen | Gets or sets the pen, which is used to draw the chart axes.
AxisShadowBrush | Gets or sets the brush, which is used when drawing the shadow of the chart axes.
ChartBackgroundBrush | Gets or sets the brush for the plot area.
Depth3D | Gets or sets the shadow depth for 3D charts.
DistBtwSeries | Gets or sets the distance among chart series.
GridBrush | Gets or sets the brush for filling odd grid stripes.
GridLabelOffset | Gets or sets the offset of grid labels.
GridLabelPointer | Gets or sets the length of the pointer to the grid labels.
GridLabelsAtLines | Gets or sets the position of grid labels.
GridOutlinePen | Gets or sets the pen for the grid border.
GridPen | Specifies the pen for drawing the chart grid.
GridType | Gets or sets the type of the chart grid.
GridWidth | Gets or sets the distance between adjacent grid points in chess grids.
HorGridBrushes | Gets or sets the brushes for drawing horizontal grid stripes in custom grids.
HorGridPens | Gets or sets the pens for drawing horizontal grid stripes in custom grids.
HorGridPoints | Gets or sets the positions of horizontal lines in custom grids.
Horizontal | Gets or sets the orientation of the chart.
Offset | Gets or sets the offset from the zero point to the beginning of the chart graphics.
PlotAreaMargins | Gets or sets the margins of the plot area.
SummaryBrushes | Gets or sets the brushes that are used for drawing summary parts in charts.
SummaryPens | Gets or sets the pens for drawing summary parts.
SummaryValues | Gets or sets the summary operations performed on chart data.
VertGridBrushes | Gets or sets the brushes for filling vertical stripes in custom grids.
VertGridPens | Gets or sets the pens for drawing vertical grid lines in custom grids.
VertGridPoints | Gets or sets the positions of vertical lines in custom grids.
XAxisSettings | Gets or sets the appearance settings for the X-axis.
XGridLabelBrushes | Gets or sets the brushes for drawing labels at the X-axis in custom grids.
XGridLabels | Gets or sets the labels drawn at the X-axis in custom grids.
XLabels | Gets or sets custom labels drawn at the X-axis.
XLabelsFields | Gets or sets the field of the data source used to populate the XLabels array.
Y2AxisSettings | Gets os sets the appearance settings for the Y2-axis.
Y2ChartBrushes | Gets or sets the brushes for drawing Y2-bound chart graphics.
Y2ChartPens | Gets or sets the pens for drawing Y2 - bound chart graphics.
Y2Data | Invokes a custom function that calculates the values for the chart.
Y2DataFields | Gets or sets the field in the data source when the data for the Y2-chart values is derived from a database.
Y2GridLabelBrushes | Gets or sets the brushes for drawing labels at the Y2-axis in custom grids.
Y2GridLabels | Gets or sets the labels drawn at the Y2-axis in custom grids.
Y2Labels | Gets or sets custom labels for the second Y-axis.
Y2LabelsFields | Gets or sets the field in the data source when the data for the Y2 - chart labels is derived from a database.
YAxisSettings | Gets or set the appearance settings for the Y-axis.
YGridLabelBrushes | Gets or sets the brushes for drawing custom grid labels at the Y-axis.
YGridLabels | Gets or sets custom grid labels at the Y-axis.
YLabels | Gets or sets the list of labels displayed along the Y axis.
YLabelsFields | Gets or sets the field of the data source used to populate the YLabels array.

See Also

AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.AltGridBrush Property

AxesChart.AltGridBrush Property

Gets or sets the alternative brush for drawing the chart's grid.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush AltGridBrush { get; set; }
Visual Basic

Public Property AltGridBrush As Brush

Property Value

An instance of MindFusion.Drawing.Brush class.

Remarks

AltGridBrush is used for filling the even grid stripes when the GridType is not GridType.None or GridType.Custom. The odd grid stripes are filled with GridBrush. The grid stripes are drawn with the GridPen.

When the GridType is GridType.Custom the grid stripes are painted with HorGridBrushes and VertGridBrushes.

Default value for the AltGridBrush is null (no brush).

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.AxisPen Property

AxesChart.AxisPen Property

Gets or sets the pen, which is used to draw the chart axes.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen AxisPen { get; set; }
Visual Basic

Public Property AxisPen As Pen

Property Value

An instance of MindFusion.Drawing.Pen class

Remarks

The property is used for drawing all chart axes. If the chart is of 3D type the axis shadow is drawn with AxisShadowBrush. If no AxisShadowBrush is specified, a shadow brush a little darker than the AxisPen is created.

Default value of the AxisPen property is black pen with width 1.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.AxisShadowBrush Property

AxesChart.AxisShadowBrush Property

Gets or sets the brush, which is used when drawing the shadow of the chart axes.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush AxisShadowBrush { get; set; }
Visual Basic

Public Property AxisShadowBrush As Brush

Property Value

An instance of MindFusion.Drawing.Brush class.

Remarks

The property specifies the brush for drawing axes shadows in 3D charts.

Axes are drawn with shadows when the type of the chart (LineType, BarType) is set to a 3D chart and Depth3D is greater than 0. If the chart has multiple series, its shadow is drawn larger so that all series could fit in.

Default value for the AxisShadowBrush property is a semitransparent SolidBrush with alpha value 100 and color equal to the color of the AxisPen.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace
ChartBackgroundBrush


MindFusion.Charting.WinForms.AxesChart.ChartBackgroundBrush Property

AxesChart.ChartBackgroundBrush Property

Gets or sets the brush for the plot area.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush ChartBackgroundBrush { get; set; }
Visual Basic

Public Property ChartBackgroundBrush As Brush

Property Value

An instance of type MindFusion.Drawing.Brush.

Remarks

The property is used for drawing the area of the chart background that lies between the chart axes. If the ChartBackgroundBrush is not set, the BackgroundBrush is used for drawing the whole chart background.

Value for the property can be any brush that is derived from MindFusion.Drawing.Brush - SolidBrush, LinearGradientBrush, PathGradientBrush and so on.

Default value for the ChartBackgroundBrush property is null, that is, the plot area is drawn with the BackgroundBrush.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.Depth3D Property

AxesChart.Depth3D Property

Gets or sets the shadow depth for 3D charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float Depth3D { get; set; }
Visual Basic

Public Property Depth3D As Single

Property Value

A float value that specifies the depth, in points.

Remarks

The property is used only by 3D charts. If the chart draws more than one series, the Depth3D property is multiplied by the count of the series. Stacked bar charts make an exception since their series are drawn as sections in a single bar.

Default value for the Depth3D property is 20f.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.DistBtwSeries Property

AxesChart.DistBtwSeries Property

Gets or sets the distance among chart series.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float DistBtwSeries { get; set; }
Visual Basic

Public Property DistBtwSeries As Single

Property Value

A float value that specifies the distance.

Remarks

The property specifies the distance among separate graphics in multi-series 3D charts. Default value for the DistBtwSeries property is 10f.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.GridBrush Property

AxesChart.GridBrush Property

Gets or sets the brush for filling odd grid stripes.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush GridBrush { get; set; }
Visual Basic

Public Property GridBrush As Brush

Property Value

An instance of MindFusion.Drawing.Brush.

Remarks

GridBrush is used for filling the odd grid stripes when the GridType is not GridType.None or GridType.Custom. The even grid stripes are filled with AltGridBrush. The grid stripes are drawn with the GridPen.

Grid stripes in custom grids are painted with HorGridBrushes and VertGridBrushes.

Default value for the GridBrush is null (no brush).

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.GridLabelOffset Property

AxesChart.GridLabelOffset Property

Gets or sets the offset of grid labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float GridLabelOffset { get; set; }
Visual Basic

Public Property GridLabelOffset As Single

Property Value

A float value.

Remarks

The property specifies the offset of custom grid labels to the nearest chart object - the grid bracket (if GridLabelPointer is greater than zero), the axis labels (if LabelType is not Empty) or the axis. The property sets the offset for labels at all axes - X, Y and Y2 (if present).

The property is used only with custom grids, for example, the GridType is set to Custom. Grid labels are set with XGridLabels, YGridLabels and Y2GridLabels.

Default value for the GridLabelOffset property is 5f.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.GridLabelPointer Property

AxesChart.GridLabelPointer Property

Gets or sets the length of the pointer to the grid labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float GridLabelPointer { get; set; }
Visual Basic

Public Property GridLabelPointer As Single

Property Value

A float value that specifies the length of the pointer, in points.

Remarks

The property specifies the length of the grid label pointer for grid labels at all chart axes - X, Y and Y2 (if present). Pointers are not drawn when the labels are located at grid lines if GridLabelsAtLines is true.

Grid labels are drawn only in charts which GridType is set to GridType.Custom. The labels are set with XGridLabels, YGridLabels and Y2GridLabels.

Default value for the GridLabelPointer property is 5f.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.GridLabelsAtLines Property

AxesChart.GridLabelsAtLines Property

Gets or sets the position of grid labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public bool GridLabelsAtLines { get; set; }
Visual Basic

Public Property GridLabelsAtLines As Boolean

Property Value

A bool value that specifies the position of the grid labels.

Remarks

The property specifies where custom grid labels are drawn - in the middle of the grid segment or at the grid line they refer to. If the labels are drawn at grid lines no pointing bracket is drawn.

The property is used only when the GridType is GridType.Custom. Custom grid labels are set with XGridLabels, YGridLabels and Y2GridLabels.

Default value for the GridLabelsAtLines property is false.

See Also

XGridLabelBrushes
YGridLabelBrushes
Y2GridLabelBrushes
HorGridPoints
VertGridPoints
AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.GridOutlinePen Property

AxesChart.GridOutlinePen Property

Gets or sets the pen for the grid border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen GridOutlinePen { get; set; }
Visual Basic

Public Property GridOutlinePen As Pen

Property Value

An object of type MindFusion.Drawing.Pen.

Remarks

The pen draws the border around the grid. It can be null and in this case, no outlining is drawn.

Default value for the GridOutlinePen property is a black pen, width 1.

See Also

GridType
GridPen
GridBrush
AltGridBrush
AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.GridPen Property

AxesChart.GridPen Property

Specifies the pen for drawing the chart grid.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen GridPen { get; set; }
Visual Basic

Public Property GridPen As Pen

Property Value

An instance of MindFusion.Drawing.Pen class.

Remarks

The GridPen is used for drawing the chart grid when the GridType is not GridType.None or GridType.Custom. The grid stripes are painted with GridBrush and AltGridBrush. You can have a grid that has only stripes and no lines are drawn. In this case, set GridPen to null.

The border of the grid is drawn with GridOutlinePen.

Default value for the GridPen is null, that is, no grid is drawn.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.GridType Property

AxesChart.GridType Property

Gets or sets the type of the chart grid.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public GridType GridType { get; set; }
Visual Basic

Public Property GridType As GridType

Property Value

One of the GridType Enumeration values.

Remarks

Grid can be drawn at all charts with axes. When the grid is of type GridType.Chess its width is set by GridWidth.

When the grid is custom, the positions of grid lines are specified with HorGridPoints and VertGridPoints. For other grid types, except GridType.None, the width is calculated automatically based on the scale of the axes.

Default value for the GridType property is GridType.None.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.GridWidth Property

AxesChart.GridWidth Property

Gets or sets the distance between adjacent grid points in chess grids.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float GridWidth { get; set; }
Visual Basic

Public Property GridWidth As Single

Property Value

A float value that specifies the width in chess grids.

Remarks

The property is considered only for GridType.Chess. Default value for the GridWidth property is 0.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.HorGridBrushes Property

AxesChart.HorGridBrushes Property

Gets or sets the brushes for drawing horizontal grid stripes in custom grids.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection HorGridBrushes { get; set; }
Visual Basic

Public Property HorGridBrushes As BrushCollection

Property Value

An instance of MindFusion.Drawing.BrushCollection.

Remarks

The GridType should be set to GridType.Custom and HorGridPoints should not be empty. If the brushes are less than the grid stripes to be filled, they are used in a cycle.

Default value for the HorGridBrushes property is an empty BrushCollection, in this case no stripes are drawn.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.HorGridPens Property

AxesChart.HorGridPens Property

Gets or sets the pens for drawing horizontal grid stripes in custom grids.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public PenCollection HorGridPens { get; set; }
Visual Basic

Public Property HorGridPens As PenCollection

Property Value

An instance of MindFusion.Drawing.PenCollection.

Remarks

The GridType should be set to GridType.Custom and HorGridPoints should not be empty. If the count of the pens is less than the count of the stripes, they are used in a cycle.

Default value for the HorGridPens is an empty PenCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.HorGridPoints Property

AxesChart.HorGridPoints Property

Gets or sets the positions of horizontal lines in custom grids.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList HorGridPoints { get; set; }
Visual Basic

Public Property HorGridPoints As IList

Property Value

An object of type .NET IList that holds float values with the points; values should range from 0 to 100.

Remarks

HorGridPoints is used when GridType is set to GridType.Custom. The values should range from 0 to 100 with 0 coinciding with the start of the Y-axis and 100 - with its end.

The stripes are drawn with HorGridPens and are filled with HorGridBrushes. You can leave the property empty if you do not need horizontal grid lines.

Default value for the HorGridPoints property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.Horizontal Property

AxesChart.Horizontal Property

Gets or sets the orientation of the chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public bool Horizontal { get; set; }
Visual Basic

Public Property Horizontal As Boolean

Property Value

A bool value; true if the chart is horizontal, otherwise false.

Remarks

In horizontal bar charts, the Data property specifies values for the X-axis. In vertical bar charts, the Data property specifies values for the Y-axis.

Line charts use data from both XData and YData lists, no matter their orientation. Summary operations are performed on XData for horizontal charts and YData for vertical ones. Bubble charts have no orientation.

Default value for the Horizontal property is false.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.Offset Property

AxesChart.Offset Property

Gets or sets the offset from the zero point to the beginning of the chart graphics.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float Offset { get; set; }
Visual Basic

Public Property Offset As Single

Property Value

A float value that specifies the offset of the chart to the start of the axis.

Remarks

Vertical charts with positive values are shifted rightwards, with offset at the X-axis. If the chart has only negative X-values, it is shifted leftwards. Horizontal charts with positive values are shifted upwards, with offset at the Y-axis. If the chart has only negative Y-values, it is shifted downwards.

The orientation of the chart is set with the Horizontal property.

Default value for the Offset property is 0 (no offset).

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.PlotAreaMargins Property

AxesChart.PlotAreaMargins Property

Gets or sets the margins of the plot area.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Margins PlotAreaMargins { get; set; }
Visual Basic

Public Property PlotAreaMargins As Margins

Property Value

An instance of type .NET Margins class.

Remarks

Use the property to set custom values for the space at any of the plot area sides.

Default value for the PlotAreaMargins property is Margins(0,0,0,0).

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.SummaryBrushes Property

AxesChart.SummaryBrushes Property

Gets or sets the brushes that are used for drawing summary parts in charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection SummaryBrushes { get; set; }
Visual Basic

Public Property SummaryBrushes As BrushCollection

Property Value

An instance of MindFusion.Drawing.BrushCollection.

Remarks

SummaryBrushes are used for filling summary parts in all types of charts that use axes. The summary graphics depend on the type of the chart - in bar charts they are bars, in area charts - areas and so on. If SummaryBrushes are not set, the control creates brushes from the SummaryPen-s, if any.

Summaries are drawn when the SummaryValues property is not an empty list.

Default value for the SummaryBrushes property is an empty BrushCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.SummaryPens Property

AxesChart.SummaryPens Property

Gets or sets the pens for drawing summary parts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public PenCollection SummaryPens { get; set; }
Visual Basic

Public Property SummaryPens As PenCollection

Property Value

An instance of type MindFusion.Drawing.PenCollection.

Remarks

SummaryPens are used for drawing summary parts in all charts that use axes. The summary graphics depends on the chart type - in line charts it is a line, in bar charts - bar and so on. If SummaryPens are not set, the control uses SummaryBrushes, if any, to create pens from them.

Use SummaryValues to add Summary-s to the chart.

Default value for the SummaryPens property is an empty PenCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.SummaryValues Property

AxesChart.SummaryValues Property

Gets or sets the summary operations performed on chart data.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList SummaryValues { get; set; }
Visual Basic

Public Property SummaryValues As IList

Property Value

An instane of type .NET IList that holds Summary values.

Remarks

SummaryValues enables you to add aggregate operations like min, max, average and so on to the chart values. Use for that the members of the Summary enumeration. You can specify your own summary values with the AddCustomSummary method.

Summary graphics follow the shape of the chart they refer to. In line charts, they are lines, in bar charts - bars, and so on. They are drawn with SummaryPens and SummaryBrushes. The labels for summary charts are the same type as those of the chart's axes.

Summary operations are performed on XData for horizontal line charts and on YData for vertical ones. In bar charts always Data is used.

Default value for the SummaryValues property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.VertGridBrushes Property

AxesChart.VertGridBrushes Property

Gets or sets the brushes for filling vertical stripes in custom grids.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection VertGridBrushes { get; set; }
Visual Basic

Public Property VertGridBrushes As BrushCollection

Property Value

An instance of type MindFusion.Drawing.BrushCollection.

Remarks

Vertical stripes and lines in custom grids are drawn when the VertGridPoints property is not an empty list. The grid lines are drawn with VertGridPens. The GridType should be set to GridType.Custom.

The respective properties for drawing horizontal grid stripes are HorGridPoints, HorGridPens and HorGridBrushes.

Default value for the VertGridBrushes property is an empty BrushCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.VertGridPens Property

AxesChart.VertGridPens Property

Gets or sets the pens for drawing vertical grid lines in custom grids.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public PenCollection VertGridPens { get; set; }
Visual Basic

Public Property VertGridPens As PenCollection

Property Value

An instance of type MindFusion.Drawing.PenCollection.

Remarks

The property specifies the pens for drawing vertical grid lines in custom grids. In this case the grid stripes are filled with brushes from the VertGridBrushes property. The position of the grid lines is specified with VertGridPoints.

Custom grids can have labels at the X-axis. The labels are set with XGridLabels property.

When the GridType is not GridType.Custom, the grid is drawn with the GridPen and the grid stripes are filled with GridBrush and AltGridBrush.

Default value for the VertGridPens property is an empty PenCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.VertGridPoints Property

AxesChart.VertGridPoints Property

Gets or sets the positions of vertical lines in custom grids.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList VertGridPoints { get; set; }
Visual Basic

Public Property VertGridPoints As IList

Property Value

An object of type .NET IList with numbers that specify the position of the grid points along the axis; values should range from 0 to 100.

Remarks

Add to the VertGridPoints property numbers between 0 and 100. Zero coincides with the start of the X-axis and 100 - with its end. Use VertGridPens and VertGridBrushes to specify the pens and brushes for filing the grid stripes. The GridType should be set to GridType.Custom.

The respective properties for drawing horizontal grid stripes are HorGridPoints, HorGridPens and HorGridBrushes.

Default value for the VertGridBrushes property is an empty BrushCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.XAxisSettings Property

AxesChart.XAxisSettings Property

Gets or sets the appearance settings for the X-axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public AxisSettings XAxisSettings { get; }
Visual Basic

Public ReadOnly Property XAxisSettings As AxisSettings

Property Value

An instance of type MindFusion.Charting.AxisSettings class.

Remarks

The property specifies all appearance characteristics of the X-axis: labels, fonts, data format, minimum and maximum value as well the intervals among them, label suffix and prefix, division coefficient and division label and so on.

For more information about the axis properties and their default values, please check the AxisSettings class.

Default value for the XAxisSettings property is a new AxisSettings object. You can access it directly through the XAxisSettings property.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.XGridLabelBrushes Property

AxesChart.XGridLabelBrushes Property

Gets or sets the brushes for drawing labels at the X-axis in custom grids.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection XGridLabelBrushes { get; set; }
Visual Basic

Public Property XGridLabelBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

Use XGridLabels to set custom labels in grids with vertical stripes. The GridType should be set to GridType.Custom. The position of the labels depends on the VertGridPoints and GridLabelsAtLines properties.

If the brushes are less than the grid labels, the control cycles through them.

Default value for the XGridLabelBrushes property is an empty BrushCollection.

See Also

XGridLabels
VertGridPoints
AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.XGridLabels Property

AxesChart.XGridLabels Property

Gets or sets the labels drawn at the X-axis in custom grids.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList XGridLabels { get; set; }
Visual Basic

Public Property XGridLabels As IList

Property Value

An object of type .NET IList that holds the labels.

Remarks

The labels are drawn with XGridLabelBrushes. The GridType should be set to GridType.Custom. Use VertGridPoints to specify the position of the XGridLabels at the X-axis. GridLabelsAtLines specifies whether the labels are drawn at grid lines or in the middle of the grid segment.

The orientation of the grid labels is set with XGridLabelsOrientation.

Default value for the XGridLabels property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.XLabels Property

AxesChart.XLabels Property

Gets or sets custom labels drawn at the X-axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList XLabels { get; set; }
Visual Basic

Public Property XLabels As IList

Property Value

An instance of type .NET IList class that holds other lists with the labels.

Remarks

The labels are drawn when XAxisSettings.LabelType is set to AxisLabelType.CustomText. If the labels are not set as strings, the control converts them automatically.

In multi-series charts, the labels are drawn in rows. The space among the rows depends on LabelSpan. LabelOffset specifies the offset of the labels to the chart axis.

The labels can be drawn rotated if RotationAngle is greater than zero. LabelBrush sets the brush for the labels. If MultiColoredLabels is true, the labels are drawn with the ChartBrushes.

If the labels are less than the data, the control adds empty strings. If they are more, the excess labels are omitted.

Default value for the XLabels property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.XLabelsFields Property

AxesChart.XLabelsFields Property

Gets or sets the field of the data source used to populate the XLabels array.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string XLabelsFields { get; set; }
Visual Basic

Public Property XLabelsFields As String

Property Value

A string that specifies the name of the data source field used as X-labels.

Remarks

The property enables you to bind the labels drawn at the X-axis to a field in a database. The data source object is specified with the DataSource property. If it is of type DataSet you can use the DataMember property to specify a given table as source for the chart data. In this case the fields of the table appear as items in the drop down combo box in the XLabelsFields property of the chart control.

The labels specified with the XLabelsFields are drawn only if the LabelType field of the XAxisSettings property is set to AxisLabelType.CustomText.

The XLabelsFields property, when populated with data, is the same as the XLabels property.

Default value for the XLabelsFields property is an empty string ("").

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.AxesChart.Y2AxisSettings Property

AxesChart.Y2AxisSettings Property

Gets os sets the appearance settings for the Y2-axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public AxisSettings Y2AxisSettings { get; }
Visual Basic

Public ReadOnly Property Y2AxisSettings As AxisSettings

Property Value

An instance of type MindFusion.Charting.AxisSettings class.

Remarks

The property specifies all appearance characteristics of the Y2-axis: labels, fonts, data format, minimum and maximum value as well the intervals among them, label suffix and prefix, division coefficient and division label and so on. For more information about the axis properties and their default values, please check the AxisSettings class.

Y2Axis is drawn only when Y2Data is not an empty list. It is drawn parallel to the Y-axis, at the end of the X-axis.

Default value for the Y2AxisSettings property is a new AxisSettings object, which properties are set to their default values.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.Y2ChartBrushes Property

AxesChart.Y2ChartBrushes Property

Gets or sets the brushes for drawing Y2-bound chart graphics.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection Y2ChartBrushes { get; set; }
Visual Basic

Public Property Y2ChartBrushes As BrushCollection

Property Value

An instance of type MindFusion.Drawing.BrushCollection.

Remarks

Y2 chart graphics are drawn only when the Y2Data property is not empty. Use Y2ChartPens to set the pens. If the brushes are less than the data series, the control cycles through them.

Default value for the Y2ChartBrushes property is an empty BrushCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.Y2ChartPens Property

AxesChart.Y2ChartPens Property

Gets or sets the pens for drawing Y2 - bound chart graphics.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public PenCollection Y2ChartPens { get; set; }
Visual Basic

Public Property Y2ChartPens As PenCollection

Property Value

An instance of MindFusion.Drawing.PenCollection class.

Remarks

Y2 chart graphics are drawn only when the Y2Data property is not an empty list. The brushes are set with Y2ChartBrushes. If the pens are less than the data series, the control cycles through them.

Default value for the Y2ChartPens property is an empty PenCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.Y2Data Property

AxesChart.Y2Data Property

Invokes a custom function that calculates the values for the chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList Y2Data { get; set; }
Visual Basic

Public Property Y2Data As IList

Property Value

An object of type .NET IList class that holds other lists with the numbers.

Remarks

Data can be either numbers or DateTime values. They can be set in any format - integer, float, string as long as it can safely be converted to double-s or DateTime values using the standard .NET DoubleConverter and DateTimeConveter classes. The appearance options for the Y2-axis are set with Y2AxisSettings.

In bubble charts, the property is used to calculate the bubbles' radii.

Default value for the Y2Data property is an empty IList object.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.Y2DataFields Property

AxesChart.Y2DataFields Property

Gets or sets the field in the data source when the data for the Y2-chart values is derived from a database.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string Y2DataFields { get; set; }
Visual Basic

Public Property Y2DataFields As String

Property Value

A string that specifies the name of the data source field.

Remarks

The property enables you to retrieve the data used for calculating the Y-coordinates of charts bound to the second Y-axis to numerical columns in a database. In bubble charts, this data is used for calculating the radiuses of the bubbles.

The data source object is specified with the DataSource property. If it is of type DataSet you can use the DataMember property to specify a given table as source for the chart data. In this case the fields of the table appear as items in the drop down combo box in the Y2DataFields property of the chart control.
If you want to add more than one table field as data for the chart you should separate the names with commas.

The Y2DataFields property, when populated with data, is the same as the Y2Data property.

Default value for the Y2DataFields property is an empty string ("").

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.AxesChart.Y2GridLabelBrushes Property

AxesChart.Y2GridLabelBrushes Property

Gets or sets the brushes for drawing labels at the Y2-axis in custom grids.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection Y2GridLabelBrushes { get; set; }
Visual Basic

Public Property Y2GridLabelBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

Grid labels are drawn when the GridType is GridType.Custom and HorGridPoints and Y2Data are not empty. The labels are set wtih Y2GridLabels. They are drawn either at the grid lines or in the middle of the grid segments - use GridLabelsAtLines to set this.

If the brushes are less than the grid labels, the control cycles through them. If no brushes are set, the Y2AxisSettings.LabelBrush is used.

Default value for the Y2GridLabelBrushes property is an empty BrushCollection.

See Also

Y2Data
Y2GridLabels
HorGridPoints
AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.Y2GridLabels Property

AxesChart.Y2GridLabels Property

Gets or sets the labels drawn at the Y2-axis in custom grids.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList Y2GridLabels { get; set; }
Visual Basic

Public Property Y2GridLabels As IList

Property Value

An instance of type .NET IList that holds the labels.

Remarks

Y2GridLabels are drawn when the GridType is GridType.Custom, the HorGridPoints and Y2Data properties are not empty lists. The labels are drawn at grid lines or in the middle of the grid segments as stated by the GridLabelsAtLines property.

When the brushes are less than the labels, they are used in cycle. If no brushes are set, Y2AxisSettings.LabelBrush is used instead.

Default value of Y2GridLabels is an empty IList.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.Y2Labels Property

AxesChart.Y2Labels Property

Gets or sets custom labels for the second Y-axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList Y2Labels { get; set; }
Visual Basic

Public Property Y2Labels As IList

Property Value

An instance .NET IList class that holds other lists with labels.

Remarks

Custom labels are drawn when the Y2AxisSettings.AxiLabelsType property is set to AxisLabelType.CustomText. Second Y-axis is drawn when the Y2Data property is not an empty list.

When there are more than one series of Y2Data, the labels are drawn in column. The distance between the columns is set with Y2AxisSettings.LabelSpan. The offset of the first label column to the Y2-axis is set with Y2AxisSettings.LabelOffset.

The labels can be of any data type - numbers, strings and so on. The control converts automatically the data into strings. The labels are drawn with the LabelBrush; the font is set with LabelFont.

Default value for the Y2Labels property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.Y2LabelsFields Property

AxesChart.Y2LabelsFields Property

Gets or sets the field in the data source when the data for the Y2 - chart labels is derived from a database.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string Y2LabelsFields { get; set; }
Visual Basic

Public Property Y2LabelsFields As String

Property Value

A string that specifies the name of the data source field used as Y2-labels.

Remarks

The property enables you to bind the data used for drawing custom text as Y2 - labels for to columns in a database, which contain text. The data source object is specified with the DataSource property. If it is of type DataSet you can use the DataMember property to specify a given table as source for the chart data. In this case the fields of the table appear as items in the drop down combo box in the Y2LabelsFields property of the line control.

If you want to add more than one table field as labels for the chart you should separate the names with commas.

The Y2LabelsFields property, when populated with data, is the same as the Y2Labels property.

Default value for the Y2LabelsFields property is an empty string ("").

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.AxesChart.YAxisSettings Property

AxesChart.YAxisSettings Property

Gets or set the appearance settings for the Y-axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public AxisSettings YAxisSettings { get; }
Visual Basic

Public ReadOnly Property YAxisSettings As AxisSettings

Property Value

An instance of type MindFusion.Charting.AxisSettings class.

Remarks

The property specifies all appearance characteristics of the Y-axis: number format, distance between labels and their rotation angle, minimum and maximum axis value, label suffix and prefix, date and time values, division coefficient and so on.

For information about the axis properties and their default values, please check the AxisSettings class.

Default value for the YAxisSettings property is a new AxisSettings object. You can access it directly through the YAxisSettings property.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.YGridLabelBrushes Property

AxesChart.YGridLabelBrushes Property

Gets or sets the brushes for drawing custom grid labels at the Y-axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection YGridLabelBrushes { get; set; }
Visual Basic

Public Property YGridLabelBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

The property specifies the brushes for drawing custom grid labels at the Y-axis. If the BrushCollection is empty, YAxisSettings.LabelBrush is used for drawing the grid labels. The property is used only when the GridType is set to GridType.Custom and HorGridPoints is not an empty list. The labels are set with YGridLabels.

If the brushes are less than the grid labels, the control uses them in a cycle.

Default value for the YGridLabelBrushes property is an empty BrushCollection.

See Also

YGridLabels
HorGridPoints
AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.YGridLabels Property

AxesChart.YGridLabels Property

Gets or sets custom grid labels at the Y-axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList YGridLabels { get; set; }
Visual Basic

Public Property YGridLabels As IList

Property Value

An object of type .NET IList that holds the labels.

Remarks

Custom grid labels are drawn when the GridType is set to GridType.Custom. They can be drawn at grid lines or in the middle of grid segments - it depends on the GridLabelsAtLines property. The position of the grid lines is specified with the HorGridPoints property. The orientation of the grid labels is set with YGridLabelsOrientation.

The labels can be drawn with pointers as specified by the GridLabelPointer property.

Default value for the YGridLabels property is an empty IList.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.YLabels Property

AxesChart.YLabels Property

Gets or sets the list of labels displayed along the Y axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList YLabels { get; set; }
Visual Basic

Public Property YLabels As IList

Property Value

An object of type .NET IList class that holds other lists with labels.

Remarks

The property is a list that holds other lists with the labels. Custom labels are drawn at the Y-axis when the LabelType property of the YAxisSettings object is set to CustomText. The labels can be of any format, the control always converts them to strings.

The labels are drawn in a column, which offset to the Y-axis is set with LabelOffset. When labels for multiple series are drawn, each series has its own column. The space among them is set with LabelsSpan.

Each labels column can be drawn in the color of the chart graphics it refers to by setting the MultiColoredLabels property to true. If the count of labels for a given series is less than the count of data values the control fills the missing label members with empty strings.

Default value for the YLabels property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.AxesChart.YLabelsFields Property

AxesChart.YLabelsFields Property

Gets or sets the field of the data source used to populate the YLabels array.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string YLabelsFields { get; set; }
Visual Basic

Public Property YLabelsFields As String

Property Value

A string that specifies the name of the data source field used as Y labels.

Remarks

The property enables you to bind the data used for drawing custom text as Y - labels for line charts to columns in a database, which contain text. The data source object is specified with the DataSource property. If it is of type DataSet you can use the DataMember property to specify a given table as source for the chart data. In this case, the fields of the table appear as items in the drop down combo box in the YLabelsFields property of the chart control.

If you want to add more than one table field as labels for the chart you should separate the names with commas.

The YLabelsFields property, when populated with data, is the same as the YLabels property.

Default value for the YLabelsFields property is an empty string ("").

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.BarChart Class

BarChart Class
Remarks See Also

A class for drawing bar charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public class BarChart : AxesChart, ISupportInitialize
Visual Basic

Public Class BarChart
Inherits AxesChart
Implements ISupportInitialize

Remarks

BarChart inherits properties and methods from its base class AxesChart.

The class is used for drawing all types of bar charts - flat (2D charts) as well with 3D visual effect. The different bar types are listed as members of the BarType Enumeration. You can set the type of the bar chart with the BarType property. The Cylinder property enables you to draw the data as cylinders instead of bars.

The data for the bar chart is set with Data, which is used for calculating the height of the bars. The data can be numbers, or in any other format that can be parsed to numbers.

The orientation of the chart is set with the Horizontal property. The layout of bars in multiple series is set with BarSeriesLayout.

You can change the offset between the first bar and the beginning of the axis Offset. The distance between the bars - both horizontal and vertical - can be specified with DistBtwBars. BarWidth regulates the thickness of bars. Distance between bar series is specified with DistBtwSeries.

Bars can have labels inside and / or at the top. The type of the labels is set with InnerLabelType and TopLabelType. Custom labels are specified with InnerLabels and TopLabels. The position of the inner label inside the bar is set with InnerLabelAlignment.

Top labels can be rotated and drawn with offset from the edge of the bars as specified by the TopLabelRotAngle and TopLabelOffset properties. Use ClusterLabels if you want to draw a label at each cluster or group of bars.

The bar chart can be drawn with a grid, which type is set with the GridType property. The width of crossed grids is set with GridWidth. The grid can be drawn with stripes. The brushes for them are specified with GridBrush and AltGridBrush. Custom-set grid points are also possible.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Charting.WinForms.Chart
MindFusion.Charting.WinForms.AxesChart
MindFusion.Charting.WinForms.BarChart

See Also

BarChart Members
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart Members

BarChart Members
Constructors Properties Methods

A class for drawing bar charts.

The following tables list the members exposed by the BarChart type.

Public Constructors

Name | Description
BarChart | Creates a new instance of the BarChart class.

Public Properties

Name | Description
BarSeriesLayout | Gets or sets the layout of bars in multi-series charts.
BarType | Gets or sets the type of the bar chart to be drawn.
BarWidth | Gets or sets the thickness of chart bars.
ClusterLabels | Gets or sets custom labels for clustered bar charts.
ClusterLabelsField | Gets or sets the database field(s), which values are used as labels for bar clusters.
Cylinder | Gets or sets whether bars are drawn as cylinders.
CylinderTension | Gets or sets the tension of chart cylinders.
Data | Gets or sets the numerical data used for calculating the height of chart bars.
DataFields | Gets or sets the database field(s), which values are used as data for the bar chart.
DistBtwBars | Gets or sets the distance between bars in a bar chart.
InnerLabelAlignment | Gets or sets the alignment of labels inside bars.
InnerLabelBackground | Gets or sets the brush for filling the background of inner labels when drawn with border.
InnerLabelBorder | Gets or sets the border drawn around inner labels.
InnerLabelFormat | Gets or sets the format of labels displayed inside chart bars.
InnerLabelMargin | Gets or sets the margin between each inner label and its border.
InnerLabelOutline | Gets or sets the pen for drawing the outline of inner labels when drawn with border.
InnerLabels | Gets or sets the labels drawn inside bars.
InnerLabelsFields | Gets or sets the database fields, which values are used as labels inside chart bars.
InnerLabelType | Gets or sets the type of labels drawn inside chart bars.
TopLabelBackground | Gets or sets the brush for filling the background of top labels when drawn with border.
TopLabelBorder | Gets or sets the border drawn around top labels.
TopLabelFormat | Gets or sets the format of labels displayed at the top of chart bars.
TopLabelMargin | Gets or sets the margin between each top label and its border.
TopLabelOffset | Gets or sets the offset of the top label to the edge of the bar.
TopLabelOutline | Gets or sets the pen for drawing the outline of top labels when drawn with border.
TopLabelRotAngle | Gets or sets the rotation angle of labels at the top of vertical chart bars.
TopLabels | Gets or sets custom labels drawn at the top of chart bars.
TopLabelsFields | Gets or sets the database fields, which values are used as labels at the top of chart bars.
TopLabelType | Gets or sets the type of labels drawn at the top of chart bars.

Public Methods

Name | Description
BeginInit | Begins the run-time initialization of an instance of the BarChart class that is used on a form or by another component.
EndInit | Ends the run-time initialization of an instance of the BarChart class that is used on a form or by another component.

See Also

BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart Constructor

BarChart Constructor

Creates a new instance of the BarChart class.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BarChart ()
Visual Basic

Public Sub New ()

See Also

BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart Methods

BarChart Methods

Public Methods

Name | Description
BeginInit | Begins the run-time initialization of an instance of the BarChart class that is used on a form or by another component.
EndInit | Ends the run-time initialization of an instance of the BarChart class that is used on a form or by another component.

See Also

BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.BeginInit Method

BarChart.BeginInit Method

Begins the run-time initialization of an instance of the BarChart class that is used on a form or by another component.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void BeginInit ()
Visual Basic

Public Sub BeginInit ()

Remarks

The Visual Studio .NET design environment uses this method to start the initialization of the BarChart component that is used on a form or by another component. The EndInit method ends the initialization. Using the BeginInit and EndInit methods prevents the control from being used before it is fully initialized.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.EndInit Method

BarChart.EndInit Method

Ends the run-time initialization of an instance of the BarChart class that is used on a form or by another component.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void EndInit ()
Visual Basic

Public Sub EndInit ()

Remarks

The Visual Studio .NET design environment uses this method to end the initialization of a component that is used on a form or by another component. The BeginInit method starts the initialization. Using the BeginInit and EndInit methods prevents the control from being used before it is fully initialized.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart Properties

BarChart Properties

Public Properties

Name | Description
BarSeriesLayout | Gets or sets the layout of bars in multi-series charts.
BarType | Gets or sets the type of the bar chart to be drawn.
BarWidth | Gets or sets the thickness of chart bars.
ClusterLabels | Gets or sets custom labels for clustered bar charts.
ClusterLabelsField | Gets or sets the database field(s), which values are used as labels for bar clusters.
Cylinder | Gets or sets whether bars are drawn as cylinders.
CylinderTension | Gets or sets the tension of chart cylinders.
Data | Gets or sets the numerical data used for calculating the height of chart bars.
DataFields | Gets or sets the database field(s), which values are used as data for the bar chart.
DistBtwBars | Gets or sets the distance between bars in a bar chart.
InnerLabelAlignment | Gets or sets the alignment of labels inside bars.
InnerLabelBackground | Gets or sets the brush for filling the background of inner labels when drawn with border.
InnerLabelBorder | Gets or sets the border drawn around inner labels.
InnerLabelFormat | Gets or sets the format of labels displayed inside chart bars.
InnerLabelMargin | Gets or sets the margin between each inner label and its border.
InnerLabelOutline | Gets or sets the pen for drawing the outline of inner labels when drawn with border.
InnerLabels | Gets or sets the labels drawn inside bars.
InnerLabelsFields | Gets or sets the database fields, which values are used as labels inside chart bars.
InnerLabelType | Gets or sets the type of labels drawn inside chart bars.
TopLabelBackground | Gets or sets the brush for filling the background of top labels when drawn with border.
TopLabelBorder | Gets or sets the border drawn around top labels.
TopLabelFormat | Gets or sets the format of labels displayed at the top of chart bars.
TopLabelMargin | Gets or sets the margin between each top label and its border.
TopLabelOffset | Gets or sets the offset of the top label to the edge of the bar.
TopLabelOutline | Gets or sets the pen for drawing the outline of top labels when drawn with border.
TopLabelRotAngle | Gets or sets the rotation angle of labels at the top of vertical chart bars.
TopLabels | Gets or sets custom labels drawn at the top of chart bars.
TopLabelsFields | Gets or sets the database fields, which values are used as labels at the top of chart bars.
TopLabelType | Gets or sets the type of labels drawn at the top of chart bars.

See Also

BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.BarSeriesLayout Property

BarChart.BarSeriesLayout Property

Gets or sets the layout of bars in multi-series charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BarSeriesLayout BarSeriesLayout { get; set; }
Visual Basic

Public Property BarSeriesLayout As BarSeriesLayout

Property Value

One of the BarSeriesLayout Enumeration values.

Remarks

The property specifies the layout of bars in multi-series charts. Multi - series charts are drawn when BarType is set to Clustered2D/3D or Groups2D/3D. Data for the bar series is set with Data.

Default value of the BarSeriesLayout property is BarSeriesLayout.InRow.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.BarType Property

BarChart.BarType Property

Gets or sets the type of the bar chart to be drawn.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BarType BarType { get; set; }
Visual Basic

Public Property BarType As BarType

Property Value

One of the BarType Enumeration values.

Remarks

The layout of bars in multi-series charts is set with BarSeriesLayout. Multi-series charts are drawn when BarType is set to BarType.Groups or BarType.Clustered.

Check the BarType enumeration members for additional information what types of bars can be created. Find detailed information how data for the bar chart is specified in the Data property.

Default value for the BarType property is BarType.Single3D.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.BarWidth Property

BarChart.BarWidth Property

Gets or sets the thickness of chart bars.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float BarWidth { get; set; }
Visual Basic

Public Property BarWidth As Single

Property Value

A float value that specifies the width of the bar, in points.

Remarks

The property specifies how thick/thin the chart bars are. The distance between the bars is set with DistBtwBars. If the bars are drawn in a group / cluster, the distance between the groups is set with DistBtwSeries.

If the distance between bars, bar width and distance between bar series (if any) are not set, they are calculated automatically according to the length of the axis, at which the bars are drawn.

Default value for the BarWidth property is 20f.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.ClusterLabels Property

BarChart.ClusterLabels Property

Gets or sets custom labels for clustered bar charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList ClusterLabels { get; set; }
Visual Basic

Public Property ClusterLabels As IList

Property Value

An object of type .NET IList that holds the labels.

Remarks

The property specifies custom labels for each bar cluster or data group. If the labels are less than the clusters, MindFusion.Charting adds empty strings. ClusterLabels are drawn when the label type for the axis at which the bars are drawn is AxisLabelType.CustomText.

Only one label is drawn at each bar cluster / data group. If the LabelType is AxisLabelType.CustomText and the ClusterLabels property is empty, MindFusion.Charting takes the labels from the XLabels or YLabels properties according to the chart's orientation. In this case, each bar has a label.

Cluster labels are considered only when the BarType is Clustered2D, Clustered3D, Groups2D or Groups3D.

Default value for the ClusterLabels property is an empty array.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.ClusterLabelsField Property

BarChart.ClusterLabelsField Property

Gets or sets the database field(s), which values are used as labels for bar clusters.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string ClusterLabelsField { get; set; }
Visual Basic

Public Property ClusterLabelsField As String

Property Value

A string that specifies the name(s) of the database field(s).

Remarks

The property enables you to bind the data used for drawing labels at bar clusters to a database field. The data source object is specified with the DataSource property. If it is of type DataSet, you can use the DataMember property to specify a particular table as source for the chart data. In this case, the fields of the table appear as items in the drop down combo box in the ClusterLabelsField property of the bar control.

The labels set with the ClusterLabelsField are drawn only if the LabelType field of the respective AxisSettings property is set to AxisLabelType.CustomText and the BarType is not BarType.Single2D or BarType.Single3D.

The ClusterLabelsField property, when populated with data, is the same as the ClusterLabels property.

Default value for the ClusterLabelsField property is an empty string ("").

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.BarChart.Cylinder Property

BarChart.Cylinder Property

Gets or sets whether bars are drawn as cylinders.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public bool Cylinder { get; set; }
Visual Basic

Public Property Cylinder As Boolean

Property Value

A bool value, true if bars are drawn as cylinders; otherwise false.

Remarks

Instances of the BarChart class can draw data not only as bars but also cylinders. The tension of the cylinders is specified with CylinderTension. All other chart settings remain the same as for bar charts.

Default value for the Cylinder property is false.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.CylinderTension Property

BarChart.CylinderTension Property

Gets or sets the tension of chart cylinders.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public int CylinderTension { get; set; }
Visual Basic

Public Property CylinderTension As Integer

Property Value

An int value that specifies the cylinder tension as percent from the length of the radius.

Remarks

Instances of the BarChart class can draw data not only as bars but also as cylinders. Cylinders are drawn when the Cylinder property is set to true. All other settings for the chart remain the same as for bar charts.

Default value for the CylinderTension property is 30.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.Data Property

BarChart.Data Property

Gets or sets the numerical data used for calculating the height of chart bars.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList Data { get; set; }
Visual Basic

Public Property Data As IList

Property Value

An instance of type .NET IList that holds other lists with numbers.

Remarks

Add lists with data to the property or assign to it a list that holds the data lists. The data can be numbers, or in any other format that can be parsed to numbers.

Each bar cluster is formed from data at the same position in the Data series. This means that the data for the first cluster will be taken from the elements at first position in the Data lists; the data for the second cluster - from the elements at second position in the Data lists and so on. The count of bars in the cluster is determined by the count of lists in the Data property. The count of the clusters is determined by the count of numbers in the longest list in Data.

Groups2D and Groups3D bar charts represent bars in a group. The data for each group is taken from the respective Data list. Thus, data for the first group is taken from all the numbers in the first list in the Data property. The count of values in the list determines the count of bars in the group. The count of lists in the Data property determines the count of the groups.

If the chart has summaries, the values are added as bars to each bar group. Summaries are added to the SummaryValues property.

Default value for the Data property is an empty list.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.DataFields Property

BarChart.DataFields Property

Gets or sets the database field(s), which values are used as data for the bar chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string DataFields { get; set; }
Visual Basic

Public Property DataFields As String

Property Value

A string that specifies the name(s) of the data field(s).

Remarks

The property enables you to bind the data used for calculating height of bars in bar charts to a numerical field in a database The data source object is specified with the DataSource property. If it is of type DataSet, you can use the DataMember property to specify a particular table as source for the chart data. In this case, the fields of the table appear as items in the drop down combo box in the DataFields property of the bar control. Use the comma as a separator in case you need to draw groups/clusters of bars and more than one database column must be selected.

The DataFields property, when populated with data, is the same as the Data property.

Default value for the DataFields property is an empty string ("").

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.BarChart.DistBtwBars Property

BarChart.DistBtwBars Property

Gets or sets the distance between bars in a bar chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float DistBtwBars { get; set; }
Visual Basic

Public Property DistBtwBars As Single

Property Value

A float value that specifies the distance between adjacent bars, in points.

Remarks

The property specifies the distance between bars - alone or in a group. The width of the bars is set with BarWidth. If the bars are drawn in clusters or groups, DistBtwSeries specifies the distance between the groups. The layout of the bars in groups is set with BarSeriesLayout.

If the bar width and the distance between the bars and bar groups/clusters is not set, the control calculates them automatically, according to the length of the axis, at which the bars are drawn. If it is also not set, the bars are drawn with width 20 and distance between them 10.

Default value for the DistBtwBars property is 10.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.InnerLabelAlignment Property

BarChart.InnerLabelAlignment Property

Gets or sets the alignment of labels inside bars.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public StringAlignment InnerLabelAlignment { get; set; }
Visual Basic

Public Property InnerLabelAlignment As StringAlignment

Property Value

One of .NET StringAlignment Enumeration values.

Remarks

The property specifies how labels inside bars are aligned. The StringAlignment.Near value indicates the label is aligned to the bottom of the bar. StringAlignment.Far aligns the label to the top of the bar, while with StringAlignment.Center the label is drawn in the center of the bar.

In order to draw labels inside bars, the InnerLabelType property should not be set to LabelType.Empty. Custom labels are set with the InnerLabels property.

Bars can also have labels at the top. Their type is set with TopLabelType.

Default value for the InnerLabelAlignment property is StringAlignment.Center.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.InnerLabelBackground Property

BarChart.InnerLabelBackground Property

Gets or sets the brush for filling the background of inner labels when drawn with border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush InnerLabelBackground { get; set; }
Visual Basic

Public Property InnerLabelBackground As Brush

Property Value

An instance of MindFusion.Drawing.Brush class.Default is a light blue SolidBrush.

Remarks

InnerLabelBorder specifies the border drawn around inner labels. The border rectangle is drawn with InnerLabelOutline. The space between the inner label and its border is set with InnerLabelMargin.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.InnerLabelBorder Property

BarChart.InnerLabelBorder Property

Gets or sets the border drawn around inner labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Border InnerLabelBorder { get; set; }
Visual Basic

Public Property InnerLabelBorder As Border

Property Value

One of the Border Enumeration values. Default is Border.None.

Remarks

The border rectangle is drawn with InnerLabelOutline and filled with InnerLabelBackground. The space between the inner label and its border is set with InnerLabelMargin.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.InnerLabelFormat Property

BarChart.InnerLabelFormat Property

Gets or sets the format of labels displayed inside chart bars.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public NumberFormat InnerLabelFormat { get; set; }
Visual Basic

Public Property InnerLabelFormat As NumberFormat

Property Value

One of NumberFormat Enumeration values.

Remarks

Use the property to specify how numbers drawn inside bars as labels are formatted. InnerLabelFormat is not considered if InnerLabelType is Empty or CustomText.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.InnerLabelMargin Property

BarChart.InnerLabelMargin Property

Gets or sets the margin between each inner label and its border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float InnerLabelMargin { get; set; }
Visual Basic

Public Property InnerLabelMargin As Single

Property Value

A float value. Default is 5f.

Remarks

InnerLabelBorder specifies the Border drawn around bar inner labels. The border rectangle is drawn with InnerLabelOutline and filled with InnerLabelBackground.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.InnerLabelOutline Property

BarChart.InnerLabelOutline Property

Gets or sets the pen for drawing the outline of inner labels when drawn with border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen InnerLabelOutline { get; set; }
Visual Basic

Public Property InnerLabelOutline As Pen

Property Value

An instance of type MindFusion.Drawing.Pen class. Default is a black Pen, width 1.

Remarks

Use InnerLabelBorder to specify the Border for bar inner labels. The label rectangle is filled with InnerLabelBackground. The space between the inner label and its border is set with InnerLabelMargin.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.InnerLabels Property

BarChart.InnerLabels Property

Gets or sets the labels drawn inside bars.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList InnerLabels { get; set; }
Visual Basic

Public Property InnerLabels As IList

Property Value

An object of type .NET IList that holds other lists with the labels.

Remarks

The property specifies the labels drawn inside chart bars when the inner label type is set to LabelType.CustomText. Add lists with the labels to the InnerLabels array. The control converts automatically any data to strings.

The data, specified with InnerLabels, is drawn only if the InnerLabelType property is LabelType.CustomText. InnerLabelAlignment sets the alignment of labels inside the bars. If the labels are less than the number of bars the control fills the missing positions with empty strings.

Bars can also have labels at the top. They are set with TopLabelType and TopLabels.

Default value for the InnerLabels property is an empty list.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.InnerLabelsFields Property

BarChart.InnerLabelsFields Property

Gets or sets the database fields, which values are used as labels inside chart bars.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string InnerLabelsFields { get; set; }
Visual Basic

Public Property InnerLabelsFields As String

Property Value

A string that specifies the name(s) of the database field(s).

Remarks

The property enables you to bind the data used for drawing labels inside bars in bar charts to a database field. The data source object is specified with the DataSource property. If it is of type DataSet, you can use the DataMember property to specify a particular table as source for the chart data. In this case, the fields of the table appear as items in the drop down combo box in the InnerLabelsField property of the bar control. Use the comma as a separator, when you want to draw groups/clusters of bars and more than one database column should be selected.

The labels set with InnerLabelsFields are drawn only if the InnerLabelType is set to LabelType.CustomText.

The InnerLabelsFields property, when populated with data, is the same as the InnerLabels property.

Default value for the InnerLabelsField property is an empty string ("").

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.BarChart.InnerLabelType Property

BarChart.InnerLabelType Property

Gets or sets the type of labels drawn inside chart bars.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public LabelType InnerLabelType { get; set; }
Visual Basic

Public Property InnerLabelType As LabelType

Property Value

One of the LabelType Enumeration values.

Remarks

The property specifies what type of labels are drawn inside chart bars. The formatting of the labels is the same as the formatting of the axis, at which the bars are drawn. For formatting and appearance options of the axis, please check the AxisSettings class.

If InnerLabelType is set to LabelType.CustomText, the inner labels are set with InnerLabels. The position of the label in the bar is set with the InnerLabelAlignment property.

Bars can also have labels at the top. They are set with TopLabelType and TopLabels.

Default value for the InnerLabelType property is LabelType.Empty, that is, no labels are drawn.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.TopLabelBackground Property

BarChart.TopLabelBackground Property

Gets or sets the brush for filling the background of top labels when drawn with border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush TopLabelBackground { get; set; }
Visual Basic

Public Property TopLabelBackground As Brush

Property Value

An instance of MindFusion.Drawing.Brush class. Default is a light blue SolidBrush.

Remarks

Use TopLabelBorder to set the type of Border drawn around top labels in bars. It is drawn with TopLabelOutline. The space between the top label and its border is set with TopLabelMargin.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.TopLabelBorder Property

BarChart.TopLabelBorder Property

Gets or sets the border drawn around top labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Border TopLabelBorder { get; set; }
Visual Basic

Public Property TopLabelBorder As Border

Property Value

One of the Border Enumeration values. Default value is Border.None.

Remarks

The border rectangle is drawn with TopLabelOutline and filled with TopLabelBackground. The space between the label and its border is set with TopLabelMargin.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.TopLabelFormat Property

BarChart.TopLabelFormat Property

Gets or sets the format of labels displayed at the top of chart bars.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public NumberFormat TopLabelFormat { get; set; }
Visual Basic

Public Property TopLabelFormat As NumberFormat

Property Value

One of NumberFormat Enumeration values.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.TopLabelMargin Property

BarChart.TopLabelMargin Property

Gets or sets the margin between each top label and its border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float TopLabelMargin { get; set; }
Visual Basic

Public Property TopLabelMargin As Single

Property Value

A float value. Default is 5f.

Remarks

Use TopLabelBorder to specify the Border draw around top labels. The border rectangle is drawn with TopLabelOutline and filled with TopLabelBackground.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.TopLabelOffset Property

BarChart.TopLabelOffset Property

Gets or sets the offset of the top label to the edge of the bar.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float TopLabelOffset { get; set; }
Visual Basic

Public Property TopLabelOffset As Single

Property Value

A float value that represents the offset of the label, in points.

Remarks

The property specifies at what distance labels at chart bars are drawn measured from the edge of the bar top. The offset is preserved no matter what the value of the TopLabelRotAngle is. Top labels are drawn when the TopLabelType property is not LabelType.Empty. Custom top labels are set with TopLabels.

Bars can also have inner labels. They are set with InnerLabelType and InnerLabels.

Default value for the TopLabelOffset property is 5f.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.TopLabelOutline Property

BarChart.TopLabelOutline Property

Gets or sets the pen for drawing the outline of top labels when drawn with border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen TopLabelOutline { get; set; }
Visual Basic

Public Property TopLabelOutline As Pen

Property Value

An instance of type MindFusion.Drawing.Pen class. Default is a black Pen, width 1.

Remarks

Use TopLabelBorder to specify the border drawn around top labels. The border rectangle is filled with TopLabelBackground. The space between the top label and its border is set with TopLabelMargin.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.TopLabelRotAngle Property

BarChart.TopLabelRotAngle Property

Gets or sets the rotation angle of labels at the top of vertical chart bars.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float TopLabelRotAngle { get; set; }
Visual Basic

Public Property TopLabelRotAngle As Single

Property Value

A float value that represents the rotation angle for the label, clockwise, in degrees.

Remarks

The property specifies the angle of rotation for labels at the top of the bars. When the TopLabelRotAngle property is set to 90, the labels are drawn vertically. If the TopLabelRotAngle is 0, the labels are drawn without any rotation, that is horizontally. Values between 0 and 90 rotate the text between absolutely vertical and absolutely horizontal.

The property is useful only for vertical bars. The top labels of horizontal bars are always drawn horizontally.

The type of top labels is set with the TopLabelType property. Custom top labels are specified with the TopLabels property.

Bars can also have inner labels. They are set with InnerLabelType and InnerLabels.

Default value for the TopLabelRotAngle property is 0.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.TopLabels Property

BarChart.TopLabels Property

Gets or sets custom labels drawn at the top of chart bars.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList TopLabels { get; set; }
Visual Basic

Public Property TopLabels As IList

Property Value

An object of type .NET IList that holds other lists with labels.

Remarks

The property specifies the labels drawn at the top of chart bars when the top label type is set to LabelType.CustomText. Data to be drawn can be added directly to the TopLabels array. The control converts automatically any data to strings.

If the labels are less than the number of bars the control fills the missing positions with empty strings.

Bars can also have inner labels. They are set with InnerLabelType and InnerLabels.

Default value for the TopLabels property is an empty array object.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.BarChart.TopLabelsFields Property

BarChart.TopLabelsFields Property

Gets or sets the database fields, which values are used as labels at the top of chart bars.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string TopLabelsFields { get; set; }
Visual Basic

Public Property TopLabelsFields As String

Property Value

A string that specifies the name(s) of the database field(s).

Remarks

The property enables you to bind the data used for drawing labels at the top of bars in bar charts to a database field. The data source object is specified with the DataSource property. If it is of type DataSet you can use the DataMember property to specify a given table as source for the chart data. In this case, the fields of the table appear as items in the drop down combo box in the TopLabelsFields property of the bar control. Use the comma as a separator in case you need to draw groups/clusters of bars and more than one database column should be selected.

The labels set with the TopLabelsFields are drawn only if the TopLabelType is set to LabelType.CustomText. You can specify a rotation angle, with which the labels are drawn with the TopLabelRotAngle property. Offset for the labels from the edge of the bar is set with TopLabelOffset.

The TopLabelsFields property, when populated with data, is the same as the TopLabels property.
Bars can also have inner labels. They are set with InnerLabelType and InnerLabels.

Default value for the TopLabelsFields property is an empty string ("").

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.BarChart.TopLabelType Property

BarChart.TopLabelType Property

Gets or sets the type of labels drawn at the top of chart bars.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public LabelType TopLabelType { get; set; }
Visual Basic

Public Property TopLabelType As LabelType

Property Value

One of the LabelType Enumeration values.

Remarks

The property specifies what labels are drawn at the top of chart bars. For appearance, format and style settings, please check the AxisSettings class. The style settings for vertical bars are regulated by XAxisSettings, the style settings for horizontal bars - by YAxisSettings.

The custom text for the top labels is set with the TopLabels property.

Bars can also have inner labels. They are set with InnerLabelType and InnerLabels.

Default value for the TopLabelType property is LabelType.Empty, in this case, no labels are drawn.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart Class

Chart Class
Remarks See Also

Base class for all chart types - bars, pies, areas, lines, or radars.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public abstract class Chart : Control
Visual Basic

Public MustInherit Class Chart
Inherits Control

Remarks

This class is the base class for all chart types - bar, pie, lines and radar and all their modifications - scatter, cylinder, polar and so on. It provides methods, properties and events for supplying data for drawing the chart and setting different chart customization options.

Each chart type has its own properties for setting the data. The chart series are drawn in the order the data for them is set. If you want to sort the series relatively to each other, use the SortSeriesBy property. SortOrder sorts the numbers in each series. Use ClearData to remove all data and labels from the chart.

ChartBrushes sets the brushes used for drawing all chart types. ChartPens property defines the pens, used for drawing the charts.

The font and brush for the chart labels are specified with the LabelFont and LabelBrush properties.

All charts can have a title and a subtitle. They are set with TitleText and SubTitleText. TitleFont, TitleBrush, SubTitleFont and SubTitleBrush properties specify the font and brush for the title and the subtitle. The TextRenderingHint property sets the quality of rendering for the chart texts.

The chart background is painted with the BackgroundBrush property.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Charting.WinForms.Chart

See Also

Chart Members
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart Members

Chart Members
Constructors Properties Methods

Base class for all chart types - bars, pies, areas, lines, or radars.

The following tables list the members exposed by the Chart type.

Protected Constructors

Name | Description
Chart | Creates a new instance of the Chart class.

Public Properties

Name | Description
BackColor | Gets or sets the background color for the Chart control.
BackgroundBrush | Specifies the brush for the chart background.
BkgrImagePos | gets or sets the position and alignment of the chart background image.
ChartBrushes | Specifies the brushes used to draw the charts.
ChartImage | Gets or sets the image drawn as background for the chart's plot area.
ChartImagePos | Gets or sets the position of the image drawn as background of the chart's plot area.
ChartMargins | Gets or sets the margins around the chart.
ChartPens | Specifies the pens for the charts.
ChartSize | Gets the size of the chart.
DataMember | Gets or sets the table used for data binding when the data source is set to a DataSet object.
DataSource | Gets or sets a data source containing the values to be drawn.
LabelBrush | Specifies the brush that is used for drawing chart labels.
LabelFont | Specifies the font for drawing the chart labels.
LegendAlignment | Gets or sets the alignment of the legend.
LegendBackgroundBrush | Gets or sets the legend background brush.
LegendBorder | Gets or sets the type of the legend border.
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels.
LegendBrush | Gets or sets the brush for the legend's bounding rectangle.
LegendColumns | Gets or sets the count of columns in the chart legend.
LegendFont | Gets or sets the font for the chart legend.
LegendGridType | Gets or sets the type of the legend grid.
LegendLabels | Gets or sets the labels for the legend.
LegendOffset | Gets or sets the offset of the chart legend.
LegendPen | Gets or sets the pen for the legend's bounding rectangle.
LegendPosition | Gets or sets the position of the chart legend.
LegendWidth | Gets or sets the width of the legend's rectangle.
LegendWordWrap | Gets or sets whether the words of the legend labels are wrapped.
MultiColored | Specifies whether the chart is drawn in one color or in different colors.
MultiColoredLabels | Specifies whether labels at the chart axes are drawn in different colors.
ResizeType | Gets or sets how the chart image is positioned in the control area.
SortOrder | Specifies the sort order of numbers in chart series.
SortSeriesBy | Specifies the sort order of data series.
SubTitleBrush | Specifies the brush that is used for drawing the chart subtitle.
SubTitleFont | Specifies the font, which is used to draw the chart subtitle.
SubTitleOffset | Gets or sets the offset of the subtitle.
SubTitleText | Specifies the text for the chart subtitle.
TextRenderingHint | Specifies the quality, with which text is rendered.
TitleBrush | Specifies the brush that is used to draw the chart title.
TitleFont | Specifies the font, which is used to draw the chart title.
TitleOffset | Gets or sets the offset of the title.
TitleText | Specifies the text for the chart title.

ProtectedProperties

Name | Description
DefaultSize | The initial size of the control when it is dropped into a form.

Public Methods

Name | Description
ClearData | Removes all labels and numerical data from the chart.
CreateBitmap | Creates a GDI+ bitmap image representing the chart.
CreateMetafile | Creates a WMF image containing the chart.
DataBind | Binds the chart to the data source set in DataSource and DataMember.
HitTest | Checks whether a point with the particular coordinates is contained inside a chart element.
UpdateScrollBars | Updates the scrollbar ranges so they correspond to the chart size.

Protected Methods

Name | Description
Finalize | Destructor.
IsEmptyList | Checks when a list has no members
OnLayout | Control.OnLayout override.
OnPaint | Control.OnPaint override.
OnPaintBackground | Control.OnPainBackground override.
OnResize | Control.OnResize override.
UpdateChart | Overloaded. Redraws the chart.

See Also

Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart Constructor

Chart Constructor

Creates a new instance of the Chart class.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

protected Chart ()
Visual Basic

Protected Sub New ()

See Also

Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart Methods

Chart Methods

Public Methods

Name | Description
ClearData | Removes all labels and numerical data from the chart.
CreateBitmap | Creates a GDI+ bitmap image representing the chart.
CreateMetafile | Creates a WMF image containing the chart.
DataBind | Binds the chart to the data source set in DataSource and DataMember.
HitTest | Checks whether a point with the particular coordinates is contained inside a chart element.
UpdateScrollBars | Updates the scrollbar ranges so they correspond to the chart size.

Protected Methods

Name | Description
Finalize | Destructor.
IsEmptyList | Checks when a list has no members
OnLayout | Control.OnLayout override.
OnPaint | Control.OnPaint override.
OnPaintBackground | Control.OnPainBackground override.
OnResize | Control.OnResize override.
UpdateChart | Overloaded. Redraws the chart.

See Also

Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.ClearData Method

Chart.ClearData Method

Removes all labels and numerical data from the chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void ClearData ()
Visual Basic

Public Sub ClearData ()

Remarks

The method removes any data that has been set to the chart. If the LabelType of a chart axis is AxisLabelType.AutoScale, the scale labels remain. Labels of any other type are cleared.

Data is removed from the XData, YData, Y2Data, Data, XLabels, YLabels and Y2Labels properties. The inner and top labels of bar charts are also removed; the labels for radar charts are removed too. The proportions of the chart are left - the length of the axis, the radius and so on.

If the chart has a legend, the LegendLabels are also cleared. Any title, subtitle, brushes and pens are left.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.CreateBitmap Method

Chart.CreateBitmap Method

Creates a GDI+ bitmap image representing the chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Image CreateBitmap ()
Visual Basic

Public Function CreateBitmap () As Image

Return Value

An instance of type .NET Image class.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.CreateMetafile Method

Chart.CreateMetafile Method

Creates a WMF image containing the chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Metafile CreateMetafile ()
Visual Basic

Public Function CreateMetafile () As Metafile

Return Value

A .NET Metafile ojbect.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.DataBind Method

Chart.DataBind Method

Binds the chart to the data source set in DataSource and DataMember.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void DataBind ()
Visual Basic

Public Sub DataBind ()

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.Finalize Method

Chart.Finalize Method

Destructor.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

protected virtual void Finalize ()
Visual Basic

Protected Overridable Sub Finalize ()

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.HitTest Method

Chart.HitTest Method

Checks whether a point with the particular coordinates is contained inside a chart element.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Object HitTest (
int x,
int y
)
Visual Basic

Public Function HitTest ( _
x As Integer, _
y As Integer _
) As Object

Parameters

x

The X - coordinate of the element to get.

y
The Y - coordinate of the element to get.

Return Value

The index of the element; -1 if none;

Remarks

Call this method inside event handlers for user interaction with the mouse. The mouse coordinates are retrieved from the event data.

The Chart control overrides HitTest to return a specific chart element. Cast the result to Bar, Line, Scatter, Bubble, PiePiece or RadarPiece according to the chart type you are using. All HitTest methods may return null so always check.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.IsEmptyList Method

Chart.IsEmptyList Method

Checks when a list has no members

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

protected bool IsEmptyList (
IList list
)
Visual Basic

Protected Function IsEmptyList ( _
list As IList _
) As Boolean

Parameters

list
The list to check

Return Value

true if the list is empty; otherwise false;

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.OnLayout Method

Chart.OnLayout Method

Control.OnLayout override.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

protected virtual void OnLayout (
LayoutEventArgs e
)
Visual Basic

Protected Overridable Sub OnLayout ( _
e As LayoutEventArgs _
)

Parameters

e
A LayoutEventArgs that contains the event data.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.OnPaint Method

Chart.OnPaint Method

Control.OnPaint override.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

protected virtual void OnPaint (
PaintEventArgs pe
)
Visual Basic

Protected Overridable Sub OnPaint ( _
pe As PaintEventArgs _
)

Parameters

pe

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.OnPaintBackground Method

Chart.OnPaintBackground Method

Control.OnPainBackground override.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

protected virtual void OnPaintBackground (
PaintEventArgs pe
)
Visual Basic

Protected Overridable Sub OnPaintBackground ( _
pe As PaintEventArgs _
)

Parameters

pe

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.OnResize Method

Chart.OnResize Method

Control.OnResize override.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

protected virtual void OnResize (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnResize ( _
e As EventArgs _
)

Parameters

e

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.UpdateChart Method

Chart.UpdateChart Method

Redraws the chart.

Overload List

Name | Description
Chart.UpdateChart () | Redraws the chart. Call this method to redraw the chart after changing the data value arrays.
Chart.UpdateChart (SizeF) | Redraws the chart. Call this method to redraw the chart after changing the data value arrays.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.UpdateChart Method ()

Chart.UpdateChart Method ()
See Also

Redraws the chart. Call this method to redraw the chart after changing the data value arrays.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void UpdateChart ()
Visual Basic

Public Sub UpdateChart ()

See Also

UpdateChart Method Overload List
Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.UpdateChart Method (SizeF)

Chart.UpdateChart Method (SizeF)
See Also

Redraws the chart. Call this method to redraw the chart after changing the data value arrays.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

protected void UpdateChart (
SizeF size
)
Visual Basic

Protected Sub UpdateChart ( _
size As SizeF _
)

Parameters

size
The size of the new chart

See Also

UpdateChart Method Overload List
Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.UpdateScrollBars Method

Chart.UpdateScrollBars Method

Updates the scrollbar ranges so they correspond to the chart size.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void UpdateScrollBars ()
Visual Basic

Public Sub UpdateScrollBars ()

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart Properties

Chart Properties

Public Properties

Name | Description
BackColor | Gets or sets the background color for the Chart control.
BackgroundBrush | Specifies the brush for the chart background.
BkgrImagePos | gets or sets the position and alignment of the chart background image.
ChartBrushes | Specifies the brushes used to draw the charts.
ChartImage | Gets or sets the image drawn as background for the chart's plot area.
ChartImagePos | Gets or sets the position of the image drawn as background of the chart's plot area.
ChartMargins | Gets or sets the margins around the chart.
ChartPens | Specifies the pens for the charts.
ChartSize | Gets the size of the chart.
DataMember | Gets or sets the table used for data binding when the data source is set to a DataSet object.
DataSource | Gets or sets a data source containing the values to be drawn.
LabelBrush | Specifies the brush that is used for drawing chart labels.
LabelFont | Specifies the font for drawing the chart labels.
LegendAlignment | Gets or sets the alignment of the legend.
LegendBackgroundBrush | Gets or sets the legend background brush.
LegendBorder | Gets or sets the type of the legend border.
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels.
LegendBrush | Gets or sets the brush for the legend's bounding rectangle.
LegendColumns | Gets or sets the count of columns in the chart legend.
LegendFont | Gets or sets the font for the chart legend.
LegendGridType | Gets or sets the type of the legend grid.
LegendLabels | Gets or sets the labels for the legend.
LegendOffset | Gets or sets the offset of the chart legend.
LegendPen | Gets or sets the pen for the legend's bounding rectangle.
LegendPosition | Gets or sets the position of the chart legend.
LegendWidth | Gets or sets the width of the legend's rectangle.
LegendWordWrap | Gets or sets whether the words of the legend labels are wrapped.
MultiColored | Specifies whether the chart is drawn in one color or in different colors.
MultiColoredLabels | Specifies whether labels at the chart axes are drawn in different colors.
ResizeType | Gets or sets how the chart image is positioned in the control area.
SortOrder | Specifies the sort order of numbers in chart series.
SortSeriesBy | Specifies the sort order of data series.
SubTitleBrush | Specifies the brush that is used for drawing the chart subtitle.
SubTitleFont | Specifies the font, which is used to draw the chart subtitle.
SubTitleOffset | Gets or sets the offset of the subtitle.
SubTitleText | Specifies the text for the chart subtitle.
TextRenderingHint | Specifies the quality, with which text is rendered.
TitleBrush | Specifies the brush that is used to draw the chart title.
TitleFont | Specifies the font, which is used to draw the chart title.
TitleOffset | Gets or sets the offset of the title.
TitleText | Specifies the text for the chart title.

ProtectedProperties

Name | Description
DefaultSize | The initial size of the control when it is dropped into a form.

See Also

Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.BackColor Property

Chart.BackColor Property

Gets or sets the background color for the Chart control.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public override Color BackColor { get; set; }
Visual Basic

Public Overrides Property BackColor As Color

Property Value

An instance of .NET Color structure that represents the background color of the control.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.BackgroundBrush Property

Chart.BackgroundBrush Property

Specifies the brush for the chart background.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush BackgroundBrush { get; set; }
Visual Basic

Public Property BackgroundBrush As Brush

Property Value

An instance of type MindFusion.Drawing.Brush class.

Remarks

The property specifies the brush for the entire chart background. If the chart is drawn in a graphics, bigger than its size the background brush paints only the background of the chart bounding rectangle and not the whole graphics.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.BkgrImagePos Property

Chart.BkgrImagePos Property

gets or sets the position and alignment of the chart background image.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public ImagePos BkgrImagePos { get; set; }
Visual Basic

Public Property BkgrImagePos As ImagePos

Property Value

One of the ImagePos Enumeration values.

Remarks

The property specifies how background images are aligned and positioned in the chart's drawing rectangle. If the background image leaves some area of the chart background uncovered, it is painted with the BackgroundBrush.

The background image is specified with the .NET Control.BackgroundImage property.

If the image position is ImagePos.Scroll and the ResizeType property of the chart is not ResizeType.Scrollable the background image is not scrolled.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.ChartBrushes Property

Chart.ChartBrushes Property

Specifies the brushes used to draw the charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection ChartBrushes { get; set; }
Visual Basic

Public Property ChartBrushes As BrushCollection

Property Value

An instance of type MindFusion.Drawing.BrushCollection.

Remarks

The property is used for drawing of any type of chart. If the MultiColored property is set to true, the brushes are taken from the ChartBrushes list one after the other till all graphics or chart parts are drawn. If the brushes needed are more than the brushes specified, the control cycles through them as many times as necessary. Thus, in a bar chart, which is multicoloured and has 9 bars, but only 5 brushes are specified, the bars from 1 to 5 are filled with the 5 brushes specified, the 6th bar - with the first brush and so on. When the chart is not multi-colored, just the first brush is used for filling of all chart graphics or chart parts.

The ChartBrushes property also sets the colors of the small squares that are drawn in legends before each legend text. If the ChartPens are specified and the ChartBrushes is an empty list, then the control fills the ChartBrushes with solid brushes, which are the same color and count as the ChartPens. If the ChartBrushes are specified and the ChartPens is an empty list, then the chart pens are filled with Pen-s which are equal in count and color to the ChartBrushes and have default width 1.

You can fill the ChartBrushes list with all sorts of brushes, which are derived from the MindFusion.Drawing.Brush class - HatchBrush, SolidBrush and so on.

Default value for the ChartBrushes property is an empty IList.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.ChartImage Property

Chart.ChartImage Property

Gets or sets the image drawn as background for the chart's plot area.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Image ChartImage { get; set; }
Visual Basic

Public Property ChartImage As Image

Property Value

An instance of .NET System.Drawing.Image class.

Remarks

The property specifies the image used as chart background. The image can be drawn in different positions and styles as set by the ChartImagePos property. If the image does not cover all the plot area of the chart, it is painted with the ChartBackgroundBrush, if specified.

When the ChartImage and ChartBackgroundBrush are not specified, the plot area is drawn with the BackgroundBrush and BackgroundImage properties.

Default value for the ChartImage property is null.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.ChartImagePos Property

Chart.ChartImagePos Property

Gets or sets the position of the image drawn as background of the chart's plot area.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public ImagePos ChartImagePos { get; set; }
Visual Basic

Public Property ChartImagePos As ImagePos

Property Value

One of the ImagePos Enumeration values.

Remarks

The property specifies the position of the image drawn as background for the chart's plot area. The background image is set with ChartImage.

If parts of the chart plot area are not covered with the ChartImage, they are drawn with the ChartBackgroundBrush. If it is not specified, they are drawn with the BackgroundImage and BackgroundBrush.

Default value for the ChartImagePos property is ImagePos.Center.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.ChartMargins Property

Chart.ChartMargins Property

Gets or sets the margins around the chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Margins ChartMargins { get; set; }
Visual Basic

Public Property ChartMargins As Margins

Property Value

An instance of the Margins class. Default is Margins set to 10f at all four sides.

Remarks

Use the property to specify the space around the chart at all sides - left, top, right and bottom.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.ChartPens Property

Chart.ChartPens Property

Specifies the pens for the charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public PenCollection ChartPens { get; set; }
Visual Basic

Public Property ChartPens As PenCollection

Property Value

An instance of type MindFusion.Drawing.PenCollection class.

Remarks

The control uses ChartPens to draw line charts, area charts with outlining as well pie and doughnut charts.

If both the ChartPens and ChartBrushes properties are empty, the control uses a default white-blue gradient brush and a black pen.

If the ChartBrushes are specified and the ChartPens is an empty list, then the control fills the ChartPens with pens which are the same count and color as the chart brushes and with default width 1. If the chart pens are specified, the control fills the chart brushes with solid brushes, which are the same color and count as the pens.

Default value of the ChartPens property is an empty array.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.ChartSize Property

Chart.ChartSize Property

Gets the size of the chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public SizeF ChartSize { get; }
Visual Basic

Public ReadOnly Property ChartSize As SizeF

Property Value

A .NET SizeF instance.

Remarks

The property is read-only and specifies the size of the chart.

Note

If you access it before specifying all chart settings, the result might not be correct.

The property is meaningful when using the control programmatically. The size of the chart is calculated according to its data and customization options and cannot be changed. You can also use the CalculateSize method to calculate the dimensions of the chart's bounding rectangle.

The size of the chart does not change when the chart's TopLeftPosition property is changed.
Initial value for the ChartSize property is (0, 0).

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.DataMember Property

Chart.DataMember Property

Gets or sets the table used for data binding when the data source is set to a DataSet object.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string DataMember { get; set; }
Visual Basic

Public Property DataMember As String

Property Value

A string value specifying the data member.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace
Retrieving chart data from a database


MindFusion.Charting.WinForms.Chart.DataSource Property

Chart.DataSource Property

Gets or sets a data source containing the values to be drawn.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Object DataSource { get; set; }
Visual Basic

Public Property DataSource As Object

Property Value

An Object representing the data source.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace
DataBind Method
DataMember Property
Retrieving chart data from a database


MindFusion.Charting.WinForms.Chart.DefaultSize Property

Chart.DefaultSize Property

The initial size of the control when it is dropped into a form.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

protected virtual Size DefaultSize { get; }
Visual Basic

Protected Overridable ReadOnly Property DefaultSize As Size

Property Value

A .NET Size object that represents the default size of the control.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LabelBrush Property

Chart.LabelBrush Property

Specifies the brush that is used for drawing chart labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush LabelBrush { get; set; }
Visual Basic

Public Property LabelBrush As Brush

Property Value

An instance of MindFusion.Drawing.Brush class.

Remarks

The property is used to draw the labels in all chart types. It is used for inner and top labels in bar charts, for scatter labels in line charts, inner and outer labels in pie charts and for the outer labels in radars. The labels are drawn with LabelFont.

Default value for the LabelBrush property is a black SolidBrush.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LabelFont Property

Chart.LabelFont Property

Specifies the font for drawing the chart labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Font LabelFont { get; set; }
Visual Basic

Public Property LabelFont As Font

Property Value

An instance of type .NET Font class.

Remarks

The property specifies the font for the labels at both X and Y chart axes as well inside and outside pie pieces in pie charts.

LabelFont is also used for drawing the explanation label and the unit of measure at the chart axis, in case they are set.

Any text, drawn with the LabelFont uses the LabelBrush for the drawing.

Default value of the LabelFont property is Times New Roman, size 10.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendAlignment Property

Chart.LegendAlignment Property

Gets or sets the alignment of the legend.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Alignment LegendAlignment { get; set; }
Visual Basic

Public Property LegendAlignment As Alignment

Property Value

One of the Alignment Enumeration values.

Remarks

The LegendAlignment property specifies the alignment of the legend at the side of the chart that it is drawn at.

Chart legends are drawn when the LegendLabels property is not an empty array. The position of the chart legend is set with LegendPosition.

Default value for the LegendAlignment property is Alignment.Begin.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendBackgroundBrush Property

Chart.LegendBackgroundBrush Property

Gets or sets the legend background brush.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush LegendBackgroundBrush { get; set; }
Visual Basic

Public Property LegendBackgroundBrush As Brush

Property Value

An instance of type MindFusion.Drawing.Brush class.

Remarks

The LegendBackgroundBrush object is used for drawing the background of the chart's legend. The legend bounding rectangle is drawn with LegendPen.

A chart is drawn with a legend when the LegendLabels property is not an empty array.

Default value for the LegendBackgroundBrush property is null.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendBorder Property

Chart.LegendBorder Property

Gets or sets the type of the legend border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Border LegendBorder { get; set; }
Visual Basic

Public Property LegendBorder As Border

Property Value

One of the Border Enumeration values. Default is Border.Rectangle.

Remarks

The border rectangle is drawn with LegendPen and filled with LegendBackgroundBrush. The space between the border and the LegendLabels is set with LegendBorderMargin.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendBorderMargin Property

Chart.LegendBorderMargin Property

Gets or sets the margin between the legend border and the legend labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float LegendBorderMargin { get; set; }
Visual Basic

Public Property LegendBorderMargin As Single

Property Value

A float value. Default is 10f.

Remarks

The type of the border is set with LegendBorder. The border rectangle is drawn with LegendPen and filled with LegendBackgroundBrush.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendBrush Property

Chart.LegendBrush Property

Gets or sets the brush for the legend's bounding rectangle.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush LegendBrush { get; set; }
Visual Basic

Public Property LegendBrush As Brush

Property Value

An instance of type MindFusion.Drawing.Brush.

Remarks

The LegendBrush object is used for drawing the legend labels. Legend labels are set with the LegendLabels property. The count of columns in the legend is set with LegendColumns.
Default value for the LegendBrush property is a black SolidBrush.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendColumns Property

Chart.LegendColumns Property

Gets or sets the count of columns in the chart legend.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public int LegendColumns { get; set; }
Visual Basic

Public Property LegendColumns As Integer

Property Value

An int value that represents the count of columns. Default is 1.

Remarks

Legend is drawn when LegendLabels is not an empty list.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendFont Property

Chart.LegendFont Property

Gets or sets the font for the chart legend.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Font LegendFont { get; set; }
Visual Basic

Public Property LegendFont As Font

Property Value

An instance of .NET Font class.

Remarks

The property specifies the font for the legend labels. The height of the font sets the height of the squares before the legend labels. The labels are drawn with LegendBrush.

Legends are drawn when the LegendLabels property is not an empty array. The position of the legend and its alignment is specified with LegendPosition and LegendAlignment.

Default value for the LegendFont property is Times New Roman, 10.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendGridType Property

Chart.LegendGridType Property

Gets or sets the type of the legend grid.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public GridType LegendGridType { get; set; }
Visual Basic

Public Property LegendGridType As GridType

Property Value

One of the GridType Enumeration values.

Remarks

Legends can be drawn with a grid. The grid can separate the rows, columns or both. Legends cannot have custom or chess grids.

The grid is drawn with the LegendPen. Legend is drawn when the LegendLabels property is not an empty list.

Default value for the LegendGridType property is GridType.None.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendLabels Property

Chart.LegendLabels Property

Gets or sets the labels for the legend.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList LegendLabels { get; set; }
Visual Basic

Public Property LegendLabels As IList

Property Value

An object of type .NET IList class that holds the labels.

Remarks

Add the legend labels to the LegendLabels property or assign to it a list that holds the labels. If the labels are not strings, the control converts them automatically. Words can be kept whole if a label is drawn in multiple rows if you set LegendWordWrap to true.

The labels can be drawn in as many columns as set by LegendColumns properties. The labels are drawn with LegendBrush.

Default value for the LegendLabels property is an empty list.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendOffset Property

Chart.LegendOffset Property

Gets or sets the offset of the chart legend.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float LegendOffset { get; set; }
Visual Basic

Public Property LegendOffset As Single

Property Value

A float that represents the offset.

Remarks

The offset of the legend is considered from the edge of the legend to the nearest chart object - the plot area, chart labels or the chart axes.

The position of the legend is set with LegendPosition. Alignment is specified with LegendAlignment. Legend is drawn when the LegendLabels is not an empty list.

Default value for the LegendOffset property is 15f.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendPen Property

Chart.LegendPen Property

Gets or sets the pen for the legend's bounding rectangle.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen LegendPen { get; set; }
Visual Basic

Public Property LegendPen As Pen

Property Value

An instance of MindFusion.Drawing.Pen class.

Remarks

Legends can be drawn with an outlining. When the legend's bounding rectangle is drawn the pen is set with LegendPen. When the property is set to null, no legend's bounding rectangle is drawn.

The LegendPen is also used for drawing the legend grid. Legend grid is drawn when the LegendGridType property is not GridType.None. The columns of the legend labels can be set with LegendColumns.

Default value for the LegendPen property is a black pen, width 1.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendPosition Property

Chart.LegendPosition Property

Gets or sets the position of the chart legend.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Position LegendPosition { get; set; }
Visual Basic

Public Property LegendPosition As Position

Property Value

One of the Position Enumeration values.

Remarks

The property specifies the position of the chart legend at the chart's plot area. The alignment of the legend is set with LegendAlignment.

Legends are drawn when the LegendLabels property contains at least one list item with a label.

The labels can be drawn with an offset to the axes / plot area, at which it is drawn. Use LegendOffset to set the offset.

Default value for the LegendPosition property is Position.Right.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendWidth Property

Chart.LegendWidth Property

Gets or sets the width of the legend's rectangle.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float LegendWidth { get; set; }
Visual Basic

Public Property LegendWidth As Single

Property Value

A float value that specifies the width.

Remarks

When LegendWidth is set to float.NaN the control calculates automatically the width of the legend so that all LegendLabels could fit in without being broken into several lines.

When the LegendWidth is custom-set, the legend value is considered to include the LegendBorderMargin, the space for the color indicators before each legend label and and so on. If space is not enough, LegendLabels are broken into several lines. Words are kept whole if LegendWordWrap is set to true.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.LegendWordWrap Property

Chart.LegendWordWrap Property

Gets or sets whether the words of the legend labels are wrapped.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public bool LegendWordWrap { get; set; }
Visual Basic

Public Property LegendWordWrap As Boolean

Property Value

A bool value; true if word wrap is enabled, otherwise false.

Remarks

When the legend labels are too long they might be automatically broken into several lines. If LegendWordWrap is set to true, only whole words are drawn at each line. In this case, provide enough space for the words to be drawn in order to avoid overlapping of labels.

The property for setting the width of the legend is LegendWidth.

Default value for the LegendWordWrap property is false.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.MultiColored Property

Chart.MultiColored Property

Specifies whether the chart is drawn in one color or in different colors.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public bool MultiColored { get; set; }
Visual Basic

Public Property MultiColored As Boolean

Property Value

A bool value; true if chart series are drawn in many colors, otherwise false.

Remarks

The property specifies whether different parts of the chart are drawn with different colors, which means:

  • In bar charts, whether data bars are drawn in one color or in several colors;
  • For pie/doughnut charts, whether the pie pieces are drawn in same color or not;
  • For area/line/bubble charts, whether separate lines / areas / bubbles are drawn in one color or not;

When the property is set to false, the charts are drawn only with the first brush from the ChartBrushes list. Otherwise, all brushes are used in a continuous cycle if their number is less than the number of the chart parts they should draw.

Default value for the MultiColored property is true.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.MultiColoredLabels Property

Chart.MultiColoredLabels Property

Specifies whether labels at the chart axes are drawn in different colors.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public bool MultiColoredLabels { get; set; }
Visual Basic

Public Property MultiColoredLabels As Boolean

Property Value

A bool value; true is labels for a single chart series are drawn in many colors, otherwise false.

Remarks

This property enables labels drawn at both chart axes to be drawn in same colors as the parts of the chart they refer to. This makes charts more readable.

When the property is true, the labels are drawn with brushes from the ChartBrushes property. When it is false, the labels are drawn with the LabelBrush.

Default value for the MultiColoredLabels property is false.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.ResizeType Property

Chart.ResizeType Property

Gets or sets how the chart image is positioned in the control area.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public ResizeType ResizeType { get; set; }
Visual Basic

Public Property ResizeType As ResizeType

Property Value

A member of the ResizeType enumeration.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.SortOrder Property

Chart.SortOrder Property

Specifies the sort order of numbers in chart series.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public SortOrder SortOrder { get; set; }
Visual Basic

Public Property SortOrder As SortOrder

Property Value

One of the SortOrder Enumeration values.

Remarks

This property specifies how the data in each series is sorted. The sorting is performed on all data lists.

For charts that use the Cartesian coordinate system the orientation is considered - XData is sorted in horizontal and YData in vertical ones. For charts without axes, PieChart.Data, BarChart.Data or RadarChart.Data is sorted.

Together with the data all label lists are rearranged in the same order as the sorted data.

SortOrder sorts the numbers in the data arrays. SortSeriesBy sorts the data lists.

Default value for the SortOrder property is SortOrder.None.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.SortSeriesBy Property

Chart.SortSeriesBy Property

Specifies the sort order of data series.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public SortSeriesBy SortSeriesBy { get; set; }
Visual Basic

Public Property SortSeriesBy As SortSeriesBy

Property Value

One of the SortSeriesBy Enumeration values.

Remarks

This property specifies the sort order of data series relatively to each other.

When considered for charts that use the Cartesian coordinate system, the XData and YData properties are sorted. Sorting is performed on the YData for vertical charts and XData for horizontal ones. When it is considered for charts that use one data list, BarChart.Data, PieChart.Data or RadarChart.Data are considered.

Sorting is performed on the lists as complex objects and not on the numbers inside the lists. The property that sorts the data in the data lists is called SortOrder.

When the data lists consist of lists with members similar in count, it is better to sort them by their sum. Otherwise, it is better to use SortSeriesBy.MaxValue as sorting criterion.

When the data lists are sorted, the same sorting order is applied to all label lists for the chart.

Default value for the SortSeriesBy property is SortSeriesBy.Nothing.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.SubTitleBrush Property

Chart.SubTitleBrush Property

Specifies the brush that is used for drawing the chart subtitle.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush SubTitleBrush { get; set; }
Visual Basic

Public Property SubTitleBrush As Brush

Property Value

An instance of MindFusion.Drawing.Brush class.

Remarks

This property is used when subtitle for the chart is drawn. The subtitle text is specifies with SubTitleText property and is drawn with the SubTitleFont property. The subtitle text can be broken in several lines with the new line ("\n") symbol.

Default value for the SubTitleBrush property is a black SolidBrush.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.SubTitleFont Property

Chart.SubTitleFont Property

Specifies the font, which is used to draw the chart subtitle.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Font SubTitleFont { get; set; }
Visual Basic

Public Property SubTitleFont As Font

Property Value

An instance of .NET Font class.

Remarks

The property defines the font with which the chart's subtitle is drawn. The subtitle text is specified with the SubTitleText property. Leave it an empty string, if you do not want any subtitle to be drawn. The subtitle is drawn with the SubTitleBrush property. The subtitle is always drawn under the title (if any).

You can make the subtitle text in several lines by using the new line ("\n") symbol.

Default value for the SubTitleFont property is Times New Roman, size 14.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.SubTitleOffset Property

Chart.SubTitleOffset Property

Gets or sets the offset of the subtitle.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float SubTitleOffset { get; set; }
Visual Basic

Public Property SubTitleOffset As Single

Property Value

A float value. Default is 5f.

Remarks

The property specifies the space between the SubTitleText and the nearest chart object.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.SubTitleText Property

Chart.SubTitleText Property

Specifies the text for the chart subtitle.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string SubTitleText { get; set; }
Visual Basic

Public Property SubTitleText As String

Property Value

A string value that specifies the text.

Remarks

The property specifies the text that is drawn as chart subtitle. If the SubTitleText is an empty string no subtitle is drawn. The subtitle is always drawn under the title (if any).

The subtitle is drawn with font and brush set respectively by the SubTitleFont and SubTitleBrush properties and is aligned in the center.

You can make the subtitle multi-lined if you insert the new line symbol ("\n") in the positions in the subtitle string, where you want new lines.

Default value of the SubTitleText property is an empty string.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.TextRenderingHint Property

Chart.TextRenderingHint Property

Specifies the quality, with which text is rendered.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public TextRenderingHint TextRenderingHint { get; set; }
Visual Basic

Public Property TextRenderingHint As TextRenderingHint

Property Value

One of the .NET TextRenderingHint Enumeration values.

Remarks

The property specifies the quality, with which chart texts are rendered. It is applied to all texts that are displayed at the chart - legend labels, title and subtitle, axis labels and so on.

The values of the TextRenderingHint enumeration range from System.Default, which means poor quality but fast performance to AntiAlias, which gives high quality but slow performance. Good choice for text displayed on screen is one of the ClearType values.

Please, check the System.Drawing.TextRenderingHint enumeration for more details about the different text rendering options.

Default value for the TextRenderingHint property is TextRenderingHint.System.Default.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.TitleBrush Property

Chart.TitleBrush Property

Specifies the brush that is used to draw the chart title.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush TitleBrush { get; set; }
Visual Basic

Public Property TitleBrush As Brush

Property Value

An instance of MindFusion.Drawing.Brush class.

Remarks

This property is used when title for the chart is drawn. The title is set with TitleText and is drawn with TitleFont.

You can draw the title text in more than one line using the new line ("\n") symbol.

Default value for the TitleBrush property is a black SolidBrush.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.TitleFont Property

Chart.TitleFont Property

Specifies the font, which is used to draw the chart title.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Font TitleFont { get; set; }
Visual Basic

Public Property TitleFont As Font

Property Value

An instance of .NET Font class.

Remarks

The property defines the font with which the chart's title is drawn. The title text is specified with the TitleText property. If it is an empty string, no title is drawn. The title is drawn with the TitleBrush property and is always above the subtitle.

You can make the title text in several lines by using the new line ("\n") symbol.

Default value for the TitleFont property is Times New Roman, size 16.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.TitleOffset Property

Chart.TitleOffset Property

Gets or sets the offset of the title.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float TitleOffset { get; set; }
Visual Basic

Public Property TitleOffset As Single

Property Value

A float value. Default is 5f.

Remarks

The property specifies the space between the SubTitleText and the nearest chart object.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.Chart.TitleText Property

Chart.TitleText Property

Specifies the text for the chart title.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string TitleText { get; set; }
Visual Basic

Public Property TitleText As String

Property Value

A value that specifies the title.

Remarks

The property specifies the title for all chart types. If it is an empty string, no title is drawn.

The chart title is drawn with font and brush set respectively by the TitleFont and TitleBrush properties. The title is placed at the top of the chart and is aligned in the center. It is always drawn above the subtitle, if any.

You can draw the title in more than one line by inserting the new line ("\n") symbol in those positions in the text that you want to start at a new line. The control itself does not divide the title text but adjusts the width of the chart so that the title could fit in.

Default value of the TitleText property is an empty string.

See Also

Chart Members
Chart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter Class

ChartPrinter Class
Remarks See Also

Defines a class for printing charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public class ChartPrinter : PrintDocument
Visual Basic

Public Class ChartPrinter
Inherits PrintDocument

Remarks

Create an instance of the ChartPrinter class if you want to print a chart. Use the Chart property to set the chart to print. Landscape specifies the orientation of the page. Call Print to start printing.

Example

The following code snippet demonstrates printing a PieChart called pieChart1:

C#

ChartPrinter chartPrinter = new ChartPrinter();
chartPrinter.Chart = pieChart1;
chartPrinter.Landscape = false;
chartPrinter.Print();

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Drawing.Printing.PrintDocument
MindFusion.Charting.WinForms.ChartPrinter

See Also

ChartPrinter Members
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter Members

ChartPrinter Members
Constructors Properties Methods

Defines a class for printing charts.

The following tables list the members exposed by the ChartPrinter type.

Public Constructors

Name | Description
ChartPrinter | Overloaded. Initializes a new instance of the ChartPrinter class.

Public Properties

Name | Description
Chart | Gets or sets the Chart to print.
Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.

Public Methods

Name | Description
Print | Starts the printing of the chart.

Protected Methods

Name | Description
Dispose | Overloaded. Releases the resources used by the .NET Component.
OnBeginPrint | It is called after the Print method and before the first page of the document prints.
OnPrintPage | It is called before a page is printed.
OnQueryPageSettings | It is called immediately before each page is printed.

See Also

ChartPrinter Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter Constructor

ChartPrinter Constructor

Initializes a new instance of the ChartPrinter class.

Overload List

Name | Description
ChartPrinter () | Initializes a new instance of the ChartPrinter class.
ChartPrinter (IContainer) | Initializes a new instance of the ChartPrinter class.

See Also

ChartPrinter Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter Constructor ()

ChartPrinter Constructor ()
See Also

Initializes a new instance of the ChartPrinter class.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public ChartPrinter ()
Visual Basic

Public Sub New ()

Remarks

The default constructor initializes all fields based upon the default printer.

See Also

ChartPrinter Constructor Overload List
ChartPrinter Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter Constructor (IContainer)

ChartPrinter Constructor (IContainer)
See Also

Initializes a new instance of the ChartPrinter class.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public ChartPrinter (
IContainer container
)
Visual Basic

Public Sub ChartPrinter ( _
container As IContainer _
)

Parameters

container
The container that contains the Chart object.

Remarks

The default constructor initializes all fields based upon the default printer.

See Also

ChartPrinter Constructor Overload List
ChartPrinter Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter Methods

ChartPrinter Methods

Public Methods

Name | Description
Print | Starts the printing of the chart.

Protected Methods

Name | Description
Dispose | Overloaded. Releases the resources used by the .NET Component.
OnBeginPrint | It is called after the Print method and before the first page of the document prints.
OnPrintPage | It is called before a page is printed.
OnQueryPageSettings | It is called immediately before each page is printed.

See Also

ChartPrinter Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter.Dispose Method

ChartPrinter.Dispose Method

Overloaded. Releases the resources used by the .NET Component.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Remarks

This method is called by the public Dispose method and the Finalize method. Dispose invokes the protected Dispose(Boolean) method with the disposing parameter set to true. Finalize invokes Dispose with disposing set to false.

When the disposing parameter is true, this method releases all resources held by any managed objects that this Component references. This method invokes the Dispose method of each referenced object.

See Also

ChartPrinter Members
ChartPrinter Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter.OnBeginPrint Method

ChartPrinter.OnBeginPrint Method

It is called after the Print method and before the first page of the document prints.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

protected override void OnBeginPrint (
PrintEventArgs e
)
Visual Basic

Protected Overrides Sub OnBeginPrint ( _
e As PrintEventArgs _
)

Parameters

e
An instance of .NET PrintEventArgs class that contains the event data.

Remarks

If the Chart to be printed is null, the printing is canceled.

See Also

ChartPrinter Members
ChartPrinter Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter.OnPrintPage Method

ChartPrinter.OnPrintPage Method

It is called before a page is printed.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

protected override void OnPrintPage (
PrintPageEventArgs e
)
Visual Basic

Protected Overrides Sub OnPrintPage ( _
e As PrintPageEventArgs _
)

Parameters

e
An instance of .NET PrintPageEventArgs class that contains the event data.

Remarks

It performs all necessary calculations according to the print settings and draws the chart in the Graphics object that is used for the printing.

See Also

ChartPrinter Members
ChartPrinter Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter.OnQueryPageSettings Method

ChartPrinter.OnQueryPageSettings Method

It is called immediately before each page is printed.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

protected override void OnQueryPageSettings (
QueryPageSettingsEventArgs e
)
Visual Basic

Protected Overrides Sub OnQueryPageSettings ( _
e As QueryPageSettingsEventArgs _
)

Parameters

e
An instance of .NET QueryPageSettingsEventArgs class that contains the event data.

Remarks

The method uses mostly the functionality of the base method and checks the value of the Landscape property.

See Also

ChartPrinter Members
ChartPrinter Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter.Print Method

ChartPrinter.Print Method

Starts the printing of the chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void Print ()
Visual Basic

Public Sub Print ()

Remarks

Use the Chart property to specify the chart to be printed.

The Print method prints the chart without using a print dialog. Use an instance of .NET PrintDialog class when you want to offer the user the ability to choose print settings.

See Also

ChartPrinter Members
ChartPrinter Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter Properties

ChartPrinter Properties

Public Properties

Name | Description
Chart | Gets or sets the Chart to print.
Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.

See Also

ChartPrinter Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter.Chart Property

ChartPrinter.Chart Property

Gets or sets the Chart to print.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Chart Chart { get; set; }
Visual Basic

Public Property Chart As Chart

Property Value

An instance of Chart class.

Remarks

When a ChartPrinter is created it has no chart to print by default. Use the property to specify the chart and set it before Print is called.

See Also

ChartPrinter Members
ChartPrinter Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ChartPrinter.Landscape Property

ChartPrinter.Landscape Property

Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public bool Landscape { get; set; }
Visual Basic

Public Property Landscape As Boolean

Property Value

true if the page should be printed in landscape orientation; otherwise, false. The default is determined by the printer.

See Also

ChartPrinter Members
ChartPrinter Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ImagePos Enumeration

ImagePos Enumeration

Specifies the position and alignment of the chart's background image.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public enum ImagePos
Visual Basic

Public Enumeration ImagePos

Members

Member name | Description
BottomCenter | The background image is centered horizontally and aligned to the bottom side of the control's drawing rectangle.
BottomLeft | The background image is aligned to the bottom left corner of the control's drawing rectangle.
BottomRight | The image is aligned to the bottom-right corner.
Center | The background image is centered in the control's drawing rectangle.
CenterLeft | The background image is centered vertically and aligned to the left side of the control's drawing rectangle.
CenterRight | The background image is centered vertically and aligned to the right side of the control's drawing rectangle.
Fit | The background image is resized to fit the control's drawing rectangle.
Scroll | The background image is scrolled with the control's drawing area.
Stretch | The background image is stretched to fill the control's drawing rectangle.
Tile | The background image is tiled across the control's drawing rectangle.
TopCenter | The background image is centered horizontally and aligned to the top side of the control's drawing rectangle.
TopLeft | The background image is aligned to the top left corner of the control's drawing rectangle.
TopRight | The background image is aligned to the top right corner of the control's drawing rectangle.

Remarks

The alignment and position of the background image is set with BkgrImagePos. The background image is specified with BackgroundImage. If part of the chart's area is left uncovered by the image, it is drawn with the BackgroundBrush.

ImagePos.Scroll value should be used when the resize type of the chart is ResizeType.Scrollable.

See Also

MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart Class

LineChart Class
Remarks See Also

A class specified for drawing line, area, bubble and scatter charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public class LineChart : AxesChart, ISupportInitialize
Visual Basic

Public Class LineChart
Inherits AxesChart
Implements ISupportInitialize

Remarks

LineChart inherits properties and methods from its base class AxesChart.

The class is used for creating line, area, scatter and bubble charts as well different combinations of them. The type of the chart is specified with LineType. The possible values are members of the LineTypes enumeration and allow bitwise combination.

The data for the chart is given with lists that contain numerical or DateTime values. The data can be any format that can safely be converted to numbers or DateTime values using the standard .NET type converters. The data is added to the XData / YData properties, which are of type IList. You can specify values for just one of the XData or YData properties.

Charts can have graphics bound to the second Y-axis. The data for them is set with Y2Data.

Scatter charts get the type of the scatter for each series from the Shapes property. The size of the scatters is set with ShapeSizes. The shapes are drawn with pens and brushes from ShapePens and ShapeBrushes.

The appearance and size options of point shapes for Y2-bound graphics are specified with Y2Shapes, Y2ShapeSizes and Y2ShapePens and Y2ShapeBrushes. The point shapes of summary graphics are customized with SummaryShapes, SummaryShapeSizes, SummaryShapePens and SummaryShapeBrushes.

When drawing area charts, it is possible that some areas, when drawn in the order their data is set, overlap too much. Use the SortSeriesBy property to change the order for drawing the charts.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Charting.WinForms.Chart
MindFusion.Charting.WinForms.AxesChart
MindFusion.Charting.WinForms.LineChart

See Also

LineChart Members
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart Members

LineChart Members
Constructors Properties Methods

A class specified for drawing line, area, bubble and scatter charts.

The following tables list the members exposed by the LineChart type.

Public Constructors

Name | Description
LineChart | Creates a new instance of the LineChart class.

Public Properties

Name | Description
CalculateFunction | Invokes a custom function that calculates the values for the chart.
Curve | Gets or sets whether lines in line charts are drawn like curves.
FunctionArguments | Gets or sets the FunctionArgs argument of the CalculateFunctionDelegate delegate.
LabelAlignment | Gets or sets the alignment of chart labels.
LabelBorder | Gets or sets the type border drawn around the labels.
LabelBorderBackground | Gets or sets the brush for filling the background of the label border.
LabelBorderMargin | Gets or sets the margin between each label and its border.
LabelBorderOutline | Gets or sets the pen for drawing the outline of the label border.
Labels | Gets or sets custom labels drawn at chart data points.
LabelsFields | Gets or sets the field in the data source when the data for the bubble labels is derived from a database.
LabelType | Gets or sets the type of chart labels.
LineType | Gets or set the type of the line chart.
MaxBubbleRadius | Gets or sets the radius length of the biggest bubble.
MinBubbleRadius | Gets or sets the radius length of the smallest bubble.
MultiColoredShapes | Gets or sets whether scatters in line charts are drawn in one color.
ShapeBrushes | Gets or sets the brushes, which are used for filling the point shapes in scatter charts.
ShapePens | Gets or sets the pens, which are used for outlining of point shapes in scatter charts.
Shapes | Gets or sets the shape of data points in scatter charts.
ShapeSizes | Gets or sets the size of point shapes drawn at scatter charts.
Stacked | Gets or sets whether multi series charts are drawn stacked.
SummaryShapeBrushes | Gets or sets the brushes for drawing of point shapes at summary scatter charts.
SummaryShapePens | Gets or sets the pens for drawing shapes at summary scatter chart.
SummaryShapes | Gets or sets the shapes drawn at summary scatter charts.
SummaryShapeSizes | Gets or sets the size of point shapes drawn at summary scatter charts.
XData | Gets or sets the numerical data, which is used for calculating the X - coordinates of line points.
XDataFields | Gets or sets the field in the data source when the data for the X - chart values is derived from a database.
Y2ScatterLabels | Gets or sets custom labels drawn at Y2 scatter shapes.
Y2ShapeBrushes | Gets or sets the brushes for drawing of point shapes at Y2 scatter charts.
Y2ShapePens | Gets or sets the pens for drawing of point shapes at Y2 scatter charts.
Y2Shapes | Gets or sets the style of point shapes drawn at Y2 scatter charts.
Y2ShapeSizes | Gets or sets the size of point shapes drawn at Y2 lines.
YData | Gets or sets the data, which is used to calculate the Y-coordinates of the chart points.
YDataFields | Gets or sets the field in the data source when the data for the Y - chart values is derived from a database.

Public Methods

Name | Description
BeginInit | Begins the run-time initialization of an instance of the LineChart class that is used on a form or by another component.
EndInit | Ends the run-time initialization of an instance of the LineChart class that is used on a form or by another component.

See Also

LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart Constructor

LineChart Constructor

Creates a new instance of the LineChart class.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public LineChart ()
Visual Basic

Public Sub New ()

See Also

LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart Methods

LineChart Methods

Public Methods

Name | Description
BeginInit | Begins the run-time initialization of an instance of the LineChart class that is used on a form or by another component.
EndInit | Ends the run-time initialization of an instance of the LineChart class that is used on a form or by another component.

See Also

LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.BeginInit Method

LineChart.BeginInit Method

Begins the run-time initialization of an instance of the LineChart class that is used on a form or by another component.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void BeginInit ()
Visual Basic

Public Sub BeginInit ()

Remarks

The Visual Studio .NET design environment uses this method to start the initialization of the LineChart component that is used on a form or by another component. The EndInit method ends the initialization. Using the BeginInit and EndInit methods prevents the control from being used before it is fully initialized.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.EndInit Method

LineChart.EndInit Method

Ends the run-time initialization of an instance of the LineChart class that is used on a form or by another component.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public virtual void EndInit ()
Visual Basic

Public Overridable Sub EndInit ()

Remarks

The Visual Studio .NET design environment uses this method to end the initialization of a component that is used on a form or by another component. The BeginInit method starts the initialization. Using the BeginInit and EndInit methods prevents the control from being used before it is fully initialized.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart Properties

LineChart Properties

Public Properties

Name | Description
CalculateFunction | Invokes a custom function that calculates the values for the chart.
Curve | Gets or sets whether lines in line charts are drawn like curves.
FunctionArguments | Gets or sets the FunctionArgs argument of the CalculateFunctionDelegate delegate.
LabelAlignment | Gets or sets the alignment of chart labels.
LabelBorder | Gets or sets the type border drawn around the labels.
LabelBorderBackground | Gets or sets the brush for filling the background of the label border.
LabelBorderMargin | Gets or sets the margin between each label and its border.
LabelBorderOutline | Gets or sets the pen for drawing the outline of the label border.
Labels | Gets or sets custom labels drawn at chart data points.
LabelsFields | Gets or sets the field in the data source when the data for the bubble labels is derived from a database.
LabelType | Gets or sets the type of chart labels.
LineType | Gets or set the type of the line chart.
MaxBubbleRadius | Gets or sets the radius length of the biggest bubble.
MinBubbleRadius | Gets or sets the radius length of the smallest bubble.
MultiColoredShapes | Gets or sets whether scatters in line charts are drawn in one color.
ShapeBrushes | Gets or sets the brushes, which are used for filling the point shapes in scatter charts.
ShapePens | Gets or sets the pens, which are used for outlining of point shapes in scatter charts.
Shapes | Gets or sets the shape of data points in scatter charts.
ShapeSizes | Gets or sets the size of point shapes drawn at scatter charts.
Stacked | Gets or sets whether multi series charts are drawn stacked.
SummaryShapeBrushes | Gets or sets the brushes for drawing of point shapes at summary scatter charts.
SummaryShapePens | Gets or sets the pens for drawing shapes at summary scatter chart.
SummaryShapes | Gets or sets the shapes drawn at summary scatter charts.
SummaryShapeSizes | Gets or sets the size of point shapes drawn at summary scatter charts.
XData | Gets or sets the numerical data, which is used for calculating the X - coordinates of line points.
XDataFields | Gets or sets the field in the data source when the data for the X - chart values is derived from a database.
Y2ScatterLabels | Gets or sets custom labels drawn at Y2 scatter shapes.
Y2ShapeBrushes | Gets or sets the brushes for drawing of point shapes at Y2 scatter charts.
Y2ShapePens | Gets or sets the pens for drawing of point shapes at Y2 scatter charts.
Y2Shapes | Gets or sets the style of point shapes drawn at Y2 scatter charts.
Y2ShapeSizes | Gets or sets the size of point shapes drawn at Y2 lines.
YData | Gets or sets the data, which is used to calculate the Y-coordinates of the chart points.
YDataFields | Gets or sets the field in the data source when the data for the Y - chart values is derived from a database.

See Also

LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.CalculateFunction Property

LineChart.CalculateFunction Property

Invokes a custom function that calculates the values for the chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public CalculateFunctionDelegate CalculateFunction { get; set; }
Visual Basic

Public Property CalculateFunction As CalculateFunctionDelegate

Property Value

An instance of type MindFusion.Charting.CalculateFunctionDelegate.

Remarks

The delegate enables custom functions to be computed and drawn rather than settings numbers with XData and YData. The delegate's function argument specifies the numerical interval, in which the function is computed. To raise the CalculateFunction event, provide a method that calculates the value of a float argument and returns float result. Then, assign the method to an instance of the CalculateFunctionDelegate delegate.

Example

The following example:

  • Creates a line chart
  • Sets the chart data with a delegate, which calculates the sine function in the interval [-3, 3];

C#

/// <summary>
/// The sine function.
/// </summary>
public float CalculateFunction(float xVal, MindFusion.Charting.FunctionArgs e)
{
return (float)Math.Sin((double)xVal);
}

// ...

// Create the chart
MindFusion.Charting.LineChart chart = new MindFusion.Charting.LineChart(MindFusion.Charting.LineTypes.Line);

// Add the delegate
chart.CalculateFunction = new MindFusion.Charting.CalculateFunctionDelegate(CalculateFunction);

// Set the interval of calculation
chart.FunctionArguments = new MindFusion.Charting.FunctionArgs(-3, 3);

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.Curve Property

LineChart.Curve Property

Gets or sets whether lines in line charts are drawn like curves.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public bool Curve { get; set; }
Visual Basic

Public Property Curve As Boolean

Property Value

A bool value; true if lines are drawn as curves, otherwise false.

Remarks

The property allows line and area charts to be drawn as rounded curves instead of a combination of straight lines. The property can be applied to all 2D and 3D line/area charts. The type of the chart is set with LineType.

Default value for the Curve property is false.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.FunctionArguments Property

LineChart.FunctionArguments Property

Gets or sets the FunctionArgs argument of the CalculateFunctionDelegate delegate.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public FunctionArgs FunctionArguments { get; set; }
Visual Basic

Public Property FunctionArguments As FunctionArgs

Property Value

An instance of the FunctionArgs class.

Remarks

The property sets the interval, in which the float argument of the CalculateFunctionDelegate delegate is computed. The interval is specified by a start and end float value and is closed, that is it includes the two border values.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.LabelAlignment Property

LineChart.LabelAlignment Property

Gets or sets the alignment of chart labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public StringAlignment LabelAlignment { get; set; }
Visual Basic

Public Property LabelAlignment As StringAlignment

Property Value

One of .NET StringAlignment Enumeration values.

Remarks

The property specifies whether the label is drawn above, below or in the center of the line data point. Is is also used for scatters and bubbles. Labels are drawn when the LabelType property is not set to LabelType.Empty. Custom labels are set with Labels.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.LabelBorder Property

LineChart.LabelBorder Property

Gets or sets the type border drawn around the labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Border LabelBorder { get; set; }
Visual Basic

Public Property LabelBorder As Border

Property Value

One of the Border Enumeration values.

Remarks

The border is drawn with LabelBorderOutline and painted with LabelBorderBackground. LabelBorderMargin sets the space between the label and its border.

Default value for the LabelBorder property is Border.None.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.LabelBorderBackground Property

LineChart.LabelBorderBackground Property

Gets or sets the brush for filling the background of the label border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush LabelBorderBackground { get; set; }
Visual Basic

Public Property LabelBorderBackground As Brush

Property Value

An object of type MindFusion.Drawing.Brush class.

Remarks

Use LabelBorder to specify the type of the border. LabelBorderOutline specifies the pen for the border outline. LabelBorderMargin sets the space between the label and its border.

Default value for the LabelBorderBackground property is a light blue SolidBrush.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.LabelBorderMargin Property

LineChart.LabelBorderMargin Property

Gets or sets the margin between each label and its border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float LabelBorderMargin { get; set; }
Visual Basic

Public Property LabelBorderMargin As Single

Property Value

A float value. Default is 5f.

Remarks

The property specifies the space between the LabelBorder and data labels drawn at line data points, scatters or bubbles. The border is drawn with LabelBorderOutline and filled with LabelBorderBackground.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.LabelBorderOutline Property

LineChart.LabelBorderOutline Property

Gets or sets the pen for drawing the outline of the label border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen LabelBorderOutline { get; set; }
Visual Basic

Public Property LabelBorderOutline As Pen

Property Value

An instance of MindFusion.Drawing.Pen class.

Remarks

Use LabelBorder to set the border for labels drawn at line data points, scatters or bubbles. The background of the border rectangle is filled with LabelBorderBackground.

Default value for the LabelBorderOutline property is a black Pen.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.Labels Property

LineChart.Labels Property

Gets or sets custom labels drawn at chart data points.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList Labels { get; set; }
Visual Basic

Public Property Labels As IList

Property Value

A list that holds other lists with the labels for each scatter series.

Remarks

The labels are drawn at line data points, scatters or bubbles depending on the chart type. They are drawn when the LabelType is set to LabelType.CustomText.

Default value for the Labels property is an empty IList object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.LabelsFields Property

LineChart.LabelsFields Property

Gets or sets the field in the data source when the data for the bubble labels is derived from a database.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string LabelsFields { get; set; }
Visual Basic

Public Property LabelsFields As String

Property Value

A string that specifies the name of the data field used as source for the bubble labels.

Remarks

The property enables you to bind the data used for drawing custom text as bubble labels to columns in a database. These labels are drawn only when the LabelType is set to LabelType.CustomText.

The data source object is specified with the DataSource property. If it is of type DataSet, you can use the DataMember property to specify a particular table as source for the chart data. In this case, the fields of the table appear as items in the drop down combo box in the LabelsFields property of the line control.

If you want to add more than one table field as labels, separate the names of the fields with commas.

The LabelsFields property, when populated with data, is the same as the Labels property.

Default value for the LabelsFields property is an empty string ("").

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.LineChart.LabelType Property

LineChart.LabelType Property

Gets or sets the type of chart labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public LabelType LabelType { get; set; }
Visual Basic

Public Property LabelType As LabelType

Property Value

One of the LabelType Enumeration values.

Remarks

LabelType specifies the type of labels drawn at line data points, scatters or bubbles according to the type of the chart. Custom labels are set with Labels.

Default value for the LabelType property is LabelType.Empty.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.LineType Property

LineChart.LineType Property

Gets or set the type of the line chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public LineTypes LineType { get; set; }
Visual Basic

Public Property LineType As LineTypes

Property Value

One of the LineTypes Enumeration values.

Remarks

The members of the LineTypes enumeration allow bitwise combination, which increases the variety of charts that can be drawn.

When using MindFusion.Charting programmatically, the type of line chart is set in the constructor. It can later be changed with the LineType property.

Line charts can be drawn not only as a combination of straight lines but also as curves. This is set with Curve.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.MaxBubbleRadius Property

LineChart.MaxBubbleRadius Property

Gets or sets the radius length of the biggest bubble.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float MaxBubbleRadius { get; set; }
Visual Basic

Public Property MaxBubbleRadius As Single

Property Value

A float value that specifies the maximum radius.

Remarks

The property sets the radius of the biggest bubble. The radius of the smallest bubble is specified with MinBubbleRadius. The length of the radiuses of all other bubbles are calculated based on their value compared to the value of the biggest and smallest bubble.

Use the Y2Data property to specify the values of the bubbles. If you do not need a third data array for the bubble chart, the size of the bubble is calculated based on its value in the YData list.

Default value for the MaxBubbleRadius property is 30.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.MinBubbleRadius Property

LineChart.MinBubbleRadius Property

Gets or sets the radius length of the smallest bubble.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float MinBubbleRadius { get; set; }
Visual Basic

Public Property MinBubbleRadius As Single

Property Value

A float value that specifies the minimum bubble radius.

Remarks

The property sets the radius of the smallest bubble. The radius of the biggest bubble is specified with MaxBubbleRadius. The length of the radiuses of all other bubbles are calculated based on their value compared to the value of the biggest and smallest bubble.

Use the Y2Data property to specify the values of the bubbles. If you do not need a third data array for the bubble chart, the size of the bubble is calculated based on its value in the YData list.

Default value for the MinBubbleRadius property is 10.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.MultiColoredShapes Property

LineChart.MultiColoredShapes Property

Gets or sets whether scatters in line charts are drawn in one color.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public bool MultiColoredShapes { get; set; }
Visual Basic

Public Property MultiColoredShapes As Boolean

Property Value

A bool value; true if shapes for a single series are drawn in many colors, otherwise false.

Remarks

Scatters are drawn when the LineType is set to LineTypes.Scatter. The type of scatters is specified with Shapes property. Line points for the Y2 axis and the summary graphics are set with Y2Shapes and SummaryShapes.

The scatters are drawn with pens and brushes from ShapePens and ShapeBrushes. The control can draw all the shapes using one brush or all the brushes in a cycle. If MultiColoredShapes is true, all scatters in a single series are drawn with all ShapeBrushes. Otherwise each series is drawn with the subsequent brush.

The pens and brushes for Y2 and summary scatters are set with Y2ShapePens, Y2ShapeBrushes and SummaryShapePens, SummaryShapeBrushes.

Default value for the MultiColoredShapes property is false.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.ShapeBrushes Property

LineChart.ShapeBrushes Property

Gets or sets the brushes, which are used for filling the point shapes in scatter charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection ShapeBrushes { get; set; }
Visual Basic

Public Property ShapeBrushes As BrushCollection

Property Value

An instance of type MindFusion.Drawing.BrushCollection class.

Remarks

The property specifies the brushes used for filling shapes in scatter charts. The pens used for drawing the outlining of line point shapes are specified with the ShapePens property. In case no pens are set, the control uses a default black shape. In case no brushes are set, a default blue-white gradient brush is used.

If point shapes are not multi colored, the control takes for each line graphics a consequent chart from the ShapeBrushes array. When necessary, it repeats the brushes in a cycle. Whether a chart is drawn with multicolored point shapes depends on the value of the MultiColoredShapes property. When the line is with MultiColoredShapes, each point shape at it is drawn with different brush.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the ShapeBrushes property is an empty list.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.ShapePens Property

LineChart.ShapePens Property

Gets or sets the pens, which are used for outlining of point shapes in scatter charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public PenCollection ShapePens { get; set; }
Visual Basic

Public Property ShapePens As PenCollection

Property Value

An instance of type MindFusion.Drawing.PenCollection class.

Remarks

The property specifies the pens for drawing the outlining of shapes in scatter charts. The shapes are filled with ShapeBrushes.

In case no pens are set with the ShapePens property, the control uses a default black pen. If the ShapeBrushes are not set, the control uses a default blue gradient brush.

If the point shapes are multicolored, all pens are used for drawing of the shapes at a given line chart. If their count is smaller than the count of line data values, the control cycles through them.

If point shapes are not multi colored, the control takes for each line graphics a consequent pen from the ShapePens array. When necessary, it repeats the pens in a cycle.

Whether a chart is drawn with multicolored point shapes depends on the value of the MultiColoredShapes property. Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the ShapePens property is an empty list.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.Shapes Property

LineChart.Shapes Property

Gets or sets the shape of data points in scatter charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList Shapes { get; set; }
Visual Basic

Public Property Shapes As IList

Property Value

An object of type .NET IList that holds Shape objects.

Remarks

The property specifies the shapes of scatter charts. Add a Shapes object for each scatter graphics. For summary lines and Y2-lines the properties are SummaryShapes and Y2Shapes.

Each point shape can have different size as indicated by the ShapeSizes property. The MultiColoredShapes property specifies whether point shapes are drawn in one color or in many colors.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the Shapes property is an empty IList.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.ShapeSizes Property

LineChart.ShapeSizes Property

Gets or sets the size of point shapes drawn at scatter charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList ShapeSizes { get; set; }
Visual Basic

Public Property ShapeSizes As IList

Property Value

An object of type .NET IList, which holds float values that represent the sizes.

Remarks

The property specifies the size of point shapes drawn in scatter charts. Add the values in the same order as you have added the Shape objects to the Shapes property.

The size of the point shapes indicates:

  • For circles - the diameter of the circle;
  • For rhombuses, triangles and squares - the length of the side;

For each point shape in the Shapes property, you can specify not only the size, but also the color with the ShapeBrushes, ShapePens and MultiColoredShapes properties.

Scatter charts are drawn when the LineType property se set to LineTypes.Scatter.

Default value for the ShapeSizes property is an empty IList.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.Stacked Property

LineChart.Stacked Property

Gets or sets whether multi series charts are drawn stacked.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public bool Stacked { get; set; }
Visual Basic

Public Property Stacked As Boolean

Property Value

A bool value; true if line series graphics are drawn stacked, otherwise false.

Remarks

When 3D line charts have multiple series they are normally drawn one behind the other with distance between them set with DistBtwSeries. The graphics can also be drawn in a block, for example stacked. The property is not useful when the chart is 2D. There is no limitation as to the chart type - bubble, scatter, area, line and so on.

The charts are drawn in the same order as their data has been added to the XData, YData and Y2Data properties. You can set a different sort order with SortSeriesBy.

Default value for the Stacked property is false.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.SummaryShapeBrushes Property

LineChart.SummaryShapeBrushes Property

Gets or sets the brushes for drawing of point shapes at summary scatter charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection SummaryShapeBrushes { get; set; }
Visual Basic

Public Property SummaryShapeBrushes As BrushCollection

Property Value

An instance of type MindFusion.Drawing.BrushCollection class.

Remarks

The property specifies the brushes, with which point shapes at summary scatter charts are drawn. In order to draw summary lines, add the desired Summary value to the SummaryValues property. Custom summaries are added with the AddCustomSummary method.

The point shapes of summary lines are drawn with pens from the SummaryShapePens and filled with brushes from the SummaryShapeBrushes property. If they both are not set, the control uses a default black pen and a default blue gradient brush.

The size of the point shapes is set with SummaryShapeSizes.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the SummaryShapeBrushes property is an empty BrushCollection object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.SummaryShapePens Property

LineChart.SummaryShapePens Property

Gets or sets the pens for drawing shapes at summary scatter chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public PenCollection SummaryShapePens { get; set; }
Visual Basic

Public Property SummaryShapePens As PenCollection

Property Value

An instance of type MindFusion.Drawing.PenCollection class.

Remarks

The property specifies the pens, with which point shapes at summary scatter charts are drawn. In order to draw summary lines, add the desired Summary value to the SummaryValues property. Custom summaries are added with the AddCustomSummary method.

The point shapes of summary lines are filled with brushes from the SummaryShapeBrushes property. If the SummaryShapeBrushes is an empty array, the control uses a default blue gradient brush. If the SummaryShapePens are an empty list, a default black pen is used.

The size of the summary point shapes is set with SummaryShapeSizes.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the SummaryShapePens property is an empty PenCollection object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.SummaryShapes Property

LineChart.SummaryShapes Property

Gets or sets the shapes drawn at summary scatter charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList SummaryShapes { get; set; }
Visual Basic

Public Property SummaryShapes As IList

Property Value

An object of type .NET IList that holds Shape objects.

Remarks

The property specifies the type of shapes, drawn at summary scatter charts. In order to draw summary lines, add the desired Summary value to the SummaryValues property. Custom summaries are added with the AddCustomSummary method. Add the Shape objects in the same order in which you add the Summary values.

The point shapes of summary lines are filled with brushes from the SummaryShapeBrushes property.

Their outlining is drawn with pens from the SummaryShapePens property.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the SummaryShapes property is an empty IList object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.SummaryShapeSizes Property

LineChart.SummaryShapeSizes Property

Gets or sets the size of point shapes drawn at summary scatter charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList SummaryShapeSizes { get; set; }
Visual Basic

Public Property SummaryShapeSizes As IList

Property Value

An object of type .NET IList class that holds float values, which represents the sizes for the SummaryShapes.

Remarks

The property specifies the size of point shapes drawn at summary scatter charts. In order to draw summary lines, add the desired Summary value to the SummaryValues property. Custom summaries are added with the AddCustomSummary method. Add the Shape objects in the same order in which you add the Summary values.

Each float value in the SummaryShapeSizes array indicates:

  • For point shapes of type Shape.Circle - the radius of the point shape
  • For point shapes of type Shape.Triangle, Shape.Rhombus and Shape.Square - the side of the figure

The point shapes of summary lines are filled with brushes from the SummaryShapeBrushes property. Their outlining is drawn with pens from the SummaryShapePens property.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the SummaryShapeSizes property is an empty IList object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.XData Property

LineChart.XData Property

Gets or sets the numerical data, which is used for calculating the X - coordinates of line points.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList XData { get; set; }
Visual Basic

Public Property XData As IList

Property Value

An object of type .NET IList class that holds other lists with numbers.

Remarks

The property holds the data used for calculating the X-coordinates of chart points. The data can be numbers or DateTime values. There is no restriction as to the format of the data as long as it can safely be converted to numbers or DateTime values using the standard .NET DoubleConverter and DateTimeConverter classes.

If the XData list is empty, the control fills it with consequent integers starting from 0, 1, 2... up till the count of data in the respective YData series. In this case, the data is equally distributed along the X-axis.

There is no limit to the count of series XData can hold.

You can also set a function that calculates the result (y) values in a given numerical interval by means of the CalculateFunctionDelegate.

XData can be sorted in two ways - both the arrays can be sorted in comparison with each other and the numbers in each series can also be sorted. The properties for this are SortSeriesBy and SortOrder.

Default value for the XData property is an empty list.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.XDataFields Property

LineChart.XDataFields Property

Gets or sets the field in the data source when the data for the X - chart values is derived from a database.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string XDataFields { get; set; }
Visual Basic

Public Property XDataFields As String

Property Value

A string that specifies the name of the data source field.

Remarks

The property enables you to bind the data used for calculating the X-coordinates of line chart points to numerical columns in a database. The data source object is specified with the DataSource property. If it is of type DataSet, you can use the DataMember property to specify a given table as source for the chart data. In this case the fields of the table appear as items in the drop down combo box in the XDataFields property of the line control.

If you want to add more than one table field as data for the chart, you should separate the names with commas.

The XDataFields property, when populated with data, is the same as the XData property.

Default value for the XDataFields property is an empty string ("").

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.LineChart.Y2ScatterLabels Property

LineChart.Y2ScatterLabels Property

Gets or sets custom labels drawn at Y2 scatter shapes.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList Y2ScatterLabels { get; set; }
Visual Basic

Public Property Y2ScatterLabels As IList

Property Value

A list that holds other lists with the labels for each Y2-scatter series.

Remarks

Use the property to set custom labels drawn at scatter charts bound to Y2. The LabelType must be set to CustomText to show the labels. LabelAlignment sets the alignment of the scatter labels.

Y2 charts are drawn when the Y2Data property is not an empty list. Scatter charts are drawn when LineType is set to LineTypes.Scatter.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.Y2ShapeBrushes Property

LineChart.Y2ShapeBrushes Property

Gets or sets the brushes for drawing of point shapes at Y2 scatter charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection Y2ShapeBrushes { get; set; }
Visual Basic

Public Property Y2ShapeBrushes As BrushCollection

Property Value

An instance of type MindFusion.Drawing.BrushCollection class.

Remarks

The property specifies the brushes, with which point shapes at scatter charts for Y2 are drawn. In order to draw graphics for the second Y-axis, add the desired data to the Y2Data property. The X-values of the lines are taken from the XData property.

The point shapes of Y2 lines are drawn with pens from the Y2ShapePens property. If the Y2ShapePens is an empty list, the control uses a default black pen. If the Y2ShapeBrushes is an empty list, a default blue gradient brush is used.

The size of the point shapes is set with Y2ShapeSizes.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the Y2ShapeBrushes property is an empty BrushCollection object.

Gets or sets the brushes for drawing of point shapes at Y2 scatter charts.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.Y2ShapePens Property

LineChart.Y2ShapePens Property

Gets or sets the pens for drawing of point shapes at Y2 scatter charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public PenCollection Y2ShapePens { get; set; }
Visual Basic

Public Property Y2ShapePens As PenCollection

Property Value

An instance of type MindFusion.Drawing.PenCollection class.

Remarks

The property specifies the pens, with which point shapes at scatter charts for Y2 are drawn. In order to draw lines for the second Y-axis, add the desired data to the Y2Data property. The X-values for the graphics are taken from the XData property.

The point shapes of summary lines are filled with brushes from the Y2ShapeBrushes property. If it is an empty list, a default white-blue gradient brush is used. If the ShapePens is an empty list, the control uses a black pen.

Their size of the point shapes is set with Y2ShapeSizes.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the Y2ShapePens property is an empty PenCollection object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.Y2Shapes Property

LineChart.Y2Shapes Property

Gets or sets the style of point shapes drawn at Y2 scatter charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList Y2Shapes { get; set; }
Visual Basic

Public Property Y2Shapes As IList

Property Value

An object of type .NET IList that holds Shape objects.

Remarks

The property specifies the pens, with which point shapes at scatter charts for Y2 are drawn. In order to draw lines for the second Y-axis, add the desired data to the Y2Data property. The X-values for the graphics are taken from the XData property.

The point shapes of summary lines are filled with brushes from the Y2ShapeBrushes property. If it is an empty list, a default white-blue gradient brush is used. If the ShapePens is an empty list, the control uses a black pen.

Their size of the point shapes is set with Y2ShapeSizes.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the Y2ShapePens property is an empty PenCollection object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.Y2ShapeSizes Property

LineChart.Y2ShapeSizes Property

Gets or sets the size of point shapes drawn at Y2 lines.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList Y2ShapeSizes { get; set; }
Visual Basic

Public Property Y2ShapeSizes As IList

Property Value

An object of type .NET IList class that holds float values, which represent the shape sizes.

Remarks

The property specifies the size of point shapes drawn at Y2 lines. In order to draw lines for the second Y-axis, add the desired data to the Y2Data property. The X-values of the lines are taken from the XData property. Each float value in the Y2ShapeSizes array indicates:

  • For point shapes of type Shape.Circle - the radius of the point shape
  • For point shapes of type Shape.Triangle, Shape.Rhombus and Shape.Square - the side of the figure

The point shapes of Y2lines are filled with brushes from the Y2ShapeBrushes property. Their outlining is drawn with pens from the Y2ShapePens property.

Scatter charts are drawn when the LineType property is set to LineTypes.Scatter.

Default value for the Y2ShapeSizes property is an empty IList object.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.YData Property

LineChart.YData Property

Gets or sets the data, which is used to calculate the Y-coordinates of the chart points.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList YData { get; set; }
Visual Basic

Public Property YData As IList

Property Value

An object of type .NET IList class that holds other lists with numbers.

Remarks

The property holds the numbers, which are used to calculate the Y-coordinates of chart points. The data can be either numbers or DateTime values. Data can be in any format (for example strings) that can safely be converted to numbers or DateTime values using the standard .NET DoubleConverter and DateTimeConverter classes.

If the YData list is empty, the control automatically fills it with consequent numbers starting from 0,1,2,3... till the count of data in the respective XData series. In this case, the points are equally spread along the axes.

There is no limit to the count of data in YData - you can add as many series with as many numbers as you need.

You can also set a function that calculates the result (y) values in a given numerical interval with the CalculateFunctionDelegate.

YData can be sorted in two ways - both the lists can be sorted in comparison with each other and the numbers in each series can also be sorted. The properties for that are SortSeriesBy and SortOrder.

Default value for the YData property is an empty list.

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.LineChart.YDataFields Property

LineChart.YDataFields Property

Gets or sets the field in the data source when the data for the Y - chart values is derived from a database.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string YDataFields { get; set; }
Visual Basic

Public Property YDataFields As String

Property Value

A string that specifies the name of the data source field.

Remarks

The property enables you to bind the data used for calculating the Y-coordinates of line chart points to numerical columns in a database. The data source object is specified with the DataSource property. If it is of type DataSet you can use the DataMember property to specify a given table as source for the chart data. In this case, the table cells appear as items in the drop down combo box in the YDataFields property of the line control.

If you want to add more than one table cell as data for the chart, you should separate the names with commas.

The YDataFields property, when populated with data, is the same as the YData property.

Default value for the YDataFields property is an empty string ("").

See Also

LineChart Members
LineChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.PieChart Class

PieChart Class
Remarks See Also

A class specified for drawing pie charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public class PieChart : Chart, ISupportInitialize
Visual Basic

Public Class PieChart
Inherits Chart
Implements ISupportInitialize

Remarks

PieChart inherits properties and methods from its base class Chart.

Instances of the PieChart class are responsible for drawing both 2D and 3D pie and doughnut charts. The type of the chart is set with the PieType property and is an instance of the PieType enumeration.

Data for the pie is specified with the Data property. It is a single-dimensional list that can hold either numbers or values of any other type that can be converted to numbers.

Pie data can be cancelled if the numbers are too big. The DivisionCoef property specifies the division coefficient. The unit of measure is set with DivisionLabel.

Pies and doughnut charts can have one or all of its pieces detached. The index of the piece detached is specified with PieceOutIndex. Drawing of pie pieces can start from an angle, other than 0. Use the StartAngle property to specify it.

Each pie can have text outside and inside its segments (pieces). The type of text is specified with OuterLabelType and InnerLabelType.

Custom text, drawn inside or outside the pie pieces is set with InnerLabels and OuterLabels.

Each label, drawn inside / outside the pie pieces can be drawn with a label before or after it - use LabelSuffix and LabelPrefix to set it.

Labels drawn outside of pie segments are drawn with pointers from the middle of the piece to the label. The length of the pointer is specified with PointerLength.

The radius of the pie is set with RadiusLength.

If you want to set the tension (flatness) and thickness of 3D pie charts use Pie3DTension and Pie3DThickness.

In doughnut charts, you can use the DoughnutThickness property to specify the thickness of doughnuts.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Charting.WinForms.Chart
MindFusion.Charting.WinForms.PieChart

See Also

PieChart Members
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart Members

PieChart Members
Constructors Properties Methods

A class specified for drawing pie charts.

The following tables list the members exposed by the PieChart type.

Public Constructors

Name | Description
PieChart | Creates a new instance of the PieChart class.

Public Properties

Name | Description
Data | Specifies the numerical data used for calculating the segments of the pie.
DataField | Gets or sets the database field, which values are used as data for the pie.
DivisionCoef | Specifies the division coefficient for pie data.
DivisionLabel | Specifies the unit of measure for data in the pie chart.
DoughnutThickness | Gets or sets the thickness of the doughut as a percentage of the radius length.
InnerLabelBackground | Gets or sets the brush for filling the background of the border for inner labels.
InnerLabelBorder | Gets or sets the type border drawn around inner labels.
InnerLabelBorderMargin | Gets or sets the margin between each inner label and its border.
InnerLabelFormat | Gets or sets the format of numbers drawn inside pie segments.
InnerLabelOutline | Gets or sets the pen for drawing the outline of the label border for inner labels.
InnerLabelPosition | Specifies the position of labels inside pie pieces.
InnerLabels | Specifies the text drawn inside each pie piece.
InnerLabelsField | Gets or sets the database field, which values are used as labels inside pie pieces.
InnerLabelType | Specifies the type of labels to be drawn inside pie pieces.
LabelPrefix | Gets or sets a string prefix for labels inside/outside the pie's pieces.
LabelSuffix | Gets or sets a string suffix for labels inside/outside the pie's pieces.
OuterLabelBackground | Gets or sets the brush for filling the background of the border for outer labels.
OuterLabelBorder | Gets or sets the type border drawn around outer labels.
OuterLabelBorderMargin | Gets or sets the margin between each outer label and its border.
OuterLabelFormat | Gets or sets the format of numbers drawn outside pie segments.
OuterLabelOutline | Gets or sets the pen for drawing the outline of the label border for outer labels.
OuterLabels | Specifies the text drawn outside each pie piece.
OuterLabelsField | Gets or sets the database field, which values are used as labels outside pie pieces.
OuterLabelType | Specifies the type of labels drawn outside pie pieces.
OutlinePen | Specifies the chart pen used for drawing the pie outlining.
Pie3DTension | Specifies the flatness of 3D pies.
Pie3DThickness | Specifies the height of 3D pies.
PieceOutIndex | Specifies the index of the detached pie piece.
PieceOutPercent | Specifies the distance at which the detached pie piece is drawn from the center of the pie/doughnut.
PieMargins | Specifies the margins for the pie chart.
PieType | Gets or sets the type of the pie chart to be drawn.
PointerLength | Gets or sets the length of the piece pointers.
RadiusLength | Specifies the radius length of the pie chart.
StartAngle | Gets or sets the start angle for drawing the pieces of the pie.

Public Methods

Name | Description
BeginInit | Begins the run-time initialization of an instance of the PieChart class that is used on a form or by another component.
EndInit | Ends the run-time initialization of an instance of the PieChart class that is used on a form or by another component.

See Also

PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart Constructor

PieChart Constructor

Creates a new instance of the PieChart class.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public PieChart ()
Visual Basic

Public Sub New ()

See Also

PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart Methods

PieChart Methods

Public Methods

Name | Description
BeginInit | Begins the run-time initialization of an instance of the PieChart class that is used on a form or by another component.
EndInit | Ends the run-time initialization of an instance of the PieChart class that is used on a form or by another component.

See Also

PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.BeginInit Method

PieChart.BeginInit Method

Begins the run-time initialization of an instance of the PieChart class that is used on a form or by another component.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void BeginInit ()
Visual Basic

Public Sub BeginInit ()

Remarks

The Visual Studio .NET design environment uses this method to start the initialization of the PieChart component that is used on a form or by another component. The EndInit method ends the initialization. Using the BeginInit and EndInit methods prevents the control from being used before it is fully initialized.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.EndInit Method

PieChart.EndInit Method

Ends the run-time initialization of an instance of the PieChart class that is used on a form or by another component.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void EndInit ()
Visual Basic

Public Sub EndInit ()

Remarks

The Visual Studio .NET design environment uses this method to end the initialization of a component that is used on a form or by another component. The BeginInit method starts the initialization. Using the BeginInit and EndInit methods prevents the control from being used before it is fully initialized.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart Properties

PieChart Properties

Public Properties

Name | Description
Data | Specifies the numerical data used for calculating the segments of the pie.
DataField | Gets or sets the database field, which values are used as data for the pie.
DivisionCoef | Specifies the division coefficient for pie data.
DivisionLabel | Specifies the unit of measure for data in the pie chart.
DoughnutThickness | Gets or sets the thickness of the doughut as a percentage of the radius length.
InnerLabelBackground | Gets or sets the brush for filling the background of the border for inner labels.
InnerLabelBorder | Gets or sets the type border drawn around inner labels.
InnerLabelBorderMargin | Gets or sets the margin between each inner label and its border.
InnerLabelFormat | Gets or sets the format of numbers drawn inside pie segments.
InnerLabelOutline | Gets or sets the pen for drawing the outline of the label border for inner labels.
InnerLabelPosition | Specifies the position of labels inside pie pieces.
InnerLabels | Specifies the text drawn inside each pie piece.
InnerLabelsField | Gets or sets the database field, which values are used as labels inside pie pieces.
InnerLabelType | Specifies the type of labels to be drawn inside pie pieces.
LabelPrefix | Gets or sets a string prefix for labels inside/outside the pie's pieces.
LabelSuffix | Gets or sets a string suffix for labels inside/outside the pie's pieces.
OuterLabelBackground | Gets or sets the brush for filling the background of the border for outer labels.
OuterLabelBorder | Gets or sets the type border drawn around outer labels.
OuterLabelBorderMargin | Gets or sets the margin between each outer label and its border.
OuterLabelFormat | Gets or sets the format of numbers drawn outside pie segments.
OuterLabelOutline | Gets or sets the pen for drawing the outline of the label border for outer labels.
OuterLabels | Specifies the text drawn outside each pie piece.
OuterLabelsField | Gets or sets the database field, which values are used as labels outside pie pieces.
OuterLabelType | Specifies the type of labels drawn outside pie pieces.
OutlinePen | Specifies the chart pen used for drawing the pie outlining.
Pie3DTension | Specifies the flatness of 3D pies.
Pie3DThickness | Specifies the height of 3D pies.
PieceOutIndex | Specifies the index of the detached pie piece.
PieceOutPercent | Specifies the distance at which the detached pie piece is drawn from the center of the pie/doughnut.
PieMargins | Specifies the margins for the pie chart.
PieType | Gets or sets the type of the pie chart to be drawn.
PointerLength | Gets or sets the length of the piece pointers.
RadiusLength | Specifies the radius length of the pie chart.
StartAngle | Gets or sets the start angle for drawing the pieces of the pie.

See Also

PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.Data Property

PieChart.Data Property

Specifies the numerical data used for calculating the segments of the pie.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList Data { get; set; }
Visual Basic

Public Property Data As IList

Property Value

An object of type .NET IList class that holds the numbers.

Remarks

The property holds the data for the pie. The values can be either numbers or of any other type that can be parsed to numbers. Add the values directly to the property or assign to it a list that holds the data.

The data numbers can be cancelled - use the DivisionCoef and DivisionLabel properties to specify the divisor and the label that indicates the units of measure.

Default value for the Data property is an empty list.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.DataField Property

PieChart.DataField Property

Gets or sets the database field, which values are used as data for the pie.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string DataField { get; set; }
Visual Basic

Public Property DataField As String

Property Value

The string that specifies the name of the database field.

Remarks

The property enables you to bind the data for the pie chart to a field in a database. The data source object is specified with the DataSource property. If it is of type DataSet you can use the DataMember property to specify a particular table as source for the chart data. In this case the fields of the table appear as items in the drop down combo box in the DataField property of the pie control.

The DataField property, when populated with data, is the same as the Data property.

Default value for the DataField property is an empty string ("").

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.PieChart.DivisionCoef Property

PieChart.DivisionCoef Property

Specifies the division coefficient for pie data.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public double DivisionCoef { get; set; }
Visual Basic

Public Property DivisionCoef As Double

Property Value

A double value that represents the division coefficient.

Remarks

The property specifies the division coefficient, with which pie data is cancelled. Use DivisionLabel to set the unit of measure when pie data has been cancelled.

The DivisionCoef property is not considered if none of the InnerLabelType and OuterLabelType properties is set to LabelType.Data.

Default value for the DivisionCoef property is Double.NaN, that is the numbers are not divided.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.DivisionLabel Property

PieChart.DivisionLabel Property

Specifies the unit of measure for data in the pie chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string DivisionLabel { get; set; }
Visual Basic

Public Property DivisionLabel As String

Property Value

A string value that represents the division label.

Remarks

The property is used to indicate the unit of measure when the pie data has been cancelled. It is considered only if the InnerLabelType or OuterLabelType for this pie is set to LabelType.Data.

The division coefficient is specified with the DivisionCoef property.

Default value for the DivisionLabel property is an empty string.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.DoughnutThickness Property

PieChart.DoughnutThickness Property

Gets or sets the thickness of the doughut as a percentage of the radius length.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public int DoughnutThickness { get; set; }
Visual Basic

Public Property DoughnutThickness As Integer

Property Value

An int value. Default is 50.

Remarks

DoughnutThickness values range from 0 to 100. Values closer to 100 make the doughnut look more like a pie. Values close to 0 make it look more like a thin ring.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.InnerLabelBackground Property

PieChart.InnerLabelBackground Property

Gets or sets the brush for filling the background of the border for inner labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush InnerLabelBackground { get; set; }
Visual Basic

Public Property InnerLabelBackground As Brush

Property Value

An instance of MindFusion.Drawing.Brush class.

Remarks

Use InnerLabelBorder to set the type of the border. The outline of the border rectangle is drawn with InnerLabelOutline. InnerLabelBorderMargin specifies the space between the label and the border.

Default value for the InnerLabelBackground property is a light blue SolidBrush.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.InnerLabelBorder Property

PieChart.InnerLabelBorder Property

Gets or sets the type border drawn around inner labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Border InnerLabelBorder { get; set; }
Visual Basic

Public Property InnerLabelBorder As Border

Property Value

One of the Border Enumeration values.

Remarks

The border rectangle is drawn with InnerLabelOutline and filled with InnerLabelBackground. The offset between the inner label and its border is set with InnerLabelBorderMargin.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.InnerLabelBorderMargin Property

PieChart.InnerLabelBorderMargin Property

Gets or sets the margin between each inner label and its border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float InnerLabelBorderMargin { get; set; }
Visual Basic

Public Property InnerLabelBorderMargin As Single

Property Value

A float value. Default is 5f.

Remarks

The property specifies the space between the inner label and its border. The border is set with InnerLabelBorder. The border rectangle is drawn with InnerLabelOutline and filled with InnerLabelBackground.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.InnerLabelFormat Property

PieChart.InnerLabelFormat Property

Gets or sets the format of numbers drawn inside pie segments.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public NumberFormat InnerLabelFormat { get; set; }
Visual Basic

Public Property InnerLabelFormat As NumberFormat

Property Value

One of the NumberFormat enumeration values. Default is NumberFormat.Fixed_point.

Remarks

The property specifies the format of labels inside pie pieces when the InnerLabelType is set to LabelType.Data or LabelType.Percents.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.InnerLabelOutline Property

PieChart.InnerLabelOutline Property

Gets or sets the pen for drawing the outline of the label border for inner labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen InnerLabelOutline { get; set; }
Visual Basic

Public Property InnerLabelOutline As Pen

Property Value

An instance of type MindFusion.Drawing.Pen class.

Remarks

The border of inner labels is set with InnerLabelBorder. It is filled with InnerLabelBackground. Use InnerLabelBorderMargin to specify the space between the inner label and its border.

Default value for the InnerLabelOutline property is a black Pen.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.InnerLabelPosition Property

PieChart.InnerLabelPosition Property

Specifies the position of labels inside pie pieces.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public int InnerLabelPosition { get; set; }
Visual Basic

Public Property InnerLabelPosition As Integer

Property Value

An int value that specifies the position of the inner label as percent of the chart radius. Values range from 0 to 100.

Remarks

The property indicates the position of labels inside pie pieces as percent from the pie radius. Set the property to a value between 0 and 100. The smaller the value, the closer the label is drawn to the center of the chart. Numbers close to 100 indicate that the labels shall be drawn close to the edge of the pie.

The type of inner and outer labels is specified with InnerLabelType and OuterLabelType properties.

Default value for the InnerLabelPosition is 50 (labels are drawn in the middle of the pie radius).

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.InnerLabels Property

PieChart.InnerLabels Property

Specifies the text drawn inside each pie piece.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList InnerLabels { get; set; }
Visual Basic

Public Property InnerLabels As IList

Property Value

An object of type .NET IList class that holds the labels.

Remarks

Use the property to specify the text drawn inside each pie piece, when you have set the InnerLabelType member to LabelType.CustomText.

The InnerLabelFormat property specifies the number format for numerical inner labels.

OuterLabels are set with the OuterLabels property and the OuterLabelType property.

Default value for the InnerLabels property is an empty array.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.InnerLabelsField Property

PieChart.InnerLabelsField Property

Gets or sets the database field, which values are used as labels inside pie pieces.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string InnerLabelsField { get; set; }
Visual Basic

Public Property InnerLabelsField As String

Property Value

A string that specifies the name of the database field.

Remarks

The property enables you to bind the labels drawn inside pie pieces to a field in a database. The data source object is specified with the DataSource property. If it is of type DataSet you can use the DataMember property to specify a particular table as source for the chart data. In this case the fields of the table appear as items in the drop down combo box in the InnerLabelsField property of the pie control.

The labels specified with the InnerLabelsField are drawn only if the InnerLabelType property of the chart is set to LabelType.CustomText.

The InnerLabelsField property, when populated with data, is the same as the InnerLabels property.

Default value for the InnerLabelsField property is an empty string ("").

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.PieChart.InnerLabelType Property

PieChart.InnerLabelType Property

Specifies the type of labels to be drawn inside pie pieces.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public LabelType InnerLabelType { get; set; }
Visual Basic

Public Property InnerLabelType As LabelType

Property Value

One of the LabelType Enumeration values.

Remarks

The property enables you to choose the type of label drawn inside each segment of a pie chart. Use InnerLabels to specify custom labels.

Outer labels are specified with OuterLabelType and OuterLabels properties. The position of the inner labels in the piece is specified with InnerLabelPosition.

Default value for the InnerLabelType property is LabelType.Empty.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.LabelPrefix Property

PieChart.LabelPrefix Property

Gets or sets a string prefix for labels inside/outside the pie's pieces.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string LabelPrefix { get; set; }
Visual Basic

Public Property LabelPrefix As String

Property Value

A string that specifies the prefix drawn before the pie label.

Remarks

Use the property to specify a prefix drawn before each label inside / outside pie pieces. Use LabelSuffix to set a suffix drawn behind each label.

The prefix and suffix are the same for all pie pieces. The label type is set with InnerLabelType and OuterLabelType. InnerLabels and OuterLabels specify custom labels.

Default value for LabelPrefix property is an empty string.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.LabelSuffix Property

PieChart.LabelSuffix Property

Gets or sets a string suffix for labels inside/outside the pie's pieces.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string LabelSuffix { get; set; }
Visual Basic

Public Property LabelSuffix As String

Property Value

A string value that specifies the postfix drawn behind the label.

Remarks

The property specifies a suffix drawn behind each label inside / outside pie pieces. You can also set a prefix drawn before each label with LabelPrefix.

The prefix and suffix are the same for all pie pieces. The type of the inner and outer labels is set with InnerLabelType and OuterLabelType. Custom labels are set with InnerLabels and OuterLabels.

Default value for LabelSuffix property is an empty string.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.OuterLabelBackground Property

PieChart.OuterLabelBackground Property

Gets or sets the brush for filling the background of the border for outer labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush OuterLabelBackground { get; set; }
Visual Basic

Public Property OuterLabelBackground As Brush

Property Value

An instance of MindFusion.Drawing.Brush class.

Remarks

Use OuterLabelBorder to specify the Border drawn around outer labels. OuterLabelOutline specifies the pen for drawing the border rectangle. The space between the label and its border is specified with OuterLabelBorderMargin.

Default value for the OuterLabelBackground property is a light blue SolidBrush.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.OuterLabelBorder Property

PieChart.OuterLabelBorder Property

Gets or sets the type border drawn around outer labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Border OuterLabelBorder { get; set; }
Visual Basic

Public Property OuterLabelBorder As Border

Property Value

One of the Border Enumeration values. Default value is Border.None.

Remarks

The border is drawn with pen specified with OuterLabelOutline and filled with OuterLabelBackground. Use OuterLabelBorderMargin to specify the space between the label and its border.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.OuterLabelBorderMargin Property

PieChart.OuterLabelBorderMargin Property

Gets or sets the margin between each outer label and its border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float OuterLabelBorderMargin { get; set; }
Visual Basic

Public Property OuterLabelBorderMargin As Single

Property Value

A float value. Default is 5f.

Remarks

The property specifies the space between the outer label and its border.

Outer labels in pies are drawn with border set by OuterLabelBorder. The border rectangle is drawn with OuterLabelOutline and filled with OuterLabelBackground.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.OuterLabelFormat Property

PieChart.OuterLabelFormat Property

Gets or sets the format of numbers drawn outside pie segments.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public NumberFormat OuterLabelFormat { get; set; }
Visual Basic

Public Property OuterLabelFormat As NumberFormat

Property Value

One of the NumberFormat enumeration values. Default is NumberFormat.Fixed_point.

Remarks

The property specifies the format of labels drawn outside pie pieces when the OuterLabelType is set to LabelType.Data or LabelType.Percents.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.OuterLabelOutline Property

PieChart.OuterLabelOutline Property

Gets or sets the pen for drawing the outline of the label border for outer labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen OuterLabelOutline { get; set; }
Visual Basic

Public Property OuterLabelOutline As Pen

Property Value

An instance of type MindFusion.Drawing.Pen class. Default is a black Pen, width 1.

Remarks

Use OuterLabelBorder to specify the border around outer labels. The border rectangle is filled with OuterLabelBackground. Space between the outer label and its border is specified with OuterLabelBorderMargin.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.OuterLabels Property

PieChart.OuterLabels Property

Specifies the text drawn outside each pie piece.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList OuterLabels { get; set; }
Visual Basic

Public Property OuterLabels As IList

Property Value

An object of type .NET IList that holds the inner labels.

Remarks

Use the property to specify the labels, drawn outside each pie piece, when you have set the OuterLabelType property to LabelType.CustomText.

You can assign to OuterLabels the array that holds the labels or add them directly to the OuterLabels property.

Inner labels are specified with the InnerLabelType and InnerLabels properties.

Default value for the OuterLabels property is an empty array.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.OuterLabelsField Property

PieChart.OuterLabelsField Property

Gets or sets the database field, which values are used as labels outside pie pieces.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string OuterLabelsField { get; set; }
Visual Basic

Public Property OuterLabelsField As String

Property Value

A string that specifies the name of the database field.

Remarks

The property enables you to bind the labels drawn outside pie pieces to a field in a database. The data source object is specified with the DataSource property. If it is of type DataSet you can use the DataMember property to specify a given table as source for the chart data. In this case the fields of the table appear as items in the drop down combo box in the OuterLabelsField property of the pie control.

The labels specified with the OuterLabelsField are drawn only if the OuterLabelType property of the chart is set to LabelType.CustomText.

The OuterLabelsField property, when populated with data, is the same as the OuterLabels property.

Default value for the OuterLabelsField property is an empty string ("").

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.PieChart.OuterLabelType Property

PieChart.OuterLabelType Property

Specifies the type of labels drawn outside pie pieces.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public LabelType OuterLabelType { get; set; }
Visual Basic

Public Property OuterLabelType As LabelType

Property Value

One of the LabelType Enumeration values.

Remarks

The property enables you to choose the type of label drawn outside each pie segment. Custom labels are specified with OuterLabels. Lines are drawn from the middle of each segment to its label. Use the PointerLength property to specify the length of this line.

Default value for the OuterLabelType property is LabelType.Empty.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.OutlinePen Property

PieChart.OutlinePen Property

Specifies the chart pen used for drawing the pie outlining.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen OutlinePen { get; set; }
Visual Basic

Public Property OutlinePen As Pen

Property Value

An instance of type MindFusion.Drawing.Pen class.

Remarks

The pie in a pie chart is drawn with a visible outlining, which makes the chart easier to understand. This property specifies the pen used for drawing the outlining not only for the whole pie but also between the separate pie pieces.

Default value for the OutlinePen property is a black Pen, width 1.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.Pie3DTension Property

PieChart.Pie3DTension Property

Specifies the flatness of 3D pies.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public int Pie3DTension { get; set; }
Visual Basic

Public Property Pie3DTension As Integer

Property Value

An int vaue that specifies the tension for 3D pies as percent from RadiusLength. Values range from 0 to 100.

Remarks

The property specifies the flatness of pies, that are 3D. The bigger the Pie3DTension, the flatter the pie. The property value should be between 0 and 100.

Generally, thick pies look better with bigger 3D tension and thin pies with a small one. Check the Pie3DThickness property for more details.

Default value for the Pie3DTension is 25.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.Pie3DThickness Property

PieChart.Pie3DThickness Property

Specifies the height of 3D pies.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float Pie3DThickness { get; set; }
Visual Basic

Public Property Pie3DThickness As Single

Property Value

A float value that specifies the thickness for 3D pies, in points.

Remarks

The property indicates how thick (tall) the 3D pie is. The flatness of a 3D pie is specified with Pie3DTension. Generally, a thick pie looks better with bigger 3D tension and a flat pie with a small one.

Default value for the Pie3DThickness is 20.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.PieceOutIndex Property

PieChart.PieceOutIndex Property

Specifies the index of the detached pie piece.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public int PieceOutIndex { get; set; }
Visual Basic

Public Property PieceOutIndex As Integer

Property Value

An int value that specifies the zero-based index of the detached pie piece.

Remarks

The property specifies the 0-based index of the detached piece. You should set this property to the count of all pieces or more and all pie pieces will be drawn detached.

The PieceOutPercent property sets the distance, at which the detached pie / doughnut piece is drawn from the pie / doughnut center.

Default value for the PieceOutIndex property is -1, which means that no pie piece is detached.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.PieceOutPercent Property

PieChart.PieceOutPercent Property

Specifies the distance at which the detached pie piece is drawn from the center of the pie/doughnut.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float PieceOutPercent { get; set; }
Visual Basic

Public Property PieceOutPercent As Single

Property Value

A float value that specifies the distance between the pie center and the top of the detached pie piece as percent of the RadiusLength.

Remarks

The property specifies the distance, at which pie pieces are drawn from the centre of the pie. The distance is set as percent from the pie radius. Add a value between 0 and 100 to PieceOutPercent.

The PieceOutIndex specifies the 0-based index of the piece, which is detached (if any).

Default value for the PieceOutPercent property is 20.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.PieMargins Property

PieChart.PieMargins Property

Specifies the margins for the pie chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float PieMargins { get; set; }
Visual Basic

Public Property PieMargins As Single

Property Value

A float value that specifies the margins for the pie charts, in points.

Remarks

The property specifies the margins that are left at all four side of the pie chart. When the PieMargins property is set, the control does not calculate any space for the OuterLabels / InnerLabels. That is why the margins should be set in accordance with the length of the labels and the piece pointers.

The size of the legend (if any) is not included in the pie margins.

Default value for the PieMargins property is -1, which means that MindFusion.Charting calculates the margins automatically so that all labels could fit in.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.PieType Property

PieChart.PieType Property

Gets or sets the type of the pie chart to be drawn.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public PieType PieType { get; set; }
Visual Basic

Public Property PieType As PieType

Property Value

One of the PieType Enumeration values.

Remarks

The property specifies the type of the pie chart drawn. The type of the pie chart is set by its declaration in the constructor. When it is changed dynamically, it should be noted that some pie types need different settings than others.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.PointerLength Property

PieChart.PointerLength Property

Gets or sets the length of the piece pointers.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float PointerLength { get; set; }
Visual Basic

Public Property PointerLength As Single

Property Value

A float value that specifies the length of the pointer to outer pie labels.

Remarks

A pointer is drawn from the middle of the edge of a pie piece to the label outside it. Labels are drawn when the OuterLabelType of the pie is not set to LabelType.Empty.

The length of the piece pointer is included in the PieMargins property, if specified.

Default value for the PointerLength property is 10f.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.RadiusLength Property

PieChart.RadiusLength Property

Specifies the radius length of the pie chart.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float RadiusLength { get; set; }
Visual Basic

Public Property RadiusLength As Single

Property Value

A float value that specifies the length of the pie radius, in points.

Remarks

The property sets how big the pie is drawn.

When the chart is 3D, use Pie3DThickness and Pie3DTension to specify the thickness and tension of the pie.

Default value for the RadiusLength property is 100F.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.PieChart.StartAngle Property

PieChart.StartAngle Property

Gets or sets the start angle for drawing the pieces of the pie.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float StartAngle { get; set; }
Visual Basic

Public Property StartAngle As Single

Property Value

A float value that specifies the start angle for the chart, clockwise, in degrees. Values should range from 0 to 360.

Remarks

The property specifies the start angle for drawing the pieces of the pie. Possible values range from 0 to 360.

The data for the pie pieces is set with Data.

Default value for the StartAngle property is 0.

See Also

PieChart Members
PieChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart Class

RadarChart Class
Remarks See Also

A class used to draw radar charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public class RadarChart : Chart, ISupportInitialize
Visual Basic

Public Class RadarChart
Inherits Chart
Implements ISupportInitialize

Remarks

RadarChart inherits properties and methods from its base class Chart.

MindFusion.Charting can draw both 2D and 3D radar and polar charts. The different radar types are listed as members of the RadarType Enumeration. 3D charts are drawn with a 3D-like background, which color is specified with the Background3D color.

The style of the radar / polar chart is set by the RadarStyle property. The property's values allow bitwise combination.

The brushes and pens that are used in radar charts are set with ChartBrushes and ChartPens. It is not necessary to set both. Use ShapeBrushes and ShapePens to set how data points are drawn.

Typically, a radar chart has as many outer axes as the count of data series. They are drawn as concentrical circles. The biggest one is the OuterAxis, the rest are alternative outer axes. Set SpiderWeb to true to draw the outer axes as polygons instead of circles. They are drawn with AltAxesPens. In polar charts, the outer axis holds information about the angles of the data points. They are specified with the Angles property.

The outer axis is drawn with the OuterAxisPen. Labels can be drawn at the intersection points of the outer axis with each inner axis. The type of those labels is set with OuterAxisLabelType. Labels might also be drawn in the middle of each segment - they are only custom text and are set with OuterLabels.

AxisLabelType.ChartData is not applied for specifying the OuterAxisLabelType property. AxisLabelType.AutoScale is used only in RadarChart objects.

Usually a radar chart will have as many inner axes as the count of elements in the longest Data series. The inner axes are drawn as radiuses. One of them is the primary InnerAxis and its position is set with InnerAxisPosition. The InnerAxis holds the scale divisions for the radar data. It starts from MinValue and ends with MaxValue. The Span property determines the count of the divisions.

The InnerAxis is drawn with the InnerAxisPen. Its labels depend on InnerAxisLabelType. Custom labels are set with InnerAxisLabels. If the labels are numbers, they are formatted with InnerLabelFormat.

The chart background can be drawn in sections or segments. Sections resemble concentric circumferences drawn with brushes from the SectionBrushes property. The positions of the sections are specified with SectionPoints.

Segments represent triangular-like areas within two inner axes. They are filled with brushes taken consecutively from the SegmentBrushes.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Charting.WinForms.Chart
MindFusion.Charting.WinForms.RadarChart

See Also

RadarChart Members
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart Members

RadarChart Members
Constructors Properties Methods

A class used to draw radar charts.

The following tables list the members exposed by the RadarChart type.

Public Constructors

Name | Description
RadarChart | Creates a new instance of the RadarChart class.

Public Properties

Name | Description
AltAxesCount | Gets or sets the count of alternative chart axes.
AltAxesPens | Specifies the collection of pens used for drawing the alternative axes.
Angles | Specifies the angles of data points in polar charts.
Background3D | Gets or sets whether the chart is drawn with 3D effect.
Data | Gets or sets the data for the chart series.
DataFields | Gets or sets the field in the data source used to populate the Data array.
InnerAxisLabels | Gets or sets custom labels for the inner axis.
InnerAxisLabelsField | Gets or sets the database field, which values are used as labels for the inner axis.
InnerAxisLabelType | Gets or sets the label type of the inner axis.
InnerAxisPen | Gets or sets the pen for drawing the inner axis.
InnerAxisPosition | Gets or sets the position of the inner axis.
InnerLabelFormat | Gets or sets the format for labels drawn at the inner axis.
LabelPrefix | Gets or sets the prefix for radar labels.
LabelSuffix | Gets or sets the suffix for radar labels.
MaxValue | Gets or sets the end value at the inner axis.
MinValue | Gets or sets the start value of the inner axis.
OuterAxisLabelBackground | Gets or sets the brush for filling the background of the border for outer axis labels.
OuterAxisLabelBorder | Gets or sets the border type drawn around outer axis labels.
OuterAxisLabelMargin | Gets or sets the margin between each outer axis label and its border.
OuterAxisLabelOutline | Gets or sets the pen for drawing the outline of the label border for outer axis labels.
OuterAxisLabels | Gets or sets custom labels drawn at the outer axis.
OuterAxisLabelsField | Gets or sets the database field, which values are used as labels for the outer axis.
OuterAxisLabelType | Specifies the type of labels drawn at the outer axis.
OuterAxisPen | Specifies the pen for drawing the outer chart axis.
OuterLabelBackground | Gets or sets the brush for filling the background of the border for outer labels.
OuterLabelBorder | Gets or sets the type border drawn around outer labels.
OuterLabelFormat | Gets or sets the format for labels drawn at the outer chart axis.
OuterLabelMargin | Gets or sets the margin between each outer label and its border.
OuterLabelOutline | Gets or sets the pen for drawing the outline of the label border for outer labels.
OuterLabels | Specifies the custom labels drawn at the chart segments of the outer axis.
OuterLabelsField | Gets or sets the database field, which values are used as labels drawn in the middle of radar segments.
RadarStyle | Gets or sets the style of the radar / polar chart to be drawn.
RadarType | Gets or sets the type of the radar chart to be drawn.
RadiusLength | Specifies the length of the chart radius.
SectionBrushes | Specifies the brushes for drawing the sections of the chart circle.
SectionPoints | Gets or sets the width and location of radar sections.
SegmentBrushes | Specifies the brushes for filling chart background segments.
ShapeBrushes | Specifies the brushes for filling data point shapes.
ShapePens | Specifies the pens for outlining the shapes drawn at data points.
Shapes | Specifies the shapes for data points.
ShapeSizes | Specifies the size of shapes drawn at data points.
Span | Specifies the numerical span of scale division at the inner axes.
SpiderWeb | Specifies whether the outer chart axes are drawn as circles or polygons.

Public Methods

Name | Description
BeginInit | Begins the run-time initialization of an instance of the RadarChart class that is used on a form or by another component.
EndInit | Ends the run-time initialization of an instance of the RadarChart class that is used on a form or by another component.

See Also

RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart Constructor

RadarChart Constructor

Creates a new instance of the RadarChart class.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public RadarChart ()
Visual Basic

Public Sub New ()

See Also

RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart Methods

RadarChart Methods

Public Methods

Name | Description
BeginInit | Begins the run-time initialization of an instance of the RadarChart class that is used on a form or by another component.
EndInit | Ends the run-time initialization of an instance of the RadarChart class that is used on a form or by another component.

See Also

RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.BeginInit Method

RadarChart.BeginInit Method

Begins the run-time initialization of an instance of the RadarChart class that is used on a form or by another component.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void BeginInit ()
Visual Basic

Public Sub BeginInit ()

Remarks

The Visual Studio .NET design environment uses this method to start the initialization of the RadarChart component that is used on a form or by another component. The EndInit method ends the initialization. Using the BeginInit and EndInit methods prevents the control from being used before it is fully initialized.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.EndInit Method

RadarChart.EndInit Method

Ends the run-time initialization of an instance of the RadarChart class that is used on a form or by another component.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public void EndInit ()
Visual Basic

Public Sub EndInit ()

Remarks

The Visual Studio .NET design environment uses this method to end the initialization of a component that is used on a form or by another component. The BeginInit method starts the initialization. Using the BeginInit and EndInit methods prevents the control from being used before it is fully initialized.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart Properties

RadarChart Properties

Public Properties

Name | Description
AltAxesCount | Gets or sets the count of alternative chart axes.
AltAxesPens | Specifies the collection of pens used for drawing the alternative axes.
Angles | Specifies the angles of data points in polar charts.
Background3D | Gets or sets whether the chart is drawn with 3D effect.
Data | Gets or sets the data for the chart series.
DataFields | Gets or sets the field in the data source used to populate the Data array.
InnerAxisLabels | Gets or sets custom labels for the inner axis.
InnerAxisLabelsField | Gets or sets the database field, which values are used as labels for the inner axis.
InnerAxisLabelType | Gets or sets the label type of the inner axis.
InnerAxisPen | Gets or sets the pen for drawing the inner axis.
InnerAxisPosition | Gets or sets the position of the inner axis.
InnerLabelFormat | Gets or sets the format for labels drawn at the inner axis.
LabelPrefix | Gets or sets the prefix for radar labels.
LabelSuffix | Gets or sets the suffix for radar labels.
MaxValue | Gets or sets the end value at the inner axis.
MinValue | Gets or sets the start value of the inner axis.
OuterAxisLabelBackground | Gets or sets the brush for filling the background of the border for outer axis labels.
OuterAxisLabelBorder | Gets or sets the border type drawn around outer axis labels.
OuterAxisLabelMargin | Gets or sets the margin between each outer axis label and its border.
OuterAxisLabelOutline | Gets or sets the pen for drawing the outline of the label border for outer axis labels.
OuterAxisLabels | Gets or sets custom labels drawn at the outer axis.
OuterAxisLabelsField | Gets or sets the database field, which values are used as labels for the outer axis.
OuterAxisLabelType | Specifies the type of labels drawn at the outer axis.
OuterAxisPen | Specifies the pen for drawing the outer chart axis.
OuterLabelBackground | Gets or sets the brush for filling the background of the border for outer labels.
OuterLabelBorder | Gets or sets the type border drawn around outer labels.
OuterLabelFormat | Gets or sets the format for labels drawn at the outer chart axis.
OuterLabelMargin | Gets or sets the margin between each outer label and its border.
OuterLabelOutline | Gets or sets the pen for drawing the outline of the label border for outer labels.
OuterLabels | Specifies the custom labels drawn at the chart segments of the outer axis.
OuterLabelsField | Gets or sets the database field, which values are used as labels drawn in the middle of radar segments.
RadarStyle | Gets or sets the style of the radar / polar chart to be drawn.
RadarType | Gets or sets the type of the radar chart to be drawn.
RadiusLength | Specifies the length of the chart radius.
SectionBrushes | Specifies the brushes for drawing the sections of the chart circle.
SectionPoints | Gets or sets the width and location of radar sections.
SegmentBrushes | Specifies the brushes for filling chart background segments.
ShapeBrushes | Specifies the brushes for filling data point shapes.
ShapePens | Specifies the pens for outlining the shapes drawn at data points.
Shapes | Specifies the shapes for data points.
ShapeSizes | Specifies the size of shapes drawn at data points.
Span | Specifies the numerical span of scale division at the inner axes.
SpiderWeb | Specifies whether the outer chart axes are drawn as circles or polygons.

See Also

RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.AltAxesCount Property

RadarChart.AltAxesCount Property

Gets or sets the count of alternative chart axes.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public int AltAxesCount { get; set; }
Visual Basic

Public Property AltAxesCount As Integer

Property Value

An int value that specifies the count of alternative axes.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.AltAxesPens Property

RadarChart.AltAxesPens Property

Specifies the collection of pens used for drawing the alternative axes.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public PenCollection AltAxesPens { get; set; }
Visual Basic

Public Property AltAxesPens As PenCollection

Property Value

An instance of type MindFusion.Drawing.PenCollection class.

Remarks

The property specifies the pens for drawing the alternative axes. The alternative axes are circumferences, which are concentric to the outer axes (the outlining) of the chart. If SpiderWeb is set to true, the axes are polygons.

The count of the alternative axes depends on the divisions of the inner axis. They are determined by the MinValue, MaxValue and the Span properties. If those are not set, the count is calculates based on the count of data series, added to the Data property.

No alternative axes are drawn if the AltAxesPens collection is empty. None of the alternative axes replace the outer axis, which is always drawn.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.Angles Property

RadarChart.Angles Property

Specifies the angles of data points in polar charts.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList Angles { get; set; }
Visual Basic

Public Property Angles As IList

Property Value

An object of type .NET IList class that holds other lists with the angles. Angles are measured clockwise, in degrees; values range from 0 to 360.

Remarks

This property is used only in polar charts. In polar charts, the position of each data point is specified by the value of the point and an angle. The values are set with Data, the angles - with Angles.

The property contains lists with angles. The values must range from 0 to 360. If an angle is not in this range, it is transformed by deduction or addition of 360 as many times as necessary until it fits the interval.

In radar charts, data points are always positioned at equal angles on the inner axes. In polar charts, points can be distributed unevenly in the circle.

If a member in the Data array has no corresponding angle in the Angles array and Angles is not empty, the data point angle is considered to be 0.

If Angles are not specified and the chart type is Polar2D / Polar3D, the angles are calculated automatically as in radar charts.

Default value for the Angles property is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.Background3D Property

RadarChart.Background3D Property

Gets or sets whether the chart is drawn with 3D effect.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Color Background3D { get; set; }
Visual Basic

Public Property Background3D As Color

Property Value

An instance of .NET Color structure.

Remarks

The property specifies the color of the chart background if the RadarType is set to RadarType.Radar3D or RadarType.Polar3D.

When a 3D chart is drawn, the 3D effect is achieved by changing the color angles of the chart background. That's why no brushes are suitable for painting the background in these types of charts.

If the radar chart is 2D, you can specify different brushes and types of background. Please check the SectionBrushes, SectionPoints and SegmentBrushes properties for further details.

Default value for the Background3D property is Color.Grey.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.Data Property

RadarChart.Data Property

Gets or sets the data for the chart series.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList Data { get; set; }
Visual Basic

Public Property Data As IList

Property Value

An instance of type .NET IList that holds other lists with numbers.

Remarks

The property holds lists with data for each radar graphics. Data can be numbers or in any other format that can be parsed to numbers.

Data lists might vary in count. The count of the longest series determines the count of the inner axes. They are drawn as equally distributed radiuses.

The position of data points is calculated using the inner axis scale. The scale starts with MinValue ends with MaxValue and the length of the intervals depends on Span. If those properties are not set, the smallest and biggest Data numbers are taken as minimum and maximum scale values. The span is calculated automatically based on the count of lists in Data.

If the chart is polar, the position of the data points depends also on the value of the angle that corresponds to that point. The angles are set with Angles.

Default value for the Data property is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.DataFields Property

RadarChart.DataFields Property

Gets or sets the field in the data source used to populate the Data array.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string DataFields { get; set; }
Visual Basic

Public Property DataFields As String

Property Value

A string that specifies the name(s) of the data field(s).

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.RadarChart.InnerAxisLabels Property

RadarChart.InnerAxisLabels Property

Gets or sets custom labels for the inner axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList InnerAxisLabels { get; set; }
Visual Basic

Public Property InnerAxisLabels As IList

Property Value

An instance of type .NET IList that holds custom labels for the inner axis.

Remarks

The property specifies the custom labels for the inner axis. Inner labels are drawn at the scale divisions of the inner axes. The inner labels might not only be custom text, but also numbers. The InnerAxisLabelType property specifies the type of the labels.

Radar / polar charts can also have labels at radar segments and / or at the crossing points of the inner and outer axes. The type of labels is set with InnerAxisLabelType.

Default value for the InnerAxisLabels property is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.InnerAxisLabelsField Property

RadarChart.InnerAxisLabelsField Property

Gets or sets the database field, which values are used as labels for the inner axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string InnerAxisLabelsField { get; set; }
Visual Basic

Public Property InnerAxisLabelsField As String

Property Value

A string that specifies the name of the database field.

Remarks

The property enables you to bind the labels drawn at the inner radar axis to a field in a database. The data source object is specified with the DataSource property. If it is of type DataSet, you can use the DataMember property to specify a particular table as source for the chart data. In this case the fields of the table appear as items in the drop down combo box in the InnerAxisLabelsField property of the radar control.

The labels specified with the InnerAxisLabelsField are drawn only if the InnerAxisLabelType property of the chart is set to LabelType.CustomText.

The InnerAxisLabelsField property, when populated with data, is the same as the InnerAxisLabels property.

Default value for the InnerAxisLabelsField property is an empty string ("").

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.RadarChart.InnerAxisLabelType Property

RadarChart.InnerAxisLabelType Property

Gets or sets the label type of the inner axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public AxisLabelType InnerAxisLabelType { get; set; }
Visual Basic

Public Property InnerAxisLabelType As AxisLabelType

Property Value

One of the AxisLabelType Enumeration values.

Remarks

The property specifies the type of labels drawn at the inner chart axis. If the InnerAxisLabelType is set to AxisLabelType.CustomText, the labels are specified with InnerAxisLabels.

The format of the labels, when numbers, is set with InnerLabelFormat.

Radar / polar charts can also have labels at radar segments and / or at the crossing points of the inner and outer axes. The type of these labels is set with OuterAxisLabelType. Custom labels are set with OuterLabels and OuterAxisLabels.

Default value for the InnerAxisLabelType property is AxisLabelType.Empty.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.InnerAxisPen Property

RadarChart.InnerAxisPen Property

Gets or sets the pen for drawing the inner axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen InnerAxisPen { get; set; }
Visual Basic

Public Property InnerAxisPen As Pen

Property Value

An instance of MindFusion.Drawing.Pen class.

Remarks

The property specifies the pen for drawing the inner axes of the chart. The inner axes coincide with some of the radiuses for the chart. The primary inner axes, the one that holds labels on it, is positioned as set with the InnerAxisPosition. The count of the inner axes depends on the count of elements in the longest list added to the Data property.

Only one of the inner axis has labels. The type of the labels is set with InnerAxisLabelType, custom labels are specified with InnerAxisLabels.

All inner axes are drawn with the same pen. In contrast, the outer axis is drawn with OuterAxisPen, while alternative axes, concentric to the outer one, are drawn with pens from the AltAxesPens property.

Default value for the InnerAxisPen property is a MindFusion.Drawing.Pen with black color and default width.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.InnerAxisPosition Property

RadarChart.InnerAxisPosition Property

Gets or sets the position of the inner axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Position InnerAxisPosition { get; set; }
Visual Basic

Public Property InnerAxisPosition As Position

Property Value

One of the Position Enumeration values.

Remarks

The property specifies the position of the primary inner chart axis. Each radar / polar chart can have many inner axes, which look like radiuses, equally distributed in the chart circle (polygon). The count of the inner axes depends on the count of the longest list added to the Data property.

All inner axes are drawn with the InnerAxisPen. Only one of them has labels on it and its position is specified with InnerAxisPosition.

The type of labels drawn at the inner axis is specified with InnerAxisLabelType. Custom labels are set with InnerAxisLabels.

Default value for the InnerAxisPosition property is Position.Bottom.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.InnerLabelFormat Property

RadarChart.InnerLabelFormat Property

Gets or sets the format for labels drawn at the inner axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public NumberFormat InnerLabelFormat { get; set; }
Visual Basic

Public Property InnerLabelFormat As NumberFormat

Property Value

One of the NumberFormat Enumeration values.

Remarks

The property specifies the format of labels drawn at the inner axis. The InnerAxisLabelType property identifies the type of the labels at the inner axis. If the labels are custom text, use InnerAxisLabels to set them.

Inner labels are drawn at the scale division of the inner axis.

InnerAxisPosition sets the position of the inner axis. Radar charts might have many inner axes but only the one drawn at the InnerAxisPosition has labels.

Default value for the InnerLabelFormat property is NumberFormat.Fixed_point.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace
MinValue
MaxValue
Span


MindFusion.Charting.WinForms.RadarChart.LabelPrefix Property

RadarChart.LabelPrefix Property

Gets or sets the prefix for radar labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string LabelPrefix { get; set; }
Visual Basic

Public Property LabelPrefix As String

Property Value

Remarks

The property specifies a prefix drawn before each label at the inner and / or outer axis of radar charts. Prefix is not drawn when the axis has no labels or shows the auto scale.

There are no limitations as to the format or length of the prefix. You can use LabelPrefix to set unit of measure, currency mark or any other text related to your data.

Default value for the LabelPrefix property is an empty string.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.LabelSuffix Property

RadarChart.LabelSuffix Property

Gets or sets the suffix for radar labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string LabelSuffix { get; set; }
Visual Basic

Public Property LabelSuffix As String

Property Value

A string.

Remarks

The property specifies a suffix drawn after each label at the inner and / or outer axis of radar charts. Suffix is not drawn when the axis has no labels or shows the auto scale.

There are no limitations as to the format or length of the suffix. You can use LabelSuffix to set unit of measure, currency mark or any other text related to your data.

Default value for the LabelSuffix property is an empty string.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.MaxValue Property

RadarChart.MaxValue Property

Gets or sets the end value at the inner axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public double MaxValue { get; set; }
Visual Basic

Public Property MaxValue As Double

Property Value

A double value that specifies the maximum number.

Remarks

The property specifies the end value for the inner axis. Together with MinValue and Span it is used for calculating the scale divisions of the inner axis. If max value is not set, the maximum number of all data series added to the Data property is considered.

The scale divisions can be drawn as labels at the inner axis, when the InnerAxisLabelType is set to AxisLabelType.AutoScale. The format of the numbers is set with InnerLabelFormat.

Default value for the MaxValue property is Double.NaN.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.MinValue Property

RadarChart.MinValue Property

Gets or sets the start value of the inner axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public double MinValue { get; set; }
Visual Basic

Public Property MinValue As Double

Property Value

A double number that specifies the minimum value.

Remarks

The property specifies the start value for the auto scale of the inner axis. Together with MaxValue and Span it is used for calculating the scale divisions of the inner axis. If MinValue is not set, the minimum number of all data series added to the Data property is considered.

The scale divisions can be drawn as labels at the inner axis, when the InnerAxisLabelType is set to AxisLabelType.AutoScale. The format of the numbers is set with InnerLabelFormat.

Default value for the MinValue property is Double.NaN.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterAxisLabelBackground Property

RadarChart.OuterAxisLabelBackground Property

Gets or sets the brush for filling the background of the border for outer axis labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush OuterAxisLabelBackground { get; set; }
Visual Basic

Public Property OuterAxisLabelBackground As Brush

Property Value

An instance of MindFusion.Drawing.Brush class. Default is a light blue SolidBrush.

Remarks

OuterAxisLabelBorder specifies the border drawn around labels at the outer axis. The border rectangle is drawn with OuterAxisLabelOutline. The space between the label and its border is set with OuterAxisLabelMargin.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterAxisLabelBorder Property

RadarChart.OuterAxisLabelBorder Property

Gets or sets the border type drawn around outer axis labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Border OuterAxisLabelBorder { get; set; }
Visual Basic

Public Property OuterAxisLabelBorder As Border

Property Value

One of the Border Enumeration values. Default is Border.None.

Remarks

Border rectangles around labels at the outer axis are drawn with OuterAxisLabelOutline and filled with OuterAxisLabelBackground. The space between the label and its border is set with OuterAxisLabelMargin.

The type of labels drawn at the outer axis depends on OuterAxisLabelType.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterAxisLabelMargin Property

RadarChart.OuterAxisLabelMargin Property

Gets or sets the margin between each outer axis label and its border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float OuterAxisLabelMargin { get; set; }
Visual Basic

Public Property OuterAxisLabelMargin As Single

Property Value

A float value. Default is 5f.

Remarks

Use OuterAxisLabelBorder to specify the border type. The border rectangle is drawn with OuterAxisLabelOutline and filled with OuterAxisLabelBackground.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterAxisLabelOutline Property

RadarChart.OuterAxisLabelOutline Property

Gets or sets the pen for drawing the outline of the label border for outer axis labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen OuterAxisLabelOutline { get; set; }
Visual Basic

Public Property OuterAxisLabelOutline As Pen

Property Value

An instance of type MindFusion.Drawing.Pen class. Default is a black Pen, width 1.

Remarks

Use OuterAxisLabelBorder to specify the type of border drawn around labels at the outer axis. The border rectangle is filled with OuterAxisLabelBackground. The space between the label and its border is set with OuterAxisLabelMargin.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterAxisLabels Property

RadarChart.OuterAxisLabels Property

Gets or sets custom labels drawn at the outer axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList OuterAxisLabels { get; set; }
Visual Basic

Public Property OuterAxisLabels As IList

Property Value

An instance of type .NET IList that holds the labels for the outer axis.

Remarks

The property specifies the custom labels drawn at the outer axis.

In radar / polar charts, the outer axis is the bounding circumference (polygon) for the radar / polar. The outer axis is just one, the circles (polygons) drawn concentric to it are called alternative axes.

OuterAxisLabels specifies the labels drawn at the crossing points of the outer axis with the inner axes when the OuterAxisLabelType is set to AxisLabelType.CustomText. In polar carts the axis labels can also be the angles grades. Labels can also be drawn in the middle of the outer axis segments. They are only custom-set and are specified with OuterLabels.

The labels are drawn with LabelBrush.

Default value for the OuterAxisLabels property is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterAxisLabelsField Property

RadarChart.OuterAxisLabelsField Property

Gets or sets the database field, which values are used as labels for the outer axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string OuterAxisLabelsField { get; set; }
Visual Basic

Public Property OuterAxisLabelsField As String

Property Value

A string that specifies the name of the database field.

Remarks

The property enables you to bind the labels drawn at the outer radar axis to a field in a database. The data source object is specified with the DataSource property. If it is of type DataSet, you can use the DataMember property to specify a given table as source for the chart data. In this case, the fields of the table appear as items in the drop down combo box in the OuterAxisLabelsField property of the radar control.

The labels specified with the OuterAxisLabelsField are drawn only if the OuterAxisLabelType property of the chart is set to LabelType.CustomText.

The OuterAxisLabelsField property, when populated with data, is the same as the InnerAxisLabels property.

Default value for the OuterAxisLabelsField property is an empty string ("").

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.RadarChart.OuterAxisLabelType Property

RadarChart.OuterAxisLabelType Property

Specifies the type of labels drawn at the outer axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public AxisLabelType OuterAxisLabelType { get; set; }
Visual Basic

Public Property OuterAxisLabelType As AxisLabelType

Property Value

One of the AxisLabelType Enumeration values.

Remarks

The property specifies the type of labels drawn at the outer chart axis. When it is set to AxisLabelType.CustomText, the labels are specified with OuterAxisLabels.

In radar / polar charts, the outer axis is the bounding circumference (polygon) for the radar / polar. The outer axis is just one, the circles (polygons) drawn concentric to it are called alternative axes.

Labels can also be drawn in the middle of the outer axis segments. They are only custom-set and are specified with OuterLabels.

AxisLabelType.ChartData is not applied for specifying the OuterAxisLabelType property. AxisLabelType.AutoScale is used only in RadarChart objects.

The labels are drawn with LabelBrush.

Default value for the OuterAxisLabelType property is AxisLabelType.Empty.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterAxisPen Property

RadarChart.OuterAxisPen Property

Specifies the pen for drawing the outer chart axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen OuterAxisPen { get; set; }
Visual Basic

Public Property OuterAxisPen As Pen

Property Value

An instance of type MindFusion.Drawing.Pen class.

Remarks

The property specifies the pen for drawing the outer chart axis.

In radar / polar charts, the outer axis is the bounding circumference (polygon) for the radar / polar. The outer axis is just one, the circles (polygons) drawn concentric to it are called alternative axes. The shape of the outer axis - circle or polygon depends on the SpiderWeb property.

The outer axis can have two types of labels: in the middle of chart segments and / or at the crossing points with the inner axes. The properties for the labels are OuterAxisLabelType, OuterAxisLabels and OuterLabels.

Default value for the OuterAxisPen property is a Pen with black color and default width.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterLabelBackground Property

RadarChart.OuterLabelBackground Property

Gets or sets the brush for filling the background of the border for outer labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Brush OuterLabelBackground { get; set; }
Visual Basic

Public Property OuterLabelBackground As Brush

Property Value

An instance of MindFusion.Drawing.Brush class. Default is light blue SolidBrush.

Remarks

The border around OuterLabels is set with OuterLabelBorder. It is drawn with OuterLabelOutline. The space between the outer label and its border is set with OuterLabelMargin.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterLabelBorder Property

RadarChart.OuterLabelBorder Property

Gets or sets the type border drawn around outer labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Border OuterLabelBorder { get; set; }
Visual Basic

Public Property OuterLabelBorder As Border

Property Value

One of the Border Enumeration values. Default is Border.None.

Remarks

The border rectangle of OuterLabels is drawn with OuterLabelOutline and filled with OuterLabelBackground. The space between the outer label and its border is set with OuterLabelMargin.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterLabelFormat Property

RadarChart.OuterLabelFormat Property

Gets or sets the format for labels drawn at the outer chart axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public NumberFormat OuterLabelFormat { get; set; }
Visual Basic

Public Property OuterLabelFormat As NumberFormat

Property Value

One of the NumberFormat Enumeration values.

Remarks

The property specifies how labels at the outer axis are formatted.

In polar charts, setting the value of the property to AxisLabelType.AutoScale draws the grads from 0 to 360. Radar charts do not use scale as outer axis.

The outer axis labels are drawn at the crossing points of the inner axes with the outer axis. Labels can also be drawn at the middle of the axes segments. Those labels are only custom text and are set with OuterLabels.

Default value for the OuterLabelFormat property is NumberFormat.Fixed_point.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterLabelMargin Property

RadarChart.OuterLabelMargin Property

Gets or sets the margin between each outer label and its border.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float OuterLabelMargin { get; set; }
Visual Basic

Public Property OuterLabelMargin As Single

Property Value

A float value. Default is 5f.

Remarks

The border of OuterLabels is set with OuterLabelBorder. It is drawn with OuterLabelOutline and filled with OuterLabelBackground.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterLabelOutline Property

RadarChart.OuterLabelOutline Property

Gets or sets the pen for drawing the outline of the label border for outer labels.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public Pen OuterLabelOutline { get; set; }
Visual Basic

Public Property OuterLabelOutline As Pen

Property Value

An instance of type MindFusion.Drawing.Pen class. Default is a black Pen, width 1.

Remarks

Use OuterLabelBorder to specify the type of border drawn around OuterLabels. The border rectangle is filled with OuterLabelBackground. OuterLabelMargin specifies the space between the outer label and its border.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterLabels Property

RadarChart.OuterLabels Property

Specifies the custom labels drawn at the chart segments of the outer axis.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList OuterLabels { get; set; }
Visual Basic

Public Property OuterLabels As IList

Property Value

An instance of type .NET IList that holds the outer labels.

Remarks

Use the property to specify the labels, drawn at the outer segments of the radar charts. You can assign to OuterLabels the array that holds the labels or add them directly to the OuterLabels property.

In radar / polar charts, the outer axis is the bounding circumference (polygon) for the radar / polar. The outer axis is just one, the circles (polygons) drawn concentric to it are called alternative axes.

Labels can also be drawn at the crossing points of the outer axis and the inner axes. Their type is set with OuterAxisLabelType. Labels drawn at the inner axis are specified with InnerAXisLabelType and InnerAxisLabels properties.

Default value for the OuterLabels property is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.OuterLabelsField Property

RadarChart.OuterLabelsField Property

Gets or sets the database field, which values are used as labels drawn in the middle of radar segments.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public string OuterLabelsField { get; set; }
Visual Basic

Public Property OuterLabelsField As String

Property Value

A string that specifies the name of the database field.

Remarks

The property enables you to bind the labels drawn at the center of radar cahrt's segments to a field in a database. The data source object is specified with the DataSource property. If it is of type DataSet you can use the DataMember property to specify a given table as source for the chart data. In this case the fields of the table appear as items in the drop down combo box in the OuterLabelsField property of the radar control.

The OuterLabelsField property, when populated with data, is the same as the OuterLabels property.

Default value for the OuterLabelsField property is an empty string ("").

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace
Retrieving Chart Data from a Database


MindFusion.Charting.WinForms.RadarChart.RadarStyle Property

RadarChart.RadarStyle Property

Gets or sets the style of the radar / polar chart to be drawn.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public RadarStyle RadarStyle { get; set; }
Visual Basic

Public Property RadarStyle As RadarStyle

Property Value

One of the RadarStyle Enumeration values.

Remarks

RadarStyle property specifies the drawing style for both radar and polar charts. The RadarStyle enumeration members allow bitwise combination for more styles, for example, you can draw radar lines with shapes at data points.

The type of the chart is set with RadarType.

All charts are drawn with pens and brushes from the ChartPens and ChartBrushes property. The data for the chart is set with Data and, for polar charts, Angles.

Default value for the RadarStyle property is RadarStyle.Lines.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.RadarType Property

RadarChart.RadarType Property

Gets or sets the type of the radar chart to be drawn.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public RadarType RadarType { get; set; }
Visual Basic

Public Property RadarType As RadarType

Property Value

One of the RadarType Enumeration values.

Remarks

The property specifies whether the chart is radar or polar and if it is 2D or 3D. When using MindFusion.Charting programmatically, the initial RadarType is specified in the constructor.

The drawing style of the chart - lines, arcs and so on, is specified with RadarStyle.

All charts are drawn with pens and brushes from the ChartPens and ChartBrushes property. The data for the chart is set with Data and, for polar charts, Angles.

Default value for the RadarType property is RadarType.Radar2D.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.RadiusLength Property

RadarChart.RadiusLength Property

Specifies the length of the chart radius.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public float RadiusLength { get; set; }
Visual Basic

Public Property RadiusLength As Single

Property Value

A float value that specifies the length of the radius, in points.

Remarks

The property specifies the size of the radius of the chart. When the chart is 3D, the size remains intact, which the 3D look is achieved only graphically.

The property is valid also for charts that draw their outer axes as polygons. This is set when the SpiderWeb property is set to true.

Default value for the radius length is 100f.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.SectionBrushes Property

RadarChart.SectionBrushes Property

Specifies the brushes for drawing the sections of the chart circle.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection SectionBrushes { get; set; }
Visual Basic

Public Property SectionBrushes As BrushCollection

Property Value

An instance of MindFusion.Drawing.BrushCollection class.

Remarks

The property specifies the brushes for drawing background sections. The sections are circles (polygons) concentric to the outer axis. The outer axis is the chart bounding circumference (polygon).

The positions of the sections are calculated based on the SectionPoints property. Its values should range from 0 to 100.

When the brushes are less than the count of sections, MindFusion.Charting cycles through them again. The brushes follow the order of setting the section points - brushes for the bigger sections should be added last.

The sections are drawn as polygons when SpiderWeb is set to true.

Alternatively, the chart background can be drawn as differently colored segments. Use SegmentBrushes to specify the brushes for that.

Background is drawn when any of the SectionBrushes or SegmentBrushes is not an empty collection. If both are specified, the background is drawn in sections.

Default value for the SectionBrushes property is an empty BrushCollection.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.SectionPoints Property

RadarChart.SectionPoints Property

Gets or sets the width and location of radar sections.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList SectionPoints { get; set; }
Visual Basic

Public Property SectionPoints As IList

Property Value

An instance of type .NET IList that holds numbers, which show the distance between radar center and the section edge as percent from the radius. Values should range from 0 to 100.

Remarks

The property specifies the positions of chart background sections. The sections are circles (polygons) concentric to the outer axis. The outer axis is the chart bounding circumference (polygon).

The positions of the sections are calculated relatively to the length of the chart radius.

The sections are filled with brushes from the SectionBrushes property. When the brushes are less than the count of sections, MindFusion.Charting cycles through them again. The brushes follow the order of setting the section points - brushes for the bigger sections should be added last.

The sections are drawn as polygons when SpiderWeb is set to true.

Alternatively, the chart background can be drawn as differently colored segments. Use SegmentBrushes to specify the brushes for that.

Background is drawn when any of the SectionBrushes or SegmentBrushes is not an empty collection. If both are specified, the background is drawn in sections.

Default value for the SectionPoints property is an empty IList.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.SegmentBrushes Property

RadarChart.SegmentBrushes Property

Specifies the brushes for filling chart background segments.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection SegmentBrushes { get; set; }
Visual Basic

Public Property SegmentBrushes As BrushCollection

Property Value

An instance of MindFusion.Drawing.BrushCollection class.

Remarks

The property specifies the brushes for drawing the segments of the chart circle. A segment is a rectangular-like area between two inner axes. The inner axes are radiuses, distributed equally inside the chart. They start from the InnerAxisPosition of the inner chart. The count of the inner axes, thus chart segments, depends on the count of elements in the longest list added to Data.

When the sections are more than the segment brushes, the control cycles again through the brushes.

The segments are triangles, when the chart outer axes are drawn as spider web, in this case SpiderWeb is set to true.

Default value for the SegmentBrushes property is an empty BrushCollection.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.ShapeBrushes Property

RadarChart.ShapeBrushes Property

Specifies the brushes for filling data point shapes.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public BrushCollection ShapeBrushes { get; set; }
Visual Basic

Public Property ShapeBrushes As BrushCollection

Property Value

An instance of type MindFusion.Drawing.BrushCollection class.

Remarks

Use the property to specify the brushes for filling shapes, drawn at data points. Shapes are drawn when the RadarStyle property is set to RadarStyle.Points.

Each Data series can be drawn with different shapes, which have different width. Add the desired Shape member and size to the Shapes and ShapeSizes property - lists. The shapes are drawn with pens from ShapePens.

When the ShapeBrushes are less than the count of data series added to the Data property, MindFusion.Charting cycles through them.

Default value for the ShapeBrushes property is an empty BrushCollection.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.ShapePens Property

RadarChart.ShapePens Property

Specifies the pens for outlining the shapes drawn at data points.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public PenCollection ShapePens { get; set; }
Visual Basic

Public Property ShapePens As PenCollection

Property Value

An instance of type MindFusion.Drawing.PenCollection class.

Remarks

Use the property to specify the pens for outlining the shapes, drawn at data points. Shapes are drawn when the RadarStyle property is set to RadarStyle.Points.

Each Data series can be drawn with different shapes, which have different width. Add the desired Shape member and size to the Shapes and ShapeSizes property - lists. The shapes are filled with brushes from the ShapeBrushes property. When the ShapePens are less than the count of data series added to the Data property, MindFusion.Charting cycles through them.

Default value for the ShapePens property is an empty PenCollection.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.Shapes Property

RadarChart.Shapes Property

Specifies the shapes for data points.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList Shapes { get; set; }
Visual Basic

Public Property Shapes As IList

Property Value

An instance of type .NET IList that holds Shape objects.

Remarks

Use the property to specify the shapes, drawn at data points. Shapes are drawn when the RadarStyle property is set to RadarStyle.Points.

Each Data series can be drawn with different shapes, which have different width. Add the desired Shape member and size to the Shapes and ShapeSizes lists.

The shapes are drawn with pens from ShapePens and are filled with brushes from ShapeBrushes.

Default value for the Shapes property is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.ShapeSizes Property

RadarChart.ShapeSizes Property

Specifies the size of shapes drawn at data points.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public IList ShapeSizes { get; set; }
Visual Basic

Public Property ShapeSizes As IList

Property Value

An instance of type .NET IList that holds float values, which represent the sizes.

Remarks

Use the property to specify the size of shapes drawn at data points. Shapes are drawn when the RadarStyle property is set to RadarStyle.Points.

Each Data series can be drawn with different shapes, which have different width. Add the desired Shape member to the Shapes property.

The shapes are drawn with pens and brushes from ShapePens and ShapeBrushes properties.

When the numbers in ShapeSizes are less than the count of data series added to the Data property, MindFusion.Charting cycles through them.

Default value for the ShapeSizes property is an empty list. If no shape is set, the shapes are drawn with width 10.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.Span Property

RadarChart.Span Property

Specifies the numerical span of scale division at the inner axes.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public double Span { get; set; }
Visual Basic

Public Property Span As Double

Property Value

A double value that specifies the span.

Remarks

The property specifies the span between scale divisions at the inner chart axes. The start and end values of the inner axis scale are set with MinValue and MaxValue.

The inner axis is one of the chart radiuses. Its position is specified with InnerAxisPosition.

The chart has as many inner axes as the count of elements in the longest series added to Data is. Only the axis at InnerAxisPosition has labels.

When the InnerAxisLabelType is set to AxisLabelType.AutoScale, the scale divisions are drawn. They are formatted with InnerLabelFormat.

Default value for the Span property is Double.NaN.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.RadarChart.SpiderWeb Property

RadarChart.SpiderWeb Property

Specifies whether the outer chart axes are drawn as circles or polygons.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public bool SpiderWeb { get; set; }
Visual Basic

Public Property SpiderWeb As Boolean

Property Value

A bool value; true if chart axes are drawn as polygons, otherwise false.

Remarks

The property specifies the shape of the outer and alternative axes - circle or polygon. The outer axis is the chart bounding circle, where the chart graphics are located. When SpiderWeb is true, the outer axes are drawn as a polygon.

The outer axis is only one and is the biggest circle (polygon). It is drawn with OuterAxisPen. The circles (polygons) drawn concentric to the outer axis are called alternative axes and are drawn with AltAxesPens.

The count of the alternative axes depends on the scale divisions of the inner axis.

Default value for the SpiderWeb property is false.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.WinForms Namespace


MindFusion.Charting.WinForms.ResizeType Enumeration

ResizeType Enumeration

Specifies how chart graphics fit into the chart control's bounding rectangle.

Namespace: MindFusion.Charting.WinForms
Assembly: MindFusion.Charting.WinForms

Syntax

C#

public enum ResizeType
Visual Basic

Public Enumeration ResizeType

Members

Member name | Description
Center | The chart is centered in the control's client rectangle.
Fit | The chart is resized proportionally and might not fit entirely the control's client rectangle if it's with different proportion.
Scrollable | The chart is scrolled when bigger than the control's client rectangle. Its size remains unchanged.
Stretch | The chart is stretched in order to fit the whole control's client rectangle and might grow un proportional if the client rectangle is with different proportions.

Remarks

The Enumeration specifies the chart behaviour when the control gets resized or when the chart graphics changes size. The resize style of the chart control is set with the ResizeType property.

See Also

MindFusion.Charting.WinForms Namespace


MindFusion.DataBinding Namespace
Classes Interfaces Enumerations

Classes

Class | Description
BoundProperty | Represents a mapping between a property and a field in the data source.
BoundPropertyList | Defines a mapping between properties and data source fields.
DataBinder | Stores or retrieves structured data to and from arbitrary collections of objects.
DataSourceTracker | Determines and manages the properties of a data source.

Interfaces

Interface | Description
BindingTarget |
IItemFactory | Provides methods for creating, adding and removing items from a collection during data-binding.
IVirtualPropertyProvider | Provides virtual properties on an object which can be data-bound.

Enumerations

Enumeration | Description
PropertyType | Specifies the way the data bound properties are interpreted.


MindFusion.DataBinding.BindingTarget Interface

BindingTarget Interface

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public interface BindingTarget
Visual Basic

Public Interface BindingTarget

See Also

BindingTarget Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BindingTarget Members

BindingTarget Members
Methods

The following tables list the members exposed by the BindingTarget type.

Public Methods

Name | Description
CollectionLoaded |

See Also

BindingTarget Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BindingTarget Methods

BindingTarget Methods

Public Methods

Name | Description
CollectionLoaded |

See Also

BindingTarget Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BindingTarget.CollectionLoaded Method

BindingTarget.CollectionLoaded Method

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public abstract void CollectionLoaded (
IList targetItems
)
Visual Basic

Public MustOverride Sub CollectionLoaded ( _
targetItems As IList _
)

Parameters

targetItems

See Also

BindingTarget Members
BindingTarget Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty Class

BoundProperty Class

Represents a mapping between a property and a field in the data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public class BoundProperty
Visual Basic

Public Class BoundProperty

Inheritance Hierarchy

System.Object
MindFusion.DataBinding.BoundProperty

See Also

BoundProperty Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty Members

BoundProperty Members
Constructors Properties

Represents a mapping between a property and a field in the data source.

The following tables list the members exposed by the BoundProperty type.

Public Constructors

Name | Description
BoundProperty | Overloaded.

Public Properties

Name | Description
ManyToManyTable | Gets or sets the name of the associated many-to-many table.
PropertyType | Gets or sets the type of the property.
SourceMember | Gets or sets the name of the corresponding field in the data source.
TargetMember | Gets or sets the name of the bound property.

See Also

BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty Constructor

BoundProperty Constructor

Overload List

Name | Description
BoundProperty (String, String, PropertyType) | Initializes a new instance of the BoundProperty class.
BoundProperty (String, String, PropertyType, String) | Initializes a new instance of the BoundProperty class.

See Also

BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty Constructor (String, String, PropertyType)

BoundProperty Constructor (String, String, PropertyType)
See Also

Initializes a new instance of the BoundProperty class.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public BoundProperty (
string sourceMember,
string targetMember,
PropertyType propertyType
)
Visual Basic

Public New ( _
sourceMember As String, _
targetMember As String, _
propertyType As PropertyType _
)

Parameters

sourceMember
The name of the field in the data source.
targetMember
The name of the property.
propertyType
The type of the property.

See Also

BoundProperty Constructor Overload List
BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty Constructor (String, String, PropertyType, String)

BoundProperty Constructor (String, String, PropertyType, String)
See Also

Initializes a new instance of the BoundProperty class.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public BoundProperty (
string sourceMember,
string targetMember,
PropertyType propertyType,
string manyToManyTable
)
Visual Basic

Public New ( _
sourceMember As String, _
targetMember As String, _
propertyType As PropertyType, _
manyToManyTable As String _
)

Parameters

sourceMember
The name of the field in the data source.
targetMember
The name of the property.
propertyType
The type of the property.
manyToManyTable
The name of the related table in the data source when the property type is ManyToMany.

See Also

BoundProperty Constructor Overload List
BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty Properties

BoundProperty Properties

Public Properties

Name | Description
ManyToManyTable | Gets or sets the name of the associated many-to-many table.
PropertyType | Gets or sets the type of the property.
SourceMember | Gets or sets the name of the corresponding field in the data source.
TargetMember | Gets or sets the name of the bound property.

See Also

BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty.ManyToManyTable Property

BoundProperty.ManyToManyTable Property

Gets or sets the name of the associated many-to-many table.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public string ManyToManyTable { get; set; }
Visual Basic

Public Property ManyToManyTable As String

Property Value

Remarks

Only valid if the property is of type ManyToMany.

See Also

BoundProperty Members
BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty.PropertyType Property

BoundProperty.PropertyType Property

Gets or sets the type of the property.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public PropertyType PropertyType { get; set; }
Visual Basic

Public Property PropertyType As PropertyType

Property Value

A member of the PropertyType Enumeration.

See Also

BoundProperty Members
BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty.SourceMember Property

BoundProperty.SourceMember Property

Gets or sets the name of the corresponding field in the data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public string SourceMember { get; set; }
Visual Basic

Public Property SourceMember As String

Property Value

See Also

BoundProperty Members
BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty.TargetMember Property

BoundProperty.TargetMember Property

Gets or sets the name of the bound property.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public string TargetMember { get; set; }
Visual Basic

Public Property TargetMember As String

Property Value

See Also

BoundProperty Members
BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundPropertyList Class

BoundPropertyList Class

Defines a mapping between properties and data source fields.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public class BoundPropertyList : List<BoundProperty>
Visual Basic

Public Class BoundPropertyList
Inherits List(Of BoundProperty)

Inheritance Hierarchy

System.Object
System.Collections.Generic.List(BoundProperty)
MindFusion.DataBinding.BoundPropertyList

See Also

BoundPropertyList Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundPropertyList Members

BoundPropertyList Members
Properties

Defines a mapping between properties and data source fields.

The following tables list the members exposed by the BoundPropertyList type.

Public Properties

Name | Description
IdField | Gets or sets the unique identifier field of the corresponding data member in the associated data source.

See Also

BoundPropertyList Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundPropertyList Properties

BoundPropertyList Properties

Public Properties

Name | Description
IdField | Gets or sets the unique identifier field of the corresponding data member in the associated data source.

See Also

BoundPropertyList Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundPropertyList.IdField Property

BoundPropertyList.IdField Property

Gets or sets the unique identifier field of the corresponding data member in the associated data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public string IdField { get; set; }
Visual Basic

Public Property IdField As String

Property Value

See Also

BoundPropertyList Members
BoundPropertyList Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder Class

DataBinder Class

Stores or retrieves structured data to and from arbitrary collections of objects.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public class DataBinder
Visual Basic

Public Class DataBinder

Inheritance Hierarchy

System.Object
MindFusion.DataBinding.DataBinder

See Also

DataBinder Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder Members

DataBinder Members
Constructors Methods

Stores or retrieves structured data to and from arbitrary collections of objects.

The following tables list the members exposed by the DataBinder type.

Public Constructors

Name | Description
DataBinder | Initializes a new instance of the DataBinder class.

Public Methods

Name | Description
AddDataSource | Overloaded.
DataBind |
LoadSourceData |
LoadTargetData |
WriteDelayedTables |

See Also

DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder Constructor

DataBinder Constructor

Initializes a new instance of the DataBinder class.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public DataBinder (
bool keepInSync
)
Visual Basic

Public New ( _
keepInSync As Boolean _
)

Parameters

keepInSync
Specifies whether the data source and the control's data collections should be kept synchronized.

See Also

DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder Methods

DataBinder Methods

Public Methods

Name | Description
AddDataSource | Overloaded.
DataBind |
LoadSourceData |
LoadTargetData |
WriteDelayedTables |

See Also

DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.AddDataSource Method

DataBinder.AddDataSource Method

Overload List

Name | Description
DataBinder.AddDataSource (Object, String) | Adds a new data source that will be managed by this DataBinder instance.
DataBinder.AddDataSource (Object, String, Boolean) | Adds a new data source that will be managed by this DataBinder instance.

See Also

DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.AddDataSource Method (Object, String)

DataBinder.AddDataSource Method (Object, String)
See Also

Adds a new data source that will be managed by this DataBinder instance.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public DataSourceTracker AddDataSource (
Object dataSource,
string dataMember
)
Visual Basic

Public Function AddDataSource ( _
dataSource As Object, _
dataMember As String _
) As DataSourceTracker

Parameters

dataSource
A data source to be managed by this DataBinder.
dataMember
The data source member that provides the data items.

Return Value

See Also

AddDataSource Method Overload List
DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.AddDataSource Method (Object, String, Boolean)

DataBinder.AddDataSource Method (Object, String, Boolean)
See Also

Adds a new data source that will be managed by this DataBinder instance.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public DataSourceTracker AddDataSource (
Object dataSource,
string dataMember,
bool append
)
Visual Basic

Public Function AddDataSource ( _
dataSource As Object, _
dataMember As String, _
append As Boolean _
) As DataSourceTracker

Parameters

dataSource
A data source to be managed by this DataBinder.
dataMember
The data source member that provides the data items.
append
Specifies whether the tracker should be added to the end of the list. When setting-up master-details binding, the master tracker should come after the details tracker.

Return Value

See Also

AddDataSource Method Overload List
DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.DataBind Method

DataBinder.DataBind Method

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public void DataBind ()
Visual Basic

Public Sub DataBind ()

See Also

DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.LoadSourceData Method

DataBinder.LoadSourceData Method

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public void LoadSourceData ()
Visual Basic

Public Sub LoadSourceData ()

See Also

DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.LoadTargetData Method

DataBinder.LoadTargetData Method

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public void LoadTargetData (
bool delayManyToMany
)
Visual Basic

Public Sub LoadTargetData ( _
delayManyToMany As Boolean _
)

Parameters

delayManyToMany

See Also

DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.WriteDelayedTables Method

DataBinder.WriteDelayedTables Method

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public void WriteDelayedTables ()
Visual Basic

Public Sub WriteDelayedTables ()

See Also

DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker Class

DataSourceTracker Class

Determines and manages the properties of a data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public class DataSourceTracker
Visual Basic

Public Class DataSourceTracker

Inheritance Hierarchy

System.Object
MindFusion.DataBinding.DataSourceTracker

See Also

DataSourceTracker Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker Members

DataSourceTracker Members
Properties Methods Events

Determines and manages the properties of a data source.

The following tables list the members exposed by the DataSourceTracker type.

Public Properties

Name | Description
DataBinder | Gets a DataBinder object that gives access to other DataSourceTracker objects, which are needed when handling references between items from different data source collections.
IdField | Gets or sets the primary key field in a data table.
Properties | Gets a Dictionary object that maps the data source item properties to the control's item properties.
SourceItems | Gets the list of source items.
TargetContext |
TargetItems | Gets or sets the list of target items.

Public Methods

Name | Description
AddProperties |
AddProperty | Overloaded.
CreateTracker | Overloaded.
ReadSourceItems | Fills the target list with items corresponding to the source items. Attaches event listeners so the items are kept synchronized.
ReadTargetItems | Fills the source list with items corresponding to the target items. Attaches event listeners so the items are kept synchronized.
SetSourceType | Specifies what type of items should be created in the source collection when an item is added to the target collection.
SetTargetFactory | Sets the factory used to create items in the target collection or remove existing items from there.
SetTargetType | Specifies what type of items should be created in the target collection when an item is added to the source collection.

Public Events

Name | Description
BindComplete | Raised when all target items have been loaded from the data source.

See Also

DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker Methods

DataSourceTracker Methods

Public Methods

Name | Description
AddProperties |
AddProperty | Overloaded.
CreateTracker | Overloaded.
ReadSourceItems | Fills the target list with items corresponding to the source items. Attaches event listeners so the items are kept synchronized.
ReadTargetItems | Fills the source list with items corresponding to the target items. Attaches event listeners so the items are kept synchronized.
SetSourceType | Specifies what type of items should be created in the source collection when an item is added to the target collection.
SetTargetFactory | Sets the factory used to create items in the target collection or remove existing items from there.
SetTargetType | Specifies what type of items should be created in the target collection when an item is added to the source collection.

See Also

DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.AddProperties Method

DataSourceTracker.AddProperties Method

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public void AddProperties (
List<BoundProperty> properties
)
Visual Basic

Public Sub AddProperties ( _
properties As List(Of BoundProperty) _
)

Parameters

properties

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.AddProperty Method

DataSourceTracker.AddProperty Method

Overload List

Name | Description
DataSourceTracker.AddProperty (String, String) | Adds a new simple value binding between the data source and the target collection.
DataSourceTracker.AddProperty (String, String, PropertyType, DataSourceTracker) | Adds a new reference binding between the data source and the target collection.

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.AddProperty Method (String, String)

DataSourceTracker.AddProperty Method (String, String)
See Also

Adds a new simple value binding between the data source and the target collection.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public void AddProperty (
string sourceMember,
string targetMember
)
Visual Basic

Public Sub AddProperty ( _
sourceMember As String, _
targetMember As String _
)

Parameters

sourceMember
A member field or property of the data source.
targetMember
A corresponding member field or property of the target items.

See Also

AddProperty Method Overload List
DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.AddProperty Method (String, String, PropertyType, DataSourceTracker)

DataSourceTracker.AddProperty Method (String, String, PropertyType, DataSourceTracker)
See Also

Adds a new reference binding between the data source and the target collection.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public void AddProperty (
string sourceMember,
string targetMember,
PropertyType propertyType,
DataSourceTracker tracker
)
Visual Basic

Public Sub AddProperty ( _
sourceMember As String, _
targetMember As String, _
propertyType As PropertyType, _
tracker As DataSourceTracker _
)

Parameters

sourceMember
A member field or property of the data source.
targetMember
A corresponding member field or property of the target items.
propertyType
Specifies the type of the property.
tracker
Tracks the collection that contains the object referred by this property.

See Also

AddProperty Method Overload List
DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.CreateTracker Method

DataSourceTracker.CreateTracker Method

Overload List

Name | Description
DataSourceTracker.CreateTracker (Object, DataBinder, Boolean) | Creates a new DataSourceTracker for the provided data source.
DataSourceTracker.CreateTracker (Object, String, DataBinder, Boolean) | Creates a new DataSourceTracker for the provided data source.

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.CreateTracker Method (Object, DataBinder, Boolean)

DataSourceTracker.CreateTracker Method (Object, DataBinder, Boolean)
See Also

Creates a new DataSourceTracker for the provided data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public static DataSourceTracker CreateTracker (
Object dataSource,
DataBinder dataBinder,
bool keepInSync
)
Visual Basic

Public Shared Function CreateTracker ( _
dataSource As Object, _
dataBinder As DataBinder, _
keepInSync As Boolean _
) As DataSourceTracker

Parameters

dataSource
The data source for which a DataSourceTracker should be created.
dataBinder
A DataBinder used to get access to other DataSourceTracker objects.
keepInSync
Specifies whether the data source and the control's data collections should be kept synchronized.

Return Value

A DataSourceTracker describing the specified data source.

See Also

CreateTracker Method Overload List
DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.CreateTracker Method (Object, String, DataBinder, Boolean)

DataSourceTracker.CreateTracker Method (Object, String, DataBinder, Boolean)
See Also

Creates a new DataSourceTracker for the provided data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public static DataSourceTracker CreateTracker (
Object dataSource,
string dataMember,
DataBinder dataBinder,
bool keepInSync
)
Visual Basic

Public Shared Function CreateTracker ( _
dataSource As Object, _
dataMember As String, _
dataBinder As DataBinder, _
keepInSync As Boolean _
) As DataSourceTracker

Parameters

dataSource
The data source for which a DataSourceTracker should be created.
dataMember
The data source member that provides the data items.
dataBinder
A DataBinder used to get access to other DataSourceTracker objects.
keepInSync
Specifies whether the data source and the control's data collections should be kept synchronized.

Return Value

A DataSourceTracker describing the specified data source.

See Also

CreateTracker Method Overload List
DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.ReadSourceItems Method

DataSourceTracker.ReadSourceItems Method

Fills the target list with items corresponding to the source items. Attaches event listeners so the items are kept synchronized.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public void ReadSourceItems ()
Visual Basic

Public Sub ReadSourceItems ()

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.ReadTargetItems Method

DataSourceTracker.ReadTargetItems Method

Fills the source list with items corresponding to the target items. Attaches event listeners so the items are kept synchronized.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public void ReadTargetItems (
bool delayManyToMany
)
Visual Basic

Public Sub ReadTargetItems ( _
delayManyToMany As Boolean _
)

Parameters

delayManyToMany

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.SetSourceType Method

DataSourceTracker.SetSourceType Method

Specifies what type of items should be created in the source collection when an item is added to the target collection.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public void SetSourceType (
Type type
)
Visual Basic

Public Sub SetSourceType ( _
type As Type _
)

Parameters

type

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.SetTargetFactory Method

DataSourceTracker.SetTargetFactory Method

Sets the factory used to create items in the target collection or remove existing items from there.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public void SetTargetFactory (
IItemFactory factory
)
Visual Basic

Public Sub SetTargetFactory ( _
factory As IItemFactory _
)

Parameters

factory
An object implementing the IItemFactory interface.

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.SetTargetType Method

DataSourceTracker.SetTargetType Method

Specifies what type of items should be created in the target collection when an item is added to the source collection.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public void SetTargetType (
Type type
)
Visual Basic

Public Sub SetTargetType ( _
type As Type _
)

Parameters

type
The type of target items.

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker Properties

DataSourceTracker Properties

Public Properties

Name | Description
DataBinder | Gets a DataBinder object that gives access to other DataSourceTracker objects, which are needed when handling references between items from different data source collections.
IdField | Gets or sets the primary key field in a data table.
Properties | Gets a Dictionary object that maps the data source item properties to the control's item properties.
SourceItems | Gets the list of source items.
TargetContext |
TargetItems | Gets or sets the list of target items.

See Also

DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.DataBinder Property

DataSourceTracker.DataBinder Property

Gets a DataBinder object that gives access to other DataSourceTracker objects, which are needed when handling references between items from different data source collections.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public DataBinder DataBinder { get; }
Visual Basic

Public ReadOnly Property DataBinder As DataBinder

Property Value

A DataBinder object.

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.IdField Property

DataSourceTracker.IdField Property

Gets or sets the primary key field in a data table.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public string IdField { get; set; }
Visual Basic

Public Property IdField As String

Property Value

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.Properties Property

DataSourceTracker.Properties Property

Gets a Dictionary object that maps the data source item properties to the control's item properties.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public Dictionary<string, List<BoundProperty>> Properties { get; }
Visual Basic

Public ReadOnly Property Properties As Dictionary(Of String, List(Of BoundProperty))

Property Value

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.SourceItems Property

DataSourceTracker.SourceItems Property

Gets the list of source items.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public IList SourceItems { get; }
Visual Basic

Public ReadOnly Property SourceItems As IList

Property Value

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.TargetContext Property

DataSourceTracker.TargetContext Property

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public string TargetContext { get; set; }
Visual Basic

Public Property TargetContext As String

Property Value

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.TargetItems Property

DataSourceTracker.TargetItems Property

Gets or sets the list of target items.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public IList TargetItems { get; set; }
Visual Basic

Public Property TargetItems As IList

Property Value

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker Events

DataSourceTracker Events

Public Events

Name | Description
BindComplete | Raised when all target items have been loaded from the data source.

See Also

DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.BindComplete Event

DataSourceTracker.BindComplete Event

Raised when all target items have been loaded from the data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public event EventHandler BindComplete
Visual Basic

Public Event BindComplete As EventHandler

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IItemFactory Interface

IItemFactory Interface

Provides methods for creating, adding and removing items from a collection during data-binding.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public interface IItemFactory
Visual Basic

Public Interface IItemFactory

See Also

IItemFactory Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IItemFactory Members

IItemFactory Members
Methods

Provides methods for creating, adding and removing items from a collection during data-binding.

The following tables list the members exposed by the IItemFactory type.

Public Methods

Name | Description
AddItem | Creates a new item and adds it to the specified collection.
RemoveItem | Removes an item from the specified collection.

See Also

IItemFactory Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IItemFactory Methods

IItemFactory Methods

Public Methods

Name | Description
AddItem | Creates a new item and adds it to the specified collection.
RemoveItem | Removes an item from the specified collection.

See Also

IItemFactory Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IItemFactory.AddItem Method

IItemFactory.AddItem Method

Creates a new item and adds it to the specified collection.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public abstract Object AddItem (
IList items
)
Visual Basic

Public MustOverride Function AddItem ( _
items As IList _
) As Object

Parameters

items
The collection where the items should be added.

Return Value

The newly created item.

See Also

IItemFactory Members
IItemFactory Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IItemFactory.RemoveItem Method

IItemFactory.RemoveItem Method

Removes an item from the specified collection.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public abstract void RemoveItem (
IList items,
Object item
)
Visual Basic

Public MustOverride Sub RemoveItem ( _
items As IList, _
item As Object _
)

Parameters

items
The collection from which the item should be removed.
item
The item that should be removed.

See Also

IItemFactory Members
IItemFactory Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IVirtualPropertyProvider Interface

IVirtualPropertyProvider Interface
Remarks See Also

Provides virtual properties on an object which can be data-bound.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public interface IVirtualPropertyProvider
Visual Basic

Public Interface IVirtualPropertyProvider

Remarks

Implement this interface when you want to perform data-binding of a property that do not exist. For example, when the name of the data-bound property is not be available at compile time.

See Also

IVirtualPropertyProvider Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IVirtualPropertyProvider Members

IVirtualPropertyProvider Members
Methods

Provides virtual properties on an object which can be data-bound.

The following tables list the members exposed by the IVirtualPropertyProvider type.

Public Methods

Name | Description
GetValue | Gets the value of the virtual property with the specified name.
SetValue | Sets the value of the specified virtual property.

See Also

IVirtualPropertyProvider Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IVirtualPropertyProvider Methods

IVirtualPropertyProvider Methods

Public Methods

Name | Description
GetValue | Gets the value of the virtual property with the specified name.
SetValue | Sets the value of the specified virtual property.

See Also

IVirtualPropertyProvider Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IVirtualPropertyProvider.GetValue Method

IVirtualPropertyProvider.GetValue Method

Gets the value of the virtual property with the specified name.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public abstract Object GetValue (
string propertyName
)
Visual Basic

Public MustOverride Function GetValue ( _
propertyName As String _
) As Object

Parameters

propertyName
The name of the virtual property.

Return Value

The value of the virtual property.

Remarks

This method is invoked during data-binding of a property that does not exist on an object.

See Also

IVirtualPropertyProvider Members
IVirtualPropertyProvider Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IVirtualPropertyProvider.SetValue Method

IVirtualPropertyProvider.SetValue Method

Sets the value of the specified virtual property.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public abstract void SetValue (
string propertyName,
Object value
)
Visual Basic

Public MustOverride Sub SetValue ( _
propertyName As String, _
value As Object _
)

Parameters

propertyName
The name of the virtual property.
value
The value of the virtual property.

Remarks

This method is invoked during data-binding of a property that does not exist on an object.

See Also

IVirtualPropertyProvider Members
IVirtualPropertyProvider Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.PropertyType Enumeration

PropertyType Enumeration

Specifies the way the data bound properties are interpreted.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C#

public enum PropertyType
Visual Basic

Public Enumeration PropertyType

Members

Member name | Description
Collection | A collection property contains references to objects in another data-bound collection.
ManyToMany | Specifies a collection of records that is retrieved through an intermediate table that defines a many-to-many relation.
ManyToOne | The property is a foreign key identifying a record in a related table.
Reference | A reference property is one that refers to an object in another data-bound collection.
Value | A simple value property.

See Also

MindFusion.DataBinding Namespace


MindFusion.Scheduling.DataBinding Namespace
Classes Enumerations

Classes

Class | Description
BoundProperty | Represents a mapping between a property in MindFusion.Scheduling and a field in the data source.
BoundPropertyList | Defines a mapping between properties in MindFusion.Scheduling and fields in the associated data source.

Enumerations

Enumeration | Description
PropertyType | Specifies the way the data bound properties are interpreted.


MindFusion.Scheduling.DataBinding.BoundProperty Class

BoundProperty Class

Represents a mapping between a property in MindFusion.Scheduling and a field in the data source.

Namespace: MindFusion.Scheduling.DataBinding
Assembly: MindFusion.Scheduling

Syntax

C#

public class BoundProperty
Visual Basic

Public Class BoundProperty

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.DataBinding.BoundProperty

See Also

BoundProperty Members
MindFusion.Scheduling.DataBinding Namespace


MindFusion.Scheduling.DataBinding.BoundProperty Members

BoundProperty Members
Constructors Properties

Represents a mapping between a property in MindFusion.Scheduling and a field in the data source.

The following tables list the members exposed by the BoundProperty type.

Public Constructors

Name | Description
BoundProperty | Overloaded. Initializes a new instance of the BoundProperty class.

Public Properties

Name | Description
DestinationMember | Gets or sets the name of the corresponding property in MindFusion.Scheduling.
ManyToManyTable | Gets or sets the name of the associated many-to-many table.
PropertyType | Gets or sets the type of the property.
SourceMember | Gets or sets the name of the corresponding field in the data source.

See Also

BoundProperty Class
MindFusion.Scheduling.DataBinding Namespace


MindFusion.Scheduling.DataBinding.BoundProperty Constructor

BoundProperty Constructor

Initializes a new instance of the BoundProperty class.

Overload List

Name | Description
BoundProperty (String, String, PropertyType) | Initializes a new instance of the BoundProperty class with the specified source and destination properties, and property type.
BoundProperty (String, String, PropertyType, String) | Initializes a new instance of the BoundProperty class with the specified source and destination properties, property type, and many-to-many table.

See Also

BoundProperty Class
MindFusion.Scheduling.DataBinding Namespace


MindFusion.Scheduling.DataBinding.BoundProperty Constructor (String, String, PropertyType)

BoundProperty Constructor (String, String, PropertyType)
See Also

Initializes a new instance of the BoundProperty class with the specified source and destination properties, and property type.

Namespace: MindFusion.Scheduling.DataBinding
Assembly: MindFusion.Scheduling

Syntax

C#

public BoundProperty (
string sourceMember,
string destinationMember,
PropertyType propertyType
)
Visual Basic

Public Sub BoundProperty ( _
sourceMember As String, _
destinationMember As String, _
propertyType As PropertyType _
)

Parameters

sourceMember
The name of the field in the data source.
destinationMember
The name of the property in MindFusion.Scheduling.
propertyType
The type of the property.

See Also

BoundProperty Constructor Overload List
BoundProperty Class
MindFusion.Scheduling.DataBinding Namespace


MindFusion.Scheduling.DataBinding.BoundProperty Constructor (String, String, PropertyType, String)

BoundProperty Constructor (String, String, PropertyType, String)
See Also

Initializes a new instance of the BoundProperty class with the specified source and destination properties, property type, and many-to-many table.

Namespace: MindFusion.Scheduling.DataBinding
Assembly: MindFusion.Scheduling

Syntax

C#

public BoundProperty (
string sourceMember,
string destinationMember,
PropertyType propertyType,
string manyToManyTable
)
Visual Basic

Public Sub BoundProperty ( _
sourceMember As String, _
destinationMember As String, _
propertyType As PropertyType, _
manyToManyTable As String _
)

Parameters

sourceMember
The name of the field in the data source.
destinationMember
The name of the property in MindFusion.Scheduling.
propertyType
The type of the property.
manyToManyTable
The name of the related table in the data source when the property type is ManyToMany.

See Also

BoundProperty Constructor Overload List
BoundProperty Class
MindFusion.Scheduling.DataBinding Namespace


MindFusion.Scheduling.DataBinding.BoundProperty Properties

BoundProperty Properties

Public Properties

Name | Description
DestinationMember | Gets or sets the name of the corresponding property in MindFusion.Scheduling.
ManyToManyTable | Gets or sets the name of the associated many-to-many table.
PropertyType | Gets or sets the type of the property.
SourceMember | Gets or sets the name of the corresponding field in the data source.

See Also

BoundProperty Class
MindFusion.Scheduling.DataBinding Namespace


MindFusion.Scheduling.DataBinding.BoundProperty.DestinationMember Property

BoundProperty.DestinationMember Property

Gets or sets the name of the corresponding property in MindFusion.Scheduling.

Namespace: MindFusion.Scheduling.DataBinding
Assembly: MindFusion.Scheduling

Syntax

C#

public string DestinationMember { get; set; }
Visual Basic

Public Property DestinationMember As String

Property Value

A string value specifying the name of the destination property.

See Also

BoundProperty Members
BoundProperty Class
MindFusion.Scheduling.DataBinding Namespace
SourceMember Property


MindFusion.Scheduling.DataBinding.BoundProperty.ManyToManyTable Property

BoundProperty.ManyToManyTable Property

Gets or sets the name of the associated many-to-many table.

Namespace: MindFusion.Scheduling.DataBinding
Assembly: MindFusion.Scheduling

Syntax

C#

public string ManyToManyTable { get; set; }
Visual Basic

Public Property ManyToManyTable As String

Property Value

A string value specifying the name of the related table.

Remarks

Only valid if the property is of type ManyToMany.

See Also

BoundProperty Members
BoundProperty Class
MindFusion.Scheduling.DataBinding Namespace


MindFusion.Scheduling.DataBinding.BoundProperty.PropertyType Property

BoundProperty.PropertyType Property

Gets or sets the type of the property.

Namespace: MindFusion.Scheduling.DataBinding
Assembly: MindFusion.Scheduling

Syntax

C#

public PropertyType PropertyType { get; set; }
Visual Basic

Public Property PropertyType As PropertyType

Property Value

A member of the PropertyType enumeration specifying the type of the property.

See Also

BoundProperty Members
BoundProperty Class
MindFusion.Scheduling.DataBinding Namespace


MindFusion.Scheduling.DataBinding.BoundProperty.SourceMember Property

BoundProperty.SourceMember Property

Gets or sets the name of the corresponding field in the data source.

Namespace: MindFusion.Scheduling.DataBinding
Assembly: MindFusion.Scheduling

Syntax

C#

public string SourceMember { get; set; }
Visual Basic

Public Property SourceMember As String

Property Value

A string value specifying the name of the source field.

See Also

BoundProperty Members
BoundProperty Class
MindFusion.Scheduling.DataBinding Namespace
DestinationMember Property


MindFusion.Scheduling.DataBinding.BoundPropertyList Class

BoundPropertyList Class

Defines a mapping between properties in MindFusion.Scheduling and fields in the associated data source.

Namespace: MindFusion.Scheduling.DataBinding
Assembly: MindFusion.Scheduling

Syntax

C#

public class BoundPropertyList : List<BoundProperty>
Visual Basic

Public Class BoundPropertyList
Inherits List(Of BoundProperty)

Inheritance Hierarchy

System.Object
System.Collections.Generic.List(BoundProperty)
MindFusion.Scheduling.DataBinding.BoundPropertyList

See Also

BoundPropertyList Members
MindFusion.Scheduling.DataBinding Namespace


MindFusion.Scheduling.DataBinding.BoundPropertyList Members

BoundPropertyList Members
Properties

Defines a mapping between properties in MindFusion.Scheduling and fields in the associated data source.

The following tables list the members exposed by the BoundPropertyList type.

Public Properties

Name | Description
IdField | Gets or sets the unique identifier field of the corresponding data member in the associated data source.

See Also

BoundPropertyList Class
MindFusion.Scheduling.DataBinding Namespace


MindFusion.Scheduling.DataBinding.BoundPropertyList Properties

BoundPropertyList Properties

Public Properties

Name | Description
IdField | Gets or sets the unique identifier field of the corresponding data member in the associated data source.

See Also

BoundPropertyList Class
MindFusion.Scheduling.DataBinding Namespace


MindFusion.Scheduling.DataBinding.BoundPropertyList.IdField Property

BoundPropertyList.IdField Property

Gets or sets the unique identifier field of the corresponding data member in the associated data source.

Namespace: MindFusion.Scheduling.DataBinding
Assembly: MindFusion.Scheduling

Syntax

C#

public string IdField { get; set; }
Visual Basic

Public Property IdField As String

Property Value

A string value specifying the name of the id field.

See Also

BoundPropertyList Members
BoundPropertyList Class
MindFusion.Scheduling.DataBinding Namespace


MindFusion.Scheduling.DataBinding.PropertyType Enumeration

PropertyType Enumeration

Specifies the way the data bound properties are interpreted.

Namespace: MindFusion.Scheduling.DataBinding
Assembly: MindFusion.Scheduling

Syntax

C#

public enum PropertyType
Visual Basic

Public Enumeration PropertyType

Members

Member name | Description
Collection | A collection property contains references to objects in another data-bound collection.
ManyToMany | Specifies a collection of records that is retrieved through an intermediate table that defines a many-to-many relation.
ManyToOne | The property is a foreign key identifying a record in a related table.
Reference | A reference property is one that refers to an object in another data-bound collection.
Value | A simple value property.

See Also

MindFusion.Scheduling.DataBinding Namespace


MindFusion.Diagramming Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
AnchorPattern | Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.
AnchorPoint | Specify the locations in a node, to which the user is allowed to connect links.
AnchorPointCollection | Represents a strongly typed collection of anchor points.
AnchorPointEventArgs | Contains the arguments passed to the anchor point-related events, such as OriginAnchorChanged and DestinationAnchorChanged.
ArcTemplate | Represents an arc in a shape definition.
AreaEventArgs | Contains arguments passed to handlers of the CreatingArea event of the HtmlBuilder class.
ArrowHeadShape | Defines the shape of a link arrowhead.
BezierTemplate | Represents a Bézier curve in a shape definition.
CellEventArgs | Contains the arguments passed to event handlers, such as CellClicked.
CellValidationEventArgs | Contains the arguments passed to event handlers, such as CellTextEditing.
CommandHistory | Maintains a queue of Command records used to undo or redo actions.
ConnectionPoint | This class represent a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink objects contains two ConnectionPoint instances describing the connections at both ends of the link.
Constants | Contains various global constants, also provides measure unit independent constants.
ContainerChildEventArgs | Contains arguments passed to ContainerChildEventHandler,
ContainerNode | Represents a diagram node that can contain other nodes.
ContainerNodeProperties | Stores the values of ContainerNode properties during undo / redo operations.
Converter | Provides capabilities to convert various types to and from strings in a culture-independent way.
Diagram | Represents a flow diagram.
DiagramEventArgs | Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.
DiagramItem | Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.
DiagramItemCollection | Represents a strongly typed collection of DiagramItem objects.
DiagramItemProperties | The base type for classes that store diagram item properties during undo / redo operations.
DiagramItemState | Contains a snapshot of the internal state of a diagram item. Instances of this class are used to store the state of items for later undo or redo operations.
DiagramLink | Represents a link between two diagram nodes.
DiagramLinkCollection | Represents a strongly typed collection of DiagramLink objects.
DiagramLinkProperties | Stores the values of DiagramLink properties during undo / redo operations.
DiagramLinkState | Contains a snapshot of the internal state of a DiagramLink.
DiagramNode | Represents a diagram node.
DiagramNodeCollection | Represents a strongly typed collection of diagram nodes.
DiagramNodeProperties | The base class for classes that store the properties for a DiagramNode-derived items during undo / redo operations.
DraggedShape | Contains drag-and-drop information for a shape being dragged from ShapeToolBar and ShapeListBox.
DrawAnchorPointEventArgs | Contains the arguments passed to the DrawAnchorPoint event handlers.
DrawCellEventArgs | Contains the arguments passed to the DrawCell event handlers.
DrawItemEventArgs | Contains the arguments passed to the DrawAdjustmentHandles event handlers.
DrawLinkEventArgs | Contains the arguments passed to the DrawLink event handlers.
DrawNodeEventArgs | Contains the arguments passed to the DrawNode event handlers.
DummyNode | Represents virtual nodes used for disconnected links.
EditCellTextEventArgs | Contains the arguments passed to the CellTextEdited event handlers.
EditLinkTextEventArgs | Contains the arguments passed to the EditLinkTextEventHandler event handlers.
EditNodeTextEventArgs | Contains the arguments passed to the NodeTextEdited event handlers.
EffectsProvider | Provides smooth shadow and emboss effects for MindFusion.Diagramming nodes.
ElementTemplate | Represents an element of a shape definition. This is the parent class of specific element types, such as ArcTemplate, LineTemplate and BezierTemplate.
Factory | Provides shortcut methods for creating and adding instances of the standard MindFusion.Diagramming item types. Call the class methods through the Factory property of the Diagram class.
Group | Represents a group of items in the diagram document.
Group.Attachment | Encapsulates attachment information.
GroupCollection | Represents a strongly typed collection of Group objects.
GroupEventArgs | Contains the arguments passed to handlers of group-related events, such as GroupDestroyed.
HitTestEventArgs | Contains the arguments passed to the HitTestAdjustmentHandles event handlers.
HtmlBuilder | Provides methods to create and use HTML client side image maps.
InstantiateItemEventArgs | Contains the arguments passed to the InstantiateItem event handlers.
InteractionState | Encapsulates the current state of user interaction with the control.
InternalUtils | Contains common helper methods, specific to MindFusion.Diagramming.
ItemCollectionBase | A base collection class for the diagram item collections.
ItemEventArgs | Contains the arguments passed to item instantiation event handlers.
LineTemplate | Represents a line segment in a shape definition.
LinkEventArgs | Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.
LinkValidationEventArgs | Contains the arguments passed to handlers of link validation events.
NodeConstraints | Defines specific constraints that can be applied to the size and location of nodes.
NodeEventArgs | Contains the arguments passed to handlers of node-related events, such as TreeCollapsed and TreeExpanded.
NodeValidationEventArgs | Contains the arguments passed to handlers of node validation events.
NotATreeException | An exception raised by the TreeEnumerator class if the specified node does not represent a root of a tree.
Path | Represents a sequence of connected DiagramNode and DiagramLink elements.
PathCollection | Represents a strongly typed collection of Path objects.
PathFinder | Provides methods that help you find paths and cycles in a graph.
PersistableCollection | A base collection class for persistable collections.
PersistContext | Contains methods that help serializing and deserializing complex MindFusion.Diagramming object to and from binary streams.
PointCollection | Represents a strongly typed collection of points.
ReadOnlyCollection | Represents a read-only wrapper of a collection.
ReadOnlyDiagramItemCollection | Represents a read-only collection of items.
ReadOnlyDiagramLinkCollection | Represents a read-only collection of links.
ReadOnlyDiagramNodeCollection | Represents a read-only collection of nodes.
RectangleFConverter | Converts from RectangleF to other data types.
RenderOptions | Provides properties that allow customization of various aspects of printing and print-preview.
RepaintEventArgs | Specifies the coordinates of the area that should be repainted by views when the Repaint event is raised.
RoundRectangleTemplate | Represents an ElementTemplate that draws round rectangle. This class ensures that the round corners do not change during resizing which is visually better. The drawback is that the radius appears to be specified in DiagramView Measure units and therefore a given shape instance will look bad when the measure unit is not the one for which the shape was designed.
RoutingOptions | Allows customization of various aspects of the link routing algorithm.
RowEventArgs | Contains the arguments passed to handlers of table row-related events, such as TableSectionCollapsed and TableSectionExpanded.
ScriptHelper | Allows calling some static MindFusion.Diagramming methods from JavaScript and VBScript. It seems the script languages do not allow calling class static methods, so a ScriptHelper instance property is provided by the Diagram class.
Selection | Represents a set of items selected in the diagram document.
SelectionCopy | Used internally in the implementation of copy/paste functions.
SerializeTagEventArgs | Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.
Shape | An instance of this class represents a shape defined through a series of arc, line and Bézier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.
ShapeCollection | Represents a read-only collection of shapes.
ShapeConverter | Converts from Shape to other data types.
ShapeEventArgs | Contains the arguments passed to the ShapeSelected and ShapeRenamed event handlers.
ShapeLibrary | The ShapeLibrary class represents a collection of shape definitions stored together.
ShapeNode | ShapeNode instances are diagram nodes that represent geometric shapes.
ShapeNodeProperties | Stores the values of ShapeNode properties during undo / redo operations.
ShapeNodeState | Contains a snapshot of the internal state of a ShapeNode.
Shapes | Provides alternative method of access to the MindFusion.Diagramming predefined shapes, that allows code completion and IntelliSense support, which is not available when using Shape.FromId.
SizeFConverter | Converts from SizeF to other data types.
TableNode | Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.
TableNode.Cell | Represents a cell in a TableNode instance.
TableNode.CellCollection | Represents a strongly-typed collection of TableNode.Cell objects.
TableNode.Column | Represents a column of a TableNode.
TableNode.ColumnCollection | Represents a strongly-typed collection of TableNode.Column objects.
TableNode.Row | Represents a row in TableNode node.
TableNode.RowCollection | Represents a strongly-typed collection of TableNode.Row objects.
TableNodeProperties | Stores the values of TableNode properties during undo / redo operations.
TreeEnumerator | Enables an easy standard method to itereate over the elements of a tree-like structure of objects.
UndoEventArgs | Contains the arguments passed to the ActionRecorded, ActionUndone and ActionRedone event handlers.
UndoManager | Implements undo/redo functionality in MindFusion.Diagramming.
UndoValidationEventArgs | Contains the arguments passed to the ActionRecording event handlers.
ValidationEventArgs | Contains the arguments passed to the SelectionMoving event handler.
XmlPersistContext | Contains methods that can help you serialize and deserialize MindFusion.Diagramming items to end from XML documents.

Interfaces

Interface | Description
IEffectsProvider | Visual effects provider.
IItemFactory | Defines an interface for constructing IPersists objects.
InplaceEditable | Represents an in-place editable object.
IPersists | Base interface for serializable MindFusion.Diagramming objects.

Delegates

Delegate | Description
AnchorPointEventHandler | Represents methods that will handle anchor point-related events.
AreaEventHandler | Represents methods that will handle the CreatingArea event of the HtmlBuilder class.
CellEventHandler | Represents methods that will handle table-related mouse events.
CellValidationEventHandler | Represents methods that will handle table-related mouse events.
ContainerChildEventHandler | Represents methods that will handle ContainerChildAdded, ContainerChildRemoved events.
DiagramEventHandler | Represents methods that will handle document-related mouse events.
DrawAnchorPointEventHandler | Represents methods that will handle anchor-related custom-drawing events.
DrawCellEventHandler | Represents methods that will handle table cell-related custom-drawing events.
DrawItemEventHandler | Represents methods that will handle item-related custom-drawing events.
DrawLinkEventHandler | Represents methods that will handle link-related custom-drawing events.
DrawNodeEventHandler | Represents methods that will handle node-related custom-drawing events.
EditCellTextEventHandler | Represents methods that will handle table cell-related in-place edit events.
EditLinkTextEventHandler | Represents methods that will handle link in-place edit events.
EditNodeTextEventHandler | Represents methods that will handle node in-place edit events.
GroupEventHandler | Represents methods that will handle general group-related events.
HitTestEventHandler | Represents methods that will handle hit-testing events.
InstantiateItemEventHandler | Represents methods that will handle item instantiation events.
ItemEventHandler | Represents methods that will handle general item-related events.
LinkEventHandler | Represents methods that will handle general link related events.
LinkValidationEventHandler | Represents methods that will handle link validation events.
NodeEventHandler | Represents methods that will handle general node related events.
NodeValidationEventHandler | Represents methods that will handle node validation events.
RepaintEventHandler | Represents methods that will handle the Repaint event.
RowEventHandler | Represents methods that will handle table row-related events.
SerializeTagEventHandler | Represents methods that will handle the SerializeTag and DeserializeTag events of the Diagram class.
ShapeEventHandler | Represents methods that will handle the ShapeSelected event.
UndoEventHandler | Represents methods that will handle undo/redo-related events.
UndoValidationEventHandler | Represents methods that will handle undo/redo-related confirmation events.
ValidationEventHandler | Represents methods that will handle validation events.

Enumerations

Enumeration | Description
Action | Defines values that identify the possible actions a user can carry out on diagram items.
AdjustmentHandles | Identifies the distinct selection handles of a node.
Anchoring | Defines values that specify how automatic layout algorithms align links to anchor points.
ArrowHead | Specifies the shape of an arrowhead.
AttachTo | Specifies the type of attachment in a group.
AttachToLink | Defines values specifying the possible ways to attach a node to a link.
AttachToNode | Defines values specifying the possible ways to attach a node to another node.
AutoResize | Defines in which directions automatic resizing can enlarge the diagram scrollable area.
Behavior | Defines values that specify how the component responds to actions performed by the user.
CellFrameStyle | Specifies the style of the cells' frame lines.
ColumnStyle | Specifies how table columns' width is set.
ContainmentKeys | For internal use.
ControlMouseAction | Specifies available ways to handle mouse clicks on .NET controls hosted in a ControlNode.
CursorHint | Specifies what mouse cursor to display while a user interacts with the diagram.
CustomDraw | Specifies what kind of custom painting to perform on diagram elements.
DelKeyAction | Specifies the type of action performed when the user presses the DEL key.
DirectionConstraint | Defines values that specify in what direction to constrain node movement.
ExpandButtonAction | Specifies what action is triggered by the [±] buttons that are displayed near expandable nodes.
ExpandButtonPosition | Defines values that specify possible locations for expand/collapse buttons.
FitSize | Specifies how the ResizeToFitText method should resize a node.
GridStyle | Defines values that specify the visual style of the alignment grid.
GroupAnchorStyles | Specifies the master node edges to which a subordinate node can be anchored.
HandlesStyle | Enumerates possible visual styles for frames that are drawn around selected nodes.
HitTestPriority | Defines values that specify the order of item hit-testing.
HyperLinkStyle | Specifies how various export components should treat the HyperLink property of items.
LinkCrossings | Defines values that indicate how to render link intersection points.
LinkStyle | Specifies available styles for the segments of links.
LinkTextStyle | Specifies the position and alignment of links' labels.
MarkStyle | Specifies the visual style of anchor point marks.
ModificationStart | Specifies how the user can start modifying an item.
ModifierKeyAction | Defines the actions that can be assigned to a modifier key such as CTRL or ALT.
MouseButton | Specifies constants that define which mouse button was pressed.
MouseButtonActions | Specifies what actions can be associated with the middle and right mouse buttons.
Orientation | Defines values that specify the orientation of the first segment of cascading links.
Relationship | Specifies the type of relationship between two tables.
RenderTarget | Specifies where the diagram is being rendered.
RerouteLinks | Provides values indicating in what circumstances links must be rerouted automatically.
RestrictToBounds | Specifies a restriction of the position of items relatively to the diagram bounds.
SaveToStringFormat | Specifies in what format to save the diagram when generating a string using the SaveToString method.
SelectionStyle | Defines values that specify how multiple selected items are indicated visually.
ShadowsStyle | Enumerates possible shadows-drawing styles.
ShowAnchors | Specifies when anchors points should be displayed.
SnapToAnchor | Specifies when link ends are snapped to nearest anchor points.
TableConnectionStyle | Specifies the possible values for the ConnectionStyle property of tables.
TableStyle | Defines the possible values for Style property of tables.
View3D | Defines keys used to associate 3D position data with a node through the LayoutTraits property.


MindFusion.Diagramming.Action Enumeration

Action Enumeration

Defines values that identify the possible actions a user can carry out on diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum Action
Visual Basic

Public Enumeration Action

Members

Member name | Description
Create | Draw a new item.
Modify | Modify an existing item.
None | Do not perform any action.
Split | Split a link's segment.

Remarks

Members of this enumeration are used as parameters of the InteractionState constructor.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.AdjustmentHandles Enumeration

AdjustmentHandles Enumeration

Identifies the distinct selection handles of a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum AdjustmentHandles
Visual Basic

Public Enumeration AdjustmentHandles

Members

Member name | Description
All | All selection handles are enabled and can be used to modify the node.
Move | The center selection handle is enabled and can be used to move the node.
None | Specifies that none of the selection handles can be used to modify the node.
ResizeBottomCenter | The bottom-center handle is enabled and can be used to resize the node vertically.
ResizeBottomLeft | The bottom-left handle is enabled and can be used to resize the node.
ResizeBottomRight | The bottom-right handle is enabled and can be used to resize the node.
ResizeMiddleLeft | The middle-left handle is enabled and can be used to resize the node horizontally.
ResizeMiddleRight | The middle-right handle is enabled and can be used to resize the node horizontally.
ResizeTopCenter | The top-center handle is enabled and can be used to resize the node vertically.
ResizeTopLeft | The top-left handle is enabled and can be used to resize the node.
ResizeTopRight | The top-right handle is enabled and can be used to resize the node.
Rotate | The rotation handle is enabled and can be used to rotate the node.

Remarks

A combination of these flags can be assigned to the EnabledHandles property of nodes.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.Anchoring Enumeration

Anchoring Enumeration

Defines values that specify how automatic layout algorithms align links to anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum Anchoring
Visual Basic

Public Enumeration Anchoring

Members

Member name | Description
Ignore | Anchor points are ignored.
Keep | Links are aligned to their original anchor points.
Reassign | Links are aligned to new anchor points, depending on the positions of graph nodes after a layout is applied.

Remarks

Assign values of this enumeration to the Anchoring property of layout algorithms. Most algorithms produce best results if they can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

See Also

MindFusion.Diagramming Namespace
AnchorPattern Class
TreeLayout Class
GridLayout Class
LayeredLayout Class
SpringLayout Class


MindFusion.Diagramming.AnchorPattern Class

AnchorPattern Class
Remarks See Also

Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class AnchorPattern : ICloneable, IPersists
Visual Basic

Public Class AnchorPattern
Implements ICloneable, IPersists

Remarks

A pattern can be assigned as an integral entity to the AnchorPattern property of nodes. By default, when assigning a pattern to a node, a new copy of the pattern is created. Thus you can modify nodes' anchor patterns independently at runtime. However, if your anchor patterns won't change while the application executes, you can register them as shared to save storage space for the diagram. To do so, use AnchorPattern constructors that take a string id parameter. The AnchorPattern class exposes several predefined patterns as static properties; all of them are considered shared.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AnchorPattern

See Also

AnchorPattern Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern Members

AnchorPattern Members
Constructors Properties Methods

Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.

The following tables list the members exposed by the AnchorPattern type.

Public Constructors

Name | Description
AnchorPattern | Overloaded. Intializes a new instance of the AnchorPattern class.

Public Properties

Name | Description
Decision1In3Out | Gets the predefined anchor pattern Decision1In3Out.
Decision2In2Out | Gets the predefined anchor pattern Decision2In2Out.
Id | Gets the AnchorPattern unique identifier.
LeftInRightOut | Gets the predefined anchor pattern LeftInRightOut.
Points | Gets a collection of the anchor points in this pattern.
TopInBottomOut | Gets the predefined anchor pattern TopInBottomOut.

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPattern object.
FromId | Returns a reference to the anchor pattern with the specified string identifier.
Register | Registers an anchor pattern as shared.

See Also

AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern Constructor

AnchorPattern Constructor

Intializes a new instance of the AnchorPattern class.

Overload List

Name | Description
AnchorPattern () | Intializes a new empty instance of the AnchorPattern class.
AnchorPattern (AnchorPoint[]) | Intializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPoint[], String) | Intializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPointCollection) | Intializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPointCollection, String) | Intializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (String) | Intializes a new empty instance of the AnchorPattern class.

See Also

AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern Constructor ()

AnchorPattern Constructor ()
See Also

Intializes a new empty instance of the AnchorPattern class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPattern ()
Visual Basic

Public Sub New ()

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPoint[])

AnchorPattern Constructor (AnchorPoint[])
See Also

Intializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPattern (
AnchorPoint[] points
)
Visual Basic

Public Sub AnchorPattern ( _
points As AnchorPoint() _
)

Parameters

points
Contains the initial set of AnchorPoint instances for the new pattern.

Example

The following code creates a decision node with two incoming anchors at the top and the left, and two outgoing at the bottom and the right vertices.

C#

AnchorPattern decision2In2Out =
new AnchorPattern(new AnchorPoint[] {
new AnchorPoint(50, 0, true, false, MarkStyle.Circle, Color.Blue),
new AnchorPoint(0, 50, true, false, MarkStyle.Circle, Color.Blue),
new AnchorPoint(50, 100, false, true, MarkStyle.Rectangle, Color.Green),
new AnchorPoint(100, 50, false, true, MarkStyle.Rectangle, Color.Red)
});

ShapeNode decisionNode = diagram.Factory.CreateShapeNode(10, 10, 50, 35);
decisionNode.AnchorPattern = decision2In2Out;
Visual Basic

Dim decision2In2Out As AnchorPattern = _
New AnchorPattern(New AnchorPoint() { _
New AnchorPoint(50, 0, True, False, MarkStyle.Circle, Color.Blue), _
New AnchorPoint(0, 50, True, False, MarkStyle.Circle, Color.Blue), _
New AnchorPoint(50, 100, False, True, MarkStyle.Rectangle, Color.Green), _
New AnchorPoint(100, 50, False, True, MarkStyle.Rectangle, Color.Red) _
})

Dim decisionNode As ShapeNode = Diagram.Factory.CreateShapeNode(10, 10, 50, 35)
decisionNode.AnchorPattern = decision2In2Out

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPoint[], String)

AnchorPattern Constructor (AnchorPoint[], String)
See Also

Intializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPattern (
AnchorPoint[] points,
string id
)
Visual Basic

Public Sub AnchorPattern ( _
points As AnchorPoint(), _
id As String _
)

Parameters

points
Contains the initial set of AnchorPoint instances for the new pattern.
id
An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPointCollection)

AnchorPattern Constructor (AnchorPointCollection)
See Also

Intializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPattern (
AnchorPointCollection points
)
Visual Basic

Public Sub AnchorPattern ( _
points As AnchorPointCollection _
)

Parameters

points
A collection of AnchorPoint objects.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPointCollection, String)

AnchorPattern Constructor (AnchorPointCollection, String)
See Also

Intializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPattern (
AnchorPointCollection points,
string id
)
Visual Basic

Public Sub AnchorPattern ( _
points As AnchorPointCollection, _
id As String _
)

Parameters

points
A collection of AnchorPoint objects.
id
An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern Constructor (String)

AnchorPattern Constructor (String)
See Also

Intializes a new empty instance of the AnchorPattern class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPattern (
string id
)
Visual Basic

Public New ( _
id As String _
)

Parameters

id
An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern Methods

AnchorPattern Methods

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPattern object.
FromId | Returns a reference to the anchor pattern with the specified string identifier.
Register | Registers an anchor pattern as shared.

See Also

AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern.Clone Method

AnchorPattern.Clone Method

Creates an exact clone of this AnchorPattern object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

An instance of the AnchorPattern class.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern.FromId Method

AnchorPattern.FromId Method

Returns a reference to the anchor pattern with the specified string identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static AnchorPattern FromId (
string id
)
Visual Basic

Public Shared Function FromId ( _
id As String _
) As AnchorPattern

Parameters

id
A string identifying an AnchorPattern instance.

Return Value

The AnchorPattern object whose Id is equal to the id parameter, or null (Nothing in Visual Basic) if no such object exists.

Remarks

The id argument should match an identifier passed to the constructor of an existing AnchorPattern object.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming Namespace
Shape Property
Shapes Property


MindFusion.Diagramming.AnchorPattern.Register Method

AnchorPattern.Register Method

Registers an anchor pattern as shared.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static void Register (
AnchorPattern pattern
)
Visual Basic

Public Shared Sub Register ( _
pattern As AnchorPattern _
)

Parameters

pattern

The AnchorPattern to register.

Remarks

This method is obsolete. Please use the Id property to create shared anchor patterns.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern Properties

AnchorPattern Properties

Public Properties

Name | Description
Decision1In3Out | Gets the predefined anchor pattern Decision1In3Out.
Decision2In2Out | Gets the predefined anchor pattern Decision2In2Out.
Id | Gets the AnchorPattern unique identifier.
LeftInRightOut | Gets the predefined anchor pattern LeftInRightOut.
Points | Gets a collection of the anchor points in this pattern.
TopInBottomOut | Gets the predefined anchor pattern TopInBottomOut.

See Also

AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern.Decision1In3Out Property

AnchorPattern.Decision1In3Out Property

Gets the predefined anchor pattern Decision1In3Out.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static AnchorPattern Decision1In3Out { get; }
Visual Basic

Public Shared ReadOnly Property Decision1In3Out As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

Incoming links connect to the top vertex; outgoing links can start from the other vertices.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern.Decision2In2Out Property

AnchorPattern.Decision2In2Out Property

Gets the predefined anchor pattern Decision2In2Out.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static AnchorPattern Decision2In2Out { get; }
Visual Basic

Public Shared ReadOnly Property Decision2In2Out As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

Incoming links can connect with the top and left vertices; outgoing links can start from the right and bottom vertices.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern.Id Property

AnchorPattern.Id Property

Gets the AnchorPattern unique identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string Id { get; }
Visual Basic

Public ReadOnly Property Id As String

Property Value

The string id that was passed as an argument to the AnchorPattern constructor. The default is an empty string.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern.LeftInRightOut Property

AnchorPattern.LeftInRightOut Property

Gets the predefined anchor pattern LeftInRightOut.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static AnchorPattern LeftInRightOut { get; }
Visual Basic

Public Shared ReadOnly Property LeftInRightOut As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

The middle point of a node's bounding rectangle left side is anchor for incoming links; that on the right side - for outgoing.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern.Points Property

AnchorPattern.Points Property

Gets a collection of the anchor points in this pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPointCollection Points { get; set; }
Visual Basic

Public Property Points As AnchorPointCollection

Property Value

The string id that was passed as an argument to the AnchorPattern constructor. The default is an empty string.

Remarks

To find an anchor pattern by its id, call the static FromId method.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPattern.TopInBottomOut Property

AnchorPattern.TopInBottomOut Property

Gets the predefined anchor pattern TopInBottomOut.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static AnchorPattern TopInBottomOut { get; }
Visual Basic

Public Shared ReadOnly Property TopInBottomOut As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

The middle point of a node's bounding rectangle top side is anchor for incoming links; that on the bottom - for outgoing.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint Class

AnchorPoint Class
Remarks See Also

Specify the locations in a node, to which the user is allowed to connect links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public sealed class AnchorPoint : ICloneable, IPersists
Visual Basic

Public NotInheritable Class AnchorPoint
Implements ICloneable, IPersists

Remarks

An anchor point can accept incoming or outgoing links, or both, as specified by the AllowIncoming and AllowOutgoing properties. The position of the anchor point inside a node's bounding rectangle is set through the X and Y properties, expressed as percent of the rectangle width and height.

How anchor points are marked on the display can be set using MarkStyle and Color properties. Custom painting can be done by setting MarkStyle to Custom and handling the DrawAnchorPoint event.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AnchorPoint

See Also

AnchorPoint Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint Members

AnchorPoint Members
Constructors Properties Methods

Specify the locations in a node, to which the user is allowed to connect links.

The following tables list the members exposed by the AnchorPoint type.

Public Constructors

Name | Description
AnchorPoint | Overloaded. The following constructors are provided for creating new AnchorPoint objects.

Public Properties

Name | Description
AllowIncoming | Gets or sets a value indicating whether incoming links can be connected to this anchor.
AllowOutgoing | Gets or sets a value indicating whether the anchor point accepts outgoing connections.
Color | Gets or sets the color of the anchor point mark.
Column | Gets or sets the column index of a cell with which the anchor point is associated.
MarkStyle | Gets or sets the appearance of the anchor point mark.
Tag | Gets or sets a user-defined data associated with the anchor point.
ToolTip | Gets or sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.
X | Gets or sets the horizontal position of the anchor point expressed as percent of a node's width.
Y | Gets or sets the vertical position of the anchor point expressed as percent of a node's height.

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPoint object.

See Also

AnchorPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint Constructor

AnchorPoint Constructor

The following constructors are provided for creating new AnchorPoint objects.

Overload List

Name | Description
AnchorPoint (Single, Single) | Initializes a new instance of the AnchorPoint class with the specified coordinates.
AnchorPoint (Single, Single, Boolean, Boolean) | Initializes a new instance of the AnchorPoint class with the specified coordinates and restrictions.
AnchorPoint (Single, Single, Boolean, Boolean, Color, Int32) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and color.
AnchorPoint (Single, Single, Boolean, Boolean, Color, Int32, Object) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, color and tag.
AnchorPoint (Single, Single, Boolean, Boolean, MarkStyle) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and style.
AnchorPoint (Single, Single, Boolean, Boolean, MarkStyle, Color) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, style and color.

See Also

AnchorPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint Constructor (Single, Single)

AnchorPoint Constructor (Single, Single)
See Also

Initializes a new instance of the AnchorPoint class with the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPoint (
float x,
float y
)
Visual Basic

Public New ( _
x As Single, _
y As Single _
)

Parameters

x
The horizontal position of the anchor expressed as percent of the width of a node.
y
The vertical position of the anchor expressed as percent of the height of a node.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint Constructor (Single, Single, Boolean, Boolean)

AnchorPoint Constructor (Single, Single, Boolean, Boolean)
See Also

Initializes a new instance of the AnchorPoint class with the specified coordinates and restrictions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPoint (
float x,
float y,
bool allowIncoming,
bool allowOutgoing
)
Visual Basic

Public New ( _
x As Single, _
y As Single, _
allowIncoming As Boolean, _
allowOutgoing As Boolean _
)

Parameters

x
The horizontal position of the anchor expressed as percent of the width of a node.
y
The vertical position of the anchor expressed as percent of the height of a node.
allowIncoming
Specifies whether incoming links can connect to this anchor.
allowOutgoing
Specifies whether outgoing links can connect to this anchor.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint Constructor (Single, Single, Boolean, Boolean, Color, Int32)

AnchorPoint Constructor (Single, Single, Boolean, Boolean, Color, Int32)
See Also

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and color.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPoint (
float x,
float y,
bool allowIncoming,
bool allowOutgoing,
Color color,
int col
)
Visual Basic

Public New ( _
x As Single, _
y As Single, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
color As Color, _
col As Integer _
)

Parameters

x
The horizontal position of the anchor expressed as percent of the width of a node.
y
The vertical position of the anchor expressed as percent of the height of a node.
allowIncoming
Specifies whether incoming links can connect to this anchor.
allowOutgoing
Specifies whether outgoing links can connect to this anchor.
color
The color with which the anchor mark is painted.
col
Specifies a table's column, with which an anchor point is associated.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint Constructor (Single, Single, Boolean, Boolean, Color, Int32, Object)

AnchorPoint Constructor (Single, Single, Boolean, Boolean, Color, Int32, Object)
See Also

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, color and tag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPoint (
float x,
float y,
bool allowIncoming,
bool allowOutgoing,
Color color,
int col,
Object tag
)
Visual Basic

Public New ( _
x As Single, _
y As Single, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
color As Color, _
col As Integer, _
tag As Object _
)

Parameters

x
The horizontal position of the anchor expressed as percent of the width of a node.
y
The vertical position of the anchor expressed as percent of the height of a node.
allowIncoming
Specifies whether incoming links can connect to this anchor.
allowOutgoing
Specifies whether outgoing links can connect to this anchor.
color
The color with which the anchor mark is painted.
col
The table's column, with which an anchor point is associated.
tag
User-defined data associated with the anchor point.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint Constructor (Single, Single, Boolean, Boolean, MarkStyle)

AnchorPoint Constructor (Single, Single, Boolean, Boolean, MarkStyle)
See Also

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and style.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPoint (
float x,
float y,
bool allowIncoming,
bool allowOutgoing,
MarkStyle markStyle
)
Visual Basic

Public Sub AnchorPoint ( _
x As Single, _
y As Single, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
markStyle As MarkStyle _
)

Parameters

x
The horizontal position of the anchor expressed as percent of the width of a node.
y
The vertical position of the anchor expressed as percent of the height of a node.
allowIncoming
Specifies whether incoming links can connect to this anchor.
allowOutgoing
Specifies whether outgoing links can connect to this anchor.
markStyle
Defines how the anchor point is marked visually.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint Constructor (Single, Single, Boolean, Boolean, MarkStyle, Color)

AnchorPoint Constructor (Single, Single, Boolean, Boolean, MarkStyle, Color)
See Also

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, style and color.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPoint (
float x,
float y,
bool allowIncoming,
bool allowOutgoing,
MarkStyle markStyle,
Color color
)
Visual Basic

Public Sub AnchorPoint ( _
x As Single, _
y As Single, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
markStyle As MarkStyle, _
color As Color _
)

Parameters

x
The horizontal position of the anchor expressed as percent of the width of a node.
y
The vertical position of the anchor expressed as percent of the height of a node.
allowIncoming
Specifies whether incoming links can connect to this anchor.
allowOutgoing
Specifies whether outgoing links can connect to this anchor.
markStyle
Defines how the anchor point is marked visually.
color
The color with which the anchor mark is painted.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint Methods

AnchorPoint Methods

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPoint object.

See Also

AnchorPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint.Clone Method

AnchorPoint.Clone Method

Creates an exact clone of this AnchorPoint object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

An instance of the AnchorPoint class.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint Properties

AnchorPoint Properties

Public Properties

Name | Description
AllowIncoming | Gets or sets a value indicating whether incoming links can be connected to this anchor.
AllowOutgoing | Gets or sets a value indicating whether the anchor point accepts outgoing connections.
Color | Gets or sets the color of the anchor point mark.
Column | Gets or sets the column index of a cell with which the anchor point is associated.
MarkStyle | Gets or sets the appearance of the anchor point mark.
Tag | Gets or sets a user-defined data associated with the anchor point.
ToolTip | Gets or sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.
X | Gets or sets the horizontal position of the anchor point expressed as percent of a node's width.
Y | Gets or sets the vertical position of the anchor point expressed as percent of a node's height.

See Also

AnchorPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint.AllowIncoming Property

AnchorPoint.AllowIncoming Property

Gets or sets a value indicating whether incoming links can be connected to this anchor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowIncoming { get; set; }
Visual Basic

Public Property AllowIncoming As Boolean

Property Value

true to allow incoming links connect to the anchor; false to forbid that. The default is true.

Remarks

If no incoming anchors are defined for a node, links end points can be placed anywhere inside that node, unless AllowUnanchoredLinks is disabled.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
AllowOutgoing Property
ValidateAnchorPoint Event


MindFusion.Diagramming.AnchorPoint.AllowOutgoing Property

AnchorPoint.AllowOutgoing Property

Gets or sets a value indicating whether the anchor point accepts outgoing connections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowOutgoing { get; set; }
Visual Basic

Public Property AllowOutgoing As Boolean

Property Value

true to allow outgoing links connect to the anchor; false to forbid that. The default is true.

Remarks

If no outgoing anchors are defined for a node, links start points can be placed anywhere inside that node, unless AllowUnanchoredLinks is disabled.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
AllowIncoming Property
ValidateAnchorPoint Event


MindFusion.Diagramming.AnchorPoint.Color Property

AnchorPoint.Color Property

Gets or sets the color of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color Color { get; set; }
Visual Basic

Public Property Color As Color

Property Value

An instance of the .NET Color structure. The default is Color.Black.

Remarks

The anchor mark shape specified by MarkStyle is painted with this color.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
MarkStyle Property


MindFusion.Diagramming.AnchorPoint.Column Property

AnchorPoint.Column Property

Gets or sets the column index of a cell with which the anchor point is associated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Column { get; set; }
Visual Basic

Public Property Column As Integer

Property Value

An integer value specifying the zero-based index of a table's column. The default is -1.

Remarks

This property is useful when the anchor point is included in table row's AnchorPattern. It defines whether the anchor point is relative to a cell or to a whole row. If Column is set to -1, the point relative coordinates specify percents of row's extents. Otherwise the point coordinates specify percents of cell's extents.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
Row.AnchorPattern Property


MindFusion.Diagramming.AnchorPoint.MarkStyle Property

AnchorPoint.MarkStyle Property

Gets or sets the appearance of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public MarkStyle MarkStyle { get; set; }
Visual Basic

Public Property MarkStyle As MarkStyle

Property Value

A member of the MarkStyle enumeration. The default is MarkStyle.X.

Remarks

Specifies how anchor points are marked visually on the display. Custom code can be used to draw the marks by setting the property value to MarkStyle.Custom and handling the DrawAnchorPoint event.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
Color Property


MindFusion.Diagramming.AnchorPoint.Tag Property

AnchorPoint.Tag Property

Gets or sets a user-defined data associated with the anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object Tag { get; set; }
Visual Basic

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object. The default is null (Nothing in Visual Basic).

Remarks

This property holds data that you define. MindFusion.Diagramming does not use it in any way. You might associate with the anchor point any value of primitive data types. The tag also might be a complex object from the .NET class library or a class defined by you. If the tag is an instance of value type, it will be serialized together with the object containing it when saving / loading a diagram. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
SerializeTag Event


MindFusion.Diagramming.AnchorPoint.ToolTip Property

AnchorPoint.ToolTip Property

Gets or sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ToolTip { get; set; }
Visual Basic

Public Property ToolTip As String

Property Value

A string specifying the tool-tip text displayed for this anchor point. The default is an empty string.

Remarks

When the mouse rests for a while over an anchor point, the tool-tip text is displayed in a small popup window near the mouse cursor. If the anchor point tooltip is an empty string, the ToolTip of the node to which the anchor point is assigned is displayed instead.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPoint.X Property

AnchorPoint.X Property

Gets or sets the horizontal position of the anchor point expressed as percent of a node's width.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float X { get; set; }
Visual Basic

Public Property X As Single

Property Value

A float value specifying the location of the anchor point, expressed in percent.

Remarks

Set the property value to a number from 0 to 100, otherwise you might get unexpected behavior.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
Y Property


MindFusion.Diagramming.AnchorPoint.Y Property

AnchorPoint.Y Property

Gets or sets the vertical position of the anchor point expressed as percent of a node's height.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float Y { get; set; }
Visual Basic

Public Property Y As Single

Property Value

A float value specifying the location of the anchor point, expressed in percent.

Remarks

Set the property value to a number from 0 to 100, otherwise you might get unexpected behavior.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming Namespace
X Property


MindFusion.Diagramming.AnchorPointCollection Class

AnchorPointCollection Class

Represents a strongly typed collection of anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class AnchorPointCollection : PersistableCollection
Visual Basic

Public Class AnchorPointCollection
Inherits PersistableCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.PersistableCollection
MindFusion.Diagramming.AnchorPointCollection

See Also

AnchorPointCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointCollection Members

AnchorPointCollection Members
Constructors Properties Methods

Represents a strongly typed collection of anchor points.

The following tables list the members exposed by the AnchorPointCollection type.

Public Constructors

Name | Description
AnchorPointCollection | Overloaded.

Public Properties

Name | Description
Item | Gets or sets the anchor point at the specified position.

Public Methods

Name | Description
Add | Adds the specified anchor point to the collection.
Clear | Removes all anchor points from the collection.
Contains | Checks whether the specified anchor point is contained in the collection.
GetAt | Gets the anchor point at the specified position.
Insert | Inserts the specified anchor point in the collection at the specified position.
Remove | Removes the specified anchor point from the collection.

See Also

AnchorPointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointCollection Constructor

AnchorPointCollection Constructor

Overload List

Name | Description
AnchorPointCollection () | Initializes a new instance of the AnchorPointCollection class.
AnchorPointCollection (AnchorPoint[]) | Initializes a new instance of the AnchorPointCollection class.

See Also

AnchorPointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointCollection Constructor ()

AnchorPointCollection Constructor ()
See Also

Initializes a new instance of the AnchorPointCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPointCollection ()
Visual Basic

Public Sub New ()

See Also

AnchorPointCollection Constructor Overload List
AnchorPointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointCollection Constructor (AnchorPoint[])

AnchorPointCollection Constructor (AnchorPoint[])
See Also

Initializes a new instance of the AnchorPointCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPointCollection (
AnchorPoint[] array
)
Visual Basic

Public Sub AnchorPointCollection ( _
array As AnchorPoint() _
)

Parameters

array

See Also

AnchorPointCollection Constructor Overload List
AnchorPointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointCollection Methods

AnchorPointCollection Methods

Public Methods

Name | Description
Add | Adds the specified anchor point to the collection.
Clear | Removes all anchor points from the collection.
Contains | Checks whether the specified anchor point is contained in the collection.
GetAt | Gets the anchor point at the specified position.
Insert | Inserts the specified anchor point in the collection at the specified position.
Remove | Removes the specified anchor point from the collection.

See Also

AnchorPointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointCollection.Add Method

AnchorPointCollection.Add Method

Adds the specified anchor point to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Add (
AnchorPoint point
)
Visual Basic

Public Sub Add ( _
point As AnchorPoint _
)

Parameters

point

See Also

AnchorPointCollection Members
AnchorPointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointCollection.Clear Method

AnchorPointCollection.Clear Method

Removes all anchor points from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

AnchorPointCollection Members
AnchorPointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointCollection.Contains Method

AnchorPointCollection.Contains Method

Checks whether the specified anchor point is contained in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Contains (
AnchorPoint point
)
Visual Basic

Public Function Contains ( _
point As AnchorPoint _
) As Boolean

Parameters

point

Return Value

See Also

AnchorPointCollection Members
AnchorPointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointCollection.GetAt Method

AnchorPointCollection.GetAt Method

Gets the anchor point at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPoint GetAt (
int index
)
Visual Basic

Public Function GetAt ( _
index As Integer _
) As AnchorPoint

Parameters

index

Return Value

See Also

AnchorPointCollection Members
AnchorPointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointCollection.Insert Method

AnchorPointCollection.Insert Method

Inserts the specified anchor point in the collection at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Insert (
int index,
AnchorPoint point
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
point As AnchorPoint _
)

Parameters

index
point

See Also

AnchorPointCollection Members
AnchorPointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointCollection.Remove Method

AnchorPointCollection.Remove Method

Removes the specified anchor point from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Remove (
AnchorPoint point
)
Visual Basic

Public Sub Remove ( _
point As AnchorPoint _
)

Parameters

point

See Also

AnchorPointCollection Members
AnchorPointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointCollection Properties

AnchorPointCollection Properties

Public Properties

Name | Description
Item | Gets or sets the anchor point at the specified position.

See Also

AnchorPointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointCollection.Item Property

AnchorPointCollection.Item Property

Gets or sets the anchor point at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPoint Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As AnchorPoint

Parameters

index

Property Value

See Also

AnchorPointCollection Members
AnchorPointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointEventArgs Class

AnchorPointEventArgs Class

Contains the arguments passed to the anchor point-related events, such as OriginAnchorChanged and DestinationAnchorChanged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class AnchorPointEventArgs : EventArgs
Visual Basic

Public Class AnchorPointEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.AnchorPointEventArgs

See Also

AnchorPointEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointEventArgs Members

AnchorPointEventArgs Members
Constructors Properties

Contains the arguments passed to the anchor point-related events, such as OriginAnchorChanged and DestinationAnchorChanged.

The following tables list the members exposed by the AnchorPointEventArgs type.

Public Constructors

Name | Description
AnchorPointEventArgs | Initializes a new instance of the AnchorPointEventArgs class.

Public Properties

Name | Description
Link | Gets the link whose anchor point index has been changed.
NewAnchorIndex | Gets the index of the new anchor point.
OldAnchorIndex | Gets the index of the old anchor point.

See Also

AnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointEventArgs Constructor

AnchorPointEventArgs Constructor

Initializes a new instance of the AnchorPointEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPointEventArgs (
DiagramLink link,
int oldAnchorIndex,
int newAnchorIndex
)
Visual Basic

Public Sub AnchorPointEventArgs ( _
link As DiagramLink, _
oldAnchorIndex As Integer, _
newAnchorIndex As Integer _
)

Parameters

link
The link whose end has been attached to a different anchor point.
oldAnchorIndex
The index of the old anchor point.
newAnchorIndex
The index of the new anchor point.

See Also

AnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointEventArgs Properties

AnchorPointEventArgs Properties

Public Properties

Name | Description
Link | Gets the link whose anchor point index has been changed.
NewAnchorIndex | Gets the index of the new anchor point.
OldAnchorIndex | Gets the index of the old anchor point.

See Also

AnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointEventArgs.Link Property

AnchorPointEventArgs.Link Property

Gets the link whose anchor point index has been changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink Link { get; }
Visual Basic

Public ReadOnly Property Link As DiagramLink

Property Value

An instance of the DiagramLink class.

See Also

AnchorPointEventArgs Members
AnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointEventArgs.NewAnchorIndex Property

AnchorPointEventArgs.NewAnchorIndex Property

Gets the index of the new anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int NewAnchorIndex { get; }
Visual Basic

Public ReadOnly Property NewAnchorIndex As Integer

Property Value

An integer value that represents the index of the anchor point within its containing AnchorPattern class.

See Also

AnchorPointEventArgs Members
AnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointEventArgs.OldAnchorIndex Property

AnchorPointEventArgs.OldAnchorIndex Property

Gets the index of the old anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int OldAnchorIndex { get; }
Visual Basic

Public ReadOnly Property OldAnchorIndex As Integer

Property Value

An integer value that represents the index of the anchor point within its containing AnchorPattern class.

See Also

AnchorPointEventArgs Members
AnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AnchorPointEventHandler Delegate

AnchorPointEventHandler Delegate

Represents methods that will handle anchor point-related events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void AnchorPointEventHandler (
Object sender,
AnchorPointEventArgs e
)
Visual Basic

Public Delegate Sub AnchorPointEventHandler ( _
sender As Object, _
e As AnchorPointEventArgs _
)

Parameters

sender

The source of the event.

e

An AnchorPointEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArcTemplate Class

ArcTemplate Class

Represents an arc in a shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ArcTemplate : ElementTemplate
Visual Basic

Public Class ArcTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.ArcTemplate

See Also

ArcTemplate Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArcTemplate Members

ArcTemplate Members
Constructors Properties Methods

Represents an arc in a shape definition.

The following tables list the members exposed by the ArcTemplate type.

Public Constructors

Name | Description
ArcTemplate | Overloaded. Initializes a new instance of the ArcTemplate class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
StartAngle | Gets the start angle of this arc element.
SweepAngle | Gets the sweep angle of this arc element.

Public Methods

Name | Description
Clone | Creates an exact copy of this ArcTemplate element.
SameAs | ElementTemplate.SameAs override.

See Also

ArcTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArcTemplate Constructor

ArcTemplate Constructor

Initializes a new instance of the ArcTemplate class.

Overload List

Name | Description
ArcTemplate (Single, Single, Single, Single, Single, Single) | Initializes a new istance of the ArcTemplate class with the specified coordinates.
ArcTemplate (Single, Single, Single, Single, Single, Single, Color, DashStyle, Single) | Initializes a new istance of the ArcTemplate class with the specified coordinates and visualization settings.

See Also

ArcTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArcTemplate Constructor (Single, Single, Single, Single, Single, Single)

ArcTemplate Constructor (Single, Single, Single, Single, Single, Single)
See Also

Initializes a new istance of the ArcTemplate class with the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ArcTemplate (
float x,
float y,
float w,
float h,
float a,
float s
)
Visual Basic

Public New ( _
x As Single, _
y As Single, _
w As Single, _
h As Single, _
a As Single, _
s As Single _
)

Parameters

x
The x-coordinate of the upper left corner of the ellipse's bounding rectangle.
y
The y-coordinate of the upper left corner of the ellipse's bounding rectangle.
w
The width of the ellipse's bounding rectangle.
h
The height of the ellipse's bounding rectangle.
a
The clockwise angle, in degrees, between the horizontal axis of the ellipse and the starting point of the arc.
s
The clockwise angle, in degrees, between the starting point and the ending point of the arc.

Remarks

An arc template is defined by an ellipse and starting and sweeping angles.

See Also

ArcTemplate Constructor Overload List
ArcTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArcTemplate Constructor (Single, Single, Single, Single, Single, Single, Color, DashStyle, Single)

ArcTemplate Constructor (Single, Single, Single, Single, Single, Single, Color, DashStyle, Single)
See Also

Initializes a new istance of the ArcTemplate class with the specified coordinates and visualization settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ArcTemplate (
float x,
float y,
float w,
float h,
float a,
float s,
Color color,
DashStyle dashStyle,
float width
)
Visual Basic

Public New ( _
x As Single, _
y As Single, _
w As Single, _
h As Single, _
a As Single, _
s As Single, _
color As Color, _
dashStyle As DashStyle, _
width As Single _
)

Parameters

x
The x-coordinate of the upper left corner of the ellipse's bounding rectangle.
y
The y-coordinate of the upper left corner of the ellipse's bounding rectangle.
w
The width of the ellipse's bounding rectangle.
h
The height of the ellipse's bounding rectangle.
a
The clockwise angle, in degrees, between the horizontal axis of the ellipse and the starting point of the arc.
s
The clockwise angle, in degrees, between the starting point and the ending point of the arc.
color
The color of this segment.
dashStyle
The dash style of this segment.
width
The width of this segment.

Remarks

An arc template is defined by an ellipse and starting and sweeping angles.

See Also

ArcTemplate Constructor Overload List
ArcTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArcTemplate Methods

ArcTemplate Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this ArcTemplate element.
SameAs | ElementTemplate.SameAs override.

See Also

ArcTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArcTemplate.Clone Method

ArcTemplate.Clone Method

Creates an exact copy of this ArcTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

An instance of the ArcTemplate class.

See Also

ArcTemplate Members
ArcTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArcTemplate.SameAs Method

ArcTemplate.SameAs Method

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool SameAs (
ElementTemplate obj
)
Visual Basic

Public Overrides Function SameAs ( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this template.

Return Value

true if the specified object is an ArcTemplate closely approximating this template; otherwise, false.

See Also

ArcTemplate Members
ArcTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArcTemplate Properties

ArcTemplate Properties

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
StartAngle | Gets the start angle of this arc element.
SweepAngle | Gets the sweep angle of this arc element.

See Also

ArcTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArcTemplate.Bounds Property

ArcTemplate.Bounds Property

Gets the bounding rectangle of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As RectangleF

Property Value

An instance of the .NET RectangleF structure.

See Also

ArcTemplate Members
ArcTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArcTemplate.StartAngle Property

ArcTemplate.StartAngle Property

Gets the start angle of this arc element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float StartAngle { get; }
Visual Basic

Public ReadOnly Property StartAngle As Single

Property Value

A float value specifying the start angle of the arc, in degrees.

See Also

ArcTemplate Members
ArcTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArcTemplate.SweepAngle Property

ArcTemplate.SweepAngle Property

Gets the sweep angle of this arc element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float SweepAngle { get; }
Visual Basic

Public ReadOnly Property SweepAngle As Single

Property Value

A float value specifying the sweep angle of the arc, in degrees.

See Also

ArcTemplate Members
ArcTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AreaEventArgs Class

AreaEventArgs Class

Contains arguments passed to handlers of the CreatingArea event of the HtmlBuilder class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class AreaEventArgs : EventArgs
Visual Basic

Public Class AreaEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.AreaEventArgs

See Also

AreaEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AreaEventArgs Members

AreaEventArgs Members
Properties

Contains arguments passed to handlers of the CreatingArea event of the HtmlBuilder class.

The following tables list the members exposed by the AreaEventArgs type.

Public Properties

Name | Description
AreaTag | Gets or sets the HTML AREA tag created by HtmlBuilder. You can insert additional attributes or JavaScript event handlers into that string.
Column | Gets the index of a column if the event is raised for a table cell.
Item | Gets the diagram element represented by AreaTag in the image map.
Row | Gets the index of a row if the event is raised for a table cell.

See Also

AreaEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AreaEventArgs Properties

AreaEventArgs Properties

Public Properties

Name | Description
AreaTag | Gets or sets the HTML AREA tag created by HtmlBuilder. You can insert additional attributes or JavaScript event handlers into that string.
Column | Gets the index of a column if the event is raised for a table cell.
Item | Gets the diagram element represented by AreaTag in the image map.
Row | Gets the index of a row if the event is raised for a table cell.

See Also

AreaEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AreaEventArgs.AreaTag Property

AreaEventArgs.AreaTag Property

Gets or sets the HTML AREA tag created by HtmlBuilder. You can insert additional attributes or JavaScript event handlers into that string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string AreaTag { get; set; }
Visual Basic

Public Property AreaTag As String

Property Value

A string value that represents the AREA tag, including the opening and closing brackets.

See Also

AreaEventArgs Members
AreaEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AreaEventArgs.Column Property

AreaEventArgs.Column Property

Gets the index of a column if the event is raised for a table cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Column { get; }
Visual Basic

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the related column.

See Also

AreaEventArgs Members
AreaEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AreaEventArgs.Item Property

AreaEventArgs.Item Property

Gets the diagram element represented by AreaTag in the image map.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; }
Visual Basic

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

AreaEventArgs Members
AreaEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AreaEventArgs.Row Property

AreaEventArgs.Row Property

Gets the index of a row if the event is raised for a table cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Row { get; }
Visual Basic

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the related row.

See Also

AreaEventArgs Members
AreaEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AreaEventHandler Delegate

AreaEventHandler Delegate

Represents methods that will handle the CreatingArea event of the HtmlBuilder class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void AreaEventHandler (
Object sender,
AreaEventArgs e
)
Visual Basic

Public Delegate Sub AreaEventHandler ( _
sender As Object, _
e As AreaEventArgs _
)

Parameters

sender

The source of the event.

e

An AreaEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArrowHead Enumeration

ArrowHead Enumeration

Specifies the shape of an arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum ArrowHead
Visual Basic

Public Enumeration ArrowHead

Members

Member name | Description
Arrow | Display an arrow-like shape.
BackSlash | Display a back slash.
BowArrow | Display a bow arrow.
Circle | Display a circle.
DefaultFlow | "Default flow" in BPMN diagrams.
DoubleArrow | Display a double arrow.
None | Do not display an arrowhead shape.
Pentagon | Display a pentagon.
PointerArrow | Display a pointer arrow.
Quill | Display a quill.
Reversed | Reversed arrowhead.
RevTriangle | Display a reversed triangle.
RevWithCirc | Reversed arrowhead with a circle.
RevWithLine | Reversed arrowhead with intersecting line.
Rhombus | Display a rhombus.
Slash | Display a slash.
Tetragon | Display a tetragon.
Triangle | Display a triangle.

Remarks

The DiagramLink class provides several properties that use values from this enumeration. The HeadShape property specifies what shape to paint at the end of a link. BaseShape specifies the shape painted at the beginning of a link. IntermediateShape is a shape that is painted in the middle of each segment of a link.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArrowHeadShape Class

ArrowHeadShape Class

Defines the shape of a link arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public sealed class ArrowHeadShape
Visual Basic

Public NotInheritable Class ArrowHeadShape

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ArrowHeadShape

See Also

ArrowHeadShape Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArrowHeadShape Members

ArrowHeadShape Members
Properties Methods

Defines the shape of a link arrowhead.

The following tables list the members exposed by the ArrowHeadShape type.

Public Properties

Name | Description
Coordinates | Gets an array containing the coordinates of the points contained within the shape.
Elements | Gets an array containing the types of the elements contained within the shape.

Public Methods

Name | Description
Draw | Renders the arrowhead on the specified graphics surface using the specified pen and brush.

See Also

ArrowHeadShape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.LinksRetainForm Property

Diagram.LinksRetainForm Property

Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool LinksRetainForm { get; set; }
Visual Basic

Public Property LinksRetainForm As Boolean

Property Value

true to retain links' forms; otherwise, false. The default is false.

Remarks

LinksRetainForm value is used to initialize the RetainForm property of new links. It has effect on links that have more than two control points. If the nodes that a link connects are moved around, usually only the segments at the ends of that link are updated, so that they stay connected to their respective nodes. In that case all intermediate control points stay where they are. However, if RetainForm is enabled, all control points will move simultaneously in a way they preserve their relative position one to another, and thus preserving the overall form of the link.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
RouteLinks Property
DynamicLinks Property


MindFusion.Diagramming.ArrowHeadShape.Draw Method

ArrowHeadShape.Draw Method

Renders the arrowhead on the specified graphics surface using the specified pen and brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Draw (
IGraphics graphics,
Pen pen,
Brush brush,
float xoff,
float yoff
)
Visual Basic

Public Sub Draw ( _
graphics As IGraphics, _
pen As Pen, _
brush As Brush, _
xoff As Single, _
yoff As Single _
)

Parameters

graphics
The IGraphics surface to draw the arrowhead on.
pen
A Pen used to draw the arrowhead outline.
brush
A Brush used to fill the arrowhead.
xoff
Draw with the specified horizontal offset.
yoff
Draw with the specified vertical offset.

See Also

ArrowHeadShape Members
ArrowHeadShape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArrowHeadShape Properties

ArrowHeadShape Properties

Public Properties

Name | Description
Coordinates | Gets an array containing the coordinates of the points contained within the shape.
Elements | Gets an array containing the types of the elements contained within the shape.

See Also

ArrowHeadShape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArrowHeadShape.Coordinates Property

ArrowHeadShape.Coordinates Property

Gets an array containing the coordinates of the points contained within the shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float[] Coordinates { get; }
Visual Basic

Public ReadOnly Property Coordinates As Single()

Property Value

An array of float values containing the coordinates of the elements composing the arrow head.

See Also

ArrowHeadShape Members
ArrowHeadShape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ArrowHeadShape.Elements Property

ArrowHeadShape.Elements Property

Gets an array containing the types of the elements contained within the shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int[] Elements { get; }
Visual Basic

Public ReadOnly Property Elements As Integer()

Property Value

An array of integer values containing the types of the elements composing the arrow head.

See Also

ArrowHeadShape Members
ArrowHeadShape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.AttachTo Enumeration

AttachTo Enumeration

Specifies the type of attachment in a group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum AttachTo
Visual Basic

Public Enumeration AttachTo

Members

Member name | Description
AnchorToEdges | Indicates attachment that is anchored to one or more sides of a node.
FixedCorner | Indicates attachment to a fixed corner of a node.
LinkPoint | Indicates attachment to an link's control point.
LinkSegment | Indicates attachment to an link's segment.
LongestHSegment | Indicates attachment to the longest horizontal segment of a link.
Proportional | Indicates proportional attachment to a node.
SideMiddle | Indicates attachment to the middle of a side of a node's bounding rectangle.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.AttachToLink Enumeration

AttachToLink Enumeration

Defines values specifying the possible ways to attach a node to a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum AttachToLink
Visual Basic

Public Enumeration AttachToLink

Members

Member name | Description
LongestHSegment | The node stays attached to the longest horizontal segment of the link.
Point | The node is attached to a fixed control point of the link.
Segment | The node is attached to a fixed segment of the link.

Remarks

Members of this enumeration are used as values for the attType argument of the AttachTo method of the DiagramNode class.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.AttachToNode Enumeration

AttachToNode Enumeration

Defines values specifying the possible ways to attach a node to another node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum AttachToNode
Visual Basic

Public Enumeration AttachToNode

Members

Member name | Description
BottomCenter | The node follows the bottom-center point of the master node.
BottomLeft | The node follows the bottom-left corner of the master node.
BottomRight | The node follows the bottom-right corner of the master node.
MiddleLeft | The node follows the middle-left point of the master node.
MiddleRight | The node follows the middle-right point of the master node.
TopCenter | The node follows the top-center point of the master node.
TopLeft | The node follows the top-left corner of the master node.
TopRight | The node follows the top-right corner of the master node.

Remarks

Members of this enumeration are used as values for the attType argument of the AttachTo method of the DiagramNode class.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.AutoResize Enumeration

AutoResize Enumeration

Defines in which directions automatic resizing can enlarge the diagram scrollable area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum AutoResize
Visual Basic

Public Enumeration AutoResize

Members

Member name | Description
AllDirections | Enlarge the diagram area in any direction if an item is moved outside the boundaries.
None | Do not enlarge the diagram area automatically.
RightAndDown | Enlarge the diagram area to the right and down if an item is moved outside the boundaries in these directions.

Remarks

Values from this enumeration can be assigned to the AutoResize property.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.Behavior Enumeration

Behavior Enumeration

Defines values that specify how the component responds to actions performed by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum Behavior
Visual Basic

Public Enumeration Behavior

Members

Member name | Description
Custom | Specifies that user input will be handled by the BehaviorBase-derived object assigned to CustomBehavior.
DoNothing | The control ignores users actions with the mouse, but raises the appropriate mouse events. This mode allows applications to implement their own mouse-drawing behavior, disabling the MindFusion.Diagramming default response to users actions.
DrawContainers | Drawing with the mouse creates ContainerNode instances.
DrawControls | Drawing with the mouse creates ControlNode instances.
DrawLinks | Drawing started over a node creates a DiagramLink. Otherwise a lasso rectangle is displayed allowing the selection of items.
DrawShapes | Drawing with the mouse creates ShapeNode instances.
DrawTables | Drawing with the mouse creates TableNode instances.
LinkContainers | Drawing over empty document area creates a ContainerNode instance. Drawing started over a node creates a DiagramLink.
LinkControls | Drawing over empty document area creates a ControlNode instance. Drawing started over a node creates a DiagramLink.
LinkShapes | A mode that is suitable for creating flowcharts and process diagrams. Drawing over empty document area creates a ShapeNode instance. Drawing started over a node creates a DiagramLink.
LinkTables | A mode that is suitable for creating entity-relationship diagrams. Drawing over empty document area creates a TableNode instance. Drawing started over a node creates a DiagramLink.
Modify | Items can be selected and modified. New items cannot be created.

Remarks

Use the Behavior property to specify how MindFusion.Diagramming interprets user's actions. In all modes:

  • single clicking selects the item under the mouse pointer and make it the ActiveItem;
  • dragging while CTRL is pressed creates multiple selection;
  • dragging while ALT is pressed pans the view;

See Also

MindFusion.Diagramming Namespace
Behavior Property


MindFusion.Diagramming.BezierTemplate Class

BezierTemplate Class

Represents a Bézier curve in a shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class BezierTemplate : ElementTemplate
Visual Basic

Public Class BezierTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.BezierTemplate

See Also

BezierTemplate Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.BezierTemplate Members

BezierTemplate Members
Constructors Properties Methods

Represents a Bézier curve in a shape definition.

The following tables list the members exposed by the BezierTemplate type.

Public Constructors

Name | Description
BezierTemplate | Overloaded. Initializes a new instance of the BezierTemplate class.

Public Properties

Name | Description
Coordinates | Gets a float array containing the coordinates of the points defining the Bézier curve represented by this element.

Public Methods

Name | Description
Clone | Creates an exact copy of this BezierTemplate element.
SameAs | ElementTemplate.SameAs override.

See Also

BezierTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.BezierTemplate Constructor

BezierTemplate Constructor

Initializes a new instance of the BezierTemplate class.

Overload List

Name | Description
BezierTemplate (Single, Single, Single, Single, Single, Single, Single, Single) | Initializes a new instance of the BezierTemplate class with the specified coordinates.
BezierTemplate (Single, Single, Single, Single, Single, Single, Single, Single, Color, DashStyle, Single) | Initializes a new instance of the BezierTemplate class with the specified coordinates and visualization settings.

See Also

BezierTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.BezierTemplate Constructor (Single, Single, Single, Single, Single, Single, Single, Single)

BezierTemplate Constructor (Single, Single, Single, Single, Single, Single, Single, Single)
See Also

Initializes a new instance of the BezierTemplate class with the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public BezierTemplate (
float x1,
float y1,
float x2,
float y2,
float x3,
float y3,
float x4,
float y4
)
Visual Basic

Public New ( _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single, _
x3 As Single, _
y3 As Single, _
x4 As Single, _
y4 As Single _
)

Parameters

x1
The x-coordinate of the first control point of the curve.
y1
The y-coordinate of the first control point of the curve.
x2
The x-coordinate of the second control point of the curve.
y2
The y-coordinate of the second control point of the curve.
x3
The x-coordinate of the third control point of the curve.
y3
The y-coordinate of the third control point of the curve.
x4

The x-coordinate of the fourth control point of the curve.

y4
The y-coordinate of the fourth control point of the curve.

Remarks

A Bézier spline is defined by four control points. The spline goes through the first and last points, and the other two define the tension of the spline.

See Also

BezierTemplate Constructor Overload List
BezierTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.BezierTemplate Constructor (Single, Single, Single, Single, Single, Single, Single, Single, Color, DashStyle, Single)

BezierTemplate Constructor (Single, Single, Single, Single, Single, Single, Single, Single, Color, DashStyle, Single)
See Also

Initializes a new instance of the BezierTemplate class with the specified coordinates and visualization settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public BezierTemplate (
float x1,
float y1,
float x2,
float y2,
float x3,
float y3,
float x4,
float y4,
Color color,
DashStyle dashStyle,
float width
)
Visual Basic

Public New ( _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single, _
x3 As Single, _
y3 As Single, _
x4 As Single, _
y4 As Single, _
color As Color, _
dashStyle As DashStyle, _
width As Single _
)

Parameters

x1
The x-coordinate of the first control point of the curve.
y1
The y-coordinate of the first control point of the curve.
x2
The x-coordinate of the second control point of the curve.
y2
The y-coordinate of the second control point of the curve.
x3
The x-coordinate of the third control point of the curve.
y3
The y-coordinate of the third control point of the curve.
x4
The x-coordinate of the fourth control point of the curve
y4
The y-coordinate of the fourth control point of the curve.
color
The color of this segment.
dashStyle

The dash style of this segment.

width
The width of this segment.

Remarks

A Bézier spline is defined by four control points. The spline goes through the first and last points, and the other two define the tension of the spline.

See Also

BezierTemplate Constructor Overload List
BezierTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.BezierTemplate Methods

BezierTemplate Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this BezierTemplate element.
SameAs | ElementTemplate.SameAs override.

See Also

BezierTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.BezierTemplate.Clone Method

BezierTemplate.Clone Method

Creates an exact copy of this BezierTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

An instance of the BezierTemplate class.

See Also

BezierTemplate Members
BezierTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.BezierTemplate.SameAs Method

BezierTemplate.SameAs Method

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool SameAs (
ElementTemplate obj
)
Visual Basic

Public Overrides Function SameAs ( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this template.

Return Value

true if the specified object is a BezierTemplate closely approximating this template; otherwise, false.

See Also

BezierTemplate Members
BezierTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.BezierTemplate Properties

BezierTemplate Properties

Public Properties

Name | Description
Coordinates | Gets a float array containing the coordinates of the points defining the Bézier curve represented by this element.

See Also

BezierTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.BezierTemplate.Coordinates Property

BezierTemplate.Coordinates Property

Gets a float array containing the coordinates of the points defining the Bézier curve represented by this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float[] Coordinates { get; }
Visual Basic

Public ReadOnly Property Coordinates As Single()

Property Value

An array of float values containing the coordinates of the points composing this element.

See Also

BezierTemplate Members
BezierTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellEventArgs Class

CellEventArgs Class

Contains the arguments passed to event handlers, such as CellClicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class CellEventArgs : EventArgs
Visual Basic

Public Class CellEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.CellEventArgs
MindFusion.Diagramming.CellValidationEventArgs

See Also

CellEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellEventArgs Members

CellEventArgs Members
Constructors Properties

Contains the arguments passed to event handlers, such as CellClicked.

The following tables list the members exposed by the CellEventArgs type.

Public Constructors

Name | Description
CellEventArgs | Initializes a new instance of the CellEventArgs class.

Public Properties

Name | Description
Cell | Get the cell for which the event is raised.
Column | Gets the index of the table's column that contains Cell.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets the current mouse pointer position.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

CellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellEventArgs Constructor

CellEventArgs Constructor

Initializes a new instance of the CellEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CellEventArgs (
TableNode.Cell cell,
MouseButton mouseButton,
PointF mousePosition,
int column,
int row
)
Visual Basic

Public Sub CellEventArgs ( _
cell As TableNode.Cell, _
mouseButton As MouseButton, _
mousePosition As PointF, _
column As Integer, _
row As Integer _
)

Parameters

cell

The TableNode.Cell related to the event.

mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse at the time the event was raised.

column

The zero-based index of the column related to the event.

row

The zero-based index of the row related to the event.

See Also

CellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellEventArgs Properties

CellEventArgs Properties

Public Properties

Name | Description
Cell | Get the cell for which the event is raised.
Column | Gets the index of the table's column that contains Cell.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets the current mouse pointer position.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

CellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellEventArgs.Cell Property

CellEventArgs.Cell Property

Get the cell for which the event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Cell Cell { get; }
Visual Basic

Public ReadOnly Property Cell As TableNode.Cell

Property Value

An instance of the TableNode.Cell class specifying the cell related to the event.

See Also

CellEventArgs Members
CellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellEventArgs.Column Property

CellEventArgs.Column Property

Gets the index of the table's column that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Column { get; }
Visual Basic

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the table column related to the event.

See Also

CellEventArgs Members
CellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellEventArgs.MouseButton Property

CellEventArgs.MouseButton Property

Gets which mouse button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public MouseButton MouseButton { get; }
Visual Basic

Public ReadOnly Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration specifying the currently pressed mouse button.

See Also

CellEventArgs Members
CellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellEventArgs.MousePosition Property

CellEventArgs.MousePosition Property

Gets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF MousePosition { get; }
Visual Basic

Public ReadOnly Property MousePosition As PointF

Property Value

A PointF value specifying the current mouse position.

See Also

CellEventArgs Members
CellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellEventArgs.Row Property

CellEventArgs.Row Property

Gets the index of the table's row that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Row { get; }
Visual Basic

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the table row related to the event.

See Also

CellEventArgs Members
CellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellEventArgs.Table Property

CellEventArgs.Table Property

Get the table that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode Table { get; }
Visual Basic

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class specifying the table related to the event.

See Also

CellEventArgs Members
CellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellEventHandler Delegate

CellEventHandler Delegate

Represents methods that will handle table-related mouse events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void CellEventHandler (
Object sender,
CellEventArgs e
)
Visual Basic

Public Delegate Sub CellEventHandler ( _
sender As Object, _
e As CellEventArgs _
)

Parameters

sender

The source of the event.

e

A CellEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellFrameStyle Enumeration

CellFrameStyle Enumeration

Specifies the style of the cells' frame lines.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum CellFrameStyle
Visual Basic

Public Enumeration CellFrameStyle

Members

Member name | Description
None | Table cells have no border.
Simple | The border of table cells is simple line.
System3D | The border has 3D look.

Remarks

The enumeration values are used when customizing table cells.

See Also

MindFusion.Diagramming Namespace
CellFrameStyle Property


MindFusion.Diagramming.CellValidationEventArgs Class

CellValidationEventArgs Class

Contains the arguments passed to event handlers, such as CellTextEditing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class CellValidationEventArgs : CellEventArgs
Visual Basic

Public Class CellValidationEventArgs
Inherits CellEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.CellEventArgs
MindFusion.Diagramming.CellValidationEventArgs

See Also

CellValidationEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellValidationEventArgs Members

CellValidationEventArgs Members
Constructors Properties

Contains the arguments passed to event handlers, such as CellTextEditing.

The following tables list the members exposed by the CellValidationEventArgs type.

Public Constructors

Name | Description
CellValidationEventArgs | Initializes a new instance of the CellValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.

See Also

CellValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellValidationEventArgs Constructor

CellValidationEventArgs Constructor

Initializes a new instance of the CellValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CellValidationEventArgs (
TableNode.Cell cell,
MouseButton mouseButton,
PointF mousePosition,
int column,
int row
)
Visual Basic

Public Sub CellValidationEventArgs ( _
cell As TableNode.Cell, _
mouseButton As MouseButton, _
mousePosition As PointF, _
column As Integer, _
row As Integer _
)

Parameters

cell

The TableNode.Cell related to the event.

mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse at the time the event was raised.

column

The zero-based index of the column related to the event.

row

The zero-based index of the row related to the event.

See Also

CellValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellValidationEventArgs Properties

CellValidationEventArgs Properties

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.

See Also

CellValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellValidationEventArgs.Cancel Property

CellValidationEventArgs.Cancel Property

Gets or sets a value indicating whether to prevent the user from completing the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Cancel { get; set; }
Visual Basic

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

See Also

CellValidationEventArgs Members
CellValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CellValidationEventHandler Delegate

CellValidationEventHandler Delegate

Represents methods that will handle table-related mouse events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void CellValidationEventHandler (
Object sender,
CellValidationEventArgs e
)
Visual Basic

Public Delegate Sub CellValidationEventHandler ( _
sender As Object, _
e As CellValidationEventArgs _
)

Parameters

sender

The source of the event.

e

A CellValidationEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.ColumnStyle Enumeration

ColumnStyle Enumeration

Specifies how table columns' width is set.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum ColumnStyle
Visual Basic

Public Enumeration ColumnStyle

Members

Member name | Description
AutoWidth | The columns' width changes when the table is resized.
FixedWidth | The columns has fixed, unchangeable width.

Remarks

Use the enumeration values to set the behavior of table columns, when the user resizes the table.

See Also

MindFusion.Diagramming Namespace
ColumnStyle Property


MindFusion.Diagramming.CommandHistory Class

CommandHistory Class
Remarks See Also

Maintains a queue of Command records used to undo or redo actions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class CommandHistory
Visual Basic

Public Class CommandHistory

Remarks

The only instance of CommandHistory can be accessed through the History property of UndoManager.

The Capacity property specifies how many Command instances can be stored in the history queue. If the queue is full and a new action is recorded, the oldest one will be removed and made unavailable for undo/redo. A read-only access to the command queue is provided by the Commands property.

The CommandHistory instance maintains an internal record pointer. The pointer is decreased or increased by one when an action is respectively undone or redone through the undo manager. The pointer actually refers to two adjacent action records - the older one to be used when undoing, the newer one when redoing commands. Those two records can be accessed by NextUndo and NextRedo properties. When no action has been undone, the pointer refers to the end of the queue and NextRedo returns null (Nothing in Visual Basic). When all actions have been undone, the pointer refers to the start of the queue and NextUndo returns null.

Call Clear to remove all action records that are currently in the history queue, making those actions unavailable for undo or redo anymore. That won't disable adding new records to the queue, so it will be possible to undo/redo any actions executed after Clear.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CommandHistory

See Also

CommandHistory Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CommandHistory Members

CommandHistory Members
Properties Methods

Maintains a queue of Command records used to undo or redo actions.

The following tables list the members exposed by the CommandHistory type.

Public Properties

Name | Description
Capacity | Gets or sets the maximum number of records to keep in the history queue.
Commands | Gets the commands saved in the undo / redo history queue.
NextRedo | Gets a reference to the command that would be redone if Redo is invoked.
NextUndo | Gets a reference to the command that would be undone if Undo is invoked.

Public Methods

Name | Description
Clear | Removes all records from the history queue.
MergeUndoRecords | Merges several undo records into a single composite record.

See Also

CommandHistory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CommandHistory Methods

CommandHistory Methods

Public Methods

Name | Description
Clear | Removes all records from the history queue.
MergeUndoRecords | Merges several undo records into a single composite record.

See Also

CommandHistory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CommandHistory.Clear Method

CommandHistory.Clear Method

Removes all records from the history queue.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Clear ()
Visual Basic

Public Sub Clear ()

Remarks

Call Clear to remove all action records that are currently in the history queue, making those actions unavailable for undo or redo anymore. That won't disable adding new records to the queue, so it will be possible to undo/redo any actions executed after the call.

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming Namespace
UndoEnabled Property


MindFusion.Diagramming.CommandHistory.MergeUndoRecords Method

CommandHistory.MergeUndoRecords Method

Merges several undo records into a single composite record.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool MergeUndoRecords (
int numRecords,
string title
)
Visual Basic

Public Function MergeUndoRecords ( _
numRecords As Integer, _
title As String _
) As Boolean

Parameters

numRecords
Specifies how many records at the end of the command list should be merged.
title
Specifies the title of the new command.

Return Value

false if the commands saved in the history are less than numRecords; otherwise, true.

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming Namespace
StartComposite Method


MindFusion.Diagramming.CommandHistory Properties

CommandHistory Properties

Public Properties

Name | Description
Capacity | Gets or sets the maximum number of records to keep in the history queue.
Commands | Gets the commands saved in the undo / redo history queue.
NextRedo | Gets a reference to the command that would be redone if Redo is invoked.
NextUndo | Gets a reference to the command that would be undone if Undo is invoked.

See Also

CommandHistory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CommandHistory.Capacity Property

CommandHistory.Capacity Property

Gets or sets the maximum number of records to keep in the history queue.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Capacity { get; set; }
Visual Basic

Public Property Capacity As Integer

Property Value

An integer value specifying the number of records to keep in the queue; cannot be less than 1. The default is 10.

Remarks

If the history queue is full, the oldest command records are removed from the beginning when new ones are added. The queue is cleared when you change Capacity, so better do this at application's startup phase.

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CommandHistory.Commands Property

CommandHistory.Commands Property

Gets the commands saved in the undo / redo history queue.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CommandList Commands { get; }
Visual Basic

Public ReadOnly Property Commands As CommandList

Property Value

An instance of the CommandList class representing a read-only collection of Command objects.

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming Namespace
NextUndo Property
NextRedo Property


MindFusion.Diagramming.CommandHistory.NextRedo Property

CommandHistory.NextRedo Property

Gets a reference to the command that would be redone if Redo is invoked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Command NextRedo { get; }
Visual Basic

Public ReadOnly Property NextRedo As Command

Property Value

An instance of the Command class.

Remarks

When no action has been undone, the current action pointer refers to the end of the history queue and NextRedo returns null (Nothing in Visual Basic).

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming Namespace
Redo Method
NextUndo Property


MindFusion.Diagramming.CommandHistory.NextUndo Property

CommandHistory.NextUndo Property

Gets a reference to the command that would be undone if Undo is invoked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Command NextUndo { get; }
Visual Basic

Public ReadOnly Property NextUndo As Command

Property Value

An instance of the Command class.

Remarks

When all actions have been undone, the current action pointer refers to the start of the history queue and NextUndo returns null (Nothing in Visual Basic).

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming Namespace
Undo Method
NextRedo Property


MindFusion.Diagramming.ConnectionPoint Class

ConnectionPoint Class

This class represent a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink objects contains two ConnectionPoint instances describing the connections at both ends of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ConnectionPoint : IPersists
Visual Basic

Public Class ConnectionPoint
Implements IPersists

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ConnectionPoint

See Also

ConnectionPoint Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint Members

ConnectionPoint Members
Constructors Properties Methods

This class represent a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink objects contains two ConnectionPoint instances describing the connections at both ends of the link.

The following tables list the members exposed by the ConnectionPoint type.

Public Constructors

Name | Description
ConnectionPoint | Overloaded. Initializes a new instance of the ConnectionPoint class.

Public Properties

Name | Description
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents.

ProtectedProperties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.
Link | Gets the link associated with this connection point.
Node | Gets the node associated with this connection point.

Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node.
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes.
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point.
GetAnchor |
GetAnchorPos | Overloaded.
GetEndPoint | Calculates the coordinates of the this connection point expressed in document coordinates.
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node.
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point.
LinkChanges | Checks whether the link would change if attached to the specified node at the specified point.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node.
SaveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

Protected Methods

Name | Description
GetClassId | Returns unique id number for this class.
LoadFrom | Deserializes the object from the specified reader.
SaveTo | Serializes the object to the specified writer.
SetReference | Updates the reference to the specified object.
UpdateFromPoint | Updates the connection stated according to the specified point, without changing the related node.

See Also

ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint Constructor

ConnectionPoint Constructor

Initializes a new instance of the ConnectionPoint class.

Overload List

Name | Description
ConnectionPoint () | Initializes a new instance of the ConnectionPoint class.
ConnectionPoint (DiagramNode, DiagramLink, Boolean) | Initializes a new instance of the ConnectionPoint class between the specified node and link.

See Also

ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint Constructor ()

ConnectionPoint Constructor ()
See Also

Initializes a new instance of the ConnectionPoint class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected ConnectionPoint ()
Visual Basic

Protected Sub New ()

Remarks

This constructor is used only during deserialization.

See Also

ConnectionPoint Constructor Overload List
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint Constructor (DiagramNode, DiagramLink, Boolean)

ConnectionPoint Constructor (DiagramNode, DiagramLink, Boolean)
See Also

Initializes a new instance of the ConnectionPoint class between the specified node and link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ConnectionPoint (
DiagramNode node,
DiagramLink link,
bool incoming
)
Visual Basic

Public Sub ConnectionPoint ( _
node As DiagramNode, _
link As DiagramLink, _
incoming As Boolean _
)

Parameters

node
The node whose connection to a link is managed by this ConnectionPoint.
link
The link whose connection to a node is managed by this ConnectionPoint.
incoming
Specifies which end of the link is represented by this ConnectionPoint.

See Also

ConnectionPoint Constructor Overload List
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint Methods

ConnectionPoint Methods

Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node.
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes.
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point.
GetAnchor |
GetAnchorPos | Overloaded.
GetEndPoint | Calculates the coordinates of the this connection point expressed in document coordinates.
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node.
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point.
LinkChanges | Checks whether the link would change if attached to the specified node at the specified point.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node.
SaveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

Protected Methods

Name | Description
GetClassId | Returns unique id number for this class.
LoadFrom | Deserializes the object from the specified reader.
SaveTo | Serializes the object to the specified writer.
SetReference | Updates the reference to the specified object.
UpdateFromPoint | Updates the connection stated according to the specified point, without changing the related node.

See Also

ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.AddLinkToNode Method

ConnectionPoint.AddLinkToNode Method

Adds the link associated with this connection point to the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void AddLinkToNode ()
Visual Basic

Public Overridable Sub AddLinkToNode ()

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.CalculateIntersections Method

ConnectionPoint.CalculateIntersections Method

Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool CalculateIntersections ()
Visual Basic

Public Overridable Function CalculateIntersections () As Boolean

Return Value

true to align the link end; otherwise, false.

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.CanMoveLink Method

ConnectionPoint.CanMoveLink Method

Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool CanMoveLink (
PointF pt
)
Visual Basic

Public Overridable Function CanMoveLink ( _
pt As PointF _
) As Boolean

Parameters

pt
The PointF to check for validity.

Return Value

true if the specified point represents a valid location for the connection point; otherwise, false.

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.GetAnchor Method (PointF, Boolean, Int32@)

ConnectionPoint.GetAnchor Method (PointF, Boolean, Int32@)
See Also

Returns the anchor point closest to the specified point from the node's asociated anchor pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual PointF GetAnchor (
PointF pt,
bool incoming,
ref int idx
)
Visual Basic

Public Overridable Function GetAnchor ( _
pt As PointF, _
incoming As Boolean, _
ByRef idx As Integer _
) As PointF

Parameters

pt
incoming
idx

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.GetAnchorPos Method

ConnectionPoint.GetAnchorPos Method

Overload List

Name | Description
ConnectionPoint.GetAnchorPos (Int32) | Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point.
ConnectionPoint.GetAnchorPos (Int32, PointF@) | Retrieves the point from the node's associated anchor pattern (if any) with the specified index.

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.GetAnchorPos Method (Int32)

ConnectionPoint.GetAnchorPos Method (Int32)
See Also

Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual PointF GetAnchorPos (
int anchorIdx
)
Visual Basic

Public Overridable Function GetAnchorPos ( _
anchorIdx As Integer _
) As PointF

Parameters

anchorIdx

Return Value

See Also

GetAnchorPos Method Overload List
ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.GetAnchorPos Method (Int32, PointF@)

ConnectionPoint.GetAnchorPos Method (Int32, PointF@)
See Also

Retrieves the point from the node's associated anchor pattern (if any) with the specified index.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool GetAnchorPos (
int anchorIdx,
ref PointF point
)
Visual Basic

Public Overridable Function GetAnchorPos ( _
anchorIdx As Integer, _
ByRef point As PointF _
) As Boolean

Parameters

anchorIdx
point

Return Value

See Also

GetAnchorPos Method Overload List
ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.GetClassId Method

ConnectionPoint.GetClassId Method

Returns unique id number for this class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual int GetClassId ()
Visual Basic

Protected Overridable Function GetClassId () As Integer

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.GetEndPoint Method

ConnectionPoint.GetEndPoint Method

Calculates the coordinates of the this connection point expressed in document coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual PointF GetEndPoint ()
Visual Basic

Public Overridable Function GetEndPoint () As PointF

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.GetInitialPoint Method

ConnectionPoint.GetInitialPoint Method

Returns a point (usually the center of the bounding rectangle) contained within the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual PointF GetInitialPoint ()
Visual Basic

Public Overridable Function GetInitialPoint () As PointF

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.GetIntersection Method

ConnectionPoint.GetIntersection Method

Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual PointF GetIntersection (
PointF pt1,
PointF pt2
)
Visual Basic

Public Overridable Function GetIntersection ( _
pt1 As PointF, _
pt2 As PointF _
) As PointF

Parameters

pt1
pt2

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.GetNodeRect Method

ConnectionPoint.GetNodeRect Method

Returns the bounding rectangle of the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual RectangleF GetNodeRect (
bool rotated
)
Visual Basic

Public Overridable Function GetNodeRect ( _
rotated As Boolean _
) As RectangleF

Parameters

rotated

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.LinkChanges Method

ConnectionPoint.LinkChanges Method

Checks whether the link would change if attached to the specified node at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool LinkChanges (
DiagramItem item,
PointF point
)
Visual Basic

Public Overridable Function LinkChanges ( _
item As DiagramItem, _
point As PointF _
) As Boolean

Parameters

item
point

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.LoadFrom Method

ConnectionPoint.LoadFrom Method

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext ctx
)
Visual Basic

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
ctx As PersistContext _
)

Parameters

reader
ctx

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.NodesIntersect Method

ConnectionPoint.NodesIntersect Method

Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool NodesIntersect (
ConnectionPoint connectionPoint
)
Visual Basic

Public Function NodesIntersect ( _
connectionPoint As ConnectionPoint _
) As Boolean

Parameters

connectionPoint

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.RemoveLinkFromNode Method

ConnectionPoint.RemoveLinkFromNode Method

Removes the link associated with this connection point from the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void RemoveLinkFromNode ()
Visual Basic

Public Overridable Sub RemoveLinkFromNode ()

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.SameNode Method

ConnectionPoint.SameNode Method

Checks whether the current connection point and the specified connection point are associated with the same node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool SameNode (
ConnectionPoint otherConnectionPoint
)
Visual Basic

Public Overridable Function SameNode ( _
otherConnectionPoint As ConnectionPoint _
) As Boolean

Parameters

otherConnectionPoint

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.SaveEndRelative Method

ConnectionPoint.SaveEndRelative Method

Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void SaveEndRelative ()
Visual Basic

Public Overridable Sub SaveEndRelative ()

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.SaveTo Method

ConnectionPoint.SaveTo Method

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext ctx
)
Visual Basic

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
ctx As PersistContext _
)

Parameters

writer
ctx

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.SetReference Method

ConnectionPoint.SetReference Method

Updates the reference to the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SetReference (
int refId,
Object obj
)
Visual Basic

Protected Overridable Sub SetReference ( _
refId As Integer, _
obj As Object _
)

Parameters

refId
obj

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.UpdateFromPoint Method

ConnectionPoint.UpdateFromPoint Method

Updates the connection stated according to the specified point, without changing the related node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void UpdateFromPoint (
PointF point
)
Visual Basic

Protected Overridable Sub UpdateFromPoint ( _
point As PointF _
)

Parameters

point

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint Properties

ConnectionPoint Properties

Public Properties

Name | Description
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents.

ProtectedProperties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.
Link | Gets the link associated with this connection point.
Node | Gets the node associated with this connection point.

See Also

ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.Incoming Property

ConnectionPoint.Incoming Property

Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected bool Incoming { get; }
Visual Basic

Protected ReadOnly Property Incoming As Boolean

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.Link Property

ConnectionPoint.Link Property

Gets the link associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected DiagramLink Link { get; }
Visual Basic

Protected ReadOnly Property Link As DiagramLink

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.Node Property

ConnectionPoint.Node Property

Gets the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual DiagramNode Node { get; }
Visual Basic

Protected Overridable ReadOnly Property Node As DiagramNode

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ConnectionPoint.RelativePosition Property

ConnectionPoint.RelativePosition Property

Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF RelativePosition { get; set; }
Visual Basic

Public Property RelativePosition As PointF

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants Class

Constants Class

Contains various global constants, also provides measure unit independent constants.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public sealed class Constants
Visual Basic

Public NotInheritable Class Constants

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Constants

See Also

Constants Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants Members

Constants Members
Fields Methods

Contains various global constants, also provides measure unit independent constants.

The following tables list the members exposed by the Constants type.

Public Fields

Name | Description
E | A very small positive real number (0.01).
IdentityMatrix | The identity matrix.
NoAnchorPattern | A constant indicating no anchor pattern during binary serialization.

Public Methods

Name | Description
GetAutoScroll | Gets the number of units to scroll the control during autoscrolling operation.
GetContainerFolderPadding | Gets the padding around the folding button of a container node.
GetExpandIconSize | Gets the size of the expand/collapse manipulator icon.
GetFitTextStep | Gets a value used when fitting the size of a node to its contained text.
GetHalfInch | Gets the size of a half inch.
GetInch | Gets the size of one inch.
GetInflation | Gets a relax value used when testing object intersections.
GetLineHitTest | Gets a value specifying relative distance from a link used during hit-testing operations.
GetMarkSize | Gets the size of an anchor point mark.
GetMillimeter | Gets the size of one millimeter.
GetMinArrowheadSize | Gets the minimum allowed size of an arrowhead.
GetMinItemSize | Gets the minimum size for a diagram node that can be achieved interactively.
GetPixel | Gets the size of one pixel.
GetReflHth | Gets the initial distance between adjacent control points of a reflexive link along the Y-axis.
GetReflWth2 | Gets the initial distance between adjacent control points of a reflexive link along the X-axis.
GetRoundRectArc | Gets the radius of the arc of the rounded rectangle node shape.
GetRouteGridSize | Gets the default size of the link routing grid.
GetScrollerWdt | Gets the width of the scroller manipulator icon.
GetSelPtTest | Gets a relax value used during selection handles hit-testing.
GetTableHeaderOffset | Gets the width of a header row icon.

See Also

Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants Fields

Constants Fields

Public Fields

Name | Description
E | A very small positive real number (0.01).
IdentityMatrix | The identity matrix.
NoAnchorPattern | A constant indicating no anchor pattern during binary serialization.

See Also

Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.E Field

Constants.E Field

A very small positive real number (0.01).

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float E
Visual Basic

Public Shared E As Single

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.IdentityMatrix Field

Constants.IdentityMatrix Field

The identity matrix.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Matrix IdentityMatrix
Visual Basic

Public Shared IdentityMatrix As Matrix

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.NoAnchorPattern Field

Constants.NoAnchorPattern Field

A constant indicating no anchor pattern during binary serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static int NoAnchorPattern
Visual Basic

Public Shared NoAnchorPattern As Integer

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants Methods

Constants Methods

Public Methods

Name | Description
GetAutoScroll | Gets the number of units to scroll the control during autoscrolling operation.
GetContainerFolderPadding | Gets the padding around the folding button of a container node.
GetExpandIconSize | Gets the size of the expand/collapse manipulator icon.
GetFitTextStep | Gets a value used when fitting the size of a node to its contained text.
GetHalfInch | Gets the size of a half inch.
GetInch | Gets the size of one inch.
GetInflation | Gets a relax value used when testing object intersections.
GetLineHitTest | Gets a value specifying relative distance from a link used during hit-testing operations.
GetMarkSize | Gets the size of an anchor point mark.
GetMillimeter | Gets the size of one millimeter.
GetMinArrowheadSize | Gets the minimum allowed size of an arrowhead.
GetMinItemSize | Gets the minimum size for a diagram node that can be achieved interactively.
GetPixel | Gets the size of one pixel.
GetReflHth | Gets the initial distance between adjacent control points of a reflexive link along the Y-axis.
GetReflWth2 | Gets the initial distance between adjacent control points of a reflexive link along the X-axis.
GetRoundRectArc | Gets the radius of the arc of the rounded rectangle node shape.
GetRouteGridSize | Gets the default size of the link routing grid.
GetScrollerWdt | Gets the width of the scroller manipulator icon.
GetSelPtTest | Gets a relax value used during selection handles hit-testing.
GetTableHeaderOffset | Gets the width of a header row icon.

See Also

Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetAutoScroll Method

Constants.GetAutoScroll Method

Gets the number of units to scroll the control during autoscrolling operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetAutoScroll (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetAutoScroll ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetContainerFolderPadding Method

Constants.GetContainerFolderPadding Method

Gets the padding around the folding button of a container node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetContainerFolderPadding (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetContainerFolderPadding ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetExpandIconSize Method

Constants.GetExpandIconSize Method

Gets the size of the expand/collapse manipulator icon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetExpandIconSize (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetExpandIconSize ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetFitTextStep Method

Constants.GetFitTextStep Method

Gets a value used when fitting the size of a node to its contained text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetFitTextStep (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetFitTextStep ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetHalfInch Method

Constants.GetHalfInch Method

Gets the size of a half inch.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetHalfInch (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetHalfInch ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetInch Method

Constants.GetInch Method

Gets the size of one inch.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetInch (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetInch ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetInflation Method

Constants.GetInflation Method

Gets a relax value used when testing object intersections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetInflation (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetInflation ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetLineHitTest Method

Constants.GetLineHitTest Method

Gets a value specifying relative distance from a link used during hit-testing operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetLineHitTest (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetLineHitTest ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetMarkSize Method

Constants.GetMarkSize Method

Gets the size of an anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetMarkSize (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetMarkSize ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetMillimeter Method

Constants.GetMillimeter Method

Gets the size of one millimeter.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetMillimeter (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetMillimeter ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetMinArrowheadSize Method

Constants.GetMinArrowheadSize Method

Gets the minimum allowed size of an arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetMinArrowheadSize (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetMinArrowheadSize ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetMinItemSize Method

Constants.GetMinItemSize Method

Gets the minimum size for a diagram node that can be achieved interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetMinItemSize (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetMinItemSize ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetPixel Method

Constants.GetPixel Method

Gets the size of one pixel.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetPixel (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetPixel ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetReflHth Method

Constants.GetReflHth Method

Gets the initial distance between adjacent control points of a reflexive link along the Y-axis.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetReflHth (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetReflHth ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetReflWth2 Method

Constants.GetReflWth2 Method

Gets the initial distance between adjacent control points of a reflexive link along the X-axis.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetReflWth2 (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetReflWth2 ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetRoundRectArc Method

Constants.GetRoundRectArc Method

Gets the radius of the arc of the rounded rectangle node shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetRoundRectArc (
GraphicsUnit currUnit,
float factor
)
Visual Basic

Public Shared Function GetRoundRectArc ( _
currUnit As GraphicsUnit, _
factor As Single _
) As Single

Parameters

currUnit
factor

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetRouteGridSize Method

Constants.GetRouteGridSize Method

Gets the default size of the link routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetRouteGridSize (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetRouteGridSize ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetScrollerWdt Method

Constants.GetScrollerWdt Method

Gets the width of the scroller manipulator icon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetScrollerWdt (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetScrollerWdt ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetSelPtTest Method

Constants.GetSelPtTest Method

Gets a relax value used during selection handles hit-testing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetSelPtTest (
GraphicsUnit currUnit
)
Visual Basic

Public Shared Function GetSelPtTest ( _
currUnit As GraphicsUnit _
) As Single

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Constants.GetTableHeaderOffset Method

Constants.GetTableHeaderOffset Method

Gets the width of a header row icon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float GetTableHeaderOffset (
GraphicsUnit unit
)
Visual Basic

Public Shared Function GetTableHeaderOffset ( _
unit As GraphicsUnit _
) As Single

Parameters

unit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerChildEventArgs Class

ContainerChildEventArgs Class

Contains arguments passed to ContainerChildEventHandler,

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ContainerChildEventArgs : NodeEventArgs
Visual Basic

Public Class ContainerChildEventArgs
Inherits NodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeEventArgs
MindFusion.Diagramming.ContainerChildEventArgs

See Also

ContainerChildEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerChildEventArgs Members

ContainerChildEventArgs Members
Constructors Properties Methods

Contains arguments passed to ContainerChildEventHandler,

The following tables list the members exposed by the ContainerChildEventArgs type.

Public Constructors

Name | Description
ContainerChildEventArgs | Initializes a new instance of the ContainerChildEventArgs class.

Public Properties

Name | Description
Container | Refers to the container related to the event.

Public Methods

Name | Description
ToString | NodeEventArgs.ToString override.

See Also

ContainerChildEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerChildEventArgs Constructor

ContainerChildEventArgs Constructor

Initializes a new instance of the ContainerChildEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerChildEventArgs (
ContainerNode container,
DiagramNode node
)
Visual Basic

Public Sub ContainerChildEventArgs ( _
container As ContainerNode, _
node As DiagramNode _
)

Parameters

container
A ContainerNode object related to the event.
node
A DiagramNode added to or removed from the container.

See Also

ContainerChildEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerChildEventArgs Methods

ContainerChildEventArgs Methods

Public Methods

Name | Description
ToString | NodeEventArgs.ToString override.

See Also

ContainerChildEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerChildEventArgs.ToString Method

ContainerChildEventArgs.ToString Method

NodeEventArgs.ToString override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

See Also

ContainerChildEventArgs Members
ContainerChildEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerChildEventArgs Properties

ContainerChildEventArgs Properties

Public Properties

Name | Description
Container | Refers to the container related to the event.

See Also

ContainerChildEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerChildEventArgs.Container Property

ContainerChildEventArgs.Container Property

Refers to the container related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNode Container { get; set; }
Visual Basic

Public Property Container As ContainerNode

Property Value

An instance of the ContainerNode class.

See Also

ContainerChildEventArgs Members
ContainerChildEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerChildEventHandler Delegate

ContainerChildEventHandler Delegate

Represents methods that will handle ContainerChildAdded, ContainerChildRemoved events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void ContainerChildEventHandler (
Object sender,
ContainerChildEventArgs e
)
Visual Basic

Public Delegate Sub ContainerChildEventHandler ( _
sender As Object, _
e As ContainerChildEventArgs _
)

Parameters

sender
The source of the event.
e
A ContainerChildEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode Class

ContainerNode Class
Remarks See Also

Represents a diagram node that can contain other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ContainerNode : DiagramNode, InplaceEditable
Visual Basic

Public Class ContainerNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

Users can drag nodes into a container interactively. When a dragged node is over a container, the container frame is painted using the HighlightPen property to indicate that the node would be added to the container.

Use the Add method to add a node to container programmatically. Use the Remove method to remove a node from the container. The GetContainer static method returns the container that contains a node.

AutoShrink specifies whether the size of a container should shrink when a node is removed from it. The container node will not shrink to a size smaller than MinimumSize, even if it does not contain any items.

A container node can be folded and unfolded, either interactively or programmatically, as specified through the Foldable and Folded properties. When a container is folded, it occupies a minimal area and its child nodes are hidden. You can get the original size of a folded container using the UnfoldedSize property.

The Caption property specifies the caption text of a container node, and CaptionColor specifies its color. Use the CaptionFormat property to define the alignment and position of the caption text. The height of the caption area of a container can be set using the CaptionHeight property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.ContainerNode

See Also

ContainerNode Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode Members

ContainerNode Members
Constructors Properties Methods

Represents a diagram node that can contain other nodes.

The following tables list the members exposed by the ContainerNode type.

Public Constructors

Name | Description
ContainerNode | Overloaded. Initializes a new instance of the ContainerNode class.

Public Properties

Name | Description
AutoShrink | Gets or sets a value indicating whether the container should shrink in size when nodes are removed from it.
Caption | Gets or sets the container caption text.
CaptionColor | Gets or sets the color of the container's caption text.
CaptionFormat | Gets or sets the caption alignment and format.
CaptionHeight | Gets or sets the height of the container's caption area.
Foldable | Gets or sets a value indicating whether the user is allowed to fold this container.
Folded | Gets or sets a value indicating whether this container is folded.
HighlightPen | Gets or sets the pen used to draw the container frame lines when an item is dragged over the container.
Margin | Gets or sets how much space should be left between contained nodes and the container borders.
MinimumSize | Gets or sets the minimum size of the container.
UnfoldedSize | Returns the original size of a folded container.
Visible | Gets or sets a value indicating whether the container is visible.

Public Methods

Name | Description
Add | Adds a node to this container.
ContainsRecursively | Determines whether this container contains the specified node, either directly or recursively through other containers.
Draw | Draws the container on the specified IGraphics surface.
DrawShadow | Draws the shadow of this container on the specified IGraphics surface.
GetContainer | Retrieves the container node (if any) the specified node belongs to.
HitTestHandle | DiagramNode.HitTestHandle override.
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
Remove | Removes a node from this container.
UpdateBounds | Updates the container bounds to fit its contents.

Protected Methods

Name | Description
CreateProperties | DiagramItem.CreateProperties override.
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
OnChildModified | Called when a group child node has been modified.
RestoreProperties | DiagramNode.RestoreProperties override.
SaveProperties | DiagramNode.SaveProperties override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetReference | DiagramNode.SetReference override.

See Also

ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode Constructor

ContainerNode Constructor

Initializes a new instance of the ContainerNode class.

Overload List

Name | Description
ContainerNode () | Initializes a new instance of the ContainerNode class.
ContainerNode (ContainerNode) | Initializes a new instance of the ContainerNode class using the specified node as a prototype.
ContainerNode (Diagram) | Initializes a new instance of the ContainerNode class with the default values of the specified diagram.

See Also

ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode Constructor ()

ContainerNode Constructor ()
See Also

Initializes a new instance of the ContainerNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNode ()
Visual Basic

Public Sub New ()

See Also

ContainerNode Constructor Overload List
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode Constructor (ContainerNode)

ContainerNode Constructor (ContainerNode)
See Also

Initializes a new instance of the ContainerNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNode (
ContainerNode prototype
)
Visual Basic

Public Sub ContainerNode ( _
prototype As ContainerNode _
)

Parameters

prototype

See Also

ContainerNode Constructor Overload List
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode Constructor (Diagram)

ContainerNode Constructor (Diagram)
See Also

Initializes a new instance of the ContainerNode class with the default values of the specified diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNode (
Diagram parent
)
Visual Basic

Public Sub ContainerNode ( _
parent As Diagram _
)

Parameters

parent

See Also

ContainerNode Constructor Overload List
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode Methods

ContainerNode Methods

Public Methods

Name | Description
Add | Adds a node to this container.
ContainsRecursively | Determines whether this container contains the specified node, either directly or recursively through other containers.
Draw | Draws the container on the specified IGraphics surface.
DrawShadow | Draws the shadow of this container on the specified IGraphics surface.
GetContainer | Retrieves the container node (if any) the specified node belongs to.
HitTestHandle | DiagramNode.HitTestHandle override.
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
Remove | Removes a node from this container.
UpdateBounds | Updates the container bounds to fit its contents.

Protected Methods

Name | Description
CreateProperties | DiagramItem.CreateProperties override.
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
OnChildModified | Called when a group child node has been modified.
RestoreProperties | DiagramNode.RestoreProperties override.
SaveProperties | DiagramNode.SaveProperties override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetReference | DiagramNode.SetReference override.

See Also

ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.Add Method

ContainerNode.Add Method

Adds a node to this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Add (
DiagramNode node
)
Visual Basic

Public Sub Add ( _
node As DiagramNode _
)

Parameters

node
The DiagramNode that will be added to the container.

Remarks

If the container bounds do not include the specified node bounds, the container will grow automatically to accommodate the new node.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
Remove Method


MindFusion.Diagramming.ContainerNode.ContainsRecursively Method

ContainerNode.ContainsRecursively Method

Determines whether this container contains the specified node, either directly or recursively through other containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ContainsRecursively (
DiagramNode node
)
Visual Basic

Public Function ContainsRecursively ( _
node As DiagramNode _
) As Boolean

Parameters

node
The DiagramNode to check.

Return Value

true if this container contains the node; otherwise, false.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.CreateProperties Method

ContainerNode.CreateProperties Method

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual DiagramItemProperties CreateProperties ()
Visual Basic

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

An instance of the DiagramItemProperties class.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.Draw Method

ContainerNode.Draw Method

Draws the container on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void Draw (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public Overrides Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
An IGraphics object where the node should be rendered.
options
Provides options for the drawing operation.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.DrawShadow Method

ContainerNode.DrawShadow Method

Draws the shadow of this container on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void DrawShadow (
IGraphics graphics,
 RenderOptions options
)
Visual Basic

Public Overrides Sub DrawShadow ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
The IGraphics surface to draw the shadow on.
options
A RenderOptions object specifying options for the drawing operation.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.GetContainer Method

ContainerNode.GetContainer Method

Retrieves the container node (if any) the specified node belongs to.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static ContainerNode GetContainer (
DiagramNode node
)
Visual Basic

Public Shared Function GetContainer ( _
node As DiagramNode _
) As ContainerNode

Parameters

node
The DiagramNode whose container you need to find.

Return Value

A ContainerNode that contains the specified node, or null (Nothing in Visual Basic) if the node is not contained.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.HitTestHandle Method

ContainerNode.HitTestHandle Method

DiagramNode.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool HitTestHandle (
PointF pt,
ref int handle
)
Visual Basic

Public Overrides Function HitTestHandle ( _
pt As PointF, _
ByRef handle As Integer _
) As Boolean

Parameters

pt
A PointF value specifying where to look for a selection handle.
handle
A reference to an integer variable, which receives the index of the found selection handle.

Return Value

true if there is a selection handle at the specified location; otherwise, false.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.LoadFrom Method

ContainerNode.LoadFrom Method

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)
Visual Basic

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the item's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.LoadFromXml Method

ContainerNode.LoadFromXml Method

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.OnChildModified Method

ContainerNode.OnChildModified Method

Called when a group child node has been modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnChildModified (
DiagramNode node,
AdjustmentHandles handle
)
Visual Basic

Protected Overridable Sub OnChildModified ( _
node As DiagramNode, _
handle As AdjustmentHandles _
)

Parameters

node
The DiagramNode that has been moved or resized.
handle
The adjustment handle used to modify the node.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.OnDragOut Method

ContainerNode.OnDragOut Method

Invoked when a diagram item is being dragged out of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void OnDragOut (
DiagramItem item
)
Visual Basic

Public Overrides Sub OnDragOut ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem being dragged.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.OnDragOver Method

ContainerNode.OnDragOver Method

Invoked when a diagram item is being dragged over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool OnDragOver (
DiagramItem item
)
Visual Basic

Public Overrides Function OnDragOver ( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem being dragged.

Return Value

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.OnDropOver Method

ContainerNode.OnDropOver Method

Invoked when a diagram item is dropped over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool OnDropOver (
DiagramItem item
)
Visual Basic

Public Overrides Function OnDropOver ( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem being dragged.

Return Value

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.Remove Method

ContainerNode.Remove Method

Removes a node from this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Remove (
DiagramNode node
)
Visual Basic

Public Sub Remove ( _
node As DiagramNode _
)

Parameters

node
The DiagramNode that should be removed from the container.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
Add Method


MindFusion.Diagramming.ContainerNode.RestoreProperties Method

ContainerNode.RestoreProperties Method

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void RestoreProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.SaveProperties Method

ContainerNode.SaveProperties Method

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object where the item's properties should be saved.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.SaveTo Method

ContainerNode.SaveTo Method

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)
Visual Basic

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the item's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.SaveToXml Method

ContainerNode.SaveToXml Method

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.SetReference Method

ContainerNode.SetReference Method

DiagramNode.SetReference override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SetReference (
int refId,
Object obj,
PersistContext context
)
Visual Basic

Protected Overridable Sub SetReference ( _
refId As Integer, _
obj As Object, _
context As PersistContext _
)

Parameters

refId
obj
context

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.UpdateBounds Method

ContainerNode.UpdateBounds Method

Updates the container bounds to fit its contents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void UpdateBounds ()
Visual Basic

Public Sub UpdateBounds ()

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode Properties

ContainerNode Properties

Public Properties

Name | Description
AutoShrink | Gets or sets a value indicating whether the container should shrink in size when nodes are removed from it.
Caption | Gets or sets the container caption text.
CaptionColor | Gets or sets the color of the container's caption text.
CaptionFormat | Gets or sets the caption alignment and format.
CaptionHeight | Gets or sets the height of the container's caption area.
Foldable | Gets or sets a value indicating whether the user is allowed to fold this container.
Folded | Gets or sets a value indicating whether this container is folded.
HighlightPen | Gets or sets the pen used to draw the container frame lines when an item is dragged over the container.
Margin | Gets or sets how much space should be left between contained nodes and the container borders.
MinimumSize | Gets or sets the minimum size of the container.
UnfoldedSize | Returns the original size of a folded container.
Visible | Gets or sets a value indicating whether the container is visible.

See Also

ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.AutoShrink Property

ContainerNode.AutoShrink Property

Gets or sets a value indicating whether the container should shrink in size when nodes are removed from it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AutoShrink { get; set; }
Visual Basic

Public Property AutoShrink As Boolean

Property Value

true if the container should shrink automatically; otherwise, false. The default is false.

Remarks

The container won't shrink to a size smaller than MinimumSize.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.Caption Property

ContainerNode.Caption Property

Gets or sets the container caption text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string Caption { get; set; }
Visual Basic

Public Property Caption As String

Property Value

A string containing the container's caption text.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
CaptionColor Property
CaptionFormat Property
CaptionHeight Property


MindFusion.Diagramming.ContainerNode.CaptionColor Property

ContainerNode.CaptionColor Property

Gets or sets the color of the container's caption text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color CaptionColor { get; set; }
Visual Basic

Public Property CaptionColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.Black.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
Caption Property
CaptionHeight Property
CaptionFormat Property


MindFusion.Diagramming.ContainerNode.CaptionFormat Property

ContainerNode.CaptionFormat Property

Gets or sets the caption alignment and format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public StringFormat CaptionFormat { get; set; }
Visual Basic

Public Property CaptionFormat As StringFormat

Property Value

An instance of the .NET StringFormat class.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
Caption Property
CaptionHeight Property


MindFusion.Diagramming.ContainerNode.CaptionHeight Property

ContainerNode.CaptionHeight Property

Gets or sets the height of the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float CaptionHeight { get; set; }
Visual Basic

Public Property CaptionHeight As Single

Property Value

A string value specifying the container's caption text. Initialized with the value of ContainerCaption.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
CaptionFormat Property
Caption Property


MindFusion.Diagramming.ContainerNode.Foldable Property

ContainerNode.Foldable Property

Gets or sets a value indicating whether the user is allowed to fold this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Foldable { get; set; }
Visual Basic

Public Property Foldable As Boolean

Property Value

true if the container can be folded; otherwise, false. Initialized with the value of ContainersFoldable.

Remarks

A foldable container can be folded and unfolded by clicking the up/down arrow displayed in the caption area.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
Folded Property


MindFusion.Diagramming.ContainerNode.Folded Property

ContainerNode.Folded Property

Gets or sets a value indicating whether this container is folded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Folded { get; set; }
Visual Basic

Public Property Folded As Boolean

Property Value

true if the container is folded; otherwise, false. The default is false.

Remarks

When folded, the container children are not visible, and only its caption bar is displayed.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
Foldable Property


MindFusion.Diagramming.ContainerNode.HighlightPen Property

ContainerNode.HighlightPen Property

Gets or sets the pen used to draw the container frame lines when an item is dragged over the container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Pen HighlightPen { get; set; }
Visual Basic

Public Property HighlightPen As Pen

Property Value

An instance of the Pen class. Initialized with the value of ContainerHighlightPen.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.Margin Property

ContainerNode.Margin Property

Gets or sets how much space should be left between contained nodes and the container borders.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float Margin { get; set; }
Visual Basic

Public Property Margin As Single

Property Value

A float value specifying the margin size. Initialized with the value of ContainerMargin.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
AutoShrink Property


MindFusion.Diagramming.ContainerNode.MinimumSize Property

ContainerNode.MinimumSize Property

Gets or sets the minimum size of the container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeF MinimumSize { get; set; }
Visual Basic

Public Property MinimumSize As SizeF

Property Value

A .NET SizeF object specifying the minimum size. Initialized with the value of ContainerMinimumSize.

Remarks

The container won't shrink smaller than that size, even if it does not contain any items.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace
AutoShrink Property


MindFusion.Diagramming.ContainerNode.UnfoldedSize Property

ContainerNode.UnfoldedSize Property

Returns the original size of a folded container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeF UnfoldedSize { get; }
Visual Basic

Public ReadOnly Property UnfoldedSize As SizeF

Property Value

A SizeF instance containing the original size of the container.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNode.Visible Property

ContainerNode.Visible Property

Gets or sets a value indicating whether the container is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool Visible { get; set; }
Visual Basic

Public Overrides Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNodeProperties Class

ContainerNodeProperties Class
Remarks See Also

Stores the values of ContainerNode properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ContainerNodeProperties : DiagramNodeProperties
Visual Basic

Public Class ContainerNodeProperties
Inherits DiagramNodeProperties

Remarks

If you need to implement undo support for the additional properties defined by a class derived from ContainerNode, do so by deriving from ContainerNodeProperties and overriding the SaveProperties, RestoreProperties, and CreateProperties methods of ContainerNode.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.ContainerNodeProperties

See Also

ContainerNodeProperties Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNodeProperties Members

ContainerNodeProperties Members
Constructors Fields

Stores the values of ContainerNode properties during undo / redo operations.

The following tables list the members exposed by the ContainerNodeProperties type.

Public Constructors

Name | Description
ContainerNodeProperties | Initializes a new instance of the ContainerNodeProperties class.

Public Fields

Name | Description
Caption | For internal use.
CaptionColor | For internal use.
CaptionHeight | For internal use.
Margin | For internal use.

See Also

ContainerNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNodeProperties Fields

ContainerNodeProperties Fields

Public Fields

Name | Description
Caption | For internal use.
CaptionColor | For internal use.
CaptionHeight | For internal use.
Margin | For internal use.

See Also

ContainerNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNodeProperties.Caption Field

ContainerNodeProperties.Caption Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string Caption
Visual Basic

Public Caption As String

See Also

ContainerNodeProperties Members
ContainerNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNodeProperties.CaptionColor Field

ContainerNodeProperties.CaptionColor Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color CaptionColor
Visual Basic

Public CaptionColor As Color

See Also

ContainerNodeProperties Members
ContainerNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNodeProperties.CaptionHeight Field

ContainerNodeProperties.CaptionHeight Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float CaptionHeight
Visual Basic

Public CaptionHeight As Single

See Also

ContainerNodeProperties Members
ContainerNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNodeProperties.Margin Field

ContainerNodeProperties.Margin Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float Margin
Visual Basic

Public Margin As Single

See Also

ContainerNodeProperties Members
ContainerNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainerNodeProperties Constructor

ContainerNodeProperties Constructor

Initializes a new instance of the ContainerNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNodeProperties ()
Visual Basic

Public Sub New ()

See Also

ContainerNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ContainmentKeys Enumeration

ContainmentKeys Enumeration

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum ContainmentKeys
Visual Basic

Public Enumeration ContainmentKeys

Members

Member name | Description
InContainer | Set for Group.Attachment objects for nodes in a container.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.ControlMouseAction Enumeration

ControlMouseAction Enumeration

Specifies available ways to handle mouse clicks on .NET controls hosted in a ControlNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum ControlMouseAction
Visual Basic

Public Enumeration ControlMouseAction

Members

Member name | Description
IgnoreControl | MindFusion.Diagramming tries to intercept the mouse message and not pass it to the control. That allows drawing links from anywhere within the control.
PassToControl | Let the control handle the mouse click. Do not select the host node.
SelectNode | The host node gets selected when the control is clicked. The control is left to handle the mouse click too.

Remarks

IgnoreControl works only with controls that do not capture the mouse.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter Class

Converter Class

Provides capabilities to convert various types to and from strings in a culture-independent way.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public sealed class Converter
Visual Basic

Public NotInheritable Class Converter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Converter

See Also

Converter Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter Members

Converter Members
Methods

Provides capabilities to convert various types to and from strings in a culture-independent way.

The following tables list the members exposed by the Converter type.

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromImageV4 | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
ImageFromString | Converts the specified string value to image.
ToBoolean | Converts the specified string value to bool.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specifed string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToImageV4 | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded. Converts a string value to 32-bit integer.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter Methods

Converter Methods

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromImageV4 | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
ImageFromString | Converts the specified string value to image.
ToBoolean | Converts the specified string value to bool.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specifed string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToImageV4 | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded. Converts a string value to 32-bit integer.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromBoolean Method

Converter.FromBoolean Method

Converts the specified bool value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromBoolean (
bool val
)
Visual Basic

Public Shared Function FromBoolean ( _
val As Boolean _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromByte Method

Converter.FromByte Method

Converts the specified byte value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromByte (
byte val
)
Visual Basic

Public Shared Function FromByte ( _
val As Byte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromChar Method

Converter.FromChar Method

Converts the specified char value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromChar (
char val
)
Visual Basic

Public Shared Function FromChar ( _
val As Char _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromColor Method

Converter.FromColor Method

Converts the specified color value to string in the format #AARRGGBB.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromColor (
Color val
)
Visual Basic

Public Shared Function FromColor ( _
val As Color _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromDecimal Method

Converter.FromDecimal Method

Converts the specified decimal to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromDecimal (
Decimal val
)
Visual Basic

Public Shared Function FromDecimal ( _
val As Decimal _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromDouble Method

Converter.FromDouble Method

Converts the specified double value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromDouble (
double val
)
Visual Basic

Public Shared Function FromDouble ( _
val As Double _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromEnum Method

Converter.FromEnum Method

Converts the specified enum value to a string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromEnum (
Object val
)
Visual Basic

Public Shared Function FromEnum ( _
val As Object _
) As String

Parameters

val
The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromImage Method

Converter.FromImage Method

Converts the specified image to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromImage (
Image val
)
Visual Basic

Public Shared Function FromImage ( _
val As Image _
) As String

Parameters

val

The Image object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromImageV4 Method

Converter.FromImageV4 Method

Converts the specified image to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromImageV4 (
Image val
)
Visual Basic

Public Shared Function FromImageV4 ( _
val As Image _
) As String

Parameters

val

The Image object to convert.

Return Value

A string representing the specified value.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromInt16 Method

Converter.FromInt16 Method

Converts the specified 16-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromInt16 (
short val
)
Visual Basic

Public Shared Function FromInt16 ( _
val As Short _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromInt32 Method

Converter.FromInt32 Method

Converts the specified 32-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromInt32 (
int val
)
Visual Basic

Public Shared Function FromInt32 ( _
val As Integer _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromInt64 Method

Converter.FromInt64 Method

Converts the specified 64-bit integer to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromInt64 (
long val
)
Visual Basic

Public Shared Function FromInt64 ( _
val As Long _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromSByte Method

Converter.FromSByte Method

Converts the specified 8-bit signed integer to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromSByte (
sbyte val
)
Visual Basic

Public Shared Function FromSByte ( _
val As SByte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromSingle Method

Converter.FromSingle Method

Converts the specified float value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromSingle (
float val
)
Visual Basic

Public Shared Function FromSingle ( _
val As Single _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromStream Method

Converter.FromStream Method

Converts the specified stream to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromStream (
Stream val
)
Visual Basic

Public Shared Function FromStream ( _
val As Stream _
) As String

Parameters

val
The Stream object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromStreamV4 Method

Converter.FromStreamV4 Method

Converts the specified memory stream to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromStreamV4 (
MemoryStream val
)
Visual Basic

Public Shared Function FromStreamV4 ( _
val As MemoryStream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromUInt16 Method

Converter.FromUInt16 Method

Converts the specified unsigned 16-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromUInt16 (
ushort val
)
Visual Basic

Public Shared Function FromUInt16 ( _
val As UShort _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromUInt32 Method

Converter.FromUInt32 Method

Converts the specified unsigned 32-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromUInt32 (
uint val
)
Visual Basic

Public Shared Function FromUInt32 ( _
val As UInteger _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.FromUInt64 Method

Converter.FromUInt64 Method

Converts the specified unsigned 64-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FromUInt64 (
ulong val
)
Visual Basic

Public Shared Function FromUInt64 ( _
val As ULong _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ImageFromString Method

Converter.ImageFromString Method

Converts the specified string value to image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Image ImageFromString (
string s
)
Visual Basic

Public Shared Function ImageFromString ( _
s As String _
) As Image

Parameters

s

The string value to convert from.

Return Value

An instance of the .NET Image class that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToBoolean Method

Converter.ToBoolean Method

Converts the specified string value to bool.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static bool ToBoolean (
string s
)
Visual Basic

Public Shared Function ToBoolean ( _
s As String _
) As Boolean

Parameters

s

The string value to convert from.

Return Value

A boolean value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToByte Method

Converter.ToByte Method

Converts the specified string value to byte value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static byte ToByte (
string s
)
Visual Basic

Public Shared Function ToByte ( _
s As String _
) As Byte

Parameters

s

The string value to convert from.

Return Value

A byte value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToChar Method

Converter.ToChar Method

Converts the specified string value to char.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static char ToChar (
string s
)
Visual Basic

Public Shared Function ToChar ( _
s As String _
) As Char

Parameters

s

The string value to convert from.

Return Value

A char value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToColor Method

Converter.ToColor Method

Converts the specified string value to Color.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Color ToColor (
string s
)
Visual Basic

Public Shared Function ToColor ( _
s As String _
) As Color

Parameters

s

The string value to convert from.

Return Value

A Color value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToDecimal Method

Converter.ToDecimal Method

Converts the specified string value to decimal.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Decimal ToDecimal (
string s
)
Visual Basic

Public Shared Function ToDecimal ( _
s As String _
) As Decimal

Parameters

s

The string value to convert from.

Return Value

A decimal value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToDouble Method

Converter.ToDouble Method

Converts the specifed string value to double.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static double ToDouble (
string s
)
Visual Basic

Public Shared Function ToDouble ( _
s As String _
) As Double

Parameters

s

The string value to convert from.

Return Value

A double value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToEnum Method

Converter.ToEnum Method

Converts the specified string value to its corresponding enumeration member of the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Object ToEnum (
Type type,
string s
)
Visual Basic

Public Shared Function ToEnum ( _
type As Type, _
s As String _
) As Object

Parameters

type

The type of the enumeration to convert to.

s

The string value to convert from.

Return Value

A member of the specified enumeration that is deserialized from the specified string, possibly a null reference (Nothing in Visual Basic) if the deserialization failed.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToImage Method

Converter.ToImage Method

Converts the specified string value to image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Image ToImage (
string s
)
Visual Basic

Public Shared Function ToImage ( _
s As String _
) As Image

Parameters

s

The string value to convert from.

Return Value

A .NET Image object that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToImageV4 Method

Converter.ToImageV4 Method

Converts the specified string value to image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Image ToImageV4 (
string s
)
Visual Basic

Public Shared Function ToImageV4 ( _
s As String _
) As Image

Parameters

s

The string value to convert from.

Return Value

A .NET Image object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToInt16 Method

Converter.ToInt16 Method

Converts the specified string value to 16-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static short ToInt16 (
string s
)
Visual Basic

Public Shared Function ToInt16 ( _
s As String _
) As Short

Parameters

s

The string value to convert from.

Return Value

A 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToInt32 Method

Converter.ToInt32 Method

Converts a string value to 32-bit integer.

Overload List

Name | Description
Converter.ToInt32 (String) | Converts the specified string value to 32-bit integer.
Converter.ToInt32 (String, Int32) | Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToInt32 Method (String)

Converter.ToInt32 Method (String)
See Also

Converts the specified string value to 32-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static int ToInt32 (
string s
)
Visual Basic

Public Shared Function ToInt32 ( _
s As String _
) As Integer

Parameters

s

The string value to convert from.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToInt32 Method (String, Int32)

Converter.ToInt32 Method (String, Int32)
See Also

Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static int ToInt32 (
string s,
int defaultValue
)
Visual Basic

Public Shared Function ToInt32 ( _
s As String, _
defaultValue As Integer _
) As Integer

Parameters

s

The string value to convert from.

defaultValue

The default value to return if s cannot be deserialized.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToInt64 Method

Converter.ToInt64 Method

Converts the specified string value to 64-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static long ToInt64 (
string s
)
Visual Basic

Public Shared Function ToInt64 ( _
s As String _
) As Long

Parameters

s

The string value to convert from.

Return Value

A 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToSByte Method

Converter.ToSByte Method

Converts the specified string value to 8-bit signed integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static sbyte ToSByte (
string s
)
Visual Basic

Public Shared Function ToSByte ( _
s As String _
) As SByte

Parameters

s

The string value to convert from.

Return Value

An 8-bit signed integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToSingle Method

Converter.ToSingle Method

Converts the specified string value to float.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float ToSingle (
string s
)
Visual Basic

Public Shared Function ToSingle ( _
s As String _
) As Single

Parameters

s

The string value to convert from.

Return Value

A float value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToStream Method

Converter.ToStream Method

Converts the specified string value to stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Stream ToStream (
string s
)
Visual Basic

Public Shared Function ToStream ( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET Stream object that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToStreamV4 Method

Converter.ToStreamV4 Method

Converts the specified string value to stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Stream ToStreamV4 (
string s
)
Visual Basic

Public Shared Function ToStreamV4 ( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET Stream object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToUint16 Method

Converter.ToUint16 Method

Converts the specified string value to unsigned 16-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static ushort ToUint16 (
string s
)
Visual Basic

Public Shared Function ToUint16 ( _
s As String _
) As UShort

Parameters

s

The string value to convert from.

Return Value

An unsigned 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToUint32 Method

Converter.ToUint32 Method

Converts the specified string value to unsigned 32-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static uint ToUint32 (
string s
)
Visual Basic

Public Shared Function ToUint32 ( _
s As String _
) As UInteger

Parameters

s

The string value to convert from.

Return Value

An unsigned 32-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Converter.ToUint64 Method

Converter.ToUint64 Method

Converts the specified string value to unsigned 64-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static ulong ToUint64 (
string s
)
Visual Basic

Public Shared Function ToUint64 ( _
s As String _
) As ULong

Parameters

s

The string value to convert from.

Return Value

An unsigned 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.CursorHint Enumeration

CursorHint Enumeration

Specifies what mouse cursor to display while a user interacts with the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum CursorHint
Visual Basic

Public Enumeration CursorHint

Members

Member name | Description
AllowLink | Indicates the cursor specified by the AllowLinkCursor property.
CounterDiagonalResize | Indicates the cursor specified by the CounterDiagonalResizeCursor property.
DiagonalResize | Indicates the cursor specified by the DiagonalResizeCursor property.
Disallow | Indicates the cursor specified by the DisallowCursor property.
DisallowLink | Indicates the cursor specified by the DisallowLinkCursor property.
DontChange | Indicates the cursor specified by the Cursor property.
DrawLink | Indicates the cursor specified by the DrawLinkCursor property.
HorizontalResize | Indicates the cursor specified by the HorizontalResizeCursor property.
Move | Indicates the cursor specified by the MoveCursor property.
Pointer | Indicates the cursor specified by the PointerCursor property.
Rotate | Indicates the cursor specified by the RotateCursor property.
VerticalResize | Indicates the cursor specified by the VerticalResizeCursor property.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.CustomDraw Enumeration

CustomDraw Enumeration

Specifies what kind of custom painting to perform on diagram elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum CustomDraw
Visual Basic

Public Enumeration CustomDraw

Members

Member name | Description
Additional | The custom painting code executes after item's interior and frame are painted by MindFusion.Diagramming, but before text is rendered. In this mode, the Graphics instance passed to the custom drawing event handler has a clipping region applied to it.
Additional2 | The custom painting code executes after all parts of an item are painted by MindFusion.Diagramming. In this mode, the Graphics instance passed to the custom drawing event handler doesn't have a clipping region applied to it.
Full | The component does not do any standard drawing, the entire painting of an item is done by the application.
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming.
ShadowOnly | Only the shadow of an item is painted by custom code, the item itself is drawn by the component.

Remarks

These values can be assigned to the CustomDraw property of shapes, tables and links.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.DelKeyAction Enumeration

DelKeyAction Enumeration

Specifies the type of action performed when the user presses the DEL key.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum DelKeyAction
Visual Basic

Public Enumeration DelKeyAction

Members

Member name | Description
DeleteActiveItem | Indicates that only the ActiveItem is deleted.
DeleteSelectedItems | Indicates that all selected items are deleted.
None | Indicates that nothing happens.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram Class

Diagram Class
Remarks See Also

Represents a flow diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class Diagram : Component, IItemFactory, IPersists
Visual Basic

Public Class Diagram
Inherits Component
Implements IItemFactory, IPersists

Remarks

An instance of the Diagram class represents a diagram document. A Diagram instance does not provide its own user interface. To display a diagram on a form, add a DiagramView instance to the form and set the view's Diagram property. A diagram can be displayed in more than one view.

A diagram can contain connected nodes and links. Nodes are instances of DiagramNode-derived classes. Nodes are stored in the Nodes collection. Links in MindFusion.Diagramming are instances of the DiagramLink class and are stored in the Links collection. Diagram items can be grouped in hierarchical structures and the so formed groups can be accessed by means of the Groups collection.

Managing Items

Items can be created by using the new operator and added to the diagram by means of the Add method of the Nodes or Links collection. Items are deleted by using the Remove method of the respective collection. There are shortcut methods provided by the diagram's Factory object that can be used to create an item and add it to the diagram with just one method call. Use the CreateTableNode, CreateShapeNode and CreateDiagramLink factory methods to create new items of the respective type.

Hierarchical groups of items are created by adding a Group instance to the diagram's Groups collection. The Factory object provides a shortcut CreateGroup method to do that with a single method call. Use the Remove method of the Groups collection to destroy a group.

Searching for a particular kind of items is done with the FindLink, FindNode and FindGroup methods, which look for an item that has a particular Tag. To get the item placed at a certain location, use the GetItemAt method.

Serialization

Binary serialization of diagrams is provided by the SaveToStream and LoadFromStream methods which serialize diagrams to / from .NET streams. SaveToFile and LoadFromFile wrap their stream counterparts to implement easy serialization to disk files. SaveToString and LoadFromString store or load diagrams to/from ASCII strings, allowing easy storage of whole diagrams in a database or their transfer between a web-server and a browser through a hidden html element.

Use the SaveToXml and LoadFromXml methods to serialize a diagram into/from XML documents.

Controlling Users' Actions

Most aspects of user interaction are controlled by the DiagramView class.

Users actions can be validated by handling various events, fired while items are being created, modified or deleted.

The following properties control what kind of links users can create: AllowLinksRepeat, AllowSelfLoops, AllowUnanchoredLinks, AllowUnconnectedLinks.

The order in which items are hit-tested when clicking on them depends on the value of HitTestPriority. The LinkHitDistance property specifies the furthest distance from a link that a click would be still considered a hit.

Appearance

The Diagram background area can be painted using a solid, gradient, texture or color brush, by setting the BackBrush property, and/or using an image specified by BackgroundImage and BackgroundImageAlign. Some more elaborate visual effects can be applied by means of the EffectsProvider, EnableEmbossEffects and EnableShadowEffects properties.

To further customize the diagram appearance, handle the DrawBackground event to render custom background graphics, or the DrawForeground event to render custom foreground graphics.

Lanes

The lane grid lets you emphasize the relationship between a group of diagram items by displaying them in a distinct lane or cell within the grid. Use the EnableLanes property to display a background grid of lanes, optionally divided into cells. The grid can be set up using the LaneGrid property.

Text Formatting

Use TextFormat and TextColor to specify alignment and color of the text for all diagram items. EnableStyledText allows using HTML-like tags to format item's text. PolygonalTextLayout allows laying text out inside non-rectangular node shapes.

Tweaks

  • While moving grouped items, they are drawn in depth conforming to either their z-order or their group hierarchy, as set in SortGroupsByZ.
  • SelectionOnTop specifies whether selected items should be painted on top of other items.
  • MergeThreshold specifies how closely one to another adjacent link points should be placed in order to merge link segments.

Default Item Properties

Many properties of the Diagram class provide initial values for the properties of new items.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Diagram

See Also

Diagram Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram Members

Diagram Members
Constructors Fields Properties Methods Events

Represents a flow diagram.

The following tables list the members exposed by the Diagram type.

Public Constructors

Name | Description
Diagram | The Diagram class represents a flow diagram.

Public Fields

Name | Description
Dummy | A shared DummyNode instance.

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element.
ActiveItemHandlesColor | Gets or sets the color of the adjustment handles of the active item.
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects.
AlignToGrid | Gets or sets a value indicating whether the diagram items is aligned to a grid.
AllowLinksRepeat | Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes.
AllowSelfLoops | Gets or sets a value indicating whether self-loops are allowed.
AllowSplitLinks | Gets or sets a value indicating whether link segments can be added and removed interactively.
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node.
AutoResize | Gets or sets a value indicating whether the document area must be resized automatically so it fits the diagram contents.
BackBrush | Gets or sets the brush used for painting the diagram background.
BackgroundImage | Gets or sets the image displayed as background of this diagram.
BackgroundImageAlign | Gets or sets a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area.
BackgroundImageUrl | URL of the image painted as diagram's background.
Bounds | Gets or sets a value representing the size of the diagram's scrollable area.
BoundsPen | The pen with which the document bounds should be drawn.
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables.
CellFrameStyle | Gets or sets the default cell border style of new tables.
ContainerCaption | Gets or sets the default value for the Caption property of containers.
ContainerCaptionHeight | Gets or sets the default value for the CaptionHeight property of containers.
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers.
ContainerMargin | Gets or sets the default value for the Margin property of containers.
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers.
ContainersFoldable | Gets or sets the default value for the Foldable property of containers.
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points.
DefaultShape | Gets or sets the default shape of shape nodes.
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save.
DisabledHandlesColor | Gets or sets the color of disabled manipulation handles.
DynamicLinks | Gets or sets the default value for the Dynamic property of new links.
EffectsProvider | Gets or sets an object used to generate visual effects for shape nodes such as embossment and shadow dispersion.
EnableEmbossEffects | Gets or sets a value indicating whether emboss effect for shape nodes is enabled.
EnableLanes | Gets or sets whether lanes are enabled.
EnableShadowEffects | Gets or sets a value indicating whether the shadow dispersion effect for nodes is enabled.
EnableStyledText | Gets or sets the default value for the EnableStyledText property of new nodes.
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes.
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes.
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded.
ExteriorBrush | Gets or sets the brush used for painting the area outside Bounds.
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram.
Font | Gets or sets the default font for new diagram items.
GridColor | Gets or sets the color of the grid points.
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid.
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid.
GridSizeX | Gets or sets the horizontal distance between adjacent grid points.
GridSizeY | Gets or sets the vertical distance between adjacent grid points.
GridStyle | Gets or sets the visual style of the alignment grid.
Groups | Gets a collection of all groups in the diagram.
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested.
Interaction | Gets an InteractionState instance representing the current action being carried out by the user.
IsProEdition | Gets a value indicating whether the currently loaded MindFusion.Diagramming is a professional version of the control.
IsTrialVersion | Gets a value indicating whether the currently loaded MindFusion.Diagramming is a trial version of the control.
Items | Gets a collection of all items in this diagram.
LaneGrid | Gets the Grid instance that represents the lane grid.
LinkBaseShape | Gets or sets the shape displayed at the base of new links.
LinkBaseShapeSize | Gets or sets the default size of the base of new links.
LinkBrush | Gets or sets the default value for the Brush property of links.
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links.
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths.
LinkCustomDraw | Gets or sets the default type of custom painting done on links.
LinkEndsMovable | Gets or sets a value indicating whether link ends can be moved by users after the link is created.
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links.
LinkHeadShape | Gets or sets the shape displayed as head of new links.
LinkHeadShapeSize | Gets or sets the default size of arrowheads.
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit.
LinkIntermediateShape | Gets or sets the default shape to be displayed in the middle of each segment of links.
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments.
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links.
Links | Gets a collection of all DiagramLink objects in the diagram.
LinkSegments | Gets or sets the default number of link segments.
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around.
LinksSnapToBorders | Gets or sets the default value for the SnapToNodeBorder property of new links.
LinkStyle | Gets or sets the default style of diagram links.
LinkText | Gets or sets the default text of links.
LinkTextStyle | Gets or sets default placement and orientation for links' text.
MeasureTextRenderingHint | Gets or sets the TextRenderingHint to use when measuring texts. This should be effectively set to the value of DiagramView.TextRenderingHint.
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram.
MergeThreshold | Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged.
Nodes | Gets a collection of all DiagramNode objects in the diagram.
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded.
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file.
PolygonalTextLayout | Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines.
RecursiveExpand | Gets or sets value indicating how a tree is expanded.
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments.
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles.
RouteLinks | Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm.
ScriptHelper | Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods.
SelectAfterCreate | Gets or sets a value indicating whether newly created objects are automatically selected.
SelectedItemHandlesColor | Gets or sets the color of the manipulation handles of selected objects.
Selection | Gets a Selection instance that represents the selection of items in this diagram.
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items.
ShadowColor | Gets or sets the default color used to paint the shadows cast by diagram items.
ShadowOffsetX | Gets or sets the horizontal offset of item shadows.
ShadowOffsetY | Gets or sets the vertical offset of item shadows.
ShadowsStyle | Gets or sets the style for rendering shadows.
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes.
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes.
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes.
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes.
ShapePen | Gets or sets the default value for the Pen property of shape nodes.
ShapeText | Gets or sets the default text of shape nodes.
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed.
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled.
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible.
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified.
SnapToAnchor | Gets or sets when link end points should be aligned to the nearest anchor points.
SortGroupsByZ | Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved.
TableBrush | Gets or sets the default value for the Brush property of tables.
TableCaption | Gets or sets the default text for tables' captions.
TableCaptionHeight | Gets or sets the default height of table captions.
TableColumnCount | Gets or sets the default number of table columns.
TableColumnWidth | Gets or sets the default width of tables' columns.
TableConnectionStyle | Gets or sets a value indicating whether drawing a link between tables should connect the rows of those tables, or the tables as whole entities.
TableCustomDraw | Gets or sets the default type of custom painting done on tables.
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables.
TablePen | Gets or sets the default value for the Pen property of tables.
TableRowCount | Gets or sets the default number of table rows.
TableRowHeight | Gets or sets the default height of tables' rows.
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables.
TableStyle | Gets or sets the default value of the Style property of new tables.
Tag | Gets or sets custom data associated with this diagram.
TextColor | Gets or sets the default color of text displayed inside diagram items.
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram.
UndoManager | Gets a reference to the diagram's UndoManager instance.
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram.

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument.
ClearAll | Removes all items from the diagram.
CopySelection | Creates a copy of the currently selected objects and groups.
CreateImage | Overloaded. Creates a bitmap containing an image of the diagram.
CreateMeasureGraphics | Creates a GdiGraphics object that can be used to obtain various string size measurements.
Draw | Renders the diagram on the specified IGraphics object.
DrawInteraction | Draws the items that the user is currently modifying.
DrawStyledText | Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links.
ExecuteCommand | Executes the specified command on this diagram.
FindGroup | Finds the group that has the specified tag value.
FindLink | Finds the link that has the specified tag value.
FindNode | Finds the node that has the specified tag value.
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects.
GetItemAt | Finds and returns the top-most diagram item that lies at the specified location.
GetLinkAt | Overloaded. Finds and returns the link that lies at the specified location.
GetNodeAt | Overloaded. Gets the node that lies at the specified location.
GetNodesAt | Returns the nodes that contain the specified point.
HitTestManipulators | Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator.
Invalidate | Overloaded. Invalidates the diagram or a region of the diagram, causing it to be repainted.
LoadFromFile | Loads the contents of an existing diagram file into the control.
LoadFromStream | Loads a diagram from the specified stream.
LoadFromString | Decodes diagram contents from a string that was created with SaveToString.
LoadFromXml | Overloaded. Loads the contents of an XML diagram document into the control.
MeasureString | Overloaded. Measures a text taking into consideration the current affine transform of the diagram.
Navigate | Selects the nearest item in the specified direction.
PasteSelection | Adds the specified items and groups to the specified diagram document.
PixelToUnit | Converts the specified point from client to document coordinates ignoring the current scale transformation.
RaiseCellTextEdited | Raises the CellTextEdited event .
RaiseCellTextEditing | Raises the CellTextEditing event to validate entering in-place editing mode.
RaiseClicked | Overloaded. Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items.
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item.
RaiseDeleting | Raises the appropriate *Deleting event according to the type of the specified item.
RaiseDoubleClicked | Overloaded. Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items.
RaiseLinkTextEdited | Raises the LinkTextEdited event.
RaiseLinkTextEditing | Raises the LinkTextEditing event to validate entering in-place editing mode.
RaiseNodeTextEdited | Raises the NodeTextEdited event.
RaiseNodeTextEditing | Raises the NodeTextEditing event to validate entering in-place editing mode.
RaisePasted | Raises the appropriate Pasted event.
RaiseSelecting | Raises the appropriate Selecting event.
RaiseViewRemoved | Raises the ViewRemoved event.
RegisterItemClass | Registers a diagram item class for serialization support.
ResizeToFitItem | Resizes the document extents so that the specified item is contained within.
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items.
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes.
SaveToFile | Overloaded. Saves the binary contents of the diagram to a disk file.
SaveToStream | Overloaded. Saves the binary contents of the diagram to a .NET stream.
SaveToString | Overloaded. Encodes the diagram contents into an ASCII string.
SaveToXml | Overloaded. Saves the diagram to an XML document.
SetShadowOffset | Sets the default offset at which items shadows are drawn.
UnitToPixel | Converts the specified point from document to client coordinates ignoring the current scale transformation.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnActionRecorded | Raises the ActionRecorded event.
OnActionRecording | Raises the ActionRecording event.
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnBeginLoad | Raises the BeginLoad event.
OnCellClicked | Raises the CellClicked event.
OnCellDoubleClicked | Raises the CellDoubleClicked event.
OnCellTextEdited | Raises the CellTextEdited event.
OnCellTextEditing | Raises the CellTextEditing event to validate entering in-place editing mode.
OnClicked | Raises the Clicked event.
OnContainerChildAdded | Raises the ContainerChildAdded event.
OnContainerChildRemoved | Raises the ContainerChildRemoved event.
OnContainerFolded | Raises the ContainerFolded event.
OnContainerUnfolded | Raises the ContainerUnfolded event.
OnDeserializeTag | Raises the DeserializeTag event.
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event.
OnDoubleClicked | Raises the DoubleClicked event.
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event.
OnDrawAnchorPoint | Raises the DrawAnchorPoint event.
OnDrawBackground | Raises the DrawBackground event.
OnDrawCell | Raises the DrawCell event.
OnDrawForeground | Raises the DrawForeground event.
OnDrawLink | Raises the DrawLink event.
OnDrawNode | Raises the DrawNode event.
OnEndLoad | Raises the EndLoad event.
OnExpandButtonClicked | Raises the ExpandButtonClicked event.
OnGroupDestroyed | Raises the GroupDestroyed event.
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event.
OnInitializeLink | Raises the InitializeLink event.
OnInitializeNode | Raises the InitializeNode event.
OnItemAdded | Raises the ItemAdded event.
OnItemRemoved | Raises the ItemRemoved event.
OnLinkActivated | Raises the LinkActivated event.
OnLinkClicked | Raises the LinkClicked event.
OnLinkCreated | Raises the LinkCreated event.
OnLinkCreating | Raises the LinkCreating event.
OnLinkDeactivated | Raises the LinkDeactivated event.
OnLinkDeleted | Raises the LinkDeleted event.
OnLinkDeleting | Raises the LinkDeleting event.
OnLinkDeselected | Raises the LinkDeselected event.
OnLinkDoubleClicked | Raises the LinkDoubleClicked event.
OnLinkModified | Raises the LinkModified event.
OnLinkModifying | Raises the LinkModifying event.
OnLinkPasted | Raises the LinkModified event.
OnLinkRouted | Raises the LinkRouted event.
OnLinkSelected | Raises the LinkSelected event.
OnLinkSelecting | Raises the LinkSelecting event.
OnLinkStartModifying | Raises the LinkStartModifying event.
OnLinkTextEdited | Raises the LinkTextEdited event.
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering in-place editing mode.
OnNodeActivated | Raises the NodeActivated event.
OnNodeClicked | Raises the NodeClicked event.
OnNodeCreated | Raises the NodeCreated event.
OnNodeCreating | Raises the NodeCreating event.
OnNodeDeactivated | Raises the NodeDeactivated event.
OnNodeDeleted | Raises the NodeDeleted event.
OnNodeDeleting | Raises the NodeDeleting event.
OnNodeDeselected | Raises the NodeDeselected event.
OnNodeDoubleClicked | Raises the NodeDoubleClicked event.
OnNodeModified | Raises the NodeModified event.
OnNodeModifying | Raises the NodeModifying event.
OnNodePasted | Raises the NodePasted event.
OnNodeSelected | Raises the NodeSelected event.
OnNodeSelecting | Raises the NodeSelecting event.
OnNodeStartModifying | Raises the NodeStartModifying event.
OnNodeTextEdited | Raises the NodeTextEdited event.
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering in-place editing mode.
OnOriginAnchorChanged | Raises the OriginAnchorChanged event.
OnSelectionChanged | Raises the SelectionChanged event.
OnSelectionMoved | Raises the SelectionMoved event.
OnSelectionMoving | Raises the SelectionMoving event.
OnSerializeTag | Raises the SerializeTag event.
OnTableSectionCollapsed | Raises the appropriate TableSection event.
OnTableSectionExpanded | Raises the appropriate TableSection event.
OnTreeCollapsed | Raises the TreeCollapsed event.
OnTreeExpanded | Raises the TreeExpanded event.
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event.
OnViewRemoved | Raises the ViewRemoved event.

Public Events

Name | Description
ActionRecorded | Raised when an action is recorded in the undo buffer.
ActionRecording | A validation event raised before an action is recorded in the undo buffer.
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream.
BoundsChanged | Raised when the Bounds property value has changed.
CellClicked | Raised when the user clicks a table's cell.
CellDoubleClicked | Raised when the user double-clicks a table's cell.
CellTextEdited | Raised when the user edits the text of a table's cell.
CellTextEditing | A validation event that lets you prevent users from editing the text of a table's cell.
Clicked | Raised when the user clicks the diagram at a point where no items are located.
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user.
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user.
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area.
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.
DefaultShapeChanged | Raised when the DefaultShape property value has changed.
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format.
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed.
DirtyChanged | Raised when the Dirty property value has changed.
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located.
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn.
DrawAnchorPoint | Raised when an anchor point must be custom drawn.
DrawBackground | Raised to let you custom draw the diagram background.
DrawCell | Raised when a table's cell must be custom drawn.
DrawForeground | Raised to let you custom draw the diagram foreground.
DrawLink | Raised when a diagram link must be custom drawn.
DrawNode | Raised when a diagram node must be custom drawn.
EndLoad | Raised when the component ends loading diagram data from a file or memory stream.
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node.
GroupDestroyed | Raised when a Group object is destroyed.
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed.
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created.
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created.
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively.
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively.
LinkActivated | Raised when a link becomes the ActiveItem.
LinkClicked | Raised when the user clicks a link.
LinkCreated | Raised when the user draws a new link.
LinkCreating | A validation event raised while the user is drawing a new link.
LinkDeactivated | Raised when a link is no longer the ActiveItem.
LinkDeleted | Raised when a link is deleted, either programmatically or by the user.
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation.
LinkDeselected | Raised when a link is deselected, either programmatically or by the user.
LinkDoubleClicked | Raised when the user double-clicks a link.
LinkModified | Raised when the user moves any control point of a link.
LinkModifying | A validation event raised while the user is modifying a link.
LinkPasted | Raised when a link has been pasted from the clipboard.
LinkRouted | Raised when a link is routed by the auto-routing algorithm.
LinkSelected | Raised when a link is selected, either programmatically or by the user.
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation.
LinkStartModifying | A validation event raised when the user starts modifying a link.
LinkTextEdited | Raised when the user edits the text of a link.
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link.
MeasureUnitChanged | Raised when the MeasureUnit property value has changed.
NodeActivated | Raised when a node becomes the ActiveItem.
NodeClicked | Raised when the user clicks a node.
NodeCreated | Raised when the user draws a new node.
NodeCreating | A validation event raised while the user is drawing a new node.
NodeDeactivated | Raised when a node is no longer the ActiveItem.
NodeDeleted | Raised when a node is deleted, either programmatically or by the user.
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation.
NodeDeselected | Raised when a node is deselected, either programmatically or by the user.
NodeDoubleClicked | Raised when the user double-clicks a node.
NodeModified | Raised when the user moves or resizes a node.
NodeModifying | A validation event raised while the user is moving or resizing a node.
NodePasted | Raised when a node has been pasted from the clipboard.
NodeSelected | Raised when a node is selected, either programmatically or by the user.
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation.
NodeStartModifying | A validation event raised when the user starts modifying a node.
NodeTextEdited | Raised when the user edits the text of a node.
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node.
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed.
Repaint | Raised when the diagram views should be repainted.
SelectionChanged | Raised when an item is added to or removed from the selection.
SelectionMoved | Raised when the user moves multiple selected items.
SelectionMoving | Raised while the user is moving multiple selected items, this event lets you cancel the modification.
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document.
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row.
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row.
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point.
ViewRemoved | Raised when a DiagramView is detached from this diagram.

See Also

Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram Fields

Diagram Fields

Public Fields

Name | Description
Dummy | A shared DummyNode instance.

See Also

Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.Dummy Field

Diagram.Dummy Field

A shared DummyNode instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DummyNode Dummy
Visual Basic

Public Dummy As DummyNode

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram Constructor

Diagram Constructor

The Diagram class represents a flow diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Diagram ()
Visual Basic

Public Sub New ()

See Also

Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram Methods

Diagram Methods

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument.
ClearAll | Removes all items from the diagram.
CopySelection | Creates a copy of the currently selected objects and groups.
CreateImage | Overloaded. Creates a bitmap containing an image of the diagram.
CreateMeasureGraphics | Creates a GdiGraphics object that can be used to obtain various string size measurements.
Draw | Renders the diagram on the specified IGraphics object.
DrawInteraction | Draws the items that the user is currently modifying.
DrawStyledText | Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links.
ExecuteCommand | Executes the specified command on this diagram.
FindGroup | Finds the group that has the specified tag value.
FindLink | Finds the link that has the specified tag value.
FindNode | Finds the node that has the specified tag value.
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects.
GetItemAt | Finds and returns the top-most diagram item that lies at the specified location.
GetLinkAt | Overloaded. Finds and returns the link that lies at the specified location.
GetNodeAt | Overloaded. Gets the node that lies at the specified location.
GetNodesAt | Returns the nodes that contain the specified point.
HitTestManipulators | Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator.
Invalidate | Overloaded. Invalidates the diagram or a region of the diagram, causing it to be repainted.
LoadFromFile | Loads the contents of an existing diagram file into the control.
LoadFromStream | Loads a diagram from the specified stream.
LoadFromString | Decodes diagram contents from a string that was created with SaveToString.
LoadFromXml | Overloaded. Loads the contents of an XML diagram document into the control.
MeasureString | Overloaded. Measures a text taking into consideration the current affine transform of the diagram.
Navigate | Selects the nearest item in the specified direction.
PasteSelection | Adds the specified items and groups to the specified diagram document.
PixelToUnit | Converts the specified point from client to document coordinates ignoring the current scale transformation.
RaiseCellTextEdited | Raises the CellTextEdited event .
RaiseCellTextEditing | Raises the CellTextEditing event to validate entering in-place editing mode.
RaiseClicked | Overloaded. Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items.
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item.
RaiseDeleting | Raises the appropriate *Deleting event according to the type of the specified item.
RaiseDoubleClicked | Overloaded. Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items.
RaiseLinkTextEdited | Raises the LinkTextEdited event.
RaiseLinkTextEditing | Raises the LinkTextEditing event to validate entering in-place editing mode.
RaiseNodeTextEdited | Raises the NodeTextEdited event.
RaiseNodeTextEditing | Raises the NodeTextEditing event to validate entering in-place editing mode.
RaisePasted | Raises the appropriate Pasted event.
RaiseSelecting | Raises the appropriate Selecting event.
RaiseViewRemoved | Raises the ViewRemoved event.
RegisterItemClass | Registers a diagram item class for serialization support.
ResizeToFitItem | Resizes the document extents so that the specified item is contained within.
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items.
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes.
SaveToFile | Overloaded. Saves the binary contents of the diagram to a disk file.
SaveToStream | Overloaded. Saves the binary contents of the diagram to a .NET stream.
SaveToString | Overloaded. Encodes the diagram contents into an ASCII string.
SaveToXml | Overloaded. Saves the diagram to an XML document.
SetShadowOffset | Sets the default offset at which items shadows are drawn.
UnitToPixel | Converts the specified point from document to client coordinates ignoring the current scale transformation.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnActionRecorded | Raises the ActionRecorded event.
OnActionRecording | Raises the ActionRecording event.
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnBeginLoad | Raises the BeginLoad event.
OnCellClicked | Raises the CellClicked event.
OnCellDoubleClicked | Raises the CellDoubleClicked event.
OnCellTextEdited | Raises the CellTextEdited event.
OnCellTextEditing | Raises the CellTextEditing event to validate entering in-place editing mode.
OnClicked | Raises the Clicked event.
OnContainerChildAdded | Raises the ContainerChildAdded event.
OnContainerChildRemoved | Raises the ContainerChildRemoved event.
OnContainerFolded | Raises the ContainerFolded event.
OnContainerUnfolded | Raises the ContainerUnfolded event.
OnDeserializeTag | Raises the DeserializeTag event.
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event.
OnDoubleClicked | Raises the DoubleClicked event.
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event.
OnDrawAnchorPoint | Raises the DrawAnchorPoint event.
OnDrawBackground | Raises the DrawBackground event.
OnDrawCell | Raises the DrawCell event.
OnDrawForeground | Raises the DrawForeground event.
OnDrawLink | Raises the DrawLink event.
OnDrawNode | Raises the DrawNode event.
OnEndLoad | Raises the EndLoad event.
OnExpandButtonClicked | Raises the ExpandButtonClicked event.
OnGroupDestroyed | Raises the GroupDestroyed event.
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event.
OnInitializeLink | Raises the InitializeLink event.
OnInitializeNode | Raises the InitializeNode event.
OnItemAdded | Raises the ItemAdded event.
OnItemRemoved | Raises the ItemRemoved event.
OnLinkActivated | Raises the LinkActivated event.
OnLinkClicked | Raises the LinkClicked event.
OnLinkCreated | Raises the LinkCreated event.
OnLinkCreating | Raises the LinkCreating event.
OnLinkDeactivated | Raises the LinkDeactivated event.
OnLinkDeleted | Raises the LinkDeleted event.
OnLinkDeleting | Raises the LinkDeleting event.
OnLinkDeselected | Raises the LinkDeselected event.
OnLinkDoubleClicked | Raises the LinkDoubleClicked event.
OnLinkModified | Raises the LinkModified event.
OnLinkModifying | Raises the LinkModifying event.
OnLinkPasted | Raises the LinkModified event.
OnLinkRouted | Raises the LinkRouted event.
OnLinkSelected | Raises the LinkSelected event.
OnLinkSelecting | Raises the LinkSelecting event.
OnLinkStartModifying | Raises the LinkStartModifying event.
OnLinkTextEdited | Raises the LinkTextEdited event.
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering in-place editing mode.
OnNodeActivated | Raises the NodeActivated event.
OnNodeClicked | Raises the NodeClicked event.
OnNodeCreated | Raises the NodeCreated event.
OnNodeCreating | Raises the NodeCreating event.
OnNodeDeactivated | Raises the NodeDeactivated event.
OnNodeDeleted | Raises the NodeDeleted event.
OnNodeDeleting | Raises the NodeDeleting event.
OnNodeDeselected | Raises the NodeDeselected event.
OnNodeDoubleClicked | Raises the NodeDoubleClicked event.
OnNodeModified | Raises the NodeModified event.
OnNodeModifying | Raises the NodeModifying event.
OnNodePasted | Raises the NodePasted event.
OnNodeSelected | Raises the NodeSelected event.
OnNodeSelecting | Raises the NodeSelecting event.
OnNodeStartModifying | Raises the NodeStartModifying event.
OnNodeTextEdited | Raises the NodeTextEdited event.
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering in-place editing mode.
OnOriginAnchorChanged | Raises the OriginAnchorChanged event.
OnSelectionChanged | Raises the SelectionChanged event.
OnSelectionMoved | Raises the SelectionMoved event.
OnSelectionMoving | Raises the SelectionMoving event.
OnSerializeTag | Raises the SerializeTag event.
OnTableSectionCollapsed | Raises the appropriate TableSection event.
OnTableSectionExpanded | Raises the appropriate TableSection event.
OnTreeCollapsed | Raises the TreeCollapsed event.
OnTreeExpanded | Raises the TreeExpanded event.
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event.
OnViewRemoved | Raises the ViewRemoved event.

See Also

Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.AlignPointToGrid Method

Diagram.AlignPointToGrid Method

Returns a point of the alignment grid nearest to the one passed as an argument.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF AlignPointToGrid (
PointF point
)
Visual Basic

Public Function AlignPointToGrid ( _
point As PointF _
) As PointF

Parameters

point
A point specified in diagram coordinates.

Return Value

A point from the alignment grid.

Remarks

Items created or moved by a user are automatically aligned to the grid. However, if items are placed in the diagram programmatically, their coordinates are set to the specified positions without aligning. In such cases use AlignPointToGrid if items must be placed exactly at grid points.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AlignToGrid Property
GridSizeX Property
GridSizeY Property


MindFusion.Diagramming.Diagram.ClearAll Method

Diagram.ClearAll Method

Removes all items from the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ClearAll ()
Visual Basic

Public Sub ClearAll ()

Remarks

Use this method to clear all Groups, Links and Nodes in the diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Items Property


MindFusion.Diagramming.Diagram.CopySelection Method

Diagram.CopySelection Method

Creates a copy of the currently selected objects and groups.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public SelectionCopy CopySelection (
Diagram source,
bool unconnectedLinks,
bool copyGroups
)
Visual Basic

Public Function CopySelection ( _
source As Diagram, _
unconnectedLinks As Boolean, _
copyGroups As Boolean _
) As SelectionCopy

Parameters

source
The source diagram.
unconnectedLinks
true to allow copying unconnected links; otherwise, false.
copyGroups
true to copy group information; otherwise, false.

Return Value

An instance of the SelectionCopy class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.CreateImage Method

Diagram.CreateImage Method

Creates a bitmap containing an image of the diagram.

Overload List

Name | Description
Diagram.CreateImage () | Creates a bitmap image representing this diagram.
Diagram.CreateImage (RectangleF, Rectangle, Single) | Creates a bitmap image representing this diagram using the specified scale factor.
Diagram.CreateImage (RectangleF, Single) | Creates a bitmap image representing this diagram using the specified scale factor.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.CreateImage Method ()

Diagram.CreateImage Method ()
See Also

Creates a bitmap image representing this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Bitmap CreateImage ()
Visual Basic

Public Function CreateImage () As Bitmap

Return Value

An instance of the .NET System.Drawing.Bitmap class.

Remarks

The method creates a new bitmap instance as big as the current document extents and paints the diagram in it. The Save method of the Bitmap class can be used to save the image in a jpeg, gif or bmp file.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
HtmlBuilder Class


MindFusion.Diagramming.Diagram.CreateImage Method (RectangleF, Rectangle, Single)

Diagram.CreateImage Method (RectangleF, Rectangle, Single)
See Also

Creates a bitmap image representing this diagram using the specified scale factor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Bitmap CreateImage (
RectangleF viewport,
Rectangle viewportDev,
float scale
)
Visual Basic

Public Function CreateImage ( _
viewport As RectangleF, _
viewportDev As Rectangle, _
scale As Single _
) As Bitmap

Parameters

viewport
Specifies what region of the diagram to export, in logical coordinates.
viewportDev
Specifies what region of the diagram to export, in device coordinates.
scale
Specifies the scale factor as percents of the original size.

Return Value

An instance of the .NET Bitmap class containing the diagram image.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.CreateImage Method (RectangleF, Single)

Diagram.CreateImage Method (RectangleF, Single)
See Also

Creates a bitmap image representing this diagram using the specified scale factor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Bitmap CreateImage (
RectangleF viewport,
float scale
)
Visual Basic

Public Function CreateImage ( _
viewport As RectangleF, _
scale As Single _
) As Bitmap

Parameters

viewport
Specifies what region of the diagram to export.
scale
Specifies the scale factor as percents of the original size.

Return Value

An instance of the .NET Bitmap class containing the diagram image.

Remarks

The method creates a new bitmap instance as big as the current document extents and paints the diagram in it. The Save method of the Bitmap class can be used to save the image in a jpeg, gif or bmp file.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
HtmlBuilder Class


MindFusion.Diagramming.Diagram.CreateMeasureGraphics Method

Diagram.CreateMeasureGraphics Method

Creates a GdiGraphics object that can be used to obtain various string size measurements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public GdiGraphics CreateMeasureGraphics ()
Visual Basic

Public Function CreateMeasureGraphics () As GdiGraphics

Return Value

An instance of the GdiGraphics class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.Dispose Method

Diagram.Dispose Method

Clean up any resources being used.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing

true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.Draw Method

Diagram.Draw Method

Renders the diagram on the specified IGraphics object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void Draw (
IGraphics graphics,
RenderOptions options,
RectangleF clipRect,
bool noModifiedItems
)
Visual Basic

Public Overridable Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions, _
clipRect As RectangleF, _
noModifiedItems As Boolean _
)

Parameters

graphics
The IGraphics surface to draw the diagram on.
options
A RenderOptions object specifying options for the drawing operation.
clipRect
A RectangleF specifying the current clipping rectangle.
noModifiedItems

true to skip rendering the items currently being modified; otherwise, false.

Remarks

MindFusion.Diagramming calls this method to draw a representation of the diagram onto the specified graphics surface. You can override Draw if you need to render additional elements over what's already drawn by the Diagram object.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.DrawInteraction Method

Diagram.DrawInteraction Method

Draws the items that the user is currently modifying.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void DrawInteraction (
IGraphics graphics,
RenderOptions options,
RectangleF clipRect
)
Visual Basic

Public Sub DrawInteraction ( _
graphics As IGraphics, _
options As RenderOptions, _
clipRect As RectangleF _
)

Parameters

graphics
The IGraphics surface to draw the items on.
options
A RenderOptions object specifying options for the drawing operation.
clipRect
A RectangleF specifying the current clipping rectangle.

Remarks

This method draws the items that are currently being modified by the user.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.DrawStyledText Method

Diagram.DrawStyledText Method

Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void DrawStyledText (
IGraphics graphics,
string text,
Font font,
RectangleF textBounds,
StringFormat format
)
Visual Basic

Public Sub DrawStyledText ( _
graphics As IGraphics, _
text As String, _
font As Font, _
textBounds As RectangleF, _
format As StringFormat _
)

Parameters

graphics
The IGraphics canvas on which to draw.
text

The text that should be drawn, including formatting tags.

font
The font used to draw the text.
textBounds
The bounds of the text layout rectangle.
format
Specifies the text alignment.

Remarks

You might use this method when you custom-draw shape nodes and still need to use the EnableStyledText rendering functionality of MindFusion.Diagramming.

Example

The following sample code illustrates how to manually render styled text.

C#

private void diagram_DrawNode(object sender, DrawNodeEventArgs e)
{
diagram.DrawStyledText(e.Graphics, "<b>test</b> <i>test</i>",
diagram.Font, e.Node.Bounds, StringFormat.GenericDefault);
}
Visual Basic

Private Sub diagram_DrawNode(ByVal sender As Object, ByVal e As DrawNodeEventArgs) Handles diagram.DrawNode

diagram.DrawStyledText(e.Graphics, "<b>test</b> <i>test</i>", _
diagram.Font, e.Node.Bounds, StringFormat.GenericDefault)

End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DrawNode


MindFusion.Diagramming.Diagram.ExecuteCommand Method

Diagram.ExecuteCommand Method

Executes the specified command on this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ExecuteCommand (
Command cmd
)
Visual Basic

Public Sub ExecuteCommand ( _
cmd As Command _
)

Parameters

cmd

The Command to execute.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.FindGroup Method

Diagram.FindGroup Method

Finds the group that has the specified tag value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Group FindGroup (
Object tagValue
)
Visual Basic

Public Function FindGroup ( _
tagValue As Object _
) As Group

Parameters

tagValue
A .NET object assigned as a tag and characterizing the group to be searched for.

Return Value

The Group instance if found; otherwise, null (Nothing in Visual Basic).

Remarks

Use this method to find a group that has been marked earlier with the specified tag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
FindLink Method
FindNode Method


MindFusion.Diagramming.Diagram.FindLink Method

Diagram.FindLink Method

Finds the link that has the specified tag value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink FindLink (
Object tagValue
)
Visual Basic

Public Function FindLink ( _
tagValue As Object _
) As DiagramLink

Parameters

tagValue
A .NET object assigned as a tag and characterizing the link to be searched for.

Return Value

The DiagramLink instance if found; otherwise, null (Nothing in Visual Basic).

Remarks

Use this method to find a link that has been marked earlier with the specified tag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
FindNode Method
FindGroup Method


MindFusion.Diagramming.Diagram.FindNode Method

Diagram.FindNode Method

Finds the node that has the specified tag value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode FindNode (
Object tagValue
)
Visual Basic

Public Function FindNode ( _
tagValue As Object _
) As DiagramNode

Parameters

tagValue
A .NET object assigned as a tag and characterizing the node to be searched for.

Return Value

The DiagramNode instance if found; otherwise, null (Nothing in Visual Basic).

Remarks

Use this method to find a node that has been marked earlier with the specified tag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
FindLink Method
FindGroup Method


MindFusion.Diagramming.Diagram.GetContentBounds Method

Diagram.GetContentBounds Method

Returns the smallest rectangle that bounds all diagram objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF GetContentBounds (
bool forPrint,
bool onlyVisible
)
Visual Basic

Public Function GetContentBounds ( _
forPrint As Boolean, _
onlyVisible As Boolean _
) As RectangleF

Parameters

forPrint
Specifies whether only printable items should be considered.
onlyVisible
Specifies whether only visible items should be considered.

Return Value

The smallest rectangle that bounds all diagram items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.GetItemAt Method

Diagram.GetItemAt Method

Finds and returns the top-most diagram item that lies at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem GetItemAt (
PointF pt,
bool exclLocked
)
Visual Basic

Public Function GetItemAt ( _
pt As PointF, _
exclLocked As Boolean _
) As DiagramItem

Parameters

pt

A PointF instance identifying a diagram location.

exclLocked

Specifies whether to ignore locked items.

Return Value

The DiagramItem found or null (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the item at a certain location in the diagram. The method searches starting from the top of z-order and returns the first item found.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetNodeAt Method
GetLinkAt Method
LinkHitDistance Property


MindFusion.Diagramming.Diagram.GetLinkAt Method

Diagram.GetLinkAt Method

Finds and returns the link that lies at the specified location.

Overload List

Name | Description
Diagram.GetLinkAt (PointF, Single) | Finds and returns the top-most link that lies at the specified location.
Diagram.GetLinkAt (PointF, Single, Boolean) | Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search.
Diagram.GetLinkAt (PointF, Single, Boolean, Int32@) | Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search. The zero-based index of the exact link segment at the specified position is also returned.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetNodeAt Method
GetItemAt Method


MindFusion.Diagramming.Diagram.GetLinkAt Method (PointF, Single)

Diagram.GetLinkAt Method (PointF, Single)
See Also

Finds and returns the top-most link that lies at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink GetLinkAt (
PointF pt,
float maxDist
)
Visual Basic

Public Function GetLinkAt ( _
pt As PointF, _
maxDist As Single _
) As DiagramLink

Parameters

pt
A PointF instance identifying a diagram location.
maxDist
The maximal distance between the point and a link, within which to consider the point as lying on the link.

Return Value

The DiagramLink found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the link at a certain place in the document. The method searches starting from the top of z-order and returns the first link found. The specified point might not be laying exactly on the link, but within a certain threshold distance from it. This threshold is specified through the second parameter.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetNodeAt Method
GetItemAt Method


MindFusion.Diagramming.Diagram.GetLinkAt Method (PointF, Single, Boolean)

Diagram.GetLinkAt Method (PointF, Single, Boolean)
See Also

Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink GetLinkAt (
PointF pt,
float maxDist,
bool exclLocked
)
Visual Basic

Public Function GetLinkAt ( _
pt As PointF, _
maxDist As Single, _
exclLocked As Boolean _
) As DiagramLink

Parameters

pt
A PointF instance identifying a diagram location.
maxDist
The maximal distance between the point and a link, within which to consider the point as lying on the link.
exclLocked

Specifies that locked links should be ignored by the search.

Return Value

The DiagramLink found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the link at a certain place in the document. The method searches starting from the top of z-order and returns the first link found. The specified point might not be laying exactly on the link, but within a certain threshold distance from it. This threshold is specified through the second parameter. Locked and invisible links can be skipped from the search by setting the third parameter to true.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetItemAt Method
GetNodeAt Method


MindFusion.Diagramming.Diagram.GetLinkAt Method (PointF, Single, Boolean, Int32@)

Diagram.GetLinkAt Method (PointF, Single, Boolean, Int32@)
See Also

Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search. The zero-based index of the exact link segment at the specified position is also returned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink GetLinkAt (
PointF pt,
float maxDist,
bool exclLocked,
ref int segmNum
)
Visual Basic

Public Function GetLinkAt ( _
pt As PointF, _
maxDist As Single, _
exclLocked As Boolean, _
ByRef segmNum As Integer _
) As DiagramLink

Parameters

pt
A PointF instance identifying a diagram location.
maxDist
The maximal distance between the point and a link, within which to consider the point as lying on the link.
exclLocked

Specifies that locked links should be ignored by the search.

segmNum
The zero-based index of the link's segment at which the point is lying is returned here.

Return Value

The DiagramLink found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the link at a certain place in the document. The method searches starting from the top of z-order and returns the first link found. The specified point might not be laying exactly on the link, but within a certain threshold distance from it. This threshold is specified through the second parameter. Locked and invisible links can be skipped from the search by setting the third parameter to true. The link's segment closest to the point is returned through the fourth parameter.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetNodeAt Method
GetItemAt Method


MindFusion.Diagramming.Diagram.GetNodeAt Method

Diagram.GetNodeAt Method

Gets the node that lies at the specified location.

Overload List

Name | Description
Diagram.GetNodeAt (PointF) | Finds and returns the top-most node that lies at the specified location.
Diagram.GetNodeAt (PointF, Boolean, Boolean) | Finds and returns the top-most node that lies at the specified location, optionally excluding locked and/or selected nodes from the search.
Diagram.GetNodeAt (PointF, Boolean, Boolean, Single) | Finds and returns the top-most node that lies within the specified threshold from the specified location, optionally excluding locked and/or selected nodes from the search.
Diagram.GetNodeAt (PointF, Single) | Finds and returns the top-most node that lies within the specified threshold from the specified location.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetItemAt Method
GetLinkAt Method


MindFusion.Diagramming.Diagram.GetNodeAt Method (PointF)

Diagram.GetNodeAt Method (PointF)
See Also

Finds and returns the top-most node that lies at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode GetNodeAt (
PointF point
)
Visual Basic

Public Function GetNodeAt ( _
point As PointF _
) As DiagramNode

Parameters

point
A PointF instance identifying a diagram location.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

The method starts searching from the top of the z-order and returns the first node that contains the specified point.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetLinkAt Method
GetItemAt Method


MindFusion.Diagramming.Diagram.GetNodeAt Method (PointF, Boolean, Boolean)

Diagram.GetNodeAt Method (PointF, Boolean, Boolean)
See Also

Finds and returns the top-most node that lies at the specified location, optionally excluding locked and/or selected nodes from the search.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode GetNodeAt (
PointF point,
bool excludeLocked,
bool excludeSelected
)
Visual Basic

Public Function GetNodeAt ( _
point As PointF, _
excludeLocked As Boolean, _
excludeSelected As Boolean _
) As DiagramNode

Parameters

point
A PointF instance identifying a diagram location.
excludeLocked
true if nodes that are locked should be omitted by searching; otherwise, false.
excludeSelected
true if nodes that are selected should be omitted by searching; otherwise, false.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no node has been found.

Remarks

This method gives you the possibility to specify search options when looking for a node occupying some location in the diagram document. The method searches starting from the top of z-order and returns the first object found.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetItemAt Method
GetLinkAt Method


MindFusion.Diagramming.Diagram.GetNodeAt Method (PointF, Boolean, Boolean, Single)

Diagram.GetNodeAt Method (PointF, Boolean, Boolean, Single)
See Also

Finds and returns the top-most node that lies within the specified threshold from the specified location, optionally excluding locked and/or selected nodes from the search.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode GetNodeAt (
PointF point,
bool excludeLocked,
bool excludeSelected,
float threshold
)
Visual Basic

Public Function GetNodeAt ( _
point As PointF, _
excludeLocked As Boolean, _
excludeSelected As Boolean, _
threshold As Single _
) As DiagramNode

Parameters

point
A PointF instance identifying a diagram location.
excludeLocked
true if nodes that are locked should be omitted by searching; otherwise, false.
excludeSelected
true if nodes that are selected should be omitted by searching; otherwise, false.
threshold
Allowed distance from the node.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no node has been found.

Remarks

This method gives you the possibility to specify search options when looking for a node occupying some location in the diagram document. The method searches starting from the top of z-order and returns the first object found.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetLinkAt Method
GetItemAt Method


MindFusion.Diagramming.Diagram.GetNodeAt Method (PointF, Single)

Diagram.GetNodeAt Method (PointF, Single)
See Also

Finds and returns the top-most node that lies within the specified threshold from the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode GetNodeAt (
PointF point,
float threshold
)
Visual Basic

Public Function GetNodeAt ( _
point As PointF, _
threshold As Single _
) As DiagramNode

Parameters

point
A PointF instance identifying a diagram location.
threshold
Allowed distance from the node.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no node has been found.

Remarks

This method gives you the possibility to specify search options when looking for a node occupying some location in the diagram document. The method searches starting from the top of z-order and returns the first object found.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetItemAt Method
GetLinkAt Method


MindFusion.Diagramming.Diagram.GetNodesAt Method

Diagram.GetNodesAt Method

Returns the nodes that contain the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNodeCollection GetNodesAt (
PointF point
)
Visual Basic

Public Function GetNodesAt ( _
point As PointF _
) As DiagramNodeCollection

Parameters

point
A PointF instance identifying a diagram location.

Return Value

An instance of the DiagramNodeCollection class containing all found nodes; null (Nothing in Visual Basic) if no node has been found.

Remarks

This method gives you the possibility to specify search options when looking for the nodes occupying some location in the diagram document.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
GetItemAt Method
GetLinkAt Method


MindFusion.Diagramming.Diagram.HitTestManipulators Method

Diagram.HitTestManipulators Method

Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool HitTestManipulators (
PointF pt
)
Visual Basic

Public Function HitTestManipulators ( _
pt As PointF _
) As Boolean

Parameters

pt

A PointF instance specifying the point to test.

Return Value

true to indicate whether there is a manipulator at the specified location; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.Invalidate Method

Diagram.Invalidate Method

Invalidates the diagram or a region of the diagram, causing it to be repainted.

Overload List

Name | Description
Diagram.Invalidate () | Invalidates the entire diagram.
Diagram.Invalidate (Boolean) | Invalidates the entire diagram and optionally repaints the back-buffer image.
Diagram.Invalidate (Object, RectangleF) | Invalidates the specified rectangle of the diagram, causing it to be repainted.
Diagram.Invalidate (RectangleF) | Invalidates the specified rectangle of the diagram, causing it to be repainted.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramView.RecreateCacheImage Method


MindFusion.Diagramming.Diagram.Invalidate Method ()

Diagram.Invalidate Method ()
See Also

Invalidates the entire diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Invalidate ()
Visual Basic

Public Sub Invalidate ()

Remarks

This method raises the Repaint event. DiagramView objects handle Repaint by redrawing the specified diagram region.

See Also

Invalidate Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramView.RecreateCacheImage Method


MindFusion.Diagramming.Diagram.Invalidate Method (Boolean)

Diagram.Invalidate Method (Boolean)
See Also

Invalidates the entire diagram and optionally repaints the back-buffer image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Invalidate (
bool redrawCacheImage
)
Visual Basic

Public Sub Invalidate ( _
redrawCacheImage As Boolean _
)

Parameters

redrawCacheImage
A boolean value specifying whether the diagram cache image used during modification should be re-created.

Remarks

This method raises the Repaint event. DiagramView objects handle Repaint by redrawing the specified diagram region.

See Also

Invalidate Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramView.RecreateCacheImage Method


MindFusion.Diagramming.Diagram.Invalidate Method (Object, RectangleF)

Diagram.Invalidate Method (Object, RectangleF)
See Also

Invalidates the specified rectangle of the diagram, causing it to be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Invalidate (
Object sender,
RectangleF invalidRect
)
Visual Basic

Public Sub Invalidate ( _
sender As Object, _
invalidRect As RectangleF _
)

Parameters

sender
The object that causes the diagram invalidation.
invalidRect
A RectangleF instance specifying the region that should be repainted. If not specified, the whole diagram will be repainted.

Remarks

This method raises the Repaint event. DiagramView objects handle Repaint by redrawing the specified diagram region.

See Also

Invalidate Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramView.RecreateCacheImage Method


MindFusion.Diagramming.Diagram.Invalidate Method (RectangleF)

Diagram.Invalidate Method (RectangleF)
See Also

Invalidates the specified rectangle of the diagram, causing it to be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Invalidate (
RectangleF invalidRect
)
Visual Basic

Public Sub Invalidate ( _
invalidRect As RectangleF _
)

Parameters

invalidRect
A RectangleF instance specifying the region that should be repainted. If not specified, the whole diagram will be repainted.

Remarks

This method raises the Repaint event. DiagramView objects handle Repaint by redrawing the specified diagram region.

See Also

Invalidate Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramView.RecreateCacheImage Method


MindFusion.Diagramming.Diagram.LoadFromFile Method

Diagram.LoadFromFile Method

Loads the contents of an existing diagram file into the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void LoadFromFile (
string fileName
)
Visual Basic

Public Sub LoadFromFile ( _
fileName As String _
)

Parameters

fileName
The name of the file the data shall be read from.

Remarks

The method reads previously saved diagram. It is implemented by creating a stream on the input file, then invoking the LoadFromStream method. It throws a FileLoadException if the file given as argument does not adhere to the proper format. Diagrams can be saved in a file using the SaveToFile method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LoadFromStream
LoadFromXml


MindFusion.Diagramming.Diagram.LoadFromStream Method

Diagram.LoadFromStream Method

Loads a diagram from the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void LoadFromStream (
Stream stream
)
Visual Basic

Public Sub LoadFromStream ( _
stream As Stream _
)

Parameters

stream
An instance of a Stream-derived class.

Remarks

The method loads previously saved diagram from a stream. Stream wraps sequences of bytes, such as files, memory buffers, TCP sockets and more. The method throws exception if the stream given as argument does not contain data of the proper format. Diagrams can be saved in a stream using the SaveToStream method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToStream
LoadFromFile
LoadFromXml


MindFusion.Diagramming.Diagram.LoadFromString Method

Diagram.LoadFromString Method

Decodes diagram contents from a string that was created with SaveToString.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void LoadFromString (
string str
)
Visual Basic

Public Sub LoadFromString ( _
str As String _
)

Parameters

str

A string containing the serialized diagram contents.

Remarks

Loads a diagram document from a string. The string must have been created by the SaveToString method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToStream
LoadFromFile


MindFusion.Diagramming.Diagram.LoadFromXml Method

Diagram.LoadFromXml Method

Loads the contents of an XML diagram document into the control.

Overload List

Name | Description
Diagram.LoadFromXml (String) | Loads the contents of the XML diagram document from the specified file into the control.
Diagram.LoadFromXml (XmlDocument) | Loads the contents of the XML diagram document represented by the specified XmlDocument into the control.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LoadFromFile Method
SaveToXml Method


MindFusion.Diagramming.Diagram.LoadFromXml Method (String)

Diagram.LoadFromXml Method (String)
See Also

Loads the contents of the XML diagram document from the specified file into the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void LoadFromXml (
string fileName
)
Visual Basic

Public Sub LoadFromXml ( _
fileName As String _
)

Parameters

fileName
The name of the XML file the data should be read from.

Remarks

The method reads a diagram previously saved via the SaveToXml method. This method is implemented by loading an XmlDocument from the specified file and calling the LoadFromXml overload.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToXml Method


MindFusion.Diagramming.Diagram.LoadFromXml Method (XmlDocument)

Diagram.LoadFromXml Method (XmlDocument)
See Also

Loads the contents of the XML diagram document represented by the specified XmlDocument into the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void LoadFromXml (
XmlDocument document
)
Visual Basic

Public Sub LoadFromXml ( _
document As XmlDocument _
)

Parameters

document
A .NET XmlDocument object from which to load the diagram data.

Remarks

The method reads a diagram previously saved via the SaveToXml method.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToXml Method


MindFusion.Diagramming.Diagram.MeasureString Method

Diagram.MeasureString Method

Measures a text taking into consideration the current affine transform of the diagram.

Overload List

Name | Description
Diagram.MeasureString (String, Font, Int32, StringFormat) | Measures the specified text when drawn with the specified font in an area with the specified width taking into consideration the current affine transform of the diagram.
Diagram.MeasureString (String, Font, RectangleF, StringFormat, Int32@, Int32@) | Measures the specified text when drawn with the specified font in the specified rectangle area taking into consideration the current affine transform of the diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.MeasureString Method (String, Font, Int32, StringFormat)

Diagram.MeasureString Method (String, Font, Int32, StringFormat)
See Also

Measures the specified text when drawn with the specified font in an area with the specified width taking into consideration the current affine transform of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeF MeasureString (
string text,
Font font,
int maxWidth,
StringFormat textFormat
)
Visual Basic

Public Function MeasureString ( _
text As String, _
font As Font, _
maxWidth As Integer, _
textFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
The font of the string.
maxWidth
The maximum width of the string.
textFormat
A StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a SizeF structure that represents the size of the string text when drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.MeasureString Method (String, Font, RectangleF, StringFormat, Int32@, Int32@)

Diagram.MeasureString Method (String, Font, RectangleF, StringFormat, Int32@, Int32@)
See Also

Measures the specified text when drawn with the specified font in the specified rectangle area taking into consideration the current affine transform of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeF MeasureString (
string text,
Font font,
RectangleF layoutArea,
StringFormat stringFormat,
ref int charactersFitted,
ref int linesFilled
)
Visual Basic

Public Function MeasureString ( _
text As String, _
font As Font, _
layoutArea As RectangleF, _
stringFormat As StringFormat, _
ByRef charactersFitted As Integer, _
ByRef linesFilled As Integer _
) As SizeF

Parameters

text
The string to measure.
font
The font of the string.
layoutArea
A RectangleF structure that specifies the maximum layout area for the text.
stringFormat
A StringFormat object that represents formatting information, such as line spacing, for the string.
charactersFitted
linesFilled

Return Value

This method returns a RectangleF structure that represents the size of the string text when drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.Navigate Method

Diagram.Navigate Method

Selects the nearest item in the specified direction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Navigate (
PointF directionVector
)
Visual Basic

Public Sub Navigate ( _
directionVector As PointF _
)

Parameters

directionVector
A PointF object specifying the direction vector.

Remarks

This method can be used to let users navigate through the diagram using the keyboard keys.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnActionRecorded Method

Diagram.OnActionRecorded Method

Raises the ActionRecorded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnActionRecorded (
UndoEventArgs e
)
Visual Basic

Protected Sub OnActionRecorded ( _
e As UndoEventArgs _
)

Parameters

e
An UndoEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnActionRecording Method

Diagram.OnActionRecording Method

Raises the ActionRecording event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnActionRecording (
UndoValidationEventArgs e
)
Visual Basic

Protected Sub OnActionRecording ( _
e As UndoValidationEventArgs _
)

Parameters

e

An UndoValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnActionRedone Method

Diagram.OnActionRedone Method

Raises the ActionRedone event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnActionRedone (
UndoEventArgs e
)
Visual Basic

Protected Sub OnActionRedone ( _
e As UndoEventArgs _
)

Parameters

e

An UndoEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnActionUndone Method

Diagram.OnActionUndone Method

Raises the ActionUndone event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnActionUndone (
UndoEventArgs e
)
Visual Basic

Protected Sub OnActionUndone ( _
e As UndoEventArgs _
)

Parameters

e

An UndoEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnBeginLoad Method

Diagram.OnBeginLoad Method

Raises the BeginLoad event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnBeginLoad (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnBeginLoad ( _
e As EventArgs _
)

Parameters

e

An EventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnCellClicked Method

Diagram.OnCellClicked Method

Raises the CellClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnCellClicked (
CellEventArgs e
)
Visual Basic

Protected Sub OnCellClicked ( _
e As CellEventArgs _
)

Parameters

e

A CellEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnCellDoubleClicked Method

Diagram.OnCellDoubleClicked Method

Raises the CellDoubleClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnCellDoubleClicked (
CellEventArgs e
)
Visual Basic

Protected Sub OnCellDoubleClicked ( _
e As CellEventArgs _
)

Parameters

e

A CellEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnCellTextEdited Method

Diagram.OnCellTextEdited Method

Raises the CellTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnCellTextEdited (
EditCellTextEventArgs e
)
Visual Basic

Protected Sub OnCellTextEdited ( _
e As EditCellTextEventArgs _
)

Parameters

e

An EditCellTextEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnCellTextEditing Method

Diagram.OnCellTextEditing Method

Raises the CellTextEditing event to validate entering in-place editing mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnCellTextEditing (
CellValidationEventArgs e
)
Visual Basic

Protected Sub OnCellTextEditing ( _
e As CellValidationEventArgs _
)

Parameters

e

A CellValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnClicked Method

Diagram.OnClicked Method

Raises the Clicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnClicked (
DiagramEventArgs e
)
Visual Basic

Protected Sub OnClicked ( _
e As DiagramEventArgs _
)

Parameters

e

A DiagramEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnContainerChildAdded Method

Diagram.OnContainerChildAdded Method

Raises the ContainerChildAdded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnContainerChildAdded (
ContainerChildEventArgs args
)
Visual Basic

Protected Sub OnContainerChildAdded ( _
args As ContainerChildEventArgs _
)

Parameters

args

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnContainerChildRemoved Method

Diagram.OnContainerChildRemoved Method

Raises the ContainerChildRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnContainerChildRemoved (
ContainerChildEventArgs args
)
Visual Basic

Protected Sub OnContainerChildRemoved ( _
args As ContainerChildEventArgs _
)

Parameters

args

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnContainerFolded Method

Diagram.OnContainerFolded Method

Raises the ContainerFolded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnContainerFolded (
NodeEventArgs e
)
Visual Basic

Protected Sub OnContainerFolded ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnContainerUnfolded Method

Diagram.OnContainerUnfolded Method

Raises the ContainerUnfolded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnContainerUnfolded (
NodeEventArgs e
)
Visual Basic

Protected Sub OnContainerUnfolded ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnDeserializeTag Method

Diagram.OnDeserializeTag Method

Raises the DeserializeTag event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnDeserializeTag (
SerializeTagEventArgs e
)
Visual Basic

Protected Overridable Sub OnDeserializeTag ( _
e As SerializeTagEventArgs _
)

Parameters

e

A SerializeTagEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnDestinationAnchorChanged Method

Diagram.OnDestinationAnchorChanged Method

Raises the DestinationAnchorChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnDestinationAnchorChanged (
AnchorPointEventArgs e
)
Visual Basic

Protected Sub OnDestinationAnchorChanged ( _
e As AnchorPointEventArgs _
)

Parameters

e

An AnchorPointEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnDoubleClicked Method

Diagram.OnDoubleClicked Method

Raises the DoubleClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnDoubleClicked (
DiagramEventArgs e
)
Visual Basic

Protected Sub OnDoubleClicked ( _
e As DiagramEventArgs _
)

Parameters

e

A DiagramEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnDrawAdjustmentHandles Method

Diagram.OnDrawAdjustmentHandles Method

Raises the DrawAdjustmentHandles event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnDrawAdjustmentHandles (
DrawItemEventArgs e
)
Visual Basic

Protected Sub OnDrawAdjustmentHandles ( _
e As DrawItemEventArgs _
)

Parameters

e

A DrawItemEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnDrawAnchorPoint Method

Diagram.OnDrawAnchorPoint Method

Raises the DrawAnchorPoint event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnDrawAnchorPoint (
DrawAnchorPointEventArgs e
)
Visual Basic

Protected Sub OnDrawAnchorPoint ( _
e As DrawAnchorPointEventArgs _
)

Parameters

e

A DrawAnchorPointEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnDrawBackground Method

Diagram.OnDrawBackground Method

Raises the DrawBackground event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnDrawBackground (
IGraphics graphics,
RectangleF visibleRect,
RectangleF clipRect
)
Visual Basic

Protected Overridable Sub OnDrawBackground ( _
graphics As IGraphics, _
visibleRect As RectangleF, _
clipRect As RectangleF _
)

Parameters

graphics
visibleRect
clipRect

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnDrawCell Method

Diagram.OnDrawCell Method

Raises the DrawCell event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnDrawCell (
DrawCellEventArgs e
)
Visual Basic

Protected Sub OnDrawCell ( _
e As DrawCellEventArgs _
)

Parameters

e

A DrawCellEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnDrawForeground Method

Diagram.OnDrawForeground Method

Raises the DrawForeground event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnDrawForeground (
IGraphics graphics,
RectangleF visibleRect,
RectangleF clipRect
)
Visual Basic

Protected Overridable Sub OnDrawForeground ( _
graphics As IGraphics, _
visibleRect As RectangleF, _
clipRect As RectangleF _
)

Parameters

graphics
visibleRect
clipRect

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnDrawLink Method

Diagram.OnDrawLink Method

Raises the DrawLink event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnDrawLink (
DrawLinkEventArgs e
)
Visual Basic

Protected Sub OnDrawLink ( _
e As DrawLinkEventArgs _
)

Parameters

e

A DrawLinkEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnDrawNode Method

Diagram.OnDrawNode Method

Raises the DrawNode event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnDrawNode (
DrawNodeEventArgs e
)
Visual Basic

Protected Sub OnDrawNode ( _
e As DrawNodeEventArgs _
)

Parameters

e

A DrawNodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnEndLoad Method

Diagram.OnEndLoad Method

Raises the EndLoad event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnEndLoad (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnEndLoad ( _
e As EventArgs _
)

Parameters

e

An EventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnExpandButtonClicked Method

Diagram.OnExpandButtonClicked Method

Raises the ExpandButtonClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnExpandButtonClicked (
NodeEventArgs e
)
Visual Basic

Protected Sub OnExpandButtonClicked ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnGroupDestroyed Method

Diagram.OnGroupDestroyed Method

Raises the GroupDestroyed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnGroupDestroyed (
GroupEventArgs e
)
Visual Basic

Protected Sub OnGroupDestroyed ( _
e As GroupEventArgs _
)

Parameters

e

A GroupEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnHitTestAdjustmentHandles Method

Diagram.OnHitTestAdjustmentHandles Method

Raises the HitTestAdjustmentHandles event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnHitTestAdjustmentHandles (
HitTestEventArgs e
)
Visual Basic

Protected Sub OnHitTestAdjustmentHandles ( _
e As HitTestEventArgs _
)

Parameters

e

A HitTestEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnInitializeLink Method

Diagram.OnInitializeLink Method

Raises the InitializeLink event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnInitializeLink (
LinkEventArgs e
)
Visual Basic

Protected Sub OnInitializeLink ( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnInitializeNode Method

Diagram.OnInitializeNode Method

Raises the InitializeNode event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnInitializeNode (
NodeEventArgs e
)
Visual Basic

Protected Sub OnInitializeNode ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnItemAdded Method

Diagram.OnItemAdded Method

Raises the ItemAdded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnItemAdded (
ItemEventArgs e
)
Visual Basic

Protected Sub OnItemAdded ( _
e As ItemEventArgs _
)

Parameters

e
An ItemEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnItemRemoved Method

Diagram.OnItemRemoved Method

Raises the ItemRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnItemRemoved (
ItemEventArgs e
)
Visual Basic

Protected Sub OnItemRemoved ( _
e As ItemEventArgs _
)

Parameters

e

An ItemEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkActivated Method

Diagram.OnLinkActivated Method

Raises the LinkActivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkActivated (
LinkEventArgs e
)
Visual Basic

Protected Sub OnLinkActivated ( _
e As LinkEventArgs _
)

Parameters

e
A LinkEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkClicked Method

Diagram.OnLinkClicked Method

Raises the LinkClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkClicked (
LinkEventArgs e
)
Visual Basic

Protected Sub OnLinkClicked ( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkCreated Method

Diagram.OnLinkCreated Method

Raises the LinkCreated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkCreated (
LinkEventArgs e
)
Visual Basic

Protected Sub OnLinkCreated ( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkCreating Method

Diagram.OnLinkCreating Method

Raises the LinkCreating event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkCreating (
LinkValidationEventArgs e
)
Visual Basic

Protected Sub OnLinkCreating ( _
e As LinkValidationEventArgs _
)

Parameters

e

A LinkValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkDeactivated Method

Diagram.OnLinkDeactivated Method

Raises the LinkDeactivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkDeactivated (
LinkEventArgs e
)
Visual Basic

Protected Sub OnLinkDeactivated ( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkDeleted Method

Diagram.OnLinkDeleted Method

Raises the LinkDeleted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkDeleted (
LinkEventArgs e
)
Visual Basic

Protected Sub OnLinkDeleted ( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkDeleting Method

Diagram.OnLinkDeleting Method

Raises the LinkDeleting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkDeleting (
LinkValidationEventArgs e
)
Visual Basic

Protected Sub OnLinkDeleting ( _
e As LinkValidationEventArgs _
)

Parameters

e

A LinkValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkDeselected Method

Diagram.OnLinkDeselected Method

Raises the LinkDeselected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkDeselected (
LinkEventArgs e
)
Visual Basic

Protected Sub OnLinkDeselected ( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkDoubleClicked Method

Diagram.OnLinkDoubleClicked Method

Raises the LinkDoubleClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkDoubleClicked (
LinkEventArgs e
)
Visual Basic

Protected Sub OnLinkDoubleClicked ( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkModified Method

Diagram.OnLinkModified Method

Raises the LinkModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkModified (
LinkEventArgs e
)
Visual Basic

Protected Sub OnLinkModified ( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkModifying Method

Diagram.OnLinkModifying Method

Raises the LinkModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkModifying (
LinkValidationEventArgs e
)
Visual Basic

Protected Sub OnLinkModifying ( _
e As LinkValidationEventArgs _
)

Parameters

e

A LinkValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkPasted Method

Diagram.OnLinkPasted Method

Raises the LinkModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkPasted (
LinkEventArgs e
)
Visual Basic

Protected Sub OnLinkPasted ( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkRouted Method

Diagram.OnLinkRouted Method

Raises the LinkRouted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkRouted (
LinkEventArgs e
)
Visual Basic

Protected Sub OnLinkRouted ( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkSelected Method

Diagram.OnLinkSelected Method

Raises the LinkSelected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkSelected (
LinkEventArgs e
)
Visual Basic

Protected Sub OnLinkSelected ( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkSelecting Method

Diagram.OnLinkSelecting Method

Raises the LinkSelecting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkSelecting (
LinkValidationEventArgs e
)
Visual Basic

Protected Sub OnLinkSelecting ( _
e As LinkValidationEventArgs _
)

Parameters

e

A LinkValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkStartModifying Method

Diagram.OnLinkStartModifying Method

Raises the LinkStartModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkStartModifying (
LinkValidationEventArgs e
)
Visual Basic

Protected Sub OnLinkStartModifying ( _
e As LinkValidationEventArgs _
)

Parameters

e

A LinkValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkTextEdited Method

Diagram.OnLinkTextEdited Method

Raises the LinkTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkTextEdited (
EditLinkTextEventArgs e
)
Visual Basic

Protected Sub OnLinkTextEdited ( _
e As EditLinkTextEventArgs _
)

Parameters

e
An EditLinkTextEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnLinkTextEditing Method

Diagram.OnLinkTextEditing Method

Raises the LinkTextEditing event to validate entering in-place editing mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnLinkTextEditing (
LinkValidationEventArgs e
)
Visual Basic

Protected Sub OnLinkTextEditing ( _
e As LinkValidationEventArgs _
)

Parameters

e
A LinkValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeActivated Method

Diagram.OnNodeActivated Method

Raises the NodeActivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeActivated (
NodeEventArgs e
)
Visual Basic

Protected Sub OnNodeActivated ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeClicked Method

Diagram.OnNodeClicked Method

Raises the NodeClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeClicked (
NodeEventArgs e
)
Visual Basic

Protected Sub OnNodeClicked ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeCreated Method

Diagram.OnNodeCreated Method

Raises the NodeCreated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeCreated (
NodeEventArgs e
)
Visual Basic

Protected Sub OnNodeCreated ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeCreating Method

Diagram.OnNodeCreating Method

Raises the NodeCreating event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeCreating (
NodeValidationEventArgs e
)
Visual Basic

Protected Sub OnNodeCreating ( _
e As NodeValidationEventArgs _
)

Parameters

e

A NodeValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeDeactivated Method

Diagram.OnNodeDeactivated Method

Raises the NodeDeactivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeDeactivated (
NodeEventArgs e
)
Visual Basic

Protected Sub OnNodeDeactivated ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeDeleted Method

Diagram.OnNodeDeleted Method

Raises the NodeDeleted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeDeleted (
NodeEventArgs e
)
Visual Basic

Protected Sub OnNodeDeleted ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeDeleting Method

Diagram.OnNodeDeleting Method

Raises the NodeDeleting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeDeleting (
NodeValidationEventArgs e
)
Visual Basic

Protected Sub OnNodeDeleting ( _
e As NodeValidationEventArgs _
)

Parameters

e

A NodeValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeDeselected Method

Diagram.OnNodeDeselected Method

Raises the NodeDeselected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeDeselected (
NodeEventArgs e
)
Visual Basic

Protected Sub OnNodeDeselected ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeDoubleClicked Method

Diagram.OnNodeDoubleClicked Method

Raises the NodeDoubleClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeDoubleClicked (
NodeEventArgs e
)
Visual Basic

Protected Sub OnNodeDoubleClicked ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeModified Method

Diagram.OnNodeModified Method

Raises the NodeModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeModified (
NodeEventArgs e
)
Visual Basic

Protected Sub OnNodeModified ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeModifying Method

Diagram.OnNodeModifying Method

Raises the NodeModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeModifying (
NodeValidationEventArgs e
)
Visual Basic

Protected Sub OnNodeModifying ( _
e As NodeValidationEventArgs _
)

Parameters

e

A NodeValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodePasted Method

Diagram.OnNodePasted Method

Raises the NodePasted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodePasted (
NodeEventArgs e
)
Visual Basic

Protected Sub OnNodePasted ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeSelected Method

Diagram.OnNodeSelected Method

Raises the NodeSelected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeSelected (
NodeEventArgs e
)
Visual Basic

Protected Sub OnNodeSelected ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeSelecting Method

Diagram.OnNodeSelecting Method

Raises the NodeSelecting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeSelecting (
NodeValidationEventArgs e
)
Visual Basic

Protected Sub OnNodeSelecting ( _
e As NodeValidationEventArgs _
)

Parameters

e

A NodeValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeStartModifying Method

Diagram.OnNodeStartModifying Method

Raises the NodeStartModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeStartModifying (
NodeValidationEventArgs e
)
Visual Basic

Protected Sub OnNodeStartModifying ( _
e As NodeValidationEventArgs _
)

Parameters

e

A NodeValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeTextEdited Method

Diagram.OnNodeTextEdited Method

Raises the NodeTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeTextEdited (
EditNodeTextEventArgs e
)
Visual Basic

Protected Sub OnNodeTextEdited ( _
e As EditNodeTextEventArgs _
)

Parameters

e

An EditNodeTextEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnNodeTextEditing Method

Diagram.OnNodeTextEditing Method

Raises the NodeTextEditing event to validate entering in-place editing mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnNodeTextEditing (
NodeValidationEventArgs e
)
Visual Basic

Protected Sub OnNodeTextEditing ( _
e As NodeValidationEventArgs _
)

Parameters

e

A NodeValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnOriginAnchorChanged Method

Diagram.OnOriginAnchorChanged Method

Raises the OriginAnchorChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnOriginAnchorChanged (
AnchorPointEventArgs e
)
Visual Basic

Protected Sub OnOriginAnchorChanged ( _
e As AnchorPointEventArgs _
)

Parameters

e

An AnchorPointEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnSelectionChanged Method

Diagram.OnSelectionChanged Method

Raises the SelectionChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnSelectionChanged (
EventArgs e
)
Visual Basic

Protected Sub OnSelectionChanged ( _
e As EventArgs _
)

Parameters

e

An EventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnSelectionMoved Method

Diagram.OnSelectionMoved Method

Raises the SelectionMoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnSelectionMoved (
EventArgs e
)
Visual Basic

Protected Sub OnSelectionMoved ( _
e As EventArgs _
)

Parameters

e

An EventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnSelectionMoving Method

Diagram.OnSelectionMoving Method

Raises the SelectionMoving event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnSelectionMoving (
ValidationEventArgs e
)
Visual Basic

Protected Sub OnSelectionMoving ( _
e As ValidationEventArgs _
)

Parameters

e

A ValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnSerializeTag Method

Diagram.OnSerializeTag Method

Raises the SerializeTag event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnSerializeTag (
SerializeTagEventArgs e
)
Visual Basic

Protected Overridable Sub OnSerializeTag ( _
e As SerializeTagEventArgs _
)

Parameters

e

A SerializeTagEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnTableSectionCollapsed Method

Diagram.OnTableSectionCollapsed Method

Raises the appropriate TableSection event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnTableSectionCollapsed (
RowEventArgs e
)
Visual Basic

Protected Sub OnTableSectionCollapsed ( _
e As RowEventArgs _
)

Parameters

e

A RowEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnTableSectionExpanded Method

Diagram.OnTableSectionExpanded Method

Raises the appropriate TableSection event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnTableSectionExpanded (
RowEventArgs e
)
Visual Basic

Protected Sub OnTableSectionExpanded ( _
e As RowEventArgs _
)

Parameters

e

A RowEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnTreeCollapsed Method

Diagram.OnTreeCollapsed Method

Raises the TreeCollapsed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnTreeCollapsed (
NodeEventArgs e
)
Visual Basic

Protected Sub OnTreeCollapsed ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnTreeExpanded Method

Diagram.OnTreeExpanded Method

Raises the TreeExpanded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnTreeExpanded (
NodeEventArgs e
)
Visual Basic

Protected Sub OnTreeExpanded ( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnValidateAnchorPoint Method

Diagram.OnValidateAnchorPoint Method

Raises the ValidateAnchorPoint event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnValidateAnchorPoint (
LinkValidationEventArgs e
)
Visual Basic

Protected Sub OnValidateAnchorPoint ( _
e As LinkValidationEventArgs _
)

Parameters

e

A LinkValidationEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.OnViewRemoved Method

Diagram.OnViewRemoved Method

Raises the ViewRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void OnViewRemoved (
CancelEventArgs e
)
Visual Basic

Protected Sub OnViewRemoved ( _
e As CancelEventArgs _
)

Parameters

e
A CancelEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.PasteSelection Method

Diagram.PasteSelection Method

Adds the specified items and groups to the specified diagram document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool PasteSelection (
Diagram doc,
SelectionCopy data,
CompositeCmd cmd,
float dx,
float dy
)
Visual Basic

Public Function PasteSelection ( _
doc As Diagram, _
data As SelectionCopy, _
cmd As CompositeCmd, _
dx As Single, _
dy As Single _
) As Boolean

Parameters

doc
A Diagram object to which the items should be added.
data
A SelectionCopy object returned by a previous call to CopySelection.
cmd
A CompositeCmd object where the items state should be recorded for later undo or redo.
dx
Horizontal offset of pasted items from their original positions.
dy
Vertical offset of pasted items from their original positions.

Return Value

true if data contains any items; otherwise, false.

Remarks

This method can be used in conjunction with CopySelection to copy selected items from one Diagram instance to another.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
CopySelection


MindFusion.Diagramming.Diagram.PixelToUnit Method

Diagram.PixelToUnit Method

Converts the specified point from client to document coordinates ignoring the current scale transformation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF PixelToUnit (
Point point
)
Visual Basic

Public Function PixelToUnit ( _
point As Point _
) As PointF

Parameters

point

The Point instance to convert.

Return Value

A PointF representing the diagram coordinates of the client point specified as an argument.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseCellTextEdited Method

Diagram.RaiseCellTextEdited Method

Raises the CellTextEdited event .

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void RaiseCellTextEdited (
TableNode.Cell cell,
string oldText,
string newText,
int column,
int row
)
Visual Basic

Public Sub RaiseCellTextEdited ( _
cell As TableNode.Cell, _
oldText As String, _
newText As String, _
column As Integer, _
row As Integer _
)

Parameters

cell

The TableNode.Cell related to the event.

oldText

The old text of the cell.

newText

The new text of the cell.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseCellTextEditing Method

Diagram.RaiseCellTextEditing Method

Raises the CellTextEditing event to validate entering in-place editing mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RaiseCellTextEditing (
TableNode table,
int column,
int row
)
Visual Basic

Public Function RaiseCellTextEditing ( _
table As TableNode, _
column As Integer, _
row As Integer _
) As Boolean

Parameters

table

The TableNode related to the event.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

Return Value

true if the in-place editing operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseClicked Method

Diagram.RaiseClicked Method

Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items.

Overload List

Name | Description
Diagram.RaiseClicked (DiagramItem, PointF, MouseButton) | Raises the appropriate *Clicked event according to the type of the specified item.
Diagram.RaiseClicked (MouseButton, PointF) | Raises the Clicked event of the Diagram class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseClicked Method (DiagramItem, PointF, MouseButton)

Diagram.RaiseClicked Method (DiagramItem, PointF, MouseButton)
See Also

Raises the appropriate *Clicked event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void RaiseClicked (
DiagramItem item,
PointF mousePosition,
MouseButton mouseButton
)
Visual Basic

Public Sub RaiseClicked ( _
item As DiagramItem, _
mousePosition As PointF, _
mouseButton As MouseButton _
)

Parameters

item

The DiagramItem related to the event.

mousePosition

The current mouse position, in document coordinates.

mouseButton

The mouse button related to the event.

See Also

RaiseClicked Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseClicked Method (MouseButton, PointF)

Diagram.RaiseClicked Method (MouseButton, PointF)
See Also

Raises the Clicked event of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void RaiseClicked (
MouseButton mouseButton,
PointF mousePosition
)
Visual Basic

Public Sub RaiseClicked ( _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

mouseButton
The mouse button related to the event.
mousePosition

The current cursor position, in document coordinates.

See Also

RaiseClicked Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseCreated Method

Diagram.RaiseCreated Method

Raises the appropriate *Created event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void RaiseCreated (
DiagramItem item
)
Visual Basic

Public Sub RaiseCreated ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem related to the event.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseDeleting Method

Diagram.RaiseDeleting Method

Raises the appropriate *Deleting event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RaiseDeleting (
DiagramItem item
)
Visual Basic

Public Function RaiseDeleting ( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem related to the event.

Return Value

true if the operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseDoubleClicked Method

Diagram.RaiseDoubleClicked Method

Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items.

Overload List

Name | Description
Diagram.RaiseDoubleClicked (DiagramItem, PointF, MouseButton) | Raises the appropriate *DoubleClicked event according to the type of the specified item.
Diagram.RaiseDoubleClicked (MouseButton, PointF) | Raises the DoubleClicked event of the Diagram class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseDoubleClicked Method (DiagramItem, PointF, MouseButton)

Diagram.RaiseDoubleClicked Method (DiagramItem, PointF, MouseButton)
See Also

Raises the appropriate *DoubleClicked event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void RaiseDoubleClicked (
DiagramItem item,
PointF mousePosition,
MouseButton mouseButton
)
Visual Basic

Public Sub RaiseDoubleClicked ( _
item As DiagramItem, _
mousePosition As PointF, _
mouseButton As MouseButton _
)

Parameters

item

The DiagramItem related to the event.

mousePosition

The current cursor position, in document coordinates.

mouseButton

The mouse button related to the event.

See Also

RaiseDoubleClicked Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseDoubleClicked Method (MouseButton, PointF)

Diagram.RaiseDoubleClicked Method (MouseButton, PointF)
See Also

Raises the DoubleClicked event of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void RaiseDoubleClicked (
MouseButton mouseButton,
PointF mousePosition
)
Visual Basic

Public Sub RaiseDoubleClicked ( _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

mouseButton

The mouse button related to the event.

mousePosition

The current cursor position, in document coordinates.

See Also

RaiseDoubleClicked Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseLinkTextEdited Method

Diagram.RaiseLinkTextEdited Method

Raises the LinkTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void RaiseLinkTextEdited (
DiagramLink link,
string oldText,
string newText
)
Visual Basic

Public Sub RaiseLinkTextEdited ( _
link As DiagramLink, _
oldText As String, _
newText As String _
)

Parameters

link
The DiagramLink related to the event.
oldText

The old text of the link.

newText

The new text of the link.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseLinkTextEditing Method

Diagram.RaiseLinkTextEditing Method

Raises the LinkTextEditing event to validate entering in-place editing mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RaiseLinkTextEditing (
DiagramLink link
)
Visual Basic

Public Function RaiseLinkTextEditing ( _
link As DiagramLink _
) As Boolean

Parameters

link

The DiagramLink related to the event.

Return Value

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseNodeTextEdited Method

Diagram.RaiseNodeTextEdited Method

Raises the NodeTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void RaiseNodeTextEdited (
DiagramNode node,
string oldText,
string newText
)
Visual Basic

Public Sub RaiseNodeTextEdited ( _
node As DiagramNode, _
oldText As String, _
newText As String _
)

Parameters

node

The DiagramNode related to the event.

oldText

The old text of the node.

newText

The new text of the node.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseNodeTextEditing Method

Diagram.RaiseNodeTextEditing Method

Raises the NodeTextEditing event to validate entering in-place editing mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RaiseNodeTextEditing (
DiagramNode node
)
Visual Basic

Public Function RaiseNodeTextEditing ( _
node As DiagramNode _
) As Boolean

Parameters

node

The DiagramNode related to the event.

Return Value

true if the in-place editing operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaisePasted Method

Diagram.RaisePasted Method

Raises the appropriate Pasted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void RaisePasted (
DiagramItem item
)
Visual Basic

Public Sub RaisePasted ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem related to the event.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseSelecting Method

Diagram.RaiseSelecting Method

Raises the appropriate Selecting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RaiseSelecting (
DiagramItem item,
PointF mousePosition
)
Visual Basic

Public Function RaiseSelecting ( _
item As DiagramItem, _
mousePosition As PointF _
) As Boolean

Parameters

item

The DiagramItem related to the event.

mousePosition

The current mouse position, in document coordinates.

Return Value

true if the operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RaiseViewRemoved Method

Diagram.RaiseViewRemoved Method

Raises the ViewRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void RaiseViewRemoved ()
Visual Basic

Public Sub RaiseViewRemoved ()

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.RegisterItemClass Method

Diagram.RegisterItemClass Method

Registers a diagram item class for serialization support.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static void RegisterItemClass (
Type itemClass,
string classId,
int classVersion
)
Visual Basic

Public Shared Sub RegisterItemClass ( _
itemClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

itemClass
A Type instance identifying the item class.
classId
A class identifier to use when saving and loading items of the specified type.
classVersion
A revision number of the item's class serialization format.

Remarks

When using custom item types, use this method to enable saving and loading the custom item instances to/from XML or binary files. The class id string is written before each item's data, and when loading items later that string indicates what class instance to create and let it load the subsequent data. The following class identifiers are reserved and should not be used by your application: "std:DiagramLink", "std:ShapeNode", "std:TableNode", "std:ContainerNode" and "std:ControlNode".

The version identifier must be increased when the format in which items are saved changes. It can be used when loading files to let your application load items data from an older format.

Note

All custom item classes must provide a parameterless constructor, or one that takes a Diagram argument. Failing to do so would result in exceptions during the load process, since the diagram will be unable to create items from the custom type.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ResizeToFitItem Method

Diagram.ResizeToFitItem Method

Resizes the document extents so that the specified item is contained within.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ResizeToFitItem (
DiagramItem item
)
Visual Basic

Public Sub ResizeToFitItem ( _
item As DiagramItem _
)

Parameters

item

The diagram item contained in the document area.

Remarks

Resizes the document area to fit the specified diagram item.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ResizeToFitItems Method
AutoResize Property


MindFusion.Diagramming.Diagram.ResizeToFitItems Method

Diagram.ResizeToFitItems Method

Resizes the document scrollable area so it fits all diagram items.

Overload List

Name | Description
Diagram.ResizeToFitItems (Single) | Resizes the document scrollable area so it fits all diagram items.
Diagram.ResizeToFitItems (Single, Boolean) | Resizes the document scrollable area so it fits all diagram items, optionally considering ony the visible items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AutoResize Property
Bounds Property


MindFusion.Diagramming.Diagram.ResizeToFitItems Method (Single)

Diagram.ResizeToFitItems Method (Single)
See Also

Resizes the document scrollable area so it fits all diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ResizeToFitItems (
float borderGap
)
Visual Basic

Public Sub ResizeToFitItems ( _
borderGap As Single _
)

Parameters

borderGap
A gap that should be left as a border around the diagram.

Remarks

Resizes the document area to be just as big as needed, for example, the smallest rectangle containing all diagram items. For aesthetic reasons, additional space can be left around the outmost items as a margin. Invoking the method on an empty document produces no result.

See Also

ResizeToFitItems Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AutoResize Method
Bounds Property


MindFusion.Diagramming.Diagram.ResizeToFitItems Method (Single, Boolean)

Diagram.ResizeToFitItems Method (Single, Boolean)
See Also

Resizes the document scrollable area so it fits all diagram items, optionally considering ony the visible items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ResizeToFitItems (
float borderGap,
bool onlyVisible
)
Visual Basic

Public Sub ResizeToFitItems ( _
borderGap As Single, _
onlyVisible As Boolean _
)

Parameters

borderGap

A gap that should be left as a border around the diagram.

onlyVisible
Specifies whether only the bounds of the Visible items should be included in the new document area.

Remarks

Resizes the document area to be just as big as needed, for example the smallest rectangle containing all diagram items. For aesthetic reasons, additional space can be left around the outmost items as a margin. Invoking the method on an empty document produces no result.

See Also

ResizeToFitItems Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AutoResize Method
Bounds Property


MindFusion.Diagramming.Diagram.RouteAllLinks Method

Diagram.RouteAllLinks Method

Routes all links in the diagram in a way they do not cross nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void RouteAllLinks ()
Visual Basic

Public Sub RouteAllLinks ()

Remarks

Each link is routed so that it goes the shortest possible way between the nodes it links without crossing any other nodes. To do so, this method might modify the number of link segments. The value of AutoRoute is not considered when RouteAllLinks executes.

RoutingOptions allows tuning the routing algorithm. The most important options are the cost values exposed as LengthCost, TurnCost and CrossingCost properties. They greatly influence the shape of the generated route.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
RouteLinks Property


MindFusion.Diagramming.Diagram.SaveToFile Method

Diagram.SaveToFile Method

Saves the binary contents of the diagram to a disk file.

Overload List

Name | Description
Diagram.SaveToFile (String) | Saves the binary contents of a diagram to the specified file.
Diagram.SaveToFile (String, Boolean) | Saves the binary contents of a diagram to the specified file, optionally clearing the Dirty flag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToXml Method


MindFusion.Diagramming.Diagram.SaveToFile Method (String)

Diagram.SaveToFile Method (String)
See Also

Saves the binary contents of a diagram to the specified file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveToFile (
string fileName
)
Visual Basic

Public Sub SaveToFile ( _
fileName As String _
)

Parameters

fileName
The full path and name of the disk file where the diagram should be saved.

Remarks

SaveToFile creates a file stream and invokes the SaveToStream method on it. The file contents can be loaded later using the LoadFromFile method.

See Also

SaveToFile Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToXml Method


MindFusion.Diagramming.Diagram.SaveToFile Method (String, Boolean)

Diagram.SaveToFile Method (String, Boolean)
See Also

Saves the binary contents of a diagram to the specified file, optionally clearing the Dirty flag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveToFile (
string fileName,
bool clearDirty
)
Visual Basic

Public Sub SaveToFile ( _
fileName As String, _
clearDirty As Boolean _
)

Parameters

fileName
The full path and name of the disk file where the diagram should be saved.
clearDirty
Indicates whether the Dirty flag should be cleared.

Remarks

SaveToFile creates a file stream and invokes the SaveToStream method on it. The file contents can be loaded later using the LoadFromFile method.

See Also

SaveToFile Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToXml Method


MindFusion.Diagramming.Diagram.SaveToStream Method

Diagram.SaveToStream Method

Saves the binary contents of the diagram to a .NET stream.

Overload List

Name | Description
Diagram.SaveToStream (Stream) | Saves the binary contents of the diagram to the specified .NET stream.
Diagram.SaveToStream (Stream, Boolean) | Saves the binary contents of a diagram to the specified .NET stream, optionally clearing the Dirty flag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToFile Method
SaveToXml Method


MindFusion.Diagramming.Diagram.SaveToStream Method (Stream)

Diagram.SaveToStream Method (Stream)
See Also

Saves the binary contents of the diagram to the specified .NET stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveToStream (
Stream stream
)
Visual Basic

Public Sub SaveToStream ( _
stream As Stream _
)

Parameters

stream
An instance of a System.IO.Stream-derived class.

Remarks

Serializes the current diagram as a sequence of bytes represented by stream. The stream may wrap a file, a memory buffer, a TCP socket, and more. The stream contents can be loaded later using the LoadFromStream method.

See Also

SaveToStream Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToFile Method
SaveToXml Method


MindFusion.Diagramming.Diagram.SaveToStream Method (Stream, Boolean)

Diagram.SaveToStream Method (Stream, Boolean)
See Also

Saves the binary contents of a diagram to the specified .NET stream, optionally clearing the Dirty flag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveToStream (
Stream stream,
bool clearDirty
)
Visual Basic

Public Sub SaveToStream ( _
stream As Stream, _
clearDirty As Boolean _
)

Parameters

stream
An instance of a System.IO.Stream-derived class.
clearDirty
Indicates whether the Dirty flag should be cleared.

Remarks

Serializes the current diagram as a sequence of bytes represented by stream. The stream may wrap a file, a memory buffer, a TCP socket, and more. The stream contents can be loaded later using the LoadFromStream method.

See Also

SaveToStream Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToFile Method
SaveToXml Method


MindFusion.Diagramming.Diagram.SaveToString Method

Diagram.SaveToString Method

Encodes the diagram contents into an ASCII string.

Overload List

Name | Description
Diagram.SaveToString () | Encodes the diagram contents into an ASCII string.
Diagram.SaveToString (SaveToStringFormat, Boolean) | Encodes the diagram contents into an ASCII string using the specified format and optionally clearing the Dirty flag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LoadFromString Method
SaveToFile Method


MindFusion.Diagramming.Diagram.SaveToString Method ()

Diagram.SaveToString Method ()
See Also

Encodes the diagram contents into an ASCII string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string SaveToString ()
Visual Basic

Public Function SaveToString () As String

Return Value

A string containing the encoded diagram data.

Remarks

The Base16 and Base64 formats represent the data returned by SaveToStream as an ASCII string. There are no special characters in the returned string, so the result can be easily stored in a database field or embedded into an XML document. That might be used also for transferring a diagram between a web page with embedded MindFusion.Diagramming and a web server, passing the string as a value of a hidden HTML field.

When using Xml or CompressedXml as the first argument, the diagram is saved in XML format. The same format is supported by the SaveToXml and LoadFromXml methods. CompressedXml specifies that the XML document should be further compressed in ZIP format and base-64 encoded.

See Also

SaveToString Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LoadFromString Method
SaveToFile Method


MindFusion.Diagramming.Diagram.SaveToString Method (SaveToStringFormat, Boolean)

Diagram.SaveToString Method (SaveToStringFormat, Boolean)
See Also

Encodes the diagram contents into an ASCII string using the specified format and optionally clearing the Dirty flag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string SaveToString (
SaveToStringFormat format,
bool clearDirty
)
Visual Basic

Public Function SaveToString ( _
format As SaveToStringFormat, _
clearDirty As Boolean _
) As String

Parameters

format
A member of the SaveToStringFormat enumeration.
clearDirty

Indicates whether the Dirty flag should be cleared.

Return Value

A string containing the encoded diagram data.

Remarks

The Base16 and Base64 formats represent the data returned by SaveToStream as an ASCII string. There are no special characters in the returned string, so the result can be easily stored in a database field or embedded into an XML document. That might be used also for transferring a diagram between a web page with embedded MindFusion.Diagramming and a web server, passing the string as a value of a hidden HTML field.

When using Xml or CompressedXml as the first argument, the diagram is saved in XML format. The same format is supported by the SaveToXml and LoadFromXml methods. CompressedXml specifies that the XML document should be further compressed in ZIP format and base-64 encoded.

Exceptions

Exception type | Condition
NotImplementedException | When saving the diagram using the CompressedXml flag under .NET Framework 1.1 or earlier.

See Also

SaveToString Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LoadFromString Method
SaveToFile Method


MindFusion.Diagramming.Diagram.SaveToXml Method

Diagram.SaveToXml Method

Saves the diagram to an XML document.

Overload List

Name | Description
Diagram.SaveToXml (String) | Saves the diagram to the specified file as an XML document.
Diagram.SaveToXml (XmlDocument) | Saves the diagram to the specified XML document.
Diagram.SaveToXml (XmlDocument, Boolean) | Saves the diagram to the specified XML document.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToFile Method


MindFusion.Diagramming.Diagram.SaveToXml Method (String)

Diagram.SaveToXml Method (String)
See Also

Saves the diagram to the specified file as an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveToXml (
string fileName
)
Visual Basic

Public Sub SaveToXml ( _
fileName As String _
)

Parameters

fileName
The full path and name of the disk file where the diagram should be saved.

Remarks

The first overloaded SaveToXml method works by creating an XmlDocument instance, calling the second overloaded method, and writing the document content to a file.

Diagram data can be loaded from an XML file or document using the LoadFromXml method.

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToFile Method


MindFusion.Diagramming.Diagram.SaveToXml Method (XmlDocument)

Diagram.SaveToXml Method (XmlDocument)
See Also

Saves the diagram to the specified XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void SaveToXml (
XmlDocument document
)
Visual Basic

Public Overridable Sub SaveToXml ( _
document As XmlDocument _
)

Parameters

document
A .NET XmlDocument object where the diagram should be saved.

Remarks

Diagram data can be loaded from an XML file or document using the LoadFromXml method.

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToFile Method


MindFusion.Diagramming.Diagram.SaveToXml Method (XmlDocument, Boolean)

Diagram.SaveToXml Method (XmlDocument, Boolean)
See Also

Saves the diagram to the specified XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void SaveToXml (
XmlDocument document,
bool includeUnalteredProperties
)
Visual Basic

Public Overridable Sub SaveToXml ( _
document As XmlDocument, _
includeUnalteredProperties As Boolean _
)

Parameters

document
A .NET XmlDocument object where the diagram should be saved.
includeUnalteredProperties
true if properties that have their default value should be saved; otherwise, false.

Remarks

Diagram data can be loaded from an XML file or document using the LoadFromXml method.

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.SetShadowOffset Method

Diagram.SetShadowOffset Method

Sets the default offset at which items shadows are drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SetShadowOffset (
float x,
float y
)
Visual Basic

Public Sub SetShadowOffset ( _
x As Single, _
y As Single _
)

Parameters

x

The horizontal offset of the item shadow.

y
The vertical offset of the item shadow.

Remarks

Use the method to draw shadows that are closer or further to the item they belong to. The values are applied respectively to the ShadowOffsetX and ShadowOffsetY properties.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShadowOffsetX Property
ShadowOffsetY Property
ShadowColor


MindFusion.Diagramming.Diagram.UnitToPixel Method

Diagram.UnitToPixel Method

Converts the specified point from document to client coordinates ignoring the current scale transformation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Point UnitToPixel (
PointF point
)
Visual Basic

Public Function UnitToPixel ( _
point As PointF _
) As Point

Parameters

point
The PointF instance to convert.

Return Value

A Point representing the client coordinates of the diagram point specified as an argument.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram Properties

Diagram Properties

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element.
ActiveItemHandlesColor | Gets or sets the color of the adjustment handles of the active item.
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects.
AlignToGrid | Gets or sets a value indicating whether the diagram items is aligned to a grid.
AllowLinksRepeat | Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes.
AllowSelfLoops | Gets or sets a value indicating whether self-loops are allowed.
AllowSplitLinks | Gets or sets a value indicating whether link segments can be added and removed interactively.
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node.
AutoResize | Gets or sets a value indicating whether the document area must be resized automatically so it fits the diagram contents.
BackBrush | Gets or sets the brush used for painting the diagram background.
BackgroundImage | Gets or sets the image displayed as background of this diagram.
BackgroundImageAlign | Gets or sets a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area.
BackgroundImageUrl | URL of the image painted as diagram's background.
Bounds | Gets or sets a value representing the size of the diagram's scrollable area.
BoundsPen | The pen with which the document bounds should be drawn.
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables.
CellFrameStyle | Gets or sets the default cell border style of new tables.
ContainerCaption | Gets or sets the default value for the Caption property of containers.
ContainerCaptionHeight | Gets or sets the default value for the CaptionHeight property of containers.
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers.
ContainerMargin | Gets or sets the default value for the Margin property of containers.
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers.
ContainersFoldable | Gets or sets the default value for the Foldable property of containers.
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points.
DefaultShape | Gets or sets the default shape of shape nodes.
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save.
DisabledHandlesColor | Gets or sets the color of disabled manipulation handles.
DynamicLinks | Gets or sets the default value for the Dynamic property of new links.
EffectsProvider | Gets or sets an object used to generate visual effects for shape nodes such as embossment and shadow dispersion.
EnableEmbossEffects | Gets or sets a value indicating whether emboss effect for shape nodes is enabled.
EnableLanes | Gets or sets whether lanes are enabled.
EnableShadowEffects | Gets or sets a value indicating whether the shadow dispersion effect for nodes is enabled.
EnableStyledText | Gets or sets the default value for the EnableStyledText property of new nodes.
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes.
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes.
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded.
ExteriorBrush | Gets or sets the brush used for painting the area outside Bounds.
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram.
Font | Gets or sets the default font for new diagram items.
GridColor | Gets or sets the color of the grid points.
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid.
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid.
GridSizeX | Gets or sets the horizontal distance between adjacent grid points.
GridSizeY | Gets or sets the vertical distance between adjacent grid points.
GridStyle | Gets or sets the visual style of the alignment grid.
Groups | Gets a collection of all groups in the diagram.
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested.
Interaction | Gets an InteractionState instance representing the current action being carried out by the user.
IsProEdition | Gets a value indicating whether the currently loaded MindFusion.Diagramming is a professional version of the control.
IsTrialVersion | Gets a value indicating whether the currently loaded MindFusion.Diagramming is a trial version of the control.
Items | Gets a collection of all items in this diagram.
LaneGrid | Gets the Grid instance that represents the lane grid.
LinkBaseShape | Gets or sets the shape displayed at the base of new links.
LinkBaseShapeSize | Gets or sets the default size of the base of new links.
LinkBrush | Gets or sets the default value for the Brush property of links.
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links.
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths.
LinkCustomDraw | Gets or sets the default type of custom painting done on links.
LinkEndsMovable | Gets or sets a value indicating whether link ends can be moved by users after the link is created.
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links.
LinkHeadShape | Gets or sets the shape displayed as head of new links.
LinkHeadShapeSize | Gets or sets the default size of arrowheads.
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit.
LinkIntermediateShape | Gets or sets the default shape to be displayed in the middle of each segment of links.
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments.
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links.
Links | Gets a collection of all DiagramLink objects in the diagram.
LinkSegments | Gets or sets the default number of link segments.
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around.
LinksSnapToBorders | Gets or sets the default value for the SnapToNodeBorder property of new links.
LinkStyle | Gets or sets the default style of diagram links.
LinkText | Gets or sets the default text of links.
LinkTextStyle | Gets or sets default placement and orientation for links' text.
MeasureTextRenderingHint | Gets or sets the TextRenderingHint to use when measuring texts. This should be effectively set to the value of DiagramView.TextRenderingHint.
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram.
MergeThreshold | Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged.
Nodes | Gets a collection of all DiagramNode objects in the diagram.
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded.
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file.
PolygonalTextLayout | Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines.
RecursiveExpand | Gets or sets value indicating how a tree is expanded.
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments.
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles.
RouteLinks | Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm.
ScriptHelper | Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods.
SelectAfterCreate | Gets or sets a value indicating whether newly created objects are automatically selected.
SelectedItemHandlesColor | Gets or sets the color of the manipulation handles of selected objects.
Selection | Gets a Selection instance that represents the selection of items in this diagram.
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items.
ShadowColor | Gets or sets the default color used to paint the shadows cast by diagram items.
ShadowOffsetX | Gets or sets the horizontal offset of item shadows.
ShadowOffsetY | Gets or sets the vertical offset of item shadows.
ShadowsStyle | Gets or sets the style for rendering shadows.
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes.
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes.
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes.
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes.
ShapePen | Gets or sets the default value for the Pen property of shape nodes.
ShapeText | Gets or sets the default text of shape nodes.
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed.
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled.
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible.
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified.
SnapToAnchor | Gets or sets when link end points should be aligned to the nearest anchor points.
SortGroupsByZ | Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved.
TableBrush | Gets or sets the default value for the Brush property of tables.
TableCaption | Gets or sets the default text for tables' captions.
TableCaptionHeight | Gets or sets the default height of table captions.
TableColumnCount | Gets or sets the default number of table columns.
TableColumnWidth | Gets or sets the default width of tables' columns.
TableConnectionStyle | Gets or sets a value indicating whether drawing a link between tables should connect the rows of those tables, or the tables as whole entities.
TableCustomDraw | Gets or sets the default type of custom painting done on tables.
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables.
TablePen | Gets or sets the default value for the Pen property of tables.
TableRowCount | Gets or sets the default number of table rows.
TableRowHeight | Gets or sets the default height of tables' rows.
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables.
TableStyle | Gets or sets the default value of the Style property of new tables.
Tag | Gets or sets custom data associated with this diagram.
TextColor | Gets or sets the default color of text displayed inside diagram items.
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram.
UndoManager | Gets a reference to the diagram's UndoManager instance.
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram.

See Also

Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ActiveItem Property

Diagram.ActiveItem Property

Gets or sets the active diagram element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem ActiveItem { get; set; }
Visual Basic

Public Property ActiveItem As DiagramItem

Property Value

A reference to the DiagramItem instance that is currently active.

Remarks

Use this property to get the active item - the one selected by the user or the last put in a multiple Selection. It is shown with white selection handles by default.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ActiveItemHandlesColor Property
SelectionOnTop Property


MindFusion.Diagramming.Diagram.ActiveItemHandlesColor Property

Diagram.ActiveItemHandlesColor Property

Gets or sets the color of the adjustment handles of the active item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color ActiveItemHandlesColor { get; set; }
Visual Basic

Public Property ActiveItemHandlesColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.FromArgb(255, 255, 255).

Remarks

Use the property to specify the color in which the manipulation handles that appear around the active item are painted.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SelectedItemHandlesColor Property
DisabledHandlesColor Property


MindFusion.Diagramming.Diagram.AdjustmentHandlesSize Property

Diagram.AdjustmentHandlesSize Property

Gets or sets the size of the handles, which appear around selected objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float AdjustmentHandlesSize { get; set; }
Visual Basic

Public Property AdjustmentHandlesSize As Single

Property Value

A float value specifying the height of the selection handles. The default is 2.

Remarks

Use the property to set the size of the manipulation handles, which appear around selected items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ModificationStart Property
SelectedItemHandlesColor Property


MindFusion.Diagramming.Diagram.AlignToGrid Property

Diagram.AlignToGrid Property

Gets or sets a value indicating whether the diagram items is aligned to a grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AlignToGrid { get; set; }
Visual Basic

Public Property AlignToGrid As Boolean

Property Value

true if the grid is activated; otherwise, false. The default is true.

Remarks

When the property is set to true, the sides of every newly created diagram item are aligned to the nearest grid points.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
GridColor Property
GridSizeX
GridSizeY
AlignPointToGrid


MindFusion.Diagramming.Diagram.AllowLinksRepeat Property

Diagram.AllowLinksRepeat Property

Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowLinksRepeat { get; set; }
Visual Basic

Public Property AllowLinksRepeat As Boolean

Property Value

true if repeated links are allowed; otherwise, false. The default is true.

Remarks

Specifies whether more than one link can connect the same origin and destination diagram nodes. If set to false, two diagram nodes can be connected with at most one link in a single direction.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AllowSelfLoops Property


MindFusion.Diagramming.Diagram.AllowSelfLoops Property

Diagram.AllowSelfLoops Property

Gets or sets a value indicating whether self-loops are allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowSelfLoops { get; set; }
Visual Basic

Public Property AllowSelfLoops As Boolean

Property Value

true if self loops are allowed; otherwise, false. The default is true.

Remarks

Use the property to specify whether the user is allowed to draw self loops - links that connect a node to itself.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AllowLinksRepeat Property


MindFusion.Diagramming.Diagram.AllowSplitLinks Property

Diagram.AllowSplitLinks Property

Gets or sets a value indicating whether link segments can be added and removed interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowSplitLinks { get; set; }
Visual Basic

Public Property AllowSplitLinks As Boolean

Property Value

true if interactive adding/removing of link segments allowed; false if not.

Remarks

Allows users insert new link segments interactively by clicking and dragging a point of a link's segment. For polyline-style link this creates one additional segment by splitting the existing one into two parts. For cascading links there are two segments inserted, keeping intact the alternating pattern of horizontal and vertical segments, each orthogonal to its neighbors. Bézier-style links cannot be split in the current MindFusion.Diagramming version.

Segments can be merged by moving their joining point until the angle between reaches certain threshold value. In case of cascading-style links, segments can be merged by placing adjacent control points close one to the other, as set in MergeThreshold.

This property also affects how users can change the orientation of cascading links. For more details see CascadeOrientation.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkSegments Property
LinkStyle Property


MindFusion.Diagramming.Diagram.AllowUnanchoredLinks Property

Diagram.AllowUnanchoredLinks Property

Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowUnanchoredLinks { get; set; }
Visual Basic

Public Property AllowUnanchoredLinks As Boolean

Property Value

true to let links connect to nodes without anchor points; otherwise, false. The default is true.

Remarks

AllowUnanchoredLinks applies to nodes whose AnchorPattern is not set or does not contain incoming or outgoing anchor points available. If the property is enabled, users can connect links to any point of such nodes. If disabled, users cannot connect links to such nodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AnchorPoint.AllowIncoming Property
AnchorPoint.AllowOutgoing Property


MindFusion.Diagramming.Diagram.AllowUnconnectedLinks Property

Diagram.AllowUnconnectedLinks Property

Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowUnconnectedLinks { get; set; }
Visual Basic

Public Property AllowUnconnectedLinks As Boolean

Property Value

true to allow drawing unconnected links; otherwise, false. The default is false.

Remarks

If the property is set to true, users will be able to draw links from or to any point of the document. Depending on which end of a link is unconnected, its Origin or Destination nodes might be of type DummyNode.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AllowUnanchoredLinks Property


MindFusion.Diagramming.Diagram.AutoResize Property

Diagram.AutoResize Property

Gets or sets a value indicating whether the document area must be resized automatically so it fits the diagram contents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AutoResize AutoResize { get; set; }
Visual Basic

Public Property AutoResize As AutoResize

Property Value

A member of the AutoResize enumeration. The default is AutoResize.RightAndDown.

Remarks

If automatic resizing is enabled, the size of the document scrollable area is updated each time an item is created, deleted or moved, either by end-users or by calling of methods. The following AutoResize values specify in what directions the diagram area is allowed to grow:

Member name | Description
None | Do not enlarge the diagram area automatically.
RightAndDown | Enlarge the diagram area to the right and down if an item is moved outside the boundaries in these directions.
AllDirections | Enlarge the diagram area in any direction if an item is moved outside the boundaries.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Bounds Property
ResizeToFitItems Method


MindFusion.Diagramming.Diagram.BackBrush Property

Diagram.BackBrush Property

Gets or sets the brush used for painting the diagram background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Brush BackBrush { get; set; }
Visual Basic

Public Property BackBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class. The default is a solid brush initialized with Color.FromArgb(170, 170, 200).

Remarks

This property enables more spectacular background painting with effects such as gradients, textures and color patterns.

Example

The following sample paints the diagram background with a gradient brush:

C#

private void Form1_Load(object sender, System.EventArgs e)
{
diagram.BackBrush = new MindFusion.Drawing.LinearGradientBrush(
Color.LightBlue, Color.LightCyan, 30);
}
Visual Basic

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

diagram.BackBrush = New MindFusion.Drawing.LinearGradientBrush( _
Color.LightBlue, Color.LightCyan, 30)

End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes


MindFusion.Diagramming.Diagram.BackgroundImage Property

Diagram.BackgroundImage Property

Gets or sets the image displayed as background of this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Image BackgroundImage { get; set; }
Visual Basic

Public Property BackgroundImage As Image

Property Value

An instance of the .NET Image class.

Remarks

This image is painted as a background of the diagram, behind the alignment grid and all items. Its position is controlled by the BackgroundImageAlign property. To have the background image appear on printed pages, set the EnableBackgroundImage property of DiagramView.PrintOptions to true.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
BackgroundImageAlign Property
BackBrush Property


MindFusion.Diagramming.Diagram.BackgroundImageAlign Property

Diagram.BackgroundImageAlign Property

Gets or sets a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ImageAlign BackgroundImageAlign { get; set; }
Visual Basic

Public Property BackgroundImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration. The default is ImageAlign.Document.

Remarks

The background image can be aligned to a corner, stretched, centered, or tiled to cover the control's area.

Example

To have a background image stretched along the drawing surface, use code like the following:

C#

diagram.BackgroundImage = Image.FromFile("back.jpg");
diagram.BackgroundImageAlign = ImageAlign.Stretch;
Visual Basic

diagram.BackgroundImage = Image.FromFile("back.jpg")
Diagram.BackgroundImageAlign = ImageAlign.Stretch

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ImageAlign Enumeration
BackgroundImage Property


MindFusion.Diagramming.Diagram.BackgroundImageUrl Property

Diagram.BackgroundImageUrl Property

URL of the image painted as diagram's background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string BackgroundImageUrl { get; set; }
Visual Basic

Public Property BackgroundImageUrl As String

Property Value

A string specifying the location of the image file.

Remarks

This property is used in the WebForms version of the control. Its advantage is that it allows for the diagram items to be loaded faster on the client side, while the background image is loaded asynchronously.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.Bounds Property

Diagram.Bounds Property

Gets or sets a value representing the size of the diagram's scrollable area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF Bounds { get; set; }
Visual Basic

Public Property Bounds As RectangleF

Property Value

An instance of the .NET RectangleF structure. The default size of the document is the standard A4 size, that is 210x297.

Remarks

Use this property to specify how large a document should be, that is, how far it can be scrolled. If ShowScrollbars is enabled, setting the document extents also updates the scrollbar ranges. After creating a diagram programmatically, you might wish to call ResizeToFitItems to make the scrollable area just big enough to contain all diagram elements.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
MeasureUnit Property
RestrictItemsToBounds Property
AutoResize Property


MindFusion.Diagramming.Diagram.BoundsPen Property

Diagram.BoundsPen Property

The pen with which the document bounds should be drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Pen BoundsPen { get; set; }
Visual Basic

Public Property BoundsPen As Pen

Property Value

A Pen instance. The default value is null.

Remarks

This pen is used to draw borders around the diagram bounding rectangle, which could be useful when the DiagramView is larger than the diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ExteriorBrush Property


MindFusion.Diagramming.Diagram.CellCustomDraw Property

Diagram.CellCustomDraw Property

Gets or sets the default type of custom painting done on the cells of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CustomDraw CellCustomDraw { get; set; }
Visual Basic

Public Property CellCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is CustomDraw.None.

Remarks

The CellCustomDraw member of new tables is initialized from this property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TableCustomDraw Property


MindFusion.Diagramming.Diagram.CellFrameStyle Property

Diagram.CellFrameStyle Property

Gets or sets the default cell border style of new tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CellFrameStyle CellFrameStyle { get; set; }
Visual Basic

Public Property CellFrameStyle As CellFrameStyle

Property Value

A member of the CellFrameStyle enumeration. The default is CellFrameStyle.System3D.

Remarks

Use this property to specify the default border style of cells in new tables. See CellFrameStyle enumeration for more details.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ContainerCaption Property

Diagram.ContainerCaption Property

Gets or sets the default value for the Caption property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ContainerCaption { get; set; }
Visual Basic

Public Property ContainerCaption As String

Property Value

A string specifying the initial caption text of containers. The default is "Container".

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ContainerCaptionHeight Property

Diagram.ContainerCaptionHeight Property

Gets or sets the default value for the CaptionHeight property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ContainerCaptionHeight { get; set; }
Visual Basic

Public Property ContainerCaptionHeight As Single

Property Value

A float value specifying the initial height of containers' caption bars. The default is 5.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ContainerHighlightPen Property

Diagram.ContainerHighlightPen Property

Gets or sets the default value for the HighlightPen property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Pen ContainerHighlightPen { get; set; }
Visual Basic

Public Property ContainerHighlightPen As Pen

Property Value

A Pen instance specifying the initial highlight pen of containers. The default is a pen with Color.LightSkyBlue color and width 0.5.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ContainerMargin Property

Diagram.ContainerMargin Property

Gets or sets the default value for the Margin property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ContainerMargin { get; set; }
Visual Basic

Public Property ContainerMargin As Single

Property Value

A float value specifying the initial margin size of containers. The default is 10.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ContainerMinimumSize Property

Diagram.ContainerMinimumSize Property

Gets or sets the default value for the MinimumSize property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeF ContainerMinimumSize { get; set; }
Visual Basic

Public Property ContainerMinimumSize As SizeF

Property Value

A SizeF value specifying the initial minimum size of containers. The default is 50x40.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ContainersFoldable Property

Diagram.ContainersFoldable Property

Gets or sets the default value for the Foldable property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ContainersFoldable { get; set; }
Visual Basic

Public Property ContainersFoldable As Boolean

Property Value

A boolean value specifying whether containers are initially foldable. The default is true.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.CrossingRadius Property

Diagram.CrossingRadius Property

Gets or sets the radius length of decorations displayed at link intersection points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float CrossingRadius { get; set; }
Visual Basic

Public Property CrossingRadius As Single

Property Value

A float value specifying the radius of the arcs drawn at link intersection points.

Remarks

If LinkCrossings is set to Cut, link segments are cut at intersection points and this property defines the length of the break left between adjacent cut points. If LinkCrossings is set to Arcs, this property defines the radius of the arcs drawn over intersection points.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
RoundedLinksRadius Property


MindFusion.Diagramming.Diagram.DefaultShape Property

Diagram.DefaultShape Property

Gets or sets the default shape of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape DefaultShape { get; set; }
Visual Basic

Public Property DefaultShape As Shape

Property Value

An instance of the Shape class. The default is the RoundRect shape.

Remarks

The Shape property of newly created shape nodes is initialized with the value of this property. It defines a series of lines, arcs and curves composed in a complex shape. There are 87 predefined shapes exposed as static members of the Shape class. You can also define your own shapes as shown below.

Example

The following example demonstrates how to create a custom shape and set it as a default in the diagram:

C#

private void example_Click(object sender, System.EventArgs e)
{
// Define a custom shape
// this is the same as: fc.DefaultShape = Shape.FromId("Tape");
diagram.DefaultShape = new Shape(
new ElementTemplate[] {
new LineTemplate(50, 100, 85, 100),
new LineTemplate(85, 100, 85, 90),
new LineTemplate(85, 90, 70, 90),
new BezierTemplate(70, 90, 85, 90, 100, 75, 100, 50),
new BezierTemplate(100, 50, 100, 25, 75, 0, 50, 0),
new BezierTemplate(50, 0, 25, 0, 0, 25, 0, 50),
new BezierTemplate(0, 50, 0, 75, 25, 100, 50, 100) },
FillMode.Winding);
}
Visual Basic

Private Sub example_Click(ByVal sender As Object, ByVal e As System.EventArgs)

' Define a custom shape
' this is the same as: fc.DefaultShape = Shape.FromId("Tape")
Diagram.DefaultShape = New Shape( _
New ElementTemplate() { _
New LineTemplate(50, 100, 85, 100), _
New LineTemplate(85, 100, 85, 90), _
New LineTemplate(85, 90, 70, 90), _
New BezierTemplate(70, 90, 85, 90, 100, 75, 100, 50), _
New BezierTemplate(100, 50, 100, 25, 75, 0, 50, 0), _
New BezierTemplate(50, 0, 25, 0, 0, 25, 0, 50), _
New BezierTemplate(0, 50, 0, 75, 25, 100, 50, 100)}, _
FillMode.Winding)

End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShapeNode.Shape Property
Shape.FromId Method
Shape.Shapes Property
ShapeOrientation Property


MindFusion.Diagramming.Diagram.Dirty Property

Diagram.Dirty Property

Gets or sets a value indicating whether the diagram has changed since the last save.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Dirty { get; set; }
Visual Basic

Public Property Dirty As Boolean

Property Value

A boolean value that indicates whether the diagram has changed.

Remarks

MindFusion.Diagramming tracks all changes that are done on the diagram contents, either programmatically or by users. If there are changes that are still not saved, the property has value of true. The Dirty flag is cleared automatically when a document is loaded from file or stream. When a document is saved, the Dirty flag can be cleared as specified by an argument of the Save* methods.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DirtyChanged Event
SaveToStream Method
LoadFromStream Method
SaveToFile Method
LoadFromFile Method


MindFusion.Diagramming.Diagram.DisabledHandlesColor Property

Diagram.DisabledHandlesColor Property

Gets or sets the color of disabled manipulation handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color DisabledHandlesColor { get; set; }
Visual Basic

Public Property DisabledHandlesColor As Color

Property Value

A .NET Color representing the color used to paint disabled handles. The default is Color.FromArgb(200, 0, 0).

Remarks

Disabled handles are displayed if ShowDisabledHandles is enabled. Individual handles can be disabled or enabled by clearing or setting the correspondent flag in node's EnabledHandles.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SelectedItemHandlesColor Property
ActiveItemHandlesColor Property


MindFusion.Diagramming.Diagram.DynamicLinks Property

Diagram.DynamicLinks Property

Gets or sets the default value for the Dynamic property of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool DynamicLinks { get; set; }
Visual Basic

Public Property DynamicLinks As Boolean

Property Value

true if dynamic links are enabled; otherwise, false. The default is false.

Remarks

Use the property to specify whether links automatically reposition their end segments, so they keep pointing to the centers of connected nodes. If enabled, moving a connected node recalculates the position of link's end point, placing it at appropriate location of the node outline. If the node has anchor points assigned to it, the end point is attached to one of them.

If the value is false, links do not look for the center of the origin and destination node, but keep their relative position as set when they were created - from the left corner of the first node to the top of the other node for instance.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.Dynamic Property
AllowSplitLinks Property


MindFusion.Diagramming.Diagram.EffectsProvider Property

Diagram.EffectsProvider Property

Gets or sets an object used to generate visual effects for shape nodes such as embossment and shadow dispersion.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public IEffectsProvider EffectsProvider { get; set; }
Visual Basic

Public Property EffectsProvider As IEffectsProvider

Property Value

An object that implements the IEffectsProvider interface. The default is null (Nothing in Visual Basic).

Remarks

For performance reasons, embossment and shadow dispersion effects are implemented through code that processes large amounts of image data by directly accessing the memory allocated to the image. The .NET runtime considers such code unsafe, and the default CAS settings prevent assemblies that contain unsafe code from being loaded in Internet Explorer or IIS. In order to keep the MindFusion.Diagramming CAS requirements low, the unsafe code resides in a separate assembly - MindFusion.Diagramming.EffectsProvider.dll. If you wish to use the EnableEmbossEffects and EnableShadowEffects properties, you must add to your project a reference to that assembly, instantiate an EffectsProvider object, and assign it to the EffectsProvider property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.EnableEmbossEffects Property

Diagram.EnableEmbossEffects Property

Gets or sets a value indicating whether emboss effect for shape nodes is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableEmbossEffects { get; set; }
Visual Basic

Public Property EnableEmbossEffects As Boolean

Property Value

true to enable embossment of shape nodes; otherwise, false. The default is false.

Remarks

In order to use the shape embossment effect, you must also set the EffectsProvider property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
EnableShadowEffects Property


MindFusion.Diagramming.Diagram.EnableLanes Property

Diagram.EnableLanes Property

Gets or sets whether lanes are enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableLanes { get; set; }
Visual Basic

Public Property EnableLanes As Boolean

Property Value

true if lanes are enabled; otherwise, false. The default is false.

Remarks

You can customize the lane grid through the LaneGrid property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.EnableShadowEffects Property

Diagram.EnableShadowEffects Property

Gets or sets a value indicating whether the shadow dispersion effect for nodes is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableShadowEffects { get; set; }
Visual Basic

Public Property EnableShadowEffects As Boolean

Property Value

true to enable shadow dispersion; otherwise, false. The default is false.

Remarks

In order to use the shadow dispersion effect, you must also set the EffectsProvider property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
EnableEmbossEffects Property


MindFusion.Diagramming.Diagram.EnableStyledText Property

Diagram.EnableStyledText Property

Gets or sets the default value for the EnableStyledText property of new nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableStyledText { get; set; }
Visual Basic

Public Property EnableStyledText As Boolean

Property Value

true to parse the text of items in order to find formatting tags; otherwise, false. The default is false.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. Formatting tags are listed and described in the Text Attributes and Formatting section of this help file.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ExpandButtonAction Property

Diagram.ExpandButtonAction Property

Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ExpandButtonAction ExpandButtonAction { get; set; }
Visual Basic

Public Property ExpandButtonAction As ExpandButtonAction

Property Value

A member of the ExpandButtonAction enumeration. The default is ExpandTreeBranch.

Remarks

The default behavior of a [±] button displayed nearby an Expandable node is to hide or show the children of that node. In that case, the children of a node are all nodes that can be reached from it by following recursively the OutgoingLinks or IncomingLinks, as defined by the ExpandOnIncoming property.

To implement custom expand/collapse functionality, set ExpandButtonAction to RaiseEvents and handle the ExpandButtonClicked event. That lets you use other criteria for what nodes should be shown or hidden, for example, containment or hierarchical grouping.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ExpandButtonPosition Property
TreeCollapsed Event
TreeExpanded Event


MindFusion.Diagramming.Diagram.ExpandButtonPosition Property

Diagram.ExpandButtonPosition Property

Gets or sets where expand/collapse buttons are located relatively to their nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ExpandButtonPosition ExpandButtonPosition { get; set; }
Visual Basic

Public Property ExpandButtonPosition As ExpandButtonPosition

Property Value

A member of the ExpandButtonPosition enumeration. The default is OuterRight.

Remarks

If diagram links tend to flow vertically, it would be useful to have the expand/collapse buttons stay at the left- or right-hand side of nodes. If diagram links tend to flow horizontally, choose position for expand buttons such that they stay above or below nodes. That will prevent button icons from being overlapped by links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodesExpandable Property
ExpandButtonAction Property


MindFusion.Diagramming.Diagram.ExpandOnIncoming Property

Diagram.ExpandOnIncoming Property

Gets or sets a value, indicating in which direction object hierarchies are expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ExpandOnIncoming { get; set; }
Visual Basic

Public Property ExpandOnIncoming As Boolean

Property Value

true if trees are expanded in the direction of the links, which come into nodes; otherwise, false. The default is false.

Remarks

Use this property when presenting tree structures with enabled collapse/expand. If the property is set to false, a clicked expand button of a node expands in the direction of the node's outgoing links. That is, the nodes pointed by links going out of a node are considered children of that node.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
RecursiveExpand Property
NodesExpandable Property


MindFusion.Diagramming.Diagram.ExteriorBrush Property

Diagram.ExteriorBrush Property

Gets or sets the brush used for painting the area outside Bounds.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Brush ExteriorBrush { get; set; }
Visual Basic

Public Property ExteriorBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class. Default value is null (Nothing in Visual Basic).

Remarks

If ExteriorBrush is set to null, the BackBrush is used to paint the areas both inside and outside Bounds. In order to scroll the exterior filling and the background image consistently, ExteriorBrush can be used only with document-relative BackgroundImageAlign.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes


MindFusion.Diagramming.Diagram.Factory Property

Diagram.Factory Property

Gets a Factory instance that lets you add programmatically new items to the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Factory Factory { get; }
Visual Basic

Public ReadOnly Property Factory As Factory

Property Value

An instance of the Factory class.

Remarks

You can add a new node or link to the diagram by creating an instance of the item class by using the new operator and adding it to the Nodes or Links collection. This works the same way for adding both items from your custom class or ones from the MindFusion.Diagramming predefined types. The Factory class methods are just shortcuts that let you do that with a single method call, and they work only for the predefined item classes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.Font Property

Diagram.Font Property

Gets or sets the default font for new diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Font Font { get; set; }
Visual Basic

Public Property Font As Font

Property Value

An instance of the .NET Font class. The default is Microsoft Sans Serif, 9pt.

Remarks

The Font of new nodes and links is initialized with the value of this property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramItem.Font Property
 DiagramView.TextRenderingHint Property


MindFusion.Diagramming.Diagram.GridColor Property

Diagram.GridColor Property

Gets or sets the color of the grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color GridColor { get; set; }
Visual Basic

Public Property GridColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.FromArgb(140, 140, 150).

Remarks

Use the property to specify the color of grid points and lines.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
GridSizeX Property
GridSizeY Property
GridStyle Property


MindFusion.Diagramming.Diagram.GridOffsetX Property

Diagram.GridOffsetX Property

Gets or sets the horizontal offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float GridOffsetX { get; set; }
Visual Basic

Public Property GridOffsetX As Single

Property Value

A float value that specifies the horizontal grid offset. The default is Single.NaN.

Remarks

The property specifies the offset of the first point of the alignment grid. The default value NaN makes the grid start at offset GridSizeX / 2.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
GridOffsetY Property
MeasureUnit Property


MindFusion.Diagramming.Diagram.GridOffsetY Property

Diagram.GridOffsetY Property

Gets or sets the vertical offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float GridOffsetY { get; set; }
Visual Basic

Public Property GridOffsetY As Single

Property Value

A float value that specifies the vertical grid offset. The default is Single.NaN.

Remarks

The property specifies the offset of the first point of the alignment grid. The default value NaN makes the grid start at offset GridSizeY / 2.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
GridOffsetX Property
MeasureUnit Property


MindFusion.Diagramming.Diagram.GridSizeX Property

Diagram.GridSizeX Property

Gets or sets the horizontal distance between adjacent grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float GridSizeX { get; set; }
Visual Basic

Public Property GridSizeX As Single

Property Value

A float number specifying the horizontal distance between grid points. The default is 4.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
AlignToGrid Property
AlignPointToGrid Method
MeasureUnit Property


MindFusion.Diagramming.Diagram.GridSizeY Property

Diagram.GridSizeY Property

Gets or sets the vertical distance between adjacent grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float GridSizeY { get; set; }
Visual Basic

Public Property GridSizeY As Single

Property Value

A float number specifying the vertical distance between grid points. The default is 4.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
AlignToGrid Property
AlignPointToGrid Method
MeasureUnit Property


MindFusion.Diagramming.Diagram.GridStyle Property

Diagram.GridStyle Property

Gets or sets the visual style of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public GridStyle GridStyle { get; set; }
Visual Basic

Public Property GridStyle As GridStyle

Property Value

A member of the GridStyle enumeration. The default is Points.

Remarks

Specifies how the alignment grid is drawn. If the property value is set to Points, the grid is painted as a matrix of points. If set to Lines, the grid is represented as a series of crossing horizontal and vertical lines. Grid points or lines are painted with the color set in GridColor; the distance between them is specified by the GridSizeX and GridSizeY properties.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowGrid Property
AlignToGrid Property


MindFusion.Diagramming.Diagram.Groups Property

Diagram.Groups Property

Gets a collection of all groups in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public GroupCollection Groups { get; }
Visual Basic

Public ReadOnly Property Groups As GroupCollection

Property Value

An instance of the GroupCollection class.

Remarks

Groups provides access to all groups defined in the current diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Items Property
Factory.CreateGroup Method


MindFusion.Diagramming.Diagram.HitTestPriority Property

Diagram.HitTestPriority Property

Gets or sets a value indicating the order in which items are hit-tested.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public HitTestPriority HitTestPriority { get; set; }
Visual Basic

Public Property HitTestPriority As HitTestPriority

Property Value

A member of the HitTestPriority enumeration. The default value is NodesBeforeLinks.

Remarks

For easier selection, links have a hit-detection area several pixels wider than their visible segment lines. However, if several links with higher z-index cross a node, it would be difficult to select it. The HitTestPriority property allows altering hit-test results in such situations. If set to NodesBeforeLinks, nodes are hit-tested before all links. ZOrder makes all items tested in decreasing z-order, independently of their type.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkHitDistance Property


MindFusion.Diagramming.Diagram.Interaction Property

Diagram.Interaction Property

Gets an InteractionState instance representing the current action being carried out by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public InteractionState Interaction { get; set; }
Visual Basic

Public Property Interaction As InteractionState

Property Value

An instance of the InteractionState class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.IsProEdition Property

Diagram.IsProEdition Property

Gets a value indicating whether the currently loaded MindFusion.Diagramming is a professional version of the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool IsProEdition { get; }
Visual Basic

Public ReadOnly Property IsProEdition As Boolean

Property Value

true if the currently loaded MindFusion.Diagramming control is a professional version; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.IsTrialVersion Property

Diagram.IsTrialVersion Property

Gets a value indicating whether the currently loaded MindFusion.Diagramming is a trial version of the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool IsTrialVersion { get; }
Visual Basic

Public ReadOnly Property IsTrialVersion As Boolean

Property Value

true if the currently loaded MindFusion.Diagramming control is a trial version; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.Items Property

Diagram.Items Property

Gets a collection of all items in this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItemCollection Items { get; }
Visual Basic

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

This collection gives you access to all items contained in this document. You can also use it to add new items to the diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Nodes Property
Links Property


MindFusion.Diagramming.Diagram.LaneGrid Property

Diagram.LaneGrid Property

Gets the Grid instance that represents the lane grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Grid LaneGrid { get; }
Visual Basic

Public ReadOnly Property LaneGrid As Grid

Property Value

An instance of the Grid class.

Remarks

The Grid object gives you full control over the lane grid. For example, it lets you set the number of rows and columns in the grid, add headers, customize the appearance, subscribe to events and so on.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.LinkBaseShape Property

Diagram.LinkBaseShape Property

Gets or sets the shape displayed at the base of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrowHead LinkBaseShape { get; set; }
Visual Basic

Public Property LinkBaseShape As ArrowHead

Property Value

A member of the ArrowHead enumeration. The default is None.

Remarks

The property specifies the default graphical shape that is displayed at the start of diagram links, for example, at the beginning of the links. Possible values are taken from the ArrowHead enumeration.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.BaseShape Property
LinkBaseShapeSize Property
LinkHeadShape Property
LinkIntermediateShape Property


MindFusion.Diagramming.Diagram.LinkBaseShapeSize Property

Diagram.LinkBaseShapeSize Property

Gets or sets the default size of the base of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float LinkBaseShapeSize { get; set; }
Visual Basic

Public Property LinkBaseShapeSize As Single

Property Value

A float value that specifies the size. The default is 5.

Remarks

The property specifies the size of the graphical shapes that are displayed at the start of new diagram links, for example, at the beginning of the links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.BaseShapeSize Property
LinkBaseShape Property


MindFusion.Diagramming.Diagram.LinkBrush Property

Diagram.LinkBrush Property

Gets or sets the default value for the Brush property of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Brush LinkBrush { get; set; }
Visual Basic

Public Property LinkBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

Remarks

The property provides a default value for the brush, with which an arrowhead's interior is filled. The Brush property of new links is initialized with a clone of LinkBrush, but after link creation the properties are independent - changing one of them does not change the other.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
LinkPen Property


MindFusion.Diagramming.Diagram.LinkCascadeOrientation Property

Diagram.LinkCascadeOrientation Property

Gets or sets the initial orientation of the first segment of new cascading links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Orientation LinkCascadeOrientation { get; set; }
Visual Basic

Public Property LinkCascadeOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

Use this property to specify the default orientation of the first segment of DiagramLink objects whose Style is set to LinkStyle.Cascading. The default value, Auto, lets the component decide whether to draw the first segment horizontally or vertically. See Orientation for more details.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.CascadeOrientation Property


MindFusion.Diagramming.Diagram.LinkCrossings Property

Diagram.LinkCrossings Property

Gets or sets how to render the intersection points where links cross their paths.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public LinkCrossings LinkCrossings { get; set; }
Visual Basic

Public Property LinkCrossings As LinkCrossings

Property Value

A member of the LinkCrossings enumeration. The default is Straight.

Remarks

Intersection points where links cross each other's paths can be rendered as arcs or breaks, depending on the value of this property. The z-order defines which links jump over the others or which links are cut by the others. If LinkCrossings is set to Arcs, links with higher ZIndex jump over those with lower ZIndex. If set to Cut, segments of links at lower z-position are cut by links at higher z-position. Radius of arcs and breaks can be set by the CrossingRadius property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.DrawCrossings Property
RouteLinks Property
RoundedLinks Property


MindFusion.Diagramming.Diagram.LinkCustomDraw Property

Diagram.LinkCustomDraw Property

Gets or sets the default type of custom painting done on links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CustomDraw LinkCustomDraw { get; set; }
Visual Basic

Public Property LinkCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is None.

Remarks

This property specifies whether and how custom painting of links is performed. Its value is assigned to the CustomDraw property of new links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DrawLink Event


MindFusion.Diagramming.Diagram.LinkEndsMovable Property

Diagram.LinkEndsMovable Property

Gets or sets a value indicating whether link ends can be moved by users after the link is created.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool LinkEndsMovable { get; set; }
Visual Basic

Public Property LinkEndsMovable As Boolean

Property Value

true if moving link ends is allowed; false, if not.

Remarks

When the property is set to true, users cannot move the ends of a link after the link is created. This prevents them from connecting the links to other origin and destination nodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkModifying Event


MindFusion.Diagramming.Diagram.LinkHandlesStyle Property

Diagram.LinkHandlesStyle Property

Gets or sets the default value for the HandlesStyle property of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public HandlesStyle LinkHandlesStyle { get; set; }
Visual Basic

Public Property LinkHandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration. The default is SquareHandles.

Remarks

Default value for the HandlesStyle property of new links, created either programmatically or by a user. That property specifies how links' selection status is indicated visually.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.LinkHeadShape Property

Diagram.LinkHeadShape Property

Gets or sets the shape displayed as head of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrowHead LinkHeadShape { get; set; }
Visual Basic

Public Property LinkHeadShape As ArrowHead

Property Value

A member of the ArrowHead enumeration that identifies an arrowhead shape. The default is Arrow.

Remarks

The property specifies the default shape displayed as links' arrowhead, that is, at the end point of links. Possible values are taken from the ArrowHead enumeration.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.HeadShape Property
LinkHeadShapeSize Property
LinkBaseShape Property
LinkIntermediateShape Property


MindFusion.Diagramming.Diagram.LinkHeadShapeSize Property

Diagram.LinkHeadShapeSize Property

Gets or sets the default size of arrowheads.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float LinkHeadShapeSize { get; set; }
Visual Basic

Public Property LinkHeadShapeSize As Single

Property Value

A float value that measures the size. The default is 5.

Remarks

The property specifies how big the shapes of new arrowheads are.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.HeadShapeSize Property
LinkHeadShape Property


MindFusion.Diagramming.Diagram.LinkHitDistance Property

Diagram.LinkHitDistance Property

Gets or sets a value specifying how far from a link a click is still considered a hit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float LinkHitDistance { get; set; }
Visual Basic

Public Property LinkHitDistance As Single

Property Value

A float value specifying the distance in MeasureUnit units. The default value is 0.

Remarks

If this property is set to 0, the control considers it a hit when a link is no further than five millimeters from the mouse position. This LinkHitDistance value is also used when hit-testing programmatically, e.g. by calling the GetItemAt method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
HitTestPriority Property


MindFusion.Diagramming.Diagram.LinkIntermediateShape Property

Diagram.LinkIntermediateShape Property

Gets or sets the default shape to be displayed in the middle of each segment of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrowHead LinkIntermediateShape { get; set; }
Visual Basic

Public Property LinkIntermediateShape As ArrowHead

Property Value

A member of the ArrowHead enumeration. The default is None.

Remarks

The property specifies default shape to be displayed in the middle of each segment of new links. It facilitates users by following the path of a link across the diagram, especially for longer links in large documents. Possible values are taken from the ArrowHead enumeration.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.IntermediateShape Property
LinkIntermediateShapeSize Property
LinkHeadShape Property
LinkBaseShape Property


MindFusion.Diagramming.Diagram.LinkIntermediateShapeSize Property

Diagram.LinkIntermediateShapeSize Property

Gets or sets the default size of the shapes at middles of link segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float LinkIntermediateShapeSize { get; set; }
Visual Basic

Public Property LinkIntermediateShapeSize As Single

Property Value

A float value that measures the size. The default is 5.

Remarks

Specifies default value for the IntermediateShapeSize property of new links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.IntermediateShapeSize Property
LinkIntermediateShape Property


MindFusion.Diagramming.Diagram.LinkPen Property

Diagram.LinkPen Property

Gets or sets the default value for the Pen and HeadPen properties of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Pen LinkPen { get; set; }
Visual Basic

Public Property LinkPen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class.

Remarks

The property provides a default value for the pens, with which link's segments and arrowhead lines are painted. The Pen and HeadPen properties of new links are initialized with clones of LinkPen, but after link creation the properties are independent - changing one of them does not change the others.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
LinkBrush Property


MindFusion.Diagramming.Diagram.Links Property

Diagram.Links Property

Gets a collection of all DiagramLink objects in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLinkCollection Links { get; }
Visual Basic

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

Links provides type-safe access to all links in the current diagram. Any diagram element can be accessed also via the Items collection.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Items Property
Nodes Property
Groups Property
Factory.CreateDiagramLink Method


MindFusion.Diagramming.Diagram.LinkSegments Property

Diagram.LinkSegments Property

Gets or sets the default number of link segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public short LinkSegments { get; set; }
Visual Basic

Public Property LinkSegments As Short

Property Value

An integer value specifying how many segments links consists of. The default is 1.

Remarks

Use the property to create more indented links, when necessary.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.SegmentCount Property
LinkStyle Property


MindFusion.Diagramming.Diagram.LinksSnapToBorders Property

Diagram.LinksSnapToBorders Property

Gets or sets the default value for the SnapToNodeBorder property of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool LinksSnapToBorders { get; set; }
Visual Basic

Public Property LinksSnapToBorders As Boolean

Property Value

true to align links' end points to node borders; otherwise, false. The default is false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DynamicLinks Property


MindFusion.Diagramming.Diagram.LinkStyle Property

Diagram.LinkStyle Property

Gets or sets the default style of diagram links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public LinkStyle LinkStyle { get; set; }
Visual Basic

Public Property LinkStyle As LinkStyle

Property Value

A member of the LinkStyle enumeration. The default value is Polyline.

Remarks

Use the property to specify how new links are composed and what they look like. The segments of a link could be curves or straight lines, and they might be restricted to be horizontal / vertical only.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.Style Property
RoundedLinks Property


MindFusion.Diagramming.Diagram.LinkText Property

Diagram.LinkText Property

Gets or sets the default text of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string LinkText { get; set; }
Visual Basic

Public Property LinkText As String

Property Value

A string specifying the initial text of links. The default is an empty string.

Remarks

The value of this property is assigned to the Text property of new links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.TextColor Property
TextFormat Property


MindFusion.Diagramming.Diagram.LinkTextStyle Property

Diagram.LinkTextStyle Property

Gets or sets default placement and orientation for links' text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public LinkTextStyle LinkTextStyle { get; set; }
Visual Basic

Public Property LinkTextStyle As LinkTextStyle

Property Value

A member of the LinkTextStyle enumeration. The default value is Center.

Remarks

The value of this property is used to initialize the TextStyle property of new links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.MeasureTextRenderingHint Property

Diagram.MeasureTextRenderingHint Property

Gets or sets the TextRenderingHint to use when measuring texts. This should be effectively set to the value of DiagramView.TextRenderingHint.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static TextRenderingHint MeasureTextRenderingHint { get; set; }
Visual Basic

Public Shared Property MeasureTextRenderingHint As TextRenderingHint

Property Value

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.MeasureUnit Property

Diagram.MeasureUnit Property

Gets or sets the unit of measure used for logical coordinates in this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public GraphicsUnit MeasureUnit { get; set; }
Visual Basic

Public Property MeasureUnit As GraphicsUnit

Property Value

A member of the .NET GraphicsUnit enumeration. The default is Millimeter.

Remarks

Many properties in the MindFusion.Diagramming API are used to specify the dimensions of diagram items or the size of various visual elements, for example, selection handles, arrowhead shapes, frame widths, and so on. MeasureUnit specifies the measure of length in which these size values are defined.

Changing the measure unit does not automatically rescale the size-related property values. Your application must set appropriate values to: Bounds, GridSizeX, GridSizeY, GridOffsetX, GridOffsetY, AdjustmentHandlesSize, LinkBaseShapeSize, LinkHeadShapeSize, LinkIntermediateShapeSize, TableCaptionHeight, TableColumnWidth, TableRowHeight, CrossingRadius, ShadowOffsetX, ShadowOffsetY and to the size-related members of RoutingOptions.

Changing the measure unit resets RoutingOptions to default values for the new unit, because performance might suffer greatly if the routing algorithm uses too big or too small GridSize.

The arguments passed to some methods depend on the measure unit too, for example, CreateShapeNode, CreateTableNode, ClientToDoc and DocToClient, GetNodeAt, GetLinkAt, ZoomToRect.

The following GraphicsUnit members can be used as MindFusion.Diagramming measure units:

Member name | Description
Display | Specifies 1/75 inch as the unit of measure. At this time zooming does not work with Display units.
Document | Specifies the document unit (1/300 inch) as the unit of measure.
Inch | Specifies the inch as the unit of measure.
Millimeter | Specifies the millimeter as the unit of measure.
Pixel | Specifies a device pixel as the unit of measure. Note that print and on-screen output will differ greatly in size when using pixels because printer pixels are much smaller than screen ones.
Point | Specifies a printer's point (1/72 inch) as the unit of measure.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.MergeThreshold Property

Diagram.MergeThreshold Property

Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float MergeThreshold { get; set; }
Visual Basic

Public Property MergeThreshold As Single

Property Value

A float value Specifying the maximum distance in the current MeasureUnit. The default is 0.

Remarks

An user may add or remove links' segments interactively when the AllowSplitLinks property is enabled. They can drag a link's control point over the next one in order to merge two adjacent segments. Usually the two points must be placed exactly at the same coordinates in order to merge the respective segments of the link. Assign a larger value to this property if you wish to make it easier for users to merge segments by just moving link's control point close one to another.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.Nodes Property

Diagram.Nodes Property

Gets a collection of all DiagramNode objects in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNodeCollection Nodes { get; }
Visual Basic

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class.

Remarks

Nodes provides type-safe access to all nodes in the current diagram. Any diagram element can be accessed also by using the Items collection.

Example

The following code adds a new ControlNode to the diagram:

C#

ControlNode controlNode = new ControlNode(diagramView);
controlNode.Bounds = new RectangleF(10, 10, 30, 30);
controlNode.Control = new DataGrid();
diagram.Nodes.Add(controlNode);
Visual Basic

Dim controlNode As New ControlNode(diagramView)
controlNode.Bounds = New RectangleF(10, 10, 30, 30)
controlNode.Control = New DataGrid
diagram.Nodes.Add(controlNode)

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Items Property
Links Property
Groups Property
Factory.CreateShapeNode Method


MindFusion.Diagramming.Diagram.NodesExpandable Property

Diagram.NodesExpandable Property

Gets or sets a value indicating whether newly created nodes can be expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool NodesExpandable { get; set; }
Visual Basic

Public Property NodesExpandable As Boolean

Property Value

true if new nodes can be expanded; otherwise, false. The default is false.

Remarks

If using MindFusion.Diagramming to present tree/hierarchical diagrams, you might set NodesExpandable to true. If enabled, the property makes each newly created node appear with a [±] sign next to it, which expands or collapses the node's descendants.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ExpandButtonPosition Property
RecursiveExpand Property
ExpandOnIncoming Property
TreeCollapsed Event
TreeExpanded Event
DiagramNode.Expandable Property


MindFusion.Diagramming.Diagram.NowLoading Property

Diagram.NowLoading Property

Gets a value indicating whether the diagram data is now being loaded from a file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool NowLoading { get; }
Visual Basic

Public ReadOnly Property NowLoading As Boolean

Property Value

true if the diagram is currently in a loading state; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LoadFromFile Method


MindFusion.Diagramming.Diagram.PolygonalTextLayout Property

Diagram.PolygonalTextLayout Property

Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool PolygonalTextLayout { get; set; }
Visual Basic

Public Property PolygonalTextLayout As Boolean

Property Value

true to enable polygonal formatting; false to disable it.

Remarks

Specifies a default value for the PolygonalTextLayout property of shape nodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DefaultShape Property


MindFusion.Diagramming.Diagram.RecursiveExpand Property

Diagram.RecursiveExpand Property

Gets or sets value indicating how a tree is expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RecursiveExpand { get; set; }
Visual Basic

Public Property RecursiveExpand As Boolean

Property Value

true if a tree is recursively expanded; otherwise, false. The default is false.

Remarks

Use the property when representing tree structures, which hide some of their elements. When the property is set to true, clicking on a certain node in the tree, expands not only its descendants, but all descendants of the descendants, and so on, till the whole tree is expanded.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ExpandOnIncoming Property
NodesExpandable Property


MindFusion.Diagramming.Diagram.RestrictItemsToBounds Property

Diagram.RestrictItemsToBounds Property

Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RestrictToBounds RestrictItemsToBounds { get; set; }
Visual Basic

Public Property RestrictItemsToBounds As RestrictToBounds

Property Value

A member of the RestrictToBounds enumeration. The default is Intersection.

Remarks

Use this property to specify whether diagram elements can be drawn or moved outside the document area. It is possible to specify that items have to be entirely inside, partly outside or there is no restriction.

If there is no restriction and AutoResize is disabled, users could place an item to a position where they cannot reach it by scrolling. That might be interpreted as an item deletion operation by handling the NodeModified event and deleting the item if it is outside the document boundaries.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Bounds Property
AutoResize Property


MindFusion.Diagramming.Diagram.RoundedLinks Property

Diagram.RoundedLinks Property

Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RoundedLinks { get; set; }
Visual Basic

Public Property RoundedLinks As Boolean

Property Value

true to use rounded segment joins; otherwise, false. The default is false.

Remarks

The value of this property is considered when drawing links whose Style is set to Polyline or Cascading. If the property is enabled, the joins between the segments of all such links are drawn as arcs, whose radius equals the value of RoundedLinksRadius.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramLink.Style Property
LinkCrossings Property


MindFusion.Diagramming.Diagram.RoundedLinksRadius Property

Diagram.RoundedLinksRadius Property

Gets or sets the radius of arc joins of rounded links' segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float RoundedLinksRadius { get; set; }
Visual Basic

Public Property RoundedLinksRadius As Single

Property Value

A float value specifying the radius length. The default is 2.

Remarks

The value of this property is used when RoundedLinks is enabled. It specifies the radius of the arcs drawn as joins between link segments.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
CrossingRadius Property


MindFusion.Diagramming.Diagram.RoundRectFactor Property

Diagram.RoundRectFactor Property

Gets or sets the relative size of arcs displayed at the corners of rounded rectangles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float RoundRectFactor { get; set; }
Visual Basic

Public Property RoundRectFactor As Single

Property Value

A float multiplier applied to the radius of the arcs used as corners of rounded rectangles. The default is 1.

Remarks

The default length of the radius of rounded-corner arcs is 7. This property lets you increase or decrease that value by multiplying it by the specified factor.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TableStyle Property


MindFusion.Diagramming.Diagram.RouteLinks Property

Diagram.RouteLinks Property

Gets or sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RouteLinks { get; set; }
Visual Basic

Public Property RouteLinks As Boolean

Property Value

true to route links; otherwise, false. The default is false.

Remarks

The value of RouteLinks is used to initialize the AutoRoute property of new links. If a node is moved or resized, all links that intersect with its new position and have AutoRoute enabled are rerouted. Keep in mind that number of link segments will probably change when routing is enabled.

RoutingOptions allows tuning the routing algorithm. The most important options are the cost values exposed as LengthCost, TurnCost and CrossingCost properties. They greatly influence the shape of the generated route.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
RouteAllLinks Method
DynamicLinks Property
LinkCrossings Property


MindFusion.Diagramming.Diagram.RoutingOptions Property

Diagram.RoutingOptions Property

Gets an object, which allows customizing various parameters of the link routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RoutingOptions RoutingOptions { get; }
Visual Basic

Public ReadOnly Property RoutingOptions As RoutingOptions

Property Value

An instance of the RoutingOptions class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
RouteLinks Property
RouteAllLinks Method


MindFusion.Diagramming.Diagram.ScriptHelper Property

Diagram.ScriptHelper Property

Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ScriptHelper ScriptHelper { get; }
Visual Basic

Public ReadOnly Property ScriptHelper As ScriptHelper

Property Value

An instance of the ScriptHelper class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.SelectAfterCreate Property

Diagram.SelectAfterCreate Property

Gets or sets a value indicating whether newly created objects are automatically selected.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool SelectAfterCreate { get; set; }
Visual Basic

Public Property SelectAfterCreate As Boolean

Property Value

true if items are selected after being created; otherwise, false. The default is true.

Remarks

Use the property to specify if the items that are drawn are selecting, which allows immediate modification actions to be performed over them.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Selection Property


MindFusion.Diagramming.Diagram.SelectedItemHandlesColor Property

Diagram.SelectedItemHandlesColor Property

Gets or sets the color of the manipulation handles of selected objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color SelectedItemHandlesColor { get; set; }
Visual Basic

Public Property SelectedItemHandlesColor As Color

Property Value

A .NET Color instance specifying the color of the handles. The default is Color.FromArgb(170, 170, 170).

Remarks

Use the property to specify the color of the adjustment handles that appear around selected objects.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ActiveItemHandlesColor Property
DisabledHandlesColor Property


MindFusion.Diagramming.Diagram.Selection Property

Diagram.Selection Property

Gets a Selection instance that represents the selection of items in this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Selection Selection { get; }
Visual Basic

Public ReadOnly Property Selection As Selection

Property Value

An instance of the Selection class representing the current selection.

Remarks

Use this property to get the items currently selected by a user. Items can be enumerated by the Items member of the Selection class. An item from the selection is considered the active one and can be accessed by using ActiveItem. To prevent users from selecting multiple items, set AllowMultipleSelection to false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramView.ModificationStart Property
AdjustmentHandlesSize Property
HitTestPriority Property


MindFusion.Diagramming.Diagram.SelectionOnTop Property

Diagram.SelectionOnTop Property

Gets or sets a value indicating whether selected items should be painted on top of other items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool SelectionOnTop { get; set; }
Visual Basic

Public Property SelectionOnTop As Boolean

Property Value

true if selected items should be painted on top; otherwise, false. The default is true.

Remarks

If SelectionOnTop is enabled, selected items are painted over non-selected ones, ignoring the z-order position specified in ZIndex. If disabled, the items are painted as set in the z-order.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Selection Class
ActiveItem Property
SortGroupsByZ Property


MindFusion.Diagramming.Diagram.ShadowColor Property

Diagram.ShadowColor Property

Gets or sets the default color used to paint the shadows cast by diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color ShadowColor { get; set; }
Visual Basic

Public Property ShadowColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.FromArgb(140, 140, 150).

Remarks

Use the property to specify an initial value for the ShadowColor property of new diagram elements.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShadowsStyle Property


MindFusion.Diagramming.Diagram.ShadowOffsetX Property

Diagram.ShadowOffsetX Property

Gets or sets the horizontal offset of item shadows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ShadowOffsetX { get; set; }
Visual Basic

Public Property ShadowOffsetX As Single

Property Value

A float value that specifies the X shadow offset.

Remarks

Use the property to specify how distant the shadow of the item should be drawing as to the x-coordinate axis. You can set both X and Y offset values with the SetShadowOffset method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SetShadowOffset Method
DiagramItem.ShadowOffsetY Property


MindFusion.Diagramming.Diagram.ShadowOffsetY Property

Diagram.ShadowOffsetY Property

Gets or sets the vertical offset of item shadows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ShadowOffsetY { get; set; }
Visual Basic

Public Property ShadowOffsetY As Single

Property Value

A float value that specifies the Y shadow offset.

Remarks

Use the property to specify how distant the shadow of the item should be drawing as to the y-coordinate axis. You can set both X and Y offset values with the SetShadowOffset method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SetShadowOffset Method
DiagramItem.ShadowOffsetX Property


MindFusion.Diagramming.Diagram.ShadowsStyle Property

Diagram.ShadowsStyle Property

Gets or sets the style for rendering shadows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShadowsStyle ShadowsStyle { get; set; }
Visual Basic

Public Property ShadowsStyle As ShadowsStyle

Property Value

A member of the ShadowsStyle enumeration.

Remarks

This property specifies how the shadows of diagram items are drawn. If its value is None no shadows are painted. OneLevel makes all shadows paint on the lowest z-level, not covering any items. Thus the diagram items will seem to appear on the same z-level. ZOrder makes the shadow paint immediately under their items, possibly covering other items. This style gives more 3D-like outlook to the diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramItem.ShadowOffsetX Property
DiagramItem.ShadowOffsetY Property
EnableShadowEffects Property


MindFusion.Diagramming.Diagram.ShapeBrush Property

Diagram.ShapeBrush Property

Gets or sets the default value for the Brush property of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Brush ShapeBrush { get; set; }
Visual Basic

Public Property ShapeBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

Remarks

The property provides a default value for the brush, with which a node' interior is filled. The Brush property of new shape nodes is initialized with a clone of ShapeBrush, but after the node creation the properties are independent - changing one of them does not change the other.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
ShapePen Property


MindFusion.Diagramming.Diagram.ShapeCustomDraw Property

Diagram.ShapeCustomDraw Property

Gets or sets the default type of custom painting done for shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CustomDraw ShapeCustomDraw { get; set; }
Visual Basic

Public Property ShapeCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is None.

Remarks

This property specifies whether and how custom painting of shape nodes is performed. Its value is assigned to the CustomDraw property of new shape nodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DrawNode Event


MindFusion.Diagramming.Diagram.ShapeHandlesStyle Property

Diagram.ShapeHandlesStyle Property

Gets or sets the default value for the HandlesStyle property of new shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public HandlesStyle ShapeHandlesStyle { get; set; }
Visual Basic

Public Property ShapeHandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration.

Remarks

This property provides default value for the HandlesStyle property of new shape nodes, created either programmatically or by the user. That property specifies how selected nodes are indicated visually, and how they can be moved, resized or connected to other objects.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ShapeOrientation Property

Diagram.ShapeOrientation Property

Gets or sets the default value for the ShapeOrientation property of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ShapeOrientation { get; set; }
Visual Basic

Public Property ShapeOrientation As Single

Property Value

A float value specifying an angle in degrees. Allowed values are 0, 90, 180 and 270.

Remarks

Use this property in conjunction with DefaultShape to define what shape will be assigned to new nodes that end-users draw.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShapeNode.ShapeOrientation Property
DefaultShape Property


MindFusion.Diagramming.Diagram.ShapePen Property

Diagram.ShapePen Property

Gets or sets the default value for the Pen property of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Pen ShapePen { get; set; }
Visual Basic

Public Property ShapePen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class.

Remarks

The property provides a default value for the pen, with which a shape node's frame is painted. The Pen property of new shape nodes is initialized with a clone of ShapePen, but after the node creation the properties are independent - changing one of them does not change the other.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
ShapeBrush Property


MindFusion.Diagramming.Diagram.ShapeText Property

Diagram.ShapeText Property

Gets or sets the default text of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ShapeText { get; set; }
Visual Basic

Public Property ShapeText As String

Property Value

A string specifying the initial text of shape nodes. The default is an empty string.

Remarks

The value of this property is assigned to the Text property of new nodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TextColor Property
TextFormat Property


MindFusion.Diagramming.Diagram.ShowAnchors Property

Diagram.ShowAnchors Property

Gets or sets a value indicating whether and when node anchor points should be displayed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShowAnchors ShowAnchors { get; set; }
Visual Basic

Public Property ShowAnchors As ShowAnchors

Property Value

A member of the ShowAnchors enumeration. The default value is Auto.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SnapToAnchor Property
Anchor Points and Patterns


MindFusion.Diagramming.Diagram.ShowDisabledHandles Property

Diagram.ShowDisabledHandles Property

Gets or sets a value indicating whether manipulation handles are painted when they are disabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ShowDisabledHandles { get; set; }
Visual Basic

Public Property ShowDisabledHandles As Boolean

Property Value

true to display disabled manipulation handles; otherwise, false. The default is true.

Remarks

Individual handles can be disabled or enabled by clearing or setting their correspondent bits in node's EnabledHandles. If disabled handles are displayed, they are painted using the color set in DisabledHandlesColor.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ShowGrid Property

Diagram.ShowGrid Property

Gets or sets a value indicating whether the alignment grid is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ShowGrid { get; set; }
Visual Basic

Public Property ShowGrid As Boolean

Property Value

true if the grid is visible; otherwise, false. The default is false.

Remarks

If it is visible, the grid is painted as either a matrix of points or crossing horizontal and vertical lines. That depends on the value of GridStyle.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AlignToGrid Property
GridColor Property
GridSizeX Property
GridSizeY Property


MindFusion.Diagramming.Diagram.ShowHandlesOnDrag Property

Diagram.ShowHandlesOnDrag Property

Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ShowHandlesOnDrag { get; set; }
Visual Basic

Public Property ShowHandlesOnDrag As Boolean

Property Value

true to display the selection handles of an item while it is being modified; false to hide them.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.SnapToAnchor Property

Diagram.SnapToAnchor Property

Gets or sets when link end points should be aligned to the nearest anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public SnapToAnchor SnapToAnchor { get; set; }
Visual Basic

Public Property SnapToAnchor As SnapToAnchor

Property Value

A member of the SnapToAnchor enumeration. The default is OnCreate.

Remarks

The default value OnCreate, specifies that links are snapped to anchor points when they are created, but allows the user to move the link ends to different locations of a node. The OnCreateOrModify value makes link ends points connect to node anchors both if links are created or modified.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ShowAnchors Property


MindFusion.Diagramming.Diagram.SortGroupsByZ Property

Diagram.SortGroupsByZ Property

Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool SortGroupsByZ { get; set; }
Visual Basic

Public Property SortGroupsByZ As Boolean

Property Value

true if grouped items should be painted according to their z-order; otherwise, false. The default is false.

Remarks

By default, while a group of nodes is being modified with the mouse, the grouped items are drawn in the order defined by the group hierarchy. For example, the group MainItem is drawn bellow all attached items, and if an attached item is the main item in another group, it is drawn below the next groups in the hierarchy. During this process, the ZIndex of items is ignored and the group appearance while it is being modified might differ from how it looks usually. The SortGroupsByZ property lets you override the default behavior and display items sorted by their z-order. Take heed if your application creates large hierarchies of groups - enabling that property might slow down the modification process.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SelectionOnTop Property


MindFusion.Diagramming.Diagram.TableBrush Property

Diagram.TableBrush Property

Gets or sets the default value for the Brush property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Brush TableBrush { get; set; }
Visual Basic

Public Property TableBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

Remarks

The property provides a default value for the brush, with which a table' interior is filled. The Brush property of new tables is initialized with a clone of TableBrush, but after table creation the properties are independent - changing one of them does not change the other.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
TablePen Property


MindFusion.Diagramming.Diagram.TableCaption Property

Diagram.TableCaption Property

Gets or sets the default text for tables' captions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string TableCaption { get; set; }
Visual Basic

Public Property TableCaption As String

Property Value

A string specifying the initial text of table captions. The default is "Table".

Remarks

The Caption property of new tables is initialized with the value of TableCaption.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TableCaptionHeight Property


MindFusion.Diagramming.Diagram.TableCaptionHeight Property

Diagram.TableCaptionHeight Property

Gets or sets the default height of table captions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float TableCaptionHeight { get; set; }
Visual Basic

Public Property TableCaptionHeight As Single

Property Value

A float value, which indicates the height of table caption. Default value is 5.

Remarks

The value of this property is used to initialize the CaptionHeight property of new tables.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TableCaption Property


MindFusion.Diagramming.Diagram.TableColumnCount Property

Diagram.TableColumnCount Property

Gets or sets the default number of table columns.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int TableColumnCount { get; set; }
Visual Basic

Public Property TableColumnCount As Integer

Property Value

An integer value, which specifies the number of columns in new tables. The default is 2.

Remarks

This value is used to initialize the ColumnCount property of new tables.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TableRowCount Property


MindFusion.Diagramming.Diagram.TableColumnWidth Property

Diagram.TableColumnWidth Property

Gets or sets the default width of tables' columns.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float TableColumnWidth { get; set; }
Visual Basic

Public Property TableColumnWidth As Single

Property Value

A float value, which specifies the width of table columns measured. The default is 18.

Remarks

This property is used to initialize the ColumnWidth property of new tables.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TableRowHeight Property


MindFusion.Diagramming.Diagram.TableConnectionStyle Property

Diagram.TableConnectionStyle Property

Gets or sets a value indicating whether drawing a link between tables should connect the rows of those tables, or the tables as whole entities.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableConnectionStyle TableConnectionStyle { get; set; }
Visual Basic

Public Property TableConnectionStyle As TableConnectionStyle

Property Value

A member of the TableConnectionStyle enumeration. The default is Rows.

Remarks

The value of TableConnectionStyle is used to initialize the ConnectionStyle property of new tables. There are three possible ways to relate tables to other nodes. This property specifies how users are allowed to create such relations:

  • Rows - relation ends are the rows of a table. A link connected to the table is connected to a particular row. This mode is convenient for database diagrams.
  • Table - relations target tables as whole entities, and not any particular row. This mode is convenient for class diagrams.
  • Both - a mixed mode where links can target either a row of a table or the table itself.

Programmatically, links can be connected to a table in any way, regardless of the table's ConnectionStyle. The value of ConnectionStyle is considered only when end-users draw links to or from a table. To link to a table as an entity and not to a specific row, pass -1 as row argument of the CreateDiagramLink method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.TableCustomDraw Property

Diagram.TableCustomDraw Property

Gets or sets the default type of custom painting done on tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CustomDraw TableCustomDraw { get; set; }
Visual Basic

Public Property TableCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is None.

Remarks

The CustomDraw member of tables is initialized from this property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
CellCustomDraw Property


MindFusion.Diagramming.Diagram.TableHandlesStyle Property

Diagram.TableHandlesStyle Property

Gets or sets the default value for the HandlesStyle property of new tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public HandlesStyle TableHandlesStyle { get; set; }
Visual Basic

Public Property TableHandlesStyle As HandlesStyle

Property Value

One of the HandlesStyle enumeration values.

Remarks

Default value for the HandlesStyle property of new tables, created either programmatically or by the user. That property specifies how selected tables are indicated visually, and how they can be moved, resized or connected to other objects.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.TablePen Property

Diagram.TablePen Property

Gets or sets the default value for the Pen property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Pen TablePen { get; set; }
Visual Basic

Public Property TablePen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class.

Remarks

The property provides a default value for the pen, with which a table's frame is painted. The Pen property of new tables is initialized with a clone of TablePen, but after table creation the properties are independent - changing one of them does not change the other.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
TableBrush Property


MindFusion.Diagramming.Diagram.TableRowCount Property

Diagram.TableRowCount Property

Gets or sets the default number of table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int TableRowCount { get; set; }
Visual Basic

Public Property TableRowCount As Integer

Property Value

An integer value specifying the number of rows.

Remarks

Use the property to set the initial number of rows for newly created tables. Further customization of table nodes can be done through TableNode class properties and methods.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TableColumnCount Property


MindFusion.Diagramming.Diagram.TableRowHeight Property

Diagram.TableRowHeight Property

Gets or sets the default height of tables' rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float TableRowHeight { get; set; }
Visual Basic

Public Property TableRowHeight As Single

Property Value

A float value specifying the height of table rows. The default is 5.

Remarks

TableRowHeight is used to initialize the RowHeight property of new tables.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TableColumnWidth Property


MindFusion.Diagramming.Diagram.TablesScrollable Property

Diagram.TablesScrollable Property

Gets or sets the default value for the Scrollable property of new tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool TablesScrollable { get; set; }
Visual Basic

Public Property TablesScrollable As Boolean

Property Value

true if the scrolling is possible; otherwise, false. The default is false.

Remarks

The Scrollable property of each new table is initialized with the value of TablesScrollable. Small up/down scroll buttons appear in the caption of scrollable tables. With the help of the buttons users can scroll table rows.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TableRowCount Property
TableNode.Scrollable Property


MindFusion.Diagramming.Diagram.TableStyle Property

Diagram.TableStyle Property

Gets or sets the default value of the Style property of new tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableStyle TableStyle { get; set; }
Visual Basic

Public Property TableStyle As TableStyle

Property Value

A member of the TableStyle enumeration. The default value is Rectangle.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.Tag Property

Diagram.Tag Property

Gets or sets custom data associated with this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object Tag { get; set; }
Visual Basic

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Any type derived from the Object class can be assigned to this property. If the Tag property is set through the Windows Forms designer, only text can be assigned. A common use for the Tag property is to store data that is closely associated with diagrams and often must be accessed when processing a diagram instance.

If the tag is an instance of a value type, it will be serialized together with the diagram when saving or loading the diagram document. Reference types are serialized if marked with the [Serializable] attribute and implement the ISerializable interface.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.TextColor Property

Diagram.TextColor Property

Gets or sets the default color of text displayed inside diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color TextColor { get; set; }
Visual Basic

Public Property TextColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.Black.

Remarks

Use the property to specify the default color of the text of diagram items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TextFormat Property


MindFusion.Diagramming.Diagram.TextFormat Property

Diagram.TextFormat Property

Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public StringFormat TextFormat { get; set; }
Visual Basic

Public Property TextFormat As StringFormat

Property Value

An instance of the .NET StringFormat class. The default value for both Alignment and LineAlignment properties is StringAlignment.Center.

Remarks

When a new node is created, its TextFormat is initialized with the value of this property. The same applies for the TextFormat of the cells of a new table.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TextColor Property


MindFusion.Diagramming.Diagram.ToolTip Property

Diagram.ToolTip Property

Gets or sets a short text message displayed when the mouse pointer rests over the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ToolTip { get; set; }
Visual Basic

Public Property ToolTip As String

Property Value

The tool-tip text displayed for this diagram. The default is an empty string.

Remarks

This tool-tip is displayed when the mouse rests over an unoccupied document area. If the mouse points to an item, the ToolTip of that item will appear. Tool-tips can be enabled or disabled using the ShowToolTips property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramView.ToolTipDelay Property


MindFusion.Diagramming.Diagram.UndoManager Property

Diagram.UndoManager Property

Gets a reference to the diagram's UndoManager instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public UndoManager UndoManager { get; }
Visual Basic

Public ReadOnly Property UndoManager As UndoManager

Property Value

A reference to UndoManager instance.

Remarks

Use this property to control the undo manager operations, Undo or Redo commands, and access the command History.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Undo Manager


MindFusion.Diagramming.Diagram.ValidityChecks Property

Diagram.ValidityChecks Property

Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ValidityChecks { get; set; }
Visual Basic

Public Property ValidityChecks As Boolean

Property Value

true to perform validity checks; otherwise, false. The default is true.

Remarks

If enabled, validity checks are performed each time an item is added to the diagram. That involves enumerating the Items collection and can slow up the process considerably for large diagrams. You can disable this property in order to skip the validity checks, however be sure that you don't add an item twice to the diagram and that links are created only between items in the same diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Factory.CreateShapeNode Method
Factory.CreateDiagramLink Method


MindFusion.Diagramming.Diagram Events

Diagram Events

Public Events

Name | Description
ActionRecorded | Raised when an action is recorded in the undo buffer.
ActionRecording | A validation event raised before an action is recorded in the undo buffer.
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream.
BoundsChanged | Raised when the Bounds property value has changed.
CellClicked | Raised when the user clicks a table's cell.
CellDoubleClicked | Raised when the user double-clicks a table's cell.
CellTextEdited | Raised when the user edits the text of a table's cell.
CellTextEditing | A validation event that lets you prevent users from editing the text of a table's cell.
Clicked | Raised when the user clicks the diagram at a point where no items are located.
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user.
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user.
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area.
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.
DefaultShapeChanged | Raised when the DefaultShape property value has changed.
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format.
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed.
DirtyChanged | Raised when the Dirty property value has changed.
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located.
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn.
DrawAnchorPoint | Raised when an anchor point must be custom drawn.
DrawBackground | Raised to let you custom draw the diagram background.
DrawCell | Raised when a table's cell must be custom drawn.
DrawForeground | Raised to let you custom draw the diagram foreground.
DrawLink | Raised when a diagram link must be custom drawn.
DrawNode | Raised when a diagram node must be custom drawn.
EndLoad | Raised when the component ends loading diagram data from a file or memory stream.
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node.
GroupDestroyed | Raised when a Group object is destroyed.
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed.
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created.
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created.
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively.
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively.
LinkActivated | Raised when a link becomes the ActiveItem.
LinkClicked | Raised when the user clicks a link.
LinkCreated | Raised when the user draws a new link.
LinkCreating | A validation event raised while the user is drawing a new link.
LinkDeactivated | Raised when a link is no longer the ActiveItem.
LinkDeleted | Raised when a link is deleted, either programmatically or by the user.
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation.
LinkDeselected | Raised when a link is deselected, either programmatically or by the user.
LinkDoubleClicked | Raised when the user double-clicks a link.
LinkModified | Raised when the user moves any control point of a link.
LinkModifying | A validation event raised while the user is modifying a link.
LinkPasted | Raised when a link has been pasted from the clipboard.
LinkRouted | Raised when a link is routed by the auto-routing algorithm.
LinkSelected | Raised when a link is selected, either programmatically or by the user.
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation.
LinkStartModifying | A validation event raised when the user starts modifying a link.
LinkTextEdited | Raised when the user edits the text of a link.
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link.
MeasureUnitChanged | Raised when the MeasureUnit property value has changed.
NodeActivated | Raised when a node becomes the ActiveItem.
NodeClicked | Raised when the user clicks a node.
NodeCreated | Raised when the user draws a new node.
NodeCreating | A validation event raised while the user is drawing a new node.
NodeDeactivated | Raised when a node is no longer the ActiveItem.
NodeDeleted | Raised when a node is deleted, either programmatically or by the user.
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation.
NodeDeselected | Raised when a node is deselected, either programmatically or by the user.
NodeDoubleClicked | Raised when the user double-clicks a node.
NodeModified | Raised when the user moves or resizes a node.
NodeModifying | A validation event raised while the user is moving or resizing a node.
NodePasted | Raised when a node has been pasted from the clipboard.
NodeSelected | Raised when a node is selected, either programmatically or by the user.
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation.
NodeStartModifying | A validation event raised when the user starts modifying a node.
NodeTextEdited | Raised when the user edits the text of a node.
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node.
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed.
Repaint | Raised when the diagram views should be repainted.
SelectionChanged | Raised when an item is added to or removed from the selection.
SelectionMoved | Raised when the user moves multiple selected items.
SelectionMoving | Raised while the user is moving multiple selected items, this event lets you cancel the modification.
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document.
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row.
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row.
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point.
ViewRemoved | Raised when a DiagramView is detached from this diagram.

See Also

Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ActionRecorded Event

Diagram.ActionRecorded Event

Raised when an action is recorded in the undo buffer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event UndoEventHandler ActionRecorded
Visual Basic

Public Event ActionRecorded As UndoEventHandler

Event Data

ActionRecorded event handlers receive an argument of type UndoEventArgs. The following UndoEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command instance that identifies the recorded action.

Remarks

This event is raised only for top-level commands. For example, it isn't raised for the constituent actions of a CompositeCmd.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ActionRedone Event
ActionUndone Event


MindFusion.Diagramming.Diagram.ActionRecording Event

Diagram.ActionRecording Event

A validation event raised before an action is recorded in the undo buffer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event UndoValidationEventHandler ActionRecording
Visual Basic

Public Event ActionRecording As UndoValidationEventHandler

Event Data

ActionRecording event handlers receive an argument of type UndoValidationEventArgs. The following UndoValidationEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command instance that identifies the action being recorded.
Cancel | Set this property to true to prevent the action from being recorded in the undo buffer.

Remarks

Do not filter commands that create or delete items and groups. Otherwise, redoing or undoing recorded commands related to the items whose create/delete command is filtered will cause various exceptions. We recommend to filter commands that modify an item, change its selection state, scroll a table, and so on.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ActionRecorded Event
ActionRedone Event


MindFusion.Diagramming.Diagram.ActionRedone Event

Diagram.ActionRedone Event

Raised when an action is redone.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event UndoEventHandler ActionRedone
Visual Basic

Public Event ActionRedone As UndoEventHandler

Event Data

ActionRedone event handlers receive an argument of type UndoEventArgs. The following UndoEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command that has been redone.

Remarks

This event is raised during calls to Redo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ActionRecorded Event
ActionUndone Event


MindFusion.Diagramming.Diagram.ActionUndone Event

Diagram.ActionUndone Event

Raised when an action is undone.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event UndoEventHandler ActionUndone
Visual Basic

Public Event ActionUndone As UndoEventHandler

Event Data

ActionUndone event handlers receive an argument of type UndoEventArgs. The following UndoEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command that has been undone.

Remarks

This event is raised during calls to Undo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ActionRecorded Event
ActionRedone Event


MindFusion.Diagramming.Diagram.BeginLoad Event

Diagram.BeginLoad Event

Raised when the component starts loading diagram data from a file or memory stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event EventHandler BeginLoad
Visual Basic

Public Event BeginLoad As EventHandler

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
EndLoad Event


MindFusion.Diagramming.Diagram.BoundsChanged Event

Diagram.BoundsChanged Event

Raised when the Bounds property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event EventHandler BoundsChanged
Visual Basic

Public Event BoundsChanged As EventHandler

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
MeasureUnitChanged Event
ActionRedone Event


MindFusion.Diagramming.Diagram.CellClicked Event

Diagram.CellClicked Event

Raised when the user clicks a table's cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event CellEventHandler CellClicked
Visual Basic

Public Event CellClicked As CellEventHandler

Event Data

CellClicked event handlers receive an argument of type CellEventArgs. The following CellEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the clicked cell.
Cell | The Cell that has been clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.
Column | Index of the column containing the clicked cell.
Row | Index of the row containing the clicked cell.

Remarks

If there is some handler attached to this event, NodeClicked won't be raised for the table that contains the clicked cell, but only CellClicked.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
CellDoubleClicked Event
ActionRedone Event


MindFusion.Diagramming.Diagram.CellDoubleClicked Event

Diagram.CellDoubleClicked Event

Raised when the user double-clicks a table's cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event CellEventHandler CellDoubleClicked
Visual Basic

Public Event CellDoubleClicked As CellEventHandler

Event Data

CellDoubleClicked event handlers receive an argument of type CellEventArgs. The following CellEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the clicked cell.
Cell | The Cell that has been double-clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.
Column | Index of the column containing the clicked cell.
Row | Index of the row containing the clicked cell.

Remarks

If there is some handler attached to this event, NodeDoubleClicked won't be raised for the table that contains the clicked cell, but only CellDoubleClicked.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
CellClicked Event


MindFusion.Diagramming.Diagram.CellTextEdited Event

Diagram.CellTextEdited Event

Raised when the user edits the text of a table's cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event EditCellTextEventHandler CellTextEdited
Visual Basic

Public Event CellTextEdited As EditCellTextEventHandler

Event Data

CellTextEdited event handlers receive an argument of type EditCellTextEventArgs. The following EditCellTextEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the edited cell.
Cell | The Cell whose text has been edited.
NewText | The cell's new text.
OldText | The cell's old text.
Column | Index of the column containing the edited cell.
Row | Index of the row containing the edited cell.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
CellTextEditing Event
ActionRedone Event


MindFusion.Diagramming.Diagram.CellTextEditing Event

Diagram.CellTextEditing Event

A validation event that lets you prevent users from editing the text of a table's cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event CellValidationEventHandler CellTextEditing
Visual Basic

Public Event CellTextEditing As CellValidationEventHandler

Event Data

CellTextEditing event handlers receive an argument of type CellValidationEventArgs. The following CellValidationEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode containing the cell that the user is trying to edit.
Cell | The Cell that the user is trying to edit.
Column | Index of the column containing the cell.
Row | Index of the row containing the cell.
Cancel | Set this property to true to prevent the user from editing the cell's text.

See Also

Diagram Members
Diagram Class
NodeTextEditing
MindFusion.Diagramming Namespace
CellTextEdited Event
ActionRedone Event


MindFusion.Diagramming.Diagram.Clicked Event

Diagram.Clicked Event

Raised when the user clicks the diagram at a point where no items are located.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event DiagramEventHandler Clicked
Visual Basic

Public Event Clicked As DiagramEventHandler

Event Data

Clicked event handlers receive an argument of type DiagramEventArgs. The following DiagramEventArgs members provide information relevant to the event:

Member name | Description
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.

Remarks

This event is raised only if the user clicks an unoccupied point of the diagram. If the user clicks a diagram item, one of the following events is raised: NodeClicked, CellClicked or LinkClicked.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
CellDoubleClicked Event


MindFusion.Diagramming.Diagram.ContainerChildAdded Event

Diagram.ContainerChildAdded Event

Raised when a node is added to a ContainerNode, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event ContainerChildEventHandler ContainerChildAdded
Visual Basic

Public Event ContainerChildAdded As ContainerChildEventHandler

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ContainerChildRemoved Event


MindFusion.Diagramming.Diagram.ContainerChildRemoved Event

Diagram.ContainerChildRemoved Event

Raised when a node is removed from a ContainerNode, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event ContainerChildEventHandler ContainerChildRemoved
Visual Basic

Public Event ContainerChildRemoved As ContainerChildEventHandler

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ContainerChildAdded Event


MindFusion.Diagramming.Diagram.ContainerFolded Event

Diagram.ContainerFolded Event

Raised when the user folds a container by clicking the arrow-up button in the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler ContainerFolded
Visual Basic

Public Event ContainerFolded As NodeEventHandler

Event Data

ContainerFolded event handlers receive an argument of type NodeEventArgs.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ContainerUnfolded Event

Diagram.ContainerUnfolded Event

Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler ContainerUnfolded
Visual Basic

Public Event ContainerUnfolded As NodeEventHandler

Event Data

ContainerUnfolded event handlers receive an argument of type NodeEventArgs.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.DefaultShapeChanged Event

Diagram.DefaultShapeChanged Event

Raised when the DefaultShape property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event EventHandler DefaultShapeChanged
Visual Basic

Public Event DefaultShapeChanged As EventHandler

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.DeserializeTag Event

Diagram.DeserializeTag Event

Raised when the Tag of a diagram item must be deserialized from XML format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event SerializeTagEventHandler DeserializeTag
Visual Basic

Public Event DeserializeTag As SerializeTagEventHandler

Event Data

DeserializeTag event handlers receive an argument of type SerializeTagEventArgs. The following SerializeTagEventArgs members provide information relevant to the event:

Member name | Description
Object | The object whose Tag is being deserialized. This object can be either a diagram item, group, cell or anchor point.
Tag | Set this property to the object that has been deserialized.
Representation | An XmlElement instance that contains the XML representation of a Tag value.
Context | An XmlPersistContext object providing information about the document being deserialized, along with methods that help you deserialize data from XML.
Handled | Set this flag to true if you perform custom tag deserialization.

Remarks

Only tags of simple value types can be saved and loaded automatically to/from the XML document. You must provide your own serialization for complex types by implementing this event and SerializeTag.

Example

The following example demonstrates how to deserialize a complex tag value using the DeserializeTag event.

C#

private void Read(string fileName)
{
diagram.DeserializeTag += new SerializeTagEventHandler(DeserializeTag);
diagram.LoadFromXml(fileName);
}

private void DeserializeTag(object sender, SerializeTagEventArgs e)
{
e.Handled = true;
string type, val;

XmlText textNode = e.Representation.LastChild as XmlText;
string stringRep = textNode.Value;
int pos = stringRep.IndexOf(";");

if (pos == -1)
return;

type = stringRep.Substring(0, pos);
val = stringRep.Substring(pos + 1);

Type t = Type.GetType(type);

object tag = null;
if (t == typeof(string))
tag = val;
else if (t == typeof(int))
tag = XmlConvert.ToInt32(val);

e.Tag = tag;
}
Visual Basic

Private Sub Read(ByVal fileName As String)

AddHandler diagram.DeserializeTag, New SerializeTagEventHandler(AddressOf DeserializeTag)
diagram.LoadFromXml(fileName)

End Sub

Private Sub DeserializeTag(ByVal sender As Object, ByVal e As SerializeTagEventArgs)

e.Handled = True

Dim type As String
Dim val As String

Dim textNode As XmlText = CType(e.Representation.LastChild, XmlText)
Dim stringRep As String = textNode.Value
Dim pos As Integer = stringRep.IndexOf(";")

If pos = -1 Then
Return
End If

type = stringRep.Substring(0, pos)
val = stringRep.Substring(pos + 1)

Dim t As Type = System.Type.GetType(type)

Dim tag As Object = Nothing
If t Is GetType(String) Then
tag = val
ElseIf t Is GetType(Integer) Then
tag = XmlConvert.ToInt32(val)
End If

e.Tag = tag

End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LoadFromXml Method


MindFusion.Diagramming.Diagram.DestinationAnchorChanged Event

Diagram.DestinationAnchorChanged Event

Raised when the DestinationAnchor property value of a link has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event AnchorPointEventHandler DestinationAnchorChanged
Visual Basic

Public Event DestinationAnchorChanged As AnchorPointEventHandler

Event Data

DestinationAnchorChanged event handlers receive an argument of type AnchorPointEventArgs. The following AnchorPointEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink whose DestinationAnchor has changed.
OldAnchorIndex | Index of the old anchor point.
NewAnchorIndex | Index of the new anchor point.

Remarks

This event is raised every time the DestinationAnchor property of a link changes, either because a user connects the link end to a different anchor point, or because an application sets it programmatically.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
OriginAnchorChanged Event
ActionRedone Event


MindFusion.Diagramming.Diagram.DirtyChanged Event

Diagram.DirtyChanged Event

Raised when the Dirty property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event EventHandler DirtyChanged
Visual Basic

Public Event DirtyChanged As EventHandler

Remarks

Dirty is set to true every time the diagram is modified, but this event is raised only if the flag value changes, either from false to true or from true to false. So the event occurs only when a diagram is modified for the first time, but not when subsequent modifications are done.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ActionRecorded Event


MindFusion.Diagramming.Diagram.DoubleClicked Event

Diagram.DoubleClicked Event

Raised when the user double-clicks the diagram at a point where no items are located.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event DiagramEventHandler DoubleClicked
Visual Basic

Public Event DoubleClicked As DiagramEventHandler

Event Data

DoubleClicked event handlers receive an argument of type DiagramEventArgs. The following DiagramEventArgs members provide information relevant to the event:

Member name | Description
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.

Remarks

This event is raised only if the user double-clicks an unoccupied point of the diagram. If the user double-clicks a diagram item, one of the following events is raised: NodeDoubleClicked, CellDoubleClicked or LinkDoubleClicked.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ActionRedone Event
Clicked Event


MindFusion.Diagramming.Diagram.DrawAdjustmentHandles Event

Diagram.DrawAdjustmentHandles Event

Raised when item's adjustment handles must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event DrawItemEventHandler DrawAdjustmentHandles
Visual Basic

Public Event DrawAdjustmentHandles As DrawItemEventHandler

Event Data

DrawAdjustmentHandles event handlers receive an argument of type DrawItemEventArgs. The following DrawItemEventArgs members provide information relevant to the event:

Member name | Description
Item | The DiagramItem whose adjustment handles should be drawn.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the item's handles.

Remarks

DrawAdjustmentHandles is raised for selected items whose HandlesStyle is set to Custom.

Example

The following example illustrates how to draw a red frame around a node as a visualization of its adjustment handles.

C#

void diagram_DrawAdjustmentHandles(object sender, MindFusion.Diagramming.DrawItemEventArgs e)
{
System.Drawing.Pen pen = new System.Drawing.Pen(Color.Red, 0);

if (e.Item is ShapeNode)
{
ShapeNode shapeNode = e.Item as ShapeNode;
RectangleF r = shapeNode.Bounds;
e.Graphics.DrawRectangle(pen, r.X, r.Y, r.Width, r.Height);
}

if (e.Item is DiagramLink)
{
DiagramLink link = e.Item as DiagramLink;
e.Graphics.DrawLines(pen, link.ControlPoints.GetArray());
}

pen.Dispose();
}
Visual Basic

Sub diagram_DrawAdjustmentHandles(ByVal sender As Object, ByVal e As MindFusion.Diagramming.DrawItemEventArgs)

Dim Pen As System.Drawing.Pen = New System.Drawing.Pen(Color.Red, 0)

If TypeOf e.Item Is ShapeNode Then

Dim shapeNode As ShapeNode = CType(e.Item, ShapeNode)
Dim r As RectangleF = shapeNode.Bounds
e.Graphics.DrawRectangle(Pen, r.X, r.Y, r.Width, r.Height)

End If

If TypeOf e.Item Is DiagramLink Then

Dim link As DiagramLink = CType(e.Item, DiagramLink)
e.Graphics.DrawLines(Pen, link.ControlPoints.GetArray())

End If

Pen.Dispose()

End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
HitTestAdjustmentHandles Event


MindFusion.Diagramming.Diagram.DrawAnchorPoint Event

Diagram.DrawAnchorPoint Event

Raised when an anchor point must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event DrawAnchorPointEventHandler DrawAnchorPoint
Visual Basic

Public Event DrawAnchorPoint As DrawAnchorPointEventHandler

Event Data

DrawAnchorPoint event handlers receive an argument of type DrawAnchorPointEventArgs. The following DrawAnchorPointEventArgs members provide information relevant to the event:

Member name | Description
Node | A DiagramNode containing the anchor point that is being painted.
AnchorIndex | Index of the anchor point withing the node's AnchorPattern.
AnchorPattern | An AnchorPattern instance that contains the anchor point definition.
Location | A PointF specifying the location of the anchor point.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the anchor point mark.

Remarks

DrawAnchorPoint is raised for an AnchorPoint if the point's MarkStyle is set to Custom.

Example

The following example demonstrates how to draw images for anchor points:

C#

void diagram_DrawAnchorPoint(object sender, DrawAnchorPointEventArgs e)
{
PointF imgPos = e.Location;
imgPos.Y -= 1.8f;

e.Graphics.DrawImage(icon, imgPos);
}
Visual Basic

Sub diagram_DrawAnchorPoint(ByVal sender As Object, ByVal e As DrawAnchorPointEventArgs) Handles diagram.DrawAnchorPoint

Dim imgPos As PointF = e.Location
imgPos.Y -= 1.8F

e.Graphics.DrawImage(icon, imgPos)

End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.DrawBackground Event

Diagram.DrawBackground Event

Raised to let you custom draw the diagram background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event DiagramEventHandler DrawBackground
Visual Basic

Public Event DrawBackground As DiagramEventHandler

Event Data

DrawBackground event handlers receive an argument of type DiagramEventArgs. The following DiagramEventArgs members provide information relevant to the event:

Member name | Description
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the custom graphics.
VisibleRect | Specifies what part of the diagram is currently visible.
ClipRect | Gets the current clipping rectangle.

Remarks

This event is raised just after drawing the BackgroundImage and before drawing the alignment grid.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DrawForeground Event


MindFusion.Diagramming.Diagram.DrawCell Event

Diagram.DrawCell Event

Raised when a table's cell must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event DrawCellEventHandler DrawCell
Visual Basic

Public Event DrawCell As DrawCellEventHandler

Event Data

DrawCell event handlers receive an argument of type DrawCellEventArgs. The following DrawCellEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode containing the cell that should be custom drawn.
Cell | The Cell that should be custom drawn.
Column | Index of the column containing the cell.
Row | Index of the row containing the cell.
Bounds | Gets the bounding rectangle of the cell being drawn.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the cell contents.

Remarks

This event is raised for tables whose CellCustomDraw property is enabled.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DrawNode Event
ActionRedone Event


MindFusion.Diagramming.Diagram.DrawForeground Event

Diagram.DrawForeground Event

Raised to let you custom draw the diagram foreground.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event DiagramEventHandler DrawForeground
Visual Basic

Public Event DrawForeground As DiagramEventHandler

Event Data

DrawForeground event handlers receive an argument of type DiagramEventArgs. The following DiagramEventArgs members provide information relevant to the event:

Member name | Description
ClipRect | Gets the current clipping rectangle.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the custom graphics.
VisibleRect | Specifies what part of the diagram is currently visible.

Remarks

This event is raised after all diagram elements has been rendered, but before drawing the diagram boundaries with BoundsPen.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DrawBackground Event


MindFusion.Diagramming.Diagram.DrawLink Event

Diagram.DrawLink Event

Raised when a diagram link must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event DrawLinkEventHandler DrawLink
Visual Basic

Public Event DrawLink As DrawLinkEventHandler

Event Data

DrawLink event handlers receive an argument of type DrawLinkEventArgs. The following DrawLinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that should be custom drawn.
Points | Gets a collection of the link's control points. When drawing shadows, the points are offset as necessary.
Shadow | True if now drawing the link's shadow, otherwise false.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the link.

Remarks

This event is raised for links whose CustomDraw property is enabled.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DrawNode Event


MindFusion.Diagramming.Diagram.DrawNode Event

Diagram.DrawNode Event

Raised when a diagram node must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event DrawNodeEventHandler DrawNode
Visual Basic

Public Event DrawNode As DrawNodeEventHandler

Event Data

DrawNode event handlers receive an argument of type DrawNodeEventArgs. The following DrawNodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that should be custom drawn.
Bounds | The bounding rectangle of the node being drawn.
Shadow | True if now drawing the node’s shadow, otherwise false.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the node.

Remarks

This event is raised for links whose CustomDraw property is enabled.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DrawLink Event


MindFusion.Diagramming.Diagram.EndLoad Event

Diagram.EndLoad Event

Raised when the component ends loading diagram data from a file or memory stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event EventHandler EndLoad
Visual Basic

Public Event EndLoad As EventHandler

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
BeginLoad Event
ActionRedone Event


MindFusion.Diagramming.Diagram.ExpandButtonClicked Event

Diagram.ExpandButtonClicked Event

Raised when the user clicks the [±] button of an Expandable node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler ExpandButtonClicked
Visual Basic

Public Event ExpandButtonClicked As NodeEventHandler

Event Data

ExpandButtonClicked event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode whose [±] button has been clicked.

Remarks

This event is raised only if ExpandButtonAction is set to RaiseEvents. Otherwise either the TreeCollapsed or TreeExpanded event is raised, depending on the state of the node.

Example

The following sample code hides or shows all subordinated nodes in a group when the master node's [±] button is clicked:

C#

void diagram_ExpandButtonClicked(object sender, NodeEventArgs e)
{
if (e.Node.SubordinateGroup != null)
{
foreach (DiagramItem item in e.Node.SubordinateGroup.AttachedNodes)
item.Visible = e.Node.Expanded;
}
}
Visual Basic

Sub diagram_ExpandButtonClicked(ByVal sender As Object, ByVal e As NodeEventArgs) Handles diagram.ExpandButtonClicked

If Not e.Node.SubordinateGroup Is Nothing Then

Dim item As DiagramItem
For Each item In e.Node.SubordinateGroup.AttachedNodes
item.Visible = e.Node.Expanded
Next

End If

End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.GroupDestroyed Event

Diagram.GroupDestroyed Event

Raised when a Group object is destroyed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event GroupEventHandler GroupDestroyed
Visual Basic

Public Event GroupDestroyed As GroupEventHandler

Event Data

GroupDestroyed event handlers receive an argument of type GroupEventArgs. The following GroupEventArgs members provide information relevant to the event:

Member name | Description
Group | The Group that has been destroyed.

Remarks

A group can be destroyed in several ways:

  • by removing it from the diagram's Groups collection.
  • by deleting the group's MainItem.
  • in case the main item is a link, if the control point or segment to which subordinated items are attached is removed. That could happen if link's Style or SegmentCount properties change.

When a group is destroyed, by default the group items are not deleted automatically. You could delete such items from the GroupDestroyed handler, or enable AutoDeleteItems to delete them automatically when the group is destroyed.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.HitTestAdjustmentHandles Event

Diagram.HitTestAdjustmentHandles Event

Raised when custom hit testing of item's adjustment handles must be performed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event HitTestEventHandler HitTestAdjustmentHandles
Visual Basic

Public Event HitTestAdjustmentHandles As HitTestEventHandler

Event Data

HitTestAdjustmentHandles event handlers receive an argument of type HitTestEventArgs. The following HitTestEventArgs members provide information relevant to the event:

Member name | Description
Item | A DiagramItem whose adjustment handles should be hit tested.
MousePosition | A PointF specifying the mouse cursor position.
HitResult | Set this property to the index of the adjustment handle that has been hit.

Remarks

For links, set the result to the index of the link's control point that has been hit. For nodes, set the result to 0, 1, 2, 3 for the corner resize handles, 4, 5, 6, 7 for the side center resize handles, 8 for the move handle and 9 for the rotation handle.

Example

C#

void diagram_HitTestAdjustmentHandles(object sender, HitTestEventArgs e)
{
ShapeNode shapeNode = e.Item as ShapeNode;
if (shapeNode != null)
{
if (shapeNode.Bounds.Contains(e.MousePosition))
{
// Always move
e.HitResult = 8;
}
}
}
Visual Basic

Private Sub diagram_HitTestAdjustmentHandles(ByVal sender As Object, ByVal e As HitTestEventArgs) Handles diagram.HitTestAdjustmentHandles

Dim shapeNode As ShapeNode = CType(e.Item, ShapeNode)

If Not shapeNode Is Nothing Then

If (shapeNode.Bounds.Contains(e.MousePosition)) Then

' Always move
e.HitResult = 8

End If

End If

End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.InitializeLink Event

Diagram.InitializeLink Event

Raised when the user starts drawing a new link, just after the DiagramLink instance is created.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkEventHandler InitializeLink
Visual Basic

Public Event InitializeLink As LinkEventHandler

Event Data

InitializeLink event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The new DiagramLink instance.

Remarks

This event is raised immediately after the user starts drawing a new link. It lets you set the appearance properties of the link if you need their values to be different from the default ones defined in the Diagram object, or if they don't have correspondent properties in the Diagram class. The Initialize* events are intended only for initializing the appearance of items. Do not alter the structure of the diagram from their handlers, that is, do not create new items nor delete existing ones; if you do that, the control will be in an undefined state and will likely throw an exception at some point.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkCreated Event
ActionRedone Event
LinkCreating Event


MindFusion.Diagramming.Diagram.InitializeNode Event

Diagram.InitializeNode Event

Raised when the user starts drawing a new node, just after the DiagramNode instance is created.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler InitializeNode
Visual Basic

Public Event InitializeNode As NodeEventHandler

Event Data

InitializeNode event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The new DiagramNode instance.

Remarks

This event is raised immediately after the user starts drawing a new node. It lets you set the appearance properties of the node if you need their values to be different from the default ones defined in the Diagram object, or if they don't have correspondent properties in the Diagram class. The Initialize* events are intended only for initializing the appearance of items. Do not alter the structure of the diagram from their handlers, that is, do not create new items nor delete existing ones; if you do that, the control will be in an undefined state and will likely throw an exception at some point.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeCreated Event
ActionRedone Event
NodeCreating Event


MindFusion.Diagramming.Diagram.ItemAdded Event

Diagram.ItemAdded Event

Raised when an item is added to the diagram, either programmatically or interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event ItemEventHandler ItemAdded
Visual Basic

Public Event ItemAdded As ItemEventHandler

Event Data

ItemAdded event handlers receive an argument of type ItemEventArgs. The following ItemEventArgs members provide information relevant to the event:

Member name | Description
Item | The DiagramItem that has been added to the diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ItemRemoved Event


MindFusion.Diagramming.Diagram.ItemRemoved Event

Diagram.ItemRemoved Event

Raised when an item is removed from the diagram, either programmatically or interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event ItemEventHandler ItemRemoved
Visual Basic

Public Event ItemRemoved As ItemEventHandler

Event Data

ItemRemoved event handlers receive an argument of type ItemEventArgs. The following ItemEventArgs members provide information relevant to the event:

Member name | Description
Item | The DiagramItem that has been removed from the diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
ItemAdded Event


MindFusion.Diagramming.Diagram.LinkActivated Event

Diagram.LinkActivated Event

Raised when a link becomes the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkEventHandler LinkActivated
Visual Basic

Public Event LinkActivated As LinkEventHandler

Event Data

LinkActivated event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has become the ActiveItem.

Remarks

When the event is raised, ActiveItem already refers to the activated link. If multiple selection is disabled, the active item is the only item selected by the user; otherwise it is usually the one added last to the selection.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkDeactivated Event
LinkDeselected Event


MindFusion.Diagramming.Diagram.LinkClicked Event

Diagram.LinkClicked Event

Raised when the user clicks a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkEventHandler LinkClicked
Visual Basic

Public Event LinkClicked As LinkEventHandler

Event Data

LinkClicked event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkDoubleClicked Event


MindFusion.Diagramming.Diagram.LinkCreated Event

Diagram.LinkCreated Event

Raised when the user draws a new link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkEventHandler LinkCreated
Visual Basic

Public Event LinkCreated As LinkEventHandler

Event Data

LinkCreated event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been created.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
InitializeLink Event
LinkCreating Event


MindFusion.Diagramming.Diagram.LinkCreating Event

Diagram.LinkCreating Event

A validation event raised while the user is drawing a new link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkValidationEventHandler LinkCreating
Visual Basic

Public Event LinkCreating As LinkValidationEventHandler

Event Data

LinkCreating event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that is being created.
MousePosition | A PointF specifying the mouse cursor position.
Destination | The DiagramNode that will be set as the link’s Destination if this event is validated.
AnchorIndex | Index of the anchor point to which the link will be connected if this event is validated.
TableRow | Index of the table row to which the link will be connected if this event is validated.
Cancel | Set this property to true to prevent the user from creating the link at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the link creation.

Remarks

LinkCreating is raised after each mouse movement while drawing a new link. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the link creation.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkCreated Event


MindFusion.Diagramming.Diagram.LinkDeactivated Event

Diagram.LinkDeactivated Event

Raised when a link is no longer the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkEventHandler LinkDeactivated
Visual Basic

Public Event LinkDeactivated As LinkEventHandler

Event Data

LinkDeactivated event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | A DiagramLink that was the ActiveItem.

Remarks

LinkDeactivated is raised when the ActiveItem changes and before that it referred to a link.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkActivated Event


MindFusion.Diagramming.Diagram.LinkDeleted Event

Diagram.LinkDeleted Event

Raised when a link is deleted, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkEventHandler LinkDeleted
Visual Basic

Public Event LinkDeleted As LinkEventHandler

Event Data

LinkDeleted event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been deleted.

Remarks

The link is removed from the Items and Links collections before the event is raised. From within an event handler you can still check the values of simple properties such as Text or Tag. Before deleting a node, all links that link to it a deleted too. So there might be several LinkDeleted events raised before NodeDeleted is raised.

To prevent users from deleting a link by pressing the DEL key, handle the LinkDeleting event.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkCreated Event


MindFusion.Diagramming.Diagram.LinkDeleting Event

Diagram.LinkDeleting Event

Raised when the user tries to delete a link, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkValidationEventHandler LinkDeleting
Visual Basic

Public Event LinkDeleting As LinkValidationEventHandler

Event Data

LinkDeleting event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | A DiagramLink that the user is trying to delete by pressing the DEL key.
Cancel | Set this property to true to prevent the user from deleting the link.

Remarks

When users delete a node, its connecting links are deleted too. However, in that case LinkDeleting validation events are not raised, but just NodeDeleting.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkDeleted Event


MindFusion.Diagramming.Diagram.LinkDeselected Event

Diagram.LinkDeselected Event

Raised when a link is deselected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkEventHandler LinkDeselected
Visual Basic

Public Event LinkDeselected As LinkEventHandler

Event Data

LinkDeselected event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been deselected.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkSelected Event


MindFusion.Diagramming.Diagram.LinkDoubleClicked Event

Diagram.LinkDoubleClicked Event

Raised when the user double-clicks a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkEventHandler LinkDoubleClicked
Visual Basic

Public Event LinkDoubleClicked As LinkEventHandler

Event Data

LinkDoubleClicked event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:
Member name | Description
Link | The DiagramLink that has been double-clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkClicked Event


MindFusion.Diagramming.Diagram.LinkModified Event

Diagram.LinkModified Event

Raised when the user moves any control point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkEventHandler LinkModified
Visual Basic

Public Event LinkModified As LinkEventHandler

Event Data

LinkModified event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been modified.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that has been moved.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkModifying Event


MindFusion.Diagramming.Diagram.LinkModifying Event

Diagram.LinkModifying Event

A validation event raised while the user is modifying a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkValidationEventHandler LinkModifying
Visual Basic

Public Event LinkModifying As LinkValidationEventHandler

Event Data

LinkModifying event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that is being modified.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that is being moved.
ChangingOrigin | A value indicating whether the operation changes the origin of the link.
Origin | The DiagramNode that will be set as the link's Origin if this event is validated.
ChangingDestination | A value indicating whether the operation changes the destination of the link.
Destination | The DiagramNode that will be set as the link's Destination if this event is validated.
AnchorIndex | Index of the anchor point to which the link will be connected if this event is validated.
TableRow | Index of the table row to which the link will be connected if this event is validated.
Cancel | Set this property to true to prevent the user from ending the modification at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the link modification.

Remarks

This event is raised after each mouse movement while modifying a link. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the modification and return the link to its original state.

The AdjustmentHandle index corresponds to the link's control point that is being dragged.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkModified Event


MindFusion.Diagramming.Diagram.LinkPasted Event

Diagram.LinkPasted Event

Raised when a link has been pasted from the clipboard.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkEventHandler LinkPasted
Visual Basic

Public Event LinkPasted As LinkEventHandler

Event Data

LinkPasted event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been pasted from the clipboard.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramView.PasteFromClipboard Method


MindFusion.Diagramming.Diagram.LinkRouted Event

Diagram.LinkRouted Event

Raised when a link is routed by the auto-routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkEventHandler LinkRouted
Visual Basic

Public Event LinkRouted As LinkEventHandler

Event Data

LinkRouted event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been routed.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
AutoRoute Property


MindFusion.Diagramming.Diagram.LinkSelected Event

Diagram.LinkSelected Event

Raised when a link is selected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkEventHandler LinkSelected
Visual Basic

Public Event LinkSelected As LinkEventHandler

Event Data

LinkSelected event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been selected.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkDeselected Event


MindFusion.Diagramming.Diagram.LinkSelecting Event

Diagram.LinkSelecting Event

Raised when the user tries to select a link, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkValidationEventHandler LinkSelecting
Visual Basic

Public Event LinkSelecting As LinkValidationEventHandler

Event Data

LinkSelecting event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that the user is trying to select.
MousePosition | A PointF specifying the mouse cursor position.
SelectionRectangle | The current selection rectangle.

Remarks

LinkSelecting is raised in two distinct cases - when the user clicks a link, or while the user is drawing a selection rectangle. When raised because of a mouse click, the MousePosition argument is set to a valid point and the SelectionRectangle argument equals to RectangleF.Empty. While the user is drawing a selection rectangle, the event is raised for each mouse movement, the SelectionRectangle contains the selection coordinates and the MousePosition parameter equals to PointF.Empty.

LinkSelecting is raised while enumerating all items in the z-order collection, so you cannot change the link's ZIndex while handling this event. A selection-related event suitable for changing the z-order of items is SelectionChanged.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkSelected Event


MindFusion.Diagramming.Diagram.LinkStartModifying Event

Diagram.LinkStartModifying Event

A validation event raised when the user starts modifying a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkValidationEventHandler LinkStartModifying
Visual Basic

Public Event LinkStartModifying As LinkValidationEventHandler

Event Data

LinkStartModifying event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that the user is starting to modify.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that is going to be moved.
Cancel | Set this property to true to prevent the user from starting the link modification.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
LinkModifying Event
ActionRedone Event


MindFusion.Diagramming.Diagram.LinkTextEdited Event

Diagram.LinkTextEdited Event

Raised when the user edits the text of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event EditLinkTextEventHandler LinkTextEdited
Visual Basic

Public Event LinkTextEdited As EditLinkTextEventHandler

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.LinkTextEditing Event

Diagram.LinkTextEditing Event

A validation event that lets you approve or reject changes made to the text of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkValidationEventHandler LinkTextEditing
Visual Basic

Public Event LinkTextEditing As LinkValidationEventHandler

See Also

Diagram Members
Diagram Class
NodeTextEditing
CellTextEditing
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.MeasureUnitChanged Event

Diagram.MeasureUnitChanged Event

Raised when the MeasureUnit property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event EventHandler MeasureUnitChanged
Visual Basic

Public Event MeasureUnitChanged As EventHandler

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
BoundsChanged Event
ActionRedone Event


MindFusion.Diagramming.Diagram.NodeActivated Event

Diagram.NodeActivated Event

Raised when a node becomes the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler NodeActivated
Visual Basic

Public Event NodeActivated As NodeEventHandler

Event Data

NodeActivated event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has become the ActiveItem.

Remarks

When this event is raised, ActiveItem already refers to the activated node. If multiple selection is disabled, the active item is the only item selected by the user; otherwise usually it is the one added last to the selection.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeDeactivated Event
NodeSelected Event


MindFusion.Diagramming.Diagram.NodeClicked Event

Diagram.NodeClicked Event

Raised when the user clicks a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler NodeClicked
Visual Basic

Public Event NodeClicked As NodeEventHandler

Event Data

NodeClicked event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeDoubleClicked Event
CellClicked Event


MindFusion.Diagramming.Diagram.NodeCreated Event

Diagram.NodeCreated Event

Raised when the user draws a new node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler NodeCreated
Visual Basic

Public Event NodeCreated As NodeEventHandler

Event Data

NodeCreated event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been created.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
InitializeNode Event
NodeCreating Event
ActionRedone


MindFusion.Diagramming.Diagram.NodeCreating Event

Diagram.NodeCreating Event

A validation event raised while the user is drawing a new node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeValidationEventHandler NodeCreating
Visual Basic

Public Event NodeCreating As NodeValidationEventHandler

Event Data

NodeCreating event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that is being created.
MousePosition | A PointF specifying the mouse cursor position.
Cancel | Set this property to true to prevent the user from creating the node at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the node creation.

Remarks

NodeCreating is raised after each mouse movement while drawing a new node. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the node creation.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeCreated Event


MindFusion.Diagramming.Diagram.NodeDeactivated Event

Diagram.NodeDeactivated Event

Raised when a node is no longer the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler NodeDeactivated
Visual Basic

Public Event NodeDeactivated As NodeEventHandler

Event Data

NodeDeactivated event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | A DiagramNode that was the ActiveItem.

Remarks

NodeDeactivated is raised when the ActiveItem changes and before that it referred to a node.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeActivated Event


MindFusion.Diagramming.Diagram.NodeDeleted Event

Diagram.NodeDeleted Event

Raised when a node is deleted, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler NodeDeleted
Visual Basic

Public Event NodeDeleted As NodeEventHandler

Event Data

NodeDeleted event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been deleted.

Remarks

When the event is raised, the node is already removed from the Items and Nodes collections and all links connected to the node are deleted. From within an event handler you can still check the values of simple properties of the node such as Text or Tag.

To prevent users from deleting a node by pressing the DEL key, handle the NodeCreating event.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeDeleting Event
NodeCreated Event


MindFusion.Diagramming.Diagram.NodeDeleting Event

Diagram.NodeDeleting Event

Raised when the user tries to delete a node, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeValidationEventHandler NodeDeleting
Visual Basic

Public Event NodeDeleting As NodeValidationEventHandler

Event Data

NodeDeleting event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | A DiagramNode that the user is trying to delete by pressing the DEL key.
Cancel | Set this property to true to prevent the user from deleting the node.

Remarks

When the user deletes a node, the links connected to it are deleted too. However, the LinkDeleting validation event is not raised in that case.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeDeleted Event


MindFusion.Diagramming.Diagram.NodeDeselected Event

Diagram.NodeDeselected Event

Raised when a node is deselected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler NodeDeselected
Visual Basic

Public Event NodeDeselected As NodeEventHandler

Event Data

NodeDeselected event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been deselected.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeSelected Event


MindFusion.Diagramming.Diagram.NodeDoubleClicked Event

Diagram.NodeDoubleClicked Event

Raised when the user double-clicks a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler NodeDoubleClicked
Visual Basic

Public Event NodeDoubleClicked As NodeEventHandler

Event Data

NodeDoubleClicked event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been double-clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A PointF specifying the mouse cursor position.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeClicked Event


MindFusion.Diagramming.Diagram.NodeModified Event

Diagram.NodeModified Event

Raised when the user moves or resizes a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler NodeModified
Visual Basic

Public Event NodeModified As NodeEventHandler

Event Data

NodeModified event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been modified.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | The adjustment handle that has been moved.

Remarks

NodeModified is not raised if the node position is changed programmatically. The event occurs only when the user has dragged an adjustment handle to a new position.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeModifying Event


MindFusion.Diagramming.Diagram.NodeModifying Event

Diagram.NodeModifying Event

A validation event raised while the user is moving or resizing a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeValidationEventHandler NodeModifying
Visual Basic

Public Event NodeModifying As NodeValidationEventHandler

Event Data

NodeModifying event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that is being modified.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | The adjustment handle that is being moved.
Cancel | Set this property to true to prevent the user from ending the modification at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the node modification.

Remarks

This event is raised after each mouse movement while modifying a node. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the modification and return the node to its original location.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeModified Event


MindFusion.Diagramming.Diagram.NodePasted Event

Diagram.NodePasted Event

Raised when a node has been pasted from the clipboard.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler NodePasted
Visual Basic

Public Event NodePasted As NodeEventHandler

Event Data

NodePasted event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been pasted from the clipboard.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DiagramView.PasteFromClipboard Method


MindFusion.Diagramming.Diagram.NodeSelected Event

Diagram.NodeSelected Event

Raised when a node is selected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler NodeSelected
Visual Basic

Public Event NodeSelected As NodeEventHandler

Event Data

NodeSelected event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been selected.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeDeselected Event


MindFusion.Diagramming.Diagram.NodeSelecting Event

Diagram.NodeSelecting Event

Raised when the user tries to select a node, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeValidationEventHandler NodeSelecting
Visual Basic

Public Event NodeSelecting As NodeValidationEventHandler

Event Data

NodeSelecting event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that the user is trying to select.
MousePosition | A PointF specifying the mouse cursor position.
SelectionRectangle | The current selection rectangle.

Remarks

NodeSelecting is raised in two distinct cases - when the user clicks a node, or while the user is drawing a selection rectangle. When raised because of a mouse click, the MousePosition argument is set to a valid point and the SelectionRectangle argument equals to RectangleF.Empty. While the user is drawing a selection rectangle, the event is raised for each mouse movement, the SelectionRectangle contains the selection coordinates and the MousePosition parameter equals to PointF.Empty.

NodeSelecting is raised while enumerating all items in the z-order collection, so you cannot change the node's ZIndex while handling this event. A selection-related event suitable for changing the z-order of items is SelectionChanged.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeSelected Event


MindFusion.Diagramming.Diagram.NodeStartModifying Event

Diagram.NodeStartModifying Event

A validation event raised when the user starts modifying a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeValidationEventHandler NodeStartModifying
Visual Basic

Public Event NodeStartModifying As NodeValidationEventHandler

Event Data

NodeStartModifying event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that the user is starting to modify.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | The adjustment handle that is going to be moved.
Cancel | Set this property to true to prevent the user from starting the node modification.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeModifying Event
ActionRedone Event


MindFusion.Diagramming.Diagram.NodeTextEdited Event

Diagram.NodeTextEdited Event

Raised when the user edits the text of a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event EditNodeTextEventHandler NodeTextEdited
Visual Basic

Public Event NodeTextEdited As EditNodeTextEventHandler

Event Data

NodeTextEdited event handlers receive an argument of type EditNodeTextEventArgs. The following EditNodeTextEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode whose text has been edited.
NewText | The node's new text.
OldText | The node's old text.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeTextEditing Event


MindFusion.Diagramming.Diagram.NodeTextEditing Event

Diagram.NodeTextEditing Event

A validation event that lets you approve or reject changes made to the text of a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeValidationEventHandler NodeTextEditing
Visual Basic

Public Event NodeTextEditing As NodeValidationEventHandler

Event Data

NodeTextEditing event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that the user is trying to edit.
Cancel | Set this property to true to prevent the user from editing the node's text.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
NodeTextEdited Event
LinkTextEditing


MindFusion.Diagramming.Diagram.OriginAnchorChanged Event

Diagram.OriginAnchorChanged Event

Raised when the OriginAnchor property value of a link has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event AnchorPointEventHandler OriginAnchorChanged
Visual Basic

Public Event OriginAnchorChanged As AnchorPointEventHandler

Event Data

OriginAnchorChanged event handlers receive an argument of type AnchorPointEventArgs. The following AnchorPointEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink whose OriginAnchor has changed.
OldAnchorIndex | Index of the old anchor point.
NewAnchorIndex | Index of the new anchor point.

Remarks

This event is raised every time the OriginAnchor property of a link changes, either because an user connects the link end to a different anchor point, or because an application sets it programmatically.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
DestinationAnchorChanged Event


MindFusion.Diagramming.Diagram.Repaint Event

Diagram.Repaint Event

Raised when the diagram views should be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event RepaintEventHandler Repaint
Visual Basic

Public Event Repaint As RepaintEventHandler

Event Data

Repaint event handlers receive an argument of type RepaintEventArgs. The following RepaintEventArgs members provide information relevant to the event:

Member name | Description
InvalidRect | A RectangleF specifying which part of the diagram should be repainted.

Remarks

If InvalidRect equals to RectangleF.Empty, the whole diagram should be repainted.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
Invalidate Method


MindFusion.Diagramming.Diagram.SelectionChanged Event

Diagram.SelectionChanged Event

Raised when an item is added to or removed from the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event EventHandler SelectionChanged
Visual Basic

Public Event SelectionChanged As EventHandler

Remarks

Use the Nodes and Links properties of the diagram's Selection to find out which items are currently selected.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.SelectionMoved Event

Diagram.SelectionMoved Event

Raised when the user moves multiple selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event EventHandler SelectionMoved
Visual Basic

Public Event SelectionMoved As EventHandler

Remarks

Use the Nodes and Links properties of the diagram's Selection to find out which items have been moved.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SelectionMoving Event


MindFusion.Diagramming.Diagram.SelectionMoving Event

Diagram.SelectionMoving Event

Raised while the user is moving multiple selected items, this event lets you cancel the modification.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event ValidationEventHandler SelectionMoving
Visual Basic

Public Event SelectionMoving As ValidationEventHandler

Event Data

SelectionMoving event handlers receive an argument of type ValidationEventArgs. The following ValidationEventArgs members provide information relevant to the event:

Member name | Description
Cancel | Set this property to true to prevent the user from placing the selected items at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the modification.

Remarks

This event is raised after each mouse movement while modifying a selection of items. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the modification and return the items to their original position.

Use the Selection property of the Diagram class to access the selected items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SelectionMoved Event


MindFusion.Diagramming.Diagram.SerializeTag Event

Diagram.SerializeTag Event

Raised when the Tag of a diagram item must be serialized into an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event SerializeTagEventHandler SerializeTag
Visual Basic

Public Event SerializeTag As SerializeTagEventHandler

Event Data

SerializeTag event handlers receive an argument of type SerializeTagEventArgs. The following SerializeTagEventArgs members provide information relevant to the event:

Member name | Description
Object | The object whose Tag is being serialized. This object can be either a diagram item, group, cell or anchor point.
Tag | The Tag object being serialized.
Representation | An XmlElement instance where the XML representation of the Tag should be saved.
Context | An XmlPersistContext object providing information about the document being serialized, along with methods that help you serialize data to XML.
Handled | Set this flag to true if you perform custom tag serialization.

Remarks

Only tags of simple value types can be saved and loaded automatically to/from the XML document. You must provide your own serialization for complex types by implementing this event and DeserializeTag.

Example

C#

private void Write(string fileName)
{
diagram.SerializeTag += new SerializeTagEventHandler(SerializeTag);
diagram.SaveToXml(fileName);
}

void SerializeTag(object sender, SerializeTagEventArgs e)
{
e.Handled = true;
object tag = e.Tag;
string stringRepresentation = "";

if (tag != null)
{
stringRepresentation = tag.GetType().ToString();
stringRepresentation += ";";
stringRepresentation += tag.ToString();
}

XmlNode repNode =
e.Context.XmlDocument.CreateTextNode(stringRepresentation);
e.Representation.AppendChild(repNode);
}
Visual Basic

Private Sub Write(ByVal fileName As String)

AddHandler diagram.SerializeTag, New SerializeTagEventHandler(AddressOf SerializeTag)
diagram.SaveToXml(fileName)

End Sub

Sub SerializeTag(ByVal sender As Object, ByVal e As SerializeTagEventArgs)

e.Handled = True

Dim tag As Object = e.Tag
Dim stringRepresentation As String = ""

If Not Tag Is Nothing Then

stringRepresentation = Tag.GetType().ToString()
stringRepresentation += ";"
stringRepresentation += Tag.ToString()

End If

Dim repNode As XmlNode = _
e.Context.XmlDocument.CreateTextNode(stringRepresentation)
e.Representation.AppendChild(repNode)

End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
SaveToXml Method


MindFusion.Diagramming.Diagram.TableSectionCollapsed Event

Diagram.TableSectionCollapsed Event

Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event RowEventHandler TableSectionCollapsed
Visual Basic

Public Event TableSectionCollapsed As RowEventHandler

Event Data

TableSectionCollapsed event handlers receive an argument of type RowEventArgs. The following RowEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the collapsed rows.
RowIndex | Index of the header row of the collapsed section.

Remarks

A header row is a row whose Header property is enabled. Such rows display a [±] button which can be used to expand or collapse all rows below a header up to the next header. TableSectionCollapsed is raised when a user clicks the [-] button, but not when Expanded is set to false programmatically.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TableSectionExpanded Event


MindFusion.Diagramming.Diagram.TableSectionExpanded Event

Diagram.TableSectionExpanded Event

Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event RowEventHandler TableSectionExpanded
Visual Basic

Public Event TableSectionExpanded As RowEventHandler

Event Data

TableSectionExpanded event handlers receive an argument of type RowEventArgs. The following RowEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the expanded rows.
RowIndex | Index of the header row of the expanded section.

Remarks

A header row is a row whose Header property is enabled. Such rows display a [±] button which can be used to expand or collapse all rows below a header up to the next header. TableSectionExpanded is raised when a user clicks the [+] button, but not when Expanded is set to true programmatically.

Example

The code below changes the color of the first cell of a header row when the table section defined via that row is expanded:

C#

void diagram_TableSectionExpanded(object sender, RowEventArgs e)
{
e.Table[0, e.RowIndex].Brush = new MindFusion.Drawing.SolidBrush(Color.Blue);
}
Visual Basic

Private Sub Diagram_TableSectionExpanded(ByVal sender As Object, ByVal e As MindFusion.Diagramming.RowEventArgs)Handles Diagram.TableSectionExpanded
e.Table(0, e.RowIndex).Brush = New MindFusion.Drawing.SolidBrush(Color.Blue)
End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TableSectionCollapsed Event


MindFusion.Diagramming.Diagram.TreeCollapsed Event

Diagram.TreeCollapsed Event

Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler TreeCollapsed
Visual Basic

Public Event TreeCollapsed As NodeEventHandler

Event Data

TreeCollapsed event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The root DiagramNode of the collapsed tree branch.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TreeExpanded Event
ActionRedone Event


MindFusion.Diagramming.Diagram.TreeExpanded Event

Diagram.TreeExpanded Event

Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event NodeEventHandler TreeExpanded
Visual Basic

Public Event TreeExpanded As NodeEventHandler

Event Data

TreeExpanded event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The root DiagramNode of the expanded tree branch.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace
TreeCollapsed Event


MindFusion.Diagramming.Diagram.ValidateAnchorPoint Event

Diagram.ValidateAnchorPoint Event

A validation event that lets you approve or reject connecting a link to an anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event LinkValidationEventHandler ValidateAnchorPoint
Visual Basic

Public Event ValidateAnchorPoint As LinkValidationEventHandler

Event Data

ValidateAnchorPoint event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that will be connected to the anchor point.
MousePosition | A PointF specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that is being moved.
ChangingOrigin | A value indicating whether the operation changes the origin of the link.
ChangingDestination | A value indicating whether the operation changes the destination of the link.
Node | The DiagramNode to which the link will be connected.
AnchorIndex | Index of an anchor point to which the link will be connected if this event is validated.
Cancel | Set this property to true to prevent connecting the link to specified point.

Remarks

This event is raised for each point of an AnchorPattern while a link's end point is being moved over a node. If none of the anchor points are validated, the mouse cursor icon changes to DisallowLinkCursor, indicating that the link cannot be connected to that node.

When the mouse button is released over a node, the event is raised again for the node's anchor points. From all validated anchor points, the one nearest to the dragged link end point is used to dock the link.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Diagram.ViewRemoved Event

Diagram.ViewRemoved Event

Raised when a DiagramView is detached from this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event CancelEventHandler ViewRemoved
Visual Basic

Public Event ViewRemoved As CancelEventHandler

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramEventArgs Class

DiagramEventArgs Class

Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DiagramEventArgs : EventArgs
Visual Basic

Public Class DiagramEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DiagramEventArgs

See Also

DiagramEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramEventArgs Members

DiagramEventArgs Members
Constructors Properties

Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.

The following tables list the members exposed by the DiagramEventArgs type.

Public Constructors

Name | Description
DiagramEventArgs | Overloaded.

Public Properties

Name | Description
ClipRect | Gets the current clipping rectangle.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the custom graphics.
MouseButton | Gets or sets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
VisibleRect | Specifies what part of the diagram is currently visible.

See Also

DiagramEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramEventArgs Constructor

DiagramEventArgs Constructor

Overload List

Name | Description
DiagramEventArgs (IGraphics, RectangleF, RectangleF) | Initializes a new instance of the DiagramEventArgs class.
DiagramEventArgs (MouseButton, PointF) | Initializes a new instance of the DiagramEventArgs class.

See Also

DiagramEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramEventArgs Constructor (IGraphics, RectangleF, RectangleF)

DiagramEventArgs Constructor (IGraphics, RectangleF, RectangleF)
See Also

Initializes a new instance of the DiagramEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramEventArgs (
IGraphics graphics,
RectangleF visibleRect,
RectangleF clipRect
)
Visual Basic

Public Sub DiagramEventArgs ( _
graphics As IGraphics, _
visibleRect As RectangleF, _
clipRect As RectangleF _
)

Parameters

graphics
visibleRect
clipRect
A RectangleF specifying the current clipping rectangle.

See Also

DiagramEventArgs Constructor Overload List
DiagramEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramEventArgs Constructor (MouseButton, PointF)

DiagramEventArgs Constructor (MouseButton, PointF)
See Also

Initializes a new instance of the DiagramEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramEventArgs (
MouseButton mouseButton,
PointF mousePosition
)
Visual Basic

Public Sub DiagramEventArgs ( _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

mouseButton

The mouse button related to the event.

mousePosition

The cursor location at the time the event is raised, expressed in document coordinates.

See Also

DiagramEventArgs Constructor Overload List
DiagramEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramEventArgs Properties

DiagramEventArgs Properties

Public Properties

Name | Description
ClipRect | Gets the current clipping rectangle.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the custom graphics.
MouseButton | Gets or sets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
VisibleRect | Specifies what part of the diagram is currently visible.

See Also

DiagramEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramEventArgs.ClipRect Property

DiagramEventArgs.ClipRect Property

Gets the current clipping rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF ClipRect { get; }
Visual Basic

Public ReadOnly Property ClipRect As RectangleF

Property Value

A RectangleF instance.

Remarks

This property is used as an argument to DrawBackground event handlers.

See Also

DiagramEventArgs Members
DiagramEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramEventArgs.Graphics Property

DiagramEventArgs.Graphics Property

Gets an object implementing the IGraphics interface whose methods should be used to draw the custom graphics.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public IGraphics Graphics { get; }
Visual Basic

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

Remarks

This property is used as an argument to DrawBackground event handlers.

See Also

DiagramEventArgs Members
DiagramEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramEventArgs.MouseButton Property

DiagramEventArgs.MouseButton Property

Gets or sets which mouse button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public MouseButton MouseButton { get; set; }
Visual Basic

Public Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration specifying the currently pressed mouse button.

See Also

DiagramEventArgs Members
DiagramEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramEventArgs.MousePosition Property

DiagramEventArgs.MousePosition Property

Gets or sets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF MousePosition { get; set; }
Visual Basic

Public Property MousePosition As PointF

Property Value

A PointF value specifying the current mouse position.

See Also

DiagramEventArgs Members
DiagramEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramEventArgs.VisibleRect Property

DiagramEventArgs.VisibleRect Property

Specifies what part of the diagram is currently visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF VisibleRect { get; }
Visual Basic

Public ReadOnly Property VisibleRect As RectangleF

Property Value

A RectangleF instance.

Remarks

This property is used as an argument to DrawBackground event handlers.

See Also

DiagramEventArgs Members
DiagramEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramEventHandler Delegate

DiagramEventHandler Delegate

Represents methods that will handle document-related mouse events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void DiagramEventHandler (
Object sender,
DiagramEventArgs e
)
Visual Basic

Public Delegate Sub DiagramEventHandler ( _
sender As Object, _
e As DiagramEventArgs _
)

Parameters

sender

The source of the event.

e

A DiagramEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem Class

DiagramItem Class
Remarks See Also

Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract class DiagramItem : IPersists, IDisposable
Visual Basic

Public MustInherit Class DiagramItem
Implements IPersists, IDisposable

Remarks

All items in the diagram document - links and nodes - share common base class called DiagramItem. Its main function is to provide interface for the most common methods and properties of every diagram element.

MindFusion.Diagramming invokes the Draw method when an item must be drawn on screen. You can call Draw if you need to draw an item on your own graphics surface. Override the method when implementing custom item types to provide your own rendering functionality. The standard item types draw their interior and borders using the objects assigned to the Brush and Pen properties. The font of the item's text is set by the Font property.

The order in which items are painted from bottom to top is called the z-order. Moving items up or down the z-order can be done by means of the ZBottom, ZTop, ZLevelUp and ZLevelDown methods. Accessing and setting the index of an item in the z-order can be done using the ZIndex property.

A hierarchy of items can be built, so that moving an item that is higher in the hierarchy moves all subordinated items too. The immediate subordinates of an item are represented by a Group instance. The group of items attached to another item is accessed through the SubordinateGroup property of the latter. MasterGroup gets the group in which an item is subordinate.

Every item can cast a shadow, whose offset from the item is specified by the ShadowOffsetX and ShadowOffsetY properties. The shadow is painted using the color set in ShadowColor.

An application can associate custom data with an item by means of the Tag property. The tags are only meant to hold data related to the entities represented by the chart items. They are not used or modified by MindFusion.Diagramming in any way. The tags are saved and loaded together with the diagram elements when serializing the document to a disk file or a stream.

Items can be locked for interactive modification through the Locked property. Locked items can still be modified programmatically. Items can also be marked as locked for automatic layout methods through the IgnoreLayout property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramLink
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.Selection

See Also

DiagramItem Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem Members

DiagramItem Members
Constructors Fields Properties Methods

Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.

The following tables list the members exposed by the DiagramItem type.

Protected Fields

Name | Description
bounds | Contains the coordinates of the item's bounding rectangle.
disposed | For internal use.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of this item.
Font | Gets or sets the font used to render the item's text.
HyperLink | Gets or sets the hyperlink associated with this diagram item.
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item.
Parent | Gets the diagram that contains this item.
Pen | Gets or sets the pen used to paint the frame of the item.
Printable | Gets or sets a value indicating whether to print the item.
Selected | Gets or sets a value indicating whether a diagram item is selected.
ShadowColor | Gets or sets the color used to paint the item's shadow.
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item.
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item.
SubordinateGroup | Gets a reference to the group of items that are attached to this one.
Tag | Gets or sets user-defined data associated with this item.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element.
Visible | Gets or sets a value indicating whether this item is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms.
ZIndex | Gets or sets the z-order position of this item.

ProtectedProperties

Name | Description
MeasureUnit | Returns the diagram measure unit.

Public Methods

Name | Description
Clone | Creates a copy of this item.
ContainsPoint | Determines whether this item contains the specified point.
Dispose | Overloaded.
Draw | Draws the item on the specified IGraphics surface.
DrawHandles | Renders the selection handles.
DrawShadow | Draws the shadow of this item on the specified IGraphics surface.
GetBounds | Gets the bounding rectangle of this item.
GetOutlinePoly |
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point.
HitTestHandle | Determines whether a selection handle of this item is located at the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item.
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user.
RestoreItemProperties | For internal use.
SaveItemProperties | For internal use.
ZBottom | Moves the item to the bottom of the z-order.
ZLevelDown | Moves the item one level down in the z-order.
ZLevelUp | Moves the item one level up in the z-order.
ZTop | Moves the item to the top of the z-order.

Protected Methods

Name | Description
AllowCreate | Invoked during interactive creation of items to test whether the operation can be completed in the current context.
AllowModify | Invoked during interactive modification of items to test whether the operation can be completed in the current context.
CompleteCreate | Invoked when the item creation has been completed.
CompleteModify | Invoked when the item modification has been completed.
CreateProperties | Creates an item property set corresponding to the type of this diagram item.
CreateState | Creates an item state corresponding to the type of this diagram item.
DrawManipulators | Draws the associated manipulators on the specified graphics.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.
LoadFrom | Deserializes the item from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.
OnChildModified | Called when a group child node has been modified.
OnClick | Invoked when the user clicks this item.
OnDoubleClick | Invoked when the user double-clicks this item.
OnLoad | Called after successful deserialization.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.
OnZoomChanged | Called when the diagram's ZoomFactor changes.
Repaint | Overloaded.
RestoreProperties | Restores the properties of this diagram item.
RestoreState | Restores the state of this diagram item.
SaveProperties | Saves the properties of this diagram item.
SaveState | Saves the state of this diagram item.
SaveTo | Serializes the item to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetDiagramDirty | Marks the diagram as changed.
SetExpanded | Sets whether the item is in expanded or collapsed state.
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them.
ShouldRender | Determines whether the item should be rendered in the current context.
StartCreate | Invoked once when the user starts creating a new item interactively.
StartModify | Invoked when the user starts modifying this item interactively.
UpdateCreate | Invoked during interactive creation of this item.
UpdateModify | Invoked during interactive modification of this item.

See Also

DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem Fields

DiagramItem Fields

Protected Fields

Name | Description
bounds | Contains the coordinates of the item's bounding rectangle.
disposed | For internal use.

See Also

DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.bounds Field

DiagramItem.bounds Field

Contains the coordinates of the item's bounding rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected RectangleF bounds
Visual Basic

Protected bounds As RectangleF

Remarks

Setting the Bounds property might have many side effects, including recording undo/redo information, repainting the diagram, updating related items, and so on. When implementing a derived class, you can assign directly to this field if you wish to avoid the side effects of the property setter.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.disposed Field

DiagramItem.disposed Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected bool disposed
Visual Basic

Protected disposed As Boolean

Remarks

This field is used in the implementation of the IDisposable pattern.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem Constructor

DiagramItem Constructor

Initializes a new instance of the DiagramItem class.

Overload List

Name | Description
DiagramItem () | Initializes a new instance of the DiagramItem class.
DiagramItem (Diagram) | Initializes a new instance of the DiagramItem class with default values supplied form the specified Diagram.
DiagramItem (DiagramItem) | Initializes a new instance of the DiagramItem class using the specified diagram item as a prototype.

See Also

DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem Constructor ()

DiagramItem Constructor ()
See Also

Initializes a new instance of the DiagramItem class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected DiagramItem ()
Visual Basic

Protected Sub New ()

Remarks

This constructor sets the DiagramItem properties to their default values.

See Also

DiagramItem Constructor Overload List
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem Constructor (Diagram)

DiagramItem Constructor (Diagram)
See Also

Initializes a new instance of the DiagramItem class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected DiagramItem (
Diagram parent
)
Visual Basic

Protected Sub DiagramItem ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the item properties.

Remarks

This constructor initializes the DiagramItem properties with the values specified in the respective default-value properties of the Diagram object. For more information see Initial Values of Item Properties.

See Also

DiagramItem Constructor Overload List
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem Constructor (DiagramItem)

DiagramItem Constructor (DiagramItem)
See Also

Initializes a new instance of the DiagramItem class using the specified diagram item as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected DiagramItem (
DiagramItem prototype
)
Visual Basic

Protected Sub DiagramItem ( _
prototype As DiagramItem _
)

Parameters

prototype
The item to use as a prototype. The properties of the new item are initialized from the property values of this item.

Remarks

This constructor copies the DiagramItem property values from the specified prototype item.

See Also

DiagramItem Constructor Overload List
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem Methods

DiagramItem Methods

Public Methods

Name | Description
Clone | Creates a copy of this item.
ContainsPoint | Determines whether this item contains the specified point.
Dispose | Overloaded.
Draw | Draws the item on the specified IGraphics surface.
DrawHandles | Renders the selection handles.
DrawShadow | Draws the shadow of this item on the specified IGraphics surface.
GetBounds | Gets the bounding rectangle of this item.
GetOutlinePoly |
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point.
HitTestHandle | Determines whether a selection handle of this item is located at the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item.
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user.
RestoreItemProperties | For internal use.
SaveItemProperties | For internal use.
ZBottom | Moves the item to the bottom of the z-order.
ZLevelDown | Moves the item one level down in the z-order.
ZLevelUp | Moves the item one level up in the z-order.
ZTop | Moves the item to the top of the z-order.

Protected Methods

Name | Description
AllowCreate | Invoked during interactive creation of items to test whether the operation can be completed in the current context.
AllowModify | Invoked during interactive modification of items to test whether the operation can be completed in the current context.
CompleteCreate | Invoked when the item creation has been completed.
CompleteModify | Invoked when the item modification has been completed.
CreateProperties | Creates an item property set corresponding to the type of this diagram item.
CreateState | Creates an item state corresponding to the type of this diagram item.
DrawManipulators | Draws the associated manipulators on the specified graphics.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.
LoadFrom | Deserializes the item from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | For internal use.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.
OnChildModified | Called when a group child node has been modified.
OnClick | Invoked when the user clicks this item.
OnDoubleClick | Invoked when the user double-clicks this item.
OnLoad | Called after successful deserialization.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.
OnZoomChanged | Called when the diagram's ZoomFactor changes.
Repaint | Overloaded.
RestoreProperties | Restores the properties of this diagram item.
RestoreState | Restores the state of this diagram item.
SaveProperties | Saves the properties of this diagram item.
SaveState | Saves the state of this diagram item.
SaveTo | Serializes the item to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetDiagramDirty | Marks the diagram as changed.
SetExpanded | Sets whether the item is in expanded or collapsed state.
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them.
ShouldRender | Determines whether the item should be rendered in the current context.
StartCreate | Invoked once when the user starts creating a new item interactively.
StartModify | Invoked when the user starts modifying this item interactively.
UpdateCreate | Invoked during interactive creation of this item.
UpdateModify | Invoked during interactive modification of this item.

See Also

DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.AllowCreate Method

DiagramItem.AllowCreate Method

Invoked during interactive creation of items to test whether the operation can be completed in the current context.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected abstract bool AllowCreate (
PointF current,
InteractionState ist
)
Visual Basic

Protected MustOverride Function AllowCreate ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
The current mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the creation of this item; otherwise, false.

Remarks

This method is invoked after each mouse movement in order to update the mouse pointer icon, so do not perform any time-consuming operations in its implementation.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.AllowModify Method

DiagramItem.AllowModify Method

Invoked during interactive modification of items to test whether the operation can be completed in the current context.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected abstract bool AllowModify (
PointF current,
InteractionState ist
)
Visual Basic

Protected MustOverride Function AllowModify ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
The current mouse pointer position.
ist

An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the modification of this item; otherwise, false.

Remarks

This method is invoked after each mouse movement in order to update the mouse pointer icon, so do not perform any time-consuming operations in its implementation.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Clone Method

DiagramItem.Clone Method

Creates a copy of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual DiagramItem Clone (
bool clipboard
)
Visual Basic

Public Overridable Function Clone ( _
clipboard As Boolean _
) As DiagramItem

Parameters

clipboard
true if the copy will be stored in the Windows clipboard; otherwise, false.

Return Value

The copy of this item.

Remarks

The default implementation of this item invokes the item's class copy constructor through reflection. If your custom type does not provide a copy constructor, you must implement this method to provide for clipboard operations support.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.CompleteCreate Method

DiagramItem.CompleteCreate Method

Invoked when the item creation has been completed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void CompleteCreate (
PointF end
)
Visual Basic

Protected Overridable Sub CompleteCreate ( _
end As PointF _
)

Parameters

end
The mouse pointer position.

Remarks

This method is invoked when the user releases the mouse button while drawing a new item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.CompleteModify Method

DiagramItem.CompleteModify Method

Invoked when the item modification has been completed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void CompleteModify (
PointF end,
InteractionState ist
)
Visual Basic

Protected Overridable Sub CompleteModify ( _
end As PointF, _
ist As InteractionState _
)

Parameters

end
The mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

Remarks

This method is invoked when the user releases the mouse button while modifying an item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.ContainsPoint Method

DiagramItem.ContainsPoint Method

Determines whether this item contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract bool ContainsPoint (
PointF point
)
Visual Basic

Public MustOverride Function ContainsPoint ( _
point As PointF _
) As Boolean

Parameters

point
The point to check.

Return Value

true it this item contains the specified point; otherwise, false.

Remarks

This method is used during hit-testing to see if the mouse is inside the item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.CreateProperties Method

DiagramItem.CreateProperties Method

Creates an item property set corresponding to the type of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual DiagramItemProperties CreateProperties ()
Visual Basic

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties -derived object containing a snapshot of the item's properties.

Remarks

This method is invoked by the undo/redo subsystem when creating a ChangeItemCmd instance.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.CreateState Method

DiagramItem.CreateState Method

Creates an item state corresponding to the type of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual DiagramItemState CreateState ()
Visual Basic

Protected Overridable Function CreateState () As DiagramItemState

Return Value

An instance of a class derived from DiagramItemState.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
SaveState Method
RestoreState Method


MindFusion.Diagramming.DiagramItem.Dispose Method

DiagramItem.Dispose Method

Overload List

Name | Description
DiagramItem.Dispose () | Disposes the resources managed by this item.
DiagramItem.Dispose (Boolean) | Disposes any disposable resources managed by this item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Dispose Method ()

DiagramItem.Dispose Method ()
See Also

Disposes the resources managed by this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void Dispose ()
Visual Basic

Public Overridable Sub Dispose ()

Remarks

This method is used in the implementation of the IDisposable pattern.

See Also

Dispose Method Overload List
DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Dispose Method (Boolean)

DiagramItem.Dispose Method (Boolean)
See Also

Disposes any disposable resources managed by this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
Specifies whether the method is called explicitly or from the garbage collector.

Remarks

This method is used in the implementation of the IDisposable pattern.

See Also

Dispose Method Overload List
DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Draw Method

DiagramItem.Draw Method

Draws the item on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract void Draw (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public MustOverride Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
The IGraphics surface to draw the item on.
options
A RenderOptions object specifying options for the drawing operation.

Remarks

MindFusion.Diagramming calls this method to draw a representation of the diagram item onto the specified graphics surface. Implement this method in custom node or link types if you need to provide your own drawing functionality. The method is called when rendering the diagram on screen, or exporting it to PDF or SVG files. The IGraphics methods call the respective GDI+ Graphics methods when drawing on screen, or generate PDF of SVG tags when using PdfExporter and SvgExporter to export diagram files.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.DrawHandles Method

DiagramItem.DrawHandles Method

Renders the selection handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract void DrawHandles (
IGraphics graphics,
Color color
)
Visual Basic

Public MustOverride Sub DrawHandles ( _
graphics As IGraphics, _
color As Color _
)

Parameters

graphics
The IGraphics surface to draw the handles on.
color
The color that should be used to render the handles.

Remarks

This method is invoked when the item's adjustment handles must be rendered.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.DrawManipulators Method

DiagramItem.DrawManipulators Method

Draws the associated manipulators on the specified graphics.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void DrawManipulators (
IGraphics graphics,
bool clip
)
Visual Basic

Protected Sub DrawManipulators ( _
graphics As IGraphics, _
clip As Boolean _
)

Parameters

graphics
The IGraphics surface to draw the manipulators on.
clip
true to render only inside the item's bounds; otherwise, false.

Remarks

This method is invoked to render the item's manipulators, for example, collapse/expand buttons, scrollbars, and so on.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.DrawShadow Method

DiagramItem.DrawShadow Method

Draws the shadow of this item on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract void DrawShadow (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public MustOverride Sub DrawShadow ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
The IGraphics surface to draw the shadow on.
options
A RenderOptions object specifying options for the drawing operation.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.FreeResources Method

DiagramItem.FreeResources Method

Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void FreeResources ()
Visual Basic

Protected Overridable Sub FreeResources ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.GetBounds Method

DiagramItem.GetBounds Method

Gets the bounding rectangle of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual RectangleF GetBounds ()
Visual Basic

Public Overridable Function GetBounds () As RectangleF

Return Value

The rectangle that bounds this item.

Remarks

The Bounds property getter returns the result of this method. MindFusion.Diagramming treats the returned value as the logical coordinates of the item and uses it in many situations when comparing items geometrically, when looking for items intersections, and so on.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.GetOutlinePoly Method (Boolean)

DiagramItem.GetOutlinePoly Method (Boolean)
See Also

Gets a polygon approximating the outline of this object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual PointCollection GetOutlinePoly (
bool rendering
)
Visual Basic

Public Overridable Function GetOutlinePoly ( _
rendering As Boolean _
) As PointCollection

Parameters

rendering
Specifies whether the outline will be used for rendering (true) or hit-testing (false).

Return Value

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.GetRepaintRect Method

DiagramItem.GetRepaintRect Method

Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual RectangleF GetRepaintRect (
bool includeConnected
)
Visual Basic

Public Overridable Function GetRepaintRect ( _
includeConnected As Boolean _
) As RectangleF

Parameters

includeConnected
true if related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this item is modified.

Remarks

This method is invoked when an item is modified by the user, or when an appearance property of the item changes. The returned region is invalidated and redrawn at the next paint operation.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.GetRotatedBounds Method

DiagramItem.GetRotatedBounds Method

Gets the bounding rectangle of this item when it is rotated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual RectangleF GetRotatedBounds ()
Visual Basic

Public Overridable Function GetRotatedBounds () As RectangleF

Return Value

A rectangle that bounds the rotated shape of the item.

Remarks

This method is invoked during hit-testing to do a quick test whether a point is within the item's bounds, before calling the possibly more time-consuming ContainsPoint method.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.GetToolTip Method

DiagramItem.GetToolTip Method

Gets the tooltip that should be displayed for this item at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual string GetToolTip (
PointF point
)
Visual Basic

Public Overridable Function GetToolTip ( _
point As PointF _
) As String

Parameters

point
The mouse pointer position.

Return Value

A string specifying the tooltip text.

Remarks

You can override this method to return different tooltips for different regions of the item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.HitTestHandle Method

DiagramItem.HitTestHandle Method

Determines whether a selection handle of this item is located at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract bool HitTestHandle (
PointF pt,
ref int handle
)
Visual Basic

Public MustOverride Function HitTestHandle ( _
pt As PointF, _
ByRef handle As Integer _
) As Boolean

Parameters

pt
A PointF value specifying where to look for a selection handle.
handle
A reference to an integer variable, which receives the index of the found selection handle.

Return Value

true if there is a selection handle at the specified location; otherwise, false.

Remarks

You might use this method when implementing custom hit-testing by handling the HitTestAdjustmentHandles event for nodes whose HandlesStyle is set to Custom.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.LoadFrom Method

DiagramItem.LoadFrom Method

Deserializes the item from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)
Visual Basic

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the item's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being deserialized from a diagram file saved in a binary format.

Example

The following example shows how to implement this method in a derived class.

C#

protected override void LoadFrom(System.IO.BinaryReader reader, PersistContext ctx)
{
base.LoadFrom(reader, ctx);

label = reader.ReadString();
icon = ctx.LoadImage();
}
Visual Basic

Protected Overrides Sub LoadFrom(ByVal reader As System.IO.BinaryReader, ByVal ctx As PersistContext)

MyBase.LoadFrom(reader, ctx)

title = reader.ReadString()
imgIcon = ctx.LoadImage()

End Sub

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.LoadFromXml Method

DiagramItem.LoadFromXml Method

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being deserialized from a diagram file saved in XML format.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.LoadObsolete Method

DiagramItem.LoadObsolete Method

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadObsolete (
XmlReader reader,
SortedList brushes,
Object extra
)
Visual Basic

Protected Overridable Sub LoadObsolete ( _
reader As XmlReader, _
brushes As SortedList, _
extra As Object _
)

Parameters

reader
brushes
extra

Remarks

Invoked for control hosts when they are loaded from a pre-5.0 Xml file.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.NotInteractive Method

DiagramItem.NotInteractive Method

Gets whether the user is prevented from manipulating this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool NotInteractive ()
Visual Basic

Public Overridable Function NotInteractive () As Boolean

Return Value

true to prevent user interaction with this item; otherwise, false.

Remarks

The default implementation prevents manipulation of invisible or locked items.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.NowModifying Method

DiagramItem.NowModifying Method

Gets a flag indicating whether this object is being currently modified interactively by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool NowModifying ()
Visual Basic

Public Function NowModifying () As Boolean

Return Value

true is the item is being modified; otherwise, false.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.OnAdd Method

DiagramItem.OnAdd Method

Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnAdd ()
Visual Basic

Protected Overridable Sub OnAdd ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.OnChildModified Method

DiagramItem.OnChildModified Method

Called when a group child node has been modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnChildModified (
DiagramNode node,
AdjustmentHandles handle
)
Visual Basic

Protected Overridable Sub OnChildModified ( _
node As DiagramNode, _
handle As AdjustmentHandles _
)

Parameters

node
The node that has been modified.
handle
The adjustment handle used to modify the node.

Remarks

Override this method if you need to know when a node from the SubordinateGroup is modified.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.OnClick Method

DiagramItem.OnClick Method

Invoked when the user clicks this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnClick (
MouseButton mouseButton,
PointF mousePosition
)
Visual Basic

Protected Overridable Sub OnClick ( _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

mouseButton
Specifies the mouse button used to click the item.
mousePosition
Specifies the mouse position.

Remarks

Implement this method in a custom item class if you need to detect clicks without handling events of the Diagram class.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.OnDoubleClick Method

DiagramItem.OnDoubleClick Method

Invoked when the user double-clicks this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnDoubleClick (
MouseButton mouseButton,
PointF mousePosition
)
Visual Basic

Protected Overridable Sub OnDoubleClick ( _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

mouseButton
Specifies the mouse button used to click the item.
mousePosition
Specifies the mouse position.

Remarks

Implement this method in a custom item class if you need to detect double-clicks without handling events of the Diagram class.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.OnLoad Method

DiagramItem.OnLoad Method

Called after successful deserialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnLoad ()
Visual Basic

Protected Overridable Sub OnLoad ()

Remarks

Override this method if you need to update the state of items after successfully loading a diagram.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.OnMeasureUnitChanged Method

DiagramItem.OnMeasureUnitChanged Method

Called when the diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnMeasureUnitChanged ()
Visual Basic

Protected Overridable Sub OnMeasureUnitChanged ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.OnRemove Method

DiagramItem.OnRemove Method

Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnRemove ()
Visual Basic

Protected Overridable Sub OnRemove ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.OnZoomChanged Method

DiagramItem.OnZoomChanged Method

Called when the diagram's ZoomFactor changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnZoomChanged ()
Visual Basic

Protected Overridable Sub OnZoomChanged ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Repaint Method

DiagramItem.Repaint Method

Overload List

Name | Description
DiagramItem.Repaint () | Repaints the region of the diagram where this item is located.
DiagramItem.Repaint (Boolean) | Repaints the specified region of the diagram.
DiagramItem.Repaint (RectangleF) | Repaints the specified region of the diagram.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Repaint Method ()

DiagramItem.Repaint Method ()
See Also

Repaints the region of the diagram where this item is located.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void Repaint ()
Visual Basic

Protected Sub Repaint ()

Remarks

Call this method to repaint the diagram after changing appearance attributes of this item.

See Also

Repaint Method Overload List
DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Repaint Method (Boolean)

DiagramItem.Repaint Method (Boolean)
See Also

Repaints the specified region of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void Repaint (
bool includeConnected
)
Visual Basic

Protected Sub Repaint ( _
includeConnected As Boolean _
)

Parameters

includeConnected
true if related items should be considered too; otherwise, false.

See Also

Repaint Method Overload List
DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Repaint Method (RectangleF)

DiagramItem.Repaint Method (RectangleF)
See Also

Repaints the specified region of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void Repaint (
RectangleF invalidRect
)
Visual Basic

Protected Sub Repaint ( _
invalidRect As RectangleF _
)

Parameters

invalidRect
The region to repaint.

Remarks

Call this method to repaint a part of the item after changing its appearance attributes.

See Also

Repaint Method Overload List
DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.RestoreItemProperties Method

DiagramItem.RestoreItemProperties Method

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void RestoreItemProperties (
DiagramItemProperties props
)
Visual Basic

Public Sub RestoreItemProperties ( _
props As DiagramItemProperties _
)

Parameters

props

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.RestoreProperties Method

DiagramItem.RestoreProperties Method

Restores the properties of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void RestoreProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

Remarks

This method is invoked by the undo/redo subsystem when undoing or redoing a ChangeItemCmd instance.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.RestoreState Method

DiagramItem.RestoreState Method

Restores the state of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected new virtual void RestoreState (
DiagramItemState state
)
Visual Basic

Protected Shadows Overridable Sub RestoreState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramItemState object.

Remarks

This method is called when an item should be restored to the state it had before user interaction.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
CreateState Method
SaveState Method


MindFusion.Diagramming.DiagramItem.SaveItemProperties Method

DiagramItem.SaveItemProperties Method

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveItemProperties (
DiagramItemProperties props
)
Visual Basic

Public Sub SaveItemProperties ( _
props As DiagramItemProperties _
)

Parameters

props

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.SaveProperties Method

DiagramItem.SaveProperties Method

Saves the properties of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object where the item's properties should be saved.

Remarks

This method is invoked by the undo/redo subsystem when saving a ChangeItemCmd instance.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.SaveState Method

DiagramItem.SaveState Method

Saves the state of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected new virtual void SaveState (
DiagramItemState state
)
Visual Basic

Protected Shadows Overridable Sub SaveState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramItemState object.

Remarks

This method is called to save undo information when the users starts modifying an item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
CreateState Method
RestoreState Method


MindFusion.Diagramming.DiagramItem.SaveTo Method

DiagramItem.SaveTo Method

Serializes the item to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)
Visual Basic

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the item's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being serialized to a binary-format diagram file.

Example

The following example shows how to implement this method in a derived class.

C#

protected override void SaveTo(System.IO.BinaryWriter writer, PersistContext ctx)
{
base.SaveTo(writer, ctx);

// Save the label using the standard .NET BinaryWriter
writer.Write(label);

// Save the image using the built-in image saving code,
// which stores the contents of shared images only once.
ctx.SaveImage(icon);
}
Visual Basic

Protected Overrides Sub SaveTo(ByVal writer As System.IO.BinaryWriter, ByVal ctx As PersistContext)

MyBase.SaveTo(writer, ctx)

' Save the label using the standard .NET BinaryWriter
writer.Write(title)

' Save the image using the built-in image saving code,
' which stores the contents of shared images only once.
ctx.SaveImage(imgIcon)

End Sub

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.SaveToXml Method

DiagramItem.SaveToXml Method

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being serialized into an XML-format diagram file.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.SetDiagramDirty Method

DiagramItem.SetDiagramDirty Method

Marks the diagram as changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void SetDiagramDirty ()
Visual Basic

Protected Sub SetDiagramDirty ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.SetExpanded Method

DiagramItem.SetExpanded Method

Sets whether the item is in expanded or collapsed state.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SetExpanded (
bool e
)
Visual Basic

Protected Overridable Sub SetExpanded ( _
e As Boolean _
)

Parameters

e
Specifies the new state of the item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.SetReference Method

DiagramItem.SetReference Method

Called during deserialization, after all objects have been instantiated, in order to update the references between them.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SetReference (
int refId,
Object obj,
PersistContext ctx
)
Visual Basic

Protected Overridable Sub SetReference ( _
refId As Integer, _
obj As Object, _
ctx As PersistContext _
)

Parameters

refId
Reference identifier.
obj
The newly loaded object.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is called for references that had been saved using the SaveReference method.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.ShouldRender Method

DiagramItem.ShouldRender Method

Determines whether the item should be rendered in the current context.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected bool ShouldRender ()
Visual Basic

Protected Function ShouldRender () As Boolean

Return Value

true to draw the item; otherwise, false.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.StartCreate Method

DiagramItem.StartCreate Method

Invoked once when the user starts creating a new item interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void StartCreate (
PointF org
)
Visual Basic

Protected Overridable Sub StartCreate ( _
org As PointF _
)

Parameters

org
Position of the mouse pointer.

Remarks

This method is invoked in response to the MouseDown event, just after an item has been instantiated.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.StartModify Method

DiagramItem.StartModify Method

Invoked when the user starts modifying this item interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void StartModify (
PointF org,
int handle,
InteractionState ist
)
Visual Basic

Protected Overridable Sub StartModify ( _
org As PointF, _
handle As Integer, _
ist As InteractionState _
)

Parameters

org
Position of the mouse pointer.
handle
Index of the adjustment handle used to modify the item.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.UpdateCreate Method

DiagramItem.UpdateCreate Method

Invoked during interactive creation of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void UpdateCreate (
PointF current
)
Visual Basic

Protected Overridable Sub UpdateCreate ( _
current As PointF _
)

Parameters

current

Position of the mouse pointer.

Remarks

This methods is invoked after each mouse movement in order to update the item's state in accordance with the new mouse position.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.UpdateModify Method

DiagramItem.UpdateModify Method

Invoked during interactive modification of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void UpdateModify (
PointF current,
InteractionState ist
)
Visual Basic

Protected Overridable Sub UpdateModify ( _
current As PointF, _
ist As InteractionState _
)

Parameters

current
Position of the mouse pointer.
ist
An InteractionState object containing more information about the current state of the operation.

Remarks

This methods is invoked after each mouse movement in order to update the item's state in accordance with the new mouse position.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.ZBottom Method

DiagramItem.ZBottom Method

Moves the item to the bottom of the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ZBottom ()
Visual Basic

Public Sub ZBottom ()

Remarks

Call the method to move the item to the bottom of the z-order.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ZTop Method
ZIndex Property


MindFusion.Diagramming.DiagramItem.ZLevelDown Method

DiagramItem.ZLevelDown Method

Moves the item one level down in the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ZLevelDown ()
Visual Basic

Public Sub ZLevelDown ()

Remarks

Call the method to change the item's position in z-order with one level down.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ZLevelUp Method
ZIndex Property


MindFusion.Diagramming.DiagramItem.ZLevelUp Method

DiagramItem.ZLevelUp Method

Moves the item one level up in the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ZLevelUp ()
Visual Basic

Public Sub ZLevelUp ()

Remarks

Call the method to change the item's position in z-order with one level up.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ZLevelDown Method
ZIndex Property


MindFusion.Diagramming.DiagramItem.ZTop Method

DiagramItem.ZTop Method

Moves the item to the top of the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ZTop ()
Visual Basic

Public Sub ZTop ()

Remarks

Call the method to move the item to the top of the z-order.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ZBottom Method
ZIndex Property


MindFusion.Diagramming.DiagramItem Properties

DiagramItem Properties

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of this item.
Font | Gets or sets the font used to render the item's text.
HyperLink | Gets or sets the hyperlink associated with this diagram item.
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.
LayoutTraits | Contains layout properties of the node, used by some layout algorithms and by DiagramView3D.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item.
Parent | Gets the diagram that contains this item.
Pen | Gets or sets the pen used to paint the frame of the item.
Printable | Gets or sets a value indicating whether to print the item.
Selected | Gets or sets a value indicating whether a diagram item is selected.
ShadowColor | Gets or sets the color used to paint the item's shadow.
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item.
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item.
SubordinateGroup | Gets a reference to the group of items that are attached to this one.
Tag | Gets or sets user-defined data associated with this item.
ToolTip | Gets or sets a short text message displayed when the mouse pointer rests over the diagram element.
Visible | Gets or sets a value indicating whether this item is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms.
ZIndex | Gets or sets the z-order position of this item.

ProtectedProperties

Name | Description
MeasureUnit | Returns the diagram measure unit.

See Also

DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Brush Property

DiagramItem.Brush Property

Gets or sets the brush used to fill the interior of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Brush Brush { get; set; }
Visual Basic

Public Property Brush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class.

Remarks

This property refers to a brush with which an item is painted. You can assign to it an instance of one of the following classes: HatchBrush, LinearGradientBrush, PathGradientBrush, SolidBrush or TextureBrush, located in the MindFusion.Drawing namespace. When applied to links, the property defines how arrowheads interior is painted.

Example

The following example demonstrates how to create a LinearGradientBrush and assign it to the first node of a diagram:

C#

diagram.Nodes[0].Brush = new MindFusion.Drawing.LinearGradientBrush(
Color.Yellow, Color.BurlyWood, 20);
Visual Basic

Diagram.Nodes(0).Brush = New MindFusion.Drawing.LinearGradientBrush( _
Color.Yellow, Color.BurlyWood, 20)

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Font Property

DiagramItem.Font Property

Gets or sets the font used to render the item's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Font Font { get; set; }
Visual Basic

Public Overridable Property Font As Font

Property Value

An instance of the System.Drawing.Font class.

Remarks

Items derived from DiagramItem use this font to draw their text. Tables for example render their captions and text in cells using this font. Initially the font is set to the value of Font.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.HyperLink Property

DiagramItem.HyperLink Property

Gets or sets the hyperlink associated with this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string HyperLink { get; set; }
Visual Basic

Public Property HyperLink As String

Property Value

A string value containing the hyperlink URL.

Remarks

This property is used by the CreateImageMap method of the HtmlBuilder class. Its value is assigned to the HREF attribute of the <AREA> tag that corresponds to the diagram item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.IgnoreLayout Property

DiagramItem.IgnoreLayout Property

Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool IgnoreLayout { get; set; }
Visual Basic

Public Property IgnoreLayout As Boolean

Property Value

true if the item must stay at its place nevertheless an automatic layout is performed; otherwise, false. The default is false.

Remarks

Enable IgnoreLayout to specify that the Arrange method of layout classes should ignore an item. If enabled, the position of an item won't be changed. This property applies to visible nodes. Invisible nodes are always ignored by automatic layout methods.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Locked Property
Visible Property


MindFusion.Diagramming.DiagramItem.LayoutTraits Property

DiagramItem.LayoutTraits Property

Contains layout properties of the node, used by some layout algorithms and by DiagramView3D.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public IDictionary LayoutTraits { get; }
Visual Basic

Public ReadOnly Property LayoutTraits As IDictionary

Property Value

A hashtable of key-value pairs that define layout-specific properties for this item.

Remarks

This property is used by some *Layout classes and the DiagramView3D class. The FlowLayout class looks for values assigned to keys from the FlowLayoutTraits enumeration. SpringLayout looks for values associated with SpringLayoutTraits members. The DiagramView3D class seeks keys values from the View3D enumeration.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Locked Property

DiagramItem.Locked Property

Gets or sets a value indicating whether users are allowed to edit the diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Locked { get; set; }
Visual Basic

Public Property Locked As Boolean

Property Value

true to prevent users from editing a diagram element; otherwise, false. The default is false.

Remarks

A locked item cannot be selected, moved or resized interactively. Additionaly, its text cannot be edited in-place.

Locked nodes still can be moved or resized programmatically through the Bounds property and the Move / Resize methods. Positions of locked links' control points can be changed programmatically too - through their ControlPoints collections.

Locked items positions can be changed also by the automatic layout algorithms. To prevent automatic layout methods from changing positions of individual items, set the IgnoreLayout property of DiagramItem to false.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Visible Property
DiagramView.Enabled Property


MindFusion.Diagramming.DiagramItem.MeasureUnit Property

DiagramItem.MeasureUnit Property

Returns the diagram measure unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected GraphicsUnit MeasureUnit { get; }
Visual Basic

Protected ReadOnly Property MeasureUnit As GraphicsUnit

Property Value

A member of the GraphicsUnit enumeration.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Parent Property

DiagramItem.Parent Property

Gets the diagram that contains this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Diagram Parent { get; }
Visual Basic

Public ReadOnly Property Parent As Diagram

Property Value

A reference to a Diagram instance.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Pen Property

DiagramItem.Pen Property

Gets or sets the pen used to paint the frame of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Pen Pen { get; set; }
Visual Basic

Public Property Pen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class.

Remarks

The property refers to a pen, with which the item frame is painted. When applied to links, the property specifies how their segments are painted.

Example

The following example demonstrates how to create a pen with a linear gradient and assign it to the first node of a diagram:

C#

MindFusion.Drawing.Brush penBrush = new MindFusion.Drawing.LinearGradientBrush(
Color.Bisque, Color.Blue, 0);
diagram.Nodes[0].Pen = new MindFusion.Drawing.Pen(penBrush);
Visual Basic

Dim penBrush As New MindFusion.Drawing.LinearGradientBrush( _
Color.Bisque, Color.Blue, 0)
diagram.Nodes(0).Pen = New MindFusion.Drawing.Pen(penBrush)

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.Printable Property

DiagramItem.Printable Property

Gets or sets a value indicating whether to print the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Printable { get; set; }
Visual Basic

Public Property Printable As Boolean

Property Value

true to print this item; otherwise, false.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Visible Property
Diagram.Print Method


MindFusion.Diagramming.DiagramItem.Selected Property

DiagramItem.Selected Property

Gets or sets a value indicating whether a diagram item is selected.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Selected { get; set; }
Visual Basic

Public Property Selected As Boolean

Property Value

true if the item is selected; otherwise, false.

Remarks

Use the property to check which items are selected by the user, or to programmatically select items if needed. Selected items adjustment handles can be painted in different color as set by the SelectedItemHandlesColor property. You can specify if users first have to select items in order to modify them with the ModificationStart property.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Selection Class
Diagram.Selection Property


MindFusion.Diagramming.DiagramItem.ShadowColor Property

DiagramItem.ShadowColor Property

Gets or sets the color used to paint the item's shadow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color ShadowColor { get; set; }
Visual Basic

Public Property ShadowColor As Color

Property Value

An instance of the .NET Color structure. Initialized with the value of ShadowColor.

Remarks

The shadow of an item has the same shape as the item itself, but with a different color and with some offset from the item position. This property specifies the color used to paint the item's shadow.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Diagram.ShadowsStyle Property


MindFusion.Diagramming.DiagramItem.ShadowOffsetX Property

DiagramItem.ShadowOffsetX Property

Gets or sets the horizontal offset of the shadow of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ShadowOffsetX { get; set; }
Visual Basic

Public Property ShadowOffsetX As Single

Property Value

A float value specifying the horizontal offset of this item's shadow. Initialized with the value of ShadowOffsetX.

Remarks

The shadow of an item has the same shape as the item itself, but with a different color and with some offset from the item position. This property specifies the horizontal offset of the shadow.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ShadowOffsetY Property
Diagram.ShadowsStyle Property


MindFusion.Diagramming.DiagramItem.ShadowOffsetY Property

DiagramItem.ShadowOffsetY Property

Gets or sets the vertical offset of the shadow of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ShadowOffsetY { get; set; }
Visual Basic

Public Property ShadowOffsetY As Single

Property Value

A float value specifying the vertical offset of this item's shadow. Initialized with the value of ShadowOffsetY.

Remarks

The shadow of an item has the same shape as the item itself, but with a different color and with some offset from the item position. This property specifies the vertical offset of the shadow.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ShadowOffsetX Property
Diagram.ShadowsStyle Property


MindFusion.Diagramming.DiagramItem.SubordinateGroup Property

DiagramItem.SubordinateGroup Property

Gets a reference to the group of items that are attached to this one.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Group SubordinateGroup { get; }
Visual Basic

Public ReadOnly Property SubordinateGroup As Group

Property Value

A reference to a Group object or null (Nothing in Visual Basic) if the item is not master of a group.

Remarks

Diagram items can be grouped hierarchically in such a manner, that if an item is moved all of its subordinated items in the hierarchy move too. The immediate subordinates of an item are contained and represented by a Group instance. SubordinateGroup provides access to the group of items that are attached to this one. If there are no attached items, the property returns null (Nothing in Visual Basic).

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
MasterGroup Property
Factory.CreateGroup Method


MindFusion.Diagramming.DiagramItem.Tag Property

DiagramItem.Tag Property

Gets or sets user-defined data associated with this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object Tag { get; set; }
Visual Basic

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

This property holds data that you define and is not used by MindFusion.Diagramming in any way. You can associate with the diagram item any value of a primitive data type, or the tag might be a complex object from the .NET class library or a class defined by you. If the tag is an instance of value type it will be serialized together with the item containing it when saving / loading the diagram. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Diagram.FindNode Method
Diagram.FindLink Method
Diagram.SerializeTag Event


MindFusion.Diagramming.DiagramItem.ToolTip Property

DiagramItem.ToolTip Property

Gets or sets a short text message displayed when the mouse pointer rests over the diagram element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ToolTip { get; set; }
Visual Basic

Public Property ToolTip As String

Property Value

The tool-tip text displayed for this item. The default value is an empty string.

Remarks

When the mouse rests for a while over an item, the item's tool-tip text is displayed. If it is an empty string, the diagram's ToolTip is displayed instead.

The tool-tip text is also used as a value of the ALT attribute of the image map AREA corresponding to the item; see HtmlBuilder for further information.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
DiagramView.ShowToolTips Property
DiagramView.ToolTipDelay Property


MindFusion.Diagramming.DiagramItem.Visible Property

DiagramItem.Visible Property

Gets or sets a value indicating whether this item is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Visible { get; set; }
Visual Basic

Public Overridable Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false.

Remarks

Invisible items are not drawn at all. You might use the property to hide or show items temporarily, or to construct complex group hierarchies in which intermediate helper items are invisible.

Invisible nodes are ignored by automatic layout methods. The position of such nodes won't change when the Arrange method of a layout class is called. Visible items can be ignored too by enabling their IgnoreLayout property.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
Printable Property
Locked Property


MindFusion.Diagramming.DiagramItem.Weight Property

DiagramItem.Weight Property

Gets or sets a weight value used in layout and path-finding algorithms.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float Weight { get; set; }
Visual Basic

Public Property Weight As Single

Property Value

A float value specifying the weight of this item. The default value is 1.

Remarks

Currently Weight is used in the implementations of:

  • The SpringLayout class: the weight of a link connecting two nodes is multiplied by the desired NodeDistance to determine the final distance between the nodes.
  • The PathFinder class: an override of the FindShortestPath method uses the Weight values of nodes and/or links to find the path with smallest total weight.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItem.ZIndex Property

DiagramItem.ZIndex Property

Gets or sets the z-order position of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int ZIndex { get; set; }
Visual Basic

Public Property ZIndex As Integer

Property Value

An integer value specifying the position of the diagram item within the z-order.

Remarks

Use the property to arrange item in z-order. Items with lower ZIndex appear behind items with higher ZIndex.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming Namespace
ZLevelDown Method
ZBottom Method
ZLevelUp Method
ZTop Method


MindFusion.Diagramming.DiagramItemCollection Class

DiagramItemCollection Class

Represents a strongly typed collection of DiagramItem objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DiagramItemCollection : ItemCollectionBase
Visual Basic

Public Class DiagramItemCollection
Inherits ItemCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.PersistableCollection
MindFusion.Diagramming.ItemCollectionBase
MindFusion.Diagramming.DiagramItemCollection

See Also

DiagramItemCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemCollection Members

DiagramItemCollection Members
Constructors Properties Methods

Represents a strongly typed collection of DiagramItem objects.

The following tables list the members exposed by the DiagramItemCollection type.

Public Constructors

Name | Description
DiagramItemCollection | Initializes a new instance of the DiagramItemCollection class.

Public Properties

Name | Description
Item | Gets or sets the item at the specified position.

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection.
Clone | Creates a shallow copy of this collection.
Contains | Checks whether the collection contains the specified diagram item.
GetAt | Gets the diagram item at the specified position.
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts the specified diagram item into the collection at the specified position.
Remove | Removes the diagram item from the collection.

See Also

DiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemCollection Constructor

DiagramItemCollection Constructor

Initializes a new instance of the DiagramItemCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItemCollection ()
Visual Basic

Public Sub New ()

See Also

DiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemCollection Methods

DiagramItemCollection Methods

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection.
Clone | Creates a shallow copy of this collection.
Contains | Checks whether the collection contains the specified diagram item.
GetAt | Gets the diagram item at the specified position.
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts the specified diagram item into the collection at the specified position.
Remove | Removes the diagram item from the collection.

See Also

DiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemCollection.Add Method

DiagramItemCollection.Add Method

Adds the specified diagram item to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Add (
DiagramItem item
)
Visual Basic

Public Sub Add ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem object to add to the collection.

See Also

DiagramItemCollection Members
DiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemCollection.Clone Method

DiagramItemCollection.Clone Method

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItemCollection Clone ()
Visual Basic

Public Function Clone () As DiagramItemCollection

Return Value

An instance of the DiagramItemCollection class.

See Also

DiagramItemCollection Members
DiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemCollection.Contains Method

DiagramItemCollection.Contains Method

Checks whether the collection contains the specified diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Contains (
DiagramItem item
)
Visual Basic

Public Function Contains ( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem object to search for in the collection.

Return Value

true if the specified item was found in the collection; otherwise, false.

See Also

DiagramItemCollection Members
DiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemCollection.GetAt Method

DiagramItemCollection.GetAt Method

Gets the diagram item at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem GetAt (
int index
)
Visual Basic

Public Function GetAt ( _
index As Integer _
) As DiagramItem

Parameters

index

The zero-based index of the item to retreive.

Return Value

An instance of the DiagramItem class that represents the item at the specified position.

See Also

DiagramItemCollection Members
DiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemCollection.IndexOf Method

DiagramItemCollection.IndexOf Method

Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int IndexOf (
DiagramItem item
)
Visual Basic

Public Function IndexOf ( _
item As DiagramItem _
) As Integer

Parameters

item
The item to locate in the collection.

Return Value

The zero-based index of the first occurrence of item within the entire collection, if found; otherwise, -1.

See Also

DiagramItemCollection Members
DiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemCollection.Insert Method

DiagramItemCollection.Insert Method

Inserts the specified diagram item into the collection at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Insert (
int index,
DiagramItem item
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
item As DiagramItem _
)

Parameters

index

The zero-based index at which to insert the item.

item

The DiagramItem object to add to the collection.

See Also

DiagramItemCollection Members
DiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemCollection.Remove Method

DiagramItemCollection.Remove Method

Removes the diagram item from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Remove (
DiagramItem item
)
Visual Basic

Public Sub Remove ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem object to remove from the collection.

See Also

DiagramItemCollection Members
DiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemCollection Properties

DiagramItemCollection Properties

Public Properties

Name | Description
Item | Gets or sets the item at the specified position.

See Also

DiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemCollection.Item Property

DiagramItemCollection.Item Property

Gets or sets the item at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As DiagramItem

Parameters

index

The zero-based index of the item to set or retrieve.

Property Value

An instance of the DiagramItem class that represents the item at the specified position.

See Also

DiagramItemCollection Members
DiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemProperties Class

DiagramItemProperties Class

The base type for classes that store diagram item properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DiagramItemProperties
Visual Basic

Public Class DiagramItemProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramLinkProperties
MindFusion.Diagramming.DiagramNodeProperties

See Also

DiagramItemProperties Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemProperties Members

DiagramItemProperties Members
Constructors Fields Methods

The base type for classes that store diagram item properties during undo / redo operations.

The following tables list the members exposed by the DiagramItemProperties type.

Public Constructors

Name | Description
DiagramItemProperties |

Public Fields

Name | Description
ItemClass | For internal use.
Selected | For internal use.
ZIndex | For internal use.

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used.

See Also

DiagramItemProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemProperties Fields

DiagramItemProperties Fields

Public Fields

Name | Description
ItemClass | For internal use.
Selected | For internal use.
ZIndex | For internal use.

See Also

DiagramItemProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemProperties.ItemClass Field

DiagramItemProperties.ItemClass Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ItemClass
Visual Basic

Public ItemClass As String

See Also

DiagramItemProperties Members
DiagramItemProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemProperties.Selected Field

DiagramItemProperties.Selected Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Selected
Visual Basic

Public Selected As Boolean

See Also

DiagramItemProperties Members
DiagramItemProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemProperties.ZIndex Field

DiagramItemProperties.ZIndex Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int ZIndex
Visual Basic

Public ZIndex As Integer

See Also

DiagramItemProperties Members
DiagramItemProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemProperties Constructor

DiagramItemProperties Constructor

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItemProperties ()
Visual Basic

Public Sub New ()

See Also

DiagramItemProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemProperties Methods

DiagramItemProperties Methods

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used.

See Also

DiagramItemProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemProperties.FreeResources Method

DiagramItemProperties.FreeResources Method

Frees stored resources which will no longer be used.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void FreeResources ()
Visual Basic

Public Overridable Sub FreeResources ()

See Also

DiagramItemProperties Members
DiagramItemProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemState Class

DiagramItemState Class

Contains a snapshot of the internal state of a diagram item. Instances of this class are used to store the state of items for later undo or redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DiagramItemState
Visual Basic

Public Class DiagramItemState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramLinkState
MindFusion.Diagramming.ShapeNodeState

See Also

DiagramItemState Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemState Members

DiagramItemState Members
Constructors

Contains a snapshot of the internal state of a diagram item. Instances of this class are used to store the state of items for later undo or redo operations.

The following tables list the members exposed by the DiagramItemState type.

Public Constructors

Name | Description
DiagramItemState | Initializes a new instance of the DiagramItemState class.

See Also

DiagramItemState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramItemState Constructor

DiagramItemState Constructor

Initializes a new instance of the DiagramItemState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItemState ()
Visual Basic

Public Sub New ()

See Also

DiagramItemState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink Class

DiagramLink Class
Remarks See Also

Represents a link between two diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DiagramLink : DiagramItem
Visual Basic

Public Class DiagramLink
Inherits DiagramItem

Remarks

Links between nodes in MindFusion.Diagramming diagrams are represented by instances of the DiagramLink class. Links connect at most two nodes, which can be accessed with the Origin and Destination properties. If connected to node anchor points, the point indices can be accessed using the OriginAnchor and DestinationAnchor properties. To control whether users are allowed to move link end points, set AllowMoveStart and AllowMoveEnd.

Links are built of smaller parts called segments, which can be straight lines, cascading orthogonal lines or Bézier curves. The type of segments is set through the Style property. The number of link's segments is specified by the SegmentCount property. Access to control point locations is provided by the ControlPoints collection.

Usually only the starting and ending segments of a link are updated if the nodes it connects are moved around. Number, orientation and/or position of link segments can change dynamically in various ways depending on the values of AutoRoute, Dynamic and RetainForm. For links of style Cascading, the CascadeOrientation property specifies the orientation of their first segments.

If SnapToNodeBorder is enabled, a link automatically aligns its end points to the border of the origin or destination nodes when a user moves the first or last control points. This has a higher priority than aligning to the grid, but a lower priority than aligning to an anchor point.

Links can display distinct arrowhead shapes at their ends. These shapes can be set with the HeadShape and BaseShape properties. The size of the base and arrowhead images is specified through the HeadShapeSize and BaseShapeSize properties. Arrowhead shapes can be displayed in the middle of each segment to facilitate users by distinguishing different links. The type and size of these shapes is set with the IntermediateShape and IntermediateShapeSize properties. The lines of arowhead shapes are painted using the HeadPen pen.

The color of link segments can be specified by the Pen property and the fill color of its base and head shapes with the Brush property. Links can have some text associated with them, displayed as specified in the Text, TextColor and TextStyle properties. The appearance of link's selection handles can be changed using HandlesStyle.

Bounds and Length are informative properties returning respectively link's location and total length.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramLink

See Also

DiagramLink Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink Members

DiagramLink Members
Constructors Properties Methods

Represents a link between two diagram nodes.

The following tables list the members exposed by the DiagramLink type.

Public Constructors

Name | Description
DiagramLink | Overloaded. Initializes a new instance of the DiagramLink class.

Public Properties

Name | Description
AllowMoveEnd | Gets or sets a value indicating whether the user is allowed to move the end point of a link.
AllowMoveStart | Gets or sets a value indicating whether the user is allowed to move the first control point of a link.
AutoRoute | Gets or sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
BaseShape | Gets or sets what shape to display at the beginning of a link.
BaseShapeSize | Gets or sets the size of the BaseShape shape.
Bounds | Gets the size of the rectangle that bounds this link.
CascadeOrientation | Gets or sets the orientation of the first segment of a cascading link.
ControlPoints | Gets a collection of the control points of this link.
CustomDraw | Gets or sets the type of custom drawing performed on this link.
Destination | Gets or sets the destination node of this link.
DestinationAnchor | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.
DestinationIndex | Gets or sets the index of link's destination anchor point or table row.
DrawCrossings | Gets or sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.
Dynamic | Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.
Font | DiagramItem.Font override.
HandlesStyle | Gets or sets the appearance of the link's selection handles.
HeadPen | Gets or sets the pen to use when painting arrowheads lines.
HeadShape | Gets or sets the shape of this link's arrowhead.
HeadShapeSize | Gets or sets the size of the arrowhead shape.
IntermediateShape | Gets or sets the shape displayed at the middle of each segment of the link.
IntermediateShapeSize | Gets or sets the size of the IntermediateShape shape.
IsConnected | Gets a value indicating whether the link is connected to nodes at both its ends.
Length | Gets the length of the link.
Origin | Gets or sets the origin node of the link.
OriginAnchor | Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.
OriginIndex | Gets or sets the index of link's origin anchor point or table row.
RetainForm | Gets or sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.
SegmentCount | Gets or sets the number of segments of this link.
SnapToNodeBorder | Gets or sets a value indicating whether the link end points should automatically align to node borders while a user moves them.
Style | Gets or sets the type of link segments and how they are positioned one relatively to another.
Text | Gets or sets the text displayed over a link.
TextColor | Gets or sets the color of the link's text.
TextStyle | Gets or sets the link's text placement and orientation.
Visible | DiagramItem.Visible override.

Public Methods

Name | Description
Clone | Creates a copy of this link.
ContainsPoint | DiagramItem.ContainsPoint override.
Draw | Draws the link on the specified IGraphics surface.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | Draws the shadow of this link on the specified IGraphics surface.
GetBaseShapeDefinition | For use by the exporter components.
GetBounds | DiagramItem.GetBounds override.
GetHeadShapeDefinition | For use by the exporter components.
GetLongestHSegment | Returns the index of the longest horizontal segment of this link.
GetOutlinePoly |
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | DiagramItem.GetRotatedBounds override.
HitTestHandle | DiagramItem.HitTestHandle override.
Intersects | Overloaded.
ReassignAnchorPoints | Attaches the link end points to the anchor points defined for the link's origin and destination nodes.
Route | Routes this link, regardless of whether the link's AutoRoute flag is enabled.
UpdateFromPoints | Overloaded. Updates the link's internal state after the link's control points have been changed.
UpdateIntersections | Aligns the link ends to the contour of the nodes it connects.

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the link content from an XML element.
OnLoad | DiagramItem.OnLoad override.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves any control point of the link.
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the link content into an XML element.
SetReference | Updates the reference to the specified object.
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateModify | DiagramItem.UpdateModify override.

See Also

DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink Constructor

DiagramLink Constructor

Initializes a new instance of the DiagramLink class.

Overload List

Name | Description
DiagramLink (Diagram) | Initializes a new instance of the DiagramLink class with default values supplied form the specified Diagram.
DiagramLink (Diagram, DiagramNode, DiagramNode) | Initializes a new instance of the DiagramLink class between the specified node with default values supplied form the specified Diagram.
DiagramLink (Diagram, DiagramNode, PointF) | Initializes a new instance of the DiagramLink class between the specified node and the specified point with default values supplied form the specified Diagram.
DiagramLink (Diagram, PointF, DiagramNode) | Initializes a new instance of the DiagramLink class between the specified point and the specified node with default values supplied form the specified Diagram.
DiagramLink (Diagram, PointF, PointF) | Initializes a new instance of the DiagramLink class between the specified points with default values supplied form the specified Diagram.
DiagramLink (DiagramLink, DiagramNode, DiagramNode) | Initializes a new instance of the DiagramLink class between the specified nodes using the specified diagram link as a prototype.

See Also

DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink Constructor (Diagram)

DiagramLink Constructor (Diagram)
See Also

Initializes a new instance of the DiagramLink class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink (
Diagram parent
)
Visual Basic

Public Sub DiagramLink ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

See Also

DiagramLink Constructor Overload List
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink Constructor (Diagram, DiagramNode, DiagramNode)

DiagramLink Constructor (Diagram, DiagramNode, DiagramNode)
See Also

Initializes a new instance of the DiagramLink class between the specified node with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink (
Diagram parent,
DiagramNode origin,
DiagramNode destination
)
Visual Basic

Public Sub DiagramLink ( _
parent As Diagram, _
origin As DiagramNode, _
destination As DiagramNode _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

origin

The origin node of the new link.

destination

The destination node of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink Constructor (Diagram, DiagramNode, PointF)

DiagramLink Constructor (Diagram, DiagramNode, PointF)
See Also

Initializes a new instance of the DiagramLink class between the specified node and the specified point with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink (
Diagram parent,
DiagramNode origin,
PointF destination
)
Visual Basic

Public Sub DiagramLink ( _
parent As Diagram, _
origin As DiagramNode, _
destination As PointF _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

origin

The origin node of the new link.

destination

The destination point of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink Constructor (Diagram, PointF, DiagramNode)

DiagramLink Constructor (Diagram, PointF, DiagramNode)
See Also

Initializes a new instance of the DiagramLink class between the specified point and the specified node with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink (
Diagram parent,
PointF src,
DiagramNode dest
)
Visual Basic

Public Sub DiagramLink ( _
parent As Diagram, _
src As PointF, _
dest As DiagramNode _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

src

The origin point of the new link.

dest

The destination node of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink Constructor (Diagram, PointF, PointF)

DiagramLink Constructor (Diagram, PointF, PointF)
See Also

Initializes a new instance of the DiagramLink class between the specified points with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink (
Diagram parent,
PointF src,
PointF dest
)
Visual Basic

Public Sub DiagramLink ( _
parent As Diagram, _
src As PointF, _
dest As PointF _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

src

The origin point of the new link.

dest

The destination point of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink Constructor (DiagramLink, DiagramNode, DiagramNode)

DiagramLink Constructor (DiagramLink, DiagramNode, DiagramNode)
See Also

Initializes a new instance of the DiagramLink class between the specified nodes using the specified diagram link as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink (
DiagramLink prototype,
DiagramNode src,
DiagramNode dest
)
Visual Basic

Public Sub DiagramLink ( _
prototype As DiagramLink, _
src As DiagramNode, _
dest As DiagramNode _
)

Parameters

prototype

The link to use as a prototype. The properties of the new link are initialized from the property values of this link.

src

The origin node of the new link.

dest

The destination node of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink Methods

DiagramLink Methods

Public Methods

Name | Description
Clone | Creates a copy of this link.
ContainsPoint | DiagramItem.ContainsPoint override.
Draw | Draws the link on the specified IGraphics surface.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | Draws the shadow of this link on the specified IGraphics surface.
GetBaseShapeDefinition | For use by the exporter components.
GetBounds | DiagramItem.GetBounds override.
GetHeadShapeDefinition | For use by the exporter components.
GetLongestHSegment | Returns the index of the longest horizontal segment of this link.
GetOutlinePoly |
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | DiagramItem.GetRotatedBounds override.
HitTestHandle | DiagramItem.HitTestHandle override.
Intersects | Overloaded.
ReassignAnchorPoints | Attaches the link end points to the anchor points defined for the link's origin and destination nodes.
Route | Routes this link, regardless of whether the link's AutoRoute flag is enabled.
UpdateFromPoints | Overloaded. Updates the link's internal state after the link's control points have been changed.
UpdateIntersections | Aligns the link ends to the contour of the nodes it connects.

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the link content from an XML element.
OnLoad | DiagramItem.OnLoad override.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves any control point of the link.
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the link content into an XML element.
SetReference | Updates the reference to the specified object.
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateModify | DiagramItem.UpdateModify override.

See Also

DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.AllowCreate Method

DiagramLink.AllowCreate Method

DiagramItem.AllowCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual bool AllowCreate (
PointF current,
InteractionState ist
)
Visual Basic

Protected Overridable Function AllowCreate ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
The current mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the creation of this link; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.AllowModify Method

DiagramLink.AllowModify Method

DiagramItem.AllowModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual bool AllowModify (
PointF current,
InteractionState ist
)
Visual Basic

Protected Overridable Function AllowModify ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
The current mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the modification of this link; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.Clone Method

DiagramLink.Clone Method

Creates a copy of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override DiagramItem Clone (
bool clipboard
)
Visual Basic

Public Overrides Function Clone ( _
clipboard As Boolean _
) As DiagramItem

Parameters

clipboard
true if the copy will be stored in the Windows clipboard; otherwise, false.

Return Value

An instance of the DiagramItem class.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.CompleteCreate Method

DiagramLink.CompleteCreate Method

DiagramItem.CompleteCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void CompleteCreate (
PointF end
)
Visual Basic

Protected Overridable Sub CompleteCreate ( _
end As PointF _
)

Parameters

end
The mouse pointer position.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.CompleteModify Method

DiagramLink.CompleteModify Method

DiagramItem.CompleteModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void CompleteModify (
PointF end,
InteractionState ist
)
Visual Basic

Protected Overridable Sub CompleteModify ( _
end As PointF, _
ist As InteractionState _
)

Parameters

end
The mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.ContainsPoint Method

DiagramLink.ContainsPoint Method

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool ContainsPoint (
PointF point
)
Visual Basic

Public Overrides Function ContainsPoint ( _
point As PointF _
) As Boolean

Parameters

point
The point to check.

Return Value

true it this link contains the specified point; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.CreateProperties Method

DiagramLink.CreateProperties Method

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual DiagramItemProperties CreateProperties ()
Visual Basic

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.CreateState Method

DiagramLink.CreateState Method

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual DiagramItemState CreateState ()
Visual Basic

Protected Overridable Function CreateState () As DiagramItemState

Return Value

A DiagramLinkState instance.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.Draw Method

DiagramLink.Draw Method

Draws the link on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void Draw (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public Overrides Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
An IGraphics object where the link should be rendered.
options
Provides options for the drawing operation.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.DrawHandles Method

DiagramLink.DrawHandles Method

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void DrawHandles (
IGraphics graphics,
Color color
)
Visual Basic

Public Overrides Sub DrawHandles ( _
graphics As IGraphics, _
color As Color _
)

Parameters

graphics
The IGraphics surface to draw the handles on.
color
The color that should be used to render the handles.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.DrawShadow Method

DiagramLink.DrawShadow Method

Draws the shadow of this link on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public Overrides Sub DrawShadow ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
An IGraphics object where the shadow should be rendered.
options
A RenderOptions object specifying options for the drawing operation.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.GetBaseShapeDefinition Method

DiagramLink.GetBaseShapeDefinition Method

For use by the exporter components.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrowHeadShape GetBaseShapeDefinition ()
Visual Basic

Public Function GetBaseShapeDefinition () As ArrowHeadShape

Return Value

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.GetBounds Method

DiagramLink.GetBounds Method

DiagramItem.GetBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override RectangleF GetBounds ()
Visual Basic

Public Overrides Function GetBounds () As RectangleF

Return Value

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.GetHeadShapeDefinition Method

DiagramLink.GetHeadShapeDefinition Method

For use by the exporter components.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrowHeadShape GetHeadShapeDefinition ()
Visual Basic

Public Function GetHeadShapeDefinition () As ArrowHeadShape

Return Value

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.GetLongestHSegment Method

DiagramLink.GetLongestHSegment Method

Returns the index of the longest horizontal segment of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int GetLongestHSegment ()
Visual Basic

Public Function GetLongestHSegment () As Integer

Return Value

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.GetOutlinePoly Method (Boolean)

DiagramLink.GetOutlinePoly Method (Boolean)
See Also

DiagramItem.GetOutlinePoly override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override PointCollection GetOutlinePoly (
bool rendering
)
Visual Basic

Public Overrides Function GetOutlinePoly ( _
rendering As Boolean _
) As PointCollection

Parameters

rendering

Return Value

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.GetRepaintRect Method

DiagramLink.GetRepaintRect Method

DiagramItem.GetRepaintRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override RectangleF GetRepaintRect (
bool includeConnected
)
Visual Basic

Public Overrides Function GetRepaintRect ( _
includeConnected As Boolean _
) As RectangleF

Parameters

includeConnected
true if related items should be considered too; otherwise, false.

Return Value

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.GetRotatedBounds Method

DiagramLink.GetRotatedBounds Method

DiagramItem.GetRotatedBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override RectangleF GetRotatedBounds ()
Visual Basic

Public Overrides Function GetRotatedBounds () As RectangleF

Return Value

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.HitTestHandle Method

DiagramLink.HitTestHandle Method

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool HitTestHandle (
PointF pt,
ref int handle
)
Visual Basic

Public Overrides Function HitTestHandle ( _
pt As PointF, _
ByRef handle As Integer _
) As Boolean

Parameters

pt
handle

Return Value

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.Intersects Method

DiagramLink.Intersects Method

Overload List

Name | Description
DiagramLink.Intersects (DiagramLink) | Checks whether this link intersects with the specified link.
DiagramLink.Intersects (DiagramNode) | Checks whether the link contour intersects with the outline of the specified node.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.Intersects Method (DiagramLink)

DiagramLink.Intersects Method (DiagramLink)
See Also

Checks whether this link intersects with the specified link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Intersects (
DiagramLink link
)
Visual Basic

Public Function Intersects ( _
link As DiagramLink _
) As Boolean

Parameters

link

Return Value

See Also

Intersects Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.Intersects Method (DiagramNode)

DiagramLink.Intersects Method (DiagramNode)
See Also

Checks whether the link contour intersects with the outline of the specified node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Intersects (
DiagramNode node
)
Visual Basic

Public Function Intersects ( _
node As DiagramNode _
) As Boolean

Parameters

node
A DiagramNode object for which to determine whether the link intersects it.

Return Value

true if the link intersects the node; otherwise, false.

See Also

Intersects Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.LoadFrom Method

DiagramLink.LoadFrom Method

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)
Visual Basic

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the link's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.LoadFromXml Method

DiagramLink.LoadFromXml Method

Loads the link content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.OnLoad Method

DiagramLink.OnLoad Method

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnLoad ()
Visual Basic

Protected Overridable Sub OnLoad ()

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.OnMeasureUnitChanged Method

DiagramLink.OnMeasureUnitChanged Method

Called when the Diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnMeasureUnitChanged ()
Visual Basic

Protected Overridable Sub OnMeasureUnitChanged ()

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.OnModify Method

DiagramLink.OnModify Method

Invoked when the user moves any control point of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnModify (
PointF mousePosition,
int adjustmentHandle
)
Visual Basic

Protected Overridable Sub OnModify ( _
mousePosition As PointF, _
adjustmentHandle As Integer _
)

Parameters

mousePosition
Specifies the mouse position.
adjustmentHandle
Specifies the adjustment handle used to modify the link.

Remarks

Implement this method in a custom link class if you need to detect modifications done by the user without handling events of the Diagram class.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.ReassignAnchorPoints Method

DiagramLink.ReassignAnchorPoints Method

Attaches the link end points to the anchor points defined for the link's origin and destination nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ReassignAnchorPoints ()
Visual Basic

Public Sub ReassignAnchorPoints ()

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.RestoreProperties Method

DiagramLink.RestoreProperties Method

DiagramItem.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void RestoreProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.RestoreState Method

DiagramLink.RestoreState Method

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void RestoreState (
DiagramItemState state
)
Visual Basic

Protected Overridable Sub RestoreState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramLinkState instance.

Remarks

This method is called when a link should be restored to the state it had before user interaction.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.Route Method

DiagramLink.Route Method

Routes this link, regardless of whether the link's AutoRoute flag is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Route ()
Visual Basic

Public Function Route () As Boolean

Return Value

true is a route has been successfully found; otherwise, false.

Remarks

Routing may fail if there is a large background node whose Obstacle property is enabled, or if the value of RoutingOptions.GridSize is too big for the average distance between adjacent nodes in the diagram.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.SaveProperties Method

DiagramLink.SaveProperties Method

DiagramItem.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.SaveState Method

DiagramLink.SaveState Method

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveState (
DiagramItemState state
)
Visual Basic

Protected Overridable Sub SaveState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramLinkState instance.

Remarks

This method is called to save undo information when the users starts modifying a link.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.SaveTo Method

DiagramLink.SaveTo Method

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)
Visual Basic

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the link's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.SaveToXml Method

DiagramLink.SaveToXml Method

Saves the link content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the link's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.SetReference Method

DiagramLink.SetReference Method

Updates the reference to the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SetReference (
int refId,
Object obj,
PersistContext context
)
Visual Basic

Protected Overridable Sub SetReference ( _
refId As Integer, _
obj As Object, _
context As PersistContext _
)

Parameters

refId
Reference identifier.
obj
The newly loaded object.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is called for references that had been saved using the SaveReference method.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.StartCreate Method

DiagramLink.StartCreate Method

DiagramItem.StartCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void StartCreate (
PointF org
)
Visual Basic

Protected Overridable Sub StartCreate ( _
org As PointF _
)

Parameters

org
Position of the mouse pointer.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.StartModify Method

DiagramLink.StartModify Method

DiagramItem.StartModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void StartModify (
PointF org,
int handle,
InteractionState ist
)
Visual Basic

Protected Overridable Sub StartModify ( _
org As PointF, _
handle As Integer, _
ist As InteractionState _
)

Parameters

org
Position of the mouse pointer.
handle
Index of the adjustment handle used to modify the link.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.UpdateCreate Method

DiagramLink.UpdateCreate Method

DiagramItem.UpdateCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void UpdateCreate (
PointF current
)
Visual Basic

Protected Overridable Sub UpdateCreate ( _
current As PointF _
)

Parameters

current
Position of the mouse pointer.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.UpdateFromPoints Method

DiagramLink.UpdateFromPoints Method

Updates the link's internal state after the link's control points have been changed.

Overload List

Name | Description
DiagramLink.UpdateFromPoints () | Updates the link's internal state after the link's control points have been changed.
DiagramLink.UpdateFromPoints (Boolean) | Updates the link's internal state after the link's control points have been changed.
DiagramLink.UpdateFromPoints (Boolean, Boolean) | Updates the link's internal state after the link's control points have been changed.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.UpdateFromPoints Method ()

DiagramLink.UpdateFromPoints Method ()
See Also

Updates the link's internal state after the link's control points have been changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void UpdateFromPoints ()
Visual Basic

Public Sub UpdateFromPoints ()

See Also

UpdateFromPoints Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.UpdateFromPoints Method (Boolean)

DiagramLink.UpdateFromPoints Method (Boolean)
See Also

Updates the link's internal state after the link's control points have been changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void UpdateFromPoints (
bool updateGroups
)
Visual Basic

Public Sub UpdateFromPoints ( _
updateGroups As Boolean _
)

Parameters

updateGroups

true to update the positions of nodes attached to the link; otherwise, false.

See Also

UpdateFromPoints Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.UpdateFromPoints Method (Boolean, Boolean)

DiagramLink.UpdateFromPoints Method (Boolean, Boolean)
See Also

Updates the link's internal state after the link's control points have been changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void UpdateFromPoints (
bool updateGroups,
bool updateSegmentCount
)
Visual Basic

Public Sub UpdateFromPoints ( _
updateGroups As Boolean, _
updateSegmentCount As Boolean _
)

Parameters

updateGroups
true to update the positions of nodes attached to the link; otherwise, false.
updateSegmentCount
true to update the SegmentCount property based on the number of points in the collection.

See Also

UpdateFromPoints Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.UpdateIntersections Method

DiagramLink.UpdateIntersections Method

Aligns the link ends to the contour of the nodes it connects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void UpdateIntersections ()
Visual Basic

Public Sub UpdateIntersections ()

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.UpdateModify Method

DiagramLink.UpdateModify Method

DiagramItem.UpdateModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void UpdateModify (
PointF current,
InteractionState ist
)
Visual Basic

Protected Overridable Sub UpdateModify ( _
current As PointF, _
ist As InteractionState _
)

Parameters

current
Position of the mouse pointer.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink Properties

DiagramLink Properties

Public Properties

Name | Description
AllowMoveEnd | Gets or sets a value indicating whether the user is allowed to move the end point of a link.
AllowMoveStart | Gets or sets a value indicating whether the user is allowed to move the first control point of a link.
AutoRoute | Gets or sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
BaseShape | Gets or sets what shape to display at the beginning of a link.
BaseShapeSize | Gets or sets the size of the BaseShape shape.
Bounds | Gets the size of the rectangle that bounds this link.
CascadeOrientation | Gets or sets the orientation of the first segment of a cascading link.
ControlPoints | Gets a collection of the control points of this link.
CustomDraw | Gets or sets the type of custom drawing performed on this link.
Destination | Gets or sets the destination node of this link.
DestinationAnchor | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.
DestinationIndex | Gets or sets the index of link's destination anchor point or table row.
DrawCrossings | Gets or sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.
Dynamic | Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.
Font | DiagramItem.Font override.
HandlesStyle | Gets or sets the appearance of the link's selection handles.
HeadPen | Gets or sets the pen to use when painting arrowheads lines.
HeadShape | Gets or sets the shape of this link's arrowhead.
HeadShapeSize | Gets or sets the size of the arrowhead shape.
IntermediateShape | Gets or sets the shape displayed at the middle of each segment of the link.
IntermediateShapeSize | Gets or sets the size of the IntermediateShape shape.
IsConnected | Gets a value indicating whether the link is connected to nodes at both its ends.
Length | Gets the length of the link.
Origin | Gets or sets the origin node of the link.
OriginAnchor | Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.
OriginIndex | Gets or sets the index of link's origin anchor point or table row.
RetainForm | Gets or sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.
SegmentCount | Gets or sets the number of segments of this link.
SnapToNodeBorder | Gets or sets a value indicating whether the link end points should automatically align to node borders while a user moves them.
Style | Gets or sets the type of link segments and how they are positioned one relatively to another.
Text | Gets or sets the text displayed over a link.
TextColor | Gets or sets the color of the link's text.
TextStyle | Gets or sets the link's text placement and orientation.
Visible | DiagramItem.Visible override.

See Also

DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.AllowMoveEnd Property

DiagramLink.AllowMoveEnd Property

Gets or sets a value indicating whether the user is allowed to move the end point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowMoveEnd { get; set; }
Visual Basic

Public Property AllowMoveEnd As Boolean

Property Value

true to enable users to move the end point of the link; otherwise, false. Initialized with the value of LinkEndsMovable.

Remarks

Set the property to false to prevent the link destination to be changed interactively. Alternatively, you might handle the LinkModifying event to implement selective validation of attaching a link to different diagram nodes.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
AllowMoveStart Property
Diagram.LinkEndsMovable Property


MindFusion.Diagramming.DiagramLink.AllowMoveStart Property

DiagramLink.AllowMoveStart Property

Gets or sets a value indicating whether the user is allowed to move the first control point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowMoveStart { get; set; }
Visual Basic

Public Property AllowMoveStart As Boolean

Property Value

true to enable users to move the start point of the link; otherwise false. Initialized with the value of LinkEndsMovable.

Remarks

Set the property to false to prevent the link origin to be changed interactively. Alternatively, you might handle the LinkModifying event to implement selective validation of attaching a link to different diagram nodes.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
AllowMoveEnd Property
Diagram.LinkEndsMovable Property


MindFusion.Diagramming.DiagramLink.AutoRoute Property

DiagramLink.AutoRoute Property

Gets or sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AutoRoute { get; set; }
Visual Basic

Public Property AutoRoute As Boolean

Property Value

true to route this link; otherwise, false. Initialized with the value of RouteLinks.

Remarks

If AutoRoute is enabled, a link automatically finds the shortest possible path between its origin and destination that doesn't intersect Obstacle nodes. The number and orientation of the link's segments are updated when the nodes it links are moved around. The positions of end points of a routed link are not changed, unless the link is also set to Dynamic.

It is best to use AutoRoute with links of the Cascading style. Note that automatic routing overrides the RetainForm behavior.

Performance note

Links whose AutoRoute property is enabled are re-routed if they intersect with newly created nodes. Thus when constructing a large diagram programmatically, each link might be re-routed many times, once for each newly added node whose location arguments collide with link's bounding rectangle. That might slow down diagram creation a lot. To avoid it, first create all nodes, and afterwards the link; that requires a single calculation for each link's route.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
RoutingOptions Class
Dynamic Property
SegmentCount Property


MindFusion.Diagramming.DiagramLink.BaseShape Property

DiagramLink.BaseShape Property

Gets or sets what shape to display at the beginning of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrowHead BaseShape { get; set; }
Visual Basic

Public Property BaseShape As ArrowHead

Property Value

A member of the ArrowHead enumeration. Initialized with the value of LinkBaseShape.

Remarks

The property specifies the shape that is displayed at the beginning of a link, that is, the point where it is connected with its Origin node. This shape is rotated simultaneously with the first segment of the link so that it follows the overall link direction.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
HeadShape Property
IntermediateShape Property
BaseShapeSize Property


MindFusion.Diagramming.DiagramLink.BaseShapeSize Property

DiagramLink.BaseShapeSize Property

Gets or sets the size of the BaseShape shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float BaseShapeSize { get; set; }
Visual Basic

Public Property BaseShapeSize As Single

Property Value

A float value that specifies the shape size. Initialized with the value of LinkBaseShapeSize.

Remarks

The property specifies how big is the shape that is displayed at the origin of a link.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
BaseShape Property


MindFusion.Diagramming.DiagramLink.Bounds Property

DiagramLink.Bounds Property

Gets the size of the rectangle that bounds this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As RectangleF

Property Value

A .NET RectangleF that represents the bounding rectangle.

Remarks

Use the property to get the smallest rectangle that bounds all link points.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.CascadeOrientation Property

DiagramLink.CascadeOrientation Property

Gets or sets the orientation of the first segment of a cascading link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Orientation CascadeOrientation { get; set; }
Visual Basic

Public Property CascadeOrientation As Orientation

Property Value

A member of the Orientation enumeration.

Remarks

Use this property to specify the orientation of the first segment of a link whose Style is set to Cascading. See Orientation for more details. The orientation of the first segment defines the orientation of all other segments in the cascade, because each next segment changes its orientation alternately to the previous one.

If the property is set to Auto, users may change the orientation of a cascading link interactively. That can be done by dragging the control point next to the first or last one to its opposite corner in the rectangle defined by its two adjacent segments. Depending on the value of AllowSplitLinks, the link orientation is changed by either inserting a new segment and changing only the orientation of the first or last segment (AllowSplitLinks is true), or by changing the orientation of all segments of the link (AllowSplitLinks is false).

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Diagram.LinkCascadeOrientation Property
Style Property


MindFusion.Diagramming.DiagramLink.ControlPoints Property

DiagramLink.ControlPoints Property

Gets a collection of the control points of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointCollection ControlPoints { get; }
Visual Basic

Public ReadOnly Property ControlPoints As PointCollection

Property Value

A collection of control points that specify the link's shape.

Remarks

You can specify new positions of a link's points through that property. The number of points in the collection depends on the Style and SegmentCount of the link. Links made of Bézier-splines has four control points for each segment. Links of the other styles have two control points per segment. Adjacent segments share a common control point. Check the Count property of the collection to get the number of points. After setting new positions of control points you must call the UpdateFromPoints method.

Example

The following example demonstrates how to programatically setup the control points of a link:

C#

DiagramLink link;
PointF cpt;

link = Diagram.Links[0];

// Move the second and the third points
cpt = link.ControlPoints[1];
link.ControlPoints[1] = new PointF(cpt.X + 5, cpt.Y);
link.ControlPoints[2] = new PointF(22.2f, 33.3f);

// Update state and redraw
link.UpdateFromPoints();
Visual Basic

Dim link As DiagramLink
Dim cpt As PointF

link = diagram.Links(0)

' Move the second and the third points
cpt = link.ControlPoints(1)
link.ControlPoints(1) = New PointF(cpt.X + 5, cpt.Y)
link.ControlPoints(2) = New PointF(22.2, 33.3)

' Update state and redraw
link.UpdateFromPoints()

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
UpdateFromPoints Method


MindFusion.Diagramming.DiagramLink.CustomDraw Property

DiagramLink.CustomDraw Property

Gets or sets the type of custom drawing performed on this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CustomDraw CustomDraw { get; set; }
Visual Basic

Public Property CustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of LinkCustomDraw.

Remarks

This property allows invoking custom painting code for a link. That code must execute in response to the DrawLink event. There are several modes of custom painting, allowing the custom code to paint the link entirely, or do that in addition to what MindFusion.Diagramming paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member name | Description
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming.
Additional | The custom painting code executes after the link segments and arrowhead shapes are painted by MindFusion.Diagramming, but before text is rendered.
Full | The component does not do any standard drawing, the entire painting of the link is done by the application.
ShadowOnly | Only the shadow of the link is painted by custom code, the link itself is drawn by the component.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.Destination Property

DiagramLink.Destination Property

Gets or sets the destination node of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Destination { get; set; }
Visual Basic

Public Property Destination As DiagramNode

Property Value

A reference to the destination DiagramNode of the link.

Remarks

The link's destination can be changed programmatically with this property. If any of the connected nodes has an AnchorPattern defined, links ends are placed at the nearest anchor points of the two nodes. If AutoRoute is enabled, the link is routed when changing its origin or destination.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Origin Property
DestinationAnchor Property


MindFusion.Diagramming.DiagramLink.DestinationAnchor Property

DiagramLink.DestinationAnchor Property

Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int DestinationAnchor { get; set; }
Visual Basic

Public Property DestinationAnchor As Integer

Property Value

An integer index of an anchor point within the AnchorPattern containing it.

Remarks

Specifies the index of an anchor point contained within the Destination anchor pattern. The link is docked and stay connected to that point if the node is moved or resized.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
OriginAnchor Property
Diagram.DestinationAnchorChanged Event


MindFusion.Diagramming.DiagramLink.DestinationIndex Property

DiagramLink.DestinationIndex Property

Gets or sets the index of link's destination anchor point or table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int DestinationIndex { get; set; }
Visual Basic

Public Property DestinationIndex As Integer

Property Value

An integer value specifying the index of table's row or the index of an anchor point within its containing AnchorPattern.

Remarks

If a link's destination is a shape node, this property lets you get or set the index of an anchor point at which the link docks to the node. If there is no AnchorPattern defined for the destination node, the property returns -1. If the link is connected to a table, the property returns or changes the related row of that table.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
OriginIndex Property


MindFusion.Diagramming.DiagramLink.DrawCrossings Property

DiagramLink.DrawCrossings Property

Gets or sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool DrawCrossings { get; set; }
Visual Basic

Public Property DrawCrossings As Boolean

Property Value

true if crossing points should be drawn as arcs or dashes; otherwise, false. The default is true.

Remarks

The LinkCrossings property of the Diagram class specifies what shapes are drawn at link crossing points. Individual links cannot display shapes different from the ones drawn for other links, but the crossing points shapes can be shown or hidden for a link through this property.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.Dynamic Property

DiagramLink.Dynamic Property

Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Dynamic { get; set; }
Visual Basic

Public Property Dynamic As Boolean

Property Value

true to make the link automatically adjust its end points; otherwise, false. Initialized with the value of DynamicLinks.

Remarks

Use the property to specify whether a link automatically repositions its end segments, so they keep pointing to the centers of nodes connected by that link. If enabled, moving a connected node recalculates the position of link's end point, placing it at appropriate location of the node outline. If the node has anchor points assigned to it, the end point is attached to one of them. End points are realigned also when moving the points next to them.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
RetainForm Property


MindFusion.Diagramming.DiagramLink.Font Property

DiagramLink.Font Property

DiagramItem.Font override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Font Font { get; set; }
Visual Basic

Public Overrides Property Font As Font

Property Value

The .NET Font to use when drawing the link's text.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.HandlesStyle Property

DiagramLink.HandlesStyle Property

Gets or sets the appearance of the link's selection handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public HandlesStyle HandlesStyle { get; set; }
Visual Basic

Public Property HandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration. Initialized with the value of LinkHandlesStyle.

Remarks

Specifies how link's selection status is indicated visually. You can choose between the following styles:

Member name | Description
SquareHandles | The selection is indicated by drawing square handles at the position of each control point.
DashFrame | The selection is indicated by drawing dashed line segments along the link's segments. In addition, there are square selection handles drawn at the location of each control point of the link.
Custom | MindFusion.Diagramming raises the DrawAdjustmentHandles events to let your application perform custom drawing of link's selection handles.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.HeadPen Property

DiagramLink.HeadPen Property

Gets or sets the pen to use when painting arrowheads lines.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Pen HeadPen { get; set; }
Visual Basic

Public Property HeadPen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class. Initialized with a clone of LinkPen.

Remarks

This property refers to a pen used to paint arrowhead lines. To change how segment lines are painted, use the Pen property.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Brush and Pen Classes
Brush Property


MindFusion.Diagramming.DiagramLink.HeadShape Property

DiagramLink.HeadShape Property

Gets or sets the shape of this link's arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrowHead HeadShape { get; set; }
Visual Basic

Public Property HeadShape As ArrowHead

Property Value

A member of the ArrowHead enumeration. Initialized with the value of LinkHeadShape.

Remarks

The property specifies what shape is displayed as an arrowhead. This shape is rotated simultaneously with the last segment of the link so that it follows the overall link direction.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
BaseShape Property
IntermediateShape Property
HeadShapeSize Property


MindFusion.Diagramming.DiagramLink.HeadShapeSize Property

DiagramLink.HeadShapeSize Property

Gets or sets the size of the arrowhead shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float HeadShapeSize { get; set; }
Visual Basic

Public Property HeadShapeSize As Single

Property Value

A float value that measures the size. Initialized with the value of LinkHeadShapeSize.

Remarks

The property specifies how big the shape of the arrowhead is.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
HeadShape Property


MindFusion.Diagramming.DiagramLink.IntermediateShape Property

DiagramLink.IntermediateShape Property

Gets or sets the shape displayed at the middle of each segment of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrowHead IntermediateShape { get; set; }
Visual Basic

Public Property IntermediateShape As ArrowHead

Property Value

A member of the ArrowHead enumeration. Initialized with the value of LinkIntermediateShape.

Remarks

The property specifies what shape to display at the middle of each segment of a link. This could help users to see more easily the direction of long links. Possible values are taken from the ArrowHead enumeration.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
HeadShape Property
BaseShape Property
IntermediateShapeSize Property


MindFusion.Diagramming.DiagramLink.IntermediateShapeSize Property

DiagramLink.IntermediateShapeSize Property

Gets or sets the size of the IntermediateShape shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float IntermediateShapeSize { get; set; }
Visual Basic

Public Property IntermediateShapeSize As Single

Property Value

A float value that measures the size. Initialized with the value of LinkIntermediateShapeSize.

Remarks

The property specifies how big are the shapes that are displayed in the middle of link segments.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
IntermediateShape Property


MindFusion.Diagramming.DiagramLink.IsConnected Property

DiagramLink.IsConnected Property

Gets a value indicating whether the link is connected to nodes at both its ends.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool IsConnected { get; }
Visual Basic

Public ReadOnly Property IsConnected As Boolean

Property Value

true to indicate that both ends of the link are connected to nodes; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLink.Length Property

DiagramLink.Length Property

Gets the length of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float Length { get; }
Visual Basic

Public ReadOnly Property Length As Single

Property Value

A float value that represents the total length of the link, sum of the lengths of all its segments.

Remarks

If the link's Style is set to Bezier, an approximate length is calculated. In that case, the approximate value is almost always slightly smaller than the real length of Bézier segments.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Style Property
SegmentCount Property


MindFusion.Diagramming.DiagramLink.Origin Property

DiagramLink.Origin Property

Gets or sets the origin node of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Origin { get; set; }
Visual Basic

Public Property Origin As DiagramNode

Property Value

A reference to the origin DiagramNode of the link.

Remarks

The link's origin can be changed programmatically with this property. If any of the connected nodes has an AnchorPattern defined, links ends are placed at the nearest anchor points of the two nodes. If AutoRoute is enabled, the link is routed when changing its origin or destination.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Destination Property
OriginAnchor Property


MindFusion.Diagramming.DiagramLink.OriginAnchor Property

DiagramLink.OriginAnchor Property

Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int OriginAnchor { get; set; }
Visual Basic

Public Property OriginAnchor As Integer

Property Value

An integer index of an anchor point within its the AnchorPattern containing it.

Remarks

Specifies the index of an anchor point contained within the Origin anchor pattern. The link is docked and stay connected to that point if the node is moved or resized.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
DestinationAnchor Property
Diagram.OriginAnchorChanged Event


MindFusion.Diagramming.DiagramLink.OriginIndex Property

DiagramLink.OriginIndex Property

Gets or sets the index of link's origin anchor point or table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int OriginIndex { get; set; }
Visual Basic

Public Property OriginIndex As Integer

Property Value

An integer value specifying the index of table's row or index of an anchor point within its containing AnchorPattern.

Remarks

If a link's origin is a shape node, this property lets you get or set the index of an anchor point at which the link docks to the node. If there is no AnchorPattern defined for the origin node, the property returns -1. If the link is connected to a table, the property returns or changes the related row of that table.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
DestinationIndex Property


MindFusion.Diagramming.DiagramLink.RetainForm Property

DiagramLink.RetainForm Property

Gets or sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RetainForm { get; set; }
Visual Basic

Public Property RetainForm As Boolean

Property Value

true to retain the form of this link; otherwise, false. Initialized with the value of LinksRetainForm.

Remarks

RetainForm is useful for links that have more than two control points. If the nodes that a link connects are moved around, usually only the segments at the ends of that link are updated, so that they stay connected to their respective nodes. In that case all intermediate control points stay where they are. However, if RetainForm is enabled, all control points will move simultaneously in a way they preserve their relative position one to another, and thus preserving the overall form of the link.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
AutoRoute Property
Dynamic Property


MindFusion.Diagramming.DiagramLink.SegmentCount Property

DiagramLink.SegmentCount Property

Gets or sets the number of segments of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public short SegmentCount { get; set; }
Visual Basic

Public Property SegmentCount As Short

Property Value

An integer value specifying how many segments the link consists of. Initialized with the value of LinkSegments.

Remarks

Use this property to make a link more indented, when necessary.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
ControlPoints Property
Length Property


MindFusion.Diagramming.DiagramLink.SnapToNodeBorder Property

DiagramLink.SnapToNodeBorder Property

Gets or sets a value indicating whether the link end points should automatically align to node borders while a user moves them.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool SnapToNodeBorder { get; set; }
Visual Basic

Public Property SnapToNodeBorder As Boolean

Property Value

true to align link's end points to node borders; otherwise, false. Initialized wth the value of LinksSnapToBorders.

Remarks

If this property is enabled, link's end point is automatically aligned to the nearest border point of a node, over which the link's end is being dragged. If there is an AnchorPattern assigned to a node, the nearest anchor point is used instead of a border point.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Dynamic Property
RetainForm Property


MindFusion.Diagramming.DiagramLink.Style Property

DiagramLink.Style Property

Gets or sets the type of link segments and how they are positioned one relatively to another.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public LinkStyle Style { get; set; }
Visual Basic

Public Property Style As LinkStyle

Property Value

A member of the LinkStyle enumeration. Initialized with the value of LinkStyle.

Remarks

This property specifies whether the segments of a link are straight lines or curves. In case of straight lines, they can be set all horizontal and vertical, each segment orthogonal to its neighbor, by using the Cascading style. Use the SegmentCount property to set the number of segments of the link.

The orientation of the first segment of a cascading link depends on the value of CascadeOrientation. If that property is set to Auto, users may change the cascade orientation interactively.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
ControlPoints Property
AutoRoute Property


MindFusion.Diagramming.DiagramLink.Text Property

DiagramLink.Text Property

Gets or sets the text displayed over a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string Text { get; set; }
Visual Basic

Public Property Text As String

Property Value

A string containing the text. Initialized with the value of LinkText.

Remarks

Gets or sets the text that should be drawn over a link. Use this to provide to end-users a short description of the relation's purpose. The text appearance can be customized through the TextColor and TextStyle properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
ToolTip Property


MindFusion.Diagramming.DiagramLink.TextColor Property

DiagramLink.TextColor Property

Gets or sets the color of the link's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color TextColor { get; set; }
Visual Basic

Public Property TextColor As Color

Property Value

An instance of the .NET Color structure. Initialized with the value of TextColor.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Text Property
TextStyle Property


MindFusion.Diagramming.DiagramLink.TextStyle Property

DiagramLink.TextStyle Property

Gets or sets the link's text placement and orientation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public LinkTextStyle TextStyle { get; set; }
Visual Basic

Public Property TextStyle As LinkTextStyle

Property Value

A member of the LinkTextStyle enumeration. Initialized with the value of LinkTextStyle.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace
Text Property
TextColor Property


MindFusion.Diagramming.DiagramLink.Visible Property

DiagramLink.Visible Property

DiagramItem.Visible override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool Visible { get; set; }
Visual Basic

Public Overrides Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkCollection Class

DiagramLinkCollection Class

Represents a strongly typed collection of DiagramLink objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DiagramLinkCollection : ItemCollectionBase
Visual Basic

Public Class DiagramLinkCollection
Inherits ItemCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.PersistableCollection
MindFusion.Diagramming.ItemCollectionBase
MindFusion.Diagramming.DiagramLinkCollection

See Also

DiagramLinkCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkCollection Members

DiagramLinkCollection Members
Constructors Properties Methods

Represents a strongly typed collection of DiagramLink objects.

The following tables list the members exposed by the DiagramLinkCollection type.

Public Constructors

Name | Description
DiagramLinkCollection | Initializes a new instance of the DiagramLinkCollection class.

Public Properties

Name | Description
Item | Gets or sets the link at the specified position.

Public Methods

Name | Description
Add | Adds the specified link to the collection.
Clone | Creates a shallow copy of this collection.
Contains | Checks whether the specified link is contained within the collection.
GetAt | Gets the link at the specified position.
IndexOf | Searches for the specified link and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts the specified link in the collection at the specified position.
Remove | Removes the specified link from the collection.

See Also

DiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkCollection Constructor

DiagramLinkCollection Constructor

Initializes a new instance of the DiagramLinkCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLinkCollection ()
Visual Basic

Public Sub New ()

See Also

DiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkCollection Methods

DiagramLinkCollection Methods

Public Methods

Name | Description
Add | Adds the specified link to the collection.
Clone | Creates a shallow copy of this collection.
Contains | Checks whether the specified link is contained within the collection.
GetAt | Gets the link at the specified position.
IndexOf | Searches for the specified link and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts the specified link in the collection at the specified position.
Remove | Removes the specified link from the collection.

See Also

DiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkCollection.Add Method

DiagramLinkCollection.Add Method

Adds the specified link to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Add (
DiagramLink link
)
Visual Basic

Public Sub Add ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink object to add to the collection.

See Also

DiagramLinkCollection Members
DiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkCollection.Clone Method

DiagramLinkCollection.Clone Method

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLinkCollection Clone ()
Visual Basic

Public Function Clone () As DiagramLinkCollection

Return Value

An instance of the DiagramLinkCollection class.

See Also

DiagramLinkCollection Members
DiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkCollection.Contains Method

DiagramLinkCollection.Contains Method

Checks whether the specified link is contained within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Contains (
DiagramLink link
)
Visual Basic

Public Function Contains ( _
link As DiagramLink _
) As Boolean

Parameters

link

The DiagramLink object to search for in the collection.

Return Value

true if the specified link was found in the collection; otherwise, false.

See Also

DiagramLinkCollection Members
DiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkCollection.GetAt Method

DiagramLinkCollection.GetAt Method

Gets the link at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink GetAt (
int index
)
Visual Basic

Public Function GetAt ( _
index As Integer _
) As DiagramLink

Parameters

index

The zero-based index of the link to retreive.

Return Value

An instance of the DiagramLink class that represents the link at the specified position.

See Also

DiagramLinkCollection Members
DiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkCollection.IndexOf Method

DiagramLinkCollection.IndexOf Method

Searches for the specified link and returns the zero-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int IndexOf (
DiagramLink link
)
Visual Basic

Public Function IndexOf ( _
link As DiagramLink _
) As Integer

Parameters

link
The link to locate in the collection.

Return Value

The zero-based index of the first occurrence of link within the entire collection, if found; otherwise, -1.

See Also

DiagramLinkCollection Members
DiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkCollection.Insert Method

DiagramLinkCollection.Insert Method

Inserts the specified link in the collection at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Insert (
int index,
DiagramLink link
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
link As DiagramLink _
)

Parameters

index

The zero-based index at which to insert the link.

link

The DiagramLink object to add to the collection.

See Also

DiagramLinkCollection Members
DiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkCollection.Remove Method

DiagramLinkCollection.Remove Method

Removes the specified link from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Remove (
DiagramLink link
)
Visual Basic

Public Sub Remove ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink object to remove from the collection.

See Also

DiagramLinkCollection Members
DiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkCollection Properties

DiagramLinkCollection Properties

Public Properties

Name | Description
Item | Gets or sets the link at the specified position.

See Also

DiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkCollection.Item Property

DiagramLinkCollection.Item Property

Gets or sets the link at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As DiagramLink

Parameters

index

The zero-based index of the link to set or retrieve.

Property Value

An instance of the DiagramLink class that represents the link at the specified position.

See Also

DiagramLinkCollection Members
DiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties Class

DiagramLinkProperties Class
Remarks See Also

Stores the values of DiagramLink properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DiagramLinkProperties : DiagramItemProperties
Visual Basic

Public Class DiagramLinkProperties
Inherits DiagramItemProperties

Remarks

If you need to implement undo support for the additional properties defined by a class derived from DiagramLink, do so by deriving from DiagramLinkProperties and overriding the SaveProperties, RestoreProperties and CreateProperties methods of DiagramLink.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramLinkProperties

See Also

DiagramLinkProperties Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties Members

DiagramLinkProperties Members
Constructors Fields

Stores the values of DiagramLink properties during undo / redo operations.

The following tables list the members exposed by the DiagramLinkProperties type.

Public Constructors

Name | Description
DiagramLinkProperties | Initializes a new instance of the DiagramLinkProperties class.

Public Fields

Name | Description
AllowMoveEnd | For internal use.
AllowMoveStart | For internal use.
AutoRoute | For internal use.
BaseShape | For internal use.
BaseShapeSize | For internal use.
CascadeOrientation | For internal use.
DrawCrossings | For internal use.
Dynamic | For internal use.
HeadShape | For internal use.
HeadShapeSize | For internal use.
IntermediateShape | For internal use.
IntermediateShapeSize | For internal use.
RetainForm | For internal use.
SnapToNodeBorder | For internal use.
Text | For internal use.
TextColor | For internal use.

See Also

DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties Fields

DiagramLinkProperties Fields

Public Fields

Name | Description
AllowMoveEnd | For internal use.
AllowMoveStart | For internal use.
AutoRoute | For internal use.
BaseShape | For internal use.
BaseShapeSize | For internal use.
CascadeOrientation | For internal use.
DrawCrossings | For internal use.
Dynamic | For internal use.
HeadShape | For internal use.
HeadShapeSize | For internal use.
IntermediateShape | For internal use.
IntermediateShapeSize | For internal use.
RetainForm | For internal use.
SnapToNodeBorder | For internal use.
Text | For internal use.
TextColor | For internal use.

See Also

DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.AllowMoveEnd Field

DiagramLinkProperties.AllowMoveEnd Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowMoveEnd
Visual Basic

Public AllowMoveEnd As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.AllowMoveStart Field

DiagramLinkProperties.AllowMoveStart Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowMoveStart
Visual Basic

Public AllowMoveStart As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.AutoRoute Field

DiagramLinkProperties.AutoRoute Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AutoRoute
Visual Basic

Public AutoRoute As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.BaseShape Field

DiagramLinkProperties.BaseShape Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrowHead BaseShape
Visual Basic

Public BaseShape As ArrowHead

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.BaseShapeSize Field

DiagramLinkProperties.BaseShapeSize Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float BaseShapeSize
Visual Basic

Public BaseShapeSize As Single

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.CascadeOrientation Field

DiagramLinkProperties.CascadeOrientation Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Orientation CascadeOrientation
Visual Basic

Public CascadeOrientation As Orientation

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.DrawCrossings Field

DiagramLinkProperties.DrawCrossings Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool DrawCrossings
Visual Basic

Public DrawCrossings As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.Dynamic Field

DiagramLinkProperties.Dynamic Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Dynamic
Visual Basic

Public Dynamic As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.HeadShape Field

DiagramLinkProperties.HeadShape Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrowHead HeadShape
Visual Basic

Public HeadShape As ArrowHead

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.HeadShapeSize Field

DiagramLinkProperties.HeadShapeSize Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float HeadShapeSize
Visual Basic

Public HeadShapeSize As Single

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.IntermediateShape Field

DiagramLinkProperties.IntermediateShape Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrowHead IntermediateShape
Visual Basic

Public IntermediateShape As ArrowHead

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.IntermediateShapeSize Field

DiagramLinkProperties.IntermediateShapeSize Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float IntermediateShapeSize
Visual Basic

Public IntermediateShapeSize As Single

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.RetainForm Field

DiagramLinkProperties.RetainForm Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RetainForm
Visual Basic

Public RetainForm As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.SnapToNodeBorder Field

DiagramLinkProperties.SnapToNodeBorder Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool SnapToNodeBorder
Visual Basic

Public SnapToNodeBorder As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.Text Field

DiagramLinkProperties.Text Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string Text
Visual Basic

Public Text As String

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties.TextColor Field

DiagramLinkProperties.TextColor Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color TextColor
Visual Basic

Public TextColor As Color

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkProperties Constructor

DiagramLinkProperties Constructor

Initializes a new instance of the DiagramLinkProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLinkProperties ()
Visual Basic

Public Sub New ()

See Also

DiagramLinkProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkState Class

DiagramLinkState Class
Remarks See Also

Contains a snapshot of the internal state of a DiagramLink.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DiagramLinkState : DiagramItemState
Visual Basic

Public Class DiagramLinkState
Inherits DiagramItemState

Remarks

Instances of this class are used to store the state of links for later undo or redo operations. If you derive from DiagramLink and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramLinkState and overriding the CreateState, SaveState and RestoreState methods of DiagramLink.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramLinkState

See Also

DiagramLinkState Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkState Members

DiagramLinkState Members
Constructors

Contains a snapshot of the internal state of a DiagramLink.

The following tables list the members exposed by the DiagramLinkState type.

Public Constructors

Name | Description
DiagramLinkState | Initializes a new instance of the DiagramLinkState class.

See Also

DiagramLinkState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramLinkState Constructor

DiagramLinkState Constructor

Initializes a new instance of the DiagramLinkState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLinkState ()
Visual Basic

Public Sub New ()

See Also

DiagramLinkState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode Class

DiagramNode Class
Remarks See Also

Represents a diagram node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract class DiagramNode : DiagramItem
Visual Basic

Public MustInherit Class DiagramNode
Inherits DiagramItem

Remarks

DiagramNode instances can represent graph vertices, nodes in organizational or flow diagrams, entities in ER diagrams, and so on. DiagramNode is an abstract class. You cannot use it directly, but instead use objects from the ShapeNode, TableNode, ContainerNode and ControlNode specific classes. You can also create your own node class by deriving from DiagramNode or its descendants.

Use the Bounds property to get or change the location and size of a node. To move a node without changing its size, call the Move method. To change only the size of a node, invoke the Resize method.

Constraints upon how users are allowed to modify a node are set through the Constraints and EnabledHandles properties. The former specifies constraints on move direction and node size. The latter enables or disables specific manipulation handles of a node.

Relations between nodes are indicated by connecting the nodes with DiagramLink instances. Links are considered directed graph edges, so each node has two collections referring to links: IncomingLinks and OutgoingLinks. AnchorPattern defines to which points of a node incoming or outgoing links can be connected. The AllowIncomingLinks property lets you specify whether incoming links can be drawn to a node. The AllowOutgoingLinks property lets you do that for outgoing links.

A user is allowed to expand or collapse the tree starting from a node if Expandable is set to true. The Expanded property gets or sets whether the subtree starting from a node is expanded or not.

Nodes can be attached to other items, and be used as simple labels, image-holders or other kinds of UI elements. The AttachTo method creates a Group instance if necessary, and calls the group's appropriate AttachTo* method.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.ContainerNode
MindFusion.Diagramming.DummyNode
MindFusion.Diagramming.ShapeNode
MindFusion.Diagramming.TableNode
MindFusion.Diagramming.WinForms.ControlNode

See Also

DiagramNode Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode Members

DiagramNode Members
Constructors Fields Properties Methods

Represents a diagram node.

The following tables list the members exposed by the DiagramNode type.

Protected Fields

Name | Description
handlesStyle | Contains a value indicating how the node adjustment handles behave and what do they look like.

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node.
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node.
Bounds | Gets or sets the rectangle that defines the position of the diagram node.
Constraints | Allows applying constraints to the location and size of the node.
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like.
IncomingLinks | Gets a collection of links that point to the node.
MasterGroup | Gets a reference to the group to which this node is attached.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
OutgoingLinks | Gets a collection of links that start from this node.

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type.
AttachTo | Overloaded. Attaches this node to another diagram item.
Collapse | Hides all nodes and links in the subtree starting from this node.
ContainsPoint | Overloaded.
Detach | Detaches this node from its master item.
DrawAnchors | Draws the anchor points of this node.
DrawHandles | DiagramItem.DrawHandles override.
Expand | Shows all nodes and links in the subtree starting from this node.
GetAllLinks | Gets all links connected to this node.
GetCenter | Gets the center of this node's bounding rectangle.
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline.
GetOutlinePoly |
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotationAngle | Gets the rotation angle of this node.
GetToolTip | DiagramItem.GetToolTip override.
HitTestHandle | DiagramItem.HitTestHandle override.
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes.
Move | Moves the node to the specified location.
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed.
ReassignUnanchoredLinks | Reassigns unanchored links
Resize | Resizes the node.
SetExpandedFlag | Sets the 'expanded' flag, repainting the node.
SetRect | This method is used internally by the Ruler control to align nodes.

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
GetRotatedBounds | Gets the rectangle that bounds another rectangle which it is rotated at the specified angle around the specified pivot point.
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy.
LoadFrom | DiagramItem.LoadFrom override.
LoadFromXml | DiagramItem.LoadFromXml override.
OnModify | Invoked when the user moves or resizes this node.
OnRemove | DiagramItem.OnRemove override.
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed.
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary.
SetExpanded | DiagramItem.SetExpanded override.
SetIncomingLinks | Sets the incoming links collection of this node.
SetOutgoingLinks | Sets the outgoing links collection of this node.
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRenderAnchors | Determines whether the node should render its anchor points.
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape.
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape.
UpdateModify | DiagramItem.UpdateModify override.

See Also

DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode Fields

DiagramNode Fields

Protected Fields

Name | Description
handlesStyle | Contains a value indicating how the node adjustment handles behave and what do they look like.

See Also

DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.handlesStyle Field

DiagramNode.handlesStyle Field

Contains a value indicating how the node adjustment handles behave and what do they look like.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected HandlesStyle handlesStyle
Visual Basic

Protected handlesStyle As HandlesStyle

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode Constructor

DiagramNode Constructor

Initializes a new instance of the DiagramNode class.

Overload List

Name | Description
DiagramNode () | Initializes a new instance of the DiagramNode class.
DiagramNode (Diagram) | Initializes a new instance of the DiagramNode class with default values supplied form the specified Diagram.
DiagramNode (DiagramNode) | Initializes a new instance of the DiagramNode class using the specified diagram item as a prototype.

See Also

DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode Constructor ()

DiagramNode Constructor ()
See Also

Initializes a new instance of the DiagramNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected DiagramNode ()
Visual Basic

Protected Sub New ()

Remarks

This constructor sets the DiagramNode properties to their default values.

See Also

DiagramNode Constructor Overload List
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode Constructor (Diagram)

DiagramNode Constructor (Diagram)
See Also

Initializes a new instance of the DiagramNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected DiagramNode (
Diagram parent
)
Visual Basic

Protected Sub DiagramNode ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the item properties.

Remarks

This constructor initializes the DiagramNode properties with the values specified in the respective default-value properties of the Diagram object. For more information see Initial Values of Item Properties.

See Also

DiagramNode Constructor Overload List
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode Constructor (DiagramNode)

DiagramNode Constructor (DiagramNode)
See Also

Initializes a new instance of the DiagramNode class using the specified diagram item as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected DiagramNode (
DiagramNode prototype
)
Visual Basic

Protected Sub DiagramNode ( _
prototype As DiagramNode _
)

Parameters

prototype

The item to use as a prototype. The properties of the new item are initialized from the property values of this item.

Remarks

This constructor copies the DiagramNode property values from the specified prototype node.

See Also

DiagramNode Constructor Overload List
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode Methods

DiagramNode Methods

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type.
AttachTo | Overloaded. Attaches this node to another diagram item.
Collapse | Hides all nodes and links in the subtree starting from this node.
ContainsPoint | Overloaded.
Detach | Detaches this node from its master item.
DrawAnchors | Draws the anchor points of this node.
DrawHandles | DiagramItem.DrawHandles override.
Expand | Shows all nodes and links in the subtree starting from this node.
GetAllLinks | Gets all links connected to this node.
GetCenter | Gets the center of this node's bounding rectangle.
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline.
GetOutlinePoly |
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotationAngle | Gets the rotation angle of this node.
GetToolTip | DiagramItem.GetToolTip override.
HitTestHandle | DiagramItem.HitTestHandle override.
Intersects | Determines whether the node intersects another one, taking into account the outlines of node shapes.
Move | Moves the node to the specified location.
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed.
ReassignUnanchoredLinks | Reassigns unanchored links
Resize | Resizes the node.
SetExpandedFlag | Sets the 'expanded' flag, repainting the node.
SetRect | This method is used internally by the Ruler control to align nodes.

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
ConstraintsInfringed | Checks whether the KeepInsideParent constrained is being violated.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
GetRotatedBounds | Gets the rectangle that bounds another rectangle which it is rotated at the specified angle around the specified pivot point.
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy.
LoadFrom | DiagramItem.LoadFrom override.
LoadFromXml | DiagramItem.LoadFromXml override.
OnModify | Invoked when the user moves or resizes this node.
OnRemove | DiagramItem.OnRemove override.
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed.
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary.
SetExpanded | DiagramItem.SetExpanded override.
SetIncomingLinks | Sets the incoming links collection of this node.
SetOutgoingLinks | Sets the outgoing links collection of this node.
SetReference | Called during deserialization, after all objects have been instantiated, in order to update the references between them.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRenderAnchors | Determines whether the node should render its anchor points.
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape.
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape.
UpdateModify | DiagramItem.UpdateModify override.

See Also

DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.AcceptLinks Method

DiagramNode.AcceptLinks Method

Determines whether the node can be connected with links of the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool AcceptLinks (
bool outgoing
)
Visual Basic

Public Overridable Function AcceptLinks ( _
outgoing As Boolean _
) As Boolean

Parameters

outgoing
true to check for outgoing links; otherwise, false.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.AllowCreate Method

DiagramNode.AllowCreate Method

DiagramItem.AllowCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual bool AllowCreate (
PointF current,
InteractionState ist
)
Visual Basic

Protected Overridable Function AllowCreate ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
The current mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the creation of this node; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.AllowModify Method

DiagramNode.AllowModify Method

DiagramItem.AllowModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual bool AllowModify (
PointF current,
InteractionState ist
)
Visual Basic

Protected Overridable Function AllowModify ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
The current mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the modification of this node; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.AttachTo Method

DiagramNode.AttachTo Method

Attaches this node to another diagram item.

Overload List

Name | Description
DiagramNode.AttachTo (DiagramLink, AttachToLink, Int32) | Attaches this node to the specified link using the specified attaching type.
DiagramNode.AttachTo (DiagramNode, AttachToNode) | Attaches this node to the specified node using the specified attaching type.
DiagramNode.AttachTo (DiagramNode, GroupAnchorStyles) | Attaches this node to one or more edges of the specified node.
DiagramNode.AttachTo (DiagramNode, Single, Single, Single, Single) | Proportionally attaches this node to the specified node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.AttachTo Method (DiagramLink, AttachToLink, Int32)

DiagramNode.AttachTo Method (DiagramLink, AttachToLink, Int32)
See Also

Attaches this node to the specified link using the specified attaching type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void AttachTo (
DiagramLink link,
AttachToLink attType,
int index
)
Visual Basic

Public Sub AttachTo ( _
link As DiagramLink, _
attType As AttachToLink, _
index As Integer _
)

Parameters

link
A DiagramLink to whose control point or segment to attach this node.
attType
A value of the AttachToLink enumeration specifying whether to attach the node to a segment or to a control point of the link.
index
An index of link's control point or segment, depending on the attType value.

Remarks

This method attaches the node to a control point or segment of the specified link. If there isn't a Group instance already associated with the master item, one is created automatically by this method. The group is then accessible through the master's SubordinateGroup property, or this node's MasterGroup property.

The node is attached by calling the AttachToLinkPoint or AttachToLinkSegment methods of Group, depending on the value of the attType argument. The attached node then maintains its original offset from a link's point or segment when link's shape changes.

See Also

AttachTo Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Detach Method


MindFusion.Diagramming.DiagramNode.AttachTo Method (DiagramNode, AttachToNode)

DiagramNode.AttachTo Method (DiagramNode, AttachToNode)
See Also

Attaches this node to the specified node using the specified attaching type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void AttachTo (
DiagramNode node,
AttachToNode attType
)
Visual Basic

Public Sub AttachTo ( _
node As DiagramNode, _
attType As AttachToNode _
)

Parameters

node
A reference to the node to whose corner to attach this node.
attType
A member of the AttachToNode enumeration specifying to which corner of a node to attach this node.

Remarks

This method attaches the current node to the corner of another node. If there isn't a Group instance already associated with the master item, one is created automatically by this method. The group is then accessible by the master's SubordinateGroup property, or this node's MasterGroup property.

The node is attached by calling the AttachToCorner method of Group. The attached node then maintains its original offset from another node's corner point.

See Also

AttachTo Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Detach Method


MindFusion.Diagramming.DiagramNode.AttachTo Method (DiagramNode, GroupAnchorStyles)

DiagramNode.AttachTo Method (DiagramNode, GroupAnchorStyles)
See Also

Attaches this node to one or more edges of the specified node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void AttachTo (
DiagramNode node,
GroupAnchorStyles anchorStyles
)
Visual Basic

Public Sub AttachTo ( _
node As DiagramNode, _
anchorStyles As GroupAnchorStyles _
)

Parameters

node
A reference to the node to which to attach this node.
anchorStyles
A member of the GroupAnchorStyles enumeration specifying the master node's edges to which this node must be anchored.

Remarks

This method attaches the current node to the corner of another node. If there isn't a Group instance already associated with the master item, one is created automatically by this method. The group is then accessible by the master's SubordinateGroup property, or this node's MasterGroup property.

The node is attached by calling the AttachToEdges method of Group, which mimics the anchoring of child controls in a form to the form edges, as implemented in Windows Forms.

See Also

AttachTo Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Detach Method


MindFusion.Diagramming.DiagramNode.AttachTo Method (DiagramNode, Single, Single, Single, Single)

DiagramNode.AttachTo Method (DiagramNode, Single, Single, Single, Single)
See Also

Proportionally attaches this node to the specified node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void AttachTo (
DiagramNode node,
float percentX1,
float percentY1,
float percentX2,
float percentY2
)
Visual Basic

Public Sub AttachTo ( _
node As DiagramNode, _
percentX1 As Single, _
percentY1 As Single, _
percentX2 As Single, _
percentY2 As Single _
)

Parameters

node
A reference to the node to which to attach this node.
percentX1
Left-hand side coordinate of the node, expressed as percent of main node's width.
percentY1
Top side coordinate of the node, expressed as percent of main node's height.
percentX2
Right-hand side coordinate of the node, expressed as percent of main node's width.
percentY2
Bottom side coordinate of the node, expressed as percent of main node's height.

Remarks

This method attaches proportionally the current node to another node. If there isn't a Group instance already associated with the master item, one is created automatically by this method. The group is then accessible through the master's SubordinateGroup property, or this node's MasterGroup property.

The node is attached by calling the AttachProportional method of Group. The attached node maintains its size and position so that it always covers the specified rectangular area of the master node.

See Also

AttachTo Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Detach Method


MindFusion.Diagramming.DiagramNode.Collapse Method

DiagramNode.Collapse Method

Hides all nodes and links in the subtree starting from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Collapse ()
Visual Basic

Public Sub Collapse ()

Remarks

This method is useful mostly when nodes form a tree-like hierarchical structure. Invoking Collapse on a node makes all its children in the tree invisible. It depends on the diagram's ExpandOnIncoming property which items connected to the node are considered its children.

Collapse is meant for use with tree structures and it is your responsibility to ensure that your chart is really a tree. A graph is a tree if every node has no more than one parent and there's one root node that can be reached from all nodes going in child-to-parent direction. The tree can be expanded again by calling the Expand method.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Expand Method
Expanded Property


MindFusion.Diagramming.DiagramNode.CompleteCreate Method

DiagramNode.CompleteCreate Method

DiagramItem.CompleteCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void CompleteCreate (
PointF end
)
Visual Basic

Protected Overridable Sub CompleteCreate ( _
end As PointF _
)

Parameters

end
The mouse pointer position.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.CompleteModify Method

DiagramNode.CompleteModify Method

DiagramItem.CompleteModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void CompleteModify (
PointF end,
InteractionState ist
)
Visual Basic

Protected Overridable Sub CompleteModify ( _
end As PointF, _
ist As InteractionState _
)

Parameters

end
The mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.ConstraintsInfringed Method

DiagramNode.ConstraintsInfringed Method

Checks whether the KeepInsideParent constrained is being violated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected bool ConstraintsInfringed ()
Visual Basic

Protected Function ConstraintsInfringed () As Boolean

Return Value

true if the current node coordinates violate the KeepInsideParent constraint; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.ContainsPoint Method

DiagramNode.ContainsPoint Method

Overload List

Name | Description
DiagramNode.ContainsPoint (PointF) | DiagramItem.ContainsPoint override.
DiagramNode.ContainsPoint (PointF, Single) | Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.ContainsPoint Method (PointF)

DiagramNode.ContainsPoint Method (PointF)
See Also

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool ContainsPoint (
PointF point
)
Visual Basic

Public Overrides Function ContainsPoint ( _
point As PointF _
) As Boolean

Parameters

point
The point to check.

Return Value

true if this node contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.ContainsPoint Method (PointF, Single)

DiagramNode.ContainsPoint Method (PointF, Single)
See Also

Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool ContainsPoint (
PointF point,
float threshold
)
Visual Basic

Public Overridable Function ContainsPoint ( _
point As PointF, _
threshold As Single _
) As Boolean

Parameters

point
The point to check.
threshold

Specifies the size of the area around the node outlines where the point is still considered inside the node.

Return Value

true if this node contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.CreateConnectionPoint Method

DiagramNode.CreateConnectionPoint Method

Creates a connection point between this node and the specified link at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
PointF pt,
bool incoming
)
Visual Basic

Protected Overridable Function CreateConnectionPoint ( _
link As DiagramLink, _
pt As PointF, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
pt
The point at which the link should be connected.
incoming
true if link is an incoming link, otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.Detach Method

DiagramNode.Detach Method

Detaches this node from its master item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Detach ()
Visual Basic

Public Sub Detach ()

Remarks

The node should be previously attached using AttachTo.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.DrawAnchors Method

DiagramNode.DrawAnchors Method

Draws the anchor points of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void DrawAnchors (
IGraphics graphics
)
Visual Basic

Public Overridable Sub DrawAnchors ( _
graphics As IGraphics _
)

Parameters

graphics
The IGraphics surface to draw the anchor points on.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.DrawHandles Method

DiagramNode.DrawHandles Method

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void DrawHandles (
IGraphics graphics,
Color color
)
Visual Basic

Public Overrides Sub DrawHandles ( _
graphics As IGraphics, _
color As Color _
)

Parameters

graphics
The IGraphics surface to draw the handles on.
color
The color that should be used to render the handles.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.Expand Method

DiagramNode.Expand Method

Shows all nodes and links in the subtree starting from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Expand ()
Visual Basic

Public Sub Expand ()

Remarks

This method is useful mostly when nodes form a tree-like hierarchical structure. Use Expand to show a subtree of nodes that was previously collapsed, either interactively or by calling Collapse. If the RecursiveExpand property is enabled, all tree levels are expanded recursively.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Collapse Method
Expanded Property


MindFusion.Diagramming.DiagramNode.GetAllLinks Method

DiagramNode.GetAllLinks Method

Gets all links connected to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLinkCollection GetAllLinks ()
Visual Basic

Public Function GetAllLinks () As DiagramLinkCollection

Return Value

A DiagramLinkCollection containing the links connected to this node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.GetCenter Method

DiagramNode.GetCenter Method

Gets the center of this node's bounding rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF GetCenter ()
Visual Basic

Public Function GetCenter () As PointF

Return Value

A PointF object representing the center point of this node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.GetIntersection Method

DiagramNode.GetIntersection Method

Calculates the intersecion point between the segment defined by the specified point pair and the node's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual PointF GetIntersection (
PointF segmentStart,
PointF segmentEnd
)
Visual Basic

Public Overridable Function GetIntersection ( _
segmentStart As PointF, _
segmentEnd As PointF _
) As PointF

Parameters

segmentStart
The first point of the segment.
segmentEnd
The second point of the segment.

Return Value

A PointF object representing the intersection point.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.GetOutlinePoly Method (Boolean)

DiagramNode.GetOutlinePoly Method (Boolean)
See Also

DiagramItem.GetOutlinePoly override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override PointCollection GetOutlinePoly (
bool rendering
)
Visual Basic

Public Overrides Function GetOutlinePoly ( _
rendering As Boolean _
) As PointCollection

Parameters

rendering

Return Value

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.GetRepaintRect Method

DiagramNode.GetRepaintRect Method

DiagramItem.GetRepaintRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override RectangleF GetRepaintRect (
bool includeConnected
)
Visual Basic

Public Overrides Function GetRepaintRect ( _
includeConnected As Boolean _
) As RectangleF

Parameters

includeConnected
true if related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this node is modified.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.GetRotatedBounds Method

DiagramNode.GetRotatedBounds Method

Gets the rectangle that bounds another rectangle which it is rotated at the specified angle around the specified pivot point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected RectangleF GetRotatedBounds (
RectangleF rect,
PointF center,
float angle
)
Visual Basic

Protected Function GetRotatedBounds ( _
rect As RectangleF, _
center As PointF, _
angle As Single _
) As RectangleF

Parameters

rect
The rectangle that will be rotated.
center
The pivot point.
angle
The rotation angle.

Return Value

A RectangleF representing the new bounding rectangle.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.GetRotationAngle Method

DiagramNode.GetRotationAngle Method

Gets the rotation angle of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual float GetRotationAngle ()
Visual Basic

Public Overridable Function GetRotationAngle () As Single

Return Value

A float value specifying the rotation angle.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.GetToolTip Method

DiagramNode.GetToolTip Method

DiagramItem.GetToolTip override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override string GetToolTip (
PointF point
)
Visual Basic

Public Overrides Function GetToolTip ( _
point As PointF _
) As String

Parameters

point
The mouse pointer position.

Return Value

A string specifying the tooltip text.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.GroupContains Method

DiagramNode.GroupContains Method

Determines whether this node is a predecessor of the specified node in the group hierarchy.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected bool GroupContains (
DiagramNode node
)
Visual Basic

Protected Function GroupContains ( _
node As DiagramNode _
) As Boolean

Parameters

node
The node to check.

Return Value

true if the specified node is subordinate to this one; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.HitTestHandle Method

DiagramNode.HitTestHandle Method

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool HitTestHandle (
PointF pt,
ref int handle
)
Visual Basic

Public Overrides Function HitTestHandle ( _
pt As PointF, _
ByRef handle As Integer _
) As Boolean

Parameters

pt
A PointF value specifying where to look for a selection handle.
handle
A reference to an integer variable, which receives the index of the found selection handle.

Return Value

true if there is a selection handle at the specified location; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.Intersects Method

DiagramNode.Intersects Method

Determines whether the node intersects another one, taking into account the outlines of node shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Intersects (
DiagramNode node
)
Visual Basic

Public Function Intersects ( _
node As DiagramNode _
) As Boolean

Parameters

node
A reference to the node to test for intersections with this one.

Return Value

true if the current node intersects with the specified node; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Bounds Property


MindFusion.Diagramming.DiagramNode.LoadFrom Method

DiagramNode.LoadFrom Method

DiagramItem.LoadFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)
Visual Basic

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the item's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.LoadFromXml Method

DiagramNode.LoadFromXml Method

DiagramItem.LoadFromXml override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.Move Method

DiagramNode.Move Method

Moves the node to the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Move (
float x,
float y
)
Visual Basic

Public Sub Move ( _
x As Single, _
y As Single _
)

Parameters

x
A float value specifying the new X-coordinate of node's location.
y
A float value specifying the new Y-coordinate of node's location.

Remarks

This method moves a node to the specified position, without changing the node's size. Moving a node also updates the control points coordinates of all links connected to the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Bounds Property
Resize Method


MindFusion.Diagramming.DiagramNode.OnDragOut Method

DiagramNode.OnDragOut Method

Invoked when a diagram item is being dragged out of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void OnDragOut (
DiagramItem item
)
Visual Basic

Public Overridable Sub OnDragOut ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem that is dragged out of the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.OnDragOver Method

DiagramNode.OnDragOver Method

Invoked when a diagram item is being dragged over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool OnDragOver (
DiagramItem item
)
Visual Basic

Public Overridable Function OnDragOver ( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem that is dragged over the node.

Return Value

false if the diagram should notify nodes below this one; otherwise, true.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.OnDropOver Method

DiagramNode.OnDropOver Method

Invoked when a diagram item is dropped over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool OnDropOver (
DiagramItem item
)
Visual Basic

Public Overridable Function OnDropOver ( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem that is dropped over the node.

Return Value

false if the diagram should notify nodes below this one; otherwise, true.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.OnModify Method

DiagramNode.OnModify Method

Invoked when the user moves or resizes this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnModify (
PointF mousePosition,
AdjustmentHandles adjustmentHandle
)
Visual Basic

Protected Overridable Sub OnModify ( _
mousePosition As PointF, _
adjustmentHandle As AdjustmentHandles _
)

Parameters

mousePosition
Specifies the mouse position.
adjustmentHandle
Specifies the adjustment handle used to modify the node.

Remarks

Implement this method in a custom node class if you need to detect modifications done by the user without handling events of the Diagram class.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.OnRemove Method

DiagramNode.OnRemove Method

DiagramItem.OnRemove override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnRemove ()
Visual Basic

Protected Overridable Sub OnRemove ()

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.OnUpdateBounds Method

DiagramNode.OnUpdateBounds Method

Invoked when the bounding rectangle of the node has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnUpdateBounds ()
Visual Basic

Protected Overridable Sub OnUpdateBounds ()

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.ReassignAnchorPoints Method

DiagramNode.ReassignAnchorPoints Method

Reassigns links to anchor points so that they are evenly disctributed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ReassignAnchorPoints ()
Visual Basic

Public Sub ReassignAnchorPoints ()

Remarks

If there are more anchor points defined for this node than links connected to it, this method ensures that each point has at most one link attached to it. ReassignAnchorPoints also tries to assign links to points that are close to their opposite end points.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
AnchorPattern Property


MindFusion.Diagramming.DiagramNode.ReassignUnanchoredLinks Method

DiagramNode.ReassignUnanchoredLinks Method

Reassigns unanchored links

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ReassignUnanchoredLinks ()
Visual Basic

Public Sub ReassignUnanchoredLinks ()

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.Resize Method

DiagramNode.Resize Method

Resizes the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Resize (
float width,
float height
)
Visual Basic

Public Sub Resize ( _
width As Single, _
height As Single _
)

Parameters

width
A float value specifying new width of the node.
height
A float value specifying new height of the node.

Remarks

This method resizes a node, without changing the node's top-left corner location. Resizing a node also updates the control points coordinates of all links connected to the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Bounds Property
Move Method


MindFusion.Diagramming.DiagramNode.RestoreProperties Method

DiagramNode.RestoreProperties Method

DiagramItem.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void RestoreProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.RestoreState Method

DiagramNode.RestoreState Method

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void RestoreState (
DiagramItemState state
)
Visual Basic

Protected Overridable Sub RestoreState ( _
state As DiagramItemState _
)

Parameters

state
A DiagramItemState-derived object.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.SaveProperties Method

DiagramNode.SaveProperties Method

DiagramItem.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object where the item's properties should be saved.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.SaveTo Method

DiagramNode.SaveTo Method

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)
Visual Basic

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the item's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.SaveToXml Method

DiagramNode.SaveToXml Method

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.SetExpandable Method

DiagramNode.SetExpandable Method

Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void SetExpandable (
bool exp
)
Visual Basic

Protected Sub SetExpandable ( _
exp As Boolean _
)

Parameters

exp
true if a collapse/expand button should be added to this node; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.SetExpanded Method

DiagramNode.SetExpanded Method

DiagramItem.SetExpanded override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SetExpanded (
bool e
)
Visual Basic

Protected Overridable Sub SetExpanded ( _
e As Boolean _
)

Parameters

e
Specifies the new state of the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.SetExpandedFlag Method

DiagramNode.SetExpandedFlag Method

Sets the 'expanded' flag, repainting the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SetExpandedFlag (
bool newState
)
Visual Basic

Public Sub SetExpandedFlag ( _
newState As Boolean _
)

Parameters

newState
Specifies the new state of the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.SetIncomingLinks Method

DiagramNode.SetIncomingLinks Method

Sets the incoming links collection of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void SetIncomingLinks (
DiagramLinkCollection links
)
Visual Basic

Protected Sub SetIncomingLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection containing the node's incoming links.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.SetOutgoingLinks Method

DiagramNode.SetOutgoingLinks Method

Sets the outgoing links collection of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void SetOutgoingLinks (
DiagramLinkCollection links
)
Visual Basic

Protected Sub SetOutgoingLinks ( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection containing the node's outgoing links.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.SetRect Method

DiagramNode.SetRect Method

This method is used internally by the Ruler control to align nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SetRect (
RectangleF rect,
bool raiseModfEvent
)
Visual Basic

Public Sub SetRect ( _
rect As RectangleF, _
raiseModfEvent As Boolean _
)

Parameters

rect
The new location of the node.
raiseModfEvent
A flag specifying whether to raise the NodeModified event.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.SetReference Method

DiagramNode.SetReference Method

Called during deserialization, after all objects have been instantiated, in order to update the references between them.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SetReference (
int refId,
Object obj,
PersistContext ctx
)
Visual Basic

Protected Overridable Sub SetReference ( _
refId As Integer, _
obj As Object, _
ctx As PersistContext _
)

Parameters

refId
Reference identifier.
obj
The newly loaded object.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is called for references that had been saved using the SaveReference method.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.SetReflexive Method

DiagramNode.SetReflexive Method

Invoked to let a node set the shape of a reflexive link connected to it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SetReflexive (
DiagramLink link
)
Visual Basic

Protected Overridable Sub SetReflexive ( _
link As DiagramLink _
)

Parameters

link
Reference to the link.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.ShouldRenderAnchors Method

DiagramNode.ShouldRenderAnchors Method

Determines whether the node should render its anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected bool ShouldRenderAnchors (
RenderOptions options
)
Visual Basic

Protected Function ShouldRenderAnchors ( _
options As RenderOptions _
) As Boolean

Parameters

options
A RenderOptions object providing more information about the current drawing context.

Return Value

true if anchor points should be rendered; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.StartCreate Method

DiagramNode.StartCreate Method

DiagramItem.StartCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void StartCreate (
PointF org
)
Visual Basic

Protected Overridable Sub StartCreate ( _
org As PointF _
)

Parameters

org
Position of the mouse pointer.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.StartModify Method

DiagramNode.StartModify Method

DiagramItem.StartModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void StartModify (
PointF org,
int handle,
InteractionState ist
)
Visual Basic

Protected Overridable Sub StartModify ( _
org As PointF, _
handle As Integer, _
ist As InteractionState _
)

Parameters

org
Position of the mouse pointer.
handle
Index of the adjustment handle used to modify the node.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.UpdateCreate Method

DiagramNode.UpdateCreate Method

DiagramItem.UpdateCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void UpdateCreate (
PointF current
)
Visual Basic

Protected Overridable Sub UpdateCreate ( _
current As PointF _
)

Parameters

current
Position of the mouse pointer.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.UpdateLinkIntersections Method

DiagramNode.UpdateLinkIntersections Method

Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void UpdateLinkIntersections ()
Visual Basic

Protected Sub UpdateLinkIntersections ()

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.UpdateLinkPositions Method

DiagramNode.UpdateLinkPositions Method

Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void UpdateLinkPositions ()
Visual Basic

Protected Sub UpdateLinkPositions ()

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.UpdateModify Method

DiagramNode.UpdateModify Method

DiagramItem.UpdateModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void UpdateModify (
PointF current,
InteractionState ist
)
Visual Basic

Protected Overridable Sub UpdateModify ( _
current As PointF, _
ist As InteractionState _
)

Parameters

current
Position of the mouse pointer.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode Properties

DiagramNode Properties

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node.
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node.
Bounds | Gets or sets the rectangle that defines the position of the diagram node.
Constraints | Allows applying constraints to the location and size of the node.
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like.
IncomingLinks | Gets a collection of links that point to the node.
MasterGroup | Gets a reference to the group to which this node is attached.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
OutgoingLinks | Gets a collection of links that start from this node.

See Also

DiagramNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNode.AllowIncomingLinks Property

DiagramNode.AllowIncomingLinks Property

Gets or sets a value indicating whether users are allowed to draw incoming links to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowIncomingLinks { get; set; }
Visual Basic

Public Property AllowIncomingLinks As Boolean

Property Value

true to let users draw incoming links to this node; otherwise, false. The default is true.

Remarks

Links to a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
IncomingLinks Property
AllowOutgoingLinks Property


MindFusion.Diagramming.DiagramNode.AllowOutgoingLinks Property

DiagramNode.AllowOutgoingLinks Property

Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowOutgoingLinks { get; set; }
Visual Basic

Public Property AllowOutgoingLinks As Boolean

Property Value

true to let users draw outgoing links from this node; otherwise, false. The default is true.

Remarks

Links from a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
OutgoingLinks Property
AllowIncomingLinks Property


MindFusion.Diagramming.DiagramNode.AnchorPattern Property

DiagramNode.AnchorPattern Property

Gets or sets the anchor points to which links are attached when connected to the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPattern AnchorPattern { get; set; }
Visual Basic

Public Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

This property specifies a set of points to which links can be attached. Each anchor point can accept either incoming links, outgoing links or both. If a node does not have any anchor points defined, links can be connected to any part of the node.

A ShapeNode whose AnchorPattern is not explicitly set uses the AnchorPattern from the Shape definition.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Diagram.SnapToAnchor Property
ReassignAnchorPoints Method


MindFusion.Diagramming.DiagramNode.Bounds Property

DiagramNode.Bounds Property

Gets or sets the rectangle that defines the position of the diagram node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF Bounds { get; set; }
Visual Basic

Public Property Bounds As RectangleF

Property Value

An instance of the.NET RectangleF structure.

Remarks

Use this property to set or get the size and/or location of a node. Moving a node also updates the control points coordinates of all links connected to the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Move Method
Resize Method
Intersects Method


MindFusion.Diagramming.DiagramNode.Constraints Property

DiagramNode.Constraints Property

Allows applying constraints to the location and size of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public NodeConstraints Constraints { get; set; }
Visual Basic

Public Property Constraints As NodeConstraints

Property Value

An instance of the NodeConstraints class.

Remarks

These constraints are considered when a user modifies the node interactively. They are ignored if node placement is changed programmatically by using methods and properties.

Example

This sample code disables moving or resizing a node vertically:

C#

DiagramNode node = diagram.ActiveItem as DiagramNode;

// Allow moving the node only horizontally
node.Constraints.MoveDirection = DirectionConstraint.Horizontal;

// Disable handles that can be used to resize the node vertically
node.EnabledHandles = AdjustmentHandles.Move |
AdjustmentHandles.ResizeMiddleLeft | AdjustmentHandles.ResizeMiddleRight;
Visual Basic

Dim node As DiagramNode = diagram.ActiveItem

' Allow moving the node only horizontally
node.Constraints.MoveDirection = DirectionConstraint.Horizontal

' Disable handles that can be used to resize the node vertically
node.EnabledHandles = AdjustmentHandles.Move + _
AdjustmentHandles.ResizeMiddleLeft + AdjustmentHandles.ResizeMiddleRight

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
EnabledHandles Property


MindFusion.Diagramming.DiagramNode.EnabledHandles Property

DiagramNode.EnabledHandles Property

Gets or sets the kinds of modifications that end-users are permitted to perform on the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AdjustmentHandles EnabledHandles { get; set; }
Visual Basic

Public Property EnabledHandles As AdjustmentHandles

Property Value

A combination of the AdjustmentHandles enumeration members. The default is AdjustmentHandles.All.

Remarks

Disabling some selection handles allows restricting the types of modifications that users can perform on a node. Each manipulation handle can be enabled or disabled by setting or clearing the respective flag in the combination.

For example, to make a node resizable only horizontally, set this property to a combination of the Move, ResizeMiddleLeft and ResizeMiddleRight flags. That will disable all manipulation handles, except the left and right ones, which allow horizontal resizing, and the central one allowing movement of the node.

Example

The following code disables the rotation handle of a shape node:

C#

node.EnabledHandles = AdjustmentHandles.All & ~ AdjustmentHandles.Rotate;
Visual Basic

node.EnabledHandles = AdjustmentHandles.All And Not AdjustmentHandles.Rotate

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Constraints Property
DiagramView.ModificationStart Property
Diagram.DisabledHandlesColor Property
Diagram.ShowDisabledHandles Property


MindFusion.Diagramming.DiagramNode.Expandable Property

DiagramNode.Expandable Property

Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Expandable { get; set; }
Visual Basic

Public Property Expandable As Boolean

Property Value

true if users are allowed to expand / collapse the tree starting from this node; otherwise, false. The default is false.

Remarks

This property is useful mostly when nodes form a tree-like hierarchical structure. If it is enabled, a small [±] button is drawn beside the node. Clicking that button either shows or hides all children of this node in the tree. It depends on the diagram's ExpandOnIncoming property which items connected to a node are considered its children. The tree expansion continues recursively down the child nodes if the RecursiveExpand property is enabled.

A tree can be collapsed or expanded programmatically by invoking the Collapse or Expand methods on the tree root node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Expanded Property
Diagram.NodesExpandable Property
HtmlBuilder.ExpandBtnHyperLink Property


MindFusion.Diagramming.DiagramNode.Expanded Property

DiagramNode.Expanded Property

Gets or sets a value indicating whether the subtree starting from this node is expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Expanded { get; set; }
Visual Basic

Public Overridable Property Expanded As Boolean

Property Value

true if the tree starting from this node is expanded; otherwise, false.

Remarks

This property is useful mostly when nodes form a tree-like hierarchical structure. Set it to false to make the subtree starting from a node collapse, with all its child nodes and links becoming invisible. Set it to true to show the child nodes and links again.

A user is allowed to expand or collapse the tree that starts from a node interactively if the Expandable property of that node is enabled.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
Expandable Property
Expand Method


MindFusion.Diagramming.DiagramNode.HandlesStyle Property

DiagramNode.HandlesStyle Property

Gets or sets a value indicating how the node adjustment handles behave and what do they look like.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public HandlesStyle HandlesStyle { get; set; }
Visual Basic

Public Property HandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration.

Remarks

Specifies how node selection status is indicated visually. In addition, this property defines how manipulation of the node can be done, that is, how to move it, resize it or link it to other nodes. You can assign any of the HandlesStyle values to this property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
ShapeHandlesStyle Property
HitTestHandle Method


MindFusion.Diagramming.DiagramNode.IncomingLinks Property

DiagramNode.IncomingLinks Property

Gets a collection of links that point to the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLinkCollection IncomingLinks { get; }
Visual Basic

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

A reference to a DiagramLinkCollection object.

Remarks

Use this collection to get access to every link pointing to the node, as well as get the number of such links. If the node is a table, links that connect to it as a whole entity are included in the collection, and links that connect to particular row of the table are included in IncomingLinks.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
AllowIncomingLinks Property
OutgoingLinks Property
TableNode.ConnectionStyle Property


MindFusion.Diagramming.DiagramNode.MasterGroup Property

DiagramNode.MasterGroup Property

Gets a reference to the group to which this node is attached.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Group MasterGroup { get; }
Visual Basic

Public ReadOnly Property MasterGroup As Group

Property Value

A reference to a Group object or null (Nothing in Visual Basic) if the node is not attached to a group.

Remarks

Diagram items can be grouped hierarchically in such a manner, that if an item is moved all of its subordinated items in the hierarchy move too. The immediate subordinates of an item are contained and represented by a Group instance. This property provides access to the group that contains the item as a subordinate. If the item is not a subordinate of another, the property returns null (Nothing in Visual Basic).

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
SubordinateGroup Property
Factory.CreateGroup Method


MindFusion.Diagramming.DiagramNode.Obstacle Property

DiagramNode.Obstacle Property

Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Obstacle { get; set; }
Visual Basic

Public Property Obstacle As Boolean

Property Value

true makes routed links look for a path going around this node; false lets links cross the node. The default is true.

Remarks

It is useful to set this property to false for nodes used as decorative containers or labels.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
DiagramLink.AutoRoute Property
Diagram.RouteAllLinks Method


MindFusion.Diagramming.DiagramNode.OutgoingLinks Property

DiagramNode.OutgoingLinks Property

Gets a collection of links that start from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLinkCollection OutgoingLinks { get; }
Visual Basic

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

A reference to a DiagramLinkCollection object.

Remarks

Use this collection to get access to every link starting from the node, as well as get the number of such links. If the node is a table, links that connect to it as a whole entity are included in the collection, and links that connect to particular row of the table are included in OutgoingLinks.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming Namespace
AllowOutgoingLinks Property
IncomingLinks Property
TableNode.ConnectionStyle Property


MindFusion.Diagramming.DiagramNodeCollection Class

DiagramNodeCollection Class

Represents a strongly typed collection of diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DiagramNodeCollection : ItemCollectionBase
Visual Basic

Public Class DiagramNodeCollection
Inherits ItemCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.PersistableCollection
MindFusion.Diagramming.ItemCollectionBase
MindFusion.Diagramming.DiagramNodeCollection

See Also

DiagramNodeCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeCollection Members

DiagramNodeCollection Members
Constructors Properties Methods

Represents a strongly typed collection of diagram nodes.

The following tables list the members exposed by the DiagramNodeCollection type.

Public Constructors

Name | Description
DiagramNodeCollection | Initializes a new instance of the DiagramNodeCollection class.

Public Properties

Name | Description
Item | Gets or sets the node at the specified position.

Public Methods

Name | Description
Add | Adds the specified node to the collection.
Clone | Creates a shallow copy of this collection.
Contains | Checks whether the specified node is contained within the collection.
GetAt | Gets the node at the specified position.
IndexOf | Searches for the specified node and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts the specified node into the collection at the specified position.
Remove | Removes the specified node from the collection.

See Also

DiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeCollection Constructor

DiagramNodeCollection Constructor

Initializes a new instance of the DiagramNodeCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNodeCollection ()
Visual Basic

Public Sub New ()

See Also

DiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeCollection Methods

DiagramNodeCollection Methods

Public Methods

Name | Description
Add | Adds the specified node to the collection.
Clone | Creates a shallow copy of this collection.
Contains | Checks whether the specified node is contained within the collection.
GetAt | Gets the node at the specified position.
IndexOf | Searches for the specified node and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts the specified node into the collection at the specified position.
Remove | Removes the specified node from the collection.

See Also

DiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeCollection.Add Method

DiagramNodeCollection.Add Method

Adds the specified node to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Add (
DiagramNode node
)
Visual Basic

Public Sub Add ( _
node As DiagramNode _
)

Parameters

node

The DiagramNode object to add to the collection.

Remarks

The DiagramNode object to add to the collection.

See Also

DiagramNodeCollection Members
DiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeCollection.Clone Method

DiagramNodeCollection.Clone Method

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNodeCollection Clone ()
Visual Basic

Public Function Clone () As DiagramNodeCollection

Return Value

An instance of the DiagramNodeCollection class.

See Also

DiagramNodeCollection Members
DiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeCollection.Contains Method

DiagramNodeCollection.Contains Method

Checks whether the specified node is contained within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Contains (
DiagramNode node
)
Visual Basic

Public Function Contains ( _
node As DiagramNode _
) As Boolean

Parameters

node

The DiagramNode object to search for in the collection.

Return Value

true if the specified node was found in the collection; otherwise, false.

See Also

DiagramNodeCollection Members
DiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeCollection.GetAt Method

DiagramNodeCollection.GetAt Method

Gets the node at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode GetAt (
int index
)
Visual Basic

Public Function GetAt ( _
index As Integer _
) As DiagramNode

Parameters

index

The zero-based index of the node to retreive.

Return Value

An instance of the DiagramNode class that represents the node at the specified position.

See Also

DiagramNodeCollection Members
DiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeCollection.IndexOf Method

DiagramNodeCollection.IndexOf Method

Searches for the specified node and returns the zero-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int IndexOf (
DiagramNode node
)
Visual Basic

Public Function IndexOf ( _
node As DiagramNode _
) As Integer

Parameters

node
The node to locate in the collection.

Return Value

The zero-based index of the first occurrence of node within the entire collection, if found; otherwise, -1.

See Also

DiagramNodeCollection Members
DiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeCollection.Insert Method

DiagramNodeCollection.Insert Method

Inserts the specified node into the collection at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Insert (
int index,
DiagramNode node
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
node As DiagramNode _
)

Parameters

index

The zero-based index at which to insert the node.

node

The DiagramNode object to add to the collection.

See Also

DiagramNodeCollection Members
DiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeCollection.Remove Method

DiagramNodeCollection.Remove Method

Removes the specified node from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Remove (
DiagramNode node
)
Visual Basic

Public Sub Remove ( _
node As DiagramNode _
)

Parameters

node

The DiagramNode object to remove from the collection.

See Also

DiagramNodeCollection Members
DiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeCollection Properties

DiagramNodeCollection Properties

Public Properties

Name | Description
Item | Gets or sets the node at the specified position.

See Also

DiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeCollection.Item Property

DiagramNodeCollection.Item Property

Gets or sets the node at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As DiagramNode

Parameters

index

The zero-based index of the node to set or retrieve.

Property Value

An instance of the DiagramNode class that represents the node at the specified position.

See Also

DiagramNodeCollection Members
DiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeProperties Class

DiagramNodeProperties Class

The base class for classes that store the properties for a DiagramNode-derived items during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DiagramNodeProperties : DiagramItemProperties
Visual Basic

Public Class DiagramNodeProperties
Inherits DiagramItemProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.ContainerNodeProperties
MindFusion.Diagramming.ShapeNodeProperties
MindFusion.Diagramming.TableNodeProperties
MindFusion.Diagramming.WinForms.ControlNodeProperties

See Also

DiagramNodeProperties Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeProperties Members

DiagramNodeProperties Members
Constructors

The base class for classes that store the properties for a DiagramNode-derived items during undo / redo operations.

The following tables list the members exposed by the DiagramNodeProperties type.

Public Constructors

Name | Description
DiagramNodeProperties | Initializes a new instance of the DiagramNodeProperties class.

See Also

DiagramNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DiagramNodeProperties Constructor

DiagramNodeProperties Constructor

Initializes a new instance of the DiagramNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNodeProperties ()
Visual Basic

Public Sub New ()

See Also

DiagramNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DirectionConstraint Enumeration

DirectionConstraint Enumeration

Defines values that specify in what direction to constrain node movement.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum DirectionConstraint
Visual Basic

Public Enumeration DirectionConstraint

Members

Member name | Description
Horizontal | Users are allowed to move the node horizontally.
None | No restrictions.
Vertical | Users are allowed to move the node vertically.

Remarks

Values from this enumeration can be assigned to the MoveDirection property of the NodeConstraints class.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.DraggedShape Class

DraggedShape Class

Contains drag-and-drop information for a shape being dragged from ShapeToolBar and ShapeListBox.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DraggedShape
Visual Basic

Public Class DraggedShape

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DraggedShape

See Also

DraggedShape Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DraggedShape Members

DraggedShape Members
Constructors Properties

Contains drag-and-drop information for a shape being dragged from ShapeToolBar and ShapeListBox.

The following tables list the members exposed by the DraggedShape type.

Public Constructors

Name | Description
DraggedShape | Initializes a new instance of the DraggedShape class.

Public Properties

Name | Description
Id | Gets the Id of the dragged shape.
Size | Gets the recommended size of the dragged shape.

See Also

DraggedShape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DraggedShape Constructor

DraggedShape Constructor

Initializes a new instance of the DraggedShape class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DraggedShape (
string id,
SizeF size
)
Visual Basic

Public New ( _
id As String, _
size As SizeF _
)

Parameters

id

The Id of the dragged shape.

size
The recommended size of the dragged shape.

See Also

DraggedShape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DraggedShape Properties

DraggedShape Properties

Public Properties

Name | Description
Id | Gets the Id of the dragged shape.
Size | Gets the recommended size of the dragged shape.

See Also

DraggedShape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DraggedShape.Id Property

DraggedShape.Id Property

Gets the Id of the dragged shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string Id { get; }
Visual Basic

Public ReadOnly Property Id As String

Property Value

A string specifying the identifier of the dragged shape.

See Also

DraggedShape Members
DraggedShape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DraggedShape.Size Property

DraggedShape.Size Property

Gets the recommended size of the dragged shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeF Size { get; }
Visual Basic

Public ReadOnly Property Size As SizeF

Property Value

A .NET SizeF object specifying the recommended size for the shape.

See Also

DraggedShape Members
DraggedShape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawAnchorPointEventArgs Class

DrawAnchorPointEventArgs Class

Contains the arguments passed to the DrawAnchorPoint event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DrawAnchorPointEventArgs : EventArgs
Visual Basic

Public Class DrawAnchorPointEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawAnchorPointEventArgs

See Also

DrawAnchorPointEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawAnchorPointEventArgs Members

DrawAnchorPointEventArgs Members
Constructors Properties

Contains the arguments passed to the DrawAnchorPoint event handlers.

The following tables list the members exposed by the DrawAnchorPointEventArgs type.

Public Constructors

Name | Description
DrawAnchorPointEventArgs | Initializes a new instance of the DrawAnchorPointEventArgs class.

Public Properties

Name | Description
AnchorIndex | Gets the index of the anchor point within its containing pattern.
AnchorPattern | Gets the anchor pattern containing the anchor point being drawn.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the anchor point mark.
Location | Gets the location of the anchor point being drawn.
Node | Gets the node whose anchor point is being drawn.

See Also

DrawAnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawAnchorPointEventArgs Constructor

DrawAnchorPointEventArgs Constructor

Initializes a new instance of the DrawAnchorPointEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DrawAnchorPointEventArgs (
IGraphics graphics,
PointF location,
DiagramNode node,
AnchorPattern anchorPattern,
int anchorIndex
)
Visual Basic

Public Sub DrawAnchorPointEventArgs ( _
graphics As IGraphics, _
location As PointF, _
node As DiagramNode, _
anchorPattern As AnchorPattern, _
anchorIndex As Integer _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

location

The position of the anchor point, expressed in document coordinates.

node

The DiagramNode related to the event.

anchorPattern

The AnchorPattern object whose point is being drawn.

anchorIndex

The zero-based index of the anchor point being drawn within its anchor pattern.

See Also

DrawAnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawAnchorPointEventArgs Properties

DrawAnchorPointEventArgs Properties

Public Properties

Name | Description
AnchorIndex | Gets the index of the anchor point within its containing pattern.
AnchorPattern | Gets the anchor pattern containing the anchor point being drawn.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the anchor point mark.
Location | Gets the location of the anchor point being drawn.
Node | Gets the node whose anchor point is being drawn.

See Also

DrawAnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawAnchorPointEventArgs.AnchorIndex Property

DrawAnchorPointEventArgs.AnchorIndex Property

Gets the index of the anchor point within its containing pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int AnchorIndex { get; }
Visual Basic

Public ReadOnly Property AnchorIndex As Integer

Property Value

An integer value specifying the zero-based index of the anchor point within its AnchorPattern.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawAnchorPointEventArgs.AnchorPattern Property

DrawAnchorPointEventArgs.AnchorPattern Property

Gets the anchor pattern containing the anchor point being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPattern AnchorPattern { get; }
Visual Basic

Public ReadOnly Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawAnchorPointEventArgs.Graphics Property

DrawAnchorPointEventArgs.Graphics Property

Gets an object implementing the IGraphics interface whose methods should be used to draw the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public IGraphics Graphics { get; }
Visual Basic

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawAnchorPointEventArgs.Location Property

DrawAnchorPointEventArgs.Location Property

Gets the location of the anchor point being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF Location { get; }
Visual Basic

Public ReadOnly Property Location As PointF

Property Value

A .NET PointF specifying the location of the anchor point.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawAnchorPointEventArgs.Node Property

DrawAnchorPointEventArgs.Node Property

Gets the node whose anchor point is being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Node { get; }
Visual Basic

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawAnchorPointEventHandler Delegate

DrawAnchorPointEventHandler Delegate

Represents methods that will handle anchor-related custom-drawing events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void DrawAnchorPointEventHandler (
Object sender,
DrawAnchorPointEventArgs e
)
Visual Basic

Public Delegate Sub DrawAnchorPointEventHandler ( _
sender As Object, _
e As DrawAnchorPointEventArgs _
)

Parameters

sender

The source of the event.

e

A DrawAnchorPointEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawCellEventArgs Class

DrawCellEventArgs Class

Contains the arguments passed to the DrawCell event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DrawCellEventArgs : EventArgs
Visual Basic

Public Class DrawCellEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawCellEventArgs

See Also

DrawCellEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawCellEventArgs Members

DrawCellEventArgs Members
Constructors Properties

Contains the arguments passed to the DrawCell event handlers.

The following tables list the members exposed by the DrawCellEventArgs type.

Public Constructors

Name | Description
DrawCellEventArgs | Initializes a new instance of the DrawCellEventArgs class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the cell being drawn.
Cell | Gets the cell that should be custom drawn.
Column | Gets the index of the table's column that contains Cell.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the cell.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

DrawCellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawCellEventArgs Constructor

DrawCellEventArgs Constructor

Initializes a new instance of the DrawCellEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DrawCellEventArgs (
IGraphics graphics,
TableNode table,
int column,
int row,
RectangleF bounds
)
Visual Basic

Public Sub DrawCellEventArgs ( _
graphics As IGraphics, _
table As TableNode, _
column As Integer, _
row As Integer, _
bounds As RectangleF _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

table

The TableNode related to the event.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

bounds

The bounding rectangle of the cell being drawn.

See Also

DrawCellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawCellEventArgs Properties

DrawCellEventArgs Properties

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the cell being drawn.
Cell | Gets the cell that should be custom drawn.
Column | Gets the index of the table's column that contains Cell.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the cell.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

DrawCellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawCellEventArgs.Bounds Property

DrawCellEventArgs.Bounds Property

Gets the bounding rectangle of the cell being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As RectangleF

Property Value

A .NET RectangleF specifying the bounding rectangle of the cell.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawCellEventArgs.Cell Property

DrawCellEventArgs.Cell Property

Gets the cell that should be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Cell Cell { get; }
Visual Basic

Public ReadOnly Property Cell As TableNode.Cell

Property Value

An instance of the TableNode.Cell class.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawCellEventArgs.Column Property

DrawCellEventArgs.Column Property

Gets the index of the table's column that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Column { get; }
Visual Basic

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the column.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawCellEventArgs.Graphics Property

DrawCellEventArgs.Graphics Property

An object implementing the IGraphics interface whose methods should be used to draw the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public IGraphics Graphics { get; }
Visual Basic

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawCellEventArgs.Row Property

DrawCellEventArgs.Row Property

Gets the index of the table's row that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Row { get; }
Visual Basic

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the row.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawCellEventArgs.Table Property

DrawCellEventArgs.Table Property

Get the table that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode Table { get; }
Visual Basic

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawCellEventHandler Delegate

DrawCellEventHandler Delegate

Represents methods that will handle table cell-related custom-drawing events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void DrawCellEventHandler (
Object sender,
DrawCellEventArgs e
)
Visual Basic

Public Delegate Sub DrawCellEventHandler ( _
sender As Object, _
e As DrawCellEventArgs _
)

Parameters

sender

The source of the event.

e

A DrawCellEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawItemEventArgs Class

DrawItemEventArgs Class

Contains the arguments passed to the DrawAdjustmentHandles event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DrawItemEventArgs : EventArgs
Visual Basic

Public Class DrawItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawItemEventArgs

See Also

DrawItemEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawItemEventArgs Members

DrawItemEventArgs Members
Constructors Properties

Contains the arguments passed to the DrawAdjustmentHandles event handlers.

The following tables list the members exposed by the DrawItemEventArgs type.

Public Constructors

Name | Description
DrawItemEventArgs | Initializes a new instance of the DrawItemEventArgs class.

Public Properties

Name | Description
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the adjustment handles.
Item | Gets the item whose selection handles are being drawn.

See Also

DrawItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawItemEventArgs Constructor

DrawItemEventArgs Constructor

Initializes a new instance of the DrawItemEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DrawItemEventArgs (
IGraphics graphics,
DiagramItem item
)
Visual Basic

Public Sub DrawItemEventArgs ( _
graphics As IGraphics, _
item As DiagramItem _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

item

The DiagramItem related to the event.

See Also

DrawItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawItemEventArgs Properties

DrawItemEventArgs Properties

Public Properties

Name | Description
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the adjustment handles.
Item | Gets the item whose selection handles are being drawn.

See Also

DrawItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawItemEventArgs.Graphics Property

DrawItemEventArgs.Graphics Property

Gets an object implementing the IGraphics interface whose methods should be used to draw the adjustment handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public IGraphics Graphics { get; }
Visual Basic

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawItemEventArgs Members
DrawItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawItemEventArgs.Item Property

DrawItemEventArgs.Item Property

Gets the item whose selection handles are being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; }
Visual Basic

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

DrawItemEventArgs Members
DrawItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawItemEventHandler Delegate

DrawItemEventHandler Delegate

Represents methods that will handle item-related custom-drawing events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void DrawItemEventHandler (
Object sender,
DrawItemEventArgs e
)
Visual Basic

Public Delegate Sub DrawItemEventHandler ( _
sender As Object, _
e As DrawItemEventArgs _
)

Parameters

sender

The source of the event.

e
A DrawItemEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawLinkEventArgs Class

DrawLinkEventArgs Class

Contains the arguments passed to the DrawLink event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DrawLinkEventArgs : EventArgs
Visual Basic

Public Class DrawLinkEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawLinkEventArgs

See Also

DrawLinkEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawLinkEventArgs Members

DrawLinkEventArgs Members
Constructors Properties

Contains the arguments passed to the DrawLink event handlers.

The following tables list the members exposed by the DrawLinkEventArgs type.

Public Constructors

Name | Description
DrawLinkEventArgs | Initializes a new instance of the DrawLinkEventArgs class.

Public Properties

Name | Description
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the link.
Link | Gets the DiagramLink object that should be custom drawn.
Points | Gets a collection of the link's control points.
Shadow | Gets a value indicating whether the event is raised to draw the link's shadow.

See Also

DrawLinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawLinkEventArgs Constructor

DrawLinkEventArgs Constructor

Initializes a new instance of the DrawLinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DrawLinkEventArgs (
IGraphics graphics,
DiagramLink link,
bool shadow,
PointCollection points
)
Visual Basic

Public Sub DrawLinkEventArgs ( _
graphics As IGraphics, _
link As DiagramLink, _
shadow As Boolean, _
points As PointCollection _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

link

The DiagramLink related to the event.

shadow

Specifies whether to draw the link's shadow or the link itself.

points

The collection containing the coordinates of the link control points, pretranslated depending on whether drawing the shadow or not.

See Also

DrawLinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawLinkEventArgs Properties

DrawLinkEventArgs Properties

Public Properties

Name | Description
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the link.
Link | Gets the DiagramLink object that should be custom drawn.
Points | Gets a collection of the link's control points.
Shadow | Gets a value indicating whether the event is raised to draw the link's shadow.

See Also

DrawLinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawLinkEventArgs.Graphics Property

DrawLinkEventArgs.Graphics Property

Gets an object implementing the IGraphics interface whose methods should be used to draw the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public IGraphics Graphics { get; }
Visual Basic

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawLinkEventArgs.Link Property

DrawLinkEventArgs.Link Property

Gets the DiagramLink object that should be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink Link { get; }
Visual Basic

Public ReadOnly Property Link As DiagramLink

Property Value

An instance of the DiagramLink class.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawLinkEventArgs.Points Property

DrawLinkEventArgs.Points Property

Gets a collection of the link's control points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointCollection Points { get; }
Visual Basic

Public ReadOnly Property Points As PointCollection

Property Value

An instance of the PointCollection class.

Remarks

When drawing shadows, the points are offset as necessary.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawLinkEventArgs.Shadow Property

DrawLinkEventArgs.Shadow Property

Gets a value indicating whether the event is raised to draw the link's shadow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Shadow { get; }
Visual Basic

Public ReadOnly Property Shadow As Boolean

Property Value

true if now drawing the link's shadow; otherwise, false.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawLinkEventHandler Delegate

DrawLinkEventHandler Delegate

Represents methods that will handle link-related custom-drawing events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void DrawLinkEventHandler (
Object sender,
DrawLinkEventArgs e
)
Visual Basic

Public Delegate Sub DrawLinkEventHandler ( _
sender As Object, _
e As DrawLinkEventArgs _
)

Parameters

sender

The source of the event.

e

A DrawLinkEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawNodeEventArgs Class

DrawNodeEventArgs Class

Contains the arguments passed to the DrawNode event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DrawNodeEventArgs : EventArgs
Visual Basic

Public Class DrawNodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawNodeEventArgs

See Also

DrawNodeEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawNodeEventArgs Members

DrawNodeEventArgs Members
Constructors Properties

Contains the arguments passed to the DrawNode event handlers.

The following tables list the members exposed by the DrawNodeEventArgs type.

Public Constructors

Name | Description
DrawNodeEventArgs | Initializes a new instance of the DrawNodeEventArgs class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the node being drawn.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the node.
Node | Gets the DiagramNode object that should be custom drawn.
Shadow | Gets a value indicating whether the event is raised to draw the node's shadow.

See Also

DrawNodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawNodeEventArgs Constructor

DrawNodeEventArgs Constructor

Initializes a new instance of the DrawNodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DrawNodeEventArgs (
IGraphics graphics,
DiagramNode node,
bool shadow,
RectangleF bounds
)
Visual Basic

Public Sub DrawNodeEventArgs ( _
graphics As IGraphics, _
node As DiagramNode, _
shadow As Boolean, _
bounds As RectangleF _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

node

The DiagramNode related to the event.

shadow

Specifies whether to draw the node's shadow or the node itself.

bounds

The bounding rectangle of the node being drawn.

See Also

DrawNodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawNodeEventArgs Properties

DrawNodeEventArgs Properties

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the node being drawn.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the node.
Node | Gets the DiagramNode object that should be custom drawn.
Shadow | Gets a value indicating whether the event is raised to draw the node's shadow.

See Also

DrawNodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawNodeEventArgs.Bounds Property

DrawNodeEventArgs.Bounds Property

Gets the bounding rectangle of the node being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As RectangleF

Property Value

A .NET RectangleF instance specifying the bounding rectangle of the node being drawn.

Remarks

When drawing shadows, the rectangle is offset as necessary.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawNodeEventArgs.Graphics Property

DrawNodeEventArgs.Graphics Property

Gets an object implementing the IGraphics interface whose methods should be used to draw the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public IGraphics Graphics { get; }
Visual Basic

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawNodeEventArgs.Node Property

DrawNodeEventArgs.Node Property

Gets the DiagramNode object that should be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Node { get; }
Visual Basic

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawNodeEventArgs.Shadow Property

DrawNodeEventArgs.Shadow Property

Gets a value indicating whether the event is raised to draw the node's shadow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Shadow { get; }
Visual Basic

Public ReadOnly Property Shadow As Boolean

Property Value

true if now drawing the node's shadow; otherwise, false.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DrawNodeEventHandler Delegate

DrawNodeEventHandler Delegate

Represents methods that will handle node-related custom-drawing events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void DrawNodeEventHandler (
Object sender,
DrawNodeEventArgs e
)
Visual Basic

Public Delegate Sub DrawNodeEventHandler ( _
sender As Object, _
e As DrawNodeEventArgs _
)

Parameters

sender

The source of the event.

e

A DrawNodeEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.DummyNode Class

DummyNode Class

Represents virtual nodes used for disconnected links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class DummyNode : DiagramNode
Visual Basic

Public Class DummyNode
Inherits DiagramNode

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.DummyNode

See Also

DummyNode Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DummyNode Members

DummyNode Members
Constructors Methods

Represents virtual nodes used for disconnected links.

The following tables list the members exposed by the DummyNode type.

Public Constructors

Name | Description
DummyNode | Initializes a new instance of the DummyNode class.

Public Methods

Name | Description
ContainsPoint | DiagramItem.ContainsPoint override.
Draw | DiagramItem.Draw override.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | DiagramItem.DrawShadow override.
GetIntersection | DiagramNode.GetIntersection override.
HitTestHandle | DiagramItem.HitTestHandle override.

Protected Methods

Name | Description
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.

See Also

DummyNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DummyNode Constructor

DummyNode Constructor

Initializes a new instance of the DummyNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DummyNode (
Diagram parent
)
Visual Basic

Public Sub DummyNode ( _
parent As Diagram _
)

Parameters

parent

The Diagram this node will be associated with.

See Also

DummyNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DummyNode Methods

DummyNode Methods

Public Methods

Name | Description
ContainsPoint | DiagramItem.ContainsPoint override.
Draw | DiagramItem.Draw override.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | DiagramItem.DrawShadow override.
GetIntersection | DiagramNode.GetIntersection override.
HitTestHandle | DiagramItem.HitTestHandle override.

Protected Methods

Name | Description
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.

See Also

DummyNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DummyNode.ContainsPoint Method

DummyNode.ContainsPoint Method

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool ContainsPoint (
PointF point
)
Visual Basic

Public Overrides Function ContainsPoint ( _
point As PointF _
) As Boolean

Parameters

point
The point to check.

Return Value

See Also

DummyNode Members
DummyNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DummyNode.CreateConnectionPoint Method

DummyNode.CreateConnectionPoint Method

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
PointF pt,
bool incoming
)
Visual Basic

Protected Overridable Function CreateConnectionPoint ( _
link As DiagramLink, _
pt As PointF, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
pt
incoming

Return Value

See Also

DummyNode Members
DummyNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DummyNode.Draw Method

DummyNode.Draw Method

DiagramItem.Draw override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void Draw (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public Overrides Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
The IGraphics surface to draw the item on.
options
A RenderOptions object specifying options for the drawing operation.

See Also

DummyNode Members
DummyNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DummyNode.DrawHandles Method

DummyNode.DrawHandles Method

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void DrawHandles (
IGraphics graphics,
Color color
)
Visual Basic

Public Overrides Sub DrawHandles ( _
graphics As IGraphics, _
color As Color _
)

Parameters

graphics
color

See Also

DummyNode Members
DummyNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DummyNode.DrawShadow Method

DummyNode.DrawShadow Method

DiagramItem.DrawShadow override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public Overrides Sub DrawShadow ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
The IGraphics surface to draw the shadow on.
options
A RenderOptions object specifying options for the drawing operation.

See Also

DummyNode Members
DummyNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DummyNode.GetIntersection Method

DummyNode.GetIntersection Method

DiagramNode.GetIntersection override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override PointF GetIntersection (
PointF segmentStart,
PointF segmentEnd
)
Visual Basic

Public Overrides Function GetIntersection ( _
segmentStart As PointF, _
segmentEnd As PointF _
) As PointF

Parameters

segmentStart
segmentEnd

Return Value

See Also

DummyNode Members
DummyNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.DummyNode.HitTestHandle Method

DummyNode.HitTestHandle Method

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool HitTestHandle (
PointF pt,
ref int handle
)
Visual Basic

Public Overrides Function HitTestHandle ( _
pt As PointF, _
ByRef handle As Integer _
) As Boolean

Parameters

pt
handle

Return Value

See Also

DummyNode Members
DummyNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditCellTextEventArgs Class

EditCellTextEventArgs Class

Contains the arguments passed to the CellTextEdited event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class EditCellTextEventArgs : EventArgs
Visual Basic

Public Class EditCellTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.EditCellTextEventArgs

See Also

EditCellTextEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditCellTextEventArgs Members

EditCellTextEventArgs Members
Constructors Properties

Contains the arguments passed to the CellTextEdited event handlers.

The following tables list the members exposed by the EditCellTextEventArgs type.

Public Constructors

Name | Description
EditCellTextEventArgs | Initializes a new instance of the EditCellTextEventArgs class.

Public Properties

Name | Description
Cell | Get the cell whose text has been edited.
Column | Gets the index of the table's column that contains Cell.
NewText | Gets the text that has just been entered by the user.
OldText | Gets the text that had been displayed in the cell before the user edited it.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

EditCellTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditCellTextEventArgs Constructor

EditCellTextEventArgs Constructor

Initializes a new instance of the EditCellTextEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public EditCellTextEventArgs (
TableNode.Cell cell,
string oldText,
string newText,
int column,
int row
)
Visual Basic

Public Sub EditCellTextEventArgs ( _
cell As TableNode.Cell, _
oldText As String, _
newText As String, _
column As Integer, _
row As Integer _
)

Parameters

cell

The TableNode.Cell related to the event.

oldText

The old text of the cell.

newText

The new text of the cell.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

See Also

EditCellTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditCellTextEventArgs Properties

EditCellTextEventArgs Properties

Public Properties

Name | Description
Cell | Get the cell whose text has been edited.
Column | Gets the index of the table's column that contains Cell.
NewText | Gets the text that has just been entered by the user.
OldText | Gets the text that had been displayed in the cell before the user edited it.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

EditCellTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditCellTextEventArgs.Cell Property

EditCellTextEventArgs.Cell Property

Get the cell whose text has been edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Cell Cell { get; }
Visual Basic

Public ReadOnly Property Cell As TableNode.Cell

Property Value

An instance of the TableNode.Cell class.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditCellTextEventArgs.Column Property

EditCellTextEventArgs.Column Property

Gets the index of the table's column that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Column { get; }
Visual Basic

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the column.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditCellTextEventArgs.NewText Property

EditCellTextEventArgs.NewText Property

Gets the text that has just been entered by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string NewText { get; }
Visual Basic

Public ReadOnly Property NewText As String

Property Value

A string specifying the new text of the cell.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditCellTextEventArgs.OldText Property

EditCellTextEventArgs.OldText Property

Gets the text that had been displayed in the cell before the user edited it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string OldText { get; }
Visual Basic

Public ReadOnly Property OldText As String

Property Value

A string specifying the old text of the cell.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditCellTextEventArgs.Row Property

EditCellTextEventArgs.Row Property

Gets the index of the table's row that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Row { get; }
Visual Basic

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the row.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditCellTextEventArgs.Table Property

EditCellTextEventArgs.Table Property

Get the table that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode Table { get; }
Visual Basic

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditCellTextEventHandler Delegate

EditCellTextEventHandler Delegate

Represents methods that will handle table cell-related in-place edit events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void EditCellTextEventHandler (
Object sender,
EditCellTextEventArgs e
)
Visual Basic

Public Delegate Sub EditCellTextEventHandler ( _
sender As Object, _
e As EditCellTextEventArgs _
)

Parameters

sender

The source of the event.

e
An EditCellTextEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditLinkTextEventArgs Class

EditLinkTextEventArgs Class

Contains the arguments passed to the EditLinkTextEventHandler event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class EditLinkTextEventArgs : EventArgs
Visual Basic

Public Class EditLinkTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.EditLinkTextEventArgs

See Also

EditLinkTextEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditLinkTextEventArgs Members

EditLinkTextEventArgs Members
Constructors Properties

Contains the arguments passed to the EditLinkTextEventHandler event handlers.

The following tables list the members exposed by the EditLinkTextEventArgs type.

Public Constructors

Name | Description
EditLinkTextEventArgs | Initializes a new instance of the EditLinkTextEventArgs class.

Public Properties

Name | Description
Link | Gets the link whose text was edited.
NewText | Gets the new text.
OldText | Gets the text before in-place editing.

See Also

EditLinkTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditLinkTextEventArgs Constructor

EditLinkTextEventArgs Constructor

Initializes a new instance of the EditLinkTextEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public EditLinkTextEventArgs (
DiagramLink link,
string oldText,
string newText
)
Visual Basic

Public Sub EditLinkTextEventArgs ( _
link As DiagramLink, _
oldText As String, _
newText As String _
)

Parameters

link
The link whose text is edited.
oldText
The old value of the link's Text.
newText
The new value of the link's Text.

See Also

EditLinkTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditLinkTextEventArgs Properties

EditLinkTextEventArgs Properties

Public Properties

Name | Description
Link | Gets the link whose text was edited.
NewText | Gets the new text.
OldText | Gets the text before in-place editing.

See Also

EditLinkTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditLinkTextEventArgs.Link Property

EditLinkTextEventArgs.Link Property

Gets the link whose text was edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink Link { get; }
Visual Basic

Public ReadOnly Property Link As DiagramLink

Property Value

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditLinkTextEventArgs.NewText Property

EditLinkTextEventArgs.NewText Property

Gets the new text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string NewText { get; }
Visual Basic

Public ReadOnly Property NewText As String

Property Value

The new value of the link's Text property.

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class
MindFusion.Diagramming Namespace
OldText Property


MindFusion.Diagramming.EditLinkTextEventArgs.OldText Property

EditLinkTextEventArgs.OldText Property

Gets the text before in-place editing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string OldText { get; }
Visual Basic

Public ReadOnly Property OldText As String

Property Value

The original value of the Text property of the edited link.

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class
MindFusion.Diagramming Namespace
NewText Property


MindFusion.Diagramming.EditLinkTextEventHandler Delegate

EditLinkTextEventHandler Delegate

Represents methods that will handle link in-place edit events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void EditLinkTextEventHandler (
Object sender,
EditLinkTextEventArgs e
)
Visual Basic

Public Delegate Sub EditLinkTextEventHandler ( _
sender As Object, _
e As EditLinkTextEventArgs _
)

Parameters

sender
The source of the event.
e
An EditLinkTextEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditNodeTextEventArgs Class

EditNodeTextEventArgs Class

Contains the arguments passed to the NodeTextEdited event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class EditNodeTextEventArgs : EventArgs
Visual Basic

Public Class EditNodeTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.EditNodeTextEventArgs

See Also

EditNodeTextEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditNodeTextEventArgs Members

EditNodeTextEventArgs Members
Constructors Properties

Contains the arguments passed to the NodeTextEdited event handlers.

The following tables list the members exposed by the EditNodeTextEventArgs type.

Public Constructors

Name | Description
EditNodeTextEventArgs | Initializes a new instance of the EditNodeTextEventArgs class.

Public Properties

Name | Description
NewText | Gets the text that has just been entered by the user.
Node | Gets the node whose text has been edited.
OldText | Gets the text that had been displayed in the node before the user edited it.

See Also

EditNodeTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditNodeTextEventArgs Constructor

EditNodeTextEventArgs Constructor

Initializes a new instance of the EditNodeTextEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public EditNodeTextEventArgs (
DiagramNode node,
string oldText,
string newText
)
Visual Basic

Public Sub EditNodeTextEventArgs ( _
node As DiagramNode, _
oldText As String, _
newText As String _
)

Parameters

node

The DiagramNode related to the event.

oldText

The old text of the node.

newText

The new text of the node.

See Also

EditNodeTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditNodeTextEventArgs Properties

EditNodeTextEventArgs Properties

Public Properties

Name | Description
NewText | Gets the text that has just been entered by the user.
Node | Gets the node whose text has been edited.
OldText | Gets the text that had been displayed in the node before the user edited it.

See Also

EditNodeTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditNodeTextEventArgs.NewText Property

EditNodeTextEventArgs.NewText Property

Gets the text that has just been entered by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string NewText { get; }
Visual Basic

Public ReadOnly Property NewText As String

Property Value

A string specifying the new text of the node.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditNodeTextEventArgs.Node Property

EditNodeTextEventArgs.Node Property

Gets the node whose text has been edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Node { get; }
Visual Basic

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditNodeTextEventArgs.OldText Property

EditNodeTextEventArgs.OldText Property

Gets the text that had been displayed in the node before the user edited it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string OldText { get; }
Visual Basic

Public ReadOnly Property OldText As String

Property Value

A string specifying the old text of the node.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EditNodeTextEventHandler Delegate

EditNodeTextEventHandler Delegate

Represents methods that will handle node in-place edit events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void EditNodeTextEventHandler (
Object sender,
EditNodeTextEventArgs e
)
Visual Basic

Public Delegate Sub EditNodeTextEventHandler ( _
sender As Object, _
e As EditNodeTextEventArgs _
)

Parameters

sender

The source of the event.

e

An EditNodeTextEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.EffectsProvider Class

EffectsProvider Class
Remarks See Also

Provides smooth shadow and emboss effects for MindFusion.Diagramming nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.EffectsProvider

Syntax

C#

public sealed class EffectsProvider : IEffectsProvider
Visual Basic

Public NotInheritable Class EffectsProvider
Implements IEffectsProvider

Remarks

You can assign an instance of this class to the EffectsProvider property of the Diagram class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.EffectsProvider

See Also

EffectsProvider Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EffectsProvider Members

EffectsProvider Members
Constructors

Provides smooth shadow and emboss effects for MindFusion.Diagramming nodes.

The following tables list the members exposed by the EffectsProvider type.

Public Constructors

Name | Description
EffectsProvider | Initializes a new instance of the EffectsProvider class.

See Also

EffectsProvider Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.EffectsProvider Constructor

EffectsProvider Constructor

Initializes a new instance of the EffectsProvider class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming.EffectsProvider

Syntax

C#

public EffectsProvider ()
Visual Basic

Public Sub New ()

See Also

EffectsProvider Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ElementTemplate Class

ElementTemplate Class

Represents an element of a shape definition. This is the parent class of specific element types, such as ArcTemplate, LineTemplate and BezierTemplate.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract class ElementTemplate : ICloneable, IPersists
Visual Basic

Public MustInherit Class ElementTemplate
Implements ICloneable, IPersists

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.ArcTemplate
MindFusion.Diagramming.BezierTemplate
MindFusion.Diagramming.LineTemplate
MindFusion.Diagramming.RoundRectangleTemplate

See Also

ElementTemplate Members
MindFusion.Diagramming Namespace
DefaultShape


MindFusion.Diagramming.ElementTemplate Members

ElementTemplate Members
Constructors Properties Methods

Represents an element of a shape definition. This is the parent class of specific element types, such as ArcTemplate, LineTemplate and BezierTemplate.

The following tables list the members exposed by the ElementTemplate type.

Protected Constructors

Name | Description
ElementTemplate | Initializes a new instance of the ElementTemplate class.

Public Properties

Name | Description
Color | Gest or sets the outline color of this element.
DashStyle | Gets or sets the dash style of the outline of this element.
Width | Gets or sets the outline width of this element.

Public Methods

Name | Description
Clone | Creates an exact copy of this element.
SameAs | Checks whether the current element and the specified element resemble each other closely enough to be considered identical.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument.

See Also

ElementTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ElementTemplate Constructor

ElementTemplate Constructor

Initializes a new instance of the ElementTemplate class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected ElementTemplate ()
Visual Basic

Protected Sub New ()

See Also

ElementTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ElementTemplate Methods

ElementTemplate Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this element.
SameAs | Checks whether the current element and the specified element resemble each other closely enough to be considered identical.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument.

See Also

ElementTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ElementTemplate.Clone Method

ElementTemplate.Clone Method

Creates an exact copy of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract Object Clone ()
Visual Basic

Public MustOverride Function Clone () As Object

Return Value

An instance of the appropriate type that represents the element clone.

See Also

ElementTemplate Members
ElementTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ElementTemplate.GetElementPen Method

ElementTemplate.GetElementPen Method

Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected Pen GetElementPen (
Pen pen
)
Visual Basic

Protected Function GetElementPen ( _
pen As Pen _
) As Pen

Parameters

pen

The Pen object specifying the base pen.

Return Value

See Also

ElementTemplate Members
ElementTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ElementTemplate.SameAs Method

ElementTemplate.SameAs Method

Checks whether the current element and the specified element resemble each other closely enough to be considered identical.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract bool SameAs (
ElementTemplate obj
)
Visual Basic

Public MustOverride Function SameAs ( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this element.

Return Value

true if the specified object closely approximates this element; otherwise, false.

See Also

ElementTemplate Members
ElementTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ElementTemplate Properties

ElementTemplate Properties

Public Properties

Name | Description
Color | Gest or sets the outline color of this element.
DashStyle | Gets or sets the dash style of the outline of this element.
Width | Gets or sets the outline width of this element.

See Also

ElementTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ElementTemplate.Color Property

ElementTemplate.Color Property

Gest or sets the outline color of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color Color { get; set; }
Visual Basic

Public Property Color As Color

Property Value

A .NET Color instance specifying the color of the outline.

See Also

ElementTemplate Members
ElementTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ElementTemplate.DashStyle Property

ElementTemplate.DashStyle Property

Gets or sets the dash style of the outline of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DashStyle DashStyle { get; set; }
Visual Basic

Public Property DashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration specifying the style of the outline.

See Also

ElementTemplate Members
ElementTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ElementTemplate.Width Property

ElementTemplate.Width Property

Gets or sets the outline width of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float Width { get; set; }
Visual Basic

Public Property Width As Single

Property Value

A float value specifying the width of the outline.

See Also

ElementTemplate Members
ElementTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ExpandButtonAction Enumeration

ExpandButtonAction Enumeration

Specifies what action is triggered by the [±] buttons that are displayed near expandable nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum ExpandButtonAction
Visual Basic

Public Enumeration ExpandButtonAction

Members

Member name | Description
ExpandTreeBranch | Expands or collapses the children of a node in a tree-like diagram and raises the TreeExpanded or TreeCollapsed event.
RaiseEvents | Raises the ExpandButtonClicked event.

Remarks

The members of this enumeration can be assigned to the ExpandButtonAction property of the Diagram class.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.ExpandButtonPosition Enumeration

ExpandButtonPosition Enumeration

Defines values that specify possible locations for expand/collapse buttons.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum ExpandButtonPosition
Visual Basic

Public Enumeration ExpandButtonPosition

Members

Member name | Description
OuterBottom | Place expand/collapse buttons at the bottom side of their nodes.
OuterLeft | Place expand/collapse buttons at the left-hand side of their nodes.
OuterLowerLeft | Place expand/collapse buttons at the lower-left corner of their nodes.
OuterLowerRight | Place expand/collapse buttons at the lower-right corner of their nodes.
OuterRight | Place expand/collapse buttons at the right-hand side of their nodes.
OuterTop | Place expand/collapse buttons at the top side of their nodes.
OuterUpperLeft | Place expand/collapse buttons at the upper-left corner of their nodes.
OuterUpperRight | Place expand/collapse buttons at the upper-right corner of their nodes.

Remarks

Assign values from this enumeration to the ExpandButtonPosition property of the Diagram class.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.Factory Class

Factory Class

Provides shortcut methods for creating and adding instances of the standard MindFusion.Diagramming item types. Call the class methods through the Factory property of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class Factory
Visual Basic

Public Class Factory

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Factory

See Also

Factory Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Factory Members

Factory Members
Constructors Methods

Provides shortcut methods for creating and adding instances of the standard MindFusion.Diagramming item types. Call the class methods through the Factory property of the Diagram class.

The following tables list the members exposed by the Factory type.

Public Constructors

Name | Description
Factory | Initializes a new instance of the Factory class over the specified Diagram.

Public Methods

Name | Description
CreateContainerNode | Overloaded. Creates a new ContainerNode instance and adds it to the Nodes collection of the underlying diagram.
CreateDiagramLink | Overloaded. Creates a new DiagramLink instance and adds it to the Links collection of the underlying diagram.
CreateGroup | Creates a new hierarchical Group with the specified main item.
CreateShapeNode | Overloaded. Creates a new ShapeNode instance and adds it to the Nodes collection of the underlying diagram.
CreateTableNode | Overloaded. Creates a new TableNode instance and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Factory Constructor

Factory Constructor

Initializes a new instance of the Factory class over the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Factory (
Diagram diagram
)
Visual Basic

Public Sub Factory ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram object for which to create the new factory.

See Also

Factory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Factory Methods

Factory Methods

Public Methods

Name | Description
CreateContainerNode | Overloaded. Creates a new ContainerNode instance and adds it to the Nodes collection of the underlying diagram.
CreateDiagramLink | Overloaded. Creates a new DiagramLink instance and adds it to the Links collection of the underlying diagram.
CreateGroup | Creates a new hierarchical Group with the specified main item.
CreateShapeNode | Overloaded. Creates a new ShapeNode instance and adds it to the Nodes collection of the underlying diagram.
CreateTableNode | Overloaded. Creates a new TableNode instance and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Factory.CreateContainerNode Method

Factory.CreateContainerNode Method

Creates a new ContainerNode instance and adds it to the Nodes collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateContainerNode (PointF, SizeF) | Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (PointF, SizeF, Boolean) | Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (RectangleF) | Creates a new ContainerNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (RectangleF, Boolean) | Creates a new ContainerNode instance with the specified dimensions, optionally foldable, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Single, Single, Single, Single) | Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Single, Single, Single, Single, Boolean) | Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Factory.CreateContainerNode Method (PointF, SizeF)

Factory.CreateContainerNode Method (PointF, SizeF)
See Also

Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNode CreateContainerNode (
PointF location,
SizeF size
)
Visual Basic

Public Function CreateContainerNode ( _
location As PointF, _
size As SizeF _
) As ContainerNode

Parameters

location
The location of the ContainerNode object.
size
The size of the ContainerNode object.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by location. The size of the container is set by size. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateContainerNode Method (PointF, SizeF, Boolean)

Factory.CreateContainerNode Method (PointF, SizeF, Boolean)
See Also

Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNode CreateContainerNode (
PointF location,
SizeF size,
bool foldable
)
Visual Basic

Public Function CreateContainerNode ( _
location As PointF, _
size As SizeF, _
foldable As Boolean _
) As ContainerNode

Parameters

location
The location of the ContainerNode object.
size
The newly created ContainerNode instance.
foldable
true if the container can be folded; otherwise, false.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by location. The size of the container is set by size. The parameter foldable specifies whether the container node is initially foldable. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateContainerNode Method (RectangleF)

Factory.CreateContainerNode Method (RectangleF)
See Also

Creates a new ContainerNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNode CreateContainerNode (
RectangleF bounds
)
Visual Basic

Public Function CreateContainerNode ( _
bounds As RectangleF _
) As ContainerNode

Parameters

bounds

The initial bounding rectangle of the new node.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node with the position and size specified by bounds. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Factory.CreateContainerNode Method (RectangleF, Boolean)

Factory.CreateContainerNode Method (RectangleF, Boolean)
See Also

Creates a new ContainerNode instance with the specified dimensions, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNode CreateContainerNode (
RectangleF bounds,
bool foldable
)
Visual Basic

Public Function CreateContainerNode ( _
bounds As RectangleF, _
foldable As Boolean _
) As ContainerNode

Parameters

bounds

The initial bounding rectangle of the new node.

foldable

true if the container can be folded; otherwise, false.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node with the position and size specified by bounds. The parameter foldable specifies whether the container node is initially foldable. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Factory.CreateContainerNode Method (Single, Single, Single, Single)

Factory.CreateContainerNode Method (Single, Single, Single, Single)
See Also

Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNode CreateContainerNode (
float x,
float y,
float width,
float height
)
Visual Basic

Public Function CreateContainerNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As ContainerNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y
The y-coordinate of the upper-left corner of the new node.
width
The width of the new node.
height
The height of the new node.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by x and y. The size of the container is set by width and height. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateContainerNode Method (Single, Single, Single, Single, Boolean)

Factory.CreateContainerNode Method (Single, Single, Single, Single, Boolean)
See Also

Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNode CreateContainerNode (
float x,
float y,
float width,
float height,
bool foldable
)
Visual Basic

Public Function CreateContainerNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
foldable As Boolean _
) As ContainerNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

foldable

true if the container can be folded; otherwise, false.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by x and y. The size of the container is set by width and height. The parameter foldable specifies whether the container node is initially foldable. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Factory.CreateDiagramLink Method

Factory.CreateDiagramLink Method

Creates a new DiagramLink instance and adds it to the Links collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateDiagramLink (DiagramNode, DiagramNode) | Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (DiagramNode, PointF) | Creates a new DiagramLink instance between the specified node and the specified point, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (DiagramNode, TableNode, Int32) | Creates a new DiagramLink instance between the specified nodes and the specified table, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (PointF, DiagramNode) | Creates a new DiagramLink instance between the specified point and the specified node, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (PointF, PointF) | Creates a new DiagramLink instance between the specified points and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (ShapeNode, Int32, ShapeNode, Int32) | Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, Int32, DiagramNode) | Creates a new DiagramLink instance between the specified table and the specified node, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, Int32, TableNode, Int32) | Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, TableNode) | Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

See Also

Factory Members
Factory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Factory.CreateDiagramLink Method (DiagramNode, DiagramNode)

Factory.CreateDiagramLink Method (DiagramNode, DiagramNode)
See Also

Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink CreateDiagramLink (
DiagramNode origin,
DiagramNode destination
)
Visual Basic

Public Function CreateDiagramLink ( _
origin As DiagramNode, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin
The origin node.
destination
The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the nodes specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateTableNode Method
CreateShapeNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (DiagramNode, PointF)

Factory.CreateDiagramLink Method (DiagramNode, PointF)
See Also

Creates a new DiagramLink instance between the specified node and the specified point, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink CreateDiagramLink (
DiagramNode origin,
PointF destination
)
Visual Basic

Public Function CreateDiagramLink ( _
origin As DiagramNode, _
destination As PointF _
) As DiagramLink

Parameters

origin
The origin node.
destination
The destination point.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the node specified by origin and the point specified by destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (DiagramNode, TableNode, Int32)

Factory.CreateDiagramLink Method (DiagramNode, TableNode, Int32)
See Also

Creates a new DiagramLink instance between the specified nodes and the specified table, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink CreateDiagramLink (
DiagramNode origin,
TableNode destination,
int destRow
)
Visual Basic

Public Function CreateDiagramLink ( _
origin As DiagramNode, _
destination As TableNode, _
destRow As Integer _
) As DiagramLink

Parameters

origin
The origin node.
destination

The destination node.

destRow
The zero-based index of the destination table row of the new link.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the node specified by origin and the table specified by destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (PointF, DiagramNode)

Factory.CreateDiagramLink Method (PointF, DiagramNode)
See Also

Creates a new DiagramLink instance between the specified point and the specified node, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink CreateDiagramLink (
PointF origin,
DiagramNode destination
)
Visual Basic

Public Function CreateDiagramLink ( _
origin As PointF, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin
The origin point.
destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the point specified by origin and the node specified by destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (PointF, PointF)

Factory.CreateDiagramLink Method (PointF, PointF)
See Also

Creates a new DiagramLink instance between the specified points and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink CreateDiagramLink (
PointF origin,
PointF destination
)
Visual Basic

Public Function CreateDiagramLink ( _
origin As PointF, _
destination As PointF _
) As DiagramLink

Parameters

origin
The origin point.
destination
The destination point.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the points specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (ShapeNode, Int32, ShapeNode, Int32)

Factory.CreateDiagramLink Method (ShapeNode, Int32, ShapeNode, Int32)
See Also

Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink CreateDiagramLink (
ShapeNode origin,
int originAnchor,
ShapeNode destination,
int destAnchor
)
Visual Basic

Public Function CreateDiagramLink ( _
origin As ShapeNode, _
originAnchor As Integer, _
destination As ShapeNode, _
destAnchor As Integer _
) As DiagramLink

Parameters

origin
The origin node.
originAnchor

The index of an anchor point within the origin node's AnchorPattern.

destination

The destination node.

destAnchor
The index of an anchor point within the destination node's AnchorPattern.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the shape nodes specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (TableNode, Int32, DiagramNode)

Factory.CreateDiagramLink Method (TableNode, Int32, DiagramNode)
See Also

Creates a new DiagramLink instance between the specified table and the specified node, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink CreateDiagramLink (
TableNode origin,
int originRow,
DiagramNode destination
)
Visual Basic

Public Function CreateDiagramLink ( _
origin As TableNode, _
originRow As Integer, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin
The origin node.
originRow

The zero-based index of the destination table row of the new link.

destination
The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the table specified by origin and the node specified by destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (TableNode, Int32, TableNode, Int32)

Factory.CreateDiagramLink Method (TableNode, Int32, TableNode, Int32)
See Also

Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink CreateDiagramLink (
TableNode origin,
int originRow,
TableNode destination,
int destRow
)
Visual Basic

Public Function CreateDiagramLink ( _
origin As TableNode, _
originRow As Integer, _
destination As TableNode, _
destRow As Integer _
) As DiagramLink

Parameters

origin
The origin node.
originRow

The zero-based index of the origin table row of the new link.

destination
The destination node.
destRow
The zero-based index of the destination table row of the new link.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the tables specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateDiagramLink Method (TableNode, TableNode)

Factory.CreateDiagramLink Method (TableNode, TableNode)
See Also

Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink CreateDiagramLink (
TableNode origin,
TableNode destination
)
Visual Basic

Public Function CreateDiagramLink ( _
origin As TableNode, _
destination As TableNode _
) As DiagramLink

Parameters

origin
The origin node.
destination
The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the tables specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateTableNode Method
Diagram.Links Property


MindFusion.Diagramming.Factory.CreateGroup Method

Factory.CreateGroup Method

Creates a new hierarchical Group with the specified main item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Group CreateGroup (
DiagramItem mainItem
)
Visual Basic

Public Function CreateGroup ( _
mainItem As DiagramItem _
) As Group

Parameters

mainItem
The DiagramItem around which the group would be built.

Return Value

The newly created Group instance if successfully created; otherwise null (Nothing in Visual Basic).

Remarks

Use this method to create an hierarchical group of items. Attach subordinated items by using the various Group members.

See Also

Factory Members
Factory Class
MindFusion.Diagramming Namespace
Diagram.GroupDestroyed Event


MindFusion.Diagramming.Factory.CreateShapeNode Method

Factory.CreateShapeNode Method

Creates a new ShapeNode instance and adds it to the Nodes collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateShapeNode (PointF, SizeF) | Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (PointF, SizeF, Shape) | Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (RectangleF) | Creates a new ShapeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (RectangleF, Shape) | Creates a new ShapeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Single, Single, Single, Single) | Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Single, Single, Single, Single, Shape) | Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Factory.CreateShapeNode Method (PointF, SizeF)

Factory.CreateShapeNode Method (PointF, SizeF)
See Also

Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeNode CreateShapeNode (
PointF location,
SizeF size
)
Visual Basic

Public Function CreateShapeNode ( _
location As PointF, _
size As SizeF _
) As ShapeNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateShapeNode Method (PointF, SizeF, Shape)

Factory.CreateShapeNode Method (PointF, SizeF, Shape)
See Also

Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeNode CreateShapeNode (
PointF location,
SizeF size,
Shape shape
)
Visual Basic

Public Function CreateShapeNode ( _
location As PointF, _
size As SizeF, _
shape As Shape _
) As ShapeNode

Parameters

location

The position of the new node.

size

The size of the new node.

shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size. The shape of the new node is specified by shape. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateShapeNode Method (RectangleF)

Factory.CreateShapeNode Method (RectangleF)
See Also

Creates a new ShapeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeNode CreateShapeNode (
RectangleF bounds
)
Visual Basic

Public Function CreateShapeNode ( _
bounds As RectangleF _
) As ShapeNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateShapeNode Method (RectangleF, Shape)

Factory.CreateShapeNode Method (RectangleF, Shape)
See Also

Creates a new ShapeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeNode CreateShapeNode (
RectangleF bounds,
Shape shape
)
Visual Basic

Public Function CreateShapeNode ( _
bounds As RectangleF, _
shape As Shape _
) As ShapeNode

Parameters

bounds

The bounding rectangle of the new node.

shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds. The shape of the new node is specified by shape. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateShapeNode Method (Single, Single, Single, Single)

Factory.CreateShapeNode Method (Single, Single, Single, Single)
See Also

Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeNode CreateShapeNode (
float x,
float y,
float width,
float height
)
Visual Basic

Public Function CreateShapeNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As ShapeNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y
The y-coordinate of the upper-left corner of the new node.
width

The width of the new node.

height
The height of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by x and y. The size of the node is set by width and height. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateShapeNode Method (Single, Single, Single, Single, Shape)

Factory.CreateShapeNode Method (Single, Single, Single, Single, Shape)
See Also

Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeNode CreateShapeNode (
float x,
float y,
float width,
float height,
Shape shape
)
Visual Basic

Public Function CreateShapeNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
shape As Shape _
) As ShapeNode

Parameters

x
The x-coordinate of the upper-left corner of the new node.
y
The y-coordinate of the upper-left corner of the new node.
width
The width of the new node.
height
The height of the new node.
shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by x and y. The size of the node is set by width and height. The shape of the new node is specified by shape. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateTableNode Method

Factory.CreateTableNode Method

Creates a new TableNode instance and adds it to the Nodes collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateTableNode (PointF, SizeF) | Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (PointF, SizeF, Int32, Int32) | Creates a new TableNode instance at the specified position with the specified size and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (RectangleF) | Creates a new TableNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (RectangleF, Int32, Int32) | Creates a new TableNode instance with the specified dimensions and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Single, Single, Single, Single) | Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Single, Single, Single, Single, Int32, Int32) | Creates a new TableNode instance at the specified position with the specified size and the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Factory.CreateTableNode Method (PointF, SizeF)

Factory.CreateTableNode Method (PointF, SizeF)
See Also

Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode CreateTableNode (
PointF location,
SizeF size
)
Visual Basic

Public Function CreateTableNode ( _
location As PointF, _
size As SizeF _
) As TableNode

Parameters

location

The position of the new table.

size

The size of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by location. The size of the node is set by size. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateTableNode Method (PointF, SizeF, Int32, Int32)

Factory.CreateTableNode Method (PointF, SizeF, Int32, Int32)
See Also

Creates a new TableNode instance at the specified position with the specified size and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode CreateTableNode (
PointF location,
SizeF size,
int columns,
int rows
)
Visual Basic

Public Function CreateTableNode ( _
location As PointF, _
size As SizeF, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

location

The position of the new table.

size

The size of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by location. The size of the node is set by size. The initial number of columns and rows in the table is specified by columns and rows respectively. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateTableNode Method (RectangleF)

Factory.CreateTableNode Method (RectangleF)
See Also

Creates a new TableNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode CreateTableNode (
RectangleF bounds
)
Visual Basic

Public Function CreateTableNode ( _
bounds As RectangleF _
) As TableNode

Parameters

bounds

The bounding rectangle of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node with dimensions specified by bounds. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateTableNode Method (RectangleF, Int32, Int32)

Factory.CreateTableNode Method (RectangleF, Int32, Int32)
See Also

Creates a new TableNode instance with the specified dimensions and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode CreateTableNode (
RectangleF bounds,
int columns,
int rows
)
Visual Basic

Public Function CreateTableNode ( _
bounds As RectangleF, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

bounds

The bounding rectangle of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node with dimensions specified by bounds. The initial number of columns and rows in the table is specified by columns and rows respectively. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateTableNode Method (Single, Single, Single, Single)

Factory.CreateTableNode Method (Single, Single, Single, Single)
See Also

Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode CreateTableNode (
float x,
float y,
float width,
float height
)
Visual Basic

Public Function CreateTableNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As TableNode

Parameters

x

The x-coordinate of the upper-left corner of the new table.

y

The y-coordinate of the upper-left corner of the new table.

width

The width of the new table.

height

The height of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by x and y. The size of the node is set by width and height. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Factory.CreateTableNode Method (Single, Single, Single, Single, Int32, Int32)

Factory.CreateTableNode Method (Single, Single, Single, Single, Int32, Int32)
See Also

Creates a new TableNode instance at the specified position with the specified size and the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode CreateTableNode (
float x,
float y,
float width,
float height,
int columns,
int rows
)
Visual Basic

Public Function CreateTableNode ( _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

x

The x-coordinate of the upper-left corner of the new table.

y

The y-coordinate of the upper-left corner of the new table.

width
The width if the new table.
height

The height of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by x and y. The size of the node is set by width and height. The initial number of columns and rows in the table is specified by columns and rows respectively. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.FitSize Enumeration

FitSize Enumeration

Specifies how the ResizeToFitText method should resize a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum FitSize
Visual Basic

Public Enumeration FitSize

Members

Member name | Description
KeepHeight | Specifies that the original node height should remain intact.
KeepRatio | Allows changing both the width and height of a node, but keep the original width/height ratio if possible.
KeepWidth | Specifies that the original node width should remain intact.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.GridStyle Enumeration

GridStyle Enumeration

Defines values that specify the visual style of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum GridStyle
Visual Basic

Public Enumeration GridStyle

Members

Member name | Description
Lines | The grid is represented as a series of crossing horizontal and vertical lines.
Points | The grid is painted as a matrix of points.

See Also

MindFusion.Diagramming Namespace
GridStyle Property


MindFusion.Diagramming.Group Class

Group Class
Remarks See Also

Represents a group of items in the diagram document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class Group : IPersists
Visual Basic

Public Class Group
Implements IPersists

Remarks

An hierarchy of items can be built, so that moving an item that is higher in the hierarchy moves all subordinated items too. The immediate subordinates of an item are represented by a Group instance. Every group should have a single master item, to which all group members are attached. The master item can be accessed from the MainItem property. The group of items attached to an item is accessed through the SubordinateGroup property of the latter. MasterGroup gets the group in which an item is subordinate.

To create a group, instantiate a Group object and add it to the diagram's Groups collection, or call the CreateGroup method passing the master item as argument. A group is automatically destroyed when its master item is deleted.

To destroy a group programmatically, call the Remove method of the Groups collection. If AutoDeleteItems is enabled, subordinated items in the group are deleted too. If AutoDeleteItems is disabled, subordinated items are just detached from their master and remain intact.

Nodes can be attached to a group in several ways, depending on the type of the master item. If the master is a node, other nodes can be attached by calling the AttachProportional or AttachToCorner methods. If the master is a link, nodes can be attached to it using the AttachToLinkSegment or AttachToLinkPoint methods. The DiagramNode class provides a shortcut AttachTo method, which creates a group if necessary and calls the group's appropriate AttachTo* method. Items can be detached from a group by calling the Detach method.

The Expandable property specifies whether expanding or collapsing a tree should propagate from the master node through the subordinated nodes. FollowMasterRotation can be used when the master node is a shape node. If it is enabled, the positions of the subordinated nodes are updated to reflect the RotationAngle of the shape node while it is rotated.

The Tag property allows attaching custom data to any group. The FindGroup methods looks for a groups having a specific tag.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Group

See Also

Group Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group Members

Group Members
Constructors Properties Methods

Represents a group of items in the diagram document.

The following tables list the members exposed by the Group type.

Public Constructors

Name | Description
Group | Overloaded. Initializes a new instance of the Group class.

Public Properties

Name | Description
AttachedNodes | Gets a collection of the nodes attached to this group.
AutoDeleteItems | Gets or sets a value indicating whether the subordinated items in a group are automatically deleted if the group is destroyed.
Expandable | Gets or sets a value indicating whether expanding/collapsing a tree branch propagates through this group.
FollowMasterContainment | Gets or sets a value indicating whether the subordinated items should be considered by a ContainerNode when the master item is added to the container.
FollowMasterRotation | Gets or sets a value indicating whether attached nodes position should follow the RotationAngle of a master ShapeNode node.
MainItem | Gets or sets the main item of this group.
Tag | Gets or sets a custom data associated with the group.
Visible | Gets or sets a value indicating whether the group is visible.

Public Methods

Name | Description
AttachProportional | Attaches a new node to the group, in such a way that its area is always occupying certain percentage of the main item's area.
AttachToCorner | Attaches a node to the specified corner of the main node.
AttachToEdges | Anchors a node to the specified edges of the master node.
AttachToLinkPoint | Attaches a node to the specified control point of the link that is MainItem.
AttachToLinkSegment | Attaches a node to the specified segment of the link that is MainItem.
AttachToLongestHSegment | Adds an item to the group, maintaining its relative position to the longest horizontal segment of the master link.
AttachToSideMiddle | Adds an item to the group, attaching it to the middle point of a side of the master node.
Detach | Detaches the specified item from this group.
GetRepaintRect | Gets a rectangle containing the repaint rectangle of the group's master and all attached objects.

See Also

Group Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group Constructor

Group Constructor

Initializes a new instance of the Group class.

Overload List

Name | Description
Group (Diagram) | Initializes a new instance of the Group class with the specified Diagram as parent.
Group (Group) | Initializes a new instance of the Group class using the specified group as a prototype.

See Also

Group Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group Constructor (Diagram)

Group Constructor (Diagram)
See Also

Initializes a new instance of the Group class with the specified Diagram as parent.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Group (
Diagram parent
)
Visual Basic

Public Sub Group ( _
parent As Diagram _
)

Parameters

parent

The Diagram the new group will belong to.

See Also

Group Constructor Overload List
Group Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group Constructor (Group)

Group Constructor (Group)
See Also

Initializes a new instance of the Group class using the specified group as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Group (
Group prototype
)
Visual Basic

Public Sub Group ( _
prototype As Group _
)

Parameters

prototype
The group to use as a prototype.

Remarks

This constructor supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code. Instead use the other constructor or the CreateGroup method of the Factory class.

See Also

Group Constructor Overload List
Group Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group Methods

Group Methods

Public Methods

Name | Description
AttachProportional | Attaches a new node to the group, in such a way that its area is always occupying certain percentage of the main item's area.
AttachToCorner | Attaches a node to the specified corner of the main node.
AttachToEdges | Anchors a node to the specified edges of the master node.
AttachToLinkPoint | Attaches a node to the specified control point of the link that is MainItem.
AttachToLinkSegment | Attaches a node to the specified segment of the link that is MainItem.
AttachToLongestHSegment | Adds an item to the group, maintaining its relative position to the longest horizontal segment of the master link.
AttachToSideMiddle | Adds an item to the group, attaching it to the middle point of a side of the master node.
Detach | Detaches the specified item from this group.
GetRepaintRect | Gets a rectangle containing the repaint rectangle of the group's master and all attached objects.

See Also

Group Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.AttachProportional Method

Group.AttachProportional Method

Attaches a new node to the group, in such a way that its area is always occupying certain percentage of the main item's area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AttachProportional (
DiagramNode node,
float left,
float top,
float right,
float bottom
)
Visual Basic

Public Function AttachProportional ( _
node As DiagramNode, _
left As Single, _
top As Single, _
right As Single, _
bottom As Single _
) As Boolean

Parameters

node

The DiagramNode to be attached.

left
The left side of the node's bounding rectangle, expressed as percent of the main node width.
top
The top side of the node's bounding rectangle, expressed as percent of the main node height.
right
The right side of the node's bounding rectangle, expressed as percent of the main node width.
bottom
The bottom side of the node's bounding rectangle, expressed as percent of the main node height.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

You can use this method when the main item of the group is a node. Use the left, top, right and bottom arguments to specify the position and size of the attached node relative to that of the main item. When moving or resizing the main node, the specified ratio between it and the attached node is preserved.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace
AttachToCorner Method


MindFusion.Diagramming.Group.AttachToCorner Method

Group.AttachToCorner Method

Attaches a node to the specified corner of the main node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AttachToCorner (
DiagramNode node,
int corner
)
Visual Basic

Public Function AttachToCorner ( _
node As DiagramNode, _
corner As Integer _
) As Boolean

Parameters

node
The DiagramNode to be attached.
corner
The zero-based index of the main node's corner.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

You can use this method if the main item of the group is a node. When the specified corner position of the main node's bounding rectangle is changed, the position of the attached node is also changed and the distance between them is preserved.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace
AttachProportional Method


MindFusion.Diagramming.Group.AttachToEdges Method

Group.AttachToEdges Method

Anchors a node to the specified edges of the master node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AttachToEdges (
DiagramNode node,
GroupAnchorStyles anchorStyles
)
Visual Basic

Public Function AttachToEdges ( _
node As DiagramNode, _
anchorStyles As GroupAnchorStyles _
) As Boolean

Parameters

node

The DiagramNode to be attached.

anchorStyles
A member of the GroupAnchorStyles enumeration.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

This method can be used only if the master item in the group is a node. Anchoring works in a manner similar to how child controls in a form can be anchored to the form edges. When the master node position changes, the position of the attached node is also changed so that the initial distance between the specified edges is preserved.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace
AttachProportional Method


MindFusion.Diagramming.Group.AttachToLinkPoint Method

Group.AttachToLinkPoint Method

Attaches a node to the specified control point of the link that is MainItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AttachToLinkPoint (
DiagramNode node,
int point
)
Visual Basic

Public Function AttachToLinkPoint ( _
node As DiagramNode, _
point As Integer _
) As Boolean

Parameters

node

The DiagramNode to be attached.

point
The link point to which the node should be attached.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

You can use this method when the main item of the group is a link. When the user moves the link control point whose index is passed as argument, the attached node is also moved with the same translation vector as that of the control point.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace
AttachToLinkSegment Method


MindFusion.Diagramming.Group.AttachToLinkSegment Method

Group.AttachToLinkSegment Method

Attaches a node to the specified segment of the link that is MainItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AttachToLinkSegment (
DiagramNode node,
int segment
)
Visual Basic

Public Function AttachToLinkSegment ( _
node As DiagramNode, _
segment As Integer _
) As Boolean

Parameters

node

The DiagramNode to be attached.

segment
The link segment to which the node will be attached.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

Call this method when the main item of the group is a link. When the specified link segment changes its position, the position of the attached node is also changed, so their mutual distance and orientation are preserved.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace
AttachToLinkPoint Method


MindFusion.Diagramming.Group.AttachToLongestHSegment Method

Group.AttachToLongestHSegment Method

Adds an item to the group, maintaining its relative position to the longest horizontal segment of the master link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AttachToLongestHSegment (
DiagramNode node
)
Visual Basic

Public Function AttachToLongestHSegment ( _
node As DiagramNode _
) As Boolean

Parameters

node
The object to attach to the current group.

Return Value

false if the node could not be attached; otherwise, true.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.AttachToSideMiddle Method

Group.AttachToSideMiddle Method

Adds an item to the group, attaching it to the middle point of a side of the master node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AttachToSideMiddle (
DiagramNode node,
int side
)
Visual Basic

Public Function AttachToSideMiddle ( _
node As DiagramNode, _
side As Integer _
) As Boolean

Parameters

node
The object to attach to the current group.
side
The corner to attach to.

Return Value

false if the node could not be attached; otherwise, true.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.Detach Method

Group.Detach Method

Detaches the specified item from this group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Detach (
DiagramItem item
)
Visual Basic

Public Function Detach ( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem to be detached.

Return Value

false if the item could not be detached; otherwise, true.

Remarks

Call this method to remove a item from this group. Note that this method does not delete the item, but just detaches it.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace
AttachToLinkSegment Method
AttachToLinkPoint Method
AttachProportional Method
AttachToCorner Method


MindFusion.Diagramming.Group.GetRepaintRect Method

Group.GetRepaintRect Method

Gets a rectangle containing the repaint rectangle of the group's master and all attached objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF GetRepaintRect ()
Visual Basic

Public Function GetRepaintRect () As RectangleF

Return Value

A .NET RectangleF instance that represents the smallest rectangle containing all diagram items related directly or indirectly to this group.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group Properties

Group Properties

Public Properties

Name | Description
AttachedNodes | Gets a collection of the nodes attached to this group.
AutoDeleteItems | Gets or sets a value indicating whether the subordinated items in a group are automatically deleted if the group is destroyed.
Expandable | Gets or sets a value indicating whether expanding/collapsing a tree branch propagates through this group.
FollowMasterContainment | Gets or sets a value indicating whether the subordinated items should be considered by a ContainerNode when the master item is added to the container.
FollowMasterRotation | Gets or sets a value indicating whether attached nodes position should follow the RotationAngle of a master ShapeNode node.
MainItem | Gets or sets the main item of this group.
Tag | Gets or sets a custom data associated with the group.
Visible | Gets or sets a value indicating whether the group is visible.

See Also

Group Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.AttachedNodes Property

Group.AttachedNodes Property

Gets a collection of the nodes attached to this group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ReadOnlyDiagramNodeCollection AttachedNodes { get; }
Visual Basic

Public ReadOnly Property AttachedNodes As ReadOnlyDiagramNodeCollection

Property Value

A collection that references all nodes attached to the group.

Remarks

The MainItem is not included in this collection.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace
MainItem Property


MindFusion.Diagramming.Group.AutoDeleteItems Property

Group.AutoDeleteItems Property

Gets or sets a value indicating whether the subordinated items in a group are automatically deleted if the group is destroyed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AutoDeleteItems { get; set; }
Visual Basic

Public Property AutoDeleteItems As Boolean

Property Value

true to delete subordinated items automatically; otherwise, false. The default is false.

Remarks

A group is destroyed explicitly by calling the Remove method of the Groups collection. A group is destroyed implicitly when its MainItem is deleted.

If a group is destroyed and this property is disabled, all subordinated items remain intact in the diagram, however they are no longer grouped. If a group is destroyed and this property is enabled, all subordinated items are deleted.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.Expandable Property

Group.Expandable Property

Gets or sets a value indicating whether expanding/collapsing a tree branch propagates through this group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Expandable { get; set; }
Visual Basic

Public Property Expandable As Boolean

Property Value

true if expanding or collapsing of a tree branch should propagate through the group members; otherwise, false. The default is false.

Remarks

By default expanding or collapsing tree branches is done by following the links between the branch nodes. If there are not links going out from a node, the expanding or collapsing stops there. However, if a node has a group of subordinated nodes, it could be desirable to continue expanding through them. To enable that, set the group's Expandable property to true.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace
Diagram.RecursiveExpand Property
Diagram.NodesExpandable Property


MindFusion.Diagramming.Group.FollowMasterContainment Property

Group.FollowMasterContainment Property

Gets or sets a value indicating whether the subordinated items should be considered by a ContainerNode when the master item is added to the container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool FollowMasterContainment { get; set; }
Visual Basic

Public Property FollowMasterContainment As Boolean

Property Value

true if the whole group is contained in the ContainerNode; otherwise, false. The default is false.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.FollowMasterRotation Property

Group.FollowMasterRotation Property

Gets or sets a value indicating whether attached nodes position should follow the RotationAngle of a master ShapeNode node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool FollowMasterRotation { get; set; }
Visual Basic

Public Property FollowMasterRotation As Boolean

Property Value

true to make attached nodes follow the rotation of the master shape node; otherwise, false. The default is false.

Remarks

The attached nodes are not rotated, but only their position change. That is, their center points are rotated at the master node's RotationAngle relative to the master node center.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.MainItem Property

Group.MainItem Property

Gets or sets the main item of this group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem MainItem { get; set; }
Visual Basic

Public Property MainItem As DiagramItem

Property Value

An instance of the DiagramItem class that represents the main item.

Remarks

Each group has an item which the subordinated items follow when it is moved. This main item can be a node or a link. The main item is passed as argument to the CreateGroup method.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace
AttachedNodes Property


MindFusion.Diagramming.Group.Tag Property

Group.Tag Property

Gets or sets a custom data associated with the group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object Tag { get; set; }
Visual Basic

Public Property Tag As Object

Property Value

An instance of a System.Object-derived class that represents the tag.

Remarks

This property holds data that you define. MindFusion.Diagramming does not use it in any way. Possible usage might be to store an integer identifier or a reference to a larger structure.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace
Diagram.FindGroup Method
Diagram.SerializeTag Event


MindFusion.Diagramming.Group.Visible Property

Group.Visible Property

Gets or sets a value indicating whether the group is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Visible { get; set; }
Visual Basic

Public Property Visible As Boolean

Property Value

true if the group is visible; otherwise, false.

Remarks

Assigning a value to this property sets the Visible property of all items in the group.

See Also

Group Members
Group Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.Attachment Class

Group.Attachment Class

Encapsulates attachment information.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class Group.Attachment : IPersists
Visual Basic

Public Class Group.Attachment
Implements IPersists

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Group.Attachment

See Also

Group.Attachment Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.Attachment Members

Group.Attachment Members
Constructors Properties Methods

Encapsulates attachment information.

The following tables list the members exposed by the Group.Attachment type.

Public Constructors

Name | Description
Group.Attachment | Initializes a new instance of the Attachment class.

Public Properties

Name | Description
Data | Gets or sets the attachment data.
Node | Gets or sets the attached node.
Percents | Gets a sets percent information for proprtional attachments.
Traits | Contains properties specific to each layout algorithm.
Type | Gets or sets the attachment type.

Public Methods

Name | Description
Clone | Creates an exact copy of this attachment.

See Also

Group.Attachment Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.Attachment Constructor

Group.Attachment Constructor

Initializes a new instance of the Attachment class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Group.Attachment ()
Visual Basic

Public Sub New ()

See Also

Group.Attachment Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.Attachment Methods

Group.Attachment Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this attachment.

See Also

Group.Attachment Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.Attachment.Clone Method

Group.Attachment.Clone Method

Creates an exact copy of this attachment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Group.Attachment Clone ()
Visual Basic

Public Function Clone () As Group.Attachment

Return Value

See Also

Group.Attachment Members
Group.Attachment Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.Attachment Properties

Group.Attachment Properties

Public Properties

Name | Description
Data | Gets or sets the attachment data.
Node | Gets or sets the attached node.
Percents | Gets a sets percent information for proprtional attachments.
Traits | Contains properties specific to each layout algorithm.
Type | Gets or sets the attachment type.

See Also

Group.Attachment Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.Attachment.Data Property

Group.Attachment.Data Property

Gets or sets the attachment data.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Data { get; set; }
Visual Basic

Public Property Data As Integer

Property Value

Remarks

The interpretation of this value depends on the type of the attachment.

See Also

Group.Attachment Members
Group.Attachment Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.Attachment.Node Property

Group.Attachment.Node Property

Gets or sets the attached node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Node { get; set; }
Visual Basic

Public Property Node As DiagramNode

Property Value

See Also

Group.Attachment Members
Group.Attachment Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.Attachment.Percents Property

Group.Attachment.Percents Property

Gets a sets percent information for proprtional attachments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF Percents { get; set; }
Visual Basic

Public Property Percents As RectangleF

Property Value

See Also

Group.Attachment Members
Group.Attachment Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.Attachment.Traits Property

Group.Attachment.Traits Property

Contains properties specific to each layout algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public IDictionary Traits { get; }
Visual Basic

Public ReadOnly Property Traits As IDictionary

Property Value

See Also

Group.Attachment Members
Group.Attachment Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Group.Attachment.Type Property

Group.Attachment.Type Property

Gets or sets the attachment type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AttachTo Type { get; set; }
Visual Basic

Public Property Type As AttachTo

Property Value

See Also

Group.Attachment Members
Group.Attachment Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupAnchorStyles Enumeration

GroupAnchorStyles Enumeration

Specifies the master node edges to which a subordinate node can be anchored.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum GroupAnchorStyles
Visual Basic

Public Enumeration GroupAnchorStyles

Members

Member name | Description
Bottom | Specifies the bottom edge.
Left | Specifies the left edge.
Right | Specifies the right edge.
Top | Specifies the top edge.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection Class

GroupCollection Class

Represents a strongly typed collection of Group objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class GroupCollection : PersistableCollection
Visual Basic

Public Class GroupCollection
Inherits PersistableCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.PersistableCollection
MindFusion.Diagramming.GroupCollection

See Also

GroupCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection Members

GroupCollection Members
Constructors Fields Properties Methods

Represents a strongly typed collection of Group objects.

The following tables list the members exposed by the GroupCollection type.

Public Constructors

Name | Description
GroupCollection | Initializes a new instance of the GroupCollection class.

Protected Fields

Name | Description
groupEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Public Properties

Name | Description
Item | Gets or sets the group at the specified position.

Public Methods

Name | Description
Add | Adds the specified group to the collection.
Clear | Removes all groups from the collection.
Clone | Creates a shallow copy of this collection.
Contains | Checks whether the the specified group is contained within the collection.
GetAt | The zero-based index of the group to retreive.
Insert | Inserts the specified group in the collection at the specified position.
Remove | Removes the specified group from the collection.

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection Fields

GroupCollection Fields

Protected Fields

Name | Description
groupEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

See Also

GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection.groupEventArgs Field

GroupCollection.groupEventArgs Field

A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected GroupEventArgs groupEventArgs
Visual Basic

Protected groupEventArgs As GroupEventArgs

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection.notifyParent Field

GroupCollection.notifyParent Field

If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected bool notifyParent
Visual Basic

Protected notifyParent As Boolean

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection Constructor

GroupCollection Constructor

Initializes a new instance of the GroupCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public GroupCollection ()
Visual Basic

Public Sub New ()

See Also

GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection Methods

GroupCollection Methods

Public Methods

Name | Description
Add | Adds the specified group to the collection.
Clear | Removes all groups from the collection.
Clone | Creates a shallow copy of this collection.
Contains | Checks whether the the specified group is contained within the collection.
GetAt | The zero-based index of the group to retreive.
Insert | Inserts the specified group in the collection at the specified position.
Remove | Removes the specified group from the collection.

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection.Add Method

GroupCollection.Add Method

Adds the specified group to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Add (
Group group
)
Visual Basic

Public Sub Add ( _
group As Group _
)

Parameters

group

The Group object to add to the collection.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection.Clear Method

GroupCollection.Clear Method

Removes all groups from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection.Clone Method

GroupCollection.Clone Method

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public GroupCollection Clone ()
Visual Basic

Public Function Clone () As GroupCollection

Return Value

An instance of the GroupCollection class.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection.Contains Method

GroupCollection.Contains Method

Checks whether the the specified group is contained within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Contains (
Group group
)
Visual Basic

Public Function Contains ( _
group As Group _
) As Boolean

Parameters

group

The Group object to search for in the collection.

Return Value

true if the specified node was found in the collection; otherwise, false.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection.GetAt Method

GroupCollection.GetAt Method

The zero-based index of the group to retreive.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Group GetAt (
int index
)
Visual Basic

Public Function GetAt ( _
index As Integer _
) As Group

Parameters

index

The zero-based index of the group to retreive.

Return Value

An instance of the Group class that represents the node at the specified position.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection.Insert Method

GroupCollection.Insert Method

Inserts the specified group in the collection at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Insert (
int index,
Group group
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
group As Group _
)

Parameters

index

The zero-based index at which to insert the group.

group

The Group object to add to the collection.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection.RaiseAdding Method

GroupCollection.RaiseAdding Method

Raises the Adding event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void RaiseAdding (
Group group
)
Visual Basic

Protected Sub RaiseAdding ( _
group As Group _
)

Parameters

group
The group that is being added.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection.RaiseInserting Method

GroupCollection.RaiseInserting Method

Raises the Inserting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void RaiseInserting (
Group group,
int index
)
Visual Basic

Protected Sub RaiseInserting ( _
group As Group, _
index As Integer _
)

Parameters

group
The group that is being added.
index
Index of the new group.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection.RaiseRemoving Method

GroupCollection.RaiseRemoving Method

Raises the Removing event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void RaiseRemoving (
Group group
)
Visual Basic

Protected Sub RaiseRemoving ( _
group As Group _
)

Parameters

group
The group that is being removed.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection.Remove Method

GroupCollection.Remove Method

Removes the specified group from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Remove (
Group group
)
Visual Basic

Public Sub Remove ( _
group As Group _
)

Parameters

group

The Group object to remove from the collection.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection Properties

GroupCollection Properties

Public Properties

Name | Description
Item | Gets or sets the group at the specified position.

See Also

GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupCollection.Item Property

GroupCollection.Item Property

Gets or sets the group at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Group Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Group

Parameters

index

The zero-based index of the group to set or retrieve.

Property Value

An instance of the Group class that represents the group at the specified position.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupEventArgs Class

GroupEventArgs Class

Contains the arguments passed to handlers of group-related events, such as GroupDestroyed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class GroupEventArgs : EventArgs
Visual Basic

Public Class GroupEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.GroupEventArgs

See Also

GroupEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupEventArgs Members

GroupEventArgs Members
Constructors Properties

Contains the arguments passed to handlers of group-related events, such as GroupDestroyed.

The following tables list the members exposed by the GroupEventArgs type.

Public Constructors

Name | Description
GroupEventArgs | Initializes a new instance of the GroupEventArgs class.

Public Properties

Name | Description
Group | Gets the group for which the event was raised.
Index | Gets an integer index related to the event.

See Also

GroupEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupEventArgs Constructor

GroupEventArgs Constructor

Initializes a new instance of the GroupEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public GroupEventArgs (
Group group
)
Visual Basic

Public Sub GroupEventArgs ( _
group As Group _
)

Parameters

group

The Group related to the event.

See Also

GroupEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupEventArgs Properties

GroupEventArgs Properties

Public Properties

Name | Description
Group | Gets the group for which the event was raised.
Index | Gets an integer index related to the event.

See Also

GroupEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupEventArgs.Group Property

GroupEventArgs.Group Property

Gets the group for which the event was raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Group Group { get; }
Visual Basic

Public ReadOnly Property Group As Group

Property Value

An instance of the Group class.

See Also

GroupEventArgs Members
GroupEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupEventArgs.Index Property

GroupEventArgs.Index Property

Gets an integer index related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Index { get; }
Visual Basic

Public ReadOnly Property Index As Integer

Property Value

An integer value.

See Also

GroupEventArgs Members
GroupEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.GroupEventHandler Delegate

GroupEventHandler Delegate

Represents methods that will handle general group-related events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void GroupEventHandler (
Object sender,
GroupEventArgs e
)
Visual Basic

Public Delegate Sub GroupEventHandler ( _
sender As Object, _
e As GroupEventArgs _
)

Parameters

sender

The source of the event.

e
A GroupEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.HandlesStyle Enumeration

HandlesStyle Enumeration

Enumerates possible visual styles for frames that are drawn around selected nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum HandlesStyle
Visual Basic

Public Enumeration HandlesStyle

Members

Member name | Description
Custom | MindFusion.Diagramming raises the DrawAdjustmentHandles and HitTestAdjustmentHandles events to let your application perform custom drawing and hit testing of selection handles.
DashFrame | If selected, a node is drawn with a dashed frame. The frame enables resizing the node. The center of the node allows moving it and the edge area enables creating links.
EasyMove | Any point of the interior of a node enables moving the node, except a small area in the center that allows creating links. Best used with ModificationStart set to AutoHandles.
HatchFrame | If selected, the item is drawn with hatched frame. Modifications can be done as with DashFrame.
HatchHandles | If selected, a node is drawn with both hatched frame and modification handles. The frame enable moving the node, and the handles enable resizing. Links are created from any point of the interior.
HatchHandles2 | Looks like HatchHandles, but allows moving the node from the interior area. Links are created from the points near the edge.
HatchHandles3 | Behaves like HatchHandles2, but paints the selection frame using a denser brush pattern.
Invisible | There is no visible difference between selected and unselected node.
InvisibleMove | There aren't any selection handles displayed. The selected node can be only moved, but not resized.
MoveOnly | If a node is selected, it can be only moved. Best used with ModificationStart set to AutoHandles.
SquareHandles | If selected, the node is drawn with square modification handles.
SquareHandles2 | Square resize handles are drawn around a selected node. There isn't a move handle in the center as with the SquareHandles style, but nodes can be moved by dragging their interior or caption areas. Links can be created by drawing from near the edges of a node.

Remarks

The selection style can be set independently for individual nodes and links through their DiagramNode.HandlesStyle and DiagramLink.HandlesStyle properties. For most of these styles, it is recommended to set ModificationStart to AutoHandles.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.HitTestEventArgs Class

HitTestEventArgs Class

Contains the arguments passed to the HitTestAdjustmentHandles event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class HitTestEventArgs : EventArgs
Visual Basic

Public Class HitTestEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.HitTestEventArgs

See Also

HitTestEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HitTestEventArgs Members

HitTestEventArgs Members
Constructors Properties

Contains the arguments passed to the HitTestAdjustmentHandles event handlers.

The following tables list the members exposed by the HitTestEventArgs type.

Public Constructors

Name | Description
HitTestEventArgs | Initializes a new instance of the HitTestEventArgs class.

Public Properties

Name | Description
HitResult | Gets or sets the index of the selection handle that has been hit.
Item | Gets the item whose adjustment handles are being hit-tested.
MousePosition | Gets the current cursor position, expressed in document coordinates.

See Also

HitTestEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HitTestEventArgs Constructor

HitTestEventArgs Constructor

Initializes a new instance of the HitTestEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public HitTestEventArgs (
DiagramItem item,
PointF mousePosition
)
Visual Basic

Public Sub HitTestEventArgs ( _
item As DiagramItem, _
mousePosition As PointF _
)

Parameters

item

The DiagramItem related to the event.

mousePosition
The cursor location at the time the event is raised, expressed in document coordinates.

See Also

HitTestEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HitTestEventArgs Properties

HitTestEventArgs Properties

Public Properties

Name | Description
HitResult | Gets or sets the index of the selection handle that has been hit.
Item | Gets the item whose adjustment handles are being hit-tested.
MousePosition | Gets the current cursor position, expressed in document coordinates.

See Also

HitTestEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HitTestEventArgs.HitResult Property

HitTestEventArgs.HitResult Property

Gets or sets the index of the selection handle that has been hit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int HitResult { get; set; }
Visual Basic

Public Property HitResult As Integer

Property Value

An integer value specifying the adjustment handle index.

See Also

HitTestEventArgs Members
HitTestEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HitTestEventArgs.Item Property

HitTestEventArgs.Item Property

Gets the item whose adjustment handles are being hit-tested.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; }
Visual Basic

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

HitTestEventArgs Members
HitTestEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HitTestEventArgs.MousePosition Property

HitTestEventArgs.MousePosition Property

Gets the current cursor position, expressed in document coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF MousePosition { get; }
Visual Basic

Public ReadOnly Property MousePosition As PointF

Property Value

A PointF value specifying the current mouse position.

See Also

HitTestEventArgs Members
HitTestEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HitTestEventHandler Delegate

HitTestEventHandler Delegate

Represents methods that will handle hit-testing events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void HitTestEventHandler (
Object sender,
HitTestEventArgs e
)
Visual Basic

Public Delegate Sub HitTestEventHandler ( _
sender As Object, _
e As HitTestEventArgs _
)

Parameters

sender

The source of the event.

e

A HitTestEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.HitTestPriority Enumeration

HitTestPriority Enumeration

Defines values that specify the order of item hit-testing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum HitTestPriority
Visual Basic

Public Enumeration HitTestPriority

Members

Member name | Description
NodesBeforeLinks | Test nodes first, then links.
ZOrder | Test items in decreasing z-order, independently of their types.

See Also

MindFusion.Diagramming Namespace
HitTestPriority Property


MindFusion.Diagramming.HtmlBuilder Class

HtmlBuilder Class
Remarks See Also

Provides methods to create and use HTML client side image maps.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class HtmlBuilder
Visual Basic

Public Class HtmlBuilder

Remarks

If an exported diagram image is displayed in an HTML page, it is helpful to create an image map whose areas correspond to the items visible in the image. The CreateImageMap method generates a full <MAP> tag, including its <AREA> elements. CreateUseMapAttr method creates the code to reference a map from within an <IMG> tag, and also adds a WIDTH and HEIGHT attributes that define to the width and height of the exported image, measured in pixels.

Each <AREA> tag in the image map has its attributes set as follows:

  • HREF is set to the HyperLink value of the diagram item or table's cell corresponding to the area;
  • ALT is set to the ToolTip value of the node or table's cell corresponding to the area;
  • TARGET is set to the value of HtmlBuilder's LinkTarget property.

Image map areas can be also generated for the [±] buttons displayed beside Expandable nodes. To enable that, assign an URL to the ExpandBtnHyperLink property. That URL can contain some format specifiers which are automatically replaced with the values of nodes' Tag or ZIndex properties. That lets you identify on the server side the node whose [±] button is clicked.

HtmlBuilder is most useful when it is used in conjunction with the WebChart library to create diagram images on the server, though it is available in the Windows Forms MindFusion.Diagramming control too.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.HtmlBuilder

See Also

HtmlBuilder Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder Members

HtmlBuilder Members
Constructors Properties Methods Events

Provides methods to create and use HTML client side image maps.

The following tables list the members exposed by the HtmlBuilder type.

Public Constructors

Name | Description
HtmlBuilder | Initializes a new instance of the HtmlBuilder class.

Public Properties

Name | Description
AreasForTableCells | Gets or sets a value indicating whether AREA tags are generated for table cells.
ExpandBtnHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the [±] buttons of Expandable nodes.
LinkTarget | Gets or sets the value of the TARGET attribute of AREA tags.
Scale | Gets or sets the scale factor for the generated image.
ScrollDownHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the lower scroll arrow of tables.
ScrollUpHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the upper scroll arrow of tables.

Public Methods

Name | Description
CreateImageHtml | Generates an image map HTML code.
CreateImageMap | Overloaded.
CreateUseMapAttr | Generates a USEMAP attribute to be used within an <IMG> tag.

Public Events

Name | Description
CreatingArea | Raised just before a new AREA tag is added to the image map.

See Also

HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder Constructor

HtmlBuilder Constructor

Initializes a new instance of the HtmlBuilder class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public HtmlBuilder (
Diagram diagram
)
Visual Basic

Public Sub HtmlBuilder ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram object whose contents will generate the image map.

See Also

HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder Methods

HtmlBuilder Methods

Public Methods

Name | Description
CreateImageHtml | Generates an image map HTML code.
CreateImageMap | Overloaded.
CreateUseMapAttr | Generates a USEMAP attribute to be used within an <IMG> tag.

See Also

HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder.CreateImageHtml Method

HtmlBuilder.CreateImageHtml Method

Generates an image map HTML code.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string CreateImageHtml (
string htmlFileName,
string htmlTitle,
string imgLocalPath,
string imgURL,
ImageFormat imgFormat
)
Visual Basic

Public Function CreateImageHtml ( _
htmlFileName As String, _
htmlTitle As String, _
imgLocalPath As String, _
imgURL As String, _
imgFormat As ImageFormat _
) As String

Parameters

htmlFileName

A string that represents the full name of the HTML file that is created.

htmlTitle
A string that represents the <TITLE> of the HTML file created.
imgLocalPath
A string that specifies the location of the image.
imgURL
A string that specifies the URL of the image at the server.
imgFormat

The image format.

Return Value

A string with the HTML code of the created HTML file.

Remarks

The method also creates an HTML file with attributes specified as parameters.

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder.CreateImageMap Method

HtmlBuilder.CreateImageMap Method

Overload List

Name | Description
HtmlBuilder.CreateImageMap (String) | Creates an HTML code for a MAP tag.
HtmlBuilder.CreateImageMap (String, RectangleF) | Creates an HTML code for a MAP tag.

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder.CreateImageMap Method (String)

HtmlBuilder.CreateImageMap Method (String)
See Also

Creates an HTML code for a MAP tag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string CreateImageMap (
string mapName
)
Visual Basic

Public Function CreateImageMap ( _
mapName As String _
) As String

Parameters

mapName
A string that represents the NAME attribute in the <MAP> tag.

Return Value

A string value containing the generated HTML code.

Remarks

There are <AREA> tags generated for each node or link whose HyperLink is not an empty string. Outlines of items that cannot be represented exactly with standard <AREA> shapes are approximated to polygons. The HREF attribute of the area is set to the value of item's HyperLink property. The ALT attribute is set to the value of item's ToolTip property.

Example

The following HTML code:

HTML

<MAP NAME="diagram1">
<AREA SHAPE ="RECT" COORDS="15,3,650,774" HREF="http://mindfusion.eu" ALT="">
<AREA SHAPE ="POLY" COORDS="198,43,195,48,185,52,170,55,151,57,130,58,109,57,90,55,75,52,65,48,62,43,65,38,75,34,90,31,109,29,130,28,151,29,170,31,185,34,195,38,198,43" HREF="" ALT="">
<AREA SHAPE ="POLY" COORDS="96,85,164,85,198,96,198,119,164,130,96,130,62,119,62,96" HREF="http://mindfusion.eu" ALT="">
<AREA SHAPE ="RECT" COORDS="60,151,196,196" HREF="" ALT="">
<AREA SHAPE ="RECT" COORDS="60,230,196,287" HREF="" ALT="">
</MAP>

is generated from the following code:

C#

HtmlBuilder hb = new HtmlBuilder(diagram);
string htmlCode = hb.CreateImageMap("diagram1");
Visual Basic

Dim hb As HtmlBuilder = New HtmlBuilder(Diagram)
Dim htmlCode As String = hb.CreateImageMap("diagram1")

See Also

CreateImageMap Method Overload List
HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder.CreateImageMap Method (String, RectangleF)

HtmlBuilder.CreateImageMap Method (String, RectangleF)
See Also

Creates an HTML code for a MAP tag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string CreateImageMap (
string mapName,
RectangleF viewport
)
Visual Basic

Public Function CreateImageMap ( _
mapName As String, _
viewport As RectangleF _
) As String

Parameters

mapName
A string that represents the NAME attribute in the <MAP> tag.
viewport
Specifies the diagram region for which to generate an image map.

Return Value

A string value containing the generated HTML code.

See Also

CreateImageMap Method Overload List
HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder.CreateUseMapAttr Method

HtmlBuilder.CreateUseMapAttr Method

Generates a USEMAP attribute to be used within an <IMG> tag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string CreateUseMapAttr (
string mapID
)
Visual Basic

Public Function CreateUseMapAttr ( _
mapID As String _
) As String

Parameters

mapID
A string that represents the ID in the USEMAP attribute of the <IMG> HTML tag.

Return Value

A string that contains the generated HTML code for the USEMAP attribute.

Remarks

Use the same mapID as the one you have passed to CreateImageMap. The method generates also WIDTH and HEIGHT attributes, converting the diagram's MeasureUnit values to pixel values.

Example

The result of this method looks like:

HTML

USEMAP="#diagram1" WIDTH="672" HEIGHT="808"

and is ready to be inserted in your <IMG> tag.

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder Properties

HtmlBuilder Properties

Public Properties

Name | Description
AreasForTableCells | Gets or sets a value indicating whether AREA tags are generated for table cells.
ExpandBtnHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the [±] buttons of Expandable nodes.
LinkTarget | Gets or sets the value of the TARGET attribute of AREA tags.
Scale | Gets or sets the scale factor for the generated image.
ScrollDownHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the lower scroll arrow of tables.
ScrollUpHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the upper scroll arrow of tables.

See Also

HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder.AreasForTableCells Property

HtmlBuilder.AreasForTableCells Property

Gets or sets a value indicating whether AREA tags are generated for table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AreasForTableCells { get; set; }
Visual Basic

Public Property AreasForTableCells As Boolean

Property Value

true to create AREA tags for table cells; otherwise, false. The default is false.

Remarks

If disabled, there is a single <AREA> created for each table, corresponding to the table's bounding rectangle. If enabled, each cell of a table has a corresponding <AREA> tag created and one <AREA> is created for the table's caption bar rectangle.

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming Namespace
Table.Cell.HyperLink Property


MindFusion.Diagramming.HtmlBuilder.ExpandBtnHyperLink Property

HtmlBuilder.ExpandBtnHyperLink Property

Gets or sets the hyperlink assigned to AREA tags generated for the [±] buttons of Expandable nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ExpandBtnHyperLink { get; set; }
Visual Basic

Public Property ExpandBtnHyperLink As String

Property Value

A string value containing an URL. The default is an empty string.

Remarks

If the value of this property is not an empty string, the HtmlBuilder creates <AREA> tags for the expand/collapse buttons displayed besides nodes. That lets you process requests to expand or collapse a tree branch on the server, or just use the [±] button as additional hot spots in the image map. The hyperlink string can contain any of the following format specifiers:

Specifier | Description
{0} | Replaced with the ZIndex of the node associated with the [±] button.
{1} | Replaced with the Tag of the node associated with the [±] button.

The ZIndex of a node can be used to directly access the node within the Items collection, it has the same value as the index of an item within that collection. The Tag can be used to find a node by calling the FindNode method.

Example

To have a JavaScript method called with node's Tag passed as parameter when a [±] button area is clicked, setup an HtmlBuilder instance as shown below:

C#

HtmlBuilder hb = new HtmlBuilder(diagram);
hb.ExpandBtnHyperLink = "javascript: void processExpand({1})";
...
Visual Basic

Dim hb As New HtmlBuilder(diagram)
hb.ExpandBtnHyperLink = "javascript: void processExpand({1})"
...

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder.LinkTarget Property

HtmlBuilder.LinkTarget Property

Gets or sets the value of the TARGET attribute of AREA tags.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string LinkTarget { get; set; }
Visual Basic

Public Property LinkTarget As String

Property Value

A string containing the target frame name. The default is "_self".

Remarks

This property provides a value for the TARGET attribute of each <AREA> tag included in the image map. TARGET indicates the target window or frame where image area hyperlinks are opened. The target could be either a named frame or one of the following special values:

Value | Description
_blank | Loads the linked document into a new blank window.
_parent | Loads the linked document into current document's parent.
_self | Loads the linked document into the same window.
_top | Loads the linked document into the topmost browser window.

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder.Scale Property

HtmlBuilder.Scale Property

Gets or sets the scale factor for the generated image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float Scale { get; set; }
Visual Basic

Public Property Scale As Single

Property Value

A float value that specifies the scale factor for the generated diagram image. The default is 100 (indicating no scale transformation).

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder.ScrollDownHyperLink Property

HtmlBuilder.ScrollDownHyperLink Property

Gets or sets the hyperlink assigned to AREA tags generated for the lower scroll arrow of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ScrollDownHyperLink { get; set; }
Visual Basic

Public Property ScrollDownHyperLink As String

Property Value

A string value containing an URL. The default is an empty string.

Remarks

If the value of this property is not an empty string, the HtmlBuilder creates <AREA> tags for the scroll-down button displayed for Scrollable tables. That lets you process requests to scroll the table rows on the server, or just use the scroll buttons as additional hot spots in the image map. If the URL contains the {0} format specifier, it is replaced with the ZIndex of the clicked table.

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder.ScrollUpHyperLink Property

HtmlBuilder.ScrollUpHyperLink Property

Gets or sets the hyperlink assigned to AREA tags generated for the upper scroll arrow of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ScrollUpHyperLink { get; set; }
Visual Basic

Public Property ScrollUpHyperLink As String

Property Value

A string value containing an URL. The default is an empty string.

Remarks

If the value of this property is not an empty string, the HtmlBuilder creates <AREA> tags for the scroll-down button displayed for Scrollable tables. That lets you process requests to scroll the table rows on the server, or just use the scroll buttons as additional hot spots in the image map. If the URL contains the {0} format specifier, it is replaced with the ZIndex of the clicked table.

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder Events

HtmlBuilder Events

Public Events

Name | Description
CreatingArea | Raised just before a new AREA tag is added to the image map.

See Also

HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HtmlBuilder.CreatingArea Event

HtmlBuilder.CreatingArea Event

Raised just before a new AREA tag is added to the image map.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event AreaEventHandler CreatingArea
Visual Basic

Public Event CreatingArea As AreaEventHandler

Event Data

CreatingArea event handlers receive an argument of type AreaEventArgs. The following AreaEventArgs members provide information relevant to the event:

Member name | Description
AreaTag | The HTML AREA tag created by HtmlBuilder.
Item | The diagram element represented by AreaTag in the image map.
Column | Contains the index of a column if the event is raised for a table cell.
Row | Contains the index of a row if the event is raised for a table cell.

Remarks

You could handle this event in order to insert additional attributes or JavaScript event handlers into the AREA tag. The tag string already ends with a closing ">" when the event is raised, so you must insert any additional attributes one character before the end of the tag string.

Example

The following code adds a JavaScript onClick event handler to the area tag:

C#

private void htb_CreatingArea(object sender, AreaEventArgs e)
{
string script = " onClick=\"alert('click click')\"";
e.AreaTag = e.AreaTag.Insert(e.AreaTag.Length - 1, script);
}
Visual Basic

Private Sub htb_CreatingArea(ByVal sender As Object, ByVal e As AreaEventArgs)

Dim script As String = " onClick=" + Chr(34) + "alert('click click')" + Chr(34)
e.AreaTag = e.AreaTag.Insert(e.AreaTag.Length - 1, script)

End Sub

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.HyperLinkStyle Enumeration

HyperLinkStyle Enumeration

Specifies how various export components should treat the HyperLink property of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum HyperLinkStyle
Visual Basic

Public Enumeration HyperLinkStyle

Members

Member name | Description
None | Do not generate hyperlinks.
Shape | Generate hyperlinks that correspond to the item's shape.
Text | Generate hyperlinks for the text bounding rectangle.

Remarks

At this time, members of this enumeration can be assigned to the HyperLinkStyle property of SvgExporter and PdfExporter.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.IEffectsProvider Interface

IEffectsProvider Interface

Visual effects provider.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public interface IEffectsProvider
Visual Basic

Public Interface IEffectsProvider

See Also

IEffectsProvider Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IEffectsProvider Members

IEffectsProvider Members
Methods

Visual effects provider.

The following tables list the members exposed by the IEffectsProvider type.

Public Methods

Name | Description
GenerateEmboss | Generates an emboss mask for the shape defined by the specified path.
GenerateShadow | Generates a shadow for the shape defined by the specified path.

See Also

IEffectsProvider Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IEffectsProvider Methods

IEffectsProvider Methods

Public Methods

Name | Description
GenerateEmboss | Generates an emboss mask for the shape defined by the specified path.
GenerateShadow | Generates a shadow for the shape defined by the specified path.

See Also

IEffectsProvider Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IEffectsProvider.GenerateEmboss Method

IEffectsProvider.GenerateEmboss Method

Generates an emboss mask for the shape defined by the specified path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract Bitmap GenerateEmboss (
Diagram diagram,
GraphicsPath path
)
Visual Basic

Public MustOverride Function GenerateEmboss ( _
diagram As Diagram, _
path As GraphicsPath _
) As Bitmap

Parameters

diagram

A reference to a Diagram object containing the shape whose emboss mask is being generated.

path

A GraphicsPath that represents of the shape outline.

Return Value

An instance of the .NET Bitmap class containing the generated emboss mask.

See Also

IEffectsProvider Members
IEffectsProvider Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IEffectsProvider.GenerateShadow Method

IEffectsProvider.GenerateShadow Method

Generates a shadow for the shape defined by the specified path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract Bitmap GenerateShadow (
Diagram diagram,
GraphicsPath path,
int dispersion,
Color color
)
Visual Basic

Public MustOverride Function GenerateShadow ( _
diagram As Diagram, _
path As GraphicsPath, _
dispersion As Integer, _
color As Color _
) As Bitmap

Parameters

diagram

A reference to a Diagram object containing the shape whose shadow is being generated.

path

A GraphicsPath that represents of the shape outline.

dispersion

The dispersion factor of the shadow.

color

The color of the shadow.

Return Value

An instance of the .NET Bitmap class containing the generated shadow.

See Also

IEffectsProvider Members
IEffectsProvider Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IItemFactory Interface

IItemFactory Interface

Defines an interface for constructing IPersists objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public interface IItemFactory
Visual Basic

Public Interface IItemFactory

See Also

IItemFactory Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IItemFactory Members

IItemFactory Members
Properties Methods Events

Defines an interface for constructing IPersists objects.

The following tables list the members exposed by the IItemFactory type.

Public Properties

Name | Description
ClsidTable | Gets the table with all registered classes.
TypeTable | Gets the table with all registered classes.

Public Methods

Name | Description
CreateItem | Overloaded. Creates a new object given its class or string identifier.

Public Events

Name | Description
InstantiateItem | Lets external classes handle item instantiation.

See Also

IItemFactory Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IItemFactory Methods

IItemFactory Methods

Public Methods

Name | Description
CreateItem | Overloaded. Creates a new object given its class or string identifier.

See Also

IItemFactory Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IItemFactory.CreateItem Method

IItemFactory.CreateItem Method

Creates a new object given its class or string identifier.

Overload List

Name | Description
IItemFactory.CreateItem (Int32) | Creates a new object given its class id.
IItemFactory.CreateItem (String) | Creates a new object given its item class string identifier.

See Also

IItemFactory Members
IItemFactory Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IItemFactory.CreateItem Method (Int32)

IItemFactory.CreateItem Method (Int32)
See Also

Creates a new object given its class id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract IPersists CreateItem (
int clsId
)
Visual Basic

Public MustOverride Function CreateItem ( _
clsId As Integer _
) As IPersists

Parameters

clsId

The class id of the item to create.

Return Value

An instance of a class implementing the IPersists interface corresponding to the class with the specified id.

See Also

CreateItem Method Overload List
IItemFactory Members
IItemFactory Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IItemFactory.CreateItem Method (String)

IItemFactory.CreateItem Method (String)
See Also

Creates a new object given its item class string identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract IPersists CreateItem (
string itemClass
)
Visual Basic

Public MustOverride Function CreateItem ( _
itemClass As String _
) As IPersists

Parameters

itemClass

The class string id of the item to create.

Return Value

An instance of a class implementing the IPersists interface corresponding to the class with the specified id.

See Also

CreateItem Method Overload List
IItemFactory Members
IItemFactory Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IItemFactory Properties

IItemFactory Properties

Public Properties

Name | Description
ClsidTable | Gets the table with all registered classes.
TypeTable | Gets the table with all registered classes.

See Also

IItemFactory Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IItemFactory.ClsidTable Property

IItemFactory.ClsidTable Property

Gets the table with all registered classes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract Hashtable ClsidTable { get; }
Visual Basic

Public MustOverride ReadOnly Property ClsidTable As Hashtable

Property Value

An instance of the .NET Hashtable class that represents a map between the class types and the corresponding registered classes.

See Also

IItemFactory Members
IItemFactory Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IItemFactory.TypeTable Property

IItemFactory.TypeTable Property

Gets the table with all registered classes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract Hashtable TypeTable { get; }
Visual Basic

Public MustOverride ReadOnly Property TypeTable As Hashtable

Property Value

An instance of the .NET Hashtable class that represents a map between the class string identifiers and the corresponding registered classes.

See Also

IItemFactory Members
IItemFactory Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IItemFactory Events

IItemFactory Events

Public Events

Name | Description
InstantiateItem | Lets external classes handle item instantiation.

See Also

IItemFactory Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IItemFactory.InstantiateItem Event

IItemFactory.InstantiateItem Event

Lets external classes handle item instantiation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public event InstantiateItemEventHandler InstantiateItem
Visual Basic

Public Event InstantiateItem As InstantiateItemEventHandler

See Also

IItemFactory Members
IItemFactory Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InplaceEditable Interface

InplaceEditable Interface

Represents an in-place editable object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public interface InplaceEditable
Visual Basic

Public Interface InplaceEditable

See Also

InplaceEditable Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InplaceEditable Members

InplaceEditable Members
Methods

Represents an in-place editable object.

The following tables list the members exposed by the InplaceEditable type.

Public Methods

Name | Description
GetEditRect | Returns the rectangle where the in-place editing control appears (in document coordinates).
GetTextToEdit | Returns the text of the object which should be displayed initially when the object is in-place edited.
SetEditedText | Sets the edited text to the object after the in-place editing operation has been completed successfully.

See Also

InplaceEditable Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InplaceEditable Methods

InplaceEditable Methods

Public Methods

Name | Description
GetEditRect | Returns the rectangle where the in-place editing control appears (in document coordinates).
GetTextToEdit | Returns the text of the object which should be displayed initially when the object is in-place edited.
SetEditedText | Sets the edited text to the object after the in-place editing operation has been completed successfully.

See Also

InplaceEditable Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InplaceEditable.GetEditRect Method

InplaceEditable.GetEditRect Method

Returns the rectangle where the in-place editing control appears (in document coordinates).

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract RectangleF GetEditRect (
PointF mousePosition
)
Visual Basic

Public MustOverride Function GetEditRect ( _
mousePosition As PointF _
) As RectangleF

Parameters

mousePosition
A PointF instance specifying the mouse position.

Return Value

A .NET RectangleF instance that represents the destination rectangle of the in-place editing control.

See Also

InplaceEditable Members
InplaceEditable Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InplaceEditable.GetTextToEdit Method

InplaceEditable.GetTextToEdit Method

Returns the text of the object which should be displayed initially when the object is in-place edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract string GetTextToEdit ()
Visual Basic

Public MustOverride Function GetTextToEdit () As String

Return Value

A string value that represents the initial contents of the in-place editing box.

See Also

InplaceEditable Members
InplaceEditable Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InplaceEditable.SetEditedText Method

InplaceEditable.SetEditedText Method

Sets the edited text to the object after the in-place editing operation has been completed successfully.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract void SetEditedText (
string newText
)
Visual Basic

Public MustOverride Sub SetEditedText ( _
newText As String _
)

Parameters

newText

The new text of the in-place edited object.

See Also

InplaceEditable Members
InplaceEditable Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InstantiateItemEventArgs Class

InstantiateItemEventArgs Class

Contains the arguments passed to the InstantiateItem event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class InstantiateItemEventArgs : EventArgs
Visual Basic

Public Class InstantiateItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.InstantiateItemEventArgs

See Also

InstantiateItemEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InstantiateItemEventArgs Members

InstantiateItemEventArgs Members
Constructors Properties

Contains the arguments passed to the InstantiateItem event handlers.

The following tables list the members exposed by the InstantiateItemEventArgs type.

Public Constructors

Name | Description
InstantiateItemEventArgs | Initializes a new instance of the InstantiateItemEventArgs class.

Public Properties

Name | Description
Item | Gets or sets a reference to the created diagram item.
ItemClass | Gets the item class identifier.

See Also

InstantiateItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InstantiateItemEventArgs Constructor

InstantiateItemEventArgs Constructor

Initializes a new instance of the InstantiateItemEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public InstantiateItemEventArgs (
string itemClass
)
Visual Basic

Public New ( _
itemClass As String _
)

Parameters

itemClass

The class string identifier specifying the type of the new item.

See Also

InstantiateItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InstantiateItemEventArgs Properties

InstantiateItemEventArgs Properties

Public Properties

Name | Description
Item | Gets or sets a reference to the created diagram item.
ItemClass | Gets the item class identifier.

See Also

InstantiateItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InstantiateItemEventArgs.Item Property

InstantiateItemEventArgs.Item Property

Gets or sets a reference to the created diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; set; }
Visual Basic

Public Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InstantiateItemEventArgs.ItemClass Property

InstantiateItemEventArgs.ItemClass Property

Gets the item class identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ItemClass { get; }
Visual Basic

Public ReadOnly Property ItemClass As String

Property Value

A string value specifying the item class identifier.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InstantiateItemEventHandler Delegate

InstantiateItemEventHandler Delegate

Represents methods that will handle item instantiation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void InstantiateItemEventHandler (
Object sender,
InstantiateItemEventArgs e
)
Visual Basic

Public Delegate Sub InstantiateItemEventHandler ( _
sender As Object, _
e As InstantiateItemEventArgs _
)

Parameters

sender

The source of the event.

e

An InstantiateItemEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState Class

InteractionState Class
Remarks See Also

Encapsulates the current state of user interaction with the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class InteractionState
Visual Basic

Public Class InteractionState

Remarks

Return an instance of this class from the StartDraw method of a custom Behavior class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.InteractionState

See Also

InteractionState Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState Members

InteractionState Members
Constructors Properties Methods

Encapsulates the current state of user interaction with the control.

The following tables list the members exposed by the InteractionState type.

Public Constructors

Name | Description
InteractionState | Initializes a new instance of the InteractionState class.

Public Properties

Name | Description
Action | Gets the type of Action currently performed by the user in the Diagram.
AdjustmentHandle | Gets the index of the selection handle to be modified.
CurrentItem | Gets a reference to the DiagramItem to be created or modified.
CurrentPoint | Gets the current location of the mouse pointer.
Diagram | Gets the current Diagram instance.
InvalidRect | Gets or sets the area that should be repainted.
LinkTarget | Gets or sets the current target node when a link is being modified.
MouseMoved | Gets or sets a value indicating whether the mouse pointer has moved since the user pressed down the mouse button.
StartPoint | Gets the mouse position where the interaction started.

Public Methods

Name | Description
Cancel | Cancels the user interaction.
CancelNow | Instruct the interaction to terminate on the next pass.
Complete | This method is invoked to complete the interaction, usually when the user releases the left mouse button.
IsAllowed | Checks whether the current interaction can be completed at the specified point.
IsCompleting | Returns whether the interaction has been completed successfully.
SetHandleIndex | Sets the modified selection handle to the handle with the specified index.
SetItemDeleted | Notifies the interaction that its associated diagram item has been deleted.
ShouldCancelDrag | Gets a value indicating whether the interaction should terminate on the next pass.
Start | This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.
Update | This method is invoked to update the interaction state, usually in response to the user moving the mouse after the modification has started.
ValidateAndSetCursor | Sets the cursor depending on whether the interaction can be completed at the specified point or not.

See Also

InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState Constructor

InteractionState Constructor

Initializes a new instance of the InteractionState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public InteractionState (
DiagramItem currentItem,
int adjustmentHandle,
Action action
)
Visual Basic

Public Sub InteractionState ( _
currentItem As DiagramItem, _
adjustmentHandle As Integer, _
action As Action _
)

Parameters

currentItem
The DiagramItem to be created or modified.
adjustmentHandle
The index of the selection handle to be dragged with the mouse, defines what kind of modification to perform.
action
One of the Action enumeration values, specifying what kind of action to perform.

Remarks

The selectionHandle argument is ignored when creating new items. When modifying a link, that index corresponds to the index of the link's control point being moved. When modifying a node, the index must have a value in the range 0..9 as specified below:

Value | Description
0 | Top-left corner modification handle, used to resize nodes.
1 | Top-right corner modification handle, used to resize nodes.
2 | Bottom-right corner modification handle, used to resize nodes.
3 | Bottom-left corner modification handle, used to resize nodes.
4 | Top-center modification handle, used to resize nodes vertically.
5 | Middle-right modification handle, used to resize nodes horizontally.
6 | Bottom-center modification handle, used to resize nodes vertically.
7 | Middle-left modification handle, used to resize nodes horizontally.
8 | The center handle, used to move nodes.
9 | The rotation handle, used to rotate nodes.

See Also

InteractionState Class
MindFusion.Diagramming Namespace
Behavior.StartDraw


MindFusion.Diagramming.InteractionState Methods

InteractionState Methods

Public Methods

Name | Description
Cancel | Cancels the user interaction.
CancelNow | Instruct the interaction to terminate on the next pass.
Complete | This method is invoked to complete the interaction, usually when the user releases the left mouse button.
IsAllowed | Checks whether the current interaction can be completed at the specified point.
IsCompleting | Returns whether the interaction has been completed successfully.
SetHandleIndex | Sets the modified selection handle to the handle with the specified index.
SetItemDeleted | Notifies the interaction that its associated diagram item has been deleted.
ShouldCancelDrag | Gets a value indicating whether the interaction should terminate on the next pass.
Start | This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.
Update | This method is invoked to update the interaction state, usually in response to the user moving the mouse after the modification has started.
ValidateAndSetCursor | Sets the cursor depending on whether the interaction can be completed at the specified point or not.

See Also

InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.Cancel Method

InteractionState.Cancel Method

Cancels the user interaction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Cancel (
Diagram diagram
)
Visual Basic

Public Sub Cancel ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram, at which the action is performed.

Remarks

Call this method to cancel interaction, usually in response to the user clicking the right mouse button while dragging.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace
CancelNow


MindFusion.Diagramming.InteractionState.CancelNow Method

InteractionState.CancelNow Method

Instruct the interaction to terminate on the next pass.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void CancelNow ()
Visual Basic

Public Sub CancelNow ()

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace
Cancel


MindFusion.Diagramming.InteractionState.Complete Method

InteractionState.Complete Method

This method is invoked to complete the interaction, usually when the user releases the left mouse button.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Complete (
PointF point,
Diagram diagram
)
Visual Basic

Public Sub Complete ( _
point As PointF, _
diagram As Diagram _
)

Parameters

point

A .NET PointF instance indicating the location of the cursor, in document coordinates.

diagram
The Diagram, at which the action is performed.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace
IsCompleting


MindFusion.Diagramming.InteractionState.IsAllowed Method

InteractionState.IsAllowed Method

Checks whether the current interaction can be completed at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool IsAllowed (
PointF point
)
Visual Basic

Public Function IsAllowed ( _
point As PointF _
) As Boolean

Parameters

point

A .NET PointF instance indicating the location of the cursor, in document coordinates.

Return Value

true if the action can be completed at point; otherwise, false.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.IsCompleting Method

InteractionState.IsCompleting Method

Returns whether the interaction has been completed successfully.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool IsCompleting ()
Visual Basic

Public Function IsCompleting () As Boolean

Return Value

true if the interaction has been completed successfully; otherwise, false.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace
Complete


MindFusion.Diagramming.InteractionState.SetHandleIndex Method

InteractionState.SetHandleIndex Method

Sets the modified selection handle to the handle with the specified index.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SetHandleIndex (
int newIndex
)
Visual Basic

Public Sub SetHandleIndex ( _
newIndex As Integer _
)

Parameters

newIndex

An integer value that specifies the index of the handle at which the modified selection handle should be set.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.SetItemDeleted Method

InteractionState.SetItemDeleted Method

Notifies the interaction that its associated diagram item has been deleted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SetItemDeleted ()
Visual Basic

Public Sub SetItemDeleted ()

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.ShouldCancelDrag Method

InteractionState.ShouldCancelDrag Method

Gets a value indicating whether the interaction should terminate on the next pass.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ShouldCancelDrag ()
Visual Basic

Public Function ShouldCancelDrag () As Boolean

Return Value

true if the interaction should terminate; otherwise, false.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.Start Method

InteractionState.Start Method

This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Start (
PointF point,
Diagram diagram
)
Visual Basic

Public Sub Start ( _
point As PointF, _
diagram As Diagram _
)

Parameters

point

A .NET PointF instance indicating the location of the cursor, in document coordinates.

diagram
The Diagram, at which the interaction is performed.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.Update Method

InteractionState.Update Method

This method is invoked to update the interaction state, usually in response to the user moving the mouse after the modification has started.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Update (
PointF point,
Diagram diagram
)
Visual Basic

Public Function Update ( _
point As PointF, _
diagram As Diagram _
) As Boolean

Parameters

point

A .NET PointF instance indicating the location of the cursor, in document coordinates.

diagram
The Diagram, at which the interaction is performed.

Return Value

true if the update has been successful; otherwise, false.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.ValidateAndSetCursor Method

InteractionState.ValidateAndSetCursor Method

Sets the cursor depending on whether the interaction can be completed at the specified point or not.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CursorHint ValidateAndSetCursor (
PointF point,
Diagram diagram
)
Visual Basic

Public Function ValidateAndSetCursor ( _
point As PointF, _
diagram As Diagram _
) As CursorHint

Parameters

point

A .NET PointF instance indicating the location of the cursor, in document coordinates.

diagram

The Diagram, at which the interaction is performed.

Return Value

One of the CursorHint enumeration values, which is used by DiagramView to set its Cursor property. The method might return CursorHint.DontChange and the cursor will be left as it is.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState Properties

InteractionState Properties

Public Properties

Name | Description
Action | Gets the type of Action currently performed by the user in the Diagram.
AdjustmentHandle | Gets the index of the selection handle to be modified.
CurrentItem | Gets a reference to the DiagramItem to be created or modified.
CurrentPoint | Gets the current location of the mouse pointer.
Diagram | Gets the current Diagram instance.
InvalidRect | Gets or sets the area that should be repainted.
LinkTarget | Gets or sets the current target node when a link is being modified.
MouseMoved | Gets or sets a value indicating whether the mouse pointer has moved since the user pressed down the mouse button.
StartPoint | Gets the mouse position where the interaction started.

See Also

InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.Action Property

InteractionState.Action Property

Gets the type of Action currently performed by the user in the Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Action Action { get; }
Visual Basic

Public ReadOnly Property Action As Action

Property Value

A member of the Action enumeration that specifies what kind of action the user currently performes on the Diagram.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.AdjustmentHandle Property

InteractionState.AdjustmentHandle Property

Gets the index of the selection handle to be modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int AdjustmentHandle { get; }
Visual Basic

Public ReadOnly Property AdjustmentHandle As Integer

Property Value

An integer value specifying the index of the handle to be modified.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.CurrentItem Property

InteractionState.CurrentItem Property

Gets a reference to the DiagramItem to be created or modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem CurrentItem { get; }
Visual Basic

Public ReadOnly Property CurrentItem As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.CurrentPoint Property

InteractionState.CurrentPoint Property

Gets the current location of the mouse pointer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF CurrentPoint { get; }
Visual Basic

Public ReadOnly Property CurrentPoint As PointF

Property Value

A .NET PointF instance that specifies the current location of the cursor, in document coordinates.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.Diagram Property

InteractionState.Diagram Property

Gets the current Diagram instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Diagram Diagram { get; }
Visual Basic

Public ReadOnly Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.InvalidRect Property

InteractionState.InvalidRect Property

Gets or sets the area that should be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF InvalidRect { get; set; }
Visual Basic

Public Property InvalidRect As RectangleF

Property Value

A RectangleF specifying a rectangular region of the diagram that should be repainted.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.LinkTarget Property

InteractionState.LinkTarget Property

Gets or sets the current target node when a link is being modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode LinkTarget { get; set; }
Visual Basic

Public Property LinkTarget As DiagramNode

Property Value

A DiagramNode that the currently modified DiagramLink should connect to if the interaction completes at the current mouse position.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.MouseMoved Property

InteractionState.MouseMoved Property

Gets or sets a value indicating whether the mouse pointer has moved since the user pressed down the mouse button.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool MouseMoved { get; set; }
Visual Basic

Public Property MouseMoved As Boolean

Property Value

true is the mouse has moved; otherwise, false.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InteractionState.StartPoint Property

InteractionState.StartPoint Property

Gets the mouse position where the interaction started.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF StartPoint { get; }
Visual Basic

Public ReadOnly Property StartPoint As PointF

Property Value

A PointF specifying the mouse position where the user started to draw or modify an item.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils Class

InternalUtils Class
Remarks See Also

Contains common helper methods, specific to MindFusion.Diagramming.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public sealed class InternalUtils
Visual Basic

Public NotInheritable Class InternalUtils

Remarks

This class supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.InternalUtils

See Also

InternalUtils Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils Members

InternalUtils Members
Methods

Contains common helper methods, specific to MindFusion.Diagramming.

The following tables list the members exposed by the InternalUtils type.

Public Methods

Name | Description
AddToRect | Inflate/deflate the specified rectangle with the specified values.
ApproxBezier | Approximates the specified Bézier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
ApproxEllipse | Approximates the ellipse contained in the specified rectanlge with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
CreateEllipticRgn | Creates an elliptic region.
CreatePolygonRgn | Creates a polygonal region.
CreateRoundRectRgn | Creates a round rectangle region.
DistanceSq | Calculates the square of the distance between the specified points.
DrawExpandButton | Renders an expand/collapse button to the specified graphics.
DrawRect | Draws the specified rectangle using the specified pen for stroking and the specified brush for filling.
GetLoadedAssembly | Gets the specified assembly.
GetLoadedType | Gets the type with the specified name from the specified assembly.
GetRoundRect | Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.
MatchPointsMinLength | Returns an array of node anchor points which match current node links anchor point
MidPoint | Returns the middle point of the segment defined by the specified points.
NormalizeRect | Overloaded. Normalizes the specified rectangle.
PointInRect | Overloaded. Checks whether the specified rectangle contains the specified point.
RectangleToPoints | Returns the points of the specified rectangle as an array.
UnionNonEmptyRects | Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.
UnionRects | Returns the smallest possible rectangle containing both of the specified rectangles.

See Also

InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils Methods

InternalUtils Methods

Public Methods

Name | Description
AddToRect | Inflate/deflate the specified rectangle with the specified values.
ApproxBezier | Approximates the specified Bézier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
ApproxEllipse | Approximates the ellipse contained in the specified rectanlge with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
CreateEllipticRgn | Creates an elliptic region.
CreatePolygonRgn | Creates a polygonal region.
CreateRoundRectRgn | Creates a round rectangle region.
DistanceSq | Calculates the square of the distance between the specified points.
DrawExpandButton | Renders an expand/collapse button to the specified graphics.
DrawRect | Draws the specified rectangle using the specified pen for stroking and the specified brush for filling.
GetLoadedAssembly | Gets the specified assembly.
GetLoadedType | Gets the type with the specified name from the specified assembly.
GetRoundRect | Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.
MatchPointsMinLength | Returns an array of node anchor points which match current node links anchor point
MidPoint | Returns the middle point of the segment defined by the specified points.
NormalizeRect | Overloaded. Normalizes the specified rectangle.
PointInRect | Overloaded. Checks whether the specified rectangle contains the specified point.
RectangleToPoints | Returns the points of the specified rectangle as an array.
UnionNonEmptyRects | Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.
UnionRects | Returns the smallest possible rectangle containing both of the specified rectangles.

See Also

InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.AddToRect Method

InternalUtils.AddToRect Method

Inflate/deflate the specified rectangle with the specified values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static void AddToRect (
ref RectangleF rect,
float w,
float h
)
Visual Basic

Public Shared Sub AddToRect ( _
ByRef rect As RectangleF, _
w As Single, _
h As Single _
)

Parameters

rect

The .NET RectangleF instance that must be modified.

w

The increment/decrement of the rectangle width.

h

The increment/decrement of the rectangle height.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.ApproxBezier Method

InternalUtils.ApproxBezier Method

Approximates the specified Bézier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static PointCollection ApproxBezier (
PointF[] points,
int startIdx,
int quality
)
Visual Basic

Public Shared Function ApproxBezier ( _
points As PointF(), _
startIdx As Integer, _
quality As Integer _
) As PointCollection

Parameters

points

An array of PointF objects, which defines the Bézier curve.

startIdx
The index of the first point to be processed in points.
quality

The quality of the produced approximation.

Return Value

An instance of the PointCollection class containing the points of the calculated approximation.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.ApproxEllipse Method

InternalUtils.ApproxEllipse Method

Approximates the ellipse contained in the specified rectanlge with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static PointCollection ApproxEllipse (
RectangleF rect,
int quality
)
Visual Basic

Public Shared Function ApproxEllipse ( _
rect As RectangleF, _
quality As Integer _
) As PointCollection

Parameters

rect

A RectangleF instance, which defines the source ellipse.

quality

The quality of the produced approximation.

Return Value

An instance of the PointCollection class containing the points of the calculated approximation.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.CreateEllipticRgn Method

InternalUtils.CreateEllipticRgn Method

Creates an elliptic region.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Region CreateEllipticRgn (
RectangleF rc
)
Visual Basic

Public Shared Function CreateEllipticRgn ( _
rc As RectangleF _
) As Region

Parameters

rc

A RectangleF instance, which defines the source ellipse.

Return Value

An instance of the .NET Region class.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.CreatePolygonRgn Method

InternalUtils.CreatePolygonRgn Method

Creates a polygonal region.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Region CreatePolygonRgn (
PointF[] poly
)
Visual Basic

Public Shared Function CreatePolygonRgn ( _
poly() As PointF _
) As Region

Parameters

poly
An array of PointF objects, which defines the source polygon.

Return Value

An instance of the .NET Region class.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.CreateRoundRectRgn Method

InternalUtils.CreateRoundRectRgn Method

Creates a round rectangle region.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Region CreateRoundRectRgn (
RectangleF rc,
float r
)
Visual Basic

Public Shared Function CreateRoundRectRgn ( _
rc As RectangleF, _
r As Single _
) As Region

Parameters

rc
A RectangleF instance, which defines the rounded rectangle bounds.
r

The radius of the rectangle corners.

Return Value

An instance of the .NET Region class.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.DistanceSq Method

InternalUtils.DistanceSq Method

Calculates the square of the distance between the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static float DistanceSq (
PointF pt1,
PointF pt2
)
Visual Basic

Public Shared Function DistanceSq ( _
pt1 As PointF, _
pt2 As PointF _
) As Single

Parameters

pt1
pt2

Return Value

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.DrawExpandButton Method

InternalUtils.DrawExpandButton Method

Renders an expand/collapse button to the specified graphics.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static void DrawExpandButton (
IGraphics graphics,
bool expanded,
RectangleF bounds,
GraphicsUnit measureUnit,
bool withShadow,
Color shadowColor
)
Visual Basic

Public Shared Sub DrawExpandButton ( _
graphics As IGraphics, _
expanded As Boolean, _
bounds As RectangleF, _
measureUnit As GraphicsUnit, _
withShadow As Boolean, _
shadowColor As Color _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

expanded

Specifies whether the drawn button is expanded or collapsed.

bounds

The destination rectangle of the button.

measureUnit

The current measure unit.

withShadow

Specifies whether to draw button shadow.

shadowColor

The color of the shadow.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.DrawRect Method

InternalUtils.DrawRect Method

Draws the specified rectangle using the specified pen for stroking and the specified brush for filling.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static void DrawRect (
IGraphics graphics,
Pen p,
Brush b,
float x,
float y,
float width,
float height
)
Visual Basic

Public Shared Sub DrawRect ( _
graphics As IGraphics, _
p As Pen, _
b As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

p

The System.Drawing.Pen to use when drawing the outline.

b

The System.Drawing.Brush to use when filling the contents.

x

The x-coordinate of the top-left corner of the drawn rectangle.

y

The y-coordinate of the top-left corner of the drawn rectangle.

width

The width of the drawn rectangle.

height

The height of the drawn rectangle.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.GetLoadedAssembly Method

InternalUtils.GetLoadedAssembly Method

Gets the specified assembly.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Assembly GetLoadedAssembly (
string asmName
)
Visual Basic

Public Shared Function GetLoadedAssembly ( _
asmName As String _
) As Assembly

Parameters

asmName

The full name of the assembly.

Return Value

An instance of the .NET Assembly class.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.GetLoadedType Method

InternalUtils.GetLoadedType Method

Gets the type with the specified name from the specified assembly.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Type GetLoadedType (
string typeName,
string asmName
)
Visual Basic

Public Shared Function GetLoadedType ( _
typeName As String, _
asmName As String _
) As Type

Parameters

typeName

The full name of the type.

asmName

The full name of the containing assembly.

Return Value

An instance of the .NET Type class.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.GetRoundRect Method

InternalUtils.GetRoundRect Method

Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static GraphicsPath GetRoundRect (
float x,
float y,
float width,
float height,
float r
)
Visual Basic

Public Shared Function GetRoundRect ( _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
r As Single _
) As GraphicsPath

Parameters

x
The x-coordinate of the top-left corner of the rectangle.
y

The y-coordinate of the top-left corner of the rectangle.

width

The width of the rectangle.

height

The height of the rectangle.

r

The radius of the rectangle corners.

Return Value

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.MatchPointsMinLength Method

InternalUtils.MatchPointsMinLength Method

Returns an array of node anchor points which match current node links anchor point

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static int[] MatchPointsMinLength (
PointF[] nodeAnchorPoints,
int[] pointRealIndexes,
PointF[] fixedLinksAnchorPoints,
List<Int32> usedAnchorPointIndexes
)
Visual Basic

Public Shared Function MatchPointsMinLength ( _
nodeAnchorPoints() As PointF, _
pointRealIndexes() As Integer, _
fixedLinksAnchorPoints() As PointF, _
usedAnchorPointIndexes As List(Of Int32) _
) As Integer()

Parameters

nodeAnchorPoints
pointRealIndexes
fixedLinksAnchorPoints
usedAnchorPointIndexes

Return Value

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.MidPoint Method

InternalUtils.MidPoint Method

Returns the middle point of the segment defined by the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static PointF MidPoint (
PointF pt1,
PointF pt2
)
Visual Basic

Public Shared Function MidPoint ( _
pt1 As PointF, _
pt2 As PointF _
) As PointF

Parameters

pt1

The first point.

pt2

The second point.

Return Value

A .NET PointF instance that represents the middle point.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.NormalizeRect Method

InternalUtils.NormalizeRect Method

Normalizes the specified rectangle.

Overload List

Name | Description
InternalUtils.NormalizeRect (Rectangle) | Normalizes the specified rectangle ensuring its height and width are non-negative numbers.
InternalUtils.NormalizeRect (RectangleF) | Normalizes the specified rectangle ensuring its height and width are non-negative numbers.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.NormalizeRect Method (Rectangle)

InternalUtils.NormalizeRect Method (Rectangle)
See Also

Normalizes the specified rectangle ensuring its height and width are non-negative numbers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Rectangle NormalizeRect (
Rectangle rc
)
Visual Basic

Public Shared Function NormalizeRect ( _
rc As Rectangle _
) As Rectangle

Parameters

rc
The .NET Rectangle to be normalized.

Return Value

A .NET Rectangle instance that represents the normalized rectangle.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

NormalizeRect Method Overload List
InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.NormalizeRect Method (RectangleF)

InternalUtils.NormalizeRect Method (RectangleF)
See Also

Normalizes the specified rectangle ensuring its height and width are non-negative numbers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static RectangleF NormalizeRect (
RectangleF rc
)
Visual Basic

Public Shared Function NormalizeRect ( _
rc As RectangleF _
) As RectangleF

Parameters

rc

The .NET RectangleF to be normalized.

Return Value

A .NET RectangleF instance that represents the normalized rectangle.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

NormalizeRect Method Overload List
InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.PointInRect Method

InternalUtils.PointInRect Method

Checks whether the specified rectangle contains the specified point.

Overload List

Name | Description
InternalUtils.PointInRect (Point, Rectangle) | Checks whether the specified rectangle contains the specified point.
InternalUtils.PointInRect (PointF, RectangleF) | Checks whether the specified rectangle contains the specified point.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.PointInRect Method (Point, Rectangle)

InternalUtils.PointInRect Method (Point, Rectangle)
See Also

Checks whether the specified rectangle contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static bool PointInRect (
Point pt,
Rectangle rc
)
Visual Basic

Public Shared Function PointInRect ( _
pt As Point, _
rc As Rectangle _
) As Boolean

Parameters

pt

The point to be checked.

rc

The rectangle to be checked.

Return Value

true if the specified rectangle contains the specified point; otherwise, false.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

PointInRect Method Overload List
InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.PointInRect Method (PointF, RectangleF)

InternalUtils.PointInRect Method (PointF, RectangleF)
See Also

Checks whether the specified rectangle contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static bool PointInRect (
PointF pt,
RectangleF rc
)
Visual Basic

Public Shared Function PointInRect ( _
pt As PointF, _
rc As RectangleF _
) As Boolean

Parameters

pt

The point to be checked.

rc

The rectangle to be checked.

Return Value

true if the specified rectangle contains the specified point; otherwise, false.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

PointInRect Method Overload List
InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.RectangleToPoints Method

InternalUtils.RectangleToPoints Method

Returns the points of the specified rectangle as an array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static PointF[] RectangleToPoints (
RectangleF r
)
Visual Basic

Public Shared Function RectangleToPoints ( _
r As RectangleF _
) As PointF()

Parameters

r

The source rectangle.

Return Value

An array of PointF objects, which contains the vertices of the rectangle.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.UnionNonEmptyRects Method

InternalUtils.UnionNonEmptyRects Method

Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static RectangleF UnionNonEmptyRects (
RectangleF rc1,
RectangleF rc2
)
Visual Basic

Public Shared Function UnionNonEmptyRects ( _
rc1 As RectangleF, _
rc2 As RectangleF _
) As RectangleF

Parameters

rc1

The first rectangle.

rc2

The second rectangle.

Return Value

A .NET RectangleF instance that represents the union of the specified arguments.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.InternalUtils.UnionRects Method

InternalUtils.UnionRects Method

Returns the smallest possible rectangle containing both of the specified rectangles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static RectangleF UnionRects (
RectangleF a,
RectangleF b
)
Visual Basic

Public Shared Function UnionRects ( _
a As RectangleF, _
b As RectangleF _
) As RectangleF

Parameters

a

The first rectangle.

b

The second rectangle.

Return Value

A .NET RectangleF instance that represents the union of the specified arguments.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IPersists Interface

IPersists Interface
Remarks See Also

Base interface for serializable MindFusion.Diagramming objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public interface IPersists
Visual Basic

Public Interface IPersists

Remarks

Serializable MindFusion.Diagramming classes implement explicitly this interface to hide it from the public. Explicit implementation however has the restrictions that the implemented methods are private and non-polymorphic. To avoid these limitations each implementing class provides another set of methods corresponding to the IPersists methods, which are declared as internal and retain polymorphism.

Example

The following sample class illustrates this technique:

C#

class PersistingItem : IPersists
{
int IPersists.GetClassId()
{
return GetClassIdInternal();
}

void IPersists.SaveTo(BinaryWriter writer, PersistContext ctx)
{
SaveToInternal(writer, ctx);
}

void IPersists.LoadFrom(BinaryReader reader, PersistContext ctx)
{
LoadFromInternal(reader, ctx);
}

void IPersists.SetReference(int refId, object obj)
{
SetReferenceInternal(refId, obj);
}

internal virtual int GetClassId()
{
return ClassId;
}

internal virtual void SaveTo(BinaryWriter writer, PersistContext ctx)
{
}

internal virtual void LoadFrom(BinaryReader reader, PersistContext ctx)
{
}

internal virtual void SetReference(int refId, object obj)
{
}
}

See Also

IPersists Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IPersists Members

IPersists Members
Methods

Base interface for serializable MindFusion.Diagramming objects.

The following tables list the members exposed by the IPersists type.

Public Methods

Name | Description
GetClassId | Returns the id of the implementing class.
LoadFrom | Deserializes the object from the specified binary reader.
SaveTo | Serializes the object to the specified binary writer.
SetReference | Updates the reference to the specified object.

See Also

IPersists Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IPersists Methods

IPersists Methods

Public Methods

Name | Description
GetClassId | Returns the id of the implementing class.
LoadFrom | Deserializes the object from the specified binary reader.
SaveTo | Serializes the object to the specified binary writer.
SetReference | Updates the reference to the specified object.

See Also

IPersists Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IPersists.GetClassId Method

IPersists.GetClassId Method

Returns the id of the implementing class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract int GetClassId ()
Visual Basic

Public MustOverride Function GetClassId () As Integer

Return Value

An integer value specifying a unique id for the implementing class.

See Also

IPersists Members
IPersists Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IPersists.LoadFrom Method

IPersists.LoadFrom Method

Deserializes the object from the specified binary reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract void LoadFrom (
BinaryReader reader,
PersistContext ctx
)
Visual Basic

Public MustOverride Sub LoadFrom ( _
reader As BinaryReader, _
ctx As PersistContext _
)

Parameters

reader

The .NET BinaryReader object to read from.

ctx

A PersistContext object supplying all necessary information during deserialization.

See Also

IPersists Members
IPersists Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IPersists.SaveTo Method

IPersists.SaveTo Method

Serializes the object to the specified binary writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract void SaveTo (
BinaryWriter writer,
PersistContext ctx
)
Visual Basic

Public MustOverride Sub SaveTo ( _
writer As BinaryWriter, _
ctx As PersistContext _
)

Parameters

writer

The .NET BinaryWriter object to write to.

ctx

A PersistContext object supplying all necessary information during serialization.

See Also

IPersists Members
IPersists Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.IPersists.SetReference Method

IPersists.SetReference Method

Updates the reference to the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract void SetReference (
int refId,
Object obj,
PersistContext ctx
)
Visual Basic

Public MustOverride Sub SetReference ( _
refId As Integer, _
obj As Object, _
ctx As PersistContext _
)

Parameters

refId

The local identifier of the referenced object.

obj

The referenced object.

ctx
A PersistContext object supplying all necessary information during deserialization.

See Also

IPersists Members
IPersists Interface
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemCollectionBase Class

ItemCollectionBase Class

A base collection class for the diagram item collections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract class ItemCollectionBase : PersistableCollection
Visual Basic

Public MustInherit Class ItemCollectionBase
Inherits PersistableCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.PersistableCollection
MindFusion.Diagramming.ItemCollectionBase
MindFusion.Diagramming.DiagramItemCollection
MindFusion.Diagramming.DiagramLinkCollection
MindFusion.Diagramming.DiagramNodeCollection

See Also

ItemCollectionBase Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemCollectionBase Members

ItemCollectionBase Members
Fields Methods

A base collection class for the diagram item collections.

The following tables list the members exposed by the ItemCollectionBase type.

Protected Fields

Name | Description
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Public Methods

Name | Description
Clear | Removes all diagram items from the collection.

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

ItemCollectionBase Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemCollectionBase Fields

ItemCollectionBase Fields

Protected Fields

Name | Description
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

See Also

ItemCollectionBase Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemCollectionBase.itemEventArgs Field

ItemCollectionBase.itemEventArgs Field

A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected ItemEventArgs itemEventArgs
Visual Basic

Protected itemEventArgs As ItemEventArgs

See Also

ItemCollectionBase Members
ItemCollectionBase Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemCollectionBase.notifyParent Field

ItemCollectionBase.notifyParent Field

If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected bool notifyParent
Visual Basic

Protected notifyParent As Boolean

See Also

ItemCollectionBase Members
ItemCollectionBase Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemCollectionBase Methods

ItemCollectionBase Methods

Public Methods

Name | Description
Clear | Removes all diagram items from the collection.

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

ItemCollectionBase Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemCollectionBase.Clear Method

ItemCollectionBase.Clear Method

Removes all diagram items from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

ItemCollectionBase Members
ItemCollectionBase Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemCollectionBase.RaiseAdding Method

ItemCollectionBase.RaiseAdding Method

Raises the Adding event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void RaiseAdding (
DiagramItem item
)
Visual Basic

Protected Sub RaiseAdding ( _
item As DiagramItem _
)

Parameters

item
The diagram item that is being added.

See Also

ItemCollectionBase Members
ItemCollectionBase Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemCollectionBase.RaiseInserting Method

ItemCollectionBase.RaiseInserting Method

Raises the Inserting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void RaiseInserting (
DiagramItem item,
int index
)
Visual Basic

Protected Sub RaiseInserting ( _
item As DiagramItem, _
index As Integer _
)

Parameters

item
The diagram item that is being inserted.
index
Index of the new item.

See Also

ItemCollectionBase Members
ItemCollectionBase Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemCollectionBase.RaiseRemoving Method

ItemCollectionBase.RaiseRemoving Method

Raises the Removing event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void RaiseRemoving (
DiagramItem item
)
Visual Basic

Protected Sub RaiseRemoving ( _
item As DiagramItem _
)

Parameters

item
The diagram item that is being removed.

See Also

ItemCollectionBase Members
ItemCollectionBase Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemEventArgs Class

ItemEventArgs Class

Contains the arguments passed to item instantiation event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ItemEventArgs : EventArgs
Visual Basic

Public Class ItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.ItemEventArgs

See Also

ItemEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemEventArgs Members

ItemEventArgs Members
Constructors Properties

Contains the arguments passed to item instantiation event handlers.

The following tables list the members exposed by the ItemEventArgs type.

Public Constructors

Name | Description
ItemEventArgs | Initializes a new instance of the ItemEventArgs class.

Public Properties

Name | Description
Index | Gets an integer index related to the event.
Item | Gets the item for which the event is raised.

See Also

ItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemEventArgs Constructor

ItemEventArgs Constructor

Initializes a new instance of the ItemEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ItemEventArgs (
DiagramItem item
)
Visual Basic

Public Sub ItemEventArgs ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem related to the event.

See Also

ItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemEventArgs Properties

ItemEventArgs Properties

Public Properties

Name | Description
Index | Gets an integer index related to the event.
Item | Gets the item for which the event is raised.

See Also

ItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemEventArgs.Index Property

ItemEventArgs.Index Property

Gets an integer index related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Index { get; }
Visual Basic

Public ReadOnly Property Index As Integer

Property Value

An integer value specifying the item's position within its containing collection.

See Also

ItemEventArgs Members
ItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemEventArgs.Item Property

ItemEventArgs.Item Property

Gets the item for which the event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; }
Visual Basic

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

ItemEventArgs Members
ItemEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ItemEventHandler Delegate

ItemEventHandler Delegate

Represents methods that will handle general item-related events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void ItemEventHandler (
Object sender,
ItemEventArgs e
)
Visual Basic

Public Delegate Sub ItemEventHandler ( _
sender As Object, _
e As ItemEventArgs _
)

Parameters

sender

The source of the event.

e

An ItemEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.LineTemplate Class

LineTemplate Class

Represents a line segment in a shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class LineTemplate : ElementTemplate
Visual Basic

Public Class LineTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.LineTemplate

See Also

LineTemplate Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LineTemplate Members

LineTemplate Members
Constructors Properties Methods

Represents a line segment in a shape definition.

The following tables list the members exposed by the LineTemplate type.

Public Constructors

Name | Description
LineTemplate | Overloaded. Initializes a new instance of the LineTemplate class.

Public Properties

Name | Description
Coordinates | Gets a float array containing the coordinates of the end points of this line segment.

Public Methods

Name | Description
Clone | Create an exact copy of this LineTemplate element.
SameAs | ElementTemplate.SameAs override.

See Also

LineTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LineTemplate Constructor

LineTemplate Constructor

Initializes a new instance of the LineTemplate class.

Overload List

Name | Description
LineTemplate (Single, Single, Single, Single) | Initializes a new instance of the LineTemplate class with the specified start and end point.
LineTemplate (Single, Single, Single, Single, Color, DashStyle, Single) | Initializes a new instance of the LineTemplate class with the specified start and end points, and the specified color and style.

See Also

LineTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LineTemplate Constructor (Single, Single, Single, Single)

LineTemplate Constructor (Single, Single, Single, Single)
See Also

Initializes a new instance of the LineTemplate class with the specified start and end point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public LineTemplate (
float x1,
float y1,
float x2,
float y2
)
Visual Basic

Public New ( _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single _
)

Parameters

x1
The x-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.
y1
The y-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.
x2
The x-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.
y2
The y-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

Remarks

A line template is defined by two points whose coordinates are passed as arguments.

See Also

LineTemplate Constructor Overload List
LineTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LineTemplate Constructor (Single, Single, Single, Single, Color, DashStyle, Single)

LineTemplate Constructor (Single, Single, Single, Single, Color, DashStyle, Single)
See Also

Initializes a new instance of the LineTemplate class with the specified start and end points, and the specified color and style.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public LineTemplate (
float x1,
float y1,
float x2,
float y2,
Color color,
DashStyle dashStyle,
float width
)
Visual Basic

Public New ( _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single, _
color As Color, _
dashStyle As DashStyle, _
width As Single _
)

Parameters

x1
The x-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.
y1
The y-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.
x2
The x-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.
y2
The y-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.
color
The color of this segment.
dashStyle
The dash style of this segment.
width
The width of this segment.

Remarks

A line template is defined by two points whose coordinates are passed as arguments.

See Also

LineTemplate Constructor Overload List
LineTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LineTemplate Methods

LineTemplate Methods

Public Methods

Name | Description
Clone | Create an exact copy of this LineTemplate element.
SameAs | ElementTemplate.SameAs override.

See Also

LineTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LineTemplate.Clone Method

LineTemplate.Clone Method

Create an exact copy of this LineTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

An instance of the LineTemplate class.

Remarks

An instance of the LineTemplate class.

See Also

LineTemplate Members
LineTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LineTemplate.SameAs Method

LineTemplate.SameAs Method

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool SameAs (
ElementTemplate obj
)
Visual Basic

Public Overrides Function SameAs ( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this template.

Return Value

true if the specified object is a LineTemplate closely approximating this template; otherwise, false.

See Also

LineTemplate Members
LineTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LineTemplate Properties

LineTemplate Properties

Public Properties

Name | Description
Coordinates | Gets a float array containing the coordinates of the end points of this line segment.

See Also

LineTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LineTemplate.Coordinates Property

LineTemplate.Coordinates Property

Gets a float array containing the coordinates of the end points of this line segment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float[] Coordinates { get; }
Visual Basic

Public ReadOnly Property Coordinates As Single()

Property Value

An array of float values containing the coordinates of the points composing this element.

See Also

LineTemplate Members
LineTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkCrossings Enumeration

LinkCrossings Enumeration

Defines values that indicate how to render link intersection points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum LinkCrossings
Visual Basic

Public Enumeration LinkCrossings

Members

Member name | Description
Arcs | An arc is drawn at the intersection point of two links. It connects the segments of the link at higher Z position and goes over the link at lower Z.
Cut | The intersection segments of links at lower Z position are cut by links at higher Z position.
Straight | No special indication for link intersection points.

Remarks

Values from this enumeration can be assigned to LinkCrossings.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkEventArgs Class

LinkEventArgs Class

Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class LinkEventArgs : EventArgs
Visual Basic

Public Class LinkEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LinkEventArgs
MindFusion.Diagramming.LinkValidationEventArgs

See Also

LinkEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkEventArgs Members

LinkEventArgs Members
Constructors Properties

Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.

The following tables list the members exposed by the LinkEventArgs type.

Public Constructors

Name | Description
LinkEventArgs | Overloaded. Initializes a new instance of the LinkEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
Link | Gets the link for which the event raised.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.

See Also

LinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkEventArgs Constructor

LinkEventArgs Constructor

Initializes a new instance of the LinkEventArgs class.

Overload List

Name | Description
LinkEventArgs (DiagramLink) | Initializes a new instance of the LinkEventArgs class.
LinkEventArgs (DiagramLink, MouseButton, PointF) | Initializes a new instance of the LinkEventArgs class.
LinkEventArgs (DiagramLink, PointF, Int32) | Initializes a new instance of the LinkEventArgs class.

See Also

LinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkEventArgs Constructor (DiagramLink)

LinkEventArgs Constructor (DiagramLink)
See Also

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public LinkEventArgs (
DiagramLink link
)
Visual Basic

Public Sub LinkEventArgs ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink related to the event.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkEventArgs Constructor (DiagramLink, MouseButton, PointF)

LinkEventArgs Constructor (DiagramLink, MouseButton, PointF)
See Also

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public LinkEventArgs (
DiagramLink link,
MouseButton mouseButton,
PointF mousePosition
)
Visual Basic

Public Sub LinkEventArgs ( _
link As DiagramLink, _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

link

The DiagramLink related to the event.

mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkEventArgs Constructor (DiagramLink, PointF, Int32)

LinkEventArgs Constructor (DiagramLink, PointF, Int32)
See Also

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public LinkEventArgs (
DiagramLink link,
PointF mousePosition,
int adjustmentHandle
)
Visual Basic

Public Sub LinkEventArgs ( _
link As DiagramLink, _
mousePosition As PointF, _
adjustmentHandle As Integer _
)

Parameters

link

The DiagramLink related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

The zero-based index of the control point related to the event.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkEventArgs Properties

LinkEventArgs Properties

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
Link | Gets the link for which the event raised.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.

See Also

LinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkEventArgs.AdjustmentHandle Property

LinkEventArgs.AdjustmentHandle Property

Gets or sets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int AdjustmentHandle { get; set; }
Visual Basic

Public Property AdjustmentHandle As Integer

Property Value

An integer that represents the index of the link's control point being moved.

See Also

LinkEventArgs Members
LinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkEventArgs.Link Property

LinkEventArgs.Link Property

Gets the link for which the event raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink Link { get; }
Visual Basic

Public ReadOnly Property Link As DiagramLink

Property Value

A DiagramLink instance.

See Also

LinkEventArgs Members
LinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkEventArgs.MouseButton Property

LinkEventArgs.MouseButton Property

Gets which mouse button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public MouseButton MouseButton { get; }
Visual Basic

Public ReadOnly Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration specifying the currently pressed mouse button.

See Also

LinkEventArgs Members
LinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkEventArgs.MousePosition Property

LinkEventArgs.MousePosition Property

Gets or sets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF MousePosition { get; set; }
Visual Basic

Public Property MousePosition As PointF

Property Value

A .NET PointF object specifying the current mouse position.

See Also

LinkEventArgs Members
LinkEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkEventHandler Delegate

LinkEventHandler Delegate

Represents methods that will handle general link related events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void LinkEventHandler (
Object sender,
LinkEventArgs e
)
Visual Basic

Public Delegate Sub LinkEventHandler ( _
sender As Object, _
e As LinkEventArgs _
)

Parameters

sender

The source of the event.

e

A LinkEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkStyle Enumeration

LinkStyle Enumeration

Specifies available styles for the segments of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum LinkStyle
Visual Basic

Public Enumeration LinkStyle

Members

Member name | Description
Bezier | The segments of a link are Bézier curves.
Cascading | The segments of a link are horizontal and vertical lines, each one orthogonal to each adjacent segment.
Polyline | The segments of the link are straight lines.

Remarks

Values from this enumeration can be assigned to the Style property of links or to the LinkStyle property of the diagram.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkTextStyle Enumeration

LinkTextStyle Enumeration

Specifies the position and alignment of links' labels.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum LinkTextStyle
Visual Basic

Public Enumeration LinkTextStyle

Members

Member name | Description
Center | The text is displayed horizontally above the middle link segment or control point, depending on whether there are an odd or even number of segments.
Follow | The label text starts from the first point of the link and follows the path defined by the link segments. This style is useful for displaying long text.
OverLongestSegment | The text follows the longest link segment and is displayed centered at the segment's middle point.
Rotate | The text is displayed rotated at the same angle as the segment where the text is placed. A long enough segment from the middle link segments is chosen for that purpose.

Remarks

Values from this enumeration can be assigned to the TextStyle property of links or the LinkTextStyle property of the diagram.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs Class

LinkValidationEventArgs Class

Contains the arguments passed to handlers of link validation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class LinkValidationEventArgs : LinkEventArgs
Visual Basic

Public Class LinkValidationEventArgs
Inherits LinkEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LinkEventArgs
MindFusion.Diagramming.LinkValidationEventArgs

See Also

LinkValidationEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs Members

LinkValidationEventArgs Members
Constructors Properties Methods

Contains the arguments passed to handlers of link validation events.

The following tables list the members exposed by the LinkValidationEventArgs type.

Public Constructors

Name | Description
LinkValidationEventArgs | Overloaded. Initializes a new instance of the LinkValidationEventArgs class.

Public Properties

Name | Description
AnchorIndex | Gets the anchor point related to a link validation event.
Cancel | Gets or sets a value indicating whether to cancel the current operation.
ChangingDestination | Gets a value indicating whether the user modifies the link's destination end point.
ChangingOrigin | Gets a value indicating whether the user modifies the link's origin end point.
Destination | Gets the node that will become the link's destination if the event is validated.
Node | Gets the node to which the link will be connected.
Origin | Gets the node that would become the link's origin if the event is validated.
SelectionRectangle | Gets the current selection rectangle.
TableRow | Gets the table row related to a link validation event.

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the link.

See Also

LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs Constructor

LinkValidationEventArgs Constructor

Initializes a new instance of the LinkValidationEventArgs class.

Overload List

Name | Description
LinkValidationEventArgs (DiagramLink) | Initializes a new instance of the LinkValidationEventArgs class.
LinkValidationEventArgs (DiagramLink, PointF, Int32, DiagramNode, Int32, Int32) | Initializes a new instance of the LinkValidationEventArgs class.
LinkValidationEventArgs (DiagramLink, RectangleF) | Initializes a new instance of the LinkValidationEventArgs class.

See Also

LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs Constructor (DiagramLink)

LinkValidationEventArgs Constructor (DiagramLink)
See Also

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public LinkValidationEventArgs (
DiagramLink link
)
Visual Basic

Public Sub LinkValidationEventArgs ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink related to the event.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs Constructor (DiagramLink, PointF, Int32, DiagramNode, Int32, Int32)

LinkValidationEventArgs Constructor (DiagramLink, PointF, Int32, DiagramNode, Int32, Int32)
See Also

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public LinkValidationEventArgs (
DiagramLink link,
PointF mousePosition,
int adjustmentHandle,
DiagramNode node,
int anchorIndex,
int tableRow
)
Visual Basic

Public Sub LinkValidationEventArgs ( _
link As DiagramLink, _
mousePosition As PointF, _
adjustmentHandle As Integer, _
node As DiagramNode, _
anchorIndex As Integer, _
tableRow As Integer _
)

Parameters

link

The DiagramLink related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

The zero-based index of the control point related to the event.

node

The DiagramNode related to the event.

anchorIndex

The zero-based index of the anchor point related to the event.

tableRow

The zero-based index of the table row related to the event.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs Constructor (DiagramLink, RectangleF)

LinkValidationEventArgs Constructor (DiagramLink, RectangleF)
See Also

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public LinkValidationEventArgs (
DiagramLink link,
RectangleF selectionRectangle
)
Visual Basic

Public Sub LinkValidationEventArgs ( _
link As DiagramLink, _
selectionRectangle As RectangleF _
)

Parameters

link

The DiagramLink related to the event.

selectionRectangle

A .NET RectangleF object that represents the current selection rectangle.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs Methods

LinkValidationEventArgs Methods

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the link.

See Also

LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs.CancelDrag Method

LinkValidationEventArgs.CancelDrag Method

Cancels the creation or modification of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void CancelDrag ()
Visual Basic

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation. On the other hand, setting Cancel to true only changes the mouse cursor to a Stop icon and the operation is cancelled when the user releases the mouse button.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs Properties

LinkValidationEventArgs Properties

Public Properties

Name | Description
AnchorIndex | Gets the anchor point related to a link validation event.
Cancel | Gets or sets a value indicating whether to cancel the current operation.
ChangingDestination | Gets a value indicating whether the user modifies the link's destination end point.
ChangingOrigin | Gets a value indicating whether the user modifies the link's origin end point.
Destination | Gets the node that will become the link's destination if the event is validated.
Node | Gets the node to which the link will be connected.
Origin | Gets the node that would become the link's origin if the event is validated.
SelectionRectangle | Gets the current selection rectangle.
TableRow | Gets the table row related to a link validation event.

See Also

LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs.AnchorIndex Property

LinkValidationEventArgs.AnchorIndex Property

Gets the anchor point related to a link validation event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int AnchorIndex { get; }
Visual Basic

Public ReadOnly Property AnchorIndex As Integer

Property Value

An integer value specifying the index of an anchor point within an AnchorPattern.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs.Cancel Property

LinkValidationEventArgs.Cancel Property

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Cancel { get; set; }
Visual Basic

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs.ChangingDestination Property

LinkValidationEventArgs.ChangingDestination Property

Gets a value indicating whether the user modifies the link's destination end point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ChangingDestination { get; }
Visual Basic

Public ReadOnly Property ChangingDestination As Boolean

Property Value

true if the user is changing the destination point; otherwise, false.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs.ChangingOrigin Property

LinkValidationEventArgs.ChangingOrigin Property

Gets a value indicating whether the user modifies the link's origin end point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ChangingOrigin { get; }
Visual Basic

Public ReadOnly Property ChangingOrigin As Boolean

Property Value

true if the user is changing the origin point; otherwise, false.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs.Destination Property

LinkValidationEventArgs.Destination Property

Gets the node that will become the link's destination if the event is validated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Destination { get; }
Visual Basic

Public ReadOnly Property Destination As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs.Node Property

LinkValidationEventArgs.Node Property

Gets the node to which the link will be connected.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Node { get; }
Visual Basic

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs.Origin Property

LinkValidationEventArgs.Origin Property

Gets the node that would become the link's origin if the event is validated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Origin { get; }
Visual Basic

Public ReadOnly Property Origin As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs.SelectionRectangle Property

LinkValidationEventArgs.SelectionRectangle Property

Gets the current selection rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF SelectionRectangle { get; }
Visual Basic

Public ReadOnly Property SelectionRectangle As RectangleF

Property Value

A .NET RectangleF instance representing the selection rectangle.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventArgs.TableRow Property

LinkValidationEventArgs.TableRow Property

Gets the table row related to a link validation event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int TableRow { get; }
Visual Basic

Public ReadOnly Property TableRow As Integer

Property Value

An integer value specifying the zero-based index of a TableNode's row.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.LinkValidationEventHandler Delegate

LinkValidationEventHandler Delegate

Represents methods that will handle link validation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void LinkValidationEventHandler (
Object sender,
LinkValidationEventArgs e
)
Visual Basic

Public Delegate Sub LinkValidationEventHandler ( _
sender As Object, _
e As LinkValidationEventArgs _
)

Parameters

sender

The source of the event.

e

A LinkValidationEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.MarkStyle Enumeration

MarkStyle Enumeration

Specifies the visual style of anchor point marks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum MarkStyle
Visual Basic

Public Enumeration MarkStyle

Members

Member name | Description
Circle | Anchor point marked with a circle.
Cross | Anchor point marked with a cross.
Custom | A DrawAnchorPoint event is fired, allowing custom painting of anchor points.
None | No visual indication for the anchor point.
Rectangle | Anchor point marked with a rectangle.
X | Anchor point marked with an 'X'.

Remarks

Members of this enumeration are used as values of the MarkStyle property of the AnchorPoint class.

See Also

MindFusion.Diagramming Namespace
AnchorPoint Class
MarkStyle Property
DrawAnchorPoint Event


MindFusion.Diagramming.ModificationStart Enumeration

ModificationStart Enumeration

Specifies how the user can start modifying an item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum ModificationStart
Visual Basic

Public Enumeration ModificationStart

Members

Member name | Description
AutoHandles | Adjustment handles appear automatically around the item under the mouse; it can be modified without selecting it first.
SelectedOnly | Only selected items can be modified.

Remarks

This enumeration specifies the possible values of the ModificationStart property.

See Also

MindFusion.Diagramming Namespace
ModificationStart Property


MindFusion.Diagramming.ModifierKeyAction Enumeration

ModifierKeyAction Enumeration

Defines the actions that can be assigned to a modifier key such as CTRL or ALT.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum ModifierKeyAction
Visual Basic

Public Enumeration ModifierKeyAction

Members

Member name | Description
None | Specifies that a modifier key does not have any specific function assigned to it.
OverrideBehavior | While the modifier key is pressed down, dragging the mouse starts creating a new item or drawing a selection rectangle instead of modifying a selected item. Otherwise, dragging the mouse could start modification of the selected item.
Pan | Pan the view if the mouse is dragged while the modifier key is pressed down.
Select | Start drawing a selection rectangle if the mouse is dragged while a modifier key is pressed down. Toggle the selection if an item is clicked while the key is down.

Remarks

The values from this enumeration can be assigned to the members of the diagram view's ModifierKeyActions.

See Also

MindFusion.Diagramming Namespace
ModifierKeyActions Class


MindFusion.Diagramming.MouseButton Enumeration

MouseButton Enumeration

Specifies constants that define which mouse button was pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum MouseButton
Visual Basic

Public Enumeration MouseButton

Members

Member name | Description
Left | The left mouse button was pressed.
Middle | The middle mouse button was pressed.
None | No mouse button was pressed.
Right | The right mouse button was pressed.
XButton1 | The first XButton was pressed.
XButton2 | The second XButton was pressed.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.MouseButtonActions Enumeration

MouseButtonActions Enumeration

Specifies what actions can be associated with the middle and right mouse buttons.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum MouseButtonActions
Visual Basic

Public Enumeration MouseButtonActions

Members

Member name | Description
Cancel | Cancels the current drawing operation.
None | Do not associate any action with the button.
Pan | Pans the view if the mouse is dragged while the button is pressed down.
Select | Starts a multiple selection operation.

Remarks

The Cancel value can be combined with Pan or Select. Thus if a user presses the mouse button while drawing an item, the operation will be cancelled; otherwise dragging with the specified button will start panning or drawing a selection rectangle.

See Also

MindFusion.Diagramming Namespace
MiddleButtonActions Property
RightButtonActions Property


MindFusion.Diagramming.NodeConstraints Class

NodeConstraints Class
Remarks See Also

Defines specific constraints that can be applied to the size and location of nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class NodeConstraints : IPersists, ICloneable
Visual Basic

Public Class NodeConstraints
Implements IPersists, ICloneable

Remarks

Instances of this class can be assigned to the Constraints property of nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.NodeConstraints

See Also

NodeConstraints Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeConstraints Members

NodeConstraints Members
Constructors Properties Methods

Defines specific constraints that can be applied to the size and location of nodes.

The following tables list the members exposed by the NodeConstraints type.

Public Constructors

Name | Description
NodeConstraints | Initializes a new instance of the NodeConstraints class.

Public Properties

Name | Description
KeepInsideParent | Gets or sets a value indicating whether a node must always stay in the boundaries of its group master node.
KeepRatio | Gets or sets a value indicating whether the initial width/height ratio of a node must be preserved.
MaxHeight | Gets or sets the maximal node height allowed.
MaxWidth | Gets or sets the maximal node width allowed.
MinHeight | Gets or sets the minimal node height allowed.
MinWidth | Gets or sets the minimal node width allowed.
MoveDirection | Gets or sets constraints on movement direction.

Public Methods

Name | Description
Clone | Creates a copy of this object.

See Also

NodeConstraints Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeConstraints Constructor

NodeConstraints Constructor

Initializes a new instance of the NodeConstraints class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public NodeConstraints ()
Visual Basic

Public Sub New ()

See Also

NodeConstraints Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeConstraints Methods

NodeConstraints Methods

Public Methods

Name | Description
Clone | Creates a copy of this object.

See Also

NodeConstraints Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeConstraints.Clone Method

NodeConstraints.Clone Method

Creates a copy of this object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

An Object instance that is a copy of the current NodeConstraints instance.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeConstraints Properties

NodeConstraints Properties

Public Properties

Name | Description
KeepInsideParent | Gets or sets a value indicating whether a node must always stay in the boundaries of its group master node.
KeepRatio | Gets or sets a value indicating whether the initial width/height ratio of a node must be preserved.
MaxHeight | Gets or sets the maximal node height allowed.
MaxWidth | Gets or sets the maximal node width allowed.
MinHeight | Gets or sets the minimal node height allowed.
MinWidth | Gets or sets the minimal node width allowed.
MoveDirection | Gets or sets constraints on movement direction.

See Also

NodeConstraints Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeConstraints.KeepInsideParent Property

NodeConstraints.KeepInsideParent Property

Gets or sets a value indicating whether a node must always stay in the boundaries of its group master node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool KeepInsideParent { get; set; }
Visual Basic

Public Property KeepInsideParent As Boolean

Property Value

true if users should be prevented from moving the node out of its parent; otherwise, false. The default is false.

Remarks

This property lets you restrict nodes attached to another node by calling the AttachTo method so that users cannot move the attached nodes out of the bounds of their parent.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeConstraints.KeepRatio Property

NodeConstraints.KeepRatio Property

Gets or sets a value indicating whether the initial width/height ratio of a node must be preserved.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool KeepRatio { get; set; }
Visual Basic

Public Property KeepRatio As Boolean

Property Value

true if the node width to height ratio should be preserved; otherwise, false. The default is false.

Remarks

If you enable this property in an initialization-event handler, the node will have an aspect ratio of 1:1. In order to let users draw perfect square or circle shapes, set KeepRatio to true in the InitializeNode handler.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeConstraints.MaxHeight Property

NodeConstraints.MaxHeight Property

Gets or sets the maximal node height allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float MaxHeight { get; set; }
Visual Basic

Public Property MaxHeight As Single

Property Value

0 = no height constraints; any other value specifies the maximal node height allowed.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeConstraints.MaxWidth Property

NodeConstraints.MaxWidth Property

Gets or sets the maximal node width allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float MaxWidth { get; set; }
Visual Basic

Public Property MaxWidth As Single

Property Value

0 = no width constraints; any other value specifies the maximal node width allowed.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeConstraints.MinHeight Property

NodeConstraints.MinHeight Property

Gets or sets the minimal node height allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float MinHeight { get; set; }
Visual Basic

Public Property MinHeight As Single

Property Value

0 = no height constraints; any other value specifies the minimal node height allowed.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeConstraints.MinWidth Property

NodeConstraints.MinWidth Property

Gets or sets the minimal node width allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float MinWidth { get; set; }
Visual Basic

Public Property MinWidth As Single

Property Value

0 = no width constraints; any other value specifies the minimal node width allowed.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeConstraints.MoveDirection Property

NodeConstraints.MoveDirection Property

Gets or sets constraints on movement direction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DirectionConstraint MoveDirection { get; set; }
Visual Basic

Public Property MoveDirection As DirectionConstraint

Property Value

One of the DirectionConstraint enumeration values; the default is None.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeEventArgs Class

NodeEventArgs Class

Contains the arguments passed to handlers of node-related events, such as TreeCollapsed and TreeExpanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class NodeEventArgs : EventArgs
Visual Basic

Public Class NodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeEventArgs
MindFusion.Diagramming.ContainerChildEventArgs
MindFusion.Diagramming.NodeValidationEventArgs

See Also

NodeEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeEventArgs Members

NodeEventArgs Members
Constructors Properties

Contains the arguments passed to handlers of node-related events, such as TreeCollapsed and TreeExpanded.

The following tables list the members exposed by the NodeEventArgs type.

Public Constructors

Name | Description
NodeEventArgs | Overloaded. Initializes a new instance of the NodeEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
Node | Gets the node for which the event was raised.

See Also

NodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeEventArgs Constructor

NodeEventArgs Constructor

Initializes a new instance of the NodeEventArgs class.

Overload List

Name | Description
NodeEventArgs (DiagramNode) | Initializes a new instance of the NodeEventArgs class.
NodeEventArgs (DiagramNode, MouseButton, PointF) | Initializes a new instance of the NodeEventArgs class.
NodeEventArgs (DiagramNode, PointF, AdjustmentHandles) | Initializes a new instance of the NodeEventArgs class.

See Also

NodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeEventArgs Constructor (DiagramNode)

NodeEventArgs Constructor (DiagramNode)
See Also

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public NodeEventArgs (
DiagramNode node
)
Visual Basic

Public Sub NodeEventArgs ( _
node As DiagramNode _
)

Parameters

node

The DiagramNode related to the event.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeEventArgs Constructor (DiagramNode, MouseButton, PointF)

NodeEventArgs Constructor (DiagramNode, MouseButton, PointF)
See Also

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public NodeEventArgs (
DiagramNode node,
MouseButton mouseButton,
PointF mousePosition
)
Visual Basic

Public Sub NodeEventArgs ( _
node As DiagramNode, _
mouseButton As MouseButton, _
mousePosition As PointF _
)

Parameters

node

The DiagramNode related to the event.

mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeEventArgs Constructor (DiagramNode, PointF, AdjustmentHandles)

NodeEventArgs Constructor (DiagramNode, PointF, AdjustmentHandles)
See Also

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public NodeEventArgs (
DiagramNode node,
PointF mousePosition,
AdjustmentHandles adjustmentHandle
)
Visual Basic

Public Sub NodeEventArgs ( _
node As DiagramNode, _
mousePosition As PointF, _
adjustmentHandle As AdjustmentHandles _
)

Parameters

node

The DiagramNode related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

The zero-based index of the adjustment handle related to the event.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeEventArgs Properties

NodeEventArgs Properties

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
Node | Gets the node for which the event was raised.

See Also

NodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeEventArgs.AdjustmentHandle Property

NodeEventArgs.AdjustmentHandle Property

Gets or sets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AdjustmentHandles AdjustmentHandle { get; set; }
Visual Basic

Public Property AdjustmentHandle As AdjustmentHandles

Property Value

A member of the AdjustmentHandles enumeration specifying what handle has been used.

See Also

NodeEventArgs Members
NodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeEventArgs.MouseButton Property

NodeEventArgs.MouseButton Property

Gets which mouse button has been pressed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public MouseButton MouseButton { get; }
Visual Basic

Public ReadOnly Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration specifying the currently pressed mouse button.

See Also

NodeEventArgs Members
NodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeEventArgs.MousePosition Property

NodeEventArgs.MousePosition Property

Gets or sets the current mouse pointer position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF MousePosition { get; set; }
Visual Basic

Public Property MousePosition As PointF

Property Value

A .NET PointF object specifying the current mouse position.

See Also

NodeEventArgs Members
NodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeEventArgs.Node Property

NodeEventArgs.Node Property

Gets the node for which the event was raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Node { get; }
Visual Basic

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

NodeEventArgs Members
NodeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeEventHandler Delegate

NodeEventHandler Delegate

Represents methods that will handle general node related events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void NodeEventHandler (
Object sender,
NodeEventArgs e
)
Visual Basic

Public Delegate Sub NodeEventHandler ( _
sender As Object, _
e As NodeEventArgs _
)

Parameters

sender

The source of the event.

e

A NodeEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeValidationEventArgs Class

NodeValidationEventArgs Class

Contains the arguments passed to handlers of node validation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class NodeValidationEventArgs : NodeEventArgs
Visual Basic

Public Class NodeValidationEventArgs
Inherits NodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeEventArgs
MindFusion.Diagramming.NodeValidationEventArgs

See Also

NodeValidationEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeValidationEventArgs Members

NodeValidationEventArgs Members
Constructors Properties Methods

Contains the arguments passed to handlers of node validation events.

The following tables list the members exposed by the NodeValidationEventArgs type.

Public Constructors

Name | Description
NodeValidationEventArgs | Overloaded. Initializes a new instance of the NodeValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
SelectionRectangle | Gets the current selection rectangle.

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the node.

See Also

NodeValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeValidationEventArgs Constructor

NodeValidationEventArgs Constructor

Initializes a new instance of the NodeValidationEventArgs class.

Overload List

Name | Description
NodeValidationEventArgs (DiagramNode) | Initializes a new instance of the NodeValidationEventArgs class.
NodeValidationEventArgs (DiagramNode, PointF, AdjustmentHandles) | Initializes a new instance of the NodeValidationEventArgs class.
NodeValidationEventArgs (DiagramNode, RectangleF) | Initializes a new instance of the NodeValidationEventArgs class.

See Also

NodeValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeValidationEventArgs Constructor (DiagramNode)

NodeValidationEventArgs Constructor (DiagramNode)
See Also

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public NodeValidationEventArgs (
DiagramNode node
)
Visual Basic

Public Sub NodeValidationEventArgs ( _
node As DiagramNode _
)

Parameters

node

The DiagramNode related to the event.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeValidationEventArgs Constructor (DiagramNode, PointF, AdjustmentHandles)

NodeValidationEventArgs Constructor (DiagramNode, PointF, AdjustmentHandles)
See Also

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public NodeValidationEventArgs (
DiagramNode node,
PointF mousePosition,
AdjustmentHandles adjustmentHandle
)
Visual Basic

Public Sub NodeValidationEventArgs ( _
node As DiagramNode, _
mousePosition As PointF, _
adjustmentHandle As AdjustmentHandles _
)

Parameters

node

The DiagramNode related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

The zero-based index of the adjustment handle related to the event.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeValidationEventArgs Constructor (DiagramNode, RectangleF)

NodeValidationEventArgs Constructor (DiagramNode, RectangleF)
See Also

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public NodeValidationEventArgs (
DiagramNode node,
RectangleF selectionRectangle
)
Visual Basic

Public Sub NodeValidationEventArgs ( _
node As DiagramNode, _
selectionRectangle As RectangleF _
)

Parameters

node

The DiagramNode related to the event.

selectionRectangle

A .NET RectangeF object representing the selection reactangle.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeValidationEventArgs Methods

NodeValidationEventArgs Methods

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the node.

See Also

NodeValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeValidationEventArgs.CancelDrag Method

NodeValidationEventArgs.CancelDrag Method

Cancels the creation or modification of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void CancelDrag ()
Visual Basic

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation. On the other hand, setting Cancel to true only changes the mouse cursor to a Stop icon and the operation is cancelled when the user releases the mouse button.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeValidationEventArgs Properties

NodeValidationEventArgs Properties

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
SelectionRectangle | Gets the current selection rectangle.

See Also

NodeValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeValidationEventArgs.Cancel Property

NodeValidationEventArgs.Cancel Property

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Cancel { get; set; }
Visual Basic

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeValidationEventArgs.SelectionRectangle Property

NodeValidationEventArgs.SelectionRectangle Property

Gets the current selection rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF SelectionRectangle { get; }
Visual Basic

Public ReadOnly Property SelectionRectangle As RectangleF

Property Value

A RectangleF instance representing the selection rectangle.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NodeValidationEventHandler Delegate

NodeValidationEventHandler Delegate

Represents methods that will handle node validation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void NodeValidationEventHandler (
Object sender,
NodeValidationEventArgs e
)
Visual Basic

Public Delegate Sub NodeValidationEventHandler ( _
sender As Object, _
e As NodeValidationEventArgs _
)

Parameters

sender

The source of the event.

e

A NodeValidationEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.NotATreeException Class

NotATreeException Class

An exception raised by the TreeEnumerator class if the specified node does not represent a root of a tree.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class NotATreeException : Exception
Visual Basic

Public Class NotATreeException
Inherits Exception

Inheritance Hierarchy

System.Object
System.Exception
MindFusion.Diagramming.NotATreeException

See Also

NotATreeException Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NotATreeException Members

NotATreeException Members
Constructors

An exception raised by the TreeEnumerator class if the specified node does not represent a root of a tree.

The following tables list the members exposed by the NotATreeException type.

Public Constructors

Name | Description
NotATreeException | Initializes a new instance of the NotATreeException class.

See Also

NotATreeException Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.NotATreeException Constructor

NotATreeException Constructor

Initializes a new instance of the NotATreeException class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public NotATreeException ()
Visual Basic

Public Sub New ()

See Also

NotATreeException Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Orientation Enumeration

Orientation Enumeration

Defines values that specify the orientation of the first segment of cascading links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum Orientation
Visual Basic

Public Enumeration Orientation

Members

Member name | Description
Auto | MindFusion.Diagramming determines automatically the initial direction of link's first segment.
Horizontal | The first segment of the link is always horizontal.
Vertical | The first segment of the link is always vertical.

See Also

MindFusion.Diagramming Namespace
CascadeOrientation Property


MindFusion.Diagramming.Path Class

Path Class
Remarks See Also

Represents a sequence of connected DiagramNode and DiagramLink elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public sealed class Path
Visual Basic

Public NotInheritable Class Path

Remarks

Path instances are returned by methods of the PathFinder class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Path

See Also

Path Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Path Members

Path Members
Properties Methods

Represents a sequence of connected DiagramNode and DiagramLink elements.

The following tables list the members exposed by the Path type.

Public Properties

Name | Description
Items | Gets a collection of all DiagramNode and DiagramLink elements in the path.
Length | Gets the length of the Path expressed as the number of Links participating in it.
Links | Gets a collection of all DiagramLink elements participating in the path.
Nodes | Gets a collection of all DiagramNode elements participating in the path.

Public Methods

Name | Description
GetWeight | Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

See Also

Path Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Path Methods

Path Methods

Public Methods

Name | Description
GetWeight | Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

See Also

Path Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Path.GetWeight Method

Path.GetWeight Method

Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float GetWeight (
bool incNodes,
bool incLinks
)
Visual Basic

Public Function GetWeight ( _
incNodes As Boolean, _
incLinks As Boolean _
) As Single

Parameters

incNodes

A boolean value, which specifies whether the Weight of DiagramNode elements should be considered.

incLinks

A boolean value, which specifies whether the Weight of DiagramLink elements should be considered.

Return Value

A float value that represents the total weight of the elements in this Path according to the incNodes and incLinks parameters.

See Also

Path Members
Path Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Path Properties

Path Properties

Public Properties

Name | Description
Items | Gets a collection of all DiagramNode and DiagramLink elements in the path.
Length | Gets the length of the Path expressed as the number of Links participating in it.
Links | Gets a collection of all DiagramLink elements participating in the path.
Nodes | Gets a collection of all DiagramNode elements participating in the path.

See Also

Path Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Path.Items Property

Path.Items Property

Gets a collection of all DiagramNode and DiagramLink elements in the path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItemCollection Items { get; }
Visual Basic

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

The collection contains consecutive DiagramNode and DiagramLink objects.

See Also

Path Members
Path Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Path.Length Property

Path.Length Property

Gets the length of the Path expressed as the number of Links participating in it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Length { get; }
Visual Basic

Public ReadOnly Property Length As Integer

Property Value

An integer value that represents the number of edges (links) in the path.

See Also

Path Members
Path Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Path.Links Property

Path.Links Property

Gets a collection of all DiagramLink elements participating in the path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLinkCollection Links { get; }
Visual Basic

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

Use Nodes to get all DiagramNode elements in the Path.

See Also

Path Members
Path Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Path.Nodes Property

Path.Nodes Property

Gets a collection of all DiagramNode elements participating in the path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItemCollection Nodes { get; }
Visual Basic

Public ReadOnly Property Nodes As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

Use Links to get all DiagramLinks elements in the Path.

See Also

Path Members
Path Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathCollection Class

PathCollection Class

Represents a strongly typed collection of Path objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public sealed class PathCollection : CollectionBase
Visual Basic

Public NotInheritable Class PathCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.PathCollection

See Also

PathCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathCollection Members

PathCollection Members
Constructors Properties Methods

Represents a strongly typed collection of Path objects.

The following tables list the members exposed by the PathCollection type.

Public Constructors

Name | Description
PathCollection | Initializes a new instance of the PathCollection class.

Public Properties

Name | Description
Item | Gets or sets the Path at the specified position.

Public Methods

Name | Description
Add | Adds the specified Path to the collection.
Clear | Removes all Path elements from the PathCollection.
GetAt | Gets the Path at the specified position.
Insert | Inserts the specified Path to the PathCollection at the specified index.
Remove | Removes the specified Path element from the PathCollection.

See Also

PathCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathCollection Constructor

PathCollection Constructor

Initializes a new instance of the PathCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PathCollection ()
Visual Basic

Public Sub New ()

See Also

PathCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathCollection Methods

PathCollection Methods

Public Methods

Name | Description
Add | Adds the specified Path to the collection.
Clear | Removes all Path elements from the PathCollection.
GetAt | Gets the Path at the specified position.
Insert | Inserts the specified Path to the PathCollection at the specified index.
Remove | Removes the specified Path element from the PathCollection.

See Also

PathCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathCollection.Add Method

PathCollection.Add Method

Adds the specified Path to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Add (
Path path
)
Visual Basic

Public Sub Add ( _
path As Path _
)

Parameters

path
The Path object to add.

Remarks

The Path object is added at the end of the PathCollection. Use Insert to specify the place of the new element.

See Also

PathCollection Members
PathCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathCollection.Clear Method

PathCollection.Clear Method

Removes all Path elements from the PathCollection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

Remarks

The method removes all Path elements in the collection. If you want to delete a specific element use Remove.

See Also

PathCollection Members
PathCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathCollection.GetAt Method

PathCollection.GetAt Method

Gets the Path at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Path GetAt (
int index
)
Visual Basic

Public Function GetAt ( _
index As Integer _
) As Path

Parameters

index
The zero-based index of the Path element to get.

Return Value

The Path at the specified position in the PathCollection.

See Also

PathCollection Members
PathCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathCollection.Insert Method

PathCollection.Insert Method

Inserts the specified Path to the PathCollection at the specified index.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Insert (
int index,
Path path
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
path As Path _
)

Parameters

index
The zero-based index at which the new Path element should be inserted.
path
The Path element to insert.

Remarks

The method insertes a new element at a gieven position in the PathCollection. Use Add to add a new element to the end of the collection.

See Also

PathCollection Members
PathCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathCollection.Remove Method

PathCollection.Remove Method

Removes the specified Path element from the PathCollection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Remove (
Path path
)
Visual Basic

Public Sub Remove ( _
path As Path _
)

Parameters

path
The Path element to remove.

Remarks

The size of the PathCollection is corrected. Indexes of the elements after path are updated too.

See Also

PathCollection Members
PathCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathCollection Properties

PathCollection Properties

Public Properties

Name | Description
Item | Gets or sets the Path at the specified position.

See Also

PathCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathCollection.Item Property

PathCollection.Item Property

Gets or sets the Path at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Path Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Path

Parameters

index
The zero-based index of the Path element to access.

Property Value

An instance of the Path class that represents the path at the specified position.

See Also

PathCollection Members
PathCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathFinder Class

PathFinder Class
Remarks See Also

Provides methods that help you find paths and cycles in a graph.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public sealed class PathFinder
Visual Basic

Public NotInheritable Class PathFinder

Remarks

By default the direction of links is taken into account when looking for paths or cycles. In that case the direction of a path is considered to be the direction defined by the outgoing links of nodes. Use the second constructor override to specify that link direction should be ignored when looking for paths.

A path-finder object caches graph information between method calls in order to achieve better performance when path and cycle -finding methods are called on the same diagram more than once. However if the diagram structure changes, you must create a new PathFinder instance in order to use the new structure of the diagram graph.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.PathFinder

See Also

PathFinder Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathFinder Members

PathFinder Members
Constructors Methods

Provides methods that help you find paths and cycles in a graph.

The following tables list the members exposed by the PathFinder type.

Public Constructors

Name | Description
PathFinder | Overloaded. Initializes a new instance of the PathFinder class.

Public Methods

Name | Description
FindAllCycles | Finds all cycles in the underlying diagram.
FindAllPaths | Finds and returns all paths that exist between two DiagramNode objects.
FindCycle | Overloaded. Finds a cycle in the underlying diagram.
FindLongestPath | Overloaded. Finds the longest path in the underlying diagram.
FindShortestPath | Overloaded. Finds the shortest path in the underlying diagram.

See Also

PathFinder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathFinder Constructor

PathFinder Constructor

Initializes a new instance of the PathFinder class.

Overload List

Name | Description
PathFinder (Diagram) | Initializes a new instance of the PathFinder class. Path-finding will depend on the direction of links.
PathFinder (Diagram, Boolean) | Initializes a new instance of the PathFinder class, optionally ignoring the link direction.

See Also

PathFinder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathFinder Constructor (Diagram)

PathFinder Constructor (Diagram)
See Also

Initializes a new instance of the PathFinder class. Path-finding will depend on the direction of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PathFinder (
Diagram diagram
)
Visual Basic

Public Sub PathFinder ( _
diagram As Diagram _
)

Parameters

diagram
An instance of the Diagram class in which to look for paths or cycles.

Remarks

The PathFinder methods look for paths and cycles in the Diagram instance specified through the argument. The diagram is treated as a directed graph and the direction of links is considered when looking for a path, that is, a path continues from a node only through its OutgoingLinks.

See Also

PathFinder Constructor Overload List
PathFinder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathFinder Constructor (Diagram, Boolean)

PathFinder Constructor (Diagram, Boolean)
See Also

Initializes a new instance of the PathFinder class, optionally ignoring the link direction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PathFinder (
Diagram diagram,
bool ignoreDirection
)
Visual Basic

Public Sub PathFinder ( _
diagram As Diagram, _
ignoreDirection As Boolean _
)

Parameters

diagram
A Diagram instance in which to look for paths or cycles.
ignoreDirection
Specifies whether the direction of links should be considered when looking for paths or cycles.

Remarks

The PathFinder methods look for paths and cycles in the Diagram instance specified with the first argument. By default, the diagram is treated as a directed graph and the direction of links is considered when looking for a path, that is, a path continues from a node only through its OutgoingLinks.

To ignore the direction of links, pass true as a value of the ignoreDirection argument; then the path-finding algorithm will look for paths both through the OutgoingLinks and IncomingLinks collections of nodes. If you do not want to ignore the direction of links you can use the alternative constructor.

See Also

PathFinder Constructor Overload List
PathFinder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathFinder Methods

PathFinder Methods

Public Methods

Name | Description
FindAllCycles | Finds all cycles in the underlying diagram.
FindAllPaths | Finds and returns all paths that exist between two DiagramNode objects.
FindCycle | Overloaded. Finds a cycle in the underlying diagram.
FindLongestPath | Overloaded. Finds the longest path in the underlying diagram.
FindShortestPath | Overloaded. Finds the shortest path in the underlying diagram.

See Also

PathFinder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathFinder.FindAllCycles Method

PathFinder.FindAllCycles Method

Finds all cycles in the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PathCollection FindAllCycles ()
Visual Basic

Public Function FindAllCycles () As PathCollection

Return Value

A collection of Path objects; if no cycles are detected, the collection is empty.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming Namespace
FindCycle Method


MindFusion.Diagramming.PathFinder.FindAllPaths Method

PathFinder.FindAllPaths Method

Finds and returns all paths that exist between two DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PathCollection FindAllPaths (
DiagramNode from,
DiagramNode to
)
Visual Basic

Public Function FindAllPaths ( _
from As DiagramNode, _
to As DiagramNode _
) As PathCollection

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.

Return Value

A collection of Path objects; if no paths are found, the collection is empty.

Remarks

The returned Path instances include the from an to nodes.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming Namespace
FindShortestPath Method


MindFusion.Diagramming.PathFinder.FindCycle Method

PathFinder.FindCycle Method

Finds a cycle in the underlying diagram.

Overload List

Name | Description
PathFinder.FindCycle () | Finds a cycle in the Diagram.
PathFinder.FindCycle (DiagramNode) | Detects whether the specified DiagramNode participates in a cycle.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathFinder.FindCycle Method ()

PathFinder.FindCycle Method ()
See Also

Finds a cycle in the Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Path FindCycle ()
Visual Basic

Public Function FindCycle () As Path

Return Value

A Path instance that represents the found cycle; null (Nothing in Visual Basic) if no cycle is detected.

See Also

FindCycle Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming Namespace
FindShortestPath Method


MindFusion.Diagramming.PathFinder.FindCycle Method (DiagramNode)

PathFinder.FindCycle Method (DiagramNode)
See Also

Detects whether the specified DiagramNode participates in a cycle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Path FindCycle (
DiagramNode participant
)
Visual Basic

Public Function FindCycle ( _
participant As DiagramNode _
) As Path

Parameters

participant
A DiagramNode element which should participate in the found cycle.

Return Value

A Path instance that represents the found cycle; null (Nothing in Visual Basic) if no cycle is detected.

See Also

FindCycle Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming Namespace
FindAllCycles Method


MindFusion.Diagramming.PathFinder.FindLongestPath Method

PathFinder.FindLongestPath Method

Finds the longest path in the underlying diagram.

Overload List

Name | Description
PathFinder.FindLongestPath () | Finds the longest path in the graph.
PathFinder.FindLongestPath (DiagramNode, DiagramNode) | Finds the longest path between the specified DiagramNode objects.
PathFinder.FindLongestPath (Int64) | Finds the longest path in the diagram.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathFinder.FindLongestPath Method ()

PathFinder.FindLongestPath Method ()
See Also

Finds the longest path in the graph.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Path FindLongestPath ()
Visual Basic

Public Function FindLongestPath () As Path

Return Value

A Path instance that represents the longest path found; null (Nothing in Visual Basic) if there are no DiagramNode elements in the graph.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming Namespace
FindAllPaths Method


MindFusion.Diagramming.PathFinder.FindLongestPath Method (DiagramNode, DiagramNode)

PathFinder.FindLongestPath Method (DiagramNode, DiagramNode)
See Also

Finds the longest path between the specified DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Path FindLongestPath (
DiagramNode from,
DiagramNode to
)
Visual Basic

Public Function FindLongestPath ( _
from As DiagramNode, _
to As DiagramNode _
) As Path

Parameters

from
The first DiagramNode element in the Path.
to
The last DiagramNode element in the Path.

Return Value

A Path instance that represents the longest path found; null (Nothing in Visual Basic) if there is no Path connecting from and to.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming Namespace
FindAllPaths Method


MindFusion.Diagramming.PathFinder.FindLongestPath Method (Int64)

PathFinder.FindLongestPath Method (Int64)
See Also

Finds the longest path in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Path FindLongestPath (
long timeLimit
)
Visual Basic

Public Function FindLongestPath ( _
timeLimit As Long _
) As Path

Parameters

timeLimit
The maximum duaration of the search process, in milliseconds.

Return Value

The longest Path found; null (Nothing in Visual Basic) if no Path has been detected.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming Namespace
FindAllPaths Method


MindFusion.Diagramming.PathFinder.FindShortestPath Method

PathFinder.FindShortestPath Method

Finds the shortest path in the underlying diagram.

Overload List

Name | Description
PathFinder.FindShortestPath (DiagramNode, DiagramNode) | Finds and returns the shortest Path between the specified DiagramNode objects.
PathFinder.FindShortestPath (DiagramNode, DiagramNode, Boolean, Boolean) | Finds and returns the shortest path between two DiagramNode elements, considering the Weight of the nodes, the Weight of the links or both.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PathFinder.FindShortestPath Method (DiagramNode, DiagramNode)

PathFinder.FindShortestPath Method (DiagramNode, DiagramNode)
See Also

Finds and returns the shortest Path between the specified DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Path FindShortestPath (
DiagramNode from,
DiagramNode to
)
Visual Basic

Public Function FindShortestPath ( _
from As DiagramNode, _
to As DiagramNode _
) As Path

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.

Return Value

A Path instance that represents the shortest path found; null (Nothing in Visual Basic) if there is no path connecting from and to.

See Also

FindShortestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming Namespace
FindAllPaths Method


MindFusion.Diagramming.PathFinder.FindShortestPath Method (DiagramNode, DiagramNode, Boolean, Boolean)

PathFinder.FindShortestPath Method (DiagramNode, DiagramNode, Boolean, Boolean)
See Also

Finds and returns the shortest path between two DiagramNode elements, considering the Weight of the nodes, the Weight of the links or both.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Path FindShortestPath (
DiagramNode from,
DiagramNode to,
bool useNodeWeights,
bool useLinkWeights
)
Visual Basic

Public Function FindShortestPath ( _
from As DiagramNode, _
to As DiagramNode, _
useNodeWeights As Boolean, _
useLinkWeights As Boolean _
) As Path

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.
useNodeWeights
If true, the Path with minimal total weight is found, summing the Weight of nodes in the Path.
useLinkWeights
If true, the Path with minimal total weight is found, summing the Weight of links in the Path.

Return Value

A Path instance that represents the shortest Path found or null (Nothing in Visual Basic) if there is no Path connecting from and to.

See Also

FindShortestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming Namespace
FindAllPaths Method


MindFusion.Diagramming.PersistableCollection Class

PersistableCollection Class

A base collection class for persistable collections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract class PersistableCollection : CollectionBase, IPersists
Visual Basic

Public MustInherit Class PersistableCollection
Inherits CollectionBase
Implements IPersists

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.PersistableCollection
MindFusion.Diagramming.AnchorPointCollection
MindFusion.Diagramming.GroupCollection
MindFusion.Diagramming.ItemCollectionBase

See Also

PersistableCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistableCollection Members

PersistableCollection Members
Constructors

A base collection class for persistable collections.

The following tables list the members exposed by the PersistableCollection type.

Protected Constructors

Name | Description
PersistableCollection | Initializes a new instance of the PersistableCollection class.

See Also

PersistableCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistableCollection Constructor

PersistableCollection Constructor

Initializes a new instance of the PersistableCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected PersistableCollection ()
Visual Basic

Protected Sub New ()

See Also

PersistableCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext Class

PersistContext Class

Contains methods that help serializing and deserializing complex MindFusion.Diagramming object to and from binary streams.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class PersistContext
Visual Basic

Public Class PersistContext

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.PersistContext

See Also

PersistContext Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext Members

PersistContext Members
Properties Methods

Contains methods that help serializing and deserializing complex MindFusion.Diagramming object to and from binary streams.

The following tables list the members exposed by the PersistContext type.

Public Properties

Name | Description
FileVersion | Gets the version of the diagram currently being loaded.
Reader | Gets the binary reader used for deserialization.
VersionTable | Gets the table of item class format revision numbers.
Writer | Gets the binary writer used for serialization.

Public Methods

Name | Description
GetObsoleteValue | This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.
LoadAnchorPattern | Loads an anchor pattern from the underlying stream.
LoadColor | Loads a color from the underlying stream.
LoadColorArray | Loads a color array from the underlying stream.
LoadFloatArray | Loads a float array from the underlying stream.
LoadFont | Loads a font from the underlying stream.
LoadHashtable | Loads a hashtable from the underlying stream.
LoadImage | Loads an image from the underlying stream.
LoadObject | Loads an IPersists object from the underlying stream.
loadPtfArray | Loads a PointF array from the underlying stream.
LoadRect | Loads a rectangle from the underlying stream.
LoadRectF | Loads a rectangle from the underlying stream.
LoadReference | Loads a reference for the specified referer.
LoadRemainingObjects | Loads the remaining referenced objects from the underlying stream.
LoadSizeF | Loads a SizeF object from the underlying stream.
LoadStringFormat | Loads a string format from the underlying stream.
LoadTag | Loads an object from the underlying stream.
ReadHeader | Reads the binary file format header from the underlying stream and throws an exception if the header is not recognized.
SaveAnchorPattern | Saves the specified anchor pattern to the underlying stream.
SaveColor | Saves the specified color to the underlying stream.
SaveColorArray | Saves the specified color array to the underlying stream.
SaveFloatArray | Saves the specified float array to the underlying stream.
SaveFont | Saves the specified font to the underlying stream.
SaveHashtable | Saves the specified hashtable to the underlying stream.
SaveImage | Saves the specified image to the underlying stream.
SaveObject | Writes the specified IPersists object to the underlying stream.
SavePtfArray | Saves the specified PointF array to the underlying stream.
SaveRect | Saves the specified rectangle to the underlying stream.
SaveRectF | Saves the specified rectangle to the underlying stream.
SaveReference | Saves the specified reference for the specified referer.
SaveSizeF | Saves the specified SizeF to the underlying stream.
SaveStringFormat | Saves the specified string format to the underlying stream.
SaveTag | Saves the specified object to the underlying stream.
SetReferences | Updates all references among loaded objects.
WriteHeader | Writes the binary file format header to the underlying stream.
WriteReferencedObjects | Writes all referenced objects to the underlying stream.

See Also

PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext Methods

PersistContext Methods

Public Methods

Name | Description
GetObsoleteValue | This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.
LoadAnchorPattern | Loads an anchor pattern from the underlying stream.
LoadColor | Loads a color from the underlying stream.
LoadColorArray | Loads a color array from the underlying stream.
LoadFloatArray | Loads a float array from the underlying stream.
LoadFont | Loads a font from the underlying stream.
LoadHashtable | Loads a hashtable from the underlying stream.
LoadImage | Loads an image from the underlying stream.
LoadObject | Loads an IPersists object from the underlying stream.
loadPtfArray | Loads a PointF array from the underlying stream.
LoadRect | Loads a rectangle from the underlying stream.
LoadRectF | Loads a rectangle from the underlying stream.
LoadReference | Loads a reference for the specified referer.
LoadRemainingObjects | Loads the remaining referenced objects from the underlying stream.
LoadSizeF | Loads a SizeF object from the underlying stream.
LoadStringFormat | Loads a string format from the underlying stream.
LoadTag | Loads an object from the underlying stream.
ReadHeader | Reads the binary file format header from the underlying stream and throws an exception if the header is not recognized.
SaveAnchorPattern | Saves the specified anchor pattern to the underlying stream.
SaveColor | Saves the specified color to the underlying stream.
SaveColorArray | Saves the specified color array to the underlying stream.
SaveFloatArray | Saves the specified float array to the underlying stream.
SaveFont | Saves the specified font to the underlying stream.
SaveHashtable | Saves the specified hashtable to the underlying stream.
SaveImage | Saves the specified image to the underlying stream.
SaveObject | Writes the specified IPersists object to the underlying stream.
SavePtfArray | Saves the specified PointF array to the underlying stream.
SaveRect | Saves the specified rectangle to the underlying stream.
SaveRectF | Saves the specified rectangle to the underlying stream.
SaveReference | Saves the specified reference for the specified referer.
SaveSizeF | Saves the specified SizeF to the underlying stream.
SaveStringFormat | Saves the specified string format to the underlying stream.
SaveTag | Saves the specified object to the underlying stream.
SetReferences | Updates all references among loaded objects.
WriteHeader | Writes the binary file format header to the underlying stream.
WriteReferencedObjects | Writes all referenced objects to the underlying stream.

See Also

PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.GetObsoleteValue Method

PersistContext.GetObsoleteValue Method

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Object GetObsoleteValue (
string id
)
Visual Basic

Public Shared Function GetObsoleteValue ( _
id As String _
) As Object

Parameters

id

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadAnchorPattern Method

PersistContext.LoadAnchorPattern Method

Loads an anchor pattern from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPattern LoadAnchorPattern ()
Visual Basic

Public Function LoadAnchorPattern () As AnchorPattern

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadColor Method

PersistContext.LoadColor Method

Loads a color from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color LoadColor ()
Visual Basic

Public Function LoadColor () As Color

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadColorArray Method

PersistContext.LoadColorArray Method

Loads a color array from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color[] LoadColorArray ()
Visual Basic

Public Function LoadColorArray () As Color()

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadFloatArray Method

PersistContext.LoadFloatArray Method

Loads a float array from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float[] LoadFloatArray ()
Visual Basic

Public Function LoadFloatArray () As Single()

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadFont Method

PersistContext.LoadFont Method

Loads a font from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Font LoadFont ()
Visual Basic

Public Function LoadFont () As Font

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadHashtable Method

PersistContext.LoadHashtable Method

Loads a hashtable from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Hashtable LoadHashtable ()
Visual Basic

Public Function LoadHashtable () As Hashtable

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadImage Method

PersistContext.LoadImage Method

Loads an image from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Image LoadImage ()
Visual Basic

Public Function LoadImage () As Image

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadObject Method

PersistContext.LoadObject Method

Loads an IPersists object from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object LoadObject ()
Visual Basic

Public Function LoadObject () As Object

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.loadPtfArray Method

PersistContext.loadPtfArray Method

Loads a PointF array from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF[] loadPtfArray ()
Visual Basic

Public Function loadPtfArray () As PointF()

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadRect Method

PersistContext.LoadRect Method

Loads a rectangle from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Rectangle LoadRect ()
Visual Basic

Public Function LoadRect () As Rectangle

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadRectF Method

PersistContext.LoadRectF Method

Loads a rectangle from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF LoadRectF ()
Visual Basic

Public Function LoadRectF () As RectangleF

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadReference Method

PersistContext.LoadReference Method

Loads a reference for the specified referer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void LoadReference (
IPersists referer
)
Visual Basic

Public Sub LoadReference ( _
referer As IPersists _
)

Parameters

referer

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadRemainingObjects Method

PersistContext.LoadRemainingObjects Method

Loads the remaining referenced objects from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void LoadRemainingObjects ()
Visual Basic

Public Sub LoadRemainingObjects ()

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadSizeF Method

PersistContext.LoadSizeF Method

Loads a SizeF object from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeF LoadSizeF ()
Visual Basic

Public Function LoadSizeF () As SizeF

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadStringFormat Method

PersistContext.LoadStringFormat Method

Loads a string format from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public StringFormat LoadStringFormat ()
Visual Basic

Public Function LoadStringFormat () As StringFormat

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.LoadTag Method

PersistContext.LoadTag Method

Loads an object from the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object LoadTag ()
Visual Basic

Public Function LoadTag () As Object

Return Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.ReadHeader Method

PersistContext.ReadHeader Method

Reads the binary file format header from the underlying stream and throws an exception if the header is not recognized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ReadHeader ()
Visual Basic

Public Sub ReadHeader ()

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveAnchorPattern Method

PersistContext.SaveAnchorPattern Method

Saves the specified anchor pattern to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveAnchorPattern (
AnchorPattern ap
)
Visual Basic

Public Sub SaveAnchorPattern ( _
ap As AnchorPattern _
)

Parameters

ap

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveColor Method

PersistContext.SaveColor Method

Saves the specified color to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveColor (
Color clr
)
Visual Basic

Public Sub SaveColor ( _
clr As Color _
)

Parameters

clr

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveColorArray Method

PersistContext.SaveColorArray Method

Saves the specified color array to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveColorArray (
Color[] arr
)
Visual Basic

Public Sub SaveColorArray ( _
arr() As Color _
)

Parameters

arr

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveFloatArray Method

PersistContext.SaveFloatArray Method

Saves the specified float array to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveFloatArray (
float[] arr
)
Visual Basic

Public Sub SaveFloatArray ( _
arr() As Single _
)

Parameters

arr

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveFont Method

PersistContext.SaveFont Method

Saves the specified font to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveFont (
Font font
)
Visual Basic

Public Sub SaveFont ( _
font As Font _
)

Parameters

font

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveHashtable Method

PersistContext.SaveHashtable Method

Saves the specified hashtable to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveHashtable (
Hashtable hashtable
)
Visual Basic

Public Sub SaveHashtable ( _
hashtable As Hashtable _
)

Parameters

hashtable

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveImage Method

PersistContext.SaveImage Method

Saves the specified image to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveImage (
Image image
)
Visual Basic

Public Sub SaveImage ( _
image As Image _
)

Parameters

image

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveObject Method

PersistContext.SaveObject Method

Writes the specified IPersists object to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveObject (
IPersists obj
)
Visual Basic

Public Sub SaveObject ( _
obj As IPersists _
)

Parameters

obj

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SavePtfArray Method

PersistContext.SavePtfArray Method

Saves the specified PointF array to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SavePtfArray (
PointF[] pts
)
Visual Basic

Public Sub SavePtfArray ( _
pts() As PointF _
)

Parameters

pts

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveRect Method

PersistContext.SaveRect Method

Saves the specified rectangle to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveRect (
Rectangle rect
)
Visual Basic

Public Sub SaveRect ( _
rect As Rectangle _
)

Parameters

rect

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveRectF Method

PersistContext.SaveRectF Method

Saves the specified rectangle to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveRectF (
RectangleF rect
)
Visual Basic

Public Sub SaveRectF ( _
rect As RectangleF _
)

Parameters

rect

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveReference Method

PersistContext.SaveReference Method

Saves the specified reference for the specified referer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveReference (
IPersists referer,
IPersists pobj,
int refId
)
Visual Basic

Public Sub SaveReference ( _
referer As IPersists, _
pobj As IPersists, _
refId As Integer _
)

Parameters

referer
pobj
refId

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveSizeF Method

PersistContext.SaveSizeF Method

Saves the specified SizeF to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveSizeF (
SizeF size
)
Visual Basic

Public Sub SaveSizeF ( _
size As SizeF _
)

Parameters

size

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveStringFormat Method

PersistContext.SaveStringFormat Method

Saves the specified string format to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveStringFormat (
StringFormat sf
)
Visual Basic

Public Sub SaveStringFormat ( _
sf As StringFormat _
)

Parameters

sf

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SaveTag Method

PersistContext.SaveTag Method

Saves the specified object to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveTag (
Object obj
)
Visual Basic

Public Sub SaveTag ( _
obj As Object _
)

Parameters

obj

Remarks

The objects is serialized if it is one of the .NET core types or if it is marked as Serializable.

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.SetReferences Method

PersistContext.SetReferences Method

Updates all references among loaded objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SetReferences ()
Visual Basic

Public Sub SetReferences ()

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.WriteHeader Method

PersistContext.WriteHeader Method

Writes the binary file format header to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void WriteHeader ()
Visual Basic

Public Sub WriteHeader ()

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.WriteReferencedObjects Method

PersistContext.WriteReferencedObjects Method

Writes all referenced objects to the underlying stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void WriteReferencedObjects ()
Visual Basic

Public Sub WriteReferencedObjects ()

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext Properties

PersistContext Properties

Public Properties

Name | Description
FileVersion | Gets the version of the diagram currently being loaded.
Reader | Gets the binary reader used for deserialization.
VersionTable | Gets the table of item class format revision numbers.
Writer | Gets the binary writer used for serialization.

See Also

PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.FileVersion Property

PersistContext.FileVersion Property

Gets the version of the diagram currently being loaded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int FileVersion { get; }
Visual Basic

Public ReadOnly Property FileVersion As Integer

Property Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.Reader Property

PersistContext.Reader Property

Gets the binary reader used for deserialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public BinaryReader Reader { get; }
Visual Basic

Public ReadOnly Property Reader As BinaryReader

Property Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.VersionTable Property

PersistContext.VersionTable Property

Gets the table of item class format revision numbers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Hashtable VersionTable { get; }
Visual Basic

Public ReadOnly Property VersionTable As Hashtable

Property Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PersistContext.Writer Property

PersistContext.Writer Property

Gets the binary writer used for serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public BinaryWriter Writer { get; }
Visual Basic

Public ReadOnly Property Writer As BinaryWriter

Property Value

See Also

PersistContext Members
PersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection Class

PointCollection Class

Represents a strongly typed collection of points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class PointCollection : CollectionBase, IPersists
Visual Basic

Public Class PointCollection
Inherits CollectionBase
Implements IPersists

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.PointCollection

See Also

PointCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection Members

PointCollection Members
Constructors Properties Methods

Represents a strongly typed collection of points.

The following tables list the members exposed by the PointCollection type.

Public Constructors

Name | Description
PointCollection | Overloaded. Initializes a new instance of the PointCollection class.

Public Properties

Name | Description
Item | Gets or sets the point at the specified position.

Public Methods

Name | Description
Add | Adds the specified point to the collection.
AddRange | Adds the points in the specified collection to this collection.
Clear | Removes all points from the collection.
Clone | Creates a shallow copy of this collection.
GetArray | Gets a PointF array containing the points in this collection.
GetAt | Gets the point at the specified position.
Insert | Inserts the specified point in the collection at the specified position.
Remove | Removes the specified point from the collection.
SetAt | Sets the specified point at the specified position within the collection.

See Also

PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection Constructor

PointCollection Constructor

Initializes a new instance of the PointCollection class.

Overload List

Name | Description
PointCollection (Int32) | Initializes a new instance of the PointCollection class with the specified initial size.
PointCollection (PointF[]) | Initializes a new instance of the PointCollection class with the specified point values.

See Also

PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection Constructor (Int32)

PointCollection Constructor (Int32)
See Also

Initializes a new instance of the PointCollection class with the specified initial size.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointCollection (
int size
)
Visual Basic

Public New ( _
size As Integer _
)

Parameters

size

The initial size of the collection.

See Also

PointCollection Constructor Overload List
PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection Constructor (PointF[])

PointCollection Constructor (PointF[])
See Also

Initializes a new instance of the PointCollection class with the specified point values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointCollection (
PointF[] points
)
Visual Basic

Public New ( _
points() As PointF _
)

Parameters

points

An array of PointF values that supplies the elements initially contained in the collection.

See Also

PointCollection Constructor Overload List
PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection Methods

PointCollection Methods

Public Methods

Name | Description
Add | Adds the specified point to the collection.
AddRange | Adds the points in the specified collection to this collection.
Clear | Removes all points from the collection.
Clone | Creates a shallow copy of this collection.
GetArray | Gets a PointF array containing the points in this collection.
GetAt | Gets the point at the specified position.
Insert | Inserts the specified point in the collection at the specified position.
Remove | Removes the specified point from the collection.
SetAt | Sets the specified point at the specified position within the collection.

See Also

PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection.Add Method

PointCollection.Add Method

Adds the specified point to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Add (
PointF point
)
Visual Basic

Public Sub Add ( _
point As PointF _
)

Parameters

point

The .NET PointF object to add to the collection.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection.AddRange Method

PointCollection.AddRange Method

Adds the points in the specified collection to this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void AddRange (
ICollection c
)
Visual Basic

Public Sub AddRange ( _
c As ICollection _
)

Parameters

c

The .NET ICollection object that contains the points to add to this collection.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection.Clear Method

PointCollection.Clear Method

Removes all points from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection.Clone Method

PointCollection.Clone Method

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointCollection Clone ()
Visual Basic

Public Function Clone () As PointCollection

Return Value

An instance of the PointCollection class.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection.GetArray Method

PointCollection.GetArray Method

Gets a PointF array containing the points in this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF[] GetArray ()
Visual Basic

Public Function GetArray () As PointF()

Return Value

An array of PointF objects containing all points in the colleciton.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection.GetAt Method

PointCollection.GetAt Method

Gets the point at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF GetAt (
int index
)
Visual Basic

Public Function GetAt ( _
index As Integer _
) As PointF

Parameters

index

The zero-based index of the point to retrieve.

Return Value

The PointF object at the specified index.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection.Insert Method

PointCollection.Insert Method

Inserts the specified point in the collection at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Insert (
int index,
PointF point
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
point As PointF _
)

Parameters

index
The zero-based index at which to insert the point.
point
The PointF object to add to the collection.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection.Remove Method

PointCollection.Remove Method

Removes the specified point from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Remove (
PointF point
)
Visual Basic

Public Sub Remove ( _
point As PointF _
)

Parameters

point

The PointF object to remove.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection.SetAt Method

PointCollection.SetAt Method

Sets the specified point at the specified position within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SetAt (
int index,
PointF point
)
Visual Basic

Public Sub SetAt ( _
index As Integer, _
point As PointF _
)

Parameters

index

The zero-based index of the point to set.

point

The PointF object to set at the specified position.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection Properties

PointCollection Properties

Public Properties

Name | Description
Item | Gets or sets the point at the specified position.

See Also

PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.PointCollection.Item Property

PointCollection.Item Property

Gets or sets the point at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As PointF

Parameters

index

The zero-based index of the point to set or retrieve.

Property Value

The PointF object at the specified index.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyCollection Class

ReadOnlyCollection Class

Represents a read-only wrapper of a collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ReadOnlyCollection : ICollection, IEnumerable
Visual Basic

Public Class ReadOnlyCollection
Implements ICollection, IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ReadOnlyCollection
MindFusion.Diagramming.ReadOnlyDiagramItemCollection
MindFusion.Diagramming.ReadOnlyDiagramLinkCollection
MindFusion.Diagramming.ReadOnlyDiagramNodeCollection

See Also

ReadOnlyCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyCollection Members

ReadOnlyCollection Members
Constructors Properties Methods

Represents a read-only wrapper of a collection.

The following tables list the members exposed by the ReadOnlyCollection type.

Public Constructors

Name | Description
ReadOnlyCollection | Initializes a new instance of the ReadOnlyCollection class.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

Name | Description
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that can iterate through the collection.

See Also

ReadOnlyCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyCollection Constructor

ReadOnlyCollection Constructor

Initializes a new instance of the ReadOnlyCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ReadOnlyCollection (
ICollection innerCollection
)
Visual Basic

Public New ( _
innerCollection As ICollection _
)

Parameters

innerCollection

A .NET ICollection that represents the collection to wrap.

See Also

ReadOnlyCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyCollection Methods

ReadOnlyCollection Methods

Public Methods

Name | Description
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that can iterate through the collection.

See Also

ReadOnlyCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyCollection.CopyTo Method

ReadOnlyCollection.CopyTo Method

Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void CopyTo (
Array array,
int index
)
Visual Basic

Public Overridable Sub CopyTo ( _
array As Array, _
index As Integer _
)

Parameters

array

The one-dimensional Array that is the destination of the elements copied from the current collection.

index

A 32-bit integer that represents the index in array at which copying begins.

See Also

ReadOnlyCollection Members
ReadOnlyCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyCollection.GetEnumerator Method

ReadOnlyCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual IEnumerator GetEnumerator ()
Visual Basic

Public Overridable Function GetEnumerator () As IEnumerator

Return Value

An .NET IEnumerator for the collection.

See Also

ReadOnlyCollection Members
ReadOnlyCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyCollection Properties

ReadOnlyCollection Properties

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

ReadOnlyCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyCollection.Count Property

ReadOnlyCollection.Count Property

Gets the number of elements contained in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual int Count { get; }
Visual Basic

Public Overridable ReadOnly Property Count As Integer

Property Value

An integer that represents the total number of elements in the collection.

See Also

ReadOnlyCollection Members
ReadOnlyCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyCollection.IsSynchronized Property

ReadOnlyCollection.IsSynchronized Property

Gets a value indicating whether the access to the collection is synchronized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool IsSynchronized { get; }
Visual Basic

Public Overridable ReadOnly Property IsSynchronized As Boolean

Property Value

true if access to the collection is synchronized (thread safe); otherwise, false. The default is false.

See Also

ReadOnlyCollection Members
ReadOnlyCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyCollection.SyncRoot Property

ReadOnlyCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Object SyncRoot { get; }
Visual Basic

Public Overridable ReadOnly Property SyncRoot As Object

Property Value

An object that can be used to synchronize access to the collection.

See Also

ReadOnlyCollection Members
ReadOnlyCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Class

ReadOnlyDiagramItemCollection Class

Represents a read-only collection of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ReadOnlyDiagramItemCollection : ReadOnlyCollection
Visual Basic

Public Class ReadOnlyDiagramItemCollection
Inherits ReadOnlyCollection

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ReadOnlyCollection
MindFusion.Diagramming.ReadOnlyDiagramItemCollection

See Also

ReadOnlyDiagramItemCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Members

ReadOnlyDiagramItemCollection Members
Constructors Properties Methods

Represents a read-only collection of items.

The following tables list the members exposed by the ReadOnlyDiagramItemCollection type.

Public Constructors

Name | Description
ReadOnlyDiagramItemCollection | Initializes a new instance of the ReadOnlyDiagramItemCollection class.

Public Properties

Name | Description
Item | Gets the DiagramItem at the specified position.

Public Methods

Name | Description
Contains | Checks whether the specified DiagramItem is contained within the collection.
IndexOf | Searches for the specified DiagramItem and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Constructor

ReadOnlyDiagramItemCollection Constructor

Initializes a new instance of the ReadOnlyDiagramItemCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ReadOnlyDiagramItemCollection (
DiagramItemCollection innerCollection
)
Visual Basic

Public Sub ReadOnlyDiagramItemCollection ( _
innerCollection As DiagramItemCollection _
)

Parameters

innerCollection

A DiagramItemCollection object that represents the collection to wrap.

Remarks

A DiagramItemCollection object that represents the collection to wrap.

See Also

ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Methods

ReadOnlyDiagramItemCollection Methods

Public Methods

Name | Description
Contains | Checks whether the specified DiagramItem is contained within the collection.
IndexOf | Searches for the specified DiagramItem and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramItemCollection.Contains Method

ReadOnlyDiagramItemCollection.Contains Method

Checks whether the specified DiagramItem is contained within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Contains (
DiagramItem item
)
Visual Basic

Public Function Contains ( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to search for in the collection.

Return Value

true if the specified item is contained in the collection; otherwise, false.

See Also

ReadOnlyDiagramItemCollection Members
ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramItemCollection.IndexOf Method

ReadOnlyDiagramItemCollection.IndexOf Method

Searches for the specified DiagramItem and returns the 0-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int IndexOf (
DiagramItem item
)
Visual Basic

Public Function IndexOf ( _
item As DiagramItem _
) As Integer

Parameters

item

The DiagramItem whose index to retreive from the collection.

Return Value

The zero-based index of the specified item within the colleciton; or -1 if the item is not found.

See Also

ReadOnlyDiagramItemCollection Members
ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Properties

ReadOnlyDiagramItemCollection Properties

Public Properties

Name | Description
Item | Gets the DiagramItem at the specified position.

See Also

ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramItemCollection.Item Property

ReadOnlyDiagramItemCollection.Item Property

Gets the DiagramItem at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item [
int index
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
index As Integer _
) As DiagramItem

Parameters

index

The zero-based index of the item to get.

Property Value

An instance of the DiagramItem class that represents the item at the specified position.

See Also

ReadOnlyDiagramItemCollection Members
ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Class

ReadOnlyDiagramLinkCollection Class

Represents a read-only collection of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ReadOnlyDiagramLinkCollection : ReadOnlyCollection
Visual Basic

Public Class ReadOnlyDiagramLinkCollection
Inherits ReadOnlyCollection

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ReadOnlyCollection
MindFusion.Diagramming.ReadOnlyDiagramLinkCollection

See Also

ReadOnlyDiagramLinkCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Members

ReadOnlyDiagramLinkCollection Members
Constructors Properties Methods

Represents a read-only collection of links.

The following tables list the members exposed by the ReadOnlyDiagramLinkCollection type.

Public Constructors

Name | Description
ReadOnlyDiagramLinkCollection | Initializes a new instance of the ReadOnlyDiagramLinkCollection class.

Public Properties

Name | Description
Item | Gets the DiagramLink at the specified position.

Public Methods

Name | Description
Contains | Checks whether the specified DiagramLink is contained within the collection.
IndexOf | Searches for the specified DiagramLink and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Constructor

ReadOnlyDiagramLinkCollection Constructor

Initializes a new instance of the ReadOnlyDiagramLinkCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ReadOnlyDiagramLinkCollection (
DiagramLinkCollection innerCollection
)
Visual Basic

Public Sub ReadOnlyDiagramLinkCollection ( _
innerCollection As DiagramLinkCollection _
)

Parameters

innerCollection

A DiagramLinkCollection object that represents the collection to wrap.

See Also

ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Methods

ReadOnlyDiagramLinkCollection Methods

Public Methods

Name | Description
Contains | Checks whether the specified DiagramLink is contained within the collection.
IndexOf | Searches for the specified DiagramLink and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection.Contains Method

ReadOnlyDiagramLinkCollection.Contains Method

Checks whether the specified DiagramLink is contained within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Contains (
DiagramLink link
)
Visual Basic

Public Function Contains ( _
link As DiagramLink _
) As Boolean

Parameters

link

The DiagramLink to search for in the collection.

Return Value

true if the specified link is contained in the collection; otherwise, false.

See Also

ReadOnlyDiagramLinkCollection Members
ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection.IndexOf Method

ReadOnlyDiagramLinkCollection.IndexOf Method

Searches for the specified DiagramLink and returns the 0-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int IndexOf (
DiagramLink link
)
Visual Basic

Public Function IndexOf ( _
link As DiagramLink _
) As Integer

Parameters

link

The DiagramLink whose index to retreive from the collection.

Return Value

The zero-based index of the specified link within the colleciton; or -1 if the link is not found.

See Also

ReadOnlyDiagramLinkCollection Members
ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Properties

ReadOnlyDiagramLinkCollection Properties

Public Properties

Name | Description
Item | Gets the DiagramLink at the specified position.

See Also

ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection.Item Property

ReadOnlyDiagramLinkCollection.Item Property

Gets the DiagramLink at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink Item [
int index
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
index As Integer _
) As DiagramLink

Parameters

index

The zero-based index of the link to get.

Property Value

An instance of the DiagramLink class that represents the link at the specified position.

See Also

ReadOnlyDiagramLinkCollection Members
ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Class

ReadOnlyDiagramNodeCollection Class

Represents a read-only collection of nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ReadOnlyDiagramNodeCollection : ReadOnlyCollection
Visual Basic

Public Class ReadOnlyDiagramNodeCollection
Inherits ReadOnlyCollection

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ReadOnlyCollection
MindFusion.Diagramming.ReadOnlyDiagramNodeCollection

See Also

ReadOnlyDiagramNodeCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Members

ReadOnlyDiagramNodeCollection Members
Constructors Properties Methods

Represents a read-only collection of nodes.

The following tables list the members exposed by the ReadOnlyDiagramNodeCollection type.

Public Constructors

Name | Description
ReadOnlyDiagramNodeCollection | Initializes a new instance of the ReadOnlyDiagramNodeCollection class.

Public Properties

Name | Description
Item | Gets the DiagramNode at the specified position.

Public Methods

Name | Description
Contains | Checks whether the specified DiagramNode is contained within the collection.
IndexOf | Searches for the specified DiagramNode and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Constructor

ReadOnlyDiagramNodeCollection Constructor

Initializes a new instance of the ReadOnlyDiagramNodeCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ReadOnlyDiagramNodeCollection (
DiagramNodeCollection innerCollection
)
Visual Basic

Public Sub ReadOnlyDiagramNodeCollection ( _
innerCollection As DiagramNodeCollection _
)

Parameters

innerCollection

A DiagramNodeCollection object that represents the collection to wrap.

See Also

ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Methods

ReadOnlyDiagramNodeCollection Methods

Public Methods

Name | Description
Contains | Checks whether the specified DiagramNode is contained within the collection.
IndexOf | Searches for the specified DiagramNode and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection.Contains Method

ReadOnlyDiagramNodeCollection.Contains Method

Checks whether the specified DiagramNode is contained within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Contains (
DiagramNode node
)
Visual Basic

Public Function Contains ( _
node As DiagramNode _
) As Boolean

Parameters

node

The DiagramNode to search for in the collection.

Return Value

true if the specified node is contained in the collection; otherwise, false.

See Also

ReadOnlyDiagramNodeCollection Members
ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection.IndexOf Method

ReadOnlyDiagramNodeCollection.IndexOf Method

Searches for the specified DiagramNode and returns the 0-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int IndexOf (
DiagramNode node
)
Visual Basic

Public Function IndexOf ( _
node As DiagramNode _
) As Integer

Parameters

node

The DiagramNode whose index to retreive from the collection.

Return Value

The zero-based index of the specified node within the colleciton; or -1 if the node is not found.

See Also

ReadOnlyDiagramNodeCollection Members
ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Properties

ReadOnlyDiagramNodeCollection Properties

Public Properties

Name | Description
Item | Gets the DiagramNode at the specified position.

See Also

ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection.Item Property

ReadOnlyDiagramNodeCollection.Item Property

Gets the DiagramNode at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Item [
int index
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
index As Integer _
) As DiagramNode

Parameters

index

The zero-based index of the node to get.

Property Value

An instance of the DiagramNode class that represents the node at the specified position.

See Also

ReadOnlyDiagramNodeCollection Members
ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RectangleFConverter Class

RectangleFConverter Class

Converts from RectangleF to other data types.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class RectangleFConverter : ExpandableObjectConverter
Visual Basic

Public Class RectangleFConverter
Inherits ExpandableObjectConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.ExpandableObjectConverter
MindFusion.Diagramming.RectangleFConverter

See Also

RectangleFConverter Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RectangleFConverter Members

RectangleFConverter Members
Constructors Methods

Converts from RectangleF to other data types.

The following tables list the members exposed by the RectangleFConverter type.

Public Constructors

Name | Description
RectangleFConverter | Initializes a new instance of the RectangleFConverter class.

Public Methods

Name | Description
CanConvertFrom | ExpandableObjectConverter.CanConvertFrom override.
CanConvertTo | ExpandableObjectConverter.CanConvertTo override.
ConvertFrom | ExpandableObjectConverter.ConvertFrom override.
ConvertTo | ExpandableObjectConverter.ConvertTo override.
CreateInstance | ExpandableObjectConverter.CreateInstance override.
GetCreateInstanceSupported | ExpandableObjectConverter.GetCreateInstanceSupported override.
GetProperties | ExpandableObjectConverter.GetProperties override.
GetPropertiesSupported | ExpandableObjectConverter.GetPropertiesSupported override.

See Also

RectangleFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RectangleFConverter Constructor

RectangleFConverter Constructor

Initializes a new instance of the RectangleFConverter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleFConverter ()
Visual Basic

Public Sub New ()

See Also

RectangleFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RectangleFConverter Methods

RectangleFConverter Methods

Public Methods

Name | Description
CanConvertFrom | ExpandableObjectConverter.CanConvertFrom override.
CanConvertTo | ExpandableObjectConverter.CanConvertTo override.
ConvertFrom | ExpandableObjectConverter.ConvertFrom override.
ConvertTo | ExpandableObjectConverter.ConvertTo override.
CreateInstance | ExpandableObjectConverter.CreateInstance override.
GetCreateInstanceSupported | ExpandableObjectConverter.GetCreateInstanceSupported override.
GetProperties | ExpandableObjectConverter.GetProperties override.
GetPropertiesSupported | ExpandableObjectConverter.GetPropertiesSupported override.

See Also

RectangleFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RectangleFConverter.CanConvertFrom Method

RectangleFConverter.CanConvertFrom Method

ExpandableObjectConverter.CanConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)
Visual Basic

Public Overrides Function CanConvertFrom ( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context
sourceType

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RectangleFConverter.CanConvertTo Method

RectangleFConverter.CanConvertTo Method

ExpandableObjectConverter.CanConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)
Visual Basic

Public Overrides Function CanConvertTo ( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context
destinationType

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RectangleFConverter.ConvertFrom Method

RectangleFConverter.ConvertFrom Method

ExpandableObjectConverter.ConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)
Visual Basic

Public Overrides Function ConvertFrom ( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context
culture
value

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RectangleFConverter.ConvertTo Method

RectangleFConverter.ConvertTo Method

ExpandableObjectConverter.ConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)
Visual Basic

Public Overrides Function ConvertTo ( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context
culture
value
destinationType

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RectangleFConverter.CreateInstance Method

RectangleFConverter.CreateInstance Method

ExpandableObjectConverter.CreateInstance override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Object CreateInstance (
ITypeDescriptorContext context,
IDictionary propertyValues
)
Visual Basic

Public Overrides Function CreateInstance ( _
context As ITypeDescriptorContext, _
propertyValues As IDictionary _
) As Object

Parameters

context
propertyValues

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RectangleFConverter.GetCreateInstanceSupported Method

RectangleFConverter.GetCreateInstanceSupported Method

ExpandableObjectConverter.GetCreateInstanceSupported override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool GetCreateInstanceSupported (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetCreateInstanceSupported ( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RectangleFConverter.GetProperties Method

RectangleFConverter.GetProperties Method

ExpandableObjectConverter.GetProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override PropertyDescriptorCollection GetProperties (
ITypeDescriptorContext context,
Object value,
Attribute[] attributes
)
Visual Basic

Public Overrides Function GetProperties ( _
context As ITypeDescriptorContext, _
value As Object, _
attributes() As Attribute _
) As PropertyDescriptorCollection

Parameters

context
value
attributes

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RectangleFConverter.GetPropertiesSupported Method

RectangleFConverter.GetPropertiesSupported Method

ExpandableObjectConverter.GetPropertiesSupported override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool GetPropertiesSupported (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetPropertiesSupported ( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context

Return Value

See Also

RectangleFConverter Members
RectangleFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Relationship Enumeration

Relationship Enumeration

Specifies the type of relationship between two tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum Relationship
Visual Basic

Public Enumeration Relationship

Members

Member name | Description
ManyToOne | The relationship is of type M:1, that is, many to one.
OneToMany | The relationship is of type 1:M, that is, one to many.

Remarks

Use the enumeration values when drawing database diagrams. It helps you specify how database tables' fields are related.

See Also

MindFusion.Diagramming Namespace
AddRelation Method


MindFusion.Diagramming.RenderOptions Class

RenderOptions Class

Provides properties that allow customization of various aspects of printing and print-preview.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class RenderOptions
Visual Basic

Public Class RenderOptions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.RenderOptions
MindFusion.Diagramming.WinForms.PrintOptions

See Also

RenderOptions Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions Members

RenderOptions Members
Constructors Properties

Provides properties that allow customization of various aspects of printing and print-preview.

The following tables list the members exposed by the RenderOptions type.

Public Constructors

Name | Description
RenderOptions | Initializes a new instance of the RenderOptions class.

Public Properties

Name | Description
CatchGdiPlusExceptions | Specifies which part of the diagram is currently visible.
EnableAnchors | Gets or sets a value indicating whether the printing of anchor point marks is enabled.
EnableBackground | Gets or sets a value indicating whether the printing of the background color is enabled.
EnableBackgroundImage | Gets or sets a value indicating whether the printing of the background image is enabled.
EnableEffects | Enables or disables special effects, such as emboss.
EnableImages | Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled.
EnableInterior | Gets or sets a value indicating whether the printing of node interiors is enabled.
EnableShadows | Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled.
EnableText | Gets or sets a value indicating whether the printing of the text of diagram items is enabled.
HyperLinkStyle | Specifies how various export components should treat the HyperLink property of items.
HyperLinkTarget | Specify the value of the target attribute generated by various export components for the HyperLink property of items.
PaintControls | Gets or sets a value indicating whether to execute custom painting code for ControlNode items when printing.
RenderTarget | Gets or sets the rendering target.
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.
ScrollX | Gets or sets the document's X scroll position.
ScrollY | Gets or sets the document's Y scroll position.
TargetView | Gets or sets the object that currently displays the Diagram.
VisibleRect | Specifies which part of the diagram is currently visible.

See Also

RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions Constructor

RenderOptions Constructor

Initializes a new instance of the RenderOptions class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RenderOptions ()
Visual Basic

Public Sub New ()

See Also

RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions Properties

RenderOptions Properties

Public Properties

Name | Description
CatchGdiPlusExceptions | Specifies which part of the diagram is currently visible.
EnableAnchors | Gets or sets a value indicating whether the printing of anchor point marks is enabled.
EnableBackground | Gets or sets a value indicating whether the printing of the background color is enabled.
EnableBackgroundImage | Gets or sets a value indicating whether the printing of the background image is enabled.
EnableEffects | Enables or disables special effects, such as emboss.
EnableImages | Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled.
EnableInterior | Gets or sets a value indicating whether the printing of node interiors is enabled.
EnableShadows | Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled.
EnableText | Gets or sets a value indicating whether the printing of the text of diagram items is enabled.
HyperLinkStyle | Specifies how various export components should treat the HyperLink property of items.
HyperLinkTarget | Specify the value of the target attribute generated by various export components for the HyperLink property of items.
PaintControls | Gets or sets a value indicating whether to execute custom painting code for ControlNode items when printing.
RenderTarget | Gets or sets the rendering target.
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.
ScrollX | Gets or sets the document's X scroll position.
ScrollY | Gets or sets the document's Y scroll position.
TargetView | Gets or sets the object that currently displays the Diagram.
VisibleRect | Specifies which part of the diagram is currently visible.

See Also

RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.CatchGdiPlusExceptions Property

RenderOptions.CatchGdiPlusExceptions Property

Specifies which part of the diagram is currently visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool CatchGdiPlusExceptions { get; set; }
Visual Basic

Public Property CatchGdiPlusExceptions As Boolean

Property Value

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.EnableAnchors Property

RenderOptions.EnableAnchors Property

Gets or sets a value indicating whether the printing of anchor point marks is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableAnchors { get; set; }
Visual Basic

Public Property EnableAnchors As Boolean

Property Value

true if anchor point marks should be printed; otherwise, false. The default is false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.EnableBackground Property

RenderOptions.EnableBackground Property

Gets or sets a value indicating whether the printing of the background color is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableBackground { get; set; }
Visual Basic

Public Property EnableBackground As Boolean

Property Value

true if the diagram background should be printed; otherwise, false. The default is false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.EnableBackgroundImage Property

RenderOptions.EnableBackgroundImage Property

Gets or sets a value indicating whether the printing of the background image is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableBackgroundImage { get; set; }
Visual Basic

Public Property EnableBackgroundImage As Boolean

Property Value

true if the background image should be printed; otherwise, false. The default is false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.EnableEffects Property

RenderOptions.EnableEffects Property

Enables or disables special effects, such as emboss.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableEffects { get; set; }
Visual Basic

Public Property EnableEffects As Boolean

Property Value

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.EnableImages Property

RenderOptions.EnableImages Property

Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableImages { get; set; }
Visual Basic

Public Property EnableImages As Boolean

Property Value

true to print node images; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.EnableInterior Property

RenderOptions.EnableInterior Property

Gets or sets a value indicating whether the printing of node interiors is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableInterior { get; set; }
Visual Basic

Public Property EnableInterior As Boolean

Property Value

true to print node interiors; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.EnableShadows Property

RenderOptions.EnableShadows Property

Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableShadows { get; set; }
Visual Basic

Public Property EnableShadows As Boolean

Property Value

true to print item shadows; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.EnableText Property

RenderOptions.EnableText Property

Gets or sets a value indicating whether the printing of the text of diagram items is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableText { get; set; }
Visual Basic

Public Property EnableText As Boolean

Property Value

true to print item texts; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.HyperLinkStyle Property

RenderOptions.HyperLinkStyle Property

Specifies how various export components should treat the HyperLink property of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public HyperLinkStyle HyperLinkStyle { get; set; }
Visual Basic

Public Property HyperLinkStyle As HyperLinkStyle

Property Value

A member of the HyperLinkStyle enumeration.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.HyperLinkTarget Property

RenderOptions.HyperLinkTarget Property

Specify the value of the target attribute generated by various export components for the HyperLink property of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string HyperLinkTarget { get; set; }
Visual Basic

Public Property HyperLinkTarget As String

Property Value

The default value is "_self".

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.PaintControls Property

RenderOptions.PaintControls Property

Gets or sets a value indicating whether to execute custom painting code for ControlNode items when printing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool PaintControls { get; set; }
Visual Basic

Public Property PaintControls As Boolean

Property Value

true to raise the appropriate event when printing controls; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.RenderTarget Property

RenderOptions.RenderTarget Property

Gets or sets the rendering target.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RenderTarget RenderTarget { get; set; }
Visual Basic

Public Property RenderTarget As RenderTarget

Property Value

A value from the RenderTarget enumeration specifying whether rendering is done on the screen or on a printer.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.Scale Property

RenderOptions.Scale Property

Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float Scale { get; set; }
Visual Basic

Public Property Scale As Single

Property Value

A float value specifying the scale factor of the print output.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.ScrollX Property

RenderOptions.ScrollX Property

Gets or sets the document's X scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ScrollX { get; set; }
Visual Basic

Public Property ScrollX As Single

Property Value

A float value specifying the X scroll position.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.ScrollY Property

RenderOptions.ScrollY Property

Gets or sets the document's Y scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ScrollY { get; set; }
Visual Basic

Public Property ScrollY As Single

Property Value

A float value specifying the Y scroll position.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.TargetView Property

RenderOptions.TargetView Property

Gets or sets the object that currently displays the Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object TargetView { get; set; }
Visual Basic

Public Property TargetView As Object

Property Value

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderOptions.VisibleRect Property

RenderOptions.VisibleRect Property

Specifies which part of the diagram is currently visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF VisibleRect { get; set; }
Visual Basic

Public Property VisibleRect As RectangleF

Property Value

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RenderTarget Enumeration

RenderTarget Enumeration

Specifies where the diagram is being rendered.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum RenderTarget
Visual Basic

Public Enumeration RenderTarget

Members

Member name | Description
Display | The diagram is rendered on the screen.
Printer | The diagram is rendered on a printer.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.RepaintEventArgs Class

RepaintEventArgs Class

Specifies the coordinates of the area that should be repainted by views when the Repaint event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class RepaintEventArgs : EventArgs
Visual Basic

Public Class RepaintEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.RepaintEventArgs

See Also

RepaintEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RepaintEventArgs Members

RepaintEventArgs Members
Constructors Properties

Specifies the coordinates of the area that should be repainted by views when the Repaint event is raised.

The following tables list the members exposed by the RepaintEventArgs type.

Public Constructors

Name | Description
RepaintEventArgs | Overloaded. Initializes a new instance of the RepaintEventArgs class.

Public Properties

Name | Description
InvalidRect | Gets the rectangular area in the diagram document that should be repainted.
RedrawCacheImage | Gets a value indicating whether the back-buffer cache image should be repainted as well.

See Also

RepaintEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RepaintEventArgs Constructor

RepaintEventArgs Constructor

Initializes a new instance of the RepaintEventArgs class.

Overload List

Name | Description
RepaintEventArgs (RectangleF) | Initializes a new instance of the RepaintEventArgs class.
RepaintEventArgs (RectangleF, Boolean) | Initializes a new instance of the RepaintEventArgs class.

See Also

RepaintEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RepaintEventArgs Constructor (RectangleF)

RepaintEventArgs Constructor (RectangleF)
See Also

Initializes a new instance of the RepaintEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RepaintEventArgs (
RectangleF invalidRect
)
Visual Basic

Public New ( _
invalidRect As RectangleF _
)

Parameters

invalidRect

A RectangleF object representing the rectangle that should be repainted.

See Also

RepaintEventArgs Constructor Overload List
RepaintEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RepaintEventArgs Constructor (RectangleF, Boolean)

RepaintEventArgs Constructor (RectangleF, Boolean)
See Also

Initializes a new instance of the RepaintEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RepaintEventArgs (
RectangleF invalidRect,
bool redrawCacheImage
)
Visual Basic

Public New ( _
invalidRect As RectangleF, _
redrawCacheImage As Boolean _
)

Parameters

invalidRect

A RectangleF object representing the rectangle that should be repainted.

redrawCacheImage

A boolean value specifying whether the diagram cache image used during modification should be re-created.

See Also

RepaintEventArgs Constructor Overload List
RepaintEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RepaintEventArgs Properties

RepaintEventArgs Properties

Public Properties

Name | Description
InvalidRect | Gets the rectangular area in the diagram document that should be repainted.
RedrawCacheImage | Gets a value indicating whether the back-buffer cache image should be repainted as well.

See Also

RepaintEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RepaintEventArgs.InvalidRect Property

RepaintEventArgs.InvalidRect Property

Gets the rectangular area in the diagram document that should be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF InvalidRect { get; }
Visual Basic

Public ReadOnly Property InvalidRect As RectangleF

Property Value

A RectangleF instance specifying the invalid rectangle. The value of RectangleF.Empty indicates that the whole view should be repainted.

See Also

RepaintEventArgs Members
RepaintEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RepaintEventArgs.RedrawCacheImage Property

RepaintEventArgs.RedrawCacheImage Property

Gets a value indicating whether the back-buffer cache image should be repainted as well.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RedrawCacheImage { get; }
Visual Basic

Public ReadOnly Property RedrawCacheImage As Boolean

Property Value

true to redraw the back-buffer image; otherwise, false.

See Also

RepaintEventArgs Members
RepaintEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RepaintEventHandler Delegate

RepaintEventHandler Delegate

Represents methods that will handle the Repaint event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void RepaintEventHandler (
Object sender,
RepaintEventArgs e
)
Visual Basic

Public Delegate Sub RepaintEventHandler ( _
sender As Object, _
e As RepaintEventArgs _
)

Parameters

sender

The source of the event.

e

A RepaintEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.RerouteLinks Enumeration

RerouteLinks Enumeration

Provides values indicating in what circumstances links must be rerouted automatically.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum RerouteLinks
Visual Basic

Public Enumeration RerouteLinks

Members

Member name | Description
Never | Do not reroute links automatically.
WhenIntersectNode | Reroute a link if it intersects a node.
WhenModified | Reroute a link if its end points are moved around.
WhileCreating | Route new links while users draw them. This flag can be combined with any of the previous two flags.

Remarks

These values can be assigned to the TriggerRerouting property of RoutingOptions.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.RestrictToBounds Enumeration

RestrictToBounds Enumeration

Specifies a restriction of the position of items relatively to the diagram bounds.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum RestrictToBounds
Visual Basic

Public Enumeration RestrictToBounds

Members

Member name | Description
InsideOnly | Items must be located entirely inside the document extents.
Intersection | Items must be located at least partially inside the document extents.
NoRestriction | No restriction on the position of items.

Remarks

This enumeration specifies the possible values of the RestrictItemsToBounds property.

See Also

MindFusion.Diagramming Namespace
RestrictItemsToBounds Property


MindFusion.Diagramming.RoundRectangleTemplate Class

RoundRectangleTemplate Class
Remarks See Also

Represents an ElementTemplate that draws round rectangle. This class ensures that the round corners do not change during resizing which is visually better. The drawback is that the radius appears to be specified in DiagramView Measure units and therefore a given shape instance will look bad when the measure unit is not the one for which the shape was designed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class RoundRectangleTemplate : ElementTemplate
Visual Basic

Public Class RoundRectangleTemplate
Inherits ElementTemplate

Remarks

This class ensures that the round corners do not change during resizing which is visually better. The drawback is that the radius appears to be specified in DiagramView Measure units and therefore a given shape instance will look bad when the measure unit is not the one for which the shape was designed.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.RoundRectangleTemplate

See Also

RoundRectangleTemplate Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoundRectangleTemplate Members

RoundRectangleTemplate Members
Constructors Properties Methods

Represents an ElementTemplate that draws round rectangle. This class ensures that the round corners do not change during resizing which is visually better. The drawback is that the radius appears to be specified in DiagramView Measure units and therefore a given shape instance will look bad when the measure unit is not the one for which the shape was designed.

The following tables list the members exposed by the RoundRectangleTemplate type.

Public Constructors

Name | Description
RoundRectangleTemplate | Overloaded. Initializes a new istance of the RoundRectangleTemplate class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Radius | Gets or sets the round radius of this element.

Public Methods

Name | Description
Clone | Creates an exact copy of this RoundRectangleTemplate element.
SameAs | ElementTemplate.SameAs override.

See Also

RoundRectangleTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoundRectangleTemplate Constructor

RoundRectangleTemplate Constructor

Initializes a new istance of the RoundRectangleTemplate class.

Overload List

Name | Description
RoundRectangleTemplate () | Initializes a new istance of the RoundRectangleTemplate class.
RoundRectangleTemplate (Single, Single, Single, Single, Single) | Initializes a new istance of the RoundRectangleTemplate class with the specified settings.

See Also

RoundRectangleTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoundRectangleTemplate Constructor ()

RoundRectangleTemplate Constructor ()
See Also

Initializes a new istance of the RoundRectangleTemplate class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RoundRectangleTemplate ()
Visual Basic

Public Sub New ()

See Also

RoundRectangleTemplate Constructor Overload List
RoundRectangleTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoundRectangleTemplate Constructor (Single, Single, Single, Single, Single)

RoundRectangleTemplate Constructor (Single, Single, Single, Single, Single)
See Also

Initializes a new istance of the RoundRectangleTemplate class with the specified settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RoundRectangleTemplate (
float x,
float y,
float w,
float h,
float r
)
Visual Basic

Public New ( _
x As Single, _
y As Single, _
w As Single, _
h As Single, _
r As Single _
)

Parameters

x
The x-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.
y

The y-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.

w
The width of the rectangle, expressed in percents of a shape node's bounding rectangle.
h

The height of the rectangle, expressed in percents of a shape node's bounding rectangle.

r

The round radius of the rectangle.

See Also

RoundRectangleTemplate Constructor Overload List
RoundRectangleTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoundRectangleTemplate Methods

RoundRectangleTemplate Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this RoundRectangleTemplate element.
SameAs | ElementTemplate.SameAs override.

See Also

RoundRectangleTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoundRectangleTemplate.Clone Method

RoundRectangleTemplate.Clone Method

Creates an exact copy of this RoundRectangleTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

An instance of the RoundRectangleTemplate class.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoundRectangleTemplate.SameAs Method

RoundRectangleTemplate.SameAs Method

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool SameAs (
ElementTemplate obj
)
Visual Basic

Public Overrides Function SameAs ( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this template.

Return Value

true if the specified object is a RoundRectangleTemplate closely approximating this template; otherwise, false.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoundRectangleTemplate Properties

RoundRectangleTemplate Properties

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Radius | Gets or sets the round radius of this element.

See Also

RoundRectangleTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoundRectangleTemplate.Bounds Property

RoundRectangleTemplate.Bounds Property

Gets the bounding rectangle of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As RectangleF

Property Value

A RectangleF object that represents the bounding rectangle of this element.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoundRectangleTemplate.Radius Property

RoundRectangleTemplate.Radius Property

Gets or sets the round radius of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float Radius { get; set; }
Visual Basic

Public Property Radius As Single

Property Value

A float value specifying the round radius of this element.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoutingOptions Class

RoutingOptions Class
Remarks See Also

Allows customization of various aspects of the link routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class RoutingOptions : RoutingOptions
Visual Basic

Public Class RoutingOptions
Implements RoutingOptions

Remarks

Use the RoutingOptions member of the Diagram class to access the sole instance of this class.

MindFusion.Diagramming uses a cost minimization algorithm to route links between nodes. For each link, there is a routing grid built for the area that encloses the link and its origin and destination nodes. The size of the grid pieces is set via GridSize. Each piece of the grid is marked as an obstacle if it intersects an Obstacle node. Some cost values are assigned to the remaining pieces, depending on how distant they are from nodes and other links.

That algorithm evaluates possible paths across the routing grid aiming to find one that has a minimal cost. The values of LengthCost, TurnCost, CrossingCost and NodeVicinityCost are added to the total cost of a route and have a great influence over the shape of the chosen path.

The StartOrientation and EndOrientation properties specify the orientation of the first and last segments of routed links, and Anchoring specifies whether link ends should be aligned to the anchor points defined for nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.RoutingOptions

See Also

RoutingOptions Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoutingOptions Members

RoutingOptions Members
Properties Methods

Allows customization of various aspects of the link routing algorithm.

The following tables list the members exposed by the RoutingOptions type.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating whether to align link ends to the anchor points of nodes.
CrossingCost | Gets or sets a value added to the total cost of a route which causes a link to cross another link.
Distance | Gets a heuristic delegate function that returns the real distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.
DistSquare | Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.
DontOptimizeLongRoutes | Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
EndPointsOffset | Gets or sets the minimum number of routing grid cells the end segments of links should occupy before they are allowed to bend.
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
MaxAbs | Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.
NodeVicinityCost | Gets or sets a value added to the total cost of a route if the route passes too close to a node.
NodeVicinitySize | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
RouteHeuristics | Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.
SmartPolylineEnds | Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.
TriggerRerouting | Gets or sets a value indicating under what circumstances links are rerouted automatically.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

Public Methods

Name | Description
SetDefaultMode | Resets all routing properties to their default values.
SetMinSegmentsMode | Assigns to the routing properties a predefined set of values which allow finding paths that have a small number of segments.
SetQuickMode | Assigns to the routing properties a predefined set of values which allow finding paths quickly but the found paths are of low quality.

See Also

RoutingOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoutingOptions Methods

RoutingOptions Methods

Public Methods

Name | Description
SetDefaultMode | Resets all routing properties to their default values.
SetMinSegmentsMode | Assigns to the routing properties a predefined set of values which allow finding paths that have a small number of segments.
SetQuickMode | Assigns to the routing properties a predefined set of values which allow finding paths quickly but the found paths are of low quality.

See Also

RoutingOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoutingOptions.SetDefaultMode Method

RoutingOptions.SetDefaultMode Method

Resets all routing properties to their default values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SetDefaultMode ()
Visual Basic

Public Sub SetDefaultMode ()

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
SetMinSegmentsMode Method
SetQuickMode Method


MindFusion.Diagramming.RoutingOptions.SetMinSegmentsMode Method

RoutingOptions.SetMinSegmentsMode Method

Assigns to the routing properties a predefined set of values which allow finding paths that have a small number of segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SetMinSegmentsMode ()
Visual Basic

Public Sub SetMinSegmentsMode ()

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
SetDefaultMode Method
SetQuickMode Method


MindFusion.Diagramming.RoutingOptions.SetQuickMode Method

RoutingOptions.SetQuickMode Method

Assigns to the routing properties a predefined set of values which allow finding paths quickly but the found paths are of low quality.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SetQuickMode ()
Visual Basic

Public Sub SetQuickMode ()

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
SetDefaultMode Method
SetMinSegmentsMode Method


MindFusion.Diagramming.RoutingOptions Properties

RoutingOptions Properties

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating whether to align link ends to the anchor points of nodes.
CrossingCost | Gets or sets a value added to the total cost of a route which causes a link to cross another link.
Distance | Gets a heuristic delegate function that returns the real distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.
DistSquare | Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.
DontOptimizeLongRoutes | Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
EndPointsOffset | Gets or sets the minimum number of routing grid cells the end segments of links should occupy before they are allowed to bend.
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
MaxAbs | Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.
NodeVicinityCost | Gets or sets a value added to the total cost of a route if the route passes too close to a node.
NodeVicinitySize | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
RouteHeuristics | Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.
SmartPolylineEnds | Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.
TriggerRerouting | Gets or sets a value indicating under what circumstances links are rerouted automatically.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoutingOptions.Anchoring Property

RoutingOptions.Anchoring Property

Gets or sets a value indicating whether to align link ends to the anchor points of nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Anchoring Anchoring { get; set; }
Visual Basic

Public Property Anchoring As Anchoring

Property Value

A member of the Anchoring enumeration. The default is Ignore.

Remarks

By default, the routing algorithm ignores anchor points. To make it align link ends to the points specified in the AnchorPattern property of nodes, set Anchoring to Keep or Reassign. Keep specifies that the routing algorithm does not change the positions of link end points. Reassign lets the routing algorithm choose new end points for a link from the ones specified in the AnchorPattern of its origin and destination nodes.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoutingOptions.CrossingCost Property

RoutingOptions.CrossingCost Property

Gets or sets a value added to the total cost of a route which causes a link to cross another link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public byte CrossingCost { get; set; }
Visual Basic

Public Property CrossingCost As Byte

Property Value

A byte value specifying the crossing cost. The default is 4.

Remarks

This is a penalty value added to the total cost of an evaluated link route if it crosses another link. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to CrossingCost leads to fewer link intersections. At this time CrossingCost processing is implemented only for links with Style set to Cascading.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
LengthCost Property
NodeVicinityCost Property
TurnCost Property


MindFusion.Diagramming.RoutingOptions.Distance Property

RoutingOptions.Distance Property

Gets a heuristic delegate function that returns the real distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static RouteHeuristics Distance { get; }
Visual Basic

Public Shared ReadOnly Property Distance As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by a RouteHeuristics delegate. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

Distance is a predefined delegate that assigns to pieces a heuristic value equaling the piece distance to the target. Thus of the four pieces adjacent to the current one, the piece closest to the target has the smallest value and the route generation continues through it. Distance is the default value of the RouteHeuristics property.

Example

The following sample demonstrates how to use this property:

C#

diagram.RoutingOptions.RouteHeuristics = RoutingOptions.Distance;
Visual Basic

Diagram.RoutingOptions.RouteHeuristics = RoutingOptions.Distance

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
DistSquare Property
MaxAbs Property


MindFusion.Diagramming.RoutingOptions.DistSquare Property

RoutingOptions.DistSquare Property

Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static RouteHeuristics DistSquare { get; }
Visual Basic

Public Shared ReadOnly Property DistSquare As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by a RouteHeuristics delegate. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

DistSquare is a predefined delegate that assigns to pieces a heuristic value equaling the piece distance to the target raised to the second power. DistSquare can be assigned to the RouteHeuristics property. By returning larger values than the default heuristic function Distance, it makes the prediction part of the routing algorithm have greater impact on the evaluated routes.That would lead to faster path-finding, but the real cost functions might have less impact and thus the quality of the found routes could be low.

Example

The following sample demonstrates how to use this property:

C#

diagram.RoutingOptions.RouteHeuristics = RoutingOptions.DistSquare;
Visual Basic

Diagram.RoutingOptions.RouteHeuristics = RoutingOptions.DistSquare

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
MaxAbs Property


MindFusion.Diagramming.RoutingOptions.DontOptimizeLongRoutes Property

RoutingOptions.DontOptimizeLongRoutes Property

Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool DontOptimizeLongRoutes { get; set; }
Visual Basic

Public Property DontOptimizeLongRoutes As Boolean

Property Value

true to disable route optimization for long links; otherwise, false. The default is false.

Remarks

Segment optimization done on routed links might need much processing time. The control allows disabling that optimization for long links. That would make the found routes have a "staircase" pattern when they run diagonally.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoutingOptions.EndOrientation Property

RoutingOptions.EndOrientation Property

Gets or sets the desired orientation of the last segments of routed links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Orientation EndOrientation { get; set; }
Visual Basic

Public Property EndOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

For some diagrams it might be desirable that first and last segments of links always have a specific direction. For example, in database ER diagrams links usually connect to table rows on the left- or right-hand sides of tables; in that case their end segments must be horizontal. EndOrientation specifies what orientation of links' last segments to be applied by the routing algorithm.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
StartOrientation Property


MindFusion.Diagramming.RoutingOptions.EndPointsOffset Property

RoutingOptions.EndPointsOffset Property

Gets or sets the minimum number of routing grid cells the end segments of links should occupy before they are allowed to bend.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int EndPointsOffset { get; set; }
Visual Basic

Public Property EndPointsOffset As Integer

Property Value

Number of routing grid cells the end segments of links should occupy before a bend is allowed. The default value is 0.

Remarks

Set this property to a value greater than 0 to ensure the first bend the link makes is not too close to the node boundaries.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
GridSize Property


MindFusion.Diagramming.RoutingOptions.GridSize Property

RoutingOptions.GridSize Property

Gets or sets the size of the pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual float GridSize { get; set; }
Visual Basic

Public Overridable Property GridSize As Single

Property Value

A float value specifying the size of the pieces of the routing grid. The default is 4.

Remarks

A smaller size of routing grid pieces helps finding more precise paths, however since the number of pieces increases, there would be more time needed to find a path.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoutingOptions.IgnoreAnchoring Property

RoutingOptions.IgnoreAnchoring Property

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool IgnoreAnchoring { get; }
Visual Basic

Public Overridable ReadOnly Property IgnoreAnchoring As Boolean

Property Value

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoutingOptions.LengthCost Property

RoutingOptions.LengthCost Property

Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual byte LengthCost { get; set; }
Visual Basic

Public Overridable Property LengthCost As Byte

Property Value

A byte value specifying the length cost. The default is 2.

Remarks

This is a penalty value added to the total cost of an evaluated link route for each piece of the routing grid it occupies. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to LengthCost leads to generating shorter paths.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
CrossingCost Property
NodeVicinityCost Property
TurnCost Property


MindFusion.Diagramming.RoutingOptions.MaxAbs Property

RoutingOptions.MaxAbs Property

Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static RouteHeuristics MaxAbs { get; }
Visual Basic

Public Shared ReadOnly Property MaxAbs As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by a RouteHeuristics delegate function. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

MaxAbs is a predefined delegate that assigns to pieces the higher value from the horizontal or vertical -only distances between a piece and the target. MaxAbs can be assigned to the RouteHeuristics property. By returning smaller values than the default heuristic function Distance, it makes the prediction part of the routing algorithm have less impact on the evaluated routes. That might lead to slower path-finding, but the real cost functions would have greater impact and thus the quality of the found routes could be higher.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoutingOptions.NodeVicinityCost Property

RoutingOptions.NodeVicinityCost Property

Gets or sets a value added to the total cost of a route if the route passes too close to a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual byte NodeVicinityCost { get; set; }
Visual Basic

Public Overridable Property NodeVicinityCost As Byte

Property Value

A byte value specifying the node vicinity cost. The default is 2.

Remarks

This is a penalty value added to the total cost of an evaluated link route if it passes too close to a node. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to NodeVicinityCost makes links avoid passing close to nodes. The size of the buffer area around nodes in which passing links get a penalty cost is set via NodeVicinitySize.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
CrossingCost Property
LengthCost Property
TurnCost Property


MindFusion.Diagramming.RoutingOptions.NodeVicinitySize Property

RoutingOptions.NodeVicinitySize Property

Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float NodeVicinitySize { get; set; }
Visual Basic

Public Property NodeVicinitySize As Single

Property Value

A floag value specifying the size of the buffer area in which passing routes receive a penalty cost. The default is 12.

Remarks

The pieces of the routing grid that are closest to a node have the value of NodeVicinityCost assigned as their cost. The outer pieces of the buffer zone are assigned a portion of NodeVicinityCost proportional to their distance to the node.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoutingOptions.RouteHeuristics Property

RoutingOptions.RouteHeuristics Property

Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RouteHeuristics RouteHeuristics { get; set; }
Visual Basic

Public Property RouteHeuristics As RouteHeuristics

Property Value

A RouteHeuristics delegate used to evaluate the distance from a current routing grid piece to the target one. The default is Distance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by RouteHeuristics. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

There are three predefined heuristic functions that can be assigned to RouteHeuristics: Distance, DistSquare and MaxAbs. All of them assign to pieces heuristic values that are larger for larger distances to the target. Thus of the four pieces adjacent to the current one, the piece closest to the target has the smallest value and the route generation continues through it.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoutingOptions.SmartPolylineEnds Property

RoutingOptions.SmartPolylineEnds Property

Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool SmartPolylineEnds { get; set; }
Visual Basic

Public Property SmartPolylineEnds As Boolean

Property Value

true to orient the end segments orthogonally to the node bounds; otherwise, false.

Remarks

This property is valid only for links of style Polyline.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
EndOrientation Property


MindFusion.Diagramming.RoutingOptions.StartOrientation Property

RoutingOptions.StartOrientation Property

Gets or sets the desired orientation of the first segments of routed links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Orientation StartOrientation { get; set; }
Visual Basic

Public Property StartOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Auto.

Remarks

For some diagrams it might be desirable that first and last segments of links always have a specific direction. For example, in database ER diagrams links usually connect to table rows on the left- or right-hand sides of tables; in that case their end segments must be horizontal. StartOrientation specifies what orientation of links' first segments to be applied by the routing algorithm.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
EndOrientation Property


MindFusion.Diagramming.RoutingOptions.TriggerRerouting Property

RoutingOptions.TriggerRerouting Property

Gets or sets a value indicating under what circumstances links are rerouted automatically.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RerouteLinks TriggerRerouting { get; set; }
Visual Basic

Public Property TriggerRerouting As RerouteLinks

Property Value

A member of the RerouteLinks enumeration. The default is WhenModified.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RoutingOptions.TurnCost Property

RoutingOptions.TurnCost Property

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual byte TurnCost { get; set; }
Visual Basic

Public Overridable Property TurnCost As Byte

Property Value

A byte value specifying the turn cost. The default is 4.

Remarks

This is a penalty value added to the total cost of an evaluated link route for each turn it makes. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to TurnCost leads paths that make less turns (hence they have less segments).

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming Namespace
CrossingCost Property
LengthCost Property
NodeVicinityCost Property


MindFusion.Diagramming.RowEventArgs Class

RowEventArgs Class

Contains the arguments passed to handlers of table row-related events, such as TableSectionCollapsed and TableSectionExpanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class RowEventArgs : EventArgs
Visual Basic

Public Class RowEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.RowEventArgs

See Also

RowEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RowEventArgs Members

RowEventArgs Members
Constructors Properties

Contains the arguments passed to handlers of table row-related events, such as TableSectionCollapsed and TableSectionExpanded.

The following tables list the members exposed by the RowEventArgs type.

Public Constructors

Name | Description
RowEventArgs | Initializes a new instance of the RowEventArgs class.

Public Properties

Name | Description
RowIndex | Gets the index of the table row for which the event has been raised.
Table | Get the table for which the event has been raised.

See Also

RowEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RowEventArgs Constructor

RowEventArgs Constructor

Initializes a new instance of the RowEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RowEventArgs (
TableNode table,
int rowIndex
)
Visual Basic

Public Sub RowEventArgs ( _
table As TableNode, _
rowIndex As Integer _
)

Parameters

table

The TableNode related to the event.

rowIndex

The zero-based index of the table row related to the event.

See Also

RowEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RowEventArgs Properties

RowEventArgs Properties

Public Properties

Name | Description
RowIndex | Gets the index of the table row for which the event has been raised.
Table | Get the table for which the event has been raised.

See Also

RowEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RowEventArgs.RowIndex Property

RowEventArgs.RowIndex Property

Gets the index of the table row for which the event has been raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int RowIndex { get; }
Visual Basic

Public ReadOnly Property RowIndex As Integer

Property Value

An integer value specifying the row's index.

See Also

RowEventArgs Members
RowEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RowEventArgs.Table Property

RowEventArgs.Table Property

Get the table for which the event has been raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode Table { get; }
Visual Basic

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class.

See Also

RowEventArgs Members
RowEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.RowEventHandler Delegate

RowEventHandler Delegate

Represents methods that will handle table row-related events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void RowEventHandler (
Object sender,
RowEventArgs e
)
Visual Basic

Public Delegate Sub RowEventHandler ( _
sender As Object, _
e As RowEventArgs _
)

Parameters

sender

The source of the event.

e

A RowEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.SaveToStringFormat Enumeration

SaveToStringFormat Enumeration

Specifies in what format to save the diagram when generating a string using the SaveToString method.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum SaveToStringFormat
Visual Basic

Public Enumeration SaveToStringFormat

Members

Member name | Description
Base16 | Indicates a Base16 ASCII encoding.
Base64 | Indicates a Base64 ASCII encoding.
CompressedXml | Indicates a compressed XML output.
Xml | Indicates a non-compressed XML output.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.ScriptHelper Class

ScriptHelper Class

Allows calling some static MindFusion.Diagramming methods from JavaScript and VBScript. It seems the script languages do not allow calling class static methods, so a ScriptHelper instance property is provided by the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ScriptHelper
Visual Basic

Public Class ScriptHelper

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ScriptHelper

See Also

ScriptHelper Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ScriptHelper Members

ScriptHelper Members
Constructors Methods

Allows calling some static MindFusion.Diagramming methods from JavaScript and VBScript. It seems the script languages do not allow calling class static methods, so a ScriptHelper instance property is provided by the Diagram class.

The following tables list the members exposed by the ScriptHelper type.

Public Constructors

Name | Description
ScriptHelper | Initializes a new instance of the ScriptHelper class.

Public Methods

Name | Description
ApplyLayout | Applies the specified layout to the underlying diagram.
CreateObject | Creates a MindFusion.Diagramming object given its class name.
CreateSolidBrush | Creates a solid brush with the specified color components.
NodesIntersect | Calculates whether the specified nodes' outlines intersect.
ShapeTemplateFromId | Returns the Shape having the specified identifier.

See Also

ScriptHelper Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ScriptHelper Constructor

ScriptHelper Constructor

Initializes a new instance of the ScriptHelper class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ScriptHelper (
Diagram diagram
)
Visual Basic

Public Sub ScriptHelper ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram the helper methods will work on.

See Also

ScriptHelper Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ScriptHelper Methods

ScriptHelper Methods

Public Methods

Name | Description
ApplyLayout | Applies the specified layout to the underlying diagram.
CreateObject | Creates a MindFusion.Diagramming object given its class name.
CreateSolidBrush | Creates a solid brush with the specified color components.
NodesIntersect | Calculates whether the specified nodes' outlines intersect.
ShapeTemplateFromId | Returns the Shape having the specified identifier.

See Also

ScriptHelper Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ScriptHelper.ApplyLayout Method

ScriptHelper.ApplyLayout Method

Applies the specified layout to the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ApplyLayout (
Object layout
)
Visual Basic

Public Sub ApplyLayout ( _
layout As Object _
)

Parameters

layout

An instance of one of the layout classes that represents the layout to perform on the underlying diagram.

See Also

ScriptHelper Members
ScriptHelper Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ScriptHelper.CreateObject Method

ScriptHelper.CreateObject Method

Creates a MindFusion.Diagramming object given its class name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object CreateObject (
string className
)
Visual Basic

Public Function CreateObject ( _
className As String _
) As Object

Parameters

className

The class name of the object to create.

Return Value

A reference to the MindFusion.Diagramming object of the specified class.

See Also

ScriptHelper Members
ScriptHelper Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ScriptHelper.CreateSolidBrush Method

ScriptHelper.CreateSolidBrush Method

Creates a solid brush with the specified color components.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Brush CreateSolidBrush (
int alpha,
int red,
int green,
int blue
)
Visual Basic

Public Function CreateSolidBrush ( _
alpha As Integer, _
red As Integer, _
green As Integer, _
blue As Integer _
) As Brush

Parameters

alpha

The alpha factor of the solid brush color.

red

The red component of the solid brush color.

green

The green component of the solid brush color.

blue
The blue component of the solid brush color.

Return Value

An instance of the MindFusion.Drawing.SolidBrush that represents the newly created brush.

See Also

ScriptHelper Members
ScriptHelper Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ScriptHelper.NodesIntersect Method

ScriptHelper.NodesIntersect Method

Calculates whether the specified nodes' outlines intersect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool NodesIntersect (
DiagramNode n1,
DiagramNode n2
)
Visual Basic

Public Function NodesIntersect ( _
n1 As DiagramNode, _
n2 As DiagramNode _
) As Boolean

Parameters

n1

The first DiagramNode to check.

n2

The second DiagramNode to check.

Return Value

true if the outlines of the specified nodes intersect; otherwise, false.

See Also

ScriptHelper Members
ScriptHelper Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ScriptHelper.ShapeTemplateFromId Method

ScriptHelper.ShapeTemplateFromId Method

Returns the Shape having the specified identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape ShapeTemplateFromId (
string shapeId
)
Visual Basic

Public Function ShapeTemplateFromId ( _
shapeId As String _
) As Shape

Parameters

shapeId

The id of the shape to create.

Return Value

An instance of the Shape class.

See Also

ScriptHelper Members
ScriptHelper Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection Class

Selection Class
Remarks See Also

Represents a set of items selected in the diagram document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public sealed class Selection : DiagramItem
Visual Basic

Public NotInheritable Class Selection
Inherits DiagramItem

Remarks

In a diagram document, several items can be selected simultaneously. If more than one item is selected, the compound set of selected items is handled by an instance of the Selection class.

Items in the selection can be of any element type. The Items property gives a collection of all the items in the selection. You can get type-safe access to items of specific class by using the Links and Nodes collections properties.

Users can select multiple items by drawing a selection rectangle. Depending on the DiagramView's Behavior, this is done either by simply dragging the mouse, or by holding CTRL down while dragging the mouse. Depending on the IncludeItemsIfIntersect value, items are selected if they are entirely inside the drawn selection rectangle, or if at least a part of them is inside the rectangle. It is possible to prevent users from selecting more than one items at the same time by setting AllowMultipleSelection to false.

Items can be always added or removed programmatically to selection by calling the AddItem and RemoveItem methods. Selection state of an item can be toggled, getting deselected from selected and vice versa, by calling the Toggle method. All items in the selection are deselected if Clear is invoked.

Use the Selected property of the DiagramItem class to determine whether a particular item is selected. The Selection's GetSize method returns how many items are selected. Bounds returns the rectangle that bounds all selected items.

The visual style of multiple selection is defined by the Style property. For example selection might be painted as a dashed rectangle or a semi-transparent filled rectangle.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.Selection

See Also

Selection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection Members

Selection Members
Properties Methods

Represents a set of items selected in the diagram document.

The following tables list the members exposed by the Selection type.

Public Properties

Name | Description
AllowMultipleSelection | Gets or sets a value indicating whether more than one items can be selected simultaneously.
Bounds | Gets the rectangle that bounds all selected items.
IncludeItemsIfIntersect | Gets or sets a value indicating which items are selected when drawing a selection rectangle.
Items | Gets a collection of all selected items.
Links | Gets the collection of all links in the selection.
Nodes | Gets a collection of all selected nodes.
Style | Gets or sets a value indicating how to display multiple selection of items.

Public Methods

Name | Description
AddItem | Adds a new item to the current selection.
Change | Selects an item and deselects all others.
Clear | Removes all items from the selection.
ContainsPoint | DiagramItem.ContainsPoint override.
Draw | DiagramItem.Draw override.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | DiagramItem.DrawShadow override.
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetSize | Gets the number of selected items.
HitTestHandle | DiagramItem.HitTestHandle override.
RemoveItem | Removes an item from the selection.
Toggle | Toggles the selection state of an item.

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
FreeResources | DiagramItem.FreeResources override.
LoadFrom | Deserializes the object from the specified reader.
SaveTo | Serializes the object to the specified writer.
SetReference | Updates the reference to the specified object.
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateModify | DiagramItem.UpdateModify override.

See Also

Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection Methods

Selection Methods

Public Methods

Name | Description
AddItem | Adds a new item to the current selection.
Change | Selects an item and deselects all others.
Clear | Removes all items from the selection.
ContainsPoint | DiagramItem.ContainsPoint override.
Draw | DiagramItem.Draw override.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | DiagramItem.DrawShadow override.
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetSize | Gets the number of selected items.
HitTestHandle | DiagramItem.HitTestHandle override.
RemoveItem | Removes an item from the selection.
Toggle | Toggles the selection state of an item.

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
FreeResources | DiagramItem.FreeResources override.
LoadFrom | Deserializes the object from the specified reader.
SaveTo | Serializes the object to the specified writer.
SetReference | Updates the reference to the specified object.
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateModify | DiagramItem.UpdateModify override.

See Also

Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.AddItem Method

Selection.AddItem Method

Adds a new item to the current selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void AddItem (
DiagramItem item
)
Visual Basic

Public Sub AddItem ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem to be added to the selection.

Remarks

This method adds a new item to the selection. It also deactivates the ActiveItem, if any, and makes the newly added item the active one.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Change Method
RemoveItem Method
Clear Method


MindFusion.Diagramming.Selection.AllowCreate Method

Selection.AllowCreate Method

DiagramItem.AllowCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual bool AllowCreate (
PointF current,
InteractionState ist
)
Visual Basic

Protected Overridable Function AllowCreate ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
ist

Return Value

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.AllowModify Method

Selection.AllowModify Method

DiagramItem.AllowModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual bool AllowModify (
PointF current,
InteractionState ist
)
Visual Basic

Protected Overridable Function AllowModify ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
ist

Return Value

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.Change Method

Selection.Change Method

Selects an item and deselects all others.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Change (
DiagramItem item
)
Visual Basic

Public Sub Change ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem which should be made active.

Remarks

Call this method to select an item and make it the ActiveItem. The method doesn't let you select locked items.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
AddItem Method
RemoveItem Method
Clear Method


MindFusion.Diagramming.Selection.Clear Method

Selection.Clear Method

Removes all items from the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Clear ()
Visual Basic

Public Sub Clear ()

Remarks

Call Clear to deselect all items. The items are not deleted. The method also sets the diagram's ActiveItem to null (Nothing in Visual Basic).

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
AddItem Method
RemoveItem Method


MindFusion.Diagramming.Selection.CompleteCreate Method

Selection.CompleteCreate Method

DiagramItem.CompleteCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void CompleteCreate (
PointF end
)
Visual Basic

Protected Overridable Sub CompleteCreate ( _
end As PointF _
)

Parameters

end

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.CompleteModify Method

Selection.CompleteModify Method

DiagramItem.CompleteModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void CompleteModify (
PointF end,
InteractionState ist
)
Visual Basic

Protected Overridable Sub CompleteModify ( _
end As PointF, _
ist As InteractionState _
)

Parameters

end
ist

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.ContainsPoint Method

Selection.ContainsPoint Method

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool ContainsPoint (
PointF point
)
Visual Basic

Public Overrides Function ContainsPoint ( _
point As PointF _
) As Boolean

Parameters

point
The point to check.

Return Value

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.Draw Method

Selection.Draw Method

DiagramItem.Draw override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void Draw (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public Overrides Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
options

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.DrawHandles Method

Selection.DrawHandles Method

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void DrawHandles (
IGraphics graphics,
Color color
)
Visual Basic

Public Overrides Sub DrawHandles ( _
graphics As IGraphics, _
color As Color _
)

Parameters

graphics
color

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.DrawShadow Method

Selection.DrawShadow Method

DiagramItem.DrawShadow override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public Overrides Sub DrawShadow ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
An IGraphics object where the shadow should be rendered.
options
A RenderOptions object specifying options for the drawing operation.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.FreeResources Method

Selection.FreeResources Method

DiagramItem.FreeResources override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void FreeResources ()
Visual Basic

Protected Overridable Sub FreeResources ()

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.GetRepaintRect Method

Selection.GetRepaintRect Method

DiagramItem.GetRepaintRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override RectangleF GetRepaintRect (
bool connected
)
Visual Basic

Public Overrides Function GetRepaintRect ( _
connected As Boolean _
) As RectangleF

Parameters

connected

Return Value

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.GetSize Method

Selection.GetSize Method

Gets the number of selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int GetSize ()
Visual Basic

Public Function GetSize () As Integer

Return Value

An integer value indicating the size of the collection.

Remarks

Call this method to get the number of selected items, including both nodes and links.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Items Property


MindFusion.Diagramming.Selection.HitTestHandle Method

Selection.HitTestHandle Method

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool HitTestHandle (
PointF pt,
ref int handle
)
Visual Basic

Public Overrides Function HitTestHandle ( _
pt As PointF, _
ByRef handle As Integer _
) As Boolean

Parameters

pt
handle

Return Value

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.LoadFrom Method

Selection.LoadFrom Method

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)
Visual Basic

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
context

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.RemoveItem Method

Selection.RemoveItem Method

Removes an item from the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RemoveItem (
DiagramItem item
)
Visual Basic

Public Function RemoveItem ( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem to be removed from the selection.

Return Value

true if the item has been successfully removed; otherwise, false.

Remarks

Call this method to deselect an item. Note that the item is not deleted, but just removed from the selection.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
AddItem Method


MindFusion.Diagramming.Selection.SaveTo Method

Selection.SaveTo Method

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)
Visual Basic

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
context

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.SetReference Method

Selection.SetReference Method

Updates the reference to the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SetReference (
int refId,
Object obj,
PersistContext context
)
Visual Basic

Protected Overridable Sub SetReference ( _
refId As Integer, _
obj As Object, _
context As PersistContext _
)

Parameters

refId
obj
context

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.StartCreate Method

Selection.StartCreate Method

DiagramItem.StartCreate override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void StartCreate (
PointF org
)
Visual Basic

Protected Overridable Sub StartCreate ( _
org As PointF _
)

Parameters

org

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.StartModify Method

Selection.StartModify Method

DiagramItem.StartModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void StartModify (
PointF org,
int handle,
InteractionState ist
)
Visual Basic

Protected Overridable Sub StartModify ( _
org As PointF, _
handle As Integer, _
ist As InteractionState _
)

Parameters

org
handle
ist

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.Toggle Method

Selection.Toggle Method

Toggles the selection state of an item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Toggle (
DiagramItem item
)
Visual Basic

Public Sub Toggle ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem whose selection state should be changed.

Remarks

Call this method to toggle an item's selection state. The method selects the diagram item passed as argument if previously it was deselected. If the item was selected, the method deselects it.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Change Method
AddItem Method
RemoveItem Method


MindFusion.Diagramming.Selection.UpdateModify Method

Selection.UpdateModify Method

DiagramItem.UpdateModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void UpdateModify (
PointF current,
InteractionState ist
)
Visual Basic

Protected Overridable Sub UpdateModify ( _
current As PointF, _
ist As InteractionState _
)

Parameters

current
ist

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection Properties

Selection Properties

Public Properties

Name | Description
AllowMultipleSelection | Gets or sets a value indicating whether more than one items can be selected simultaneously.
Bounds | Gets the rectangle that bounds all selected items.
IncludeItemsIfIntersect | Gets or sets a value indicating which items are selected when drawing a selection rectangle.
Items | Gets a collection of all selected items.
Links | Gets the collection of all links in the selection.
Nodes | Gets a collection of all selected nodes.
Style | Gets or sets a value indicating how to display multiple selection of items.

See Also

Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.AllowMultipleSelection Property

Selection.AllowMultipleSelection Property

Gets or sets a value indicating whether more than one items can be selected simultaneously.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowMultipleSelection { get; set; }
Visual Basic

Public Property AllowMultipleSelection As Boolean

Property Value

A boolean flag indicating whether multiple items can be selected simultaneously by the user.

Remarks

The property controls whether multiple items can be selected interactively. If it is disabled, multiple items can still be selected programmatically.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.Bounds Property

Selection.Bounds Property

Gets the rectangle that bounds all selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As RectangleF

Property Value

An instance of the.NET RectangleF structure.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.IncludeItemsIfIntersect Property

Selection.IncludeItemsIfIntersect Property

Gets or sets a value indicating which items are selected when drawing a selection rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool IncludeItemsIfIntersect { get; set; }
Visual Basic

Public Property IncludeItemsIfIntersect As Boolean

Property Value

true to select items that intersect the drawn selection rectangle; false to select items only if they are entirely inside the selection rectangle. The default is true.

Remarks

The value of this property is considered when users draw a selection rectangle using a pointing device. By default, all items inside the drawn rectangle and the ones that are only partially inside it are selected. Set the property to false to let users select items only when the items are entirely inside the selection rectangle.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Selection.Items Property

Selection.Items Property

Gets a collection of all selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItemCollection Items { get; }
Visual Basic

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class that represents the selected diagram items.

Remarks

You can select items programmatically by adding them to this collection.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Nodes Property
Links Property


MindFusion.Diagramming.Selection.Links Property

Selection.Links Property

Gets the collection of all links in the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLinkCollection Links { get; }
Visual Basic

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class that represents the selected diagram items.

Remarks

You can select links programmatically by adding them to this collection.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Items Property
Nodes Property


MindFusion.Diagramming.Selection.Nodes Property

Selection.Nodes Property

Gets a collection of all selected nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNodeCollection Nodes { get; }
Visual Basic

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class that represents the nodes in the selection.

Remarks

You can select nodes programmatically by adding them to this collection.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace
Items Property
Links Property


MindFusion.Diagramming.Selection.Style Property

Selection.Style Property

Gets or sets a value indicating how to display multiple selection of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public SelectionStyle Style { get; set; }
Visual Basic

Public Property Style As SelectionStyle

Property Value

A member of the SelectionStyle enumeration. The default is SelectionHandles.

Remarks

The property specifies how multiple selection is presented visually to users - with manipulation handles painted around each item or with a rectangle painted around all items.

See Also

Selection Members
Selection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SelectionCopy Class

SelectionCopy Class
Remarks See Also

Used internally in the implementation of copy/paste functions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public sealed class SelectionCopy
Visual Basic

Public NotInheritable Class SelectionCopy

Remarks

This class supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.SelectionCopy

See Also

SelectionCopy Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SelectionCopy Members

SelectionCopy Members
Constructors Properties

Used internally in the implementation of copy/paste functions.

The following tables list the members exposed by the SelectionCopy type.

Public Constructors

Name | Description
SelectionCopy | Initializes a new instance of the SelectionCopy class.

Public Properties

Name | Description
Groups | Gets the underlying collection of groups.
Items | Gets the underlying collection of items.
OriginalItems | Gets a collection of the original items.

See Also

SelectionCopy Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SelectionCopy Constructor

SelectionCopy Constructor

Initializes a new instance of the SelectionCopy class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public SelectionCopy (
DiagramItemCollection items,
DiagramItemCollection originalItems,
GroupCollection groups
)
Visual Basic

Public Sub SelectionCopy ( _
items As DiagramItemCollection, _
originalItems As DiagramItemCollection, _
groups As GroupCollection _
)

Parameters

items
A collection containing the item copies.
originalItems
A collection containing the original items.
groups
A collection containing the group copies.

Remarks

This constructor supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SelectionCopy Properties

SelectionCopy Properties

Public Properties

Name | Description
Groups | Gets the underlying collection of groups.
Items | Gets the underlying collection of items.
OriginalItems | Gets a collection of the original items.

See Also

SelectionCopy Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SelectionCopy.Groups Property

SelectionCopy.Groups Property

Gets the underlying collection of groups.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public GroupCollection Groups { get; }
Visual Basic

Public ReadOnly Property Groups As GroupCollection

Property Value

An instance of the GroupCollection class.

Remarks

This property supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Members
SelectionCopy Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SelectionCopy.Items Property

SelectionCopy.Items Property

Gets the underlying collection of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItemCollection Items { get; }
Visual Basic

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

This property supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Members
SelectionCopy Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SelectionCopy.OriginalItems Property

SelectionCopy.OriginalItems Property

Gets a collection of the original items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItemCollection OriginalItems { get; }
Visual Basic

Public ReadOnly Property OriginalItems As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

This property supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Members
SelectionCopy Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SelectionStyle Enumeration

SelectionStyle Enumeration

Defines values that specify how multiple selected items are indicated visually.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum SelectionStyle
Visual Basic

Public Enumeration SelectionStyle

Members

Member name | Description
Frame | A dashed rectangle is drawn around selected items.
SelectionHandles | Rectangular manipulation handles are painted over selected items.

Remarks

These values affect multiple selection of items. If only a single item is selected, it is drawn with manipulation handles around it.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.SerializeTagEventArgs Class

SerializeTagEventArgs Class

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class SerializeTagEventArgs : EventArgs
Visual Basic

Public Class SerializeTagEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.SerializeTagEventArgs

See Also

SerializeTagEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SerializeTagEventArgs Members

SerializeTagEventArgs Members
Properties

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

The following tables list the members exposed by the SerializeTagEventArgs type.

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the diagram element whose tag is being serialized/deserialized.
Representation | Gets or sets an XmlElement object where the tag should be serialized/deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SerializeTagEventArgs Properties

SerializeTagEventArgs Properties

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the diagram element whose tag is being serialized/deserialized.
Representation | Gets or sets an XmlElement object where the tag should be serialized/deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SerializeTagEventArgs.Context Property

SerializeTagEventArgs.Context Property

Gets a context object that can help you write and read various values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlPersistContext Context { get; }
Visual Basic

Public ReadOnly Property Context As XmlPersistContext

Property Value

An instance of the XmlPersistContext class.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SerializeTagEventArgs.Handled Property

SerializeTagEventArgs.Handled Property

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Handled { get; set; }
Visual Basic

Public Property Handled As Boolean

Property Value

true if you have serialized/deserialized the tag object; otherwise, false.

Remarks

Always set this flag to true if you perform custom tag serialization.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SerializeTagEventArgs.Object Property

SerializeTagEventArgs.Object Property

Gets the diagram element whose tag is being serialized/deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object Object { get; }
Visual Basic

Public ReadOnly Property Object As Object

Property Value

A diagram item, group, cell or anchor point.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SerializeTagEventArgs.Representation Property

SerializeTagEventArgs.Representation Property

Gets or sets an XmlElement object where the tag should be serialized/deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement Representation { get; set; }
Visual Basic

Public Property Representation As XmlElement

Property Value

An instance of the .NET XmlElement class that represents the root of the XML branch where the tag is / should be stored.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SerializeTagEventArgs.Tag Property

SerializeTagEventArgs.Tag Property

Gets or sets the tag object being serialized/deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object Tag { get; set; }
Visual Basic

Public Property Tag As Object

Property Value

An object containing the custom tag data.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SerializeTagEventHandler Delegate

SerializeTagEventHandler Delegate

Represents methods that will handle the SerializeTag and DeserializeTag events of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void SerializeTagEventHandler (
Object sender,
SerializeTagEventArgs e
)
Visual Basic

Public Delegate Sub SerializeTagEventHandler ( _
sender As Object, _
e As SerializeTagEventArgs _
)

Parameters

sender

The source of the event.

e

A SerializeTagEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShadowsStyle Enumeration

ShadowsStyle Enumeration

Enumerates possible shadows-drawing styles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum ShadowsStyle
Visual Basic

Public Enumeration ShadowsStyle

Members

Member name | Description
None | No shadows are drawn.
OneLevel | All shadows are drawn at the lowest z-level, and appear to be on one level.
ZOrder | Every shadows is drawn just below its item, possibly covering other items.

Remarks

This enumeration provides the possible values for the ShadowsStyle property of the Diagram class.

See Also

MindFusion.Diagramming Namespace
ShadowsStyle Property


MindFusion.Diagramming.Shape Class

Shape Class
Remarks See Also

An instance of this class represents a shape defined through a series of arc, line and Bézier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class Shape : ICloneable, IPersists
Visual Basic

Public Class Shape
Implements ICloneable, IPersists

Remarks

Shape Definitions

The Shape class provides the means for defining complex node shapes. With its help you can design any shape composed of lines, arcs and Bézier-curves. A shape template should contain an outline to be used for hit testing, clipping and finding intersections with other items. If the outline is not defined, the rectangle specified by the Bounds property of nodes is used for hit-testing. Optionally, shapes can contain decoration elements and text region definitions. Decorations are visual elements that do not take part in clipping, and are used for hit-testing only if DecorationHitTesting is enabled. Text regions are the parts of shapes in which node's text is laid out and rendered.

Predefined Shapes

MindFusion.Diagramming provides a set of about 100 predefined shape templates accessible through the static Shapes collection and the FromId method of Shape. A shape template can be applied to a node by assigning it to the Shape property of shape nodes. The predefined shapes are also exposed as properties of the Shapes class.

Custom Shapes

There are several Shape constructor overrides you might choose from, depending on the complexity of the shapes you want to create. They take arrays of ElementTemplate objects as arguments, which define the outline, decorations and text region definitions. Templates are described with coordinates expressed as percents of a shape node's area. It is also possible to associate an image with a shape definition by means of the Image property and to define the area in which the image is displayed by ImageRectangle.

Shape Libraries

The ShapeDesigner tool included in the MindFusion.Diagramming suite lets you draw custom shapes and store them in shape libraries. A library file can be loaded into your application using the ShapeLibrary class. The definitions loaded from a shape library are automatically added to the Shapes collection and can be accessed through the FromId method, just as the predefined shapes.

Example

Here is how the DirectAccessStorage shape is defined in the MindFusion.Diagramming source code:

C#

new Shape(

// Outlines
new ElementTemplate[]
{
new LineTemplate(10, 0, 90, 0),
new ArcTemplate(80, 0, 20, 100, -90, 180),
new LineTemplate(90, 100, 10, 100),
new ArcTemplate(0, 0, 20, 100, 90, 180)
},

// Decorations
new ElementTemplate[]
{
new ArcTemplate(0, 0, 20, 100, -90, 180)
},

// Text area
new ElementTemplate[]
{
new LineTemplate(10, 0, 90, 0),
new ArcTemplate(80, 0, 20, 100, -90, 180),
new LineTemplate(90, 100, 10, 100),
new BezierTemplate(10, 100, 35, 66, 35, 33, 10, 0)
},

FillMode.Winding, "DirectAccessStorage");
Visual Basic

New Shape( _
New ElementTemplate() _
{ _
New LineTemplate(10, 0, 90, 0), _
New ArcTemplate(80, 0, 20, 100, -90, 180), _
New LineTemplate(90, 100, 10, 100), _
New ArcTemplate(0, 0, 20, 100, 90, 180) _
}, _
New ElementTemplate() _
{ _
New ArcTemplate(0, 0, 20, 100, -90, 180) _
}, _
New ElementTemplate() _
{ _
New LineTemplate(10, 0, 90, 0), _
New ArcTemplate(80, 0, 20, 100, -90, 180), _
New LineTemplate(90, 100, 10, 100), _
New BezierTemplate(10, 100, 35, 66, 35, 33, 10, 0) _
}, _
FillMode.Winding, "DirectAccessStorage")

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Shape

See Also

Shape Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape Members

Shape Members
Constructors Properties Methods

An instance of this class represents a shape defined through a series of arc, line and Bézier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.

The following tables list the members exposed by the Shape type.

Public Constructors

Name | Description
Shape | Overloaded. Initializes a new instance of the Shape class.

Public Properties

Name | Description
AnchorPattern | Gets or sets the default anchor pattern for nodes that use this shape.
DecorationHitTesting | Gets or sets a value indicating whether decoration lines should be considered when hit-testing.
Decorations | Gets or sets a list with all decorations of this shape.
DisplayName | Specifies the name that should be displayed for this shape in user interface objects, for example the ShapeListBox or ShapeToolBar.
EnableOutline | Gets or sets a value indicating whether to enable the shape's outline.
FillMode | Gets or sets a value indicating how areas are filled if the outline path of the shape intersects itself.
Id | Gets or sets the shape identifier.
Image | Gets or sets the image displayed in all instances of this shape.
ImageLocation | Gets or sets the path to the file that contains the image displayed in this shape.
ImageRectangle | Gets or sets the position of the images displayed in instances of this shape.
Outline | Gets or sets the outline of this shape.
Shapes | Gets a read-only collection of all named shapes.
TextArea | Gets or sets the outline of the text area of this shape.

Public Methods

Name | Description
Clone | Creates an exact copy of this shape.
Equals | Checks whether this shape template is equivalent to the specified shape.
FromId | Returns a reference to the shape with the specified string identifier.
LoadFromXml | Loads the shape content from an XML element.
SaveToXml | Saves the shape content into an XML element.
ToString | Returns the identifier of this shape template.

See Also

Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape Constructor

Shape Constructor

Initializes a new instance of the Shape class.

Overload List

Name | Description
Shape (Byte[]) | Initializes a new instance of the Shape class with the specified outline.
Shape (Byte[], String) | Initializes a new instance of the Shape class with the specified outline and id.
Shape (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode) | Initializes a new instance of the Shape class with the specified outline, decorations and text area.
Shape (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String) | Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.
Shape (ElementTemplate[], FillMode) | Initializes a new instance of the Shape class with the specified outline.
Shape (ElementTemplate[], FillMode, String) | Initializes a new instance of the Shape class with the specified outline and id.

See Also

Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape Constructor (Byte[])

Shape Constructor (Byte[])
See Also

Initializes a new instance of the Shape class with the specified outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape (
byte[] outline
)
Visual Basic

Public New ( _
outline() As Byte _
)

Parameters

outline
An array containing even number of coordinate values, which define the points of the shape outline.

Remarks

The specified array should contain even number of values. Each odd value represents the X-coordinate and each even value represents the Y-coordinate of the corresponding point in the shape outline. The point coordinates are expressed in numbers in the interval [0..100] indicating the position of this point relative to the node's bounding rectangle.

Exceptions

Exception Type | Condition
ArgumentException | The specified array is a null reference (Nothing in Visual Basic), does not contain even number of elements or contains less than six arguments.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape Constructor (Byte[], String)

Shape Constructor (Byte[], String)
See Also

Initializes a new instance of the Shape class with the specified outline and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape (
byte[] outline,
string id
)
Visual Basic

Public New ( _
outline() As Byte, _
id As String _
)

Parameters

outline
An array containing even number of coordinate values, which define the points of the shape outline.
id
The string identifier of the new shape.

Remarks

The specified array should contain even number of values. Each odd value represents the X-coordinate and each even value represents the Y-coordinate of the corresponding point in the shape outline. The point coordinates are expressed in numbers in the interval [0..100] indicating the position of this point relative to the node's bounding rectangle.

Exceptions

Exception Type | Condition
ArgumentException | The specified array is a null reference (Nothing in Visual Basic), does not contain even number of elements or contains less than six arguments.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode)

Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode)
See Also

Initializes a new instance of the Shape class with the specified outline, decorations and text area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
ElementTemplate[] textArea,
FillMode fillMode
)
Visual Basic

Public Sub Shape ( _
elements As ElementTemplate(), _
decorations As ElementTemplate(), _
textArea As ElementTemplate(), _
fillMode As FillMode _
)

Parameters

elements
An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.
decorations
An array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. Decorations are visual elements that do not take part in hit testing and clipping.
textArea
An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bézier curves. Latter two are approximated to polygons by the text-formatting algorithm.
fillMode
Specifies how areas are filled if the outline path intersects itself.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String)

Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String)
See Also

Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
ElementTemplate[] textArea,
FillMode fillMode,
string id
)
Visual Basic

Public Sub Shape ( _
elements As ElementTemplate(), _
decorations As ElementTemplate(), _
textArea As ElementTemplate(), _
fillMode As FillMode, _
id As String _
)

Parameters

elements
An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.
decorations
An array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. Decorations are visual elements that do not take part in hit testing and clipping.
textArea

An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bézier curves. Latter two are approximated to polygons by the text-formatting algorithm.

fillMode
Specifies how areas are filled if the outline path intersects itself.
id
The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], FillMode)

Shape Constructor (ElementTemplate[], FillMode)
See Also

Initializes a new instance of the Shape class with the specified outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape (
ElementTemplate[] elements,
FillMode fillMode
)
Visual Basic

Public Sub Shape ( _
elements As ElementTemplate(), _
fillMode As FillMode _
)

Parameters

elements
An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.
fillMode
Specifies how areas are filled if the outline path intersects itself.

Example

C#

diagram.DefaultShape = new Shape(
new ElementTemplate[] {
new LineTemplate(0, 100, 35, 0),
new LineTemplate(35, 0, 100, 0),
new LineTemplate(100, 0, 65, 100),
new LineTemplate(65, 100, 0, 100) },
FillMode.Winding);
Visual Basic

diagram.DefaultShape = new Shape( _
new ElementTemplate() { _
new LineTemplate(0, 100, 35, 0), _
new LineTemplate(35, 0, 100, 0), _
new LineTemplate(100, 0, 65, 100), _
new LineTemplate(65, 100, 0, 100) }, _
FillMode.Winding)

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], FillMode, String)

Shape Constructor (ElementTemplate[], FillMode, String)
See Also

Initializes a new instance of the Shape class with the specified outline and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape (
ElementTemplate[] elements,
FillMode fillMode,
string id
)
Visual Basic

Public Sub Shape ( _
elements As ElementTemplate(), _
fillMode As FillMode, _
id As String _
)

Parameters

elements
Refers to an array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.
fillMode
Specifies how areas are filled if the outline path intersects itself.
id
The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape Methods

Shape Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this shape.
Equals | Checks whether this shape template is equivalent to the specified shape.
FromId | Returns a reference to the shape with the specified string identifier.
LoadFromXml | Loads the shape content from an XML element.
SaveToXml | Saves the shape content into an XML element.
ToString | Returns the identifier of this shape template.

See Also

Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.Clone Method

Shape.Clone Method

Creates an exact copy of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

An instance of the Shape class representing the newly created clone.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.Equals Method

Shape.Equals Method

Checks whether this shape template is equivalent to the specified shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public new bool Equals (
Shape shape
)
Visual Basic

Public Shadows Function Equals ( _
shape As Shape _
) As Boolean

Parameters

shape
The shape to check for equality with the current shape.

Return Value

true if the current shape is equivalent to the specified shape; otherwise, false.

Remarks

Two shapes are considered equivalent if they have the same fill type, the same number and type of segments and if the points of those segments are close enough to each other.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.FromId Method

Shape.FromId Method

Returns a reference to the shape with the specified string identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape FromId (
string id
)
Visual Basic

Public Shared Function FromId ( _
id As String _
) As Shape

Parameters

id
The identifier of the shape of interest.

Return Value

A reference to the Shape with the specified identifier or a null reference (Nothing in Visual Basic) if there is no such shape.

Remarks

The id argument should match an identifier passed to a constructor of the existing shape templates.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.LoadFromXml Method

Shape.LoadFromXml Method

Loads the shape content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Public Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
The XmlElement containing the shape's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace
SaveToXml Method


MindFusion.Diagramming.Shape.SaveToXml Method

Shape.SaveToXml Method

Saves the shape content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Public Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
The XmlElement the shape's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace
LoadFromXml Method


MindFusion.Diagramming.Shape.ToString Method

Shape.ToString Method

Returns the identifier of this shape template.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string value representing the shape identifier.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape Properties

Shape Properties

Public Properties

Name | Description
AnchorPattern | Gets or sets the default anchor pattern for nodes that use this shape.
DecorationHitTesting | Gets or sets a value indicating whether decoration lines should be considered when hit-testing.
Decorations | Gets or sets a list with all decorations of this shape.
DisplayName | Specifies the name that should be displayed for this shape in user interface objects, for example the ShapeListBox or ShapeToolBar.
EnableOutline | Gets or sets a value indicating whether to enable the shape's outline.
FillMode | Gets or sets a value indicating how areas are filled if the outline path of the shape intersects itself.
Id | Gets or sets the shape identifier.
Image | Gets or sets the image displayed in all instances of this shape.
ImageLocation | Gets or sets the path to the file that contains the image displayed in this shape.
ImageRectangle | Gets or sets the position of the images displayed in instances of this shape.
Outline | Gets or sets the outline of this shape.
Shapes | Gets a read-only collection of all named shapes.
TextArea | Gets or sets the outline of the text area of this shape.

See Also

Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.AnchorPattern Property

Shape.AnchorPattern Property

Gets or sets the default anchor pattern for nodes that use this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPattern AnchorPattern { get; set; }
Visual Basic

Public Property AnchorPattern As AnchorPattern

Property Value

An AnchorPattern instance. The default value is null (Nothing in Visual Basic).

Remarks

If the AnchorPattern of a ShapeNode is set, it overrides the one associated with the Shape definition.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.DecorationHitTesting Property

Shape.DecorationHitTesting Property

Gets or sets a value indicating whether decoration lines should be considered when hit-testing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool DecorationHitTesting { get; set; }
Visual Basic

Public Property DecorationHitTesting As Boolean

Property Value

true if decoration lines should be considered for hit-testing; otherwise, false. The default is false.

Remarks

If this property is enabled, users are able to select shape nodes of such shape by clicking near a decoration line or curve, even if it lies outside the shape outlines.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.Decorations Property

Shape.Decorations Property

Gets or sets a list with all decorations of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ElementTemplate[] Decorations { get; set; }
Visual Basic

Public Property Decorations As ElementTemplate()

Property Value

An array of ElementTemplate objects, defining the decorations of this shape.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.DisplayName Property

Shape.DisplayName Property

Specifies the name that should be displayed for this shape in user interface objects, for example the ShapeListBox or ShapeToolBar.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string DisplayName { get; set; }
Visual Basic

Public Property DisplayName As String

Property Value

The DisplayName of all predefined shapes is set to the value of their Id property.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.EnableOutline Property

Shape.EnableOutline Property

Gets or sets a value indicating whether to enable the shape's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableOutline { get; set; }
Visual Basic

Public Property EnableOutline As Boolean

Property Value

Remarks

When

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.FillMode Property

Shape.FillMode Property

Gets or sets a value indicating how areas are filled if the outline path of the shape intersects itself.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public FillMode FillMode { get; }
Visual Basic

Public ReadOnly Property FillMode As FillMode

Property Value

A member of the .NET FillMode enumeration specifying the fill type of the shape.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.Id Property

Shape.Id Property

Gets or sets the shape identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string Id { get; set; }
Visual Basic

Public Property Id As String

Property Value

A string id that has been passed as an argument of the Shape constructor.

Remarks

Once assigned through the constructor, the shape identifier should not be changed, that is, do not use the set accessor of this property. To get the shape with a specified id, call the static FromId method.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.Image Property

Shape.Image Property

Gets or sets the image displayed in all instances of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Image Image { get; set; }
Visual Basic

Public Property Image As Image

Property Value

An instance of the .NET Image class. The default is null (Nothing in Visual Basic).

Remarks

Assigning an image object to this property sets the ImageLocation to null (Nothing in Visual Basic). The image is displayed in the rectangle specified in ImageRectangle. If the Image property of a shape node is set, it overrides the image specified in the shape definition.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.ImageLocation Property

Shape.ImageLocation Property

Gets or sets the path to the file that contains the image displayed in this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ImageLocation { get; set; }
Visual Basic

Public Property ImageLocation As String

Property Value

A string containing the file path. The default is null (Nothing in Visual Basic).

Remarks

Assigning a valid file path to this property will automatically load the image. When adding a shape to a ShapeLibrary, if the Image property is set and the image location is not specified, the image bitmap contents is stored in the library file. If the image location is specified, only the path to the image file is saved in the shape library.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.ImageRectangle Property

Shape.ImageRectangle Property

Gets or sets the position of the images displayed in instances of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF ImageRectangle { get; set; }
Visual Basic

Public Property ImageRectangle As RectangleF

Property Value

A .NET RectangleF object specifying the location of an image relatively to the shape node that displays the image.

Remarks

The coordinates of the image location are specified in percent, relatively to the rectangular bounds of shape nodes. The default value (0, 0, 100, 100) makes the image displayed in the whole area of that node.

Example

The following code defines a shape, which displays an image in the lower-right quarter of shape nodes and lays out text in the other three quarters.

C#

Shape myShape = new Shape(

// Outlines: reuse the rectangle definition
Shape.FromId("Rectangle").Outline,

// Decorations: draw frame lines around the image
new ElementTemplate[] {
new LineTemplate(100, 50, 50, 50),
new LineTemplate(50, 50, 50, 100),
},

// Text area: the area not covered by the image rectangle
new ElementTemplate[] {
new LineTemplate(0, 0, 100, 0),
new LineTemplate(100, 0, 100, 50),
new LineTemplate(100, 50, 50, 50),
new LineTemplate(50, 50, 50, 100),
new LineTemplate(50, 100, 0, 100),
new LineTemplate(0, 100, 0, 0)
},

// The fill type
FillMode.Winding,

// The id
"MyShape");

// Image area: the lower right corner of boxes
myShape.ImageRectangle = new RectangleF(50, 50, 50, 50);

// Use the shape defined above
diagram.DefaultShape = myShape;

// Use polygonal text layout
diagram.EnableStyledText = true;
diagram.PolygonalTextLayout = true;
Visual Basic

Dim myShape As New Shape( _
Shape.FromId("Rectangle").Outline, _
New ElementTemplate() { _
New LineTemplate(100, 50, 50, 50), _
New LineTemplate(50, 50, 50, 100) _
}, _
New ElementTemplate() { _
New LineTemplate(0, 0, 100, 0), _
New LineTemplate(100, 0, 100, 50), _
New LineTemplate(100, 50, 50, 50), _
New LineTemplate(50, 50, 50, 100), _
New LineTemplate(50, 100, 0, 100), _
New LineTemplate(0, 100, 0, 0) _
}, _
FillMode.Winding, _
"MyShape")

' Image area: the lower right corner of boxes
myShape.ImageRectangle = New RectangleF(50, 50, 50, 50)

' Use the shape defined above
diagram.DefaultShape = myShape

' Use polygonal text layout
diagram.EnableStyledText = True
diagram.PolygonalTextLayout = True

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace
Image Property
Image Property


MindFusion.Diagramming.Shape.Outline Property

Shape.Outline Property

Gets or sets the outline of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ElementTemplate[] Outline { get; set; }
Visual Basic

Public Property Outline As ElementTemplate()

Property Value

An array of ElementTemplate object specifying the outline of the shape.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shape.Shapes Property

Shape.Shapes Property

Gets a read-only collection of all named shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static ShapeCollection Shapes { get; }
Visual Basic

Public Shared ReadOnly Property Shapes As ShapeCollection

Property Value

An instance of the ShapeCollection class.

Remarks

Initially the collection contains only the predefined shapes. Any new shape you create is added automatically to Shapes if an identifier has been specified via the Shape constructor.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace
FromId Method


MindFusion.Diagramming.Shape.TextArea Property

Shape.TextArea Property

Gets or sets the outline of the text area of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ElementTemplate[] TextArea { get; set; }
Visual Basic

Public Property TextArea As ElementTemplate()

Property Value

An array of ElementTemplate objects, defining the text area of this shape.

See Also

Shape Members
Shape Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeCollection Class

ShapeCollection Class

Represents a read-only collection of shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ShapeCollection : ICollection, IEnumerable
Visual Basic

Public Class ShapeCollection
Implements ICollection, IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ShapeCollection

See Also

ShapeCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeCollection Members

ShapeCollection Members
Properties Methods

Represents a read-only collection of shapes.

The following tables list the members exposed by the ShapeCollection type.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to this collection is synchronized.
Item | Gets or sets the diagram item at the specified position.
SyncRoot | Gets an object that can be used to synchoronize access to this collection.

Public Methods

Name | Description
Contains | Checks whether the specified shape is contained in the collection.
CopyTo | Copies a range of shapes from this collection to the specified one-dimensional array starting at the specified index of the target array.
GetAt | Gets the shape at the specified position.
GetEnumerator | Returns an enumerator for this collection.

See Also

ShapeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeCollection Methods

ShapeCollection Methods

Public Methods

Name | Description
Contains | Checks whether the specified shape is contained in the collection.
CopyTo | Copies a range of shapes from this collection to the specified one-dimensional array starting at the specified index of the target array.
GetAt | Gets the shape at the specified position.
GetEnumerator | Returns an enumerator for this collection.

See Also

ShapeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeCollection.Contains Method

ShapeCollection.Contains Method

Checks whether the specified shape is contained in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Contains (
Shape shape
)
Visual Basic

Public Function Contains ( _
shape As Shape _
) As Boolean

Parameters

shape

The Shape object to search for in the collection.

Return Value

true if the specified item was found in the collection; otherwise, false.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeCollection.CopyTo Method

ShapeCollection.CopyTo Method

Copies a range of shapes from this collection to the specified one-dimensional array starting at the specified index of the target array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void CopyTo (
Array array,
int index
)
Visual Basic

Public Overridable Sub CopyTo ( _
array As Array, _
index As Integer _
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from the current collection.
index

A 32-bit integer that represents the index in array at which copying begins.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeCollection.GetAt Method

ShapeCollection.GetAt Method

Gets the shape at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape GetAt (
int index
)
Visual Basic

Public Function GetAt ( _
index As Integer _
) As Shape

Parameters

index

The zero-based index of the shape to retrieve.

Return Value

An instance of the Shape class that represents the shape at the specified position.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeCollection.GetEnumerator Method

ShapeCollection.GetEnumerator Method

Returns an enumerator for this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual IEnumerator GetEnumerator ()
Visual Basic

Public Overridable Function GetEnumerator () As IEnumerator

Return Value

An .NET IEnumerator for the collection.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeCollection Properties

ShapeCollection Properties

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to this collection is synchronized.
Item | Gets or sets the diagram item at the specified position.
SyncRoot | Gets an object that can be used to synchoronize access to this collection.

See Also

ShapeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeCollection.Count Property

ShapeCollection.Count Property

Gets the number of elements contained in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual int Count { get; }
Visual Basic

Public Overridable ReadOnly Property Count As Integer

Property Value

An integer value specifying the size of the collection.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeCollection.IsSynchronized Property

ShapeCollection.IsSynchronized Property

Gets a value indicating whether the access to this collection is synchronized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool IsSynchronized { get; }
Visual Basic

Public Overridable ReadOnly Property IsSynchronized As Boolean

Property Value

true if access to the collection is synchronized (thread safe); otherwise, false. The default is false.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeCollection.Item Property

ShapeCollection.Item Property

Gets or sets the diagram item at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape Item [
int index
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
index As Integer _
) As Shape

Parameters

index

The zero-based index of the shape to retrieve.

Property Value

An instance of the Shape class that represents the shape at the specified position.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeCollection.SyncRoot Property

ShapeCollection.SyncRoot Property

Gets an object that can be used to synchoronize access to this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Object SyncRoot { get; }
Visual Basic

Public Overridable ReadOnly Property SyncRoot As Object

Property Value

An object that can be used to synchronize access to the collection.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeConverter Class

ShapeConverter Class

Converts from Shape to other data types.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ShapeConverter : TypeConverter
Visual Basic

Public Class ShapeConverter
Inherits TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Diagramming.ShapeConverter

See Also

ShapeConverter Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeConverter Members

ShapeConverter Members
Constructors Methods

Converts from Shape to other data types.

The following tables list the members exposed by the ShapeConverter type.

Public Constructors

Name | Description
ShapeConverter | Initializes a new instance of the ShapeConverter class.

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.
GetStandardValues | TypeConverter.GetStandardValues override.
GetStandardValuesExclusive | TypeConverter.GetStandardValuesExclusive override.
GetStandardValuesSupported | TypeConverter.GetStandardValuesSupported override.

See Also

ShapeConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeConverter Constructor

ShapeConverter Constructor

Initializes a new instance of the ShapeConverter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeConverter ()
Visual Basic

Public Sub New ()

See Also

ShapeConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeConverter Methods

ShapeConverter Methods

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.
GetStandardValues | TypeConverter.GetStandardValues override.
GetStandardValuesExclusive | TypeConverter.GetStandardValuesExclusive override.
GetStandardValuesSupported | TypeConverter.GetStandardValuesSupported override.

See Also

ShapeConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeConverter.CanConvertFrom Method

ShapeConverter.CanConvertFrom Method

TypeConverter.CanConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)
Visual Basic

Public Overrides Function CanConvertFrom ( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context
sourceType

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeConverter.CanConvertTo Method

ShapeConverter.CanConvertTo Method

TypeConverter.CanConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)
Visual Basic

Public Overrides Function CanConvertTo ( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context
destinationType

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeConverter.ConvertFrom Method

ShapeConverter.ConvertFrom Method

TypeConverter.ConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)
Visual Basic

Public Overrides Function ConvertFrom ( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context
culture
value

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeConverter.ConvertTo Method

ShapeConverter.ConvertTo Method

TypeConverter.ConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)
Visual Basic

Public Overrides Function ConvertTo ( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context
culture
value
destinationType

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeConverter.GetStandardValues Method

ShapeConverter.GetStandardValues Method

TypeConverter.GetStandardValues override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override TypeConverter.StandardValuesCollection GetStandardValues (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetStandardValues ( _
context As ITypeDescriptorContext _
) As TypeConverter.StandardValuesCollection

Parameters

context

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeConverter.GetStandardValuesExclusive Method

ShapeConverter.GetStandardValuesExclusive Method

TypeConverter.GetStandardValuesExclusive override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool GetStandardValuesExclusive (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetStandardValuesExclusive ( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeConverter.GetStandardValuesSupported Method

ShapeConverter.GetStandardValuesSupported Method

TypeConverter.GetStandardValuesSupported override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool GetStandardValuesSupported (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetStandardValuesSupported ( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeEventArgs Class

ShapeEventArgs Class

Contains the arguments passed to the ShapeSelected and ShapeRenamed event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ShapeEventArgs : EventArgs
Visual Basic

Public Class ShapeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.ShapeEventArgs

See Also

ShapeEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeEventArgs Members

ShapeEventArgs Members
Constructors Properties Methods

Contains the arguments passed to the ShapeSelected and ShapeRenamed event handlers.

The following tables list the members exposed by the ShapeEventArgs type.

Public Constructors

Name | Description
ShapeEventArgs | Overloaded. Initializes a new instance of the ShapeEventArgs class.

Public Properties

Name | Description
Index | Gets or sets the index of the Shape item within its containing collection.
OldName | Gets or sets the name of the shape before renaming.
Shape | Gets the shape related to the event.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

ShapeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeEventArgs Constructor

ShapeEventArgs Constructor

Initializes a new instance of the ShapeEventArgs class.

Overload List

Name | Description
ShapeEventArgs (Shape) | Initializes a new instance of the ShapeEventArgs class.
ShapeEventArgs (Shape, Int32) | Initializes a new instance of the ShapeEventArgs class.
ShapeEventArgs (Shape, Int32, String) | Initializes a new instance of the ShapeEventArgs class.

See Also

ShapeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeEventArgs Constructor (Shape)

ShapeEventArgs Constructor (Shape)
See Also

Initializes a new instance of the ShapeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeEventArgs (
Shape shapeTemplate
)
Visual Basic

Public Sub ShapeEventArgs ( _
shapeTemplate As Shape _
)

Parameters

shapeTemplate

The Shape related to the event.

See Also

ShapeEventArgs Constructor Overload List
ShapeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeEventArgs Constructor (Shape, Int32)

ShapeEventArgs Constructor (Shape, Int32)
See Also

Initializes a new instance of the ShapeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeEventArgs (
Shape shapeTemplate,
int index
)
Visual Basic

Public Sub ShapeEventArgs ( _
shapeTemplate As Shape, _
index As Integer _
)

Parameters

shapeTemplate

The Shape related to the event.

index

The zero-based index of the shape within its containing collection.

See Also

ShapeEventArgs Constructor Overload List
ShapeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeEventArgs Constructor (Shape, Int32, String)

ShapeEventArgs Constructor (Shape, Int32, String)
See Also

Initializes a new instance of the ShapeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeEventArgs (
Shape shapeTemplate,
int index,
string oldId
)
Visual Basic

Public Sub ShapeEventArgs ( _
shapeTemplate As Shape, _
index As Integer, _
oldId As String _
)

Parameters

shapeTemplate

The Shape related to the event.

index

The zero-based index of the shape within its containing collection.

oldName
The old DisplayName of the shape.

See Also

ShapeEventArgs Constructor Overload List
ShapeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeEventArgs Methods

ShapeEventArgs Methods

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

ShapeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeEventArgs.ToString Method

ShapeEventArgs.ToString Method

Object.ToString override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string that represents the object.

See Also

ShapeEventArgs Members
ShapeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeEventArgs Properties

ShapeEventArgs Properties

Public Properties

Name | Description
Index | Gets or sets the index of the Shape item within its containing collection.
OldName | Gets or sets the name of the shape before renaming.
Shape | Gets the shape related to the event.

See Also

ShapeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeEventArgs.Index Property

ShapeEventArgs.Index Property

Gets or sets the index of the Shape item within its containing collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int Index { get; set; }
Visual Basic

Public Property Index As Integer

Property Value

An integer value specifying the zero-based index of the shape.

See Also

ShapeEventArgs Members
ShapeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeEventArgs.OldName Property

ShapeEventArgs.OldName Property

Gets or sets the name of the shape before renaming.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string OldName { get; set; }
Visual Basic

Public Property OldName As String

Property Value

A string specifying the old value of the shape's DisplayName property.

Remarks

This property is relevant only for the ShapeRenamed event.

See Also

ShapeEventArgs Members
ShapeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeEventArgs.Shape Property

ShapeEventArgs.Shape Property

Gets the shape related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape Shape { get; }
Visual Basic

Public ReadOnly Property Shape As Shape

Property Value

An instance of the Shape class.

See Also

ShapeEventArgs Members
ShapeEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeEventHandler Delegate

ShapeEventHandler Delegate

Represents methods that will handle the ShapeSelected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void ShapeEventHandler (
Object sender,
ShapeEventArgs e
)
Visual Basic

Public Delegate Sub ShapeEventHandler ( _
sender As Object, _
e As ShapeEventArgs _
)

Parameters

sender

The source of the event.

e

A ShapeEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary Class

ShapeLibrary Class
Remarks See Also

The ShapeLibrary class represents a collection of shape definitions stored together.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ShapeLibrary
Visual Basic

Public Class ShapeLibrary

Remarks

Shape libraries can be created using the ShapeDesigner tool that comes with MindFusion.Diagramming. Use the LoadFrom method to load a shape library from a file. The loaded shapes can be accessed through the Shapes property. They will be automatically added to the shared list of shapes kept in the Shape class, which lets you access them through the FromId method. A shape library can be saved into a file in XML based format using the SaveToXml method.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ShapeLibrary

See Also

ShapeLibrary Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary Members

ShapeLibrary Members
Constructors Properties Methods

The ShapeLibrary class represents a collection of shape definitions stored together.

The following tables list the members exposed by the ShapeLibrary type.

Public Constructors

Name | Description
ShapeLibrary | Overloaded.

Public Properties

Name | Description
Shapes | Gets or sets the array of all shapes in the library.

Public Methods

Name | Description
LoadFrom | Loads a shape library from the specified file.
LoadFromXml | Overloaded.
SaveToXml | Overloaded.

See Also

ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary Constructor

ShapeLibrary Constructor

Overload List

Name | Description
ShapeLibrary () | Initializes a new empty instance of the ShapeLibrary class.
ShapeLibrary (Shape[]) | Initializes a new instance of the ShapeLibrary class.

See Also

ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary Constructor ()

ShapeLibrary Constructor ()
See Also

Initializes a new empty instance of the ShapeLibrary class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeLibrary ()
Visual Basic

Public Sub New ()

See Also

ShapeLibrary Constructor Overload List
ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary Constructor (Shape[])

ShapeLibrary Constructor (Shape[])
See Also

Initializes a new instance of the ShapeLibrary class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeLibrary (
Shape[] shapes
)
Visual Basic

Public Sub ShapeLibrary ( _
shapes As Shape() _
)

Parameters

shapes

An array of Shape object to initialize the libarary with.

See Also

ShapeLibrary Constructor Overload List
ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary Methods

ShapeLibrary Methods

Public Methods

Name | Description
LoadFrom | Loads a shape library from the specified file.
LoadFromXml | Overloaded.
SaveToXml | Overloaded.

See Also

ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary.LoadFrom Method

ShapeLibrary.LoadFrom Method

Loads a shape library from the specified file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static ShapeLibrary LoadFrom (
string fileName
)
Visual Basic

Public Shared Function LoadFrom ( _
fileName As String _
) As ShapeLibrary

Parameters

fileName
The name of the file that contains the shape library.

Return Value

An instance of the ShapeLibrary class whose Shapes array contains the loaded shape definitions.

See Also

ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method

ShapeLibrary.LoadFromXml Method

Overload List

Name | Description
ShapeLibrary.LoadFromXml (String) | Loads this library from the specified file.
ShapeLibrary.LoadFromXml (XmlDocument) | Loads the shape library from the specified XML document.
ShapeLibrary.LoadFromXml (XmlDocument, String) | Loads the library from the specified XML document. All locations of images associated with shapes in the library are loaded relative to the specified library path.

See Also

ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method (String)

ShapeLibrary.LoadFromXml Method (String)
See Also

Loads this library from the specified file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void LoadFromXml (
string fileName
)
Visual Basic

Public Sub LoadFromXml ( _
fileName As String _
)

Parameters

fileName
The name of the file from which to load the shape library.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method (XmlDocument)

ShapeLibrary.LoadFromXml Method (XmlDocument)
See Also

Loads the shape library from the specified XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void LoadFromXml (
XmlDocument document
)
Visual Basic

Public Sub LoadFromXml ( _
document As XmlDocument _
)

Parameters

document
The document to load the library from.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method (XmlDocument, String)

ShapeLibrary.LoadFromXml Method (XmlDocument, String)
See Also

Loads the library from the specified XML document. All locations of images associated with shapes in the library are loaded relative to the specified library path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void LoadFromXml (
XmlDocument document,
string libraryPath
)
Visual Basic

Public Sub LoadFromXml ( _
document As XmlDocument, _
libraryPath As String _
)

Parameters

document
libraryPath

Remarks

If the path is an empty string or null, image locations are loaded relative to the BaseURI of the specified document.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method

ShapeLibrary.SaveToXml Method

Overload List

Name | Description
ShapeLibrary.SaveToXml (String) | Saves this library to the specified file.
ShapeLibrary.SaveToXml (XmlDocument) | Saves the shape libaray into the specified XML document.
ShapeLibrary.SaveToXml (XmlDocument, String) | Saves the shape library into the specified XML document. All locations of images associated with shapes in the library are saved relative to the specified destination path.

See Also

ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method (String)

ShapeLibrary.SaveToXml Method (String)
See Also

Saves this library to the specified file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveToXml (
string fileName
)
Visual Basic

Public Sub SaveToXml ( _
fileName As String _
)

Parameters

fileName
The name of the file where to save the shape library.

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method (XmlDocument)

ShapeLibrary.SaveToXml Method (XmlDocument)
See Also

Saves the shape libaray into the specified XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveToXml (
XmlDocument document
)
Visual Basic

Public Sub SaveToXml ( _
document As XmlDocument _
)

Parameters

document

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method (XmlDocument, String)

ShapeLibrary.SaveToXml Method (XmlDocument, String)
See Also

Saves the shape library into the specified XML document. All locations of images associated with shapes in the library are saved relative to the specified destination path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void SaveToXml (
XmlDocument document,
string libraryFileName
)
Visual Basic

Public Sub SaveToXml ( _
document As XmlDocument, _
libraryFileName As String _
)

Parameters

document
libraryFileName

Remarks

If the path is an empty string or null, image locations are written as absolute.

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary Properties

ShapeLibrary Properties

Public Properties

Name | Description
Shapes | Gets or sets the array of all shapes in the library.

See Also

ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeLibrary.Shapes Property

ShapeLibrary.Shapes Property

Gets or sets the array of all shapes in the library.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape[] Shapes { get; set; }
Visual Basic

Public Property Shapes As Shape()

Property Value

An array of Shape objects containing the shape definitions.

See Also

ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode Class

ShapeNode Class
Remarks See Also

ShapeNode instances are diagram nodes that represent geometric shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ShapeNode : DiagramNode, InplaceEditable
Visual Basic

Public Class ShapeNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

A ShapeNode instance represents nodes in graphs, tree, process diagrams, and so on.

The shape of a node is specified through the Shape property. Shapes can be rotated, either interactively using the rotation handle above the node, or programmatically using the RotationAngle property.

Shape nodes can display images and text. Set an image to be painted inside a node by assigning it to the Image property. The position of the image within the node and its alignment are set by the ImageAlign property. To make a node as big as its image, call ResizeToFitImage.

Text inside a shape node is represented by the Text property. Its attributes can be changed by the TextColor and TextFormat properties. To get even richer text formatting, set EnableStyledText to true and embed HTML-like formatting tags in the raw text. Text can be laid out inside arbitrary polygonal shapes by enabling PolygonalTextLayout. To make a node big enough to display its text without clipping, call ResizeToFitText.

To let users edit a node's text inline, call the BeginEdit method of DiagramView. Call EndEdit to exit in-place editing mode.

Fill and border colors can be specified by setting the Pen and Brush properties. Shape nodes can be transparent as set through the Transparent property.

Shape nodes can have incoming and outgoing DiagramLink objects accessible through the IncomingLinks and OutgoingLinks properties defined in the DiagramNode class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.ShapeNode

See Also

ShapeNode Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode Members

ShapeNode Members
Constructors Properties Methods

ShapeNode instances are diagram nodes that represent geometric shapes.

The following tables list the members exposed by the ShapeNode type.

Public Constructors

Name | Description
ShapeNode | Overloaded. Initializes a new instance of the ShapeNode class.

Public Properties

Name | Description
CustomDraw | Gets or sets the type of custom drawing performed on this shape node.
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Font | Gets or sets the font used to render the node's text.
Image | Gets or sets the image that is displayed in this shape node.
ImageAlign | Gets or sets the alignment of the image displayed in this shape node.
PlainText | Gets the plain text of this shape node.
PolygonalTextLayout | Gets or sets a value indicating whether the node's Text is formatted inside non-rectangular outline.
RotateImage | Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated.
RotateText | Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated.
RotationAngle | Gets or sets the angle at which this shape node is rotated.
Shape | Gets or sets a reference to the node's geometric shape definition.
ShapeOrientation | Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds.
Text | Gets or sets the text displayed inside the shape node.
TextColor | Gets or sets the color of the text displayed in this shape node.
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes.
Transparent | Gets or sets a value indicating whether this shape node is transparent.

Public Methods

Name | Description
ContainsPoint | Overloaded.
Draw | Draws the node on the specified IGraphics surface.
DrawShadow | Draws the shadow of this node on the specified IGraphics surface.
GetIntersection | Finds the intersection of the node contour with the line segment defined by the specified points.
GetOutlinePoly |
GetRepaintRect | DiagramNode.GetRepaintRect override.
GetRotatedBounds | DiagramItem.GetRotatedBounds override.
GetRotationAngle | Returns the node rotation angle.
ResizeToFitImage | Makes the shape node as big as the image it displays.
ResizeToFitText | Makes the shape node big enough to display its text without clipping.

Protected Methods

Name | Description
AllowModify | DiagramNode.AllowModify override.
CompleteModify | DiagramNode.CompleteModify override.
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
Dispose | Disposes any disposable resources managed by this shape.
FreeResources | Called when the shape is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by users, programmatically or via undo / redo.
OnLoad | Called after the item is deserialized.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the Diagram's ZoomFactor changes.
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | Node.RestoreState override.
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetReference | Updates the reference to the specified object.
StartModify | DiagramNode.StartModify override.
UpdateModify | DiagramNode.UpdateModify override.

See Also

ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode Constructor

ShapeNode Constructor

Initializes a new instance of the ShapeNode class.

Overload List

Name | Description
ShapeNode () | Initializes a new instance of the ShapeNode class.
ShapeNode (Diagram) | Initializes a new instance of the ShapeNode class with default values supplied form the specified Diagram.
ShapeNode (ShapeNode) | Initializes a new instance of the ShapeNode class using the specified node as a prototype.

See Also

ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode Constructor ()

ShapeNode Constructor ()
See Also

Initializes a new instance of the ShapeNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeNode ()
Visual Basic

Public Sub New ()

See Also

ShapeNode Constructor Overload List
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode Constructor (Diagram)

ShapeNode Constructor (Diagram)
See Also

Initializes a new instance of the ShapeNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeNode (
Diagram parent
)
Visual Basic

Public Sub ShapeNode ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the ShapeNode properties with the values specified in the respective default-value properties of the Diagram object. For more information see Initial Values of Item Properties.

See Also

ShapeNode Constructor Overload List
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode Constructor (ShapeNode)

ShapeNode Constructor (ShapeNode)
See Also

Initializes a new instance of the ShapeNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeNode (
ShapeNode prototype
)
Visual Basic

Public Sub ShapeNode ( _
prototype As ShapeNode _
)

Parameters

prototype
The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

Remarks

This constructor copies the ShapeNode property values from the specified prototype node.

See Also

ShapeNode Constructor Overload List
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode Methods

ShapeNode Methods

Public Methods

Name | Description
ContainsPoint | Overloaded.
Draw | Draws the node on the specified IGraphics surface.
DrawShadow | Draws the shadow of this node on the specified IGraphics surface.
GetIntersection | Finds the intersection of the node contour with the line segment defined by the specified points.
GetOutlinePoly |
GetRepaintRect | DiagramNode.GetRepaintRect override.
GetRotatedBounds | DiagramItem.GetRotatedBounds override.
GetRotationAngle | Returns the node rotation angle.
ResizeToFitImage | Makes the shape node as big as the image it displays.
ResizeToFitText | Makes the shape node big enough to display its text without clipping.

Protected Methods

Name | Description
AllowModify | DiagramNode.AllowModify override.
CompleteModify | DiagramNode.CompleteModify override.
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
Dispose | Disposes any disposable resources managed by this shape.
FreeResources | Called when the shape is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by users, programmatically or via undo / redo.
OnLoad | Called after the item is deserialized.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the Diagram's ZoomFactor changes.
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | Node.RestoreState override.
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetReference | Updates the reference to the specified object.
StartModify | DiagramNode.StartModify override.
UpdateModify | DiagramNode.UpdateModify override.

See Also

ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.AllowModify Method

ShapeNode.AllowModify Method

DiagramNode.AllowModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual bool AllowModify (
PointF current,
InteractionState ist
)
Visual Basic

Protected Overridable Function AllowModify ( _
current As PointF, _
ist As InteractionState _
) As Boolean

Parameters

current
The current mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the modification of this node; otherwise, false.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.CompleteModify Method

ShapeNode.CompleteModify Method

DiagramNode.CompleteModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void CompleteModify (
PointF end,
InteractionState ist
)
Visual Basic

Protected Overridable Sub CompleteModify ( _
end As PointF, _
ist As InteractionState _
)

Parameters

end
The mouse pointer position.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.ContainsPoint Method

ShapeNode.ContainsPoint Method

Overload List

Name | Description
ShapeNode.ContainsPoint (PointF) | DiagramItem.ContainsPoint override.
ShapeNode.ContainsPoint (PointF, Single) | Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.ContainsPoint Method (PointF)

ShapeNode.ContainsPoint Method (PointF)
See Also

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool ContainsPoint (
PointF diagramPoint
)
Visual Basic

Public Overrides Function ContainsPoint ( _
diagramPoint As PointF _
) As Boolean

Parameters

diagramPoint

Return Value

See Also

ContainsPoint Method Overload List
ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.ContainsPoint Method (PointF, Single)

ShapeNode.ContainsPoint Method (PointF, Single)
See Also

Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool ContainsPoint (
PointF point,
float threshold
)
Visual Basic

Public Overrides Function ContainsPoint ( _
point As PointF, _
threshold As Single _
) As Boolean

Parameters

point
threshold

Return Value

See Also

ContainsPoint Method Overload List
ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.CreateConnectionPoint Method

ShapeNode.CreateConnectionPoint Method

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
PointF pt,
bool incoming
)
Visual Basic

Protected Overridable Function CreateConnectionPoint ( _
link As DiagramLink, _
pt As PointF, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
pt
The point at which the link should be connected.
incoming
true if link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.CreateProperties Method

ShapeNode.CreateProperties Method

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual DiagramItemProperties CreateProperties ()
Visual Basic

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.CreateState Method

ShapeNode.CreateState Method

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual DiagramItemState CreateState ()
Visual Basic

Protected Overridable Function CreateState () As DiagramItemState

Return Value

A ShapeNodeState instance.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.Dispose Method

ShapeNode.Dispose Method

Disposes any disposable resources managed by this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
Specifies whether the method is called explicitly or from the garbage collector.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.Draw Method

ShapeNode.Draw Method

Draws the node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void Draw (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public Overrides Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
An IGraphics object where the node should be rendered.
options
Provides options for the drawing operation.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.DrawShadow Method

ShapeNode.DrawShadow Method

Draws the shadow of this node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public Overrides Sub DrawShadow ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
An IGraphics object where the shadow should be rendered.
options
A RenderOptions object specifying options for the drawing operation.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.FreeResources Method

ShapeNode.FreeResources Method

Called when the shape is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void FreeResources ()
Visual Basic

Protected Overridable Sub FreeResources ()

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.GetIntersection Method

ShapeNode.GetIntersection Method

Finds the intersection of the node contour with the line segment defined by the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override PointF GetIntersection (
PointF segmentStart,
PointF segmentEnd
)
Visual Basic

Public Overrides Function GetIntersection ( _
segmentStart As PointF, _
segmentEnd As PointF _
) As PointF

Parameters

segmentStart
The first point of the segment.
segmentEnd
The second point of the segment.

Return Value

A PointF object representing the intersection point.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.GetOutlinePoly Method (Boolean)

ShapeNode.GetOutlinePoly Method (Boolean)
See Also

Node.GetOutlinePoly override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override PointCollection GetOutlinePoly (
bool rendering
)
Visual Basic

Public Overrides Function GetOutlinePoly ( _
rendering As Boolean _
) As PointCollection

Parameters

rendering

Return Value

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.GetRepaintRect Method

ShapeNode.GetRepaintRect Method

DiagramNode.GetRepaintRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override RectangleF GetRepaintRect (
bool includeConnected
)
Visual Basic

Public Overrides Function GetRepaintRect ( _
includeConnected As Boolean _
) As RectangleF

Parameters

includeConnected
true if related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this node is modified.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.GetRotatedBounds Method

ShapeNode.GetRotatedBounds Method

DiagramItem.GetRotatedBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override RectangleF GetRotatedBounds ()
Visual Basic

Public Overrides Function GetRotatedBounds () As RectangleF

Return Value

A rectangle that bounds the rotated shape of the item.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.GetRotationAngle Method

ShapeNode.GetRotationAngle Method

Returns the node rotation angle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override float GetRotationAngle ()
Visual Basic

Public Overrides Function GetRotationAngle () As Single

Return Value

A float value specifying the rotation angle.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.LoadFrom Method

ShapeNode.LoadFrom Method

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)
Visual Basic

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the item's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.LoadFromXml Method

ShapeNode.LoadFromXml Method

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.OnAdd Method

ShapeNode.OnAdd Method

Called when the item is added to a Diagram, either by users, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnAdd ()
Visual Basic

Protected Overridable Sub OnAdd ()

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.OnLoad Method

ShapeNode.OnLoad Method

Called after the item is deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnLoad ()
Visual Basic

Protected Overridable Sub OnLoad ()

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.OnMeasureUnitChanged Method

ShapeNode.OnMeasureUnitChanged Method

Called when the Diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnMeasureUnitChanged ()
Visual Basic

Protected Overridable Sub OnMeasureUnitChanged ()

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.OnUpdateBounds Method

ShapeNode.OnUpdateBounds Method

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnUpdateBounds ()
Visual Basic

Protected Overridable Sub OnUpdateBounds ()

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.OnZoomChanged Method

ShapeNode.OnZoomChanged Method

Called when the Diagram's ZoomFactor changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnZoomChanged ()
Visual Basic

Protected Overridable Sub OnZoomChanged ()

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.ResizeToFitImage Method

ShapeNode.ResizeToFitImage Method

Makes the shape node as big as the image it displays.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ResizeToFitImage ()
Visual Basic

Public Sub ResizeToFitImage ()

Remarks

Call this method to make a shape node exactly the same size as the image it contains. The dots-per-inch resolution of the image is considered too when calculating the new node size. Use the Image property to assign an image to a node and ImageAlign to specify position of the image within the node.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
ResizeToFitText Method


MindFusion.Diagramming.ShapeNode.ResizeToFitText Method

ShapeNode.ResizeToFitText Method

Makes the shape node big enough to display its text without clipping.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ResizeToFitText (
FitSize fit
)
Visual Basic

Public Function ResizeToFitText ( _
fit As FitSize _
) As Boolean

Parameters

fit
A member of the FitSize enumeration specifying whether the width or height of the node should remain unchanged.

Return Value

true if the node is resized successfully; otherwise, false.

Example

The following sample resizes a node to fit its text, using 1:1 width to height ratio.

C#

r = new RectangleF(shapeNode.Bounds.Left, shapeNode.Bounds.Top, 10, 10);

shapeNode.PolygonalTextLayout = true;
shapeNode.Bounds = r;
shapeNode.Text = "the method changes both the box' width" +
"and height, maintaining their original ratio.";
shapeNode.ResizeToFitText(FitSize.KeepRatio);
Visual Basic

r = New RectangleF(shapeNode.Bounds.Left, shapeNode.Bounds.Top, 10, 10)

shapeNode.PolygonalTextLayout = True
shapeNode.Bounds = r
shapeNode.Text = "the method changes both the box' width" + _
"and height, maintaining their original ratio."
shapeNode.ResizeToFitText(FitSize.KeepRatio)

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Text Property
ResizeToFitImage Method


MindFusion.Diagramming.ShapeNode.RestoreProperties Method

ShapeNode.RestoreProperties Method

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void RestoreProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.RestoreState Method

ShapeNode.RestoreState Method

Node.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void RestoreState (
DiagramItemState state
)
Visual Basic

Protected Overridable Sub RestoreState ( _
state As DiagramItemState _
)

Parameters

state

A ShapeNodeState instance.

Remarks

This method is called when a link should be restored to the state it had before user interaction.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.SaveProperties Method

ShapeNode.SaveProperties Method

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object where the item's properties should be saved.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.SaveState Method

ShapeNode.SaveState Method

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveState (
DiagramItemState state
)
Visual Basic

Protected Overridable Sub SaveState ( _
state As DiagramItemState _
)

Parameters

state
A ShapeNodeState instance.

Remarks

This method is called to save undo information when the users starts modifying a link.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.SaveTo Method

ShapeNode.SaveTo Method

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)
Visual Basic

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the item's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.SaveToXml Method

ShapeNode.SaveToXml Method

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.SetReference Method

ShapeNode.SetReference Method

Updates the reference to the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SetReference (
int refId,
Object obj,
PersistContext ctx
)
Visual Basic

Protected Overridable Sub SetReference ( _
refId As Integer, _
obj As Object, _
ctx As PersistContext _
)

Parameters

refId
Reference identifier.
obj
The newly loaded object.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is called for references that had been saved using the SaveReference method.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.StartModify Method

ShapeNode.StartModify Method

DiagramNode.StartModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void StartModify (
PointF org,
int handle,
InteractionState ist
)
Visual Basic

Protected Overridable Sub StartModify ( _
org As PointF, _
handle As Integer, _
ist As InteractionState _
)

Parameters

org
Position of the mouse pointer.
handle
Index of the adjustment handle used to modify the node.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.UpdateModify Method

ShapeNode.UpdateModify Method

DiagramNode.UpdateModify override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void UpdateModify (
PointF current,
InteractionState ist
)
Visual Basic

Protected Overridable Sub UpdateModify ( _
current As PointF, _
ist As InteractionState _
)

Parameters

current
Position of the mouse pointer.
ist
An InteractionState object containing more information about the current state of the operation.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode Properties

ShapeNode Properties

Public Properties

Name | Description
CustomDraw | Gets or sets the type of custom drawing performed on this shape node.
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Font | Gets or sets the font used to render the node's text.
Image | Gets or sets the image that is displayed in this shape node.
ImageAlign | Gets or sets the alignment of the image displayed in this shape node.
PlainText | Gets the plain text of this shape node.
PolygonalTextLayout | Gets or sets a value indicating whether the node's Text is formatted inside non-rectangular outline.
RotateImage | Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated.
RotateText | Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated.
RotationAngle | Gets or sets the angle at which this shape node is rotated.
Shape | Gets or sets a reference to the node's geometric shape definition.
ShapeOrientation | Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds.
Text | Gets or sets the text displayed inside the shape node.
TextColor | Gets or sets the color of the text displayed in this shape node.
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes.
Transparent | Gets or sets a value indicating whether this shape node is transparent.

See Also

ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.CustomDraw Property

ShapeNode.CustomDraw Property

Gets or sets the type of custom drawing performed on this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CustomDraw CustomDraw { get; set; }
Visual Basic

Public Property CustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of ShapeCustomDraw.

Remarks

This property allows invoking custom painting code for a shape node. That code must execute in response to the DrawNode event. There are several modes of custom painting, allowing the custom code to paint the shape node entirely, or do that in addition to what MindFusion.Diagramming paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member Name | Description
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming.
Additional | The custom painting code executes after the node interior and frame are painted by MindFusion.Diagramming, but before text is rendered. In this mode, the Graphics instance passed to the custom drawing event handler has a clipping region applied to it.
Full | The component does not do any standard drawing, the entire painting of the node is done by the application.
ShadowOnly | Only the shadow of the node is painted by custom code, the node itself is drawn by the component.
Additional2 | The custom painting code executes after all parts of the node are painted by MindFusion.Diagramming. In this mode, the Graphics instance passed to the custom drawing event handler doesn't have a clipping region applied to it.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.EnableStyledText Property

ShapeNode.EnableStyledText Property

Gets or sets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableStyledText { get; set; }
Visual Basic

Public Property EnableStyledText As Boolean

Property Value

true to parse the node's text in order to find formatting tags; otherwise, false. Initialized with the value of EnableStyledText.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. Formatting tags are listed and described in the Text Attributes and Formatting section of this help file.

Styled text can be enabled only if PolygonalTextLayout is set to true. If enabled, Text is parsed and analyzed each time it is changed. Parsing determines what formatting tags are used and adds the corresponding attribute records to MindFusion.Diagramming's internal representation of styled text. If the property value is false, the text is not processed in any way and is displayed without formatting.

Example

The following sample code demonstrates how to use styled text:

C#

shapeNode.PolygonalTextLayout = true;
shapeNode.EnableStyledText = true;
shapeNode.Text = "CH<sub>2</sub>CL<sub>2</sub> " + "\n" +
"<b><color=#0088FF>methylene-chloride</b>";
Visual Basic

shapeNode.PolygonalTextLayout = True
shapeNode.EnableStyledText = True
shapeNode.Text = "CH<sub>2</sub>CL<sub>2</sub> " + vbNewLine + _
"<b><color=#0088FF>methylene-chloride</b>"

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
TextFormat Property
Text Attributes and Formatting


MindFusion.Diagramming.ShapeNode.Font Property

ShapeNode.Font Property

Gets or sets the font used to render the node's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Font Font { get; set; }
Visual Basic

Public Overrides Property Font As Font

Property Value

A .NET Font instance specifying the font attributes.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.Image Property

ShapeNode.Image Property

Gets or sets the image that is displayed in this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Image Image { get; set; }
Visual Basic

Public Property Image As Image

Property Value

An instance of the .NET Image class. The default value is null (Nothing in Visual Basic).

Remarks

This property lets you display an image inside the node. The ImageRectangle attribute of the shape definition specifies a rectangular area inside the node in which the image is displayed. Use the ImageAlign property to specify how the image is aligned to that area. By default, the image is displayed in the center of the bounding rectangle of the node.

If there isn't any image assigned to this property, the shape node displays the Image specified in its Shape template.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
RotateImage Property
ResizeToFitImage Method


MindFusion.Diagramming.ShapeNode.ImageAlign Property

ShapeNode.ImageAlign Property

Gets or sets the alignment of the image displayed in this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ImageAlign ImageAlign { get; set; }
Visual Basic

Public Property ImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration. The default is Center.

Remarks

This property specifies how the Image is aligned to the bounding rectangle of this node. The image is aligned relatively to the rectangle specified in the ImageRectangle attribute of the Shape definition.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Image Property


MindFusion.Diagramming.ShapeNode.PlainText Property

ShapeNode.PlainText Property

Gets the plain text of this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string PlainText { get; }
Visual Basic

Public ReadOnly Property PlainText As String

Property Value

A string containing the plain text of the shape node.

Remarks

This property removes any formatting tags from the node's Text and returns the plain human-readable text. That is useful when styled text formatting is enabled and you need to display the node's text outside of MindFusion.Diagramming, for example in a message box or a dialog box.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
EnableStyledText Property


MindFusion.Diagramming.ShapeNode.PolygonalTextLayout Property

ShapeNode.PolygonalTextLayout Property

Gets or sets a value indicating whether the node's Text is formatted inside non-rectangular outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool PolygonalTextLayout { get; set; }
Visual Basic

Public Property PolygonalTextLayout As Boolean

Property Value

true to enable polygonal formatting; false to disable it.

Remarks

The node's area in which text is rendered can be explicitly defined for each Shape definition, and if it is not specified, the shape outline is used implicitly. The formatting algorithm is designed to layout text inside polygonal outlines. A polygonal approximation is created for outlines that have curved segments, so text can be laid out in shapes that consist of Bézier curves too.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Text Property
EnableStyledText Property
Shape Property


MindFusion.Diagramming.ShapeNode.RotateImage Property

ShapeNode.RotateImage Property

Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RotateImage { get; set; }
Visual Basic

Public Property RotateImage As Boolean

Property Value

true to rotate the node's image; otherwise, false. The default is true.

Remarks

The image is clipped by the rotated shape outline, even if this property is set to false.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
RotationAngle Property
RotateText Property


MindFusion.Diagramming.ShapeNode.RotateText Property

ShapeNode.RotateText Property

Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RotateText { get; set; }
Visual Basic

Public Property RotateText As Boolean

Property Value

true to rotate the node's text; otherwise, false. The default is false.

Remarks

If the property is set to false and PolygonalTextLayout is enabled, the text stays horizontal but it adapts to the rotated outline of the shape node.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
RotationAngle Property
RotateImage Property


MindFusion.Diagramming.ShapeNode.RotationAngle Property

ShapeNode.RotationAngle Property

Gets or sets the angle at which this shape node is rotated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float RotationAngle { get; set; }
Visual Basic

Public Property RotationAngle As Single

Property Value

A float number specifying the angle at which the shape node is rotated. The default is 0.

Remarks

Rotation is done around the center of a shape node, and it affects the shape outline, decoration lines and text position. The Text follows the node rotation if the RotateText property is activated, and the Image follows the node rotation if the RotateImage property is enabled. Even if your application does not need rotation of geometric shapes, it can still use rotated Transparent nodes to implement rotated text labels and images attached to composite objects.

The rotation angle grows in clockwise direction. Any value can be assigned programmatically to the property - MindFusion.Diagramming will use its modulo 360 as a rotation angle. If a user rotates a node with the rotation handle, the values of this property range from -180 to +180 degrees. By default, users are allowed to rotate shape nodes; to disable interactive rotation, clear the respective flag in EnabledHandles.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNode.Shape Property

ShapeNode.Shape Property

Gets or sets a reference to the node's geometric shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape Shape { get; set; }
Visual Basic

Public Property Shape As Shape

Property Value

An instance of the Shape class.

Remarks

Use this property to assign a complex shape to a node. Complex shapes consist of outlines, decorations and text-region definitions that can be defined as series of lines, arcs and curves. To define a custom shape, create an instance of the Shape class. That class also provides 87 predefined shapes exposed by the Shapes collection.

Example

The following sample code illustrates how to use the predefined shapes and how to create your own custom shapes.

C#

private void example_Click(object sender, System.EventArgs e)
{
ShapeNode shapeNode0 = diagram.Nodes[0] as ShapeNode;
ShapeNode shapeNode1 = diagram.Nodes[1] as ShapeNode;

// Use one of the predefined shapes
shapeNode0.Shape = Shape.FromId("MultiDocument");

// Create a custom shape
shapeNode1.Shape = new Shape(
new ElementTemplate[] {
new LineTemplate(0, 100, 60, 100),
new BezierTemplate(60, 100, 80, 100, 100, 75, 100, 50),
new BezierTemplate(100, 50, 100, 25, 80, 0, 60, 0),
new LineTemplate(60, 0, 0, 0),
new LineTemplate(0, 0, 0, 100) },
FillMode.Winding);
}
Visual Basic

Private Sub example_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles example.Click

Dim shapeNode0 As ShapeNode = CType(diagram.Nodes(0), ShapeNode)
Dim shapeNode1 As ShapeNode = CType(diagram.Nodes(1), ShapeNode)

' Use one of the predefined shapes
shapeNode0.Shape = Shape.FromId("MultiDocument")

' Create a custom shape
shapeNode1.Shape = New Shape( _
New ElementTemplate() { _
New LineTemplate(0, 100, 60, 100), _
New BezierTemplate(60, 100, 80, 100, 100, 75, 100, 50), _
New BezierTemplate(100, 50, 100, 25, 80, 0, 60, 0), _
New LineTemplate(60, 0, 0, 0), _
New LineTemplate(0, 0, 0, 100)}, _
FillMode.Winding)

End Sub

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Shape.FromId Method
Shape.Shapes Property
PolygonalTextLayout Property
ShapeOrientation Property


MindFusion.Diagramming.ShapeNode.ShapeOrientation Property

ShapeNode.ShapeOrientation Property

Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ShapeOrientation { get; set; }
Visual Basic

Public Property ShapeOrientation As Single

Property Value

A float value specifying the orientation angle in degrees. Initialized with the value of ShapeOrientation.

Remarks

That property does not rotate the node, that is, does not rotate the bounding rectangle of the node around its center. It specifies a rotation transformation to be performed on the definition of the Shape when it is applied to a node; the node's bounding rectangle (location, width and height) remain intact. In the current MindFusion.Diagramming version, only 0, 90, 180 or 270 can be set as value of ShapeOrientation.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Shape Property
RotationAngle Property


MindFusion.Diagramming.ShapeNode.Text Property

ShapeNode.Text Property

Gets or sets the text displayed inside the shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string Text { get; set; }
Visual Basic

Public Property Text As String

Property Value

A string containing the node's text. Initialized with the value of ShapeText.

Remarks

This property specifies the text that should be drawn inside the shape. The text appearance can be customized through the TextColor and TextFormat properties.

Styled text allows applying various attributes to the text characters. Attributes are specified by embedding HTML-like formatting tags within the raw text. Styled text is enabled by setting EnableStyledText to true.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
ToolTip Property


MindFusion.Diagramming.ShapeNode.TextColor Property

ShapeNode.TextColor Property

Gets or sets the color of the text displayed in this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color TextColor { get; set; }
Visual Basic

Public Property TextColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.Black.

Remarks

Use the property to specify the color of the text inside shape nodes. Further text customisation is possible with the Text and TextFormat properties.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Text Property
TextFormat Property
Diagram.TextColor Property


MindFusion.Diagramming.ShapeNode.TextFormat Property

ShapeNode.TextFormat Property

Gets or sets the alignment of the text that is displayed inside shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public StringFormat TextFormat { get; set; }
Visual Basic

Public Property TextFormat As StringFormat

Property Value

An instance of the .NET StringFormat class. Initialized with the value of TextFormat.

Remarks

Use this property to specify the wrapping mode and alignment of the text that is contained in nodes.

If there isn't enough space available to fit a whole line of text, MindFusion.Diagramming wraps the text to a new line when it reaches the edge of the node. You can specify that the text should be wrapped only at word boundaries by setting the Trimming member of TextFormat to StringTrimming.Word. The default is to split words into multiple parts if there is not enough space to fit a whole word.

If you prefer to use your own line-breaks, you can disable the automatic text wrapping by enabling the NoWrap flag in the FormatFlags member of TextFormat. If automatic wrapping is disabled and there isn't enough space to fit the whole line, the text is clipped at the node boundaries.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Text Property
TextColor Property
Diagram.TextFormat Property


MindFusion.Diagramming.ShapeNode.Transparent Property

ShapeNode.Transparent Property

Gets or sets a value indicating whether this shape node is transparent.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Transparent { get; set; }
Visual Basic

Public Property Transparent As Boolean

Property Value

true if the shape node is transparent; otherwise, false. The default is false.

Remarks

If a node is transparent, only its image and text are drawn. Shape, filling and frames are not painted.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
Visible Property


MindFusion.Diagramming.ShapeNodeProperties Class

ShapeNodeProperties Class
Remarks See Also

Stores the values of ShapeNode properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ShapeNodeProperties : DiagramNodeProperties
Visual Basic

Public Class ShapeNodeProperties
Inherits DiagramNodeProperties

Remarks

If you need to implement undo support for the additional properties defined by a class derived from ShapeNode, do so by deriving from ShapeNodeProperties and overriding the SaveProperties, RestoreProperties, and CreateProperties methods of ShapeNode.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.ShapeNodeProperties

See Also

ShapeNodeProperties Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeProperties Members

ShapeNodeProperties Members
Constructors Fields Methods

Stores the values of ShapeNode properties during undo / redo operations.

The following tables list the members exposed by the ShapeNodeProperties type.

Public Constructors

Name | Description
ShapeNodeProperties | Initializes a new instance of the ShapeNodeProperties class.

Public Fields

Name | Description
RotateText | For internal use.
Shape | For internal use.
ShapeOrientation | For internal use.
Text | For internal use.
TextColor | For internal use.
Transparent | For internal use.
UsePolyTextLt | For internal use.

Public Methods

Name | Description
FreeResources | DiagramItemProperties.FreeResources override.

See Also

ShapeNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeProperties Fields

ShapeNodeProperties Fields

Public Fields

Name | Description
RotateText | For internal use.
Shape | For internal use.
ShapeOrientation | For internal use.
Text | For internal use.
TextColor | For internal use.
Transparent | For internal use.
UsePolyTextLt | For internal use.

See Also

ShapeNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeProperties.RotateText Field

ShapeNodeProperties.RotateText Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RotateText
Visual Basic

Public RotateText As Boolean

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeProperties.Shape Field

ShapeNodeProperties.Shape Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape Shape
Visual Basic

Public Shape As Shape

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeProperties.ShapeOrientation Field

ShapeNodeProperties.ShapeOrientation Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ShapeOrientation
Visual Basic

Public ShapeOrientation As Single

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeProperties.Text Field

ShapeNodeProperties.Text Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string Text
Visual Basic

Public Text As String

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeProperties.TextColor Field

ShapeNodeProperties.TextColor Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color TextColor
Visual Basic

Public TextColor As Color

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeProperties.Transparent Field

ShapeNodeProperties.Transparent Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Transparent
Visual Basic

Public Transparent As Boolean

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeProperties.UsePolyTextLt Field

ShapeNodeProperties.UsePolyTextLt Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool UsePolyTextLt
Visual Basic

Public UsePolyTextLt As Boolean

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeProperties Constructor

ShapeNodeProperties Constructor

Initializes a new instance of the ShapeNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeNodeProperties ()
Visual Basic

Public Sub New ()

See Also

ShapeNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeProperties Methods

ShapeNodeProperties Methods

Public Methods

Name | Description
FreeResources | DiagramItemProperties.FreeResources override.

See Also

ShapeNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeProperties.FreeResources Method

ShapeNodeProperties.FreeResources Method

DiagramItemProperties.FreeResources override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void FreeResources ()
Visual Basic

Public Overrides Sub FreeResources ()

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeState Class

ShapeNodeState Class
Remarks See Also

Contains a snapshot of the internal state of a ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ShapeNodeState : DiagramItemState
Visual Basic

Public Class ShapeNodeState
Inherits DiagramItemState

Remarks

Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from ShapeNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from ShapeNodeState and overriding the CreateState, SaveState and RestoreState methods of ShapeNode.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.ShapeNodeState

See Also

ShapeNodeState Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeState Members

ShapeNodeState Members
Constructors

Contains a snapshot of the internal state of a ShapeNode.

The following tables list the members exposed by the ShapeNodeState type.

Public Constructors

Name | Description
ShapeNodeState | Initializes a new instance of the ShapeNodeState class.

See Also

ShapeNodeState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShapeNodeState Constructor

ShapeNodeState Constructor

Initializes a new instance of the ShapeNodeState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ShapeNodeState ()
Visual Basic

Public Sub New ()

See Also

ShapeNodeState Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes Class

Shapes Class
Remarks See Also

Provides alternative method of access to the MindFusion.Diagramming predefined shapes, that allows code completion and IntelliSense support, which is not available when using Shape.FromId.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class Shapes
Visual Basic

Public Class Shapes

Remarks

The accessor properties are generating using the following code:

C#

TextWriter writer = new StreamWriter(@"D:\shapes.txt");
foreach (Shape shape in Shape.Shapes)
{
writer.WriteLine("static public Shape " + shape.Id);
writer.WriteLine("{");
writer.WriteLine("\tget { return Shape.FromId(\"" + shape.Id + "\"); }");
writer.WriteLine("}");
writer.WriteLine();
writer.Flush();
}

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Shapes

See Also

Shapes Members
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes Members

Shapes Members
Properties

Provides alternative method of access to the MindFusion.Diagramming predefined shapes, that allows code completion and IntelliSense support, which is not available when using Shape.FromId.

The following tables list the members exposed by the Shapes type.

Public Properties

Name | Description
Actor | Gets the Actor predefined shape.
Alternative | Gets the Alternative predefined shape.
Arrow1 | Gets the Arrow1 predefined shape.
Arrow2 | Gets the Arrow2 predefined shape.
Arrow3 | Gets the Arrow3 predefined shape.
Arrow4 | Gets the Arrow4 predefined shape.
Arrow5 | Gets the Arrow5 predefined shape.
Arrow6 | Gets the Arrow6 predefined shape.
Arrow7 | Gets the Arrow7 predefined shape.
Arrow8 | Gets the Arrow8 predefined shape.
Arrow9 | Gets the Arrow9 predefined shape.
BeginLoop | Gets the BeginLoop predefined shape.
Cloud | Gets the Cloud predefined shape.
Collate | Gets the Collate predefined shape.
ConeDown | Gets the ConeDown predefined shape.
ConeUp | Gets the ConeUp predefined shape.
ConnectedIssues | Gets the ConnectedIssues predefined shape.
CreateRequest | Gets the CreateRequest predefined shape.
Cross | Gets the Cross predefined shape.
Cube | Gets the Cube predefined shape.
Cylinder | Gets the Cylinder predefined shape.
Database | Gets the Database predefined shape.
DataTransmition | Gets the DataTransmition predefined shape.
DDelay | Gets the DDelay predefined shape.
Decision | Gets the Decision predefined shape.
Decision2 | Gets the Decision2 predefined shape.
Delay | Gets the Delay predefined shape.
DInDelay | Gets the DInDelay predefined shape.
DirectAccessStorage | Gets the DirectAccessStorage predefined shape.
DiskStorage | Gets the DiskStorage predefined shape.
Display | Gets the Display predefined shape.
DividedEvent | Gets the DividedEvent predefined shape.
DividedProcess | Gets the DividedProcess predefined shape.
Document | Gets the Document predefined shape.
DOutDelay | Gets the DOutDelay predefined shape.
Ellipse | Gets the Ellipse predefined shape.
EndLoop | Gets the EndLoop predefined shape.
ExternalOrganization | Gets the ExternalOrganization predefined shape.
ExternalProcess | Gets the ExternalProcess predefined shape.
File | Gets the File predefined shape.
FramedRectangle | Gets the FramedRectangle predefined shape.
Gate | Gets the Gate predefined shape.
Heart | Gets the Heart predefined shape.
Heptagon | Gets the Heptagon predefined shape.
Hourglass | Gets the Hourglass predefined shape.
Input | Gets the Input predefined shape.
InternalStorage | Gets the InternalStorage predefined shape.
Interrupt | Gets the Interrupt predefined shape.
Interrupt2 | Gets the Interrupt2 predefined shape.
IsoProcess | Gets the IsoProcess predefined shape.
Junction | Gets the Junction predefined shape.
Lightning | Gets the Lightning predefined shape.
LinedDocument | Gets the LinedDocument predefined shape.
ManualOperation | Gets the ManualOperation predefined shape.
Merge | Gets the Merge predefined shape.
MessageFromUser | Gets the MessageFromUser predefined shape.
MessageToUser | Gets the MessageToUser predefined shape.
Microform | Gets the Microform predefined shape.
MicroformProcessing | Gets the MicroformProcessing predefined shape.
MicroformRecording | Gets the MicroformRecording predefined shape.
MultiDocument | Gets the MultiDocument predefined shape.
MultiProc | Gets the MultiProc predefined shape.
Octagon | Gets the Octagon predefined shape.
OfflineStorage | Gets the OfflineStorage predefined shape.
OffpageConnection | Gets the OffpageConnection predefined shape.
OffpageReference | Gets the OffpageReference predefined shape.
Or | Gets the Or predefined shape.
Pentagon | Gets the Pentagon predefined shape.
PrimitiveFromCall | Gets the PrimitiveFromCall predefined shape.
PrimitiveToCall | Gets the PrimitiveToCall predefined shape.
Procedure | Gets the Procedure predefined shape.
Process | Gets the Process predefined shape.
Prysm | Gets the Prysm predefined shape.
PunchedCard | Gets the PunchedCard predefined shape.
PyramidDown | Gets the PyramidDown predefined shape.
PyramidUp | Gets the PyramidUp predefined shape.
Rectangle | Gets the Rectangle predefined shape.
RoundRect | Gets the RoundRect predefined shape.
RSave | Gets the RSave predefined shape.
Save | Gets the Save predefined shape.
Sort | Gets the Sort predefined shape.
Sphere | Gets the Sphere predefined shape.
Star | Gets the Star predefined shape.
Start | Gets the Start predefined shape.
Tape | Gets the Tape predefined shape.
Terminator | Gets the Terminator predefined shape.
TransmittalTape | Gets the TransmittalTape predefined shape.

See Also

Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes Properties

Shapes Properties

Public Properties

Name | Description
Actor | Gets the Actor predefined shape.
Alternative | Gets the Alternative predefined shape.
Arrow1 | Gets the Arrow1 predefined shape.
Arrow2 | Gets the Arrow2 predefined shape.
Arrow3 | Gets the Arrow3 predefined shape.
Arrow4 | Gets the Arrow4 predefined shape.
Arrow5 | Gets the Arrow5 predefined shape.
Arrow6 | Gets the Arrow6 predefined shape.
Arrow7 | Gets the Arrow7 predefined shape.
Arrow8 | Gets the Arrow8 predefined shape.
Arrow9 | Gets the Arrow9 predefined shape.
BeginLoop | Gets the BeginLoop predefined shape.
Cloud | Gets the Cloud predefined shape.
Collate | Gets the Collate predefined shape.
ConeDown | Gets the ConeDown predefined shape.
ConeUp | Gets the ConeUp predefined shape.
ConnectedIssues | Gets the ConnectedIssues predefined shape.
CreateRequest | Gets the CreateRequest predefined shape.
Cross | Gets the Cross predefined shape.
Cube | Gets the Cube predefined shape.
Cylinder | Gets the Cylinder predefined shape.
Database | Gets the Database predefined shape.
DataTransmition | Gets the DataTransmition predefined shape.
DDelay | Gets the DDelay predefined shape.
Decision | Gets the Decision predefined shape.
Decision2 | Gets the Decision2 predefined shape.
Delay | Gets the Delay predefined shape.
DInDelay | Gets the DInDelay predefined shape.
DirectAccessStorage | Gets the DirectAccessStorage predefined shape.
DiskStorage | Gets the DiskStorage predefined shape.
Display | Gets the Display predefined shape.
DividedEvent | Gets the DividedEvent predefined shape.
DividedProcess | Gets the DividedProcess predefined shape.
Document | Gets the Document predefined shape.
DOutDelay | Gets the DOutDelay predefined shape.
Ellipse | Gets the Ellipse predefined shape.
EndLoop | Gets the EndLoop predefined shape.
ExternalOrganization | Gets the ExternalOrganization predefined shape.
ExternalProcess | Gets the ExternalProcess predefined shape.
File | Gets the File predefined shape.
FramedRectangle | Gets the FramedRectangle predefined shape.
Gate | Gets the Gate predefined shape.
Heart | Gets the Heart predefined shape.
Heptagon | Gets the Heptagon predefined shape.
Hourglass | Gets the Hourglass predefined shape.
Input | Gets the Input predefined shape.
InternalStorage | Gets the InternalStorage predefined shape.
Interrupt | Gets the Interrupt predefined shape.
Interrupt2 | Gets the Interrupt2 predefined shape.
IsoProcess | Gets the IsoProcess predefined shape.
Junction | Gets the Junction predefined shape.
Lightning | Gets the Lightning predefined shape.
LinedDocument | Gets the LinedDocument predefined shape.
ManualOperation | Gets the ManualOperation predefined shape.
Merge | Gets the Merge predefined shape.
MessageFromUser | Gets the MessageFromUser predefined shape.
MessageToUser | Gets the MessageToUser predefined shape.
Microform | Gets the Microform predefined shape.
MicroformProcessing | Gets the MicroformProcessing predefined shape.
MicroformRecording | Gets the MicroformRecording predefined shape.
MultiDocument | Gets the MultiDocument predefined shape.
MultiProc | Gets the MultiProc predefined shape.
Octagon | Gets the Octagon predefined shape.
OfflineStorage | Gets the OfflineStorage predefined shape.
OffpageConnection | Gets the OffpageConnection predefined shape.
OffpageReference | Gets the OffpageReference predefined shape.
Or | Gets the Or predefined shape.
Pentagon | Gets the Pentagon predefined shape.
PrimitiveFromCall | Gets the PrimitiveFromCall predefined shape.
PrimitiveToCall | Gets the PrimitiveToCall predefined shape.
Procedure | Gets the Procedure predefined shape.
Process | Gets the Process predefined shape.
Prysm | Gets the Prysm predefined shape.
PunchedCard | Gets the PunchedCard predefined shape.
PyramidDown | Gets the PyramidDown predefined shape.
PyramidUp | Gets the PyramidUp predefined shape.
Rectangle | Gets the Rectangle predefined shape.
RoundRect | Gets the RoundRect predefined shape.
RSave | Gets the RSave predefined shape.
Save | Gets the Save predefined shape.
Sort | Gets the Sort predefined shape.
Sphere | Gets the Sphere predefined shape.
Star | Gets the Star predefined shape.
Start | Gets the Start predefined shape.
Tape | Gets the Tape predefined shape.
Terminator | Gets the Terminator predefined shape.
TransmittalTape | Gets the TransmittalTape predefined shape.

See Also

Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Actor Property

Shapes.Actor Property

Gets the Actor predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Actor { get; }
Visual Basic

Public Shared ReadOnly Property Actor As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Alternative Property

Shapes.Alternative Property

Gets the Alternative predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Alternative { get; }
Visual Basic

Public Shared ReadOnly Property Alternative As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Arrow1 Property

Shapes.Arrow1 Property

Gets the Arrow1 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Arrow1 { get; }
Visual Basic

Public Shared ReadOnly Property Arrow1 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.Arrow2 Property

Shapes.Arrow2 Property

Gets the Arrow2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Arrow2 { get; }
Visual Basic

Public Shared ReadOnly Property Arrow2 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Arrow3 Property

Shapes.Arrow3 Property

Gets the Arrow3 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Arrow3 { get; }
Visual Basic

Public Shared ReadOnly Property Arrow3 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Arrow4 Property

Shapes.Arrow4 Property

Gets the Arrow4 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Arrow4 { get; }
Visual Basic

Public Shared ReadOnly Property Arrow4 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Arrow5 Property

Shapes.Arrow5 Property

Gets the Arrow5 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Arrow5 { get; }
Visual Basic

Public Shared ReadOnly Property Arrow5 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Arrow6 Property

Shapes.Arrow6 Property

Gets the Arrow6 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Arrow6 { get; }
Visual Basic

Public Shared ReadOnly Property Arrow6 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Arrow7 Property

Shapes.Arrow7 Property

Gets the Arrow7 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Arrow7 { get; }
Visual Basic

Public Shared ReadOnly Property Arrow7 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Arrow8 Property

Shapes.Arrow8 Property

Gets the Arrow8 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Arrow8 { get; }
Visual Basic

Public Shared ReadOnly Property Arrow8 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Arrow9 Property

Shapes.Arrow9 Property

Gets the Arrow9 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Arrow9 { get; }
Visual Basic

Public Shared ReadOnly Property Arrow9 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.BeginLoop Property

Shapes.BeginLoop Property

Gets the BeginLoop predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape BeginLoop { get; }
Visual Basic

Public Shared ReadOnly Property BeginLoop As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Cloud Property

Shapes.Cloud Property

Gets the Cloud predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Cloud { get; }
Visual Basic

Public Shared ReadOnly Property Cloud As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace
Table of Predefined Shapes


MindFusion.Diagramming.Shapes.Collate Property

Shapes.Collate Property

Gets the Collate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Collate { get; }
Visual Basic

Public Shared ReadOnly Property Collate As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.ConeDown Property

Shapes.ConeDown Property

Gets the ConeDown predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape ConeDown { get; }
Visual Basic

Public Shared ReadOnly Property ConeDown As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.ConeUp Property

Shapes.ConeUp Property

Gets the ConeUp predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape ConeUp { get; }
Visual Basic

Public Shared ReadOnly Property ConeUp As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.ConnectedIssues Property

Shapes.ConnectedIssues Property

Gets the ConnectedIssues predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape ConnectedIssues { get; }
Visual Basic

Public Shared ReadOnly Property ConnectedIssues As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.CreateRequest Property

Shapes.CreateRequest Property

Gets the CreateRequest predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape CreateRequest { get; }
Visual Basic

Public Shared ReadOnly Property CreateRequest As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Cross Property

Shapes.Cross Property

Gets the Cross predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Cross { get; }
Visual Basic

Public Shared ReadOnly Property Cross As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Cube Property

Shapes.Cube Property

Gets the Cube predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Cube { get; }
Visual Basic

Public Shared ReadOnly Property Cube As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Cylinder Property

Shapes.Cylinder Property

Gets the Cylinder predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Cylinder { get; }
Visual Basic

Public Shared ReadOnly Property Cylinder As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Database Property

Shapes.Database Property

Gets the Database predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Database { get; }
Visual Basic

Public Shared ReadOnly Property Database As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.DataTransmition Property

Shapes.DataTransmition Property

Gets the DataTransmition predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape DataTransmition { get; }
Visual Basic

Public Shared ReadOnly Property DataTransmition As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.DDelay Property

Shapes.DDelay Property

Gets the DDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape DDelay { get; }
Visual Basic

Public Shared ReadOnly Property DDelay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Decision Property

Shapes.Decision Property

Gets the Decision predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Decision { get; }
Visual Basic

Public Shared ReadOnly Property Decision As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Decision2 Property

Shapes.Decision2 Property

Gets the Decision2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Decision2 { get; }
Visual Basic

Public Shared ReadOnly Property Decision2 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Delay Property

Shapes.Delay Property

Gets the Delay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Delay { get; }
Visual Basic

Public Shared ReadOnly Property Delay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.DInDelay Property

Shapes.DInDelay Property

Gets the DInDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape DInDelay { get; }
Visual Basic

Public Shared ReadOnly Property DInDelay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.DirectAccessStorage Property

Shapes.DirectAccessStorage Property

Gets the DirectAccessStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape DirectAccessStorage { get; }
Visual Basic

Public Shared ReadOnly Property DirectAccessStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.DiskStorage Property

Shapes.DiskStorage Property

Gets the DiskStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape DiskStorage { get; }
Visual Basic

Public Shared ReadOnly Property DiskStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Display Property

Shapes.Display Property

Gets the Display predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Display { get; }
Visual Basic

Public Shared ReadOnly Property Display As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.DividedEvent Property

Shapes.DividedEvent Property

Gets the DividedEvent predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape DividedEvent { get; }
Visual Basic

Public Shared ReadOnly Property DividedEvent As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.DividedProcess Property

Shapes.DividedProcess Property

Gets the DividedProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape DividedProcess { get; }
Visual Basic

Public Shared ReadOnly Property DividedProcess As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Document Property

Shapes.Document Property

Gets the Document predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Document { get; }
Visual Basic

Public Shared ReadOnly Property Document As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.DOutDelay Property

Shapes.DOutDelay Property

Gets the DOutDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape DOutDelay { get; }
Visual Basic

Public Shared ReadOnly Property DOutDelay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Ellipse Property

Shapes.Ellipse Property

Gets the Ellipse predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Ellipse { get; }
Visual Basic

Public Shared ReadOnly Property Ellipse As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.EndLoop Property

Shapes.EndLoop Property

Gets the EndLoop predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape EndLoop { get; }
Visual Basic

Public Shared ReadOnly Property EndLoop As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.ExternalOrganization Property

Shapes.ExternalOrganization Property

Gets the ExternalOrganization predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape ExternalOrganization { get; }
Visual Basic

Public Shared ReadOnly Property ExternalOrganization As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.ExternalProcess Property

Shapes.ExternalProcess Property

Gets the ExternalProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape ExternalProcess { get; }
Visual Basic

Public Shared ReadOnly Property ExternalProcess As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.File Property

Shapes.File Property

Gets the File predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape File { get; }
Visual Basic

Public Shared ReadOnly Property File As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.FramedRectangle Property

Shapes.FramedRectangle Property

Gets the FramedRectangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape FramedRectangle { get; }
Visual Basic

Public Shared ReadOnly Property FramedRectangle As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Gate Property

Shapes.Gate Property

Gets the Gate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Gate { get; }
Visual Basic

Public Shared ReadOnly Property Gate As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Heart Property

Shapes.Heart Property

Gets the Heart predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Heart { get; }
Visual Basic

Public Shared ReadOnly Property Heart As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Heptagon Property

Shapes.Heptagon Property

Gets the Heptagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Heptagon { get; }
Visual Basic

Public Shared ReadOnly Property Heptagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Hourglass Property

Shapes.Hourglass Property

Gets the Hourglass predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Hourglass { get; }
Visual Basic

Public Shared ReadOnly Property Hourglass As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Input Property

Shapes.Input Property

Gets the Input predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Input { get; }
Visual Basic

Public Shared ReadOnly Property Input As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.InternalStorage Property

Shapes.InternalStorage Property

Gets the InternalStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape InternalStorage { get; }
Visual Basic

Public Shared ReadOnly Property InternalStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Interrupt Property

Shapes.Interrupt Property

Gets the Interrupt predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Interrupt { get; }
Visual Basic

Public Shared ReadOnly Property Interrupt As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Interrupt2 Property

Shapes.Interrupt2 Property

Gets the Interrupt2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Interrupt2 { get; }
Visual Basic

Public Shared ReadOnly Property Interrupt2 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.IsoProcess Property

Shapes.IsoProcess Property

Gets the IsoProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape IsoProcess { get; }
Visual Basic

Public Shared ReadOnly Property IsoProcess As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Junction Property

Shapes.Junction Property

Gets the Junction predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Junction { get; }
Visual Basic

Public Shared ReadOnly Property Junction As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Lightning Property

Shapes.Lightning Property

Gets the Lightning predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Lightning { get; }
Visual Basic

Public Shared ReadOnly Property Lightning As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.LinedDocument Property

Shapes.LinedDocument Property

Gets the LinedDocument predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape LinedDocument { get; }
Visual Basic

Public Shared ReadOnly Property LinedDocument As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.ManualOperation Property

Shapes.ManualOperation Property

Gets the ManualOperation predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape ManualOperation { get; }
Visual Basic

Public Shared ReadOnly Property ManualOperation As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Merge Property

Shapes.Merge Property

Gets the Merge predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Merge { get; }
Visual Basic

Public Shared ReadOnly Property Merge As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.MessageFromUser Property

Shapes.MessageFromUser Property

Gets the MessageFromUser predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape MessageFromUser { get; }
Visual Basic

Public Shared ReadOnly Property MessageFromUser As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.MessageToUser Property

Shapes.MessageToUser Property

Gets the MessageToUser predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape MessageToUser { get; }
Visual Basic

Public Shared ReadOnly Property MessageToUser As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Microform Property

Shapes.Microform Property

Gets the Microform predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Microform { get; }
Visual Basic

Public Shared ReadOnly Property Microform As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.MicroformProcessing Property

Shapes.MicroformProcessing Property

Gets the MicroformProcessing predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape MicroformProcessing { get; }
Visual Basic

Public Shared ReadOnly Property MicroformProcessing As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.MicroformRecording Property

Shapes.MicroformRecording Property

Gets the MicroformRecording predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape MicroformRecording { get; }
Visual Basic

Public Shared ReadOnly Property MicroformRecording As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.MultiDocument Property

Shapes.MultiDocument Property

Gets the MultiDocument predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape MultiDocument { get; }
Visual Basic

Public Shared ReadOnly Property MultiDocument As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.MultiProc Property

Shapes.MultiProc Property

Gets the MultiProc predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape MultiProc { get; }
Visual Basic

Public Shared ReadOnly Property MultiProc As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Octagon Property

Shapes.Octagon Property

Gets the Octagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Octagon { get; }
Visual Basic

Public Shared ReadOnly Property Octagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.OfflineStorage Property

Shapes.OfflineStorage Property

Gets the OfflineStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape OfflineStorage { get; }
Visual Basic

Public Shared ReadOnly Property OfflineStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.OffpageConnection Property

Shapes.OffpageConnection Property

Gets the OffpageConnection predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape OffpageConnection { get; }
Visual Basic

Public Shared ReadOnly Property OffpageConnection As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.OffpageReference Property

Shapes.OffpageReference Property

Gets the OffpageReference predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape OffpageReference { get; }
Visual Basic

Public Shared ReadOnly Property OffpageReference As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Or Property

Shapes.Or Property

Gets the Or predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Or { get; }
Visual Basic

Public Shared ReadOnly Property Or As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Pentagon Property

Shapes.Pentagon Property

Gets the Pentagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Pentagon { get; }
Visual Basic

Public Shared ReadOnly Property Pentagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.PrimitiveFromCall Property

Shapes.PrimitiveFromCall Property

Gets the PrimitiveFromCall predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape PrimitiveFromCall { get; }
Visual Basic

Public Shared ReadOnly Property PrimitiveFromCall As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.PrimitiveToCall Property

Shapes.PrimitiveToCall Property

Gets the PrimitiveToCall predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape PrimitiveToCall { get; }
Visual Basic

Public Shared ReadOnly Property PrimitiveToCall As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Procedure Property

Shapes.Procedure Property

Gets the Procedure predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Procedure { get; }
Visual Basic

Public Shared ReadOnly Property Procedure As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Process Property

Shapes.Process Property

Gets the Process predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Process { get; }
Visual Basic

Public Shared ReadOnly Property Process As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Prysm Property

Shapes.Prysm Property

Gets the Prysm predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Prysm { get; }
Visual Basic

Public Shared ReadOnly Property Prysm As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.PunchedCard Property

Shapes.PunchedCard Property

Gets the PunchedCard predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape PunchedCard { get; }
Visual Basic

Public Shared ReadOnly Property PunchedCard As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.PyramidDown Property

Shapes.PyramidDown Property

Gets the PyramidDown predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape PyramidDown { get; }
Visual Basic

Public Shared ReadOnly Property PyramidDown As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.PyramidUp Property

Shapes.PyramidUp Property

Gets the PyramidUp predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape PyramidUp { get; }
Visual Basic

Public Shared ReadOnly Property PyramidUp As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Rectangle Property

Shapes.Rectangle Property

Gets the Rectangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Rectangle { get; }
Visual Basic

Public Shared ReadOnly Property Rectangle As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.RoundRect Property

Shapes.RoundRect Property

Gets the RoundRect predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape RoundRect { get; }
Visual Basic

Public Shared ReadOnly Property RoundRect As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.RSave Property

Shapes.RSave Property

Gets the RSave predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape RSave { get; }
Visual Basic

Public Shared ReadOnly Property RSave As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Save Property

Shapes.Save Property

Gets the Save predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Save { get; }
Visual Basic

Public Shared ReadOnly Property Save As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Sort Property

Shapes.Sort Property

Gets the Sort predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Sort { get; }
Visual Basic

Public Shared ReadOnly Property Sort As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Sphere Property

Shapes.Sphere Property

Gets the Sphere predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Sphere { get; }
Visual Basic

Public Shared ReadOnly Property Sphere As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Star Property

Shapes.Star Property

Gets the Star predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Star { get; }
Visual Basic

Public Shared ReadOnly Property Star As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Start Property

Shapes.Start Property

Gets the Start predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Start { get; }
Visual Basic

Public Shared ReadOnly Property Start As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Tape Property

Shapes.Tape Property

Gets the Tape predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Tape { get; }
Visual Basic

Public Shared ReadOnly Property Tape As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.Terminator Property

Shapes.Terminator Property

Gets the Terminator predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape Terminator { get; }
Visual Basic

Public Shared ReadOnly Property Terminator As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Shapes.TransmittalTape Property

Shapes.TransmittalTape Property

Gets the TransmittalTape predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public static Shape TransmittalTape { get; }
Visual Basic

Public Shared ReadOnly Property TransmittalTape As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ShowAnchors Enumeration

ShowAnchors Enumeration

Specifies when anchors points should be displayed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum ShowAnchors
Visual Basic

Public Enumeration ShowAnchors

Members

Member name | Description
Always | Anchor point marks are always painted.
Auto | Anchor point marks are shown for the node under the mouse cursor.
Never | Anchor point marks are never painted.
Selected | Anchor point marks are painted for the selected node.

Remarks

Members of this enumeration are used as values of the ShowAnchors property of the Diagram class. Auto and Selected can be combined using the bitwise or operator.

See Also

MindFusion.Diagramming Namespace
ShowAnchors Property
MarkStyle Enumeration


MindFusion.Diagramming.SizeFConverter Class

SizeFConverter Class

Converts from SizeF to other data types.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class SizeFConverter : TypeConverter
Visual Basic

Public Class SizeFConverter
Inherits TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Diagramming.SizeFConverter

See Also

SizeFConverter Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SizeFConverter Members

SizeFConverter Members
Constructors Methods

Converts from SizeF to other data types.

The following tables list the members exposed by the SizeFConverter type.

Public Constructors

Name | Description
SizeFConverter | Initializes a new instance of the SizeFConverter class.

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.
CreateInstance | TypeConverter.CreateInstance override.
GetCreateInstanceSupported | TypeConverter.GetCreateInstanceSupported override.
GetProperties | TypeConverter.GetProperties override.
GetPropertiesSupported | TypeConverter.GetPropertiesSupported override.

See Also

SizeFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SizeFConverter Constructor

SizeFConverter Constructor

Initializes a new instance of the SizeFConverter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeFConverter ()
Visual Basic

Public Sub New ()

See Also

SizeFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SizeFConverter Methods

SizeFConverter Methods

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.
CreateInstance | TypeConverter.CreateInstance override.
GetCreateInstanceSupported | TypeConverter.GetCreateInstanceSupported override.
GetProperties | TypeConverter.GetProperties override.
GetPropertiesSupported | TypeConverter.GetPropertiesSupported override.

See Also

SizeFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SizeFConverter.CanConvertFrom Method

SizeFConverter.CanConvertFrom Method

TypeConverter.CanConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)
Visual Basic

Public Overrides Function CanConvertFrom ( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context
sourceType

Return Value

See Also

SizeFConverter Members
SizeFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SizeFConverter.CanConvertTo Method

SizeFConverter.CanConvertTo Method

TypeConverter.CanConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)
Visual Basic

Public Overrides Function CanConvertTo ( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context
destinationType

Return Value

See Also

SizeFConverter Members
SizeFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SizeFConverter.ConvertFrom Method

SizeFConverter.ConvertFrom Method

TypeConverter.ConvertFrom override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)
Visual Basic

Public Overrides Function ConvertFrom ( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context
culture
value

Return Value

See Also

SizeFConverter Members
SizeFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SizeFConverter.ConvertTo Method

SizeFConverter.ConvertTo Method

TypeConverter.ConvertTo override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)
Visual Basic

Public Overrides Function ConvertTo ( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context
culture
value
destinationType

Return Value

See Also

SizeFConverter Members
SizeFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SizeFConverter.CreateInstance Method

SizeFConverter.CreateInstance Method

TypeConverter.CreateInstance override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Object CreateInstance (
ITypeDescriptorContext context,
IDictionary propertyValues
)
Visual Basic

Public Overrides Function CreateInstance ( _
context As ITypeDescriptorContext, _
propertyValues As IDictionary _
) As Object

Parameters

context
propertyValues

Return Value

See Also

SizeFConverter Members
SizeFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SizeFConverter.GetCreateInstanceSupported Method

SizeFConverter.GetCreateInstanceSupported Method

TypeConverter.GetCreateInstanceSupported override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool GetCreateInstanceSupported (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetCreateInstanceSupported ( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context

Return Value

See Also

SizeFConverter Members
SizeFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SizeFConverter.GetProperties Method

SizeFConverter.GetProperties Method

TypeConverter.GetProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override PropertyDescriptorCollection GetProperties (
ITypeDescriptorContext context,
Object value,
Attribute[] attributes
)
Visual Basic

Public Overrides Function GetProperties ( _
context As ITypeDescriptorContext, _
value As Object, _
attributes() As Attribute _
) As PropertyDescriptorCollection

Parameters

context
value
attributes

Return Value

See Also

SizeFConverter Members
SizeFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SizeFConverter.GetPropertiesSupported Method

SizeFConverter.GetPropertiesSupported Method

TypeConverter.GetPropertiesSupported override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool GetPropertiesSupported (
ITypeDescriptorContext context
)
Visual Basic

Public Overrides Function GetPropertiesSupported ( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context

Return Value

See Also

SizeFConverter Members
SizeFConverter Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.SnapToAnchor Enumeration

SnapToAnchor Enumeration

Specifies when link ends are snapped to nearest anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum SnapToAnchor
Visual Basic

Public Enumeration SnapToAnchor

Members

Member name | Description
OnCreate | Snap to anchor point when creating a new link.
OnCreateOrModify | Snap to anchor point when creating or modifying a link.

Remarks

Members of this enumeration are used as values of the SnapToAnchor property of the Diagram class.

See Also

MindFusion.Diagramming Namespace
SnapToAnchor Property
ShowAnchors Enumeration


MindFusion.Diagramming.TableConnectionStyle Enumeration

TableConnectionStyle Enumeration

Specifies the possible values for the ConnectionStyle property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum TableConnectionStyle
Visual Basic

Public Enumeration TableConnectionStyle

Members

Member name | Description
Both | Users are allowed to create relations both to the rows of a table or the the table as a whole.
Rows | Users are allowed to create relations to the rows of a table.
Table | Users are allowed to create relations to a table as whole entity.

Remarks

The enumeration provides possible values for the ConnectionStyle property, which specifies whether relation ends are the rows of a table or the table as a whole entity.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode Class

TableNode Class
Remarks See Also

Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class TableNode : DiagramNode, InplaceEditable
Visual Basic

Public Class TableNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

Tables in flow diagrams are represented by instances of the TableNode class. Probably the most important property of tables is ConnectionStyle, which specifies whether users are allowed to draw links to the rows of a table, to the table as an integral entity, or both.

Tables consist of Cell instances distributed across rows and columns. Number of rows and columns can be set with the RowCount and ColumnCount properties. The width of the columns is set with ColumnWidth property and the height of the rows with the RowHeight property. Cells can be made to span several rows and columns by setting their RowSpan and ColumnSpan properties to values larger than one.

Rows can be assigned to distinct sections of the table. Each section can be collapsed or expanded, hiding or showing all rows in the section except the header one. To define a section, set a Header row. A section consists of all rows after a header row and spans to the next header. Each header row displays a [±] button that allows expanding or collapsing the section interactively. The button appears either on the left of the first cell of a header row or in a separate column, as set in OffsetHeaderRows. Clicking that button raises the TableSectionCollapsed and TableSectionExpanded events. Sections can be collapsed or expanded programmatically using the Expanded property of their header rows.

The structure of a table can be dynamically changed by adding and deleting rows and columns. This can be done with the AddColumn and AddRow methods as well as with the InsertColumn, InsertRow and RedimTable methods. DeleteRow and DeleteColumn methods delete existing rows and columns.

Table cells contain Text, displayed as specified through TextColor and TextFormat. A table can also have a caption, whose text is set by the Caption property. The height of the caption and the alignment of the text are specified by CaptionHeight and CaptionFormat properties. To get even richer text formatting, set EnableStyledText to true and embed HTML-like formatting tags in the caption and cell texts. The ResizeToFitText method resizes all columns and rows so that each table cell fits its text on a single line without clipping it.

To display a text box that lets users edit the table caption or the text of a cell, call the BeginEdit method of DiagramView. Call EndEdit to exit the in-place editing mode. If the view's AllowInplaceEdit property is enabled, users can double-click the table caption bar or a cell in order to edit their text.

The interior of tables is filled using their Brush property. The color of the table and cell borders can be set by using the Pen property. The table caption area is painted using the CaptionBackBrush brush.

In order to set an image as table's background use the Image property. The alignment of the image in relation to the table's rectangle is set through the ImageAlign property. The table can be resized to fit the size of its image by calling the ResizeToFitImage method.

The rectangle, which a table occupies, is accessible with the Bounds property. Rows and columns that build the table are stored and accessed by means of the Rows and Columns collections.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.TableNode

See Also

TableNode Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode Members

TableNode Members
Constructors Properties Methods

Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.

The following tables list the members exposed by the TableNode type.

Public Constructors

Name | Description
TableNode | Overloaded. Initializes a new instance of the TableNode class.

Public Properties

Name | Description
Caption | Gets or sets the text displayed as caption of the table.
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table.
CaptionColor | Gets or sets the color of the text used as table caption.
CaptionFormat | Gets or sets the alignment and line position of the text used as table caption.
CaptionHeight | Gets or sets the height of the table's caption area.
CaptionPlainText | Gets the plain text of the table's caption.
CellCustomDraw | Gets or sets the type of custom drawing performed on the table cells.
CellFrameStyle | Gets or sets the style of the table cells.
ColumnCount | Gets or sets the number of columns in the table.
Columns | Gets a list of all columns in the table.
ColumnWidth | Gets or sets the default width of the table columns.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.
CurrentScrollRow | Gets or sets the index of the first visible row in the table.
CustomDraw | Gets or sets the type of custom drawing performed on this table.
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Font | Gets or sets the font used when rendering the table's texts.
Image | Gets or sets the image that is displayed in this table.
ImageAlign | Gets or sets the alignment of the image displayed in this table.
Item | Gets the Cell instance at the specified position.
OffsetHeaderRows | Gets or sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.
RowAnchorPattern | Gets or sets a default anchor pattern for the rows of this table.
RowCount | Gets or sets the number of rows in the table.
RowHeight | Gets or sets the default height of table rows.
Rows | Gets a list of all rows in the table.
Scrollable | Gets or sets a value indicating whether users are allowed to scroll table rows.
Style | Gets or sets the shape of the table's outline.
TextColor | Gets or sets the color of the text inside table cells.

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AddColumn | Adds new empty column at the right end of the table.
AddRelation | Creates a relation with the specified table.
AddRow | Adds new empty row at the bottom of the table.
BreakRelation | Breaks the relation with the specified table.
CellFromPoint |
DeleteColumn | Deletes the column with the specified index within the table.
DeleteRow | Deletes the row at the specified position within the table.
Draw | Draws the node on the specified IGraphics surface.
DrawAnchors | DiagramNode.DrawAnchors override.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | Draws the shadow of this node on the specified IGraphics surface.
GetIntersection | DiagramNode.GetIntersection override.
GetRepaintRect | DiagramNode.GetRepaintRect override.
GetToolTip | DiagramNode.GetToolTip override.
HitTestHandle | DiagramNode.HitTestHandle override.
InsertColumn | Inserts new empty column at the specified position within the table.
InsertRow | Inserts new empty row at the specified position within the table.
RedimTable | Sets new number of rows and columns for this table.
ResizeToFitImage | Makes a table as big as the image it displays.
ResizeToFitText | Overloaded.
ScrollDown | Scrolls the table rows downwards.
ScrollUp | Scrolls the table rows upwards.

Protected Methods

Name | Description
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateProperties | DiagramItem.CreateProperties override.
Dispose | Disposes any disposable resources managed by this table.
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
OnLoad | DiagramItem.OnLoad override.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the DiagramView.ZoomFactor changes.
RestoreProperties | DiagramNode.RestoreProperties override.
SaveProperties | DiagramNode.SaveProperties override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetReference | Updates the reference to the specified object.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.

See Also

TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode Constructor

TableNode Constructor

Initializes a new instance of the TableNode class.

Overload List

Name | Description
TableNode () | Initializes a new instance of the TableNode class.
TableNode (Diagram) | Initializes a new instance of the TableNode class.
TableNode (TableNode) | Initializes a new instance of the TableNode class using the specified node as a prototype.

See Also

TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode Constructor ()

TableNode Constructor ()
See Also

Initializes a new instance of the TableNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode ()
Visual Basic

Public Sub New ()

See Also

TableNode Constructor Overload List
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode Constructor (Diagram)

TableNode Constructor (Diagram)
See Also

Initializes a new instance of the TableNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode (
Diagram parent
)
Visual Basic

Public Sub TableNode ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the TableNode properties with the values specified in the respective default-value properties of the Diagram object. For more information see Initial Values of Item Properties.

See Also

TableNode Constructor Overload List
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode Constructor (TableNode)

TableNode Constructor (TableNode)
See Also

Initializes a new instance of the TableNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode (
TableNode prototype
)
Visual Basic

Public Sub TableNode ( _
prototype As TableNode _
)

Parameters

prototype

The table node to use as a prototype. The properties of the new table are initialized from the property values of prototype.

Remarks

This constructor copies the TableNode property values from the specified prototype node.

See Also

TableNode Constructor Overload List
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode Methods

TableNode Methods

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AddColumn | Adds new empty column at the right end of the table.
AddRelation | Creates a relation with the specified table.
AddRow | Adds new empty row at the bottom of the table.
BreakRelation | Breaks the relation with the specified table.
CellFromPoint |
DeleteColumn | Deletes the column with the specified index within the table.
DeleteRow | Deletes the row at the specified position within the table.
Draw | Draws the node on the specified IGraphics surface.
DrawAnchors | DiagramNode.DrawAnchors override.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | Draws the shadow of this node on the specified IGraphics surface.
GetIntersection | DiagramNode.GetIntersection override.
GetRepaintRect | DiagramNode.GetRepaintRect override.
GetToolTip | DiagramNode.GetToolTip override.
HitTestHandle | DiagramNode.HitTestHandle override.
InsertColumn | Inserts new empty column at the specified position within the table.
InsertRow | Inserts new empty row at the specified position within the table.
RedimTable | Sets new number of rows and columns for this table.
ResizeToFitImage | Makes a table as big as the image it displays.
ResizeToFitText | Overloaded.
ScrollDown | Scrolls the table rows downwards.
ScrollUp | Scrolls the table rows upwards.

Protected Methods

Name | Description
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateProperties | DiagramItem.CreateProperties override.
Dispose | Disposes any disposable resources managed by this table.
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
OnLoad | DiagramItem.OnLoad override.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the DiagramView.ZoomFactor changes.
RestoreProperties | DiagramNode.RestoreProperties override.
SaveProperties | DiagramNode.SaveProperties override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetReference | Updates the reference to the specified object.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.

See Also

TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.AcceptLinks Method

TableNode.AcceptLinks Method

DiagramNode.AcceptLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool AcceptLinks (
bool outgoing
)
Visual Basic

Public Overrides Function AcceptLinks ( _
outgoing As Boolean _
) As Boolean

Parameters

outgoing
true to check for outgoing links; otherwise, false.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.AddColumn Method

TableNode.AddColumn Method

Adds new empty column at the right end of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int AddColumn ()
Visual Basic

Public Function AddColumn () As Integer

Return Value

Returns the index of the newly added column within the Columns collection.

Remarks

Call the method to add new columns at the end of the table. The size of the table is automatically updated and the columns are added to the column collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
InsertColumn Method
DeleteColumn Method
RedimTable Method
Columns Property


MindFusion.Diagramming.TableNode.AddRelation Method

TableNode.AddRelation Method

Creates a relation with the specified table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLink AddRelation (
int row,
Relationship rel,
TableNode tableNode,
int relRow
)
Visual Basic

Public Function AddRelation ( _
row As Integer, _
rel As Relationship, _
tableNode As TableNode, _
relRow As Integer _
) As DiagramLink

Parameters

row
Zero-based index of a row in this table to be related.
rel
The type of the relation (and the direction of the link).
tableNode
The other table in the relation.
relRow
Zero-based index of the row in the other table.

Return Value

A DiagramLink object representing the relation.

Remarks

Call this method to link rows of two tables.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
BreakRelation Method


MindFusion.Diagramming.TableNode.AddRow Method

TableNode.AddRow Method

Adds new empty row at the bottom of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int AddRow ()
Visual Basic

Public Function AddRow () As Integer

Return Value

Returns the index of the newly added row within the Rows collection.

Remarks

Call the method to add new rows at the end of the table. The size of the table is automatically updated and the rows are added to the row collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
InsertRow Method
DeleteRow Method
RedimTable Method
Rows Property


MindFusion.Diagramming.TableNode.BreakRelation Method

TableNode.BreakRelation Method

Breaks the relation with the specified table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void BreakRelation (
int row,
Relationship rel,
TableNode tableNode
)
Visual Basic

Public Sub BreakRelation ( _
row As Integer, _
rel As Relationship, _
tableNode As TableNode _
)

Parameters

row
Zero-based index of a row in this table that is related to a row in another.
rel
The type of the relation (and the direction of the link).
tableNode
The other table in the relation.

Remarks

Call this method to break the link between two tables.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
AddRelation Method


MindFusion.Diagramming.TableNode.CellFromPoint Method (PointF, Int32@, Int32@)

TableNode.CellFromPoint Method (PointF, Int32@, Int32@)
See Also

Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool CellFromPoint (
PointF point,
ref int row,
ref int col
)
Visual Basic

Public Function CellFromPoint ( _
point As PointF, _
ByRef row As Integer, _
ByRef col As Integer _
) As Boolean

Parameters

point
The point to check.
row
Receives the row index if a cell is found at the specified position.
col
Receives the column index if a cell is found at the specified position.

Return Value

true if a cell of this table contains the specified point; otherwise, false.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CreateConnectionPoint Method

TableNode.CreateConnectionPoint Method

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
PointF pt,
bool incoming
)
Visual Basic

Protected Overridable Function CreateConnectionPoint ( _
link As DiagramLink, _
pt As PointF, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
pt
The point at which the link should be connected.
incoming
true if link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CreateProperties Method

TableNode.CreateProperties Method

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual DiagramItemProperties CreateProperties ()
Visual Basic

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.DeleteColumn Method

TableNode.DeleteColumn Method

Deletes the column with the specified index within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void DeleteColumn (
int col
)
Visual Basic

Public Sub DeleteColumn ( _
col As Integer _
)

Parameters

col
The zero-based index of the column to be deleted.

Remarks

Call the method to delete a column from the table. The size of the table is automatically updated and the columns are removed from the column collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
DeleteRow Method
AddColumn Method
InsertColumn Method
RedimTable Method


MindFusion.Diagramming.TableNode.DeleteRow Method

TableNode.DeleteRow Method

Deletes the row at the specified position within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void DeleteRow (
int row
)
Visual Basic

Public Sub DeleteRow ( _
row As Integer _
)

Parameters

row
The zero-based index of the row to be deleted.

Remarks

Call the method to delete a row from the table. The size of the table is automatically updated and the rows are removed from the row collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
DeleteColumn Method
AddRow Method
InsertRow Method
RedimTable Method


MindFusion.Diagramming.TableNode.Dispose Method

TableNode.Dispose Method

Disposes any disposable resources managed by this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
Specifies whether the method is called explicitly or from the garbage collector.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Draw Method

TableNode.Draw Method

Draws the node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void Draw (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public Overrides Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
An IGraphics object where the node should be rendered.
options
Provides options for the drawing operation.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.DrawAnchors Method

TableNode.DrawAnchors Method

DiagramNode.DrawAnchors override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void DrawAnchors (
IGraphics graphics
)
Visual Basic

Public Overrides Sub DrawAnchors ( _
graphics As IGraphics _
)

Parameters

graphics
The IGraphics surface to draw the anchor points on.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.DrawHandles Method

TableNode.DrawHandles Method

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void DrawHandles (
IGraphics graphics,
Color color
)
Visual Basic

Public Overrides Sub DrawHandles ( _
graphics As IGraphics, _
color As Color _
)

Parameters

graphics
The IGraphics surface to draw the handles on.
color
The color that should be used to render the handles.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.DrawShadow Method

TableNode.DrawShadow Method

Draws the shadow of this node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public Overrides Sub DrawShadow ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
An IGraphics object where the shadow should be rendered.
options
A RenderOptions object specifying options for the drawing operation.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.GetIntersection Method

TableNode.GetIntersection Method

DiagramNode.GetIntersection override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override PointF GetIntersection (
PointF segmentStart,
PointF segmentEnd
)
Visual Basic

Public Overrides Function GetIntersection ( _
segmentStart As PointF, _
segmentEnd As PointF _
) As PointF

Parameters

segmentStart
The first point of the segment.
segmentEnd
The second point of the segment.

Return Value

A PointF object representing the intersection point.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.GetRepaintRect Method

TableNode.GetRepaintRect Method

DiagramNode.GetRepaintRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override RectangleF GetRepaintRect (
bool includeConnected
)
Visual Basic

Public Overrides Function GetRepaintRect ( _
includeConnected As Boolean _
) As RectangleF

Parameters

includeConnected
true if related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this node is modified.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.GetToolTip Method

TableNode.GetToolTip Method

DiagramNode.GetToolTip override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override string GetToolTip (
PointF point
)
Visual Basic

Public Overrides Function GetToolTip ( _
point As PointF _
) As String

Parameters

point
The mouse pointer position.

Return Value

A string specifying the tooltip text.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.HitTestHandle Method

TableNode.HitTestHandle Method

DiagramNode.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool HitTestHandle (
PointF pt,
ref int handle
)
Visual Basic

Public Overrides Function HitTestHandle ( _
pt As PointF, _
ByRef handle As Integer _
) As Boolean

Parameters

pt
A PointF value specifying where to look for a selection handle.
handle
A reference to an integer variable, which receives the index of the found selection handle.

Return Value

true if there is a selection handle at the specified location; otherwise, false.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.InsertColumn Method

TableNode.InsertColumn Method

Inserts new empty column at the specified position within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void InsertColumn (
int col
)
Visual Basic

Public Sub InsertColumn ( _
col As Integer _
)

Parameters

col
The zero-based index of the column to be inserted.

Remarks

Call the method to add new column at a particular position in the table. The size of the table is automatically updated and the columns are added to the column collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
AddColumn Method
DeleteColumn Method
RedimTable Method


MindFusion.Diagramming.TableNode.InsertRow Method

TableNode.InsertRow Method

Inserts new empty row at the specified position within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void InsertRow (
int row
)
Visual Basic

Public Sub InsertRow ( _
row As Integer _
)

Parameters

row
The zero-based index of the row to be inserted.

Remarks

Call the method to add new row at a particular position in the table. The size of the table is automatically updated and the rows are added to the row collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
AddRow Method
DeleteRow Method
RedimTable Method


MindFusion.Diagramming.TableNode.LoadFrom Method

TableNode.LoadFrom Method

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)
Visual Basic

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
A BinaryReader object from which to read the item's data.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.LoadFromXml Method

TableNode.LoadFromXml Method

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.OnLoad Method

TableNode.OnLoad Method

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnLoad ()
Visual Basic

Protected Overridable Sub OnLoad ()

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.OnMeasureUnitChanged Method

TableNode.OnMeasureUnitChanged Method

Called when the Diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnMeasureUnitChanged ()
Visual Basic

Protected Overridable Sub OnMeasureUnitChanged ()

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.OnUpdateBounds Method

TableNode.OnUpdateBounds Method

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnUpdateBounds ()
Visual Basic

Protected Overridable Sub OnUpdateBounds ()

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.OnZoomChanged Method

TableNode.OnZoomChanged Method

Called when the DiagramView.ZoomFactor changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void OnZoomChanged ()
Visual Basic

Protected Overridable Sub OnZoomChanged ()

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RedimTable Method

TableNode.RedimTable Method

Sets new number of rows and columns for this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void RedimTable (
int cols,
int rows
)
Visual Basic

Public Sub RedimTable ( _
cols As Integer, _
rows As Integer _
)

Parameters

cols
The new number of columns.
rows
The new number of rows.

Remarks

This method does not preserve the old contents of table cells. After its invocation all cells are empty and columns and rows are with default sizes.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
AddColumn Method
AddRow Method
DeleteColumn Method
DeleteRow Method


MindFusion.Diagramming.TableNode.ResizeToFitImage Method

TableNode.ResizeToFitImage Method

Makes a table as big as the image it displays.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ResizeToFitImage ()
Visual Basic

Public Sub ResizeToFitImage ()

Remarks

Call this method to make a table exactly the same size as the image it contains. The dots-per-inch resolution of the image is considered too when calculating the new table size. You can use ImageAlign to specify position of the picture and Image to set the picture itself.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
Image Property


MindFusion.Diagramming.TableNode.ResizeToFitText Method

TableNode.ResizeToFitText Method

Overload List

Name | Description
TableNode.ResizeToFitText (Boolean) | Resizes the columns and rows so that the cells are large enough to fit their text.
TableNode.ResizeToFitText (Boolean, Boolean) | Resizes the columns and rows so that the cells are large enough to fit their text.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.ResizeToFitText Method (Boolean)

TableNode.ResizeToFitText Method (Boolean)
See Also

Resizes the columns and rows so that the cells are large enough to fit their text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ResizeToFitText (
bool ignoreCaption
)
Visual Basic

Public Sub ResizeToFitText ( _
ignoreCaption As Boolean _
)

Parameters

ignoreCaption

false if the caption bar too should be resized to fit the caption text; otherwise, true.

Remarks

This method resizes the cells so they fit their Text on a single line, as long as the text does not contain new-line characters. The Width of each column is set to the width of its widest cell, and the Height of each row is set to the height of its highest cell. In the end, the table size is set to the sum of the extents of all rows and columns.

If ignoreCaption is false, the caption bar too will be resized, by setting CaptionHeight and the table width, so that it fits the Caption text.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
ResizeToFitImage Method


MindFusion.Diagramming.TableNode.ResizeToFitText Method (Boolean, Boolean)

TableNode.ResizeToFitText Method (Boolean, Boolean)
See Also

Resizes the columns and rows so that the cells are large enough to fit their text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ResizeToFitText (
bool ignoreCaption,
bool keepCellWidth
)
Visual Basic

Public Sub ResizeToFitText ( _
ignoreCaption As Boolean, _
keepCellWidth As Boolean _
)

Parameters

ignoreCaption
false if the caption bar too should be resized to fit the caption text; otherwise, true.
keepCellWidth
true if column widths should stay unchanged; otherwise, false.

Remarks

This method resizes the cells so they fit their Text on a single line, as long as the text does not contain new-line characters. The Width of each column is set to the width of its widest cell, and the Height of each row is set to the height of its highest cell. In the end, the table size is set to the sum of the extents of all rows and columns.

If ignoreCaption is false, the caption bar too will be resized, by setting CaptionHeight and the table width, so that it fits the Caption text.

If keepCellWidth is true, the cell width is preserved unchanged.

See Also

ResizeToFitText Method Overload List
TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RestoreProperties Method

TableNode.RestoreProperties Method

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void RestoreProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.SaveProperties Method

TableNode.SaveProperties Method

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object where the item's properties should be saved.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.SaveTo Method

TableNode.SaveTo Method

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)
Visual Basic

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
A BinaryWriter object the item's data should be written to.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.SaveToXml Method

TableNode.SaveToXml Method

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.ScrollDown Method

TableNode.ScrollDown Method

Scrolls the table rows downwards.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ScrollDown ()
Visual Basic

Public Sub ScrollDown ()

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.ScrollUp Method

TableNode.ScrollUp Method

Scrolls the table rows upwards.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void ScrollUp ()
Visual Basic

Public Sub ScrollUp ()

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.SetReference Method

TableNode.SetReference Method

Updates the reference to the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SetReference (
int refId,
Object obj,
PersistContext ctx
)
Visual Basic

Protected Overridable Sub SetReference ( _
refId As Integer, _
obj As Object, _
ctx As PersistContext _
)

Parameters

refId
Reference identifier.
obj
The newly loaded object.
context
A PersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is called for references that had been saved using the SaveReference method.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.SetReflexive Method

TableNode.SetReflexive Method

Invoked to let a node set the shape of a reflexive link connected to it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void SetReflexive (
DiagramLink link
)
Visual Basic

Protected Overridable Sub SetReflexive ( _
link As DiagramLink _
)

Parameters

link
Reference to the link.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode Properties

TableNode Properties

Public Properties

Name | Description
Caption | Gets or sets the text displayed as caption of the table.
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table.
CaptionColor | Gets or sets the color of the text used as table caption.
CaptionFormat | Gets or sets the alignment and line position of the text used as table caption.
CaptionHeight | Gets or sets the height of the table's caption area.
CaptionPlainText | Gets the plain text of the table's caption.
CellCustomDraw | Gets or sets the type of custom drawing performed on the table cells.
CellFrameStyle | Gets or sets the style of the table cells.
ColumnCount | Gets or sets the number of columns in the table.
Columns | Gets a list of all columns in the table.
ColumnWidth | Gets or sets the default width of the table columns.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.
CurrentScrollRow | Gets or sets the index of the first visible row in the table.
CustomDraw | Gets or sets the type of custom drawing performed on this table.
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Font | Gets or sets the font used when rendering the table's texts.
Image | Gets or sets the image that is displayed in this table.
ImageAlign | Gets or sets the alignment of the image displayed in this table.
Item | Gets the Cell instance at the specified position.
OffsetHeaderRows | Gets or sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.
RowAnchorPattern | Gets or sets a default anchor pattern for the rows of this table.
RowCount | Gets or sets the number of rows in the table.
RowHeight | Gets or sets the default height of table rows.
Rows | Gets a list of all rows in the table.
Scrollable | Gets or sets a value indicating whether users are allowed to scroll table rows.
Style | Gets or sets the shape of the table's outline.
TextColor | Gets or sets the color of the text inside table cells.

See Also

TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Caption Property

TableNode.Caption Property

Gets or sets the text displayed as caption of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string Caption { get; set; }
Visual Basic

Public Property Caption As String

Property Value

A string containing the text of the caption. Initialized with the value of TableCaption.

Remarks

Text color and alignment can be customized by using the CaptionColor and CaptionFormat properties.

Styled text allows applying various attributes to the text characters. Attributes are specified by embedding HTML-like formatting tags within the raw text. Styled text is enabled by setting EnableStyledText to true.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CaptionHeight Property
CaptionBackBrush Property
Diagram.TableCaption Property


MindFusion.Diagramming.TableNode.CaptionBackBrush Property

TableNode.CaptionBackBrush Property

Gets or sets the brush used to paint the caption area of this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Brush CaptionBackBrush { get; set; }
Visual Basic

Public Property CaptionBackBrush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class. The default is null (Nothing in Visual Basic).

Remarks

This property refers to a brush object used to paint the interior of the caption area. An instance of one of the following classes can be assigned to it: HatchBrush, LinearGradientBrush, PathGradientBrush, SolidBrush or TextureBrush, all located in the MindFusion.Drawing namespace. If there is no brush assigned to this property, the caption area is painted using the Brush property of the TableNode class.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CaptionHeight Property
Caption Property


MindFusion.Diagramming.TableNode.CaptionColor Property

TableNode.CaptionColor Property

Gets or sets the color of the text used as table caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color CaptionColor { get; set; }
Visual Basic

Public Property CaptionColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.FromArgb(0, 0, 0).

Remarks

Use the property to make table caption more distinguished.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CaptionHeight Property
CaptionFormat Property
Caption Property


MindFusion.Diagramming.TableNode.CaptionFormat Property

TableNode.CaptionFormat Property

Gets or sets the alignment and line position of the text used as table caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public StringFormat CaptionFormat { get; set; }
Visual Basic

Public Property CaptionFormat As StringFormat

Property Value

An instance of the .NET StringFormat class.

Remarks

Use this property to change the alignment of text or its position inside the caption area.

If there isn't enough space available to fit a whole line of text, MindFusion.Diagramming wraps the text to a new line when it reaches the edge of the table. You can specify that the text should be wrapped only at word boundaries by setting the Trimming member of CaptionFormat to StringTrimming.Word. The default is to split words into multiple parts if there is not enough space to fit a whole word.

If you prefer to use your own line-breaks, you can disable the automatic text wrapping by enabling the NoWrap flag in the FormatFlags member of CaptionFormat. If automatic wrapping is disabled and there isn't enough space to fit the whole line, the text is clipped at the table boundaries.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CaptionHeight Property
CaptionColor Property
Caption Property


MindFusion.Diagramming.TableNode.CaptionHeight Property

TableNode.CaptionHeight Property

Gets or sets the height of the table's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float CaptionHeight { get; set; }
Visual Basic

Public Property CaptionHeight As Single

Property Value

A float value specifying the height of the table caption. Initialized with the value of TableCaptionHeight.

Remarks

Keep in mind that tables are moved by clicking their captions and dragging. Don't make captions too narrow or they would become harder to move.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CaptionFormat Property
CaptionColor Property
Caption Property
Diagram.TableCaptionHeight Property


MindFusion.Diagramming.TableNode.CaptionPlainText Property

TableNode.CaptionPlainText Property

Gets the plain text of the table's caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string CaptionPlainText { get; }
Visual Basic

Public ReadOnly Property CaptionPlainText As String

Property Value

A string containing the plain text of the caption.

Remarks

This property removes any formatting tags from Caption and returns the plain human-readable text. That is useful when styled text is enabled and you need to display caption's content outside of MindFusion.Diagramming, that is, in a message box or a dialog box.

Example

The following sample code demonstrates how CaptionPlainText can be used.

C#

t.EnableStyledText = true;
t.Caption = "<b>interface</b> <i><u>IMouseListener</u></i>";
MessageBox.Show(t.CaptionPlainText);
Visual Basic

t.EnableStyledText = True
t.Caption = "<b>interface</b> <i><u>IMouseListener</u></i>"
MessageBox.Show(t.CaptionPlainText)

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CaptionFormat Property
EnableStyledText Property


MindFusion.Diagramming.TableNode.CellCustomDraw Property

TableNode.CellCustomDraw Property

Gets or sets the type of custom drawing performed on the table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CustomDraw CellCustomDraw { get; set; }
Visual Basic

Public Property CellCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of CellCustomDraw.

Remarks

This property allows invoking custom painting code for the cells of a table. That code must execute in response to the DrawCell event. There are several modes of custom painting, allowing the custom code to paint the cell entirely, or do that in addition to what MindFusion.Diagramming paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member Name | Description
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming.
Additional | The custom painting code executes after the cell interior is painted by MindFusion.Diagramming, but before the cell's text is rendered.
Full | The component does not do any standard drawing of the cell, the entire painting is left for the application.
Additional2 | The custom painting code executes after all parts of the cell, including its text, are painted by MindFusion.Diagramming.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
TableNode.CustomDraw Property


MindFusion.Diagramming.TableNode.CellFrameStyle Property

TableNode.CellFrameStyle Property

Gets or sets the style of the table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CellFrameStyle CellFrameStyle { get; set; }
Visual Basic

Public Property CellFrameStyle As CellFrameStyle

Property Value

A member of the CellFrameStyle enumeration. Initialized with the value of CellFrameStyle.

Remarks

This property specifies whether there are borders drawn around table cells, and if yes, their appearance.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
CellFrameStyle Enumeration
Diagram.CellFrameStyle Property


MindFusion.Diagramming.TableNode.ColumnCount Property

TableNode.ColumnCount Property

Gets or sets the number of columns in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int ColumnCount { get; set; }
Visual Basic

Public Property ColumnCount As Integer

Property Value

An integer value indicating the number of columns in the table.

Remarks

If you increase the number of columns the contents of the old columns will remain intact. If you decrease the number, the last columns are removed and the other remain unchanged.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
Columns Property


MindFusion.Diagramming.TableNode.Columns Property

TableNode.Columns Property

Gets a list of all columns in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.ColumnCollection Columns { get; }
Visual Basic

Public ReadOnly Property Columns As TableNode.ColumnCollection

Property Value

An instance of the ColumnCollection class.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
Rows Property


MindFusion.Diagramming.TableNode.ColumnWidth Property

TableNode.ColumnWidth Property

Gets or sets the default width of the table columns.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ColumnWidth { get; set; }
Visual Basic

Public Property ColumnWidth As Single

Property Value

A float value specifying the width of the table columns. Initialized with the value of TableColumnWidth.

Remarks

The value of this property is used to initialize the width of new columns when they are created.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
RowHeight Property


MindFusion.Diagramming.TableNode.ConnectionStyle Property

TableNode.ConnectionStyle Property

Gets or sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableConnectionStyle ConnectionStyle { get; set; }
Visual Basic

Public Property ConnectionStyle As TableConnectionStyle

Property Value

A member of the TableConnectionStyle enumeration. Initialized with the value of TableConnectionStyle.

Remarks

There are three possible ways to relate tables to other nodes. This property specifies how users are allowed to create such relations:

  • Rows - relation ends are the rows of a table. A link connected to the table is connected to a particular row. This mode is convenient for database diagrams.
  • Table - relations target the table as a whole entity, and not any particular row. This mode is convenient for class diagrams.
  • Both - a mixed mode where links can target either a row of the table or the table itself.
Programmatically, links can be connected to a table in any way, regardless of the ConnectionStyle. ConnectionStyle value is considered only when end-users draw links to or from a table. To link to a table as an entity and not to a specific row, pass -1 as row argument of the CreateDiagramLink method.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CurrentScrollRow Property

TableNode.CurrentScrollRow Property

Gets or sets the index of the first visible row in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int CurrentScrollRow { get; set; }
Visual Basic

Public Property CurrentScrollRow As Integer

Property Value

An integer value indicating the index of the first visible row.

Remarks

To allow users to scroll the table interactively, enable the Scrollable property.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
Rows Property


MindFusion.Diagramming.TableNode.CustomDraw Property

TableNode.CustomDraw Property

Gets or sets the type of custom drawing performed on this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CustomDraw CustomDraw { get; set; }
Visual Basic

Public Property CustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of TableCustomDraw.

Remarks

This property allows invoking custom painting code for a table. That code must execute in response to the DrawNode event. There are several modes of custom painting, allowing the custom code to paint the table entirely, or do that in addition to what MindFusion.Diagramming paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member Name | Description
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming.
Additional | The custom painting code executes after the table interior and frame are painted by MindFusion.Diagramming, but before cells are rendered.
Full | The component does not do any standard drawing of the table frame, whose painting is left for the application. Cells are painted independently, as set in CellCustomDraw.
ShadowOnly | Only the shadow of the table is painted by custom code, the table itself is drawn by the component.
Additional2 | The custom painting code executes after all parts of the table, including its cells, are painted by MindFusion.Diagramming.

This property doesn't affect the painting of table cells. Table cells can be custom painted in the DrawCell event as set in CellCustomDraw.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.EnableStyledText Property

TableNode.EnableStyledText Property

Gets or sets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableStyledText { get; set; }
Visual Basic

Public Property EnableStyledText As Boolean

Property Value

true to parse the text of table's caption and cells in order to find formatting tags; otherwise false. Initialized with the value of EnableStyledText.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. Formatting tags are listed and described in the Text Attributes and Formatting section of this help file.

If EnableStyledText is set to true, table's Caption and cells' Text are parsed and analyzed each time they change. Parsing determines what formatting tags are used and adds the corresponding attribute records to MindFusion.Diagramming's internal representation of styled text. If the property value is false, the text is not processed in any way and is displayed without formatting.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
ResizeToFitText Method
CaptionPlainText Property


MindFusion.Diagramming.TableNode.Font Property

TableNode.Font Property

Gets or sets the font used when rendering the table's texts.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override Font Font { get; set; }
Visual Basic

Public Overrides Property Font As Font

Property Value

A .NET Font instance specifying the font attributes.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Image Property

TableNode.Image Property

Gets or sets the image that is displayed in this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Image Image { get; set; }
Visual Basic

Public Property Image As Image

Property Value

An instance of the .NET Image class.

Remarks

Use the property to customize your table's background. Further customization can be done with the ImageAlign property.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
ImageAlign Property
ResizeToFitImage Method
Cell.Image Property


MindFusion.Diagramming.TableNode.ImageAlign Property

TableNode.ImageAlign Property

Gets or sets the alignment of the image displayed in this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ImageAlign ImageAlign { get; set; }
Visual Basic

Public Property ImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration. The default value is Fit.

Remarks

This property specifies how images are positioned inside tables.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
Image Property


MindFusion.Diagramming.TableNode.Item Property

TableNode.Item Property

Gets the Cell instance at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Cell Item [
int col,
int row
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
col As Integer, _
row As Integer _
) As TableNode.Cell

Parameters

col
The zero-based index of the cell's column.
row
The zero-based index of the cell's row.

Property Value

An instance of the Cell class that represents the cell of the table at the specified position.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
ColumnCount Property
RowCount Property
RedimTable Method


MindFusion.Diagramming.TableNode.OffsetHeaderRows Property

TableNode.OffsetHeaderRows Property

Gets or sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool OffsetHeaderRows { get; set; }
Visual Basic

Public Property OffsetHeaderRows As Boolean

Property Value

true to offset table cells when there are header rows defined; otherwise, false. The default is false.

Remarks

If this property is set to false, the [±] buttons used to expand or collapse table sections are drawn inside the first cell of each header row. Otherwise, the buttons are drawn in their own column in front of the table's first column of cells.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RowAnchorPattern Property

TableNode.RowAnchorPattern Property

Gets or sets a default anchor pattern for the rows of this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPattern RowAnchorPattern { get; set; }
Visual Basic

Public Property RowAnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class. The default is null (Nothing in Visual Basic).

Remarks

Defines a default value for the AnchorPattern property of the rows of a table.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
AnchorPoint.Column Property
Row.AnchorPattern Property


MindFusion.Diagramming.TableNode.RowCount Property

TableNode.RowCount Property

Gets or sets the number of rows in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int RowCount { get; set; }
Visual Basic

Public Property RowCount As Integer

Property Value

An integer value specifying the number of rows in the table.

Remarks

If you increase the number of rows the content of the initial rows will remain intact. If you decrease the number, the last rows are removed and the other remain unchanged.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
Rows Property


MindFusion.Diagramming.TableNode.RowHeight Property

TableNode.RowHeight Property

Gets or sets the default height of table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float RowHeight { get; set; }
Visual Basic

Public Property RowHeight As Single

Property Value

A float value specifying the height of the table rows. Initialized with the value of TableRowHeight.

Remarks

The value of this property is used to initialize the height of new rows when they are created.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
ColumnWidth Property


MindFusion.Diagramming.TableNode.Rows Property

TableNode.Rows Property

Gets a list of all rows in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.RowCollection Rows { get; }
Visual Basic

Public ReadOnly Property Rows As TableNode.RowCollection

Property Value

An instance of the RowCollection class.

Remarks

The property refers to the collection of all rows that compose the table. Do not add or remove rows through this collection, but use the table's AddRow, InsertRow or DeleteRow methods.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
Columns Property
CurrentScrollRow Property


MindFusion.Diagramming.TableNode.Scrollable Property

TableNode.Scrollable Property

Gets or sets a value indicating whether users are allowed to scroll table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Scrollable { get; set; }
Visual Basic

Public Property Scrollable As Boolean

Property Value

true to allow scrolling the table up or down; otherwise, false. Initialized with the value of TablesScrollable.

Remarks

A button containing up and down arrows appears in the caption area of a table for which scrolling is enabled. If a user clicks these arrows, table rows scroll up or down. The table can always be scrolled programmatically using the CurrentScrollRow property.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace
Rows Property


MindFusion.Diagramming.TableNode.Style Property

TableNode.Style Property

Gets or sets the shape of the table's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableStyle Style { get; set; }
Visual Basic

Public Property Style As TableStyle

Property Value

A member of the TableStyle enumeration. Initialized with the value of TableStyle.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.TextColor Property

TableNode.TextColor Property

Gets or sets the color of the text inside table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color TextColor { get; set; }
Visual Basic

Public Property TextColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.Black.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell Class

TableNode.Cell Class
Remarks See Also

Represents a cell in a TableNode instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class TableNode.Cell : InplaceEditable, IPersists
Visual Basic

Public Class TableNode.Cell
Implements InplaceEditable, IPersists

Remarks

Cells are the building blocks of tables. They get their height and width indirectly, from the width of table columns and the height of table rows as set by the ColumnWidth and RowHeight properties. Cells can be made to span several rows and columns by setting their RowSpan and ColumnSpan properties to values larger than 1.

Cells can hold text, which is set by their Text property. The text can be aligned and this is set by the TextFormat property. Color of the text in the cells is set with the TextColor property.

Appearance of a cell can be customized further by the Brush and Image properties.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TableNode.Cell

See Also

TableNode.Cell Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell Members

TableNode.Cell Members
Constructors Properties Methods

Represents a cell in a TableNode instance.

The following tables list the members exposed by the TableNode.Cell type.

Public Constructors

Name | Description
TableNode.Cell | Initializes a new instance of the TableNode.Cell class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill this cell.
ColumnSpan | Gets or sets how many columns the cell should span.
Font | Gets or sets the font used to draw text inside this cell.
HyperLink | Gets or sets the hyperlink associated with the cell.
Image | Gets or sets the image that is displayed in this cell.
ImageAlign | Gets or sets the alignment of the image displayed in this cell.
PlainText | Gets the plain text of the cell.
RowSpan | Gets or sets how many rows the cell should span.
Table | Gets a reference to the TableNode containing this cell.
Tag | Gets or sets custom data associated with this cell.
Text | Gets or sets text displayed inside the cell.
TextColor | Gets or sets the color used for painting the text of the cell.
TextFormat | Gets or sets the alignment of the text that is displayed inside the cell.
ToolTip | Gets or sets the tooltip text associated with the cell.

Public Methods

Name | Description
Clone | Creates a copy of this cell.

Protected Methods

Name | Description
LoadFromXml | Loads the cell content from an XML element.
SaveToXml | Saves the cell content into an XML element.

See Also

TableNode.Cell Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell Constructor

TableNode.Cell Constructor

Initializes a new instance of the TableNode.Cell class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Cell (
TableNode table
)
Visual Basic

Public Sub TableNode.Cell ( _
table As TableNode _
)

Parameters

table

The TableNode this cell belongs to.

See Also

TableNode.Cell Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell Methods

TableNode.Cell Methods

Public Methods

Name | Description
Clone | Creates a copy of this cell.

Protected Methods

Name | Description
LoadFromXml | Loads the cell content from an XML element.
SaveToXml | Saves the cell content into an XML element.

See Also

TableNode.Cell Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell.Clone Method

TableNode.Cell.Clone Method

Creates a copy of this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Cell Clone ()
Visual Basic

Public Function Clone () As TableNode.Cell

Return Value

An instance of the TableNode.Cell class.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell.LoadFromXml Method

TableNode.Cell.LoadFromXml Method

Loads the cell content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the cell's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell.SaveToXml Method

TableNode.Cell.SaveToXml Method

Saves the cell content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the cell's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell Properties

TableNode.Cell Properties

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill this cell.
ColumnSpan | Gets or sets how many columns the cell should span.
Font | Gets or sets the font used to draw text inside this cell.
HyperLink | Gets or sets the hyperlink associated with the cell.
Image | Gets or sets the image that is displayed in this cell.
ImageAlign | Gets or sets the alignment of the image displayed in this cell.
PlainText | Gets the plain text of the cell.
RowSpan | Gets or sets how many rows the cell should span.
Table | Gets a reference to the TableNode containing this cell.
Tag | Gets or sets custom data associated with this cell.
Text | Gets or sets text displayed inside the cell.
TextColor | Gets or sets the color used for painting the text of the cell.
TextFormat | Gets or sets the alignment of the text that is displayed inside the cell.
ToolTip | Gets or sets the tooltip text associated with the cell.

See Also

TableNode.Cell Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell.Brush Property

TableNode.Cell.Brush Property

Gets or sets the brush used to fill this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Brush Brush { get; set; }
Visual Basic

Public Property Brush As Brush

Property Value

An instance of a MindFusion.Drawing.Brush-derived class. The default is null (Nothing in Visual Basic).

Remarks

This property refers to a brush used to paint the cell's interior. You can assign to it an instance of one of the following classes: HatchBrush, LinearGradientBrush, PathGradientBrush, SolidBrush or TextureBrush, located in the MindFusion.Drawing namespace. If the default null value is used, the cell's interior is painted with the table's Brush instead of cell's one.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace
Image Property


MindFusion.Diagramming.TableNode.Cell.ColumnSpan Property

TableNode.Cell.ColumnSpan Property

Gets or sets how many columns the cell should span.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int ColumnSpan { get; set; }
Visual Basic

Public Property ColumnSpan As Integer

Property Value

A positive integer value specifying how many columns the cell spans to the right. The default is 1.

Remarks

Use this property and RowSpan to define a cell that overlaps several columns and rows of the table's grid. The spanning cell covers any non-spanning cells to the right or below it, as far as the spanned columns and rows go. The Image and Text of spanning cells are aligned and laid out inside the enlarged bounding rectangles of the cells. That allows composing nodes with a very elaborate structure using spanning cells, as alternative to attaching ShapeNode objects to a container/master node.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell.Font Property

TableNode.Cell.Font Property

Gets or sets the font used to draw text inside this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Font Font { get; set; }
Visual Basic

Public Property Font As Font

Property Value

A .NET Font used to render the cell's Text, or null (Nothing in Visual Basic) if the text should be rendered using the table's Font.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell.HyperLink Property

TableNode.Cell.HyperLink Property

Gets or sets the hyperlink associated with the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string HyperLink { get; set; }
Visual Basic

Public Property HyperLink As String

Property Value

A string value containing the hyperlink URL.

Remarks

This property is used by the CreateImageMap method of the HtmlBuilder class. Its value is assigned to the HREF attribute of the <AREA> tag that corresponds to the cell. Map areas are defined for table cells only if the AreasForTableCells property is enabled.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell.Image Property

TableNode.Cell.Image Property

Gets or sets the image that is displayed in this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Image Image { get; set; }
Visual Basic

Public Property Image As Image

Property Value

An instance of the .NET Image class. The default is null (Nothing in Visual Basic).

Remarks

Use this property to set an image to be displayed in the cell. Use the ImageAlign property to specify how the image is placed.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace
ImageAlign Property


MindFusion.Diagramming.TableNode.Cell.ImageAlign Property

TableNode.Cell.ImageAlign Property

Gets or sets the alignment of the image displayed in this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ImageAlign ImageAlign { get; set; }
Visual Basic

Public Property ImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace
Image Property


MindFusion.Diagramming.TableNode.Cell.PlainText Property

TableNode.Cell.PlainText Property

Gets the plain text of the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string PlainText { get; }
Visual Basic

Public ReadOnly Property PlainText As String

Property Value

A string containing the plain text of the cell.

Remarks

This property removes any formatting tags from cell's Text and returns the plain human-readable text. That is useful when styled text is enabled and you need to display cell's content outside of MindFusion.Diagramming, that is, in a message or a dialog box.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace
TextFormat Property
TableNode.EnableStyledText Property


MindFusion.Diagramming.TableNode.Cell.RowSpan Property

TableNode.Cell.RowSpan Property

Gets or sets how many rows the cell should span.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int RowSpan { get; set; }
Visual Basic

Public Property RowSpan As Integer

Property Value

A positive integer value specifying how many rows the cell spans downwards. The default is 1.

Remarks

Use this property and ColumnSpan to define a cell that overlaps several columns and rows of the table's grid. The spanning cell covers any non-spanning cells to the right or below it, as far as the spanned columns and rows go. The Image and Text displayed in spanning cells are aligned and laid out inside the enlarged bounding rectangles of the cells. That allows composing nodes with a very elaborate structure using spanning cells, as an alternative to attaching ShapeNode objects to a container/master node.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell.Table Property

TableNode.Cell.Table Property

Gets a reference to the TableNode containing this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode Table { get; }
Visual Basic

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class representing the table containing this cell.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Cell.Tag Property

TableNode.Cell.Tag Property

Gets or sets custom data associated with this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object Tag { get; set; }
Visual Basic

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object. The default value is null (Nothing in Visual Basic).

Remarks

This property holds data that you define and is not used by MindFusion.Diagramming in any way. The tag could be any value of a primitive data type or a complex object from the .NET class library or a class defined by you. If the tag is an instance of a value type, it will be serialized together with the cell containing it when saving/loading the diagram. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace
Diagram.SerializeTag Event


MindFusion.Diagramming.TableNode.Cell.Text Property

TableNode.Cell.Text Property

Gets or sets text displayed inside the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string Text { get; set; }
Visual Basic

Public Property Text As String

Property Value

A string value containing the text. The default is an empty string.

Remarks

The property specifies text that appears inside a cell. Text can be customized via the TextColor and TextFormat properties.

Styled text allows applying various attributes to the text characters. Attributes are specified by embedding HTML-like formatting tags within the raw text. Styled text is enabled by setting EnableStyledText to true.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace
Image Property
TableNode.ResizeToFitText Method


MindFusion.Diagramming.TableNode.Cell.TextColor Property

TableNode.Cell.TextColor Property

Gets or sets the color used for painting the text of the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color TextColor { get; set; }
Visual Basic

Public Property TextColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.Empty.

Remarks

The Text of the cell is painted with this color. However, if the property is set to the default Color.Empty value, the table's TextColor property is used instead of the cell's one.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace
Font Property
TextFormat Property


MindFusion.Diagramming.TableNode.Cell.TextFormat Property

TableNode.Cell.TextFormat Property

Gets or sets the alignment of the text that is displayed inside the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public StringFormat TextFormat { get; set; }
Visual Basic

Public Property TextFormat As StringFormat

Property Value

An instance of the .NET StringFormat class. The default alignment is StringAlignment.Center for lines and StringAlignment.Near for the written text.

Remarks

Use this property to specify the alignment of the text that is contained in cells.

If there isn't enough space available to fit a whole line of text, MindFusion.Diagramming wraps the text to a new line when it reaches the edge of the cell. You can specify that the text should be wrapped only at word boundaries by setting the Trimming member of TextFormat to StringTrimming.Word. The default is to split words into multiple parts if there is not enough space to fit a whole word.

If you prefer to use your own line-breaks, disable the automatic text wrapping by enabling the NoWrap flag in the FormatFlags member of TextFormat. If automatic wrapping is disabled and there isn't enough space to fit the whole line, the text is clipped at the cell boundaries.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace
Font Property
Text Property


MindFusion.Diagramming.TableNode.Cell.ToolTip Property

TableNode.Cell.ToolTip Property

Gets or sets the tooltip text associated with the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ToolTip { get; set; }
Visual Basic

Public Property ToolTip As String

Property Value

The tool-tip text displayed for this cell. The default is an empty string.

Remarks

For more information, see the DiagramItem.ToolTip property.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CellCollection Class

TableNode.CellCollection Class
Remarks See Also

Represents a strongly-typed collection of TableNode.Cell objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class TableNode.CellCollection : CollectionBase, IPersists
Visual Basic

Public Class TableNode.CellCollection
Inherits CollectionBase
Implements IPersists

Remarks

Do not use the methods and properties of this class to modify the contents of this collection directly. If you want to add or remove cells from a table, use the AddRow, AddColumn, InsertRow, InsertColumn, DeleteRow, DeleteColumn and RedimTable methods of the TableNode class instead.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.TableNode.CellCollection

See Also

TableNode.CellCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CellCollection Members

TableNode.CellCollection Members
Constructors Properties Methods

Represents a strongly-typed collection of TableNode.Cell objects.

The following tables list the members exposed by the TableNode.CellCollection type.

Public Constructors

Name | Description
TableNode.CellCollection | Initializes a new instance of the TableNode.CellCollection class.

Public Properties

Name | Description
Item | Gets or sets the cell at the specified position within the collection.

Public Methods

Name | Description
Add | Adds the specified cell to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the cell at the specified position.
Insert | Inserts the specified cell at the specified index within the collection.
Remove | Removes the specified cell from the collection.

See Also

TableNode.CellCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CellCollection Constructor

TableNode.CellCollection Constructor

Initializes a new instance of the TableNode.CellCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.CellCollection ()
Visual Basic

Public Sub New ()

Remarks

This constructor supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

TableNode.CellCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CellCollection Methods

TableNode.CellCollection Methods

Public Methods

Name | Description
Add | Adds the specified cell to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the cell at the specified position.
Insert | Inserts the specified cell at the specified index within the collection.
Remove | Removes the specified cell from the collection.

See Also

TableNode.CellCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CellCollection.Add Method

TableNode.CellCollection.Add Method

Adds the specified cell to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Add (
TableNode.Cell cell
)
Visual Basic

Public Sub Add ( _
cell As TableNode.Cell _
)

Parameters

cell
The TableNode.Cell object to add to the collection.

Remarks

Do not use this method directly. Use the methods of the TableNode class instead.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CellCollection.Clone Method

TableNode.CellCollection.Clone Method

Creates a deep copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.CellCollection Clone ()
Visual Basic

Public Function Clone () As TableNode.CellCollection

Return Value

An instance of the TableNode.CellCollection class.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CellCollection.GetAt Method

TableNode.CellCollection.GetAt Method

Returns the cell at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Cell GetAt (
int index
)
Visual Basic

Public Function GetAt ( _
index As Integer _
) As TableNode.Cell

Parameters

index

The zero-based index of the cell to retrieve.

Return Value

A reference to the TableNode.Cell object at the specified position.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CellCollection.Insert Method

TableNode.CellCollection.Insert Method

Inserts the specified cell at the specified index within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Insert (
int index,
TableNode.Cell cell
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
cell As TableNode.Cell _
)

Parameters

index

The zero-based index at which to insert the cell.

cell

The TableNode.Cell object to add to the collection.

Remarks

Do not use this method directly. Use the methods of the TableNode class instead.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CellCollection.Remove Method

TableNode.CellCollection.Remove Method

Removes the specified cell from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Remove (
TableNode.Cell cell
)
Visual Basic

Public Sub Remove ( _
cell As TableNode.Cell _
)

Parameters

cell

The TableNode.Cell object to add to the collection.

Remarks

Do not use this method directly. Use the methods of the TableNode class instead.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CellCollection Properties

TableNode.CellCollection Properties

Public Properties

Name | Description
Item | Gets or sets the cell at the specified position within the collection.

See Also

TableNode.CellCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.CellCollection.Item Property

TableNode.CellCollection.Item Property

Gets or sets the cell at the specified position within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Cell Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As TableNode.Cell

Parameters

index

The zero-based index of the item which should be get or set.

Property Value

A reference to the TableNode.Cell object at the specified index.

Remarks

Do not use the set accessor of this property. It supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Column Class

TableNode.Column Class
Remarks See Also

Represents a column of a TableNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class TableNode.Column : IPersists
Visual Basic

Public Class TableNode.Column
Implements IPersists

Remarks

The width of a column can be set via its Width property. The width of a column determines the width of all cells contained within the column.

When resizing a table, its columns can be resized too. That depends on the value of ColumnStyle, which specifies whether columns are with fixed width or they resize to keep column-to-table width ratio.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TableNode.Column

See Also

TableNode.Column Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Column Members

TableNode.Column Members
Constructors Properties Methods

Represents a column of a TableNode.

The following tables list the members exposed by the TableNode.Column type.

Public Constructors

Name | Description
TableNode.Column | Initializes a new instance of the TableNode.Column class.

Public Properties

Name | Description
ColumnStyle | Gets or sets the manner in which column's width is set.
Width | Gets or sets the width of the table column.

Public Methods

Name | Description
Clone | Creates a copy of this column.

Protected Methods

Name | Description
LoadFromXml | Loads the column properties from an XML element.
SaveToXml | Saves the column properties into an XML element.

See Also

TableNode.Column Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Column Constructor

TableNode.Column Constructor

Initializes a new instance of the TableNode.Column class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Column (
TableNode tableNode
)
Visual Basic

Public Sub TableNode.Column ( _
tableNode As TableNode _
)

Parameters

tableNode
The TableNode this column belongs to.

See Also

TableNode.Column Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Column Methods

TableNode.Column Methods

Public Methods

Name | Description
Clone | Creates a copy of this column.

Protected Methods

Name | Description
LoadFromXml | Loads the column properties from an XML element.
SaveToXml | Saves the column properties into an XML element.

See Also

TableNode.Column Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Column.Clone Method

TableNode.Column.Clone Method

Creates a copy of this column.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Column Clone ()
Visual Basic

Public Function Clone () As TableNode.Column

Return Value

An instance of the TableNode.Column class.

See Also

TableNode.Column Members
TableNode.Column Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Column.LoadFromXml Method

TableNode.Column.LoadFromXml Method

Loads the column properties from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the column's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Column Members
TableNode.Column Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Column.SaveToXml Method

TableNode.Column.SaveToXml Method

Saves the column properties into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the column's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Column Members
TableNode.Column Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Column Properties

TableNode.Column Properties

Public Properties

Name | Description
ColumnStyle | Gets or sets the manner in which column's width is set.
Width | Gets or sets the width of the table column.

See Also

TableNode.Column Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Column.ColumnStyle Property

TableNode.Column.ColumnStyle Property

Gets or sets the manner in which column's width is set.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ColumnStyle ColumnStyle { get; set; }
Visual Basic

Public Property ColumnStyle As ColumnStyle

Property Value

A member of the ColumnStyle enumeration. The default is ColumnStyle.FixedWidth.

Remarks

This property is used for calculating the width of a table column. The column can have either a fixed width set through the Width property, or can be resized proportionally to the table width.

See Also

TableNode.Column Members
TableNode.Column Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Column.Width Property

TableNode.Column.Width Property

Gets or sets the width of the table column.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float Width { get; set; }
Visual Basic

Public Property Width As Single

Property Value

A float value indicating the width of the column. The default is 50.

See Also

TableNode.Column Members
TableNode.Column Class
MindFusion.Diagramming Namespace
TableNode.ColumnWidth Property


MindFusion.Diagramming.TableNode.ColumnCollection Class

TableNode.ColumnCollection Class
Remarks See Also

Represents a strongly-typed collection of TableNode.Column objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class TableNode.ColumnCollection : CollectionBase, IPersists
Visual Basic

Public Class TableNode.ColumnCollection
Inherits CollectionBase
Implements IPersists

Remarks

Do not use the methods and properties of this class to modify the contents of this collection directly. If you want to add or remove columns from a table, use the AddColumn, InsertColumn, DeleteColumn and RedimTable methods of the TableNode class instead.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.TableNode.ColumnCollection

See Also

TableNode.ColumnCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.ColumnCollection Members

TableNode.ColumnCollection Members
Constructors Properties Methods

Represents a strongly-typed collection of TableNode.Column objects.

The following tables list the members exposed by the TableNode.ColumnCollection type.

Public Constructors

Name | Description
TableNode.ColumnCollection | Initializes a new instance of the TableNode.ColumnCollection class.

Public Properties

Name | Description
Item | Gets or sets the column at the specified position within the collection.

Public Methods

Name | Description
Add | Adds the specified column to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the column at the specified position.
Insert | Inserts the specified column at the specified index within the collection.
Remove | Removes the specified column from the collection.

See Also

TableNode.ColumnCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.ColumnCollection Constructor

TableNode.ColumnCollection Constructor

Initializes a new instance of the TableNode.ColumnCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.ColumnCollection ()
Visual Basic

Public Sub New ()

Remarks

This constructor supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

TableNode.ColumnCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.ColumnCollection Methods

TableNode.ColumnCollection Methods

Public Methods

Name | Description
Add | Adds the specified column to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the column at the specified position.
Insert | Inserts the specified column at the specified index within the collection.
Remove | Removes the specified column from the collection.

See Also

TableNode.ColumnCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.ColumnCollection.Add Method

TableNode.ColumnCollection.Add Method

Adds the specified column to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Add (
TableNode.Column column
)
Visual Basic

Public Sub Add ( _
column As TableNode.Column _
)

Parameters

column
The TableNode.Column object to add to the collection.

Remarks

Do not use this method directly. Use the AddColumn method of the TableNode class instead.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.ColumnCollection.Clone Method

TableNode.ColumnCollection.Clone Method

Creates a deep copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.ColumnCollection Clone ()
Visual Basic

Public Function Clone () As TableNode.ColumnCollection

Return Value

An instance of the TableNode.ColumnCollection class.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.ColumnCollection.GetAt Method

TableNode.ColumnCollection.GetAt Method

Returns the column at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Column GetAt (
int index
)
Visual Basic

Public Function GetAt ( _
index As Integer _
) As TableNode.Column

Parameters

index
The zero-based index of the column to retrieve.

Return Value

A reference to the TableNode.Column object at the specified position.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.ColumnCollection.Insert Method

TableNode.ColumnCollection.Insert Method

Inserts the specified column at the specified index within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Insert (
int index,
TableNode.Column column
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
column As TableNode.Column _
)

Parameters

index
The zero-based index at which to insert the column.
column
The TableNode.Column object to add to the collection.

Remarks

Do not use this method directly. Use the InsertColumn method of the TableNode class instead.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.ColumnCollection.Remove Method

TableNode.ColumnCollection.Remove Method

Removes the specified column from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Remove (
TableNode.Column column
)
Visual Basic

Public Sub Remove ( _
column As TableNode.Column _
)

Parameters

column
The TableNode.Column object to add to the collection.

Remarks

Do not use this method directly. Use the DeleteColumn method of the TableNode class instead.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.ColumnCollection Properties

TableNode.ColumnCollection Properties

Public Properties

Name | Description
Item | Gets or sets the column at the specified position within the collection.

See Also

TableNode.ColumnCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.ColumnCollection.Item Property

TableNode.ColumnCollection.Item Property

Gets or sets the column at the specified position within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Column Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As TableNode.Column

Parameters

index
The zero-based index of the item which should be get or set.

Property Value

A reference to the TableNode.Column object at the specified index.

Remarks

Do not use the set accessor of this property. It supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Row Class

TableNode.Row Class
Remarks See Also

Represents a row in TableNode node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class TableNode.Row : IPersists
Visual Basic

Public Class TableNode.Row
Implements IPersists

Remarks

Table rows can be assigned to distinct sections of a table. For example, sections could contain rows representing different types of class members in class diagrams, there could be one section displaying the methods, another one for the events and one more for the properties of a class. Each section can be collapsed or expanded, hiding or showing all rows in the section except the header one. To define a section, set a Header row. A section consists of all rows after a header row and spans to the next header. Each header row displays a [±] button that allows expanding or collapsing the section interactively. Sections can be collapsed and expanded programmatically using the Expanded property of the header row.

The height of a row is set via the Height property. That determines the height of all non-spanning cells contained within the row. Cells can be made to span several rows by setting their RowSpan property.

Rows can be bound together to represent relationship between database tables. The relationship can be one to many and many to one. The tables that stay on the left side of M:1 relationships are stored in the RelatedManyToOne collection; the tables in 1:M relationship with the row are stored in the RelatedOneToMany collection.

The relationship between tables is shown with links. You can access the DiagramLink elements that go out of a table row via the OutgoingLinks property. Links that come into a given row can be accessed with the IncomingLinks property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TableNode.Row

See Also

TableNode.Row Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Row Members

TableNode.Row Members
Constructors Properties Methods

Represents a row in TableNode node.

The following tables list the members exposed by the TableNode.Row type.

Public Constructors

Name | Description
TableNode.Row | Initializes a new instance of the TableNode.Row class.

Public Properties

Name | Description
AnchorPattern | Gets or sets a set of anchor points to which links can dock when connected to this row.
Expanded | Gets or sets a value indicating whether the table section starting from this Header row is collapsed or expanded.
Header | Gets or sets a value indicating whether this row is a section header.
Height | Gets or sets the height of the table row.
IncomingLinks | Gets a collection of all links that point to this table row.
OutgoingLinks | Gets a collection of all links that go out of this table row.
RelatedManyToOne | Gets a collection of all tables that are in many-to-one relation with this table row.
RelatedOneToMany | Gets a collection of all tables that are in one-to-many relation with this table row.

Public Methods

Name | Description
Clone | Creates a copy of this row.

Protected Methods

Name | Description
LoadFromXml | Loads the row properties from an XML element.
SaveToXml | Saves the row properties into an XML element.

See Also

TableNode.Row Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Row Constructor

TableNode.Row Constructor

Initializes a new instance of the TableNode.Row class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Row (
TableNode tableNode
)
Visual Basic

Public Sub TableNode.Row ( _
tableNode As TableNode _
)

Parameters

tableNode
The TableNode this row belongs to.

See Also

TableNode.Row Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Row Methods

TableNode.Row Methods

Public Methods

Name | Description
Clone | Creates a copy of this row.

Protected Methods

Name | Description
LoadFromXml | Loads the row properties from an XML element.
SaveToXml | Saves the row properties into an XML element.

See Also

TableNode.Row Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Row.Clone Method

TableNode.Row.Clone Method

Creates a copy of this row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Row Clone ()
Visual Basic

Public Function Clone () As TableNode.Row

Return Value

An instance of the TableNode.Row class.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Row.LoadFromXml Method

TableNode.Row.LoadFromXml Method

Loads the row properties from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the row's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Row.SaveToXml Method

TableNode.Row.SaveToXml Method

Saves the row properties into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

protected void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the row's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Row Properties

TableNode.Row Properties

Public Properties

Name | Description
AnchorPattern | Gets or sets a set of anchor points to which links can dock when connected to this row.
Expanded | Gets or sets a value indicating whether the table section starting from this Header row is collapsed or expanded.
Header | Gets or sets a value indicating whether this row is a section header.
Height | Gets or sets the height of the table row.
IncomingLinks | Gets a collection of all links that point to this table row.
OutgoingLinks | Gets a collection of all links that go out of this table row.
RelatedManyToOne | Gets a collection of all tables that are in many-to-one relation with this table row.
RelatedOneToMany | Gets a collection of all tables that are in one-to-many relation with this table row.

See Also

TableNode.Row Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Row.AnchorPattern Property

TableNode.Row.AnchorPattern Property

Gets or sets a set of anchor points to which links can dock when connected to this row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPattern AnchorPattern { get; set; }
Visual Basic

Public Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

AnchorPattern defines a set of locations where links connected to a row are allowed to connect. When a link is connected to a row, the respective end of the link is aligned to the nearest AnchorPoint assigned to that row. If a row does not have associated anchor points of the appropriate type (incoming/outgoing), the link will be connected to the nearest row that has such anchors defined. If none of the rows of a table has an associated anchor pattern, links are connected to the middle of the left or right side of the pointed row.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming Namespace
TableNode.RowAnchorPattern Property
AnchorPoint.Column Property


MindFusion.Diagramming.TableNode.Row.Expanded Property

TableNode.Row.Expanded Property

Gets or sets a value indicating whether the table section starting from this Header row is collapsed or expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Expanded { get; set; }
Visual Basic

Public Property Expanded As Boolean

Property Value

true if the table section that starts from this row is expanded; otherwise, false. The default is true.

Remarks

This property can be set only if the row is a Header. Links connected to the rows of a collapsed table section appear to be connected to the section header row.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.Row.Header Property

TableNode.Row.Header Property

Gets or sets a value indicating whether this row is a section header.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Header { get; set; }
Visual Basic

Public Property Header As Boolean

Property Value

true if this is the header row of a table section, otherwise false. The default is false.

Remarks

Each header row defines a section of the table that includes all non-header rows after the header. Such sections can be expanded or collapsed, that is, the rows included in them can be shown or hidden. This can be done interactively by pressing the [±] button displayed in header rows, or programmatically by setting the Expanded property. The TableSectionCollapsed and TableSectionExpanded events are raised when a user clicks the [±] button.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming Namespace
OffsetHeaderRows Property


MindFusion.Diagramming.TableNode.Row.Height Property

TableNode.Row.Height Property

Gets or sets the height of the table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float Height { get; set; }
Visual Basic

Public Property Height As Single

Property Value

A float value indicating the height of the row. The default is 22.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming Namespace
TableNode.RowHeight Property


MindFusion.Diagramming.TableNode.Row.IncomingLinks Property

TableNode.Row.IncomingLinks Property

Gets a collection of all links that point to this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLinkCollection IncomingLinks { get; }
Visual Basic

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

A DiagramLinkCollection containing references to the incoming links.

Remarks

The property returns a collection of all links that point to this table row. Use it to access the links or get their number.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming Namespace
OutgoingLinks Property


MindFusion.Diagramming.TableNode.Row.OutgoingLinks Property

TableNode.Row.OutgoingLinks Property

Gets a collection of all links that go out of this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramLinkCollection OutgoingLinks { get; }
Visual Basic

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

A DiagramLinkCollection containing references to the outgoing links.

Remarks

The property returns a collection of all links that start from this table row. Use it to access the links or get their number.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming Namespace
IncomingLinks Property


MindFusion.Diagramming.TableNode.Row.RelatedManyToOne Property

TableNode.Row.RelatedManyToOne Property

Gets a collection of all tables that are in many-to-one relation with this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNodeCollection RelatedManyToOne { get; }
Visual Basic

Public ReadOnly Property RelatedManyToOne As DiagramNodeCollection

Property Value

A DiagramNodeCollection containing references to the TableNode objects, which are in relation M:1 with this row.

Remarks

When working with database diagrams, use this property to find all tables which are in M:1 relation with this row.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming Namespace
RelatedOneToMany Property


MindFusion.Diagramming.TableNode.Row.RelatedOneToMany Property

TableNode.Row.RelatedOneToMany Property

Gets a collection of all tables that are in one-to-many relation with this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNodeCollection RelatedOneToMany { get; }
Visual Basic

Public ReadOnly Property RelatedOneToMany As DiagramNodeCollection

Property Value

A DiagramNodeCollection containing references to the TableNode objects, which are in relation 1:M with this row.

Remarks

When working with database diagrams, use this property to find all tables which are in 1:M relation with this row.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RowCollection Class

TableNode.RowCollection Class
Remarks See Also

Represents a strongly-typed collection of TableNode.Row objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class TableNode.RowCollection : CollectionBase, IPersists
Visual Basic

Public Class TableNode.RowCollection
Inherits CollectionBase
Implements IPersists

Remarks

Do not use the methods and properties of this class to modify the contents of this collection directly. If you want to add or remove rows from a table, use the AddRow, InsertRow, DeleteRow and RedimTable methods of the TableNode class instead.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.TableNode.RowCollection

See Also

TableNode.RowCollection Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RowCollection Members

TableNode.RowCollection Members
Constructors Properties Methods

Represents a strongly-typed collection of TableNode.Row objects.

The following tables list the members exposed by the TableNode.RowCollection type.

Public Constructors

Name | Description
TableNode.RowCollection | Initializes a new instance of the TableNode.RowCollection class.

Public Properties

Name | Description
Item | Gets or sets the row at the specified position within the collection.

Public Methods

Name | Description
Add | Adds the specified row to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the row at the specified position.
IndexOf | Returns the index of the specified row within the collection.
Insert | Inserts the specified row at the specified index within the collection.
Remove | Removes the specified row from the collection.

See Also

TableNode.RowCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RowCollection Constructor

TableNode.RowCollection Constructor

Initializes a new instance of the TableNode.RowCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.RowCollection ()
Visual Basic

Public Sub New ()

Remarks

This constructor supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

TableNode.RowCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RowCollection Methods

TableNode.RowCollection Methods

Public Methods

Name | Description
Add | Adds the specified row to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the row at the specified position.
IndexOf | Returns the index of the specified row within the collection.
Insert | Inserts the specified row at the specified index within the collection.
Remove | Removes the specified row from the collection.

See Also

TableNode.RowCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RowCollection.Add Method

TableNode.RowCollection.Add Method

Adds the specified row to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Add (
TableNode.Row r
)
Visual Basic

Public Sub Add ( _
r As TableNode.Row _
)

Parameters

r
The TableNode.Row object to add to the collection.

Remarks

Do not use this method directly. Use the AddRow method of the TableNode class instead.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RowCollection.Clone Method

TableNode.RowCollection.Clone Method

Creates a deep copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.RowCollection Clone ()
Visual Basic

Public Function Clone () As TableNode.RowCollection

Return Value

An instance of the TableNode.RowCollection class.

Remarks

This method supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RowCollection.GetAt Method

TableNode.RowCollection.GetAt Method

Returns the row at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Row GetAt (
int index
)
Visual Basic

Public Function GetAt ( _
index As Integer _
) As TableNode.Row

Parameters

index
The zero-based index of the row to retrieve.

Return Value

A reference to the TableNode.Row object at the specified position.

Remarks

A reference to the TableNode.Row object at the specified position.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RowCollection.IndexOf Method

TableNode.RowCollection.IndexOf Method

Returns the index of the specified row within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int IndexOf (
TableNode.Row row
)
Visual Basic

Public Function IndexOf ( _
row As TableNode.Row _
) As Integer

Parameters

row
The TableNode.Row object whose index to search for in the collection.

Return Value

An integer value specifying the index of the row within the collection or -1, if the row was not found.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RowCollection.Insert Method

TableNode.RowCollection.Insert Method

Inserts the specified row at the specified index within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Insert (
int index,
TableNode.Row row
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
row As TableNode.Row _
)

Parameters

index

The zero-based index at which to insert the row.

row

The TableNode.Row object to add to the collection.

Remarks

Do not use this method directly. Use the InsertRow method of the TableNode class instead.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RowCollection.Remove Method

TableNode.RowCollection.Remove Method

Removes the specified row from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Remove (
TableNode.Row row
)
Visual Basic

Public Sub Remove ( _
row As TableNode.Row _
)

Parameters

row

The TableNode.Row object to add to the collection.

Remarks

Do not use this method directly. Use the DeleteRow method of the TableNode class instead.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RowCollection Properties

TableNode.RowCollection Properties

Public Properties

Name | Description
Item | Gets or sets the row at the specified position within the collection.

See Also

TableNode.RowCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNode.RowCollection.Item Property

TableNode.RowCollection.Item Property

Gets or sets the row at the specified position within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode.Row Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As TableNode.Row

Parameters

index

Property Value

A reference to the TableNode.Row object at the specified index.

Remarks

Do not use the set accessor of this property. It supports the MindFusion.Diagramming infrastructure and is not intended to be used directly from your code.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties Class

TableNodeProperties Class
Remarks See Also

Stores the values of TableNode properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class TableNodeProperties : DiagramNodeProperties
Visual Basic

Public Class TableNodeProperties
Inherits DiagramNodeProperties

Remarks

If you need to implement undo support for the additional properties defined by a class derived from TableNode, do so by deriving from TableNodeProperties and overriding the SaveProperties, RestoreProperties, and CreateProperties methods of TableNode.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.TableNodeProperties

See Also

TableNodeProperties Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties Members

TableNodeProperties Members
Constructors Fields Methods

Stores the values of TableNode properties during undo / redo operations.

The following tables list the members exposed by the TableNodeProperties type.

Public Constructors

Name | Description
TableNodeProperties | Initializes a new instance of the TableNodeProperties class.

Public Fields

Name | Description
Caption | For internal use.
CaptionColor | For internal use.
CaptionHeight | For internal use.
ColumnWidth | For internal use.
CurrScrollRow | For internal use.
RowHeight | For internal use.
Scrollable | For internal use.
TextColor | For internal use.

Public Methods

Name | Description
FreeResources | DiagramItemProperties.FreeResources override.

See Also

TableNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties Fields

TableNodeProperties Fields

Public Fields

Name | Description
Caption | For internal use.
CaptionColor | For internal use.
CaptionHeight | For internal use.
ColumnWidth | For internal use.
CurrScrollRow | For internal use.
RowHeight | For internal use.
Scrollable | For internal use.
TextColor | For internal use.

See Also

TableNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties.Caption Field

TableNodeProperties.Caption Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string Caption
Visual Basic

Public Caption As String

See Also

TableNodeProperties Members
TableNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties.CaptionColor Field

TableNodeProperties.CaptionColor Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color CaptionColor
Visual Basic

Public CaptionColor As Color

See Also

TableNodeProperties Members
TableNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties.CaptionHeight Field

TableNodeProperties.CaptionHeight Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float CaptionHeight
Visual Basic

Public CaptionHeight As Single

See Also

TableNodeProperties Members
TableNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties.ColumnWidth Field

TableNodeProperties.ColumnWidth Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ColumnWidth
Visual Basic

Public ColumnWidth As Single

See Also

TableNodeProperties Members
TableNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties.CurrScrollRow Field

TableNodeProperties.CurrScrollRow Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int CurrScrollRow
Visual Basic

Public CurrScrollRow As Integer

See Also

TableNodeProperties Members
TableNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties.RowHeight Field

TableNodeProperties.RowHeight Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float RowHeight
Visual Basic

Public RowHeight As Single

See Also

TableNodeProperties Members
TableNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties.Scrollable Field

TableNodeProperties.Scrollable Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Scrollable
Visual Basic

Public Scrollable As Boolean

See Also

TableNodeProperties Members
TableNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties.TextColor Field

TableNodeProperties.TextColor Field

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color TextColor
Visual Basic

Public TextColor As Color

See Also

TableNodeProperties Members
TableNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties Constructor

TableNodeProperties Constructor

Initializes a new instance of the TableNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNodeProperties ()
Visual Basic

Public Sub New ()

See Also

TableNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties Methods

TableNodeProperties Methods

Public Methods

Name | Description
FreeResources | DiagramItemProperties.FreeResources override.

See Also

TableNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableNodeProperties.FreeResources Method

TableNodeProperties.FreeResources Method

DiagramItemProperties.FreeResources override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public override void FreeResources ()
Visual Basic

Public Overrides Sub FreeResources ()

See Also

TableNodeProperties Members
TableNodeProperties Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TableStyle Enumeration

TableStyle Enumeration

Defines the possible values for Style property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum TableStyle
Visual Basic

Public Enumeration TableStyle

Members

Member name | Description
Rectangle | Sets table's shape to rectangle.
RoundedRectangle | Sets table's shape to rounded rectangle.

Remarks

The enumeration provides possible values for the Style property of TableNode objects.

See Also

MindFusion.Diagramming Namespace
Style Property


MindFusion.Diagramming.TreeEnumerator Class

TreeEnumerator Class
Remarks See Also

Enables an easy standard method to itereate over the elements of a tree-like structure of objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class TreeEnumerator : IEnumerator
Visual Basic

Public Class TreeEnumerator
Implements IEnumerator

Remarks

The TreeEnumerator class implements the standard .NET IEnumerator interface. It provides an easy method to iterate over the elements of a tree-like structure of diagram items.

Example

The following example demonstrates how to use the TreeEnumerator:

C#

TreeEnumerator te = new TreeEnumerator(
rootObj, false, false);

while (te.MoveNext())
{
ShapeNode node = (ShapeNode)te.Current;
node.Brush = new SolidBrush(Color.Blue);
}
Visual Basic

Dim te As MindFusion.Diagramming.TreeEnumerator = New MindFusion.Diagramming.TreeEnumerator( _
rootObj, False, False)

While te.MoveNext()
Dim node As ShapeNode = CType(te.Current, ShapeNode)
Node.Brush = New SolidBrush(Color.Blue)
End While

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TreeEnumerator

See Also

TreeEnumerator Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TreeEnumerator Members

TreeEnumerator Members
Constructors Properties Methods

Enables an easy standard method to itereate over the elements of a tree-like structure of objects.

The following tables list the members exposed by the TreeEnumerator type.

Public Constructors

Name | Description
TreeEnumerator | Initializes a new instance of the TreeEnumerator class.

Public Properties

Name | Description
Current | Gets the current element of the iteration.

Public Methods

Name | Description
MoveNext | Advances the enumerator to the next element of the tree.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

See Also

TreeEnumerator Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TreeEnumerator Constructor

TreeEnumerator Constructor

Initializes a new instance of the TreeEnumerator class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public TreeEnumerator (
DiagramNode root,
bool enumLinks,
bool strict
)
Visual Basic

Public Sub TreeEnumerator ( _
root As DiagramNode, _
enumLinks As Boolean, _
strict As Boolean _
)

Parameters

root
The root of the tree or subtree to be enumerated.
enumLinks
Specifies whether to enumerate links.
strict

Specifies whether to check strictly if the passed structure is a tree. If this option is enabled, NotATreeException will be thrown if a cycle or multiple links to a node are encountered. If the option is disabled, the enumerator will ignore any cycles or multiple links found and continue the iteration.

See Also

TreeEnumerator Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TreeEnumerator Methods

TreeEnumerator Methods

Public Methods

Name | Description
MoveNext | Advances the enumerator to the next element of the tree.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

See Also

TreeEnumerator Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TreeEnumerator.MoveNext Method

TreeEnumerator.MoveNext Method

Advances the enumerator to the next element of the tree.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool MoveNext ()
Visual Basic

Public Overridable Function MoveNext () As Boolean

Return Value

true if the enumerator has successfully passed to the next DiagramItem in the collection; false if there are no more elements available to enumerate.

Remarks

Initially an enumerator is positioned before the first element of the tree (the root), and the first call to MoveNext moves the enumerator over that first element.

See Also

TreeEnumerator Members
TreeEnumerator Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TreeEnumerator.Reset Method

TreeEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void Reset ()
Visual Basic

Public Overridable Sub Reset ()

See Also

TreeEnumerator Members
TreeEnumerator Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TreeEnumerator Properties

TreeEnumerator Properties

Public Properties

Name | Description
Current | Gets the current element of the iteration.

See Also

TreeEnumerator Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.TreeEnumerator.Current Property

TreeEnumerator.Current Property

Gets the current element of the iteration.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Object Current { get; }
Visual Basic

Public Overridable ReadOnly Property Current As Object

Property Value

The DiagramItem that is current in the enumeration.

Remarks

If the enumLinks constructor argument is set to false, only nodes are enumerated. After an enumerator is created or after a Reset, MoveNext must be called to advance the enumerator to the first element before reading the value of Current; otherwise, Current is undefined.

See Also

TreeEnumerator Members
TreeEnumerator Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoEventArgs Class

UndoEventArgs Class

Contains the arguments passed to the ActionRecorded, ActionUndone and ActionRedone event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class UndoEventArgs : EventArgs
Visual Basic

Public Class UndoEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.UndoEventArgs
MindFusion.Diagramming.UndoValidationEventArgs

See Also

UndoEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoEventArgs Members

UndoEventArgs Members
Constructors Properties

Contains the arguments passed to the ActionRecorded, ActionUndone and ActionRedone event handlers.

The following tables list the members exposed by the UndoEventArgs type.

Public Constructors

Name | Description
UndoEventArgs | Initializes a new instance of the UndoEventArgs class.

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoEventArgs Constructor

UndoEventArgs Constructor

Initializes a new instance of the UndoEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public UndoEventArgs (
Command command
)
Visual Basic

Public Sub UndoEventArgs ( _
command As Command _
)

Parameters

command

The Command related to the event.

See Also

UndoEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoEventArgs Properties

UndoEventArgs Properties

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoEventArgs.Command Property

UndoEventArgs.Command Property

Gets a reference to the Command instance related to the event being handled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Command Command { get; }
Visual Basic

Public ReadOnly Property Command As Command

Property Value

An instance of the Command class.

See Also

UndoEventArgs Members
UndoEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoEventHandler Delegate

UndoEventHandler Delegate

Represents methods that will handle undo/redo-related events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void UndoEventHandler (
Object sender,
UndoEventArgs e
)
Visual Basic

Public Delegate Sub UndoEventHandler ( _
sender As Object, _
e As UndoEventArgs _
)

Parameters

sender

The source of the event.

e

An UndoEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoManager Class

UndoManager Class
Remarks See Also

Implements undo/redo functionality in MindFusion.Diagramming.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class UndoManager
Visual Basic

Public Class UndoManager

Remarks

The only instance of UndoManager can be accessed through the UndoManager property of Diagram.

Use the UndoEnabled property to enable or disable saving action records for later undo. You might need to disable undo before performing actions that must not be undoable by end-users, such as creating special start/end nodes.

MindFusion.Diagramming does not provide shortcuts to undo or redo an action. An application must provide the user interface means for undo/redo and call the Undo or Redo methods when necessary. Undoing or redoing an action updates the current record pointer of the undo-history queue. To get access to that queue, use the History property.

Sometimes several actions must be represented as a single atomic operation. That can be achieved by using composites, represented by the CompositeCmd class. However actions records that are implicitly created by MindFusion.Diagramming as a response to users actions or method calls cannot be added directly to a composite. Instead you must use the StartComposite method to create an 'active' composite, to which implicitly created records are added automatically.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.UndoManager

See Also

UndoManager Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoManager Members

UndoManager Members
Properties Methods

Implements undo/redo functionality in MindFusion.Diagramming.

The following tables list the members exposed by the UndoManager type.

Public Properties

Name | Description
History | Gets a reference to the undo manager's CommandHistory instance.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.

Public Methods

Name | Description
Redo | Executes again an action saved in the command history.
StartComposite | Overloaded. Creates an 'active' composite record to store records of actions that are implicitly created by MindFusion.Diagramming.
Undo | Undoes an action saved in the command history.

See Also

UndoManager Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoManager Methods

UndoManager Methods

Public Methods

Name | Description
Redo | Executes again an action saved in the command history.
StartComposite | Overloaded. Creates an 'active' composite record to store records of actions that are implicitly created by MindFusion.Diagramming.
Undo | Undoes an action saved in the command history.

See Also

UndoManager Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoManager.Redo Method

UndoManager.Redo Method

Executes again an action saved in the command history.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Redo ()
Visual Basic

Public Sub Redo ()

Remarks

Executes again a command from the command history. The action that would be redone by calling this method is pointed by NextRedo property of the CommandHistory class.

See Also

UndoManager Members
UndoManager Class
MindFusion.Diagramming Namespace
Undo Method


MindFusion.Diagramming.UndoManager.StartComposite Method

UndoManager.StartComposite Method

Creates an 'active' composite record to store records of actions that are implicitly created by MindFusion.Diagramming.

Overload List

Name | Description
UndoManager.StartComposite (String) | Creates an 'active' composite record with the specified title.
UndoManager.StartComposite (String, Boolean) | Creates an 'active' composite record with the specified settings.

See Also

UndoManager Members
UndoManager Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoManager.StartComposite Method (String)

UndoManager.StartComposite Method (String)
See Also

Creates an 'active' composite record with the specified title.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CompositeCmd StartComposite (
string title
)
Visual Basic

Public Function StartComposite ( _
title As String _
) As CompositeCmd

Parameters

title
A string to be associated with the composite record. It can be used later to give more information to users what exactly will be undone or redone. Use the Title property of the command class to get the title of an action record.

Return Value

An instance of the CompositeCmd class which represents the active composite record. Call its Execute method when done with recording actions in the composite.

Remarks

Sometimes several actions must be represented as a single atomic operation. That can be achieved by using composites, represented by the CompositeCmd class. However actions records that are implicitly created by MindFusion.Diagramming as a response to users actions or method calls cannot be added directly to a composite. The StartComposite method creates an 'active' composite, to which implicitly created records are added automatically. Call the composite's Execute method to stop adding action records to it and save it in the command history. Calling Undo or Redo for the composite record, undoes or redoes all actions contained within it.

Example

The following example illustrates how to create composite commands:

C#

// Implicitly created undo records will be saved here
CompositeCmd composite = diagram.UndoManager.StartComposite("Create group");

// Call methods that create undo records
ShapeNode node1 = diagram.Factory.CreateShapeNode(0, 0, 30, 30);
ShapeNode node2 = diagram.Factory.CreateShapeNode(0, 0, 15, 15);
Group g = diagram.Factory.CreateGroup(node1);
g.AttachToCorner(node2, 0);

// This goes to the active composite too
ChangeItemCmd change = new ChangeItemCmd(node2, "");
node2.Locked = true;
change.Execute();

// Save the active composite in history
composite.Execute();
Visual Basic

' Implicitly created undo records will be saved here
Dim composite As CompositeCmd = diagram.UndoManager.StartComposite("Create group")

' Call methods that create undo records
Dim node1 As ShapeNode = diagram.Factory.CreateShapeNode(0, 0, 30, 30)
Dim node2 As ShapeNode = diagram.Factory.CreateShapeNode(0, 0, 15, 15)
Dim g As Group = diagram.Factory.CreateGroup(node1)
g.AttachToCorner(node2, 0)

' This goes to the active composite too
Dim change As ChangeItemCmd = New ChangeItemCmd(node2, "")
node2.Locked = True
change.Execute()

' Save the active composite in history
composite.Execute()

See Also

StartComposite Method Overload List
UndoManager Members
UndoManager Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoManager.StartComposite Method (String, Boolean)

UndoManager.StartComposite Method (String, Boolean)
See Also

Creates an 'active' composite record with the specified settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CompositeCmd StartComposite (
string title,
bool saveZOrder
)
Visual Basic

Public Function StartComposite ( _
title As String, _
saveZOrder As Boolean _
) As CompositeCmd

Parameters

title
A string to be associated with the composite record. It can be used later to give more information to users what exactly will be undone or redone. Use the Title property of the command class to get the title of an action record.
saveZOrder
Set this parameter to true to save the whole z-order array before executing the composite command, and to restore it back when the command is undone. Use that when there will be create or delete commands added to the composite one, because they do not guarantee restoring the items in the same z-order when the commands are undone or redone.

Return Value

An instance of the CompositeCmd class which represents the active composite record. Call its Execute method when done with recording actions in the composite.

Remarks

Sometimes several actions must be represented as a single atomic operation. That can be achieved by using composites, represented by the CompositeCmd class. However actions records that are implicitly created by MindFusion.Diagramming as a response to users actions or method calls cannot be added directly to a composite. The StartComposite method creates an 'active' composite, to which implicitly created records are added automatically. Call the composite's Execute method to stop adding action records to it and save it in the command history. Calling Undo or Redo for the composite record, undoes or redoes all actions contained within it.

Example

The following example illustrates how to create composite commands:

C#

// Implicitly created undo records will be saved here
CompositeCmd composite = diagram.UndoManager.StartComposite("Create group");

// Call methods that create undo records
ShapeNode node1 = diagram.Factory.CreateShapeNode(0, 0, 30, 30);
ShapeNode node2 = diagram.Factory.CreateShapeNode(0, 0, 15, 15);
Group g = diagram.Factory.CreateGroup(node1);
g.AttachToCorner(node2, 0);

// This goes to the active composite too
ChangeItemCmd change = new ChangeItemCmd(node2, "");
node2.Locked = true;
change.Execute();

// Save the active composite in history
composite.Execute();
Visual Basic

' Implicitly created undo records will be saved here
Dim composite As CompositeCmd = diagram.UndoManager.StartComposite("Create group")

' Call methods that create undo records
Dim node1 As ShapeNode = diagram.Factory.CreateShapeNode(0, 0, 30, 30)
Dim node2 As ShapeNode = diagram.Factory.CreateShapeNode(0, 0, 15, 15)
Dim g As Group = diagram.Factory.CreateGroup(node1)
g.AttachToCorner(node2, 0)

' This goes to the active composite too
Dim change As ChangeItemCmd = New ChangeItemCmd(node2, "")
node2.Locked = True
change.Execute()

' Save the active composite in history
composite.Execute()

See Also

StartComposite Method Overload List
UndoManager Members
UndoManager Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoManager.Undo Method

UndoManager.Undo Method

Undoes an action saved in the command history.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void Undo ()
Visual Basic

Public Sub Undo ()

Remarks

Undoes a command from the command history. The action that would be undone by calling this method is pointed by NextUndo property of the CommandHistory class.

See Also

UndoManager Members
UndoManager Class
MindFusion.Diagramming Namespace
Redo Method


MindFusion.Diagramming.UndoManager Properties

UndoManager Properties

Public Properties

Name | Description
History | Gets a reference to the undo manager's CommandHistory instance.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.

See Also

UndoManager Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoManager.History Property

UndoManager.History Property

Gets a reference to the undo manager's CommandHistory instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public CommandHistory History { get; }
Visual Basic

Public ReadOnly Property History As CommandHistory

Property Value

An instance of the CommandHistory class.

Remarks

History represents the undo manager's queue of action records. This queue provides access to the NextUndo and NextRedo records. You could set the queue's Capacity, specifying how many records can be added to the queue before the oldest ones start to drop off its end.

See Also

UndoManager Members
UndoManager Class
MindFusion.Diagramming Namespace
Command class


MindFusion.Diagramming.UndoManager.UndoEnabled Property

UndoManager.UndoEnabled Property

Gets or sets a value indicating whether saving action records for later undo is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool UndoEnabled { get; set; }
Visual Basic

Public Property UndoEnabled As Boolean

Property Value

true to save actions for later undo; otherwise false. The default is false.

Remarks

You might need to disable undo:

  • before executing actions you don't want end-users to undo, for example creating special start/end nodes.
  • before creating programmatically a lot of new diagram items - say hundreds or thousands. MindFusion.Diagramming creates an undo record for each item creation; if the Capacity of the command history is smaller than the number of items created, most of the records will drop from the history queue while adding new ones. That would waste processing power and memory for creating undo records that won't be used.

See Also

UndoManager Members
UndoManager Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoValidationEventArgs Class

UndoValidationEventArgs Class

Contains the arguments passed to the ActionRecording event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class UndoValidationEventArgs : UndoEventArgs
Visual Basic

Public Class UndoValidationEventArgs
Inherits UndoEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.UndoEventArgs
MindFusion.Diagramming.UndoValidationEventArgs

See Also

UndoValidationEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoValidationEventArgs Members

UndoValidationEventArgs Members
Constructors Properties

Contains the arguments passed to the ActionRecording event handlers.

The following tables list the members exposed by the UndoValidationEventArgs type.

Public Constructors

Name | Description
UndoValidationEventArgs | Initializes a new instance of the UndoValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value value indicating whether the operation should be canceled.

See Also

UndoValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoValidationEventArgs Constructor

UndoValidationEventArgs Constructor

Initializes a new instance of the UndoValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public UndoValidationEventArgs (
Command command
)
Visual Basic

Public Sub UndoValidationEventArgs ( _
command As Command _
)

Parameters

command

The Command related to the event.

See Also

UndoValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoValidationEventArgs Properties

UndoValidationEventArgs Properties

Public Properties

Name | Description
Cancel | Gets or sets a value value indicating whether the operation should be canceled.

See Also

UndoValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoValidationEventArgs.Cancel Property

UndoValidationEventArgs.Cancel Property

Gets or sets a value value indicating whether the operation should be canceled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Cancel { get; set; }
Visual Basic

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

See Also

UndoValidationEventArgs Members
UndoValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.UndoValidationEventHandler Delegate

UndoValidationEventHandler Delegate

Represents methods that will handle undo/redo-related confirmation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void UndoValidationEventHandler (
Object sender,
UndoValidationEventArgs e
)
Visual Basic

Public Delegate Sub UndoValidationEventHandler ( _
sender As Object, _
e As UndoValidationEventArgs _
)

Parameters

sender

The source of the event.

e

An UndoValidationEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.ValidationEventArgs Class

ValidationEventArgs Class

Contains the arguments passed to the SelectionMoving event handler.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class ValidationEventArgs : EventArgs
Visual Basic

Public Class ValidationEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.ValidationEventArgs

See Also

ValidationEventArgs Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ValidationEventArgs Members

ValidationEventArgs Members
Constructors Properties Methods

Contains the arguments passed to the SelectionMoving event handler.

The following tables list the members exposed by the ValidationEventArgs type.

Public Constructors

Name | Description
ValidationEventArgs | Initializes a new instance of the ValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevrent the user from completing the operation.

Public Methods

Name | Description
CancelDrag | Cancels the modification of the selected items.

See Also

ValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ValidationEventArgs Constructor

ValidationEventArgs Constructor

Initializes a new instance of the ValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ValidationEventArgs ()
Visual Basic

Public Sub New ()

See Also

ValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ValidationEventArgs Methods

ValidationEventArgs Methods

Public Methods

Name | Description
CancelDrag | Cancels the modification of the selected items.

See Also

ValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ValidationEventArgs.CancelDrag Method

ValidationEventArgs.CancelDrag Method

Cancels the modification of the selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public void CancelDrag ()
Visual Basic

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation. On the other hand, setting Cancel to true only changes the mouse cursor to a Stop icon and the operation is cancelled when the user releases the mouse button.

See Also

ValidationEventArgs Members
ValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ValidationEventArgs Properties

ValidationEventArgs Properties

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevrent the user from completing the operation.

See Also

ValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ValidationEventArgs.Cancel Property

ValidationEventArgs.Cancel Property

Gets or sets a value indicating whether to prevrent the user from completing the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Cancel { get; set; }
Visual Basic

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

See Also

ValidationEventArgs Members
ValidationEventArgs Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.ValidationEventHandler Delegate

ValidationEventHandler Delegate

Represents methods that will handle validation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void ValidationEventHandler (
Object sender,
ValidationEventArgs e
)
Visual Basic

Public Delegate Sub ValidationEventHandler ( _
sender As Object, _
e As ValidationEventArgs _
)

Parameters

sender

The source of the event.

e

A ValidationEventArgs that contains the event data.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.View3D Enumeration

View3D Enumeration

Defines keys used to associate 3D position data with a node through the LayoutTraits property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public enum View3D
Visual Basic

Public Enumeration View3D

Members

Member name | Description
Position | Specifies the position of a node in 3D coordinate space. The value associated with this key should be a Point3D object.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext Class

XmlPersistContext Class

Contains methods that can help you serialize and deserialize MindFusion.Diagramming items to end from XML documents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public class XmlPersistContext
Visual Basic

Public Class XmlPersistContext

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.XmlPersistContext

See Also

XmlPersistContext Members
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext Members

XmlPersistContext Members
Constructors Properties Methods

Contains methods that can help you serialize and deserialize MindFusion.Diagramming items to end from XML documents.

The following tables list the members exposed by the XmlPersistContext type.

Public Constructors

Name | Description
XmlPersistContext | Initializes a new instance of the XmlPersistContext class.

Public Properties

Name | Description
BaseURI | Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.
ClassVersion | Gets the class version of the currently deserialized item.
DefaultNamespaceURI | Gets or sets the default NamespaceURI for elements created through the AddChildElement method and nodes selected through the SelectNode and SelectNodes methods.
Diagram | Gets the underlying diagram object.
IncludeUnalteredProperties | Gets or sets a value specifies whether properties that have their default value should be serialized to XML.
XmlDocument | Gets the underlying XML document.

Public Methods

Name | Description
AddChildElement | Overloaded.
FromRelativePath | Converts the specified path from relative to the BaseURI to an absolute path.
ReadAnchorPattern | Reads an AnchorPattern with the specified name.
ReadBool | Overloaded.
ReadBrush | Reads a MindFusion.Drawing.Brush object with the specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Overloaded.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEnum | Overloaded.
ReadFloat | Overloaded.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Overloaded.
ReadGroup | Reads a group object with the specified name.
ReadHashtable | Reads a hash table object with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Overloaded.
ReadItemReference | Overloaded.
ReadLong | Reads a long value with the specified name.
ReadNodeConstraints | Reads a NodeConstraints object with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Reads a MindFusion.Drawing.Pen object with the specified name.
ReadPointCollection | Reads a PointCollection object with the specified name.
ReadPointF | Overloaded.
ReadRectangleF | Reads a RectangleF object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShape | Reads a Shape object with the specified name.
ReadShort | Overloaded.
ReadSizeF | Reads a Size object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded.
ReadStringFormat | Overloaded.
ReadTag | Reads the specified tag for the specified object.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
SelectNode | Overloaded.
SelectNodes | Overloaded.
ToRelativePath | Converts the specified absolute path to a path relative to the BaseURI.
WriteAnchorPattern | Writes the specified anchor pattern.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteGroup | Writes the specified group object.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteItemReference | Writes a reference to the specified item with the specified name.
WriteLong | Writes a long value with the specified name.
WriteNodeConstraints | Writes the specified NodeConstraints object.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePointCollection | Writes the specified point collection.
WritePointF | Overloaded.
WriteRectangleF | Writes a Size with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShape | Writes the specified shape with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a Size with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteTag | Writes the specified tag of the specified object.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext Constructor

XmlPersistContext Constructor

Initializes a new instance of the XmlPersistContext class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlPersistContext (
Diagram diagram,
XmlDocument document
)
Visual Basic

Public Sub XmlPersistContext ( _
diagram As Diagram, _
document As XmlDocument _
)

Parameters

diagram

The Diagram this class will operate on.

document

The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext Methods

XmlPersistContext Methods

Public Methods

Name | Description
AddChildElement | Overloaded.
FromRelativePath | Converts the specified path from relative to the BaseURI to an absolute path.
ReadAnchorPattern | Reads an AnchorPattern with the specified name.
ReadBool | Overloaded.
ReadBrush | Reads a MindFusion.Drawing.Brush object with the specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Overloaded.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEnum | Overloaded.
ReadFloat | Overloaded.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Overloaded.
ReadGroup | Reads a group object with the specified name.
ReadHashtable | Reads a hash table object with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Overloaded.
ReadItemReference | Overloaded.
ReadLong | Reads a long value with the specified name.
ReadNodeConstraints | Reads a NodeConstraints object with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Reads a MindFusion.Drawing.Pen object with the specified name.
ReadPointCollection | Reads a PointCollection object with the specified name.
ReadPointF | Overloaded.
ReadRectangleF | Reads a RectangleF object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShape | Reads a Shape object with the specified name.
ReadShort | Overloaded.
ReadSizeF | Reads a Size object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded.
ReadStringFormat | Overloaded.
ReadTag | Reads the specified tag for the specified object.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
SelectNode | Overloaded.
SelectNodes | Overloaded.
ToRelativePath | Converts the specified absolute path to a path relative to the BaseURI.
WriteAnchorPattern | Writes the specified anchor pattern.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteGroup | Writes the specified group object.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteItemReference | Writes a reference to the specified item with the specified name.
WriteLong | Writes a long value with the specified name.
WriteNodeConstraints | Writes the specified NodeConstraints object.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePointCollection | Writes the specified point collection.
WritePointF | Overloaded.
WriteRectangleF | Writes a Size with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShape | Writes the specified shape with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a Size with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteTag | Writes the specified tag of the specified object.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method

XmlPersistContext.AddChildElement Method

Overload List

Name | Description
XmlPersistContext.AddChildElement (String, String, XmlElement) | Adds a new child node with the specified name and namespace to the specified parent node.
XmlPersistContext.AddChildElement (String, String, XmlElement, String) | Adds a new child node with the specified name and value to the specified parent node.
XmlPersistContext.AddChildElement (String, XmlElement) | Adds a new child node with the specified name to the specified parent node.
XmlPersistContext.AddChildElement (String, XmlElement, String) | Adds a new child node with the specified name and value to the specified parent node.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method (String, String, XmlElement)

XmlPersistContext.AddChildElement Method (String, String, XmlElement)
See Also

Adds a new child node with the specified name and namespace to the specified parent node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement AddChildElement (
string elementName,
string elementNamespace,
XmlElement parentElement
)
Visual Basic

Public Function AddChildElement ( _
elementName As String, _
elementNamespace As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

elementName
elementNamespace
parentElement

Return Value

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method (String, String, XmlElement, String)

XmlPersistContext.AddChildElement Method (String, String, XmlElement, String)
See Also

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement AddChildElement (
string elementName,
string elementNamespace,
XmlElement parentElement,
string innerText
)
Visual Basic

Public Function AddChildElement ( _
elementName As String, _
elementNamespace As String, _
parentElement As XmlElement, _
innerText As String _
) As XmlElement

Parameters

elementName
elementNamespace
parentElement
innerText

Return Value

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method (String, XmlElement)

XmlPersistContext.AddChildElement Method (String, XmlElement)
See Also

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function AddChildElement ( _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

elementName
parentElement

Return Value

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method (String, XmlElement, String)

XmlPersistContext.AddChildElement Method (String, XmlElement, String)
See Also

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement,
string innerText
)
Visual Basic

Public Function AddChildElement ( _
elementName As String, _
parentElement As XmlElement, _
innerText As String _
) As XmlElement

Parameters

elementName
parentElement
innerText

Return Value

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.FromRelativePath Method

XmlPersistContext.FromRelativePath Method

Converts the specified path from relative to the BaseURI to an absolute path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string FromRelativePath (
string path
)
Visual Basic

Public Function FromRelativePath ( _
path As String _
) As String

Parameters

path

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadAnchorPattern Method

XmlPersistContext.ReadAnchorPattern Method

Reads an AnchorPattern with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public AnchorPattern ReadAnchorPattern (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadAnchorPattern ( _
elementName As String, _
parentElement As XmlElement _
) As AnchorPattern

Parameters

elementName
The name of the element containing the AnchorPattern object.
parentElement
The parent element of the node with the specified name.

Return Value

An AnchorPattern object.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadBool Method

XmlPersistContext.ReadBool Method

Overload List

Name | Description
XmlPersistContext.ReadBool (String, XmlElement) | Reads a boolean value with the specified name.
XmlPersistContext.ReadBool (String, XmlElement, Boolean) | Reads a boolean value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadBool Method (String, XmlElement)

XmlPersistContext.ReadBool Method (String, XmlElement)
See Also

Reads a boolean value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ReadBool (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadBool ( _
elementName As String, _
parentElement As XmlElement _
) As Boolean

Parameters

elementName
parentElement

Return Value

See Also

ReadBool Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadBool Method (String, XmlElement, Boolean)

XmlPersistContext.ReadBool Method (String, XmlElement, Boolean)
See Also

Reads a boolean value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ReadBool (
string elementName,
XmlElement parentElement,
bool defaultValue
)
Visual Basic

Public Function ReadBool ( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName
parentElement
defaultValue

Return Value

See Also

ReadBool Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadBrush Method

XmlPersistContext.ReadBrush Method

Reads a MindFusion.Drawing.Brush object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Brush ReadBrush (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadBrush ( _
elementName As String, _
parentElement As XmlElement _
) As Brush

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadByte Method

XmlPersistContext.ReadByte Method

Reads a byte value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public byte ReadByte (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadByte ( _
elementName As String, _
parentElement As XmlElement _
) As Byte

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadChar Method

XmlPersistContext.ReadChar Method

Reads a char value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public char ReadChar (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadChar ( _
elementName As String, _
parentElement As XmlElement _
) As Char

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadColor Method

XmlPersistContext.ReadColor Method

Overload List

Name | Description
XmlPersistContext.ReadColor (String, XmlElement) | Reads a color with the specified name.
XmlPersistContext.ReadColor (String, XmlElement, Color) | Reads a color with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadColor Method (String, XmlElement)

XmlPersistContext.ReadColor Method (String, XmlElement)
See Also

Reads a color with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color ReadColor (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadColor ( _
elementName As String, _
parentElement As XmlElement _
) As Color

Parameters

elementName
parentElement

Return Value

See Also

ReadColor Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadColor Method (String, XmlElement, Color)

XmlPersistContext.ReadColor Method (String, XmlElement, Color)
See Also

Reads a color with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color ReadColor (
string elementName,
XmlElement parentElement,
Color defaultValue
)
Visual Basic

Public Function ReadColor ( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Color _
) As Color

Parameters

elementName
parentElement
defaultValue

Return Value

See Also

ReadColor Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadColorArray Method

XmlPersistContext.ReadColorArray Method

Reads a color array with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Color[] ReadColorArray (
string elementName,
string subElementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadColorArray ( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Color()

Parameters

elementName
subElementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadDecimal Method

XmlPersistContext.ReadDecimal Method

Reads a decimal value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Decimal ReadDecimal (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadDecimal ( _
elementName As String, _
parentElement As XmlElement _
) As Decimal

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadDouble Method

XmlPersistContext.ReadDouble Method

Reads a double value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public double ReadDouble (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadDouble ( _
elementName As String, _
parentElement As XmlElement _
) As Double

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadEnum Method

XmlPersistContext.ReadEnum Method

Overload List

Name | Description
XmlPersistContext.ReadEnum (String, XmlElement) | Reads an enum value with the specified name.
XmlPersistContext.ReadEnum (String, XmlElement, Object) | Reads an enum value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadEnum Method (String, XmlElement)

XmlPersistContext.ReadEnum Method (String, XmlElement)
See Also

Reads an enum value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object ReadEnum (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadEnum ( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName
parentElement

Return Value

See Also

ReadEnum Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadEnum Method (String, XmlElement, Object)

XmlPersistContext.ReadEnum Method (String, XmlElement, Object)
See Also

Reads an enum value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object ReadEnum (
string elementName,
XmlElement parentElement,
Object defaultValue
)
Visual Basic

Public Function ReadEnum ( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Object _
) As Object

Parameters

elementName
parentElement
defaultValue

Return Value

See Also

ReadEnum Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadFloat Method

XmlPersistContext.ReadFloat Method

Overload List

Name | Description
XmlPersistContext.ReadFloat (String, XmlElement) | Reads a float value with the specified name.
XmlPersistContext.ReadFloat (String, XmlElement, Single) | Reads a float value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadFloat Method (String, XmlElement)

XmlPersistContext.ReadFloat Method (String, XmlElement)
See Also

Reads a float value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ReadFloat (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadFloat ( _
elementName As String, _
parentElement As XmlElement _
) As Single

Parameters

elementName
parentElement

Return Value

See Also

ReadFloat Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadFloat Method (String, XmlElement, Single)

XmlPersistContext.ReadFloat Method (String, XmlElement, Single)
See Also

Reads a float value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float ReadFloat (
string elementName,
XmlElement parentElement,
float defaultValue
)
Visual Basic

Public Function ReadFloat ( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Single _
) As Single

Parameters

elementName
parentElement
defaultValue

Return Value

See Also

ReadFloat Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadFloatArray Method

XmlPersistContext.ReadFloatArray Method

Reads a float array with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public float[] ReadFloatArray (
string elementName,
string subElementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadFloatArray ( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Single()

Parameters

elementName
subElementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadFont Method

XmlPersistContext.ReadFont Method

Overload List

Name | Description
XmlPersistContext.ReadFont (String, XmlElement) | Reads a Font object with the specified name.
XmlPersistContext.ReadFont (String, XmlElement, Font) | Reads a Font object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadFont Method (String, XmlElement)

XmlPersistContext.ReadFont Method (String, XmlElement)
See Also

Reads a Font object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Font ReadFont (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadFont ( _
elementName As String, _
parentElement As XmlElement _
) As Font

Parameters

elementName
parentElement

Return Value

See Also

ReadFont Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadFont Method (String, XmlElement, Font)

XmlPersistContext.ReadFont Method (String, XmlElement, Font)
See Also

Reads a Font object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Font ReadFont (
string elementName,
XmlElement parentElement,
Font defaultFont
)
Visual Basic

Public Function ReadFont ( _
elementName As String, _
parentElement As XmlElement, _
defaultFont As Font _
) As Font

Parameters

elementName
parentElement
defaultFont

Return Value

See Also

ReadFont Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadGroup Method

XmlPersistContext.ReadGroup Method

Reads a group object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Group ReadGroup (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadGroup ( _
elementName As String, _
parentElement As XmlElement _
) As Group

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadHashtable Method

XmlPersistContext.ReadHashtable Method

Reads a hash table object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Hashtable ReadHashtable (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadHashtable ( _
elementName As String, _
parentElement As XmlElement _
) As Hashtable

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadImage Method

XmlPersistContext.ReadImage Method

Reads an Image object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Image ReadImage (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadImage ( _
elementName As String, _
parentElement As XmlElement _
) As Image

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadInt Method

XmlPersistContext.ReadInt Method

Overload List

Name | Description
XmlPersistContext.ReadInt (String, XmlElement) | Reads an integer value with the specified name.
XmlPersistContext.ReadInt (String, XmlElement, Int32) | Reads an integer value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadInt Method (String, XmlElement)

XmlPersistContext.ReadInt Method (String, XmlElement)
See Also

Reads an integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int ReadInt (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadInt ( _
elementName As String, _
parentElement As XmlElement _
) As Integer

Parameters

elementName
parentElement

Return Value

See Also

ReadInt Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadInt Method (String, XmlElement, Int32)

XmlPersistContext.ReadInt Method (String, XmlElement, Int32)
See Also

Reads an integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int ReadInt (
string elementName,
XmlElement parentElement,
int defaultValue
)
Visual Basic

Public Function ReadInt ( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Integer _
) As Integer

Parameters

elementName
parentElement
defaultValue

Return Value

See Also

ReadInt Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadItemReference Method

XmlPersistContext.ReadItemReference Method

Overload List

Name | Description
XmlPersistContext.ReadItemReference (String, XmlElement) | Reads a reference to the item with the specified name.
XmlPersistContext.ReadItemReference (XmlElement) | Reads an item reference from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadItemReference Method (String, XmlElement)

XmlPersistContext.ReadItemReference Method (String, XmlElement)
See Also

Reads a reference to the item with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem ReadItemReference (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadItemReference ( _
elementName As String, _
parentElement As XmlElement _
) As DiagramItem

Parameters

elementName
parentElement

Return Value

See Also

ReadItemReference Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadItemReference Method (XmlElement)

XmlPersistContext.ReadItemReference Method (XmlElement)
See Also

Reads an item reference from the specified element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem ReadItemReference (
XmlElement itemElement
)
Visual Basic

Public Function ReadItemReference ( _
itemElement As XmlElement _
) As DiagramItem

Parameters

itemElement

Return Value

See Also

ReadItemReference Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadLong Method

XmlPersistContext.ReadLong Method

Reads a long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public long ReadLong (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadLong ( _
elementName As String, _
parentElement As XmlElement _
) As Long

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadNodeConstraints Method

XmlPersistContext.ReadNodeConstraints Method

Reads a NodeConstraints object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public NodeConstraints ReadNodeConstraints (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadNodeConstraints ( _
elementName As String, _
parentElement As XmlElement _
) As NodeConstraints

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadObject Method

XmlPersistContext.ReadObject Method

Reads an object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object ReadObject (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadObject ( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadPen Method

XmlPersistContext.ReadPen Method

Reads a MindFusion.Drawing.Pen object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Pen ReadPen (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadPen ( _
elementName As String, _
parentElement As XmlElement _
) As Pen

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadPointCollection Method

XmlPersistContext.ReadPointCollection Method

Reads a PointCollection object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointCollection ReadPointCollection (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadPointCollection ( _
elementName As String, _
parentElement As XmlElement _
) As PointCollection

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadPointF Method

XmlPersistContext.ReadPointF Method

Overload List

Name | Description
XmlPersistContext.ReadPointF (String, XmlElement) | Reads a PointF object with the specified name.
XmlPersistContext.ReadPointF (XmlElement) | Reads a PointF object from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadPointF Method (String, XmlElement)

XmlPersistContext.ReadPointF Method (String, XmlElement)
See Also

Reads a PointF object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF ReadPointF (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadPointF ( _
elementName As String, _
parentElement As XmlElement _
) As PointF

Parameters

elementName
parentElement

Return Value

See Also

ReadPointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadPointF Method (XmlElement)

XmlPersistContext.ReadPointF Method (XmlElement)
See Also

Reads a PointF object from the specified element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public PointF ReadPointF (
XmlElement element
)
Visual Basic

Public Function ReadPointF ( _
element As XmlElement _
) As PointF

Parameters

element

Return Value

See Also

ReadPointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadRectangleF Method

XmlPersistContext.ReadRectangleF Method

Reads a RectangleF object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF ReadRectangleF (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadRectangleF ( _
elementName As String, _
parentElement As XmlElement _
) As RectangleF

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadSByte Method

XmlPersistContext.ReadSByte Method

Reads a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public sbyte ReadSByte (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadSByte ( _
elementName As String, _
parentElement As XmlElement _
) As SByte

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadShape Method

XmlPersistContext.ReadShape Method

Reads a Shape object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Shape ReadShape (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadShape ( _
elementName As String, _
parentElement As XmlElement _
) As Shape

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadShort Method

XmlPersistContext.ReadShort Method

Overload List

Name | Description
XmlPersistContext.ReadShort (String, XmlElement) | Reads a short value with the specified name.
XmlPersistContext.ReadShort (String, XmlElement, Int16) | Reads a short value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadShort Method (String, XmlElement)

XmlPersistContext.ReadShort Method (String, XmlElement)
See Also

Reads a short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public short ReadShort (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadShort ( _
elementName As String, _
parentElement As XmlElement _
) As Short

Parameters

elementName
parentElement

Return Value

See Also

ReadShort Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadShort Method (String, XmlElement, Int16)

XmlPersistContext.ReadShort Method (String, XmlElement, Int16)
See Also

Reads a short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public short ReadShort (
string elementName,
XmlElement parentElement,
short defaultValue
)
Visual Basic

Public Function ReadShort ( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Short _
) As Short

Parameters

elementName
parentElement
defaultValue

Return Value

See Also

ReadShort Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadSizeF Method

XmlPersistContext.ReadSizeF Method

Reads a Size object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeF ReadSizeF (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadSizeF ( _
elementName As String, _
parentElement As XmlElement _
) As SizeF

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadStream Method

XmlPersistContext.ReadStream Method

Reads a stream with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Stream ReadStream (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadStream ( _
elementName As String, _
parentElement As XmlElement _
) As Stream

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadString Method

XmlPersistContext.ReadString Method

Overload List

Name | Description
XmlPersistContext.ReadString (String, XmlElement) | Reads a string value with the specified name.
XmlPersistContext.ReadString (String, XmlElement, String) | Reads a string value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadString Method (String, XmlElement)

XmlPersistContext.ReadString Method (String, XmlElement)
See Also

Reads a string value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ReadString (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadString ( _
elementName As String, _
parentElement As XmlElement _
) As String

Parameters

elementName
parentElement

Return Value

See Also

ReadString Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadString Method (String, XmlElement, String)

XmlPersistContext.ReadString Method (String, XmlElement, String)
See Also

Reads a string value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ReadString (
string elementName,
XmlElement parentElement,
string defaultValue
)
Visual Basic

Public Function ReadString ( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As String _
) As String

Parameters

elementName
parentElement
defaultValue

Return Value

See Also

ReadString Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadStringFormat Method

XmlPersistContext.ReadStringFormat Method

Overload List

Name | Description
XmlPersistContext.ReadStringFormat (String, XmlElement) | Reads a StringFormat object with the specified name.
XmlPersistContext.ReadStringFormat (String, XmlElement, StringFormat) | Reads a StringFormat object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadStringFormat Method (String, XmlElement)

XmlPersistContext.ReadStringFormat Method (String, XmlElement)
See Also

Reads a StringFormat object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public StringFormat ReadStringFormat (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadStringFormat ( _
elementName As String, _
parentElement As XmlElement _
) As StringFormat

Parameters

elementName
parentElement

Return Value

See Also

ReadStringFormat Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadStringFormat Method (String, XmlElement, StringFormat)

XmlPersistContext.ReadStringFormat Method (String, XmlElement, StringFormat)
See Also

Reads a StringFormat object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public StringFormat ReadStringFormat (
string elementName,
XmlElement parentElement,
StringFormat defultFormat
)
Visual Basic

Public Function ReadStringFormat ( _
elementName As String, _
parentElement As XmlElement, _
defultFormat As StringFormat _
) As StringFormat

Parameters

elementName
parentElement
defultFormat

Return Value

See Also

ReadStringFormat Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadTag Method

XmlPersistContext.ReadTag Method

Reads the specified tag for the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Object ReadTag (
Object item,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadTag ( _
item As Object, _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

item
elementName
parentElement

Return Value

Remarks

Tags are read similarly to arbitrary objects except that the client of the diagram is given a chance to perform custom deserialization through event handling.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadUInt Method

XmlPersistContext.ReadUInt Method

Reads an unsigned integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public uint ReadUInt (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadUInt ( _
elementName As String, _
parentElement As XmlElement _
) As UInteger

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadULong Method

XmlPersistContext.ReadULong Method

Reads an unsigned long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ulong ReadULong (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadULong ( _
elementName As String, _
parentElement As XmlElement _
) As ULong

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ReadUShort Method

XmlPersistContext.ReadUShort Method

Reads an unsigned short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public ushort ReadUShort (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadUShort ( _
elementName As String, _
parentElement As XmlElement _
) As UShort

Parameters

elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.SelectNode Method

XmlPersistContext.SelectNode Method

Overload List

Name | Description
XmlPersistContext.SelectNode (XmlElement, String) | Returns the child node with the specified name.
XmlPersistContext.SelectNode (XmlElement, String, String) | Returns the child node with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.SelectNode Method (XmlElement, String)

XmlPersistContext.SelectNode Method (XmlElement, String)
See Also

Returns the child node with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement SelectNode (
XmlElement parentElement,
string name
)
Visual Basic

Public Function SelectNode ( _
parentElement As XmlElement, _
name As String _
) As XmlElement

Parameters

parentElement
The parent XML element.
name
A string specifying the name of the child node.

Return Value

An XmlElement corresponding to the child node.

See Also

SelectNode Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.SelectNode Method (XmlElement, String, String)

XmlPersistContext.SelectNode Method (XmlElement, String, String)
See Also

Returns the child node with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement SelectNode (
XmlElement parentElement,
string elementName,
string elementNamespace
)
Visual Basic

Public Function SelectNode ( _
parentElement As XmlElement, _
elementName As String, _
elementNamespace As String _
) As XmlElement

Parameters

parentElement
The parent XML element.
elementName
A string specifying the name of the child node.
elementNamespace
A string specifying the XML namespace of the child node.

Return Value

An XmlElement corresponding to the child node.

See Also

SelectNode Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.SelectNodes Method

XmlPersistContext.SelectNodes Method

Overload List

Name | Description
XmlPersistContext.SelectNodes (XmlElement, String) | Returns the child nodes with the specified name.
XmlPersistContext.SelectNodes (XmlElement, String, String) | Returns the child nodes with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.SelectNodes Method (XmlElement, String)

XmlPersistContext.SelectNodes Method (XmlElement, String)
See Also

Returns the child nodes with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlNodeList SelectNodes (
XmlElement parentElement,
string name
)
Visual Basic

Public Function SelectNodes ( _
parentElement As XmlElement, _
name As String _
) As XmlNodeList

Parameters

parentElement
The parent XML element.
name
A string specifying the name of the child nodes.

Return Value

An XmlNodeList containing the found child nodes.

See Also

SelectNodes Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.SelectNodes Method (XmlElement, String, String)

XmlPersistContext.SelectNodes Method (XmlElement, String, String)
See Also

Returns the child nodes with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlNodeList SelectNodes (
XmlElement parentElement,
string elementName,
string elementNamespace
)
Visual Basic

Public Function SelectNodes ( _
parentElement As XmlElement, _
elementName As String, _
elementNamespace As String _
) As XmlNodeList

Parameters

parentElement
The parent XML element.
elementName
A string specifying the name of the child nodes.
elementNamespace
A string specifying the XML namespace of the child nodes.

Return Value

An XmlNodeList containing the found child nodes.

See Also

SelectNodes Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ToRelativePath Method

XmlPersistContext.ToRelativePath Method

Converts the specified absolute path to a path relative to the BaseURI.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string ToRelativePath (
string path
)
Visual Basic

Public Function ToRelativePath ( _
path As String _
) As String

Parameters

path

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteAnchorPattern Method

XmlPersistContext.WriteAnchorPattern Method

Writes the specified anchor pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteAnchorPattern (
AnchorPattern anchorPattern,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteAnchorPattern ( _
anchorPattern As AnchorPattern, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

anchorPattern
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteBool Method

XmlPersistContext.WriteBool Method

Writes a boolean value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteBool (
bool boolValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteBool ( _
boolValue As Boolean, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

boolValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteBrush Method

XmlPersistContext.WriteBrush Method

Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteBrush (
Brush brush,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteBrush ( _
brush As Brush, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

brush
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteByte Method

XmlPersistContext.WriteByte Method

Write a byte value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteByte (
byte byteValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteByte ( _
byteValue As Byte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

byteValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteChar Method

XmlPersistContext.WriteChar Method

Write a char value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteChar (
char charValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteChar ( _
charValue As Char, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

charValue
elementName
parentElement

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteColor Method

XmlPersistContext.WriteColor Method

Writes the specified color.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteColor (
Color color,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteColor ( _
color As Color, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

color
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteColorArray Method

XmlPersistContext.WriteColorArray Method

Writes the specified array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteColorArray (
Color[] array,
string elementName,
string subElementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteColorArray ( _
array() As Color, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array
elementName
subElementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteDecimal Method

XmlPersistContext.WriteDecimal Method

Write a decimal value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteDecimal (
Decimal decimalValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteDecimal ( _
decimalValue As Decimal, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

decimalValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteDouble Method

XmlPersistContext.WriteDouble Method

Writes a double value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteDouble (
double doubleValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteDouble ( _
doubleValue As Double, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

doubleValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteEnum Method

XmlPersistContext.WriteEnum Method

Writes the specified enum value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteEnum (
Object enumValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteEnum ( _
enumValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

enumValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteFloat Method

XmlPersistContext.WriteFloat Method

Writes a float value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteFloat (
float floatValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteFloat ( _
floatValue As Single, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

floatValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteFloatArray Method

XmlPersistContext.WriteFloatArray Method

Writes the specified array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteFloatArray (
float[] array,
string elementName,
string subElementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteFloatArray ( _
array() As Single, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array
elementName
subElementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteFont Method

XmlPersistContext.WriteFont Method

Writes the specified font.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteFont (
Font font,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteFont ( _
font As Font, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

font
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteGroup Method

XmlPersistContext.WriteGroup Method

Writes the specified group object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteGroup (
Group group,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteGroup ( _
group As Group, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

group
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteHashtable Method

XmlPersistContext.WriteHashtable Method

Writes the specified hashtable.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteHashtable (
Hashtable hashtable,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteHashtable ( _
hashtable As Hashtable, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

hashtable
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteImage Method

XmlPersistContext.WriteImage Method

Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteImage (
Image image,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteImage ( _
image As Image, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

image
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteInt Method

XmlPersistContext.WriteInt Method

Writes an integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteInt (
int intValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteInt ( _
intValue As Integer, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

intValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteItemReference Method

XmlPersistContext.WriteItemReference Method

Writes a reference to the specified item with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteItemReference (
DiagramItem item,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteItemReference ( _
item As DiagramItem, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

item
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteLong Method

XmlPersistContext.WriteLong Method

Writes a long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteLong (
long longValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteLong ( _
longValue As Long, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

longValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteNodeConstraints Method

XmlPersistContext.WriteNodeConstraints Method

Writes the specified NodeConstraints object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteNodeConstraints (
NodeConstraints nodeConstraints,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteNodeConstraints ( _
nodeConstraints As NodeConstraints, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

nodeConstraints
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteObject Method

XmlPersistContext.WriteObject Method

Writes the specified object under the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteObject (
Object objectValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteObject ( _
objectValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

objectValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WritePen Method

XmlPersistContext.WritePen Method

Writes the specified pen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WritePen (
Pen pen,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WritePen ( _
pen As Pen, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

pen
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WritePointCollection Method

XmlPersistContext.WritePointCollection Method

Writes the specified point collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WritePointCollection (
PointCollection points,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WritePointCollection ( _
points As PointCollection, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

points
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WritePointF Method

XmlPersistContext.WritePointF Method

Overload List

Name | Description
XmlPersistContext.WritePointF (PointF, String, XmlElement) | Writes a PointF with the specified name.
XmlPersistContext.WritePointF (Single, Single, String, XmlElement) | Writes the specified PointF under the specified name. The x and y components of the point are written as attributes.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WritePointF Method (PointF, String, XmlElement)

XmlPersistContext.WritePointF Method (PointF, String, XmlElement)
See Also

Writes a PointF with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WritePointF (
PointF point,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WritePointF ( _
point As PointF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

point
elementName
parentElement

Return Value

See Also

WritePointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WritePointF Method (Single, Single, String, XmlElement)

XmlPersistContext.WritePointF Method (Single, Single, String, XmlElement)
See Also

Writes the specified PointF under the specified name. The x and y components of the point are written as attributes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WritePointF (
float x,
float y,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WritePointF ( _
x As Single, _
y As Single, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

x
y
elementName
parentElement

Return Value

See Also

WritePointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteRectangleF Method

XmlPersistContext.WriteRectangleF Method

Writes a Size with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteRectangleF (
RectangleF rectangle,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteRectangleF ( _
rectangle As RectangleF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

rectangle
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteSByte Method

XmlPersistContext.WriteSByte Method

Write a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteSByte (
sbyte byteValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteSByte ( _
byteValue As SByte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

byteValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteShape Method

XmlPersistContext.WriteShape Method

Writes the specified shape with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteShape (
Shape shape,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteShape ( _
shape As Shape, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

shape
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteShort Method

XmlPersistContext.WriteShort Method

Writes a short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteShort (
short shortValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteShort ( _
shortValue As Short, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

shortValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteSizeF Method

XmlPersistContext.WriteSizeF Method

Writes a Size with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteSizeF (
SizeF size,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteSizeF ( _
size As SizeF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

size
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteStream Method

XmlPersistContext.WriteStream Method

Writes the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteStream (
Stream stream,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteStream ( _
stream As Stream, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stream
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteString Method

XmlPersistContext.WriteString Method

Writes a string value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteString (
string stringValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteString ( _
stringValue As String, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stringValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteStringFormat Method

XmlPersistContext.WriteStringFormat Method

Writes the specified StringFormat object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteStringFormat (
StringFormat stringFormat,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteStringFormat ( _
stringFormat As StringFormat, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stringFormat
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteTag Method

XmlPersistContext.WriteTag Method

Writes the specified tag of the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteTag (
Object item,
Object tagValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteTag ( _
item As Object, _
tagValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

item
tagValue
elementName
parentElement

Return Value

Remarks

Tags are written similarly to arbitrary objects except that the client of the diagram is given a chance to perform custom serialization through event handling.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteUInt Method

XmlPersistContext.WriteUInt Method

Writes an unsigned integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteUInt (
uint uintValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteUInt ( _
uintValue As UInteger, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

uintValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteULong Method

XmlPersistContext.WriteULong Method

Writes an unsigned long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteULong (
ulong ulongValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteULong ( _
ulongValue As ULong, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

ulongValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.WriteUShort Method

XmlPersistContext.WriteUShort Method

Writes an unsigned short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlElement WriteUShort (
ushort ushortValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteUShort ( _
ushortValue As UShort, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

ushortValue
elementName
parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext Properties

XmlPersistContext Properties

Public Properties

Name | Description
BaseURI | Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.
ClassVersion | Gets the class version of the currently deserialized item.
DefaultNamespaceURI | Gets or sets the default NamespaceURI for elements created through the AddChildElement method and nodes selected through the SelectNode and SelectNodes methods.
Diagram | Gets the underlying diagram object.
IncludeUnalteredProperties | Gets or sets a value specifies whether properties that have their default value should be serialized to XML.
XmlDocument | Gets the underlying XML document.

See Also

XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.BaseURI Property

XmlPersistContext.BaseURI Property

Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string BaseURI { get; set; }
Visual Basic

Public Property BaseURI As String

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.ClassVersion Property

XmlPersistContext.ClassVersion Property

Gets the class version of the currently deserialized item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public int ClassVersion { get; }
Visual Basic

Public ReadOnly Property ClassVersion As Integer

Property Value

An integer value specifying the class version.

Remarks

This property is only useful when deserializing items.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.DefaultNamespaceURI Property

XmlPersistContext.DefaultNamespaceURI Property

Gets or sets the default NamespaceURI for elements created through the AddChildElement method and nodes selected through the SelectNode and SelectNodes methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public string DefaultNamespaceURI { get; set; }
Visual Basic

Public Property DefaultNamespaceURI As String

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.Diagram Property

XmlPersistContext.Diagram Property

Gets the underlying diagram object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public Diagram Diagram { get; }
Visual Basic

Public ReadOnly Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.IncludeUnalteredProperties Property

XmlPersistContext.IncludeUnalteredProperties Property

Gets or sets a value specifies whether properties that have their default value should be serialized to XML.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public bool IncludeUnalteredProperties { get; set; }
Visual Basic

Public Property IncludeUnalteredProperties As Boolean

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.XmlPersistContext.XmlDocument Property

XmlPersistContext.XmlDocument Property

Gets the underlying XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C#

public XmlDocument XmlDocument { get; }
Visual Basic

Public ReadOnly Property XmlDocument As XmlDocument

Property Value

An instance of the .NET XmlDocument class.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming Namespace


MindFusion.Diagramming.Commands Namespace
Classes

Classes

Class | Description
AddGroupCmd | Implements creation of groups.
AddItemCmd | Implements creation of new diagram items.
AddToContainerCmd | Undoable command that implements an addition of a node to a container.
ChangeItemCmd | Handles undo / redo of programmatic property changes.
Command | Represent an action that can be carried out on a diagram, and later undone or redone.
CommandCollection | A collection of commands.
CommandContext | The context of an executing command.
CommandList | Represents a read-only collection of Command objects.
CompositeCmd | Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.
ExpandHeaderRowCmd | Implements undo and redo of collapsing or expanding the header row of a table section.
ExpandItemCmd | Implements expanding/collapsing trees of items.
FoldContainerCmd | Undoable command that implements scrolling of table rows.
GroupAttachCmd | Implements an addition of a subordinated item to a group.
GroupDetachCmd | Implements removal of an item from a group.
ModifyItemCmd | Implements changes of item's size and position.
RedimTableCmd | Implements changes to the number of table's rows and coolumns.
RemoveFromContainerCmd | Undoable command that implements an addition of a node to a container.
RemoveGroupCmd | Implements destruction of groups.
RemoveItemCmd | Implements deletion of diagram items.
ScrollTableCmd | Implements scrolling of table's rows.


MindFusion.Diagramming.Commands.AddGroupCmd Class

AddGroupCmd Class
Remarks See Also

Implements creation of groups.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class AddGroupCmd : Command
Visual Basic

Public Class AddGroupCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to calls to the CreateGroup method. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.AddGroupCmd

See Also

AddGroupCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddGroupCmd Members

AddGroupCmd Members
Constructors Properties Methods

Implements creation of groups.

The following tables list the members exposed by the AddGroupCmd type.

Public Constructors

Name | Description
AddGroupCmd | Initializes a new instance of the AddGroupCmd class.

Public Properties

Name | Description
Group | Gets a reference to the new group.
Item | Gets a reference to the master item in the group.

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

AddGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddGroupCmd Constructor

AddGroupCmd Constructor

Initializes a new instance of the AddGroupCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public AddGroupCmd (
DiagramItem item,
Group group
)
Visual Basic

Public Sub AddGroupCmd ( _
item As DiagramItem, _
group As Group _
)

Parameters

item
group

See Also

AddGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddGroupCmd Methods

AddGroupCmd Methods

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

AddGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddGroupCmd.Execute Method

AddGroupCmd.Execute Method

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

AddGroupCmd Members
AddGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddGroupCmd.Redo Method

AddGroupCmd.Redo Method

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

AddGroupCmd Members
AddGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddGroupCmd.Undo Method

AddGroupCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

AddGroupCmd Members
AddGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddGroupCmd Properties

AddGroupCmd Properties

Public Properties

Name | Description
Group | Gets a reference to the new group.
Item | Gets a reference to the master item in the group.

See Also

AddGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddGroupCmd.Group Property

AddGroupCmd.Group Property

Gets a reference to the new group.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public Group Group { get; }
Visual Basic

Public ReadOnly Property Group As Group

Property Value

See Also

AddGroupCmd Members
AddGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddGroupCmd.Item Property

AddGroupCmd.Item Property

Gets a reference to the master item in the group.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; }
Visual Basic

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

AddGroupCmd Members
AddGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd Class

AddItemCmd Class
Remarks See Also

Implements creation of new diagram items.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class AddItemCmd : Command
Visual Basic

Public Class AddItemCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to users drawing new items or to programmatically calling the Add method of the diagram's Nodes or Links collections. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.AddItemCmd

See Also

AddItemCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd Members

AddItemCmd Members
Constructors Properties Methods

Implements creation of new diagram items.

The following tables list the members exposed by the AddItemCmd type.

Public Constructors

Name | Description
AddItemCmd | Initializes a new instance of the AddItemCmd class.

Public Properties

Name | Description
Item | Gets a reference to the newly added item.

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd Constructor

AddItemCmd Constructor

Initializes a new instance of the AddItemCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public AddItemCmd (
DiagramItem item
)
Visual Basic

Public Sub AddItemCmd ( _
item As DiagramItem _
)

Parameters

item

See Also

AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd Methods

AddItemCmd Methods

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd.Execute Method

AddItemCmd.Execute Method

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

AddItemCmd Members
AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd.Redo Method

AddItemCmd.Redo Method

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

AddItemCmd Members
AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd.Undo Method

AddItemCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

AddItemCmd Members
AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd Properties

AddItemCmd Properties

Public Properties

Name | Description
Item | Gets a reference to the newly added item.

See Also

AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd.Item Property

AddItemCmd.Item Property

Gets a reference to the newly added item.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; }
Visual Basic

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

AddItemCmd Members
AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd Class

AddToContainerCmd Class

Undoable command that implements an addition of a node to a container.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class AddToContainerCmd : Command
Visual Basic

Public Class AddToContainerCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.AddToContainerCmd

See Also

AddToContainerCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd Members

AddToContainerCmd Members
Constructors Properties Methods

Undoable command that implements an addition of a node to a container.

The following tables list the members exposed by the AddToContainerCmd type.

Protected Constructors

Name | Description
AddToContainerCmd | Intializes a new instance of the AddToContainerCmd class.

Public Properties

Name | Description
Container | Gets the container node associated with the command.
Nodes | Gets the item associated with the command.

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and must be treated as a derivative.
Redo | Redoes the command.
Undo | Undoes the command.

See Also

AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd Constructor

AddToContainerCmd Constructor

Intializes a new instance of the AddToContainerCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected AddToContainerCmd (
ContainerNode container,
DiagramNodeCollection nodes,
bool interactive
)
Visual Basic

Protected Sub AddToContainerCmd ( _
container As ContainerNode, _
nodes As DiagramNodeCollection, _
interactive As Boolean _
)

Parameters

container
nodes
interactive

See Also

AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd Methods

AddToContainerCmd Methods

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and must be treated as a derivative.
Redo | Redoes the command.
Undo | Undoes the command.

See Also

AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.Adopt Method

AddToContainerCmd.Adopt Method

Merges adjacent commands in the history queue if they are related.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual bool Adopt (
Command command
)
Visual Basic

Protected Overridable Function Adopt ( _
command As Command _
) As Boolean

Parameters

command
The Command that might be adopted by this command.

Return Value

true if the specified command has been adopted; otherwise, false.

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.Execute Method

AddToContainerCmd.Execute Method

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.IsContainerOf Method

AddToContainerCmd.IsContainerOf Method

Determines whether a command has been initiated by this command and must be treated as a derivative.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual bool IsContainerOf (
Command command
)
Visual Basic

Protected Overridable Function IsContainerOf ( _
command As Command _
) As Boolean

Parameters

command
The Command for which to determine whether it is a derivative.

Return Value

true if the specified command should be considered a derivative; otherwise, false.

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.Redo Method

AddToContainerCmd.Redo Method

Redoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.Undo Method

AddToContainerCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd Properties

AddToContainerCmd Properties

Public Properties

Name | Description
Container | Gets the container node associated with the command.
Nodes | Gets the item associated with the command.

See Also

AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.Container Property

AddToContainerCmd.Container Property

Gets the container node associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNode Container { get; }
Visual Basic

Public ReadOnly Property Container As ContainerNode

Property Value

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.Nodes Property

AddToContainerCmd.Nodes Property

Gets the item associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNodeCollection Nodes { get; }
Visual Basic

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd Class

ChangeItemCmd Class
Remarks See Also

Handles undo / redo of programmatic property changes.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class ChangeItemCmd : Command
Visual Basic

Public Class ChangeItemCmd
Inherits Command

Remarks

You would create an instance of this class in order to enable undo / redo of changes to item's properties. The constructor records the initial state of the item and the Execute method records the final state and adds the ChangeItemCmd object to the undo manager's history.

Example

C#

// Save item state
ChangeItemCmd propChange = new ChangeItemCmd(diagram.Nodes[0], "Change");

// Change properties
ShapeNode shape = (ShapeNode)diagram.Nodes[0];
shape.Text = "new text";
shape.Brush = new SolidBrush(Color.Blue);
shape.Shape = Shape.FromId("Ellipse");

// Add to history
propChange.Execute();
Visual Basic

' Save item state
Dim propChange As ChangeItemCmd = New ChangeItemCmd(Diagram.Nodes(0), "Change")

' Change properties
Dim shape As ShapeNode = CType(Diagram.Nodes(0), ShapeNode)
Shape.Text = "new text"
Shape.Brush = New SolidBrush(Color.Blue)
shape.Shape = MindFusion.Diagramming.Shape.FromId("Ellipse")

' Add to history
propChange.Execute()

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ChangeItemCmd

See Also

ChangeItemCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd Members

ChangeItemCmd Members
Constructors Properties Methods

Handles undo / redo of programmatic property changes.

The following tables list the members exposed by the ChangeItemCmd type.

Public Constructors

Name | Description
ChangeItemCmd | Initializes a new instance of the ChangeItemCmd class.

Public Properties

Name | Description
Item | Gets a reference to diagram item affected by this operation.

Protected Methods

Name | Description
Execute | Overloaded.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd Constructor

ChangeItemCmd Constructor

Initializes a new instance of the ChangeItemCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public ChangeItemCmd (
DiagramItem item,
string title
)
Visual Basic

Public Sub ChangeItemCmd ( _
item As DiagramItem, _
title As String _
)

Parameters

item
title

See Also

ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd Methods

ChangeItemCmd Methods

Protected Methods

Name | Description
Execute | Overloaded.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd.Execute Method

ChangeItemCmd.Execute Method

Overload List

Name | Description
ChangeItemCmd.Execute () | Excutes the command, adding it to the command history.
ChangeItemCmd.Execute (Boolean) | Carries out the command action.

See Also

ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd.Execute Method ()

ChangeItemCmd.Execute Method ()
See Also

Excutes the command, adding it to the command history.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public void Execute ()
Visual Basic

Public Sub Execute ()

Remarks

Subcommands are executed or redone in the same order in which they were added to the composite, and are undone in the opposite order.

See Also

Execute Method Overload List
ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd.Execute Method (Boolean)

ChangeItemCmd.Execute Method (Boolean)
See Also

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

Execute Method Overload List
ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd.Redo Method

ChangeItemCmd.Redo Method

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd.Undo Method

ChangeItemCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd Properties

ChangeItemCmd Properties

Public Properties

Name | Description
Item | Gets a reference to diagram item affected by this operation.

See Also

ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd.Item Property

ChangeItemCmd.Item Property

Gets a reference to diagram item affected by this operation.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; }
Visual Basic

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command Class

Command Class
Remarks See Also

Represent an action that can be carried out on a diagram, and later undone or redone.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract class Command
Visual Basic

Public MustInherit Class Command

Remarks

Command is an abctract class which defines the interface expected by the undo manager for undoing or redoing actions. All actions that can be carried out by MindFusion.Diagramming in response to users' input or method calls are implemented in Command subclasses. For a list of Command-derived classes see Actions and Commands.

The Execute, Undo or Redo methods are defined as abstract and must be implemented by derived classes. You must not call these methods directly - use the Undo or Redo methods of the UndoManager instead.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.AddGroupCmd
MindFusion.Diagramming.Commands.AddItemCmd
MindFusion.Diagramming.Commands.AddToContainerCmd
MindFusion.Diagramming.Commands.ChangeItemCmd
MindFusion.Diagramming.Commands.CompositeCmd
MindFusion.Diagramming.Commands.ExpandHeaderRowCmd
MindFusion.Diagramming.Commands.ExpandItemCmd
MindFusion.Diagramming.Commands.FoldContainerCmd
MindFusion.Diagramming.Commands.GroupAttachCmd
MindFusion.Diagramming.Commands.GroupDetachCmd
MindFusion.Diagramming.Commands.ModifyItemCmd
MindFusion.Diagramming.Commands.RedimTableCmd
MindFusion.Diagramming.Commands.RemoveFromContainerCmd
MindFusion.Diagramming.Commands.RemoveGroupCmd
MindFusion.Diagramming.Commands.RemoveItemCmd
MindFusion.Diagramming.Commands.ScrollTableCmd

See Also

Command Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command Members

Command Members
Constructors Properties Methods

Represent an action that can be carried out on a diagram, and later undone or redone.

The following tables list the members exposed by the Command type.

Protected Constructors

Name | Description
Command | Initializes a new instance of the Command class.

Public Properties

Name | Description
Title | Gets or sets the text associated with the action.

ProtectedProperties

Name | Description
Context | Gets the command's context.
SubCommands | Gets a collection of all command objects contained within the composite one.

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command.

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out an action, usually changing the diagram in some way.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command Constructor

Command Constructor

Initializes a new instance of the Command class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected Command (
string title
)
Visual Basic

Protected New ( _
title As String _
)

Parameters

title

See Also

Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command Methods

Command Methods

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command.

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out an action, usually changing the diagram in some way.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.AddSubCmd Method

Command.AddSubCmd Method

Adds an action to a composite command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public void AddSubCmd (
Command cmd
)
Visual Basic

Public Sub AddSubCmd ( _
cmd As Command _
)

Parameters

cmd
The Command to add.

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.Adopt Method

Command.Adopt Method

Merges adjacent commands in the history queue if they are related.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual bool Adopt (
Command command
)
Visual Basic

Protected Overridable Function Adopt ( _
command As Command _
) As Boolean

Parameters

command
The Command that might be adopted by this command.

Return Value

true if the specified command has been adopted; otherwise, false.

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.Execute Method

Command.Execute Method

Carries out an action, usually changing the diagram in some way.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected abstract void Execute (
bool undoEnabled
)
Visual Basic

Protected MustOverride Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled. If undo is disabled, the command won't be saved in undo history and will never be called to undo or redo itself. In such case you might choose to skip some housekeeping operations such as saving state variables for later undo/redo.

Remarks

Implement your action's logic here. You must not execute commands by calling this method - instead pass them to diagram's ExecuteCommand. ExecuteCommand calls Execute and if UndoEnabled is set to true, adds the command to the undo manager's history.

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.IsContainerOf Method

Command.IsContainerOf Method

Determines whether a command has been initiated by this command and should be treated as a derivative.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual bool IsContainerOf (
Command command
)
Visual Basic

Protected Overridable Function IsContainerOf ( _
command As Command _
) As Boolean

Parameters

command
The Command for which to determine whether it is a derivative.

Return Value

true if the specified command should be considered a derivative; otherwise, false.

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.Redo Method

Command.Redo Method

Repeats an action that has been undone.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

Remarks

The default implementation of Redo calls Execute.

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.Undo Method

Command.Undo Method

Undoes an action, restoring the diagram to the state it was in before carrying out the action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command Properties

Command Properties

Public Properties

Name | Description
Title | Gets or sets the text associated with the action.

ProtectedProperties

Name | Description
Context | Gets the command's context.
SubCommands | Gets a collection of all command objects contained within the composite one.

See Also

Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.Context Property

Command.Context Property

Gets the command's context.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected CommandContext Context { get; }
Visual Basic

Protected ReadOnly Property Context As CommandContext

Property Value

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.SubCommands Property

Command.SubCommands Property

Gets a collection of all command objects contained within the composite one.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected CommandCollection SubCommands { get; }
Visual Basic

Protected ReadOnly Property SubCommands As CommandCollection

Property Value

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.Title Property

Command.Title Property

Gets or sets the text associated with the action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public string Title { get; set; }
Visual Basic

Public Property Title As String

Property Value

Remarks

This text can be used to indicate to users what exactly will be undone or redone.

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection Class

CommandCollection Class

A collection of commands.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class CommandCollection : CollectionBase
Visual Basic

Public Class CommandCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.Commands.CommandCollection

See Also

CommandCollection Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection Members

CommandCollection Members
Constructors Properties Methods

A collection of commands.

The following tables list the members exposed by the CommandCollection type.

Public Constructors

Name | Description
CommandCollection | Overloaded.

Public Properties

Name | Description
Item | Gets or sets the command at the specified index.

Public Methods

Name | Description
Add | Adds the specified command to the collection.
Clear | Removes all commands from the collection.
Contains | Determines whether the specified command is contained in the collection.
GetAt | Returns the command at the specified index.
Remove | Removes the specified command from the collection.
RemoveRange | Removes the specified number of commands from the collection starting at the specified index.

See Also

CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection Constructor

CommandCollection Constructor

Overload List

Name | Description
CommandCollection () | Initializes a new instance of the CommandCollection class with the default initial capacity.
CommandCollection (Int32) | Initializes a new instance of the CommandCollection class with the specified initial capacity.

See Also

CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection Constructor ()

CommandCollection Constructor ()
See Also

Initializes a new instance of the CommandCollection class with the default initial capacity.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public CommandCollection ()
Visual Basic

Public Sub New ()

See Also

CommandCollection Constructor Overload List
CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection Constructor (Int32)

CommandCollection Constructor (Int32)
See Also

Initializes a new instance of the CommandCollection class with the specified initial capacity.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public CommandCollection (
int capacity
)
Visual Basic

Public New ( _
capacity As Integer _
)

Parameters

capacity

See Also

CommandCollection Constructor Overload List
CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection Methods

CommandCollection Methods

Public Methods

Name | Description
Add | Adds the specified command to the collection.
Clear | Removes all commands from the collection.
Contains | Determines whether the specified command is contained in the collection.
GetAt | Returns the command at the specified index.
Remove | Removes the specified command from the collection.
RemoveRange | Removes the specified number of commands from the collection starting at the specified index.

See Also

CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection.Add Method

CommandCollection.Add Method

Adds the specified command to the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public void Add (
Command cmd
)
Visual Basic

Public Sub Add ( _
cmd As Command _
)

Parameters

cmd
The Command that might be added by this command.

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection.Clear Method

CommandCollection.Clear Method

Removes all commands from the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection.Contains Method

CommandCollection.Contains Method

Determines whether the specified command is contained in the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Contains (
Command cmd
)
Visual Basic

Public Function Contains ( _
cmd As Command _
) As Boolean

Parameters

cmd

Return Value

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection.GetAt Method

CommandCollection.GetAt Method

Returns the command at the specified index.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public Command GetAt (
int i
)
Visual Basic

Public Function GetAt ( _
i As Integer _
) As Command

Parameters

i

Return Value

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection.Remove Method

CommandCollection.Remove Method

Removes the specified command from the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public void Remove (
Command cmd
)
Visual Basic

Public Sub Remove ( _
cmd As Command _
)

Parameters

cmd
The Command that might be removed by this command.

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection.RemoveRange Method

CommandCollection.RemoveRange Method

Removes the specified number of commands from the collection starting at the specified index.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public void RemoveRange (
int index,
int count
)
Visual Basic

Public Sub RemoveRange ( _
index As Integer, _
count As Integer _
)

Parameters

index
count

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection Properties

CommandCollection Properties

Public Properties

Name | Description
Item | Gets or sets the command at the specified index.

See Also

CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection.Item Property

CommandCollection.Item Property

Gets or sets the command at the specified index.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public Command Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Command

Parameters

index

Property Value

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandContext Class

CommandContext Class

The context of an executing command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class CommandContext
Visual Basic

Public Class CommandContext

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.CommandContext

See Also

CommandContext Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandContext Members

CommandContext Members
Properties

The context of an executing command.

The following tables list the members exposed by the CommandContext type.

Public Properties

Name | Description
Document | Gets the document this command will operate on.

See Also

CommandContext Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandContext Properties

CommandContext Properties

Public Properties

Name | Description
Document | Gets the document this command will operate on.

See Also

CommandContext Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandContext.Document Property

CommandContext.Document Property

Gets the document this command will operate on.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public Diagram Document { get; }
Visual Basic

Public ReadOnly Property Document As Diagram

Property Value

See Also

CommandContext Members
CommandContext Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList Class

CommandList Class

Represents a read-only collection of Command objects.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class CommandList : ICollection, IEnumerable
Visual Basic

Public Class CommandList
Implements ICollection, IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.CommandList

See Also

CommandList Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList Members

CommandList Members
Constructors Properties Methods

Represents a read-only collection of Command objects.

The following tables list the members exposed by the CommandList type.

Public Constructors

Name | Description
CommandList | Initializes a new instance of the CommandList class.

Public Properties

Name | Description
Count | Gets the number of commands contained within the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
Item | Gets the command at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

Name | Description
Contains | Determines whether the specified command is contained within the collection.
CopyTo | Copies a range of commands from the current collection to the specified array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator for the collection.
IndexOf | Returns the zero-based index of the specfied command within the collection.

See Also

CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList Constructor

CommandList Constructor

Initializes a new instance of the CommandList class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public CommandList (
CommandCollection innerCollection
)
Visual Basic

Public Sub CommandList ( _
innerCollection As CommandCollection _
)

Parameters

innerCollection

See Also

CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList Methods

CommandList Methods

Public Methods

Name | Description
Contains | Determines whether the specified command is contained within the collection.
CopyTo | Copies a range of commands from the current collection to the specified array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator for the collection.
IndexOf | Returns the zero-based index of the specfied command within the collection.

See Also

CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.Contains Method

CommandList.Contains Method

Determines whether the specified command is contained within the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Contains (
Command value
)
Visual Basic

Public Function Contains ( _
value As Command _
) As Boolean

Parameters

value
The Command that might be contained within the collection.

Return Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.CopyTo Method

CommandList.CopyTo Method

Copies a range of commands from the current collection to the specified array, starting at the specified index of the target array.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual void CopyTo (
Array array,
int index
)
Visual Basic

Public Overridable Sub CopyTo ( _
array As Array, _
index As Integer _
)

Parameters

array
index

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.GetEnumerator Method

CommandList.GetEnumerator Method

Returns an enumerator for the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual IEnumerator GetEnumerator ()
Visual Basic

Public Overridable Function GetEnumerator () As IEnumerator

Return Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.IndexOf Method

CommandList.IndexOf Method

Returns the zero-based index of the specfied command within the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public int IndexOf (
Command value
)
Visual Basic

Public Function IndexOf ( _
value As Command _
) As Integer

Parameters

value

Return Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList Properties

CommandList Properties

Public Properties

Name | Description
Count | Gets the number of commands contained within the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
Item | Gets the command at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.Count Property

CommandList.Count Property

Gets the number of commands contained within the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual int Count { get; }
Visual Basic

Public Overridable ReadOnly Property Count As Integer

Property Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.IsSynchronized Property

CommandList.IsSynchronized Property

Gets a value indicating whether the access to the collection is synchronized.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool IsSynchronized { get; }
Visual Basic

Public Overridable ReadOnly Property IsSynchronized As Boolean

Property Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.Item Property

CommandList.Item Property

Gets the command at the specified index.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public Command Item [
int index
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
index As Integer _
) As Command

Parameters

index

Property Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.SyncRoot Property

CommandList.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Object SyncRoot { get; }
Visual Basic

Public Overridable ReadOnly Property SyncRoot As Object

Property Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Class

CompositeCmd Class
Remarks See Also

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class CompositeCmd : Command
Visual Basic

Public Class CompositeCmd
Inherits Command

Remarks

To add a subaction to the composite call the AddSubCmd method. The Execute method executes all subactions and adds the composite to undo manager's history.

Example

C#

if (diagram.Selection.Nodes.Count == 0)
return;

// Make all changes seem like a single operation by
// putting them in composite Command
CompositeCmd composite = new CompositeCmd(diagram, "Change selection");

foreach (DiagramNode node in diagram.Selection.Nodes)
{
ShapeNode shape = node as ShapeNode;
if (shape == null)
continue;

// Save item state
ChangeItemCmd propChange = new ChangeItemCmd(shape, "Change");

// Change properties
shape.Text = "new text";
shape.Brush = new SolidBrush(Color.Blue);

// Add to the composite
composite.AddSubCmd(propChange);
}

// Store final state of all contained commands
composite.Execute();
Visual Basic

If diagram.Selection.Nodes.Count = 0 Then
Return
End If

' Make all changes seem like a single operation by
' putting them in composite Command
Dim composite As CompositeCmd = New CompositeCmd(diagram, "Change selection")

Dim node As DiagramNode
For Each node In diagram.Selection.Nodes

Dim shape As ShapeNode = CType(node, ShapeNode)

If Not shape Is Nothing Then

' Save item state
Dim propChange As ChangeItemCmd = New ChangeItemCmd(shape, "Change")

' Change properties
shape.Text = "new text"
shape.Brush = New SolidBrush(Color.Blue)

' Add to the composite
composite.AddSubCmd(propChange)

End If

Next

' Store final state of all contained commands
composite.Execute()

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.CompositeCmd

See Also

CompositeCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Members

CompositeCmd Members
Constructors Properties Methods

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

The following tables list the members exposed by the CompositeCmd type.

Public Constructors

Name | Description
CompositeCmd | Overloaded.

Public Properties

Name | Description
SubCommands | Gets a collection of all command objects contained within the composite one.

Protected Methods

Name | Description
Execute | Overloaded.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Constructor

CompositeCmd Constructor

Overload List

Name | Description
CompositeCmd (Diagram, String) | Initializes a new instance of the CompositeCmd class.
CompositeCmd (Diagram, String, Boolean) | Initializes a new instance of the CompositeCmd class.

See Also

CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Constructor (Diagram, String)

CompositeCmd Constructor (Diagram, String)
See Also

Initializes a new instance of the CompositeCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public CompositeCmd (
Diagram diagram,
string title
)
Visual Basic

Public Sub CompositeCmd ( _
diagram As Diagram, _
title As String _
)

Parameters

diagram
title

See Also

CompositeCmd Constructor Overload List
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Constructor (Diagram, String, Boolean)

CompositeCmd Constructor (Diagram, String, Boolean)
See Also

Initializes a new instance of the CompositeCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public CompositeCmd (
Diagram diagram,
string title,
bool saveZOrder
)
Visual Basic

Public Sub CompositeCmd ( _
diagram As Diagram, _
title As String, _
saveZOrder As Boolean _
)

Parameters

diagram
title
saveZOrder

See Also

CompositeCmd Constructor Overload List
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Methods

CompositeCmd Methods

Protected Methods

Name | Description
Execute | Overloaded.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd.Execute Method

CompositeCmd.Execute Method

Overload List

Name | Description
CompositeCmd.Execute () | Executes the command, adding it to the command history.
CompositeCmd.Execute (Boolean) | Carries out the command action.

See Also

CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd.Execute Method ()

CompositeCmd.Execute Method ()
See Also

Executes the command, adding it to the command history.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public void Execute ()
Visual Basic

Public Sub Execute ()

Remarks

Subcommands are executed or redone in the same order in which they were added to the composite, and are undone in the opposite order.

See Also

Execute Method Overload List
CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd.Execute Method (Boolean)

CompositeCmd.Execute Method (Boolean)
See Also

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

Execute Method Overload List
CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd.Redo Method

CompositeCmd.Redo Method

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd.Undo Method

CompositeCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Properties

CompositeCmd Properties

Public Properties

Name | Description
SubCommands | Gets a collection of all command objects contained within the composite one.

See Also

CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd.SubCommands Property

CompositeCmd.SubCommands Property

Gets a collection of all command objects contained within the composite one.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public CommandCollection SubCommands { get; }
Visual Basic

Public ReadOnly Property SubCommands As CommandCollection

Property Value

See Also

CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd Class

ExpandHeaderRowCmd Class
Remarks See Also

Implements undo and redo of collapsing or expanding the header row of a table section.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class ExpandHeaderRowCmd : Command
Visual Basic

Public Class ExpandHeaderRowCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to expanding or collapsing Header rows, either interactively or programmatically. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ExpandHeaderRowCmd

See Also

ExpandHeaderRowCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd Members

ExpandHeaderRowCmd Members
Constructors Properties Methods

Implements undo and redo of collapsing or expanding the header row of a table section.

The following tables list the members exposed by the ExpandHeaderRowCmd type.

Public Constructors

Name | Description
ExpandHeaderRowCmd | Intializes a new instance of the ExpandHeaderRowCmd class.

Public Properties

Name | Description
RowIndex | Gets the index of the header row whose section is expanded or collapsed.
TableNode | Gets a reference to table affected by this operation.

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd Constructor

ExpandHeaderRowCmd Constructor

Intializes a new instance of the ExpandHeaderRowCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public ExpandHeaderRowCmd (
TableNode tableNode,
int rowIndex
)
Visual Basic

Public Sub ExpandHeaderRowCmd ( _
tableNode As TableNode, _
rowIndex As Integer _
)

Parameters

tableNode
rowIndex

See Also

ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd Methods

ExpandHeaderRowCmd Methods

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd.Execute Method

ExpandHeaderRowCmd.Execute Method

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd.Redo Method

ExpandHeaderRowCmd.Redo Method

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd.Undo Method

ExpandHeaderRowCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd Properties

ExpandHeaderRowCmd Properties

Public Properties

Name | Description
RowIndex | Gets the index of the header row whose section is expanded or collapsed.
TableNode | Gets a reference to table affected by this operation.

See Also

ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd.RowIndex Property

ExpandHeaderRowCmd.RowIndex Property

Gets the index of the header row whose section is expanded or collapsed.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public int RowIndex { get; }
Visual Basic

Public ReadOnly Property RowIndex As Integer

Property Value

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd.TableNode Property

ExpandHeaderRowCmd.TableNode Property

Gets a reference to table affected by this operation.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode TableNode { get; }
Visual Basic

Public ReadOnly Property TableNode As TableNode

Property Value

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd Class

ExpandItemCmd Class
Remarks See Also

Implements expanding/collapsing trees of items.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class ExpandItemCmd : Command
Visual Basic

Public Class ExpandItemCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to expanding or collapsing trees of items, either interactively or programmatically. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ExpandItemCmd

See Also

ExpandItemCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd Members

ExpandItemCmd Members
Constructors Properties Methods

Implements expanding/collapsing trees of items.

The following tables list the members exposed by the ExpandItemCmd type.

Public Constructors

Name | Description
ExpandItemCmd | Initializes a new instance of the ExpandItemCmd class.

Public Properties

Name | Description
Item | Gets a reference to diagram item affected by this operation.

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd Constructor

ExpandItemCmd Constructor

Initializes a new instance of the ExpandItemCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public ExpandItemCmd (
DiagramItem item
)
Visual Basic

Public Sub ExpandItemCmd ( _
item As DiagramItem _
)

Parameters

item

See Also

ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd Methods

ExpandItemCmd Methods

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd.Execute Method

ExpandItemCmd.Execute Method

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

ExpandItemCmd Members
ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd.Redo Method

ExpandItemCmd.Redo Method

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

ExpandItemCmd Members
ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd.Undo Method

ExpandItemCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

ExpandItemCmd Members
ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd Properties

ExpandItemCmd Properties

Public Properties

Name | Description
Item | Gets a reference to diagram item affected by this operation.

See Also

ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd.Item Property

ExpandItemCmd.Item Property

Gets a reference to diagram item affected by this operation.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; }
Visual Basic

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

ExpandItemCmd Members
ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd Class

FoldContainerCmd Class

Undoable command that implements scrolling of table rows.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class FoldContainerCmd : Command
Visual Basic

Public Class FoldContainerCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.FoldContainerCmd

See Also

FoldContainerCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd Members

FoldContainerCmd Members
Constructors Properties Methods

Undoable command that implements scrolling of table rows.

The following tables list the members exposed by the FoldContainerCmd type.

Public Constructors

Name | Description
FoldContainerCmd | Initializes a new instance of the ScrollTableCmd class.

Public Properties

Name | Description
Container | Gets the table associated with the command.

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd Constructor

FoldContainerCmd Constructor

Initializes a new instance of the ScrollTableCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public FoldContainerCmd (
ContainerNode container
)
Visual Basic

Public Sub FoldContainerCmd ( _
container As ContainerNode _
)

Parameters

container

See Also

FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd Methods

FoldContainerCmd Methods

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd.Execute Method

FoldContainerCmd.Execute Method

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

FoldContainerCmd Members
FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd.Redo Method

FoldContainerCmd.Redo Method

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

FoldContainerCmd Members
FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd.Undo Method

FoldContainerCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

FoldContainerCmd Members
FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd Properties

FoldContainerCmd Properties

Public Properties

Name | Description
Container | Gets the table associated with the command.

See Also

FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd.Container Property

FoldContainerCmd.Container Property

Gets the table associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNode Container { get; }
Visual Basic

Public ReadOnly Property Container As ContainerNode

Property Value

See Also

FoldContainerCmd Members
FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupAttachCmd Class

GroupAttachCmd Class
Remarks See Also

Implements an addition of a subordinated item to a group.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class GroupAttachCmd : Command
Visual Basic

Public Class GroupAttachCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to calls to any of the Attach methods of the Group class. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.GroupAttachCmd

See Also

GroupAttachCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupAttachCmd Members

GroupAttachCmd Members
Constructors Properties Methods

Implements an addition of a subordinated item to a group.

The following tables list the members exposed by the GroupAttachCmd type.

Protected Constructors

Name | Description
GroupAttachCmd | Intializes a new instance of the GroupAttachCmd class.

Public Properties

Name | Description
Group | Gets a reference to the group the item was added to.
Item | Gets a reference to the subordinated item added to the group by this command.

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

GroupAttachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupAttachCmd Constructor

GroupAttachCmd Constructor

Intializes a new instance of the GroupAttachCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected GroupAttachCmd (
Group group,
Group.Attachment attachment
)
Visual Basic

Protected Sub GroupAttachCmd ( _
group As Group, _
attachment As Group.Attachment _
)

Parameters

group
attachment

See Also

GroupAttachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupAttachCmd Methods

GroupAttachCmd Methods

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

GroupAttachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupAttachCmd.Execute Method

GroupAttachCmd.Execute Method

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

GroupAttachCmd Members
GroupAttachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupAttachCmd.Redo Method

GroupAttachCmd.Redo Method

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

GroupAttachCmd Members
GroupAttachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupAttachCmd.Undo Method

GroupAttachCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

GroupAttachCmd Members
GroupAttachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupAttachCmd Properties

GroupAttachCmd Properties

Public Properties

Name | Description
Group | Gets a reference to the group the item was added to.
Item | Gets a reference to the subordinated item added to the group by this command.

See Also

GroupAttachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupAttachCmd.Group Property

GroupAttachCmd.Group Property

Gets a reference to the group the item was added to.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public Group Group { get; }
Visual Basic

Public ReadOnly Property Group As Group

Property Value

See Also

GroupAttachCmd Members
GroupAttachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupAttachCmd.Item Property

GroupAttachCmd.Item Property

Gets a reference to the subordinated item added to the group by this command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; }
Visual Basic

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

GroupAttachCmd Members
GroupAttachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupDetachCmd Class

GroupDetachCmd Class
Remarks See Also

Implements removal of an item from a group.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class GroupDetachCmd : Command
Visual Basic

Public Class GroupDetachCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to calls to the Detach methods of the Group class. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.GroupDetachCmd

See Also

GroupDetachCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupDetachCmd Members

GroupDetachCmd Members
Constructors Properties Methods

Implements removal of an item from a group.

The following tables list the members exposed by the GroupDetachCmd type.

Protected Constructors

Name | Description
GroupDetachCmd | Initializes a new instance of the GroupDetachCmd class.

Public Properties

Name | Description
Group | Gets the group associated with the command.
Item | Gets the item associated with the command.

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

GroupDetachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupDetachCmd Constructor

GroupDetachCmd Constructor

Initializes a new instance of the GroupDetachCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected GroupDetachCmd (
Group group,
Group.Attachment attachment
)
Visual Basic

Protected Sub GroupDetachCmd ( _
group As Group, _
attachment As Group.Attachment _
)

Parameters

group
attachment

See Also

GroupDetachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupDetachCmd Methods

GroupDetachCmd Methods

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

GroupDetachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupDetachCmd.Execute Method

GroupDetachCmd.Execute Method

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

GroupDetachCmd Members
GroupDetachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupDetachCmd.Redo Method

GroupDetachCmd.Redo Method

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

GroupDetachCmd Members
GroupDetachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupDetachCmd.Undo Method

GroupDetachCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

GroupDetachCmd Members
GroupDetachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupDetachCmd Properties

GroupDetachCmd Properties

Public Properties

Name | Description
Group | Gets the group associated with the command.
Item | Gets the item associated with the command.

See Also

GroupDetachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupDetachCmd.Group Property

GroupDetachCmd.Group Property

Gets the group associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public Group Group { get; }
Visual Basic

Public ReadOnly Property Group As Group

Property Value

See Also

GroupDetachCmd Members
GroupDetachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.GroupDetachCmd.Item Property

GroupDetachCmd.Item Property

Gets the item associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; }
Visual Basic

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

GroupDetachCmd Members
GroupDetachCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd Class

ModifyItemCmd Class
Remarks See Also

Implements changes of item's size and position.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class ModifyItemCmd : Command
Visual Basic

Public Class ModifyItemCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to moving or resizing items, either interactively or programmatically. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ModifyItemCmd

See Also

ModifyItemCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd Members

ModifyItemCmd Members
Constructors Properties Methods

Implements changes of item's size and position.

The following tables list the members exposed by the ModifyItemCmd type.

Public Constructors

Name | Description
ModifyItemCmd | Initializes a new instance of the ModifyItemCmd class.

Public Properties

Name | Description
Item | Gets a reference to the modified item.

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd Constructor

ModifyItemCmd Constructor

Initializes a new instance of the ModifyItemCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public ModifyItemCmd (
DiagramItem item
)
Visual Basic

Public Sub ModifyItemCmd ( _
item As DiagramItem _
)

Parameters

item

See Also

ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd Methods

ModifyItemCmd Methods

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd.Adopt Method

ModifyItemCmd.Adopt Method

Merges adjacent commands in the history queue if they are related.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual bool Adopt (
Command command
)
Visual Basic

Protected Overridable Function Adopt ( _
command As Command _
) As Boolean

Parameters

command
The Command that might be adopted by this command.

Return Value

true if the specified command has been adopted; otherwise, false.

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd.Execute Method

ModifyItemCmd.Execute Method

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd.Redo Method

ModifyItemCmd.Redo Method

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd.Undo Method

ModifyItemCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd Properties

ModifyItemCmd Properties

Public Properties

Name | Description
Item | Gets a reference to the modified item.

See Also

ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd.Item Property

ModifyItemCmd.Item Property

Gets a reference to the modified item.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; }
Visual Basic

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd Class

RedimTableCmd Class
Remarks See Also

Implements changes to the number of table's rows and coolumns.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class RedimTableCmd : Command
Visual Basic

Public Class RedimTableCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to method calls and property changes that alter the number of table's rows or columns. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.RedimTableCmd

See Also

RedimTableCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd Members

RedimTableCmd Members
Constructors Properties Methods

Implements changes to the number of table's rows and coolumns.

The following tables list the members exposed by the RedimTableCmd type.

Public Constructors

Name | Description
RedimTableCmd | Initializes a new instance of the RedimTableCmd class.

Public Properties

Name | Description
TableNode | Gets a reference to the modified table.

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command.
Undo | Undoes the command.

See Also

RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd Constructor

RedimTableCmd Constructor

Initializes a new instance of the RedimTableCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public RedimTableCmd (
TableNode tableNode,
string title
)
Visual Basic

Public Sub RedimTableCmd ( _
tableNode As TableNode, _
title As String _
)

Parameters

tableNode
title

See Also

RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd Methods

RedimTableCmd Methods

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command.
Undo | Undoes the command.

See Also

RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd.Execute Method

RedimTableCmd.Execute Method

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

RedimTableCmd Members
RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd.Redo Method

RedimTableCmd.Redo Method

Redoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

RedimTableCmd Members
RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd.Undo Method

RedimTableCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

RedimTableCmd Members
RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd Properties

RedimTableCmd Properties

Public Properties

Name | Description
TableNode | Gets a reference to the modified table.

See Also

RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd.TableNode Property

RedimTableCmd.TableNode Property

Gets a reference to the modified table.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode TableNode { get; }
Visual Basic

Public ReadOnly Property TableNode As TableNode

Property Value

See Also

RedimTableCmd Members
RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd Class

RemoveFromContainerCmd Class

Undoable command that implements an addition of a node to a container.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class RemoveFromContainerCmd : Command
Visual Basic

Public Class RemoveFromContainerCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.RemoveFromContainerCmd

See Also

RemoveFromContainerCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd Members

RemoveFromContainerCmd Members
Constructors Properties Methods

Undoable command that implements an addition of a node to a container.

The following tables list the members exposed by the RemoveFromContainerCmd type.

Protected Constructors

Name | Description
RemoveFromContainerCmd | Intializes a new instance of the AddToContainerCmd class.

Public Properties

Name | Description
Container | Gets the group associated with the command.
Node | Gets the item associated with the command.

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
Redo | Redoes the command.
Undo | Undoes the command.

See Also

RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd Constructor

RemoveFromContainerCmd Constructor

Intializes a new instance of the AddToContainerCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected RemoveFromContainerCmd (
ContainerNode container,
DiagramNode node,
bool interactive
)
Visual Basic

Protected Sub RemoveFromContainerCmd ( _
container As ContainerNode, _
node As DiagramNode, _
interactive As Boolean _
)

Parameters

container
node
interactive

See Also

RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd Methods

RemoveFromContainerCmd Methods

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
Redo | Redoes the command.
Undo | Undoes the command.

See Also

RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd.Adopt Method

RemoveFromContainerCmd.Adopt Method

Merges adjacent commands in the history queue if they are related.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual bool Adopt (
Command command
)
Visual Basic

Protected Overridable Function Adopt ( _
command As Command _
) As Boolean

Parameters

command
The Command that might be adopted by this command.

Return Value

true if the specified command has been adopted; otherwise, false.

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd.Execute Method

RemoveFromContainerCmd.Execute Method

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd.Redo Method

RemoveFromContainerCmd.Redo Method

Redoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd.Undo Method

RemoveFromContainerCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd Properties

RemoveFromContainerCmd Properties

Public Properties

Name | Description
Container | Gets the group associated with the command.
Node | Gets the item associated with the command.

See Also

RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd.Container Property

RemoveFromContainerCmd.Container Property

Gets the group associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public ContainerNode Container { get; }
Visual Basic

Public ReadOnly Property Container As ContainerNode

Property Value

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd.Node Property

RemoveFromContainerCmd.Node Property

Gets the item associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Node { get; }
Visual Basic

Public ReadOnly Property Node As DiagramNode

Property Value

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveGroupCmd Class

RemoveGroupCmd Class
Remarks See Also

Implements destruction of groups.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class RemoveGroupCmd : Command
Visual Basic

Public Class RemoveGroupCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to calls to the DestroyGroup method. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.RemoveGroupCmd

See Also

RemoveGroupCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveGroupCmd Members

RemoveGroupCmd Members
Constructors Properties Methods

Implements destruction of groups.

The following tables list the members exposed by the RemoveGroupCmd type.

Public Constructors

Name | Description
RemoveGroupCmd | Initializes a new instance of the RemoveGroupCmd class.

Public Properties

Name | Description
Group | Gets a reference to the removed Group object.
Item | Gets a reference to the master item of the group.

Protected Methods

Name | Description
Execute | Overloaded.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

RemoveGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveGroupCmd Constructor

RemoveGroupCmd Constructor

Initializes a new instance of the RemoveGroupCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public RemoveGroupCmd (
DiagramItem item,
Group group
)
Visual Basic

Public Sub RemoveGroupCmd ( _
item As DiagramItem, _
group As Group _
)

Parameters

item
group

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to calls to the DestroyGroup method. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

See Also

RemoveGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveGroupCmd Methods

RemoveGroupCmd Methods

Protected Methods

Name | Description
Execute | Overloaded.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

RemoveGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveGroupCmd.Execute Method

RemoveGroupCmd.Execute Method

Overload List

Name | Description
RemoveGroupCmd.Execute () | Executes the command.
RemoveGroupCmd.Execute (Boolean) | Carries out the command action.

See Also

RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveGroupCmd.Execute Method ()

RemoveGroupCmd.Execute Method ()
See Also

Executes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public void Execute ()
Visual Basic

Public Sub Execute ()

See Also

Execute Method Overload List
RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveGroupCmd.Execute Method (Boolean)

RemoveGroupCmd.Execute Method (Boolean)
See Also

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

Execute Method Overload List
RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveGroupCmd.Redo Method

RemoveGroupCmd.Redo Method

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveGroupCmd.Undo Method

RemoveGroupCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveGroupCmd Properties

RemoveGroupCmd Properties

Public Properties

Name | Description
Group | Gets a reference to the removed Group object.
Item | Gets a reference to the master item of the group.

See Also

RemoveGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveGroupCmd.Group Property

RemoveGroupCmd.Group Property

Gets a reference to the removed Group object.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public Group Group { get; }
Visual Basic

Public ReadOnly Property Group As Group

Property Value

See Also

RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveGroupCmd.Item Property

RemoveGroupCmd.Item Property

Gets a reference to the master item of the group.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; }
Visual Basic

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd Class

RemoveItemCmd Class
Remarks See Also

Implements deletion of diagram items.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class RemoveItemCmd : Command
Visual Basic

Public Class RemoveItemCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to deleting items interactively or programmatically. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.RemoveItemCmd

See Also

RemoveItemCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd Members

RemoveItemCmd Members
Constructors Properties Methods

Implements deletion of diagram items.

The following tables list the members exposed by the RemoveItemCmd type.

Public Constructors

Name | Description
RemoveItemCmd | Initializes a new instance of the RemoveItemCmd class.

Public Properties

Name | Description
Item | Gets the item associated with the command.

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd Constructor

RemoveItemCmd Constructor

Initializes a new instance of the RemoveItemCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public RemoveItemCmd (
DiagramItem item
)
Visual Basic

Public Sub RemoveItemCmd ( _
item As DiagramItem _
)

Parameters

item

See Also

RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd Methods

RemoveItemCmd Methods

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd.Execute Method

RemoveItemCmd.Execute Method

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

RemoveItemCmd Members
RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd.Redo Method

RemoveItemCmd.Redo Method

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

RemoveItemCmd Members
RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd.Undo Method

RemoveItemCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

RemoveItemCmd Members
RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd Properties

RemoveItemCmd Properties

Public Properties

Name | Description
Item | Gets the item associated with the command.

See Also

RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd.Item Property

RemoveItemCmd.Item Property

Gets the item associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramItem Item { get; }
Visual Basic

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

RemoveItemCmd Members
RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd Class

ScrollTableCmd Class
Remarks See Also

Implements scrolling of table's rows.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public class ScrollTableCmd : Command
Visual Basic

Public Class ScrollTableCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to scrolling table's rows, either interactively or programmatically. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ScrollTableCmd

See Also

ScrollTableCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd Members

ScrollTableCmd Members
Constructors Properties Methods

Implements scrolling of table's rows.

The following tables list the members exposed by the ScrollTableCmd type.

Public Constructors

Name | Description
ScrollTableCmd | Initializes a new instance of the ScrollTableCmd class.

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd Constructor

ScrollTableCmd Constructor

Initializes a new instance of the ScrollTableCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public ScrollTableCmd (
TableNode tableNode
)
Visual Basic

Public Sub ScrollTableCmd ( _
tableNode As TableNode _
)

Parameters

tableNode

See Also

ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd Methods

ScrollTableCmd Methods

Protected Methods

Name | Description
Execute | Carries out the command action.
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd.Execute Method

ScrollTableCmd.Execute Method

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Execute (
bool undoEnabled
)
Visual Basic

Protected Overridable Sub Execute ( _
undoEnabled As Boolean _
)

Parameters

undoEnabled
Specifies whether undo/redo is enabled.

See Also

ScrollTableCmd Members
ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd.Redo Method

ScrollTableCmd.Redo Method

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Redo ()
Visual Basic

Protected Overridable Sub Redo ()

See Also

ScrollTableCmd Members
ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd.Undo Method

ScrollTableCmd.Undo Method

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

protected virtual void Undo ()
Visual Basic

Protected Overridable Sub Undo ()

See Also

ScrollTableCmd Members
ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd Properties

ScrollTableCmd Properties

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.

See Also

ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd.TableNode Property

ScrollTableCmd.TableNode Property

Gets a reference to table affected by this operation.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C#

public TableNode TableNode { get; }
Visual Basic

Public ReadOnly Property TableNode As TableNode

Property Value

See Also

ScrollTableCmd Members
ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Export Namespace
Classes Enumerations

Classes

Class | Description
DxfExporter | Exports MindFusion.Diagramming diagrams to AutoDesk Drawing Exchange Format (DXF) files.
PdfExporter | Exports MindFusion.Diagramming diagrams to Adobe Portable Document Format (PDF) files.
SvgExporter | Creates SVG (Scalable Vector Graphics) files from MindFusion.Diagramming diagrams.
VisioExporter | Exports MindFusion.Diagramming diagrams to Visio 2003 XML Drawing files (*.vdx).

Enumerations

Enumeration | Description
AutoScale | Specifies the auto-scale mode when exporting to a PDF document.


MindFusion.Diagramming.Export.AutoScale Enumeration

AutoScale Enumeration

Specifies the auto-scale mode when exporting to a PDF document.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C#

public enum AutoScale
Visual Basic

Public Enumeration AutoScale

Members

Member name | Description
FitToPage | Scales the chart (aspect ratio is preserved) to fit the page bounds if the document is too large.
FitToPageNoUpScale | Scales down the chart (aspect ratio is preserved) to fit the page bounds if the document is too large. Otherwise chart's size is left untouched.
FitToWidth | Scales down the chart (aspect ratio is preserved) to make sure that the width of the chart is less than the width of the PDF page.
None | No automatic scaling.

See Also

MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter Class

DxfExporter Class
Remarks See Also

Exports MindFusion.Diagramming diagrams to AutoDesk Drawing Exchange Format (DXF) files.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Dxf

Syntax

C#

public class DxfExporter
Visual Basic

Public Class DxfExporter

Remarks

In order to use this component, add a reference to the MindFusion.Diagramming.Export.Dxf.dll to your project.

AutoCAD DXF (Drawing Exchange Format) is a file format developed by Autodesk to enable interoperability between AutoCAD and other programs. Now virtually every CAD application and most graphics programs can import DXF files.

To create a DXF file from a MindFusion.Diagramming diagram, create a DxfExporter instance and call its Export method, specifying a Diagram object and a file path as arguments.

Raster images can be used in DXF by referencing external image files. To avoid creating extraneous files, DxfExporter does not export images by default. To export the images displayed in diagram elements, enable the ExportImages property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Export.DxfExporter

See Also

DxfExporter Members
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter Members

DxfExporter Members
Constructors Properties Methods

Exports MindFusion.Diagramming diagrams to AutoDesk Drawing Exchange Format (DXF) files.

The following tables list the members exposed by the DxfExporter type.

Public Constructors

Name | Description
DxfExporter | Initializes a new instance of the DxfExporter class.

Public Properties

Name | Description
ExportImages | Gets or sets a value indicating whether the images that are displayed inside diagram nodes should be exported.
ExportTextAsMultiline | Gets or sets a value indicating whether item labels should be exported to DXF MTEXT entities.

Public Methods

Name | Description
Export | Creates a DXF file representing the specified MindFusion.Diagramming diagram.

See Also

DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter Constructor

DxfExporter Constructor

Initializes a new instance of the DxfExporter class.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Dxf

Syntax

C#

public DxfExporter ()
Visual Basic

Public Sub New ()

See Also

DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter Methods

DxfExporter Methods

Public Methods

Name | Description
Export | Creates a DXF file representing the specified MindFusion.Diagramming diagram.

See Also

DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter.Export Method

DxfExporter.Export Method

Creates a DXF file representing the specified MindFusion.Diagramming diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Dxf

Syntax

C#

public void Export (
Diagram diagram,
string filePath
)
Visual Basic

Public Sub Export ( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram
A reference to the diagram to be exported.
filePath
The full path to the .dxf file.

Remarks

Each MindFusion.Diagramming node or link is exported as a group of graphic primitives, such as lines and arcs, defined as DXF entities. DxfExporter uses the entities defined in version 14 of the DXF format.

See Also

DxfExporter Members
DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter Properties

DxfExporter Properties

Public Properties

Name | Description
ExportImages | Gets or sets a value indicating whether the images that are displayed inside diagram nodes should be exported.
ExportTextAsMultiline | Gets or sets a value indicating whether item labels should be exported to DXF MTEXT entities.

See Also

DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter.ExportImages Property

DxfExporter.ExportImages Property

Gets or sets a value indicating whether the images that are displayed inside diagram nodes should be exported.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Dxf

Syntax

C#

public bool ExportImages { get; set; }
Visual Basic

Public Property ExportImages As Boolean

Property Value

true to export images; otherwise, false. The default is false.

Remarks

If this property is enabled, images displayed in MindFusion.Diagramming nodes are saved into external files and references to these files are placed inside the generated DXF code. The image files have the same base name as the specified DXF name, followed by an underscore symbol and a sequential number.

See Also

DxfExporter Members
DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.DxfExporter.ExportTextAsMultiline Property

DxfExporter.ExportTextAsMultiline Property

Gets or sets a value indicating whether item labels should be exported to DXF MTEXT entities.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Dxf

Syntax

C#

public bool ExportTextAsMultiline { get; set; }
Visual Basic

Public Property ExportTextAsMultiline As Boolean

Property Value

true to create multiple-line text entities, otherwise, false. The default is true.

Remarks

Some applications do not support the multiple-line text DXF entity - MTEXT. If you notice that the application you target does not display the labels of diagram items, set this property to false.

See Also

DxfExporter Members
DxfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter Class

PdfExporter Class
Remarks See Also

Exports MindFusion.Diagramming diagrams to Adobe Portable Document Format (PDF) files.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C#

public class PdfExporter
Visual Basic

Public Class PdfExporter

Remarks

In order to use this component, add references to the MindFusion.Diagramming.Export.Pdf.dll and MindFusion.Pdf.dll assemblies to your project.

The Adobe Portable Document Format (PDF) is the most popular open format for representing textual and graphic information in resolution independent manner. In addition, PDF is a multiplatform format, viewable and printable on all popular operating systems. These features, along with its ability to describe complex documents that use a variety of graphics, images and fonts, make PDF a good choice when it comes to distributing your flowcharts and diagrams to others.

The PdfExporter class lets you create PDF files that represent MindFusion.Diagramming diagrams. In order to do that, create a PdfExporter instance and call its Export method. If you need to set the page size and orientation, use the PageSize, and PageOrientation properties. Margins specifies the page margins for all pages in the document. The AutoScale property lets you scale the diagram so it fits in one or more PDF pages.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Export.PdfExporter

See Also

PdfExporter Members
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter Members

PdfExporter Members
Constructors Properties Methods

Exports MindFusion.Diagramming diagrams to Adobe Portable Document Format (PDF) files.

The following tables list the members exposed by the PdfExporter type.

Public Constructors

Name | Description
PdfExporter | Initializes a new instance of the PdfExporter class.

Public Properties

Name | Description
AutoScale | Gets or sets a value indicating whether the diagram should be scaled to fit one or more pages of the PDF document.
DefaultEncoding | Specifies encoding for far-east languages.
EnableBackground | Specifies whether to fill the background with color.
HyperLinkStyle | Specifies what kind of hyperlinks should be generated for the HyperLink property of items.
InvisibleItems | Gets or sets a value indicating whether invisible items should be exported.
Margins | Gets or sets the margins for the PDF pages.
PageOrientation | Gets or sets the orientation of the PDF pages.
PageSize | Gets or sets the size of the PDF pages.
Scale | Gets or sets the scale of the PDF output relatively to the original on-screen size of the diagram.

Public Methods

Name | Description
Export | Creates a PDF file representing the specified MindFusion.Diagramming diagram.

See Also

PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter Constructor

PdfExporter Constructor

Initializes a new instance of the PdfExporter class.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C#

public PdfExporter ()
Visual Basic

Public Sub New ()

See Also

PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter Methods

PdfExporter Methods

Public Methods

Name | Description
Export | Creates a PDF file representing the specified MindFusion.Diagramming diagram.

See Also

PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.Export Method

PdfExporter.Export Method

Creates a PDF file representing the specified MindFusion.Diagramming diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C#

public void Export (
Diagram diagram,
string filePath
)
Visual Basic

Public Sub Export ( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram
A reference to the diagram that will be exported.
filePath
The full path to the PDF file.

Remarks

By default, PdfExporter preserves the original scale of the diagram. If Bounds can not fit in a single page of size PageSize, the exported diagram is divided into multiple pages. The AutoScale property allows scaling the diagram so that it exactly fits in one or more pages.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter Properties

PdfExporter Properties

Public Properties

Name | Description
AutoScale | Gets or sets a value indicating whether the diagram should be scaled to fit one or more pages of the PDF document.
DefaultEncoding | Specifies encoding for far-east languages.
EnableBackground | Specifies whether to fill the background with color.
HyperLinkStyle | Specifies what kind of hyperlinks should be generated for the HyperLink property of items.
InvisibleItems | Gets or sets a value indicating whether invisible items should be exported.
Margins | Gets or sets the margins for the PDF pages.
PageOrientation | Gets or sets the orientation of the PDF pages.
PageSize | Gets or sets the size of the PDF pages.
Scale | Gets or sets the scale of the PDF output relatively to the original on-screen size of the diagram.

See Also

PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.AutoScale Property

PdfExporter.AutoScale Property

Gets or sets a value indicating whether the diagram should be scaled to fit one or more pages of the PDF document.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C#

public AutoScale AutoScale { get; set; }
Visual Basic

Public Property AutoScale As AutoScale

Property Value

A member of the AutoScale enumeration. The default is None.

Remarks

By default, the original scale of the diagram is preserved and the diagram is divided into multiple pages if needed. This property lets you scale the diagram so that it exactly fits in one or more pages.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace
PageSize Property
Scale Property


MindFusion.Diagramming.Export.PdfExporter.DefaultEncoding Property

PdfExporter.DefaultEncoding Property

Specifies encoding for far-east languages.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C#

public Encodings DefaultEncoding { get; set; }
Visual Basic

Public Property DefaultEncoding As Encodings

Property Value

A member of the MindFusion.Pdf.Encodings enumeration. The default value is Auto.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.EnableBackground Property

PdfExporter.EnableBackground Property

Specifies whether to fill the background with color.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C#

public bool EnableBackground { get; set; }
Visual Basic

Public Property EnableBackground As Boolean

Property Value

true to paint the page background with the diagram's BackBrush, otherwise false. The default value is true.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.HyperLinkStyle Property

PdfExporter.HyperLinkStyle Property

Specifies what kind of hyperlinks should be generated for the HyperLink property of items.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C#

public HyperLinkStyle HyperLinkStyle { get; set; }
Visual Basic

Public Property HyperLinkStyle As HyperLinkStyle

Property Value

A member of the HyperLinkStyle enumeration. The default is Text.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.InvisibleItems Property

PdfExporter.InvisibleItems Property

Gets or sets a value indicating whether invisible items should be exported.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C#

public bool InvisibleItems { get; set; }
Visual Basic

Public Property InvisibleItems As Boolean

Property Value

true if invisible items should be displayed in the PDF; otherwise, false. The default is false.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.PdfExporter.Margins Property

PdfExporter.Margins Property

Gets or sets the margins for the PDF pages.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C#

public Margins Margins { get; set; }
Visual Basic

Public Property Margins As Margins

Property Value

An instance of the .NET Margins class that represents the margins in hundredths of an inch. The default is half-inch margins on all sides.

Example

The following C# code creates a PDF file with one-inch page margins:

C#

PdfExporter exp = new PdfExporter();
exp.Margins = new System.Drawing.Printing.Margins(100, 100, 100, 100);
exp.Export(diagram, @"D:\diagram.pdf");
Visual Basic

Dim exp As New PdfExporter
exp.Margins = New System.Drawing.Printing.Margins(100, 100, 100, 100)
exp.Export(diagram, "D:\diagram.pdf")

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace
PageSize Property


MindFusion.Diagramming.Export.PdfExporter.PageOrientation Property

PdfExporter.PageOrientation Property

Gets or sets the orientation of the PDF pages.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C#

public PageOrientation PageOrientation { get; set; }
Visual Basic

Public Property PageOrientation As PageOrientation

Property Value

A member of the PageOrientation enumeration. The default is Portrait. The members of the PageOrientation enumeration are: Landscape, Portrait or Auto.

Remarks

If the Auto value is set, PdfExporter will choose the appropriate orientation according to the proportion of width to height of the diagram.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace
PageSize Property


MindFusion.Diagramming.Export.PdfExporter.PageSize Property

PdfExporter.PageSize Property

Gets or sets the size of the PDF pages.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C#

public PageSize PageSize { get; set; }
Visual Basic

Public Property PageSize As PageSize

Property Value

A member of the PageSize enumeration. The default is A4.

Remarks

The diagram is divided into multiple pages of the specified size, as long as AutoScale is not set to FitToPage.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace
PageOrientation Property
Margins Property


MindFusion.Diagramming.Export.PdfExporter.Scale Property

PdfExporter.Scale Property

Gets or sets the scale of the PDF output relatively to the original on-screen size of the diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Pdf

Syntax

C#

public float Scale { get; set; }
Visual Basic

Public Property Scale As Single

Property Value

A float value specifying the scale as percent of the original size. The default is 100.

Remarks

This value is used only if AutoScale is disabled.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter Class

SvgExporter Class
Remarks See Also

Creates SVG (Scalable Vector Graphics) files from MindFusion.Diagramming diagrams.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C#

public class SvgExporter
Visual Basic

Public Class SvgExporter

Remarks

In order to use this component, add references to the MindFusion.Diagramming.Export.Svg.dll and MindFusion.Svg.dll assemblies to your project.

Scalable Vector Graphics is an XML-based graphics language that describes images with vector shapes, text, and embedded raster graphics. SVG files can be displayed in a browser using the Adobe SVG Viewer. The most popular vector graphics editing applications provide support for SVG too.

In order to create an SVG file from a MindFusion.Diagramming diagram, create an SvgExporter instance and call its Export method, passing a Diagram object as parameter.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Export.SvgExporter

See Also

SvgExporter Members
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter Members

SvgExporter Members
Constructors Properties Methods

Creates SVG (Scalable Vector Graphics) files from MindFusion.Diagramming diagrams.

The following tables list the members exposed by the SvgExporter type.

Public Constructors

Name | Description
SvgExporter | Initializes a new instance of the SvgExporter class.

Public Properties

Name | Description
ExternalImages | Specifies whether images displayed by diagram items should be exported to external files.
HyperLinkStyle | Specifies what kind of hyperlinks should be generated for the HyperLink property of items.
HyperLinkTarget | Specify the value of the target attribute generated for the HyperLink property of items.

Public Methods

Name | Description
Export | Creates an SVG file representing the specified MindFusion.Diagramming diagram.

See Also

SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter Constructor

SvgExporter Constructor

Initializes a new instance of the SvgExporter class.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C#

public SvgExporter ()
Visual Basic

Public Sub New ()

See Also

SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter Methods

SvgExporter Methods

Public Methods

Name | Description
Export | Creates an SVG file representing the specified MindFusion.Diagramming diagram.

See Also

SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter.Export Method

SvgExporter.Export Method

Creates an SVG file representing the specified MindFusion.Diagramming diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C#

public void Export (
Diagram diagram,
string filePath
)
Visual Basic

Public Sub Export ( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram
A reference to the diagram to be exported.
filePath
A full path to the .svg file.

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter Properties

SvgExporter Properties

Public Properties

Name | Description
ExternalImages | Specifies whether images displayed by diagram items should be exported to external files.
HyperLinkStyle | Specifies what kind of hyperlinks should be generated for the HyperLink property of items.
HyperLinkTarget | Specify the value of the target attribute generated for the HyperLink property of items.

See Also

SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter.ExternalImages Property

SvgExporter.ExternalImages Property

Specifies whether images displayed by diagram items should be exported to external files.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C#

public bool ExternalImages { get; set; }
Visual Basic

Public Property ExternalImages As Boolean

Property Value

true to export images to external files; false to keep them as inline binary data in the SVG file. The default is false.

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter.HyperLinkStyle Property

SvgExporter.HyperLinkStyle Property

Specifies what kind of hyperlinks should be generated for the HyperLink property of items.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C#

public HyperLinkStyle HyperLinkStyle { get; set; }
Visual Basic

Public Property HyperLinkStyle As HyperLinkStyle

Property Value

A member of the HyperLinkStyle enumeration. The default is Text.

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.SvgExporter.HyperLinkTarget Property

SvgExporter.HyperLinkTarget Property

Specify the value of the target attribute generated for the HyperLink property of items.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Svg

Syntax

C#

public string HyperLinkTarget { get; set; }
Visual Basic

Public Property HyperLinkTarget As String

Property Value

The default is "_self".

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter Class

VisioExporter Class
Remarks See Also

Exports MindFusion.Diagramming diagrams to Visio 2003 XML Drawing files (*.vdx).

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C#

public class VisioExporter
Visual Basic

Public Class VisioExporter

Remarks

Add a reference to the MindFusion.Diagramming.Export.Visio.dll to your project in order to use this component.

The component allows exporting Visio 2003 XML Drawing files from MindFusion.Diagramming. The MindFusion.Diagramming ShapeNode objects are mapped to their closest Visio counterparts and TableNode objects are exported as groups of Visio shapes. MindFusion.Diagramming DiagramLink instances are exported as Visio connectors of a similar style. In addition, most of the attributes of diagram items such as text, text formatting, fill and line colors and styles are preserved.

To function properly, the exporter object requires the VisioExport.vxt file to be present in the application's directory. This file contains an XML template data used by the component to generate Visio documents.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Export.VisioExporter

See Also

VisioExporter Members
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter Members

VisioExporter Members
Constructors Properties Methods

Exports MindFusion.Diagramming diagrams to Visio 2003 XML Drawing files (*.vdx).

The following tables list the members exposed by the VisioExporter type.

Public Constructors

Name | Description
VisioExporter | Initializes a new instance of the VisioExporter class.

Public Properties

Name | Description
CreateVisioGroups | Gets or sets a value indicating whether Visio groups are created from the MindFusion.Diagramming groups.
ExportImagesAsGroups | Specifies whether a shape node that contains an image should be exported as a Visio group of a shape, picture and text objects.
ExportInvisibleItems | Gets or sets a value indicating whether to export invisible items.
ExportTablesAsGroups | Gets or sets a value indicating whether MindFusion.Diagramming TableNode objects should be exported as groups of Visio rectangular shapes.
TemplatePath | Gets or sets the full path to the VisioExport.vxt template file.

Public Methods

Name | Description
ApproxColors | Approximate two color of gradient to get corresponded ACI.
Export | Creates a Visio XML Drawing file representing the specified MindFusion.Diagramming diagram.

See Also

VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter Constructor

VisioExporter Constructor

Initializes a new instance of the VisioExporter class.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C#

public VisioExporter ()
Visual Basic

Public Sub New ()

See Also

VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter Methods

VisioExporter Methods

Public Methods

Name | Description
ApproxColors | Approximate two color of gradient to get corresponded ACI.
Export | Creates a Visio XML Drawing file representing the specified MindFusion.Diagramming diagram.

See Also

VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter.ApproxColors Method

VisioExporter.ApproxColors Method

Approximate two color of gradient to get corresponded ACI.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C#

public static Color ApproxColors (
Color cr1,
Color cr2
)
Visual Basic

Public Shared Function ApproxColors ( _
cr1 As Color, _
cr2 As Color _
) As Color

Parameters

cr1
Color 1 of gradient
cr2
Color 2 of gradient

Return Value

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter.Export Method

VisioExporter.Export Method

Creates a Visio XML Drawing file representing the specified MindFusion.Diagramming diagram.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C#

public void Export (
Diagram diagram,
string vdxPathName
)
Visual Basic

Public Sub Export ( _
diagram As Diagram, _
vdxPathName As String _
)

Parameters

diagram
A reference to the diagram to be exported.
vdxPathName
The full path to the exported Visio .vdx file.

Remarks

The exported document contains a single page, as big as the MindFusion.Diagramming scrollable diagram area. The Visio page dimension and items size measure unit is set to the diagram's MeasureUnit.

To run properly, this method requires the VisioExport.vxt file to be present in the application's directory. That file contains an XML template data used by the component to construct Visio documents.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter Properties

VisioExporter Properties

Public Properties

Name | Description
CreateVisioGroups | Gets or sets a value indicating whether Visio groups are created from the MindFusion.Diagramming groups.
ExportImagesAsGroups | Specifies whether a shape node that contains an image should be exported as a Visio group of a shape, picture and text objects.
ExportInvisibleItems | Gets or sets a value indicating whether to export invisible items.
ExportTablesAsGroups | Gets or sets a value indicating whether MindFusion.Diagramming TableNode objects should be exported as groups of Visio rectangular shapes.
TemplatePath | Gets or sets the full path to the VisioExport.vxt template file.

See Also

VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter.CreateVisioGroups Property

VisioExporter.CreateVisioGroups Property

Gets or sets a value indicating whether Visio groups are created from the MindFusion.Diagramming groups.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C#

public bool CreateVisioGroups { get; set; }
Visual Basic

Public Property CreateVisioGroups As Boolean

Property Value

true to create Visio groups when possible; otherwise, false. The default is false.

Remarks

It is not always possible to create a Visio group corresponding to a MindFusion.Diagramming one. If the structure of your diagram seems incorrect when imported in Visio, disable this property.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace
ExportTablesAsGroups Property


MindFusion.Diagramming.Export.VisioExporter.ExportImagesAsGroups Property

VisioExporter.ExportImagesAsGroups Property

Specifies whether a shape node that contains an image should be exported as a Visio group of a shape, picture and text objects.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C#

public bool ExportImagesAsGroups { get; set; }
Visual Basic

Public Property ExportImagesAsGroups As Boolean

Property Value

true to export nodes with images as groups; otherwise, false. The default is true.

Remarks

Visio shapes cannot contain images inside them, and by default a MindFusion.Diagramming shape node that contains an image s exported as a Visio Picture object. Unfortunately, that leads to losing the node shape and the image alignment. Setting this property to true lets you export a shape node with an image as a group of several Visio objects that will preserve the appearance of the original MindFusion.Diagramming node as closely as possible.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace
ExportTablesAsGroups Property


MindFusion.Diagramming.Export.VisioExporter.ExportInvisibleItems Property

VisioExporter.ExportInvisibleItems Property

Gets or sets a value indicating whether to export invisible items.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C#

public bool ExportInvisibleItems { get; set; }
Visual Basic

Public Property ExportInvisibleItems As Boolean

Property Value

true to export invisible items; otherwise, false.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Export.VisioExporter.ExportTablesAsGroups Property

VisioExporter.ExportTablesAsGroups Property

Gets or sets a value indicating whether MindFusion.Diagramming TableNode objects should be exported as groups of Visio rectangular shapes.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C#

public bool ExportTablesAsGroups { get; set; }
Visual Basic

Public Property ExportTablesAsGroups As Boolean

Property Value

true to export tables as groups; otherwise, false. The default is false.

Remarks

Visio table entities cannot display cells in multiple columns. If your MindFusion.Diagramming diagrams contains tables having more than two columns, consider enabling this property. Then the VisioExporter would create a rectangular shape for each cell, and group the cells of each table into a Visio compound shape corresponding to the table.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace
ExportImagesAsGroups Property


MindFusion.Diagramming.Export.VisioExporter.TemplatePath Property

VisioExporter.TemplatePath Property

Gets or sets the full path to the VisioExport.vxt template file.

Namespace: MindFusion.Diagramming.Export
Assembly: MindFusion.Diagramming.Export.Visio

Syntax

C#

public string TemplatePath { get; set; }
Visual Basic

Public Property TemplatePath As String

Property Value

A string specifying the location of the template file. The default is an empty string.

Remarks

If you do not specify the path to the template file, MindFusion.Diagramming looks for the file in the same folder where the MindFusion.Diagramming.Export.Svg.dll assembly is, in the folder of the application executable file, and in the current folder. However that might not work under restricted security permissions, for example when running in a browser or in an IIS process.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Export Namespace


MindFusion.Diagramming.Import Namespace
Classes Delegates

Classes

Class | Description
ConnectorImportedEventArgs | Contains the arguments passed to handlers of the ConnectorImported event.
GroupImportedArgs | Contains the arguments passed to handlers of the GroupImported event.
ShapeImportedEventArgs | Contains the arguments passed to handlers of the ShapeImported event.
VisioImporter | Imports Visio 2003 XML Drawing files (*.vdx) into MindFusion.Diagramming.

Delegates

Delegate | Description
ConnectorImportedEventHandler | Represents methods that will handle the ConnectorImported event.
GroupImportedEventHandler | Represents methods that will handle the GroupImported event.
ShapeImportedEventHandler | Represents methods that will handle the ShapeImported event.


MindFusion.Diagramming.Import.ConnectorImportedEventArgs Class

ConnectorImportedEventArgs Class

Contains the arguments passed to handlers of the ConnectorImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public class ConnectorImportedEventArgs : EventArgs
Visual Basic

Public Class ConnectorImportedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Import.ConnectorImportedEventArgs

See Also

ConnectorImportedEventArgs Members
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ConnectorImportedEventArgs Members

ConnectorImportedEventArgs Members
Properties

Contains the arguments passed to handlers of the ConnectorImported event.

The following tables list the members exposed by the ConnectorImportedEventArgs type.

Public Properties

Name | Description
ConnectorXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported connector.
Link | Gets a reference to the imported diagram link.
ShapeName | Gets the Visio name of the connector shape.

See Also

ConnectorImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ConnectorImportedEventArgs Properties

ConnectorImportedEventArgs Properties

Public Properties

Name | Description
ConnectorXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported connector.
Link | Gets a reference to the imported diagram link.
ShapeName | Gets the Visio name of the connector shape.

See Also

ConnectorImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ConnectorImportedEventArgs.ConnectorXml Property

ConnectorImportedEventArgs.ConnectorXml Property

Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported connector.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public XmlNode ConnectorXml { get; }
Visual Basic

Public ReadOnly Property ConnectorXml As XmlNode

Property Value

An XmlNode object corresponding to the section of the VDX document which describes the imported connector.

See Also

ConnectorImportedEventArgs Members
ConnectorImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ConnectorImportedEventArgs.Link Property

ConnectorImportedEventArgs.Link Property

Gets a reference to the imported diagram link.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public DiagramLink Link { get; }
Visual Basic

Public ReadOnly Property Link As DiagramLink

Property Value

An instance of the DiagramLink class.

See Also

ConnectorImportedEventArgs Members
ConnectorImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ConnectorImportedEventArgs.ShapeName Property

ConnectorImportedEventArgs.ShapeName Property

Gets the Visio name of the connector shape.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public string ShapeName { get; }
Visual Basic

Public ReadOnly Property ShapeName As String

Property Value

A string specifying the Visio name of the connector.

See Also

ConnectorImportedEventArgs Members
ConnectorImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ConnectorImportedEventHandler Delegate

ConnectorImportedEventHandler Delegate

Represents methods that will handle the ConnectorImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public delegate void ConnectorImportedEventHandler (
Object sender,
ConnectorImportedEventArgs e
)
Visual Basic

Public Delegate Sub ConnectorImportedEventHandler ( _
sender As Object, _
e As ConnectorImportedEventArgs _
)

Parameters

sender
The source of the event.
e

A ConnectorImportedEventArgs that contains the event data.

See Also

MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.GroupImportedArgs Class

GroupImportedArgs Class

Contains the arguments passed to handlers of the GroupImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public class GroupImportedArgs : EventArgs
Visual Basic

Public Class GroupImportedArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Import.GroupImportedArgs

See Also

GroupImportedArgs Members
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.GroupImportedArgs Members

GroupImportedArgs Members
Properties

Contains the arguments passed to handlers of the GroupImported event.

The following tables list the members exposed by the GroupImportedArgs type.

Public Properties

Name | Description
Group | Gets a reference to the imported group.

See Also

GroupImportedArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.GroupImportedArgs Properties

GroupImportedArgs Properties

Public Properties

Name | Description
Group | Gets a reference to the imported group.

See Also

GroupImportedArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.GroupImportedArgs.Group Property

GroupImportedArgs.Group Property

Gets a reference to the imported group.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public Group Group { get; }
Visual Basic

Public ReadOnly Property Group As Group

Property Value

An instance of the Group class.

See Also

GroupImportedArgs Members
GroupImportedArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.GroupImportedEventHandler Delegate

GroupImportedEventHandler Delegate

Represents methods that will handle the GroupImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public delegate void GroupImportedEventHandler (
Object sender,
GroupImportedArgs e
)
Visual Basic

Public Delegate Sub GroupImportedEventHandler ( _
sender As Object, _
e As GroupImportedArgs _
)

Parameters

sender

The source of the event.

e

A GroupImportedArgs that contains the event data.

See Also

MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ShapeImportedEventArgs Class

ShapeImportedEventArgs Class

Contains the arguments passed to handlers of the ShapeImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public class ShapeImportedEventArgs : EventArgs
Visual Basic

Public Class ShapeImportedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Import.ShapeImportedEventArgs

See Also

ShapeImportedEventArgs Members
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ShapeImportedEventArgs Members

ShapeImportedEventArgs Members
Properties

Contains the arguments passed to handlers of the ShapeImported event.

The following tables list the members exposed by the ShapeImportedEventArgs type.

Public Properties

Name | Description
Shape | Gets a reference to the imported diagram shape.
ShapeName | Gets the Visio name of the node shape.
ShapeXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

See Also

ShapeImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ShapeImportedEventArgs Properties

ShapeImportedEventArgs Properties

Public Properties

Name | Description
Shape | Gets a reference to the imported diagram shape.
ShapeName | Gets the Visio name of the node shape.
ShapeXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

See Also

ShapeImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ShapeImportedEventArgs.Shape Property

ShapeImportedEventArgs.Shape Property

Gets a reference to the imported diagram shape.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public ShapeNode Shape { get; }
Visual Basic

Public ReadOnly Property Shape As ShapeNode

Property Value

An instance of the ShapeNode class.

See Also

ShapeImportedEventArgs Members
ShapeImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ShapeImportedEventArgs.ShapeName Property

ShapeImportedEventArgs.ShapeName Property

Gets the Visio name of the node shape.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public string ShapeName { get; }
Visual Basic

Public ReadOnly Property ShapeName As String

Property Value

A string specifying the Visio name of the shape.

See Also

ShapeImportedEventArgs Members
ShapeImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ShapeImportedEventArgs.ShapeXml Property

ShapeImportedEventArgs.ShapeXml Property

Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public XmlNode ShapeXml { get; }
Visual Basic

Public ReadOnly Property ShapeXml As XmlNode

Property Value

An XmlNode object corresponding to the section of the VDX document which describes the imported shape.

Example

The following sample shows how to read a custom property value defined in Visio by handling the ShapeImported event.

C#

private void ShapeImported(object sender, ShapeImportedEventArgs e)
{
XmlNode vdxCode = e.ShapeXml;
try
{
XmlNamespaceManager ns = new XmlNamespaceManager(e.ShapeXml.OwnerDocument.NameTable);
ns.AddNamespace("vdx", "http://schemas.microsoft.com/visio/2003/core");

XmlNode myPropVal = vdxCode.SelectSingleNode("vdx:Prop[vdx:Label='MyProperty']/vdx:Value", ns);
if (myPropVal != null)
e.Shape.Tag = myPropVal.InnerText;
}
catch (Exception ex)
{
MessageBox.Show(ex.Message);
}
}

See Also

ShapeImportedEventArgs Members
ShapeImportedEventArgs Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.ShapeImportedEventHandler Delegate

ShapeImportedEventHandler Delegate

Represents methods that will handle the ShapeImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public delegate void ShapeImportedEventHandler (
Object sender,
ShapeImportedEventArgs e
)
Visual Basic

Public Delegate Sub ShapeImportedEventHandler ( _
sender As Object, _
e As ShapeImportedEventArgs _
)

Parameters

sender

The source of the event.

e

A ShapeImportedEventArgs that contains the event data.

See Also

MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter Class

VisioImporter Class
Remarks See Also

Imports Visio 2003 XML Drawing files (*.vdx) into MindFusion.Diagramming.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public class VisioImporter
Visual Basic

Public Class VisioImporter

Remarks

Add a reference to the MindFusion.Diagramming.Import.Visio.dll to your project in order to use this component.

The component allows importing Visio 2003 XML Drawing files (*.vdx) into MindFusion.Diagramming. The standard Visio flowchart shapes, as well as most of the UML and Database entity shapes are imported to their closest representation in MindFusion.Diagramming. The Visio connectors are imported as MindFusion.Diagramming DiagramLink objects, preserving the relationship between the connected nodes. In addition, most of the attributes of Visio objects such as text, text formatting, fill and line colors and styles are preserved. The component raises an event for each imported node to let you set the node shape if it is not recognized by MindFusion.Diagramming or if you need to set a different shape.

To determine how many pages contains the Visio document and import only a single page, call the GetPageCount and ImportPage methods. All pages of a Visio diagram can be imported at once by calling the ImportAllPages method, which lays out the pages as set in PagesPerRow. More properties and events provided by the class are listed below.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Import.VisioImporter

See Also

VisioImporter Members
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter Members

VisioImporter Members
Constructors Properties Methods Events

Imports Visio 2003 XML Drawing files (*.vdx) into MindFusion.Diagramming.

The following tables list the members exposed by the VisioImporter type.

Public Constructors

Name | Description
VisioImporter | Initializes a new instance of the VisioImporter class.

Public Properties

Name | Description
ImportEntitiesAsTables | Gets or sets a value indicating whether Visio UML and DB entities are imported as MindFusion.Diagramming tables.
PagesPerRow | Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.

Public Methods

Name | Description
GetPageCount | Determines how many pages are there in a Visio diagram.
ImportAllPages | Imports all pages from the specified Visio document.
ImportPage | Imports a single page from the specified Visio document.

Protected Methods

Name | Description
OnConnectorImported | Raises the ConnectorImported event.
OnGroupImported | Raises the GroupImported event.
OnShapeImported | Raises the ShapeImported event.

Public Events

Name | Description
ConnectorImported | Raised when a Visio connector is imported as a MindFusion.Diagramming link.
GroupImported | Raised when a Visio group is imported as a MindFusion.Diagramming group.
ShapeImported | Raised when a Visio shape is imported into MindFusion.Diagramming as a ShapeNode.

See Also

VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter Constructor

VisioImporter Constructor

Initializes a new instance of the VisioImporter class.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public VisioImporter ()
Visual Basic

Public Sub New ()

See Also

VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter Methods

VisioImporter Methods

Public Methods

Name | Description
GetPageCount | Determines how many pages are there in a Visio diagram.
ImportAllPages | Imports all pages from the specified Visio document.
ImportPage | Imports a single page from the specified Visio document.

Protected Methods

Name | Description
OnConnectorImported | Raises the ConnectorImported event.
OnGroupImported | Raises the GroupImported event.
OnShapeImported | Raises the ShapeImported event.

See Also

VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.GetPageCount Method

VisioImporter.GetPageCount Method

Determines how many pages are there in a Visio diagram.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public long GetPageCount (
string vdxPathName
)
Visual Basic

Public Function GetPageCount ( _
vdxPathName As String _
) As Long

Parameters

vdxPathName
A full path to the Visio VDX file.

Return Value

An integer value specifying the number of pages in the Visio diagram.

Remarks

Use this method to determine the valid range of pages for ImportPage.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.ImportAllPages Method

VisioImporter.ImportAllPages Method

Imports all pages from the specified Visio document.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public void ImportAllPages (
string vdxPathName,
Diagram diagram
)
Visual Basic

Public Sub ImportAllPages ( _
vdxPathName As String, _
diagram As Diagram _
)

Parameters

vdxPathName
A full path to the Visio VDX file.
diagram
Reference to the diagram where the Visio drawing is imported.

Remarks

The pages are imported starting from the top-left point of the MindFusion.Diagramming diagram area. The current import location is moved one page-width to the right with each new page imported, until PagesPerRow pages are imported on the same y-coordinate. When that happens, the current location moves to the left-most x-coordinate and one page-height down. If there are more pages to import, the process continues as above.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.ImportPage Method

VisioImporter.ImportPage Method

Imports a single page from the specified Visio document.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public void ImportPage (
string vdxPathName,
Diagram diagram,
int PageIndex
)
Visual Basic

Public Sub ImportPage ( _
vdxPathName As String, _
diagram As Diagram, _
PageIndex As Integer _
)

Parameters

vdxPathName
A full path to the Visio VDX file.
diagram
Reference to the Diagram document into which the Visio data is imported.
PageIndex
Specifies which page of the Visio document to import.

Remarks

The page index is zero based. Use GetPageCount to determine how many pages are there in the Visio diagram.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.OnConnectorImported Method

VisioImporter.OnConnectorImported Method

Raises the ConnectorImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

protected virtual void OnConnectorImported (
ConnectorImportedEventArgs e
)
Visual Basic

Protected Overridable Sub OnConnectorImported ( _
e As ConnectorImportedEventArgs _
)

Parameters

e
An ConnectorImportedEventArgs that contains the event data.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.OnGroupImported Method

VisioImporter.OnGroupImported Method

Raises the GroupImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

protected virtual void OnGroupImported (
GroupImportedArgs e
)
Visual Basic

Protected Overridable Sub OnGroupImported ( _
e As GroupImportedArgs _
)

Parameters

e
An GroupImportedArgs that contains the event data.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.OnShapeImported Method

VisioImporter.OnShapeImported Method

Raises the ShapeImported event.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

protected virtual void OnShapeImported (
ShapeImportedEventArgs e
)
Visual Basic

Protected Overridable Sub OnShapeImported ( _
e As ShapeImportedEventArgs _
)

Parameters

e
An ShapeImportedEventArgs that contains the event data.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter Properties

VisioImporter Properties

Public Properties

Name | Description
ImportEntitiesAsTables | Gets or sets a value indicating whether Visio UML and DB entities are imported as MindFusion.Diagramming tables.
PagesPerRow | Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.

See Also

VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.ImportEntitiesAsTables Property

VisioImporter.ImportEntitiesAsTables Property

Gets or sets a value indicating whether Visio UML and DB entities are imported as MindFusion.Diagramming tables.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public bool ImportEntitiesAsTables { get; set; }
Visual Basic

Public Property ImportEntitiesAsTables As Boolean

Property Value

true to import Visio entity nodes as tables; otherwise, false. The default is false.

Remarks

If this property is disabled, Visio entity objects are imported as MindFusion.Diagramming groups of rectangular nodes; if it is enabled, entities are imported as tables.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.PagesPerRow Property

VisioImporter.PagesPerRow Property

Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public long PagesPerRow { get; set; }
Visual Basic

Public Property PagesPerRow As Long

Property Value

An integer value specifying how many pages to import in a row. The default is 1.

Remarks

MindFusion.Diagramming does not support stacked pages as Visio does, so the ImportAllPages method imports all pages from a Visio document in a grid that prevents items from one page to overlap with items from another page. This property specifies the width of the page grid.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter Events

VisioImporter Events

Public Events

Name | Description
ConnectorImported | Raised when a Visio connector is imported as a MindFusion.Diagramming link.
GroupImported | Raised when a Visio group is imported as a MindFusion.Diagramming group.
ShapeImported | Raised when a Visio shape is imported into MindFusion.Diagramming as a ShapeNode.

See Also

VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.ConnectorImported Event

VisioImporter.ConnectorImported Event

Raised when a Visio connector is imported as a MindFusion.Diagramming link.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public event ConnectorImportedEventHandler ConnectorImported
Visual Basic

Public Event ConnectorImported As ConnectorImportedEventHandler

Event Data

ConnectorImported event handlers receive an argument of type ConnectorImportedEventArgs. The following ConnectorImportedEventArgs members provide information relevant to the event:

Member Name | Description
Link | Refers to the imported DiagramLink instance.
ShapeName | The name of the Visio connector shape.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.GroupImported Event

VisioImporter.GroupImported Event

Raised when a Visio group is imported as a MindFusion.Diagramming group.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public event GroupImportedEventHandler GroupImported
Visual Basic

Public Event GroupImported As GroupImportedEventHandler

Event Data

GroupImported event handlers receive an argument of type GroupImportedArgs. The following GroupImportedArgs members provide information relevant to the event:

Member name | Description
Group | Refers to the imported Group instance.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Import.VisioImporter.ShapeImported Event

VisioImporter.ShapeImported Event

Raised when a Visio shape is imported into MindFusion.Diagramming as a ShapeNode.

Namespace: MindFusion.Diagramming.Import
Assembly: MindFusion.Diagramming.Import.Visio

Syntax

C#

public event ShapeImportedEventHandler ShapeImported
Visual Basic

Public Event ShapeImported As ShapeImportedEventHandler

Event Data

ShapeImported event handlers receive an argument of type ShapeImportedEventArgs. The following ShapeImportedEventArgs members provide information relevant to the event:

Member name | Description
Shape | Refers to the imported ShapeNode instance.
ShapeName | The name of the Visio node shape.

Remarks

The basic Visio flowchart shapes are mapped to the MindFusion.Diagramming predefined shape templates. If the importer does not recognize a specific Visio shape, the node created for it is set to a simple rectangle. You can handle this event in order to set the shape of a node whose Visio counterpart is not recognized, or whose default value set by the importer is not appropriate for your application.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Import Namespace


MindFusion.Diagramming.Lanes Namespace
Classes Interfaces Delegates Enumerations

Contains classes that let you display lanes and grids in MindFusion.Diagramming.

The lane grid lets you emphasize the relationship between a group of diagram items by displaying them in a distinct lane or cell within the grid. For example, your diagram might display a complicated processes that involves several departments of an organization. Each department might be represented by a lane, and the nodes that represent the responsibilities of a single department will be displayed in the same lane. The lanes can be further divided into cells. For example, that could be used to display a timeline and allocate the diagram nodes to specific dates.

To display lanes or a grid, set the EnableLanes property of the Diagram class to true. In order to customize the grid, set the various attributes exposed by the LaneGrid property, which lets you specify the number of rows and columns, add headers, customize the cell appearance, and so on.

Classes

Class | Description
CellBoundsEventArgs | Contains the arguments passed to handlers of the CellBoundsChanged event.
Grid | Represents a lane grid.
Header | Represents a header in a grid view.
HeaderCollection | Represents a strongly typed collection of Header objects.
HeaderEventArgs | Contains the arguments passed to handlers of header-related events.
HeaderResizeEventArgs | Contains the arguments passed to handlers of header resize events.
Style | Encapsulates the appearance properties of an element in a lane grid.

Interfaces

Interface | Description
ICell | Defines a base for cells in a lane list.

Delegates

Delegate | Description
CellBoundsEventHandler | Represents methods that will handle the CellBoundsChanged event.

Enumerations

Enumeration | Description
ResizeType | Specifies how to resize child columns and rows in the lanes grid when their parent column or row is resized.


MindFusion.Diagramming.Lanes.CellBoundsEventArgs Class

CellBoundsEventArgs Class

Contains the arguments passed to handlers of the CellBoundsChanged event.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public class CellBoundsEventArgs : EventArgs
Visual Basic

Public Class CellBoundsEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Lanes.CellBoundsEventArgs

See Also

CellBoundsEventArgs Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs Members

CellBoundsEventArgs Members
Properties

Contains the arguments passed to handlers of the CellBoundsChanged event.

The following tables list the members exposed by the CellBoundsEventArgs type.

Public Properties

Name | Description
Cell | Gets the cell which has been resized.
NewBounds | Gets the new bounding rectangle of the cell.
OldBounds | Gets the old bounding rectangle of the cell.

See Also

CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs Properties

CellBoundsEventArgs Properties

Public Properties

Name | Description
Cell | Gets the cell which has been resized.
NewBounds | Gets the new bounding rectangle of the cell.
OldBounds | Gets the old bounding rectangle of the cell.

See Also

CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs.Cell Property

CellBoundsEventArgs.Cell Property

Gets the cell which has been resized.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public ICell Cell { get; }
Visual Basic

Public ReadOnly Property Cell As ICell

Property Value

An instance of a class implementing the ICell interface that represents the cell that has been resized.

See Also

CellBoundsEventArgs Members
CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs.NewBounds Property

CellBoundsEventArgs.NewBounds Property

Gets the new bounding rectangle of the cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF NewBounds { get; }
Visual Basic

Public ReadOnly Property NewBounds As RectangleF

Property Value

A .NET RectangleF object specifying the new bounding rectangle of the cell.

See Also

CellBoundsEventArgs Members
CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs.OldBounds Property

CellBoundsEventArgs.OldBounds Property

Gets the old bounding rectangle of the cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF OldBounds { get; }
Visual Basic

Public ReadOnly Property OldBounds As RectangleF

Property Value

A .NET RectangleF object specifying the old bounding rectangle of the cell.

See Also

CellBoundsEventArgs Members
CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventHandler Delegate

CellBoundsEventHandler Delegate

Represents methods that will handle the CellBoundsChanged event.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void CellBoundsEventHandler (
Object sender,
CellBoundsEventArgs e
)
Visual Basic

Public Delegate Sub CellBoundsEventHandler ( _
sender As Object, _
e As CellBoundsEventArgs _
)

Parameters

sender

The source of the event.

e

A CellBoundsEventArgs that contains the event data.

See Also

MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Class

Grid Class
Remarks See Also

Represents a lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public class Grid : IPersists
Visual Basic

Public Class Grid
Implements IPersists

Remarks

The Grid class lets you define a background grid or table that can be used in Swimlane diagrams or Gantt charts. To activate the grid, set the EnableLanes property of the Diagram class to true.

Grids can include varying number of lanes, divided into child rows and columns whose intersections form cells. The grid can be resized by setting the ColumnCount and RowCount properties or by adding headers to the ColumnHeaders and RowHeaders collections. A column or row can be divided into child elements by adding to the SubHeaders collection of a Header, which lets you form a complex hierarchy of unlimited depth.

The intersection of rows and columns can be either a simple cell for bottommost elements in the lane hierarchy, or a group of cells for parent rows and columns. Cells or cell groups can be accessed by the Item property, that lets you index cells either by their integer positions, or by their Header objects.

If the AllowResizeHeaders property of the Grid class is enabled, users can resize the grid columns and rows as desired. The LaneColumnResizeCursor and LaneRowResizeCursor properties of the DiagramView class specify the mouse cursor shown when resizing the lane column header or the lane row header. The CellBoundsChanged event is raised when lane cell bounds are resized.

The position of the grid and grid headers within the diagram document is defined by TopMargin and LeftMargin, which specify the grid offset relative to Bounds. HookHeaders enables lane headers to be anchored to the left or right side of the control's visible area. The sizes of headers at different levels in the lane hierarchy can be set in a single operation by using the RowHeadersWidths and ColumnHeadersHeights proeprties.

The appearance of the lanes grid can be customized further in the AlignCells property which specifies whether cells are aligned to each other, the HeadersOnTop poperty which specifies whether headers should appear on top of the z-order, and the TopLeftAreaStyle specifying the appearance of the grid's top left corner.

The Grid class provides many miscellaneous methods that can be used to find grid elements, for determining their bounds and for hit-testing.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Lanes.Grid

See Also

Grid Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Members

Grid Members
Properties Methods Events

Represents a lane grid.

The following tables list the members exposed by the Grid type.

Public Properties

Name | Description
AlignCells | Gets or sets a value indicating whether cells are aligned one next to another so that their borders don't overlap.
AllowResizeHeaders | Gets or sets a value indicating whether users can resize the headers of the grid interactively.
ColumnCount | Gets or sets the number of columns in the grid.
ColumnHeaders | Gets the collection with the topmost column headers.
ColumnHeadersHeights | Gets or sets an array with float values specifying the heights of individual column levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.
HeadersOnTop | Gets or sets a value indicating whether lane headers appear at the top of the z-order above all other items.
HookHeaders | Gets or sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).
Item | Gets a cell or cluster of cells from the grid.
LeftMargin | Gets or sets the offset of the lane grid from the left side of the document bounds.
MinHeaderSize | Gets or sets the minimum size of a header.
RowCount | Gets or sets the number of rows in the grid.
RowHeaders | Gets the collection with the leftmost row headers.
RowHeadersWidths | Gets or sets an array with float values specifying the widths of individual row levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.
TopLeftAreaStyle | Gets or sets the style of the area above all row headers and to the left of all column headers.
TopLeftAreaText | Gets or sets the text displayed in the top left area.
TopLeftAreaTextColor | Gets or sets the color of the text displayed in the top left area.
TopLeftAreaTextFont | Gets or sets the font used to display text in the top left area.
TopLeftAreaTextFormat | Gets or sets the format of the text displayed in the top left area.
TopMargin | Gets or sets the offset of the lane grid from the top side of the document bounds.

Public Methods

Name | Description
FindColumn | Returns the first column header matching the specified caption.
FindRow | Finds the first row whose header caption matches the specified string.
GetCellBounds | Returns the bounding rectangle of the specified cell.
GetCellColumn | Returns the column index of the specified cell.
GetCellFromPoint | Gets the cell located at the specified point.
GetCellRow | Returns the row index of the specified cell.
GetColumn | Returns the column header with the specified index from the bottommost column header level.
GetColumnHeaderBounds | Returns the bounding rectangle of all column headers.
GetColumnIndex | Returns the 0-based index of the specified column.
GetHeaderBounds | Returns the bounding rectangle of the specified header.
GetHeaderFromPoint | Overloaded.
GetHeaderLevel | Gets the level of the specified header.
GetHeaderParent | Returns the header containing the specified header, or null, if the header is a top-level header.
GetRow | Returns the row header with the specified index from the bottommost row header level.
GetRowHeaderBounds | Returns the bounding rectangle of all row headers.
GetRowIndex | Returns the 0-based index of the specified row.
InsertAfter | Inserts a new header after the specified header and returns a reference to it.
InsertBefore | Inserts a new header before the specified header and returns a reference to it.
RaiseHeaderAdded | Raises the HeaderAdded event from outside the lane grid.
RaiseHeaderResized | Raises the HeaderResized event from outside the lane grid.
RaiseHeaderStartResizing | Raises the HeaderStartResizing event from outside the lane grid.
ResizeColumnHeaderHeights | Resizes the heights of all column headers from the specified level with the specified amount.
ResizeRowHeaderWidths | Resizes the widths of all row headers from the specified level with the specified amount.

Public Events

Name | Description
CellBoundsChanged | Raised when the bounding rectangle of a cell has been changed.
HeaderAdded | Raised when a header has been inserted into the grid, either interactively or through a call to the InsertBefore or InsertAfter methods.
HeaderResized | Raised when the user finishes resizing a header.
HeaderStartResizing | Raises when the user starts resizing a header.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Methods

Grid Methods

Public Methods

Name | Description
FindColumn | Returns the first column header matching the specified caption.
FindRow | Finds the first row whose header caption matches the specified string.
GetCellBounds | Returns the bounding rectangle of the specified cell.
GetCellColumn | Returns the column index of the specified cell.
GetCellFromPoint | Gets the cell located at the specified point.
GetCellRow | Returns the row index of the specified cell.
GetColumn | Returns the column header with the specified index from the bottommost column header level.
GetColumnHeaderBounds | Returns the bounding rectangle of all column headers.
GetColumnIndex | Returns the 0-based index of the specified column.
GetHeaderBounds | Returns the bounding rectangle of the specified header.
GetHeaderFromPoint | Overloaded.
GetHeaderLevel | Gets the level of the specified header.
GetHeaderParent | Returns the header containing the specified header, or null, if the header is a top-level header.
GetRow | Returns the row header with the specified index from the bottommost row header level.
GetRowHeaderBounds | Returns the bounding rectangle of all row headers.
GetRowIndex | Returns the 0-based index of the specified row.
InsertAfter | Inserts a new header after the specified header and returns a reference to it.
InsertBefore | Inserts a new header before the specified header and returns a reference to it.
RaiseHeaderAdded | Raises the HeaderAdded event from outside the lane grid.
RaiseHeaderResized | Raises the HeaderResized event from outside the lane grid.
RaiseHeaderStartResizing | Raises the HeaderStartResizing event from outside the lane grid.
ResizeColumnHeaderHeights | Resizes the heights of all column headers from the specified level with the specified amount.
ResizeRowHeaderWidths | Resizes the widths of all row headers from the specified level with the specified amount.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.FindColumn Method

Grid.FindColumn Method

Returns the first column header matching the specified caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Header FindColumn (
string title
)
Visual Basic

Public Function FindColumn ( _
title As String _
) As Header

Parameters

title
A string containing the header title to look for.

Return Value

Returns the first column Header that has the specified caption.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace
FindRow Method


MindFusion.Diagramming.Lanes.Grid.FindRow Method

Grid.FindRow Method

Finds the first row whose header caption matches the specified string.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Header FindRow (
string title
)
Visual Basic

Public Function FindRow ( _
title As String _
) As Header

Parameters

title
A string containing the header title to look for.

Return Value

Returns the first row Header that has the specified caption.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace
FindColumn Method


MindFusion.Diagramming.Lanes.Grid.GetCellBounds Method

Grid.GetCellBounds Method

Returns the bounding rectangle of the specified cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF GetCellBounds (
ICell cell
)
Visual Basic

Public Function GetCellBounds ( _
cell As ICell _
) As RectangleF

Parameters

cell
An ICell object representing a cell or a group of cells in the grid.

Return Value

A RectangleF instance representing the rectangle that bounds the specified cell or group of cells.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellColumn Method

Grid.GetCellColumn Method

Returns the column index of the specified cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public int GetCellColumn (
ICell cell
)
Visual Basic

Public Function GetCellColumn ( _
cell As ICell _
) As Integer

Parameters

cell
An ICell object representing a single cell in the grid.

Return Value

The index of the column that contains cell; -1 if cell is not found or refers to a group of cells.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellFromPoint Method

Grid.GetCellFromPoint Method

Gets the cell located at the specified point.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public ICell GetCellFromPoint (
PointF point,
ref RectangleF cellBounds
)
Visual Basic

Public Function GetCellFromPoint ( _
point As PointF, _
ByRef cellBounds As RectangleF _
) As ICell

Parameters

point
A PointF instance specifying a point within the grid.
cellBounds
A RectangleF instance that receives the coordinates of the found cell.

Return Value

An ICell reference to the found cell, or null (Nothing in Visual Basic) if there is no cell located at the specified point.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellRow Method

Grid.GetCellRow Method

Returns the row index of the specified cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public int GetCellRow (
ICell cell
)
Visual Basic

Public Function GetCellRow ( _
cell As ICell _
) As Integer

Parameters

cell
An ICell object representing a single cell in the grid.

Return Value

The index of the row that contains cell; -1 if cell is not found or refers to a group of cells.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetColumn Method

Grid.GetColumn Method

Returns the column header with the specified index from the bottommost column header level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Header GetColumn (
int index
)
Visual Basic

Public Function GetColumn ( _
index As Integer _
) As Header

Parameters

index
An integer value specifying the column index.

Return Value

A Header object representing the column at the specified index. A grid column that contains child columns cannot be accessed by index; only the bottommost child elements in the hierarchy are considered by this method.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetColumnHeaderBounds Method

Grid.GetColumnHeaderBounds Method

Returns the bounding rectangle of all column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF GetColumnHeaderBounds ()
Visual Basic

Public Function GetColumnHeaderBounds () As RectangleF

Return Value

A RectangleF that bounds all column headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetColumnIndex Method

Grid.GetColumnIndex Method

Returns the 0-based index of the specified column.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public int GetColumnIndex (
Header column
)
Visual Basic

Public Function GetColumnIndex ( _
column As Header _
) As Integer

Parameters

column
A Header instance that represents a grid column.

Return Value

The index of column, or -1 if the specified header represents a row or a group of child columns.

Remarks

Only works for bottommost headers. If the specified column is a group header, returns -1.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderBounds Method

Grid.GetHeaderBounds Method

Returns the bounding rectangle of the specified header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF GetHeaderBounds (
Header header,
bool includeSubHeaders
)
Visual Basic

Public Function GetHeaderBounds ( _
header As Header, _
includeSubHeaders As Boolean _
) As RectangleF

Parameters

header
The Header object whose coordinates to return.
includeSubHeaders
true to include the coordinates of the child headers in the returned rectangle; otherwise, false.

Return Value

A RectangleF that bounds the specified header, and optionally its child headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderFromPoint Method

Grid.GetHeaderFromPoint Method

Overload List

Name | Description
Grid.GetHeaderFromPoint (PointF, RectangleF@) | Gets the Header that is located at the specified point.
Grid.GetHeaderFromPoint (PointF, RectangleF@, PointF) | Gets the Header that is located at the specified point.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderFromPoint Method (PointF, RectangleF@)

Grid.GetHeaderFromPoint Method (PointF, RectangleF@)
See Also

Gets the Header that is located at the specified point.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Header GetHeaderFromPoint (
PointF point,
ref RectangleF headerBounds
)
Visual Basic

Public Function GetHeaderFromPoint ( _
point As PointF, _
ByRef headerBounds As RectangleF _
) As Header

Parameters

point
A PointF instance specifying a point within the grid.
headerBounds
A RectangleF instance that receives the coordinates of the found header.

Return Value

The found Header object, or null (Nothing in Visual Basic) if there is no header located at the specified point.

See Also

GetHeaderFromPoint Method Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderFromPoint Method (PointF, RectangleF@, PointF)

Grid.GetHeaderFromPoint Method (PointF, RectangleF@, PointF)
See Also

Gets the Header that is located at the specified point.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Header GetHeaderFromPoint (
PointF point,
ref RectangleF headerBounds,
PointF scrollPosition
)
Visual Basic

Public Function GetHeaderFromPoint ( _
point As PointF, _
ByRef headerBounds As RectangleF, _
scrollPosition As PointF _
) As Header

Parameters

point
A Point instance specifying a point within the grid.
headerBounds
A Rect instance that receives the coordinates of the found header.
scrollPosition
When the headers are hooked this parameter should provide information about the current scroll position in the view.

Return Value

The found Header object, or null (Nothing in Visual Basic) if there is no header located at the specified point.

See Also

GetHeaderFromPoint Method Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderLevel Method

Grid.GetHeaderLevel Method

Gets the level of the specified header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public int GetHeaderLevel (
Header header
)
Visual Basic

Public Function GetHeaderLevel ( _
header As Header _
) As Integer

Parameters

header

Return Value

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderParent Method

Grid.GetHeaderParent Method

Returns the header containing the specified header, or null, if the header is a top-level header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Header GetHeaderParent (
Header header
)
Visual Basic

Public Function GetHeaderParent ( _
header As Header _
) As Header

Parameters

header
The header whose parent is being searched for.

Return Value

The parent header.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetRow Method

Grid.GetRow Method

Returns the row header with the specified index from the bottommost row header level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Header GetRow (
int index
)
Visual Basic

Public Function GetRow ( _
index As Integer _
) As Header

Parameters

index
An integer value specifying the row index.

Return Value

A Header object representing the row at the specified index. A grid row that contains child rows cannot be accessed by index; only the bottommost child elements in the hierarchy are considered by this method.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetRowHeaderBounds Method

Grid.GetRowHeaderBounds Method

Returns the bounding rectangle of all row headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF GetRowHeaderBounds ()
Visual Basic

Public Function GetRowHeaderBounds () As RectangleF

Return Value

A RectangleF that bounds all row headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetRowIndex Method

Grid.GetRowIndex Method

Returns the 0-based index of the specified row.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public int GetRowIndex (
Header row
)
Visual Basic

Public Function GetRowIndex ( _
row As Header _
) As Integer

Parameters

row
A Header instance that represents a grid row.

Return Value

The index of row, or -1 if the specified header represents a column or a group of child rows.

Remarks

Only works for bottommost headers. If the specified row is a group header, returns -1.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.InsertAfter Method

Grid.InsertAfter Method

Inserts a new header after the specified header and returns a reference to it.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Header InsertAfter (
Header header
)
Visual Basic

Public Function InsertAfter ( _
header As Header _
) As Header

Parameters

header
The header after which to insert the new header.

Return Value

A reference to the newly created header.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace
InsertBefore Method


MindFusion.Diagramming.Lanes.Grid.InsertBefore Method

Grid.InsertBefore Method

Inserts a new header before the specified header and returns a reference to it.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Header InsertBefore (
Header header
)
Visual Basic

Public Function InsertBefore ( _
header As Header _
) As Header

Parameters

header
The header before which to insert the new header.

Return Value

A reference to the newly created header.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace
InsertAfter Method


MindFusion.Diagramming.Lanes.Grid.RaiseHeaderAdded Method

Grid.RaiseHeaderAdded Method

Raises the HeaderAdded event from outside the lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public void RaiseHeaderAdded (
Header header
)
Visual Basic

Public Sub RaiseHeaderAdded ( _
header As Header _
)

Parameters

header

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RaiseHeaderResized Method

Grid.RaiseHeaderResized Method

Raises the HeaderResized event from outside the lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public void RaiseHeaderResized (
Header header,
bool horizontal,
bool vertical
)
Visual Basic

Public Sub RaiseHeaderResized ( _
header As Header, _
horizontal As Boolean, _
vertical As Boolean _
)

Parameters

header
horizontal
vertical

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RaiseHeaderStartResizing Method

Grid.RaiseHeaderStartResizing Method

Raises the HeaderStartResizing event from outside the lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public void RaiseHeaderStartResizing (
Header header,
bool horizontal,
bool vertical
)
Visual Basic

Public Sub RaiseHeaderStartResizing ( _
header As Header, _
horizontal As Boolean, _
vertical As Boolean _
)

Parameters

header
horizontal
vertical

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.ResizeColumnHeaderHeights Method

Grid.ResizeColumnHeaderHeights Method

Resizes the heights of all column headers from the specified level with the specified amount.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public void ResizeColumnHeaderHeights (
int level,
float increase
)
Visual Basic

Public Sub ResizeColumnHeaderHeights ( _
level As Integer, _
increase As Single _
)

Parameters

level
increase

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.ResizeRowHeaderWidths Method

Grid.ResizeRowHeaderWidths Method

Resizes the widths of all row headers from the specified level with the specified amount.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public void ResizeRowHeaderWidths (
int level,
float increase
)
Visual Basic

Public Sub ResizeRowHeaderWidths ( _
level As Integer, _
increase As Single _
)

Parameters

level
increase

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Properties

Grid Properties

Public Properties

Name | Description
AlignCells | Gets or sets a value indicating whether cells are aligned one next to another so that their borders don't overlap.
AllowResizeHeaders | Gets or sets a value indicating whether users can resize the headers of the grid interactively.
ColumnCount | Gets or sets the number of columns in the grid.
ColumnHeaders | Gets the collection with the topmost column headers.
ColumnHeadersHeights | Gets or sets an array with float values specifying the heights of individual column levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.
HeadersOnTop | Gets or sets a value indicating whether lane headers appear at the top of the z-order above all other items.
HookHeaders | Gets or sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).
Item | Gets a cell or cluster of cells from the grid.
LeftMargin | Gets or sets the offset of the lane grid from the left side of the document bounds.
MinHeaderSize | Gets or sets the minimum size of a header.
RowCount | Gets or sets the number of rows in the grid.
RowHeaders | Gets the collection with the leftmost row headers.
RowHeadersWidths | Gets or sets an array with float values specifying the widths of individual row levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.
TopLeftAreaStyle | Gets or sets the style of the area above all row headers and to the left of all column headers.
TopLeftAreaText | Gets or sets the text displayed in the top left area.
TopLeftAreaTextColor | Gets or sets the color of the text displayed in the top left area.
TopLeftAreaTextFont | Gets or sets the font used to display text in the top left area.
TopLeftAreaTextFormat | Gets or sets the format of the text displayed in the top left area.
TopMargin | Gets or sets the offset of the lane grid from the top side of the document bounds.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.AlignCells Property

Grid.AlignCells Property

Gets or sets a value indicating whether cells are aligned one next to another so that their borders don't overlap.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AlignCells { get; set; }
Visual Basic

Public Property AlignCells As Boolean

Property Value

true to align cells; otherwise, false. The default is true.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.AllowResizeHeaders Property

Grid.AllowResizeHeaders Property

Gets or sets a value indicating whether users can resize the headers of the grid interactively.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AllowResizeHeaders { get; set; }
Visual Basic

Public Property AllowResizeHeaders As Boolean

Property Value

true to let users resize the grid elements; otherwise, false. The default is true.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.ColumnCount Property

Grid.ColumnCount Property

Gets or sets the number of columns in the grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public int ColumnCount { get; set; }
Visual Basic

Public Property ColumnCount As Integer

Property Value

An integer value indicating the number of columns in the grid.

Remarks

If a smaller value is assigned to this property, the control will reduce the number of child columns. If all child columns in a parent column are removed, the parent will be removed too. To have greater control over where in the hierarchy columns will be added or removed, use the ColumnHeaders and the SubHeaders properties.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace
RowCount Property
Item Property


MindFusion.Diagramming.Lanes.Grid.ColumnHeaders Property

Grid.ColumnHeaders Property

Gets the collection with the topmost column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public HeaderCollection ColumnHeaders { get; }
Visual Basic

Public ReadOnly Property ColumnHeaders As HeaderCollection

Property Value

An instance of the HeaderCollection class containing the topmost column headers.

Remarks

Adding headers to or removing them from this collection also adds or removes top-level columns. Columns can be further divided into child columns by adding to the SubHeaders collection of the Header that represents a parent column.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.ColumnHeadersHeights Property

Grid.ColumnHeadersHeights Property

Gets or sets an array with float values specifying the heights of individual column levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public float[] ColumnHeadersHeights { get; set; }
Visual Basic

Public Property ColumnHeadersHeights As Single()

Property Value

An array of float values where each value represents the height of an individual level of column headers.

Remarks

The first level of column headers is the one defined by the ColumnHeaders collection. Each next level is defnied by the SubHeaders collection of the headers in the upper level.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HeadersOnTop Property

Grid.HeadersOnTop Property

Gets or sets a value indicating whether lane headers appear at the top of the z-order above all other items.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public bool HeadersOnTop { get; set; }
Visual Basic

Public Property HeadersOnTop As Boolean

Property Value

true if lane headers should be displayed on top, otherwise false. The default is true.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HookHeaders Property

Grid.HookHeaders Property

Gets or sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public bool HookHeaders { get; set; }
Visual Basic

Public Property HookHeaders As Boolean

Property Value

true if lane headers should be anchored to their corresponding side; otherwise, false. The default is true.

Remarks

If this property is equal to false, the lane grid headers will follow the diagram scroll position, thus they might be hidden from view. Otherwise the headers will always be rendered in the currently visible area of the diagram, aligned to the ClientRectangle edges.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.Item Property

Grid.Item Property

Gets a cell or cluster of cells from the grid.

Overload List

Name | Description
Grid.Item (Header, Header) | Gets the cell or the cluster of cells corresponding to the specified row and column.
Grid.Item (Int32, Int32) | Gets the cell at the specified position.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.Item Property (Header, Header)

Grid.Item Property (Header, Header)
See Also

Gets the cell or the cluster of cells corresponding to the specified row and column.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public ICell Item [
Header column,
Header row
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
column As Header, _
row As Header _
) As ICell

Parameters

column
A Header object that represents the column of the cell to get.
row
A Header object that represents the row of the cell to get.

Property Value

An ICell instance representing all grid cell corresponding to the specified headers.

Remarks

If both Header parameters are null (Nothing in Visual Basic), a group containing all cells in the grid is returned. If only one of the Header parameters is null, the returned cell group contains all cells from the row or a column specified through the other parameter. This feature lets you set the Style of all cells in a group through a single assignment.

See Also

Item Property Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace
ColumnCount Property
RowCount Property


MindFusion.Diagramming.Lanes.Grid.Item Property (Int32, Int32)

Grid.Item Property (Int32, Int32)
See Also

Gets the cell at the specified position.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public ICell Item [
int column,
int row
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
column As Integer, _
row As Integer _
) As ICell

Parameters

column
An integer value that represents the column of the cell to get.
row
An integer value that represents the index of the row to get.

Property Value

An ICell instance representing the cell at the specified position.

See Also

Item Property Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace
ColumnCount Property
RowCount Property


MindFusion.Diagramming.Lanes.Grid.LeftMargin Property

Grid.LeftMargin Property

Gets or sets the offset of the lane grid from the left side of the document bounds.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public float LeftMargin { get; set; }
Visual Basic

Public Property LeftMargin As Single

Property Value

A float value specifying the left margin size in MeasureUnit.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.MinHeaderSize Property

Grid.MinHeaderSize Property

Gets or sets the minimum size of a header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public float MinHeaderSize { get; set; }
Visual Basic

Public Property MinHeaderSize As Single

Property Value

A float value specifying the minimal size of a header. The default is 10.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RowCount Property

Grid.RowCount Property

Gets or sets the number of rows in the grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public int RowCount { get; set; }
Visual Basic

Public Property RowCount As Integer

Property Value

An integer value indicating the number of rows in the grid.

Remarks

If a smaller value is assigned to this property, the control will reduce the number of child rows. If all child rows in a parent row are removed, the parent will be removed too. To have greater control over where in the hierarchy rows will be added or removed, use the RowHeaders and the SubHeaders properties.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RowHeaders Property

Grid.RowHeaders Property

Gets the collection with the leftmost row headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public HeaderCollection RowHeaders { get; }
Visual Basic

Public ReadOnly Property RowHeaders As HeaderCollection

Property Value

An instance of the HeaderCollection class containing the leftmost row headers.

Remarks

Adding headers to or removing them from this collection also adds or removes top-level rows. Rows can be further divided into child rows by adding to the SubHeaders collection of the Header that represents a parent row.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RowHeadersWidths Property

Grid.RowHeadersWidths Property

Gets or sets an array with float values specifying the widths of individual row levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public float[] RowHeadersWidths { get; set; }
Visual Basic

Public Property RowHeadersWidths As Single()

Property Value

An array of float values where each value represents the width of an individual level of row headers.

Remarks

The first level of row headers is the one defined by the RowHeaders collection. Each next level is defnied by the SubHeaders collection of the headers in the upper level.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopLeftAreaStyle Property

Grid.TopLeftAreaStyle Property

Gets or sets the style of the area above all row headers and to the left of all column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Style TopLeftAreaStyle { get; set; }
Visual Basic

Public Property TopLeftAreaStyle As Style

Property Value

An instance of the Style class specifying how to paint the top left corner. The default value is null (Nothing in Visual Basic).

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopLeftAreaText Property

Grid.TopLeftAreaText Property

Gets or sets the text displayed in the top left area.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public string TopLeftAreaText { get; set; }
Visual Basic

Public Property TopLeftAreaText As String

Property Value

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopLeftAreaTextColor Property

Grid.TopLeftAreaTextColor Property

Gets or sets the color of the text displayed in the top left area.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Color TopLeftAreaTextColor { get; set; }
Visual Basic

Public Property TopLeftAreaTextColor As Color

Property Value

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopLeftAreaTextFont Property

Grid.TopLeftAreaTextFont Property

Gets or sets the font used to display text in the top left area.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Font TopLeftAreaTextFont { get; set; }
Visual Basic

Public Property TopLeftAreaTextFont As Font

Property Value

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopLeftAreaTextFormat Property

Grid.TopLeftAreaTextFormat Property

Gets or sets the format of the text displayed in the top left area.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public StringFormat TopLeftAreaTextFormat { get; set; }
Visual Basic

Public Property TopLeftAreaTextFormat As StringFormat

Property Value

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopMargin Property

Grid.TopMargin Property

Gets or sets the offset of the lane grid from the top side of the document bounds.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public float TopMargin { get; set; }
Visual Basic

Public Property TopMargin As Single

Property Value

A float value specifying the top margin size in MeasureUnit.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Events

Grid Events

Public Events

Name | Description
CellBoundsChanged | Raised when the bounding rectangle of a cell has been changed.
HeaderAdded | Raised when a header has been inserted into the grid, either interactively or through a call to the InsertBefore or InsertAfter methods.
HeaderResized | Raised when the user finishes resizing a header.
HeaderStartResizing | Raises when the user starts resizing a header.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.CellBoundsChanged Event

Grid.CellBoundsChanged Event

Raised when the bounding rectangle of a cell has been changed.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public event CellBoundsEventHandler CellBoundsChanged
Visual Basic

Public Event CellBoundsChanged As CellBoundsEventHandler

Event Data

CellBoundsChanged event handlers receive an argument of type CellBoundsEventArgs.

Remarks

By default, diagram items are not affected by resizing cells in the lanes grid. By handling this event, you can move or resize items so that they stay aligned to their enclosing grid elements, as suits your application logic.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HeaderAdded Event

Grid.HeaderAdded Event

Raised when a header has been inserted into the grid, either interactively or through a call to the InsertBefore or InsertAfter methods.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public event EventHandler<HeaderEventArgs> HeaderAdded
Visual Basic

Public Event HeaderAdded As EventHandler(Of HeaderEventArgs)

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HeaderResized Event

Grid.HeaderResized Event

Raised when the user finishes resizing a header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public event EventHandler<HeaderResizeEventArgs> HeaderResized
Visual Basic

Public Event HeaderResized As EventHandler(Of HeaderResizeEventArgs)

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace
HeaderStartResizing Event


MindFusion.Diagramming.Lanes.Grid.HeaderStartResizing Event

Grid.HeaderStartResizing Event

Raises when the user starts resizing a header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public event EventHandler<HeaderResizeEventArgs> HeaderStartResizing
Visual Basic

Public Event HeaderStartResizing As EventHandler(Of HeaderResizeEventArgs)

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace
HeaderResized Event


MindFusion.Diagramming.Lanes.Header Class

Header Class
Remarks See Also

Represents a header in a grid view.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public class Header : IPersists
Visual Basic

Public Class Header
Implements IPersists

Remarks

The Header class provides the properties to define and adjust headers in the lanes grid.

The size of a header can be set through the Height and Width properties. Note that the size of the rows and columns in the grid is controlled through the size of their headers. The SubHeaders property lets you add child rows or columns to the grid. The ResizeType property is used to specify how to resize child columns and rows when the topmost headers are resized. The possible values for the ResizeType property are defined in the ResizeType enumeration.

In order to specify the color, font or alignment of the header Title, set the TitleColor, TitleFont or TitleFormat properties.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Lanes.Header

See Also

Header Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Members

Header Members
Constructors Properties

Represents a header in a grid view.

The following tables list the members exposed by the Header type.

Public Constructors

Name | Description
Header | Overloaded. Initializes a new instance of the Header class.

Public Properties

Name | Description
Height | Gets or sets the height of this header.
IsColumnHeader | Gets a value indicating whether this header is a column header.
IsRowHeader | Gets a value indicating whether this header is a row header.
ResizeType | Gets or sets how a row or a column is resized relatively to its parent.
RotateTitle | Gets or sets a value indicating whether to rotate the header caption at 90 degree.
Style | Gets or sets the style of this header.
SubHeaders | Gets a collection of the subheaders of this header.
Title | Gets or sets the header caption.
TitleColor | Gets or sets the color of the header caption.
TitleFont | Gets or sets the font of the header caption.
TitleFormat | Gets or sets the alignment of the header caption.
Width | Gets or sets the width of this header.

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Constructor

Header Constructor

Initializes a new instance of the Header class.

Overload List

Name | Description
Header () | Initializes a new instance of the Header class.
Header (String) | Initializes a new instance of the Header class with the specified title.

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Constructor ()

Header Constructor ()
See Also

Initializes a new instance of the Header class.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Header ()
Visual Basic

Public Sub New ()

See Also

Header Constructor Overload List
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Constructor (String)

Header Constructor (String)
See Also

Initializes a new instance of the Header class with the specified title.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Header (
string title
)
Visual Basic

Public New ( _
title As String _
)

Parameters

title
A string value that represents the title for this Header object.

See Also

Header Constructor Overload List
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Properties

Header Properties

Public Properties

Name | Description
Height | Gets or sets the height of this header.
IsColumnHeader | Gets a value indicating whether this header is a column header.
IsRowHeader | Gets a value indicating whether this header is a row header.
ResizeType | Gets or sets how a row or a column is resized relatively to its parent.
RotateTitle | Gets or sets a value indicating whether to rotate the header caption at 90 degree.
Style | Gets or sets the style of this header.
SubHeaders | Gets a collection of the subheaders of this header.
Title | Gets or sets the header caption.
TitleColor | Gets or sets the color of the header caption.
TitleFont | Gets or sets the font of the header caption.
TitleFormat | Gets or sets the alignment of the header caption.
Width | Gets or sets the width of this header.

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.Height Property

Header.Height Property

Gets or sets the height of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public float Height { get; set; }
Visual Basic

Public Property Height As Single

Property Value

A float value specifying the header height. The default is 0.

Remarks

If this is a row header, the property specifies the height of the whole row.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.IsColumnHeader Property

Header.IsColumnHeader Property

Gets a value indicating whether this header is a column header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool IsColumnHeader { get; }
Visual Basic

Public Overridable ReadOnly Property IsColumnHeader As Boolean

Property Value

true if the header is a column header; otherwise, false.

Remarks

Both IsColumnHeader and IsRowHeader return false if the header is not attached to a lane grid.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace
IsRowHeader Property


MindFusion.Diagramming.Lanes.Header.IsRowHeader Property

Header.IsRowHeader Property

Gets a value indicating whether this header is a row header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool IsRowHeader { get; }
Visual Basic

Public Overridable ReadOnly Property IsRowHeader As Boolean

Property Value

true if the header is a row header; otherwise, false.

Remarks

Both IsColumnHeader and IsRowHeader return false if the header is not attached to a lane grid.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace
IsColumnHeader Property


MindFusion.Diagramming.Lanes.Header.ResizeType Property

Header.ResizeType Property

Gets or sets how a row or a column is resized relatively to its parent.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public ResizeType ResizeType { get; set; }
Visual Basic

Public Property ResizeType As ResizeType

Property Value

A member of the ResizeType enumeration. The default is Proportional.

Remarks

When a topmost header is resized, the child elements of the row or column related to the header either keep their size or are resized as set through this property.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace
SubHeaders Property


MindFusion.Diagramming.Lanes.Header.RotateTitle Property

Header.RotateTitle Property

Gets or sets a value indicating whether to rotate the header caption at 90 degree.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RotateTitle { get; set; }
Visual Basic

Public Property RotateTitle As Boolean

Property Value

true if the title should be rotated; otherwise, false. The default is false.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.Style Property

Header.Style Property

Gets or sets the style of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Style Style { get; set; }
Visual Basic

Public Property Style As Style

Property Value

An instance of the Style class that specifies the appearance of the header.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.SubHeaders Property

Header.SubHeaders Property

Gets a collection of the subheaders of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public HeaderCollection SubHeaders { get; }
Visual Basic

Public ReadOnly Property SubHeaders As HeaderCollection

Property Value

An instance of the HeaderCollection class.

Remarks

Adding SubHeaders to a row header creates child rows controlled through the same parent header. In the same way you can add child columns to a column by adding SubHeaders to the column header.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.Title Property

Header.Title Property

Gets or sets the header caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public string Title { get; set; }
Visual Basic

Public Property Title As String

Property Value

A string containing the caption text. The default is an empty string.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.TitleColor Property

Header.TitleColor Property

Gets or sets the color of the header caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Color TitleColor { get; set; }
Visual Basic

Public Property TitleColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.Black.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.TitleFont Property

Header.TitleFont Property

Gets or sets the font of the header caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Font TitleFont { get; set; }
Visual Basic

Public Property TitleFont As Font

Property Value

An instance of the .NET Font class. The default is null (Nothing in Visual Basic).

Remarks

If this property is set to null, the header text will be rendered using the diagram's Font.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.TitleFormat Property

Header.TitleFormat Property

Gets or sets the alignment of the header caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public StringFormat TitleFormat { get; set; }
Visual Basic

Public Property TitleFormat As StringFormat

Property Value

An instance of the .NET StringFormat class. The default is null (Nothing in Visual Basic).

Remarks

Set this property to null to use the default (centered) alignment.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.Width Property

Header.Width Property

Gets or sets the width of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public float Width { get; set; }
Visual Basic

Public Property Width As Single

Property Value

A float value specifying the header width. The default is 0.

Remarks

If this is a column header, the property specifies the width of the whole column.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection Class

HeaderCollection Class
Remarks See Also

Represents a strongly typed collection of Header objects.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public class HeaderCollection : CollectionBase, IPersists
Visual Basic

Public Class HeaderCollection
Inherits CollectionBase
Implements IPersists

Remarks

The ColumnHeaders and RowHeaders properties of the Grid class are of this collection type. Adding or removing headers to them automatically adds or removes parent columns and rows to the grid. Adding to or removing form the SubHeaders property of the Header class automatically adds or removes child columns or rows.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.Lanes.HeaderCollection

See Also

HeaderCollection Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection Members

HeaderCollection Members
Properties Methods

Represents a strongly typed collection of Header objects.

The following tables list the members exposed by the HeaderCollection type.

Public Properties

Name | Description
Item | Gets or sets the Header at the specified position.

Public Methods

Name | Description
Add | Adds the specified header to the collection.
Clear | Removes all headers from the collection.
Contains | Checks whether a Header is in the collection.
IndexOf | Gets the index of the specified header within this collection.
Insert | Inserts the specified Header at the specified position within the HeaderCollection.
Remove | Removes the first occurrence of the specified Header from the collection.
RemoveAt | Removes the Header at the specified position within the collection.

See Also

HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection Methods

HeaderCollection Methods

Public Methods

Name | Description
Add | Adds the specified header to the collection.
Clear | Removes all headers from the collection.
Contains | Checks whether a Header is in the collection.
IndexOf | Gets the index of the specified header within this collection.
Insert | Inserts the specified Header at the specified position within the HeaderCollection.
Remove | Removes the first occurrence of the specified Header from the collection.
RemoveAt | Removes the Header at the specified position within the collection.

See Also

HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Add Method

HeaderCollection.Add Method

Adds the specified header to the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public int Add (
Header header
)
Visual Basic

Public Function Add ( _
header As Header _
) As Integer

Parameters

header
The Header object to add.

Return Value

The index at which the header was added in the collection.

Remarks

The method adds a Header object to the end of the collection. If you need to place the Header at a certain position, use the Insert method instead.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Clear Method

HeaderCollection.Clear Method

Removes all headers from the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Contains Method

HeaderCollection.Contains Method

Checks whether a Header is in the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Contains (
Header header
)
Visual Basic

Public Function Contains ( _
header As Header _
) As Boolean

Parameters

header

The Header to locate in the collection.

Return Value

true if the header was found in the collection; otherwise, false.

Remarks

Call the method to determine whether a Header is contained within the collection. If not, you can add it with the Add method. Otherwise, if it is there, you can remove it with Remove.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.IndexOf Method

HeaderCollection.IndexOf Method

Gets the index of the specified header within this collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public int IndexOf (
Header header
)
Visual Basic

Public Function IndexOf ( _
header As Header _
) As Integer

Parameters

header
The Header to locate in the HeaderCollection. The value can be a null reference (Nothing in Visual Basic).

Return Value

The zero-based index of the first occurrence of value within the entire HeaderCollection, if found; otherwise, -1.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Insert Method

HeaderCollection.Insert Method

Inserts the specified Header at the specified position within the HeaderCollection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public void Insert (
int index,
Header header
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
header As Header _
)

Parameters

index
The zero-based index at which the Header should be inserted.
header
The Header object to insert.

Remarks

Use this method to insert Header objects at a specific position in the collection. If you do not need to specify header's position, use the Add method instead, which adds new headers to the end of the list.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Remove Method

HeaderCollection.Remove Method

Removes the first occurrence of the specified Header from the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public void Remove (
Header header
)
Visual Basic

Public Sub Remove ( _
header As Header _
)

Parameters

header
The Header object to remove.

Remarks

Use this method to remove headers from the collection. Headers can be added to the collection with the Add or Insert methods.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.RemoveAt Method

HeaderCollection.RemoveAt Method

Removes the Header at the specified position within the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public new void RemoveAt (
int index
)
Visual Basic

Public Shadows Sub RemoveAt ( _
index As Integer _
)

Parameters

index
The index at which the Header object should be removed.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection Properties

HeaderCollection Properties

Public Properties

Name | Description
Item | Gets or sets the Header at the specified position.

See Also

HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Item Property

HeaderCollection.Item Property

Gets or sets the Header at the specified position.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Header Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Header

Parameters

index
The 0-based index of the Header to get.

Property Value

An instance of the Header class that represents the header at the specified position.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderEventArgs Class

HeaderEventArgs Class

Contains the arguments passed to handlers of header-related events.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public class HeaderEventArgs : EventArgs
Visual Basic

Public Class HeaderEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Lanes.HeaderEventArgs
MindFusion.Diagramming.Lanes.HeaderResizeEventArgs

See Also

HeaderEventArgs Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderEventArgs Members

HeaderEventArgs Members
Properties

Contains the arguments passed to handlers of header-related events.

The following tables list the members exposed by the HeaderEventArgs type.

Public Properties

Name | Description
Header | Gets or sets the header related to the event.

See Also

HeaderEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderEventArgs Properties

HeaderEventArgs Properties

Public Properties

Name | Description
Header | Gets or sets the header related to the event.

See Also

HeaderEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderEventArgs.Header Property

HeaderEventArgs.Header Property

Gets or sets the header related to the event.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Header Header { get; set; }
Visual Basic

Public Property Header As Header

Property Value

See Also

HeaderEventArgs Members
HeaderEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderResizeEventArgs Class

HeaderResizeEventArgs Class

Contains the arguments passed to handlers of header resize events.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public class HeaderResizeEventArgs : HeaderEventArgs
Visual Basic

Public Class HeaderResizeEventArgs
Inherits HeaderEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Lanes.HeaderEventArgs
MindFusion.Diagramming.Lanes.HeaderResizeEventArgs

See Also

HeaderResizeEventArgs Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderResizeEventArgs Members

HeaderResizeEventArgs Members
Properties

Contains the arguments passed to handlers of header resize events.

The following tables list the members exposed by the HeaderResizeEventArgs type.

Public Properties

Name | Description
IsHorizontal | Gets a value indicating whether the user resizes the header horizontally.
IsVertical | Gets a value indicating whether the user resizes the header vertically.

See Also

HeaderResizeEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderResizeEventArgs Properties

HeaderResizeEventArgs Properties

Public Properties

Name | Description
IsHorizontal | Gets a value indicating whether the user resizes the header horizontally.
IsVertical | Gets a value indicating whether the user resizes the header vertically.

See Also

HeaderResizeEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderResizeEventArgs.IsHorizontal Property

HeaderResizeEventArgs.IsHorizontal Property

Gets a value indicating whether the user resizes the header horizontally.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public bool IsHorizontal { get; }
Visual Basic

Public ReadOnly Property IsHorizontal As Boolean

Property Value

See Also

HeaderResizeEventArgs Members
HeaderResizeEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderResizeEventArgs.IsVertical Property

HeaderResizeEventArgs.IsVertical Property

Gets a value indicating whether the user resizes the header vertically.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public bool IsVertical { get; }
Visual Basic

Public ReadOnly Property IsVertical As Boolean

Property Value

See Also

HeaderResizeEventArgs Members
HeaderResizeEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell Interface

ICell Interface

Defines a base for cells in a lane list.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public interface ICell
Visual Basic

Public Interface ICell

See Also

ICell Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell Members

ICell Members
Properties

Defines a base for cells in a lane list.

The following tables list the members exposed by the ICell type.

Public Properties

Name | Description
Style | Gets or sets the Style of the cell or group of cells.
Text | Gets or sets the text of the cell or group of cells.
TextColor | Gets or sets the text color of the cell or group of cells.
TextFont | Gets or sets the font of the cell or group of cells.
TextFormat | Gets or sets the text format of the cell or group of cells.

See Also

ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell Properties

ICell Properties

Public Properties

Name | Description
Style | Gets or sets the Style of the cell or group of cells.
Text | Gets or sets the text of the cell or group of cells.
TextColor | Gets or sets the text color of the cell or group of cells.
TextFont | Gets or sets the font of the cell or group of cells.
TextFormat | Gets or sets the text format of the cell or group of cells.

See Also

ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell.Style Property

ICell.Style Property

Gets or sets the Style of the cell or group of cells.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract Style Style { get; set; }
Visual Basic

Public MustOverride Property Style As Style

Property Value

An instance of the Lanes.Style class that specifies the style of this cell.

Remarks

The Item property of the Grid class lets you access a group of cells through a single ICell reference, which lets you set the style of all cells in the group with a single assignment.

Example

The following statement sets the brush for all cells in the specified column:

C#

diagram.LaneGrid[column, null].Style.BackgroundBrush =
new MindFusion.Drawing.SolidBrush(Color.PaleGoldenrod);
Visual Basic

diagram.LaneGrid(column, Nothing).Style.BackgroundBrush = _
new MindFusion.Drawing.SolidBrush(Color.PaleGoldenrod)

See Also

ICell Members
ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell.Text Property

ICell.Text Property

Gets or sets the text of the cell or group of cells.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract string Text { get; set; }
Visual Basic

Public MustOverride Property Text As String

Property Value

Remarks

The Item property of the Grid class lets you access a group of cells through a single ICell reference, which lets you set the text of all cells in the group with a single assignment.

See Also

ICell Members
ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell.TextColor Property

ICell.TextColor Property

Gets or sets the text color of the cell or group of cells.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract Color TextColor { get; set; }
Visual Basic

Public MustOverride Property TextColor As Color

Property Value

Remarks

The Item property of the Grid class lets you access a group of cells through a single ICell reference, which lets you set the text color of all cells in the group with a single assignment.

See Also

ICell Members
ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell.TextFont Property

ICell.TextFont Property

Gets or sets the font of the cell or group of cells.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract Font TextFont { get; set; }
Visual Basic

Public MustOverride Property TextFont As Font

Property Value

Remarks

The Item property of the Grid class lets you access a group of cells through a single ICell reference, which lets you set the font of all cells in the group with a single assignment.

See Also

ICell Members
ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell.TextFormat Property

ICell.TextFormat Property

Gets or sets the text format of the cell or group of cells.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract StringFormat TextFormat { get; set; }
Visual Basic

Public MustOverride Property TextFormat As StringFormat

Property Value

Remarks

The Item property of the Grid class lets you access a group of cells through a single ICell reference, which lets you set the text format of all cells in the group with a single assignment.

See Also

ICell Members
ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ResizeType Enumeration

ResizeType Enumeration

Specifies how to resize child columns and rows in the lanes grid when their parent column or row is resized.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public enum ResizeType
Visual Basic

Public Enumeration ResizeType

Members

Member name | Description
Fixed | The header's size (width or height) is fixed and does not change when its parent header is being resized unless all its siblings have fixed size too.
Proportional | The header resizes in proportion to its parent header.

Remarks

This enumeration specifies the possible values of the ResizeType property of the Header class.

See Also

MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Class

Style Class

Encapsulates the appearance properties of an element in a lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public class Style : IPersists
Visual Basic

Public Class Style
Implements IPersists

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Lanes.Style

See Also

Style Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Members

Style Members
Constructors Properties

Encapsulates the appearance properties of an element in a lane grid.

The following tables list the members exposed by the Style type.

Public Constructors

Name | Description
Style | Initializes a new instance of the Style class.

Public Properties

Name | Description
BackgroundBrush | Gets or sets the background Brush of this style.
BottomBorderPen | Gets or sets the Pen for drawing the bottom border for this style.
LeftBorderPen | Gets or sets the Pen for drawing the left border for this style.
RightBorderPen | Gets or sets the Pen for drawing the right border for this style.
TopBorderPen | Gets or sets the Pen for drawing the top border for this style.

See Also

Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Constructor

Style Constructor

Initializes a new instance of the Style class.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public Style ()
Visual Basic

Public Sub New ()

See Also

Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Properties

Style Properties

Public Properties

Name | Description
BackgroundBrush | Gets or sets the background Brush of this style.
BottomBorderPen | Gets or sets the Pen for drawing the bottom border for this style.
LeftBorderPen | Gets or sets the Pen for drawing the left border for this style.
RightBorderPen | Gets or sets the Pen for drawing the right border for this style.
TopBorderPen | Gets or sets the Pen for drawing the top border for this style.

See Also

Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.BackgroundBrush Property

Style.BackgroundBrush Property

Gets or sets the background Brush of this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Brush BackgroundBrush { get; set; }
Visual Basic

Public Overridable Property BackgroundBrush As Brush

Property Value

An instance of the MindFusion.Drawing.Brush class.

Remarks

You can assign to this property an instance of one of the following classes: HatchBrush, LinearGradientBrush, PathGradientBrush, SolidBrush or TextureBrush, located in the MindFusion.Drawing namespace.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.BottomBorderPen Property

Style.BottomBorderPen Property

Gets or sets the Pen for drawing the bottom border for this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Pen BottomBorderPen { get; set; }
Visual Basic

Public Overridable Property BottomBorderPen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class.

Remarks

The property refers to a Pen used to paint the bottom border of a cell.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.LeftBorderPen Property

Style.LeftBorderPen Property

Gets or sets the Pen for drawing the left border for this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Pen LeftBorderPen { get; set; }
Visual Basic

Public Overridable Property LeftBorderPen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class.

Remarks

The property refers to a Pen used for painting the left border of a cell.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.RightBorderPen Property

Style.RightBorderPen Property

Gets or sets the Pen for drawing the right border for this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Pen RightBorderPen { get; set; }
Visual Basic

Public Overridable Property RightBorderPen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class.

Remarks

The property refers to the Pen used for painting the right border of a cell.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.TopBorderPen Property

Style.TopBorderPen Property

Gets or sets the Pen for drawing the top border for this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual Pen TopBorderPen { get; set; }
Visual Basic

Public Overridable Property TopBorderPen As Pen

Property Value

An instance of the MindFusion.Drawing.Pen class.

Remarks

The property refers to the Pen used for painting the top border of a cell.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Layout Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
AnnealLayout | Implements a simulated annealing graph layout algorithm.
CircularLayout | Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.
FlowLayout | Implements a flowchart, workflow and process diagrams layout algorithm.
GridLayout | Implements a grid graph layout algorithm.
LayeredLayout | Implements a layered graph layout algorithm.
Layout | The base class for all layout classes.
OrthogonalLayout | Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.
OrthogonalRouter | Implements an orthogonal link routing algorithm.
SpringLayout | Implements the Spring-Embedder graph layout algorithm.
TreeLayout | Implements several algorithms for arranging tree structures.

Interfaces

Interface | Description
ILayout | Common interface for all MindFusion.Diagramming layouters.

Delegates

Delegate | Description
LayoutLink | Represents methods that are called by the layout algorithms when the position of a link changes.
LayoutNode | Represents methods that are called by the layout algorithms when the position of a node changes.
LayoutProgress | Represents methods that are called to report on progress of layout algorithms.

Enumerations

Enumeration | Description
Direction | Specifies a layout direction.
LaneType | Specifies where FlowLayout gets the swimlane dimensions from.
LayeredLayoutLinkType | Specifies the style of the links after they are laid out.
MultipleGraphsPlacement | Specifies graph orientation.
Orientation | Specifies axial orientation.
TreeLayoutBalance | Specifies how to order child nodes in order to produce tree layouts with custom balance.
TreeLayoutDirections | Specifies the direction of a tree layout.
TreeLayoutLinkType | Specifies the style of the diagram links after they are laid out.
TreeLayoutType | Specifies the type of a tree layout.


MindFusion.Diagramming.Layout.AnnealLayout Class

AnnealLayout Class
Remarks See Also

Implements a simulated annealing graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class AnnealLayout : Layout
Visual Basic

Public Class AnnealLayout
Inherits Layout

Remarks

Simulated Annealing is a general-purpose optimization method used to solve large-scale combinatorial problems by simulating the process of heating and cooling of metal to achieve freedom from defects. Finding a nice arrangement of a graph is a combinatorial problem that can be reduced to assigning costs to graph configurations and finding the minimum cost configuration. In that case, a cost is assigned to a graph configuration by evaluating different aesthetic criteria such as distance between nodes, length of links and the number of link crossings.

The AnnealLayout class implements a Simulated Annealing graph layout algorithm that can be used to arrange MindFusion.Diagramming diagrams. To arrange a diagram, create an AnnealLayout instance, set its properties and call the Arrange method.

The algorithm starts the simulation with the temperature set in InitialTemperature, and runs several cooling Stages. At each stage the algorithm evaluates several graph configurations for each node, as set in IterationsPerStage. At the end of each stage, the algorithm selects the configuration that has a minimum cost and decreases the temperature by multiplying it by TemperatureScale. The relative weight of an aesthetic criterion relative to the other criteria is set by the DistributionFactor, LinkLengthFactor, BoundaryFactor and CrossingLinksCost properties.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.AnnealLayout

See Also

AnnealLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Members

AnnealLayout Members
Constructors Properties Methods

Implements a simulated annealing graph layout algorithm.

The following tables list the members exposed by the AnnealLayout type.

Public Constructors

Name | Description
AnnealLayout | Initializes a new instance of the AnnealLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes.
BoundaryFactor | Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.
CrossingLinksCost | Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.
DistributionFactor | Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.
GatherStatistics |
InitialTemperature | Gets or sets the initial temperature of the simulated annealing process.
IterationsPerStage | Gets or sets how many node shift iterations to perform at each stage of the algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
LinkLengthFactor | Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.
NodeLinkCrossingCost | Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.
NodeLinkDistFactor | Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.
Randomize | Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stages | Gets or sets how many cool-down stages the algorithm should simulate.
Statistics |
TemperatureScale | Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.
WidthHeightRatio | Gets or sets what width/height ratio the layout area should have.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout.
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution started with a call to BeginArrange.
Iterate | Runs one or more layout iterations.

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Constructor

AnnealLayout Constructor

Initializes a new instance of the AnnealLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public AnnealLayout ()
Visual Basic

Public Sub New ()

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Methods

AnnealLayout Methods

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout.
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution started with a call to BeginArrange.
Iterate | Runs one or more layout iterations.

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Arrange Method

AnnealLayout.Arrange Method

Applies the layout.

Overload List

Name | Description
AnnealLayout.Arrange (Diagram) | Applies the layout on the specified Diagram instance.
AnnealLayout.Arrange (Diagram, DiagramItemCollection) | Applies the layout on the specified subset of items from the specified Diagram instance.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Arrange Method (Diagram)

AnnealLayout.Arrange Method (Diagram)
See Also

Applies the layout on the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram _
) As Boolean

Parameters

diagram
The Diagram that will be arranged.

Return Value

This method always returns true.

See Also

Arrange Method Overload List
AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Arrange Method (Diagram, DiagramItemCollection)

AnnealLayout.Arrange Method (Diagram, DiagramItemCollection)
See Also

Applies the layout on the specified subset of items from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram,
DiagramItemCollection items
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that will be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

This method always returns true.

See Also

Arrange Method Overload List
AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.BeginArrange Method

AnnealLayout.BeginArrange Method

Initializes the layout object for a step-by-step execution.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool BeginArrange (
Diagram diagram,
DiagramItemCollection items
)
Visual Basic

Public Function BeginArrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that will be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the layout object has been initialized successfully; otherwise, false.

Remarks

You can use this method together with Iterate and EndArrange to display an animation of the layout process. To run all iterations of the proces at once and display just the end result, call Arrange.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.EndArrange Method

AnnealLayout.EndArrange Method

Completes the step-by-step execution started with a call to BeginArrange.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public void EndArrange ()
Visual Basic

Public Sub EndArrange ()

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Iterate Method

AnnealLayout.Iterate Method

Runs one or more layout iterations.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public void Iterate (
int iterationFrom,
int iterationTo
)
Visual Basic

Public Sub Iterate ( _
iterationFrom As Integer, _
iterationTo As Integer _
)

Parameters

iterationFrom
Specifies from which iteration to start.
iterationTo
Specifies at which iteration to stop.

Remarks

Use this method to create an animation of the layout process, for example, by calling it from a timer. Call BeginArrange to prepare the layout object for use of Iterate, and call EndArrange when done. Each call to Iterate should start from the iteration next to the one where the previous call has stopped.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Properties

AnnealLayout Properties

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes.
BoundaryFactor | Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.
CrossingLinksCost | Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.
DistributionFactor | Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.
GatherStatistics |
InitialTemperature | Gets or sets the initial temperature of the simulated annealing process.
IterationsPerStage | Gets or sets how many node shift iterations to perform at each stage of the algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
LinkLengthFactor | Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.
NodeLinkCrossingCost | Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.
NodeLinkDistFactor | Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.
Randomize | Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stages | Gets or sets how many cool-down stages the algorithm should simulate.
Statistics |
TemperatureScale | Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.
WidthHeightRatio | Gets or sets what width/height ratio the layout area should have.

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Anchoring Property

AnnealLayout.Anchoring Property

Gets or sets a value indicating how to align links to the anchor points of graph nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Anchoring Anchoring { get; set; }
Visual Basic

Public Property Anchoring As Anchoring

Property Value

A member of the Anchoring enumeration. The default is Ignore.

Remarks

The layout algorithm produces best results if it can place link ends at arbitrary positions over the nodes outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.BoundaryFactor Property

AnnealLayout.BoundaryFactor Property

Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double BoundaryFactor { get; set; }
Visual Basic

Public Property BoundaryFactor As Double

Property Value

A double multiplier applied to the node-to-boundary distance cost when evaluating the total cost of a graph configuration. The default is 3000.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which nodes are placed farther from the layout area bounds, that is, nodes will tend to gather in the center of the layout area.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
LinkLengthFactor Property
DistributionFactor Property


MindFusion.Diagramming.Layout.AnnealLayout.CrossingLinksCost Property

AnnealLayout.CrossingLinksCost Property

Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double CrossingLinksCost { get; set; }
Visual Basic

Public Property CrossingLinksCost As Double

Property Value

A double value added to the total cost of a graph configuration for each pair of crossing links. The default is 120000.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations with fewer link crossings.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
LinkLengthFactor Property


MindFusion.Diagramming.Layout.AnnealLayout.DistributionFactor Property

AnnealLayout.DistributionFactor Property

Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double DistributionFactor { get; set; }
Visual Basic

Public Property DistributionFactor As Double

Property Value

A double multiplier applied to the node distribution cost when evaluating the total cost of a graph configuration. The default is 40000.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which the nodes are placed farther one from another.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
LinkLengthFactor Property
BoundaryFactor Property


MindFusion.Diagramming.Layout.AnnealLayout.GatherStatistics Property

AnnealLayout.GatherStatistics Property

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool GatherStatistics { get; set; }
Visual Basic

Public Property GatherStatistics As Boolean

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.InitialTemperature Property

AnnealLayout.InitialTemperature Property

Gets or sets the initial temperature of the simulated annealing process.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double InitialTemperature { get; set; }
Visual Basic

Public Property InitialTemperature As Double

Property Value

A double value specifying the initial temperature of the simulation. The default is 40.

Remarks

A low initial temperature prevents nodes from moving far from their initial position. If you need the final arrangement to have resemblance to the initial formation of the graph elements, set a lower initial temperature and disable Randomize.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
TemperatureScale Property


MindFusion.Diagramming.Layout.AnnealLayout.IterationsPerStage Property

AnnealLayout.IterationsPerStage Property

Gets or sets how many node shift iterations to perform at each stage of the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public int IterationsPerStage { get; set; }
Visual Basic

Public Property IterationsPerStage As Integer

Property Value

An integer value specifying the number of node shift iterations. The default is 50.

Remarks

IterationsPerStage specifies how many node configurations to evaluate at each stage of the temperature cool-down simulation. More iterations will yield better layouts but require more time to complete.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
Progress Property
Stages Property


MindFusion.Diagramming.Layout.AnnealLayout.KeepGroupLayout Property

AnnealLayout.KeepGroupLayout Property

Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool KeepGroupLayout { get; set; }
Visual Basic

Public Property KeepGroupLayout As Boolean

Property Value

true if each Group should be processed as an integral graph node; otherwise, false. The default is false.

Remarks

Enabling this property has an effect similar to setting the IgnoreLayout property of group's subordinated nodes to true. The two methods differ in how the size of the graph node corresponding to a group is calculated. If KeepGroupLayout is enabled, the union of all bounding rectangles of grouped items is used to determine the size of the graph node. When the IgnoreLayout property of subordinated items is enabled, the bounding rectangle of the main node defines the size of the graph node corresponding to the group.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
AttachTo Method


MindFusion.Diagramming.Layout.AnnealLayout.LayoutArea Property

AnnealLayout.LayoutArea Property

Gets or sets the size of the layout area.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF LayoutArea { get; set; }
Visual Basic

Public Property LayoutArea As RectangleF

Property Value

A .NET RectangleF representing the boundaries of the layout area. The default is RectangleF.Empty.

Remarks

If the layout area is not explicitly set, the algorithm will choose one suitable for the graph size. In that case the WidthHeightRatio property specifies how much larger the layout area width should be than its height.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.LayoutLink Property

AnnealLayout.LayoutLink Property

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutLink LayoutLink { get; set; }
Visual Basic

Public Overridable Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.LayoutNode Property

AnnealLayout.LayoutNode Property

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutNode LayoutNode { get; set; }
Visual Basic

Public Overridable Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.LinkLengthFactor Property

AnnealLayout.LinkLengthFactor Property

Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double LinkLengthFactor { get; set; }
Visual Basic

Public Property LinkLengthFactor As Double

Property Value

A double multiplier applied to the link length cost when evaluating the total cost of a graph configuration. The default is 0.25.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which links are shorter.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
CrossingLinksCost Property
DistributionFactor Property


MindFusion.Diagramming.Layout.AnnealLayout.MultipleGraphsPlacement Property

AnnealLayout.MultipleGraphsPlacement Property

Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }
Visual Basic

Public Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

Remarks

If SplitGraph is enabled and the diagram contains several unconnected subgraphs, each of them is processed by the algorithm independently from the others. This property specifies how such subgraphs should be placed one relatively to another. The possible options are to arrange them in a row, in a column, or in such a way that the diagram covers a minimal area.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.NodeLinkCrossingCost Property

AnnealLayout.NodeLinkCrossingCost Property

Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double NodeLinkCrossingCost { get; set; }
Visual Basic

Public Property NodeLinkCrossingCost As Double

Property Value

A double value added to the total cost of a graph configuration when a link crosses a node. The default is 15000.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.NodeLinkDistFactor Property

AnnealLayout.NodeLinkDistFactor Property

Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double NodeLinkDistFactor { get; set; }
Visual Basic

Public Property NodeLinkDistFactor As Double

Property Value

A double value specifying the distance factor.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Progress Property

AnnealLayout.Progress Property

Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public LayoutProgress Progress { get; set; }
Visual Basic

Public Property Progress As LayoutProgress

Property Value

A LayoutProgress delegate method to call while the algorithm proceeds.

Remarks

It might take a lot of time to arrange large diagrams or run more iterations of the algorithm to get better results. In such situations an application can be notified about the progress of the layout routine by assigning a delegate method to this property. On its turn the application could update the UI to indicate the current progress to the users.

Example

The following example updates a label text to indicate AnnealLayout algorithm progress:

C#

AnnealLayout al = new AnnealLayout();
al.Progress = new LayoutProgress(onProgress);
al.Arrange(diagram);

...

void onProgress(int c, int n)
{
label1.Text = (100*c/n).ToString() + "% complete";
label1.Refresh();
}
Visual Basic

Dim al = New AnnealLayout
al.Progress = New LayoutProgress(AddressOf onProgress)
al.Arrange(diagram)

...

Sub onProgress(ByVal c As Integer, ByVal n As Integer)

label1.Text = (100 * c / n).ToString() + "% complete"
label1.Refresh()

End Sub

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Randomize Property

AnnealLayout.Randomize Property

Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Randomize { get; set; }
Visual Basic

Public Property Randomize As Boolean

Property Value

true to start the simulation with random node positions; false to start it with the original node positions. The default is true.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Root Property

AnnealLayout.Root Property

Gets or sets a node indicating which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Root { get; set; }
Visual Basic

Public Property Root As DiagramNode

Property Value

A DiagramNode whose containing graph should be arranged. The default is null (Nothing in Visual Basic).

Remarks

If a root nodes is specified and SplitGraph is enabled, only the graph that contains the root node is laid out by Arrange.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.SplitGraph Property

AnnealLayout.SplitGraph Property

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool SplitGraph { get; set; }
Visual Basic

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is false.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area. If a Root node is specified and SplitGraph is true, only the graph that contains the root node will be arranged.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Stages Property

AnnealLayout.Stages Property

Gets or sets how many cool-down stages the algorithm should simulate.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public int Stages { get; set; }
Visual Basic

Public Property Stages As Integer

Property Value

An integer value specifying the number of temperature decreases the simulation should run. The default is 15.

Remarks

At each stage the algorithm evaluates different graph arrangements produced by modifying the best configuration from the previous stage. The modifications are done by shifting nodes by a distance that depends on the current temperature. The TemperatureScale property specifies how much the temperature decreases at each stage. IterationsPerStage specifies how many configurations are evaluated at each stage.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
Progress Property


MindFusion.Diagramming.Layout.AnnealLayout.Statistics Property

AnnealLayout.Statistics Property

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public AnnealLayoutStatistics Statistics { get; }
Visual Basic

Public ReadOnly Property Statistics As AnnealLayoutStatistics

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.TemperatureScale Property

AnnealLayout.TemperatureScale Property

Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double TemperatureScale { get; set; }
Visual Basic

Public Property TemperatureScale As Double

Property Value

A double multiplier applied to the simulated temperature at each stage of the algorithm. The default is 0.75.

Remarks

This value should be in the interval (0,1). The algorithm produces better results when running for many Stages with a gradual temperature decrease, that is, a TemperatureScale closer to 1.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace
InitialTemperature Property


MindFusion.Diagramming.Layout.AnnealLayout.WidthHeightRatio Property

AnnealLayout.WidthHeightRatio Property

Gets or sets what width/height ratio the layout area should have.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float WidthHeightRatio { get; set; }
Visual Basic

Public Property WidthHeightRatio As Single

Property Value

A float value specifying the layout area width to height ration. The default is 1.

Remarks

If the LayoutArea is not explicitly set, the algorithm will choose one suitable for the graph size. In that case the WidthHeightRatio property specifies how much larger the layout area width should be than its height.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Class

CircularLayout Class

Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class CircularLayout : Layout
Visual Basic

Public Class CircularLayout
Inherits Layout

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.CircularLayout

See Also

CircularLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Members

CircularLayout Members
Constructors Properties Methods

Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.

The following tables list the members exposed by the CircularLayout type.

Public Constructors

Name | Description
CircularLayout | Initializes a new instance of the CircularLayout class with the default settings.

Public Properties

Name | Description
Radius | Gets or sets the radius of the layout circle.
SiftingRounds | Gets or sets the number of sifts to perform during the layout.

Public Methods

Name | Description
Arrange | Applies the layout on the specified subset of items from the specified Diagram instance.

See Also

CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Constructor

CircularLayout Constructor

Initializes a new instance of the CircularLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public CircularLayout ()
Visual Basic

Public Sub New ()

See Also

CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Methods

CircularLayout Methods

Public Methods

Name | Description
Arrange | Applies the layout on the specified subset of items from the specified Diagram instance.

See Also

CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.Arrange Method

CircularLayout.Arrange Method

Applies the layout on the specified subset of items from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool Arrange (
Diagram diagram,
DiagramItemCollection items
)
Visual Basic

Public Overrides Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

This method always returns true.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Properties

CircularLayout Properties

Public Properties

Name | Description
Radius | Gets or sets the radius of the layout circle.
SiftingRounds | Gets or sets the number of sifts to perform during the layout.

See Also

CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.Radius Property

CircularLayout.Radius Property

Gets or sets the radius of the layout circle.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float Radius { get; set; }
Visual Basic

Public Property Radius As Single

Property Value

A float value specifying the radius. The default value is 60.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.SiftingRounds Property

CircularLayout.SiftingRounds Property

Gets or sets the number of sifts to perform during the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public int SiftingRounds { get; set; }
Visual Basic

Public Property SiftingRounds As Integer

Property Value

An integer value specifying the number of sifting rounds. The default value is 1.

Remarks

After calculating the initial placement of nodes using a fast but inaccurate layout function, the algorithm can run a few sifting rounds to reduce the link crossings, as set in this property.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Direction Enumeration

Direction Enumeration

Specifies a layout direction.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum Direction
Visual Basic

Public Enumeration Direction

Members

Member name | Description
Reversed | Indicates either right-to-left or bottom-to-top direction.
Straight | Indicates either left-to-right or top-to-bottom direction.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout Class

FlowLayout Class
Remarks See Also

Implements a flowchart, workflow and process diagrams layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class FlowLayout : Layout
Visual Basic

Public Class FlowLayout
Inherits Layout

Remarks

The FlowLayout algorithm can be used to lay out flowcharts, workflow and process diagrams. It works by applying a customizable set of rules for local positioning of connected nodes relatively to each other. On a larger scale, the algorithm keeps groups of nodes separate and prevents links between the groups from crossing nodes. The FlowLayout and ProcessLayout examples included in the MindFusion.Diagramming package demonstrate two sample sets of layout rules.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.FlowLayout

See Also

FlowLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout Members

FlowLayout Members
Constructors Properties Methods

Implements a flowchart, workflow and process diagrams layout algorithm.

The following tables list the members exposed by the FlowLayout type.

Public Constructors

Name | Description
FlowLayout | Initializes a new instance of the FlowLayout class.

Public Properties

Name | Description
Anchoring | Not supported by FlowLayout.
AutoRoute | Gets or sets a value indicating whether longer links should be routed to avoid crossing the diagram nodes.
ChangeLaneDimensions | Gets or sets a value indicating whether the layout algorithm is allowed to change the initial Lane dimensions.
Direction | Gets or sets the direction of the arranged diagram.
HorizontalGroupOffset | Gets or sets the horizontal subgroup offset.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LaneBoundaries | Gets or sets the array of custom lane borders.
LaneDistance | Gets or sets the desired distance between adjacent lanes.
LaneType | Gets or sets a value indicating how process diagram swimlanes are defined in the current Diagram.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
LayoutRules | Gets or sets the rules used to infer the node positions from their logic identifiers and the connections in the graph.
LevelOffset | Gets or sets the lane border offset.
LinksBend | Specifies whether links between non-adjacent nodes should bend.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Not supported by FlowLayout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets a the overall orientation of the arranged diagram.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RecreateGraph | Gets or sets a value indicating whether the layout algorithm should recreate its internal graph representation for the MindFusion.Diagramming diagram.
Root | Gets or sets the node specifying which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
VerticalGroupOffset | Gets or sets the vertical subgroup offset.

Public Methods

Name | Description
AddNode | Adds the specified node to the already arranged diagram.
AddNode |
Arrange | Overloaded.
BendLinks | Bends all links in an already arranged diagram.
InsertNode | Inserts the specified node between two nodes connected by the by specified link.
InsertNode |
RemoveNode | Removes the specified node from an existing diagram.
RemoveNode |

See Also

FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout Constructor

FlowLayout Constructor

Initializes a new instance of the FlowLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public FlowLayout ()
Visual Basic

Public Sub New ()

See Also

FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout Methods

FlowLayout Methods

Public Methods

Name | Description
AddNode | Adds the specified node to the already arranged diagram.
AddNode |
Arrange | Overloaded.
BendLinks | Bends all links in an already arranged diagram.
InsertNode | Inserts the specified node between two nodes connected by the by specified link.
InsertNode |
RemoveNode | Removes the specified node from an existing diagram.
RemoveNode |

See Also

FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.AddNode Method

FlowLayout.AddNode Method

Adds the specified node to the already arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddNode (
DiagramNode dNode,
Diagram diagram
)
Visual Basic

Public Function AddNode ( _
dNode As DiagramNode, _
diagram As Diagram _
) As Boolean

Parameters

diagram
A Diagram instance.
node
A DiagramNode instance.

Return Value

true if the node has been added successfully; otherwise, false.

Remarks

You can use AddNode to implement incremental layout of a diagram, for example, by adding new nodes drawn by the user or added by a context menu command. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.AddNode Method (DiagramNode, Diagram)

FlowLayout.AddNode Method (DiagramNode, Diagram)
See Also

Adds the specified node to the already arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddNode (
DiagramNode node,
Diagram diagram
)
Visual Basic

Public Function AddNode ( _
node As DiagramNode, _
diagram As Diagram _
) As Boolean

Parameters

node
A DiagramNode instance.
diagram
A Diagram instance.

Return Value

true if the node has been added successfully; otherwise, false.

Remarks

You can use AddNode to implement incremental layout of a diagram, for example, by adding new nodes drawn by the user or added via a context menu command. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Arrange Method

FlowLayout.Arrange Method

Overload List

Name | Description
FlowLayout.Arrange (Diagram) | Applies the layout to the specified Diagram instance.
FlowLayout.Arrange (Diagram, DiagramItemCollection) | Applies the layout on the specified subset of objects from the specified Diagram instance.
FlowLayout.Arrange (Diagram, DiagramItemCollection, RectangleF[]) | Applies the layout on the specified subset of items from the specified Diagram instance and an array of rectangles defining custom lane borders.
FlowLayout.Arrange (Diagram, RectangleF[]) | Applies the layout to the specified Diagram instance and an array of rectangles defining custom lane borders.
FlowLayout.Arrange (Diagram, RectangleF[], DiagramItemCollection) | Applies the layout on the specified subset of objects from the specified Diagram instance and an array of rectangles defining custom lane borders.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Arrange Method (Diagram)

FlowLayout.Arrange Method (Diagram)
See Also

Applies the layout to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram _
) As Boolean

Parameters

diagram
The Diagram to arrange.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Arrange Method (Diagram, DiagramItemCollection)

FlowLayout.Arrange Method (Diagram, DiagramItemCollection)
See Also

Applies the layout on the specified subset of objects from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool Arrange (
Diagram diagram,
DiagramItemCollection items
)
Visual Basic

Public Overrides Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram to arrange.
items
Specifies a subset of diagram items to arrange.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Arrange Method (Diagram, DiagramItemCollection, RectangleF[])

FlowLayout.Arrange Method (Diagram, DiagramItemCollection, RectangleF[])
See Also

Applies the layout on the specified subset of items from the specified Diagram instance and an array of rectangles defining custom lane borders.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram,
DiagramItemCollection items,
RectangleF[] laneBorders
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection, _
laneBorders() As RectangleF _
) As Boolean

Parameters

diagram
The Diagram to arrange.
items
Specifies a subset of diagram items to arrange.
laneBorders
An array of rectangles defining custom lane borders.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Arrange Method (Diagram, RectangleF[])

FlowLayout.Arrange Method (Diagram, RectangleF[])
See Also

Applies the layout to the specified Diagram instance and an array of rectangles defining custom lane borders.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram,
RectangleF[] laneBorders
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram, _
laneBorders As RectangleF() _
) As Boolean

Parameters

diagram
The Diagram to arrange.
laneBorders
An array of rectangles defining custom lane borders.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Arrange Method (Diagram, RectangleF[], DiagramItemCollection)

FlowLayout.Arrange Method (Diagram, RectangleF[], DiagramItemCollection)
See Also

Applies the layout on the specified subset of objects from the specified Diagram instance and an array of rectangles defining custom lane borders.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram,
DiagramItemCollection objects,
RectangleF[] laneBorders
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram, _
objects As DiagramItemCollection, _
laneBorders As RectangleF() _
) As Boolean

Parameters

diagram
The Diagram to arrange.
laneBorders
An array of rectangles defining custom lane borders.
items
Specifies a subset of diagram items to arrange.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.BendLinks Method

FlowLayout.BendLinks Method

Bends all links in an already arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public void BendLinks (
Diagram diagram
)
Visual Basic

Public Sub BendLinks ( _
diagram As Diagram _
)

Parameters

diagram
A Diagram instance.

Remarks

You can use BendLinks to implement incremental layout of a diagram, for example, by calling it after the user draws a new link, or after several new links are added programmatically. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.InsertNode Method

FlowLayout.InsertNode Method

Inserts the specified node between two nodes connected by the by specified link.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool InsertNode (
DiagramNode dNode,
DiagramLink linkToSplit,
Diagram diagram
)
Visual Basic

Public Function InsertNode ( _
dNode As DiagramNode, _
linkToSplit As DiagramLink, _
diagram As Diagram _
) As Boolean

Parameters

linkToSplit
The DiagramLink to split.
diagram
A Diagram instance.
node
The DiagramNode to insert.

Return Value

true if the node has been added successfully; otherwise, false.

Remarks

You can use InsertNode to implement incremental layout of a diagram, for example, by adding new nodes drawn by the user or added through a context menu command. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.InsertNode Method (DiagramNode, DiagramLink, Diagram)

FlowLayout.InsertNode Method (DiagramNode, DiagramLink, Diagram)
See Also

Inserts the specified node between two nodes connected by the by specified link.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool InsertNode (
DiagramNode node,
DiagramLink linkToSplit,
Diagram diagram
)
Visual Basic

Public Function InsertNode ( _
node As DiagramNode, _
linkToSplit As DiagramLink, _
diagram As Diagram _
) As Boolean

Parameters

node
The DiagramNode to insert.
linkToSplit
The DiagramLink to split.
diagram
A Diagram instance.

Return Value

true if the node has been added successfully; otherwise, false.

Remarks

You can use InsertNode to implement incremental layout of a diagram, for example, by adding new nodes drawn by the user or added via a context menu command. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.RemoveNode Method

FlowLayout.RemoveNode Method

Removes the specified node from an existing diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RemoveNode (
DiagramNode dNode,
Diagram diagram
)
Visual Basic

Public Function RemoveNode ( _
dNode As DiagramNode, _
diagram As Diagram _
) As Boolean

Parameters

diagram
An already arranged Diagram.
node
The DiagramNode to remove.

Return Value

true if the node has been removed successfully; otherwise, false.

Remarks

You can use RemoveNode to implement incremental layout of a diagram, for example, by removing nodes deleted by the user or removed via a context menu command. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.RemoveNode Method (DiagramNode, Diagram)

FlowLayout.RemoveNode Method (DiagramNode, Diagram)
See Also

Removes the specified node from an existing diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RemoveNode (
DiagramNode node,
Diagram diagram
)
Visual Basic

Public Function RemoveNode ( _
node As DiagramNode, _
diagram As Diagram _
) As Boolean

Parameters

node
The DiagramNode to remove.
diagram
An already arranged Diagram.

Return Value

true if the node has been removed successfully; otherwise, false.

Remarks

You can use RemoveNode to implement incremental layout of a diagram, for example, by removing nodes deleted by the user or removed via a context menu command. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout Properties

FlowLayout Properties

Public Properties

Name | Description
Anchoring | Not supported by FlowLayout.
AutoRoute | Gets or sets a value indicating whether longer links should be routed to avoid crossing the diagram nodes.
ChangeLaneDimensions | Gets or sets a value indicating whether the layout algorithm is allowed to change the initial Lane dimensions.
Direction | Gets or sets the direction of the arranged diagram.
HorizontalGroupOffset | Gets or sets the horizontal subgroup offset.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LaneBoundaries | Gets or sets the array of custom lane borders.
LaneDistance | Gets or sets the desired distance between adjacent lanes.
LaneType | Gets or sets a value indicating how process diagram swimlanes are defined in the current Diagram.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
LayoutRules | Gets or sets the rules used to infer the node positions from their logic identifiers and the connections in the graph.
LevelOffset | Gets or sets the lane border offset.
LinksBend | Specifies whether links between non-adjacent nodes should bend.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Not supported by FlowLayout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets a the overall orientation of the arranged diagram.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RecreateGraph | Gets or sets a value indicating whether the layout algorithm should recreate its internal graph representation for the MindFusion.Diagramming diagram.
Root | Gets or sets the node specifying which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
VerticalGroupOffset | Gets or sets the vertical subgroup offset.

See Also

FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Anchoring Property

FlowLayout.Anchoring Property

Not supported by FlowLayout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Anchoring Anchoring { get; set; }
Visual Basic

Public Property Anchoring As Anchoring

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.AutoRoute Property

FlowLayout.AutoRoute Property

Gets or sets a value indicating whether longer links should be routed to avoid crossing the diagram nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AutoRoute { get; set; }
Visual Basic

Public Property AutoRoute As Boolean

Property Value

true to look for link routes that do not cross nodes; otherwise, false. The default is false.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.ChangeLaneDimensions Property

FlowLayout.ChangeLaneDimensions Property

Gets or sets a value indicating whether the layout algorithm is allowed to change the initial Lane dimensions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ChangeLaneDimensions { get; set; }
Visual Basic

Public Property ChangeLaneDimensions As Boolean

Property Value

true if the algorithm is allowed to change the lane dimensions; otherwise, false. The default is true.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Direction Property

FlowLayout.Direction Property

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Direction Direction { get; set; }
Visual Basic

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default is Straight.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.HorizontalGroupOffset Property

FlowLayout.HorizontalGroupOffset Property

Gets or sets the horizontal subgroup offset.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float HorizontalGroupOffset { get; set; }
Visual Basic

Public Property HorizontalGroupOffset As Single

Property Value

A value specifying the horizontal distance between groups of nodes. The default is 25.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.KeepGroupLayout Property

FlowLayout.KeepGroupLayout Property

Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool KeepGroupLayout { get; set; }
Visual Basic

Public Property KeepGroupLayout As Boolean

Property Value

true if each Group should be processed as an integral graph node; otherwise, false. The default is false.

Remarks

Enabling this property has an effect similar to setting the IgnoreLayout property of group's subordinated nodes to true. The two methods differ in how the size of the graph node corresponding to a group is calculated. If KeepGroupLayout is enabled, the union of all bounding rectangles of grouped items is used to determine the size of the graph node. When the IgnoreLayout property of subordinated items is enabled, the bounding rectangle of the main node defines the size of the graph node corresponding to the group.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LaneBoundaries Property

FlowLayout.LaneBoundaries Property

Gets or sets the array of custom lane borders.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF[] LaneBoundaries { get; set; }
Visual Basic

Public Property LaneBoundaries As RectangleF()

Property Value

An array of rectangles specifying custom lane borders.

Remarks

This array is used when LaneType is set to Custom.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LaneDistance Property

FlowLayout.LaneDistance Property

Gets or sets the desired distance between adjacent lanes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float LaneDistance { get; set; }
Visual Basic

Public Property LaneDistance As Single

Property Value

Remarks

The lanes are placed at the specified distance from each other only if ChangeLaneDimensions is enabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LaneType Property

FlowLayout.LaneType Property

Gets or sets a value indicating how process diagram swimlanes are defined in the current Diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public LaneType LaneType { get; set; }
Visual Basic

Public Property LaneType As LaneType

Property Value

A member of the LaneType enumeration. The default is LaneBoxes.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LayoutLink Property

FlowLayout.LayoutLink Property

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutLink LayoutLink { get; set; }
Visual Basic

Public Overridable Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LayoutNode Property

FlowLayout.LayoutNode Property

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutNode LayoutNode { get; set; }
Visual Basic

Public Overridable Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LayoutRules Property

FlowLayout.LayoutRules Property

Gets or sets the rules used to infer the node positions from their logic identifiers and the connections in the graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public FlowLayoutRules LayoutRules { get; set; }
Visual Basic

Public Property LayoutRules As FlowLayoutRules

Property Value

An instance of the FlowLayoutRules class.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LevelOffset Property

FlowLayout.LevelOffset Property

Gets or sets the lane border offset.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float LevelOffset { get; set; }
Visual Basic

Public Property LevelOffset As Single

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.LinksBend Property

FlowLayout.LinksBend Property

Specifies whether links between non-adjacent nodes should bend.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool LinksBend { get; set; }
Visual Basic

Public Property LinksBend As Boolean

Property Value

true if links should bend; otherwise, false. The default is true.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Margins Property

FlowLayout.Margins Property

Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeF Margins { get; set; }
Visual Basic

Public Property Margins As SizeF

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.MultipleGraphsPlacement Property

FlowLayout.MultipleGraphsPlacement Property

Not supported by FlowLayout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }
Visual Basic

Public Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.NodeDistance Property

FlowLayout.NodeDistance Property

Gets or sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float NodeDistance { get; set; }
Visual Basic

Public Property NodeDistance As Single

Property Value

A float value specifying the desired distance between nodes. The default is 4.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Orientation Property

FlowLayout.Orientation Property

Gets or sets a the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Orientation Orientation { get; set; }
Visual Basic

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Vertical.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.RandomSeed Property

FlowLayout.RandomSeed Property

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public int RandomSeed { get; set; }
Visual Basic

Public Property RandomSeed As Integer

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.RecreateGraph Property

FlowLayout.RecreateGraph Property

Gets or sets a value indicating whether the layout algorithm should recreate its internal graph representation for the MindFusion.Diagramming diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool RecreateGraph { get; set; }
Visual Basic

Public Property RecreateGraph As Boolean

Property Value

true if the graph representation should be recreated when Arrange is executed, otherwise, false. The default is false.

Remarks

Keep this property set to false if you wish to use the AddNode and InsertNode methods to implement incremental layout.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.Root Property

FlowLayout.Root Property

Gets or sets the node specifying which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Root { get; set; }
Visual Basic

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class. The default is a null reference (Nothing in Visual Basic).

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph which it defines is laid out by Arrange.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.SplitGraph Property

FlowLayout.SplitGraph Property

Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool SplitGraph { get; set; }
Visual Basic

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is false.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area. If a Root node is specified and SplitGraph is true, only the graph that contains the root node will be arranged.

Do not enable SplitGraph when using lanes, or otherwise you will get incorrect results.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowLayout.VerticalGroupOffset Property

FlowLayout.VerticalGroupOffset Property

Gets or sets the vertical subgroup offset.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float VerticalGroupOffset { get; set; }
Visual Basic

Public Property VerticalGroupOffset As Single

Property Value

A value specifying the vertical distance between groups of nodes. The default is 70.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Class

GridLayout Class
Remarks See Also

Implements a grid graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class GridLayout : Layout
Visual Basic

Public Class GridLayout
Inherits Layout

Remarks

GridLayout arranges diagram nodes in a grid, keeping connected nodes close together. The algorithm strives to achieve a small number of link crossings. It is based on an iterative process whose initial steps shuffle the grid nodes randomly. That can lead to very different results each time the algorithm is run.

To apply the layout to a diagram, create a GridLayout instance, set its members and invoke the Arrange method. Arrange lays out all subgraphs in a diagram, unless the Root property is set.

The distance between points in the layout grid can be changed through GridSize. Nodes to be placed at the upper-left and lower-right corners of the grid can be assigned to StartNode and EndNode.

Anchoring specifies whether the layout algorithm must attach links to the anchor points of graphs nodes.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.GridLayout

See Also

GridLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Members

GridLayout Members
Constructors Properties Methods

Implements a grid graph layout algorithm.

The following tables list the members exposed by the GridLayout type.

Public Constructors

Name | Description
GridLayout | Initializes a new instance of the GridLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes.
EndNode | Gets or sets the node that is placed at the lower right corner of the grid.
GridSize | Gets or sets the desired distance between adjacent grid points.
Iterations | Gets or sets for how many iterations to run the grid layout algorithm.
KeepGroupLayout | Gets or sets whether to treat each Group of nodes as a single vertex in the arranged graph.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
StartNode | Gets or sets the node that is placed at the upper left corner of the grid.
TimeLimit | Gets or sets a time-out value for the path-finding part of the grid layout algorithm.
UseLongestPath | Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout.

See Also

GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Constructor

GridLayout Constructor

Initializes a new instance of the GridLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public GridLayout ()
Visual Basic

Public Sub New ()

See Also

GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Methods

GridLayout Methods

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout.

See Also

GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Arrange Method

GridLayout.Arrange Method

Applies the layout.

Overload List

Name | Description
GridLayout.Arrange (Diagram) | Applies the layout to the specified Diagram instance.
GridLayout.Arrange (Diagram, DiagramItemCollection) | Applies the layout to a subgraph of the specified Diagram instance.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Arrange Method (Diagram)

GridLayout.Arrange Method (Diagram)
See Also

Applies the layout to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.

Return Value

true if the layout is successfully applied; false if StartNode and EndNode are specified and there is no path between them.

See Also

Arrange Method Overload List
GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Arrange Method (Diagram, DiagramItemCollection)

GridLayout.Arrange Method (Diagram, DiagramItemCollection)
See Also

Applies the layout to a subgraph of the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram,
DiagramItemCollection items
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the layout is successfully applied; false if StartNode and EndNode are specified and there is no path between them.

See Also

Arrange Method Overload List
GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Properties

GridLayout Properties

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes.
EndNode | Gets or sets the node that is placed at the lower right corner of the grid.
GridSize | Gets or sets the desired distance between adjacent grid points.
Iterations | Gets or sets for how many iterations to run the grid layout algorithm.
KeepGroupLayout | Gets or sets whether to treat each Group of nodes as a single vertex in the arranged graph.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
StartNode | Gets or sets the node that is placed at the upper left corner of the grid.
TimeLimit | Gets or sets a time-out value for the path-finding part of the grid layout algorithm.
UseLongestPath | Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

See Also

GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Anchoring Property

GridLayout.Anchoring Property

Gets or sets a value indicating how to align links to the anchor points of graph nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Anchoring Anchoring { get; set; }
Visual Basic

Public Property Anchoring As Anchoring

Property Value

A member of the Anchoring enumeration. The default is Ignore.

Remarks

The grid layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace
AnchorPattern Property


MindFusion.Diagramming.Layout.GridLayout.EndNode Property

GridLayout.EndNode Property

Gets or sets the node that is placed at the lower right corner of the grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode EndNode { get; set; }
Visual Basic

Public Property EndNode As DiagramNode

Property Value

An instance of the DiagramNode class. Default value is null (Nothing in Visual Basic).

Remarks

If you assign a node to that property, then StartNode cannot be null and must be set too. GridLayout usually produces better layouts if both StartNode and EndNode are null references; in such a case the algorithm automatically selects suitable nodes.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.GridSize Property

GridLayout.GridSize Property

Gets or sets the desired distance between adjacent grid points.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float GridSize { get; set; }
Visual Basic

Public Property GridSize As Single

Property Value

A float number specifying the grid size. The default is 25.

Remarks

When placing a node at a grid position, the node center point is aligned to the grid point at that position.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Iterations Property

GridLayout.Iterations Property

Gets or sets for how many iterations to run the grid layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public int Iterations { get; set; }
Visual Basic

Public Property Iterations As Integer

Property Value

An integer number specifying the number of iterations. The default is 3000.

Remarks

More iterations would yield better layouts but require more time to complete.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace
Progress Property


MindFusion.Diagramming.Layout.GridLayout.KeepGroupLayout Property

GridLayout.KeepGroupLayout Property

Gets or sets whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool KeepGroupLayout { get; set; }
Visual Basic

Public Property KeepGroupLayout As Boolean

Property Value

true to treat a group of nodes as a single graph node; otherwise, false. The default is false.

Remarks

Enabling this property has an effect similar to setting the IgnoreLayout property of group's subordinated nodes to true. The two methods differ in how the size of the graph node corresponding to a group is calculated. If KeepGroupLayout is enabled, the union of all bounding rectangles of grouped items is used to determine the size of the graph node. When the IgnoreLayout property of subordinated items is enabled, the bounding rectangle of the main node defines the size of the graph node corresponding to the group.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace
AttachTo Method


MindFusion.Diagramming.Layout.GridLayout.LayoutLink Property

GridLayout.LayoutLink Property

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutLink LayoutLink { get; set; }
Visual Basic

Public Overridable Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.LayoutNode Property

GridLayout.LayoutNode Property

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutNode LayoutNode { get; set; }
Visual Basic

Public Overridable Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Margins Property

GridLayout.Margins Property

Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeF Margins { get; set; }
Visual Basic

Public Property Margins As SizeF

Property Value

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.MultipleGraphsPlacement Property

GridLayout.MultipleGraphsPlacement Property

Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }
Visual Basic

Public Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

Remarks

If SplitGraph is enabled and the diagram contains several unconnected subgraphs, each of them is processed by the algorithm independently from the others. This property specifies how such subgraphs should be placed one relatively to another. The possible options are to arrange them in a row, in a column, or in such a way that the diagram covers a minimal area.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Progress Property

GridLayout.Progress Property

Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public LayoutProgress Progress { get; set; }
Visual Basic

Public Property Progress As LayoutProgress

Property Value

A LayoutProgress delegate method to call while the algorithm proceeds.

Remarks

It might take a lot of time to arrange large diagrams or run more iterations of the algorithm to get better results. In such situations an application can indicate to end users the progress of the layout routine by connecting a delegate to this property.

Example

The following example updates a label text to indicate GridLayout algorithm progress:

C#

GridLayout gl = new GridLayout();
gl.Iterations = 20000;
gl.Progress = new LayoutProgress(onProgress);
gl.Arrange(diagram);

...

void onProgress(int c, int n)
{
label1.Text = (100*c/n).ToString() + "% complete";
label1.Refresh();
}
Visual Basic

Dim gl As New GridLayout
gl.Iterations = 20000
gl.Progress = New LayoutProgress(AddressOf onProgress)
gl.Arrange(diagram)

...

Sub onProgress(ByVal c As Integer, ByVal n As Integer)

label1.Text = (100 * c / n).ToString() + "% complete"
label1.Refresh()

End Sub

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace
Iterations Property


MindFusion.Diagramming.Layout.GridLayout.RandomSeed Property

GridLayout.RandomSeed Property

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public int RandomSeed { get; set; }
Visual Basic

Public Property RandomSeed As Integer

Property Value

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Root Property

GridLayout.Root Property

Gets or sets a node indicating which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Root { get; set; }
Visual Basic

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class. The default is a null reference (Nothing in Visual Basic).

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph which it defines is laid out by Arrange.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.SplitGraph Property

GridLayout.SplitGraph Property

Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool SplitGraph { get; set; }
Visual Basic

Public Property SplitGraph As Boolean

Property Value

true to split the graph; otherwise, false.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.StartNode Property

GridLayout.StartNode Property

Gets or sets the node that is placed at the upper left corner of the grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode StartNode { get; set; }
Visual Basic

Public Property StartNode As DiagramNode

Property Value

An instance of the DiagramNode class. The default is null (Nothing in Visual Basic).

Remarks

If you assign a node to that property, then EndNode cannot be null and must be set too. GridLayout usually produces better layouts if both StartNode and EndNode are null references; in such a case the algorithm automatically selects suitable nodes.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.TimeLimit Property

GridLayout.TimeLimit Property

Gets or sets a time-out value for the path-finding part of the grid layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public long TimeLimit { get; set; }
Visual Basic

Public Property TimeLimit As Long

Property Value

An integer value specifying time-out in milliseconds. The default is 10000 (10 seconds).

Remarks

The grid layout algorithm arranges graph nodes and links along the longest path in the graph. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. When the time-out set with this property occurs, the path-finding routine stops and the layout algorithm uses the longest path known at that moment. Usually, for graphs containing several hundreds of nodes, 1-2 seconds are enough to find a path long enough to produce a nice layout.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.UseLongestPath Property

GridLayout.UseLongestPath Property

Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool UseLongestPath { get; set; }
Visual Basic

Public Property UseLongestPath As Boolean

Property Value

true to look for the longest path in the graph and arrange nodes around it; otherwise, false.

Remarks

Initially, the algorithm places nodes and links from the longest path in the graph at the grid diagonal, and arranges the rest of the nodes around the diagonal. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. Disabling this property will let you skip the path-finding part of the algorithm, which will make it work much faster.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Interface

ILayout Interface

Common interface for all MindFusion.Diagramming layouters.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public interface ILayout
Visual Basic

Public Interface ILayout

See Also

ILayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Members

ILayout Members
Properties Methods

Common interface for all MindFusion.Diagramming layouters.

The following tables list the members exposed by the ILayout type.

Public Properties

Name | Description
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Public Methods

Name | Description
Arrange | Applies the layout to the specified Diagram instance.

See Also

ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Methods

ILayout Methods

Public Methods

Name | Description
Arrange | Applies the layout to the specified Diagram instance.

See Also

ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout.Arrange Method

ILayout.Arrange Method

Applies the layout to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract bool Arrange (
Diagram diagram
)
Visual Basic

Public MustOverride Function Arrange ( _
diagram As Diagram _
) As Boolean

Parameters

diagram

The Diagram that will be arranged.

Return Value

Returns whether the arrangement was successful.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Properties

ILayout Properties

Public Properties

Name | Description
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

See Also

ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout.LayoutLink Property

ILayout.LayoutLink Property

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract LayoutLink LayoutLink { get; set; }
Visual Basic

Public MustOverride Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout.LayoutNode Property

ILayout.LayoutNode Property

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract LayoutNode LayoutNode { get; set; }
Visual Basic

Public MustOverride Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneType Enumeration

LaneType Enumeration

Specifies where FlowLayout gets the swimlane dimensions from.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum LaneType
Visual Basic

Public Enumeration LaneType

Members

Member name | Description
Custom | FlowLayout should get the swimlane dimensions from the array of rectangles passed as an argument to Arrange.
LaneGrid | FlowLayout gets the swimlane dimensions from Diagram.LaneGrid.
LaneNodes | FlowLayout interprets locked background nodes as swimlanes.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Class

LayeredLayout Class
Remarks See Also

Implements a layered graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class LayeredLayout : Layout
Visual Basic

Public Class LayeredLayout
Inherits Layout

Remarks

This algorithm assigns diagram nodes to distinct horizontal or vertical layers. While arranging the layers, the layout routine seeks to meet the following criteria:

  • connected nodes must be placed close together;
  • links must flow in one direction if possible;
  • links must cross as few layers as possible;
  • links must not cross other links;

To apply this layout to a diagram, create a LayeredLayout instance, set its members and invoke the Arrange method. Arrange lays out all subgraphs in a diagram, unless the Root property is set.

The final appearance of arranged graphs depends mostly on the Orientation and Direction properties which define the overall orientation of the layout. The LayerDistance and NodeDistance properties specify how much space to leave between adjacent layers and adjacent nodes in a layer.

The performance of LayeredLayout is dependent on the number of links in the diagram. At its first stage, the algorithm looks for the longest sequence of links in the graph and builds the node layers along it. That stage can be the most time consuming if there are a lot of links in a graph, so there is the TimeLimit property provided to control how much time the layout routine is allowed to spend on path-finding. Next, if there are layers much longer than the other ones and SplitLayers is enabled, nodes from these layers are moved to new ones so the graph width is uniformly distributed.

The layout routine continues by shuffling nodes and link points across their layers, so the criteria mentioned above are approximated. Finally, link ends are aligned to anchor points if Anchoring is enabled and the distance between outermost links is decreased as set in LinksCompactFactor.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.LayeredLayout

See Also

LayeredLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Members

LayeredLayout Members
Constructors Properties Methods

Implements a layered graph layout algorithm.

The following tables list the members exposed by the LayeredLayout type.

Public Constructors

Name | Description
LayeredLayout | Overloaded. Initializes a new instance of the LayeredLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes.
Direction | Gets or sets the direction of the arranged diagram.
IgnoreNodeSize | Gets or sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LayerDistance | Gets or sets the desired distance between layer axis lines.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
LinksCompactFactor | Gets or sets a value indicating how much to compact the outermost links.
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets a delegate which is invoked regularly during the layout process to inform clients about the layout progress.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitLayers | Gets or sets a value indicating whether to split layers that are much wider than the other layers.
SwapPairsIterations | Gets or sets how many times to perform pair-swapping iterations on each layer.
TimeLimit | Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout.

See Also

LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Constructor

LayeredLayout Constructor

Initializes a new instance of the LayeredLayout class.

Overload List

Name | Description
LayeredLayout () | Initializes a new instance of the LayeredLayout class with the default settings.
LayeredLayout (Orientation, Single, Single, SizeF) | Initializes a new instance of the LayeredLayout class with the specified settings.

See Also

LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Constructor ()

LayeredLayout Constructor ()
See Also

Initializes a new instance of the LayeredLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public LayeredLayout ()
Visual Basic

Public Sub New ()

See Also

LayeredLayout Constructor Overload List
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Constructor (Orientation, Single, Single, SizeF)

LayeredLayout Constructor (Orientation, Single, Single, SizeF)
See Also

Initializes a new instance of the LayeredLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public LayeredLayout (
Orientation orientation,
float layerDistance,
float nodeDistance,
SizeF margins
)
Visual Basic

Public Sub LayeredLayout ( _
orientation As Orientation, _
layerDistance As Single, _
nodeDistance As Single, _
margins As SizeF _
)

Parameters

orientation

The orientation of the layout.

layerDistance

The distance between adjacent layers.

nodeDistance

The distance between adjacent nodes within the same layer.

margins

The margin between the produced graph and the left side of the diagram bounding rectangle.

See Also

LayeredLayout Constructor Overload List
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Methods

LayeredLayout Methods

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout.

See Also

LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Arrange Method

LayeredLayout.Arrange Method

Applies the layout.

Overload List

Name | Description
LayeredLayout.Arrange (Diagram) | Applies the algorithm to the specified Diagram instance.
LayeredLayout.Arrange (Diagram, DiagramItemCollection) | Applies the layout on the specified subset of objects from the specified Diagram instance.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Arrange Method (Diagram)

LayeredLayout.Arrange Method (Diagram)
See Also

Applies the algorithm to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram _
) As Boolean

Parameters

diagram
The Diagram that will be arranged.

Return Value

This method always returns true.

See Also

Arrange Method Overload List
LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Arrange Method (Diagram, DiagramItemCollection)

LayeredLayout.Arrange Method (Diagram, DiagramItemCollection)
See Also

Applies the layout on the specified subset of objects from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram,
DiagramItemCollection items
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that will be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

This method always returns true.

See Also

Arrange Method Overload List
LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Properties

LayeredLayout Properties

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of graph nodes.
Direction | Gets or sets the direction of the arranged diagram.
IgnoreNodeSize | Gets or sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LayerDistance | Gets or sets the desired distance between layer axis lines.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
LinksCompactFactor | Gets or sets a value indicating how much to compact the outermost links.
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets a delegate which is invoked regularly during the layout process to inform clients about the layout progress.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitLayers | Gets or sets a value indicating whether to split layers that are much wider than the other layers.
SwapPairsIterations | Gets or sets how many times to perform pair-swapping iterations on each layer.
TimeLimit | Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

See Also

LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Anchoring Property

LayeredLayout.Anchoring Property

Gets or sets a value indicating how to align links to the anchor points of graph nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Anchoring Anchoring { get; set; }
Visual Basic

Public Property Anchoring As Anchoring

Property Value

A member of the Anchoring enumeration. The default is Ignore.

Remarks

The layered graph layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace
AnchorPattern Property


MindFusion.Diagramming.Layout.LayeredLayout.Direction Property

LayeredLayout.Direction Property

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Direction Direction { get; set; }
Visual Basic

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default is Straight.

Remarks

If Orientation is set to Horizontal, Direction.Straight stands for "left to right" and Direction.Reversed for "right to left". If Orientation is set to Vertical, Direction.Straight stands for "top to bottom" and Direction.Reversed for "bottom to top".

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.IgnoreNodeSize Property

LayeredLayout.IgnoreNodeSize Property

Gets or sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool IgnoreNodeSize { get; set; }
Visual Basic

Public Property IgnoreNodeSize As Boolean

Property Value

true to ignore the node size; otherwise, false. The default is true.

Remarks

At this time, considering the size of nodes deteriorates the performance of the algorithm, so that's disabled by default.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.KeepGroupLayout Property

LayeredLayout.KeepGroupLayout Property

Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool KeepGroupLayout { get; set; }
Visual Basic

Public Property KeepGroupLayout As Boolean

Property Value

true to treat a group of nodes as a single graph node; otherwise, false. The default is false.

Remarks

Enabling this property has an effect similar to setting the IgnoreLayout property of group's subordinated nodes to true. The two methods differ in how the size of the graph node corresponding to a group is calculated. If KeepGroupLayout is enabled, the union of all bounding rectangles of grouped items is used to determine the size of the graph node. When the IgnoreLayout property of subordinated items is enabled, the bounding rectangle of the main node defines the size of the graph node corresponding to the group.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace
AttachTo Method


MindFusion.Diagramming.Layout.LayeredLayout.LayerDistance Property

LayeredLayout.LayerDistance Property

Gets or sets the desired distance between layer axis lines.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float LayerDistance { get; set; }
Visual Basic

Public Property LayerDistance As Single

Property Value

A float value specifying the distance between layers. The default is 25.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.LayoutLink Property

LayeredLayout.LayoutLink Property

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutLink LayoutLink { get; set; }
Visual Basic

Public Overridable Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.LayoutNode Property

LayeredLayout.LayoutNode Property

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutNode LayoutNode { get; set; }
Visual Basic

Public Overridable Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.LinksCompactFactor Property

LayeredLayout.LinksCompactFactor Property

Gets or sets a value indicating how much to compact the outermost links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float LinksCompactFactor { get; set; }
Visual Basic

Public Property LinksCompactFactor As Single

Property Value

A float number in the interval [0, 1]. The default is 1.

Remarks

Links and nodes on the same graph layer are distributed uniformly as specified via the NodeDistance value. However, if there are more than 2-3 outermost links on a layer, they usually take up too much space without improving the visual quality of the diagram layout. This property allows compacting such links to save space. The factor specifies roughly a fraction of NodeDistance to leave between outer links.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.LinkType Property

LayeredLayout.LinkType Property

Gets or sets the appearance of the links in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public LayeredLayoutLinkType LinkType { get; set; }
Visual Basic

Public Property LinkType As LayeredLayoutLinkType

Property Value

A member of the LayeredLayoutLinkType enumeration. The default is Straight.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Margins Property

LayeredLayout.Margins Property

Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeF Margins { get; set; }
Visual Basic

Public Property Margins As SizeF

Property Value

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.MultipleGraphsPlacement Property

LayeredLayout.MultipleGraphsPlacement Property

Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }
Visual Basic

Public Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default is Horizontal.

Remarks

If the diagram contains several unconnected subgraphs, each of them is processed by the algorithm independently from the others. This property specifies how such subgraphs should be placed one relatively to another. The possible options are to arrange them in a row, in a column, or in such a way that the diagram covers a minimal area.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.NodeDistance Property

LayeredLayout.NodeDistance Property

Gets or sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float NodeDistance { get; set; }
Visual Basic

Public Property NodeDistance As Single

Property Value

A float value specifying the distance between adjacent nodes. The default is 20.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Orientation Property

LayeredLayout.Orientation Property

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Orientation Orientation { get; set; }
Visual Basic

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Vertical.

Remarks

Specify Orientation.Vertical to have links flow in vertical direction and Orientation.Horizontal to have links flow in horizontal direction. The orientation of the resulting layers is opposite to that of the links. Thus, if the link tends to go in a vertical direction, the nodes are distributed in horizontal layers.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace
Direction Property


MindFusion.Diagramming.Layout.LayeredLayout.Progress Property

LayeredLayout.Progress Property

Gets or sets a delegate which is invoked regularly during the layout process to inform clients about the layout progress.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public LayoutProgress Progress { get; set; }
Visual Basic

Public Property Progress As LayoutProgress

Property Value

A LayoutProgress delegate method to call while the algorithm proceeds.

Remarks

It might take a lot of time to arrange large diagrams or run more iterations of the algorithm to get better results. In such situations an application can indicate to end users the progress of the layout routine by connecting a delegate to this property.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace
TimeLimit Property


MindFusion.Diagramming.Layout.LayeredLayout.Root Property

LayeredLayout.Root Property

Gets or sets a node indicating which subgraph of the diagram must be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Root { get; set; }
Visual Basic

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class. The default is a null reference (Nothing in Visual Basic).

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph containing it is laid out by Arrange.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.SplitLayers Property

LayeredLayout.SplitLayers Property

Gets or sets a value indicating whether to split layers that are much wider than the other layers.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool SplitLayers { get; set; }
Visual Basic

Public Property SplitLayers As Boolean

Property Value

true to split wide layers; otherwise, false. The default is false.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.SwapPairsIterations Property

LayeredLayout.SwapPairsIterations Property

Gets or sets how many times to perform pair-swapping iterations on each layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public int SwapPairsIterations { get; set; }
Visual Basic

Public Property SwapPairsIterations As Integer

Property Value

An integer value specifying how many pair-swapping iterations to perform. The default is 5.

Remarks

The algorithm swaps node pairs on each layer aiming to decrease the number of crossing links. Setting a higher value to this property helps to decrease the number of crossings.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.TimeLimit Property

LayeredLayout.TimeLimit Property

Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public long TimeLimit { get; set; }
Visual Basic

Public Property TimeLimit As Long

Property Value

An integer value specifying time-out in milliseconds. The default is 10000 (10 seconds).

Remarks

The layered layout algorithm arranges graph nodes and links along the longest path in the graph. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. When the time-out set with this property occurs, the path-finding routine stops and the layout algorithm uses the longest path known at that moment. Usually, for graphs containing several hundreds of nodes, 1-2 seconds are enough to find a long-enough path to produce nice layered layout.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutLinkType Enumeration

LayeredLayoutLinkType Enumeration

Specifies the style of the links after they are laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum LayeredLayoutLinkType
Visual Basic

Public Enumeration LayeredLayoutLinkType

Members

Member name | Description
Cascading | Indicates cascading links.
Straight | Indicates straight links.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Class

Layout Class

The base class for all layout classes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract class Layout : Component, ILayout
Visual Basic

Public MustInherit Class Layout
Inherits Component
Implements ILayout

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.AnnealLayout
MindFusion.Diagramming.Layout.CircularLayout
MindFusion.Diagramming.Layout.FlowLayout
MindFusion.Diagramming.Layout.GridLayout
MindFusion.Diagramming.Layout.LayeredLayout
MindFusion.Diagramming.Layout.OrthogonalLayout
MindFusion.Diagramming.Layout.OrthogonalRouter
MindFusion.Diagramming.Layout.SpringLayout
MindFusion.Diagramming.Layout.TreeLayout

See Also

Layout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Members

Layout Members
Constructors Properties Methods

The base class for all layout classes.

The following tables list the members exposed by the Layout type.

Protected Constructors

Name | Description
Layout | Initialzes a new instance of the Layout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Progress | Gets or sets the progress callback delegate.

Public Methods

Name | Description
Arrange | Overloaded.

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Constructor

Layout Constructor

Initialzes a new instance of the Layout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

protected Layout ()
Visual Basic

Protected Sub New ()

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Methods

Layout Methods

Public Methods

Name | Description
Arrange | Overloaded.

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Arrange Method

Layout.Arrange Method

Overload List

Name | Description
Layout.Arrange (Diagram) | Applies the layout to the specified Diagram instance.
Layout.Arrange (Diagram, DiagramItemCollection) | Applies the layout on the specified subset of objects from the specified Diagram instance.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Arrange Method (Diagram)

Layout.Arrange Method (Diagram)
See Also

Applies the layout to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram _
) As Boolean

Parameters

diagram
The Diagram that must be arranged.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Arrange Method (Diagram, DiagramItemCollection)

Layout.Arrange Method (Diagram, DiagramItemCollection)
See Also

Applies the layout on the specified subset of objects from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract bool Arrange (
Diagram diagram,
DiagramItemCollection items
)
Visual Basic

Public MustOverride Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that must be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Properties

Layout Properties

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Progress | Gets or sets the progress callback delegate.

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Anchoring Property

Layout.Anchoring Property

Gets or sets how to align links to the anchor points of nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Anchoring Anchoring { get; set; }
Visual Basic

Public Property Anchoring As Anchoring

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.KeepGroupLayout Property

Layout.KeepGroupLayout Property

Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool KeepGroupLayout { get; set; }
Visual Basic

Public Property KeepGroupLayout As Boolean

Property Value

Enabling this property has an effect similar to setting the IgnoreLayout property of group's subordinated nodes to true. The two methods differ in how the size of the graph node corresponding to a group is calculated. If KeepGroupLayout is enabled, the union of all bounding rectangles of grouped items is used to determine the size of the graph node. When the IgnoreLayout property of subordinated items is enabled, the bounding rectangle of the main node defines the size of the graph node corresponding to the group.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.LayoutLink Property

Layout.LayoutLink Property

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutLink LayoutLink { get; set; }
Visual Basic

Public Overridable Property LayoutLink As LayoutLink

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.LayoutNode Property

Layout.LayoutNode Property

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutNode LayoutNode { get; set; }
Visual Basic

Public Overridable Property LayoutNode As LayoutNode

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Margins Property

Layout.Margins Property

Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeF Margins { get; set; }
Visual Basic

Public Property Margins As SizeF

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.MultipleGraphsPlacement Property

Layout.MultipleGraphsPlacement Property

Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }
Visual Basic

Public Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

Remarks

If the diagram contains several unconnected subgraphs, each of them is processed by the algorithm independently from the others. This property specifies how such subgraphs should be placed one relatively to another. The possible options are to arrange them in a row, in a column, or in such a way that the diagram covers a minimal area.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Progress Property

Layout.Progress Property

Gets or sets the progress callback delegate.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutProgress Progress { get; set; }
Visual Basic

Public Overridable Property Progress As LayoutProgress

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutLink Delegate

LayoutLink Delegate

Represents methods that are called by the layout algorithms when the position of a link changes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void LayoutLink (
DiagramLink link
)
Visual Basic

Public Delegate Sub LayoutLink ( _
link As DiagramLink _
)

Parameters

link

A reference to the link being laid out.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutNode Delegate

LayoutNode Delegate

Represents methods that are called by the layout algorithms when the position of a node changes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void LayoutNode (
DiagramNode node,
RectangleF oldBounds
)
Visual Basic

Public Delegate Sub LayoutNode ( _
node As DiagramNode, _
oldBounds As RectangleF _
)

Parameters

node

A reference to the node being laid out.

oldBounds

The bounding rectangle of the node before it was repositioned by the layouting algorithm.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutProgress Delegate

LayoutProgress Delegate

Represents methods that are called to report on progress of layout algorithms.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate void LayoutProgress (
int current,
int total
)
Visual Basic

Public Delegate Sub LayoutProgress ( _
current As Integer, _
total As Integer _
)

Parameters

current

An integer value specifying the current relative progress of the layout algorithm.

total

An integer value specifying the total number of steps required by the layouting algorithm in order to finish.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.MultipleGraphsPlacement Enumeration

MultipleGraphsPlacement Enumeration

Specifies graph orientation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum MultipleGraphsPlacement
Visual Basic

Public Enumeration MultipleGraphsPlacement

Members

Member name | Description
Horizontal | Indicates that graphs should be placed in a row.
MinimalArea | Indicates that graphs should be placed so that they cover minimal area.
Vertical | Indicates that graphs should be placed in a column.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Orientation Enumeration

Orientation Enumeration

Specifies axial orientation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum Orientation
Visual Basic

Public Enumeration Orientation

Members

Member name | Description
Horizontal | Indicates horizontal orientation.
Vertical | Indicates vertical orientation.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Class

OrthogonalLayout Class
Remarks See Also

Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class OrthogonalLayout : Layout
Visual Basic

Public Class OrthogonalLayout
Inherits Layout

Remarks

This algorithm was designed for planar graphs where the nodes have at most four incident links, and produces best results with such graphs as input. It can arrange any arbitrary graph as well, by adding some dummy nodes and links to planarize the graph and reduce its vertex degree, and removing them after the layout. However this might lead to using larger area than necessary, due to the space occupied by dummy elements.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.OrthogonalLayout

See Also

OrthogonalLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Members

OrthogonalLayout Members
Constructors Properties Methods

Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.

The following tables list the members exposed by the OrthogonalLayout type.

Public Constructors

Name | Description
OrthogonalLayout | Initializes a new instance of the OrthogonalLayout class with the default settings.

Public Properties

Name | Description
Directed | Gets or sets a value indicating whether the graph being laid out is directed.
MinLaneSize | Gets or sets a value indicating the minimum size of a lane.
Padding | Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.
Refine | Gets or sets a value indicating whether to refine the layout.

Public Methods

Name | Description
Arrange | Applies the layout on the specified subset of items from the specified Diagram instance.

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Constructor

OrthogonalLayout Constructor

Initializes a new instance of the OrthogonalLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public OrthogonalLayout ()
Visual Basic

Public Sub New ()

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Methods

OrthogonalLayout Methods

Public Methods

Name | Description
Arrange | Applies the layout on the specified subset of items from the specified Diagram instance.

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Arrange Method

OrthogonalLayout.Arrange Method

Applies the layout on the specified subset of items from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool Arrange (
Diagram diagram,
DiagramItemCollection items
)
Visual Basic

Public Overrides Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

This method always returns true.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Properties

OrthogonalLayout Properties

Public Properties

Name | Description
Directed | Gets or sets a value indicating whether the graph being laid out is directed.
MinLaneSize | Gets or sets a value indicating the minimum size of a lane.
Padding | Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.
Refine | Gets or sets a value indicating whether to refine the layout.

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Directed Property

OrthogonalLayout.Directed Property

Gets or sets a value indicating whether the graph being laid out is directed.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Directed { get; set; }
Visual Basic

Public Property Directed As Boolean

Property Value

true to consider the direction of graph edges, false to ignore it; the default value is false.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.MinLaneSize Property

OrthogonalLayout.MinLaneSize Property

Gets or sets a value indicating the minimum size of a lane.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float MinLaneSize { get; set; }
Visual Basic

Public Property MinLaneSize As Single

Property Value

A float value specifying the minimum lane size. The default value is 10.

Remarks

The result of the layout's Arrange is a grid that contains the diagram's nodes and links. This property specifies the size of lanes which does not contain nodes, but only links.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Padding Property

OrthogonalLayout.Padding Property

Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float Padding { get; set; }
Visual Basic

Public Property Padding As Single

Property Value

A float value specifying the padding. The default is 15.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Refine Property

OrthogonalLayout.Refine Property

Gets or sets a value indicating whether to refine the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Refine { get; set; }
Visual Basic

Public Property Refine As Boolean

Property Value

true to run a refinement pass, otherwise false. The default value is true.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Class

OrthogonalRouter Class
Remarks See Also

Implements an orthogonal link routing algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class OrthogonalRouter : Layout
Visual Basic

Public Class OrthogonalRouter
Inherits Layout

Remarks

OrthogonalRouter is a secondary layout algorithm that can be used to arrange links after an initial node arrangement has already been applied. The orthogonal layout is useful when there are much more links than nodes in a graph. The algorithm strives to achieve the following criteria, while preserving as much of the initial node configuration as possible.

  • links must not overlap;
  • only vertical and horizontal routing lines are used;
  • graph routing is performed with respect to the specified main layout direction;
  • links crossings are minimized;
  • bends are minimized;

To arrange a diagram, create an OrthogonalRouter instance, set its properties and call the Arrange method.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.OrthogonalRouter

See Also

OrthogonalRouter Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Members

OrthogonalRouter Members
Constructors Properties Methods

Implements an orthogonal link routing algorithm.

The following tables list the members exposed by the OrthogonalRouter type.

Public Constructors

Name | Description
OrthogonalRouter | Initializes a new instance of the OrthogonalRouter class.

Public Properties

Name | Description
BendDistance | Gets or sets how far from its adjacent node a link should bend.
Direction | Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
GridSize | Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.
LayerDistance | Gets or sets the desired distance between layer axis lines.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.
PutEndPointsAtNodeBorders | Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.

Public Methods

Name | Description
Arrange | Applies the layout on the specified subset of objects from the specified Diagram instance.

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Constructor

OrthogonalRouter Constructor

Initializes a new instance of the OrthogonalRouter class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public OrthogonalRouter ()
Visual Basic

Public Sub New ()

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Methods

OrthogonalRouter Methods

Public Methods

Name | Description
Arrange | Applies the layout on the specified subset of objects from the specified Diagram instance.

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.Arrange Method

OrthogonalRouter.Arrange Method

Applies the layout on the specified subset of objects from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool Arrange (
Diagram diagram,
DiagramItemCollection items
)
Visual Basic

Public Overrides Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

This method always returns true.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Properties

OrthogonalRouter Properties

Public Properties

Name | Description
BendDistance | Gets or sets how far from its adjacent node a link should bend.
Direction | Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
GridSize | Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.
LayerDistance | Gets or sets the desired distance between layer axis lines.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.
PutEndPointsAtNodeBorders | Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.BendDistance Property

OrthogonalRouter.BendDistance Property

Gets or sets how far from its adjacent node a link should bend.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float BendDistance { get; set; }
Visual Basic

Public Property BendDistance As Single

Property Value

A float value specifying the distance from a link's first bend to its adjacent node. The default is 0, specifying that the algorithm should automatically choose a value for this parameter.

Remarks

This should be a value between 0 and 1, specifying a distance proportional to the node size.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.Direction Property

OrthogonalRouter.Direction Property

Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Direction Direction { get; set; }
Visual Basic

Public Property Direction As Direction

Property Value

Remarks

This value is assigned to the Direction property of the base LayeredLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.EndOrientation Property

OrthogonalRouter.EndOrientation Property

Gets or sets the desired orientation of the last segments of routed links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Orientation EndOrientation { get; set; }
Visual Basic

Public Property EndOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

If this property is set to Horizontal, links will end at the left or right sides of nodes. If set to Vertical, links will end at the top or bottom sides.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace
StartOrientation Property


MindFusion.Diagramming.Layout.OrthogonalRouter.GridSize Property

OrthogonalRouter.GridSize Property

Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float GridSize { get; set; }
Visual Basic

Public Property GridSize As Single

Property Value

Remarks

This value is assigned to the GridSize property of the base GridLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.LayerDistance Property

OrthogonalRouter.LayerDistance Property

Gets or sets the desired distance between layer axis lines.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float LayerDistance { get; set; }
Visual Basic

Public Property LayerDistance As Single

Property Value

Remarks

Gets or sets the distance between layers when BaseLayout is set to Layered or Cascading.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.NodeDistance Property

OrthogonalRouter.NodeDistance Property

Gets or sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float NodeDistance { get; set; }
Visual Basic

Public Property NodeDistance As Single

Property Value

Remarks

Gets or sets the distance between nodes in the same layer when BaseLayout is set to Layered or Cascading.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.Orientation Property

OrthogonalRouter.Orientation Property

Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Orientation Orientation { get; set; }
Visual Basic

Public Property Orientation As Orientation

Property Value

Remarks

This value is assigned to the Orientation property of the base LayeredLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.PutEndPointsAtNodeBorders Property

OrthogonalRouter.PutEndPointsAtNodeBorders Property

Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool PutEndPointsAtNodeBorders { get; set; }
Visual Basic

Public Property PutEndPointsAtNodeBorders As Boolean

Property Value

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.RandomSeed Property

OrthogonalRouter.RandomSeed Property

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public int RandomSeed { get; set; }
Visual Basic

Public Property RandomSeed As Integer

Property Value

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.Root Property

OrthogonalRouter.Root Property

Gets or sets a node indicating which subgraph of the diagram must be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Root { get; set; }
Visual Basic

Public Property Root As DiagramNode

Property Value

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph which it defines is laid out by Arrange.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.SplitGraph Property

OrthogonalRouter.SplitGraph Property

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool SplitGraph { get; set; }
Visual Basic

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is true.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area. If a Root node is specified and SplitGraph is true, only the graph that contains the root node will be arranged.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.StartOrientation Property

OrthogonalRouter.StartOrientation Property

Gets or sets the desired orientation of the first segments of routed links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Orientation StartOrientation { get; set; }
Visual Basic

Public Property StartOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

If this property is set to Horizontal, links will end at the left or right sides of nodes. If set to Vertical, links will end at the top or bottom sides.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace
EndOrientation Property


MindFusion.Diagramming.Layout.SpringLayout Class

SpringLayout Class
Remarks See Also

Implements the Spring-Embedder graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class SpringLayout : Layout
Visual Basic

Public Class SpringLayout
Inherits Layout

Remarks

Spring-Embedder produces layouts having uniform distribution of nodes by simulating a physical system in which nodes repulse each other and the links between them act as confining springs. Nodes are moved around in an iterative process. The forces that act on a node are calculated, taking in account the positions of surrounding nodes and links from the previous iteration.

To apply this layout to a diagram, call the Arrange method of a SpringLayout instance. Arrange lays out all subgraphs in a diagram, unless the Root property is set.

If the LayoutTraits value associated with a node through SpringLayoutTraits.Frozen is true, SpringLayout considers the repulsion forces exerted by the node on other nodes, but ignores forces acting on the node and keeps it in place.

The final appearance of arranged graphs depends mostly on the values of EnableClusters and NodeDistance properties that specify how nodes are distributed by the layout routine. Enabling the MinimizeCrossings property helps to decrease the number of link crossings, though that makes the algorithm run somewhat slower.

The layout routine runs as much iterations as set in IterationCount, calculating better node positions at each step. When that stage of the algorithm completes, if Anchoring is enabled, link ends are aligned to nodes' anchor points.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.SpringLayout

See Also

SpringLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Members

SpringLayout Members
Constructors Properties Methods

Implements the Spring-Embedder graph layout algorithm.

The following tables list the members exposed by the SpringLayout type.

Public Constructors

Name | Description
SpringLayout | Overloaded. Initializes a new instance of the SpringLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of graph nodes.
EnableClusters | Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.
IterationCount | Gets or sets for how many iterations to run the layout routine.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
Layout3D | Specifies whether the layout should set the 3D coordinates of nodes for display inside DiagramView3D.
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
MinimizeCrossings | Gets or sets a value indicating whether crossing minimization mode is enabled.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.
NodeDistance | Gets or sets the desired distance between nodes.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepulsionFactor | Gets or sets the repulsion factor.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stretch | Gets or sets the stretch factor.
Surface | Specifies on what surface the nodes should be placed initially.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout.
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution started with a call to BeginArrange.
Iterate | Runs one or more layout iterations.

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor

SpringLayout Constructor

Initializes a new instance of the SpringLayout class.

Overload List

Name | Description
SpringLayout () | Initializes a new instance of the SpringLayout class with the default settings.
SpringLayout (Int32, Single, Boolean) | Initializes a new instance of the SpringLayout class with the specified settings.
SpringLayout (Int32, Single, Boolean, Boolean) | Initializes a new instance of the SpringLayout class with the specified settings.

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor ()

SpringLayout Constructor ()
See Also

Initializes a new instance of the SpringLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SpringLayout ()
Visual Basic

Public Sub New ()

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor (Int32, Single, Boolean)

SpringLayout Constructor (Int32, Single, Boolean)
See Also

Initializes a new instance of the SpringLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SpringLayout (
int iterationCount,
float nodeDistance,
bool minimizeCrossings
)
Visual Basic

Public New ( _
iterationCount As Integer, _
nodeDistance As Single, _
minimizeCrossings As Boolean _
)

Parameters

iterationCount

The number of iterations to perform.

nodeDistance

The distance between nodes.

minimizeCrossings

Specifies whether to try to minimize crossings while layouting.

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor (Int32, Single, Boolean, Boolean)

SpringLayout Constructor (Int32, Single, Boolean, Boolean)
See Also

Initializes a new instance of the SpringLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SpringLayout (
int iterationCount,
float nodeDistance,
bool minimizeCrossings,
bool keepGroupLayout
)
Visual Basic

Public New ( _
iterationCount As Integer, _
nodeDistance As Single, _
minimizeCrossings As Boolean, _
keepGroupLayout As Boolean _
)

Parameters

iterationCount

The number of iterations to perform.

nodeDistance

The distance between nodes.

minimizeCrossings

Specifies whether to try to minimize crossings while layouting.

keepGroupLayout

Specifies whether to keep the relative position of groupped items.

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Methods

SpringLayout Methods

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout.
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution started with a call to BeginArrange.
Iterate | Runs one or more layout iterations.

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Arrange Method

SpringLayout.Arrange Method

Applies the layout.

Overload List

Name | Description
SpringLayout.Arrange (Diagram) | Applies the layout to the specified Diagram instance.
SpringLayout.Arrange (Diagram, DiagramItemCollection) | Applies the layout on the specified subset of objects from the specified Diagram instance.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Arrange Method (Diagram)

SpringLayout.Arrange Method (Diagram)
See Also

Applies the layout to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram _
) As Boolean

Parameters

diagram
The Diagram that must be arranged.

Return Value

This method always returns true.

See Also

Arrange Method Overload List
SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Arrange Method (Diagram, DiagramItemCollection)

SpringLayout.Arrange Method (Diagram, DiagramItemCollection)
See Also

Applies the layout on the specified subset of objects from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram,
DiagramItemCollection items
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that must be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

This method always returns true.

See Also

Arrange Method Overload List
SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.BeginArrange Method

SpringLayout.BeginArrange Method

Initializes the layout object for a step-by-step execution.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool BeginArrange (
Diagram diagram,
DiagramItemCollection items
)
Visual Basic

Public Function BeginArrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the layout object has been initialized successfully; otherwise, false.

Remarks

You can use this method together with Iterate and EndArrange to display an animation of the layout process. To run all iterations of the proces at once and display just the end result, call Arrange.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.EndArrange Method

SpringLayout.EndArrange Method

Completes the step-by-step execution started with a call to BeginArrange.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public void EndArrange ()
Visual Basic

Public Sub EndArrange ()

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Iterate Method

SpringLayout.Iterate Method

Runs one or more layout iterations.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public void Iterate (
int iterationFrom,
int iterationTo
)
Visual Basic

Public Sub Iterate ( _
iterationFrom As Integer, _
iterationTo As Integer _
)

Parameters

iterationFrom
Specifies from which iteration to start.
iterationTo
Specifies at which iteration to stop.

Remarks

Use this method to create an animation of the layout process, for example, by calling it from a timer. Call BeginArrange to prepare the layout object for use of Iterate, and call EndArrange when done. Each call to Iterate should start from the iteration next to the one where the previous call has stopped.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Properties

SpringLayout Properties

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of graph nodes.
EnableClusters | Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.
IterationCount | Gets or sets for how many iterations to run the layout routine.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
Layout3D | Specifies whether the layout should set the 3D coordinates of nodes for display inside DiagramView3D.
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
MinimizeCrossings | Gets or sets a value indicating whether crossing minimization mode is enabled.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.
NodeDistance | Gets or sets the desired distance between nodes.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepulsionFactor | Gets or sets the repulsion factor.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stretch | Gets or sets the stretch factor.
Surface | Specifies on what surface the nodes should be placed initially.

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Anchoring Property

SpringLayout.Anchoring Property

Gets or sets how to align links to the anchor points of graph nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Anchoring Anchoring { get; set; }
Visual Basic

Public Property Anchoring As Anchoring

Property Value

A member of the Anchoring enumeration. The default is Ignore.

Remarks

The Spring-Embedder layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace
AnchorPattern Property


MindFusion.Diagramming.Layout.SpringLayout.EnableClusters Property

SpringLayout.EnableClusters Property

Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableClusters { get; set; }
Visual Basic

Public Property EnableClusters As Boolean

Property Value

true to detect and process node clusters; otherwise, false. The default is false.

Remarks

If enabled, the SpringLayout algorithm detects node clusters and places them at distinct positions. Each cluster consists of a center node surrounded by several local nodes. Clusters might be connected with other clusters by their center nodes. Best-looking results are achieved when there aren't links between the local nodes in a cluster.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.IterationCount Property

SpringLayout.IterationCount Property

Gets or sets for how many iterations to run the layout routine.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public int IterationCount { get; set; }
Visual Basic

Public Property IterationCount As Integer

Property Value

An integer number specifying the number of iterations. The default is 100.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.KeepGroupLayout Property

SpringLayout.KeepGroupLayout Property

Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool KeepGroupLayout { get; set; }
Visual Basic

Public Property KeepGroupLayout As Boolean

Property Value

true to treat a group of nodes as a single graph node; otherwise, false. The default is false.

Remarks

Enabling this property has an effect similar to setting the IgnoreLayout property of group's subordinated nodes to true. The two methods differ in how the size of the graph node corresponding to a group is calculated. If KeepGroupLayout is enabled, the union of all bounding rectangles of grouped items is used to determine the size of the graph node. When the IgnoreLayout property of subordinated items is enabled, the bounding rectangle of the main node defines the size of the graph node corresponding to the group.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace
AttachTo Method


MindFusion.Diagramming.Layout.SpringLayout.Layout3D Property

SpringLayout.Layout3D Property

Specifies whether the layout should set the 3D coordinates of nodes for display inside DiagramView3D.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool Layout3D { get; set; }
Visual Basic

Public Property Layout3D As Boolean

Property Value

Remarks

true to set the 3D coordinates of nodes; otherwise, false. The default value is false.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace
Surface Property


MindFusion.Diagramming.Layout.SpringLayout.LayoutArea Property

SpringLayout.LayoutArea Property

Gets or sets the size of the layout area.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public RectangleF LayoutArea { get; set; }
Visual Basic

Public Property LayoutArea As RectangleF

Property Value

A .NET RectangleF representing the boundaries of the layout area. The default is RectangleF.Empty.

Remarks

If the layout area is not explicitly set, the algorithm will choose one suitable for the graph size.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.LayoutLink Property

SpringLayout.LayoutLink Property

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutLink LayoutLink { get; set; }
Visual Basic

Public Overridable Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.LayoutNode Property

SpringLayout.LayoutNode Property

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutNode LayoutNode { get; set; }
Visual Basic

Public Overridable Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.MinimizeCrossings Property

SpringLayout.MinimizeCrossings Property

Gets or sets a value indicating whether crossing minimization mode is enabled.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool MinimizeCrossings { get; set; }
Visual Basic

Public Property MinimizeCrossings As Boolean

Property Value

true to attempt crossing minimization; otherwise, false. The default is false.

Remarks

If enabled, MindFusion.Diagramming tries to decrease number of crossing links. For better results, use greater IterationCount.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.MultipleGraphsPlacement Property

SpringLayout.MultipleGraphsPlacement Property

Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }
Visual Basic

Public Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

Remarks

If the diagram contains several unconnected subgraphs, each of them is processed by the algorithm independently from the others. This property specifies how such subgraphs should be placed one relatively to another. The possible options are to arrange them in a row, in a column, or in such a way that the diagram covers a minimal area.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.NodeDistance Property

SpringLayout.NodeDistance Property

Gets or sets the desired distance between nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float NodeDistance { get; set; }
Visual Basic

Public Property NodeDistance As Single

Property Value

A float value specifying the distance between nodes. The default is 30.

Remarks

The final distance between connected nodes is determined by multiplying the Weight of the link that connects them by the value of NodeDistance.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Progress Property

SpringLayout.Progress Property

Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public LayoutProgress Progress { get; set; }
Visual Basic

Public Property Progress As LayoutProgress

Property Value

A LayoutProgress delegate method to call while the algorithm proceeds.

Remarks

It might take a lot of time to arrange large diagrams or run more iterations of the algorithm to get better results. In such situations an application can indicate to end users the progress of the layout routine by connecting a delegate to this property.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace
IterationCount Property


MindFusion.Diagramming.Layout.SpringLayout.RandomSeed Property

SpringLayout.RandomSeed Property

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public int RandomSeed { get; set; }
Visual Basic

Public Property RandomSeed As Integer

Property Value

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.RepulsionFactor Property

SpringLayout.RepulsionFactor Property

Gets or sets the repulsion factor.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double RepulsionFactor { get; set; }
Visual Basic

Public Property RepulsionFactor As Double

Property Value

A double value specifying the repulsion factor used by the spring layout.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Root Property

SpringLayout.Root Property

Gets or sets a node indicating which subgraph of the diagram must be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Root { get; set; }
Visual Basic

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class. The default is a null reference (Nothing in Visual Basic).

Remarks

All links and nodes that can be reached from the root by following recursively its links from a graph. If the root is specified, only the graph which it defines is laid out by Arrange.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.SplitGraph Property

SpringLayout.SplitGraph Property

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool SplitGraph { get; set; }
Visual Basic

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is false.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area. If a Root node is specified and SplitGraph is true, only the graph that contains the root node will be arranged.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Stretch Property

SpringLayout.Stretch Property

Gets or sets the stretch factor.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double Stretch { get; set; }
Visual Basic

Public Property Stretch As Double

Property Value

A double value specifying the stretch factor used by the spring layout.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Surface Property

SpringLayout.Surface Property

Specifies on what surface the nodes should be placed initially.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public new Surface Surface { get; set; }
Visual Basic

Public Shadows Property Surface As Surface

Property Value

A member of the Surface enumeration. The default value is Sphere.

Remarks

Specifies on what surface the graph nodes should be placed initially, when Layout3D is enabled.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Class

TreeLayout Class
Remarks See Also

Implements several algorithms for arranging tree structures.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class TreeLayout : Layout
Visual Basic

Public Class TreeLayout
Inherits Layout

Remarks

Set the Type property of a TreeLayout instance to select which tree layout algorithm to run, and call the Arrange method to apply the layout on a tree/subtree in the current diagram.

As long as the graph is a tree, the algorithm can find the root node automatically. You can override it by setting the Root property, e.g. in order to arrange only a selected branch of the tree. The distance between the root and the second level and between all subsequent levels can be set through the LevelDistance property. The distance between adjacent nodes in the same level is set through NodeDistance.

In addition to arranging the tree nodes, TreeLayout also sets the shape of links as set through its LinkStyle property. Anchoring specifies whether the links should be attached to the anchor points of tree nodes. Note that links that are not part of the tree are ignored, e.g. graph links that go in opposite direction of the general parent-to-child flow or cross-links that connect different tree branches. You can post-process such links after calling Arrange, e.g. by setting their ControlPoints coordinates or by calling their Route method.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.TreeLayout

See Also

TreeLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Members

TreeLayout Members
Constructors Properties Methods

Implements several algorithms for arranging tree structures.

The following tables list the members exposed by the TreeLayout type.

Public Constructors

Name | Description
TreeLayout | Overloaded. Initializes a new instance of the TreeLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of tree nodes.
Balance | Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.
Direction | Gets or sets the tree direction.
EnableAssistants | Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
LevelDistance | Gets or sets how much space to leave between levels of the tree.
LinkStyle | Gets or sets a value indicating how links in the arranged tree should look.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.
NodeDistance | Gets or sets how much space to leave between nodes on the same level.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the root node of the tree.
StretchFactor | Gets or sets the stretch factor applied on Radial tree layouts.
Type | Gets or sets what type of tree layout to apply to the diagram.

Public Methods

Name | Description
Arrange | Overloaded.
UpdateLink | Updates the style and position of the specified link.

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor

TreeLayout Constructor

Initializes a new instance of the TreeLayout class.

Overload List

Name | Description
TreeLayout () | Initializes a new instance of the TreeLayout class with the default settings.
TreeLayout (DiagramNode) | Initializes a new instance of the TreeLayout class with the specified node as root.
TreeLayout (DiagramNode, TreeLayoutType) | Initializes a new instance of the TreeLayout class with the specified node as root and the specified type.
TreeLayout (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Single, Single, Boolean, SizeF) | Initializes a new instance of the TreeLayout class with the specified settings.
TreeLayout (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Single, Single, Boolean, SizeF, Boolean) | Initializes a new instance of the TreeLayout class with the specified settings.
TreeLayout (TreeLayoutType) | Initializes a new instance of the TreeLayout class with the specified type.

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor ()

TreeLayout Constructor ()
See Also

Initializes a new instance of the TreeLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public TreeLayout ()
Visual Basic

Public Sub New ()

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (DiagramNode)

TreeLayout Constructor (DiagramNode)
See Also

Initializes a new instance of the TreeLayout class with the specified node as root.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public TreeLayout (
DiagramNode root
)
Visual Basic

Public Sub TreeLayout ( _
root As DiagramNode _
)

Parameters

root

The root of the arranged tree.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (DiagramNode, TreeLayoutType)

TreeLayout Constructor (DiagramNode, TreeLayoutType)
See Also

Initializes a new instance of the TreeLayout class with the specified node as root and the specified type.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public TreeLayout (
DiagramNode root,
TreeLayoutType type
)
Visual Basic

Public Sub TreeLayout ( _
root As DiagramNode, _
type As TreeLayoutType _
)

Parameters

root

The root of the arranged tree.

type
The type of the tree layout.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Single, Single, Boolean, SizeF)

TreeLayout Constructor (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Single, Single, Boolean, SizeF)
See Also

Initializes a new instance of the TreeLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public TreeLayout (
DiagramNode root,
TreeLayoutType type,
bool reversedLinks,
TreeLayoutLinkType linkStyle,
TreeLayoutDirections direction,
float levelDistance,
float nodeDistance,
bool keepRootPosition,
SizeF margins
)
Visual Basic

Public Sub TreeLayout ( _
root As DiagramNode, _
type As TreeLayoutType, _
reversedLinks As Boolean, _
linkStyle As TreeLayoutLinkType, _
direction As TreeLayoutDirections, _
levelDistance As Single, _
nodeDistance As Single, _
keepRootPosition As Boolean, _
margins as SizeF _
)

Parameters

root

The root of the arranged tree.

type

The type of the tree layout.

reversedLinks

Specifies whether the parent-to-child direction in the tree is reversed, that is, from the end of the link towards its beginning.

linkStyle

The style of the links in the produced layout.

direction

The layout direction.

levelDistance

The distance between adjacent levels.

nodeDistance

The distance between adjacent nodes.

keepRootPosition

Specifies whether to keep the position of the tree root.

margins

The margin between the produced tree and the left side of the diagram bounding rectangle.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Single, Single, Boolean, SizeF, Boolean)

TreeLayout Constructor (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Single, Single, Boolean, SizeF, Boolean)
See Also

Initializes a new instance of the TreeLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public TreeLayout (
DiagramNode root,
TreeLayoutType type,
bool reversedLinks,
TreeLayoutLinkType linkStyle,
TreeLayoutDirections direction,
float levelDistance,
float nodeDistance,
bool keepRootPosition,
SizeF margins,
bool keepGroupLayout
)
Visual Basic

Public Sub TreeLayout ( _
root As DiagramNode, _
type As TreeLayoutType, _
reversedLinks As Boolean, _
linkStyle As TreeLayoutLinkType, _
direction As TreeLayoutDirections, _
levelDistance As Single, _
nodeDistance As Single, _
keepRootPosition As Boolean, _
margins as SizeF, _
keepGroupLayout As Boolean _
)

Parameters

root

The root of the arranged tree.

type

The type of the tree layout.

reversedLinks

Specifies whether the parent-to-child direction in the tree should be reversed, that is, from the end of the link towards its beginning.

linkStyle

The style of the links in the produced layout.

direction

The layout direction.

levelDistance

The distance between adjacent levels.

nodeDistance

The distance between adjacent nodes.

keepRootPosition

Specifies whether to keep the position of the tree root.

margins

The margin between the produced tree and the left side of the diagram bounding rectangle.

keepGroupLayout

Specifies whether to keep the relative position of groupped items.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (TreeLayoutType)

TreeLayout Constructor (TreeLayoutType)
See Also

Initializes a new instance of the TreeLayout class with the specified type.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public TreeLayout (
TreeLayoutType type
)
Visual Basic

Public Sub TreeLayout ( _
type As TreeLayoutType _
)

Parameters

type

The type of the tree layout.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Methods

TreeLayout Methods

Public Methods

Name | Description
Arrange | Overloaded.
UpdateLink | Updates the style and position of the specified link.

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Arrange Method

TreeLayout.Arrange Method

Overload List

Name | Description
TreeLayout.Arrange (Diagram) | Applies the layout on the specified Diagram instance.
TreeLayout.Arrange (Diagram, DiagramItemCollection) | Applies the layout on the specified subset of objects from the specified Diagram instance.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Arrange Method (Diagram)

TreeLayout.Arrange Method (Diagram)
See Also

Applies the layout on the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.

Return Value

false only if the Root property is set to a link; otherwise, true.

See Also

Arrange Method Overload List
TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Arrange Method (Diagram, DiagramItemCollection)

TreeLayout.Arrange Method (Diagram, DiagramItemCollection)
See Also

Applies the layout on the specified subset of objects from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool Arrange (
Diagram diagram,
DiagramItemCollection items
)
Visual Basic

Public Overridable Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that will be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

false only if the Root property is set to a link; otherwise, true.

See Also

Arrange Method Overload List
TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.UpdateLink Method

TreeLayout.UpdateLink Method

Updates the style and position of the specified link.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public void UpdateLink (
DiagramLink a,
bool ignoredDirection
)
Visual Basic

Public Sub UpdateLink ( _
a As DiagramLink, _
ignoredDirection As Boolean _
)

Parameters

a
A DiagramLink that will be updated.
ignoredDirection

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Properties

TreeLayout Properties

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating how to align links to the anchor points of tree nodes.
Balance | Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.
Direction | Gets or sets the tree direction.
EnableAssistants | Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
LevelDistance | Gets or sets how much space to leave between levels of the tree.
LinkStyle | Gets or sets a value indicating how links in the arranged tree should look.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.
NodeDistance | Gets or sets how much space to leave between nodes on the same level.
Progress | Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the root node of the tree.
StretchFactor | Gets or sets the stretch factor applied on Radial tree layouts.
Type | Gets or sets what type of tree layout to apply to the diagram.

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Anchoring Property

TreeLayout.Anchoring Property

Gets or sets a value indicating how to align links to the anchor points of tree nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Anchoring Anchoring { get; set; }
Visual Basic

Public Property Anchoring As Anchoring

Property Value

A member of the Anchoring enumeration. The default is Ignore.

Remarks

The tree layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace
AnchorPattern Property


MindFusion.Diagramming.Layout.TreeLayout.Balance Property

TreeLayout.Balance Property

Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public TreeLayoutBalance Balance { get; set; }
Visual Basic

Public Property Balance As TreeLayoutBalance

Property Value

A member of the TreeLayoutBalance enumeration. The default value is Original.

Remarks

The value of this property is considered when Type is set to HorizontalVertical.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Direction Property

TreeLayout.Direction Property

Gets or sets the tree direction.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public TreeLayoutDirections Direction { get; set; }
Visual Basic

Public Property Direction As TreeLayoutDirections

Property Value

A member of the TreeLayoutDirections enumeration.

Remarks

This property must be set to a combination of two TreeLayoutDirections members when using Type is HorizontalVertical.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.EnableAssistants Property

TreeLayout.EnableAssistants Property

Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool EnableAssistants { get; set; }
Visual Basic

Public Property EnableAssistants As Boolean

Property Value

true to enable assistant nodes, otherwise false; the default value is false.

Remarks

Enabling this property lets you create organizational charts as in MS office. To designate some nodes as assistants, assign true as a value for the TreeLayoutTraits.Assistant key in the node's LayoutTraits.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.IgnoreLinkDirection Property

TreeLayout.IgnoreLinkDirection Property

Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool IgnoreLinkDirection { get; set; }
Visual Basic

Public Property IgnoreLinkDirection As Boolean

Property Value

true to ignore link direction; otherwise, false. The default is false.

Remarks

Parent-child direction is considered the one in which nodes go further from the root, instead that of the links. If IgnoreLinkDirection is set to true, you must explicitly specify the tree Root.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.KeepGroupLayout Property

TreeLayout.KeepGroupLayout Property

Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool KeepGroupLayout { get; set; }
Visual Basic

Public Property KeepGroupLayout As Boolean

Property Value

true to treat a group of nodes as a single graph node; otherwise, false. The default is false.

Remarks

Enabling this property has an effect similar to setting the IgnoreLayout property of group's subordinated nodes to true. The two methods differ in how the size of the graph node corresponding to a group is calculated. If KeepGroupLayout is enabled, the union of all bounding rectangles of grouped items is used to determine the size of the graph node. When the IgnoreLayout property of subordinated items is enabled, the bounding rectangle of the main node defines the size of the graph node corresponding to the group.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace
AttachTo Method


MindFusion.Diagramming.Layout.TreeLayout.KeepRootPosition Property

TreeLayout.KeepRootPosition Property

Gets or sets a value indicating whether to keep the root node at its original position.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool KeepRootPosition { get; set; }
Visual Basic

Public Property KeepRootPosition As Boolean

Property Value

true to keep the root position; otherwise, false.

Remarks

If the root position is not kept, that is, the value of this property is false, the entire tree is dispositioned after the layout is complete, according to the values of Margins.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.LayoutLink Property

TreeLayout.LayoutLink Property

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutLink LayoutLink { get; set; }
Visual Basic

Public Overridable Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.LayoutNode Property

TreeLayout.LayoutNode Property

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual LayoutNode LayoutNode { get; set; }
Visual Basic

Public Overridable Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.LevelDistance Property

TreeLayout.LevelDistance Property

Gets or sets how much space to leave between levels of the tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float LevelDistance { get; set; }
Visual Basic

Public Property LevelDistance As Single

Property Value

A float value specifying the distance between adjacent levels in the tree.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.LinkStyle Property

TreeLayout.LinkStyle Property

Gets or sets a value indicating how links in the arranged tree should look.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public TreeLayoutLinkType LinkStyle { get; set; }
Visual Basic

Public Property LinkStyle As TreeLayoutLinkType

Property Value

A member of the TreeLayoutLinkType enumeration.

Remarks

This property is ignored if Type is set to Radial.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Margins Property

TreeLayout.Margins Property

Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SizeF Margins { get; set; }
Visual Basic

Public Property Margins As SizeF

Property Value

Remarks

This value is also set as the distance between unconnected sub-graphs when they are placed as specified via MultipleGraphsPlacement.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.MultipleGraphsPlacement Property

TreeLayout.MultipleGraphsPlacement Property

Gets or sets a value indicating how multiple unconnected subgraphs in the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }
Visual Basic

Public Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

Remarks

If the diagram contains several unconnected subgraphs, each of them is processed by the algorithm independently from the others. This property specifies how such subgraphs should be placed one relatively to another. The possible options are to arrange them in a row, in a column, or in such a way that the diagram covers a minimal area.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.NodeDistance Property

TreeLayout.NodeDistance Property

Gets or sets how much space to leave between nodes on the same level.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float NodeDistance { get; set; }
Visual Basic

Public Property NodeDistance As Single

Property Value

A float value specifying the distance between adjacent nodes.

Remarks

This property is ignored if Type is set to Radial.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Progress Property

TreeLayout.Progress Property

Gets or sets a delegate, which is invoked regularly during the layout process to inform clients about the layout progress.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public LayoutProgress Progress { get; set; }
Visual Basic

Public Property Progress As LayoutProgress

Property Value

A LayoutProgress delegate method to call while the algorithm proceeds

Remarks

It might take a lot of time to arrange large diagrams or run more iterations of the algorithm to get better results. In such situations, an application can indicate to end users the progress of the layout routine by connecting a delegate to this property.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.ReversedLinks Property

TreeLayout.ReversedLinks Property

Gets or sets a value indicating the link direction that relates parent nodes to child nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ReversedLinks { get; set; }
Visual Basic

Public Property ReversedLinks As Boolean

Property Value

true to indicate reversed direction, that is, the parent node is the one the link points to; otherwise, false.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Root Property

TreeLayout.Root Property

Gets or sets the root node of the tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public DiagramNode Root { get; set; }
Visual Basic

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class that represents the root node.

Remarks

If not set, MindFusion.Diagramming will try to find the root automatically. This root must be specified if IgnoreLinkDirection is set to true.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.StretchFactor Property

TreeLayout.StretchFactor Property

Gets or sets the stretch factor applied on Radial tree layouts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float StretchFactor { get; set; }
Visual Basic

Public Property StretchFactor As Single

Property Value

A real number specifying the ratio between the horizontal and vertical radii of radial layout outlines. The default is 1.

Remarks

When applying a radial layout, node layers are laid out in concentric circles around the Root node. Stretching them by changing this property makes layers laid out in elliptic outlines.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Type Property

TreeLayout.Type Property

Gets or sets what type of tree layout to apply to the diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public TreeLayoutType Type { get; set; }
Visual Basic

Public Property Type As TreeLayoutType

Property Value

A member of the TreeLayoutType enumeration.

Remarks

The available tree layout types include the following:

Layout type | Appearance
Cascading |
Centered |
Radial |
HorizontalVertical |

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutBalance Enumeration

TreeLayoutBalance Enumeration

Specifies how to order child nodes in order to produce tree layouts with custom balance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum TreeLayoutBalance
Visual Basic

Public Enumeration TreeLayoutBalance

Members

Member name | Description
LeftHeavy | Indicates that the child nodes with most total children will be processed first, thus producing a left-heavy layout.
Original | Indicates that the child order should not be changed.
RightHeavy | Indicates that the child nodes with least total children will be processed first, thus producing a right-heavy layout.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutDirections Enumeration

TreeLayoutDirections Enumeration

Specifies the direction of a tree layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum TreeLayoutDirections
Visual Basic

Public Enumeration TreeLayoutDirections

Members

Member name | Description
BottomToTop | Indicates a bottom-to-top direction.
LeftToRight | Indicates a left-to-right direction.
RightToLeft | Indicates a right-to-left direction.
TopToBottom | Indicates a top-to-bottom direction.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutLinkType Enumeration

TreeLayoutLinkType Enumeration

Specifies the style of the diagram links after they are laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum TreeLayoutLinkType
Visual Basic

Public Enumeration TreeLayoutLinkType

Members

Member name | Description
Cascading2 | Indicates cascading links with two segments.
Cascading3 | Indicates cascading links with three segments.
Rounded | Indicates Bézier links with a single segment.
Straight | Indicates straight links with a single segment.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutType Enumeration

TreeLayoutType Enumeration

Specifies the type of a tree layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum TreeLayoutType
Visual Basic

Public Enumeration TreeLayoutType

Members

Member name | Description
Cascading | Indicates cascading tree layout.
Centered | Indicates centered tree layout.
Radial | Indicates radial tree layout.
HorizontalVertical | Indicates the Horizontal-Vertical layout algorithm, used to arrange full binary trees.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.WinForms Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
ControlNode | ControlNode instances represent diagram nodes which can host .NET controls.
ControlNodeEventArgs | Contains the arguments passes to handlers of the control host serialization events, such as ControlNodeSerializing.
ControlNodeProperties | Stores the values of ControlNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from ControlNode, do so by deriving from ControlNodeProperties and overriding the ControlNode.SaveProperties, ControlNode.RestoreProperties, and ControlNode.CreateProperties methods.
CopyHostedControlEventArgs | Contains the arguments passes to the CopyHostedControl event handlers.
CustomCursors | Provides a collection of cursor object to use with the DiagramView control.
DiagramView | A .NET Windows Forms control that displays the content of a Diagram object.
DiagramView3D | Displays graphs in 3D.
InPlaceEditEventArgs | Contains the arguments passed in-place editing related event handlers.
ModifierKeyActions | Maps keyboard modifier keys to special actions in MindFusion.Diagramming such as panning and drawing selection rectangle.
Overview | The Overview control provides a scaled-down view of a DiagramView contents and allows scrolling and zooming the diagram with the mouse.
PaintControlEventArgs | Contains the arguments passed to the PaintControlHost event handlers.
PreviewOptions | Provides properties that allow customization of various aspects of the extended print-preview window.
PrintOptions | Allows customization of various aspects of printing and print-preview.
Ruler | The Ruler control provides horizontal and vertical scales that helps users measure diagram items.
ShapeListBox | The ShapeListBox control displays a set of shapes defined via the Shape class.
ShapeToolBar | The ShapeToolBar control displays image buttons representing selected shapes defined via the Shape class. These buttons can be used to create new shape nodes that have a specific shape or to change the shape of existing nodes.

Interfaces

Interface | Description
IPrintPreview | An interface that should be implemented by custom Print Preview forms.

Delegates

Delegate | Description
ControlNodeEventHandler | Represents methods that will handle control host serialization and deserialization events.
CopyHostedControlEventHandler | Represents methods that handle the CopyHostedControl event.
InPlaceEditEventHandler | Represents methods that will handle general in-place edit events.
PaintControlEventHandler | Represents methods that will handle control host-related custom-drawing events.

Enumerations

Enumeration | Description
Alignment | Specifies the alignment of an object relative to its container.
RulerUnit | Specifies a measurement unit for the Ruler.


MindFusion.Diagramming.WinForms.Alignment Enumeration

Alignment Enumeration

Specifies the alignment of an object relative to its container.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public enum Alignment
Visual Basic

Public Enumeration Alignment

Members

Member name | Description
Far | Specifies that the object is aligned at the opposite side of the origin position of the layout rectangle.
Near | Specifies that the object is aligned at the origin position of the layout rectangle.

See Also

MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode Class

ControlNode Class
Remarks See Also

ControlNode instances represent diagram nodes which can host .NET controls.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class ControlNode : DiagramNode
Visual Basic

Public Class ControlNode
Inherits DiagramNode

Remarks

A ControlNode instance might be used to implement advanced entity viewers or editors. An instance of any .NET Windows.Form.Control-derived class can be asigned to the Control property of the host. That might be a standard .NET control such as a DataGrid or your own custom or user control.

If the Behavior property of DiagramView is set to DrawControls or LinkControls, then users are allowed to draw conrol host nodes interactively. Such host nodes will have their Control initialized to an instance of the type specified via DefaultControlType.

If a user presses the mouse button while the mouse pointer is over a hosted control, MindFusion.Diagramming will either pass the mouse event to the control, or will try to intercept it in order to start moving or resizing the host node. That depends on the value of the ControlMouseAction property.

Performance note

If many ControlNode objects must be created consecutively, enclose the calls to Nodes.Add between SuspendLayout and ResumeLayout. Consider the sample code in the example section.

That example ensures that the OnLayout method is executed only once; otherwise it would be executed after each call to Nodes.Add. The .NET Framework invokes OnLayout when the positions of form controls change or when controls are added to or removed from a form. The DiagramView class overrides that method to update the location and size of its scrollbars, which however could lead to unnecessary delay if the method is called for each new ControlNode added.

Example

The following example illustrates how to add many ControlNode instances to the diagram without causing a layout pass for each individual control:

C#

diagView.SuspendLayout();

for (int i = 0; i < 500; ++i)
{
ControlNode host = new ControlNode(diagView);
host.Bounds = new RectangleF((i % 10) * 40, (i / 10) * 40, 30, 30);
diag.Nodes.Add(host);
}

diagView.ResumeLayout();
Visual Basic

diagView.SuspendLayout()

Dim i As Integer
For i = 0 To 499

Dim host As ControlNode = New ControlNode(diagView)
host.Bounds = New RectangleF((i Mod 10) * 40, (i / 10) * 40, 30, 30)
diag.Nodes.Add(host)

Next

diagView.ResumeLayout()

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.WinForms.ControlNode

See Also

ControlNode Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode Members

ControlNode Members
Constructors Properties Methods

ControlNode instances represent diagram nodes which can host .NET controls.

The following tables list the members exposed by the ControlNode type.

Public Constructors

Name | Description
ControlNode | Overloaded. Initializes a new instance of the ControlNode class.

Public Properties

Name | Description
Control | Gets or sets the .NET control hosted inside this node.
ControlMouseAction | Gets or sets a value indicating how to handle mouse messages sent to hosted control.
ControlPadding | Gets or sets how much space to leave between the borders of the node and the hosted control.
ForceControlRedraw | Calls Refresh() on the hosted control when updating the position of the host node. This forces the control to immediately redraw itself and its child controls.
Visible | Gets or sets a value indicating whether the node is visible.

Public Methods

Name | Description
Clone | Creates a copy of this item.
Draw | Draws the node on the specified IGraphics surface.
DrawShadow | Draws the shadow of this node on the specified IGraphics surface.

Protected Methods

Name | Description
CreateProperties | DiagramItem.CreateProperties override.
Dispose | Disposes any disposable resources managed by this control node.
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | Loads the contents of the control node from the specified XML reader, in a pre-5.0 format.
OnAdd | Called when the control node is added to a Diagram, either by users, programmatically or via undo / redo.
OnLoad | DiagramItem.OnLoad override.
OnRemove | DiagramItem.OnRemove override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
RestoreProperties | DiagramNode.RestoreProperties override.
SaveProperties | DiagramNode.SaveProperties override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetReference | Updates the reference to the specified object.

See Also

ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode Constructor

ControlNode Constructor

Initializes a new instance of the ControlNode class.

Overload List

Name | Description
ControlNode () | Initializes a new instance of the ControlNode class.
ControlNode (ControlNode) | Initializes a new instance of the ControlNode class using the specified control node as a prototype.
ControlNode (Diagram) | Initializes a new instance of the ControlNode class with default values supplied form the specified Diagram.
ControlNode (DiagramView) | Initializes a new instance of the ControlNode class.
ControlNode (DiagramView, Control) | Initializes a new instance of the ControlNode class.

See Also

ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode Constructor ()

ControlNode Constructor ()
See Also

Initializes a new instance of the ControlNode class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ControlNode ()
Visual Basic

Public Sub New ()

See Also

ControlNode Constructor Overload List
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode Constructor (ControlNode)

ControlNode Constructor (ControlNode)
See Also

Initializes a new instance of the ControlNode class using the specified control node as a prototype.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ControlNode (
ControlNode prototype
)
Visual Basic

Public Sub ControlNode ( _
prototype As ControlNode _
)

Parameters

prototype
The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

See Also

ControlNode Constructor Overload List
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode Constructor (Diagram)

ControlNode Constructor (Diagram)
See Also

Initializes a new instance of the ControlNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ControlNode (
Diagram diagram
)
Visual Basic

Public Sub ControlNode ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram from which to obtain default values for the node properties.

See Also

ControlNode Constructor Overload List
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode Constructor (DiagramView)

ControlNode Constructor (DiagramView)
See Also

Initializes a new instance of the ControlNode class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ControlNode (
DiagramView diagramView
)
Visual Basic

Public Sub ControlNode ( _
diagramView As DiagramView _
)

Parameters

diagramView

See Also

ControlNode Constructor Overload List
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode Constructor (DiagramView, Control)

ControlNode Constructor (DiagramView, Control)
See Also

Initializes a new instance of the ControlNode class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ControlNode (
DiagramView diagramView,
Control control
)
Visual Basic

Public Sub ControlNode ( _
diagramView As DiagramView, _
control As Control _
)

Parameters

diagramView
control

See Also

ControlNode Constructor Overload List
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode Methods

ControlNode Methods

Public Methods

Name | Description
Clone | Creates a copy of this item.
Draw | Draws the node on the specified IGraphics surface.
DrawShadow | Draws the shadow of this node on the specified IGraphics surface.

Protected Methods

Name | Description
CreateProperties | DiagramItem.CreateProperties override.
Dispose | Disposes any disposable resources managed by this control node.
LoadFrom | Deserializes the object from the specified reader.
LoadFromXml | Loads the item content from an XML element.
LoadObsolete | Loads the contents of the control node from the specified XML reader, in a pre-5.0 format.
OnAdd | Called when the control node is added to a Diagram, either by users, programmatically or via undo / redo.
OnLoad | DiagramItem.OnLoad override.
OnRemove | DiagramItem.OnRemove override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
RestoreProperties | DiagramNode.RestoreProperties override.
SaveProperties | DiagramNode.SaveProperties override.
SaveTo | Serializes the object to the specified writer.
SaveToXml | Saves the item content into an XML element.
SetReference | Updates the reference to the specified object.

See Also

ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.Clone Method

ControlNode.Clone Method

Creates a copy of this item.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public override DiagramItem Clone (
bool clipboard
)
Visual Basic

Public Overrides Function Clone ( _
clipboard As Boolean _
) As DiagramItem

Parameters

clipboard

Return Value

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.CreateProperties Method

ControlNode.CreateProperties Method

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual DiagramItemProperties CreateProperties ()
Visual Basic

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.Dispose Method

ControlNode.Dispose Method

Disposes any disposable resources managed by this control node.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
Specifies whether the method is called explicitly or from the garbage collector.

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.Draw Method

ControlNode.Draw Method

Draws the node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public override void Draw (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public Overrides Sub Draw ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
An IGraphics object where the node should be rendered.
options
Provides options for the drawing operation.

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.DrawShadow Method

ControlNode.DrawShadow Method

Draws the shadow of this node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)
Visual Basic

Public Overrides Sub DrawShadow ( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics
An IGraphics object where the shadow should be rendered.
options
A RenderOptions object specifying options for the drawing operation.

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.LoadFrom Method

ControlNode.LoadFrom Method

Deserializes the object from the specified reader.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void LoadFrom (
BinaryReader reader,
PersistContext context
)
Visual Basic

Protected Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As PersistContext _
)

Parameters

reader
context

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.LoadFromXml Method

ControlNode.LoadFromXml Method

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub LoadFromXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
context

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.LoadObsolete Method

ControlNode.LoadObsolete Method

Loads the contents of the control node from the specified XML reader, in a pre-5.0 format.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void LoadObsolete (
XmlReader reader,
SortedList brushes,
Object extra
)
Visual Basic

Protected Overridable Sub LoadObsolete ( _
reader As XmlReader, _
brushes As SortedList, _
extra As Object _
)

Parameters

reader
brushes
extra

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.OnAdd Method

ControlNode.OnAdd Method

Called when the control node is added to a Diagram, either by users, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnAdd ()
Visual Basic

Protected Overridable Sub OnAdd ()

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.OnLoad Method

ControlNode.OnLoad Method

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnLoad ()
Visual Basic

Protected Overridable Sub OnLoad ()

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.OnRemove Method

ControlNode.OnRemove Method

DiagramItem.OnRemove override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnRemove ()
Visual Basic

Protected Overridable Sub OnRemove ()

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.OnUpdateBounds Method

ControlNode.OnUpdateBounds Method

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnUpdateBounds ()
Visual Basic

Protected Overridable Sub OnUpdateBounds ()

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.RestoreProperties Method

ControlNode.RestoreProperties Method

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void RestoreProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub RestoreProperties ( _
props As DiagramItemProperties _
)

Parameters

props

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.SaveProperties Method

ControlNode.SaveProperties Method

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void SaveProperties (
DiagramItemProperties props
)
Visual Basic

Protected Overridable Sub SaveProperties ( _
props As DiagramItemProperties _
)

Parameters

props

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.SaveTo Method

ControlNode.SaveTo Method

Serializes the object to the specified writer.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void SaveTo (
BinaryWriter writer,
PersistContext context
)
Visual Basic

Protected Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As PersistContext _
)

Parameters

writer
context

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.SaveToXml Method

ControlNode.SaveToXml Method

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)
Visual Basic

Protected Overridable Sub SaveToXml ( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
context

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.SetReference Method

ControlNode.SetReference Method

Updates the reference to the specified object.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void SetReference (
int refId,
Object obj,
PersistContext ctx
)
Visual Basic

Protected Overridable Sub SetReference ( _
refId As Integer, _
obj As Object, _
ctx As PersistContext _
)

Parameters

refId
obj
ctx

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode Properties

ControlNode Properties

Public Properties

Name | Description
Control | Gets or sets the .NET control hosted inside this node.
ControlMouseAction | Gets or sets a value indicating how to handle mouse messages sent to hosted control.
ControlPadding | Gets or sets how much space to leave between the borders of the node and the hosted control.
ForceControlRedraw | Calls Refresh() on the hosted control when updating the position of the host node. This forces the control to immediately redraw itself and its child controls.
Visible | Gets or sets a value indicating whether the node is visible.

See Also

ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.Control Property

ControlNode.Control Property

Gets or sets the .NET control hosted inside this node.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Control Control { get; set; }
Visual Basic

Public Property Control As Control

Property Value

An instance of a any Control-derived class.

Remarks

A ControlNode drawn by the user has its Control initialized to an instance of the DefaultControlType type. At any time you can assign another control to this property.

Example

The example below shows how to create a new ControlNode node and set its control:

C#

ControlNode host = new ControlNode(diagramView);
host.Control = new DataGrid();
diagram.Nodes.Add(host);
Visual Basic

Dim host As ControlNode = New ControlNode(DiagramView)
host.Control = New DataGrid()
Diagram.Nodes.Add(host)

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.ControlMouseAction Property

ControlNode.ControlMouseAction Property

Gets or sets a value indicating how to handle mouse messages sent to hosted control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ControlMouseAction ControlMouseAction { get; set; }
Visual Basic

Public Property ControlMouseAction As ControlMouseAction

Property Value

A member of the ControlMouseAction enumeration. Initialized with the value of ControlMouseAction.

Remarks

Control nodes can handle mouse-down messages sent to their controls in several ways, depending on the value of this property.

Value | Description
PassToControl | Let the control handle the mouse click. Do not select the host node.
SelectHost | The host node gets selected when the control is clicked. The control is left to handle the mouse click too.
IgnoreControl | MindFusion.Diagramming tries to intercept the mouse message and not pass it to the control. That allows drawing links from anywhere within the control.

IgnoreControl works only with controls which do not capture the mouse.

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.ControlPadding Property

ControlNode.ControlPadding Property

Gets or sets how much space to leave between the borders of the node and the hosted control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public float ControlPadding { get; set; }
Visual Basic

Public Property ControlPadding As Single

Property Value

A float value specifying the size of the padding space in the unit set in MeasureUnit.

Remarks

By default, there is 1 unit padding space left between the Bounds border and the control itself. It is used to let users select ControlNode nodes by clicking in this area, for situations in which MindFusion.Diagramming cannot detect mouse-clicks on the control.

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.ForceControlRedraw Property

ControlNode.ForceControlRedraw Property

Calls Refresh() on the hosted control when updating the position of the host node. This forces the control to immediately redraw itself and its child controls.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool ForceControlRedraw { get; set; }
Visual Basic

Public Property ForceControlRedraw As Boolean

Property Value

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNode.Visible Property

ControlNode.Visible Property

Gets or sets a value indicating whether the node is visible.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public override bool Visible { get; set; }
Visual Basic

Public Overrides Property Visible As Boolean

Property Value

true if the control node is visible; otherwise, false.

See Also

ControlNode Members
ControlNode Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNodeEventArgs Class

ControlNodeEventArgs Class

Contains the arguments passes to handlers of the control host serialization events, such as ControlNodeSerializing.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class ControlNodeEventArgs : EventArgs
Visual Basic

Public Class ControlNodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.WinForms.ControlNodeEventArgs
MindFusion.Diagramming.WinForms.PaintControlEventArgs

See Also

ControlNodeEventArgs Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNodeEventArgs Members

ControlNodeEventArgs Members
Properties

Contains the arguments passes to handlers of the control host serialization events, such as ControlNodeSerializing.

The following tables list the members exposed by the ControlNodeEventArgs type.

Public Properties

Name | Description
Node | Gets a reference to the ControlNode being serialized or deserialized.
Stream | Gets a stream object where you can store or retrieve any custom data.

See Also

ControlNodeEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNodeEventArgs Properties

ControlNodeEventArgs Properties

Public Properties

Name | Description
Node | Gets a reference to the ControlNode being serialized or deserialized.
Stream | Gets a stream object where you can store or retrieve any custom data.

See Also

ControlNodeEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNodeEventArgs.Node Property

ControlNodeEventArgs.Node Property

Gets a reference to the ControlNode being serialized or deserialized.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ControlNode Node { get; }
Visual Basic

Public ReadOnly Property Node As ControlNode

Property Value

An instance of the ControlNode class.

See Also

ControlNodeEventArgs Members
ControlNodeEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNodeEventArgs.Stream Property

ControlNodeEventArgs.Stream Property

Gets a stream object where you can store or retrieve any custom data.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Stream Stream { get; }
Visual Basic

Public ReadOnly Property Stream As Stream

Property Value

An instance of the .NET Stream class.

See Also

ControlNodeEventArgs Members
ControlNodeEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNodeEventHandler Delegate

ControlNodeEventHandler Delegate

Represents methods that will handle control host serialization and deserialization events.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public delegate void ControlNodeEventHandler (
Object sender,
ControlNodeEventArgs e
)
Visual Basic

Public Delegate Sub ControlNodeEventHandler ( _
sender As Object, _
e As ControlNodeEventArgs _
)

Parameters

sender

The source of the event.

e

A ControlNodeEventArgs that contains the event data.

See Also

MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNodeProperties Class

ControlNodeProperties Class

Stores the values of ControlNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from ControlNode, do so by deriving from ControlNodeProperties and overriding the ControlNode.SaveProperties, ControlNode.RestoreProperties, and ControlNode.CreateProperties methods.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class ControlNodeProperties : DiagramNodeProperties
Visual Basic

Public Class ControlNodeProperties
Inherits DiagramNodeProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.WinForms.ControlNodeProperties

See Also

ControlNodeProperties Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNodeProperties Members

ControlNodeProperties Members
Constructors

Stores the values of ControlNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from ControlNode, do so by deriving from ControlNodeProperties and overriding the ControlNode.SaveProperties, ControlNode.RestoreProperties, and ControlNode.CreateProperties methods.

The following tables list the members exposed by the ControlNodeProperties type.

Public Constructors

Name | Description
ControlNodeProperties |

See Also

ControlNodeProperties Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ControlNodeProperties Constructor

ControlNodeProperties Constructor

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ControlNodeProperties ()
Visual Basic

Public Sub New ()

See Also

ControlNodeProperties Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.CopyHostedControlEventArgs Class

CopyHostedControlEventArgs Class

Contains the arguments passes to the CopyHostedControl event handlers.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class CopyHostedControlEventArgs : EventArgs
Visual Basic

Public Class CopyHostedControlEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.WinForms.CopyHostedControlEventArgs

See Also

CopyHostedControlEventArgs Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.CopyHostedControlEventArgs Members

CopyHostedControlEventArgs Members
Properties

Contains the arguments passes to the CopyHostedControl event handlers.

The following tables list the members exposed by the CopyHostedControlEventArgs type.

Public Properties

Name | Description
Destination | Gets a reference to the control embedded in the ControlNode clone.
Source | Gets a reference to the control embedded in the original ControlNode.

See Also

CopyHostedControlEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.CopyHostedControlEventArgs Properties

CopyHostedControlEventArgs Properties

Public Properties

Name | Description
Destination | Gets a reference to the control embedded in the ControlNode clone.
Source | Gets a reference to the control embedded in the original ControlNode.

See Also

CopyHostedControlEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.CopyHostedControlEventArgs.Destination Property

CopyHostedControlEventArgs.Destination Property

Gets a reference to the control embedded in the ControlNode clone.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Control Destination { get; }
Visual Basic

Public ReadOnly Property Destination As Control

Property Value

An instance of the .NET System.Windows.Forms.Control class.

See Also

CopyHostedControlEventArgs Members
CopyHostedControlEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.CopyHostedControlEventArgs.Source Property

CopyHostedControlEventArgs.Source Property

Gets a reference to the control embedded in the original ControlNode.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Control Source { get; }
Visual Basic

Public ReadOnly Property Source As Control

Property Value

An instance of the .NET System.Windows.Forms.Control class.

See Also

CopyHostedControlEventArgs Members
CopyHostedControlEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.CopyHostedControlEventHandler Delegate

CopyHostedControlEventHandler Delegate

Represents methods that handle the CopyHostedControl event.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public delegate void CopyHostedControlEventHandler (
Object sender,
CopyHostedControlEventArgs e
)
Visual Basic

Public Delegate Sub CopyHostedControlEventHandler ( _
sender As Object, _
e As CopyHostedControlEventArgs _
)

Parameters

sender

The source of the event.

e
A CopyHostedControlEventArgs that contains the event data.

See Also

MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.CustomCursors Class

CustomCursors Class

Provides a collection of cursor object to use with the DiagramView control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public sealed class CustomCursors
Visual Basic

Public NotInheritable Class CustomCursors

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.CustomCursors

See Also

CustomCursors Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.CustomCursors Members

CustomCursors Members
Properties

Provides a collection of cursor object to use with the DiagramView control.

The following tables list the members exposed by the CustomCursors type.

Public Properties

Name | Description
Rotate | Gets the cursor, which is displayed when the mouse is positioned over the rotation handle.

See Also

CustomCursors Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.CustomCursors Properties

CustomCursors Properties

Public Properties

Name | Description
Rotate | Gets the cursor, which is displayed when the mouse is positioned over the rotation handle.

See Also

CustomCursors Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.CustomCursors.Rotate Property

CustomCursors.Rotate Property

Gets the cursor, which is displayed when the mouse is positioned over the rotation handle.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public static Cursor Rotate { get; }
Visual Basic

Public Shared ReadOnly Property Rotate As Cursor

Property Value

An instance of the .NET Cursor class.

See Also

CustomCursors Members
CustomCursors Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView Class

DiagramView Class
Remarks See Also

A .NET Windows Forms control that displays the content of a Diagram object.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class DiagramView : Control
Visual Basic

Public Class DiagramView
Inherits Control

Remarks

Controlling Users' Actions

Most aspects of user interaction are controlled by the DiagramView class.

The Behavior property specifies how the control responds to user actions with the mouse. To create a custom behavior class, use the CustomBehavior property. To enable creating links or nodes of your custom type interactively by using the CustomLinkType or CustomNodeType properties, set Behavior to Custom.

AllowInplaceEdit specifies whether users are allowed to edit in-place the content of a diagram element by double-clicking it. Set InplaceEditAcceptOnEnter to true to accept changes and exit inplace-edit mode by pressing ENTER. The InplaceEditCancelOnEsc property allows setting the inplace editing to be rejected by pressing ESC.

MiddleButtonActions allows assigning the following actions to the middle mouse button: panning the diagram view, canceling the current drawing operation, or starting a multiple selection operation. ModifierKeyActions allows changing the function of keyboard modifier keys such as the ALT, CTRL and SHIFT keys.

Users actions can be validated by handling various events, fired while the diagram or zoom factor is changed, or a custom in-place editor control is created.

The following properties control what kind of links users can create: AllowLinksRepeat, AllowSelfLoops, AllowUnanchoredLinks, AllowUnconnectedLinks. The order in which items are hit-tested when clicking on them depends on the value of HitTestPriority.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Diagramming.WinForms.DiagramView

See Also

DiagramView Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView Members

DiagramView Members
Constructors Properties Methods Events

A .NET Windows Forms control that displays the content of a Diagram object.

The following tables list the members exposed by the DiagramView type.

Public Constructors

Name | Description
DiagramView | Overloaded.

Public Properties

Name | Description
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled.
AllowLinkCursor | Gets or sets the mouse cursor shown to the user when a link can be created.
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled.
AutoScrollAmount | Gets or sets the amount by which to auto-scroll the view when the mouse leaves the view boundaries while drawing.
Behavior | Gets or sets a value indicating how the control responds to user actions.
CatchGdiPlusExceptions | Specifies which part of the diagram is currently visible.
ControlHandlesStyle | Gets or sets the default value for the HandlesStyle property of new ControlNode nodes.
ControlMouseAction | Gets or sets a value indicating how to handle mouse messages sent to controls hosted in ControlNode objects.
CounterDiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.
CurrentCursor | Gets or sets the currently displayed mouse cursor.
Cursor | Control.Cursor override.
CustomBehavior | Gets or sets a custom behavior object specifying how MindFusion.Diagramming responds to mouse input.
CustomLinkType | Gets or sets a custom type of DiagramLink-derived objects that will be created when the users starts drawing with the mouse.
CustomNodeType | Gets or sets the type of a DiagramNode-derived class whose instance should be created when a user starts drawing.
DefaultControlType | Gets or sets the type of .NET controls to create in ControlNode objects.
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key.
DiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.
Diagram | Gets or sets the diagram displayed by this view.
DisallowCursor | Gets or sets the mouse cursor shown to the user when an object cannot be created at a particular location.
DisallowLinkCursor | Gets or sets the mouse cursor shown to the user, when a link is being created but cannot be ended at the current location.
DrawLinkCursor | Gets or sets the mouse cursor shown to the user when a link can be started at the current position.
HorizontalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object horizontally.
HScrollBar | Gets the horizontal scrollbar of the view.
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key should exit inplace-edit mode and accept changes made to text.
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit inplace-edit mode and reject changes made to text.
InplaceEditFont | Gets or sets the font of the inplace-edit text box.
LaneColumnResizeCursor | Gets or sets the mouse cursor shown to the user when dragging would resize a lane column header.
LaneRowResizeCursor | Gets or sets the mouse cursor shown to the user when dragging would resize a lane row header.
MiddleButtonActions | Gets or sets what actions are performed via the middle mouse button.
ModificationStart | Gets or sets how users can start modifying diagram items.
ModifierKeyActions | Gets an object, which allows changing the function of keyboard modifier keys such as CTRL and ALT.
MoveCursor | Gets or sets the mouse cursor shown to the user if the pointed object can be modified.
PanCursor | Gets or sets the mouse cursor displayed while panning the diagram view.
PointerCursor | Gets or sets the mouse cursor shown to the user when no modification is performed.
PreviewOptions | Gets an object which provides customization properties for the extended print-preview window.
PrintOptions | Gets an object which provides customization properties for printing and print-preview.
RightButtonActions | Gets or sets a combination of flags that specify what actions can be performed by clicking the right mouse button.
RotateCursor | Gets or sets the cursor shown when the mouse is over a node rotation handle.
ScrollX | Gets or sets the horizontal scroll position of the document.
ScrollY | Gets or sets the vertical scroll position of the document.
ShowScrollbars | Gets or sets a value indicating whether scrollbars are present in the document's area.
ShowToolTips | Gets or sets a value indicating whether tooltips are enabled.
SmoothingMode | Gets or sets the current anti-alias mode.
TextRenderingHint | Gets or sets the rendering mode for text displayed in this diagram.
ToolTipControl | Gets the ToolTip control used to display tool tips for the diagram items.
ToolTipDelay | Gets or sets the time that passes before a tool-tip appears when the mouse hovers over an item.
VerticalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object vertically.
VScrollBar | Gets the vertical scrollbar of the control.
ZoomFactor | Gets or sets the zoom factor used to scale up or down the diagram.

ProtectedProperties

Name | Description
DefaultSize | Gets or sets the initial size of the control when it is dropped into a form.

Public Methods

Name | Description
AdoptHostedControls | Adopts controls hosted in other views and moves them to this view.
BeginEdit | Overloaded.
BringIntoView | Scrolls the diagram area to make the specified item visible in this view.
ClientToDoc | Overloaded. Transforms points from the client coordinate space to the document coordinate space.
CopyToClipboard | Overloaded. Copies the currently selected items to the Windows clipboard.
CreatePrintDocument | Creates a PrintDocument object that can be used to print or preview the current diagram.
CutToClipboard | Overloaded. Cuts the currently selected items to the Windows clipboard.
DisposePrintDocument | Detaches the diagram's BeginPrint and PrintPage event handlers from the specified PrintDocument, created by a previous call to the CreatePrintDocument method.
DocToClient | Overloaded. Transforms points from the document coordinate space to the client coordinate space.
EndEdit | Exits inplace-edit mode and either accepts or rejects the changes made to the item's text.
LoadFromFile | Loads a diagram from a file.
LoadFromStream | Loads the Diagram document from a stream.
LoadFromString | Loads the diagram data from a string.
LoadFromXml | Overloaded. Loads the diagram from an XML.
PasteFromClipboard | Overloaded. Pastes diagram items from the Windows clipboard.
Print | Overloaded. Prints the current diagram on a printer selected by the user.
PrintPreview | Overloaded. Displays the standard .NET print-preview form.
PrintPreviewEx | Overloaded. Displays the extended MindFusion.Diagramming print-preview window or a custom preview form.
RecreateCacheImage | Recreates the cache bitmap, containing an image of the items that are not affected by the currently performed modification. This image is blitted to screen while dragging items, and the modified items are drawn over it.
SaveToFile | Saves the diagram into a file.
SaveToStream | Saves the diagram data into a .NET stream.
SaveToString | Saves the diagram as an ASCII string.
SaveToXml | Overloaded. Saves the diagram to an XML document.
ScrollTo | Scrolls the document to the specified point.
ZoomIn | Zooms document's items thus making them appear closer.
ZoomOut | Zooms the diagram out making items appear further away.
ZoomToFit | Zooms the view to fit the document contents in the Diagram.NET client area.
ZoomToRect | Zooms and scrolls the view to fit the specified document rectangle in the MindFusion.Diagramming client area.

Protected Methods

Name | Description
Dispose | Cleans up any resources being used.
OnDragDrop | Control.OnDragDrop override.
OnDragEnter | Contorl.OnDragEnter override.
OnDragOver | Control.OnDragOver override.
OnKeyDown | Control.OnKeyDown override.
OnLayout | Control.OnLayout override.
OnLostFocus | Control.OnLostFocus override.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnPaint | Control.OnPaint override.
OnPaintBackground | Control.OnPaintBackground override.

Public Events

Name | Description
CopyHostedControl | Raised when a ControlNode's hosted control is copied to or from the clipboard.
CreateEditControl | Raised to let you create a custom in-place editor control.
DeserializeControl | Lets you load custom data associated with a hosted control when deserializing a diagram from a stream.
DestroyEditControl | Raised to let you destroy a custom inplace editor control.
DiagramChanged | Occurs when the Diagram property value has changed.
EnterInplaceEditMode | Raised when entering inplace-edit mode.
LeaveInplaceEditMode | Raised when leaving inplace-edit mode.
PaintControl | Raised when a hosted control must be printed, drawn in a print-preview or Overview window, or drawn in an exported bitmap.
ScrollChanged | Occurs when the scroll position has changed.
SerializeControl | Lets you save additional data for hosted controls when serializing the diagram into a file.
ZoomFactorChanged | Occurs when the ZoomFactor property value has changed.

See Also

DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView Constructor

DiagramView Constructor

Overload List

Name | Description
DiagramView () | Initializes a new instance of the DiagramView class.
DiagramView (Diagram) | Initializes a new instance of the DiagramView class.

See Also

DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView Constructor ()

DiagramView Constructor ()
See Also

Initializes a new instance of the DiagramView class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public DiagramView ()
Visual Basic

Public Sub New ()

See Also

DiagramView Constructor Overload List
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView Constructor (Diagram)

DiagramView Constructor (Diagram)
See Also

Initializes a new instance of the DiagramView class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public DiagramView (
Diagram diagram
)
Visual Basic

Public Sub DiagramView ( _
diagram As Diagram _
)

Parameters

diagram

See Also

DiagramView Constructor Overload List
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView Methods

DiagramView Methods

Public Methods

Name | Description
AdoptHostedControls | Adopts controls hosted in other views and moves them to this view.
BeginEdit | Overloaded.
BringIntoView | Scrolls the diagram area to make the specified item visible in this view.
ClientToDoc | Overloaded. Transforms points from the client coordinate space to the document coordinate space.
CopyToClipboard | Overloaded. Copies the currently selected items to the Windows clipboard.
CreatePrintDocument | Creates a PrintDocument object that can be used to print or preview the current diagram.
CutToClipboard | Overloaded. Cuts the currently selected items to the Windows clipboard.
DisposePrintDocument | Detaches the diagram's BeginPrint and PrintPage event handlers from the specified PrintDocument, created by a previous call to the CreatePrintDocument method.
DocToClient | Overloaded. Transforms points from the document coordinate space to the client coordinate space.
EndEdit | Exits inplace-edit mode and either accepts or rejects the changes made to the item's text.
LoadFromFile | Loads a diagram from a file.
LoadFromStream | Loads the Diagram document from a stream.
LoadFromString | Loads the diagram data from a string.
LoadFromXml | Overloaded. Loads the diagram from an XML.
PasteFromClipboard | Overloaded. Pastes diagram items from the Windows clipboard.
Print | Overloaded. Prints the current diagram on a printer selected by the user.
PrintPreview | Overloaded. Displays the standard .NET print-preview form.
PrintPreviewEx | Overloaded. Displays the extended MindFusion.Diagramming print-preview window or a custom preview form.
RecreateCacheImage | Recreates the cache bitmap, containing an image of the items that are not affected by the currently performed modification. This image is blitted to screen while dragging items, and the modified items are drawn over it.
SaveToFile | Saves the diagram into a file.
SaveToStream | Saves the diagram data into a .NET stream.
SaveToString | Saves the diagram as an ASCII string.
SaveToXml | Overloaded. Saves the diagram to an XML document.
ScrollTo | Scrolls the document to the specified point.
ZoomIn | Zooms document's items thus making them appear closer.
ZoomOut | Zooms the diagram out making items appear further away.
ZoomToFit | Zooms the view to fit the document contents in the Diagram.NET client area.
ZoomToRect | Zooms and scrolls the view to fit the specified document rectangle in the MindFusion.Diagramming client area.

Protected Methods

Name | Description
Dispose | Cleans up any resources being used.
OnDragDrop | Control.OnDragDrop override.
OnDragEnter | Contorl.OnDragEnter override.
OnDragOver | Control.OnDragOver override.
OnKeyDown | Control.OnKeyDown override.
OnLayout | Control.OnLayout override.
OnLostFocus | Control.OnLostFocus override.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnPaint | Control.OnPaint override.
OnPaintBackground | Control.OnPaintBackground override.

See Also

DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.AdoptHostedControls Method

DiagramView.AdoptHostedControls Method

Adopts controls hosted in other views and moves them to this view.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void AdoptHostedControls (
bool onlyUnparented
)
Visual Basic

Public Sub AdoptHostedControls ( _
onlyUnparented As Boolean _
)

Parameters

onlyUnparented

true if only controls that currently do not have a parent view are adopted; false to adopt all controls.

Remarks

This method is useful when displaying ControlNode objects in multiple views. For example, you might want to invoke it when a view becomes the topmost window in a MDI application.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.BeginEdit Method

DiagramView.BeginEdit Method

Overload List

Name | Description
DiagramView.BeginEdit (InplaceEditable) | Enters inplace-edit mode, letting the user edit the text of the specified item.
DiagramView.BeginEdit (InplaceEditable, PointF) | Enters inplace-edit mode, letting the user edit the text of the specified item.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.BeginEdit Method (InplaceEditable)

DiagramView.BeginEdit Method (InplaceEditable)
See Also

Enters inplace-edit mode, letting the user edit the text of the specified item.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void BeginEdit (
InplaceEditable item
)
Visual Basic

Public Sub BeginEdit ( _
item As InplaceEditable _
)

Parameters

item

The diagram item or table's cell whose text should be edited.

Remarks

If AllowInplaceEdit is enabled, the user can start editing the text of an item by double-clicking the item.

By default, MindFusion.Diagramming displays a TextBox control to let the user enter text. You can create a custom editor by handling the CreateEditControl event.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
EndEdit


MindFusion.Diagramming.WinForms.DiagramView.BeginEdit Method (InplaceEditable, PointF)

DiagramView.BeginEdit Method (InplaceEditable, PointF)
See Also

Enters inplace-edit mode, letting the user edit the text of the specified item.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void BeginEdit (
InplaceEditable item,
PointF mousePosition
)
Visual Basic

Public Sub BeginEdit ( _
item As InplaceEditable, _
mousePosition As PointF _
)

Parameters

item
The diagram item or table's cell whose text should be edited.
mousePosition

A PointF specifying where the in-place edit box should appear.

Remarks

If AllowInplaceEdit is enabled, the user can start editing the text of an item by double-clicking the item.

See Also

BeginEdit Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.BringIntoView Method

DiagramView.BringIntoView Method

Scrolls the diagram area to make the specified item visible in this view.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void BringIntoView (
DiagramItem item
)
Visual Basic

Public Sub BringIntoView ( _
item As DiagramItem _
)

Parameters

item
The item to be brought into view.

Remarks

Scrolls the diagram view to ensure that the specified item is visible. No scrolling is done if the item is already in view.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ScrollTo


MindFusion.Diagramming.WinForms.DiagramView.ClientToDoc Method

DiagramView.ClientToDoc Method

Transforms points from the client coordinate space to the document coordinate space.

Overload List

Name | Description
DiagramView.ClientToDoc (Point) | Transforms points from the client coordinate space to the document coordinate space.
DiagramView.ClientToDoc (Rectangle) | Transforms points from the client coordinate space to the document coordinate space.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.ClientToDoc Method (Point)

DiagramView.ClientToDoc Method (Point)
See Also

Transforms points from the client coordinate space to the document coordinate space.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public PointF ClientToDoc (
Point clientPoint
)
Visual Basic

Public Function ClientToDoc ( _
clientPoint As Point _
) As PointF

Parameters

clientPoint
An instance of the .NET Point structure, whose coordinates should be transformed and returned.

Return Value

A .NET PointF instance, which represents the document coordinates of clientPoint.

Remarks

This method is useful when the document coordinates of a device point are needed.

See Also

ClientToDoc Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
DocToClient Method
Bounds Property


MindFusion.Diagramming.WinForms.DiagramView.ClientToDoc Method (Rectangle)

DiagramView.ClientToDoc Method (Rectangle)
See Also

Transforms points from the client coordinate space to the document coordinate space.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public RectangleF ClientToDoc (
Rectangle clientRect
)
Visual Basic

Public Function ClientToDoc ( _
clientRect As Rectangle _
) As RectangleF

Parameters

clientRect
An instance of the .NET Rectangle structure, whose coordinates should be transformed and returned.

Return Value

A .NET RectangleF instance, which represents the document coordinates of clientRect.

Remarks

This method is useful when the document coordinates of a rectangle are needed. For example, the method can be used to determine the visual area of the diagram by calling it with the control's ClientRectangle as an argument.

See Also

ClientToDoc Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
DocToClient Method
Bounds Property


MindFusion.Diagramming.WinForms.DiagramView.CopyToClipboard Method

DiagramView.CopyToClipboard Method

Copies the currently selected items to the Windows clipboard.

Overload List

Name | Description
DiagramView.CopyToClipboard (Boolean) | Copies the current selection of items to the clipboard.
DiagramView.CopyToClipboard (Boolean, Boolean) | Copies the current selection of items to the clipboard.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.CopyToClipboard Method (Boolean)

DiagramView.CopyToClipboard Method (Boolean)
See Also

Copies the current selection of items to the clipboard.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool CopyToClipboard (
bool persist
)
Visual Basic

Public Function CopyToClipboard ( _
persist As Boolean _
) As Boolean

Parameters

persist
true if you want data to remain on the Clipboard after this application exits; otherwise, false.

Return Value

true if items were successfully copied to clipboard; otherwise, false.

Remarks

Call this method when writing message handler for the Copy command from the Edit menu of your application. MindFusion.Diagramming does not provide keyboard interface for clipboard operations, so you might assign a CTRL+C shortcut to this command.

This overloaded method simply calls the second one, setting false as the value of the groups argument.

See Also

CopyToClipboard Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
CutToClipboard Method
PasteFromClipboard Method


MindFusion.Diagramming.WinForms.DiagramView.CopyToClipboard Method (Boolean, Boolean)

DiagramView.CopyToClipboard Method (Boolean, Boolean)
See Also

Copies the current selection of items to the clipboard.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool CopyToClipboard (
bool persist,
bool groups
)
Visual Basic

Public Function CopyToClipboard ( _
persist As Boolean, _
groups As Boolean _
) As Boolean

Parameters

persist
true if you want data to remain on the Clipboard after this application exits; otherwise, false.
groups
true to copy item groups; otherwise, false.

Return Value

true if items were successfully copied; otherwise, false.

Remarks

Call this method when writing message handler for the Copy command from the Edit menu of your application. MindFusion.Diagramming does not provide keyboard interface for clipboard operations, so you might assign a CTRL+C shortcut to this command.

The first overloaded method simply calls this one, setting false as the value of the groups argument. When calling this method with groups set to true, only the first level of groups attached to selected items are copied. In that case, the subordinated items included in the groups are copied too.

See Also

CopyToClipboard Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
CutToClipboard Method
PasteFromClipboard Method


MindFusion.Diagramming.WinForms.DiagramView.CreatePrintDocument Method

DiagramView.CreatePrintDocument Method

Creates a PrintDocument object that can be used to print or preview the current diagram.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public PrintDocument CreatePrintDocument ()
Visual Basic

Public Function CreatePrintDocument () As PrintDocument

Return Value

A PrintDocument instance.

Remarks

The DisposePrintDocument method must be called when done using the document.

Example

The following example shows how to use this method to display the diagram in a PrintPreviewControl placed inside your own form.

C#

previewControl.Document = diagramView.CreatePrintDocument();
Visual Basic

previewControl.Document = diagramView.CreatePrintDocument()

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.CutToClipboard Method

DiagramView.CutToClipboard Method

Cuts the currently selected items to the Windows clipboard.

Overload List

Name | Description
DiagramView.CutToClipboard (Boolean) | Cuts the currently selected items to the Windows clipboard.
DiagramView.CutToClipboard (Boolean, Boolean) | Cuts the currently selected items to the Windows clipboard.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.CutToClipboard Method (Boolean)

DiagramView.CutToClipboard Method (Boolean)
See Also

Cuts the currently selected items to the Windows clipboard.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool CutToClipboard (
bool copy
)
Visual Basic

Public Function CutToClipboard ( _
copy As Boolean _
) As Boolean

Parameters

copy
true if you want data to remain on the clipboard after this application exits; otherwise, false.

Return Value

true if items are successfully copied to clipboard; otherwise, false.

Remarks

Call this method when writing message handler for the Cut command from the Edit menu of your application. MindFusion.Diagramming does not provide keyboard interface for clipboard operations, so you might assign a CTRL+X shortcut to this command.

The method deletes all selected items after copying them to clipboard. That operation can be undone in the sense that deleted items are restored by calling UndoManager.Undo; however the clipboard data is not restored and the items remain in the clipboard available for further pasting.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
CopyToClipboard
PasteFromClipboard


MindFusion.Diagramming.WinForms.DiagramView.CutToClipboard Method (Boolean, Boolean)

DiagramView.CutToClipboard Method (Boolean, Boolean)
See Also

Cuts the currently selected items to the Windows clipboard.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool CutToClipboard (
bool copy,
bool groups
)
Visual Basic

Public Function CutToClipboard ( _
copy As Boolean, _
groups As Boolean _
) As Boolean

Parameters

copy
true if you want data to remain on the clipboard after this application exits; otherwise, false.
groups
true to cut item groups; otherwise, false.

Return Value

true if items are successfully copied to clipboard; otherwise, false.

Remarks

Call this method when writing message handler for the Cut command from the Edit menu of your application. MindFusion.Diagramming does not provide keyboard interface for clipboard operations, so you might assign a CTRL+X shortcut to this command.

When calling this method with the groups argument set to true, only the first level of groups attached to selected items are copied. In that case, the subordinated items included in the groups are copied too.

The method deletes all selected items after copying them to clipboard. That operation can be undone in the sense that deleted items are restored by calling UndoManager.Undo; however the clipboard data is not restored and the items remain in the clipboard available for further pasting.

See Also

CutToClipboard Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
CopyToClipboard Method
PasteFromClipboard Method


MindFusion.Diagramming.WinForms.DiagramView.Dispose Method

DiagramView.Dispose Method

Cleans up any resources being used.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.DisposePrintDocument Method

DiagramView.DisposePrintDocument Method

Detaches the diagram's BeginPrint and PrintPage event handlers from the specified PrintDocument, created by a previous call to the CreatePrintDocument method.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void DisposePrintDocument (
PrintDocument doc
)
Visual Basic

Public Sub DisposePrintDocument ( _
doc As PrintDocument _
)

Parameters

doc
A PrintDocument instance created by a previous call to the CreatePrintDocument method.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.DocToClient Method

DiagramView.DocToClient Method

Transforms points from the document coordinate space to the client coordinate space.

Overload List

Name | Description
DiagramView.DocToClient (PointF) | Transforms points from the document coordinate space to the client coordinate space.
DiagramView.DocToClient (RectangleF) | Converts the specified rectangle from document to client coordinates.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.DocToClient Method (PointF)

DiagramView.DocToClient Method (PointF)
See Also

Transforms points from the document coordinate space to the client coordinate space.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Point DocToClient (
PointF docPoint
)
Visual Basic

Public Function DocToClient ( _
docPoint As PointF _
) As Point

Parameters

docPoint
An instance of the .NET PointF structure, whose coordinates should be transformed and returned.

Return Value

A Point instance, which represents the client coordinates of docPoint.

Remarks

This method is useful when the client (device) coordinates of a diagram location are needed. For example, it can be used to get the device point where a context menu should be displayed.

See Also

DocToClient Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ClientToDoc
Bounds


MindFusion.Diagramming.WinForms.DiagramView.DocToClient Method (RectangleF)

DiagramView.DocToClient Method (RectangleF)
See Also

Converts the specified rectangle from document to client coordinates.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Rectangle DocToClient (
RectangleF docRect
)
Visual Basic

Public Function DocToClient ( _
docRect As RectangleF _
) As Rectangle

Parameters

docRect
An instance of the .NET RectangleF structure, whose coordinates should be transformed and returned.

Return Value

A Rectangle instance, which represents the client coordinates of docRect.

Remarks

This method is useful when the client (device) coordinates of a diagram location are needed. For example, it can be used to get the device point where a context menu should be displayed.

See Also

DocToClient Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ClientToDoc
Bounds


MindFusion.Diagramming.WinForms.DiagramView.EndEdit Method

DiagramView.EndEdit Method

Exits inplace-edit mode and either accepts or rejects the changes made to the item's text.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void EndEdit (
bool accept
)
Visual Basic

Public Sub EndEdit ( _
accept As Boolean _
)

Parameters

accept
true to accept changes made to text; false to reject them.

Remarks

A user can exit inplace-edit mode by clicking outside of the edit control; that accept the changes made to text. Pressing ENTER or ESC exits inplace-edit mode if respectively InplaceEditAcceptOnEnter and InplaceEditCancelOnEsc are enabled. Pressing ENTER accepts changes and ESC rejects them.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
BeginEdit


MindFusion.Diagramming.WinForms.DiagramView.LoadFromFile Method

DiagramView.LoadFromFile Method

Loads a diagram from a file.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void LoadFromFile (
string fileName
)
Visual Basic

Public Sub LoadFromFile ( _
fileName As String _
)

Parameters

fileName
The name of the file the data shall be read from.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
LoadFromStream
LoadFromXml


MindFusion.Diagramming.WinForms.DiagramView.LoadFromStream Method

DiagramView.LoadFromStream Method

Loads the Diagram document from a stream.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void LoadFromStream (
Stream stream
)
Visual Basic

Public Sub LoadFromStream ( _
stream As Stream _
)

Parameters

stream
Object of a Stream-derived class.

Remarks

The method loads previously saved diagram from a stream. Stream wraps sequences of bytes, such as files, memory buffers, TCP sockets and more. The method throws exception if the stream given as argument does not contain data of the proper format. Diagrams can be saved in a stream using the SaveToStream method.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.LoadFromString Method

DiagramView.LoadFromString Method

Loads the diagram data from a string.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void LoadFromString (
string str
)
Visual Basic

Public Sub LoadFromString ( _
str As String _
)

Parameters

str

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.LoadFromXml Method

DiagramView.LoadFromXml Method

Loads the diagram from an XML.

Overload List

Name | Description
DiagramView.LoadFromXml (String) | Loads the diagram from an XML file.
DiagramView.LoadFromXml (XmlDocument) | Loads the diagram from an XML document.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.LoadFromXml Method (String)

DiagramView.LoadFromXml Method (String)
See Also

Loads the diagram from an XML file.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void LoadFromXml (
string fileName
)
Visual Basic

Public Sub LoadFromXml ( _
fileName As String _
)

Parameters

fileName

The name of the XML file from which to load the diagram.

See Also

LoadFromXml Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.LoadFromXml Method (XmlDocument)

DiagramView.LoadFromXml Method (XmlDocument)
See Also

Loads the diagram from an XML document.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void LoadFromXml (
XmlDocument document
)
Visual Basic

Public Sub LoadFromXml ( _
document As XmlDocument _
)

Parameters

document
The XML document from which to load the diagram.

See Also

LoadFromXml Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.OnDragDrop Method

DiagramView.OnDragDrop Method

Control.OnDragDrop override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnDragDrop (
DragEventArgs e
)
Visual Basic

Protected Overridable Sub OnDragDrop ( _
e As DragEventArgs _
)

Parameters

e
A DragEventArgs that provides data for the event.

Remarks

Raises the DragDrop event.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
OnDragOver


MindFusion.Diagramming.WinForms.DiagramView.OnDragEnter Method

DiagramView.OnDragEnter Method

Contorl.OnDragEnter override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnDragEnter (
DragEventArgs e
)
Visual Basic

Protected Overridable Sub OnDragEnter ( _
e As DragEventArgs _
)

Parameters

e
A DragEventArgs that provides data for the event.

Remarks

Raises the DragEnter event.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
OnDragDrop


MindFusion.Diagramming.WinForms.DiagramView.OnDragOver Method

DiagramView.OnDragOver Method

Control.OnDragOver override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnDragOver (
DragEventArgs drgevent
)
Visual Basic

Protected Overridable Sub OnDragOver ( _
drgevent As DragEventArgs _
)

Parameters

drgevent
A DragEventArgs that provides data for the event.

Remarks

Raises the DragOver event.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
OnDragEnter


MindFusion.Diagramming.WinForms.DiagramView.OnKeyDown Method

DiagramView.OnKeyDown Method

Control.OnKeyDown override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnKeyDown (
KeyEventArgs e
)
Visual Basic

Protected Overridable Sub OnKeyDown ( _
e As KeyEventArgs _
)

Parameters

e
A KeyEventArgs that contains the event data.

Remarks

Raises the KeyDown event.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
OnMouseDown


MindFusion.Diagramming.WinForms.DiagramView.OnLayout Method

DiagramView.OnLayout Method

Control.OnLayout override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnLayout (
LayoutEventArgs e
)
Visual Basic

Protected Overridable Sub OnLayout ( _
e As LayoutEventArgs _
)

Parameters

e
A LayoutEventArgs that contains the event data.

Remarks

Raises the Layout event.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.OnLostFocus Method

DiagramView.OnLostFocus Method

Control.OnLostFocus override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnLostFocus (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnLostFocus ( _
e As EventArgs _
)

Parameters

e
An EventArgs that contains the event data.

Remarks

Raises the LostFocus event.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.OnMouseDown Method

DiagramView.OnMouseDown Method

Control.OnMouseDown override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnMouseDown (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseDown ( _
e As MouseEventArgs _
)

Parameters

e
A MouseEventArgs that contains the event data.

Remarks

Raises the MouseDown event.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.OnMouseMove Method

DiagramView.OnMouseMove Method

Control.OnMouseMove override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnMouseMove (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseMove ( _
e As MouseEventArgs _
)

Parameters

e
A MouseEventArgs that contains the event data.

Remarks

Raises the MouseMove event.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.OnMouseUp Method

DiagramView.OnMouseUp Method

Control.OnMouseUp override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnMouseUp (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseUp ( _
e As MouseEventArgs _
)

Parameters

e
A MouseEventArgs that contains the event data.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.OnPaint Method

DiagramView.OnPaint Method

Control.OnPaint override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnPaint (
PaintEventArgs pe
)
Visual Basic

Protected Overridable Sub OnPaint ( _
pe As PaintEventArgs _
)

Parameters

pe
A PaintEventArgs that contains the event data.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.OnPaintBackground Method

DiagramView.OnPaintBackground Method

Control.OnPaintBackground override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnPaintBackground (
PaintEventArgs pevent
)
Visual Basic

Protected Overridable Sub OnPaintBackground ( _
pevent As PaintEventArgs _
)

Parameters

pevent
A PaintEventArgs that contains information about the DiagramView to paint.

Remarks

Paints the background of the DiagramView.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.PasteFromClipboard Method

DiagramView.PasteFromClipboard Method

Pastes diagram items from the Windows clipboard.

Overload List

Name | Description
DiagramView.PasteFromClipboard (Single, Single) | Pastes diagram items from the Windows clipboard.
DiagramView.PasteFromClipboard (Single, Single, Boolean) | Pastes diagram items from the Windows clipboard.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.PasteFromClipboard Method (Single, Single)

DiagramView.PasteFromClipboard Method (Single, Single)
See Also

Pastes diagram items from the Windows clipboard.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool PasteFromClipboard (
float dx,
float dy
)
Visual Basic

Public Function PasteFromClipboard ( _
dx As Single, _
dy As Single _
) As Boolean

Parameters

dx
The horizontal offset of pasted items from their original positions.
dy
The vertical offset of pasted items from their original positions.

Return Value

true if successful; otherwise, false.

Remarks

If MindFusion.Diagramming items are available in the clipboard, this method clones them and adds them to the current diagram. Non-zero dx / dy offset is useful when pasting items several times consecutively, so the pasted items don't overlay the original ones completely.

Example

Copying and pasting can be implemented like that:

C#

private float pasteDX;
private float pasteDY;

private void miCopy_Click(object sender, System.EventArgs e)
{
diagramView.CopyToClipboard(true);
pasteDX = 0;
pasteDY = 0;
}

private void miPaste_Click(object sender , System.EventArgs e)
{
pasteDX += 10;
pasteDY += 10;
diagramView.PasteFromClipboard(pasteDX, pasteDY);
}
Visual Basic

Private pasteDX As Single
Private pasteDY As Single

Private Sub miCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles miCopy.Click

diagramView.CopyToClipboard(True)
pasteDX = 0
pasteDY = 0

End Sub

Private Sub miPaste_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles miPaste.Click

pasteDX += 10
pasteDY += 10
diagramView.PasteFromClipboard(pasteDX, pasteDY)

End Sub

See Also

PasteFromClipboard Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
CopyToClipboard
CutToClipboard


MindFusion.Diagramming.WinForms.DiagramView.PasteFromClipboard Method (Single, Single, Boolean)

DiagramView.PasteFromClipboard Method (Single, Single, Boolean)
See Also

Pastes diagram items from the Windows clipboard.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool PasteFromClipboard (
float dx,
float dy,
bool unconnectedLinks
)
Visual Basic

Public Function PasteFromClipboard ( _
dx As Single, _
dy As Single, _
unconnectedLinks As Boolean _
) As Boolean

Parameters

dx
The horizontal offset of pasted items from their original positions.
dy
The vertical offset of pasted items from their original positions.
unconnectedLinks
true to allow pasting links whose origin or destination node has not been copied; otherwise, false.

Return Value

true if successful; otherwise, false.

Remarks

If MindFusion.Diagramming items are available in the clipboard, this method clones them and adds them to the current diagram. Non-zero dx / dy offset is useful when pasting items several times consecutively, so the pasted items don't overlay the original ones completely.

See Also

PasteFromClipboard Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
CopyToClipboard
CutToClipboard


MindFusion.Diagramming.WinForms.DiagramView.Print Method

DiagramView.Print Method

Prints the current diagram on a printer selected by the user.

Overload List

Name | Description
DiagramView.Print () | Prints the diagram to the default printer.
DiagramView.Print (PrintDocument) | Prints the diagram to the specified document.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.Print Method ()

DiagramView.Print Method ()
See Also

Prints the diagram to the default printer.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void Print ()
Visual Basic

Public Sub Print ()

Remarks

The method displays the standard Windows print dialog, allowing users to select a printer and choose which portions of the document to print. The smallest rectangular area of the document that contains all diagram elements is printed. Various setting for the print job can be assigned via the PrintOptions structure. That structure exposes as properties the title of the print job and several flags that control whether images, shadows, headers, and so on, are printed. PrintOptions values are used also in preview mode. That ensures similar output on the printed pages and the display.

The second overloaded method does not display print dialog, but uses the options specified through the doc argument. The DefaultPageSettings property of PrintDocument allows setting page size and orientation. The PrinterSettings property allows choosing the device used to print the diagram. It is also possible to attach print-event handlers to doc and do custom printing in addition to the MindFusion.Diagramming standard output.

See Also

Print Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
Bounds
PrintPreview
PrintPreviewEx
Printable


MindFusion.Diagramming.WinForms.DiagramView.Print Method (PrintDocument)

DiagramView.Print Method (PrintDocument)
See Also

Prints the diagram to the specified document.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void Print (
PrintDocument doc
)
Visual Basic

Public Sub Print ( _
doc As PrintDocument _
)

Parameters

doc
An instance of the .NET PrintDocument class.

Remarks

The smallest rectangular area of the document that contains all diagram elements is printed. Various setting for the print job can be assigned via the PrintOptions structure. That structure exposes as properties the title of the print job and several flags that control whether images, shadows, headers, and so on, are printed. PrintOptions values are used also in preview mode. That ensures similar output on the printed pages and the display.

This method does not display print dialog, but uses the options specified through the doc argument. The DefaultPageSettings property of PrintDocument allows setting page size and orientation. The PrinterSettings property allows choosing the device used to print the diagram. It is also possible to attach print-event handlers to doc and do custom printing in addition to the MindFusion.Diagramming standard output.

See Also

Print Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
Bounds
PrintPreview
PrintPreviewEx
Printable


MindFusion.Diagramming.WinForms.DiagramView.PrintPreview Method

DiagramView.PrintPreview Method

Displays the standard .NET print-preview form.

Overload List

Name | Description
DiagramView.PrintPreview () | Displays the standard .NET print preview form.
DiagramView.PrintPreview (PrintDocument) | Displays the standard .NET print preview form.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
Bounds
Print
PrintOptions
PrintPreviewEx


MindFusion.Diagramming.WinForms.DiagramView.PrintPreview Method ()

DiagramView.PrintPreview Method ()
See Also

Displays the standard .NET print preview form.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void PrintPreview ()
Visual Basic

Public Sub PrintPreview ()

Remarks

Opens an extended Print Preview window for the current diagram. Compared to the standard .NET preview dialog, the extended one provides better-looking icons and additional buttons such as "page orientation" and "scale to page". PreviewOptions allows assigning custom images to the preview toolbar buttons and localizing the menu item and tooltip texts.

The preview output is rendered with the same settings that are used for printing, assigned by the PrintOptions structure. That ensures uniform output of the printed document both on paper and in the preview mode. Print job settings include document title and several flags that control whether images, shadows, headers, and so on, are printed.

The second overloaded method allows attaching print-event handlers to doc and doing custom printing in addition to the MindFusion.Diagramming standard output.

It is possible to create your own preview form and specify it as an argument to the third overload of PrintPreviewEx. Your preview form class must implement the IPrintPreview interface defined in MindFusion.Diagramming.WinForms.dll. IPrintPreview contains a single property called Document of type System.Drawing.Printing.PrintDocument. The method sets this property to the diagram document and calls the ShowDialog method of your form.

See Also

PrintPreview Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
Bounds
Print
PrintOptions
PrintPreviewEx


MindFusion.Diagramming.WinForms.DiagramView.PrintPreview Method (PrintDocument)

DiagramView.PrintPreview Method (PrintDocument)
See Also

Displays the standard .NET print preview form.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void PrintPreview (
PrintDocument doc
)
Visual Basic

Public Sub PrintPreview ( _
doc As PrintDocument _
)

Parameters

doc
An instance of the .NET PrintDocument class.

Remarks

Opens an extended Print Preview window for the current diagram. Compared to the standard .NET preview dialog, the extended one provides better-looking icons and additional buttons such as "page orientation" and "scale to page". PreviewOptions allows assigning custom images to the preview toolbar buttons and localizing the menu item and tooltip texts.

The preview output is rendered with the same settings that are used for printing, assigned by the PrintOptions structure. That ensures uniform output of the printed document both on paper and in the preview mode. Print job settings include document title and several flags that control whether images, shadows, headers, and so on, are printed.

This overloaded method allows attaching print-event handlers to doc and doing custom printing in addition to the MindFusion.Diagramming standard output.

It is possible to create your own preview form and specify it as an argument to the third overload of PrintPreviewEx. Your preview form class must implement the IPrintPreview interface defined in MindFusion.Diagramming.WinForms.dll. IPrintPreview contains a single property called Document of type System.Drawing.Printing.PrintDocument. The method sets this property to the diagram document and calls the ShowDialog method of your form.

See Also

PrintPreview Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
Bounds
Print
PrintOptions
PrintPreviewEx


MindFusion.Diagramming.WinForms.DiagramView.PrintPreviewEx Method

DiagramView.PrintPreviewEx Method

Displays the extended MindFusion.Diagramming print-preview window or a custom preview form.

Overload List

Name | Description
DiagramView.PrintPreviewEx () | Displays the extended MindFusion.Diagramming print-preview window.
DiagramView.PrintPreviewEx (Form) | Displays a custom preview form.
DiagramView.PrintPreviewEx (PrintDocument) | Displays an extended print-preview window.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
Bounds
Print
PrintOptions
PrintPreview


MindFusion.Diagramming.WinForms.DiagramView.PrintPreviewEx Method ()

DiagramView.PrintPreviewEx Method ()
See Also

Displays the extended MindFusion.Diagramming print-preview window.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void PrintPreviewEx ()
Visual Basic

Public Sub PrintPreviewEx ()

Remarks

Opens an extended Print Preview window for the current diagram. Compared to the standard .NET preview dialog, the extended one provides better-looking icons and additional buttons such as "page orientation" and "scale to page". PreviewOptions allows assigning custom images to the preview toolbar buttons and localizing the menu item and tooltip texts.

The preview output is rendered with the same settings that are used for printing, assigned by the PrintOptions structure. That ensures uniform output of the printed document both on paper and in the preview mode. Print job settings include document title and several flags that control whether images, shadows, headers, and so on, are printed.

It is possible to create your own preview form and specify it as an argument to the third overload of PrintPreviewEx. Your preview form class must implement the IPrintPreview interface defined in MindFusion.Diagramming.WinForms.dll. IPrintPreview contains a single property called Document of type System.Drawing.Printing.PrintDocument. The method sets this property to the diagram document and calls the ShowDialog method of your form.

See Also

PrintPreviewEx Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
Bounds
Print
PrintOptions
PrintPreview
PrintPreviewEx(Form)
PrintPreviewEx Method (Doc)


MindFusion.Diagramming.WinForms.DiagramView.PrintPreviewEx Method (Form)

DiagramView.PrintPreviewEx Method (Form)
See Also

Displays a custom preview form.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void PrintPreviewEx (
Form previewForm
)
Visual Basic

Public Sub PrintPreviewEx ( _
previewForm As Form _
)

Parameters

previewForm
A custom preview form to display instead of the standard .NET print preview dialog.

Remarks

Opens an extended Print Preview window for the current diagram. Compared to the standard .NET preview dialog, the extended one provides better-looking icons and additional buttons such as "page orientation" and "scale to page". PreviewOptions allows assigning custom images to the preview toolbar buttons and localizing the menu item and tooltip texts.

The preview output is rendered with the same settings that are used for printing, assigned by the PrintOptions structure. That ensures uniform output of the printed document both on paper and in the preview mode. Print job settings include document title and several flags that control whether images, shadows, headers, and so on, are printed.

It is possible to create your own preview form and specify it as an argument. Your preview form class must implement the IPrintPreview interface defined in MindFusion.Diagramming.WinForms.dll. IPrintPreview contains a single property called Document of type System.Drawing.Printing.

See Also

PrintPreviewEx Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
Bounds
Print
PrintOptions
PrintPreview


MindFusion.Diagramming.WinForms.DiagramView.PrintPreviewEx Method (PrintDocument)

DiagramView.PrintPreviewEx Method (PrintDocument)
See Also

Displays an extended print-preview window.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void PrintPreviewEx (
PrintDocument doc
)
Visual Basic

Public Sub PrintPreviewEx ( _
doc As PrintDocument _
)

Parameters

doc
An instance of the .NET PrintDocument class.

Remarks

Opens an extended Print Preview window for the current diagram. Compared to the standard .NET preview dialog, the extended one provides better-looking icons and additional buttons such as "page orientation" and "scale to page". PreviewOptions allows assigning custom images to the preview toolbar buttons and localizing the menu item and tooltip texts.

The preview output is rendered with the same settings that are used for printing, assigned by the PrintOptions structure. That ensures uniform output of the printed document both on paper and in the preview mode. Print job settings include document title and several flags that control whether images, shadows, headers, and so on, are printed.

You can attach print-event handlers to doc and do custom printing in addition to the MindFusion.Diagramming standard output.

It is possible to create your own preview form and specify it as an argument to the third overload of PrintPreviewEx. Your preview form class must implement the IPrintPreview interface defined in MindFusion.Diagramming.WinForms.dll. IPrintPreview contains a single property called Document of type System.Drawing.Printing.PrintDocument. The method sets this property to the diagram document and calls the ShowDialog method of your form.

See Also

PrintPreviewEx Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
Bounds
Print
PrintOptions
PrintPreview


MindFusion.Diagramming.WinForms.DiagramView.RecreateCacheImage Method

DiagramView.RecreateCacheImage Method

Recreates the cache bitmap, containing an image of the items that are not affected by the currently performed modification. This image is blitted to screen while dragging items, and the modified items are drawn over it.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void RecreateCacheImage ()
Visual Basic

Public Sub RecreateCacheImage ()

Remarks

In order to repaint the screen quickly while modifying items or drawing new items, MindFusion.Diagramming caches the representation of all items not affected by the modification in an off-screen bitmap. When the mouse is moved, the cache bitmap is blitted to the screen and only the item being modified is redrawn. That provides for good performance while users create or edit the diagram interactively.

However, if an application changes the appearance properties of items in the cache while handling the MouseMove event, the changes won't be visualized correctly on the screen until the mouse button is released and drawing completes. Use RecreateCacheImage to recreate the cache bitmap so the changes in item's appearance are immediately visualized.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.SaveToFile Method

DiagramView.SaveToFile Method

Saves the diagram into a file.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void SaveToFile (
string fileName,
bool clearDirty
)
Visual Basic

Public Sub SaveToFile ( _
fileName As String, _
clearDirty As Boolean _
)

Parameters

fileName
The full path and name of the disk file where the diagram should be saved.
clearDirty
Indicates whether the Dirty flag should be cleared.

Remarks

SaveToFile creates a file stream and invokes the SaveToStream method on it. The file contents can be loaded later using the LoadFromFile method.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.SaveToStream Method

DiagramView.SaveToStream Method

Saves the diagram data into a .NET stream.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void SaveToStream (
Stream stream,
bool clearDirty
)
Visual Basic

Public Sub SaveToStream ( _
stream As Stream, _
clearDirty As Boolean _
)

Parameters

stream
An instance of a System.IO.Stream-derived class.
clearDirty
Indicates whether the Dirty flag should be cleared.

Remarks

Serializes the current diagram as a sequence of bytes represented by stream. The stream may wrap a file, a memory buffer, a TCP socket, and more. The stream contents can be loaded later using the LoadFromStream method.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.SaveToString Method

DiagramView.SaveToString Method

Saves the diagram as an ASCII string.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string SaveToString (
SaveToStringFormat format,
bool clearDirty
)
Visual Basic

Public Function SaveToString ( _
format As SaveToStringFormat, _
clearDirty As Boolean _
) As String

Parameters

format
One of the SaveToStringFormat values.
clearDirty
Indicates whether the Dirty flag should be cleared.

Return Value

A string containing the encoded diagram data.

Remarks

The Base16 and Base64 formats represent the data returned by SaveToStream as an ASCII string. There are no special characters in the returned string, so the result can be easily stored in a database field or embedded into an XML document. That might be used also for transferring a diagram between a web page with embedded MindFusion.Diagramming and a web server, passing the string as a value of a hidden HTML field.

When using Xml or CompressedXml as the first argument, the diagram is saved in XML format. The same format is supported by the SaveToXml and LoadFromXml methods. CompressedXml specifies that the XML document should be further compressed in ZIP format and base-64 encoded.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.SaveToXml Method

DiagramView.SaveToXml Method

Saves the diagram to an XML document.

Overload List

Name | Description
DiagramView.SaveToXml (String) | Saves the diagram into an XML file.
DiagramView.SaveToXml (XmlDocument) | Saves the diagram into an XML document.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.SaveToXml Method (String)

DiagramView.SaveToXml Method (String)
See Also

Saves the diagram into an XML file.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void SaveToXml (
string fileName
)
Visual Basic

Public Sub SaveToXml ( _
fileName As String _
)

Parameters

fileName
The full path and name of the disk file where the diagram should be saved.

Remarks

The first overloaded SaveToXml method works by creating an XmlDocument instance, calling the second overloaded method, and writing the document content to a file.

Diagram data can be loaded from an XML file or document using the LoadFromXml method.

See Also

SaveToXml Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.SaveToXml Method (XmlDocument)

DiagramView.SaveToXml Method (XmlDocument)
See Also

Saves the diagram into an XML document.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public virtual void SaveToXml (
XmlDocument document
)
Visual Basic

Public Overridable Sub SaveToXml ( _
document As XmlDocument _
)

Parameters

document
A .NET XmlDocument object where the diagram should be saved.

Remarks

The first overloaded SaveToXml method works by creating an XmlDocument instance, calling the second overloaded method, and writing the document content to a file.

Diagram data can be loaded from an XML file or document using the LoadFromXml method.

See Also

SaveToXml Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.ScrollTo Method

DiagramView.ScrollTo Method

Scrolls the document to the specified point.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void ScrollTo (
float x,
float y
)
Visual Basic

Public Sub ScrollTo ( _
x As Single, _
y As Single _
)

Parameters

x
The point on the x-axis of the document, to which it should be scrolled to, in the current units of measure.
y
The point on the y-axis of the document, to which it should be scrolled to, in the current units of measure.

Remarks

Call the method to move the scroll bar and the current view of the document to a new position, as set by the method's parameters.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ShowScrollbars
ScrollY Property
ScrollX Property


MindFusion.Diagramming.WinForms.DiagramView.ZoomIn Method

DiagramView.ZoomIn Method

Zooms document's items thus making them appear closer.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void ZoomIn ()
Visual Basic

Public Sub ZoomIn ()

Remarks

Call this method every time you want to make diagram items appear nearer and bigger. It increases the ZoomFactor with 10 each time it executes.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ZoomFactor Property
ZoomOut Method


MindFusion.Diagramming.WinForms.DiagramView.ZoomOut Method

DiagramView.ZoomOut Method

Zooms the diagram out making items appear further away.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void ZoomOut ()
Visual Basic

Public Sub ZoomOut ()

Remarks

Call this method if you want to make the diagram items appear further and smaller. It decreases the ZoomFactor with 10 each time it executes.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ZoomFactor Property
ZoomIn Method


MindFusion.Diagramming.WinForms.DiagramView.ZoomToFit Method

DiagramView.ZoomToFit Method

Zooms the view to fit the document contents in the Diagram.NET client area.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void ZoomToFit ()
Visual Basic

Public Sub ZoomToFit ()

Remarks

ZoomToFit calculates the extents of the rectangle that contain all diagram items and sets the scroll position and zoom factor of the view to fit exactly that rectangle. As a result the whole diagram is displayed on the screen, with the lowest possible zoom.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ScrollTo Method
ZoomFactor Property


MindFusion.Diagramming.WinForms.DiagramView.ZoomToRect Method

DiagramView.ZoomToRect Method

Zooms and scrolls the view to fit the specified document rectangle in the MindFusion.Diagramming client area.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void ZoomToRect (
RectangleF rect
)
Visual Basic

Public Sub ZoomToRect ( _
rect As RectangleF _
)

Parameters

rect
A RectangleF instance specifying viewport position and size.

Remarks

The scroll position and zoom factor of the view are set so the specified rectangular area of the document is entirely visible in MindFusion.Diagramming's client area.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ScrollTo Method
ZoomFactor Property


MindFusion.Diagramming.WinForms.DiagramView Properties

DiagramView Properties

Public Properties

Name | Description
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled.
AllowLinkCursor | Gets or sets the mouse cursor shown to the user when a link can be created.
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled.
AutoScrollAmount | Gets or sets the amount by which to auto-scroll the view when the mouse leaves the view boundaries while drawing.
Behavior | Gets or sets a value indicating how the control responds to user actions.
CatchGdiPlusExceptions | Specifies which part of the diagram is currently visible.
ControlHandlesStyle | Gets or sets the default value for the HandlesStyle property of new ControlNode nodes.
ControlMouseAction | Gets or sets a value indicating how to handle mouse messages sent to controls hosted in ControlNode objects.
CounterDiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.
CurrentCursor | Gets or sets the currently displayed mouse cursor.
Cursor | Control.Cursor override.
CustomBehavior | Gets or sets a custom behavior object specifying how MindFusion.Diagramming responds to mouse input.
CustomLinkType | Gets or sets a custom type of DiagramLink-derived objects that will be created when the users starts drawing with the mouse.
CustomNodeType | Gets or sets the type of a DiagramNode-derived class whose instance should be created when a user starts drawing.
DefaultControlType | Gets or sets the type of .NET controls to create in ControlNode objects.
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key.
DiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.
Diagram | Gets or sets the diagram displayed by this view.
DisallowCursor | Gets or sets the mouse cursor shown to the user when an object cannot be created at a particular location.
DisallowLinkCursor | Gets or sets the mouse cursor shown to the user, when a link is being created but cannot be ended at the current location.
DrawLinkCursor | Gets or sets the mouse cursor shown to the user when a link can be started at the current position.
HorizontalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object horizontally.
HScrollBar | Gets the horizontal scrollbar of the view.
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key should exit inplace-edit mode and accept changes made to text.
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit inplace-edit mode and reject changes made to text.
InplaceEditFont | Gets or sets the font of the inplace-edit text box.
LaneColumnResizeCursor | Gets or sets the mouse cursor shown to the user when dragging would resize a lane column header.
LaneRowResizeCursor | Gets or sets the mouse cursor shown to the user when dragging would resize a lane row header.
MiddleButtonActions | Gets or sets what actions are performed via the middle mouse button.
ModificationStart | Gets or sets how users can start modifying diagram items.
ModifierKeyActions | Gets an object, which allows changing the function of keyboard modifier keys such as CTRL and ALT.
MoveCursor | Gets or sets the mouse cursor shown to the user if the pointed object can be modified.
PanCursor | Gets or sets the mouse cursor displayed while panning the diagram view.
PointerCursor | Gets or sets the mouse cursor shown to the user when no modification is performed.
PreviewOptions | Gets an object which provides customization properties for the extended print-preview window.
PrintOptions | Gets an object which provides customization properties for printing and print-preview.
RightButtonActions | Gets or sets a combination of flags that specify what actions can be performed by clicking the right mouse button.
RotateCursor | Gets or sets the cursor shown when the mouse is over a node rotation handle.
ScrollX | Gets or sets the horizontal scroll position of the document.
ScrollY | Gets or sets the vertical scroll position of the document.
ShowScrollbars | Gets or sets a value indicating whether scrollbars are present in the document's area.
ShowToolTips | Gets or sets a value indicating whether tooltips are enabled.
SmoothingMode | Gets or sets the current anti-alias mode.
TextRenderingHint | Gets or sets the rendering mode for text displayed in this diagram.
ToolTipControl | Gets the ToolTip control used to display tool tips for the diagram items.
ToolTipDelay | Gets or sets the time that passes before a tool-tip appears when the mouse hovers over an item.
VerticalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object vertically.
VScrollBar | Gets the vertical scrollbar of the control.
ZoomFactor | Gets or sets the zoom factor used to scale up or down the diagram.

ProtectedProperties

Name | Description
DefaultSize | Gets or sets the initial size of the control when it is dropped into a form.

See Also

DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.AllowInplaceEdit Property

DiagramView.AllowInplaceEdit Property

Gets or sets a value indicating whether in-place editing of the text of objects is enabled.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool AllowInplaceEdit { get; set; }
Visual Basic

Public Property AllowInplaceEdit As Boolean

Property Value

true if in-place editing is allowed, otherwise false. The default is false.

Remarks

Specifies whether users are allowed to edit in-place the content of a diagram element by double-clicking it. To enter or exit in-place edit mode programmatically, use the BeginEdit and EndEdit methods of DiagramView.

By default, when an item is double-clicked, a text-entry field appears at the item's position. In-place editing mode can be exited by clicking anywhere outside the text-field. When this happens, the control raises the NodeTextEdited, LinkTextEdited or CellTextEdited event depending on the type of the edited item.

You can use the EnterInplaceEditMode event to customize the properties of the built-in text box used as an editor, or to attach event handlers to it. Another possibility is to create a custom editor by handling CreateEditControl.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
InplaceEditFont Property
InplaceEditAcceptOnEnter Property
InplaceEditCancelOnEsc Property


MindFusion.Diagramming.WinForms.DiagramView.AllowLinkCursor Property

DiagramView.AllowLinkCursor Property

Gets or sets the mouse cursor shown to the user when a link can be created.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor AllowLinkCursor { get; set; }
Visual Basic

Public Property AllowLinkCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.Hand.

Remarks

Use the property to indicate visually to the user that the mouse is over a location where link can be created (ended).

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
DisallowCursor Property
DrawLinkCursor Property
MoveCursor Property
PointerCursor
DisallowLinkCursor


MindFusion.Diagramming.WinForms.DiagramView.AutoScroll Property

DiagramView.AutoScroll Property

Gets or sets a value indicating whether auto scrolling of the document area is enabled.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool AutoScroll { get; set; }
Visual Basic

Public Property AutoScroll As Boolean

Property Value

true if auto scrolling is enabled; otherwise, false. The default is true.

Remarks

Enable this property to have the document scroll automatically when new items are added or existing items are being dragged outside the visible area.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
AutoScrollAmount Property
ScrollX Property
ScrollY Property
ShowScrollbars Property


MindFusion.Diagramming.WinForms.DiagramView.AutoScrollAmount Property

DiagramView.AutoScrollAmount Property

Gets or sets the amount by which to auto-scroll the view when the mouse leaves the view boundaries while drawing.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public float AutoScrollAmount { get; set; }
Visual Basic

Public Property AutoScrollAmount As Single

Property Value

A value specifying how much to add or subtract from the current scroll position at each tick of the auto-scroll timer. The default value is 0.

Remarks

To enable auto-scrolling, set AutoScroll = true. If auto-scrolling is enabled and the mouse pointer leaves the view boundaries while drawing, the controls starts a timer and adds AutoScrollAmount to the current scroll position each time the Tick event is raised. If this property is set to 0, the scroll amount added is 4 millimeters, independent fro the current MeasureUnit. If you set a value greater than 0, it is interpreted as a number of MeasureUnit units.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ScrollX Property
ScrollY Property


MindFusion.Diagramming.WinForms.DiagramView.Behavior Property

DiagramView.Behavior Property

Gets or sets a value indicating how the control responds to user actions.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Behavior Behavior { get; set; }
Visual Basic

Public Property Behavior As Behavior

Property Value

A member of the Behavior enumeration. The default is LinkShapes.

Remarks

The property specifies how the control responds to user actions with the mouse. The default value, LinkShapes, facilitates drawing of flowchart diagrams. LinkTables makes MindFusion.Diagramming create table nodes and links while the user draws with the mouse, allowing creation of entity-relationship or class-hierarchy diagrams. There are several more values that can be assigned to the property, that make the control draw single types of items, for example only shape nodes, only control hosts, only links, and so on. These are useful when implementing the ability to select specific drawing tools in applications.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
Behavior Enumeration


MindFusion.Diagramming.WinForms.DiagramView.CatchGdiPlusExceptions Property

DiagramView.CatchGdiPlusExceptions Property

Specifies which part of the diagram is currently visible.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool CatchGdiPlusExceptions { get; set; }
Visual Basic

Public Property CatchGdiPlusExceptions As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.ControlHandlesStyle Property

DiagramView.ControlHandlesStyle Property

Gets or sets the default value for the HandlesStyle property of new ControlNode nodes.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public HandlesStyle ControlHandlesStyle { get; set; }
Visual Basic

Public Property ControlHandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration. The default is HatchHandles.

Remarks

Default value for the HandlesStyle property of new control host nodes, created either programmatically or by a user. That property specifies how selected host nodes are indicated visually, and how they can be moved, resized or connected to other objects.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.ControlMouseAction Property

DiagramView.ControlMouseAction Property

Gets or sets a value indicating how to handle mouse messages sent to controls hosted in ControlNode objects.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ControlMouseAction ControlMouseAction { get; set; }
Visual Basic

Public Property ControlMouseAction As ControlMouseAction

Property Value

A member of the ControlMouseAction enumeration. The default is SelectHost.

Remarks

The ControlMouseAction property of new ControlNode instances is initialized with the value of this property. The value IgnoreControl works only with controls which do not capture the mouse.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.CounterDiagonalResizeCursor Property

DiagramView.CounterDiagonalResizeCursor Property

Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor CounterDiagonalResizeCursor { get; set; }
Visual Basic

Public Property CounterDiagonalResizeCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.SizeNESW.

Remarks

This cursor indicates visually to the user that the mouse is over a place, where clicking+dragging would resize an item both vertically and horizontally.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
HorizontalResizeCursor Property
VerticalResizeCursor Property
DiagonalResizeCursor Property


MindFusion.Diagramming.WinForms.DiagramView.CurrentCursor Property

DiagramView.CurrentCursor Property

Gets or sets the currently displayed mouse cursor.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor CurrentCursor { get; set; }
Visual Basic

Public Property CurrentCursor As Cursor

Property Value

An instance of the .NET Cursor class representing the current mouse cursor.

Remarks

Setting this property while an item modification is performed with the mouse will override the cursor that is set by the control after each mouse movement.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.Cursor Property

DiagramView.Cursor Property

Control.Cursor override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public override Cursor Cursor { get; set; }
Visual Basic

Public Overrides Property Cursor As Cursor

Property Value

An instance of the .NET Cursor class.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.CustomBehavior Property

DiagramView.CustomBehavior Property

Gets or sets a custom behavior object specifying how MindFusion.Diagramming responds to mouse input.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public BehaviorBase CustomBehavior { get; set; }
Visual Basic

Public Property CustomBehavior As BehaviorBase

Property Value

An instance of a BehaviorBase-derived class. The default value is null (Nothing in Visual Basic).

Remarks

MindFusion.Diagramming provides several stock implementations of the BehaviorBase class that can be used by assigning a member of the Behavior enumeration to the view's Behavior property. Create a custom behavior class only if the predefined ones don't meet your application requirements.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.CustomLinkType Property

DiagramView.CustomLinkType Property

Gets or sets a custom type of DiagramLink-derived objects that will be created when the users starts drawing with the mouse.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Type CustomLinkType { get; set; }
Visual Basic

Public Property CustomLinkType As Type

Property Value

A reference to a System.Type that specifies the custom link class.

Remarks

You must set Behavior to Custom to enable creating links of your custom type interactively.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
CustomNodeType Property


MindFusion.Diagramming.WinForms.DiagramView.CustomNodeType Property

DiagramView.CustomNodeType Property

Gets or sets the type of a DiagramNode-derived class whose instance should be created when a user starts drawing.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Type CustomNodeType { get; set; }
Visual Basic

Public Property CustomNodeType As Type

Property Value

A reference to a System.Type that specifies the custom node class.

Remarks

You must set Behavior to Custom to enable creating nodes of your custom type interactively.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
CustomLinkType Property


MindFusion.Diagramming.WinForms.DiagramView.DefaultControlType Property

DiagramView.DefaultControlType Property

Gets or sets the type of .NET controls to create in ControlNode objects.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Type DefaultControlType { get; set; }
Visual Basic

Public Property DefaultControlType As Type

Property Value

A reference to the System.Type that specifies a class of .NET controls to create.

Remarks

DefaultControlType must be subclass of System.Windows.Forms.Control. In addition, the type must provide a constructor that takes no parameters. When a control-hosting node is created, the control's constructor is invoked and the newly-created instance is made a child of the DiagramView control. ControlNode nodes can be created either interactively or via method calls. Reference to the hosted System.Windows.Forms.Control-derived object can be get via the host's Control property.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.DefaultSize Property

DiagramView.DefaultSize Property

Gets or sets the initial size of the control when it is dropped into a form.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual Size DefaultSize { get; }
Visual Basic

Protected Overridable ReadOnly Property DefaultSize As Size

Property Value

A .NET Size object that represents the default size of the control. The default is 256x256.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.DelKeyAction Property

DiagramView.DelKeyAction Property

Gets or sets a value that specifies what action should be performed when the user hits the Del key.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public DelKeyAction DelKeyAction { get; set; }
Visual Basic

Public Property DelKeyAction As DelKeyAction

Property Value

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.DiagonalResizeCursor Property

DiagramView.DiagonalResizeCursor Property

Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor DiagonalResizeCursor { get; set; }
Visual Basic

Public Property DiagonalResizeCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.SizeNWSE.

Remarks

This cursor indicates visually to the user that the mouse is over a place, where clicking+dragging would resize an item both vertically and horizontally.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
HorizontalResizeCursor Property
VerticalResizeCursor Property
CounterDiagonalResizeCursor Property


MindFusion.Diagramming.WinForms.DiagramView.Diagram Property

DiagramView.Diagram Property

Gets or sets the diagram displayed by this view.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Diagram Diagram { get; set; }
Visual Basic

Public Property Diagram As Diagram

Property Value

An instance of the Diagram class.

Remarks

If this property is not set, there is a default Diagram instance created. It is possible to display several views of the same diagram by assigning a shared Diagram object to multiple DiagramView objects.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.DisallowCursor Property

DiagramView.DisallowCursor Property

Gets or sets the mouse cursor shown to the user when an object cannot be created at a particular location.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor DisallowCursor { get; set; }
Visual Basic

Public Property DisallowCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.No.

Remarks

Use the property to demonstrate visually to the user that an item cannot be created at the current mouse position.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
DrawLinkCursor Property
MoveCursor Property
AllowLinkCursor Property
PointerCursor Property
DisallowLinkCursor Property


MindFusion.Diagramming.WinForms.DiagramView.DisallowLinkCursor Property

DiagramView.DisallowLinkCursor Property

Gets or sets the mouse cursor shown to the user, when a link is being created but cannot be ended at the current location.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor DisallowLinkCursor { get; set; }
Visual Basic

Public Property DisallowLinkCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.No.

Remarks

Use the property to indicate visually to the user that the mouse is over a place, where the currently dragged link cannot be ended.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
DisallowCursor Property
DrawLinkCursor Property
MoveCursor Property
AllowLinkCursor Property
PointerCursor Property


MindFusion.Diagramming.WinForms.DiagramView.DrawLinkCursor Property

DiagramView.DrawLinkCursor Property

Gets or sets the mouse cursor shown to the user when a link can be started at the current position.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor DrawLinkCursor { get; set; }
Visual Basic

Public Property DrawLinkCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.Hand.

Remarks

Use the property to indicate visually to the user that a link can be started at the current mouse position.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
DisallowCursor Property
MoveCursor Property
AllowLinkCursor Property
PointerCursor Property
DisallowLinkCursor Property


MindFusion.Diagramming.WinForms.DiagramView.HorizontalResizeCursor Property

DiagramView.HorizontalResizeCursor Property

Gets or sets the mouse cursor shown to the user if dragging would resize an object horizontally.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor HorizontalResizeCursor { get; set; }
Visual Basic

Public Property HorizontalResizeCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.SizeWE.

Remarks

This cursor indicates visually to the user that the mouse is over a place, where clicking+dragging would resize an item horizontally.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
VerticalResizeCursor Property
DiagonalResizeCursor Property
CounterDiagonalResizeCursor Property


MindFusion.Diagramming.WinForms.DiagramView.HScrollBar Property

DiagramView.HScrollBar Property

Gets the horizontal scrollbar of the view.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public HScrollBar HScrollBar { get; }
Visual Basic

Public ReadOnly Property HScrollBar As HScrollBar

Property Value

An instance of the .NET HScrollBar class.

Remarks

To ensure that the scroll bar is visible, enable the view's ShowScrollbars property.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
VScrollBar Property


MindFusion.Diagramming.WinForms.DiagramView.InplaceEditAcceptOnEnter Property

DiagramView.InplaceEditAcceptOnEnter Property

Gets or sets a value indicating whether pressing the ENTER key should exit inplace-edit mode and accept changes made to text.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool InplaceEditAcceptOnEnter { get; set; }
Visual Basic

Public Property InplaceEditAcceptOnEnter As Boolean

Property Value

true to accept changes and exit inplace-edit mode when ENTER is pressed; otherwise, false. The default is false.

Remarks

If the value of this property is false, pressing the ENTER key inserts a new line in the text while in inplace-edit mode.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
AllowInplaceEdit Property
InplaceEditCancelOnEsc Property


MindFusion.Diagramming.WinForms.DiagramView.InplaceEditCancelOnEsc Property

DiagramView.InplaceEditCancelOnEsc Property

Gets or sets a value indicating whether pressing the ESC key should exit inplace-edit mode and reject changes made to text.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool InplaceEditCancelOnEsc { get; set; }
Visual Basic

Public Property InplaceEditCancelOnEsc As Boolean

Property Value

true to reject changes and exit inplace-edit mode when ESC is pressed; otherwise, false. The default is true.

Remarks

If the value of this property is false, pressing the ESC key has no effect while in inplace-edit mode.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
AllowInplaceEdit Property
InplaceEditAcceptOnEnter Property


MindFusion.Diagramming.WinForms.DiagramView.InplaceEditFont Property

DiagramView.InplaceEditFont Property

Gets or sets the font of the inplace-edit text box.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Font InplaceEditFont { get; set; }
Visual Basic

Public Property InplaceEditFont As Font

Property Value

An instance of the .NET Font class.

Remarks

When inplace-editing starts, MindFusion.Diagramming creates a new TextBox control over the edited item, unless you handle the CreateEditControl event to create a custom editor. InplaceEditFont is assigned to the Font property of that text box.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
AllowInplaceEdit Property


MindFusion.Diagramming.WinForms.DiagramView.LaneColumnResizeCursor Property

DiagramView.LaneColumnResizeCursor Property

Gets or sets the mouse cursor shown to the user when dragging would resize a lane column header.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor LaneColumnResizeCursor { get; set; }
Visual Basic

Public Property LaneColumnResizeCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.VSplit.

Remarks

This cursor indicates visually that the mouse is over the outside lane column border, where clicking+dragging would resize the lane column.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.LaneRowResizeCursor Property

DiagramView.LaneRowResizeCursor Property

Gets or sets the mouse cursor shown to the user when dragging would resize a lane row header.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor LaneRowResizeCursor { get; set; }
Visual Basic

Public Property LaneRowResizeCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.HSplit.

Remarks

This cursor indicates visually that the mouse is over the outside lane row border, where clicking+dragging would resize the lane row.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.MiddleButtonActions Property

DiagramView.MiddleButtonActions Property

Gets or sets what actions are performed via the middle mouse button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public MouseButtonActions MiddleButtonActions { get; set; }
Visual Basic

Public Property MiddleButtonActions As MouseButtonActions

Property Value

A combination of the MouseButtonActions enumeration members. The default is None.

Remarks

This property allows the following actions to be assigned to the middle mouse button: panning the diagram view, canceling the current drawing operation, or starting a multiple selection operation.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
RightButtonActions Property


MindFusion.Diagramming.WinForms.DiagramView.ModificationStart Property

DiagramView.ModificationStart Property

Gets or sets how users can start modifying diagram items.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ModificationStart ModificationStart { get; set; }
Visual Basic

Public Property ModificationStart As ModificationStart

Property Value

A member of the ModificationStart enumeration. The default is SelectedOnly.

Remarks

Use this property to specify what should users do in order to start item modification.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ModificationStart Enumeration


MindFusion.Diagramming.WinForms.DiagramView.ModifierKeyActions Property

DiagramView.ModifierKeyActions Property

Gets an object, which allows changing the function of keyboard modifier keys such as CTRL and ALT.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ModifierKeyActions ModifierKeyActions { get; }
Visual Basic

Public ReadOnly Property ModifierKeyActions As ModifierKeyActions

Property Value

An instance of the ModifierKeyActions class.

Remarks

Use the Alt, Control and Shift properties of this ModifierKeyActions instance to specify the functions of the ALT, CTRL and SHIFT keys. These properties can be set to values of the ModifierKeyAction enumeration.

Example

This code enables drawing a selection rectangle using the SHIFT modifier key:

C#

diagramView.ModifierKeyActions.Shift = ModifierKeyAction.Select;
Visual Basic

diagramView.ModifierKeyActions.Shift = ModifierKeyAction.Select

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.MoveCursor Property

DiagramView.MoveCursor Property

Gets or sets the mouse cursor shown to the user if the pointed object can be modified.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor MoveCursor { get; set; }
Visual Basic

Public Property MoveCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.SizeAll.

Remarks

Use the property to indicate visually to the user that they are pointing to an item, which can be modified at the current moment.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
DrawLinkCursor Property
AllowLinkCursor Property
PointerCursor Property
DisallowCursor Property
PanCursor Property


MindFusion.Diagramming.WinForms.DiagramView.PanCursor Property

DiagramView.PanCursor Property

Gets or sets the mouse cursor displayed while panning the diagram view.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor PanCursor { get; set; }
Visual Basic

Public Property PanCursor As Cursor

Property Value

An instance of the .NET Cursor class representing the mouse cursor that is displayed while panning.

Remarks

The diagram view can be panned by holding down the ALT key and dragging with the mouse. This can be changed via the ModifierKeyActions and MiddleButtonActions properties.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
MoveCursor Property
PointerCursor Property


MindFusion.Diagramming.WinForms.DiagramView.PointerCursor Property

DiagramView.PointerCursor Property

Gets or sets the mouse cursor shown to the user when no modification is performed.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor PointerCursor { get; set; }
Visual Basic

Public Property PointerCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.Arrow.

Remarks

This cursor is shown when clicking and dragging the mouse would start creation of a node.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
DrawLinkCursor Property
MoveCursor Property
AllowLinkCursor Property
PanCursor Property


MindFusion.Diagramming.WinForms.DiagramView.PreviewOptions Property

DiagramView.PreviewOptions Property

Gets an object which provides customization properties for the extended print-preview window.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public PreviewOptions PreviewOptions { get; }
Visual Basic

Public ReadOnly Property PreviewOptions As PreviewOptions

Property Value

An instance of the PreviewOptions class.

Remarks

Settings that alter the appearance of a diagram rendered to the printer or the preview dialog are set via PrintOptions. The PreviewOptions properties apply only to the UI elements of the extended preview dialog, displayed by the PrintPreviewEx method.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.PrintOptions Property

DiagramView.PrintOptions Property

Gets an object which provides customization properties for printing and print-preview.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public PrintOptions PrintOptions { get; }
Visual Basic

Public ReadOnly Property PrintOptions As PrintOptions

Property Value

An instance of the PrintOptions class.

Remarks

Allows customization of various print and print-preview aspects. The settings exposed as properties include document title, page header format and several bool flags that control if images, shadows, headers, and so on are printed or rendered in preview mode.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
PrintOptions Class
Print Method
PrintPreview Method


MindFusion.Diagramming.WinForms.DiagramView.RightButtonActions Property

DiagramView.RightButtonActions Property

Gets or sets a combination of flags that specify what actions can be performed by clicking the right mouse button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public MouseButtonActions RightButtonActions { get; set; }
Visual Basic

Public Property RightButtonActions As MouseButtonActions

Property Value

A combination of the MouseButtonActions enumeration members. The default is Cancel.

Remarks

This property allows the following actions to be assigned to the right mouse button: panning the diagram view, canceling the current drawing operation, or starting a multiple selection operation.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
MiddleButtonActions Property


MindFusion.Diagramming.WinForms.DiagramView.RotateCursor Property

DiagramView.RotateCursor Property

Gets or sets the cursor shown when the mouse is over a node rotation handle.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor RotateCursor { get; set; }
Visual Basic

Public Property RotateCursor As Cursor

Property Value

An instance of the .NET Cursor class.

Remarks

This cursor is shown when clicking and dragging the mouse will start rotating a shape node.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
MoveCursor Property


MindFusion.Diagramming.WinForms.DiagramView.ScrollX Property

DiagramView.ScrollX Property

Gets or sets the horizontal scroll position of the document.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public float ScrollX { get; set; }
Visual Basic

Public Property ScrollX As Single

Property Value

A float value specifying the new horizontal scroll position in the current units of measure. The default is 0, indicating the left corner.

Remarks

Use the property to set where the horizontal scroll bar should be positioned.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ShowScrollbars Property
ScrollY Property
ScrollTo Method


MindFusion.Diagramming.WinForms.DiagramView.ScrollY Property

DiagramView.ScrollY Property

Gets or sets the vertical scroll position of the document.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public float ScrollY { get; set; }
Visual Basic

Public Property ScrollY As Single

Property Value

A float value specifying the new vertical scroll position in the current units of measure. The default is 0, indicating the top corner.

Remarks

Use the property to set where the vertical scroll bar should be positioned.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ShowScrollbars Property
ScrollX Property
ScrollTo Method


MindFusion.Diagramming.WinForms.DiagramView.ShowScrollbars Property

DiagramView.ShowScrollbars Property

Gets or sets a value indicating whether scrollbars are present in the document's area.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool ShowScrollbars { get; set; }
Visual Basic

Public Property ShowScrollbars As Boolean

Property Value

true if scrollbars are visible; otherwise, false. The default is true.

Remarks

Enable this property to let users scroll the document area with the built-in scrollbars. In order to customize the scrollbars you can use the AutoScroll, ScrollX and ScrollY properties.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ScrollX Property
ScrollY Property
ScrollTo Method


MindFusion.Diagramming.WinForms.DiagramView.ShowToolTips Property

DiagramView.ShowToolTips Property

Gets or sets a value indicating whether tooltips are enabled.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool ShowToolTips { get; set; }
Visual Basic

Public Property ShowToolTips As Boolean

Property Value

true to display tooltips; otherwise, false. The default is true.

Remarks

Use the property to specify if tooltips - small labels with explanation texts - are displayed when the mouse pointer rests over the control.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
DiagramItem.ToolTip Property
ToolTipDelay Property


MindFusion.Diagramming.WinForms.DiagramView.SmoothingMode Property

DiagramView.SmoothingMode Property

Gets or sets the current anti-alias mode.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public SmoothingMode SmoothingMode { get; set; }
Visual Basic

Public Property SmoothingMode As SmoothingMode

Property Value

A member of the .NET SmoothingMode enumeration. The default is None.

Remarks

This property specifies whether smoothing is applied to lines and curves. The HighQuality and AntiAlias values specify that smoothing is applied. All other values specify that smoothing is not applied. Anti-aliasing slows down drawing of bigger diagrams, so it is not used by default.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
TextRenderingHint Property


MindFusion.Diagramming.WinForms.DiagramView.TextRenderingHint Property

DiagramView.TextRenderingHint Property

Gets or sets the rendering mode for text displayed in this diagram.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public TextRenderingHint TextRenderingHint { get; set; }
Visual Basic

Public Property TextRenderingHint As TextRenderingHint

Property Value

A member of the .NET TextRenderingHint enumeration. The default is SystemDefault.

Remarks

The text rendering mode specifies whether text renders with antialiasing and what type of antialiasing to use.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
SmoothingMode Property


MindFusion.Diagramming.WinForms.DiagramView.ToolTipControl Property

DiagramView.ToolTipControl Property

Gets the ToolTip control used to display tool tips for the diagram items.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ToolTip ToolTipControl { get; }
Visual Basic

Public ReadOnly Property ToolTipControl As ToolTip

Property Value

An instance of the System.Windows.Forms.ToolTip class.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.ToolTipDelay Property

DiagramView.ToolTipDelay Property

Gets or sets the time that passes before a tool-tip appears when the mouse hovers over an item.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public int ToolTipDelay { get; set; }
Visual Basic

Public Property ToolTipDelay As Integer

Property Value

An integer value specifying the delay for tool-tips in milliseconds. The default is 500.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
DiagramItem.ToolTip Property
Diagram.ToolTip Property
ShowToolTips Property


MindFusion.Diagramming.WinForms.DiagramView.VerticalResizeCursor Property

DiagramView.VerticalResizeCursor Property

Gets or sets the mouse cursor shown to the user if dragging would resize an object vertically.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Cursor VerticalResizeCursor { get; set; }
Visual Basic

Public Property VerticalResizeCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.SizeNS.

Remarks

This cursor indicates visually to the user that the mouse is over a place, where clicking+dragging would resize an item vertically.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
HorizontalResizeCursor Property
DiagonalResizeCursor Property
CounterDiagonalResizeCursor Property


MindFusion.Diagramming.WinForms.DiagramView.VScrollBar Property

DiagramView.VScrollBar Property

Gets the vertical scrollbar of the control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public VScrollBar VScrollBar { get; }
Visual Basic

Public ReadOnly Property VScrollBar As VScrollBar

Property Value

An instance of the .NET VScrollBar class.

Remarks

To ensure that the scroll bar is visible, enable the view's ShowScrollbars property.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
HScrollBar Property


MindFusion.Diagramming.WinForms.DiagramView.ZoomFactor Property

DiagramView.ZoomFactor Property

Gets or sets the zoom factor used to scale up or down the diagram.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public float ZoomFactor { get; set; }
Visual Basic

Public Property ZoomFactor As Single

Property Value

A float value specifying percent of the original diagram size. The default is 100.

Remarks

Use the property to set how far the diagram items should look. Values smaller than 100 make items appear further, bigger than 100 - nearer. The default value is 100, specifying that no scaling transformation is applied.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ZoomIn Method
ZoomOut Method
ZoomToRect Method


MindFusion.Diagramming.WinForms.DiagramView Events

DiagramView Events

Public Events

Name | Description
CopyHostedControl | Raised when a ControlNode's hosted control is copied to or from the clipboard.
CreateEditControl | Raised to let you create a custom in-place editor control.
DeserializeControl | Lets you load custom data associated with a hosted control when deserializing a diagram from a stream.
DestroyEditControl | Raised to let you destroy a custom inplace editor control.
DiagramChanged | Occurs when the Diagram property value has changed.
EnterInplaceEditMode | Raised when entering inplace-edit mode.
LeaveInplaceEditMode | Raised when leaving inplace-edit mode.
PaintControl | Raised when a hosted control must be printed, drawn in a print-preview or Overview window, or drawn in an exported bitmap.
ScrollChanged | Occurs when the scroll position has changed.
SerializeControl | Lets you save additional data for hosted controls when serializing the diagram into a file.
ZoomFactorChanged | Occurs when the ZoomFactor property value has changed.

See Also

DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.CopyHostedControl Event

DiagramView.CopyHostedControl Event

Raised when a ControlNode's hosted control is copied to or from the clipboard.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public event CopyHostedControlEventHandler CopyHostedControl
Visual Basic

Public Event CopyHostedControl As CopyHostedControlEventHandler

Event Data

CopyHostedControl event handlers receive an argument of type CopyHostedControlEventArgs. The following CopyHostedControlEventArgs members provide information relevant to the event:

Member name | Description
Source | The source Control-derived object.
Destination | The destination Control-derived object.

Remarks

When copying a ControlNode to the clipboard, MindFusion.Diagramming copies automatically all properties of the hosted control which are of value or string types. CopyHostedControl lets you copy properties that do not fall into that category.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
CopyToClipboard


MindFusion.Diagramming.WinForms.DiagramView.CreateEditControl Event

DiagramView.CreateEditControl Event

Raised to let you create a custom in-place editor control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public event InPlaceEditEventHandler CreateEditControl
Visual Basic

Public Event CreateEditControl As InPlaceEditEventHandler

Event Data

CreateEditControl event handlers receive an argument of type InPlaceEditEventArgs. The following InPlaceEditEventArgs members provide information relevant to the event.

Member name | Description
EditControl | Assign a reference to an instance of your custom editor control to this property.
Item | Refers to the diagram element being edited.
Node | Refers to the node containing the element being edited (useful when editing a table cell).

Remarks

This event is raised if AllowInplaceEdit is enabled and the user double-clicks an item, or when the application invokes the BeginEdit method of DiagramView. If the event is not handled, or if EditControl is set to null, MindFusion.Diagramming uses a TextBox control to allow editing the item's text. If you prefer to use the built-in TextBox, you can still customize it by handling the EnterInplaceEditMode event.

Note that if you create a custom editor control, you must transfer the values entered into it to the respective properties of the edited diagram item. You could do that in response to the DestroyEditControl event.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.DeserializeControl Event

DiagramView.DeserializeControl Event

Lets you load custom data associated with a hosted control when deserializing a diagram from a stream.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public event ControlNodeEventHandler DeserializeControl
Visual Basic

Public Event DeserializeControl As ControlNodeEventHandler

Event Data

DeserializeControl event handlers receive an argument of type ControlNodeEventArgs. The following ControlNodeEventArgs members provide information relevant to the event:
Member name | Description
Node | The ControlNode being deserialized.
Stream | A Stream object from which to read the custom data.

Remarks

You must read from the stream exactly as many bytes as were written from the SerializeControl event handler.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
LoadFromFile
LoadFromStream


MindFusion.Diagramming.WinForms.DiagramView.DestroyEditControl Event

DiagramView.DestroyEditControl Event

Raised to let you destroy a custom inplace editor control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public event InPlaceEditEventHandler DestroyEditControl
Visual Basic

Public Event DestroyEditControl As InPlaceEditEventHandler

Event Data

DestroyEditControl event handlers receive an argument of type InPlaceEditEventArgs. The following InPlaceEditEventArgs members provide information relevant to the event.

Member name | Description
EditControl | Refers to the custom editor created by the CreateEditControl handler.
Item | Refers to the diagram element being edited.
Node | Refers to the node containing the element being edited (useful when editing a table cell).

Remarks

This event is raised when the user clicks outside the editor, or when the EndEdit method is invoked. Handle it to hide or destroy the edit control. You might also implement the copying of values from the editor to the diagram item's properties in this event handler.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.DiagramChanged Event

DiagramView.DiagramChanged Event

Occurs when the Diagram property value has changed.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public event EventHandler DiagramChanged
Visual Basic

Public Event DiagramChanged As EventHandler

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.EnterInplaceEditMode Event

DiagramView.EnterInplaceEditMode Event

Raised when entering inplace-edit mode.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public event InPlaceEditEventHandler EnterInplaceEditMode
Visual Basic

Public Event EnterInplaceEditMode As InPlaceEditEventHandler

Event Data

EnterInplaceEditMode event handlers receive an argument of type InPlaceEditEventArgs. The following InPlaceEditEventArgs members provide information relevant to the event:
Member name | Description
Item | The node or table cell whose text will be edited.
Node | The node whose text will be edited. If Item is a cell, this property returns the TableNode that contains that cell.
EditControl | The control where the user can edit the item's content.

Remarks

By default, MindFusion.Diagramming creates a TextBox control to let users edit item's text. This event allows customizing the properties of that control, or attaching event handlers to it. A TextBox instance is created each time in-place editing starts, so it could be necessary to set its properties and register event handlers each time EnterInplaceEditMode is raised.

Note that you can use a custom control for in-place editing. This can be done by handling CreateEditControl and specifying what object should be used as an editor by assigning it to EditControl.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
LeaveInplaceEditMode


MindFusion.Diagramming.WinForms.DiagramView.LeaveInplaceEditMode Event

DiagramView.LeaveInplaceEditMode Event

Raised when leaving inplace-edit mode.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public event InPlaceEditEventHandler LeaveInplaceEditMode
Visual Basic

Public Event LeaveInplaceEditMode As InPlaceEditEventHandler

Event Data

LeaveInplaceEditMode event handlers receive an argument of type InPlaceEditEventArgs. The following InPlaceEditEventArgs members provide information relevant to the event:

Member name | Description
Item | The node or table cell whose text has been edited.
Node | The node whose text has been edited. If Item is a cell, this property returns the TableNode containing the cell.
EditControl | The control used to edit the text.

Remarks

This event is raised in all situations that lead to closing the inplace-edit control, for example, when the user accepts or cancels the changes made to an item's text, or when the EndEdit method is called.

If you have created a custom edit control by handling the CreateEditControl event, EditControl refers to the custom editor. Otherwise, it is a simple TextBox.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
EnterInplaceEditMode


MindFusion.Diagramming.WinForms.DiagramView.PaintControl Event

DiagramView.PaintControl Event

Raised when a hosted control must be printed, drawn in a print-preview or Overview window, or drawn in an exported bitmap.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public event PaintControlEventHandler PaintControl
Visual Basic

Public Event PaintControl As PaintControlEventHandler

Event Data

PaintControl event handlers receive an argument of type PaintControlEventArgs. The following PaintControlEventArgs members provide information relevant to the event:

Member name | Description
Node | The ControlNode whose hosted control should be custom-drawn.
PaintRect | The bounding rectangle of the hosted control.
Handled | Set this flag to true if you have custom-drawn the control.
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the control.

Remarks

This event is raised when a control hosted inside a ControlNode must be painted off screen. When MindFusion.Diagramming displays a diagram on the screen, hosted controls have their own windows in which they paint themselves. However, when printing diagrams, exporting them to image files or displaying them in overview or print preview windows, hosted controls cannot be always painted by MindFusion.Diagramming.

By handling PaintControl, your application can provide own rendering of the control's data. That is done by painting in the rectangle specified in PaintRect argument by means of the methods of the Graphics argument.

If that event is not handled, MindFusion.Diagramming invokes the OnPaint method of the hosted System.Windows.Forms.Control instance. However, not all controls do their painting in OnPaint; for example, some are mere wrappers of Windows common controls and their OnPaint implementation is empty.

Example

The following example shows how to handle the event for hosted TextBox controls:

C#

void diagramView_PaintControl(object sender, PaintControlEventArgs e)
{
// If we host TextBox controls, paint a close representation of their
// contents when rendering to printer/preview/overview and so on
if (e.Node.Control is TextBox)
{
TextBox tb = (TextBox)e.Node.Control;

System.Drawing.Brush wb = new System.Drawing.SolidBrush(Color.Blue);
e.Graphics.FillRectangle(wb, e.PaintRect);
wb.Dispose();

// Now you can't distinguish that from a real TextBox
System.Drawing.Brush bb = new System.Drawing.SolidBrush(Color.Black);
Font font = new Font("Arial", 2, GraphicsUnit.World);

e.Graphics.DrawString(tb.Text, font, bb, e.PaintRect);

font.Dispose();
bb.Dispose();
}
}
Visual Basic

Private Sub diagramView_PaintControl(ByVal sender As Object, ByVal e As PaintControlEventArgs) Handles diagramView.PaintControl

' If we host TextBox controls, paint a close representation of their
' contents when rendering to printer/preview/overview and so on
If TypeOf e.Node.Control Is TextBox Then

Dim tb As TextBox = CType(e.Node.Control, TextBox)

Dim wb As New System.Drawing.SolidBrush(Color.Blue)
e.Graphics.FillRectangle(wb, e.PaintRect)
wb.Dispose()

' Now you can't distinguish that from a real TextBox
Dim bb As New System.Drawing.SolidBrush(Color.Black)
Dim font As New Font("Arial", 2, GraphicsUnit.World)

e.Graphics.DrawString(tb.Text, font, bb, e.PaintRect)

font.Dispose()
bb.Dispose()

End If

End Sub

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView.ScrollChanged Event

DiagramView.ScrollChanged Event

Occurs when the scroll position has changed.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public event EventHandler ScrollChanged
Visual Basic

Public Event ScrollChanged As EventHandler

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
ScrollX
ScrollY


MindFusion.Diagramming.WinForms.DiagramView.SerializeControl Event

DiagramView.SerializeControl Event

Lets you save additional data for hosted controls when serializing the diagram into a file.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public event ControlNodeEventHandler SerializeControl
Visual Basic

Public Event SerializeControl As ControlNodeEventHandler

Event Data

SerializeControl event handlers receive an argument of type ControlNodeEventArgs. The following ControlNodeEventArgs members provide information relevant to the event:
Member name | Description
Node | The ControlNode being serialized.
Stream | A Stream object into which the custom data should be serialized.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace
DeserializeControl


MindFusion.Diagramming.WinForms.DiagramView.ZoomFactorChanged Event

DiagramView.ZoomFactorChanged Event

Occurs when the ZoomFactor property value has changed.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public event EventHandler ZoomFactorChanged
Visual Basic

Public Event ZoomFactorChanged As EventHandler

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D Class

DiagramView3D Class
Remarks See Also

Displays graphs in 3D.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class DiagramView3D : Control
Visual Basic

Public Class DiagramView3D
Inherits Control

Remarks

Assign the Diagram that should be displayed in this view to the Diagram property.

The CameraPosition property specifies the position of the camera in 3D space. To specify the camera's pitch, roll and yaw angles, set the CameraRotation property. PointCameraTo lets you direct the camera to a specified point. The ViewerDistance property specifies the distance of the viewer from the camera.

After changing the camera position or direction, or after changing the location of graph nodes, call the ResetProjection method. It calculates the new projection coordinates of nodes and updates the view.

The following mouse and keyboard actions allow moving the camera around the 3D scene:

  • Mouse drag: Moves the camera across the plane perpendicular to direction of the camera.
  • CTRL+mouse drag: Rotate the camera by changing the pitch and yaw angles.
  • Mouse wheel: Causes moving the camera forwards or backwards.
  • CTRL+mouse wheel: Rolls the camera around the Z-axis.

Set the EnableOrbitingCamera property to true to enable using the CTRL key to move the camera in an orbit around a node.

DiagramView3D uses the following coordinate system:

  • The X axis is horizontal and points to the right.
  • The Y axis is vertical and points upwards.
  • The Z axis specifies depth and its values grow with distance.

Look at the SpringLayout solution in the Samples folder that demonstrates how to apply a 3D SpringLayout algorithm and display a 3D view of the diagram.

Example

To specify a 3D position of a node, use the LayoutTraits property:

C#

node.LayoutTraits[View3D.Position] = new Point3D(x, y, z);
diagView3D.ResetProjection();

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Diagramming.WinForms.DiagramView3D

See Also

DiagramView3D Members
MindFusion.Diagramming.WinForms Namespace
LayoutTraits


MindFusion.Diagramming.WinForms.DiagramView3D Members

DiagramView3D Members
Constructors Properties Methods

Displays graphs in 3D.

The following tables list the members exposed by the DiagramView3D type.

Public Constructors

Name | Description
DiagramView3D | Initializes a new instance of the DiagramView3D class.

Public Properties

Name | Description
CameraPosition | Gets or sets the camera position.
CameraRotation | Gets or sets the camera rotation in yaw, roll and pitch angles.
Diagram | Gets or sets the diagram displayed by this view.
DimColor | Gets or sets a color used to dim items further from the camera.
EnableOrbitingCamera | Specifies whether users can use the CTRL key to orbit around a node with the camera.
ViewerDistance | Gets or sets the viewer distance from the camera.

Public Methods

Name | Description
ClientToDoc | Overloaded.
DocToClient | Overloaded.
DrawDiagram3D | Draws the projection of the 3D graph on the specified IGraphics surface.
GetNodeAt | Gets the node projected at the specified 2D point.
PointCameraTo | Points the camera to the specified point in 3D space.
ResetProjection | Invalidates the view and causes the node projections to be recalculated.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnDoubleClick | Control.OnDoubleClick override.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnMouseWheel | Control.OnMouseWheel override.
OnPaint | Control.OnPaint override.
OnPaintBackground | Control.OnPaintBackground override.

See Also

DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D Constructor

DiagramView3D Constructor

Initializes a new instance of the DiagramView3D class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public DiagramView3D ()
Visual Basic

Public Sub New ()

See Also

DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D Methods

DiagramView3D Methods

Public Methods

Name | Description
ClientToDoc | Overloaded.
DocToClient | Overloaded.
DrawDiagram3D | Draws the projection of the 3D graph on the specified IGraphics surface.
GetNodeAt | Gets the node projected at the specified 2D point.
PointCameraTo | Points the camera to the specified point in 3D space.
ResetProjection | Invalidates the view and causes the node projections to be recalculated.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnDoubleClick | Control.OnDoubleClick override.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnMouseWheel | Control.OnMouseWheel override.
OnPaint | Control.OnPaint override.
OnPaintBackground | Control.OnPaintBackground override.

See Also

DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.ClientToDoc Method

DiagramView3D.ClientToDoc Method

Overload List

Name | Description
DiagramView3D.ClientToDoc (Point) | Converts the specified point from client to document coordinates.
DiagramView3D.ClientToDoc (Rectangle) | Converts the specified rectangle from client to document coordinates.

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.ClientToDoc Method (Point)

DiagramView3D.ClientToDoc Method (Point)
See Also

Converts the specified point from client to document coordinates.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public PointF ClientToDoc (
Point clientPoint
)
Visual Basic

Public Function ClientToDoc ( _
clientPoint As Point _
) As PointF

Parameters

clientPoint

Return Value

See Also

ClientToDoc Method Overload List
DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.ClientToDoc Method (Rectangle)

DiagramView3D.ClientToDoc Method (Rectangle)
See Also

Converts the specified rectangle from client to document coordinates.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public RectangleF ClientToDoc (
Rectangle clientRect
)
Visual Basic

Public Function ClientToDoc ( _
clientRect As Rectangle _
) As RectangleF

Parameters

clientRect

Return Value

See Also

ClientToDoc Method Overload List
DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.Dispose Method

DiagramView3D.Dispose Method

Clean up any resources being used.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.DocToClient Method

DiagramView3D.DocToClient Method

Overload List

Name | Description
DiagramView3D.DocToClient (PointF) | Converts the specified point from document to client coordinates.
DiagramView3D.DocToClient (RectangleF) | Converts the specified rectangle from document to client coordinates.

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.DocToClient Method (PointF)

DiagramView3D.DocToClient Method (PointF)
See Also

Converts the specified point from document to client coordinates.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Point DocToClient (
PointF docPoint
)
Visual Basic

Public Function DocToClient ( _
docPoint As PointF _
) As Point

Parameters

docPoint

Return Value

See Also

DocToClient Method Overload List
DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.DocToClient Method (RectangleF)

DiagramView3D.DocToClient Method (RectangleF)
See Also

Converts the specified rectangle from document to client coordinates.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Rectangle DocToClient (
RectangleF docRect
)
Visual Basic

Public Function DocToClient ( _
docRect As RectangleF _
) As Rectangle

Parameters

docRect

Return Value

See Also

DocToClient Method Overload List
DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.DrawDiagram3D Method

DiagramView3D.DrawDiagram3D Method

Draws the projection of the 3D graph on the specified IGraphics surface.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void DrawDiagram3D (
IGraphics graphics
)
Visual Basic

Public Sub DrawDiagram3D ( _
graphics As IGraphics _
)

Parameters

graphics
An object implementing the IGraphics interface.

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.GetNodeAt Method

DiagramView3D.GetNodeAt Method

Gets the node projected at the specified 2D point.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public DiagramNode GetNodeAt (
Point point
)
Visual Basic

Public Function GetNodeAt ( _
point As Point _
) As DiagramNode

Parameters

point
A PointF value specifying a point in the projection place where to look for node projections.

Return Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.OnDoubleClick Method

DiagramView3D.OnDoubleClick Method

Control.OnDoubleClick override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnDoubleClick (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnDoubleClick ( _
e As EventArgs _
)

Parameters

e

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.OnMouseDown Method

DiagramView3D.OnMouseDown Method

Control.OnMouseDown override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnMouseDown (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseDown ( _
e As MouseEventArgs _
)

Parameters

e

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.OnMouseMove Method

DiagramView3D.OnMouseMove Method

Control.OnMouseMove override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnMouseMove (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseMove ( _
e As MouseEventArgs _
)

Parameters

e

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.OnMouseUp Method

DiagramView3D.OnMouseUp Method

Control.OnMouseUp override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnMouseUp (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseUp ( _
e As MouseEventArgs _
)

Parameters

e

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.OnMouseWheel Method

DiagramView3D.OnMouseWheel Method

Control.OnMouseWheel override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnMouseWheel (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseWheel ( _
e As MouseEventArgs _
)

Parameters

e

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.OnPaint Method

DiagramView3D.OnPaint Method

Control.OnPaint override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnPaint (
PaintEventArgs e
)
Visual Basic

Protected Overridable Sub OnPaint ( _
e As PaintEventArgs _
)

Parameters

e

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.OnPaintBackground Method

DiagramView3D.OnPaintBackground Method

Control.OnPaintBackground override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual void OnPaintBackground (
PaintEventArgs pevent
)
Visual Basic

Protected Overridable Sub OnPaintBackground ( _
pevent As PaintEventArgs _
)

Parameters

pevent

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.PointCameraTo Method

DiagramView3D.PointCameraTo Method

Points the camera to the specified point in 3D space.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void PointCameraTo (
Point3D point
)
Visual Basic

Public Sub PointCameraTo ( _
point As Point3D _
)

Parameters

point
A Point3D value specifying where the camera should point to.

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.ResetProjection Method

DiagramView3D.ResetProjection Method

Invalidates the view and causes the node projections to be recalculated.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void ResetProjection ()
Visual Basic

Public Sub ResetProjection ()

Remarks

Call this method after changing the positions of nodes or their appearance properties.

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D Properties

DiagramView3D Properties

Public Properties

Name | Description
CameraPosition | Gets or sets the camera position.
CameraRotation | Gets or sets the camera rotation in yaw, roll and pitch angles.
Diagram | Gets or sets the diagram displayed by this view.
DimColor | Gets or sets a color used to dim items further from the camera.
EnableOrbitingCamera | Specifies whether users can use the CTRL key to orbit around a node with the camera.
ViewerDistance | Gets or sets the viewer distance from the camera.

See Also

DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.CameraPosition Property

DiagramView3D.CameraPosition Property

Gets or sets the camera position.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Point3D CameraPosition { get; set; }
Visual Basic

Public Property CameraPosition As Point3D

Property Value

A Point3D value specifying the camera position.

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.CameraRotation Property

DiagramView3D.CameraRotation Property

Gets or sets the camera rotation in yaw, roll and pitch angles.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Point3D CameraRotation { get; set; }
Visual Basic

Public Property CameraRotation As Point3D

Property Value

A Point3D value specifying the camera's pitch, roll and yaw angles.

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.Diagram Property

DiagramView3D.Diagram Property

Gets or sets the diagram displayed by this view.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Diagram Diagram { get; set; }
Visual Basic

Public Property Diagram As Diagram

Property Value

A Diagram instance.

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.DimColor Property

DiagramView3D.DimColor Property

Gets or sets a color used to dim items further from the camera.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Color DimColor { get; set; }
Visual Basic

Public Property DimColor As Color

Property Value

A Color value specifying the dim color. The default is White.

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.EnableOrbitingCamera Property

DiagramView3D.EnableOrbitingCamera Property

Specifies whether users can use the CTRL key to orbit around a node with the camera.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool EnableOrbitingCamera { get; set; }
Visual Basic

Public Property EnableOrbitingCamera As Boolean

Property Value

true to enable orbiting camera, otherwise false. The default value is false.

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.DiagramView3D.ViewerDistance Property

DiagramView3D.ViewerDistance Property

Gets or sets the viewer distance from the camera.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public float ViewerDistance { get; set; }
Visual Basic

Public Property ViewerDistance As Single

Property Value

A float value specifying the viewer distance. The default value is 200.

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.InPlaceEditEventArgs Class

InPlaceEditEventArgs Class

Contains the arguments passed in-place editing related event handlers.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class InPlaceEditEventArgs : EventArgs
Visual Basic

Public Class InPlaceEditEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.WinForms.InPlaceEditEventArgs

See Also

InPlaceEditEventArgs Members
MindFusion.Diagramming.WinForms Namespace
EnterInplaceEditMode Event
LeaveInplaceEditMode Event
CreateEditControl Event
DestroyEditControl Event


MindFusion.Diagramming.WinForms.InPlaceEditEventArgs Members

InPlaceEditEventArgs Members
Properties

Contains the arguments passed in-place editing related event handlers.

The following tables list the members exposed by the InPlaceEditEventArgs type.

Public Properties

Name | Description
EditControl | Gets or sets the control used to edit the item's text.
Item | Gets a reference to the item being edited.
Node | Gets the diagram node being edited.

See Also

InPlaceEditEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.InPlaceEditEventArgs Properties

InPlaceEditEventArgs Properties

Public Properties

Name | Description
EditControl | Gets or sets the control used to edit the item's text.
Item | Gets a reference to the item being edited.
Node | Gets the diagram node being edited.

See Also

InPlaceEditEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.InPlaceEditEventArgs.EditControl Property

InPlaceEditEventArgs.EditControl Property

Gets or sets the control used to edit the item's text.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Control EditControl { get; }
Visual Basic

Public Property EditControl As Control

Property Value

An instance of the .NET Control class.

Remarks

By default, MindFusion.Diagramming uses a TextBox control to let users enter text. You can override this by handling the CreateEditControl event.

See Also

InPlaceEditEventArgs Members
InPlaceEditEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.InPlaceEditEventArgs.Item Property

InPlaceEditEventArgs.Item Property

Gets a reference to the item being edited.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public InplaceEditable Item { get; }
Visual Basic

Public ReadOnly Property Item As InplaceEditable

Property Value

An InplaceEditable reference representing the node or table cell being edited.

See Also

InPlaceEditEventArgs Members
InPlaceEditEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.InPlaceEditEventArgs.Node Property

InPlaceEditEventArgs.Node Property

Gets the diagram node being edited.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public DiagramNode Node { get; }
Visual Basic

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class that represents either the node being edited, or the table that contains the edited cell.

See Also

InPlaceEditEventArgs Members
InPlaceEditEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.InPlaceEditEventHandler Delegate

InPlaceEditEventHandler Delegate

Represents methods that will handle general in-place edit events.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public delegate void InPlaceEditEventHandler (
Object sender,
InPlaceEditEventArgs e
)
Visual Basic

Public Delegate Sub InPlaceEditEventHandler ( _
sender As Object, _
e As InPlaceEditEventArgs _
)

Parameters

sender

The source of the event.

e

An InPlaceEditEventArgs that contains the event data.

See Also

MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.IPrintPreview Interface

IPrintPreview Interface

An interface that should be implemented by custom Print Preview forms.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public interface IPrintPreview
Visual Basic

Public Interface IPrintPreview

See Also

IPrintPreview Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.IPrintPreview Members

IPrintPreview Members
Properties

An interface that should be implemented by custom Print Preview forms.

The following tables list the members exposed by the IPrintPreview type.

Public Properties

Name | Description
Document | Gets or sets the print document associated with this form.

See Also

IPrintPreview Interface
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.IPrintPreview Properties

IPrintPreview Properties

Public Properties

Name | Description
Document | Gets or sets the print document associated with this form.

See Also

IPrintPreview Interface
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.IPrintPreview.Document Property

IPrintPreview.Document Property

Gets or sets the print document associated with this form.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public abstract PrintDocument Document { get; set; }
Visual Basic

Public MustOverride Property Document As PrintDocument

Property Value

An instance of the .NET PrintDocument class.

See Also

IPrintPreview Members
IPrintPreview Interface
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ModifierKeyActions Class

ModifierKeyActions Class
Remarks See Also

Maps keyboard modifier keys to special actions in MindFusion.Diagramming such as panning and drawing selection rectangle.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public sealed class ModifierKeyActions
Visual Basic

Public NotInheritable Class ModifierKeyActions

Remarks

The ModifierKeyActions property of DiagramView returns an object from this class, letting you specify the modifier key functions for each DiagramView instance.

Assign member of the ModifierKeyAction enumeration to the Alt, Control and Shift properties to specify what function is assigned to the ALT, CTRL and SHIFT keys.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.ModifierKeyActions

See Also

ModifierKeyActions Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ModifierKeyActions Members

ModifierKeyActions Members
Properties

Maps keyboard modifier keys to special actions in MindFusion.Diagramming such as panning and drawing selection rectangle.

The following tables list the members exposed by the ModifierKeyActions type.

Public Properties

Name | Description
Alt | Gets or sets what action is triggered by the ALT key.
Control | Gets or sets what action is triggered by the CTRL key.
Shift | Gets or sets what action is triggered by the SHIFT key.

See Also

ModifierKeyActions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ModifierKeyActions Properties

ModifierKeyActions Properties

Public Properties

Name | Description
Alt | Gets or sets what action is triggered by the ALT key.
Control | Gets or sets what action is triggered by the CTRL key.
Shift | Gets or sets what action is triggered by the SHIFT key.

See Also

ModifierKeyActions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ModifierKeyActions.Alt Property

ModifierKeyActions.Alt Property

Gets or sets what action is triggered by the ALT key.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ModifierKeyAction Alt { get; set; }
Visual Basic

Public Property Alt As ModifierKeyAction

Property Value

A member of the ModifierKeyAction enumeration. The default is Pan.

Remarks

The value of this property specifies what happens when a user holds down the ALT key and drags the mouse. The default value Pan makes the control enter pan mode, letting the user scroll the diagram contents by dragging it with the mouse. You can change the function of ALT by assigning a different value to this property.

See Also

ModifierKeyActions Members
ModifierKeyActions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ModifierKeyActions.Control Property

ModifierKeyActions.Control Property

Gets or sets what action is triggered by the CTRL key.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ModifierKeyAction Control { get; set; }
Visual Basic

Public Property Control As ModifierKeyAction

Property Value

A member of the ModifierKeyAction enumeration. The default is Select.

Remarks

The value of this property specifies what happens when a user holds down the CTRL key and drags the mouse. The default value Select makes the control enter selection mode, letting the user draw a lasso rectangle around diagram items in order to select them. You can change the function of CTRL by assigning a different value to this property.

See Also

ModifierKeyActions Members
ModifierKeyActions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ModifierKeyActions.Shift Property

ModifierKeyActions.Shift Property

Gets or sets what action is triggered by the SHIFT key.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ModifierKeyAction Shift { get; set; }
Visual Basic

Public Property Shift As ModifierKeyAction

Property Value

A member of the ModifierKeyAction enumeration. The default value is OverrideBehavior.

Remarks

The value of this property specifies what happens when a user holds down the SHIFT key and drags the mouse. The default value OverrideBehavior makes the control ignore item's selection handles, thus not allowing modifying a selected item but starts the creation of a new item. You can change the function of SHIFT by assigning a different value to this property.

See Also

ModifierKeyActions Members
ModifierKeyActions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview Class

Overview Class
Remarks See Also

The Overview control provides a scaled-down view of a DiagramView contents and allows scrolling and zooming the diagram with the mouse.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public class Overview : Control
Visual Basic

Public Class Overview
Inherits Control

Remarks

To use the Overview control, select "Customize" from the Visual Studio toolbox context menu and add a reference to MindFusion.Diagramming.WinForms.Overview.dll. Now the Overview control appears in the toolbox - select it and draw on a form to create its instance.

To specify which DiagramView instance is shown in the overview, set the DiagramView property. After adding a DiagramView or an Overview instance to a form, you might have to close and reopen that form, to make the property browser's drop-down list for DiagramView populated with all available DiagramView instances.

The scale in which the overview control paints items is determined by ScaleFactor and FitAll. FitAll makes the whole diagram fit into the control.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Diagramming.WinForms.Overview

See Also

Overview Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview Members

Overview Members
Constructors Properties Methods

The Overview control provides a scaled-down view of a DiagramView contents and allows scrolling and zooming the diagram with the mouse.

The following tables list the members exposed by the Overview type.

Public Constructors

Name | Description
Overview | Initializes a new instance of the Overview class.

Public Properties

Name | Description
BackColor | Gets or sets the background color of the overview control.
DiagramView | Gets or sets the DiagramView instance whose contents to display in this overview control.
DimColor | Gets or sets a color used to blend with the part of the diagram that is not visible in the DiagramView's client rectangle.
DisplayBackground | Gets or sets a value indicating whether to paint the diagram background with the diagram's BackBrush.
DisplayBackgroundImage | Gets or sets a value indicating whether to paint the diagram's BackgroundImage in the overview control.
DisplayImages | Gets or sets a value indicating whether to paint node images in the overview control.
DisplayInterior | Gets or sets a value indicating whether to fill interior of nodes with their Brush.
DisplayShadows | Gets or sets a value indicating whether to paint the shadows of items in the overview control.
DisplayText | Gets or sets a value indicating whether to paint the text of items in the overview control.
FitAll | Gets or sets a value indicating whether to fit the whole diagram inside the overview control.
ScaleFactor | Gets or sets a fixed scale factor to be used when FitAll is disabled.
ShowScrollbars | Gets or sets a value indicating whether the scrollbars of the overview control are visible.
SmoothingMode | Gets or sets the current anti-alias mode.

Public Methods

Name | Description
Update | Causes the control to recalculate its internals and repaint itself.

Protected Methods

Name | Description
Dispose | Control.Dispose override.
Finalize | The destructor of the Overview class.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnMouseWheel | Control.OnMouseWheel override.
OnPaint | Control.OnPaint override.
OnPaintBackground | Control.OnPaintBackground override.
OnResize | Control.OnResize override.

See Also

Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview Constructor

Overview Constructor

Initializes a new instance of the Overview class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public Overview ()
Visual Basic

Public Sub New ()

See Also

Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview Methods

Overview Methods

Public Methods

Name | Description
Update | Causes the control to recalculate its internals and repaint itself.

Protected Methods

Name | Description
Dispose | Control.Dispose override.
Finalize | The destructor of the Overview class.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnMouseWheel | Control.OnMouseWheel override.
OnPaint | Control.OnPaint override.
OnPaintBackground | Control.OnPaintBackground override.
OnResize | Control.OnResize override.

See Also

Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.Dispose Method

Overview.Dispose Method

Control.Dispose override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.Finalize Method

Overview.Finalize Method

The destructor of the Overview class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

protected virtual void Finalize ()
Visual Basic

Protected Overridable Sub Finalize ()

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.OnMouseDown Method

Overview.OnMouseDown Method

Control.OnMouseDown override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

protected virtual void OnMouseDown (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseDown ( _
e As MouseEventArgs _
)

Parameters

e
A MouseEventArgs that contains the event data.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.OnMouseMove Method

Overview.OnMouseMove Method

Control.OnMouseMove override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

protected virtual void OnMouseMove (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseMove ( _
e As MouseEventArgs _
)

Parameters

e
A MouseEventArgs that contains the event data.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.OnMouseUp Method

Overview.OnMouseUp Method

Control.OnMouseUp override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

protected virtual void OnMouseUp (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseUp ( _
e As MouseEventArgs _
)

Parameters

e
A MouseEventArgs that contains the event data.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.OnMouseWheel Method

Overview.OnMouseWheel Method

Control.OnMouseWheel override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

protected virtual void OnMouseWheel (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseWheel ( _
e As MouseEventArgs _
)

Parameters

e
A MouseEventArgs that contains the event data.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.OnPaint Method

Overview.OnPaint Method

Control.OnPaint override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

protected virtual void OnPaint (
PaintEventArgs e
)
Visual Basic

Protected Overridable Sub OnPaint ( _
e As PaintEventArgs _
)

Parameters

e
A PaintEventArgs that contains the event data.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.OnPaintBackground Method

Overview.OnPaintBackground Method

Control.OnPaintBackground override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

protected virtual void OnPaintBackground (
PaintEventArgs pevent
)
Visual Basic

Protected Overridable Sub OnPaintBackground ( _
pevent As PaintEventArgs _
)

Parameters

pevent
A PaintEventArgs that contains the event data.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.OnResize Method

Overview.OnResize Method

Control.OnResize override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

protected virtual void OnResize (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnResize ( _
e As EventArgs _
)

Parameters

e
An EventArgs that contains the event data.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.Update Method

Overview.Update Method

Causes the control to recalculate its internals and repaint itself.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public void Update ()
Visual Basic

Public Sub Update ()

Remarks

Call this method after changing the size of the diagram view or the overview size, to ensure the tracking rectangle correctly matches the currently visible part of the diagram.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview Properties

Overview Properties

Public Properties

Name | Description
BackColor | Gets or sets the background color of the overview control.
DiagramView | Gets or sets the DiagramView instance whose contents to display in this overview control.
DimColor | Gets or sets a color used to blend with the part of the diagram that is not visible in the DiagramView's client rectangle.
DisplayBackground | Gets or sets a value indicating whether to paint the diagram background with the diagram's BackBrush.
DisplayBackgroundImage | Gets or sets a value indicating whether to paint the diagram's BackgroundImage in the overview control.
DisplayImages | Gets or sets a value indicating whether to paint node images in the overview control.
DisplayInterior | Gets or sets a value indicating whether to fill interior of nodes with their Brush.
DisplayShadows | Gets or sets a value indicating whether to paint the shadows of items in the overview control.
DisplayText | Gets or sets a value indicating whether to paint the text of items in the overview control.
FitAll | Gets or sets a value indicating whether to fit the whole diagram inside the overview control.
ScaleFactor | Gets or sets a fixed scale factor to be used when FitAll is disabled.
ShowScrollbars | Gets or sets a value indicating whether the scrollbars of the overview control are visible.
SmoothingMode | Gets or sets the current anti-alias mode.

See Also

Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.BackColor Property

Overview.BackColor Property

Gets or sets the background color of the overview control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public override Color BackColor { get; set; }
Visual Basic

Public Overrides Property BackColor As Color

Property Value

A .NET Color structure representing the background color. The default is SystemColors.Control.

Remarks

The area of the Overview window corresponding to the diagram's Bounds is painted with the diagram's BackBrush. Everything outside the diagram rectangle is filled with this color.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace
DimColor Property


MindFusion.Diagramming.WinForms.Overview.DiagramView Property

Overview.DiagramView Property

Gets or sets the DiagramView instance whose contents to display in this overview control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public DiagramView DiagramView { get; set; }
Visual Basic

Public Property DiagramView As DiagramView

Property Value

A DiagramView instance bound to this Overview control.

Remarks

The overview control needs a DiagramView reference and not a Diagram one, because a part of the overview functionality is displaying a tracking rectangle that corresponds to the diagram region currently visible inside a view. If you need to present to your users a diagram only in overview mode, you must still create an invisible DiagramView and assign it to the Overview control.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.DimColor Property

Overview.DimColor Property

Gets or sets a color used to blend with the part of the diagram that is not visible in the DiagramView's client rectangle.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public Color DimColor { get; set; }
Visual Basic

Public Property DimColor As Color

Property Value

A .NET Color instance representing the blend color. The default is Color.FromArgb(35, Color.Black).

Remarks

The diagram portion that is currently visible in the view's client rectangle is painted in the overview using the exact item and background colors. Colors in the area outside that rectangle are alpha-blended with the value of DimColor.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace
BackColor Property


MindFusion.Diagramming.WinForms.Overview.DisplayBackground Property

Overview.DisplayBackground Property

Gets or sets a value indicating whether to paint the diagram background with the diagram's BackBrush.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public bool DisplayBackground { get; set; }
Visual Basic

Public Property DisplayBackground As Boolean

Property Value

true to fill diagram area with BackBrush; otherwise, false. The default is true.

Remarks

Only the area of the Overview corresponding to diagram's Bounds is painted with BackBrush. The area outside that rectangle is filled with Overview's BackColor.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.DisplayBackgroundImage Property

Overview.DisplayBackgroundImage Property

Gets or sets a value indicating whether to paint the diagram's BackgroundImage in the overview control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public bool DisplayBackgroundImage { get; set; }
Visual Basic

Public Property DisplayBackgroundImage As Boolean

Property Value

true to paint the BackgroundImage; otherwise, false. The default is true.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace
BackgroundImageAlign Property


MindFusion.Diagramming.WinForms.Overview.DisplayImages Property

Overview.DisplayImages Property

Gets or sets a value indicating whether to paint node images in the overview control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public bool DisplayImages { get; set; }
Visual Basic

Public Property DisplayImages As Boolean

Property Value

true to paint node images; otherwise, false. The default is true.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.DisplayInterior Property

Overview.DisplayInterior Property

Gets or sets a value indicating whether to fill interior of nodes with their Brush.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public bool DisplayInterior { get; set; }
Visual Basic

Public Property DisplayInterior As Boolean

Property Value

true to fill interior of nodes with color; otherwise, false. The default is true.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.DisplayShadows Property

Overview.DisplayShadows Property

Gets or sets a value indicating whether to paint the shadows of items in the overview control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public bool DisplayShadows { get; set; }
Visual Basic

Public Property DisplayShadows As Boolean

Property Value

true to paint shadows; otherwise, false. The default is true.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace
ShadowsStyle Property


MindFusion.Diagramming.WinForms.Overview.DisplayText Property

Overview.DisplayText Property

Gets or sets a value indicating whether to paint the text of items in the overview control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public bool DisplayText { get; set; }
Visual Basic

Public Property DisplayText As Boolean

Property Value

true to paint text; otherwise, false. The default is true.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.FitAll Property

Overview.FitAll Property

Gets or sets a value indicating whether to fit the whole diagram inside the overview control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public bool FitAll { get; set; }
Visual Basic

Public Property FitAll As Boolean

Property Value

true to fit the whole diagram in the overview; otherwise, false. The default is false.

Remarks

If enabled, the ScaleFactor is changed to a suitable value, small enough to make the diagram's contents entirely visible.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.ScaleFactor Property

Overview.ScaleFactor Property

Gets or sets a fixed scale factor to be used when FitAll is disabled.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public float ScaleFactor { get; set; }
Visual Basic

Public Property ScaleFactor As Single

Property Value

A float value specifying the scale as percent of actual output. The default is 30.

Remarks

This factor is combined with the view's own ZoomFactor to get the final scale.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.ShowScrollbars Property

Overview.ShowScrollbars Property

Gets or sets a value indicating whether the scrollbars of the overview control are visible.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public bool ShowScrollbars { get; set; }
Visual Basic

Public Property ShowScrollbars As Boolean

Property Value

true to show scrollbars; otherwise, false. The default is false.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Overview.SmoothingMode Property

Overview.SmoothingMode Property

Gets or sets the current anti-alias mode.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Overview

Syntax

C#

public SmoothingMode SmoothingMode { get; set; }
Visual Basic

Public Property SmoothingMode As SmoothingMode

Property Value

A value from the .NET System.Drawing.Drawing2D.SmoothingMode enumeration.

Remarks

The HighQuality and AntiAlias values specify that smoothing is applied. All other values disable smoothing. Anti-aliasing slows down drawing of large diagrams, so it is disabled by default.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PaintControlEventArgs Class

PaintControlEventArgs Class

Contains the arguments passed to the PaintControlHost event handlers.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class PaintControlEventArgs : ControlNodeEventArgs
Visual Basic

Public Class PaintControlEventArgs
Inherits ControlNodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.WinForms.ControlNodeEventArgs
MindFusion.Diagramming.WinForms.PaintControlEventArgs

See Also

PaintControlEventArgs Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PaintControlEventArgs Members

PaintControlEventArgs Members
Properties

Contains the arguments passed to the PaintControlHost event handlers.

The following tables list the members exposed by the PaintControlEventArgs type.

Public Properties

Name | Description
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the control.
Handled | Gets or sets a value indicating whether the event handler performed custom painting.
PaintRect | Gets the bounding rectangle of the control.

See Also

PaintControlEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PaintControlEventArgs Properties

PaintControlEventArgs Properties

Public Properties

Name | Description
Graphics | An object implementing the IGraphics interface whose methods should be used to draw the control.
Handled | Gets or sets a value indicating whether the event handler performed custom painting.
PaintRect | Gets the bounding rectangle of the control.

See Also

PaintControlEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PaintControlEventArgs.Graphics Property

PaintControlEventArgs.Graphics Property

An object implementing the IGraphics interface whose methods should be used to draw the control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public IGraphics Graphics { get; }
Visual Basic

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

PaintControlEventArgs Members
PaintControlEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PaintControlEventArgs.Handled Property

PaintControlEventArgs.Handled Property

Gets or sets a value indicating whether the event handler performed custom painting.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool Handled { get; set; }
Visual Basic

Public Property Handled As Boolean

Property Value

true to indicate that the event was handled; otherwise, false.

Remarks

Always set this flag to true if you perform custom painting.

See Also

PaintControlEventArgs Members
PaintControlEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PaintControlEventArgs.PaintRect Property

PaintControlEventArgs.PaintRect Property

Gets the bounding rectangle of the control.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public RectangleF PaintRect { get; }
Visual Basic

Public ReadOnly Property PaintRect As RectangleF

Property Value

A .NET RectangleF instance.

See Also

PaintControlEventArgs Members
PaintControlEventArgs Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PaintControlEventHandler Delegate

PaintControlEventHandler Delegate

Represents methods that will handle control host-related custom-drawing events.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public delegate void PaintControlEventHandler (
Object sender,
PaintControlEventArgs e
)
Visual Basic

Public Delegate Sub PaintControlEventHandler ( _
sender As Object, _
e As PaintControlEventArgs _
)

Parameters

sender

The source of the event.

e

A PaintControlEventArgs that contains the event data.

See Also

MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions Class

PreviewOptions Class
Remarks See Also

Provides properties that allow customization of various aspects of the extended print-preview window.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public sealed class PreviewOptions
Visual Basic

Public NotInheritable Class PreviewOptions

Remarks

Use the PreviewOptions member of the DiagramView class to access the sole instance of this class.

Settings that alter the appearance of a diagram rendered to the printer or the preview dialog are set via PrintOptions. The PreviewOptions properties apply only to the UI elements of the extended preview dialog, displayed by the PrintPreviewEx method.

If DisplayPrintDialog is enabled, MindFusion.Diagramming displays a printer setup dialog when a user clicks the Print button in the preview window. Enable that property to let users change some printer settings before they start the print job. For example they could select a different printer, change the printer color settings or select the range of pages to be printed.

The ButtonImages property allows changing the images displayed inside the preview window toolbar buttons. The icon displayed in the titlebar can be set in the TitleBarIcon property.

The remaining properties allow changing the text of tooltips and menu items, which lets your application be localized or just use better English than ours.

Example

To display a customized print preview dialog, use code like this:

C#

private void preview_Click(object sender, System.EventArgs e)
{
diagramView.PreviewOptions.ButtonImages = myCoolImages;
diagramView.PrintPreviewEx();
}
Visual Basic

Private Sub preview_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles preview.Click

diagramView.PreviewOptions.ButtonImages = myCoolImages
diagramView.PrintPreviewEx()

End Sub

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.PreviewOptions

See Also

PreviewOptions Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions Members

PreviewOptions Members
Constructors Properties

Provides properties that allow customization of various aspects of the extended print-preview window.

The following tables list the members exposed by the PreviewOptions type.

Public Constructors

Name | Description
PreviewOptions | Initializes a new instance of the PreviewOptions class.

Public Properties

Name | Description
ButtonImages | Gets or sets the list of images to be displayed at print preview toolbar buttons.
DecreaseScaleCmdText | Gets or sets the caption of the "Decrease Scale" menu item.
DisplayPrintDialog | Gets or sets a value indicating whether a print setup dialog is displayed when the print button of the preview form is clicked.
DoubleScaleCmdText | Gets or sets the caption of the "Double Scale" menu item.
FirstPageToolTip | Gets or sets the ToolTip text displayed for the "First Page" toolbar button.
FitToPageToolTip | Gets or sets the ToolTip text displayed for the "Fit to Page" toolbar button.
FourPagesToolTip | Gets or sets the ToolTip text displayed for the "Four Pages" toolbar button.
HalveScaleCmdText | Gets or sets the caption for the "Halve Scale" item on the "Scale" menu.
IncreaseScaleCmdText | Gets or sets the caption of the "Increase Scale" item on the "Scale" toolbar menu.
LandscapeToolTip | Gets or sets the ToolTip text displayed for the "Landscape" toolbar button.
LastPageToolTip | Gets or sets the ToolTip text displayed for the "Last Page" toolbar button.
NextPageToolTip | Gets or sets the ToolTip text displayed for the "Next Page" toolbar button.
OnePageToolTip | Gets or sets the ToolTip text displayed for the "One Page" toolbar button.
OriginalScaleCmdText | Gets or sets the caption for the "Original Scale" item on the "Scale" menu.
PortraitToolTip | Gets or sets the ToolTip text displayed for the "Portrait" toolbar button.
PreviousPageToolTip | Gets or sets the ToolTip text displayed for the "Previous Page" toolbar button.
PrintToolTip | Gets or sets the ToolTip text displayed for the "Print" toolbar button.
ScaleFitToPageCmdText | Gets or sets the caption of the "Fit to Page" item on the "Scale" menu.
SixPagesToolTip | Gets or sets the ToolTip text displayed for the "Six Pages" toolbar button.
ThreePagesToolTip | Gets or sets the ToolTip text displayed for the "Three Pages" toolbar button.
TitleBarIcon | Gets or sets the icon displayed in the titlebar of the preview window.
TwoPagesToolTip | Gets or sets the ToolTip text displayed for the "Two Pages" toolbar button.
ZoomAutoCmdText | Gets or sets the caption for the "Auto" item in the "Zoom" menu.
ZoomToolTip | Gets or sets the ToolTip text displayed for the "Zoom" toolbar button.

See Also

PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions Constructor

PreviewOptions Constructor

Initializes a new instance of the PreviewOptions class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public PreviewOptions ()
Visual Basic

Public Sub New ()

See Also

PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions Properties

PreviewOptions Properties

Public Properties

Name | Description
ButtonImages | Gets or sets the list of images to be displayed at print preview toolbar buttons.
DecreaseScaleCmdText | Gets or sets the caption of the "Decrease Scale" menu item.
DisplayPrintDialog | Gets or sets a value indicating whether a print setup dialog is displayed when the print button of the preview form is clicked.
DoubleScaleCmdText | Gets or sets the caption of the "Double Scale" menu item.
FirstPageToolTip | Gets or sets the ToolTip text displayed for the "First Page" toolbar button.
FitToPageToolTip | Gets or sets the ToolTip text displayed for the "Fit to Page" toolbar button.
FourPagesToolTip | Gets or sets the ToolTip text displayed for the "Four Pages" toolbar button.
HalveScaleCmdText | Gets or sets the caption for the "Halve Scale" item on the "Scale" menu.
IncreaseScaleCmdText | Gets or sets the caption of the "Increase Scale" item on the "Scale" toolbar menu.
LandscapeToolTip | Gets or sets the ToolTip text displayed for the "Landscape" toolbar button.
LastPageToolTip | Gets or sets the ToolTip text displayed for the "Last Page" toolbar button.
NextPageToolTip | Gets or sets the ToolTip text displayed for the "Next Page" toolbar button.
OnePageToolTip | Gets or sets the ToolTip text displayed for the "One Page" toolbar button.
OriginalScaleCmdText | Gets or sets the caption for the "Original Scale" item on the "Scale" menu.
PortraitToolTip | Gets or sets the ToolTip text displayed for the "Portrait" toolbar button.
PreviousPageToolTip | Gets or sets the ToolTip text displayed for the "Previous Page" toolbar button.
PrintToolTip | Gets or sets the ToolTip text displayed for the "Print" toolbar button.
ScaleFitToPageCmdText | Gets or sets the caption of the "Fit to Page" item on the "Scale" menu.
SixPagesToolTip | Gets or sets the ToolTip text displayed for the "Six Pages" toolbar button.
ThreePagesToolTip | Gets or sets the ToolTip text displayed for the "Three Pages" toolbar button.
TitleBarIcon | Gets or sets the icon displayed in the titlebar of the preview window.
TwoPagesToolTip | Gets or sets the ToolTip text displayed for the "Two Pages" toolbar button.
ZoomAutoCmdText | Gets or sets the caption for the "Auto" item in the "Zoom" menu.
ZoomToolTip | Gets or sets the ToolTip text displayed for the "Zoom" toolbar button.

See Also

PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.ButtonImages Property

PreviewOptions.ButtonImages Property

Gets or sets the list of images to be displayed at print preview toolbar buttons.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public ImageList ButtonImages { get; set; }
Visual Basic

Public Property ButtonImages As ImageList

Property Value

An instance of the .NET ImageList class. The default is a null reference (Nothing in Visual Basic).

Remarks

If this property is set to null, the default MindFusion.Diagramming toolbar buttons are used. In order to use a different image list, it must contain at least 14 images with size 25x25 pixels. The following table shows the mapping between toolbar buttons and the ImageList indices:

Index | Button
0 | Print
1 | Zoom
2 | One Page
3 | Two Pages
4 | Three Pages
5 | Four Pages
6 | Six Pages
7 | First Page
8 | Previous Page
9 | Next Page
10 | Last Page
11 | Portrait
12 | Landscape
13 | Fit to Page

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.DecreaseScaleCmdText Property

PreviewOptions.DecreaseScaleCmdText Property

Gets or sets the caption of the "Decrease Scale" menu item.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string DecreaseScaleCmdText { get; set; }
Visual Basic

Public Property DecreaseScaleCmdText As String

Property Value

A string that specifies the caption of the "Decrease Scale" menu item.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.DisplayPrintDialog Property

PreviewOptions.DisplayPrintDialog Property

Gets or sets a value indicating whether a print setup dialog is displayed when the print button of the preview form is clicked.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public bool DisplayPrintDialog { get; set; }
Visual Basic

Public Property DisplayPrintDialog As Boolean

Property Value

true to display the printer setup dialog; otherwise, false. The default is false.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.DoubleScaleCmdText Property

PreviewOptions.DoubleScaleCmdText Property

Gets or sets the caption of the "Double Scale" menu item.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string DoubleScaleCmdText { get; set; }
Visual Basic

Public Property DoubleScaleCmdText As String

Property Value

A string that specifies the caption of the "Double Scale" item in the Scale menu.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.FirstPageToolTip Property

PreviewOptions.FirstPageToolTip Property

Gets or sets the ToolTip text displayed for the "First Page" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string FirstPageToolTip { get; set; }
Visual Basic

Public Property FirstPageToolTip As String

Property Value

A string that represents the ToolTip for the "First Page" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.FitToPageToolTip Property

PreviewOptions.FitToPageToolTip Property

Gets or sets the ToolTip text displayed for the "Fit to Page" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string FitToPageToolTip { get; set; }
Visual Basic

Public Property FitToPageToolTip As String

Property Value

A string that represents the ToolTip for the "Fit to Page" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.FourPagesToolTip Property

PreviewOptions.FourPagesToolTip Property

Gets or sets the ToolTip text displayed for the "Four Pages" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string FourPagesToolTip { get; set; }
Visual Basic

Public Property FourPagesToolTip As String

Property Value

A string that represents the ToolTip for the "Four Pages" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.HalveScaleCmdText Property

PreviewOptions.HalveScaleCmdText Property

Gets or sets the caption for the "Halve Scale" item on the "Scale" menu.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string HalveScaleCmdText { get; set; }
Visual Basic

Public Property HalveScaleCmdText As String

Property Value

A string that represents the caption of the "Halve Scale" menu item.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.IncreaseScaleCmdText Property

PreviewOptions.IncreaseScaleCmdText Property

Gets or sets the caption of the "Increase Scale" item on the "Scale" toolbar menu.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string IncreaseScaleCmdText { get; set; }
Visual Basic

Public Property IncreaseScaleCmdText As String

Property Value

A string that represents the caption of the "Increase Scale" menu item.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.LandscapeToolTip Property

PreviewOptions.LandscapeToolTip Property

Gets or sets the ToolTip text displayed for the "Landscape" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string LandscapeToolTip { get; set; }
Visual Basic

Public Property LandscapeToolTip As String

Property Value

A string that represents the ToolTip for the "Landscape" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.LastPageToolTip Property

PreviewOptions.LastPageToolTip Property

Gets or sets the ToolTip text displayed for the "Last Page" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string LastPageToolTip { get; set; }
Visual Basic

Public Property LastPageToolTip As String

Property Value

A string that represents the ToolTip for the "Last Page" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.NextPageToolTip Property

PreviewOptions.NextPageToolTip Property

Gets or sets the ToolTip text displayed for the "Next Page" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string NextPageToolTip { get; set; }
Visual Basic

Public Property NextPageToolTip As String

Property Value

A string that represents the ToolTip for the "Nect Page" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.OnePageToolTip Property

PreviewOptions.OnePageToolTip Property

Gets or sets the ToolTip text displayed for the "One Page" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string OnePageToolTip { get; set; }
Visual Basic

Public Property OnePageToolTip As String

Property Value

A string value that represents the ToolTip for the "Last Page" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.OriginalScaleCmdText Property

PreviewOptions.OriginalScaleCmdText Property

Gets or sets the caption for the "Original Scale" item on the "Scale" menu.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string OriginalScaleCmdText { get; set; }
Visual Basic

Public Property OriginalScaleCmdText As String

Property Value

A string that represents the caption on the "Original Scale" menu item.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.PortraitToolTip Property

PreviewOptions.PortraitToolTip Property

Gets or sets the ToolTip text displayed for the "Portrait" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string PortraitToolTip { get; set; }
Visual Basic

Public Property PortraitToolTip As String

Property Value

A string that represents the ToolTip for the "Portrait" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.PreviousPageToolTip Property

PreviewOptions.PreviousPageToolTip Property

Gets or sets the ToolTip text displayed for the "Previous Page" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string PreviousPageToolTip { get; set; }
Visual Basic

Public Property PreviousPageToolTip As String

Property Value

A string that represents the ToolTip for the "Previous Page" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.PrintToolTip Property

PreviewOptions.PrintToolTip Property

Gets or sets the ToolTip text displayed for the "Print" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string PrintToolTip { get; set; }
Visual Basic

Public Property PrintToolTip As String

Property Value

A string that represents the ToolTip for the "Print" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.ScaleFitToPageCmdText Property

PreviewOptions.ScaleFitToPageCmdText Property

Gets or sets the caption of the "Fit to Page" item on the "Scale" menu.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string ScaleFitToPageCmdText { get; set; }
Visual Basic

Public Property ScaleFitToPageCmdText As String

Property Value

A string that represents the caption of the "Fit to Page" item on the "Scale" menu.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.SixPagesToolTip Property

PreviewOptions.SixPagesToolTip Property

Gets or sets the ToolTip text displayed for the "Six Pages" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string SixPagesToolTip { get; set; }
Visual Basic

Public Property SixPagesToolTip As String

Property Value

A string that represents the ToolTip for the "Six Pages" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.ThreePagesToolTip Property

PreviewOptions.ThreePagesToolTip Property

Gets or sets the ToolTip text displayed for the "Three Pages" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string ThreePagesToolTip { get; set; }
Visual Basic

Public Property ThreePagesToolTip As String

Property Value

A string that represents the ToolTip for the "Three Pages" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.TitleBarIcon Property

PreviewOptions.TitleBarIcon Property

Gets or sets the icon displayed in the titlebar of the preview window.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Icon TitleBarIcon { get; set; }
Visual Basic

Public Property TitleBarIcon As Icon

Property Value

An instance of the .NET Icon class. The default value is null (Nothing in Visual Basic).

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.TwoPagesToolTip Property

PreviewOptions.TwoPagesToolTip Property

Gets or sets the ToolTip text displayed for the "Two Pages" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string TwoPagesToolTip { get; set; }
Visual Basic

Public Property TwoPagesToolTip As String

Property Value

A string that represents the ToolTip for the "Two Pages" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.ZoomAutoCmdText Property

PreviewOptions.ZoomAutoCmdText Property

Gets or sets the caption for the "Auto" item in the "Zoom" menu.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string ZoomAutoCmdText { get; set; }
Visual Basic

Public Property ZoomAutoCmdText As String

Property Value

A string that represents the caption for the "Auto" item in the "Zoom" menu.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PreviewOptions.ZoomToolTip Property

PreviewOptions.ZoomToolTip Property

Gets or sets the ToolTip text displayed for the "Zoom" toolbar button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string ZoomToolTip { get; set; }
Visual Basic

Public Property ZoomToolTip As String

Property Value

A string that represents the ToolTip for the "Zoom" toolbar button.

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PrintOptions Class

PrintOptions Class
Remarks See Also

Allows customization of various aspects of printing and print-preview.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class PrintOptions : RenderOptions
Visual Basic

Public Class PrintOptions
Inherits RenderOptions

Remarks

Use the PrintOptions member of the DiagramView class to access the sole instance of this class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.RenderOptions
MindFusion.Diagramming.WinForms.PrintOptions

See Also

PrintOptions Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PrintOptions Members

PrintOptions Members
Constructors Properties Methods

Allows customization of various aspects of printing and print-preview.

The following tables list the members exposed by the PrintOptions type.

Public Constructors

Name | Description
PrintOptions | Initializes a new instance of the PrintOptions class.

Public Properties

Name | Description
DocumentName | Gets or sets the name of the printed document.
HeaderFormat | Specifies the format of page headers.
Margins | Gets or sets the margins for the printed pages.

Public Methods

Name | Description
ScaleToPage | Overloaded. Adjusts the value of the Scale property so that the whole diagram would fit on a single page.

See Also

PrintOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PrintOptions Constructor

PrintOptions Constructor

Initializes a new instance of the PrintOptions class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public PrintOptions (
DiagramView diagramView
)
Visual Basic

Public Sub PrintOptions ( _
diagramView As DiagramView _
)

Parameters

diagramView

The diagram view this object will be associated with.

See Also

PrintOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PrintOptions Methods

PrintOptions Methods

Public Methods

Name | Description
ScaleToPage | Overloaded. Adjusts the value of the Scale property so that the whole diagram would fit on a single page.

See Also

PrintOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PrintOptions.ScaleToPage Method

PrintOptions.ScaleToPage Method

Adjusts the value of the Scale property so that the whole diagram would fit on a single page.

Overload List

Name | Description
PrintOptions.ScaleToPage () | Sets Scale to a value that makes a single printed page fit the whole diagram.
PrintOptions.ScaleToPage (PrintDocument) | Sets Scale to a value that makes a single printed page fit the whole diagram.

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PrintOptions.ScaleToPage Method ()

PrintOptions.ScaleToPage Method ()
See Also

Sets Scale to a value that makes a single printed page fit the whole diagram.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void ScaleToPage ()
Visual Basic

Public Sub ScaleToPage ()

Remarks

ScaleToPage queries the default printer about its page size and assigns to Scale such a value that a single page fits the whole diagram. This method is used internally by the 'Scale to page' button in the extended print preview dialog.

See Also

ScaleToPage Method Overload List
PrintOptions Members
PrintOptions Class
MindFusion.Diagramming.WinForms Namespace
Bounds Property


MindFusion.Diagramming.WinForms.PrintOptions.ScaleToPage Method (PrintDocument)

PrintOptions.ScaleToPage Method (PrintDocument)
See Also

Sets Scale to a value that makes a single printed page fit the whole diagram.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public void ScaleToPage (
PrintDocument doc
)
Visual Basic

Public Sub ScaleToPage ( _
doc As PrintDocument _
)

Parameters

doc

See Also

ScaleToPage Method Overload List
PrintOptions Members
PrintOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PrintOptions Properties

PrintOptions Properties

Public Properties

Name | Description
DocumentName | Gets or sets the name of the printed document.
HeaderFormat | Specifies the format of page headers.
Margins | Gets or sets the margins for the printed pages.

See Also

PrintOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PrintOptions.DocumentName Property

PrintOptions.DocumentName Property

Gets or sets the name of the printed document.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string DocumentName { get; set; }
Visual Basic

Public Property DocumentName As String

Property Value

A string value specifying the name of the printed document. The default is " - Untitled - ".

Remarks

This string is displayed in the print queue status window and in page headers.

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PrintOptions.HeaderFormat Property

PrintOptions.HeaderFormat Property

Specifies the format of page headers.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public string HeaderFormat { get; set; }
Visual Basic

Public Property HeaderFormat As String

Property Value

A string value specifying the name of the printed document. The default is "%D , Page %P".

Remarks

The header format string can contain fixed text and format specifiers. Currently, there are two format specifiers supported: %D is a placeholder for the document title; %P is a placholder for the page number.

Example

To get page headers of the form "Page 21 of document MyChart.fc", use code like this:

C#

diagramView.PrintOptions.HeaderFormat = "Page %P of document %D";
diagramView.PrintOptions.DocumentName = "MyChart.fc";
diagramView.Print();
Visual Basic

diagramView.PrintOptions.HeaderFormat = "Page %P of document %D"
diagramView.PrintOptions.DocumentName = "MyChart.fc"
diagramView.Print()

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.PrintOptions.Margins Property

PrintOptions.Margins Property

Gets or sets the margins for the printed pages.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public Margins Margins { get; set; }
Visual Basic

Public Property Margins As Margins

Property Value

An instance of the .NET System.Drawing.Printing.Margins class. The default is 1-inch margins on all sides.

Remarks

Margins are measured in hundredths of an inch. The value of this property is used by the Print override that doesn't get a PrintDocument argument. The overrides that get a PrintDocument use the margins specified in its DefaultPageSettings member.

If using page headers, make sure there is enough space left for the top margin because the headers are printed there.

Example

C#

private void preview_Click(object sender, System.EventArgs e)
{
diagramView.PrintOptions.Margins = new Margins(50, 50, 50, 50);
diagramView.PrintPreviewEx();
}
Visual Basic

Private Sub preview_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles preview.Click

diagramView.PrintOptions.Margins = New Margins(50, 50, 50, 50)
diagramView.PrintPreviewEx()

End Sub

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Diagramming.WinForms Namespace
HeaderFormat Property


MindFusion.Diagramming.WinForms.Ruler Class

Ruler Class
Remarks See Also

The Ruler control provides horizontal and vertical scales that helps users measure diagram items.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public class Ruler : Control
Visual Basic

Public Class Ruler
Inherits Control

Remarks

To use the Ruler control, you must customize the Visual Studio toolbox and add a reference to MindFusion.Diagramming.WinForms.Ruler.dll. To specify which DiagramView instance is shown in the ruler, set the DiagramView property. After adding a DiagramView or a Ruler to a form, you might need to close and reopen that form, in order to have the DiagramView property drop-down list refreshed and populated with all DiagramView objects on the form.

The ruler tracks mouse movements and modifications being performed on an item, and displays markers over the scales indicating the current position in diagram's coordinate system. The colors of these markers can be changed using the PointerColor and ProjectionColor properties.

If EnableGuides is set to true, the ruler allows aligning several items by clicking on a scale and dragging. That displays alignment guides which follow the mouse pointer and move all selected items on their way. If no diagram elements are selected, all items are moved.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Diagramming.WinForms.Ruler

See Also

Ruler Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler Members

Ruler Members
Constructors Properties Methods

The Ruler control provides horizontal and vertical scales that helps users measure diagram items.

The following tables list the members exposed by the Ruler type.

Public Constructors

Name | Description
Ruler | Initializes a new instance of the Ruler class.

Public Properties

Name | Description
ContextMenu | Gets or sets the context menu associated with the ruler.
DiagramView | Gets or sets the DiagramView document this ruler is associated with.
EnableGuides | Gets or sets a value indicating whether the alignment guides are enabled.
ForeColor | Gets or sets the foreground color of the ruler.
GuideColor | Gets or sets the color of the alignment guide lines.
HorizontalScaleAlignment | Gets or sets the alignment of the horizontal scale.
HorizontalScaleVisible | Gets or sets a value specifying whether the horizontal scale is visible.
PointerColor | Gets or sets the color of the mouse pointer's projections.
ProjectionColor | Gets or sets the color of the projections of the active node on the ruler scales.
ShowIcon | Gets or sets a value indicating whether to show the icon between the horizontal and vertical scales.
Text | Gets or sets the text displayed in the ruler's corner button.
Unit | Gets or sets the measure units displayed in the ruler scales.
VerticalScaleAlignment | Gets or sets the alignment of the vertical scale.
VerticalScaleVisible | Gets or sets a value indicating whether the vertical scale is visible.

Protected Methods

Name | Description
Dispose | Control.Dispose override.
OnBackgroundImageChanged | Control.OnBackgroundImageChanged override.
OnFontChanged | Control.OnFontChanged override.
OnPaint | Control.OnPaint override.

See Also

Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler Constructor

Ruler Constructor

Initializes a new instance of the Ruler class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public Ruler ()
Visual Basic

Public Sub New ()

See Also

Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler Methods

Ruler Methods

Protected Methods

Name | Description
Dispose | Control.Dispose override.
OnBackgroundImageChanged | Control.OnBackgroundImageChanged override.
OnFontChanged | Control.OnFontChanged override.
OnPaint | Control.OnPaint override.

See Also

Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.Dispose Method

Ruler.Dispose Method

Control.Dispose override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.OnBackgroundImageChanged Method

Ruler.OnBackgroundImageChanged Method

Control.OnBackgroundImageChanged override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

protected virtual void OnBackgroundImageChanged (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnBackgroundImageChanged ( _
e As EventArgs _
)

Parameters

e
An EventArgs that contains the event data.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.OnFontChanged Method

Ruler.OnFontChanged Method

Control.OnFontChanged override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

protected virtual void OnFontChanged (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnFontChanged ( _
e As EventArgs _
)

Parameters

e
An EventArgs that contains the event data.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.OnPaint Method

Ruler.OnPaint Method

Control.OnPaint override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

protected virtual void OnPaint (
PaintEventArgs e
)
Visual Basic

Protected Overridable Sub OnPaint ( _
e As PaintEventArgs _
)

Parameters

e
A PaintEventArgs that contains the event data.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler Properties

Ruler Properties

Public Properties

Name | Description
ContextMenu | Gets or sets the context menu associated with the ruler.
DiagramView | Gets or sets the DiagramView document this ruler is associated with.
EnableGuides | Gets or sets a value indicating whether the alignment guides are enabled.
ForeColor | Gets or sets the foreground color of the ruler.
GuideColor | Gets or sets the color of the alignment guide lines.
HorizontalScaleAlignment | Gets or sets the alignment of the horizontal scale.
HorizontalScaleVisible | Gets or sets a value specifying whether the horizontal scale is visible.
PointerColor | Gets or sets the color of the mouse pointer's projections.
ProjectionColor | Gets or sets the color of the projections of the active node on the ruler scales.
ShowIcon | Gets or sets a value indicating whether to show the icon between the horizontal and vertical scales.
Text | Gets or sets the text displayed in the ruler's corner button.
Unit | Gets or sets the measure units displayed in the ruler scales.
VerticalScaleAlignment | Gets or sets the alignment of the vertical scale.
VerticalScaleVisible | Gets or sets a value indicating whether the vertical scale is visible.

See Also

Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.ContextMenu Property

Ruler.ContextMenu Property

Gets or sets the context menu associated with the ruler.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public override ContextMenu ContextMenu { get; set; }
Visual Basic

Public Overrides Property ContextMenu As ContextMenu

Property Value

An instance of the .NET ContextMenu class. The default is null (Nothing in Visual Basic).

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.DiagramView Property

Ruler.DiagramView Property

Gets or sets the DiagramView document this ruler is associated with.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public DiagramView DiagramView { get; set; }
Visual Basic

Public Property DiagramView As DiagramView

Property Value

An instance of the DiagramView class contained within the ruler.

Remarks

This property can be set in design time by dragging a DiagramView control into the ruler control, or by selecting a DiagramView instance from the combo box displayed in the property grid for DiagramView.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.EnableGuides Property

Ruler.EnableGuides Property

Gets or sets a value indicating whether the alignment guides are enabled.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public bool EnableGuides { get; set; }
Visual Basic

Public Property EnableGuides As Boolean

Property Value

true to allow aligning diagram items using ruler guides; otherwise, false. The default is true.

Remarks

If alignment guides are enabled, users can start aligning items by pressing the left mouse button over a scale and dragging. The horizontal scale displays vertical guide lines that allow aligning the left or right sides of items. The vertical scale displays horizontal guide lines that allow aligning the top or bottom sides of items.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace
GuideColor Property


MindFusion.Diagramming.WinForms.Ruler.ForeColor Property

Ruler.ForeColor Property

Gets or sets the foreground color of the ruler.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public new Color ForeColor { get; set; }
Visual Basic

Public Shadows Property ForeColor As Color

Property Value

A .NET Color structure representing the fore color of the ruler.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.GuideColor Property

Ruler.GuideColor Property

Gets or sets the color of the alignment guide lines.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public Color GuideColor { get; set; }
Visual Basic

Public Property GuideColor As Color

Property Value

A .NET Color instance specifying the color of the guide lines. The default is SystemColors.ControlText.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace
EnableGuides Property


MindFusion.Diagramming.WinForms.Ruler.HorizontalScaleAlignment Property

Ruler.HorizontalScaleAlignment Property

Gets or sets the alignment of the horizontal scale.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public Alignment HorizontalScaleAlignment { get; set; }
Visual Basic

Public Property HorizontalScaleAlignment As Alignment

Property Value

Near to place the horizontal scale at the top; Far to place it at the bottom. The default is Near.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.HorizontalScaleVisible Property

Ruler.HorizontalScaleVisible Property

Gets or sets a value specifying whether the horizontal scale is visible.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public bool HorizontalScaleVisible { get; set; }
Visual Basic

Public Property HorizontalScaleVisible As Boolean

Property Value

true to display the horizontal scale; otherwise, false. The default is true.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.PointerColor Property

Ruler.PointerColor Property

Gets or sets the color of the mouse pointer's projections.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public Color PointerColor { get; set; }
Visual Basic

Public Property PointerColor As Color

Property Value

A .NET Color instance specifying the color of the pointer projection lines. The default is Color.Red.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.ProjectionColor Property

Ruler.ProjectionColor Property

Gets or sets the color of the projections of the active node on the ruler scales.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public Color ProjectionColor { get; set; }
Visual Basic

Public Property ProjectionColor As Color

Property Value

A .NET Color instance specifying the color of the selected node's projection on the scales. The default is Color.LightSteelBlue.

Remarks

The active node is a DiagramNode instance which is the current diagram's ActiveItem.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.ShowIcon Property

Ruler.ShowIcon Property

Gets or sets a value indicating whether to show the icon between the horizontal and vertical scales.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public bool ShowIcon { get; set; }
Visual Basic

Public Property ShowIcon As Boolean

Property Value

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.Text Property

Ruler.Text Property

Gets or sets the text displayed in the ruler's corner button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public new string Text { get; set; }
Visual Basic

Public Shadows Property Text As String

Property Value

A string specifying the label of the ruler's corner button.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.Unit Property

Ruler.Unit Property

Gets or sets the measure units displayed in the ruler scales.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public RulerUnit Unit { get; set; }
Visual Basic

Public Property Unit As RulerUnit

Property Value

A member of the RulerUnit enumeration specifying what units are displayed in the scales. The default is Millimeter.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.VerticalScaleAlignment Property

Ruler.VerticalScaleAlignment Property

Gets or sets the alignment of the vertical scale.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public Alignment VerticalScaleAlignment { get; set; }
Visual Basic

Public Property VerticalScaleAlignment As Alignment

Property Value

Near to place the vertical scale at the left side; Far to place it at the right side. The default is Near.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Ruler.VerticalScaleVisible Property

Ruler.VerticalScaleVisible Property

Gets or sets a value indicating whether the vertical scale is visible.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public bool VerticalScaleVisible { get; set; }
Visual Basic

Public Property VerticalScaleVisible As Boolean

Property Value

true to display the vertical scale; otherwise, false. The default is true.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.RulerUnit Enumeration

RulerUnit Enumeration

Specifies a measurement unit for the Ruler.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.Ruler

Syntax

C#

public enum RulerUnit
Visual Basic

Public Enumeration RulerUnit

Members

Member name | Description
Inch | Indicates an inch.
Millimeter | Indicates a millimeter.
Percent | Indicates percent.
Pixel | Indicates a pixel.
Point | Indicates a point.

See Also

MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox Class

ShapeListBox Class
Remarks See Also

The ShapeListBox control displays a set of shapes defined via the Shape class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public class ShapeListBox : ListBox
Visual Basic

Public Class ShapeListBox
Inherits ListBox

Remarks

In order to use the ShapeListBox control, customize the Visual Studio toolbox and add a reference to MindFusion.Diagramming.WinForms.ShapeListBox.dll.

Shapes from the list box can be dragged to the DiagramView drawing canvas to create new shape nodes. Changing the shape of an existing node can be implemented by handling the ShapeSelected event and assigning the selected shape to the Shape property of a node.

Initially, the ShapeListBox displays all shapes accessible via Shape.FromId. You could limit the list only to a subset of the available shapes by setting the ShapeFilter property. It is also possible to load a shape library from a file using the ShapeLibrary class, and display the loaded shapes as shown below:

C#

ShapeLibrary lib = ShapeLibrary.LoadFrom("shapeLib.shl");
shapeList.Shapes = lib.Shapes;

The control creates an icon image for each shape added. The size of an icon displayed in the list box can be defined via the IconSize property, and IconMargin specifies the horizontal and vertical margin of the icon. The shape's DisplayName is displayed as a label near the icon.

If the AllowRename property is set to true, users can press the F2 key and rename a shape in the list box. When a shape is renamed, the ShapeRenamed event is raised. If the AllowRemove property is enabled, list box items can be deleted by pressing the DEL key. When a shape is removed, the ShapeRemoved event is raised.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ListBox
MindFusion.Diagramming.WinForms.ShapeListBox

See Also

ShapeListBox Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox Members

ShapeListBox Members
Constructors Properties Methods Events

The ShapeListBox control displays a set of shapes defined via the Shape class.

The following tables list the members exposed by the ShapeListBox type.

Public Constructors

Name | Description
ShapeListBox | Initializes a new instance of the ShapeListBox class.

Public Properties

Name | Description
AllowRemove | Gets or sets a value indicating whether users are allowed to remove list box items by pressing DEL. DiagrammingProProductName
AllowRename | Gets or sets a value indicating whether users are allowed to rename the list box items by pressing F2.
DefaultNodeSize | Gets or sets the size of the shapes that are created by dragging list box items to the diagram.
DrawMode | ListBox.DrawMode override.
IconMargin | Gets or sets the horizontal and vertical margins left around the shape icons.
IconSize | Gets or sets the size of the shape icons.
ShapeCount | Gets the number of shapes in the list box.
ShapeFillColor | Gets or sets the fill color of the shapes icons.
ShapeFilter | Gets or sets the ids of shapes that should be displayed in the listbox.
Shapes | Gets or sets the shapes displayed in the list box.

Public Methods

Name | Description
AddShape | Adds a new shape to the end of the list box.
AddShapes | Overloaded. Adds the specified shapes to the end of the list box.
ClearShapes | Removes all shapes from the list box.
GetShapeAt | Gets the shape at the specified index in the list box.
InsertShape | Inserts the specified shape at the specified position.
InvalidateShapeAt | Invalidates shape at the specified index causing it to be redrawn.
RemoveShapeAt | Removes the shape at the specified index.
SetShapeAt | Sets a new shape at the specified position.
StartInlineEdit | Enters inplace-edit mode, allowing users to edit the label of the selected shape.

Protected Methods

Name | Description
OnDrawItem | ListBox.OnDrawItem override.
OnKeyDown | Control.OnKeyDown override.
OnMeasureItem | ListBox.OnMeasureItem override.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnSelectedIndexChanged | ListBox.OnSelectedIndexChanged override.
OnShapeRemoved | Raises the ShapeRemoved event.
OnShapeRenamed | Raises the ShapeRenamed event.
OnShapeSelected | Raises the ShapeSelected event.

Public Events

Name | Description
ShapeRemoved | Raised when the user removes a shape from the list box.
ShapeRenamed | Raised when the user renames a shape in the list box.
ShapeSelected | Raised when the user selects a shape in the list box.

See Also

ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox Constructor

ShapeListBox Constructor

Initializes a new instance of the ShapeListBox class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public ShapeListBox ()
Visual Basic

Public Sub New ()

See Also

ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox Methods

ShapeListBox Methods

Public Methods

Name | Description
AddShape | Adds a new shape to the end of the list box.
AddShapes | Overloaded. Adds the specified shapes to the end of the list box.
ClearShapes | Removes all shapes from the list box.
GetShapeAt | Gets the shape at the specified index in the list box.
InsertShape | Inserts the specified shape at the specified position.
InvalidateShapeAt | Invalidates shape at the specified index causing it to be redrawn.
RemoveShapeAt | Removes the shape at the specified index.
SetShapeAt | Sets a new shape at the specified position.
StartInlineEdit | Enters inplace-edit mode, allowing users to edit the label of the selected shape.

Protected Methods

Name | Description
OnDrawItem | ListBox.OnDrawItem override.
OnKeyDown | Control.OnKeyDown override.
OnMeasureItem | ListBox.OnMeasureItem override.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnSelectedIndexChanged | ListBox.OnSelectedIndexChanged override.
OnShapeRemoved | Raises the ShapeRemoved event.
OnShapeRenamed | Raises the ShapeRenamed event.
OnShapeSelected | Raises the ShapeSelected event.

See Also

ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.AddShape Method

ShapeListBox.AddShape Method

Adds a new shape to the end of the list box.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public void AddShape (
Shape t
)
Visual Basic

Public Sub AddShape ( _
t As Shape _
)

Parameters

t
A Shape representing the shape that will be added to the list box.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
AddShapes Method
RemoveShapeAt Method


MindFusion.Diagramming.WinForms.ShapeListBox.AddShapes Method

ShapeListBox.AddShapes Method

Adds the specified shapes to the end of the list box.

Overload List

Name | Description
ShapeListBox.AddShapes (Shape[]) | Adds the shapes from the specified array to the end of the list box.
ShapeListBox.AddShapes (ShapeCollection) | Adds the shapes from the specified collection to the end of the list box.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.AddShapes Method (Shape[])

ShapeListBox.AddShapes Method (Shape[])
See Also

Adds the shapes from the specified array to the end of the list box.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public void AddShapes (
Shape[] shapes
)
Visual Basic

Public Sub AddShapes ( _
shapes As Shape() _
)

Parameters

shapes
An array of Shape objects representing the shapes to be added to the list box.

See Also

AddShapes Method Overload List
ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
AddShape Method
ClearShapes Method


MindFusion.Diagramming.WinForms.ShapeListBox.AddShapes Method (ShapeCollection)

ShapeListBox.AddShapes Method (ShapeCollection)
See Also

Adds the shapes from the specified collection to the end of the list box.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public void AddShapes (
ShapeCollection shapes
)
Visual Basic

Public Sub AddShapes ( _
shapes As ShapeCollection _
)

Parameters

shapes
A collection of Shape objects representing the shapes to be added to the list box.

See Also

AddShapes Method Overload List
ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
AddShape Method
ClearShapes Method


MindFusion.Diagramming.WinForms.ShapeListBox.ClearShapes Method

ShapeListBox.ClearShapes Method

Removes all shapes from the list box.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public void ClearShapes ()
Visual Basic

Public Sub ClearShapes ()

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
AddShapes Method
Shapes Property


MindFusion.Diagramming.WinForms.ShapeListBox.GetShapeAt Method

ShapeListBox.GetShapeAt Method

Gets the shape at the specified index in the list box.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public Shape GetShapeAt (
int index
)
Visual Basic

Public Function GetShapeAt ( _
index As Integer _
) As Shape

Parameters

index
An integer value specifying the index of the shape within the list box.

Return Value

A Shape instance representing the shape at the specified position in the list.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
SetShapeAt Method


MindFusion.Diagramming.WinForms.ShapeListBox.InsertShape Method

ShapeListBox.InsertShape Method

Inserts the specified shape at the specified position.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public void InsertShape (
int i,
Shape s
)
Visual Basic

Public Sub InsertShape ( _
i As Integer, _
s As Shape _
)

Parameters

i
An integer value specifying the index of the new shape.
s
A Shape representing the shape that should be added to the list box.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
RemoveShapeAt Method


MindFusion.Diagramming.WinForms.ShapeListBox.InvalidateShapeAt Method

ShapeListBox.InvalidateShapeAt Method

Invalidates shape at the specified index causing it to be redrawn.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public void InvalidateShapeAt (
int i
)
Visual Basic

Public Sub InvalidateShapeAt ( _
i As Integer _
)

Parameters

i
An integer value specifying the index of the shape to be redrawn.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
GetShapeAt Method


MindFusion.Diagramming.WinForms.ShapeListBox.OnDrawItem Method

ShapeListBox.OnDrawItem Method

ListBox.OnDrawItem override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

protected virtual void OnDrawItem (
DrawItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnDrawItem ( _
e As DrawItemEventArgs _
)

Parameters

e
A DrawItemEventArgs that contains the event data.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.OnKeyDown Method

ShapeListBox.OnKeyDown Method

Control.OnKeyDown override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

protected virtual void OnKeyDown (
KeyEventArgs e
)
Visual Basic

Protected Overridable Sub OnKeyDown ( _
e As KeyEventArgs _
)

Parameters

e
A KeyEventArgs that contains the event data.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.OnMeasureItem Method

ShapeListBox.OnMeasureItem Method

ListBox.OnMeasureItem override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

protected virtual void OnMeasureItem (
MeasureItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnMeasureItem ( _
e As MeasureItemEventArgs _
)

Parameters

e
A MeasureItemEventArgs that contains the event data.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.OnMouseDown Method

ShapeListBox.OnMouseDown Method

Control.OnMouseDown override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

protected virtual void OnMouseDown (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseDown ( _
e As MouseEventArgs _
)

Parameters

e
A MouseEventArgs that contains the event data.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.OnMouseMove Method

ShapeListBox.OnMouseMove Method

Control.OnMouseMove override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

protected virtual void OnMouseMove (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseMove ( _
e As MouseEventArgs _
)

Parameters

e
A MouseEventArgs that contains the event data.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.OnSelectedIndexChanged Method

ShapeListBox.OnSelectedIndexChanged Method

ListBox.OnSelectedIndexChanged override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

protected virtual void OnSelectedIndexChanged (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnSelectedIndexChanged ( _
e As EventArgs _
)

Parameters

e
An EventArgs that contains the event data.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.OnShapeRemoved Method

ShapeListBox.OnShapeRemoved Method

Raises the ShapeRemoved event.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

protected virtual void OnShapeRemoved (
ShapeEventArgs e
)
Visual Basic

Protected Overridable Sub OnShapeRemoved ( _
e As ShapeEventArgs _
)

Parameters

e
A ShapeEventArgs that contains the event data.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.OnShapeRenamed Method

ShapeListBox.OnShapeRenamed Method

Raises the ShapeRenamed event.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

protected virtual void OnShapeRenamed (
ShapeEventArgs e
)
Visual Basic

Protected Overridable Sub OnShapeRenamed ( _
e As ShapeEventArgs _
)

Parameters

e
A ShapeEventArgs that contains the event data.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.OnShapeSelected Method

ShapeListBox.OnShapeSelected Method

Raises the ShapeSelected event.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

protected virtual void OnShapeSelected (
ShapeEventArgs e
)
Visual Basic

Protected Overridable Sub OnShapeSelected ( _
e As ShapeEventArgs _
)

Parameters

e
A ShapeEventArgs that contains the event data.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.RemoveShapeAt Method

ShapeListBox.RemoveShapeAt Method

Removes the shape at the specified index.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public void RemoveShapeAt (
int i
)
Visual Basic

Public Sub RemoveShapeAt ( _
i As Integer _
)

Parameters

i
An integer value specifying the index of the shape to be removed.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
AddShape Method
InsertShape Method
ClearShapes Method


MindFusion.Diagramming.WinForms.ShapeListBox.SetShapeAt Method

ShapeListBox.SetShapeAt Method

Sets a new shape at the specified position.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public void SetShapeAt (
int index,
Shape shape
)
Visual Basic

Public Sub SetShapeAt ( _
index As Integer, _
shape As Shape _
)

Parameters

index
An integer value specifying the index where the new shape should be placed.
shape
A Shape representing the shape that should be added to the list box.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
GetShapeAt Method
InsertShape Method


MindFusion.Diagramming.WinForms.ShapeListBox.StartInlineEdit Method

ShapeListBox.StartInlineEdit Method

Enters inplace-edit mode, allowing users to edit the label of the selected shape.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public void StartInlineEdit ()
Visual Basic

Public Sub StartInlineEdit ()

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox Properties

ShapeListBox Properties

Public Properties

Name | Description
AllowRemove | Gets or sets a value indicating whether users are allowed to remove list box items by pressing DEL. DiagrammingProProductName
AllowRename | Gets or sets a value indicating whether users are allowed to rename the list box items by pressing F2.
DefaultNodeSize | Gets or sets the size of the shapes that are created by dragging list box items to the diagram.
DrawMode | ListBox.DrawMode override.
IconMargin | Gets or sets the horizontal and vertical margins left around the shape icons.
IconSize | Gets or sets the size of the shape icons.
ShapeCount | Gets the number of shapes in the list box.
ShapeFillColor | Gets or sets the fill color of the shapes icons.
ShapeFilter | Gets or sets the ids of shapes that should be displayed in the listbox.
Shapes | Gets or sets the shapes displayed in the list box.

See Also

ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.AllowRemove Property

ShapeListBox.AllowRemove Property

Gets or sets a value indicating whether users are allowed to remove list box items by pressing DEL.

DiagrammingProProductName

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public bool AllowRemove { get; set; }
Visual Basic

Public Property AllowRemove As Boolean

Property Value

true to allow users remove items; otherwise, false. The default is false.

Remarks

The ShapeRemoved event is raised when the user removes a shape. Removing an item from the list box does not delete the corresponding Shape object from the MindFusion.Diagramming list of shapes.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.AllowRename Property

ShapeListBox.AllowRename Property

Gets or sets a value indicating whether users are allowed to rename the list box items by pressing F2.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public bool AllowRename { get; set; }
Visual Basic

Public Property AllowRename As Boolean

Property Value

true to allow users rename items; otherwise, false. The default is false.

Remarks

The ShapeRenamed event is raised when a user renames a shape. Renaming an item in the list box does actually change the DisplayName of the corresponding Shape object.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.DefaultNodeSize Property

ShapeListBox.DefaultNodeSize Property

Gets or sets the size of the shapes that are created by dragging list box items to the diagram.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public SizeF DefaultNodeSize { get; set; }
Visual Basic

Public Property DefaultNodeSize As SizeF

Property Value

An instance of the .NET SizeF structure. The default is 20x20.

Remarks

You must enable the DiagramView.AllowDrop property in order to let users create shapes by drag-and-drop from the list box.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.DrawMode Property

ShapeListBox.DrawMode Property

ListBox.DrawMode override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public override DrawMode DrawMode { get; set; }
Visual Basic

Public Overrides Property DrawMode As DrawMode

Property Value

A member of the .NET DrawMode enumeration.

Remarks

This property is overridden. Get is unchanged, set is ignored. Its value is always DrawMode.OwnerDrawVariable.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.IconMargin Property

ShapeListBox.IconMargin Property

Gets or sets the horizontal and vertical margins left around the shape icons.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public Size IconMargin { get; set; }
Visual Basic

Public Property IconMargin As Size

Property Value

An instance of the .NET Size structure. The default is 5x5.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
IconSize Property


MindFusion.Diagramming.WinForms.ShapeListBox.IconSize Property

ShapeListBox.IconSize Property

Gets or sets the size of the shape icons.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public Size IconSize { get; set; }
Visual Basic

Public Property IconSize As Size

Property Value

An instance of the .NET Size structure. The default is 48x32.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
IconMargin Property


MindFusion.Diagramming.WinForms.ShapeListBox.ShapeCount Property

ShapeListBox.ShapeCount Property

Gets the number of shapes in the list box.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public int ShapeCount { get; }
Visual Basic

Public ReadOnly Property ShapeCount As Integer

Property Value

An integer value representing the number of shapes currently in the list box.

Remarks

If a ShapeFilter is applied, only the non-filtered items will be counted.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
Shapes Property


MindFusion.Diagramming.WinForms.ShapeListBox.ShapeFillColor Property

ShapeListBox.ShapeFillColor Property

Gets or sets the fill color of the shapes icons.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public Color ShapeFillColor { get; set; }
Visual Basic

Public Property ShapeFillColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.Cyan.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.ShapeFilter Property

ShapeListBox.ShapeFilter Property

Gets or sets the ids of shapes that should be displayed in the listbox.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public string[] ShapeFilter { get; set; }
Visual Basic

Public Property ShapeFilter As String()

Property Value

An array containing the identifiers of shapes that should be displayed in the list box. The default is null (Nothing in Visual Basic).

Remarks

By default, the list box displays all available shapes. This property lets you display a subset of all shapes by listing the identifiers of the Shape objects that must be included in the subset. You might want to apply a filter also after loading a ShapeLibrary.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
Shapes Property


MindFusion.Diagramming.WinForms.ShapeListBox.Shapes Property

ShapeListBox.Shapes Property

Gets or sets the shapes displayed in the list box.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public Shape[] Shapes { get; set; }
Visual Basic

Public Property Shapes As Shape()

Property Value

An array of Shape objects representing the shapes displayed in this list box.

Example

This following example loads a shape library created with the ShapeDesigner tool and assigns the shapes to the ShapeListBox:

C#

ShapeLibrary lib = ShapeLibrary.LoadFrom("shapeLib.shl");
shapeList.Shapes = lib.Shapes;
Visual Basic

Dim library As ShapeLibrary = ShapeLibrary.LoadFrom("shapeLib.shl")
shapeList.Shapes = library.Shapes

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace
ShapeFilter Property


MindFusion.Diagramming.WinForms.ShapeListBox Events

ShapeListBox Events

Public Events

Name | Description
ShapeRemoved | Raised when the user removes a shape from the list box.
ShapeRenamed | Raised when the user renames a shape in the list box.
ShapeSelected | Raised when the user selects a shape in the list box.

See Also

ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.ShapeRemoved Event

ShapeListBox.ShapeRemoved Event

Raised when the user removes a shape from the list box.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public event ShapeEventHandler ShapeRemoved
Visual Basic

Public Event ShapeRemoved As ShapeEventHandler

Event Data

ShapeRemoved event handlers receive an argument of type ShapeEventArgs. The following ShapeEventArgs members provide information relevant to the event.

Member name | Description
Shape | Refers to a Shape instance that represents the removed shape.
Index | Indicates the shape position within the Items collection of the list box.

Remarks

Users can remove list box items by pressing DEL. To enable this, set the AllowRemove property to true. Removing an item from the list box does not delete the corresponding Shape object from the MindFusion.Diagramming list of shapes.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.ShapeRenamed Event

ShapeListBox.ShapeRenamed Event

Raised when the user renames a shape in the list box.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public event ShapeEventHandler ShapeRenamed
Visual Basic

Public Event ShapeRenamed As ShapeEventHandler

Event Data

ShapeRenamed event handlers receive an argument of type ShapeEventArgs. The following ShapeEventArgs members provide information relevant to the event.

Member name | Description
Shape | Refers to a Shape instance that represents the renamed shape.
Index | Indicates the shape position within the Items collection of the list box.
OldName | Indicates the old DisplayName of the renamed shape.

Remarks

Users can rename list box items by pressing F2. To enable this, set the AllowRename property to true.

Renaming an item in the list box does actually change the DisplayName property of the corresponding Shape. At the moment when the event is raised, that property already contains the value entered by the user. Its old value is accessible through the OldName event argument.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeListBox.ShapeSelected Event

ShapeListBox.ShapeSelected Event

Raised when the user selects a shape in the list box.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeListBox

Syntax

C#

public event ShapeEventHandler ShapeSelected
Visual Basic

Public Event ShapeSelected As ShapeEventHandler

Event Data

ShapeSelected event handlers receive an argument of type ShapeEventArgs. The following ShapeEventArgs members provide information relevant to the event.

Member name | Description
Shape | Refers to a Shape instance that represents the selected shape.
Index | Indicates the shape position within the Items collection of the list box.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar Class

ShapeToolBar Class
Remarks See Also

The ShapeToolBar control displays image buttons representing selected shapes defined via the Shape class. These buttons can be used to create new shape nodes that have a specific shape or to change the shape of existing nodes.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public class ShapeToolBar : ToolBar
Visual Basic

Public Class ShapeToolBar
Inherits ToolBar

Remarks

In order to use the ShapeToolBar control, customize the Visual Studio toolbox and add a reference to MindFusion.Diagramming.WinForms.ShapeToolBar.dll.

Optionally, specify the list of shapes to display in the toolbar by assigning their string identifiers to the Shapes property. If Shapes is not set, or if it's an empty array, all available shapes are displayed in the toolbar. After changing Shapes or changing a Shape definition, you might have to call RecreateImages.

A shape can be dragged to the diagram canvas to create a new ShapeNode having that shape. To enable that, set the toolbar's AllowDrag and the DiagramView's AllowDrop properties to true.

Handle the ShapeClicked event to perform some action when the user clicks a shape button. For example, you could create a new ShapeNode, change the shape of selected nodes or change the Diagram's DefaultShape.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ToolBar
MindFusion.Diagramming.WinForms.ShapeToolBar

See Also

ShapeToolBar Members
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar Members

ShapeToolBar Members
Constructors Properties Methods Events

The ShapeToolBar control displays image buttons representing selected shapes defined via the Shape class. These buttons can be used to create new shape nodes that have a specific shape or to change the shape of existing nodes.

The following tables list the members exposed by the ShapeToolBar type.

Public Constructors

Name | Description
ShapeToolBar | Initializes a new instance of the ShapeToolBar class.

Public Properties

Name | Description
AllowDrag | Gets or sets a value indicating whether dragging shapes from the toolbar to a DiagramView is enabled.
ButtonImageSize | Gets or sets the size of the icon images displayed inside toolbar buttons.
Buttons | Gets a list of all buttons in the toolbar.
DefaultNodeSize | Gets or sets the size of nodes created by dragging shapes from the toolbar to the diagram canvas.
SelectedShape | Gets the Shape currently selected in the toolbar.
ShapeFillColor | Gets or sets the color of toolbar button icons.
Shapes | Gets or sets the identifiers of all shapes available in the toolbar.
ShowImages | Gets or sets a value indicating whether to display shape icons in the toolbar buttons.
ShowText | Gets or sets a value indicating whether to show the DisplayName of the shapes as toolbar button titles.

Public Methods

Name | Description
RecreateImages | Recreates the toolbar button images.

Protected Methods

Name | Description
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.

Public Events

Name | Description
DrawNode | Raised to perform custom drawing on a toolbar's shape image.
ShapeClicked | Raised when the user clicks a shape button.

See Also

ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar Constructor

ShapeToolBar Constructor

Initializes a new instance of the ShapeToolBar class.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public ShapeToolBar ()
Visual Basic

Public Sub New ()

See Also

ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar Methods

ShapeToolBar Methods

Public Methods

Name | Description
RecreateImages | Recreates the toolbar button images.

Protected Methods

Name | Description
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.

See Also

ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.OnMouseDown Method

ShapeToolBar.OnMouseDown Method

Control.OnMouseDown override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

protected virtual void OnMouseDown (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseDown ( _
e As MouseEventArgs _
)

Parameters

e
A MouseEventArgs that contains the event data.

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.OnMouseMove Method

ShapeToolBar.OnMouseMove Method

Control.OnMouseMove override.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

protected virtual void OnMouseMove (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseMove ( _
e As MouseEventArgs _
)

Parameters

e
A MouseEventArgs that contains the event data.

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.RecreateImages Method

ShapeToolBar.RecreateImages Method

Recreates the toolbar button images.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public void RecreateImages ()
Visual Basic

Public Sub RecreateImages ()

Remarks

You might have to call this method after changing the Shapes collection or changing a Shape definition.

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar Properties

ShapeToolBar Properties

Public Properties

Name | Description
AllowDrag | Gets or sets a value indicating whether dragging shapes from the toolbar to a DiagramView is enabled.
ButtonImageSize | Gets or sets the size of the icon images displayed inside toolbar buttons.
Buttons | Gets a list of all buttons in the toolbar.
DefaultNodeSize | Gets or sets the size of nodes created by dragging shapes from the toolbar to the diagram canvas.
SelectedShape | Gets the Shape currently selected in the toolbar.
ShapeFillColor | Gets or sets the color of toolbar button icons.
Shapes | Gets or sets the identifiers of all shapes available in the toolbar.
ShowImages | Gets or sets a value indicating whether to display shape icons in the toolbar buttons.
ShowText | Gets or sets a value indicating whether to show the DisplayName of the shapes as toolbar button titles.

See Also

ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.AllowDrag Property

ShapeToolBar.AllowDrag Property

Gets or sets a value indicating whether dragging shapes from the toolbar to a DiagramView is enabled.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public bool AllowDrag { get; set; }
Visual Basic

Public Property AllowDrag As Boolean

Property Value

true to allow dragging shapes, otherwise false. The default is false.

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.ButtonImageSize Property

ShapeToolBar.ButtonImageSize Property

Gets or sets the size of the icon images displayed inside toolbar buttons.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public Size ButtonImageSize { get; set; }
Visual Basic

Public Property ButtonImageSize As Size

Property Value

A .NET Size instance specifying the size of button icons. The default is 16x16.

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.Buttons Property

ShapeToolBar.Buttons Property

Gets a list of all buttons in the toolbar.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public ToolBar.ToolBarButtonCollection Buttons { get; }
Visual Basic

Public ReadOnly Property Buttons As ToolBar.ToolBarButtonCollection

Property Value

An instance of the .NET ToolBarButtonCollection class.

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.DefaultNodeSize Property

ShapeToolBar.DefaultNodeSize Property

Gets or sets the size of nodes created by dragging shapes from the toolbar to the diagram canvas.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public SizeF DefaultNodeSize { get; set; }
Visual Basic

Public Property DefaultNodeSize As SizeF

Property Value

A .NET SizeF instance specifying the size of nodes. The default is 20x20.

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.SelectedShape Property

ShapeToolBar.SelectedShape Property

Gets the Shape currently selected in the toolbar.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public Shape SelectedShape { get; }
Visual Basic

Public ReadOnly Property SelectedShape As Shape

Property Value

An instance of the Shape class representing the currently selected button in the toolbar.

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.ShapeFillColor Property

ShapeToolBar.ShapeFillColor Property

Gets or sets the color of toolbar button icons.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public Color ShapeFillColor { get; set; }
Visual Basic

Public Property ShapeFillColor As Color

Property Value

An instance of the .NET Color class specifying icons' fill color. The default is Color.FromArgb(150, 180, 210).

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.Shapes Property

ShapeToolBar.Shapes Property

Gets or sets the identifiers of all shapes available in the toolbar.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public string[] Shapes { get; set; }
Visual Basic

Public Property Shapes As String()

Property Value

An array of string identifiers. The default value is null (Nothing in Visual Basic).

Remarks

The shape identifiers should be the same ones used with Shape objects. The 87 stock shapes and their identifiers are listed in the table of predefined shapes here. If there are not any shapes assigned to this property, the toolbar displays all available shapes.

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.ShowImages Property

ShapeToolBar.ShowImages Property

Gets or sets a value indicating whether to display shape icons in the toolbar buttons.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public bool ShowImages { get; set; }
Visual Basic

Public Property ShowImages As Boolean

Property Value

true to display shape images; otherwise, false. The default is true.

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.ShowText Property

ShapeToolBar.ShowText Property

Gets or sets a value indicating whether to show the DisplayName of the shapes as toolbar button titles.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public bool ShowText { get; set; }
Visual Basic

Public Property ShowText As Boolean

Property Value

true to show the DisplayName of the shapes; otherwise, false. The default is false.

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar Events

ShapeToolBar Events

Public Events

Name | Description
DrawNode | Raised to perform custom drawing on a toolbar's shape image.
ShapeClicked | Raised when the user clicks a shape button.

See Also

ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.DrawNode Event

ShapeToolBar.DrawNode Event

Raised to perform custom drawing on a toolbar's shape image.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public event DrawNodeEventHandler DrawNode
Visual Basic

Public Event DrawNode As DrawNodeEventHandler

Event Data

DrawNode event handlers receive an argument of type DrawNodeEventArgs. The following DrawNodeEventArgs members provide information relevant to the event:

Member name | Description
Node | A node used to draw a toolbar button image.
Graphics | A Graphics object used to draw the button image.
Bounds | The bounding rectangle of the node to draw.

Remarks

The toolbar creates an image for each Shape or for the shapes defined in Shapes. A shape image is generated dynamically by creating a ShapeNode of that shape and drawing it in a bitmap. The toolbar treats the node as custom drawn one of type Additional and raises the DrawNode event after the standard shape drawing is performed.

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.ShapeToolBar.ShapeClicked Event

ShapeToolBar.ShapeClicked Event

Raised when the user clicks a shape button.

Namespace: MindFusion.Diagramming.WinForms
Assembly: MindFusion.Diagramming.WinForms.ShapeToolBar

Syntax

C#

public event ShapeEventHandler ShapeClicked
Visual Basic

Public Event ShapeClicked As ShapeEventHandler

Event Data

ShapeClicked event handlers receive an argument of type ShapeEventArgs. The following ShapeEventArgs members provide information relevant to the event:

Member name | Description
Shape | A Shape instance corresponding to the clicked button.

See Also

ShapeToolBar Members
ShapeToolBar Class
MindFusion.Diagramming.WinForms Namespace


MindFusion.Diagramming.WinForms.Behaviors Namespace
Classes

Classes

Class | Description
BehaviorBase | An abstract base class for classes that define how MindFusion.Diagramming reacts to users' actions with a mouse or other pointing devices.
CustomTypesBehavior | This class is used when the diagram behavior is set to Behavior.Custom.
DrawContainersBehavior | This class is used when the diagram behavior is set to Behavior.DrawContainers.
DrawControlsBehavior | This class is used when the diagram behavior is set to Behavior.DrawControls.
DrawLinksBehavior | This class is used when the diagram behavior is set to Behavior.DrawLinks.
DrawNodesBehavior | This class is the base for node-drawing behavior classes.
DrawShapesBehavior | This class is used when the diagram behavior is set to Behavior.DrawShapes.
DrawTablesBehavior | This class is used when the diagram behavior is set to Behavior.DrawTables.
LinkContainersBehavior | This class is used when the diagram behavior is set to Behavior.LinkContainers.
LinkControlsBehavior | This class is used when the diagram behavior is set to Behavior.LinkControls.
LinkNodesBehavior | Declares a base class for all node-link behaviors, such as LinkShapesBehavior, LinkTablesBehavior, and so on.
LinkShapesBehavior | This class is used when the diagram behavior is set to Behavior.LinkShapes.
LinkTablesBehavior | This class is used when the diagram behavior is set to Behavior.LinkTables.
ModifyBehavior | This class is used when the diagram behavior is set to Behavior.Modify.


MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase Class

BehaviorBase Class
Remarks See Also

An abstract base class for classes that define how MindFusion.Diagramming reacts to users' actions with a mouse or other pointing devices.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public abstract class BehaviorBase
Visual Basic

Public MustInherit Class BehaviorBase

Remarks

MindFusion.Diagramming comes with several predefined Behavior classes that can be selected by the Behavior property of the Diagram class. Custom behavior objects can be assigned to the CustomBehavior property.

To define a custom behavior class, implement the StartDraw method which specifies how the control responds when a user starts to draw with the mouse. Implement the GetTargetNode method to let users draw connections between nodes. The SetMouseCursor method is called while the mouse moves to let you set a custom mouse cursor depending on the current mouse location.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.DrawLinksBehavior
MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.ModifyBehavior

See Also

BehaviorBase Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase Members

BehaviorBase Members
Constructors Properties Methods

An abstract base class for classes that define how MindFusion.Diagramming reacts to users' actions with a mouse or other pointing devices.

The following tables list the members exposed by the BehaviorBase type.

Protected Constructors

Name | Description
BehaviorBase | Initializes a new instance of the BehaviorBase class.

ProtectedProperties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with.
DiagramView | Gets a reference to the DiagramView control this Behavior is associated with.

Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let your application set the mouse cursor.
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior.
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state.

See Also

BehaviorBase Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase Constructor

BehaviorBase Constructor

Initializes a new instance of the BehaviorBase class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected BehaviorBase (
DiagramView diagramView
)
Visual Basic

Protected Sub BehaviorBase ( _
diagramView As DiagramView _
)

Parameters

diagramView

The DiagramView this behavior will be associated with.

See Also

BehaviorBase Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase Methods

BehaviorBase Methods

Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let your application set the mouse cursor.
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior.
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state.

See Also

BehaviorBase Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase.CreateLink Method

BehaviorBase.CreateLink Method

Creates a link of the type appropriate for the current behavior.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual DiagramLink CreateLink ()
Visual Basic

Protected Overridable Function CreateLink () As DiagramLink

Return Value

An instance of the DiagramLink class.

Remarks

Override this method to specify the type of DiagramLink, which is most appropriate for your diagram. The link is created every time the user connects two DiagramNode objects.

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase.SetModfCursor Method

BehaviorBase.SetModfCursor Method

Updates the current cursor according to the specified cursor position and diagram state.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected CursorHint SetModfCursor (
PointF pt,
int handle,
bool active,
bool autoh
)
Visual Basic

Protected Function SetModfCursor ( _
pt As PointF, _
handle As Integer, _
active As Boolean, _
autoh As Boolean _
) As CursorHint

Parameters

pt
A PointF structure that specifies the current mouse position.
handle
The index of the adjustment handle, at which the mouse points.
active
Specifies whether the mouse is over the ActiveItem.
autoh
true when the mouse is over a DiagramItem and the ModificationStart property of the DiagramView is set to AutoHandles.

Return Value

A member of the CursorHint enumeration.

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase.SetMouseCursor Method

BehaviorBase.SetMouseCursor Method

Invoked while the mouse is moved to let your application set the mouse cursor.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public abstract CursorHint SetMouseCursor (
PointF point,
ref bool startInteraction
)
Visual Basic

Public MustOverride Function SetMouseCursor ( _
point As PointF, _
ByRef startInteraction As Boolean _
) As CursorHint

Parameters

point
A PointF structure that specifies the position of the mouse cursor.
startInteraction
true if the user is going to create, delete, modify or select a DiagramItem; false if mouse behavior is not considered; in this case the mouse pointer is set to a default cursor according to the background LaneGrid.

Return Value

A member of the CursorHint enumeration.

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase.StartDraw Method

BehaviorBase.StartDraw Method

Invoked when a user presses the left mouse button inside the diagram drawing area.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public abstract InteractionState StartDraw (
PointF point
)
Visual Basic

Public MustOverride Function StartDraw ( _
point As PointF _
) As InteractionState

Parameters

point
A PointF structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class, which specifies whether dragging the mouse should create or modify an item.

Remarks

To start creating an item, pass a new instance of a DiagramItem derived class to the InteractionState constructor and set the constructor's action argument to Action.Create. Do not use methods such as Nodes.Add or CreateShapeNode to add the new item to the diagram; the item will be added automatically when the user completes drawing it. If creating a link, use the DiagramLink constructor that takes a single DiagramNode argument, specifying the origin node.

To start modifying an item, provide a reference to an existing item as argument of the InteractionState constructor and set the action argument to Action.Modify.

Example

This StartDraw implementation allows only moving existing nodes or creating new nodes using the mouse:

C#

public override InteractionState StartDraw(PointF point)
{
DiagramNode node = Diagram.GetNodeAt(point, true, false);
if (node != null)
return new InteractionState(node, 8, Action.Modify);
else
return new InteractionState(new ShapeNode(Diagram), -1, Action.Create);
}
Visual Basic

Public Overrides Function StartDraw(ByVal point As PointF) As InteractionState

Dim node As DiagramNode = Diagram.GetNodeAt(point, True, False)

If Not node Is Nothing Then
Return New InteractionState(node, 8, Action.Modify)
Else
Return New InteractionState(New ShapeNode(Diagram), -1, Action.Create)
End If

End Function

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase Properties

BehaviorBase Properties

ProtectedProperties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with.
DiagramView | Gets a reference to the DiagramView control this Behavior is associated with.

See Also

BehaviorBase Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase.Diagram Property

BehaviorBase.Diagram Property

Gets a reference to the Diagram instance this behavior is associated with.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected Diagram Diagram { get; }
Visual Basic

Protected ReadOnly Property Diagram As Diagram

Property Value

An instance of the Diagram class that represents the component, this Behavior is associated with.

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase.DiagramView Property

BehaviorBase.DiagramView Property

Gets a reference to the DiagramView control this Behavior is associated with.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected DiagramView DiagramView { get; }
Visual Basic

Protected ReadOnly Property DiagramView As DiagramView

Property Value

An instance of the DiagramView class, with which this Behavior is associated.

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.CustomTypesBehavior Class

CustomTypesBehavior Class

This class is used when the diagram behavior is set to Behavior.Custom.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class CustomTypesBehavior : LinkNodesBehavior
Visual Basic

Public Class CustomTypesBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.CustomTypesBehavior

See Also

CustomTypesBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.CustomTypesBehavior Members

CustomTypesBehavior Members
Constructors Methods

This class is used when the diagram behavior is set to Behavior.Custom.

The following tables list the members exposed by the CustomTypesBehavior type.

Protected Constructors

Name | Description
CustomTypesBehavior | Initializes a new instance of the CustomTypesBehavior class.

Protected Methods

Name | Description
CreateLink | BehaviorBase.CreateLink override.
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

CustomTypesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.CustomTypesBehavior Constructor

CustomTypesBehavior Constructor

Initializes a new instance of the CustomTypesBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected CustomTypesBehavior (
DiagramView diagramView
)
Visual Basic

Protected Sub CustomTypesBehavior ( _
diagramView As DiagramView _
)

Parameters

diagramView

The DiagramView this behavior will be associated with.

See Also

CustomTypesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.CustomTypesBehavior Methods

CustomTypesBehavior Methods

Protected Methods

Name | Description
CreateLink | BehaviorBase.CreateLink override.
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

CustomTypesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.CustomTypesBehavior.CreateLink Method

CustomTypesBehavior.CreateLink Method

BehaviorBase.CreateLink override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual DiagramLink CreateLink ()
Visual Basic

Protected Overridable Function CreateLink () As DiagramLink

Return Value

An instance of the DiagramLink class.

See Also

CustomTypesBehavior Members
CustomTypesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.CustomTypesBehavior.CreateNode Method

CustomTypesBehavior.CreateNode Method

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual DiagramNode CreateNode ()
Visual Basic

Protected Overridable Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

CustomTypesBehavior Members
CustomTypesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawContainersBehavior Class

DrawContainersBehavior Class

This class is used when the diagram behavior is set to Behavior.DrawContainers.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class DrawContainersBehavior : DrawNodesBehavior
Visual Basic

Public Class DrawContainersBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.DrawContainersBehavior

See Also

DrawContainersBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawContainersBehavior Members

DrawContainersBehavior Members
Constructors Methods

This class is used when the diagram behavior is set to Behavior.DrawContainers.

The following tables list the members exposed by the DrawContainersBehavior type.

Protected Constructors

Name | Description
DrawContainersBehavior | Initializes a new instance of the DrawContainersBehavior class.

Protected Methods

Name | Description
CreateNode | DrawNodesBehavior.CreateNode override.

See Also

DrawContainersBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawContainersBehavior Constructor

DrawContainersBehavior Constructor

Initializes a new instance of the DrawContainersBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected DrawContainersBehavior (
DiagramView diagramView
)
Visual Basic

Protected Sub DrawContainersBehavior ( _
diagramView As DiagramView _
)

Parameters

diagramView
The DiagramView this behavior will be associated with.

See Also

DrawContainersBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawContainersBehavior Methods

DrawContainersBehavior Methods

Protected Methods

Name | Description
CreateNode | DrawNodesBehavior.CreateNode override.

See Also

DrawContainersBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawContainersBehavior.CreateNode Method

DrawContainersBehavior.CreateNode Method

DrawNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual DiagramNode CreateNode ()
Visual Basic

Protected Overridable Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawContainersBehavior Members
DrawContainersBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawControlsBehavior Class

DrawControlsBehavior Class

This class is used when the diagram behavior is set to Behavior.DrawControls.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class DrawControlsBehavior : DrawNodesBehavior
Visual Basic

Public Class DrawControlsBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.DrawControlsBehavior

See Also

DrawControlsBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawControlsBehavior Members

DrawControlsBehavior Members
Constructors Methods

This class is used when the diagram behavior is set to Behavior.DrawControls.

The following tables list the members exposed by the DrawControlsBehavior type.

Protected Constructors

Name | Description
DrawControlsBehavior | Initializes a new instance of the DrawControlsBehavior class.

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

DrawControlsBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawControlsBehavior Constructor

DrawControlsBehavior Constructor

Initializes a new instance of the DrawControlsBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected DrawControlsBehavior (
DiagramView diagramView
)
Visual Basic

Protected Sub DrawControlsBehavior ( _
diagramView As DiagramView _
)

Parameters

diagramView

The DiagramView this behavior will be associated with.

See Also

DrawControlsBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawControlsBehavior Methods

DrawControlsBehavior Methods

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

DrawControlsBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawControlsBehavior.CreateNode Method

DrawControlsBehavior.CreateNode Method

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual DiagramNode CreateNode ()
Visual Basic

Protected Overridable Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawControlsBehavior Members
DrawControlsBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawLinksBehavior Class

DrawLinksBehavior Class

This class is used when the diagram behavior is set to Behavior.DrawLinks.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class DrawLinksBehavior : BehaviorBase
Visual Basic

Public Class DrawLinksBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.DrawLinksBehavior

See Also

DrawLinksBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawLinksBehavior Members

DrawLinksBehavior Members
Constructors Methods

This class is used when the diagram behavior is set to Behavior.DrawLinks.

The following tables list the members exposed by the DrawLinksBehavior type.

Protected Constructors

Name | Description
DrawLinksBehavior | Initializes a new instance of the DrawLinksBehavior class.

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

See Also

DrawLinksBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawLinksBehavior Constructor

DrawLinksBehavior Constructor

Initializes a new instance of the DrawLinksBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected DrawLinksBehavior (
DiagramView diagramView
)
Visual Basic

Protected Sub DrawLinksBehavior ( _
diagramView As DiagramView _
)

Parameters

diagramView

The DiagramView this behavior will be associated with.

See Also

DrawLinksBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawLinksBehavior Methods

DrawLinksBehavior Methods

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

See Also

DrawLinksBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawLinksBehavior.SetMouseCursor Method

DrawLinksBehavior.SetMouseCursor Method

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public override CursorHint SetMouseCursor (
PointF point,
ref bool startInteraction
)
Visual Basic

Public Overrides Function SetMouseCursor ( _
point As PointF, _
ByRef startInteraction As Boolean _
) As CursorHint

Parameters

point
A PointF structure that specifies the position of the mouse cursor.
startInteraction
true if the user is going to create, delete, modify or select a DiagramItem; false if mouse behavior is not considered; in this case the mouse pointer is set to a default cursor according to the background LaneGrid.

Return Value

A member of the CursorHint enumeration.

See Also

DrawLinksBehavior Members
DrawLinksBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawLinksBehavior.StartDraw Method

DrawLinksBehavior.StartDraw Method

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public override InteractionState StartDraw (
PointF point
)
Visual Basic

Public Overrides Function StartDraw ( _
point As PointF _
) As InteractionState

Parameters

point
A PointF structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

DrawLinksBehavior Members
DrawLinksBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior Class

DrawNodesBehavior Class

This class is the base for node-drawing behavior classes.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public abstract class DrawNodesBehavior : BehaviorBase
Visual Basic

Public MustInherit Class DrawNodesBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.DrawContainersBehavior
MindFusion.Diagramming.WinForms.Behaviors.DrawControlsBehavior
MindFusion.Diagramming.WinForms.Behaviors.DrawShapesBehavior
MindFusion.Diagramming.WinForms.Behaviors.DrawTablesBehavior

See Also

DrawNodesBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior Members

DrawNodesBehavior Members
Constructors Methods

This class is the base for node-drawing behavior classes.

The following tables list the members exposed by the DrawNodesBehavior type.

Protected Constructors

Name | Description
DrawNodesBehavior | Initializes a new instance of the DrawNodesBehavior class.

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateNode | Creates a node of the type appropriate for the current behavior.

See Also

DrawNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior Constructor

DrawNodesBehavior Constructor

Initializes a new instance of the DrawNodesBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected DrawNodesBehavior (
DiagramView diagramView
)
Visual Basic

Protected Sub DrawNodesBehavior ( _
diagramView As DiagramView _
)

Parameters

diagramView

The DiagramView this behavior will be associated with.

See Also

DrawNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior Methods

DrawNodesBehavior Methods

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateNode | Creates a node of the type appropriate for the current behavior.

See Also

DrawNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior.CreateNode Method

DrawNodesBehavior.CreateNode Method

Creates a node of the type appropriate for the current behavior.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected abstract DiagramNode CreateNode ()
Visual Basic

Protected MustOverride Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawNodesBehavior Members
DrawNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior.SetMouseCursor Method

DrawNodesBehavior.SetMouseCursor Method

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public override CursorHint SetMouseCursor (
PointF point,
ref bool startInteraction
)
Visual Basic

Public Overrides Function SetMouseCursor ( _
point As PointF, _
ByRef startInteraction As Boolean _
) As CursorHint

Parameters

point

A PointF structure that specifies the position of the mouse cursor.

startInteraction
true if the user is going to create, delete, modify or select a DiagramItem; false if mouse behavior is not considered; in this case the mouse pointer is set to a default cursor according to the background LaneGrid.

Return Value

A member of the CursorHint enumeration.

See Also

DrawNodesBehavior Members
DrawNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior.StartDraw Method

DrawNodesBehavior.StartDraw Method

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public override InteractionState StartDraw (
PointF point
)
Visual Basic

Public Overrides Function StartDraw ( _
point As PointF _
) As InteractionState

Parameters

point
A PointF structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

DrawNodesBehavior Members
DrawNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawShapesBehavior Class

DrawShapesBehavior Class

This class is used when the diagram behavior is set to Behavior.DrawShapes.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class DrawShapesBehavior : DrawNodesBehavior
Visual Basic

Public Class DrawShapesBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.DrawShapesBehavior

See Also

DrawShapesBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawShapesBehavior Members

DrawShapesBehavior Members
Constructors Methods

This class is used when the diagram behavior is set to Behavior.DrawShapes.

The following tables list the members exposed by the DrawShapesBehavior type.

Protected Constructors

Name | Description
DrawShapesBehavior | Initializes a new instance of the DrawShapesBehavior class.

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

DrawShapesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawShapesBehavior Constructor

DrawShapesBehavior Constructor

Initializes a new instance of the DrawShapesBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected DrawShapesBehavior (
DiagramView diagramView
)
Visual Basic

Protected Sub DrawShapesBehavior ( _
diagramView As DiagramView _
)

Parameters

diagramView
The DiagramView this behavior will be associated with.

See Also

DrawShapesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawShapesBehavior Methods

DrawShapesBehavior Methods

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

DrawShapesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawShapesBehavior.CreateNode Method

DrawShapesBehavior.CreateNode Method

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual DiagramNode CreateNode ()
Visual Basic

Protected Overridable Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawShapesBehavior Members
DrawShapesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawTablesBehavior Class

DrawTablesBehavior Class

This class is used when the diagram behavior is set to Behavior.DrawTables.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class DrawTablesBehavior : DrawNodesBehavior
Visual Basic

Public Class DrawTablesBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.DrawTablesBehavior

See Also

DrawTablesBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawTablesBehavior Members

DrawTablesBehavior Members
Constructors Methods

This class is used when the diagram behavior is set to Behavior.DrawTables.

The following tables list the members exposed by the DrawTablesBehavior type.

Protected Constructors

Name | Description
DrawTablesBehavior | Initializes a new instance of the DrawTablesBehavior class.

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

DrawTablesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawTablesBehavior Constructor

DrawTablesBehavior Constructor

Initializes a new instance of the DrawTablesBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected DrawTablesBehavior (
DiagramView diagramView
)
Visual Basic

Protected Sub DrawTablesBehavior ( _
diagramView As DiagramView _
)

Parameters

diagramView
The DiagramView this behavior will be associated with.

See Also

DrawTablesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawTablesBehavior Methods

DrawTablesBehavior Methods

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

DrawTablesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.DrawTablesBehavior.CreateNode Method

DrawTablesBehavior.CreateNode Method

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual DiagramNode CreateNode ()
Visual Basic

Protected Overridable Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawTablesBehavior Members
DrawTablesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkContainersBehavior Class

LinkContainersBehavior Class

This class is used when the diagram behavior is set to Behavior.LinkContainers.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class LinkContainersBehavior : LinkNodesBehavior
Visual Basic

Public Class LinkContainersBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.LinkContainersBehavior

See Also

LinkContainersBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkContainersBehavior Members

LinkContainersBehavior Members
Constructors Methods

This class is used when the diagram behavior is set to Behavior.LinkContainers.

The following tables list the members exposed by the LinkContainersBehavior type.

Protected Constructors

Name | Description
LinkContainersBehavior | Initializes a new instance of the LinkContainersBehavior class.

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

LinkContainersBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkContainersBehavior Constructor

LinkContainersBehavior Constructor

Initializes a new instance of the LinkContainersBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected LinkContainersBehavior (
DiagramView diagramView
)
Visual Basic

Protected Sub LinkContainersBehavior ( _
diagramView As DiagramView _
)

Parameters

diagramView
The DiagramView this behavior will be associated with.

See Also

LinkContainersBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkContainersBehavior Methods

LinkContainersBehavior Methods

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

LinkContainersBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkContainersBehavior.CreateNode Method

LinkContainersBehavior.CreateNode Method

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual DiagramNode CreateNode ()
Visual Basic

Protected Overridable Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

LinkContainersBehavior Members
LinkContainersBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkControlsBehavior Class

LinkControlsBehavior Class

This class is used when the diagram behavior is set to Behavior.LinkControls.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class LinkControlsBehavior : LinkNodesBehavior
Visual Basic

Public Class LinkControlsBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.LinkControlsBehavior

See Also

LinkControlsBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkControlsBehavior Members

LinkControlsBehavior Members
Constructors Methods

This class is used when the diagram behavior is set to Behavior.LinkControls.

The following tables list the members exposed by the LinkControlsBehavior type.

Protected Constructors

Name | Description
LinkControlsBehavior | Initializes a new instance of the LinkControlsBehavior class.

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

LinkControlsBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkControlsBehavior Constructor

LinkControlsBehavior Constructor

Initializes a new instance of the LinkControlsBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected LinkControlsBehavior (
DiagramView diagramView
)
Visual Basic

Protected Sub LinkControlsBehavior ( _
diagramView As DiagramView _
)

Parameters

diagramView

The DiagramView this behavior will be associated with.

See Also

LinkControlsBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkControlsBehavior Methods

LinkControlsBehavior Methods

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

LinkControlsBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkControlsBehavior.CreateNode Method

LinkControlsBehavior.CreateNode Method

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual DiagramNode CreateNode ()
Visual Basic

Protected Overridable Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

LinkControlsBehavior Members
LinkControlsBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior Class

LinkNodesBehavior Class

Declares a base class for all node-link behaviors, such as LinkShapesBehavior, LinkTablesBehavior, and so on.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public abstract class LinkNodesBehavior : BehaviorBase
Visual Basic

Public MustInherit Class LinkNodesBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.CustomTypesBehavior
MindFusion.Diagramming.WinForms.Behaviors.LinkContainersBehavior
MindFusion.Diagramming.WinForms.Behaviors.LinkControlsBehavior
MindFusion.Diagramming.WinForms.Behaviors.LinkShapesBehavior
MindFusion.Diagramming.WinForms.Behaviors.LinkTablesBehavior

See Also

LinkNodesBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior Members

LinkNodesBehavior Members
Constructors Methods

Declares a base class for all node-link behaviors, such as LinkShapesBehavior, LinkTablesBehavior, and so on.

The following tables list the members exposed by the LinkNodesBehavior type.

Protected Constructors

Name | Description
LinkNodesBehavior | Initializes a new instance of the LinkNodesBehavior class.

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateNode | Creates a node of the type appropriate for the current behavior.

See Also

LinkNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior Constructor

LinkNodesBehavior Constructor

Initializes a new instance of the LinkNodesBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected LinkNodesBehavior (
DiagramView diagramView
)
Visual Basic

Protected Sub LinkNodesBehavior ( _
diagramView As DiagramView _
)

Parameters

diagramView
The DiagramView this behavior will be associated with.

See Also

LinkNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior Methods

LinkNodesBehavior Methods

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateNode | Creates a node of the type appropriate for the current behavior.

See Also

LinkNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior.CreateNode Method

LinkNodesBehavior.CreateNode Method

Creates a node of the type appropriate for the current behavior.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected abstract DiagramNode CreateNode ()
Visual Basic

Protected MustOverride Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

LinkNodesBehavior Members
LinkNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior.SetMouseCursor Method

LinkNodesBehavior.SetMouseCursor Method

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public override CursorHint SetMouseCursor (
PointF point,
ref bool startInteraction
)
Visual Basic

Public Overrides Function SetMouseCursor ( _
point As PointF, _
ByRef startInteraction As Boolean _
) As CursorHint

Parameters

point
A PointF structure that specifies the position of the mouse cursor.
startInteraction
true if the user is going to create, delete, modify or select a DiagramItem; false if mouse behavior is not considered; in this case the mouse pointer is set to a default cursor according to the background LaneGrid.

Return Value

A member of the CursorHint enumeration.

See Also

LinkNodesBehavior Members
LinkNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior.StartDraw Method

LinkNodesBehavior.StartDraw Method

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public override InteractionState StartDraw (
PointF point
)
Visual Basic

Public Overrides Function StartDraw ( _
point As PointF _
) As InteractionState

Parameters

point
A PointF structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

LinkNodesBehavior Members
LinkNodesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkShapesBehavior Class

LinkShapesBehavior Class

This class is used when the diagram behavior is set to Behavior.LinkShapes.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class LinkShapesBehavior : LinkNodesBehavior
Visual Basic

Public Class LinkShapesBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.LinkShapesBehavior

See Also

LinkShapesBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkShapesBehavior Members

LinkShapesBehavior Members
Constructors Methods

This class is used when the diagram behavior is set to Behavior.LinkShapes.

The following tables list the members exposed by the LinkShapesBehavior type.

Protected Constructors

Name | Description
LinkShapesBehavior | Initializes a new instance of the LinkShapesBehavior class.

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

LinkShapesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkShapesBehavior Constructor

LinkShapesBehavior Constructor

Initializes a new instance of the LinkShapesBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected LinkShapesBehavior (
DiagramView diagramView
)
Visual Basic

Protected Sub LinkShapesBehavior ( _
diagramView As DiagramView _
)

Parameters

diagramView
The DiagramView this behavior will be associated with.

See Also

LinkShapesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkShapesBehavior Methods

LinkShapesBehavior Methods

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

LinkShapesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkShapesBehavior.CreateNode Method

LinkShapesBehavior.CreateNode Method

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual DiagramNode CreateNode ()
Visual Basic

Protected Overridable Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

LinkShapesBehavior Members
LinkShapesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkTablesBehavior Class

LinkTablesBehavior Class

This class is used when the diagram behavior is set to Behavior.LinkTables.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class LinkTablesBehavior : LinkNodesBehavior
Visual Basic

Public Class LinkTablesBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.WinForms.Behaviors.LinkTablesBehavior

See Also

LinkTablesBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkTablesBehavior Members

LinkTablesBehavior Members
Constructors Methods

This class is used when the diagram behavior is set to Behavior.LinkTables.

The following tables list the members exposed by the LinkTablesBehavior type.

Protected Constructors

Name | Description
LinkTablesBehavior | Initializes a new instance of the LinkTablesBehavior class.

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

LinkTablesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkTablesBehavior Constructor

LinkTablesBehavior Constructor

Initializes a new instance of the LinkTablesBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected LinkTablesBehavior (
DiagramView diagramView
)
Visual Basic

Protected Sub LinkTablesBehavior ( _
diagramView As DiagramView _
)

Parameters

diagramView
The DiagramView this behavior will be associated with.

See Also

LinkTablesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkTablesBehavior Methods

LinkTablesBehavior Methods

Protected Methods

Name | Description
CreateNode | LinkNodesBehavior.CreateNode override.

See Also

LinkTablesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.LinkTablesBehavior.CreateNode Method

LinkTablesBehavior.CreateNode Method

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected virtual DiagramNode CreateNode ()
Visual Basic

Protected Overridable Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

LinkTablesBehavior Members
LinkTablesBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.ModifyBehavior Class

ModifyBehavior Class

This class is used when the diagram behavior is set to Behavior.Modify.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public class ModifyBehavior : BehaviorBase
Visual Basic

Public Class ModifyBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.WinForms.Behaviors.BehaviorBase
MindFusion.Diagramming.WinForms.Behaviors.ModifyBehavior

See Also

ModifyBehavior Members
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.ModifyBehavior Members

ModifyBehavior Members
Constructors Methods

This class is used when the diagram behavior is set to Behavior.Modify.

The following tables list the members exposed by the ModifyBehavior type.

Protected Constructors

Name | Description
ModifyBehavior | Initializes a new instance of the ModifyBehavior class.

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

See Also

ModifyBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.ModifyBehavior Constructor

ModifyBehavior Constructor

Initializes a new instance of the ModifyBehavior class.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

protected ModifyBehavior (
DiagramView diagramView
)
Visual Basic

Protected Sub ModifyBehavior ( _
diagramView As DiagramView _
)

Parameters

diagramView
The DiagramView this behavior will be associated with.

See Also

ModifyBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.ModifyBehavior Methods

ModifyBehavior Methods

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

See Also

ModifyBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.ModifyBehavior.SetMouseCursor Method

ModifyBehavior.SetMouseCursor Method

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public override CursorHint SetMouseCursor (
PointF point,
ref bool startInteraction
)
Visual Basic

Public Overrides Function SetMouseCursor ( _
point As PointF, _
ByRef startInteraction As Boolean _
) As CursorHint

Parameters

point
A PointF structure that specifies the position of the mouse cursor.
startInteraction
true if the user is going to create, delete, modify or select a DiagramItem; false if mouse behavior is not considered; in this case the mouse pointer is set to a default cursor according to the background LaneGrid.

Return Value

A member of the CursorHint enumeration.

See Also

ModifyBehavior Members
ModifyBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Diagramming.WinForms.Behaviors.ModifyBehavior.StartDraw Method

ModifyBehavior.StartDraw Method

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming.WinForms.Behaviors
Assembly: MindFusion.Diagramming.WinForms

Syntax

C#

public override InteractionState StartDraw (
PointF point
)
Visual Basic

Public Overrides Function StartDraw ( _
point As PointF _
) As InteractionState

Parameters

point
A PointF structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

ModifyBehavior Members
ModifyBehavior Class
MindFusion.Diagramming.WinForms.Behaviors Namespace


MindFusion.Drawing Namespace
Classes Interfaces Enumerations

Classes

Class | Description
Brush | Brush objects are used to fill the interiors of geometric shapes. Brush is abstract base class inherited by SolidBrush, HatchBrush, TextureBrush, PathGradientBrush and LinearGradientBrush.
BrushCollection | A collection of MindFusion.Drawing.Brush objects.
GdiGraphics | A wrapper of the System.Drawing.Graphics class that implements the IGraphics interface.
GraphicObject | The base class for graphical objects such as pens and brushes.
HatchBrush | HatchBrush objects represent rectangular brushes with a hatch style, a foreground color, and a background color that are used to fill the interiors of geometric shapes.
LinearGradientBrush | LinearGradientBrush objects represent brushes that fill the interiors of geometric shapes with a linear gradient.
PathGradientBrush | PathGradientBrush represents a brush that fills the interiors of geometric shapes with a gradient.
Pen | Pen instances are used to draw the outline of geometric shapes.
PenCollection | A collection of MindFusion.Drawing.Pen objects.
SolidBrush | SolidBrush objects represent brushes of a single color that are used to fill the interiors of geometric shapes.
TextureBrush | TextureBrush objects represent brushes that use images to fill the interiors of geometric shapes.

Interfaces

Interface | Description
IGraphics | This interface exposes the public interface of the .NET System.Drawing.Graphics class.

Enumerations

Enumeration | Description
ImageAlign | Specifies the position and alignment of a picture relative to its destination rectangle.


MindFusion.Drawing.Brush Class

Brush Class
Remarks See Also

Brush objects are used to fill the interiors of geometric shapes. Brush is abstract base class inherited by SolidBrush, HatchBrush, TextureBrush, PathGradientBrush and LinearGradientBrush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract class Brush : GraphicObject
Visual Basic

Public MustInherit Class Brush
Inherits GraphicObject

Remarks

The Brush-derived classes act as proxies for the .NET standard GDI+ System.Drawing.Brush-derived classes. There are two reasons to use proxy classes instead the original GDI classes:

  • First, the GDI resources are limited and would be exhausted by keeping a GDI brushes all the time; by using proxies GDI brushes can be created only at the time of drawing, and immediately disposed after that.
  • Second, the GDI Brush classes do not support serialization; the proxy-classes implement the required interfaces instead.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush

See Also

Brush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Members

Brush Members
Constructors Methods

Brush objects are used to fill the interiors of geometric shapes. Brush is abstract base class inherited by SolidBrush, HatchBrush, TextureBrush, PathGradientBrush and LinearGradientBrush.

The following tables list the members exposed by the Brush type.

Protected Constructors

Name | Description
Brush | Initializes a new instance of the Brush class.

Public Methods

Name | Description
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.
Deserialize | Creates and returns a new brush according to its string representation.
Serialize | Serializes the specified brush to a string.

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Constructor

Brush Constructor

Initializes a new instance of the Brush class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

protected Brush ()
Visual Basic

Protected Sub New ()

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Methods

Brush Methods

Public Methods

Name | Description
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.
Deserialize | Creates and returns a new brush according to its string representation.
Serialize | Serializes the specified brush to a string.

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.CreateGdiBrush Method

Brush.CreateGdiBrush Method

Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.

Overload List

Name | Description
Brush.CreateGdiBrush (RectangleF) | Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object.
Brush.CreateGdiBrush (RectangleF, Single, Single) | Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object. The specified offset is used for texture or pattern brushes whose contents must scroll with the rest of the drawn image.

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.CreateGdiBrush Method (RectangleF)

Brush.CreateGdiBrush Method (RectangleF)
See Also

Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract Brush CreateGdiBrush (
RectangleF rc
)
Visual Basic

Public MustOverride Function CreateGdiBrush ( _
rc As RectangleF _
) As Brush

Parameters

rc
The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.CreateGdiBrush Method (RectangleF, Single, Single)

Brush.CreateGdiBrush Method (RectangleF, Single, Single)
See Also

Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object. The specified offset is used for texture or pattern brushes whose contents must scroll with the rest of the drawn image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual Brush CreateGdiBrush (
RectangleF rc,
float dx,
float dy
)
Visual Basic

Public Overridable Function CreateGdiBrush ( _
rc As RectangleF, _
dx As Single, _
dy As Single _
) As Brush

Parameters

rc
The rectangle in which painting will be performed.
dx
Specifies a horizontal offset to apply to this brush.
dy
Specifies a vertical offset to apply to this brush.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.Deserialize Method

Brush.Deserialize Method

Creates and returns a new brush according to its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public static Brush Deserialize (
string image
)
Visual Basic

Public Shared Function Deserialize ( _
image As String _
) As Brush

Parameters

image

A string that represents the serialized bursh.

Return Value

An instance of a Brush-derived class.

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.Serialize Method

Brush.Serialize Method

Serializes the specified brush to a string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public static string Serialize (
Brush brush
)
Visual Basic

Public Shared Function Serialize ( _
brush As Brush _
) As String

Parameters

brush

The Brush object to serialize.

Return Value

A string that represents the specified brush.

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Class

BrushCollection Class

A collection of MindFusion.Drawing.Brush objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public sealed class BrushCollection : CollectionBase, ICloneable
Visual Basic

Public NotInheritable Class BrushCollection
Inherits CollectionBase
Implements ICloneable

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Drawing.BrushCollection

See Also

BrushCollection Members
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Members

BrushCollection Members
Constructors Properties Methods

A collection of MindFusion.Drawing.Brush objects.

The following tables list the members exposed by the BrushCollection type.

Public Constructors

Name | Description
BrushCollection | Overloaded. Initializes a new instance of the BrushCollection class.

Public Properties

Name | Description
DefaultBrush | Gets or sets the default brush added to a brush collection from within a design-time editor.
Item | Gets or sets the Brush, located at the specified position.

Public Methods

Name | Description
Add | Adds the specified Brush to the collection.
Clone | Returns a shallow copy of this BrushCollection object.
Contains | Checks whether the specified Brush is contained in the collection.
IndexOf | Returns the index of the first occurrence of the specified Brush.
Insert | Inserts the specified Brush at the specified position within the collection.
Remove | Removes the first occurrence of the specified Brush from the collection.
RemoveAt | Removes the Brush at the specified index.

See Also

BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Constructor

BrushCollection Constructor

Initializes a new instance of the BrushCollection class.

Overload List

Name | Description
BrushCollection () | Initializes a new empty instance of the BrushCollection class.
BrushCollection (String) | Initializes a new instance of the BrushCollection class using the specified string representation.

See Also

BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Constructor ()

BrushCollection Constructor ()
See Also

Initializes a new empty instance of the BrushCollection class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public BrushCollection ()
Visual Basic

Public Sub New ()

See Also

BrushCollection Constructor Overload List
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Constructor (String)

BrushCollection Constructor (String)
See Also

Initializes a new instance of the BrushCollection class using the specified string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public BrushCollection (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation
The string that represents serialized contents of a BrushCollection.

See Also

BrushCollection Constructor Overload List
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Methods

BrushCollection Methods

Public Methods

Name | Description
Add | Adds the specified Brush to the collection.
Clone | Returns a shallow copy of this BrushCollection object.
Contains | Checks whether the specified Brush is contained in the collection.
IndexOf | Returns the index of the first occurrence of the specified Brush.
Insert | Inserts the specified Brush at the specified position within the collection.
Remove | Removes the first occurrence of the specified Brush from the collection.
RemoveAt | Removes the Brush at the specified index.

See Also

BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Add Method

BrushCollection.Add Method

Adds the specified Brush to the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public int Add (
Brush brush
)
Visual Basic

Public Function Add ( _
brush As Brush _
) As Integer

Parameters

brush

The Brush object to add to the end of the collection.

Return Value

The zero-based index within the collection of the newly added brush.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Clone Method

BrushCollection.Clone Method

Returns a shallow copy of this BrushCollection object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

An instance of the BrushCollection class.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Contains Method

BrushCollection.Contains Method

Checks whether the specified Brush is contained in the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public bool Contains (
Brush brush
)
Visual Basic

Public Function Contains ( _
brush As Brush _
) As Boolean

Parameters

brush

The Brush object to search for in the collection.

Return Value

true if the specified brush is contained in the collection; otherwise, false.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.IndexOf Method

BrushCollection.IndexOf Method

Returns the index of the first occurrence of the specified Brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public int IndexOf (
Brush brush
)
Visual Basic

Public Function IndexOf ( _
brush As Brush _
) As Integer

Parameters

brush

The Brush object to locate in the collection.

Return Value

The zero-based index of the first occurrence of brush within the entire collection, if found; otherwise, -1.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Insert Method

BrushCollection.Insert Method

Inserts the specified Brush at the specified position within the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void Insert (
int index,
Brush brush
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
brush As Brush _
)

Parameters

index
The zero-based index at which to insert the brush.
brush
The Brush object to add to the collection.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Remove Method

BrushCollection.Remove Method

Removes the first occurrence of the specified Brush from the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void Remove (
Brush brush
)
Visual Basic

Public Sub Remove ( _
brush As Brush _
)

Parameters

brush

The Brush object to remove from the collection.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.RemoveAt Method

BrushCollection.RemoveAt Method

Removes the Brush at the specified index.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public new void RemoveAt (
int index
)
Visual Basic

Public Shadows Sub RemoveAt ( _
index As Integer _
)

Parameters

index

The index at which the Brush object should be removed.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Properties

BrushCollection Properties

Public Properties

Name | Description
DefaultBrush | Gets or sets the default brush added to a brush collection from within a design-time editor.
Item | Gets or sets the Brush, located at the specified position.

See Also

BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.DefaultBrush Property

BrushCollection.DefaultBrush Property

Gets or sets the default brush added to a brush collection from within a design-time editor.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Brush DefaultBrush { get; set; }
Visual Basic

Public Property DefaultBrush As Brush

Property Value

An instance of the Brush class.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Item Property

BrushCollection.Item Property

Gets or sets the Brush, located at the specified position.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Brush Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Brush

Parameters

index

The zero-based index of the brush to set or retrieve.

Property Value

An instance of the Brush class that represents the brush at the specified position.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Class

GdiGraphics Class

A wrapper of the System.Drawing.Graphics class that implements the IGraphics interface.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public class GdiGraphics : IGraphics
Visual Basic

Public Class GdiGraphics
Implements IGraphics

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GdiGraphics

See Also

GdiGraphics Members
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Members

GdiGraphics Members
Constructors Properties Methods

A wrapper of the System.Drawing.Graphics class that implements the IGraphics interface.

The following tables list the members exposed by the GdiGraphics type.

Public Constructors

Name | Description
GdiGraphics | Initializes a new instance of the GdiGraphics class over the specified GDI+ Graphics object.

Public Properties

Name | Description
Clip | Gets or sets a .NET Region object that limits the drawing region of this GdiGraphics object.
ClipBounds | Gets a .NET RectangleF structure that bounds the clipping region of this GdiGraphics object.
CompositingMode | Gets or sets a value that specifies how composited images are drawn to this GdiGraphics object.
CompositingQuality | Gets or sets the rendering quality of composited images drawn to this GdiGraphics object.
DpiX | Gets the horizontal resolution of this GdiGraphics object.
DpiY | Gets the vertical resolution of this GdiGraphics object.
Graphics | Gets a reference to the underlying .NET Graphics object.
InterpolationMode | Gets or sets the interpolation mode associated with this GdiGraphics object.
IsClipEmpty | Gets a value indicating whether the clipping region of this GdiGraphics object is empty.
IsVisibleClipEmpty | Gets a value indicating whether the visible clipping region of this GdiGraphics object is empty.
PageScale | Gets or sets the scaling between world units and page units for this GdiGraphics object.
PageUnit | Gets or sets the unit of measure used for page coordinates in this GdiGraphics object.
PixelOffsetMode | Gets or set a value specifying how pixels are offset during rendering of this GdiGraphics object.
RenderingOrigin | Gets or sets the rendering origin of this GdiGraphics object for dithering and for hatch brushes.
SmoothingMode | Gets or sets the rendering quality for this GdiGraphics object.
TextContrast | Gets or sets the gamma correction value for rendering text.
TextRenderingHint | Gets or sets the rendering mode for text associated with this GdiGraphics object.
Transform | Gets or sets the world transformation for this GdiGraphics object.
VisibleClipBounds | Gets the bounding rectangle of the visible clipping region of this GdiGraphics object.

Public Methods

Name | Description
AddMetafileComment | Adds a comment to the current Metafile object.
BeginContainer | Overloaded. Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.
BeginHyperLink |
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Releases all resources used by this GdiGraphics object.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bézier spline defined by four .NET Point structures.
DrawBeziers | Overloaded. Draws a series of Bézier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of Point structures.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawIcon | Overloaded. Draws the image represented by the specified .NET Icon object at the specified coordinates.
DrawIconUnstretched | Draws the image represented by the specified .NET Icon object without scaling the image.
DrawImage | Overloaded. Draws the specified .NET Image object at the specified location and with the original size.
DrawImageUnscaled | Overloaded. Draws the specified image using its original physical size at the location specified by a coordinate pair.
DrawLine | Overloaded. Draws a line connecting the two points specified by coordinate pairs.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a .NET GraphicsPath object.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of Point or PointF structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangles | Overloaded. Draws a series of rectangles specified by Rectangle or RectangleF structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndContainer | Closes the current graphics container and restores the state of this GdiGraphics object to the state saved by a call to the BeginContainer method.
EndHyperLink |
EnumerateMetafile | Overloaded. Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
ExcludeClip | Overloaded. Updates the clip region of this GdiGraphics object to exclude the area specified by a .NET Rectangle structure.
FillClosedCurve | Overloaded. Fills the interior a closed cardinal spline curve defined by an array of Point structures.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillPath | Fills the interior of a .NET GraphicsPath object.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by Point structures.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a .NET Region object.
Flush | Overloaded. Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GetFontHeight |
GetHdc | Gets the handle to the device context associated with this GdiGraphics.
GetNearestColor | Gets the nearest color to the specified Color structure.
IntersectClip | Overloaded. Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IsVisible | Overloaded. Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.
MeasureCharacterRanges | Gets an array of Region objects, each of which bounds a range of character positions within the specified string.
MeasureString | Overloaded. Measures the specified string when drawn with the specified Font object.
MultiplyTransform | Overloaded. Multiplies the world transformation of this GdiGraphics object and specified the .NET Matrix object.
ReleaseHdc | Releases a device context handle obtained by a previous call to the GetHdc method of this GdiGraphics object.
ReleaseHdcInternal | Internal method. Do not use.
ResetClip | Resets the clip region of this GdiGraphics object to an infinite region.
ResetTransform | Resets the world transformation matrix of this GdiGraphics object to the identity matrix.
Restore | Restores the state of this GdiGraphics object to the state represented by a GraphicsState object.
RotateTransform | Overloaded. Applies the specified rotation to the transformation matrix of this GdiGraphics object.
Save | Saves the current state of this GdiGraphics object and identifies the saved state with a GraphicsState object.
ScaleTransform | Overloaded. Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.
SetClip | Overloaded. Sets the clipping region of this GdiGraphics object.
TransformPoints | Overloaded. Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.
TranslateClip | Overloaded. Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.
TranslateTransform | Overloaded. Prepends the specified translation to the transformation matrix of this GdiGraphics object.

See Also

GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Constructor

GdiGraphics Constructor

Initializes a new instance of the GdiGraphics class over the specified GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public GdiGraphics (
Graphics graphics
)
Visual Basic

Public New ( _
graphics As Graphics _
)

Parameters

graphics
The .NET Graphics object to wrap.

See Also

GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Methods

GdiGraphics Methods

Public Methods

Name | Description
AddMetafileComment | Adds a comment to the current Metafile object.
BeginContainer | Overloaded. Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.
BeginHyperLink |
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Releases all resources used by this GdiGraphics object.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bézier spline defined by four .NET Point structures.
DrawBeziers | Overloaded. Draws a series of Bézier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of Point structures.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawIcon | Overloaded. Draws the image represented by the specified .NET Icon object at the specified coordinates.
DrawIconUnstretched | Draws the image represented by the specified .NET Icon object without scaling the image.
DrawImage | Overloaded. Draws the specified .NET Image object at the specified location and with the original size.
DrawImageUnscaled | Overloaded. Draws the specified image using its original physical size at the location specified by a coordinate pair.
DrawLine | Overloaded. Draws a line connecting the two points specified by coordinate pairs.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a .NET GraphicsPath object.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of Point or PointF structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangles | Overloaded. Draws a series of rectangles specified by Rectangle or RectangleF structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndContainer | Closes the current graphics container and restores the state of this GdiGraphics object to the state saved by a call to the BeginContainer method.
EndHyperLink |
EnumerateMetafile | Overloaded. Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
ExcludeClip | Overloaded. Updates the clip region of this GdiGraphics object to exclude the area specified by a .NET Rectangle structure.
FillClosedCurve | Overloaded. Fills the interior a closed cardinal spline curve defined by an array of Point structures.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillPath | Fills the interior of a .NET GraphicsPath object.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by Point structures.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a .NET Region object.
Flush | Overloaded. Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GetFontHeight |
GetHdc | Gets the handle to the device context associated with this GdiGraphics.
GetNearestColor | Gets the nearest color to the specified Color structure.
IntersectClip | Overloaded. Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IsVisible | Overloaded. Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.
MeasureCharacterRanges | Gets an array of Region objects, each of which bounds a range of character positions within the specified string.
MeasureString | Overloaded. Measures the specified string when drawn with the specified Font object.
MultiplyTransform | Overloaded. Multiplies the world transformation of this GdiGraphics object and specified the .NET Matrix object.
ReleaseHdc | Releases a device context handle obtained by a previous call to the GetHdc method of this GdiGraphics object.
ReleaseHdcInternal | Internal method. Do not use.
ResetClip | Resets the clip region of this GdiGraphics object to an infinite region.
ResetTransform | Resets the world transformation matrix of this GdiGraphics object to the identity matrix.
Restore | Restores the state of this GdiGraphics object to the state represented by a GraphicsState object.
RotateTransform | Overloaded. Applies the specified rotation to the transformation matrix of this GdiGraphics object.
Save | Saves the current state of this GdiGraphics object and identifies the saved state with a GraphicsState object.
ScaleTransform | Overloaded. Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.
SetClip | Overloaded. Sets the clipping region of this GdiGraphics object.
TransformPoints | Overloaded. Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.
TranslateClip | Overloaded. Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.
TranslateTransform | Overloaded. Prepends the specified translation to the transformation matrix of this GdiGraphics object.

See Also

GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.AddMetafileComment Method

GdiGraphics.AddMetafileComment Method

Adds a comment to the current Metafile object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void AddMetafileComment (
byte[] data
)
Visual Basic

Public Overridable Sub AddMetafileComment ( _
data() As Byte _
)

Parameters

data
Array of bytes that contains the comment.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginContainer Method

GdiGraphics.BeginContainer Method

Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.

Overload List

Name | Description
GdiGraphics.BeginContainer () | Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.
GdiGraphics.BeginContainer (Rectangle, Rectangle, GraphicsUnit) | Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container with the specified scale transformation.
GdiGraphics.BeginContainer (RectangleF, RectangleF, GraphicsUnit) | Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container with the specified scale transformation.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginContainer Method ()

GdiGraphics.BeginContainer Method ()
See Also

Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual GraphicsContainer BeginContainer ()
Visual Basic

Public Overridable Function BeginContainer () As GraphicsContainer

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this GdiGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginContainer Method (Rectangle, Rectangle, GraphicsUnit)

GdiGraphics.BeginContainer Method (Rectangle, Rectangle, GraphicsUnit)
See Also

Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container with the specified scale transformation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual GraphicsContainer BeginContainer (
Rectangle dstrect,
Rectangle srcrect,
GraphicsUnit unit
)
Visual Basic

Public Overridable Function BeginContainer ( _
dstrect As Rectangle, _
srcrect As Rectangle, _
unit As GraphicsUnit _
) As GraphicsContainer

Parameters

dstrect
A .NET Rectangle structure that, together with the srcrect parameter, specifies a scale transformation for the container.
srcrect
A .NET Rectangle structure that, together with the dstrect parameter, specifies a scale transformation for the container.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure for the container.

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this GdiGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginContainer Method (RectangleF, RectangleF, GraphicsUnit)

GdiGraphics.BeginContainer Method (RectangleF, RectangleF, GraphicsUnit)
See Also

Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container with the specified scale transformation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual GraphicsContainer BeginContainer (
RectangleF dstrect,
RectangleF srcrect,
GraphicsUnit unit
)
Visual Basic

Public Overridable Function BeginContainer ( _
dstrect As RectangleF, _
srcrect As RectangleF, _
unit As GraphicsUnit _
) As GraphicsContainer

Parameters

dstrect
A .NET RectangleF structure that, together with the srcrect parameter, specifies a scale transformation for the new graphics container.
srcrect
A .NET RectangleF structure that, together with the dstrect parameter, specifies a scale transformation for the new graphics container.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure for the container.

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this GdiGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginHyperLink Method

GdiGraphics.BeginHyperLink Method

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void BeginHyperLink (
string url,
string target
)
Visual Basic

Public Overridable Sub BeginHyperLink ( _
url As String, _
target As String _
)

Parameters

url
target

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Clear Method

GdiGraphics.Clear Method

Clears the entire drawing surface and fills it with the specified background color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void Clear (
Color color
)
Visual Basic

Public Overridable Sub Clear ( _
color As Color _
)

Parameters

color
A .NET Color structure that represents the background color of the drawing surface.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Dispose Method

GdiGraphics.Dispose Method

Releases all resources used by this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void Dispose ()
Visual Basic

Public Overridable Sub Dispose ()

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method

GdiGraphics.DrawArc Method

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
GdiGraphics.DrawArc (Pen, Int32, Int32, Int32, Int32, Int32, Int32) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
GdiGraphics.DrawArc (Pen, Rectangle, Single, Single) | Draws an arc representing a portion of an ellipse specified by a .NET Rectangle structure.
GdiGraphics.DrawArc (Pen, RectangleF, Single, Single) | Draws an arc representing a portion of an ellipse specified by a .NET RectangleF structure.
GdiGraphics.DrawArc (Pen, Single, Single, Single, Single, Single, Single) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

GdiGraphics.DrawArc Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)
See Also

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawArc (
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)
Visual Basic

Public Overridable Sub DrawArc ( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
The width of the rectangle that defines the ellipse.
height
The height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method (Pen, Rectangle, Single, Single)

GdiGraphics.DrawArc Method (Pen, Rectangle, Single, Single)
See Also

Draws an arc representing a portion of an ellipse specified by a .NET Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawArc (
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
)
Visual Basic

Public Overridable Sub DrawArc ( _
pen As Pen, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method (Pen, RectangleF, Single, Single)

GdiGraphics.DrawArc Method (Pen, RectangleF, Single, Single)
See Also

Draws an arc representing a portion of an ellipse specified by a .NET RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawArc (
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
)
Visual Basic

Public Overridable Sub DrawArc ( _
pen As Pen, _
rect As RectangleF, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method (Pen, Single, Single, Single, Single, Single, Single)

GdiGraphics.DrawArc Method (Pen, Single, Single, Single, Single, Single, Single)
See Also

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawArc (
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)
Visual Basic

Public Overridable Sub DrawArc ( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
The width of the rectangle that defines the ellipse.
height
The height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBezier Method

GdiGraphics.DrawBezier Method

Draws a Bézier spline defined by four .NET Point structures.

Overload List

Name | Description
GdiGraphics.DrawBezier (Pen, Point, Point, Point, Point) | Draws a Bézier spline defined by four Point structures.
GdiGraphics.DrawBezier (Pen, PointF, PointF, PointF, PointF) | Draws a Bézier spline defined by four PointF structures.
GdiGraphics.DrawBezier (Pen, Single, Single, Single, Single, Single, Single, Single, Single) | Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBezier Method (Pen, Point, Point, Point, Point)

GdiGraphics.DrawBezier Method (Pen, Point, Point, Point, Point)
See Also

Draws a Bézier spline defined by four Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawBezier (
Pen pen,
Point pt1,
Point pt2,
Point pt3,
Point pt4
)
Visual Basic

Public Overridable Sub DrawBezier ( _
pen As Pen, _
pt1 As Point, _
pt2 As Point, _
pt3 As Point, _
pt4 As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
pt1
A .NET Point structure that represents the starting point of the curve.
pt2
A .NET Point structure that represents the first control point for the curve.
pt3
A .NET Point structure that represents the second control point for the curve.
pt4
A .NET Point structure that represents the ending point of the curve.

See Also

DrawBezier Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBezier Method (Pen, PointF, PointF, PointF, PointF)

GdiGraphics.DrawBezier Method (Pen, PointF, PointF, PointF, PointF)
See Also

Draws a Bézier spline defined by four PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawBezier (
Pen pen,
PointF pt1,
PointF pt2,
PointF pt3,
PointF pt4
)
Visual Basic

Public Overridable Sub DrawBezier ( _
pen As Pen, _
pt1 As PointF, _
pt2 As PointF, _
pt3 As PointF, _
pt4 As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
pt1
A .NET PointF structure that represents the starting point of the curve.
pt2
A .NET PointF structure that represents the first control point for the curve.
pt3
A .NET PointF structure that represents the second control point for the curve.
pt4
A .NET PointF structure that represents the ending point of the curve.

See Also

DrawBezier Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBezier Method (Pen, Single, Single, Single, Single, Single, Single, Single, Single)

GdiGraphics.DrawBezier Method (Pen, Single, Single, Single, Single, Single, Single, Single, Single)
See Also

Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawBezier (
Pen pen,
float x1,
float y1,
float x2,
float y2,
float x3,
float y3,
float x4,
float y4
)
Visual Basic

Public Overridable Sub DrawBezier ( _
pen As Pen, _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single, _
x3 As Single, _
y3 As Single, _
x4 As Single, _
y4 As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
x1
The x-coordinate of the starting point of the curve.
y1
The y-coordinate of the starting point of the curve.
x2
The x-coordinate of the first control point of the curve.
y2
The y-coordinate of the first control point of the curve.
x3
The x-coordinate of the second control point of the curve.
y3
The y-coordinate of the second control point of the curve.
x4
The x-coordinate of the ending point of the curve.
y4
The y-coordinate of the ending point of the curve.

See Also

DrawBezier Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBeziers Method

GdiGraphics.DrawBeziers Method

Draws a series of Bézier splines from an array of Point structures.

Overload List

Name | Description
GdiGraphics.DrawBeziers (Pen, Point[]) | Draws a series of Bézier splines from an array of Point structures.
GdiGraphics.DrawBeziers (Pen, PointF[]) | Draws a series of Bézier splines from an array of PointF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBeziers Method (Pen, Point[])

GdiGraphics.DrawBeziers Method (Pen, Point[])
See Also

Draws a series of Bézier splines from an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawBeziers (
Pen pen,
Point[] points
)
Visual Basic

Public Overridable Sub DrawBeziers ( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
points
An array of .NET Point structures that represent the points that determine the curve.

See Also

DrawBeziers Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBeziers Method (Pen, PointF[])

GdiGraphics.DrawBeziers Method (Pen, PointF[])
See Also

Draws a series of Bézier splines from an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawBeziers (
Pen pen,
PointF[] points
)
Visual Basic

Public Overridable Sub DrawBeziers ( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
points
An array of .NET PointF structures that represent the points that determine the curve.

See Also

DrawBeziers Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method

GdiGraphics.DrawClosedCurve Method

Draws a closed cardinal spline defined by an array of Point structures.

Overload List

Name | Description
GdiGraphics.DrawClosedCurve (Pen, Point[]) | Draws a closed cardinal spline defined by an array of Point structures.
GdiGraphics.DrawClosedCurve (Pen, Point[], Single, FillMode) | Draws a closed cardinal spline defined by an array of Point structures using a specified tension.
GdiGraphics.DrawClosedCurve (Pen, PointF[]) | Draws a closed cardinal spline defined by an array of PointF structures.
GdiGraphics.DrawClosedCurve (Pen, PointF[], Single, FillMode) | Draws a closed cardinal spline defined by an array of PointF structures using a specified tension.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method (Pen, Point[])

GdiGraphics.DrawClosedCurve Method (Pen, Point[])
See Also

Draws a closed cardinal spline defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawClosedCurve (
Pen pen,
Point[] points
)
Visual Basic

Public Overridable Sub DrawClosedCurve ( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.

See Also

DrawClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method (Pen, Point[], Single, FillMode)

GdiGraphics.DrawClosedCurve Method (Pen, Point[], Single, FillMode)
See Also

Draws a closed cardinal spline defined by an array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawClosedCurve (
Pen pen,
Point[] points,
float tension,
FillMode fillmode
)
Visual Basic

Public Overridable Sub DrawClosedCurve ( _
pen As Pen, _
points() As Point, _
tension As Single, _
fillmode As FillMode _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled. This parameter is required but ignored.

See Also

DrawClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method (Pen, PointF[])

GdiGraphics.DrawClosedCurve Method (Pen, PointF[])
See Also

Draws a closed cardinal spline defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawClosedCurve (
Pen pen,
PointF[] points
)
Visual Basic

Public Overridable Sub DrawClosedCurve ( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of PointF structures that define the spline.

See Also

DrawClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method (Pen, PointF[], Single, FillMode)

GdiGraphics.DrawClosedCurve Method (Pen, PointF[], Single, FillMode)
See Also

Draws a closed cardinal spline defined by an array of PointF structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawClosedCurve (
Pen pen,
PointF[] points,
float tension,
FillMode fillmode
)
Visual Basic

Public Overridable Sub DrawClosedCurve ( _
pen As Pen, _
points() As PointF, _
tension As Single, _
fillmode As FillMode _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of PointF structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.
fillmode
Member of the FillMode enumeration that determines how the curve is filled. This parameter is required but is ignored.

See Also

DrawClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method

GdiGraphics.DrawCurve Method

Draws a cardinal spline through a specified array of Point structures.

Overload List

Name | Description
GdiGraphics.DrawCurve (Pen, Point[]) | Draws a cardinal spline through a specified array of Point structures.
GdiGraphics.DrawCurve (Pen, Point[], Int32, Int32, Single) | Draws a cardinal spline through a specified array of Point structures using a specified tension.
GdiGraphics.DrawCurve (Pen, Point[], Single) | Draws a cardinal spline through a specified array of Point structures using a specified tension.
GdiGraphics.DrawCurve (Pen, PointF[]) | Draws a cardinal spline through a specified array of PointF structures.
GdiGraphics.DrawCurve (Pen, PointF[], Int32, Int32) | Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array.
GdiGraphics.DrawCurve (Pen, PointF[], Int32, Int32, Single) | Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.
GdiGraphics.DrawCurve (Pen, PointF[], Single) | Draws a cardinal spline through a specified array of PointF structures using a specified tension.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, Point[])

GdiGraphics.DrawCurve Method (Pen, Point[])
See Also

Draws a cardinal spline through a specified array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawCurve (
Pen pen,
Point[] points
)
Visual Basic

Public Overridable Sub DrawCurve ( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, Point[], Int32, Int32, Single)

GdiGraphics.DrawCurve Method (Pen, Point[], Int32, Int32, Single)
See Also

Draws a cardinal spline through a specified array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawCurve (
Pen pen,
Point[] points,
int offset,
int numberOfSegments,
float tension
)
Visual Basic

Public Overridable Sub DrawCurve ( _
pen As Pen, _
points() As Point, _
offset As Integer, _
numberOfSegments As Integer, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, Point[], Single)

GdiGraphics.DrawCurve Method (Pen, Point[], Single)
See Also

Draws a cardinal spline through a specified array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawCurve (
Pen pen,
Point[] points,
float tension
)
Visual Basic

Public Overridable Sub DrawCurve ( _
pen As Pen, _
points() As Point, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, PointF[])

GdiGraphics.DrawCurve Method (Pen, PointF[])
See Also

Draws a cardinal spline through a specified array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawCurve (
Pen pen,
PointF[] points
)
Visual Basic

Public Overridable Sub DrawCurve ( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32)

GdiGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32)
See Also

Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawCurve (
Pen pen,
PointF[] points,
int offset,
int numberOfSegments
)
Visual Basic

Public Overridable Sub DrawCurve ( _
pen As Pen, _
points() As PointF, _
offset As Integer, _
numberOfSegments As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32, Single)

GdiGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32, Single)
See Also

Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawCurve (
Pen pen,
PointF[] points,
int offset,
int numberOfSegments,
float tension
)
Visual Basic

Public Overridable Sub DrawCurve ( _
pen As Pen, _
points() As PointF, _
offset As Integer, _
numberOfSegments As Integer, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, PointF[], Single)

GdiGraphics.DrawCurve Method (Pen, PointF[], Single)
See Also

Draws a cardinal spline through a specified array of PointF structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawCurve (
Pen pen,
PointF[] points,
float tension
)
Visual Basic

Public Overridable Sub DrawCurve ( _
pen As Pen, _
points() As PointF, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that represent the points that define the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method

GdiGraphics.DrawEllipse Method

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Overload List

Name | Description
GdiGraphics.DrawEllipse (Pen, Int32, Int32, Int32, Int32) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
GdiGraphics.DrawEllipse (Pen, Rectangle) | Draws an ellipse specified by a bounding Rectangle structure.
GdiGraphics.DrawEllipse (Pen, RectangleF) | Draws an ellipse defined by a bounding RectangleF structure.
GdiGraphics.DrawEllipse (Pen, Single, Single, Single, Single) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method (Pen, Int32, Int32, Int32, Int32)

GdiGraphics.DrawEllipse Method (Pen, Int32, Int32, Int32, Int32)
See Also

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawEllipse (
Pen pen,
int x,
int y,
int width,
int height
)
Visual Basic

Public Overridable Sub DrawEllipse ( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
x

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

DrawEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method (Pen, Rectangle)

GdiGraphics.DrawEllipse Method (Pen, Rectangle)
See Also

Draws an ellipse specified by a bounding Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawEllipse (
Pen pen,
Rectangle rect
)
Visual Basic

Public Overridable Sub DrawEllipse ( _
pen As Pen, _
rect As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
rect
A .NET Rectangle structure that defines the boundaries of the ellipse.

See Also

DrawEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method (Pen, RectangleF)

GdiGraphics.DrawEllipse Method (Pen, RectangleF)
See Also

Draws an ellipse defined by a bounding RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawEllipse (
Pen pen,
RectangleF rect
)
Visual Basic

Public Overridable Sub DrawEllipse ( _
pen As Pen, _
rect As RectangleF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.

See Also

DrawEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method (Pen, Single, Single, Single, Single)

GdiGraphics.DrawEllipse Method (Pen, Single, Single, Single, Single)
See Also

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawEllipse (
Pen pen,
float x,
float y,
float width,
float height
)
Visual Basic

Public Overridable Sub DrawEllipse ( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
x

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

DrawEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawIcon Method

GdiGraphics.DrawIcon Method

Draws the image represented by the specified .NET Icon object at the specified coordinates.

Overload List

Name | Description
GdiGraphics.DrawIcon (Icon, Int32, Int32) | Draws the image represented by the specified .NET Icon object at the specified coordinates.
GdiGraphics.DrawIcon (Icon, Rectangle) | Draws the image represented by the specified .NET Icon object within the area specified by a Rectangle structure.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawIcon Method (Icon, Int32, Int32)

GdiGraphics.DrawIcon Method (Icon, Int32, Int32)
See Also

Draws the image represented by the specified .NET Icon object at the specified coordinates.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawIcon (
Icon icon,
int x,
int y
)
Visual Basic

Public Overridable Sub DrawIcon ( _
icon As Icon, _
x As Integer, _
y As Integer _
)

Parameters

icon
A .NET Icon object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawIcon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawIcon Method (Icon, Rectangle)

GdiGraphics.DrawIcon Method (Icon, Rectangle)
See Also

Draws the image represented by the specified .NET Icon object within the area specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawIcon (
Icon icon,
Rectangle targetRect
)
Visual Basic

Public Overridable Sub DrawIcon ( _
icon As Icon, _
targetRect As Rectangle _
)

Parameters

icon
A .NET Icon object to draw.
targetRect
A .NET Rectangle structure that specifies the location and size of the resulting image on the display surface. The image contained in the icon parameter is scaled to the dimensions of this rectangular area.

See Also

DrawIcon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawIconUnstretched Method

GdiGraphics.DrawIconUnstretched Method

Draws the image represented by the specified .NET Icon object without scaling the image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawIconUnstretched (
Icon icon,
Rectangle targetRect
)
Visual Basic

Public Overridable Sub DrawIconUnstretched ( _
icon As Icon, _
targetRect As Rectangle _
)

Parameters

icon
A .NET Icon object to draw.
targetRect
A .NET Rectangle structure that specifies the location and size of the resulting image. The image is not scaled to fit this rectangle, but retains its original size. If the image is larger than the rectangle, it is clipped to fit inside it.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method

GdiGraphics.DrawImage Method

Draws the specified .NET Image object at the specified location and with the original size.

Overload List

Name | Description
GdiGraphics.DrawImage (Image, Int32, Int32) | Draws the specified image, using its original physical size, at the location specified by a coordinate pair.
GdiGraphics.DrawImage (Image, Int32, Int32, Int32, Int32) | Draws the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Int32, Int32, Rectangle, GraphicsUnit) | Draws a portion of an image at a specified location.
GdiGraphics.DrawImage (Image, Point) | Draws the specified .NET Image object, using its original physical size, at the specified location.
GdiGraphics.DrawImage (Image, Point[]) | Draws the specified .NET Image object at the specified location and with the specified shape and size.
GdiGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location.
GdiGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, PointF) | Draws the specified .NET Image object, using its original physical size, at the specified location.
GdiGraphics.DrawImage (Image, PointF[]) | Draws the specified .NET Image object at the specified location and with the specified shape and size.
GdiGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle) | Draws the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Rectangle, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, RectangleF) | Draws the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, RectangleF, RectangleF, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Single, Single) | Draws the specified .NET Image object, using its original physical size, at the specified location.
GdiGraphics.DrawImage (Image, Single, Single, RectangleF, GraphicsUnit) | Draws a portion of an image at a specified location.
GdiGraphics.DrawImage (Image, Single, Single, Single, Single) | Draws the specified .NET Image object at the specified location and with the specified size.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Int32, Int32)

GdiGraphics.DrawImage Method (Image, Int32, Int32)
See Also

Draws the specified image, using its original physical size, at the location specified by a coordinate pair.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
int x,
int y
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
x As Integer, _
y As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Int32, Int32, Int32, Int32)

GdiGraphics.DrawImage Method (Image, Int32, Int32, Int32, Int32)
See Also

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
int x,
int y,
int width,
int height
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
The width of the drawn image.
height
The height of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Int32, Int32, Rectangle, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Int32, Int32, Rectangle, GraphicsUnit)
See Also

Draws a portion of an image at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
int x,
int y,
Rectangle srcRect,
GraphicsUnit srcUnit
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
x As Integer, _
y As Integer, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point)

GdiGraphics.DrawImage Method (Image, Point)
See Also

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
Point point
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
point As Point _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that represents the location of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[])

GdiGraphics.DrawImage Method (Image, Point[])
See Also

Draws the specified .NET Image object at the specified location and with the specified shape and size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
Point[] destPoints
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
destPoints() As Point _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)

GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)
See Also

Draws the specified portion of the specified .NET Image object at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)

GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32)

GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback,
int callbackData
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort, _
callbackData As Integer _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.
callbackData

Value specifying additional data for the Graphics.DrawImageAbort delegate to use when checking whether to stop execution of the DrawImage method.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF)

GdiGraphics.DrawImage Method (Image, PointF)
See Also

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
PointF point
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
point As PointF _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that represents the location of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[])

GdiGraphics.DrawImage Method (Image, PointF[])
See Also

Draws the specified .NET Image object at the specified location and with the specified shape and size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
PointF[] destPoints
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
destPoints() As PointF _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)

GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)

GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET Rectanglef structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32)

GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback,
int callbackData
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort, _
callbackData As Integer _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.
callbackData
Value specifying additional data for the Graphics.DrawImageAbort delegate to use when checking whether to stop execution of the DrawImage method.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle)

GdiGraphics.DrawImage Method (Image, Rectangle)
See Also

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
Rectangle rect
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
rect As Rectangle _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET Rectangle structure that specifies the location and size of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)

GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)

GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr)

GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs,
Graphics.DrawImageAbort callback,
IntPtr callbackData
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes, _
callback As Graphics.DrawImageAbort, _
callbackData As IntPtr _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.
callbackData
Value specifying additional data for the DrawImageAbort delegate to use when checking whether to stop execution of the DrawImage method.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit srcUnit
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)

GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)

GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs,
Graphics.DrawImageAbort callback
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes, _
callback As Graphics.DrawImageAbort _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr)

GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs,
Graphics.DrawImageAbort callback,
IntPtr callbackData
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes, _
callback As Graphics.DrawImageAbort, _
callbackData As IntPtr _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.
callbackData
Value specifying additional data for the DrawImageAbort delegate to use when checking whether to stop execution of the DrawImage method.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, RectangleF)

GdiGraphics.DrawImage Method (Image, RectangleF)
See Also

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
RectangleF rect
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
rect As RectangleF _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET RectangleF structure that specifies the location and size of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit srcUnit
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
destRect As RectangleF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET RectangleF structure.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Single, Single)

GdiGraphics.DrawImage Method (Image, Single, Single)
See Also

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
float x,
float y
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
x As Single, _
y As Single _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Single, Single, RectangleF, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Single, Single, RectangleF, GraphicsUnit)
See Also

Draws a portion of an image at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
float x,
float y,
RectangleF srcRect,
GraphicsUnit srcUnit
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
x As Single, _
y As Single, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Single, Single, Single, Single)

GdiGraphics.DrawImage Method (Image, Single, Single, Single, Single)
See Also

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImage (
Image image,
float x,
float y,
float width,
float height
)
Visual Basic

Public Overridable Sub DrawImage ( _
image As Image, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
The width of the drawn image.
height
The height of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method

GdiGraphics.DrawImageUnscaled Method

Draws the specified image using its original physical size at the location specified by a coordinate pair.

Overload List

Name | Description
GdiGraphics.DrawImageUnscaled (Image, Int32, Int32) | Draws the specified image using its original physical size at the location specified by a coordinate pair.
GdiGraphics.DrawImageUnscaled (Image, Int32, Int32, Int32, Int32) | Draws a specified image using its original physical size at a specified location.
GdiGraphics.DrawImageUnscaled (Image, Point) | Draws a specified image using its original physical size at a specified location.
GdiGraphics.DrawImageUnscaled (Image, Rectangle) | Draws a specified image using its original physical size at a specified location.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method (Image, Int32, Int32)

GdiGraphics.DrawImageUnscaled Method (Image, Int32, Int32)
See Also

Draws the specified image using its original physical size at the location specified by a coordinate pair.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImageUnscaled (
Image image,
int x,
int y
)
Visual Basic

Public Overridable Sub DrawImageUnscaled ( _
image As Image, _
x As Integer, _
y As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImageUnscaled Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method (Image, Int32, Int32, Int32, Int32)

GdiGraphics.DrawImageUnscaled Method (Image, Int32, Int32, Int32, Int32)
See Also

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImageUnscaled (
Image image,
int x,
int y,
int width,
int height
)
Visual Basic

Public Overridable Sub DrawImageUnscaled ( _
image As Image, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
Not used.
height
Not used.

See Also

DrawImageUnscaled Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method (Image, Point)

GdiGraphics.DrawImageUnscaled Method (Image, Point)
See Also

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImageUnscaled (
Image image,
Point point
)
Visual Basic

Public Overridable Sub DrawImageUnscaled ( _
image As Image, _
point As Point _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that specifies the upper-left corner of the drawn image.

See Also

DrawImageUnscaled Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method (Image, Rectangle)

GdiGraphics.DrawImageUnscaled Method (Image, Rectangle)
See Also

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawImageUnscaled (
Image image,
Rectangle rect
)
Visual Basic

Public Overridable Sub DrawImageUnscaled ( _
image As Image, _
rect As Rectangle _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET Rectangle structure that specifies the drawn image.

See Also

DrawImageUnscaled Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method

GdiGraphics.DrawLine Method

Draws a line connecting the two points specified by coordinate pairs.

Overload List

Name | Description
GdiGraphics.DrawLine (Pen, Int32, Int32, Int32, Int32) | Draws a line connecting the two points specified by coordinate pairs.
GdiGraphics.DrawLine (Pen, Point, Point) | Draws a line connecting two Point structures.
GdiGraphics.DrawLine (Pen, PointF, PointF) | Draws a line connecting two PointF structures.
GdiGraphics.DrawLine (Pen, Single, Single, Single, Single) | Draws a line connecting the two points specified by coordinate pairs.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method (Pen, Int32, Int32, Int32, Int32)

GdiGraphics.DrawLine Method (Pen, Int32, Int32, Int32, Int32)
See Also

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawLine (
Pen pen,
int x1,
int y1,
int x2,
int y2
)
Visual Basic

Public Overridable Sub DrawLine ( _
pen As Pen, _
x1 As Integer, _
y1 As Integer, _
x2 As Integer, _
y2 As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

See Also

DrawLine Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method (Pen, Point, Point)

GdiGraphics.DrawLine Method (Pen, Point, Point)
See Also

Draws a line connecting two Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawLine (
Pen pen,
Point pt1,
Point pt2
)
Visual Basic

Public Overridable Sub DrawLine ( _
pen As Pen, _
pt1 As Point, _
pt2 As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
pt1
A .NET Point structure that represents the first point to connect.
pt2
A .NET Point structure that represents the second point to connect.

See Also

DrawLine Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method (Pen, PointF, PointF)

GdiGraphics.DrawLine Method (Pen, PointF, PointF)
See Also

Draws a line connecting two PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawLine (
Pen pen,
PointF pt1,
PointF pt2
)
Visual Basic

Public Overridable Sub DrawLine ( _
pen As Pen, _
pt1 As PointF, _
pt2 As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
pt1
A .NET PointF structure that represents the first point to connect.
pt2
A .NET PointF structure that represents the second point to connect.

See Also

DrawLine Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method (Pen, Single, Single, Single, Single)

GdiGraphics.DrawLine Method (Pen, Single, Single, Single, Single)
See Also

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawLine (
Pen pen,
float x1,
float y1,
float x2,
float y2
)
Visual Basic

Public Overridable Sub DrawLine ( _
pen As Pen, _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

See Also

DrawLine Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLines Method

GdiGraphics.DrawLines Method

Draws a series of line segments that connect an array of Point structures.

Overload List

Name | Description
GdiGraphics.DrawLines (Pen, Point[]) | Draws a series of line segments that connect an array of Point structures.
GdiGraphics.DrawLines (Pen, PointF[]) | Draws a series of line segments that connect an array of PointF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLines Method (Pen, Point[])

GdiGraphics.DrawLines Method (Pen, Point[])
See Also

Draws a series of line segments that connect an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawLines (
Pen pen,
Point[] points
)
Visual Basic

Public Overridable Sub DrawLines ( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line segments.
points
An array of .NET Point structures that represent the points to connect.

See Also

DrawLines Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLines Method (Pen, PointF[])

GdiGraphics.DrawLines Method (Pen, PointF[])
See Also

Draws a series of line segments that connect an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawLines (
Pen pen,
PointF[] points
)
Visual Basic

Public Overridable Sub DrawLines ( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line segments.
points
An array of .NET PointF structures that represent the points to connect.

See Also

DrawLines Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPath Method

GdiGraphics.DrawPath Method

Draws a .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawPath (
Pen pen,
GraphicsPath path
)
Visual Basic

Public Overridable Sub DrawPath ( _
pen As Pen, _
path As GraphicsPath _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the path.
path
A .NET GraphicsPath object to draw.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method

GdiGraphics.DrawPie Method

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Overload List

Name | Description
GdiGraphics.DrawPie (Pen, Int32, Int32, Int32, Int32, Int32, Int32) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
GdiGraphics.DrawPie (Pen, Rectangle, Single, Single) | Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.
GdiGraphics.DrawPie (Pen, RectangleF, Single, Single) | Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.
GdiGraphics.DrawPie (Pen, Single, Single, Single, Single, Single, Single) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

GdiGraphics.DrawPie Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)
See Also

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawPie (
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)
Visual Basic

Public Overridable Sub DrawPie ( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method (Pen, Rectangle, Single, Single)

GdiGraphics.DrawPie Method (Pen, Rectangle, Single, Single)
See Also

Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawPie (
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
)
Visual Basic

Public Overridable Sub DrawPie ( _
pen As Pen, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method (Pen, RectangleF, Single, Single)

GdiGraphics.DrawPie Method (Pen, RectangleF, Single, Single)
See Also

Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawPie (
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
)
Visual Basic

Public Overridable Sub DrawPie ( _
pen As Pen, _
rect As RectangleF, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
rect
A .NET RectangleF structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method (Pen, Single, Single, Single, Single, Single, Single)

GdiGraphics.DrawPie Method (Pen, Single, Single, Single, Single, Single, Single)
See Also

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawPie (
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)
Visual Basic

Public Overridable Sub DrawPie ( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPolygon Method

GdiGraphics.DrawPolygon Method

Draws a polygon defined by an array of Point or PointF structures.

Overload List

Name | Description
GdiGraphics.DrawPolygon (Pen, Point[]) | Draws a polygon defined by an array of Point structures.
GdiGraphics.DrawPolygon (Pen, PointF[]) | Draws a polygon defined by an array of PointF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPolygon Method (Pen, Point[])

GdiGraphics.DrawPolygon Method (Pen, Point[])
See Also

Draws a polygon defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawPolygon (
Pen pen,
Point[] points
)
Visual Basic

Public Overridable Sub DrawPolygon ( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the polygon.
points
An array of .NET Point structures that represent the vertices of the polygon.

See Also

DrawPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPolygon Method (Pen, PointF[])

GdiGraphics.DrawPolygon Method (Pen, PointF[])
See Also

Draws a polygon defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawPolygon (
Pen pen,
PointF[] points
)
Visual Basic

Public Overridable Sub DrawPolygon ( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the polygon.
points
An array of .NET PointF structures that represent the vertices of the polygon.

See Also

DrawPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangle Method

GdiGraphics.DrawRectangle Method

Draws a rectangle specified by a coordinate pair, a width, and a height.

Overload List

Name | Description
GdiGraphics.DrawRectangle (Pen, Int32, Int32, Int32, Int32) | Draws a rectangle specified by a coordinate pair, a width, and a height.
GdiGraphics.DrawRectangle (Pen, Rectangle) | Draws a rectangle specified by a Rectangle structure.
GdiGraphics.DrawRectangle (Pen, Single, Single, Single, Single) | Draws a rectangle specified by a coordinate pair, a width, and a height.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)

GdiGraphics.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)
See Also

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawRectangle (
Pen pen,
int x,
int y,
int width,
int height
)
Visual Basic

Public Overridable Sub DrawRectangle ( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangle Method (Pen, Rectangle)

GdiGraphics.DrawRectangle Method (Pen, Rectangle)
See Also

Draws a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawRectangle (
Pen pen,
Rectangle rect
)
Visual Basic

Public Overridable Sub DrawRectangle ( _
pen As Pen, _
rect As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
rect
A .NET Rectangle structure that represents the rectangle to draw.

See Also

DrawRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangle Method (Pen, Single, Single, Single, Single)

GdiGraphics.DrawRectangle Method (Pen, Single, Single, Single, Single)
See Also

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawRectangle (
Pen pen,
float x,
float y,
float width,
float height
)
Visual Basic

Public Overridable Sub DrawRectangle ( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangles Method

GdiGraphics.DrawRectangles Method

Draws a series of rectangles specified by Rectangle or RectangleF structures.

Overload List

Name | Description
GdiGraphics.DrawRectangles (Pen, Rectangle[]) | Draws a series of rectangles specified by Rectangle structures.
GdiGraphics.DrawRectangles (Pen, RectangleF[]) | Draws a series of rectangles specified by RectangleF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangles Method (Pen, Rectangle[])

GdiGraphics.DrawRectangles Method (Pen, Rectangle[])
See Also

Draws a series of rectangles specified by Rectangle structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawRectangles (
Pen pen,
Rectangle[] rects
)
Visual Basic

Public Overridable Sub DrawRectangles ( _
pen As Pen, _
rects() As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the outlines of the rectangles.
rects
An array of .NET Rectangle structures that represent the rectangles to draw.

See Also

DrawRectangles Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangles Method (Pen, RectangleF[])

GdiGraphics.DrawRectangles Method (Pen, RectangleF[])
See Also

Draws a series of rectangles specified by RectangleF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawRectangles (
Pen pen,
RectangleF[] rects
)
Visual Basic

Public Overridable Sub DrawRectangles ( _
pen As Pen, _
rects() As RectangleF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the outlines of the rectangles.
rects
An array of .NET RectangleF structures that represent the rectangles to draw.

See Also

DrawRectangles Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method

GdiGraphics.DrawString Method

Draws the specified text string at the specified location with the specified Brush and Font objects.

Overload List

Name | Description
GdiGraphics.DrawString (String, Font, Brush, PointF) | Draws the specified text string at the specified location with the specified Brush and Font objects.
GdiGraphics.DrawString (String, Font, Brush, PointF, StringFormat) | Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.
GdiGraphics.DrawString (String, Font, Brush, RectangleF) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects.
GdiGraphics.DrawString (String, Font, Brush, RectangleF, StringFormat) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.
GdiGraphics.DrawString (String, Font, Brush, Single, Single) | Draws the specified text string at the specified location with the specified Brush and Font objects.
GdiGraphics.DrawString (String, Font, Brush, Single, Single, StringFormat) | Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, PointF)

GdiGraphics.DrawString Method (String, Font, Brush, PointF)
See Also

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawString (
string s,
Font font,
Brush brush,
PointF point
)
Visual Basic

Public Overridable Sub DrawString ( _
s As String, _
font As Font, _
brush As Brush, _
point As PointF _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
point
A .NET PointF structure that specifies the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, PointF, StringFormat)

GdiGraphics.DrawString Method (String, Font, Brush, PointF, StringFormat)
See Also

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawString (
string s,
Font font,
Brush brush,
PointF point,
StringFormat format
)
Visual Basic

Public Overridable Sub DrawString ( _
s As String, _
font As Font, _
brush As Brush, _
point As PointF, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
point
A .NET PointF structure that specifies the upper-left corner of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, RectangleF)

GdiGraphics.DrawString Method (String, Font, Brush, RectangleF)
See Also

Draws the specified text string in the specified rectangle with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawString (
string s,
Font font,
Brush brush,
RectangleF layoutRectangle
)
Visual Basic

Public Overridable Sub DrawString ( _
s As String, _
font As Font, _
brush As Brush, _
layoutRectangle As RectangleF _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
layoutRectangle
A .NET RectangleF structure that specifies the location of the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)

GdiGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)
See Also

Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawString (
string s,
Font font,
Brush brush,
RectangleF layoutRectangle,
StringFormat format
)
Visual Basic

Public Overridable Sub DrawString ( _
s As String, _
font As Font, _
brush As Brush, _
layoutRectangle As RectangleF, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
layoutRectangle
A .NET RectangleF structure that specifies the location of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, Single, Single)

GdiGraphics.DrawString Method (String, Font, Brush, Single, Single)
See Also

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawString (
string s,
Font font,
Brush brush,
float x,
float y
)
Visual Basic

Public Overridable Sub DrawString ( _
s As String, _
font As Font, _
brush As Brush, _
x As Single, _
y As Single _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, Single, Single, StringFormat)

GdiGraphics.DrawString Method (String, Font, Brush, Single, Single, StringFormat)
See Also

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void DrawString (
string s,
Font font,
Brush brush,
float x,
float y,
StringFormat format
)
Visual Basic

Public Overridable Sub DrawString ( _
s As String, _
font As Font, _
brush As Brush, _
x As Single, _
y As Single, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EndContainer Method

GdiGraphics.EndContainer Method

Closes the current graphics container and restores the state of this GdiGraphics object to the state saved by a call to the BeginContainer method.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void EndContainer (
GraphicsContainer container
)
Visual Basic

Public Overridable Sub EndContainer ( _
container As GraphicsContainer _
)

Parameters

container
A .NET GraphicsContainer object that represents the container this method restores.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EndHyperLink Method

GdiGraphics.EndHyperLink Method

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void EndHyperLink ()
Visual Basic

Public Overridable Sub EndHyperLink ()

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method

GdiGraphics.EnumerateMetafile Method

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Overload List

Name | Description
GdiGraphics.EnumerateMetafile (Metafile, Point, Graphics.EnumerateMetafileProc) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Graphics.EnumerateMetafileProc) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, PointF, Graphics.EnumerateMetafileProc) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], Graphics.EnumerateMetafileProc) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Graphics.EnumerateMetafileProc) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, Graphics.EnumerateMetafileProc) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc)
See Also

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Graphics.EnumerateMetafileProc callback
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoint As Point, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr)
See Also

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoint As Point, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoint As Point, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoint As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoint As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Rectangle srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoint As Point, _
srcRect As Rectangle, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc)
See Also

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Graphics.EnumerateMetafileProc callback
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoints() As Point, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr)
See Also

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoints() As Point, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoints() As Point, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoints() As Point, _
srcRect As Rectangle, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc)
See Also

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
Graphics.EnumerateMetafileProc callback
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoint As PointF, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr)
See Also

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoint As PointF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoint As PointF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoint As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoint As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
RectangleF srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoint As PointF, _
srcRect As RectangleF, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc)
See Also

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
Graphics.EnumerateMetafileProc callback
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoints() As PointF, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr)
See Also

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoints() As PointF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoints() As PointF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET RectangleF structures that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destPoints() As PointF, _
srcRect As RectangleF, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc)
See Also

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Graphics.EnumerateMetafileProc callback
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destRect As Rectangle, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr)
See Also

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destRect As Rectangle, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destRect As Rectangle, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destRect As Rectangle, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destRect As Rectangle, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destRect As Rectangle, _
srcRect As Rectangle, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc)
See Also

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
Graphics.EnumerateMetafileProc callback
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destRect As RectangleF, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr)
See Also

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destRect As RectangleF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destRect As RectangleF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destRect As RectangleF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destRect As RectangleF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)
Visual Basic

Public Sub EnumerateMetafile ( _
metafile As Metafile, _
destRect As RectangleF, _
srcRect As RectangleF, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ExcludeClip Method

GdiGraphics.ExcludeClip Method

Updates the clip region of this GdiGraphics object to exclude the area specified by a .NET Rectangle structure.

Overload List

Name | Description
GdiGraphics.ExcludeClip (Rectangle) | Updates the clip region of this GdiGraphics object to exclude the area specified by a Rectangle structure.
GdiGraphics.ExcludeClip (Region) | Updates the clip region of this GdiGraphics object to exclude the area specified by a Region object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ExcludeClip Method (Rectangle)

GdiGraphics.ExcludeClip Method (Rectangle)
See Also

Updates the clip region of this GdiGraphics object to exclude the area specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void ExcludeClip (
Rectangle rect
)
Visual Basic

Public Overridable Sub ExcludeClip ( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure that specifies the rectangle to exclude from the clip region.

See Also

ExcludeClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ExcludeClip Method (Region)

GdiGraphics.ExcludeClip Method (Region)
See Also

Updates the clip region of this GdiGraphics object to exclude the area specified by a Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void ExcludeClip (
Region region
)
Visual Basic

Public Overridable Sub ExcludeClip ( _
region As Region _
)

Parameters

region
A .NET Region object that specifies the region to exclude from the clip region.

See Also

ExcludeClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method

GdiGraphics.FillClosedCurve Method

Fills the interior a closed cardinal spline curve defined by an array of Point structures.

Overload List

Name | Description
GdiGraphics.FillClosedCurve (Brush, Point[]) | Fills the interior a closed cardinal spline curve defined by an array of Point structures.
GdiGraphics.FillClosedCurve (Brush, Point[], FillMode) | Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode.
GdiGraphics.FillClosedCurve (Brush, Point[], FillMode, Single) | Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.
GdiGraphics.FillClosedCurve (Brush, PointF[]) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures.
GdiGraphics.FillClosedCurve (Brush, PointF[], FillMode) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode.
GdiGraphics.FillClosedCurve (Brush, PointF[], FillMode, Single) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, Point[])

GdiGraphics.FillClosedCurve Method (Brush, Point[])
See Also

Fills the interior a closed cardinal spline curve defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillClosedCurve (
Brush brush,
Point[] points
)
Visual Basic

Public Overridable Sub FillClosedCurve ( _
brush As Brush, _
points() As Point _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, Point[], FillMode)

GdiGraphics.FillClosedCurve Method (Brush, Point[], FillMode)
See Also

Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillClosedCurve (
Brush brush,
Point[] points,
FillMode fillmode
)
Visual Basic

Public Overridable Sub FillClosedCurve ( _
brush As Brush, _
points() As Point, _
fillmode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, Point[], FillMode, Single)

GdiGraphics.FillClosedCurve Method (Brush, Point[], FillMode, Single)
See Also

Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillClosedCurve (
Brush brush,
Point[] points,
FillMode fillmode,
float tension
)
Visual Basic

Public Overridable Sub FillClosedCurve ( _
brush As Brush, _
points() As Point, _
fillmode As FillMode, _
tension As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, PointF[])

GdiGraphics.FillClosedCurve Method (Brush, PointF[])
See Also

Fills the interior a closed cardinal spline curve defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillClosedCurve (
Brush brush,
PointF[] points
)
Visual Basic

Public Overridable Sub FillClosedCurve ( _
brush As Brush, _
points() As PointF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, PointF[], FillMode)

GdiGraphics.FillClosedCurve Method (Brush, PointF[], FillMode)
See Also

Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillClosedCurve (
Brush brush,
PointF[] points,
FillMode fillmode
)
Visual Basic

Public Overridable Sub FillClosedCurve ( _
brush As Brush, _
points() As PointF, _
fillmode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, PointF[], FillMode, Single)

GdiGraphics.FillClosedCurve Method (Brush, PointF[], FillMode, Single)
See Also

Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillClosedCurve (
Brush brush,
PointF[] points,
FillMode fillmode,
float tension
)
Visual Basic

Public Overridable Sub FillClosedCurve ( _
brush As Brush, _
points() As PointF, _
fillmode As FillMode, _
tension As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method

GdiGraphics.FillEllipse Method

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
GdiGraphics.FillEllipse (Brush, Int32, Int32, Int32, Int32) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
GdiGraphics.FillEllipse (Brush, Rectangle) | Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.
GdiGraphics.FillEllipse (Brush, RectangleF) | Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.
GdiGraphics.FillEllipse (Brush, Single, Single, Single, Single) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method (Brush, Int32, Int32, Int32, Int32)

GdiGraphics.FillEllipse Method (Brush, Int32, Int32, Int32, Int32)
See Also

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillEllipse (
Brush brush,
int x,
int y,
int width,
int height
)
Visual Basic

Public Overridable Sub FillEllipse ( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method (Brush, Rectangle)

GdiGraphics.FillEllipse Method (Brush, Rectangle)
See Also

Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillEllipse (
Brush brush,
Rectangle rect
)
Visual Basic

Public Overridable Sub FillEllipse ( _
brush As Brush, _
rect As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method (Brush, RectangleF)

GdiGraphics.FillEllipse Method (Brush, RectangleF)
See Also

Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillEllipse (
Brush brush,
RectangleF rect
)
Visual Basic

Public Overridable Sub FillEllipse ( _
brush As Brush, _
rect As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET RectangleF structure that represents the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method (Brush, Single, Single, Single, Single)

GdiGraphics.FillEllipse Method (Brush, Single, Single, Single, Single)
See Also

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillEllipse (
Brush brush,
float x,
float y,
float width,
float height
)
Visual Basic

Public Overridable Sub FillEllipse ( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPath Method

GdiGraphics.FillPath Method

Fills the interior of a .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillPath (
Brush brush,
GraphicsPath path
)
Visual Basic

Public Overridable Sub FillPath ( _
brush As Brush, _
path As GraphicsPath _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
path
A .NET GraphicsPath object that represents the path to fill.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPie Method

GdiGraphics.FillPie Method

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Overload List

Name | Description
GdiGraphics.FillPie (Brush, Int32, Int32, Int32, Int32, Int32, Int32) | Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
GdiGraphics.FillPie (Brush, Rectangle, Single, Single) | Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.
GdiGraphics.FillPie (Brush, Single, Single, Single, Single, Single, Single) | Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPie Method (Brush, Int32, Int32, Int32, Int32, Int32, Int32)

GdiGraphics.FillPie Method (Brush, Int32, Int32, Int32, Int32, Int32, Int32)
See Also

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillPie (
Brush brush,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)
Visual Basic

Public Overridable Sub FillPie ( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPie Method (Brush, Rectangle, Single, Single)

GdiGraphics.FillPie Method (Brush, Rectangle, Single, Single)
See Also

Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillPie (
Brush brush,
Rectangle rect,
float startAngle,
float sweepAngle
)
Visual Basic

Public Overridable Sub FillPie ( _
brush As Brush, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPie Method (Brush, Single, Single, Single, Single, Single, Single)

GdiGraphics.FillPie Method (Brush, Single, Single, Single, Single, Single, Single)
See Also

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillPie (
Brush brush,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)
Visual Basic

Public Overridable Sub FillPie ( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method

GdiGraphics.FillPolygon Method

Fills the interior of a polygon defined by an array of points specified by Point structures.

Overload List

Name | Description
GdiGraphics.FillPolygon (Brush, Point[]) | Fills the interior of a polygon defined by an array of points specified by Point structures.
GdiGraphics.FillPolygon (Brush, Point[], FillMode) | Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.
GdiGraphics.FillPolygon (Brush, PointF[]) | Fills the interior of a polygon defined by an array of points specified by PointF structures.
GdiGraphics.FillPolygon (Brush, PointF[], FillMode) | Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method (Brush, Point[])

GdiGraphics.FillPolygon Method (Brush, Point[])
See Also

Fills the interior of a polygon defined by an array of points specified by Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillPolygon (
Brush brush,
Point[] points
)
Visual Basic

Public Overridable Sub FillPolygon ( _
brush As Brush, _
points() As Point _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that represent the vertices of the polygon to fill.

See Also

FillPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method (Brush, Point[], FillMode)

GdiGraphics.FillPolygon Method (Brush, Point[], FillMode)
See Also

Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillPolygon (
Brush brush,
Point[] points,
FillMode fillMode
)
Visual Basic

Public Overridable Sub FillPolygon ( _
brush As Brush, _
points() As Point, _
fillMode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that represent the vertices of the polygon to fill.
fillMode
Member of the .NET FillMode enumeration that determines the style of the fill.

See Also

FillPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method (Brush, PointF[])

GdiGraphics.FillPolygon Method (Brush, PointF[])
See Also

Fills the interior of a polygon defined by an array of points specified by PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillPolygon (
Brush brush,
PointF[] points
)
Visual Basic

Public Overridable Sub FillPolygon ( _
brush As Brush, _
points() As PointF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that represent the vertices of the polygon to fill.

See Also

FillPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method (Brush, PointF[], FillMode)

GdiGraphics.FillPolygon Method (Brush, PointF[], FillMode)
See Also

Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillPolygon (
Brush brush,
PointF[] points,
FillMode fillMode
)
Visual Basic

Public Overridable Sub FillPolygon ( _
brush As Brush, _
points() As PointF, _
fillMode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that represent the vertices of the polygon to fill.
fillMode
Member of the .NET FillMode enumeration that determines the style of the fill.

See Also

FillPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method

GdiGraphics.FillRectangle Method

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
GdiGraphics.FillRectangle (Brush, Int32, Int32, Int32, Int32) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
GdiGraphics.FillRectangle (Brush, Rectangle) | Fills the interior of a rectangle specified by a Rectangle structure.
GdiGraphics.FillRectangle (Brush, RectangleF) | Fills the interior of a rectangle specified by a RectangleF structure.
GdiGraphics.FillRectangle (Brush, Single, Single, Single, Single) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method (Brush, Int32, Int32, Int32, Int32)

GdiGraphics.FillRectangle Method (Brush, Int32, Int32, Int32, Int32)
See Also

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillRectangle (
Brush brush,
int x,
int y,
int width,
int height
)
Visual Basic

Public Overridable Sub FillRectangle ( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
The width of the rectangle to fill.
height
The height of the rectangle to fill.

See Also

FillRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method (Brush, Rectangle)

GdiGraphics.FillRectangle Method (Brush, Rectangle)
See Also

Fills the interior of a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillRectangle (
Brush brush,
Rectangle rect
)
Visual Basic

Public Overridable Sub FillRectangle ( _
brush As Brush, _
rect As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the rectangle to fill.

See Also

FillRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method (Brush, RectangleF)

GdiGraphics.FillRectangle Method (Brush, RectangleF)
See Also

Fills the interior of a rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillRectangle (
Brush brush,
RectangleF rect
)
Visual Basic

Public Overridable Sub FillRectangle ( _
brush As Brush, _
rect As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET RectangleF structure that represents the rectangle to fill.

See Also

FillRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method (Brush, Single, Single, Single, Single)

GdiGraphics.FillRectangle Method (Brush, Single, Single, Single, Single)
See Also

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillRectangle (
Brush brush,
float x,
float y,
float width,
float height
)
Visual Basic

Public Overridable Sub FillRectangle ( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
The width of the rectangle to fill.
height
The height of the rectangle to fill.

See Also

FillRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangles Method

GdiGraphics.FillRectangles Method

Fills the interiors of a series of rectangles specified by Rectangle structures.

Overload List

Name | Description
GdiGraphics.FillRectangles (Brush, Rectangle[]) | Fills the interiors of a series of rectangles specified by Rectangle structures.
GdiGraphics.FillRectangles (Brush, RectangleF[]) | Fills the interiors of a series of rectangles specified by RectangleF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangles Method (Brush, Rectangle[])

GdiGraphics.FillRectangles Method (Brush, Rectangle[])
See Also

Fills the interiors of a series of rectangles specified by Rectangle structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillRectangles (
Brush brush,
Rectangle[] rects
)
Visual Basic

Public Overridable Sub FillRectangles ( _
brush As Brush, _
rects() As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rects
An array of .NET Rectangle structures that represent the rectangles to fill.

See Also

FillRectangles Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangles Method (Brush, RectangleF[])

GdiGraphics.FillRectangles Method (Brush, RectangleF[])
See Also

Fills the interiors of a series of rectangles specified by RectangleF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillRectangles (
Brush brush,
RectangleF[] rects
)
Visual Basic

Public Overridable Sub FillRectangles ( _
brush As Brush, _
rects() As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rects
An array of .NET RectangleF structures that represent the rectangles to fill.

See Also

FillRectangles Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRegion Method

GdiGraphics.FillRegion Method

Fills the interior of a .NET Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void FillRegion (
Brush brush,
Region region
)
Visual Basic

Public Overridable Sub FillRegion ( _
brush As Brush, _
region As Region _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
region
A .NET Region object that represents the area to fill.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Flush Method

GdiGraphics.Flush Method

Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.

Overload List

Name | Description
GdiGraphics.Flush () | Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GdiGraphics.Flush (FlushIntention) | Forces execution of all pending graphics operations with the method waiting or not waiting, as specified, to return before the operations finish.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Flush Method ()

GdiGraphics.Flush Method ()
See Also

Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void Flush ()
Visual Basic

Public Overridable Sub Flush ()

See Also

Flush Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Flush Method (FlushIntention)

GdiGraphics.Flush Method (FlushIntention)
See Also

Forces execution of all pending graphics operations with the method waiting or not waiting, as specified, to return before the operations finish.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void Flush (
FlushIntention intention
)
Visual Basic

Public Overridable Sub Flush ( _
intention As FlushIntention _
)

Parameters

intention
Member of the .NET FlushIntention enumeration that specifies whether the method returns immediately or waits for any existing operations to finish.

See Also

Flush Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.GetFontHeight Method

GdiGraphics.GetFontHeight Method

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual float GetFontHeight (
Font font
)
Visual Basic

Public Overridable Function GetFontHeight ( _
font As Font _
) As Single

Parameters

font

Return Value

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.GetHdc Method

GdiGraphics.GetHdc Method

Gets the handle to the device context associated with this GdiGraphics.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual IntPtr GetHdc ()
Visual Basic

Public Overridable Function GetHdc () As IntPtr

Return Value

Handle to the device context associated with this GdiGraphics.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.GetNearestColor Method

GdiGraphics.GetNearestColor Method

Gets the nearest color to the specified Color structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual Color GetNearestColor (
Color color
)
Visual Basic

Public Overridable Function GetNearestColor ( _
color As Color _
) As Color

Parameters

color
A .NET Color structure for which to find a match.

Return Value

A .NET Color structure that represents the nearest color to the one specified with the color parameter.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IntersectClip Method

GdiGraphics.IntersectClip Method

Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.

Overload List

Name | Description
GdiGraphics.IntersectClip (Rectangle) | Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.
GdiGraphics.IntersectClip (RectangleF) | Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified RectangleF structure.
GdiGraphics.IntersectClip (Region) | Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Region object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IntersectClip Method (Rectangle)

GdiGraphics.IntersectClip Method (Rectangle)
See Also

Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void IntersectClip (
Rectangle rect
)
Visual Basic

Public Overridable Sub IntersectClip ( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure to intersect with the current clip region.

See Also

IntersectClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IntersectClip Method (RectangleF)

GdiGraphics.IntersectClip Method (RectangleF)
See Also

Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void IntersectClip (
RectangleF rect
)
Visual Basic

Public Overridable Sub IntersectClip ( _
rect As RectangleF _
)

Parameters

rect
A .NET RectangleF structure to intersect with the current clip region.

See Also

IntersectClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IntersectClip Method (Region)

GdiGraphics.IntersectClip Method (Region)
See Also

Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void IntersectClip (
Region region
)
Visual Basic

Public Overridable Sub IntersectClip ( _
region As Region _
)

Parameters

region
A .NET Region object to intersect with the current region.

See Also

IntersectClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method

GdiGraphics.IsVisible Method

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.IsVisible (Int32, Int32) | Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Int32, Int32, Int32, Int32) | Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Point) | Indicates whether the specified Point structure is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (PointF) | Indicates whether the specified PointF structure is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Rectangle) | Indicates whether the rectangle specified by a Rectangle structure is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (RectangleF) | Indicates whether the rectangle specified by a RectangleF structure is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Single, Single) | Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Single, Single, Single, Single) | Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Int32, Int32)

GdiGraphics.IsVisible Method (Int32, Int32)
See Also

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual bool IsVisible (
int x,
int y
)
Visual Basic

Public Overridable Function IsVisible ( _
x As Integer, _
y As Integer _
) As Boolean

Parameters

x
The x-coordinate of the point to test for visibility.
y
The y-coordinate of the point to test for visibility.

Return Value

This method returns true if the point defined by the x and y parameters is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Int32, Int32, Int32, Int32)

GdiGraphics.IsVisible Method (Int32, Int32, Int32, Int32)
See Also

Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual bool IsVisible (
int x,
int y,
int width,
int height
)
Visual Basic

Public Overridable Function IsVisible ( _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
) As Boolean

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test for visibility.
y
The y-coordinate of the upper-left corner of the rectangle to test for visibility.
width
The width of the rectangle to test for visibility.
height
The height of the rectangle to test for visibility.

Return Value

This method returns true if the rectangle defined by the x, y, width, and height parameters is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Point)

GdiGraphics.IsVisible Method (Point)
See Also

Indicates whether the specified Point structure is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual bool IsVisible (
Point point
)
Visual Basic

Public Overridable Function IsVisible ( _
point As Point _
) As Boolean

Parameters

point
A .NET Point structure to test for visibility.

Return Value

This method returns true if the point specified by the point parameter is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (PointF)

GdiGraphics.IsVisible Method (PointF)
See Also

Indicates whether the specified PointF structure is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual bool IsVisible (
PointF point
)
Visual Basic

Public Overridable Function IsVisible ( _
point As PointF _
) As Boolean

Parameters

point
A .NET PointF structure to test for visibility.

Return Value

This method returns true if the point specified by the point parameter is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Rectangle)

GdiGraphics.IsVisible Method (Rectangle)
See Also

Indicates whether the rectangle specified by a Rectangle structure is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual bool IsVisible (
Rectangle rect
)
Visual Basic

Public Overridable Function IsVisible ( _
rect As Rectangle _
) As Boolean

Parameters

rect
A .NET Rectangle structure to test for visibility.

Return Value

This method returns true if the rectangle specified by the rect parameter is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (RectangleF)

GdiGraphics.IsVisible Method (RectangleF)
See Also

Indicates whether the rectangle specified by a RectangleF structure is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual bool IsVisible (
RectangleF rect
)
Visual Basic

Public Overridable Function IsVisible ( _
rect As RectangleF _
) As Boolean

Parameters

rect
A .NET RectangleF structure to test for visibility.

Return Value

This method returns true if the rectangle specified by the rect parameter is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Single, Single)

GdiGraphics.IsVisible Method (Single, Single)
See Also

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual bool IsVisible (
float x,
float y
)
Visual Basic

Public Overridable Function IsVisible ( _
x As Single, _
y As Single _
) As Boolean

Parameters

x
The x-coordinate of the point to test for visibility.
y
The y-coordinate of the point to test for visibility.

Return Value

This method returns true if the point defined by the x and y parameters is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Single, Single, Single, Single)

GdiGraphics.IsVisible Method (Single, Single, Single, Single)
See Also

Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual bool IsVisible (
float x,
float y,
float width,
float height
)
Visual Basic

Public Overridable Function IsVisible ( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As Boolean

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test for visibility.
y
The y-coordinate of the upper-left corner of the rectangle to test for visibility.
width
The width of the rectangle to test for visibility.
height
The height of the rectangle to test for visibility.

Return Value

This method returns true if the rectangle defined by the x, y, width, and height parameters is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureCharacterRanges Method

GdiGraphics.MeasureCharacterRanges Method

Gets an array of Region objects, each of which bounds a range of character positions within the specified string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual RectangleF[] MeasureCharacterRanges (
string text,
Font font,
RectangleF layoutRect,
StringFormat stringFormat
)
Visual Basic

Public Overridable Function MeasureCharacterRanges ( _
text As String, _
font As Font, _
layoutRect As RectangleF, _
stringFormat As StringFormat _
) As RectangleF()

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
layoutRect
A .NET RectangleF structure that specifies the layout rectangle for the string.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns an array of .NET Region objects, each of which bounds a range of character positions within the specified string.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method

GdiGraphics.MeasureString Method

Measures the specified string when drawn with the specified Font object.

Overload List

Name | Description
GdiGraphics.MeasureString (String, Font) | Measures the specified string when drawn with the specified Font object.
GdiGraphics.MeasureString (String, Font, Int32) | Measures the specified string when drawn with the specified Font object.
GdiGraphics.MeasureString (String, Font, Int32, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
GdiGraphics.MeasureString (String, Font, PointF, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
GdiGraphics.MeasureString (String, Font, SizeF) | Measures the specified string when drawn with the specified Font object within the specified layout area.
GdiGraphics.MeasureString (String, Font, SizeF, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
GdiGraphics.MeasureString (String, Font, SizeF, StringFormat, Int32@, Int32@) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font)

GdiGraphics.MeasureString Method (String, Font)
See Also

Measures the specified string when drawn with the specified Font object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual SizeF MeasureString (
string text,
Font font
)
Visual Basic

Public Overridable Function MeasureString ( _
text As String, _
font As Font _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified by the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, Int32)

GdiGraphics.MeasureString Method (String, Font, Int32)
See Also

Measures the specified string when drawn with the specified Font object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual SizeF MeasureString (
string text,
Font font,
int width
)
Visual Basic

Public Overridable Function MeasureString ( _
text As String, _
font As Font, _
width As Integer _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the format of the string.
width
The maximum width of the string in pixels.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, Int32, StringFormat)

GdiGraphics.MeasureString Method (String, Font, Int32, StringFormat)
See Also

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual SizeF MeasureString (
string text,
Font font,
int width,
StringFormat format
)
Visual Basic

Public Overridable Function MeasureString ( _
text As String, _
font As Font, _
width As Integer, _
format As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
width
The maximum width of the string.
format
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, PointF, StringFormat)

GdiGraphics.MeasureString Method (String, Font, PointF, StringFormat)
See Also

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual SizeF MeasureString (
string text,
Font font,
PointF origin,
StringFormat stringFormat
)
Visual Basic

Public Overridable Function MeasureString ( _
text As String, _
font As Font, _
origin As PointF, _
stringFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
origin
A .NET PointF structure that represents the upper-left corner of the string.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size of the string, in pixels, of the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, SizeF)

GdiGraphics.MeasureString Method (String, Font, SizeF)
See Also

Measures the specified string when drawn with the specified Font object within the specified layout area.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual SizeF MeasureString (
string text,
Font font,
SizeF layoutArea
)
Visual Basic

Public Overridable Function MeasureString ( _
text As String, _
font As Font, _
layoutArea As SizeF _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, SizeF, StringFormat)

GdiGraphics.MeasureString Method (String, Font, SizeF, StringFormat)
See Also

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual SizeF MeasureString (
string text,
Font font,
SizeF layoutArea,
StringFormat stringFormat
)
Visual Basic

Public Overridable Function MeasureString ( _
text As String, _
font As Font, _
layoutArea As SizeF, _
stringFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, SizeF, StringFormat, Int32@, Int32@)

GdiGraphics.MeasureString Method (String, Font, SizeF, StringFormat, Int32@, Int32@)
See Also

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual SizeF MeasureString (
string text,
Font font,
SizeF layoutArea,
StringFormat stringFormat,
ref int charactersFitted,
ref int linesFilled
)
Visual Basic

Public Overridable Function MeasureString ( _
text As String, _
font As Font, _
layoutArea As SizeF, _
stringFormat As StringFormat, _
ByRef charactersFitted As Integer, _
ByRef linesFilled As Integer _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.
charactersFitted
Number of characters in the string.
linesFilled
Number of text lines in the string.

Return Value

This method returns a .NET SizeF structure that represents the size of the string, in pixels, of the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MultiplyTransform Method

GdiGraphics.MultiplyTransform Method

Multiplies the world transformation of this GdiGraphics object and specified the .NET Matrix object.

Overload List

Name | Description
GdiGraphics.MultiplyTransform (Matrix) | Multiplies the world transformation of this GdiGraphics object and specified the Matrix object.
GdiGraphics.MultiplyTransform (Matrix, MatrixOrder) | Multiplies the world transformation of this GdiGraphics object and specified the Matrix object in the specified order.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MultiplyTransform Method (Matrix)

GdiGraphics.MultiplyTransform Method (Matrix)
See Also

Multiplies the world transformation of this GdiGraphics object and specified the Matrix object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void MultiplyTransform (
Matrix matrix
)
Visual Basic

Public Overridable Sub MultiplyTransform ( _
matrix As Matrix _
)

Parameters

matrix
A 4x4 .NET Matrix object that multiplies the world transformation.

See Also

MultiplyTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MultiplyTransform Method (Matrix, MatrixOrder)

GdiGraphics.MultiplyTransform Method (Matrix, MatrixOrder)
See Also

Multiplies the world transformation of this GdiGraphics object and specified the Matrix object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void MultiplyTransform (
Matrix matrix,
MatrixOrder order
)
Visual Basic

Public Overridable Sub MultiplyTransform ( _
matrix As Matrix, _
order As MatrixOrder _
)

Parameters

matrix
A 4x4 .NET Matrix object that multiplies the world transformation.
order
Member of the .NET MatrixOrder enumeration that determines the order of the multiplication.

See Also

MultiplyTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ReleaseHdc Method

GdiGraphics.ReleaseHdc Method

Releases a device context handle obtained by a previous call to the GetHdc method of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void ReleaseHdc (
IntPtr hdc
)
Visual Basic

Public Overridable Sub ReleaseHdc ( _
hdc As IntPtr _
)

Parameters

hdc
Handle to a device context obtained by a previous call to the GetHdc method of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ReleaseHdcInternal Method

GdiGraphics.ReleaseHdcInternal Method

Internal method. Do not use.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void ReleaseHdcInternal (
IntPtr hdc
)
Visual Basic

Public Overridable Sub ReleaseHdcInternal ( _
hdc As IntPtr _
)

Parameters

hdc
Handle to a device context.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ResetClip Method

GdiGraphics.ResetClip Method

Resets the clip region of this GdiGraphics object to an infinite region.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void ResetClip ()
Visual Basic

Public Overridable Sub ResetClip ()

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ResetTransform Method

GdiGraphics.ResetTransform Method

Resets the world transformation matrix of this GdiGraphics object to the identity matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void ResetTransform ()
Visual Basic

Public Overridable Sub ResetTransform ()

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Restore Method

GdiGraphics.Restore Method

Restores the state of this GdiGraphics object to the state represented by a GraphicsState object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void Restore (
GraphicsState gstate
)
Visual Basic

Public Overridable Sub Restore ( _
gstate As GraphicsState _
)

Parameters

gstate
A .NET GraphicsState object that represents the state to which to restore this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.RotateTransform Method

GdiGraphics.RotateTransform Method

Applies the specified rotation to the transformation matrix of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.RotateTransform (Single) | Applies the specified rotation to the transformation matrix of this GdiGraphics object.
GdiGraphics.RotateTransform (Single, MatrixOrder) | Applies the specified rotation to the transformation matrix of this GdiGraphics object in the specified order.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.RotateTransform Method (Single)

GdiGraphics.RotateTransform Method (Single)
See Also

Applies the specified rotation to the transformation matrix of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void RotateTransform (
float angle
)
Visual Basic

Public Overridable Sub RotateTransform ( _
angle As Single _
)

Parameters

angle
The angle of rotation in degrees.

See Also

RotateTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.RotateTransform Method (Single, MatrixOrder)

GdiGraphics.RotateTransform Method (Single, MatrixOrder)
See Also

Applies the specified rotation to the transformation matrix of this GdiGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void RotateTransform (
float angle,
MatrixOrder order
)
Visual Basic

Public Overridable Sub RotateTransform ( _
angle As Single, _
order As MatrixOrder _
)

Parameters

angle
The angle of rotation in degrees.
order
Member of the .NET MatrixOrder enumeration that specifies whether the rotation is appended or prepended to the matrix transformation.

See Also

RotateTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Save Method

GdiGraphics.Save Method

Saves the current state of this GdiGraphics object and identifies the saved state with a GraphicsState object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual GraphicsState Save ()
Visual Basic

Public Overridable Function Save () As GraphicsState

Return Value

This method returns a .NET GraphicsState object that represents the saved state of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ScaleTransform Method

GdiGraphics.ScaleTransform Method

Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.

Overload List

Name | Description
GdiGraphics.ScaleTransform (Single, Single) | Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.
GdiGraphics.ScaleTransform (Single, Single, MatrixOrder) | Applies the specified scaling operation to the transformation matrix of this GdiGraphics object in the specified order.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ScaleTransform Method (Single, Single)

GdiGraphics.ScaleTransform Method (Single, Single)
See Also

Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void ScaleTransform (
float sx,
float sy
)
Visual Basic

Public Overridable Sub ScaleTransform ( _
sx As Single, _
sy As Single _
)

Parameters

sx
The scale factor in the x direction.
sy
The scale factor in the y direction.

See Also

ScaleTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ScaleTransform Method (Single, Single, MatrixOrder)

GdiGraphics.ScaleTransform Method (Single, Single, MatrixOrder)
See Also

Applies the specified scaling operation to the transformation matrix of this GdiGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void ScaleTransform (
float sx,
float sy,
MatrixOrder order
)
Visual Basic

Public Overridable Sub ScaleTransform ( _
sx As Single, _
sy As Single, _
order As MatrixOrder _
)

Parameters

sx
The scale factor in the x direction.
sy
The scale factor in the y direction.
order
Member of the .NET MatrixOrder enumeration that specifies whether the scaling operation is prepended or appended to the transformation matrix.

See Also

ScaleTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method

GdiGraphics.SetClip Method

Sets the clipping region of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.SetClip (GraphicsPath) | Sets the clipping region of this GdiGraphics object to the specified .NET GraphicsPath object.
GdiGraphics.SetClip (GraphicsPath, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the specified .NET GraphicsPath object.
GdiGraphics.SetClip (IGraphics) | Sets the clipping region of this GdiGraphics object to the Clip property of the specified IGraphics object.
GdiGraphics.SetClip (IGraphics, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified combining operation of the current clip region and the Clip property of the specified IGraphics object.
GdiGraphics.SetClip (Rectangle) | Sets the clipping region of this GdiGraphics object to the rectangle specified by a Rectangle structure.
GdiGraphics.SetClip (Rectangle, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a Rectangle structure.
GdiGraphics.SetClip (RectangleF) | Sets the clipping region of this GdiGraphics object to the rectangle specified by a RectangleF structure.
GdiGraphics.SetClip (RectangleF, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a RectangleF structure.
GdiGraphics.SetClip (Region, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the specified Region object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (GraphicsPath)

GdiGraphics.SetClip Method (GraphicsPath)
See Also

Sets the clipping region of this GdiGraphics object to the specified .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void SetClip (
GraphicsPath path
)
Visual Basic

Public Overridable Sub SetClip ( _
path As GraphicsPath _
)

Parameters

path
A .NET GraphicsPath object that represents the new clip region.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (GraphicsPath, CombineMode)

GdiGraphics.SetClip Method (GraphicsPath, CombineMode)
See Also

Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the specified .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void SetClip (
GraphicsPath path,
CombineMode combineMode
)
Visual Basic

Public Overridable Sub SetClip ( _
path As GraphicsPath, _
combineMode As CombineMode _
)

Parameters

path
A .NET GraphicsPath object to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (IGraphics)

GdiGraphics.SetClip Method (IGraphics)
See Also

Sets the clipping region of this GdiGraphics object to the Clip property of the specified IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void SetClip (
IGraphics g
)
Visual Basic

Public Overridable Sub SetClip ( _
g As IGraphics _
)

Parameters

g
An IGraphics object from which to take the new clip region.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (IGraphics, CombineMode)

GdiGraphics.SetClip Method (IGraphics, CombineMode)
See Also

Sets the clipping region of this GdiGraphics object to the result of the specified combining operation of the current clip region and the Clip property of the specified IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void SetClip (
IGraphics g,
CombineMode combineMode
)
Visual Basic

Public Overridable Sub SetClip ( _
g As IGraphics, _
combineMode As CombineMode _
)

Parameters

g
An IGraphics object that specifies the clip region to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (Rectangle)

GdiGraphics.SetClip Method (Rectangle)
See Also

Sets the clipping region of this GdiGraphics object to the rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void SetClip (
Rectangle rect
)
Visual Basic

Public Overridable Sub SetClip ( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure that represents the new clip region.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (Rectangle, CombineMode)

GdiGraphics.SetClip Method (Rectangle, CombineMode)
See Also

Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void SetClip (
Rectangle rect,
CombineMode combineMode
)
Visual Basic

Public Overridable Sub SetClip ( _
rect As Rectangle, _
combineMode As CombineMode _
)

Parameters

rect
A .NET Rectangle structure to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (RectangleF)

GdiGraphics.SetClip Method (RectangleF)
See Also

Sets the clipping region of this GdiGraphics object to the rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void SetClip (
RectangleF rect
)
Visual Basic

Public Overridable Sub SetClip ( _
rect As RectangleF _
)

Parameters

rect
A .NET RectangleF structure that represents the new clip region.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (RectangleF, CombineMode)

GdiGraphics.SetClip Method (RectangleF, CombineMode)
See Also

Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void SetClip (
RectangleF rect,
CombineMode combineMode
)
Visual Basic

Public Overridable Sub SetClip ( _
rect As RectangleF, _
combineMode As CombineMode _
)

Parameters

rect
A .NET RectangleF structure to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (Region, CombineMode)

GdiGraphics.SetClip Method (Region, CombineMode)
See Also

Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the specified Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void SetClip (
Region region,
CombineMode combineMode
)
Visual Basic

Public Overridable Sub SetClip ( _
region As Region, _
combineMode As CombineMode _
)

Parameters

region
A .NET Region object to combine.
combineMode
Member from the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TransformPoints Method

GdiGraphics.TransformPoints Method

Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.TransformPoints (CoordinateSpace, CoordinateSpace, Point[]) | Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.
GdiGraphics.TransformPoints (CoordinateSpace, CoordinateSpace, PointF[]) | Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, Point[])

GdiGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, Point[])
See Also

Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void TransformPoints (
CoordinateSpace destSpace,
CoordinateSpace srcSpace,
Point[] pts
)
Visual Basic

Public Overridable Sub TransformPoints ( _
destSpace As CoordinateSpace, _
srcSpace As CoordinateSpace, _
pts() As Point _
)

Parameters

destSpace
Member of the .NET CoordinateSpace enumeration that specifies the destination coordinate space.
srcSpace
Member of the .NET CoordinateSpace enumeration that specifies the source coordinate space.
pts
An array of .NET Point structures that represents the points to transformation.

See Also

TransformPoints Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, PointF[])

GdiGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, PointF[])
See Also

Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void TransformPoints (
CoordinateSpace destSpace,
CoordinateSpace srcSpace,
PointF[] pts
)
Visual Basic

Public Overridable Sub TransformPoints ( _
destSpace As CoordinateSpace, _
srcSpace As CoordinateSpace, _
pts() As PointF _
)

Parameters

destSpace
Member of the .NET CoordinateSpace enumeration that specifies the destination coordinate space.
srcSpace
Member of the .NET CoordinateSpace enumeration that specifies the source coordinate space.
pts
An array of .NET PointF structures that represent the points to transform.

See Also

TransformPoints Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateClip Method

GdiGraphics.TranslateClip Method

Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.

Overload List

Name | Description
GdiGraphics.TranslateClip (Int32, Int32) | Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.
GdiGraphics.TranslateClip (Single, Single) | Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateClip Method (Int32, Int32)

GdiGraphics.TranslateClip Method (Int32, Int32)
See Also

Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void TranslateClip (
int dx,
int dy
)
Visual Basic

Public Overridable Sub TranslateClip ( _
dx As Integer, _
dy As Integer _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateClip Method (Single, Single)

GdiGraphics.TranslateClip Method (Single, Single)
See Also

Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void TranslateClip (
float dx,
float dy
)
Visual Basic

Public Overridable Sub TranslateClip ( _
dx As Single, _
dy As Single _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateTransform Method

GdiGraphics.TranslateTransform Method

Prepends the specified translation to the transformation matrix of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.TranslateTransform (Single, Single) | Prepends the specified translation to the transformation matrix of this GdiGraphics object.
GdiGraphics.TranslateTransform (Single, Single, MatrixOrder) | Applies the specified translation to the transformation matrix of this GdiGraphics object in the specified order.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateTransform Method (Single, Single)

GdiGraphics.TranslateTransform Method (Single, Single)
See Also

Prepends the specified translation to the transformation matrix of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void TranslateTransform (
float dx,
float dy
)
Visual Basic

Public Overridable Sub TranslateTransform ( _
dx As Single, _
dy As Single _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateTransform Method (Single, Single, MatrixOrder)

GdiGraphics.TranslateTransform Method (Single, Single, MatrixOrder)
See Also

Applies the specified translation to the transformation matrix of this GdiGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void TranslateTransform (
float dx,
float dy,
MatrixOrder order
)
Visual Basic

Public Overridable Sub TranslateTransform ( _
dx As Single, _
dy As Single, _
order As MatrixOrder _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.
order
Member of the .NET MatrixOrder enumeration that specifies whether the translation is prepended or appended to the transformation matrix.

See Also

TranslateTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Properties

GdiGraphics Properties

Public Properties

Name | Description
Clip | Gets or sets a .NET Region object that limits the drawing region of this GdiGraphics object.
ClipBounds | Gets a .NET RectangleF structure that bounds the clipping region of this GdiGraphics object.
CompositingMode | Gets or sets a value that specifies how composited images are drawn to this GdiGraphics object.
CompositingQuality | Gets or sets the rendering quality of composited images drawn to this GdiGraphics object.
DpiX | Gets the horizontal resolution of this GdiGraphics object.
DpiY | Gets the vertical resolution of this GdiGraphics object.
Graphics | Gets a reference to the underlying .NET Graphics object.
InterpolationMode | Gets or sets the interpolation mode associated with this GdiGraphics object.
IsClipEmpty | Gets a value indicating whether the clipping region of this GdiGraphics object is empty.
IsVisibleClipEmpty | Gets a value indicating whether the visible clipping region of this GdiGraphics object is empty.
PageScale | Gets or sets the scaling between world units and page units for this GdiGraphics object.
PageUnit | Gets or sets the unit of measure used for page coordinates in this GdiGraphics object.
PixelOffsetMode | Gets or set a value specifying how pixels are offset during rendering of this GdiGraphics object.
RenderingOrigin | Gets or sets the rendering origin of this GdiGraphics object for dithering and for hatch brushes.
SmoothingMode | Gets or sets the rendering quality for this GdiGraphics object.
TextContrast | Gets or sets the gamma correction value for rendering text.
TextRenderingHint | Gets or sets the rendering mode for text associated with this GdiGraphics object.
Transform | Gets or sets the world transformation for this GdiGraphics object.
VisibleClipBounds | Gets the bounding rectangle of the visible clipping region of this GdiGraphics object.

See Also

GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Clip Property

GdiGraphics.Clip Property

Gets or sets a .NET Region object that limits the drawing region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual Region Clip { get; set; }
Visual Basic

Public Overridable Property Clip As Region

Property Value

This property specifies a .NET Region object that limits the portion of this GdiGraphics object that is currently available for drawing.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ClipBounds Property

GdiGraphics.ClipBounds Property

Gets a .NET RectangleF structure that bounds the clipping region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual RectangleF ClipBounds { get; }
Visual Basic

Public Overridable ReadOnly Property ClipBounds As RectangleF

Property Value

This property indicates a .NET RectangleF structure that represents a bounding rectangle for the clipping region of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.CompositingMode Property

GdiGraphics.CompositingMode Property

Gets or sets a value that specifies how composited images are drawn to this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual CompositingMode CompositingMode { get; set; }
Visual Basic

Public Overridable Property CompositingMode As CompositingMode

Property Value

This property specifies a member of the .NET CompositingMode enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.CompositingQuality Property

GdiGraphics.CompositingQuality Property

Gets or sets the rendering quality of composited images drawn to this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual CompositingQuality CompositingQuality { get; set; }
Visual Basic

Public Overridable Property CompositingQuality As CompositingQuality

Property Value

This property specifies a member of the .NET CompositingQuality enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DpiX Property

GdiGraphics.DpiX Property

Gets the horizontal resolution of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual float DpiX { get; }
Visual Basic

Public Overridable ReadOnly Property DpiX As Single

Property Value

This property indicates a value, in dots per inch, for the horizontal resolution supported by this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DpiY Property

GdiGraphics.DpiY Property

Gets the vertical resolution of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual float DpiY { get; }
Visual Basic

Public Overridable ReadOnly Property DpiY As Single

Property Value

This property indicates a value, in dots per inch, for the vertical resolution supported by this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Graphics Property

GdiGraphics.Graphics Property

Gets a reference to the underlying .NET Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Graphics Graphics { get; }
Visual Basic

Public ReadOnly Property Graphics As Graphics

Property Value

An instance of the .NET System.Drawing.Graphics class.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.InterpolationMode Property

GdiGraphics.InterpolationMode Property

Gets or sets the interpolation mode associated with this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual InterpolationMode InterpolationMode { get; set; }
Visual Basic

Public Overridable Property InterpolationMode As InterpolationMode

Property Value

This property specifies a member of the InterpolationMode enumeration associated with this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsClipEmpty Property

GdiGraphics.IsClipEmpty Property

Gets a value indicating whether the clipping region of this GdiGraphics object is empty.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual bool IsClipEmpty { get; }
Visual Basic

Public Overridable ReadOnly Property IsClipEmpty As Boolean

Property Value

This property is true if the clipping region of this GdiGraphics object is empty; otherwise, false.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisibleClipEmpty Property

GdiGraphics.IsVisibleClipEmpty Property

Gets a value indicating whether the visible clipping region of this GdiGraphics object is empty.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual bool IsVisibleClipEmpty { get; }
Visual Basic

Public Overridable ReadOnly Property IsVisibleClipEmpty As Boolean

Property Value

This property is true if the visible portion of the clipping region of this GdiGraphics object is empty; otherwise, false.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.PageScale Property

GdiGraphics.PageScale Property

Gets or sets the scaling between world units and page units for this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual float PageScale { get; set; }
Visual Basic

Public Overridable Property PageScale As Single

Property Value

This property specifies a value for the scaling between world units and page units for this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.PageUnit Property

GdiGraphics.PageUnit Property

Gets or sets the unit of measure used for page coordinates in this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual GraphicsUnit PageUnit { get; set; }
Visual Basic

Public Overridable Property PageUnit As GraphicsUnit

Property Value

This property specifies a member of the .NET GraphicsUnit enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.PixelOffsetMode Property

GdiGraphics.PixelOffsetMode Property

Gets or set a value specifying how pixels are offset during rendering of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual PixelOffsetMode PixelOffsetMode { get; set; }
Visual Basic

Public Overridable Property PixelOffsetMode As PixelOffsetMode

Property Value

This property specifies a member of the .NET PixelOffsetMode enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.RenderingOrigin Property

GdiGraphics.RenderingOrigin Property

Gets or sets the rendering origin of this GdiGraphics object for dithering and for hatch brushes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual Point RenderingOrigin { get; set; }
Visual Basic

Public Overridable Property RenderingOrigin As Point

Property Value

This property specifies a .NET Point structure that represents the dither origin for 8-bits-per-pixel and 16-bits-per-pixel dithering and is also used to set the origin for hatch brushes.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SmoothingMode Property

GdiGraphics.SmoothingMode Property

Gets or sets the rendering quality for this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual SmoothingMode SmoothingMode { get; set; }
Visual Basic

Public Overridable Property SmoothingMode As SmoothingMode

Property Value

This property specifies a member of the .NET SmoothingMode enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TextContrast Property

GdiGraphics.TextContrast Property

Gets or sets the gamma correction value for rendering text.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual int TextContrast { get; set; }
Visual Basic

Public Overridable Property TextContrast As Integer

Property Value

This property specifies a value of the gamma correction used for rendering antialiased and ClearType text.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TextRenderingHint Property

GdiGraphics.TextRenderingHint Property

Gets or sets the rendering mode for text associated with this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual TextRenderingHint TextRenderingHint { get; set; }
Visual Basic

Public Overridable Property TextRenderingHint As TextRenderingHint

Property Value

This property specifies a member of the .NET TextRenderingHint enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Transform Property

GdiGraphics.Transform Property

Gets or sets the world transformation for this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual Matrix Transform { get; set; }
Visual Basic

Public Overridable Property Transform As Matrix

Property Value

This property specifies a Matrix object that represents the world transformation for this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.VisibleClipBounds Property

GdiGraphics.VisibleClipBounds Property

Gets the bounding rectangle of the visible clipping region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual RectangleF VisibleClipBounds { get; }
Visual Basic

Public Overridable ReadOnly Property VisibleClipBounds As RectangleF

Property Value

A .NET RectangleF structure that represents a bounding rectangle for the visible clipping region of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Class

GraphicObject Class

The base class for graphical objects such as pens and brushes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract class GraphicObject : ICloneable
Visual Basic

Public MustInherit Class GraphicObject
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject

See Also

GraphicObject Members
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Members

GraphicObject Members
Constructors Methods

The base class for graphical objects such as pens and brushes.

The following tables list the members exposed by the GraphicObject type.

Protected Constructors

Name | Description
GraphicObject | Initializes a new instance of the GraphicObject class.

Public Methods

Name | Description
Clone | Creates an exact copy of the graphic object.
Deserialize | Creates and returns a new graphics object according to its string representation.
Equals | Determines whether two GraphicObject instances are equal.
GetHashCode | Returns a hash code for this object.
Serialize | Serializes the specified object to a string.

See Also

GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Constructor

GraphicObject Constructor

Initializes a new instance of the GraphicObject class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

protected GraphicObject ()
Visual Basic

Protected Sub New ()

See Also

GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Methods

GraphicObject Methods

Public Methods

Name | Description
Clone | Creates an exact copy of the graphic object.
Deserialize | Creates and returns a new graphics object according to its string representation.
Equals | Determines whether two GraphicObject instances are equal.
GetHashCode | Returns a hash code for this object.
Serialize | Serializes the specified object to a string.

See Also

GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Clone Method

GraphicObject.Clone Method

Creates an exact copy of the graphic object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract Object Clone ()
Visual Basic

Public MustOverride Function Clone () As Object

Return Value

An instance of the GraphicObject class.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Deserialize Method

GraphicObject.Deserialize Method

Creates and returns a new graphics object according to its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public static GraphicObject Deserialize (
string image
)
Visual Basic

Public Shared Function Deserialize ( _
image As String _
) As GraphicObject

Parameters

image
A string that represents the serialized object.

Return Value

An instance of the GraphicObject class.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Equals Method

GraphicObject.Equals Method

Determines whether two GraphicObject instances are equal.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override bool Equals (
Object obj
)
Visual Basic

Public Overrides Function Equals ( _
obj As Object _
) As Boolean

Parameters

obj
The object to compare to this one.

Return Value

true is the objects are equal; otherwise, false.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.GetHashCode Method

GraphicObject.GetHashCode Method

Returns a hash code for this object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override int GetHashCode ()
Visual Basic

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for this object.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Serialize Method

GraphicObject.Serialize Method

Serializes the specified object to a string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public static string Serialize (
GraphicObject obj
)
Visual Basic

Public Shared Function Serialize ( _
obj As GraphicObject _
) As String

Parameters

obj
The graphic object to serialize.

Return Value

A string that represents the specified object.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Class

HatchBrush Class
Remarks See Also

HatchBrush objects represent rectangular brushes with a hatch style, a foreground color, and a background color that are used to fill the interiors of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public class HatchBrush : Brush, ISerializable
Visual Basic

Public Class HatchBrush
Inherits Brush
Implements ISerializable

Remarks

The HatchBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.Drawing2D.HatchBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.HatchBrush

See Also

HatchBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Members

HatchBrush Members
Constructors Properties Methods

HatchBrush objects represent rectangular brushes with a hatch style, a foreground color, and a background color that are used to fill the interiors of geometric shapes.

The following tables list the members exposed by the HatchBrush type.

Public Constructors

Name | Description
HatchBrush | Overloaded. Initialize a new instance of the HatchBrush class with the specified attributes.

Public Properties

Name | Description
BackgroundColor | Gets or sets the color of spaces between the hatch lines drawn by this brush.
ForegroundColor | Gets or sets the color of hatch lines drawn by this brush.
HatchStyle | Gets or sets the hatch style of this brush.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.Drawing2D.HatchBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Hatch".

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Constructor

HatchBrush Constructor

Initialize a new instance of the HatchBrush class with the specified attributes.

Overload List

Name | Description
HatchBrush (HatchStyle, Color) | Initializes a new instance of the HatchBrush class with the specified hatch style and color.
HatchBrush (HatchStyle, Color, Color) | Initializes a new instance of the HatchBrush class with the specified style, foreground color and background color.
HatchBrush (String) | Initializes a new instance of the HatchBrush class according to its string representation.

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Constructor (HatchStyle, Color)

HatchBrush Constructor (HatchStyle, Color)
See Also

Initializes a new instance of the HatchBrush class with the specified hatch style and color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public HatchBrush (
HatchStyle hatchStyle,
Color foreColor
)
Visual Basic

Public New ( _
hatchStyle As HatchStyle, _
foreColor As Color _
)

Parameters

hatchStyle
A member of the .NET HatchStyle enumeration that represents the pattern drawn by this brush.
foreColor
A Color structure that specifies the color of lines drawn by this brush.

See Also

HatchBrush Constructor Overload List
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Constructor (HatchStyle, Color, Color)

HatchBrush Constructor (HatchStyle, Color, Color)
See Also

Initializes a new instance of the HatchBrush class with the specified style, foreground color and background color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public HatchBrush (
HatchStyle hatchStyle,
Color foreColor,
Color backColor
)
Visual Basic

Public New ( _
hatchStyle As HatchStyle, _
foreColor As Color, _
backColor As Color _
)

Parameters

hatchStyle
A member of the .NET HatchStyle enumeration that represents the pattern drawn by this brush.
foreColor
A Color structure that specifies the color of lines drawn by this brush.
backColor
A Color structure that specifies the color of spaces between the lines drawn by this brush.

See Also

HatchBrush Constructor Overload List
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Constructor (String)

HatchBrush Constructor (String)
See Also

Initializes a new instance of the HatchBrush class according to its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public HatchBrush (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized bursh.

See Also

HatchBrush Constructor Overload List
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Methods

HatchBrush Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.Drawing2D.HatchBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Hatch".

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.Clone Method

HatchBrush.Clone Method

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

An instance of the HatchBrush class.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.CreateGdiBrush Method

HatchBrush.CreateGdiBrush Method

Returns an instance of the System.Drawing.Drawing2D.HatchBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override Brush CreateGdiBrush (
RectangleF rc
)
Visual Basic

Public Overrides Function CreateGdiBrush ( _
rc As RectangleF _
) As Brush

Parameters

rc
The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.GetObjectData Method

HatchBrush.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)
Visual Basic

Public Overridable Sub GetObjectData ( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info
The object that holds the serialized object data.
context
The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.ToString Method

HatchBrush.ToString Method

Returns "Hatch".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Properties

HatchBrush Properties

Public Properties

Name | Description
BackgroundColor | Gets or sets the color of spaces between the hatch lines drawn by this brush.
ForegroundColor | Gets or sets the color of hatch lines drawn by this brush.
HatchStyle | Gets or sets the hatch style of this brush.

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.BackgroundColor Property

HatchBrush.BackgroundColor Property

Gets or sets the color of spaces between the hatch lines drawn by this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Color BackgroundColor { get; set; }
Visual Basic

Public Property BackgroundColor As Color

Property Value

An instance of the .NET Color structure that represents the background color of this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.ForegroundColor Property

HatchBrush.ForegroundColor Property

Gets or sets the color of hatch lines drawn by this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Color ForegroundColor { get; set; }
Visual Basic

Public Property ForegroundColor As Color

Property Value

An instance of the .NET Color structure that represents the foreground color of this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.HatchStyle Property

HatchBrush.HatchStyle Property

Gets or sets the hatch style of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public HatchStyle HatchStyle { get; set; }
Visual Basic

Public Property HatchStyle As HatchStyle

Property Value

A member of the .NET HatchStyle enumeration that represents the pattern of this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Interface

IGraphics Interface

This interface exposes the public interface of the .NET System.Drawing.Graphics class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public interface IGraphics
Visual Basic

Public Interface IGraphics

See Also

IGraphics Members
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Members

IGraphics Members
Properties Methods

This interface exposes the public interface of the .NET System.Drawing.Graphics class.

The following tables list the members exposed by the IGraphics type.

Public Properties

Name | Description
Clip | Gets or sets a .NET Region object that limits the drawing region of this IGraphics object.
ClipBounds | Gets a .NET RectangleF structure that bounds the clipping region of this IGraphics object.
CompositingMode | Gets or sets a value that specifies how composited images are drawn to this IGraphics object.
CompositingQuality | Gets or sets the rendering quality of composited images drawn to this IGraphics object.
DpiX | Gets the horizontal resolution of this IGraphics object.
DpiY | Gets the vertical resolution of this IGraphics object.
InterpolationMode | Gets or sets the interpolation mode associated with this IGraphics object.
IsClipEmpty | Gets a value indicating whether the clipping region of this IGraphics object is empty.
IsVisibleClipEmpty | Gets a value indicating whether the visible clipping region of this IGraphics object is empty.
PageScale | Gets or sets the scaling between world units and page units for this IGraphics object.
PageUnit | Gets or sets the unit of measure used for page coordinates in this IGraphics object.
PixelOffsetMode | Gets or set a value specifying how pixels are offset during rendering of this IGraphics object.
RenderingOrigin | Gets or sets the rendering origin of this IGraphics object for dithering and for hatch brushes.
SmoothingMode | Gets or sets the rendering quality for this IGraphics object.
TextContrast | Gets or sets the gamma correction value for rendering text.
TextRenderingHint | Gets or sets the rendering mode for text associated with this IGraphics object.
Transform | Gets or sets the world transformation for this IGraphics object.
VisibleClipBounds | Gets or sets the bounding rectangle of the visible clipping region of this IGraphics object.

Public Methods

Name | Description
AddMetafileComment | Adds a comment to the current Metafile object.
BeginContainer | Overloaded. Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.
BeginHyperLink |
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Releases all resources used by this IGraphics object.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bézier spline defined by four .NET Point structures.
DrawBeziers | Overloaded. Draws a series of Bézier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of Point structures.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawIcon | Overloaded. Draws the image represented by the specified .NET Icon object at the specified coordinates.
DrawIconUnstretched | Draws the image represented by the specified .NET Icon object without scaling the image.
DrawImage | Overloaded. Draws the specified .NET Image object at the specified location and with the original size.
DrawImageUnscaled | Overloaded. Draws the specified image using its original physical size at the location specified by a coordinate pair.
DrawLine | Overloaded. Draws a line connecting the two points specified by coordinate pairs.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a .NET GraphicsPath object.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of Point structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangles | Overloaded. Draws a series of rectangles specified by Rectangle structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndContainer | Closes the current graphics container and restores the state of this IGraphics object to the state saved by a call to the BeginContainer method.
EndHyperLink |
ExcludeClip | Overloaded. Updates the clip region of this IGraphics object to exclude the area specified by a .NET Rectangle structure.
FillClosedCurve | Overloaded. Fills the interior a closed cardinal spline curve defined by an array of Point structures.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillPath | Fills the interior of a .NET GraphicsPath object.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by Point structures.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a .NET Region object.
Flush | Overloaded. Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GetFontHeight |
GetHdc | Gets the handle to the device context associated with this IGraphics.
GetNearestColor | Gets the nearest color to the specified Color structure.
IntersectClip | Overloaded. Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IsVisible | Overloaded. Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.
MeasureCharacterRanges | Gets an array of Region objects, each of which bounds a range of character positions within the specified string.
MeasureString | Overloaded. Measures the specified string when drawn with the specified Font object.
MultiplyTransform | Overloaded. Multiplies the world transformation of this IGraphics object and specified the .NET Matrix object.
ReleaseHdc | Releases a device context handle obtained by a previous call to the GetHdc method of this IGraphics object.
ReleaseHdcInternal | Internal method. Do not use.
ResetClip | Resets the clip region of this IGraphics object to an infinite region.
ResetTransform | Resets the world transformation matrix of this IGraphics object to the identity matrix.
Restore | Restores the state of this IGraphics object to the state represented by a GraphicsState object.
RotateTransform | Overloaded. Applies the specified rotation to the transformation matrix of this IGraphics object.
Save | Saves the current state of this IGraphics object and identifies the saved state with a GraphicsState object.
ScaleTransform | Overloaded. Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.
SetClip | Overloaded. Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.
TransformPoints | Overloaded. Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.
TranslateClip | Overloaded. Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.
TranslateTransform | Overloaded. Prepends the specified translation to the transformation matrix of this IGraphics object.

See Also

IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Methods

IGraphics Methods

Public Methods

Name | Description
AddMetafileComment | Adds a comment to the current Metafile object.
BeginContainer | Overloaded. Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.
BeginHyperLink |
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Releases all resources used by this IGraphics object.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bézier spline defined by four .NET Point structures.
DrawBeziers | Overloaded. Draws a series of Bézier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of Point structures.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawIcon | Overloaded. Draws the image represented by the specified .NET Icon object at the specified coordinates.
DrawIconUnstretched | Draws the image represented by the specified .NET Icon object without scaling the image.
DrawImage | Overloaded. Draws the specified .NET Image object at the specified location and with the original size.
DrawImageUnscaled | Overloaded. Draws the specified image using its original physical size at the location specified by a coordinate pair.
DrawLine | Overloaded. Draws a line connecting the two points specified by coordinate pairs.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a .NET GraphicsPath object.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of Point structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangles | Overloaded. Draws a series of rectangles specified by Rectangle structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndContainer | Closes the current graphics container and restores the state of this IGraphics object to the state saved by a call to the BeginContainer method.
EndHyperLink |
ExcludeClip | Overloaded. Updates the clip region of this IGraphics object to exclude the area specified by a .NET Rectangle structure.
FillClosedCurve | Overloaded. Fills the interior a closed cardinal spline curve defined by an array of Point structures.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillPath | Fills the interior of a .NET GraphicsPath object.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by Point structures.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a .NET Region object.
Flush | Overloaded. Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GetFontHeight |
GetHdc | Gets the handle to the device context associated with this IGraphics.
GetNearestColor | Gets the nearest color to the specified Color structure.
IntersectClip | Overloaded. Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IsVisible | Overloaded. Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.
MeasureCharacterRanges | Gets an array of Region objects, each of which bounds a range of character positions within the specified string.
MeasureString | Overloaded. Measures the specified string when drawn with the specified Font object.
MultiplyTransform | Overloaded. Multiplies the world transformation of this IGraphics object and specified the .NET Matrix object.
ReleaseHdc | Releases a device context handle obtained by a previous call to the GetHdc method of this IGraphics object.
ReleaseHdcInternal | Internal method. Do not use.
ResetClip | Resets the clip region of this IGraphics object to an infinite region.
ResetTransform | Resets the world transformation matrix of this IGraphics object to the identity matrix.
Restore | Restores the state of this IGraphics object to the state represented by a GraphicsState object.
RotateTransform | Overloaded. Applies the specified rotation to the transformation matrix of this IGraphics object.
Save | Saves the current state of this IGraphics object and identifies the saved state with a GraphicsState object.
ScaleTransform | Overloaded. Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.
SetClip | Overloaded. Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.
TransformPoints | Overloaded. Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.
TranslateClip | Overloaded. Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.
TranslateTransform | Overloaded. Prepends the specified translation to the transformation matrix of this IGraphics object.

See Also

IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.AddMetafileComment Method

IGraphics.AddMetafileComment Method

Adds a comment to the current Metafile object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void AddMetafileComment (
byte[] data
)
Visual Basic

Public MustOverride Sub AddMetafileComment ( _
data() As Byte _
)

Parameters

data
Array of bytes that contains the comment.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginContainer Method

IGraphics.BeginContainer Method

Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.

Overload List

Name | Description
IGraphics.BeginContainer () | Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.
IGraphics.BeginContainer (Rectangle, Rectangle, GraphicsUnit) | Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container with the specified scale transformation.
IGraphics.BeginContainer (RectangleF, RectangleF, GraphicsUnit) | Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container with the specified scale transformation.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginContainer Method ()

IGraphics.BeginContainer Method ()
See Also

Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract GraphicsContainer BeginContainer ()
Visual Basic

Public MustOverride Function BeginContainer () As GraphicsContainer

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this IGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginContainer Method (Rectangle, Rectangle, GraphicsUnit)

IGraphics.BeginContainer Method (Rectangle, Rectangle, GraphicsUnit)
See Also

Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container with the specified scale transformation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract GraphicsContainer BeginContainer (
Rectangle dstrect,
Rectangle srcrect,
GraphicsUnit unit
)
Visual Basic

Public MustOverride Function BeginContainer ( _
dstrect As Rectangle, _
srcrect As Rectangle, _
unit As GraphicsUnit _
) As GraphicsContainer

Parameters

dstrect
A .NET Rectangle structure that, together with the srcrect parameter, specifies a scale transformation for the container.
srcrect
A .NET Rectangle structure that, together with the dstrect parameter, specifies a scale transformation for the container.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure for the container.

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this IGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginContainer Method (RectangleF, RectangleF, GraphicsUnit)

IGraphics.BeginContainer Method (RectangleF, RectangleF, GraphicsUnit)
See Also

Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container with the specified scale transformation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract GraphicsContainer BeginContainer (
RectangleF dstrect,
RectangleF srcrect,
GraphicsUnit unit
)
Visual Basic

Public MustOverride Function BeginContainer ( _
dstrect As RectangleF, _
srcrect As RectangleF, _
unit As GraphicsUnit _
) As GraphicsContainer

Parameters

dstrect
A .NET RectangleF structure that, together with the srcrect parameter, specifies a scale transformation for the new graphics container.
srcrect
A .NET RectangleF structure that, together with the dstrect parameter, specifies a scale transformation for the new graphics container.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure for the container.

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this IGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginHyperLink Method

IGraphics.BeginHyperLink Method

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void BeginHyperLink (
string url,
string target
)
Visual Basic

Public MustOverride Sub BeginHyperLink ( _
url As String, _
target As String _
)

Parameters

url
target

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Clear Method

IGraphics.Clear Method

Clears the entire drawing surface and fills it with the specified background color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void Clear (
Color color
)
Visual Basic

Public MustOverride Sub Clear ( _
color As Color _
)

Parameters

color
A .NET Color structure that represents the background color of the drawing surface.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Dispose Method

IGraphics.Dispose Method

Releases all resources used by this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void Dispose ()
Visual Basic

Public MustOverride Sub Dispose ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method

IGraphics.DrawArc Method

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
IGraphics.DrawArc (Pen, Int32, Int32, Int32, Int32, Int32, Int32) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
IGraphics.DrawArc (Pen, Rectangle, Single, Single) | Draws an arc representing a portion of an ellipse specified by a .NET Rectangle structure.
IGraphics.DrawArc (Pen, RectangleF, Single, Single) | Draws an arc representing a portion of an ellipse specified by a .NET RectangleF structure.
IGraphics.DrawArc (Pen, Single, Single, Single, Single, Single, Single) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

IGraphics.DrawArc Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)
See Also

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawArc (
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)
Visual Basic

Public MustOverride Sub DrawArc ( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
The width of the rectangle that defines the ellipse.
height
The height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, Rectangle, Single, Single)

IGraphics.DrawArc Method (Pen, Rectangle, Single, Single)
See Also

Draws an arc representing a portion of an ellipse specified by a .NET Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawArc (
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
)
Visual Basic

Public MustOverride Sub DrawArc ( _
pen As Pen, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
rect
A .NET Rectangle structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, RectangleF, Single, Single)

IGraphics.DrawArc Method (Pen, RectangleF, Single, Single)
See Also

Draws an arc representing a portion of an ellipse specified by a .NET RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawArc (
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
)
Visual Basic

Public MustOverride Sub DrawArc ( _
pen As Pen, _
rect As RectangleF, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, Single, Single, Single, Single, Single, Single)

IGraphics.DrawArc Method (Pen, Single, Single, Single, Single, Single, Single)
See Also

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawArc (
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)
Visual Basic

Public MustOverride Sub DrawArc ( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
The width of the rectangle that defines the ellipse.
height
The height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBezier Method

IGraphics.DrawBezier Method

Draws a Bézier spline defined by four .NET Point structures.

Overload List

Name | Description
IGraphics.DrawBezier (Pen, Point, Point, Point, Point) | Draws a Bézier spline defined by four Point structures.
IGraphics.DrawBezier (Pen, PointF, PointF, PointF, PointF) | Draws a Bézier spline defined by four PointF structures.
IGraphics.DrawBezier (Pen, Single, Single, Single, Single, Single, Single, Single, Single) | Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBezier Method (Pen, Point, Point, Point, Point)

IGraphics.DrawBezier Method (Pen, Point, Point, Point, Point)
See Also

Draws a Bézier spline defined by four Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawBezier (
Pen pen,
Point pt1,
Point pt2,
Point pt3,
Point pt4
)
Visual Basic

Public MustOverride Sub DrawBezier ( _
pen As Pen, _
pt1 As Point, _
pt2 As Point, _
pt3 As Point, _
pt4 As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
pt1
A .NET Point structure that represents the starting point of the curve.
pt2
A .NET Point structure that represents the first control point for the curve.
pt3
A .NET Point structure that represents the second control point for the curve.
pt4
A .NET Point structure that represents the ending point of the curve.

See Also

DrawBezier Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBezier Method (Pen, PointF, PointF, PointF, PointF)

IGraphics.DrawBezier Method (Pen, PointF, PointF, PointF, PointF)
See Also

Draws a Bézier spline defined by four PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawBezier (
Pen pen,
PointF pt1,
PointF pt2,
PointF pt3,
PointF pt4
)
Visual Basic

Public MustOverride Sub DrawBezier ( _
pen As Pen, _
pt1 As PointF, _
pt2 As PointF, _
pt3 As PointF, _
pt4 As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
pt1
A .NET PointF structure that represents the starting point of the curve.
pt2
A .NET PointF structure that represents the first control point for the curve.
pt3
A .NET PointF structure that represents the second control point for the curve.
pt4
A .NET PointF structure that represents the ending point of the curve.

See Also

DrawBezier Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBezier Method (Pen, Single, Single, Single, Single, Single, Single, Single, Single)

IGraphics.DrawBezier Method (Pen, Single, Single, Single, Single, Single, Single, Single, Single)
See Also

Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawBezier (
Pen pen,
float x1,
float y1,
float x2,
float y2,
float x3,
float y3,
float x4,
float y4
)
Visual Basic

Public MustOverride Sub DrawBezier ( _
pen As Pen, _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single, _
x3 As Single, _
y3 As Single, _
x4 As Single, _
y4 As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
x1
The x-coordinate of the starting point of the curve.
y1
The y-coordinate of the starting point of the curve.
x2
The x-coordinate of the first control point of the curve.
y2
The y-coordinate of the first control point of the curve.
x3
The x-coordinate of the second control point of the curve.
y3
The y-coordinate of the second control point of the curve.
x4
The x-coordinate of the ending point of the curve.
y4
The y-coordinate of the ending point of the curve.

See Also

DrawBezier Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBeziers Method

IGraphics.DrawBeziers Method

Draws a series of Bézier splines from an array of Point structures.

Overload List

Name | Description
IGraphics.DrawBeziers (Pen, Point[]) | Draws a series of Bézier splines from an array of Point structures.
IGraphics.DrawBeziers (Pen, PointF[]) | Draws a series of Bézier splines from an array of PointF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBeziers Method (Pen, Point[])

IGraphics.DrawBeziers Method (Pen, Point[])
See Also

Draws a series of Bézier splines from an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawBeziers (
Pen pen,
Point[] points
)
Visual Basic

Public MustOverride Sub DrawBeziers ( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
points
An array of .NET Point structures that represent the points that determine the curve.

See Also

DrawBeziers Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBeziers Method (Pen, PointF[])

IGraphics.DrawBeziers Method (Pen, PointF[])
See Also

Draws a series of Bézier splines from an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawBeziers (
Pen pen,
PointF[] points
)
Visual Basic

Public MustOverride Sub DrawBeziers ( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
points
An array of .NET PointF structures that represent the points that determine the curve.

See Also

DrawBeziers Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method

IGraphics.DrawClosedCurve Method

Draws a closed cardinal spline defined by an array of Point structures.

Overload List

Name | Description
IGraphics.DrawClosedCurve (Pen, Point[]) | Draws a closed cardinal spline defined by an array of Point structures.
IGraphics.DrawClosedCurve (Pen, Point[], Single, FillMode) | Draws a closed cardinal spline defined by an array of Point structures using a specified tension.
IGraphics.DrawClosedCurve (Pen, PointF[]) | Draws a closed cardinal spline defined by an array of PointF structures.
IGraphics.DrawClosedCurve (Pen, PointF[], Single, FillMode) | Draws a closed cardinal spline defined by an array of PointF structures using a specified tension.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method (Pen, Point[])

IGraphics.DrawClosedCurve Method (Pen, Point[])
See Also

Draws a closed cardinal spline defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawClosedCurve (
Pen pen,
Point[] points
)
Visual Basic

Public MustOverride Sub DrawClosedCurve ( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.

See Also

DrawClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method (Pen, Point[], Single, FillMode)

IGraphics.DrawClosedCurve Method (Pen, Point[], Single, FillMode)
See Also

Draws a closed cardinal spline defined by an array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawClosedCurve (
Pen pen,
Point[] points,
float tension,
FillMode fillmode
)
Visual Basic

Public MustOverride Sub DrawClosedCurve ( _
pen As Pen, _
points() As Point, _
tension As Single, _
fillmode As FillMode _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled. This parameter is required but ignored.

See Also

DrawClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method (Pen, PointF[])

IGraphics.DrawClosedCurve Method (Pen, PointF[])
See Also

Draws a closed cardinal spline defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawClosedCurve (
Pen pen,
PointF[] points
)
Visual Basic

Public MustOverride Sub DrawClosedCurve ( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of PointF structures that define the spline.

See Also

DrawClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method (Pen, PointF[], Single, FillMode)

IGraphics.DrawClosedCurve Method (Pen, PointF[], Single, FillMode)
See Also

Draws a closed cardinal spline defined by an array of PointF structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawClosedCurve (
Pen pen,
PointF[] points,
float tension,
FillMode fillmode
)
Visual Basic

Public MustOverride Sub DrawClosedCurve ( _
pen As Pen, _
points() As PointF, _
tension As Single, _
fillmode As FillMode _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of PointF structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.
fillmode
Member of the FillMode enumeration that determines how the curve is filled. This parameter is required but is ignored.

See Also

DrawClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method

IGraphics.DrawCurve Method

Draws a cardinal spline through a specified array of Point structures.

Overload List

Name | Description
IGraphics.DrawCurve (Pen, Point[]) | Draws a cardinal spline through a specified array of Point structures.
IGraphics.DrawCurve (Pen, Point[], Int32, Int32, Single) | Draws a cardinal spline through a specified array of Point structures using a specified tension.
IGraphics.DrawCurve (Pen, Point[], Single) | Draws a cardinal spline through a specified array of Point structures using a specified tension.
IGraphics.DrawCurve (Pen, PointF[]) | Draws a cardinal spline through a specified array of PointF structures.
IGraphics.DrawCurve (Pen, PointF[], Int32, Int32) | Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array.
IGraphics.DrawCurve (Pen, PointF[], Int32, Int32, Single) | Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.
IGraphics.DrawCurve (Pen, PointF[], Single) | Draws a cardinal spline through a specified array of PointF structures using a specified tension.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, Point[])

IGraphics.DrawCurve Method (Pen, Point[])
See Also

Draws a cardinal spline through a specified array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawCurve (
Pen pen,
Point[] points
)
Visual Basic

Public MustOverride Sub DrawCurve ( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, Point[], Int32, Int32, Single)

IGraphics.DrawCurve Method (Pen, Point[], Int32, Int32, Single)
See Also

Draws a cardinal spline through a specified array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawCurve (
Pen pen,
Point[] points,
int offset,
int numberOfSegments,
float tension
)
Visual Basic

Public MustOverride Sub DrawCurve ( _
pen As Pen, _
points() As Point, _
offset As Integer, _
numberOfSegments As Integer, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, Point[], Single)

IGraphics.DrawCurve Method (Pen, Point[], Single)
See Also

Draws a cardinal spline through a specified array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawCurve (
Pen pen,
Point[] points,
float tension
)
Visual Basic

Public MustOverride Sub DrawCurve ( _
pen As Pen, _
points() As Point, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, PointF[])

IGraphics.DrawCurve Method (Pen, PointF[])
See Also

Draws a cardinal spline through a specified array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawCurve (
Pen pen,
PointF[] points
)
Visual Basic

Public MustOverride Sub DrawCurve ( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32)

IGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32)
See Also

Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawCurve (
Pen pen,
PointF[] points,
int offset,
int numberOfSegments
)
Visual Basic

Public MustOverride Sub DrawCurve ( _
pen As Pen, _
points() As PointF, _
offset As Integer, _
numberOfSegments As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32, Single)

IGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32, Single)
See Also

Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawCurve (
Pen pen,
PointF[] points,
int offset,
int numberOfSegments,
float tension
)
Visual Basic

Public MustOverride Sub DrawCurve ( _
pen As Pen, _
points() As PointF, _
offset As Integer, _
numberOfSegments As Integer, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, PointF[], Single)

IGraphics.DrawCurve Method (Pen, PointF[], Single)
See Also

Draws a cardinal spline through a specified array of PointF structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawCurve (
Pen pen,
PointF[] points,
float tension
)
Visual Basic

Public MustOverride Sub DrawCurve ( _
pen As Pen, _
points() As PointF, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that represent the points that define the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method

IGraphics.DrawEllipse Method

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Overload List

Name | Description
IGraphics.DrawEllipse (Pen, Int32, Int32, Int32, Int32) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
IGraphics.DrawEllipse (Pen, Rectangle) | Draws an ellipse specified by a bounding Rectangle structure.
IGraphics.DrawEllipse (Pen, RectangleF) | Draws an ellipse defined by a bounding RectangleF structure.
IGraphics.DrawEllipse (Pen, Single, Single, Single, Single) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, Int32, Int32, Int32, Int32)

IGraphics.DrawEllipse Method (Pen, Int32, Int32, Int32, Int32)
See Also

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawEllipse (
Pen pen,
int x,
int y,
int width,
int height
)
Visual Basic

Public MustOverride Sub DrawEllipse ( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
x

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, Rectangle)

IGraphics.DrawEllipse Method (Pen, Rectangle)
See Also

Draws an ellipse specified by a bounding Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawEllipse (
Pen pen,
Rectangle rect
)
Visual Basic

Public MustOverride Sub DrawEllipse ( _
pen As Pen, _
rect As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
rect
A .NET Rectangle structure that defines the boundaries of the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, RectangleF)

IGraphics.DrawEllipse Method (Pen, RectangleF)
See Also

Draws an ellipse defined by a bounding RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawEllipse (
Pen pen,
RectangleF rect
)
Visual Basic

Public MustOverride Sub DrawEllipse ( _
pen As Pen, _
rect As RectangleF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, Single, Single, Single, Single)

IGraphics.DrawEllipse Method (Pen, Single, Single, Single, Single)
See Also

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawEllipse (
Pen pen,
float x,
float y,
float width,
float height
)
Visual Basic

Public MustOverride Sub DrawEllipse ( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawIcon Method

IGraphics.DrawIcon Method

Draws the image represented by the specified .NET Icon object at the specified coordinates.

Overload List

Name | Description
IGraphics.DrawIcon (Icon, Int32, Int32) | Draws the image represented by the specified .NET Icon object at the specified coordinates.
IGraphics.DrawIcon (Icon, Rectangle) | Draws the image represented by the specified .NET Icon object within the area specified by a Rectangle structure.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawIcon Method (Icon, Int32, Int32)

IGraphics.DrawIcon Method (Icon, Int32, Int32)
See Also

Draws the image represented by the specified .NET Icon object at the specified coordinates.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawIcon (
Icon icon,
int x,
int y
)
Visual Basic

Public MustOverride Sub DrawIcon ( _
icon As Icon, _
x As Integer, _
y As Integer _
)

Parameters

icon
A .NET Icon object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawIcon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawIcon Method (Icon, Rectangle)

IGraphics.DrawIcon Method (Icon, Rectangle)
See Also

Draws the image represented by the specified .NET Icon object within the area specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawIcon (
Icon icon,
Rectangle targetRect
)
Visual Basic

Public MustOverride Sub DrawIcon ( _
icon As Icon, _
targetRect As Rectangle _
)

Parameters

icon
A .NET Icon object to draw.
targetRect
A .NET Rectangle structure that specifies the location and size of the resulting image on the display surface. The image contained in the icon parameter is scaled to the dimensions of this rectangular area.

See Also

DrawIcon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawIconUnstretched Method

IGraphics.DrawIconUnstretched Method

Draws the image represented by the specified .NET Icon object without scaling the image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawIconUnstretched (
Icon icon,
Rectangle targetRect
)
Visual Basic

Public MustOverride Sub DrawIconUnstretched ( _
icon As Icon, _
targetRect As Rectangle _
)

Parameters

icon
A .NET Icon object to draw.
targetRect
A .NET Rectangle structure that specifies the location and size of the resulting image. The image is not scaled to fit this rectangle, but retains its original size. If the image is larger than the rectangle, it is clipped to fit inside it.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method

IGraphics.DrawImage Method

Draws the specified .NET Image object at the specified location and with the original size.

Overload List

Name | Description
IGraphics.DrawImage (Image, Int32, Int32) | Draws the specified image, using its original physical size, at the location specified by a coordinate pair.
IGraphics.DrawImage (Image, Int32, Int32, Int32, Int32) | Draws the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Int32, Int32, Rectangle, GraphicsUnit) | Draws a portion of an image at a specified location.
IGraphics.DrawImage (Image, Point) | Draws the specified .NET Image object, using its original physical size, at the specified location.
IGraphics.DrawImage (Image, Point[]) | Draws the specified .NET Image object at the specified location and with the specified shape and size.
IGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location.
IGraphics.DrawImage (Image, PointF) | Draws the specified .NET Image object, using its original physical size, at the specified location.
IGraphics.DrawImage (Image, PointF[]) | Draws the specified .NET Image object at the specified location and with the specified shape and size.
IGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle) | Draws the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Rectangle, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, RectangleF) | Draws the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, RectangleF, RectangleF, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Single, Single) | Draws the specified .NET Image object, using its original physical size, at the specified location.
IGraphics.DrawImage (Image, Single, Single, RectangleF, GraphicsUnit) | Draws a portion of an image at a specified location.
IGraphics.DrawImage (Image, Single, Single, Single, Single) | Draws the specified .NET Image object at the specified location and with the specified size.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Int32, Int32)

IGraphics.DrawImage Method (Image, Int32, Int32)
See Also

Draws the specified image, using its original physical size, at the location specified by a coordinate pair.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
int x,
int y
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
x As Integer, _
y As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Int32, Int32, Int32, Int32)

IGraphics.DrawImage Method (Image, Int32, Int32, Int32, Int32)
See Also

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
int x,
int y,
int width,
int height
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
The width of the drawn image.
height
The height of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Int32, Int32, Rectangle, GraphicsUnit)

IGraphics.DrawImage Method (Image, Int32, Int32, Rectangle, GraphicsUnit)
See Also

Draws a portion of an image at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
int x,
int y,
Rectangle srcRect,
GraphicsUnit srcUnit
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
x As Integer, _
y As Integer, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Point)

IGraphics.DrawImage Method (Image, Point)
See Also

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
Point point
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
point As Point _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that represents the location of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Point[])

IGraphics.DrawImage Method (Image, Point[])
See Also

Draws the specified .NET Image object at the specified location and with the specified shape and size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
Point[] destPoints
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
destPoints() As Point _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit)

IGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)

IGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)
See Also

Draws the specified portion of the specified .NET Image object at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, PointF)

IGraphics.DrawImage Method (Image, PointF)
See Also

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
PointF point
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
point As PointF _
)

Parameters

image
A .NET Image object to draw.
point
A .NET PointF structure that represents the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, PointF[])

IGraphics.DrawImage Method (Image, PointF[])
See Also

Draws the specified .NET Image object at the specified location and with the specified shape and size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
PointF[] destPoints
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
destPoints() As PointF _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit)

IGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)

IGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle)

IGraphics.DrawImage Method (Image, Rectangle)
See Also

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
Rectangle rect
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
rect As Rectangle _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET Rectangle structure that specifies the location and size of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit)

IGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)

IGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit)

IGraphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit srcUnit
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)

IGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)

IGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, RectangleF)

IGraphics.DrawImage Method (Image, RectangleF)
See Also

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
RectangleF rect
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
rect As RectangleF _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET RectangleF structure that specifies the location and size of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit)

IGraphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit)
See Also

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit srcUnit
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
destRect As RectangleF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Single, Single)

IGraphics.DrawImage Method (Image, Single, Single)
See Also

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
float x,
float y
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
x As Single, _
y As Single _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Single, Single, RectangleF, GraphicsUnit)

IGraphics.DrawImage Method (Image, Single, Single, RectangleF, GraphicsUnit)
See Also

Draws a portion of an image at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
float x,
float y,
RectangleF srcRect,
GraphicsUnit srcUnit
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
x As Single, _
y As Single, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Single, Single, Single, Single)

IGraphics.DrawImage Method (Image, Single, Single, Single, Single)
See Also

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImage (
Image image,
float x,
float y,
float width,
float height
)
Visual Basic

Public MustOverride Sub DrawImage ( _
image As Image, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
The width of the drawn image.
height
The height of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method

IGraphics.DrawImageUnscaled Method

Draws the specified image using its original physical size at the location specified by a coordinate pair.

Overload List

Name | Description
IGraphics.DrawImageUnscaled (Image, Int32, Int32) | Draws the specified image using its original physical size at the location specified by a coordinate pair.
IGraphics.DrawImageUnscaled (Image, Int32, Int32, Int32, Int32) | Draws a specified image using its original physical size at a specified location.
IGraphics.DrawImageUnscaled (Image, Point) | Draws a specified image using its original physical size at a specified location.
IGraphics.DrawImageUnscaled (Image, Rectangle) | Draws a specified image using its original physical size at a specified location.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method (Image, Int32, Int32)

IGraphics.DrawImageUnscaled Method (Image, Int32, Int32)
See Also

Draws the specified image using its original physical size at the location specified by a coordinate pair.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImageUnscaled (
Image image,
int x,
int y
)
Visual Basic

Public MustOverride Sub DrawImageUnscaled ( _
image As Image, _
x As Integer, _
y As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImageUnscaled Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method (Image, Int32, Int32, Int32, Int32)

IGraphics.DrawImageUnscaled Method (Image, Int32, Int32, Int32, Int32)
See Also

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImageUnscaled (
Image image,
int x,
int y,
int width,
int height
)
Visual Basic

Public MustOverride Sub DrawImageUnscaled ( _
image As Image, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
Not used.
height
Not used.

See Also

DrawImageUnscaled Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method (Image, Point)

IGraphics.DrawImageUnscaled Method (Image, Point)
See Also

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImageUnscaled (
Image image,
Point point
)
Visual Basic

Public MustOverride Sub DrawImageUnscaled ( _
image As Image, _
point As Point _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that specifies the upper-left corner of the drawn image.

See Also

DrawImageUnscaled Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method (Image, Rectangle)

IGraphics.DrawImageUnscaled Method (Image, Rectangle)
See Also

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawImageUnscaled (
Image image,
Rectangle rect
)
Visual Basic

Public MustOverride Sub DrawImageUnscaled ( _
image As Image, _
rect As Rectangle _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET Rectangle that specifies the upper-left corner of the drawn image. The X and Y properties of the rectangle specify the upper-left corner. The Width and Height properties are ignored.

See Also

DrawImageUnscaled Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method

IGraphics.DrawLine Method

Draws a line connecting the two points specified by coordinate pairs.

Overload List

Name | Description
IGraphics.DrawLine (Pen, Int32, Int32, Int32, Int32) | Draws a line connecting the two points specified by coordinate pairs.
IGraphics.DrawLine (Pen, Point, Point) | Draws a line connecting two Point structures.
IGraphics.DrawLine (Pen, PointF, PointF) | Draws a line connecting two PointF structures.
IGraphics.DrawLine (Pen, Single, Single, Single, Single) | Draws a line connecting the two points specified by coordinate pairs.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, Int32, Int32, Int32, Int32)

IGraphics.DrawLine Method (Pen, Int32, Int32, Int32, Int32)
See Also

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawLine (
Pen pen,
int x1,
int y1,
int x2,
int y2
)
Visual Basic

Public MustOverride Sub DrawLine ( _
pen As Pen, _
x1 As Integer, _
y1 As Integer, _
x2 As Integer, _
y2 As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, Point, Point)

IGraphics.DrawLine Method (Pen, Point, Point)
See Also

Draws a line connecting two Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawLine (
Pen pen,
Point pt1,
Point pt2
)
Visual Basic

Public MustOverride Sub DrawLine ( _
pen As Pen, _
pt1 As Point, _
pt2 As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
pt1
A .NET Point structure that represents the first point to connect.
pt2
A .NET Point structure that represents the second point to connect.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, PointF, PointF)

IGraphics.DrawLine Method (Pen, PointF, PointF)
See Also

Draws a line connecting two PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawLine (
Pen pen,
PointF pt1,
PointF pt2
)
Visual Basic

Public MustOverride Sub DrawLine ( _
pen As Pen, _
pt1 As PointF, _
pt2 As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
pt1
A .NET PointF structure that represents the first point to connect.
pt2
A .NET PointF structure that represents the second point to connect.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, Single, Single, Single, Single)

IGraphics.DrawLine Method (Pen, Single, Single, Single, Single)
See Also

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawLine (
Pen pen,
float x1,
float y1,
float x2,
float y2
)
Visual Basic

Public MustOverride Sub DrawLine ( _
pen As Pen, _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLines Method

IGraphics.DrawLines Method

Draws a series of line segments that connect an array of Point structures.

Overload List

Name | Description
IGraphics.DrawLines (Pen, Point[]) | Draws a series of line segments that connect an array of Point structures.
IGraphics.DrawLines (Pen, PointF[]) | Draws a series of line segments that connect an array of PointF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLines Method (Pen, Point[])

IGraphics.DrawLines Method (Pen, Point[])
See Also

Draws a series of line segments that connect an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawLines (
Pen pen,
Point[] points
)
Visual Basic

Public MustOverride Sub DrawLines ( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line segments.
points
An array of .NET Point structures that represent the points to connect.

See Also

DrawLines Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLines Method (Pen, PointF[])

IGraphics.DrawLines Method (Pen, PointF[])
See Also

Draws a series of line segments that connect an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawLines (
Pen pen,
PointF[] points
)
Visual Basic

Public MustOverride Sub DrawLines ( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line segments.
points
An array of .NET PointF structures that represent the points to connect.

See Also

DrawLines Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPath Method

IGraphics.DrawPath Method

Draws a .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawPath (
Pen pen,
GraphicsPath path
)
Visual Basic

Public MustOverride Sub DrawPath ( _
pen As Pen, _
path As GraphicsPath _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the path.
path
A .NET GraphicsPath object to draw.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method

IGraphics.DrawPie Method

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Overload List

Name | Description
IGraphics.DrawPie (Pen, Int32, Int32, Int32, Int32, Int32, Int32) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
IGraphics.DrawPie (Pen, Rectangle, Single, Single) | Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.
IGraphics.DrawPie (Pen, RectangleF, Single, Single) | Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.
IGraphics.DrawPie (Pen, Single, Single, Single, Single, Single, Single) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

IGraphics.DrawPie Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)
See Also

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawPie (
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)
Visual Basic

Public MustOverride Sub DrawPie ( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method (Pen, Rectangle, Single, Single)

IGraphics.DrawPie Method (Pen, Rectangle, Single, Single)
See Also

Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawPie (
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
)
Visual Basic

Public MustOverride Sub DrawPie ( _
pen As Pen, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method (Pen, RectangleF, Single, Single)

IGraphics.DrawPie Method (Pen, RectangleF, Single, Single)
See Also

Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawPie (
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
)
Visual Basic

Public MustOverride Sub DrawPie ( _
pen As Pen, _
rect As RectangleF, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
rect
A .NET RectangleF structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method (Pen, Single, Single, Single, Single, Single, Single)

IGraphics.DrawPie Method (Pen, Single, Single, Single, Single, Single, Single)
See Also

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawPie (
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)
Visual Basic

Public MustOverride Sub DrawPie ( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPolygon Method

IGraphics.DrawPolygon Method

Draws a polygon defined by an array of Point structures.

Overload List

Name | Description
IGraphics.DrawPolygon (Pen, Point[]) | Draws a polygon defined by an array of Point structures.
IGraphics.DrawPolygon (Pen, PointF[]) | Draws a polygon defined by an array of PointF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPolygon Method (Pen, Point[])

IGraphics.DrawPolygon Method (Pen, Point[])
See Also

Draws a polygon defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawPolygon (
Pen pen,
Point[] points
)
Visual Basic

Public MustOverride Sub DrawPolygon ( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the polygon.
points
An array of .NET Point structures that represent the vertices of the polygon.

See Also

DrawPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPolygon Method (Pen, PointF[])

IGraphics.DrawPolygon Method (Pen, PointF[])
See Also

Draws a polygon defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawPolygon (
Pen pen,
PointF[] points
)
Visual Basic

Public MustOverride Sub DrawPolygon ( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the polygon.
points
An array of .NET PointF structures that represent the vertices of the polygon.

See Also

DrawPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method

IGraphics.DrawRectangle Method

Draws a rectangle specified by a coordinate pair, a width, and a height.

Overload List

Name | Description
IGraphics.DrawRectangle (Pen, Int32, Int32, Int32, Int32) | Draws a rectangle specified by a coordinate pair, a width, and a height.
IGraphics.DrawRectangle (Pen, Rectangle) | Draws a rectangle specified by a Rectangle structure.
IGraphics.DrawRectangle (Pen, Single, Single, Single, Single) | Draws a rectangle specified by a coordinate pair, a width, and a height.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)

IGraphics.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)
See Also

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawRectangle (
Pen pen,
int x,
int y,
int width,
int height
)
Visual Basic

Public MustOverride Sub DrawRectangle ( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method (Pen, Rectangle)

IGraphics.DrawRectangle Method (Pen, Rectangle)
See Also

Draws a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawRectangle (
Pen pen,
Rectangle rect
)
Visual Basic

Public MustOverride Sub DrawRectangle ( _
pen As Pen, _
rect As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
rect
A .NET Rectangle structure that represents the rectangle to draw.

See Also

DrawRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method (Pen, Single, Single, Single, Single)

IGraphics.DrawRectangle Method (Pen, Single, Single, Single, Single)
See Also

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawRectangle (
Pen pen,
float x,
float y,
float width,
float height
)
Visual Basic

Public MustOverride Sub DrawRectangle ( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangles Method

IGraphics.DrawRectangles Method

Draws a series of rectangles specified by Rectangle structures.

Overload List

Name | Description
IGraphics.DrawRectangles (Pen, Rectangle[]) | Draws a series of rectangles specified by Rectangle structures.
IGraphics.DrawRectangles (Pen, RectangleF[]) | Draws a series of rectangles specified by RectangleF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangles Method (Pen, Rectangle[])

IGraphics.DrawRectangles Method (Pen, Rectangle[])
See Also

Draws a series of rectangles specified by Rectangle structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawRectangles (
Pen pen,
Rectangle[] rects
)
Visual Basic

Public MustOverride Sub DrawRectangles ( _
pen As Pen, _
rects() As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the outlines of the rectangles.
rects
An array of .NET Rectangle structures that represent the rectangles to draw.

See Also

DrawRectangles Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangles Method (Pen, RectangleF[])

IGraphics.DrawRectangles Method (Pen, RectangleF[])
See Also

Draws a series of rectangles specified by RectangleF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawRectangles (
Pen pen,
RectangleF[] rects
)
Visual Basic

Public MustOverride Sub DrawRectangles ( _
pen As Pen, _
rects() As RectangleF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the outlines of the rectangles.
rects
An array of .NET RectangleF structures that represent the rectangles to draw.

See Also

DrawRectangles Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method

IGraphics.DrawString Method

Draws the specified text string at the specified location with the specified Brush and Font objects.

Overload List

Name | Description
IGraphics.DrawString (String, Font, Brush, PointF) | Draws the specified text string at the specified location with the specified Brush and Font objects.
IGraphics.DrawString (String, Font, Brush, PointF, StringFormat) | Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.
IGraphics.DrawString (String, Font, Brush, RectangleF) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects.
IGraphics.DrawString (String, Font, Brush, RectangleF, StringFormat) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.
IGraphics.DrawString (String, Font, Brush, Single, Single) | Draws the specified text string at the specified location with the specified Brush and Font objects.
IGraphics.DrawString (String, Font, Brush, Single, Single, StringFormat) | Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, PointF)

IGraphics.DrawString Method (String, Font, Brush, PointF)
See Also

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawString (
string s,
Font font,
Brush brush,
PointF point
)
Visual Basic

Public MustOverride Sub DrawString ( _
s As String, _
font As Font, _
brush As Brush, _
point As PointF _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
point
A .NET PointF structure that specifies the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, PointF, StringFormat)

IGraphics.DrawString Method (String, Font, Brush, PointF, StringFormat)
See Also

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawString (
string s,
Font font,
Brush brush,
PointF point,
StringFormat format
)
Visual Basic

Public MustOverride Sub DrawString ( _
s As String, _
font As Font, _
brush As Brush, _
point As PointF, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
point
A .NET PointF structure that specifies the upper-left corner of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, RectangleF)

IGraphics.DrawString Method (String, Font, Brush, RectangleF)
See Also

Draws the specified text string in the specified rectangle with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawString (
string s,
Font font,
Brush brush,
RectangleF layoutRectangle
)
Visual Basic

Public MustOverride Sub DrawString ( _
s As String, _
font As Font, _
brush As Brush, _
layoutRectangle As RectangleF _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
layoutRectangle
A .NET RectangleF structure that specifies the location of the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)

IGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)
See Also

Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawString (
string s,
Font font,
Brush brush,
RectangleF layoutRectangle,
StringFormat format
)
Visual Basic

Public MustOverride Sub DrawString ( _
s As String, _
font As Font, _
brush As Brush, _
layoutRectangle As RectangleF, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
layoutRectangle
A .NET RectangleF structure that specifies the location of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, Single, Single)

IGraphics.DrawString Method (String, Font, Brush, Single, Single)
See Also

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawString (
string s,
Font font,
Brush brush,
float x,
float y
)
Visual Basic

Public MustOverride Sub DrawString ( _
s As String, _
font As Font, _
brush As Brush, _
x As Single, _
y As Single _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, Single, Single, StringFormat)

IGraphics.DrawString Method (String, Font, Brush, Single, Single, StringFormat)
See Also

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void DrawString (
string s,
Font font,
Brush brush,
float x,
float y,
StringFormat format
)
Visual Basic

Public MustOverride Sub DrawString ( _
s As String, _
font As Font, _
brush As Brush, _
x As Single, _
y As Single, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.EndContainer Method

IGraphics.EndContainer Method

Closes the current graphics container and restores the state of this IGraphics object to the state saved by a call to the BeginContainer method.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void EndContainer (
GraphicsContainer container
)
Visual Basic

Public MustOverride Sub EndContainer ( _
container As GraphicsContainer _
)

Parameters

container
A .NET GraphicsContainer object that represents the container this method restores.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.EndHyperLink Method

IGraphics.EndHyperLink Method

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void EndHyperLink ()
Visual Basic

Public MustOverride Sub EndHyperLink ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ExcludeClip Method

IGraphics.ExcludeClip Method

Updates the clip region of this IGraphics object to exclude the area specified by a .NET Rectangle structure.

Overload List

Name | Description
IGraphics.ExcludeClip (Rectangle) | Updates the clip region of this IGraphics object to exclude the area specified by a Rectangle structure.
IGraphics.ExcludeClip (Region) | Updates the clip region of this IGraphics object to exclude the area specified by a Region object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ExcludeClip Method (Rectangle)

IGraphics.ExcludeClip Method (Rectangle)
See Also

Updates the clip region of this IGraphics object to exclude the area specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void ExcludeClip (
Rectangle rect
)
Visual Basic

Public MustOverride Sub ExcludeClip ( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure that specifies the rectangle to exclude from the clip region.

See Also

ExcludeClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ExcludeClip Method (Region)

IGraphics.ExcludeClip Method (Region)
See Also

Updates the clip region of this IGraphics object to exclude the area specified by a Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void ExcludeClip (
Region region
)
Visual Basic

Public MustOverride Sub ExcludeClip ( _
region As Region _
)

Parameters

region
A .NET Region object that specifies the region to exclude from the clip region.

See Also

ExcludeClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method

IGraphics.FillClosedCurve Method

Fills the interior a closed cardinal spline curve defined by an array of Point structures.

Overload List

Name | Description
IGraphics.FillClosedCurve (Brush, Point[]) | Fills the interior a closed cardinal spline curve defined by an array of Point structures.
IGraphics.FillClosedCurve (Brush, Point[], FillMode) | Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode.
IGraphics.FillClosedCurve (Brush, Point[], FillMode, Single) | Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.
IGraphics.FillClosedCurve (Brush, PointF[]) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures.
IGraphics.FillClosedCurve (Brush, PointF[], FillMode) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode.
IGraphics.FillClosedCurve (Brush, PointF[], FillMode, Single) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, Point[])

IGraphics.FillClosedCurve Method (Brush, Point[])
See Also

Fills the interior a closed cardinal spline curve defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillClosedCurve (
Brush brush,
Point[] points
)
Visual Basic

Public MustOverride Sub FillClosedCurve ( _
brush As Brush, _
points() As Point _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, Point[], FillMode)

IGraphics.FillClosedCurve Method (Brush, Point[], FillMode)
See Also

Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillClosedCurve (
Brush brush,
Point[] points,
FillMode fillmode
)
Visual Basic

Public MustOverride Sub FillClosedCurve ( _
brush As Brush, _
points() As Point, _
fillmode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, Point[], FillMode, Single)

IGraphics.FillClosedCurve Method (Brush, Point[], FillMode, Single)
See Also

Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillClosedCurve (
Brush brush,
Point[] points,
FillMode fillmode,
float tension
)
Visual Basic

Public MustOverride Sub FillClosedCurve ( _
brush As Brush, _
points() As Point, _
fillmode As FillMode, _
tension As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, PointF[])

IGraphics.FillClosedCurve Method (Brush, PointF[])
See Also

Fills the interior a closed cardinal spline curve defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillClosedCurve (
Brush brush,
PointF[] points
)
Visual Basic

Public MustOverride Sub FillClosedCurve ( _
brush As Brush, _
points() As PointF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, PointF[], FillMode)

IGraphics.FillClosedCurve Method (Brush, PointF[], FillMode)
See Also

Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillClosedCurve (
Brush brush,
PointF[] points,
FillMode fillmode
)
Visual Basic

Public MustOverride Sub FillClosedCurve ( _
brush As Brush, _
points() As PointF, _
fillmode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, PointF[], FillMode, Single)

IGraphics.FillClosedCurve Method (Brush, PointF[], FillMode, Single)
See Also

Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillClosedCurve (
Brush brush,
PointF[] points,
FillMode fillmode,
float tension
)
Visual Basic

Public MustOverride Sub FillClosedCurve ( _
brush As Brush, _
points() As PointF, _
fillmode As FillMode, _
tension As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method

IGraphics.FillEllipse Method

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
IGraphics.FillEllipse (Brush, Int32, Int32, Int32, Int32) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
IGraphics.FillEllipse (Brush, Rectangle) | Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.
IGraphics.FillEllipse (Brush, RectangleF) | Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.
IGraphics.FillEllipse (Brush, Single, Single, Single, Single) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, Int32, Int32, Int32, Int32)

IGraphics.FillEllipse Method (Brush, Int32, Int32, Int32, Int32)
See Also

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillEllipse (
Brush brush,
int x,
int y,
int width,
int height
)
Visual Basic

Public MustOverride Sub FillEllipse ( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, Rectangle)

IGraphics.FillEllipse Method (Brush, Rectangle)
See Also

Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillEllipse (
Brush brush,
Rectangle rect
)
Visual Basic

Public MustOverride Sub FillEllipse ( _
brush As Brush, _
rect As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, RectangleF)

IGraphics.FillEllipse Method (Brush, RectangleF)
See Also

Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillEllipse (
Brush brush,
RectangleF rect
)
Visual Basic

Public MustOverride Sub FillEllipse ( _
brush As Brush, _
rect As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET RectangleF structure that represents the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, Single, Single, Single, Single)

IGraphics.FillEllipse Method (Brush, Single, Single, Single, Single)
See Also

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillEllipse (
Brush brush,
float x,
float y,
float width,
float height
)
Visual Basic

Public MustOverride Sub FillEllipse ( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPath Method

IGraphics.FillPath Method

Fills the interior of a .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillPath (
Brush brush,
GraphicsPath path
)
Visual Basic

Public MustOverride Sub FillPath ( _
brush As Brush, _
path As GraphicsPath _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
path
A .NET GraphicsPath object that represents the path to fill.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPie Method

IGraphics.FillPie Method

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Overload List

Name | Description
IGraphics.FillPie (Brush, Int32, Int32, Int32, Int32, Int32, Int32) | Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
IGraphics.FillPie (Brush, Rectangle, Single, Single) | Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.
IGraphics.FillPie (Brush, Single, Single, Single, Single, Single, Single) | Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPie Method (Brush, Int32, Int32, Int32, Int32, Int32, Int32)

IGraphics.FillPie Method (Brush, Int32, Int32, Int32, Int32, Int32, Int32)
See Also

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillPie (
Brush brush,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)
Visual Basic

Public MustOverride Sub FillPie ( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPie Method (Brush, Rectangle, Single, Single)

IGraphics.FillPie Method (Brush, Rectangle, Single, Single)
See Also

Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillPie (
Brush brush,
Rectangle rect,
float startAngle,
float sweepAngle
)
Visual Basic

Public MustOverride Sub FillPie ( _
brush As Brush, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPie Method (Brush, Single, Single, Single, Single, Single, Single)

IGraphics.FillPie Method (Brush, Single, Single, Single, Single, Single, Single)
See Also

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillPie (
Brush brush,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)
Visual Basic

Public MustOverride Sub FillPie ( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method

IGraphics.FillPolygon Method

Fills the interior of a polygon defined by an array of points specified by Point structures.

Overload List

Name | Description
IGraphics.FillPolygon (Brush, Point[]) | Fills the interior of a polygon defined by an array of points specified by Point structures.
IGraphics.FillPolygon (Brush, Point[], FillMode) | Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.
IGraphics.FillPolygon (Brush, PointF[]) | Fills the interior of a polygon defined by an array of points specified by PointF structures.
IGraphics.FillPolygon (Brush, PointF[], FillMode) | Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method (Brush, Point[])

IGraphics.FillPolygon Method (Brush, Point[])
See Also

Fills the interior of a polygon defined by an array of points specified by Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillPolygon (
Brush brush,
Point[] points
)
Visual Basic

Public MustOverride Sub FillPolygon ( _
brush As Brush, _
points() As Point _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that represent the vertices of the polygon to fill.

See Also

FillPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method (Brush, Point[], FillMode)

IGraphics.FillPolygon Method (Brush, Point[], FillMode)
See Also

Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillPolygon (
Brush brush,
Point[] points,
FillMode fillMode
)
Visual Basic

Public MustOverride Sub FillPolygon ( _
brush As Brush, _
points() As Point, _
fillMode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that represent the vertices of the polygon to fill.
fillMode
Member of the .NET FillMode enumeration that determines the style of the fill.

See Also

FillPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method (Brush, PointF[])

IGraphics.FillPolygon Method (Brush, PointF[])
See Also

Fills the interior of a polygon defined by an array of points specified by PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillPolygon (
Brush brush,
PointF[] points
)
Visual Basic

Public MustOverride Sub FillPolygon ( _
brush As Brush, _
points() As PointF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that represent the vertices of the polygon to fill.

See Also

FillPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method (Brush, PointF[], FillMode)

IGraphics.FillPolygon Method (Brush, PointF[], FillMode)
See Also

Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillPolygon (
Brush brush,
PointF[] points,
FillMode fillMode
)
Visual Basic

Public MustOverride Sub FillPolygon ( _
brush As Brush, _
points() As PointF, _
fillMode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that represent the vertices of the polygon to fill.
fillMode
Member of the .NET FillMode enumeration that determines the style of the fill.

See Also

FillPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method

IGraphics.FillRectangle Method

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
IGraphics.FillRectangle (Brush, Int32, Int32, Int32, Int32) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
IGraphics.FillRectangle (Brush, Rectangle) | Fills the interior of a rectangle specified by a Rectangle structure.
IGraphics.FillRectangle (Brush, RectangleF) | Fills the interior of a rectangle specified by a RectangleF structure.
IGraphics.FillRectangle (Brush, Single, Single, Single, Single) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, Int32, Int32, Int32, Int32)

IGraphics.FillRectangle Method (Brush, Int32, Int32, Int32, Int32)
See Also

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillRectangle (
Brush brush,
int x,
int y,
int width,
int height
)
Visual Basic

Public MustOverride Sub FillRectangle ( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
The width of the rectangle to fill.
height
The height of the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, Rectangle)

IGraphics.FillRectangle Method (Brush, Rectangle)
See Also

Fills the interior of a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillRectangle (
Brush brush,
Rectangle rect
)
Visual Basic

Public MustOverride Sub FillRectangle ( _
brush As Brush, _
rect As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, RectangleF)

IGraphics.FillRectangle Method (Brush, RectangleF)
See Also

Fills the interior of a rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillRectangle (
Brush brush,
RectangleF rect
)
Visual Basic

Public MustOverride Sub FillRectangle ( _
brush As Brush, _
rect As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET RectangleF structure that represents the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, Single, Single, Single, Single)

IGraphics.FillRectangle Method (Brush, Single, Single, Single, Single)
See Also

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillRectangle (
Brush brush,
float x,
float y,
float width,
float height
)
Visual Basic

Public MustOverride Sub FillRectangle ( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
The width of the rectangle to fill.
height
The height of the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangles Method

IGraphics.FillRectangles Method

Fills the interiors of a series of rectangles specified by Rectangle structures.

Overload List

Name | Description
IGraphics.FillRectangles (Brush, Rectangle[]) | Fills the interiors of a series of rectangles specified by Rectangle structures.
IGraphics.FillRectangles (Brush, RectangleF[]) | Fills the interiors of a series of rectangles specified by RectangleF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangles Method (Brush, Rectangle[])

IGraphics.FillRectangles Method (Brush, Rectangle[])
See Also

Fills the interiors of a series of rectangles specified by Rectangle structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillRectangles (
Brush brush,
Rectangle[] rects
)
Visual Basic

Public MustOverride Sub FillRectangles ( _
brush As Brush, _
rects() As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rects
An array of .NET Rectangle structures that represent the rectangles to fill.

See Also

FillRectangles Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangles Method (Brush, RectangleF[])

IGraphics.FillRectangles Method (Brush, RectangleF[])
See Also

Fills the interiors of a series of rectangles specified by RectangleF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillRectangles (
Brush brush,
RectangleF[] rects
)
Visual Basic

Public MustOverride Sub FillRectangles ( _
brush As Brush, _
rects() As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rects
An array of .NET RectangleF structures that represent the rectangles to fill.

See Also

FillRectangles Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRegion Method

IGraphics.FillRegion Method

Fills the interior of a .NET Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void FillRegion (
Brush brush,
Region region
)
Visual Basic

Public MustOverride Sub FillRegion ( _
brush As Brush, _
region As Region _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
region
A .NET Region object that represents the area to fill.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Flush Method

IGraphics.Flush Method

Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.

Overload List

Name | Description
IGraphics.Flush () | Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
IGraphics.Flush (FlushIntention) | Forces execution of all pending graphics operations with the method waiting or not waiting, as specified, to return before the operations finish.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Flush Method ()

IGraphics.Flush Method ()
See Also

Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void Flush ()
Visual Basic

Public MustOverride Sub Flush ()

See Also

Flush Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Flush Method (FlushIntention)

IGraphics.Flush Method (FlushIntention)
See Also

Forces execution of all pending graphics operations with the method waiting or not waiting, as specified, to return before the operations finish.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void Flush (
FlushIntention intention
)
Visual Basic

Public MustOverride Sub Flush ( _
intention As FlushIntention _
)

Parameters

intention
Member of the .NET FlushIntention enumeration that specifies whether the method returns immediately or waits for any existing operations to finish.

See Also

Flush Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.GetFontHeight Method

IGraphics.GetFontHeight Method

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract float GetFontHeight (
Font font
)
Visual Basic

Public MustOverride Function GetFontHeight ( _
font As Font _
) As Single

Parameters

font

Return Value

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.GetHdc Method

IGraphics.GetHdc Method

Gets the handle to the device context associated with this IGraphics.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract IntPtr GetHdc ()
Visual Basic

Public MustOverride Function GetHdc () As IntPtr

Return Value

Handle to the device context associated with this IGraphics.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.GetNearestColor Method

IGraphics.GetNearestColor Method

Gets the nearest color to the specified Color structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract Color GetNearestColor (
Color color
)
Visual Basic

Public MustOverride Function GetNearestColor ( _
color As Color _
) As Color

Parameters

color
A .NET Color structure for which to find a match.

Return Value

A .NET Color structure that represents the nearest color to the one specified with the color parameter.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IntersectClip Method

IGraphics.IntersectClip Method

Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.

Overload List

Name | Description
IGraphics.IntersectClip (Rectangle) | Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IGraphics.IntersectClip (RectangleF) | Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified RectangleF structure.
IGraphics.IntersectClip (Region) | Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Region object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IntersectClip Method (Rectangle)

IGraphics.IntersectClip Method (Rectangle)
See Also

Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void IntersectClip (
Rectangle rect
)
Visual Basic

Public MustOverride Sub IntersectClip ( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure to intersect with the current clip region.

See Also

IntersectClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IntersectClip Method (RectangleF)

IGraphics.IntersectClip Method (RectangleF)
See Also

Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void IntersectClip (
RectangleF rect
)
Visual Basic

Public MustOverride Sub IntersectClip ( _
rect As RectangleF _
)

Parameters

rect
A .NET RectangleF structure to intersect with the current clip region.

See Also

IntersectClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IntersectClip Method (Region)

IGraphics.IntersectClip Method (Region)
See Also

Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void IntersectClip (
Region region
)
Visual Basic

Public MustOverride Sub IntersectClip ( _
region As Region _
)

Parameters

region
A .NET Region object to intersect with the current region.

See Also

IntersectClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method

IGraphics.IsVisible Method

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.

Overload List

Name | Description
IGraphics.IsVisible (Int32, Int32) | Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Int32, Int32, Int32, Int32) | Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Point) | Indicates whether the specified Point structure is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (PointF) | Indicates whether the specified PointF structure is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Rectangle) | Indicates whether the rectangle specified by a Rectangle structure is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (RectangleF) | Indicates whether the rectangle specified by a RectangleF structure is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Single, Single) | Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Single, Single, Single, Single) | Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Int32, Int32)

IGraphics.IsVisible Method (Int32, Int32)
See Also

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract bool IsVisible (
int x,
int y
)
Visual Basic

Public MustOverride Function IsVisible ( _
x As Integer, _
y As Integer _
) As Boolean

Parameters

x
The x-coordinate of the point to test for visibility.
y
The y-coordinate of the point to test for visibility.

Return Value

This method returns true if the point defined by the x and y parameters is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Int32, Int32, Int32, Int32)

IGraphics.IsVisible Method (Int32, Int32, Int32, Int32)
See Also

Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract bool IsVisible (
int x,
int y,
int width,
int height
)
Visual Basic

Public MustOverride Function IsVisible ( _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
) As Boolean

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test for visibility.
y
The y-coordinate of the upper-left corner of the rectangle to test for visibility.
width
The width of the rectangle to test for visibility.
height
The height of the rectangle to test for visibility.

Return Value

This method returns true if the rectangle defined by the x, y, width, and height parameters is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Point)

IGraphics.IsVisible Method (Point)
See Also

Indicates whether the specified Point structure is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract bool IsVisible (
Point point
)
Visual Basic

Public MustOverride Function IsVisible ( _
point As Point _
) As Boolean

Parameters

point
A .NET Point structure to test for visibility.

Return Value

This method returns true if the point specified by the point parameter is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (PointF)

IGraphics.IsVisible Method (PointF)
See Also

Indicates whether the specified PointF structure is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract bool IsVisible (
PointF point
)
Visual Basic

Public MustOverride Function IsVisible ( _
point As PointF _
) As Boolean

Parameters

point
A .NET PointF structure to test for visibility.

Return Value

This method returns true if the point specified by the point parameter is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Rectangle)

IGraphics.IsVisible Method (Rectangle)
See Also

Indicates whether the rectangle specified by a Rectangle structure is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract bool IsVisible (
Rectangle rect
)
Visual Basic

Public MustOverride Function IsVisible ( _
rect As Rectangle _
) As Boolean

Parameters

rect
A .NET Rectangle structure to test for visibility.

Return Value

This method returns true if the rectangle specified by the rect parameter is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (RectangleF)

IGraphics.IsVisible Method (RectangleF)
See Also

Indicates whether the rectangle specified by a RectangleF structure is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract bool IsVisible (
RectangleF rect
)
Visual Basic

Public MustOverride Function IsVisible ( _
rect As RectangleF _
) As Boolean

Parameters

rect
A .NET RectangleF structure to test for visibility.

Return Value

This method returns true if the rectangle specified by the rect parameter is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Single, Single)

IGraphics.IsVisible Method (Single, Single)
See Also

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract bool IsVisible (
float x,
float y
)
Visual Basic

Public MustOverride Function IsVisible ( _
x As Single, _
y As Single _
) As Boolean

Parameters

x
The x-coordinate of the point to test for visibility.
y
The y-coordinate of the point to test for visibility.

Return Value

This method returns true if the point defined by the x and y parameters is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Single, Single, Single, Single)

IGraphics.IsVisible Method (Single, Single, Single, Single)
See Also

Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract bool IsVisible (
float x,
float y,
float width,
float height
)
Visual Basic

Public MustOverride Function IsVisible ( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As Boolean

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test for visibility.
y
The y-coordinate of the upper-left corner of the rectangle to test for visibility.
width
The width of the rectangle to test for visibility.
height
The height of the rectangle to test for visibility.

Return Value

This method returns true if the rectangle defined by the x, y, width, and height parameters is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureCharacterRanges Method

IGraphics.MeasureCharacterRanges Method

Gets an array of Region objects, each of which bounds a range of character positions within the specified string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract RectangleF[] MeasureCharacterRanges (
string text,
Font font,
RectangleF layoutRect,
StringFormat stringFormat
)
Visual Basic

Public MustOverride Function MeasureCharacterRanges ( _
text As String, _
font As Font, _
layoutRect As RectangleF, _
stringFormat As StringFormat _
) As RectangleF()

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
layoutRect
A .NET RectangleF structure that specifies the layout rectangle for the string.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns an array of .NET Region objects, each of which bounds a range of character positions within the specified string.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method

IGraphics.MeasureString Method

Measures the specified string when drawn with the specified Font object.

Overload List

Name | Description
IGraphics.MeasureString (String, Font) | Measures the specified string when drawn with the specified Font object.
IGraphics.MeasureString (String, Font, Int32) | Measures the specified string when drawn with the specified Font object.
IGraphics.MeasureString (String, Font, Int32, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
IGraphics.MeasureString (String, Font, PointF, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
IGraphics.MeasureString (String, Font, SizeF) | Measures the specified string when drawn with the specified Font object within the specified layout area.
IGraphics.MeasureString (String, Font, SizeF, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
IGraphics.MeasureString (String, Font, SizeF, StringFormat, Int32@, Int32@) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font)

IGraphics.MeasureString Method (String, Font)
See Also

Measures the specified string when drawn with the specified Font object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract SizeF MeasureString (
string text,
Font font
)
Visual Basic

Public MustOverride Function MeasureString ( _
text As String, _
font As Font _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified by the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, Int32)

IGraphics.MeasureString Method (String, Font, Int32)
See Also

Measures the specified string when drawn with the specified Font object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract SizeF MeasureString (
string text,
Font font,
int width
)
Visual Basic

Public MustOverride Function MeasureString ( _
text As String, _
font As Font, _
width As Integer _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the format of the string.
width
The maximum width of the string in pixels.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, Int32, StringFormat)

IGraphics.MeasureString Method (String, Font, Int32, StringFormat)
See Also

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract SizeF MeasureString (
string text,
Font font,
int width,
StringFormat format
)
Visual Basic

Public MustOverride Function MeasureString ( _
text As String, _
font As Font, _
width As Integer, _
format As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
width
The maximum width of the string.
format
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, PointF, StringFormat)

IGraphics.MeasureString Method (String, Font, PointF, StringFormat)
See Also

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract SizeF MeasureString (
string text,
Font font,
PointF origin,
StringFormat stringFormat
)
Visual Basic

Public MustOverride Function MeasureString ( _
text As String, _
font As Font, _
origin As PointF, _
stringFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
origin
A .NET PointF structure that represents the upper-left corner of the string.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size of the string, in pixels, of the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, SizeF)

IGraphics.MeasureString Method (String, Font, SizeF)
See Also

Measures the specified string when drawn with the specified Font object within the specified layout area.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract SizeF MeasureString (
string text,
Font font,
SizeF layoutArea
)
Visual Basic

Public MustOverride Function MeasureString ( _
text As String, _
font As Font, _
layoutArea As SizeF _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, SizeF, StringFormat)

IGraphics.MeasureString Method (String, Font, SizeF, StringFormat)
See Also

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract SizeF MeasureString (
string text,
Font font,
SizeF layoutArea,
StringFormat stringFormat
)
Visual Basic

Public MustOverride Function MeasureString ( _
text As String, _
font As Font, _
layoutArea As SizeF, _
stringFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, SizeF, StringFormat, Int32@, Int32@)

IGraphics.MeasureString Method (String, Font, SizeF, StringFormat, Int32@, Int32@)
See Also

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract SizeF MeasureString (
string text,
Font font,
SizeF layoutArea,
StringFormat stringFormat,
ref int charactersFitted,
ref int linesFilled
)
Visual Basic

Public MustOverride Function MeasureString ( _
text As String, _
font As Font, _
layoutArea As SizeF, _
stringFormat As StringFormat, _
ByRef charactersFitted As Integer, _
ByRef linesFilled As Integer _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.
charactersFitted
Number of characters in the string.
linesFilled
Number of text lines in the string.

Return Value

This method returns a .NET SizeF structure that represents the size of the string, in pixels, of the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MultiplyTransform Method

IGraphics.MultiplyTransform Method

Multiplies the world transformation of this IGraphics object and specified the .NET Matrix object.

Overload List

Name | Description
IGraphics.MultiplyTransform (Matrix) | Multiplies the world transformation of this IGraphics object and specified the Matrix object.
IGraphics.MultiplyTransform (Matrix, MatrixOrder) | Multiplies the world transformation of this IGraphics object and specified the Matrix object in the specified order.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MultiplyTransform Method (Matrix)

IGraphics.MultiplyTransform Method (Matrix)
See Also

Multiplies the world transformation of this IGraphics object and specified the Matrix object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void MultiplyTransform (
Matrix matrix
)
Visual Basic

Public MustOverride Sub MultiplyTransform ( _
matrix As Matrix _
)

Parameters

matrix
A 4x4 .NET Matrix object that multiplies the world transformation.

See Also

MultiplyTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MultiplyTransform Method (Matrix, MatrixOrder)

IGraphics.MultiplyTransform Method (Matrix, MatrixOrder)
See Also

Multiplies the world transformation of this IGraphics object and specified the Matrix object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void MultiplyTransform (
Matrix matrix,
MatrixOrder order
)
Visual Basic

Public MustOverride Sub MultiplyTransform ( _
matrix As Matrix, _
order As MatrixOrder _
)

Parameters

matrix
A 4x4 .NET Matrix object that multiplies the world transformation.
order
Member of the .NET MatrixOrder enumeration that determines the order of the multiplication.

See Also

MultiplyTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ReleaseHdc Method

IGraphics.ReleaseHdc Method

Releases a device context handle obtained by a previous call to the GetHdc method of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void ReleaseHdc (
IntPtr hdc
)
Visual Basic

Public MustOverride Sub ReleaseHdc ( _
hdc As IntPtr _
)

Parameters

hdc
Handle to a device context obtained by a previous call to the GetHdc method of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ReleaseHdcInternal Method

IGraphics.ReleaseHdcInternal Method

Internal method. Do not use.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void ReleaseHdcInternal (
IntPtr hdc
)
Visual Basic

Public MustOverride Sub ReleaseHdcInternal ( _
hdc As IntPtr _
)

Parameters

hdc
Handle to a device context.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ResetClip Method

IGraphics.ResetClip Method

Resets the clip region of this IGraphics object to an infinite region.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void ResetClip ()
Visual Basic

Public MustOverride Sub ResetClip ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ResetTransform Method

IGraphics.ResetTransform Method

Resets the world transformation matrix of this IGraphics object to the identity matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void ResetTransform ()
Visual Basic

Public MustOverride Sub ResetTransform ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Restore Method

IGraphics.Restore Method

Restores the state of this IGraphics object to the state represented by a GraphicsState object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void Restore (
GraphicsState gstate
)
Visual Basic

Public MustOverride Sub Restore ( _
gstate As GraphicsState _
)

Parameters

gstate
A .NET GraphicsState object that represents the state to which to restore this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.RotateTransform Method

IGraphics.RotateTransform Method

Applies the specified rotation to the transformation matrix of this IGraphics object.

Overload List

Name | Description
IGraphics.RotateTransform (Single) | Applies the specified rotation to the transformation matrix of this IGraphics object.
IGraphics.RotateTransform (Single, MatrixOrder) | Applies the specified rotation to the transformation matrix of this IGraphics object in the specified order.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.RotateTransform Method (Single)

IGraphics.RotateTransform Method (Single)
See Also

Applies the specified rotation to the transformation matrix of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void RotateTransform (
float angle
)
Visual Basic

Public MustOverride Sub RotateTransform ( _
angle As Single _
)

Parameters

angle
The angle of rotation in degrees.

See Also

RotateTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.RotateTransform Method (Single, MatrixOrder)

IGraphics.RotateTransform Method (Single, MatrixOrder)
See Also

Applies the specified rotation to the transformation matrix of this IGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void RotateTransform (
float angle,
MatrixOrder order
)
Visual Basic

Public MustOverride Sub RotateTransform ( _
angle As Single, _
order As MatrixOrder _
)

Parameters

angle
The angle of rotation in degrees.
order
Member of the .NET MatrixOrder enumeration that specifies whether the rotation is appended or prepended to the matrix transformation.

See Also

RotateTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Save Method

IGraphics.Save Method

Saves the current state of this IGraphics object and identifies the saved state with a GraphicsState object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract GraphicsState Save ()
Visual Basic

Public MustOverride Function Save () As GraphicsState

Return Value

This method returns a .NET GraphicsState object that represents the saved state of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ScaleTransform Method

IGraphics.ScaleTransform Method

Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.

Overload List

Name | Description
IGraphics.ScaleTransform (Single, Single) | Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.
IGraphics.ScaleTransform (Single, Single, MatrixOrder) | Applies the specified scaling operation to the transformation matrix of this IGraphics object in the specified order.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ScaleTransform Method (Single, Single)

IGraphics.ScaleTransform Method (Single, Single)
See Also

Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void ScaleTransform (
float sx,
float sy
)
Visual Basic

Public MustOverride Sub ScaleTransform ( _
sx As Single, _
sy As Single _
)

Parameters

sx
The scale factor in the x direction.
sy
The scale factor in the y direction.

See Also

ScaleTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ScaleTransform Method (Single, Single, MatrixOrder)

IGraphics.ScaleTransform Method (Single, Single, MatrixOrder)
See Also

Applies the specified scaling operation to the transformation matrix of this IGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void ScaleTransform (
float sx,
float sy,
MatrixOrder order
)
Visual Basic

Public MustOverride Sub ScaleTransform ( _
sx As Single, _
sy As Single, _
order As MatrixOrder _
)

Parameters

sx
The scale factor in the x direction.
sy
The scale factor in the y direction.
order
Member of the .NET MatrixOrder enumeration that specifies whether the scaling operation is prepended or appended to the transformation matrix.

See Also

ScaleTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method

IGraphics.SetClip Method

Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.

Overload List

Name | Description
IGraphics.SetClip (GraphicsPath) | Sets the clipping region of this IGraphics object to the specified .NET GraphicsPath object.
IGraphics.SetClip (GraphicsPath, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified .NET GraphicsPath object.
IGraphics.SetClip (IGraphics) | Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.
IGraphics.SetClip (IGraphics, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified combining operation of the current clip region and the Clip property of the specified IGraphics object.
IGraphics.SetClip (Rectangle) | Sets the clipping region of this IGraphics object to the rectangle specified by a Rectangle structure.
IGraphics.SetClip (Rectangle, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a Rectangle structure.
IGraphics.SetClip (RectangleF) | Sets the clipping region of this IGraphics object to the rectangle specified by a RectangleF structure.
IGraphics.SetClip (RectangleF, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a RectangleF structure.
IGraphics.SetClip (Region, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified Region object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (GraphicsPath)

IGraphics.SetClip Method (GraphicsPath)
See Also

Sets the clipping region of this IGraphics object to the specified .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void SetClip (
GraphicsPath path
)
Visual Basic

Public MustOverride Sub SetClip ( _
path As GraphicsPath _
)

Parameters

path
A .NET GraphicsPath object that represents the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (GraphicsPath, CombineMode)

IGraphics.SetClip Method (GraphicsPath, CombineMode)
See Also

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void SetClip (
GraphicsPath path,
CombineMode combineMode
)
Visual Basic

Public MustOverride Sub SetClip ( _
path As GraphicsPath, _
combineMode As CombineMode _
)

Parameters

path
A .NET GraphicsPath object to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (IGraphics)

IGraphics.SetClip Method (IGraphics)
See Also

Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void SetClip (
IGraphics g
)
Visual Basic

Public MustOverride Sub SetClip ( _
g As IGraphics _
)

Parameters

g
An IGraphics object from which to take the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (IGraphics, CombineMode)

IGraphics.SetClip Method (IGraphics, CombineMode)
See Also

Sets the clipping region of this IGraphics object to the result of the specified combining operation of the current clip region and the Clip property of the specified IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void SetClip (
IGraphics g,
CombineMode combineMode
)
Visual Basic

Public MustOverride Sub SetClip ( _
g As IGraphics, _
combineMode As CombineMode _
)

Parameters

g
An IGraphics object that specifies the clip region to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (Rectangle)

IGraphics.SetClip Method (Rectangle)
See Also

Sets the clipping region of this IGraphics object to the rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void SetClip (
Rectangle rect
)
Visual Basic

Public MustOverride Sub SetClip ( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure that represents the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (Rectangle, CombineMode)

IGraphics.SetClip Method (Rectangle, CombineMode)
See Also

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void SetClip (
Rectangle rect,
CombineMode combineMode
)
Visual Basic

Public MustOverride Sub SetClip ( _
rect As Rectangle, _
combineMode As CombineMode _
)

Parameters

rect
A .NET Rectangle structure to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (RectangleF)

IGraphics.SetClip Method (RectangleF)
See Also

Sets the clipping region of this IGraphics object to the rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void SetClip (
RectangleF rect
)
Visual Basic

Public MustOverride Sub SetClip ( _
rect As RectangleF _
)

Parameters

rect
A .NET RectangleF structure that represents the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (RectangleF, CombineMode)

IGraphics.SetClip Method (RectangleF, CombineMode)
See Also

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void SetClip (
RectangleF rect,
CombineMode combineMode
)
Visual Basic

Public MustOverride Sub SetClip ( _
rect As RectangleF, _
combineMode As CombineMode _
)

Parameters

rect
A .NET RectangleF structure to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (Region, CombineMode)

IGraphics.SetClip Method (Region, CombineMode)
See Also

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void SetClip (
Region region,
CombineMode combineMode
)
Visual Basic

Public MustOverride Sub SetClip ( _
region As Region, _
combineMode As CombineMode _
)

Parameters

region
A .NET Region object to combine.
combineMode
Member from the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TransformPoints Method

IGraphics.TransformPoints Method

Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.

Overload List

Name | Description
IGraphics.TransformPoints (CoordinateSpace, CoordinateSpace, Point[]) | Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.
IGraphics.TransformPoints (CoordinateSpace, CoordinateSpace, PointF[]) | Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, Point[])

IGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, Point[])
See Also

Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void TransformPoints (
CoordinateSpace destSpace,
CoordinateSpace srcSpace,
Point[] pts
)
Visual Basic

Public MustOverride Sub TransformPoints ( _
destSpace As CoordinateSpace, _
srcSpace As CoordinateSpace, _
pts() As Point _
)

Parameters

destSpace
Member of the .NET CoordinateSpace enumeration that specifies the destination coordinate space.
srcSpace
Member of the .NET CoordinateSpace enumeration that specifies the source coordinate space.
pts
An array of .NET Point structures that represents the points to transformation.

See Also

TransformPoints Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, PointF[])

IGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, PointF[])
See Also

Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void TransformPoints (
CoordinateSpace destSpace,
CoordinateSpace srcSpace,
PointF[] pts
)
Visual Basic

Public MustOverride Sub TransformPoints ( _
destSpace As CoordinateSpace, _
srcSpace As CoordinateSpace, _
pts() As PointF _
)

Parameters

destSpace
Member of the .NET CoordinateSpace enumeration that specifies the destination coordinate space.
srcSpace
Member of the .NET CoordinateSpace enumeration that specifies the source coordinate space.
pts
An array of .NET PointF structures that represent the points to transform.

See Also

TransformPoints Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateClip Method

IGraphics.TranslateClip Method

Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.

Overload List

Name | Description
IGraphics.TranslateClip (Int32, Int32) | Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.
IGraphics.TranslateClip (Single, Single) | Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateClip Method (Int32, Int32)

IGraphics.TranslateClip Method (Int32, Int32)
See Also

Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void TranslateClip (
int dx,
int dy
)
Visual Basic

Public MustOverride Sub TranslateClip ( _
dx As Integer, _
dy As Integer _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateClip Method (Single, Single)

IGraphics.TranslateClip Method (Single, Single)
See Also

Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void TranslateClip (
float dx,
float dy
)
Visual Basic

Public MustOverride Sub TranslateClip ( _
dx As Single, _
dy As Single _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateTransform Method

IGraphics.TranslateTransform Method

Prepends the specified translation to the transformation matrix of this IGraphics object.

Overload List

Name | Description
IGraphics.TranslateTransform (Single, Single) | Prepends the specified translation to the transformation matrix of this IGraphics object.
IGraphics.TranslateTransform (Single, Single, MatrixOrder) | Applies the specified translation to the transformation matrix of this IGraphics object in the specified order.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateTransform Method (Single, Single)

IGraphics.TranslateTransform Method (Single, Single)
See Also

Prepends the specified translation to the transformation matrix of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void TranslateTransform (
float dx,
float dy
)
Visual Basic

Public MustOverride Sub TranslateTransform ( _
dx As Single, _
dy As Single _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateTransform Method (Single, Single, MatrixOrder)

IGraphics.TranslateTransform Method (Single, Single, MatrixOrder)
See Also

Applies the specified translation to the transformation matrix of this IGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract void TranslateTransform (
float dx,
float dy,
MatrixOrder order
)
Visual Basic

Public MustOverride Sub TranslateTransform ( _
dx As Single, _
dy As Single, _
order As MatrixOrder _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.
order
Member of the .NET MatrixOrder enumeration that specifies whether the translation is prepended or appended to the transformation matrix.

See Also

TranslateTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Properties

IGraphics Properties

Public Properties

Name | Description
Clip | Gets or sets a .NET Region object that limits the drawing region of this IGraphics object.
ClipBounds | Gets a .NET RectangleF structure that bounds the clipping region of this IGraphics object.
CompositingMode | Gets or sets a value that specifies how composited images are drawn to this IGraphics object.
CompositingQuality | Gets or sets the rendering quality of composited images drawn to this IGraphics object.
DpiX | Gets the horizontal resolution of this IGraphics object.
DpiY | Gets the vertical resolution of this IGraphics object.
InterpolationMode | Gets or sets the interpolation mode associated with this IGraphics object.
IsClipEmpty | Gets a value indicating whether the clipping region of this IGraphics object is empty.
IsVisibleClipEmpty | Gets a value indicating whether the visible clipping region of this IGraphics object is empty.
PageScale | Gets or sets the scaling between world units and page units for this IGraphics object.
PageUnit | Gets or sets the unit of measure used for page coordinates in this IGraphics object.
PixelOffsetMode | Gets or set a value specifying how pixels are offset during rendering of this IGraphics object.
RenderingOrigin | Gets or sets the rendering origin of this IGraphics object for dithering and for hatch brushes.
SmoothingMode | Gets or sets the rendering quality for this IGraphics object.
TextContrast | Gets or sets the gamma correction value for rendering text.
TextRenderingHint | Gets or sets the rendering mode for text associated with this IGraphics object.
Transform | Gets or sets the world transformation for this IGraphics object.
VisibleClipBounds | Gets or sets the bounding rectangle of the visible clipping region of this IGraphics object.

See Also

IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Clip Property

IGraphics.Clip Property

Gets or sets a .NET Region object that limits the drawing region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract Region Clip { get; set; }
Visual Basic

Public MustOverride Property Clip As Region

Property Value

This property specifies a .NET Region object that limits the portion of this IGraphics object that is currently available for drawing.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ClipBounds Property

IGraphics.ClipBounds Property

Gets a .NET RectangleF structure that bounds the clipping region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract RectangleF ClipBounds { get; }
Visual Basic

Public MustOverride ReadOnly Property ClipBounds As RectangleF

Property Value

This property indicates a .NET RectangleF structure that represents a bounding rectangle for the clipping region of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.CompositingMode Property

IGraphics.CompositingMode Property

Gets or sets a value that specifies how composited images are drawn to this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract CompositingMode CompositingMode { get; set; }
Visual Basic

Public MustOverride Property CompositingMode As CompositingMode

Property Value

This property specifies a member of the .NET CompositingMode enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.CompositingQuality Property

IGraphics.CompositingQuality Property

Gets or sets the rendering quality of composited images drawn to this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract CompositingQuality CompositingQuality { get; set; }
Visual Basic

Public MustOverride Property CompositingQuality As CompositingQuality

Property Value

This property specifies a member of the .NET CompositingQuality enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DpiX Property

IGraphics.DpiX Property

Gets the horizontal resolution of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract float DpiX { get; }
Visual Basic

Public MustOverride ReadOnly Property DpiX As Single

Property Value

This property indicates a value, in dots per inch, for the horizontal resolution supported by this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DpiY Property

IGraphics.DpiY Property

Gets the vertical resolution of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract float DpiY { get; }
Visual Basic

Public MustOverride ReadOnly Property DpiY As Single

Property Value

This property indicates a value, in dots per inch, for the vertical resolution supported by this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.InterpolationMode Property

IGraphics.InterpolationMode Property

Gets or sets the interpolation mode associated with this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract InterpolationMode InterpolationMode { get; set; }
Visual Basic

Public MustOverride Property InterpolationMode As InterpolationMode

Property Value

This property specifies a member of the InterpolationMode enumeration associated with this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsClipEmpty Property

IGraphics.IsClipEmpty Property

Gets a value indicating whether the clipping region of this IGraphics object is empty.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract bool IsClipEmpty { get; }
Visual Basic

Public MustOverride ReadOnly Property IsClipEmpty As Boolean

Property Value

This property is true if the clipping region of this IGraphics object is empty; otherwise, false.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisibleClipEmpty Property

IGraphics.IsVisibleClipEmpty Property

Gets a value indicating whether the visible clipping region of this IGraphics object is empty.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract bool IsVisibleClipEmpty { get; }
Visual Basic

Public MustOverride ReadOnly Property IsVisibleClipEmpty As Boolean

Property Value

This property is true if the visible portion of the clipping region of this IGraphics object is empty; otherwise, false.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.PageScale Property

IGraphics.PageScale Property

Gets or sets the scaling between world units and page units for this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract float PageScale { get; set; }
Visual Basic

Public MustOverride Property PageScale As Single

Property Value

This property specifies a value for the scaling between world units and page units for this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.PageUnit Property

IGraphics.PageUnit Property

Gets or sets the unit of measure used for page coordinates in this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract GraphicsUnit PageUnit { get; set; }
Visual Basic

Public MustOverride Property PageUnit As GraphicsUnit

Property Value

This property specifies a member of the .NET GraphicsUnit enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.PixelOffsetMode Property

IGraphics.PixelOffsetMode Property

Gets or set a value specifying how pixels are offset during rendering of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract PixelOffsetMode PixelOffsetMode { get; set; }
Visual Basic

Public MustOverride Property PixelOffsetMode As PixelOffsetMode

Property Value

This property specifies a member of the .NET PixelOffsetMode enumeration

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.RenderingOrigin Property

IGraphics.RenderingOrigin Property

Gets or sets the rendering origin of this IGraphics object for dithering and for hatch brushes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract Point RenderingOrigin { get; set; }
Visual Basic

Public MustOverride Property RenderingOrigin As Point

Property Value

This property specifies a .NET Point structure that represents the dither origin for 8-bits-per-pixel and 16-bits-per-pixel dithering and is also used to set the origin for hatch brushes.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SmoothingMode Property

IGraphics.SmoothingMode Property

Gets or sets the rendering quality for this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract SmoothingMode SmoothingMode { get; set; }
Visual Basic

Public MustOverride Property SmoothingMode As SmoothingMode

Property Value

This property specifies a member of the .NET SmoothingMode enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TextContrast Property

IGraphics.TextContrast Property

Gets or sets the gamma correction value for rendering text.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract int TextContrast { get; set; }
Visual Basic

Public MustOverride Property TextContrast As Integer

Property Value

This property specifies a value of the gamma correction used for rendering antialiased and ClearType text.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TextRenderingHint Property

IGraphics.TextRenderingHint Property

Gets or sets the rendering mode for text associated with this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract TextRenderingHint TextRenderingHint { get; set; }
Visual Basic

Public MustOverride Property TextRenderingHint As TextRenderingHint

Property Value

This property specifies a member of the .NET TextRenderingHint enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Transform Property

IGraphics.Transform Property

Gets or sets the world transformation for this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract Matrix Transform { get; set; }
Visual Basic

Public MustOverride Property Transform As Matrix

Property Value

This property specifies a Matrix object that represents the world transformation for this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.VisibleClipBounds Property

IGraphics.VisibleClipBounds Property

Gets or sets the bounding rectangle of the visible clipping region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public abstract RectangleF VisibleClipBounds { get; }
Visual Basic

Public MustOverride ReadOnly Property VisibleClipBounds As RectangleF

Property Value

A .NET RectangleF structure that represents a bounding rectangle for the visible clipping region of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.ImageAlign Enumeration

ImageAlign Enumeration

Specifies the position and alignment of a picture relative to its destination rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public enum ImageAlign
Visual Basic

Public Enumeration ImageAlign

Members

Member name | Description
BottomCenter | The image is centered horizontally and aligned to the bottom side.
BottomLeft | The image is aligned to the bottom left corner.
BottomRight | The image is aligned to the bottom right corner.
Center | The image is centered.
Fit | The image is resized to fit the size the destination rectangle.
MiddleLeft | The image is centered vertically and aligned to the left-hand side.
MiddleRight | The image is centered vertically and aligned to the right-hand side.
Stretch | The image is stretched to fill the destination rectangle.
Tile | The image is tiled across the destination rectangle.
TopCenter | The image is centered horizontally and aligned to the top side.
TopLeft | The image is aligned to the top left corner.
TopRight | The image is aligned o the top right corner.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.ImageAlignment Enumeration

MindFusion Pack Programmer's Guide

ImageAlignment Enumeration
See Also

Specifies the alignment of an image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Scheduling

Syntax

C#

public enum ImageAlignment
Visual Basic

Public Enumeration ImageAlignment

Members

Member name | Description
Bottom | The image is aligned to the bottom side of the layout rectangle.
Center | The image is centered within the layout rectangle.
Fit | The image is stretched to fit in the layout rectangle, but its original ratio is preserved.
Left | The image is aligned to the left side of the layout rectangle.
None | Same as Center.
Right | The image is aligned to the right side of the layout rectangle.
Stretch | The image is stretched. Equal to Left | Top | Right | Bottom.
Tile | The image is tiled across the layout rectangle.
Top | The image is aligned to the top side of the layout rectangle.
Unspecified | Invalid image alignment.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Class

LinearGradientBrush Class
Remarks See Also

LinearGradientBrush objects represent brushes that fill the interiors of geometric shapes with a linear gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public class LinearGradientBrush : Brush, ISerializable
Visual Basic

Public Class LinearGradientBrush
Inherits Brush
Implements ISerializable

Remarks

The LinearGradientBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.Drawing2D.LinearGradientBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.LinearGradientBrush

See Also

LinearGradientBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Members

LinearGradientBrush Members
Constructors Properties Methods

LinearGradientBrush objects represent brushes that fill the interiors of geometric shapes with a linear gradient.

The following tables list the members exposed by the LinearGradientBrush type.

Public Constructors

Name | Description
LinearGradientBrush | Overloaded. Initializes a new instance of the LinearGradientBrush class.

Public Properties

Name | Description
Angle | Gets or sets the angle of the gradient's orientation line.
Blend | Gets or sets a .NET Blend object that specifies positions and factors that define a custom falloff for the gradient.
InterpolationColors | Gets or sets a .NET ColorBlend object that defines a multicolor linear gradient.
LinearColors | Gets or sets the starting and ending colors of the gradient.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Creates an instance of the System.Drawing.Drawing2D.LinearGradientBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Gradient".

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor

LinearGradientBrush Constructor

Initializes a new instance of the LinearGradientBrush class.

Overload List

Name | Description
LinearGradientBrush (Color, Color) | Initializes a new instance of the LinearGradientBrush class with the specified start and end colors.
LinearGradientBrush (Color, Color, Single) | Initializes a new instance of the LinearGradientBrush class with the specified start and end colors and an orientation angle measured in degrees.
LinearGradientBrush (String) | Initializes a new instance of the LinearGradientBrush class given its string representation.

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor (Color, Color)

LinearGradientBrush Constructor (Color, Color)
See Also

Initializes a new instance of the LinearGradientBrush class with the specified start and end colors.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public LinearGradientBrush (
Color color1,
Color color2
)
Visual Basic

Public New ( _
color1 As Color, _
color2 As Color _
)

Parameters

color1
The first color of the gradient.
color2
The second color of the gradient.

See Also

LinearGradientBrush Constructor Overload List
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor (Color, Color, Single)

LinearGradientBrush Constructor (Color, Color, Single)
See Also

Initializes a new instance of the LinearGradientBrush class with the specified start and end colors and an orientation angle measured in degrees.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public LinearGradientBrush (
Color color1,
Color color2,
float angle
)
Visual Basic

Public New ( _
color1 As Color, _
color2 As Color, _
angle As Single _
)

Parameters

color1
The first color of the gradient.
color2
The second color of the gradient.
angle
The gradient direction angle.

See Also

LinearGradientBrush Constructor Overload List
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor (String)

LinearGradientBrush Constructor (String)
See Also

Initializes a new instance of the LinearGradientBrush class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public LinearGradientBrush (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized bursh.

See Also

LinearGradientBrush Constructor Overload List
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Methods

LinearGradientBrush Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Creates an instance of the System.Drawing.Drawing2D.LinearGradientBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Gradient".

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Clone Method

LinearGradientBrush.Clone Method

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

An instance of the LinearGradientBrush class.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.CreateGdiBrush Method

LinearGradientBrush.CreateGdiBrush Method

Creates an instance of the System.Drawing.Drawing2D.LinearGradientBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override Brush CreateGdiBrush (
RectangleF rc
)
Visual Basic

Public Overrides Function CreateGdiBrush ( _
rc As RectangleF _
) As Brush

Parameters

rc
The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.GetObjectData Method

LinearGradientBrush.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)
Visual Basic

Public Overridable Sub GetObjectData ( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info
The object that holds the serialized object data.
context
The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.ToString Method

LinearGradientBrush.ToString Method

Returns "Gradient".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Properties

LinearGradientBrush Properties

Public Properties

Name | Description
Angle | Gets or sets the angle of the gradient's orientation line.
Blend | Gets or sets a .NET Blend object that specifies positions and factors that define a custom falloff for the gradient.
InterpolationColors | Gets or sets a .NET ColorBlend object that defines a multicolor linear gradient.
LinearColors | Gets or sets the starting and ending colors of the gradient.

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Angle Property

LinearGradientBrush.Angle Property

Gets or sets the angle of the gradient's orientation line.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public float Angle { get; set; }
Visual Basic

Public Property Angle As Single

Property Value

A float value that represents he angle, measured in degrees clockwise from the x-axis, of the gradient's orientation line.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Blend Property

LinearGradientBrush.Blend Property

Gets or sets a .NET Blend object that specifies positions and factors that define a custom falloff for the gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Blend Blend { get; set; }
Visual Basic

Public Property Blend As Blend

Property Value

An instance of the .NET Blend class that represents a custom falloff for the gradient.

Remarks

A Blend object contains corresponding arrays of blend factors and positions. The blend factors specify the percentages of the starting color and ending color to use at the corresponding position. The positions are specified as a percentage of distance along the gradient line.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.InterpolationColors Property

LinearGradientBrush.InterpolationColors Property

Gets or sets a .NET ColorBlend object that defines a multicolor linear gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public ColorBlend InterpolationColors { get; set; }
Visual Basic

Public Property InterpolationColors As ColorBlend

Property Value

An instance of the .NET ColorBlend class that defines a multicolor linear gradient.

Remarks

A ColorBlend object contains corresponding arrays of colors and positions. The positions are values from 0 through 1 that specify the percentage of the distance along the gradient line where the corresponding color is located.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.LinearColors Property

LinearGradientBrush.LinearColors Property

Gets or sets the starting and ending colors of the gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Color[] LinearColors { get; set; }
Visual Basic

Public Property LinearColors As Color()

Property Value

An array of two .NET Color objects that represents the starting and ending colors of the gradient.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Class

PathGradientBrush Class
Remarks See Also

PathGradientBrush represents a brush that fills the interiors of geometric shapes with a gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public class PathGradientBrush : Brush, ISerializable
Visual Basic

Public Class PathGradientBrush
Inherits Brush
Implements ISerializable

Remarks

The PathGradientBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.Drawing2D.PathGradientBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.PathGradientBrush

See Also

PathGradientBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Members

PathGradientBrush Members
Constructors Properties Methods

PathGradientBrush represents a brush that fills the interiors of geometric shapes with a gradient.

The following tables list the members exposed by the PathGradientBrush type.

Public Constructors

Name | Description
PathGradientBrush | Overloaded. Initializes a new instance of the PathGradientBrush class.

Public Properties

Name | Description
CenterColor | Gets or sets the color at the center of the gradient path.
CenterPoint | Gets or sets the center of the gradient path.
InterpolationColors | Gets or sets a ColorBlend object that defines a multiple color gradient.
SurroundingColor | Gets or sets the color drawn at the borders of the gradient path.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.Drawing2D.PathGradientBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "PathGradient".

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Constructor

PathGradientBrush Constructor

Initializes a new instance of the PathGradientBrush class.

Overload List

Name | Description
PathGradientBrush (Color, Color) | Initializes a new instance of the PathGradientBrush class with the specified center and surrounding colors.
PathGradientBrush (String) | Initializes a new instance of the PathGradientBrush class given its string representation.

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Constructor (Color, Color)

PathGradientBrush Constructor (Color, Color)
See Also

Initializes a new instance of the PathGradientBrush class with the specified center and surrounding colors.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public PathGradientBrush (
Color centerColor,
Color surroundingColor
)
Visual Basic

Public New ( _
centerColor As Color, _
surroundingColor As Color _
)

Parameters

centerColor
Specifies an initial center color.
surroundingColor
Specifies an initial surrounding color.

See Also

PathGradientBrush Constructor Overload List
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Constructor (String)

PathGradientBrush Constructor (String)
See Also

Initializes a new instance of the PathGradientBrush class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public PathGradientBrush (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation

A string that represents the serialized bursh.

See Also

PathGradientBrush Constructor Overload List
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Methods

PathGradientBrush Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.Drawing2D.PathGradientBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "PathGradient".

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.Clone Method

PathGradientBrush.Clone Method

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

An instance of the PathGradientBrush class.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.CreateGdiBrush Method

PathGradientBrush.CreateGdiBrush Method

Returns an instance of the System.Drawing.Drawing2D.PathGradientBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override Brush CreateGdiBrush (
RectangleF rc
)
Visual Basic

Public Overrides Function CreateGdiBrush ( _
rc As RectangleF _
) As Brush

Parameters

rc
The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.GetObjectData Method

PathGradientBrush.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)
Visual Basic

Public Overridable Sub GetObjectData ( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info
The object that holds the serialized object data.
context
The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.ToString Method

PathGradientBrush.ToString Method

Returns "PathGradient".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Properties

PathGradientBrush Properties

Public Properties

Name | Description
CenterColor | Gets or sets the color at the center of the gradient path.
CenterPoint | Gets or sets the center of the gradient path.
InterpolationColors | Gets or sets a ColorBlend object that defines a multiple color gradient.
SurroundingColor | Gets or sets the color drawn at the borders of the gradient path.

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.CenterColor Property

PathGradientBrush.CenterColor Property

Gets or sets the color at the center of the gradient path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Color CenterColor { get; set; }
Visual Basic

Public Property CenterColor As Color

Property Value

Instance of the .NET Color structure that represents the color at the center of the path gradient.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.CenterPoint Property

PathGradientBrush.CenterPoint Property

Gets or sets the center of the gradient path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public PointF CenterPoint { get; set; }
Visual Basic

Public Property CenterPoint As PointF

Property Value

A .NET PointF structure that represents the center point of the path gradient.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.InterpolationColors Property

PathGradientBrush.InterpolationColors Property

Gets or sets a ColorBlend object that defines a multiple color gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public ColorBlend InterpolationColors { get; set; }
Visual Basic

Public Property InterpolationColors As ColorBlend

Property Value

Instance of the .NET ColorBlend object that defines a multicolor linear gradient.

Remarks

A ColorBlend object contains corresponding arrays of colors and positions. The positions are values from 0 through 1 that specify the percentage of the distance along the gradient path where the corresponding color is located.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.SurroundingColor Property

PathGradientBrush.SurroundingColor Property

Gets or sets the color drawn at the borders of the gradient path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Color SurroundingColor { get; set; }
Visual Basic

Public Property SurroundingColor As Color

Property Value

Instance of .NET Color structure that represents the color at the border of the path gradient.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Class

Pen Class
Remarks See Also

Pen instances are used to draw the outline of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public class Pen : GraphicObject, ISerializable
Visual Basic

Public Class Pen
Inherits GraphicObject
Implements ISerializable

Remarks

The Pen class acts as a proxy for the .NET standard GDI+ System.Drawing.Pen class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Pen

See Also

Pen Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Members

Pen Members
Constructors Properties Methods

Pen instances are used to draw the outline of geometric shapes.

The following tables list the members exposed by the Pen type.

Public Constructors

Name | Description
Pen | Overloaded. Initialize a new instance of the Pen class.

Public Properties

Name | Description
Brush | Gets or sets the Brush object that determines attributes of this pen.
Color | Gets or sets the color of this pen.
CompoundArray | Gets or sets an array values that specify a compound pen. A compound pen draws a compound line made up of parallel lines and spaces.
DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
DashPattern | Gets or sets an array of custom dashes and spaces.
DashStyle | Gets or sets the style used for dashed lines drawn with this pen.
LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this pen.
MiterLimit | Gets or sets the limit of the thickness of the join on a mitered corner.
Width | Gets or sets the width of the pen.

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.
CreateGdiPen | Overloaded. Returns an instance of the System.Drawing.Pen class corresponding to the current pen.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the pen.
Serialize | Serializes the specified pen to a string.
ToString | Returns the string representation of this Pen object.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor

Pen Constructor

Initialize a new instance of the Pen class.

Overload List

Name | Description
Pen (Brush) | Initializes a new instance of the Pen class with a specified Brush object.
Pen (Brush, Single) | Initializes a new instance of the Pen class with the specified Brush object and the specified width.
Pen (Color) | Initializes a new instance of the Pen class with the specified color.
Pen (Color, Single) | Initializes a new instance of the Pen class with the specified color and width.
Pen (String) | Initializes a new instance of the Pen class given its string representation.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Brush)

Pen Constructor (Brush)
See Also

Initializes a new instance of the Pen class with a specified Brush object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Pen (
Brush brush
)
Visual Basic

Public Sub Pen ( _
brush As Brush _
)

Parameters

brush
A Brush instance that determines the fill properties of the new pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Brush, Single)

Pen Constructor (Brush, Single)
See Also

Initializes a new instance of the Pen class with the specified Brush object and the specified width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Pen (
Brush brush,
float width
)
Visual Basic

Public Sub Pen ( _
brush As Brush, _
width As Single _
)

Parameters

brush
A Brush instance that determines the fill properties of the new pen.
width
The width of the new pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Color)

Pen Constructor (Color)
See Also

Initializes a new instance of the Pen class with the specified color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Pen (
Color color
)
Visual Basic

Public New ( _
color As Color _
)

Parameters

color
A Color structure that specifies the color of the new pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Color, Single)

Pen Constructor (Color, Single)
See Also

Initializes a new instance of the Pen class with the specified color and width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Pen (
Color color,
float width
)
Visual Basic

Public New ( _
color As Color, _
width As Single _
)

Parameters

color
A Color structure that specifies the color of the new pen.
width
The width of the new pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (String)

Pen Constructor (String)
See Also

Initializes a new instance of the Pen class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Pen (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Methods

Pen Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.
CreateGdiPen | Overloaded. Returns an instance of the System.Drawing.Pen class corresponding to the current pen.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the pen.
Serialize | Serializes the specified pen to a string.
ToString | Returns the string representation of this Pen object.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Clone Method

Pen.Clone Method

Creates an exact copy of this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

An instance of the Pen class.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CreateGdiPen Method

Pen.CreateGdiPen Method

Returns an instance of the System.Drawing.Pen class corresponding to the current pen.

Overload List

Name | Description
Pen.CreateGdiPen () | Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.
Pen.CreateGdiPen (RectangleF) | Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CreateGdiPen Method ()

Pen.CreateGdiPen Method ()
See Also

Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Pen CreateGdiPen ()
Visual Basic

Public Function CreateGdiPen () As Pen

Return Value

A System.Drawing.Pen instance corresponding to this pen.

See Also

CreateGdiPen Method Overload List
Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CreateGdiPen Method (RectangleF)

Pen.CreateGdiPen Method (RectangleF)
See Also

Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Pen CreateGdiPen (
RectangleF rc
)
Visual Basic

Public Function CreateGdiPen ( _
rc As RectangleF _
) As Pen

Parameters

rc
The rectangle in which painting will be performed.

Return Value

A System.Drawing.Pen instance corresponding to this pen.

See Also

CreateGdiPen Method Overload List
Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.GetObjectData Method

Pen.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)
Visual Basic

Public Overridable Sub GetObjectData ( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info
The object that holds the serialized object data.
context
The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Serialize Method

Pen.Serialize Method

Serializes the specified pen to a string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public static string Serialize (
Pen pen
)
Visual Basic

Public Shared Function Serialize ( _
pen As Pen _
) As String

Parameters

pen

The Pen object to serialize.

Return Value

A string that represents the specified pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.ToString Method

Pen.ToString Method

Returns the string representation of this Pen object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string representing this pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Properties

Pen Properties

Public Properties

Name | Description
Brush | Gets or sets the Brush object that determines attributes of this pen.
Color | Gets or sets the color of this pen.
CompoundArray | Gets or sets an array values that specify a compound pen. A compound pen draws a compound line made up of parallel lines and spaces.
DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
DashPattern | Gets or sets an array of custom dashes and spaces.
DashStyle | Gets or sets the style used for dashed lines drawn with this pen.
LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this pen.
MiterLimit | Gets or sets the limit of the thickness of the join on a mitered corner.
Width | Gets or sets the width of the pen.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Brush Property

Pen.Brush Property

Gets or sets the Brush object that determines attributes of this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Brush Brush { get; set; }
Visual Basic

Public Property Brush As Brush

Property Value

An instance of the Brush class that determines attributes of this pen.

Remarks

Setting this property causes the pen to draw filled lines and curves. It overrides the Color property of the pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Color Property

Pen.Color Property

Gets or sets the color of this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Color Color { get; set; }
Visual Basic

Public Property Color As Color

Property Value

An instance of the .NET Color structure that represents the color of this pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CompoundArray Property

Pen.CompoundArray Property

Gets or sets an array values that specify a compound pen. A compound pen draws a compound line made up of parallel lines and spaces.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public float[] CompoundArray { get; set; }
Visual Basic

Public Property CompoundArray As Single()

Property Value

An array of real numbers that specifies the compound array. The elements in the array must be in increasing order, not less than 0, and not greater than 1.

Remarks

A compound line is made up of alternating parallel lines and spaces of varying widths. The values in the array specify the starting points of each component of the compound line relative to the pen's width. The first value in the array specifies where the first component (a line) begins as a fraction of the distance across the width of the pen. The second value in the array specifies the beginning of the next component (a space) as a fraction of the distance across the width of the pen. The final value in the array specifies where the last component ends.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.DashOffset Property

Pen.DashOffset Property

Gets or sets the distance from the start of a line to the beginning of a dash pattern.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public float DashOffset { get; set; }
Visual Basic

Public Property DashOffset As Single

Property Value

A float value representing the distance from the start of a line to the beginning of a dash pattern.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.DashPattern Property

Pen.DashPattern Property

Gets or sets an array of custom dashes and spaces.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public float[] DashPattern { get; set; }
Visual Basic

Public Property DashPattern As Single()

Property Value

An array of real numbers that specify the lengths of alternating dashes and spaces in dashed lines.

Remarks

The elements in the array set the length of each dash and space in the dash pattern. The first element sets the length of a dash, the second element sets the length of a space, the third element sets the length of a dash, and so on.The length of each dash and space in the dash pattern is the product of the element value in the array and the width of the pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.DashStyle Property

Pen.DashStyle Property

Gets or sets the style used for dashed lines drawn with this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public DashStyle DashStyle { get; set; }
Visual Basic

Public Property DashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration that represents the style used for dashed lines.

Remarks

A value of DashStyle.Custom for this property specifies that a custom pattern of dashes and spaces, defined by the DashPattern property, make up lines drawn with this pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.LineJoin Property

Pen.LineJoin Property

Gets or sets the join style for the ends of two consecutive lines drawn with this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public LineJoin LineJoin { get; set; }
Visual Basic

Public Property LineJoin As LineJoin

Property Value

A member of the .NET LineJoin enumeration that represents the join style for the ends of two consecutive lines.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.MiterLimit Property

Pen.MiterLimit Property

Gets or sets the limit of the thickness of the join on a mitered corner.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public float MiterLimit { get; set; }
Visual Basic

Public Property MiterLimit As Single

Property Value

A floag value representing the limit of the thickness of the join on a mitered corner. The default is 10.0f.

Remarks

The miter length is the distance from the intersection of the line walls on the inside of the join to the intersection of the line walls outside of the join. The miter length can be large when the angle between two lines is small. The miter limit is the maximum allowed ratio of miter length to stroke width. If the miter length of the join of the intersection exceeds the limit of the join, then the join will be beveled to keep it within the limit of the join of the intersection.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Width Property

Pen.Width Property

Gets or sets the width of the pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public float Width { get; set; }
Visual Basic

Public Property Width As Single

Property Value

A float value indicating the width of the pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Class

PenCollection Class

A collection of MindFusion.Drawing.Pen objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public class PenCollection : CollectionBase, ICloneable
Visual Basic

Public Class PenCollection
Inherits CollectionBase
Implements ICloneable

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Drawing.PenCollection

See Also

PenCollection Members
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Members

PenCollection Members
Constructors Properties Methods

A collection of MindFusion.Drawing.Pen objects.

The following tables list the members exposed by the PenCollection type.

Public Constructors

Name | Description
PenCollection | Overloaded. Initializes a new instance of the PenCollection class.

Public Properties

Name | Description
Item | Gets or sets the Pen, located at the specified position.

Public Methods

Name | Description
Add | Adds the specified Pen to the collection.
Clone | Returns a shallow copy of this PenCollection object.
Contains | Checks whether the specified Pen is contained in the collection.
IndexOf | Returns the index of the first occurrence of the specified Pen.
Insert | Inserts the specified Pen at the specified position within the collection.
Remove | Removes the first occurrence of the specified Pen from the collection.
RemoveAt | Removes the Pen at the specified index.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Constructor

PenCollection Constructor

Initializes a new instance of the PenCollection class.

Overload List

Name | Description
PenCollection () | Initializes a new empty instance of the PenCollection class.
PenCollection (String) | Initializes a new instance of the PenCollection class using the specified string representation.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Constructor ()

PenCollection Constructor ()
See Also

Initializes a new empty instance of the PenCollection class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public PenCollection ()
Visual Basic

Public Sub New ()

See Also

PenCollection Constructor Overload List
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Constructor (String)

PenCollection Constructor (String)
See Also

Initializes a new instance of the PenCollection class using the specified string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public PenCollection (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation
The string that represents serialized contents of a PenCollection.

See Also

PenCollection Constructor Overload List
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Methods

PenCollection Methods

Public Methods

Name | Description
Add | Adds the specified Pen to the collection.
Clone | Returns a shallow copy of this PenCollection object.
Contains | Checks whether the specified Pen is contained in the collection.
IndexOf | Returns the index of the first occurrence of the specified Pen.
Insert | Inserts the specified Pen at the specified position within the collection.
Remove | Removes the first occurrence of the specified Pen from the collection.
RemoveAt | Removes the Pen at the specified index.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Add Method

PenCollection.Add Method

Adds the specified Pen to the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public int Add (
Pen value
)
Visual Basic

Public Function Add ( _
value As Pen _
) As Integer

Parameters

value
The Pen object to add to the end of the collection.

Return Value

The zero-based index within the collection of the newly added pen.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Clone Method

PenCollection.Clone Method

Returns a shallow copy of this PenCollection object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

An instance of the PenCollection class.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Contains Method

PenCollection.Contains Method

Checks whether the specified Pen is contained in the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public bool Contains (
Pen value
)
Visual Basic

Public Function Contains ( _
value As Pen _
) As Boolean

Parameters

value
The Pen object to search for in the collection.

Return Value

true if the specified pen is contained in the collection; otherwise, false.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.IndexOf Method

PenCollection.IndexOf Method

Returns the index of the first occurrence of the specified Pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public int IndexOf (
Pen value
)
Visual Basic

Public Function IndexOf ( _
value As Pen _
) As Integer

Parameters

value
The Pen object to locate in the collection.

Return Value

The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Insert Method

PenCollection.Insert Method

Inserts the specified Pen at the specified position within the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void Insert (
int index,
Pen value
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
value As Pen _
)

Parameters

index
The zero-based index at which to insert the pen.
value
The Pen object to add to the collection.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Remove Method

PenCollection.Remove Method

Removes the first occurrence of the specified Pen from the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public void Remove (
Pen value
)
Visual Basic

Public Sub Remove ( _
value As Pen _
)

Parameters

value
The Pen object to remove from the collection.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.RemoveAt Method

PenCollection.RemoveAt Method

Removes the Pen at the specified index.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public new void RemoveAt (
int index
)
Visual Basic

Public Shadows Sub RemoveAt ( _
index As Integer _
)

Parameters

index
The index at which the Pen object should be removed.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Properties

PenCollection Properties

Public Properties

Name | Description
Item | Gets or sets the Pen, located at the specified position.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Item Property

PenCollection.Item Property

Gets or sets the Pen, located at the specified position.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Pen Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Pen

Parameters

index
The zero-based index of the element to get or set.

Property Value

The Pen element at the specified index.

Remarks

This property provides the ability to access a specific Pen element in the PenCollection.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Class

SolidBrush Class
Remarks See Also

SolidBrush objects represent brushes of a single color that are used to fill the interiors of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public class SolidBrush : Brush, ISerializable
Visual Basic

Public Class SolidBrush
Inherits Brush
Implements ISerializable

Remarks

The SolidBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.SolidBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.SolidBrush

See Also

SolidBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Members

SolidBrush Members
Constructors Properties Methods

SolidBrush objects represent brushes of a single color that are used to fill the interiors of geometric shapes.

The following tables list the members exposed by the SolidBrush type.

Public Constructors

Name | Description
SolidBrush | Overloaded. Initializes a new instance of the SolidBrush class.

Public Properties

Name | Description
Color | Gets or sets the color of this brush.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.SolidBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Solid".

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Constructor

SolidBrush Constructor

Initializes a new instance of the SolidBrush class.

Overload List

Name | Description
SolidBrush (Color) | Initializes a new instance of the SolidBrush class with the specified color.
SolidBrush (String) | Initializes a new instance of the SolidBrush class given its string representation.

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Constructor (Color)

SolidBrush Constructor (Color)
See Also

Initializes a new instance of the SolidBrush class with the specified color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public SolidBrush (
Color color
)
Visual Basic

Public New ( _
color As Color _
)

Parameters

color
A Color object that specifies the color of the new brush.

See Also

SolidBrush Constructor Overload List
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Constructor (String)

SolidBrush Constructor (String)
See Also

Initializes a new instance of the SolidBrush class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public SolidBrush (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized bursh.

See Also

SolidBrush Constructor Overload List
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Methods

SolidBrush Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.SolidBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Solid".

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.Clone Method

SolidBrush.Clone Method

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

An instance of the SolidBrush class.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.CreateGdiBrush Method

SolidBrush.CreateGdiBrush Method

Returns an instance of the System.Drawing.SolidBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override Brush CreateGdiBrush (
RectangleF rc
)
Visual Basic

Public Overrides Function CreateGdiBrush ( _
rc As RectangleF _
) As Brush

Parameters

rc
The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.GetObjectData Method

SolidBrush.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)
Visual Basic

Public Overridable Sub GetObjectData ( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info
The object that holds the serialized object data.
context
The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.ToString Method

SolidBrush.ToString Method

Returns "Solid".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Properties

SolidBrush Properties

Public Properties

Name | Description
Color | Gets or sets the color of this brush.

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.Color Property

SolidBrush.Color Property

Gets or sets the color of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Color Color { get; set; }
Visual Basic

Public Property Color As Color

Property Value

Instance of the .NET Color structure that represents the color of this brush.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Class

TextureBrush Class
Remarks See Also

TextureBrush objects represent brushes that use images to fill the interiors of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public class TextureBrush : Brush, ISerializable
Visual Basic

Public Class TextureBrush
Inherits Brush
Implements ISerializable

Remarks

The TextureBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.TextureBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.TextureBrush

See Also

TextureBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Members

TextureBrush Members
Constructors Properties Methods

TextureBrush objects represent brushes that use images to fill the interiors of geometric shapes.

The following tables list the members exposed by the TextureBrush type.

Public Constructors

Name | Description
TextureBrush | Overloaded. Initializes a new instance of the TextureBrush class.

Public Properties

Name | Description
Image | Gets or sets the Image instance associated with this brush.
ScaleFactor | Gets or sets the scale factor applied to all texture brushes.
WrapMode | Gets or sets a value that indicates the wrap mode for this brush.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.
Equals | Determines whether two TextureBrush instances are equal.
GetHashCode | Returns the hash code for this brush instance.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Texture".

See Also

TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Constructor

TextureBrush Constructor

Initializes a new instance of the TextureBrush class.

Overload List

Name | Description
TextureBrush (Image) | Initializes a new instance of the TextureBrush class with the specified image.
TextureBrush (Image, WrapMode) | Initializes a new instance of the TextureBrush class with the specified image and wrap mode.
TextureBrush (String) | Initializes a new instance of TextureBrush class given its string representation.

See Also

TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Constructor (Image)

TextureBrush Constructor (Image)
See Also

Initializes a new instance of the TextureBrush class with the specified image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public TextureBrush (
Image image
)
Visual Basic

Public New ( _
image As Image _
)

Parameters

image
The Image object with which this brush fills interiors.

See Also

TextureBrush Constructor Overload List
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Constructor (Image, WrapMode)

TextureBrush Constructor (Image, WrapMode)
See Also

Initializes a new instance of the TextureBrush class with the specified image and wrap mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public TextureBrush (
Image image,
WrapMode wrapMode
)
Visual Basic

Public New ( _
image As Image, _
wrapMode As WrapMode _
)

Parameters

image
Sets the texture image.
wrapMode
Sets the texture wrap mode.

See Also

TextureBrush Constructor Overload List
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Constructor (String)

TextureBrush Constructor (String)
See Also

Initializes a new instance of TextureBrush class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public TextureBrush (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized bursh.

See Also

TextureBrush Constructor Overload List
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Methods

TextureBrush Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.
Equals | Determines whether two TextureBrush instances are equal.
GetHashCode | Returns the hash code for this brush instance.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Texture".

See Also

TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.Clone Method

TextureBrush.Clone Method

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

An instance of the TextureBrush class.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.CreateGdiBrush Method

TextureBrush.CreateGdiBrush Method

Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.

Overload List

Name | Description
TextureBrush.CreateGdiBrush (RectangleF) | Creates an instance of the System.Drawing.TextureBrush class that can be used to paint in a GDI+ Graphics object.
TextureBrush.CreateGdiBrush (RectangleF, Single, Single) | Creates an instance of the System.Drawing.TextureBrush class that can be used to paint in a GDI+ Graphics object.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.CreateGdiBrush Method (RectangleF)

TextureBrush.CreateGdiBrush Method (RectangleF)
See Also

Creates an instance of the System.Drawing.TextureBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override Brush CreateGdiBrush (
RectangleF rc
)
Visual Basic

Public Overrides Function CreateGdiBrush ( _
rc As RectangleF _
) As Brush

Parameters

rc
The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.CreateGdiBrush Method (RectangleF, Single, Single)

TextureBrush.CreateGdiBrush Method (RectangleF, Single, Single)
See Also

Creates an instance of the System.Drawing.TextureBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override Brush CreateGdiBrush (
RectangleF rc,
float dx,
float dy
)
Visual Basic

Public Overrides Function CreateGdiBrush ( _
rc As RectangleF, _
dx As Single, _
dy As Single _
) As Brush

Parameters

rc
The rectangle in which painting will be performed.
dx
Specifies a horizontal offset to apply to this brush.
dy
Specifies a vertical offset to apply to this brush.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.Equals Method

TextureBrush.Equals Method

Determines whether two TextureBrush instances are equal.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override bool Equals (
Object obj
)
Visual Basic

Public Overrides Function Equals ( _
obj As Object _
) As Boolean

Parameters

obj
The object to compare to this one.

Return Value

true is the brushes are equal; otherwise, false.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.GetHashCode Method

TextureBrush.GetHashCode Method

Returns the hash code for this brush instance.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override int GetHashCode ()
Visual Basic

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for this object.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.GetObjectData Method

TextureBrush.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)
Visual Basic

Public Overridable Sub GetObjectData ( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info
The object that holds the serialized object data.
context
The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.ToString Method

TextureBrush.ToString Method

Returns "Texture".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Properties

TextureBrush Properties

Public Properties

Name | Description
Image | Gets or sets the Image instance associated with this brush.
ScaleFactor | Gets or sets the scale factor applied to all texture brushes.
WrapMode | Gets or sets a value that indicates the wrap mode for this brush.

See Also

TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.Image Property

TextureBrush.Image Property

Gets or sets the Image instance associated with this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public Image Image { get; set; }
Visual Basic

Public Property Image As Image

Property Value

Instance of the .NET Image class that represents the image with which this brush fills shapes.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.ScaleFactor Property

TextureBrush.ScaleFactor Property

Gets or sets the scale factor applied to all texture brushes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public static float ScaleFactor { get; set; }
Visual Basic

Public Shared Property ScaleFactor As Single

Property Value

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.WrapMode Property

TextureBrush.WrapMode Property

Gets or sets a value that indicates the wrap mode for this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C#

public WrapMode WrapMode { get; set; }
Visual Basic

Public Property WrapMode As WrapMode

Property Value

A member of the .NET WrapMode enumeration that specifies how fills drawn with this brush are tiled.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Layout Namespace
Classes Interfaces Structures Delegates Enumerations

The types in this namespace support the MindFusion.Diagramming layout functionality and are not supposed to be used directly.

Classes

Class | Description
AnnealLayoutStatistics | Contains the accumulated costs for a graph configuration produced by AnnealLayout.
ConnectorRules | Represents a set of rules that are applied according to the logic identifiers of links.
FlowLayoutKeys | Defines keys that can be used to define FlowLayout rules.
FlowLayoutRules | A class representing a set of rules that define the behavior of the FlowLayout class.
LayoutRules | Summary description for LayoutRules.
NodeRules | Represents a set of rules that are applied according to the logic identifiers of node pairs.
Pair | Represents a coupling between two arbitrary objects.
SimpleKeys | Defines keys that can be used to define FlowLayout rules.
SimpleLinkLogic | Contains link identifiers for the predefined SimpleRules set of rules.
SimpleNodeLogic | Contains node identifiers for the predefined SimpleRules set of rules.
SimpleRules | Class of simple rules requisited for Flowlayout algorithm.

Interfaces

Interface | Description
RoutingOptions | Allows customization of various aspects of the link routing algorithm.

Structures

Structure | Description
Point3D | Represents the coordinates of a point in a 3-dimentional space.

Delegates

Delegate | Description
RouteHeuristics | The link routing algorithm uses a heuristic function of this type in its prediction steps.

Enumerations

Enumeration | Description
BaseLayout | Specifies how OrthogonalRouter should arrange nodes.
FlowLayoutTraits | Values used as keys in FlowLayout rules.
OrderDirection | Values controlling the direction of link segments in FlowLayout rules.
PreferredRules | Specifies which set of rules to use.
SimpleOrientation | Specifies the preferred orientation for the main connector type in FlowLayout.
SpringLayoutTraits | Indicates item traits specific to SpringLayout. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
TreeLayoutTraits | Indicates item traits specific to tree layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.


MindFusion.Layout.AnnealLayoutStatistics Class

AnnealLayoutStatistics Class

Contains the accumulated costs for a graph configuration produced by AnnealLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class AnnealLayoutStatistics
Visual Basic

Public Class AnnealLayoutStatistics

Inheritance Hierarchy

System.Object
MindFusion.Layout.AnnealLayoutStatistics

See Also

AnnealLayoutStatistics Members
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Members

AnnealLayoutStatistics Members
Constructors Properties Methods

Contains the accumulated costs for a graph configuration produced by AnnealLayout.

The following tables list the members exposed by the AnnealLayoutStatistics type.

Public Constructors

Name | Description
AnnealLayoutStatistics |

Public Properties

Name | Description
BoundaryCost | The total distance-to-boundary cost of a graph configuration.
DistributionCost | The total distribution cost of a graph configuration.
EdgeCrossingsCost | The total edge crossings cost of a graph configuration.
EdgeCrossingsFound | The number of edge crossings in the graph configuration.
EdgeLengthsCost | The total edge lengths cost of a graph configuration.
NodeEdgeDistance | The total node-to-edge-distance cost of a graph configuration.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Constructor

AnnealLayoutStatistics Constructor

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public AnnealLayoutStatistics ()
Visual Basic

Public Sub New ()

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Methods

AnnealLayoutStatistics Methods

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.ToString Method

AnnealLayoutStatistics.ToString Method

Object.ToString override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Properties

AnnealLayoutStatistics Properties

Public Properties

Name | Description
BoundaryCost | The total distance-to-boundary cost of a graph configuration.
DistributionCost | The total distribution cost of a graph configuration.
EdgeCrossingsCost | The total edge crossings cost of a graph configuration.
EdgeCrossingsFound | The number of edge crossings in the graph configuration.
EdgeLengthsCost | The total edge lengths cost of a graph configuration.
NodeEdgeDistance | The total node-to-edge-distance cost of a graph configuration.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.BoundaryCost Property

AnnealLayoutStatistics.BoundaryCost Property

The total distance-to-boundary cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double BoundaryCost { get; set; }
Visual Basic

Public Property BoundaryCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.DistributionCost Property

AnnealLayoutStatistics.DistributionCost Property

The total distribution cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double DistributionCost { get; set; }
Visual Basic

Public Property DistributionCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeCrossingsCost Property

AnnealLayoutStatistics.EdgeCrossingsCost Property

The total edge crossings cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double EdgeCrossingsCost { get; set; }
Visual Basic

Public Property EdgeCrossingsCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeCrossingsFound Property

AnnealLayoutStatistics.EdgeCrossingsFound Property

The number of edge crossings in the graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public int EdgeCrossingsFound { get; set; }
Visual Basic

Public Property EdgeCrossingsFound As Integer

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeLengthsCost Property

AnnealLayoutStatistics.EdgeLengthsCost Property

The total edge lengths cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double EdgeLengthsCost { get; set; }
Visual Basic

Public Property EdgeLengthsCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.NodeEdgeDistance Property

AnnealLayoutStatistics.NodeEdgeDistance Property

The total node-to-edge-distance cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public double NodeEdgeDistance { get; set; }
Visual Basic

Public Property NodeEdgeDistance As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.BaseLayout Enumeration

BaseLayout Enumeration

Specifies how OrthogonalRouter should arrange nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum BaseLayout
Visual Basic

Public Enumeration BaseLayout

Members

Member name | Description
Cascading | Use TreeLayout to arrange nodes.
Grid | Use GridLayout to arrange nodes.
Layered | Use LayeredLayout to arrange nodes.
Custom | Use the current node configuration.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules Class

ConnectorRules Class

Represents a set of rules that are applied according to the logic identifiers of links.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class ConnectorRules : LayoutRules
Visual Basic

Public Class ConnectorRules
Inherits LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.ConnectorRules

See Also

ConnectorRules Members
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules Members

ConnectorRules Members
Properties

Represents a set of rules that are applied according to the logic identifiers of links.

The following tables list the members exposed by the ConnectorRules type.

Public Properties

Name | Description
DownOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed downwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
HorizontalBendOrientation | Specifies whether links should start with a horizontal segment.
LeftOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed leftwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
RightOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed rightwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
UpOriented | Specifies a set of link identifiers for which nodes connected via such links will be placed upwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

See Also

ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules Properties

ConnectorRules Properties

Public Properties

Name | Description
DownOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed downwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
HorizontalBendOrientation | Specifies whether links should start with a horizontal segment.
LeftOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed leftwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
RightOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed rightwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
UpOriented | Specifies a set of link identifiers for which nodes connected via such links will be placed upwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

See Also

ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.DownOriented Property

ConnectorRules.DownOriented Property

Specifies a set of link identifiers for which nodes connected through such links will be placed downwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Object DownOriented { get; set; }
Visual Basic

Public Property DownOriented As Object

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.HorizontalBendOrientation Property

ConnectorRules.HorizontalBendOrientation Property

Specifies whether links should start with a horizontal segment.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool HorizontalBendOrientation { get; set; }
Visual Basic

Public Property HorizontalBendOrientation As Boolean

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.LeftOriented Property

ConnectorRules.LeftOriented Property

Specifies a set of link identifiers for which nodes connected through such links will be placed leftwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Object LeftOriented { get; set; }
Visual Basic

Public Property LeftOriented As Object

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.RightOriented Property

ConnectorRules.RightOriented Property

Specifies a set of link identifiers for which nodes connected through such links will be placed rightwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Object RightOriented { get; set; }
Visual Basic

Public Property RightOriented As Object

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.UpOriented Property

ConnectorRules.UpOriented Property

Specifies a set of link identifiers for which nodes connected via such links will be placed upwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Object UpOriented { get; set; }
Visual Basic

Public Property UpOriented As Object

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys Class

FlowLayoutKeys Class

Defines keys that can be used to define FlowLayout rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class FlowLayoutKeys : SimpleKeys
Visual Basic

Public Class FlowLayoutKeys
Inherits SimpleKeys

Inheritance Hierarchy

System.Object
MindFusion.Layout.SimpleKeys
MindFusion.Layout.FlowLayoutKeys

See Also

FlowLayoutKeys Members
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys Members

FlowLayoutKeys Members
Constructors Fields

Defines keys that can be used to define FlowLayout rules.

The following tables list the members exposed by the FlowLayoutKeys type.

Public Constructors

Name | Description
FlowLayoutKeys | Initializes a new instance of the FlowLayoutKeys class.

Public Fields

Name | Description
PossibleNodeLogic | Specifies a list of identifiers for nodes that should be processed by FlowLayout.
SemiLevel | Specifies a list of identifiers for nodes that should be placed with some offset from the main sequence line.

See Also

FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys Fields

FlowLayoutKeys Fields

Public Fields

Name | Description
PossibleNodeLogic | Specifies a list of identifiers for nodes that should be processed by FlowLayout.
SemiLevel | Specifies a list of identifiers for nodes that should be placed with some offset from the main sequence line.

See Also

FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys.PossibleNodeLogic Field

FlowLayoutKeys.PossibleNodeLogic Field

Specifies a list of identifiers for nodes that should be processed by FlowLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string PossibleNodeLogic
Visual Basic

Public Shared PossibleNodeLogic As String

See Also

FlowLayoutKeys Members
FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys.SemiLevel Field

FlowLayoutKeys.SemiLevel Field

Specifies a list of identifiers for nodes that should be placed with some offset from the main sequence line.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string SemiLevel
Visual Basic

Public Shared SemiLevel As String

See Also

FlowLayoutKeys Members
FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys Constructor

FlowLayoutKeys Constructor

Initializes a new instance of the FlowLayoutKeys class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public FlowLayoutKeys ()
Visual Basic

Public Sub New ()

See Also

FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Class

FlowLayoutRules Class

A class representing a set of rules that define the behavior of the FlowLayout class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class FlowLayoutRules : LayoutRules
Visual Basic

Public Class FlowLayoutRules
Inherits LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.FlowLayoutRules

See Also

FlowLayoutRules Members
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Members

FlowLayoutRules Members
Constructors Properties Methods

A class representing a set of rules that define the behavior of the FlowLayout class.

The following tables list the members exposed by the FlowLayoutRules type.

Public Constructors

Name | Description
FlowLayoutRules | Initializes a new instance of the FlowLayoutRules class.

Public Properties

Name | Description
ConnectorRules | A set of rules that are applied according to the logic identifiers of links.
NodeRules | A set of rules that are applied according to the logic identifiers of node pairs.
PreferredRules | Specifies which set of rules to use.

Public Methods

Name | Description
AddBendRule | Overloaded.
AddIncomingBendRule | Overloaded.
AddOutgoingBendRule | Overloaded.
UseRuleManagedLinkBend | Specifies whether FlowLayout should use custom link-bending rules specified through the various Add*BendRule methods.

See Also

FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Constructor

FlowLayoutRules Constructor

Initializes a new instance of the FlowLayoutRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public FlowLayoutRules ()
Visual Basic

Public Sub New ()

See Also

FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Methods

FlowLayoutRules Methods

Public Methods

Name | Description
AddBendRule | Overloaded.
AddIncomingBendRule | Overloaded.
AddOutgoingBendRule | Overloaded.
UseRuleManagedLinkBend | Specifies whether FlowLayout should use custom link-bending rules specified through the various Add*BendRule methods.

See Also

FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method

FlowLayoutRules.AddBendRule Method

Overload List

Name | Description
FlowLayoutRules.AddBendRule (String, String, OrderDirection) | Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String, String, OrderDirection[]) | Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String, String[], OrderDirection) | Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String, String[], OrderDirection[]) | Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String[], String, OrderDirection) | Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String[], String, OrderDirection[]) | Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String, String, OrderDirection)

FlowLayoutRules.AddBendRule Method (String, String, OrderDirection)
See Also

Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddBendRule (
string nodeType,
string linkType,
OrderDirection direction
)
Visual Basic

Public Function AddBendRule ( _
nodeType As String, _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

nodeType
The logic identifier of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
direction
An OrderDirection value defining the orientation of the links starting or ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String, String, OrderDirection[])

FlowLayoutRules.AddBendRule Method (String, String, OrderDirection[])
See Also

Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddBendRule (
string nodeType,
string linkType,
OrderDirection[] directions
)
Visual Basic

Public Function AddBendRule ( _
nodeType As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

nodeType
The logic identifier of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting or ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String, String[], OrderDirection)

FlowLayoutRules.AddBendRule Method (String, String[], OrderDirection)
See Also

Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddBendRule (
string nodeType,
string[] linkTypes,
OrderDirection direction
)
Visual Basic

Public Function AddBendRule ( _
nodeType As String, _
linkTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

nodeType
The logic identifier of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
direction
An OrderDirection value defining the orientation of the links starting or ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String, String[], OrderDirection[])

FlowLayoutRules.AddBendRule Method (String, String[], OrderDirection[])
See Also

Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddBendRule (
string nodeType,
string[] linkTypes,
OrderDirection[] directions
)
Visual Basic

Public Function AddBendRule ( _
nodeType As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

nodeType
The logic identifier of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting or ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String[], String, OrderDirection)

FlowLayoutRules.AddBendRule Method (String[], String, OrderDirection)
See Also

Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddBendRule (
string[] nodeTypes,
string linkType,
OrderDirection direction
)
Visual Basic

Public Function AddBendRule ( _
nodeTypes As String(), _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

nodeTypes
The logic identifiers of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
direction
An OrderDirection value defining the orientation of the links starting or ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String[], String, OrderDirection[])

FlowLayoutRules.AddBendRule Method (String[], String, OrderDirection[])
See Also

Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddBendRule (
string[] nodeTypes,
string linkType,
OrderDirection[] directions
)
Visual Basic

Public Function AddBendRule ( _
nodeTypes() As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

nodeTypes
The logic identifiers of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting or ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method

FlowLayoutRules.AddIncomingBendRule Method

Overload List

Name | Description
FlowLayoutRules.AddIncomingBendRule (String, String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String, String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String, String, String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String, String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String, String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String, String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String, String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String, String[], String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String[], String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String[], String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String[], String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String[], String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String[], String, String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String, String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String, String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String, String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String, OrderDirection)
See Also

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
OrderDirection direction
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType
The logic identifier of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String, OrderDirection[])
See Also

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
OrderDirection[] directions
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkType As String, _
directions As OrderDirection() _
) As Boolean

Parameters

destNodeType
The logic identifier of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String, String, OrderDirection)
See Also

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
string originNodeType,
OrderDirection direction
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkType As String, _
originNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType
The logic identifier of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
originNodeType
The logic identifier of nodes this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String, String, OrderDirection[])
See Also

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
string originNodeType,
OrderDirection[] directions
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkType As String, _
originNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType
The logic identifier of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
originNodeType
The logic identifier of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String, String[], OrderDirection)
See Also

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
string[] originNodeTypes,
OrderDirection direction
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkType As String, _
originNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType
The logic identifier of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
originNodeTypes
The logic identifiers of nodes this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String, String[], OrderDirection[])
See Also

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
string[] originNodeTypes,
OrderDirection[] directions
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkType As String, _
originNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType
The logic identifier of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
originNodeTypes
The logic identifiers of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String[], OrderDirection)
See Also

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
OrderDirection direction
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType
The logic identifier of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String[], OrderDirection[])
See Also

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
OrderDirection[] directions
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType
The logic identifier of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String[], String, OrderDirection)
See Also

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
string originNodeType,
OrderDirection direction
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkTypes As String(), _
originNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType
The logic identifier of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
originNodeType
The logic identifier of nodes this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String[], String, OrderDirection[])
See Also

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
string originNodeType,
OrderDirection[] directions
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkTypes() As String, _
originNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType
The logic identifier of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
originNodeType
The logic identifier of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String[], String[], OrderDirection)
See Also

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
string[] originNodeTypes,
OrderDirection direction
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkTypes As String(), _
originNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType
The logic identifier of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
originNodeTypes
The logic identifiers of nodes this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String[], String[], OrderDirection[])
See Also

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
string[] originNodeTypes,
OrderDirection[] directions
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeType As String, _
linkTypes() As String, _
originNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType
The logic identifier of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
originNodeTypes
The logic identifiers of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String, OrderDirection)
See Also

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
OrderDirection direction
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeTypes As String(), _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String, OrderDirection[])
See Also

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
OrderDirection[] directions
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeTypes() As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String, String, OrderDirection)
See Also

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
string originNodeType,
OrderDirection direction
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeTypes As String(), _
linkType As String, _
originNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
originNodeType
The logic identifier of nodes this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String, String, OrderDirection[])
See Also

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
string originNodeType,
OrderDirection[] directions
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeTypes() As String, _
linkType As String, _
originNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
originNodeType
The logic identifier of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String, String[], OrderDirection)
See Also

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
string[] originNodeTypes,
OrderDirection direction
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeTypes As String(), _
linkType As String, _
originNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
originNodeTypes
The logic identifiers of nodes this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String, String[], OrderDirection[])
See Also

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
string[] originNodeTypes,
OrderDirection[] directions
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeTypes() As String, _
linkType As String, _
originNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
originNodeTypes
The logic identifiers of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], OrderDirection)
See Also

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
OrderDirection direction
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeTypes As String(), _
linkTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], OrderDirection[])
See Also

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
OrderDirection[] directions
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeTypes() As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String, OrderDirection)
See Also

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
string originNodeType,
OrderDirection direction
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeTypes As String(), _
linkTypes As String(), _
originNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
originNodeType
The logic identifier of nodes this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String, OrderDirection[])
See Also

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
string originNodeType,
OrderDirection[] directions
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeTypes() As String, _
linkTypes() As String, _
originNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
originNodeType
The logic identifier of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String[], OrderDirection)
See Also

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
string[] originNodeTypes,
OrderDirection direction
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeTypes As String(), _
linkTypes As String(), _
originNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
originNodeTypes
The logic identifiers of nodes this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String[], OrderDirection[])
See Also

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
string[] originNodeTypes,
OrderDirection[] directions
)
Visual Basic

Public Function AddIncomingBendRule ( _
destNodeTypes() As String, _
linkTypes() As String, _
originNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
originNodeTypes
The logic identifiers of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method

FlowLayoutRules.AddOutgoingBendRule Method

Overload List

Name | Description
FlowLayoutRules.AddOutgoingBendRule (String, String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String, OrderDirection)
See Also

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
OrderDirection direction
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule to be applied to.
linkType
The logic identifier of links this rule will be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String, OrderDirection[])
See Also

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
OrderDirection[] directions
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String, String, OrderDirection)
See Also

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
string destNodeType,
OrderDirection direction
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkType As String, _
destNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule will be applied to.
linkType
The logic identifier of links this rule will be applied to.
destNodeType
The logic identifier of nodes this rule will be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String, String, OrderDirection[])
See Also

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
string destNodeType,
OrderDirection[] directions
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkType As String, _
destNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
destNodeType
The logic identifier of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String, String[], OrderDirection)
See Also

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
string[] destNodeTypes,
OrderDirection direction
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkType As String, _
destNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule will be applied to.
linkType
The logic identifier of links this rule will be applied to.
destNodeTypes
The logic identifiers of nodes this rule will be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String, String[], OrderDirection[])
See Also

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
string[] destNodeTypes,
OrderDirection[] directions
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkType As String, _
destNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule should be applied to.
linkType
The logic identifier of links this rule should be applied to.
destNodeTypes
The logic identifiers of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], OrderDirection)
See Also

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
OrderDirection direction
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], OrderDirection[])
See Also

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
OrderDirection[] directions
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String, OrderDirection)
See Also

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
string destNodeType,
OrderDirection direction
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkTypes As String(), _
destNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
destNodeType
The logic identifier of nodes this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String, OrderDirection[])
See Also

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
string destNodeType,
OrderDirection[] directions
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkTypes() As String, _
destNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
destNodeType
The logic identifier of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String[], OrderDirection)
See Also

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
string[] destNodeTypes,
OrderDirection direction
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkTypes As String(), _
destNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule to apply to.
linkTypes
The logic identifiers of links this rule to be applied to.
destNodeTypes
The logic identifiers of nodes this rule to be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String[], OrderDirection[])
See Also

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
string[] destNodeTypes,
OrderDirection[] directions
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeType As String, _
linkTypes() As String, _
destNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType
The logic identifier of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
destNodeTypes
The logic identifiers of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, OrderDirection)
See Also

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
OrderDirection direction
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeTypes As String(), _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to be applied to.
linkType
The logic identifier of links this rule to be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, OrderDirection[])
See Also

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
OrderDirection[] directions
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeTypes() As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to be applied to.
linkType
The logic identifier of links this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String, OrderDirection)
See Also

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
string destNodeType,
OrderDirection direction
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeTypes As String(), _
linkType As String, _
destNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to apply.
linkType
The logic identifier of links this rule to apply.
destNodeType
The logic identifier of nodes this rule will be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String, OrderDirection[])
See Also

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
string destNodeType,
OrderDirection[] directions
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeTypes() As String, _
linkType As String, _
destNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to be applied to.
linkType
The logic identifier of links this rule to be applied to.
destNodeType
The logic identifier of nodes this rule to be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String[], OrderDirection)
See Also

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
string[] destNodeTypes,
OrderDirection direction
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeTypes As String(), _
linkType As String, _
destNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to be applied to.
linkType
The logic identifier of links this rule to be applied to.
destNodeTypes
The logic identifiers of nodes this rule to be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String[], OrderDirection[])
See Also

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
string[] destNodeTypes,
OrderDirection[] directions
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeTypes() As String, _
linkType As String, _
destNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to be applied to.
linkType
The logic identifier of links this rule to be applied to.
destNodeTypes
The logic identifiers of nodes this rule to be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], OrderDirection)
See Also

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
OrderDirection direction
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeTypes As String(), _
linkTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule to be applied to.
linkTypes
The logic identifiers of links this rule to be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], OrderDirection[])
See Also

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
OrderDirection[] directions
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeTypes() As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkTypes
The logic identifier of links this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String, OrderDirection)
See Also

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
string destNodeType,
OrderDirection direction
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeTypes As String(), _
linkTypes As String(), _
destNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
destNodeType
The logic identifier of nodes this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String, OrderDirection[])
See Also

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
string destNodeType,
OrderDirection[] directions
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeTypes() As String, _
linkTypes() As String, _
destNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
destNodeType
The logic identifier of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String[], OrderDirection)
See Also

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
string[] destNodeTypes,
OrderDirection direction
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeTypes As String(), _
linkTypes As String(), _
destNodeTypes As String(), _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
destNodeTypes
The logic identifiers of nodes this rule should be applied to.
direction
An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String[], OrderDirection[])
See Also

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
string[] destNodeTypes,
OrderDirection[] directions
)
Visual Basic

Public Function AddOutgoingBendRule ( _
originNodeTypes() As String, _
linkTypes() As String, _
destNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes
The logic identifiers of nodes this rule should be applied to.
linkTypes
The logic identifiers of links this rule should be applied to.
destNodeTypes
The logic identifiers of nodes this rule should be applied to.
directions
An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.UseRuleManagedLinkBend Method

FlowLayoutRules.UseRuleManagedLinkBend Method

Specifies whether FlowLayout should use custom link-bending rules specified through the various Add*BendRule methods.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool UseRuleManagedLinkBend (
bool ruleManaged
)
Visual Basic

Public Function UseRuleManagedLinkBend ( _
ruleManaged As Boolean _
) As Boolean

Parameters

ruleManaged
true to use custom link-bending rules; otherwise, false.

Return Value

true if this rule has been set successfully; otherwise, false.

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Properties

FlowLayoutRules Properties

Public Properties

Name | Description
ConnectorRules | A set of rules that are applied according to the logic identifiers of links.
NodeRules | A set of rules that are applied according to the logic identifiers of node pairs.
PreferredRules | Specifies which set of rules to use.

See Also

FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.ConnectorRules Property

FlowLayoutRules.ConnectorRules Property

A set of rules that are applied according to the logic identifiers of links.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public ConnectorRules ConnectorRules { get; set; }
Visual Basic

Public Property ConnectorRules As ConnectorRules

Property Value

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.NodeRules Property

FlowLayoutRules.NodeRules Property

A set of rules that are applied according to the logic identifiers of node pairs.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public NodeRules NodeRules { get; set; }
Visual Basic

Public Property NodeRules As NodeRules

Property Value

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.PreferredRules Property

FlowLayoutRules.PreferredRules Property

Specifies which set of rules to use.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public PreferredRules PreferredRules { get; set; }
Visual Basic

Public Property PreferredRules As PreferredRules

Property Value

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutTraits Enumeration

FlowLayoutTraits Enumeration

Values used as keys in FlowLayout rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum FlowLayoutTraits
Visual Basic

Public Enumeration FlowLayoutTraits

Members

Member name | Description
Lane | Specifies the lane to which a node should be assigned.
LaneNode | Specifies that FlowLayout should treat a node as a lane.
LogicID | Specifies a string used to identify items in FlowLayout rules.
NodeDirection | For internal use.
NodeDistance | Specifies the distance left between this node and the next in the sequence.
NotSpecified | For internal use.
OrderingRule | Specified the preferred order for nodes.
PossibleConnection | For internal use.
StandardLinkBend | For internal use.
VerticalSubgroupsAlignment | A boolean value specifying the alignment of nodes within a group.
InLink | Identifies possible incoming links in FlowLayout rules.
OutLink | Identifies possible outgoing links in FlowLayout rules.
VerticalDisconnectedGroupsAlignment | A boolean value specifying the alignment of nodes within a group.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Class

LayoutRules Class

Summary description for LayoutRules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class LayoutRules
Visual Basic

Public Class LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.ConnectorRules
MindFusion.Layout.FlowLayoutRules
MindFusion.Layout.NodeRules
MindFusion.Layout.SimpleRules

See Also

LayoutRules Members
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Members

LayoutRules Members
Constructors Methods

Summary description for LayoutRules.

The following tables list the members exposed by the LayoutRules type.

Public Constructors

Name | Description
LayoutRules | Initializes a new instance of the LayoutRules class.

Public Methods

Name | Description
AddLayoutRule | Overloaded.
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2.
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails;
ValidateRules | Checks if there is a rule for each key in KeyList

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Constructor

LayoutRules Constructor

Initializes a new instance of the LayoutRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public LayoutRules ()
Visual Basic

Public Sub New ()

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Methods

LayoutRules Methods

Public Methods

Name | Description
AddLayoutRule | Overloaded.
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2.
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails;
ValidateRules | Checks if there is a rule for each key in KeyList

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method

LayoutRules.AddLayoutRule Method

Overload List

Name | Description
LayoutRules.AddLayoutRule (Object, Object) | Adds or sets a new rule, depending on if the rule with key - Key already exists or no;
LayoutRules.AddLayoutRule (Object, Object, Object) | Builds a key as a pair of the objects Object1 and Object2 and adds or sets a new rule, with this key anf value - Value;

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method (Object, Object)

LayoutRules.AddLayoutRule Method (Object, Object)
See Also

Adds or sets a new rule, depending on if the rule with key - Key already exists or no;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddLayoutRule (
Object Key,
Object Value
)
Visual Basic

Public Function AddLayoutRule ( _
Key As Object, _
Value As Object _
) As Boolean

Parameters

Key
Value

Return Value

See Also

AddLayoutRule Method Overload List
LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method (Object, Object, Object)

LayoutRules.AddLayoutRule Method (Object, Object, Object)
See Also

Builds a key as a pair of the objects Object1 and Object2 and adds or sets a new rule, with this key anf value - Value;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool AddLayoutRule (
Object Object1,
Object Object2,
Object Value
)
Visual Basic

Public Function AddLayoutRule ( _
Object1 As Object, _
Object2 As Object, _
Value As Object _
) As Boolean

Parameters

Object1
Object2
Value

Return Value

See Also

AddLayoutRule Method Overload List
LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.BuildKey Method

LayoutRules.BuildKey Method

Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Object BuildKey (
Object obj1,
Object obj2
)
Visual Basic

Public Function BuildKey ( _
obj1 As Object, _
obj2 As Object _
) As Object

Parameters

obj1
obj2

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.GetLayoutRule Method

LayoutRules.GetLayoutRule Method

If there is rule with key - Key initializes - Value otherwise fails;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual bool GetLayoutRule (
Object Key,
ref Object Value
)
Visual Basic

Public Overridable Function GetLayoutRule ( _
Key As Object, _
ByRef Value As Object _
) As Boolean

Parameters

Key
Value

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.ValidateRules Method

LayoutRules.ValidateRules Method

Checks if there is a rule for each key in KeyList

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ValidateRules (
ArrayList KeyList
)
Visual Basic

Public Function ValidateRules ( _
KeyList As ArrayList _
) As Boolean

Parameters

KeyList

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules Class

NodeRules Class

Represents a set of rules that are applied according to the logic identifiers of node pairs.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class NodeRules : LayoutRules
Visual Basic

Public Class NodeRules
Inherits LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.NodeRules

See Also

NodeRules Members
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules Members

NodeRules Members
Properties

Represents a set of rules that are applied according to the logic identifiers of node pairs.

The following tables list the members exposed by the NodeRules type.

Public Properties

Name | Description
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Assign an array of the node types logic identifiers to this property.
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Assign an array of the node types logic identifiers to this property.
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Assign an array of the node types logic identifiers to this property.
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Assign an array of the node types logic identifiers to this property.
MainConnectorId | Specifies which type of connectors define the control flow in the process represented by the arranged diagram.
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.
VerticalDisconnectedGroupsAlignment | Specifies whether disconnected subgroups from the same lane should be aligned and arranged vertically.
VerticalSubgroupsAlignment | Specifies whether connected subgroups from the same lane should be aligned and arranged vertically.

See Also

NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules Properties

NodeRules Properties

Public Properties

Name | Description
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Assign an array of the node types logic identifiers to this property.
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Assign an array of the node types logic identifiers to this property.
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Assign an array of the node types logic identifiers to this property.
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Assign an array of the node types logic identifiers to this property.
MainConnectorId | Specifies which type of connectors define the control flow in the process represented by the arranged diagram.
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.
VerticalDisconnectedGroupsAlignment | Specifies whether disconnected subgroups from the same lane should be aligned and arranged vertically.
VerticalSubgroupsAlignment | Specifies whether connected subgroups from the same lane should be aligned and arranged vertically.

See Also

NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.FirstGroupLevelNegative Property

NodeRules.FirstGroupLevelNegative Property

A rule defining which nodes should be placed above the "Control Flow" line. Assign an array of the node types logic identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Object FirstGroupLevelNegative { get; set; }
Visual Basic

Public Property FirstGroupLevelNegative As Object

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.FirstGroupLevelPositive Property

NodeRules.FirstGroupLevelPositive Property

A rule defining which nodes should be placed below the "Control Flow" line. Assign an array of the node types logic identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Object FirstGroupLevelPositive { get; set; }
Visual Basic

Public Property FirstGroupLevelPositive As Object

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.GroupEndNodes Property

NodeRules.GroupEndNodes Property

Specifies which nodes should be considered the end of the current sub-group. Assign an array of the node types logic identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Object GroupEndNodes { get; set; }
Visual Basic

Public Property GroupEndNodes As Object

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.GroupStartNodes Property

NodeRules.GroupStartNodes Property

Specifies which nodes should be considered the start of a new sub-group. Assign an array of the node types logic identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Object GroupStartNodes { get; set; }
Visual Basic

Public Property GroupStartNodes As Object

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.MainConnectorId Property

NodeRules.MainConnectorId Property

Specifies which type of connectors define the control flow in the process represented by the arranged diagram.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public string MainConnectorId { get; set; }
Visual Basic

Public Property MainConnectorId As String

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.MainConnectorOrientation Property

NodeRules.MainConnectorOrientation Property

Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SimpleOrientation MainConnectorOrientation { get; set; }
Visual Basic

Public Property MainConnectorOrientation As SimpleOrientation

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.VerticalDisconnectedGroupsAlignment Property

NodeRules.VerticalDisconnectedGroupsAlignment Property

Specifies whether disconnected subgroups from the same lane should be aligned and arranged vertically.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool VerticalDisconnectedGroupsAlignment { get; set; }
Visual Basic

Public Property VerticalDisconnectedGroupsAlignment As Boolean

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.VerticalSubgroupsAlignment Property

NodeRules.VerticalSubgroupsAlignment Property

Specifies whether connected subgroups from the same lane should be aligned and arranged vertically.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool VerticalSubgroupsAlignment { get; set; }
Visual Basic

Public Property VerticalSubgroupsAlignment As Boolean

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.OrderDirection Enumeration

OrderDirection Enumeration

Values controlling the direction of link segments in FlowLayout rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum OrderDirection
Visual Basic

Public Enumeration OrderDirection

Members

Member name | Description
Downward | Specifies downward link direction.
Leftward | Specifies leftward link direction.
NotSpecified | Unspecified link direction.
Rightward | Specifies rightward link direction.
Upward | Specifies upward link direction.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.Pair Class

Pair Class

Represents a coupling between two arbitrary objects.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class Pair : IComparable
Visual Basic

Public Class Pair
Implements IComparable

Inheritance Hierarchy

System.Object
MindFusion.Layout.Pair

See Also

Pair Members
MindFusion.Layout Namespace


MindFusion.Layout.Pair Members

Pair Members
Constructors Properties Methods

Represents a coupling between two arbitrary objects.

The following tables list the members exposed by the Pair type.

Public Constructors

Name | Description
Pair | Overloaded.

Public Properties

Name | Description
FirstObject | Gets or sets the first pair object.
PairElements | Gets the elements of the pair as an arraylist.
SecondObject | Gets or sets the second pair object.

Public Methods

Name | Description
CompareTo | Implements IComparable.CompareTo.
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor

Pair Constructor

Overload List

Name | Description
Pair () | Initializes a new instance of the Pair class.
Pair (Object, Object) | Initializes a new instance of the Pair class.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor ()

Pair Constructor ()
See Also

Initializes a new instance of the Pair class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Pair ()
Visual Basic

Public Sub New ()

See Also

Pair Constructor Overload List
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor (Object, Object)

Pair Constructor (Object, Object)
See Also

Initializes a new instance of the Pair class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Pair (
Object obj1,
Object obj2
)
Visual Basic

Public New ( _
obj1 As Object, _
obj2 As Object _
)

Parameters

obj1
obj2

See Also

Pair Constructor Overload List
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Methods

Pair Methods

Public Methods

Name | Description
CompareTo | Implements IComparable.CompareTo.
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.CompareTo Method

Pair.CompareTo Method

Implements IComparable.CompareTo.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public virtual int CompareTo (
Object obj
)
Visual Basic

Public Overridable Function CompareTo ( _
obj As Object _
) As Integer

Parameters

obj

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.Equals Method

Pair.Equals Method

Object.Equals override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public override bool Equals (
Object obj
)
Visual Basic

Public Overrides Function Equals ( _
obj As Object _
) As Boolean

Parameters

obj

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.GetHashCode Method

Pair.GetHashCode Method

Object.GetHashCode override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public override int GetHashCode ()
Visual Basic

Public Overrides Function GetHashCode () As Integer

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Properties

Pair Properties

Public Properties

Name | Description
FirstObject | Gets or sets the first pair object.
PairElements | Gets the elements of the pair as an arraylist.
SecondObject | Gets or sets the second pair object.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.FirstObject Property

Pair.FirstObject Property

Gets or sets the first pair object.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Object FirstObject { get; set; }
Visual Basic

Public Property FirstObject As Object

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.PairElements Property

Pair.PairElements Property

Gets the elements of the pair as an arraylist.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrayList PairElements { get; }
Visual Basic

Public ReadOnly Property PairElements As ArrayList

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.SecondObject Property

Pair.SecondObject Property

Gets or sets the second pair object.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Object SecondObject { get; set; }
Visual Basic

Public Property SecondObject As Object

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Point3D Structure

Point3D Structure

Represents the coordinates of a point in a 3-dimentional space.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public struct Point3D
Visual Basic

Public Structure Point3D

See Also

Point3D Members
MindFusion.Layout Namespace


MindFusion.Layout.Point3D Members

Point3D Members
Constructors Properties

Represents the coordinates of a point in a 3-dimentional space.

The following tables list the members exposed by the Point3D type.

Public Constructors

Name | Description
Point3D | Initializes a new instance of the Point3D class.

Public Properties

Name | Description
X | Gets or sets the X coordinate of this point.
Y | Gets or sets the Y coordinate of this point.
Z | Gets or sets the Z coordinate of this point.

See Also

Point3D Structure
MindFusion.Layout Namespace


MindFusion.Layout.Point3D Constructor

Point3D Constructor

Initializes a new instance of the Point3D class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public Point3D (
float x,
float y,
float z
)
Visual Basic

Public New ( _
x As Single, _
y As Single, _
z As Single _
)

Parameters

x
y
z

See Also

Point3D Structure
MindFusion.Layout Namespace


MindFusion.Layout.Point3D Properties

Point3D Properties

Public Properties

Name | Description
X | Gets or sets the X coordinate of this point.
Y | Gets or sets the Y coordinate of this point.
Z | Gets or sets the Z coordinate of this point.

See Also

Point3D Structure
MindFusion.Layout Namespace


MindFusion.Layout.Point3D.X Property

Point3D.X Property

Gets or sets the X coordinate of this point.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float X { get; set; }
Visual Basic

Public Property X As Single

Property Value

See Also

Point3D Members
Point3D Structure
MindFusion.Layout Namespace


MindFusion.Layout.Point3D.Y Property

Point3D.Y Property

Gets or sets the Y coordinate of this point.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float Y { get; set; }
Visual Basic

Public Property Y As Single

Property Value

See Also

Point3D Members
Point3D Structure
MindFusion.Layout Namespace


MindFusion.Layout.Point3D.Z Property

Point3D.Z Property

Gets or sets the Z coordinate of this point.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public float Z { get; set; }
Visual Basic

Public Property Z As Single

Property Value

See Also

Point3D Members
Point3D Structure
MindFusion.Layout Namespace


MindFusion.Layout.PreferredRules Enumeration

PreferredRules Enumeration

Specifies which set of rules to use.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum PreferredRules
Visual Basic

Public Enumeration PreferredRules

Members

Member name | Description
ConnectorRules | Use connector rules.
NodeRules | Use node rules.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.RouteHeuristics Delegate

RouteHeuristics Delegate

The link routing algorithm uses a heuristic function of this type in its prediction steps.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public delegate int RouteHeuristics (
Point start,
Point end
)
Visual Basic

Public Delegate Function RouteHeuristics ( _
start As Point, _
end As Point _
) As Integer

Parameters

start
A Point specifying the first of the points, between which the distance is calculated.
end
A Point specifying the first of the points, between which the distance is calculated.

Return Value

An integer value indicating the calculated distance between the specified points.

Remarks

Functions of this type can be assigned to the RouteHeuristics property of the RoutingOptions class.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Interface

RoutingOptions Interface

Allows customization of various aspects of the link routing algorithm.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public interface RoutingOptions
Visual Basic

Public Interface RoutingOptions

See Also

RoutingOptions Members
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Members

RoutingOptions Members
Properties

Allows customization of various aspects of the link routing algorithm.

The following tables list the members exposed by the RoutingOptions type.

Public Properties

Name | Description
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Properties

RoutingOptions Properties

Public Properties

Name | Description
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.GridSize Property

RoutingOptions.GridSize Property

Gets or sets the size of the pieces of the routing grid.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract float GridSize { get; set; }
Visual Basic

Public MustOverride Property GridSize As Single

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.IgnoreAnchoring Property

RoutingOptions.IgnoreAnchoring Property

For internal use.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract bool IgnoreAnchoring { get; }
Visual Basic

Public MustOverride ReadOnly Property IgnoreAnchoring As Boolean

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.LengthCost Property

RoutingOptions.LengthCost Property

Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract byte LengthCost { get; }
Visual Basic

Public MustOverride ReadOnly Property LengthCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.NodeVicinityCost Property

RoutingOptions.NodeVicinityCost Property

Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract byte NodeVicinityCost { get; }
Visual Basic

Public MustOverride ReadOnly Property NodeVicinityCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.TurnCost Property

RoutingOptions.TurnCost Property

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public abstract byte TurnCost { get; }
Visual Basic

Public MustOverride ReadOnly Property TurnCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Class

SimpleKeys Class

Defines keys that can be used to define FlowLayout rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class SimpleKeys
Visual Basic

Public Class SimpleKeys

Inheritance Hierarchy

System.Object
MindFusion.Layout.SimpleKeys
MindFusion.Layout.FlowLayoutKeys

See Also

SimpleKeys Members
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Members

SimpleKeys Members
Constructors Fields Properties Methods

Defines keys that can be used to define FlowLayout rules.

The following tables list the members exposed by the SimpleKeys type.

Public Constructors

Name | Description
SimpleKeys | Initializes a new instance of the SimpleKeys class.

Public Fields

Name | Description
ConnectorTypes | Specifies a list of connector identifiers.
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Associate an array of the node types logic identifiers with this key.
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Associate an array of the node types logic identifiers with this key.
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Associate an array of the node types logic identifiers with this key.
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Associate an array of the node types logic identifiers with this key.
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.
MainSubgroupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow).
PossibleConnection | Specifies what kind of node connections are allowed.

Public Properties

Name | Description
AllKeys | A list of all keys defined in this class.

Public Methods

Name | Description
ValidateRules | Checks if there is a rule for each key in the key list.

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Fields

SimpleKeys Fields

Public Fields

Name | Description
ConnectorTypes | Specifies a list of connector identifiers.
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Associate an array of the node types logic identifiers with this key.
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Associate an array of the node types logic identifiers with this key.
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Associate an array of the node types logic identifiers with this key.
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Associate an array of the node types logic identifiers with this key.
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.
MainSubgroupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow).
PossibleConnection | Specifies what kind of node connections are allowed.

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.ConnectorTypes Field

SimpleKeys.ConnectorTypes Field

Specifies a list of connector identifiers.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string ConnectorTypes
Visual Basic

Public Shared ConnectorTypes As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.FirstGroupLevelNegative Field

SimpleKeys.FirstGroupLevelNegative Field

A rule defining which nodes should be placed above the "Control Flow" line. Associate an array of the node types logic identifiers with this key.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FirstGroupLevelNegative
Visual Basic

Public Shared FirstGroupLevelNegative As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.FirstGroupLevelPositive Field

SimpleKeys.FirstGroupLevelPositive Field

A rule defining which nodes should be placed below the "Control Flow" line. Associate an array of the node types logic identifiers with this key.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string FirstGroupLevelPositive
Visual Basic

Public Shared FirstGroupLevelPositive As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.GroupEndNodes Field

SimpleKeys.GroupEndNodes Field

Specifies which nodes should be considered the end of the current sub-group. Associate an array of the node types logic identifiers with this key.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string GroupEndNodes
Visual Basic

Public Shared GroupEndNodes As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.GroupStartNodes Field

SimpleKeys.GroupStartNodes Field

Specifies which nodes should be considered the start of a new sub-group. Associate an array of the node types logic identifiers with this key.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string GroupStartNodes
Visual Basic

Public Shared GroupStartNodes As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.MainConnectorOrientation Field

SimpleKeys.MainConnectorOrientation Field

Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string MainConnectorOrientation
Visual Basic

Public Shared MainConnectorOrientation As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.MainSubgroupConnector Field

SimpleKeys.MainSubgroupConnector Field

Defines which type of connectors can be used as guideline (defining the graph control flow).

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string MainSubgroupConnector
Visual Basic

Public Shared MainSubgroupConnector As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.PossibleConnection Field

SimpleKeys.PossibleConnection Field

Specifies what kind of node connections are allowed.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string PossibleConnection
Visual Basic

Public Shared PossibleConnection As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Constructor

SimpleKeys Constructor

Initializes a new instance of the SimpleKeys class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SimpleKeys ()
Visual Basic

Public Sub New ()

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Methods

SimpleKeys Methods

Public Methods

Name | Description
ValidateRules | Checks if there is a rule for each key in the key list.

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.ValidateRules Method

SimpleKeys.ValidateRules Method

Checks if there is a rule for each key in the key list.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public bool ValidateRules (
LayoutRules lr
)
Visual Basic

Public Function ValidateRules ( _
lr As LayoutRules _
) As Boolean

Parameters

lr

Return Value

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Properties

SimpleKeys Properties

Public Properties

Name | Description
AllKeys | A list of all keys defined in this class.

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.AllKeys Property

SimpleKeys.AllKeys Property

A list of all keys defined in this class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrayList AllKeys { get; }
Visual Basic

Public ReadOnly Property AllKeys As ArrayList

Property Value

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic Class

SimpleLinkLogic Class

Contains link identifiers for the predefined SimpleRules set of rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class SimpleLinkLogic
Visual Basic

Public Class SimpleLinkLogic

Inheritance Hierarchy

System.Object
MindFusion.Layout.SimpleLinkLogic

See Also

SimpleLinkLogic Members
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic Members

SimpleLinkLogic Members
Constructors Fields

Contains link identifiers for the predefined SimpleRules set of rules.

The following tables list the members exposed by the SimpleLinkLogic type.

Public Constructors

Name | Description
SimpleLinkLogic | Initializes a new instance of the SimpleLinkLogic class.

Public Fields

Name | Description
Master | Identifier for the main connector type.
NotSpecified | Unspecified connector type.
Slave | Identifier for the secondary connector type.

See Also

SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic Fields

SimpleLinkLogic Fields

Public Fields

Name | Description
Master | Identifier for the main connector type.
NotSpecified | Unspecified connector type.
Slave | Identifier for the secondary connector type.

See Also

SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic.Master Field

SimpleLinkLogic.Master Field

Identifier for the main connector type.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string Master
Visual Basic

Public Shared Master As String

See Also

SimpleLinkLogic Members
SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic.NotSpecified Field

SimpleLinkLogic.NotSpecified Field

Unspecified connector type.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string NotSpecified
Visual Basic

Public Shared NotSpecified As String

See Also

SimpleLinkLogic Members
SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic.Slave Field

SimpleLinkLogic.Slave Field

Identifier for the secondary connector type.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string Slave
Visual Basic

Public Shared Slave As String

See Also

SimpleLinkLogic Members
SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic Constructor

SimpleLinkLogic Constructor

Initializes a new instance of the SimpleLinkLogic class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SimpleLinkLogic ()
Visual Basic

Public Sub New ()

See Also

SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic Class

SimpleNodeLogic Class

Contains node identifiers for the predefined SimpleRules set of rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class SimpleNodeLogic
Visual Basic

Public Class SimpleNodeLogic

Inheritance Hierarchy

System.Object
MindFusion.Layout.SimpleNodeLogic

See Also

SimpleNodeLogic Members
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic Members

SimpleNodeLogic Members
Constructors Fields

Contains node identifiers for the predefined SimpleRules set of rules.

The following tables list the members exposed by the SimpleNodeLogic type.

Public Constructors

Name | Description
SimpleNodeLogic |

Public Fields

Name | Description
Action | Identifier for action nodes.
End | Identifier for group end nodes.
NotSpecified | Unspecified node type.
Start | Identifier for group start nodes.

See Also

SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic Fields

SimpleNodeLogic Fields

Public Fields

Name | Description
Action | Identifier for action nodes.
End | Identifier for group end nodes.
NotSpecified | Unspecified node type.
Start | Identifier for group start nodes.

See Also

SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic.Action Field

SimpleNodeLogic.Action Field

Identifier for action nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string Action
Visual Basic

Public Shared Action As String

See Also

SimpleNodeLogic Members
SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic.End Field

SimpleNodeLogic.End Field

Identifier for group end nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string End
Visual Basic

Public Shared End As String

See Also

SimpleNodeLogic Members
SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic.NotSpecified Field

SimpleNodeLogic.NotSpecified Field

Unspecified node type.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string NotSpecified
Visual Basic

Public Shared NotSpecified As String

See Also

SimpleNodeLogic Members
SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic.Start Field

SimpleNodeLogic.Start Field

Identifier for group start nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public static string Start
Visual Basic

Public Shared Start As String

See Also

SimpleNodeLogic Members
SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic Constructor

SimpleNodeLogic Constructor

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SimpleNodeLogic ()
Visual Basic

Public Sub New ()

See Also

SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleOrientation Enumeration

SimpleOrientation Enumeration

Specifies the preferred orientation for the main connector type in FlowLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum SimpleOrientation
Visual Basic

Public Enumeration SimpleOrientation

Members

Member name | Description
LeftToRight | Specifies left-to-right orientation.
RightToLeft | Specifies right-to-left orientation.
BottomToTop | Specifies bottom-to-top orientation.
None | Unspecified orientation.
TopToBottom | Specifies top-to-bottom orientation.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Class

SimpleRules Class

Class of simple rules requisited for Flowlayout algorithm.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public class SimpleRules : LayoutRules
Visual Basic

Public Class SimpleRules
Inherits LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.SimpleRules

See Also

SimpleRules Members
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Members

SimpleRules Members
Constructors Properties

Class of simple rules requisited for Flowlayout algorithm.

The following tables list the members exposed by the SimpleRules type.

Public Constructors

Name | Description
SimpleRules | Overloaded.

Public Properties

Name | Description
EndSubgproupNode | Defines which type of nodes will be used as a "sub group end" node;
MainConnectorOrientation | A key defining the space orientation of a "Control Flow" and respectively for the layout;
MainSubgproupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow).
StartSubgproupNode | Defines which type of nodes will be used as a "sub group" start node.

See Also

SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Constructor

SimpleRules Constructor

Overload List

Name | Description
SimpleRules () | Initializes a new instance of the SimpleRules class.
SimpleRules (ArrayList, ArrayList, String) | Initializes a new instance of the SimpleRules class.
SimpleRules (ArrayList, ArrayList, String, SimpleOrientation) | Initializes a new instance of the SimpleRules class.

See Also

SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Constructor ()

SimpleRules Constructor ()
See Also

Initializes a new instance of the SimpleRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SimpleRules ()
Visual Basic

Public Sub New ()

See Also

SimpleRules Constructor Overload List
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Constructor (ArrayList, ArrayList, String)

SimpleRules Constructor (ArrayList, ArrayList, String)
See Also

Initializes a new instance of the SimpleRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SimpleRules (
ArrayList strtSubGroupNodeType_ls,
ArrayList endSubGroupNodeType_ls,
string mainConnector
)
Visual Basic

Public New ( _
strtSubGroupNodeType_ls As ArrayList, _
endSubGroupNodeType_ls As ArrayList, _
mainConnector As String _
)

Parameters

strtSubGroupNodeType_ls
endSubGroupNodeType_ls
mainConnector

See Also

SimpleRules Constructor Overload List
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Constructor (ArrayList, ArrayList, String, SimpleOrientation)

SimpleRules Constructor (ArrayList, ArrayList, String, SimpleOrientation)
See Also

Initializes a new instance of the SimpleRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SimpleRules (
ArrayList strtSubGroupNodeType_ls,
ArrayList endSubGroupNodeType_ls,
string mainConnector,
SimpleOrientation mainConnectorOrdrDrctn
)
Visual Basic

Public New ( _
strtSubGroupNodeType_ls As ArrayList, _
endSubGroupNodeType_ls As ArrayList, _
mainConnector As String, _
mainConnectorOrdrDrctn As SimpleOrientation _
)

Parameters

strtSubGroupNodeType_ls
endSubGroupNodeType_ls
mainConnector
mainConnectorOrdrDrctn

See Also

SimpleRules Constructor Overload List
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Properties

SimpleRules Properties

Public Properties

Name | Description
EndSubgproupNode | Defines which type of nodes will be used as a "sub group end" node;
MainConnectorOrientation | A key defining the space orientation of a "Control Flow" and respectively for the layout;
MainSubgproupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow).
StartSubgproupNode | Defines which type of nodes will be used as a "sub group" start node.

See Also

SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules.EndSubgproupNode Property

SimpleRules.EndSubgproupNode Property

Defines which type of nodes will be used as a "sub group end" node;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrayList EndSubgproupNode { get; set; }
Visual Basic

Public Property EndSubgproupNode As ArrayList

Property Value

See Also

SimpleRules Members
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules.MainConnectorOrientation Property

SimpleRules.MainConnectorOrientation Property

A key defining the space orientation of a "Control Flow" and respectively for the layout;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public SimpleOrientation MainConnectorOrientation { get; set; }
Visual Basic

Public Property MainConnectorOrientation As SimpleOrientation

Property Value

See Also

SimpleRules Members
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules.MainSubgproupConnector Property

SimpleRules.MainSubgproupConnector Property

Defines which type of connectors can be used as guideline (defining the graph control flow).

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public string MainSubgproupConnector { get; set; }
Visual Basic

Public Property MainSubgproupConnector As String

Property Value

See Also

SimpleRules Members
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules.StartSubgproupNode Property

SimpleRules.StartSubgproupNode Property

Defines which type of nodes will be used as a "sub group" start node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public ArrayList StartSubgproupNode { get; set; }
Visual Basic

Public Property StartSubgproupNode As ArrayList

Property Value

See Also

SimpleRules Members
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SpringLayoutTraits Enumeration

SpringLayoutTraits Enumeration

Indicates item traits specific to SpringLayout. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum SpringLayoutTraits
Visual Basic

Public Enumeration SpringLayoutTraits

Members

Member name | Description
Frozen | If the LayoutTraits value associated with a node through this key is true, SpringLayout considers the repulsion forces exerted by the node to other nodes, but ignores forces acting on the node and keeps it in place.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.TreeLayoutTraits Enumeration

TreeLayoutTraits Enumeration

Indicates item traits specific to tree layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C#

public enum TreeLayoutTraits
Visual Basic

Public Enumeration TreeLayoutTraits

Members

Member name | Description
Assistant | If the LayoutTraits value associated with a node through this key is true, centered TreeLayout treats this node as an "assistant" during the arrangement. If the value is false or is not present, the node is treated as "subordinate". This value is considered when the EnableAssistants property of TreeLayout is set to true.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.Layout3D Namespace
Enumerations

Enumerations

Enumeration | Description
Surface | Contains values specifying the type of surface on which nodes are initially placed when running 3D SpringLayout.


MindFusion.Layout.Layout3D.Surface Enumeration

Surface Enumeration

Contains values specifying the type of surface on which nodes are initially placed when running 3D SpringLayout.

Namespace: MindFusion.Layout.Layout3D
Assembly: MindFusion.Diagramming

Syntax

C#

public enum Surface
Visual Basic

Public Enumeration Surface

Members

Member name | Description
Cone | The nodes are initially placed on a cone.
Cylinder | The nodes are initially placed on a cylinder.
Sphere | The nodes are initially placed on a sphere.
Unspecified | The nodes are initially placed on a sphere.

See Also

MindFusion.Layout.Layout3D Namespace


MindFusion.Reporting Namespace
Classes Structures Enumerations

Classes

Class | Description
AxesChart | A base class for report items representing charts that use the rectangular coordinate system.
BarChart | Represents a report item that can display bar charts.
Border | Defines a border around a report element.
Canvas | Represents a report item that provides a way to render custom contents within the report.
Chart | Base class for all charts in the report. Holds methods and properties common for all derived charts.
ControlWrapper | Represents a wrapper around a System.Windows.Forms.Control that can be added and rendered in a MindFusion.Reporting.Report.
DataRange | Represents a report item that provides master detail relation during data-binding.
DataRangeSection | Represents a data range header or footer.
DrawCanvasEventArgs | Contains the arguments passed to handlers of the RenderContents event of the Canvas class.
DrawContext | Provides contextual information when drawing report items.
DrawEventArgs | Provides data for various rendering events.
Ellipse | A report element that draws a simple ellipse.
ItemContainer | Represents a base class for report items that can serve as containers for other report items, such as DataRange.
Label | A report element that draws a static text.
Line | A report element that draws a simple line.
LineChart | Represents a report item that can display line charts.
Margins | Specifies the dimensions of the margins of a rectangle.
Page | Represents a page within a report.
PageBreak | Represents a single line across the whole width of a page, which indicates a page break at that location.
PageSection | Represents a page header or footer.
Picture | A report element that draws an image.
PieChart | Represents a report item that can display pie charts.
RadarChart | Represents a report item that can display radar charts.
Report | Serves as base class for all reports.
ReportItem | Represents an abstract base class for all report elements.
ReportLayout | Represents precalculated report layout.

Structures

Structure | Description
Dimension | Stores an ordered pair of floating-point numbers, typically the width and height of an object.
Location | Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.

Enumerations

Enumeration | Description
MeasureUnit | Specifies units of measure.
PageOrientation | Specifies the orientation of a printed page.


MindFusion.Reporting.AxesChart Class

AxesChart Class
Remarks See Also

A base class for report items representing charts that use the rectangular coordinate system.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public abstract class AxesChart : Chart
Visual Basic

Public MustInherit Class AxesChart
Inherits Chart

Remarks

AxesChart inherits properties and methods from its base class Chart.

Chart axes can be drawn with a shadow, which length is set with the Depth3D property. Use AxisShadowBrush to set the brush for the axis shadow. AxisPen specifies the pen for the chart axes.

Every axes chart can be drawn with a grid. You can choose among several grid types by using the GridType property. If the grid is Crossed, its density is set with GridWidth. The stripes of the grid are filled with GridBrush and AltGridBrush. The grid is drawn with the GridPen.

Custom grid points are set with HorGridPoints and VertGridPoints. They are drawn with HorGridPens and VertGridPens. Stripes in custom grids are filled with HorGridBrushes and VertGridBrushes.

Custom grids can have grid labels. They are set wtih XGridLabels, YGridLabels and Y2GridLabels. The orientation of the labels at the X-axis is set with XGridLabelsOrientation. If you want pointers to the grid labels, use GridLabelPointer.

The summary graphics or parts of graphics are drawn with SummaryBrushes and SummaryPens. Graphics, which data is bound to the Y2-axis are drawn with the Y2ChartBrushes and Y2ChartPens.

The AxisSettings class holds the settings for the chart axes - chart label, length, type of axis labels, label prefix and suffix, data formatting and so on. The properties for each chart axis are called XAxisSettings, YAxisSettings and Y2AxisSettings.

The chart data is set with XData and YData. Use Y2Data if you want to draw graphics for the second Y-axis, parallel to the first one. Data can be either numbers or DateTime values or any other format that can safely be converted to numbers / DateTime values using the standard .NET type converters.

Charts can be drawn with an Offset from the start of the coordinate system.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Chart
MindFusion.Reporting.AxesChart
MindFusion.Reporting.BarChart
MindFusion.Reporting.LineChart

See Also

AxesChart Members
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart Members

AxesChart Members
Constructors Properties

A base class for report items representing charts that use the rectangular coordinate system.

The following tables list the members exposed by the AxesChart type.

Protected Constructors

Name | Description
AxesChart | Initializes a new instance of the AxesChart class.

Public Properties

Name | Description
AltGridBrush | Gets or sets the brush used for filling even grid stripes.
AxisPen | Gets or sets the pen used for drawing the chart axis.
AxisShadowBrush | Gets or sets the brush used for filling the axis shadow in 3D charts.
ChartBackgroundBrush | Gets or sets the brush used for filling the plot area of the chart.
Depth3D | Gets or sets the depth of 3D charts.
DistBtwSeries | Gets or sets the distance between chart graphics drawn behind each other.
GridBrush | Gets or sets the brush used for filling odd grid stripes.
GridLabelPointer | Gets or sets the length of the pointer to custom grid labels.
GridPen | Gets or sets the pen for drawing grid lines.
GridType | Gets or sets the type of the grid.
GridWidth | Gets or sets the distance between adjacent grid lines in custom grids.
HorGridBrushes | Gets or sets the brushes for filling horizontal stripes in custom grids.
HorGridPens | Gets or sets the pens used for drawing horizontal grid lines in custom grids.
HorGridPoints | Gets or sets the positions of horizontal lines in custom grids.
Horizontal | Gets or sets the orientation of the chart.
Offset | Gets or sets the offset of the chart from the beginning of the axis.
SummaryBrushes | Gets or sets the brushes used for filling summary chart parts.
SummaryPens | Gets or sets the pens used for drawing summary chart parts.
SummaryValues | Gets or sets a list with the summary operations performed at chart data.
VertGridBrushes | Gets or sets the brushes used for filling vertical grid stripes in a custom grid.
VertGridPens | Gets or sets the pens used for drawing vertical lines in a custom grid.
VertGridPoints | Gets or sets the positions of vertical lines in a custom grid.
XAxisSettings | Gets or sets the appearance settings for the x-axis.
XGridLabels | Gets or sets the labels drawn at the x-axis in a custom grid with vertical stripes.
XGridLabelsOrientation | Gets or sets the orientation of the labels drawn at the X-axis in a custom grid with vertical stripes.
XLabels | Gets or sets custom labels for the x-axis.
XLabelsFields | Gets or sets the database columns from which custom labels for the x-axis are retrieved.
Y2AxisSettings | Gets or sets the appearance settings for the second y-axis.
Y2ChartBrushes | Gets or sets the brushes used for filling chart parts bound to the second y-axis.
Y2ChartPens | Gets or sets the pens used for drawing chart parts bound to the second y-axis.
Y2Data | Gets or sets the data for the second Y-axis.
Y2DataFields | Gets or sets the database columns, from which data for chart graphics bound to the second Y-axis is retrieved.
Y2GridLabels | Gets or sets the labels for the second y-axis in a custom grid with horizontal stripes.
Y2GridLabelsOrientation | Gets or sets the orientation for labels drawn at the second y-axis in a custom grid with horizontal stripes.
Y2Labels | Gets or sets custom labels for the second Y-axis.
Y2LabelsFields | Gets or sets the database columns, from which custom labels for the second y-axis are retrieved.
YAxisSettings | Gets or sets the appearance settings for the y-axis.
YGridLabels | Gets or sets the labels drawn at the y-axis in a custom grid with horizontal stripes.
YGridLabelsOrientation | Gets or sets the orientation of labels drawn at the y-axis in a custom grid with horizontal stripes.
YLabels | Gets or sets custom labels for the y-axis.
YLabelsFields | Gets or sets the database columns, from which custom labels for the y-axis are retrieved.

See Also

AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart Constructor

AxesChart Constructor

Initializes a new instance of the AxesChart class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

protected AxesChart ()
Visual Basic

Protected Sub New ()

See Also

AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart Properties

AxesChart Properties

Public Properties

Name | Description
AltGridBrush | Gets or sets the brush used for filling even grid stripes.
AxisPen | Gets or sets the pen used for drawing the chart axis.
AxisShadowBrush | Gets or sets the brush used for filling the axis shadow in 3D charts.
ChartBackgroundBrush | Gets or sets the brush used for filling the plot area of the chart.
Depth3D | Gets or sets the depth of 3D charts.
DistBtwSeries | Gets or sets the distance between chart graphics drawn behind each other.
GridBrush | Gets or sets the brush used for filling odd grid stripes.
GridLabelPointer | Gets or sets the length of the pointer to custom grid labels.
GridPen | Gets or sets the pen for drawing grid lines.
GridType | Gets or sets the type of the grid.
GridWidth | Gets or sets the distance between adjacent grid lines in custom grids.
HorGridBrushes | Gets or sets the brushes for filling horizontal stripes in custom grids.
HorGridPens | Gets or sets the pens used for drawing horizontal grid lines in custom grids.
HorGridPoints | Gets or sets the positions of horizontal lines in custom grids.
Horizontal | Gets or sets the orientation of the chart.
Offset | Gets or sets the offset of the chart from the beginning of the axis.
SummaryBrushes | Gets or sets the brushes used for filling summary chart parts.
SummaryPens | Gets or sets the pens used for drawing summary chart parts.
SummaryValues | Gets or sets a list with the summary operations performed at chart data.
VertGridBrushes | Gets or sets the brushes used for filling vertical grid stripes in a custom grid.
VertGridPens | Gets or sets the pens used for drawing vertical lines in a custom grid.
VertGridPoints | Gets or sets the positions of vertical lines in a custom grid.
XAxisSettings | Gets or sets the appearance settings for the x-axis.
XGridLabels | Gets or sets the labels drawn at the x-axis in a custom grid with vertical stripes.
XGridLabelsOrientation | Gets or sets the orientation of the labels drawn at the X-axis in a custom grid with vertical stripes.
XLabels | Gets or sets custom labels for the x-axis.
XLabelsFields | Gets or sets the database columns from which custom labels for the x-axis are retrieved.
Y2AxisSettings | Gets or sets the appearance settings for the second y-axis.
Y2ChartBrushes | Gets or sets the brushes used for filling chart parts bound to the second y-axis.
Y2ChartPens | Gets or sets the pens used for drawing chart parts bound to the second y-axis.
Y2Data | Gets or sets the data for the second Y-axis.
Y2DataFields | Gets or sets the database columns, from which data for chart graphics bound to the second Y-axis is retrieved.
Y2GridLabels | Gets or sets the labels for the second y-axis in a custom grid with horizontal stripes.
Y2GridLabelsOrientation | Gets or sets the orientation for labels drawn at the second y-axis in a custom grid with horizontal stripes.
Y2Labels | Gets or sets custom labels for the second Y-axis.
Y2LabelsFields | Gets or sets the database columns, from which custom labels for the second y-axis are retrieved.
YAxisSettings | Gets or sets the appearance settings for the y-axis.
YGridLabels | Gets or sets the labels drawn at the y-axis in a custom grid with horizontal stripes.
YGridLabelsOrientation | Gets or sets the orientation of labels drawn at the y-axis in a custom grid with horizontal stripes.
YLabels | Gets or sets custom labels for the y-axis.
YLabelsFields | Gets or sets the database columns, from which custom labels for the y-axis are retrieved.

See Also

AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.AltGridBrush Property

AxesChart.AltGridBrush Property

Gets or sets the brush used for filling even grid stripes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush AltGridBrush { get; set; }
Visual Basic

Public Property AltGridBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

AltGridBrush is used for filling the even grid stripes when the GridType is not GridType.None or GridType.Custom. The odd grid stripes are filled with GridBrush. The grid stripes are drawn with the GridPen.

When the GridType is GridType.Custom the grid stripes are painted with HorGridBrushes and VertGridBrushes.

Default value for the AltGridBrush is null (no brush).

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.AxisPen Property

AxesChart.AxisPen Property

Gets or sets the pen used for drawing the chart axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Pen AxisPen { get; set; }
Visual Basic

Public Property AxisPen As Pen

Property Value

An instance of the Pen class.

Remarks

The property is used for drawing all chart axes. If the chart is of 3D type the axis shadow is drawn with AxisShadowBrush. If no AxisShadowBrush is specified, a shadow brush a little darker than the AxisPen is created.

Default value of the AxisPen property is black pen with width 1.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.AxisShadowBrush Property

AxesChart.AxisShadowBrush Property

Gets or sets the brush used for filling the axis shadow in 3D charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush AxisShadowBrush { get; set; }
Visual Basic

Public Property AxisShadowBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

The property specifies the brush for drawing axes shadows in 3D charts.

Axes are drawn with shadows when the type of the chart (LineType, BarType) is set to a 3D chart and Depth3D is greater than 0. If the chart has multiple series, its shadow is drawn larger so that all series could fit in.

Default value for the AxisShadowBrush property is a semi - transparent SolidBrush with alpha value 100 and color equal to the color of the AxisPen.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.ChartBackgroundBrush Property

AxesChart.ChartBackgroundBrush Property

Gets or sets the brush used for filling the plot area of the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush ChartBackgroundBrush { get; set; }
Visual Basic

Public Property ChartBackgroundBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

The property is used for drawing the area of the chart background that lies between the chart axes. If the ChartBackgroundBrush is not set, the BackgroundBrush is used for drawing the whole chart background.

Value for the property can be any brush that is derived from MindFusion.Drawing.Brush - SolidBrush, LinearGradientBrush, PathGradientBrush and so on.

Default value for the ChartBackgroundBrush property is null, that is, the plot area is drawn with the BackgroundBrush.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.Depth3D Property

AxesChart.Depth3D Property

Gets or sets the depth of 3D charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float Depth3D { get; set; }
Visual Basic

Public Property Depth3D As Single

Property Value

A float value specifying the depth of the 3D charts, in pixels.

Remarks

The property is used only by 3D charts. If the chart draws more than one series, the Depth3D property is multiplied by the count of the series. Stacked bar charts make an exception since their series are drawn as sections in a single bar.

Default value for the Depth3D property is 20f.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.DistBtwSeries Property

AxesChart.DistBtwSeries Property

Gets or sets the distance between chart graphics drawn behind each other.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float DistBtwSeries { get; set; }
Visual Basic

Public Property DistBtwSeries As Single

Property Value

A float value specifying the distance between the chart series, in pixels.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.GridBrush Property

AxesChart.GridBrush Property

Gets or sets the brush used for filling odd grid stripes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush GridBrush { get; set; }
Visual Basic

Public Property GridBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

GridBrush is used for filling the odd grid stripes when the GridType is not GridType.None or GridType.Custom. The even grid stripes are filled with AltGridBrush. The grid stripes are drawn with the GridPen.

Grid stripes in custom grids are painted with HorGridBrushes and VertGridBrushes.

Default value for the GridBrush is null (no brush).

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.GridLabelPointer Property

AxesChart.GridLabelPointer Property

Gets or sets the length of the pointer to custom grid labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float GridLabelPointer { get; set; }
Visual Basic

Public Property GridLabelPointer As Single

Property Value

A float value specifying the length of the pointer.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.GridPen Property

AxesChart.GridPen Property

Gets or sets the pen for drawing grid lines.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Pen GridPen { get; set; }
Visual Basic

Public Property GridPen As Pen

Property Value

An object of type MindFusion.Drawing.Pen.

Remarks

The GridPen is used for drawing the chart grid when the GridType is not GridType.None or GridType.Custom. The grid stripes are painted with GridBrush and AltGridBrush. You can have a grid that has only stripes and no lines are drawn. In this case, set GridPen to null.

The border of the grid is drawn with GridOutlinePen.

Default value for the GridPen is null, that is, no grid is drawn.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.GridType Property

AxesChart.GridType Property

Gets or sets the type of the grid.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public GridType GridType { get; set; }
Visual Basic

Public Property GridType As GridType

Property Value

One of the GridType Enumeration members.

Remarks

Grid can be drawn at all charts with axes. When the grid is of type GridType.Chess its width is set by GridWidth.

When the grid is custom, the positions of grid lines are specified with HorGridPoints and VertGridPoints. For all grid types, except GridType.None, the width is calculated automatically based on the scale of the axes.

Default value for the GridType property is GridType.None.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.GridWidth Property

AxesChart.GridWidth Property

Gets or sets the distance between adjacent grid lines in custom grids.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float GridWidth { get; set; }
Visual Basic

Public Property GridWidth As Single

Property Value

A float value.

Remarks

The property is considered only for GridType.Chess. Default value for the GridWidth property is 0.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.HorGridBrushes Property

AxesChart.HorGridBrushes Property

Gets or sets the brushes for filling horizontal stripes in custom grids.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BrushCollection HorGridBrushes { get; set; }
Visual Basic

Public Property HorGridBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

The GridType should be set to GridType.Custom and HorGridPoints should not be empty. If the brushes are less than the grid stripes to be filled, they are used in a cycle.

Default value for the HorGridBrushes property is an empty BrushCollection, in this case no stripes are drawn.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.HorGridPens Property

AxesChart.HorGridPens Property

Gets or sets the pens used for drawing horizontal grid lines in custom grids.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenCollection HorGridPens { get; set; }
Visual Basic

Public Property HorGridPens As PenCollection

Property Value

An object of type MindFusion.Drawing.PenCollection.

Remarks

The GridType should be set to GridType.Custom and HorGridPoints should not be empty. If the count of the pens is less than the count of the stripes, they are used in a cycle.

Default value for the HorGridPens is an empty PenCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.HorGridPoints Property

AxesChart.HorGridPoints Property

Gets or sets the positions of horizontal lines in custom grids.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList HorGridPoints { get; set; }
Visual Basic

Public Property HorGridPoints As IList

Property Value

An object of type .NET IList.

Remarks

HorGridPoints is used when GridType is set to GridType.Custom. The values should range from 0 to 100 with 0 coinciding with the start of the Y-axis and 100 - with its end.

The stripes are drawn with HorGridPens and are filled with HorGridBrushes. You can leave the property empty if you do not need horizontal grid lines.

Default value for the HorGridPoints property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.Horizontal Property

AxesChart.Horizontal Property

Gets or sets the orientation of the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool Horizontal { get; set; }
Visual Basic

Public Property Horizontal As Boolean

Property Value

true if the chart is horizontal; otherwise false.

Remarks

In horizontal bar charts, the Data property specifies values for the X-axis. In vertical bar charts, the Data property specifies values for the Y-axis.

Line charts use data from both XData and YData lists, no matter their orientation. Summary operations are performed on XData for horizontal charts and YData for vertical ones. Bubble charts have no orientation.

Default value for the Horizontal property is false.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.Offset Property

AxesChart.Offset Property

Gets or sets the offset of the chart from the beginning of the axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float Offset { get; set; }
Visual Basic

Public Property Offset As Single

Property Value

A float value.

Remarks

Vertical charts with positive values are shifted rightwards, with offset at the X-axis. If the chart has only negative X-values, it is shifted leftwards. Horizontal charts with positive values are shifted upwards, with offset at the Y-axis. If the chart has only negative Y-values, it is shifted downwards.

The orientation of the chart is set with the Horizontal property.

Default value for the Offset property is 0 (no offset).

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.SummaryBrushes Property

AxesChart.SummaryBrushes Property

Gets or sets the brushes used for filling summary chart parts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BrushCollection SummaryBrushes { get; set; }
Visual Basic

Public Property SummaryBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

SummaryBrushes are used for filling summary parts in all types of charts that use axes. The summary graphics depend on the type of the chart - in bar charts they are bars, in area charts - areas and so on. If SummaryBrushes are not set, the control creates brushes from the SummaryPens, if any.

Summaries are drawn when the SummaryValues property is not an empty list.

Default value for the SummaryBrushes property is an empty BrushCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.SummaryPens Property

AxesChart.SummaryPens Property

Gets or sets the pens used for drawing summary chart parts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenCollection SummaryPens { get; set; }
Visual Basic

Public Property SummaryPens As PenCollection

Property Value

An object of type MindFusion.Drawing.PenCollection.

Remarks

SummaryPens are used for drawing summary parts in all charts that use axes. The summary graphics depends on the chart type - in line charts it is a line, in bar charts - bar and so on. If SummaryPens are not set, the control uses SummaryBrushes, if any, to create pens from them.

Use SummaryValues to add Summary-s to the chart.

Default value for the SummaryPens property is an empty PenCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.SummaryValues Property

AxesChart.SummaryValues Property

Gets or sets a list with the summary operations performed at chart data.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList SummaryValues { get; set; }
Visual Basic

Public Property SummaryValues As IList

Property Value

An object of type System.Collection.IList that holds the summaries.

Remarks

SummaryValues enables you to add aggregate operations like min, max, average and so on to the chart values. Use the members of the Summary enumeration. You can specify your own summary values with the AddCustomSummary method.

Summary graphics follow the shape of the chart they refer to. In line charts, they are lines, in bar charts - bars, and so on. They are drawn with SummaryPens and SummaryBrushes. The labels for sumary charts are the same type as those of the chart's axes.

Summary operations are performed on XData for horizontal line charts and on YData for vertical ones. In bar charts always Data is used.

Default value for the SummaryValues property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.VertGridBrushes Property

AxesChart.VertGridBrushes Property

Gets or sets the brushes used for filling vertical grid stripes in a custom grid.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BrushCollection VertGridBrushes { get; set; }
Visual Basic

Public Property VertGridBrushes As BrushCollection

Property Value

An object of type MindFusion.Drawing.BrushCollection.

Remarks

Vertical stripes and lines in custom grids are drawn when the VertGridPoints property is not an empty list. The grid lines are drawn with VertGridPens. The GridType should be set to GridType.Custom.

The respective properties for drawing horizontal grid stripes are HorGridPoints, HorGridPens and HorGridBrushes.

Default value for the VertGridBrushes property is an empty BrushCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.VertGridPens Property

AxesChart.VertGridPens Property

Gets or sets the pens used for drawing vertical lines in a custom grid.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenCollection VertGridPens { get; set; }
Visual Basic

Public Property VertGridPens As PenCollection

Property Value

An object of type MindFusion.Drawing.PenCollection.

Remarks

The property specifies the pens for drawing vertical grid lines in custom grids. In this case the grid stripes are filled with brushes from the VertGridBrushes property. The position of the grid lines is specified with VertGridPoints.

Custom grids can have labels at the X-axis. The labels are set with XGridLabels property.

When the GridType is not GridType.Custom, the grid is drawn with the GridPen and the grid stripes are filled with GridBrush and AltGridBrush.

Default value for the VertGridPens property is an empty PenCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.VertGridPoints Property

AxesChart.VertGridPoints Property

Gets or sets the positions of vertical lines in a custom grid.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList VertGridPoints { get; set; }
Visual Basic

Public Property VertGridPoints As IList

Property Value

An object of type .NET IList.

Remarks

Add to the VertGridPoints property numbers between 0 and 100. Zero coincides with the start of the X-axis and 100 - with its end. Use VertGridPens and VertGridBrushes to specify the pens and brushes for filing the grid stripes. The GridType should be set to GridType.Custom.

The respective properties for drawing horizontal grid stripes are HorGridPoints, HorGridPens and HorGridBrushes.

Default value for the VertGridBrushes property is an empty BrushCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.XAxisSettings Property

AxesChart.XAxisSettings Property

Gets or sets the appearance settings for the x-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public AxisSettings XAxisSettings { get; set; }
Visual Basic

Public Property XAxisSettings As AxisSettings

Property Value

An AxisSettings object.

Remarks

The property specifies all appearance characteristics of the X-axis: labels, fonts, data format, minimum and maximum value as well the intervals among them, label suffix and prefix, division coefficient and division label and so on.

For more information about the axis properties and their default values, please check the AxisSettings class.

Default value for the XAxisSettings property is a new AxisSettings object. You can access it directly through the XAxisSettings property.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.XGridLabels Property

AxesChart.XGridLabels Property

Gets or sets the labels drawn at the x-axis in a custom grid with vertical stripes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList XGridLabels { get; set; }
Visual Basic

Public Property XGridLabels As IList

Property Value

An object of type .NET IList.

Remarks

The labels are drawn with XGridLabelBrushes. The GridType should be set to GridType.Custom. Use VertGridPoints to specify the position of the XGridLabels at the X-axis. GridLabelsAtLines specifies whether the labels are drawn at grid lines or in the middle of the grid segment.

The orientation of the grid labels is set with XGridLabelsOrientation.

Default value for the XGridLabels property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.XGridLabelsOrientation Property

AxesChart.XGridLabelsOrientation Property

Gets or sets the orientation of the labels drawn at the X-axis in a custom grid with vertical stripes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public LabelOrientation XGridLabelsOrientation { get; set; }
Visual Basic

Public Property XGridLabelsOrientation As LabelOrientation

Property Value

One of the LabelOrientation Enumeration values.

Remarks

The property specifies the orientation of grid labels drawn at the X-axis when the GridType is GridType.Custom. Grid labels are specified with the XGridLabels property. Their position depends on the VertGridPoints and GridLabelsAtLines properties.

Default value for XGridLabelsOrientation property is LabelOrientation.InRow.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.XLabels Property

AxesChart.XLabels Property

Gets or sets custom labels for the x-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList XLabels { get; set; }
Visual Basic

Public Property XLabels As IList

Property Value

An object of type .NET IList that holds other lists with the labels.

Remarks

The labels are drawn when XAxisSettings.LabelType is set to AxisLabelType.CustomText. If the labels are not set as strings, the control converts them automatically.

In multi-series charts, the labels are drawn in rows. The space among the rows depends on LabelSpan. LabelOffset specifies the offset of the labels to the chart axis.

The labels can be drawn rotated if RotationAngle is greater than zero. LabelBrush sets the brush for the labels. If MultiColoredLabels is true, the labels are drawn with the ChartBrushes.

If the labels are less than the data, the control adds empty strings. If they are more, the excess labels are omitted.

Default value for the XLabels property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.XLabelsFields Property

AxesChart.XLabelsFields Property

Gets or sets the database columns from which custom labels for the x-axis are retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string XLabelsFields { get; set; }
Visual Basic

Public Property XLabelsFields As String

Property Value

A string that specifies the name of the data source field used as X-labels.

Remarks

The property enables you to bind the labels drawn at the X-axis to a field in a database. The data source object is specified with the DataSource property. If it is of type DataSet, you can use the DataMember property to specify a given table as source for the chart data. In this case, the fields of the table appear as items in the drop down combo box in the XLabelsFields property of the chart control.

The labels specified with the XLabelsFields are drawn only if the LabelType of the XAxisSettings property is set to AxisLabelType.CustomText.

The XLabelsFields property, when populated with data, is the same as the XLabels property.

Default value for the XLabelsFields property is an empty string ("").

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.Y2AxisSettings Property

AxesChart.Y2AxisSettings Property

Gets or sets the appearance settings for the second y-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public AxisSettings Y2AxisSettings { get; set; }
Visual Basic

Public Property Y2AxisSettings As AxisSettings

Property Value

An instance of the AxisSettings class.

Remarks

The property specifies all appearance characteristics of the Y2-axis: labels, fonts, data format, minimum and maximum value as well the intervals among them, label suffix and prefix, division coefficient and division label and so on. For more information about the axis properties and their default values, please check the AxisSettings class.

Y2Axis is drawn only when Y2Data is not an empty list. It is drawn parallel to the Y-axis, at the end of the X-axis.

Default value for the Y2AxisSettings property is a new AxisSettings object, which properties are set to their default values.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.Y2ChartBrushes Property

AxesChart.Y2ChartBrushes Property

Gets or sets the brushes used for filling chart parts bound to the second y-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BrushCollection Y2ChartBrushes { get; set; }
Visual Basic

Public Property Y2ChartBrushes As BrushCollection

Property Value

An instance of type MindFusion.Drawing.BrushCollection.

Remarks

Y2 chart graphics are drawn only when the Y2Data property is not empty. Use Y2ChartPens to set the pens. If the brushes are less than the data series, the control cycles through them.

Default value for the Y2ChartBrushes property is an empty BrushCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.Y2ChartPens Property

AxesChart.Y2ChartPens Property

Gets or sets the pens used for drawing chart parts bound to the second y-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenCollection Y2ChartPens { get; set; }
Visual Basic

Public Property Y2ChartPens As PenCollection

Property Value

An instance of MindFusion.Drawing.PenCollection class.

Remarks

Y2 chart graphics are drawn only when the Y2Data property is not an empty list. The brushes are set with Y2ChartBrushes. If the pens are less than the data series, the control cycles through them.

Default value for the Y2ChartPens property is an empty PenCollection.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.Y2Data Property

AxesChart.Y2Data Property

Gets or sets the data for the second Y-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList Y2Data { get; set; }
Visual Basic

Public Property Y2Data As IList

Property Value

An object of type .NET IList class that holds other lists with the numbers.

Remarks

Data can be either numbers or DateTime values. They can be set in any format - integer, float, string as long as it can safely be converted to double-s or DateTime values using the standard .NET DoubleConverter and DateTimeConveter classes. The appearance options for the Y2-axis are set with Y2AxisSettings.

In bubble charts, the property is used to calculate the bubbles' radii.

Default value for the Y2Data property is an empty IList object.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.Y2DataFields Property

AxesChart.Y2DataFields Property

Gets or sets the database columns, from which data for chart graphics bound to the second Y-axis is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string Y2DataFields { get; set; }
Visual Basic

Public Property Y2DataFields As String

Property Value

A string that specifies the name of the data source field.

Remarks

The property enables you to retrieve the data used for calculating the Y-coordinates of charts bound to the second Y-axis to numerical columns in a database. In bubble charts, this data is used for calculating the radiuses of the bubbles.

The data source object is specified with the DataSource property. If it is of type DataSet you can use the DataMember property to specify a given table as source for the chart data. In this case the fields of the table appear as items in the drop down combo box in the Y2DataFields property of the chart control. If you want to add more than one table field as data for the chart you should separate the names with commas.

The Y2DataFields property, when populated with data, is the same as the Y2Data property.

Default value for the Y2DataFields property is an empty string ("").

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.Y2GridLabels Property

AxesChart.Y2GridLabels Property

Gets or sets the labels for the second y-axis in a custom grid with horizontal stripes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList Y2GridLabels { get; set; }
Visual Basic

Public Property Y2GridLabels As IList

Property Value

An instance of type .NET IList that holds the labels.

Remarks

Y2GridLabels are drawn when the GridType is GridType.Custom, the HorGridPoints and Y2Data properties are not empty lists. The labels are drawn at grid lines or in the middle of the grid segments as stated by the GridLabelsAtLines property.

Default value of Y2GridLabels is an empty IList.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.Y2GridLabelsOrientation Property

AxesChart.Y2GridLabelsOrientation Property

Gets or sets the orientation for labels drawn at the second y-axis in a custom grid with horizontal stripes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public LabelOrientation Y2GridLabelsOrientation { get; set; }
Visual Basic

Public Property Y2GridLabelsOrientation As LabelOrientation

Property Value

One of the LabelOrientation Enumeration values.

Remarks

Grid labels at the Y2-axis are drawn when the GridType is GridType.Custom, HorGridPoints and Y2Data are not empty lists. The labels are set with Y2GridLabels. Their position depends on the value of the GridLabelsAtLines property.

Default value of Y2GridLabelsOrientation is LabelOrientation.InRow.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.Y2Labels Property

AxesChart.Y2Labels Property

Gets or sets custom labels for the second Y-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList Y2Labels { get; set; }
Visual Basic

Public Property Y2Labels As IList

Property Value

An instance of type .NET IList that holds other lists with the labels.

Remarks

Custom labels are drawn when the Y2AxisSettings.LabelType property is set to AxisLabelType.CustomText. Second Y-axis is drawn when the Y2Data property is not an empty list.

When there are more than one series of Y2Data, the labels are drawn in column. The distance between the columns is set with Y2AxisSettings.LabelSpan. The offset of the first label column to the Y2-axis is set with Y2AxisSettings.LabelOffset.

The labels can be of any data type - numbers, strings and so on. The control converts automatically the data into strings. The labels are drawn with the LabelBrush; the font is set with LabelFont.

Default value for the Y2Labels property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.Y2LabelsFields Property

AxesChart.Y2LabelsFields Property

Gets or sets the database columns, from which custom labels for the second y-axis are retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string Y2LabelsFields { get; set; }
Visual Basic

Public Property Y2LabelsFields As String

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.YAxisSettings Property

AxesChart.YAxisSettings Property

Gets or sets the appearance settings for the y-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public AxisSettings YAxisSettings { get; set; }
Visual Basic

Public Property YAxisSettings As AxisSettings

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.YGridLabels Property

AxesChart.YGridLabels Property

Gets or sets the labels drawn at the y-axis in a custom grid with horizontal stripes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList YGridLabels { get; set; }
Visual Basic

Public Property YGridLabels As IList

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.YGridLabelsOrientation Property

AxesChart.YGridLabelsOrientation Property

Gets or sets the orientation of labels drawn at the y-axis in a custom grid with horizontal stripes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public LabelOrientation YGridLabelsOrientation { get; set; }
Visual Basic

Public Property YGridLabelsOrientation As LabelOrientation

Property Value

One of the LabelOrientation Enumeration values.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.YLabels Property

AxesChart.YLabels Property

Gets or sets custom labels for the y-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList YLabels { get; set; }
Visual Basic

Public Property YLabels As IList

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.YLabelsFields Property

AxesChart.YLabelsFields Property

Gets or sets the database columns, from which custom labels for the y-axis are retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string YLabelsFields { get; set; }
Visual Basic

Public Property YLabelsFields As String

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart Class

BarChart Class

Represents a report item that can display bar charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class BarChart : AxesChart, IVirtualPropertyProvider
Visual Basic

Public Class BarChart
Inherits AxesChart
Implements IVirtualPropertyProvider

Example

BarChart inherits properties and methods from its base class AxesChart.

The class is used for drawing all types of bar charts - flat (2D charts) as well with 3D visual effect. The different bar types are listed as members of the BarType Enumeration. You can set the type of the bar chart with the BarType property. The Cylinder property enables you to draw the data as cylinders instead of bars.

The data for the bar chart is set with Data, which is used for calculating the height of the bars. The data can be numbers, or in any other format that can be parsed to numbers.

The orientation of the chart is set with the Horizontal property. The layout of bars in multiple series is set with BarSeriesLayout.

You can change the offset between the first bar and the beginning of the axis Offset. The distance between the bars - both horizontal and vertical - can be specified with DistBtwBars. BarWidth regulates the thickness of bars. Distance between bar series is specified with DistBtwSeries.

Bars can have labels inside and / or at the top. The type of the labels is set with InnerLabelType and TopLabelType. Custom labels are specified with InnerLabels and TopLabels. The position of the inner label inside the bar is set with InnerLabelAlignment.

Top labels can be rotated and drawn with offset from the edge of the bars as specified by the TopLabelRotAngle and TopLabelOffset properties. Use ClusterLabels if you want to draw a label at each cluster or group of bars.

The bar chart can be drawn with a grid, which type is set with the GridType property. The width of crossed grids is set with GridWidth. The grid can be drawn with stripes. The brushes for them are specified with GridBrush and AltGridBrush. Custom-set grid points are also possible.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Chart
MindFusion.Reporting.AxesChart
MindFusion.Reporting.BarChart

See Also

BarChart Members
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart Members

BarChart Members
Constructors Properties

Represents a report item that can display bar charts.

The following tables list the members exposed by the BarChart type.

Public Constructors

Name | Description
BarChart | Initializes a new instance of the BarChart class.

Public Properties

Name | Description
BarSeriesLayout | Gets or sets the layout of multi-series bars.
BarType | Gets or sets the type of bars.
BarWidth | Gets or sets the thickness of bars.
ClusterLabels | Gets or sets custom labels for bar clusters and groups.
Cylinder | Gets or sets a value indicating whether bars are drawn as cylinders.
CylinderTension | Gets or sets the tension of the cylinder.
Data | Gets or sets the data for the chart, when not retrieved from a database.
DataFields | Gets or sets the names of database columns, from which data for the chart is retrieved.
DistBtwBars | Gets or sets the distance between adjacent bars.
InnerLabelAlignment | Gets or sets the alignment of the inner label.
InnerLabels | Gets or sets custom text for the labels inside bars when not retrieved from a database.
InnerLabelsFields | Gets or sets the names of database columns, from which text for custom labels drawn inside bars is retrieved.
InnerLabelType | Gets or sets the type of labels drawn inside bars.
MultiColored | Gets or sets whether different parts of the same chart graphics are drawn with different chart brushes.
TopLabelOffset | Gets or sets the offset of the top label to the edge of the bar.
TopLabelRotAngle | Gets or sets the alignment of labels drawn at the top of bars.
TopLabels | Gets or sets custom text as top labels when not retrieved from a database.
TopLabelsFields | Gets or sets the names of database columns, from which text for custom labels drawn at the top of bars is retrieved.
TopLabelType | Gets or sets the type of labels drawn at the top of bars.

See Also

BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart Constructor

BarChart Constructor

Initializes a new instance of the BarChart class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BarChart ()
Visual Basic

Public Sub New ()

See Also

BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart Properties

BarChart Properties

Public Properties

Name | Description
BarSeriesLayout | Gets or sets the layout of multi-series bars.
BarType | Gets or sets the type of bars.
BarWidth | Gets or sets the thickness of bars.
ClusterLabels | Gets or sets custom labels for bar clusters and groups.
Cylinder | Gets or sets a value indicating whether bars are drawn as cylinders.
CylinderTension | Gets or sets the tension of the cylinder.
Data | Gets or sets the data for the chart, when not retrieved from a database.
DataFields | Gets or sets the names of database columns, from which data for the chart is retrieved.
DistBtwBars | Gets or sets the distance between adjacent bars.
InnerLabelAlignment | Gets or sets the alignment of the inner label.
InnerLabels | Gets or sets custom text for the labels inside bars when not retrieved from a database.
InnerLabelsFields | Gets or sets the names of database columns, from which text for custom labels drawn inside bars is retrieved.
InnerLabelType | Gets or sets the type of labels drawn inside bars.
MultiColored | Gets or sets whether different parts of the same chart graphics are drawn with different chart brushes.
TopLabelOffset | Gets or sets the offset of the top label to the edge of the bar.
TopLabelRotAngle | Gets or sets the alignment of labels drawn at the top of bars.
TopLabels | Gets or sets custom text as top labels when not retrieved from a database.
TopLabelsFields | Gets or sets the names of database columns, from which text for custom labels drawn at the top of bars is retrieved.
TopLabelType | Gets or sets the type of labels drawn at the top of bars.

See Also

BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.BarSeriesLayout Property

BarChart.BarSeriesLayout Property

Gets or sets the layout of multi-series bars.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BarSeriesLayout BarSeriesLayout { get; set; }
Visual Basic

Public Property BarSeriesLayout As BarSeriesLayout

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.BarType Property

BarChart.BarType Property

Gets or sets the type of bars.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BarType BarType { get; set; }
Visual Basic

Public Property BarType As BarType

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.BarWidth Property

BarChart.BarWidth Property

Gets or sets the thickness of bars.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float BarWidth { get; set; }
Visual Basic

Public Property BarWidth As Single

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.ClusterLabels Property

BarChart.ClusterLabels Property

Gets or sets custom labels for bar clusters and groups.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList ClusterLabels { get; set; }
Visual Basic

Public Property ClusterLabels As IList

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.Cylinder Property

BarChart.Cylinder Property

Gets or sets a value indicating whether bars are drawn as cylinders.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool Cylinder { get; set; }
Visual Basic

Public Property Cylinder As Boolean

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.CylinderTension Property

BarChart.CylinderTension Property

Gets or sets the tension of the cylinder.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public int CylinderTension { get; set; }
Visual Basic

Public Property CylinderTension As Integer

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.Data Property

BarChart.Data Property

Gets or sets the data for the chart, when not retrieved from a database.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList Data { get; set; }
Visual Basic

Public Property Data As IList

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.DataFields Property

BarChart.DataFields Property

Gets or sets the names of database columns, from which data for the chart is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string DataFields { get; set; }
Visual Basic

Public Property DataFields As String

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.DistBtwBars Property

BarChart.DistBtwBars Property

Gets or sets the distance between adjacent bars.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float DistBtwBars { get; set; }
Visual Basic

Public Property DistBtwBars As Single

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.InnerLabelAlignment Property

BarChart.InnerLabelAlignment Property

Gets or sets the alignment of the inner label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public StringAlignment InnerLabelAlignment { get; set; }
Visual Basic

Public Property InnerLabelAlignment As StringAlignment

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.InnerLabels Property

BarChart.InnerLabels Property

Gets or sets custom text for the labels inside bars when not retrieved from a database.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList InnerLabels { get; set; }
Visual Basic

Public Property InnerLabels As IList

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.InnerLabelsFields Property

BarChart.InnerLabelsFields Property

Gets or sets the names of database columns, from which text for custom labels drawn inside bars is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string InnerLabelsFields { get; set; }
Visual Basic

Public Property InnerLabelsFields As String

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.InnerLabelType Property

BarChart.InnerLabelType Property

Gets or sets the type of labels drawn inside bars.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public LabelType InnerLabelType { get; set; }
Visual Basic

Public Property InnerLabelType As LabelType

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.MultiColored Property

BarChart.MultiColored Property

Gets or sets whether different parts of the same chart graphics are drawn with different chart brushes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool MultiColored { get; set; }
Visual Basic

Public Property MultiColored As Boolean

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.TopLabelOffset Property

BarChart.TopLabelOffset Property

Gets or sets the offset of the top label to the edge of the bar.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float TopLabelOffset { get; set; }
Visual Basic

Public Property TopLabelOffset As Single

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.TopLabelRotAngle Property

BarChart.TopLabelRotAngle Property

Gets or sets the alignment of labels drawn at the top of bars.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float TopLabelRotAngle { get; set; }
Visual Basic

Public Property TopLabelRotAngle As Single

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.TopLabels Property

BarChart.TopLabels Property

Gets or sets custom text as top labels when not retrieved from a database.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList TopLabels { get; set; }
Visual Basic

Public Property TopLabels As IList

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.TopLabelsFields Property

BarChart.TopLabelsFields Property

Gets or sets the names of database columns, from which text for custom labels drawn at the top of bars is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string TopLabelsFields { get; set; }
Visual Basic

Public Property TopLabelsFields As String

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.TopLabelType Property

BarChart.TopLabelType Property

Gets or sets the type of labels drawn at the top of bars.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public LabelType TopLabelType { get; set; }
Visual Basic

Public Property TopLabelType As LabelType

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Class

Border Class
Remarks See Also

Defines a border around a report element.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public sealed class Border : ICloneable
Visual Basic

Public NotInheritable Class Border
Implements ICloneable

Remarks

The border class lets you define a border around certain report elements - in particular those that provide a Border property. You need to create an instance of this class and assign it to the Border property of the report element.

It is not necessary to specify all the sides of a Border object. For example, you can create a border, which has only a left side, or whose sides have different colors or widths.

The following example creates a simple black border and assigns it to a Label element:

C#

label1.Border = new Border(Color.Black, 0);

Visual Basic

Label1.Border = New Border(Color.Black, 0)

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Border

See Also

Border Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Members

Border Members
Constructors Properties Methods

Defines a border around a report element.

The following tables list the members exposed by the Border type.

Public Constructors

Name | Description
Border | Overloaded. Initializes a new instance of the Border class.

Public Properties

Name | Description
BottomAlignment | Gets or sets the alignment of the bottom border.
BottomColor | Gets or sets the color of the bottom border.
BottomDashStyle | Gets or sets the style of the bottom border.
BottomVisible | Gets or sets a value indicating whether the bottom border is visible.
BottomWidth | Gets or sets the width of the bottom border.
IsEmpty | Gets a value indicating whether the border is empty.
LeftAlignment | Gets or sets the alignment of the left border.
LeftColor | Gets or sets the color of the left border.
LeftDashStyle | Gets or sets the style of the left border.
LeftVisible | Gets or sets a value indicating whether the left border is visible.
LeftWidth | Gets or sets the width of the left border.
RightAlignment | Gets or sets the alignment of the right border.
RightColor | Gets or sets the color of the left border.
RightDashStyle | Gets or sets the style of the right border.
RightVisible | Gets or sets a value indicating whether the right border is visible.
RightWidth | Gets or sets the width of the right border.
TopAlignment | Gets or sets the alignment of the top border.
TopColor | Gets or sets the color of the top border.
TopDashStyle | Gets or sets the style of the top border.
TopVisible | Gets or sets a value indicating whether the top border is visible.
TopWidth | Gets or sets the width of the top border.

Public Methods

Name | Description
Clone | Creates an exact clone of this Border object.
MakeEmpty | Resets the border to be invisible.
ToString | Object.ToString override.

See Also

Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Constructor

Border Constructor

Initializes a new instance of the Border class.

Overload List

Name | Description
Border () | Initializes a new instance of the Border class.
Border (Color, Single) | Initializes a new instance of the Border class.
Border (Color, Single, PenAlignment) | Initializes a new instance of the Border class.

See Also

Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Constructor ()

Border Constructor ()
See Also

Initializes a new instance of the Border class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Border ()
Visual Basic

Public Sub New ()

See Also

Border Constructor Overload List
Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Constructor (Color, Single)

Border Constructor (Color, Single)
See Also

Initializes a new instance of the Border class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Border (
Color color,
float width
)
Visual Basic

Public New ( _
color As Color, _
width As Single _
)

Parameters

color
A .NET Color object that specifies the color of all four sides of the new border.
width
An integer value specifying the width of all four sides of the new border.

See Also

Border Constructor Overload List
Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Constructor (Color, Single, PenAlignment)

Border Constructor (Color, Single, PenAlignment)
See Also

Initializes a new instance of the Border class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Border (
Color color,
float width,
PenAlignment alignment
)
Visual Basic

Public New ( _
color As Color, _
width As Single, _
alignment As PenAlignment _
)

Parameters

color
A .NET Color object that specifies the color of all four sides of the new border.
width
An integer value specifying the width of all four sides of the new border.
alignment
A .NET PenAlignment value specifying the alignment of all four sides of the border.

See Also

Border Constructor Overload List
Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Methods

Border Methods

Public Methods

Name | Description
Clone | Creates an exact clone of this Border object.
MakeEmpty | Resets the border to be invisible.
ToString | Object.ToString override.

See Also

Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border.Clone Method

Border.Clone Method

Creates an exact clone of this Border object.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

An instance of the Border class.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border.MakeEmpty Method

Border.MakeEmpty Method

Resets the border to be invisible.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public void MakeEmpty ()
Visual Basic

Public Sub MakeEmpty ()

Remarks

Calling this method is equivalent to setting the visibility of each of the four border sides to false.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftVisible Property
TopVisible Property
RightVisible Property
BottomVisible Property


MindFusion.Reporting.Border.ToString Method

Border.ToString Method

Object.ToString override.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

See Also

Border Members
Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Properties

Border Properties

Public Properties

Name | Description
BottomAlignment | Gets or sets the alignment of the bottom border.
BottomColor | Gets or sets the color of the bottom border.
BottomDashStyle | Gets or sets the style of the bottom border.
BottomVisible | Gets or sets a value indicating whether the bottom border is visible.
BottomWidth | Gets or sets the width of the bottom border.
IsEmpty | Gets a value indicating whether the border is empty.
LeftAlignment | Gets or sets the alignment of the left border.
LeftColor | Gets or sets the color of the left border.
LeftDashStyle | Gets or sets the style of the left border.
LeftVisible | Gets or sets a value indicating whether the left border is visible.
LeftWidth | Gets or sets the width of the left border.
RightAlignment | Gets or sets the alignment of the right border.
RightColor | Gets or sets the color of the left border.
RightDashStyle | Gets or sets the style of the right border.
RightVisible | Gets or sets a value indicating whether the right border is visible.
RightWidth | Gets or sets the width of the right border.
TopAlignment | Gets or sets the alignment of the top border.
TopColor | Gets or sets the color of the top border.
TopDashStyle | Gets or sets the style of the top border.
TopVisible | Gets or sets a value indicating whether the top border is visible.
TopWidth | Gets or sets the width of the top border.

See Also

Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border.BottomAlignment Property

Border.BottomAlignment Property

Gets or sets the alignment of the bottom border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenAlignment BottomAlignment { get; set; }
Visual Basic

Public Property BottomAlignment As PenAlignment

Property Value

A member of the .NET PenAlignment enumeration that specifies the alignment of the bottom side of the border. The default is Center.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftAlignment Property
TopAlignment Property
RightAlignment Property


MindFusion.Reporting.Border.BottomColor Property

Border.BottomColor Property

Gets or sets the color of the bottom border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Color BottomColor { get; set; }
Visual Basic

Public Property BottomColor As Color

Property Value

A .NET Color object specifying the color of the bottom side of the border. The default is Color.Empty.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftColor Property
TopColor Property
RightColor Property


MindFusion.Reporting.Border.BottomDashStyle Property

Border.BottomDashStyle Property

Gets or sets the style of the bottom border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public DashStyle BottomDashStyle { get; set; }
Visual Basic

Public Property BottomDashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration that specifies the dash pattern of the bottom side of the border. The default is Solid.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftDashStyle Property
TopDashStyle Property
RightDashStyle Property


MindFusion.Reporting.Border.BottomVisible Property

Border.BottomVisible Property

Gets or sets a value indicating whether the bottom border is visible.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool BottomVisible { get; set; }
Visual Basic

Public Property BottomVisible As Boolean

Property Value

A boolean value specifying whether the bottom side of the border is visible. The default is false.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftVisible Property
TopVisible Property
RightVisible Property


MindFusion.Reporting.Border.BottomWidth Property

Border.BottomWidth Property

Gets or sets the width of the bottom border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float BottomWidth { get; set; }
Visual Basic

Public Property BottomWidth As Single

Property Value

An integer value specifying the width of the bottom side of the border. The default is 0.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftWidth Property
TopWidth Property
RightWidth Property


MindFusion.Reporting.Border.IsEmpty Property

Border.IsEmpty Property

Gets a value indicating whether the border is empty.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool IsEmpty { get; }
Visual Basic

Public ReadOnly Property IsEmpty As Boolean

Property Value

A boolean value specifying whether the border is empty.

Remarks

This property returns true for borders all sides of which are invisible, that is, LeftVisible, TopVisible, RightVisible and BottomVisible are all set to false. This property will still return false for borders that are not rendered because their sides have transparent colors for example.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftVisible Property
TopVisible Property
RightVisible Property
BottomVisible Property


MindFusion.Reporting.Border.LeftAlignment Property

Border.LeftAlignment Property

Gets or sets the alignment of the left border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenAlignment LeftAlignment { get; set; }
Visual Basic

Public Property LeftAlignment As PenAlignment

Property Value

A member of the .NET PenAlignment enumeration that specifies the alignment of the left side of the border. The default is Center.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
TopAlignment Property
RightAlignment Property
BottomAlignment Property


MindFusion.Reporting.Border.LeftColor Property

Border.LeftColor Property

Gets or sets the color of the left border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Color LeftColor { get; set; }
Visual Basic

Public Property LeftColor As Color

Property Value

A .NET Color object specifying the color of the left side of the border. The default is Color.Empty.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
TopColor Property
RightColor Property
BottomColor Property


MindFusion.Reporting.Border.LeftDashStyle Property

Border.LeftDashStyle Property

Gets or sets the style of the left border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public DashStyle LeftDashStyle { get; set; }
Visual Basic

Public Property LeftDashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration that specifies the dash pattern of the left side of the border. The default is Solid.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
TopDashStyle Property
RightDashStyle Property
BottomDashStyle Property


MindFusion.Reporting.Border.LeftVisible Property

Border.LeftVisible Property

Gets or sets a value indicating whether the left border is visible.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool LeftVisible { get; set; }
Visual Basic

Public Property LeftVisible As Boolean

Property Value

A boolean value specifying whether the left side of the border is visible. The default is false.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
TopVisible Property
RightVisible Property
BottomVisible Property


MindFusion.Reporting.Border.LeftWidth Property

Border.LeftWidth Property

Gets or sets the width of the left border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float LeftWidth { get; set; }
Visual Basic

Public Property LeftWidth As Single

Property Value

An integer value specifying the width of the left side of the border. The default is 0.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
TopWidth Property
RightWidth Property
BottomWidth Property


MindFusion.Reporting.Border.RightAlignment Property

Border.RightAlignment Property

Gets or sets the alignment of the right border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenAlignment RightAlignment { get; set; }
Visual Basic

Public Property RightAlignment As PenAlignment

Property Value

A member of the .NET PenAlignment enumeration that specifies the alignment of the right side of the border. The default is Center.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftAlignment Property
TopAlignment Property
BottomAlignment Property


MindFusion.Reporting.Border.RightColor Property

Border.RightColor Property

Gets or sets the color of the left border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Color RightColor { get; set; }
Visual Basic

Public Property RightColor As Color

Property Value

A .NET Color object specifying the color of the right side of the border. The default is Color.Empty.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftColor Property
TopColor Property
BottomColor Property


MindFusion.Reporting.Border.RightDashStyle Property

Border.RightDashStyle Property

Gets or sets the style of the right border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public DashStyle RightDashStyle { get; set; }
Visual Basic

Public Property RightDashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration that specifies the dash pattern of the right side of the border. The default is Solid.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftDashStyle Property
TopDashStyle Property
BottomDashStyle Property


MindFusion.Reporting.Border.RightVisible Property

Border.RightVisible Property

Gets or sets a value indicating whether the right border is visible.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool RightVisible { get; set; }
Visual Basic

Public Property RightVisible As Boolean

Property Value

A boolean value specifying whether the right side of the border is visible. The default is false.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftVisible Property
TopVisible Property
BottomVisible Property


MindFusion.Reporting.Border.RightWidth Property

Border.RightWidth Property

Gets or sets the width of the right border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float RightWidth { get; set; }
Visual Basic

Public Property RightWidth As Single

Property Value

An integer value specifying the width of the right side of the border. The default is 0.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftWidth Property
TopWidth Property
BottomWidth Property


MindFusion.Reporting.Border.TopAlignment Property

Border.TopAlignment Property

Gets or sets the alignment of the top border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenAlignment TopAlignment { get; set; }
Visual Basic

Public Property TopAlignment As PenAlignment

Property Value

A member of the .NET PenAlignment enumeration that specifies the alignment of the top side of the border. The default is Center.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftAlignment Property
RightAlignment Property
BottomAlignment Property


MindFusion.Reporting.Border.TopColor Property

Border.TopColor Property

Gets or sets the color of the top border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Color TopColor { get; set; }
Visual Basic

Public Property TopColor As Color

Property Value

A .NET Color object specifying the color of the top side of the border. The default is Color.Empty.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftColor Property
RightColor Property
BottomColor Property


MindFusion.Reporting.Border.TopDashStyle Property

Border.TopDashStyle Property

Gets or sets the style of the top border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public DashStyle TopDashStyle { get; set; }
Visual Basic

Public Property TopDashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration that specifies the dash pattern of the top side of the border. The default is Solid.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftDashStyle Property
RightDashStyle Property
BottomDashStyle Property


MindFusion.Reporting.Border.TopVisible Property

Border.TopVisible Property

Gets or sets a value indicating whether the top border is visible.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool TopVisible { get; set; }
Visual Basic

Public Property TopVisible As Boolean

Property Value

A boolean value specifying whether the top side of the border is visible. The default is false.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftVisible Property
RightVisible Property
BottomVisible Property


MindFusion.Reporting.Border.TopWidth Property

Border.TopWidth Property

Gets or sets the width of the top border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float TopWidth { get; set; }
Visual Basic

Public Property TopWidth As Single

Property Value

An integer value specifying the width of the right side of the border. The default is 0.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftWidth Property
RightWidth Property
BottomWidth Property


MindFusion.Reporting.Canvas Class

Canvas Class
Remarks See Also

Represents a report item that provides a way to render custom contents within the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class Canvas : ReportItem
Visual Basic

Public Class Canvas
Inherits ReportItem

Remarks

The Canvas element does not provide any visualization by default. In order to perform rendering through the Canvas, you need to handle its RenderContents event and place the custom drawing code in the event handler.

The following example illustrates how to render a rectangle using a Canvas object. The example assumes that canvas1 is a variable that references a valid Canvas instance.

C#

canvas1.RenderContents += new DrawCanvasEventHandler(this.OnDrawCanvas);

// ...

private void OnDrawCanvas(object sender, DrawCanvasEventArgs e)
{
// Render a black rectangle
e.Graphics.DrawRectangle(Pens.Black, e.Bounds);
}
Visual Basic

AddHandler(canvas1.RenderCanvas, AddressOf Me.OnDrawCanvas)

' ...

Private Sub OnDrawCanvas(ByRef sender As Object, ByRef e As DrawCanvasEventArgs)

' Render a black rectangle
e.Graphics.DrawRectangle(Pens.Black, e.Bounds)

End Sub

The Canvas element can be data-bound, similarly to a Label or a Picture. In this case, the value retrieved from the data source can be accessed through the DataValue property of the DrawCanvasEventArgs object passed to the RenderContents event handler. The type of this value depends on the type of the field the Canvas is data-bound to.

To learn more about data-binding, visit the Binding Reports to a Data Source.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Canvas

See Also

Canvas Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas Members

Canvas Members
Constructors Properties Methods Events

Represents a report item that provides a way to render custom contents within the report.

The following tables list the members exposed by the Canvas type.

Public Constructors

Name | Description
Canvas | Initializes a new instance of the Canvas class.

Public Properties

Name | Description
DataField | Gets or sets the name of the data field to bind to.

Protected Methods

Name | Description
OnRenderContents | Fires the RenderContents event.

Public Events

Name | Description
RenderContents | Raised to enable you to perform custom rendering within the canvas.

See Also

Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas Constructor

Canvas Constructor

Initializes a new instance of the Canvas class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Canvas ()
Visual Basic

Public Sub New ()

See Also

Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas Methods

Canvas Methods

Protected Methods

Name | Description
OnRenderContents | Fires the RenderContents event.

See Also

Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas.OnRenderContents Method

Canvas.OnRenderContents Method

Fires the RenderContents event.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

protected virtual void OnRenderContents (
DrawCanvasEventArgs e
)
Visual Basic

Protected Overridable Sub OnRenderContents ( _
e As DrawCanvasEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Canvas Members
Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas Properties

Canvas Properties

Public Properties

Name | Description
DataField | Gets or sets the name of the data field to bind to.

See Also

Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas.DataField Property

Canvas.DataField Property

Gets or sets the name of the data field to bind to.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string DataField { get; set; }
Visual Basic

Public Property DataField As String

Property Value

A string containing the name of the database field to bind the Canvas to.

Remarks

This property is valid only when the Canvas object is placed in a data-bound DataRange container. Otherwise the value of the property is ignored since the Canvas cannot obtain a data source to bind to.

See Also

Canvas Members
Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas Events

Canvas Events

Public Events

Name | Description
RenderContents | Raised to enable you to perform custom rendering within the canvas.

See Also

Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas.RenderContents Event

Canvas.RenderContents Event

Raised to enable you to perform custom rendering within the canvas.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public event EventHandler<DrawCanvasEventArgs> RenderContents
Visual Basic

Public Event RenderContents As EventHandler(Of DrawCanvasEventArgs)

Event Data

RenderContents event handlers receive an argument of type DrawCanvasEventArgs.

Example

The following example illustrates how to render a rectangle using a Canvas object. The example assumes that canvas1 is a variable that references a valid Canvas instance.

C#

canvas1.RenderContents += new DrawCanvasEventHandler(this.OnDrawCanvas);

// ...

private void OnDrawCanvas(object sender, DrawCanvasEventArgs e)
{
// Render a black rectangle
e.Graphics.DrawRectangle(Pens.Black, e.Bounds);
}
Visual Basic

AddHandler(canvas1.RenderCanvas, AddressOf Me.OnDrawCanvas)

' ...

Private Sub OnDrawCanvas(ByRef sender As Object, ByRef e As DrawCanvasEventArgs)

' Render a black rectangle
e.Graphics.DrawRectangle(Pens.Black, e.Bounds)

End Sub

See Also

Canvas Members
Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart Class

Chart Class

Base class for all charts in the report. Holds methods and properties common for all derived charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public abstract class Chart : ReportItem
Visual Basic

Public MustInherit Class Chart
Inherits ReportItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Chart
MindFusion.Reporting.AxesChart
MindFusion.Reporting.PieChart
MindFusion.Reporting.RadarChart

See Also

Chart Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart Members

Chart Members
Constructors Properties

Base class for all charts in the report. Holds methods and properties common for all derived charts.

The following tables list the members exposed by the Chart type.

Protected Constructors

Name | Description
Chart | Initializes a new instance of the Chart class.

Public Properties

Name | Description
BackgroundBrush | Gets or sets the brush that fills the chart background.
Border | Gets or sets the border of this chart.
ChartBrushes | Gets or sets the brushes for the chart.
ChartMargins | Gets or sets the margins of the chart.
ChartPens | Gets or sets the pens for the chart.
ChartSize | Gets the size of the chart.
DataMember | Gets or sets from which member in the data source data is read.
DataSource | Gets or sets the object, from which chart data is retrieved.
LabelBrush | Gets or sets the brush for the chart labels.
LabelFont | Gets or sets the font for the chart labels.
LegendAlignment | Gets or sets the alignment of the legend alongside the chart.
LegendBackgroundBrush | Gets or sets the brush for the legend background.
LegendBrush | Gets or sets the brush for drawing the legend labels.
LegendColumns | Gets or sets the count of columns with labels in the legend.
LegendFont | Gets or sets the font for the legend labels.
LegendGridType | Gets or sets the type of the legend grid.
LegendLabels | Gets or sets the legend labels.
LegendOffset | Gets or sets the offset of the legend to the axis labels.
LegendPen | Gets or sets the pen for the legend outlining and grid.
LegendPosition | Gets or sets the position of the legend.
LegendWidth | Gets or sets the width of the legend's bounding rectangle.
LegendWordWrap | Gets or sets the whether legend labels are wrapped.
MasterDetailRelation | Gets or sets the master detail relation.
MultiColored | Gets or sets whether different parts of the same chart graphics are drawn with different chart brushes.
MultiColoredLabels | Gets or sets whether labels are drawn with the brush of the series they refer to.
SortOrder | Gets or sets the sort order for the numbers in each data series.
SortSeriesBy | Gets or sets the sort order of data series in multi-series charts.
SubTitleBrush | Gets or sets the brush used for drawing the subtitle.
SubTitleFont | Gets or sets the font for the subtitle.
SubTitleText | Gets or sets the text for the subtitle.
TextRenderingHint | Gets or sets the quality of text rendering for the chart.
TitleBrush | Gets or sets the brush used for drawing the title.
TitleFont | Gets or sets the font for the title.
TitleText | Gets or sets the title text.

See Also

Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart Constructor

Chart Constructor

Initializes a new instance of the Chart class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

protected Chart ()
Visual Basic

Protected Sub New ()

See Also

Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart Properties

Chart Properties

Public Properties

Name | Description
BackgroundBrush | Gets or sets the brush that fills the chart background.
Border | Gets or sets the border of this chart.
ChartBrushes | Gets or sets the brushes for the chart.
ChartMargins | Gets or sets the margins of the chart.
ChartPens | Gets or sets the pens for the chart.
ChartSize | Gets the size of the chart.
DataMember | Gets or sets from which member in the data source data is read.
DataSource | Gets or sets the object, from which chart data is retrieved.
LabelBrush | Gets or sets the brush for the chart labels.
LabelFont | Gets or sets the font for the chart labels.
LegendAlignment | Gets or sets the alignment of the legend alongside the chart.
LegendBackgroundBrush | Gets or sets the brush for the legend background.
LegendBrush | Gets or sets the brush for drawing the legend labels.
LegendColumns | Gets or sets the count of columns with labels in the legend.
LegendFont | Gets or sets the font for the legend labels.
LegendGridType | Gets or sets the type of the legend grid.
LegendLabels | Gets or sets the legend labels.
LegendOffset | Gets or sets the offset of the legend to the axis labels.
LegendPen | Gets or sets the pen for the legend outlining and grid.
LegendPosition | Gets or sets the position of the legend.
LegendWidth | Gets or sets the width of the legend's bounding rectangle.
LegendWordWrap | Gets or sets the whether legend labels are wrapped.
MasterDetailRelation | Gets or sets the master detail relation.
MultiColored | Gets or sets whether different parts of the same chart graphics are drawn with different chart brushes.
MultiColoredLabels | Gets or sets whether labels are drawn with the brush of the series they refer to.
SortOrder | Gets or sets the sort order for the numbers in each data series.
SortSeriesBy | Gets or sets the sort order of data series in multi-series charts.
SubTitleBrush | Gets or sets the brush used for drawing the subtitle.
SubTitleFont | Gets or sets the font for the subtitle.
SubTitleText | Gets or sets the text for the subtitle.
TextRenderingHint | Gets or sets the quality of text rendering for the chart.
TitleBrush | Gets or sets the brush used for drawing the title.
TitleFont | Gets or sets the font for the title.
TitleText | Gets or sets the title text.

See Also

Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.BackgroundBrush Property

Chart.BackgroundBrush Property

Gets or sets the brush that fills the chart background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush BackgroundBrush { get; set; }
Visual Basic

Public Property BackgroundBrush As Brush

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.Border Property

Chart.Border Property

Gets or sets the border of this chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Border Border { get; set; }
Visual Basic

Public Property Border As Border

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.ChartBrushes Property

Chart.ChartBrushes Property

Gets or sets the brushes for the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BrushCollection ChartBrushes { get; set; }
Visual Basic

Public Property ChartBrushes As BrushCollection

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.ChartMargins Property

Chart.ChartMargins Property

Gets or sets the margins of the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Margins ChartMargins { get; set; }
Visual Basic

Public Property ChartMargins As Margins

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.ChartPens Property

Chart.ChartPens Property

Gets or sets the pens for the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenCollection ChartPens { get; set; }
Visual Basic

Public Property ChartPens As PenCollection

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.ChartSize Property

Chart.ChartSize Property

Gets the size of the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public SizeF ChartSize { get; }
Visual Basic

Public ReadOnly Property ChartSize As SizeF

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.DataMember Property

Chart.DataMember Property

Gets or sets from which member in the data source data is read.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string DataMember { get; set; }
Visual Basic

Public Property DataMember As String

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.DataSource Property

Chart.DataSource Property

Gets or sets the object, from which chart data is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Object DataSource { get; set; }
Visual Basic

Public Property DataSource As Object

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LabelBrush Property

Chart.LabelBrush Property

Gets or sets the brush for the chart labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush LabelBrush { get; set; }
Visual Basic

Public Property LabelBrush As Brush

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LabelFont Property

Chart.LabelFont Property

Gets or sets the font for the chart labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Font LabelFont { get; set; }
Visual Basic

Public Property LabelFont As Font

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendAlignment Property

Chart.LegendAlignment Property

Gets or sets the alignment of the legend alongside the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Alignment LegendAlignment { get; set; }
Visual Basic

Public Property LegendAlignment As Alignment

Property Value

One of the Alignment Enumeration values.

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendBackgroundBrush Property

Chart.LegendBackgroundBrush Property

Gets or sets the brush for the legend background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush LegendBackgroundBrush { get; set; }
Visual Basic

Public Property LegendBackgroundBrush As Brush

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendBrush Property

Chart.LegendBrush Property

Gets or sets the brush for drawing the legend labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush LegendBrush { get; set; }
Visual Basic

Public Property LegendBrush As Brush

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendColumns Property

Chart.LegendColumns Property

Gets or sets the count of columns with labels in the legend.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public int LegendColumns { get; set; }
Visual Basic

Public Property LegendColumns As Integer

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendFont Property

Chart.LegendFont Property

Gets or sets the font for the legend labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Font LegendFont { get; set; }
Visual Basic

Public Property LegendFont As Font

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendGridType Property

Chart.LegendGridType Property

Gets or sets the type of the legend grid.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public GridType LegendGridType { get; set; }
Visual Basic

Public Property LegendGridType As GridType

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendLabels Property

Chart.LegendLabels Property

Gets or sets the legend labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList LegendLabels { get; set; }
Visual Basic

Public Property LegendLabels As IList

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendOffset Property

Chart.LegendOffset Property

Gets or sets the offset of the legend to the axis labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float LegendOffset { get; set; }
Visual Basic

Public Property LegendOffset As Single

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendPen Property

Chart.LegendPen Property

Gets or sets the pen for the legend outlining and grid.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Pen LegendPen { get; set; }
Visual Basic

Public Property LegendPen As Pen

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendPosition Property

Chart.LegendPosition Property

Gets or sets the position of the legend.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Position LegendPosition { get; set; }
Visual Basic

Public Property LegendPosition As Position

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendWidth Property

Chart.LegendWidth Property

Gets or sets the width of the legend's bounding rectangle.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float LegendWidth { get; set; }
Visual Basic

Public Property LegendWidth As Single

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendWordWrap Property

Chart.LegendWordWrap Property

Gets or sets the whether legend labels are wrapped.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool LegendWordWrap { get; set; }
Visual Basic

Public Property LegendWordWrap As Boolean

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.MasterDetailRelation Property

Chart.MasterDetailRelation Property

Gets or sets the master detail relation.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string MasterDetailRelation { get; set; }
Visual Basic

Public Property MasterDetailRelation As String

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.MultiColored Property

Chart.MultiColored Property

Gets or sets whether different parts of the same chart graphics are drawn with different chart brushes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool MultiColored { get; set; }
Visual Basic

Public Property MultiColored As Boolean

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.MultiColoredLabels Property

Chart.MultiColoredLabels Property

Gets or sets whether labels are drawn with the brush of the series they refer to.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool MultiColoredLabels { get; set; }
Visual Basic

Public Property MultiColoredLabels As Boolean

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.SortOrder Property

Chart.SortOrder Property

Gets or sets the sort order for the numbers in each data series.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public SortOrder SortOrder { get; set; }
Visual Basic

Public Property SortOrder As SortOrder

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.SortSeriesBy Property

Chart.SortSeriesBy Property

Gets or sets the sort order of data series in multi-series charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public SortSeriesBy SortSeriesBy { get; set; }
Visual Basic

Public Property SortSeriesBy As SortSeriesBy

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.SubTitleBrush Property

Chart.SubTitleBrush Property

Gets or sets the brush used for drawing the subtitle.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush SubTitleBrush { get; set; }
Visual Basic

Public Property SubTitleBrush As Brush

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.SubTitleFont Property

Chart.SubTitleFont Property

Gets or sets the font for the subtitle.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Font SubTitleFont { get; set; }
Visual Basic

Public Property SubTitleFont As Font

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.SubTitleText Property

Chart.SubTitleText Property

Gets or sets the text for the subtitle.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string SubTitleText { get; set; }
Visual Basic

Public Property SubTitleText As String

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.TextRenderingHint Property

Chart.TextRenderingHint Property

Gets or sets the quality of text rendering for the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public TextRenderingHint TextRenderingHint { get; set; }
Visual Basic

Public Property TextRenderingHint As TextRenderingHint

Property Value

A value of type System.DrawingText.TextRenderingHint.

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.TitleBrush Property

Chart.TitleBrush Property

Gets or sets the brush used for drawing the title.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush TitleBrush { get; set; }
Visual Basic

Public Property TitleBrush As Brush

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.TitleFont Property

Chart.TitleFont Property

Gets or sets the font for the title.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Font TitleFont { get; set; }
Visual Basic

Public Property TitleFont As Font

Property Value

A value of type .NET Font class.

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.TitleText Property

Chart.TitleText Property

Gets or sets the title text.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string TitleText { get; set; }
Visual Basic

Public Property TitleText As String

Property Value

A string value.

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper Class

ControlWrapper Class
Remarks See Also

Represents a wrapper around a System.Windows.Forms.Control that can be added and rendered in a MindFusion.Reporting.Report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class ControlWrapper : ReportItem
Visual Basic

Public Class ControlWrapper
Inherits ReportItem

Remarks

The ControlWrapper class provides means to render any System.Windows.Forms.Control in a MindFusion.Reporting report. Instances of this class are automatically created when the user drags a control from the Visual Studio Toolbox palette to the report surface.

The ControlWrapper class relies on the DrawBitmap method of the Control class in order to render the contents of the control to an image. If the underlying control fails to render itself through this method, the control wrapper will not display anything. Because the wrapper class creates an image of the control, rendering in higher resolution devices (such as printers) might suffer from a loss of quality.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.ControlWrapper

See Also

ControlWrapper Members
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper Members

ControlWrapper Members
Constructors Properties

Represents a wrapper around a System.Windows.Forms.Control that can be added and rendered in a MindFusion.Reporting.Report.

The following tables list the members exposed by the ControlWrapper type.

Public Constructors

Name | Description
ControlWrapper | Initializes a new instance of the ControlWrapper class.

Public Properties

Name | Description
Border | Gets or sets the border of this picture.
Control | Gets or sets the System.Windows.Forms.Control wrapped by this instance.
ScaleDimensions | Gets or sets the design-time scale factor of the control.

See Also

ControlWrapper Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper Constructor

ControlWrapper Constructor

Initializes a new instance of the ControlWrapper class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public ControlWrapper ()
Visual Basic

Public Sub New ()

See Also

ControlWrapper Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper Properties

ControlWrapper Properties

Public Properties

Name | Description
Border | Gets or sets the border of this picture.
Control | Gets or sets the System.Windows.Forms.Control wrapped by this instance.
ScaleDimensions | Gets or sets the design-time scale factor of the control.

See Also

ControlWrapper Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper.Border Property

ControlWrapper.Border Property

Gets or sets the border of this picture.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Border Border { get; set; }
Visual Basic

Public Property Border As Border

Property Value

An instance of the Border class specifying the border around the object.

See Also

ControlWrapper Members
ControlWrapper Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper.Control Property

ControlWrapper.Control Property

Gets or sets the System.Windows.Forms.Control wrapped by this instance.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Control Control { get; set; }
Visual Basic

Public Property Control As Control

Property Value

A .NET System.Windows.Forms.Control instance representing the wrapped control.

See Also

ControlWrapper Members
ControlWrapper Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper.ScaleDimensions Property

ControlWrapper.ScaleDimensions Property

Gets or sets the design-time scale factor of the control.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public SizeF ScaleDimensions { get; set; }
Visual Basic

Public Property ScaleDimensions As SizeF

Property Value

A .NET SizeF object specifying the ratio between the device dimensions of the wrapped control and the size of the control on the design surface.

Remarks

This property is not meant to be used directly.

See Also

ControlWrapper Members
ControlWrapper Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange Class

DataRange Class
Remarks See Also

Represents a report item that provides master detail relation during data-binding.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class DataRange : ReportItem, IItemFactory
Visual Basic

Public Class DataRange
Inherits ReportItem
Implements IItemFactory

Remarks

If you want to bind Label, Picture or Canvas objects to a data source, you need to create an object of the DataRange class first and set its DataSource and DataMember properties to the appropriate values. Once this is done, you can add Label, Picture and Canvas objects to this DataRange (as well as any other non-bound report elements) and set their DataField property to the name of the field in the associated data source you want to bind them to. When the report is being processed, a new instance of the DataRange is created for each record in the associated data source. Then the values of the data-bound report elements contained in this data range are obtained from the respective fields in that record.

For more information on data-binding, check the Binding Reports to a Data Source.

Example

The following example illustrates how to data-bind a Label report element through code. The example assumes that dataRange1 and label1 already reference DataRange and Label objects respectively, and that label1 is a child of dataRange1.

C#

dataRange1.DataSource = myDataSource;
dataRange1.DataMember = "MyDataMember";

label1.DataField = "MyDataField";
Visual Basic

dataRange1.DataSource = myDataSource
dataRange1.DataMember = "MyDataMember"

label1.DataField = "MyDataField"

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.DataRange

See Also

DataRange Members
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange Members

DataRange Members
Constructors Properties

Represents a report item that provides master detail relation during data-binding.

The following tables list the members exposed by the DataRange type.

Public Constructors

Name | Description
DataRange | Initializes a new instance of the DataRange class.

Public Properties

Name | Description
AllowSplit | Gets or sets a value indicating whether this data range contents are allowed to split across several pages.
AlternatingBackground | Gets or sets the brush that will be used to fill the background of the alternating instances of this data range.
AlternatingBorder | Gets or sets the alternating border of this data range.
ArrangeByX | Gets or sets a value indicating whether to attempt to arrange the instances of this data range by the x-axis first.
Background | Gets or sets the brush that will be used to fill the data range background.
Border | Gets or sets the border of this data range.
DataMember | Gets or sets the name of the data member this range is bound to.
DataSource | Gets or sets the data source this range is bound to.
Footer | Gets or sets the footer of this data range.
Header | Gets or sets the header of this data range.
Items | Gets or sets the items contained in the DataRange.
Margin | Gets or sets the margin of this data range, that is, the distance between the edge of this data range and the report elements adjacent to it.
MasterDetailRelation | Gets or sets the master detail relation.
Repeat | Gets or sets the number of occurrences of this data range.

See Also

DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange Constructor

DataRange Constructor

Initializes a new instance of the DataRange class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public DataRange ()
Visual Basic

Public Sub New ()

See Also

DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange Properties

DataRange Properties

Public Properties

Name | Description
AllowSplit | Gets or sets a value indicating whether this data range contents are allowed to split across several pages.
AlternatingBackground | Gets or sets the brush that will be used to fill the background of the alternating instances of this data range.
AlternatingBorder | Gets or sets the alternating border of this data range.
ArrangeByX | Gets or sets a value indicating whether to attempt to arrange the instances of this data range by the x-axis first.
Background | Gets or sets the brush that will be used to fill the data range background.
Border | Gets or sets the border of this data range.
DataMember | Gets or sets the name of the data member this range is bound to.
DataSource | Gets or sets the data source this range is bound to.
Footer | Gets or sets the footer of this data range.
Header | Gets or sets the header of this data range.
Items | Gets or sets the items contained in the DataRange.
Margin | Gets or sets the margin of this data range, that is, the distance between the edge of this data range and the report elements adjacent to it.
MasterDetailRelation | Gets or sets the master detail relation.
Repeat | Gets or sets the number of occurrences of this data range.

See Also

DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange.AllowSplit Property

DataRange.AllowSplit Property

Gets or sets a value indicating whether this data range contents are allowed to split across several pages.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool AllowSplit { get; set; }
Visual Basic

Public Property AllowSplit As Boolean

Property Value

true, to enable splitting of this DataRange across pages; false, to attempt to prevent this. The default is true.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange.AlternatingBackground Property

DataRange.AlternatingBackground Property

Gets or sets the brush that will be used to fill the background of the alternating instances of this data range.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush AlternatingBackground { get; set; }
Visual Basic

Public Property AlternatingBackground As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic).

Remarks

The value of this property determines the background of all even instances of this DataRange. If the property value is null (Nothing in Visual Basic), the background of even instances is determined by the Background property.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
Background Property
AlternatingBorder Property


MindFusion.Reporting.DataRange.AlternatingBorder Property

DataRange.AlternatingBorder Property

Gets or sets the alternating border of this data range.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Border AlternatingBorder { get; set; }
Visual Basic

Public Property AlternatingBorder As Border

Property Value

An instance of the Border class. The default is null (Nothing in Visual Basic).

Remarks

The value of this property determines the border of all even instances of this DataRange. If the property value is null (Nothing in Visual Basic), the border of even instances is determined by the Border property.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
Border Property
AlternatingBackground Property


MindFusion.Reporting.DataRange.ArrangeByX Property

DataRange.ArrangeByX Property

Gets or sets a value indicating whether to attempt to arrange the instances of this data range by the x-axis first.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool ArrangeByX { get; set; }
Visual Basic

Public Property ArrangeByX As Boolean

Property Value

true, to attempt to arrange the instances of this DataRange horizontally first; otherwise, false. The default is false.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange.Background Property

DataRange.Background Property

Gets or sets the brush that will be used to fill the data range background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush Background { get; set; }
Visual Basic

Public Property Background As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic), indicating a transparent background.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
AlternatingBackground Property


MindFusion.Reporting.DataRange.Border Property

DataRange.Border Property

Gets or sets the border of this data range.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Border Border { get; set; }
Visual Basic

Public Property Border As Border

Property Value

An instance of the Border class. The default is an empty border.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
AlternatingBorder Property


MindFusion.Reporting.DataRange.DataMember Property

DataRange.DataMember Property

Gets or sets the name of the data member this range is bound to.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string DataMember { get; set; }
Visual Basic

Public Property DataMember As String

Property Value

A string value specifying the name of the data member from the associated data source. The default is an empty string.

Remarks

This property is taken into consideration only when DataSource is specified.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
DataSource Property


MindFusion.Reporting.DataRange.DataSource Property

DataRange.DataSource Property

Gets or sets the data source this range is bound to.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Object DataSource { get; set; }
Visual Basic

Public Property DataSource As Object

Property Value

An object specifying the data source this DataRange is bound to. The default is null (Nothing in Visual Basic), indicating a disconnected data range.

Remarks

The member this data range binds to is specified through the DataMember property.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
DataMember Property


MindFusion.Reporting.DataRange.Footer Property

DataRange.Footer Property

Gets or sets the footer of this data range.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public DataRangeSection Footer { get; set; }
Visual Basic

Public Property Footer As DataRangeSection

Property Value

An instance of the DataRangeSection class representing the footer of this DataRange.

Remarks

You can add items to the footer through its Items property.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
Header Property


MindFusion.Reporting.DataRange.Header Property

DataRange.Header Property

Gets or sets the header of this data range.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public DataRangeSection Header { get; set; }
Visual Basic

Public Property Header As DataRangeSection

Property Value

An instance of the DataRangeSection class representing the header of this DataRange.

Remarks

You can add items to the header through its Items property.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
Footer Property


MindFusion.Reporting.DataRange.Items Property

DataRange.Items Property

Gets or sets the items contained in the DataRange.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList<ReportItem> Items { get; set; }
Visual Basic

Public Property Items As IList(Of ReportItem)

Property Value

An instance of a IList(ReportItem) class with the report items contained in the DataRange.

Remarks

This collection does not include the items contained in the header or footer of the data range. To access these, use the Items property of the DataRangeSection object returned from the Header or Footer property of the data range respectively.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange.Margin Property

DataRange.Margin Property

Gets or sets the margin of this data range, that is, the distance between the edge of this data range and the report elements adjacent to it.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Margins Margin { get; set; }
Visual Basic

Public Property Margin As Margins

Property Value

An instance of the Margins class. The default is a Margins object with all sides set to 0.

Remarks

This property is particularly useful when you want to specify spacing between the adjacent instances of a DataRange.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange.MasterDetailRelation Property

DataRange.MasterDetailRelation Property

Gets or sets the master detail relation.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string MasterDetailRelation { get; set; }
Visual Basic

Public Property MasterDetailRelation As String

Property Value

A string value specifying the name of the master detail relationship. The default is an empty string.

Remarks

This property is used to establish a master detail relationship between embedded data ranges. For extensive information on how to perform data-binding and master detail relations in particular, visit Binding Reports to a Data Source.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange.Repeat Property

DataRange.Repeat Property

Gets or sets the number of occurrences of this data range.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public int Repeat { get; set; }
Visual Basic

Public Property Repeat As Integer

Property Value

A positive integer value specifying the number of occurrences.

Remarks

This property is only valid for disconnected data ranges. It specifies the number of instances of this data range in the final layout of the containing report.

Note

The number of instances of data-bound data ranges depends on the data the data range is bound to.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRangeSection Class

DataRangeSection Class
Remarks See Also

Represents a data range header or footer.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class DataRangeSection : ItemContainer
Visual Basic

Public Class DataRangeSection
Inherits ItemContainer

Remarks

When working with the MindFusion.Reporting Designer you don't have to worry about creating instances of this class and assigning them to the appropriate DataRange properties.

If you want to create a header or footer for a DataRange object through code, you have to instantiate from this class and assign the instance to the Header or Footer property of the DataRange object respectively. You can add items to the header or footer through its Items property.

Example

The following example demonstrates how to create a header for an existing DataRange object:

C#

DataRangeSection header = new DataRangeSection();

Label headerLabel = new Label();
headerLabel.Text = "Header Text";

header.Items.Add(headerLabel);

dataRange1.Header = header;
Visual Basic

Dim header As New DataRangeSection()

Dim headerLabel As New Label()
headerLabel.Text = "Header Text"

header.Items.Add(headerLabel)

dataRange1.Header = header

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.ItemContainer
MindFusion.Reporting.DataRangeSection

See Also

DataRangeSection Members
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRangeSection Members

DataRangeSection Members
Constructors

Represents a data range header or footer.

The following tables list the members exposed by the DataRangeSection type.

Public Constructors

Name | Description
DataRangeSection | Initializes a new instance of the DataRangeSection class.

See Also

DataRangeSection Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRangeSection Constructor

DataRangeSection Constructor

Initializes a new instance of the DataRangeSection class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public DataRangeSection ()
Visual Basic

Public Sub New ()

See Also

DataRangeSection Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Structure

Dimension Structure

Stores an ordered pair of floating-point numbers, typically the width and height of an object.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public struct Dimension
Visual Basic

Public Structure Dimension

See Also

Dimension Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Members

Dimension Members
Constructors Fields Properties Methods

Stores an ordered pair of floating-point numbers, typically the width and height of an object.

The following tables list the members exposed by the Dimension type.

Public Constructors

Name | Description
Dimension | Overloaded. Initializes a new instance of the Dimension stucture.

Public Fields

Name | Description
Empty | An empty instance of the Dimension structure.

Public Properties

Name | Description
Height | Gets or sets the vertical component of this Dimension.
HeightUnit | Gets or sets the vertical units of measure of this Dimension.
IsEmpty | Gets a value indicating whether this Dimension has zero width and height.
Width | Gets or sets the horizontal component of this Dimension.
WidthUnit | Gets or sets the horizontal units of measure of this Dimension.

Public Methods

Name | Description
Add | Adds the width and height of one Dimension structure to the width and height of another Dimension structure.
Equals | Determines if two Dimension structures have the same height and width.
GetHashCode | Returns a hash code for this Dimension structure.
Subtract | Subtracts the width and height of one Dimension structure from the width and height of another Dimensions structure.
ToLocation | Converts this Dimension to a Location.
ToString | Creates a human-readable string that represents this Dimension.

See Also

Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Fields

Dimension Fields

Public Fields

Name | Description
Empty | An empty instance of the Dimension structure.

See Also

Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.Empty Field

Dimension.Empty Field

An empty instance of the Dimension structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public static readonly Dimension Empty
Visual Basic

Public Shared ReadOnly Empty As Dimension

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Constructor

Dimension Constructor

Initializes a new instance of the Dimension stucture.

Overload List

Name | Description
Dimension (Dimension) | Initializes a new instance of the Dimension structure from the specified Dimension.
Dimension (Location) | Initializes a new instance of the Dimension structure from the specified Location.
Dimension (Single, MeasureUnit, Single, MeasureUnit) | Initializes a new instance of the Dimension structure.
Dimension (Single, Single) | Initializes a new instance of the Dimension structure with the specified width and height.

See Also

Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Constructor (Dimension)

Dimension Constructor (Dimension)
See Also

Initializes a new instance of the Dimension structure from the specified Dimension.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Dimension (
Dimension size
)
Visual Basic

Public New ( _
size As Dimension _
)

Parameters

size

The Dimension from which to initialize the new object.

See Also

Dimension Constructor Overload List
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Constructor (Location)

Dimension Constructor (Location)
See Also

Initializes a new instance of the Dimension structure from the specified Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Dimension (
Location location
)
Visual Basic

Public New ( _
location As Location _
)

Parameters

location
The Location from which to initialize the new object.

See Also

Dimension Constructor Overload List
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Constructor (Single, MeasureUnit, Single, MeasureUnit)

Dimension Constructor (Single, MeasureUnit, Single, MeasureUnit)
See Also

Initializes a new instance of the Dimension structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Dimension (
float width,
MeasureUnit widthUnit,
float height,
MeasureUnit heightUnit
)
Visual Basic

Public New ( _
width As Single, _
widthUnit As MeasureUnit, _
height As Single, _
heightUnit As MeasureUnit _
)

Parameters

width
The width component of the new Dimension.
widthUnit
The width unit component of the new Dimension.
height
The height component of the new Dimension.
heightUnit
The height unit component of the new Dimension.

See Also

Dimension Constructor Overload List
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Constructor (Single, Single)

Dimension Constructor (Single, Single)
See Also

Initializes a new instance of the Dimension structure with the specified width and height.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Dimension (
float width,
float height
)
Visual Basic

Public New ( _
width As Single, _
height As Single _
)

Parameters

width
The width component of the new Dimension.
height
The height component of the new Dimension.

See Also

Dimension Constructor Overload List
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Methods

Dimension Methods

Public Methods

Name | Description
Add | Adds the width and height of one Dimension structure to the width and height of another Dimension structure.
Equals | Determines if two Dimension structures have the same height and width.
GetHashCode | Returns a hash code for this Dimension structure.
Subtract | Subtracts the width and height of one Dimension structure from the width and height of another Dimensions structure.
ToLocation | Converts this Dimension to a Location.
ToString | Creates a human-readable string that represents this Dimension.

See Also

Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.Add Method

Dimension.Add Method

Adds the width and height of one Dimension structure to the width and height of another Dimension structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public static Dimension Add (
Dimension dimension1,
Dimension dimension2
)
Visual Basic

Public Shared Function Add ( _
dimension1 As Dimension, _
dimension2 As Dimension _
) As Dimension

Parameters

dimension1
The first Dimension to add.
dimension2
The second Dimension to add.

Return Value

A Dimension structure that is the result of the addition operation. The WidthUnit and HeightUnit of the result are both set to Document.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.Equals Method

Dimension.Equals Method

Determines if two Dimension structures have the same height and width.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public override bool Equals (
Object obj
)
Visual Basic

Public Overrides Function Equals ( _
obj As Object _
) As Boolean

Parameters

obj
The System.Object to test.

Return Value

true if obj is a Dimension and has the same width, height and units as this Dimension; otherwise, false.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.GetHashCode Method

Dimension.GetHashCode Method

Returns a hash code for this Dimension structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public override int GetHashCode ()
Visual Basic

Public Overrides Function GetHashCode () As Integer

Return Value

An integer value that specifies a hash value for this Dimension structure.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.Subtract Method

Dimension.Subtract Method

Subtracts the width and height of one Dimension structure from the width and height of another Dimensions structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public static Dimension Subtract (
Dimension dimension1,
Dimension dimension2
)
Visual Basic

Public Shared Function Subtract ( _
dimension1 As Dimension, _
dimension2 As Dimension _
) As Dimension

Parameters

dimension1
The Dimension structure on the left side of the subtraction operator.
dimension2
The Dimension structure on the right side of the subtraction operator.

Return Value

The Dimension that is a result of the subtraction operation. The WidthUnit and HeightUnit of the result are both set to Document.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.ToLocation Method

Dimension.ToLocation Method

Converts this Dimension to a Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Location ToLocation ()
Visual Basic

Public Function ToLocation () As Location

Return Value

An instance of the Location structure to which this Dimension converts.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.ToString Method

Dimension.ToString Method

Creates a human-readable string that represents this Dimension.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string that represents this Dimension.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Properties

Dimension Properties

Public Properties

Name | Description
Height | Gets or sets the vertical component of this Dimension.
HeightUnit | Gets or sets the vertical units of measure of this Dimension.
IsEmpty | Gets a value indicating whether this Dimension has zero width and height.
Width | Gets or sets the horizontal component of this Dimension.
WidthUnit | Gets or sets the horizontal units of measure of this Dimension.

See Also

Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.Height Property

Dimension.Height Property

Gets or sets the vertical component of this Dimension.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float Height { get; set; }
Visual Basic

Public Property Height As Single

Property Value

A float number specifying the vertical component of the Dimension, in the units of measure specified by HeightUnit.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace
HeightUnit Property
Width Property


MindFusion.Reporting.Dimension.HeightUnit Property

Dimension.HeightUnit Property

Gets or sets the vertical units of measure of this Dimension.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public MeasureUnit HeightUnit { get; set; }
Visual Basic

Public Property HeightUnit As MeasureUnit

Property Value

A member of the MeasureUnit enumeration specifying the units of measure of the Height component of this Dimension.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace
WidthUnit Property
Height Property


MindFusion.Reporting.Dimension.IsEmpty Property

Dimension.IsEmpty Property

Gets a value indicating whether this Dimension has zero width and height.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool IsEmpty { get; }
Visual Basic

Public ReadOnly Property IsEmpty As Boolean

Property Value

true if both Width and Height of the Dimension are 0; otherwise, false.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.Width Property

Dimension.Width Property

Gets or sets the horizontal component of this Dimension.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float Width { get; set; }
Visual Basic

Public Property Width As Single

Property Value

A float number specifying the horizontal component of the Dimension, in the units of measure specified by WidthUnit.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace
WidthUnit Property
Height Property


MindFusion.Reporting.Dimension.WidthUnit Property

Dimension.WidthUnit Property

Gets or sets the horizontal units of measure of this Dimension.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public MeasureUnit WidthUnit { get; set; }
Visual Basic

Public Property WidthUnit As MeasureUnit

Property Value

A member of the MeasureUnit enumeration specifying the units of measure of the Width component of this Dimension.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace
HeightUnit Property
Width Property


MindFusion.Reporting.DrawCanvasEventArgs Class

DrawCanvasEventArgs Class
Remarks See Also

Contains the arguments passed to handlers of the RenderContents event of the Canvas class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class DrawCanvasEventArgs : DrawEventArgs
Visual Basic

Public Class DrawCanvasEventArgs
Inherits DrawEventArgs

Remarks

The DrawCanvasEventArgs class exposes several properties, which provide contextual information when rendering Canvas objects, in addition to the Graphics property derived from the DrawEventArgs class. The DataValue property supplies the database value associated with the drawn Canvas, if the canvas is data-bound. PageIndex and PageCount specify the current index and total number of pages in the report. RangeIndex and RangeCount specify the current index and total number of data range instances, if the Canvas is contained in a DataRange.

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Reporting.DrawEventArgs
MindFusion.Reporting.DrawCanvasEventArgs

See Also

DrawCanvasEventArgs Members
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs Members

DrawCanvasEventArgs Members
Properties

Contains the arguments passed to handlers of the RenderContents event of the Canvas class.

The following tables list the members exposed by the DrawCanvasEventArgs type.

Public Properties

Name | Description
DataValue | Gets the object assigned to the target data-bound canvas. If the canvas is not data-bound, this value is null (Nothing in Visual Basic).
PageCount | Gets the total number of pages in the report.
PageIndex | Gets the index of the current page.
RangeCount | Gets the total number of instances of the data range, which contains the target Canvas (if any).
RangeIndex | Gets the index of the data range instance, which contains the target Canvas (if any).

See Also

DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs Properties

DrawCanvasEventArgs Properties

Public Properties

Name | Description
DataValue | Gets the object assigned to the target data-bound canvas. If the canvas is not data-bound, this value is null (Nothing in Visual Basic).
PageCount | Gets the total number of pages in the report.
PageIndex | Gets the index of the current page.
RangeCount | Gets the total number of instances of the data range, which contains the target Canvas (if any).
RangeIndex | Gets the index of the data range instance, which contains the target Canvas (if any).

See Also

DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs.DataValue Property

DrawCanvasEventArgs.DataValue Property

Gets the object assigned to the target data-bound canvas. If the canvas is not data-bound, this value is null (Nothing in Visual Basic).

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Object DataValue { get; }
Visual Basic

Public ReadOnly Property DataValue As Object

Property Value

A System.Object representing the value obtained through data-binding.

See Also

DrawCanvasEventArgs Members
DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs.PageCount Property

DrawCanvasEventArgs.PageCount Property

Gets the total number of pages in the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public int PageCount { get; }
Visual Basic

Public ReadOnly Property PageCount As Integer

Property Value

An integer specifying the number of pages in the report.

See Also

DrawCanvasEventArgs Members
DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs.PageIndex Property

DrawCanvasEventArgs.PageIndex Property

Gets the index of the current page.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public int PageIndex { get; }
Visual Basic

Public ReadOnly Property PageIndex As Integer

Property Value

An integer specifying the index of the page on which the target Canvas appears in the final report layout.

See Also

DrawCanvasEventArgs Members
DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs.RangeCount Property

DrawCanvasEventArgs.RangeCount Property

Gets the total number of instances of the data range, which contains the target Canvas (if any).

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public int RangeCount { get; }
Visual Basic

Public ReadOnly Property RangeCount As Integer

Property Value

An integer specifying the total number of instances in the final report layout of the DataRange, which contains the target Canvas. If the canvas is not contained in a DataRange, the value of this property is undefined.

See Also

DrawCanvasEventArgs Members
DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs.RangeIndex Property

DrawCanvasEventArgs.RangeIndex Property

Gets the index of the data range instance, which contains the target Canvas (if any).

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public int RangeIndex { get; }
Visual Basic

Public ReadOnly Property RangeIndex As Integer

Property Value

An integer specifying the index in the final report layout of the DataRange instance, which contains the target Canvas. If the canvas is not contained in a DataRange, the value of this property is undefined.

See Also

DrawCanvasEventArgs Members
DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext Class

DrawContext Class
Remarks See Also

Provides contextual information when drawing report items.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class DrawContext
Visual Basic

Public Class DrawContext

Remarks

Instances of this class are passed as arguments to the DrawPage method of the ReportLayout.

Example

The following example layouts a report and draws its last page. The layout assumes that report1 is a variable identifying an existing report and that graphics identifies an instance of IGraphics.

C#

ReportLayout layout = report1.Layout(new SizeF(210, 297),
new Margins(20), PageOrientation.Portrait);
DrawContext context = new DrawContext(report1);

report1.DrawPage(graphics, layout.PageCount - 1, context);

Inheritance Hierarchy

System.Object
MindFusion.Reporting.DrawContext

See Also

DrawContext Members
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext Members

DrawContext Members
Constructors Properties

Provides contextual information when drawing report items.

The following tables list the members exposed by the DrawContext type.

Public Constructors

Name | Description
DrawContext | Initializes a new instance of the DrawContext class.

Public Properties

Name | Description
Font | Gets the non-null font of the closest parent.
Scale | Gets or sets the zoom factor of the drawing.

See Also

DrawContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext Constructor

DrawContext Constructor

Initializes a new instance of the DrawContext class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public DrawContext (
Report report
)
Visual Basic

Public New ( _
report As Report _
)

Parameters

report

The Report object whose items will be drawn using this DrawContext.

See Also

DrawContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext Properties

DrawContext Properties

Public Properties

Name | Description
Font | Gets the non-null font of the closest parent.
Scale | Gets or sets the zoom factor of the drawing.

See Also

DrawContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext.Font Property

DrawContext.Font Property

Gets the non-null font of the closest parent.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Font Font { get; }
Visual Basic

Public ReadOnly Property Font As Font

Property Value

An .NET Font object specifying a non-null font in the current context. Report elements, such as labels, whose Font property is null (Nothing in Visual Basic), should use this value when drawing their text.

See Also

DrawContext Members
DrawContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext.Scale Property

DrawContext.Scale Property

Gets or sets the zoom factor of the drawing.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float Scale { get; set; }
Visual Basic

Public Property Scale As Single

Property Value

A float value indicating a scale factor of the drawing. The default is 1.

Remarks

This value is used when rendering Picture elements in a Graphics with applied scale transformation.

See Also

DrawContext Members
DrawContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs Class

DrawEventArgs Class

Provides data for various rendering events.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class DrawEventArgs : EventArgs
Visual Basic

Public Class DrawEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Reporting.DrawEventArgs
MindFusion.Reporting.DrawCanvasEventArgs

See Also

DrawEventArgs Members
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs Members

DrawEventArgs Members
Properties Methods

Provides data for various rendering events.

The following tables list the members exposed by the DrawEventArgs type.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the item being rendered.
Graphics | Gets the IGraphics object to use for rendering.

Public Methods

Name | Description
DrawBorder | Renders the specified border around the specified rectangle in the underlying graphics.

See Also

DrawEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs Methods

DrawEventArgs Methods

Public Methods

Name | Description
DrawBorder | Renders the specified border around the specified rectangle in the underlying graphics.

See Also

DrawEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs.DrawBorder Method

DrawEventArgs.DrawBorder Method

Renders the specified border around the specified rectangle in the underlying graphics.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public void DrawBorder (
Border border,
RectangleF bounds
)
Visual Basic

Public Sub DrawBorder ( _
border As Border, _
bounds As RectangleF _
)

Parameters

border
The Border object to render.
bounds
The RectangleF around which to render a border.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs Properties

DrawEventArgs Properties

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the item being rendered.
Graphics | Gets the IGraphics object to use for rendering.

See Also

DrawEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs.Bounds Property

DrawEventArgs.Bounds Property

Gets the bounding rectangle of the item being rendered.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public RectangleF Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As RectangleF

Property Value

A .NET RectangleF specifying the bounding rectangle of the item being renderd.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs.Graphics Property

DrawEventArgs.Graphics Property

Gets the IGraphics object to use for rendering.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IGraphics Graphics { get; }
Visual Basic

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class, implementing the IGraphics interface.

Remarks

When the drawing is performed in a GDI+ graphics, the value of this property is of type GdiGraphics.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse Class

Ellipse Class

A report element that draws a simple ellipse.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class Ellipse : ReportItem
Visual Basic

Public Class Ellipse
Inherits ReportItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Ellipse

See Also

Ellipse Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse Members

Ellipse Members
Constructors Properties

A report element that draws a simple ellipse.

The following tables list the members exposed by the Ellipse type.

Public Constructors

Name | Description
Ellipse | Initializes a new instance of the Ellipse class.

Public Properties

Name | Description
Color | Gets or sets the color of the ellipse outline.
DashStyle | Gets or sets the dash style of the ellipse outline.
Width | Gets or sets the width of the ellipse outline.

See Also

Ellipse Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse Constructor

Ellipse Constructor

Initializes a new instance of the Ellipse class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Ellipse ()
Visual Basic

Public Sub New ()

See Also

Ellipse Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse Properties

Ellipse Properties

Public Properties

Name | Description
Color | Gets or sets the color of the ellipse outline.
DashStyle | Gets or sets the dash style of the ellipse outline.
Width | Gets or sets the width of the ellipse outline.

See Also

Ellipse Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse.Color Property

Ellipse.Color Property

Gets or sets the color of the ellipse outline.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Color Color { get; set; }
Visual Basic

Public Property Color As Color

Property Value

A .NET Color object specifying the color of the ellipse outline. The default is the WindowText system color.

See Also

Ellipse Members
Ellipse Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse.DashStyle Property

Ellipse.DashStyle Property

Gets or sets the dash style of the ellipse outline.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public DashStyle DashStyle { get; set; }
Visual Basic

Public Property DashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration specifying the style of the ellipse outline. The default is Solid.

See Also

Ellipse Members
Ellipse Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse.Width Property

Ellipse.Width Property

Gets or sets the width of the ellipse outline.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float Width { get; set; }
Visual Basic

Public Property Width As Single

Property Value

A float value indicating the thickness of the ellipse outline. The default is 1. Specify 0 for the value of this property to indicate a hairline thickness.

See Also

Ellipse Members
Ellipse Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer Class

ItemContainer Class
Remarks See Also

Represents a base class for report items that can serve as containers for other report items, such as DataRange.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class ItemContainer : ReportItem
Visual Basic

Public Class ItemContainer
Inherits ReportItem

Remarks

The items in an item container can be accessed through its Items property.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.ItemContainer
MindFusion.Reporting.DataRangeSection
MindFusion.Reporting.PageSection

See Also

ItemContainer Members
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer Members

ItemContainer Members
Constructors Properties

Represents a base class for report items that can serve as containers for other report items, such as DataRange.

The following tables list the members exposed by the ItemContainer type.

Public Constructors

Name | Description
ItemContainer | Initializes a new instance of the ItemContainer class.

Public Properties

Name | Description
Background | Gets or sets the brush that will be used to fill the container's background.
Border | Gets or sets the border of this container.
Bounds | Gets the bounding rectangle of this container.
Items | Gets or sets the report items contained in this container.

See Also

ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer Constructor

ItemContainer Constructor

Initializes a new instance of the ItemContainer class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public ItemContainer ()
Visual Basic

Public Sub New ()

See Also

ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer Properties

ItemContainer Properties

Public Properties

Name | Description
Background | Gets or sets the brush that will be used to fill the container's background.
Border | Gets or sets the border of this container.
Bounds | Gets the bounding rectangle of this container.
Items | Gets or sets the report items contained in this container.

See Also

ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer.Background Property

ItemContainer.Background Property

Gets or sets the brush that will be used to fill the container's background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush Background { get; set; }
Visual Basic

Public Property Background As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic) indicating a transparent background.

See Also

ItemContainer Members
ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer.Border Property

ItemContainer.Border Property

Gets or sets the border of this container.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Border Border { get; set; }
Visual Basic

Public Property Border As Border

Property Value

An instance of the Border class. The default value is an empty Border object.

See Also

ItemContainer Members
ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer.Bounds Property

ItemContainer.Bounds Property

Gets the bounding rectangle of this container.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public RectangleF Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As RectangleF

Property Value

A .NET RectangleF object specifying the bounds of the container relative to its parent.

See Also

ItemContainer Members
ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer.Items Property

ItemContainer.Items Property

Gets or sets the report items contained in this container.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList<ReportItem> Items { get; set; }
Visual Basic

Public Property Items As IList(Of ReportItem)

Property Value

An instance of an IList(ReportItem) class containing all items in the container.

See Also

ItemContainer Members
ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label Class

Label Class
Remarks See Also

A report element that draws a static text.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class Label : ReportItem, IVirtualPropertyProvider
Visual Basic

Public Class Label
Inherits ReportItem
Implements IVirtualPropertyProvider

Remarks

Usually, labels display static text. In this case, simply assign the text to be displayed to their Text property.

Alternatively, the labels can be bound to fields in a data source. To do this, the label must be placed in a data-bound DataRange object and its DataField property must be set to the name of the respective data field. For more information regarding this, check the Report Items and Binding Reports to a Data Source topics.

Finally, the text of the label may contained the so-called expressions. The expressions within the label's text are evaluated when the report is run and the result of the evaluation is displayed by the label. Extensive information about how to integrate expressions in the text of labels can be found in the Using Expressions in Label Texts topic.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Label

See Also

Report Items
Label Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Label Members

Label Members
Constructors Properties

A report element that draws a static text.

The following tables list the members exposed by the Label type.

Public Constructors

Name | Description
Label | Initializes a new instance of the Label class.

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the text displayed in the label.
Background | Gets or sets the brush that will be used to fill the label background.
Border | Gets or sets the border of this label.
Color | Gets or sets the color that will be used to draw the label.
DataField | Gets or sets the name of the data field to bind to.
Font | Gets or sets the label font.
Format | Gets or sets the format of the text displayed in the label.
LineAlignment | Gets or sets the vertical alignment of the text displayed in the label.
Padding | Gets or sets the padding of the label text.
RotationAngle | Gets or sets the rotation angle of the label text.
Size | ReportItem.Size override.
Text | Gets or sets the label text.

See Also

Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label Constructor

Label Constructor

Initializes a new instance of the Label class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Label ()
Visual Basic

Public Sub New ()

See Also

Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label Properties

Label Properties

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the text displayed in the label.
Background | Gets or sets the brush that will be used to fill the label background.
Border | Gets or sets the border of this label.
Color | Gets or sets the color that will be used to draw the label.
DataField | Gets or sets the name of the data field to bind to.
Font | Gets or sets the label font.
Format | Gets or sets the format of the text displayed in the label.
LineAlignment | Gets or sets the vertical alignment of the text displayed in the label.
Padding | Gets or sets the padding of the label text.
RotationAngle | Gets or sets the rotation angle of the label text.
Size | ReportItem.Size override.
Text | Gets or sets the label text.

See Also

Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Alignment Property

Label.Alignment Property

Gets or sets the alignment of the text displayed in the label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public StringAlignment Alignment { get; set; }
Visual Basic

Public Property Alignment As StringAlignment

Property Value

A member of the .NET StringAlignment enumeration indicating the horizontal alignment of the text. The default is Near.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Background Property

Label.Background Property

Gets or sets the brush that will be used to fill the label background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush Background { get; set; }
Visual Basic

Public Property Background As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic) indicating a transparent background.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Border Property

Label.Border Property

Gets or sets the border of this label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Border Border { get; set; }
Visual Basic

Public Property Border As Border

Property Value

An instance of the Border class. The default value is an empty Border object.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Color Property

Label.Color Property

Gets or sets the color that will be used to draw the label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Color Color { get; set; }
Visual Basic

Public Property Color As Color

Property Value

A .NET Color object specifying the color of the label's text. The default is Black.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.DataField Property

Label.DataField Property

Gets or sets the name of the data field to bind to.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string DataField { get; set; }
Visual Basic

Public Property DataField As String

Property Value

A string specifying the data field this label is bound to. The default is an empty string indicating that the label is not data-bound.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Font Property

Label.Font Property

Gets or sets the label font.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Font Font { get; set; }
Visual Basic

Public Property Font As Font

Property Value

A .NET Font object specifying the font of the label's text. The default value is null (Nothing in Visual Basic).

Remarks

When this property is null (Nothing in Visual Basic) the font of the label's text is determined by the value of the Font property of the containing Report.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Format Property

Label.Format Property

Gets or sets the format of the text displayed in the label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public StringFormat Format { get; set; }
Visual Basic

Public Property Format As StringFormat

Property Value

A member of the .NET StringAlignment enumeration.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.LineAlignment Property

Label.LineAlignment Property

Gets or sets the vertical alignment of the text displayed in the label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public StringAlignment LineAlignment { get; set; }
Visual Basic

Public Property LineAlignment As StringAlignment

Property Value

A member of the .NET StringAlignment enumeration indicating the vertical alignment of the text. The default is Center.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Padding Property

Label.Padding Property

Gets or sets the padding of the label text.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Margins Padding { get; set; }
Visual Basic

Public Property Padding As Margins

Property Value

An instance of the Margins class specifying the distance between the label's outline and text. The default is a Margins object with all sides set to 0.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.RotationAngle Property

Label.RotationAngle Property

Gets or sets the rotation angle of the label text.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float RotationAngle { get; set; }
Visual Basic

Public Property RotationAngle As Single

Property Value

A float value specifying the rotation angle of the label text, in degrees.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Size Property

Label.Size Property

ReportItem.Size override.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public override Dimension Size { get; set; }
Visual Basic

Public Overrides Property Size As Dimension

Property Value

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Text Property

Label.Text Property

Gets or sets the label text.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string Text { get; set; }
Visual Basic

Public Property Text As String

Property Value

A string representing the label's text.

Remarks

This property is ignored if the label is data-bound, that is, its DataField property is not empty. The text of the label in this case is obtained from the data source.

Expressions

The text of the label can contain expressions embedded in it. To embed an expression, simply encompass it in square brackets - '[' and ']'. The following example embeds the expression Now() in the text of a label. The example assumes that label1 is a variable identifying an existing label.

C#

label1.Text = "The time now is [Now()]";

Visual Basic

label1.Text = "The time now is [Now()]"

For more information about expressions in general, check Expressions. For more information on how to use expressions in label texts, check Using Expressions in Label Texts.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line Class

Line Class

A report element that draws a simple line.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class Line : ReportItem
Visual Basic

Public Class Line
Inherits ReportItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Line

See Also

Line Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Line Members

Line Members
Constructors Properties

A report element that draws a simple line.

The following tables list the members exposed by the Line type.

Public Constructors

Name | Description
Line | Initializes a new instance of the Line class.

Public Properties

Name | Description
Color | Gets or sets the color that will be used to draw the line.
DashStyle | Gets or sets the dash style of the line.
EndPoint | Gets or sets the end point of the line.
StartPoint | The start point of the line.
Width | Gets or sets the width of the line.

See Also

Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line Constructor

Line Constructor

Initializes a new instance of the Line class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Line ()
Visual Basic

Public Sub New ()

See Also

Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line Properties

Line Properties

Public Properties

Name | Description
Color | Gets or sets the color that will be used to draw the line.
DashStyle | Gets or sets the dash style of the line.
EndPoint | Gets or sets the end point of the line.
StartPoint | The start point of the line.
Width | Gets or sets the width of the line.

See Also

Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line.Color Property

Line.Color Property

Gets or sets the color that will be used to draw the line.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Color Color { get; set; }
Visual Basic

Public Property Color As Color

Property Value

A .NET Color object specifying the color of the line. The default is the WindowText system color.

See Also

Line Members
Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line.DashStyle Property

Line.DashStyle Property

Gets or sets the dash style of the line.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public DashStyle DashStyle { get; set; }
Visual Basic

Public Property DashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration specifying the style of the line. The default is Solid.

See Also

Line Members
Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line.EndPoint Property

Line.EndPoint Property

Gets or sets the end point of the line.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Location EndPoint { get; set; }
Visual Basic

Public Property EndPoint As Location

Property Value

A Location object specifying the end point of the line.

See Also

Line Members
Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line.StartPoint Property

Line.StartPoint Property

The start point of the line.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Location StartPoint { get; set; }
Visual Basic

Public Property StartPoint As Location

Property Value

A Location object specifying the start point of the line.

See Also

Line Members
Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line.Width Property

Line.Width Property

Gets or sets the width of the line.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float Width { get; set; }
Visual Basic

Public Property Width As Single

Property Value

A float value indicating the thickness of the line. The default is 1. Specify 0 for the value of this property to indicate a hairline thickness.

See Also

Line Members
Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart Class

LineChart Class

Represents a report item that can display line charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class LineChart : AxesChart, IVirtualPropertyProvider
Visual Basic

Public Class LineChart
Inherits AxesChart
Implements IVirtualPropertyProvider

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Chart
MindFusion.Reporting.AxesChart
MindFusion.Reporting.LineChart

See Also

LineChart Members
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart Members

LineChart Members
Constructors Properties

Represents a report item that can display line charts.

The following tables list the members exposed by the LineChart type.

Public Constructors

Name | Description
LineChart | Initializes a new instance of the LineChart class.

Public Properties

Name | Description
CalculateFunction | Gets or sets a custom function that will be invoked in order to calculates the values for the chart.
Curve | Gets or sets a value indicating whether lines are drawn as curves.
FunctionArguments | Gets or sets the FunctionArgs object that will be passed to the CalculateFunctionDelegate method when it is invoked.
LabelAlignment | Gets or sets the alignment of labels drawn at data points.
Labels | Gets or sets custom labels drawn at chart data points.
LabelsFields | Gets or sets the database columns, from which custom text for data point labels is retrieved.
LabelType | Gets or sets the type of labels drawn at chart data points.
LineType | Gets or sets the type of the line chart.
MaxBubbleRadius | Gets or sets the radius length of the biggest bubble.
MinBubbleRadius | Gets or sets the radius length of the smallest bubble.
MultiColoredShapes | Gets or sets a value indicating whether shapes for a single series are drawn using all ShapeBrushes.
ShapeBrushes | Gets or sets the brushes for filling point shapes in scatter charts.
ShapePens | Gets or sets the pens for drawing shapes in scatter charts.
Shapes | Gets or sets the shapes for data series in scatter charts.
ShapeSizes | Gets or sets the size of point shapes for each data series in scatter charts.
Stacked | Gets or sets a value indicating whether multi-series 3D graphics are drawn stacked.
SummaryShapeBrushes | Gets or sets the brushes used for filling point shapes for summary graphics in scatter charts.
SummaryShapePens | Gets or sets the pens used for drawing point shapes for summary graphics in scatter charts.
SummaryShapes | Gets or sets the point shapes drawn at summary graphics in scatter charts.
SummaryShapeSizes | Gets or sets the size of point shapes drawn at summary graphics in scatter charts.
XData | Gets or sets the data for calculating the X-coordinates of line charts.
XDataFields | Gets or sets the database columns, from which data for calculating the X-coordinates of charts is retrieved.
Y2ShapeBrushes | Gets or sets the brushes used for filling summary point shapes in scatter charts bound to the second y-axis.
Y2ShapePens | Gets or sets the pens used for drawing point shapes in scatter charts bound to the second y-axis.
Y2Shapes | Gets or sets the type of shapes drawn at scatter charts bound to the second y-axis.
Y2ShapeSizes | Gets or sets the size of point shapes drawn at scatter charts bound to the second y-axis.
YData | Gets or sets the data for calculating the Y-coordinates of charts.
YDataFields | Gets or sets the database columns, from which data for calculating the Y-coordinates of charts is retrieved.

See Also

LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart Constructor

LineChart Constructor

Initializes a new instance of the LineChart class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public LineChart ()
Visual Basic

Public Sub New ()

See Also

LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart Properties

LineChart Properties

Public Properties

Name | Description
CalculateFunction | Gets or sets a custom function that will be invoked in order to calculates the values for the chart.
Curve | Gets or sets a value indicating whether lines are drawn as curves.
FunctionArguments | Gets or sets the FunctionArgs object that will be passed to the CalculateFunctionDelegate method when it is invoked.
LabelAlignment | Gets or sets the alignment of labels drawn at data points.
Labels | Gets or sets custom labels drawn at chart data points.
LabelsFields | Gets or sets the database columns, from which custom text for data point labels is retrieved.
LabelType | Gets or sets the type of labels drawn at chart data points.
LineType | Gets or sets the type of the line chart.
MaxBubbleRadius | Gets or sets the radius length of the biggest bubble.
MinBubbleRadius | Gets or sets the radius length of the smallest bubble.
MultiColoredShapes | Gets or sets a value indicating whether shapes for a single series are drawn using all ShapeBrushes.
ShapeBrushes | Gets or sets the brushes for filling point shapes in scatter charts.
ShapePens | Gets or sets the pens for drawing shapes in scatter charts.
Shapes | Gets or sets the shapes for data series in scatter charts.
ShapeSizes | Gets or sets the size of point shapes for each data series in scatter charts.
Stacked | Gets or sets a value indicating whether multi-series 3D graphics are drawn stacked.
SummaryShapeBrushes | Gets or sets the brushes used for filling point shapes for summary graphics in scatter charts.
SummaryShapePens | Gets or sets the pens used for drawing point shapes for summary graphics in scatter charts.
SummaryShapes | Gets or sets the point shapes drawn at summary graphics in scatter charts.
SummaryShapeSizes | Gets or sets the size of point shapes drawn at summary graphics in scatter charts.
XData | Gets or sets the data for calculating the X-coordinates of line charts.
XDataFields | Gets or sets the database columns, from which data for calculating the X-coordinates of charts is retrieved.
Y2ShapeBrushes | Gets or sets the brushes used for filling summary point shapes in scatter charts bound to the second y-axis.
Y2ShapePens | Gets or sets the pens used for drawing point shapes in scatter charts bound to the second y-axis.
Y2Shapes | Gets or sets the type of shapes drawn at scatter charts bound to the second y-axis.
Y2ShapeSizes | Gets or sets the size of point shapes drawn at scatter charts bound to the second y-axis.
YData | Gets or sets the data for calculating the Y-coordinates of charts.
YDataFields | Gets or sets the database columns, from which data for calculating the Y-coordinates of charts is retrieved.

See Also

LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.CalculateFunction Property

LineChart.CalculateFunction Property

Gets or sets a custom function that will be invoked in order to calculates the values for the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public CalculateFunctionDelegate CalculateFunction { get; set; }
Visual Basic

Public Property CalculateFunction As CalculateFunctionDelegate

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.Curve Property

LineChart.Curve Property

Gets or sets a value indicating whether lines are drawn as curves.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool Curve { get; set; }
Visual Basic

Public Property Curve As Boolean

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.FunctionArguments Property

LineChart.FunctionArguments Property

Gets or sets the FunctionArgs object that will be passed to the CalculateFunctionDelegate method when it is invoked.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public FunctionArgs FunctionArguments { get; set; }
Visual Basic

Public Property FunctionArguments As FunctionArgs

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.LabelAlignment Property

LineChart.LabelAlignment Property

Gets or sets the alignment of labels drawn at data points.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public StringAlignment LabelAlignment { get; set; }
Visual Basic

Public Property LabelAlignment As StringAlignment

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.Labels Property

LineChart.Labels Property

Gets or sets custom labels drawn at chart data points.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList Labels { get; set; }
Visual Basic

Public Property Labels As IList

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.LabelsFields Property

LineChart.LabelsFields Property

Gets or sets the database columns, from which custom text for data point labels is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string LabelsFields { get; set; }
Visual Basic

Public Property LabelsFields As String

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.LabelType Property

LineChart.LabelType Property

Gets or sets the type of labels drawn at chart data points.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public LabelType LabelType { get; set; }
Visual Basic

Public Property LabelType As LabelType

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.LineType Property

LineChart.LineType Property

Gets or sets the type of the line chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public LineTypes LineType { get; set; }
Visual Basic

Public Property LineType As LineTypes

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.MaxBubbleRadius Property

LineChart.MaxBubbleRadius Property

Gets or sets the radius length of the biggest bubble.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float MaxBubbleRadius { get; set; }
Visual Basic

Public Property MaxBubbleRadius As Single

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.MinBubbleRadius Property

LineChart.MinBubbleRadius Property

Gets or sets the radius length of the smallest bubble.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float MinBubbleRadius { get; set; }
Visual Basic

Public Property MinBubbleRadius As Single

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.MultiColoredShapes Property

LineChart.MultiColoredShapes Property

Gets or sets a value indicating whether shapes for a single series are drawn using all ShapeBrushes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool MultiColoredShapes { get; set; }
Visual Basic

Public Property MultiColoredShapes As Boolean

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.ShapeBrushes Property

LineChart.ShapeBrushes Property

Gets or sets the brushes for filling point shapes in scatter charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BrushCollection ShapeBrushes { get; set; }
Visual Basic

Public Property ShapeBrushes As BrushCollection

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.ShapePens Property

LineChart.ShapePens Property

Gets or sets the pens for drawing shapes in scatter charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenCollection ShapePens { get; set; }
Visual Basic

Public Property ShapePens As PenCollection

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.Shapes Property

LineChart.Shapes Property

Gets or sets the shapes for data series in scatter charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList Shapes { get; set; }
Visual Basic

Public Property Shapes As IList

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.ShapeSizes Property

LineChart.ShapeSizes Property

Gets or sets the size of point shapes for each data series in scatter charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList ShapeSizes { get; set; }
Visual Basic

Public Property ShapeSizes As IList

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.Stacked Property

LineChart.Stacked Property

Gets or sets a value indicating whether multi-series 3D graphics are drawn stacked.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool Stacked { get; set; }
Visual Basic

Public Property Stacked As Boolean

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.SummaryShapeBrushes Property

LineChart.SummaryShapeBrushes Property

Gets or sets the brushes used for filling point shapes for summary graphics in scatter charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BrushCollection SummaryShapeBrushes { get; set; }
Visual Basic

Public Property SummaryShapeBrushes As BrushCollection

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.SummaryShapePens Property

LineChart.SummaryShapePens Property

Gets or sets the pens used for drawing point shapes for summary graphics in scatter charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenCollection SummaryShapePens { get; set; }
Visual Basic

Public Property SummaryShapePens As PenCollection

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.SummaryShapes Property

LineChart.SummaryShapes Property

Gets or sets the point shapes drawn at summary graphics in scatter charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList SummaryShapes { get; set; }
Visual Basic

Public Property SummaryShapes As IList

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.SummaryShapeSizes Property

LineChart.SummaryShapeSizes Property

Gets or sets the size of point shapes drawn at summary graphics in scatter charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList SummaryShapeSizes { get; set; }
Visual Basic

Public Property SummaryShapeSizes As IList

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.XData Property

LineChart.XData Property

Gets or sets the data for calculating the X-coordinates of line charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList XData { get; set; }
Visual Basic

Public Property XData As IList

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.XDataFields Property

LineChart.XDataFields Property

Gets or sets the database columns, from which data for calculating the X-coordinates of charts is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string XDataFields { get; set; }
Visual Basic

Public Property XDataFields As String

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.Y2ShapeBrushes Property

LineChart.Y2ShapeBrushes Property

Gets or sets the brushes used for filling summary point shapes in scatter charts bound to the second y-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BrushCollection Y2ShapeBrushes { get; set; }
Visual Basic

Public Property Y2ShapeBrushes As BrushCollection

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.Y2ShapePens Property

LineChart.Y2ShapePens Property

Gets or sets the pens used for drawing point shapes in scatter charts bound to the second y-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenCollection Y2ShapePens { get; set; }
Visual Basic

Public Property Y2ShapePens As PenCollection

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.Y2Shapes Property

LineChart.Y2Shapes Property

Gets or sets the type of shapes drawn at scatter charts bound to the second y-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList Y2Shapes { get; set; }
Visual Basic

Public Property Y2Shapes As IList

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.Y2ShapeSizes Property

LineChart.Y2ShapeSizes Property

Gets or sets the size of point shapes drawn at scatter charts bound to the second y-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList Y2ShapeSizes { get; set; }
Visual Basic

Public Property Y2ShapeSizes As IList

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.YData Property

LineChart.YData Property

Gets or sets the data for calculating the Y-coordinates of charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList YData { get; set; }
Visual Basic

Public Property YData As IList

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.YDataFields Property

LineChart.YDataFields Property

Gets or sets the database columns, from which data for calculating the Y-coordinates of charts is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string YDataFields { get; set; }
Visual Basic

Public Property YDataFields As String

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Structure

Location Structure

Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public struct Location
Visual Basic

Public Structure Location

See Also

Location Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Members

Location Members
Constructors Fields Properties Methods

Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.

The following tables list the members exposed by the Location type.

Public Constructors

Name | Description
Location | Overloaded.

Public Fields

Name | Description
Empty | An empty instance of the Location structure.

Public Properties

Name | Description
IsEmpty | Gets a value indicating whether this Location is empty.
X | Gets or sets the x-coordinate of this location.
XUnit | Gets or sets the units of measure of the x-coordinate of this Location.
Y | Gets or sets the y-coordinate of this location.
YUnit | Gets or sets the units of measure of the y-coordinate of this Location.

Public Methods

Name | Description
Add | Adds the width and height of the specified Dimension to the specified Location.
Equals | Determines if two Location structures have the same coordinates.
GetHashCode | Returns a hash code for this Location structure.
Subtract | Returns the result of subtracting the specified Dimension from the specified Location.
ToString | Creates a human-readable string that represents this Location.

See Also

Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Fields

Location Fields

Public Fields

Name | Description
Empty | An empty instance of the Location structure.

See Also

Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.Empty Field

Location.Empty Field

An empty instance of the Location structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public static readonly Location Empty
Visual Basic

Public Shared ReadOnly Empty As Location

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Constructor

Location Constructor

Overload List

Name | Description
Location (Single, MeasureUnit, Single, MeasureUnit) | Initializes a new instance of the Location structure.
Location (Single, Single) | Initializes a new instance of the Location structure with the specified coordinates.

See Also

Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Constructor (Single, MeasureUnit, Single, MeasureUnit)

Location Constructor (Single, MeasureUnit, Single, MeasureUnit)
See Also

Initializes a new instance of the Location structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Location (
float x,
MeasureUnit xUnit,
float y,
MeasureUnit yUnit
)
Visual Basic

Public New ( _
x As Single, _
xUnit As MeasureUnit, _
y As Single, _
yUnit As MeasureUnit _
)

Parameters

x
The x component of the new Location.
xUnit
The x unit component of the new Location.
y
The y component of the new Location.
yUnit
The y unit component of the new Location.

See Also

Location Constructor Overload List
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Constructor (Single, Single)

Location Constructor (Single, Single)
See Also

Initializes a new instance of the Location structure with the specified coordinates.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Location (
float x,
float y
)
Visual Basic

Public New ( _
x As Single, _
y As Single _
)

Parameters

x
The x component of the new Location.
y
The y component of the new Location.

See Also

Location Constructor Overload List
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Methods

Location Methods

Public Methods

Name | Description
Add | Adds the width and height of the specified Dimension to the specified Location.
Equals | Determines if two Location structures have the same coordinates.
GetHashCode | Returns a hash code for this Location structure.
Subtract | Returns the result of subtracting the specified Dimension from the specified Location.
ToString | Creates a human-readable string that represents this Location.

See Also

Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.Add Method

Location.Add Method

Adds the width and height of the specified Dimension to the specified Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public static Location Add (
Location location,
Dimension dimension
)
Visual Basic

Public Shared Function Add ( _
location As Location, _
dimension As Dimension _
) As Location

Parameters

location
The Location to add to.
dimension
The Dimension to add.

Return Value

A Location structure that is the result of the addition operation. The XUnit and YUnit of the result are both set to Document.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.Equals Method

Location.Equals Method

Determines if two Location structures have the same coordinates.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public override bool Equals (
Object obj
)
Visual Basic

Public Overrides Function Equals ( _
obj As Object _
) As Boolean

Parameters

obj
The System.Object to test.

Return Value

true if obj is a Location and has the same coordinates and units as this Location; otherwise, false.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.GetHashCode Method

Location.GetHashCode Method

Returns a hash code for this Location structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public override int GetHashCode ()
Visual Basic

Public Overrides Function GetHashCode () As Integer

Return Value

An integer value that specifies a hash value for this Location structure.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.Subtract Method

Location.Subtract Method

Returns the result of subtracting the specified Dimension from the specified Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public static Location Subtract (
Location location,
Dimension dimension
)
Visual Basic

Public Shared Function Subtract ( _
location As Location, _
dimension As Dimension _
) As Location

Parameters

location
The Location structure to subtract from.
dimension
The Dimension structure to subtract.

Return Value

The Location that is a result of the subtraction operation. The XUnit and YUnit of the result are both set to Document.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.ToString Method

Location.ToString Method

Creates a human-readable string that represents this Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string that represents this Location.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Properties

Location Properties

Public Properties

Name | Description
IsEmpty | Gets a value indicating whether this Location is empty.
X | Gets or sets the x-coordinate of this location.
XUnit | Gets or sets the units of measure of the x-coordinate of this Location.
Y | Gets or sets the y-coordinate of this location.
YUnit | Gets or sets the units of measure of the y-coordinate of this Location.

See Also

Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.IsEmpty Property

Location.IsEmpty Property

Gets a value indicating whether this Location is empty.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool IsEmpty { get; }
Visual Basic

Public ReadOnly Property IsEmpty As Boolean

Property Value

true if both X and Y of the Location are 0; otherwise, false.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.X Property

Location.X Property

Gets or sets the x-coordinate of this location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float X { get; set; }
Visual Basic

Public Property X As Single

Property Value

A float number specifying the x-axis component of the Location, in the units of measure specified by XUnit.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace
Y Property
XUnit Property


MindFusion.Reporting.Location.XUnit Property

Location.XUnit Property

Gets or sets the units of measure of the x-coordinate of this Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public MeasureUnit XUnit { get; set; }
Visual Basic

Public Property XUnit As MeasureUnit

Property Value

A member of the MeasureUnit enumeration specifying the units of measure of the X component of this Location.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace
YUnit Property
X Property


MindFusion.Reporting.Location.Y Property

Location.Y Property

Gets or sets the y-coordinate of this location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float Y { get; set; }
Visual Basic

Public Property Y As Single

Property Value

A float number specifying the y-axis component of the Location, in the units of measure specified by YUnit.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace
YUnit Property
X Property


MindFusion.Reporting.Location.YUnit Property

Location.YUnit Property

Gets or sets the units of measure of the y-coordinate of this Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public MeasureUnit YUnit { get; set; }
Visual Basic

Public Property YUnit As MeasureUnit

Property Value

A member of the MeasureUnit enumeration specifying the units of measure of the Y component of this Location.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace
XUnit Property
Y Property


MindFusion.Reporting.Margins Class

Margins Class

Specifies the dimensions of the margins of a rectangle.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class Margins
Visual Basic

Public Class Margins

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Margins

See Also

Margins Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Members

Margins Members
Constructors Properties Methods

Specifies the dimensions of the margins of a rectangle.

The following tables list the members exposed by the Margins type.

Public Constructors

Name | Description
Margins | Overloaded.

Public Properties

Name | Description
Bottom | Gets or sets the bottom component of this margin.
Left | Gets or sets the left component of this margin.
Right | Gets or sets the right component of this margin.
Top | Gets or sets the top component of this margin.

Public Methods

Name | Description
Clone | Creates a copy of this Margins object.
Equals | Determines if two Margins objects are identicat, that is, have the same values for all four sides.
GetHashCode | Returns a hash code for this Margins instance.
ToString | Creates a human-readable string that represents this Margins.

See Also

Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Constructor

Margins Constructor

Overload List

Name | Description
Margins () | Initializes a new instance of the Margins class.
Margins (Single) | Initializes a new instance of the Margins class.
Margins (Single, Single, Single, Single) | Initializes a new instance of the Margins class.

See Also

Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Constructor ()

Margins Constructor ()
See Also

Initializes a new instance of the Margins class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Margins ()
Visual Basic

Public Sub New ()

See Also

Margins Constructor Overload List
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Constructor (Single)

Margins Constructor (Single)
See Also

Initializes a new instance of the Margins class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Margins (
float value
)
Visual Basic

Public New ( _
value As Single _
)

Parameters

value
The initial value for all sides of the new Margins.

See Also

Margins Constructor Overload List
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Constructor (Single, Single, Single, Single)

Margins Constructor (Single, Single, Single, Single)
See Also

Initializes a new instance of the Margins class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Margins (
float left,
float top,
float right,
float bottom
)
Visual Basic

Public New ( _
left As Single, _
top As Single, _
right As Single, _
bottom As Single _
)

Parameters

left
The left component of the new Margins.
top
The top component of the new Margins.
right
The right component of the new Margins.
bottom
The bottom component of the new Margins.

See Also

Margins Constructor Overload List
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Methods

Margins Methods

Public Methods

Name | Description
Clone | Creates a copy of this Margins object.
Equals | Determines if two Margins objects are identicat, that is, have the same values for all four sides.
GetHashCode | Returns a hash code for this Margins instance.
ToString | Creates a human-readable string that represents this Margins.

See Also

Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins.Clone Method

Margins.Clone Method

Creates a copy of this Margins object.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Margins Clone ()
Visual Basic

Public Function Clone () As Margins

Return Value

An instance of the Margins class identical to the current instance.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins.Equals Method

Margins.Equals Method

Determines if two Margins objects are identicat, that is, have the same values for all four sides.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public override bool Equals (
Object obj
)
Visual Basic

Public Overrides Function Equals ( _
obj As Object _
) As Boolean

Parameters

obj
The System.Object to test.

Return Value

true if obj is a Margins and has the same sides as this Margins; otherwise, false.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins.GetHashCode Method

Margins.GetHashCode Method

Returns a hash code for this Margins instance.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public override int GetHashCode ()
Visual Basic

Public Overrides Function GetHashCode () As Integer

Return Value

An integer value that specifies a hash value for this Margins object.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins.ToString Method

Margins.ToString Method

Creates a human-readable string that represents this Margins.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string that represents this Margins.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Properties

Margins Properties

Public Properties

Name | Description
Bottom | Gets or sets the bottom component of this margin.
Left | Gets or sets the left component of this margin.
Right | Gets or sets the right component of this margin.
Top | Gets or sets the top component of this margin.

See Also

Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins.Bottom Property

Margins.Bottom Property

Gets or sets the bottom component of this margin.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float Bottom { get; set; }
Visual Basic

Public Property Bottom As Single

Property Value

A float number specifying the bottom component of the Margins.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace
Left Property
Right Property
Top Property


MindFusion.Reporting.Margins.Left Property

Margins.Left Property

Gets or sets the left component of this margin.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float Left { get; set; }
Visual Basic

Public Property Left As Single

Property Value

A float number specifying the left component of the Margins.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace
Bottom Property
Right Property
Top Property


MindFusion.Reporting.Margins.Right Property

Margins.Right Property

Gets or sets the right component of this margin.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float Right { get; set; }
Visual Basic

Public Property Right As Single

Property Value

A float number specifying the right component of the Margins.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace
Bottom Property
Left Property
Top Property


MindFusion.Reporting.Margins.Top Property

Margins.Top Property

Gets or sets the top component of this margin.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float Top { get; set; }
Visual Basic

Public Property Top As Single

Property Value

A float number specifying the top component of the Margins.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace
Bottom Property
Left Property
Right Property


MindFusion.Reporting.MeasureUnit Enumeration

MeasureUnit Enumeration

Specifies units of measure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public enum MeasureUnit
Visual Basic

Public Enumeration MeasureUnit

Members

Member name | Description
Document | Indicates a measure units identical to those of the current document.
Percent | Indicates percentage relative to the total size of the containing element.
PercentRemainder | Indicates percentage relative to the remaining size of the containing element.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.Page Class

Page Class

Represents a page within a report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class Page : Component
Visual Basic

Public Class Page
Inherits Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.Page

See Also

Page Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Page Members

Page Members
Constructors Properties

Represents a page within a report.

The following tables list the members exposed by the Page type.

Public Constructors

Name | Description
Page | Initializes a new instance of the Page class.

Public Properties

Name | Description
Background | Gets or sets the brush that will be used to fill the page background.
Border | Gets or sets the border of this page.
Footer | Gets or sets the page footer.
Header | Gets or sets the page header.
Items | Gets or sets the items contained in this page.
Name | Gets or sets the name of the report item.
PageOrientation | Gets or sets the orientation of the page.

See Also

Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page Constructor

Page Constructor

Initializes a new instance of the Page class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Page ()
Visual Basic

Public Sub New ()

See Also

Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page Properties

Page Properties

Public Properties

Name | Description
Background | Gets or sets the brush that will be used to fill the page background.
Border | Gets or sets the border of this page.
Footer | Gets or sets the page footer.
Header | Gets or sets the page header.
Items | Gets or sets the items contained in this page.
Name | Gets or sets the name of the report item.
PageOrientation | Gets or sets the orientation of the page.

See Also

Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page.Background Property

Page.Background Property

Gets or sets the brush that will be used to fill the page background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush Background { get; set; }
Visual Basic

Public Property Background As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic) indicating a transparent background.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page.Border Property

Page.Border Property

Gets or sets the border of this page.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Border Border { get; set; }
Visual Basic

Public Property Border As Border

Property Value

An instance of the Border class. The default value is an empty Border object.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page.Footer Property

Page.Footer Property

Gets or sets the page footer.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public ItemContainer Footer { get; set; }
Visual Basic

Public Property Footer As ItemContainer

Property Value

An instance of the PageSection class representing the footer of this Page.

Remarks

You can add items to the footer through its Items property.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace
Header Property


MindFusion.Reporting.Page.Header Property

Page.Header Property

Gets or sets the page header.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public ItemContainer Header { get; set; }
Visual Basic

Public Property Header As ItemContainer

Property Value

An instance of the PageSection class representing the header of this Page.

Remarks

You can add items to the footer through its Items property.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace
Footer Property


MindFusion.Reporting.Page.Items Property

Page.Items Property

Gets or sets the items contained in this page.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList<ReportItem> Items { get; set; }
Visual Basic

Public Property Items As IList(Of ReportItem)

Property Value

An instance of a IList(ReportItem) class with the report items contained on the Page.

Remarks

This collection does not include the items contained in the header or footer of the page. To access these, use the Items property of the PageSection object returned from the Header or Footer property of the page respectively.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page.Name Property

Page.Name Property

Gets or sets the name of the report item.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string Name { get; set; }
Visual Basic

Public Property Name As String

Property Value

A string specifying the name of the page.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page.PageOrientation Property

Page.PageOrientation Property

Gets or sets the orientation of the page.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PageOrientation PageOrientation { get; set; }
Visual Basic

Public Property PageOrientation As PageOrientation

Property Value

A member of the PageOrientation enumeration specifying the orientation of the page. The default is Unspecified.

Remarks

When PageOrientation is set to Unspecified, the actual page orientation is determined by the value of the defaultPageOrientation argument passed to the Layout method of the Report class during report layouting.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PageBreak Class

PageBreak Class

Represents a single line across the whole width of a page, which indicates a page break at that location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class PageBreak : ReportItem
Visual Basic

Public Class PageBreak
Inherits ReportItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.PageBreak

See Also

Report Items
PageBreak Members
MindFusion.Reporting Namespace


MindFusion.Reporting.PageBreak Members

PageBreak Members
Constructors Properties

Represents a single line across the whole width of a page, which indicates a page break at that location.

The following tables list the members exposed by the PageBreak type.

Public Constructors

Name | Description
PageBreak | Initializes a new instance of the PageBreak class.

Public Properties

Name | Description
Location | ReportItem.Location override.

See Also

PageBreak Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PageBreak Constructor

PageBreak Constructor

Initializes a new instance of the PageBreak class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PageBreak ()
Visual Basic

Public Sub New ()

See Also

PageBreak Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PageBreak Properties

PageBreak Properties

Public Properties

Name | Description
Location | ReportItem.Location override.

See Also

PageBreak Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PageBreak.Location Property

PageBreak.Location Property

ReportItem.Location override.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public override Location Location { get; set; }
Visual Basic

Public Overrides Property Location As Location

Property Value

A Location object specifying the position of the PageBreak relative to its parent.

Remarks

The x component of this property is irrelevant and is always 0.

See Also

PageBreak Members
PageBreak Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PageOrientation Enumeration

PageOrientation Enumeration

Specifies the orientation of a printed page.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public enum PageOrientation
Visual Basic

Public Enumeration PageOrientation

Members

Member name | Description
Landscape | Indicates landscape orientation.
Portrait | Indicates portrait orientation.
Unspecified | Indicates that the page will get its orientation from the default printer settings at the time of printing or previewing.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.PageSection Class

PageSection Class
Remarks See Also

Represents a page header or footer.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class PageSection : ItemContainer
Visual Basic

Public Class PageSection
Inherits ItemContainer

Remarks

When working with the MindFusion.Reporting Designer you don't have to worry about creating instances of this class and assigning them to the appropriate Page properties.

If you want to create a header or footer for a Page object through code, you have to instantiate from this class and assign the instance to the Header or Footer property of the Page object respectively. You can add items to the header or footer through its Items property.

Example

The following example demonstrates how to create a header for an existing Page object:

C#

PageSection header = new PageSection();

Label headerLabel = new Label();
headerLabel.Text = "Header Text";

header.Items.Add(headerLabel);

page1.Header = header;
Visual Basic

Dim header As New PageSection()

Dim headerLabel As New Label()
headerLabel.Text = "Header Text"

header.Items.Add(headerLabel)

page1.Header = header

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.ItemContainer
MindFusion.Reporting.PageSection

See Also

PageSection Members
MindFusion.Reporting Namespace


MindFusion.Reporting.PageSection Members

PageSection Members
Constructors

Represents a page header or footer.

The following tables list the members exposed by the PageSection type.

Public Constructors

Name | Description
PageSection | Initializes a new instance of the PageSection class.

See Also

PageSection Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PageSection Constructor

PageSection Constructor

Initializes a new instance of the PageSection class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PageSection ()
Visual Basic

Public Sub New ()

See Also

PageSection Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture Class

Picture Class
Remarks See Also

A report element that draws an image.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class Picture : ReportItem
Visual Basic

Public Class Picture
Inherits ReportItem

Remarks

In order to associate an image with the Picture element, create a .NET System.Drawing.Image object and assign it to its Image property. The stretching and alignment of the displayed image can be specified through the ImageAlign property.

Alternatively, pictures can be bound to fields in a data source. To do this, the picture must be placed in a data-bound DataRange object and its DataField property must be set to the name of the respective data field. For more information regarding this, check the Report Items and Binding Reports to a Data Source topics.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Picture

See Also

Report Items
Picture Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture Members

Picture Members
Constructors Properties

A report element that draws an image.

The following tables list the members exposed by the Picture type.

Public Constructors

Name | Description
Picture | Initializes a new instance of the Picture class.

Public Properties

Name | Description
Background | Gets or sets the brush that will be used to fill the picture background.
Border | Gets or sets the border of this picture.
DataField | Gets or sets the name of the data field to bind to.
Image | Gets or sets the System.Drawing.Image object displayed by this picture.
ImageAlign | Gets or sets the alignment of the displayed image.
RotationAngle | Gets or sets the rotation angle of the picture.

See Also

Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture Constructor

Picture Constructor

Initializes a new instance of the Picture class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Picture ()
Visual Basic

Public Sub New ()

See Also

Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture Properties

Picture Properties

Public Properties

Name | Description
Background | Gets or sets the brush that will be used to fill the picture background.
Border | Gets or sets the border of this picture.
DataField | Gets or sets the name of the data field to bind to.
Image | Gets or sets the System.Drawing.Image object displayed by this picture.
ImageAlign | Gets or sets the alignment of the displayed image.
RotationAngle | Gets or sets the rotation angle of the picture.

See Also

Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture.Background Property

Picture.Background Property

Gets or sets the brush that will be used to fill the picture background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Brush Background { get; set; }
Visual Basic

Public Property Background As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic) indicating a transparent background.

See Also

Picture Members
Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture.Border Property

Picture.Border Property

Gets or sets the border of this picture.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Border Border { get; set; }
Visual Basic

Public Property Border As Border

Property Value

An instance of the Border class. The default value is an empty Border object.

See Also

Picture Members
Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture.DataField Property

Picture.DataField Property

Gets or sets the name of the data field to bind to.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string DataField { get; set; }
Visual Basic

Public Property DataField As String

Property Value

A string specifying the data field this picture is bound to. The default is an empty string indicating that the picture is not data-bound.

See Also

Picture Members
Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture.Image Property

Picture.Image Property

Gets or sets the System.Drawing.Image object displayed by this picture.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Image Image { get; set; }
Visual Basic

Public Property Image As Image

Property Value

An instance of the .NET System.Drawing.Image class.

Remarks

This property is ignored if the picture is data-bound, that is, its DataField property is not empty. The image of the picture in this case is obtained from the data source.

See Also

Picture Members
Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture.ImageAlign Property

Picture.ImageAlign Property

Gets or sets the alignment of the displayed image.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public ImageAlign ImageAlign { get; set; }
Visual Basic

Public Property ImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration specifying the stretching and alignment of the displayed image. The default is Fit.

See Also

Picture Members
Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture.RotationAngle Property

Picture.RotationAngle Property

Gets or sets the rotation angle of the picture.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float RotationAngle { get; set; }
Visual Basic

Public Property RotationAngle As Single

Property Value

A float value specifying the rotation angle of the displayed image, in degrees.

See Also

Picture Members
Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart Class

PieChart Class

Represents a report item that can display pie charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class PieChart : Chart
Visual Basic

Public Class PieChart
Inherits Chart

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Chart
MindFusion.Reporting.PieChart

See Also

PieChart Members
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart Members

PieChart Members
Constructors Properties

Represents a report item that can display pie charts.

The following tables list the members exposed by the PieChart type.

Public Constructors

Name | Description
PieChart | Initializes a new instance of the PieChart class.

Public Properties

Name | Description
Data | Gets or sets the data for the chart.
DataField | Gets or sets the data for the chart.
DivisionCoef | Gets or sets the division coefficient for chart data.
DivisionLabel | Gets or sets the division label.
InnerLabelFormat | Gets or sets the format of the number drawn as a label inside the piece.
InnerLabelPosition | Gets or sets the position of the inner label.
InnerLabels | Gets or sets custom text for the inner labels of the chart.
InnerLabelsField | Gets or sets the database column, from which custom text for the inner labels is retrieved.
InnerLabelType | Gets or sets the type of the inner labels.
LabelPrefix | Gets or sets the prefix for chart labels.
LabelSuffix | Gets or sets the suffix for chart labels.
OuterLabelFormat | Gets or sets the format of the number drawn as a label outside the piece.
OuterLabels | Gets or sets custom text as outer labels.
OuterLabelsField | Gets or sets the database column, from which custom text for the outer labels is retrieved.
OuterLabelType | Gets or sets the type of the outer labels.
OutlinePen | Gets or sets the outline pen for the chart.
Pie3DTension | Gets or sets the tension for 3D charts.
Pie3DThickness | Gets or sets the thickness of 3D charts.
PieceOutIndex | Gets or sets the index of the detached chart piece.
PieceOutPercent | Gets or sets the distance, at which the detached piece is drawn as a percent from the radius length.
PieMargins | Gets or sets the margins for the chart.
PieType | Gets or sets the type of the chart.
PointerLength | Gets or sets the length of the pointer to the outer labels.
RadiusLength | Gets or sets the length of the chart radius.
StartAngle | Gets or sets the angle, at which drawing of pie pieces starts.

See Also

PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart Constructor

PieChart Constructor

Initializes a new instance of the PieChart class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PieChart ()
Visual Basic

Public Sub New ()

See Also

PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart Properties

PieChart Properties

Public Properties

Name | Description
Data | Gets or sets the data for the chart.
DataField | Gets or sets the data for the chart.
DivisionCoef | Gets or sets the division coefficient for chart data.
DivisionLabel | Gets or sets the division label.
InnerLabelFormat | Gets or sets the format of the number drawn as a label inside the piece.
InnerLabelPosition | Gets or sets the position of the inner label.
InnerLabels | Gets or sets custom text for the inner labels of the chart.
InnerLabelsField | Gets or sets the database column, from which custom text for the inner labels is retrieved.
InnerLabelType | Gets or sets the type of the inner labels.
LabelPrefix | Gets or sets the prefix for chart labels.
LabelSuffix | Gets or sets the suffix for chart labels.
OuterLabelFormat | Gets or sets the format of the number drawn as a label outside the piece.
OuterLabels | Gets or sets custom text as outer labels.
OuterLabelsField | Gets or sets the database column, from which custom text for the outer labels is retrieved.
OuterLabelType | Gets or sets the type of the outer labels.
OutlinePen | Gets or sets the outline pen for the chart.
Pie3DTension | Gets or sets the tension for 3D charts.
Pie3DThickness | Gets or sets the thickness of 3D charts.
PieceOutIndex | Gets or sets the index of the detached chart piece.
PieceOutPercent | Gets or sets the distance, at which the detached piece is drawn as a percent from the radius length.
PieMargins | Gets or sets the margins for the chart.
PieType | Gets or sets the type of the chart.
PointerLength | Gets or sets the length of the pointer to the outer labels.
RadiusLength | Gets or sets the length of the chart radius.
StartAngle | Gets or sets the angle, at which drawing of pie pieces starts.

See Also

PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.Data Property

PieChart.Data Property

Gets or sets the data for the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList Data { get; set; }
Visual Basic

Public Property Data As IList

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.DataField Property

PieChart.DataField Property

Gets or sets the data for the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string DataField { get; set; }
Visual Basic

Public Property DataField As String

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.DivisionCoef Property

PieChart.DivisionCoef Property

Gets or sets the division coefficient for chart data.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public double DivisionCoef { get; set; }
Visual Basic

Public Property DivisionCoef As Double

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.DivisionLabel Property

PieChart.DivisionLabel Property

Gets or sets the division label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string DivisionLabel { get; set; }
Visual Basic

Public Property DivisionLabel As String

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.InnerLabelFormat Property

PieChart.InnerLabelFormat Property

Gets or sets the format of the number drawn as a label inside the piece.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public NumberFormat InnerLabelFormat { get; set; }
Visual Basic

Public Property InnerLabelFormat As NumberFormat

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.InnerLabelPosition Property

PieChart.InnerLabelPosition Property

Gets or sets the position of the inner label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public int InnerLabelPosition { get; set; }
Visual Basic

Public Property InnerLabelPosition As Integer

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.InnerLabels Property

PieChart.InnerLabels Property

Gets or sets custom text for the inner labels of the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList InnerLabels { get; set; }
Visual Basic

Public Property InnerLabels As IList

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.InnerLabelsField Property

PieChart.InnerLabelsField Property

Gets or sets the database column, from which custom text for the inner labels is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string InnerLabelsField { get; set; }
Visual Basic

Public Property InnerLabelsField As String

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.InnerLabelType Property

PieChart.InnerLabelType Property

Gets or sets the type of the inner labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public LabelType InnerLabelType { get; set; }
Visual Basic

Public Property InnerLabelType As LabelType

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.LabelPrefix Property

PieChart.LabelPrefix Property

Gets or sets the prefix for chart labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string LabelPrefix { get; set; }
Visual Basic

Public Property LabelPrefix As String

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.LabelSuffix Property

PieChart.LabelSuffix Property

Gets or sets the suffix for chart labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string LabelSuffix { get; set; }
Visual Basic

Public Property LabelSuffix As String

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.OuterLabelFormat Property

PieChart.OuterLabelFormat Property

Gets or sets the format of the number drawn as a label outside the piece.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public NumberFormat OuterLabelFormat { get; set; }
Visual Basic

Public Property OuterLabelFormat As NumberFormat

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.OuterLabels Property

PieChart.OuterLabels Property

Gets or sets custom text as outer labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList OuterLabels { get; set; }
Visual Basic

Public Property OuterLabels As IList

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.OuterLabelsField Property

PieChart.OuterLabelsField Property

Gets or sets the database column, from which custom text for the outer labels is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string OuterLabelsField { get; set; }
Visual Basic

Public Property OuterLabelsField As String

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.OuterLabelType Property

PieChart.OuterLabelType Property

Gets or sets the type of the outer labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public LabelType OuterLabelType { get; set; }
Visual Basic

Public Property OuterLabelType As LabelType

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.OutlinePen Property

PieChart.OutlinePen Property

Gets or sets the outline pen for the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Pen OutlinePen { get; set; }
Visual Basic

Public Property OutlinePen As Pen

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.Pie3DTension Property

PieChart.Pie3DTension Property

Gets or sets the tension for 3D charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public int Pie3DTension { get; set; }
Visual Basic

Public Property Pie3DTension As Integer

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.Pie3DThickness Property

PieChart.Pie3DThickness Property

Gets or sets the thickness of 3D charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float Pie3DThickness { get; set; }
Visual Basic

Public Property Pie3DThickness As Single

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.PieceOutIndex Property

PieChart.PieceOutIndex Property

Gets or sets the index of the detached chart piece.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public int PieceOutIndex { get; set; }
Visual Basic

Public Property PieceOutIndex As Integer

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.PieceOutPercent Property

PieChart.PieceOutPercent Property

Gets or sets the distance, at which the detached piece is drawn as a percent from the radius length.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float PieceOutPercent { get; set; }
Visual Basic

Public Property PieceOutPercent As Single

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.PieMargins Property

PieChart.PieMargins Property

Gets or sets the margins for the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float PieMargins { get; set; }
Visual Basic

Public Property PieMargins As Single

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.PieType Property

PieChart.PieType Property

Gets or sets the type of the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PieType PieType { get; set; }
Visual Basic

Public Property PieType As PieType

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.PointerLength Property

PieChart.PointerLength Property

Gets or sets the length of the pointer to the outer labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float PointerLength { get; set; }
Visual Basic

Public Property PointerLength As Single

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.RadiusLength Property

PieChart.RadiusLength Property

Gets or sets the length of the chart radius.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float RadiusLength { get; set; }
Visual Basic

Public Property RadiusLength As Single

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.StartAngle Property

PieChart.StartAngle Property

Gets or sets the angle, at which drawing of pie pieces starts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float StartAngle { get; set; }
Visual Basic

Public Property StartAngle As Single

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart Class

RadarChart Class

Represents a report item that can display radar charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class RadarChart : Chart
Visual Basic

Public Class RadarChart
Inherits Chart

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Chart
MindFusion.Reporting.RadarChart

See Also

RadarChart Members
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart Members

RadarChart Members
Constructors Properties

Represents a report item that can display radar charts.

The following tables list the members exposed by the RadarChart type.

Public Constructors

Name | Description
RadarChart | Initializes a new instance of the RadarChart class.

Public Properties

Name | Description
AltAxesCount | Gets or sets the count of alternative radar axes.
AltAxesPens | Gets or sets the pens used for drawing the alternative radar axes.
Angles | Gets or sets the angles in polar charts.
Background3D | Gets or sets the background of 3D charts.
Data | Gets or sets the chart data.
DataFields | Gets or sets the database column, from which data for the chart is retrieved.
InnerAxisLabels | Gets or sets custom labels for the inner axis.
InnerAxisLabelsField | Gets or sets the database column, from which labels for the inner axis are retrieved.
InnerAxisLabelType | Gets or sets the type of the labels at the inner axis.
InnerAxisPen | Gets or sets the pen used for drawing the inner axis.
InnerAxisPosition | Gets or sets the position of the inner axis.
InnerLabelFormat | Gets or sets the format of numbers drawn as labels at the inner axis.
MaxValue | Gets or sets the maximum number at the inner axis.
MinValue | Gets or sets the minimum number at the inner axis.
OuterAxisLabels | Gets or sets custom labels at the outer axis.
OuterAxisLabelsField | Gets or sets the database column, from which labels for the outer axis are retrieved.
OuterAxisLabelType | Gets or sets the type of labels drawn at the outer axis.
OuterAxisPen | Gets or sets the pen used for drawing the outer axis.
OuterLabelFormat | Gets or sets the format of numbers drawn as labels at the outer axis.
OuterLabels | Gets or sets custom labels drawn in the middle of outer axis segments.
OuterLabelsField | Gets or sets the database column, from which labels at the chart segments are retrieved.
RadarStyle | Gets or sets the style of the radar chart.
RadarType | Gets or sets the type of the radar chart.
RadiusLength | Gets or sets the length of the radar radius.
SectionBrushes | Gets or sets the brushes for filling the radar sections.
SectionPoints | Gets or sets the points that mark the positions of radar background sections.
SegmentBrushes | Gets or sets the brushes for filling the radar segments.
ShapeBrushes | Gets or sets the brushes for filling the radar shapes.
ShapePens | Gets or sets the pens for drawing the radar shapes.
Shapes | Gets or sets the point shapes for radar charts.
ShapeSizes | Gets or sets the size of shapes for radar series.
Span | Gets or sets the numerical span between two adjacent intervals of the inner axis.
SpiderWeb | Gets or sets a value indicating whether the outer and alternative axes are drawn as spider web.

See Also

RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart Constructor

RadarChart Constructor

Initializes a new instance of the RadarChart class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public RadarChart ()
Visual Basic

Public Sub New ()

See Also

RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart Properties

RadarChart Properties

Public Properties

Name | Description
AltAxesCount | Gets or sets the count of alternative radar axes.
AltAxesPens | Gets or sets the pens used for drawing the alternative radar axes.
Angles | Gets or sets the angles in polar charts.
Background3D | Gets or sets the background of 3D charts.
Data | Gets or sets the chart data.
DataFields | Gets or sets the database column, from which data for the chart is retrieved.
InnerAxisLabels | Gets or sets custom labels for the inner axis.
InnerAxisLabelsField | Gets or sets the database column, from which labels for the inner axis are retrieved.
InnerAxisLabelType | Gets or sets the type of the labels at the inner axis.
InnerAxisPen | Gets or sets the pen used for drawing the inner axis.
InnerAxisPosition | Gets or sets the position of the inner axis.
InnerLabelFormat | Gets or sets the format of numbers drawn as labels at the inner axis.
MaxValue | Gets or sets the maximum number at the inner axis.
MinValue | Gets or sets the minimum number at the inner axis.
OuterAxisLabels | Gets or sets custom labels at the outer axis.
OuterAxisLabelsField | Gets or sets the database column, from which labels for the outer axis are retrieved.
OuterAxisLabelType | Gets or sets the type of labels drawn at the outer axis.
OuterAxisPen | Gets or sets the pen used for drawing the outer axis.
OuterLabelFormat | Gets or sets the format of numbers drawn as labels at the outer axis.
OuterLabels | Gets or sets custom labels drawn in the middle of outer axis segments.
OuterLabelsField | Gets or sets the database column, from which labels at the chart segments are retrieved.
RadarStyle | Gets or sets the style of the radar chart.
RadarType | Gets or sets the type of the radar chart.
RadiusLength | Gets or sets the length of the radar radius.
SectionBrushes | Gets or sets the brushes for filling the radar sections.
SectionPoints | Gets or sets the points that mark the positions of radar background sections.
SegmentBrushes | Gets or sets the brushes for filling the radar segments.
ShapeBrushes | Gets or sets the brushes for filling the radar shapes.
ShapePens | Gets or sets the pens for drawing the radar shapes.
Shapes | Gets or sets the point shapes for radar charts.
ShapeSizes | Gets or sets the size of shapes for radar series.
Span | Gets or sets the numerical span between two adjacent intervals of the inner axis.
SpiderWeb | Gets or sets a value indicating whether the outer and alternative axes are drawn as spider web.

See Also

RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.AltAxesCount Property

RadarChart.AltAxesCount Property

Gets or sets the count of alternative radar axes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public int AltAxesCount { get; set; }
Visual Basic

Public Property AltAxesCount As Integer

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.AltAxesPens Property

RadarChart.AltAxesPens Property

Gets or sets the pens used for drawing the alternative radar axes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenCollection AltAxesPens { get; set; }
Visual Basic

Public Property AltAxesPens As PenCollection

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.Angles Property

RadarChart.Angles Property

Gets or sets the angles in polar charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList Angles { get; set; }
Visual Basic

Public Property Angles As IList

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.Background3D Property

RadarChart.Background3D Property

Gets or sets the background of 3D charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Color Background3D { get; set; }
Visual Basic

Public Property Background3D As Color

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.Data Property

RadarChart.Data Property

Gets or sets the chart data.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList Data { get; set; }
Visual Basic

Public Property Data As IList

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.DataFields Property

RadarChart.DataFields Property

Gets or sets the database column, from which data for the chart is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string DataFields { get; set; }
Visual Basic

Public Property DataFields As String

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.InnerAxisLabels Property

RadarChart.InnerAxisLabels Property

Gets or sets custom labels for the inner axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList InnerAxisLabels { get; set; }
Visual Basic

Public Property InnerAxisLabels As IList

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.InnerAxisLabelsField Property

RadarChart.InnerAxisLabelsField Property

Gets or sets the database column, from which labels for the inner axis are retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string InnerAxisLabelsField { get; set; }
Visual Basic

Public Property InnerAxisLabelsField As String

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.InnerAxisLabelType Property

RadarChart.InnerAxisLabelType Property

Gets or sets the type of the labels at the inner axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public AxisLabelType InnerAxisLabelType { get; set; }
Visual Basic

Public Property InnerAxisLabelType As AxisLabelType

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.InnerAxisPen Property

RadarChart.InnerAxisPen Property

Gets or sets the pen used for drawing the inner axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Pen InnerAxisPen { get; set; }
Visual Basic

Public Property InnerAxisPen As Pen

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.InnerAxisPosition Property

RadarChart.InnerAxisPosition Property

Gets or sets the position of the inner axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Position InnerAxisPosition { get; set; }
Visual Basic

Public Property InnerAxisPosition As Position

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.InnerLabelFormat Property

RadarChart.InnerLabelFormat Property

Gets or sets the format of numbers drawn as labels at the inner axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public DataFormat InnerLabelFormat { get; set; }
Visual Basic

Public Property InnerLabelFormat As DataFormat

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.MaxValue Property

RadarChart.MaxValue Property

Gets or sets the maximum number at the inner axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public double MaxValue { get; set; }
Visual Basic

Public Property MaxValue As Double

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.MinValue Property

RadarChart.MinValue Property

Gets or sets the minimum number at the inner axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public double MinValue { get; set; }
Visual Basic

Public Property MinValue As Double

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.OuterAxisLabels Property

RadarChart.OuterAxisLabels Property

Gets or sets custom labels at the outer axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList OuterAxisLabels { get; set; }
Visual Basic

Public Property OuterAxisLabels As IList

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.OuterAxisLabelsField Property

RadarChart.OuterAxisLabelsField Property

Gets or sets the database column, from which labels for the outer axis are retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string OuterAxisLabelsField { get; set; }
Visual Basic

Public Property OuterAxisLabelsField As String

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.OuterAxisLabelType Property

RadarChart.OuterAxisLabelType Property

Gets or sets the type of labels drawn at the outer axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public AxisLabelType OuterAxisLabelType { get; set; }
Visual Basic

Public Property OuterAxisLabelType As AxisLabelType

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.OuterAxisPen Property

RadarChart.OuterAxisPen Property

Gets or sets the pen used for drawing the outer axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Pen OuterAxisPen { get; set; }
Visual Basic

Public Property OuterAxisPen As Pen

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.OuterLabelFormat Property

RadarChart.OuterLabelFormat Property

Gets or sets the format of numbers drawn as labels at the outer axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public DataFormat OuterLabelFormat { get; set; }
Visual Basic

Public Property OuterLabelFormat As DataFormat

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.OuterLabels Property

RadarChart.OuterLabels Property

Gets or sets custom labels drawn in the middle of outer axis segments.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList OuterLabels { get; set; }
Visual Basic

Public Property OuterLabels As IList

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.OuterLabelsField Property

RadarChart.OuterLabelsField Property

Gets or sets the database column, from which labels at the chart segments are retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string OuterLabelsField { get; set; }
Visual Basic

Public Property OuterLabelsField As String

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.RadarStyle Property

RadarChart.RadarStyle Property

Gets or sets the style of the radar chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public RadarStyle RadarStyle { get; set; }
Visual Basic

Public Property RadarStyle As RadarStyle

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.RadarType Property

RadarChart.RadarType Property

Gets or sets the type of the radar chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public RadarType RadarType { get; set; }
Visual Basic

Public Property RadarType As RadarType

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.RadiusLength Property

RadarChart.RadiusLength Property

Gets or sets the length of the radar radius.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public float RadiusLength { get; set; }
Visual Basic

Public Property RadiusLength As Single

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.SectionBrushes Property

RadarChart.SectionBrushes Property

Gets or sets the brushes for filling the radar sections.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BrushCollection SectionBrushes { get; set; }
Visual Basic

Public Property SectionBrushes As BrushCollection

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.SectionPoints Property

RadarChart.SectionPoints Property

Gets or sets the points that mark the positions of radar background sections.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList SectionPoints { get; set; }
Visual Basic

Public Property SectionPoints As IList

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.SegmentBrushes Property

RadarChart.SegmentBrushes Property

Gets or sets the brushes for filling the radar segments.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BrushCollection SegmentBrushes { get; set; }
Visual Basic

Public Property SegmentBrushes As BrushCollection

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.ShapeBrushes Property

RadarChart.ShapeBrushes Property

Gets or sets the brushes for filling the radar shapes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public BrushCollection ShapeBrushes { get; set; }
Visual Basic

Public Property ShapeBrushes As BrushCollection

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.ShapePens Property

RadarChart.ShapePens Property

Gets or sets the pens for drawing the radar shapes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PenCollection ShapePens { get; set; }
Visual Basic

Public Property ShapePens As PenCollection

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.Shapes Property

RadarChart.Shapes Property

Gets or sets the point shapes for radar charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList Shapes { get; set; }
Visual Basic

Public Property Shapes As IList

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.ShapeSizes Property

RadarChart.ShapeSizes Property

Gets or sets the size of shapes for radar series.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList ShapeSizes { get; set; }
Visual Basic

Public Property ShapeSizes As IList

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.Span Property

RadarChart.Span Property

Gets or sets the numerical span between two adjacent intervals of the inner axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public double Span { get; set; }
Visual Basic

Public Property Span As Double

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.SpiderWeb Property

RadarChart.SpiderWeb Property

Gets or sets a value indicating whether the outer and alternative axes are drawn as spider web.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool SpiderWeb { get; set; }
Visual Basic

Public Property SpiderWeb As Boolean

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report Class

Report Class
Remarks See Also

Serves as base class for all reports.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public class Report : Component
Visual Basic

Public Class Report
Inherits Component

Remarks

You can create new reports by instantiating from this class. New pages can be added to the report by creating Page objects and adding them to the collection returned by the report's Pages property. Report items are added to the Report indirectly by adding them to one of the pages contained in the report.

Creating reports in the Designer

An alternative (and much easier) way to create and design reports is to use the integrated MindFusion.Reporting Designer. In order to use the Designer, you need to create a custom class that derives from Report. A convenient way for creating custom report classes is by using the 'MindFusion Report' item template installed in Visual Studio with the MindFusion.Reporting package.

Note

If you create your custom report class manually, and you want this class to be designable, you need to ensure that the class provides a parameterless constructor and an InitializeComponent method, which should be called from the constructor.

Once the custom report class is created, double-click on it in the Solution Explorer in order to open the MindFusion.Reporting Designer and open the report.

For more information about the Designer and how to use it, check Report Designer.

Running the report

Once the report is initialized, you need to process it by calling its Run method. After the report has been processed it is ready to be used in various scenarios.

You can print the report by using a ReportPrinter object. You can open a preview of the report by using the PrintPreviewForm class. For details, check Printing and Print Previewing.

You can display the report on a Windows Form by using the ReportViewer control. For more information on how to do this, visit Displaying Reports on a Windows Form.

You can export the report to PDF or HTML by using the PdfExporter and HtmlExporter classes respectively. Check Exporting for more information.

Finally, you can manually layout the report and render its pages to any IGraphics object. To do this, call the Layout method of the Report class, then use the DrawPage method of the ReportLayout object returned as a result from the method.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.Report

See Also

Report Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Report Members

Report Members
Constructors Properties Methods Events

Serves as base class for all reports.

The following tables list the members exposed by the Report type.

Public Constructors

Name | Description
Report | Initializes a new instance of the Report class.

Public Properties

Name | Description
Font | Gets or sets the default font in the report.
MeasureUnit | Gets or sets the unit of the report measures.
Pages | Gets a collection with all report pages.

Public Methods

Name | Description
Layout | Layouts the report after it has been previously processed by a call to the Run method.
Run | Starts the report processing.

Protected Methods

Name | Description
OnReportRun | Fires the ReportRun event.

Public Events

Name | Description
ReportRun | Raised after the report has been processed.

See Also

Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report Constructor

Report Constructor

Initializes a new instance of the Report class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Report ()
Visual Basic

Public Sub New ()

See Also

Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report Methods

Report Methods

Public Methods

Name | Description
Layout | Layouts the report after it has been previously processed by a call to the Run method.
Run | Starts the report processing.

Protected Methods

Name | Description
OnReportRun | Fires the ReportRun event.

See Also

Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.Layout Method

Report.Layout Method

Layouts the report after it has been previously processed by a call to the Run method.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public ReportLayout Layout (
SizeF paperSize,
Margins margin,
PageOrientation defaultPageOrientation
)
Visual Basic

Public Function Layout ( _
paperSize As SizeF, _
margin As Margins, _
defaultPageOrientation As PageOrientation _
) As ReportLayout

Parameters

paperSize
The size of the report pages.
margin
The margin of the report pages.
defaultPageOrientation
The orientation to use for all pages which do not have an explicitly specified orientation. This value is used for all pages who have their PageOrientation property set to Unspecified.

Return Value

An instance of the ReportLayout class.

Remarks

This ReportLayout object, returned by this method contains information about the total number of pages in the final layout. It also provides means for obtaining the physical size of individual pages as well as the ability to render individual pages to an IGraphics object.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.OnReportRun Method

Report.OnReportRun Method

Fires the ReportRun event.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

protected virtual void OnReportRun (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnReportRun ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.Run Method

Report.Run Method

Starts the report processing.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public void Run ()
Visual Basic

Public Sub Run ()

Remarks

It is imperative to invoke this method after the report design has been completed and before the report is actually used. This method performs all necessary operations such as data-binding of report items, expression evaluation, and so on.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report Properties

Report Properties

Public Properties

Name | Description
Font | Gets or sets the default font in the report.
MeasureUnit | Gets or sets the unit of the report measures.
Pages | Gets a collection with all report pages.

See Also

Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.Font Property

Report.Font Property

Gets or sets the default font in the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public Font Font { get; set; }
Visual Basic

Public Property Font As Font

Property Value

A .NET Font object specifying the font for all report elements which have their Font property set to null (Nothing in Visual Basic). The defualt is a 10 point Arial font.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.MeasureUnit Property

Report.MeasureUnit Property

Gets or sets the unit of the report measures.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public GraphicsUnit MeasureUnit { get; set; }
Visual Basic

Public Property MeasureUnit As GraphicsUnit

Property Value

A member of the .NET GraphicsUnit enumeration specifying the units of measure in the report.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.Pages Property

Report.Pages Property

Gets a collection with all report pages.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public IList<Page> Pages { get; }
Visual Basic

Public ReadOnly Property Pages As IList(Of Page)

Property Value

An instance of an IList(Page) collection that contains all pages in the report.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report Events

Report Events

Public Events

Name | Description
ReportRun | Raised after the report has been processed.

See Also

Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.ReportRun Event

Report.ReportRun Event

Raised after the report has been processed.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public event EventHandler ReportRun
Visual Basic

Public Event ReportRun As EventHandler

Event Data

EndRenderReport event handlers receive an argument of type EventArgs.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem Class

ReportItem Class

Represents an abstract base class for all report elements.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public abstract class ReportItem : Component
Visual Basic

Public MustInherit Class ReportItem
Inherits Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Canvas
MindFusion.Reporting.Chart
MindFusion.Reporting.ControlWrapper
MindFusion.Reporting.DataRange
MindFusion.Reporting.Ellipse
MindFusion.Reporting.ItemContainer
MindFusion.Reporting.Label
MindFusion.Reporting.Line
MindFusion.Reporting.PageBreak
MindFusion.Reporting.Picture

See Also

ReportItem Members
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem Members

ReportItem Members
Constructors Properties

Represents an abstract base class for all report elements.

The following tables list the members exposed by the ReportItem type.

Protected Constructors

Name | Description
ReportItem | Initialize a new instance of the ReportItem class.

Public Properties

Name | Description
Location | Gets or sets the position of the item.
Name | Gets or sets the name of the report item.
Size | Gets or sets the size of the item.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order.
Visible | Gets or sets a value indicating whether the item will be printed in the report.

See Also

ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem Constructor

ReportItem Constructor

Initialize a new instance of the ReportItem class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

protected ReportItem ()
Visual Basic

Protected Sub New ()

See Also

ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem Properties

ReportItem Properties

Public Properties

Name | Description
Location | Gets or sets the position of the item.
Name | Gets or sets the name of the report item.
Size | Gets or sets the size of the item.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order.
Visible | Gets or sets a value indicating whether the item will be printed in the report.

See Also

ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem.Location Property

ReportItem.Location Property

Gets or sets the position of the item.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public virtual Location Location { get; set; }
Visual Basic

Public Overridable Property Location As Location

Property Value

A Location object specifyinf the position of the report item relative to its parent element.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting Namespace
Size Property


MindFusion.Reporting.ReportItem.Name Property

ReportItem.Name Property

Gets or sets the name of the report item.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public string Name { get; set; }
Visual Basic

Public Property Name As String

Property Value

A string specifying the name of the item.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem.Size Property

ReportItem.Size Property

Gets or sets the size of the item.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public virtual Dimension Size { get; set; }
Visual Basic

Public Overridable Property Size As Dimension

Property Value

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting Namespace
Location Property


MindFusion.Reporting.ReportItem.UseDesignOrder Property

ReportItem.UseDesignOrder Property

Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool UseDesignOrder { get; set; }
Visual Basic

Public Property UseDesignOrder As Boolean

Property Value

true to force the design-time order of the item to take precedence over the item's vertical position when determining the order in which the items are being laid out; otherwise, false. The default is false.

Remarks

When determining the order in which items are process during report layout, the following rules apply based on the value of this property:

Item1.UseDesignOrder | Item2.UseDesignOrder | Description
false | false | The vertical position of the items is considered when determining the layout order. The item with smaller y-coordinate is laid out first.
false | true | Item1 is laid out first.
true | false | Item2 is laid out first.
true | true | The design-time order of the items is considered when determining the items layout order. The item with smaller design-time order is laid out first.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem.Visible Property

ReportItem.Visible Property

Gets or sets a value indicating whether the item will be printed in the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public bool Visible { get; set; }
Visual Basic

Public Property Visible As Boolean

Property Value

true to print this item; otherwise, false. The default is true.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout Class

ReportLayout Class
Remarks See Also

Represents precalculated report layout.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public sealed class ReportLayout
Visual Basic

Public NotInheritable Class ReportLayout

Remarks

You cannot instantiate from this class directly. Instead, invoke the Layout method of an existing Report object, which has been previously processed by a call to its Run method. The ReportLayout objects encapsulate the layout of the report, that is, the page split up and the position of individual report items.

Once you obtain a ReportLayout object you can perform several operations on it. The PageCount property returns the total number of pages in the layout. Individual pages can be rendered to an IGraphics object by calling the DrawPage method. The orientation and physical size of a page can be obtained through the GetPageOrientation and GetPageSize methods respectively.

Example

The following example creates a ReportLayout from an existing report and renders its 10th page to a GDI+ Graphics object. The example assumes that report1 is a variable identifying an existing Report, which has been previously processed through a call to its Run method and that graphics is a variable identifying existing GDI+ Graphics.

C#

// Layout the report
ReportLayout layout = report1.Layout(new SizeF(210, 297), new Margins(20), PageOrientation.Portrait);

// Create the drawing context and the target IGraphics
DrawContext context = new DrawContext(report1);
GdiGraphics target = new GdiGraphics(graphics);

// Draw the page
layout.DrawPage(target, 9, context);
Visual Basic

' Layout the report
Dim layout As New ReportLayout = report1.Layout(New SizeF(210, 297), New Margins(20), PageOrientation.Portrait)

' Create the drawing context and the target IGraphics
Dim context As New DrawContext(report1)
Dim target As New GdiGraphics(graphics)

' Draw the page
layout.DrawPage(target, 9, context)

Inheritance Hierarchy

System.Object
MindFusion.Reporting.ReportLayout

See Also

ReportLayout Members
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout Members

ReportLayout Members
Properties Methods

Represents precalculated report layout.

The following tables list the members exposed by the ReportLayout type.

Public Properties

Name | Description
PageCount | Gets the number of pages within the layout.

Public Methods

Name | Description
DrawPage | Renders the page with the specified 0-based index to the specified IGraphics object.
GetPageOrientation | Returns the orientation of the page with the specified 0-based index.
GetPageSize | Returns the size of the page with the specified 0-based index. The returned value indicates the paper size of the page, including padding, margin and content.

See Also

ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout Methods

ReportLayout Methods

Public Methods

Name | Description
DrawPage | Renders the page with the specified 0-based index to the specified IGraphics object.
GetPageOrientation | Returns the orientation of the page with the specified 0-based index.
GetPageSize | Returns the size of the page with the specified 0-based index. The returned value indicates the paper size of the page, including padding, margin and content.

See Also

ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout.DrawPage Method

ReportLayout.DrawPage Method

Renders the page with the specified 0-based index to the specified IGraphics object.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public void DrawPage (
IGraphics graphics,
int pageIndex,
DrawContext context
)
Visual Basic

Public Sub DrawPage ( _
graphics As IGraphics, _
pageIndex As Integer, _
context As DrawContext _
)

Parameters

graphics
The IGraphics object to render to page to.
pageIndex
The 0-based index of the page to render. If the index is less than 0 or greater or equal to the number of available pages, an IndexOutOfRangeException is thrown.
context
A DrawContext object.

Example

The following example creates a ReportLayout from an existing report and renders its 10th page to a GDI+ Graphics object. The example assumes that report1 is a variable identifying an existing Report, which has been previously processed through a call to its Run method and that graphics is a variable identifying existing GDI+ Graphics.

C#

// Layout the report
ReportLayout layout = report1.Layout(new SizeF(210, 297), new Margins(20), PageOrientation.Portrait);

// Create the drawing context and the target IGraphics
DrawContext context = new DrawContext(report1);
GdiGraphics target = new GdiGraphics(graphics);

// Draw the page
layout.DrawPage(target, 9, context);
Visual Basic

' Layout the report
Dim layout As New ReportLayout = report1.Layout(New SizeF(210, 297), New Margins(20), PageOrientation.Portrait)

' Create the drawing context and the target IGraphics
Dim context As New DrawContext(report1)
Dim target As New GdiGraphics(graphics)

' Draw the page
layout.DrawPage(target, 9, context)

See Also

ReportLayout Members
ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout.GetPageOrientation Method

ReportLayout.GetPageOrientation Method

Returns the orientation of the page with the specified 0-based index.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public PageOrientation GetPageOrientation (
int pageIndex
)
Visual Basic

Public Function GetPageOrientation ( _
pageIndex As Integer _
) As PageOrientation

Parameters

pageIndex
The 0-based index of the page. If the index is less than 0 or greater or equal to the number of available pages, an IndexOutOfRangeException is thrown.

Return Value

A member of the PageOrientation enumeration specifying the actual orientation of the page with the specified index.

See Also

ReportLayout Members
ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout.GetPageSize Method

ReportLayout.GetPageSize Method

Returns the size of the page with the specified 0-based index. The returned value indicates the paper size of the page, including padding, margin and content.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public SizeF GetPageSize (
int pageIndex
)
Visual Basic

Public Function GetPageSize ( _
pageIndex As Integer _
) As SizeF

Parameters

pageIndex
The 0-based index of the page. If the index is less than 0 or greater or equal to the number of available pages, an IndexOutOfRangeException is thrown.

Return Value

A .NET SizeF object specifying the page size.

See Also

ReportLayout Members
ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout Properties

ReportLayout Properties

Public Properties

Name | Description
PageCount | Gets the number of pages within the layout.

See Also

ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout.PageCount Property

ReportLayout.PageCount Property

Gets the number of pages within the layout.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C#

public int PageCount { get; }
Visual Basic

Public ReadOnly Property PageCount As Integer

Property Value

An integer value specifying the number of pages in the layout.

See Also

ReportLayout Members
ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Export Namespace
Classes

Classes

Class | Description
HtmlExporter | Exports MindFusion reports to HTML files.
MetaTagNames | Provides common HTML meta-tag names.
PdfExporter | Exports MindFusion reports to Adobe Portable Document Format (PDF) files.
RenderHtmlEventArgs | Provides information to various rendering events of the HtmlExporter, such as BeginRenderHead, EndRenderHead, and so on.


MindFusion.Reporting.Export.HtmlExporter Class

HtmlExporter Class
Remarks See Also

Exports MindFusion reports to HTML files.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public class HtmlExporter
Visual Basic

Public Class HtmlExporter

Remarks

For more information on how to use the HtmlExporter, check Exporting.

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Export.HtmlExporter

See Also

HtmlExporter Members
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter Members

HtmlExporter Members
Constructors Properties Methods Events

Exports MindFusion reports to HTML files.

The following tables list the members exposed by the HtmlExporter type.

Public Constructors

Name | Description
HtmlExporter | Initializes a new instance of the HtmlExporter class.

Public Properties

Name | Description
EmbedImages | Gets or sets a value indicating whether to embed images in the HTML or copy them in a specified directory.
ImageFolder | Gets or sets the directory where the images referenced in the HTML should be copied.
MetaTags | Gets a list with the names and values of the meta-tags to be included in the resulting HTML.
Title | Gets or sets the title of the resulting HTML.

Public Methods

Name | Description
Export | Overloaded. Exports the specified report as an HTML. The contents are written either to a file or to a specified StringBuilder object.

Protected Methods

Name | Description
OnBeginRenderHead | Fires the BeginRenderHead event.
OnBeginRenderReport | Fires the BeginRenderReport event.
OnEndRenderHead | Fires the EndRenderHead event.
OnEndRenderReport | Fires the EndRenderReport event.

Public Events

Name | Description
BeginRenderHead | Raised before the <head> tag contents are being rendered, but after the tag itself has been appended.
BeginRenderReport | Raised within the <body> right before rendering the report.
EndRenderHead | Raised after the <head> tag contents are being rendered, but before the closing tag has been appended.
EndRenderReport | Raised within the <body> right after rendering the report.

See Also

HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter Constructor

HtmlExporter Constructor

Initializes a new instance of the HtmlExporter class.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public HtmlExporter ()
Visual Basic

Public Sub New ()

See Also

HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter Methods

HtmlExporter Methods

Public Methods

Name | Description
Export | Overloaded. Exports the specified report as an HTML. The contents are written either to a file or to a specified StringBuilder object.

Protected Methods

Name | Description
OnBeginRenderHead | Fires the BeginRenderHead event.
OnBeginRenderReport | Fires the BeginRenderReport event.
OnEndRenderHead | Fires the EndRenderHead event.
OnEndRenderReport | Fires the EndRenderReport event.

See Also

HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter.Export Method

HtmlExporter.Export Method

Exports the specified report as an HTML. The contents are written either to a file or to a specified StringBuilder object.

Overload List

Name | Description
HtmlExporter.Export (Report, String) | Creates an HTML file representing the specified report.
HtmlExporter.Export (Report, StringBuilder, String) | Exports the specified report as an HTML.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter.Export Method (Report, String)

HtmlExporter.Export Method (Report, String)
See Also

Creates an HTML file representing the specified report.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public void Export (
Report report,
string filePath
)
Visual Basic

Public Sub Export ( _
report As Report, _
filePath As String _
)

Parameters

report
A reference to the report that will be exported.
filePath
The full path to the HTML file.

Example

The following example creates an instance of the HtmlExporter class and uses it to export an existing Report object. The Report is identified by the report1 variable.

C#

HtmlExporter exporter = new HtmlExporter();

exporter.Title = "My report";
exporter.EmbedImages = false;
exporter.ImageFolder = "Images";

exporter.Export(report1, @"c:\MyReport.htm");
Visual Basic

Dim Exporter As New HtmlExporter()

exporter.Title = "My report"
exporter.EmbedImages = False
exporter.ImageFolder = "Images"

exporter.Export(report1, "c:\MyReport.htm")

See Also

Export Method Overload List
HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter.Export Method (Report, StringBuilder, String)

HtmlExporter.Export Method (Report, StringBuilder, String)
See Also

Exports the specified report as an HTML.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public void Export (
Report report,
StringBuilder target,
string rootFolder
)
Visual Basic

Public Sub Export ( _
report As Report, _
target As StringBuilder, _
rootFolder As String _
)

Parameters

report
A reference to the report that will be exported.
target
The destination StringBuilder where the report contents will be rendered.
rootFolder
The folder of the target HTML. If images are not embedded and ImageFolder is a relative path, this parameter is used as a root.

Remarks

This method neither raises events nor uses any of the HTML-related properties of the HtmlExporter class. Check the individual property remarks for details.

See Also

Export Method Overload List
HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter.OnBeginRenderHead Method

HtmlExporter.OnBeginRenderHead Method

Fires the BeginRenderHead event.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

protected virtual void OnBeginRenderHead (
RenderHtmlEventArgs e
)
Visual Basic

Protected Overridable Sub OnBeginRenderHead ( _
e As RenderHtmlEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter.OnBeginRenderReport Method

HtmlExporter.OnBeginRenderReport Method

Fires the BeginRenderReport event.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

protected virtual void OnBeginRenderReport (
RenderHtmlEventArgs e
)
Visual Basic

Protected Overridable Sub OnBeginRenderReport ( _
e As RenderHtmlEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter.OnEndRenderHead Method

HtmlExporter.OnEndRenderHead Method

Fires the EndRenderHead event.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

protected virtual void OnEndRenderHead (
RenderHtmlEventArgs e
)
Visual Basic

Protected Overridable Sub OnEndRenderHead ( _
e As RenderHtmlEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter.OnEndRenderReport Method

HtmlExporter.OnEndRenderReport Method

Fires the EndRenderReport event.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

protected virtual void OnEndRenderReport (
RenderHtmlEventArgs e
)
Visual Basic

Protected Overridable Sub OnEndRenderReport ( _
e As RenderHtmlEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter Properties

HtmlExporter Properties

Public Properties

Name | Description
EmbedImages | Gets or sets a value indicating whether to embed images in the HTML or copy them in a specified directory.
ImageFolder | Gets or sets the directory where the images referenced in the HTML should be copied.
MetaTags | Gets a list with the names and values of the meta-tags to be included in the resulting HTML.
Title | Gets or sets the title of the resulting HTML.

See Also

HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter.EmbedImages Property

HtmlExporter.EmbedImages Property

Gets or sets a value indicating whether to embed images in the HTML or copy them in a specified directory.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public bool EmbedImages { get; set; }
Visual Basic

Public Property EmbedImages As Boolean

Property Value

true, to embed the report images in the resulting HTML file; false, to copy the images to the folder specified through the ImageFolder property. The default is true.

Remarks

This property is ignored when exporting directly to a StringBuilder. In this case, the images are always embedded in the resulting HTML.

Note

Not all browsers can handle embedded images. Make sure the target browser supports them when using the EmbedImages property.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace
ImageFolder Property


MindFusion.Reporting.Export.HtmlExporter.ImageFolder Property

HtmlExporter.ImageFolder Property

Gets or sets the directory where the images referenced in the HTML should be copied.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public string ImageFolder { get; set; }
Visual Basic

Public Property ImageFolder As String

Property Value

A string value specifying the directory where the report images should be copied. The default is an empty string.

Remarks

This property is ignored when exporting directly to a StringBuilder. This property is also ignored when EmbedImages is set to true, indicating that the images are embedded directly in the resulting HTML.

Note

This property can contain an incomplete path. In this case, the path is interpreted as relative to the directory containing the resulting HTML.

If the property value is an empty string, the images will be copied to the directory containing the resulting HTML.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace
EmbedImages Property


MindFusion.Reporting.Export.HtmlExporter.MetaTags Property

HtmlExporter.MetaTags Property

Gets a list with the names and values of the meta-tags to be included in the resulting HTML.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public SortedList<string, string> MetaTags { get; }
Visual Basic

Public ReadOnly Property MetaTags As SortedList(Of String, String)

Property Value

An instance of a string-to-string map containing the names and values of the meta tags to be included in the <head> of the resulting HTML.

Remarks

This property is ignored when exporting directly to a StringBuilder.

For each entry in this map a meta tag with the following structure is generated in the resulting HTML:

<meta name="key" content="value">

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter.Title Property

HtmlExporter.Title Property

Gets or sets the title of the resulting HTML.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public string Title { get; set; }
Visual Basic

Public Property Title As String

Property Value

A string value specifying the HTML title. The default is an empty string.

Remarks

This property is ignored when exporting directly to a StringBuilder.

If the value of this property is an empty string, the name of the resulting HTML file is used as a title.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter Events

HtmlExporter Events

Public Events

Name | Description
BeginRenderHead | Raised before the <head> tag contents are being rendered, but after the tag itself has been appended.
BeginRenderReport | Raised within the <body> right before rendering the report.
EndRenderHead | Raised after the <head> tag contents are being rendered, but before the closing tag has been appended.
EndRenderReport | Raised within the <body> right after rendering the report.

See Also

HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter.BeginRenderHead Event

HtmlExporter.BeginRenderHead Event

Raised before the <head> tag contents are being rendered, but after the tag itself has been appended.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public event EventHandler<RenderHtmlEventArgs> BeginRenderHead
Visual Basic

Public Event BeginRenderHead As EventHandler(Of RenderHtmlEventArgs)

Event Data

BeginRenderHead event handlers receive an argument of type RenderHtmlEventArgs.

Remarks

This event is raised when exporting a report through the Export method. It enables clients to write custom contents in the beginning of the <head> section of the exported HTML file.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace
EndRenderHead Event


MindFusion.Reporting.Export.HtmlExporter.BeginRenderReport Event

HtmlExporter.BeginRenderReport Event

Raised within the <body> right before rendering the report.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public event EventHandler<RenderHtmlEventArgs> BeginRenderReport
Visual Basic

Public Event BeginRenderReport As EventHandler(Of RenderHtmlEventArgs)

Event Data

BeginRenderReport event handlers receive an argument of type RenderHtmlEventArgs.

Remarks

This event is raised when exporting a report through the Export method. It enables clients to write custom contents in the beginning of the <body> section of the exported HTML file.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace
EndRenderReport Event


MindFusion.Reporting.Export.HtmlExporter.EndRenderHead Event

HtmlExporter.EndRenderHead Event

Raised after the <head> tag contents are being rendered, but before the closing tag has been appended.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public event EventHandler<RenderHtmlEventArgs> EndRenderHead
Visual Basic

Public Event EndRenderHead As EventHandler(Of RenderHtmlEventArgs)

Event Data

BeginRenderReport event handlers receive an argument of type RenderHtmlEventArgs.

Remarks

This event is raised when exporting a report through the Export method. It enables clients to write custom contents at the end of the <head> section of the exported HTML file.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace
BeginRenderHead Event


MindFusion.Reporting.Export.HtmlExporter.EndRenderReport Event

HtmlExporter.EndRenderReport Event

Raised within the <body> right after rendering the report.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public event EventHandler<RenderHtmlEventArgs> EndRenderReport
Visual Basic

Public Event EndRenderReport As EventHandler(Of RenderHtmlEventArgs)

Event Data

EndRenderReport event handlers receive an argument of type RenderHtmlEventArgs.

Remarks

This event is raised when exporting a report through the Export method. It enables clients to write custom contents at the end of the <body> section of the exported HTML file.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace
BeginRenderReport Event


MindFusion.Reporting.Export.MetaTagNames Class

MetaTagNames Class

Provides common HTML meta-tag names.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public sealed class MetaTagNames
Visual Basic

Public NotInheritable Class MetaTagNames

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Export.MetaTagNames

See Also

MetaTagNames Members
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames Members

MetaTagNames Members
Fields

Provides common HTML meta-tag names.

The following tables list the members exposed by the MetaTagNames type.

Public Fields

Name | Description
Abstract | The "abstract" tag. It defines a secondary description.
Author | The "author" tag. Records the name of the author of the document.
Classification | The "classification" tag. It classifies the site into the appropriate category.
Copyright | The "copyright" tag. Used to include copyright information in the document.
Description | The "description" tag. Some search engines pick up this description to show with the results of searches.
Distribution | The "distribution" tag. Declares whether a document is available to the web or on an intranet. Possible content values are "Global", "Local", "IU".
DocClass | The "doc-class" tag. Indicates completion status of a document. Possible values are "Completed", "Draft", "Living Document", "Published".
DocRights | The "doc-rights" tag. Indicates copyright status of document. Possible values are "Copywritten Work", "Private", "Public", "Public Domain".
DocType | The "doc-type" tag. Specifies type of document. Possible content values are "Confidential Company Papers", "eZine", "Government", "Journal", "Manuscript", "Paper", "Private", "Public", "Web Page", "White Paper".
Expires | The "expires" tag. Expiration date of the document.
Generator | The "generator" tag. The name of the program that created the document.
Googlebot | The "googlebot" tag. Define pages to be excluded from googlebot indexing. Possible content values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "nosnippet", "noarchive".
Keywords | The "keywords" tag. Informs search engines what your web site or page is about.
MSSmartTagsPreventParsing | The "MSSmartTagsPreventParsing" tag. Use this tag to prevent any Microsoft product from automatically generating smart tags. Possible content value is "TRUE".
Owner | The "owner" tag. Define the owner of the page or site.
ProgId | The "progid" tag.
Rating | The "rating" tag. A simple rating for a site.
Refresh | The "refresh" tag. Indicates that the document is displayed for a specified time before switching to a new URL. The content value should be in the format "n;url", where "n" is the number of seconds to wait before loading the URL specified by "url".
ReplyTo | The "reply-to" tag. Email address of contact for document.
ResourceType | The "resource-type" tag. Indicates the type of web resource. Possible content value is "document".
RevisitAfter | The "revisit-after" tag. Defines how often search engine spiders should revisit your site.
Robots | The "robots" tag. Defines pages to be excluded from robot indexing. Possible values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "noimageindex".

See Also

MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames Fields

MetaTagNames Fields

Public Fields

Name | Description
Abstract | The "abstract" tag. It defines a secondary description.
Author | The "author" tag. Records the name of the author of the document.
Classification | The "classification" tag. It classifies the site into the appropriate category.
Copyright | The "copyright" tag. Used to include copyright information in the document.
Description | The "description" tag. Some search engines pick up this description to show with the results of searches.
Distribution | The "distribution" tag. Declares whether a document is available to the web or on an intranet. Possible content values are "Global", "Local", "IU".
DocClass | The "doc-class" tag. Indicates completion status of a document. Possible values are "Completed", "Draft", "Living Document", "Published".
DocRights | The "doc-rights" tag. Indicates copyright status of document. Possible values are "Copywritten Work", "Private", "Public", "Public Domain".
DocType | The "doc-type" tag. Specifies type of document. Possible content values are "Confidential Company Papers", "eZine", "Government", "Journal", "Manuscript", "Paper", "Private", "Public", "Web Page", "White Paper".
Expires | The "expires" tag. Expiration date of the document.
Generator | The "generator" tag. The name of the program that created the document.
Googlebot | The "googlebot" tag. Define pages to be excluded from googlebot indexing. Possible content values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "nosnippet", "noarchive".
Keywords | The "keywords" tag. Informs search engines what your web site or page is about.
MSSmartTagsPreventParsing | The "MSSmartTagsPreventParsing" tag. Use this tag to prevent any Microsoft product from automatically generating smart tags. Possible content value is "TRUE".
Owner | The "owner" tag. Define the owner of the page or site.
ProgId | The "progid" tag.
Rating | The "rating" tag. A simple rating for a site.
Refresh | The "refresh" tag. Indicates that the document is displayed for a specified time before switching to a new URL. The content value should be in the format "n;url", where "n" is the number of seconds to wait before loading the URL specified by "url".
ReplyTo | The "reply-to" tag. Email address of contact for document.
ResourceType | The "resource-type" tag. Indicates the type of web resource. Possible content value is "document".
RevisitAfter | The "revisit-after" tag. Defines how often search engine spiders should revisit your site.
Robots | The "robots" tag. Defines pages to be excluded from robot indexing. Possible values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "noimageindex".

See Also

MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Abstract Field

MetaTagNames.Abstract Field

The "abstract" tag. It defines a secondary description.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Abstract
Visual Basic

Public Shared Abstract As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Author Field

MetaTagNames.Author Field

The "author" tag. Records the name of the author of the document.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Author
Visual Basic

Public Shared Author As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Classification Field

MetaTagNames.Classification Field

The "classification" tag. It classifies the site into the appropriate category.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Classification
Visual Basic

Public Shared Classification As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Copyright Field

MetaTagNames.Copyright Field

The "copyright" tag. Used to include copyright information in the document.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Copyright
Visual Basic

Public Shared Copyright As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Description Field

MetaTagNames.Description Field

The "description" tag. Some search engines pick up this description to show with the results of searches.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Description
Visual Basic

Public Shared Description As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Distribution Field

MetaTagNames.Distribution Field

The "distribution" tag. Declares whether a document is available to the web or on an intranet. Possible content values are "Global", "Local", "IU".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Distribution
Visual Basic

Public Shared Distribution As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.DocClass Field

MetaTagNames.DocClass Field

The "doc-class" tag. Indicates completion status of a document. Possible values are "Completed", "Draft", "Living Document", "Published".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string DocClass
Visual Basic

Public Shared DocClass As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.DocRights Field

MetaTagNames.DocRights Field

The "doc-rights" tag. Indicates copyright status of document. Possible values are "Copywritten Work", "Private", "Public", "Public Domain".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string DocRights
Visual Basic

Public Shared DocRights As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.DocType Field

MetaTagNames.DocType Field

The "doc-type" tag. Specifies type of document. Possible content values are "Confidential Company Papers", "eZine", "Government", "Journal", "Manuscript", "Paper", "Private", "Public", "Web Page", "White Paper".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string DocType
Visual Basic

Public Shared DocType As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Expires Field

MetaTagNames.Expires Field

The "expires" tag. Expiration date of the document.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Expires
Visual Basic

Public Shared Expires As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Generator Field

MetaTagNames.Generator Field

The "generator" tag. The name of the program that created the document.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Generator
Visual Basic

Public Shared Generator As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Googlebot Field

MetaTagNames.Googlebot Field

The "googlebot" tag. Define pages to be excluded from googlebot indexing. Possible content values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "nosnippet", "noarchive".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Googlebot
Visual Basic

Public Shared Googlebot As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Keywords Field

MetaTagNames.Keywords Field

The "keywords" tag. Informs search engines what your web site or page is about.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Keywords
Visual Basic

Public Shared Keywords As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.MSSmartTagsPreventParsing Field

MetaTagNames.MSSmartTagsPreventParsing Field

The "MSSmartTagsPreventParsing" tag. Use this tag to prevent any Microsoft product from automatically generating smart tags. Possible content value is "TRUE".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string MSSmartTagsPreventParsing
Visual Basic

Public Shared MSSmartTagsPreventParsing As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Owner Field

MetaTagNames.Owner Field

The "owner" tag. Define the owner of the page or site.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Owner
Visual Basic

Public Shared Owner As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.ProgId Field

MetaTagNames.ProgId Field

The "progid" tag.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string ProgId
Visual Basic

Public Shared ProgId As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Rating Field

MetaTagNames.Rating Field

The "rating" tag. A simple rating for a site.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Rating
Visual Basic

Public Shared Rating As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Refresh Field

MetaTagNames.Refresh Field

The "refresh" tag. Indicates that the document is displayed for a specified time before switching to a new URL. The content value should be in the format "n;url", where "n" is the number of seconds to wait before loading the URL specified by "url".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Refresh
Visual Basic

Public Shared Refresh As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.ReplyTo Field

MetaTagNames.ReplyTo Field

The "reply-to" tag. Email address of contact for document.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string ReplyTo
Visual Basic

Public Shared ReplyTo As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.ResourceType Field

MetaTagNames.ResourceType Field

The "resource-type" tag. Indicates the type of web resource. Possible content value is "document".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string ResourceType
Visual Basic

Public Shared ResourceType As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.RevisitAfter Field

MetaTagNames.RevisitAfter Field

The "revisit-after" tag. Defines how often search engine spiders should revisit your site.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string RevisitAfter
Visual Basic

Public Shared RevisitAfter As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Robots Field

MetaTagNames.Robots Field

The "robots" tag. Defines pages to be excluded from robot indexing. Possible values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "noimageindex".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public static string Robots
Visual Basic

Public Shared Robots As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter Class

PdfExporter Class

Exports MindFusion reports to Adobe Portable Document Format (PDF) files.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Pdf

Syntax

C#

public class PdfExporter
Visual Basic

Public Class PdfExporter

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Export.PdfExporter

See Also

PdfExporter Members
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter Members

PdfExporter Members
Constructors Properties Methods

Exports MindFusion reports to Adobe Portable Document Format (PDF) files.

The following tables list the members exposed by the PdfExporter type.

Public Constructors

Name | Description
PdfExporter | Initializes a new instance of the PdfExporter class.

Public Properties

Name | Description
Margins | Gets or sets the margins for the PDF pages.
PageOrientation | Gets or sets page orientation that is set to the resulting PDF pages.
PageSize | Gets or sets PDF page size.

Public Methods

Name | Description
Export | Creates a PDF file representing the specified report.

See Also

PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter Constructor

PdfExporter Constructor

Initializes a new instance of the PdfExporter class.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Pdf

Syntax

C#

public PdfExporter ()
Visual Basic

Public Sub New ()

See Also

PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter Methods

PdfExporter Methods

Public Methods

Name | Description
Export | Creates a PDF file representing the specified report.

See Also

PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter.Export Method

PdfExporter.Export Method

Creates a PDF file representing the specified report.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Pdf

Syntax

C#

public void Export (
Report report,
string filePath
)
Visual Basic

Public Sub Export ( _
report As Report, _
filePath As String _
)

Parameters

report
A reference to the report that will be exported.
filePath
The full path to the PDF file.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter Properties

PdfExporter Properties

Public Properties

Name | Description
Margins | Gets or sets the margins for the PDF pages.
PageOrientation | Gets or sets page orientation that is set to the resulting PDF pages.
PageSize | Gets or sets PDF page size.

See Also

PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter.Margins Property

PdfExporter.Margins Property

Gets or sets the margins for the PDF pages.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Pdf

Syntax

C#

public Margins Margins { get; set; }
Visual Basic

Public Property Margins As Margins

Property Value

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter.PageOrientation Property

PdfExporter.PageOrientation Property

Gets or sets page orientation that is set to the resulting PDF pages.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Pdf

Syntax

C#

public PageOrientation PageOrientation { get; set; }
Visual Basic

Public Property PageOrientation As PageOrientation

Property Value

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter.PageSize Property

PdfExporter.PageSize Property

Gets or sets PDF page size.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Pdf

Syntax

C#

public PageSize PageSize { get; set; }
Visual Basic

Public Property PageSize As PageSize

Property Value

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.RenderHtmlEventArgs Class

RenderHtmlEventArgs Class

Provides information to various rendering events of the HtmlExporter, such as BeginRenderHead, EndRenderHead, and so on.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public class RenderHtmlEventArgs : EventArgs
Visual Basic

Public Class RenderHtmlEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Reporting.Export.RenderHtmlEventArgs

See Also

RenderHtmlEventArgs Members
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.RenderHtmlEventArgs Members

RenderHtmlEventArgs Members
Properties

Provides information to various rendering events of the HtmlExporter, such as BeginRenderHead, EndRenderHead, and so on.

The following tables list the members exposed by the RenderHtmlEventArgs type.

Public Properties

Name | Description
Target | Gets the rendering target.

See Also

RenderHtmlEventArgs Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.RenderHtmlEventArgs Properties

RenderHtmlEventArgs Properties

Public Properties

Name | Description
Target | Gets the rendering target.

See Also

RenderHtmlEventArgs Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.RenderHtmlEventArgs.Target Property

RenderHtmlEventArgs.Target Property

Gets the rendering target.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C#

public StringBuilder Target { get; }
Visual Basic

Public ReadOnly Property Target As StringBuilder

Property Value

An instance of the .NET StringBuilder class. Use this object to render the custom HTML contents to.

See Also

RenderHtmlEventArgs Members
RenderHtmlEventArgs Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.WinForms Namespace
Classes

Classes

Class | Description
PreviewOptions | Provides properties that allow customization of various aspects of the extended print-preview window.
PrintPreviewForm | Implements an extended print preview form.
ReportCanvas | Represents a control that can display a MindFusion.Reporting.Report object.
ReportPrinter | Serves as a PrintDocument for MindFusion.Reporting.Report components.
ReportViewer | Represents a scrollable control that can display a MindFusion.Reporting.Report objects.
ScrollViewer | Represents a control that can host another control and provide scrolling capabilities if the hosted control is larger than the client area.


MindFusion.Reporting.WinForms.PreviewOptions Class

PreviewOptions Class

Provides properties that allow customization of various aspects of the extended print-preview window.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public sealed class PreviewOptions
Visual Basic

Public NotInheritable Class PreviewOptions

Inheritance Hierarchy

System.Object
MindFusion.Reporting.WinForms.PreviewOptions

See Also

PreviewOptions Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions Members

PreviewOptions Members
Constructors Properties

Provides properties that allow customization of various aspects of the extended print-preview window.

The following tables list the members exposed by the PreviewOptions type.

Public Constructors

Name | Description
PreviewOptions | Initializes a new instance of the PreviewOptions class.

Public Properties

Name | Description
ButtonImages | Gets or sets the list of images to display in print preview toolbar buttons.
DisplayPrintDialog | Get or sets a value indicating whether a print setup dialog box is displayed when the print button of the preview form is clicked.
FirstPageToolTip | Gets or sets the ToolTip text displayed for the First Page button.
FitToPageToolTip | Gets or sets the ToolTip text displayed for the Fit to Page button.
FourPagesToolTip | Gets or sets the ToolTip text displayed for the Four Pages button.
LandscapeToolTip | Gets or sets the ToolTip text displayed for the Landscape button.
LastPageToolTip | Gets or sets the ToolTip text displayed for the Last Page button.
NextPageToolTip | Gets or sets the ToolTip text displayed for the Next Page button.
OnePageToolTip | Gets or sets the ToolTip text displayed for the One Page button.
PortraitToolTip | Gets or sets the ToolTip text displayed for the Portrait button.
PreviousPageToolTip | Gets or sets the ToolTip text displayed for the Previous Page button.
PrintToolTip | Gets or sets the ToolTip text displayed for the Print button.
SixPagesToolTip | Gets or sets the ToolTip text displayed for the Six Pages button.
ThreePagesToolTip | Gets or sets the ToolTip text displayed for the Three Pages button.
TitleBarIcon | Gets or sets the icon displayed in the titlebar of the preview window.
TwoPagesToolTip | Gets or sets the ToolTip text displayed for the Two Pages button.
ZoomAutoCmdText | Gets or sets the Label of the Zoom menu Auto item.
ZoomToolTip | Gets or sets the ToolTip text displayed for the Zoom button.

See Also

PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions Constructor

PreviewOptions Constructor

Initializes a new instance of the PreviewOptions class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public PreviewOptions ()
Visual Basic

Public Sub New ()

See Also

PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions Properties

PreviewOptions Properties

Public Properties

Name | Description
ButtonImages | Gets or sets the list of images to display in print preview toolbar buttons.
DisplayPrintDialog | Get or sets a value indicating whether a print setup dialog box is displayed when the print button of the preview form is clicked.
FirstPageToolTip | Gets or sets the ToolTip text displayed for the First Page button.
FitToPageToolTip | Gets or sets the ToolTip text displayed for the Fit to Page button.
FourPagesToolTip | Gets or sets the ToolTip text displayed for the Four Pages button.
LandscapeToolTip | Gets or sets the ToolTip text displayed for the Landscape button.
LastPageToolTip | Gets or sets the ToolTip text displayed for the Last Page button.
NextPageToolTip | Gets or sets the ToolTip text displayed for the Next Page button.
OnePageToolTip | Gets or sets the ToolTip text displayed for the One Page button.
PortraitToolTip | Gets or sets the ToolTip text displayed for the Portrait button.
PreviousPageToolTip | Gets or sets the ToolTip text displayed for the Previous Page button.
PrintToolTip | Gets or sets the ToolTip text displayed for the Print button.
SixPagesToolTip | Gets or sets the ToolTip text displayed for the Six Pages button.
ThreePagesToolTip | Gets or sets the ToolTip text displayed for the Three Pages button.
TitleBarIcon | Gets or sets the icon displayed in the titlebar of the preview window.
TwoPagesToolTip | Gets or sets the ToolTip text displayed for the Two Pages button.
ZoomAutoCmdText | Gets or sets the Label of the Zoom menu Auto item.
ZoomToolTip | Gets or sets the ToolTip text displayed for the Zoom button.

See Also

PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.ButtonImages Property

PreviewOptions.ButtonImages Property

Gets or sets the list of images to display in print preview toolbar buttons.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public ImageList ButtonImages { get; set; }
Visual Basic

Public Property ButtonImages As ImageList

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.DisplayPrintDialog Property

PreviewOptions.DisplayPrintDialog Property

Get or sets a value indicating whether a print setup dialog box is displayed when the print button of the preview form is clicked.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public bool DisplayPrintDialog { get; set; }
Visual Basic

Public Property DisplayPrintDialog As Boolean

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.FirstPageToolTip Property

PreviewOptions.FirstPageToolTip Property

Gets or sets the ToolTip text displayed for the First Page button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string FirstPageToolTip { get; set; }
Visual Basic

Public Property FirstPageToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.FitToPageToolTip Property

PreviewOptions.FitToPageToolTip Property

Gets or sets the ToolTip text displayed for the Fit to Page button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string FitToPageToolTip { get; set; }
Visual Basic

Public Property FitToPageToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.FourPagesToolTip Property

PreviewOptions.FourPagesToolTip Property

Gets or sets the ToolTip text displayed for the Four Pages button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string FourPagesToolTip { get; set; }
Visual Basic

Public Property FourPagesToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.LandscapeToolTip Property

PreviewOptions.LandscapeToolTip Property

Gets or sets the ToolTip text displayed for the Landscape button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string LandscapeToolTip { get; set; }
Visual Basic

Public Property LandscapeToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.LastPageToolTip Property

PreviewOptions.LastPageToolTip Property

Gets or sets the ToolTip text displayed for the Last Page button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string LastPageToolTip { get; set; }
Visual Basic

Public Property LastPageToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.NextPageToolTip Property

PreviewOptions.NextPageToolTip Property

Gets or sets the ToolTip text displayed for the Next Page button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string NextPageToolTip { get; set; }
Visual Basic

Public Property NextPageToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.OnePageToolTip Property

PreviewOptions.OnePageToolTip Property

Gets or sets the ToolTip text displayed for the One Page button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string OnePageToolTip { get; set; }
Visual Basic

Public Property OnePageToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.PortraitToolTip Property

PreviewOptions.PortraitToolTip Property

Gets or sets the ToolTip text displayed for the Portrait button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string PortraitToolTip { get; set; }
Visual Basic

Public Property PortraitToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.PreviousPageToolTip Property

PreviewOptions.PreviousPageToolTip Property

Gets or sets the ToolTip text displayed for the Previous Page button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string PreviousPageToolTip { get; set; }
Visual Basic

Public Property PreviousPageToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.PrintToolTip Property

PreviewOptions.PrintToolTip Property

Gets or sets the ToolTip text displayed for the Print button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string PrintToolTip { get; set; }
Visual Basic

Public Property PrintToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.SixPagesToolTip Property

PreviewOptions.SixPagesToolTip Property

Gets or sets the ToolTip text displayed for the Six Pages button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string SixPagesToolTip { get; set; }
Visual Basic

Public Property SixPagesToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.ThreePagesToolTip Property

PreviewOptions.ThreePagesToolTip Property

Gets or sets the ToolTip text displayed for the Three Pages button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string ThreePagesToolTip { get; set; }
Visual Basic

Public Property ThreePagesToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.TitleBarIcon Property

PreviewOptions.TitleBarIcon Property

Gets or sets the icon displayed in the titlebar of the preview window.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public Icon TitleBarIcon { get; set; }
Visual Basic

Public Property TitleBarIcon As Icon

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.TwoPagesToolTip Property

PreviewOptions.TwoPagesToolTip Property

Gets or sets the ToolTip text displayed for the Two Pages button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string TwoPagesToolTip { get; set; }
Visual Basic

Public Property TwoPagesToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.ZoomAutoCmdText Property

PreviewOptions.ZoomAutoCmdText Property

Gets or sets the Label of the Zoom menu Auto item.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string ZoomAutoCmdText { get; set; }
Visual Basic

Public Property ZoomAutoCmdText As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.ZoomToolTip Property

PreviewOptions.ZoomToolTip Property

Gets or sets the ToolTip text displayed for the Zoom button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public string ZoomToolTip { get; set; }
Visual Basic

Public Property ZoomToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Class

PrintPreviewForm Class

Implements an extended print preview form.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public class PrintPreviewForm : Form
Visual Basic

Public Class PrintPreviewForm
Inherits Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
MindFusion.Reporting.WinForms.PrintPreviewForm

See Also

PrintPreviewForm Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Members

PrintPreviewForm Members
Constructors Properties Methods

Implements an extended print preview form.

The following tables list the members exposed by the PrintPreviewForm type.

Public Constructors

Name | Description
PrintPreviewForm | Overloaded. Initializes a new instance of the PrintPreviewForm class.

Public Properties

Name | Description
Document | Gets or sets the internal version of the document.
UseAntiAlias | Gets or sets the anti-alias flag on the preview control.

Protected Methods

Name | Description
Dispose | Form.Dispose override.
OnLoad | Form.OnLoad override.

See Also

PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Constructor

PrintPreviewForm Constructor

Initializes a new instance of the PrintPreviewForm class.

Overload List

Name | Description
PrintPreviewForm () | Initializes a new instance of the PrintPreviewForm class.
PrintPreviewForm (String, PreviewOptions) | Initializes a new instance of the PrintPreviewForm class.

See Also

PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Constructor ()

PrintPreviewForm Constructor ()
See Also

Initializes a new instance of the PrintPreviewForm class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public PrintPreviewForm ()
Visual Basic

Public Sub New ()

See Also

PrintPreviewForm Constructor Overload List
PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Constructor (String, PreviewOptions)

PrintPreviewForm Constructor (String, PreviewOptions)
See Also

Initializes a new instance of the PrintPreviewForm class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public PrintPreviewForm (
string documentName,
PreviewOptions options
)
Visual Basic

Public New ( _
documentName As String, _
options As PreviewOptions _
)

Parameters

documentName
options

See Also

PrintPreviewForm Constructor Overload List
PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Methods

PrintPreviewForm Methods

Protected Methods

Name | Description
Dispose | Form.Dispose override.
OnLoad | Form.OnLoad override.

See Also

PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm.Dispose Method

PrintPreviewForm.Dispose Method

Form.Dispose override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing

See Also

PrintPreviewForm Members
PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm.OnLoad Method

PrintPreviewForm.OnLoad Method

Form.OnLoad override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

protected virtual void OnLoad (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnLoad ( _
e As EventArgs _
)

Parameters

e

See Also

PrintPreviewForm Members
PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Properties

PrintPreviewForm Properties

Public Properties

Name | Description
Document | Gets or sets the internal version of the document.
UseAntiAlias | Gets or sets the anti-alias flag on the preview control.

See Also

PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm.Document Property

PrintPreviewForm.Document Property

Gets or sets the internal version of the document.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public PrintDocument Document { get; set; }
Visual Basic

Public Property Document As PrintDocument

Property Value

See Also

PrintPreviewForm Members
PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm.UseAntiAlias Property

PrintPreviewForm.UseAntiAlias Property

Gets or sets the anti-alias flag on the preview control.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public bool UseAntiAlias { get; set; }
Visual Basic

Public Property UseAntiAlias As Boolean

Property Value

See Also

PrintPreviewForm Members
PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas Class

ReportCanvas Class

Represents a control that can display a MindFusion.Reporting.Report object.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public class ReportCanvas : Control, IScrollable
Visual Basic

Public Class ReportCanvas
Inherits Control
Implements IScrollable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Reporting.WinForms.ReportCanvas

See Also

ReportCanvas Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas Members

ReportCanvas Members
Constructors Properties Methods Events

Represents a control that can display a MindFusion.Reporting.Report object.

The following tables list the members exposed by the ReportCanvas type.

Public Constructors

Name | Description
ReportCanvas | Initializes a new instance of the ReportCanvas class.

Public Properties

Name | Description
Margins | Gets or sets the margins of the displayed pages.
PaperSize | Gets or sets the size of the pages displayed on the canvas.
Report | Gets or sets a reference to the associated MindFusion.Reporting.Report object.
ScrollPosition | IScrollable.ScrollPosition implementation.
ScrollRange | IScrollable.ScrollRange implementation.

Public Methods

Name | Description
DocToDevice | Overloaded.
Recalc | Causes the control to recalculate all internals and repaint its client area.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnPaint | Control.OnPaint override.

Public Events

Name | Description
ScrollRangeChanged | IScrollable.ScrollRangeChanged implementation.

See Also

ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas Constructor

ReportCanvas Constructor

Initializes a new instance of the ReportCanvas class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public ReportCanvas ()
Visual Basic

Public Sub New ()

See Also

ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas Methods

ReportCanvas Methods

Public Methods

Name | Description
DocToDevice | Overloaded.
Recalc | Causes the control to recalculate all internals and repaint its client area.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnPaint | Control.OnPaint override.

See Also

ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.Dispose Method

ReportCanvas.Dispose Method

Clean up any resources being used.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.DocToDevice Method

ReportCanvas.DocToDevice Method

Overload List

Name | Description
ReportCanvas.DocToDevice (PointF) | Converts the specified point from document to client coordinates.
ReportCanvas.DocToDevice (RectangleF) | Converts the specified point from document to client coordinates.

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.DocToDevice Method (PointF)

ReportCanvas.DocToDevice Method (PointF)
See Also

Converts the specified point from document to client coordinates.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public Point DocToDevice (
PointF docPoint
)
Visual Basic

Public Function DocToDevice ( _
docPoint As PointF _
) As Point

Parameters

docPoint

Return Value

See Also

DocToDevice Method Overload List
ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.DocToDevice Method (RectangleF)

ReportCanvas.DocToDevice Method (RectangleF)
See Also

Converts the specified point from document to client coordinates.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public Rectangle DocToDevice (
RectangleF docRect
)
Visual Basic

Public Function DocToDevice ( _
docRect As RectangleF _
) As Rectangle

Parameters

docRect

Return Value

See Also

DocToDevice Method Overload List
ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.OnPaint Method

ReportCanvas.OnPaint Method

Control.OnPaint override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

protected virtual void OnPaint (
PaintEventArgs pe
)
Visual Basic

Protected Overridable Sub OnPaint ( _
pe As PaintEventArgs _
)

Parameters

pe

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.Recalc Method

ReportCanvas.Recalc Method

Causes the control to recalculate all internals and repaint its client area.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public void Recalc (
int pageNum,
SizeF pageSize
)
Visual Basic

Public Sub Recalc ( _
pageNum As Integer, _
pageSize As SizeF _
)

Parameters

pageNum
pageSize

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas Properties

ReportCanvas Properties

Public Properties

Name | Description
Margins | Gets or sets the margins of the displayed pages.
PaperSize | Gets or sets the size of the pages displayed on the canvas.
Report | Gets or sets a reference to the associated MindFusion.Reporting.Report object.
ScrollPosition | IScrollable.ScrollPosition implementation.
ScrollRange | IScrollable.ScrollRange implementation.

See Also

ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.Margins Property

ReportCanvas.Margins Property

Gets or sets the margins of the displayed pages.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public Margins Margins { get; set; }
Visual Basic

Public Property Margins As Margins

Property Value

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.PaperSize Property

ReportCanvas.PaperSize Property

Gets or sets the size of the pages displayed on the canvas.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public SizeF PaperSize { get; set; }
Visual Basic

Public Property PaperSize As SizeF

Property Value

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.Report Property

ReportCanvas.Report Property

Gets or sets a reference to the associated MindFusion.Reporting.Report object.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public Report Report { get; set; }
Visual Basic

Public Property Report As Report

Property Value

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.ScrollPosition Property

ReportCanvas.ScrollPosition Property

IScrollable.ScrollPosition implementation.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public virtual Point ScrollPosition { get; set; }
Visual Basic

Public Overridable Property ScrollPosition As Point

Property Value

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.ScrollRange Property

ReportCanvas.ScrollRange Property

IScrollable.ScrollRange implementation.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public virtual Size ScrollRange { get; }
Visual Basic

Public Overridable ReadOnly Property ScrollRange As Size

Property Value

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas Events

ReportCanvas Events

Public Events

Name | Description
ScrollRangeChanged | IScrollable.ScrollRangeChanged implementation.

See Also

ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.ScrollRangeChanged Event

ReportCanvas.ScrollRangeChanged Event

IScrollable.ScrollRangeChanged implementation.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public event EventHandler ScrollRangeChanged
Visual Basic

Public Event ScrollRangeChanged As EventHandler

Event Data

EndRenderReport event handlers receive an argument of type EventArgs.

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Class

ReportPrinter Class

Serves as a PrintDocument for MindFusion.Reporting.Report components.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public class ReportPrinter : PrintDocument
Visual Basic

Public Class ReportPrinter
Inherits PrintDocument

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Drawing.Printing.PrintDocument
MindFusion.Reporting.WinForms.ReportPrinter

See Also

ReportPrinter Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Members

ReportPrinter Members
Constructors Properties Methods

Serves as a PrintDocument for MindFusion.Reporting.Report components.

The following tables list the members exposed by the ReportPrinter type.

Public Constructors

Name | Description
ReportPrinter | Overloaded.

Public Properties

Name | Description
Report | Gets or sets the Report associated with this print document.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnBeginPrint | PrintDocument.OnBeginPrint override.
OnPrintPage | PrintDocument.OnPrintPage override.
OnQueryPageSettings | PrintDocument.OnQueryPageSettings override.

See Also

ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Constructor

ReportPrinter Constructor

Overload List

Name | Description
ReportPrinter () | Initializes a new instance of the ReportPrinter class.
ReportPrinter (IContainer) | Initializes a new instance of the ReportPrinter class.

See Also

ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Constructor ()

ReportPrinter Constructor ()
See Also

Initializes a new instance of the ReportPrinter class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public ReportPrinter ()
Visual Basic

Public Sub New ()

See Also

ReportPrinter Constructor Overload List
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Constructor (IContainer)

ReportPrinter Constructor (IContainer)
See Also

Initializes a new instance of the ReportPrinter class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public ReportPrinter (
IContainer container
)
Visual Basic

Public New ( _
container As IContainer _
)

Parameters

container

See Also

ReportPrinter Constructor Overload List
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Methods

ReportPrinter Methods

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnBeginPrint | PrintDocument.OnBeginPrint override.
OnPrintPage | PrintDocument.OnPrintPage override.
OnQueryPageSettings | PrintDocument.OnQueryPageSettings override.

See Also

ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter.Dispose Method

ReportPrinter.Dispose Method

Clean up any resources being used.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter.OnBeginPrint Method

ReportPrinter.OnBeginPrint Method

PrintDocument.OnBeginPrint override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

protected virtual void OnBeginPrint (
PrintEventArgs e
)
Visual Basic

Protected Overridable Sub OnBeginPrint ( _
e As PrintEventArgs _
)

Parameters

e

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter.OnPrintPage Method

ReportPrinter.OnPrintPage Method

PrintDocument.OnPrintPage override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

protected virtual void OnPrintPage (
PrintPageEventArgs e
)
Visual Basic

Protected Overridable Sub OnPrintPage ( _
e As PrintPageEventArgs _
)

Parameters

e

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter.OnQueryPageSettings Method

ReportPrinter.OnQueryPageSettings Method

PrintDocument.OnQueryPageSettings override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

protected virtual void OnQueryPageSettings (
QueryPageSettingsEventArgs e
)
Visual Basic

Protected Overridable Sub OnQueryPageSettings ( _
e As QueryPageSettingsEventArgs _
)

Parameters

e

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Properties

ReportPrinter Properties

Public Properties

Name | Description
Report | Gets or sets the Report associated with this print document.

See Also

ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter.Report Property

ReportPrinter.Report Property

Gets or sets the Report associated with this print document.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public Report Report { get; set; }
Visual Basic

Public Property Report As Report

Property Value

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer Class

ReportViewer Class

Represents a scrollable control that can display a MindFusion.Reporting.Report objects.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public class ReportViewer : UserControl
Visual Basic

Public Class ReportViewer
Inherits UserControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
MindFusion.Reporting.WinForms.ReportViewer

See Also

ReportViewer Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer Members

ReportViewer Members
Constructors Properties Methods

Represents a scrollable control that can display a MindFusion.Reporting.Report objects.

The following tables list the members exposed by the ReportViewer type.

Public Constructors

Name | Description
ReportViewer | Initializes a new instance of the ReportViewer class.

Public Properties

Name | Description
PaperSize | Gets or sets the size of the pages displayed in the viewer.
Report | Gets or sets a reference to the Report displayed in the viewer.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.

See Also

ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer Constructor

ReportViewer Constructor

Initializes a new instance of the ReportViewer class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public ReportViewer ()
Visual Basic

Public Sub New ()

See Also

ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer Methods

ReportViewer Methods

Protected Methods

Name | Description
Dispose | Clean up any resources being used.

See Also

ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer.Dispose Method

ReportViewer.Dispose Method

Clean up any resources being used.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

ReportViewer Members
ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer Properties

ReportViewer Properties

Public Properties

Name | Description
PaperSize | Gets or sets the size of the pages displayed in the viewer.
Report | Gets or sets a reference to the Report displayed in the viewer.

See Also

ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer.PaperSize Property

ReportViewer.PaperSize Property

Gets or sets the size of the pages displayed in the viewer.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public SizeF PaperSize { get; set; }
Visual Basic

Public Property PaperSize As SizeF

Property Value

See Also

ReportViewer Members
ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer.Report Property

ReportViewer.Report Property

Gets or sets a reference to the Report displayed in the viewer.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public Report Report { get; set; }
Visual Basic

Public Property Report As Report

Property Value

See Also

ReportViewer Members
ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer Class

ScrollViewer Class

Represents a control that can host another control and provide scrolling capabilities if the hosted control is larger than the client area.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public class ScrollViewer : UserControl
Visual Basic

Public Class ScrollViewer
Inherits UserControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
MindFusion.Reporting.WinForms.ScrollViewer

See Also

ScrollViewer Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer Members

ScrollViewer Members
Constructors Properties Methods

Represents a control that can host another control and provide scrolling capabilities if the hosted control is larger than the client area.

The following tables list the members exposed by the ScrollViewer type.

Public Constructors

Name | Description
ScrollViewer | Initializes a new instance of the ScrollViewer class.

Public Properties

Name | Description
ScrollableControl | Gets or sets a reference to the hosted control.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnLayout | ContainerControl.OnLayout override.

See Also

ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer Constructor

ScrollViewer Constructor

Initializes a new instance of the ScrollViewer class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public ScrollViewer ()
Visual Basic

Public Sub New ()

See Also

ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer Methods

ScrollViewer Methods

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnLayout | ContainerControl.OnLayout override.

See Also

ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer.Dispose Method

ScrollViewer.Dispose Method

Clean up any resources being used.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

ScrollViewer Members
ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer.OnLayout Method

ScrollViewer.OnLayout Method

ContainerControl.OnLayout override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

protected virtual void OnLayout (
LayoutEventArgs e
)
Visual Basic

Protected Overridable Sub OnLayout ( _
e As LayoutEventArgs _
)

Parameters

e

See Also

ScrollViewer Members
ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer Properties

ScrollViewer Properties

Public Properties

Name | Description
ScrollableControl | Gets or sets a reference to the hosted control.

See Also

ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer.ScrollableControl Property

ScrollViewer.ScrollableControl Property

Gets or sets a reference to the hosted control.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C#

public Control ScrollableControl { get; set; }
Visual Basic

Public Property ScrollableControl As Control

Property Value

See Also

ScrollViewer Members
ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Scheduling Namespace
Classes Enumerations

Classes

Class | Description
Appointment | Represents appointments within a schedule.
BinarySerializationContext | Contains methods that can help you serialize/deserialize MindFusion.Scheduling items to/from binary documents.
Contact | Instances of the Contact class contain information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.
ContactCollection | Represents a strongly-typed collection of Contact objects.
CustomBrushes | Defines a pair of brushes to be used to paint cells in cells in Timetable, WeekRange and Resource views.
InstantiateItemEventArgs | Provides data for the InstantiateItem event.
InstantiateResourceEventArgs | Provides data for the InstantiateResource event.
Item | Represents events scheduled to occur at some point in time. It is derived by concrete classes such as Appointment.
ItemCollection | Represents a strongly typed collection of Item objects.
ItemEventArgs | Contains the arguments passed to handlers of item related events raised by the Schedule class.
ItemTimeEventArgs | Contains the arguments passed to handlers of time related events.
Location | Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.
LocationCollection | Represents a strongly typed collection of Location objects.
Recurrence | Defines recurrence patterns for items scheduled to repeat over and over again.
RecurrenceException | This class represents exceptions of a recurrence patterns.
Reminder | Represents reminders associated with schedule items.
Resource | Instances of the Resource class contain information about arbitrary resources.
ResourceCollection | Represents a strongly-typed collection of Resource objects.
Schedule | Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances - the views.
SerializationContext | This class contains information required to serialize a Schedule element to and from a binary stream or XML document.
SerializeTagEventArgs | Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.
Style | Specifies the appearance of calendar elements.
Task | Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.
TaskCollection | Represents a strongly-typed collection of Task objects.
TaskEventArgs | Contains the arguments passed to handlers of task related events raised by the Schedule class.
XmlSerializationContext | Contains methods that can help you serialize/deserialize MindFusion.Scheduling items to/from XML documents.

Enumerations

Enumeration | Description
ContentType | Specifies the type of file contents.
DailyRecurrence | Specifies how daily recurrence patterns are defined.
DayOfWeekType | Specifies the type of week days, used with ByDayType monthly and yearly recurrence patterns.
DaysOfWeek | Specifies the day of the week.
MonthlyRecurrence | Specifies the types of monthly recurrence patterns.
Occurrence | Specifies the occurrence number of a day or a week within a month.
RecurrenceEnd | Specifies when to stop repeating recurring events.
RecurrencePattern | Specifies the interval at which recurring items occur.
RecurrenceState | Specifies the recurrence state of items.
ReminderType | Specifies the type of a reminder.
ShadowStyle | Specifies what type of shadow effect to apply to a calendar UI element.
TaskPriority | Specifies the priority of a task.
TaskStatus | Enumeration providing task status values.
YearlyRecurrence | Specifies the types of yearly recurrence patterns.


MindFusion.Scheduling.Appointment Class

Appointment Class

Represents appointments within a schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class Appointment : Item
Visual Basic

Public Class Appointment
Inherits Item

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Item
MindFusion.Scheduling.Appointment

See Also

Appointment Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Members

Appointment Members
Constructors Properties Methods

Represents appointments within a schedule.

The following tables list the members exposed by the Appointment type.

Public Constructors

Name | Description
Appointment | Initializes a new instance of the Appointment class.

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the appointment is an all-day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the appointment's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the appointment's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the appointment.
Attendees | Gets the attendees of this appointment.
Contacts | Gets references to all contacts associated with this appointment.
DescriptionText | Gets or sets the details text displayed for this appointment by scheduling controls.
Details | Gets or sets the detailed description of this appointment.
EndTime | Gets or sets the appointment's scheduled end time.
HeaderText | Gets or sets the header text displayed for this appointment by scheduling controls.
Id | Gets or sets the string identifier of this appointment.
Location | Gets or sets the appointment location.
Locked | Gets or sets a value indicating whether users are forbidden to modify this appointment.
PointedSelectedStyle | Gets or sets the style associated with this appointment.
PointedStyle | Gets or sets the style associated with this appointment.
Reminder | Gets or sets the reminder for this appointment.
Resources | Gets references to all resources associated with this appointment.
SelectedStyle | Gets or sets the style used when this appointment is selected.
StartTime | Gets or sets the appointment's scheduled start time.
Style | Gets or sets the style associated with this appointment.
Subject | Gets or sets the subject of this appointment.
Tag | Gets or sets custom data associated with the appointment.
Task | Gets or sets the task associated with this appointment.
Visible | Gets or sets whether the appointment is visible or not.

Public Methods

Name | Description
Clone | Creates an exact shallow clone of this appointment.
LoadFrom | Overloaded. Loads appointment data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the appointment data to a binary stream or an XML document.

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Constructor

Appointment Constructor

Initializes a new instance of the Appointment class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Appointment ()
Visual Basic

Public Sub New ()

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Methods

Appointment Methods

Public Methods

Name | Description
Clone | Creates an exact shallow clone of this appointment.
LoadFrom | Overloaded. Loads appointment data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the appointment data to a binary stream or an XML document.

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Clone Method

Appointment.Clone Method

Creates an exact shallow clone of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

A new Appointment object representing a shallow copy of this one.

Remarks

The Clone method creates an exact copy of an item with the following exceptions. The duplicates of a recurring item created through the Clone method are no longer recurring items. The Id of the newly created item is unique and not the same as the Id of the source item.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.LoadFrom Method

Appointment.LoadFrom Method

Loads appointment data from a binary stream or an XML document.

Overload List

Name | Description
Appointment.LoadFrom (BinaryReader, BinarySerializationContext) | Loads appointment data from a binary stream.
Appointment.LoadFrom (XmlElement, XmlSerializationContext) | Loads appointment data from an XML document.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.LoadFrom Method (BinaryReader, BinarySerializationContext)

Appointment.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also

Loads appointment data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Allows reading primitive data types from a binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

Loads the fields of an appointment object from a binary stream that contains data previously saved by SaveTo.

See Also

LoadFrom Method Overload List
Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Appointment.LoadFrom Method (XmlElement, XmlSerializationContext)

Appointment.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads appointment data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

Loads the appointment's fields from an XML document where they were stored by a previous call to the SaveTo method.

See Also

LoadFrom Method Overload List
Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Appointment.SaveTo Method

Appointment.SaveTo Method

Saves the appointment data to a binary stream or an XML document.

Overload List

Name | Description
Appointment.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the appointment data to a binary stream.
Appointment.SaveTo (XmlElement, XmlSerializationContext) | Saves the appointment data to an XML document.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.SaveTo Method (BinaryWriter, BinarySerializationContext)

Appointment.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also

Saves the appointment data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Allows writing primitive data types to a binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

This method saves the appointment fields as bytes in a binary stream, from which they can be loaded later via the LoadFrom method.

See Also

SaveTo Method Overload List
Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Appointment.SaveTo Method (XmlElement, XmlSerializationContext)

Appointment.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the appointment data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the appointment's fields as elements of an XML document, from which they can be loaded later via the LoadFrom method.

See Also

SaveTo Method Overload List
Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Appointment Properties

Appointment Properties

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the appointment is an all-day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the appointment's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the appointment's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the appointment.
Attendees | Gets the attendees of this appointment.
Contacts | Gets references to all contacts associated with this appointment.
DescriptionText | Gets or sets the details text displayed for this appointment by scheduling controls.
Details | Gets or sets the detailed description of this appointment.
EndTime | Gets or sets the appointment's scheduled end time.
HeaderText | Gets or sets the header text displayed for this appointment by scheduling controls.
Id | Gets or sets the string identifier of this appointment.
Location | Gets or sets the appointment location.
Locked | Gets or sets a value indicating whether users are forbidden to modify this appointment.
PointedSelectedStyle | Gets or sets the style associated with this appointment.
PointedStyle | Gets or sets the style associated with this appointment.
Reminder | Gets or sets the reminder for this appointment.
Resources | Gets references to all resources associated with this appointment.
SelectedStyle | Gets or sets the style used when this appointment is selected.
StartTime | Gets or sets the appointment's scheduled start time.
Style | Gets or sets the style associated with this appointment.
Subject | Gets or sets the subject of this appointment.
Tag | Gets or sets custom data associated with the appointment.
Task | Gets or sets the task associated with this appointment.
Visible | Gets or sets whether the appointment is visible or not.

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.AllDayEvent Property

Appointment.AllDayEvent Property

Gets or sets a value indicating whether the appointment is an all-day event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override bool AllDayEvent { get; set; }
Visual Basic

Public Overrides Property AllDayEvent As Boolean

Property Value

true if the item is an all day event; otherwise, false. The default is false.

Remarks

All day events are displayed in a special header area when the Calendar displays a timetable view.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
StartTime Property
EndTime Property


MindFusion.Scheduling.Appointment.AllowChangeEnd Property

Appointment.AllowChangeEnd Property

Gets or sets a value indicating whether users are allowed to change the appointment's end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override bool AllowChangeEnd { get; set; }
Visual Basic

Public Overrides Property AllowChangeEnd As Boolean

Property Value

true if the appointment's end can be modified interactively; otherwise, false. The default is true.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowMove Property


MindFusion.Scheduling.Appointment.AllowChangeStart Property

Appointment.AllowChangeStart Property

Gets or sets a value indicating whether users are allowed to change the appointment's start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override bool AllowChangeStart { get; set; }
Visual Basic

Public Overrides Property AllowChangeStart As Boolean

Property Value

true if the appointment's start can be modified interactively; otherwise, false. The default is true.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
AllowChangeEnd Property
AllowMove Property


MindFusion.Scheduling.Appointment.AllowMove Property

Appointment.AllowMove Property

Gets or sets a value indicating whether users are allowed to move the appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override bool AllowMove { get; set; }
Visual Basic

Public Overrides Property AllowMove As Boolean

Property Value

true if the appointment can be moved interactively; otherwise, false. The default is true.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowChangeEnd Property


MindFusion.Scheduling.Appointment.Attendees Property

Appointment.Attendees Property

Gets the attendees of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ContactCollection Attendees { get; }
Visual Basic

Public ReadOnly Property Attendees As ContactCollection

Property Value

An instance of the ContactCollection class specifying the appointment's attendees.

Remarks

This property is equivalent to Contacts.

Example

The following example creates a new contact and associates it with an existing appointment. The example assumes that app references an existing appointment. The last call is equivalent to app.Contacts.Add(c), since Attendees and Contacts both return a reference to the same collection.

C#

// Create the contact
Contact c = new Contact();
c.FirstName = "John";
c.LastName = "Silver";

// Associate the contact with the appointment
app.Attendees.Add(c);
Visual Basic

' Create the contact
Dim c As New Contact()
c.FirstName = "John"
c.LastName = "Silver"

' Associate the contact with the appointment
app.Attendees.Add(c)

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Contacts Property

Appointment.Contacts Property

Gets references to all contacts associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override ContactCollection Contacts { get; }
Visual Basic

Public Overrides ReadOnly Property Contacts As ContactCollection

Property Value

An instance of the ContactCollection class containing the contacts associated with this appointment.

Remarks

This property is equivalent to Attendees.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.DescriptionText Property

Appointment.DescriptionText Property

Gets or sets the details text displayed for this appointment by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override string DescriptionText { get; set; }
Visual Basic

Public Overrides Property DescriptionText As String

Property Value

A string containing the appointment's description. The default is an empty string.

Remarks

This property implements the DescriptionText property of the Item class and is equivalent to Details.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Details Property

Appointment.Details Property

Gets or sets the detailed description of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string Details { get; set; }
Visual Basic

Public Property Details As String

Property Value

A string containing the appointment's description. The default is an empty string.

Remarks

This property is equivalent to DescriptionText.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.EndTime Property

Appointment.EndTime Property

Gets or sets the appointment's scheduled end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override DateTime EndTime { get; set; }
Visual Basic

Public Overrides Property EndTime As DateTime

Property Value

A .NET DateTime object specifying the appointment's end time. The default is DateTime.MaxValue.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
StartTime Property
AllDayEvent Property


MindFusion.Scheduling.Appointment.HeaderText Property

Appointment.HeaderText Property

Gets or sets the header text displayed for this appointment by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override string HeaderText { get; set; }
Visual Basic

Public Overrides Property HeaderText As String

Property Value

A string containing the appointment's header text. The default is an empty string.

Remarks

This property implements the Item's class HeaderText property and is equivalent to Subject.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Id Property

Appointment.Id Property

Gets or sets the string identifier of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override string Id { get; set; }
Visual Basic

Public Overrides Property Id As String

Property Value

A string value that identifies uniquely this appointment.

Remarks

If you need to change its value, make sure the identifier is always unique.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Location Property

Appointment.Location Property

Gets or sets the appointment location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override Location Location { get; set; }
Visual Basic

Public Overrides Property Location As Location

Property Value

An instance of the Location class specifying the appointment's location. The default is null (Nothing in Visual Basic).

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Locked Property

Appointment.Locked Property

Gets or sets a value indicating whether users are forbidden to modify this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override bool Locked { get; set; }
Visual Basic

Public Overrides Property Locked As Boolean

Property Value

true if users are allowed to move an appointment thus changing its scheduled time; otherwise, false. The default is false.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.PointedSelectedStyle Property

Appointment.PointedSelectedStyle Property

Gets or sets the style associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override Style PointedSelectedStyle { get; set; }
Visual Basic

Public Overrides Property PointedSelectedStyle As Style

Property Value

An instance of the Style class that defines the appearance of the item.

Remarks

This style is applied to the appointment when it is pointed with the mouse and selected at the same time. This property is ignored and SelectedStyle is used instead of it when UseExtendedStyles is set to Disabled. To read more about how this property affects items appearance, refer to the Customizing the Appearance of Items topic.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
Style Property
SelectedStyle Property
PointedStyle Property


MindFusion.Scheduling.Appointment.PointedStyle Property

Appointment.PointedStyle Property

Gets or sets the style associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override Style PointedStyle { get; set; }
Visual Basic

Public Overrides Property PointedStyle As Style

Property Value

An instance of the Style class that defines the appearance of the item.

Remarks

This style is applied to the appointment when it is pointed with the mouse. This property is ignored and Style is used instead of it when UseExtendedStyles is set to Disabled. To read more about how this property affects items appearance, refer to the Customizing the Appearance of Items topic.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
Style Property
SelectedStyle Property
PointedSelectedStyle Property


MindFusion.Scheduling.Appointment.Reminder Property

Appointment.Reminder Property

Gets or sets the reminder for this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override Reminder Reminder { get; set; }
Visual Basic

Public Overrides Property Reminder As Reminder

Property Value

An instance of the Reminder class.

Remarks

If the reminder type is Exact, the ItemReminderTriggered event is raised at the time set in the reminder's Time property. If the reminder type is Leading, the ItemReminderTriggered event is raised certain amount of time prior to the item's StartTime, as specified in the reminder's TimeInterval property.

Note:

Recurring items cannot have leading reminders.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Resources Property

Appointment.Resources Property

Gets references to all resources associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override ResourceCollection Resources { get; }
Visual Basic

Public Overrides ReadOnly Property Resources As ResourceCollection

Property Value

An instance of the ResourceCollection class containing the resources associated with this item.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.SelectedStyle Property

Appointment.SelectedStyle Property

Gets or sets the style used when this appointment is selected.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override Style SelectedStyle { get; set; }
Visual Basic

Public Overrides Property SelectedStyle As Style

Property Value

An instance of the Style class that defines the appearance of the item.

Remarks

This style is applied on the appointment when it is selected.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
Style Property
PointedStyle Property
PointedSelectedStyle Property


MindFusion.Scheduling.Appointment.StartTime Property

Appointment.StartTime Property

Gets or sets the appointment's scheduled start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override DateTime StartTime { get; set; }
Visual Basic

Public Overrides Property StartTime As DateTime

Property Value

A .NET DateTime instance specifying the scheduled time for the item.

Remarks

This property affects the initial time cell occupied by the item when it is displayed in a Calendar view.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
EndTime Property
AllDayEvent Property


MindFusion.Scheduling.Appointment.Style Property

Appointment.Style Property

Gets or sets the style associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

An instance of the Style class that defines the appearance of the item.

Remarks

This style is applied to the item when it is neither pointed with the mouse nor selected.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
SelectedStyle Property
PointedStyle Property
PointedSelectedStyle Property


MindFusion.Scheduling.Appointment.Subject Property

Appointment.Subject Property

Gets or sets the subject of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string Subject { get; set; }
Visual Basic

Public Property Subject As String

Property Value

A string that identifies the subject of the appointment. The default is an empty string.

Remarks

This is equivalent to the HeaderText property.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Tag Property

Appointment.Tag Property

Gets or sets custom data associated with the appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override Object Tag { get; set; }
Visual Basic

Public Overrides Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Use this property to store your custom data. The tag can be a value from a primitive data type or a complex object from the .NET class library or a class defined by you. If the tag is an instance of a value type, it will be serialized together with the object containing it when saving / loading the schedule. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Task Property

Appointment.Task Property

Gets or sets the task associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override Task Task { get; set; }
Visual Basic

Public Overrides Property Task As Task

Property Value

An instance of the Task class. The default is null (Nothing in Visual Basic).

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Visible Property

Appointment.Visible Property

Gets or sets whether the appointment is visible or not.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override bool Visible { get; set; }
Visual Basic

Public Overrides Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false. The default is true.

Remarks

Invisible items are not drawn at all. You could use this property to hide an item temporarily, or to store additional data in a helper item object that always stays invisible.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.BinarySerializationContext Class

BinarySerializationContext Class

Contains methods that can help you serialize/deserialize MindFusion.Scheduling items to/from binary documents.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class BinarySerializationContext : SerializationContext
Visual Basic

Public Class BinarySerializationContext
Inherits SerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.SerializationContext
MindFusion.Scheduling.BinarySerializationContext

See Also

BinarySerializationContext Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.BinarySerializationContext Members

BinarySerializationContext Members
Constructors Properties Methods

Contains methods that can help you serialize/deserialize MindFusion.Scheduling items to/from binary documents.

The following tables list the members exposed by the BinarySerializationContext type.

Public Constructors

Name | Description
BinarySerializationContext | Overloaded. Initializes a new instance of the BinarySerializationContext class.

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.

Public Methods

Name | Description
ReadBool | Reads a boolean value.
ReadBrush | Reads a MindFusion.Drawing.Brush object.
ReadByte | Reads a byte value.
ReadChar | Reads a char value.
ReadColor | Reads a color.
ReadColorArray | Reads a color array.
ReadCustomBrushes | Reads a CustomBrushes object.
ReadDateTime | Reads a DateTime object.
ReadDecimal | Reads a decimal value.
ReadDouble | Reads a double value.
ReadEnum | Reads an enum value.
ReadFloat | Reads a float value with the specified name.
ReadFloatArray | Reads a float array.
ReadFont | Reads a Font object.
ReadHashtable | Reads a hashtable object.
ReadImage | Reads an Image object.
ReadInt | Reads an integer value.
ReadLong | Reads a long value.
ReadObject | Reads an object.
ReadPen | Reads a MindFusion.Drawing.Pen object.
ReadPointF | Reads a PointF object.
ReadRectangleF | Reads a RectangleF object.
ReadRecurrence | Reads a Recurrence object.
ReadReminder | Reads a Reminder object.
ReadSByte | Reads a 8-bit signed integer value.
ReadShort | Reads a short value.
ReadSizeF | Reads a SizeF object.
ReadStream | Reads a stream.
ReadString | Reads a string value.
ReadStringFormat | Reads a StringFormat object.
ReadStyle | Reads a Style object.
ReadTag | Reads a tag object for the specified object.
ReadUInt | Reads an unsigned integer value.
ReadULong | Reads an unsigned long value.
ReadUShort | Reads an unsigned short value.
WriteBool | Writes a boolean value.
WriteBrush | Writes a Brush object.
WriteByte | Write a byte value to the stream.
WriteChar | Write a char value to the stream.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteCustomBrushes | Writes the specified CustomBrushes object.
WriteDateTime | Writes the specified DateTime object.
WriteDecimal | Write a decimal value to the stream.
WriteDouble | Writes a double value.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes the specified image.
WriteInt | Writes an integer value.
WriteLong | Writes a long value.
WriteObject | Writes the specified object.
WritePen | Writes a Pen object.
WritePointF | Writes a PointF object.
WriteRectangleF | Writes a RectangleF object.
WriteRecurrence | Writes the specified Recurrence object.
WriteReminder | Writes the specified Reminder object.
WriteSByte | Write a 8-bit signed integer value to the stream.
WriteShort | Writes a short value.
WriteSizeF | Writes a SizeF object.
WriteStream | Writes the specified stream.
WriteString | Writes a string value.
WriteStringFormat | Writes the specified StringFormat object.
WriteStyle | Writes the specified Style object.
WriteTag | Writes the specified tag of the specified object.
WriteUInt | Writes an unsigned integer value.
WriteULong | Writes an unsigned long value.
WriteUShort | Writes an unsigned short value.

See Also

BinarySerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.BinarySerializationContext Constructor

BinarySerializationContext Constructor

Initializes a new instance of the BinarySerializationContext class.

Overload List

Name | Description
BinarySerializationContext (Schedule) | Initializes a new instance of the BinarySerializationContext class.
BinarySerializationContext (Schedule, Int32) | Initializes a new instance of the BinarySerializationContext class.

See Also

BinarySerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.BinarySerializationContext Constructor (Schedule)

BinarySerializationContext Constructor (Schedule)
See Also

Initializes a new instance of the BinarySerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public BinarySerializationContext (
Schedule schedule
)
Visual Basic

Public Sub BinarySerializationContext ( _
schedule As Schedule _
)

Parameters

schedule
The Schedule this class will operate on.

See Also

BinarySerializationContext Constructor Overload List
BinarySerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.BinarySerializationContext Constructor (Schedule, Int32)

BinarySerializationContext Constructor (Schedule, Int32)
See Also

Initializes a new instance of the BinarySerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public BinarySerializationContext (
Schedule schedule,
int fileVersion
)
Visual Basic

Public Sub BinarySerializationContext ( _
schedule As Schedule, _
fileVersion As Integer _
)

Parameters

schedule
The Schedule this class will operate on.
fileVersion
The file version of the file being deserialized.

See Also

BinarySerializationContext Constructor Overload List
BinarySerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.BinarySerializationContext Methods

BinarySerializationContext Methods

Public Methods

Name | Description
ReadBool | Reads a boolean value.
ReadBrush | Reads a MindFusion.Drawing.Brush object.
ReadByte | Reads a byte value.
ReadChar | Reads a char value.
ReadColor | Reads a color.
ReadColorArray | Reads a color array.
ReadCustomBrushes | Reads a CustomBrushes object.
ReadDateTime | Reads a DateTime object.
ReadDecimal | Reads a decimal value.
ReadDouble | Reads a double value.
ReadEnum | Reads an enum value.
ReadFloat | Reads a float value with the specified name.
ReadFloatArray | Reads a float array.
ReadFont | Reads a Font object.
ReadHashtable | Reads a hashtable object.
ReadImage | Reads an Image object.
ReadInt | Reads an integer value.
ReadLong | Reads a long value.
ReadObject | Reads an object.
ReadPen | Reads a MindFusion.Drawing.Pen object.
ReadPointF | Reads a PointF object.
ReadRectangleF | Reads a RectangleF object.
ReadRecurrence | Reads a Recurrence object.
ReadReminder | Reads a Reminder object.
ReadSByte | Reads a 8-bit signed integer value.
ReadShort | Reads a short value.
ReadSizeF | Reads a SizeF object.
ReadStream | Reads a stream.
ReadString | Reads a string value.
ReadStringFormat | Reads a StringFormat object.
ReadStyle | Reads a Style object.
ReadTag | Reads a tag object for the specified object.
ReadUInt | Reads an unsigned integer value.
ReadULong | Reads an unsigned long value.
ReadUShort | Reads an unsigned short value.
WriteBool | Writes a boolean value.
WriteBrush | Writes a Brush object.
WriteByte | Write a byte value to the stream.
WriteChar | Write a char value to the stream.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteCustomBrushes | Writes the specified CustomBrushes object.
WriteDateTime | Writes the specified DateTime object.
WriteDecimal | Write a decimal value to the stream.
WriteDouble | Writes a double value.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes the specified image.
WriteInt | Writes an integer value.
WriteLong | Writes a long value.
WriteObject | Writes the specified object.
WritePen | Writes a Pen object.
WritePointF | Writes a PointF object.
WriteRectangleF | Writes a RectangleF object.
WriteRecurrence | Writes the specified Recurrence object.
WriteReminder | Writes the specified Reminder object.
WriteSByte | Write a 8-bit signed integer value to the stream.
WriteShort | Writes a short value.
WriteSizeF | Writes a SizeF object.
WriteStream | Writes the specified stream.
WriteString | Writes a string value.
WriteStringFormat | Writes the specified StringFormat object.
WriteStyle | Writes the specified Style object.
WriteTag | Writes the specified tag of the specified object.
WriteUInt | Writes an unsigned integer value.
WriteULong | Writes an unsigned long value.
WriteUShort | Writes an unsigned short value.

See Also

BinarySerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.BinarySerializationContext.ReadBool Method

BinarySerializationContext.ReadBool Method

Reads a boolean value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ReadBool (
BinaryReader reader
)
Visual Basic

Public Function ReadBool ( _
reader As BinaryReader _
) As Boolean

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

A bool value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteBool Method


MindFusion.Scheduling.BinarySerializationContext.ReadBrush Method

BinarySerializationContext.ReadBrush Method

Reads a MindFusion.Drawing.Brush object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush ReadBrush (
BinaryReader reader
)
Visual Basic

Public Function ReadBrush ( _
reader As BinaryReader _
) As Brush

Parameters

reader
A .NET BinaryReader to read the brush from.

Return Value

An instance of the MindFusion.Drawing.Brush class.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteBrush Method


MindFusion.Scheduling.BinarySerializationContext.ReadByte Method

BinarySerializationContext.ReadByte Method

Reads a byte value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public byte ReadByte (
BinaryReader reader
)
Visual Basic

Public Function ReadByte ( _
reader As BinaryReader _
) As Byte

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

A byte value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteByte Method


MindFusion.Scheduling.BinarySerializationContext.ReadChar Method

BinarySerializationContext.ReadChar Method

Reads a char value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public char ReadChar (
BinaryReader reader
)
Visual Basic

Public Function ReadChar ( _
reader As BinaryReader _
) As Char

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

A char value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteChar Method


MindFusion.Scheduling.BinarySerializationContext.ReadColor Method

BinarySerializationContext.ReadColor Method

Reads a color.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color ReadColor (
BinaryReader reader
)
Visual Basic

Public Function ReadColor ( _
reader As BinaryReader _
) As Color

Parameters

reader
A .NET BinaryReader to read the color from.

Return Value

A .NET Color object.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteColor Method


MindFusion.Scheduling.BinarySerializationContext.ReadColorArray Method

BinarySerializationContext.ReadColorArray Method

Reads a color array.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color[] ReadColorArray (
BinaryReader reader
)
Visual Basic

Public Function ReadColorArray ( _
reader As BinaryReader _
) As Color()

Parameters

reader
A .NET BinaryReader to read the array from.

Return Value

An array of .NET Color objects.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteColorArray Method


MindFusion.Scheduling.BinarySerializationContext.ReadCustomBrushes Method

BinarySerializationContext.ReadCustomBrushes Method

Reads a CustomBrushes object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public CustomBrushes ReadCustomBrushes (
BinaryReader reader
)
Visual Basic

Public Function ReadCustomBrushes ( _
reader As BinaryReader _
) As CustomBrushes

Parameters

reader
A .NET BinaryReader to read the brushes from.

Return Value

An instance of the CustomBrushes class.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteCustomBrushes Method


MindFusion.Scheduling.BinarySerializationContext.ReadDateTime Method

BinarySerializationContext.ReadDateTime Method

Reads a DateTime object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime ReadDateTime (
BinaryReader reader
)
Visual Basic

Public Function ReadDateTime ( _
reader As BinaryReader _
) As DateTime

Parameters

reader
A .NET BinaryReader to read the date from.

Return Value

A .NET DateTime object.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteDateTime Method


MindFusion.Scheduling.BinarySerializationContext.ReadDecimal Method

BinarySerializationContext.ReadDecimal Method

Reads a decimal value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Decimal ReadDecimal (
BinaryReader reader
)
Visual Basic

Public Function ReadDecimal ( _
reader As BinaryReader _
) As Decimal

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

A decimal value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteDecimal Method


MindFusion.Scheduling.BinarySerializationContext.ReadDouble Method

BinarySerializationContext.ReadDouble Method

Reads a double value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public double ReadDouble (
BinaryReader reader
)
Visual Basic

Public Function ReadDouble ( _
reader As BinaryReader _
) As Double

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

A double value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteDouble Method


MindFusion.Scheduling.BinarySerializationContext.ReadEnum Method

BinarySerializationContext.ReadEnum Method

Reads an enum value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Object ReadEnum (
BinaryReader reader
)
Visual Basic

Public Function ReadEnum ( _
reader As BinaryReader _
) As Object

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

An enum value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteEnum Method


MindFusion.Scheduling.BinarySerializationContext.ReadFloat Method

BinarySerializationContext.ReadFloat Method

Reads a float value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public float ReadFloat (
BinaryReader reader
)
Visual Basic

Public Function ReadFloat ( _
reader As BinaryReader _
) As Single

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

A float value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteFloat Method


MindFusion.Scheduling.BinarySerializationContext.ReadFloatArray Method

BinarySerializationContext.ReadFloatArray Method

Reads a float array.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public float[] ReadFloatArray (
BinaryReader reader
)
Visual Basic

Public Function ReadFloatArray ( _
reader As BinaryReader _
) As Single()

Parameters

reader
A .NET BinaryReader to read the array from.

Return Value

An array of float values.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteFloatArray Method


MindFusion.Scheduling.BinarySerializationContext.ReadFont Method

BinarySerializationContext.ReadFont Method

Reads a Font object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Font ReadFont (
BinaryReader reader
)
Visual Basic

Public Function ReadFont ( _
reader As BinaryReader _
) As Font

Parameters

reader
A .NET BinaryReader to read the font from.

Return Value

A .NET Font object.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteFont Method


MindFusion.Scheduling.BinarySerializationContext.ReadHashtable Method

BinarySerializationContext.ReadHashtable Method

Reads a hashtable object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Hashtable ReadHashtable (
BinaryReader reader
)
Visual Basic

Public Function ReadHashtable ( _
reader As BinaryReader _
) As Hashtable

Parameters

reader
A .NET BinaryReader to read the hashtable from.

Return Value

A .NET Hashtable object.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteHashtable Method


MindFusion.Scheduling.BinarySerializationContext.ReadImage Method

BinarySerializationContext.ReadImage Method

Reads an Image object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Image ReadImage (
BinaryReader reader
)
Visual Basic

Public Function ReadImage ( _
reader As BinaryReader _
) As Image

Parameters

reader
A .NET BinaryReader to read the image from.

Return Value

A .NET Image object.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteImage Method


MindFusion.Scheduling.BinarySerializationContext.ReadInt Method

BinarySerializationContext.ReadInt Method

Reads an integer value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int ReadInt (
BinaryReader reader
)
Visual Basic

Public Function ReadInt ( _
reader As BinaryReader _
) As Integer

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

An integer value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteInt Method


MindFusion.Scheduling.BinarySerializationContext.ReadLong Method

BinarySerializationContext.ReadLong Method

Reads a long value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public long ReadLong (
BinaryReader reader
)
Visual Basic

Public Function ReadLong ( _
reader As BinaryReader _
) As Long

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

A long value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteLong Method


MindFusion.Scheduling.BinarySerializationContext.ReadObject Method

BinarySerializationContext.ReadObject Method

Reads an object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Object ReadObject (
BinaryReader reader
)
Visual Basic

Public Function ReadObject ( _
reader As BinaryReader _
) As Object

Parameters

reader
A .NET BinaryReader to read the object from.

Return Value

An object.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteObject Method


MindFusion.Scheduling.BinarySerializationContext.ReadPen Method

BinarySerializationContext.ReadPen Method

Reads a MindFusion.Drawing.Pen object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Pen ReadPen (
BinaryReader reader
)
Visual Basic

Public Function ReadPen ( _
reader As BinaryReader _
) As Pen

Parameters

reader
A .NET BinaryReader to read the pen from.

Return Value

An instance of the MindFusion.Drawing.Pen class.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WritePen Method


MindFusion.Scheduling.BinarySerializationContext.ReadPointF Method

BinarySerializationContext.ReadPointF Method

Reads a PointF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public PointF ReadPointF (
BinaryReader reader
)
Visual Basic

Public Function ReadPointF ( _
reader As BinaryReader _
) As PointF

Parameters

reader
A .NET BinaryReader to read the point from.

Return Value

A .NET PointF object.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WritePointF Method


MindFusion.Scheduling.BinarySerializationContext.ReadRectangleF Method

BinarySerializationContext.ReadRectangleF Method

Reads a RectangleF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public RectangleF ReadRectangleF (
BinaryReader reader
)
Visual Basic

Public Function ReadRectangleF ( _
reader As BinaryReader _
) As RectangleF

Parameters

reader
A .NET BinaryReader to read the rectangle from.

Return Value

A .NET RectangleF object.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteRectangleF Method


MindFusion.Scheduling.BinarySerializationContext.ReadRecurrence Method

BinarySerializationContext.ReadRecurrence Method

Reads a Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Recurrence ReadRecurrence (
BinaryReader reader
)
Visual Basic

Public Function ReadRecurrence ( _
reader As BinaryReader _
) As Recurrence

Parameters

reader
A .NET BinaryReader to read the recurrence from.

Return Value

An instance of the Recurrence class.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteRecurrence Method


MindFusion.Scheduling.BinarySerializationContext.ReadReminder Method

BinarySerializationContext.ReadReminder Method

Reads a Reminder object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Reminder ReadReminder (
BinaryReader reader
)
Visual Basic

Public Function ReadReminder ( _
reader As BinaryReader _
) As Reminder

Parameters

reader
A .NET BinaryReader to read the reminder from.

Return Value

An instance of the Reminder class.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteReminder Method


MindFusion.Scheduling.BinarySerializationContext.ReadSByte Method

BinarySerializationContext.ReadSByte Method

Reads a 8-bit signed integer value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public sbyte ReadSByte (
BinaryReader reader
)
Visual Basic

Public Function ReadSByte ( _
reader As BinaryReader _
) As SByte

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

A signed byte value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteSByte Method


MindFusion.Scheduling.BinarySerializationContext.ReadShort Method

BinarySerializationContext.ReadShort Method

Reads a short value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public short ReadShort (
BinaryReader reader
)
Visual Basic

Public Function ReadShort ( _
reader As BinaryReader _
) As Short

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

A short value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteShort Method


MindFusion.Scheduling.BinarySerializationContext.ReadSizeF Method

BinarySerializationContext.ReadSizeF Method

Reads a SizeF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public SizeF ReadSizeF (
BinaryReader reader
)
Visual Basic

Public Function ReadSizeF ( _
reader As BinaryReader _
) As SizeF

Parameters

reader
A .NET BinaryReader to read the size from.

Return Value

A .NET SizeF object.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteSizeF Method


MindFusion.Scheduling.BinarySerializationContext.ReadStream Method

BinarySerializationContext.ReadStream Method

Reads a stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Stream ReadStream (
BinaryReader reader
)
Visual Basic

Public Function ReadStream ( _
reader As BinaryReader _
) As Stream

Parameters

reader
A .NET BinaryReader to read the stream from.

Return Value

A .NET Stream object.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteStream Method


MindFusion.Scheduling.BinarySerializationContext.ReadString Method

BinarySerializationContext.ReadString Method

Reads a string value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string ReadString (
BinaryReader reader
)
Visual Basic

Public Function ReadString ( _
reader As BinaryReader _
) As String

Parameters

reader
A .NET BinaryReader to read the string from.

Return Value

A string value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteString Method


MindFusion.Scheduling.BinarySerializationContext.ReadStringFormat Method

BinarySerializationContext.ReadStringFormat Method

Reads a StringFormat object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public StringFormat ReadStringFormat (
BinaryReader reader
)
Visual Basic

Public Function ReadStringFormat ( _
reader As BinaryReader _
) As StringFormat

Parameters

reader
A .NET BinaryReader to read the string format from.

Return Value

A .NET StringFormat object.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteStringFormat Method


MindFusion.Scheduling.BinarySerializationContext.ReadStyle Method

BinarySerializationContext.ReadStyle Method

Reads a Style object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Style ReadStyle (
BinaryReader reader
)
Visual Basic

Public Function ReadStyle ( _
reader As BinaryReader _
) As Style

Parameters

reader
A .NET BinaryReader to read the style from.

Return Value

An instance of the Style class.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteStyle Method


MindFusion.Scheduling.BinarySerializationContext.ReadTag Method

BinarySerializationContext.ReadTag Method

Reads a tag object for the specified object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Object ReadTag (
BinaryReader reader
)
Visual Basic

Public Function ReadTag ( _
reader As BinaryReader _
) As Object

Parameters

reader
A .NET BinaryReader to read the tag from.

Return Value

An object representing the item tag.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteTag Method


MindFusion.Scheduling.BinarySerializationContext.ReadUInt Method

BinarySerializationContext.ReadUInt Method

Reads an unsigned integer value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public uint ReadUInt (
BinaryReader reader
)
Visual Basic

Public Function ReadUInt ( _
reader As BinaryReader _
) As UInteger

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

An unsigned integer value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteUInt Method


MindFusion.Scheduling.BinarySerializationContext.ReadULong Method

BinarySerializationContext.ReadULong Method

Reads an unsigned long value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ulong ReadULong (
BinaryReader reader
)
Visual Basic

Public Function ReadULong ( _
reader As BinaryReader _
) As ULong

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

An unsigned long value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteULong Method


MindFusion.Scheduling.BinarySerializationContext.ReadUShort Method

BinarySerializationContext.ReadUShort Method

Reads an unsigned short value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ushort ReadUShort (
BinaryReader reader
)
Visual Basic

Public Function ReadUShort ( _
reader As BinaryReader _
) As UShort

Parameters

reader
A .NET BinaryReader to read the value from.

Return Value

An unsigned short value.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
WriteUShort Method


MindFusion.Scheduling.BinarySerializationContext.WriteBool Method

BinarySerializationContext.WriteBool Method

Writes a boolean value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteBool (
bool boolValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteBool ( _
boolValue As Boolean, _
writer As BinaryWriter _
)

Parameters

boolValue
The bool value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadBool Method


MindFusion.Scheduling.BinarySerializationContext.WriteBrush Method

BinarySerializationContext.WriteBrush Method

Writes a Brush object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteBrush (
Brush brush,
BinaryWriter writer
)
Visual Basic

Public Sub WriteBrush ( _
brush As Brush, _
writer As BinaryWriter _
)

Parameters

brush
The Brush instance to write.
writer
A .NET BinaryWriter to write the brush to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadBrush Method


MindFusion.Scheduling.BinarySerializationContext.WriteByte Method

BinarySerializationContext.WriteByte Method

Write a byte value to the stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteByte (
byte byteValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteByte ( _
byteValue As Byte, _
writer As BinaryWriter _
)

Parameters

byteValue
The byte value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadByte Method


MindFusion.Scheduling.BinarySerializationContext.WriteChar Method

BinarySerializationContext.WriteChar Method

Write a char value to the stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteChar (
char charValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteChar ( _
charValue As Char, _
writer As BinaryWriter _
)

Parameters

charValue
The char value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadChar Method


MindFusion.Scheduling.BinarySerializationContext.WriteColor Method

BinarySerializationContext.WriteColor Method

Writes the specified color.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteColor (
Color color,
BinaryWriter writer
)
Visual Basic

Public Sub WriteColor ( _
color As Color, _
writer As BinaryWriter _
)

Parameters

color
The .NET Color object to write.
writer
A .NET BinaryWriter to write the color to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadColor Method


MindFusion.Scheduling.BinarySerializationContext.WriteColorArray Method

BinarySerializationContext.WriteColorArray Method

Writes the specified array.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteColorArray (
Color[] array,
BinaryWriter writer
)
Visual Basic

Public Sub WriteColorArray ( _
array() As Color, _
writer As BinaryWriter _
)

Parameters

array
The array to write.
writer
A .NET BinaryWriter to write the array to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadColorArray Method


MindFusion.Scheduling.BinarySerializationContext.WriteCustomBrushes Method

BinarySerializationContext.WriteCustomBrushes Method

Writes the specified CustomBrushes object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteCustomBrushes (
CustomBrushes customBrushes,
BinaryWriter writer
)
Visual Basic

Public Sub WriteCustomBrushes ( _
customBrushes As CustomBrushes, _
writer As BinaryWriter _
)

Parameters

customBrushes
The CustomBrushes instance to write.
writer
A .NET BinaryWriter to write the brushes to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadCustomBrushes Method


MindFusion.Scheduling.BinarySerializationContext.WriteDateTime Method

BinarySerializationContext.WriteDateTime Method

Writes the specified DateTime object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteDateTime (
DateTime dateTime,
BinaryWriter writer
)
Visual Basic

Public Sub WriteDateTime ( _
dateTime As DateTime, _
writer As BinaryWriter _
)

Parameters

dateTime
The .NET DateTime object to write.
writer
A .NET BinaryWriter to write the date to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadDateTime Method


MindFusion.Scheduling.BinarySerializationContext.WriteDecimal Method

BinarySerializationContext.WriteDecimal Method

Write a decimal value to the stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteDecimal (
Decimal decimalValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteDecimal ( _
decimalValue As Decimal, _
writer As BinaryWriter _
)

Parameters

decimalValue
The decimal value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadDecimal Method


MindFusion.Scheduling.BinarySerializationContext.WriteDouble Method

BinarySerializationContext.WriteDouble Method

Writes a double value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteDouble (
double doubleValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteDouble ( _
doubleValue As Double, _
writer As BinaryWriter _
)

Parameters

doubleValue
The double value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadDouble Method


MindFusion.Scheduling.BinarySerializationContext.WriteEnum Method

BinarySerializationContext.WriteEnum Method

Writes the specified enum value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteEnum (
Object enumValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteEnum ( _
enumValue As Object, _
writer As BinaryWriter _
)

Parameters

enumValue
The enum value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadEnum Method


MindFusion.Scheduling.BinarySerializationContext.WriteFloat Method

BinarySerializationContext.WriteFloat Method

Writes a float value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteFloat (
float floatValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteFloat ( _
floatValue As Single, _
writer As BinaryWriter _
)

Parameters

floatValue
The float value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadFloat Method


MindFusion.Scheduling.BinarySerializationContext.WriteFloatArray Method

BinarySerializationContext.WriteFloatArray Method

Writes the specified array.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteFloatArray (
float[] array,
BinaryWriter writer
)
Visual Basic

Public Sub WriteFloatArray ( _
array() As Single, _
writer As BinaryWriter _
)

Parameters

array
The array to write.
writer
A .NET BinaryWriter to write the array to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadFloatArray Method


MindFusion.Scheduling.BinarySerializationContext.WriteFont Method

BinarySerializationContext.WriteFont Method

Writes the specified font.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteFont (
Font font,
BinaryWriter writer
)
Visual Basic

Public Sub WriteFont ( _
font As Font, _
writer As BinaryWriter _
)

Parameters

font
The .NET Font object to write.
writer
A .NET BinaryWriter to write the font to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadFont Method


MindFusion.Scheduling.BinarySerializationContext.WriteHashtable Method

BinarySerializationContext.WriteHashtable Method

Writes the specified hashtable.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteHashtable (
Hashtable hashtable,
BinaryWriter writer
)
Visual Basic

Public Sub WriteHashtable ( _
hashtable As Hashtable, _
writer As BinaryWriter _
)

Parameters

hashtable
The .NET Hashtable object to write.
writer
A .NET BinaryWriter to write the hashtable to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadHashtable Method


MindFusion.Scheduling.BinarySerializationContext.WriteImage Method

BinarySerializationContext.WriteImage Method

Writes the specified image.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteImage (
Image image,
BinaryWriter writer
)
Visual Basic

Public Sub WriteImage ( _
image As Image, _
writer As BinaryWriter _
)

Parameters

image
The .NET Image object to write.
writer
A .NET BinaryWriter to write the image to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadImage Method


MindFusion.Scheduling.BinarySerializationContext.WriteInt Method

BinarySerializationContext.WriteInt Method

Writes an integer value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteInt (
int intValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteInt ( _
intValue As Integer, _
writer As BinaryWriter _
)

Parameters

intValue
The integer value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadInt Method


MindFusion.Scheduling.BinarySerializationContext.WriteLong Method

BinarySerializationContext.WriteLong Method

Writes a long value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteLong (
long longValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteLong ( _
longValue As Long, _
writer As BinaryWriter _
)

Parameters

longValue
The long value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadLong Method


MindFusion.Scheduling.BinarySerializationContext.WriteObject Method

BinarySerializationContext.WriteObject Method

Writes the specified object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteObject (
Object objectValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteObject ( _
objectValue As Object, _
writer As BinaryWriter _
)

Parameters

objectValue
The object to write.
writer
A .NET BinaryWriter to write the object to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadObject Method


MindFusion.Scheduling.BinarySerializationContext.WritePen Method

BinarySerializationContext.WritePen Method

Writes a Pen object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WritePen (
Pen pen,
BinaryWriter writer
)
Visual Basic

Public Sub WritePen ( _
pen As Pen, _
writer As BinaryWriter _
)

Parameters

pen
The Pen instance to write.
writer
A .NET BinaryWriter to write the pen to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadPen Method


MindFusion.Scheduling.BinarySerializationContext.WritePointF Method

BinarySerializationContext.WritePointF Method

Writes a PointF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WritePointF (
PointF point,
BinaryWriter writer
)
Visual Basic

Public Sub WritePointF ( _
point As PointF, _
writer As BinaryWriter _
)

Parameters

point
The .NET PointF object to write.
writer
A .NET BinaryWriter to write the point to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadPointF Method


MindFusion.Scheduling.BinarySerializationContext.WriteRectangleF Method

BinarySerializationContext.WriteRectangleF Method

Writes a RectangleF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteRectangleF (
RectangleF rectangle,
BinaryWriter writer
)
Visual Basic

Public Sub WriteRectangleF ( _
rectangle As RectangleF, _
writer As BinaryWriter _
)

Parameters

rectangle
The .NET RectangleF object to write.
writer
A .NET BinaryWriter to write the rectangle to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadRectangleF Method


MindFusion.Scheduling.BinarySerializationContext.WriteRecurrence Method

BinarySerializationContext.WriteRecurrence Method

Writes the specified Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteRecurrence (
Recurrence recurrence,
BinaryWriter writer
)
Visual Basic

Public Sub WriteRecurrence ( _
recurrence As Recurrence, _
writer As BinaryWriter _
)

Parameters

recurrence
The Recurrence instance to write.
writer
A .NET BinaryWriter to write the recurrence to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadRecurrence Method


MindFusion.Scheduling.BinarySerializationContext.WriteReminder Method

BinarySerializationContext.WriteReminder Method

Writes the specified Reminder object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteReminder (
Reminder reminder,
BinaryWriter writer
)
Visual Basic

Public Sub WriteReminder ( _
reminder As Reminder, _
writer As BinaryWriter _
)

Parameters

reminder
The Reminder instance to write.
writer
A .NET BinaryWriter to write the reminder to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadReminder Method


MindFusion.Scheduling.BinarySerializationContext.WriteSByte Method

BinarySerializationContext.WriteSByte Method

Write a 8-bit signed integer value to the stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteSByte (
sbyte byteValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteSByte ( _
byteValue As SByte, _
writer As BinaryWriter _
)

Parameters

byteValue
The signed byte value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadSByte Method


MindFusion.Scheduling.BinarySerializationContext.WriteShort Method

BinarySerializationContext.WriteShort Method

Writes a short value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteShort (
short shortValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteShort ( _
shortValue As Short, _
writer As BinaryWriter _
)

Parameters

shortValue
The short value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadShort Method


MindFusion.Scheduling.BinarySerializationContext.WriteSizeF Method

BinarySerializationContext.WriteSizeF Method

Writes a SizeF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteSizeF (
SizeF size,
BinaryWriter writer
)
Visual Basic

Public Sub WriteSizeF ( _
size As SizeF, _
writer As BinaryWriter _
)

Parameters

size
The .NET SizeF object to write.
writer
A .NET BinaryWriter to write the size to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadSizeF Method


MindFusion.Scheduling.BinarySerializationContext.WriteStream Method

BinarySerializationContext.WriteStream Method

Writes the specified stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteStream (
Stream stream,
BinaryWriter writer
)
Visual Basic

Public Sub WriteStream ( _
stream As Stream, _
writer As BinaryWriter _
)

Parameters

stream
The .NET Stream object to write.
writer
A .NET BinaryWriter to write the stream to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadStream Method


MindFusion.Scheduling.BinarySerializationContext.WriteString Method

BinarySerializationContext.WriteString Method

Writes a string value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteString (
string stringValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteString ( _
stringValue As String, _
writer As BinaryWriter _
)

Parameters

stringValue
The string value to write.
writer
A .NET BinaryWriter to write the string to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadString Method


MindFusion.Scheduling.BinarySerializationContext.WriteStringFormat Method

BinarySerializationContext.WriteStringFormat Method

Writes the specified StringFormat object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteStringFormat (
StringFormat stringFormat,
BinaryWriter writer
)
Visual Basic

Public Sub WriteStringFormat ( _
stringFormat As StringFormat, _
writer As BinaryWriter _
)

Parameters

stringFormat
The .NET StringFormat object to write.
writer
A .NET BinaryWriter to write the string format to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadStringFormat Method


MindFusion.Scheduling.BinarySerializationContext.WriteStyle Method

BinarySerializationContext.WriteStyle Method

Writes the specified Style object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteStyle (
Style style,
BinaryWriter writer
)
Visual Basic

Public Sub WriteStyle ( _
style As Style, _
writer As BinaryWriter _
)

Parameters

style
The Style instance to write.
writer
A .NET BinaryWriter to write the style to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadStyle Method


MindFusion.Scheduling.BinarySerializationContext.WriteTag Method

BinarySerializationContext.WriteTag Method

Writes the specified tag of the specified object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteTag (
Object tagValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteTag ( _
tagValue As Object, _
writer As BinaryWriter _
)

Parameters

tagValue
The tag object to write.
writer
A .NET BinaryWriter to write the tag to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadTag Method


MindFusion.Scheduling.BinarySerializationContext.WriteUInt Method

BinarySerializationContext.WriteUInt Method

Writes an unsigned integer value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteUInt (
uint uintValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteUInt ( _
uintValue As UInteger, _
writer As BinaryWriter _
)

Parameters

uintValue
The unsigned integer value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadUInt Method


MindFusion.Scheduling.BinarySerializationContext.WriteULong Method

BinarySerializationContext.WriteULong Method

Writes an unsigned long value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteULong (
ulong ulongValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteULong ( _
ulongValue As ULong, _
writer As BinaryWriter _
)

Parameters

ulongValue
The unsigned long value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadULong Method


MindFusion.Scheduling.BinarySerializationContext.WriteUShort Method

BinarySerializationContext.WriteUShort Method

Writes an unsigned short value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void WriteUShort (
ushort ushortValue,
BinaryWriter writer
)
Visual Basic

Public Sub WriteUShort ( _
ushortValue As UShort, _
writer As BinaryWriter _
)

Parameters

ushortValue
The unsigned short value to write.
writer
A .NET BinaryWriter to write the value to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace
ReadUShort Method


MindFusion.Scheduling.BinarySerializationContext Properties

BinarySerializationContext Properties

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.

See Also

BinarySerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.BinarySerializationContext.ClassVersion Property

BinarySerializationContext.ClassVersion Property

Gets the class version of the currently deserialized item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int ClassVersion { get; }
Visual Basic

Public ReadOnly Property ClassVersion As Integer

Property Value

An integer value specifying the class version of the currently deserialized item as specified by the call to RegisterItemClass method at the time the item type was registered.

Remarks

This property is only useful when deserializing items.

See Also

BinarySerializationContext Members
BinarySerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Class

Contact Class

Instances of the Contact class contain information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class Contact : Resource
Visual Basic

Public Class Contact
Inherits Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Contact

See Also

Contact Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Members

Contact Members
Constructors Properties Methods

Instances of the Contact class contain information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.

The following tables list the members exposed by the Contact type.

Public Constructors

Name | Description
Contact | Initializes a new instance of the Contact class.

Public Properties

Name | Description
Address | Gets or sets the address of the contact.
Email | Gets or sets the e-mail address of the contact.
FirstName | Gets or sets the first name of the contact.
LastName | Gets or sets the last name of the contact.
MiddleName | Gets or sets the middle name of the contact.
Phone | Gets or sets the phone of the contact.

Public Methods

Name | Description
LoadFrom | Overloaded. Loads contact data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the contact data to a binary stream or an XML document.

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Constructor

Contact Constructor

Initializes a new instance of the Contact class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Contact ()
Visual Basic

Public Sub New ()

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Methods

Contact Methods

Public Methods

Name | Description
LoadFrom | Overloaded. Loads contact data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the contact data to a binary stream or an XML document.

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.LoadFrom Method

Contact.LoadFrom Method

Loads contact data from a binary stream or an XML document.

Overload List

Name | Description
Contact.LoadFrom (BinaryReader, BinarySerializationContext) | Loads contact data from a binary stream.
Contact.LoadFrom (XmlElement, XmlSerializationContext) | Loads contact data from an XML document.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.LoadFrom Method (BinaryReader, BinarySerializationContext)

Contact.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also

Loads contact data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Allows reading primitive data types from a binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

The reader parameter wraps a stream that contains data stored by a previous call to the SaveTo method.

See Also

LoadFrom Method Overload List
Contact Members
Contact Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Contact.LoadFrom Method (XmlElement, XmlSerializationContext)

Contact.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads contact data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

The context parameter wraps an XML document that contains data stored by a previous call to the SaveTo method.

See Also

LoadFrom Method Overload List
Contact Members
Contact Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Contact.SaveTo Method

Contact.SaveTo Method

Saves the contact data to a binary stream or an XML document.

Overload List

Name | Description
Contact.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the contact data to a binary stream.
Contact.SaveTo (XmlElement, XmlSerializationContext) | Saves the contact data to an XML document.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.SaveTo Method (BinaryWriter, BinarySerializationContext)

Contact.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also

Saves the contact data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Allows writing primitive data types to a binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

See Also

SaveTo Method Overload List
Contact Members
Contact Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Contact.SaveTo Method (XmlElement, XmlSerializationContext)

Contact.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the contact data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the contact properties as elements of an XML document.

See Also

SaveTo Method Overload List
Contact Members
Contact Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Contact Properties

Contact Properties

Public Properties

Name | Description
Address | Gets or sets the address of the contact.
Email | Gets or sets the e-mail address of the contact.
FirstName | Gets or sets the first name of the contact.
LastName | Gets or sets the last name of the contact.
MiddleName | Gets or sets the middle name of the contact.
Phone | Gets or sets the phone of the contact.

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.Address Property

Contact.Address Property

Gets or sets the address of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string Address { get; set; }
Visual Basic

Public Property Address As String

Property Value

A string containing address information. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.Email Property

Contact.Email Property

Gets or sets the e-mail address of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string Email { get; set; }
Visual Basic

Public Property Email As String

Property Value

A string containing an e-mail address. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.FirstName Property

Contact.FirstName Property

Gets or sets the first name of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string FirstName { get; set; }
Visual Basic

Public Property FirstName As String

Property Value

A string containing the first name of a person. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
LastName Property
MiddleName Property


MindFusion.Scheduling.Contact.LastName Property

Contact.LastName Property

Gets or sets the last name of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string LastName { get; set; }
Visual Basic

Public Property LastName As String

Property Value

A string containing person's last name. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
FirstName Property
LastName Property


MindFusion.Scheduling.Contact.MiddleName Property

Contact.MiddleName Property

Gets or sets the middle name of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string MiddleName { get; set; }
Visual Basic

Public Property MiddleName As String

Property Value

A string containing person's last name. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
FirstName Property
LastName Property


MindFusion.Scheduling.Contact.Phone Property

Contact.Phone Property

Gets or sets the phone of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string Phone { get; set; }
Visual Basic

Public Property Phone As String

Property Value

A string containing a phone number. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection Class

ContactCollection Class

Represents a strongly-typed collection of Contact objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class ContactCollection : CollectionBase
Visual Basic

Public NotInheritable Class ContactCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.ContactCollection

See Also

ContactCollection Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection Members

ContactCollection Members
Constructors Properties Methods Events

Represents a strongly-typed collection of Contact objects.

The following tables list the members exposed by the ContactCollection type.

Public Constructors

Name | Description
ContactCollection | Initializes a new instance of the ContactCollection class.

Public Properties

Name | Description
Item | Gets a Contact object from the collection given its zero-based index or identifier.

Public Methods

Name | Description
Add | Adds the specified contact to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified contact.
Insert | Inserts the specified Contact object at the specified position within the collection.
Remove | Removes the first occurrence of the specified Contact object from this collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection Constructor

ContactCollection Constructor

Initializes a new instance of the ContactCollection class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ContactCollection ()
Visual Basic

Public Sub New ()

See Also

ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection Methods

ContactCollection Methods

Public Methods

Name | Description
Add | Adds the specified contact to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified contact.
Insert | Inserts the specified Contact object at the specified position within the collection.
Remove | Removes the first occurrence of the specified Contact object from this collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.

See Also

ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Add Method

ContactCollection.Add Method

Adds the specified contact to this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Add (
Contact contact
)
Visual Basic

Public Sub Add ( _
contact As Contact _
)

Parameters

contact
An instance of the Contact class to be added to the collection.

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace
Insert Method


MindFusion.Scheduling.ContactCollection.Clear Method

ContactCollection.Clear Method

Removes all elements from the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Contains Method

ContactCollection.Contains Method

Determines whether this collection contains the specified contact.

Overload List

Name | Description
ContactCollection.Contains (Contact) | Determines whether this collection contains the specified contact.
ContactCollection.Contains (String) | Determines whether this collection contains a contact identified by the specified string.

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Contains Method (Contact)

ContactCollection.Contains Method (Contact)
See Also

Determines whether this collection contains the specified contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
Contact contact
)
Visual Basic

Public Function Contains ( _
contact As Contact _
) As Boolean

Parameters

contact
The Contact object to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Contains Method (String)

ContactCollection.Contains Method (String)
See Also

Determines whether this collection contains a contact identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
string contactId
)
Visual Basic

Public Function Contains ( _
contactId As String _
) As Boolean

Parameters

contactId
The identifier of a contact to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Insert Method

ContactCollection.Insert Method

Inserts the specified Contact object at the specified position within the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Insert (
int index,
Contact contact
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
contact As Contact _
)

Parameters

index
The zero-based index at which the contact must be inserted.
contact
An instance of the Contact class to be added to the collection.

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace
Add Method


MindFusion.Scheduling.ContactCollection.OnClearComplete Method

ContactCollection.OnClearComplete Method

CollectionBase.OnClearComplete override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnClearComplete ()
Visual Basic

Protected Overridable Sub OnClearComplete ()

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.OnInsertComplete Method

ContactCollection.OnInsertComplete Method

CollectionBase.OnInsertComplete override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnInsertComplete (
int index,
Object value
)
Visual Basic

Protected Overridable Sub OnInsertComplete ( _
index As Integer, _
value As Object _
)

Parameters

index
value

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.OnRemoveComplete Method

ContactCollection.OnRemoveComplete Method

CollectionBase.OnRemoveComplete override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnRemoveComplete (
int index,
Object value
)
Visual Basic

Protected Overridable Sub OnRemoveComplete ( _
index As Integer, _
value As Object _
)

Parameters

index
value

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Remove Method

ContactCollection.Remove Method

Removes the first occurrence of the specified Contact object from this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Remove (
Contact contact
)
Visual Basic

Public Sub Remove ( _
contact As Contact _
)

Parameters

contact
A Contact instance which must be removed from the collection.

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection Properties

ContactCollection Properties

Public Properties

Name | Description
Item | Gets a Contact object from the collection given its zero-based index or identifier.

See Also

ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Item Property

ContactCollection.Item Property

Gets a Contact object from the collection given its zero-based index or identifier.

Overload List

Name | Description
ContactCollection.Item (Int32) | Gets or sets the Contact object located at the specified position within this collection.
ContactCollection.Item (String) | Gets the Contact object identified by the specified string.

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Item Property (Int32)

ContactCollection.Item Property (Int32)
See Also

Gets or sets the Contact object located at the specified position within this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Contact Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Contact

Parameters

index
The zero-based index of the Contact to set or retrieve.

Property Value

The Contact instance at the specified index.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their integer indices.

See Also

Item Property Overload List
ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Item Property (String)

ContactCollection.Item Property (String)
See Also

Gets the Contact object identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Contact Item [
string id
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
id As String _
) As Contact

Parameters

id
The Id of the Contact to get.

Property Value

The Contact instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

Item Property Overload List
ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection Events

ContactCollection Events

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Changed Event

ContactCollection.Changed Event

Raised when the collection has been changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler Changed
Visual Basic

Public Event Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContentType Enumeration

ContentType Enumeration

Specifies the type of file contents.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum ContentType
Visual Basic

Public Enumeration ContentType

Members

Member name | Description
Binary | Specifies that a file stores information in binary format.
Xml | Specifies that a file stores information in XML format.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.CustomBrushes Class

CustomBrushes Class

Defines a pair of brushes to be used to paint cells in cells in Timetable, WeekRange and Resource views.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class CustomBrushes
Visual Basic

Public Class CustomBrushes

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.CustomBrushes

See Also

CustomBrushes Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CustomBrushes Members

CustomBrushes Members
Constructors Properties

Defines a pair of brushes to be used to paint cells in cells in Timetable, WeekRange and Resource views.

The following tables list the members exposed by the CustomBrushes type.

Public Constructors

Name | Description
CustomBrushes | Initializes a new instance of the CustomBrushes class.

Public Properties

Name | Description
PrimaryBrush | Gets or sets the brush used to paint primary calendar elements.
SecondaryBrush | Gets or sets the brush used to paint secondary calendar elements.

See Also

CustomBrushes Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CustomBrushes Constructor

CustomBrushes Constructor

Initializes a new instance of the CustomBrushes class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public CustomBrushes ()
Visual Basic

Public Sub New ()

See Also

CustomBrushes Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CustomBrushes Properties

CustomBrushes Properties

Public Properties

Name | Description
PrimaryBrush | Gets or sets the brush used to paint primary calendar elements.
SecondaryBrush | Gets or sets the brush used to paint secondary calendar elements.

See Also

CustomBrushes Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CustomBrushes.PrimaryBrush Property

CustomBrushes.PrimaryBrush Property

Gets or sets the brush used to paint primary calendar elements.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush PrimaryBrush { get; set; }
Visual Basic

Public Property PrimaryBrush As Brush

Property Value

A Brush instance used to fill the interior of calendar UI elements. The default is null (Nothing in Visual Basic).

Remarks

What is painted with this brush depends on the current view and the context in which the CustomBrushes instance is used. For example in timetable view contact's primary custom brush is used to paint the non-work time cells for the contact.

See Also

CustomBrushes Members
CustomBrushes Class
MindFusion.Scheduling Namespace
SecondaryBrush Property


MindFusion.Scheduling.CustomBrushes.SecondaryBrush Property

CustomBrushes.SecondaryBrush Property

Gets or sets the brush used to paint secondary calendar elements.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush SecondaryBrush { get; set; }
Visual Basic

Public Property SecondaryBrush As Brush

Property Value

A Brush instance used to fill the interior of calendar UI elements. The default is null (Nothing in Visual Basic).

Remarks

What is painted with this brush depends on the current view and the context in which the CustomBrushes instance is used. For example in timetable view contact's secondary custom brush is used to paint the work time cells for the contact.

See Also

CustomBrushes Members
CustomBrushes Class
MindFusion.Scheduling Namespace
PrimaryBrush Property


MindFusion.Scheduling.DailyRecurrence Enumeration

DailyRecurrence Enumeration

Specifies how daily recurrence patterns are defined.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum DailyRecurrence
Visual Basic

Public Enumeration DailyRecurrence

Members

Member name | Description
ByDayInterval | Repeats the item after every number of days specified in the Recurrence.Days property.
EveryWeekend | Repeats the item each Saturday and Sunday.
EveryWorkday | Repeats the item each workday, Monday through Friday.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.DayOfWeekType Enumeration

DayOfWeekType Enumeration

Specifies the type of week days, used with ByDayType monthly and yearly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum DayOfWeekType
Visual Basic

Public Enumeration DayOfWeekType

Members

Member name | Description
AnyDay | Indicates any day.
Friday | Indicates Friday.
Monday | Indicates Monday.
Saturday | Indicates Saturday.
Sunday | Indicates Sunday.
Thursday | Indicates Thursday.
Tuesday | Indicates Tuesday.
Wednesday | Indicates Wednesday.
Weekend | Indicates a weekend day.
Workday | Indicates a workday.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.DaysOfWeek Enumeration

DaysOfWeek Enumeration

Specifies the day of the week.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum DaysOfWeek
Visual Basic

Public Enumeration DaysOfWeek

Members

Member name | Description
All | Indicates all days of the week.
Friday | Indicates Friday.
Monday | Indicates Monday.
None | Indicates an undefined day value.
Saturday | Indicates Saturday.
Sunday | Indicates Sunday.
Thursday | Indicates Thursday.
Tuesday | Indicates Tuesday.
Wednesday | Indicates Wednesday.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs Class

InstantiateItemEventArgs Class

Provides data for the InstantiateItem event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class InstantiateItemEventArgs : EventArgs
Visual Basic

Public Class InstantiateItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.InstantiateItemEventArgs

See Also

InstantiateItemEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs Members

InstantiateItemEventArgs Members
Properties

Provides data for the InstantiateItem event.

The following tables list the members exposed by the InstantiateItemEventArgs type.

Public Properties

Name | Description
ClassId | Gets the class identifier of the item.
Item | Gets or sets the newly created item.

See Also

InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs Properties

InstantiateItemEventArgs Properties

Public Properties

Name | Description
ClassId | Gets the class identifier of the item.
Item | Gets or sets the newly created item.

See Also

InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs.ClassId Property

InstantiateItemEventArgs.ClassId Property

Gets the class identifier of the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string ClassId { get; }
Visual Basic

Public ReadOnly Property ClassId As String

Property Value

A string value representing the class identifier of the item, which should be created.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs.Item Property

InstantiateItemEventArgs.Item Property

Gets or sets the newly created item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Item Item { get; set; }
Visual Basic

Public Property Item As Item

Property Value

An instance of an Item-derived class.

Remarks

Upon handling the InstantiateItem event, you have to create an item of the appropriate type, as specified by ClassId, and assign it to this property.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs Class

InstantiateResourceEventArgs Class

Provides data for the InstantiateResource event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class InstantiateResourceEventArgs : EventArgs
Visual Basic

Public Class InstantiateResourceEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.InstantiateResourceEventArgs

See Also

InstantiateResourceEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs Members

InstantiateResourceEventArgs Members
Properties

Provides data for the InstantiateResource event.

The following tables list the members exposed by the InstantiateResourceEventArgs type.

Public Properties

Name | Description
ClassId | Gets the class identifier of the resource.
Resource | Gets or sets the newly created resource.

See Also

InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs Properties

InstantiateResourceEventArgs Properties

Public Properties

Name | Description
ClassId | Gets the class identifier of the resource.
Resource | Gets or sets the newly created resource.

See Also

InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs.ClassId Property

InstantiateResourceEventArgs.ClassId Property

Gets the class identifier of the resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string ClassId { get; }
Visual Basic

Public ReadOnly Property ClassId As String

Property Value

A string value representing the class identifier of the resource, which should be created.

See Also

InstantiateResourceEventArgs Members
InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs.Resource Property

InstantiateResourceEventArgs.Resource Property

Gets or sets the newly created resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Resource Resource { get; set; }
Visual Basic

Public Property Resource As Resource

Property Value

An instance of a Resource-derived class.

Remarks

Upon handling the InstantiateResource event, you have to create a resource of the appropriate type, as specified by ClassId, and assign it to this property.

See Also

InstantiateResourceEventArgs Members
InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Class

Item Class

Represents events scheduled to occur at some point in time. It is derived by concrete classes such as Appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract class Item : ICloneable
Visual Basic

Public MustInherit Class Item
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Item
MindFusion.Scheduling.Appointment

See Also

Item Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Members

Item Members
Constructors Properties Methods

Represents events scheduled to occur at some point in time. It is derived by concrete classes such as Appointment.

The following tables list the members exposed by the Item type.

Protected Constructors

Name | Description
Item | Initializes a new instance of the Item class.

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the item represents an all day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the item's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the item's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the item.
Contacts | Gets references to all contacts associated with this item.
DescriptionText | Gets or sets the description displayed for this item by scheduling controls.
EndTime | Gets or sets the item's scheduled end time.
HeaderText | Gets or sets the header text displayed for this item by scheduling controls.
Id | Gets or sets the string identifier of this item.
Location | Gets or sets the location associated with this item.
Locked | Gets or sets a value indicating whether users are forbidden to modify this item.
OccurrenceIndex | Gets the index of a repeating occurrence of a recurring item.
PointedSelectedStyle | Gets or sets the style associated with the item.
PointedStyle | Gets or sets the style associated with the item.
Priority | Gets or sets the priority of this item.
Recurrence | Gets or sets the recurrence pattern of this item.
RecurrenceState | Gets the recurrence state of this item.
Reminder | Gets or sets the reminder for this item.
Resources | Gets references to all resources associated with this item.
SelectedStyle | Gets or sets the selected style associated with the item.
StartTime | Gets or sets the item's scheduled start time.
Style | Gets or sets a style associated with the item.
Tag | Gets or sets custom data associated with the item.
Task | Gets or sets the task associated with this item.
Visible | Gets or sets a flag indicating whether the item is visible or not.

Public Methods

Name | Description
Clone | Creates a clone of this item.
GetHashCode | Returns a hash code for this item.
LoadFrom | Overloaded. Loads item data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the item data to a binary stream or an XML document.

Protected Methods

Name | Description
CopyOccurrence | Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item.
OnVisualsChanged | Forces the item to be repainted.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Constructor

Item Constructor

Initializes a new instance of the Item class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected Item ()
Visual Basic

Protected Sub New ()

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Methods

Item Methods

Public Methods

Name | Description
Clone | Creates a clone of this item.
GetHashCode | Returns a hash code for this item.
LoadFrom | Overloaded. Loads item data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the item data to a binary stream or an XML document.

Protected Methods

Name | Description
CopyOccurrence | Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item.
OnVisualsChanged | Forces the item to be repainted.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Clone Method

Item.Clone Method

Creates a clone of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract Object Clone ()
Visual Basic

Public MustOverride Function Clone () As Object

Return Value

This method is a pure abstract method and does not return a value.

Remarks

The clone of a recurring item is not an occurrence but an ordinary item. Aside from this, the clone is an exact duplicate of the original item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.CopyOccurrence Method

Item.CopyOccurrence Method

Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void CopyOccurrence (
Item master
)
Visual Basic

Protected Overridable Sub CopyOccurrence ( _
master As Item _
)

Parameters

master
A reference to the master to copy from.

Remarks

This method is usually overridden in classes which derive from Item or Appointment in order to copy the custom fields from the master item to a particular occurrence. If the method is not overridden, the custom fields for all occurrences will have their default values and not the value of the master item.

Example

The following example illustrates how to override CopyOccurrence in a class deriving from Appointment and how to copy the custom fields from the master item.

C#

class CustomAppointment : Appointment
{
protected override void CopyOccurrence(Item master)
{
_customField = (master as CustomAppointment)._customField;
base.CopyOccurrence(master);
}

private int _customField;
}
Visual Basic

Class CustomAppointment
Inherits Appointment

Protected Overrides Sub CopyOccurrence(ByVal master As Item)

_customField = CType(master, CustomAppointment)._customField
MyBase.CopyOccurrence(master)

End Sub

Private _customField As Integer

End Class

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.GetHashCode Method

Item.GetHashCode Method

Returns a hash code for this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override int GetHashCode ()
Visual Basic

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the current item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.LoadFrom Method

Item.LoadFrom Method

Loads item data from a binary stream or an XML document.

Overload List

Name | Description
Item.LoadFrom (BinaryReader, BinarySerializationContext) | Loads item data from a binary stream.
Item.LoadFrom (XmlElement, XmlSerializationContext) | Loads item data from an XML document.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.LoadFrom Method (BinaryReader, BinarySerializationContext)

Item.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also

Loads item data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)
Visual Basic

Public Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Allows reading primitive data types from a binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

See Also

LoadFrom Method Overload List
Item Members
Item Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Item.LoadFrom Method (XmlElement, XmlSerializationContext)

Item.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads item data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overridable Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

LoadFrom Method Overload List
Item Members
Item Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Item.OnVisualsChanged Method

Item.OnVisualsChanged Method

Forces the item to be repainted.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected void OnVisualsChanged ()
Visual Basic

Protected Sub OnVisualsChanged ()

Remarks

Call this method from within your derived classes when the appearance of the item has been changed.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.SaveTo Method

Item.SaveTo Method

Saves the item data to a binary stream or an XML document.

Overload List

Name | Description
Item.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the item data to a binary stream.
Item.SaveTo (XmlElement, XmlSerializationContext) | Saves the item data to an XML document.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.SaveTo Method (BinaryWriter, BinarySerializationContext)

Item.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also

Saves the item data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)
Visual Basic

Public Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Allows writing primitive data types to a binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

See Also

SaveTo Method Overload List
Item Members
Item Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Item.SaveTo Method (XmlElement, XmlSerializationContext)

Item.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the item data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overridable Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

SaveTo Method Overload List
Item Members
Item Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Item Properties

Item Properties

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the item represents an all day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the item's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the item's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the item.
Contacts | Gets references to all contacts associated with this item.
DescriptionText | Gets or sets the description displayed for this item by scheduling controls.
EndTime | Gets or sets the item's scheduled end time.
HeaderText | Gets or sets the header text displayed for this item by scheduling controls.
Id | Gets or sets the string identifier of this item.
Location | Gets or sets the location associated with this item.
Locked | Gets or sets a value indicating whether users are forbidden to modify this item.
OccurrenceIndex | Gets the index of a repeating occurrence of a recurring item.
PointedSelectedStyle | Gets or sets the style associated with the item.
PointedStyle | Gets or sets the style associated with the item.
Priority | Gets or sets the priority of this item.
Recurrence | Gets or sets the recurrence pattern of this item.
RecurrenceState | Gets the recurrence state of this item.
Reminder | Gets or sets the reminder for this item.
Resources | Gets references to all resources associated with this item.
SelectedStyle | Gets or sets the selected style associated with the item.
StartTime | Gets or sets the item's scheduled start time.
Style | Gets or sets a style associated with the item.
Tag | Gets or sets custom data associated with the item.
Task | Gets or sets the task associated with this item.
Visible | Gets or sets a flag indicating whether the item is visible or not.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.AllDayEvent Property

Item.AllDayEvent Property

Gets or sets a value indicating whether the item represents an all day event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract bool AllDayEvent { get; set; }
Visual Basic

Public MustOverride Property AllDayEvent As Boolean

Property Value

true if the item is an all day event; otherwise, false.

Remarks

All day event items are displayed in a special header area when the Calendar displays a timetable view.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
StartTime Property
EndTime Property


MindFusion.Scheduling.Item.AllowChangeEnd Property

Item.AllowChangeEnd Property

Gets or sets a value indicating whether users are allowed to change the item's end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract bool AllowChangeEnd { get; set; }
Visual Basic

Public MustOverride Property AllowChangeEnd As Boolean

Property Value

true if the item's end can be modified interactively; otherwise, false. The default is true.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowMove Property


MindFusion.Scheduling.Item.AllowChangeStart Property

Item.AllowChangeStart Property

Gets or sets a value indicating whether users are allowed to change the item's start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract bool AllowChangeStart { get; set; }
Visual Basic

Public MustOverride Property AllowChangeStart As Boolean

Property Value

true if the item's start can be modified interactively; otherwise, false. The default is true.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
AllowChangeEnd Property
AllowMove Property


MindFusion.Scheduling.Item.AllowMove Property

Item.AllowMove Property

Gets or sets a value indicating whether users are allowed to move the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract bool AllowMove { get; set; }
Visual Basic

Public MustOverride Property AllowMove As Boolean

Property Value

true if the item can be moved interactively; otherwise, false. The default is true.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowChangeEnd Property


MindFusion.Scheduling.Item.Contacts Property

Item.Contacts Property

Gets references to all contacts associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract ContactCollection Contacts { get; }
Visual Basic

Public MustOverride ReadOnly Property Contacts As ContactCollection

Property Value

An instance of the ContactCollection class containing the Contact objects associated with the item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.DescriptionText Property

Item.DescriptionText Property

Gets or sets the description displayed for this item by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract string DescriptionText { get; set; }
Visual Basic

Public MustOverride Property DescriptionText As String

Property Value

A string containing the description of this item.

Remarks

All classes that derive from Item must implement this property. Controls such as Calendar display this text in the details area of an item visual representation.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.EndTime Property

Item.EndTime Property

Gets or sets the item's scheduled end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract DateTime EndTime { get; set; }
Visual Basic

Public MustOverride Property EndTime As DateTime

Property Value

A .NET DateTime instance.

Remarks

This property specifies the last time cell occupied by the item in a Calendar view.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
StartTime Property
AllDayEvent Property


MindFusion.Scheduling.Item.HeaderText Property

Item.HeaderText Property

Gets or sets the header text displayed for this item by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract string HeaderText { get; set; }
Visual Basic

Public MustOverride Property HeaderText As String

Property Value

A string specifying the item's header text.

Remarks

Calendar views display this value in the header area of the box that represents an item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Id Property

Item.Id Property

Gets or sets the string identifier of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract string Id { get; set; }
Visual Basic

Public MustOverride Property Id As String

Property Value

A string whose value uniquely identifies the item.

Remarks

If you need to change its value, make sure the identifier is always unique.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Location Property

Item.Location Property

Gets or sets the location associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract Location Location { get; set; }
Visual Basic

Public MustOverride Property Location As Location

Property Value

An instance of the Location class.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Locked Property

Item.Locked Property

Gets or sets a value indicating whether users are forbidden to modify this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract bool Locked { get; set; }
Visual Basic

Public MustOverride Property Locked As Boolean

Property Value

true if users are allowed to move the item thus changing its scheduled time; otherwise, false.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.OccurrenceIndex Property

Item.OccurrenceIndex Property

Gets the index of a repeating occurrence of a recurring item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int OccurrenceIndex { get; set; }
Visual Basic

Public Property OccurrenceIndex As Integer

Property Value

An integer value identifying the index of an occurrence item within the recurrence array. If the item is not recurring, this property returns -1.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
Recurrence Property
RecurrenceState Property


MindFusion.Scheduling.Item.PointedSelectedStyle Property

Item.PointedSelectedStyle Property

Gets or sets the style associated with the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract Style PointedSelectedStyle { get; set; }
Visual Basic

Public MustOverride Property PointedSelectedStyle As Style

Property Value

An instance of the Style class that defines the appearance of the item.

Remarks

This style is applied to the item when it is pointed with the mouse and selected at the same time. This property is ignored and SelectedStyle is used instead of it when UseExtendedStyles is set to Disabled. To read more about how this property affects items appearance, refer to the Customizing the Appearance of Items topic.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
Style Property
SelectedStyle Property
PointedStyle Property


MindFusion.Scheduling.Item.PointedStyle Property

Item.PointedStyle Property

Gets or sets the style associated with the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract Style PointedStyle { get; set; }
Visual Basic

Public MustOverride Property PointedStyle As Style

Property Value

A Style object that defines the appearance of the appointment.

Remarks

This style is applied to the item when it is pointed with the mouse. This property is ignored and Style is used instead of it when UseExtendedStyles is set to Disabled. To read more about how this property affects appearance, refer to the Customizing the Appearance of Items topic.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
Style Property
SelectedStyle Property
PointedSelectedStyle Property


MindFusion.Scheduling.Item.Priority Property

Item.Priority Property

Gets or sets the priority of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int Priority { get; set; }
Visual Basic

Public Property Priority As Integer

Property Value

An integer value, specifying the item's priority.

Remarks

Items with higher priority have a better chance to be displayed prior items with lower priority. If two items start and end at the same time, the item with higher Priority will be displayed before the item with lower Priority. In other words, this property gives you control over the order of the items.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Recurrence Property

Item.Recurrence Property

Gets or sets the recurrence pattern of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Recurrence Recurrence { get; set; }
Visual Basic

Public Property Recurrence As Recurrence

Property Value

An instance of the Recurrence class. The default is null (Nothing in Visual Basic).

Remarks

If this property is set, the item becomes a recurring event and the Calendar control displays multiple occurrences of the item. To detach a previously set recurrence from an item, set this property to null.

Example

The following example demonstrates how to create and attach a recurring pattern to an existing item. The example assumes that item identifies an existing Item object.

C#

// Create the recurrence so that the item occurs once every two days
Recurrence recurrence = new Recurrence();
recurrence.Pattern = RecurrencePattern.Daily;
recurrence.Days = 2;
recurrence.StartDate = item.StartTime;
recurrence.RecurrenceEnd = RecurrenceEnd.Never;

// Associate the recurrence with the item by simply setting the Recurrence property
item.Recurrence = recurrence;
Visual Basic

' Create the recurrence so that the item occurs once every two days
Dim recurrence As New Recurrence()
recurrence.Pattern = RecurrencePattern.Daily
recurrence.Days = 2
recurrence.StartDate = item.StartTime
recurrence.RecurrenceEnd = RecurrenceEnd.Never

' Associate the recurrence with the item by simply setting the Recurrence property
item.Recurrence = recurrence

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
RecurrenceState Property
OccurrenceIndex Property


MindFusion.Scheduling.Item.RecurrenceState Property

Item.RecurrenceState Property

Gets the recurrence state of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public RecurrenceState RecurrenceState { get; set; }
Visual Basic

Public Property RecurrenceState As RecurrenceState

Property Value

A member of the RecurrenceState enumeration.

Remarks

Events raised by the Calendar control could pass as an argument an occurrence or an exception of a recurring item. This property lets you determine the exact state of the item's recurrence state.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
Recurrence Property
OccurrenceIndex Property


MindFusion.Scheduling.Item.Reminder Property

Item.Reminder Property

Gets or sets the reminder for this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract Reminder Reminder { get; set; }
Visual Basic

Public MustOverride Property Reminder As Reminder

Property Value

An instance of the Reminder class.

Remarks

If the reminder type is Exact, the ItemReminderTriggered event is raised at the time set in the reminder's Time property. If the reminder type is Leading, the ItemReminderTriggered event is raised certain amount of time prior to the item's StartTime, as specified in the reminder's TimeInterval property.

Note:

Recurring items cannot have leading reminders.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Resources Property

Item.Resources Property

Gets references to all resources associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract ResourceCollection Resources { get; }
Visual Basic

Public MustOverride ReadOnly Property Resources As ResourceCollection

Property Value

An instance of the ResourceCollection class containing the resources associated with this item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.SelectedStyle Property

Item.SelectedStyle Property

Gets or sets the selected style associated with the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract Style SelectedStyle { get; set; }
Visual Basic

Public MustOverride Property SelectedStyle As Style

Property Value

A Style object that defines the appearance of the item.

Remarks

This style is applied to the item when it is selected.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
Style Property
PointedStyle Property
PointedSelectedStyle Property


MindFusion.Scheduling.Item.StartTime Property

Item.StartTime Property

Gets or sets the item's scheduled start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract DateTime StartTime { get; set; }
Visual Basic

Public MustOverride Property StartTime As DateTime

Property Value

A .NET DateTime instance specifying the scheduled time for the item.

Remarks

This property affects the initial time cell occupied by the item when it is displayed in a Calendar view.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
EndTime Property
AllDayEvent Property


MindFusion.Scheduling.Item.Style Property

Item.Style Property

Gets or sets a style associated with the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract Style Style { get; set; }
Visual Basic

Public MustOverride Property Style As Style

Property Value

A Style object that defines the appearance of the item.

Remarks

This style is applied to the item when it is neither pointed with the mouse nor selected.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
SelectedStyle Property
PointedStyle Property
PointedSelectedStyle Property


MindFusion.Scheduling.Item.Tag Property

Item.Tag Property

Gets or sets custom data associated with the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract Object Tag { get; set; }
Visual Basic

Public MustOverride Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Use this property to store your custom data. The tag can be a value from a primitive data type or a complex object from the .NET class library or a class defined by you. If the tag is an instance of a value type, it will be serialized together with the object containing it when saving / loading the schedule. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Task Property

Item.Task Property

Gets or sets the task associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract Task Task { get; set; }
Visual Basic

Public MustOverride Property Task As Task

Property Value

An instance of the Task class.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Visible Property

Item.Visible Property

Gets or sets a flag indicating whether the item is visible or not.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract bool Visible { get; set; }
Visual Basic

Public MustOverride Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false. The default is true.

Remarks

Invisible items are not drawn at all. You could use this property to hide an item temporarily, or to store additional data in a helper item object that always stays invisible.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Class

ItemCollection Class

Represents a strongly typed collection of Item objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class ItemCollection : CollectionBase
Visual Basic

Public NotInheritable Class ItemCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.ItemCollection

See Also

ItemCollection Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Members

ItemCollection Members
Constructors Properties Methods Events

Represents a strongly typed collection of Item objects.

The following tables list the members exposed by the ItemCollection type.

Public Constructors

Name | Description
ItemCollection | Initializes a new instance of the ItemCollection class.

Public Properties

Name | Description
Item | Gets an Item object from the collection given its zero-based index or identifier.

Public Methods

Name | Description
Add | Adds the specified item to this collection.
AddRange | Adds the specified items to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified item.
IndexOf | Returns the zero-based index of the first occurrence of the specified item within this collection.
Insert | Inserts the specified item at the specified position within the collection.
Remove | Removes the first occurrence of the specified item from this collection.
RemoveAt | Removes the item at the specified index of this collection.

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Constructor

ItemCollection Constructor

Initializes a new instance of the ItemCollection class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemCollection ()
Visual Basic

Public Sub New ()

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Methods

ItemCollection Methods

Public Methods

Name | Description
Add | Adds the specified item to this collection.
AddRange | Adds the specified items to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified item.
IndexOf | Returns the zero-based index of the first occurrence of the specified item within this collection.
Insert | Inserts the specified item at the specified position within the collection.
Remove | Removes the first occurrence of the specified item from this collection.
RemoveAt | Removes the item at the specified index of this collection.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Add Method

ItemCollection.Add Method

Adds the specified item to this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Add (
Item item
)
Visual Basic

Public Sub Add ( _
item As Item _
)

Parameters

item
An Item instance to be added to the collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
AddRange Method
Insert Method


MindFusion.Scheduling.ItemCollection.AddRange Method

ItemCollection.AddRange Method

Adds the specified items to this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void AddRange (
ItemCollection items
)
Visual Basic

Public Sub AddRange ( _
items As ItemCollection _
)

Parameters

items
A collection of items to add to this collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
Add Method
Insert Method


MindFusion.Scheduling.ItemCollection.Clear Method

ItemCollection.Clear Method

Removes all elements from the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Contains Method

ItemCollection.Contains Method

Determines whether this collection contains the specified item.

Overload List

Name | Description
ItemCollection.Contains (Item) | Determines whether this collection contains the specified item.
ItemCollection.Contains (String) | Determines whether this collection contains an item identified by the specified string.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Contains Method (Item)

ItemCollection.Contains Method (Item)
See Also

Determines whether this collection contains the specified item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
Item item
)
Visual Basic

Public Function Contains ( _
item As Item _
) As Boolean

Parameters

item
The item to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
IndexOf Method


MindFusion.Scheduling.ItemCollection.Contains Method (String)

ItemCollection.Contains Method (String)
See Also

Determines whether this collection contains an item identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
string id
)
Visual Basic

Public Function Contains ( _
id As String _
) As Boolean

Parameters

id
The identifier of an item to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
IndexOf Method


MindFusion.Scheduling.ItemCollection.IndexOf Method

ItemCollection.IndexOf Method

Returns the zero-based index of the first occurrence of the specified item within this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int IndexOf (
Item item
)
Visual Basic

Public Function IndexOf ( _
item As Item _
) As Integer

Parameters

item
The item to locate in the collection.

Return Value

The zero-based index of the first occurrence of the item within the collection, if found; otherwise, -1.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Insert Method

ItemCollection.Insert Method

Inserts the specified item at the specified position within the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Insert (
int index,
Item item
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
item As Item _
)

Parameters

index
The zero-based index at which the item must be inserted.
item
An instance of the Item class to be added to the collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
Add Method
AddRange Method


MindFusion.Scheduling.ItemCollection.Remove Method

ItemCollection.Remove Method

Removes the first occurrence of the specified item from this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Remove (
Item item
)
Visual Basic

Public Sub Remove ( _
item As Item _
)

Parameters

item
An instance of the Item class, which must be removed from the collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
RemoveAt Method


MindFusion.Scheduling.ItemCollection.RemoveAt Method

ItemCollection.RemoveAt Method

Removes the item at the specified index of this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public new void RemoveAt (
int index
)
Visual Basic

Public Shadows Sub RemoveAt ( _
index As Integer _
)

Parameters

index
The zero-based index of the item to remove.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
Remove Method


MindFusion.Scheduling.ItemCollection Properties

ItemCollection Properties

Public Properties

Name | Description
Item | Gets an Item object from the collection given its zero-based index or identifier.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Item Property

ItemCollection.Item Property

Gets an Item object from the collection given its zero-based index or identifier.

Overload List

Name | Description
ItemCollection.Item (Int32) | Gets or sets the item located at the specified position within this collection.
ItemCollection.Item (String) | Gets the item identified by the specified string.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Item Property (Int32)

ItemCollection.Item Property (Int32)
See Also

Gets or sets the item located at the specified position within this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Item Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Item

Parameters

index
The zero-based index of the Item to set or retrieve.

Property Value

The Item instance at the specified index.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their integer indices.

See Also

Item Property Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Item Property (String)

ItemCollection.Item Property (String)
See Also

Gets the item identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Item Item [
string id
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
id As String _
) As Item

Parameters

id
The Id of the Item to get.

Property Value

The Item instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

Item Property Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Events

ItemCollection Events

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Changed Event

ItemCollection.Changed Event

Raised when the collection has been changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler Changed
Visual Basic

Public Event Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs Class

ItemEventArgs Class

Contains the arguments passed to handlers of item related events raised by the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class ItemEventArgs : EventArgs
Visual Basic

Public Class ItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.ItemTimeEventArgs
MindFusion.Scheduling.WinForms.ItemConfirmEventArgs
MindFusion.Scheduling.WinForms.ItemModifiedEventArgs
MindFusion.Scheduling.WinForms.ItemMouseEventArgs
MindFusion.Scheduling.WinForms.ItemSelectionEventArgs
MindFusion.Scheduling.WinForms.ItemTooltipEventArgs
MindFusion.Scheduling.WinForms.RecurringItemConfirmEventArgs

See Also

ItemEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs Members

ItemEventArgs Members
Properties

Contains the arguments passed to handlers of item related events raised by the Schedule class.

The following tables list the members exposed by the ItemEventArgs type.

Public Properties

Name | Description
Item | Gets the item related to the event.

See Also

ItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs Properties

ItemEventArgs Properties

Public Properties

Name | Description
Item | Gets the item related to the event.

See Also

ItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs.Item Property

ItemEventArgs.Item Property

Gets the item related to the event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Item Item { get; }
Visual Basic

Public ReadOnly Property Item As Item

Property Value

An instance of the Item class.

See Also

ItemEventArgs Members
ItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs Class

ItemTimeEventArgs Class

Contains the arguments passed to handlers of time related events.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class ItemTimeEventArgs : ItemEventArgs
Visual Basic

Public Class ItemTimeEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.ItemTimeEventArgs

See Also

ItemTimeEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs Members

ItemTimeEventArgs Members
Properties

Contains the arguments passed to handlers of time related events.

The following tables list the members exposed by the ItemTimeEventArgs type.

Public Properties

Name | Description
Time | Gets the old value of the time property whose change caused the event to occur.

See Also

ItemTimeEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs Properties

ItemTimeEventArgs Properties

Public Properties

Name | Description
Time | Gets the old value of the time property whose change caused the event to occur.

See Also

ItemTimeEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs.Time Property

ItemTimeEventArgs.Time Property

Gets the old value of the time property whose change caused the event to occur.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime Time { get; }
Visual Basic

Public ReadOnly Property Time As DateTime

Property Value

An instance of the .NET DateTime class.

See Also

ItemTimeEventArgs Members
ItemTimeEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Class

Location Class

Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class Location : Resource
Visual Basic

Public Class Location
Inherits Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Location

See Also

Location Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Members

Location Members
Constructors Properties Methods

Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.

The following tables list the members exposed by the Location type.

Public Constructors

Name | Description
Location | Initializes a new instance of the Location class.

Public Properties

Name | Description
Address | Gets or sets the address of the location.
City | Gets or sets the city of this location.
Country | Gets or sets the country of this location.
State | Gets or sets the state of this location.
ZipCode | Gets or sets the zip-code of this location.

Public Methods

Name | Description
LoadFrom | Overloaded. Loads location data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the location data to a binary stream or an XML document.

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Constructor

Location Constructor

Initializes a new instance of the Location class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Location ()
Visual Basic

Public Sub New ()

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Methods

Location Methods

Public Methods

Name | Description
LoadFrom | Overloaded. Loads location data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the location data to a binary stream or an XML document.

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.LoadFrom Method

Location.LoadFrom Method

Loads location data from a binary stream or an XML document.

Overload List

Name | Description
Location.LoadFrom (BinaryReader, BinarySerializationContext) | Loads location data from a binary stream.
Location.LoadFrom (XmlElement, XmlSerializationContext) | Loads location data from an XML document.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.LoadFrom Method (BinaryReader, BinarySerializationContext)

Location.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also

Loads location data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Allows reading primitive data types from the binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

See Also

LoadFrom Method Overload List
Location Members
Location Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Location.LoadFrom Method (XmlElement, XmlSerializationContext)

Location.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads location data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

LoadFrom Method Overload List
Location Members
Location Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Location.SaveTo Method

Location.SaveTo Method

Saves the location data to a binary stream or an XML document.

Overload List

Name | Description
Location.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the location data to a binary stream.
Location.SaveTo (XmlElement, XmlSerializationContext) | Saves the location data to an XML document.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.SaveTo Method (BinaryWriter, BinarySerializationContext)

Location.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also

Saves the location data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Allows writing primitive data types to the binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

See Also

SaveTo Method Overload List
Location Members
Location Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Location.SaveTo Method (XmlElement, XmlSerializationContext)

Location.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the location data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

SaveTo Method Overload List
Location Members
Location Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Location Properties

Location Properties

Public Properties

Name | Description
Address | Gets or sets the address of the location.
City | Gets or sets the city of this location.
Country | Gets or sets the country of this location.
State | Gets or sets the state of this location.
ZipCode | Gets or sets the zip-code of this location.

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.Address Property

Location.Address Property

Gets or sets the address of the location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string Address { get; set; }
Visual Basic

Public Property Address As String

Property Value

A string specifying the address of this location. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
City Property
State Property
Country Property


MindFusion.Scheduling.Location.City Property

Location.City Property

Gets or sets the city of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string City { get; set; }
Visual Basic

Public Property City As String

Property Value

A string specifying the city where this location is located. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
Address Property
State Property
Country Property


MindFusion.Scheduling.Location.Country Property

Location.Country Property

Gets or sets the country of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string Country { get; set; }
Visual Basic

Public Property Country As String

Property Value

A string specifying the country where this location is located. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.State Property

Location.State Property

Gets or sets the state of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string State { get; set; }
Visual Basic

Public Property State As String

Property Value

A string identifying the state where this location is. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
Address Property
City Property
Country Property


MindFusion.Scheduling.Location.ZipCode Property

Location.ZipCode Property

Gets or sets the zip-code of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string ZipCode { get; set; }
Visual Basic

Public Property ZipCode As String

Property Value

A string containing the location's Zip code. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection Class

LocationCollection Class

Represents a strongly typed collection of Location objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class LocationCollection : CollectionBase
Visual Basic

Public NotInheritable Class LocationCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.LocationCollection

See Also

LocationCollection Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection Members

LocationCollection Members
Constructors Properties Methods Events

Represents a strongly typed collection of Location objects.

The following tables list the members exposed by the LocationCollection type.

Public Constructors

Name | Description
LocationCollection | Initializes a new instance of the LocationCollection class.

Public Properties

Name | Description
Item | Gets a Location object from the collection given its zero-based index or identifier.

Public Methods

Name | Description
Add | Adds the specified location to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified location.
Insert | Inserts the specified location object at the specified position within the collection.
Remove | Removes the first occurrence of the specified location object from this collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection Constructor

LocationCollection Constructor

Initializes a new instance of the LocationCollection class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public LocationCollection ()
Visual Basic

Public Sub New ()

See Also

LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection Methods

LocationCollection Methods

Public Methods

Name | Description
Add | Adds the specified location to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified location.
Insert | Inserts the specified location object at the specified position within the collection.
Remove | Removes the first occurrence of the specified location object from this collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.

See Also

LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Add Method

LocationCollection.Add Method

Adds the specified location to this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Add (
Location location
)
Visual Basic

Public Sub Add ( _
location As Location _
)

Parameters

location
An instance of the Location class to be added to the collection.

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace
Insert Method


MindFusion.Scheduling.LocationCollection.Clear Method

LocationCollection.Clear Method

Removes all elements from the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Contains Method

LocationCollection.Contains Method

Determines whether this collection contains the specified location.

Overload List

Name | Description
LocationCollection.Contains (Location) | Determines whether this collection contains the specified location.
LocationCollection.Contains (String) | Determines whether this collection contains a location identified by the specified string.

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Contains Method (Location)

LocationCollection.Contains Method (Location)
See Also

Determines whether this collection contains the specified location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
Location location
)
Visual Basic

Public Function Contains ( _
location As Location _
) As Boolean

Parameters

location
The Location object to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Contains Method (String)

LocationCollection.Contains Method (String)
See Also

Determines whether this collection contains a location identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
string locationId
)
Visual Basic

Public Function Contains ( _
locationId As String _
) As Boolean

Parameters

locationId
The identifier of a location to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Insert Method

LocationCollection.Insert Method

Inserts the specified location object at the specified position within the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Insert (
int index,
Location location
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
location As Location _
)

Parameters

index
The zero-based index at which the location must be inserted.
location
An instance of the Location class to be added to the collection.

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace
Add Method


MindFusion.Scheduling.LocationCollection.OnClearComplete Method

LocationCollection.OnClearComplete Method

CollectionBase.OnClearComplete override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnClearComplete ()
Visual Basic

Protected Overridable Sub OnClearComplete ()

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.OnInsertComplete Method

LocationCollection.OnInsertComplete Method

CollectionBase.OnInsertComplete override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnInsertComplete (
int index,
Object value
)
Visual Basic

Protected Overridable Sub OnInsertComplete ( _
index As Integer, _
value As Object _
)

Parameters

index
value

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.OnRemoveComplete Method

LocationCollection.OnRemoveComplete Method

CollectionBase.OnRemoveComplete override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnRemoveComplete (
int index,
Object value
)
Visual Basic

Protected Overridable Sub OnRemoveComplete ( _
index As Integer, _
value As Object _
)

Parameters

index
value

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Remove Method

LocationCollection.Remove Method

Removes the first occurrence of the specified location object from this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Remove (
Location location
)
Visual Basic

Public Sub Remove ( _
location As Location _
)

Parameters

location
A Location instance which must be removed from the collection.

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection Properties

LocationCollection Properties

Public Properties

Name | Description
Item | Gets a Location object from the collection given its zero-based index or identifier.

See Also

LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Item Property

LocationCollection.Item Property

Gets a Location object from the collection given its zero-based index or identifier.

Overload List

Name | Description
LocationCollection.Item (Int32) | Gets or sets the location object located at the specified position within this collection.
LocationCollection.Item (String) | Gets the location object identified by the specified string.

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Item Property (Int32)

LocationCollection.Item Property (Int32)
See Also

Gets or sets the location object located at the specified position within this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Location Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Location

Parameters

index
The zero-based index of the Location to set or retrieve.

Property Value

The Location object at the specified index.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their integer indices.

See Also

Item Property Overload List
LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Item Property (String)

LocationCollection.Item Property (String)
See Also

Gets the location object identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Location Item [
string id
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
id As String _
) As Location

Parameters

id
The Id of the Location to get.

Property Value

The Location instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

Item Property Overload List
LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection Events

LocationCollection Events

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Changed Event

LocationCollection.Changed Event

Raised when the collection has been changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler Changed
Visual Basic

Public Event Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.MonthlyRecurrence Enumeration

MonthlyRecurrence Enumeration

Specifies the types of monthly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum MonthlyRecurrence
Visual Basic

Public Enumeration MonthlyRecurrence

Members

Member name | Description
ByDayNumber | The event occurs on a specific day of the month.
ByDayType | The event occurs on a specific type of day of the specified week of the month.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Occurrence Enumeration

Occurrence Enumeration

Specifies the occurrence number of a day or a week within a month.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum Occurrence
Visual Basic

Public Enumeration Occurrence

Members

Member name | Description
First | Indicates the first occurrence.
Fourth | Indicates the fourth occurrence.
Last | Indicates the last occurrence.
Second | Indicates the second occurrence.
Third | Indicates the third occurrence.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Class

Recurrence Class

Defines recurrence patterns for items scheduled to repeat over and over again.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class Recurrence : ICloneable
Visual Basic

Public Class Recurrence
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Recurrence

See Also

Recurrence Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Members

Recurrence Members
Constructors Properties Methods

Defines recurrence patterns for items scheduled to repeat over and over again.

The following tables list the members exposed by the Recurrence type.

Public Constructors

Name | Description
Recurrence | Initializes a new instance of the Recurrence class.

Public Properties

Name | Description
DailyRecurrence | Gets or sets the type of daily recurrence.
Day | Gets or sets a value indicating on which day of a week the event occurs.
DayOfMonth | Gets or sets on which day of a month the event occurs.
Days | Gets or sets how many days should pass before the event occurs again.
DaysOfWeek | Gets or sets on which days of a week the event occurs.
EndDate | Gets or sets the end date of the recurrence.
Exceptions | Gets the list of all recurrence exceptions.
Interval | Gets or sets the recurrence interval.
Master | Gets the master item of this recurrence. The property returns null if the recurrence is not associated with an item.
MonthlyRecurrence | Gets or sets the type of monthly recurrence.
MonthOfYear | Gets or sets in which month of the year the event occurs.
Months | Gets or sets how many months should pass before the event occurs again.
NumOccurrences | Gets or sets how many times the recurring event should occur.
Occurrence | Gets or sets on which occurrence of the day type specified in Day the event occurs.
Pattern | Gets or sets the recurrence pattern.
RecurrenceEnd | Gets or sets when the event should stop recurring.
StartDate | Gets or sets when the recurring event should occur for the first time.
Weeks | Gets or sets how many weeks should pass before the event occurs again.
YearlyRecurrence | Gets or sets the type of yearly recurrence.

Public Methods

Name | Description
ApplyPattern | Copies the fields of the specified Recurrence object to this recurrence.
ClearExceptions | Removes all exceptions of this recurrence.
Clone | Creates an exact copy of this Recurrence object.
GenerateItems | Creates occurrence items for this recurrence in the specified date range.
GetEndDate | Returns the end date for this recurrence.
GetOccurrence | Overloaded. Returns the occurrence having the specified index.
LoadFrom | Overloaded. Loads recurrence data from a binary stream or an XML document.
MarkException | Marks the specified item as an exception of a recurrence pattern.
SamePatternAs | Determines whether two Recurrence objects define the same recurrence pattern.
SaveTo | Overloaded. Saves the recurrence data to a binary stream or an XML document.
ToString | Overloaded. Creates a string from this recurrence.

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Constructor

Recurrence Constructor

Initializes a new instance of the Recurrence class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Recurrence ()
Visual Basic

Public Sub New ()

Example

The following example creates a new recurrence object and associates it with an existing appointment. The example assumes that the appointment referenced by app already exists.

C#

// Create a recurrence that happens at the third weekend
// every three months, effective July 14th, 2005.
// The recurrence is infinite
Recurrence recurrence = new Recurrence();
recurrence.Pattern = RecurrencePattern.Monthly;
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType;
recurrence.Occurrence = Occurrence.Third;
recurrence.Day = DayOfWeekType.Weekend;
recurrence.Months = 3;
recurrence.StartDate = new DateTime(2005, 7, 14);
recurrence.RecurrenceEnd = RecurrenceEnd.Never;

// Associate the recurrence with the appointment
app.Recurrence = recurrence;
Visual Basic

' Create a recurrence that happens at the third weekend
' every three months, effective July 14th, 2005.
' The recurrence is infinite
Dim recurrence As New Recurrence()
recurrence.Pattern = RecurrencePattern.Monthly
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType
recurrence.Occurrence = Occurrence.Third
recurrence.Day = DayOfWeekType.Weekend
recurrence.Months = 3
recurrence.StartDate = New DateTime(2005, 7, 14)
recurrence.RecurrenceEnd = RecurrenceEnd.Never

' Associate the recurrence with the appointment
app.Recurrence = recurrence

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Methods

Recurrence Methods

Public Methods

Name | Description
ApplyPattern | Copies the fields of the specified Recurrence object to this recurrence.
ClearExceptions | Removes all exceptions of this recurrence.
Clone | Creates an exact copy of this Recurrence object.
GenerateItems | Creates occurrence items for this recurrence in the specified date range.
GetEndDate | Returns the end date for this recurrence.
GetOccurrence | Overloaded. Returns the occurrence having the specified index.
LoadFrom | Overloaded. Loads recurrence data from a binary stream or an XML document.
MarkException | Marks the specified item as an exception of a recurrence pattern.
SamePatternAs | Determines whether two Recurrence objects define the same recurrence pattern.
SaveTo | Overloaded. Saves the recurrence data to a binary stream or an XML document.
ToString | Overloaded. Creates a string from this recurrence.

Protected Methods

Name Description

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ApplyPattern Method

Recurrence.ApplyPattern Method

Copies the fields of the specified Recurrence object to this recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void ApplyPattern (
Recurrence recurrence
)
Visual Basic

Public Sub ApplyPattern ( _
recurrence As Recurrence _
)

Parameters

recurrence
The Recurrence object whose fields to copy.

Remarks

This method behaves similarly to the Clone method except that it does not create a new object.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ClearExceptions Method

Recurrence.ClearExceptions Method

Removes all exceptions of this recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void ClearExceptions ()
Visual Basic

Public Sub ClearExceptions ()

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Clone Method

Recurrence.Clone Method

Creates an exact copy of this Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

A new Recurrence object, cloned from this one.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
ApplyPattern Method


MindFusion.Scheduling.Recurrence.GenerateItems Method

Recurrence.GenerateItems Method

Creates occurrence items for this recurrence in the specified date range.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemCollection GenerateItems (
DateTime startDate,
DateTime endDate
)
Visual Basic

Public Function GenerateItems ( _
startDate As DateTime, _
endDate As DateTime _
) As ItemCollection

Parameters

startDate
The range start date.
endDate
The range end date.

Return Value

A collection of Item instances representing each occurrence of the recurrent event in the specified date range.

Remarks

The Calendar control uses this method to generate item occurrences when a recurrent item must be displayed in the current view.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetEndDate Method

Recurrence.GetEndDate Method

Returns the end date for this recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetEndDate ()
Visual Basic

Public Function GetEndDate () As DateTime

Return Value

The end date of the recurrence if the recurrence is set to expire or DateTime.MaxValue otherwise.

Remarks

The end date is calculated from the specified repeat number if RecurrenceEnd is set to NumOccurrences.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method

Recurrence.GetOccurrence Method

Returns the occurrence having the specified index.

Overload List

Name | Description
Recurrence.GetOccurrence (Int32, Boolean@) | Returns the occurrence having the specified index.
Recurrence.GetOccurrence (Int32, Boolean@, Boolean) | Returns the occurrence having the specified index.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32, Boolean@)

Recurrence.GetOccurrence Method (Int32, Boolean@)
See Also

Returns the occurrence having the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Item GetOccurrence (
int index,
ref bool isDeleted
)
Visual Basic

Public Function GetOccurrence ( _
index As Integer, _
ByRef isDeleted As Boolean _
) As Item

Parameters

index

The index of the occurrence to retrieve.

isDeleted
If the specified occurrence is an exception, this parameter contains upon function completion whether the exception is deleted or not.

Return Value

A reference to the occurrence with the specified index or null (Nothing in Visual Basic), if there is no such occurrence.

Remarks

This function might take considerable amount of time if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32, Boolean@, Boolean)

Recurrence.GetOccurrence Method (Int32, Boolean@, Boolean)
See Also

Returns the occurrence having the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Item GetOccurrence (
int index,
ref bool isDeleted,
bool noException
)
Visual Basic

Public Function GetOccurrence ( _
index As Integer, _
ByRef isDeleted As Boolean, _
noException As Boolean _
) As Item

Parameters

index
The index of the occurrence to retrieve.
isDeleted
If the specified occurrence is an exception, this parameter contains upon function completion whether the exception is deleted or not.
noException
Specifies whether to return the original item, in case this occurrence is an exception.

Return Value

A reference to the occurrence with the specified index or null (Nothing in Visual Basic), if there is no such occurrence.

Remarks

This function might take considerable amount of time if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.LoadFrom Method

Recurrence.LoadFrom Method

Loads recurrence data from a binary stream or an XML document.

Overload List

Name | Description
Recurrence.LoadFrom (BinaryReader, BinarySerializationContext) | Loads the recurrence data from a binary stream.
Recurrence.LoadFrom (XmlElement, XmlSerializationContext) | Loads the recurrence data from an XML document.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.LoadFrom Method (BinaryReader, BinarySerializationContext)

Recurrence.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also

Loads the recurrence data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)
Visual Basic

Public Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Allows reading primitive data types from the binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

Loads the state of a recurrence from a binary stream where it was previously saved via SaveTo.

See Also

LoadFrom Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Recurrence.LoadFrom Method (XmlElement, XmlSerializationContext)

Recurrence.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads the recurrence data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

Loads the state of a recurrence from an XML document, where it was previously saved via SaveTo.

See Also

LoadFrom Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Recurrence.MarkException Method

Recurrence.MarkException Method

Marks the specified item as an exception of a recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void MarkException (
Item item,
bool deleted
)
Visual Basic

Public Sub MarkException ( _
item As Item, _
deleted As Boolean _
)

Parameters

item
The Item instance to be marked as an exception.
deleted
Specifies whether the exception is created by deleting one occurrence from the recurrent pattern or by changing the occurrence time properties.

Remarks

The Calendar control calls this method when a user drags an occurrence item or edits its text, thus creating an exception of the recurrence.

Example

The following example deletes the occurrences of an existing recurrence that are located in the specified date interval. The example assumes that recurrence identifies an existing Recurrence object.

C#

ItemCollection items =
recurrence.GenerateItems(new DateTime(2005, 1, 1), new DateTime(2005, 12, 31));

foreach (Item item in items)
recurrence.MarkException(item, true);
Visual Basic

Dim items As ItemCollection = _
recurrence.GenerateItems(New DateTime(2005, 1, 1), New DateTime(2005, 12, 31))

Dim item as Item
For Each item in items
recurrence.MarkException(item, True)
Next item

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
Exceptions Property


MindFusion.Scheduling.Recurrence.SamePatternAs Method

Recurrence.SamePatternAs Method

Determines whether two Recurrence objects define the same recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool SamePatternAs (
Recurrence recurrence
)
Visual Basic

Public Function SamePatternAs ( _
recurrence As Recurrence _
) As Boolean

Parameters

recurrence
A Recurrence object to compare with this recurrence.

Return Value

true if the Recurrence instances represent the same recurrence patterns; otherwise, false.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.SaveTo Method

Recurrence.SaveTo Method

Saves the recurrence data to a binary stream or an XML document.

Overload List

Name | Description
Recurrence.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the recurrence data to a binary stream.
Recurrence.SaveTo (XmlElement, XmlSerializationContext) | Saves the recurrence data to an XML document.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.SaveTo Method (BinaryWriter, BinarySerializationContext)

Recurrence.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also

Saves the recurrence data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)
Visual Basic

Public Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Allows writing primitive data types to the binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

This method saves the recurrence properties as bytes in a binary stream. Use LoadFrom to restore the property later.

See Also

SaveTo Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Recurrence.SaveTo Method (XmlElement, XmlSerializationContext)

Recurrence.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the recurrence data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

The recurrence properties are saved as elements of an XML document, and can be later restored using the LoadFrom method.

See Also

SaveTo Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Recurrence.ToString Method

Recurrence.ToString Method

Creates a string from this recurrence.

Overload List

Name | Description
Recurrence.ToString () | Creates a string from this recurrence using the date and time formatting information defined in the current culture.
Recurrence.ToString (DateTimeFormatInfo) | Creates a string from this recurrence using the specified date and time formatting.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ToString Method ()

Recurrence.ToString Method ()
See Also

Creates a string from this recurrence using the date and time formatting information defined in the current culture.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string representation of the recurrence object.

See Also

ToString Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ToString Method (DateTimeFormatInfo)

Recurrence.ToString Method (DateTimeFormatInfo)
See Also

Creates a string from this recurrence using the specified date and time formatting.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string ToString (
DateTimeFormatInfo info
)
Visual Basic

Public Function ToString ( _
info As DateTimeFormatInfo _
) As String

Parameters

info
Defines how date and time values are formatted and displayed.

Return Value

A string representation of the recurrence object.

See Also

ToString Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Properties

Recurrence Properties

Public Properties

Name | Description
DailyRecurrence | Gets or sets the type of daily recurrence.
Day | Gets or sets a value indicating on which day of a week the event occurs.
DayOfMonth | Gets or sets on which day of a month the event occurs.
Days | Gets or sets how many days should pass before the event occurs again.
DaysOfWeek | Gets or sets on which days of a week the event occurs.
EndDate | Gets or sets the end date of the recurrence.
Exceptions | Gets the list of all recurrence exceptions.
Interval | Gets or sets the recurrence interval.
Master | Gets the master item of this recurrence. The property returns null if the recurrence is not associated with an item.
MonthlyRecurrence | Gets or sets the type of monthly recurrence.
MonthOfYear | Gets or sets in which month of the year the event occurs.
Months | Gets or sets how many months should pass before the event occurs again.
NumOccurrences | Gets or sets how many times the recurring event should occur.
Occurrence | Gets or sets on which occurrence of the day type specified in Day the event occurs.
Pattern | Gets or sets the recurrence pattern.
RecurrenceEnd | Gets or sets when the event should stop recurring.
StartDate | Gets or sets when the recurring event should occur for the first time.
Weeks | Gets or sets how many weeks should pass before the event occurs again.
YearlyRecurrence | Gets or sets the type of yearly recurrence.

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.DailyRecurrence Property

Recurrence.DailyRecurrence Property

Gets or sets the type of daily recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DailyRecurrence DailyRecurrence { get; set; }
Visual Basic

Public Property DailyRecurrence As DailyRecurrence

Property Value

A member of the DailyRecurrence enumeration.

Remarks

This value is used when the recurrence Pattern is set to Daily.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Day Property

Recurrence.Day Property

Gets or sets a value indicating on which day of a week the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DayOfWeekType Day { get; set; }
Visual Basic

Public Property Day As DayOfWeekType

Property Value

A member of the DayOfWeekType enumeration.

Remarks

This value is used when the recurrence Pattern is set to Monthly or Yearly and MonthlyRecurrence or YearlyRecurrence are set to ByDayType.

Example

Check the Recurrence constructor for an example on how to use this property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.DayOfMonth Property

Recurrence.DayOfMonth Property

Gets or sets on which day of a month the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int DayOfMonth { get; set; }
Visual Basic

Public Property DayOfMonth As Integer

Property Value

An integer vale specifying at which month the recurring event occurs. The allowed values range from 1 to 31.

Remarks

This value is used when the recurrence Pattern is set to Monthly or Yearly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Days Property

Recurrence.Days Property

Gets or sets how many days should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int Days { get; set; }
Visual Basic

Public Property Days As Integer

Property Value

An integer value specifying the number of days between event occurrences. The minimal allowed value is 1.

Remarks

This value is used when the recurrence Pattern is set to Daily.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.DaysOfWeek Property

Recurrence.DaysOfWeek Property

Gets or sets on which days of a week the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DaysOfWeek DaysOfWeek { get; set; }
Visual Basic

Public Property DaysOfWeek As DaysOfWeek

Property Value

A member of the DaysOfWeek enumeration.

Remarks

This value is used when the recurrence Pattern is set to Weekly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.EndDate Property

Recurrence.EndDate Property

Gets or sets the end date of the recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime EndDate { get; set; }
Visual Basic

Public Property EndDate As DateTime

Property Value

A DateTime object specifying the end date of the recurring event.

Remarks

This property is considered by the recurrence only if the RecurrenceEnd is set to EndDate.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Exceptions Property

Recurrence.Exceptions Property

Gets the list of all recurrence exceptions.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ICollection Exceptions { get; }
Visual Basic

Public ReadOnly Property Exceptions As ICollection

Property Value

A collection containing all exceptions defined for this recurrence.

Example

The following example traverses all deleted occurrences of a recurrence. The example assumes that recurrence references an existing Recurrence object.

C#

foreach (RecurrenceException exception in recurrence.Exceptions)
{
if (exception.IsDeleted)
{
// Do something here
}
}
Visual Basic

For Each exception As RecurrenceException in recurrence.Exceptions

If exception.IsDeleted Then

' Do something here

End If

Next

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Interval Property

Recurrence.Interval Property

Gets or sets the recurrence interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public TimeSpan Interval { get; set; }
Visual Basic

Public Property Interval As TimeSpan

Property Value

A TimeSpan value indicating the time interval between recurring items.

Remarks

This value is used when the recurrence Pattern is set to ByTimeInterval.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Master Property

Recurrence.Master Property

Gets the master item of this recurrence. The property returns null if the recurrence is not associated with an item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Item Master { get; }
Visual Basic

Public ReadOnly Property Master As Item

Property Value

A reference to the schedule item whose recurrence is defined by this object.

Remarks

To associate a recurrence with an item, set a reference to a Recurrence object to the item's Recurrence property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.MonthlyRecurrence Property

Recurrence.MonthlyRecurrence Property

Gets or sets the type of monthly recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public MonthlyRecurrence MonthlyRecurrence { get; set; }
Visual Basic

Public Property MonthlyRecurrence As MonthlyRecurrence

Property Value

A member of the MonthlyRecurrence enumeration.

Remarks

This value is used when the recurrence Pattern is set to Monthly.

Example

Check the Recurrence constructor for an example on how to use this property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.MonthOfYear Property

Recurrence.MonthOfYear Property

Gets or sets in which month of the year the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int MonthOfYear { get; set; }
Visual Basic

Public Property MonthOfYear As Integer

Property Value

An integer value specifying at which month the event occurs. The allowed values range from 1 to 12.

Remarks

The value of this property is used when the recurrence Pattern is set to Yearly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Months Property

Recurrence.Months Property

Gets or sets how many months should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int Months { get; set; }
Visual Basic

Public Property Months As Integer

Property Value

An integer value specifying the number of days between event occurrences. The minimal allowed value is 1.

Remarks

The value of this property is used when the recurrence Pattern is set to Monthly.

Example

Check the Recurrence constructor for an example on how to use this property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.NumOccurrences Property

Recurrence.NumOccurrences Property

Gets or sets how many times the recurring event should occur.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int NumOccurrences { get; set; }
Visual Basic

Public Property NumOccurrences As Integer

Property Value

An integer value specifying the number of occurrences. The allowed values range from 1 to 999.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Occurrence Property

Recurrence.Occurrence Property

Gets or sets on which occurrence of the day type specified in Day the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Occurrence Occurrence { get; set; }
Visual Basic

Public Property Occurrence As Occurrence

Property Value

A member of the Occurrence enumeration.

Remarks

The value of this property is used when the recurrence Pattern is set to Monthly or Yearly and MonthlyRecurrence or YearlyRecurrence are set to ByDayType.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Pattern Property

Recurrence.Pattern Property

Gets or sets the recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public RecurrencePattern Pattern { get; set; }
Visual Basic

Public Property Pattern As RecurrencePattern

Property Value

A member of the RecurrencePattern enumeration.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.RecurrenceEnd Property

Recurrence.RecurrenceEnd Property

Gets or sets when the event should stop recurring.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public RecurrenceEnd RecurrenceEnd { get; set; }
Visual Basic

Public Property RecurrenceEnd As RecurrenceEnd

Property Value

A member of the RecurrenceEnd enumeration.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
NumOccurrences
EndDate


MindFusion.Scheduling.Recurrence.StartDate Property

Recurrence.StartDate Property

Gets or sets when the recurring event should occur for the first time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime StartDate { get; set; }
Visual Basic

Public Property StartDate As DateTime

Property Value

A DateTime object specifying the recurrence start date.

Remarks

The time properties set in a recurrence object override the time properties of a schedule item to which the recurrence is assigned. The Calendar control displays "occurrence" items corresponding to the recurring master item. The first occurrence is displayed in the date cell specified in this property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
EndDate


MindFusion.Scheduling.Recurrence.Weeks Property

Recurrence.Weeks Property

Gets or sets how many weeks should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int Weeks { get; set; }
Visual Basic

Public Property Weeks As Integer

Property Value

An integer value specifying the number of weeks between event occurrences. The minimal allowed value is 1.

Remarks

This value is used when the recurrence Pattern is set to Weekly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.YearlyRecurrence Property

Recurrence.YearlyRecurrence Property

Gets or sets the type of yearly recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public YearlyRecurrence YearlyRecurrence { get; set; }
Visual Basic

Public Property YearlyRecurrence As YearlyRecurrence

Property Value

A member of the YearlyRecurrence enumeration.

Remarks

The value of this property is used when the recurrence Pattern is set to Yearly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceEnd Enumeration

RecurrenceEnd Enumeration

Specifies when to stop repeating recurring events.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum RecurrenceEnd
Visual Basic

Public Enumeration RecurrenceEnd

Members

Member name | Description
EndDate | The recurrence ends at a specified date.
Never | Never stop repeating events.
NumOccurrences | Stop repeating events after a specified number of occurrences.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException Class

RecurrenceException Class

This class represents exceptions of a recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class RecurrenceException
Visual Basic

Public Class RecurrenceException

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.RecurrenceException

See Also

RecurrenceException Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException Members

RecurrenceException Members
Properties

This class represents exceptions of a recurrence patterns.

The following tables list the members exposed by the RecurrenceException type.

Public Properties

Name | Description
IsDeleted | Gets or sets a value indicating whether this particular occurrence has been deleted.
Item | Gets the item representing the recurrence exception.

See Also

RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException Properties

RecurrenceException Properties

Public Properties

Name | Description
IsDeleted | Gets or sets a value indicating whether this particular occurrence has been deleted.
Item | Gets the item representing the recurrence exception.

See Also

RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException.IsDeleted Property

RecurrenceException.IsDeleted Property

Gets or sets a value indicating whether this particular occurrence has been deleted.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool IsDeleted { get; set; }
Visual Basic

Public Property IsDeleted As Boolean

Property Value

true if this exception identifies a deleted occurrence; otherwise, false.

See Also

RecurrenceException Members
RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException.Item Property

RecurrenceException.Item Property

Gets the item representing the recurrence exception.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Item Item { get; set; }
Visual Basic

Public Property Item As Item

Property Value

An instance of the item class representing the schedule item for which this exception is defined.

See Also

RecurrenceException Members
RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrencePattern Enumeration

RecurrencePattern Enumeration

Specifies the interval at which recurring items occur.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum RecurrencePattern
Visual Basic

Public Enumeration RecurrencePattern

Members

Member name | Description
ByTimeInterval | Repeats an item over a specified time interval.
Daily | Repeats an item every day.
Monthly | Repeats an item every month.
Weekly | Repeats an item every week.
Yearly | Repeats an item every year.

Remarks

These values can be assigned to the Pattern property of the Recurrence class.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceState Enumeration

RecurrenceState Enumeration

Specifies the recurrence state of items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum RecurrenceState
Visual Basic

Public Enumeration RecurrenceState

Members

Member name | Description
Exception | Specifies an exception of a recurring event.
Master | Specifies a recurring event.
None | Specifies an one-time non-recurring event.
Occurrence | Specifies a single occurrence of a recurring event.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Class

Reminder Class

Represents reminders associated with schedule items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class Reminder : ICloneable
Visual Basic

Public NotInheritable Class Reminder
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Reminder

See Also

Reminder Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Members

Reminder Members
Constructors Fields Properties Methods

Represents reminders associated with schedule items.

The following tables list the members exposed by the Reminder type.

Public Constructors

Name | Description
Reminder | Initializes a new instance of the Reminder class.

Public Fields

Name | Description
MaxInterval | The maximum time interval that can be set as value of TimeInterval for a Reminder object.

Public Properties

Name | Description
Message | Gets or sets the message to display as a reminder.
PlaySound | Gets or sets a value indicating whether to play a sound when the reminder is triggered.
SoundFileName | Gets or sets the name of a sound file to play with this reminder.
Time | Gets or sets the exact time when to trigger the reminder.
TimeInterval | Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.
Type | Gets or sets the type of this reminder.

Public Methods

Name | Description
Clone | Clones this Reminder object.
LoadFrom | Overloaded. Loads reminder data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the reminder data to a binary stream or an XML document.

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Fields

Reminder Fields

Public Fields

Name | Description
MaxInterval | The maximum time interval that can be set as value of TimeInterval for a Reminder object.

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.MaxInterval Field

Reminder.MaxInterval Field

The maximum time interval that can be set as value of TimeInterval for a Reminder object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public static readonly TimeSpan MaxInterval
Visual Basic

Public Shared ReadOnly MaxInterval As TimeSpan

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Constructor

Reminder Constructor

Initializes a new instance of the Reminder class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Reminder ()
Visual Basic

Public Sub New ()

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Methods

Reminder Methods

Public Methods

Name | Description
Clone | Clones this Reminder object.
LoadFrom | Overloaded. Loads reminder data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the reminder data to a binary stream or an XML document.

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Clone Method

Reminder.Clone Method

Clones this Reminder object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

An exact copy of this reminder.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.LoadFrom Method

Reminder.LoadFrom Method

Loads reminder data from a binary stream or an XML document.

Overload List

Name | Description
Reminder.LoadFrom (BinaryReader, BinarySerializationContext) | Loads reminder data from a binary stream.
Reminder.LoadFrom (XmlElement, XmlSerializationContext) | Loads reminder data from an XML document.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.LoadFrom Method (BinaryReader, BinarySerializationContext)

Reminder.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also

Loads reminder data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)
Visual Basic

Public Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Allows reading primitive data types from the binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

This method loads the reminder fields from a binary stream where they were previously saved via SaveTo.

See Also

LoadFrom Method Overload List
Reminder Members
Reminder Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Reminder.LoadFrom Method (XmlElement, XmlSerializationContext)

Reminder.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads reminder data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method loads the reminder fields from an XML document, where they were previously saved via SaveTo.

See Also

LoadFrom Method Overload List
Reminder Members
Reminder Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Reminder.SaveTo Method

Reminder.SaveTo Method

Saves the reminder data to a binary stream or an XML document.

Overload List

Name | Description
Reminder.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the reminder data to a binary stream.
Reminder.SaveTo (XmlElement, XmlSerializationContext) | Saves the reminder data to an XML document.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.SaveTo Method (BinaryWriter, BinarySerializationContext)

Reminder.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also

Saves the reminder data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)
Visual Basic

Public Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Allows writing primitive data types to the binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

This method saves the reminder object fields as bytes in a binary stream. They can be restored later via the LoadFrom method.

See Also

SaveTo Method Overload List
Reminder Members
Reminder Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Reminder.SaveTo Method (XmlElement, XmlSerializationContext)

Reminder.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the reminder data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saved the reminder object fields as elements in a XML document. They can be restored later using the LoadFrom method.

See Also

SaveTo Method Overload List
Reminder Members
Reminder Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Reminder Properties

Reminder Properties

Public Properties

Name | Description
Message | Gets or sets the message to display as a reminder.
PlaySound | Gets or sets a value indicating whether to play a sound when the reminder is triggered.
SoundFileName | Gets or sets the name of a sound file to play with this reminder.
Time | Gets or sets the exact time when to trigger the reminder.
TimeInterval | Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.
Type | Gets or sets the type of this reminder.

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Message Property

Reminder.Message Property

Gets or sets the message to display as a reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string Message { get; set; }
Visual Basic

Public Property Message As String

Property Value

A string containing the message text.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.PlaySound Property

Reminder.PlaySound Property

Gets or sets a value indicating whether to play a sound when the reminder is triggered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool PlaySound { get; set; }
Visual Basic

Public Property PlaySound As Boolean

Property Value

true to play the sound file; otherwise, false.

Remarks

The path to the sound file can be set in the SoundFileName property.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.SoundFileName Property

Reminder.SoundFileName Property

Gets or sets the name of a sound file to play with this reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string SoundFileName { get; set; }
Visual Basic

Public Property SoundFileName As String

Property Value

A string specifying which file to play.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Time Property

Reminder.Time Property

Gets or sets the exact time when to trigger the reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime Time { get; set; }
Visual Basic

Public Property Time As DateTime

Property Value

A .NET DateTime object specifying when the reminder should be triggered.

Remarks

The value of this property is considered only if the Type of the reminder is set to Exact.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.TimeInterval Property

Reminder.TimeInterval Property

Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public TimeSpan TimeInterval { get; set; }
Visual Basic

Public Property TimeInterval As TimeSpan

Property Value

A .NET TimeSpan instance specifying how much time before event's scheduled time to trigger the reminder.

Remarks

The value of this property is considered only if the Type of the reminder is set to Leading.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Type Property

Reminder.Type Property

Gets or sets the type of this reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ReminderType Type { get; set; }
Visual Basic

Public Property Type As ReminderType

Property Value

A member of the ReminderType enumeration specifying the reminder type.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ReminderType Enumeration

ReminderType Enumeration

Specifies the type of a reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum ReminderType
Visual Basic

Public Enumeration ReminderType

Members

Member name | Description
Exact | Trigger the reminder at the exact time specified in its Time property. Note: Recurring items cannot have exact reminders.
Leading | Trigger the reminder at the specified TimeInterval before the item's scheduled start time. Note: Tasks cannot have leading reminders.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Class

Resource Class

Instances of the Resource class contain information about arbitrary resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class Resource
Visual Basic

Public Class Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Contact
MindFusion.Scheduling.Location
MindFusion.Scheduling.Task

See Also

Resource Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Members

Resource Members
Constructors Properties Methods

Instances of the Resource class contain information about arbitrary resources.

The following tables list the members exposed by the Resource type.

Public Constructors

Name | Description
Resource | Initializes a new instance of the Resource class.

Public Properties

Name | Description
CustomBrushes | Gets a CustomBrushes object associated with the resource.
Id | Gets or sets the string identifier of this resource.
Name | Gets or sets the name of the resource.
Tag | Gets or sets custom data associated with the resource.

Public Methods

Name | Description
LoadFrom | Overloaded. Loads resource data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the resource data to a binary stream or an XML document.

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Constructor

Resource Constructor

Initializes a new instance of the Resource class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Resource ()
Visual Basic

Public Sub New ()

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Methods

Resource Methods

Public Methods

Name | Description
LoadFrom | Overloaded. Loads resource data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the resource data to a binary stream or an XML document.

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.LoadFrom Method

Resource.LoadFrom Method

Loads resource data from a binary stream or an XML document.

Overload List

Name | Description
Resource.LoadFrom (BinaryReader, BinarySerializationContext) | Loads resource data from a binary stream.
Resource.LoadFrom (XmlElement, XmlSerializationContext) | Loads resource data from an XML document.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.LoadFrom Method (BinaryReader, BinarySerializationContext)

Resource.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also

Loads resource data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)
Visual Basic

Public Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Allows reading primitive data types from a binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

The reader parameter wraps a stream that contains data by a previous call to the SaveTo method.

See Also

LoadFrom Method Overload List
Resource Members
Resource Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Resource.LoadFrom Method (XmlElement, XmlSerializationContext)

Resource.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads resource data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overridable Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

The reader parameter wraps an XML document that contains data stored by a previous call to the SaveTo method.

See Also

LoadFrom Method Overload List
Resource Members
Resource Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Resource.SaveTo Method

Resource.SaveTo Method

Saves the resource data to a binary stream or an XML document.

Overload List

Name | Description
Resource.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the resource data to a binary stream.
Resource.SaveTo (XmlElement, XmlSerializationContext) | Saves the resource data to an XML document.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.SaveTo Method (BinaryWriter, BinarySerializationContext)

Resource.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also

Saves the resource data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)
Visual Basic

Public Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Allows writing primitive data types to a binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

The fields of the resource are saved as bytes into a binary stream, from which they can be loaded later by calling LoadFrom.

See Also

SaveTo Method Overload List
Resource Members
Resource Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Resource.SaveTo Method (XmlElement, XmlSerializationContext)

Resource.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the resource data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overridable Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the resource properties as elements of an XML document.

See Also

SaveTo Method Overload List
Resource Members
Resource Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Resource Properties

Resource Properties

Public Properties

Name | Description
CustomBrushes | Gets a CustomBrushes object associated with the resource.
Id | Gets or sets the string identifier of this resource.
Name | Gets or sets the name of the resource.
Tag | Gets or sets custom data associated with the resource.

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.CustomBrushes Property

Resource.CustomBrushes Property

Gets a CustomBrushes object associated with the resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public CustomBrushes CustomBrushes { get; set; }
Visual Basic

Public Property CustomBrushes As CustomBrushes

Property Value

An instance of the CustomBrushes class that defines brushes used to paint the background of calendar elements associated with this resource.

Remarks

This property defines a primary and a secondary brush used to paint the background of resource-related UI elements. The scheduled events for a resource can be displayed in their own columns in timetable, week range and resource views. In timetable view the primary brush is used to paint the non-work time cells, and the secondary brush is used to paint the work time cells. In week range view the two brushes are used to alternately paint odd and even weeks.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.Id Property

Resource.Id Property

Gets or sets the string identifier of this resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string Id { get; set; }
Visual Basic

Public Property Id As String

Property Value

A string value identifying uniquely this resource instance.

Remarks

If you need to change its value, make sure the identifier is always unique.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.Name Property

Resource.Name Property

Gets or sets the name of the resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string Name { get; set; }
Visual Basic

Public Property Name As String

Property Value

A string containing the name of the resource. The default is an empty string.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.Tag Property

Resource.Tag Property

Gets or sets custom data associated with the resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Object Tag { get; set; }
Visual Basic

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Use this property to store your custom data. The tag can be a value from a primitive data type or a complex object from the .NET class library or a class defined by you. If the tag is an instance of a value type, it will be serialized together with the object containing it when saving / loading the schedule. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection Class

ResourceCollection Class

Represents a strongly-typed collection of Resource objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class ResourceCollection : CollectionBase
Visual Basic

Public NotInheritable Class ResourceCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.ResourceCollection

See Also

ResourceCollection Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection Members

ResourceCollection Members
Constructors Properties Methods Events

Represents a strongly-typed collection of Resource objects.

The following tables list the members exposed by the ResourceCollection type.

Public Constructors

Name | Description
ResourceCollection | Initializes a new instance of the ResourceCollection class.

Public Properties

Name | Description
Item | Gets a Resource object from the collection given its zero-based index or identifier.

Public Methods

Name | Description
Add | Adds the specified resource to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains particular resource.
Insert | Inserts the specified Resource object at the specified position within the collection.
Remove | Removes the first occurrence of the specified Resource object from this collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection Constructor

ResourceCollection Constructor

Initializes a new instance of the ResourceCollection class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ResourceCollection ()
Visual Basic

Public Sub New ()

See Also

ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection Methods

ResourceCollection Methods

Public Methods

Name | Description
Add | Adds the specified resource to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains particular resource.
Insert | Inserts the specified Resource object at the specified position within the collection.
Remove | Removes the first occurrence of the specified Resource object from this collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.

See Also

ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Add Method

ResourceCollection.Add Method

Adds the specified resource to this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Add (
Resource resource
)
Visual Basic

Public Sub Add ( _
resource As Resource _
)

Parameters

resource
An instance of the Resource class to be added to the collection.

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace
Insert Method


MindFusion.Scheduling.ResourceCollection.Clear Method

ResourceCollection.Clear Method

Removes all elements from the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Contains Method

ResourceCollection.Contains Method

Determines whether this collection contains particular resource.

Overload List

Name | Description
ResourceCollection.Contains (Resource) | Determines whether this collection contains the specified resource.
ResourceCollection.Contains (String) | Determines whether this collection contains a resource identified by the specified string.

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Contains Method (Resource)

ResourceCollection.Contains Method (Resource)
See Also

Determines whether this collection contains the specified resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
Resource resource
)
Visual Basic

Public Function Contains ( _
resource As Resource _
) As Boolean

Parameters

resource
The Resource object to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Contains Method (String)

ResourceCollection.Contains Method (String)
See Also

Determines whether this collection contains a resource identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
string resourceId
)
Visual Basic

Public Function Contains ( _
resourceId As String _
) As Boolean

Parameters

resourceId
The identifier of a resource to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Insert Method

ResourceCollection.Insert Method

Inserts the specified Resource object at the specified position within the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Insert (
int index,
Resource resource
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
resource As Resource _
)

Parameters

index
The zero-based index at which the contact must be inserted.
resource
An instance of the Resource class to be added to the collection.

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace
Add Method


MindFusion.Scheduling.ResourceCollection.OnClearComplete Method

ResourceCollection.OnClearComplete Method

CollectionBase.OnClearComplete override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnClearComplete ()
Visual Basic

Protected Overridable Sub OnClearComplete ()

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.OnInsertComplete Method

ResourceCollection.OnInsertComplete Method

CollectionBase.OnInsertComplete override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnInsertComplete (
int index,
Object value
)
Visual Basic

Protected Overridable Sub OnInsertComplete ( _
index As Integer, _
value As Object _
)

Parameters

index
value

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.OnRemoveComplete Method

ResourceCollection.OnRemoveComplete Method

CollectionBase.OnRemoveComplete override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnRemoveComplete (
int index,
Object value
)
Visual Basic

Protected Overridable Sub OnRemoveComplete ( _
index As Integer, _
value As Object _
)

Parameters

index
value

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Remove Method

ResourceCollection.Remove Method

Removes the first occurrence of the specified Resource object from this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Remove (
Resource resource
)
Visual Basic

Public Sub Remove ( _
resource As Resource _
)

Parameters

resource
A Resource instance which must be removed from the collection.

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection Properties

ResourceCollection Properties

Public Properties

Name | Description
Item | Gets a Resource object from the collection given its zero-based index or identifier.

See Also

ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Item Property

ResourceCollection.Item Property

Gets a Resource object from the collection given its zero-based index or identifier.

Overload List

Name | Description
ResourceCollection.Item (Int32) | Gets or sets the Resource object located at the specified position within this collection.
ResourceCollection.Item (String) | Gets the Resource object identified by the specified string.

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Item Property (Int32)

ResourceCollection.Item Property (Int32)
See Also

Gets or sets the Resource object located at the specified position within this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Resource Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Resource

Parameters

index
The zero-based index of the Resource to set or retrieve.

Property Value

The Resource instance at the specified index.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their integer indices.

See Also

Item Property Overload List
ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Item Property (String)

ResourceCollection.Item Property (String)
See Also

Gets the Resource object identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Resource Item [
string id
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
id As String _
) As Resource

Parameters

id

The Id of the Resource to get.

Property Value

The Resource instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

Item Property Overload List
ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection Events

ResourceCollection Events

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Changed Event

ResourceCollection.Changed Event

Raised when the collection has been changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler Changed
Visual Basic

Public Event Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Class

Schedule Class

Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances - the views.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class Schedule : IDisposable
Visual Basic

Public Class Schedule
Implements IDisposable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Schedule

See Also

Schedule Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Members

Schedule Members
Constructors Fields Properties Methods Events

Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances - the views.

The following tables list the members exposed by the Schedule type.

Public Constructors

Name | Description
Schedule | Initializes a new instance of the Schedule class.

Public Fields

Name | Description
CurrentVersion | The current version of the schedule file format.

Public Properties

Name | Description
Contacts | Gets all contacts defined in the Schedule.
DisableReminders | Gets or sets a value indicating whether to completely disable reminders in the whole schedule.
Items | Gets all scheduled items.
Locations | Gets all locations defined in the Schedule.
RemindersCheckInterval | Gets or sets the interval between reminder checks, expressed in seconds.
Resources | Gets all resources defined in the Schedule.
Tasks | Gets all tasks defined in this Schedule.

Public Methods

Name | Description
Clear | Clears all items, tasks, locations, contacts and resources contained in this schedule.
Dispose | Disposes any resources used by this Schedule object.
GetAllItems | Overloaded. Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.
GetFreePeriod | Overloaded. Returns the next period with the specified duration after the specified date, which is not occupied by items.
GetItemsToRemindOf | Overloaded. Retrieves a collection of all items that must be reminded of.
GetTasksToRemindOf | Overloaded. Retrieves a collection of all tasks that must be reminded of.
IsClassRegistered | Overloaded. Checks whether a specified class identifier or type is registered for serialization.
LoadFrom | Overloaded. Loads schedule data from a file, a binary stream or an XML document.
LoadFromStream | Loads schedule data from a binary stream.
LoadFromString | Overloaded.
LoadFromXml | Loads schedule data from an XML document.
RegisterItemClass | Registers a schedule item class for serialization support.
RegisterResourceClass | Registers a resource class for serialization support.
SaveTo | Overloaded. Saves the schedule to a file, a binary stream or an XML document.
SaveToStream | Saves the schedule to a binary stream.
SaveToString | Overloaded.
SaveToXml | Saves the schedule to an XML document.
UnregisterClass | Overloaded. Unregisters the item or resource with the specified class identifier or type from the system.

Protected Methods

Name | Description
OnDeserializeTag | Raises the DeserializeTag event.
OnExceptionCreated | Raises the ExceptionCreated event.
OnInstantiateItem | Raises the InstantiateItem event.
OnInstantiateResource | Raises the InstantiateResource event.
OnItemEndTimeChanged | Raises the ItemEndTimeChanged event.
OnItemEndTimeTriggered | Raises the ItemEndTimeTriggered event.
OnItemReminderTriggered | Raises the ItemReminderTriggered event.
OnItemStartTimeChanged | Raises the ItemStartTimeChanged event.
OnItemVisualsChanged | Raises the ItemVisualsChanged event.
OnRecurrenceReset | Raises the RecurrenceReset event.
OnSerializeTag | Raises the SerializeTag event.
OnTaskReminderTriggered | Raises the TaskReminderTriggered event.

Public Events

Name | Description
Changed | Raised when items are added or removed from the schedule or when the schedule is loaded.
DeserializeTag | Raised during XML deserialization to enable users to perform custom deserialization of the tag values of items and resources.
ExceptionCreated | Raised when a recurrence exception item is created.
InstantiateItem | Raised when deserializing a custom item whose type has not been registered.
InstantiateResource | Raised when deserializing a custom resource whose type has not been registered.
ItemEndTimeChanged | Raised when the EndTime property of an item in this Schedule has changed. The ItemTimeEventArgs.Time property provides the previous EndTime value of the item.
ItemEndTimeTriggered | Raised when the reminder for an item is triggered, but taking into consideration the item's end time for the purpose.
ItemReminderTriggered | Raised when the reminder for an item is triggered.
ItemStartTimeChanged | Raised when the StartTime property of an item in this Schedule has changed. The ItemTimeEventArgs.Time property provides the previous StartTime value of the item.
ItemVisualsChanged | Raised when the appearance of an item in the schedule has changed.
RecurrenceReset | Raised when the recurrence pattern associated with an item has been reset, causing all associated exception items to be lost.
SerializeTag | Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.
TaskReminderTriggered | Raised when the reminder for a task is triggered.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Fields

Schedule Fields

Public Fields

Name | Description
CurrentVersion | The current version of the schedule file format.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.CurrentVersion Field

Schedule.CurrentVersion Field

The current version of the schedule file format.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public static int CurrentVersion
Visual Basic

Public Shared CurrentVersion As Integer

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Constructor

Schedule Constructor

Initializes a new instance of the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Schedule ()
Visual Basic

Public Sub New ()

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Methods

Schedule Methods

Public Methods

Name | Description
Clear | Clears all items, tasks, locations, contacts and resources contained in this schedule.
Dispose | Disposes any resources used by this Schedule object.
GetAllItems | Overloaded. Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.
GetFreePeriod | Overloaded. Returns the next period with the specified duration after the specified date, which is not occupied by items.
GetItemsToRemindOf | Overloaded. Retrieves a collection of all items that must be reminded of.
GetTasksToRemindOf | Overloaded. Retrieves a collection of all tasks that must be reminded of.
IsClassRegistered | Overloaded. Checks whether a specified class identifier or type is registered for serialization.
LoadFrom | Overloaded. Loads schedule data from a file, a binary stream or an XML document.
LoadFromStream | Loads schedule data from a binary stream.
LoadFromString | Overloaded.
LoadFromXml | Loads schedule data from an XML document.
RegisterItemClass | Registers a schedule item class for serialization support.
RegisterResourceClass | Registers a resource class for serialization support.
SaveTo | Overloaded. Saves the schedule to a file, a binary stream or an XML document.
SaveToStream | Saves the schedule to a binary stream.
SaveToString | Overloaded.
SaveToXml | Saves the schedule to an XML document.
UnregisterClass | Overloaded. Unregisters the item or resource with the specified class identifier or type from the system.

Protected Methods

Name | Description
OnDeserializeTag | Raises the DeserializeTag event.
OnExceptionCreated | Raises the ExceptionCreated event.
OnInstantiateItem | Raises the InstantiateItem event.
OnInstantiateResource | Raises the InstantiateResource event.
OnItemEndTimeChanged | Raises the ItemEndTimeChanged event.
OnItemEndTimeTriggered | Raises the ItemEndTimeTriggered event.
OnItemReminderTriggered | Raises the ItemReminderTriggered event.
OnItemStartTimeChanged | Raises the ItemStartTimeChanged event.
OnItemVisualsChanged | Raises the ItemVisualsChanged event.
OnRecurrenceReset | Raises the RecurrenceReset event.
OnSerializeTag | Raises the SerializeTag event.
OnTaskReminderTriggered | Raises the TaskReminderTriggered event.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Clear Method

Schedule.Clear Method

Clears all items, tasks, locations, contacts and resources contained in this schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Clear ()
Visual Basic

Public Sub Clear ()

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Contacts Property
Items Property
Locations Property
Resources Property
Tasks Property


MindFusion.Scheduling.Schedule.Dispose Method

Schedule.Dispose Method

Disposes any resources used by this Schedule object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void Dispose ()
Visual Basic

Public Overridable Sub Dispose ()

Remarks

It is important to call Dispose on the object when you are done using it, in order to stop the schedule's timer used to trigger reminder events.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method

Schedule.GetAllItems Method

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.

Overload List

Name | Description
Schedule.GetAllItems (DateTime, DateTime) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.
Schedule.GetAllItems (DateTime, DateTime, Contact) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Contact object.
Schedule.GetAllItems (DateTime, DateTime, Location) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Location object.
Schedule.GetAllItems (DateTime, DateTime, Resource) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Resource object.
Schedule.GetAllItems (DateTime, DateTime, Task) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Task object.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime)

Schedule.GetAllItems Method (DateTime, DateTime)
See Also

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemCollection GetAllItems (
DateTime startTime,
DateTime endTime
)
Visual Basic

Public Function GetAllItems ( _
startTime As DateTime, _
endTime As DateTime _
) As ItemCollection

Parameters

startTime
Time interval start.
endTime
Time interval end.

Return Value

A collection that contains the events scheduled to occur in the specified period.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Contact)

Schedule.GetAllItems Method (DateTime, DateTime, Contact)
See Also

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Contact object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Contact contact
)
Visual Basic

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
contact As Contact _
) As ItemCollection

Parameters

startDate
Specifies the start of the time period.
endDate
Specifies the end of the time period.
contact
A Contact instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified contact.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Location)

Schedule.GetAllItems Method (DateTime, DateTime, Location)
See Also

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Location object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Location location
)
Visual Basic

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
location As Location _
) As ItemCollection

Parameters

startDate
Specifies the start of the time period.
endDate
Specifies the end of the time period.
location
A Location instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified location.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Resource)

Schedule.GetAllItems Method (DateTime, DateTime, Resource)
See Also

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Resource object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Resource resource
)
Visual Basic

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
resource As Resource _
) As ItemCollection

Parameters

startDate
Specifies the start of the time period.
endDate
Specifies the end of the time period.
resource
A Resource instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified resource.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Task)

Schedule.GetAllItems Method (DateTime, DateTime, Task)
See Also

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Task object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Task task
)
Visual Basic

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
task As Task _
) As ItemCollection

Parameters

startDate
Specifies the start of the time period.
endDate
Specifies the end of the time period.
task
A Task instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified task.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method

Schedule.GetFreePeriod Method

Returns the next period with the specified duration after the specified date, which is not occupied by items.

Overload List

Name | Description
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan) | Returns the next period with the specified duration after the specified date, which is not occupied by items.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ContactCollection) | Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified contacts.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, LocationCollection) | Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified locations.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection) | Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified resources.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, TaskCollection) | Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified tasks.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan)

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan)
See Also

Returns the next period with the specified duration after the specified date, which is not occupied by items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration
)
Visual Basic

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ContactCollection)

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ContactCollection)
See Also

Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified contacts.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ContactCollection contacts
)
Visual Basic

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
contacts As ContactCollection _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.
contacts
The contacts whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, LocationCollection)

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, LocationCollection)
See Also

Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified locations.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
LocationCollection locations
)
Visual Basic

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
locations As LocationCollection _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.
locations
The locations whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection)

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection)
See Also

Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection resources
)
Visual Basic

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
resources As ResourceCollection _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.
resources
The resources whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, TaskCollection)

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, TaskCollection)
See Also

Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified tasks.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
TaskCollection tasks
)
Visual Basic

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
tasks As TaskCollection _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.
tasks
The tasks whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method

Schedule.GetItemsToRemindOf Method

Retrieves a collection of all items that must be reminded of.

Overload List

Name | Description
Schedule.GetItemsToRemindOf () | Retrieves a collection with all items that must be reminded of at the current time.
Schedule.GetItemsToRemindOf (DateTime) | Retrieves a collection with all items that must be reminded of at the specified time.
Schedule.GetItemsToRemindOf (DateTime, DateTime) | Retrieves a collection with all items that must be reminded of in the specified interval.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method ()

Schedule.GetItemsToRemindOf Method ()
See Also

Retrieves a collection with all items that must be reminded of at the current time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemCollection GetItemsToRemindOf ()
Visual Basic

Public Function GetItemsToRemindOf () As ItemCollection

Return Value

The collection of all items whose reminders must be displayed at the current time.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetTasksToRemindOf Method


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method (DateTime)

Schedule.GetItemsToRemindOf Method (DateTime)
See Also

Retrieves a collection with all items that must be reminded of at the specified time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemCollection GetItemsToRemindOf (
DateTime time
)
Visual Basic

Public Function GetItemsToRemindOf ( _
time As DateTime _
) As ItemCollection

Parameters

time
Determine whether any reminders should be displayed at this time.

Return Value

The collection of all items whose reminders must be displayed at the specified time.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetTasksToRemindOf Method


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method (DateTime, DateTime)

Schedule.GetItemsToRemindOf Method (DateTime, DateTime)
See Also

Retrieves a collection with all items that must be reminded of in the specified interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemCollection GetItemsToRemindOf (
DateTime start,
DateTime end
)
Visual Basic

Public Function GetItemsToRemindOf ( _
start As DateTime, _
end As DateTime _
) As ItemCollection

Parameters

start
The start of the time interval containing the items of interest.
end
The end of the time interval containing the items of interest.

Return Value

The collection of all items whose reminders must be displayed in the specified time interval.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetTasksToRemindOf Method


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method

Schedule.GetTasksToRemindOf Method

Retrieves a collection of all tasks that must be reminded of.

Overload List

Name | Description
Schedule.GetTasksToRemindOf () | Retrieves a collection of all tasks that must be reminded of at the current time.
Schedule.GetTasksToRemindOf (DateTime) | Retrieves a collection of all tasks that must be reminded of at the specified time.
Schedule.GetTasksToRemindOf (DateTime, DateTime) | Retrieves a collection of all tasks that must be reminded of in the specified interval.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method ()

Schedule.GetTasksToRemindOf Method ()
See Also

Retrieves a collection of all tasks that must be reminded of at the current time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public TaskCollection GetTasksToRemindOf ()
Visual Basic

Public Function GetTasksToRemindOf () As TaskCollection

Return Value

The collection of all tasks whose reminders must be displayed at the current time.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetItemsToRemindOf Method


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method (DateTime)

Schedule.GetTasksToRemindOf Method (DateTime)
See Also

Retrieves a collection of all tasks that must be reminded of at the specified time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public TaskCollection GetTasksToRemindOf (
DateTime time
)
Visual Basic

Public Function GetTasksToRemindOf ( _
time As DateTime _
) As TaskCollection

Parameters

time
Determine whether any task reminders should be displayed at this time.

Return Value

The collection of all tasks whose reminders must be displayed at the specified time.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetItemsToRemindOf Method


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method (DateTime, DateTime)

Schedule.GetTasksToRemindOf Method (DateTime, DateTime)
See Also

Retrieves a collection of all tasks that must be reminded of in the specified interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public TaskCollection GetTasksToRemindOf (
DateTime start,
DateTime end
)
Visual Basic

Public Function GetTasksToRemindOf ( _
start As DateTime, _
end As DateTime _
) As TaskCollection

Parameters

start
The start of the time interval containing the tasks of interest.
end
The end of the time interval containing the tasks of interest.

Return Value

The collection of all tasks whose reminders must be displayed in the specified time interval.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetItemsToRemindOf Method


MindFusion.Scheduling.Schedule.IsClassRegistered Method

Schedule.IsClassRegistered Method

Checks whether a specified class identifier or type is registered for serialization.

Overload List

Name | Description
Schedule.IsClassRegistered (String) | Checks whether the specified item or resource class identifier is registered for serializaiton.
Schedule.IsClassRegistered (Type) | Checks whether the specified item or resource type is registered for serializaiton.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterItemClass Method
RegisterResourceClass Method
UnregisterClass Method


MindFusion.Scheduling.Schedule.IsClassRegistered Method (String)

Schedule.IsClassRegistered Method (String)
See Also

Checks whether the specified item or resource class identifier is registered for serializaiton.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public static bool IsClassRegistered (
string classId
)
Visual Basic

Public Shared Function IsClassRegistered ( _
classId As String _
) As Boolean

Parameters

classId
The string identifier of an item or resource class.

Return Value

true if the specified class identifier is already registered; otherwise, false.

See Also

IsClassRegistered Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterItemClass Method
RegisterResourceClass Method
UnregisterClass Method


MindFusion.Scheduling.Schedule.IsClassRegistered Method (Type)

Schedule.IsClassRegistered Method (Type)
See Also

Checks whether the specified item or resource type is registered for serializaiton.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public static bool IsClassRegistered (
Type classType
)
Visual Basic

Public Shared Function IsClassRegistered ( _
classType As Type _
) As Boolean

Parameters

classType
The type of an item or a resource.

Return Value

true if the specified class identifier is already registered; otherwise, false.

See Also

IsClassRegistered Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterItemClass Method
RegisterResourceClass Method
UnregisterClass Method


MindFusion.Scheduling.Schedule.LoadFrom Method

Schedule.LoadFrom Method

Loads schedule data from a file, a binary stream or an XML document.

Overload List

Name | Description
Schedule.LoadFrom (String) | Loads schedule data from a file.
Schedule.LoadFrom (String, ContentType) | Loads schedule data from a file.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.LoadFrom Method (String)

Schedule.LoadFrom Method (String)
See Also

Loads schedule data from a file.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

public void LoadFrom (
string fileName
)
Visual Basic

Public Sub LoadFrom ( _
fileName As String _
)

Parameters

fileName
The name of the file from which to load the schedule.

Remarks

This method loads the schedule data from a file where it was previously saved by a call to SaveTo. Any data contained in the schedule is discarded before the items stored in the file are loaded.

See Also

LoadFrom Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Schedule.LoadFrom Method (String, ContentType)

Schedule.LoadFrom Method (String, ContentType)
See Also

Loads schedule data from a file.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void LoadFrom (
string fileName,
ContentType contentType
)
Visual Basic

Public Sub LoadFrom ( _
fileName As String, _
contentType As ContentType _
)

Parameters

fileName
The name of the file from which to load the schedule.
contentType
Specifies whether the data is in binary or XML format.

Remarks

This method loads the schedule data from a file where it was previously saved by a call to SaveTo. Any data contained in the schedule is discarded before the items stored in the file are loaded.

See Also

LoadFrom Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Schedule.LoadFromStream Method

Schedule.LoadFromStream Method

Loads schedule data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void LoadFromStream (
Stream stream
)
Visual Basic

Public Sub LoadFromStream ( _
stream As Stream _
)

Parameters

stream
The stream to load the schedule from.

Remarks

This method loads data from a binary stream previously saved there by SaveToStream. Any data contained in the schedule is discarded before the items stored in the stream are loaded.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveToStream Method


MindFusion.Scheduling.Schedule.LoadFromString Method

Schedule.LoadFromString Method

Overload List

Name | Description
Schedule.LoadFromString (String) | Decodes schedule data from a string previously created by SaveToString.
Schedule.LoadFromString (String, ContentType) | Decodes schedule data from a string previously created by SaveToString.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.LoadFromString Method (String)

Schedule.LoadFromString Method (String)
See Also

Decodes schedule data from a string previously created by SaveToString.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

public void LoadFromString (
string content
)
Visual Basic

Public Sub LoadFromString ( _
content As String _
)

Parameters

content
A string that contains schedule data.

Remarks

This method loads from a string data previously saved by SaveToString.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveToString Method


MindFusion.Scheduling.Schedule.LoadFromString Method (String, ContentType)

Schedule.LoadFromString Method (String, ContentType)
See Also

Decodes schedule data from a string previously created by SaveToString.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void LoadFromString (
string content,
ContentType contentType
)
Visual Basic

Public Sub LoadFromString ( _
content As String, _
contentType As ContentType _
)

Parameters

content
A string that contains schedule data.
contentType
Specifies whether the data is stored in binary or XML format.

Remarks

This method loads from a string data previously saved by SaveToString.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveToString Method


MindFusion.Scheduling.Schedule.LoadFromXml Method

Schedule.LoadFromXml Method

Loads schedule data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void LoadFromXml (
XmlDocument document
)
Visual Basic

Public Sub LoadFromXml ( _
document As XmlDocument _
)

Parameters

document
A .NET XmlDocument instance that allows reading data from the XML document.

Remarks

Loads schedule data from an XML document previously created by SaveToXml. Any data contained in the schedule is discarded before the items stored in the reader are loaded.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveToXml Method


MindFusion.Scheduling.Schedule.OnDeserializeTag Method

Schedule.OnDeserializeTag Method

Raises the DeserializeTag event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnDeserializeTag (
SerializeTagEventArgs e
)
Visual Basic

Protected Overridable Sub OnDeserializeTag ( _
e As SerializeTagEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnExceptionCreated Method

Schedule.OnExceptionCreated Method

Raises the ExceptionCreated event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnExceptionCreated (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnExceptionCreated ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnInstantiateItem Method

Schedule.OnInstantiateItem Method

Raises the InstantiateItem event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnInstantiateItem (
InstantiateItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnInstantiateItem ( _
e As InstantiateItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnInstantiateResource Method

Schedule.OnInstantiateResource Method

Raises the InstantiateResource event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnInstantiateResource (
InstantiateResourceEventArgs e
)
Visual Basic

Protected Overridable Sub OnInstantiateResource ( _
e As InstantiateResourceEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemEndTimeChanged Method

Schedule.OnItemEndTimeChanged Method

Raises the ItemEndTimeChanged event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemEndTimeChanged (
ItemTimeEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemEndTimeChanged ( _
e As ItemTimeEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemEndTimeTriggered Method

Schedule.OnItemEndTimeTriggered Method

Raises the ItemEndTimeTriggered event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemEndTimeTriggered (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemEndTimeTriggered ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemReminderTriggered Method

Schedule.OnItemReminderTriggered Method

Raises the ItemReminderTriggered event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemReminderTriggered (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemReminderTriggered ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemStartTimeChanged Method

Schedule.OnItemStartTimeChanged Method

Raises the ItemStartTimeChanged event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemStartTimeChanged (
ItemTimeEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemStartTimeChanged ( _
e As ItemTimeEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemVisualsChanged Method

Schedule.OnItemVisualsChanged Method

Raises the ItemVisualsChanged event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemVisualsChanged (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemVisualsChanged ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnRecurrenceReset Method

Schedule.OnRecurrenceReset Method

Raises the RecurrenceReset event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnRecurrenceReset (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnRecurrenceReset ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnSerializeTag Method

Schedule.OnSerializeTag Method

Raises the SerializeTag event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnSerializeTag (
SerializeTagEventArgs e
)
Visual Basic

Protected Overridable Sub OnSerializeTag ( _
e As SerializeTagEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnTaskReminderTriggered Method

Schedule.OnTaskReminderTriggered Method

Raises the TaskReminderTriggered event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnTaskReminderTriggered (
TaskEventArgs e
)
Visual Basic

Protected Overridable Sub OnTaskReminderTriggered ( _
e As TaskEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.RegisterItemClass Method

Schedule.RegisterItemClass Method

Registers a schedule item class for serialization support.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public static void RegisterItemClass (
Type itemClass,
string classId,
int classVersion
)
Visual Basic

Public Shared Sub RegisterItemClass ( _
itemClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

itemClass
A .NET Type instance identifying the item class.
classId
A class identifier to use when saving and loading items of the specified type.
classVersion
A revision number of the item's class serialization format.

Remarks

When using custom item classes, use this method to enable saving and loading the custom item objects to/from XML or binary files. The class id string is written before each item's data, and when loading items later that string indicates to the schedule what class instance to create and let it load the subsequent data. The following class identifiers are reserved and should not be used: 'std:appointment', 'std:resource', 'std:contact', 'std:location' and 'std:task'.

The version identifier must be increased when the format in which items are saved changes. It is used when loading files to let your application load items data from an older format.

Note

All custom item classes must provide a parameterless constructor. Failing to do so would result in exceptions during the load process, since the schedule will be unable to create custom items.

Example

The following example demonstrates how to use custom item classes with the schedule and how to load and save a schedule containing custom items. The example presumes that schedule already references an existing Schedule object.

Running the example should dump the following line to the output console:

Hello, friend!

C#

/// <summary>
/// The declaration of the custom item class.
/// </summary>
class CustomItem : Appointment
{
/// <summary>
/// The parameterless constructor, required by the Schedule.
/// </summary>
public CustomItem()
{
_customField = "This is my field.";
}

public override void LoadFrom(
System.IO.BinaryReader reader,
SerializationContext context)
{
// Don't forget to invoke LoadFrom on the base class
base.LoadFrom(reader, context);

_customField = reader.ReadString();
}

public override void LoadFrom(
System.Xml.XmlReader reader,
SerializationContext context)
{
// Don't forget to invoke LoadFrom on the base class
base.LoadFrom(reader, context);

_customField = reader.ReadElementString("customField");
}

public override void SaveTo(
System.IO.BinaryWriter writer,
SerializationContext context)
{
// Don't forget to invoke SaveTo on the base class
base.SaveTo(writer, context);

writer.Write(_customField);
}

public override void SaveTo(
System.Xml.XmlWriter writer,
SerializationContext context)
{
base.SaveTo(writer, context);

writer.WriteElementString("customField", _customField);
}

public string CustomField
{
get { return _customField; }
set { _customField = value; }
}

private string _customField;
}

// ...

// Register our custom item class for use with the schedule
Schedule.RegisterItemClass(typeof(CustomItem), "customItemId", 1);

// Create a new custom item and add it to the schedule
CustomItem customItem = new CustomItem();
customItem.CustomField = "Hello, friend!";
schedule.Items.Add(customItem);

// Save the schedule to a file.
// Make sure the specified path exists on your drive
schedule.SaveTo(@"c:\schedule.save", ContentType.Xml);

// Clear the schedule
schedule.Items.Clear();

// Load the previously saved schedule data
schedule.LoadFrom(@"c:\schedule.save", ContentType.Xml);

// Test the data
foreach (Item item in schedule.Items)
{
if (item is CustomItem)
{
System.Diagnostics.Debug.WriteLine(
(item as CustomItem).CustomField);
}
}
Visual Basic

' <summary>
' The declaration of the custom item class.
' </summary>
Class CustomItem
Inherits Appointment

' <summary>
' The parameterless constructor, required by the Schedule.
' </summary>
Public Sub New()

_customField = "This is my field."

End Sub

Public Overloads Overrides Sub LoadFrom( _
ByVal reader As System.IO.BinaryReader, _
ByVal context As SerializationContext)

' Don't forget to invoke LoadFrom on the base class
MyBase.LoadFrom(reader, context)

_customField = reader.ReadString()

End Sub

Public Overloads Overrides Sub LoadFrom( _
ByVal reader As System.Xml.XmlReader, _
ByVal context As SerializationContext)

' Don't forget to invoke LoadFrom on the base class
MyBase.LoadFrom(reader, context)

_customField = reader.ReadElementString("customField")

End Sub

Public Overloads Overrides Sub SaveTo( _
ByVal writer As System.IO.BinaryWriter, _
ByVal context As SerializationContext)

' Don't forget to invoke SaveTo on the base class
MyBase.SaveTo(writer, context)

writer.Write(_customField)

End Sub

Public Overloads Overrides Sub SaveTo( _
ByVal writer As System.Xml.XmlWriter, _
ByVal context As SerializationContext)

MyBase.SaveTo(writer, context)

writer.WriteElementString("customField", _customField)

End Sub

Public Property CustomField() As String

Get
Return _customField
End Get

Set(ByVal Value As String)
_customField = Value
End Set

End Property

Private _customField As String

End Class

' ...

' Register our custom item class for use with the schedule
schedule.RegisterItemClass(GetType(CustomItem), "customItemId", 1)

' Create a new custom item and add it to the schedule
Dim customItem As New CustomItem
customItem.CustomField = "Hello, friend!"
schedule.Items.Add(customItem)

' Save the schedule to a file.
' Make sure the specified path exists on your drive
schedule.SaveTo("c:\schedule.save", ContentType.Xml)

' Clear the schedule
schedule.Items.Clear()

' Load the previously saved schedule data
schedule.LoadFrom("c:\schedule.save", ContentType.Xml)

' Test the data
Dim item As Item
For Each item In schedule.Items

If TypeOf item Is CustomItem Then

System.Diagnostics.Debug.WriteLine( _
CType(item, CustomItem).CustomField)

End If

Next item

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterResourceClass Method


MindFusion.Scheduling.Schedule.RegisterResourceClass Method

Schedule.RegisterResourceClass Method

Registers a resource class for serialization support.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public static void RegisterResourceClass (
Type resourceClass,
string classId,
int classVersion
)
Visual Basic

Public Shared Sub RegisterResourceClass ( _
resourceClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

resourceClass
A .NET Type instance identifying the resource class.
classId
A class identifier to use when saving and loading resources of the specified type.
classVersion
A revision number of the resource's class serialization format.

Remarks

When using custom resource classes, use this method to enable saving and loading the custom resource objects to/from XML or binary files. The class id string is written before each resource's data, and when loading resources later that string indicates to the schedule what class instance to create and let it load the subsequent data. The following class identifiers are reserved and should not be used: 'std:appointment', 'std:resource', 'std:contact', 'std:location' and 'std:task'.

The version identifier must be increased when the format in which resources are saved changes. It is used when loading files to let your application load resources data from an older format.

Note

All custom resource classes must provide a parameterless constructor. Failing to do so would result in exceptions during the load process, since the schedule will be unable to create custom resources.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SaveTo Method

Schedule.SaveTo Method

Saves the schedule to a file, a binary stream or an XML document.

Overload List

Name | Description
Schedule.SaveTo (String) | Saves the schedule to a file.
Schedule.SaveTo (String, ContentType) | Saves the schedule to a file.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SaveTo Method (String)

Schedule.SaveTo Method (String)
See Also

Saves the schedule to a file.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

public void SaveTo (
string fileName
)
Visual Basic

Public Sub SaveTo ( _
fileName As String _
)

Parameters

fileName

The path of the file to save to.

Remarks

Saves the schedule data into a binary or XML file. Use LoadFrom to restore the data later.

See Also

SaveTo Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Schedule.SaveTo Method (String, ContentType)

Schedule.SaveTo Method (String, ContentType)
See Also

Saves the schedule to a file.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void SaveTo (
string fileName,
ContentType contentType
)
Visual Basic

Public Sub SaveTo ( _
fileName As String, _
contentType As ContentType _
)

Parameters

fileName
The path of the file to save to.
contentType
Specifies whether to save the data in binary or XML format.

Remarks

Saves the schedule data into a binary or XML file. Use LoadFrom to restore the data later.

See Also

SaveTo Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Schedule.SaveToStream Method

Schedule.SaveToStream Method

Saves the schedule to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void SaveToStream (
Stream stream
)
Visual Basic

Public Sub SaveToStream ( _
stream As Stream _
)

Parameters

stream
The stream to save the schedule to.

Remarks

Saves the schedule data as bytes in a binary stream. Use LoadFromStream to restore the data later.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFromStream Method


MindFusion.Scheduling.Schedule.SaveToString Method

Schedule.SaveToString Method

Overload List

Name | Description
Schedule.SaveToString () | Encodes the schedule into a string.
Schedule.SaveToString (ContentType) | Encodes the schedule into a string.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SaveToString Method ()

Schedule.SaveToString Method ()
See Also

Encodes the schedule into a string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

public string SaveToString ()
Visual Basic

Public Function SaveToString () As String

Return Value

A string containing all schedule data.

Remarks

Saves the schedule data into a base64-encoded string. Use LoadFromString to restore the data later.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFromString Method


MindFusion.Scheduling.Schedule.SaveToString Method (ContentType)

Schedule.SaveToString Method (ContentType)
See Also

Encodes the schedule into a string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string SaveToString (
ContentType contentType
)
Visual Basic

Public Function SaveToString ( _
contentType As ContentType _
) As String

Parameters

contentType
Specifies whether the schedule data should be saved in binary or XML format.

Return Value

A string containing all schedule data.

Remarks

Saves the schedule data into a base64-encoded string. Use LoadFromString to restore the data later.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFromString Method


MindFusion.Scheduling.Schedule.SaveToXml Method

Schedule.SaveToXml Method

Saves the schedule to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void SaveToXml (
XmlDocument document
)
Visual Basic

Public Sub SaveToXml ( _
document As XmlDocument _
)

Parameters

document
A .NET XmlDocument object that allows adding data to the XML document.

Remarks

Saves the schedule data as tags in an XML document. Use LoadFromXml to restore the schedule data later.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFromXml Method


MindFusion.Scheduling.Schedule.UnregisterClass Method

Schedule.UnregisterClass Method

Unregisters the item or resource with the specified class identifier or type from the system.

Overload List

Name | Description
Schedule.UnregisterClass (String) | Unregisters the item or resource with the specified class id from the system.
Schedule.UnregisterClass (Type) | Unregisters the specified item or resource type from the system.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
IsClassRegistered Method
RegisterItemClass Method
RegisterResourceClass Method


MindFusion.Scheduling.Schedule.UnregisterClass Method (String)

Schedule.UnregisterClass Method (String)
See Also

Unregisters the item or resource with the specified class id from the system.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public static void UnregisterClass (
string classId
)
Visual Basic

Public Shared Sub UnregisterClass ( _
classId As String _
)

Parameters

classId
The string identifier of an item or resource class.

See Also

UnregisterClass Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
IsClassRegistered Method
RegisterItemClass Method
RegisterResourceClass Method


MindFusion.Scheduling.Schedule.UnregisterClass Method (Type)

Schedule.UnregisterClass Method (Type)
See Also

Unregisters the specified item or resource type from the system.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public static void UnregisterClass (
Type classType
)
Visual Basic

Public Shared Sub UnregisterClass ( _
classType As Type _
)

Parameters

classType
The type of an item or a resource.

See Also

UnregisterClass Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
IsClassRegistered Method
RegisterItemClass Method
RegisterResourceClass Method


MindFusion.Scheduling.Schedule Properties

Schedule Properties

Public Properties

Name | Description
Contacts | Gets all contacts defined in the Schedule.
DisableReminders | Gets or sets a value indicating whether to completely disable reminders in the whole schedule.
Items | Gets all scheduled items.
Locations | Gets all locations defined in the Schedule.
RemindersCheckInterval | Gets or sets the interval between reminder checks, expressed in seconds.
Resources | Gets all resources defined in the Schedule.
Tasks | Gets all tasks defined in this Schedule.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Contacts Property

Schedule.Contacts Property

Gets all contacts defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ContactCollection Contacts { get; }
Visual Basic

Public ReadOnly Property Contacts As ContactCollection

Property Value

An instance of the ContactCollection class containing all contacts used in the schedule.

Remarks

Add contacts to this collection before assigning them to a schedule item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Contact Class


MindFusion.Scheduling.Schedule.DisableReminders Property

Schedule.DisableReminders Property

Gets or sets a value indicating whether to completely disable reminders in the whole schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool DisableReminders { get; set; }
Visual Basic

Public Property DisableReminders As Boolean

Property Value

true to disable reminders; false to enable them. The default is false.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Items Property

Schedule.Items Property

Gets all scheduled items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemCollection Items { get; }
Visual Basic

Public ReadOnly Property Items As ItemCollection

Property Value

An instance of the ItemCollection class containing all items in the schedule.

Remarks

The Calendar control displays each element of this collection in the time cells corresponding to the item's StartTime and EndTime.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Item Class


MindFusion.Scheduling.Schedule.Locations Property

Schedule.Locations Property

Gets all locations defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public LocationCollection Locations { get; }
Visual Basic

Public ReadOnly Property Locations As LocationCollection

Property Value

An instance of the LocationCollection class containing all locations associated with this schedule.

Remarks

Add locations to this collection before assigning them to schedule items.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Location Class


MindFusion.Scheduling.Schedule.RemindersCheckInterval Property

Schedule.RemindersCheckInterval Property

Gets or sets the interval between reminder checks, expressed in seconds.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int RemindersCheckInterval { get; set; }
Visual Basic

Public Property RemindersCheckInterval As Integer

Property Value

A positive integer value specifying the time between subsequent reminder checks.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Resources Property

Schedule.Resources Property

Gets all resources defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ResourceCollection Resources { get; }
Visual Basic

Public ReadOnly Property Resources As ResourceCollection

Property Value

An instance of the ResourceCollection class containing all resources associated with this schedule.

Remarks

Add resources to this collection before assigning them to schedule items.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Resource Class


MindFusion.Scheduling.Schedule.Tasks Property

Schedule.Tasks Property

Gets all tasks defined in this Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public TaskCollection Tasks { get; }
Visual Basic

Public ReadOnly Property Tasks As TaskCollection

Property Value

An instance of the TaskCollection class containing references to the tasks assigned to the schedule.

Remarks

If you need to assign a Task object to schedule items, add the task to this collection before assigning it to the item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Task Class


MindFusion.Scheduling.Schedule Events

Schedule Events

Public Events

Name | Description
Changed | Raised when items are added or removed from the schedule or when the schedule is loaded.
DeserializeTag | Raised during XML deserialization to enable users to perform custom deserialization of the tag values of items and resources.
ExceptionCreated | Raised when a recurrence exception item is created.
InstantiateItem | Raised when deserializing a custom item whose type has not been registered.
InstantiateResource | Raised when deserializing a custom resource whose type has not been registered.
ItemEndTimeChanged | Raised when the EndTime property of an item in this Schedule has changed. The ItemTimeEventArgs.Time property provides the previous EndTime value of the item.
ItemEndTimeTriggered | Raised when the reminder for an item is triggered, but taking into consideration the item's end time for the purpose.
ItemReminderTriggered | Raised when the reminder for an item is triggered.
ItemStartTimeChanged | Raised when the StartTime property of an item in this Schedule has changed. The ItemTimeEventArgs.Time property provides the previous StartTime value of the item.
ItemVisualsChanged | Raised when the appearance of an item in the schedule has changed.
RecurrenceReset | Raised when the recurrence pattern associated with an item has been reset, causing all associated exception items to be lost.
SerializeTag | Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.
TaskReminderTriggered | Raised when the reminder for a task is triggered.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Changed Event

Schedule.Changed Event

Raised when items are added or removed from the schedule or when the schedule is loaded.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler Changed
Visual Basic

Public Event Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.DeserializeTag Event

Schedule.DeserializeTag Event

Raised during XML deserialization to enable users to perform custom deserialization of the tag values of items and resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<SerializeTagEventArgs> DeserializeTag
Visual Basic

Public Event DeserializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

DeserializeTag event handlers receive an argument of type SerializeTagEventArgs.

Remarks

This event is being raised during the deserialization of item and resource tag values from a XML document. If the event is not handled the system will try to deserialize the tags as an arbitrary objects.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ExceptionCreated Event

Schedule.ExceptionCreated Event

Raised when a recurrence exception item is created.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemEventArgs> ExceptionCreated
Visual Basic

Public Event ExceptionCreated As EventHandler(Of ItemEventArgs)

Event Data

ExceptionCreated event handlers receive an argument of type ItemEventArgs.

Remarks

An exception is created if a user drags an occurrence of a recurring event thus changing its time, or changes its text.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RecurrenceException Class


MindFusion.Scheduling.Schedule.InstantiateItem Event

Schedule.InstantiateItem Event

Raised when deserializing a custom item whose type has not been registered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<InstantiateItemEventArgs> InstantiateItem
Visual Basic

Public Event InstantiateItem As EventHandler(Of InstantiateItemEventArgs)

Event Data

InstantiateItem event handlers receive an argument of type InstantiateItemEventArgs.

Remarks

This event is being raised during deserialization for all custom items whose types have not been previously registered within the system through a call to RegisterItemClass. The event provides an alternative way for instantiating item of custom types.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.InstantiateResource Event

Schedule.InstantiateResource Event

Raised when deserializing a custom resource whose type has not been registered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<InstantiateResourceEventArgs> InstantiateResource
Visual Basic

Public Event InstantiateResource As EventHandler(Of InstantiateResourceEventArgs)

Event Data

InstantiateResource event handlers receive an argument of type InstantiateResourceEventArgs.

Remarks

This event is being raised during deserialization for all custom resources whose types have not been previously registered within the system through a call to RegisterResourceClass. The event provides an alternative way for instantiating resources of custom types.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemEndTimeChanged Event

Schedule.ItemEndTimeChanged Event

Raised when the EndTime property of an item in this Schedule has changed. The ItemTimeEventArgs.Time property provides the previous EndTime value of the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemTimeEventArgs> ItemEndTimeChanged
Visual Basic

Public Event ItemEndTimeChanged As EventHandler(Of ItemTimeEventArgs)

Event Data

ItemEndTimeChanged event handlers receive an argument of type ItemTimeEventArgs.

Remarks

The ItemTimeEventArgs.Time property provides the previous EndTime value of the item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemEndTimeTriggered Event

Schedule.ItemEndTimeTriggered Event

Raised when the reminder for an item is triggered, but taking into consideration the item's end time for the purpose.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemEventArgs> ItemEndTimeTriggered
Visual Basic

Public Event ItemEndTimeTriggered As EventHandler(Of ItemEventArgs)

Event Data

ItemEndTimeTriggered event handlers receive an argument of type ItemEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemReminderTriggered Event

Schedule.ItemReminderTriggered Event

Raised when the reminder for an item is triggered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemEventArgs> ItemReminderTriggered
Visual Basic

Public Event ItemReminderTriggered As EventHandler(Of ItemEventArgs)

Event Data

ItemReminderTriggered event handlers receive an argument of type ItemEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemStartTimeChanged Event

Schedule.ItemStartTimeChanged Event

Raised when the StartTime property of an item in this Schedule has changed. The ItemTimeEventArgs.Time property provides the previous StartTime value of the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemTimeEventArgs> ItemStartTimeChanged
Visual Basic

Public Event ItemStartTimeChanged As EventHandler(Of ItemTimeEventArgs)

Event Data

ItemStartTimeChanged event handlers receive an argument of type ItemTimeEventArgs.

Remarks

The ItemTimeEventArgs.Time property provides the previous StartTime value of the item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemVisualsChanged Event

Schedule.ItemVisualsChanged Event

Raised when the appearance of an item in the schedule has changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemEventArgs> ItemVisualsChanged
Visual Basic

Public Event ItemVisualsChanged As EventHandler(Of ItemEventArgs)

Event Data

ItemVisualsChanged event handlers receive an argument of type ItemEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.RecurrenceReset Event

Schedule.RecurrenceReset Event

Raised when the recurrence pattern associated with an item has been reset, causing all associated exception items to be lost.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemEventArgs> RecurrenceReset
Visual Basic

Public Event RecurrenceReset As EventHandler(Of ItemEventArgs)

Event Data

RecurrenceReset event handlers receive an argument of type ItemEventArgs.

Remarks

The recurrence is reset when the value of any of the properties that define it is changed. The recurrence is also reset when it is associated to or dissociated from an item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SerializeTag Event

Schedule.SerializeTag Event

Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<SerializeTagEventArgs> SerializeTag
Visual Basic

Public Event SerializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

SerializeTag event handlers receive an argument of type SerializeTagEventArgs.

Remarks

This event is being raised during the serialization of item and resource tag values in a XML document. If the event is not handled the system will try to serialize the tags as an arbitrary objects.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.TaskReminderTriggered Event

Schedule.TaskReminderTriggered Event

Raised when the reminder for a task is triggered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<TaskEventArgs> TaskReminderTriggered
Visual Basic

Public Event TaskReminderTriggered As EventHandler(Of TaskEventArgs)

Event Data

TaskReminderTriggered event handlers receive an argument of type TaskEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Class

SerializationContext Class

This class contains information required to serialize a Schedule element to and from a binary stream or XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class SerializationContext
Visual Basic

Public NotInheritable Class SerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.SerializationContext
MindFusion.Scheduling.BinarySerializationContext
MindFusion.Scheduling.XmlSerializationContext

See Also

SerializationContext Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Members

SerializationContext Members
Constructors Properties Events

This class contains information required to serialize a Schedule element to and from a binary stream or XML document.

The following tables list the members exposed by the SerializationContext type.

Public Constructors

Name | Description
SerializationContext | Initializes a new instance of the SerializationContext class.

Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded.
Schedule | Gets a reference to the schedule currently being serialized or deserialized.

Public Events

Name | Description
Completed | Raised when the serialization or deserialization has completed successfully.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Constructor

SerializationContext Constructor

Initializes a new instance of the SerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public SerializationContext (
Schedule schedule
)
Visual Basic

Public Sub SerializationContext ( _
schedule As Schedule _
)

Parameters

schedule

An instance of the Schedule class representing the schedule to associate with.

Remarks

Generally, you do not have to instantiate from SerializationContext explicitly unless you want to serialize only particular elements and not the entire schedule.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Properties

SerializationContext Properties

Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded.
Schedule | Gets a reference to the schedule currently being serialized or deserialized.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext.FileVersion Property

SerializationContext.FileVersion Property

Gets the format revision number of the file being loaded.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int FileVersion { get; }
Visual Basic

Public ReadOnly Property FileVersion As Integer

Property Value

An integer value identifying the schedule file format revision number.

Remarks

This revision number specifies the format of the schedule binary and XML files, but not of distinct item classes. If using custom item classes, specify their format revision number when registering them with the schedule via the RegisterItemClass method.

See Also

SerializationContext Members
SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext.Schedule Property

SerializationContext.Schedule Property

Gets a reference to the schedule currently being serialized or deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Schedule Schedule { get; }
Visual Basic

Public ReadOnly Property Schedule As Schedule

Property Value

An instance of the Schedule class.

See Also

SerializationContext Members
SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Events

SerializationContext Events

Public Events

Name | Description
Completed | Raised when the serialization or deserialization has completed successfully.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext.Completed Event

SerializationContext.Completed Event

Raised when the serialization or deserialization has completed successfully.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler Completed
Visual Basic

Public Event Completed As EventHandler

Event Data

Completed event handlers receive an argument of type EventArgs.

Remarks

You can use this event in your custom items to deserialize references to other Item and/or Resource objects.

Example

The following example demonstrates a technique for loading references to Item objects when deserializing a custom item.

C#

/// <summary>
/// Custom appointment class.
/// </summary>
public class MyItem : Appointment
{
/// <summary>
/// Initializes a new instance of the MyItem class.
/// </summary>
public MyItem()
{
referencedItems = new List<Item>();
itemIds = new List<string>();
}

/// <summary>
/// Appointment.SaveTo override.
/// </summary>
public override void SaveTo(BinaryWriter writer, BinarySerializationContext context)
{
base.SaveTo(writer, context);

// Write the id's of the referenced items
context.WriteInt(referencedItems.Count, writer);
foreach (Item item in referencedItems)
context.WriteString(item.Id, writer);
}

/// <summary>
/// Appointment.LoadFrom override.
/// </summary>
public override void LoadFrom(BinaryReader reader, BinarySerializationContext context)
{
base.LoadFrom(reader, context);

// Read the id's of the referenced items. We will obtain the actual references
// after the deserialization has been completed, because the items might not
// be available at this time
int count = context.ReadInt(reader);
itemIds = new List<string>();
for (int i = 0; i < count; i++)
itemIds.Add(context.ReadString(reader));

// Register an event handler
context.Completed += new EventHandler(OnLoadCompleted);
}

/// <summary>
/// Handles the Completed event on the SerializationContext object.
/// </summary>
private void OnLoadCompleted(object sender, EventArgs e)
{
SerializationContext context = sender as SerializationContext;

referencedItems.Clear();
foreach (string id in itemIds)
{
if (context.Schedule.Items.Contains(id))
referencedItems.Add(context.Schedule.Items[id]);
}

itemIds.Clear();

// Unregister the event handler
context.Completed -= new EventHandler(OnLoadCompleted);
}

/// <summary>
/// A list with the item references.
/// </summary>
private List<Item> referencedItems;

/// <summary>
/// A temporary list holding the IDs of the referenced items during deserialization.
/// </summary>
private List<string> itemIds;
}
Visual Basic

''' <summary>
''' Custom appointment class.
''' </summary>
Public Class MyItem
Inherits Appointment

''' <summary>
''' Initializes a new instance of the MyItem class.
''' </summary>
Public Sub New()

referencedItems = New List(Of Item)()
itemIds = New List(Of String)()

End Sub

''' <summary>
''' Appointment.SaveTo override.
''' </summary>
Public Overrides Sub SaveTo(ByVal writer As BinaryWriter, ByVal context As BinarySerializationContext)

MyBase.SaveTo(writer, context)

' Write the id's of the referenced items
context.WriteInt(referencedItems.Count, writer)
For Each item As Item in referencedItems
context.WriteString(item.Id, writer)
Next item

End Sub

''' <summary>
''' Appointment.LoadFrom override.
''' </summary>
Public Overrides Sub LoadFrom(ByVal reader As BinaryReader, ByVal context As BinarySerializationContext)

MyBase.LoadFrom(reader, context)

' Read the id's of the referenced items. We will obtain the actual references
' after the deserialization has been completed, because the items might not
' be available at this time
Dim count As Integer = context.ReadInt(reader)
itemIds = new List(Of String)()
For i As Integer = 0 To count
itemIds.Add(context.ReadString(reader))
Next i

' Register an event handler
AddHandler context.Completed, New EventHandler(AddressOf Me.OnLoadCompleted)

End Sub

' <summary>
' Handles the Completed event on the SerializationContext object.
' </summary>
Private Sub OnLoadCompleted(ByVal sender As Object, ByVal e As EventArgs)

Dim context As SerializationContext = CType(sender, SerializationContext)

referencedItems.Clear()
For Each id As String In itemIds

If context.Schedule.Items.Contains(id) Then
referencedItems.Add(context.Schedule.Items(id))
End If

Next id

itemIds.Clear()

' Unregister the event handler
RemoveHandler context.Completed, New EventHandler(AddressOf Me.OnLoadCompleted)

End Sub

''' <summary>
''' A list with the item references.
''' </summary>
Private referencedItems As List(Of Item)

''' <summary>
''' A temporary list holding the IDs of the referenced items during deserialization.
''' </summary>
Private itemIds As List(Of String)

End Class

See Also

SerializationContext Members
SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs Class

SerializeTagEventArgs Class

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class SerializeTagEventArgs : EventArgs
Visual Basic

Public Class SerializeTagEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.SerializeTagEventArgs

See Also

SerializeTagEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs Members

SerializeTagEventArgs Members
Properties

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

The following tables list the members exposed by the SerializeTagEventArgs type.

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the Item or Resource whose Tag is being serialized/deserialized.
Representation | Gets or sets the XmlElement representing the root element in the XML tree of the tag object being serialized/deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs Properties

SerializeTagEventArgs Properties

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the Item or Resource whose Tag is being serialized/deserialized.
Representation | Gets or sets the XmlElement representing the root element in the XML tree of the tag object being serialized/deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Context Property

SerializeTagEventArgs.Context Property

Gets a context object that can help you write and read various values.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlSerializationContext Context { get; }
Visual Basic

Public ReadOnly Property Context As XmlSerializationContext

Property Value

An instance of the XmlSerializationContext class.

Remarks

It is recommended to operate with the underlying XML document by calling the methods of this object. See the example section below for a demonstration on how to use this object.

Example

The following example demonstrates how to use the Context object in order to write and read complex tag values in the XML document.

C#

class MyTag
{
public MyTag(int intValue, string stringValue)
{
IntValue = intValue;
StringValue = stringValue;
}

public int IntValue;
public string StringValue;
}

// ...

private void OnSerializeTag(object sender, SerializeTagEventArgs e)
{
if (e.Tag is MyTag)
{
e.Handled = true;
e.Context.WriteBool(true, "mytag", e.Representation);

MyTag tag = e.Tag as MyTag;
e.Context.WriteInt(tag.IntValue, "intValue", e.Representation);
e.Context.WriteString(tag.StringValue, "stringValue", e.Representation);
}
}

private void OnDeserializeTag(object sender, SerializeTagEventArgs e)
{
if (e.Context.ReadBool("mytag", e.Representation, false))
{
e.Handled = true;

int intValue = e.Context.ReadInt("intValue", e.Representation);
string stringValue = e.Context.ReadString("stringValue", e.Representation);

e.Tag = new MyTag(intValue, stringValue);
}
}
Visual Basic

Class MyTag

Public Sub New(ByVal intValue As Integer, ByVal stringValue As String)

IntValue = intValue;
StringValue = stringValue;

End Sub

Public IntValue As Integer
Public StringValue As String

End Class

Private Sub OnSerializeTag(ByVal sender As Object, ByVal e As SerializeTagEventArgs)

If TypeOf e.Tag Is MyTag Then

e.Handled = True
e.Context.WriteBool(True, "mytag", e.Representation)

Dim tag As MyTag = CType(e.Tag, MyTag)
e.Context.WriteInt(tag.IntValue, "intValue", e.Representation)
e.Context.WriteString(tag.StringValue, "stringValue", e.Representation)

End If

End Sub

Private Sub OnDeserializeTag(ByVal sender As Object, ByVal e As SerializeTagEventArgs)

If e.Context.ReadBool("mytag", e.Representation, False) Then

e.Handled = True

Dim intValue As Integer = e.Context.ReadInt("intValue", e.Representation)
Dim stringValue As String = e.Context.ReadString("stringValue", e.Representation)

e.Tag = New MyTag(intValue, stringValue)

End If

End Sub

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Handled Property

SerializeTagEventArgs.Handled Property

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Handled { get; set; }
Visual Basic

Public Property Handled As Boolean

Property Value

true to indicate that the system should not attempt to serialize or deserialize the tag; otherwise, false.

Remarks

Always set this flag to true if you perform custom tag serialization.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Object Property

SerializeTagEventArgs.Object Property

Gets the Item or Resource whose Tag is being serialized/deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Object Object { get; }
Visual Basic

Public ReadOnly Property Object As Object

Property Value

A reference to an Item or Resource class.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Representation Property

SerializeTagEventArgs.Representation Property

Gets or sets the XmlElement representing the root element in the XML tree of the tag object being serialized/deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement Representation { get; set; }
Visual Basic

Public Property Representation As XmlElement

Property Value

An instance of the .NET XmlElement class representing the node in the XML document, containing the tag representation.

Remarks

When serializing tags use this XML element as a root of the tag representation by adding child elements to it. When deserializing the tag use this XML element as a root of the tag representation by reading child elements from it.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Tag Property

SerializeTagEventArgs.Tag Property

Gets or sets the tag object being serialized/deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Object Tag { get; set; }
Visual Basic

Public Property Tag As Object

Property Value

An object representing the tag value being serialized or deserialized.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ShadowStyle Enumeration

ShadowStyle Enumeration

Specifies what type of shadow effect to apply to a calendar UI element.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum ShadowStyle
Visual Basic

Public Enumeration ShadowStyle

Members

Member name | Description
Fading | Display a fading shadow.
None | Do not display a shadow.
Solid | Display a solid shadow.
Unspecified | The shadow style is not specified.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Class

Style Class

Specifies the appearance of calendar elements.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class Style : ICloneable, ISerializable
Visual Basic

Public Class Style
Implements ICloneable, ISerializable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Style

See Also

Style Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Members

Style Members
Constructors Properties Methods Events

Specifies the appearance of calendar elements.

The following tables list the members exposed by the Style type.

Public Constructors

Name | Description
Style | Overloaded.

Public Properties

Name | Description
BorderBottomColor | Gets or sets the color used to paint the bottom border of a calendar element.
BorderBottomWidth | Gets or sets the width in pixels of the bottom border of an element.
BorderLeftColor | Gets or sets the color used to paint the left border of a calendar element.
BorderLeftWidth | Gets or sets the width in pixels of the left border of an element.
BorderRightColor | Gets or sets the color used to paint the right border of a calendar element.
BorderRightWidth | Gets or sets the width in pixels of the right border of an element.
BorderTopColor | Gets or sets the color used to paint the top border of a calendar element.
BorderTopWidth | Gets or sets the width in pixels of the top border of an element.
Brush | Gets or sets the brush used to fill the interior of elements.
Definition | Gets the string representation of this Style.
FillColor | Gets or sets the color used to fill calendar elements.
Font | Gets or sets the font used to display an element's text.
HeaderBorderBottomColor | Gets or sets the color used to paint the bottom border of an element's header.
HeaderBorderBottomWidth | Gets or sets the width in pixels of the bottom border of an element's header.
HeaderBorderLeftColor | Gets or sets the color used to paint the left border of an element's header.
HeaderBorderLeftWidth | Gets or sets the width in pixels of the left border of an element's header.
HeaderBorderRightColor | Gets or sets the color used to paint the right border of an element's header.
HeaderBorderRightWidth | Gets or sets the width in pixels of the right border of an element's header.
HeaderBorderTopColor | Gets or sets the color used to paint the top border of an element's header.
HeaderBorderTopWidth | Gets or sets the width in pixels of the top border of an element's header.
HeaderBrush | Gets or sets the brush used to fill the interior of an element's header.
HeaderFont | Gets or sets the font used to paint the text of an element's header.
HeaderTextAlignment | Gets or sets the alignment of the headers' text.
HeaderTextBottomMargin | Gets or sets the bottom header text margin.
HeaderTextColor | Gets or sets the color used to paint the text of an element's header.
HeaderTextLeftMargin | Gets or sets the left header text margin.
HeaderTextRightMargin | Gets or sets the right header text margin.
HeaderTextShadowColor | Gets or sets the color of the shadow cast by the header text.
HeaderTextShadowOffset | Gets or sets the distance of the shadow from the header text that casts it.
HeaderTextShadowStyle | Gets or sets the type of the shadow cast by the header text.
HeaderTextTopMargin | Gets or sets the top header text margin.
Image | Gets or sets an image associated with this style.
ImageAlignment | Gets or sets the image alignment to be used when rendering the image assigned to this style.
ImageIndex | Gets or sets the index of the image from the calendar image list assigned to this style.
ImageTransparency | Gets or sets the transparency of the image associated with this style.
LineColor | Gets or sets the color used to paint various lines that are not part of element borders.
TextAlignment | Gets or sets the alignment of the text contents of a calendar element.
TextBottomMargin | Gets or sets the bottom text margin.
TextColor | Gets or sets the color used to paint an element's text.
TextLeftMargin | Gets or sets the left text margin.
TextRightMargin | Gets or sets the right text margin.
TextShadowColor | Gets or sets the color of the shadow cast by the text.
TextShadowOffset | Gets or sets the distance of the shadow from the text that casts it.
TextShadowStyle | Gets or sets the type of the shadow cast by the text.
TextTopMargin | Gets or sets the top text margin.

Public Methods

Name | Description
Clone | Creates an exact copy of this Style object.
Equals | Determines whether this style is equivalent to the specified style.
FromDefinition | Creates a new style from the specified definition.
GetHashCode | Returns the hash code for this Style instance.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the style.
Restore | Restores a Style object from a style string representation.
Store | Creates a string representation of the Style.

Protected Methods

Name | Description
OnChanged | Fires the Changed event.

Public Events

Name | Description
Changed | Raised when the style changes.

See Also

Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Constructor

Style Constructor

Overload List

Name | Description
Style () | Initializes a new empty instance of the Style class.
Style (String) | Initializes a new Style instance out of the specified string representation.

See Also

Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Constructor ()

Style Constructor ()
See Also

Initializes a new empty instance of the Style class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Style ()
Visual Basic

Public Sub New ()

See Also

Style Constructor Overload List
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Constructor (String)

Style Constructor (String)
See Also

Initializes a new Style instance out of the specified string representation.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

public Style (
string representation
)
Visual Basic

Public New ( _
representation As String _
)

Parameters

representation

Remarks

This constructor is for internal use only.

See Also

Style Constructor Overload List
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Methods

Style Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this Style object.
Equals | Determines whether this style is equivalent to the specified style.
FromDefinition | Creates a new style from the specified definition.
GetHashCode | Returns the hash code for this Style instance.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the style.
Restore | Restores a Style object from a style string representation.
Store | Creates a string representation of the Style.

Protected Methods

Name | Description
OnChanged | Fires the Changed event.

See Also

Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.Clone Method

Style.Clone Method

Creates an exact copy of this Style object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

The Style copy created by this method.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.Equals Method

Style.Equals Method

Determines whether this style is equivalent to the specified style.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override bool Equals (
Object obj
)
Visual Basic

Public Overrides Function Equals ( _
obj As Object _
) As Boolean

Parameters

obj
A Style object to compare with this one.

Return Value

true if the two styles are the same; otherwise, false.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.FromDefinition Method

Style.FromDefinition Method

Creates a new style from the specified definition.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public static Style FromDefinition (
string representation
)
Visual Basic

Public Shared Function FromDefinition ( _
representation As String _
) As Style

Parameters

representation

The string representation of the style.

Return Value

A new Style object corresponding to the specified representation.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.GetHashCode Method

Style.GetHashCode Method

Returns the hash code for this Style instance.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override int GetHashCode ()
Visual Basic

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for this object.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.GetObjectData Method

Style.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the style.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)
Visual Basic

Public Overridable Sub GetObjectData ( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info
The object that holds the serialized object data.
context
The contextual information about the source or destination.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.OnChanged Method

Style.OnChanged Method

Fires the Changed event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected void OnChanged (
EventArgs e
)
Visual Basic

Protected Sub OnChanged ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.Restore Method

Style.Restore Method

Restores a Style object from a style string representation.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

public void Restore (
string representation
)
Visual Basic

Public Sub Restore ( _
representation As String _
)

Parameters

representation
The string representation of the style.

Remarks

Restore the Style members from the string created by Store.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.Store Method

Style.Store Method

Creates a string representation of the Style.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

public string Store ()
Visual Basic

Public Function Store () As String

Return Value

A string containing the Style representation.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Properties

Style Properties

Public Properties

Name | Description
BorderBottomColor | Gets or sets the color used to paint the bottom border of a calendar element.
BorderBottomWidth | Gets or sets the width in pixels of the bottom border of an element.
BorderLeftColor | Gets or sets the color used to paint the left border of a calendar element.
BorderLeftWidth | Gets or sets the width in pixels of the left border of an element.
BorderRightColor | Gets or sets the color used to paint the right border of a calendar element.
BorderRightWidth | Gets or sets the width in pixels of the right border of an element.
BorderTopColor | Gets or sets the color used to paint the top border of a calendar element.
BorderTopWidth | Gets or sets the width in pixels of the top border of an element.
Brush | Gets or sets the brush used to fill the interior of elements.
Definition | Gets the string representation of this Style.
FillColor | Gets or sets the color used to fill calendar elements.
Font | Gets or sets the font used to display an element's text.
HeaderBorderBottomColor | Gets or sets the color used to paint the bottom border of an element's header.
HeaderBorderBottomWidth | Gets or sets the width in pixels of the bottom border of an element's header.
HeaderBorderLeftColor | Gets or sets the color used to paint the left border of an element's header.
HeaderBorderLeftWidth | Gets or sets the width in pixels of the left border of an element's header.
HeaderBorderRightColor | Gets or sets the color used to paint the right border of an element's header.
HeaderBorderRightWidth | Gets or sets the width in pixels of the right border of an element's header.
HeaderBorderTopColor | Gets or sets the color used to paint the top border of an element's header.
HeaderBorderTopWidth | Gets or sets the width in pixels of the top border of an element's header.
HeaderBrush | Gets or sets the brush used to fill the interior of an element's header.
HeaderFont | Gets or sets the font used to paint the text of an element's header.
HeaderTextAlignment | Gets or sets the alignment of the headers' text.
HeaderTextBottomMargin | Gets or sets the bottom header text margin.
HeaderTextColor | Gets or sets the color used to paint the text of an element's header.
HeaderTextLeftMargin | Gets or sets the left header text margin.
HeaderTextRightMargin | Gets or sets the right header text margin.
HeaderTextShadowColor | Gets or sets the color of the shadow cast by the header text.
HeaderTextShadowOffset | Gets or sets the distance of the shadow from the header text that casts it.
HeaderTextShadowStyle | Gets or sets the type of the shadow cast by the header text.
HeaderTextTopMargin | Gets or sets the top header text margin.
Image | Gets or sets an image associated with this style.
ImageAlignment | Gets or sets the image alignment to be used when rendering the image assigned to this style.
ImageIndex | Gets or sets the index of the image from the calendar image list assigned to this style.
ImageTransparency | Gets or sets the transparency of the image associated with this style.
LineColor | Gets or sets the color used to paint various lines that are not part of element borders.
TextAlignment | Gets or sets the alignment of the text contents of a calendar element.
TextBottomMargin | Gets or sets the bottom text margin.
TextColor | Gets or sets the color used to paint an element's text.
TextLeftMargin | Gets or sets the left text margin.
TextRightMargin | Gets or sets the right text margin.
TextShadowColor | Gets or sets the color of the shadow cast by the text.
TextShadowOffset | Gets or sets the distance of the shadow from the text that casts it.
TextShadowStyle | Gets or sets the type of the shadow cast by the text.
TextTopMargin | Gets or sets the top text margin.

See Also

Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.BorderBottomColor Property

Style.BorderBottomColor Property

Gets or sets the color used to paint the bottom border of a calendar element.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color BorderBottomColor { get; set; }
Visual Basic

Public Property BorderBottomColor As Color

Property Value

A .NET Color object specifying the color of the bottom border lines. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no bottom border or set the BorderBottomWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderBottomWidth Property


MindFusion.Scheduling.Style.BorderBottomWidth Property

Style.BorderBottomWidth Property

Gets or sets the width in pixels of the bottom border of an element.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int BorderBottomWidth { get; set; }
Visual Basic

Public Property BorderBottomWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the bottom border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderBottomColor Property


MindFusion.Scheduling.Style.BorderLeftColor Property

Style.BorderLeftColor Property

Gets or sets the color used to paint the left border of a calendar element.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color BorderLeftColor { get; set; }
Visual Basic

Public Property BorderLeftColor As Color

Property Value

A .NET Color object specifying the color left border lines. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no left border or set the BorderLeftWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderLeftWidth Property


MindFusion.Scheduling.Style.BorderLeftWidth Property

Style.BorderLeftWidth Property

Gets or sets the width in pixels of the left border of an element.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int BorderLeftWidth { get; set; }
Visual Basic

Public Property BorderLeftWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the left border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderLeftColor Property


MindFusion.Scheduling.Style.BorderRightColor Property

Style.BorderRightColor Property

Gets or sets the color used to paint the right border of a calendar element.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color BorderRightColor { get; set; }
Visual Basic

Public Property BorderRightColor As Color

Property Value

A .NET Color object specifying the color of the right border lines. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no right border or set the BorderRightWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderRightWidth Property


MindFusion.Scheduling.Style.BorderRightWidth Property

Style.BorderRightWidth Property

Gets or sets the width in pixels of the right border of an element.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int BorderRightWidth { get; set; }
Visual Basic

Public Property BorderRightWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the right border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderRightColor Property


MindFusion.Scheduling.Style.BorderTopColor Property

Style.BorderTopColor Property

Gets or sets the color used to paint the top border of a calendar element.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color BorderTopColor { get; set; }
Visual Basic

Public Property BorderTopColor As Color

Property Value

A .NET Color object specifying the color of the top border lines. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no top border or set the BorderTopWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderTopWidth Property


MindFusion.Scheduling.Style.BorderTopWidth Property

Style.BorderTopWidth Property

Gets or sets the width in pixels of the top border of an element.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int BorderTopWidth { get; set; }
Visual Basic

Public Property BorderTopWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the top border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderTopColor Property


MindFusion.Scheduling.Style.Brush Property

Style.Brush Property

Gets or sets the brush used to fill the interior of elements.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush Brush { get; set; }
Visual Basic

Public Property Brush As Brush

Property Value

A Brush instance used to fill the interior of calendar UI elements. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.Definition Property

Style.Definition Property

Gets the string representation of this Style.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string Definition { get; }
Visual Basic

Public ReadOnly Property Definition As String

Property Value

A string value, which represents the current style.

Remarks

The string representation can be used in the FromDefinition method to recreate the style later.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.FillColor Property

Style.FillColor Property

Gets or sets the color used to fill calendar elements.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color FillColor { get; set; }
Visual Basic

Public Property FillColor As Color

Property Value

A .NET Color object used to fill calendar elements. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
LineColor Property


MindFusion.Scheduling.Style.Font Property

Style.Font Property

Gets or sets the font used to display an element's text.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Font Font { get; set; }
Visual Basic

Public Property Font As Font

Property Value

A .NET Font object specifying the font of calendar elements' text. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextAlignment Property
TextColor Property


MindFusion.Scheduling.Style.HeaderBorderBottomColor Property

Style.HeaderBorderBottomColor Property

Gets or sets the color used to paint the bottom border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color HeaderBorderBottomColor { get; set; }
Visual Basic

Public Property HeaderBorderBottomColor As Color

Property Value

A .NET Color object specifying the color of the bottom side of the header's rectangle. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no border or set the HeaderBorderBottomWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderBottomWidth Property


MindFusion.Scheduling.Style.HeaderBorderBottomWidth Property

Style.HeaderBorderBottomWidth Property

Gets or sets the width in pixels of the bottom border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderBorderBottomWidth { get; set; }
Visual Basic

Public Property HeaderBorderBottomWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the bottom border of the header, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderBottomColor Property


MindFusion.Scheduling.Style.HeaderBorderLeftColor Property

Style.HeaderBorderLeftColor Property

Gets or sets the color used to paint the left border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color HeaderBorderLeftColor { get; set; }
Visual Basic

Public Property HeaderBorderLeftColor As Color

Property Value

A .NET Color object specifying the color of the left side of the header's rectangle. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no border or set the HeaderBorderLeftWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderLeftWidth Property


MindFusion.Scheduling.Style.HeaderBorderLeftWidth Property

Style.HeaderBorderLeftWidth Property

Gets or sets the width in pixels of the left border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderBorderLeftWidth { get; set; }
Visual Basic

Public Property HeaderBorderLeftWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the left border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderLeftColor Property


MindFusion.Scheduling.Style.HeaderBorderRightColor Property

Style.HeaderBorderRightColor Property

Gets or sets the color used to paint the right border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color HeaderBorderRightColor { get; set; }
Visual Basic

Public Property HeaderBorderRightColor As Color

Property Value

A .NET Color object specifying the color of the right side of the header's rectangle. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no border or set the HeaderBorderRightWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderRightWidth Property


MindFusion.Scheduling.Style.HeaderBorderRightWidth Property

Style.HeaderBorderRightWidth Property

Gets or sets the width in pixels of the right border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderBorderRightWidth { get; set; }
Visual Basic

Public Property HeaderBorderRightWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the right border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderRightColor Property


MindFusion.Scheduling.Style.HeaderBorderTopColor Property

Style.HeaderBorderTopColor Property

Gets or sets the color used to paint the top border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color HeaderBorderTopColor { get; set; }
Visual Basic

Public Property HeaderBorderTopColor As Color

Property Value

A .NET Color object specifying the color of the top side of the header's rectangle. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no border or set the HeaderBorderTopWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderTopWidth Property


MindFusion.Scheduling.Style.HeaderBorderTopWidth Property

Style.HeaderBorderTopWidth Property

Gets or sets the width in pixels of the top border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderBorderTopWidth { get; set; }
Visual Basic

Public Property HeaderBorderTopWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the top border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderTopColor Property


MindFusion.Scheduling.Style.HeaderBrush Property

Style.HeaderBrush Property

Gets or sets the brush used to fill the interior of an element's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush HeaderBrush { get; set; }
Visual Basic

Public Property HeaderBrush As Brush

Property Value

A Brush object used to fill header interior. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.HeaderFont Property

Style.HeaderFont Property

Gets or sets the font used to paint the text of an element's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Font HeaderFont { get; set; }
Visual Basic

Public Property HeaderFont As Font

Property Value

A .NET Font object specifying the font of text displayed in headers. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextAlignment Property
HeaderTextColor Property


MindFusion.Scheduling.Style.HeaderTextAlignment Property

Style.HeaderTextAlignment Property

Gets or sets the alignment of the headers' text.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public TextAlignment HeaderTextAlignment { get; set; }
Visual Basic

Public Property HeaderTextAlignment As TextAlignment

Property Value

A member of the TextAlignment enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderFont Property
HeaderTextColor Property


MindFusion.Scheduling.Style.HeaderTextBottomMargin Property

Style.HeaderTextBottomMargin Property

Gets or sets the bottom header text margin.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderTextBottomMargin { get; set; }
Visual Basic

Public Property HeaderTextBottomMargin As Integer

Property Value

A non-negative integer specifying the bottom margin of header texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextLeftMargin Property
HeaderTextRightMargin Property
HeaderTextTopMargin Property


MindFusion.Scheduling.Style.HeaderTextColor Property

Style.HeaderTextColor Property

Gets or sets the color used to paint the text of an element's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color HeaderTextColor { get; set; }
Visual Basic

Public Property HeaderTextColor As Color

Property Value

A .NET Color object specifying the color of text displayed in headers. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderFont Property
HeaderTextAlignment Property


MindFusion.Scheduling.Style.HeaderTextLeftMargin Property

Style.HeaderTextLeftMargin Property

Gets or sets the left header text margin.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderTextLeftMargin { get; set; }
Visual Basic

Public Property HeaderTextLeftMargin As Integer

Property Value

A non-negative integer specifying the left margin of header texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextBottomMargin Property
HeaderTextRightMargin Property
HeaderTextTopMargin Property


MindFusion.Scheduling.Style.HeaderTextRightMargin Property

Style.HeaderTextRightMargin Property

Gets or sets the right header text margin.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderTextRightMargin { get; set; }
Visual Basic

Public Property HeaderTextRightMargin As Integer

Property Value

A non-negative integer specifying the right margin of header texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextBottomMargin Property
HeaderTextLeftMargin Property
HeaderTextTopMargin Property


MindFusion.Scheduling.Style.HeaderTextShadowColor Property

Style.HeaderTextShadowColor Property

Gets or sets the color of the shadow cast by the header text.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color HeaderTextShadowColor { get; set; }
Visual Basic

Public Property HeaderTextShadowColor As Color

Property Value

A .NET Color object specifying the color of the header text shadows drawn with this style. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextShadowOffset Property
HeaderTextShadowStyle Property
TextShadowColor Property


MindFusion.Scheduling.Style.HeaderTextShadowOffset Property

Style.HeaderTextShadowOffset Property

Gets or sets the distance of the shadow from the header text that casts it.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderTextShadowOffset { get; set; }
Visual Basic

Public Property HeaderTextShadowOffset As Integer

Property Value

An integer value specifying the distance between the drawn shadow and the header text that casts it, expressed in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextShadowColor Property
HeaderTextShadowStyle Property
TextShadowOffset Property


MindFusion.Scheduling.Style.HeaderTextShadowStyle Property

Style.HeaderTextShadowStyle Property

Gets or sets the type of the shadow cast by the header text.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ShadowStyle HeaderTextShadowStyle { get; set; }
Visual Basic

Public Property HeaderTextShadowStyle As ShadowStyle

Property Value

A member of the ShadowStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextShadowColor Property
HeaderTextShadowOffset Property
TextShadowStyle Property


MindFusion.Scheduling.Style.HeaderTextTopMargin Property

Style.HeaderTextTopMargin Property

Gets or sets the top header text margin.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderTextTopMargin { get; set; }
Visual Basic

Public Property HeaderTextTopMargin As Integer

Property Value

A non-negative integer specifying the top margin of header texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextBottomMargin Property
HeaderTextLeftMargin Property
HeaderTextRightMargin Property


MindFusion.Scheduling.Style.Image Property

Style.Image Property

Gets or sets an image associated with this style.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Image Image { get; set; }
Visual Basic

Public Property Image As Image

Property Value

A .NET Image object. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

This image takes precedence over the image associated with an item through an image list / image index pair.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
ImageAlignment Property
ImageIndex Property
ImageTransparency Property


MindFusion.Scheduling.Style.ImageAlignment Property

Style.ImageAlignment Property

Gets or sets the image alignment to be used when rendering the image assigned to this style.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ImageAlignment ImageAlignment { get; set; }
Visual Basic

Public Property ImageAlignment As ImageAlignment

Property Value

A member of the ImageAlignment enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
Image Property
ImageIndex Property
ImageTransparency Property


MindFusion.Scheduling.Style.ImageIndex Property

Style.ImageIndex Property

Gets or sets the index of the image from the calendar image list assigned to this style.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int ImageIndex { get; set; }
Visual Basic

Public Property ImageIndex As Integer

Property Value

An integer value specifying the image index. Assign -2 to this property to use the corresponding value from the current theme.

Remarks

If there is an Image assigned to this style, it takes precedence over the image identified by this index.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
Image Property
ImageAlignment Property
ImageTransparency Property


MindFusion.Scheduling.Style.ImageTransparency Property

Style.ImageTransparency Property

Gets or sets the transparency of the image associated with this style.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int ImageTransparency { get; set; }
Visual Basic

Public Property ImageTransparency As Integer

Property Value

An integer value specifying the image transparency. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

The accepted values range from 0 (fully transparent) to 255 (opaque).

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
Image Property
ImageIndex Property
ImageAlignment Property


MindFusion.Scheduling.Style.LineColor Property

Style.LineColor Property

Gets or sets the color used to paint various lines that are not part of element borders.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color LineColor { get; set; }
Visual Basic

Public Property LineColor As Color

Property Value

A .NET Color object specifying the color of lines. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
FillColor Property


MindFusion.Scheduling.Style.TextAlignment Property

Style.TextAlignment Property

Gets or sets the alignment of the text contents of a calendar element.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public TextAlignment TextAlignment { get; set; }
Visual Basic

Public Property TextAlignment As TextAlignment

Property Value

A member of the TextAlignment enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
Font Property
TextColor Property


MindFusion.Scheduling.Style.TextBottomMargin Property

Style.TextBottomMargin Property

Gets or sets the bottom text margin.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int TextBottomMargin { get; set; }
Visual Basic

Public Property TextBottomMargin As Integer

Property Value

A non-negative integer specifying the bottom margin of texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextLeftMargin Property
TextRightMargin Property
TextTopMargin Property


MindFusion.Scheduling.Style.TextColor Property

Style.TextColor Property

Gets or sets the color used to paint an element's text.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color TextColor { get; set; }
Visual Basic

Public Property TextColor As Color

Property Value

A .NET Color object specifying the text color. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
Font Property
TextAlignment Property


MindFusion.Scheduling.Style.TextLeftMargin Property

Style.TextLeftMargin Property

Gets or sets the left text margin.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int TextLeftMargin { get; set; }
Visual Basic

Public Property TextLeftMargin As Integer

Property Value

A non-negative integer specifying the left margin of texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextBottomMargin Property
TextRightMargin Property
TextTopMargin Property


MindFusion.Scheduling.Style.TextRightMargin Property

Style.TextRightMargin Property

Gets or sets the right text margin.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int TextRightMargin { get; set; }
Visual Basic

Public Property TextRightMargin As Integer

Property Value

A non-negative integer specifying the right margin of texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextBottomMargin Property
TextLeftMargin Property
TextTopMargin Property


MindFusion.Scheduling.Style.TextShadowColor Property

Style.TextShadowColor Property

Gets or sets the color of the shadow cast by the text.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color TextShadowColor { get; set; }
Visual Basic

Public Property TextShadowColor As Color

Property Value

A .NET Color object specifying the color of the text shadows drawn with this style. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextShadowOffset Property
TextShadowStyle Property
HeaderTextShadowColor Property


MindFusion.Scheduling.Style.TextShadowOffset Property

Style.TextShadowOffset Property

Gets or sets the distance of the shadow from the text that casts it.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int TextShadowOffset { get; set; }
Visual Basic

Public Property TextShadowOffset As Integer

Property Value

An integer value specifying the distance between the drawn shadow and the text that casts it, expressed in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextShadowColor Property
TextShadowStyle Property
HeaderTextShadowOffset Property


MindFusion.Scheduling.Style.TextShadowStyle Property

Style.TextShadowStyle Property

Gets or sets the type of the shadow cast by the text.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ShadowStyle TextShadowStyle { get; set; }
Visual Basic

Public Property TextShadowStyle As ShadowStyle

Property Value

A member of the ShadowStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextShadowColor Property
TextShadowOffset Property
HeaderTextShadowStyle Property


MindFusion.Scheduling.Style.TextTopMargin Property

Style.TextTopMargin Property

Gets or sets the top text margin.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int TextTopMargin { get; set; }
Visual Basic

Public Property TextTopMargin As Integer

Property Value

A non-negative integer specifying the top margin of texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextBottomMargin Property
TextLeftMargin Property
TextRightMargin Property


MindFusion.Scheduling.Style Events

Style Events

Public Events

Name | Description
Changed | Raised when the style changes.

See Also

Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.Changed Event

Style.Changed Event

Raised when the style changes.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler Changed
Visual Basic

Public Event Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Class

Task Class

Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class Task : Resource
Visual Basic

Public Class Task
Inherits Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Task

See Also

Task Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Members

Task Members
Constructors Properties Methods

Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.

The following tables list the members exposed by the Task type.

Public Constructors

Name | Description
Task | Initializes a new instance of the Task class.

Public Properties

Name | Description
ActualCost | Gets or sets the actual cost of this task.
ActualDuration | Gets or sets the task actual duration measured in minutes.
ActualEnd | Gets or sets the task's actual completion date.
ActualStart | Gets or sets the task's actual start date.
Details | Gets or sets the detailed description of this task.
DueDate | Gets or sets the task's due date.
EstimatedCost | Gets or sets the estimated cost of this task.
EstimatedDuration | Gets or sets the estimated duration of this task.
ImageIndex | Gets or sets the index of the image associated with this task.
Priority | Gets or sets the task priority.
Progress | Gets or sets the task progress measured in percents.
Reminder | Gets or sets the reminder for this task.
StartDate | Gets or sets the task's start date.
Status | Gets or sets the status of this task.
Subject | Gets or sets the subject of this task.

Public Methods

Name | Description
LoadFrom | Overloaded. Loads task data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the task data to a binary stream or an XML document.

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Constructor

Task Constructor

Initializes a new instance of the Task class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Task ()
Visual Basic

Public Sub New ()

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Methods

Task Methods

Public Methods

Name | Description
LoadFrom | Overloaded. Loads task data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the task data to a binary stream or an XML document.

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.LoadFrom Method

Task.LoadFrom Method

Loads task data from a binary stream or an XML document.

Overload List

Name | Description
Task.LoadFrom (BinaryReader, BinarySerializationContext) | Loads task data from a binary stream.
Task.LoadFrom (XmlElement, XmlSerializationContext) | Loads task data from an XML document.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.LoadFrom Method (BinaryReader, BinarySerializationContext)

Task.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also

Loads task data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Allows reading primitive data types from the binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

This method loads the task properties from a binary stream where they were previously saved by SaveTo.

See Also

LoadFrom Method Overload List
Task Members
Task Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Task.LoadFrom Method (XmlElement, XmlSerializationContext)

Task.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads task data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method loads the task properties from an XML document where they were previously saved by SaveTo.

See Also

LoadFrom Method Overload List
Task Members
Task Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Task.SaveTo Method

Task.SaveTo Method

Saves the task data to a binary stream or an XML document.

Overload List

Name | Description
Task.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the task data to a binary stream.
Task.SaveTo (XmlElement, XmlSerializationContext) | Saves the task data to an XML document.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.SaveTo Method (BinaryWriter, BinarySerializationContext)

Task.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also

Saves the task data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Allows writing primitive data types to the binary stream.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

This method saves the task properties as elements in an XML document. Later they can be restored via the LoadFrom method.

See Also

SaveTo Method Overload List
Task Members
Task Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Task.SaveTo Method (XmlElement, XmlSerializationContext)

Task.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the task data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the task properties as elements in an XML document. Later they can be restored via the LoadFrom method.

See Also

SaveTo Method Overload List
Task Members
Task Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Task Properties

Task Properties

Public Properties

Name | Description
ActualCost | Gets or sets the actual cost of this task.
ActualDuration | Gets or sets the task actual duration measured in minutes.
ActualEnd | Gets or sets the task's actual completion date.
ActualStart | Gets or sets the task's actual start date.
Details | Gets or sets the detailed description of this task.
DueDate | Gets or sets the task's due date.
EstimatedCost | Gets or sets the estimated cost of this task.
EstimatedDuration | Gets or sets the estimated duration of this task.
ImageIndex | Gets or sets the index of the image associated with this task.
Priority | Gets or sets the task priority.
Progress | Gets or sets the task progress measured in percents.
Reminder | Gets or sets the reminder for this task.
StartDate | Gets or sets the task's start date.
Status | Gets or sets the status of this task.
Subject | Gets or sets the subject of this task.

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualCost Property

Task.ActualCost Property

Gets or sets the actual cost of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public float ActualCost { get; set; }
Visual Basic

Public Property ActualCost As Single

Property Value

A float value specifying the task's actual cost. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualDuration Property

Task.ActualDuration Property

Gets or sets the task actual duration measured in minutes.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int ActualDuration { get; set; }
Visual Basic

Public Property ActualDuration As Integer

Property Value

An integer value specifying the task's duration. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualEnd Property

Task.ActualEnd Property

Gets or sets the task's actual completion date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime ActualEnd { get; set; }
Visual Basic

Public Property ActualEnd As DateTime

Property Value

A .NET DateTime object specifying the task's actual end date. The default is DateTime.MaxValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
ActualStart Property


MindFusion.Scheduling.Task.ActualStart Property

Task.ActualStart Property

Gets or sets the task's actual start date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime ActualStart { get; set; }
Visual Basic

Public Property ActualStart As DateTime

Property Value

A .NET DateTime object specifying the task's actual start date. The default is DateTime.MinValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
ActualEnd Property


MindFusion.Scheduling.Task.Details Property

Task.Details Property

Gets or sets the detailed description of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string Details { get; set; }
Visual Basic

Public Property Details As String

Property Value

A string containing the task's details text. The default is an empty string.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.DueDate Property

Task.DueDate Property

Gets or sets the task's due date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime DueDate { get; set; }
Visual Basic

Public Property DueDate As DateTime

Property Value

A .NET DateTime object specifying the task's sue date. The default is DateTime.MaxValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
StartDate Property


MindFusion.Scheduling.Task.EstimatedCost Property

Task.EstimatedCost Property

Gets or sets the estimated cost of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public float EstimatedCost { get; set; }
Visual Basic

Public Property EstimatedCost As Single

Property Value

A float value specifying the task's estimated cost. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.EstimatedDuration Property

Task.EstimatedDuration Property

Gets or sets the estimated duration of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int EstimatedDuration { get; set; }
Visual Basic

Public Property EstimatedDuration As Integer

Property Value

An integer value specifying the task's scheduled duration. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ImageIndex Property

Task.ImageIndex Property

Gets or sets the index of the image associated with this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int ImageIndex { get; set; }
Visual Basic

Public Property ImageIndex As Integer

Property Value

An integer value specifying the index of the task image within the calendar's ImageList. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Priority Property

Task.Priority Property

Gets or sets the task priority.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public TaskPriority Priority { get; set; }
Visual Basic

Public Property Priority As TaskPriority

Property Value

A member of the TaskPriority enumeration. The default is Normal.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Progress Property

Task.Progress Property

Gets or sets the task progress measured in percents.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public float Progress { get; set; }
Visual Basic

Public Property Progress As Single

Property Value

A float value specifying the progress made on this task. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Reminder Property

Task.Reminder Property

Gets or sets the reminder for this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Reminder Reminder { get; set; }
Visual Basic

Public Property Reminder As Reminder

Property Value

A Reminder instance specifying when the task should be reminded of. The default is null (Nothing in Visual Basic).

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.StartDate Property

Task.StartDate Property

Gets or sets the task's start date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime StartDate { get; set; }
Visual Basic

Public Property StartDate As DateTime

Property Value

A .NET DateTime object specifying the task's scheduled start time. The default is DateTime.MinValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
DueDate Property


MindFusion.Scheduling.Task.Status Property

Task.Status Property

Gets or sets the status of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public TaskStatus Status { get; set; }
Visual Basic

Public Property Status As TaskStatus

Property Value

A member of the TaskStatus enumeration. The default is NotStarted.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Subject Property

Task.Subject Property

Gets or sets the subject of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string Subject { get; set; }
Visual Basic

Public Property Subject As String

Property Value

A string containing the task subject text. The default is an empty string.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection Class

TaskCollection Class

Represents a strongly-typed collection of Task objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class TaskCollection : CollectionBase
Visual Basic

Public NotInheritable Class TaskCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.TaskCollection

See Also

TaskCollection Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection Members

TaskCollection Members
Constructors Properties Methods Events

Represents a strongly-typed collection of Task objects.

The following tables list the members exposed by the TaskCollection type.

Public Constructors

Name | Description
TaskCollection | Initializes a new instance of the TaskCollection class.

Public Properties

Name | Description
Item | Gets a Task object from the collection given its zero-based index or identifier.

Public Methods

Name | Description
Add | Adds the specified task to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified task.
Insert | Inserts a location object into the collection at the specified index.
Remove | Removes the first occurrence of the specified Task object from this collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection Constructor

TaskCollection Constructor

Initializes a new instance of the TaskCollection class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public TaskCollection ()
Visual Basic

Public Sub New ()

See Also

TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection Methods

TaskCollection Methods

Public Methods

Name | Description
Add | Adds the specified task to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified task.
Insert | Inserts a location object into the collection at the specified index.
Remove | Removes the first occurrence of the specified Task object from this collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.

See Also

TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Add Method

TaskCollection.Add Method

Adds the specified task to this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Add (
Task task
)
Visual Basic

Public Sub Add ( _
task As Task _
)

Parameters

task
An instance of the Task class to be added to the collection.

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace
Insert Method


MindFusion.Scheduling.TaskCollection.Clear Method

TaskCollection.Clear Method

Removes all elements from the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Contains Method

TaskCollection.Contains Method

Determines whether this collection contains the specified task.

Overload List

Name | Description
TaskCollection.Contains (String) | Determines whether this collection contains a task identified by the specified string.
TaskCollection.Contains (Task) | Determines whether this collection contains the specified task.

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Contains Method (String)

TaskCollection.Contains Method (String)
See Also

Determines whether this collection contains a task identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
string taskId
)
Visual Basic

Public Function Contains ( _
taskId As String _
) As Boolean

Parameters

taskId
The identifier of a task to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Contains Method (Task)

TaskCollection.Contains Method (Task)
See Also

Determines whether this collection contains the specified task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
Task task
)
Visual Basic

Public Function Contains ( _
task As Task _
) As Boolean

Parameters

task
The Task object to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Insert Method

TaskCollection.Insert Method

Inserts a location object into the collection at the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Insert (
int index,
Task task
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
task As Task _
)

Parameters

index
The zero-based index at which the task must be inserted.
task
An instance of the Task class to be added to the collection.

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace
Add Method


MindFusion.Scheduling.TaskCollection.OnClearComplete Method

TaskCollection.OnClearComplete Method

CollectionBase.OnClearComplete override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnClearComplete ()
Visual Basic

Protected Overridable Sub OnClearComplete ()

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.OnInsertComplete Method

TaskCollection.OnInsertComplete Method

CollectionBase.OnInsertComplete override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnInsertComplete (
int index,
Object value
)
Visual Basic

Protected Overridable Sub OnInsertComplete ( _
index As Integer, _
value As Object _
)

Parameters

index
value

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.OnRemoveComplete Method

TaskCollection.OnRemoveComplete Method

CollectionBase.OnRemoveComplete override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnRemoveComplete (
int index,
Object value
)
Visual Basic

Protected Overridable Sub OnRemoveComplete ( _
index As Integer, _
value As Object _
)

Parameters

index
value

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Remove Method

TaskCollection.Remove Method

Removes the first occurrence of the specified Task object from this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public void Remove (
Task task
)
Visual Basic

Public Sub Remove ( _
task As Task _
)

Parameters

task
A Task instance which must be removed from the collection.

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection Properties

TaskCollection Properties

Public Properties

Name | Description
Item | Gets a Task object from the collection given its zero-based index or identifier.

See Also

TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Item Property

TaskCollection.Item Property

Gets a Task object from the collection given its zero-based index or identifier.

Overload List

Name | Description
TaskCollection.Item (Int32) | Gets or sets the task object located at the specified position within this collection.
TaskCollection.Item (String) | Gets the task object identified by the specified string.

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Item Property (Int32)

TaskCollection.Item Property (Int32)
See Also

Gets or sets the task object located at the specified position within this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Task Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Task

Parameters

index
The zero-based index of the Task to set or retrieve.

Property Value

A reference to the task at the specified position.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their integer indices.

See Also

Item Property Overload List
TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Item Property (String)

TaskCollection.Item Property (String)
See Also

Gets the task object identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Task Item [
string id
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
id As String _
) As Task

Parameters

id
The Id of the Task to get.

Property Value

The Task instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

Item Property Overload List
TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection Events

TaskCollection Events

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Changed Event

TaskCollection.Changed Event

Raised when the collection has been changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler Changed
Visual Basic

Public Event Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs Class

TaskEventArgs Class

Contains the arguments passed to handlers of task related events raised by the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public class TaskEventArgs : EventArgs
Visual Basic

Public Class TaskEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.TaskEventArgs

See Also

TaskEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs Members

TaskEventArgs Members
Properties

Contains the arguments passed to handlers of task related events raised by the Schedule class.

The following tables list the members exposed by the TaskEventArgs type.

Public Properties

Name | Description
Task | Gets the task related to the event.

See Also

TaskEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs Properties

TaskEventArgs Properties

Public Properties

Name | Description
Task | Gets the task related to the event.

See Also

TaskEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs.Task Property

TaskEventArgs.Task Property

Gets the task related to the event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Task Task { get; }
Visual Basic

Public ReadOnly Property Task As Task

Property Value

An instance of the Task class related to the raised event.

See Also

TaskEventArgs Members
TaskEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskPriority Enumeration

TaskPriority Enumeration

Specifies the priority of a task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum TaskPriority
Visual Basic

Public Enumeration TaskPriority

Members

Member name | Description
High | Indicates high task priority.
Low | Indicates low task priority.
Normal | Indicates normal task priority.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskStatus Enumeration

TaskStatus Enumeration

Enumeration providing task status values.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum TaskStatus
Visual Basic

Public Enumeration TaskStatus

Members

Member name | Description
Completed | Indicates a completed task.
Deferred | Indicates a deferred task.
InProgress | Indicates a task in progress.
NotStarted | Indicates that the task has not started yet.
WaitingOther | Indicates a task that depends on another task.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Class

XmlSerializationContext Class

Contains methods that can help you serialize/deserialize MindFusion.Scheduling items to/from XML documents.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class XmlSerializationContext : SerializationContext
Visual Basic

Public NotInheritable Class XmlSerializationContext
Inherits SerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.SerializationContext
MindFusion.Scheduling.XmlSerializationContext

See Also

XmlSerializationContext Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Members

XmlSerializationContext Members
Constructors Properties Methods

Contains methods that can help you serialize/deserialize MindFusion.Scheduling items to/from XML documents.

The following tables list the members exposed by the XmlSerializationContext type.

Public Constructors

Name | Description
XmlSerializationContext | Overloaded. Initializes a new instance of the XmlSerializationContext class.

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
XmlDocument | Gets the underlying XML document.

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node with the specified name to the specified parent node.
ReadBool | Overloaded. Reads a boolean value with the specified name.
ReadBrush | Reads a MindFusion.Drawing.Brush object with the specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a color with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadCustomBrushes | Reads a CustomBrushes object with the specified name.
ReadDateTime | Reads a DateTime object with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEnum | Reads an enum value with the specified name.
ReadFloat | Reads a float value with the specified name.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Reads a Font object with the specified name.
ReadHashtable | Reads a hashtable object with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Reads an integer value with the specified name.
ReadLong | Reads a long value with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Reads a MindFusion.Drawing.Pen object with the specified name.
ReadPointF | Reads a PointF object with the specified name.
ReadRectangleF | Reads a RectangleF object with the specified name.
ReadRecurrence | Reads a Recurrence object with the specified name.
ReadReminder | Reads a Reminder object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShort | Reads a short value with the specified name.
ReadSizeF | Reads a SizeF object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Reads a string value with the specified name.
ReadStringFormat | Reads a StringFormat object with the specified name.
ReadStyle | Reads a Style object with the specified name.
ReadTag | Reads the specified tag for the specified object.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteCustomBrushes | Writes the specified CustomBrushes object.
WriteDateTime | Writes the specified DateTime object.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteLong | Writes a long value with the specified name.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePointF | Writes a PointF with the specified name.
WriteRectangleF | Writes a RectangleF with the specified name.
WriteRecurrence | Writes the specified Recurrence object.
WriteReminder | Writes the specified Reminder object.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a SizeF with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteStyle | Writes the specified Style object.
WriteTag | Writes the specified tag of the specified object.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Constructor

XmlSerializationContext Constructor

Initializes a new instance of the XmlSerializationContext class.

Overload List

Name | Description
XmlSerializationContext (Schedule, Int32, XmlDocument) | Initializes a new instance of the XmlSerializationContext class.
XmlSerializationContext (Schedule, XmlDocument) | Initializes a new instance of the XmlSerializationContext class.

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Constructor (Schedule, Int32, XmlDocument)

XmlSerializationContext Constructor (Schedule, Int32, XmlDocument)
See Also

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlSerializationContext (
Schedule schedule,
int fileVersion,
XmlDocument document
)
Visual Basic

Public Sub XmlSerializationContext ( _
schedule As Schedule, _
fileVersion As Integer, _
document As XmlDocument _
)

Parameters

schedule
The Schedule this class will operate on.
fileVersion
The file version of the file being deserialized.
document
The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Constructor (Schedule, XmlDocument)

XmlSerializationContext Constructor (Schedule, XmlDocument)
See Also

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlSerializationContext (
Schedule schedule,
XmlDocument document
)
Visual Basic

Public Sub XmlSerializationContext ( _
schedule As Schedule, _
document As XmlDocument _
)

Parameters

schedule
The Schedule this class will operate on.
document
The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Methods

XmlSerializationContext Methods

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node with the specified name to the specified parent node.
ReadBool | Overloaded. Reads a boolean value with the specified name.
ReadBrush | Reads a MindFusion.Drawing.Brush object with the specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a color with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadCustomBrushes | Reads a CustomBrushes object with the specified name.
ReadDateTime | Reads a DateTime object with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEnum | Reads an enum value with the specified name.
ReadFloat | Reads a float value with the specified name.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Reads a Font object with the specified name.
ReadHashtable | Reads a hashtable object with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Reads an integer value with the specified name.
ReadLong | Reads a long value with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Reads a MindFusion.Drawing.Pen object with the specified name.
ReadPointF | Reads a PointF object with the specified name.
ReadRectangleF | Reads a RectangleF object with the specified name.
ReadRecurrence | Reads a Recurrence object with the specified name.
ReadReminder | Reads a Reminder object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShort | Reads a short value with the specified name.
ReadSizeF | Reads a SizeF object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Reads a string value with the specified name.
ReadStringFormat | Reads a StringFormat object with the specified name.
ReadStyle | Reads a Style object with the specified name.
ReadTag | Reads the specified tag for the specified object.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteCustomBrushes | Writes the specified CustomBrushes object.
WriteDateTime | Writes the specified DateTime object.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteLong | Writes a long value with the specified name.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePointF | Writes a PointF with the specified name.
WriteRectangleF | Writes a RectangleF with the specified name.
WriteRecurrence | Writes the specified Recurrence object.
WriteReminder | Writes the specified Reminder object.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a SizeF with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteStyle | Writes the specified Style object.
WriteTag | Writes the specified tag of the specified object.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method

XmlSerializationContext.AddChildElement Method

Adds a new child node with the specified name to the specified parent node.

Overload List

Name | Description
XmlSerializationContext.AddChildElement (String, XmlElement) | Adds a new child node with the specified name to the specified parent node.
XmlSerializationContext.AddChildElement (String, XmlElement, String) | Adds a new child node with the specified name and value to the specified parent node.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method (String, XmlElement)

XmlSerializationContext.AddChildElement Method (String, XmlElement)
See Also

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function AddChildElement ( _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

elementName
The desired name of the new node.
parentElement
The parent element of the newly created node.

Return Value

A .NET XmlElement object representing the newly created element.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method (String, XmlElement, String)

XmlSerializationContext.AddChildElement Method (String, XmlElement, String)
See Also

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement,
string innerText
)
Visual Basic

Public Function AddChildElement ( _
elementName As String, _
parentElement As XmlElement, _
innerText As String _
) As XmlElement

Parameters

elementName
The desired name of the new node.
parentElement
The parent element of the newly created node.
innerText
The desired value of the new node.

Return Value

A .NET XmlElement object representing the newly created element.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method

XmlSerializationContext.ReadBool Method

Reads a boolean value with the specified name.

Overload List

Name | Description
XmlSerializationContext.ReadBool (String, XmlElement) | Reads a boolean value with the specified name.
XmlSerializationContext.ReadBool (String, XmlElement, Boolean) | Reads a boolean value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method (String, XmlElement)

XmlSerializationContext.ReadBool Method (String, XmlElement)
See Also

Reads a boolean value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ReadBool (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadBool ( _
elementName As String, _
parentElement As XmlElement _
) As Boolean

Parameters

elementName
The name of the element containing the bool value.
parentElement
The parent element of the node with the specified name.

Return Value

A bool value. Returns false if there is no element with the specified name under the specified parent.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteBool Method


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method (String, XmlElement, Boolean)

XmlSerializationContext.ReadBool Method (String, XmlElement, Boolean)
See Also

Reads a boolean value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ReadBool (
string elementName,
XmlElement parentElement,
bool defaultValue
)
Visual Basic

Public Function ReadBool ( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName
The name of the element containing the bool value.
parentElement
The parent element of the node with the specified name.
defaultValue
The value that should be returned if there is no node with the specified name under the specified parent element.

Return Value

A bool value.

Remarks

If there is no element with the specified name, returns the specified default value.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteBool Method


MindFusion.Scheduling.XmlSerializationContext.ReadBrush Method

XmlSerializationContext.ReadBrush Method

Reads a MindFusion.Drawing.Brush object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush ReadBrush (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadBrush ( _
elementName As String, _
parentElement As XmlElement _
) As Brush

Parameters

elementName
The name of the element containing the Brush object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the MindFusion.Drawing.Brush class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteBrush Method


MindFusion.Scheduling.XmlSerializationContext.ReadByte Method

XmlSerializationContext.ReadByte Method

Reads a byte value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public byte ReadByte (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadByte ( _
elementName As String, _
parentElement As XmlElement _
) As Byte

Parameters

elementName
The name of the element containing the byte value.
parentElement
The parent element of the node with the specified name.

Return Value

A byte value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteByte Method


MindFusion.Scheduling.XmlSerializationContext.ReadChar Method

XmlSerializationContext.ReadChar Method

Reads a char value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public char ReadChar (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadChar ( _
elementName As String, _
parentElement As XmlElement _
) As Char

Parameters

elementName
The name of the element containing the char value.
parentElement
The parent element of the node with the specified name.

Return Value

A char value. Returns 'a' if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteChar Method


MindFusion.Scheduling.XmlSerializationContext.ReadColor Method

XmlSerializationContext.ReadColor Method

Reads a color with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color ReadColor (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadColor ( _
elementName As String, _
parentElement As XmlElement _
) As Color

Parameters

elementName
The name of the element containing the .NET Color object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Color object. Returns Black if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteColor Method


MindFusion.Scheduling.XmlSerializationContext.ReadColorArray Method

XmlSerializationContext.ReadColorArray Method

Reads a color array with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Color[] ReadColorArray (
string elementName,
string subElementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadColorArray ( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Color()

Parameters

elementName
The name of the element containing the array.
subElementName
The name of the elements containing the individual array values.
parentElement
The parent element of the node with the specified name.

Return Value

An array of .NET Color objects. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteColorArray Method


MindFusion.Scheduling.XmlSerializationContext.ReadCustomBrushes Method

XmlSerializationContext.ReadCustomBrushes Method

Reads a CustomBrushes object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public CustomBrushes ReadCustomBrushes (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadCustomBrushes ( _
elementName As String, _
parentElement As XmlElement _
) As CustomBrushes

Parameters

elementName
The name of the element containing the CustomBrushes object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the CustomBrushes class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteCustomBrushes Method


MindFusion.Scheduling.XmlSerializationContext.ReadDateTime Method

XmlSerializationContext.ReadDateTime Method

Reads a DateTime object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime ReadDateTime (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadDateTime ( _
elementName As String, _
parentElement As XmlElement _
) As DateTime

Parameters

elementName
The name of the element containing the .NET DateTime object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET DateTime object. Returns DateTime.MinValue if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteDateTime Method


MindFusion.Scheduling.XmlSerializationContext.ReadDecimal Method

XmlSerializationContext.ReadDecimal Method

Reads a decimal value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Decimal ReadDecimal (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadDecimal ( _
elementName As String, _
parentElement As XmlElement _
) As Decimal

Parameters

elementName
The name of the element containing the decimal value.
parentElement
The parent element of the node with the specified name.

Return Value

A decimal value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteDecimal Method


MindFusion.Scheduling.XmlSerializationContext.ReadDouble Method

XmlSerializationContext.ReadDouble Method

Reads a double value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public double ReadDouble (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadDouble ( _
elementName As String, _
parentElement As XmlElement _
) As Double

Parameters

elementName
The name of the element containing the double value.
parentElement
The parent element of the node with the specified name.

Return Value

A double value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteDouble Method


MindFusion.Scheduling.XmlSerializationContext.ReadEnum Method

XmlSerializationContext.ReadEnum Method

Reads an enum value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Object ReadEnum (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadEnum ( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName
The name of the element containing the enum value.
parentElement
The parent element of the node with the specified name.

Return Value

An enum value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteEnum Method


MindFusion.Scheduling.XmlSerializationContext.ReadFloat Method

XmlSerializationContext.ReadFloat Method

Reads a float value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public float ReadFloat (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadFloat ( _
elementName As String, _
parentElement As XmlElement _
) As Single

Parameters

elementName
The name of the element containing the float value.
parentElement
The parent element of the node with the specified name.

Return Value

A float value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteFloat Method


MindFusion.Scheduling.XmlSerializationContext.ReadFloatArray Method

XmlSerializationContext.ReadFloatArray Method

Reads a float array with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public float[] ReadFloatArray (
string elementName,
string subElementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadFloatArray ( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Single()

Parameters

elementName
The name of the element containing the array.
subElementName
The name of the elements containing the individual array values.
parentElement
The parent element of the node with the specified name.

Return Value

An array of float values. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteFloatArray Method


MindFusion.Scheduling.XmlSerializationContext.ReadFont Method

XmlSerializationContext.ReadFont Method

Reads a Font object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Font ReadFont (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadFont ( _
elementName As String, _
parentElement As XmlElement _
) As Font

Parameters

elementName
The name of the element containing the .NET Font object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Font object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteFont Method


MindFusion.Scheduling.XmlSerializationContext.ReadHashtable Method

XmlSerializationContext.ReadHashtable Method

Reads a hashtable object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Hashtable ReadHashtable (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadHashtable ( _
elementName As String, _
parentElement As XmlElement _
) As Hashtable

Parameters

elementName
The name of the element containing the .NET Hashtable object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Hashtable object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteHashtable Method


MindFusion.Scheduling.XmlSerializationContext.ReadImage Method

XmlSerializationContext.ReadImage Method

Reads an Image object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Image ReadImage (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadImage ( _
elementName As String, _
parentElement As XmlElement _
) As Image

Parameters

elementName
The name of the element containing the .NET Image object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Image object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteImage Method


MindFusion.Scheduling.XmlSerializationContext.ReadInt Method

XmlSerializationContext.ReadInt Method

Reads an integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int ReadInt (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadInt ( _
elementName As String, _
parentElement As XmlElement _
) As Integer

Parameters

elementName
The name of the element containing the integer value.
parentElement
The parent element of the node with the specified name.

Return Value

An integer value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteInt Method


MindFusion.Scheduling.XmlSerializationContext.ReadLong Method

XmlSerializationContext.ReadLong Method

Reads a long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public long ReadLong (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadLong ( _
elementName As String, _
parentElement As XmlElement _
) As Long

Parameters

elementName
The name of the element containing the long value.
parentElement
The parent element of the node with the specified name.

Return Value

An long value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteLong Method


MindFusion.Scheduling.XmlSerializationContext.ReadObject Method

XmlSerializationContext.ReadObject Method

Reads an object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Object ReadObject (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadObject ( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName
The name of the element containing the object.
parentElement
The parent element of the node with the specified name.

Return Value

An object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent or if the object cannot be deserialized.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteObject Method


MindFusion.Scheduling.XmlSerializationContext.ReadPen Method

XmlSerializationContext.ReadPen Method

Reads a MindFusion.Drawing.Pen object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Pen ReadPen (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadPen ( _
elementName As String, _
parentElement As XmlElement _
) As Pen

Parameters

elementName
The name of the element containing the Pen object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the MindFusion.Drawing.Pen class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WritePen Method


MindFusion.Scheduling.XmlSerializationContext.ReadPointF Method

XmlSerializationContext.ReadPointF Method

Reads a PointF object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public PointF ReadPointF (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadPointF ( _
elementName As String, _
parentElement As XmlElement _
) As PointF

Parameters

elementName
The name of the element containing the .NET PointF object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET PointF object. Returns PointF.Empty if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WritePointF Method


MindFusion.Scheduling.XmlSerializationContext.ReadRectangleF Method

XmlSerializationContext.ReadRectangleF Method

Reads a RectangleF object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public RectangleF ReadRectangleF (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadRectangleF ( _
elementName As String, _
parentElement As XmlElement _
) As RectangleF

Parameters

elementName
The name of the element containing the RectangleF object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET RectangleF object. Returns RectangleF.Empty if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteRectangleF Method


MindFusion.Scheduling.XmlSerializationContext.ReadRecurrence Method

XmlSerializationContext.ReadRecurrence Method

Reads a Recurrence object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Recurrence ReadRecurrence (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadRecurrence ( _
elementName As String, _
parentElement As XmlElement _
) As Recurrence

Parameters

elementName
The name of the element containing the Recurrence object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the Recurrence class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteRecurrence Method


MindFusion.Scheduling.XmlSerializationContext.ReadReminder Method

XmlSerializationContext.ReadReminder Method

Reads a Reminder object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Reminder ReadReminder (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadReminder ( _
elementName As String, _
parentElement As XmlElement _
) As Reminder

Parameters

elementName
The name of the element containing the Reminder object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the Reminder class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteReminder Method


MindFusion.Scheduling.XmlSerializationContext.ReadSByte Method

XmlSerializationContext.ReadSByte Method

Reads a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public sbyte ReadSByte (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadSByte ( _
elementName As String, _
parentElement As XmlElement _
) As SByte

Parameters

elementName
The name of the element containing the signed byte value.
parentElement
The parent element of the node with the specified name.

Return Value

A signed byte value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteSByte Method


MindFusion.Scheduling.XmlSerializationContext.ReadShort Method

XmlSerializationContext.ReadShort Method

Reads a short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public short ReadShort (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadShort ( _
elementName As String, _
parentElement As XmlElement _
) As Short

Parameters

elementName
The name of the element containing the short value.
parentElement
The parent element of the node with the specified name.

Return Value

A short value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteShort Method


MindFusion.Scheduling.XmlSerializationContext.ReadSizeF Method

XmlSerializationContext.ReadSizeF Method

Reads a SizeF object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public SizeF ReadSizeF (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadSizeF ( _
elementName As String, _
parentElement As XmlElement _
) As SizeF

Parameters

elementName
The name of the element containing the .NET SizeF object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET SizeF object. Returns SizeF.Empty if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteSizeF Method


MindFusion.Scheduling.XmlSerializationContext.ReadStream Method

XmlSerializationContext.ReadStream Method

Reads a stream with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Stream ReadStream (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadStream ( _
elementName As String, _
parentElement As XmlElement _
) As Stream

Parameters

elementName
The name of the element containing the .NET Stream object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Stream object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteStream Method


MindFusion.Scheduling.XmlSerializationContext.ReadString Method

XmlSerializationContext.ReadString Method

Reads a string value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public string ReadString (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadString ( _
elementName As String, _
parentElement As XmlElement _
) As String

Parameters

elementName
The name of the element containing the string value.
parentElement
The parent element of the node with the specified name.

Return Value

A string value. Returns an empty string if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteString Method


MindFusion.Scheduling.XmlSerializationContext.ReadStringFormat Method

XmlSerializationContext.ReadStringFormat Method

Reads a StringFormat object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public StringFormat ReadStringFormat (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadStringFormat ( _
elementName As String, _
parentElement As XmlElement _
) As StringFormat

Parameters

elementName
The name of the element containing the .NET StringFormat object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET StringFormat object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteStringFormat Method


MindFusion.Scheduling.XmlSerializationContext.ReadStyle Method

XmlSerializationContext.ReadStyle Method

Reads a Style object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Style ReadStyle (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadStyle ( _
elementName As String, _
parentElement As XmlElement _
) As Style

Parameters

elementName
The name of the element containing the Style object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the Style class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteStyle Method


MindFusion.Scheduling.XmlSerializationContext.ReadTag Method

XmlSerializationContext.ReadTag Method

Reads the specified tag for the specified object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public Object ReadTag (
Object item,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadTag ( _
item As Object, _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

item
The Item whose tag is being deserialized.
elementName
The name of the element containing the tag object.
parentElement
The parent element of the node with the specified name.

Return Value

An object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent or if the tag cannot be deserialized.

Remarks

This method raises the DeserializeTag event of the underlying schedule, giving clients a chance to perform custom deserialization. If the event is not handled, the system attempts to deserialize the tag as an arbitrary object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteTag Method
Schedule.DeserializeTag Event


MindFusion.Scheduling.XmlSerializationContext.ReadUInt Method

XmlSerializationContext.ReadUInt Method

Reads an unsigned integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public uint ReadUInt (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadUInt ( _
elementName As String, _
parentElement As XmlElement _
) As UInteger

Parameters

elementName
The name of the element containing the unsigned integer value.
parentElement
The parent element of the node with the specified name.

Return Value

An unsigned integer value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteUInt Method


MindFusion.Scheduling.XmlSerializationContext.ReadULong Method

XmlSerializationContext.ReadULong Method

Reads an unsigned long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ulong ReadULong (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadULong ( _
elementName As String, _
parentElement As XmlElement _
) As ULong

Parameters

elementName
The name of the element containing the unsigned long value.
parentElement
The parent element of the node with the specified name.

Return Value

An unsigned long value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteULong Method


MindFusion.Scheduling.XmlSerializationContext.ReadUShort Method

XmlSerializationContext.ReadUShort Method

Reads an unsigned short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public ushort ReadUShort (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadUShort ( _
elementName As String, _
parentElement As XmlElement _
) As UShort

Parameters

elementName
The name of the element containing the unsigned short value.
parentElement
The parent element of the node with the specified name.

Return Value

An unsigned short value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.WriteBool Method

XmlSerializationContext.WriteBool Method

Writes a boolean value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteBool (
bool value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteBool ( _
value As Boolean, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The bool value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadBool Method


MindFusion.Scheduling.XmlSerializationContext.WriteBrush Method

XmlSerializationContext.WriteBrush Method

Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteBrush (
Brush brush,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteBrush ( _
brush As Brush, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

brush
The Brush instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadBrush Method


MindFusion.Scheduling.XmlSerializationContext.WriteByte Method

XmlSerializationContext.WriteByte Method

Write a byte value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteByte (
byte value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteByte ( _
value As Byte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The byte value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadByte Method


MindFusion.Scheduling.XmlSerializationContext.WriteChar Method

XmlSerializationContext.WriteChar Method

Write a char value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteChar (
char value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteChar ( _
value As Char, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The char value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadChar Method


MindFusion.Scheduling.XmlSerializationContext.WriteColor Method

XmlSerializationContext.WriteColor Method

Writes the specified color.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteColor (
Color color,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteColor ( _
color As Color, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

color
The .NET Color object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadColor Method


MindFusion.Scheduling.XmlSerializationContext.WriteColorArray Method

XmlSerializationContext.WriteColorArray Method

Writes the specified array.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteColorArray (
Color[] array,
string elementName,
string subElementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteColorArray ( _
array() As Color, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array
The array to write.
elementName
The name of the element under which the array should be written.
subElementName
The name of the XML elements under which the individual array values will be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadColorArray Method


MindFusion.Scheduling.XmlSerializationContext.WriteCustomBrushes Method

XmlSerializationContext.WriteCustomBrushes Method

Writes the specified CustomBrushes object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteCustomBrushes (
CustomBrushes customBrushes,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteCustomBrushes ( _
customBrushes As CustomBrushes, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

customBrushes
The CustomBrushes instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadCustomBrushes Method


MindFusion.Scheduling.XmlSerializationContext.WriteDateTime Method

XmlSerializationContext.WriteDateTime Method

Writes the specified DateTime object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteDateTime (
DateTime value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteDateTime ( _
value As DateTime, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The .NET DateTime object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadDateTime Method


MindFusion.Scheduling.XmlSerializationContext.WriteDecimal Method

XmlSerializationContext.WriteDecimal Method

Write a decimal value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteDecimal (
Decimal value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteDecimal ( _
value As Decimal, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The decimal value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadDecimal Method


MindFusion.Scheduling.XmlSerializationContext.WriteDouble Method

XmlSerializationContext.WriteDouble Method

Writes a double value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteDouble (
double value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteDouble ( _
value As Double, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The double value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadDouble Method


MindFusion.Scheduling.XmlSerializationContext.WriteEnum Method

XmlSerializationContext.WriteEnum Method

Writes the specified enum value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteEnum (
Object value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteEnum ( _
value As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The enum value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadEnum Method


MindFusion.Scheduling.XmlSerializationContext.WriteFloat Method

XmlSerializationContext.WriteFloat Method

Writes a float value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteFloat (
float value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteFloat ( _
value As Single, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The float value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadFloat Method


MindFusion.Scheduling.XmlSerializationContext.WriteFloatArray Method

XmlSerializationContext.WriteFloatArray Method

Writes the specified array.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteFloatArray (
float[] array,
string elementName,
string subElementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteFloatArray ( _
array() As Single, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array
The array to write.
elementName
The name of the element under which the array should be written.
subElementName
The name of the XML elements under which the individual array values will be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadFloatArray Method


MindFusion.Scheduling.XmlSerializationContext.WriteFont Method

XmlSerializationContext.WriteFont Method

Writes the specified font.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteFont (
Font font,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteFont ( _
font As Font, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

font
The .NET Font object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadFont Method


MindFusion.Scheduling.XmlSerializationContext.WriteHashtable Method

XmlSerializationContext.WriteHashtable Method

Writes the specified hashtable.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteHashtable (
Hashtable hashtable,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteHashtable ( _
hashtable As Hashtable, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

hashtable
The .NET Hashtable object to write.
elementName
The name of the element under which the hashtable should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadHashtable Method


MindFusion.Scheduling.XmlSerializationContext.WriteImage Method

XmlSerializationContext.WriteImage Method

Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteImage (
Image image,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteImage ( _
image As Image, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

image
The .NET Image object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadImage Method


MindFusion.Scheduling.XmlSerializationContext.WriteInt Method

XmlSerializationContext.WriteInt Method

Writes an integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteInt (
int value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteInt ( _
value As Integer, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The integer value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadInt Method


MindFusion.Scheduling.XmlSerializationContext.WriteLong Method

XmlSerializationContext.WriteLong Method

Writes a long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteLong (
long value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteLong ( _
value As Long, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The long value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadLong Method


MindFusion.Scheduling.XmlSerializationContext.WriteObject Method

XmlSerializationContext.WriteObject Method

Writes the specified object under the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteObject (
Object value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteObject ( _
value As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadObject Method


MindFusion.Scheduling.XmlSerializationContext.WritePen Method

XmlSerializationContext.WritePen Method

Writes the specified pen.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WritePen (
Pen pen,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WritePen ( _
pen As Pen, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

pen
The Pen instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadPen Method


MindFusion.Scheduling.XmlSerializationContext.WritePointF Method

XmlSerializationContext.WritePointF Method

Writes a PointF with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WritePointF (
PointF value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WritePointF ( _
value As PointF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The .NET PointF object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadPointF Method


MindFusion.Scheduling.XmlSerializationContext.WriteRectangleF Method

XmlSerializationContext.WriteRectangleF Method

Writes a RectangleF with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteRectangleF (
RectangleF value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteRectangleF ( _
value As RectangleF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The .NET RectangleF object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadRectangleF Method


MindFusion.Scheduling.XmlSerializationContext.WriteRecurrence Method

XmlSerializationContext.WriteRecurrence Method

Writes the specified Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteRecurrence (
Recurrence recurrence,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteRecurrence ( _
recurrence As Recurrence, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

recurrence
The Recurrence instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadRecurrence Method


MindFusion.Scheduling.XmlSerializationContext.WriteReminder Method

XmlSerializationContext.WriteReminder Method

Writes the specified Reminder object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteReminder (
Reminder reminder,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteReminder ( _
reminder As Reminder, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

reminder
The Reminder instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadReminder Method


MindFusion.Scheduling.XmlSerializationContext.WriteSByte Method

XmlSerializationContext.WriteSByte Method

Write a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteSByte (
sbyte value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteSByte ( _
value As SByte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The signed byte value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadSByte Method


MindFusion.Scheduling.XmlSerializationContext.WriteShort Method

XmlSerializationContext.WriteShort Method

Writes a short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteShort (
short value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteShort ( _
value As Short, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The short value to write.
elementName

The name of the element under which the value should be written.

parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadShort Method


MindFusion.Scheduling.XmlSerializationContext.WriteSizeF Method

XmlSerializationContext.WriteSizeF Method

Writes a SizeF with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteSizeF (
SizeF value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteSizeF ( _
value As SizeF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The .NET SizeF object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadSizeF Method


MindFusion.Scheduling.XmlSerializationContext.WriteStream Method

XmlSerializationContext.WriteStream Method

Writes the specified stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteStream (
Stream stream,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteStream ( _
stream As Stream, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stream
The .NET Stream object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadStream Method


MindFusion.Scheduling.XmlSerializationContext.WriteString Method

XmlSerializationContext.WriteString Method

Writes a string value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteString (
string value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteString ( _
value As String, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The string value to write.

elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadString Method


MindFusion.Scheduling.XmlSerializationContext.WriteStringFormat Method

XmlSerializationContext.WriteStringFormat Method

Writes the specified StringFormat object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteStringFormat (
StringFormat stringFormat,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteStringFormat ( _
stringFormat As StringFormat, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stringFormat
The .NET StringFormat object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadStringFormat Method


MindFusion.Scheduling.XmlSerializationContext.WriteStyle Method

XmlSerializationContext.WriteStyle Method

Writes the specified Style object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteStyle (
Style style,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteStyle ( _
style As Style, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

style
The Style instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadStyle Method


MindFusion.Scheduling.XmlSerializationContext.WriteTag Method

XmlSerializationContext.WriteTag Method

Writes the specified tag of the specified object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteTag (
Object item,
Object tagValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteTag ( _
item As Object, _
tagValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

item
The Item whose tag is being serialized.
tagValue
The tag object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

Remarks

This method raises the SerializeTag event of the underlying schedule, giving clients a chance to perform custom serialization. If the event is not handled, the system attempts to serialize the tag as an arbitrary object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadTag Method
Schedule.SerializeTag Event


MindFusion.Scheduling.XmlSerializationContext.WriteUInt Method

XmlSerializationContext.WriteUInt Method

Writes an unsigned integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteUInt (
uint value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteUInt ( _
value As UInteger, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The unsigned integer value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadUInt Method


MindFusion.Scheduling.XmlSerializationContext.WriteULong Method

XmlSerializationContext.WriteULong Method

Writes an unsigned long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteULong (
ulong value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteULong ( _
value As ULong, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The unsigned long value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadULong Method


MindFusion.Scheduling.XmlSerializationContext.WriteUShort Method

XmlSerializationContext.WriteUShort Method

Writes an unsigned short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlElement WriteUShort (
ushort value,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteUShort ( _
value As UShort, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The unsigned short value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadUShort Method


MindFusion.Scheduling.XmlSerializationContext Properties

XmlSerializationContext Properties

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
XmlDocument | Gets the underlying XML document.

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ClassVersion Property

XmlSerializationContext.ClassVersion Property

Gets the class version of the currently deserialized item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public int ClassVersion { get; }
Visual Basic

Public ReadOnly Property ClassVersion As Integer

Property Value

An integer value specifying the class version of the currently deserialized item as specified by the call to RegisterItemClass method at the time the item type was registered.

Remarks

This property is only useful when deserializing items.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.XmlDocument Property

XmlSerializationContext.XmlDocument Property

Gets the underlying XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public XmlDocument XmlDocument { get; }
Visual Basic

Public ReadOnly Property XmlDocument As XmlDocument

Property Value

An instance of the .NET XmlDocument class.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.YearlyRecurrence Enumeration

YearlyRecurrence Enumeration

Specifies the types of yearly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C#

public enum YearlyRecurrence
Visual Basic

Public Enumeration YearlyRecurrence

Members

Member name | Description
ByDayType | The event occurs on a specific type of day of the specified week and month of the year.
SpecificDate | The event occurs on a specific date of the year.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Outlook Namespace
Classes

Classes

Class | Description
ContactConfirmEventArgs | Contains the arguments passed to handlers of contact validation events.
ItemConfirmEventArgs | Contains the arguments passed to handlers of item validation events.
OutlookExporter | Provides methods for exporting items, contacts and tasks to Microsoft Outlook.
OutlookImporter | Provides methods for importing items, contacts and tasks from Microsoft Outlook.
TaskConfirmEventArgs | Contains the arguments passed to handlers of task validation events.


MindFusion.Scheduling.Outlook.ContactConfirmEventArgs Class

ContactConfirmEventArgs Class

Contains the arguments passed to handlers of contact validation events.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public class ContactConfirmEventArgs : EventArgs
Visual Basic

Public Class ContactConfirmEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Outlook.ContactConfirmEventArgs

See Also

ContactConfirmEventArgs Members
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ContactConfirmEventArgs Members

ContactConfirmEventArgs Members
Properties

Contains the arguments passed to handlers of contact validation events.

The following tables list the members exposed by the ContactConfirmEventArgs type.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Contact | Gets the contact related to the event.

See Also

ContactConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ContactConfirmEventArgs Properties

ContactConfirmEventArgs Properties

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Contact | Gets the contact related to the event.

See Also

ContactConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ContactConfirmEventArgs.Confirm Property

ContactConfirmEventArgs.Confirm Property

Gets or sets a value indicating whether the operation is confirmed.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public bool Confirm { get; set; }
Visual Basic

Public Property Confirm As Boolean

Property Value

true to confirm the operation; false to decline it. The default is true.

See Also

ContactConfirmEventArgs Members
ContactConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ContactConfirmEventArgs.Contact Property

ContactConfirmEventArgs.Contact Property

Gets the contact related to the event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public Contact Contact { get; }
Visual Basic

Public ReadOnly Property Contact As Contact

Property Value

An instance of the Contact class for which the event is raised.

See Also

ContactConfirmEventArgs Members
ContactConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ItemConfirmEventArgs Class

ItemConfirmEventArgs Class

Contains the arguments passed to handlers of item validation events.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public class ItemConfirmEventArgs : EventArgs
Visual Basic

Public Class ItemConfirmEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Outlook.ItemConfirmEventArgs

See Also

ItemConfirmEventArgs Members
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ItemConfirmEventArgs Members

ItemConfirmEventArgs Members
Properties

Contains the arguments passed to handlers of item validation events.

The following tables list the members exposed by the ItemConfirmEventArgs type.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Item | Gets the Item related to the event.

See Also

ItemConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ItemConfirmEventArgs Properties

ItemConfirmEventArgs Properties

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Item | Gets the Item related to the event.

See Also

ItemConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ItemConfirmEventArgs.Confirm Property

ItemConfirmEventArgs.Confirm Property

Gets or sets a value indicating whether the operation is confirmed.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public bool Confirm { get; set; }
Visual Basic

Public Property Confirm As Boolean

Property Value

true to confirm the operation; false to decline it. The default is true.

See Also

ItemConfirmEventArgs Members
ItemConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ItemConfirmEventArgs.Item Property

ItemConfirmEventArgs.Item Property

Gets the Item related to the event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public Item Item { get; }
Visual Basic

Public ReadOnly Property Item As Item

Property Value

An instance of the Item class for which the event is raised.

See Also

ItemConfirmEventArgs Members
ItemConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Class

OutlookExporter Class

Provides methods for exporting items, contacts and tasks to Microsoft Outlook.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public class OutlookExporter
Visual Basic

Public Class OutlookExporter

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Outlook.OutlookExporter

See Also

OutlookExporter Members
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Members

OutlookExporter Members
Constructors Properties Methods Events

Provides methods for exporting items, contacts and tasks to Microsoft Outlook.

The following tables list the members exposed by the OutlookExporter type.

Public Constructors

Name | Description
OutlookExporter | Overloaded. Initializes a new instance of the OutlookExporter class.

Public Properties

Name | Description
Schedule | Gets the Schedule associated with the exporter.

Public Methods

Name | Description
ExportContacts | Exports all contacts from associated schedule to Outlook.
ExportItems | Exports all events from the associated schedule to Outlook.
ExportTasks | Exports all tasks from the associated schedule to Outlook.

Protected Methods

Name | Description
OnContactExporting | Raises the ContactExporting event.
OnItemExporting | Raises the ItemExporting event.
OnTaskExporting | Raises the TaskExporting event.

Public Events

Name | Description
ContactExporting | Fired for each contact to confirm that the contact should be exported.
ItemExporting | Fired for each item to confirm that the item should be exported.
TaskExporting | Fired for each task to confirm that the task should be exported.

See Also

OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Constructor

OutlookExporter Constructor

Initializes a new instance of the OutlookExporter class.

Overload List

Name | Description
OutlookExporter (Schedule) | Initializes a new instance of the OutlookExporter class with the specified Schedule object.
OutlookExporter (Schedule, Object, Object) | Initializes a new instance of the OutlookExporter class with the specified Schedule object.

See Also

OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Constructor (Schedule)

OutlookExporter Constructor (Schedule)
See Also

Initializes a new instance of the OutlookExporter class with the specified Schedule object.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public OutlookExporter (
Schedule schedule
)
Visual Basic

Public Sub OutlookExporter ( _
schedule As Schedule _
)

Parameters

schedule

A Schedule object to supply the data to export.

See Also

OutlookExporter Constructor Overload List
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Constructor (Schedule, Object, Object)

OutlookExporter Constructor (Schedule, Object, Object)
See Also

Initializes a new instance of the OutlookExporter class with the specified Schedule object.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public OutlookExporter (
Schedule schedule,
Object profile,
Object password
)
Visual Basic

Public Sub OutlookExporter ( _
schedule As Schedule, _
profile As Object, _
password As Object _
)

Parameters

schedule
A Schedule object to supply the data to export.
profile
Outlook's profile name. Pass null (Nothing in Visual Basic) or empty string for default profile.
password
Profile's password. If no password is required by mentioned profile pass null or empty string.

See Also

OutlookExporter Constructor Overload List
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Methods

OutlookExporter Methods

Public Methods

Name | Description
ExportContacts | Exports all contacts from associated schedule to Outlook.
ExportItems | Exports all events from the associated schedule to Outlook.
ExportTasks | Exports all tasks from the associated schedule to Outlook.

Protected Methods

Name | Description
OnContactExporting | Raises the ContactExporting event.
OnItemExporting | Raises the ItemExporting event.
OnTaskExporting | Raises the TaskExporting event.

See Also

OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter.ExportContacts Method

OutlookExporter.ExportContacts Method

Exports all contacts from associated schedule to Outlook.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public void ExportContacts ()
Visual Basic

Public Sub ExportContacts ()

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace
ExportItems Method
ExportTasks Method


MindFusion.Scheduling.Outlook.OutlookExporter.ExportItems Method

OutlookExporter.ExportItems Method

Exports all events from the associated schedule to Outlook.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public void ExportItems ()
Visual Basic

Public Sub ExportItems ()

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace
ExportContacts Method
ExportTasks Method


MindFusion.Scheduling.Outlook.OutlookExporter.ExportTasks Method

OutlookExporter.ExportTasks Method

Exports all tasks from the associated schedule to Outlook.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public void ExportTasks ()
Visual Basic

Public Sub ExportTasks ()

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace
ExportItems Method
ExportContacts Method


MindFusion.Scheduling.Outlook.OutlookExporter.OnContactExporting Method

OutlookExporter.OnContactExporting Method

Raises the ContactExporting event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

protected virtual void OnContactExporting (
ContactConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnContactExporting ( _
e As ContactConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter.OnItemExporting Method

OutlookExporter.OnItemExporting Method

Raises the ItemExporting event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

protected virtual void OnItemExporting (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemExporting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter.OnTaskExporting Method

OutlookExporter.OnTaskExporting Method

Raises the TaskExporting event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

protected virtual void OnTaskExporting (
TaskConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnTaskExporting ( _
e As TaskConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Properties

OutlookExporter Properties

Public Properties

Name | Description
Schedule | Gets the Schedule associated with the exporter.

See Also

OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter.Schedule Property

OutlookExporter.Schedule Property

Gets the Schedule associated with the exporter.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public Schedule Schedule { get; set; }
Visual Basic

Public Property Schedule As Schedule

Property Value

An instance of the Schedule class providing the schedule data to be exported to Outlook.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Events

OutlookExporter Events

Public Events

Name | Description
ContactExporting | Fired for each contact to confirm that the contact should be exported.
ItemExporting | Fired for each item to confirm that the item should be exported.
TaskExporting | Fired for each task to confirm that the task should be exported.

See Also

OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter.ContactExporting Event

OutlookExporter.ContactExporting Event

Fired for each contact to confirm that the contact should be exported.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public event EventHandler<ContactConfirmEventArgs> ContactExporting
Visual Basic

Public Event ContactExporting As EventHandler(Of ContactConfirmEventArgs)

Event Data

ContactExporting event handlers receive an argument of type ContactConfirmEventArgs.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace
ItemExporting Event
TaskExporting Event


MindFusion.Scheduling.Outlook.OutlookExporter.ItemExporting Event

OutlookExporter.ItemExporting Event

Fired for each item to confirm that the item should be exported.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public event EventHandler<ItemConfirmEventArgs> ItemExporting
Visual Basic

Public Event ItemExporting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemExporting event handlers receive an argument of type ItemConfirmEventArgs.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace
ContactExporting Event
TaskExporting Event


MindFusion.Scheduling.Outlook.OutlookExporter.TaskExporting Event

OutlookExporter.TaskExporting Event

Fired for each task to confirm that the task should be exported.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public event EventHandler<TaskConfirmEventArgs> TaskExporting
Visual Basic

Public Event TaskExporting As EventHandler(Of TaskConfirmEventArgs)

Event Data

TaskExporting event handlers receive an argument of type TaskConfirmEventArgs.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace
ContactExporting Event
ItemExporting Event


MindFusion.Scheduling.Outlook.OutlookImporter Class

OutlookImporter Class

Provides methods for importing items, contacts and tasks from Microsoft Outlook.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public class OutlookImporter
Visual Basic

Public Class OutlookImporter

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Outlook.OutlookImporter

See Also

OutlookImporter Members
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Members

OutlookImporter Members
Constructors Properties Methods Events

Provides methods for importing items, contacts and tasks from Microsoft Outlook.

The following tables list the members exposed by the OutlookImporter type.

Public Constructors

Name | Description
OutlookImporter | Overloaded. Initializes a new instance of the OutlookImporter class.

Public Properties

Name | Description
ItemType | Gets or sets the type of the items that will be created by the importer. The default value, null, indicates items of type Appointment.
Schedule | Gets or sets the Schedule, associated with the importer.

Public Methods

Name | Description
ImportContacts | Imports all contacts from Outlook to the associated schedule.
ImportItems | Imports all events from Outlook to the associated schedule.
ImportTasks | Imports all tasks from Outlook to the associated schedule.

Protected Methods

Name | Description
OnContactImporting | Raises the ContactImporting event.
OnItemImporting | Raises the ItemImporting event.
OnTaskImporting | Raises the TaskImporting event.

Public Events

Name | Description
ContactImporting | Fired for each contact to confirm that the contact should be imported.
ItemImporting | Fired for each item to confirm that the item should be imported.
TaskImporting | Fired for each task to confirm that the task should be imported.

See Also

OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Constructor

OutlookImporter Constructor

Initializes a new instance of the OutlookImporter class.

Overload List

Name | Description
OutlookImporter (Schedule) | Initializes a new instance of the OutlookImporter class with the specified Schedule object.
OutlookImporter (Schedule, Object, Object) | Initializes a new instance of the OutlookImporter class and initializes it with the specified Schedule object.

See Also

OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Constructor (Schedule)

OutlookImporter Constructor (Schedule)
See Also

Initializes a new instance of the OutlookImporter class with the specified Schedule object.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public OutlookImporter (
Schedule schedule
)
Visual Basic

Public Sub OutlookImporter ( _
schedule As Schedule _
)

Parameters

schedule
A Schedule object where the data will be imported.

See Also

OutlookImporter Constructor Overload List
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Constructor (Schedule, Object, Object)

OutlookImporter Constructor (Schedule, Object, Object)
See Also

Initializes a new instance of the OutlookImporter class and initializes it with the specified Schedule object.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public OutlookImporter (
Schedule schedule,
Object profile,
Object password
)
Visual Basic

Public Sub OutlookImporter ( _
schedule As Schedule, _
profile As Object, _
password As Object _
)

Parameters

schedule
A Schedule object where the data will be imported.
profile
Outlook's profile name. Pass null (Nothing in Visual Basic) or empty string for default profile.
password
Profile's password. If no password is required by mentioned profile pass null or empty string.

See Also

OutlookImporter Constructor Overload List
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Methods

OutlookImporter Methods

Public Methods

Name | Description
ImportContacts | Imports all contacts from Outlook to the associated schedule.
ImportItems | Imports all events from Outlook to the associated schedule.
ImportTasks | Imports all tasks from Outlook to the associated schedule.

Protected Methods

Name | Description
OnContactImporting | Raises the ContactImporting event.
OnItemImporting | Raises the ItemImporting event.
OnTaskImporting | Raises the TaskImporting event.

See Also

OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.ImportContacts Method

OutlookImporter.ImportContacts Method

Imports all contacts from Outlook to the associated schedule.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public void ImportContacts ()
Visual Basic

Public Sub ImportContacts ()

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ImportItems Method
ImportTasks Method


MindFusion.Scheduling.Outlook.OutlookImporter.ImportItems Method

OutlookImporter.ImportItems Method

Imports all events from Outlook to the associated schedule.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public void ImportItems ()
Visual Basic

Public Sub ImportItems ()

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ImportContacts Method
ImportTasks Method


MindFusion.Scheduling.Outlook.OutlookImporter.ImportTasks Method

OutlookImporter.ImportTasks Method

Imports all tasks from Outlook to the associated schedule.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public void ImportTasks ()
Visual Basic

Public Sub ImportTasks ()

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ImportContacts Method
ImportItems Method


MindFusion.Scheduling.Outlook.OutlookImporter.OnContactImporting Method

OutlookImporter.OnContactImporting Method

Raises the ContactImporting event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

protected virtual void OnContactImporting (
ContactConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnContactImporting ( _
e As ContactConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.OnItemImporting Method

OutlookImporter.OnItemImporting Method

Raises the ItemImporting event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

protected virtual void OnItemImporting (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemImporting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.OnTaskImporting Method

OutlookImporter.OnTaskImporting Method

Raises the TaskImporting event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

protected virtual void OnTaskImporting (
TaskConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnTaskImporting ( _
e As TaskConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Properties

OutlookImporter Properties

Public Properties

Name | Description
ItemType | Gets or sets the type of the items that will be created by the importer. The default value, null, indicates items of type Appointment.
Schedule | Gets or sets the Schedule, associated with the importer.

See Also

OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.ItemType Property

OutlookImporter.ItemType Property

Gets or sets the type of the items that will be created by the importer. The default value, null, indicates items of type Appointment.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public Type ItemType { get; set; }
Visual Basic

Public Property ItemType As Type

Property Value

An object of type Type that specifies the type of items the importer class should create when importing items from Outlook. The default value, null, indicates items of type Appointment.

Remarks

You usually need to set this property when you are using custom items and would want the items created by the importer class to be of your custom type instead of Appointment. The specified type should derive, directly or indirectly, from Item and should provide a parameterless constructor.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.Schedule Property

OutlookImporter.Schedule Property

Gets or sets the Schedule, associated with the importer.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public Schedule Schedule { get; set; }
Visual Basic

Public Property Schedule As Schedule

Property Value

A Schedule object where the data from Outlook is imported.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Events

OutlookImporter Events

Public Events

Name | Description
ContactImporting | Fired for each contact to confirm that the contact should be imported.
ItemImporting | Fired for each item to confirm that the item should be imported.
TaskImporting | Fired for each task to confirm that the task should be imported.

See Also

OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.ContactImporting Event

OutlookImporter.ContactImporting Event

Fired for each contact to confirm that the contact should be imported.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public event EventHandler<ContactConfirmEventArgs> ContactImporting
Visual Basic

Public Event ContactImporting As EventHandler(Of ContactConfirmEventArgs)

Event Data

ContactImporting event handlers receive an argument of type ContactConfirmEventArgs.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ItemImporting Event
TaskImporting Event


MindFusion.Scheduling.Outlook.OutlookImporter.ItemImporting Event

OutlookImporter.ItemImporting Event

Fired for each item to confirm that the item should be imported.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public event EventHandler<ItemConfirmEventArgs> ItemImporting
Visual Basic

Public Event ItemImporting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemImporting event handlers receive an argument of type ItemConfirmEventArgs.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ContactImporting Event
TaskImporting Event


MindFusion.Scheduling.Outlook.OutlookImporter.TaskImporting Event

OutlookImporter.TaskImporting Event

Fired for each task to confirm that the task should be imported.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public event EventHandler<TaskConfirmEventArgs> TaskImporting
Visual Basic

Public Event TaskImporting As EventHandler(Of TaskConfirmEventArgs)

Event Data

TaskImporting event handlers receive an argument of type TaskConfirmEventArgs.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ContactImporting Event
ItemImporting Event


MindFusion.Scheduling.Outlook.TaskConfirmEventArgs Class

TaskConfirmEventArgs Class

Contains the arguments passed to handlers of task validation events.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public class TaskConfirmEventArgs : EventArgs
Visual Basic

Public Class TaskConfirmEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Outlook.TaskConfirmEventArgs

See Also

TaskConfirmEventArgs Members
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.TaskConfirmEventArgs Members

TaskConfirmEventArgs Members
Properties

Contains the arguments passed to handlers of task validation events.

The following tables list the members exposed by the TaskConfirmEventArgs type.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Task | Gets the task related to the event.

See Also

TaskConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.TaskConfirmEventArgs Properties

TaskConfirmEventArgs Properties

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Task | Gets the task related to the event.

See Also

TaskConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.TaskConfirmEventArgs.Confirm Property

TaskConfirmEventArgs.Confirm Property

Gets or sets a value indicating whether the operation is confirmed.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public bool Confirm { get; set; }
Visual Basic

Public Property Confirm As Boolean

Property Value

true to confirm the operation; false to decline it. The default is true.

See Also

TaskConfirmEventArgs Members
TaskConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.TaskConfirmEventArgs.Task Property

TaskConfirmEventArgs.Task Property

Gets the task related to the event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Outlook

Syntax

C#

public Task Task { get; }
Visual Basic

Public ReadOnly Property Task As Task

Property Value

An instance of the Task class for which the event is raised.

See Also

TaskConfirmEventArgs Members
TaskConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Reporting Namespace
Classes Enumerations

Classes

Class | Description
ContinuePrintingReportEventArgs | Provides data for the ContinuePrinting event of the Report class.
Report | Provides methods to generate, preview and print reports of Schedule objects.
ReportColumn | Represents a column in the report table.
ReportColumnCollection | Represents a strongly-typed collection of ReportColumn objects.
ReportFilterItemEventArgs | Contains the arguments passed to handlers of the FilterItem event raised by the report class.
ReportOptions | Encapsulates the options controlling the printing and previewing of a MindFusion.Scheduling report.
ReportQueryHeaderTextEventArgs | Contains the arguments passed to handlers of the QueryHeaderText event raised by the report class.
ReportQueryStyleEventArgs | Contains the arguments passed to handlers of the QueryStyle event raised by the Report class.
ReportQueryTextEventArgs | Contains the arguments passed to handlers of the QueryText event raised by the Report class.

Enumerations

Enumeration | Description
ReportGroupType | Specifies grouping criteria for MindFusion.Scheduling reports.
Sort | Specifies a sorting order.


MindFusion.Scheduling.Reporting.ContinuePrintingReportEventArgs Class

ContinuePrintingReportEventArgs Class

Provides data for the ContinuePrinting event of the Report class.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public class ContinuePrintingReportEventArgs : EventArgs
Visual Basic

Public Class ContinuePrintingReportEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Reporting.ContinuePrintingReportEventArgs

See Also

ContinuePrintingReportEventArgs Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ContinuePrintingReportEventArgs Members

ContinuePrintingReportEventArgs Members
Properties Methods

Provides data for the ContinuePrinting event of the Report class.

The following tables list the members exposed by the ContinuePrintingReportEventArgs type.

Public Properties

Name | Description
Report | Gets a reference to the Report control being printed.

Public Methods

Name | Description
ContinuePrinting | Call this method if you want the print operation to continue on a new page with the view settings specified in the Calendar control. Call this method only once per event to avoid unnecessary calculations.

See Also

ContinuePrintingReportEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ContinuePrintingReportEventArgs Methods

ContinuePrintingReportEventArgs Methods

Public Methods

Name | Description
ContinuePrinting | Call this method if you want the print operation to continue on a new page with the view settings specified in the Calendar control. Call this method only once per event to avoid unnecessary calculations.

See Also

ContinuePrintingReportEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ContinuePrintingReportEventArgs.ContinuePrinting Method

ContinuePrintingReportEventArgs.ContinuePrinting Method

Call this method if you want the print operation to continue on a new page with the view settings specified in the Calendar control. Call this method only once per event to avoid unnecessary calculations.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public void ContinuePrinting ()
Visual Basic

Public Sub ContinuePrinting ()

See Also

ContinuePrintingReportEventArgs Members
ContinuePrintingReportEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ContinuePrintingReportEventArgs Properties

ContinuePrintingReportEventArgs Properties

Public Properties

Name | Description
Report | Gets a reference to the Report control being printed.

See Also

ContinuePrintingReportEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ContinuePrintingReportEventArgs.Report Property

ContinuePrintingReportEventArgs.Report Property

Gets a reference to the Report control being printed.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Report Report { get; }
Visual Basic

Public ReadOnly Property Report As Report

Property Value

An instance of the Report class.

See Also

ContinuePrintingReportEventArgs Members
ContinuePrintingReportEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report Class

Report Class

Provides methods to generate, preview and print reports of Schedule objects.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public class Report
Visual Basic

Public Class Report

Example

The following example illustrates how to create a simple report and print out the headers and start and end times of the items contained in a schedule. The example assumes that the variable theSchedule references an existing Schedule object.

C#

Report report = new Report();

ReportColumn column = null;

// Create the column representing the item header
column = report.CreateColumn();
column.Property = "HeaderText";
column.Width = 100;
report.Columns.Add(column);

// Create the column representing the item start time
column = report.CreateColumn();
column.Property = "StartTime";
column.Width = 50;
report.Columns.Add(column);

// Create the column representing the item end time
column = report.CreateColumn();
column.Property = "EndTime";
column.Width = 50;
report.Columns.Add(column);

report.Schedule = theSchedule;
report.Preview(DateTime.MinValue, DateTime.MaxValue);
Visual Basic

Dim report as New Report()

Dim column As ReportColumn = Nothing

' Create the column representing the item header
column = report.CreateColumn()
column.Property = "HeaderText"
column.Width = 100
report.Columns.Add(column)

' Create the column representing the item start time
column = report.CreateColumn()
column.Property = "StartTime"
column.Width = 50
report.Columns.Add(column)

' Create the column representing the item end time
column = report.CreateColumn()
column.Property = "EndTime"
column.Width = 50
report.Columns.Add(column)

report.Schedule = theSchedule
report.Preview(DateTime.MinValue, DateTime.MaxValue)

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Reporting.Report

See Also

Report Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report Members

Report Members
Constructors Properties Methods Events

Provides methods to generate, preview and print reports of Schedule objects.

The following tables list the members exposed by the Report type.

Public Constructors

Name | Description
Report | Initializes a new instance of the Report class.

Public Properties

Name | Description
Columns | Gets a collection with all columns in the report.
Options | Gets the options, controlling the print output.
Schedule | Gets or sets the schedule to be printed or previewed by the report.

Public Methods

Name | Description
CreateColumn | Creates a new report column.
Preview | Overloaded. Previews the report.
Print | Overloaded. Prints the report.

Protected Methods

Name | Description
OnContinuePrinting | Raises the ContinuePrinting event.
OnFilterItem | Raises the FilterItem event.
OnQueryHeaderText | Raises the QueryHeaderText event.
OnQueryStyle | Raises the QueryStyle event.
OnQueryText | Raises the QueryText event.

Public Events

Name | Description
ContinuePrinting | Raised at the end of a printing operation to enable users to continue printing the report with different view settings.
FilterItem | Raised for each individual item in the report during printing or previewing to confirm the item's availability in the report.
QueryHeaderText | Raised to allow clients to customize the text of column headers.
QueryStyle | Raised during the printing or previewing to allow clients to customize the style of elements displayed in the report.
QueryText | Raised during the printing or previewing to allow clients to customize particular texts displayed in the report.

See Also

Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report Constructor

Report Constructor

Initializes a new instance of the Report class.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Report ()
Visual Basic

Public Sub New ()

See Also

Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report Methods

Report Methods

Public Methods

Name | Description
CreateColumn | Creates a new report column.
Preview | Overloaded. Previews the report.
Print | Overloaded. Prints the report.

Protected Methods

Name | Description
OnContinuePrinting | Raises the ContinuePrinting event.
OnFilterItem | Raises the FilterItem event.
OnQueryHeaderText | Raises the QueryHeaderText event.
OnQueryStyle | Raises the QueryStyle event.
OnQueryText | Raises the QueryText event.

See Also

Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.CreateColumn Method

Report.CreateColumn Method

Creates a new report column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public ReportColumn CreateColumn ()
Visual Basic

Public Function CreateColumn () As ReportColumn

Return Value

An instance of the ReportColumn class representing a newly created column, compatible with the report.

Remarks

Once the column is created, you can add it to the report by calling the Add method on the ReportColumnCollection returned by the Columns property. A column should be added only to the report that was used to create it.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.OnContinuePrinting Method

Report.OnContinuePrinting Method

Raises the ContinuePrinting event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

protected virtual void OnContinuePrinting (
ContinuePrintingReportEventArgs e
)
Visual Basic

Protected Overridable Sub OnContinuePrinting ( _
e As ContinuePrintingReportEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.OnFilterItem Method

Report.OnFilterItem Method

Raises the FilterItem event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

protected void OnFilterItem (
ReportFilterItemEventArgs e
)
Visual Basic

Protected Sub OnFilterItem ( _
e As ReportFilterItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.OnQueryHeaderText Method

Report.OnQueryHeaderText Method

Raises the QueryHeaderText event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

protected void OnQueryHeaderText (
ReportQueryHeaderTextEventArgs e
)
Visual Basic

Protected Sub OnQueryHeaderText ( _
e As ReportQueryHeaderTextEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.OnQueryStyle Method

Report.OnQueryStyle Method

Raises the QueryStyle event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

protected void OnQueryStyle (
ReportQueryStyleEventArgs e
)
Visual Basic

Protected Sub OnQueryStyle ( _
e As ReportQueryStyleEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.OnQueryText Method

Report.OnQueryText Method

Raises the QueryText event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

protected void OnQueryText (
ReportQueryTextEventArgs e
)
Visual Basic

Protected Sub OnQueryText ( _
e As ReportQueryTextEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.Preview Method

Report.Preview Method

Previews the report.

Overload List

Name | Description
Report.Preview (DateTime, DateTime) | Generates a print preview of the items in the specified range from the underlying schedule.
Report.Preview (PrintDocument, DateTime, DateTime) | Generates a print preview of the items in the specified range from the underlying schedule.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.Preview Method (DateTime, DateTime)

Report.Preview Method (DateTime, DateTime)
See Also

Generates a print preview of the items in the specified range from the underlying schedule.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public void Preview (
DateTime start,
DateTime end
)
Visual Basic

Public Sub Preview ( _
start As DateTime, _
end As DateTime _
)

Parameters

start
A .NET DateTime object, specifying the beginning of the time interval containing the items to be included in the report.
end
A .NET DateTime object, specifying the end of the time interval containing the items to be included in the report.

Remarks

Use the start and end parameters when there are infinite recurring items in your schedule. Otherwise, it is safe to specify DateTime.MinValue and DateTime.MaxValue for the start and end time parameters respectively to ensure all items will get included in the report.

Note

Make sure you assign a Schedule object to the report through its Schedule property. Calling this method before doing this will result in an InvalidOperationException.

See Also

Preview Method Overload List
Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace
Print Method


MindFusion.Scheduling.Reporting.Report.Preview Method (PrintDocument, DateTime, DateTime)

Report.Preview Method (PrintDocument, DateTime, DateTime)
See Also

Generates a print preview of the items in the specified range from the underlying schedule.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public void Preview (
PrintDocument doc,
DateTime start,
DateTime end
)
Visual Basic

Public Sub Preview ( _
doc As PrintDocument, _
start As DateTime, _
end As DateTime _
)

Parameters

doc
A .NET PrintDocument object to print to.
start
A .NET DateTime object, specifying the beginning of the time interval containing the items to be included in the report.
end
A .NET DateTime object, specifying the end of the time interval containing the items to be included in the report.

Remarks

Use the start and end parameters when there are infinite recurring items in your schedule. Otherwise, it is safe to specify DateTime.MinValue and DateTime.MaxValue for the start and end time parameters respectively to ensure all items will get included in the report.

Note

Make sure you assign a Schedule object to the report through its Schedule property. Calling this method before doing this will result in an InvalidOperationException.

See Also

Preview Method Overload List
Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace
Print Method


MindFusion.Scheduling.Reporting.Report.Print Method

Report.Print Method

Prints the report.

Overload List

Name | Description
Report.Print (DateTime, DateTime) | Prints the items in the specified range from the underlying schedule.
Report.Print (PrintDocument, DateTime, DateTime) | Prints the items in the specified range from the underlying schedule.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.Print Method (DateTime, DateTime)

Report.Print Method (DateTime, DateTime)
See Also

Prints the items in the specified range from the underlying schedule.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public void Print (
DateTime start,
DateTime end
)
Visual Basic

Public Sub Print ( _
start As DateTime, _
end As DateTime _
)

Parameters

start
A .NET DateTime object, specifying the beginning of the time interval containing the items to be included in the report.
end
A .NET DateTime object, specifying the end of the time interval containing the items to be included in the report.

Remarks

Use the start and end parameters when there are infinite recurring items in your schedule. Otherwise, it is safe to specify DateTime.MinValue and DateTime.MaxValue for the start and end time parameters respectively to ensure all items will get included in the report.

Note

Make sure you assign a Schedule object to the report through its Schedule property. Calling this method before doing this will result in an InvalidOperationException.

See Also

Print Method Overload List
Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace
Preview Method


MindFusion.Scheduling.Reporting.Report.Print Method (PrintDocument, DateTime, DateTime)

Report.Print Method (PrintDocument, DateTime, DateTime)
See Also

Prints the items in the specified range from the underlying schedule.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public void Print (
PrintDocument doc,
DateTime start,
DateTime end
)
Visual Basic

Public Sub Print ( _
doc As PrintDocument, _
start As DateTime, _
end As DateTime _
)

Parameters

doc
A .NET PrintDocument object to print to.
start
A .NET DateTime object, specifying the beginning of the time interval containing the items to be included in the report.
end
A .NET DateTime object, specifying the end of the time interval containing the items to be included in the report.

Remarks

Use the start and end parameters when there are infinite recurring items in your schedule. Otherwise, it is safe to specify DateTime.MinValue and DateTime.MaxValue for the start and end time parameters respectively to ensure all items will get included in the report.

Note

Make sure you assign a Schedule object to the report through its Schedule property. Calling this method before doing this will result in an InvalidOperationException.

See Also

Print Method Overload List
Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace
Preview Method


MindFusion.Scheduling.Reporting.Report Properties

Report Properties

Public Properties

Name | Description
Columns | Gets a collection with all columns in the report.
Options | Gets the options, controlling the print output.
Schedule | Gets or sets the schedule to be printed or previewed by the report.

See Also

Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.Columns Property

Report.Columns Property

Gets a collection with all columns in the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public ReportColumnCollection Columns { get; }
Visual Basic

Public ReadOnly Property Columns As ReportColumnCollection

Property Value

An instance of the ReportColumnCollection class containing the columns associated with this report. Use this collection to modify the columns produced by the report.

Remarks

You create new report columns by calling the CreateColumn method on the Report class. Then you add the new column to the report by calling the Add method on the ReportColumnCollection returned by this property.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.Options Property

Report.Options Property

Gets the options, controlling the print output.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public ReportOptions Options { get; }
Visual Basic

Public ReadOnly Property Options As ReportOptions

Property Value

An instance of the ReportOptions class containing various report settings.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.Schedule Property

Report.Schedule Property

Gets or sets the schedule to be printed or previewed by the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Schedule Schedule { get; set; }
Visual Basic

Public Property Schedule As Schedule

Property Value

An instance of the Schedule class containing the items to be displayed in the report.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report Events

Report Events

Public Events

Name | Description
ContinuePrinting | Raised at the end of a printing operation to enable users to continue printing the report with different view settings.
FilterItem | Raised for each individual item in the report during printing or previewing to confirm the item's availability in the report.
QueryHeaderText | Raised to allow clients to customize the text of column headers.
QueryStyle | Raised during the printing or previewing to allow clients to customize the style of elements displayed in the report.
QueryText | Raised during the printing or previewing to allow clients to customize particular texts displayed in the report.

See Also

Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.ContinuePrinting Event

Report.ContinuePrinting Event

Raised at the end of a printing operation to enable users to continue printing the report with different view settings.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public event EventHandler<ContinuePrintingReportEventArgs> ContinuePrinting
Visual Basic

Public Event ContinuePrinting As EventHandler(Of ContinuePrintingReportEventArgs)

Event Data

ContinuePrinting event handlers receive an argument of type ContinuePrintingReportEventArgs.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.FilterItem Event

Report.FilterItem Event

Raised for each individual item in the report during printing or previewing to confirm the item's availability in the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public event EventHandler<ReportFilterItemEventArgs> FilterItem
Visual Basic

Public Event FilterItem As EventHandler(Of ReportFilterItemEventArgs)

Event Data

FilterItem event handlers receive an argument of type ReportFilterItemEventArgs.

Remarks

This event can be used to filter out items that are not to be displayed in the report. To prevent item from displaying, set the Filter property of the accompanying event data object to true.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.QueryHeaderText Event

Report.QueryHeaderText Event

Raised to allow clients to customize the text of column headers.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public event EventHandler<ReportQueryHeaderTextEventArgs> QueryHeaderText
Visual Basic

Public Event QueryHeaderText As EventHandler(Of ReportQueryHeaderTextEventArgs)

Event Data

QueryHeaderText event handlers receive an argument of type ReportQueryHeaderTextEventArgs.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.QueryStyle Event

Report.QueryStyle Event

Raised during the printing or previewing to allow clients to customize the style of elements displayed in the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public event EventHandler<ReportQueryStyleEventArgs> QueryStyle
Visual Basic

Public Event QueryStyle As EventHandler(Of ReportQueryStyleEventArgs)

Event Data

QueryStyle event handlers receive an argument of type ReportQueryStyleEventArgs.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.QueryText Event

Report.QueryText Event

Raised during the printing or previewing to allow clients to customize particular texts displayed in the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public event EventHandler<ReportQueryTextEventArgs> QueryText
Visual Basic

Public Event QueryText As EventHandler(Of ReportQueryTextEventArgs)

Event Data

QueryText event handlers receive an argument of type ReportQueryTextEventArgs.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn Class

ReportColumn Class

Represents a column in the report table.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public class ReportColumn
Visual Basic

Public Class ReportColumn

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Reporting.ReportColumn

See Also

ReportColumn Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn Members

ReportColumn Members
Properties

Represents a column in the report table.

The following tables list the members exposed by the ReportColumn type.

Public Properties

Name | Description
AlternativeStyle | Gets or sets the style used for the alternative rows in this column.
Header | Gets or sets the header text of the column.
Property | Gets or sets the name of the property of the Item class whose value will be displayed in the column.
Sort | Gets or sets the sort of the column.
SortPriority | Gets or sets the sort priority of the column.
Style | Gets or sets the style of the column.
Visible | Gets or sets a value indicating whether the column is displayed in the report.
Width | Gets or sets the width of the column.

See Also

ReportColumn Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn Properties

ReportColumn Properties

Public Properties

Name | Description
AlternativeStyle | Gets or sets the style used for the alternative rows in this column.
Header | Gets or sets the header text of the column.
Property | Gets or sets the name of the property of the Item class whose value will be displayed in the column.
Sort | Gets or sets the sort of the column.
SortPriority | Gets or sets the sort priority of the column.
Style | Gets or sets the style of the column.
Visible | Gets or sets a value indicating whether the column is displayed in the report.
Width | Gets or sets the width of the column.

See Also

ReportColumn Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn.AlternativeStyle Property

ReportColumn.AlternativeStyle Property

Gets or sets the style used for the alternative rows in this column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Style AlternativeStyle { get; set; }
Visual Basic

Public Property AlternativeStyle As Style

Property Value

An instance of the Style class specifying the appearance of alternative cells in this column.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace
Style Property


MindFusion.Scheduling.Reporting.ReportColumn.Header Property

ReportColumn.Header Property

Gets or sets the header text of the column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public string Header { get; set; }
Visual Basic

Public Property Header As String

Property Value

A string containing the text displayed in the column's header.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn.Property Property

ReportColumn.Property Property

Gets or sets the name of the property of the Item class whose value will be displayed in the column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public string Property { get; set; }
Visual Basic

Public Property Property As String

Property Value

A string containing the name of the property whose value should be displayed in this column.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn.Sort Property

ReportColumn.Sort Property

Gets or sets the sort of the column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Sort Sort { get; set; }
Visual Basic

Public Property Sort As Sort

Property Value

A value of the Sort enumeration specifying the sort type for this column. Use None to disable sorting.

Remarks

If you specify sorting by more than one column, you can use the SortPriority property to determine which sort should have greater priority.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace
SortPriority Property


MindFusion.Scheduling.Reporting.ReportColumn.SortPriority Property

ReportColumn.SortPriority Property

Gets or sets the sort priority of the column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public int SortPriority { get; set; }
Visual Basic

Public Property SortPriority As Integer

Property Value

An integer value specifying the sorting priority of this column.

Remarks

Columns with higher sort priority take precedence during sorting.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace
Sort Property


MindFusion.Scheduling.Reporting.ReportColumn.Style Property

ReportColumn.Style Property

Gets or sets the style of the column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Style Style { get; set; }
Visual Basic

Public Property Style As Style

Property Value

An instance of the Style class specifying the appearance of the cells in the column.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace
AlternativeStyle Property


MindFusion.Scheduling.Reporting.ReportColumn.Visible Property

ReportColumn.Visible Property

Gets or sets a value indicating whether the column is displayed in the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public bool Visible { get; set; }
Visual Basic

Public Property Visible As Boolean

Property Value

A Boolean value indicating whether the column will be displayed in the report.

Remarks

Invisible columns can still be used for sorting.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn.Width Property

ReportColumn.Width Property

Gets or sets the width of the column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public int Width { get; set; }
Visual Basic

Public Property Width As Integer

Property Value

An integer value, specifying the width of the column.

Remarks

The width of the column is expressed in either percents or as hundredths of an inch depending on the ReportOptions.AbsoluteColumnWidth property.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumnCollection Class

ReportColumnCollection Class

Represents a strongly-typed collection of ReportColumn objects.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public sealed class ReportColumnCollection : CollectionBase
Visual Basic

Public NotInheritable Class ReportColumnCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.Reporting.ReportColumnCollection

See Also

ReportColumnCollection Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumnCollection Members

ReportColumnCollection Members
Constructors Properties Methods

Represents a strongly-typed collection of ReportColumn objects.

The following tables list the members exposed by the ReportColumnCollection type.

Public Constructors

Name | Description
ReportColumnCollection | Initializes a new instance of the ReportColumnCollection class.

Public Properties

Name | Description
Item | Gets or sets the column object located at the specified position within this collection.

Public Methods

Name | Description
Add | Adds the specified column to this collection.
Clear | Removes all elements from the collection.
Contains | Determines whether this collection contains the specified column.
Insert | Inserts the specified ReportColumn object at the specified position within the collection.
Remove | Removes the first occurrence of the specified ReportColumn object from this collection.

See Also

ReportColumnCollection Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumnCollection Constructor

ReportColumnCollection Constructor

Initializes a new instance of the ReportColumnCollection class.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public ReportColumnCollection ()
Visual Basic

Public Sub New ()

See Also

ReportColumnCollection Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumnCollection Methods

ReportColumnCollection Methods

Public Methods

Name | Description
Add | Adds the specified column to this collection.
Clear | Removes all elements from the collection.
Contains | Determines whether this collection contains the specified column.
Insert | Inserts the specified ReportColumn object at the specified position within the collection.
Remove | Removes the first occurrence of the specified ReportColumn object from this collection.

Protected Methods

Name Description

See Also

ReportColumnCollection Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumnCollection.Add Method

ReportColumnCollection.Add Method

Adds the specified column to this collection.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public void Add (
ReportColumn column
)
Visual Basic

Public Sub Add ( _
column As ReportColumn _
)

Parameters

column
An instance of the ReportColumn class to be added to the collection.

See Also

ReportColumnCollection Members
ReportColumnCollection Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumnCollection.Clear Method

ReportColumnCollection.Clear Method

Removes all elements from the collection.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

ReportColumnCollection Members
ReportColumnCollection Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumnCollection.Contains Method

ReportColumnCollection.Contains Method

Determines whether this collection contains the specified column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public bool Contains (
ReportColumn column
)
Visual Basic

Public Function Contains ( _
column As ReportColumn _
) As Boolean

Parameters

column
The ReportColumn object to search for in the collection.

Return Value

true if the object is found within the collection; otherwise, false.

See Also

ReportColumnCollection Members
ReportColumnCollection Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumnCollection.Insert Method

ReportColumnCollection.Insert Method

Inserts the specified ReportColumn object at the specified position within the collection.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public void Insert (
int index,
ReportColumn column
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
column As ReportColumn _
)

Parameters

index
The zero-based position at which the column must be inserted.
column
An instance of the ReportColumn class to be added to the collection.

See Also

ReportColumnCollection Members
ReportColumnCollection Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumnCollection.Remove Method

ReportColumnCollection.Remove Method

Removes the first occurrence of the specified ReportColumn object from this collection.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public void Remove (
ReportColumn column
)
Visual Basic

Public Sub Remove ( _
column As ReportColumn _
)

Parameters

column
A ReportColumn instance which must be removed from the collection.

See Also

ReportColumnCollection Members
ReportColumnCollection Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumnCollection Properties

ReportColumnCollection Properties

Public Properties

Name | Description
Item | Gets or sets the column object located at the specified position within this collection.

See Also

ReportColumnCollection Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumnCollection.Item Property

ReportColumnCollection.Item Property

Gets or sets the column object located at the specified position within this collection.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public ReportColumn Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As ReportColumn

Parameters

index
The zero-based index of the ReportColumn object to set or retrieve.

Property Value

An instance of the ReportColumn class located at the specified index.

See Also

ReportColumnCollection Members
ReportColumnCollection Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs Class

ReportFilterItemEventArgs Class

Contains the arguments passed to handlers of the FilterItem event raised by the report class.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public class ReportFilterItemEventArgs : EventArgs
Visual Basic

Public Class ReportFilterItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs

See Also

ReportFilterItemEventArgs Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs Members

ReportFilterItemEventArgs Members
Properties

Contains the arguments passed to handlers of the FilterItem event raised by the report class.

The following tables list the members exposed by the ReportFilterItemEventArgs type.

Public Properties

Name | Description
Filter | Gets or sets a value indicating whether the item should be filtered out of the report.
Item | Gets the item related to the event.
Resource | Gets the resource related to the item in a grouped report.

See Also

ReportFilterItemEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs Properties

ReportFilterItemEventArgs Properties

Public Properties

Name | Description
Filter | Gets or sets a value indicating whether the item should be filtered out of the report.
Item | Gets the item related to the event.
Resource | Gets the resource related to the item in a grouped report.

See Also

ReportFilterItemEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs.Filter Property

ReportFilterItemEventArgs.Filter Property

Gets or sets a value indicating whether the item should be filtered out of the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public bool Filter { get; set; }
Visual Basic

Public Property Filter As Boolean

Property Value

A Boolean value, specifying whether the item should be removed from the report.

Remarks

Specify true for this property to filter the item.

See Also

ReportFilterItemEventArgs Members
ReportFilterItemEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs.Item Property

ReportFilterItemEventArgs.Item Property

Gets the item related to the event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Item Item { get; }
Visual Basic

Public ReadOnly Property Item As Item

Property Value

A reference to the item associated with the event.

See Also

ReportFilterItemEventArgs Members
ReportFilterItemEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs.Resource Property

ReportFilterItemEventArgs.Resource Property

Gets the resource related to the item in a grouped report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Resource Resource { get; }
Visual Basic

Public ReadOnly Property Resource As Resource

Property Value

An instance of the Resource class or null (Nothing in Visual Basic) if the report is not grouped.

Remarks

In a grouped report the event FilterItem is fired once for each resource an item is associated with. This way it is possible to filter the same item for one resource and to retain it for another.

See Also

ReportFilterItemEventArgs Members
ReportFilterItemEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportGroupType Enumeration

ReportGroupType Enumeration

Specifies grouping criteria for MindFusion.Scheduling reports.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public enum ReportGroupType
Visual Basic

Public Enumeration ReportGroupType

Members

Member name | Description
ByContacts | Indicates grouping by contacts.
ByLocations | Indicates grouping by locations.
ByResources | Indicates grouping by resources.
ByTasks | Indicates grouping by tasks.
None | Indicates that grouping is disabled.

See Also

MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions Class

ReportOptions Class

Encapsulates the options controlling the printing and previewing of a MindFusion.Scheduling report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public class ReportOptions
Visual Basic

Public Class ReportOptions

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Reporting.ReportOptions

See Also

ReportOptions Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions Members

ReportOptions Members
Properties

Encapsulates the options controlling the printing and previewing of a MindFusion.Scheduling report.

The following tables list the members exposed by the ReportOptions type.

Public Properties

Name | Description
AbsoluteColumnWidth | Gets or sets a value indicating whether the width specified for individual columns are expressed in units relative to the page width or as points.
AlternativeStyle | Gets or sets the default style for alternative rows.
CellPadding | Gets or sets the padding of the resource cells, expressed in hundredths of an inch.
ColumnSpacing | Gets or sets the spacing between adjacent columns, expressed in hundredths of an inch.
DocumentName | Gets or sets the name of the print document.
FixedRowHeight | Gets or sets a value indicating whether to use a fixed row height as specified by the RowHeight property or to calculate the height of individual rows according to the contained text.
GroupHeaderStyle | Gets or sets the style of the resource headers in a grouped report.
GroupType | Gets or sets a value indicating whether grouping is enabled within the report.
HeaderHeight | Gets or sets the height of the columns' header, expressed in hundredths of an inch.
HeaderSpacing | Gets or sets the spacing between the header and the contents, expressed in hundredths of an inch.
Landscape | Gets or sets the orientation of the pages.
PageMargins | Gets or sets the page margins.
RowHeight | Gets or sets the height of individual rows, expressed in hundredths of an inch.
RowSpacing | Gets or sets the spacing between adjacent rows, expressed in hundredths of an inch.
ShowHeader | Gets or sets a value indicating whether the columns headers are displayed.
ShowHeadersOnAllPages | Gets or sets a value indicating whether the column headers are displayed on top of each page or only on the first one.
Style | Gets or sets the default style used for columns in the report.

See Also

ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions Properties

ReportOptions Properties

Public Properties

Name | Description
AbsoluteColumnWidth | Gets or sets a value indicating whether the width specified for individual columns are expressed in units relative to the page width or as points.
AlternativeStyle | Gets or sets the default style for alternative rows.
CellPadding | Gets or sets the padding of the resource cells, expressed in hundredths of an inch.
ColumnSpacing | Gets or sets the spacing between adjacent columns, expressed in hundredths of an inch.
DocumentName | Gets or sets the name of the print document.
FixedRowHeight | Gets or sets a value indicating whether to use a fixed row height as specified by the RowHeight property or to calculate the height of individual rows according to the contained text.
GroupHeaderStyle | Gets or sets the style of the resource headers in a grouped report.
GroupType | Gets or sets a value indicating whether grouping is enabled within the report.
HeaderHeight | Gets or sets the height of the columns' header, expressed in hundredths of an inch.
HeaderSpacing | Gets or sets the spacing between the header and the contents, expressed in hundredths of an inch.
Landscape | Gets or sets the orientation of the pages.
PageMargins | Gets or sets the page margins.
RowHeight | Gets or sets the height of individual rows, expressed in hundredths of an inch.
RowSpacing | Gets or sets the spacing between adjacent rows, expressed in hundredths of an inch.
ShowHeader | Gets or sets a value indicating whether the columns headers are displayed.
ShowHeadersOnAllPages | Gets or sets a value indicating whether the column headers are displayed on top of each page or only on the first one.
Style | Gets or sets the default style used for columns in the report.

See Also

ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.AbsoluteColumnWidth Property

ReportOptions.AbsoluteColumnWidth Property

Gets or sets a value indicating whether the width specified for individual columns are expressed in units relative to the page width or as points.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public bool AbsoluteColumnWidth { get; set; }
Visual Basic

Public Property AbsoluteColumnWidth As Boolean

Property Value

true to indicate that the numbers specified for the ReportColumn.Width property should be interpreted as printer units (a hundredths of an inch); false to indicate that the numbers should be treated as relative units (see below). The default is false.

Remarks

When this property is set to false all columns in the report fit in a single page and the actual width of each individual column relates to the total width of the page as the column Width relates to the total width of all columns. If, for example, you have two columns, the width of the first column is 100 and the width of the second column is 200, then the columns would exactly fit in the page and the second column would be twice as wide as the first one. Specifying the values 1 and 2 for those columns respectively would yield the same result when AbsoluteColumnWidth is set to false.

If this property is set to true, the numbers specified for the column width is interpreted as absolute printer dots.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.AlternativeStyle Property

ReportOptions.AlternativeStyle Property

Gets or sets the default style for alternative rows.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Style AlternativeStyle { get; set; }
Visual Basic

Public Property AlternativeStyle As Style

Property Value

An instance of the Style class specifying the default appearance of alternative cells in the report.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace
Style Property


MindFusion.Scheduling.Reporting.ReportOptions.CellPadding Property

ReportOptions.CellPadding Property

Gets or sets the padding of the resource cells, expressed in hundredths of an inch.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public int CellPadding { get; set; }
Visual Basic

Public Property CellPadding As Integer

Property Value

An integer value, specifying the padding of the contents within cells. The padding is the distance between the contents and the cell border. The default is 2.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.ColumnSpacing Property

ReportOptions.ColumnSpacing Property

Gets or sets the spacing between adjacent columns, expressed in hundredths of an inch.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public int ColumnSpacing { get; set; }
Visual Basic

Public Property ColumnSpacing As Integer

Property Value

An integer value specifying the distance between columns in the report. The default is 0.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.DocumentName Property

ReportOptions.DocumentName Property

Gets or sets the name of the print document.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public string DocumentName { get; set; }
Visual Basic

Public Property DocumentName As String

Property Value

A string value specifying the name of the print document. The default is " - Untitled - ".

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.FixedRowHeight Property

ReportOptions.FixedRowHeight Property

Gets or sets a value indicating whether to use a fixed row height as specified by the RowHeight property or to calculate the height of individual rows according to the contained text.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public bool FixedRowHeight { get; set; }
Visual Basic

Public Property FixedRowHeight As Boolean

Property Value

true, to use the value specified by the RowHeight property; false, to automatically calculate the height of each row so that the text within is not cut.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.GroupHeaderStyle Property

ReportOptions.GroupHeaderStyle Property

Gets or sets the style of the resource headers in a grouped report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Style GroupHeaderStyle { get; set; }
Visual Basic

Public Property GroupHeaderStyle As Style

Property Value

An instance of the Style class specifying the appearance of the resource headers in a grouped report.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace
GroupType Property


MindFusion.Scheduling.Reporting.ReportOptions.GroupType Property

ReportOptions.GroupType Property

Gets or sets a value indicating whether grouping is enabled within the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public ReportGroupType GroupType { get; set; }
Visual Basic

Public Property GroupType As ReportGroupType

Property Value

A member of the ReportGroupType enumeration.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.HeaderHeight Property

ReportOptions.HeaderHeight Property

Gets or sets the height of the columns' header, expressed in hundredths of an inch.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public int HeaderHeight { get; set; }
Visual Basic

Public Property HeaderHeight As Integer

Property Value

An integer value specifying the height of the report header. The default is 25.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.HeaderSpacing Property

ReportOptions.HeaderSpacing Property

Gets or sets the spacing between the header and the contents, expressed in hundredths of an inch.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public int HeaderSpacing { get; set; }
Visual Basic

Public Property HeaderSpacing As Integer

Property Value

An integer value specifying the distance between the header and the rows in the report. The default is 2.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.Landscape Property

ReportOptions.Landscape Property

Gets or sets the orientation of the pages.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public bool Landscape { get; set; }
Visual Basic

Public Property Landscape As Boolean

Property Value

A Boolean value, specifying the orientation of the pages in the report. Set to true to indicate landscape orientation; false to indicate portrait orientation. The default is false.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.PageMargins Property

ReportOptions.PageMargins Property

Gets or sets the page margins.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Margins PageMargins { get; set; }
Visual Basic

Public Property PageMargins As Margins

Property Value

An instance of the .NET Margins class specifying the spacing between the report contents and the physical page border. The default is 0.75 inches from all sides.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.RowHeight Property

ReportOptions.RowHeight Property

Gets or sets the height of individual rows, expressed in hundredths of an inch.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public int RowHeight { get; set; }
Visual Basic

Public Property RowHeight As Integer

Property Value

An integer value specifying the height of individual rows. The default is 20.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.RowSpacing Property

ReportOptions.RowSpacing Property

Gets or sets the spacing between adjacent rows, expressed in hundredths of an inch.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public int RowSpacing { get; set; }
Visual Basic

Public Property RowSpacing As Integer

Property Value

An integer value specifying the distance between rows. The default is 0.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.ShowHeader Property

ReportOptions.ShowHeader Property

Gets or sets a value indicating whether the columns headers are displayed.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public bool ShowHeader { get; set; }
Visual Basic

Public Property ShowHeader As Boolean

Property Value

A Boolean value indicating whether to display column header. The default is true.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.ShowHeadersOnAllPages Property

ReportOptions.ShowHeadersOnAllPages Property

Gets or sets a value indicating whether the column headers are displayed on top of each page or only on the first one.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public bool ShowHeadersOnAllPages { get; set; }
Visual Basic

Public Property ShowHeadersOnAllPages As Boolean

Property Value

A Boolean value indicating whether the column headers should appear on each page. The default is false.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.Style Property

ReportOptions.Style Property

Gets or sets the default style used for columns in the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Style Style { get; set; }
Visual Basic

Public Property Style As Style

Property Value

An instance of the Style class defining the default appearance of cells in the report.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace
AlternativeStyle Property


MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs Class

ReportQueryHeaderTextEventArgs Class

Contains the arguments passed to handlers of the QueryHeaderText event raised by the report class.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public class ReportQueryHeaderTextEventArgs : EventArgs
Visual Basic

Public Class ReportQueryHeaderTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs

See Also

ReportQueryHeaderTextEventArgs Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs Members

ReportQueryHeaderTextEventArgs Members
Properties

Contains the arguments passed to handlers of the QueryHeaderText event raised by the report class.

The following tables list the members exposed by the ReportQueryHeaderTextEventArgs type.

Public Properties

Name | Description
Column | Gets the column whose header text is being processed.
Representation | Gets or sets the text of the column.
Resource | Gets the resource whose header text is being processed when the event is fired for a group header.

See Also

ReportQueryHeaderTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs Properties

ReportQueryHeaderTextEventArgs Properties

Public Properties

Name | Description
Column | Gets the column whose header text is being processed.
Representation | Gets or sets the text of the column.
Resource | Gets the resource whose header text is being processed when the event is fired for a group header.

See Also

ReportQueryHeaderTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs.Column Property

ReportQueryHeaderTextEventArgs.Column Property

Gets the column whose header text is being processed.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public ReportColumn Column { get; }
Visual Basic

Public ReadOnly Property Column As ReportColumn

Property Value

A reference to the report column related to the event.

See Also

ReportQueryHeaderTextEventArgs Members
ReportQueryHeaderTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs.Representation Property

ReportQueryHeaderTextEventArgs.Representation Property

Gets or sets the text of the column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public string Representation { get; set; }
Visual Basic

Public Property Representation As String

Property Value

A string value that specifies the text displayed in the column header.

Remarks

Usually the column header displays the name of the property associated with the column. You can handle the QueryHeaderText event and assign another value to this property to alter this behavior.

See Also

ReportQueryHeaderTextEventArgs Members
ReportQueryHeaderTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs.Resource Property

ReportQueryHeaderTextEventArgs.Resource Property

Gets the resource whose header text is being processed when the event is fired for a group header.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Resource Resource { get; }
Visual Basic

Public ReadOnly Property Resource As Resource

Property Value

An instance of the Resource class or null (Nothing in Visual Basic) if the event is fired for one of the column headers.

See Also

ReportQueryHeaderTextEventArgs Members
ReportQueryHeaderTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs Class

ReportQueryStyleEventArgs Class

Contains the arguments passed to handlers of the QueryStyle event raised by the Report class.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public class ReportQueryStyleEventArgs : EventArgs
Visual Basic

Public Class ReportQueryStyleEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs

See Also

ReportQueryStyleEventArgs Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs Members

ReportQueryStyleEventArgs Members
Properties

Contains the arguments passed to handlers of the QueryStyle event raised by the Report class.

The following tables list the members exposed by the ReportQueryStyleEventArgs type.

Public Properties

Name | Description
Column | Gets the column where the text would appear.
Item | Gets the item related to the event.
Style | Gets or sets the Style to use for the processed cell.
Value | Gets the object that would be displayed.

See Also

ReportQueryStyleEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs Properties

ReportQueryStyleEventArgs Properties

Public Properties

Name | Description
Column | Gets the column where the text would appear.
Item | Gets the item related to the event.
Style | Gets or sets the Style to use for the processed cell.
Value | Gets the object that would be displayed.

See Also

ReportQueryStyleEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs.Column Property

ReportQueryStyleEventArgs.Column Property

Gets the column where the text would appear.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public ReportColumn Column { get; }
Visual Basic

Public ReadOnly Property Column As ReportColumn

Property Value

A reference to the ReportColumn object related to the cell whose Style is being queried.

See Also

ReportQueryStyleEventArgs Members
ReportQueryStyleEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs.Item Property

ReportQueryStyleEventArgs.Item Property

Gets the item related to the event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Item Item { get; }
Visual Basic

Public ReadOnly Property Item As Item

Property Value

A reference to the item related to the cell whose style is being queried.

See Also

ReportQueryStyleEventArgs Members
ReportQueryStyleEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs.Style Property

ReportQueryStyleEventArgs.Style Property

Gets or sets the Style to use for the processed cell.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Style Style { get; set; }
Visual Basic

Public Property Style As Style

Property Value

An instance of the Style class to use for the cell being processed or null (Nothing in Visual Basic) to use the default style.

See Also

ReportQueryStyleEventArgs Members
ReportQueryStyleEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs.Value Property

ReportQueryStyleEventArgs.Value Property

Gets the object that would be displayed.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Object Value { get; }
Visual Basic

Public ReadOnly Property Value As Object

Property Value

The value of the item's property associated with the column the processed cell belongs to. This could be null (Nothing in Visual Basic) if the value of the corresponding item property is null.

See Also

ReportQueryStyleEventArgs Members
ReportQueryStyleEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs Class

ReportQueryTextEventArgs Class

Contains the arguments passed to handlers of the QueryText event raised by the Report class.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public class ReportQueryTextEventArgs : EventArgs
Visual Basic

Public Class ReportQueryTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs

See Also

ReportQueryTextEventArgs Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs Members

ReportQueryTextEventArgs Members
Properties

Contains the arguments passed to handlers of the QueryText event raised by the Report class.

The following tables list the members exposed by the ReportQueryTextEventArgs type.

Public Properties

Name | Description
Column | Gets the column where the text would appear.
Item | Gets the item related to the event.
Representation | Gets or sets the text representation of the object.
Resource | Gets the resource related to the item in a grouped report.
Value | Gets the object that would be displayed.

See Also

ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs Properties

ReportQueryTextEventArgs Properties

Public Properties

Name | Description
Column | Gets the column where the text would appear.
Item | Gets the item related to the event.
Representation | Gets or sets the text representation of the object.
Resource | Gets the resource related to the item in a grouped report.
Value | Gets the object that would be displayed.

See Also

ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs.Column Property

ReportQueryTextEventArgs.Column Property

Gets the column where the text would appear.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public ReportColumn Column { get; }
Visual Basic

Public ReadOnly Property Column As ReportColumn

Property Value

A reference to the ReportColumn object related to the cell whose text is being queried.

See Also

ReportQueryTextEventArgs Members
ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs.Item Property

ReportQueryTextEventArgs.Item Property

Gets the item related to the event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Item Item { get; }
Visual Basic

Public ReadOnly Property Item As Item

Property Value

A reference to the item related to the cell whose text is being queried.

See Also

ReportQueryTextEventArgs Members
ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs.Representation Property

ReportQueryTextEventArgs.Representation Property

Gets or sets the text representation of the object.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public string Representation { get; set; }
Visual Basic

Public Property Representation As String

Property Value

A string containing the text to be displayed in the processed cell. The default is the string representation of the item's property value obtained by calling ToString or an empty string if the value is null (Nothing in Visual Basic).

See Also

ReportQueryTextEventArgs Members
ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs.Resource Property

ReportQueryTextEventArgs.Resource Property

Gets the resource related to the item in a grouped report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Resource Resource { get; }
Visual Basic

Public ReadOnly Property Resource As Resource

Property Value

An instance of the Resource class or null (Nothing in Visual Basic) if the report is not grouped.

Remarks

In a grouped report the event QueryText is fired once for each resource an item is associated with. This way it is possible to display one text for the same item for one resource and another text for another resource.

See Also

ReportQueryTextEventArgs Members
ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs.Value Property

ReportQueryTextEventArgs.Value Property

Gets the object that would be displayed.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public Object Value { get; }
Visual Basic

Public ReadOnly Property Value As Object

Property Value

A reference of the corresponding property value of the item related to the cell being processed.

See Also

ReportQueryTextEventArgs Members
ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Sort Enumeration

Sort Enumeration

Specifies a sorting order.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Reporting

Syntax

C#

public enum Sort
Visual Basic

Public Enumeration Sort

Members

Member name | Description
Ascending | Indicates ascending sort order.
Descending | Indicates descending sort order.
None | Indicates that sorting is disabled.

See Also

MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.WinForms Namespace
Classes Interfaces Enumerations

Classes

Class | Description
AppointmentForm | Ready-made form for appointment editing.
Calendar | The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.
CellSettings | Defines appearance settings for the cells representing time ranges in the calendar in the calendar.
ContinuePrintingEventArgs | Provides data for the ContinuePrinting event.
ControlStyle | A ControlStyle instance defines the appearance style of calendar child controls, such as buttons and scrollbars.
DateChangedEventArgs | Contains the arguments passed to handlers of the VisibleDateChanged event.
DateCollection | Represents a strongly-typed sorted collection of DateTime objects.
DateEventArgs | Contains the arguments passed to handlers of mouse events related to date and time cells in the calendar.
DateStyle | Defines formatting for a range of dates. Can be used either to format either days or months.
DateStyleCollection | Represents a strongly-typed collection of DateStyle objects.
DayOfWeekStyle | An instance of this class defines how a day of the week should be displayed and formatted.
DayOfWeekStyleCollection | Represents a strongly-typed collection of DayOfWeekStyle objects.
DrawEventArgs | Contains the arguments passed to handlers of the Draw event.
ItemConfirmEventArgs | Contains the arguments passed to handlers of item validation events, such as ItemCreating and ItemDeleting.
ItemDrawContext | Provides information about an item being drawn by an item viewer.
ItemEditConfirmEventArgs | Contains the arguments passed to handlers of the ItemInplaceEditEnding event.
ItemEditContext | Provides information about an item when it is being edited using a custom item editor.
ItemEditorAttribute | Associates a custom item editor with a schedule item class.
ItemEditorEx | An item editor that enables modification of the item description as well as the item header.
ItemModifiedEventArgs | Contains the arguments passed to handlers of the ItemModified event.
ItemModifyConfirmEventArgs | Contains the arguments passed to handlers of the ItemModifying event.
ItemMouseEventArgs | Contains the arguments passed to handlers of the ItemClick event.
ItemSelection | Represents a set of selected schedule items.
ItemSelectionEventArgs | Contains the arguments passed to handlers of selection related events.
ItemSettings | Defines properties that allow customizing the visualization of schedule items in the calendar views.
ItemTooltipEventArgs | Contains the arguments passed to handlers of the ItemTooltipDisplaying event.
ItemViewerAttribute | Associates a custom item viewer with a schedule item class.
ListViewSettings | Defines properties that allow customizing the visualization of the calendar in a List view.
MonthRangeSettings | Defines settings for the years in the calendar.
MonthSettings | Defines properties that allow customizing the visualization of months in the SingleMonth and MonthRange views.
PrintOptions | Defines a set of properties that allow customization of various print and print-preview aspects.
RecurrenceForm | Ready-made form for recurrence editing.
RecurringItemConfirmEventArgs | Contains the arguments passed to handlers of the RecurringItemDeleting event.
ResourceDateEventArgs | Contains the arguments passed to handlers of mouse events related to date/time and resource related cells in the calendar.
ResourceViewSettings | Defines properties that allow customizing the visualization of the calendar in Resource view.
Selection | Represents a set of selected date cells and defines a visualization style applied to the selected elements.
SelectionState | Represents the saved state of a Selection object.
TaskForm | Ready-made form for task editing.
Theme | Encapsulates visualization settings that can be applied to a Calendar control by calling the ApplyTheme method. A theme includes settings for all calendar views - List, Month, Timetable, and so on.
TimelineSettings | Encapsulates settings for a timeline in a Resource view.
TimetableSettings | Defines properties that allow customizing the visualization of the calendar in Timetable view.
TooltipEventArgs | Contains the arguments passed to handlers of the TooltipDisplaying event.
ViewSettings | The base class for the different view settings classes.
WeekRangeSettings | Defines properties that allow customizing the visualization of weeks in WeekRange view.

Interfaces

Interface | Description
IItemEditor | Defines the interface that must be implemented by item editor classes.
IItemViewer | Defines the interface that must be implemented by custom item viewer classes.

Enumerations

Enumeration | Description
CalendarElement | Specifies a calendar subelement.
CalendarView | Specifies the type of view to display in a calendar control.
ControlAppearance | Specifies the visual style of the calendar child controls.
CustomDrawElements | Specifies which elements of the calendar are custom-drawn.
DayOfWeekFormat | Specifies the display format of a day of the week.
GroupType | Specifies grouping or filtering criteria for views that support grouping.
ItemAction | Specifies a user action on a schedule item.
ItemModificationStyle | Specifies the way items are processed when modified interactively.
LineStyle | Specifies the style of lines.
ListViewHeaderStyles | Specifies the appearance and behavior of the header in a List view.
MinuteFormat | Specifies how to format and display minutes in the Timetable view.
MonthCellLayout | Specifies the layout of the cells in a SingleMonth and MonthRange views.
MonthHeaderStyles | Specifies the appearance and behavior of month headers in a SingleMonth and MonthRange views.
MonthRangeHeaderStyles | Specifies the appearance and behavior of the header in a MonthRange view.
MonthWeekHeaderStyle | Specifies the placement of the week numbers header in a SingleMonth view.
Orientation | Specifies horizontal or vertical orientation.
Position | Specifies the position of an element relative to its container.
ResourceLengthMethod | Specifies how to calculate the length of the resources in a Resource view.
ResourceResizeMethod | Specifies the item resizing method in a Resource view.
ResourceViewStyle | Specifies the style of a Resource view.
SelectionStyle | Specifies what type of frame to draw around selected elements.
ShowClocks | Specifies whether and when to display clocks in items.
State | Specifies the state of a subject.
ThemeType | Specifies a calendar theme.
TimeUnit | Specifies a time resolution.
WeekRangeHeaderStyle | Specifies the appearance of the time period header in WeekRange view.
WeekRangeViewStyle | Specifies whether there are multiple weeks displayed in WeekRange view.


MindFusion.Scheduling.WinForms.AppointmentForm Class

AppointmentForm Class

Ready-made form for appointment editing.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public class AppointmentForm : Form
Visual Basic

Public Class AppointmentForm
Inherits Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
MindFusion.Scheduling.WinForms.AppointmentForm

See Also

AppointmentForm Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.AppointmentForm Members

AppointmentForm Members
Constructors Properties Methods

Ready-made form for appointment editing.

The following tables list the members exposed by the AppointmentForm type.

Public Constructors

Name | Description
AppointmentForm | Initializes a new instance of the AppointmentForm class.

Public Properties

Name | Description
Appointment | Gets the appointment being edited in this form.
TimeFormat | Gets or sets the format of times displayed within the form.

Public Methods

Name | Description
SetAppointment | Sets the appointment that is to be edited in the form.
SetDates | Sets the dates to be used to initialize the form if no appointment is initially set.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.

See Also

AppointmentForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.AppointmentForm Constructor

AppointmentForm Constructor

Initializes a new instance of the AppointmentForm class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public AppointmentForm (
Schedule schedule
)
Visual Basic

Public Sub AppointmentForm ( _
schedule As Schedule _
)

Parameters

schedule
A schedule object used to initialize certain fields on the form, such as the list with available locations. This value cannot be null (Nothing in Visual Basic).

See Also

AppointmentForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.AppointmentForm Methods

AppointmentForm Methods

Public Methods

Name | Description
SetAppointment | Sets the appointment that is to be edited in the form.
SetDates | Sets the dates to be used to initialize the form if no appointment is initially set.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.

See Also

AppointmentForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.AppointmentForm.Dispose Method

AppointmentForm.Dispose Method

Clean up any resources being used.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

AppointmentForm Members
AppointmentForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.AppointmentForm.SetAppointment Method

AppointmentForm.SetAppointment Method

Sets the appointment that is to be edited in the form.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public void SetAppointment (
Appointment appointment
)
Visual Basic

Public Sub SetAppointment ( _
appointment As Appointment _
)

Parameters

appointment
A reference to the Appointment object to be selected in the form for editing.

Remarks

If the appointment represents a recurrence instance or exception, only the instance is being edited. If it represents a recurrence master, all instances are edited.

See Also

AppointmentForm Members
AppointmentForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.AppointmentForm.SetDates Method

AppointmentForm.SetDates Method

Sets the dates to be used to initialize the form if no appointment is initially set.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public void SetDates (
DateTime start,
DateTime end,
bool allDay
)
Visual Basic

Public Sub SetDates ( _
start As DateTime, _
end As DateTime, _
allDay As Boolean _
)

Parameters

start
A DateTime instance specifying the initial start date of the new appointment.
end
A DateTime instance specifying the initial end date of the new appointment.
allDay
A Boolean flag indicating whether the appointment is an all-day event initially.

Remarks

After you create a new instance of the AppointmentForm class, either call SetAppointment to select existing appointment for editing, or optionally call SetDates to initialize some fields on the form.

See Also

AppointmentForm Members
AppointmentForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.AppointmentForm Properties

AppointmentForm Properties

Public Properties

Name | Description
Appointment | Gets the appointment being edited in this form.
TimeFormat | Gets or sets the format of times displayed within the form.

See Also

AppointmentForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.AppointmentForm.Appointment Property

AppointmentForm.Appointment Property

Gets the appointment being edited in this form.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public Appointment Appointment { get; }
Visual Basic

Public ReadOnly Property Appointment As Appointment

Property Value

A reference to a schedule Appointment, which is being edited in the form. This is usually the appointment selected for editing with a call to the SetAppointment method.

See Also

AppointmentForm Members
AppointmentForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.AppointmentForm.TimeFormat Property

AppointmentForm.TimeFormat Property

Gets or sets the format of times displayed within the form.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public string TimeFormat { get; set; }
Visual Basic

Public Property TimeFormat As String

Property Value

A string specifying the display format.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

AppointmentForm Members
AppointmentForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar Class

Calendar Class

The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class Calendar : Control, ISupportInitialize
Visual Basic

Public Class Calendar
Inherits Control
Implements ISupportInitialize

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Scheduling.WinForms.Calendar

See Also

Calendar Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar Members

Calendar Members
Constructors Properties Methods Events

The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.

The following tables list the members exposed by the Calendar type.

Public Constructors

Name | Description
Calendar | Overloaded. Initializes a new instance of the Calendar class.

Public Properties

Name | Description
AllowAutoScroll | Gets or sets a value indicating whether the control scrolls automatically its contents when users drag items near the edge of the client rectangle.
AllowDrag | Gets or sets a value indicating whether the user can initiate a drag operation within the control.
AllowInplaceCreate | Gets or sets a value indicating whether users are allowed to create items interactively.
AllowInplaceEdit | Gets or sets a value indicating whether users are allowed to edit items interactively.
ButtonOffset | Gets or set the offset of the buttons, displayed in the MonthRange and SingleMonth views' headers.
ButtonSize | Gets or sets the size of the navigation buttons, displayed in the views' headers.
ColorKey | Gets or sets the color key to use when drawing images.
ColumnResizeCursorH | Gets or set the cursor that is displayed when a column can be resized or is being resized in a horizontal Timetable view.
ColumnResizeCursorV | Gets or set the cursor that is displayed when a column can be resized or is being resized in a vertical Timetable view.
ContactNameFormat | Gets or sets how to format and display contact names in the timetable header.
Contacts | Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.
ContactsDataMember | Gets or sets the name of the data member from the associated data source to bind the contacts to.
ContactsDataPropertyMap | Gets or sets a BoundPropertyList object that maps contact properties to fields in the associated data member.
ControlAppearance | Gets or sets the visual style of the calendar child controls.
ControlStyle | Gets a ControlStyle object that allows customizing the visualization of the calendar child controls.
Culture | Gets or sets the CultureInfo object used to format and display time information in the calendar.
CurrentTime | Gets or sets the current time. When this property is set to DateTime.MinValue, the actual system time is returned.
CurrentView | Gets or sets the type of the calendar view.
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the calendar.
CustomBrushesDataMember | Gets or sets the name of the data member from the associated data source to bind the custom brushes to.
CustomBrushesDataPropertyMap | Gets or sets a BoundPropertyList object that maps custom brush properties to fields in the associated data member.
CustomDraw | Gets or sets which UI elements of the calendar should be custom drawn.
CustomTheme | Gets or sets the custom theme applied to the control.
DataSource | Gets or sets the data source associated with the control.
Date | Gets or sets the date currently displayed in the calendar.
DateTimeFormat | Gets or sets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.
DayOfWeekStyles | Gets a collection of DayOfWeekStyle objects that allow customizing the appearance of specific days of the week in the calendar.
DayStyles | Gets a collection of DateStyle objects that allow customizing the appearance of specific days in the calendar.
DelayInplaceEdit | Gets or sets a value indicating whether the in-place editing of an item is delayed for a second when the item is clicked.
DragItemsOnDisabledAreas | Gets or sets a value indicating whether to update the position of items dragged over areas which do not allow items.
EnableDragCreate | Gets or sets a value indicating whether items are created merely by dragging in the control.
EnableKeyboard | Gets or sets a value indicating whether the selection can be manipulated through the keyboard.
EnableOptimization | Gets or sets a value indicating whether the control should try to optimize item rendering.
EndDate | Gets or sets the last date displayed in the calendar.
EnsureVisibleSelection | Gets or sets a value indicating whether the selected cells should be automatically brought into view.
FirstWeekendDay | Gets or sets the first weekend day in the calendar.
GroupType | Gets or sets the grouping criteria for the Timetable, WeekRange, List and Resource views.
HiddenItemsCursor | Gets or sets the cursor that is displayed when the mouse pointer is over the hidden items cue icon.
HScrollerSmallChange | Gets or sets the small step for the horizontal scroll bar.
HScrollerVisible | Gets or sets a value indicating whether the horizontal scroller should always be visible, always hidden or visible only when it is needed.
HScrollPos | Gets or sets the current horizontal scroll position.
ImageList | Gets or sets the image list associated with the calendar.
InteractiveItemType | Gets or sets the type of an Item derived class whose instance should be created when a user starts typing while the calendar control has the keyboard focus.
ItemChangeReferenceKey | Gets or sets the modifier key, which lets users drag items between different contacts, resources, locations or tasks in a grouped view.
ItemCloneKey | Gets or sets the modifier key, which when pressed allows users to interactively clone items.
ItemDragCursor | Gets or sets the cursor that is displayed when an item is being dragged.
ItemDragKey | Gets or sets the modifier key that lets users start an OLE drag-and-drop operation when they drag an item.
ItemHResizeCursor | Gets or sets the cursor that is displayed when the mouse pointer is over the horizontal resize area of an item.
ItemModificationStyle | Gets or sets a value indicating the way items are processed when modified interactively.
ItemMoveCursor | Gets or sets the cursor that is displayed when the mouse pointer is over the move area of an item.
ItemNoDragCursor | Gets or sets the cursor that is displayed when an item is dragged over a location that cannot contain items.
ItemScroll | Gets or sets the current scroll position in a List view whose EnableVirtualItemSpace property is set to Enabled.
ItemsDataMember | Gets or sets the name of the data member from the associated data source to bind the schedule items to.
ItemsDataPropertyMap | Gets or sets a BoundPropertyList object that maps item properties to fields in the associated data member.
ItemSelection | Gets a list of all selected items.
ItemSettings | Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.
ItemTooltipFormat | Gets or sets the format of item tooltips.
ItemVResizeCursor | Gets or sets the cursor that is displayed when the mouse pointer is over the vertical resize area of an item.
KeepItemSelection | Gets or sets a value indicating whether the item selection is preserved when an item from the selection is clicked.
ListViewSettings | Gets the ListViewSettings object used to customize the visualization of the List view.
Locations | Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.
LocationsDataMember | Gets or sets the name of the data member from the associated data source to bind the locations to.
LocationsDataPropertyMap | Gets or sets a BoundPropertyList object that maps location properties to fields in the associated data member.
MinItemLength | Gets or sets the minimal length of interactively created items, expressed in minutes.
MonthRangeSettings | Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.
MonthSettings | Gets the MonthSettings object used to customize the visualization of months in the MonthRange and SingleMonth views.
MonthStyles | Gets a collection of DateStyle objects that allow customizing the appearance of specific months in the calendar.
PrintOptions | Gets a PrintOptions object that allows customizing various aspects of printing.
RecurrenceExceptionsDataMember | Gets or sets the name of the data member from the associated data source to bind the recurrence exceptions to.
RecurrenceExceptionsDataPropertyMap | Gets or sets a BoundPropertyList object that maps recurrence exception properties to fields in the associated data member.
RecurrencesDataMember | Gets or sets the name of the data member from the associated data source to bind the recurrences to.
RecurrencesDataPropertyMap | Gets or sets a BoundPropertyList object that maps recurrence properties to fields in the associated data member.
RemindersDataMember | Gets or sets the name of the data member from the associated data source to bind the reminders to.
RemindersDataPropertyMap | Gets or sets a BoundPropertyList object that maps reminder properties to fields in the associated data member.
Resources | Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.
ResourcesDataMember | Gets or sets the name of the data member from the associated data source to bind the resources to.
ResourcesDataPropertyMap | Gets or sets a BoundPropertyList object that maps resource properties to fields in the associated data member.
ResourceViewSettings | Gets the ResourceViewSettings object used to customize the visualization of a Resource view.
Schedule | Gets or sets the schedule whose information should be displayed inside the calendar control.
ScrollPosition | Gets or sets the current scroll position.
Selection | Gets a Selection object representing the current selection in the calendar.
ShowToolTips | Gets or sets a value indicating whether the calendar displays tooltips.
StartEditAfterModify | Gets or sets a value indicating whether in-place editing of items should automatically start after they are modified interactively.
StylesDataMember | Gets or sets the name of the data member from the associated data source to bind the styles to.
StylesDataPropertyMap | Gets or sets a BoundPropertyList object that maps style properties to fields in the associated data member.
Tasks | Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.
TasksDataMember | Gets or sets the name of the data member from the associated data source to bind the schedule tasks to.
TasksDataPropertyMap | Gets or sets a BoundPropertyList object that maps task properties to fields in the associated data member.
TextRendering | Gets or sets the text rendering mode.
Theme | Gets or sets the theme applied to the calendar control UI elements.
TimetableSettings | Gets the TimetableSettings object used to customize the visualization of days and hours in Timetable view.
ToolTip | Gets the underlying ToolTip component.
VScrollerSmallChange | Gets or sets the small step for the vertical scroll bar.
VScrollerVisible | Gets or sets a value indicating whether the vertical scroller should always be visible, always hidden or visible only when it is needed.
VScrollPos | Gets or sets the current vertical scroll position.
WeekRangeSettings | Gets the WeekRangeSettings object used to customize the visualization of weeks in a WeekRange view.

ProtectedProperties

Name | Description
DefaultSize | Gets the default size of the control.

Public Methods

Name | Description
ApplyTheme | Overloaded. Applies a Theme to the calendar.
BeginInit | Implements the ISupportInitialize.BeginInit method. Call this method before making several consecutive changes to the control to suppress internal updates, but don't forget to invoke EndInit at the end.
CancelModify | Cancels an interactive modification of an item, previously started by a call to StartModify.
CollapseResourceRow | Collapses the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
CompactItemLanes | Overloaded.
CompleteModify | Completes an interactive modification of an item, previously started by a call to StartModify.
CreateImage | Overloaded. Creates a bitmap image of the current calendar view.
EndInit | Implements the ISupportInitialize.EndInit method. Call this method to signal that object initialization started with BeginInit is complete.
EnsureVisible | Overloaded. Ensures that the specified date or item is visible within the control, scrolling the contents of the control if necessary.
ExpandResourceRow | Expands the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
GetContactAt | Overloaded. Gets the Contact object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetDateAt | Overloaded. Returns the date of the calendar cell located at the specified coordinates.
GetElementBounds | Gets the bounding rectangle of a particular calendar element.
GetExactDateAt | Overloaded. Returns the date located at a specified position.
GetFirstDate | Gets the first date of the time range displayed in the calendar.
GetFirstVisibleDate | Determines which is the first visible date in the current view.
GetItemAt | Overloaded. Gets the scheduled Item object displayed at the specified coordinates.
GetItemBounds | Retrieves the bounding rectangle of the specified item.
GetItemListLane | Gets the index of the lane of the specified item within a List view whose FreeDrag property is enabled.
GetLastDate | Gets the last date of the time range displayed in the calendar.
GetLastVisibleDate | Determines which is the last visible date in the current view.
GetListLaneAt | Retrieves the index of the List view lane at the specified point, expressed in client coordinates.
GetLocationAt | Overloaded. Gets the Location object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetResourceAt | Overloaded. Gets the Resource object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetTaskAt | Overloaded. Gets the Task object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetVisibleItems | Retrieves a collection with all currently visible items.
IsResourceRowExpanded | Checks whether the row associated with the specified Contact, Location, Task or Resource in a Resource view is expanded.
LoadFrom | Overloaded.
LoadFromDataSource | Loads the schedule from the underlying data source.
LoadViewSettings | Overloaded. Loads the view settings from the specified stream or XML document.
Print | Overloaded. Prints the current calendar view.
PrintPreview | Overloaded. Displays a print preview window for the current calendar view.
ResetDrag | If there is a mouse drag operation in progress, it is canceled.
ResetItemViewState | Resets the view-related item data contained in the underlying schedule. For example, items moved around in a list view with enabled FreeDrag property have their relative positions within the view reset.
ResumeDrag | Resumes the previously paused mouse drag operation.
SaveTo | Overloaded.
SaveToDataSource | Overloaded. Saves the current schedule to the underlying data source.
SaveViewSettings | Overloaded. Saves the view settings to the specified stream or XML document.
SetItemListLane | Sets the lane index for the specified item within a List view whose FreeDrag property is enabled.
StartInplaceEdit | Starts in-place editing mode for the specified item to let users edit the item's text.
StartModify | Initiates interactive modification on the specified item.
SuspendDrag | Temporarily pauses the current mouse drag operation.
UpdateLayout | Updates the position of the calendar's child controls such as buttons and scrollbars.
UpdateModify | Updates an interactive modification of an item, previously started by a call to StartModify.

Protected Methods

Name | Description
Dispose | Cleans up any resources being used.
OnContinuePrinting | Raises the ContinuePrinting event.
OnDateClick | Raises the DateClick event.
OnDraw | Raises the Draw event.
OnHiddenItemClick | Raises the HiddenItemClick event.
OnHScroll | Overloaded.
OnItemClick | Raises the ItemClick event.
OnItemCloned | Raises the ItemCloned event.
OnItemCloning | Raises the ItemCloning event.
OnItemCreated | Raises the ItemCreated event.
OnItemCreating | Raises the ItemCreating event.
OnItemCreationCanceled | Raises the ItemCreationCanceled event.
OnItemDeleted | Raises the ItemDeleted event.
OnItemDeleting | Raises the ItemDeleting event.
OnItemDeselecting | Raises the ItemDeselecting event.
OnItemInplaceEdited | Raises the ItemInplaceEdited event.
OnItemInplaceEditEnding | Raises the ItemInplaceEditEnding event.
OnItemInplaceEditStarting | Raises the ItemInplaceEditStarting event.
OnItemListLaneChanged | Raises the ItemListLaneChanged event.
OnItemModificationCanceled | Raises the ItemModificationCanceled event.
OnItemModified | Raises the ItemModified event.
OnItemModifying | Raises the ItemModifying event.
OnItemSelecting | Raises the ItemSelecting event.
OnItemSelectionChanged | Raises the ItemSelectionChanged event.
OnItemSelectionComplete | Raises the ItemSelectionComplete event.
OnItemTooltipDisplaying | Raises the ItemTooltipDisplaying event.
OnKeyDown | Control.OnKeyDown override.
OnKeyPress | Control.OnKeyPress override.
OnListViewHeaderClick | Raises the ListViewHeaderClick event.
OnLostFocus | Control.OnLostFocus override.
OnMonthCellClick | Raises the MonthCellClick event.
OnMonthHeaderClick | Raises the MonthHeaderClick event.
OnMonthRangeHeaderClick | Raises the MonthRangeHeaderClick event.
OnMonthWeekHeaderClick | Raises the MonthWeekHeaderClick event.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnPaint | Control.OnPaint override.
OnPaintBackground | Control.OnPaintBackground override.
OnRecurringItemDeleting | Raises the RecurringItemDeleting event.
OnResize | Control.OnResize override.
OnResourceViewBottomTimelineClick | Raises the ResourceViewBottomTimelineClick event.
OnResourceViewMiddleTimelineClick | Raises the ResourceViewMiddleTimelineClick event.
OnResourceViewRowHeaderClick | Raises the ResourceViewRowHeaderClick event.
OnResourceViewTopTimelineClick | Raises the ResourceViewTopTimelineClick event.
OnRightToLeftChanged | Control.OnRightToLeftChanged override.
OnScroll | Raises the Scroll event.
OnTimetableColumnHeaderClick | Raises the TimetableColumnHeaderClick event.
OnTooltipDisplaying | Raises the TooltipDisplaying event.
OnVisibleDateChanged | Raises the VisibleDateChanged event.
OnVScroll | Overloaded.
OnWeekRangeHeaderClick | Raises the WeekRangeHeaderClick event.
ProcessDialogKey | Control.ProcessDialogKey override.

Public Events

Name | Description
ContinuePrinting | Occurs at the end of a printing operation to enable users to continue printing the calendar with different view settings.
DateClick | Raised when the user clicks a date cell in the calendar.
Draw | Raised to allow custom drawing of calendar UI elements.
HiddenItemClick | Raised when a hidden items cue icon is clicked.
HScroll | Raised when the control has been scrolled horizontally.
ItemClick | Raised when the user clicks a schedule item.
ItemCloned | Raised when the user has cloned an item interactively.
ItemCloning | Raised when the user is about to clone an item interactively.
ItemCreated | Raised when a schedule item is created by the user.
ItemCreating | Raised when the user is about to create a new schedule item.
ItemCreationCanceled | Raised when an interactive item creation is canceled by the user.
ItemDeleted | Raised when the user deletes a schedule item.
ItemDeleting | Raised when the user is about to delete a schedule item.
ItemDeselecting | Raised when an item is about to be deselected.
ItemInplaceEdited | Raised when item's text is in-place edited.
ItemInplaceEditEnding | Raised when in-place editing of item's text is about to be accepted.
ItemInplaceEditStarting | Raised when in-place editing of item's text is about to begin.
ItemListLaneChanged | Raised when the lane index of an item within a List view has changed.
ItemModificationCanceled | Raised when an item modification is canceled by the user.
ItemModified | Raised when a schedule item is moved or resized by the user.
ItemModifying | Raised when the user moves or resizes a schedule item, which would change the item's scheduled start or end date and time.
ItemSelecting | Raised when an item is about to be selected.
ItemSelectionChanged | Raised when an item is selected or deselected.
ItemSelectionComplete | Raised when an item is selected or deselected.
ItemTooltipDisplaying | Raised to allow modification of an item's ToolTip before it gets displayed.
ListViewHeaderClick | Raised when the header of a List view is clicked.
MonthCellClick | Raised when the user clicks on a month cell in a SingleMonth and MonthRange views.
MonthHeaderClick | Raised when the header of a Month view is clicked.
MonthRangeHeaderClick | Raised when the header of an MonthRange view is clicked.
MonthWeekHeaderClick | Raised when a cell in the week header of a Month view is clicked.
RecurringItemDeleting | Raised when the user is about to delete a recurring item.
ResourceViewBottomTimelineClick | Raised when the bottom timeline of a Resource view is clicked.
ResourceViewMiddleTimelineClick | Raised when the middle timeline of a Resource view is clicked.
ResourceViewRowHeaderClick | Raised when the header of a Resource view row is clicked.
ResourceViewTopTimelineClick | Raised when the top timeline of a Resource view is clicked.
Scroll | Raised when the value of a scrollbar has changed.
TimetableColumnHeaderClick | Raised when the header of a Timetable column is clicked.
TooltipDisplaying | Raised to allow modification of the ToolTip of a calendar element before it gets displayed.
VisibleDateChanged | Raised when the user selects another date using the month or year navigation controls on the calendar header area.
VScroll | Raised when the control has been scrolled vertically.
WeekRangeHeaderClick | Raised when the header of a WeekRange view is clicked.

See Also

Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar Constructor

Calendar Constructor

Initializes a new instance of the Calendar class.

Overload List

Name | Description
Calendar () | Initializes a new instance of the Calendar class using the current culture info.
Calendar (CultureInfo) | Initializes a new instance of the Calendar class using the specified culture info.

See Also

Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar Constructor ()

Calendar Constructor ()
See Also

Initializes a new instance of the Calendar class using the current culture info.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Calendar ()
Visual Basic

Public Sub New ()

See Also

Calendar Constructor Overload List
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar Constructor (CultureInfo)

Calendar Constructor (CultureInfo)
See Also

Initializes a new instance of the Calendar class using the specified culture info.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Calendar (
CultureInfo culture
)
Visual Basic

Public New ( _
culture As CultureInfo _
)

Parameters

culture
A .NET CultureInfo object providing information about formatting and displaying dates and times.

See Also

Calendar Constructor Overload List
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar Methods

Calendar Methods

Public Methods

Name | Description
ApplyTheme | Overloaded. Applies a Theme to the calendar.
BeginInit | Implements the ISupportInitialize.BeginInit method. Call this method before making several consecutive changes to the control to suppress internal updates, but don't forget to invoke EndInit at the end.
CancelModify | Cancels an interactive modification of an item, previously started by a call to StartModify.
CollapseResourceRow | Collapses the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
CompactItemLanes | Overloaded.
CompleteModify | Completes an interactive modification of an item, previously started by a call to StartModify.
CreateImage | Overloaded. Creates a bitmap image of the current calendar view.
EndInit | Implements the ISupportInitialize.EndInit method. Call this method to signal that object initialization started with BeginInit is complete.
EnsureVisible | Overloaded. Ensures that the specified date or item is visible within the control, scrolling the contents of the control if necessary.
ExpandResourceRow | Expands the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
GetContactAt | Overloaded. Gets the Contact object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetDateAt | Overloaded. Returns the date of the calendar cell located at the specified coordinates.
GetElementBounds | Gets the bounding rectangle of a particular calendar element.
GetExactDateAt | Overloaded. Returns the date located at a specified position.
GetFirstDate | Gets the first date of the time range displayed in the calendar.
GetFirstVisibleDate | Determines which is the first visible date in the current view.
GetItemAt | Overloaded. Gets the scheduled Item object displayed at the specified coordinates.
GetItemBounds | Retrieves the bounding rectangle of the specified item.
GetItemListLane | Gets the index of the lane of the specified item within a List view whose FreeDrag property is enabled.
GetLastDate | Gets the last date of the time range displayed in the calendar.
GetLastVisibleDate | Determines which is the last visible date in the current view.
GetListLaneAt | Retrieves the index of the List view lane at the specified point, expressed in client coordinates.
GetLocationAt | Overloaded. Gets the Location object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetResourceAt | Overloaded. Gets the Resource object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetTaskAt | Overloaded. Gets the Task object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetVisibleItems | Retrieves a collection with all currently visible items.
IsResourceRowExpanded | Checks whether the row associated with the specified Contact, Location, Task or Resource in a Resource view is expanded.
LoadFrom | Overloaded.
LoadFromDataSource | Loads the schedule from the underlying data source.
LoadViewSettings | Overloaded. Loads the view settings from the specified stream or XML document.
Print | Overloaded. Prints the current calendar view.
PrintPreview | Overloaded. Displays a print preview window for the current calendar view.
ResetDrag | If there is a mouse drag operation in progress, it is canceled.
ResetItemViewState | Resets the view-related item data contained in the underlying schedule. For example, items moved around in a list view with enabled FreeDrag property have their relative positions within the view reset.
ResumeDrag | Resumes the previously paused mouse drag operation.
SaveTo | Overloaded.
SaveToDataSource | Overloaded. Saves the current schedule to the underlying data source.
SaveViewSettings | Overloaded. Saves the view settings to the specified stream or XML document.
SetItemListLane | Sets the lane index for the specified item within a List view whose FreeDrag property is enabled.
StartInplaceEdit | Starts in-place editing mode for the specified item to let users edit the item's text.
StartModify | Initiates interactive modification on the specified item.
SuspendDrag | Temporarily pauses the current mouse drag operation.
UpdateLayout | Updates the position of the calendar's child controls such as buttons and scrollbars.
UpdateModify | Updates an interactive modification of an item, previously started by a call to StartModify.

Protected Methods

Name | Description
Dispose | Cleans up any resources being used.
OnContinuePrinting | Raises the ContinuePrinting event.
OnDateClick | Raises the DateClick event.
OnDraw | Raises the Draw event.
OnHiddenItemClick | Raises the HiddenItemClick event.
OnHScroll | Overloaded.
OnItemClick | Raises the ItemClick event.
OnItemCloned | Raises the ItemCloned event.
OnItemCloning | Raises the ItemCloning event.
OnItemCreated | Raises the ItemCreated event.
OnItemCreating | Raises the ItemCreating event.
OnItemCreationCanceled | Raises the ItemCreationCanceled event.
OnItemDeleted | Raises the ItemDeleted event.
OnItemDeleting | Raises the ItemDeleting event.
OnItemDeselecting | Raises the ItemDeselecting event.
OnItemInplaceEdited | Raises the ItemInplaceEdited event.
OnItemInplaceEditEnding | Raises the ItemInplaceEditEnding event.
OnItemInplaceEditStarting | Raises the ItemInplaceEditStarting event.
OnItemListLaneChanged | Raises the ItemListLaneChanged event.
OnItemModificationCanceled | Raises the ItemModificationCanceled event.
OnItemModified | Raises the ItemModified event.
OnItemModifying | Raises the ItemModifying event.
OnItemSelecting | Raises the ItemSelecting event.
OnItemSelectionChanged | Raises the ItemSelectionChanged event.
OnItemSelectionComplete | Raises the ItemSelectionComplete event.
OnItemTooltipDisplaying | Raises the ItemTooltipDisplaying event.
OnKeyDown | Control.OnKeyDown override.
OnKeyPress | Control.OnKeyPress override.
OnListViewHeaderClick | Raises the ListViewHeaderClick event.
OnLostFocus | Control.OnLostFocus override.
OnMonthCellClick | Raises the MonthCellClick event.
OnMonthHeaderClick | Raises the MonthHeaderClick event.
OnMonthRangeHeaderClick | Raises the MonthRangeHeaderClick event.
OnMonthWeekHeaderClick | Raises the MonthWeekHeaderClick event.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnPaint | Control.OnPaint override.
OnPaintBackground | Control.OnPaintBackground override.
OnRecurringItemDeleting | Raises the RecurringItemDeleting event.
OnResize | Control.OnResize override.
OnResourceViewBottomTimelineClick | Raises the ResourceViewBottomTimelineClick event.
OnResourceViewMiddleTimelineClick | Raises the ResourceViewMiddleTimelineClick event.
OnResourceViewRowHeaderClick | Raises the ResourceViewRowHeaderClick event.
OnResourceViewTopTimelineClick | Raises the ResourceViewTopTimelineClick event.
OnRightToLeftChanged | Control.OnRightToLeftChanged override.
OnScroll | Raises the Scroll event.
OnTimetableColumnHeaderClick | Raises the TimetableColumnHeaderClick event.
OnTooltipDisplaying | Raises the TooltipDisplaying event.
OnVisibleDateChanged | Raises the VisibleDateChanged event.
OnVScroll | Overloaded.
OnWeekRangeHeaderClick | Raises the WeekRangeHeaderClick event.
ProcessDialogKey | Control.ProcessDialogKey override.

See Also

Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ApplyTheme Method

Calendar.ApplyTheme Method

Applies a Theme to the calendar.

Overload List

Name | Description
Calendar.ApplyTheme (Theme) | Applies the specified theme to the calendar.
Calendar.ApplyTheme (Theme, Boolean) | Applies the specified theme to the calendar, optionally resetting all current settings.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ApplyTheme Method (Theme)

Calendar.ApplyTheme Method (Theme)
See Also

Applies the specified theme to the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void ApplyTheme (
Theme theme
)
Visual Basic

Public Sub ApplyTheme ( _
theme As Theme _
)

Parameters

theme
A Theme object containing appearance settings.

See Also

ApplyTheme Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
Theme Property


MindFusion.Scheduling.WinForms.Calendar.ApplyTheme Method (Theme, Boolean)

Calendar.ApplyTheme Method (Theme, Boolean)
See Also

Applies the specified theme to the calendar, optionally resetting all current settings.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void ApplyTheme (
Theme theme,
bool reset
)
Visual Basic

Public Sub ApplyTheme ( _
theme As Theme, _
reset As Boolean _
)

Parameters

theme
A Theme object containing appearance settings.
reset
Specifies whether to reset the settings.

Example

The following example attaches the Windows2003 theme to a calendar. The example assumes that calendar already references an existing Calendar object.

C#

calendar.ApplyTheme(MindFusion.Scheduling.WinForms.Theme.Windows2003, false);
Visual Basic

calendar.ApplyTheme(MindFusion.Scheduling.WinForms.Theme.Windows2003, False)

See Also

ApplyTheme Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
Theme Property


MindFusion.Scheduling.WinForms.Calendar.BeginInit Method

Calendar.BeginInit Method

Implements the ISupportInitialize.BeginInit method. Call this method before making several consecutive changes to the control to suppress internal updates, but don't forget to invoke EndInit at the end.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void BeginInit ()
Visual Basic

Public Overridable Sub BeginInit ()

Example

The following example demonstrates how to use BeginInit and EndInit to prevent unnecessary updating.

C#

using MindFusion.Scheduling.WinForms;

// ...

calendar.BeginInit();
calendar.Date = DateTime.Today;
calendar.EndDate = DateTime.Today + TimeSpan.FromDays(100);
calendar.CurrentView = CalendarView.WeekRange;
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow;
calendar.WeekRangeSettings.GroupWeekends = State.Enabled;
calendar.EndInit();
Visual Basic

Imports MindFusion.Scheduling.WinForms

' ...

calendar.BeginInit()
calendar.Date = DateTime.Today
calendar.EndDate = DateTime.Today.Add(TimeSpan.FromDays(100))
calendar.CurrentView = CalendarView.WeekRange
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow
calendar.WeekRangeSettings.GroupWeekends = State.Enabled
calendar.EndInit()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
EndInit Method


MindFusion.Scheduling.WinForms.Calendar.CancelModify Method

Calendar.CancelModify Method

Cancels an interactive modification of an item, previously started by a call to StartModify.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool CancelModify ()
Visual Basic

Public Function CancelModify () As Boolean

Return Value

true if there was a started modification before the call; otherwise, false.

Remarks

Through the use of the StartModify, UpdateModify, CompleteModify and CancelModify methods you can implement item drag operations within the Calendar control. This is useful in certain situations, such as when implementing OLE drag & drop operation over the Calendar control and you want the dragged item to be modified within the control before the drag & drop operation is complete.

Example

The following code demonstrates how to implement the drag & drop scenario from the remarks section using these four methods. The sample assumes that the calendar variable already identifies a valid Calendar instance.

C#

// ...

private Appointment dragged = null;
private bool started = false;

/// <summary>
/// Handles the DragEnter event of the Calendar class.
/// </summary>
private void calendar_DragEnter(object sender, DragEventArgs e)
{
dragged = new Appointment();
dragged.StartTime = DateTime.MinValue;
dragged.EndTime = dragged.StartTime + TimeSpan.FromDays(1);
dragged.HeaderText = "Dragged appointment";
calendar.Schedule.Items.Add(dragged);
started = calendar.StartModify(dragged,
calendar.PointToClient(new Point(e.X, e.Y)));
}

/// <summary>
/// Handles the DragLeave event of the Calendar class.
/// </summary>
private void calendar_DragLeave(object sender, EventArgs e)
{
if (dragged != null)
{
calendar.CancelModify();
calendar.Schedule.Items.Remove(dragged);
dragged = null;
}
}

/// <summary>
/// Handles the DragOver event of the Calendar class.
/// </summary>
private void calendar_DragOver(object sender, DragEventArgs e)
{
if (dragged != null)
{
if (!started)
started = calendar.StartModify(dragged, calendar.PointToClient(new Point(e.X, e.Y)));

if (started)
{
calendar.UpdateModify(calendar.PointToClient(new Point(e.X, e.Y)));
e.Effect = DragDropEffects.Copy;
return;
}
}

e.Effect = DragDropEffects.None;
}

/// <summary>
/// Handles the DragDrop event of the Calendar class.
/// </summary>
private void calendar_DragDrop(object sender, DragEventArgs e)
{
if (dragged != null)
{
calendar.CompleteModify(calendar.PointToClient(new Point(e.X, e.Y)));
dragged = null;

calendar.UpdateLayout();
}
}

// ...
Visual Basic

' ...

Private dragged As Appointment = Nothing
Private started As Boolean = False

' <summary>
' Handles the DragEnter event of the Calendar class.
' </summary>
Private Sub calendar_DragEnter(ByVal sender As Object, ByVal e As DragEventArgs) Handles calendar.DragEnter

dragged = New Appointment
dragged.StartTime = DateTime.MinValue
dragged.EndTime = dragged.StartTime.Add(TimeSpan.FromDays(1))
dragged.HeaderText = "Dragged appointment"
calendar.Schedule.Items.Add(dragged)
started = calendar.StartModify(dragged, _
calendar.PointToClient(New Point(e.X, e.Y)))

End Sub

' <summary>
' Handles the DragLeave event of the Calendar class.
' </summary>
Private Sub calendar_DragLeave(ByVal sender As Object, ByVal e As EventArgs) Handles calendar.DragLeave

If Not dragged Is Nothing Then

calendar.CancelModify()
calendar.Schedule.Items.Remove(dragged)
dragged = Nothing

End If

End Sub

' <summary>
' Handles the DragOver event of the Calendar class.
' </summary>
Private Sub calendar_DragOver(ByVal sender As Object, ByVal e As DragEventArgs) Handles calendar.DragOver

If Not dragged Is Nothing Then

If Not started Then
started = calendar.StartModify(dragged, calendar.PointToClient(New Point(e.X, e.Y)))
End If

If started Then

calendar.UpdateModify(calendar.PointToClient(New Point(e.X, e.Y)))
e.Effect = DragDropEffects.Copy
Return

End If

End If

e.Effect = DragDropEffects.None

End Sub

' <summary>
' Handles the DragDrop event of the Calendar class.
' </summary>
Private Sub calendar_DragDrop(ByVal sender As Object, ByVal e As DragEventArgs) Handles calendar.DragDrop

If Not dragged Is Nothing Then

calendar.CompleteModify(calendar.PointToClient(New Point(e.X, e.Y)))
dragged = Nothing

calendar.UpdateLayout()

End If

End Sub

' ...

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
UpdateModify Method
CompleteModify Method
StartModify Method


MindFusion.Scheduling.WinForms.Calendar.CollapseResourceRow Method

Calendar.CollapseResourceRow Method

Collapses the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void CollapseResourceRow (
Resource resource
)
Visual Basic

Public Sub CollapseResourceRow ( _
resource As Resource _
)

Parameters

resource
A reference to a Contact, Location, Task or Resource object whose row is to be collapsed.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ExpandResourceRow Method
IsResourceRowExpanded Method


MindFusion.Scheduling.WinForms.Calendar.CompactItemLanes Method

Calendar.CompactItemLanes Method

Overload List

Name | Description
Calendar.CompactItemLanes () | Reassigns new lane indices to schedule items in a List view whose FreeDrag property is enabled in order to remove empty spaces between items. The relative order of the items remains untouched.
Calendar.CompactItemLanes (IList(Item)) | Reassigns new lane indices to the specified schedule items in order to remove empty spaces between the items and their neighbours.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.CompactItemLanes Method ()

Calendar.CompactItemLanes Method ()
See Also

Reassigns new lane indices to schedule items in a List view whose FreeDrag property is enabled in order to remove empty spaces between items. The relative order of the items remains untouched.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void CompactItemLanes ()
Visual Basic

Public Sub CompactItemLanes ()

See Also

CompactItemLanes Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.CompactItemLanes Method (IList(Item))

Calendar.CompactItemLanes Method (IList(Item))
See Also

Reassigns new lane indices to the specified schedule items in order to remove empty spaces between the items and their neighbours.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void CompactItemLanes (
IList<Item> items
)
Visual Basic

Public Sub CompactItemLanes ( _
items As IList(Of Item) _
)

Parameters

items

See Also

CompactItemLanes Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.CompleteModify Method

Calendar.CompleteModify Method

Completes an interactive modification of an item, previously started by a call to StartModify.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool CompleteModify (
Point point
)
Visual Basic

Public Function CompleteModify ( _
point As Point _
) As Boolean

Parameters

point
The final point of the interactive modification.

Return Value

true if there was a started modification before the call; otherwise, false.

Remarks

Through the use of the StartModify, UpdateModify, CompleteModify and CancelModify methods you can implement item drag operations within the Calendar control. This is useful in certain situations, such as when implementing OLE drag & drop operation over the Calendar control and you want the dragged item to be modified within the control before the drag & drop operation is complete.

Example

The following code demonstrates how to implement the drag & drop scenario from the remarks section using these four methods. The sample assumes that the calendar variable already identifies a valid Calendar instance.

C#

// ...

private Appointment dragged = null;
private bool started = false;

/// <summary>
/// Handles the DragEnter event of the Calendar class.
/// </summary>
private void calendar_DragEnter(object sender, DragEventArgs e)
{
dragged = new Appointment();
dragged.StartTime = DateTime.MinValue;
dragged.EndTime = dragged.StartTime + TimeSpan.FromDays(1);
dragged.HeaderText = "Dragged appointment";
calendar.Schedule.Items.Add(dragged);
started = calendar.StartModify(dragged,
calendar.PointToClient(new Point(e.X, e.Y)));
}

/// <summary>
/// Handles the DragLeave event of the Calendar class.
/// </summary>
private void calendar_DragLeave(object sender, EventArgs e)
{
if (dragged != null)
{
calendar.CancelModify();
calendar.Schedule.Items.Remove(dragged);
dragged = null;
}
}

/// <summary>
/// Handles the DragOver event of the Calendar class.
/// </summary>
private void calendar_DragOver(object sender, DragEventArgs e)
{
if (dragged != null)
{
if (!started)
started = calendar.StartModify(dragged, calendar.PointToClient(new Point(e.X, e.Y)));

if (started)
{
calendar.UpdateModify(calendar.PointToClient(new Point(e.X, e.Y)));
e.Effect = DragDropEffects.Copy;
return;
}
}

e.Effect = DragDropEffects.None;
}

/// <summary>
/// Handles the DragDrop event of the Calendar class.
/// </summary>
private void calendar_DragDrop(object sender, DragEventArgs e)
{
if (dragged != null)
{
calendar.CompleteModify(calendar.PointToClient(new Point(e.X, e.Y)));
dragged = null;

calendar.UpdateLayout();
}
}

// ...
Visual Basic

' ...

Private dragged As Appointment = Nothing
Private started As Boolean = False

' <summary>
' Handles the DragEnter event of the Calendar class.
' </summary>
Private Sub calendar_DragEnter(ByVal sender As Object, ByVal e As DragEventArgs) Handles calendar.DragEnter

dragged = New Appointment
dragged.StartTime = DateTime.MinValue
dragged.EndTime = dragged.StartTime.Add(TimeSpan.FromDays(1))
dragged.HeaderText = "Dragged appointment"
calendar.Schedule.Items.Add(dragged)
started = calendar.StartModify(dragged, _
calendar.PointToClient(New Point(e.X, e.Y)))

End Sub

' <summary>
' Handles the DragLeave event of the Calendar class.
' </summary>
Private Sub calendar_DragLeave(ByVal sender As Object, ByVal e As EventArgs) Handles calendar.DragLeave

If Not dragged Is Nothing Then

calendar.CancelModify()
calendar.Schedule.Items.Remove(dragged)
dragged = Nothing

End If

End Sub

' <summary>
' Handles the DragOver event of the Calendar class.
' </summary>
Private Sub calendar_DragOver(ByVal sender As Object, ByVal e As DragEventArgs) Handles calendar.DragOver

If Not dragged Is Nothing Then

If Not started Then
started = calendar.StartModify(dragged, calendar.PointToClient(New Point(e.X, e.Y)))
End If

If started Then

calendar.UpdateModify(calendar.PointToClient(New Point(e.X, e.Y)))
e.Effect = DragDropEffects.Copy
Return

End If

End If

e.Effect = DragDropEffects.None

End Sub

' <summary>
' Handles the DragDrop event of the Calendar class.
' </summary>
Private Sub calendar_DragDrop(ByVal sender As Object, ByVal e As DragEventArgs) Handles calendar.DragDrop

If Not dragged Is Nothing Then

calendar.CompleteModify(calendar.PointToClient(New Point(e.X, e.Y)))
dragged = Nothing

calendar.UpdateLayout()

End If

End Sub

' ...

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
StartModify Method
UpdateModify Method
CancelModify Method


MindFusion.Scheduling.WinForms.Calendar.CreateImage Method

Calendar.CreateImage Method

Creates a bitmap image of the current calendar view.

Overload List

Name | Description
Calendar.CreateImage (Boolean) | Creates a bitmap image of the current calendar view.
Calendar.CreateImage (Boolean, Int32, Int32) | Creates a bitmap image of the current calendar view.
Calendar.CreateImage (Boolean, Single, Single) | Creates a bitmap image of the current calendar view.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.CreateImage Method (Boolean)

Calendar.CreateImage Method (Boolean)
See Also

Creates a bitmap image of the current calendar view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Bitmap CreateImage (
bool visibleOnly
)
Visual Basic

Public Function CreateImage ( _
visibleOnly As Boolean _
) As Bitmap

Parameters

visibleOnly
Specifies whether to create an image only of the calendar area that is currently visible on screen.

Return Value

An instance of the .NET Bitmap class containing the image data.

See Also

CreateImage Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.CreateImage Method (Boolean, Int32, Int32)

Calendar.CreateImage Method (Boolean, Int32, Int32)
See Also

Creates a bitmap image of the current calendar view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Bitmap CreateImage (
bool visibleOnly,
int desiredWidth,
int desiredHeight
)
Visual Basic

Public Function CreateImage ( _
visibleOnly As Boolean, _
desiredWidth As Integer, _
desiredHeight As Integer _
) As Bitmap

Parameters

visibleOnly
Specifies whether to create an image only of the calendar area that is currently visible on screen.
desiredWidth
The width of the bitmap.
desiredHeight
The height of the bitmap.

Return Value

An instance of the .NET Bitmap class containing the image data.

See Also

CreateImage Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.CreateImage Method (Boolean, Single, Single)

Calendar.CreateImage Method (Boolean, Single, Single)
See Also

Creates a bitmap image of the current calendar view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Bitmap CreateImage (
bool visibleOnly,
float scaleX,
float scaleY
)
Visual Basic

Public Function CreateImage ( _
visibleOnly As Boolean, _
scaleX As Single, _
scaleY As Single _
) As Bitmap

Parameters

visibleOnly
Specifies whether to create an image only of the calendar area that is currently visible on screen.
scaleX
The scale along the x-axis of the resulting image.
scaleY
The scale along the y-axis of the resulting image.

Return Value

An instance of the .NET Bitmap class containing the image data.

See Also

CreateImage Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.Dispose Method

Calendar.Dispose Method

Cleans up any resources being used.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.EndInit Method

Calendar.EndInit Method

Implements the ISupportInitialize.EndInit method. Call this method to signal that object initialization started with BeginInit is complete.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void EndInit ()
Visual Basic

Public Overridable Sub EndInit ()

Example

The following example demonstrates how to use BeginInit and EndInit to prevent unnecessary updating.

C#

using MindFusion.Scheduling.WinForms;

// ...

calendar.BeginInit();
calendar.Date = DateTime.Today;
calendar.EndDate = DateTime.Today + TimeSpan.FromDays(100);
calendar.CurrentView = CalendarView.WeekRange;
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow;
calendar.WeekRangeSettings.GroupWeekends = State.Enabled;
calendar.EndInit();
Visual Basic

Imports MindFusion.Scheduling.WinForms

' ...

calendar.BeginInit()
calendar.Date = DateTime.Today
calendar.EndDate = DateTime.Today.Add(TimeSpan.FromDays(100))
calendar.CurrentView = CalendarView.WeekRange
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow
calendar.WeekRangeSettings.GroupWeekends = State.Enabled
calendar.EndInit()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
BeginInit Method


MindFusion.Scheduling.WinForms.Calendar.EnsureVisible Method

Calendar.EnsureVisible Method

Ensures that the specified date or item is visible within the control, scrolling the contents of the control if necessary.

Overload List

Name | Description
Calendar.EnsureVisible (DateTime) | Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary.
Calendar.EnsureVisible (DateTime, Resource) | Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary. The reference parameter allows specifying a Task, Location, Contact or Resource for which to display the date in a view with enabled grouping.
Calendar.EnsureVisible (Item) | Ensures that the item is visible within the control, scrolling the contents of the control if necessary.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.EnsureVisible Method (DateTime)

Calendar.EnsureVisible Method (DateTime)
See Also

Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void EnsureVisible (
DateTime date
)
Visual Basic

Public Sub EnsureVisible ( _
date As DateTime _
)

Parameters

date
A DateTime instance identifying the date to scroll into view.

Remarks

This method does nothing if the specified date is not included in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.EnsureVisible Method (DateTime, Resource)

Calendar.EnsureVisible Method (DateTime, Resource)
See Also

Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary. The reference parameter allows specifying a Task, Location, Contact or Resource for which to display the date in a view with enabled grouping.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void EnsureVisible (
DateTime date,
Resource resource
)
Visual Basic

Public Sub EnsureVisible ( _
date As DateTime, _
resource As Resource _
)

Parameters

date
A .NET DateTime instance identifying the date to scroll into view.
resource
A reference to Task, Location, Contact or Resource whose group to display in the view.

Remarks

This method does nothing if the specified date is not included in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.EnsureVisible Method (Item)

Calendar.EnsureVisible Method (Item)
See Also

Ensures that the item is visible within the control, scrolling the contents of the control if necessary.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void EnsureVisible (
Item item
)
Visual Basic

Public Sub EnsureVisible ( _
item As Item _
)

Parameters

item
The schedule Item to scroll into view.

Remarks

This method does nothing if the item is not scheduled to occur in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ExpandResourceRow Method

Calendar.ExpandResourceRow Method

Expands the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void ExpandResourceRow (
Resource resource
)
Visual Basic

Public Sub ExpandResourceRow ( _
resource As Resource _
)

Parameters

resource
A reference to a Contact, Location, Task or Resource object whose row is to be expanded.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
CollapseResourceRow Method
IsResourceRowExpanded Method


MindFusion.Scheduling.WinForms.Calendar.GetContactAt Method

Calendar.GetContactAt Method

Gets the Contact object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.

Overload List

Name | Description
Calendar.GetContactAt (Int32, Int32) | Gets the Contact object whose schedule is displayed at the specified coordinates.
Calendar.GetContactAt (Point) | Gets the Contact object whose schedule is displayed at the specified coordinates.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetContactAt Method (Int32, Int32)

Calendar.GetContactAt Method (Int32, Int32)
See Also

Gets the Contact object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Contact GetContactAt (
int x,
int y
)
Visual Basic

Public Function GetContactAt ( _
x As Integer, _
y As Integer _
) As Contact

Parameters

x
The x-coordinate of the position at which to look for contact's scheduled items.
y
The y-coordinate of the position at which to look for contact's scheduled items.

Return Value

An instance of the Contact class representing the contact related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetContactAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetLocationAt Method
GetTaskAt Method
GetResourceAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetContactAt Method (Point)

Calendar.GetContactAt Method (Point)
See Also

Gets the Contact object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Contact GetContactAt (
Point point
)
Visual Basic

Public Function GetContactAt ( _
point As Point _
) As Contact

Parameters

point
The position at which to look for contact's scheduled items.

Return Value

An instance of the Contact class representing the contact related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetContactAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetLocationAt Method
GetTaskAt Method
GetResourceAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetDateAt Method

Calendar.GetDateAt Method

Returns the date of the calendar cell located at the specified coordinates.

Overload List

Name | Description
Calendar.GetDateAt (Int32, Int32) | Returns the date of the calendar cell located at the specified coordinates.
Calendar.GetDateAt (Int32, Int32, Rectangle@) | Returns the date of the calendar cell located at the specified position and the bounding rectangle of the cell.
Calendar.GetDateAt (Point) | Returns the date of the calendar cell located at the specified position.
Calendar.GetDateAt (Point, Rectangle@) | Returns the date of the calendar cell located at the specified position and the bounding rectangle of the cell.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetDateAt Method (Int32, Int32)

Calendar.GetDateAt Method (Int32, Int32)
See Also

Returns the date of the calendar cell located at the specified coordinates.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetDateAt (
int x,
int y
)
Visual Basic

Public Function GetDateAt ( _
x As Integer, _
y As Integer _
) As DateTime

Parameters

x
The x-coordinate of the position at which to look for a date cell.
y
The y-coordinate of the position at which to look for a date cell.

Return Value

A .NET DateTime instance indicating which date is displayed at the specified position. If there is no date cell at the specified position, the return value is DateTime.MinValue.

See Also

GetDateAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetContactAt Method
GetLocationAt Method
GetTaskAt Method
GetResourceAt Method
GetItemAt Method


MindFusion.Scheduling.WinForms.Calendar.GetDateAt Method (Int32, Int32, Rectangle@)

Calendar.GetDateAt Method (Int32, Int32, Rectangle@)
See Also

Returns the date of the calendar cell located at the specified position and the bounding rectangle of the cell.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetDateAt (
int x,
int y,
ref Rectangle bounds
)
Visual Basic

Public Function GetDateAt ( _
x As Integer, _
y As Integer, _
ByRef bounds As Rectangle _
) As DateTime

Parameters

x
y
bounds

Return Value

See Also

GetDateAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetDateAt Method (Point)

Calendar.GetDateAt Method (Point)
See Also

Returns the date of the calendar cell located at the specified position.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetDateAt (
Point point
)
Visual Basic

Public Function GetDateAt ( _
point As Point _
) As DateTime

Parameters

point
The position at which to look for a date cell.

Return Value

A .NET DateTime instance indicating which date is displayed at the specified position. If there is no date cell at the specified point, the return value is DateTime.MinValue.

See Also

GetDateAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetContactAt Method
GetLocationAt Method
GetTaskAt Method
GetResourceAt Method
GetItemAt Method


MindFusion.Scheduling.WinForms.Calendar.GetDateAt Method (Point, Rectangle@)

Calendar.GetDateAt Method (Point, Rectangle@)
See Also

Returns the date of the calendar cell located at the specified position and the bounding rectangle of the cell.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetDateAt (
Point point,
ref Rectangle bounds
)
Visual Basic

Public Function GetDateAt ( _
point As Point, _
ByRef bounds As Rectangle _
) As DateTime

Parameters

point
bounds

Return Value

See Also

GetDateAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetElementBounds Method

Calendar.GetElementBounds Method

Gets the bounding rectangle of a particular calendar element.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Rectangle GetElementBounds (
CalendarElement element,
int index
)
Visual Basic

Public Function GetElementBounds ( _
element As CalendarElement, _
index As Integer _
) As Rectangle

Parameters

element
The type of the element whose bounds to retrieve.
index
The index of the element, if there is more than one element of the specified type.

Return Value

The bounding rectangle of the specified element or Rectangle.Empty if the element is either not present in the current view or not visible in the current viewport.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetExactDateAt Method

Calendar.GetExactDateAt Method

Returns the date located at a specified position.

Overload List

Name | Description
Calendar.GetExactDateAt (Int32, Int32) | Returns the date located at the specified coordinates.
Calendar.GetExactDateAt (Point) | Returns the date located at the specified position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetExactDateAt Method (Int32, Int32)

Calendar.GetExactDateAt Method (Int32, Int32)
See Also

Returns the date located at the specified coordinates.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetExactDateAt (
int x,
int y
)
Visual Basic

Public Function GetExactDateAt ( _
x As Integer, _
y As Integer _
) As DateTime

Parameters

x
The x-coordinate of the position at which to look for a date.
y
The y-coordinate of the position at which to look for a date.

Return Value

A DateTime instance indicating which date is displayed at the specified position. If there is no date at the specified position, the return value is DateTime.MinValue.

Remarks

The returned value represents the exact date located at the specified position in contrast with GetDateAt, which returns the start date of the cell, located at the specified position.

This method works only in a Timetable view.

See Also

GetExactDateAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetExactDateAt Method (Point)

Calendar.GetExactDateAt Method (Point)
See Also

Returns the date located at the specified position.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetExactDateAt (
Point point
)
Visual Basic

Public Function GetExactDateAt ( _
point As Point _
) As DateTime

Parameters

point
The position at which to look for a date.

Return Value

A .NET DateTime instance indicating which date is displayed at the specified position. If there is no date cell at the specified point, the return value is DateTime.MinValue.

Remarks

The returned value represents the exact date located at the specified position in contrast with GetDateAt, which returns the start date of the cell, located at the specified position.

This method works only in a Timetable view.

See Also

GetExactDateAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetFirstDate Method

Calendar.GetFirstDate Method

Gets the first date of the time range displayed in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetFirstDate ()
Visual Basic

Public Function GetFirstDate () As DateTime

Return Value

A .NET DateTime instance indicating the first date.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetLastDate Method
GetFirstVisibleDate Method


MindFusion.Scheduling.WinForms.Calendar.GetFirstVisibleDate Method

Calendar.GetFirstVisibleDate Method

Determines which is the first visible date in the current view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetFirstVisibleDate ()
Visual Basic

Public Function GetFirstVisibleDate () As DateTime

Return Value

A .NET DateTime object indicating the first visible date.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetLastVisibleDate Method
GetFirstDate Method


MindFusion.Scheduling.WinForms.Calendar.GetItemAt Method

Calendar.GetItemAt Method

Gets the scheduled Item object displayed at the specified coordinates.

Overload List

Name | Description
Calendar.GetItemAt (Int32, Int32) | Gets the scheduled Item object displayed at the specified coordinates.
Calendar.GetItemAt (Point) | Gets the scheduled Item object displayed at the specified coordinates.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetItemAt Method (Int32, Int32)

Calendar.GetItemAt Method (Int32, Int32)
See Also

Gets the scheduled Item object displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Item GetItemAt (
int x,
int y
)
Visual Basic

Public Function GetItemAt ( _
x As Integer, _
y As Integer _
) As Item

Parameters

x
The x-coordinate of the position at which to look for a scheduled item.
y
The y-coordinate of the position at which to look for a scheduled item.

Return Value

The scheduled Item displayed at the specified position.

See Also

GetItemAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetContactAt Method
GetLocationAt Method
GetTaskAt Method
GetResourceAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetItemAt Method (Point)

Calendar.GetItemAt Method (Point)
See Also

Gets the scheduled Item object displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Item GetItemAt (
Point point
)
Visual Basic

Public Function GetItemAt ( _
point As Point _
) As Item

Parameters

point
The position at which to look for a scheduled item.

Return Value

The scheduled Item displayed at the specified position.

See Also

GetItemAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetContactAt Method
GetLocationAt Method
GetTaskAt Method
GetResourceAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetItemBounds Method

Calendar.GetItemBounds Method

Retrieves the bounding rectangle of the specified item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Rectangle GetItemBounds (
Item item
)
Visual Basic

Public Function GetItemBounds ( _
item As Item _
) As Rectangle

Parameters

item
A reference to the item whose bounds to retrieve.

Return Value

The visible part of the bounding rectangle of the specified item, expressed in coordinates relative to the control. The return value is Rectangle.Empty if the item is not visible.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetItemListLane Method

Calendar.GetItemListLane Method

Gets the index of the lane of the specified item within a List view whose FreeDrag property is enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int GetItemListLane (
Item item
)
Visual Basic

Public Function GetItemListLane ( _
item As Item _
) As Integer

Parameters

item
A reference to the Item whose lane index to retrieve.

Return Value

The zero-based index of the item lane or -1, if the item is not associated with a lane.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
SetItemListLane Method


MindFusion.Scheduling.WinForms.Calendar.GetLastDate Method

Calendar.GetLastDate Method

Gets the last date of the time range displayed in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetLastDate ()
Visual Basic

Public Function GetLastDate () As DateTime

Return Value

A .NET DateTime instance indicating the last date.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetFirstDate Method
GetLastVisibleDate Method


MindFusion.Scheduling.WinForms.Calendar.GetLastVisibleDate Method

Calendar.GetLastVisibleDate Method

Determines which is the last visible date in the current view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime GetLastVisibleDate ()
Visual Basic

Public Function GetLastVisibleDate () As DateTime

Return Value

A .NET DateTime object indicating the last visible date.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetLastDate Method
GetFirstVisibleDate Method


MindFusion.Scheduling.WinForms.Calendar.GetListLaneAt Method

Calendar.GetListLaneAt Method

Retrieves the index of the List view lane at the specified point, expressed in client coordinates.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int GetListLaneAt (
Point point
)
Visual Basic

Public Function GetListLaneAt ( _
point As Point _
) As Integer

Parameters

point
The point to test, expressed in client coordinates.

Return Value

The zero-based index of the lane at the specified position or -1, if the the point does not lie over a lane.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetLocationAt Method

Calendar.GetLocationAt Method

Gets the Location object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.

Overload List

Name | Description
Calendar.GetLocationAt (Int32, Int32) | Gets the Location object whose schedule is displayed at the specified coordinates.
Calendar.GetLocationAt (Point) | Gets the Location object whose schedule is displayed at the specified position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetLocationAt Method (Int32, Int32)

Calendar.GetLocationAt Method (Int32, Int32)
See Also

Gets the Location object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Location GetLocationAt (
int x,
int y
)
Visual Basic

Public Function GetLocationAt ( _
x As Integer, _
y As Integer _
) As Location

Parameters

x
The x-coordinate of the position at which to look for location's scheduled items.
y
The y-coordinate of the position at which to look for location's scheduled items.

Return Value

An instance of the Location class representing the location related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetLocationAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetContactAt Method
GetTaskAt Method
GetResourceAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetLocationAt Method (Point)

Calendar.GetLocationAt Method (Point)
See Also

Gets the Location object whose schedule is displayed at the specified position.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Location GetLocationAt (
Point point
)
Visual Basic

Public Function GetLocationAt ( _
point As Point _
) As Location

Parameters

point
The position at which to look for location's scheduled items.

Return Value

An instance of the Location class representing the location related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetLocationAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetContactAt Method
GetTaskAt Method
GetResourceAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetResourceAt Method

Calendar.GetResourceAt Method

Gets the Resource object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.

Overload List

Name | Description
Calendar.GetResourceAt (Int32, Int32) | Gets the Resource object whose schedule is displayed at the specified coordinates.
Calendar.GetResourceAt (Point) | Gets the Resource object whose schedule is displayed at the specified coordinates.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetResourceAt Method (Int32, Int32)

Calendar.GetResourceAt Method (Int32, Int32)
See Also

Gets the Resource object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Resource GetResourceAt (
int x,
int y
)
Visual Basic

Public Function GetResourceAt ( _
x As Integer, _
y As Integer _
) As Resource

Parameters

x
The x-coordinate of the position at which to look for resource's scheduled items.
y
The y-coordinate of the position at which to look for resource's scheduled items.

Return Value

An instance of the Resource class representing the resource related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetResourceAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetContactAt Method
GetLocationAt Method
GetTaskAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetResourceAt Method (Point)

Calendar.GetResourceAt Method (Point)
See Also

Gets the Resource object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Resource GetResourceAt (
Point point
)
Visual Basic

Public Function GetResourceAt ( _
point As Point _
) As Resource

Parameters

point
The position at which to look for resource's scheduled items.

Return Value

An instance of the Resource class representing the resource related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetResourceAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetContactAt Method
GetLocationAt Method
GetTaskAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetTaskAt Method

Calendar.GetTaskAt Method

Gets the Task object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.

Overload List

Name | Description
Calendar.GetTaskAt (Int32, Int32) | Gets the Task object whose schedule is displayed at the specified coordinates.
Calendar.GetTaskAt (Point) | Gets the Task object whose schedule is displayed at the specified position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GetTaskAt Method (Int32, Int32)

Calendar.GetTaskAt Method (Int32, Int32)
See Also

Gets the Task object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Task GetTaskAt (
int x,
int y
)
Visual Basic

Public Function GetTaskAt ( _
x As Integer, _
y As Integer _
) As Task

Parameters

x
The x-coordinate of the position at which to look for task's scheduled items.
y
The y-coordinate of the position at which to look for task's scheduled items.

Return Value

An instance of the Task class representing the task related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetTaskAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetContactAt Method
GetLocationAt Method
GetResourceAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetTaskAt Method (Point)

Calendar.GetTaskAt Method (Point)
See Also

Gets the Task object whose schedule is displayed at the specified position.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Task GetTaskAt (
Point point
)
Visual Basic

Public Function GetTaskAt ( _
point As Point _
) As Task

Parameters

point
The position at which to look for task's scheduled items.

Return Value

An instance of the Task class representing the task related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetTaskAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetContactAt Method
GetLocationAt Method
GetResourceAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetVisibleItems Method

Calendar.GetVisibleItems Method

Retrieves a collection with all currently visible items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemCollection GetVisibleItems ()
Visual Basic

Public Function GetVisibleItems () As ItemCollection

Return Value

An instance of the ItemCollection class containing all items currently visible within the control. The collection is empty if there are no visible items.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.IsResourceRowExpanded Method

Calendar.IsResourceRowExpanded Method

Checks whether the row associated with the specified Contact, Location, Task or Resource in a Resource view is expanded.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool IsResourceRowExpanded (
Resource reference
)
Visual Basic

Public Function IsResourceRowExpanded ( _
reference As Resource _
) As Boolean

Parameters

reference
A reference to a Contact, Location, Task or Resource object to be checked.

Return Value

Returns true if the associated row is expanded or false if either the row is collapsed, there is no such row or the current view is not a ResourceView.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
CollapseResourceRow Method
ExpandResourceRow Method


MindFusion.Scheduling.WinForms.Calendar.LoadFrom Method

Calendar.LoadFrom Method

Overload List

Name | Description
Calendar.LoadFrom (String) | Loads schedule data from the specified file.
Calendar.LoadFrom (String, ContentType) | Loads schedule data from the specified file.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.LoadFrom Method (String)

Calendar.LoadFrom Method (String)
See Also

Loads schedule data from the specified file.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

public void LoadFrom (
string fileName
)
Visual Basic

Public Sub LoadFrom ( _
fileName As String _
)

Parameters

fileName
The name of the file from which to load the schedule.

Remarks

This method loads the schedule data from a file where it was previously saved by a call to SaveTo. Any data contained in the schedule is discarded before the items stored in the file are loaded. This method also attempts to load a previously saved view state.

See Also

LoadFrom Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.LoadFrom Method (String, ContentType)

Calendar.LoadFrom Method (String, ContentType)
See Also

Loads schedule data from the specified file.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void LoadFrom (
string fileName,
ContentType contentType
)
Visual Basic

Public Sub LoadFrom ( _
fileName As String, _
contentType As ContentType _
)

Parameters

fileName
The name of the file from which to load the schedule.
contentType
Specifies whether the data is in binary or XML format.

Remarks

This method loads the schedule data from a file where it was previously saved by a call to SaveTo. Any data contained in the schedule is discarded before the items stored in the file are loaded. This method also attempts to load a previously saved view state such as the item position within a List view whose FreeDrag property is enabled.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
SaveTo Method
Schedule.LoadFrom Method


MindFusion.Scheduling.WinForms.Calendar.LoadFromDataSource Method

Calendar.LoadFromDataSource Method

Loads the schedule from the underlying data source.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void LoadFromDataSource ()
Visual Basic

Public Sub LoadFromDataSource ()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
SaveToDataSource Method


MindFusion.Scheduling.WinForms.Calendar.LoadViewSettings Method

Calendar.LoadViewSettings Method

Loads the view settings from the specified stream or XML document.

Overload List

Name | Description
Calendar.LoadViewSettings (Stream) | Loads the view settings from the specified stream.
Calendar.LoadViewSettings (XmlDocument, String) | Loads the view settings under the specified name from the specified XML document.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.LoadViewSettings Method (Stream)

Calendar.LoadViewSettings Method (Stream)
See Also

Loads the view settings from the specified stream.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void LoadViewSettings (
Stream stream
)
Visual Basic

Public Sub LoadViewSettings ( _
stream As Stream _
)

Parameters

stream
A .NET System.IO.Stream to load the settings from.

Remarks

This method restores view settings (such as the item position within a List view whose FreeDrag property is enabled) where they were previously saved by a call to SaveViewSettings.

See Also

LoadViewSettings Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
SaveViewSettings Method


MindFusion.Scheduling.WinForms.Calendar.LoadViewSettings Method (XmlDocument, String)

Calendar.LoadViewSettings Method (XmlDocument, String)
See Also

Loads the view settings under the specified name from the specified XML document.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void LoadViewSettings (
XmlDocument document,
string name
)
Visual Basic

Public Sub LoadViewSettings ( _
document As XmlDocument, _
name As String _
)

Parameters

document
A .NET System.Xml.XmlDocument to load the settings from.
name
The name of the XML element where the settings should be looked for. If the name is null (Nothing in Visual Basic), the name of the control is used as a key.

Remarks

This method restores view settings (such as the item position within a List view whose FreeDrag property is enabled) where they were previously saved by a call to SaveViewSettings.

See Also

LoadViewSettings Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
SaveViewSettings Method


MindFusion.Scheduling.WinForms.Calendar.OnContinuePrinting Method

Calendar.OnContinuePrinting Method

Raises the ContinuePrinting event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnContinuePrinting (
ContinuePrintingEventArgs e
)
Visual Basic

Protected Overridable Sub OnContinuePrinting ( _
e As ContinuePrintingEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnDateClick Method

Calendar.OnDateClick Method

Raises the DateClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnDateClick (
ResourceDateEventArgs e
)
Visual Basic

Protected Overridable Sub OnDateClick ( _
e As ResourceDateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnDraw Method

Calendar.OnDraw Method

Raises the Draw event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnDraw (
DrawEventArgs e
)
Visual Basic

Protected Overridable Sub OnDraw ( _
e As DrawEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnHiddenItemClick Method

Calendar.OnHiddenItemClick Method

Raises the HiddenItemClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnHiddenItemClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnHiddenItemClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnHScroll Method

Calendar.OnHScroll Method

Overload List

Name | Description
Calendar.OnHScroll (EventArgs) | Raises the HScroll event.
Calendar.OnHScroll (ScrollEventArgs) | Raises the HScroll event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnHScroll Method (EventArgs)

Calendar.OnHScroll Method (EventArgs)
See Also

Raises the HScroll event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

protected virtual void OnHScroll (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnHScroll ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

OnHScroll Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnHScroll Method (ScrollEventArgs)

Calendar.OnHScroll Method (ScrollEventArgs)
See Also

Raises the HScroll event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnHScroll (
ScrollEventArgs e
)
Visual Basic

Protected Overridable Sub OnHScroll ( _
e As ScrollEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

OnHScroll Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemClick Method

Calendar.OnItemClick Method

Raises the ItemClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemClick (
ItemMouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemClick ( _
e As ItemMouseEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemCloned Method

Calendar.OnItemCloned Method

Raises the ItemCloned event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemCloned (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemCloned ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemCloning Method

Calendar.OnItemCloning Method

Raises the ItemCloning event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemCloning (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemCloning ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemCreated Method

Calendar.OnItemCreated Method

Raises the ItemCreated event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemCreated (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemCreated ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemCreating Method

Calendar.OnItemCreating Method

Raises the ItemCreating event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemCreating (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemCreating ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemCreationCanceled Method

Calendar.OnItemCreationCanceled Method

Raises the ItemCreationCanceled event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemCreationCanceled (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemCreationCanceled ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemDeleted Method

Calendar.OnItemDeleted Method

Raises the ItemDeleted event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemDeleted (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemDeleted ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemDeleting Method

Calendar.OnItemDeleting Method

Raises the ItemDeleting event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemDeleting (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemDeleting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemDeselecting Method

Calendar.OnItemDeselecting Method

Raises the ItemDeselecting event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemDeselecting (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemDeselecting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemInplaceEdited Method

Calendar.OnItemInplaceEdited Method

Raises the ItemInplaceEdited event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemInplaceEdited (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemInplaceEdited ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemInplaceEditEnding Method

Calendar.OnItemInplaceEditEnding Method

Raises the ItemInplaceEditEnding event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemInplaceEditEnding (
ItemEditConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemInplaceEditEnding ( _
e As ItemEditConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemInplaceEditStarting Method

Calendar.OnItemInplaceEditStarting Method

Raises the ItemInplaceEditStarting event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemInplaceEditStarting (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemInplaceEditStarting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemListLaneChanged Method

Calendar.OnItemListLaneChanged Method

Raises the ItemListLaneChanged event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemListLaneChanged (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemListLaneChanged ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemModificationCanceled Method

Calendar.OnItemModificationCanceled Method

Raises the ItemModificationCanceled event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemModificationCanceled (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemModificationCanceled ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemModified Method

Calendar.OnItemModified Method

Raises the ItemModified event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemModified (
ItemModifiedEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemModified ( _
e As ItemModifiedEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemModifying Method

Calendar.OnItemModifying Method

Raises the ItemModifying event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemModifying (
ItemModifyConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemModifying ( _
e As ItemModifyConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemSelecting Method

Calendar.OnItemSelecting Method

Raises the ItemSelecting event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemSelecting (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemSelecting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemSelectionChanged Method

Calendar.OnItemSelectionChanged Method

Raises the ItemSelectionChanged event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemSelectionChanged (
ItemSelectionEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemSelectionChanged ( _
e As ItemSelectionEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemSelectionComplete Method

Calendar.OnItemSelectionComplete Method

Raises the ItemSelectionComplete event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemSelectionComplete (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnItemSelectionComplete ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemTooltipDisplaying Method

Calendar.OnItemTooltipDisplaying Method

Raises the ItemTooltipDisplaying event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnItemTooltipDisplaying (
ItemTooltipEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemTooltipDisplaying ( _
e As ItemTooltipEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnKeyDown Method

Calendar.OnKeyDown Method

Control.OnKeyDown override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnKeyDown (
KeyEventArgs e
)
Visual Basic

Protected Overridable Sub OnKeyDown ( _
e As KeyEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnKeyPress Method

Calendar.OnKeyPress Method

Control.OnKeyPress override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnKeyPress (
KeyPressEventArgs e
)
Visual Basic

Protected Overridable Sub OnKeyPress ( _
e As KeyPressEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnListViewHeaderClick Method

Calendar.OnListViewHeaderClick Method

Raises the ListViewHeaderClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnListViewHeaderClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnListViewHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnLostFocus Method

Calendar.OnLostFocus Method

Control.OnLostFocus override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnLostFocus (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnLostFocus ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnMonthCellClick Method

Calendar.OnMonthCellClick Method

Raises the MonthCellClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnMonthCellClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnMonthCellClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnMonthHeaderClick Method

Calendar.OnMonthHeaderClick Method

Raises the MonthHeaderClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnMonthHeaderClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnMonthHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnMonthRangeHeaderClick Method

Calendar.OnMonthRangeHeaderClick Method

Raises the MonthRangeHeaderClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnMonthRangeHeaderClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnMonthRangeHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnMonthWeekHeaderClick Method

Calendar.OnMonthWeekHeaderClick Method

Raises the MonthWeekHeaderClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnMonthWeekHeaderClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnMonthWeekHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnMouseDown Method

Calendar.OnMouseDown Method

Control.OnMouseDown override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnMouseDown (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseDown ( _
e As MouseEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnMouseMove Method

Calendar.OnMouseMove Method

Control.OnMouseMove override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnMouseMove (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseMove ( _
e As MouseEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnMouseUp Method

Calendar.OnMouseUp Method

Control.OnMouseUp override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnMouseUp (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseUp ( _
e As MouseEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnPaint Method

Calendar.OnPaint Method

Control.OnPaint override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnPaint (
PaintEventArgs e
)
Visual Basic

Protected Overridable Sub OnPaint ( _
e As PaintEventArgs _
)

Parameters

e

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnPaintBackground Method

Calendar.OnPaintBackground Method

Control.OnPaintBackground override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnPaintBackground (
PaintEventArgs pevent
)
Visual Basic

Protected Overridable Sub OnPaintBackground ( _
pevent As PaintEventArgs _
)

Parameters

pevent
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnRecurringItemDeleting Method

Calendar.OnRecurringItemDeleting Method

Raises the RecurringItemDeleting event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnRecurringItemDeleting (
RecurringItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnRecurringItemDeleting ( _
e As RecurringItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnResize Method

Calendar.OnResize Method

Control.OnResize override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnResize (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnResize ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnResourceViewBottomTimelineClick Method

Calendar.OnResourceViewBottomTimelineClick Method

Raises the ResourceViewBottomTimelineClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnResourceViewBottomTimelineClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnResourceViewBottomTimelineClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnResourceViewMiddleTimelineClick Method

Calendar.OnResourceViewMiddleTimelineClick Method

Raises the ResourceViewMiddleTimelineClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnResourceViewMiddleTimelineClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnResourceViewMiddleTimelineClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnResourceViewRowHeaderClick Method

Calendar.OnResourceViewRowHeaderClick Method

Raises the ResourceViewRowHeaderClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnResourceViewRowHeaderClick (
ResourceDateEventArgs e
)
Visual Basic

Protected Overridable Sub OnResourceViewRowHeaderClick ( _
e As ResourceDateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnResourceViewTopTimelineClick Method

Calendar.OnResourceViewTopTimelineClick Method

Raises the ResourceViewTopTimelineClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnResourceViewTopTimelineClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnResourceViewTopTimelineClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnRightToLeftChanged Method

Calendar.OnRightToLeftChanged Method

Control.OnRightToLeftChanged override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnRightToLeftChanged (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnRightToLeftChanged ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnScroll Method

Calendar.OnScroll Method

Raises the Scroll event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnScroll (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnScroll ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnTimetableColumnHeaderClick Method

Calendar.OnTimetableColumnHeaderClick Method

Raises the TimetableColumnHeaderClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnTimetableColumnHeaderClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnTimetableColumnHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnTooltipDisplaying Method

Calendar.OnTooltipDisplaying Method

Raises the TooltipDisplaying event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnTooltipDisplaying (
TooltipEventArgs e
)
Visual Basic

Protected Overridable Sub OnTooltipDisplaying ( _
e As TooltipEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnVisibleDateChanged Method

Calendar.OnVisibleDateChanged Method

Raises the VisibleDateChanged event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnVisibleDateChanged (
DateChangedEventArgs e
)
Visual Basic

Protected Overridable Sub OnVisibleDateChanged ( _
e As DateChangedEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnVScroll Method

Calendar.OnVScroll Method

Overload List

Name | Description
Calendar.OnVScroll (EventArgs) | Raises the VScroll event.
Calendar.OnVScroll (ScrollEventArgs) | Raises the VScroll event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnVScroll Method (EventArgs)

Calendar.OnVScroll Method (EventArgs)
See Also

Raises the VScroll event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

protected virtual void OnVScroll (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnVScroll ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

OnVScroll Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnVScroll Method (ScrollEventArgs)

Calendar.OnVScroll Method (ScrollEventArgs)
See Also

Raises the VScroll event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnVScroll (
ScrollEventArgs e
)
Visual Basic

Protected Overridable Sub OnVScroll ( _
e As ScrollEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

OnVScroll Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.OnWeekRangeHeaderClick Method

Calendar.OnWeekRangeHeaderClick Method

Raises the WeekRangeHeaderClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnWeekRangeHeaderClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnWeekRangeHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.Print Method

Calendar.Print Method

Prints the current calendar view.

Overload List

Name | Description
Calendar.Print () | Prints the current calendar view.
Calendar.Print (PrintDocument) | Prints the current calendar view using the specified PrintDocument object.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.Print Method ()

Calendar.Print Method ()
See Also

Prints the current calendar view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Print ()
Visual Basic

Public Sub Print ()

Remarks

Use the PrintOptions members to customize the print output, used both when printing and when displaying print preview.

See Also

Print Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
PrintPreview Method


MindFusion.Scheduling.WinForms.Calendar.Print Method (PrintDocument)

Calendar.Print Method (PrintDocument)
See Also

Prints the current calendar view using the specified PrintDocument object.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Print (
PrintDocument doc
)
Visual Basic

Public Sub Print ( _
doc As PrintDocument _
)

Parameters

doc
A .NET PrintDocument object to print to.

Remarks

Use the PrintOptions members to customize the print output, used both when printing and when displaying print preview.

See Also

Print Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
PrintPreview Method


MindFusion.Scheduling.WinForms.Calendar.PrintPreview Method

Calendar.PrintPreview Method

Displays a print preview window for the current calendar view.

Overload List

Name | Description
Calendar.PrintPreview () | Displays a print preview window for the current calendar view.
Calendar.PrintPreview (PrintDocument) | Displays a print preview window for the current calendar view. Drawing is done using the specified PrintDocument object.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.PrintPreview Method ()

Calendar.PrintPreview Method ()
See Also

Displays a print preview window for the current calendar view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void PrintPreview ()
Visual Basic

Public Sub PrintPreview ()

Remarks

Use the PrintOptions members to customize the print output, used both when printing and when displaying print preview.

See Also

PrintPreview Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
Print Method


MindFusion.Scheduling.WinForms.Calendar.PrintPreview Method (PrintDocument)

Calendar.PrintPreview Method (PrintDocument)
See Also

Displays a print preview window for the current calendar view. Drawing is done using the specified PrintDocument object.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void PrintPreview (
PrintDocument doc
)
Visual Basic

Public Sub PrintPreview ( _
doc As PrintDocument _
)

Parameters

doc
A .NET PrintDocument object to print to.

Remarks

Use the PrintOptions members to customize the print output, used both when printing and when displaying print preview.

See Also

PrintPreview Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
Print Method


MindFusion.Scheduling.WinForms.Calendar.ProcessDialogKey Method

Calendar.ProcessDialogKey Method

Control.ProcessDialogKey override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual bool ProcessDialogKey (
Keys keyData
)
Visual Basic

Protected Overridable Function ProcessDialogKey ( _
keyData As Keys _
) As Boolean

Parameters

keyData
One of the values from the .NET Keys enumeration that represents the key to process.

Return Value

true if the key was processed by the control; otherwise, false.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ResetDrag Method

Calendar.ResetDrag Method

If there is a mouse drag operation in progress, it is canceled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void ResetDrag ()
Visual Basic

Public Sub ResetDrag ()

Remarks

Call this method if a message box or a dialog must be displayed in response to various *Click events, but you do not want the control to continue tracking the mouse afterwards.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ResetItemViewState Method

Calendar.ResetItemViewState Method

Resets the view-related item data contained in the underlying schedule. For example, items moved around in a list view with enabled FreeDrag property have their relative positions within the view reset.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void ResetItemViewState ()
Visual Basic

Public Sub ResetItemViewState ()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ResumeDrag Method

Calendar.ResumeDrag Method

Resumes the previously paused mouse drag operation.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void ResumeDrag ()
Visual Basic

Public Sub ResumeDrag ()

Remarks

Use this method in conjunction with the SuspendDrag method to temporarily disable control response to user interactions. The most common scenario where you would use these two methods is when you want to display a modal dialog during user interaction without terminating it.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
SuspendDrag Method


MindFusion.Scheduling.WinForms.Calendar.SaveTo Method

Calendar.SaveTo Method

Overload List

Name | Description
Calendar.SaveTo (String) | Saves the underlying schedule to the specified file.
Calendar.SaveTo (String, ContentType) | Saves the underlying schedule to the specified file.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.SaveTo Method (String)

Calendar.SaveTo Method (String)
See Also

Saves the underlying schedule to the specified file.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

public void SaveTo (
string fileName
)
Visual Basic

Public Sub SaveTo ( _
fileName As String _
)

Parameters

fileName
The path of the file to save to.

Remarks

Saves the schedule data into a XML file. Use LoadFrom to restore the data later. This method also attempts to save the current view state.

See Also

SaveTo Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.SaveTo Method (String, ContentType)

Calendar.SaveTo Method (String, ContentType)
See Also

Saves the underlying schedule to the specified file.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void SaveTo (
string fileName,
ContentType contentType
)
Visual Basic

Public Sub SaveTo ( _
fileName As String, _
contentType As ContentType _
)

Parameters

fileName
The path of the file to save to.
contentType
Specifies whether to save the data in binary or XML format.

Remarks

This method saves the schedule data to the specified binary or XML file. The data can be subsequently restored by a call to the LoadFrom method. This method also attempts to save the current view state such as the item position within a List view whose FreeDrag property is enabled.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
LoadFrom Method


MindFusion.Scheduling.WinForms.Calendar.SaveToDataSource Method

Calendar.SaveToDataSource Method

Saves the current schedule to the underlying data source.

Overload List

Name | Description
Calendar.SaveToDataSource () | Saves the current schedule to the underlying data source.
Calendar.SaveToDataSource (Component, Component, Component, Component, Component, Component, Component, Component, Component, Component, Component, Component, Component) | Saves the current schedule to the underlying data source.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.SaveToDataSource Method ()

Calendar.SaveToDataSource Method ()
See Also

Saves the current schedule to the underlying data source.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void SaveToDataSource ()
Visual Basic

Public Sub SaveToDataSource ()

See Also

SaveToDataSource Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
LoadFromDataSource Method


MindFusion.Scheduling.WinForms.Calendar.SaveToDataSource Method (Component, Component, Component, Component, Component, Component, Component, Component, Component, Component, Component, Component, Component)

Calendar.SaveToDataSource Method (Component, Component, Component, Component, Component, Component, Component, Component, Component, Component, Component, Component, Component)
See Also

Saves the current schedule to the underlying data source.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void SaveToDataSource (
Component reminderTableAdapter,
Component styleTableAdapter,
Component customBrushesTableAdapter,
Component contactTableAdapter,
Component locationTableAdapter,
Component resourceTableAdapter,
Component taskTableAdapter,
Component itemTableAdapter,
Component itemContactsTableAdapter,
Component itemResourcesTableAdapter,
Component recurrenceTableAdapter,
Component recurrenceExceptionTableAdapter,
Component recurrenceExceptionsTableAdapter
)
Visual Basic

Public Sub SaveToDataSource ( _
reminderTableAdapter As Component, _
styleTableAdapter As Component, _
customBrushesTableAdapter As Component, _
contactTableAdapter As Component, _
locationTableAdapter As Component, _
resourceTableAdapter As Component, _
taskTableAdapter As Component, _
itemTableAdapter As Component, _
itemContactsTableAdapter As Component, _
itemResourcesTableAdapter As Component, _
recurrenceTableAdapter As Component, _
recurrenceExceptionTableAdapter As Component, _
recurrenceExceptionsTableAdapter As Component _
)

Parameters

reminderTableAdapter
A data adapter for the reminders table.
styleTableAdapter
A data adapter for the styles table.
customBrushesTableAdapter
A data adapter for the custom brushes table.
contactTableAdapter
A data adapter for the contacts table.
locationTableAdapter
A data adapter for the locations table.
resourceTableAdapter
A data adapter for the resources table.
taskTableAdapter
A data adapter for the tasks table.
itemTableAdapter
A data adapter for the items table.
itemContactsTableAdapter
A data adapter for the many-to-many table between items and contacts.
itemResourcesTableAdapter
A data adapter for the many-to-many table between items and resources.
recurrenceTableAdapter
A data adapter for the recurrences table.
recurrenceExceptionTableAdapter
A data adapter for the recurrence exceptions table.
recurrenceExceptionsTableAdapter
A data adapter for the many-to-many table between recurrences and their exceptions.

See Also

SaveToDataSource Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
LoadFromDataSource Method


MindFusion.Scheduling.WinForms.Calendar.SaveViewSettings Method

Calendar.SaveViewSettings Method

Saves the view settings to the specified stream or XML document.

Overload List

Name | Description
Calendar.SaveViewSettings (Stream) | Saves the view settings to the specified stream.
Calendar.SaveViewSettings (XmlDocument, String) | Saves the view settings to the specified XML document under the specified name.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.SaveViewSettings Method (Stream)

Calendar.SaveViewSettings Method (Stream)
See Also

Saves the view settings to the specified stream.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void SaveViewSettings (
Stream stream
)
Visual Basic

Public Sub SaveViewSettings ( _
stream As Stream _
)

Parameters

stream
A .NET System.IO.Stream to save the settings to.

Remarks

This method stores the current view settings (such as the item position within a List view whose FreeDrag property is enabled) to the specified stream where they can be subsequently restored from by a call to LoadViewSettings.

See Also

SaveViewSettings Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
LoadViewSettings Method


MindFusion.Scheduling.WinForms.Calendar.SaveViewSettings Method (XmlDocument, String)

Calendar.SaveViewSettings Method (XmlDocument, String)
See Also

Saves the view settings to the specified XML document under the specified name.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void SaveViewSettings (
XmlDocument document,
string name
)
Visual Basic

Public Sub SaveViewSettings ( _
document As XmlDocument, _
name As String _
)

Parameters

document
A .NET System.Xml.XmlDocument to save the settings to.
name
The name of the XML element where the settings should be saved. If the name is null (Nothing in Visual Basic), the name of the control is used as a key.

Remarks

This method stores the current view settings (such as the item position within a List view whose FreeDrag property is enabled) to the specified document where they can be subsequently restored from by a call to LoadViewSettings.

See Also

SaveViewSettings Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
LoadViewSettings Method


MindFusion.Scheduling.WinForms.Calendar.SetItemListLane Method

Calendar.SetItemListLane Method

Sets the lane index for the specified item within a List view whose FreeDrag property is enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void SetItemListLane (
Item item,
int lane
)
Visual Basic

Public Sub SetItemListLane ( _
item As Item, _
lane As Integer _
)

Parameters

item
A reference to the Item whose lane index to set.
lane
The zero-based index of the new item lane.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
GetItemListLane Method


MindFusion.Scheduling.WinForms.Calendar.StartInplaceEdit Method

Calendar.StartInplaceEdit Method

Starts in-place editing mode for the specified item to let users edit the item's text.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void StartInplaceEdit (
Item item
)
Visual Basic

Public Sub StartInplaceEdit ( _
item As Item _
)

Parameters

item
Specifies which Item should be edited in place.

Remarks

The ItemInplaceEditStarting event is raised to validate the operation, even if entering in-place edit mode programmatically.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.StartModify Method

Calendar.StartModify Method

Initiates interactive modification on the specified item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool StartModify (
Item item,
Point initial
)
Visual Basic

Public Function StartModify ( _
item As Item, _
initial As Point _
) As Boolean

Parameters

item
The item to modify interactively.
initial
The initial point of the interactive modification.

Return Value

true if the modification was successfully started; otherwise, false.

Remarks

Through the use of the StartModify, UpdateModify, CompleteModify and CancelModify methods you can implement item drag operations within the Calendar control. This is useful in certain situations, such as when implementing OLE drag & drop operation over the Calendar control and you want the dragged item to be modified within the control before the drag & drop operation is complete.

Example

The following code demonstrates how to implement the drag & drop scenario from the remarks section using these four methods. The sample assumes that the calendar variable already identifies a valid Calendar instance.

C#

// ...

private Appointment dragged = null;
private bool started = false;

/// <summary>
/// Handles the DragEnter event of the Calendar class.
/// </summary>
private void calendar_DragEnter(object sender, DragEventArgs e)
{
dragged = new Appointment();
dragged.StartTime = DateTime.MinValue;
dragged.EndTime = dragged.StartTime + TimeSpan.FromDays(1);
dragged.HeaderText = "Dragged appointment";
calendar.Schedule.Items.Add(dragged);
started = calendar.StartModify(dragged,
calendar.PointToClient(new Point(e.X, e.Y)));
}

/// <summary>
/// Handles the DragLeave event of the Calendar class.
/// </summary>
private void calendar_DragLeave(object sender, EventArgs e)
{
if (dragged != null)
{
calendar.CancelModify();
calendar.Schedule.Items.Remove(dragged);
dragged = null;
}
}

/// <summary>
/// Handles the DragOver event of the Calendar class.
/// </summary>
private void calendar_DragOver(object sender, DragEventArgs e)
{
if (dragged != null)
{
if (!started)
started = calendar.StartModify(dragged, calendar.PointToClient(new Point(e.X, e.Y)));

if (started)
{
calendar.UpdateModify(calendar.PointToClient(new Point(e.X, e.Y)));
e.Effect = DragDropEffects.Copy;
return;
}
}

e.Effect = DragDropEffects.None;
}

/// <summary>
/// Handles the DragDrop event of the Calendar class.
/// </summary>
private void calendar_DragDrop(object sender, DragEventArgs e)
{
if (dragged != null)
{
calendar.CompleteModify(calendar.PointToClient(new Point(e.X, e.Y)));
dragged = null;

calendar.UpdateLayout();
}
}

// ...
Visual Basic

' ...

Private dragged As Appointment = Nothing
Private started As Boolean = False

' <summary>
' Handles the DragEnter event of the Calendar class.
' </summary>
Private Sub calendar_DragEnter(ByVal sender As Object, ByVal e As DragEventArgs) Handles calendar.DragEnter

dragged = New Appointment
dragged.StartTime = DateTime.MinValue
dragged.EndTime = dragged.StartTime.Add(TimeSpan.FromDays(1))
dragged.HeaderText = "Dragged appointment"
calendar.Schedule.Items.Add(dragged)
started = calendar.StartModify(dragged, _
calendar.PointToClient(New Point(e.X, e.Y)))

End Sub

' <summary>
' Handles the DragLeave event of the Calendar class.
' </summary>
Private Sub calendar_DragLeave(ByVal sender As Object, ByVal e As EventArgs) Handles calendar.DragLeave

If Not dragged Is Nothing Then

calendar.CancelModify()
calendar.Schedule.Items.Remove(dragged)
dragged = Nothing

End If

End Sub

' <summary>
' Handles the DragOver event of the Calendar class.
' </summary>
Private Sub calendar_DragOver(ByVal sender As Object, ByVal e As DragEventArgs) Handles calendar.DragOver

If Not dragged Is Nothing Then

If Not started Then
started = calendar.StartModify(dragged, calendar.PointToClient(New Point(e.X, e.Y)))
End If

If started Then

calendar.UpdateModify(calendar.PointToClient(New Point(e.X, e.Y)))
e.Effect = DragDropEffects.Copy
Return

End If

End If

e.Effect = DragDropEffects.None

End Sub

' <summary>
' Handles the DragDrop event of the Calendar class.
' </summary>
Private Sub calendar_DragDrop(ByVal sender As Object, ByVal e As DragEventArgs) Handles calendar.DragDrop

If Not dragged Is Nothing Then

calendar.CompleteModify(calendar.PointToClient(New Point(e.X, e.Y)))
dragged = Nothing

calendar.UpdateLayout()

End If

End Sub

' ...

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
UpdateModify Method
CompleteModify Method
CancelModify Method


MindFusion.Scheduling.WinForms.Calendar.SuspendDrag Method

Calendar.SuspendDrag Method

Temporarily pauses the current mouse drag operation.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void SuspendDrag ()
Visual Basic

Public Sub SuspendDrag ()

Remarks

Use this method in conjunction with the ResumeDrag method to temporarily disable control response to user interactions. The most common scenario where you would use these two methods is when you want to display a modal dialog during user interaction without terminating it.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ResumeDrag Method


MindFusion.Scheduling.WinForms.Calendar.UpdateLayout Method

Calendar.UpdateLayout Method

Updates the position of the calendar's child controls such as buttons and scrollbars.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void UpdateLayout ()
Visual Basic

Public Sub UpdateLayout ()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.UpdateModify Method

Calendar.UpdateModify Method

Updates an interactive modification of an item, previously started by a call to StartModify.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool UpdateModify (
Point point
)
Visual Basic

Public Function UpdateModify ( _
point As Point _
) As Boolean

Parameters

point
The current point of the interactive modification.

Return Value

true if the modification was successfully updated; otherwise, false.

Remarks

Through the use of the StartModify, UpdateModify, CompleteModify and CancelModify methods you can implement item drag operations within the Calendar control. This is useful in certain situations, such as when implementing OLE drag & drop operation over the Calendar control and you want the dragged item to be modified within the control before the drag & drop operation is complete.

Example

The following code demonstrates how to implement the drag & drop scenario from the remarks section using these four methods. The sample assumes that the calendar variable already identifies a valid Calendar instance.

C#

// ...

private Appointment dragged = null;
private bool started = false;

/// <summary>
/// Handles the DragEnter event of the Calendar class.
/// </summary>
private void calendar_DragEnter(object sender, DragEventArgs e)
{
dragged = new Appointment();
dragged.StartTime = DateTime.MinValue;
dragged.EndTime = dragged.StartTime + TimeSpan.FromDays(1);
dragged.HeaderText = "Dragged appointment";
calendar.Schedule.Items.Add(dragged);
started = calendar.StartModify(dragged,
calendar.PointToClient(new Point(e.X, e.Y)));
}

/// <summary>
/// Handles the DragLeave event of the Calendar class.
/// </summary>
private void calendar_DragLeave(object sender, EventArgs e)
{
if (dragged != null)
{
calendar.CancelModify();
calendar.Schedule.Items.Remove(dragged);
dragged = null;
}
}

/// <summary>
/// Handles the DragOver event of the Calendar class.
/// </summary>
private void calendar_DragOver(object sender, DragEventArgs e)
{
if (dragged != null)
{
if (!started)
started = calendar.StartModify(dragged, calendar.PointToClient(new Point(e.X, e.Y)));

if (started)
{
calendar.UpdateModify(calendar.PointToClient(new Point(e.X, e.Y)));
e.Effect = DragDropEffects.Copy;
return;
}
}

e.Effect = DragDropEffects.None;
}

/// <summary>
/// Handles the DragDrop event of the Calendar class.
/// </summary>
private void calendar_DragDrop(object sender, DragEventArgs e)
{
if (dragged != null)
{
calendar.CompleteModify(calendar.PointToClient(new Point(e.X, e.Y)));
dragged = null;

calendar.UpdateLayout();
}
}

// ...
Visual Basic

' ...

Private dragged As Appointment = Nothing
Private started As Boolean = False

' <summary>
' Handles the DragEnter event of the Calendar class.
' </summary>
Private Sub calendar_DragEnter(ByVal sender As Object, ByVal e As DragEventArgs) Handles calendar.DragEnter

dragged = New Appointment
dragged.StartTime = DateTime.MinValue
dragged.EndTime = dragged.StartTime.Add(TimeSpan.FromDays(1))
dragged.HeaderText = "Dragged appointment"
calendar.Schedule.Items.Add(dragged)
started = calendar.StartModify(dragged, _
calendar.PointToClient(New Point(e.X, e.Y)))

End Sub

' <summary>
' Handles the DragLeave event of the Calendar class.
' </summary>
Private Sub calendar_DragLeave(ByVal sender As Object, ByVal e As EventArgs) Handles calendar.DragLeave

If Not dragged Is Nothing Then

calendar.CancelModify()
calendar.Schedule.Items.Remove(dragged)
dragged = Nothing

End If

End Sub

' <summary>
' Handles the DragOver event of the Calendar class.
' </summary>
Private Sub calendar_DragOver(ByVal sender As Object, ByVal e As DragEventArgs) Handles calendar.DragOver

If Not dragged Is Nothing Then

If Not started Then
started = calendar.StartModify(dragged, calendar.PointToClient(New Point(e.X, e.Y)))
End If

If started Then

calendar.UpdateModify(calendar.PointToClient(New Point(e.X, e.Y)))
e.Effect = DragDropEffects.Copy
Return

End If

End If

e.Effect = DragDropEffects.None

End Sub

' <summary>
' Handles the DragDrop event of the Calendar class.
' </summary>
Private Sub calendar_DragDrop(ByVal sender As Object, ByVal e As DragEventArgs) Handles calendar.DragDrop

If Not dragged Is Nothing Then

calendar.CompleteModify(calendar.PointToClient(New Point(e.X, e.Y)))
dragged = Nothing

calendar.UpdateLayout()

End If

End Sub

' ...

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
StartModify Method
CompleteModify Method
CancelModify Method


MindFusion.Scheduling.WinForms.Calendar Properties

Calendar Properties

Public Properties

Name | Description
AllowAutoScroll | Gets or sets a value indicating whether the control scrolls automatically its contents when users drag items near the edge of the client rectangle.
AllowDrag | Gets or sets a value indicating whether the user can initiate a drag operation within the control.
AllowInplaceCreate | Gets or sets a value indicating whether users are allowed to create items interactively.
AllowInplaceEdit | Gets or sets a value indicating whether users are allowed to edit items interactively.
ButtonOffset | Gets or set the offset of the buttons, displayed in the MonthRange and SingleMonth views' headers.
ButtonSize | Gets or sets the size of the navigation buttons, displayed in the views' headers.
ColorKey | Gets or sets the color key to use when drawing images.
ColumnResizeCursorH | Gets or set the cursor that is displayed when a column can be resized or is being resized in a horizontal Timetable view.
ColumnResizeCursorV | Gets or set the cursor that is displayed when a column can be resized or is being resized in a vertical Timetable view.
ContactNameFormat | Gets or sets how to format and display contact names in the timetable header.
Contacts | Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.
ContactsDataMember | Gets or sets the name of the data member from the associated data source to bind the contacts to.
ContactsDataPropertyMap | Gets or sets a BoundPropertyList object that maps contact properties to fields in the associated data member.
ControlAppearance | Gets or sets the visual style of the calendar child controls.
ControlStyle | Gets a ControlStyle object that allows customizing the visualization of the calendar child controls.
Culture | Gets or sets the CultureInfo object used to format and display time information in the calendar.
CurrentTime | Gets or sets the current time. When this property is set to DateTime.MinValue, the actual system time is returned.
CurrentView | Gets or sets the type of the calendar view.
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the calendar.
CustomBrushesDataMember | Gets or sets the name of the data member from the associated data source to bind the custom brushes to.
CustomBrushesDataPropertyMap | Gets or sets a BoundPropertyList object that maps custom brush properties to fields in the associated data member.
CustomDraw | Gets or sets which UI elements of the calendar should be custom drawn.
CustomTheme | Gets or sets the custom theme applied to the control.
DataSource | Gets or sets the data source associated with the control.
Date | Gets or sets the date currently displayed in the calendar.
DateTimeFormat | Gets or sets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.
DayOfWeekStyles | Gets a collection of DayOfWeekStyle objects that allow customizing the appearance of specific days of the week in the calendar.
DayStyles | Gets a collection of DateStyle objects that allow customizing the appearance of specific days in the calendar.
DelayInplaceEdit | Gets or sets a value indicating whether the in-place editing of an item is delayed for a second when the item is clicked.
DragItemsOnDisabledAreas | Gets or sets a value indicating whether to update the position of items dragged over areas which do not allow items.
EnableDragCreate | Gets or sets a value indicating whether items are created merely by dragging in the control.
EnableKeyboard | Gets or sets a value indicating whether the selection can be manipulated through the keyboard.
EnableOptimization | Gets or sets a value indicating whether the control should try to optimize item rendering.
EndDate | Gets or sets the last date displayed in the calendar.
EnsureVisibleSelection | Gets or sets a value indicating whether the selected cells should be automatically brought into view.
FirstWeekendDay | Gets or sets the first weekend day in the calendar.
GroupType | Gets or sets the grouping criteria for the Timetable, WeekRange, List and Resource views.
HiddenItemsCursor | Gets or sets the cursor that is displayed when the mouse pointer is over the hidden items cue icon.
HScrollerSmallChange | Gets or sets the small step for the horizontal scroll bar.
HScrollerVisible | Gets or sets a value indicating whether the horizontal scroller should always be visible, always hidden or visible only when it is needed.
HScrollPos | Gets or sets the current horizontal scroll position.
ImageList | Gets or sets the image list associated with the calendar.
InteractiveItemType | Gets or sets the type of an Item derived class whose instance should be created when a user starts typing while the calendar control has the keyboard focus.
ItemChangeReferenceKey | Gets or sets the modifier key, which lets users drag items between different contacts, resources, locations or tasks in a grouped view.
ItemCloneKey | Gets or sets the modifier key, which when pressed allows users to interactively clone items.
ItemDragCursor | Gets or sets the cursor that is displayed when an item is being dragged.
ItemDragKey | Gets or sets the modifier key that lets users start an OLE drag-and-drop operation when they drag an item.
ItemHResizeCursor | Gets or sets the cursor that is displayed when the mouse pointer is over the horizontal resize area of an item.
ItemModificationStyle | Gets or sets a value indicating the way items are processed when modified interactively.
ItemMoveCursor | Gets or sets the cursor that is displayed when the mouse pointer is over the move area of an item.
ItemNoDragCursor | Gets or sets the cursor that is displayed when an item is dragged over a location that cannot contain items.
ItemScroll | Gets or sets the current scroll position in a List view whose EnableVirtualItemSpace property is set to Enabled.
ItemsDataMember | Gets or sets the name of the data member from the associated data source to bind the schedule items to.
ItemsDataPropertyMap | Gets or sets a BoundPropertyList object that maps item properties to fields in the associated data member.
ItemSelection | Gets a list of all selected items.
ItemSettings | Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.
ItemTooltipFormat | Gets or sets the format of item tooltips.
ItemVResizeCursor | Gets or sets the cursor that is displayed when the mouse pointer is over the vertical resize area of an item.
KeepItemSelection | Gets or sets a value indicating whether the item selection is preserved when an item from the selection is clicked.
ListViewSettings | Gets the ListViewSettings object used to customize the visualization of the List view.
Locations | Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.
LocationsDataMember | Gets or sets the name of the data member from the associated data source to bind the locations to.
LocationsDataPropertyMap | Gets or sets a BoundPropertyList object that maps location properties to fields in the associated data member.
MinItemLength | Gets or sets the minimal length of interactively created items, expressed in minutes.
MonthRangeSettings | Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.
MonthSettings | Gets the MonthSettings object used to customize the visualization of months in the MonthRange and SingleMonth views.
MonthStyles | Gets a collection of DateStyle objects that allow customizing the appearance of specific months in the calendar.
PrintOptions | Gets a PrintOptions object that allows customizing various aspects of printing.
RecurrenceExceptionsDataMember | Gets or sets the name of the data member from the associated data source to bind the recurrence exceptions to.
RecurrenceExceptionsDataPropertyMap | Gets or sets a BoundPropertyList object that maps recurrence exception properties to fields in the associated data member.
RecurrencesDataMember | Gets or sets the name of the data member from the associated data source to bind the recurrences to.
RecurrencesDataPropertyMap | Gets or sets a BoundPropertyList object that maps recurrence properties to fields in the associated data member.
RemindersDataMember | Gets or sets the name of the data member from the associated data source to bind the reminders to.
RemindersDataPropertyMap | Gets or sets a BoundPropertyList object that maps reminder properties to fields in the associated data member.
Resources | Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.
ResourcesDataMember | Gets or sets the name of the data member from the associated data source to bind the resources to.
ResourcesDataPropertyMap | Gets or sets a BoundPropertyList object that maps resource properties to fields in the associated data member.
ResourceViewSettings | Gets the ResourceViewSettings object used to customize the visualization of a Resource view.
Schedule | Gets or sets the schedule whose information should be displayed inside the calendar control.
ScrollPosition | Gets or sets the current scroll position.
Selection | Gets a Selection object representing the current selection in the calendar.
ShowToolTips | Gets or sets a value indicating whether the calendar displays tooltips.
StartEditAfterModify | Gets or sets a value indicating whether in-place editing of items should automatically start after they are modified interactively.
StylesDataMember | Gets or sets the name of the data member from the associated data source to bind the styles to.
StylesDataPropertyMap | Gets or sets a BoundPropertyList object that maps style properties to fields in the associated data member.
Tasks | Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.
TasksDataMember | Gets or sets the name of the data member from the associated data source to bind the schedule tasks to.
TasksDataPropertyMap | Gets or sets a BoundPropertyList object that maps task properties to fields in the associated data member.
TextRendering | Gets or sets the text rendering mode.
Theme | Gets or sets the theme applied to the calendar control UI elements.
TimetableSettings | Gets the TimetableSettings object used to customize the visualization of days and hours in Timetable view.
ToolTip | Gets the underlying ToolTip component.
VScrollerSmallChange | Gets or sets the small step for the vertical scroll bar.
VScrollerVisible | Gets or sets a value indicating whether the vertical scroller should always be visible, always hidden or visible only when it is needed.
VScrollPos | Gets or sets the current vertical scroll position.
WeekRangeSettings | Gets the WeekRangeSettings object used to customize the visualization of weeks in a WeekRange view.

ProtectedProperties

Name | Description
DefaultSize | Gets the default size of the control.

See Also

Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.AllowAutoScroll Property

Calendar.AllowAutoScroll Property

Gets or sets a value indicating whether the control scrolls automatically its contents when users drag items near the edge of the client rectangle.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool AllowAutoScroll { get; set; }
Visual Basic

Public Property AllowAutoScroll As Boolean

Property Value

true to enable automatic scrolling; otherwise, false. The default is true.

Remarks

Automatic scrolling starts when a schedule item or a selection of items is dragged near the borders of the calendar contents rectangle. The contents rectangle is the part of a calendar view that contains all time cells and excludes the headers. If the mouse is moved outside the contents rectangle, the scrolling stops.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.AllowDrag Property

Calendar.AllowDrag Property

Gets or sets a value indicating whether the user can initiate a drag operation within the control.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool AllowDrag { get; set; }
Visual Basic

Public Property AllowDrag As Boolean

Property Value

true, to enable dragging within the control; otherwise, false. The default is true.

Remarks

Dragging can be initiated within the control when the user holds down the ItemDragKey, clicks on an item and starts dragging. By settings this property to false, you can effectively disable this.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.AllowInplaceCreate Property

Calendar.AllowInplaceCreate Property

Gets or sets a value indicating whether users are allowed to create items interactively.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool AllowInplaceCreate { get; set; }
Visual Basic

Public Property AllowInplaceCreate As Boolean

Property Value

true to allow users to create schedule items; otherwise, false. The default is true.

Remarks

If this property is disabled, users cannot create items interactively. If it is enabled and InteractiveItemType is not null (Nothing in Visual Basic), a new schedule item of the specified type is created when users start typing in a time cell. This raises the ItemCreating event, which lets your application validate the operation or cancel it.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
InteractiveItemType Property
AllowInplaceEdit Property


MindFusion.Scheduling.WinForms.Calendar.AllowInplaceEdit Property

Calendar.AllowInplaceEdit Property

Gets or sets a value indicating whether users are allowed to edit items interactively.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool AllowInplaceEdit { get; set; }
Visual Basic

Public Property AllowInplaceEdit As Boolean

Property Value

true to allow users to edit schedule items; otherwise, false. The default is true.

Remarks

If this property is disabled, users cannot edit item's text interactively. Controlling the editing of item text can be done by handling the ItemInplaceEditStarting and ItemInplaceEditEnding events.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
InteractiveItemType Property
AllowInplaceCreate Property


MindFusion.Scheduling.WinForms.Calendar.ButtonOffset Property

Calendar.ButtonOffset Property

Gets or set the offset of the buttons, displayed in the MonthRange and SingleMonth views' headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ButtonOffset { get; set; }
Visual Basic

Public Property ButtonOffset As Integer

Property Value

An integer value specifying how many pixels there are between a button and header edges. The default is 4.

Remarks

The buttons get smaller if the value of this property is increased.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ButtonSize Property


MindFusion.Scheduling.WinForms.Calendar.ButtonSize Property

Calendar.ButtonSize Property

Gets or sets the size of the navigation buttons, displayed in the views' headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ButtonSize { get; set; }
Visual Basic

Public Property ButtonSize As Integer

Property Value

An integer value specifying the size of the navigation buttons displayed in the List, SingleMonth, MonthRange and Timetable views. The default is 0.

Remarks

The value of this property specifies the absolute size of the navigation buttons. If the value is 0, the size of the buttons is calculated automatically according to the size of the headers that contain them and the value of the ButtonOffset property.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ButtonOffset Property


MindFusion.Scheduling.WinForms.Calendar.ColorKey Property

Calendar.ColorKey Property

Gets or sets the color key to use when drawing images.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

public Color ColorKey { get; set; }
Visual Basic

Public Property ColorKey As Color

Property Value

Remarks

Use Color.Empty to specify no color key.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ColumnResizeCursorH Property

Calendar.ColumnResizeCursorH Property

Gets or set the cursor that is displayed when a column can be resized or is being resized in a horizontal Timetable view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Cursor ColumnResizeCursorH { get; set; }
Visual Basic

Public Property ColumnResizeCursorH As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.VSplit.

Remarks

To let users resize the columns in a timetable view, set TimetableSettings.AllowResizeColumns to true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ColumnResizeCursorV Property


MindFusion.Scheduling.WinForms.Calendar.ColumnResizeCursorV Property

Calendar.ColumnResizeCursorV Property

Gets or set the cursor that is displayed when a column can be resized or is being resized in a vertical Timetable view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Cursor ColumnResizeCursorV { get; set; }
Visual Basic

Public Property ColumnResizeCursorV As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.VSplit.

Remarks

To let users resize the columns in a timetable view, set TimetableSettings.AllowResizeColumns to true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ColumnResizeCursorH Property


MindFusion.Scheduling.WinForms.Calendar.ContactNameFormat Property

Calendar.ContactNameFormat Property

Gets or sets how to format and display contact names in the timetable header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string ContactNameFormat { get; set; }
Visual Basic

Public Property ContactNameFormat As String

Property Value

A string specifying the name format. The default is "F M L".

Remarks

Use the capital letters F, M and L as placeholders for the First, Middle and Last names. Any other character will be displayed unchanged.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.Contacts Property

Calendar.Contacts Property

Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ContactCollection Contacts { get; }
Visual Basic

Public ReadOnly Property Contacts As ContactCollection

Property Value

An instance of the ContactCollection class specifying which contacts are displayed as columns in timetable, week range and resource views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ContactsDataMember Property

Calendar.ContactsDataMember Property

Gets or sets the name of the data member from the associated data source to bind the contacts to.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string ContactsDataMember { get; set; }
Visual Basic

Public Property ContactsDataMember As String

Property Value

A string value specifying the contacts data member.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ContactsDataPropertyMap Property


MindFusion.Scheduling.WinForms.Calendar.ContactsDataPropertyMap Property

Calendar.ContactsDataPropertyMap Property

Gets or sets a BoundPropertyList object that maps contact properties to fields in the associated data member.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public BoundPropertyList ContactsDataPropertyMap { get; set; }
Visual Basic

Public Property ContactsDataPropertyMap As BoundPropertyList

Property Value

An instance of the BoundPropertyList class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ContactsDataMember Property


MindFusion.Scheduling.WinForms.Calendar.ControlAppearance Property

Calendar.ControlAppearance Property

Gets or sets the visual style of the calendar child controls.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ControlAppearance ControlAppearance { get; set; }
Visual Basic

Public Property ControlAppearance As ControlAppearance

Property Value

A member of the ControlAppearance enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

ControlStyle can be used only if this property is set to Custom.

Example

The following example sets custom colors for the calendar buttons. The example assumes that calendar references an existing Calendar control.

C#

calendar.CurrentView = CalendarView.SingleMonth;
calendar.MonthSettings.HeaderStyle =
MonthHeaderStyles.Title | MonthHeaderStyles.MonthButtons;

calendar.ControlAppearance = ControlAppearance.Custom;
calendar.ControlStyle.ButtonFillBrush =
new MindFusion.Drawing.LinearGradientBrush(
Color.White, Color.Violet, 90);
calendar.ControlStyle.ButtonFillBrushOver =
new MindFusion.Drawing.LinearGradientBrush(
Color.White, Color.LightPink, 90);
calendar.ControlStyle.ButtonFillBrushDown =
new MindFusion.Drawing.LinearGradientBrush(
Color.MediumOrchid, Color.Violet, 90);

calendar.UpdateLayout();
Visual Basic

calendar.CurrentView = CalendarView.SingleMonth
calendar.MonthSettings.HeaderStyle =
MonthHeaderStyles.Title Or MonthHeaderStyles.MonthButtons

calendar.ControlAppearance = ControlAppearance.Custom
calendar.ControlStyle.ButtonFillBrush = _
New MindFusion.Drawing.LinearGradientBrush( _
Color.White, Color.Violet, 90)
calendar.ControlStyle.ButtonFillBrushOver = _
New MindFusion.Drawing.LinearGradientBrush( _
Color.White, Color.LightPink, 90)
calendar.ControlStyle.ButtonFillBrushDown = _
New MindFusion.Drawing.LinearGradientBrush( _
Color.MediumOrchid, Color.Violet, 90)

calendar.UpdateLayout()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ControlStyle Property


MindFusion.Scheduling.WinForms.Calendar.ControlStyle Property

Calendar.ControlStyle Property

Gets a ControlStyle object that allows customizing the visualization of the calendar child controls.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ControlStyle ControlStyle { get; }
Visual Basic

Public ReadOnly Property ControlStyle As ControlStyle

Property Value

An instance of the ControlStyle class.

Remarks

Members of the ControlStyle class let you customize the appearance of the button and scrollbar child controls contained in the calendar control. This property is ignored if ControlAppearance is set to System.

Example

The following example sets custom colors for the calendar buttons. The example assumes that calendar references an existing Calendar control.

C#

calendar.CurrentView = CalendarView.SingleMonth;
calendar.MonthSettings.HeaderStyle =
MonthHeaderStyles.Title | MonthHeaderStyles.MonthButtons;

calendar.ControlAppearance = ControlAppearance.Custom;
calendar.ControlStyle.ButtonFillBrush =
new MindFusion.Drawing.LinearGradientBrush(
Color.White, Color.Violet, 90);
calendar.ControlStyle.ButtonFillBrushOver =
new MindFusion.Drawing.LinearGradientBrush(
Color.White, Color.LightPink, 90);
calendar.ControlStyle.ButtonFillBrushDown =
new MindFusion.Drawing.LinearGradientBrush(
Color.MediumOrchid, Color.Violet, 90);

calendar.UpdateLayout();
Visual Basic

calendar.CurrentView = CalendarView.SingleMonth
calendar.MonthSettings.HeaderStyle =
MonthHeaderStyles.Title Or MonthHeaderStyles.MonthButtons

calendar.ControlAppearance = ControlAppearance.Custom
calendar.ControlStyle.ButtonFillBrush = _
New MindFusion.Drawing.LinearGradientBrush( _
Color.White, Color.Violet, 90)
calendar.ControlStyle.ButtonFillBrushOver = _
New MindFusion.Drawing.LinearGradientBrush( _
Color.White, Color.LightPink, 90)
calendar.ControlStyle.ButtonFillBrushDown = _
New MindFusion.Drawing.LinearGradientBrush( _
Color.MediumOrchid, Color.Violet, 90)

calendar.UpdateLayout()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ControlAppearance Property


MindFusion.Scheduling.WinForms.Calendar.Culture Property

Calendar.Culture Property

Gets or sets the CultureInfo object used to format and display time information in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public CultureInfo Culture { get; set; }
Visual Basic

Public Property Culture As CultureInfo

Property Value

An instance of the .NET CultureInfo class.

Remarks

Setting the culture info results in reinitialization of all culture-specific properties, such as day and month names, first day of the week, and so on.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
DateTimeFormat Property


MindFusion.Scheduling.WinForms.Calendar.CurrentTime Property

Calendar.CurrentTime Property

Gets or sets the current time. When this property is set to DateTime.MinValue, the actual system time is returned.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime CurrentTime { get; set; }
Visual Basic

Public Property CurrentTime As DateTime

Property Value

A .NET DateTime object representing the time to use as current.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.CurrentView Property

Calendar.CurrentView Property

Gets or sets the type of the calendar view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public CalendarView CurrentView { get; set; }
Visual Basic

Public Property CurrentView As CalendarView

Property Value

A member of the CalendarView enumeration. The default is SingleMonth.

Remarks

The control can display the schedule data in several different types of views. This property allows changing the current view and can be used to implement drill down into the schedule data by switching from more general to more specialized views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.Cursor Property

Calendar.Cursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public new Cursor Cursor { get; set; }
Visual Basic

Public Shadows Property Cursor As Cursor

Property Value

An instance of the .NET Cursor class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.CustomBrushesDataMember Property

Calendar.CustomBrushesDataMember Property

Gets or sets the name of the data member from the associated data source to bind the custom brushes to.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string CustomBrushesDataMember { get; set; }
Visual Basic

Public Property CustomBrushesDataMember As String

Property Value

A string value specifying the custom brushes data member.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
CustomBrushesDataPropertyMap Property


MindFusion.Scheduling.WinForms.Calendar.CustomBrushesDataPropertyMap Property

Calendar.CustomBrushesDataPropertyMap Property

Gets or sets a BoundPropertyList object that maps custom brush properties to fields in the associated data member.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public BoundPropertyList CustomBrushesDataPropertyMap { get; set; }
Visual Basic

Public Property CustomBrushesDataPropertyMap As BoundPropertyList

Property Value

An instance of the BoundPropertyList class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
CustomBrushesDataMember Property


MindFusion.Scheduling.WinForms.Calendar.CustomDraw Property

Calendar.CustomDraw Property

Gets or sets which UI elements of the calendar should be custom drawn.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public CustomDrawElements CustomDraw { get; set; }
Visual Basic

Public Property CustomDraw As CustomDrawElements

Property Value

A combination of CustomDrawElements enumeration members. The default is None.

Remarks

Use the bitwise or operation to combine members of CustomDrawElements specifying which elements of the view must be custom drawn. Handle the Draw event to perform custom drawing.

Example

The following example demonstrates how to use the CustomDraw property in conjunction with the Draw event. The example assumes that calendar references a valid Calendar instance.

The example draws a red ellipse around specific dates in a SingleMonth view.

C#

calendar.CurrentView = CalendarView.SingleMonth;
calendar.CustomDraw = CustomDrawElements.CellHeader;
calendar.Draw += new CustomDraw(calendar_Draw);

// ...

private bool IsHoliday(DateTime date)
{
if (date.Day == 31 && date.Month == 12)
return true;
if (date.Day == 24 && date.Month == 5)
return true;

return false;
}

// ...

private void calendar_Draw(object sender, CustomDrawArgs e)
{
if (e.Element == CustomDrawElements.CellHeader)
{
if (IsHoliday(e.Date))
e.Graphics.DrawEllipse(Pens.Red, e.Bounds);
}
}
Visual Basic

calendar.CurrentView = CalendarView.SingleMonth
calendar.CustomDraw = CustomDrawElements.CellHeader
AddHandler calendar.Draw, AddressOf calendar_Draw

' ...

Private Function IsHoliday(ByVal ddate As DateTime) As Boolean

If ddate.Day = 31 And ddate.Month = 12 Then
Return True
End If

If ddate.Day = 24 And ddate.Month = 5 Then
Return True
End If

Return False

End Function

' ...

Private Sub calendar_Draw(ByVal sender As Object, ByVal e As CustomDrawArgs)

If e.Element = CustomDrawElements.CellHeader Then

If IsHoliday(e.Date) Then
e.Graphics.DrawEllipse(Pens.Red, e.Bounds)
End If

End If

End Sub

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
Draw Event


MindFusion.Scheduling.WinForms.Calendar.CustomTheme Property

Calendar.CustomTheme Property

Gets or sets the custom theme applied to the control.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Theme CustomTheme { get; set; }
Visual Basic

Public Property CustomTheme As Theme

Property Value

A Theme object specifying the user-defined theme currently applied to the control. The default is null (Nothing in Visual Basic).

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
Theme Property


MindFusion.Scheduling.WinForms.Calendar.DataSource Property

Calendar.DataSource Property

Gets or sets the data source associated with the control.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Object DataSource { get; set; }
Visual Basic

Public Property DataSource As Object

Property Value

An Object representing the data source.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.Date Property

Calendar.Date Property

Gets or sets the date currently displayed in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime Date { get; set; }
Visual Basic

Public Property Date As DateTime

Property Value

A .NET DateTime object. The initial value is DateTime.Today.

Remarks

This value is not used in a timetable view. To specify the dates displayed in timetable view, use TimetableSettings.Dates.

The single month view displays the month containing the specified date. The first month in a month range view is the one containing the specified date. The first day in a day range view is the specified date.

The week range and resource views display all dates in the range defined from this property and the EndDate property.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
EndDate Property
TimetableSettings.Dates Property


MindFusion.Scheduling.WinForms.Calendar.DateTimeFormat Property

Calendar.DateTimeFormat Property

Gets or sets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTimeFormatInfo DateTimeFormat { get; set; }
Visual Basic

Public Property DateTimeFormat As DateTimeFormatInfo

Property Value

An instance of the .NET DateTimeFormatInfo class.

Remarks

If this property is not set, the calendar uses the DateFormatInfo from the associated Culture.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
Culture Property


MindFusion.Scheduling.WinForms.Calendar.DayOfWeekStyles Property

Calendar.DayOfWeekStyles Property

Gets a collection of DayOfWeekStyle objects that allow customizing the appearance of specific days of the week in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DayOfWeekStyleCollection DayOfWeekStyles { get; }
Visual Basic

Public ReadOnly Property DayOfWeekStyles As DayOfWeekStyleCollection

Property Value

An instance of the DayOfWeekStyleCollection class.

Remarks

Add DayOfWeekStyle objects to this collection to specify a distinct style for a day of the week. If several styles are defined for the same day, the one having the highest Priority is used.

Example

The following example demonstrates how to make all weekend days to be colored differently. The example assumes that calendar references an existing Calendar object.

C#

calendar.CurrentView = CalendarView.SingleMonth;

DayOfWeekStyle s;

s = new DayOfWeekStyle();
s.DayOfWeek = DayOfWeek.Saturday;
s.Style = new Style();
s.Style.HeaderBrush = new MindFusion.Drawing.SolidBrush(Color.PaleGreen);
calendar.DayOfWeekStyles.Add(s);

s = new DayOfWeekStyle();
s.DayOfWeek = DayOfWeek.Sunday;
s.Style = new Style();
s.Style.HeaderBrush = new MindFusion.Drawing.SolidBrush(Color.PaleGreen);
calendar.DayOfWeekStyles.Add(s);
Visual Basic

calendar.CurrentView = CalendarView.SingleMonth

Dim s As DayOfWeekStyle s

s = New DayOfWeekStyle()
s.DayOfWeek = DayOfWeek.Saturday
s.Style = New Style()
s.Style.HeaderBrush = New MindFusion.Drawing.SolidBrush(Color.PaleGreen)
calendar.DayOfWeekStyles.Add(s)

s = New DayOfWeekStyle()
s.DayOfWeek = DayOfWeek.Sunday
s.Style = New Style()
s.Style.HeaderBrush = New MindFusion.Drawing.SolidBrush(Color.PaleGreen)
calendar.DayOfWeekStyles.Add(s)

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
DayStyles Property
MonthStyles Property


MindFusion.Scheduling.WinForms.Calendar.DayStyles Property

Calendar.DayStyles Property

Gets a collection of DateStyle objects that allow customizing the appearance of specific days in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateStyleCollection DayStyles { get; }
Visual Basic

Public ReadOnly Property DayStyles As DateStyleCollection

Property Value

An instance of the DateStyleCollection class.

Remarks

Use this collection to assign a distinct style to a day or a range of days, overriding the default style of the current view. If there are several styles defined for the same day, the one with highest Priority is used.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
DayOfWeekStyles Property
MonthStyles Property


MindFusion.Scheduling.WinForms.Calendar.DefaultSize Property

Calendar.DefaultSize Property

Gets the default size of the control.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual Size DefaultSize { get; }
Visual Basic

Protected Overridable ReadOnly Property DefaultSize As Size

Property Value

A .NET Size object. The returned size is 176x168 pixels.

Remarks

This property overrides Control.DefaultSize.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.DelayInplaceEdit Property

Calendar.DelayInplaceEdit Property

Gets or sets a value indicating whether the in-place editing of an item is delayed for a second when the item is clicked.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool DelayInplaceEdit { get; set; }
Visual Basic

Public Property DelayInplaceEdit As Boolean

Property Value

true to delay in-place editing; otherwise, false. The default is true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.DragItemsOnDisabledAreas Property

Calendar.DragItemsOnDisabledAreas Property

Gets or sets a value indicating whether to update the position of items dragged over areas which do not allow items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool DragItemsOnDisabledAreas { get; set; }
Visual Basic

Public Property DragItemsOnDisabledAreas As Boolean

Property Value

true to indicate that the modified items will follow the cursor over areas which do not allow items; otherwise, false.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.EnableDragCreate Property

Calendar.EnableDragCreate Property

Gets or sets a value indicating whether items are created merely by dragging in the control.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool EnableDragCreate { get; set; }
Visual Basic

Public Property EnableDragCreate As Boolean

Property Value

true to enable interactive item creation when the users clicks and drags in the control; false to disable it. The default is false.

Remarks

By default, the items in MindFusion.Scheduling are created interactively by selecting a time range in the current view and typing. Setting this property to true overrides this behavior and enables users to create items by clicking and dragging.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.EnableKeyboard Property

Calendar.EnableKeyboard Property

Gets or sets a value indicating whether the selection can be manipulated through the keyboard.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool EnableKeyboard { get; set; }
Visual Basic

Public Property EnableKeyboard As Boolean

Property Value

A Boolean value specifying whether the selection can be modified through the keyboard. The default is true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.EnableOptimization Property

Calendar.EnableOptimization Property

Gets or sets a value indicating whether the control should try to optimize item rendering.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool EnableOptimization { get; set; }
Visual Basic

Public Property EnableOptimization As Boolean

Property Value

A Boolean value specifying whether item rendering optimization is enabled. The default is false.

Remarks

Turning this flag on will increase repainting speed at the cost of memory.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.EndDate Property

Calendar.EndDate Property

Gets or sets the last date displayed in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime EndDate { get; set; }
Visual Basic

Public Property EndDate As DateTime

Property Value

A .NET DateTime object. The initial value is set 30 days after Date.

Remarks

This member is only valid in WeekRange and Resource views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
Date Property


MindFusion.Scheduling.WinForms.Calendar.EnsureVisibleSelection Property

Calendar.EnsureVisibleSelection Property

Gets or sets a value indicating whether the selected cells should be automatically brought into view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool EnsureVisibleSelection { get; set; }
Visual Basic

Public Property EnsureVisibleSelection As Boolean

Property Value

A Boolean value specifying whether the control should automatically scroll when the user selects cells outside of the current viewport (by using the keyboard for example).

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.FirstWeekendDay Property

Calendar.FirstWeekendDay Property

Gets or sets the first weekend day in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DayOfWeek FirstWeekendDay { get; set; }
Visual Basic

Public Property FirstWeekendDay As DayOfWeek

Property Value

A member of the .NET DayOfWeek enumeration.

Remarks

Specifies which day to regard as start of the weekend.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.GroupType Property

Calendar.GroupType Property

Gets or sets the grouping criteria for the Timetable, WeekRange, List and Resource views.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public GroupType GroupType { get; set; }
Visual Basic

Public Property GroupType As GroupType

Property Value

A member of the GroupType enumeration. The default is None.

Remarks

See the Timetable View topic for more information regarding grouping.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.HiddenItemsCursor Property

Calendar.HiddenItemsCursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the hidden items cue icon.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Cursor HiddenItemsCursor { get; set; }
Visual Basic

Public Property HiddenItemsCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.Hand.

Remarks

The hidden items cue icon is shown if ItemSettings.ShowMoreItemsCue is enabled and there are schedule items that are not currently visible because of insufficient space.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.HScrollerSmallChange Property

Calendar.HScrollerSmallChange Property

Gets or sets the small step for the horizontal scroll bar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HScrollerSmallChange { get; set; }
Visual Basic

Public Property HScrollerSmallChange As Integer

Property Value

An integer value representing the small step of the horizontal scroll bar.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
VScrollerSmallChange Property


MindFusion.Scheduling.WinForms.Calendar.HScrollerVisible Property

Calendar.HScrollerVisible Property

Gets or sets a value indicating whether the horizontal scroller should always be visible, always hidden or visible only when it is needed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State HScrollerVisible { get; set; }
Visual Basic

Public Property HScrollerVisible As State

Property Value

A member of the State enumeration specifying the visibility state of the horizontal scroller.

Remarks

Specify Disabled for this property to always hide the scroller, Enabled to always show it and Unspecified to let the Calendar control decide when to show the scroller.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
VScrollerVisible Property


MindFusion.Scheduling.WinForms.Calendar.HScrollPos Property

Calendar.HScrollPos Property

Gets or sets the current horizontal scroll position.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HScrollPos { get; set; }
Visual Basic

Public Property HScrollPos As Integer

Property Value

An integer value specifying the current horizontal scroll position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
VScrollPos Property
ScrollPosition Property


MindFusion.Scheduling.WinForms.Calendar.ImageList Property

Calendar.ImageList Property

Gets or sets the image list associated with the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ImageList ImageList { get; set; }
Visual Basic

Public Property ImageList As ImageList

Property Value

An instance of the .NET ImageList class. The default is null (Nothing in Visual Basic).

Remarks

The value of each Style.ImageIndex is an index within this list.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.InteractiveItemType Property

Calendar.InteractiveItemType Property

Gets or sets the type of an Item derived class whose instance should be created when a user starts typing while the calendar control has the keyboard focus.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Type InteractiveItemType { get; set; }
Visual Basic

Public Property InteractiveItemType As Type

Property Value

An instance of the .NET Type class specifying what type of items to create when a user starts typing. The default is Appointment.

Remarks

If this property is set to null (Nothing in Visual Basic), users cannot create items interactively.

Note

If you implement custom Item derived class, make sure it provides parameterless constructor. Otherwise, no items will be created.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
AllowInplaceEdit Property


MindFusion.Scheduling.WinForms.Calendar.ItemChangeReferenceKey Property

Calendar.ItemChangeReferenceKey Property

Gets or sets the modifier key, which lets users drag items between different contacts, resources, locations or tasks in a grouped view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Keys ItemChangeReferenceKey { get; set; }
Visual Basic

Public Property ItemChangeReferenceKey As Keys

Property Value

Must be set to Control, Alt or Shift.

Remarks

By default an item dragged in a grouped view can be dropped only into a column associated with the original contact, location or task of the item. This behavior can be overridden by pressing a modifier key while dragging. That allows dropping the item into a column of a different contact, location or task, thus changing the original contact, location or task.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemCloneKey Property

Calendar.ItemCloneKey Property

Gets or sets the modifier key, which when pressed allows users to interactively clone items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Keys ItemCloneKey { get; set; }
Visual Basic

Public Property ItemCloneKey As Keys

Property Value

Must be set to Control, Alt, Shift or None.

Remarks

If the user starts dragging an item (or items) when the key specified as a value of this property is pressed, an exact duplicate of the dragged item is created and the user continues dragging the newly created item instead of the original one.

Note

When cloning a recurring item, the newly created item is not recurring. In addition, the Id of the new item is unique.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemDragCursor Property

Calendar.ItemDragCursor Property

Gets or sets the cursor that is displayed when an item is being dragged.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Cursor ItemDragCursor { get; set; }
Visual Basic

Public Property ItemDragCursor As Cursor

Property Value

An instance of the .NET Cursor class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemDragKey Property

Calendar.ItemDragKey Property

Gets or sets the modifier key that lets users start an OLE drag-and-drop operation when they drag an item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Keys ItemDragKey { get; set; }
Visual Basic

Public Property ItemDragKey As Keys

Property Value

Must be set to Control, Alt or Shift.

Remarks

By default, a dragged schedule item can be dropped only inside the Calendar control. Users can drag an item to another control on the form or to an external application by pressing the modifier key set in this property.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemHResizeCursor Property

Calendar.ItemHResizeCursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the horizontal resize area of an item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Cursor ItemHResizeCursor { get; set; }
Visual Basic

Public Property ItemHResizeCursor As Cursor

Property Value

An instance of the .NET Cursor class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemVResizeCursor Property


MindFusion.Scheduling.WinForms.Calendar.ItemModificationStyle Property

Calendar.ItemModificationStyle Property

Gets or sets a value indicating the way items are processed when modified interactively.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemModificationStyle ItemModificationStyle { get; set; }
Visual Basic

Public Property ItemModificationStyle As ItemModificationStyle

Property Value

A member of the ItemModificationStyle enumeration. The default is InPlace.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemMoveCursor Property

Calendar.ItemMoveCursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the move area of an item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Cursor ItemMoveCursor { get; set; }
Visual Basic

Public Property ItemMoveCursor As Cursor

Property Value

An instance of the .NET Cursor class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemNoDragCursor Property

Calendar.ItemNoDragCursor Property

Gets or sets the cursor that is displayed when an item is dragged over a location that cannot contain items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Cursor ItemNoDragCursor { get; set; }
Visual Basic

Public Property ItemNoDragCursor As Cursor

Property Value

An instance of the .NET Cursor class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemScroll Property

Calendar.ItemScroll Property

Gets or sets the current scroll position in a List view whose EnableVirtualItemSpace property is set to Enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ItemScroll { get; set; }
Visual Basic

Public Property ItemScroll As Integer

Property Value

An integer value specifying the current scroll bar position.

Remarks

The value of this property equals the HScrollPos value in a vertical list view or the VScrollPos value in a horizontal list view.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemsDataMember Property

Calendar.ItemsDataMember Property

Gets or sets the name of the data member from the associated data source to bind the schedule items to.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string ItemsDataMember { get; set; }
Visual Basic

Public Property ItemsDataMember As String

Property Value

A string value specifying the items data member.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemsDataPropertyMap Property


MindFusion.Scheduling.WinForms.Calendar.ItemsDataPropertyMap Property

Calendar.ItemsDataPropertyMap Property

Gets or sets a BoundPropertyList object that maps item properties to fields in the associated data member.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public BoundPropertyList ItemsDataPropertyMap { get; set; }
Visual Basic

Public Property ItemsDataPropertyMap As BoundPropertyList

Property Value

An instance of the BoundPropertyList class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemsDataMember Property


MindFusion.Scheduling.WinForms.Calendar.ItemSelection Property

Calendar.ItemSelection Property

Gets a list of all selected items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemSelection ItemSelection { get; }
Visual Basic

Public ReadOnly Property ItemSelection As ItemSelection

Property Value

An instance of the ItemSelection class representing the currently selected items.

Remarks

Use Selection to get the collection of all selected time cells.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
Selection Property


MindFusion.Scheduling.WinForms.Calendar.ItemSettings Property

Calendar.ItemSettings Property

Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemSettings ItemSettings { get; }
Visual Basic

Public ReadOnly Property ItemSettings As ItemSettings

Property Value

An instance of the ItemSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemTooltipFormat Property

Calendar.ItemTooltipFormat Property

Gets or sets the format of item tooltips.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string ItemTooltipFormat { get; set; }
Visual Basic

Public Property ItemTooltipFormat As String

Property Value

A string specifying the item's tooltip format. The default is "%s[d] %s[t] - %e[d] %e[t]\n%h\n%d".

Remarks

The format string contains format specifiers that let you define what properties of an item are displayed in its tool tip. The following specifiers are supported at this time:

Specifier | Description
%s[{format}] | The item's StartTime, formatted according to the standard date formatting string, specified by {format}. The brackets '{' and '}' should not be included.
%e[{format}] | The item's EndTime, formatted according to the standard date formatting string, specified by {format}. The brackets '{' and '}' should not be included.
%h | The item's header, as set in HeaderText.
%d | The item's description, as set in DescriptionText.

The formatting string can contain any number of the above specifiers in any order.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemVResizeCursor Property

Calendar.ItemVResizeCursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the vertical resize area of an item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Cursor ItemVResizeCursor { get; set; }
Visual Basic

Public Property ItemVResizeCursor As Cursor

Property Value

An instance of the .NET Cursor class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemHResizeCursor Property


MindFusion.Scheduling.WinForms.Calendar.KeepItemSelection Property

Calendar.KeepItemSelection Property

Gets or sets a value indicating whether the item selection is preserved when an item from the selection is clicked.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool KeepItemSelection { get; set; }
Visual Basic

Public Property KeepItemSelection As Boolean

Property Value

true to preserve the selection when an item from the selection is clicked or false to deselect all items except the one that is clicked.

Remarks

If the property is set to false, only the clicked item is selected.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ListViewSettings Property

Calendar.ListViewSettings Property

Gets the ListViewSettings object used to customize the visualization of the List view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ListViewSettings ListViewSettings { get; }
Visual Basic

Public ReadOnly Property ListViewSettings As ListViewSettings

Property Value

An instance of the ListViewSettings class.

Remarks

Use the ListViewSettings members to customize the appearance of the calendar when CurrentView is set to List.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.Locations Property

Calendar.Locations Property

Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public LocationCollection Locations { get; }
Visual Basic

Public ReadOnly Property Locations As LocationCollection

Property Value

An instance of the LocationCollection class specifying which locations are displayed as columns in a grouped view.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.LocationsDataMember Property

Calendar.LocationsDataMember Property

Gets or sets the name of the data member from the associated data source to bind the locations to.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string LocationsDataMember { get; set; }
Visual Basic

Public Property LocationsDataMember As String

Property Value

A string value specifying the locations data member.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
LocationsDataPropertyMap Property


MindFusion.Scheduling.WinForms.Calendar.LocationsDataPropertyMap Property

Calendar.LocationsDataPropertyMap Property

Gets or sets a BoundPropertyList object that maps location properties to fields in the associated data member.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public BoundPropertyList LocationsDataPropertyMap { get; set; }
Visual Basic

Public Property LocationsDataPropertyMap As BoundPropertyList

Property Value

An instance of the BoundPropertyList class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
LocationsDataMember Property


MindFusion.Scheduling.WinForms.Calendar.MinItemLength Property

Calendar.MinItemLength Property

Gets or sets the minimal length of interactively created items, expressed in minutes.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int MinItemLength { get; set; }
Visual Basic

Public Property MinItemLength As Integer

Property Value

A non-negative integer value.

Remarks

Specify 0 for no item length restrictions.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.MonthRangeSettings Property

Calendar.MonthRangeSettings Property

Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public MonthRangeSettings MonthRangeSettings { get; }
Visual Basic

Public ReadOnly Property MonthRangeSettings As MonthRangeSettings

Property Value

An instance of the MonthRangeSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.MonthSettings Property

Calendar.MonthSettings Property

Gets the MonthSettings object used to customize the visualization of months in the MonthRange and SingleMonth views.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public MonthSettings MonthSettings { get; }
Visual Basic

Public ReadOnly Property MonthSettings As MonthSettings

Property Value

An instance of the MonthSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.MonthStyles Property

Calendar.MonthStyles Property

Gets a collection of DateStyle objects that allow customizing the appearance of specific months in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateStyleCollection MonthStyles { get; }
Visual Basic

Public ReadOnly Property MonthStyles As DateStyleCollection

Property Value

An instance of the DateStyleCollection class.

Remarks

Use this collection to assign a distinct style to a month or a range of months, overriding the default style of the current view. If there are several styles defined for the same month, the one with highest Priority is used.

Example

The following example creates a custom style for the current month. The example assumes that calendar references existing Calendar control.

C#

// Create the custom date style
DateStyle dateStyle = new DateStyle();

// Change the brush used to fill the header contents
dateStyle.Style.HeaderBrush =
new MindFusion.Drawing.LinearGradientBrush(
Color.LightSteelBlue, Color.SteelBlue, 90);

// Set the time range of the style to span the whole month
DateTime today = DateTime.Today;
dateStyle.From = new DateTime(today.Year, today.Month, 1);
dateStyle.To = new DateTime(today.Year, today.Month,
DateTime.DaysInMonth(today.Year, today.Month));

// Add the style
calendar.MonthStyles.Add(dateStyle);
Visual Basic

' Create the custom date style
Dim dateStyle As New DateStyle()

' Change the brush used to fill the header contents
dateStyle.Style.HeaderBrush = _
New MindFusion.Drawing.LinearGradientBrush( _
Color.LightSteelBlue, Color.SteelBlue, 90)

' Set the time range of the style to span the whole month
Dim today As DateTime = DateTime.Today
dateStyle.From = New DateTime(today.Year, today.Month, 1)
dateStyle.To = New DateTime(today.Year, today.Month, _
DateTime.DaysInMonth(today.Year, today.Month))

' Add the style
calendar.MonthStyles.Add(dateStyle)

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
DayStyles Property
DayOfWeekStyles Property


MindFusion.Scheduling.WinForms.Calendar.PrintOptions Property

Calendar.PrintOptions Property

Gets a PrintOptions object that allows customizing various aspects of printing.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public PrintOptions PrintOptions { get; }
Visual Basic

Public ReadOnly Property PrintOptions As PrintOptions

Property Value

An instance of the PrintOptions class.

Remarks

Use the PrintOptions members to customize the print output, used both when printing and when displaying print preview.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
Print Method
PrintPreview Method


MindFusion.Scheduling.WinForms.Calendar.RecurrenceExceptionsDataMember Property

Calendar.RecurrenceExceptionsDataMember Property

Gets or sets the name of the data member from the associated data source to bind the recurrence exceptions to.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string RecurrenceExceptionsDataMember { get; set; }
Visual Basic

Public Property RecurrenceExceptionsDataMember As String

Property Value

A string value specifying the recurrence exceptions data member.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
RecurrenceExceptionsDataPropertyMap Property


MindFusion.Scheduling.WinForms.Calendar.RecurrenceExceptionsDataPropertyMap Property

Calendar.RecurrenceExceptionsDataPropertyMap Property

Gets or sets a BoundPropertyList object that maps recurrence exception properties to fields in the associated data member.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public BoundPropertyList RecurrenceExceptionsDataPropertyMap { get; set; }
Visual Basic

Public Property RecurrenceExceptionsDataPropertyMap As BoundPropertyList

Property Value

An instance of the BoundPropertyList class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
RecurrenceExceptionsDataMember Property


MindFusion.Scheduling.WinForms.Calendar.RecurrencesDataMember Property

Calendar.RecurrencesDataMember Property

Gets or sets the name of the data member from the associated data source to bind the recurrences to.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string RecurrencesDataMember { get; set; }
Visual Basic

Public Property RecurrencesDataMember As String

Property Value

A string value specifying the recurrences data member.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
RecurrencesDataPropertyMap Property


MindFusion.Scheduling.WinForms.Calendar.RecurrencesDataPropertyMap Property

Calendar.RecurrencesDataPropertyMap Property

Gets or sets a BoundPropertyList object that maps recurrence properties to fields in the associated data member.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public BoundPropertyList RecurrencesDataPropertyMap { get; set; }
Visual Basic

Public Property RecurrencesDataPropertyMap As BoundPropertyList

Property Value

An instance of the BoundPropertyList class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
RecurrencesDataMember Property


MindFusion.Scheduling.WinForms.Calendar.RemindersDataMember Property

Calendar.RemindersDataMember Property

Gets or sets the name of the data member from the associated data source to bind the reminders to.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string RemindersDataMember { get; set; }
Visual Basic

Public Property RemindersDataMember As String

Property Value

A string value specifying the reminders data member.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
RecurrencesDataPropertyMap Property


MindFusion.Scheduling.WinForms.Calendar.RemindersDataPropertyMap Property

Calendar.RemindersDataPropertyMap Property

Gets or sets a BoundPropertyList object that maps reminder properties to fields in the associated data member.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public BoundPropertyList RemindersDataPropertyMap { get; set; }
Visual Basic

Public Property RemindersDataPropertyMap As BoundPropertyList

Property Value

An instance of the BoundPropertyList class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
RemindersDataMember Property


MindFusion.Scheduling.WinForms.Calendar.Resources Property

Calendar.Resources Property

Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ResourceCollection Resources { get; }
Visual Basic

Public ReadOnly Property Resources As ResourceCollection

Property Value

An instance of the ResourceCollection class specifying which resources are displayed as columns in timetable, week range and resource views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ResourcesDataMember Property

Calendar.ResourcesDataMember Property

Gets or sets the name of the data member from the associated data source to bind the resources to.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string ResourcesDataMember { get; set; }
Visual Basic

Public Property ResourcesDataMember As String

Property Value

A string value specifying the resources data member.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ResourcesDataPropertyMap Property


MindFusion.Scheduling.WinForms.Calendar.ResourcesDataPropertyMap Property

Calendar.ResourcesDataPropertyMap Property

Gets or sets a BoundPropertyList object that maps resource properties to fields in the associated data member.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public BoundPropertyList ResourcesDataPropertyMap { get; set; }
Visual Basic

Public Property ResourcesDataPropertyMap As BoundPropertyList

Property Value

An instance of the BoundPropertyList class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ResourcesDataMember Property


MindFusion.Scheduling.WinForms.Calendar.ResourceViewSettings Property

Calendar.ResourceViewSettings Property

Gets the ResourceViewSettings object used to customize the visualization of a Resource view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ResourceViewSettings ResourceViewSettings { get; }
Visual Basic

Public ReadOnly Property ResourceViewSettings As ResourceViewSettings

Property Value

An instance of the ResourceViewSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.Schedule Property

Calendar.Schedule Property

Gets or sets the schedule whose information should be displayed inside the calendar control.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Schedule Schedule { get; set; }
Visual Basic

Public Property Schedule As Schedule

Property Value

An Schedule object providing the schedule data displayed in the calendar view.

Remarks

You can easily substitute the schedule being displayed by the control at any time by simply assigning a new Schedule object to this property. You can also make two or more MindFusion.Scheduling controls display the same schedule.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
Schedule Class


MindFusion.Scheduling.WinForms.Calendar.ScrollPosition Property

Calendar.ScrollPosition Property

Gets or sets the current scroll position.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Point ScrollPosition { get; set; }
Visual Basic

Public Property ScrollPosition As Point

Property Value

A .NET Point object specifying the scroll position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
HScrollPos Property
VScrollPos Property


MindFusion.Scheduling.WinForms.Calendar.Selection Property

Calendar.Selection Property

Gets a Selection object representing the current selection in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Selection Selection { get; }
Visual Basic

Public ReadOnly Property Selection As Selection

Property Value

An instance of the Selection class representing the selection of time cells.

Remarks

Use ItemSelection to get the selection of schedule items.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemSelection Property


MindFusion.Scheduling.WinForms.Calendar.ShowToolTips Property

Calendar.ShowToolTips Property

Gets or sets a value indicating whether the calendar displays tooltips.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ShowToolTips { get; set; }
Visual Basic

Public Property ShowToolTips As Boolean

Property Value

true to display tooltips; otherwise, false. The default is false.

Remarks

Tooltips can be displayed for schedule items and for various calendar elements.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.StartEditAfterModify Property

Calendar.StartEditAfterModify Property

Gets or sets a value indicating whether in-place editing of items should automatically start after they are modified interactively.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool StartEditAfterModify { get; set; }
Visual Basic

Public Property StartEditAfterModify As Boolean

Property Value

true to enable automatic in-place editing after item modification; false to disable it. The default is false.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.StylesDataMember Property

Calendar.StylesDataMember Property

Gets or sets the name of the data member from the associated data source to bind the styles to.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string StylesDataMember { get; set; }
Visual Basic

Public Property StylesDataMember As String

Property Value

A string value specifying the styles data member.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
StylesDataPropertyMap Property


MindFusion.Scheduling.WinForms.Calendar.StylesDataPropertyMap Property

Calendar.StylesDataPropertyMap Property

Gets or sets a BoundPropertyList object that maps style properties to fields in the associated data member.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public BoundPropertyList StylesDataPropertyMap { get; set; }
Visual Basic

Public Property StylesDataPropertyMap As BoundPropertyList

Property Value

An instance of the BoundPropertyList class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
StylesDataMember Property


MindFusion.Scheduling.WinForms.Calendar.Tasks Property

Calendar.Tasks Property

Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TaskCollection Tasks { get; }
Visual Basic

Public ReadOnly Property Tasks As TaskCollection

Property Value

An instance of the TaskCollection class specifying which tasks are displayed as columns in a grouped view.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.TasksDataMember Property

Calendar.TasksDataMember Property

Gets or sets the name of the data member from the associated data source to bind the schedule tasks to.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string TasksDataMember { get; set; }
Visual Basic

Public Property TasksDataMember As String

Property Value

A string value specifying the tasks data member.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
TasksDataPropertyMap Property


MindFusion.Scheduling.WinForms.Calendar.TasksDataPropertyMap Property

Calendar.TasksDataPropertyMap Property

Gets or sets a BoundPropertyList object that maps task properties to fields in the associated data member.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public BoundPropertyList TasksDataPropertyMap { get; set; }
Visual Basic

Public Property TasksDataPropertyMap As BoundPropertyList

Property Value

An instance of the BoundPropertyList class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
TasksDataMember Property


MindFusion.Scheduling.WinForms.Calendar.TextRendering Property

Calendar.TextRendering Property

Gets or sets the text rendering mode.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TextRenderingHint TextRendering { get; set; }
Visual Basic

Public Property TextRendering As TextRenderingHint

Property Value

A member of the .NET TextRenderingHint enumeration.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.Theme Property

Calendar.Theme Property

Gets or sets the theme applied to the calendar control UI elements.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ThemeType Theme { get; set; }
Visual Basic

Public Property Theme As ThemeType

Property Value

A member of the ThemeType enumeration.

Remarks

You cannot specify the value Custom for this property. In order to apply a custom theme, either assign the theme to the CustomTheme property of the Calendar control or pass it as an argument to the ApplyTheme method.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ApplyTheme Method


MindFusion.Scheduling.WinForms.Calendar.TimetableSettings Property

Calendar.TimetableSettings Property

Gets the TimetableSettings object used to customize the visualization of days and hours in Timetable view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimetableSettings TimetableSettings { get; }
Visual Basic

Public ReadOnly Property TimetableSettings As TimetableSettings

Property Value

An instance of the TimetableSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ToolTip Property

Calendar.ToolTip Property

Gets the underlying ToolTip component.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ToolTip ToolTip { get; }
Visual Basic

Public ReadOnly Property ToolTip As ToolTip

Property Value

An instance of the .NET ToolTip class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.VScrollerSmallChange Property

Calendar.VScrollerSmallChange Property

Gets or sets the small step for the vertical scroll bar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int VScrollerSmallChange { get; set; }
Visual Basic

Public Property VScrollerSmallChange As Integer

Property Value

An integer value representing the small step of the vertical scroll bar.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
HScrollerSmallChange Property


MindFusion.Scheduling.WinForms.Calendar.VScrollerVisible Property

Calendar.VScrollerVisible Property

Gets or sets a value indicating whether the vertical scroller should always be visible, always hidden or visible only when it is needed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State VScrollerVisible { get; set; }
Visual Basic

Public Property VScrollerVisible As State

Property Value

A member of the State enumeration specifying the visibility state of the horizontal scroller.

Remarks

Specify Disabled for this property to always hide the scroller, Enabled to always show it and Unspecified to let the Calendar control decide when to show the scroller.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
HScrollerVisible Property


MindFusion.Scheduling.WinForms.Calendar.VScrollPos Property

Calendar.VScrollPos Property

Gets or sets the current vertical scroll position.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int VScrollPos { get; set; }
Visual Basic

Public Property VScrollPos As Integer

Property Value

An integer value specifying the current vertical scroll position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
HScrollPos Property
ScrollPosition Property


MindFusion.Scheduling.WinForms.Calendar.WeekRangeSettings Property

Calendar.WeekRangeSettings Property

Gets the WeekRangeSettings object used to customize the visualization of weeks in a WeekRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public WeekRangeSettings WeekRangeSettings { get; }
Visual Basic

Public ReadOnly Property WeekRangeSettings As WeekRangeSettings

Property Value

An instance of the WeekRangeSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar Events

Calendar Events

Public Events

Name | Description
ContinuePrinting | Occurs at the end of a printing operation to enable users to continue printing the calendar with different view settings.
DateClick | Raised when the user clicks a date cell in the calendar.
Draw | Raised to allow custom drawing of calendar UI elements.
HiddenItemClick | Raised when a hidden items cue icon is clicked.
HScroll | Raised when the control has been scrolled horizontally.
ItemClick | Raised when the user clicks a schedule item.
ItemCloned | Raised when the user has cloned an item interactively.
ItemCloning | Raised when the user is about to clone an item interactively.
ItemCreated | Raised when a schedule item is created by the user.
ItemCreating | Raised when the user is about to create a new schedule item.
ItemCreationCanceled | Raised when an interactive item creation is canceled by the user.
ItemDeleted | Raised when the user deletes a schedule item.
ItemDeleting | Raised when the user is about to delete a schedule item.
ItemDeselecting | Raised when an item is about to be deselected.
ItemInplaceEdited | Raised when item's text is in-place edited.
ItemInplaceEditEnding | Raised when in-place editing of item's text is about to be accepted.
ItemInplaceEditStarting | Raised when in-place editing of item's text is about to begin.
ItemListLaneChanged | Raised when the lane index of an item within a List view has changed.
ItemModificationCanceled | Raised when an item modification is canceled by the user.
ItemModified | Raised when a schedule item is moved or resized by the user.
ItemModifying | Raised when the user moves or resizes a schedule item, which would change the item's scheduled start or end date and time.
ItemSelecting | Raised when an item is about to be selected.
ItemSelectionChanged | Raised when an item is selected or deselected.
ItemSelectionComplete | Raised when an item is selected or deselected.
ItemTooltipDisplaying | Raised to allow modification of an item's ToolTip before it gets displayed.
ListViewHeaderClick | Raised when the header of a List view is clicked.
MonthCellClick | Raised when the user clicks on a month cell in a SingleMonth and MonthRange views.
MonthHeaderClick | Raised when the header of a Month view is clicked.
MonthRangeHeaderClick | Raised when the header of an MonthRange view is clicked.
MonthWeekHeaderClick | Raised when a cell in the week header of a Month view is clicked.
RecurringItemDeleting | Raised when the user is about to delete a recurring item.
ResourceViewBottomTimelineClick | Raised when the bottom timeline of a Resource view is clicked.
ResourceViewMiddleTimelineClick | Raised when the middle timeline of a Resource view is clicked.
ResourceViewRowHeaderClick | Raised when the header of a Resource view row is clicked.
ResourceViewTopTimelineClick | Raised when the top timeline of a Resource view is clicked.
Scroll | Raised when the value of a scrollbar has changed.
TimetableColumnHeaderClick | Raised when the header of a Timetable column is clicked.
TooltipDisplaying | Raised to allow modification of the ToolTip of a calendar element before it gets displayed.
VisibleDateChanged | Raised when the user selects another date using the month or year navigation controls on the calendar header area.
VScroll | Raised when the control has been scrolled vertically.
WeekRangeHeaderClick | Raised when the header of a WeekRange view is clicked.

See Also

Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ContinuePrinting Event

Calendar.ContinuePrinting Event

Occurs at the end of a printing operation to enable users to continue printing the calendar with different view settings.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ContinuePrintingEventArgs> ContinuePrinting
Visual Basic

Public Event ContinuePrinting As EventHandler(Of ContinuePrintingEventArgs)

Event Data

ContinuePrinting event handlers receive an argument of type ContinuePrintingEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.DateClick Event

Calendar.DateClick Event

Raised when the user clicks a date cell in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ResourceDateEventArgs> DateClick
Visual Basic

Public Event DateClick As EventHandler(Of ResourceDateEventArgs)

Event Data

DateClick event handlers receive an argument of type ResourceDateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.Draw Event

Calendar.Draw Event

Raised to allow custom drawing of calendar UI elements.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event CustomDraw Draw
Visual Basic

Public Event Draw As CustomDraw

Event Data

Draw event handlers receive an argument of type DrawEventArgs.

Remarks

This event is raised if the CustomDraw property is set to a value different than None.

Example

The following example demonstrates how to use the CustomDraw property in conjunction with the Draw event. The example assumes that calendar references a valid Calendar instance.

The example draws a red ellipse around specific dates in a SingleMonth view.

C#

calendar.CurrentView = CalendarView.SingleMonth;
calendar.CustomDraw = CustomDrawElements.CellHeader;
calendar.Draw += new CustomDraw(calendar_Draw);

// ...

private bool IsHoliday(DateTime date)
{
if (date.Day == 31 && date.Month == 12)
return true;
if (date.Day == 24 && date.Month == 5)
return true;

return false;
}

// ...

private void calendar_Draw(object sender, CustomDrawArgs e)
{
if (e.Element == CustomDrawElements.CellHeader)
{
if (IsHoliday(e.Date))
e.Graphics.DrawEllipse(Pens.Red, e.Bounds);
}
}
Visual Basic

calendar.CurrentView = CalendarView.SingleMonth
calendar.CustomDraw = CustomDrawElements.CellHeader
AddHandler calendar.Draw, AddressOf calendar_Draw

' ...

Private Function IsHoliday(ByVal ddate As DateTime) As Boolean

If ddate.Day = 31 And ddate.Month = 12 Then
Return True
End If

If ddate.Day = 24 And ddate.Month = 5 Then
Return True
End If

Return False

End Function

' ...

Private Sub calendar_Draw(ByVal sender As Object, ByVal e As CustomDrawArgs)

If e.Element = CustomDrawElements.CellHeader Then

If IsHoliday(e.Date) Then
e.Graphics.DrawEllipse(Pens.Red, e.Bounds)
End If

End If

End Sub

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.HiddenItemClick Event

Calendar.HiddenItemClick Event

Raised when a hidden items cue icon is clicked.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<DateEventArgs> HiddenItemClick
Visual Basic

Public Event HiddenItemClick As EventHandler(Of DateEventArgs)

Event Data

HiddenItemClick event handlers receive an argument of type DateEventArgs.

Remarks

The hidden items cue is displayed when there are schedule items included in the time range of the current calendar view, but not currently visible because of insufficient space.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemClick Event


MindFusion.Scheduling.WinForms.Calendar.HScroll Event

Calendar.HScroll Event

Raised when the control has been scrolled horizontally.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event ScrollEventHandler HScroll
Visual Basic

Public Event HScroll As ScrollEventHandler

Event Data

HScroll event handlers receive an argument of type ScrollEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
VScroll Event
Scroll Event


MindFusion.Scheduling.WinForms.Calendar.ItemClick Event

Calendar.ItemClick Event

Raised when the user clicks a schedule item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemMouseEventArgs> ItemClick
Visual Basic

Public Event ItemClick As EventHandler(Of ItemMouseEventArgs)

Event Data

ItemClick event handlers receive an argument of type ItemMouseEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
HiddenItemClick Event


MindFusion.Scheduling.WinForms.Calendar.ItemCloned Event

Calendar.ItemCloned Event

Raised when the user has cloned an item interactively.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemEventArgs> ItemCloned
Visual Basic

Public Event ItemCloned As EventHandler(Of ItemEventArgs)

Event Data

ItemCloned event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemCloning Event


MindFusion.Scheduling.WinForms.Calendar.ItemCloning Event

Calendar.ItemCloning Event

Raised when the user is about to clone an item interactively.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemConfirmEventArgs> ItemCloning
Visual Basic

Public Event ItemCloning As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemCloning event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemCloned Event


MindFusion.Scheduling.WinForms.Calendar.ItemCreated Event

Calendar.ItemCreated Event

Raised when a schedule item is created by the user.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemEventArgs> ItemCreated
Visual Basic

Public Event ItemCreated As EventHandler(Of ItemEventArgs)

Event Data

ItemCreated event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemCreating Event


MindFusion.Scheduling.WinForms.Calendar.ItemCreating Event

Calendar.ItemCreating Event

Raised when the user is about to create a new schedule item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemConfirmEventArgs> ItemCreating
Visual Basic

Public Event ItemCreating As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemCreating event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemCreated Event


MindFusion.Scheduling.WinForms.Calendar.ItemCreationCanceled Event

Calendar.ItemCreationCanceled Event

Raised when an interactive item creation is canceled by the user.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemEventArgs> ItemCreationCanceled
Visual Basic

Public Event ItemCreationCanceled As EventHandler(Of ItemEventArgs)

Event Data

ItemCreationCanceled event handlers receive an argument of type ItemEventArgs.

Remarks

This event is raised when the user presses the ESC button while in-place editing the text of an item currently being created.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemDeleted Event

Calendar.ItemDeleted Event

Raised when the user deletes a schedule item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemEventArgs> ItemDeleted
Visual Basic

Public Event ItemDeleted As EventHandler(Of ItemEventArgs)

Event Data

ItemDeleted event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemDeleting Event


MindFusion.Scheduling.WinForms.Calendar.ItemDeleting Event

Calendar.ItemDeleting Event

Raised when the user is about to delete a schedule item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemConfirmEventArgs> ItemDeleting
Visual Basic

Public Event ItemDeleting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemDeleting event handlers receive an argument of type ItemConfirmEventArgs.

Remarks

This event can be used to prevent users from deleting specific non-recurring items by pressing DEL. This event is raised once for each element of the item selection. To control the deletion of recurring items, handle the RecurringItemDeleting event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemDeleted Event


MindFusion.Scheduling.WinForms.Calendar.ItemDeselecting Event

Calendar.ItemDeselecting Event

Raised when an item is about to be deselected.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemConfirmEventArgs> ItemDeselecting
Visual Basic

Public Event ItemDeselecting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemDeselecting event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemSelecting Event


MindFusion.Scheduling.WinForms.Calendar.ItemInplaceEdited Event

Calendar.ItemInplaceEdited Event

Raised when item's text is in-place edited.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemEventArgs> ItemInplaceEdited
Visual Basic

Public Event ItemInplaceEdited As EventHandler(Of ItemEventArgs)

Event Data

ItemInplaceEdited event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemInplaceEditStarting Event
ItemInplaceEditEnding Event


MindFusion.Scheduling.WinForms.Calendar.ItemInplaceEditEnding Event

Calendar.ItemInplaceEditEnding Event

Raised when in-place editing of item's text is about to be accepted.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemEditConfirmEventArgs> ItemInplaceEditEnding
Visual Basic

Public Event ItemInplaceEditEnding As EventHandler(Of ItemEditConfirmEventArgs)

Event Data

ItemInplaceEditEnding event handlers receive an argument of type ItemEditConfirmEventArgs.

Remarks

This event can be used to validate the text entered into a schedule item during the in-place editing mode.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemInplaceEditStarting Event
ItemInplaceEdited Event


MindFusion.Scheduling.WinForms.Calendar.ItemInplaceEditStarting Event

Calendar.ItemInplaceEditStarting Event

Raised when in-place editing of item's text is about to begin.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemConfirmEventArgs> ItemInplaceEditStarting
Visual Basic

Public Event ItemInplaceEditStarting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemInplaceEditStarting event handlers receive an argument of type ItemConfirmEventArgs.

Remarks

This event can be handled to prevent users from editing the text of specific schedule items.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemInplaceEditEnding Event
ItemInplaceEdited Event


MindFusion.Scheduling.WinForms.Calendar.ItemListLaneChanged Event

Calendar.ItemListLaneChanged Event

Raised when the lane index of an item within a List view has changed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemEventArgs> ItemListLaneChanged
Visual Basic

Public Event ItemListLaneChanged As EventHandler(Of ItemEventArgs)

Event Data

ItemListLaneChanged event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemModificationCanceled Event

Calendar.ItemModificationCanceled Event

Raised when an item modification is canceled by the user.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemEventArgs> ItemModificationCanceled
Visual Basic

Public Event ItemModificationCanceled As EventHandler(Of ItemEventArgs)

Event Data

ItemModificationCanceled event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemModified Event
ItemModifying Event


MindFusion.Scheduling.WinForms.Calendar.ItemModified Event

Calendar.ItemModified Event

Raised when a schedule item is moved or resized by the user.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemModifiedEventArgs> ItemModified
Visual Basic

Public Event ItemModified As EventHandler(Of ItemModifiedEventArgs)

Event Data

ItemModified event handlers receive an argument of type ItemModifiedEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemModifying Event
ItemModificationCanceled Event


MindFusion.Scheduling.WinForms.Calendar.ItemModifying Event

Calendar.ItemModifying Event

Raised when the user moves or resizes a schedule item, which would change the item's scheduled start or end date and time.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemModifyConfirmEventArgs> ItemModifying
Visual Basic

Public Event ItemModifying As EventHandler(Of ItemModifyConfirmEventArgs)

Event Data

ItemModifying event handlers receive an argument of type ItemModifyConfirmEventArgs.

Remarks

This event can be used to prevent users from modifying an item interactively.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemModified Event
ItemModificationCanceled Event


MindFusion.Scheduling.WinForms.Calendar.ItemSelecting Event

Calendar.ItemSelecting Event

Raised when an item is about to be selected.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemConfirmEventArgs> ItemSelecting
Visual Basic

Public Event ItemSelecting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemSelecting event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemDeselecting Event


MindFusion.Scheduling.WinForms.Calendar.ItemSelectionChanged Event

Calendar.ItemSelectionChanged Event

Raised when an item is selected or deselected.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemSelectionEventArgs> ItemSelectionChanged
Visual Basic

Public Event ItemSelectionChanged As EventHandler(Of ItemSelectionEventArgs)

Event Data

ItemSelectionChanged event handlers receive an argument of type ItemSelectionEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemSelectionComplete Event


MindFusion.Scheduling.WinForms.Calendar.ItemSelectionComplete Event

Calendar.ItemSelectionComplete Event

Raised when an item is selected or deselected.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler ItemSelectionComplete
Visual Basic

Public Event ItemSelectionComplete As EventHandler

Event Data

ItemSelectionComplete event handlers receive an argument of type EventArgs.

Remarks

This event is fired only once unlike ItemSelectionChanged which is fired for each individual item affected by the selection operation.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemSelectionChanged Event


MindFusion.Scheduling.WinForms.Calendar.ItemTooltipDisplaying Event

Calendar.ItemTooltipDisplaying Event

Raised to allow modification of an item's ToolTip before it gets displayed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ItemTooltipEventArgs> ItemTooltipDisplaying
Visual Basic

Public Event ItemTooltipDisplaying As EventHandler(Of ItemTooltipEventArgs)

Event Data

ItemTooltipDisplaying event handlers receive an argument of type ItemTooltipEventArgs.

Remarks

Set the Tooltip member of the ItemTooltipEventArgs object to override the default ToolTip text.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ListViewHeaderClick Event

Calendar.ListViewHeaderClick Event

Raised when the header of a List view is clicked.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<DateEventArgs> ListViewHeaderClick
Visual Basic

Public Event ListViewHeaderClick As EventHandler(Of DateEventArgs)

Event Data

ListViewHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.MonthCellClick Event

Calendar.MonthCellClick Event

Raised when the user clicks on a month cell in a SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<DateEventArgs> MonthCellClick
Visual Basic

Public Event MonthCellClick As EventHandler(Of DateEventArgs)

Event Data

MonthCellClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.MonthHeaderClick Event

Calendar.MonthHeaderClick Event

Raised when the header of a Month view is clicked.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<DateEventArgs> MonthHeaderClick
Visual Basic

Public Event MonthHeaderClick As EventHandler(Of DateEventArgs)

Event Data

MonthHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
MonthWeekHeaderClick Event


MindFusion.Scheduling.WinForms.Calendar.MonthRangeHeaderClick Event

Calendar.MonthRangeHeaderClick Event

Raised when the header of an MonthRange view is clicked.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<DateEventArgs> MonthRangeHeaderClick
Visual Basic

Public Event MonthRangeHeaderClick As EventHandler(Of DateEventArgs)

Event Data

MonthRangeHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.MonthWeekHeaderClick Event

Calendar.MonthWeekHeaderClick Event

Raised when a cell in the week header of a Month view is clicked.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<DateEventArgs> MonthWeekHeaderClick
Visual Basic

Public Event MonthWeekHeaderClick As EventHandler(Of DateEventArgs)

Event Data

MonthWeekHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
MonthHeaderClick Event


MindFusion.Scheduling.WinForms.Calendar.RecurringItemDeleting Event

Calendar.RecurringItemDeleting Event

Raised when the user is about to delete a recurring item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<RecurringItemConfirmEventArgs> RecurringItemDeleting
Visual Basic

Public Event RecurringItemDeleting As EventHandler(Of RecurringItemConfirmEventArgs)

Event Data

RecurringItemDeleting event handlers receive an argument of type RecurringItemConfirmEventArgs.

Remarks

This event can be used to prevent the deletion of recurring items. For non-recurring items, handle the ItemDeleting event.

Example

The following example demonstrates how to use RecurringItemDeleting event to ask the user whether he or she wants to delete all items of a recurring pattern or only the selected item(s). The example assumes that calendar already references a Calendar control. The method ConfirmDelete is supposed to return 0 if the user cancels the deletion of the item, 1 if the user chooses that only the selected item is to be deleted, and 2 if the user wants to delete the entire pattern.

C#

// Attach a handler to the event
calendar.RecurringItemDeleting +=
new EventHandler<RecurringItemConfirmEventArgs>(calendar_RecurringItemDeleting);

// ...

private void calendar_RecurringItemDeleting(object sender, RecurringItemConfirmEventArgs e)
{
int result = ConfirmDelete(e.Item);

switch (result)
{

case 0:
// Do nothing
break;

case 1:
e.ConfirmOccurrence = true;
break;

case 2:
e.ConfirmAll = true;
break;

}
}
Visual Basic

' Attach a handler to the event
AddHandler calendar.RecurringItemDeleting, AddressOf calendar_RecurringItemDeleting

' ...

Private Sub calendar_RecurringItemDeleting(ByVal sender As Object, ByVal e As RecurringItemConfirmEventArgs)

Dim result As Integer = ConfirmDelete(e.Item)

Select Case result

Case 0
' Do nothing

Case 1
e.ConfirmOccurrence = True

Case 2
e.ConfirmAll = True

End Select

End Sub

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ResourceViewBottomTimelineClick Event

Calendar.ResourceViewBottomTimelineClick Event

Raised when the bottom timeline of a Resource view is clicked.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<DateEventArgs> ResourceViewBottomTimelineClick
Visual Basic

Public Event ResourceViewBottomTimelineClick As EventHandler(Of DateEventArgs)

Event Data

ResourceViewBottomTimelineClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ResourceViewMiddleTimelineClick Event
ResourceViewTopTimelineClick Event


MindFusion.Scheduling.WinForms.Calendar.ResourceViewMiddleTimelineClick Event

Calendar.ResourceViewMiddleTimelineClick Event

Raised when the middle timeline of a Resource view is clicked.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<DateEventArgs> ResourceViewMiddleTimelineClick
Visual Basic

Public Event ResourceViewMiddleTimelineClick As EventHandler(Of DateEventArgs)

Event Data

ResourceViewMiddleTimelineClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ResourceViewBottomTimelineClick Event
ResourceViewTopTimelineClick Event


MindFusion.Scheduling.WinForms.Calendar.ResourceViewRowHeaderClick Event

Calendar.ResourceViewRowHeaderClick Event

Raised when the header of a Resource view row is clicked.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<ResourceDateEventArgs> ResourceViewRowHeaderClick
Visual Basic

Public Event ResourceViewRowHeaderClick As EventHandler(Of ResourceDateEventArgs)

Event Data

ResourceViewRowHeaderClick event handlers receive an argument of type ResourceDateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.ResourceViewTopTimelineClick Event

Calendar.ResourceViewTopTimelineClick Event

Raised when the top timeline of a Resource view is clicked.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<DateEventArgs> ResourceViewTopTimelineClick
Visual Basic

Public Event ResourceViewTopTimelineClick As EventHandler(Of DateEventArgs)

Event Data

ResourceViewTopTimelineClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ResourceViewBottomTimelineClick Event
ResourceViewMiddleTimelineClick Event


MindFusion.Scheduling.WinForms.Calendar.Scroll Event

Calendar.Scroll Event

Raised when the value of a scrollbar has changed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler Scroll
Visual Basic

Public Event Scroll As EventHandler

Event Data

Scroll event handlers receive an argument of type EventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
HScroll Event
VScroll Event


MindFusion.Scheduling.WinForms.Calendar.TimetableColumnHeaderClick Event

Calendar.TimetableColumnHeaderClick Event

Raised when the header of a Timetable column is clicked.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<DateEventArgs> TimetableColumnHeaderClick
Visual Basic

Public Event TimetableColumnHeaderClick As EventHandler(Of DateEventArgs)

Event Data

TimetableColumnHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.TooltipDisplaying Event

Calendar.TooltipDisplaying Event

Raised to allow modification of the ToolTip of a calendar element before it gets displayed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<TooltipEventArgs> TooltipDisplaying
Visual Basic

Public Event TooltipDisplaying As EventHandler(Of TooltipEventArgs)

Event Data

TooltipDisplaying event handlers receive an argument of type TooltipEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
ItemTooltipDisplaying Event


MindFusion.Scheduling.WinForms.Calendar.VisibleDateChanged Event

Calendar.VisibleDateChanged Event

Raised when the user selects another date using the month or year navigation controls on the calendar header area.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<DateChangedEventArgs> VisibleDateChanged
Visual Basic

Public Event VisibleDateChanged As EventHandler(Of DateChangedEventArgs)

Event Data

VisibleDateChanged event handlers receive an argument of type DateChangedEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Calendar.VScroll Event

Calendar.VScroll Event

Raised when the control has been scrolled vertically.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event ScrollEventHandler VScroll
Visual Basic

Public Event VScroll As ScrollEventHandler

Event Data

VScroll event handlers receive an argument of type ScrollEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace
HScroll Event
Scroll Event


MindFusion.Scheduling.WinForms.Calendar.WeekRangeHeaderClick Event

Calendar.WeekRangeHeaderClick Event

Raised when the header of a WeekRange view is clicked.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler<DateEventArgs> WeekRangeHeaderClick
Visual Basic

Public Event WeekRangeHeaderClick As EventHandler(Of DateEventArgs)

Event Data

WeekRangeHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.CalendarElement Enumeration

CalendarElement Enumeration

Specifies a calendar subelement.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum CalendarElement
Visual Basic

Public Enumeration CalendarElement

Members

Member name | Description
Cell | A cell in a SingleMonth, MonthRange, WeekRange or List view.
MonthWeek | The week header in a SingleMonth and MonthRange view.
ResourceViewBottomTimeline | The bottom timeline in a Resource view.
ResourceViewCell | A cell in a Resource view.
ResourceViewHeader | The row header in a Resource view.
ResourceViewMiddleTimeline | The middle timeline in a Resource view.
ResourceViewTopTimeline | The topmost timeline in a Resource view.
TimetableCell | A cell in a Timetable view.
TimetableColumnHeader | The header of a Timetable view column. This might be the header displaying the column date, if no grouping is enabled, or the header displaying the referenced contact or location if grouping is enabled.
TimetableDayHeader | The all-day header in a Timetable view.
TimetableGroupHeader | The group header in a Timetable view. Only available when grouping is enabled.
TimetableInfoHeader | The info header in a Timetable view.
TimetableTimeline | The timeline in a Timetable view.
NavigationButtonLeft | The left navigation button that performs a small step.
NavigationButtonLeftFast | The left navigation button that performs a large step.
NavigationButtonRight | The right navigation button that performs a small step.
NavigationButtonRightFast | The right navigation button that performs a large step.
HorizontalScrollBar | The horizontal scrollbar.
VerticalScrollBar | The vertical scrollbar.

Remarks

The values of this enumeration are used to identify various parts of the Calendar control when you need to obtain the bounding rectangle of a particular element through a call to the GetElementBounds method.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.CalendarView Enumeration

CalendarView Enumeration

Specifies the type of view to display in a calendar control.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum CalendarView
Visual Basic

Public Enumeration CalendarView

Members

Member name | Description
List | The calendar displays several seconds, minutes, hours, days, weeks, months or years in a row or a column (see List View).
MonthRange | The calendar displays several months in a grid. The days of each month are visible too (see Month Range View).
ResourceView | The calendar displays the distribution of items over a period of time (see Resource View).
SingleMonth | The calendar displays a single month at a time. The days of the month are displayed in a grid (see Single Month View).
Timetable | The calendar displays a timetable where each row represents a fixed arbitrary time interval and each column represents a day. This view allow further division by various grouping criteria such as by contacts, locations or tasks (see Timetable View).
WeekRange | The calendar displays a grid of days, with the columns representing the week days from Monday to Sunday and the rows representing weeks (see Week Range View).

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.CellSettings Class

CellSettings Class

Defines appearance settings for the cells representing time ranges in the calendar in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class CellSettings : ViewSettings
Visual Basic

Public NotInheritable Class CellSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.ViewSettings
MindFusion.Scheduling.WinForms.CellSettings

See Also

CellSettings Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.CellSettings Members

CellSettings Members
Properties

Defines appearance settings for the cells representing time ranges in the calendar in the calendar.

The following tables list the members exposed by the CellSettings type.

Public Properties

Name | Description
FirstDayOfMonthFormat | Gets or sets the string used to format and display the first day of each month in the calendar.
FirstDayOfYearFormat | Gets or sets the string used to format and display the first day of each year in the calendar.
GeneralFormat | Gets or sets the string used to format and display dates and times in the calendar.
HeaderPosition | Gets or sets the position of the cell header.
HeaderSize | Gets or sets the size of the cell header in pixels.
Margin | Gets or sets the distance between the outermost border of the cell and the cell contents.
RotateHeader | Gets or sets a value indicating whether to rotate header text when the header position is set to Left or Right.
ShowToday | Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TodayColor | Gets or sets the color used to paint the line that marks the current cell.
TodayFillColor | Gets or sets the color used to fill the header of the current cell.

See Also

CellSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.CellSettings Properties

CellSettings Properties

Public Properties

Name | Description
FirstDayOfMonthFormat | Gets or sets the string used to format and display the first day of each month in the calendar.
FirstDayOfYearFormat | Gets or sets the string used to format and display the first day of each year in the calendar.
GeneralFormat | Gets or sets the string used to format and display dates and times in the calendar.
HeaderPosition | Gets or sets the position of the cell header.
HeaderSize | Gets or sets the size of the cell header in pixels.
Margin | Gets or sets the distance between the outermost border of the cell and the cell contents.
RotateHeader | Gets or sets a value indicating whether to rotate header text when the header position is set to Left or Right.
ShowToday | Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TodayColor | Gets or sets the color used to paint the line that marks the current cell.
TodayFillColor | Gets or sets the color used to fill the header of the current cell.

See Also

CellSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.CellSettings.FirstDayOfMonthFormat Property

CellSettings.FirstDayOfMonthFormat Property

Gets or sets the string used to format and display the first day of each month in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string FirstDayOfMonthFormat { get; set; }
Visual Basic

Public Property FirstDayOfMonthFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WinForms Namespace
GeneralFormat Property
FirstDayOfYearFormat Property


MindFusion.Scheduling.WinForms.CellSettings.FirstDayOfYearFormat Property

CellSettings.FirstDayOfYearFormat Property

Gets or sets the string used to format and display the first day of each year in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string FirstDayOfYearFormat { get; set; }
Visual Basic

Public Property FirstDayOfYearFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WinForms Namespace
GeneralFormat Property
FirstDayOfMonthFormat Property


MindFusion.Scheduling.WinForms.CellSettings.GeneralFormat Property

CellSettings.GeneralFormat Property

Gets or sets the string used to format and display dates and times in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string GeneralFormat { get; set; }
Visual Basic

Public Property GeneralFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WinForms Namespace
FirstDayOfMonthFormat Property
FirstDayOfYearFormat Property


MindFusion.Scheduling.WinForms.CellSettings.HeaderPosition Property

CellSettings.HeaderPosition Property

Gets or sets the position of the cell header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Position HeaderPosition { get; set; }
Visual Basic

Public Property HeaderPosition As Position

Property Value

A member of the Position enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderSize Property
RotateHeader Property


MindFusion.Scheduling.WinForms.CellSettings.HeaderSize Property

CellSettings.HeaderSize Property

Gets or sets the size of the cell header in pixels.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderSize { get; set; }
Visual Basic

Public Property HeaderSize As Integer

Property Value

A non-negative integer value specifying the size in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property specifies the height of the header if HeaderPosition is set to either Top or Bottom, or the width of the header if HeaderPosition is set to Left or Right. Specifying 0 for this property expands the header to fill the entire cell.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderPosition Property


MindFusion.Scheduling.WinForms.CellSettings.Margin Property

CellSettings.Margin Property

Gets or sets the distance between the outermost border of the cell and the cell contents.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Margin { get; set; }
Visual Basic

Public Property Margin As Integer

Property Value

A non-negative integer value specifying the margin size in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.CellSettings.RotateHeader Property

CellSettings.RotateHeader Property

Gets or sets a value indicating whether to rotate header text when the header position is set to Left or Right.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State RotateHeader { get; set; }
Visual Basic

Public Property RotateHeader As State

Property Value

Specify Enabled to rotate header text, otherwise Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderPosition Property


MindFusion.Scheduling.WinForms.CellSettings.ShowToday Property

CellSettings.ShowToday Property

Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowToday { get; set; }
Visual Basic

Public Property ShowToday As State

Property Value

Specify Enabled to indicate visually the current day; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WinForms Namespace
TodayColor Property
TodayFillColor Property


MindFusion.Scheduling.WinForms.CellSettings.Style Property

CellSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.CellSettings.TodayColor Property

CellSettings.TodayColor Property

Gets or sets the color used to paint the line that marks the current cell.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color TodayColor { get; set; }
Visual Basic

Public Property TodayColor As Color

Property Value

A .NET Color object. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WinForms Namespace
TodayFillColor Property
ShowToday Property


MindFusion.Scheduling.WinForms.CellSettings.TodayFillColor Property

CellSettings.TodayFillColor Property

Gets or sets the color used to fill the header of the current cell.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color TodayFillColor { get; set; }
Visual Basic

Public Property TodayFillColor As Color

Property Value

A .NET Color object. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WinForms Namespace
TodayColor Property
ShowToday Property


MindFusion.Scheduling.WinForms.ContinuePrintingEventArgs Class

ContinuePrintingEventArgs Class

Provides data for the ContinuePrinting event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class ContinuePrintingEventArgs : EventArgs
Visual Basic

Public Class ContinuePrintingEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.WinForms.ContinuePrintingEventArgs

See Also

ContinuePrintingEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ContinuePrintingEventArgs Members

ContinuePrintingEventArgs Members
Properties Methods

Provides data for the ContinuePrinting event.

The following tables list the members exposed by the ContinuePrintingEventArgs type.

Public Properties

Name | Description
Calendar | Gets a reference to the Calendar control being printed.

Public Methods

Name | Description
ContinuePrinting | Call this method if you want the print operation to continue on a new page with the view settings specified in the Calendar control. Call this method only once per event to avoid unnecessary calculations.

See Also

ContinuePrintingEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ContinuePrintingEventArgs Methods

ContinuePrintingEventArgs Methods

Public Methods

Name | Description
ContinuePrinting | Call this method if you want the print operation to continue on a new page with the view settings specified in the Calendar control. Call this method only once per event to avoid unnecessary calculations.

See Also

ContinuePrintingEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ContinuePrintingEventArgs.ContinuePrinting Method

ContinuePrintingEventArgs.ContinuePrinting Method

Call this method if you want the print operation to continue on a new page with the view settings specified in the Calendar control. Call this method only once per event to avoid unnecessary calculations.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void ContinuePrinting ()
Visual Basic

Public Sub ContinuePrinting ()

See Also

ContinuePrintingEventArgs Members
ContinuePrintingEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ContinuePrintingEventArgs Properties

ContinuePrintingEventArgs Properties

Public Properties

Name | Description
Calendar | Gets a reference to the Calendar control being printed.

See Also

ContinuePrintingEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ContinuePrintingEventArgs.Calendar Property

ContinuePrintingEventArgs.Calendar Property

Gets a reference to the Calendar control being printed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Calendar Calendar { get; }
Visual Basic

Public ReadOnly Property Calendar As Calendar

Property Value

An instance of the Calendar class.

See Also

ContinuePrintingEventArgs Members
ContinuePrintingEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlAppearance Enumeration

ControlAppearance Enumeration

Specifies the visual style of the calendar child controls.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum ControlAppearance
Visual Basic

Public Enumeration ControlAppearance

Members

Member name | Description
Custom | Use custom child controls that allow applying MindFusion.Scheduling styles to them.
System | Use the standard controls provided by the .NET framework, such as TextBox, Button and ScrollBar.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle Class

ControlStyle Class

A ControlStyle instance defines the appearance style of calendar child controls, such as buttons and scrollbars.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class ControlStyle
Visual Basic

Public NotInheritable Class ControlStyle

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.ControlStyle

See Also

ControlStyle Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle Members

ControlStyle Members
Properties

A ControlStyle instance defines the appearance style of calendar child controls, such as buttons and scrollbars.

The following tables list the members exposed by the ControlStyle type.

Public Properties

Name | Description
ButtonBorderColor | Gets or sets the color used to draw the buttons border lines.
ButtonFillBrush | Gets or sets the brush used to fill the background of button child controls when they are neither pushed nor the mouse pointer hovers over them.
ButtonFillBrushDown | Gets or sets the brush used to fill the background of button child controls when they are pushed down.
ButtonFillBrushOver | Gets or sets the brush used to fill the background of button child controls when the mouse pointer hovers over them.
HScrollBarBackBrush | Gets or sets the brush used to fill the background of the horizontal scrollbar.
HScrollBarBackBrushDark | Gets or sets the brush used to fill the background of the horizontal scrollbar when a user clicks on the scrollbar shaft in order to scroll a page left or right.
HScrollBarBorderColor | Gets or sets the color used to draw the horizontal scrollbar border lines.
HScrollBarFillBrush | Gets or sets the brush used to fill the elements of the horizontal scrollbar when they are neither pushed nor the mouse pointer hovers over them.
HScrollBarFillBrushDown | Gets or sets the brush used to fill the elements of the horizontal scrollbar when they are pushed down.
HScrollBarFillBrushOver | Gets or sets the brush used to fill the elements of the horizontal scroll bar when the mouse pointer hovers over them.
VScrollBarBackBrush | Gets or sets the brush used to fill the background of the vertical scrollbar.
VScrollBarBackBrushDark | Gets or sets the brush used to fill the background of the vertical scrollbar when a user clicks on the scrollbar shaft in order to scroll a page up or down.
VScrollBarBorderColor | Gets or sets the color used to draw the vertical scrollbar border lines.
VScrollBarFillBrush | Gets or sets the brush used to fill the elements of the vertical scrollbar when they are neither pushed nor the mouse pointer hovers over them.
VScrollBarFillBrushDown | Gets or sets the brush used to fill the elements of the vertical scrollbar when they are pushed down.
VScrollBarFillBrushOver | Gets or sets the brush used to fill the elements of the vertical scroll bar when the mouse pointer hovers over them.

See Also

ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle Properties

ControlStyle Properties

Public Properties

Name | Description
ButtonBorderColor | Gets or sets the color used to draw the buttons border lines.
ButtonFillBrush | Gets or sets the brush used to fill the background of button child controls when they are neither pushed nor the mouse pointer hovers over them.
ButtonFillBrushDown | Gets or sets the brush used to fill the background of button child controls when they are pushed down.
ButtonFillBrushOver | Gets or sets the brush used to fill the background of button child controls when the mouse pointer hovers over them.
HScrollBarBackBrush | Gets or sets the brush used to fill the background of the horizontal scrollbar.
HScrollBarBackBrushDark | Gets or sets the brush used to fill the background of the horizontal scrollbar when a user clicks on the scrollbar shaft in order to scroll a page left or right.
HScrollBarBorderColor | Gets or sets the color used to draw the horizontal scrollbar border lines.
HScrollBarFillBrush | Gets or sets the brush used to fill the elements of the horizontal scrollbar when they are neither pushed nor the mouse pointer hovers over them.
HScrollBarFillBrushDown | Gets or sets the brush used to fill the elements of the horizontal scrollbar when they are pushed down.
HScrollBarFillBrushOver | Gets or sets the brush used to fill the elements of the horizontal scroll bar when the mouse pointer hovers over them.
VScrollBarBackBrush | Gets or sets the brush used to fill the background of the vertical scrollbar.
VScrollBarBackBrushDark | Gets or sets the brush used to fill the background of the vertical scrollbar when a user clicks on the scrollbar shaft in order to scroll a page up or down.
VScrollBarBorderColor | Gets or sets the color used to draw the vertical scrollbar border lines.
VScrollBarFillBrush | Gets or sets the brush used to fill the elements of the vertical scrollbar when they are neither pushed nor the mouse pointer hovers over them.
VScrollBarFillBrushDown | Gets or sets the brush used to fill the elements of the vertical scrollbar when they are pushed down.
VScrollBarFillBrushOver | Gets or sets the brush used to fill the elements of the vertical scroll bar when the mouse pointer hovers over them.

See Also

ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.ButtonBorderColor Property

ControlStyle.ButtonBorderColor Property

Gets or sets the color used to draw the buttons border lines.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color ButtonBorderColor { get; set; }
Visual Basic

Public Property ButtonBorderColor As Color

Property Value

A .NET Color object. To reset this property, set it to Color.Empty.

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.ButtonFillBrush Property

ControlStyle.ButtonFillBrush Property

Gets or sets the brush used to fill the background of button child controls when they are neither pushed nor the mouse pointer hovers over them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush ButtonFillBrush { get; set; }
Visual Basic

Public Property ButtonFillBrush As Brush

Property Value

An instance of the Brush class. To reset this property, set it to null (Nothing in Visual Basic).

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.ButtonFillBrushDown Property

ControlStyle.ButtonFillBrushDown Property

Gets or sets the brush used to fill the background of button child controls when they are pushed down.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush ButtonFillBrushDown { get; set; }
Visual Basic

Public Property ButtonFillBrushDown As Brush

Property Value

An instance of the Brush class. To reset this property, set it to null (Nothing in Visual Basic).

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.ButtonFillBrushOver Property

ControlStyle.ButtonFillBrushOver Property

Gets or sets the brush used to fill the background of button child controls when the mouse pointer hovers over them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush ButtonFillBrushOver { get; set; }
Visual Basic

Public Property ButtonFillBrushOver As Brush

Property Value

An instance of the Brush class. To reset this property, set it to null (Nothing in Visual Basic).

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.HScrollBarBackBrush Property

ControlStyle.HScrollBarBackBrush Property

Gets or sets the brush used to fill the background of the horizontal scrollbar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush HScrollBarBackBrush { get; set; }
Visual Basic

Public Property HScrollBarBackBrush As Brush

Property Value

An instance of the Brush class. To reset this property, set it to null (Nothing in Visual Basic).

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.HScrollBarBackBrushDark Property

ControlStyle.HScrollBarBackBrushDark Property

Gets or sets the brush used to fill the background of the horizontal scrollbar when a user clicks on the scrollbar shaft in order to scroll a page left or right.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush HScrollBarBackBrushDark { get; set; }
Visual Basic

Public Property HScrollBarBackBrushDark As Brush

Property Value

An instance of the Brush class. To reset this property, set it to null (Nothing in Visual Basic).

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.HScrollBarBorderColor Property

ControlStyle.HScrollBarBorderColor Property

Gets or sets the color used to draw the horizontal scrollbar border lines.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color HScrollBarBorderColor { get; set; }
Visual Basic

Public Property HScrollBarBorderColor As Color

Property Value

A .NET Color object. To reset this property, set it to Color.Empty.

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.HScrollBarFillBrush Property

ControlStyle.HScrollBarFillBrush Property

Gets or sets the brush used to fill the elements of the horizontal scrollbar when they are neither pushed nor the mouse pointer hovers over them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush HScrollBarFillBrush { get; set; }
Visual Basic

Public Property HScrollBarFillBrush As Brush

Property Value

An instance of the Brush class. To reset this property, set it to null (Nothing in Visual Basic).

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.HScrollBarFillBrushDown Property

ControlStyle.HScrollBarFillBrushDown Property

Gets or sets the brush used to fill the elements of the horizontal scrollbar when they are pushed down.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush HScrollBarFillBrushDown { get; set; }
Visual Basic

Public Property HScrollBarFillBrushDown As Brush

Property Value

An instance of the Brush class. To reset this property, set it to null (Nothing in Visual Basic).

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.HScrollBarFillBrushOver Property

ControlStyle.HScrollBarFillBrushOver Property

Gets or sets the brush used to fill the elements of the horizontal scroll bar when the mouse pointer hovers over them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush HScrollBarFillBrushOver { get; set; }
Visual Basic

Public Property HScrollBarFillBrushOver As Brush

Property Value

An instance of the Brush class. To reset this property, set it to null (Nothing in Visual Basic).

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.VScrollBarBackBrush Property

ControlStyle.VScrollBarBackBrush Property

Gets or sets the brush used to fill the background of the vertical scrollbar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush VScrollBarBackBrush { get; set; }
Visual Basic

Public Property VScrollBarBackBrush As Brush

Property Value

An instance of the Brush class. To reset this property, set it to null (Nothing in Visual Basic).

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.VScrollBarBackBrushDark Property

ControlStyle.VScrollBarBackBrushDark Property

Gets or sets the brush used to fill the background of the vertical scrollbar when a user clicks on the scrollbar shaft in order to scroll a page up or down.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush VScrollBarBackBrushDark { get; set; }
Visual Basic

Public Property VScrollBarBackBrushDark As Brush

Property Value

An instance of the Brush class. To reset this property, set it to null (Nothing in Visual Basic).

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.VScrollBarBorderColor Property

ControlStyle.VScrollBarBorderColor Property

Gets or sets the color used to draw the vertical scrollbar border lines.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color VScrollBarBorderColor { get; set; }
Visual Basic

Public Property VScrollBarBorderColor As Color

Property Value

A .NET Color object. To reset this property, set it to Color.Empty.

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.VScrollBarFillBrush Property

ControlStyle.VScrollBarFillBrush Property

Gets or sets the brush used to fill the elements of the vertical scrollbar when they are neither pushed nor the mouse pointer hovers over them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush VScrollBarFillBrush { get; set; }
Visual Basic

Public Property VScrollBarFillBrush As Brush

Property Value

An instance of the Brush class. To reset this property, set it to null (Nothing in Visual Basic).

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.VScrollBarFillBrushDown Property

ControlStyle.VScrollBarFillBrushDown Property

Gets or sets the brush used to fill the elements of the vertical scrollbar when they are pushed down.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush VScrollBarFillBrushDown { get; set; }
Visual Basic

Public Property VScrollBarFillBrushDown As Brush

Property Value

An instance of the Brush class. To reset this property, set it to null (Nothing in Visual Basic).

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ControlStyle.VScrollBarFillBrushOver Property

ControlStyle.VScrollBarFillBrushOver Property

Gets or sets the brush used to fill the elements of the vertical scroll bar when the mouse pointer hovers over them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush VScrollBarFillBrushOver { get; set; }
Visual Basic

Public Property VScrollBarFillBrushOver As Brush

Property Value

An instance of the Brush class. To reset this property, set it to null (Nothing in Visual Basic).

See Also

ControlStyle Members
ControlStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.CustomDrawElements Enumeration

CustomDrawElements Enumeration

Specifies which elements of the calendar are custom-drawn.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum CustomDrawElements
Visual Basic

Public Enumeration CustomDrawElements

Members

Member name | Description
All | All elements.
CalendarItem | An all day item in a Timetable view, or an item in any other view.
CellContents | The contents of a single cell.
CellHeader | The header of a single cell.
ListViewHeader | The header of a List view.
ListViewHeaderCell | A cell in the header of a List view.
ListViewSubHeader | A subheader of a List view.
ListViewSubHeaderCell | A cell in a subheader of a List view.
MonthContents | The contents of a month cell.
MonthMainHeader | A month main header in MonthRange or SingleMonth view.
MonthRangeHeader | The header in a MonthRange view.
MonthSubHeader | The day of week header in MonthRange or SingleMonth view.
MonthSubHeaderCell | A cell in the day of week header in MonthRange or SingleMonth view.
MonthWeekNumbersHeader | The week numbers header in MonthRange or SingleMonth view.
MonthWeekNumbersHeaderCell | A cell in the week numbers header in MonthRange or SingleMonth view.
None | Do not use custom drawing.
ResourceViewCell | A cell in a Resource view. If the view style is Lanes this enumeration value indicates a cell in each individual lane.
ResourceViewCellComplete | A cell in a Resource view. If the view style is Lanes this enumeration value indicates a cell that encompasses all lanes for the associated Resource.
ResourceViewItem | An item in a Resource view.
ResourceViewRowHeader | The header of a Resource view row.
ResourceViewTimeline | A timeline of a Resource view.
ResourceViewTimelineCell | A cell of a timeline in a Resource view.
TimetableItem | A non all-day item in a Timetable view. For all-day items, the CalendarItem value is specified.
TimetableCell | A cell in a Timetable view.
TimetableColumnHeader | A column header in a Timetable view.
TimetableGroupHeader | The group header in a Timetable view.
TimetableGroupHeaderCell | A cell of the group header in a Timetable view.
TimetableInfoHeader | The timetable info header. Occurs for each column in the view.
TimetableTimeline | The timeline in a Timetable view. Occurs before the timeline divisions are painted.
TimetableTimelineCell | A portion of the timeline in a Timetable view.
TimetableTimelineHourCell | An hour cell of the timeline in a Timetable view.
TimetableWholeDayHeader | A whole day portion of the header in a Timetable view. Occurs for each column in the view.
WeekRangeHeader | The header in a WeekRange view.
WeekRangeResourceHeader | The reference header in a WeekRange view.
WeekRangeSubHeader | The day of week header in a WeekRange view.
WeekRangeSubHeaderCell | A cell in the day of week header in a WeekRange view.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateChangedEventArgs Class

DateChangedEventArgs Class

Contains the arguments passed to handlers of the VisibleDateChanged event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class DateChangedEventArgs : EventArgs
Visual Basic

Public Class DateChangedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.WinForms.DateChangedEventArgs

See Also

DateChangedEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateChangedEventArgs Members

DateChangedEventArgs Members
Properties

Contains the arguments passed to handlers of the VisibleDateChanged event.

The following tables list the members exposed by the DateChangedEventArgs type.

Public Properties

Name | Description
NewDate | Gets the new visible date.
PreviousDate | Gets the previous visible date.

See Also

DateChangedEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateChangedEventArgs Properties

DateChangedEventArgs Properties

Public Properties

Name | Description
NewDate | Gets the new visible date.
PreviousDate | Gets the previous visible date.

See Also

DateChangedEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateChangedEventArgs.NewDate Property

DateChangedEventArgs.NewDate Property

Gets the new visible date.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime NewDate { get; }
Visual Basic

Public ReadOnly Property NewDate As DateTime

Property Value

A .NET DateTime object specifying the new date related to the raised event.

See Also

DateChangedEventArgs Members
DateChangedEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateChangedEventArgs.PreviousDate Property

DateChangedEventArgs.PreviousDate Property

Gets the previous visible date.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime PreviousDate { get; }
Visual Basic

Public ReadOnly Property PreviousDate As DateTime

Property Value

A .NET DateTime object specifying the previous date related to the raised event.

See Also

DateChangedEventArgs Members
DateChangedEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection Class

DateCollection Class

Represents a strongly-typed sorted collection of DateTime objects.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class DateCollection : CollectionBase
Visual Basic

Public NotInheritable Class DateCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.WinForms.DateCollection

See Also

DateCollection Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection Members

DateCollection Members
Constructors Properties Methods

Represents a strongly-typed sorted collection of DateTime objects.

The following tables list the members exposed by the DateCollection type.

Public Constructors

Name | Description
DateCollection | Initializes a new instance of the DateCollection class.

Public Properties

Name | Description
Item | Gets or sets the DateTime located at the specified position within this collection.

Public Methods

Name | Description
Add | Adds the specified DateTime object to this collection.
Clear | Removes all elements from the collection.
Contains | Determines whether this collection contains the specified DateTime instance.
CopyTo | Copies the elements of the DateCollection to another collection, starting from the specified index.
IndexOf | Returns the zero-based index of the first occurrence of the specified DateTime object in this collection.
Insert | Inserts a DateTime object into the collection at the specified index.
Remove | Removes the first occurrence of a DateTime object from this collection.
RemoveAt | Removes the DateTime object at the specified index of this collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.
OnSetComplete | CollectionBase.OnSetComplete override.

See Also

DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection Constructor

DateCollection Constructor

Initializes a new instance of the DateCollection class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateCollection ()
Visual Basic

Public Sub New ()

See Also

DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection Methods

DateCollection Methods

Public Methods

Name | Description
Add | Adds the specified DateTime object to this collection.
Clear | Removes all elements from the collection.
Contains | Determines whether this collection contains the specified DateTime instance.
CopyTo | Copies the elements of the DateCollection to another collection, starting from the specified index.
IndexOf | Returns the zero-based index of the first occurrence of the specified DateTime object in this collection.
Insert | Inserts a DateTime object into the collection at the specified index.
Remove | Removes the first occurrence of a DateTime object from this collection.
RemoveAt | Removes the DateTime object at the specified index of this collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.
OnSetComplete | CollectionBase.OnSetComplete override.

See Also

DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection.Add Method

DateCollection.Add Method

Adds the specified DateTime object to this collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Add (
DateTime date
)
Visual Basic

Public Sub Add ( _
date As DateTime _
)

Parameters

date
A DateTime instance to be added to the collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection.Clear Method

DateCollection.Clear Method

Removes all elements from the collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection.Contains Method

DateCollection.Contains Method

Determines whether this collection contains the specified DateTime instance.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
DateTime date
)
Visual Basic

Public Function Contains ( _
date As DateTime _
) As Boolean

Parameters

date
The DateTime object to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection.CopyTo Method

DateCollection.CopyTo Method

Copies the elements of the DateCollection to another collection, starting from the specified index.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void CopyTo (
DateCollection collection,
int index
)
Visual Basic

Public Sub CopyTo ( _
collection As DateCollection, _
index As Integer _
)

Parameters

collection
The target collection to which items should be copied.
index
Specifies the index at which items should be inserted in the target collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection.IndexOf Method

DateCollection.IndexOf Method

Returns the zero-based index of the first occurrence of the specified DateTime object in this collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int IndexOf (
DateTime date
)
Visual Basic

Public Function IndexOf ( _
date As DateTime _
) As Integer

Parameters

date
The DateTime to locate in the collection.

Return Value

The zero-based index of the first occurrence of the element within the collection if found; otherwise, -1.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection.Insert Method

DateCollection.Insert Method

Inserts a DateTime object into the collection at the specified index.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Insert (
int index,
DateTime date
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
date As DateTime _
)

Parameters

index
Specifies the position at which the DateTime must be inserted.
date
A DateTime instance to be added to the collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection.OnClearComplete Method

DateCollection.OnClearComplete Method

CollectionBase.OnClearComplete override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnClearComplete ()
Visual Basic

Protected Overridable Sub OnClearComplete ()

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection.OnInsertComplete Method

DateCollection.OnInsertComplete Method

CollectionBase.OnInsertComplete override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnInsertComplete (
int index,
Object value
)
Visual Basic

Protected Overridable Sub OnInsertComplete ( _
index As Integer, _
value As Object _
)

Parameters

index
The zero-based index where the item was inserted.
value
The inserted item.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection.OnRemoveComplete Method

DateCollection.OnRemoveComplete Method

CollectionBase.OnRemoveComplete override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnRemoveComplete (
int index,
Object value
)
Visual Basic

Protected Overridable Sub OnRemoveComplete ( _
index As Integer, _
value As Object _
)

Parameters

index

The zero-based index at which value can be found.

value
The value of the element to remove from index.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection.OnSetComplete Method

DateCollection.OnSetComplete Method

CollectionBase.OnSetComplete override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnSetComplete (
int index,
Object oldValue,
Object newValue
)
Visual Basic

Protected Overridable Sub OnSetComplete ( _
index As Integer, _
oldValue As Object, _
newValue As Object _
)

Parameters

index
The zero-based index at which oldValue can be found.
oldValue

The value to replace with newValue.

newValue
The new value of the element at index.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection.Remove Method

DateCollection.Remove Method

Removes the first occurrence of a DateTime object from this collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Remove (
DateTime date
)
Visual Basic

Public Sub Remove ( _
date As DateTime _
)

Parameters

date
A DateTime instance which must be removed from the collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection.RemoveAt Method

DateCollection.RemoveAt Method

Removes the DateTime object at the specified index of this collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public new void RemoveAt (
int index
)
Visual Basic

Public Shadows Sub RemoveAt ( _
index As Integer _
)

Parameters

index
The zero-based index of the DateTime object to remove.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection Properties

DateCollection Properties

Public Properties

Name | Description
Item | Gets or sets the DateTime located at the specified position within this collection.

See Also

DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateCollection.Item Property

DateCollection.Item Property

Gets or sets the DateTime located at the specified position within this collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As DateTime

Parameters

index
The zero-based index of the DateTime object to set or retrieve.

Property Value

A DateTime instance located at the specified index within this collection.

Remarks

This indexer property allows using the C# [] or VB.NET () operators to access elements of this collection by their integer index.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateEventArgs Class

DateEventArgs Class

Contains the arguments passed to handlers of mouse events related to date and time cells in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class DateEventArgs : EventArgs
Visual Basic

Public Class DateEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.WinForms.DateEventArgs
MindFusion.Scheduling.WinForms.ResourceDateEventArgs

See Also

DateEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateEventArgs Members

DateEventArgs Members
Properties

Contains the arguments passed to handlers of mouse events related to date and time cells in the calendar.

The following tables list the members exposed by the DateEventArgs type.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the clicked date cell.
Button | Gets the pressed mouse button.
Clicks | Gets the number of clicks.
Date | Gets the date and time associated with the event.
Index | Gets the index (if any) of the calendar cell related to the event or -1 otherwise.

See Also

DateEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateEventArgs Properties

DateEventArgs Properties

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the clicked date cell.
Button | Gets the pressed mouse button.
Clicks | Gets the number of clicks.
Date | Gets the date and time associated with the event.
Index | Gets the index (if any) of the calendar cell related to the event or -1 otherwise.

See Also

DateEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateEventArgs.Bounds Property

DateEventArgs.Bounds Property

Gets the bounding rectangle of the clicked date cell.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Rectangle Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As Rectangle

Property Value

A .NET Rectangle object specifying the bounds of the cell related to the raised event.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateEventArgs.Button Property

DateEventArgs.Button Property

Gets the pressed mouse button.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public MouseButtons Button { get; }
Visual Basic

Public ReadOnly Property Button As MouseButtons

Property Value

A member of the .NET MouseButtons enumeration specifying what mouse button was pressed.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateEventArgs.Clicks Property

DateEventArgs.Clicks Property

Gets the number of clicks.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Clicks { get; }
Visual Basic

Public ReadOnly Property Clicks As Integer

Property Value

An integer value specifying the number of clicks related to the raised event.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateEventArgs.Date Property

DateEventArgs.Date Property

Gets the date and time associated with the event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime Date { get; }
Visual Basic

Public ReadOnly Property Date As DateTime

Property Value

A .NET DateTime object specifying the date related to the raised event.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateEventArgs.Index Property

DateEventArgs.Index Property

Gets the index (if any) of the calendar cell related to the event or -1 otherwise.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Index { get; }
Visual Basic

Public ReadOnly Property Index As Integer

Property Value

An integer value specifying the index of the related cell or -1 if no index is applicable to the selected cell.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyle Class

DateStyle Class

Defines formatting for a range of dates. Can be used either to format either days or months.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class DateStyle
Visual Basic

Public Class DateStyle

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.DateStyle

See Also

DateStyle Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyle Members

DateStyle Members
Constructors Properties

Defines formatting for a range of dates. Can be used either to format either days or months.

The following tables list the members exposed by the DateStyle type.

Public Constructors

Name | Description
DateStyle | Initializes a new instance of the DateStyle class. Both the start and end dates are set to the current date.

Public Properties

Name | Description
AllowItems | Gets or sets a value indicating whether the date cells in this range allow items to be placed or created in them interactively.
AllowSelect | Gets or sets a value indicating whether the date cells in this range can be selected.
From | Gets or sets the start date of the formatted range.
Priority | Gets or sets the format priority. If one date has several styles applied to it, only the highest in priority is taken into account.
Style | Gets or sets the visualization style of the date cells included in the formatted range.
To | Gets or sets the end date of the formatted range.

See Also

DateStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyle Constructor

DateStyle Constructor

Initializes a new instance of the DateStyle class. Both the start and end dates are set to the current date.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateStyle ()
Visual Basic

Public Sub New ()

See Also

DateStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyle Properties

DateStyle Properties

Public Properties

Name | Description
AllowItems | Gets or sets a value indicating whether the date cells in this range allow items to be placed or created in them interactively.
AllowSelect | Gets or sets a value indicating whether the date cells in this range can be selected.
From | Gets or sets the start date of the formatted range.
Priority | Gets or sets the format priority. If one date has several styles applied to it, only the highest in priority is taken into account.
Style | Gets or sets the visualization style of the date cells included in the formatted range.
To | Gets or sets the end date of the formatted range.

See Also

DateStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyle.AllowItems Property

DateStyle.AllowItems Property

Gets or sets a value indicating whether the date cells in this range allow items to be placed or created in them interactively.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool AllowItems { get; set; }
Visual Basic

Public Property AllowItems As Boolean

Property Value

true to let users place schedule items in the specified cells; otherwise, false. The default is false.

See Also

DateStyle Members
DateStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyle.AllowSelect Property

DateStyle.AllowSelect Property

Gets or sets a value indicating whether the date cells in this range can be selected.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool AllowSelect { get; set; }
Visual Basic

Public Property AllowSelect As Boolean

Property Value

true to let users select the date cells; otherwise, false. The default is true.

See Also

DateStyle Members
DateStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyle.From Property

DateStyle.From Property

Gets or sets the start date of the formatted range.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime From { get; set; }
Visual Basic

Public Property From As DateTime

Property Value

A .NET DateTime object specifying the start of the time interval whose cells' style is defined in this object.

See Also

DateStyle Members
DateStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyle.Priority Property

DateStyle.Priority Property

Gets or sets the format priority. If one date has several styles applied to it, only the highest in priority is taken into account.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Priority { get; set; }
Visual Basic

Public Property Priority As Integer

Property Value

An integer value specifying the priority of this style.

Remarks

When a time cell is included in the time intervals of several DateStyle or DayOfWeekStyle objects, the style that has the highest priority is used.

Example

Note

If you want the overlapping styles for a single date to cascade, you have to specify different priorities for them.

The following example illustrates how to create overlapping DateStyle objects for a specific date in a SingleMonth view. The example creates two date styles - one for the time range 03/15 - 03/20 and another for the time range 03/18 - 03/24. The two styles have different priorities to allow cascading. If both styles have had the same priorities, only the second style would have been used for the dates in the overlapped range (03/18 - 03/20).

C#

DateStyle style1 = new DateStyle();
style1.From = new DateTime(2006, 3, 15);
style1.To = new DateTime(2006, 3, 20);
style1.Style = new Style();
style1.Style.BorderLeftWidth = 2;
style1.Style.BorderTopWidth = 2;
style1.Style.BorderRightWidth = 2;
style1.Style.BorderBottomWidth = 2;
style1.Priority = 1;
calendar.DayStyles.Add(style1);

DateStyle style2 = new DateStyle();
style2.From = new DateTime(2006, 3, 18);
style2.To = new DateTime(2006, 3, 24);
style2.Style = new Style();
style2.Style.Brush = new MindFusion.Drawing.SolidBrush(Color.PaleGoldenrod);
style2.Priority = 2;
calendar.DayStyles.Add(style2);
Visual Basic

Dim style1 As New DateStyle()
style1.From = New DateTime(2006, 3, 15)
style1.To = New DateTime(2006, 3, 20)
style1.Style = New Style()
style1.Style.BorderLeftWidth = 2
style1.Style.BorderTopWidth = 2
style1.Style.BorderRightWidth = 2
style1.Style.BorderBottomWidth = 2
style1.Priority = 1
calendar.DayStyles.Add(style1)

Dim style2 As New DateStyle()
style2.From = New DateTime(2006, 3, 18)
style2.To = New DateTime(2006, 3, 24)
style2.Style = New Style()
style2.Style.Brush = New MindFusion.Drawing.SolidBrush(Color.PaleGoldenrod)
style2.Priority = 2
calendar.DayStyles.Add(style2)

See Also

DateStyle Members
DateStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyle.Style Property

DateStyle.Style Property

Gets or sets the visualization style of the date cells included in the formatted range.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style Style { get; set; }
Visual Basic

Public Property Style As Style

Property Value

A Style object that defines the appearance of time cells included in the specified interval.

Remarks

Only the properties in this Style object that have been explicitly set would be used. See the example section below for more detail.

Example

The following example creates a custom style for the dates in the range 03/20 - 03/24. The style changes only the border color and the border width of the cells in the specified range. The values of all other properties are retrieved from the default settings, because they are never explicitly set in this custom style.

C#

DateStyle style = new DateStyle();
style.From = new DateTime(2006, 3, 20);
style.To = new DateTime(2006, 3, 24);
style.Style = new Style();
style.Style.BorderLeftColor = Color.LightBlue;
style.Style.BorderLeftWidth = 1;
style.Style.BorderTopColor = Color.LightBlue;
style.Style.BorderTopWidth = 1;
style.Style.BorderRightColor = Color.SteelBlue;
style.Style.BorderRightWidth = 1;
style.Style.BorderBottomColor = Color.SteelBlue;
style.Style.BorderBottomWidth = 1;
calendar.DayStyles.Add(style);
Visual Basic

Dim style As New DateStyle()
style.From = New DateTime(2006, 3, 20)
style.To = New DateTime(2006, 3, 24)
style.Style = New Style()
style.Style.BorderLeftColor = Color.LightBlue
style.Style.BorderLeftWidth = 1
style.Style.BorderTopColor = Color.LightBlue
style.Style.BorderTopWidth = 1
style.Style.BorderRightColor = Color.SteelBlue
style.Style.BorderRightWidth = 1
style.Style.BorderBottomColor = Color.SteelBlue
style.Style.BorderBottomWidth = 1
calendar.DayStyles.Add(style)

See Also

DateStyle Members
DateStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyle.To Property

DateStyle.To Property

Gets or sets the end date of the formatted range.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime To { get; set; }
Visual Basic

Public Property To As DateTime

Property Value

A .NET DateTime object specifying the end of the time interval whose cells' style is defined in this object.

See Also

DateStyle Members
DateStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection Class

DateStyleCollection Class

Represents a strongly-typed collection of DateStyle objects.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class DateStyleCollection : CollectionBase
Visual Basic

Public Class DateStyleCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.WinForms.DateStyleCollection

See Also

DateStyleCollection Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection Members

DateStyleCollection Members
Constructors Properties Methods

Represents a strongly-typed collection of DateStyle objects.

The following tables list the members exposed by the DateStyleCollection type.

Public Constructors

Name | Description
DateStyleCollection | Initializes a new instance of the DateStyleCollection class.

Public Properties

Name | Description
Item | Gets or sets the DateStyle located at the specified position within this collection.

Public Methods

Name | Description
Add | Adds the specified DateStyle object to this collection.
Contains | Determines whether this collection contains the specified DateStyle instance.
CopyTo | Copies the elements of the DateStyleCollection to another collection, starting from a particular index.
IndexOf | Returns the zero-based index of the first occurrence of a DateStyle object in this collection.
Insert | Inserts the specified DateStyle object at the specified position within the collection.
Remove | Removes the first occurrence of the specified DateStyle object from this collection.

See Also

DateStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection Constructor

DateStyleCollection Constructor

Initializes a new instance of the DateStyleCollection class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateStyleCollection ()
Visual Basic

Public Sub New ()

See Also

DateStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection Methods

DateStyleCollection Methods

Public Methods

Name | Description
Add | Adds the specified DateStyle object to this collection.
Contains | Determines whether this collection contains the specified DateStyle instance.
CopyTo | Copies the elements of the DateStyleCollection to another collection, starting from a particular index.
IndexOf | Returns the zero-based index of the first occurrence of a DateStyle object in this collection.
Insert | Inserts the specified DateStyle object at the specified position within the collection.
Remove | Removes the first occurrence of the specified DateStyle object from this collection.

See Also

DateStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.Add Method

DateStyleCollection.Add Method

Adds the specified DateStyle object to this collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Add (
DateStyle style
)
Visual Basic

Public Sub Add ( _
style As DateStyle _
)

Parameters

style
A DateStyle instance to be added to the collection.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.Contains Method

DateStyleCollection.Contains Method

Determines whether this collection contains the specified DateStyle instance.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
DateStyle style
)
Visual Basic

Public Function Contains ( _
style As DateStyle _
) As Boolean

Parameters

style
The DateStyle value to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.CopyTo Method

DateStyleCollection.CopyTo Method

Copies the elements of the DateStyleCollection to another collection, starting from a particular index.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void CopyTo (
DateStyleCollection collection,
int index
)
Visual Basic

Public Sub CopyTo ( _
collection As DateStyleCollection, _
index As Integer _
)

Parameters

collection
The target collection to which items should be copied.
index
Specifies the index at which items should be inserted in the target collection.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.IndexOf Method

DateStyleCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a DateStyle object in this collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int IndexOf (
DateStyle style
)
Visual Basic

Public Function IndexOf ( _
style As DateStyle _
) As Integer

Parameters

style
The DateStyle to locate in the collection.

Return Value

The zero-based index of the first occurrence of the element within the collection if found; otherwise, -1.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.Insert Method

DateStyleCollection.Insert Method

Inserts the specified DateStyle object at the specified position within the collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Insert (
int index,
DateStyle style
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
style As DateStyle _
)

Parameters

index
Specifies the position at which the DateStyle must be inserted.
style
A DateStyle instance to be added to the collection.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.Remove Method

DateStyleCollection.Remove Method

Removes the first occurrence of the specified DateStyle object from this collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Remove (
DateStyle style
)
Visual Basic

Public Sub Remove ( _
style As DateStyle _
)

Parameters

style
A DateStyle instance which must be removed from the collection.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection Properties

DateStyleCollection Properties

Public Properties

Name | Description
Item | Gets or sets the DateStyle located at the specified position within this collection.

See Also

DateStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.Item Property

DateStyleCollection.Item Property

Gets or sets the DateStyle located at the specified position within this collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateStyle Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As DateStyle

Parameters

index
The zero-based index of the DateStyle object to set or retrieve.

Property Value

An instance of the DateStyle class located at the specified index within this collection.

Remarks

This indexer property allows using the C# [] or VB.NET () operators to access elements of this collection by their integer index.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekFormat Enumeration

DayOfWeekFormat Enumeration

Specifies the display format of a day of the week.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum DayOfWeekFormat
Visual Basic

Public Enumeration DayOfWeekFormat

Members

Member name | Description
Abbreviated | The first three letters of the day of the week are displayed.
Full | The complete name of the day of the week is displayed.
SingleLetter | Only the first letter of the name of the day is displayed.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle Class

DayOfWeekStyle Class

An instance of this class defines how a day of the week should be displayed and formatted.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class DayOfWeekStyle
Visual Basic

Public Class DayOfWeekStyle

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.DayOfWeekStyle

See Also

DayOfWeekStyle Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle Members

DayOfWeekStyle Members
Constructors Properties

An instance of this class defines how a day of the week should be displayed and formatted.

The following tables list the members exposed by the DayOfWeekStyle type.

Public Constructors

Name | Description
DayOfWeekStyle | Initializes a new instance of the DayOfWeekStyle class.

Public Properties

Name | Description
AllowItems | Gets or sets a value indicating whether the calendar cell for the specified day allows items to be placed or created in it interactively.
AllowSelect | Gets or sets a value indicating whether the specified day of the week can be selected.
DayOfWeek | Gets or sets the day of the week to which this DayOfWeekStyle object is assigned.
Priority | Gets or sets the style priority. If one date has several styles applied to it, only the highest in priority is taken into account.
Style | Gets or sets the visualization style of the specified day.

See Also

DayOfWeekStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle Constructor

DayOfWeekStyle Constructor

Initializes a new instance of the DayOfWeekStyle class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DayOfWeekStyle ()
Visual Basic

Public Sub New ()

See Also

DayOfWeekStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle Properties

DayOfWeekStyle Properties

Public Properties

Name | Description
AllowItems | Gets or sets a value indicating whether the calendar cell for the specified day allows items to be placed or created in it interactively.
AllowSelect | Gets or sets a value indicating whether the specified day of the week can be selected.
DayOfWeek | Gets or sets the day of the week to which this DayOfWeekStyle object is assigned.
Priority | Gets or sets the style priority. If one date has several styles applied to it, only the highest in priority is taken into account.
Style | Gets or sets the visualization style of the specified day.

See Also

DayOfWeekStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle.AllowItems Property

DayOfWeekStyle.AllowItems Property

Gets or sets a value indicating whether the calendar cell for the specified day allows items to be placed or created in it interactively.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool AllowItems { get; set; }
Visual Basic

Public Property AllowItems As Boolean

Property Value

true to let users place schedule items in the specified cells; otherwise, false. The default is false.

See Also

DayOfWeekStyle Members
DayOfWeekStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle.AllowSelect Property

DayOfWeekStyle.AllowSelect Property

Gets or sets a value indicating whether the specified day of the week can be selected.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool AllowSelect { get; set; }
Visual Basic

Public Property AllowSelect As Boolean

Property Value

true to let users select the date cells; otherwise, false. The default is true.

See Also

DayOfWeekStyle Members
DayOfWeekStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle.DayOfWeek Property

DayOfWeekStyle.DayOfWeek Property

Gets or sets the day of the week to which this DayOfWeekStyle object is assigned.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DayOfWeek DayOfWeek { get; set; }
Visual Basic

Public Property DayOfWeek As DayOfWeek

Property Value

A member of the .NET DayOfWeek enumeration. The default is Sunday.

See Also

DayOfWeekStyle Members
DayOfWeekStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle.Priority Property

DayOfWeekStyle.Priority Property

Gets or sets the style priority. If one date has several styles applied to it, only the highest in priority is taken into account.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Priority { get; set; }
Visual Basic

Public Property Priority As Integer

Property Value

An integer value specifying the priority of this style.

Remarks

When a time cell is included in the time intervals of several DateStyle or DayOfWeekStyle objects, the style that has the highest priority is used.

See Also

DayOfWeekStyle Members
DayOfWeekStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle.Style Property

DayOfWeekStyle.Style Property

Gets or sets the visualization style of the specified day.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style Style { get; set; }
Visual Basic

Public Property Style As Style

Property Value

A Style object that defines the appearance of time cells included in the specified interval.

See Also

DayOfWeekStyle Members
DayOfWeekStyle Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection Class

DayOfWeekStyleCollection Class

Represents a strongly-typed collection of DayOfWeekStyle objects.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class DayOfWeekStyleCollection : CollectionBase
Visual Basic

Public Class DayOfWeekStyleCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection

See Also

DayOfWeekStyleCollection Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection Members

DayOfWeekStyleCollection Members
Constructors Properties Methods

Represents a strongly-typed collection of DayOfWeekStyle objects.

The following tables list the members exposed by the DayOfWeekStyleCollection type.

Public Constructors

Name | Description
DayOfWeekStyleCollection | Initializes a new instance of the DayOfWeekStyleCollection class.

Public Properties

Name | Description
Item | Gets or sets the DayOfWeekStyle located at the specified index within this collection.

Public Methods

Name | Description
Add | Adds the specified DayOfWeekStyle object to this collection.
Contains | Determines whether this collection contains the specified DayOfWeekStyle instance.
CopyTo | Copies the elements of the DayOfWeekStyleCollection to another collection, starting from a particular index.
IndexOf | Returns the zero-based index of the first occurrence of a DayOfWeekStyle object in this collection.
Insert | Inserts the specified DayOfWeekStyle object at the specified position within the collection.
Remove | Removes the first occurrence of the specified DayOfWeekStyle object from this collection.

See Also

DayOfWeekStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection Constructor

DayOfWeekStyleCollection Constructor

Initializes a new instance of the DayOfWeekStyleCollection class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DayOfWeekStyleCollection ()
Visual Basic

Public Sub New ()

See Also

DayOfWeekStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection Methods

DayOfWeekStyleCollection Methods

Public Methods

Name | Description
Add | Adds the specified DayOfWeekStyle object to this collection.
Contains | Determines whether this collection contains the specified DayOfWeekStyle instance.
CopyTo | Copies the elements of the DayOfWeekStyleCollection to another collection, starting from a particular index.
IndexOf | Returns the zero-based index of the first occurrence of a DayOfWeekStyle object in this collection.
Insert | Inserts the specified DayOfWeekStyle object at the specified position within the collection.
Remove | Removes the first occurrence of the specified DayOfWeekStyle object from this collection.

See Also

DayOfWeekStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.Add Method

DayOfWeekStyleCollection.Add Method

Adds the specified DayOfWeekStyle object to this collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Add (
DayOfWeekStyle style
)
Visual Basic

Public Sub Add ( _
style As DayOfWeekStyle _
)

Parameters

style
A DayOfWeekStyle instance to be added to the collection.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.Contains Method

DayOfWeekStyleCollection.Contains Method

Determines whether this collection contains the specified DayOfWeekStyle instance.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
DayOfWeekStyle style
)
Visual Basic

Public Function Contains ( _
style As DayOfWeekStyle _
) As Boolean

Parameters

style
The DayOfWeekStyle value to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.CopyTo Method

DayOfWeekStyleCollection.CopyTo Method

Copies the elements of the DayOfWeekStyleCollection to another collection, starting from a particular index.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void CopyTo (
DayOfWeekStyleCollection collection,
int index
)
Visual Basic

Public Sub CopyTo ( _
collection As DayOfWeekStyleCollection, _
index As Integer _
)

Parameters

collection
The target collection to which items should be copied.
index
Specifies the index at which items should be inserted in the target collection.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.IndexOf Method

DayOfWeekStyleCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a DayOfWeekStyle object in this collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int IndexOf (
DayOfWeekStyle style
)
Visual Basic

Public Function IndexOf ( _
style As DayOfWeekStyle _
) As Integer

Parameters

style
The DayOfWeekStyle to locate in the collection.

Return Value

The zero-based index of the first occurrence of the element within the collection if found; otherwise, -1.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.Insert Method

DayOfWeekStyleCollection.Insert Method

Inserts the specified DayOfWeekStyle object at the specified position within the collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Insert (
int index,
DayOfWeekStyle style
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
style As DayOfWeekStyle _
)

Parameters

index
Specifies the position at which the DayOfWeekStyle must be inserted.
style
A DayOfWeekStyle instance to be added to the collection.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.Remove Method

DayOfWeekStyleCollection.Remove Method

Removes the first occurrence of the specified DayOfWeekStyle object from this collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Remove (
DayOfWeekStyle style
)
Visual Basic

Public Sub Remove ( _
style As DayOfWeekStyle _
)

Parameters

style
A DayOfWeekStyle instance which must be removed from the collection.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection Properties

DayOfWeekStyleCollection Properties

Public Properties

Name | Description
Item | Gets or sets the DayOfWeekStyle located at the specified index within this collection.

See Also

DayOfWeekStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.Item Property

DayOfWeekStyleCollection.Item Property

Gets or sets the DayOfWeekStyle located at the specified index within this collection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DayOfWeekStyle Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As DayOfWeekStyle

Parameters

index
The zero-based index of the DayOfWeekStyle object to set or retrieve.

Property Value

A DayOfWeekStyle instance located at the specified index within this collection.

Remarks

This indexer property allows using the C# [] or VB.NET () operators to access elements of this collection by their integer index.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs Class

DrawEventArgs Class

Contains the arguments passed to handlers of the Draw event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class DrawEventArgs : EventArgs
Visual Basic

Public NotInheritable Class DrawEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.WinForms.DrawEventArgs

See Also

DrawEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs Members

DrawEventArgs Members
Properties

Contains the arguments passed to handlers of the Draw event.

The following tables list the members exposed by the DrawEventArgs type.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the element being drawn.
Date | Gets the date and time associated with the element being drawn.
Element | Gets the type of the calendar element being drawn.
EndTime | Gets the end time associated with the element being drawn.
Graphics |
Index | Gets the index associated with the element being drawn.
Item | Gets the item being custom drawn.
Pointed | Gets a value indicating whether the associated item (if any) is being pointed by the mouse.
Resource | Gets the resource related to the element being drawn.
StartTime | Gets the start time associated with the element being drawn.
Style | Gets the style associated with the element being drawn.
Text | Gets the text associated with the element being drawn.

See Also

DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs Properties

DrawEventArgs Properties

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the element being drawn.
Date | Gets the date and time associated with the element being drawn.
Element | Gets the type of the calendar element being drawn.
EndTime | Gets the end time associated with the element being drawn.
Graphics |
Index | Gets the index associated with the element being drawn.
Item | Gets the item being custom drawn.
Pointed | Gets a value indicating whether the associated item (if any) is being pointed by the mouse.
Resource | Gets the resource related to the element being drawn.
StartTime | Gets the start time associated with the element being drawn.
Style | Gets the style associated with the element being drawn.
Text | Gets the text associated with the element being drawn.

See Also

DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.Bounds Property

DrawEventArgs.Bounds Property

Gets the bounding rectangle of the element being drawn.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Rectangle Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As Rectangle

Property Value

A .NET Rectangle object specifying the element's bounds.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.Date Property

DrawEventArgs.Date Property

Gets the date and time associated with the element being drawn.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime Date { get; }
Visual Basic

Public ReadOnly Property Date As DateTime

Property Value

A DateTime object specifying the date related to the element being drawn.

Remarks

If there is not any time associated with the element, the return value is DateTime.MinValue.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.Element Property

DrawEventArgs.Element Property

Gets the type of the calendar element being drawn.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public CustomDrawElements Element { get; }
Visual Basic

Public ReadOnly Property Element As CustomDrawElements

Property Value

A member of the CustomDrawElements enumeration specifying what element to draw.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.EndTime Property

DrawEventArgs.EndTime Property

Gets the end time associated with the element being drawn.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimeSpan EndTime { get; }
Visual Basic

Public ReadOnly Property EndTime As TimeSpan

Property Value

A .NET TimeSpan object specifying the end time related to the element being drawn.

Remarks

This property is used only with certain events in the Timetable view. For events that do not use it, it is set to TimeSpan.Zero.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.Graphics Property

DrawEventArgs.Graphics Property

Overload List

Name | Description
DrawEventArgs.Graphics () | Gets the GraphicsEx instance whose methods can be used to perform custom drawing.
DrawEventArgs.Graphics () | Gets the IGraphics instance whose methods can be used to perform custom drawing.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.Graphics Property ()

DrawEventArgs.Graphics Property ()
See Also

Gets the GraphicsEx instance whose methods can be used to perform custom drawing.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

public GraphicsEx Graphics { get; }
Visual Basic

Public ReadOnly Property Graphics As GraphicsEx

Property Value

See Also

Graphics Property Overload List
DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.Graphics Property ()

DrawEventArgs.Graphics Property ()
See Also

Gets the IGraphics instance whose methods can be used to perform custom drawing.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public IGraphics Graphics { get; }
Visual Basic

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of the IGraphics class used to render the calendar elements.

See Also

Graphics Property Overload List
DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.Index Property

DrawEventArgs.Index Property

Gets the index associated with the element being drawn.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Index { get; }
Visual Basic

Public ReadOnly Property Index As Integer

Property Value

An integer value specifying the element's index.

Remarks

This property specifies the index of a view column, cell or a scheduled item being custom drawn. If there is not an index associated with the element, the return value is 0.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.Item Property

DrawEventArgs.Item Property

Gets the item being custom drawn.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Item Item { get; }
Visual Basic

Public ReadOnly Property Item As Item

Property Value

A reference to a schedule Item. If no item is associated with the drawn element, returns null (Nothing in Visual Basic).

Remarks

This property refers to an item when CustomDraw is set to CalendarItem or TimetableItem.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.Pointed Property

DrawEventArgs.Pointed Property

Gets a value indicating whether the associated item (if any) is being pointed by the mouse.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Pointed { get; }
Visual Basic

Public ReadOnly Property Pointed As Boolean

Property Value

A boolean value specifying whether the item associated with the event is currently being pointed.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.Resource Property

DrawEventArgs.Resource Property

Gets the resource related to the element being drawn.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Resource Resource { get; }
Visual Basic

Public ReadOnly Property Resource As Resource

Property Value

A reference to a Contact, Location, Task or Resource related to the custom drawn element.

Remarks

This could be null (Nothing in Visual Basic) when no resource is related to the element.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.StartTime Property

DrawEventArgs.StartTime Property

Gets the start time associated with the element being drawn.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimeSpan StartTime { get; }
Visual Basic

Public ReadOnly Property StartTime As TimeSpan

Property Value

A .NET TimeSpan object specifying the start time related to the custom drawn element.

Remarks

This property is used only with certain events in Timetable view. For events that do not use it, it is set to TimeSpan.Zero.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.Style Property

DrawEventArgs.Style Property

Gets the style associated with the element being drawn.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style Style { get; }
Visual Basic

Public ReadOnly Property Style As Style

Property Value

The Style object associated with the element being drawn.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.DrawEventArgs.Text Property

DrawEventArgs.Text Property

Gets the text associated with the element being drawn.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string Text { get; }
Visual Basic

Public ReadOnly Property Text As String

Property Value

A string specifying the text associated with a custom drawn element.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.GroupType Enumeration

GroupType Enumeration

Specifies grouping or filtering criteria for views that support grouping.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum GroupType
Visual Basic

Public Enumeration GroupType

Members

Member name | Description
FilterByContacts | Filter by contacts.
FilterByLocations | Filter by locations.
FilterByResources | Filter by resources.
FilterByTasks | Filter by tasks.
GroupByContacts | Group by contacts.
GroupByLocations | Group by locations.
GroupByResources | Group by resources.
GroupByTasks | Group by tasks.
None | No grouping or filtering.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.IItemEditor Interface

IItemEditor Interface

Defines the interface that must be implemented by item editor classes.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public interface IItemEditor
Visual Basic

Public Interface IItemEditor

Example

See Tutorial 5: Custom Item Viewers and Editors for example on how to use custom item editors and viewers.

See Also

IItemEditor Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.IItemEditor Members

IItemEditor Members
Properties Methods

Defines the interface that must be implemented by item editor classes.

The following tables list the members exposed by the IItemEditor type.

Public Properties

Name | Description
Text | Gets the new header text of the item, when the in-place editing operation is about to be confirmed via ItemInplaceEditEnding event.

Public Methods

Name | Description
EndEdit | Invoked when an operation outside of the item editor causes the editor to be closed.
StartEdit | Invoked for an item when the user initiates in-place editing operation.

See Also

IItemEditor Interface
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.IItemEditor Methods

IItemEditor Methods

Public Methods

Name | Description
EndEdit | Invoked when an operation outside of the item editor causes the editor to be closed.
StartEdit | Invoked for an item when the user initiates in-place editing operation.

See Also

IItemEditor Interface
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.IItemEditor.EndEdit Method

IItemEditor.EndEdit Method

Invoked when an operation outside of the item editor causes the editor to be closed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract void EndEdit (
ItemEditContext context,
bool accept
)
Visual Basic

Public MustOverride Sub EndEdit ( _
context As ItemEditContext, _
accept As Boolean _
)

Parameters

context
An instance of the ItemEditContext class that exposes information about the edit operation.
accept
true to accept the change, false to cancel it.

Remarks

This method is invoked by the Calendar when it closes the editor.

See Also

IItemEditor Members
IItemEditor Interface
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.IItemEditor.StartEdit Method

IItemEditor.StartEdit Method

Invoked for an item when the user initiates in-place editing operation.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract void StartEdit (
ItemEditContext context
)
Visual Basic

Public MustOverride Sub StartEdit ( _
context As ItemEditContext _
)

Parameters

context
An object, containing all information required to start editing the item.

Remarks

By the time this function is invoked the custom control is created, positioned and displayed in the Calendar. It is a responsibility of the derived class to initialize the fields of the custom control with the desired data from the item being edited.

See Also

IItemEditor Members
IItemEditor Interface
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.IItemEditor Properties

IItemEditor Properties

Public Properties

Name | Description
Text | Gets the new header text of the item, when the in-place editing operation is about to be confirmed via ItemInplaceEditEnding event.

See Also

IItemEditor Interface
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.IItemEditor.Text Property

IItemEditor.Text Property

Gets the new header text of the item, when the in-place editing operation is about to be confirmed via ItemInplaceEditEnding event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract string Text { get; }
Visual Basic

Public MustOverride ReadOnly Property Text As String

Property Value

A string containing the item's header text.

See Also

IItemEditor Members
IItemEditor Interface
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.IItemViewer Interface

IItemViewer Interface

Defines the interface that must be implemented by custom item viewer classes.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public interface IItemViewer
Visual Basic

Public Interface IItemViewer

Example

See Tutorial 5: Custom Item Viewers and Editors for example on how to use custom item editors and viewers.

See Also

IItemViewer Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.IItemViewer Members

IItemViewer Members
Methods

Defines the interface that must be implemented by custom item viewer classes.

The following tables list the members exposed by the IItemViewer type.

Public Methods

Name | Description
Draw | Renders the contents of a particular item.

See Also

IItemViewer Interface
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.IItemViewer Methods

IItemViewer Methods

Public Methods

Name | Description
Draw | Renders the contents of a particular item.

See Also

IItemViewer Interface
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.IItemViewer.Draw Method

IItemViewer.Draw Method

Renders the contents of a particular item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract void Draw (
ItemDrawContext context
)
Visual Basic

Public MustOverride Sub Draw ( _
context As ItemDrawContext _
)

Parameters

context
An object, containing all information required to visualize the item.

Remarks

The viewer must draw the item using the methods of the .NET Graphics object specified in the ItemDrawContext argument.

See Also

IItemViewer Members
IItemViewer Interface
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemAction Enumeration

ItemAction Enumeration

Specifies a user action on a schedule item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum ItemAction
Visual Basic

Public Enumeration ItemAction

Members

Member name | Description
Move | Indicates that the item is being moved.
None | Indicates no action.
ResizeEnd | Indicates that the item's end is being modified.
ResizeStart | Indicates that the item's start is being modified.
Unspecified | An unspecified action.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemConfirmEventArgs Class

ItemConfirmEventArgs Class

Contains the arguments passed to handlers of item validation events, such as ItemCreating and ItemDeleting.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class ItemConfirmEventArgs : ItemEventArgs
Visual Basic

Public Class ItemConfirmEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.WinForms.ItemConfirmEventArgs
MindFusion.Scheduling.WinForms.ItemEditConfirmEventArgs
MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs

See Also

ItemConfirmEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemConfirmEventArgs Members

ItemConfirmEventArgs Members
Properties

Contains the arguments passed to handlers of item validation events, such as ItemCreating and ItemDeleting.

The following tables list the members exposed by the ItemConfirmEventArgs type.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled.

See Also

ItemConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemConfirmEventArgs Properties

ItemConfirmEventArgs Properties

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled.

See Also

ItemConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemConfirmEventArgs.Confirm Property

ItemConfirmEventArgs.Confirm Property

Gets or sets a value indicating whether the action related to this event should be confirmed or canceled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Confirm { get; set; }
Visual Basic

Public Property Confirm As Boolean

Property Value

Set Confirm to false to prevent the action or to true to allow it. The default is true.

See Also

ItemConfirmEventArgs Members
ItemConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext Class

ItemDrawContext Class

Provides information about an item being drawn by an item viewer.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class ItemDrawContext
Visual Basic

Public Class ItemDrawContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.ItemDrawContext

See Also

ItemDrawContext Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext Members

ItemDrawContext Members
Properties Methods

Provides information about an item being drawn by an item viewer.

The following tables list the members exposed by the ItemDrawContext type.

Public Properties

Name | Description
Bounds | Gets the rectangle bounding the item contents.
Calendar | Gets the Calendar control, associated with the item.
EndsHere | Gets a value indicating whether the item part being drawn is the last part of the item.
Graphics | Gets or sets the target graphics object.
IsAllDayEvent | Gets a value indicating whether the item is an all day event or not. The item is always considered an all day event if it is drawn outside of a Timetable view.
IsHorizontal | Gets a value indicating the item's orientation.
Item | Gets the item that is being drawn.
Pointed | Gets a value indicating whether the mouse is over the drawn item.
StartsHere | Gets a value indicating whether the item part being drawn is the first part of the item.
Style | Gets the style that should be used to draw the item.

Public Methods

Name | Description
DrawBorder | Renders a frame around the specified rectangle.
DrawContentsText | Renders the underlying item's contents text at the specified location.
DrawEndClock | Draws a clock icon representing the underlying item's end time at the specified location.
DrawFormattedContentsText | Renders the underlying item's contents text at the specified location, taking into consideration specific HTML tags.
DrawHeaderBorder | Renders a header frame around the specified rectangle.
DrawHeaderText | Renders the underlying item's header text at the specified location.
DrawImage | Draws the specified image in the specified rectangle, using the specified alignment.
DrawRecurrenceIcon | Draws an icon representing the underlying item's recurrence state at the specified location.
DrawReminderIcon | Draws an icon representing the underlying item's reminder at the specified location.
DrawStartClock | Draws a clock icon representing the underlying item's start time at the specified location.

See Also

ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext Methods

ItemDrawContext Methods

Public Methods

Name | Description
DrawBorder | Renders a frame around the specified rectangle.
DrawContentsText | Renders the underlying item's contents text at the specified location.
DrawEndClock | Draws a clock icon representing the underlying item's end time at the specified location.
DrawFormattedContentsText | Renders the underlying item's contents text at the specified location, taking into consideration specific HTML tags.
DrawHeaderBorder | Renders a header frame around the specified rectangle.
DrawHeaderText | Renders the underlying item's header text at the specified location.
DrawImage | Draws the specified image in the specified rectangle, using the specified alignment.
DrawRecurrenceIcon | Draws an icon representing the underlying item's recurrence state at the specified location.
DrawReminderIcon | Draws an icon representing the underlying item's reminder at the specified location.
DrawStartClock | Draws a clock icon representing the underlying item's start time at the specified location.

See Also

ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.DrawBorder Method

ItemDrawContext.DrawBorder Method

Renders a frame around the specified rectangle.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void DrawBorder (
Rectangle destination
)
Visual Basic

Public Sub DrawBorder ( _
destination As Rectangle _
)

Parameters

destination
The rectangle around which to render a border.

Remarks

This method renders a border around the specified rectangle using the settings from the underlying style, such as BorderLeftColor, BorderLeftWidth, and so on. Since the style is based on the current theme, the rendered frame is guaranteed to be theme independent, that is, the color and thickness of the frame, unless overriden, are the same as those specified in the current theme. If the theme is changed, the color and thickness are updated accordingly.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.DrawContentsText Method

ItemDrawContext.DrawContentsText Method

Renders the underlying item's contents text at the specified location.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool DrawContentsText (
ref Rectangle destination,
bool useSettings,
bool rotate
)
Visual Basic

Public Function DrawContentsText ( _
ByRef destination As Rectangle, _
useSettings As Boolean, _
rotate As Boolean _
) As Boolean

Parameters

destination
A reference to the destination rectangle. This rectangle might be changed in the process of rendering.
useSettings
Specifies whether to take into consideration validation properties, such as EnableDefaultRendering. Specify false for this property to perform unconditional rendering.
rotate
Specifies whether to rotate the text at 90 degree.

Return Value

true if the text has been rendered; otherwise, false.

Remarks

This method renders the DescriptionText of the underlying item using the settings from the underlying style, such as TextColor, TextAlignment, and so on. Since the style is based on the current theme, the rendered text is guaranteed to be theme independent, that is, the color and font of the text, unless overriden, are the same as those specified in the current theme. If the theme is changed, the font and color are updated accordingly.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.DrawEndClock Method

ItemDrawContext.DrawEndClock Method

Draws a clock icon representing the underlying item's end time at the specified location.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool DrawEndClock (
ref Rectangle destination,
bool useSettings
)
Visual Basic

Public Function DrawEndClock ( _
ByRef destination As Rectangle, _
useSettings As Boolean _
) As Boolean

Parameters

destination
A reference to the destination rectangle. This rectangle might be changed in the process of rendering.
useSettings

Specifies whether to take into consideration validation properties, such as EnableDefaultRendering and ShowClocks. Specify false for this property to perform unconditional rendering.

Return Value

true if the icon has been rendered; otherwise, false.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.DrawFormattedContentsText Method

ItemDrawContext.DrawFormattedContentsText Method

Renders the underlying item's contents text at the specified location, taking into consideration specific HTML tags.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool DrawFormattedContentsText (
ref Rectangle destination,
bool useSettings
)
Visual Basic

Public Function DrawFormattedContentsText ( _
ByRef destination As Rectangle, _
useSettings As Boolean _
) As Boolean

Parameters

destination
A reference to the destination rectangle. This rectangle might be changed in the process of rendering.
useSettings

Specifies whether to take into consideration validation properties, such as EnableDefaultRendering. Specify false for this property to perform the rendering unconditionally.

Return Value

true if the text has been rendered; otherwise, false.

Remarks

This method renders the DescriptionText of the underlying item using the settings from the underlying style, such as TextColor, TextAlignment, and so on. The method also takes into consideration some HTML formatting tags, such as <b>, <i> and <color>. Since the style is based on the current theme, the rendered text is guaranteed to be theme independent, that is, the color and font of the text, unless overriden, are the same as those specified in the current theme. If the theme is changed, the font and color are updated accordingly.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.DrawHeaderBorder Method

ItemDrawContext.DrawHeaderBorder Method

Renders a header frame around the specified rectangle.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void DrawHeaderBorder (
Rectangle destination
)
Visual Basic

Public Sub DrawHeaderBorder ( _
destination As Rectangle _
)

Parameters

destination
The rectangle around which to render a border.

Remarks

This method renders a border around the specified rectangle using the settings from the underlying style, such as HeaderBorderLeftColor, HeaderBorderLeftWidth, and so on. Since the style is based on the current theme, the rendered frame is guaranteed to be theme independent, that is, the color and thickness of the frame, unless overriden, are the same as those specified in the current theme. If the theme is changed, the color and thickness are updated accordingly.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.DrawHeaderText Method

ItemDrawContext.DrawHeaderText Method

Renders the underlying item's header text at the specified location.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool DrawHeaderText (
ref Rectangle destination,
bool useSettings,
bool rotate
)
Visual Basic

Public Function DrawHeaderText ( _
ByRef destination As Rectangle, _
useSettings As Boolean, _
rotate As Boolean _
) As Boolean

Parameters

destination
A reference to the destination rectangle. This rectangle might be changed in the process of rendering.
useSettings

Specifies whether to take into consideration validation properties, such as EnableDefaultRendering. Specify false for this property to perform unconditional rendering.

rotate
Specifies whether to rotate the text at 90 degree.

Return Value

true if the text has been rendered; otherwise, false.

Remarks

This method renders the HeaderText of the underlying item using the settings from the underlying style, such as HeaderTextColor, HeaderTextAlignment, and so on. Since the style is based on the current theme, the rendered text is guaranteed to be theme independent, that is, the color and font of the text, unless overriden, are the same as those specified in the current theme. If the theme is changed, the font and color are updated accordingly.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.DrawImage Method

ItemDrawContext.DrawImage Method

Draws the specified image in the specified rectangle, using the specified alignment.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void DrawImage (
Image image,
Rectangle bounds,
ImageAlignment alignment
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
bounds As Rectangle, _
alignment As ImageAlignment _
)

Parameters

image
The image to draw.
bounds
The destination rectangle.
alignment
The alignment to use when drawing.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.DrawRecurrenceIcon Method

ItemDrawContext.DrawRecurrenceIcon Method

Draws an icon representing the underlying item's recurrence state at the specified location.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool DrawRecurrenceIcon (
ref Rectangle destination,
bool useSettings
)
Visual Basic

Public Function DrawRecurrenceIcon ( _
ByRef destination As Rectangle, _
useSettings As Boolean _
) As Boolean

Parameters

destination
A reference to the destination rectangle. This rectangle might be changed in the process of rendering.
useSettings

Specifies whether to take into consideration validation properties, such as EnableDefaultRendering, ShowRecurrenceIcons and ShowRecurrenceExceptionIcons. Specify false for this property to perform unconditional rendering.

Return Value

true if the icon has been rendered; otherwise, false.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.DrawReminderIcon Method

ItemDrawContext.DrawReminderIcon Method

Draws an icon representing the underlying item's reminder at the specified location.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool DrawReminderIcon (
ref Rectangle destination,
bool useSettings
)
Visual Basic

Public Function DrawReminderIcon ( _
ByRef destination As Rectangle, _
useSettings As Boolean _
) As Boolean

Parameters

destination
A reference to the destination rectangle. This rectangle might be changed in the process of rendering.
useSettings
Specifies whether to take into consideration validation properties, such as EnableDefaultRendering and ShowReminderIcons. Specify false for this property to perform unconditional rendering.

Return Value

true if the icon has been rendered; otherwise, false.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.DrawStartClock Method

ItemDrawContext.DrawStartClock Method

Draws a clock icon representing the underlying item's start time at the specified location.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool DrawStartClock (
ref Rectangle destination,
bool useSettings
)
Visual Basic

Public Function DrawStartClock ( _
ByRef destination As Rectangle, _
useSettings As Boolean _
) As Boolean

Parameters

destination
A reference to the destination rectangle. This rectangle might be changed in the process of rendering.
useSettings
Specifies whether to take into consideration validation properties, such as EnableDefaultRendering and ShowClocks. Specify false for this property to perform unconditional rendering.

Return Value

true if the icon has been rendered; otherwise, false.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext Properties

ItemDrawContext Properties

Public Properties

Name | Description
Bounds | Gets the rectangle bounding the item contents.
Calendar | Gets the Calendar control, associated with the item.
EndsHere | Gets a value indicating whether the item part being drawn is the last part of the item.
Graphics | Gets or sets the target graphics object.
IsAllDayEvent | Gets a value indicating whether the item is an all day event or not. The item is always considered an all day event if it is drawn outside of a Timetable view.
IsHorizontal | Gets a value indicating the item's orientation.
Item | Gets the item that is being drawn.
Pointed | Gets a value indicating whether the mouse is over the drawn item.
StartsHere | Gets a value indicating whether the item part being drawn is the first part of the item.
Style | Gets the style that should be used to draw the item.

See Also

ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.Bounds Property

ItemDrawContext.Bounds Property

Gets the rectangle bounding the item contents.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Rectangle Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As Rectangle

Property Value

A .NET Rectangle object.

Remarks

The item viewer must paint the item inside these bounds.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.Calendar Property

ItemDrawContext.Calendar Property

Gets the Calendar control, associated with the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Calendar Calendar { get; }
Visual Basic

Public ReadOnly Property Calendar As Calendar

Property Value

Refers to the Calendar object associated with the item viewer.

Remarks

A class can be set as an item viewer using the ItemViewerAttribute attribute.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.EndsHere Property

ItemDrawContext.EndsHere Property

Gets a value indicating whether the item part being drawn is the last part of the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool EndsHere { get; }
Visual Basic

Public ReadOnly Property EndsHere As Boolean

Property Value

true if the last part of an item is being painted; otherwise, false.

Remarks

Items consist of several parts when they span several time cells in the month, list and week range views.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.Graphics Property

ItemDrawContext.Graphics Property

Gets or sets the target graphics object.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public IGraphics Graphics { get; set; }
Visual Basic

Public Property Graphics As IGraphics

Property Value

An instance of the IGraphics interface that must be used to paint the item.

Remarks

A custom item viewer should use this IGraphics instance to draw a schedule item.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.IsAllDayEvent Property

ItemDrawContext.IsAllDayEvent Property

Gets a value indicating whether the item is an all day event or not. The item is always considered an all day event if it is drawn outside of a Timetable view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool IsAllDayEvent { get; }
Visual Basic

Public ReadOnly Property IsAllDayEvent As Boolean

Property Value

true if the item being painted is an all-day event; otherwise, false.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.IsHorizontal Property

ItemDrawContext.IsHorizontal Property

Gets a value indicating the item's orientation.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool IsHorizontal { get; }
Visual Basic

Public ReadOnly Property IsHorizontal As Boolean

Property Value

true if the item is painted horizontally; otherwise, false.

Remarks

Items are painted horizontally or vertically depending on the orientation of the current view.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.Item Property

ItemDrawContext.Item Property

Gets the item that is being drawn.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Item Item { get; }
Visual Basic

Public ReadOnly Property Item As Item

Property Value

Refers to the schedule item that must be painted by the item viewer.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.Pointed Property

ItemDrawContext.Pointed Property

Gets a value indicating whether the mouse is over the drawn item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Pointed { get; }
Visual Basic

Public ReadOnly Property Pointed As Boolean

Property Value

true if the mouse is currently over the item; otherwise, false.

Remarks

You can inspect the value of this property if you intend to change the appearance of your items when the mouse hovers over them. For example, you might wish to implement some form of highlighting.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.StartsHere Property

ItemDrawContext.StartsHere Property

Gets a value indicating whether the item part being drawn is the first part of the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool StartsHere { get; }
Visual Basic

Public ReadOnly Property StartsHere As Boolean

Property Value

true if the first part of an item is being painted; otherwise, false.

Remarks

Items consist of several parts when they span several time cells in the month, list and week range views.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemDrawContext.Style Property

ItemDrawContext.Style Property

Gets the style that should be used to draw the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style Style { get; }
Visual Basic

Public ReadOnly Property Style As Style

Property Value

Refers to the Style for the item being painted.

See Also

ItemDrawContext Members
ItemDrawContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditConfirmEventArgs Class

ItemEditConfirmEventArgs Class

Contains the arguments passed to handlers of the ItemInplaceEditEnding event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class ItemEditConfirmEventArgs : ItemConfirmEventArgs
Visual Basic

Public Class ItemEditConfirmEventArgs
Inherits ItemConfirmEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.WinForms.ItemConfirmEventArgs
MindFusion.Scheduling.WinForms.ItemEditConfirmEventArgs

See Also

ItemEditConfirmEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditConfirmEventArgs Members

ItemEditConfirmEventArgs Members
Properties

Contains the arguments passed to handlers of the ItemInplaceEditEnding event.

The following tables list the members exposed by the ItemEditConfirmEventArgs type.

Public Properties

Name | Description
NewText | Gets the new text that will be applied to the item if the in-place editing operation is allowed.

See Also

ItemEditConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditConfirmEventArgs Properties

ItemEditConfirmEventArgs Properties

Public Properties

Name | Description
NewText | Gets the new text that will be applied to the item if the in-place editing operation is allowed.

See Also

ItemEditConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditConfirmEventArgs.NewText Property

ItemEditConfirmEventArgs.NewText Property

Gets the new text that will be applied to the item if the in-place editing operation is allowed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string NewText { get; }
Visual Basic

Public ReadOnly Property NewText As String

Property Value

A string containing the new text of the item.

See Also

ItemEditConfirmEventArgs Members
ItemEditConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditContext Class

ItemEditContext Class

Provides information about an item when it is being edited using a custom item editor.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class ItemEditContext
Visual Basic

Public Class ItemEditContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.ItemEditContext

See Also

ItemEditContext Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditContext Members

ItemEditContext Members
Properties Methods

Provides information about an item when it is being edited using a custom item editor.

The following tables list the members exposed by the ItemEditContext type.

Public Properties

Name | Description
Bounds | Gets the rectangle bounding the item contents.
Calendar | Gets the Calendar control, associated with the item.
IsHorizontal | Gets a value indicating the item's orientation.
Item | Gets the item that is being edited.
TextAlignment | Gets the alignment of the text of the item being edited.
TextFont | Gets the font of the text of the item being edited.

Public Methods

Name | Description
Accept | Accepts the changes made on the item during the in-place editing.
Cancel | Cancels the in-place editing mode.

See Also

ItemEditContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditContext Methods

ItemEditContext Methods

Public Methods

Name | Description
Accept | Accepts the changes made on the item during the in-place editing.
Cancel | Cancels the in-place editing mode.

See Also

ItemEditContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditContext.Accept Method

ItemEditContext.Accept Method

Accepts the changes made on the item during the in-place editing.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Accept ()
Visual Basic

Public Sub Accept ()

Remarks

Invoke this method when the user has confirmed the in-place editing of an item through the custom editor control.

See Also

ItemEditContext Members
ItemEditContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditContext.Cancel Method

ItemEditContext.Cancel Method

Cancels the in-place editing mode.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Cancel ()
Visual Basic

Public Sub Cancel ()

Remarks

Invoke this method when the user has canceled the in-place editing of an item through the custom editor control.

See Also

ItemEditContext Members
ItemEditContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditContext Properties

ItemEditContext Properties

Public Properties

Name | Description
Bounds | Gets the rectangle bounding the item contents.
Calendar | Gets the Calendar control, associated with the item.
IsHorizontal | Gets a value indicating the item's orientation.
Item | Gets the item that is being edited.
TextAlignment | Gets the alignment of the text of the item being edited.
TextFont | Gets the font of the text of the item being edited.

See Also

ItemEditContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditContext.Bounds Property

ItemEditContext.Bounds Property

Gets the rectangle bounding the item contents.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Rectangle Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As Rectangle

Property Value

A .NET Rectangle object.

Remarks

The item is painted inside these bounds, so the custom editor should be displayed in them or near them.

See Also

ItemEditContext Members
ItemEditContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditContext.Calendar Property

ItemEditContext.Calendar Property

Gets the Calendar control, associated with the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Calendar Calendar { get; }
Visual Basic

Public ReadOnly Property Calendar As Calendar

Property Value

Refers to the Calendar object associated with the item editor.

Remarks

A class can be set as an item editor using the ItemEditorAttribute attribute.

See Also

ItemEditContext Members
ItemEditContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditContext.IsHorizontal Property

ItemEditContext.IsHorizontal Property

Gets a value indicating the item's orientation.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool IsHorizontal { get; }
Visual Basic

Public ReadOnly Property IsHorizontal As Boolean

Property Value

true if the item is painted horizontally; otherwise, false.

Remarks

Items are painted horizontally or vertically depending on the orientation of the current view.

See Also

ItemEditContext Members
ItemEditContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditContext.Item Property

ItemEditContext.Item Property

Gets the item that is being edited.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Item Item { get; }
Visual Basic

Public ReadOnly Property Item As Item

Property Value

Refers to the schedule item that must be edited via the item editor.

See Also

ItemEditContext Members
ItemEditContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditContext.TextAlignment Property

ItemEditContext.TextAlignment Property

Gets the alignment of the text of the item being edited.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public HorizontalAlignment TextAlignment { get; }
Visual Basic

Public ReadOnly Property TextAlignment As HorizontalAlignment

Property Value

A member of the .NET HorizontalAlignment enumeration.

Remarks

This value corresponds to the TextAlignment property of the style set for the item being edited.

See Also

ItemEditContext Members
ItemEditContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditContext.TextFont Property

ItemEditContext.TextFont Property

Gets the font of the text of the item being edited.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Font TextFont { get; }
Visual Basic

Public ReadOnly Property TextFont As Font

Property Value

An instance of the .NET Font class.

Remarks

This is the font set in the Font property of the style set for the edited item.

See Also

ItemEditContext Members
ItemEditContext Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorAttribute Class

ItemEditorAttribute Class

Associates a custom item editor with a schedule item class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class ItemEditorAttribute : Attribute
Visual Basic

Public NotInheritable Class ItemEditorAttribute
Inherits Attribute

Inheritance Hierarchy

System.Object
System.Attribute
MindFusion.Scheduling.WinForms.ItemEditorAttribute

See Also

ItemEditorAttribute Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorAttribute Members

ItemEditorAttribute Members
Constructors Properties

Associates a custom item editor with a schedule item class.

The following tables list the members exposed by the ItemEditorAttribute type.

Public Constructors

Name | Description
ItemEditorAttribute | Overloaded. Initializes a new instance of the ItemEditorAttribute class.

Public Properties

Name | Description
EditorType | Gets the type of the item editor associated with an item class.
EditorTypeName | Gets the type name of the item editor associated with an item class.

See Also

ItemEditorAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorAttribute Constructor

ItemEditorAttribute Constructor

Initializes a new instance of the ItemEditorAttribute class.

Overload List

Name | Description
ItemEditorAttribute (String) | Initializes a new instance of the ItemEditorAttribute class.
ItemEditorAttribute (Type) | Initialize a new instance of the ItemEditorAttribute class.

See Also

ItemEditorAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorAttribute Constructor (String)

ItemEditorAttribute Constructor (String)
See Also

Initializes a new instance of the ItemEditorAttribute class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemEditorAttribute (
string editorTypeName
)
Visual Basic

Public New ( _
editorTypeName As String _
)

Parameters

editorTypeName

A string containing the fully qualified name of the type to be used as an item editor.

See Also

ItemEditorAttribute Constructor Overload List
ItemEditorAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorAttribute Constructor (Type)

ItemEditorAttribute Constructor (Type)
See Also

Initialize a new instance of the ItemEditorAttribute class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemEditorAttribute (
Type editorType
)
Visual Basic

Public New ( _
editorType As Type _
)

Parameters

editorType
An instance of the .NET Type class specifying the custom editor class.

Remarks

The custom editor class must inherit the .NET System.Windows.Forms.Control class and implement the IItemEditor interface.

See Also

ItemEditorAttribute Constructor Overload List
ItemEditorAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorAttribute Properties

ItemEditorAttribute Properties

Public Properties

Name | Description
EditorType | Gets the type of the item editor associated with an item class.
EditorTypeName | Gets the type name of the item editor associated with an item class.

See Also

ItemEditorAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorAttribute.EditorType Property

ItemEditorAttribute.EditorType Property

Gets the type of the item editor associated with an item class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Type EditorType { get; }
Visual Basic

Public ReadOnly Property EditorType As Type

Property Value

A .NET Type object that specifies the custom editor class.

Remarks

The custom editor class must inherit the .NET System.Windows.Forms.Control class and implement the IItemEditor interface.

See Also

ItemEditorAttribute Members
ItemEditorAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorAttribute.EditorTypeName Property

ItemEditorAttribute.EditorTypeName Property

Gets the type name of the item editor associated with an item class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string EditorTypeName { get; }
Visual Basic

Public ReadOnly Property EditorTypeName As String

Property Value

A string containing the fully qualified name of the type that specifies the custom editor class.

Remarks

The custom editor class must inherit the .NET System.Windows.Forms.Control class and implement the IItemEditor interface.

See Also

ItemEditorAttribute Members
ItemEditorAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorEx Class

ItemEditorEx Class

An item editor that enables modification of the item description as well as the item header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class ItemEditorEx : UserControl, IItemEditor
Visual Basic

Public NotInheritable Class ItemEditorEx
Inherits UserControl
Implements IItemEditor

Example

The following example illustrates how to use this class as a default item editor with MindFusion.Scheduling. Because item editors are associated with items at class level, a new empty class is derived from Appointment and the ItemEditorEx is bound to it via the ItemEditor attribute. Finally the Calendar control is instructed to instantiate appointments from the new class by using the InteractiveItemType property.

C#

[ItemEditor(typeof(ItemEditorEx))]
class AppointmentEx : Appointment
{
// Empty class
}

// ...Somewhere during initialization...
calendar.InteractiveItemType = typeof(AppointmentEx);
Visual Basic

<ItemEditor(GetType(ItemEditorEx))> _
Class AppointmentEx
Inherits Appointment

' Empty class

End Class

' ...Somewhere during initialization...
calendar.InteractiveItemType = GetType(AppointmentEx)

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
MindFusion.Scheduling.WinForms.ItemEditorEx

See Also

ItemEditorEx Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorEx Members

ItemEditorEx Members
Constructors Properties Methods

An item editor that enables modification of the item description as well as the item header.

The following tables list the members exposed by the ItemEditorEx type.

Public Constructors

Name | Description
ItemEditorEx | Initializes a new instance of the ItemEditorEx class.

Public Properties

Name | Description
Text | Gets the new header text of the item, when the in-place editing operation is about to be confirmed via ItemInplaceEditEnding event.

Public Methods

Name | Description
EndEdit | Invoked when an operation outside of the item editor causes the editor to be closed.
StartEdit | Invoked for an item when the user initiates in-place editing operation.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnLostFocus | Control.OnLostFocus override.
ProcessDialogKey | ContainerControl.ProcessDialogKey override.

See Also

ItemEditorEx Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorEx Constructor

ItemEditorEx Constructor

Initializes a new instance of the ItemEditorEx class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemEditorEx ()
Visual Basic

Public Sub New ()

See Also

ItemEditorEx Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorEx Methods

ItemEditorEx Methods

Public Methods

Name | Description
EndEdit | Invoked when an operation outside of the item editor causes the editor to be closed.
StartEdit | Invoked for an item when the user initiates in-place editing operation.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnLostFocus | Control.OnLostFocus override.
ProcessDialogKey | ContainerControl.ProcessDialogKey override.

See Also

ItemEditorEx Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorEx.Dispose Method

ItemEditorEx.Dispose Method

Clean up any resources being used.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

ItemEditorEx Members
ItemEditorEx Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorEx.EndEdit Method

ItemEditorEx.EndEdit Method

Invoked when an operation outside of the item editor causes the editor to be closed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void EndEdit (
ItemEditContext context,
bool accept
)
Visual Basic

Public Overridable Sub EndEdit ( _
context As ItemEditContext, _
accept As Boolean _
)

Parameters

context
An instance of the ItemEditContext class that exposes information about the edit operation.
accept
true to accept the change, false to cancel it.

Remarks

This method is invoked by the Calendar when it closes the editor.

See Also

ItemEditorEx Members
ItemEditorEx Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorEx.OnLostFocus Method

ItemEditorEx.OnLostFocus Method

Control.OnLostFocus override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnLostFocus (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnLostFocus ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

ItemEditorEx Members
ItemEditorEx Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorEx.ProcessDialogKey Method

ItemEditorEx.ProcessDialogKey Method

ContainerControl.ProcessDialogKey override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual bool ProcessDialogKey (
Keys keyData
)
Visual Basic

Protected Overridable Function ProcessDialogKey ( _
keyData As Keys _
) As Boolean

Parameters

keyData
One of the Keys values that represents the key to process.

Return Value

true if the key was processed by the control; otherwise, false.

See Also

ItemEditorEx Members
ItemEditorEx Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorEx.StartEdit Method

ItemEditorEx.StartEdit Method

Invoked for an item when the user initiates in-place editing operation.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void StartEdit (
ItemEditContext context
)
Visual Basic

Public Overridable Sub StartEdit ( _
context As ItemEditContext _
)

Parameters

context
An object, containing all information required to start editing the item.

Remarks

By the time this function is invoked the custom control is created, positioned and displayed in the Calendar. It is a responsibility of the derived class to initialize the fields of the custom control with the desired data from the item being edited.

See Also

ItemEditorEx Members
ItemEditorEx Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorEx Properties

ItemEditorEx Properties

Public Properties

Name | Description
Text | Gets the new header text of the item, when the in-place editing operation is about to be confirmed via ItemInplaceEditEnding event.

See Also

ItemEditorEx Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemEditorEx.Text Property

ItemEditorEx.Text Property

Gets the new header text of the item, when the in-place editing operation is about to be confirmed via ItemInplaceEditEnding event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public override string Text { get; }
Visual Basic

Public Overrides ReadOnly Property Text As String

Property Value

A string containing the item's header text.

See Also

ItemEditorEx Members
ItemEditorEx Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModificationStyle Enumeration

ItemModificationStyle Enumeration

Specifies the way items are processed when modified interactively.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum ItemModificationStyle
Visual Basic

Public Enumeration ItemModificationStyle

Members

Member name | Description
Black | A semi-transparent black rectangle is rendered at the drop location. The item layout remains unchanged until the modified items are actually dropped.
DashOutline | A dashed outline of the modified items is rendered at the drop location. The item layout remains unchanged until the modified items are actually dropped.
InPlace | The items are dragged when modified. The item layout is rearranged during the modification.
SolidOutline | A solid outline of the modified items is rendered at the drop location. The item layout remains unchanged until the modified items are actually dropped.
Transparent | A transparent image of the modified items is rendered at the drop location. The item layout remains unchanged until the items are actually dropped.

Remarks

Assign a value of this enumeration to the ItemModificationStyle property of the Calendar class.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs Class

ItemModifiedEventArgs Class

Contains the arguments passed to handlers of the ItemModified event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class ItemModifiedEventArgs : ItemEventArgs
Visual Basic

Public Class ItemModifiedEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.WinForms.ItemModifiedEventArgs

See Also

ItemModifiedEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs Members

ItemModifiedEventArgs Members
Properties

Contains the arguments passed to handlers of the ItemModified event.

The following tables list the members exposed by the ItemModifiedEventArgs type.

Public Properties

Name | Description
OldEndTime | Gets the old end time of the item.
OldResources | Gets the old resources the item was associated with.
OldStartTime | Gets the old start time of the item.
ResizeEnd | Gets a value indicating whether the item's end has been modified.
ResizeStart | Gets a value indicating whether the item's start has been modified.

See Also

ItemModifiedEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs Properties

ItemModifiedEventArgs Properties

Public Properties

Name | Description
OldEndTime | Gets the old end time of the item.
OldResources | Gets the old resources the item was associated with.
OldStartTime | Gets the old start time of the item.
ResizeEnd | Gets a value indicating whether the item's end has been modified.
ResizeStart | Gets a value indicating whether the item's start has been modified.

See Also

ItemModifiedEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs.OldEndTime Property

ItemModifiedEventArgs.OldEndTime Property

Gets the old end time of the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime OldEndTime { get; }
Visual Basic

Public ReadOnly Property OldEndTime As DateTime

Property Value

A .NET DateTime value representing the original end time of the modified item.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs.OldResources Property

ItemModifiedEventArgs.OldResources Property

Gets the old resources the item was associated with.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ResourceCollection OldResources { get; }
Visual Basic

Public ReadOnly Property OldResources As ResourceCollection

Property Value

A collection of resources originally associated with the item.

Remarks

The returned collection might contain Contact, Location, Task or Resource objects depending on the current grouping type.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs.OldStartTime Property

ItemModifiedEventArgs.OldStartTime Property

Gets the old start time of the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime OldStartTime { get; }
Visual Basic

Public ReadOnly Property OldStartTime As DateTime

Property Value

A .NET DateTime value representing the original start time of the modified item.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs.ResizeEnd Property

ItemModifiedEventArgs.ResizeEnd Property

Gets a value indicating whether the item's end has been modified.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ResizeEnd { get; }
Visual Basic

Public ReadOnly Property ResizeEnd As Boolean

Property Value

true if the item's end has been modified; false if item was moved or its start has been modified.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs.ResizeStart Property

ItemModifiedEventArgs.ResizeStart Property

Gets a value indicating whether the item's start has been modified.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ResizeStart { get; }
Visual Basic

Public ReadOnly Property ResizeStart As Boolean

Property Value

true if the item's start has been modified; false if item was moved or its end has been modified.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs Class

ItemModifyConfirmEventArgs Class

Contains the arguments passed to handlers of the ItemModifying event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class ItemModifyConfirmEventArgs : ItemConfirmEventArgs
Visual Basic

Public Class ItemModifyConfirmEventArgs
Inherits ItemConfirmEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.WinForms.ItemConfirmEventArgs
MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs

See Also

ItemModifyConfirmEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs Members

ItemModifyConfirmEventArgs Members
Properties

Contains the arguments passed to handlers of the ItemModifying event.

The following tables list the members exposed by the ItemModifyConfirmEventArgs type.

Public Properties

Name | Description
NewEndTime | Gets or sets the new end time of the item.
NewListLane | Gets or sets the index of the new list lane of the item.
NewStartTime | Gets or sets the new start time of the item.
ResizeEnd | Gets a value indicating whether the item's end is being modified.
ResizeStart | Gets a value indicating whether the item's start is being modified.
Resource | Gets the new resource of the item.

See Also

ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs Properties

ItemModifyConfirmEventArgs Properties

Public Properties

Name | Description
NewEndTime | Gets or sets the new end time of the item.
NewListLane | Gets or sets the index of the new list lane of the item.
NewStartTime | Gets or sets the new start time of the item.
ResizeEnd | Gets a value indicating whether the item's end is being modified.
ResizeStart | Gets a value indicating whether the item's start is being modified.
Resource | Gets the new resource of the item.

See Also

ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs.NewEndTime Property

ItemModifyConfirmEventArgs.NewEndTime Property

Gets or sets the new end time of the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime NewEndTime { get; set; }
Visual Basic

Public Property NewEndTime As DateTime

Property Value

A .NET DateTime object specifying the item's new end time.

Remarks

You will generally need to inspect the value of this property in order to see whether the new end time of the item would satisfy the criteria of your application, in order to confirm or refuse the user operation accordingly. In certain cases, however, you might want to set a new value to this property, thus forcing the end time of the item, disregarding the user's actions.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs.NewListLane Property

ItemModifyConfirmEventArgs.NewListLane Property

Gets or sets the index of the new list lane of the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int NewListLane { get; set; }
Visual Basic

Public Property NewListLane As Integer

Property Value

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs.NewStartTime Property

ItemModifyConfirmEventArgs.NewStartTime Property

Gets or sets the new start time of the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime NewStartTime { get; set; }
Visual Basic

Public Property NewStartTime As DateTime

Property Value

A .NET DateTime object specifying the item's new start time.

Remarks

You will generally need to inspect the value of this property in order to see whether the new start time of the item would satisfy the criteria of your application, so to confirm or refuse the user operation accordingly. In certain cases, however, you might want to set a new value to this property, thus forcing the start time of the item, disregarding the user's actions.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs.ResizeEnd Property

ItemModifyConfirmEventArgs.ResizeEnd Property

Gets a value indicating whether the item's end is being modified.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ResizeEnd { get; }
Visual Basic

Public ReadOnly Property ResizeEnd As Boolean

Property Value

true if the item's end is being modified; false if item is moved or its start is being modified.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs.ResizeStart Property

ItemModifyConfirmEventArgs.ResizeStart Property

Gets a value indicating whether the item's start is being modified.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ResizeStart { get; }
Visual Basic

Public ReadOnly Property ResizeStart As Boolean

Property Value

true if the item's start is being modified; false if item is moved or its end is being modified.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs.Resource Property

ItemModifyConfirmEventArgs.Resource Property

Gets the new resource of the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Resource Resource { get; }
Visual Basic

Public ReadOnly Property Resource As Resource

Property Value

A reference to a Contact, Location, Task or Resource depending on the current grouping type.

Remarks

This value can be null (Nothing in Visual Basic), if the item doesn't change associated resource.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs Class

ItemMouseEventArgs Class

Contains the arguments passed to handlers of the ItemClick event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class ItemMouseEventArgs : ItemEventArgs
Visual Basic

Public Class ItemMouseEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.WinForms.ItemMouseEventArgs

See Also

ItemMouseEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs Members

ItemMouseEventArgs Members
Properties

Contains the arguments passed to handlers of the ItemClick event.

The following tables list the members exposed by the ItemMouseEventArgs type.

Public Properties

Name | Description
Button | Gets the pressed mouse button.
Clicks | Gets the number of clicks.
ResizeEnd | Gets a value indicating whether the item's end is about to be resized.
ResizeStart | Gets a value indicating whether the item's start is about to be resized.
X | Gets the x-position of the mouse relative to the item.
Y | Gets the y-position of the mouse relative to the item.

See Also

ItemMouseEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs Properties

ItemMouseEventArgs Properties

Public Properties

Name | Description
Button | Gets the pressed mouse button.
Clicks | Gets the number of clicks.
ResizeEnd | Gets a value indicating whether the item's end is about to be resized.
ResizeStart | Gets a value indicating whether the item's start is about to be resized.
X | Gets the x-position of the mouse relative to the item.
Y | Gets the y-position of the mouse relative to the item.

See Also

ItemMouseEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs.Button Property

ItemMouseEventArgs.Button Property

Gets the pressed mouse button.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public MouseButtons Button { get; }
Visual Basic

Public ReadOnly Property Button As MouseButtons

Property Value

A member of the .NET MouseButtons enumeration.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs.Clicks Property

ItemMouseEventArgs.Clicks Property

Gets the number of clicks.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Clicks { get; }
Visual Basic

Public ReadOnly Property Clicks As Integer

Property Value

An integer value specifying the number of mouse clicks related to the raised event.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs.ResizeEnd Property

ItemMouseEventArgs.ResizeEnd Property

Gets a value indicating whether the item's end is about to be resized.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ResizeEnd { get; }
Visual Basic

Public ReadOnly Property ResizeEnd As Boolean

Property Value

A Boolean value indicating whether the item's end is about to be resized in an ItemClick event.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs.ResizeStart Property

ItemMouseEventArgs.ResizeStart Property

Gets a value indicating whether the item's start is about to be resized.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ResizeStart { get; }
Visual Basic

Public ReadOnly Property ResizeStart As Boolean

Property Value

A Boolean value indicating whether the item's start is about to be resized in an ItemClick event.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs.X Property

ItemMouseEventArgs.X Property

Gets the x-position of the mouse relative to the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int X { get; }
Visual Basic

Public ReadOnly Property X As Integer

Property Value

An integer value specifying the mouse position relatively to the item.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.WinForms Namespace
Y Property


MindFusion.Scheduling.WinForms.ItemMouseEventArgs.Y Property

ItemMouseEventArgs.Y Property

Gets the y-position of the mouse relative to the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Y { get; }
Visual Basic

Public ReadOnly Property Y As Integer

Property Value

An integer value specifying the mouse position relatively to the item.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.WinForms Namespace
X Property


MindFusion.Scheduling.WinForms.ItemSelection Class

ItemSelection Class

Represents a set of selected schedule items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class ItemSelection
Visual Basic

Public NotInheritable Class ItemSelection

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.ItemSelection

See Also

ItemSelection Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSelection Members

ItemSelection Members
Properties Methods

Represents a set of selected schedule items.

The following tables list the members exposed by the ItemSelection type.

Public Properties

Name | Description
Count | Gets the number of selected items.
Items | Gets the selected items.

Public Methods

Name | Description
Add | Adds the specified item to the selection.
Clear | Clears the selection.
Contains | Determines whether the specified item is currently selected.
Remove | Removes the specified item from the selection.

See Also

ItemSelection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSelection Methods

ItemSelection Methods

Public Methods

Name | Description
Add | Adds the specified item to the selection.
Clear | Clears the selection.
Contains | Determines whether the specified item is currently selected.
Remove | Removes the specified item from the selection.

See Also

ItemSelection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSelection.Add Method

ItemSelection.Add Method

Adds the specified item to the selection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Add (
Item item
)
Visual Basic

Public Sub Add ( _
item As Item _
)

Parameters

item
The Item instance to be added to the selection.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSelection.Clear Method

ItemSelection.Clear Method

Clears the selection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Clear ()
Visual Basic

Public Sub Clear ()

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSelection.Contains Method

ItemSelection.Contains Method

Determines whether the specified item is currently selected.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
Item item
)
Visual Basic

Public Function Contains ( _
item As Item _
) As Boolean

Parameters

item
The Item instance to search for in the selection.

Return Value

true if the item is selected or false if it isn't.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSelection.Remove Method

ItemSelection.Remove Method

Removes the specified item from the selection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Remove (
Item item
)
Visual Basic

Public Sub Remove ( _
item As Item _
)

Parameters

item
The Item instance to be removed from the selection.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSelection Properties

ItemSelection Properties

Public Properties

Name | Description
Count | Gets the number of selected items.
Items | Gets the selected items.

See Also

ItemSelection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSelection.Count Property

ItemSelection.Count Property

Gets the number of selected items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Count { get; }
Visual Basic

Public ReadOnly Property Count As Integer

Property Value

An integer value specifying the number of selected items.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSelection.Items Property

ItemSelection.Items Property

Gets the selected items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Item[] Items { get; }
Visual Basic

Public ReadOnly Property Items As Item()

Property Value

An array of selected Item objects.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSelectionEventArgs Class

ItemSelectionEventArgs Class

Contains the arguments passed to handlers of selection related events.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class ItemSelectionEventArgs : ItemEventArgs
Visual Basic

Public Class ItemSelectionEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.WinForms.ItemSelectionEventArgs

See Also

ItemSelectionEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSelectionEventArgs Members

ItemSelectionEventArgs Members
Properties

Contains the arguments passed to handlers of selection related events.

The following tables list the members exposed by the ItemSelectionEventArgs type.

Public Properties

Name | Description
IsDeselected | Gets a value indicating whether the item was deselected.
IsSelected | Gets a value indicating whether the item was selected.

See Also

ItemSelectionEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSelectionEventArgs Properties

ItemSelectionEventArgs Properties

Public Properties

Name | Description
IsDeselected | Gets a value indicating whether the item was deselected.
IsSelected | Gets a value indicating whether the item was selected.

See Also

ItemSelectionEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSelectionEventArgs.IsDeselected Property

ItemSelectionEventArgs.IsDeselected Property

Gets a value indicating whether the item was deselected.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool IsDeselected { get; }
Visual Basic

Public ReadOnly Property IsDeselected As Boolean

Property Value

true if the the item was deselected by the user; false if the item was selected.

Remarks

This property is mutually exclusive with IsSelected, that is, when one of them is false, the other is true, and vice versa.

See Also

ItemSelectionEventArgs Members
ItemSelectionEventArgs Class
MindFusion.Scheduling.WinForms Namespace
IsSelected Property


MindFusion.Scheduling.WinForms.ItemSelectionEventArgs.IsSelected Property

ItemSelectionEventArgs.IsSelected Property

Gets a value indicating whether the item was selected.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool IsSelected { get; }
Visual Basic

Public ReadOnly Property IsSelected As Boolean

Property Value

true if the the item was selected by the user; false if the item was deselected.

Remarks

This property is mutually exclusive with IsDeselected, that is, when one of them is false, the other is true, and vice versa.

See Also

ItemSelectionEventArgs Members
ItemSelectionEventArgs Class
MindFusion.Scheduling.WinForms Namespace
IsDeselected Property


MindFusion.Scheduling.WinForms.ItemSettings Class

ItemSettings Class

Defines properties that allow customizing the visualization of schedule items in the calendar views.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class ItemSettings
Visual Basic

Public Class ItemSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.ItemSettings

See Also

ItemSettings Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings Members

ItemSettings Members
Properties Methods Events

Defines properties that allow customizing the visualization of schedule items in the calendar views.

The following tables list the members exposed by the ItemSettings type.

Public Properties

Name | Description
CapIncompleteSegments | Gets or sets a value indicating whether to cap incomplete item segments.
EnableDefaultRendering | Gets or sets a value indicating whether the default item rendering is enabled.
HeaderSize | Gets or sets the size of the item header for non all-day items in the Timetable view.
ItemsVisible | Gets or sets a value indicating whether to display schedule items in the calendar.
MoveBandSize | Gets or sets the size of the move band of items in the Timetable view.
Padding | Gets or sets the amount of space between each item and the frame lines of the calendar cell that contains the item.
PaddingBottom | Gets or sets the amount of space between the bottom side of an item and bottom frame line of the calendar cell that contains the item.
PaddingLeft | Gets or sets the amount of space between the left side of an item and left frame line of the calendar cell that contains the item.
PaddingRight | Gets or sets the amount of space between the right side of an item and right frame line of the calendar cell that contains the item.
PaddingTop | Gets or sets the amount of space between the top side of an item and top frame line of the calendar cell that contains the item.
PointedItemStyle | Gets or sets the Style used to paint items when they are pointed with the mouse.
PointedSelectedItemStyle | Gets or sets the Style used to paint items when they are pointed with the mouse and selected at the same time.
ResizeBandSize | Gets or sets the size of the bands used to resize an item in a Timetable view.
ScaleClocks | Gets or sets a value indicating whether the clock icons are scaled proportionally to the size of the items.
SelectedItemStyle | Gets or sets the Style used to paint selected schedule items.
ShadowColor | Gets or sets the color of the shadow cast by the items.
ShadowOffset | Gets or set the offset of the shadows from the items that cast them.
ShadowStyle | Gets or sets the style of the shadow cast by the items.
ShowClocks | Gets or sets whether and when the clocks displaying the items' start and end time are shown.
ShowContinuationArrows | Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.
ShowMoreItemsCue | Gets or sets a value indicating whether to display a 'more items' icon in a calendar cell which isn't big enough to contain all of its items.
ShowRecurrenceExceptionIcons | Gets or sets a value indicating whether the icon of recurrence exception items is displayed.
ShowRecurrenceIcons | Gets or sets a value indicating whether the icon of recurring items is displayed.
ShowReminderIcons | Gets or sets a value indicating whether the reminder icon of items is displayed.
Size | Gets or sets the size of schedule items drawn in the calendar.
Spacing | Gets or sets the amount of space between adjacent items.
Style | Gets or sets the Style used to paint schedule items that don't have a distinct style assigned to them.
UseExtendedStyles | Gets or sets a value indicating whether the appropriate styles are used when an item is pointed with the mouse.
UseStyledText | Gets or sets a value indicating whether formatting tags such as <b> and <i> are taken into consideration in the items' description text.

Protected Methods

Name | Description
OnSettingsChanged | Fires the SettingsChanged event.

Public Events

Name | Description
SettingsChanged | Raised when an ItemSettings object has changed.

See Also

ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings Methods

ItemSettings Methods

Protected Methods

Name | Description
OnSettingsChanged | Fires the SettingsChanged event.

See Also

ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings.OnSettingsChanged Method

ItemSettings.OnSettingsChanged Method

Fires the SettingsChanged event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected virtual void OnSettingsChanged (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnSettingsChanged ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings Properties

ItemSettings Properties

Public Properties

Name | Description
CapIncompleteSegments | Gets or sets a value indicating whether to cap incomplete item segments.
EnableDefaultRendering | Gets or sets a value indicating whether the default item rendering is enabled.
HeaderSize | Gets or sets the size of the item header for non all-day items in the Timetable view.
ItemsVisible | Gets or sets a value indicating whether to display schedule items in the calendar.
MoveBandSize | Gets or sets the size of the move band of items in the Timetable view.
Padding | Gets or sets the amount of space between each item and the frame lines of the calendar cell that contains the item.
PaddingBottom | Gets or sets the amount of space between the bottom side of an item and bottom frame line of the calendar cell that contains the item.
PaddingLeft | Gets or sets the amount of space between the left side of an item and left frame line of the calendar cell that contains the item.
PaddingRight | Gets or sets the amount of space between the right side of an item and right frame line of the calendar cell that contains the item.
PaddingTop | Gets or sets the amount of space between the top side of an item and top frame line of the calendar cell that contains the item.
PointedItemStyle | Gets or sets the Style used to paint items when they are pointed with the mouse.
PointedSelectedItemStyle | Gets or sets the Style used to paint items when they are pointed with the mouse and selected at the same time.
ResizeBandSize | Gets or sets the size of the bands used to resize an item in a Timetable view.
ScaleClocks | Gets or sets a value indicating whether the clock icons are scaled proportionally to the size of the items.
SelectedItemStyle | Gets or sets the Style used to paint selected schedule items.
ShadowColor | Gets or sets the color of the shadow cast by the items.
ShadowOffset | Gets or set the offset of the shadows from the items that cast them.
ShadowStyle | Gets or sets the style of the shadow cast by the items.
ShowClocks | Gets or sets whether and when the clocks displaying the items' start and end time are shown.
ShowContinuationArrows | Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.
ShowMoreItemsCue | Gets or sets a value indicating whether to display a 'more items' icon in a calendar cell which isn't big enough to contain all of its items.
ShowRecurrenceExceptionIcons | Gets or sets a value indicating whether the icon of recurrence exception items is displayed.
ShowRecurrenceIcons | Gets or sets a value indicating whether the icon of recurring items is displayed.
ShowReminderIcons | Gets or sets a value indicating whether the reminder icon of items is displayed.
Size | Gets or sets the size of schedule items drawn in the calendar.
Spacing | Gets or sets the amount of space between adjacent items.
Style | Gets or sets the Style used to paint schedule items that don't have a distinct style assigned to them.
UseExtendedStyles | Gets or sets a value indicating whether the appropriate styles are used when an item is pointed with the mouse.
UseStyledText | Gets or sets a value indicating whether formatting tags such as <b> and <i> are taken into consideration in the items' description text.

See Also

ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings.CapIncompleteSegments Property

ItemSettings.CapIncompleteSegments Property

Gets or sets a value indicating whether to cap incomplete item segments.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State CapIncompleteSegments { get; set; }
Visual Basic

Public Property CapIncompleteSegments As State

Property Value

Specify Enabled to cap incomplete items segments; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

This property is ignored for non all-day items in the Timetable view.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings.EnableDefaultRendering Property

ItemSettings.EnableDefaultRendering Property

Gets or sets a value indicating whether the default item rendering is enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State EnableDefaultRendering { get; set; }
Visual Basic

Public Property EnableDefaultRendering As State

Property Value

A member of the State enumeration specifying whether the control should paint schedule items.

Remarks

You can disable this property when you perform complete custom drawing of your items and don't want the Calendar control to perform default painting. This way you can substantially optimize the performance of your application.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings.HeaderSize Property

ItemSettings.HeaderSize Property

Gets or sets the size of the item header for non all-day items in the Timetable view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderSize { get; set; }
Visual Basic

Public Property HeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the item header (in pixels). Assign -1 to this property to use the corresponding value from the current theme.

Remarks

You can assign 0 to hide the item header completely.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings.ItemsVisible Property

ItemSettings.ItemsVisible Property

Gets or sets a value indicating whether to display schedule items in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ItemsVisible { get; set; }
Visual Basic

Public Property ItemsVisible As State

Property Value

Specify Enabled to display schedule items; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings.MoveBandSize Property

ItemSettings.MoveBandSize Property

Gets or sets the size of the move band of items in the Timetable view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int MoveBandSize { get; set; }
Visual Basic

Public Property MoveBandSize As Integer

Property Value

A non-negative integer value specifying the band size in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings.Padding Property

ItemSettings.Padding Property

Gets or sets the amount of space between each item and the frame lines of the calendar cell that contains the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Padding { get; set; }
Visual Basic

Public Property Padding As Integer

Property Value

A non-negative integer value specifying how many pixels there are left between items and the time cells containing them. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

In a Timetable view this is the distance between consecutive items.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
PaddingLeft Property
PaddingTop Property
PaddingRight Property
PaddingBottom Property


MindFusion.Scheduling.WinForms.ItemSettings.PaddingBottom Property

ItemSettings.PaddingBottom Property

Gets or sets the amount of space between the bottom side of an item and bottom frame line of the calendar cell that contains the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int PaddingBottom { get; set; }
Visual Basic

Public Property PaddingBottom As Integer

Property Value

An integer value specifying the distance between the bottom side of an item and the bottom side of the cell containing it. Assign -2 to this property to use the corresponding value from the current theme. Assign -1 to indicate that this property should be ignored and the value of Padding should be regarded instead.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
Padding Property
PaddingLeft Property
PaddingTop Property
PaddingRight Property


MindFusion.Scheduling.WinForms.ItemSettings.PaddingLeft Property

ItemSettings.PaddingLeft Property

Gets or sets the amount of space between the left side of an item and left frame line of the calendar cell that contains the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int PaddingLeft { get; set; }
Visual Basic

Public Property PaddingLeft As Integer

Property Value

An integer value specifying the distance between the left side of an item and the left side of the cell containing it. Assign -2 to this property to use the corresponding value from the current theme. Assign -1 to indicate that this property should be ignored and the value of Padding should be regarded instead.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
Padding Property
PaddingTop Property
PaddingRight Property
PaddingBottom Property


MindFusion.Scheduling.WinForms.ItemSettings.PaddingRight Property

ItemSettings.PaddingRight Property

Gets or sets the amount of space between the right side of an item and right frame line of the calendar cell that contains the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int PaddingRight { get; set; }
Visual Basic

Public Property PaddingRight As Integer

Property Value

An integer value specifying the distance between the right side of an item and the right side of the cell containing it. Assign -2 to this property to use the corresponding value from the current theme. Assign -1 to indicate that this property should be ignored and the value of Padding should be regarded instead.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
Padding Property
PaddingLeft Property
PaddingTop Property
PaddingBottom Property


MindFusion.Scheduling.WinForms.ItemSettings.PaddingTop Property

ItemSettings.PaddingTop Property

Gets or sets the amount of space between the top side of an item and top frame line of the calendar cell that contains the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int PaddingTop { get; set; }
Visual Basic

Public Property PaddingTop As Integer

Property Value

An integer value specifying the distance between the top side of an item and the top side of the cell containing it. Assign -2 to this property to use the corresponding value from the current theme. Assign -1 to indicate that this property should be ignored and the value of Padding should be regarded instead.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
Padding Property
PaddingLeft Property
PaddingRight Property
PaddingBottom Property


MindFusion.Scheduling.WinForms.ItemSettings.PointedItemStyle Property

ItemSettings.PointedItemStyle Property

Gets or sets the Style used to paint items when they are pointed with the mouse.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style PointedItemStyle { get; set; }
Visual Basic

Public Property PointedItemStyle As Style

Property Value

A Style object defining the appearance of schedule items when they are pointed with the mouse. This property cannot be null.

Remarks

This property is ignored when UseExtendedStyles is set to Disabled.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
Style Property
SelectedItemStyle Property
PointedSelectedItemStyle Property
UseExtendedStyles Property


MindFusion.Scheduling.WinForms.ItemSettings.PointedSelectedItemStyle Property

ItemSettings.PointedSelectedItemStyle Property

Gets or sets the Style used to paint items when they are pointed with the mouse and selected at the same time.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style PointedSelectedItemStyle { get; set; }
Visual Basic

Public Property PointedSelectedItemStyle As Style

Property Value

A Style object defining the appearance of schedule items when they are pointed with the mouse and selected at the same time. This property cannot be null.

Remarks

This property is ignored when UseExtendedStyles is set to Disabled.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
Style Property
SelectedItemStyle Property
PointedItemStyle Property
UseExtendedStyles Property


MindFusion.Scheduling.WinForms.ItemSettings.ResizeBandSize Property

ItemSettings.ResizeBandSize Property

Gets or sets the size of the bands used to resize an item in a Timetable view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ResizeBandSize { get; set; }
Visual Basic

Public Property ResizeBandSize As Integer

Property Value

An integer value specifying the bands' size in pixels. The minimal allowed value is 2. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings.ScaleClocks Property

ItemSettings.ScaleClocks Property

Gets or sets a value indicating whether the clock icons are scaled proportionally to the size of the items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ScaleClocks { get; set; }
Visual Basic

Public Property ScaleClocks As State

Property Value

A member of the State enumeration.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings.SelectedItemStyle Property

ItemSettings.SelectedItemStyle Property

Gets or sets the Style used to paint selected schedule items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style SelectedItemStyle { get; set; }
Visual Basic

Public Property SelectedItemStyle As Style

Property Value

A Style object defining the appearance of schedule items. This property cannot be null.

Remarks

To read more about how this property affects items appearance, refer to the Customizing the Appearance of Items topic.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
Style Property
PointedItemStyle Property
PointedSelectedItemStyle Property
UseExtendedStyles Property


MindFusion.Scheduling.WinForms.ItemSettings.ShadowColor Property

ItemSettings.ShadowColor Property

Gets or sets the color of the shadow cast by the items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color ShadowColor { get; set; }
Visual Basic

Public Property ShadowColor As Color

Property Value

A .NET Color object specifying the color of item shadows. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
ShadowOffset Property
ShadowStyle Property


MindFusion.Scheduling.WinForms.ItemSettings.ShadowOffset Property

ItemSettings.ShadowOffset Property

Gets or set the offset of the shadows from the items that cast them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ShadowOffset { get; set; }
Visual Basic

Public Property ShadowOffset As Integer

Property Value

An integer value specifying with how many pixels an item's shadow is offset from the item. The allowed values range from 1 to 5. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
ShadowColor Property
ShadowStyle Property


MindFusion.Scheduling.WinForms.ItemSettings.ShadowStyle Property

ItemSettings.ShadowStyle Property

Gets or sets the style of the shadow cast by the items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ShadowStyle ShadowStyle { get; set; }
Visual Basic

Public Property ShadowStyle As ShadowStyle

Property Value

A member of the ShadowStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
ShadowColor Property
ShadowOffset Property


MindFusion.Scheduling.WinForms.ItemSettings.ShowClocks Property

ItemSettings.ShowClocks Property

Gets or sets whether and when the clocks displaying the items' start and end time are shown.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ShowClocks ShowClocks { get; set; }
Visual Basic

Public Property ShowClocks As ShowClocks

Property Value

A member of the ShowClocks enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings.ShowContinuationArrows Property

ItemSettings.ShowContinuationArrows Property

Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowContinuationArrows { get; set; }
Visual Basic

Public Property ShowContinuationArrows As State

Property Value

Specify Enabled to display arrow icons when an item continues in next time cell; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings.ShowMoreItemsCue Property

ItemSettings.ShowMoreItemsCue Property

Gets or sets a value indicating whether to display a 'more items' icon in a calendar cell which isn't big enough to contain all of its items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowMoreItemsCue { get; set; }
Visual Basic

Public Property ShowMoreItemsCue As State

Property Value

Specify Enabled to display the 'more items' cue icon when there are items not visible in the current viewport. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings.ShowRecurrenceExceptionIcons Property

ItemSettings.ShowRecurrenceExceptionIcons Property

Gets or sets a value indicating whether the icon of recurrence exception items is displayed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowRecurrenceExceptionIcons { get; set; }
Visual Basic

Public Property ShowRecurrenceExceptionIcons As State

Property Value

Specify Enabled to display an icon for the exceptions of recurring items; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
ShowRecurrenceIcons Property
ShowReminderIcons Property


MindFusion.Scheduling.WinForms.ItemSettings.ShowRecurrenceIcons Property

ItemSettings.ShowRecurrenceIcons Property

Gets or sets a value indicating whether the icon of recurring items is displayed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowRecurrenceIcons { get; set; }
Visual Basic

Public Property ShowRecurrenceIcons As State

Property Value

Specify Enabled to display an icon for recurring items; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
ShowRecurrenceExceptionIcons Property
ShowReminderIcons Property


MindFusion.Scheduling.WinForms.ItemSettings.ShowReminderIcons Property

ItemSettings.ShowReminderIcons Property

Gets or sets a value indicating whether the reminder icon of items is displayed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowReminderIcons { get; set; }
Visual Basic

Public Property ShowReminderIcons As State

Property Value

Specify Enabled to display an icon for items that have a reminder; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
ShowRecurrenceIcons Property
ShowRecurrenceExceptionIcons Property


MindFusion.Scheduling.WinForms.ItemSettings.Size Property

ItemSettings.Size Property

Gets or sets the size of schedule items drawn in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Size { get; set; }
Visual Basic

Public Property Size As Integer

Property Value

A non-negative integer value specifying items width or height in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property specifies the height of horizontal items or the width of vertical items. The items length is defined by their start time and duration. The property is ignored for items drawn in timetable view.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
Padding Property
Spacing Property


MindFusion.Scheduling.WinForms.ItemSettings.Spacing Property

ItemSettings.Spacing Property

Gets or sets the amount of space between adjacent items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Spacing { get; set; }
Visual Basic

Public Property Spacing As Integer

Property Value

A non-negative integer value specifying how many pixels there are between adjacent items. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
Padding Property


MindFusion.Scheduling.WinForms.ItemSettings.Style Property

ItemSettings.Style Property

Gets or sets the Style used to paint schedule items that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style Style { get; set; }
Visual Basic

Public Property Style As Style

Property Value

A Style object defining the appearance of schedule items. This property cannot be null.

Remarks

To read more about how this property affects items appearance, refer to the Customizing the Appearance of Items topic.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
SelectedItemStyle Property
PointedItemStyle Property
PointedSelectedItemStyle Property
UseExtendedStyles Property


MindFusion.Scheduling.WinForms.ItemSettings.UseExtendedStyles Property

ItemSettings.UseExtendedStyles Property

Gets or sets a value indicating whether the appropriate styles are used when an item is pointed with the mouse.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State UseExtendedStyles { get; set; }
Visual Basic

Public Property UseExtendedStyles As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

If this property is set to Disabled, the pointed styles (that is, PointedItemStyle and PointedSelectedItemStyle) are ignored.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace
Style Property
SelectedItemStyle Property
PointedItemStyle Property
PointedSelectedItemStyle Property


MindFusion.Scheduling.WinForms.ItemSettings.UseStyledText Property

ItemSettings.UseStyledText Property

Gets or sets a value indicating whether formatting tags such as <b> and <i> are taken into consideration in the items' description text.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State UseStyledText { get; set; }
Visual Basic

Public Property UseStyledText As State

Property Value

Specify Enabled to enable the use of formatting tags in the item's description; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. The following table lists all permissible formatting tags in the item's description.

Tag | Description
<b>text</b> | Indicates bold text.
<i>text</i> | Indicates italic text.
<u>text</u> | Indicates underlined text.
<sup>text</sup> | Indicates superscript.
<sub>text</sub> | Indicates subscript.
<color=#RRGGBB>text</color> | Changes the color of the text. The red green and blue color channels are specified as two-digit hexadecimal numbers.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings Events

ItemSettings Events

Public Events

Name | Description
SettingsChanged | Raised when an ItemSettings object has changed.

See Also

ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemSettings.SettingsChanged Event

ItemSettings.SettingsChanged Event

Raised when an ItemSettings object has changed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler SettingsChanged
Visual Basic

Public Event SettingsChanged As EventHandler

Event Data

SettingsChanged event handlers receive an argument of type EventArgs.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemTooltipEventArgs Class

ItemTooltipEventArgs Class

Contains the arguments passed to handlers of the ItemTooltipDisplaying event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class ItemTooltipEventArgs : ItemEventArgs
Visual Basic

Public Class ItemTooltipEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.WinForms.ItemTooltipEventArgs

See Also

ItemTooltipEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemTooltipEventArgs Members

ItemTooltipEventArgs Members
Properties

Contains the arguments passed to handlers of the ItemTooltipDisplaying event.

The following tables list the members exposed by the ItemTooltipEventArgs type.

Public Properties

Name | Description
Tooltip | Gets or sets the ToolTip of the item.

See Also

ItemTooltipEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemTooltipEventArgs Properties

ItemTooltipEventArgs Properties

Public Properties

Name | Description
Tooltip | Gets or sets the ToolTip of the item.

See Also

ItemTooltipEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemTooltipEventArgs.Tooltip Property

ItemTooltipEventArgs.Tooltip Property

Gets or sets the ToolTip of the item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string Tooltip { get; set; }
Visual Basic

Public Property Tooltip As String

Property Value

A string specifying the item's tool tip.

Remarks

Change this value if you need to override the default tool tip text.

See Also

ItemTooltipEventArgs Members
ItemTooltipEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemViewerAttribute Class

ItemViewerAttribute Class

Associates a custom item viewer with a schedule item class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class ItemViewerAttribute : Attribute
Visual Basic

Public NotInheritable Class ItemViewerAttribute
Inherits Attribute

Inheritance Hierarchy

System.Object
System.Attribute
MindFusion.Scheduling.WinForms.ItemViewerAttribute

See Also

ItemViewerAttribute Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemViewerAttribute Members

ItemViewerAttribute Members
Constructors Properties

Associates a custom item viewer with a schedule item class.

The following tables list the members exposed by the ItemViewerAttribute type.

Public Constructors

Name | Description
ItemViewerAttribute | Overloaded. Initializes a new instance of the ItemViewerAttribute class.

Public Properties

Name | Description
ViewerType | Gets or sets the type of the item viewer associated with an item class.
ViewerTypeName | Gets or sets the type name of the item viewer associated with an item class.

See Also

ItemViewerAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemViewerAttribute Constructor

ItemViewerAttribute Constructor

Initializes a new instance of the ItemViewerAttribute class.

Overload List

Name | Description
ItemViewerAttribute (String) | Initializes a new instance of the ItemViewerAttribute class.
ItemViewerAttribute (Type) | Initialize a new instance of the ItemViewerAttribute class.

See Also

ItemViewerAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemViewerAttribute Constructor (String)

ItemViewerAttribute Constructor (String)
See Also

Initializes a new instance of the ItemViewerAttribute class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemViewerAttribute (
string viewerTypeName
)
Visual Basic

Public New ( _
viewerTypeName As String _
)

Parameters

viewerTypeName

A string containing the fully qualified name of the type to be used as an item viewer.

See Also

ItemViewerAttribute Constructor Overload List
ItemViewerAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemViewerAttribute Constructor (Type)

ItemViewerAttribute Constructor (Type)
See Also

Initialize a new instance of the ItemViewerAttribute class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemViewerAttribute (
Type viewerType
)
Visual Basic

Public New ( _
viewerType As Type _
)

Parameters

viewerType
An instance of the .NET Type class specifying the custom viewer class.

Remarks

The custom viewer class must implement the IItemViewer interface.

See Also

ItemViewerAttribute Constructor Overload List
ItemViewerAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemViewerAttribute Properties

ItemViewerAttribute Properties

Public Properties

Name | Description
ViewerType | Gets or sets the type of the item viewer associated with an item class.
ViewerTypeName | Gets or sets the type name of the item viewer associated with an item class.

See Also

ItemViewerAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemViewerAttribute.ViewerType Property

ItemViewerAttribute.ViewerType Property

Gets or sets the type of the item viewer associated with an item class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Type ViewerType { get; }
Visual Basic

Public ReadOnly Property ViewerType As Type

Property Value

An instance of the .NET Type class specifying the custom viewer class.

Remarks

The custom viewer class must implement the IItemViewer interface.

See Also

ItemViewerAttribute Members
ItemViewerAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ItemViewerAttribute.ViewerTypeName Property

ItemViewerAttribute.ViewerTypeName Property

Gets or sets the type name of the item viewer associated with an item class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string ViewerTypeName { get; }
Visual Basic

Public ReadOnly Property ViewerTypeName As String

Property Value

A string containing the fully qualified name of the type that specifies the custom viewer class.

Remarks

The custom viewer class must implement the IItemViewer interface.

See Also

ItemViewerAttribute Members
ItemViewerAttribute Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.LineStyle Enumeration

LineStyle Enumeration

Specifies the style of lines.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum LineStyle
Visual Basic

Public Enumeration LineStyle

Members

Member name | Description
Dotted | Specifies dotted style. This value is available only in MindFusion.Scheduling.
Invisible | Specifies invisible style.
Solid | Specifies solid style.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewHeaderStyles Enumeration

ListViewHeaderStyles Enumeration

Specifies the appearance and behavior of the header in a List view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum ListViewHeaderStyles
Visual Basic

Public Enumeration ListViewHeaderStyles

Members

Member name | Description
None | Do not display a header.
Subheader | Draw a sub-header below the main header. The subheader can be customized through the SubHeaderSize, SubTitleFormat and SubHeaderDivisions properties of the ListViewSettings class.
SubheaderPerCell | Draw the header background for each cell separately, rather than for the whole interval.
Title | Display the cells' dates in the header.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings Class

ListViewSettings Class

Defines properties that allow customizing the visualization of the calendar in a List view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class ListViewSettings : ViewSettings
Visual Basic

Public NotInheritable Class ListViewSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.ViewSettings
MindFusion.Scheduling.WinForms.ListViewSettings

See Also

ListViewSettings Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings Members

ListViewSettings Members
Properties

Defines properties that allow customizing the visualization of the calendar in a List view.

The following tables list the members exposed by the ListViewSettings type.

Public Properties

Name | Description
CellSettings | Gets a CellSettings object used to customize the visualization of cells in the List view.
CellSpacing | Gets or sets the amount space between adjacent cells.
CellUnits | Gets or sets the resolution of the list view.
ContentsMargin | Gets or sets the amount of space between the contents border and the actual contents of the view.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EnableVirtualItemSpace | Gets or sets a value indicating whether items in the list view can be scrolled through.
EvenWeeksBrush | Gets or sets the brush used to paint the background of the contents of even weeks.
FreeDrag | Gets or sets a value indicating whether users can drag items anywhere in the view, not only in the first unoccupied row.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the headers of individual columns.
HeaderShadowColor | Gets or sets the color of the shadows cast by headers.
HeaderShadowOffset | Gets or sets the offset of the shadows from the headers that cast them.
HeaderShadowStyle | Gets or sets the style of the shadows cast by headers.
HeaderSize | Gets or sets the header size in pixels.
HeaderStyle | Gets or sets the style of the List view header.
ItemOrientation | Gets or sets a value indicating whether the items are displayed horizontally, vertically or according to the orientation of the view.
NumberOfCells | Gets or sets the total number of cells to be displayed in the List view.
OddWeeksBrush | Gets or sets the brush used to paint the background of the contents of odd weeks.
Orientation | Gets or sets a value indicating whether the cells are displayed horizontally or vertically.
RotateHeaderTexts | Gets or sets a value indicating whether the header texts in a horizontal list view are rotated.
ScrollStep | Gets or sets the number of units to scroll when the user clicks the navigation buttons.
ShowGroupHeader | Gets or sets a value indicating whether to display the resource grouping header.
ShowNavigationButtons | Gets or sets a value indicating whether the List view displays navigation buttons.
SnapUnit | Gets or sets the snap unit.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubHeaderDivisions | Gets or sets the number of divisions in the sub-header.
SubHeaderSize | Gets or sets the subheader size in pixels.
SubTitleFormat | Gets or sets a string used to format the cells subtitles.
TitleFormat | Gets or sets a string used to format the cells titles.
TotalLaneCount | Gets or sets the number of lanes in a List view whose EnableVirtualItemSpace is set to Enabled.
VisibleCells | Gets or sets the number of cells visible at the same time.
VisibleColumns | Gets or sets the number of visible group columns in a list view.

See Also

ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings Properties

ListViewSettings Properties

Public Properties

Name | Description
CellSettings | Gets a CellSettings object used to customize the visualization of cells in the List view.
CellSpacing | Gets or sets the amount space between adjacent cells.
CellUnits | Gets or sets the resolution of the list view.
ContentsMargin | Gets or sets the amount of space between the contents border and the actual contents of the view.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EnableVirtualItemSpace | Gets or sets a value indicating whether items in the list view can be scrolled through.
EvenWeeksBrush | Gets or sets the brush used to paint the background of the contents of even weeks.
FreeDrag | Gets or sets a value indicating whether users can drag items anywhere in the view, not only in the first unoccupied row.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the headers of individual columns.
HeaderShadowColor | Gets or sets the color of the shadows cast by headers.
HeaderShadowOffset | Gets or sets the offset of the shadows from the headers that cast them.
HeaderShadowStyle | Gets or sets the style of the shadows cast by headers.
HeaderSize | Gets or sets the header size in pixels.
HeaderStyle | Gets or sets the style of the List view header.
ItemOrientation | Gets or sets a value indicating whether the items are displayed horizontally, vertically or according to the orientation of the view.
NumberOfCells | Gets or sets the total number of cells to be displayed in the List view.
OddWeeksBrush | Gets or sets the brush used to paint the background of the contents of odd weeks.
Orientation | Gets or sets a value indicating whether the cells are displayed horizontally or vertically.
RotateHeaderTexts | Gets or sets a value indicating whether the header texts in a horizontal list view are rotated.
ScrollStep | Gets or sets the number of units to scroll when the user clicks the navigation buttons.
ShowGroupHeader | Gets or sets a value indicating whether to display the resource grouping header.
ShowNavigationButtons | Gets or sets a value indicating whether the List view displays navigation buttons.
SnapUnit | Gets or sets the snap unit.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubHeaderDivisions | Gets or sets the number of divisions in the sub-header.
SubHeaderSize | Gets or sets the subheader size in pixels.
SubTitleFormat | Gets or sets a string used to format the cells subtitles.
TitleFormat | Gets or sets a string used to format the cells titles.
TotalLaneCount | Gets or sets the number of lanes in a List view whose EnableVirtualItemSpace is set to Enabled.
VisibleCells | Gets or sets the number of cells visible at the same time.
VisibleColumns | Gets or sets the number of visible group columns in a list view.

See Also

ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.CellSettings Property

ListViewSettings.CellSettings Property

Gets a CellSettings object used to customize the visualization of cells in the List view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public CellSettings CellSettings { get; }
Visual Basic

Public ReadOnly Property CellSettings As CellSettings

Property Value

An instance of the CellSettings class.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.CellSpacing Property

ListViewSettings.CellSpacing Property

Gets or sets the amount space between adjacent cells.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int CellSpacing { get; set; }
Visual Basic

Public Property CellSpacing As Integer

Property Value

A non-negative integer value specifying how much space to leave (expressed in pixels). Assign -1 to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.CellUnits Property

ListViewSettings.CellUnits Property

Gets or sets the resolution of the list view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimeUnit CellUnits { get; set; }
Visual Basic

Public Property CellUnits As TimeUnit

Property Value

A member of the TimeUnit enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.ContentsMargin Property

ListViewSettings.ContentsMargin Property

Gets or sets the amount of space between the contents border and the actual contents of the view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ContentsMargin { get; set; }
Visual Basic

Public Property ContentsMargin As Integer

Property Value

A non-negative integer value defining the border space in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.EnableSnapping Property

ListViewSettings.EnableSnapping Property

Gets or sets a value indicating whether custom snapping is enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State EnableSnapping { get; set; }
Visual Basic

Public Property EnableSnapping As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

When this property is enabled, the users will move and resize items with the precision specified in the SnapUnit property instead of the precision of the view's resolution. When this property is disabled, the items will snap automatically to the border of their containing cells.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
SnapUnit Property


MindFusion.Scheduling.WinForms.ListViewSettings.EnableVirtualItemSpace Property

ListViewSettings.EnableVirtualItemSpace Property

Gets or sets a value indicating whether items in the list view can be scrolled through.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State EnableVirtualItemSpace { get; set; }
Visual Basic

Public Property EnableVirtualItemSpace As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Use this property to override the default behavior of the vertical scrollbar (in a horizontal List view) or the horizontal scrollbar (in a vertical List view). When this property is enabled, the appropriate scrollbar will scroll through the items that are not visible within the view (due to insufficient space) rather than scroll through the cells associated with resources in a grouped List view.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
FreeDrag Property


MindFusion.Scheduling.WinForms.ListViewSettings.EvenWeeksBrush Property

ListViewSettings.EvenWeeksBrush Property

Gets or sets the brush used to paint the background of the contents of even weeks.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush EvenWeeksBrush { get; set; }
Visual Basic

Public Property EvenWeeksBrush As Brush

Property Value

An instance of a Brush-derived class. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
OddWeeksBrush Property


MindFusion.Scheduling.WinForms.ListViewSettings.FreeDrag Property

ListViewSettings.FreeDrag Property

Gets or sets a value indicating whether users can drag items anywhere in the view, not only in the first unoccupied row.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State FreeDrag { get; set; }
Visual Basic

Public Property FreeDrag As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Set this property to Enabled to disable the default item layout algorithm, where colliding items are arranged relative to each other according to their start and end times and their Priority. Turning this property on will allow users to move items anywhere within the view.

The position of an item acquired through free dragging is related to the view. This means that if the schedule, containing the item is displayed in another Calendar control, the item's position within the List view might not be the same as its position in the initial view. Additionally, view-related data is not serialized by calling the serialization methods of the Schedule class. In order to serialize and deserialize this data, you have to invoke the SaveTo and LoadFrom methods of the Calendar class instead.

Finally, the position of an item within the view can be obtained and set programmatically through the use of the GetItemListLane and SetItemListLane methods of the Calendar class.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.GroupHeaderSize Property

ListViewSettings.GroupHeaderSize Property

Gets or sets the size of the group header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int GroupHeaderSize { get; set; }
Visual Basic

Public Property GroupHeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the calendar to automatically calculate a header size based on the size of the header font.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
ShowGroupHeader Property


MindFusion.Scheduling.WinForms.ListViewSettings.GroupHeaderStyle Property

ListViewSettings.GroupHeaderStyle Property

Gets or sets the appearance style used to paint the headers of individual columns.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style GroupHeaderStyle { get; set; }
Visual Basic

Public Property GroupHeaderStyle As Style

Property Value

A Style object specifying the style of the column headers. This property cannot be null.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.HeaderShadowColor Property

ListViewSettings.HeaderShadowColor Property

Gets or sets the color of the shadows cast by headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color HeaderShadowColor { get; set; }
Visual Basic

Public Property HeaderShadowColor As Color

Property Value

A .NET Color object specifying the shadow color. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowOffset Property
HeaderShadowStyle Property


MindFusion.Scheduling.WinForms.ListViewSettings.HeaderShadowOffset Property

ListViewSettings.HeaderShadowOffset Property

Gets or sets the offset of the shadows from the headers that cast them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderShadowOffset { get; set; }
Visual Basic

Public Property HeaderShadowOffset As Integer

Property Value

An integer value specifying the distance between a header and its shadow. The allowed values range from 1 to 5. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowColor Property
HeaderShadowStyle Property


MindFusion.Scheduling.WinForms.ListViewSettings.HeaderShadowStyle Property

ListViewSettings.HeaderShadowStyle Property

Gets or sets the style of the shadows cast by headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ShadowStyle HeaderShadowStyle { get; set; }
Visual Basic

Public Property HeaderShadowStyle As ShadowStyle

Property Value

A member of the ShadowStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowColor Property
HeaderShadowOffset Property


MindFusion.Scheduling.WinForms.ListViewSettings.HeaderSize Property

ListViewSettings.HeaderSize Property

Gets or sets the header size in pixels.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderSize { get; set; }
Visual Basic

Public Property HeaderSize As Integer

Property Value

A non-negative integer value specifying the header size. A value of 0 hides the header. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property specifies the header width if Orientation is Horizontal or the height if Orientation is Vertical.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderStyle Property
TitleFormat Property


MindFusion.Scheduling.WinForms.ListViewSettings.HeaderStyle Property

ListViewSettings.HeaderStyle Property

Gets or sets the style of the List view header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ListViewHeaderStyles HeaderStyle { get; set; }
Visual Basic

Public Property HeaderStyle As ListViewHeaderStyles

Property Value

A member of the ListViewHeaderStyles enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderSize Property
TitleFormat Property


MindFusion.Scheduling.WinForms.ListViewSettings.ItemOrientation Property

ListViewSettings.ItemOrientation Property

Gets or sets a value indicating whether the items are displayed horizontally, vertically or according to the orientation of the view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Orientation ItemOrientation { get; set; }
Visual Basic

Public Property ItemOrientation As Orientation

Property Value

A member of the Orientation enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Items are usually oriented according to the view's Orientation. That is, items are horizontal in a horizontal List view and vice versa. The orientation of the items can be explicitly specified by using this property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.NumberOfCells Property

ListViewSettings.NumberOfCells Property

Gets or sets the total number of cells to be displayed in the List view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int NumberOfCells { get; set; }
Visual Basic

Public Property NumberOfCells As Integer

Property Value

An integer value specifying how many days to display. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This value cannot be less than 1 or less than the number of visible days set in the VisibleCells property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
VisibleCells Property


MindFusion.Scheduling.WinForms.ListViewSettings.OddWeeksBrush Property

ListViewSettings.OddWeeksBrush Property

Gets or sets the brush used to paint the background of the contents of odd weeks.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush OddWeeksBrush { get; set; }
Visual Basic

Public Property OddWeeksBrush As Brush

Property Value

An instance of a Brush-derived class. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
EvenWeeksBrush Property


MindFusion.Scheduling.WinForms.ListViewSettings.Orientation Property

ListViewSettings.Orientation Property

Gets or sets a value indicating whether the cells are displayed horizontally or vertically.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Orientation Orientation { get; set; }
Visual Basic

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

If this property is set to Horizontal, the view header is displayed at the top and the day cells are arranged in a horizontal row underneath it. If set to Vertical, the header is displayed on the left side and the days are arranged in a vertical row on the right.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.RotateHeaderTexts Property

ListViewSettings.RotateHeaderTexts Property

Gets or sets a value indicating whether the header texts in a horizontal list view are rotated.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State RotateHeaderTexts { get; set; }
Visual Basic

Public Property RotateHeaderTexts As State

Property Value

Specify Enabled to display the header text rotated; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.ScrollStep Property

ListViewSettings.ScrollStep Property

Gets or sets the number of units to scroll when the user clicks the navigation buttons.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ScrollStep { get; set; }
Visual Basic

Public Property ScrollStep As Integer

Property Value

An integer value specifying the number of units to scroll. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property specifies the amount of units (as specified by the CellUnits property) to scroll back and forth when using the navigation buttons in the List view.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
ShowNavigationButtons Property


MindFusion.Scheduling.WinForms.ListViewSettings.ShowGroupHeader Property

ListViewSettings.ShowGroupHeader Property

Gets or sets a value indicating whether to display the resource grouping header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowGroupHeader { get; set; }
Visual Basic

Public Property ShowGroupHeader As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
GroupHeaderSize Property


MindFusion.Scheduling.WinForms.ListViewSettings.ShowNavigationButtons Property

ListViewSettings.ShowNavigationButtons Property

Gets or sets a value indicating whether the List view displays navigation buttons.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowNavigationButtons { get; set; }
Visual Basic

Public Property ShowNavigationButtons As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

The size of the buttons can be controlled through the ButtonSize property of the Calendar class. The amount of units to scroll can be specified through the ScrollStep property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
ScrollStep Property


MindFusion.Scheduling.WinForms.ListViewSettings.SnapUnit Property

ListViewSettings.SnapUnit Property

Gets or sets the snap unit.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimeUnit SnapUnit { get; set; }
Visual Basic

Public Property SnapUnit As TimeUnit

Property Value

A member of the TimeUnit enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Use this property in a conjunction with the EnableSnapping property to specify the precision with which users can move and resize items interactively. If EnableSnapping is set to Disabled the value of this property is ignored and items snap to cell borders.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
EnableSnapping Property


MindFusion.Scheduling.WinForms.ListViewSettings.Style Property

ListViewSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. This property cannot be null.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
Style Class


MindFusion.Scheduling.WinForms.ListViewSettings.SubHeaderDivisions Property

ListViewSettings.SubHeaderDivisions Property

Gets or sets the number of divisions in the sub-header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int SubHeaderDivisions { get; set; }
Visual Basic

Public Property SubHeaderDivisions As Integer

Property Value

An integer value specifying the number of cells in the subheader. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

The value of this property is used only when the subheader of the List view is displayed (as specified by the HeaderStyle property). The value specifies the number of cells in the subheader. The date in each cell is calculated automatically and is displayed according to the SubTitleFormat property.

Example

The following example demonstrates how to setup a List view to display a week in each cell and the days of the week in the subheader. The example assumes that the variable calendar references an existing Calendar instance.

C#

calendar.CurrentView = CalendarView.List;
calendar.ListViewSettings.CellUnits = TimeUnit.Week;
calendar.ListViewSettings.CellSettings.HeaderPosition = Position.None;
calendar.ListViewSettings.TitleFormat = "dd, MMM";
calendar.ListViewSettings.Orientation = MindFusion.Scheduling.WinForms.Orientation.Horizontal;
calendar.ListViewSettings.HeaderStyle = ListViewHeaderStyles.Subheader |
ListViewHeaderStyles.SubheaderPerCell | ListViewHeaderStyles.Title;
calendar.ListViewSettings.SubHeaderDivisions = 7;
calendar.ListViewSettings.SubTitleFormat = "w1";
Visual Basic

calendar.CurrentView = CalendarView.List
calendar.ListViewSettings.CellUnits = TimeUnit.Week
calendar.ListViewSettings.CellSettings.HeaderPosition = Position.None
calendar.ListViewSettings.TitleFormat = "dd, MMM"
calendar.ListViewSettings.Orientation = MindFusion.Scheduling.WinForms.Orientation.Horizontal
calendar.ListViewSettings.HeaderStyle = ListViewHeaderStyles.Subheader Or _
ListViewHeaderStyles.SubheaderPerCell Or ListViewHeaderStyles.Title
calendar.ListViewSettings.SubHeaderDivisions = 7
calendar.ListViewSettings.SubTitleFormat = "w1"

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderStyle Property
SubHeaderSize Property
SubTitleFormat Property


MindFusion.Scheduling.WinForms.ListViewSettings.SubHeaderSize Property

ListViewSettings.SubHeaderSize Property

Gets or sets the subheader size in pixels.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int SubHeaderSize { get; set; }
Visual Basic

Public Property SubHeaderSize As Integer

Property Value

A non-negative integer value specifying the subheader size. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property specifies the subheader width if Orientation is Horizontal or the height if Orientation is Vertical.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderStyle Property
SubHeaderDivisions Property
SubTitleFormat Property


MindFusion.Scheduling.WinForms.ListViewSettings.SubTitleFormat Property

ListViewSettings.SubTitleFormat Property

Gets or sets a string used to format the cells subtitles.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string SubTitleFormat { get; set; }
Visual Basic

Public Property SubTitleFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic. Additionally, the "w1" format specifier can be used to display only the first letter of the day of the week (that is, 'M' for Monday, 'T' for Tuesday, and so on). This specifier cannot be combined with other specifiers, it can be used only by its own.

Example

The following example demonstrates how to setup a List view to display a week in each cell and the days of the week in the subheader. The example assumes that the variable calendar references an existing Calendar instance.

C#

calendar.CurrentView = CalendarView.List;
calendar.ListViewSettings.CellUnits = TimeUnit.Week;
calendar.ListViewSettings.CellSettings.HeaderPosition = Position.None;
calendar.ListViewSettings.TitleFormat = "dd, MMM";
calendar.ListViewSettings.Orientation = MindFusion.Scheduling.WinForms.Orientation.Horizontal;
calendar.ListViewSettings.HeaderStyle = ListViewHeaderStyles.Subheader |
ListViewHeaderStyles.SubheaderPerCell | ListViewHeaderStyles.Title;
calendar.ListViewSettings.SubHeaderDivisions = 7;
calendar.ListViewSettings.SubTitleFormat = "w1";
Visual Basic

calendar.CurrentView = CalendarView.List
calendar.ListViewSettings.CellUnits = TimeUnit.Week
calendar.ListViewSettings.CellSettings.HeaderPosition = Position.None
calendar.ListViewSettings.TitleFormat = "dd, MMM"
calendar.ListViewSettings.Orientation = MindFusion.Scheduling.WinForms.Orientation.Horizontal
calendar.ListViewSettings.HeaderStyle = ListViewHeaderStyles.Subheader Or _
ListViewHeaderStyles.SubheaderPerCell Or ListViewHeaderStyles.Title
calendar.ListViewSettings.SubHeaderDivisions = 7
calendar.ListViewSettings.SubTitleFormat = "w1"

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.TitleFormat Property

ListViewSettings.TitleFormat Property

Gets or sets a string used to format the cells titles.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string TitleFormat { get; set; }
Visual Basic

Public Property TitleFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.TotalLaneCount Property

ListViewSettings.TotalLaneCount Property

Gets or sets the number of lanes in a List view whose EnableVirtualItemSpace is set to Enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int TotalLaneCount { get; set; }
Visual Basic

Public Property TotalLaneCount As Integer

Property Value

A non-negative integer value specifying the number of lanes in the view. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

When this property is set to 0, the item scrollbar is automatically adjusted so that it covers all existing items. Otherwise the item scrollbar is adjusted so that it covers the specified number of lanes.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
EnableVirtualItemSpace Property


MindFusion.Scheduling.WinForms.ListViewSettings.VisibleCells Property

ListViewSettings.VisibleCells Property

Gets or sets the number of cells visible at the same time.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int VisibleCells { get; set; }
Visual Basic

Public Property VisibleCells As Integer

Property Value

A positive integer value specifying how many days to display simultaneously in the day range view. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

The value assigned to this property cannot be less than 1 or less than the total number of days available in the view, as specified in the NumberOfCells property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace
NumberOfCells Property


MindFusion.Scheduling.WinForms.ListViewSettings.VisibleColumns Property

ListViewSettings.VisibleColumns Property

Gets or sets the number of visible group columns in a list view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int VisibleColumns { get; set; }
Visual Basic

Public Property VisibleColumns As Integer

Property Value

A positive integer value specifying the number of columns visible at the same time. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property is actually used only in a grouped day range view. Otherwise, the number of columns in the view is always 1.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MinuteFormat Enumeration

MinuteFormat Enumeration

Specifies how to format and display minutes in the Timetable view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum MinuteFormat
Visual Basic

Public Enumeration MinuteFormat

Members

Member name | Description
Colons | Display a colon and a leading zero.
LeadingZero | Display a leading zero for single digit minutes.
NoLeadingZero | No leading zero for single digit minutes.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthCellLayout Enumeration

MonthCellLayout Enumeration

Specifies the layout of the cells in a SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum MonthCellLayout
Visual Basic

Public Enumeration MonthCellLayout

Members

Member name | Description
Grid | Indicates that the cells are laid out in a grid, where each row in the grid contains the days of a single week.
Linear | Indicates that the cells are laid out in a single row.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthHeaderStyles Enumeration

MonthHeaderStyles Enumeration

Specifies the appearance and behavior of month headers in a SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum MonthHeaderStyles
Visual Basic

Public Enumeration MonthHeaderStyles

Members

Member name | Description
MonthButtons | Display buttons for scrolling to previous or next month.
None | Do not display the header.
SubheaderPerDay | The sub headers are drawn separately for each day, rather than for the whole interval.
Title | Display the date of the month in the header.
Unspecified | Unspecified.
YearButtons | Display buttons for scrolling to previous or next year.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthRangeHeaderStyles Enumeration

MonthRangeHeaderStyles Enumeration

Specifies the appearance and behavior of the header in a MonthRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum MonthRangeHeaderStyles
Visual Basic

Public Enumeration MonthRangeHeaderStyles

Members

Member name | Description
Buttons | The header displays buttons that can be used to scroll to previous and following moths.
None | The header is not displayed.
Title | The header displays the start and end dates.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthRangeSettings Class

MonthRangeSettings Class

Defines settings for the years in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class MonthRangeSettings : ViewSettings
Visual Basic

Public NotInheritable Class MonthRangeSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.ViewSettings
MindFusion.Scheduling.WinForms.MonthRangeSettings

See Also

MonthRangeSettings Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthRangeSettings Members

MonthRangeSettings Members
Properties

Defines settings for the years in the calendar.

The following tables list the members exposed by the MonthRangeSettings type.

Public Properties

Name | Description
ContentsMargin | Gets or sets the amount of space between the contents border and the actual contents of the view.
HeaderHeight | Gets or sets the height of the header in a MonthRange view.
HeaderShadowColor | Gets or sets the color of the shadows cast by headers.
HeaderShadowOffset | Gets or sets the offset of the shadows from the headers that cast them.
HeaderShadowStyle | Gets or sets the style of the shadows cast by headers.
HeaderSpacing | Gets or sets the amount of space between the headers.
HeaderStyle | Gets or sets the style of the MonthRange view header.
Margin | Gets or sets the amount of space between the outermost border of the view and its contents.
MonthSpacing | Gets or sets the amount of space between adjacent months.
MonthsPerRow | Gets or sets the number of months to be displayed in a row.
NumberOfMonths | Gets or sets the number of months to display in the MonthRange view.
ScrollInterval | Gets or sets the number of months to scroll the view back or forth in time when a scroll button is pressed.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TitleFormat | Gets or sets the string used to format the month titles.
TitleSeparator | Gets or sets the string used as a title separator in a MonthRange view that displays more than 1 month at a time.
VisibleRows | Gets or sets the number of rows to display at the same time.

See Also

MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthRangeSettings Properties

MonthRangeSettings Properties

Public Properties

Name | Description
ContentsMargin | Gets or sets the amount of space between the contents border and the actual contents of the view.
HeaderHeight | Gets or sets the height of the header in a MonthRange view.
HeaderShadowColor | Gets or sets the color of the shadows cast by headers.
HeaderShadowOffset | Gets or sets the offset of the shadows from the headers that cast them.
HeaderShadowStyle | Gets or sets the style of the shadows cast by headers.
HeaderSpacing | Gets or sets the amount of space between the headers.
HeaderStyle | Gets or sets the style of the MonthRange view header.
Margin | Gets or sets the amount of space between the outermost border of the view and its contents.
MonthSpacing | Gets or sets the amount of space between adjacent months.
MonthsPerRow | Gets or sets the number of months to be displayed in a row.
NumberOfMonths | Gets or sets the number of months to display in the MonthRange view.
ScrollInterval | Gets or sets the number of months to scroll the view back or forth in time when a scroll button is pressed.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TitleFormat | Gets or sets the string used to format the month titles.
TitleSeparator | Gets or sets the string used as a title separator in a MonthRange view that displays more than 1 month at a time.
VisibleRows | Gets or sets the number of rows to display at the same time.

See Also

MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthRangeSettings.ContentsMargin Property

MonthRangeSettings.ContentsMargin Property

Gets or sets the amount of space between the contents border and the actual contents of the view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ContentsMargin { get; set; }
Visual Basic

Public Property ContentsMargin As Integer

Property Value

A non-negative integer value specifying how many pixels to leave between the contents border and the time cells. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderSpacing Property
Margin Property
MonthSpacing Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.HeaderHeight Property

MonthRangeSettings.HeaderHeight Property

Gets or sets the height of the header in a MonthRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderHeight { get; set; }
Visual Basic

Public Property HeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the calendar control to automatically calculate the header height based on the size of the header font.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderStyle Property
TitleFormat Property
TitleSeparator Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.HeaderShadowColor Property

MonthRangeSettings.HeaderShadowColor Property

Gets or sets the color of the shadows cast by headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color HeaderShadowColor { get; set; }
Visual Basic

Public Property HeaderShadowColor As Color

Property Value

A .NET Color object specifying the color of headers' shadows. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowOffset Property
HeaderShadowStyle Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.HeaderShadowOffset Property

MonthRangeSettings.HeaderShadowOffset Property

Gets or sets the offset of the shadows from the headers that cast them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderShadowOffset { get; set; }
Visual Basic

Public Property HeaderShadowOffset As Integer

Property Value

An integer value specifying with how many pixels to offset a header's shadow from the header. The allowed values range from 1 to 5. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowColor Property
HeaderShadowStyle Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.HeaderShadowStyle Property

MonthRangeSettings.HeaderShadowStyle Property

Gets or sets the style of the shadows cast by headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ShadowStyle HeaderShadowStyle { get; set; }
Visual Basic

Public Property HeaderShadowStyle As ShadowStyle

Property Value

A member of the ShadowStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowColor Property
HeaderShadowOffset Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.HeaderSpacing Property

MonthRangeSettings.HeaderSpacing Property

Gets or sets the amount of space between the headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderSpacing { get; set; }
Visual Basic

Public Property HeaderSpacing As Integer

Property Value

An integer value specifying how many pixels there are between adjacent headers. The minimal allowed value is -1. Assign -2 to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
ContentsMargin Property
Margin Property
MonthSpacing Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.HeaderStyle Property

MonthRangeSettings.HeaderStyle Property

Gets or sets the style of the MonthRange view header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public MonthRangeHeaderStyles HeaderStyle { get; set; }
Visual Basic

Public Property HeaderStyle As MonthRangeHeaderStyles

Property Value

A member of the MonthRangeHeaderStyles enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderHeight Property
TitleFormat Property
TitleSeparator Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.Margin Property

MonthRangeSettings.Margin Property

Gets or sets the amount of space between the outermost border of the view and its contents.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Margin { get; set; }
Visual Basic

Public Property Margin As Integer

Property Value

A non-negative integer value specifying how many pixels there are between the view contents and the outermost view border. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
ContentsMargin Property
HeaderSpacing Property
MonthSpacing Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.MonthSpacing Property

MonthRangeSettings.MonthSpacing Property

Gets or sets the amount of space between adjacent months.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int MonthSpacing { get; set; }
Visual Basic

Public Property MonthSpacing As Integer

Property Value

A non-negative integer value specifying how many pixels there are between adjacent month cells. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
ContentsMargin Property
HeaderSpacing Property
Margin Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.MonthsPerRow Property

MonthRangeSettings.MonthsPerRow Property

Gets or sets the number of months to be displayed in a row.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int MonthsPerRow { get; set; }
Visual Basic

Public Property MonthsPerRow As Integer

Property Value

An integer value specifying how many months are displayed in a row in the month range view. The allowed values range from 1 to 12. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

If this value multiplied by VisibleRows is larger than NumberOfMonths, the calendar control displays scrollbars letting users scroll the view up and down.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
VisibleRows Property
NumberOfMonths Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.NumberOfMonths Property

MonthRangeSettings.NumberOfMonths Property

Gets or sets the number of months to display in the MonthRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int NumberOfMonths { get; set; }
Visual Basic

Public Property NumberOfMonths As Integer

Property Value

A positive integer value specifying how many months to display in the view. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

If the number of months is set larger than number of rows multiplied by MonthsPerRow, the calendar displays scrollbar, letting users scroll the view up and down.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
VisibleRows Property
MonthsPerRow Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.ScrollInterval Property

MonthRangeSettings.ScrollInterval Property

Gets or sets the number of months to scroll the view back or forth in time when a scroll button is pressed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ScrollInterval { get; set; }
Visual Basic

Public Property ScrollInterval As Integer

Property Value

A positive integer value specifying with how many months to scroll the view. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthRangeSettings.Style Property

MonthRangeSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. This property cannot be null.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthRangeSettings.TitleFormat Property

MonthRangeSettings.TitleFormat Property

Gets or sets the string used to format the month titles.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string TitleFormat { get; set; }
Visual Basic

Public Property TitleFormat As String

Property Value

A string specifying the display format. Assign null to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
TitleSeparator Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.TitleSeparator Property

MonthRangeSettings.TitleSeparator Property

Gets or sets the string used as a title separator in a MonthRange view that displays more than 1 month at a time.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string TitleSeparator { get; set; }
Visual Basic

Public Property TitleSeparator As String

Property Value

A string containing the separator text. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format of the text displayed in the view's header is in the format "<FirstDate><TitleSeparator><LastDate>", where <FirstDate> and <LastDate> indicate the first and the last visible dates in the calendar, formatted according to the TitleFormat property. The <TitleSeparator> represents the value of this property. If TitleSeparator is set to an empty string, then the header's text is only "<FirstDate>". See the example below for more information.

Example

The following example shows how to display only the current year in the header of a MonthRange view. The sample assumes that calendar references an existing Calendar object.

C#

calendar.MonthRangeSettings.TitleFormat = "yyyy";
calendar.MonthRangeSettings.TitleSeparator = "";
Visual Basic

calendar.MonthRangeSettings.TitleFormat = "yyyy"
calendar.MonthRangeSettings.TitleSeparator = ""

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
TitleFormat Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.VisibleRows Property

MonthRangeSettings.VisibleRows Property

Gets or sets the number of rows to display at the same time.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int VisibleRows { get; set; }
Visual Basic

Public Property VisibleRows As Integer

Property Value

A positive integer value specifying how many rows of month cells to display. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
MonthsPerRow Property
NumberOfMonths Property


MindFusion.Scheduling.WinForms.MonthSettings Class

MonthSettings Class

Defines properties that allow customizing the visualization of months in the SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class MonthSettings : ViewSettings
Visual Basic

Public NotInheritable Class MonthSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.ViewSettings
MindFusion.Scheduling.WinForms.MonthSettings

See Also

MonthSettings Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings Members

MonthSettings Members
Properties

Defines properties that allow customizing the visualization of months in the SingleMonth and MonthRange views.

The following tables list the members exposed by the MonthSettings type.

Public Properties

Name | Description
CellLayout | Gets or sets the layout of the cells in SingleMonth and MonthRange views.
ContentsMargin | Gets or sets the amount of space between the month's day cells and the month's bounding rectangle.
DayOfWeekFormat | Gets or sets the format of the day names displayed in the week header.
DaySettings | Gets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.
DaySpacing | Gets or sets the amount of space between adjacent days.
HeaderShadowColor | Gets or sets the color of the shadow cast by headers.
HeaderShadowOffset | Gets or sets the offset of the shadows from the headers that cast them.
HeaderShadowStyle | Gets or sets the style of the shadows cast by headers.
HeaderSpacing | Gets or sets the amount of space between headers.
HeaderStyle | Gets or sets the style of the month's header.
HideTrailingWeeks | Gets or sets a value indicating whether to hide trailing weeks, which do not contain days from the current month.
LeadingWeekCount | Gets or sets the number of full weeks to display from the previous month.
MainHeaderHeight | Gets or sets the height of the main header in a SingleMonth view.
Margin | Gets or sets the amount of space between the outermost frame of the month and the month's contents.
PaddingDaysStyle | Gets or sets the Style object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
RotateWeekHeaderTexts | Gets or sets a value indicating whether the week header texts should be rotated.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the month's header.
ShowPaddingDays | Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubHeaderHeight | Gets or sets the height of the secondary header in a SingleMonth view.
TitleFormat | Gets or sets the string used to format the month's title.
TrailingWeekCount | Gets or sets the number of full weeks to display from the next month.
WeekHeaderFormat | Gets or sets the format of the text displayed for each week in the week header.
WeekHeaderStyle | Gets or sets the style of the week numbers header.
WeekNumbersHeaderWidth | Gets or sets the width of the header, which displays week numbers.

See Also

MonthSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings Properties

MonthSettings Properties

Public Properties

Name | Description
CellLayout | Gets or sets the layout of the cells in SingleMonth and MonthRange views.
ContentsMargin | Gets or sets the amount of space between the month's day cells and the month's bounding rectangle.
DayOfWeekFormat | Gets or sets the format of the day names displayed in the week header.
DaySettings | Gets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.
DaySpacing | Gets or sets the amount of space between adjacent days.
HeaderShadowColor | Gets or sets the color of the shadow cast by headers.
HeaderShadowOffset | Gets or sets the offset of the shadows from the headers that cast them.
HeaderShadowStyle | Gets or sets the style of the shadows cast by headers.
HeaderSpacing | Gets or sets the amount of space between headers.
HeaderStyle | Gets or sets the style of the month's header.
HideTrailingWeeks | Gets or sets a value indicating whether to hide trailing weeks, which do not contain days from the current month.
LeadingWeekCount | Gets or sets the number of full weeks to display from the previous month.
MainHeaderHeight | Gets or sets the height of the main header in a SingleMonth view.
Margin | Gets or sets the amount of space between the outermost frame of the month and the month's contents.
PaddingDaysStyle | Gets or sets the Style object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
RotateWeekHeaderTexts | Gets or sets a value indicating whether the week header texts should be rotated.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the month's header.
ShowPaddingDays | Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubHeaderHeight | Gets or sets the height of the secondary header in a SingleMonth view.
TitleFormat | Gets or sets the string used to format the month's title.
TrailingWeekCount | Gets or sets the number of full weeks to display from the next month.
WeekHeaderFormat | Gets or sets the format of the text displayed for each week in the week header.
WeekHeaderStyle | Gets or sets the style of the week numbers header.
WeekNumbersHeaderWidth | Gets or sets the width of the header, which displays week numbers.

See Also

MonthSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings.CellLayout Property

MonthSettings.CellLayout Property

Gets or sets the layout of the cells in SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public MonthCellLayout CellLayout { get; set; }
Visual Basic

Public Property CellLayout As MonthCellLayout

Property Value

A member of the MonthCellLayout enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings.ContentsMargin Property

MonthSettings.ContentsMargin Property

Gets or sets the amount of space between the month's day cells and the month's bounding rectangle.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ContentsMargin { get; set; }
Visual Basic

Public Property ContentsMargin As Integer

Property Value

A non-negative integer value specifying how many pixels to leave between the cells and the month's bounds. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
DaySpacing Property
HeaderSpacing Property
Margin Property


MindFusion.Scheduling.WinForms.MonthSettings.DayOfWeekFormat Property

MonthSettings.DayOfWeekFormat Property

Gets or sets the format of the day names displayed in the week header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DayOfWeekFormat DayOfWeekFormat { get; set; }
Visual Basic

Public Property DayOfWeekFormat As DayOfWeekFormat

Property Value

A member of the DayOfWeekFormat enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings.DaySettings Property

MonthSettings.DaySettings Property

Gets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public CellSettings DaySettings { get; }
Visual Basic

Public ReadOnly Property DaySettings As CellSettings

Property Value

An instance of the CellSettings class.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings.DaySpacing Property

MonthSettings.DaySpacing Property

Gets or sets the amount of space between adjacent days.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int DaySpacing { get; set; }
Visual Basic

Public Property DaySpacing As Integer

Property Value

A non-negative integer value specifying how many pixels to leave between adjacent day cells. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
ContentsMargin Property
HeaderSpacing Property
Margin Property


MindFusion.Scheduling.WinForms.MonthSettings.HeaderShadowColor Property

MonthSettings.HeaderShadowColor Property

Gets or sets the color of the shadow cast by headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color HeaderShadowColor { get; set; }
Visual Basic

Public Property HeaderShadowColor As Color

Property Value

A .NET Color object specifying the color of headers' shadows. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowOffset Property
HeaderShadowStyle Property


MindFusion.Scheduling.WinForms.MonthSettings.HeaderShadowOffset Property

MonthSettings.HeaderShadowOffset Property

Gets or sets the offset of the shadows from the headers that cast them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderShadowOffset { get; set; }
Visual Basic

Public Property HeaderShadowOffset As Integer

Property Value

An integer value specifying how many pixels there are between headers and their shadows. The allowed values range from 1 to 5. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowColor Property
HeaderShadowStyle Property


MindFusion.Scheduling.WinForms.MonthSettings.HeaderShadowStyle Property

MonthSettings.HeaderShadowStyle Property

Gets or sets the style of the shadows cast by headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ShadowStyle HeaderShadowStyle { get; set; }
Visual Basic

Public Property HeaderShadowStyle As ShadowStyle

Property Value

A member of the ShadowStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowColor Property
HeaderShadowOffset Property


MindFusion.Scheduling.WinForms.MonthSettings.HeaderSpacing Property

MonthSettings.HeaderSpacing Property

Gets or sets the amount of space between headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderSpacing { get; set; }
Visual Basic

Public Property HeaderSpacing As Integer

Property Value

An integer value specifying how many pixels to leave between headers. The minimal allowed value is -1. Assign -2 to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
ContentsMargin Property
DaySpacing Property
Margin Property


MindFusion.Scheduling.WinForms.MonthSettings.HeaderStyle Property

MonthSettings.HeaderStyle Property

Gets or sets the style of the month's header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public MonthHeaderStyles HeaderStyle { get; set; }
Visual Basic

Public Property HeaderStyle As MonthHeaderStyles

Property Value

A member of the MonthHeaderStyles enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings.HideTrailingWeeks Property

MonthSettings.HideTrailingWeeks Property

Gets or sets a value indicating whether to hide trailing weeks, which do not contain days from the current month.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State HideTrailingWeeks { get; set; }
Visual Basic

Public Property HideTrailingWeeks As State

Property Value

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings.LeadingWeekCount Property

MonthSettings.LeadingWeekCount Property

Gets or sets the number of full weeks to display from the previous month.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int LeadingWeekCount { get; set; }
Visual Basic

Public Property LeadingWeekCount As Integer

Property Value

A non-negative integer value specifying the number of weeks to display before the first week of the selected month. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
TrailingWeekCount Property


MindFusion.Scheduling.WinForms.MonthSettings.MainHeaderHeight Property

MonthSettings.MainHeaderHeight Property

Gets or sets the height of the main header in a SingleMonth view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int MainHeaderHeight { get; set; }
Visual Basic

Public Property MainHeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the main header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the Calendar control to automatically calculate the header size based on the header font size.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings.Margin Property

MonthSettings.Margin Property

Gets or sets the amount of space between the outermost frame of the month and the month's contents.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Margin { get; set; }
Visual Basic

Public Property Margin As Integer

Property Value

A non-negative integer value specifying the margins size in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
ContentsMargin Property
DaySpacing Property
HeaderSpacing Property


MindFusion.Scheduling.WinForms.MonthSettings.PaddingDaysStyle Property

MonthSettings.PaddingDaysStyle Property

Gets or sets the Style object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style PaddingDaysStyle { get; set; }
Visual Basic

Public Property PaddingDaysStyle As Style

Property Value

An instance of the Style class. This property cannot be null.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
ShowPaddingDays Property


MindFusion.Scheduling.WinForms.MonthSettings.RotateWeekHeaderTexts Property

MonthSettings.RotateWeekHeaderTexts Property

Gets or sets a value indicating whether the week header texts should be rotated.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State RotateWeekHeaderTexts { get; set; }
Visual Basic

Public Property RotateWeekHeaderTexts As State

Property Value

Specify Enabled to rotate the texts in the week header; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings.ShowDayOfWeek Property

MonthSettings.ShowDayOfWeek Property

Gets or sets a value indicating whether the day names are displayed in the month's header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowDayOfWeek { get; set; }
Visual Basic

Public Property ShowDayOfWeek As State

Property Value

Specify Enabled to display day names; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

The day names are obtained from the DateTimeFormat property of the Calendar class, if it is not a null reference (Nothing in Visual Basic), or from the corresponding DateTimeFormat property of the .NET CultureInfo object assigned to calendar's Culture.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
SubHeaderHeight Property


MindFusion.Scheduling.WinForms.MonthSettings.ShowPaddingDays Property

MonthSettings.ShowPaddingDays Property

Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowPaddingDays { get; set; }
Visual Basic

Public Property ShowPaddingDays As State

Property Value

Specify Enabled to display days from the previous and next months to fill up this month's grid; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Padding days are also displayed in the month range view for the first and the last months contained in the view.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings.Style Property

MonthSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. This property cannot be null.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings.SubHeaderHeight Property

MonthSettings.SubHeaderHeight Property

Gets or sets the height of the secondary header in a SingleMonth view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int SubHeaderHeight { get; set; }
Visual Basic

Public Property SubHeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the Calendar control to automatically calculate the header size based on the header font size.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
ShowDayOfWeek Property


MindFusion.Scheduling.WinForms.MonthSettings.TitleFormat Property

MonthSettings.TitleFormat Property

Gets or sets the string used to format the month's title.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string TitleFormat { get; set; }
Visual Basic

Public Property TitleFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings.TrailingWeekCount Property

MonthSettings.TrailingWeekCount Property

Gets or sets the number of full weeks to display from the next month.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int TrailingWeekCount { get; set; }
Visual Basic

Public Property TrailingWeekCount As Integer

Property Value

A non-negative integer value specifying the number of weeks to display after the selected month. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
LeadingWeekCount Property


MindFusion.Scheduling.WinForms.MonthSettings.WeekHeaderFormat Property

MonthSettings.WeekHeaderFormat Property

Gets or sets the format of the text displayed for each week in the week header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string WeekHeaderFormat { get; set; }
Visual Basic

Public Property WeekHeaderFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The string controls how to format the text displayed by week headers in a SingleMonth and MonthRange views. The value of this property can contain the following formatting specifiers among ordinary text in any number and order:

Specified | Description
%s[{format}] | The date of the first day in the corresponding week, formatted according to the standard date formatting string, specified by {format}. The brackets '{' and '}' should not be included.
%e[{format}] | The date of the last day in the corresponding week, formatted according to the standard date formatting string, specified by {format}. The brackets '{' and '}' should not be included.
%w | The number of the corresponding week relative to the current year.

Example

For example, the formatting string "(%w) %s[d ]-%e[d ], %s[MMM]" for the week 13.08-19.08 will yield the following result: "(33) 13-19, Aug". Pay attention to the space following 'd' in the format specification '[d ]'. If the space is missing, the format will be interpreted by the .NET framework as standard short date formatting.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.MonthSettings.WeekHeaderStyle Property

MonthSettings.WeekHeaderStyle Property

Gets or sets the style of the week numbers header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public MonthWeekHeaderStyle WeekHeaderStyle { get; set; }
Visual Basic

Public Property WeekHeaderStyle As MonthWeekHeaderStyle

Property Value

A member of the MonthWeekHeaderStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
WeekNumbersHeaderWidth Property


MindFusion.Scheduling.WinForms.MonthSettings.WeekNumbersHeaderWidth Property

MonthSettings.WeekNumbersHeaderWidth Property

Gets or sets the width of the header, which displays week numbers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int WeekNumbersHeaderWidth { get; set; }
Visual Basic

Public Property WeekNumbersHeaderWidth As Integer

Property Value

A non-negative integer value specifying the header width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the Calendar control to automatically calculate the header size based on the header font size.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WinForms Namespace
WeekHeaderStyle Property


MindFusion.Scheduling.WinForms.MonthWeekHeaderStyle Enumeration

MonthWeekHeaderStyle Enumeration

Specifies the placement of the week numbers header in a SingleMonth view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum MonthWeekHeaderStyle
Visual Basic

Public Enumeration MonthWeekHeaderStyle

Members

Member name | Description
Left | Display the header on the left side of the calendar.
None | Do not display a week numbers header.
Right | Display the header on the right side of the calendar.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Orientation Enumeration

Orientation Enumeration

Specifies horizontal or vertical orientation.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum Orientation
Visual Basic

Public Enumeration Orientation

Members

Member name | Description
Horizontal | Indicates a horizontal orientation.
Unspecified | Unspecified.
Vertical | Indicates a vertical orientation.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Position Enumeration

Position Enumeration

Specifies the position of an element relative to its container.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum Position
Visual Basic

Public Enumeration Position

Members

Member name | Description
Bottom | The element is docked at the bottom side.
Left | The element is docked at the left side.
None | The element is not displayed.
Right | The element is docked at the right side.
Top | The element is docked at the top side.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.PrintOptions Class

PrintOptions Class

Defines a set of properties that allow customization of various print and print-preview aspects.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class PrintOptions
Visual Basic

Public NotInheritable Class PrintOptions

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.PrintOptions

See Also

PrintOptions Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.PrintOptions Members

PrintOptions Members
Constructors Properties

Defines a set of properties that allow customization of various print and print-preview aspects.

The following tables list the members exposed by the PrintOptions type.

Public Constructors

Name | Description
PrintOptions | Initializes a new instance of the PrintOptions class.

Public Properties

Name | Description
DocumentName | Gets or sets the name of the printed document.
FillContents | Gets or sets a value indicating whether to print calendar elements with their original fill or to use a white brush for filling.
FitToPage | Gets or sets a value indicating whether the print output is scaled to fit in a single page, preserving the aspect ratio of the original view.
HeaderFormat | Gets or sets the format of the page headers.
Landscape | Gets or sets the orientation of the pages.
PageMargins | Gets or sets the page margins.
ResourceHeaderTextsPerPage | Gets or sets a value indicating whether row header texts in a resource view are printed on each page or only once in the middle of the row.
Scale | Gets or sets the scale of the print output.

See Also

PrintOptions Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.PrintOptions Constructor

PrintOptions Constructor

Initializes a new instance of the PrintOptions class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public PrintOptions ()
Visual Basic

Public Sub New ()

See Also

PrintOptions Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.PrintOptions Properties

PrintOptions Properties

Public Properties

Name | Description
DocumentName | Gets or sets the name of the printed document.
FillContents | Gets or sets a value indicating whether to print calendar elements with their original fill or to use a white brush for filling.
FitToPage | Gets or sets a value indicating whether the print output is scaled to fit in a single page, preserving the aspect ratio of the original view.
HeaderFormat | Gets or sets the format of the page headers.
Landscape | Gets or sets the orientation of the pages.
PageMargins | Gets or sets the page margins.
ResourceHeaderTextsPerPage | Gets or sets a value indicating whether row header texts in a resource view are printed on each page or only once in the middle of the row.
Scale | Gets or sets the scale of the print output.

See Also

PrintOptions Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.PrintOptions.DocumentName Property

PrintOptions.DocumentName Property

Gets or sets the name of the printed document.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string DocumentName { get; set; }
Visual Basic

Public Property DocumentName As String

Property Value

A string specifying the document name. The default is " - Untitled - ".

Remarks

This name is usually displayed at the top of each printed page and in the print job queue window.

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.PrintOptions.FillContents Property

PrintOptions.FillContents Property

Gets or sets a value indicating whether to print calendar elements with their original fill or to use a white brush for filling.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool FillContents { get; set; }
Visual Basic

Public Property FillContents As Boolean

Property Value

true, to fill calendar contents with their associated colors when printing; false, to fill them with white. The default is true.

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.PrintOptions.FitToPage Property

PrintOptions.FitToPage Property

Gets or sets a value indicating whether the print output is scaled to fit in a single page, preserving the aspect ratio of the original view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool FitToPage { get; set; }
Visual Basic

Public Property FitToPage As Boolean

Property Value

true to fit the print output into a single page; otherwise, false. The default is false.

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.PrintOptions.HeaderFormat Property

PrintOptions.HeaderFormat Property

Gets or sets the format of the page headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string HeaderFormat { get; set; }
Visual Basic

Public Property HeaderFormat As String

Property Value

A string specifying the headers format. The default is "%D , Page %P".

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.PrintOptions.Landscape Property

PrintOptions.Landscape Property

Gets or sets the orientation of the pages.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Landscape { get; set; }
Visual Basic

Public Property Landscape As Boolean

Property Value

true to set the initial orientation of the print pages to landscape; false to set it to portrait. The default is false.

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.PrintOptions.PageMargins Property

PrintOptions.PageMargins Property

Gets or sets the page margins.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Margins PageMargins { get; set; }
Visual Basic

Public Property PageMargins As Margins

Property Value

A .NET Margins object specifying the page margins size.

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.PrintOptions.ResourceHeaderTextsPerPage Property

PrintOptions.ResourceHeaderTextsPerPage Property

Gets or sets a value indicating whether row header texts in a resource view are printed on each page or only once in the middle of the row.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ResourceHeaderTextsPerPage { get; set; }
Visual Basic

Public Property ResourceHeaderTextsPerPage As Boolean

Property Value

true to print resource row header texts on each page; false to print the text in the middle of the row (on whatever page it might occur). The default is false.

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.PrintOptions.Scale Property

PrintOptions.Scale Property

Gets or sets the scale of the print output.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public float Scale { get; set; }
Visual Basic

Public Property Scale As Single

Property Value

A float value specifying the scale of print output relative to the screen. The default is 1.

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm Class

RecurrenceForm Class

Ready-made form for recurrence editing.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public class RecurrenceForm : Form
Visual Basic

Public Class RecurrenceForm
Inherits Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
MindFusion.Scheduling.WinForms.RecurrenceForm

See Also

RecurrenceForm Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm Members

RecurrenceForm Members
Constructors Properties Methods

Ready-made form for recurrence editing.

The following tables list the members exposed by the RecurrenceForm type.

Public Constructors

Name | Description
RecurrenceForm | Initializes a new instance of the RecurrenceForm class.

Public Properties

Name | Description
EndTime | Gets the end time of the recurrence.
Recurrence | Gets the recurrence being edited in this form.
StartTime | Gets the start time of the recurrence.
TimeFormat | Gets or sets the format of times displayed within the form.

Public Methods

Name | Description
EnableRemoveButton | Enables or disables the 'Remove' button.
SetDate | Sets a date to be used to initialize the form if no recurrence is set initially.
SetDates | Sets the dates to be used to initialize the form if no recurrence is initially set.
SetRecurrence | Sets the recurrence pattern to be edited in the form.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnRightToLeftChanged | Form.OnRightToLeftChanged override.
OnRightToLeftLayoutChanged | Form.OnRightToLeftLayoutChanged override.

See Also

RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm Constructor

RecurrenceForm Constructor

Initializes a new instance of the RecurrenceForm class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public RecurrenceForm ()
Visual Basic

Public Sub New ()

See Also

RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm Methods

RecurrenceForm Methods

Public Methods

Name | Description
EnableRemoveButton | Enables or disables the 'Remove' button.
SetDate | Sets a date to be used to initialize the form if no recurrence is set initially.
SetDates | Sets the dates to be used to initialize the form if no recurrence is initially set.
SetRecurrence | Sets the recurrence pattern to be edited in the form.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnRightToLeftChanged | Form.OnRightToLeftChanged override.
OnRightToLeftLayoutChanged | Form.OnRightToLeftLayoutChanged override.

See Also

RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm.Dispose Method

RecurrenceForm.Dispose Method

Clean up any resources being used.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm.EnableRemoveButton Method

RecurrenceForm.EnableRemoveButton Method

Enables or disables the 'Remove' button.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public void EnableRemoveButton (
bool enable
)
Visual Basic

Public Sub EnableRemoveButton ( _
enable As Boolean _
)

Parameters

enable
true to enable the 'Remove' button; false to disable it.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm.OnRightToLeftChanged Method

RecurrenceForm.OnRightToLeftChanged Method

Form.OnRightToLeftChanged override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

protected virtual void OnRightToLeftChanged (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnRightToLeftChanged ( _
e As EventArgs _
)

Parameters

e

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm.OnRightToLeftLayoutChanged Method

RecurrenceForm.OnRightToLeftLayoutChanged Method

Form.OnRightToLeftLayoutChanged override.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

protected virtual void OnRightToLeftLayoutChanged (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnRightToLeftLayoutChanged ( _
e As EventArgs _
)

Parameters

e

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm.SetDate Method

RecurrenceForm.SetDate Method

Sets a date to be used to initialize the form if no recurrence is set initially.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public void SetDate (
DateTime date
)
Visual Basic

Public Sub SetDate ( _
date As DateTime _
)

Parameters

date
A .NET DateTime object specifying the start and end time of the recurrence displayed in the form.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm.SetDates Method

RecurrenceForm.SetDates Method

Sets the dates to be used to initialize the form if no recurrence is initially set.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public void SetDates (
DateTime start,
DateTime end
)
Visual Basic

Public Sub SetDates ( _
start As DateTime, _
end As DateTime _
)

Parameters

start
A .NET DateTime instance specifying the start time of the recurrence.
end
A .NET DateTime instance specifying the end time of the recurrence.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm.SetRecurrence Method

RecurrenceForm.SetRecurrence Method

Sets the recurrence pattern to be edited in the form.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public void SetRecurrence (
Recurrence recurrence,
DateTime startTime,
DateTime endTime
)
Visual Basic

Public Sub SetRecurrence ( _
recurrence As Recurrence, _
startTime As DateTime, _
endTime As DateTime _
)

Parameters

recurrence
A reference to the Recurrence object to be selected in the form for editing.
startTime
A .NET DateTime instance specifying the initial start time of the recurrence.
endTime
A .NET DateTime instance specifying the initial end time of the recurrence.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm Properties

RecurrenceForm Properties

Public Properties

Name | Description
EndTime | Gets the end time of the recurrence.
Recurrence | Gets the recurrence being edited in this form.
StartTime | Gets the start time of the recurrence.
TimeFormat | Gets or sets the format of times displayed within the form.

See Also

RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm.EndTime Property

RecurrenceForm.EndTime Property

Gets the end time of the recurrence.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public DateTime EndTime { get; }
Visual Basic

Public ReadOnly Property EndTime As DateTime

Property Value

A .NET DateTime object specifying the end time of the recurrence.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm.Recurrence Property

RecurrenceForm.Recurrence Property

Gets the recurrence being edited in this form.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public Recurrence Recurrence { get; }
Visual Basic

Public ReadOnly Property Recurrence As Recurrence

Property Value

An instance of the Recurrence class, which is being edited in the form.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm.StartTime Property

RecurrenceForm.StartTime Property

Gets the start time of the recurrence.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public DateTime StartTime { get; }
Visual Basic

Public ReadOnly Property StartTime As DateTime

Property Value

A .NET DateTime object specifying the start time of the recurrence.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurrenceForm.TimeFormat Property

RecurrenceForm.TimeFormat Property

Gets or sets the format of times displayed within the form.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public string TimeFormat { get; set; }
Visual Basic

Public Property TimeFormat As String

Property Value

A string specifying the display format.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurringItemConfirmEventArgs Class

RecurringItemConfirmEventArgs Class

Contains the arguments passed to handlers of the RecurringItemDeleting event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class RecurringItemConfirmEventArgs : ItemEventArgs
Visual Basic

Public Class RecurringItemConfirmEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.WinForms.RecurringItemConfirmEventArgs

See Also

RecurringItemConfirmEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurringItemConfirmEventArgs Members

RecurringItemConfirmEventArgs Members
Properties

Contains the arguments passed to handlers of the RecurringItemDeleting event.

The following tables list the members exposed by the RecurringItemConfirmEventArgs type.

Public Properties

Name | Description
ConfirmAll | Gets or sets a value indicating whether the operation is allowed for all occurrences of a repeating item.
ConfirmOccurrence | Gets or sets a value indicating whether the operation is allowed for the particular occurrence.

See Also

RecurringItemConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurringItemConfirmEventArgs Properties

RecurringItemConfirmEventArgs Properties

Public Properties

Name | Description
ConfirmAll | Gets or sets a value indicating whether the operation is allowed for all occurrences of a repeating item.
ConfirmOccurrence | Gets or sets a value indicating whether the operation is allowed for the particular occurrence.

See Also

RecurringItemConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurringItemConfirmEventArgs.ConfirmAll Property

RecurringItemConfirmEventArgs.ConfirmAll Property

Gets or sets a value indicating whether the operation is allowed for all occurrences of a repeating item.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ConfirmAll { get; set; }
Visual Basic

Public Property ConfirmAll As Boolean

Property Value

true to allow the operation for all occurrences of the recurring item.

See Also

RecurringItemConfirmEventArgs Members
RecurringItemConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.RecurringItemConfirmEventArgs.ConfirmOccurrence Property

RecurringItemConfirmEventArgs.ConfirmOccurrence Property

Gets or sets a value indicating whether the operation is allowed for the particular occurrence.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ConfirmOccurrence { get; set; }
Visual Basic

Public Property ConfirmOccurrence As Boolean

Property Value

true to allow the operation for the specified item's occurrence; otherwise, false.

See Also

RecurringItemConfirmEventArgs Members
RecurringItemConfirmEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceDateEventArgs Class

ResourceDateEventArgs Class

Contains the arguments passed to handlers of mouse events related to date/time and resource related cells in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class ResourceDateEventArgs : DateEventArgs
Visual Basic

Public Class ResourceDateEventArgs
Inherits DateEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.WinForms.DateEventArgs
MindFusion.Scheduling.WinForms.ResourceDateEventArgs

See Also

ResourceDateEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceDateEventArgs Members

ResourceDateEventArgs Members
Properties

Contains the arguments passed to handlers of mouse events related to date/time and resource related cells in the calendar.

The following tables list the members exposed by the ResourceDateEventArgs type.

Public Properties

Name | Description
Resource | Gets the resource associated with the clicked cell.

See Also

ResourceDateEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceDateEventArgs Properties

ResourceDateEventArgs Properties

Public Properties

Name | Description
Resource | Gets the resource associated with the clicked cell.

See Also

ResourceDateEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceDateEventArgs.Resource Property

ResourceDateEventArgs.Resource Property

Gets the resource associated with the clicked cell.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Resource Resource { get; }
Visual Basic

Public ReadOnly Property Resource As Resource

Property Value

A reference to a Resource, Contact, Location or Task object or null (Nothing in Visual Basic).

See Also

ResourceDateEventArgs Members
ResourceDateEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceLengthMethod Enumeration

ResourceLengthMethod Enumeration

Specifies how to calculate the length of the resources in a Resource view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum ResourceLengthMethod
Visual Basic

Public Enumeration ResourceLengthMethod

Members

Member name | Description
Exact | The length of the resources depends on the time span they occupy.
MinimumAuto | The length of the resources is at least big enough to fit their contents.
MinimumFixed | The length of the resources is not less than a specified predefined value.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceResizeMethod Enumeration

ResourceResizeMethod Enumeration

Specifies the item resizing method in a Resource view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum ResourceResizeMethod
Visual Basic

Public Enumeration ResourceResizeMethod

Members

Member name | Description
DurationBounds | The items are resized by pointing near the ends of the bounding rectangle of the bands showing their duration.
ItemBounds | The items are resized by pointing near the ends of their bounding rectangle.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings Class

ResourceViewSettings Class

Defines properties that allow customizing the visualization of the calendar in Resource view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class ResourceViewSettings : ViewSettings
Visual Basic

Public Class ResourceViewSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.ViewSettings
MindFusion.Scheduling.WinForms.ResourceViewSettings

See Also

ResourceViewSettings Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings Members

ResourceViewSettings Members
Properties

Defines properties that allow customizing the visualization of the calendar in Resource view.

The following tables list the members exposed by the ResourceViewSettings type.

Public Properties

Name | Description
BottomTimelineSettings | Gets the settings for the bottom timeline.
CellOffset | Gets or sets the time offset of the first cell from the origin of the resource view.
EnableRowTitleFormat | Gets or sets a value indicating whether the RowTitleFormat property will be taken into consideration.
ExpandableRows | Gets or sets a value indicating whether the rows in the resource view can be expanded/collapsed.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GridStyle | Gets or sets the style of the grid lines.
GroupRowHeader | Gets or sets a value indicating whether the rows display the header as a group header.
HeaderShadowColor | Gets or sets the color of the shadow cast by headers.
HeaderShadowOffset | Gets or sets the offset of the shadows from the headers that cast them.
HeaderShadowStyle | Gets or sets the style of the shadows cast by headers.
HeaderSpacing | Gets or sets the amount of space between headers.
HiddenDays | Gets or sets the days of the week that should not be displayed in a resource view.
InnerGridStyle | Gets or sets the style of the internal grid lines.
LaneSize | Gets or sets the size of a single lane.
MiddleTimelineSettings | Gets the settings for the middle timeline.
MinItemSize | Gets or sets the smallest size allowed for resource items.
MinResourceLength | Gets or sets the minimum length for resources when the ResourceLengthMethod property is set to MinimumFixed.
MinRowSize | Gets or sets the smallest size allowed for resource rows.
ResourceLengthMethod | Gets or sets the method used to calculate the length of the resources.
ResourceResizeMethod | Gets or sets the method to be used when resizing resources in the view.
RowHeaderSize | Gets or sets the size of the row header.
RowTitleFormat | Gets or sets the string used to format and display resource titles in row headers.
ScrollStep | Gets or sets the time modification interval when the user scrolls the view.
ShowPaddingDates | Gets or sets a value indicating whether to display padding dates.
ShowResourceDuration | Gets or sets a value indicating whether to display the duration of individual resources.
ShowSubTicks | Gets or sets a value indicating whether the view displays sub ticks in the bottom timeline.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubTickSize | Gets or sets the size of the sub ticks displayed in the bottom timeline.
Timelines | Gets or sets the number of timelines displayed in the view.
TimelineScale | Gets or sets the scale factor of the timeline.
TopTimelineSettings | Gets the settings for the top timeline.
ViewStyle | Gets or sets the style of the view.
VisibleEndTime | Gets or sets the last visible time of displayed days.
VisibleRows | Gets or sets the number of rows visible in the view.
VisibleStartTime | Gets or sets the first visible time of displayed days.
WeekendStyle | Gets or sets the style of the weekend cells.

See Also

ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings Properties

ResourceViewSettings Properties

Public Properties

Name | Description
BottomTimelineSettings | Gets the settings for the bottom timeline.
CellOffset | Gets or sets the time offset of the first cell from the origin of the resource view.
EnableRowTitleFormat | Gets or sets a value indicating whether the RowTitleFormat property will be taken into consideration.
ExpandableRows | Gets or sets a value indicating whether the rows in the resource view can be expanded/collapsed.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GridStyle | Gets or sets the style of the grid lines.
GroupRowHeader | Gets or sets a value indicating whether the rows display the header as a group header.
HeaderShadowColor | Gets or sets the color of the shadow cast by headers.
HeaderShadowOffset | Gets or sets the offset of the shadows from the headers that cast them.
HeaderShadowStyle | Gets or sets the style of the shadows cast by headers.
HeaderSpacing | Gets or sets the amount of space between headers.
HiddenDays | Gets or sets the days of the week that should not be displayed in a resource view.
InnerGridStyle | Gets or sets the style of the internal grid lines.
LaneSize | Gets or sets the size of a single lane.
MiddleTimelineSettings | Gets the settings for the middle timeline.
MinItemSize | Gets or sets the smallest size allowed for resource items.
MinResourceLength | Gets or sets the minimum length for resources when the ResourceLengthMethod property is set to MinimumFixed.
MinRowSize | Gets or sets the smallest size allowed for resource rows.
ResourceLengthMethod | Gets or sets the method used to calculate the length of the resources.
ResourceResizeMethod | Gets or sets the method to be used when resizing resources in the view.
RowHeaderSize | Gets or sets the size of the row header.
RowTitleFormat | Gets or sets the string used to format and display resource titles in row headers.
ScrollStep | Gets or sets the time modification interval when the user scrolls the view.
ShowPaddingDates | Gets or sets a value indicating whether to display padding dates.
ShowResourceDuration | Gets or sets a value indicating whether to display the duration of individual resources.
ShowSubTicks | Gets or sets a value indicating whether the view displays sub ticks in the bottom timeline.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubTickSize | Gets or sets the size of the sub ticks displayed in the bottom timeline.
Timelines | Gets or sets the number of timelines displayed in the view.
TimelineScale | Gets or sets the scale factor of the timeline.
TopTimelineSettings | Gets the settings for the top timeline.
ViewStyle | Gets or sets the style of the view.
VisibleEndTime | Gets or sets the last visible time of displayed days.
VisibleRows | Gets or sets the number of rows visible in the view.
VisibleStartTime | Gets or sets the first visible time of displayed days.
WeekendStyle | Gets or sets the style of the weekend cells.

See Also

ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.BottomTimelineSettings Property

ResourceViewSettings.BottomTimelineSettings Property

Gets the settings for the bottom timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimelineSettings BottomTimelineSettings { get; }
Visual Basic

Public ReadOnly Property BottomTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class that defines the preferences for the bottom timeline.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
MiddleTimelineSettings Property
TopTimelineSettings Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.CellOffset Property

ResourceViewSettings.CellOffset Property

Gets or sets the time offset of the first cell from the origin of the resource view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public float CellOffset { get; set; }
Visual Basic

Public Property CellOffset As Single

Property Value

A floating point value, specifying the offset in the units set in the Unit property of the BottomTimelineSettings.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.EnableRowTitleFormat Property

ResourceViewSettings.EnableRowTitleFormat Property

Gets or sets a value indicating whether the RowTitleFormat property will be taken into consideration.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State EnableRowTitleFormat { get; set; }
Visual Basic

Public Property EnableRowTitleFormat As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

If this property is disabled the title of each row is determined by to the type of resources the view is currently grouped by. If the view is grouped by contacts, the title displays the FirstName, MiddleName and LastName of the contact according to the pattern specified by ContactNameFormat. If the view is grouped by locations or resources, the title displays the Name of the resource. If the view is grouped by tasks, the title displays the Subject of the task.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
RowTitleFormat Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.ExpandableRows Property

ResourceViewSettings.ExpandableRows Property

Gets or sets a value indicating whether the rows in the resource view can be expanded/collapsed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ExpandableRows { get; set; }
Visual Basic

Public Property ExpandableRows As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

This property is only used if the ViewStyle is set to Lanes.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ExpandActiveItemOn Property

ResourceViewSettings.ExpandActiveItemOn Property

Gets or sets whether the active item should ignore collisions.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemAction ExpandActiveItemOn { get; set; }
Visual Basic

Public Property ExpandActiveItemOn As ItemAction

Property Value

A member of the ItemAction enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

This property is only used if the ViewStyle is set to General.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.GridStyle Property

ResourceViewSettings.GridStyle Property

Gets or sets the style of the grid lines.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public LineStyle GridStyle { get; set; }
Visual Basic

Public Property GridStyle As LineStyle

Property Value

A member of the LineStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
InnerGridStyle Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.GroupRowHeader Property

ResourceViewSettings.GroupRowHeader Property

Gets or sets a value indicating whether the rows display the header as a group header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State GroupRowHeader { get; set; }
Visual Basic

Public Property GroupRowHeader As State

Property Value

A member of the State enumeration. Set it to Enabled to activate this feature or to Disabled to turn it off. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

This property is only used if the ViewStyle is set to Lanes.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.HeaderShadowColor Property

ResourceViewSettings.HeaderShadowColor Property

Gets or sets the color of the shadow cast by headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color HeaderShadowColor { get; set; }
Visual Basic

Public Property HeaderShadowColor As Color

Property Value

A .NET Color object specifying the color of headers' shadows. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowOffset Property
HeaderShadowStyle Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.HeaderShadowOffset Property

ResourceViewSettings.HeaderShadowOffset Property

Gets or sets the offset of the shadows from the headers that cast them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderShadowOffset { get; set; }
Visual Basic

Public Property HeaderShadowOffset As Integer

Property Value

An integer value specifying with how many pixels to offset a header's shadow from the header. The allowed values range from 1 to 5. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowColor Property
HeaderShadowStyle Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.HeaderShadowStyle Property

ResourceViewSettings.HeaderShadowStyle Property

Gets or sets the style of the shadows cast by headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ShadowStyle HeaderShadowStyle { get; set; }
Visual Basic

Public Property HeaderShadowStyle As ShadowStyle

Property Value

A member of the ShadowStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowColor Property
HeaderShadowOffset Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.HeaderSpacing Property

ResourceViewSettings.HeaderSpacing Property

Gets or sets the amount of space between headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderSpacing { get; set; }
Visual Basic

Public Property HeaderSpacing As Integer

Property Value

An integer value specifying how many pixels there are between adjacent headers. The minimal allowed value is -1. Assign -2 to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.HiddenDays Property

ResourceViewSettings.HiddenDays Property

Gets or sets the days of the week that should not be displayed in a resource view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DaysOfWeek HiddenDays { get; set; }
Visual Basic

Public Property HiddenDays As DaysOfWeek

Property Value

A member of the DaysOfWeek enumeration indicating the visible days in a ResourceView.

Remarks

This property determines which days should be filtered (that is, not displayed) in a resource view. This setting only works if the Unit of the bottom timeline is set to Day or Hour.

Example

The following example demonstrates how to use filtering in a resource view. The example assumes that calendar references an existing Calendar object.

C#

// Enable resource view
calendar.ResourceViewSettings.Timelines = 2;
calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour;
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "h:mm";
calendar.ResourceViewSettings.MiddleTimelineSettings.Unit = TimeUnit.Day;
calendar.ResourceViewSettings.MiddleTimelineSettings.Format = "d ddd";

// Show only work days from 9 to 18
calendar.ResourceViewSettings.HiddenDays = DaysOfWeek.Saturday | DaysOfWeek.Sunday;
calendar.ResourceViewSettings.VisibleStartTime = TimeSpan.FromHours(9);
calendar.ResourceViewSettings.VisibleEndTime = TimeSpan.FromHours(18);

// Set appropriate scroll step
calendar.ResourceViewSettings.ScrollStep = TimeSpan.FromHours(1);
Visual Basic

' Enable resource view
calendar.ResourceViewSettings.Timelines = 2
calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "h:mm"
calendar.ResourceViewSettings.MiddleTimelineSettings.Unit = TimeUnit.Day
calendar.ResourceViewSettings.MiddleTimelineSettings.Format = "d ddd"

' Show only work days from 9 to 18
calendar.ResourceViewSettings.HiddenDays = DaysOfWeek.Saturday Or DaysOfWeek.Sunday
calendar.ResourceViewSettings.VisibleStartTime = TimeSpan.FromHours(9)
calendar.ResourceViewSettings.VisibleEndTime = TimeSpan.FromHours(18)

' Set appropriate scroll step
calendar.ResourceViewSettings.ScrollStep = TimeSpan.FromHours(1)

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
VisibleStartTime Property
VisibleEndTime Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.InnerGridStyle Property

ResourceViewSettings.InnerGridStyle Property

Gets or sets the style of the internal grid lines.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public LineStyle InnerGridStyle { get; set; }
Visual Basic

Public Property InnerGridStyle As LineStyle

Property Value

A member of the LineStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
GridStyle Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.LaneSize Property

ResourceViewSettings.LaneSize Property

Gets or sets the size of a single lane.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int LaneSize { get; set; }
Visual Basic

Public Property LaneSize As Integer

Property Value

An integer value specifying the size in pixels of a resource lane. The minimal allowed value is 10. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property is only used if the ViewStyle is set to Lanes.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.MiddleTimelineSettings Property

ResourceViewSettings.MiddleTimelineSettings Property

Gets the settings for the middle timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimelineSettings MiddleTimelineSettings { get; }
Visual Basic

Public ReadOnly Property MiddleTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class that defines the preferences for the middle timeline.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
BottomTimelineSettings Property
TopTimelineSettings Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.MinItemSize Property

ResourceViewSettings.MinItemSize Property

Gets or sets the smallest size allowed for resource items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int MinItemSize { get; set; }
Visual Basic

Public Property MinItemSize As Integer

Property Value

An integer value, specifying the minimal item size in pixels. The minimal allowed value is 5. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

If there is not enough space in a row to display all related items, the items that do not fit remain invisible. This property is only used if the ViewStyle is set to General.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.MinResourceLength Property

ResourceViewSettings.MinResourceLength Property

Gets or sets the minimum length for resources when the ResourceLengthMethod property is set to MinimumFixed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int MinResourceLength { get; set; }
Visual Basic

Public Property MinResourceLength As Integer

Property Value

An integer value, specifying the minimal resource length in pixels. The minimal allowed value is 5. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.MinRowSize Property

ResourceViewSettings.MinRowSize Property

Gets or sets the smallest size allowed for resource rows.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int MinRowSize { get; set; }
Visual Basic

Public Property MinRowSize As Integer

Property Value

An integer value, specifying the minimal row size in pixels. The minimal allowed value is 10. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property is only used if the ViewStyle is set to General.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ResourceLengthMethod Property

ResourceViewSettings.ResourceLengthMethod Property

Gets or sets the method used to calculate the length of the resources.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ResourceLengthMethod ResourceLengthMethod { get; set; }
Visual Basic

Public Property ResourceLengthMethod As ResourceLengthMethod

Property Value

A value of the ResourceLengthMethod enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ResourceResizeMethod Property

ResourceViewSettings.ResourceResizeMethod Property

Gets or sets the method to be used when resizing resources in the view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ResourceResizeMethod ResourceResizeMethod { get; set; }
Visual Basic

Public Property ResourceResizeMethod As ResourceResizeMethod

Property Value

A member of the ResourceResizeMethod enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.RowHeaderSize Property

ResourceViewSettings.RowHeaderSize Property

Gets or sets the size of the row header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int RowHeaderSize { get; set; }
Visual Basic

Public Property RowHeaderSize As Integer

Property Value

An integer value specifying the size in pixels of the row headers. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

The size of a header is used only when GroupRowHeader is enabled. Otherwise, the size of the header equals LaneSize.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.RowTitleFormat Property

ResourceViewSettings.RowTitleFormat Property

Gets or sets the string used to format and display resource titles in row headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string RowTitleFormat { get; set; }
Visual Basic

Public Property RowTitleFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The RowTitleFormat represents raw text containing property references enclosed in curly brackets. The following is an example of a formatting string containing a single reference to a property called Name:

Example

This is {Name}.

The value of the referenced property is obtained from the resource object associated with the row whose title is being formatted with this string.

More complicated format strings can be specified. For example, assuming that the view is grouped by contacts, the following format specifies that the first, middle and last name of the contact should be displayed (in that order):

Example

{FirstName} {MiddleName} {LastName}

The property references can contain additional formatting specifiers indicating how the value of the referenced property should be formatted. The additional formatting specifiers are separated from the property name with colon ':'. The following is an example of how to format the value of a DateTime property:

Example

{ActualStart:dd, MMM}

The above example will display the value of the ActualStart property with the specified formatting.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
EnableRowTitleFormat Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.ScrollStep Property

ResourceViewSettings.ScrollStep Property

Gets or sets the time modification interval when the user scrolls the view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimeSpan ScrollStep { get; set; }
Visual Basic

Public Property ScrollStep As TimeSpan

Property Value

A .NET TimeSpan object that defines the scroll interval. The minimal allowed value is 1 second. Assign -1 ticks to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ShowPaddingDates Property

ResourceViewSettings.ShowPaddingDates Property

Gets or sets a value indicating whether to display padding dates.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowPaddingDates { get; set; }
Visual Basic

Public Property ShowPaddingDates As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

It is sometimes possible that the control draws dates outside of the range specified by the Date and EndDate properties. This usually happens when the viewport is larger than the entire time range. Set this property to Disabled if you don't want the control to draw external dates.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ShowResourceDuration Property

ResourceViewSettings.ShowResourceDuration Property

Gets or sets a value indicating whether to display the duration of individual resources.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowResourceDuration { get; set; }
Visual Basic

Public Property ShowResourceDuration As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ShowSubTicks Property

ResourceViewSettings.ShowSubTicks Property

Gets or sets a value indicating whether the view displays sub ticks in the bottom timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowSubTicks { get; set; }
Visual Basic

Public Property ShowSubTicks As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
SubTicksSize Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.SnapUnit Property

ResourceViewSettings.SnapUnit Property

Gets or sets the snap unit.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimeUnit SnapUnit { get; set; }
Visual Basic

Public Property SnapUnit As TimeUnit

Property Value

A member of the TimeUnit enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Specifies the time unit of the nearest value to align to when an item is being modified interactively. For example specifying Day causes the manipulated item to always be aligned to the nearest day. To practically disable snapping, specify Second for this property.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
SnapUnitCount Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.SnapUnitCount Property

ResourceViewSettings.SnapUnitCount Property

Gets or sets the snap unit count.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int SnapUnitCount { get; set; }
Visual Basic

Public Property SnapUnitCount As Integer

Property Value

A positive integer value specifying the number of units from the associated SnapUnit to snap to. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

When SnapUnitCount is 1 the snapping is absolute. When SnapUnitCount is greater than 1, then the snapping is relative to the element being dragged. For example, if the item is moved or its start is being resized, the snapping is relative to the item's start. If the item's end is being resized, the snapping is relative to the item's end. For example if the item starts at 02/16, the unit count is 3 and the unit is Day, an attempt to resize the item's start on the left would cause snapping at 02/13 (which is the item's start time minus 3 days).

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
SnapUnit Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.Style Property

ResourceViewSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. This property cannot be null.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.SubTickSize Property

ResourceViewSettings.SubTickSize Property

Gets or sets the size of the sub ticks displayed in the bottom timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int SubTickSize { get; set; }
Visual Basic

Public Property SubTickSize As Integer

Property Value

A non-negative integer value. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
ShowSubTicks Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.Timelines Property

ResourceViewSettings.Timelines Property

Gets or sets the number of timelines displayed in the view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Timelines { get; set; }
Visual Basic

Public Property Timelines As Integer

Property Value

An integer value specifying the number of timelines visible in the view. The allowed values range from 1 to 3. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
BottomTimelineSettings Property
MiddleTimelineSettings Property
TopTimelineSettings Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.TimelineScale Property

ResourceViewSettings.TimelineScale Property

Gets or sets the scale factor of the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int TimelineScale { get; set; }
Visual Basic

Public Property TimelineScale As Integer

Property Value

An integer value specifying the scale of the timeline expressed in percents. The allowed values range from 10 to 1000. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

Usually the size of the cells in the ResourceView is calculated to be large enough so that the texts in the timeline can fit without clipping. By using values other than 100 for this property, you can scale up or down the precalculated size of the cells.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.TopTimelineSettings Property

ResourceViewSettings.TopTimelineSettings Property

Gets the settings for the top timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimelineSettings TopTimelineSettings { get; }
Visual Basic

Public ReadOnly Property TopTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class that defines the preferences for the top timeline.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
BottomTimelineSettings Property
MiddleTimelineSettings Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.ViewStyle Property

ResourceViewSettings.ViewStyle Property

Gets or sets the style of the view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ResourceViewStyle ViewStyle { get; set; }
Visual Basic

Public Property ViewStyle As ResourceViewStyle

Property Value

A member of the ResourceViewStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.VisibleEndTime Property

ResourceViewSettings.VisibleEndTime Property

Gets or sets the last visible time of displayed days.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimeSpan VisibleEndTime { get; set; }
Visual Basic

Public Property VisibleEndTime As TimeSpan

Property Value

A .NET TimeSpan value indicating the last visible hour of the day in a ResourceView.

Remarks

This property along with the VisibleStartTime property determine the range of hours displayed in a resource view for each day. The rest of the day is filtered (that is, the hours outside this range are not displayed). Despite being a TimeSpan, only the Hour component is taken into consideration when filtering. Furthermore, this setting only works if the Unit property of the bottom timeline is set to Hour and the UnitCount is set to 1 or if Unit is set to Minute.

Example

The following example demonstrates how to use filtering in a resource view. The example assumes that calendar references an existing Calendar object.

C#

// Enable resource view
calendar.ResourceViewSettings.Timelines = 2;
calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour;
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "h:mm";
calendar.ResourceViewSettings.MiddleTimelineSettings.Unit = TimeUnit.Day;
calendar.ResourceViewSettings.MiddleTimelineSettings.Format = "d ddd";

// Show only work days from 9 to 18
calendar.ResourceViewSettings.HiddenDays = DaysOfWeek.Saturday | DaysOfWeek.Sunday;
calendar.ResourceViewSettings.VisibleStartTime = TimeSpan.FromHours(9);
calendar.ResourceViewSettings.VisibleEndTime = TimeSpan.FromHours(18);

// Set appropriate scroll step
calendar.ResourceViewSettings.ScrollStep = TimeSpan.FromHours(1);
Visual Basic

' Enable resource view
calendar.ResourceViewSettings.Timelines = 2
calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "h:mm"
calendar.ResourceViewSettings.MiddleTimelineSettings.Unit = TimeUnit.Day
calendar.ResourceViewSettings.MiddleTimelineSettings.Format = "d ddd"

' Show only work days from 9 to 18
calendar.ResourceViewSettings.HiddenDays = DaysOfWeek.Saturday Or DaysOfWeek.Sunday
calendar.ResourceViewSettings.VisibleStartTime = TimeSpan.FromHours(9)
calendar.ResourceViewSettings.VisibleEndTime = TimeSpan.FromHours(18)

' Set appropriate scroll step
calendar.ResourceViewSettings.ScrollStep = TimeSpan.FromHours(1)

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
VisibleStartTime Property
HiddenDays Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.VisibleRows Property

ResourceViewSettings.VisibleRows Property

Gets or sets the number of rows visible in the view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int VisibleRows { get; set; }
Visual Basic

Public Property VisibleRows As Integer

Property Value

An integer value specifying the number of rows visible at a time. The minimal allowed value is 1. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property is only used if the ViewStyle is set to General.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.VisibleStartTime Property

ResourceViewSettings.VisibleStartTime Property

Gets or sets the first visible time of displayed days.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimeSpan VisibleStartTime { get; set; }
Visual Basic

Public Property VisibleStartTime As TimeSpan

Property Value

A .NET TimeSpan value indicating the first visible hour of the day in a ResourceView.

Remarks

This property along with the VisibleEndTime property determine the range of hours displayed in a resource view for each day. The rest of the day is filtered (that is, the hours outside this range are not displayed). Despite being a TimeSpan, only the Hour component is taken into consideration when filtering. Furthermore, this setting only works if the Unit property of the bottom timeline is set to Hour and the UnitCount is set to 1 or if the Unit is set to Minute.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace
VisibleEndTime Property
HiddenDays Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.WeekendStyle Property

ResourceViewSettings.WeekendStyle Property

Gets or sets the style of the weekend cells.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style WeekendStyle { get; set; }
Visual Basic

Public Property WeekendStyle As Style

Property Value

A Style object specifying the appearance of weekend cells. This property cannot be null.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ResourceViewStyle Enumeration

ResourceViewStyle Enumeration

Specifies the style of a Resource view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum ResourceViewStyle
Visual Basic

Public Enumeration ResourceViewStyle

Members

Member name | Description
General | Each row in a Resource view has a fixed width. The items within the row are positioned much like in a Timetable view.
Lanes | Each row in a Resource view displays one or more lanes where items are positioned. More lanes are added automatically to respect the requirement that all overlapping items are on separate lanes.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection Class

Selection Class

Represents a set of selected date cells and defines a visualization style applied to the selected elements.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class Selection : IDisposable
Visual Basic

Public NotInheritable Class Selection
Implements IDisposable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.Selection

See Also

Selection Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection Members

Selection Members
Properties Methods Events

Represents a set of selected date cells and defines a visualization style applied to the selected elements.

The following tables list the members exposed by the Selection type.

Public Properties

Name | Description
AllowMultiple | Gets or sets a value indicating whether users are allowed to select multiple elements at a time.
Contact | Gets the contact related to the current selection.
Continuous | Gets or sets a value indicating whether users can select only one range of dates in the calendar.
DayRanges | Gets a read-only list of .NET DateTime objects, sorted chronologically. Each pair in the list represents an interval of selected days.
Enabled | Gets or sets a value indicating whether users are allowed to select any cells in the calendar.
IsEmpty | Gets a value indicating whether this selection is empty.
Location | Gets the location related to the current selection.
Ranges | Gets a read-only list of .NET DateTime objects, sorted chronologically. Each pair in the list represents a selected time range.
Resource | Gets the resource related to the current selection.
SelectedElementsStyle | Gets or sets the visualization style to apply to selected elements.
Style | Gets or sets the style of the selection frame drawn around selected calendar cells.
Task | Gets the task related to the current selection.

Public Methods

Name | Description
Add | Overloaded. Adds the specified date or range of dates to the selection.
Contains | Determines whether the specified date is currently selected.
ContainsDay | Determines whether any part of the specified day is selected.
Dispose | Disposes any resources used by this Selection object.
Remove | Overloaded. Removes the specified date or range of dates from the selection.
Reset | Clears the selection.
Restore | Restores a previously saved state.
Save | Saves the current selection state.
Set | Overloaded. Sets the current selection to the specified date or range of dates.

Public Events

Name | Description
Changed | Raised when the selection changes.
SelectedElementsStyleChanged | Raised when the appearance style of the selection changes.

See Also

Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection Methods

Selection Methods

Public Methods

Name | Description
Add | Overloaded. Adds the specified date or range of dates to the selection.
Contains | Determines whether the specified date is currently selected.
ContainsDay | Determines whether any part of the specified day is selected.
Dispose | Disposes any resources used by this Selection object.
Remove | Overloaded. Removes the specified date or range of dates from the selection.
Reset | Clears the selection.
Restore | Restores a previously saved state.
Save | Saves the current selection state.
Set | Overloaded. Sets the current selection to the specified date or range of dates.

See Also

Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Add Method

Selection.Add Method

Adds the specified date or range of dates to the selection.

Overload List

Name | Description
Selection.Add (DateTime) | Adds the specified date to the selection.
Selection.Add (DateTime, DateTime) | Adds the specified date range to the selection.
Selection.Add (DateTime, DateTime, Contact, Resource, Location, Task) | Adds the specified date range to the selection of the specified resource.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Add Method (DateTime)

Selection.Add Method (DateTime)
See Also

Adds the specified date to the selection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Add (
DateTime date
)
Visual Basic

Public Sub Add ( _
date As DateTime _
)

Parameters

date
The date to be added to the selection.

See Also

Add Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Add Method (DateTime, DateTime)

Selection.Add Method (DateTime, DateTime)
See Also

Adds the specified date range to the selection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Add (
DateTime start,
DateTime end
)
Visual Basic

Public Sub Add ( _
start As DateTime, _
end As DateTime _
)

Parameters

start
The start of the time range to be added to the selection.
end
The end of the time range to be added to the selection.

See Also

Add Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Add Method (DateTime, DateTime, Contact, Resource, Location, Task)

Selection.Add Method (DateTime, DateTime, Contact, Resource, Location, Task)
See Also

Adds the specified date range to the selection of the specified resource.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Add (
DateTime start,
DateTime end,
Contact contact,
Resource resource,
Location location,
Task task
)
Visual Basic

Public Sub Add ( _
start As DateTime, _
end As DateTime, _
contact As Contact, _
resource As Resource, _
location As Location, _
task As Task _
)

Parameters

start
The start of the time range to be added to the selection.
end
The end of the time range to be added to the selection.
contact
A reference to a Contact to associate the selection with.
resource
A reference to a Resource to associate the selection with.
location
A reference to a Location to associate the selection with.
task
A reference to a Task to associate the selection with.

Remarks

Either all of the parameters contact, resource, location and task must be set to null or only one of them should be a non-null reference.

See Also

Add Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Contains Method

Selection.Contains Method

Determines whether the specified date is currently selected.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool Contains (
DateTime date
)
Visual Basic

Public Function Contains ( _
date As DateTime _
) As Boolean

Parameters

date
A date to search for in the selection.

Return Value

true if the date's cell is selected; otherwise false.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.ContainsDay Method

Selection.ContainsDay Method

Determines whether any part of the specified day is selected.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool ContainsDay (
DateTime date
)
Visual Basic

Public Function ContainsDay ( _
date As DateTime _
) As Boolean

Parameters

date
A DateTime instance specifying the day to check.

Return Value

true if any part of the day is into the selection; otherwise false.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Dispose Method

Selection.Dispose Method

Disposes any resources used by this Selection object.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public virtual void Dispose ()
Visual Basic

Public Overridable Sub Dispose ()

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Remove Method

Selection.Remove Method

Removes the specified date or range of dates from the selection.

Overload List

Name | Description
Selection.Remove (DateTime) | Removes the specified date from the selection.
Selection.Remove (DateTime, DateTime) | Removes the specified date range from the selection.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Remove Method (DateTime)

Selection.Remove Method (DateTime)
See Also

Removes the specified date from the selection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Remove (
DateTime date
)
Visual Basic

Public Sub Remove ( _
date As DateTime _
)

Parameters

date
The date to be removed from the selection.

See Also

Remove Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Remove Method (DateTime, DateTime)

Selection.Remove Method (DateTime, DateTime)
See Also

Removes the specified date range from the selection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Remove (
DateTime start,
DateTime end
)
Visual Basic

Public Sub Remove ( _
start As DateTime, _
end As DateTime _
)

Parameters

start
The start of the time range to be removed from the selection.
end
The end of the time range to be removed from the selection.

See Also

Remove Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Reset Method

Selection.Reset Method

Clears the selection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Reset ()
Visual Basic

Public Sub Reset ()

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Restore Method

Selection.Restore Method

Restores a previously saved state.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Restore (
SelectionState state
)
Visual Basic

Public Sub Restore ( _
state As SelectionState _
)

Parameters

state
A previously saved selection state.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Save Method

Selection.Save Method

Saves the current selection state.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public SelectionState Save ()
Visual Basic

Public Function Save () As SelectionState

Return Value

A SelectionState object representing the current selection state.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Set Method

Selection.Set Method

Sets the current selection to the specified date or range of dates.

Overload List

Name | Description
Selection.Set (DateTime) | Selects the specified date cell.
Selection.Set (DateTime, DateTime) | Selects a range of date cells.
Selection.Set (DateTime, DateTime, Contact, Resource, Location, Task) | Selects a range of date cells for a specified resource.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Set Method (DateTime)

Selection.Set Method (DateTime)
See Also

Selects the specified date cell.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Set (
DateTime date
)
Visual Basic

Public Sub Set ( _
date As DateTime _
)

Parameters

date
A date whose calendar cell to select.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Set Method (DateTime, DateTime)

Selection.Set Method (DateTime, DateTime)
See Also

Selects a range of date cells.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Set (
DateTime start,
DateTime end
)
Visual Basic

Public Sub Set ( _
start As DateTime, _
end As DateTime _
)

Parameters

start
Specifies the first date in the range.
end
Specifies the last date in the range.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Set Method (DateTime, DateTime, Contact, Resource, Location, Task)

Selection.Set Method (DateTime, DateTime, Contact, Resource, Location, Task)
See Also

Selects a range of date cells for a specified resource.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public void Set (
DateTime start,
DateTime end,
Contact contact,
Resource resource,
Location location,
Task task
)
Visual Basic

Public Sub Set ( _
start As DateTime, _
end As DateTime, _
contact As Contact, _
resource As Resource, _
location As Location, _
task As Task _
)

Parameters

start
Specifies the first date in the range.
end
Specifies the last date in the range.
contact
A reference to a Contact to associate the selection with.
resource
A reference to a Resource to associate the selection with.
location
A reference to a Location to associate the selection with.
task
A reference to a Task to associate the selection with.

Remarks

Either all of the parameters contact, resource, location and task must be set to null or only one of them should be a non-null reference.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection Properties

Selection Properties

Public Properties

Name | Description
AllowMultiple | Gets or sets a value indicating whether users are allowed to select multiple elements at a time.
Contact | Gets the contact related to the current selection.
Continuous | Gets or sets a value indicating whether users can select only one range of dates in the calendar.
DayRanges | Gets a read-only list of .NET DateTime objects, sorted chronologically. Each pair in the list represents an interval of selected days.
Enabled | Gets or sets a value indicating whether users are allowed to select any cells in the calendar.
IsEmpty | Gets a value indicating whether this selection is empty.
Location | Gets the location related to the current selection.
Ranges | Gets a read-only list of .NET DateTime objects, sorted chronologically. Each pair in the list represents a selected time range.
Resource | Gets the resource related to the current selection.
SelectedElementsStyle | Gets or sets the visualization style to apply to selected elements.
Style | Gets or sets the style of the selection frame drawn around selected calendar cells.
Task | Gets the task related to the current selection.

See Also

Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.AllowMultiple Property

Selection.AllowMultiple Property

Gets or sets a value indicating whether users are allowed to select multiple elements at a time.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State AllowMultiple { get; set; }
Visual Basic

Public Property AllowMultiple As State

Property Value

Specify Enabled to allow multiple selection; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Contact Property

Selection.Contact Property

Gets the contact related to the current selection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Contact Contact { get; }
Visual Basic

Public ReadOnly Property Contact As Contact

Property Value

The contact related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a contact.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace
Location Property
Task Property
Resource Property


MindFusion.Scheduling.WinForms.Selection.Continuous Property

Selection.Continuous Property

Gets or sets a value indicating whether users can select only one range of dates in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State Continuous { get; set; }
Visual Basic

Public Property Continuous As State

Property Value

Specify Enabled to prevent users from selecting more than one, continuous range of dates in the control; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.DayRanges Property

Selection.DayRanges Property

Gets a read-only list of .NET DateTime objects, sorted chronologically. Each pair in the list represents an interval of selected days.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public IList<DateTime> DayRanges { get; }
Visual Basic

Public ReadOnly Property DayRanges As IList(Of DateTime)

Property Value

An instance of an IList class containing even number of DateTime objects.

Remarks

Any attempt to modify the returned list will result in a NotSupportedException exception. If you want to add or remove date intervals from the selection, use the Add, Set and Remove methods respectively.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace
Ranges Property


MindFusion.Scheduling.WinForms.Selection.Enabled Property

Selection.Enabled Property

Gets or sets a value indicating whether users are allowed to select any cells in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State Enabled { get; set; }
Visual Basic

Public Property Enabled As State

Property Value

Specify Enabled if users are allowed to select calendar cells; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.IsEmpty Property

Selection.IsEmpty Property

Gets a value indicating whether this selection is empty.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public bool IsEmpty { get; }
Visual Basic

Public ReadOnly Property IsEmpty As Boolean

Property Value

true if there are selected calendar cells; otherwise, false.

Remarks

Attempts to access either StartDate or EndDate of an empty selection return the current date and time.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Location Property

Selection.Location Property

Gets the location related to the current selection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Location Location { get; }
Visual Basic

Public ReadOnly Property Location As Location

Property Value

The location related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a location.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace
Contact Property
Task Property
Resource Property


MindFusion.Scheduling.WinForms.Selection.Ranges Property

Selection.Ranges Property

Gets a read-only list of .NET DateTime objects, sorted chronologically. Each pair in the list represents a selected time range.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public IList<DateTime> Ranges { get; }
Visual Basic

Public ReadOnly Property Ranges As IList(Of DateTime)

Property Value

An instance of an IList class containing even number of DateTime objects.

Remarks

Any attempt to modify the returned list will result in a NotSupportedException exception. If you want to add or remove time intervals from the selection, use the Add, Set and Remove methods respectively.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace
DayRanges Property


MindFusion.Scheduling.WinForms.Selection.Resource Property

Selection.Resource Property

Gets the resource related to the current selection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Resource Resource { get; }
Visual Basic

Public ReadOnly Property Resource As Resource

Property Value

The resource related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a resource.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace
Contact Property
Location Property
Task Property


MindFusion.Scheduling.WinForms.Selection.SelectedElementsStyle Property

Selection.SelectedElementsStyle Property

Gets or sets the visualization style to apply to selected elements.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style SelectedElementsStyle { get; set; }
Visual Basic

Public Property SelectedElementsStyle As Style

Property Value

A Style object specifying the style applied to selected calendar cells. This property cannot be null.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace
Style Class


MindFusion.Scheduling.WinForms.Selection.Style Property

Selection.Style Property

Gets or sets the style of the selection frame drawn around selected calendar cells.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public SelectionStyle Style { get; set; }
Visual Basic

Public Property Style As SelectionStyle

Property Value

A member of the SelectionStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Task Property

Selection.Task Property

Gets the task related to the current selection.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Task Task { get; }
Visual Basic

Public ReadOnly Property Task As Task

Property Value

The task related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a task.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace
Contact Property
Location Property
Resource Property


MindFusion.Scheduling.WinForms.Selection Events

Selection Events

Public Events

Name | Description
Changed | Raised when the selection changes.
SelectedElementsStyleChanged | Raised when the appearance style of the selection changes.

See Also

Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.Changed Event

Selection.Changed Event

Raised when the selection changes.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler Changed
Visual Basic

Public Event Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Selection.SelectedElementsStyleChanged Event

Selection.SelectedElementsStyleChanged Event

Raised when the appearance style of the selection changes.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler SelectedElementsStyleChanged
Visual Basic

Public Event SelectedElementsStyleChanged As EventHandler

Event Data

SelectedElementsStyleChanged event handlers receive an argument of type EventArgs.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.SelectionState Class

SelectionState Class

Represents the saved state of a Selection object.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class SelectionState
Visual Basic

Public NotInheritable Class SelectionState

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.SelectionState

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.SelectionStyle Enumeration

SelectionStyle Enumeration

Specifies what type of frame to draw around selected elements.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum SelectionStyle
Visual Basic

Public Enumeration SelectionStyle

Members

Member name | Description
FocusFrame | Draw a focus frame around the selected elements.
None | Do not draw a frame.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ShowClocks Enumeration

ShowClocks Enumeration

Specifies whether and when to display clocks in items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum ShowClocks
Visual Basic

Public Enumeration ShowClocks

Members

Member name | Description
Always | Indicates that the clocks are always displayed.
Default | Indicates that the clocks are displayed for non all-day times.
Never | Indicates that the clocks are always hidden.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.State Enumeration

State Enumeration

Specifies the state of a subject.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum State
Visual Basic

Public Enumeration State

Members

Member name | Description
Disabled | Indicates that the subject is disabled.
Enabled | Indicates that the subject is enabled.
Unspecified | Indicates undetermined state.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TaskForm Class

TaskForm Class

Ready-made form for task editing.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public class TaskForm : Form
Visual Basic

Public Class TaskForm
Inherits Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
MindFusion.Scheduling.WinForms.TaskForm

See Also

TaskForm Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TaskForm Members

TaskForm Members
Constructors Properties Methods

Ready-made form for task editing.

The following tables list the members exposed by the TaskForm type.

Public Constructors

Name | Description
TaskForm | Initializes a new instance of the TaskForm class.

Public Properties

Name | Description
Task | Gets the task being edited in this form.
TimeFormat | Gets or sets the format of times displayed within the form.

Public Methods

Name | Description
SetDates | Sets the dates to be used to initialize the form if no task is initially set.
SetTask | Sets the task that is to be edited in the form.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.

See Also

TaskForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TaskForm Constructor

TaskForm Constructor

Initializes a new instance of the TaskForm class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public TaskForm ()
Visual Basic

Public Sub New ()

See Also

TaskForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TaskForm Methods

TaskForm Methods

Public Methods

Name | Description
SetDates | Sets the dates to be used to initialize the form if no task is initially set.
SetTask | Sets the task that is to be edited in the form.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.

See Also

TaskForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TaskForm.Dispose Method

TaskForm.Dispose Method

Clean up any resources being used.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

TaskForm Members
TaskForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TaskForm.SetDates Method

TaskForm.SetDates Method

Sets the dates to be used to initialize the form if no task is initially set.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public void SetDates (
DateTime start,
DateTime due
)
Visual Basic

Public Sub SetDates ( _
start As DateTime, _
due As DateTime _
)

Parameters

start
A .NET DateTime instance specifying the start date initially displayed in the form.
due
A .NET DateTime instance specifying the due date initially displayed in the form.

See Also

TaskForm Members
TaskForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TaskForm.SetTask Method

TaskForm.SetTask Method

Sets the task that is to be edited in the form.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public void SetTask (
Task task
)
Visual Basic

Public Sub SetTask ( _
task As Task _
)

Parameters

task
A reference to the Task object to be selected in the form for editing.

See Also

TaskForm Members
TaskForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TaskForm Properties

TaskForm Properties

Public Properties

Name | Description
Task | Gets the task being edited in this form.
TimeFormat | Gets or sets the format of times displayed within the form.

See Also

TaskForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TaskForm.Task Property

TaskForm.Task Property

Gets the task being edited in this form.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public Task Task { get; }
Visual Basic

Public ReadOnly Property Task As Task

Property Value

A reference to a Task object representing the task currently being edited.

See Also

TaskForm Members
TaskForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TaskForm.TimeFormat Property

TaskForm.TimeFormat Property

Gets or sets the format of times displayed within the form.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.WinForms.StandardForms

Syntax

C#

public string TimeFormat { get; set; }
Visual Basic

Public Property TimeFormat As String

Property Value

A string specifying the display format.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

TaskForm Members
TaskForm Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme Class

Theme Class
Remarks See Also

Encapsulates visualization settings that can be applied to a Calendar control by calling the ApplyTheme method. A theme includes settings for all calendar views - List, Month, Timetable, and so on.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract class Theme : Component
Visual Basic

Public MustInherit Class Theme
Inherits Component

Remarks

You can create custom themes by deriving from this class and overriding all of the exposed properties. You can assign a custom theme to the control through the CustomTheme property. For more information on how to create custom themes, refer to Custom Themes.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Scheduling.WinForms.Theme

See Also

Theme Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme Members

Theme Members
Constructors Properties Methods

Encapsulates visualization settings that can be applied to a Calendar control by calling the ApplyTheme method. A theme includes settings for all calendar views - List, Month, Timetable, and so on.

The following tables list the members exposed by the Theme type.

Protected Constructors

Name | Description
Theme | Initializes a new instance of the Theme class.

Public Properties

Name | Description
ControlAppearance | Gets the appearance of the child controls in this theme.
ControlStyle | Gets a value indicating the appearance of the system controls within the Calendar, such as buttons and scrollbars.
ItemSettings | Gets an object defining the appearance of items in this theme.
LightBlue | Gets the LightBlue predefined theme.
LightBrown | Gets the LightBrown predefined theme.
Lila | Gets the Lila predefined theme.
ListViewSettings | Gets an object defining the appearance of the List view in this theme.
MonthRangeSettings | Gets an object defining the appearance of the MonthRange view in this theme.
MonthSettings | Gets an object defining the appearance of the SingleMonth view in this view.
ResourceViewSettings | Gets an object defining the appearance of the Resource view in this theme.
SelectionAllowMultiple | Gets whether the multiple selection is allowed.
SelectionContinuous | Gets a flag indicating whether the users can select only one range of dates in the calendar.
SelectionEnabled | Gets whether the selection is enabled.
SelectionSelectedElementsStyle | Gets the Style of the selected elements in this theme.
SelectionStyle | Gets the selection style in this theme.
Silver | Gets the Silver predefined theme.
Standard | Gets the standard MindFusion.Scheduling theme.
TimetableSettings | Gets an object defining the appearance of the Timetable view in this theme.
Vista | Gets the Vista predefined theme.
WeekRangeSettings | Gets an object defining the appearance of the WeekRange view in this theme.
Windows2003 | Gets the Windows2003 predefined theme.

Protected Methods

Name | Description
CreateControlStyle | Creates a new ControlStyle object.
CreateItemSettings | Creates a new ItemSettings object.
CreateListViewSettings | Creates a new ListViewSettings object.
CreateMonthRangeSettings | Creates a new MonthRangeSettings object.
CreateMonthSettings | Creates a new MonthSettings object.
CreateResourceViewSettings | Creates a new ResourceViewSettings object.
CreateTimetableSettings | Creates a new TimetableSettings object.
CreateWeekRangeSettings | Creates a new WeekRangeSettings object.

See Also

Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme Constructor

Theme Constructor

Initializes a new instance of the Theme class.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected Theme ()
Visual Basic

Protected Sub New ()

Remarks

This method is marked as protected because the Theme class is abstract and cannot be instantiated.

See Also

Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme Methods

Theme Methods

Protected Methods

Name | Description
CreateControlStyle | Creates a new ControlStyle object.
CreateItemSettings | Creates a new ItemSettings object.
CreateListViewSettings | Creates a new ListViewSettings object.
CreateMonthRangeSettings | Creates a new MonthRangeSettings object.
CreateMonthSettings | Creates a new MonthSettings object.
CreateResourceViewSettings | Creates a new ResourceViewSettings object.
CreateTimetableSettings | Creates a new TimetableSettings object.
CreateWeekRangeSettings | Creates a new WeekRangeSettings object.

See Also

Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.CreateControlStyle Method

Theme.CreateControlStyle Method

Creates a new ControlStyle object.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected ControlStyle CreateControlStyle ()
Visual Basic

Protected Function CreateControlStyle () As ControlStyle

Return Value

An instance of the ControlStyle class.

Remarks

Invoke this method from within a derived custom theme class in order to create an instance of the ControlStyle class. This is necessary since ControlStyle does not have a public constructor and cannot be instantiated directly.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.CreateItemSettings Method

Theme.CreateItemSettings Method

Creates a new ItemSettings object.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected ItemSettings CreateItemSettings ()
Visual Basic

Protected Function CreateItemSettings () As ItemSettings

Return Value

An instance of the ItemSettings class.

Remarks

Invoke this method from within a derived custom theme class in order to create an instance of the ItemSettings class. This is necessary since ItemSettings does not have a public constructor and cannot be instantiated directly.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.CreateListViewSettings Method

Theme.CreateListViewSettings Method

Creates a new ListViewSettings object.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected ListViewSettings CreateListViewSettings ()
Visual Basic

Protected Function CreateListViewSettings () As ListViewSettings

Return Value

An instance of the ListViewSettings class.

Remarks

Invoke this method from within a derived custom theme class in order to create an instance of the ListViewSettings class. This is necessary since ListViewSettings does not have a public constructor and cannot be instantiated directly.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.CreateMonthRangeSettings Method

Theme.CreateMonthRangeSettings Method

Creates a new MonthRangeSettings object.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected MonthRangeSettings CreateMonthRangeSettings ()
Visual Basic

Protected Function CreateMonthRangeSettings () As MonthRangeSettings

Return Value

An instance of the MonthRangeSettings class.

Remarks

Invoke this method from within a derived custom theme class in order to create an instance of the MonthRangeSettings class. This is necessary since MonthRangeSettings does not have a public constructor and cannot be instantiated directly.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.CreateMonthSettings Method

Theme.CreateMonthSettings Method

Creates a new MonthSettings object.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected MonthSettings CreateMonthSettings ()
Visual Basic

Protected Function CreateMonthSettings () As MonthSettings

Return Value

An instance of the MonthSettings class.

Remarks

Invoke this method from within a derived custom theme class in order to create an instance of the MonthSettings class. This is necessary since MonthSettings does not have a public constructor and cannot be instantiated directly.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.CreateResourceViewSettings Method

Theme.CreateResourceViewSettings Method

Creates a new ResourceViewSettings object.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected ResourceViewSettings CreateResourceViewSettings ()
Visual Basic

Protected Function CreateResourceViewSettings () As ResourceViewSettings

Return Value

An instance of the ResourceViewSettings class.

Remarks

Invoke this method from within a derived custom theme class in order to create an instance of the ResourceViewSettings class. This is necessary since ResourceViewSettings does not have a public constructor and cannot be instantiated directly.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.CreateTimetableSettings Method

Theme.CreateTimetableSettings Method

Creates a new TimetableSettings object.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected TimetableSettings CreateTimetableSettings ()
Visual Basic

Protected Function CreateTimetableSettings () As TimetableSettings

Return Value

An instance of the TimetableSettings class.

Remarks

Invoke this method from within a derived custom theme class in order to create an instance of the TimetableSettings class. This is necessary since TimetableSettings does not have a public constructor and cannot be instantiated directly.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.CreateWeekRangeSettings Method

Theme.CreateWeekRangeSettings Method

Creates a new WeekRangeSettings object.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

protected WeekRangeSettings CreateWeekRangeSettings ()
Visual Basic

Protected Function CreateWeekRangeSettings () As WeekRangeSettings

Return Value

An instance of the WeekRangeSettings class.

Remarks

Invoke this method from within a derived custom theme class in order to create an instance of the WeekRangeSettings class. This is necessary since WeekRangeSettings does not have a public constructor and cannot be instantiated directly.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme Properties

Theme Properties

Public Properties

Name | Description
ControlAppearance | Gets the appearance of the child controls in this theme.
ControlStyle | Gets a value indicating the appearance of the system controls within the Calendar, such as buttons and scrollbars.
ItemSettings | Gets an object defining the appearance of items in this theme.
LightBlue | Gets the LightBlue predefined theme.
LightBrown | Gets the LightBrown predefined theme.
Lila | Gets the Lila predefined theme.
ListViewSettings | Gets an object defining the appearance of the List view in this theme.
MonthRangeSettings | Gets an object defining the appearance of the MonthRange view in this theme.
MonthSettings | Gets an object defining the appearance of the SingleMonth view in this view.
ResourceViewSettings | Gets an object defining the appearance of the Resource view in this theme.
SelectionAllowMultiple | Gets whether the multiple selection is allowed.
SelectionContinuous | Gets a flag indicating whether the users can select only one range of dates in the calendar.
SelectionEnabled | Gets whether the selection is enabled.
SelectionSelectedElementsStyle | Gets the Style of the selected elements in this theme.
SelectionStyle | Gets the selection style in this theme.
Silver | Gets the Silver predefined theme.
Standard | Gets the standard MindFusion.Scheduling theme.
TimetableSettings | Gets an object defining the appearance of the Timetable view in this theme.
Vista | Gets the Vista predefined theme.
WeekRangeSettings | Gets an object defining the appearance of the WeekRange view in this theme.
Windows2003 | Gets the Windows2003 predefined theme.

See Also

Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.ControlAppearance Property

Theme.ControlAppearance Property

Gets the appearance of the child controls in this theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract ControlAppearance ControlAppearance { get; }
Visual Basic

Public MustOverride ReadOnly Property ControlAppearance As ControlAppearance

Property Value

A member of the ControlAppearance enumeration.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.ControlStyle Property

Theme.ControlStyle Property

Gets a value indicating the appearance of the system controls within the Calendar, such as buttons and scrollbars.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract ControlStyle ControlStyle { get; }
Visual Basic

Public MustOverride ReadOnly Property ControlStyle As ControlStyle

Property Value

An instance of the ControlStyle class.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.ItemSettings Property

Theme.ItemSettings Property

Gets an object defining the appearance of items in this theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract ItemSettings ItemSettings { get; }
Visual Basic

Public MustOverride ReadOnly Property ItemSettings As ItemSettings

Property Value

An instance of the ItemSettings class.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.LightBlue Property

Theme.LightBlue Property

Gets the LightBlue predefined theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

public static Theme LightBlue { get; }
Visual Basic

Public Shared ReadOnly Property LightBlue As Theme

Property Value

An instance of the Theme class representing the LightBlue theme.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.Compact Namespace
PocketPlanner Themes
Standard Property
LightBrown Property


MindFusion.Scheduling.WinForms.Theme.LightBrown Property

Theme.LightBrown Property

Gets the LightBrown predefined theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling.Compact

Syntax

C#

public static Theme LightBrown { get; }
Visual Basic

Public Shared ReadOnly Property LightBrown As Theme

Property Value

An instance of the Theme class representing the LightBrown theme.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.Compact Namespace
PocketPlanner Themes
Standard Property
LightBlue Property


MindFusion.Scheduling.WinForms.Theme.Lila Property

Theme.Lila Property

Gets the Lila predefined theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public static Theme Lila { get; }
Visual Basic

Public Shared ReadOnly Property Lila As Theme

Property Value

An instance of the Theme class representing the Lila theme.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace
MindFusion.Scheduling Themes
Standard Property
Windows2003 Property
Silver Property
Vista Property


MindFusion.Scheduling.WinForms.Theme.ListViewSettings Property

Theme.ListViewSettings Property

Gets an object defining the appearance of the List view in this theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract ListViewSettings ListViewSettings { get; }
Visual Basic

Public MustOverride ReadOnly Property ListViewSettings As ListViewSettings

Property Value

An instance of the ListViewSettings class.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.MonthRangeSettings Property

Theme.MonthRangeSettings Property

Gets an object defining the appearance of the MonthRange view in this theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract MonthRangeSettings MonthRangeSettings { get; }
Visual Basic

Public MustOverride ReadOnly Property MonthRangeSettings As MonthRangeSettings

Property Value

An instance of the MonthRangeSettings class.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.MonthSettings Property

Theme.MonthSettings Property

Gets an object defining the appearance of the SingleMonth view in this view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract MonthSettings MonthSettings { get; }
Visual Basic

Public MustOverride ReadOnly Property MonthSettings As MonthSettings

Property Value

An instance of the MonthSettings class.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.ResourceViewSettings Property

Theme.ResourceViewSettings Property

Gets an object defining the appearance of the Resource view in this theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract ResourceViewSettings ResourceViewSettings { get; }
Visual Basic

Public MustOverride ReadOnly Property ResourceViewSettings As ResourceViewSettings

Property Value

An instance of the ResourceViewSettings class.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.SelectionAllowMultiple Property

Theme.SelectionAllowMultiple Property

Gets whether the multiple selection is allowed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract State SelectionAllowMultiple { get; }
Visual Basic

Public MustOverride ReadOnly Property SelectionAllowMultiple As State

Property Value

A member of the State enumeration.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.SelectionContinuous Property

Theme.SelectionContinuous Property

Gets a flag indicating whether the users can select only one range of dates in the calendar.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract State SelectionContinuous { get; }
Visual Basic

Public MustOverride ReadOnly Property SelectionContinuous As State

Property Value

A member of the State enumeration.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.SelectionEnabled Property

Theme.SelectionEnabled Property

Gets whether the selection is enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract State SelectionEnabled { get; }
Visual Basic

Public MustOverride ReadOnly Property SelectionEnabled As State

Property Value

A member of the State enumeration.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.SelectionSelectedElementsStyle Property

Theme.SelectionSelectedElementsStyle Property

Gets the Style of the selected elements in this theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract Style SelectionSelectedElementsStyle { get; }
Visual Basic

Public MustOverride ReadOnly Property SelectionSelectedElementsStyle As Style

Property Value

An instance of the Style class.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.SelectionStyle Property

Theme.SelectionStyle Property

Gets the selection style in this theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract SelectionStyle SelectionStyle { get; }
Visual Basic

Public MustOverride ReadOnly Property SelectionStyle As SelectionStyle

Property Value

A member of the SelectionStyle enumeration.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.Silver Property

Theme.Silver Property

Gets the Silver predefined theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public static Theme Silver { get; }
Visual Basic

Public Shared ReadOnly Property Silver As Theme

Property Value

An instance of the Theme class representing the Silver theme.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace
MindFusion.Scheduling Themes
Standard Property
Windows2003 Property
Lila Property
Vista Property


MindFusion.Scheduling.WinForms.Theme.Standard Property

Theme.Standard Property

Gets the standard MindFusion.Scheduling theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public static Theme Standard { get; }
Visual Basic

Public Shared ReadOnly Property Standard As Theme

Property Value

An instance of the Theme class representing the Standard theme.

Remarks

The standard theme is based on the current color settings of Windows.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace
MindFusion.Scheduling Themes
Lila Property
Windows2003 Property
Silver Property
Vista Property


MindFusion.Scheduling.WinForms.Theme.TimetableSettings Property

Theme.TimetableSettings Property

Gets an object defining the appearance of the Timetable view in this theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract TimetableSettings TimetableSettings { get; }
Visual Basic

Public MustOverride ReadOnly Property TimetableSettings As TimetableSettings

Property Value

An instance of the TimetableSettings class.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.Vista Property

Theme.Vista Property

Gets the Vista predefined theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public static Theme Vista { get; }
Visual Basic

Public Shared ReadOnly Property Vista As Theme

Property Value

An instance of the Theme class representing the Vista theme.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace
MindFusion.Scheduling Themes
Standard Property
Windows2003 Property
Silver Property
Lila Property


MindFusion.Scheduling.WinForms.Theme.WeekRangeSettings Property

Theme.WeekRangeSettings Property

Gets an object defining the appearance of the WeekRange view in this theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract WeekRangeSettings WeekRangeSettings { get; }
Visual Basic

Public MustOverride ReadOnly Property WeekRangeSettings As WeekRangeSettings

Property Value

An instance of the WeekRangeSettings class.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.Theme.Windows2003 Property

Theme.Windows2003 Property

Gets the Windows2003 predefined theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public static Theme Windows2003 { get; }
Visual Basic

Public Shared ReadOnly Property Windows2003 As Theme

Property Value

An instance of the Theme class representing the Windows2003 theme.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.Compact Namespace
MindFusion.Scheduling Themes
Standard Property
Silver Property
Lila Property
Vista Property


MindFusion.Scheduling.WinForms.ThemeType Enumeration

ThemeType Enumeration

Specifies a calendar theme.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum ThemeType
Visual Basic

Public Enumeration ThemeType

Members

Member name | Description
Custom | Indicates a user-defined theme. This value is available only in MindFusion.Scheduling.
Lila | The Lila theme. This value is available only in MindFusion.Scheduling.
Silver | The Silver theme. This value is available only in MindFusion.Scheduling.
Standard | The standard MindFusion.Scheduling theme.
Windows2003 | The Windows2003 standard theme. This value is available only in MindFusion.Scheduling.
Vista | A theme with a Windows Vista look and feel. This value is available only in MindFusion.Scheduling.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimelineSettings Class

TimelineSettings Class

Encapsulates settings for a timeline in a Resource view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class TimelineSettings
Visual Basic

Public NotInheritable Class TimelineSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.TimelineSettings

See Also

TimelineSettings Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimelineSettings Members

TimelineSettings Members
Properties

Encapsulates settings for a timeline in a Resource view.

The following tables list the members exposed by the TimelineSettings type.

Public Properties

Name | Description
Format | Gets or sets the format of the displayed dates in the timeline.
NowColor | Gets or sets the color used to mark the current time in the timeline.
NowFillColor | Gets or sets the fill color used to mark the current time in the timeline.
ShowCurrentTime | Gets or sets a value indicating whether to indicate the current time in the timeline.
ShowTicks | Gets or sets a value indicating whether the timeline displays tick lines.
Size | Gets or sets the size of the timeline.
SpanCellCount | Gets or sets a value indicating the number of cells to span when SpanTexts is enabled.
SpanTexts | Gets or sets a value indicating whether some cell texts will span more than one cell when the space in their corresponding cells is insufficient due to scaling the view.
Style | Gets or sets the style of the timeline.
TickSize | Gets or sets the size of the ticks displayed in the timeline.
Unit | Gets or sets the time unit of the timeline.
UnitCount | Gets or sets the number of units between adjacent ticks in the timeline.

See Also

TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimelineSettings Properties

TimelineSettings Properties

Public Properties

Name | Description
Format | Gets or sets the format of the displayed dates in the timeline.
NowColor | Gets or sets the color used to mark the current time in the timeline.
NowFillColor | Gets or sets the fill color used to mark the current time in the timeline.
ShowCurrentTime | Gets or sets a value indicating whether to indicate the current time in the timeline.
ShowTicks | Gets or sets a value indicating whether the timeline displays tick lines.
Size | Gets or sets the size of the timeline.
SpanCellCount | Gets or sets a value indicating the number of cells to span when SpanTexts is enabled.
SpanTexts | Gets or sets a value indicating whether some cell texts will span more than one cell when the space in their corresponding cells is insufficient due to scaling the view.
Style | Gets or sets the style of the timeline.
TickSize | Gets or sets the size of the ticks displayed in the timeline.
Unit | Gets or sets the time unit of the timeline.
UnitCount | Gets or sets the number of units between adjacent ticks in the timeline.

See Also

TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.Format Property

TimelineSettings.Format Property

Gets or sets the format of the displayed dates in the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string Format { get; set; }
Visual Basic

Public Property Format As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.NowColor Property

TimelineSettings.NowColor Property

Gets or sets the color used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color NowColor { get; set; }
Visual Basic

Public Property NowColor As Color

Property Value

A .NET Color object specifying the color used to indicate the current time. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace
NowFillColor Property
ShowCurrentTime Property


MindFusion.Scheduling.WinForms.TimelineSettings.NowFillColor Property

TimelineSettings.NowFillColor Property

Gets or sets the fill color used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color NowFillColor { get; set; }
Visual Basic

Public Property NowFillColor As Color

Property Value

A .NET Color object specifying the color used to indicate the current time. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace
NowColor Property
ShowCurrentTime Property


MindFusion.Scheduling.WinForms.TimelineSettings.ShowCurrentTime Property

TimelineSettings.ShowCurrentTime Property

Gets or sets a value indicating whether to indicate the current time in the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowCurrentTime { get; set; }
Visual Basic

Public Property ShowCurrentTime As State

Property Value

Specify Enabled to indicate the current time; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace
NowColor Property
NowFillColor Property


MindFusion.Scheduling.WinForms.TimelineSettings.ShowTicks Property

TimelineSettings.ShowTicks Property

Gets or sets a value indicating whether the timeline displays tick lines.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowTicks { get; set; }
Visual Basic

Public Property ShowTicks As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.Size Property

TimelineSettings.Size Property

Gets or sets the size of the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Size { get; set; }
Visual Basic

Public Property Size As Integer

Property Value

A non-negative integer value. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the size to be calculated automatically based on the size of the header font.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.SpanCellCount Property

TimelineSettings.SpanCellCount Property

Gets or sets a value indicating the number of cells to span when SpanTexts is enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int SpanCellCount { get; set; }
Visual Basic

Public Property SpanCellCount As Integer

Property Value

A non-negative integer value specifying the number of cells to span. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

If this value is 0, it is automatically calculated based on the current scale factor, which is specified by TimelineScale.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.SpanTexts Property

TimelineSettings.SpanTexts Property

Gets or sets a value indicating whether some cell texts will span more than one cell when the space in their corresponding cells is insufficient due to scaling the view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State SpanTexts { get; set; }
Visual Basic

Public Property SpanTexts As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

The number of spanned cells is specified by the SpanCellCount property. If the value of this property is 0, then the number of cells is automatically calculated based on the current scale factor, which is specified by the TimelineScale property.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace
SpanCellCount Property


MindFusion.Scheduling.WinForms.TimelineSettings.Style Property

TimelineSettings.Style Property

Gets or sets the style of the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style Style { get; set; }
Visual Basic

Public Property Style As Style

Property Value

A Style object specifying the style of the timeline. This property cannot be null.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.TickSize Property

TimelineSettings.TickSize Property

Gets or sets the size of the ticks displayed in the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int TickSize { get; set; }
Visual Basic

Public Property TickSize As Integer

Property Value

A non-negative integer value. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.Unit Property

TimelineSettings.Unit Property

Gets or sets the time unit of the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimeUnit Unit { get; set; }
Visual Basic

Public Property Unit As TimeUnit

Property Value

A member of the TimeUnit enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace
UnitCount Property


MindFusion.Scheduling.WinForms.TimelineSettings.UnitCount Property

TimelineSettings.UnitCount Property

Gets or sets the number of units between adjacent ticks in the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int UnitCount { get; set; }
Visual Basic

Public Property UnitCount As Integer

Property Value

A non-negative integer value. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WinForms Namespace
Unit Property


MindFusion.Scheduling.WinForms.TimetableSettings Class

TimetableSettings Class

Defines properties that allow customizing the visualization of the calendar in Timetable view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public sealed class TimetableSettings : ViewSettings
Visual Basic

Public NotInheritable Class TimetableSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.ViewSettings
MindFusion.Scheduling.WinForms.TimetableSettings

See Also

TimetableSettings Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings Members

TimetableSettings Members
Properties

Defines properties that allow customizing the visualization of the calendar in Timetable view.

The following tables list the members exposed by the TimetableSettings type.

Public Properties

Name | Description
AllowResizeColumns | Gets or sets a value indicating whether the users can resize timetable columns.
CellSize | Gets or sets the size of time cells.
CellStyle | Gets or sets the style of a time segment cell.
CellTime | Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.
ColumnBandSize | Gets or sets the size of the bands displayed on the left/top side of each timetable column.
Dates | Gets a collection of all dates visualized in the timetable.
DayHeaderBrush | Gets or sets the brush used to paint the subheader where the all-day items are displayed.
DayHeaderMinSize | Gets or sets the minimum size of the header displaying all-day items.
EnableAutoDayChange | Gets or sets a value indicating whether the Timetable view will automatically scroll one day forth and back when the user moves the mouse at the top or at the bottom of the view.
EnableCollisions | Gets or sets a value indicating whether the item collision processing is enabled.
EnableDayItems | Gets or sets a value indicating whether items longer than 24 hours are displayed in the day header or not.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EndTime | Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GeneralFormat | Gets or sets the string to use when formatting times in the timeline.
GroupHours | Gets or sets a value indicating whether hours displayed in the timeline are grouped.
HeaderDateFormat | Gets or sets how to format and display dates in the timetable header.
HeaderShadowColor | Gets or sets the color of the shadows cast by headers.
HeaderShadowOffset | Gets or sets the offset of the shadows from the headers that cast them.
HeaderShadowStyle | Gets or sets the style of the shadows cast by headers.
InfoHeaderBrush | Gets or sets the brush used to paint the info header.
InfoHeaderSize | Gets or sets the size of the info header.
ItemOffset | Gets or set the distance between the first item and its adjoining cell side.
MainHeaderSize | Gets or sets the size of the main header.
MaxAllDayItems | Gets or sets the maximum number of all-day items visible in the columns headers at a time.
MinColumnSize | Gets or sets the smallest size allowed for timetable columns.
MinItemSize | Gets or sets the smallest size allowed for schedule items.
MinuteFormat | Gets or sets how to format and display minutes.
NowColor | Gets or sets the color used to mark the current time in the timeline.
NowFillColor | Gets or sets the fill color used to mark the current time in the timeline.
Orientation | Gets or sets the view orientation.
ReverseGrouping | Gets or sets a value indicating whether grouping (if enabled) will be performed first by the resource, and then by the date.
RotateHeaderTexts | Gets or sets a value indicating whether the header texts are rotated in a view with Horizontal orientation.
RotateTimelineTexts | Gets or sets a value indicating whether the timeline texts are rotated in a view with Horizontal orientation.
ScrollStep | Gets or sets the number of days to scroll when the user clicks the navigation buttons.
SecondTimelineOffset | Gets or sets the offset in hours of the second timeline.
SecondTimelineStyle | Gets or sets a value indicating whether a second timeline is displayed in addition to the primary one.
SelectWholeDayOnHeaderClick | Gets or sets a value indicating whether the whole day is selected when the user clicks in the column's header.
ShowAM | Gets or sets a value indicating whether the AM and PM suffixes are displayed.
ShowCurrentTime | Gets or sets a value indicating whether to display the current time in the timeline.
ShowDayHeader | Gets or sets a value indicating whether to show the header displaying all-day items.
ShowInfoHeader | Gets or sets a value indicating whether to show the info header.
ShowItemSpans | Gets or sets a value indicating whether the item time spans are also drawn in the left band of the corresponding column.
ShowMinutesInHourHeaders | Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.
ShowMoreItemsCue | Gets or sets a value indicating whether to display a 'more items' icon in the timeline header when some items in a timetable column are not currently visible.
ShowNavigationButtons | Gets or sets a value indicating whether the Timetable view displays navigation buttons.
ShowPadding | Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.
ShowWorkTime | Gets or sets a value indicating whether the work time should be displayed with different style.
SnapInterval | Gets or sets the custom snap interval.
StartTime | Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubHeaderSize | Gets or sets the size of the secondary header.
TimelineSize | Gets or sets the size of the timeline header.
TimelineStyle | Gets or sets the style of the timeline header.
TwelveHourFormat | Gets or sets a value indicating whether to use a 12-hour format.
UseZoom | Gets or sets a value indicating whether to use the associated zoom factor or the fixed cell height when displaying cells.
VisibleColumns | Gets or sets the number of columns visible in the view.
WorkTimeCellStyle | Gets or sets the style of cells in the work time interval.
WorkTimeEndHour | Gets or sets the end hour of the work time interval.
WorkTimeStartHour | Gets or sets the start hour of the work time interval.
ZoomFactor | Gets or sets the zoom factor when zoom is enabled.

See Also

TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings Properties

TimetableSettings Properties

Public Properties

Name | Description
AllowResizeColumns | Gets or sets a value indicating whether the users can resize timetable columns.
CellSize | Gets or sets the size of time cells.
CellStyle | Gets or sets the style of a time segment cell.
CellTime | Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.
ColumnBandSize | Gets or sets the size of the bands displayed on the left/top side of each timetable column.
Dates | Gets a collection of all dates visualized in the timetable.
DayHeaderBrush | Gets or sets the brush used to paint the subheader where the all-day items are displayed.
DayHeaderMinSize | Gets or sets the minimum size of the header displaying all-day items.
EnableAutoDayChange | Gets or sets a value indicating whether the Timetable view will automatically scroll one day forth and back when the user moves the mouse at the top or at the bottom of the view.
EnableCollisions | Gets or sets a value indicating whether the item collision processing is enabled.
EnableDayItems | Gets or sets a value indicating whether items longer than 24 hours are displayed in the day header or not.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EndTime | Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GeneralFormat | Gets or sets the string to use when formatting times in the timeline.
GroupHours | Gets or sets a value indicating whether hours displayed in the timeline are grouped.
HeaderDateFormat | Gets or sets how to format and display dates in the timetable header.
HeaderShadowColor | Gets or sets the color of the shadows cast by headers.
HeaderShadowOffset | Gets or sets the offset of the shadows from the headers that cast them.
HeaderShadowStyle | Gets or sets the style of the shadows cast by headers.
InfoHeaderBrush | Gets or sets the brush used to paint the info header.
InfoHeaderSize | Gets or sets the size of the info header.
ItemOffset | Gets or set the distance between the first item and its adjoining cell side.
MainHeaderSize | Gets or sets the size of the main header.
MaxAllDayItems | Gets or sets the maximum number of all-day items visible in the columns headers at a time.
MinColumnSize | Gets or sets the smallest size allowed for timetable columns.
MinItemSize | Gets or sets the smallest size allowed for schedule items.
MinuteFormat | Gets or sets how to format and display minutes.
NowColor | Gets or sets the color used to mark the current time in the timeline.
NowFillColor | Gets or sets the fill color used to mark the current time in the timeline.
Orientation | Gets or sets the view orientation.
ReverseGrouping | Gets or sets a value indicating whether grouping (if enabled) will be performed first by the resource, and then by the date.
RotateHeaderTexts | Gets or sets a value indicating whether the header texts are rotated in a view with Horizontal orientation.
RotateTimelineTexts | Gets or sets a value indicating whether the timeline texts are rotated in a view with Horizontal orientation.
ScrollStep | Gets or sets the number of days to scroll when the user clicks the navigation buttons.
SecondTimelineOffset | Gets or sets the offset in hours of the second timeline.
SecondTimelineStyle | Gets or sets a value indicating whether a second timeline is displayed in addition to the primary one.
SelectWholeDayOnHeaderClick | Gets or sets a value indicating whether the whole day is selected when the user clicks in the column's header.
ShowAM | Gets or sets a value indicating whether the AM and PM suffixes are displayed.
ShowCurrentTime | Gets or sets a value indicating whether to display the current time in the timeline.
ShowDayHeader | Gets or sets a value indicating whether to show the header displaying all-day items.
ShowInfoHeader | Gets or sets a value indicating whether to show the info header.
ShowItemSpans | Gets or sets a value indicating whether the item time spans are also drawn in the left band of the corresponding column.
ShowMinutesInHourHeaders | Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.
ShowMoreItemsCue | Gets or sets a value indicating whether to display a 'more items' icon in the timeline header when some items in a timetable column are not currently visible.
ShowNavigationButtons | Gets or sets a value indicating whether the Timetable view displays navigation buttons.
ShowPadding | Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.
ShowWorkTime | Gets or sets a value indicating whether the work time should be displayed with different style.
SnapInterval | Gets or sets the custom snap interval.
StartTime | Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubHeaderSize | Gets or sets the size of the secondary header.
TimelineSize | Gets or sets the size of the timeline header.
TimelineStyle | Gets or sets the style of the timeline header.
TwelveHourFormat | Gets or sets a value indicating whether to use a 12-hour format.
UseZoom | Gets or sets a value indicating whether to use the associated zoom factor or the fixed cell height when displaying cells.
VisibleColumns | Gets or sets the number of columns visible in the view.
WorkTimeCellStyle | Gets or sets the style of cells in the work time interval.
WorkTimeEndHour | Gets or sets the end hour of the work time interval.
WorkTimeStartHour | Gets or sets the start hour of the work time interval.
ZoomFactor | Gets or sets the zoom factor when zoom is enabled.

See Also

TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.AllowResizeColumns Property

TimetableSettings.AllowResizeColumns Property

Gets or sets a value indicating whether the users can resize timetable columns.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State AllowResizeColumns { get; set; }
Visual Basic

Public Property AllowResizeColumns As State

Property Value

Specify Enabled to let users resize the view columns; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.CellSize Property

TimetableSettings.CellSize Property

Gets or sets the size of time cells.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int CellSize { get; set; }
Visual Basic

Public Property CellSize As Integer

Property Value

An integer value specifying the cell size. The minimal allowed value is 10. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
CellStyle Property


MindFusion.Scheduling.WinForms.TimetableSettings.CellStyle Property

TimetableSettings.CellStyle Property

Gets or sets the style of a time segment cell.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style CellStyle { get; set; }
Visual Basic

Public Property CellStyle As Style

Property Value

A Style object specifying the style of timetable cells. This property cannot be null.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
CellSize Property


MindFusion.Scheduling.WinForms.TimetableSettings.CellTime Property

TimetableSettings.CellTime Property

Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimeSpan CellTime { get; set; }
Visual Basic

Public Property CellTime As TimeSpan

Property Value

A TimeSpan object that specifies the time length of a single cell. The allowed values range from 1 second to 1 hour inclusive. Assign -1 ticks to this property to use the corresponding value from the current theme.

Example

The following sample demonstrates several ways for setting the time span of timetable cells. The sample assumes that calendar already references an existing Calendar object.

C#

// Set the cell time to 10 minutes
calendar.TimetableSettings.CellTime = TimeSpan.FromMinutes(10);

// Set the cell time to 1 second
calendar.TimetableSettings.CellTime = TimeSpan.FromSeconds(1);

// Set the cell time to 1 minute and 20 seconds
calendar.TimetableSettings.CellTime = new TimeSpan(0, 1, 20);
Visual Basic

' Set the cell time to 10 minutes
calendar.TimetableSettings.CellTime = TimeSpan.FromMinutes(10)

' Set the cell time to 1 second
calendar.TimetableSettings.CellTime = TimeSpan.FromSeconds(1)

' Set the cell time to 1 minute and 20 seconds
calendar.TimetableSettings.CellTime = New TimeSpan(0, 1, 20)

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ColumnBandSize Property

TimetableSettings.ColumnBandSize Property

Gets or sets the size of the bands displayed on the left/top side of each timetable column.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ColumnBandSize { get; set; }
Visual Basic

Public Property ColumnBandSize As Integer

Property Value

A non-negative integer specifying band width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

For best results, assign to this property the value of ItemSettings.MoveBandSize.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.Dates Property

TimetableSettings.Dates Property

Gets a collection of all dates visualized in the timetable.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateCollection Dates { get; }
Visual Basic

Public ReadOnly Property Dates As DateCollection

Property Value

An instance of the DateCollection class specifying which dates to display as columns in the timetable view.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.DayHeaderBrush Property

TimetableSettings.DayHeaderBrush Property

Gets or sets the brush used to paint the subheader where the all-day items are displayed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush DayHeaderBrush { get; set; }
Visual Basic

Public Property DayHeaderBrush As Brush

Property Value

An instance of a Brush-derived class used to fill the day header. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.DayHeaderMinSize Property

TimetableSettings.DayHeaderMinSize Property

Gets or sets the minimum size of the header displaying all-day items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int DayHeaderMinSize { get; set; }
Visual Basic

Public Property DayHeaderMinSize As Integer

Property Value

An integer value specifying the minimal header size in pixels. The minimal allowed value is 5. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.EnableAutoDayChange Property

TimetableSettings.EnableAutoDayChange Property

Gets or sets a value indicating whether the Timetable view will automatically scroll one day forth and back when the user moves the mouse at the top or at the bottom of the view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State EnableAutoDayChange { get; set; }
Visual Basic

Public Property EnableAutoDayChange As State

Property Value

A member of the State enumeration.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.EnableCollisions Property

TimetableSettings.EnableCollisions Property

Gets or sets a value indicating whether the item collision processing is enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State EnableCollisions { get; set; }
Visual Basic

Public Property EnableCollisions As State

Property Value

A member of the State enumeration.

Remarks

Turn this flag off if you don't need collision detection to improve performance.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.EnableDayItems Property

TimetableSettings.EnableDayItems Property

Gets or sets a value indicating whether items longer than 24 hours are displayed in the day header or not.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State EnableDayItems { get; set; }
Visual Basic

Public Property EnableDayItems As State

Property Value

A value of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

By default, items longer than 1 day or items marked as AllDayEvent are displayed in the day header of the view. If the day header is not displayed (that is, ShowDayHeader is set to State.Disabled) then these items are never displayed. Settings this property to State.Disabled causes all items regardless of their length to be displayed in the main view.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.EnableSnapping Property

TimetableSettings.EnableSnapping Property

Gets or sets a value indicating whether custom snapping is enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State EnableSnapping { get; set; }
Visual Basic

Public Property EnableSnapping As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
SnapInterval Property


MindFusion.Scheduling.WinForms.TimetableSettings.EndTime Property

TimetableSettings.EndTime Property

Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int EndTime { get; set; }
Visual Basic

Public Property EndTime As Integer

Property Value

An integer value specifying the end time in minutes. The allowed values range from 0 to 2880. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

Specifying value for this property which is smaller than the value of StartTime is permissible. This indicates that the end value represents time from the next day. For example if StartTime is set to 600 (10:00 AM) and EndTime is set to 480 (8:00 AM), then each column in the view represents the time from 10:00 AM until 8:00 AM on the following day. Specifying 1920 (480 + 1440) for the EndTime yields the same result.

Note

It is possible to specify more than 24 hours to be displayed in a single timetable column. Doing so though might lead to ambiguities because certain periods of time will appear in more than one place (for example, a period will appear once at the end of a column and again in the beginning of the next one).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
StartTime Property
CellTime Property


MindFusion.Scheduling.WinForms.TimetableSettings.ExpandActiveItemOn Property

TimetableSettings.ExpandActiveItemOn Property

Gets or sets whether the active item should ignore collisions.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ItemAction ExpandActiveItemOn { get; set; }
Visual Basic

Public Property ExpandActiveItemOn As ItemAction

Property Value

A member of the ItemAction enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.GeneralFormat Property

TimetableSettings.GeneralFormat Property

Gets or sets the string to use when formatting times in the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string GeneralFormat { get; set; }
Visual Basic

Public Property GeneralFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.GroupHours Property

TimetableSettings.GroupHours Property

Gets or sets a value indicating whether hours displayed in the timeline are grouped.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State GroupHours { get; set; }
Visual Basic

Public Property GroupHours As State

Property Value

Specify Enabled to enable grouping; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Certain conditions prevent hours from grouping, such as when the hours are not divisible by the specified CellTime.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.HeaderDateFormat Property

TimetableSettings.HeaderDateFormat Property

Gets or sets how to format and display dates in the timetable header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string HeaderDateFormat { get; set; }
Visual Basic

Public Property HeaderDateFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.HeaderShadowColor Property

TimetableSettings.HeaderShadowColor Property

Gets or sets the color of the shadows cast by headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color HeaderShadowColor { get; set; }
Visual Basic

Public Property HeaderShadowColor As Color

Property Value

A .NET Color object specifying the color of headers' shadows. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowOffset Property
HeaderShadowStyle Property


MindFusion.Scheduling.WinForms.TimetableSettings.HeaderShadowOffset Property

TimetableSettings.HeaderShadowOffset Property

Gets or sets the offset of the shadows from the headers that cast them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderShadowOffset { get; set; }
Visual Basic

Public Property HeaderShadowOffset As Integer

Property Value

An integer value specifying how many pixels there are between headers and their shadows. The allowed values range from 1 to 5. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowColor Property
HeaderShadowStyle Property


MindFusion.Scheduling.WinForms.TimetableSettings.HeaderShadowStyle Property

TimetableSettings.HeaderShadowStyle Property

Gets or sets the style of the shadows cast by headers.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ShadowStyle HeaderShadowStyle { get; set; }
Visual Basic

Public Property HeaderShadowStyle As ShadowStyle

Property Value

A member of the ShadowStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowColor Property
HeaderShadowOffset Property


MindFusion.Scheduling.WinForms.TimetableSettings.InfoHeaderBrush Property

TimetableSettings.InfoHeaderBrush Property

Gets or sets the brush used to paint the info header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush InfoHeaderBrush { get; set; }
Visual Basic

Public Property InfoHeaderBrush As Brush

Property Value

A Brush object specifying the interior fill of the header. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.InfoHeaderSize Property

TimetableSettings.InfoHeaderSize Property

Gets or sets the size of the info header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int InfoHeaderSize { get; set; }
Visual Basic

Public Property InfoHeaderSize As Integer

Property Value

A positive integer value specifying the size of the info header. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ItemOffset Property

TimetableSettings.ItemOffset Property

Gets or set the distance between the first item and its adjoining cell side.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ItemOffset { get; set; }
Visual Basic

Public Property ItemOffset As Integer

Property Value

A non-negative integer value specifying the item offset in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.MainHeaderSize Property

TimetableSettings.MainHeaderSize Property

Gets or sets the size of the main header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int MainHeaderSize { get; set; }
Visual Basic

Public Property MainHeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the calendar to automatically calculate a header size based on the size of the header font.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.MaxAllDayItems Property

TimetableSettings.MaxAllDayItems Property

Gets or sets the maximum number of all-day items visible in the columns headers at a time.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int MaxAllDayItems { get; set; }
Visual Basic

Public Property MaxAllDayItems As Integer

Property Value

An integer value specifying how many all-day items to display at most in the column headers. The allowed values range from 1 to 20. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

The all-day items header is automatically resized to hold all items up to the number set in this property. If there are more all-day items, the rest of them are not shown. In that case, the 'hidden items' icon is displayed if ShowMoreItemsCue is enabled.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
ShowDayHeader Property


MindFusion.Scheduling.WinForms.TimetableSettings.MinColumnSize Property

TimetableSettings.MinColumnSize Property

Gets or sets the smallest size allowed for timetable columns.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int MinColumnSize { get; set; }
Visual Basic

Public Property MinColumnSize As Integer

Property Value

An integer value specifying the minimal column size. The minimal allowed value is 10. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.MinItemSize Property

TimetableSettings.MinItemSize Property

Gets or sets the smallest size allowed for schedule items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int MinItemSize { get; set; }
Visual Basic

Public Property MinItemSize As Integer

Property Value

An integer value specifying the minimal size in pixels. The minimal allowed value is 5. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

If there is not enough space in a column to display all related items, the items that do not fit remain invisible.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.MinuteFormat Property

TimetableSettings.MinuteFormat Property

Gets or sets how to format and display minutes.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public MinuteFormat MinuteFormat { get; set; }
Visual Basic

Public Property MinuteFormat As MinuteFormat

Property Value

A MinuteFormat object specifying the minutes format. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.NowColor Property

TimetableSettings.NowColor Property

Gets or sets the color used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color NowColor { get; set; }
Visual Basic

Public Property NowColor As Color

Property Value

A .NET Color object specifying the color used to indicate the current time. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
NowFillColor Property
ShowCurrentTime Property


MindFusion.Scheduling.WinForms.TimetableSettings.NowFillColor Property

TimetableSettings.NowFillColor Property

Gets or sets the fill color used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color NowFillColor { get; set; }
Visual Basic

Public Property NowFillColor As Color

Property Value

A .NET Color object specifying the color used to indicate the current time. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
NowColor Property
ShowCurrentTime Property


MindFusion.Scheduling.WinForms.TimetableSettings.Orientation Property

TimetableSettings.Orientation Property

Gets or sets the view orientation.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Orientation Orientation { get; set; }
Visual Basic

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

A vertical timetable view displays cells for the same daytime in a row, and cells for the same date in a column. A horizontal timetable view displays cells for the same time of the day in a column, and cells for the same date in a row.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ReverseGrouping Property

TimetableSettings.ReverseGrouping Property

Gets or sets a value indicating whether grouping (if enabled) will be performed first by the resource, and then by the date.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ReverseGrouping { get; set; }
Visual Basic

Public Property ReverseGrouping As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

By default grouping is done first by available dates, then by the resources specified in the current grouping type. Setting this property to Enabled reverses this behavior.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.RotateHeaderTexts Property

TimetableSettings.RotateHeaderTexts Property

Gets or sets a value indicating whether the header texts are rotated in a view with Horizontal orientation.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State RotateHeaderTexts { get; set; }
Visual Basic

Public Property RotateHeaderTexts As State

Property Value

Specify Enabled to display the header text rotated; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
RotateTimelineTexts Property


MindFusion.Scheduling.WinForms.TimetableSettings.RotateTimelineTexts Property

TimetableSettings.RotateTimelineTexts Property

Gets or sets a value indicating whether the timeline texts are rotated in a view with Horizontal orientation.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State RotateTimelineTexts { get; set; }
Visual Basic

Public Property RotateTimelineTexts As State

Property Value

Specify Enabled to display the timeline text rotated; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
RotateHeaderTexts Property


MindFusion.Scheduling.WinForms.TimetableSettings.ScrollStep Property

TimetableSettings.ScrollStep Property

Gets or sets the number of days to scroll when the user clicks the navigation buttons.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ScrollStep { get; set; }
Visual Basic

Public Property ScrollStep As Integer

Property Value

A positive integer value specifying the number of days to scroll. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.SecondTimelineOffset Property

TimetableSettings.SecondTimelineOffset Property

Gets or sets the offset in hours of the second timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int SecondTimelineOffset { get; set; }
Visual Basic

Public Property SecondTimelineOffset As Integer

Property Value

An integer value specifying the offset in hours. The allowed values range from 0 to 23. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
SecondTimelineStyle Property


MindFusion.Scheduling.WinForms.TimetableSettings.SecondTimelineStyle Property

TimetableSettings.SecondTimelineStyle Property

Gets or sets a value indicating whether a second timeline is displayed in addition to the primary one.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Alignment SecondTimelineStyle { get; set; }
Visual Basic

Public Property SecondTimelineStyle As Alignment

Property Value

Specify Near to show the second timeline next to the main one, Far to place it at the opposite side of the view, or None to hide it. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
SecondTimelineOffset Property


MindFusion.Scheduling.WinForms.TimetableSettings.SelectWholeDayOnHeaderClick Property

TimetableSettings.SelectWholeDayOnHeaderClick Property

Gets or sets a value indicating whether the whole day is selected when the user clicks in the column's header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State SelectWholeDayOnHeaderClick { get; set; }
Visual Basic

Public Property SelectWholeDayOnHeaderClick As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowAM Property

TimetableSettings.ShowAM Property

Gets or sets a value indicating whether the AM and PM suffixes are displayed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowAM { get; set; }
Visual Basic

Public Property ShowAM As State

Property Value

Specify Enabled to show AM/PM suffixes; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowCurrentTime Property

TimetableSettings.ShowCurrentTime Property

Gets or sets a value indicating whether to display the current time in the timeline.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowCurrentTime { get; set; }
Visual Basic

Public Property ShowCurrentTime As State

Property Value

Specify Enabled to indicate the current time; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
NowColor Property
NowFillColor Property


MindFusion.Scheduling.WinForms.TimetableSettings.ShowDayHeader Property

TimetableSettings.ShowDayHeader Property

Gets or sets a value indicating whether to show the header displaying all-day items.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowDayHeader { get; set; }
Visual Basic

Public Property ShowDayHeader As State

Property Value

Specify Enabled to show the days header; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
MaxAllDayItems Property


MindFusion.Scheduling.WinForms.TimetableSettings.ShowInfoHeader Property

TimetableSettings.ShowInfoHeader Property

Gets or sets a value indicating whether to show the info header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowInfoHeader { get; set; }
Visual Basic

Public Property ShowInfoHeader As State

Property Value

A value of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowItemSpans Property

TimetableSettings.ShowItemSpans Property

Gets or sets a value indicating whether the item time spans are also drawn in the left band of the corresponding column.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowItemSpans { get; set; }
Visual Basic

Public Property ShowItemSpans As State

Property Value

Specify Enabled to display item spans; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowMinutesInHourHeaders Property

TimetableSettings.ShowMinutesInHourHeaders Property

Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowMinutesInHourHeaders { get; set; }
Visual Basic

Public Property ShowMinutesInHourHeaders As State

Property Value

Specify Enabled to show minutes; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Whole hour cells are displayed when the hours are divisible by the specified CellTime.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowMoreItemsCue Property

TimetableSettings.ShowMoreItemsCue Property

Gets or sets a value indicating whether to display a 'more items' icon in the timeline header when some items in a timetable column are not currently visible.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowMoreItemsCue { get; set; }
Visual Basic

Public Property ShowMoreItemsCue As State

Property Value

Specify Enabled to show the 'more items' cue when there are items not visible in the current viewport; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowNavigationButtons Property

TimetableSettings.ShowNavigationButtons Property

Gets or sets a value indicating whether the Timetable view displays navigation buttons.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowNavigationButtons { get; set; }
Visual Basic

Public Property ShowNavigationButtons As State

Property Value

Specify Enabled to show navigation buttons; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowPadding Property

TimetableSettings.ShowPadding Property

Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowPadding { get; set; }
Visual Basic

Public Property ShowPadding As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowWorkTime Property

TimetableSettings.ShowWorkTime Property

Gets or sets a value indicating whether the work time should be displayed with different style.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowWorkTime { get; set; }
Visual Basic

Public Property ShowWorkTime As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
WorkTimeCellStyle Property


MindFusion.Scheduling.WinForms.TimetableSettings.SnapInterval Property

TimetableSettings.SnapInterval Property

Gets or sets the custom snap interval.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public TimeSpan SnapInterval { get; set; }
Visual Basic

Public Property SnapInterval As TimeSpan

Property Value

A .NET TimeSpan object that specifies the snap interval, relative to the beginning of the timetable column. The allowed values range from 1 second to 1 hour inclusive. Assign -1 ticks to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
EnableSnapping Property


MindFusion.Scheduling.WinForms.TimetableSettings.StartTime Property

TimetableSettings.StartTime Property

Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int StartTime { get; set; }
Visual Basic

Public Property StartTime As Integer

Property Value

An integer value specifying the view start time in minutes. The allowed values range from 0 to 1440. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
EndTime Property
CellTime Property


MindFusion.Scheduling.WinForms.TimetableSettings.Style Property

TimetableSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. This property cannot be null.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.SubHeaderSize Property

TimetableSettings.SubHeaderSize Property

Gets or sets the size of the secondary header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int SubHeaderSize { get; set; }
Visual Basic

Public Property SubHeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the secondary header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the calendar to automatically calculate a header size based on the size of the header font.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.TimelineSize Property

TimetableSettings.TimelineSize Property

Gets or sets the size of the timeline header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int TimelineSize { get; set; }
Visual Basic

Public Property TimelineSize As Integer

Property Value

A non-negative integer value specifying the size of the timeline header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.TimelineStyle Property

TimetableSettings.TimelineStyle Property

Gets or sets the style of the timeline header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style TimelineStyle { get; set; }
Visual Basic

Public Property TimelineStyle As Style

Property Value

A Style object specifying the appearance of the timeline header. This property cannot be null.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.TwelveHourFormat Property

TimetableSettings.TwelveHourFormat Property

Gets or sets a value indicating whether to use a 12-hour format.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State TwelveHourFormat { get; set; }
Visual Basic

Public Property TwelveHourFormat As State

Property Value

Specify Enabled to use 12-hour format, or Disabled to use 24-hour format. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.UseZoom Property

TimetableSettings.UseZoom Property

Gets or sets a value indicating whether to use the associated zoom factor or the fixed cell height when displaying cells.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State UseZoom { get; set; }
Visual Basic

Public Property UseZoom As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
ZoomFactor Property


MindFusion.Scheduling.WinForms.TimetableSettings.VisibleColumns Property

TimetableSettings.VisibleColumns Property

Gets or sets the number of columns visible in the view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int VisibleColumns { get; set; }
Visual Basic

Public Property VisibleColumns As Integer

Property Value

A positive integer value specifying the number of columns visible at the same time. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.WorkTimeCellStyle Property

TimetableSettings.WorkTimeCellStyle Property

Gets or sets the style of cells in the work time interval.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Style WorkTimeCellStyle { get; set; }
Visual Basic

Public Property WorkTimeCellStyle As Style

Property Value

A Style object specifying the style of the work time cells. This property cannot be null.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
ShowWorkTime Property


MindFusion.Scheduling.WinForms.TimetableSettings.WorkTimeEndHour Property

TimetableSettings.WorkTimeEndHour Property

Gets or sets the end hour of the work time interval.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int WorkTimeEndHour { get; set; }
Visual Basic

Public Property WorkTimeEndHour As Integer

Property Value

An integer value specifying the start of the work time in hours. The allowed values range from 0 to 23. The value cannot be less than WorkTimeStartHour. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property and WorkTimeStartHour specify the working time period, whose cells are usually displayed in a different style as set in WorkTimeCellStyle. To use the same style for all cells in the timetable view, set WorkTimeCellStyle to a new empty Style.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
WorkTimeStartHour Property


MindFusion.Scheduling.WinForms.TimetableSettings.WorkTimeStartHour Property

TimetableSettings.WorkTimeStartHour Property

Gets or sets the start hour of the work time interval.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int WorkTimeStartHour { get; set; }
Visual Basic

Public Property WorkTimeStartHour As Integer

Property Value

An integer value specifying the start of the work time in hours. The allowed values range from 0 to 23. The value cannot be greater than WorkTimeEndHour. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property and WorkTimeEndHour specify the working time period, whose cells are usually displayed in a different style as set in WorkTimeCellStyle. To use the same style for all cells in the timetable view, set WorkTimeCellStyle to a new empty Style.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
WorkTimeEndHour Property


MindFusion.Scheduling.WinForms.TimetableSettings.ZoomFactor Property

TimetableSettings.ZoomFactor Property

Gets or sets the zoom factor when zoom is enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ZoomFactor { get; set; }
Visual Basic

Public Property ZoomFactor As Integer

Property Value

An integer value specifying the zoom factor when UseZoom is enabled. The allowed values range from 100 to 1000. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To make the whole timeline visible at a time, set this to 100.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WinForms Namespace
UseZoom Property


MindFusion.Scheduling.WinForms.TimeUnit Enumeration

TimeUnit Enumeration

Specifies a time resolution.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum TimeUnit
Visual Basic

Public Enumeration TimeUnit

Members

Member name | Description
Day | Specifies days.
Hour | Specifies hours.
Minute | Specifies minutes.
Month | Specifies months.
Second | Specifies seconds.
Unspecified | Unspecified.
Week | Specifies weeks.
Year | Specifies years.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TooltipEventArgs Class

TooltipEventArgs Class

Contains the arguments passed to handlers of the TooltipDisplaying event.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class TooltipEventArgs : EventArgs
Visual Basic

Public Class TooltipEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.WinForms.TooltipEventArgs

See Also

TooltipEventArgs Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TooltipEventArgs Members

TooltipEventArgs Members
Properties

Contains the arguments passed to handlers of the TooltipDisplaying event.

The following tables list the members exposed by the TooltipEventArgs type.

Public Properties

Name | Description
Element | Gets the element whose ToolTip is being displayed.
Resource | Gets the resource associated with the calendar element or null (Nothing in Visual Basic) if none.
Time | Gets the time associated with the calendar element or DateTime.MinValue if none.
Tooltip | Gets or sets the ToolTip of the element.

See Also

TooltipEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TooltipEventArgs Properties

TooltipEventArgs Properties

Public Properties

Name | Description
Element | Gets the element whose ToolTip is being displayed.
Resource | Gets the resource associated with the calendar element or null (Nothing in Visual Basic) if none.
Time | Gets the time associated with the calendar element or DateTime.MinValue if none.
Tooltip | Gets or sets the ToolTip of the element.

See Also

TooltipEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TooltipEventArgs.Element Property

TooltipEventArgs.Element Property

Gets the element whose ToolTip is being displayed.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public CalendarElement Element { get; }
Visual Basic

Public ReadOnly Property Element As CalendarElement

Property Value

A member of the CalendarElement enumeration identifying the calendar element whose tooltip is about to be displayed.

See Also

TooltipEventArgs Members
TooltipEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TooltipEventArgs.Resource Property

TooltipEventArgs.Resource Property

Gets the resource associated with the calendar element or null (Nothing in Visual Basic) if none.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Resource Resource { get; }
Visual Basic

Public ReadOnly Property Resource As Resource

Property Value

A reference to a Contact, Location, Task or Resource. This value can be null (Nothing in Visual Basic) if the current view is not grouped or the element whose tooltip is being displayed is not associated with a resource.

See Also

TooltipEventArgs Members
TooltipEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TooltipEventArgs.Time Property

TooltipEventArgs.Time Property

Gets the time associated with the calendar element or DateTime.MinValue if none.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DateTime Time { get; }
Visual Basic

Public ReadOnly Property Time As DateTime

Property Value

A .NET DateTime value representing the date and time associated with the element whose tooltip is being displayed or DateTime.MinValue if no time is related with the element.

See Also

TooltipEventArgs Members
TooltipEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.TooltipEventArgs.Tooltip Property

TooltipEventArgs.Tooltip Property

Gets or sets the ToolTip of the element.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string Tooltip { get; set; }
Visual Basic

Public Property Tooltip As String

Property Value

The text of the tooltip.

See Also

TooltipEventArgs Members
TooltipEventArgs Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ViewSettings Class

ViewSettings Class

The base class for the different view settings classes.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract class ViewSettings
Visual Basic

Public MustInherit Class ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.ViewSettings
MindFusion.Scheduling.WinForms.CellSettings
MindFusion.Scheduling.WinForms.ListViewSettings
MindFusion.Scheduling.WinForms.MonthRangeSettings
MindFusion.Scheduling.WinForms.MonthSettings
MindFusion.Scheduling.WinForms.ResourceViewSettings
MindFusion.Scheduling.WinForms.TimetableSettings
MindFusion.Scheduling.WinForms.WeekRangeSettings

See Also

ViewSettings Members
MindFusion.Scheduling.WinForms Namespace
CellSettings Class
ListViewSettings Class
MonthRangeSettings Class
MonthSettings Class
TimetableSettings Class
ResourceViewSettings Class
WeekRangeSettings Class


MindFusion.Scheduling.WinForms.ViewSettings Members

ViewSettings Members
Properties Events

The base class for the different view settings classes.

The following tables list the members exposed by the ViewSettings type.

Public Properties

Name | Description
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Public Events

Name | Description
SettingsChanged | Raised when the view settings change.

See Also

ViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ViewSettings Properties

ViewSettings Properties

Public Properties

Name | Description
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

See Also

ViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ViewSettings.Style Property

ViewSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public abstract Style Style { get; set; }
Visual Basic

Public MustOverride Property Style As Style

Property Value

An instance of the Style class specifying the style of calendar UI elements. This property cannot be null.

See Also

ViewSettings Members
ViewSettings Class
MindFusion.Scheduling.WinForms Namespace
Style Class


MindFusion.Scheduling.WinForms.ViewSettings Events

ViewSettings Events

Public Events

Name | Description
SettingsChanged | Raised when the view settings change.

See Also

ViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.ViewSettings.SettingsChanged Event

ViewSettings.SettingsChanged Event

Raised when the view settings change.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public event EventHandler SettingsChanged
Visual Basic

Public Event SettingsChanged As EventHandler

Event Data

SettingsChanged event handlers receive an argument of type EventArgs.

See Also

ViewSettings Members
ViewSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeHeaderStyle Enumeration

WeekRangeHeaderStyle Enumeration

Specifies the appearance of the time period header in WeekRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum WeekRangeHeaderStyle
Visual Basic

Public Enumeration WeekRangeHeaderStyle

Members

Member name | Description
None | There isn't a header displayed.
Reference | The header displays the name of the associated contact, resource, location or task. This flag is valid only if grouping is enabled.
Title | The header displays the start and end dates specified in the WeekRangeSettings object.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings Class

WeekRangeSettings Class

Defines properties that allow customizing the visualization of weeks in WeekRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public class WeekRangeSettings : ViewSettings
Visual Basic

Public Class WeekRangeSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WinForms.ViewSettings
MindFusion.Scheduling.WinForms.WeekRangeSettings

See Also

WeekRangeSettings Members
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings Members

WeekRangeSettings Members
Properties

Defines properties that allow customizing the visualization of weeks in WeekRange view.

The following tables list the members exposed by the WeekRangeSettings type.

Public Properties

Name | Description
DayDistance | Gets or sets the distance between adjacent days.
DayNamesHeaderHeight | Gets or sets the height of the day-names header in the WeekRange view.
DayOfWeekFormat | Gets or sets the display format of the names of the days of the week.
DaySettings | Gets the CellSettings object used to customize the visualization of days in a WeekRange view.
EvenMonthsBrush | Gets or sets the brush used to paint the background of all even months' areas in the WeekRange view.
GroupWeekends | Gets or sets a value indicating whether weekend days are grouped in a single calendar cell. Weekends are always grouped in a SingleWeek view.
GroupWeekendsTitleSeparator | Gets or sets the separator string displayed between Saturday and Sunday strings when GroupWeekends is enabled.
HeaderShadowColor | Gets or sets the color of the headers' shadows.
HeaderShadowOffset | Gets or sets the offset of the shadows from the headers that cast them.
HeaderShadowStyle | Gets or sets the style of the headers' shadows.
HeaderStyle | Gets or sets the style of the time-period header, displayed above the day-names header.
Margin | Gets or sets the distance between the outermost border and the rest of the calendar contents.
NumberOfDays | Gets the total number of days displayed in the WeekRange view.
OddMonthsBrush | Gets or sets the brush used to paint the background of all odd months' areas in the WeekRange view.
ReferenceHeaderHeight | Gets or sets the height of the reference header in the WeekRange view.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the header area of the WeekRange view.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TimePeriodHeaderHeight | Gets or sets the height of the time-period header in the WeekRange view.
TitleFormat | Gets or sets the format of the calendar's title.
TitleSeparator | Gets or sets the string used as a separator in the calendar's title.
ViewStyle | Gets or sets the style of the WeekRange view.
VisibleColumns | Gets or sets the number of columns visible when the GroupType is enabled.
VisibleRows | Gets or sets the number of weeks visible at a time.

See Also

WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings Properties

WeekRangeSettings Properties

Public Properties

Name | Description
DayDistance | Gets or sets the distance between adjacent days.
DayNamesHeaderHeight | Gets or sets the height of the day-names header in the WeekRange view.
DayOfWeekFormat | Gets or sets the display format of the names of the days of the week.
DaySettings | Gets the CellSettings object used to customize the visualization of days in a WeekRange view.
EvenMonthsBrush | Gets or sets the brush used to paint the background of all even months' areas in the WeekRange view.
GroupWeekends | Gets or sets a value indicating whether weekend days are grouped in a single calendar cell. Weekends are always grouped in a SingleWeek view.
GroupWeekendsTitleSeparator | Gets or sets the separator string displayed between Saturday and Sunday strings when GroupWeekends is enabled.
HeaderShadowColor | Gets or sets the color of the headers' shadows.
HeaderShadowOffset | Gets or sets the offset of the shadows from the headers that cast them.
HeaderShadowStyle | Gets or sets the style of the headers' shadows.
HeaderStyle | Gets or sets the style of the time-period header, displayed above the day-names header.
Margin | Gets or sets the distance between the outermost border and the rest of the calendar contents.
NumberOfDays | Gets the total number of days displayed in the WeekRange view.
OddMonthsBrush | Gets or sets the brush used to paint the background of all odd months' areas in the WeekRange view.
ReferenceHeaderHeight | Gets or sets the height of the reference header in the WeekRange view.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the header area of the WeekRange view.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TimePeriodHeaderHeight | Gets or sets the height of the time-period header in the WeekRange view.
TitleFormat | Gets or sets the format of the calendar's title.
TitleSeparator | Gets or sets the string used as a separator in the calendar's title.
ViewStyle | Gets or sets the style of the WeekRange view.
VisibleColumns | Gets or sets the number of columns visible when the GroupType is enabled.
VisibleRows | Gets or sets the number of weeks visible at a time.

See Also

WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.DayDistance Property

WeekRangeSettings.DayDistance Property

Gets or sets the distance between adjacent days.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int DayDistance { get; set; }
Visual Basic

Public Property DayDistance As Integer

Property Value

A non-negative integer value specifying the distance between adjacent day cells in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
Margin Property


MindFusion.Scheduling.WinForms.WeekRangeSettings.DayNamesHeaderHeight Property

WeekRangeSettings.DayNamesHeaderHeight Property

Gets or sets the height of the day-names header in the WeekRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int DayNamesHeaderHeight { get; set; }
Visual Basic

Public Property DayNamesHeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the day-names header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the height to be calculated automatically based on the size of the header font.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.DayOfWeekFormat Property

WeekRangeSettings.DayOfWeekFormat Property

Gets or sets the display format of the names of the days of the week.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public DayOfWeekFormat DayOfWeekFormat { get; set; }
Visual Basic

Public Property DayOfWeekFormat As DayOfWeekFormat

Property Value

A member of the DayOfWeekFormat enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.DaySettings Property

WeekRangeSettings.DaySettings Property

Gets the CellSettings object used to customize the visualization of days in a WeekRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public CellSettings DaySettings { get; }
Visual Basic

Public ReadOnly Property DaySettings As CellSettings

Property Value

An instance of the CellSettings class.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.EvenMonthsBrush Property

WeekRangeSettings.EvenMonthsBrush Property

Gets or sets the brush used to paint the background of all even months' areas in the WeekRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush EvenMonthsBrush { get; set; }
Visual Basic

Public Property EvenMonthsBrush As Brush

Property Value

An instance of a Brush-derived class used to fill the even month cells. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
OddMonthsBrush Property


MindFusion.Scheduling.WinForms.WeekRangeSettings.GroupWeekends Property

WeekRangeSettings.GroupWeekends Property

Gets or sets a value indicating whether weekend days are grouped in a single calendar cell. Weekends are always grouped in a SingleWeek view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State GroupWeekends { get; set; }
Visual Basic

Public Property GroupWeekends As State

Property Value

Specify Enabled to display weekend days together; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.GroupWeekendsTitleSeparator Property

WeekRangeSettings.GroupWeekendsTitleSeparator Property

Gets or sets the separator string displayed between Saturday and Sunday strings when GroupWeekends is enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string GroupWeekendsTitleSeparator { get; set; }
Visual Basic

Public Property GroupWeekendsTitleSeparator As String

Property Value

A string specifying the separator text. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.HeaderShadowColor Property

WeekRangeSettings.HeaderShadowColor Property

Gets or sets the color of the headers' shadows.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Color HeaderShadowColor { get; set; }
Visual Basic

Public Property HeaderShadowColor As Color

Property Value

A .NET Color object specifying the color of headers' shadows. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowOffset Property
HeaderShadowStyle Property


MindFusion.Scheduling.WinForms.WeekRangeSettings.HeaderShadowOffset Property

WeekRangeSettings.HeaderShadowOffset Property

Gets or sets the offset of the shadows from the headers that cast them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int HeaderShadowOffset { get; set; }
Visual Basic

Public Property HeaderShadowOffset As Integer

Property Value

An integer value specifying with how many pixels to offset a header's shadow from the header. The allowed values range from 1 to 5. Assign -1 to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowColor Property
HeaderShadowStyle Property


MindFusion.Scheduling.WinForms.WeekRangeSettings.HeaderShadowStyle Property

WeekRangeSettings.HeaderShadowStyle Property

Gets or sets the style of the headers' shadows.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public ShadowStyle HeaderShadowStyle { get; set; }
Visual Basic

Public Property HeaderShadowStyle As ShadowStyle

Property Value

A member of the ShadowStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
HeaderShadowColor Property
HeaderShadowOffset Property


MindFusion.Scheduling.WinForms.WeekRangeSettings.HeaderStyle Property

WeekRangeSettings.HeaderStyle Property

Gets or sets the style of the time-period header, displayed above the day-names header.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public WeekRangeHeaderStyle HeaderStyle { get; set; }
Visual Basic

Public Property HeaderStyle As WeekRangeHeaderStyle

Property Value

A member of the WeekRangeHeaderStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.Margin Property

WeekRangeSettings.Margin Property

Gets or sets the distance between the outermost border and the rest of the calendar contents.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int Margin { get; set; }
Visual Basic

Public Property Margin As Integer

Property Value

A non-negative integer value specifying the margin size in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
DayDistance Property


MindFusion.Scheduling.WinForms.WeekRangeSettings.NumberOfDays Property

WeekRangeSettings.NumberOfDays Property

Gets the total number of days displayed in the WeekRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int NumberOfDays { get; }
Visual Basic

Public ReadOnly Property NumberOfDays As Integer

Property Value

An integer value specifying how many days are contained in the week range view.

Remarks

Use the Date and EndDate properties of the Calendar control to set the time period displayed in the week range view.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
VisibleRows Property


MindFusion.Scheduling.WinForms.WeekRangeSettings.OddMonthsBrush Property

WeekRangeSettings.OddMonthsBrush Property

Gets or sets the brush used to paint the background of all odd months' areas in the WeekRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public Brush OddMonthsBrush { get; set; }
Visual Basic

Public Property OddMonthsBrush As Brush

Property Value

An instance of a Brush-derived class used to fill the odd month cells. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
EvenMonthsBrush Property


MindFusion.Scheduling.WinForms.WeekRangeSettings.ReferenceHeaderHeight Property

WeekRangeSettings.ReferenceHeaderHeight Property

Gets or sets the height of the reference header in the WeekRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int ReferenceHeaderHeight { get; set; }
Visual Basic

Public Property ReferenceHeaderHeight As Integer

Property Value

A non-negative integer value specifying the header height. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This header is where the contact, task, location or resource names are displayed, depending on the calendar GroupType. A value of 0 causes the height to be calculated automatically based on the size of the header font.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.ShowDayOfWeek Property

WeekRangeSettings.ShowDayOfWeek Property

Gets or sets a value indicating whether the day names are displayed in the header area of the WeekRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public State ShowDayOfWeek { get; set; }
Visual Basic

Public Property ShowDayOfWeek As State

Property Value

Specify Enabled to display the day names; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

The day names are obtained from the DateTimeFormat property of the Calendar class, if it isn't a null reference (Nothing in Visual Basic), or from the corresponding DateTimeFormat property of the .NET CultureInfo object assigned to calendar's Culture.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.Style Property

WeekRangeSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. This property cannot be null.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.TimePeriodHeaderHeight Property

WeekRangeSettings.TimePeriodHeaderHeight Property

Gets or sets the height of the time-period header in the WeekRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int TimePeriodHeaderHeight { get; set; }
Visual Basic

Public Property TimePeriodHeaderHeight As Integer

Property Value

A non-negative integer value specifying the header height in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the height to be calculated automatically based on the size of the header font.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.TitleFormat Property

WeekRangeSettings.TitleFormat Property

Gets or sets the format of the calendar's title.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string TitleFormat { get; set; }
Visual Basic

Public Property TitleFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.TitleSeparator Property

WeekRangeSettings.TitleSeparator Property

Gets or sets the string used as a separator in the calendar's title.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public string TitleSeparator { get; set; }
Visual Basic

Public Property TitleSeparator As String

Property Value

A string specifying the separator text. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.ViewStyle Property

WeekRangeSettings.ViewStyle Property

Gets or sets the style of the WeekRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public WeekRangeViewStyle ViewStyle { get; set; }
Visual Basic

Public Property ViewStyle As WeekRangeViewStyle

Property Value

A member of the WeekRangeViewStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.VisibleColumns Property

WeekRangeSettings.VisibleColumns Property

Gets or sets the number of columns visible when the GroupType is enabled.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int VisibleColumns { get; set; }
Visual Basic

Public Property VisibleColumns As Integer

Property Value

A positive integer value specifying how many columns are visible simultaneously. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

In the week range view schedule data can be displayed in several columns grouped by contact, location, task or resource, as set in Calendar.GroupType. This property determines how many parallel columns are visible at a time.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.VisibleRows Property

WeekRangeSettings.VisibleRows Property

Gets or sets the number of weeks visible at a time.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public int VisibleRows { get; set; }
Visual Basic

Public Property VisibleRows As Integer

Property Value

The allowed values range from 1 to 10. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

Used only when ViewStyle is set to WeekPerRow.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WinForms Namespace
NumberOfDays Property


MindFusion.Scheduling.WinForms.WeekRangeViewStyle Enumeration

WeekRangeViewStyle Enumeration

Specifies whether there are multiple weeks displayed in WeekRange view.

Namespace: MindFusion.Scheduling.WinForms
Assembly: MindFusion.Scheduling

Syntax

C#

public enum WeekRangeViewStyle
Visual Basic

Public Enumeration WeekRangeViewStyle

Members

Member name | Description
SingleWeek | The calendar view displays a single week at a time.
Unspecified | Unspecified.
WeekPerRow | The calendar view displays several weeks at a time.

See Also

MindFusion.Scheduling.WinForms Namespace


MindFusion.Tools.ShapeDesignerCtrl Namespace
Classes Delegates Enumerations

Classes

Class | Description
ShapeDesigner |

Delegates

Delegate | Description
OutlineChanged |
ShapeChanged |

Enumerations

Enumeration | Description
GridStyle |
SourceCodeLanguage |


MindFusion.Tools.ShapeDesignerCtrl.GridStyle Enumeration

GridStyle Enumeration

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public enum GridStyle
Visual Basic

Public Enumeration GridStyle

Members

Member name | Description
Dots |
Lines |

See Also

MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.OutlineChanged Delegate

OutlineChanged Delegate

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public delegate void OutlineChanged (
Object sender,
EventArgs e
)
Visual Basic

Public Delegate Sub OutlineChanged ( _
sender As Object, _
e As EventArgs _
)

Parameters

sender
e

See Also

MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeChanged Delegate

ShapeChanged Delegate

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public delegate void ShapeChanged (
Object sender,
EventArgs e
)
Visual Basic

Public Delegate Sub ShapeChanged ( _
sender As Object, _
e As EventArgs _
)

Parameters

sender
e

See Also

MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner Class

ShapeDesigner Class

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public class ShapeDesigner : Control
Visual Basic

Public Class ShapeDesigner
Inherits Control

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner

See Also

ShapeDesigner Members
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner Members

ShapeDesigner Members
Constructors Properties Methods Events

The following tables list the members exposed by the ShapeDesigner type.

Public Constructors

Name | Description
ShapeDesigner |

Public Properties

Name | Description
BackColor |
DecorationColor |
GridColor |
GridSpacing |
GridStyle |
Image |
ImageLocation |
MainContourColor |
OutlineColor |
RoundRectRadius |
SelectionColor |
Shape |
ShapeSize |
ShowGrid |
ShowScrollbars |
TextAreaContourColor |

Public Methods

Name | Description
ClientToShapeX |
ClientToShapeY |
ExportTemplateCode |
ReadLayoutFromFile |
SaveLayoutToFile |

Protected Methods

Name | Description
OnCreateControl |
OnMouseDown |
OnMouseMove |
OnMouseUp |
OnPaint |
OnPaintBackground |

Public Events

Name | Description
ShapeChanged |

See Also

ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner Constructor

ShapeDesigner Constructor

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public ShapeDesigner ()
Visual Basic

Public Sub New ()

See Also

ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner Methods

ShapeDesigner Methods

Public Methods

Name | Description
ClientToShapeX |
ClientToShapeY |
ExportTemplateCode |
ReadLayoutFromFile |
SaveLayoutToFile |

Protected Methods

Name | Description
OnCreateControl |
OnMouseDown |
OnMouseMove |
OnMouseUp |
OnPaint |
OnPaintBackground |

See Also

ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.ClientToShapeX Method

ShapeDesigner.ClientToShapeX Method

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public float ClientToShapeX (
float clientX
)
Visual Basic

Public Function ClientToShapeX ( _
clientX As Single _
) As Single

Parameters

clientX

Return Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.ClientToShapeY Method

ShapeDesigner.ClientToShapeY Method

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public float ClientToShapeY (
float clientY
)
Visual Basic

Public Function ClientToShapeY ( _
clientY As Single _
) As Single

Parameters

clientY

Return Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.ExportTemplateCode Method (SourceCodeLanguage)

ShapeDesigner.ExportTemplateCode Method (SourceCodeLanguage)
See Also

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public string[] ExportTemplateCode (
SourceCodeLanguage srcCode
)
Visual Basic

Public Function ExportTemplateCode ( _
srcCode As SourceCodeLanguage _
) As String()

Parameters

srcCode

Return Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.OnCreateControl Method

ShapeDesigner.OnCreateControl Method

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

protected virtual void OnCreateControl ()
Visual Basic

Protected Overridable Sub OnCreateControl ()

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.OnMouseDown Method

ShapeDesigner.OnMouseDown Method

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

protected virtual void OnMouseDown (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseDown ( _
e As MouseEventArgs _
)

Parameters

e

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.OnMouseMove Method

ShapeDesigner.OnMouseMove Method

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

protected virtual void OnMouseMove (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseMove ( _
e As MouseEventArgs _
)

Parameters

e

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.OnMouseUp Method

ShapeDesigner.OnMouseUp Method

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

protected virtual void OnMouseUp (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseUp ( _
e As MouseEventArgs _
)

Parameters

e

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.OnPaint Method

ShapeDesigner.OnPaint Method

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

protected virtual void OnPaint (
PaintEventArgs pe
)
Visual Basic

Protected Overridable Sub OnPaint ( _
pe As PaintEventArgs _
)

Parameters

pe

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.OnPaintBackground Method

ShapeDesigner.OnPaintBackground Method

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

protected virtual void OnPaintBackground (
PaintEventArgs pevent
)
Visual Basic

Protected Overridable Sub OnPaintBackground ( _
pevent As PaintEventArgs _
)

Parameters

pevent

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.ReadLayoutFromFile Method

ShapeDesigner.ReadLayoutFromFile Method

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public void ReadLayoutFromFile (
string path
)
Visual Basic

Public Sub ReadLayoutFromFile ( _
path As String _
)

Parameters

path

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.SaveLayoutToFile Method

ShapeDesigner.SaveLayoutToFile Method

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public void SaveLayoutToFile (
string path
)
Visual Basic

Public Sub SaveLayoutToFile ( _
path As String _
)

Parameters

path

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner Properties

ShapeDesigner Properties

Public Properties

Name | Description
BackColor |
DecorationColor |
GridColor |
GridSpacing |
GridStyle |
Image |
ImageLocation |
MainContourColor |
OutlineColor |
RoundRectRadius |
SelectionColor |
Shape |
ShapeSize |
ShowGrid |
ShowScrollbars |
TextAreaContourColor |

See Also

ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.BackColor Property

ShapeDesigner.BackColor Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public override Color BackColor { get; set; }
Visual Basic

Public Overrides Property BackColor As Color

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.DecorationColor Property

ShapeDesigner.DecorationColor Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public Color DecorationColor { get; set; }
Visual Basic

Public Property DecorationColor As Color

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.GridColor Property

ShapeDesigner.GridColor Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public Color GridColor { get; set; }
Visual Basic

Public Property GridColor As Color

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.GridSpacing Property

ShapeDesigner.GridSpacing Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public int GridSpacing { get; set; }
Visual Basic

Public Property GridSpacing As Integer

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.GridStyle Property

ShapeDesigner.GridStyle Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public GridStyle GridStyle { get; set; }
Visual Basic

Public Property GridStyle As GridStyle

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.Image Property

ShapeDesigner.Image Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public Image Image { get; set; }
Visual Basic

Public Property Image As Image

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.ImageLocation Property

ShapeDesigner.ImageLocation Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public string ImageLocation { get; set; }
Visual Basic

Public Property ImageLocation As String

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.MainContourColor Property

ShapeDesigner.MainContourColor Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public Color MainContourColor { get; set; }
Visual Basic

Public Property MainContourColor As Color

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.OutlineColor Property

ShapeDesigner.OutlineColor Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public Color OutlineColor { get; set; }
Visual Basic

Public Property OutlineColor As Color

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.RoundRectRadius Property

ShapeDesigner.RoundRectRadius Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public int RoundRectRadius { get; set; }
Visual Basic

Public Property RoundRectRadius As Integer

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.SelectionColor Property

ShapeDesigner.SelectionColor Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public Color SelectionColor { get; set; }
Visual Basic

Public Property SelectionColor As Color

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.Shape Property

ShapeDesigner.Shape Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public Shape Shape { get; set; }
Visual Basic

Public Property Shape As Shape

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.ShapeSize Property

ShapeDesigner.ShapeSize Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public int ShapeSize { get; set; }
Visual Basic

Public Property ShapeSize As Integer

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.ShowGrid Property

ShapeDesigner.ShowGrid Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public bool ShowGrid { get; set; }
Visual Basic

Public Property ShowGrid As Boolean

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.ShowScrollbars Property

ShapeDesigner.ShowScrollbars Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public bool ShowScrollbars { get; set; }
Visual Basic

Public Property ShowScrollbars As Boolean

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.TextAreaContourColor Property

ShapeDesigner.TextAreaContourColor Property

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public Color TextAreaContourColor { get; set; }
Visual Basic

Public Property TextAreaContourColor As Color

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner Events

ShapeDesigner Events

Public Events

Name | Description
ShapeChanged |

See Also

ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.ShapeDesigner.ShapeChanged Event

ShapeDesigner.ShapeChanged Event

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public event ShapeChanged ShapeChanged
Visual Basic

Public Event ShapeChanged As ShapeChanged

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Tools.ShapeDesignerCtrl Namespace


MindFusion.Tools.ShapeDesignerCtrl.SourceCodeLanguage Enumeration

SourceCodeLanguage Enumeration

Namespace: MindFusion.Tools.ShapeDesignerCtrl
Assembly: MindFusion.Tools.ShapeDesigner

Syntax

C#

public enum SourceCodeLanguage
Visual Basic

Public Enumeration SourceCodeLanguage

Members

Member name | Description
CSharp |
VB |

See Also

MindFusion.Tools.ShapeDesignerCtrl Namespace


Technical Support

Detailed information about everything connected with software products offered by MindFusion - online documentation, demos, information about forthcoming products can be found at http://www.mindfusion.eu [image] . The site is updated every day, so make sure you visit it regularly to catch up with the newest from us.

Apart from that, MindFusion employs a dedicated and technically proficient support team. This guarantees that all your questions and inquiries will be answered in quick and professional manner. They can be reached by e-mail at support@mindfusion.eu [image] or by phone at +359 877 65 22 51.

If you need a higher support level, use our premium support [image] .

In addition, you can post a question about the components contained in the MindFusion Pack for WinForms on the discussion boards:

Component | Forums
MindFusion.Charting | http://mindfusion.eu/Forum/YaBB.pl#mchart_cat
MindFusion.Diagramming | http://mindfusion.eu/Forum/YaBB.pl#fcnet_cat
MindFusion.Reporting | http://mindfusion.eu/Forum/YaBB.pl#reporting_winforms
MindFusion.Scheduling | http://mindfusion.eu/Forum/YaBB.pl#calnet_cat

or visit our help desk site:

http://www.mindfusion.eu/HelpDesk/index.php

We will be happy to hear any suggestions and recommendations you might have regarding MindFusion Pack for WinForms. We do take in account the opinion of every single person who has shown interest in our products.


MindFusion Products

MindFusion offers various programming components for different platforms. Below is a list of our products with links to their sections on our website as well link to download a trial version. Clients that have already purchased a product use an increasing discount for each subsequent one.

MindFusion.Reporting for WinForms

A .NET reporting component.

Product Information
Download

WpfDiagram

A flow-diagramming component for WPF.

Product Information
Download

MindFusion.Diagramming for WinForms

A flow-diagramming component for .NET.

Product Information
Download

FlowChartX

An ActiveX flow-diagramming component.

Product Information
Download

NetDiagram

An ASP.NET flow-diagramming component.

Product Information
Download

JDiagram

A flow-diagramming component for Java.

Product Information
Download

PocketChart

A flow-diagramming component for the .NET Compact Framework.

Product Information
Download

MindFusion.Scheduling for WinForms

Time-management and task-planning component for .NET.

Product Information
Download

PocketPlanner

Time-management and task-planning component for the .NET Compact Framework.

Product Information
Download

MindFusion.Charting

A charting component for .NET WinForms and WebForms.

Product Information
Download

InSight Diagrammer

Ready-to-use software for drawing of diagrams and charts.

Product Information
Download

XML Viewer

Freeware product for viewing and editing *.xml files.

Product Information
Download


MindFusion.Drawing.TextAlignment Enumeration

MindFusion Pack Programmer's Guide

TextAlignment Enumeration
See Also

Specifies the alignment of text on the drawing surface.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Scheduling

Syntax

C#

public enum TextAlignment
Visual Basic

Public Enumeration TextAlignment

Members

Member name | Description
AlignmentFlag | For internal use only. This value is available only in MindFusion.Scheduling.
BottomCenter | Text is vertically aligned at the bottom, and horizontally aligned at the center. This value is available only in MindFusion.Scheduling.
BottomLeft | Text is vertically aligned at the bottom, and horizontally aligned on the left. This value is available only in MindFusion.Scheduling.
BottomRight | Text is vertically aligned at the bottom, and horizontally aligned on the right. This value is available only in MindFusion.Scheduling.
MiddleCenter | Text is vertically aligned in the middle, and horizontally aligned at the center.
MiddleLeft | Text is vertically aligned in the middle, and horizontally aligned on the left. This value is available only in MindFusion.Scheduling.
MiddleRight | Text is vertically aligned in the middle, and horizontally aligned on the right. This value is available only in MindFusion.Scheduling.
NoWrap | The only flag that can be combines with any of the alignment flags. Specifies that the drawn text should not wrap when the text does not fit in a single line. This value is available only in MindFusion.Scheduling.
TopCenter | Text is vertically aligned at the top, and horizontally aligned at the center.
TopLeft | Text is vertically aligned at the top, and horizontally aligned on the left.
TopRight | Text is vertically aligned at the top, and horizontally aligned on the right. This value is available only in MindFusion.Scheduling.
Unspecified | No alignment is specified.

See Also

MindFusion.Drawing Namespace