Introduction

MindFusion.Reporting Programmer's Guide
Introduction

MindFusion.Reporting is a general-purpose software component that can be used [image] to design, display and print various types of reports and charts. It is implemented as a .NET Windows Forms component and can be easily integrated into any application targeting the Microsoft .NET platform. By providing your software with ready to use capabilities for visualizing and editing relational data, MindFusion.Reporting saves you from hundreds of hours of coding and debugging efforts.

MindFusion.Reporting supports:

  • Creating reports with header and footer
  • Including charts and pictures
  • All .NET data sources
  • Line, Bar, Pie and Radar charts for data presentations
  • Exporting reports to HTML, XLSX and PDF files
  • XML serialization
  • Previewing and printing
  • Displaying reports on a Windows Form
  • Standalone editor control

MindFusion.Reporting provides rich design-time support with a full-featured editor seamlessly built into the development environment.

The control has been tested with the most popular .NET development environments and programming languages C#, VB.NET and Delphi.NET.

© 2016 MindFusion


General Information

General Information

The MindFusion.Reporting component

  • Redistribution is royalty free
  • Assembly is strong-named
  • Can be purchased with source code
  • Is written in C#

Report design

  • Assigning text style, size, font color, format, alignment
  • Using a built-in charting component for visual presentation of report's data
  • Arrangement of Line, Bar, Pie and Radar charts for data presentation
  • Placement of any WinForms control as a report element
  • Setting page size and orientation within a single report
  • Setting page header and footer
  • Single and multiple item selection
  • Zooming reports at design time
  • Advanced expression editor for labels and report parameters

Reports data

  • Supports all .NET data sources
  • Compatible with ADO.NET
  • Multiple data sources can be used in a single report
  • Both bound and unbound modes are supported

Visualisation

  • Design of charts for visual data representation
  • Support for pictures and shapes
  • Multi-page reports
  • Side-by-side containers

Charts

  • 4 chart types: Pie, Bar, Line and Radar
  • Display charts in 3D
  • Customizable legend, grid, title
  • Full control over the brushes, pens, fonts
  • Stacked charts
  • Second Y-axis

Output

  • Display reports through Windows Forms
  • Printing and print preview of reports
  • Reports preview

Exporting reports

  • To HTML and MHTML files
  • To Adobe Portable Document Format (PDF) files
  • To Open Office XML (XLSX) files
  • To XML files

Tools

  • Reports Designer automates customizing the report's appearance
  • Report Viewer displays reports on a Windows Form
  • Standalone Report Editor control that can be hosted in any Windows Forms application
  • Collection editors for charts allow inserting and editing charts data


What's New in this Release

What's New in this Release

The list below describes recent changes and additions to MindFusion.Reporting:

New in Version 2.5

Improved font support

The Font properties of the report and various report items are now obsolete. They are replaced by FontName, FontSize, and FontStyle properties. It is now easier to change the font size or style of a label without replacing the entire label font. This way, changing the default font name will reflect on report items which have had their font size or style changed.

Improved measure unit support

Changing the measure unit of existing reports is now more fluent and does not require resizing of existing items in order to accommodate. Various properties are now expressed in millimeters and not in report units. For example, PaperSize and Margins.

New and updated samples

All samples have been overhauled and new samples have been added to demonstrate additional features of the report.


Version History

Version History

The list below describes recent changes and additions to MindFusion.Reporting:

New in Version 2.4

Improved charts

MindFusion.Reporting now uses the new MindFusion charting engine to display charts in reports. The presentation of the charts has been greatly improved (particularly when resizing the charts).

New in Version 2.3

Visual Studio 2015 support

MindFusion.Reporting now includes support for Visual Studio 2015. The installer can create VS2015 toolbox palette for the component.

Licensing

There is no separate trial build of the control assemblies anymore. Instead, set the LicenseKey property of the individual components to disable the component's evaluation mode and stop displaying trial messages. If your application contains more than one control by MindFusion, you could call MindFusion.Licensing.LicenseManager.AddLicense(key) to specify the key once instead of setting it per each control. License key strings are listed on the Keys & Downloads page at MindFusion's customer portal.

Barcodes

MindFusion.Reporting reports can now display UPC-A, UPC-E, EAN-8, EAN-13, and QR barcodes. The barcodes are represented by the new Barcode report item.

New in Version 2.2

Visual Studio 2013 support

MindFusion.Reporting now includes support for Visual Studio 2013. The installer can create VS2013 toolbox palette for the component, and can optionally install VS2013 sample projects. In addition, toolbox palettes are now created for all .NET target frameworks supported by the respective Visual Studio versions.

New in Version 2.1.2

Additional bug fixes and improvements.

New in Version 2.1.1

Several bug fixes and layout improvements.

New in Version 2.1

Visual Studio 2012 support

MindFusion.Reporting now includes support for Visual Studio 2012. The installer can create VS2012 toolbox palette for the component, and can optionally install VS2012 sample projects. In addition, toolbox palettes are now created for all .NET target frameworks supported by the respective Visual Studio versions.

New in Version 2.0.1

Side-By-Side Containers

Items in the report can now be arranged parallelly by putting them inside the new SideBySideContainer report item. For example, this is useful to display two (or more) data ranges one next to the other.

Exporting

A new exporter has been added - MhtmlExporter, which enable exporting reports to the MHTML format. MhtmlExporter and HtmlExporter now share the same base class.

Autosize Labels

Labels can now automatically resize to fit their contents through the new AutoSize property.

New in Version 2.0

ReportEditor Control

A new ReportEditor control is now available. The report can be embedded in any application to provide the ability to create, save, open, preview and print reports. The editor UI consists of a designer area, a property grid, a toolbox, and a preview panel. The report provides features, such as clipboard operations, undo and redo, the ability to register external data sources for use inside the editor, simplified serialization, and more. To read more about the editor, visit ReportEditor Control.

XML Serialization

The reports can now be serialized and deserialized to and from XML files through the means of the SaveToXml and LoadFromXml methods respectively. For additional information about XML serialization, refer to the XML Serialization topic.

Report Parameters

Parameters can now be added to a report through the new Parameters collection of the Report class. The parameters provide name, description and value and can be of any type, including expression. For more information about parameters, check the Report Parameters topic.

Improved Expression Editor

The built-in Expression Editor has been improved. It now provides direct access to the built-in expression functions as well as the available keywords, operators, report parameters and table fields. The Using Expressions in Reports topic contains additional information about the new Expression Editor.

New in Version 1.1

Exporting

Two new exporters have been added - ExcelExporter and ImageExporter, which enable exporting reports to the Open Office XML format and as images respectively. In addition, the APIs of all exporters have been unified.

Charts

Many new properties have been added to the chart classes - PieChart, BarChart, RadarChart.


Licensing

Licensing

There are no separate trial builds of MindFusion assemblies. When you purchase a component you can find the license key for this component listed on the Keys & Downloads page at the customer's portal [image] . Assign this license key to the LicenseKey property to disable the component's evaluation mode and stop displaying trial messages. If your application contains more than one MindFusion component, you could call MindFusion.Licensing.LicenseManager.AddLicense(key) method from application start-up code to specify the key once instead of setting it per each control.


Programming Interface Overview

Programming Interface Overview

The next few chapters will give you an overview of the majority of the MindFusion.Reporting features, grouped by functionality. Hyperlinks refer to the detailed description of methods and properties of each class.


Report Designer

Report Designer

MindFusion.Reporting provides rich design-time support in order to facilitate the creation and modification of reports. The MindFusion.Reporting report designer integrates seamlessly in the MS Visual Studio environment. The designer is very intuitive because its behavior closely resembles the built-in Windows Forms editor of MS Visual Studio. Below you can see a sample report opened in MS Visual Studio using the MindFusion.Reporting designer:

The report designer is automatically activated when you open a source code file containing a MindFusion.Reporting report, that is, when you double-click the file or select the 'View Designer' command from its context menu. The report designer provides means for editing the layout of a report visually. The following sections describe the major features of the MindFusion.Reporting in more details.

Creating Report Items

Items in the designer can be created in the same way as they are created in a Windows Forms designer - by dragging them from the toolbox and dropping them onto the report designer surface. Alternatively you can double-click on an item in order to create an object of the appropriate type in the currently active report. The report items in the toolbox can be found under the 'MindFusion.Reporting' category, which becomes visible when you activate a report designer. You can also drag common Windows control to the report, which will create a ControlWrapper report item for this control.

Note

The Document Outline window of MS Visual Studio can help you to see the report items in a report. To open the Document Outline window, choose the 'View -> Other Windows -> Document Outline' command from the menu.

For more information about the individual items that can participate in a report, see Report Items.

The Report Structure

Each report consists of one or more design pages. These pages provide a way to design logically independent parts of complex reports separately. For example, you can have one page for the title of the report and general report information and another for the report's actual contents. You can place all the report elements on a single page and use PageBreak items to denote page breaks but with more complex reports this single page may get rather big and hard to manipulate. Splitting the report into several logical pages can improve the design-time experience in such cases.

Item containment

Each report page can contain an arbitrary number of report items. Certain report items (such as DataRange) can have items on their own, including other containers. This forms a hierarchy of report items, the root of the hierarchy being the report itself.

In order to place a new item in a specific container, drag the item from the MS Visual Studio toolbox and drop it within the container of interest. You can perform the same technique with existing items - simply drag them over the container.

Headers and footers

Report pages can contain headers and footers. The headers and footers contain items that are displayed on each individual instance of the page in the final report layout. For example, a common scenario would be to place a label displaying the current page number in the page footer.

By default, the pages do not have header and footer. In order to create one, right-click on the page surface in the designer and select either the 'Header' or 'Footer' command from the context menu. Make sure you click on an unoccupied section of the page. Otherwise the context menu will contain only the commands specific to the clicked element. The following image displays how the context menu of a report page should look like:

Once the header or footer is created, it becomes visible in the designer and is positioned either above or below the page contents area. The following image illustrates a designer of a page with header and footer, both outlined with a red contour:

You can expand or collapse various page sections by clicking the [image] and [image] buttons in the section's header respectively. Collapsing a section does not affect the way it is rendered in the final report layout. It only affects the design-time appearance of the page.

As with other elements in the report, you can resize page sections by selecting them and dragging the resize handles that appear at the selection border. Page sections can only be resized to the bottom and right. Alternatively you can resize page sections by dragging their headers with the mouse.

Headers and footers for data ranges

DataRange objects can have their own headers and footers, similar to those of the page. The header and footer of a data range are displayed in the beginning and the end of each occurrence of this data range in the final report layout. For example, if a data range is split across two pages, its header and footer will be displayed once on both pages. The header and footer of a data range are usually used to display column header texts.

In order to create a header/footer for a data range, right-click on the data range's surface in the designer and select the 'Header'/'Footer' command from the context menu. Unlike to page, the header and footer of a data range do not have headers and can be resized in any direction.

Designer Toolbar

The toolbar is displayed at the top of the report designer. The majority of the commands in the toolbar affect only the behavior of the designer and rarely have impact on the way the report output at run-time.

The following commands are present in the designer toolbar:

Command | Description
Zoom Out | Reduces the size of the report designer. The minimum zoom factor is 100% thus this option can only be used to reverse the effect of the Zoom In command.
Zoom Factor | Displays the current zoom factor. You can type in any zoom factor in the 100-1600% range.
Zoom In | Increases the size of the report designer. The maximum zoom factor is 1600%.
Previous Page | Moves to the previous page in the report.
Current Page | Displays the current page. You can type in a page number to go directly to that page.
Next page | Moves to the next page in the report.
Add Page | Adds a new page at the end of the report.
Delete Page | Deletes the current page. A report should always have at least one page, so, if this is the last page in the report, the deletion will fail.
Toggle Grid | Shows or hides the report designer grid.
Toggle Grid Snap | Turns grid snapping on and off.
Toggle Ordering | Shows or hides the ordering of report items on the current page.

In addition to the default toolbar, the report designer takes advantage of the layout capabilities built in MS Visual Studio. These features can be accessed either through the 'Format' menu or through the 'Layout' toolbar. The toolbar can be displayed by right-clicking on any other MS Visual Studio toolbar and selecting 'Layout' from the context menu.

Designer Toolbox

While the report designer is active a new group of elements (called 'MindFusion.Reporting') is visible in the MS Visual Studio Toolbox. It contains all report items available to use in a report.

More detailed information about individual report items can be found in Report Items.


ReportEditor Control

ReportEditor Control

This ReportEditor control can be used to create, open, save, preview and print MindFusion.Reporting reports. It can be integrated in any WinForms application and provide it with the ability to edit reports. This can be useful for full-scale reporting applications as well as smaller applications that let the end users modify existing reports in a visual environment. For example, an application hosting the ReportEditor control can be used to allow end-users to adjust preexisting report templates according to their needs.

Note

The ReportEditor class is located in the MindFusion.Reporting.Editor.dll assembly.

Important

The minimum required "Target framework" of applications using the Report Editor is ".NET Framework 4".

The Editor Components

The editor consists of four major components - designer area, property grid, toolbox and preview panel. The following image illustrates the default appearance of the ReportEditor control.

The designer area is located in the middle with the properties grid and the toolbox located to the left and right respectively. The preview panel can be switched to from the tab at the bottom of the control. All of those components can be hidden through the ShowPropertiesWindow, ShowToolboxWindow and ShowPreview properties respectively. To programmatically toggle between the Design and Preview tabs, use the ActiveTabPage property.

Working With the Editor

User Experience

Because the ReportEditor control is based on the same components and services that are used for implementing the design-time support of MindFusion.Reporting reports in Visual Studio, creating reports using the ReportEditor control and creating reports in Visual Studio is nearly identical from user's point of view. To learn the basics about how to design reports interactively, check the Report Designer topic.

Creating, Opening and Saving Reports

The Report instance displayed inside the editor can be accessed through the Report property. Note, that this property is read-only. Because of this, to open an existing report for editing, first save the report using its SaveToXml method, then open the report inside the editor through the OpenReport method. Opening the report directly by calling LoadFromXml on the Report itself is not advisable. More generally, modifying the edited report programmatically in any way needs to be done with caution. Check the Modifying the Edited Report Programmatically section at the end of this topic for tips how to do this.

To create a new report or save the current report, use the NewReport and SaveReport methods respectively. To check if the current report is modified since it was opened or last saved, use the IsReportDirty property. This property is automatically updated whenever the report is changed, opened or saved through the editor.

Commands

The editor supports a variety of standard menu commands that can be invoked through the InvokeCommand method. For example, to align the left sides of the report items currently selected in the editor, invoke the standard command AlignLeft using the following code:

C# [image] Copy Code

reportEditor.InvokeCommand(StandardCommands.Align);

Visual Basic [image] Copy Code

reportEditor.InvokeCommand(StandardCommands.Align)

Alternatively, commands can be invoked through the MenuCommandService, which can be obtained from the editor through its GetService method.

The following table lists the majority of the standard menu commands supported by the editor:

CommandID | Description
AlignBottom | Aligns the bottom sides of the currently selected components.
AlignHorizontalCenters | Aligns the horizontal centers of the currently selected components.
AlignLeft | Aligns the left sides of the currently selected components.
AlignRight | Aligns the right sides of the currently selected components.
AlignTop | Aligns the top sides of the currently selected components.
AlignVerticalCenters | Aligns the vertical centers of the currently selected components.
BringToFront | Brings the currently selected components at the top of the z-order.
CenterHorizontally | Centers the currently selected components horizontally inside their respective parents.
CenterVertically | Centers the currently selected components vertically inside their respective parents.
Copy | Copies the selected components to the clipboard.
Cut | Cuts the selected components.
Delete | Deletes the selected components.
HorizSpaceConcatenate | Removes the horizontal spacing between the currently selected components. The primary selected component remains stationary.
HorizSpaceDecrease | Decreases the horizontal spacing between the currently selected components. The primary selected component remains stationary.
HorizSpaceIncrease | Increases the horizontal spacing between the currently selected components. The primary selected component remains stationary.
HorizSpaceMakeEqual | Makes the horizontal spacing between the currently selected components equal. The leftmost and rightmost components remain stationary.
Paste | Pastes the components in the clipboard.
PropertiesWindow | Displays and focuses the Properties window.
Redo | Redoes the last undone operation.
SendToBack | Sends the currently selected components at the bottom of the z-order.
SizeToControl | Makes the size of the currently selected components the same as the size of the primary selected component.
SizeToControlHeight | Makes the height of the currently selected components the same as the height of the primary selected component.
SizeToControlWidth | Makes the width of the currently selected components the same as the width of the primary selected component.
Undo | Undoes the most recent operation.
VertSpaceConcatenate | Removes the vertical spacing between the currently selected components. The primary selected component remains stationary.
VertSpaceDecrease | Decreases the vertical spacing between the currently selected components. The primary selected component remains stationary.
VertSpaceIncrease | Increases the vertical spacing between the currently selected components. The primary selected component remains stationary.
VertSpaceMakeEqual | Makes the vertical spacing between the currently selected components equal. The topmost and bottommost components remain stationary.

In addition, the editor supports the custom menu commands from the MenuCommands class.

Associating UI Elements with Commands

The report editor provides means to listen to changes of the supported commands. This can be useful when a UI element in the application needs to be associated with a specific command. When the command not enabled, the element needs to be automatically grayed out (or disabled) to indicate this. For example, a button in the application that triggers the Undo command should be disabled when Undo is not available.

To listen to command changes, pass an instance of a class implementing the ICommandListener interface (along with the ID of the respective command) to the RegisterCommandListener method. When the state of the command with the specified ID changes, the specified listener is notified through its UpdateState method.

The implementation of the ICommandListener interface depends on the type of the user elements that need to be updated. For example, let's examine an application, which provides a ToolStripButton components to trigger various commands. Here is a sample implementation of the ICommandListener interface for this application:

C# [image] Copy Code

private class ToolStripItemCommandListener : ICommandListener
{
public CommandListener(ToolStripItem item)
{
this.item = item;
}

public void UpdateState(bool enabled, bool visible)
{
item.Enabled = enabled;
item.Visible = visible;
}

private ToolStripItem item;
}

Visual Basic [image] Copy Code

Private Class CommandListener
Implements ICommandListener

Public Sub New(item As ToolStripItem)
Me.item = item
End Sub

Public Sub UpdateState(enabled As Boolean, visible As Boolean) Implements ICommandListener.UpdateState
item.Enabled = enabled
item.Visible = visible
End Sub

Private item As ToolStripItem

End Class

Let's assume that undoButton is an existing ToolStripButton inside the application that should trigger the Undo command. Then the following code will associate undoButton with the Undo command:

C# [image] Copy Code

reportEditor.RegisterCommandListener(StandardCommands.Undo, new CommandListener(undoButton));

Visual Basic [image] Copy Code

reportEditor.RegisterCommandListener(StandardCommands.Undo, New CommandListener(undoButton))

Now, when Undo is available, the button will be enabled, when Undo is not available, the button will be disabled.

Registering Data Sources

The data sources represent data objects that the report elements can be bound to. Any object can be used as a data source, including DataSet, array of business objects, custom objects, and so on. The data sources can be added to the editor through one of the AddDataSource overloads. The newly added data sources appear as components in a small tray window at the bottom of the designer area and can be subsequently selected inside the property grid as DataSource for DataRange and Chart report items. Adding a data source to the editor does not cause the edited report to become dirty nor does it change the report in any way, until the data source is actually selected as DataSource for a report item. Creating a new report (through NewReport) or closing the current report (through CloseReport) do not cause the registered data sources to disappear.

When a data source is added to the editor it is associated with a unique name. This name is serialized when the report is saved and is used during deserialization to identify the data source an item is bound to. The name of the data source can be specified explicitly by using the AddDataSource overload or generated automatically by the editor by using the AddDataSource overload. Both overloads return an IComponent object, which is the component representing the data source inside the editor. In the case when the editor automatically generated a name for the data source, this name can be obtained through the IComponent.Site.Name property of the returned object.

DataRange objects can be automatically created from registered data sources. To do this, right-click on a page inside the designer area and select 'Create DataRange from Data Source...' item in the context menu. This will display a dialog with all registered data sources and their fields or properties. The user can select the members to include in the generated DataRange.

Modifying the Report Programmatically

The edited report should not be modified directly. More specifically, new items should not be created through constructors and added to the report or to item containers, and existing items should not be removed or modified through property assignment. Direct modifications are not tracked by the undo engine, do not update the designer surface and the UI elements automatically, and will often cause exceptions. For example, the following modifications are not recommended:

C# [image] Copy Code

reportEditor.Report.Pages.Add(new Page());
reportEditor.Report.Pages[0].Items[0].Location = new Location(10, 10);
reportEditor.Report.Pages.RemoveAt(0);

Visual Basic [image] Copy Code

reportEditor.Report.Pages.Add(New Page())
reportEditor.Report.Pages[0].Items[0].Location = New Location(10, 10)
reportEditor.Report.Pages.RemoveAt(0)

Creating Items

New items should be created through the IDesignerHost service. A reference to this service can be obtained from the editor by calling the GetService method. The following code illustrates how to create a new page:

C# [image] Copy Code

IDesignerHost designerHost = reportEditor.GetService<IDesignerHost>();
Page newPage = designerHost.CreateComponent(typeof(Page)) as Page;

Visual Basic [image] Copy Code

Dim designerHost As IDesignerHost = reportEditor.GetService(Of IDesignerHost)()
Dim newPage As Page = CType(designerHost.CreateComponent(GetType(Page)), Page)

Adding Items

Adding new item to a container should be wrapped in calls to the OnComponentChanging and OnComponentChanged methods of the IComponentChangeService. A reference to this service can be obtained through the GetService method as well. The following code illustrates how to add the previously created page instance to the report:

C# [image] Copy Code

IComponentChangeService componentChange = reportEditor.GetService<IComponentChangeService>();
componentChange.OnComponentChanging(reportEditor.Report, null);
reportEditor.Report.Pages.Add(newPage);
componentChange.OnComponentChanged(reportEditor.Report, null, null, null);

Visual Basic [image] Copy Code

Dim componentChange As IComponentChangeService = reportEditor.GetService(Of IComponentChangeService)()
componentChange.OnComponentChanging(reportEditor.Report, Nothing)
reportEditor.Report.Pages.Add(newPage)
componentChange.OnComponentChanged(reportEditor.Report, Nothing, Nothing, Nothing);

Modifying Items

Items can be modified by wrapping the property assignment in an OnComponentChanging/OnComponentChanged block, similarly to how items are added. Alternatively, items can be modified through PropertyDescriptor objects. The following code demonstrates how to change the location of an existing item using the second approach:

C# [image] Copy Code

PropertyDescriptor locationProperty = TypeDescriptor.GetProperties(item)["Location"];
locationProperty.SetValue(item, new Location(0, 0));

Visual Basic [image] Copy Code

Dim locationProperty As PropertyDescriptor = TypeDescriptor.GetProperties(item)("Location")
locationProperty.SetValue(item, New Location(0, 0))

Removing Items

Items are removed similarly to how they are added. The removed items also need be destroyed through the DestroyComponent method of the IDesignerHost service. The following snippet removes the first page of the edited report:

C# [image] Copy Code

IDesignerHost designerHost = reportEditor.GetService<IDesignerHost>();
IComponentChangeService componentChange = reportEditor.GetService<IComponentChangeService>();
componentChange.OnComponentChanging(reportEditor.Report, null);
Page removedPage = reportEditor.Report.Pages[0];
reportEditor.Report.Pages.RemoveAt(0);
componentChange.OnComponentChanged(reportEditor.Report, null, null, null);
designerHost.DestroyComponent(removedPage);

Visual Basic [image] Copy Code

Dim designerHost As IDesignerHost = reportEditor.GetService(Of IDesignerHost)()
Dim componentChange As IComponentChangeService = reportEditor.GetService(Of IComponentChangeService)()
componentChange.OnComponentChanging(reportEditor.Report, Nothing)
Dim removedPage as Page = reportEditor.Report.Pages(0)
reportEditor.Report.Pages.RemoveAt(0)
componentChange.OnComponentChanged(reportEditor.Report, Nothing, Nothing, Nothing)
designerHost.DestroyComponent(removedPage)

Note

Keep in mind that reports need to have at least one page. Removing the last page of the report will result in an exception.

Using Transactions

Each modification to the report results in an undo record i the undo history. Some modifications produce even more than one record due to various indirect modifications, such as property initializations of newly created objects. To wrap up several modifications as a single undo record, they can be performed inside a transaction. The following example modifies the Location and Size of an existing item inside a transaction:

C# [image] Copy Code

IDesignerHost designerHost = reportEditor.GetService<IDesignerHost>();
using (DesignerTransaction transaction = designerHost.CreateTransaction("Modifying item"))
{
PropertyDescriptor locationProperty = TypeDescriptor.GetProperties(item)["Location"];
locationProperty.SetValue(item, new Location(0, 0));
PropertyDescriptor sizeProperty = TypeDescriptor.GetProperties(item)["Size"];
sizeProperty.SetValue(item, new Dimension(20, 20));
transaction.Commit();
}

Visual Basic [image] Copy Code

Dim designerHost As IDesignerHost = reportEditor.GetService(Of IDesignerHost)()
Using transaction As DesignerTransaction = designerHost.CreateTransaction("Modifying item")

Dim locationProperty As PropertyDescriptor = TypeDescriptor.GetProperties(item)("Location")
locationProperty.SetValue(item, New Location(0, 0))
Dim sizeProperty As PropertyDescriptor = TypeDescriptor.GetProperties(item)("Size")
sizeProperty.SetValue(item, New Dimension(20, 20))
transaction.Commit()

End Using

It is also possible to nest transactions.


Report Items

Report Items

The following items are available to use in the MindFusion.Reporting reports. The majority of the report items share two common properties: Location and Size - specifying the position of the element relative to its parent element, and its size respectively.

Page

The page is the most fundamental element of a MindFusion.Reporting report. Pages in the report are represented by objects of the Page class. Each report can contain an arbitrary number of pages. The page itself can contain an arbitrary number of other report elements, such as labels and data ranges. When the report is processed by a call to its Run method, the pages can be split if the target space is insufficient to hold the processed page contents.

Properties

The most notable page properties are Background, Border and PageOrientation. The first two define the background and border of the page. The latter is used to specify the page orientation. If PageOrientation is set to Unspecified, the actual orientation of the page is determined by the defaultPageOrientation parameter passed to the Layout method of the Report class.

Header and footer

Each page can optionally contain a header and/or a footer. Headers are displayed on top of the page, while footers are displayed at the bottom. If a page is split during report processing, its header and footer are displayed for each occurrence of the page in the final layout. You can assign a header and/or a footer to a page either through the report designer (see Report Designer) or through code. The latter requires you to assign a PageSection object to the Header or Footer property of the Page respectively. The following code illustrates this:

C# [image] Copy Code

// Create the header
PageSection header = new PageSection();

// Perform initialization of the header here, by adding various report items
// to it, for example

// Set the header to a page
page.Header = header;

VB.NET [image] Copy Code

' Create the header
Dim header As New PageSection()

' Perform initialization of the header here, by adding various report items
' to it, for example

' Set the header to a page
page.Header = header

There are various properties, such as Border, Background and Visible, which affect the visualization of the header and footer in the final layout.

Label

The label elements display text within a report. Labels are represented by the Label class. The text displayed by the label can be either static, a value from a data source or a value calculated by an expression. Additionally, the text can contain various formatting specifiers, such as <b>, <i> and so on. The text displayed by a label is specified through its Text property.

Data-bound labels

Data-bound labels can be created only within DataRange objects. The data source of the label is specified by the DataSource property of its containing DataRange object. The name of the data field that the label is bound to is specified through the DataField property. When DataField is set, the Text property of the label is ignored and the displayed text is determined by the value of the related field in the data source.

Expressions

Labels can display texts more complex than static and data field values. You can include the so-called expressions within the text of the label. When the text is processed, the expressions within it are evaluated and the expressions are replaced with the result of the evaluation.

To embed expressions in the label text enclose the expressions in square brackets. For example, the following label text is valid and it will display the string "Date: " followed by the system's date at the time of evaluation. Note, that the expression in the example is highlighted in bold.

Expression [image] Copy Code

Date: [Now()]

The result of the evaluation of the above text will be something similar to "Date: 12/10/2008 2:23:38 PM".

It is possible to specify formatting to the value of the expression. To do so, add an '@' symbol after the expression but before the closing ']' then add the string representing the formatting specifier enclosed in quotes. The following example extends the previous one by adding formatting to the resulting date. Note, that the formatting specifier in the example is highlighted in bold.

Expression [image] Copy Code

Date: [Now()@"d"]

The result of the evaluation will now be similar to the following: "Date: 12/10/2008".

For more information about the expressions in MindFusion.Reporting in general, visit Expressions. For more information on how to use expressions in label texts, check Using Expressions in Reports.

Properties

Besides the Text and the DataField properties, labels expose several other properties that can be used to further customize the appearance of the label text. The Alignment, LineAlignment, Padding, Color and Font control how the text of the label is displayed and the position within the label's bounds.

DataRange

The data range elements provide a way to perform data-binding in MindFusion.Reporting reports. The data ranges are represented by the DataRange class. For extensive information about how to data-bind using data ranges can be found in the Binding Reports to a Data Source topic.

Properties

DataRange objects expose some common visualization properties, such as Background and Border. There are two additional properties - AlternatingBackground and AlternatingBorder, both of which default to null (Nothing in Visual Basic). When these properties are assigned values different from null, they are used as the background and border of every second occurrence of this data range in the final layout. In other words, Background and Border are used for the odd occurrences of a data range, while AlternatingBackground and AlternatingBorder are used for the even ones.

The AllowSplit property, when set to false, prevents the data range from splitting to more than one page when the report is processed. The ArrangeByX property specifies whether to lay out data range instances horizontally first, then vertically. If ArrangeByX is set to false (the default), the instances of the data range are always arranged vertically regardless of whether there is space along the x-axis. The Repeat property is used with disconnected data ranges to specify the number of occurrences of these data ranges in the final layout.

Picture

The picture elements enable you to add static images to a report. Pictures are represented by the Picture class. Similarly to labels, pictures can be data-bound if they are positioned within a data-bound DataRange element. To bind a picture to a field in the data source, use its DataField property.

Properties

To assign a static image to a picture, use the Image property. The border and background of the image can be specified through the Border and Background properties respectively. You can rotate the image at arbitrary degrees through the RotationAngle property. The alignment of the displayed image is controlled through the ImageAlign property.

Canvas

The canvas elements can be used in order to perform custom rendering within a report. The canvas elements are represented by the Canvas class. In order to perform drawing within the canvas, you need to handle its RenderContents event. The DrawCanvasEventArgs argument passed to the handler of this event contains an IGraphics object, which can be used to perform the necessary drawing.

Data-bound canvases

You can data-bind canvases in the same way you can bind labels and pictures - by placing them within a data-bound DataRange and setting the appropriate value to its DataField property. The value acquired through the data-binding is supplied to the RenderContents event handler through the DataValue property of the event argument.

Charts

MindFusion.Reporting provides four chart types that can be used in reports. They are represented by the BarChart, LineChart, PieChart and RadarChart classes. Each of these classes provides a set of properties that lets you customize the chart's appearance. For further information, read the topics of the respective classes. For more information on how to use charts in reports, visit Charts in Reports.

Page Break

The page break elements are a special kind of report elements represented by the PageBreak class. Page breaks do not appear in the final layout of the report. When a page break is encountered during layout, it forces (as its name suggests) a new page to be created and the layout to continue on this new page. Page breaks should not be placed in containers other than pages or they may cause unpredictable results.

Properties

The only notable property of a PageBreak object is its position within its containing element specified by the Location property.

Line

The line elements enable you to add straight colored lines to a report. Lines are represented by the Line class.

Properties

The Line objects expose two properties that define the position of the line relative to its containing element - StartPoint and EndPoint. The appearance of the line can be modified through the Color, DashStyle and Width properties.

Ellipse

The Ellipse elements are similar to the line - they enable you to add a static shape, an ellipse to a report.

Properties

To modify the appearance of the ellipse, use the Color, DashStyle and Width properties.


Binding Reports to a Data Source

Binding Reports to a Data Source

There are several ways to create data-bound contents in a MindFusion.Reporting report. The majority of the data-binding mechanisms involve the use of one or more DataRange objects. It is also possible to create data-bound Chart objects outside of data ranges.

Note

The sections below assume you are already acquainted with the process of adding data sources to a .NET application. For a step-by-step tutorial on how to do this, refer to Tutorial 1: Getting Started.

Using DataRange objects

In order to perform data-binding you have to create a DataRange object and add it to the report. Then assign the appropriate data source to the DataSource property of the data range and the name of the respective data member (usually table or view) to its DataMember property. You can do this either from the property grid in the report designer or directly via code.

In the following example a data range is bound to the Employees table in an existing data set:

C# [image] Copy Code

this.dataRange1.DataSource = this.nwindDataSet1;
this.dataRange1.DataMember = "Employees";

Visual Basic [image] Copy Code

Me.dataRange1.DataSource = Me.nwindDataSet1
Me.dataRange1.DataMember = "Employees"

The above code assumes that dataRange1 identifies the existing DataRange object and nwindDataSet1 - an existing .NET DataSet object.

Once the data range is bound to a data source, you can associate the report items contained in that data range with individual fields in the bound data member by assigning the name of the field to the item's DataField property. In the example, if we assume that we have a label label1 within the data range, we can associate this label with the 'FirstName' field in the Employees table by assigning 'FirstName' to the label's DataField property:

C# [image] Copy Code

this.label1.DataField = "FirstName";

Visual Basic [image] Copy Code

Me.label1.DataField = "FirstName"

When running the report, the data range will be multiplied as many times as there are records in the Employees table. The label1 in each occurrence of the data range will contain the 'FirstName' of the employee from the corresponding record.

Note

Currently, it is not possible to create data-bound DataRange objects within headers and footers.

For a step-by-step example on how to create data-bound reports using data ranges, see Tutorial 2: Binding to a Data Source.

Master detail relation

MindFusion.Reporting supports master detail relation through data range composition. You need to create a data range, bound to one of the data members. Then you need to create another data range as a child of the first one, bound to the data member related to the first one. Finally, you have to specify the name of the relation as a value to the MasterDetailRelation property of the inner data range. The following code illustrates this:

C# [image] Copy Code

this.innerRange.DataSource = this.nwindDataSet1;
this.innerRange.DataMember = "Products";
this.innerRange.MasterDetailRelation = "CategoriesProducts";

this.outerRange.DataSource = this.nwindDataSet1;
this.outerRange.DataMember = "Categories";
this.outerRange.Items.Add(this.innerRange);

Visual Basic [image] Copy Code

Me.innerRange.DataSource = Me.nwindDataSet1
Me.innerRange.DataMember = "Products"
Me.innerRange.MasterDetailRelation = "CategoriesProducts"

Me.outerRange.DataSource = Me.nwindDataSet1
Me.outerRange.DataMember = "Categories"
Me.outerRange.Items.Add(Me.innerRange)

The code makes many assumptions including the correctness of the DataRange objects referenced by innerRange and outerRange and the availability of the 'Categories' and 'Products' data members within the specified data set.

Data range composition can be achieved very easily through the Report Designer by dragging the inner data range to the outer one.

Automation

It is possible to create data-bound DataRange objects automatically within the Report Designer. This automatic creation involves setting up the DataSource and DataMember properties of the data range automatically as well as adding one or more labels representing individual data fields to the new data range. It is also possible to create a header, containing static label texts with the names of the individual columns.

To create a data-bound DataRange object right-click anywhere on the page surface in the report designer and select the 'Create DataRange from Adapter...' command from the context menu. This command displays a dialog box with the table adapters currently available in the report. In order for this to work, you have to have created at least one data adapter in the report from which to create the new data range. The following image shows how this dialog box looks like:

You need to select the fields you want to be present in the data range and whether the data range should have a header or not. The labels representing the selected fields are evenly distributed along the width of the newly created data range.

For a step-by-step example on how to use this automation option, visit Tutorial 1: Getting Started.

Data-binding Chart objects

There is one type of MindFusion.Reporting elements that can be data-bound without the need to place them in a data-bound DataRange object, namely, the classes deriving from Chart - BarChart, LineChart, PieChart and RadarChart. For more information about those elements and how you can use them in reports, check Charts in Reports.

As with data ranges, you can bind Chart objects by using their DataSource and DataMember to specify the data source and member respectively. Then you need to assign the field to bind to through the appropriate property. If you want to data-bind a BarChart object, you should assign the name of the data field to its DataFields property. If you want to bind a PieChart, you should assign to its DataField property. To bind a LineChart, use its XDataFields and YDataFields properties. Finally, to bind a RadarChart, use its DataFields property.

For example, the following code binds the BarChart object referenced by the variable barChart1 to the field "UnitPrice" in a table "Products" of a data source identified by a .NET DataSet referenced by the variable dataSet1:

C# [image] Copy Code

this.barChart1.DataFields = "UnitPrice";
this.barChart1.DataMember = "Products";
this.barChart1.DataSource = this.dataSet1;

Visual Basic [image] Copy Code

Me.barChart1.DataFields = "UnitPrice"
Me.barChart1.DataMember = "Products"
Me.barChart1.DataSource = Me.dataSet1

The Chart objects provide other properties that can be data-bound. For example, the XLabelsFields property of the BarChart class can be set to the name of the field to supply the texts of the labels across the x-axis. In order for this binding to work, you also have to set the LabelType property of the XAxisSettings property of the BarChart class to CustomText. Here is how you can do this in code:

C# [image] Copy Code

this.barChart1.XLabelsFields = "ProductName";
this.barChart1.XAxisSettings.LabelType = MindFusion.Charting.AxisLabelType.CustomText;

Visual Basic [image] Copy Code

Me.barChart1.XLabelsFields = "ProductName"
Me.barChart1.XAxisSettings.LabelType = MindFusion.Charting.AxisLabelType.CustomText


Charts in Reports

Charts in Reports

MindFusion.Reporting provides several report items that can be used to visualize information as a chart. The following table lists the available charting elements along with a short description and their corresponding icon in the Visual Studio Toolbox:

Name | Description
BarChart | Displays 2D and 3D bar charts.
LineChart | Displays line, area, scatter and bubble charts as well as different combinations of them.
PieChart | Displays both 2D and 3D pie and doughnut charts.
RadarChart | Displays 2D and 3D radar and polar charts.

To add a chart element to the report in the Designer, simply drag its icon from the Visual Studio Toolbox and drop onto the page surface. To bind the chart to a data source, you have to use the properties provided by that particular chart type. For example, to bind a BarChart object, you have to use its DataSource, DataMember and DataFields properties. For more information on how to data-bind chart elements, check Binding Reports to a Data Source. For a step-by-step tutorial on how to use charts in reports, visit Tutorial 4: Using Charts in Reports.


Report Parameters

Report Parameters

Report parameters have names, description and value. The value of a parameter can be any object, including expression.

Adding Report Parameters

Report parameters can be added to a report through the Parameters collection of the Report class. Parameters can be added either programmatically or through the built-in editor inside a designer.

Adding Parameters in Code

To add a parameter in code, create an instance of this class, specify its name, value, and optionally description and type (through the Name, Value, Description, and Type properties respectively), and add it to the Parameters collection. The type of a parameter is determined automatically from the value. However, setting the type explicitly is required when the parameter value is an expression. Otherwise, the value will be interpreted as string. The following code illustrates how to create a parameter with expression value in code:

C# [image] Copy Code

ReportParameter parameter = new ReportParameter("DateCreated", "[Now()]");
parameter.Type = ReportParameterType.Expression;
report.Parameters.Add(parameter);

Visual Basic [image] Copy Code

Dim parameter As New ReportParameter("DateCreated", "[Now()]")
parameter.Type = ReportParameterType.Expression
report.Parameters.Add(parameter)

Adding Parameters in the Designer

To add a report parameter in the designer, select the report, navigate to the Parameters property in the property grid and press the 'Browse' button. This will display the ReportParameter Collection Editor as illustrated by the following image:

Click the 'Add' Button at the button to create a new parameter, select the parameter in the list, then fill in its properties in the property grid at the right side. The value editor in the property grid changes dynamically based on the selected type.

Accessing Report Parameters

Report parameters can be referenced in expressions by name. To access a report parameter, prefix its name with "Properties." or "Report.". The following example demonstrates an expression that references the DateCreated parameter defined earlier:

Expression [image] Copy Code

The report was created on [Parameters.DateCreated.Value]

The Value member reference above is optional. Specifying [Parameters.DateCreated] will yield the same result. If the value of a parameter is an expression, it will be evaluated when the parameter is accessed.

The name, type or description of the parameter can be referenced using the same syntax. For example, the following expression displays the description of a parameter:

Expression [image] Copy Code

[Parameters.MyParam.Description]

If the value of the report parameter is a custom object, the properties of this object can be accessed in the same manner.

It is possible to reference report parameters within the value of other parameters. This needs to be done with caution to avoid cyclic referencing, which will result in an exception.


Displaying Reports on a Windows Form

Displaying Reports on a Windows Form

In order to display a MindFusion.Reporting report on a form, you need to use an instance of the ReportViewer class. The ReportViewer class is contained in the MindFusion.Reporting.WinForms.dll assembly.

To add an instance of the ReportViewer class to your project, open the Windows form where you want to place the viewer and customize the Visual Studio Toolbox by adding the MindFusion.Reporting.WinForms.dll assembly. Then either drag and drop or double-click on the ReportViewer icon ( [image]) in the Toolbox. This will create a new instance of the ReportViewer class and place it on the current form.

Note

You can display the Visual Studio Toolbox through the View -> Toolbox command from the main menu.

Once the ReportViewer object is created, you can associate it with an existing report through its Report property. You need to ensure that the report is processed by a call to its Run method before the viewer is actually displayed.

The following code illustrates how to create a report and associate it with an existing viewer. The example assumes that reportViewer1 is a variable identifying an existing viewer.

C# [image] Copy Code

Report report = new Report();
report.Run();
reportViewer1.Report = report;

Visual Basic [image] Copy Code

Dim report As New Report()
report.Run()
reportViewer1.Report = report

The report associated with the viewer in the above example is empty and therefore only a single empty page will be displayed.

For a step-by-step demonstration on how to use the ReportViewer class, refer to Tutorial 1: Getting Started.


Report Serialization and Output

Report Serialization and Output


XML Serialization

XML Serialization

Reports can be serialized to and deserialized from XML files through one of the SaveToXml and LoadFromXml overloads respectively.

Serializing Data Sources

Data sources that are referenced by various report elements are not serialized/deserialized automatically when a report is saved or loaded from a file. When a report is saved to a file, the SerializeDataSource event is raised for each data source in the report. The event argument provides a reference to the data source being serialized and expects to receive a name that should identify the data source in the XML file. This event can be raised multiple times for the same data source if a data source is referenced by more than one report item. When a data source is deserialized, the DeserializeDataSource event is raised to allow clients to resolve a data source using the name specified during serialization.

For example, when serializing a DataSet data source, the DataSetName can be used as a name.

Custom Report Serialization

Internally the SaveToXml and LoadFromXml methods call the Save and Load protected methods of the Report class to carry out the serialization and deserialization of the report contents. These methods can be overriden in derived report classes to serialize and deserialize custom report contents. For example, the following Report-derived class provides a new PageMargins property and overrides Save and Load in order to handle the serialization/deserialization of this property:

C# [image] Copy Code

class MyReport : Report
{
protected override void Save(XmlElement element, XmlSerializationContext context)
{
context.WriteMargins(PageMargins, "pageMargins", element);
base.Save(element, context);
}

protected override void Load(XmlElement element, XmlSerializationContext context)
{
PageMargins = context.ReadMargins("pageMargins", element);
base.Load(element, context);
}

public Margins PageMargins
{
get { return pageMargins; }
set { pageMargins = value; }
}

private Margins pageMargins;
}

Visual Basic [image] Copy Code

Class MyReport
Inherits Report

Protected Overrides Sub Save(element As XmlElement, context As XmlSerializationContext)
context.WriteMargins(PageMargins, "pageMargins", element)
MyBase.Save(element, context)
End Sub

Protected Overrides Sub Load(element As XmlElement, context As XmlSerializationContext)
PageMargins = context.ReadMargins("pageMargins", element)
MyBase.Load(element, context)
End Sub

Public Property PageMargins() As Margins
Get
Return _pageMargins
End Get
Set
_pageMargins = value
End Set
End Property

Private _pageMargins As Margins

End Class


Exporting

Exporting

Currently MindFusion.Reporting reports support exporting to image, PDF, HTML, and XLSX formats.

Exporting to PDF Files

Add references to the MindFusion.Reporting.Pdf.dll and MindFusion.Pdf.dll assemblies to your project. Create a PdfExporter instance and call its Export method, passing a reference to the report to be exported and a string specifying the output file name. Margins specifies the page margins for all pages in the document. If you need to set the page size and orientation, use the PageSize, and PageOrientation properties.

The following example shows how to export a report to a PDF file. The example assumes that pdfPath is a variable containing the name of the file to export to and report is a variable identifying the Report to export.

C# [image] Copy Code

MindFusion.Reporting.Export.PdfExporter pdfExporter =
new MindFusion.Reporting.Export.PdfExporter();
pdfExporter.Export(report, pdfPath);

Visual Basic [image] Copy Code

Dim pdfExporter As New MindFusion.Reporting.Export.PdfExporter()
pdfExporter.Export(report, pdfPath)

Exporting to HTML Files

Add reference to the MindFusion.Reporting.Html.dll assembly to your project. Create an HtmlExporter instance and call one of its Export method overloads.

If there are images in the report, set EmbedImages to true to embed the images in the HTML as text. If this property is set to false, the images will be copied to the directory specified by the ImageFolder property. This property can also specify a directory relative to the output directory of the exported HTML file.

Note

Not all browsers can handle embedded images. Make sure the target browser supports them when using the EmbedImages property.

The following example demonstrates the use of the HtmlExporter class. The example assumes that pdfPath is a variable containing the name of the file to export to and report is a variable identifying the Report to export.

C# [image] Copy Code

MindFusion.Reporting.Export.HtmlExporter htmlExporter =
new MindFusion.Reporting.Export.HtmlExporter();
htmlExporter.Export(report, htmlPath);

Visual Basic [image] Copy Code

Dim htmlExporter As New MindFusion.Reporting.Export.HtmlExporter()
htmlExporter.Export(report, htmlPath)

The HtmlExporter class provides a second overload of the Export method, which exports the report to a .NET StringBuilder rather than a file. This is useful when you want to embed the report in a custom page, for example, within a scrollable DIV tag.

Exporting to MHTML Files

Exporting to MHTML is similar to exporting to HTML. It is done through the MhtmlExporter class.

Exporting to Image

The following example demonstrates the use of the ImageExporter class. The example assumes that imagePath is a variable containing the name of the file to export to and report is a variable identifying the Report to export.

C# [image] Copy Code

MindFusion.Reporting.Export.ImageExporter imageExporter =
new MindFusion.Reporting.Export.ImageExporter();
imageExporter.Export(report, imagePath);

VB.NET [image] Copy Code

Dim imageExporter As New MindFusion.Reporting.Export.ImageExporter()
imageExporter.Export(report, imagePath)

Exporting to Open Office XML (XLSX) Files

Add references to the MindFusion.Reporting.Excel.dll and MindFusion.Excel.dll assemblies to your project. Create an ExcelExporter instance and call its Export method, passing a reference to the report to be exported and a string specifying the output file name. Margins specifies the page margins for all pages in the document. If you need to set the page size and orientation, use the PageSize, and PageOrientation properties.

The following example shows how to export a report to an XLSX file. The example assumes that xlsxPath is a variable containing the name of the file to export to and report is a variable identifying the Report to export.

C# [image] Copy Code

MindFusion.Reporting.Export.ExcelExporter excelExporter =
new MindFusion.Reporting.Export.ExcelExporter();
excelExporter.Export(report, xlsxPath);

VB.NET [image] Copy Code

Dim excelExporter As New MindFusion.Reporting.Export.ExcelExporter()
excelExporter.Export(report, xlsxPath)


Printing and Print Previewing

Printing and Print Previewing

Printing

To print the report, you need an instance of the ReportPrinter class. Assign the report to be printed to the Report property of the ReportPrinter object then call its Print method. Make sure that the attached report has been previously processed by a call to its Run method.

The following example demonstrates the use of the ReportPrinter class. The example assumes that report1 is a variable identifying a valid Report instance and that the Run method of this instance has already been invoked.

C# [image] Copy Code

ReportPrinter printer = new ReportPrinter();
printer.Report = report1;
printer.Print();

Visual Basic [image] Copy Code

Dim printer As New ReportPrinter()
printer.Report = report1
printer.Print()

Previewing

To preview the report, create a ReportPrinter object and assign the report to its Report property in a way similar to the one specified above. Instead of calling the Print method however, create an instance of the .NET PrintPreviewDialog class, assign the previously created ReportPrinter object to its Document property and call its Show or ShowDialog method.

The following example demonstrates how to preview an existing report. The example makes the same assumptions as the one above.

C# [image] Copy Code

ReportPrinter printer = new ReportPrinter();
printer.Report = report1;

PrintePreviewDialog previewDialog = new PrintePreviewDialog();
previewDialog.Document = printer;
previewDialog.ShowDialog();

Visual Basic [image] Copy Code

Dim printer As New ReportPrinter()
printer.Report = report1

Dim previewDialog As New PrintePreviewDialog()
previewDialog.Document = printer
previewDialog.ShowDialog()

Using the extended Print Preview form

MindFusion.Reporting supplies a custom print preview form. This form contains better looking toolbar icons but its functionality is similar to the standard PrintPreviewDialog. The extended preview form is exposed by the PrintPreviewForm class, found in the MindFusion.Reporting.WinForms.dll. The extended form is used the same way as the standard .NET PrintPreviewDialog - you assign the ReportPrinter object to its Document property and call either Show or ShowDialog methods.

The following image shows the extended preview form displaying a report:

The extended preview form can be customized through the options argument supplied to its overloaded constructor. This argument is of type PreviewOptions and provide several properties that allow you to customize various aspect of the form, such as the tooltips of the toolbar buttons.


Expressions

Expressions


Overview

Overview

Expressions in MindFusion.Reporting are conceptually very similar to expressions in various programming languages, such as C# and Visual Basic. An expression is a text fragment that can be evaluated to a single value or object. Expressions can contain a literal value, a function invocation, an operator and its operands, or a field name.

Expressions can use operators that in turn use other expressions as parameters, or function calls whose parameters are in turn other method calls, so expressions can range from simple to very complex.

Literals

The simplest type of expression is a literal. A literal is a constant value written directly in the expression. For example 5 and "Hello World" in the example below are both literals.

Expression [image] Copy Code

"Hello World"
5

The first line in the example is an expression containing a single literal - the string "Hello World". The second line is another expression containing the number 5. Both of these expressions evaluate to their contained literals.

Literals in MindFusion.Reporting can be numbers, strings and colors. The string literals should be enclosed in quotes. The color literals have the format #RRGGBB, where RR, GG and BB are the hexidecimal representations of the red, green and blue channels of the color.

Table Fields

You can include names of table fields in an expression. The available fields to choose from depend on the context in which the expression is evaluated. For example, if you include an expression in a Label's text, the fields that can be referenced within the expression are only those contained in the data table bound to the DataRange object, containing the label. If the label is not contained in a data range, or the data range is not data-bound, no fields will be available for use in the expression.

The following example shows an expression, which concatenates two data fields of type string - FirstName and LastName:

Expression [image] Copy Code

FirstName + " " + LastName

For more information on how to use expressions, check Using Expressions in Reports.

Report Parameters

Report parameters can be referenced in expressions by using the "Parameters." or "Report." keywords followed by the name of the parameter. For example, the expresion below references a parameter named MyParam:

Expression [image] Copy Code

Parameters.MyParam

For more information about report parameters and how to use them in expressions, check Report Parameters.

Invoking Functions

The following example demonstrates another type of expression, called function invocation. The function in the example is Len with a single string argument.

Expression [image] Copy Code

Len("Hello World")

A function invocation requires the name of the function, followed by parenthesis and any function parameters. The function invocation evaluates to the return value of the function. In the above example, the invocation will evaluate to the number of characters in the string specified as argument, that is, 11.

Each function expects arguments of specific type. Passing an argument of type that does not match the type the function expects will either result in false evaluation or a run-time error. Additionally, the number of arguments passed to the function should match the number of arguments expected.

There are numerous predefined functions that can be called within an expression. A complete list with all available functions, see Function Reference.

Operators

An operator is a symbol that takes one or more expressions, called operands, as input and returns a value. Operators that take one operand, such as the unary minus operator (-) are called unary operators. Operators that take two operands, such as arithmetic operators (+, -, *, /) are called binary operators. In MindFusion.Reporting there are no tertiary operators.

The following example illustrates an expression that is the sum of two numbers (operands).

Expression [image] Copy Code

2 + 3

The operand of an operator can be any valid expression that evaluates to a value of the same type as the one expected by the operator. For example, the following expression applies operators to the result of a function invocation, then passes the result as an argument to another function.

Expression [image] Copy Code

Sqrt(Pow(SideA, 2) + Pow(SideB, 2))

The example evaluates the hypotenuse of a right triangle with sides identified by the fields SideA and SideB respectively.

The following table describes the operators available in MindFusion.Reporting in more details:

Operator | Description
+ | Addition. The addition operator can work on both number and string operands, including mixing between both.
- | Subtraction or Unary minus. Can be applied on numeric operands.
! | Logical negation. Unary operator that can be applied only on boolean operands.
*, / | Multiplication and Division. Can be applied to any numeric operands.
% | Modulo. Can be applied on integer operands and returns the reminder of the division between them.
<, >, <=, >= | Comparison operators. Can be used on numeric operands.
==, <> | Equality operators. Can be used on numeric and string operands.
&&, || | Logical AND and OR operators. Can be applied on boolean operands.
&, ^, | | Bitwise operators (OR, XOR and OR). Can be applied on integer operands.

Operator Precedence

The operators encountered in an expression are evaluated according to their precedence. Operators with higher priority are evaluated before operators with lower priority. For example, the following example will evaluate to 14, because the multiplication will be evaluated first.

Expression [image] Copy Code

2 + 3 * 4

You can change operator precedence by using parenthesis. Changing the order of the operators in the above example, so that the addition is evaluated first, can be done like this:

Expression [image] Copy Code

(2 + 3) * 4

The following table lists the operators in order of precedence:

Unary | - (unary), !
Arithmetic - Multiplicative | *, /, %
Arithmetic - Additive | +, - (binary)
Relational | <, >, <=, >=
Equality | ==, <>
Logical, in order of precedence | &, ^, |
Conditional, in order of precedence | &&, ||


Function Reference

Function Reference

The functions available in expressions are organized in several categories, based on their purpose. Some functions belong to more than one category. Below is a table of all functions sorted alphabetically.

Name | Description
Abs | Returns the absolute value of a specified number.
Acos | Returns the angle whose cosine is the specified number.
Asc | Returns the ANSI character code corresponding to the first letter in a string.
Asin | Returns the angle whose sine is the specified number.
Atn | Returns the angle whose tangent is the specified number.
CBool | Converts the value, specified as an argument, to a value of type Boolean.
CDate | Converts the value, specified as an argument, to a value of type Date.
CDbl | Converts the value, specified as an argument, to a value of type Double.
Chr | Returns the character associated with the specified ANSI character code.
CInt | Converts the value, specified as an argument, to a value of type Integer.
CLong | Converts the value, specified as an argument, to a value of type Long.
Cos | Returns the cosine of an angle.
CStr | Converts the value, specified as an argument, to a value of type String.
CSng | Converts the value, specified as an argument, to a value of type float.
DateAdd | Returns a date to which a specified time interval has been added.
DatePart | Returns the specified part of a given date.
Day | Returns a whole number between 1 and 31, inclusive, representing the day of the month.
DateDiff | Returns the number of intervals between two dates.
DateSerial | Returns a value of type Date for a specified year, month, and day.
E | Represents the natural logarithmic base, specified by the constant, e.
Exp | Returns e raised to the specified power.
Hour | Returns a whole number between 0 and 23, inclusive, representing the hour of the day.
IIf | Returns one of two parts, depending on the evaluation of an expression.
InStr | Returns the position of the first occurrence of one string within another.
InStrRev | Returns the position of an occurrence of one string within another, from the end of string.
Int | Returns the integer portion of a number.
IsDate | Returns a Boolean value indicating whether an expression can be converted to a date.
IsNull | Returns a Boolean value that indicates whether an expression contains no valid data (Null).
IsNumeric | Returns a Boolean value indicating whether an expression can be evaluated as a number.
LCase | Returns a string that has been converted to lowercase.
Left | Returns a specified number of characters from the left side of a string.
Len | Returns the number of characters in a string.
Log | Returns the logarithm of a specified number.
LTrim | Returns a copy of a string without leading spaces.
Mid | Returns a specified number of characters from a string.
Minute | Returns a whole number between 0 and 59, inclusive, representing the minute of the hour.
Month | Returns a whole number between 1 and 12, inclusive, representing the month of the year.
Now | Returns the current date and time according to the setting of your computer's system date and time.
PageCount | Returns the number of pages.
PageCurrent | Returns the number of the current page.
PI | Represents the ratio of the circumference of a circle to its diameter.
Pow | Returns a specified number raised to the specified power.
RangeItemCount | Returns the count of the items in the current DataRange.
RangeItemCurrent | Returns a number that is the index of the current instance of the DataRange.
Replace | Returns a string in which a specified substring has been replaced with another substring a specified number of times.
Right | Returns a specified number of characters from the right side of a string.
Rnd | Returns a random number.
Round | Returns the number nearest the specified value.
RTrim | Returns a copy of a string without trailing spaces.
Second | Returns a whole number between 0 and 59, inclusive, representing the second of the minute.
Sgn | Returns a value indicating the sign of a number.
Sin | Returns the sine of the specified angle.
Space | Returns a string consisting of the specified number of spaces.
Sqr | Returns the square root of a number.
Sqrt | Returns the square root of a number.
Str | Returns a string representation of a number.
StrComp | Returns a value indicating the result of a string comparison.
String | Returns a repeating character string of the length specified.
StrReverse | Returns a string in which the character order of a specified string is reversed.
Today | Returns a DateTime value containing the current date according to your system.
Tan | Returns the tangent of the specified angle.


Conversion Functions

Conversion Functions

The following functions are contained in this category:

Name | Description
CBool | Converts the value, specified as an argument, to a value of type Boolean.
CDate | Converts the value, specified as an argument, to a value of type Date.
CDbl | Converts the value, specified as an argument, to a value of type Double.
CInt | Converts the value, specified as an argument, to a value of type Integer.
CLong | Converts the value, specified as an argument, to a value of type Long.
CSng | Converts the value, specified as an argument, to a value of type float.
CStr | Converts the value, specified as an argument, to a value of type String.
Int | Returns the integer portion of a number.
Str | Returns a string representation of a number.


CBool

CBool

Converts the value, specified as an argument, to a value of boolean type.

Syntax

Copy Code

bool CBool (
object value
)

Parameters

value
An expression that can be evaluated to a boolean.

Return Value

true, if the specified value can be evaluated as a boolean and evaluates to true; otherwise, false.

Remarks

If value is a boolean, value is returned. If value is a number, true is returned if the number is non-zero, otherwise - false. If value is a string, true is returned if the string is "true" and false if the string is "false", no case-sensitive.

See Also

Conversion Functions
CDate Function
CDbl Function
CInt Function
CLong Function
CSng Function
CStr Function


CDate

CDate

Converts the value, specified as an argument, to a value of date type.

Syntax

Copy Code

DateTime CDate (
object value
)

Parameters

value
Any date expression or a string expression recognizable as a date or time.

Return Value

A DateTime value.

Remarks

Use the IsDate function to determine if value can be converted to a date. CDate recognizes date literals and time literals as well as some numbers that fall within the range of acceptable dates.

CDate recognizes date formats according to the locale setting of your system. The correct order of day, month, and year may not be determined if it is provided in a format other than one of the recognized date settings. In addition, a long date format is not recognized if it also contains the day-of-the-week string.

See Also

Conversion Functions
Date & Time Functions
DateAdd Function
DatePart Function


CDbl

CDbl

Converts the value, specified as an argument, to a value of type double.

Syntax

Copy Code

double CDbl (
object value
)

Parameters

value
Any valid expression.

Return Value

Returns the specified argument converted to double, or 0, if the argument cannot be converted.

Remarks

If value is a number of any kind, it is converted to double. If value is a string, it is parsed as a double and the result is returned. If none of the above applies, 0 is returned.

See Also

Conversion Functions
CBool Function
CDate Function
CInt Function
CSng Function
CStr Function


CInt

CInt

Converts the value, specified as an argument, to a value of type int.

Syntax

Copy Code

int CInt (
object value
)

Parameters

value
Any valid expression.

Return Value

Returns the specified argument converted to int, or 0, if the argument cannot be converted.

Remarks

If value is a number of any kind, it is converted to int. If value is a string, it is parsed as an integer and the result is returned. If none of the above applies, 0 is returned.

See Also

Conversion Functions
CBool Function
CDate Function
CDbl Function
CSng Function
CStr Function


CLong

CLong

Converts the value, specified as an argument, to a value of type long.

Syntax

Copy Code

long CLong (
object value
)

Parameters

value
Any valid expression.

Return Value

Returns the specified argument converted to long, or 0, if the argument cannot be converted.

Remarks

If value is a number of any kind, it is converted to long. If value is a string, it is parsed as a long and the result is returned. If none of the above applies, 0 is returned.

See Also

Conversion Functions
CBool Function
CDate Function
CDbl Function
CInt Function
CStr Function


CSng

CSng

Converts the value, specified as an argument, to a value of type float.

Syntax

Copy Code

float CSng (
object value
)

Parameters

value
Any valid expression.

Return Value

Returns the specified argument converted to float, or 0, if the argument cannot be converted.

Remarks

If value is a number of any kind, it is converted to float. If value is a string, it is parsed as a float and the result is returned. If none of the above applies, 0 is returned.

See Also

Conversion Functions
CBool Function
CDate Function
CInt Function
CLong Function
CStr Function


CStr

CStr

Converts the value, specified as an argument, to a string value.

Syntax

Copy Code

string CStr (
object value
)

Parameters

value
Any valid expression.

Remarks

The data in value determines what is returned according to the following table:

Parameter Type | Return Value
Boolean | A string containing "true" or "false".
Date | A string containing a date in the short-date format of your system.
Null | A zero-length string ("").
Empty | A zero-length string ("").
Other numeric | A string containing the number.

See Also

Conversion Functions
CBool Function
CDate Function
CInt Function
CLong Function
CSng Function
Str Function


Int

Int

Returns the integer portion of a number.

Syntax

Copy Code

int Int (
double value
)

Parameters

value
Any valid numeric expression.

Return Value

The largest integer less than or equal to value.

See Also

Conversion Functions
Math Functions
CInt Function
Round Function


Str

Str

Returns a string representation of the specified number.

Syntax

Copy Code

string Str (
double value
)

Parameters

value
Any valid numeric expression.

Remarks

Str converts the specified number to a string using the current regional settings. If you want to perform a more sophisticated formatting of a number or use a different culture, you have to use the formatting capabilities provided when embedding an expression.

See Also

Conversion Functions
String Function
Len Function


Date & Time Functions

Date & Time Functions

The following functions are contained in this category:

Name | Description
CDate | Converts the value, specified as an argument, to a value of type Date.
DateAdd | Returns a date to which a specified time interval has been added.
DateDiff | Returns the number of intervals between two dates.
DatePart | Returns the specified part of a given date.
DateSerial | Returns a value of type Date for a specified year, month, and day.
Day | Returns a whole number between 1 and 31, inclusive, representing the day of the month.
Hour | Returns a whole number between 0 and 23, inclusive, representing the hour of the day.
Minute | Returns a whole number between 0 and 59, inclusive, representing the minute of the hour.
Month | Returns a whole number between 1 and 12, inclusive, representing the month of the year.
Now | Returns the current date and time according to the setting of your computer's system date and time.
Second | Returns a whole number between 0 and 59, inclusive, representing the second of the minute.
Today | Returns a DateTime value containing the current date according to your system.


DateAdd

DateAdd

Returns a date to which a specified time interval has been added.

Syntax

Copy Code

DateTime DateAdd (
string type,
double count,
DateTime date
)

Parameters

type
A string expression that defines the type of units to add.
count
A numeric expression that specifies the number of units to add. This expression can either be positive, to perform addition, or negative, to perform subtraction.
date
A DateTime value to which the units are added.

Settings

The type parameter can have one of the following values:

Parameter Value | Description
y | The value of count represents the number of years to add or subtract from date.
m | The value of count represents the number of months to add or subtract from date.
d | The value of count represents the number of days to add or subtract from date.
h | The value of count represents the number of hours to add or subtract from date.
n | The value of count represents the number of minutes to add or subtract from date.
s | The value of count represents the number of seconds to add or subtract from date.

Remarks

You can use the DateAdd function to add or subtract a specified time interval from a date.

See Also

Date & Time Functions
DateDiff Function
DatePart Function


DateDiff

DateDiff

Returns the number of intervals between two dates.

Syntax

Copy Code

long DateDiff (
string part,
DateTime a,
DateTime b
)

Parameters

part
String expression that is the interval you want to use to calculate the differences between a and b. See Remarks section for values.
a
A DateTime value.
b
A DateTime value.

Remarks

The part parameter can have one of the following values:

Parameter Value | Description
y | The returned value specifies the difference between a and b, expressed in years.
m | The returned value specifies the difference between a and b, expressed in months.
d | The returned value specifies the difference between a and b, expressed in days.
h | The returned value specifies the difference between a and b, expressed in hours.
n | The returned value specifies the difference between a and b, expressed in minutes.
s | The returned value specifies the difference between a and b, expressed in seconds.

You can use the DateDiff function to determine how many specified time intervals exist between two dates. For example, use DateDiff to calculate the number of days between two dates.

If a refers to a later point in time than b, the DateDiff function returns a negative number.

When comparing December 31 to January 1 of the immediately succeeding year, DateDiff for Year ("y") returns 1 even though only a day has elapsed.

See Also

Date & Time Functions
DateAdd Function
DatePart Function


DatePart

DatePart

Returns the specified component of the specified date.

Syntax

Copy Code

int DatePart (
string part,
DateTime date
)

Parameters

part
A string expression that is the interval of time you want to return. See the Remarks section for possible values.
date
A DateTime value you want to evaluate.

Remarks

The part parameter can have the following values:

Parameter Value | Description
y | Returns the year component of date.
m | Returns the month component of date.
d | Returns the day component of date.
h | Returns the hour component of date.
n | Returns the minute component of date.
s | Returns the second component of date.

You can use the DatePart function to obtain a specific component of a date. For example, you can use DatePart to obtain the month of a particular date.

See Also

Date & Time Functions
DateAdd Function
DateDiff Function
Month Function
Day Function
Hour Functinon
Minute Function
Second Function


DateSerial

DateSerial

Returns a value of type DateTime for a specified year, month, and day.

Syntax

Copy Code

DateTime DateSerial (
int year,
int month,
int day
)

Parameters

year
An expression evaluating to a number between 100 and 9999, inclusive.
month
Any numeric expression.
day
Any numeric expression.

Remarks

To specify a date, such as December 31, 1991, the range of numbers for each DateSerial parameter should be in the accepted range for the unit; that is, 1-31 for days and 1-12 for months. However, you can also specify relative dates for each parameter using any numeric expression that represents some number of days, months, or years before or after a certain date.

When any parameter exceeds the accepted range for that parameter, it increments to the next larger unit as appropriate. For example, if you specify 35 days, it is evaluated as one month and some number of days, depending on where in the year it is applied. However, if the date specified by the three parameters, either directly or by expression, falls outside the acceptable range of dates, an error occurs.

See Also

Date & Time Functions
Day Function
Month Function
Now Function


Day

Day

Returns an integer number between 1 and 31, inclusive, representing the day of the month component of the specified date.

Syntax

Copy Code

int Day (
DateTime date
)

Parameters

date
A DateTime value.

See Also

Date & Time Functions
Hour Function
Minute Function
Month Function
Now Function
Second Function


Hour

Hour

Returns a whole number between 0 and 23, inclusive, representing the hour of the day component of the specified date.

Syntax

Copy Code

double Hour (
DateTime date
)

Parameters

date
A DateTime value.

See Also

Date & Time Functions
Day Function
Minute Function
Month Function
Now Function
Second Function


Minute

Minute

Returns an integer number between 0 and 59, inclusive, representing the minute of the hour component of the specified date.

Syntax

Copy Code

int Minute (
DateTime date
)

Parameters

date
A DateTime value.

Remarks

Alternatively, you can obtain the minute of the hour by calling DatePart.

See Also

Date & Time Functions
Day Function
Hour Function
Now Function
Second Function


Month

Month

Returns a integer number between 1 and 12, inclusive, representing the month of the year component of the specified date.

Syntax

Copy Code

int Month (
DateTime date
)

Parameters

date
A DateTime value.

Remarks

Alternatively, you can obtain the month of the year by calling DatePart.

See Also

Date & Time Functions
Day Function
Now Function


Now

Now

Returns the current date and time according to the setting of your computer's system date and time.

Syntax

Copy Code

DateTime Now ()

Remarks

To access the system date, use the Today property.

See Also

Date & Time Functions
Day Function
Hour Function
Minute Function
Month Function
Second Function


Second

Second

Returns an integer value between 0 and 59, inclusive, representing the second of the minute component of the specified date.

Syntax

Copy Code

int Second (
DateTime date
)

Parameters

date
A DateTime value.

Remarks

Alternatively, you can obtain the second of the hour by calling DatePart.

See Also

Date & Time Functions
Day Function
Hour Function
Minute Function
Now Property


Today

Today

Returns a DateTime value containing the current system date.

Syntax

Copy Code

DateTime Today ()

Remarks

The DateTime data type includes time components. When returning the system date, Today sets all of these to 0, so the returned value represents midnight (00:00:00).

To access the day of a date, use the Day property.

See Also

Date & Time Functions
Now Function
DatePart Function
DateSerial Function
DateAdd Function


Inspection Functions

Inspection Functions

The following functions are contained in this category:

Name | Description
IsDate | Returns a Boolean value indicating whether an expression can be converted to a date.
IsNull | Returns a Boolean value that indicates whether an expression contains no valid data (Null).
IsNumeric | Returns a Boolean value indicating whether an expression can be evaluated as a number.


IsDate

IsDate

Returns a boolean value indicating whether the specified expression can be converted to a date.

Syntax

Copy Code

bool IsDate (
object value
)

Parameters

value
Any expression.

Return Value

true, if value is a date or can be converted to a valid date; otherwise, false.

Remarks

A value is recognized as a date if it is a date, it is a string that contains a valid representation of a date, or it is a number. In the last case, the number will be interpreted as the number of ticks.

See Also

Inspection Functions
CDate Function
IsNull Function
IsNumeric Function


IsNull

IsNull

Returns a boolean value that indicates whether the specified expression contains no valid data (null).

Syntax

Copy Code

bool IsNull (
object value
)

Parameters

value
Any expression.

Return Value

true, if value is null, that is, it contains no valid data; otherwise, false.

See Also

Inspection Functions
IsDate Function
IsNumeric Function


IsNumeric

IsNumeric

Returns a boolean value indicating whether the specified expression can be evaluated to a number.

Syntax

Copy Code

bool IsNumeric (
object value
)

Parameters

value
Any expression.

Return Value

true, if the specified expression is recognized as a number; otherwise, false.

See Also

Inspection Functions
IsDate Function
IsNull Function


Math Functions

Math Functions

The following functions are contained in this category:

Name | Description
Abs | Returns the absolute value of a specified number.
Acos | Returns the angle whose cosine is the specified number.
Asin | Returns the angle whose sine is the specified number.
Atn | Returns the angle whose tangent is the specified number.
Cos | Returns the cosine of an angle.
E | Represents the natural logarithmic base, specified by the constant, e.
Exp | Returns e raised to the specified power.
Int | Returns the integer portion of a number.
Log | Returns the logarithm of a specified number.
PI | Represents the ratio of the circumference of a circle to its diameter.
Pow | Returns a specified number raised to the specified power.
Rnd | Returns a random number.
Round | Returns the number nearest the specified value.
Sgn | Returns a value indicating the sign of a number.
Sin | Returns the sine of the specified angle.
Sqr | Returns the square root of a number.
Sqrt | Returns the square root of a number.
Tan | Returns the tangent of the specified angle.


Abs

Abs

Returns the absolute value of the specified number.

Syntax

Copy Code

double Abs (
double value
)

Parameters

value
Any valid numeric expression.

Return Value

The absolute value of the specified number. If the specified value is not a number, 0 is returned.

Remarks

The absolute value of a number is its unsigned magnitude. For example, Abs(-1) and Abs(1) both return 1.

See Also

Math Functions
Sgn Function


Acos

Acos

Returns the angle whose cosine is the specified number.

Syntax

Copy Code

double Acos (
double value
)

Parameters

value
Any valid numeric expression.

Return Value

The angle whose cosine is the specified number.

See Also

Math Functions
Asin Function
Atn Function


Asin

Asin

Returns the angle whose sine is the specified number.

Syntax

Copy Code

double Asin (
double value
)

Parameters

value
Any valid numeric expression, where -1 <= value <= 1.

Remarks

A positive return value represents a counterclockwise angle from the x-axis; a negative return value represents a clockwise angle.

See Also

Math Functions
Acos Function
Atn Function


Atn

Atn

Returns the arctangent of the specified number.

Syntax

Copy Code

double Atn (
double value
)

Parameters

value
Any valid numeric expression.

Remarks

The Atn function takes the ratio of two sides of a right triangle (number) and returns the corresponding angle in radians. The ratio is the length of the side opposite the angle divided by the length of the side adjacent to the angle. The range of the result is -pi/2 to pi/2 radians.

See Also

Math Functions
Cos Function
Sin Function
Tan Function


Cos

Cos

Returns the cosine of the specified angle.

Syntax

Copy Code

double Cos (
double value
)

Parameters

value
Any valid numeric expression that specifies an angle in radians.

Remarks

The Cos function takes an angle and returns the ratio of two sides of a right triangle. The ratio is the length of the side adjacent to the angle divided by the length of the hypotenuse. The result lies in the range -1 to 1, inclusive.

See Also

Math Functions
Sin Function
Tan Function


E

E

Represents the natural logarithmic base, specified by the constant, e.

Syntax

Copy Code

double E ()

Return Value

The return value is the constant 2.71828.

See Also

Math Functions
Exp Function
Log Function


Exp

Exp

Returns e (the base of natural logarithms) raised to the specified power.

Syntax

Copy Code

double Exp (
double value
)

Parameters

value
Any valid numeric expression.

Return Value

The number e raised to the power value.

Remarks

The Exp function complements the action of the Log function and is sometimes referred to as the antilogarithm.

See Also

Math Functions
Sqr Function


Log

Log

Returns the natural (base e) logarithm of the specified number.

Syntax

Copy Code

double Log (
double value
)

Parameters

value
Any valid numeric expression greater than 0.

Remarks

The natural logarithm is the logarithm to the base e. The constant e is approximately 2.718282.

See Also

Math Functions
Exp Function


PI

PI

Returns the constant value of p.

Syntax

Copy Code

double PI ()

Remarks

The numeric constant p is the ratio of the circumference of a circle to its diameter.

Return Value

The return value is the constant 3.14159.

See Also

Math Functions
Pow Function


Pow

Pow

Returns the specified number raised to the specified power.

Syntax

Copy Code

double Pow (
double a,
double b
)

Parameters

a
A number to be raised to a power.
b
A number that specifies a power.

Return Value

The number x raised to the power y.

See Also

Math Functions
Sqr Function


Rnd

Rnd

Returns a random number.

Syntax

Copy Code

double Rnd (
int type
)

Parameters

type
An integer value.

Return Value

The return value depends on the type parameter. The following table describes the behavior of the function depending on the value of the value of type:

Parameter Value | Description
Less than zero | The same number every time, using type as the seed.
Greater than zero | The next random number in the sequence.
Equal to zero | The most recently generated number.

Remarks

The Rnd function returns a value less than 1, but greater than or equal to zero. The value of type determines how Rnd generates a random number as outlined in the above table.

See Also

Math Functions


Round

Round

Returns the specified value rounded to the specified precision.

Syntax

Copy Code

double Round (
double value,
int digits
)

Parameters

value
A number to be rounded.
digits
The number of significant fractional digits (precision) in the return value.

Return Value

Returns the number nearest to value with precision equal to digits. If value is halfway between two numbers, one of which is even and the other odd, then the even number is returned. If the precision of value is less than digits, then value is returned unchanged.

Remarks

The digits parameter specifies the number of significant fractional digits in the return value and ranges from 0 to 28. If digits is zero, then a whole number is returned.

This kind of rounding is sometimes called rounding to nearest, or banker's rounding. If digits is zero, this kind of rounding is sometimes called rounding toward zero.

See Also

Math Functions
Left Function
RTrim Function


Sgn

Sgn

Indicates the sign of a number.

Syntax

Copy Code

double Sgn (
double value
)

Parameters

value
A numeric expression.

Return Value

The function has the following possible return values:

Parameter Value | Return Value
Greater than zero | 1
Equal to zero | 0
Less than zero | -1

If value cannot be evaluated to a number or is null, the function returns 0.

Remarks

The sign of the value parameter determines the return value of the Sgn function.

See Also

Math Functions
Abs Function
Str Function


Sin

Sin

Returns the sine of the specified angle.

Syntax

Copy Code

double Sin (
double value
)

Parameters

value
Any valid numeric expression.

Remarks

This function takes an angle and returns the ratio of two sides of a right triangle. The ratio is the length of the side opposite the angle divided by the length of the hypotenuse. The result lies in the range -1 to 1, inclusive.

See Also

Math Functions
Asin Function
Cos Function
Tan Function


Sqr

Sqr

Returns square root of the specified number.

Syntax

Copy Code

double Sqr (
double value
)

Parameters

value
A numeric expression for which the square root is calculated.

Remarks

If value is negative, the return value is NaN.

See Also

Math Functions
Log Function


Sqrt

Sqrt

Returns the square root of the specified number.

Syntax

Copy Code

double Sqrt (
double value
)

Parameters

value
A numeric expression for which the square root is calculated.

Remarks

If value is negative, the return value is NaN.

See Also

Math Functions


Tan

Tan

Returns the tangent of the specified angle.

Copy Code

double Tan (
double value
)

Parameters

value
Any valid numeric expression that specifies the angle in radians.

Remarks

Tan takes an angle and returns the ratio of two sides of a right triangle. The ratio is the length of the side opposite the angle divided by the length of the side adjacent to the angle.

See Also

Math Functions
Atn Function
Cos Function
Sin Function


Miscellaneous Functions

Miscellaneous Functions

The following functions are contained in this category:

Name | Description
PageCount | Returns the number of pages.
PageCurrent | Returns the number of the current page.
RangeItemCount | Returns the count of the items in the current DataRange.
RangeItemCurrent | Returns a number that is the index of the current instance of the DataRange.


PageCount

PageCount

Returns the total number of pages within the current report.

Syntax

Copy Code

int PageCount ()

Remarks

PageCount is only usable in expressions related to report items. For example, PageCount is usable in expressions embedded in the Text of a Label. When evaluated it returns the total number of pages in the final report layout.

See Also

Miscellaneous Functions
PageCurrent Function
RangeItemCurrent Function
RangeItemCount Function


PageCurrent

PageCurrent

Returns the number of the current page.

Syntax

Copy Code

int PageCurrent ()

Remarks

PageCurrent is only usable in expressions related to report items. For example, PageCurrent is usable in expressions embedded in the Text of a Label. When evaluated it returns the index of the page in the final report layout to which the associated report item belongs to.

See Also

Miscellaneous Functions
PageCount Function
RangeItemCount Function
RangeItemCurrent Function


RangeItemCount

RangeItemCount

Returns the total number of instances of the current DataRange.

Syntax

Copy Code

int RangeItemCount ()

Remarks

RangeItemCount is only usable in expressions related to report items, which are containted in DataRange containers. For example, RangeItemCount is usable in expressions embedded in the Text of a Label, but only when this label is contained in a DataRange. When evaluated it returns the total number of instances of the related DataRange.

See Also

Miscellaneous Functions
RangeItemCurrent Function
PageCount Function
PageCurrent Function


RangeItemCurrent

RangeItemCurrent

Returns the index of the current instance of the current DataRange.

Syntax

Copy Code

int RangeItemCurrent ()

Remarks

RangeItemCurrent is only usable in expressions related to report items, which are containted in DataRange containers. For example, RangeItemCurrent is usable in expressions embedded in the Text of a Label, but only when this label is contained in a DataRange. When evaluated it returns the total number of instances of the related DataRange.

See Also

Miscellaneous Functions
RangeItemCount Function
PageCount Function
PageCurrent Function


Program Flow Functions

Program Flow Functions

The following functions are contained in this category:

Name | Description
IIf | Returns one of two objects, depending on the evaluation of an expression.


IIf

IIf

Returns one of two objects, depending on the evaluation of an expression.

Syntax

Copy Code

object IIf (
bool condition,
object a,
object b
)

Parameters

condition
The expression you want to evaluate.
a
An expression returned if condition evaluates to true.
b
An expression returned if condition evaluates to false.

Return Value

Returns a if condition evaluates to true; otherwise, returns b.

Example

The following example demonstrates how you can use IIf to find the smaller of two numbers:

Copy Code

IIf(5 < 3, 5, 3)

Although the result of the above calculation is obvious, this may not always be the case. Here is the same example applied to fields from a database:

Copy Code

IIf(Field1 < Field2, Field1, Field2)

See Also

Program Flow Functions


Text Functions

Text Functions

The following functions are contained in this category:

Name | Description
Asc | Returns the ANSI character code corresponding to the first letter in a string.
Chr | Returns the character associated with the specified ANSI character code.
InStr | Returns the position of the first occurrence of one string within another.
InStrRev | Returns the position of an occurrence of one string within another, from the end of string.
LCase | Returns a string that has been converted to lowercase.
Left | Returns a specified number of characters from the left side of a string.
Len | Returns the number of characters in a string.
LTrim | Returns a copy of a string without leading spaces.
Mid | Returns a specified number of characters from a string.
Replace | Returns a string in which a specified substring has been replaced with another substring a specified number of times.
Right | Returns a specified number of characters from the right side of a string.
RTrim | Returns a copy of a string without trailing spaces.
Space | Returns a string consisting of the specified number of spaces.
StrComp | Returns a value indicating the result of a string comparison.
String | Returns a repeating character string of the length specified.
StrReverse | Returns a string in which the character order of a specified string is reversed.


Asc

Asc

Returns the ANSI character code corresponding to the first letter in the specified string.

Syntax

Copy Code

string Asc (
string value
)

Parameters

value
A string expression.

Remarks

If value contains no characters, a run-time error occurs.

See Also

Text Functions
Chr Function


Chr

Chr

Returns the character associated with the specified ANSI character code.

Syntax

Copy Code

string Chr (
int c
)

Parameters

c
A number that identifies a character.

Remarks

Numbers from 0 to 31 are the same as standard, nonprintable ASCII codes.

See Also

Text Functions
Asc Function


InStr

InStr

Returns the position of the first occurrence of one string within another.

Syntax

Copy Code

int InStr (
string a,
string b
)

Parameters

a
A string expression representing the string being searched.
b
A string expression representing the string being searched for.

Return Value

The InStr function returns the following values:

Parameter | Return Value
a is zero-length | -1
a is null | -1
b is zero-length | -1
b is null | -1
b is not found | -1
b is found within a | The position at which match is found.

See Also

Text Functions
InStrRev Function


InStrRev

InStrRev

Returns the position of the first occurrence of one string within another, starting from the end of string.

Syntax

Copy Code

int InStrRev (
string a,
string b
)

Parameters

a
A string expression representing the string being searched.
b
A string expression representing the string being searched for.

Return Value

InStrRev returns the following values:

Parameter | Return Value
a is zero-length | -1
a is null | -1
b is zero-length | -1
b is null | -1
b is not found | -1
b is found within a | The position at which match is found.

See Also

Text Functions
InStr Function


LCase

LCase

Returns the specified string converted to lowercase.

Syntax

Copy Code

string LCase (
string value
)

Parameters

value
Any valid string expression.

Remarks

Only uppercase letters are converted to lowercase; all lowercase letters and non-letter characters remain unchanged.

See Also

Text Functions
Str Function


Left

Left

Returns the specified number of characters from the left side of the specified string.

Syntax

Copy Code

string Left (
string a,
int length
)

Parameters

a
A string expression from which the leftmost characters are returned. If a is null, null is returned.
length
A numeric expression indicating how many characters to return. If 0, a zero-length string is returned. If greater than or equal to the number of characters in a, the entire string is returned.

Remarks

To determine the number of characters in a, use the Len function.

See Also

Text Functions
Right Function
Len Function
Mid Function


Len

Len

Returns the number of characters in the specified string.

Syntax

Copy Code

int Len (
string value
)

Parameters

value
Any valid string expression. If value is null, the function returns zero.

See Also

Text Functions
InStr Function


LTrim

LTrim

Returns a copy of the specified string without leading white spaces.

Syntax

Copy Code

string LTrim (
string value
)

Parameters

value
Any valid string expression. If value is null, null is returned.

Remarks

Use RTrim to return a string without its trailing white spaces.

See Also

Text Functions
Left Function
Right Function
RTrim Function


Mid

Mid

Returns a specified number of characters from a string.

Syntax

Copy Code

string Mid (
string value,
int pos,
int length
)

Parameters

value
A string expression from which characters are returned. If value is null, null is returned.
pos
The zero-based starting character position in value of the substing to be returned. If pos is greater than the number of characters in value, the function returns an empty string ("").
length
The number of characters to return. If there are fewer than length characters in the string, all characters from pos to the end of the string are returned.

Remarks

To determine the number of characters in a string, use the Len function.

See Also

Text Functions
Left Function
Right Function
Len Function


Replace

Replace

Returns a string in which a specified substring has been replaced with another substring a specified number of times.

Syntax

Copy Code

string Replace (
string value,
string oldValue,
string newValue
)

Parameters

value
A string expression representing the string to be searched for.
oldValue
A string expression representing the substring to be replaced.
newValue
A string expression representing the substring to replace all occurrences of oldValue.

Return Value

A string equivalent to value but with all instances of oldValue replaced with newValue. If any of the specified parameters is null, null is returned.

See Also

Text Functions
Left Function
RTrim Function


Right

Right

Returns the specified number of characters from the right side of the specified string.

Syntax

Copy Code

string Right (
string a,
int length
)

Parameters

a
A string expression from which the rightmost characters are returned. If a is null, null is returned.
length
A numeric expression indicating how many characters to return. If 0, a zero-length string is returned. If greater than or equal to the number of characters in a, the entire string is returned.

Remarks

To determine the number of characters in a, use the Len function.

See Also

Text Functions
Len Function
Left Function
Mid Function


RTrim

RTrim

Returns a copy of the specified string without trailing white spaces.

Syntax

Copy Code

string RTrim (
string value
)

Parameters

value
Any valid string expression. If value is null, null is returned.

Remarks

Use LTrim to return a string without its leading white spaces.

See Also

Text Functions
Left Function
Right Function
LTrim Function


Space

Space

Returns a string consisting of the specified number of spaces.

Syntax

Copy Code

string Space (
int count
)

Parameters

count
Any valid integer expression. Represents the number of spaces in the resulting string.

Remarks

The Space function is useful for formatting output and clearing data in fixed-length strings.

See Also

Text Functions
Replace Function


StrComp

StrComp

Returns a value indicating the result of a comparison of the specified strings.

Syntax

Copy Code

int StrComp (
string a,
string b
)

Parameters

a
Any valid string expression.
b
Any valid string expression.

Return Value

The StrComp function has the following return values.

Parameters | Return Value
String a sorts ahead of string b | -1
String a is equal to string b | 0
String a sorts after string b | 1

Remarks

The strings are compared by alphanumeric sort values beginning with the first character.

See Also

Text Functions
InStr Function


String

String

Returns a string consisting of the specified character repeating the specified number of times.

Syntax

Copy Code

string String (
int count,
int c
)

Parameters

count
A numberic expression specifying the number of occurrences of c in the resulting string.
c
A numberic expression specifying the character or string expression whose first character is used to build the return string.

See Also

Text Functions
Space Function
Str Function


StrReverse

StrReverse

Returns a string in which the character order of the specified string is reversed.

Syntax

Copy Code

string StrReverse (
string value
)

Parameters

value
A string value that must be reversed.

Remarks

The value argument is the string whose characters are to be reversed. If value is a zero-length string (""), a zero-length string is returned. If value is null, null is returned.

See Also

Text Functions
StrComp Function


Using Expressions in Reports

Using Expressions in Reports

You can embed expressions within the text of Label elements and the values of ReportParameter objects by enclosing the expression in square brackets. The following example shows the text of a label with a function call expression embedded within it:

Example [image] Copy Code

The date and time now is: [Now()]

The expression will be evaluated when the report, containing the label is processed by a call to its Run method. Once the expression is evaluated, its string representation is inserted at its place in the text. In the above example, when the label is displayed, the result will be similar to the following: "The date and time now is: 12/15/2000 1:05:11 PM".

Formatting

By default the result from the evaluation of an embedded expression is formatted to a string through a call to its ToString method. It is also possible to apply custom formatting as illustrated by the following example:

Example [image] Copy Code

The date and time now is: [Now() @ "d"]

The above example will format the date received as a result of the expression evaluation using short date format. The result will be similar to the following: "The date and time now is: 12/15/2000".

Generally, you can apply any string, which would be a valid format string for the ToString method of the expression evaluation result. The following example illustrates how you can apply formatting to an expression, which evaluates to a number. The example assumes that Price is a field of type double in the data source related to the current context.

Example [image] Copy Code

Cost: [Price @ "$#,##0.00"]

Specifying Culture

When applying formatting to an expression, the current culture is used by default. The following example will produce text similar to "16 Jan" when evaluated on machines with regional settings set to en-US or similar:

Example [image] Copy Code

[Now() @ "dd MMM"]

Evaluating the example is dependent on the current culture however and may yield unexpected results if the current culture is not the one we expect. To force explicitly specify the culture, use the following syntax:

Example [image] Copy Code

[Now() @ "dd MMM" : "en-US"]

This will force the expression to always be evaluated with the specified culture regardless of the current regional settings.

The Expression Editor

The built-in expression editor facilitates the creation of expressions for both labels and report parameters in design-time. To open the editor, press the '...' button next to the Text property (or Value property in the case of parameters) of the label in the property grid. The following image illustrates the Expression Editor:

The editor contains the following sections: the expression text editor at the top, and the list of categories, items, as well as information panel at the bottom.

The Expression Text Editor

The text editor is the place to enter the text of the expression by typing. This editor supports auto-completion and function information. To activate auto-completion, press CTRL+Space. To display the information about the function in the current context, press CTRL+SHIFT+Space.

Category View

This tree view contains the categories of the various elements that can be included in an expression. The categories include Keywords, Report parameters, Table fields, Operators, and Common functions. The functions and operators are further divided to subcategories based on their type. For functions these include Date & Time, Math, Text, and more. The operators include arithmetic, logical, comparison, and more.

Item View

This view displays all expression elements contained in the currently selected category in the Category View. Selecting an item will display additional information about this item and its usage in the Info View to the right. Double-clicking on an item will automatically insert the item at the current position in the Text Editor.

Info View

This view displays information about the currently selected item in the Item View as well as syntax and example usage (if available).


Tutorials

Tutorials

The following tutorials will show you how to create and design MindFusion.Reporting reports. The reports are applicable for both Visual Studio 2005 and Visual Studio 2008.

Tutorial 1: Getting Started
This tutorial will help you create a very simple data-bound report from scratch.

Tutorial 2: Binding to a Data Source
This tutorial will demonstrate how to create and bind DataRange objects manually and how to create master-detail relationship between data-ranges representing related tables.

Tutorial 3: Customizing Your Report
This tutorial illustrates how to adjust various settings of a report in order to customize its appearance.

Tutorial 4: Using Charts in Reports
This tutorial extends Tutorial 1 by adding a bar chart to the report.

Tutorial 5: Adding a RadarChart to a Report


Tutorial 1: Getting Started

Tutorial 1: Getting Started

This tutorial will help you create a very simple data-bound report from scratch. The following steps are explained in more details below:

  • Creating a new project
  • Adding a MindFusion report to the project
  • Adding a data source to the project
  • Adding the data source to the MindFusion report
  • Creating a data-bound DataRange
  • Creating a report viewer
  • Running the application

1. Creating a new project

From MS Visual Studio select the File -> New -> Project menu command in order to create a new project.

In the dialog box that appears, select the project language and type. Select the desired programming language, then pick the 'Windows' category and select 'Windows Application' from the list to the right. Type the name and the location of the project in the text boxes at the bottom of the dialog, then click 'OK'. This tutorial uses 'myapp' as a name of the project.

2. Adding a MindFusion report to the project

From the 'Project' menu within MS Visual Studio select the 'Add New Item...' command.

The 'Add New Item' dialog box is displayed with the list of all item templates registered within MS Visual Studio. Select the 'MindFusion Report' item in the list, then type the name of the report class file in the text box at the bottom of the dialog ('myreport' for the purposes of this tutorial) and click 'Add'.

A class file representing the new report is created and added to the current project. A designer for the report is automatically opened in the environment.

3. Adding a data source to the project

Select the 'Add New Data Source...' command from the 'Data' menu in MS Visual Studio. This will display the 'Data Source Configuration Wizard', which will automate the process of adding a new data source to your application.

Follow the instructions in the wizard that appears in order to create a new data source. On the first step of the wizard select the type of the data source ('Database' in this particular sample), then click 'Next'.

In the next step of the wizard, set up the database connection.

- Click on the 'New Connection' button and enter the information required to describe the connection in the 'Add Connection' dialog box that appears. This tutorial uses the nwind.mdb file supplied with the project installation as its data source. For this purpose, select 'Microsoft Access Database File (OLE DB)' as a data adapter and enter the path to the nwind.mdb file as a database file name.

- Click 'OK' to close the 'Add Connection' dialog box, then click 'Next' to move to the next step of the wizard. The MS Visual Studio will ask you whether you want to copy the mdb file to your project directory and modify the connection string to reflect this. Select 'Yes'.

Note

After saving the connection string, a new app.config file is added to your project, and it appears in the Solution Explorer.

On the following step save the connection under the default name 'nwindConnectionString', then click 'Next'.

Select the database objects you want to import in the project.

Expand the 'Tables' node and select the 'Products' table by placing a check in the box to its left. Type the name of the imported dataset in the text box at the bottom of the dialog (this tutorial uses the default - nwindDataSet), then click 'Finish'.

4. Adding the data source to the MindFusion report

Either rebuild or close and reopen the project. This is necessary in order to display the newly imported data objects in the MS Visual Studio toolbox.

A new category has appeared in the toolbox. It is named after your project (in this particular case - 'myapp Components'). There are two items in this category - nwindDataSet and ProductsTableAdapter representing the data set and the data adapter for the Products table respectively.

Note

If the toolbox is not visible, you can display it through the 'Toolbox' command in the View menu or by using the respective shortcut key combination (CTRL+ALT+X by default).

Now that the data items are visible in the toolbox, double-click on each of them in order to create an object of the corresponding type within the report. Alternatively, you can drag the items from the toolbox and drop them onto the report design surface. The newly created data objects appear in the list at the very bottom of the report designer.

5. Creating a data-bound DataRange

Right-click on the report design surface and select the 'Create DataRange from Adapter...' command from the context menu.

In the 'Select Data Source' dialog box that appears, place a check on those fields from the Products table you want to have displayed by the report. The tutorial uses ProductID, ProductName, QuantityPerUnit, UnitPrice and UnitsInStock.

Select the 'Generate Header' option at the bottom of the dialog box in order to generate a header for the DataRange and click 'OK'.

A new DataRange appears in the report. The DataRange contains five labels bound to the selected fields. The labels are evenly distributed along the width of its parent DataRange. The DataRange also includes a header containing labels with the static names of the displayed fields.

The DataRange is already bound to the Products table. However, the table adapter needs to be filled with information from the database. Unfortunately this cannot be performed in the designer. Instead, we have to manually modify the source code of the report.

Right-click on the report and select the 'View Code' command from the context menu.

Locate the constructor of the report within the source code and add the following line of code right after the call to InitializeComponent (note, that the newly added code is outlined in bold):

C# [image] Copy Code

public myreport()
{
InitializeComponent();

// Fill the data adapter from the dataset
productsTableAdapter1.Fill(nwindDataSet1.Products);
}

Visual Basic [image] Copy Code

Public Sub New()

InitializeComponent()

' Fill the data adapter from the dataset
productsTableAdapter1.Fill(nwindDataSet1.Products)

End Sub

The report is ready to use. Close it and return back to the main application form designer.

6. Creating a report viewer

Ensure that the designer of the main application form is currently active in the MS Visual Studio. Right-click on the toolbox and select the 'Choose Items...' command from the context menu.

This will bring up the 'Choose Toolbox Items' dialog box. The '.NET Framework Components' should be initially active.

Click on the 'Browse...' button and navigate to the MindFusion.Reporting.WinForms.dll file located in the MindFusion.Reporting installation folder. Select the file and click 'Open'.

This will add the ReportPrinter and ReportViewer components to the list. They should be initially selected, so simply confirm the import by clicking 'OK'.

The two components should now appear in the toolbox. Double-click on (or drag and drop) the ReportViewer component to add it to the form.

While the newly added ReportViewer component is selected on the form, open the 'Properties' window and modify the value of its Dock property from None to Fill, as illustrated below:

Note

You can display the 'Properties' window through the 'Properties Window' command in the view menu or by using the respective shortcut key combination (ALT+ENTER by default).

Now that we have a report viewer and a ready report class, all we need to do is create an instance of the report and select this instance in the viewer. We have to do this manually in the code of the form class. Right-click on the form designer and select the 'View Code' command from the context menu.

Locate the form's constructor within the source code and add the following lines of code right after the call to InitializeComponent (note, that the newly added code is outlined in bold):

C# [image] Copy Code

public Form1()
{
InitializeComponent();

// Create and run the report
myreport report = new myreport();
report.Run();

// Select the report in the viewer
reportViewer1.Report = report;
}

Visual Basic [image] Copy Code

Public Sub New()

InitializeComponent()

' Create and run the report
Dim report As New myreport()
report.Run()

' Select the report in the viewer
reportViewer1.Report = report
}

7. Running the application

The application is ready. Compile and run to see the result. After expanding the main application form, it should look similar to the following:

Click the 'Print' button in the viewer's toolbar to print the report.


Tutorial 2: Binding to a Data Source

Tutorial 2: Binding to a Data Source

This tutorial will demonstrate how to create and bind DataRange objects manually and how to create master-detail relationship between data-ranges representing related tables. The following steps are explained in more details below:

  • Prerequisites
  • Adding a new data adapter
  • Creating DataRange objects manually
  • Setting MasterDetail relationship
  • Running the application

Prerequisites

This tutorial continues from where Tutorial 1: Getting Started has ended. It is therefore assumed that we have an existing application with a single data-bound report in it and a form with a set up ReportViewer that displays an instance of this report.

1. Adding a new data adapter

Now that we have an existing data set and an adapter for the 'Products' table, we will expand this data source by creating an adapter for the 'Categories' table.

To do this, go to the 'Data Sources' window, select the 'nwindDataSet' and click the 'Configure DataSet with Wizard' button from the 'Data Sources' window toolbar. This will bring up the 'Data Source Configuration Wizard' that we used in Tutorial 1 in order to setup the data source initially.

Note

To open the 'Data Sources' window, select the Data -> Show Data Sources menu command.

Expand the 'Tables' node and select the 'Categories' table by placing a check in the box to its left. Click 'Finish' to create a new table adapter for the selected table.

Rebuild the project to force the new table adapter to appear in the Visual Studio Toolbox. Add an instance of the CategoriesTableAdapter to the report by double-clicking on the adapter name.

2. Creating DataRange objects manually

In the previous tutorial we demonstrated how to create DataRange objects from an adapter automatically. To create a DataRange manually, drag it from the Toolbox and drop it onto the page surface. From the 'Properties' window set its Location to "0mm, 30mm" (this is temporary to prevent the data range from overlapping the previously created one) and its Size to "100%, 40mm".

Select the page and set its ContentSize to "180, 74" to ensure that the new DataRange will be visible in the designer.

To bind the new data range to the 'Categories' table, set its DataSource property to nwindDataSet1 and its DataMember property to "Categories". The new DataRange is now positioned and data-bound.

To add a label to the data range, simply drag the label from the Toolbox and make sure to drop the label onto the data range surface within the Designer. To ensure that the label is placed within the data range, select the label once it is positioned and press the ESCAPE key. This should select the label's parent, which in this case should be the newly created data range. Set the Location of the new label to "2mm, 2mm", its Size to "50%, 6mm" and its DataField to "CategoryName".

Add a Picture element to the data range. Set its Location to "60%, 2mm", its Size to "38%, 36mm" and its DataField to "Picture".

The report containing the two data ranges should now look similar to the following (the newly created data range is outlined in red):

3. Setting MasterDetail relationship

In order to create master detail relationships between the two data range elements, we have to embed them into one another. To do this, select the first data range object in the Designer and drag it onto the second one.

Note

To drag a data range, click on the [image] icon located at the top left corner of the data range when it is selected.

Adjust the position of the dragged data range. Set its Location to "2mm, 20mm" and its Size to "50%, 8mm". Finally move the containing data range at the beginning of the report, by settings its Location to "0mm, 0mm". The following image illustrates the result:

Now we have to setup the MasterDetailRelation property of the internal (embedded) data range. The name of the relation can be obtained from the data set designer.

To open the data set designer, navigate to the nwindDataSet.xsd file in the 'Solution Explorer', right-click on it and select the 'View Designer' command from the context menu. A database relationship diagram will be displayed. Select the relation connecting the 'Products' and 'Categories' tables in the diagram and open the 'Properties' window. The Name property contains the value ("CategoriesProducts" in our case) that should be set to the MasterDetailRelation property of the embedded data range.

Go back to the Report Designer, select the internal data range (the one bound to the 'Products' table) and set its MasterDetailRelation property to "CategoriesProducts".

Finally modify the report's constructor like this (the new lines are outlined in bold):

C# [image] Copy Code

public myreport()
{
InitializeComponent();

// Fill the data adapter from the dataset
productsTableAdapter1.Fill(nwindDataSet1.Products);
categoriesTableAdapter1.Fill(nwindDataSet1.Categories);
}

Visual Basic [image] Copy Code

Public Sub New()

InitializeComponent()

' Fill the data adapter from the dataset
productsTableAdapter1.Fill(nwindDataSet1.Products)
categoriesTableAdapter1.Fill(nwindDataSet1.Categories)

End Sub

4. Running the application

The main application form should remain unchanged from Tutorial 1. Running the application will yield a result similar to the one illustrated by the following image:


Tutorial 3: Customizing Your Report

Tutorial 3: Customizing Your Report

This tutorial illustrates how to adjust various settings of a report in order to customize its appearance. The following steps are explained in more details below:

  • Prerequisites
  • Adding report header and footer
  • Customizing background colors
  • Customizing borders
  • Customizing fonts
  • Additional customizations

Prerequisites

This tutorial continues from where Tutorial 2: Binding to a Data Source has ended. It is therefore assumed that the reader is acquainted with Tutorial 1 and Tutorial 2 before reading further.

1. Adding report header and footer

You can add header and/or footer to a report page by right-clicking on the page surface in the Designer and selecting respectively the 'Header' or 'Footer' command from the context menu that appears. Selecting the same command again will remove the header and/or footer from the report. Removing a header or footer clears all the report elements contained within them.

For the purposes of this tutorial, lets add a footer to the report. Report elements are added to the footer in the same way they are added to a page - by dragging them from the Visual Studio Toolbox and dropping them onto the header/footer surface in the Designer.

Create a new Label within the footer and set its Location to "0mm, 0mm", its Size to "100%, 10mm" and its Alignment to "Center".

Set the Text property to "[PageCurrent()] of [PageCount()]". The specified text contains the so-called Expressions. The expressions found within the text are evaluated when the report is processed and the result of the evaluation is used in the final label text. To learn more about expressions, see Overview. To learn how to use expressions in label texts, see Using Expressions in Reports.

Finally, set the height of the of the footer itself to "10mm" so that it is exactly as big as the label it contains.

The report designer will now look similar to the image below. The newly created footer and its label are outlined with red.

If you run the application now, you will notice a small text at the bottom of each page specifying the current page and the total number of pages in the report.

2. Customizing background colors

Many report elements allow their background color to be changed. The page header/footer and the page itself allow this too. In this tutorial we will set the background of the footer, created in the previous step, to Gainsboro. To do this, select the footer in the Designer, navigate to its Background property in the Property grid, click the drop-down arrow to the right and select the 'Solid' brush from the drop-down brush editor that appears. The following image illustrates this:

Now we will customize the background of the alternating rows of the internal data range. To do this, select the data range, navigate to its AlternatingBackground property in the Property grid and set it to PaleGoldenrod solid brush the same way we set the brush of the footer above.

Finally, select the header of the internal data range and change its brush to a LightSteelBlue solid brush.

Running the application will yield the following result:

3. Customizing borders

Many report elements allow their border to be customized. In this tutorial we will set the border of the outer data range. To do this, select the data range and navigate to its Border property in the Property grid. The value of this property cannot be set directly. Click on the '...' button to the right of the property value in order to invoke the Format Border dialog box.

In the Format Border dialog box setup the line properties to the right, then click on the buttons corresponding to the various border sides to the left. Set Style to "Solid", Color to "160, 168, 176", Width to "0.0" and Alignment to "Center", then click on each of the four buttons to the left, to indicate that the border will have all four sides. Click 'OK' to confirm. The following image shows the Format Border dialog box:

Note

The Format Border dialog box can be alternatively displayed by clicking on the "Design Border..." command in an element's context menu.

4. Customizing fonts

You can customize the font of individual labels or of the entire report. Changing the font of the report will automatically change the font of all labels on that report whose font has not been explicitly changed. In this tutorial we will change the font of the report to ensure that all texts fit in their corresponding elements. Select the report (by clicking outside of the page in the Designer for example), navigate to its Font property in the Property grid and set its value to "Arial, 8pt".

5. Additional customizations

Running the report now reveals some minor flaws that we might want to get fixed. For example, the instances of the outer data range appear to be adjoined to each other because of the border we applied to the data range earlier. To insert some spacing between adjacent instances, set the Bottom component of the Margin property of the outer data range to, say, "5".

We may further improve the report by preventing the data range instances to split accross pages. In order to do this, set the AllowSplit property of the outer data range to false.

Running the application now and setting the viewer to display two pages at once will result in the following:


Tutorial 4: Using Charts in Reports

Tutorial 4: Using Charts in Reports

This tutorial extends Tutorial 1: Getting Started by adding a bar chart to the report. The following steps are illustrated in more details:

  • Prerequisites
  • Adding a bar chart to the report
  • Data-binding the chart
  • Binding to a custom query

Prerequisites

As mentioned above this tutorial extends Tutorial 1. Therefore it is expected that the reader has finished with Tutorial 1 before reading further.

1. Adding a bar chart to the report

The BarChart is another type of report element, just like Label and Picture. The simplest way to create one is to drag it from the Visual Studio Toolbox and drop it onto the page surface in the Designer.

Once the chart is added to the report, we have to position and resize the chart. This particular chart will hold quite a few bars, so we will stretch it along the width of the first page of the report. Set the Location of the chart to "0mm, 0mm" and its Size to "100%, 60mm". Set the ContentSize property of the current page to "180, 90" so that the whole chart is visible in the Designer. Adjust the Location of the existing data range so that it does not overlap with the newly added chart. Set it to "0mm, 70mm".

Here is how the Designer will look like after these modifications:

2. Data-binding the chart

To data-bind the chart, set its DataSource property to nwindDataSet1 (a variable referencing an instance of the data set we added to the report in Tutorial 1), set DataMember to "Products" and DataFields to "UnitPrice".

Now we can bind even more chart properties to this data source. For example, to display the names of the products along the x-axis, set the XLabelsFields property to "ProductName" and the LabelType property of XAxisSettings to CustomText. To display the actual prices of the products on top of each bar in the chart, set the TopLabelsFields property to "UnitPrice" and TopLabelType to CustomText.

Running the application will have the following result:

3. Binding to a custom query

As is observed from the illustration above, the chart bars are very small due to the large amount of products displayed. One way to partially resolve this problem is to set the PageOrientation property of the page to Landscape. This way the chart will span a larger area and the size of its bars will increase. Another way is to filter the data displayed on the chart with some criteria. To do this we need to create a custom query and a new data adapter in our data set.

Navigate to the nwindDataSet.xsd file in the Solution Explorer window and double-click on it to open the data sat diagram in the environment. Right-click on an empty area in the diagram designer and select the 'Add -> TableAdapter...' command from the context menu.

A new table adapter is created in the data set and the TableAdapter Configuration Wizard is displayed. Ensure that the appropriate connection is selected in the combo box and click 'Next'. On the 'Choose a Command Type' step leave 'Use SQL statements' as selected and click 'Next'. The 'Enter a SQL Statement' step appears.

We have to enter the text of our SQL query in the next step. There are several ways to improve the query creation experience, but we will use a ready-made query text that selects only the products with price less than 20 and sorts them in ascending order.

SQL [image] Copy Code

SELECT ProductName, UnitPrice
FROM Products
WHERE (UnitPrice < 20)
ORDER BY UnitPrice

Click the 'Advanced Options...' and uncheck the 'Generate Insert, Update and Delete statements' check box. Click 'OK' to close the 'Advanced Options' dialog box, then click 'Finish'. The table adapter representing our query is now properly initialized and appears on the diagram.

Select the data table representing the newly created query and press F2 to rename it. Replace "Products1" with "CheapProducts" then press ENTER. The name of the corresponding adapter is changed to "CheapProductsTableAdapter" automatically. Save the data set and close it. Recompile the project.

Now get back to the Report Designer. The data adapter representing the new query is now visible in the Toolbox under the 'Tutorial4 Components' tab. Double-click on it in order to create a new instance of the adapter and add it to the report.

Select the BarChart in the report, navigate to its DataMember property in the Properties window and set its value to "CheapProducts". Since the fields of our query have the same name as those in the original 'Products' table, there is nothing more that needs to be changed.

Finally, go back to the report's constructor and add the following line of code (outlined in bold):

C# [image] Copy Code

public myreport()
{
InitializeComponent();

// Fill the data adapter from the dataset
productsTableAdapter1.Fill(nwindDataSet1.Products);
cheapProductsTableAdapter1.Fill(nwindDataSet1.CheapProducts);
}

Visual Basic [image] Copy Code

Public Sub New()

InitializeComponent()

' Fill the data adapter from the dataset
productsTableAdapter1.Fill(nwindDataSet1.Products)
cheapProductsTableAdapter1.Fill(nwindDataSet1.CheapProducts)

End Sub

Running the application will now display the filtered list of products as illustrated below:


Tutorial 5: Adding a RadarChart to a Report

Tutorial 5: Adding a RadarChart to a Report

This tutorial demonstrates how to use RadarChart elements in a report. The following steps are described in more details below:

  • Prerequisites
  • Creating and setting up a radar chart
  • Binding the chart to a data source
  • Creating a report viewer
  • Running the application

Prerequisites

The tutorial does not have any special prerequisites. However it is assumed that the reader is acquainted with the creation of MindFusion.Reporting applications. For more details on this, check Tutorial 1. Also, the process of adding the data source and binding the chart to it is briefly described. For information on how to perform data-binding in reports, refer to Tutorial 2.

1. Creating and setting up a radar chart

Create a new application ('Tutorial5') and add a single MindFusion.Reporting report to it. Name the report 'RadarChartReport'. Open the report in the Visual Studio Designer and drag and drop a RadarChart element from the Toolbox to the report surface. This will create a new instance of the RadarChart class and add it to the report.

Select the RadarChart element within the designer and open the 'Properties' window. Set the following properties, in no particular order:

  • Set Location to "2mm, 2mm".
  • Set Size to "80mm, 80mm".
  • Set RadarType to Radar3D.
  • Set RadarStyle to Lines.
  • Set SpiderWeb to true.
  • Set Background3D to an Orange color.

Modify the chart's title settings as follows:

  • Set TitleText to "Sales".
  • Set TitleFont to "Arial, 12pt, style=Bold".
  • Set SubTitleText to "Product sales for 1995".
  • Set SubTitleFont to "Arial, 10pt".

To modify the brush and pen of the area drawn by the radar chart, navigate to the ChartBrushes property in the Properties window, select it and click on the '...' button at its right. The 'BrushCollection Editor' dialog appears. Click on the 'Add' button in the toolbar to create a new brush. Select the brush in the property grid below and click the drop-down arrow. In the brush editor click 'Solid' and enter LightSteelBlue for a value of color. The following image illustrates this:

The area pen is specified in a similar manner, only this time edit the ChartPens property. Add a single pen with DarkSlateBlue color, as shown below:

Resize the report page by setting its ContentSize to "180, 100".

2. Binding the chart to a data source

Add the 'Category Sales for 1995' view from the nwind.mdb database to the project. Extensive information on how to add data sources to a project can be found in both Tutorial 1 and Tutorial 2.

After rebuilding the project a new category will be visible in the Toolbox - 'Tutorial5 Components'. This new category contains two items - nwindDataSet and Category_Sales_for_1995TableAdapter. While the designer is active, double-click on any of these items in order to instantiate them. The nwindDataSet1 and category_Sales_for_1995TableAdapter1 are created and added to the report and can now be observed at the bottom side of the report designer.

To bind the radar chart to the newly created data source, set its DataSource to nwindDataSet1 and its DataMember to "Category Sales for 1995". Set the DataField property to the appropriate field in the data table, in this case - "CategorySales".

Set OuterAxisLabelType to CustomText and OuterAxisLabelsField to "CategoryName".

Finally, go to the source code of our report and modify its constructor as following:

C# [image] Copy Code

public RadarChartReport()
{
InitializeComponent();

category_Sales_for_1995TableAdapter1.Fill(nwindDataSet1.Category_Sales_for_1995);
}

Visual Basic [image] Copy Code

Public Sub New()

InitializeComponent()

category_Sales_for_1995TableAdapter1.Fill(nwindDataSet1.Category_Sales_for_1995)

End Sub

3. Creating a report viewer

For more information on how to create a ReportViewer, refer to Tutorial 1. Leave the default name of the newly created viewer - reportViewer1. Create an instance of our report and select it within the report viewer.

C# [image] Copy Code

public Form1()
{
InitializeComponent();

// Create and run the report
RadarChartReport report = new RadarChartReport();
report.Run();

// Select the report in the viewer
reportViewer1.Report = report;
}

Visual Basic [image] Copy Code

Public Sub New()

InitializeComponent()

' Create and run the report
Dim report As New RadarChartReport()
report.Run()

' Select the report in the viewer
reportViewer1.Report = report

End Sub

4. Running the application

The following image illustrates the result when running the application:


Reference

Reference


MindFusion.Charting Namespace

MindFusion.Charting Namespace
Classes Interfaces Structures Delegates Enumerations

Classes

Class | Description
AnnotationRenderer | A SeriesRenderer that draws annotations in its containing plot.
AreaRenderer | A SeriesRenderer that draws each series as an area in its containing plot.
AreaStackRenderer | A SeriesRenderer that draws stacked areas in its containing plot.
Axis | Represents an axis range.
AxisRenderer | A base class for components that render Axis ranges.
BarOverlayRenderer | A SeriesRenderer that draws overlaying bars in its containing plot.
BarOverlayRenderer3D | A SeriesRenderer that draws a row of 3D bars for each series.
BarRenderer | A SeriesRenderer that draws bars in its containing plot.
BarRenderer3D | A SeriesRenderer that draws 3D bars in its containing plot.
BarSeries | Represents one-dimensional series defined by e list of data values and several lists of labels.
BarStackRenderer | A SeriesRenderer that draws stacked bars in its containing plot.
BarStackRenderer3D | A SeriesRenderer that draws stacked 3D bars in its containing plot.
BubbleRenderer | A SeriesRenderer that draws bubbles representing data items in its containing plot.
CandlestickRenderer | A SeriesRenderer that draws candlesticks in its containing plot.
CandlestickSeriesStyle | Defines appearance attributes for candlestick charts.
Converter | Provides capabilities to convert various types to and from strings in a cutlure-independent way.
CurveAreaRenderer | A SeriesRenderer that draws each series as an area with curved boundaries in its containing plot.
CurveAreaStackRenderer | A SeriesRenderer that draws stacked areas in its containing plot.
CurveRenderer | A SeriesRenderer that draws series as a cardinal spline.
DataBoundSeries | Represents a series whose data items are retrieved from a data source.
DateTimeSeries | Represents a series that contains DateTime values as X coordinates and double values as Y coordinates.
FunctionSeries | Represents a series that calculates its values from provided formula.
HitResult | Represents the result of a hit-test operation.
LegendController | Lets users move a legend within the boundaries of its parent Panel.
LegendRenderer | A component that renders chart legend.
LineRenderer | A SeriesRenderer that draws series as polylines.
Margins | Describes rectangular margins.
MarginsConverter | The TypeConverter of the Margins structure.
MixedSeriesStyle | Implements SeriesStyle using mixed per-element and uniform values for attributes.
Pair(T1, T2) | Contains two values.
PanController | Represents a controller that pans its plot's data range.
PerElementSeriesStyle | Implements SeriesStyle using different attributes for each data item.
PerSeriesStyle | Implements SeriesStyle using a different set of attributes for each series, where all elements in a single series have common appearance.
PieRadarRenderer | A SeriesRenderer that draws pie-radars, where data items are represented by circular sectors of equal central angles, and the sector corresponding to a data item has radius proportional to its value.
PieRenderer | A SeriesRenderer that draws pies in its containing plot.
PieSeries | Represents one-dimensional series defined by e list of data values and lists of inner and outer labels, convenient for providing data to PieRenderer.
Plot | The base class for components used to draw chart graphics.
Plot2D | A plot whose series are rendered relatively to a two-dimensional Cartesian coordinate system.
Plot2DController | A base class for controllers that let users interact with Plot2D objects.
Plot3D | A plot whose series are rendered relatively to a three-dimensional Cartesian coordinate system.
PlotController | A base class for controllers implementing user interaction with Plot components.
PointSeries | Represents a data series defined by a list of PointF objects.
PointSeries3D | Represents a data series defined by a list of Point3D objects.
PolarPlot | A plot used to draw graphics in polar coordinate system.
PropertyEventArgs | Provides data for the PropertyValueChanged event.
RadarAxisOptions | Provides properties for customizing axis rendering in radar charts.
RadarPlot | A plot containing radar-chart graphics.
RadarRenderer | A SeriesRenderer that draws series as polygons in polar coordinate system, where adjacent data points are at equal angular distances and radial coordinates correspond to magnitude of data item values.
RadarScatterRenderer | A SeriesRenderer that draws scatter in radar plots.
RenderContext | Provides contextual information about the dashboard to its child components when calling their draw, layout and user input methods.
Renderer2D | A base class for series renderers that draw in two dimensional Cartesian coordinate system.
RotationController | Represents a controller that rotates a polar plot by changing its StartAngle.
ScatterRenderer | A SeriesRenderer that draws scatter in its containing plot.
Series2D | Represents a data series defined by two lists of values containing respectively X and Y coordinates.
Series3D | Represents a data series defined by three lists of values containing respectively X, Y and Z coordinates.
SeriesRenderer | Base class for renderer objects that draw data series inside a Plot.
SimpleSeries | Represents one-dimensional series defined by e list of data values and a list of labels.
StackRenderer | A base SeriesRenderer for stacked graphics.
StepAreaRenderer | A SeriesRenderer that draws series as filled steps between data points.
StepRenderer | A SeriesRenderer that draws series as steps between data points.
StockPrice | Represents a data object, containing open, close, low and high values for a certain date.
StockPriceSeries | Represents a data series defined by a list of StockPrice objects.
TextRenderer | Draws text and labels inside chart components.
TextStyle | Defines text appearance attributes.
Theme | Represents a dashboard's theme defining all appearance attributes of its elements.
ToolTip | Represents current tooltip.
UniformSeriesStyle | Implements SeriesStyle using uniform attributes for all elements in all series.
XAxisRenderer | A Component that renders horizontal Axis ranges.
XmlPersistContext | Contains methods that facilitate serializing and deserializing objects to and from XML documents.
XmlSeries | Represents a series whose data items are retrieved from an XML document.
YAxisRenderer | A Component that renders vertical Axis ranges.
ZoomController | Represents a controller that zooms into plot's data range.

Interfaces

Interface | Description
BarContainer | Defines properties common to all bar-chart renderers.
INotifyPropertyValueChanged | Provides notification for property changes.
Renderer3D | Defines the interface called by Plot3D to build 3D models.
Series | Specifies the interface that data providers should implement in order to feed data to SeriesRenderer classes.
SeriesContainer | Defines an interface for enumerating all series associated with a component of the dashboard.
SeriesStyle | Defines appearance attributes of series elements.

Structures

Structure | Description
Plot2DController.AxisInfo | Stores information about Axis ranges processed by this controller.
Point3D | Represents a point in 3D space.
RectD | Represents a rectangle with double-precision coordinates.
Vector | Represents a two-dimensional vector.

Delegates

Delegate | Description
BarOverlayRenderer.ProcessBars | Defines the signature of delegates called to process bars.
BarRenderer.ProcessBars | Defines the signature of delegates called to process bars.
BarStackRenderer.ProcessStackBars | Defines the signature of delegates called to process stacked bars.
CandlestickRenderer.ProcessCandlesticks | Defines the signature of delegates called to process candlesticks.
FunctionSeries.EvaluateFunction | Defines the signature of methods called to evaluate unknown functions used in the expression.
PieRadarRenderer.ProcessSectors | Defines the signature of delegates called to process sectors generated for a series.
PieRenderer.ProcessSlice | Defines the signature of delegates called to process pie slices.
RadarRenderer.ProcessRange | Defines the signature of delegates called to process all points from current data range at once.
Renderer2D.ProcessPoint | Defines the signature of delegates called to process a data point one element at a time.
Renderer2D.ProcessPoints | Defines the signature of delegates called to process data points in pairs.
Renderer2D.ProcessRange | Defines the signature of delegates called to process all points from current data range at once.
SeriesRenderer.StyleCheck | Defines the signature of filter methods used to find SeriesStyle objects that meet specified criteria.
StackRenderer.ProcessStackPoint | Defines the signature of delegates called to process a data point one element at a time.
StackRenderer.ProcessStackRange | Defines the signature of delegates called to process all points from current data range at once.

Enumerations

Enumeration | Description
BarLayout | Identifies supported bar placements when rendering multiple series.
BubbleLabelAlignment | Specifies the alignment of a label relative to its associated bubble.
DateTimeFormat | Specifies formats for DateTime values
GridType | Indicates Plot2D grid type.
LabelKinds | Identifies the various kinds of labels that can be drawn for data items.
LineType | Identifies how to connect adjacent data points in line and area charts.
RadarGridType | Identifies the grid types supported by RadarPlot.
RadarType | Identifies the type of radar-chart.
ScatterType | Identifies the shapes rendered by a ScatterRenderer.
TextStyleHint | Identifies text styles that can be accessed through RenderContent.


MindFusion.Charting.AnnotationRenderer Class

AnnotationRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws annotations in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class AnnotationRenderer : Renderer2D

Visual Basic [image] Copy Code

Public Class AnnotationRenderer
Inherits Renderer2D

Remarks

AnnotationRenderer must be placed inside a Plot2D component. It draws framed labels at positions in the plot indicated by series' GetValue results. The annotation text to draw corresponds to GetLabel result returned for LabelKinds.InnerLabel.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.AnnotationRenderer

See Also

AnnotationRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.AnnotationRenderer Members

AnnotationRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws annotations in its containing plot.

The following tables list the members exposed by the AnnotationRenderer type.

Public Constructors

Name | Description
AnnotationRenderer | Initializes a new instance of the AnnotationRenderer class.

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

AnnotationRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AnnotationRenderer Constructor

AnnotationRenderer Constructor
See Also
[image]

Initializes a new instance of the AnnotationRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public AnnotationRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as annotations.

See Also

AnnotationRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AnnotationRenderer Methods

AnnotationRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

AnnotationRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AnnotationRenderer.Draw Method

AnnotationRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

AnnotationRenderer Members
AnnotationRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AreaRenderer Class

AreaRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws each series as an area in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class AreaRenderer : Renderer2D

Visual Basic [image] Copy Code

Public Class AreaRenderer
Inherits Renderer2D

Remarks

AreaRenderer must be placed inside a Plot2D component. It draws the values of each series as a filled polygon. If the GetLabel method of Series object returns InnerLabel or OuterLabel strings, they are rendered near the polygon vertex corresponding to respective data item.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.AreaRenderer
MindFusion.Charting.CurveAreaRenderer

See Also

AreaRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.AreaRenderer Members

AreaRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws each series as an area in its containing plot.

The following tables list the members exposed by the AreaRenderer type.

Public Constructors

Name | Description
AreaRenderer | Initializes a new instance of the AreaRenderer class.

Public Properties

Name | Description
AreaOpacity | Gets or sets the opacity of radar polygons.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

AreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AreaRenderer Constructor

AreaRenderer Constructor
[image]

Initializes a new instance of the AreaRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public AreaRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as areas.

See Also

AreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AreaRenderer Methods

AreaRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

AreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AreaRenderer.Draw Method

AreaRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

AreaRenderer Members
AreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AreaRenderer Properties

AreaRenderer Properties
[image]

Public Properties

Name | Description
AreaOpacity | Gets or sets the opacity of radar polygons.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

See Also

AreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AreaRenderer.AreaOpacity Property

AreaRenderer.AreaOpacity Property
[image]

Gets or sets the opacity of radar polygons.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double AreaOpacity { get; set; }

Visual Basic [image] Copy Code

Public Property AreaOpacity As Double

Property Value

See Also

AreaRenderer Members
AreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AreaStackRenderer Class

AreaStackRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws stacked areas in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class AreaStackRenderer : StackRenderer

Visual Basic [image] Copy Code

Public Class AreaStackRenderer
Inherits StackRenderer

Remarks

AreaStackRenderer must be placed inside a Plot2D component. It draws the values of each series as a filled polygon stacked over the one of previous series. If the GetLabel method of Series object returns InnerLabel or OuterLabel strings, they are rendered near the polygon vertex corresponding to respective data item.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.StackRenderer
MindFusion.Charting.AreaStackRenderer

See Also

AreaStackRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.AreaStackRenderer Members

AreaStackRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws stacked areas in its containing plot.

The following tables list the members exposed by the AreaStackRenderer type.

Public Constructors

Name | Description
AreaStackRenderer | Initializes a new instance of the AreaStackRenderer class.

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the stack representations of data items. (Inherited from StackRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
EnumVisibleStackPoints | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from StackRenderer.)
EnumVisibleStackRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from StackRenderer.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Gets the coordinates of specified data item when mapped to a Plot2D pixel. (Inherited from StackRenderer.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from StackRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

AreaStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AreaStackRenderer Constructor

AreaStackRenderer Constructor
[image]

Initializes a new instance of the AreaStackRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public AreaStackRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as stacked areas.

See Also

AreaStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AreaStackRenderer Methods

AreaStackRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the stack representations of data items. (Inherited from StackRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
EnumVisibleStackPoints | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from StackRenderer.)
EnumVisibleStackRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from StackRenderer.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Gets the coordinates of specified data item when mapped to a Plot2D pixel. (Inherited from StackRenderer.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from StackRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

AreaStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AreaStackRenderer.Draw Method

AreaStackRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

AreaStackRenderer Members
AreaStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis Class

Axis Class
[image]

Represents an axis range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class Axis : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class Axis
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.Charting.Axis

See Also

Axis Members
MindFusion.Charting Namespace


MindFusion.Charting.Axis Members

Axis Members
Constructors Properties Methods Events
[image]

Represents an axis range.

The following tables list the members exposed by the Axis type.

Public Constructors

Name | Description
Axis | Initializes a new instance of the Axis class.

Public Properties

Name | Description
Interval | Gets or sets the size of axis intervals.
MaxValue | Gets or sets the largest value displayed on this axis.
MinValue | Gets or sets the smallest value displayed on this axis.
NumberFormat | Gets or sets the number format of coordinate labels.
Title | Gets or sets the axis title.

Public Methods

Name | Description
InRange | Determines whether specified value is within the axis range.
MapValueToPixelX | Maps a value from this axis' coordinate system to a pixel position in specified view.
MapValueToPixelY | Maps a value from this axis' coordinate system to a pixel position in specified view.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

Public Events

Name | Description
PropertyChanged | Implements INotifyPropertyChanged.

See Also

Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis Constructor

Axis Constructor
[image]

Initializes a new instance of the Axis class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Axis ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis Methods

Axis Methods
[image]

Public Methods

Name | Description
InRange | Determines whether specified value is within the axis range.
MapValueToPixelX | Maps a value from this axis' coordinate system to a pixel position in specified view.
MapValueToPixelY | Maps a value from this axis' coordinate system to a pixel position in specified view.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

See Also

Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis.InRange Method

Axis.InRange Method
[image]

Determines whether specified value is within the axis range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool InRange (
double value
)

Visual Basic [image] Copy Code

Public Function InRange( _
value As Double _
) As Boolean

Parameters

value

A double value.

Return Value

true if value is inside the current axis range, or false otherwise.

See Also

Axis Members
Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis.MapValueToPixelX Method

Axis.MapValueToPixelX Method
[image]

Maps a value from this axis' coordinate system to a pixel position in specified view.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double MapValueToPixelX (
double value,
double viewSize
)

Visual Basic [image] Copy Code

Public Function MapValueToPixelX( _
value As Double, _
viewSize As Double _
) As Double

Parameters

value

A double value.

viewSize

The view size.

Return Value

X coordinate of pixel.

See Also

Axis Members
Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis.MapValueToPixelY Method

Axis.MapValueToPixelY Method
[image]

Maps a value from this axis' coordinate system to a pixel position in specified view.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double MapValueToPixelY (
double value,
double viewSize
)

Visual Basic [image] Copy Code

Public Function MapValueToPixelY( _
value As Double, _
viewSize As Double _
) As Double

Parameters

value

A double value.

viewSize

The view size.

Return Value

Y coordinate of pixel.

See Also

Axis Members
Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis.OnPropertyChanged Method

Axis.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
string propertyName
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
propertyName As String _
)

Parameters

propertyName

Specifies the name of changed property.

See Also

Axis Members
Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis Properties

Axis Properties
[image]

Public Properties

Name | Description
Interval | Gets or sets the size of axis intervals.
MaxValue | Gets or sets the largest value displayed on this axis.
MinValue | Gets or sets the smallest value displayed on this axis.
NumberFormat | Gets or sets the number format of coordinate labels.
Title | Gets or sets the axis title.

See Also

Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis.Interval Property

Axis.Interval Property
[image]

Gets or sets the size of axis intervals.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> Interval { get; set; }

Visual Basic [image] Copy Code

Public Property Interval As Nullable(Of Double)

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis.MaxValue Property

Axis.MaxValue Property
[image]

Gets or sets the largest value displayed on this axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> MaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property MaxValue As Nullable(Of Double)

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis.MinValue Property

Axis.MinValue Property
[image]

Gets or sets the smallest value displayed on this axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> MinValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinValue As Nullable(Of Double)

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis.NumberFormat Property

Axis.NumberFormat Property
[image]

Gets or sets the number format of coordinate labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string NumberFormat { get; set; }

Visual Basic [image] Copy Code

Public Property NumberFormat As String

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis.Title Property

Axis.Title Property
[image]

Gets or sets the axis title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis Events

Axis Events
[image]

Public Events

Name | Description
PropertyChanged | Implements INotifyPropertyChanged.

See Also

Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.Axis.PropertyChanged Event

Axis.PropertyChanged Event
[image]

Implements INotifyPropertyChanged.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

Axis Members
Axis Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer Class

AxisRenderer Class
Remarks See Also
[image]

A base class for components that render Axis ranges.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public abstract class AxisRenderer : Component

Visual Basic [image] Copy Code

Public MustInherit Class AxisRenderer
Inherits Component

Remarks

AxisRenderer is not aware of the location of Plot components that display graphics on same Axis, and will not match series coordinates correctly if the plots are not aligned with the AxisRenderer. You can ensure axis renderer and plots are aligned by placing them in same StackPanel, or in same row or column of a GridPanel.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Components.Component
MindFusion.Charting.AxisRenderer
MindFusion.Charting.RadarAxisOptions
MindFusion.Charting.XAxisRenderer
MindFusion.Charting.YAxisRenderer

See Also

AxisRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer Members

AxisRenderer Members
Constructors Properties Methods
[image]

A base class for components that render Axis ranges.

The following tables list the members exposed by the AxisRenderer type.

Protected Constructors

Name | Description
AxisRenderer | Initializes a new instance of the AxisRenderer class.

Public Properties

Name | Description
Axis | The Axis that will be drawn by this object.
AxisStroke | Gets or sets the Brush that should be used to draw axis lines.
AxisStrokeDashStyle | Gets or sets the dash style axis lines should be stroked with.
AxisStrokeThickness | Gets or sets the thickness axis lines should be stroked with.
LabelBrush | Gets or sets the Brush that should be used to draw axis labels.
LabelFontName | Gets or sets the name of font that should be used to draw axis labels.
LabelFontSize | Gets or sets the size of font that should be used to draw axis labels.
LabelFontStyle | Gets or sets the style of font that should be used to draw axis labels.
LabelPadding | Gets or sets the padding space between the axis line and coordinate labels.
LabelsSource | Gets or sets the object whose Series labels should be rendered along this axis.
PinLabels | Gets or sets a value indicating whether coordinate labels should be pinned in place or scroll together with the plot when users pan it.
ShowCoordinates | Gets or sets a value indicating whether this AxisRenderer should draw axis coordinates.
ShowSeriesLabels | Gets or sets a value indicating whether this AxisRenderer should draw data labels.
ShowTicks | Gets or sets a value indicating whether this AxisRenderer should draw axis ticks.
TickLength | Gets or sets the length of the axis ticks.
TitleBrush | Gets or sets the Brush that should be used to draw the axis Title.
TitleFontName | Gets or sets the name of font that should be used to draw the axis Title.
TitleFontSize | Gets or sets the size of font that should be used to draw the axis Title.
TitleFontStyle | Gets or sets the style of font that should be used to draw the axis Title.

Protected Methods

Name | Description
EffectiveAxis | Gets the effective Axis in current context, getting one from Plot2D or chart control if there's no local Axis associated with this renderer.
EffectiveAxisDashStyle | Gets the dash style of axis line strokes.
EffectiveAxisStroke | Gets the Brush that should be used to stroke axis lines.
EffectiveAxisStrokeThickness | Gets the thickness of axis line strokes.
EffectiveLabelBrush | Gets the Brush that should be used to draw axis labels.
EffectiveLabelFont | Gets the Font that should be used to draw axis labels.
EffectivePen | Gets the Pen that should be used to draw axis lines.
EffectiveTitleBrush | Gets the Brush that should be used to draw the axis Title.
EffectiveTitleFont | Gets the Font that should be used to draw the axis Title.

See Also

AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer Constructor

AxisRenderer Constructor
[image]

Initializes a new instance of the AxisRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected AxisRenderer (
Axis axis
)

Visual Basic [image] Copy Code

Protected New ( _
axis As Axis _
)

Parameters

axis

The Axis that will be drawn by this object.

See Also

AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer Methods

AxisRenderer Methods
[image]

Protected Methods

Name | Description
EffectiveAxis | Gets the effective Axis in current context, getting one from Plot2D or chart control if there's no local Axis associated with this renderer.
EffectiveAxisDashStyle | Gets the dash style of axis line strokes.
EffectiveAxisStroke | Gets the Brush that should be used to stroke axis lines.
EffectiveAxisStrokeThickness | Gets the thickness of axis line strokes.
EffectiveLabelBrush | Gets the Brush that should be used to draw axis labels.
EffectiveLabelFont | Gets the Font that should be used to draw axis labels.
EffectivePen | Gets the Pen that should be used to draw axis lines.
EffectiveTitleBrush | Gets the Brush that should be used to draw the axis Title.
EffectiveTitleFont | Gets the Font that should be used to draw the axis Title.

See Also

AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.EffectiveAxis Method

AxisRenderer.EffectiveAxis Method
[image]

Gets the effective Axis in current context, getting one from Plot2D or chart control if there's no local Axis associated with this renderer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected abstract Axis EffectiveAxis (
RenderContext context
)

Visual Basic [image] Copy Code

Protected MustOverride Function EffectiveAxis( _
context As RenderContext _
) As Axis

Parameters

context

A RenderContext instance.

Return Value

An Axis instance.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.EffectiveAxisDashStyle Method

AxisRenderer.EffectiveAxisDashStyle Method
[image]

Gets the dash style of axis line strokes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected DashStyle EffectiveAxisDashStyle (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveAxisDashStyle( _
context As RenderContext _
) As DashStyle

Parameters

context

A RenderContext instance.

Return Value

A member of the DashStyle enumeration.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.EffectiveAxisStroke Method

AxisRenderer.EffectiveAxisStroke Method
[image]

Gets the Brush that should be used to stroke axis lines.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Brush EffectiveAxisStroke (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveAxisStroke( _
context As RenderContext _
) As Brush

Parameters

context

A RenderContext instance.

Return Value

A Brush instance.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.EffectiveAxisStrokeThickness Method

AxisRenderer.EffectiveAxisStrokeThickness Method
[image]

Gets the thickness of axis line strokes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected double EffectiveAxisStrokeThickness (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveAxisStrokeThickness( _
context As RenderContext _
) As Double

Parameters

context

A RenderContext instance.

Return Value

A double value.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.EffectiveLabelBrush Method

AxisRenderer.EffectiveLabelBrush Method
[image]

Gets the Brush that should be used to draw axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Brush EffectiveLabelBrush (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveLabelBrush( _
context As RenderContext _
) As Brush

Parameters

context

A RenderContext instance.

Return Value

A System.Drawing.Brush instance.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.EffectiveLabelFont Method

AxisRenderer.EffectiveLabelFont Method
[image]

Gets the Font that should be used to draw axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Font EffectiveLabelFont (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveLabelFont( _
context As RenderContext _
) As Font

Parameters

context

A RenderContext instance.

Return Value

A System.Drawing.Font instance.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.EffectivePen Method

AxisRenderer.EffectivePen Method
[image]

Gets the Pen that should be used to draw axis lines.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Pen EffectivePen (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectivePen( _
context As RenderContext _
) As Pen

Parameters

context

A RenderContext instance.

Return Value

A System.Drawing.Pen instance.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.EffectiveTitleBrush Method

AxisRenderer.EffectiveTitleBrush Method
[image]

Gets the Brush that should be used to draw the axis Title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Brush EffectiveTitleBrush (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveTitleBrush( _
context As RenderContext _
) As Brush

Parameters

context

A RenderContext instance.

Return Value

A System.Drawing.Brush instance.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.EffectiveTitleFont Method

AxisRenderer.EffectiveTitleFont Method
[image]

Gets the Font that should be used to draw the axis Title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Font EffectiveTitleFont (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveTitleFont( _
context As RenderContext _
) As Font

Parameters

context

A RenderContext instance.

Return Value

A System.Drawing.Font instance.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer Properties

AxisRenderer Properties
[image]

Public Properties

Name | Description
Axis | The Axis that will be drawn by this object.
AxisStroke | Gets or sets the Brush that should be used to draw axis lines.
AxisStrokeDashStyle | Gets or sets the dash style axis lines should be stroked with.
AxisStrokeThickness | Gets or sets the thickness axis lines should be stroked with.
LabelBrush | Gets or sets the Brush that should be used to draw axis labels.
LabelFontName | Gets or sets the name of font that should be used to draw axis labels.
LabelFontSize | Gets or sets the size of font that should be used to draw axis labels.
LabelFontStyle | Gets or sets the style of font that should be used to draw axis labels.
LabelPadding | Gets or sets the padding space between the axis line and coordinate labels.
LabelsSource | Gets or sets the object whose Series labels should be rendered along this axis.
PinLabels | Gets or sets a value indicating whether coordinate labels should be pinned in place or scroll together with the plot when users pan it.
ShowCoordinates | Gets or sets a value indicating whether this AxisRenderer should draw axis coordinates.
ShowSeriesLabels | Gets or sets a value indicating whether this AxisRenderer should draw data labels.
ShowTicks | Gets or sets a value indicating whether this AxisRenderer should draw axis ticks.
TickLength | Gets or sets the length of the axis ticks.
TitleBrush | Gets or sets the Brush that should be used to draw the axis Title.
TitleFontName | Gets or sets the name of font that should be used to draw the axis Title.
TitleFontSize | Gets or sets the size of font that should be used to draw the axis Title.
TitleFontStyle | Gets or sets the style of font that should be used to draw the axis Title.

See Also

AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.Axis Property

AxisRenderer.Axis Property
[image]

The Axis that will be drawn by this object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Axis Axis { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Axis As Axis

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.AxisStroke Property

AxisRenderer.AxisStroke Property
[image]

Gets or sets the Brush that should be used to draw axis lines.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush AxisStroke { get; set; }

Visual Basic [image] Copy Code

Public Property AxisStroke As Brush

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.AxisStrokeDashStyle Property

AxisRenderer.AxisStrokeDashStyle Property
[image]

Gets or sets the dash style axis lines should be stroked with.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<DashStyle> AxisStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property AxisStrokeDashStyle As Nullable(Of DashStyle)

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.AxisStrokeThickness Property

AxisRenderer.AxisStrokeThickness Property
[image]

Gets or sets the thickness axis lines should be stroked with.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> AxisStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property AxisStrokeThickness As Nullable(Of Double)

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.LabelBrush Property

AxisRenderer.LabelBrush Property
[image]

Gets or sets the Brush that should be used to draw axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush LabelBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBrush As Brush

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.LabelFontName Property

AxisRenderer.LabelFontName Property
[image]

Gets or sets the name of font that should be used to draw axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string LabelFontName { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontName As String

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.LabelFontSize Property

AxisRenderer.LabelFontSize Property
[image]

Gets or sets the size of font that should be used to draw axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> LabelFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontSize As Nullable(Of Double)

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.LabelFontStyle Property

AxisRenderer.LabelFontStyle Property
[image]

Gets or sets the style of font that should be used to draw axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<FontStyle> LabelFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontStyle As Nullable(Of FontStyle)

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.LabelPadding Property

AxisRenderer.LabelPadding Property
[image]

Gets or sets the padding space between the axis line and coordinate labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double LabelPadding { get; set; }

Visual Basic [image] Copy Code

Public Property LabelPadding As Double

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.LabelsSource Property

AxisRenderer.LabelsSource Property
[image]

Gets or sets the object whose Series labels should be rendered along this axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public SeriesContainer LabelsSource { get; set; }

Visual Basic [image] Copy Code

Public Property LabelsSource As SeriesContainer

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.PinLabels Property

AxisRenderer.PinLabels Property
[image]

Gets or sets a value indicating whether coordinate labels should be pinned in place or scroll together with the plot when users pan it.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool PinLabels { get; set; }

Visual Basic [image] Copy Code

Public Property PinLabels As Boolean

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.ShowCoordinates Property

AxisRenderer.ShowCoordinates Property
[image]

Gets or sets a value indicating whether this AxisRenderer should draw axis coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool ShowCoordinates { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCoordinates As Boolean

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.ShowSeriesLabels Property

AxisRenderer.ShowSeriesLabels Property
[image]

Gets or sets a value indicating whether this AxisRenderer should draw data labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool ShowSeriesLabels { get; set; }

Visual Basic [image] Copy Code

Public Property ShowSeriesLabels As Boolean

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.ShowTicks Property

AxisRenderer.ShowTicks Property
[image]

Gets or sets a value indicating whether this AxisRenderer should draw axis ticks.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool ShowTicks { get; set; }

Visual Basic [image] Copy Code

Public Property ShowTicks As Boolean

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.TickLength Property

AxisRenderer.TickLength Property
[image]

Gets or sets the length of the axis ticks.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double TickLength { get; set; }

Visual Basic [image] Copy Code

Public Property TickLength As Double

Property Value

A double value specifying the length of axis ticks. The default value is 5.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.TitleBrush Property

AxisRenderer.TitleBrush Property
[image]

Gets or sets the Brush that should be used to draw the axis Title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush TitleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TitleBrush As Brush

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.TitleFontName Property

AxisRenderer.TitleFontName Property
[image]

Gets or sets the name of font that should be used to draw the axis Title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string TitleFontName { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontName As String

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.TitleFontSize Property

AxisRenderer.TitleFontSize Property
[image]

Gets or sets the size of font that should be used to draw the axis Title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> TitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontSize As Nullable(Of Double)

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.AxisRenderer.TitleFontStyle Property

AxisRenderer.TitleFontStyle Property
[image]

Gets or sets the style of font that should be used to draw the axis Title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<FontStyle> TitleFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontStyle As Nullable(Of FontStyle)

Property Value

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarContainer Interface

BarContainer Interface
[image]

Defines properties common to all bar-chart renderers.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public interface BarContainer

Visual Basic [image] Copy Code

Public Interface BarContainer

Inheritors

MindFusion.Charting.BarOverlayRenderer
MindFusion.Charting.BarRenderer
MindFusion.Charting.BarStackRenderer

See Also

BarContainer Members
MindFusion.Charting Namespace


MindFusion.Charting.BarContainer Members

BarContainer Members
Properties
[image]

Defines properties common to all bar-chart renderers.

The following tables list the members exposed by the BarContainer type.

Public Properties

Name | Description
BarSpacingRatio | Gets or sets the ratio of empty space between bars to space occupied by bars.
HorizontalBars | Gets or sets a value identifying whether bars should be horizontal.

See Also

BarContainer Interface
MindFusion.Charting Namespace


MindFusion.Charting.BarContainer Properties

BarContainer Properties
[image]

Public Properties

Name | Description
BarSpacingRatio | Gets or sets the ratio of empty space between bars to space occupied by bars.
HorizontalBars | Gets or sets a value identifying whether bars should be horizontal.

See Also

BarContainer Interface
MindFusion.Charting Namespace


MindFusion.Charting.BarContainer.BarSpacingRatio Property

BarContainer.BarSpacingRatio Property
[image]

Gets or sets the ratio of empty space between bars to space occupied by bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

double BarSpacingRatio { get; set; }

Visual Basic [image] Copy Code

Property BarSpacingRatio As Double

Property Value

See Also

BarContainer Members
BarContainer Interface
MindFusion.Charting Namespace


MindFusion.Charting.BarContainer.HorizontalBars Property

BarContainer.HorizontalBars Property
[image]

Gets or sets a value identifying whether bars should be horizontal.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

bool HorizontalBars { get; set; }

Visual Basic [image] Copy Code

Property HorizontalBars As Boolean

Property Value

See Also

BarContainer Members
BarContainer Interface
MindFusion.Charting Namespace


MindFusion.Charting.BarLayout Enumeration

BarLayout Enumeration
[image]

Identifies supported bar placements when rendering multiple series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public enum BarLayout

Visual Basic [image] Copy Code

Public Enum BarLayout

Members

Member name | Description
Overlay | Render elements at same index from all series as overlaid bars.
SideBySide | Render elements at same index from all series as a group of side-by-side bars.
Stack | Render elements at same index from all series as stacked bars.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer Class

BarOverlayRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws overlaying bars in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class BarOverlayRenderer : Renderer2D, BarContainer

Visual Basic [image] Copy Code

Public Class BarOverlayRenderer
Inherits Renderer2D
Implements BarContainer

Remarks

BarOverlayRenderer must be placed inside a Plot2D component. It draws each data item as a bar, and if there are more than one series provided, groups of data elements at same index are drawn as overlaying bars. If the GetLabel method of Series object returns InnerLabel string, it is drawn inside its corresponding bar, so inner labels are only useful for the first series drawn. If GetLabel returns OuterLabel string, it is draw at top side of the bar.

Bar renderers can work with either one- or two- dimensional data series. If series' Dimensions property returns 1, the data values are used to calculate the height of bars. If Dimensions returns 2, values from first dimension are used to calculate positions of bars, and values from second dimension are used to calculate heights. If a bar renderer contains more than one series, positions of bar groups are determined only by GetValue results of first series.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.BarOverlayRenderer
MindFusion.Charting.BarOverlayRenderer3D

See Also

BarOverlayRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer Members

BarOverlayRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws overlaying bars in its containing plot.

The following tables list the members exposed by the BarOverlayRenderer type.

Public Constructors

Name | Description
BarOverlayRenderer | Initializes a new instance of the BarOverlayRenderer class.

Public Properties

Name | Description
BarSpacingRatio | Gets or sets the ratio of empty space between adjacent bar groups to space occupied by bars.
HorizontalBars | Gets or sets a value identifying whether bars should be horizontal.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the bar representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | SeriesRenderer.AdjustDataRange override. Adjusts the data range of associated Axis objects after initial measure pass.
BackToFrontRatio | Gets the ratio between widths of backmost and frontmost bars.
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisibleOverlays | Enumerates the bars visible in current data range.
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

BarOverlayRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer Constructor

BarOverlayRenderer Constructor
[image]

Initializes a new instance of the BarOverlayRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public BarOverlayRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as overlaying bars.

See Also

BarOverlayRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer Methods

BarOverlayRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the bar representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | SeriesRenderer.AdjustDataRange override. Adjusts the data range of associated Axis objects after initial measure pass.
BackToFrontRatio | Gets the ratio between widths of backmost and frontmost bars.
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisibleOverlays | Enumerates the bars visible in current data range.
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

BarOverlayRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer.AdjustDataRange Method

BarOverlayRenderer.AdjustDataRange Method
[image]

SeriesRenderer.AdjustDataRange override. Adjusts the data range of associated Axis objects after initial measure pass.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void AdjustDataRange (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub AdjustDataRange( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

BarOverlayRenderer Members
BarOverlayRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer.BackToFrontRatio Method

BarOverlayRenderer.BackToFrontRatio Method
[image]

Gets the ratio between widths of backmost and frontmost bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual float BackToFrontRatio ()

Visual Basic [image] Copy Code

Protected Overridable Function BackToFrontRatio () As Single

Return Value

3

See Also

BarOverlayRenderer Members
BarOverlayRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer.Draw Method

BarOverlayRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

BarOverlayRenderer Members
BarOverlayRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer.DrawHighlight Method

BarOverlayRenderer.DrawHighlight Method
[image]

Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void DrawHighlight (
RenderContext context,
HitResult hitResult
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawHighlight( _
context As RenderContext, _
hitResult As HitResult _
)

Parameters

context

A RenderContext instance.

hitResult

A HitResult instance identifying highlighted data item.

See Also

BarOverlayRenderer Members
BarOverlayRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer.EnumVisibleOverlays Method

BarOverlayRenderer.EnumVisibleOverlays Method
[image]

Enumerates the bars visible in current data range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void EnumVisibleOverlays (
RenderContext context,
bool frontToBack,
BarOverlayRenderer.ProcessBars process
)

Visual Basic [image] Copy Code

Protected Sub EnumVisibleOverlays( _
context As RenderContext, _
frontToBack As Boolean, _
process As BarOverlayRenderer.ProcessBars _
)

Parameters

context

A RenderContext instance.

frontToBack

true to enumerate from front bar to back bar, or false otherwise.

process

A ProcessBars callback.

See Also

BarOverlayRenderer Members
BarOverlayRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer.HitTest Method

BarOverlayRenderer.HitTest Method
[image]

Renderer2D.HitTest override. Hit-tests the bar representations of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override HitResult HitTest (
RenderContext context,
PointD location
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
context As RenderContext, _
location As PointD _
) As HitResult

Parameters

context

A RenderContext instance.

location

A PointD specifying where to look for a bar.

Return Value

A HitResult instance identifying the found data item.

See Also

BarOverlayRenderer Members
BarOverlayRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer.MeasureDataRange Method

BarOverlayRenderer.MeasureDataRange Method
[image]

Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void MeasureDataRange (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub MeasureDataRange( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

BarOverlayRenderer Members
BarOverlayRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer Properties

BarOverlayRenderer Properties
[image]

Public Properties

Name | Description
BarSpacingRatio | Gets or sets the ratio of empty space between adjacent bar groups to space occupied by bars.
HorizontalBars | Gets or sets a value identifying whether bars should be horizontal.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

See Also

BarOverlayRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer.BarSpacingRatio Property

BarOverlayRenderer.BarSpacingRatio Property
[image]

Gets or sets the ratio of empty space between adjacent bar groups to space occupied by bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double BarSpacingRatio { get; set; }

Visual Basic [image] Copy Code

Public Property BarSpacingRatio As Double

Property Value

See Also

BarOverlayRenderer Members
BarOverlayRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer.HorizontalBars Property

BarOverlayRenderer.HorizontalBars Property
[image]

Gets or sets a value identifying whether bars should be horizontal.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool HorizontalBars { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalBars As Boolean

Property Value

See Also

BarOverlayRenderer Members
BarOverlayRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer.ProcessBars Delegate

BarOverlayRenderer.ProcessBars Delegate
[image]

Defines the signature of delegates called to process bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected delegate void BarOverlayRenderer.ProcessBars (
int seriesIndex,
int dataIndex,
RectangleF bounds
)

Visual Basic [image] Copy Code

Protected Delegate Sub BarOverlayRenderer.ProcessBars( _
seriesIndex As Integer, _
dataIndex As Integer, _
bounds As RectangleF _
)

Parameters

seriesIndex

An integer index of series in Series list.

dataIndex

An integer index of data item in specified series.

bounds

A RectangleF representing the boundaries of current bar.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer3D Class

BarOverlayRenderer3D Class
Remarks See Also
[image]

A SeriesRenderer that draws a row of 3D bars for each series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class BarOverlayRenderer3D : BarOverlayRenderer, Renderer3D

Visual Basic [image] Copy Code

Public Class BarOverlayRenderer3D
Inherits BarOverlayRenderer
Implements Renderer3D

Remarks

BarOverlayRenderer3D must be placed inside a Plot3D component. It draws each series as a row of 3D bars, where subsequent series are placed further away from the viewer. If the GetLabel method of Series object returns InnerLabel string, it is drawn inside its corresponding bar, so inner labels are only useful for the first series drawn. If GetLabel returns OuterLabel string, it is draw at top side of the bar.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.BarOverlayRenderer
MindFusion.Charting.BarOverlayRenderer3D

See Also

BarOverlayRenderer3D Members
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer3D Members

BarOverlayRenderer3D Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws a row of 3D bars for each series.

The following tables list the members exposed by the BarOverlayRenderer3D type.

Public Constructors

Name | Description
BarOverlayRenderer3D | Initializes a new instance of the BarOverlayRenderer3D class.

Public Properties

Name | Description
BarSpacingRatio | Gets or sets the ratio of empty space between adjacent bar groups to space occupied by bars. (Inherited from BarOverlayRenderer.)
HorizontalBars | Gets or sets a value identifying whether bars should be horizontal. (Inherited from BarOverlayRenderer.)
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
BuildModels | Implements Renderer3D.BuildModels. Adds 3D bar models for the series data to specified scene.
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the bar representations of data items. (Inherited from BarOverlayRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | SeriesRenderer.AdjustDataRange override. Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from BarOverlayRenderer.)
BackToFrontRatio | BarOverlayRenderer.BackToFrontRatio override. Gets the ratio between widths of backmost and frontmost bars.
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext. (Inherited from BarOverlayRenderer.)
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext. (Inherited from BarOverlayRenderer.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisibleOverlays | Enumerates the bars visible in current data range. (Inherited from BarOverlayRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from BarOverlayRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

BarOverlayRenderer3D Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer3D Constructor

BarOverlayRenderer3D Constructor
[image]

Initializes a new instance of the BarOverlayRenderer3D class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public BarOverlayRenderer3D (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as rows of bars.

See Also

BarOverlayRenderer3D Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer3D Methods

BarOverlayRenderer3D Methods
[image]

Public Methods

Name | Description
BuildModels | Implements Renderer3D.BuildModels. Adds 3D bar models for the series data to specified scene.
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the bar representations of data items. (Inherited from BarOverlayRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | SeriesRenderer.AdjustDataRange override. Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from BarOverlayRenderer.)
BackToFrontRatio | BarOverlayRenderer.BackToFrontRatio override. Gets the ratio between widths of backmost and frontmost bars.
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext. (Inherited from BarOverlayRenderer.)
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext. (Inherited from BarOverlayRenderer.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisibleOverlays | Enumerates the bars visible in current data range. (Inherited from BarOverlayRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from BarOverlayRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

BarOverlayRenderer3D Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer3D.BackToFrontRatio Method

BarOverlayRenderer3D.BackToFrontRatio Method
[image]

BarOverlayRenderer.BackToFrontRatio override. Gets the ratio between widths of backmost and frontmost bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override float BackToFrontRatio ()

Visual Basic [image] Copy Code

Protected Overrides Function BackToFrontRatio () As Single

Return Value

1

See Also

BarOverlayRenderer3D Members
BarOverlayRenderer3D Class
MindFusion.Charting Namespace


MindFusion.Charting.BarOverlayRenderer3D.BuildModels Method

BarOverlayRenderer3D.BuildModels Method
[image]

Implements Renderer3D.BuildModels. Adds 3D bar models for the series data to specified scene.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual void BuildModels (
Scene3D scene,
RenderContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub BuildModels( _
scene As Scene3D, _
context As RenderContext _
)

Parameters

scene

A Scene3D instance.

context

A RenderContext instance.

See Also

BarOverlayRenderer3D Members
BarOverlayRenderer3D Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer Class

BarRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws bars in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class BarRenderer : Renderer2D, BarContainer

Visual Basic [image] Copy Code

Public Class BarRenderer
Inherits Renderer2D
Implements BarContainer

Remarks

BarRenderer must be placed inside a Plot2D component. It draws each data item as a bar, and if there are more than one series provided, groups of data elements at same index are drawn as group of bars centered around items' coordinates. If the GetLabel method of Series object returns InnerLabel or OuterLabel strings, they are drawn respectively inside or above their corresponding bar.

Bar renderers can work with either one- or two- dimensional data series. If series' Dimensions property returns 1, the data values are used to calculate the height of bars. If Dimensions returns 2, values from first dimension are used to calculate positions of bars, and values from second dimension are used to calculate heights. If a bar renderer contains more than one series, positions of bar groups are determined only by GetValue results of first series.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.BarRenderer
MindFusion.Charting.BarRenderer3D

See Also

BarRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer Members

BarRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws bars in its containing plot.

The following tables list the members exposed by the BarRenderer type.

Public Constructors

Name | Description
BarRenderer | Initializes a new instance of the BarRenderer class.

Public Properties

Name | Description
BarSpacingRatio | Gets or sets the ratio of empty space between adjacent bar groups to space occupied by bars.
HorizontalBars | Gets or sets a value identifying whether bars should be horizontal.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
SameIndexSpacingRatio | Gets or sets the ratio of empty space to occupied space in bar groups drawn for data items as same index in each series.
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the bar representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | SeriesRenderer.AdjustDataRange override. Adjusts the data range of associated Axis objects after initial measure pass.
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisibleBars | Enumerates the bars visible in current data range.
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

BarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer Constructor

BarRenderer Constructor
[image]

Initializes a new instance of the BarRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public BarRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as bars.

See Also

BarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer Methods

BarRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the bar representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | SeriesRenderer.AdjustDataRange override. Adjusts the data range of associated Axis objects after initial measure pass.
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisibleBars | Enumerates the bars visible in current data range.
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

BarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer.AdjustDataRange Method

BarRenderer.AdjustDataRange Method
[image]

SeriesRenderer.AdjustDataRange override. Adjusts the data range of associated Axis objects after initial measure pass.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void AdjustDataRange (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub AdjustDataRange( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

BarRenderer Members
BarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer.Draw Method

BarRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

BarRenderer Members
BarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer.DrawHighlight Method

BarRenderer.DrawHighlight Method
[image]

Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void DrawHighlight (
RenderContext context,
HitResult hitResult
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawHighlight( _
context As RenderContext, _
hitResult As HitResult _
)

Parameters

context

A RenderContext instance.

hitResult

A HitResult instance identifying highlighted data item.

See Also

BarRenderer Members
BarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer.EnumVisibleBars Method

BarRenderer.EnumVisibleBars Method
[image]

Enumerates the bars visible in current data range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void EnumVisibleBars (
RenderContext context,
BarRenderer.ProcessBars process
)

Visual Basic [image] Copy Code

Protected Sub EnumVisibleBars( _
context As RenderContext, _
process As BarRenderer.ProcessBars _
)

Parameters

context

A RenderContext instance.

process

A ProcessBars callback.

See Also

BarRenderer Members
BarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer.HitTest Method

BarRenderer.HitTest Method
[image]

Renderer2D.HitTest override. Hit-tests the bar representations of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override HitResult HitTest (
RenderContext context,
PointD location
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
context As RenderContext, _
location As PointD _
) As HitResult

Parameters

context

A RenderContext instance.

location

A PointD specifying where to look for a bar.

Return Value

A HitResult instance identifying the found data item.

See Also

BarRenderer Members
BarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer.MeasureDataRange Method

BarRenderer.MeasureDataRange Method
[image]

Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void MeasureDataRange (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub MeasureDataRange( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

BarRenderer Members
BarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer Properties

BarRenderer Properties
[image]

Public Properties

Name | Description
BarSpacingRatio | Gets or sets the ratio of empty space between adjacent bar groups to space occupied by bars.
HorizontalBars | Gets or sets a value identifying whether bars should be horizontal.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
SameIndexSpacingRatio | Gets or sets the ratio of empty space to occupied space in bar groups drawn for data items as same index in each series.
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

See Also

BarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer.BarSpacingRatio Property

BarRenderer.BarSpacingRatio Property
[image]

Gets or sets the ratio of empty space between adjacent bar groups to space occupied by bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double BarSpacingRatio { get; set; }

Visual Basic [image] Copy Code

Public Property BarSpacingRatio As Double

Property Value

See Also

BarRenderer Members
BarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer.HorizontalBars Property

BarRenderer.HorizontalBars Property
[image]

Gets or sets a value identifying whether bars should be horizontal.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool HorizontalBars { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalBars As Boolean

Property Value

See Also

BarRenderer Members
BarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer.SameIndexSpacingRatio Property

BarRenderer.SameIndexSpacingRatio Property
[image]

Gets or sets the ratio of empty space to occupied space in bar groups drawn for data items as same index in each series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double SameIndexSpacingRatio { get; set; }

Visual Basic [image] Copy Code

Public Property SameIndexSpacingRatio As Double

Property Value

See Also

BarRenderer Members
BarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer.ProcessBars Delegate

BarRenderer.ProcessBars Delegate
[image]

Defines the signature of delegates called to process bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected delegate void BarRenderer.ProcessBars (
int seriesIndex,
int dataIndex,
RectangleF bounds
)

Visual Basic [image] Copy Code

Protected Delegate Sub BarRenderer.ProcessBars( _
seriesIndex As Integer, _
dataIndex As Integer, _
bounds As RectangleF _
)

Parameters

seriesIndex

An integer index of series in Series list.

dataIndex

An integer index of data item in specified series.

bounds

A RectangleF representing the boundaries of current bar.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer3D Class

BarRenderer3D Class
Remarks See Also
[image]

A SeriesRenderer that draws 3D bars in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class BarRenderer3D : BarRenderer, Renderer3D

Visual Basic [image] Copy Code

Public Class BarRenderer3D
Inherits BarRenderer
Implements Renderer3D

Remarks

BarRenderer3D must be placed inside a Plot3D component. It draws each data item as a 3D bar, and if there are more than one series provided, groups of data elements at same index are drawn as group of bars centered around items' coordinates. If the GetLabel method of Series object returns InnerLabel or OuterLabel strings, they are drawn respectively inside or above their corresponding bar.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.BarRenderer
MindFusion.Charting.BarRenderer3D

See Also

BarRenderer3D Members
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer3D Members

BarRenderer3D Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws 3D bars in its containing plot.

The following tables list the members exposed by the BarRenderer3D type.

Public Constructors

Name | Description
BarRenderer3D | Initializes a new instance of the BarRenderer3D class.

Public Properties

Name | Description
BarSpacingRatio | Gets or sets the ratio of empty space between adjacent bar groups to space occupied by bars. (Inherited from BarRenderer.)
HorizontalBars | Gets or sets a value identifying whether bars should be horizontal. (Inherited from BarRenderer.)
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
SameIndexSpacingRatio | Gets or sets the ratio of empty space to occupied space in bar groups drawn for data items as same index in each series. (Inherited from BarRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
BuildModels | Implements Renderer3D.BuildModels. Adds 3D bar models for the series data to specified scene.
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the bar representations of data items. (Inherited from BarRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | SeriesRenderer.AdjustDataRange override. Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from BarRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext. (Inherited from BarRenderer.)
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext. (Inherited from BarRenderer.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisibleBars | Enumerates the bars visible in current data range. (Inherited from BarRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from BarRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

BarRenderer3D Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer3D Constructor

BarRenderer3D Constructor
[image]

Initializes a new instance of the BarRenderer3D class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public BarRenderer3D (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as 3D bars.

See Also

BarRenderer3D Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer3D Methods

BarRenderer3D Methods
[image]

Public Methods

Name | Description
BuildModels | Implements Renderer3D.BuildModels. Adds 3D bar models for the series data to specified scene.
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the bar representations of data items. (Inherited from BarRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | SeriesRenderer.AdjustDataRange override. Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from BarRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext. (Inherited from BarRenderer.)
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext. (Inherited from BarRenderer.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisibleBars | Enumerates the bars visible in current data range. (Inherited from BarRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from BarRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

BarRenderer3D Class
MindFusion.Charting Namespace


MindFusion.Charting.BarRenderer3D.BuildModels Method

BarRenderer3D.BuildModels Method
[image]

Implements Renderer3D.BuildModels. Adds 3D bar models for the series data to specified scene.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual void BuildModels (
Scene3D scene,
RenderContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub BuildModels( _
scene As Scene3D, _
context As RenderContext _
)

Parameters

scene

A Scene3D instance.

context

A RenderContext instance.

See Also

BarRenderer3D Members
BarRenderer3D Class
MindFusion.Charting Namespace


MindFusion.Charting.BarSeries Class

BarSeries Class
[image]

Represents one-dimensional series defined by e list of data values and several lists of labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class BarSeries : SimpleSeries

Visual Basic [image] Copy Code

Public Class BarSeries
Inherits SimpleSeries

Inheritance Hierarchy

System.Object
MindFusion.Charting.SimpleSeries
MindFusion.Charting.BarSeries

See Also

BarSeries Members
MindFusion.Charting Namespace


MindFusion.Charting.BarSeries Members

BarSeries Members
Constructors Fields Properties Methods Events
[image]

Represents one-dimensional series defined by e list of data values and several lists of labels.

The following tables list the members exposed by the BarSeries type.

Public Constructors

Name | Description
BarSeries | Overloaded.

Protected Fields

Name | Description
emphasizedIndices | Contains the indices of emphasized data items. (Inherited from SimpleSeries.)
labels | Contains the labels of data items. (Inherited from SimpleSeries.)

Public Properties

Name | Description
Data | Gets or sets the data values contained in this series. (Inherited from SimpleSeries.)
Dimensions | Implements Series.Dimensions. Returns 1. (Inherited from SimpleSeries.)
InnerLabels | Gets or sets the inner labels.
Size | Implements Series.Size. Returns the number of elements in Data list. (Inherited from SimpleSeries.)
SupportedLabels | SimpleSeries.SupportedLabels override. Returns a combination of InnerLabel, OuterLabel and XAxisLabel.
Title | Implements Series.Title. Gets or sets the title of this series. (Inherited from SimpleSeries.)
TopLabels | Gets or sets the top labels.
XAxisLabels | Gets or sets the X axis labels.

Public Methods

Name | Description
GetLabel | SimpleSeries.GetLabel override. Returns an element of a labels list.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in this series. (Inherited from SimpleSeries.)
IsEmphasized | Implements Series.IsEmphasized. Gets a value indicating whether the specified data item should be emphasized by the SeriesRenderer. (Inherited from SimpleSeries.)
IsSorted | Implements Series.IsSorted. SimpleSeries always returns false. (Inherited from SimpleSeries.)

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event. (Inherited from SimpleSeries.)

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change. (Inherited from SimpleSeries.)

See Also

BarSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.BarSeries Constructor

BarSeries Constructor
[image]

Overload List

Name | Description
BarSeries (IList(Double), IList(String), IList(String)) | Initializes a new instance of the BarSeries class.
BarSeries (IList(Double), IList(String), IList(String), IList(String)) | Initializes a new instance of the BarSeries class.

See Also

BarSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.BarSeries Constructor (IList(Double), IList(String), IList(String))

BarSeries Constructor (IList(Double), IList(String), IList(String))
See Also
[image]

Initializes a new instance of the BarSeries class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public BarSeries (
IList<Double> values,
IList<string> innerLabels,
IList<string> topLabels
)

Visual Basic [image] Copy Code

Public New ( _
values As IList(Of Double), _
innerLabels As IList(Of String), _
topLabels As IList(Of String) _
)

Parameters

values

A list of data values.

innerLabels

A list of inner labels.

topLabels

A list of top labels.

See Also

BarSeries Constructor Overload List
BarSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.BarSeries Constructor (IList(Double), IList(String), IList(String), IList(String))

BarSeries Constructor (IList(Double), IList(String), IList(String), IList(String))
See Also
[image]

Initializes a new instance of the BarSeries class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public BarSeries (
IList<Double> values,
IList<string> innerLabels,
IList<string> topLabels,
IList<string> xAxisLabels
)

Visual Basic [image] Copy Code

Public New ( _
values As IList(Of Double), _
innerLabels As IList(Of String), _
topLabels As IList(Of String), _
xAxisLabels As IList(Of String) _
)

Parameters

values

A list of data values.

innerLabels

A list of inner labels.

topLabels

A list of top labels.

xAxisLabels

A list of X axis labels.

See Also

BarSeries Constructor Overload List
BarSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.BarSeries Methods

BarSeries Methods
[image]

Public Methods

Name | Description
GetLabel | SimpleSeries.GetLabel override. Returns an element of a labels list.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in this series. (Inherited from SimpleSeries.)
IsEmphasized | Implements Series.IsEmphasized. Gets a value indicating whether the specified data item should be emphasized by the SeriesRenderer. (Inherited from SimpleSeries.)
IsSorted | Implements Series.IsSorted. SimpleSeries always returns false. (Inherited from SimpleSeries.)

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event. (Inherited from SimpleSeries.)

See Also

BarSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.BarSeries.GetLabel Method

BarSeries.GetLabel Method
[image]

SimpleSeries.GetLabel override. Returns an element of a labels list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override string GetLabel (
int index,
LabelKinds kind
)

Visual Basic [image] Copy Code

Public Overrides Function GetLabel( _
index As Integer, _
kind As LabelKinds _
) As String

Parameters

index

An integer value specifying the index of a data item.

kind

A member of the LabelKinds enumeration.

Return Value

A string containing the item's label.

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.BarSeries Properties

BarSeries Properties
[image]

Public Properties

Name | Description
Data | Gets or sets the data values contained in this series. (Inherited from SimpleSeries.)
Dimensions | Implements Series.Dimensions. Returns 1. (Inherited from SimpleSeries.)
InnerLabels | Gets or sets the inner labels.
Size | Implements Series.Size. Returns the number of elements in Data list. (Inherited from SimpleSeries.)
SupportedLabels | SimpleSeries.SupportedLabels override. Returns a combination of InnerLabel, OuterLabel and XAxisLabel.
Title | Implements Series.Title. Gets or sets the title of this series. (Inherited from SimpleSeries.)
TopLabels | Gets or sets the top labels.
XAxisLabels | Gets or sets the X axis labels.

See Also

BarSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.BarSeries.InnerLabels Property

BarSeries.InnerLabels Property
[image]

Gets or sets the inner labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<string> InnerLabels { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabels As IList(Of String)

Property Value

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.BarSeries.SupportedLabels Property

BarSeries.SupportedLabels Property
[image]

SimpleSeries.SupportedLabels override. Returns a combination of InnerLabel, OuterLabel and XAxisLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override LabelKinds SupportedLabels { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedLabels As LabelKinds

Property Value

A combination of LabelKinds flags.

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.BarSeries.TopLabels Property

BarSeries.TopLabels Property
[image]

Gets or sets the top labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<string> TopLabels { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabels As IList(Of String)

Property Value

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.BarSeries.XAxisLabels Property

BarSeries.XAxisLabels Property
[image]

Gets or sets the X axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<string> XAxisLabels { get; set; }

Visual Basic [image] Copy Code

Public Property XAxisLabels As IList(Of String)

Property Value

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer Class

BarStackRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws stacked bars in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class BarStackRenderer : StackRenderer, BarContainer

Visual Basic [image] Copy Code

Public Class BarStackRenderer
Inherits StackRenderer
Implements BarContainer

Remarks

BarStackRenderer must be placed inside a Plot2D component. It draws each data item as a bar, and if there are more than one series provided, the bar is stacked over the one drawn for previous series. If the GetLabel method of Series object returns InnerLabel string, it is drawn inside its corresponding bar. If GetLabel returns OuterLabel string, it is drawn to the right side of the bar.

Bar renderers can work with either one- or two- dimensional data series. If series' Dimensions property returns 1, the data values are used to calculate the height of bars. If Dimensions returns 2, values from first dimension are used to calculate positions of bars, and values from second dimension are used to calculate heights. If a bar renderer contains more than one series, positions of bar stacks are determined only by GetValue results of first series.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.StackRenderer
MindFusion.Charting.BarStackRenderer
MindFusion.Charting.BarStackRenderer3D

See Also

BarStackRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer Members

BarStackRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws stacked bars in its containing plot.

The following tables list the members exposed by the BarStackRenderer type.

Public Constructors

Name | Description
BarStackRenderer | Initializes a new instance of the BarStackRenderer class.

Public Properties

Name | Description
BarSpacingRatio | Gets or sets the ratio of empty space between adjacent bar groups to space occupied by bars.
HorizontalBars | Gets or sets a value identifying whether bars should be horizontal.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | StackRenderer.HitTest override. Hit-tests the bar representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
EnumVisibleStackBars | Enumerates the bars visible in current data range.
EnumVisibleStackPoints | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from StackRenderer.)
EnumVisibleStackRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from StackRenderer.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Gets the coordinates of specified data item when mapped to a Plot2D pixel. (Inherited from StackRenderer.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | StackRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

BarStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer Constructor

BarStackRenderer Constructor
[image]

Initializes a new instance of the BarStackRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public BarStackRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as stacked bars.

See Also

BarStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer Methods

BarStackRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | StackRenderer.HitTest override. Hit-tests the bar representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
EnumVisibleStackBars | Enumerates the bars visible in current data range.
EnumVisibleStackPoints | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from StackRenderer.)
EnumVisibleStackRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from StackRenderer.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Gets the coordinates of specified data item when mapped to a Plot2D pixel. (Inherited from StackRenderer.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | StackRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

BarStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer.Draw Method

BarStackRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

BarStackRenderer Members
BarStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer.DrawHighlight Method

BarStackRenderer.DrawHighlight Method
[image]

Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void DrawHighlight (
RenderContext context,
HitResult hitResult
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawHighlight( _
context As RenderContext, _
hitResult As HitResult _
)

Parameters

context

A RenderContext instance.

hitResult

A HitResult instance identifying highlighted data item.

See Also

BarStackRenderer Members
BarStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer.EnumVisibleStackBars Method

BarStackRenderer.EnumVisibleStackBars Method
[image]

Enumerates the bars visible in current data range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void EnumVisibleStackBars (
RenderContext context,
BarStackRenderer.ProcessStackBars process
)

Visual Basic [image] Copy Code

Protected Sub EnumVisibleStackBars( _
context As RenderContext, _
process As BarStackRenderer.ProcessStackBars _
)

Parameters

context

A RenderContext instance.

process

A ProcessStackBars callback.

See Also

BarStackRenderer Members
BarStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer.HitTest Method

BarStackRenderer.HitTest Method
[image]

StackRenderer.HitTest override. Hit-tests the bar representations of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override HitResult HitTest (
RenderContext context,
PointD location
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
context As RenderContext, _
location As PointD _
) As HitResult

Parameters

context

A RenderContext instance.

location

A PointD specifying where to look for a bar.

Return Value

A HitResult instance identifying the found data item.

See Also

BarStackRenderer Members
BarStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer.MeasureDataRange Method

BarStackRenderer.MeasureDataRange Method
[image]

StackRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void MeasureDataRange (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub MeasureDataRange( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

BarStackRenderer Members
BarStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer Properties

BarStackRenderer Properties
[image]

Public Properties

Name | Description
BarSpacingRatio | Gets or sets the ratio of empty space between adjacent bar groups to space occupied by bars.
HorizontalBars | Gets or sets a value identifying whether bars should be horizontal.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

See Also

BarStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer.BarSpacingRatio Property

BarStackRenderer.BarSpacingRatio Property
[image]

Gets or sets the ratio of empty space between adjacent bar groups to space occupied by bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double BarSpacingRatio { get; set; }

Visual Basic [image] Copy Code

Public Property BarSpacingRatio As Double

Property Value

See Also

BarStackRenderer Members
BarStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer.HorizontalBars Property

BarStackRenderer.HorizontalBars Property
[image]

Gets or sets a value identifying whether bars should be horizontal.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool HorizontalBars { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalBars As Boolean

Property Value

See Also

BarStackRenderer Members
BarStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer.ProcessStackBars Delegate

BarStackRenderer.ProcessStackBars Delegate
[image]

Defines the signature of delegates called to process stacked bars.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected delegate void BarStackRenderer.ProcessStackBars (
int seriesIndex,
int dataIndex,
RectangleF bounds
)

Visual Basic [image] Copy Code

Protected Delegate Sub BarStackRenderer.ProcessStackBars( _
seriesIndex As Integer, _
dataIndex As Integer, _
bounds As RectangleF _
)

Parameters

seriesIndex

An integer index of series in Series list.

dataIndex

An integer index of data item in specified series.

bounds

A RectangleF representing the boundaries of current bar.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer3D Class

BarStackRenderer3D Class
Remarks See Also
[image]

A SeriesRenderer that draws stacked 3D bars in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class BarStackRenderer3D : BarStackRenderer, Renderer3D

Visual Basic [image] Copy Code

Public Class BarStackRenderer3D
Inherits BarStackRenderer
Implements Renderer3D

Remarks

BarStackRenderer3D must be placed inside a Plot3D component. It draws each data item as a bar, and if there are more than one series provided, the bar is stacked over the one drawn for previous series. If the GetLabel method of Series object returns InnerLabel string, it is drawn inside its corresponding bar. If GetLabel returns OuterLabel string, it is drawn to the right side of the bar.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.StackRenderer
MindFusion.Charting.BarStackRenderer
MindFusion.Charting.BarStackRenderer3D

See Also

BarStackRenderer3D Members
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer3D Members

BarStackRenderer3D Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws stacked 3D bars in its containing plot.

The following tables list the members exposed by the BarStackRenderer3D type.

Public Constructors

Name | Description
BarStackRenderer3D | Initializes a new instance of the BarStackRenderer3D class.

Public Properties

Name | Description
BarSpacingRatio | Gets or sets the ratio of empty space between adjacent bar groups to space occupied by bars. (Inherited from BarStackRenderer.)
HorizontalBars | Gets or sets a value identifying whether bars should be horizontal. (Inherited from BarStackRenderer.)
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
BuildModels | Implements Renderer3D.BuildModels. Adds 3D bar models for the series data to specified scene.
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | StackRenderer.HitTest override. Hit-tests the bar representations of data items. (Inherited from BarStackRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext. (Inherited from BarStackRenderer.)
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext. (Inherited from BarStackRenderer.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
EnumVisibleStackBars | Enumerates the bars visible in current data range. (Inherited from BarStackRenderer.)
EnumVisibleStackPoints | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from StackRenderer.)
EnumVisibleStackRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from StackRenderer.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Gets the coordinates of specified data item when mapped to a Plot2D pixel. (Inherited from StackRenderer.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | StackRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from BarStackRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

BarStackRenderer3D Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer3D Constructor

BarStackRenderer3D Constructor
[image]

Initializes a new instance of the BarStackRenderer3D class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public BarStackRenderer3D (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as stacked bars.

See Also

BarStackRenderer3D Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer3D Methods

BarStackRenderer3D Methods
[image]

Public Methods

Name | Description
BuildModels | Implements Renderer3D.BuildModels. Adds 3D bar models for the series data to specified scene.
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | StackRenderer.HitTest override. Hit-tests the bar representations of data items. (Inherited from BarStackRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext. (Inherited from BarStackRenderer.)
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bar in specified RenderContext. (Inherited from BarStackRenderer.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
EnumVisibleStackBars | Enumerates the bars visible in current data range. (Inherited from BarStackRenderer.)
EnumVisibleStackPoints | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from StackRenderer.)
EnumVisibleStackRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from StackRenderer.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Gets the coordinates of specified data item when mapped to a Plot2D pixel. (Inherited from StackRenderer.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | StackRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from BarStackRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

BarStackRenderer3D Class
MindFusion.Charting Namespace


MindFusion.Charting.BarStackRenderer3D.BuildModels Method

BarStackRenderer3D.BuildModels Method
[image]

Implements Renderer3D.BuildModels. Adds 3D bar models for the series data to specified scene.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual void BuildModels (
Scene3D scene,
RenderContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub BuildModels( _
scene As Scene3D, _
context As RenderContext _
)

Parameters

scene

A Scene3D instance.

context

A RenderContext instance.

See Also

BarStackRenderer3D Members
BarStackRenderer3D Class
MindFusion.Charting Namespace


MindFusion.Charting.BubbleLabelAlignment Enumeration

BubbleLabelAlignment Enumeration
[image]

Specifies the alignment of a label relative to its associated bubble.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public enum BubbleLabelAlignment

Visual Basic [image] Copy Code

Public Enum BubbleLabelAlignment

Members

Member name | Description
Above | Indicates that the label is positioned above the bubble.
Below | Indicates that the label is positioned below the bubble.
Center | Indicates that the label is centered inside the bubble.
Left | Indicates that the label is positioned to the left of the bubble.
Right | Indicates that the label is positioned to the right of the bubble.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.BubbleRenderer Class

BubbleRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws bubbles representing data items in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class BubbleRenderer : Renderer2D

Visual Basic [image] Copy Code

Public Class BubbleRenderer
Inherits Renderer2D

Remarks

The Series assigned to this renderer must support at least three Dimensions, where first and second dimensions specify position and third dimension specifies size. BubbleRenderer must be placed inside a Plot2D component. It draws each data item as a bubble, whose radius is returned by GetValue for third dimension. If the GetLabel method of Series object returns InnerLabel string, the label is drawn inside its corresponding bubble by default. Label position can be changed using the LabelAlignment property.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.BubbleRenderer

See Also

BubbleRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.BubbleRenderer Members

BubbleRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws bubbles representing data items in its containing plot.

The following tables list the members exposed by the BubbleRenderer type.

Public Constructors

Name | Description
BubbleRenderer | Initializes a new instance of the BubbleRenderer class.

Public Properties

Name | Description
LabelAlignment | Gets or sets the label alignment.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the bubble representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws bubbles representing data items in specified RenderContext.
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bubble in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

BubbleRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BubbleRenderer Constructor

BubbleRenderer Constructor
[image]

Initializes a new instance of the BubbleRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public BubbleRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as bubbles.

See Also

BubbleRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BubbleRenderer Methods

BubbleRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the bubble representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws bubbles representing data items in specified RenderContext.
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted bubble in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

BubbleRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BubbleRenderer.Draw Method

BubbleRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws bubbles representing data items in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

BubbleRenderer Members
BubbleRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BubbleRenderer.DrawHighlight Method

BubbleRenderer.DrawHighlight Method
[image]

Renderer2D.DrawHighlight override. Draws highlighted bubble in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void DrawHighlight (
RenderContext context,
HitResult hitResult
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawHighlight( _
context As RenderContext, _
hitResult As HitResult _
)

Parameters

context

A RenderContext instance.

hitResult

A HitResult instance identifying highlighted data item.

See Also

BubbleRenderer Members
BubbleRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BubbleRenderer.HitTest Method

BubbleRenderer.HitTest Method
[image]

Renderer2D.HitTest override. Hit-tests the bubble representations of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override HitResult HitTest (
RenderContext context,
PointD location
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
context As RenderContext, _
location As PointD _
) As HitResult

Parameters

context

A RenderContext instance.

location

A PointD specifying where to look for a bubble.

Return Value

A HitResult instance identifying the found data item.

See Also

BubbleRenderer Members
BubbleRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BubbleRenderer Properties

BubbleRenderer Properties
[image]

Public Properties

Name | Description
LabelAlignment | Gets or sets the label alignment.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

See Also

BubbleRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.BubbleRenderer.LabelAlignment Property

BubbleRenderer.LabelAlignment Property
[image]

Gets or sets the label alignment.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public BubbleLabelAlignment LabelAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property LabelAlignment As BubbleLabelAlignment

Property Value

A member of the BubbleLabelAlignment enumeration. The default value is Center.

See Also

BubbleRenderer Members
BubbleRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer Class

CandlestickRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws candlesticks in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class CandlestickRenderer : Renderer2D

Visual Basic [image] Copy Code

Public Class CandlestickRenderer
Inherits Renderer2D

Remarks

The Series assigned to this renderer must support at least five Dimensions, where first dimension specifies horizontal position and the next four coordinates specify vertical positions of candlestick body and wicks. StockPriceSeries is a convenience class that implements this kind of data in terms of open/close/low/high stock prices per date. CandlestickRenderer must be placed inside a Plot2D component. If the GetLabel method of Series object returns OuterLabel string, the label is drawn above its corresponding candlestick.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.CandlestickRenderer

See Also

CandlestickRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer Members

CandlestickRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws candlesticks in its containing plot.

The following tables list the members exposed by the CandlestickRenderer type.

Public Constructors

Name | Description
CandlestickRenderer | Initializes a new instance of the CandlestickRenderer class.

Public Properties

Name | Description
CandlestickWidth | Gets or sets the width of the candlesticks.
CloseDimension | Gets or sets the index of the dimension, containing close values.
HighDimension | Gets or sets the index of the dimension, containing high values.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LowDimension | Gets or sets the index of the dimension, containing low values.
OpenDimension | Gets or sets the index of the dimension, containing open values.
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item.
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the bar representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted candlestick in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisibleCandlesticks | Enumerates the candlesticks visible in current data range.
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer Constructor

CandlestickRenderer Constructor
[image]

Initializes a new instance of the CandlestickRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public CandlestickRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered by this object.

See Also

CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer Methods

CandlestickRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item.
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the bar representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted candlestick in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisibleCandlesticks | Enumerates the candlesticks visible in current data range.
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer.Draw Method

CandlestickRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

CandlestickRenderer Members
CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer.DrawHighlight Method

CandlestickRenderer.DrawHighlight Method
[image]

Renderer2D.DrawHighlight override. Draws highlighted candlestick in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void DrawHighlight (
RenderContext context,
HitResult hitResult
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawHighlight( _
context As RenderContext, _
hitResult As HitResult _
)

Parameters

context

A RenderContext instance.

hitResult

A HitResult instance identifying highlighted data item.

See Also

CandlestickRenderer Members
CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer.EffectiveFill Method

CandlestickRenderer.EffectiveFill Method
[image]

Gets the brush that should be used to fill the representation of specified data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public new Brush EffectiveFill (
int seriesIndex,
int dataIndex,
RenderContext context
)

Visual Basic [image] Copy Code

Public Shadows Function EffectiveFill( _
seriesIndex As Integer, _
dataIndex As Integer, _
context As RenderContext _
) As Brush

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this SeriesRenderer.

dataIndex

An integer index of the data item in specified series.

context

A RenderContext instance.

Return Value

A Brush instance.

See Also

CandlestickRenderer Members
CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer.EnumVisibleCandlesticks Method

CandlestickRenderer.EnumVisibleCandlesticks Method
[image]

Enumerates the candlesticks visible in current data range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void EnumVisibleCandlesticks (
RenderContext context,
CandlestickRenderer.ProcessCandlesticks process
)

Visual Basic [image] Copy Code

Protected Sub EnumVisibleCandlesticks( _
context As RenderContext, _
process As CandlestickRenderer.ProcessCandlesticks _
)

Parameters

context

A RenderContext instance.

process

A ProcessBars callback.

See Also

CandlestickRenderer Members
CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer.HitTest Method

CandlestickRenderer.HitTest Method
[image]

Renderer2D.HitTest override. Hit-tests the bar representations of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override HitResult HitTest (
RenderContext context,
PointD location
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
context As RenderContext, _
location As PointD _
) As HitResult

Parameters

context

A RenderContext instance.

location

A PointD specifying where to look for a candlestick.

Return Value

A HitResult instance identifying the found data item.

See Also

CandlestickRenderer Members
CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer.MeasureDataRange Method

CandlestickRenderer.MeasureDataRange Method
[image]

Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void MeasureDataRange (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub MeasureDataRange( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

CandlestickRenderer Members
CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer Properties

CandlestickRenderer Properties
[image]

Public Properties

Name | Description
CandlestickWidth | Gets or sets the width of the candlesticks.
CloseDimension | Gets or sets the index of the dimension, containing close values.
HighDimension | Gets or sets the index of the dimension, containing high values.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LowDimension | Gets or sets the index of the dimension, containing low values.
OpenDimension | Gets or sets the index of the dimension, containing open values.
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

See Also

CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer.CandlestickWidth Property

CandlestickRenderer.CandlestickWidth Property
[image]

Gets or sets the width of the candlesticks.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double CandlestickWidth { get; set; }

Visual Basic [image] Copy Code

Public Property CandlestickWidth As Double

Property Value

See Also

CandlestickRenderer Members
CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer.CloseDimension Property

CandlestickRenderer.CloseDimension Property
[image]

Gets or sets the index of the dimension, containing close values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int CloseDimension { get; set; }

Visual Basic [image] Copy Code

Public Property CloseDimension As Integer

Property Value

See Also

CandlestickRenderer Members
CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer.HighDimension Property

CandlestickRenderer.HighDimension Property
[image]

Gets or sets the index of the dimension, containing high values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int HighDimension { get; set; }

Visual Basic [image] Copy Code

Public Property HighDimension As Integer

Property Value

See Also

CandlestickRenderer Members
CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer.LowDimension Property

CandlestickRenderer.LowDimension Property
[image]

Gets or sets the index of the dimension, containing low values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int LowDimension { get; set; }

Visual Basic [image] Copy Code

Public Property LowDimension As Integer

Property Value

See Also

CandlestickRenderer Members
CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer.OpenDimension Property

CandlestickRenderer.OpenDimension Property
[image]

Gets or sets the index of the dimension, containing open values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int OpenDimension { get; set; }

Visual Basic [image] Copy Code

Public Property OpenDimension As Integer

Property Value

See Also

CandlestickRenderer Members
CandlestickRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickRenderer.ProcessCandlesticks Delegate

CandlestickRenderer.ProcessCandlesticks Delegate
[image]

Defines the signature of delegates called to process candlesticks.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected delegate void CandlestickRenderer.ProcessCandlesticks (
int seriesIndex,
int dataIndex,
PointF[] points,
RectangleF bounds
)

Visual Basic [image] Copy Code

Protected Delegate Sub CandlestickRenderer.ProcessCandlesticks( _
seriesIndex As Integer, _
dataIndex As Integer, _
points() As PointF, _
bounds As RectangleF _
)

Parameters

seriesIndex

An integer index of series in Series list.

dataIndex

An integer index of data item in specified series.

points

An array of four points containing wick ends' coordinates.

bounds

A RectangleF representing the boundaries of current candlestick.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.CandlestickSeriesStyle Class

CandlestickSeriesStyle Class
[image]

Defines appearance attributes for candlestick charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class CandlestickSeriesStyle : SeriesStyle

Visual Basic [image] Copy Code

Public Class CandlestickSeriesStyle
Implements SeriesStyle

Inheritance Hierarchy

System.Object
MindFusion.Charting.CandlestickSeriesStyle

See Also

CandlestickSeriesStyle Members
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickSeriesStyle Members

CandlestickSeriesStyle Members
Constructors Properties Methods
[image]

Defines appearance attributes for candlestick charts.

The following tables list the members exposed by the CandlestickSeriesStyle type.

Public Constructors

Name | Description
CandlestickSeriesStyle | Initializes a new instance of CandlestickSeriesStyle.

Public Properties

Name | Description
FallingBrush | Gets or sets a Brush used to fill candlesticks, which open value is greater than its close value.
RisingBrush | Gets or sets a Brush used to fill candlesticks, which open value is smaller or equal to its close value.
Stroke | Gets or sets a Brush used to stroke candlesticks;
StrokeDashStyle | Gets or sets the stroke dash style of the candlesticks.
StrokeThickness | Gets or sets the stroke thickness of the candlesticks.

Public Methods

Name | Description
Fill | Implements SeriesStyle.Fill. Returns a Brush instance, depending on the series data.

See Also

CandlestickSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickSeriesStyle Constructor

CandlestickSeriesStyle Constructor
[image]

Initializes a new instance of CandlestickSeriesStyle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public CandlestickSeriesStyle (
Brush risingBrush,
Brush fallingBrush,
Brush stroke,
double strokeThickness,
DashStyle strokeDashStyle,
CandlestickRenderer renderer
)

Visual Basic [image] Copy Code

Public New ( _
risingBrush As Brush, _
fallingBrush As Brush, _
stroke As Brush, _
strokeThickness As Double, _
strokeDashStyle As DashStyle, _
renderer As CandlestickRenderer _
)

Parameters

risingBrush

fallingBrush

stroke

strokeThickness

strokeDashStyle

renderer

See Also

CandlestickSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickSeriesStyle Methods

CandlestickSeriesStyle Methods
[image]

Public Methods

Name | Description
Fill | Implements SeriesStyle.Fill. Returns a Brush instance, depending on the series data.

See Also

CandlestickSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickSeriesStyle.Fill Method

CandlestickSeriesStyle.Fill Method
[image]

Implements SeriesStyle.Fill. Returns a Brush instance, depending on the series data.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush Fill (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function Fill( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Brush

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A Brush instance.

See Also

CandlestickSeriesStyle Members
CandlestickSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickSeriesStyle Properties

CandlestickSeriesStyle Properties
[image]

Public Properties

Name | Description
FallingBrush | Gets or sets a Brush used to fill candlesticks, which open value is greater than its close value.
RisingBrush | Gets or sets a Brush used to fill candlesticks, which open value is smaller or equal to its close value.
Stroke | Gets or sets a Brush used to stroke candlesticks;
StrokeDashStyle | Gets or sets the stroke dash style of the candlesticks.
StrokeThickness | Gets or sets the stroke thickness of the candlesticks.

See Also

CandlestickSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickSeriesStyle.FallingBrush Property

CandlestickSeriesStyle.FallingBrush Property
[image]

Gets or sets a Brush used to fill candlesticks, which open value is greater than its close value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush FallingBrush { get; set; }

Visual Basic [image] Copy Code

Public Property FallingBrush As Brush

Property Value

See Also

CandlestickSeriesStyle Members
CandlestickSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickSeriesStyle.RisingBrush Property

CandlestickSeriesStyle.RisingBrush Property
[image]

Gets or sets a Brush used to fill candlesticks, which open value is smaller or equal to its close value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush RisingBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RisingBrush As Brush

Property Value

See Also

CandlestickSeriesStyle Members
CandlestickSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickSeriesStyle.Stroke Property

CandlestickSeriesStyle.Stroke Property
[image]

Gets or sets a Brush used to stroke candlesticks;

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

See Also

CandlestickSeriesStyle Members
CandlestickSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickSeriesStyle.StrokeDashStyle Property

CandlestickSeriesStyle.StrokeDashStyle Property
[image]

Gets or sets the stroke dash style of the candlesticks.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<DashStyle> StrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashStyle As Nullable(Of DashStyle)

Property Value

See Also

CandlestickSeriesStyle Members
CandlestickSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.CandlestickSeriesStyle.StrokeThickness Property

CandlestickSeriesStyle.StrokeThickness Property
[image]

Gets or sets the stroke thickness of the candlesticks.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Nullable(Of Double)

Property Value

See Also

CandlestickSeriesStyle Members
CandlestickSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter Class

Converter Class
[image]

Provides capabilities to convert various types to and from strings in a cutlure-independent way.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public sealed class Converter

Visual Basic [image] Copy Code

Public NotInheritable Class Converter

Inheritance Hierarchy

System.Object
MindFusion.Charting.Converter

See Also

Converter Members
MindFusion.Charting Namespace


MindFusion.Charting.Converter Members

Converter Members
Methods
[image]

Provides capabilities to convert various types to and from strings in a cutlure-independent way.

The following tables list the members exposed by the Converter type.

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromImageV4 | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
ImageFromString | Converts the specified string value to image.
ToBoolean | Converts the specified string value to bool.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specified string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToImageV4 | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter Methods

Converter Methods
[image]

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromImageV4 | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
ImageFromString | Converts the specified string value to image.
ToBoolean | Converts the specified string value to bool.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specified string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToImageV4 | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromBoolean Method

Converter.FromBoolean Method
[image]

Converts the specified bool value to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromBoolean (
bool val
)

Visual Basic [image] Copy Code

Public Shared Function FromBoolean( _
val As Boolean _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromByte Method

Converter.FromByte Method
[image]

Converts the specified byte value to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromByte (
byte val
)

Visual Basic [image] Copy Code

Public Shared Function FromByte( _
val As Byte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromChar Method

Converter.FromChar Method
[image]

Converts the specified char value to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromChar (
char val
)

Visual Basic [image] Copy Code

Public Shared Function FromChar( _
val As Char _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromColor Method

Converter.FromColor Method
[image]

Converts the specified color value to string in the format #AARRGGBB.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromColor (
Color val
)

Visual Basic [image] Copy Code

Public Shared Function FromColor( _
val As Color _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromDecimal Method

Converter.FromDecimal Method
[image]

Converts the specified decimal to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromDecimal (
decimal val
)

Visual Basic [image] Copy Code

Public Shared Function FromDecimal( _
val As Decimal _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromDouble Method

Converter.FromDouble Method
[image]

Converts the specified double value to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromDouble (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromDouble( _
val As Double _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromEnum Method

Converter.FromEnum Method
[image]

Converts the specified enum value to a string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromEnum (
Object val
)

Visual Basic [image] Copy Code

Public Shared Function FromEnum( _
val As Object _
) As String

Parameters

val

The value to convert.

Return Value

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromImage Method

Converter.FromImage Method
[image]

Converts the specified image to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromImage (
Image val
)

Visual Basic [image] Copy Code

Public Shared Function FromImage( _
val As Image _
) As String

Parameters

val

The image object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromImageV4 Method

Converter.FromImageV4 Method
[image]

Converts the specified image to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromImageV4 (
Image val
)

Visual Basic [image] Copy Code

Public Shared Function FromImageV4( _
val As Image _
) As String

Parameters

val

The Image object to convert.

Return Value

A string representing the specified value.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromInt16 Method

Converter.FromInt16 Method
[image]

Converts the specified 16-bit integer value to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromInt16 (
short val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt16( _
val As Short _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromInt32 Method

Converter.FromInt32 Method
[image]

Converts the specified 32-bit integer value to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromInt32 (
int val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt32( _
val As Integer _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromInt64 Method

Converter.FromInt64 Method
[image]

Converts the specified 64-bit integer to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromInt64 (
long val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt64( _
val As Long _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromSByte Method

Converter.FromSByte Method
[image]

Converts the specified 8-bit signed integer to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromSByte (
sbyte val
)

Visual Basic [image] Copy Code

Public Shared Function FromSByte( _
val As SByte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromSingle Method

Converter.FromSingle Method
[image]

Converts the specified float value to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromSingle (
float val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Single _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromStream Method

Converter.FromStream Method
[image]

Converts the specified stream to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromStream (
Stream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStream( _
val As Stream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromStreamV4 Method

Converter.FromStreamV4 Method
[image]

Converts the specified memory stream to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromStreamV4 (
MemoryStream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStreamV4( _
val As MemoryStream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromUInt16 Method

Converter.FromUInt16 Method
[image]

Converts the specified unsigned 16-bit integer value to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromUInt16 (
ushort val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt16( _
val As UShort _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromUInt32 Method

Converter.FromUInt32 Method
[image]

Converts the specified unsigned 32-bit integer value to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromUInt32 (
uint val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt32( _
val As UInteger _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.FromUInt64 Method

Converter.FromUInt64 Method
[image]

Converts the specified unsigned 64-bit integer value to string.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string FromUInt64 (
ulong val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt64( _
val As ULong _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ImageFromString Method

Converter.ImageFromString Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static Image ImageFromString (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ImageFromString( _
s As String _
) As Image

Parameters

s

The string value to convert from.

Return Value

An instance of the .NET Image class that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToBoolean Method

Converter.ToBoolean Method
[image]

Converts the specified string value to bool.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static bool ToBoolean (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBoolean( _
s As String _
) As Boolean

Parameters

s

The string value to convert from.

Return Value

A boolean value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToByte Method

Converter.ToByte Method
[image]

Converts the specified string value to byte value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static byte ToByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToByte( _
s As String _
) As Byte

Parameters

s

The string value to convert from.

Return Value

A byte value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToChar Method

Converter.ToChar Method
[image]

Converts the specified string value to char.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static char ToChar (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToChar( _
s As String _
) As Char

Parameters

s

The string value to convert from.

Return Value

A char value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToColor Method

Converter.ToColor Method
[image]

Converts the specified string value to Color.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static Color ToColor (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToColor( _
s As String _
) As Color

Parameters

s

The string value to convert from.

Return Value

A Color value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToDecimal Method

Converter.ToDecimal Method
[image]

Converts the specified string value to decimal.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static decimal ToDecimal (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDecimal( _
s As String _
) As Decimal

Parameters

s

The string value to convert from.

Return Value

A decimal value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToDouble Method

Converter.ToDouble Method
[image]

Converts the specified string value to double.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static double ToDouble (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDouble( _
s As String _
) As Double

Parameters

s

The string value to convert from.

Return Value

A double value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToEnum Method

Converter.ToEnum Method
[image]

Converts the specified string value to its corresponding enumeration member of the specified type.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static Object ToEnum (
Type type,
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToEnum( _
type As Type, _
s As String _
) As Object

Parameters

type

The type of the enumeration to convert to.

s

The string value to convert from.

Return Value

A member of the specified enumeration that is deserialized from the specified string, possibly a null reference (Nothing in Visual Basic) if the deserialization failed.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToImage Method

Converter.ToImage Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static Image ToImage (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToImage( _
s As String _
) As Image

Parameters

s

Return Value

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToImageV4 Method

Converter.ToImageV4 Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static Image ToImageV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToImageV4( _
s As String _
) As Image

Parameters

s

The string value to convert from.

Return Value

A .NET Image object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToInt16 Method

Converter.ToInt16 Method
[image]

Converts the specified string value to 16-bit integer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static short ToInt16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt16( _
s As String _
) As Short

Parameters

s

The string value to convert from.

Return Value

A 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToInt32 Method

Converter.ToInt32 Method
[image]

Overload List

Name | Description
Converter.ToInt32 (String) | Converts the specified string value to 32-bit integer.
Converter.ToInt32 (String, Int32) | Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToInt32 Method (String)

Converter.ToInt32 Method (String)
See Also
[image]

Converts the specified string value to 32-bit integer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String _
) As Integer

Parameters

s

The string value to convert from.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToInt32 Method (String, Int32)

Converter.ToInt32 Method (String, Int32)
See Also
[image]

Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s,
int defaultValue
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String, _
defaultValue As Integer _
) As Integer

Parameters

s

The string value to convert from.

defaultValue

The default value to return if s cannot be deserialized.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToInt64 Method

Converter.ToInt64 Method
[image]

Converts the specified string value to 64-bit integer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static long ToInt64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt64( _
s As String _
) As Long

Parameters

s

The string value to convert from.

Return Value

A 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToSByte Method

Converter.ToSByte Method
[image]

Converts the specified string value to 8-bit signed integer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static sbyte ToSByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSByte( _
s As String _
) As SByte

Parameters

s

The string value to convert from.

Return Value

An 8-bit signed integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToSingle Method

Converter.ToSingle Method
[image]

Converts the specified string value to float.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static float ToSingle (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSingle( _
s As String _
) As Single

Parameters

s

The string value to convert from.

Return Value

A float value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToStream Method

Converter.ToStream Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static Stream ToStream (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStream( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET Stream object that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToStreamV4 Method

Converter.ToStreamV4 Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static Stream ToStreamV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStreamV4( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET Stream object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToUint16 Method

Converter.ToUint16 Method
[image]

Converts the specified string value to unsigned 16-bit integer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static ushort ToUint16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint16( _
s As String _
) As UShort

Parameters

s

The string value to convert from.

Return Value

An unsigned 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToUint32 Method

Converter.ToUint32 Method
[image]

Converts the specified string value to unsigned 32-bit integer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static uint ToUint32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint32( _
s As String _
) As UInteger

Parameters

s

The string value to convert from.

Return Value

An unsigned 32-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.Converter.ToUint64 Method

Converter.ToUint64 Method
[image]

Converts the specified string value to unsigned 64-bit integer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static ulong ToUint64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint64( _
s As String _
) As ULong

Parameters

s

The string value to convert from.

Return Value

Remarks

An unsigned 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting Namespace


MindFusion.Charting.CurveAreaRenderer Class

CurveAreaRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws each series as an area with curved boundaries in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class CurveAreaRenderer : AreaRenderer

Visual Basic [image] Copy Code

Public Class CurveAreaRenderer
Inherits AreaRenderer

Remarks

CurveAreaRenderer must be placed inside a Plot2D component. It draws the values of each series as a filled area enclosed by a cardinal spline. If the GetLabel method of Series object returns InnerLabel or OuterLabel strings, they are rendered near the point corresponding to respective data item.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.AreaRenderer
MindFusion.Charting.CurveAreaRenderer

See Also

CurveAreaRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.CurveAreaRenderer Members

CurveAreaRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws each series as an area with curved boundaries in its containing plot.

The following tables list the members exposed by the CurveAreaRenderer type.

Public Constructors

Name | Description
CurveAreaRenderer | Initializes a new instance of the CurveAreaRenderer class.

Public Properties

Name | Description
AreaOpacity | Gets or sets the opacity of radar polygons. (Inherited from AreaRenderer.)
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | AreaRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

CurveAreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CurveAreaRenderer Constructor

CurveAreaRenderer Constructor
[image]

Initializes a new instance of the CurveAreaRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public CurveAreaRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as areas.

See Also

CurveAreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CurveAreaRenderer Methods

CurveAreaRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | AreaRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

CurveAreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CurveAreaRenderer.Draw Method

CurveAreaRenderer.Draw Method
[image]

AreaRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

CurveAreaRenderer Members
CurveAreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CurveAreaStackRenderer Class

CurveAreaStackRenderer Class
[image]

A SeriesRenderer that draws stacked areas in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class CurveAreaStackRenderer : StackRenderer

Visual Basic [image] Copy Code

Public Class CurveAreaStackRenderer
Inherits StackRenderer

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.StackRenderer
MindFusion.Charting.CurveAreaStackRenderer

See Also

CurveAreaStackRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.CurveAreaStackRenderer Members

CurveAreaStackRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws stacked areas in its containing plot.

The following tables list the members exposed by the CurveAreaStackRenderer type.

Public Constructors

Name | Description
CurveAreaStackRenderer | Initializes a new instance of the CurveAreaStackRenderer class.

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the stack representations of data items. (Inherited from StackRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
EnumVisibleStackPoints | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from StackRenderer.)
EnumVisibleStackRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from StackRenderer.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Gets the coordinates of specified data item when mapped to a Plot2D pixel. (Inherited from StackRenderer.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from StackRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

CurveAreaStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CurveAreaStackRenderer Constructor

CurveAreaStackRenderer Constructor
[image]

Initializes a new instance of the CurveAreaStackRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public CurveAreaStackRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as stacked areas.

See Also

CurveAreaStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CurveAreaStackRenderer Methods

CurveAreaStackRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the stack representations of data items. (Inherited from StackRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
EnumVisibleStackPoints | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from StackRenderer.)
EnumVisibleStackRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from StackRenderer.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Gets the coordinates of specified data item when mapped to a Plot2D pixel. (Inherited from StackRenderer.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from StackRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

CurveAreaStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CurveAreaStackRenderer.Draw Method

CurveAreaStackRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

CurveAreaStackRenderer Members
CurveAreaStackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CurveRenderer Class

CurveRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws series as a cardinal spline.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class CurveRenderer : LineRenderer

Visual Basic [image] Copy Code

Public Class CurveRenderer
Inherits LineRenderer

Remarks

CurveRenderer must be placed inside a Plot2D component. It draws a cardinal spline through the points of each series. If the GetLabel method of Series object returns InnerLabel or OuterLabel strings, they are rendered near the point corresponding to respective data item.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.LineRenderer
MindFusion.Charting.CurveRenderer

See Also

CurveRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.CurveRenderer Members

CurveRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws series as a cardinal spline.

The following tables list the members exposed by the CurveRenderer type.

Public Constructors

Name | Description
CurveRenderer | Initializes a new instance of the CurveRenderer class.

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | LineRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

CurveRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CurveRenderer Constructor

CurveRenderer Constructor
[image]

Initializes a new instance of the CurveRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public CurveRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as a cardinal spline.

See Also

CurveRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CurveRenderer Methods

CurveRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | LineRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

CurveRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.CurveRenderer.Draw Method

CurveRenderer.Draw Method
[image]

LineRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

CurveRenderer Members
CurveRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries Class

DataBoundSeries Class
[image]

Represents a series whose data items are retrieved from a data source.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class DataBoundSeries : Series

Visual Basic [image] Copy Code

Public Class DataBoundSeries
Implements Series

Inheritance Hierarchy

System.Object
MindFusion.Charting.DataBoundSeries

See Also

DataBoundSeries Members
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries Members

DataBoundSeries Members
Constructors Properties Methods Events
[image]

Represents a series whose data items are retrieved from a data source.

The following tables list the members exposed by the DataBoundSeries type.

Public Constructors

Name | Description
DataBoundSeries | Initializes a new instance of the DataBoundSeries class.

Public Properties

Name | Description
DataSource | Gets or sets the data source this series is bound to.
Dimensions | Implements Series.Dimensions. Returns the number of X/Y/ZDataField properties set.
InnerLabelsDataField | Gets or sets the name of inner labels data field in the data source.
OuterLabelsDataField | Gets or sets the name of outer labels data field in the data source.
Size | Implements Series.Size. Gets the number of data items in the data source.
SupportedLabels | Implements Series.SupportedLabels. Result depends on which *LabelsDataField properties are set.
Title | Implements Series.Title. Gets or sets the title of this series.
ToolTipsDataField | Gets or sets the name of tooltips data field in the data source.
XAxisLabelsDataField | Gets or sets the name of X axis labels data field in the data source.
XDataField | Gets or sets the name of X data field in the data source.
YAxisLabelsDataField | Gets or sets the name of Y axis labels data field in the data source.
YDataField | Gets or sets the name of Y data field in the data source.
ZAxisLabelsDataField | Gets or sets the name of Z axis labels data field in the data source.
ZDataField | Gets or sets the name of Z data field in the data source.

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns a label for the specified data item in the data source.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in the data source.
IsEmphasized | Implements Series.IsEmphasized. DataBoundSeries always returns false.
IsSorted | Implements Series.IsSorted. Gets a value indicating whether the series values increase monotonously in specified dimension.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries Constructor

DataBoundSeries Constructor
[image]

Initializes a new instance of the DataBoundSeries class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public DataBoundSeries (
Object dataSource
)

Visual Basic [image] Copy Code

Public New ( _
dataSource As Object _
)

Parameters

dataSource

A reference to the data source object.

See Also

DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries Methods

DataBoundSeries Methods
[image]

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns a label for the specified data item in the data source.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in the data source.
IsEmphasized | Implements Series.IsEmphasized. DataBoundSeries always returns false.
IsSorted | Implements Series.IsSorted. Gets a value indicating whether the series values increase monotonously in specified dimension.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

See Also

DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.GetLabel Method

DataBoundSeries.GetLabel Method
[image]

Implements Series.GetLabel. Returns a label for the specified data item in the data source.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string GetLabel (
int index,
LabelKinds kind
)

Visual Basic [image] Copy Code

Public Function GetLabel( _
index As Integer, _
kind As LabelKinds _
) As String

Parameters

index

An integer value specifying the index of a data item.

kind

A member of the LabelKinds enumeration.

Return Value

A string containing the item's label.

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.GetValue Method

DataBoundSeries.GetValue Method
[image]

Implements Series.GetValue. Returns a value for the specified data item in the data source.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GetValue (
int index,
int dimension
)

Visual Basic [image] Copy Code

Public Function GetValue( _
index As Integer, _
dimension As Integer _
) As Double

Parameters

index

An integer value specifying the index of a data item.

dimension

An integer value specifying the dimension whose coordinate to return.

Return Value

A double-precision number representing the value of a data item in the data source.

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.IsEmphasized Method

DataBoundSeries.IsEmphasized Method
[image]

Implements Series.IsEmphasized. DataBoundSeries always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsEmphasized (
int index
)

Visual Basic [image] Copy Code

Public Function IsEmphasized( _
index As Integer _
) As Boolean

Parameters

index

An integer value specifying the index of a data item.

Return Value

true to emphasize the specified data item, or false otherwise.

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.IsSorted Method

DataBoundSeries.IsSorted Method
[image]

Implements Series.IsSorted. Gets a value indicating whether the series values increase monotonously in specified dimension.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsSorted (
int dimension
)

Visual Basic [image] Copy Code

Public Function IsSorted( _
dimension As Integer _
) As Boolean

Parameters

dimension

An integer value identifying the dimension.

Return Value

true if the values are sorted in specified dimension, or false otherwise.

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.OnDataChanged Method

DataBoundSeries.OnDataChanged Method
[image]

Raises the DataChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void OnDataChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnDataChanged( _
e As EventArgs _
)

Parameters

e

An instance of the EventArgs class.

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries Properties

DataBoundSeries Properties
[image]

Public Properties

Name | Description
DataSource | Gets or sets the data source this series is bound to.
Dimensions | Implements Series.Dimensions. Returns the number of X/Y/ZDataField properties set.
InnerLabelsDataField | Gets or sets the name of inner labels data field in the data source.
OuterLabelsDataField | Gets or sets the name of outer labels data field in the data source.
Size | Implements Series.Size. Gets the number of data items in the data source.
SupportedLabels | Implements Series.SupportedLabels. Result depends on which *LabelsDataField properties are set.
Title | Implements Series.Title. Gets or sets the title of this series.
ToolTipsDataField | Gets or sets the name of tooltips data field in the data source.
XAxisLabelsDataField | Gets or sets the name of X axis labels data field in the data source.
XDataField | Gets or sets the name of X data field in the data source.
YAxisLabelsDataField | Gets or sets the name of Y axis labels data field in the data source.
YDataField | Gets or sets the name of Y data field in the data source.
ZAxisLabelsDataField | Gets or sets the name of Z axis labels data field in the data source.
ZDataField | Gets or sets the name of Z data field in the data source.

See Also

DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.DataSource Property

DataBoundSeries.DataSource Property
[image]

Gets or sets the data source this series is bound to.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Object DataSource { get; set; }

Visual Basic [image] Copy Code

Public Property DataSource As Object

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.Dimensions Property

DataBoundSeries.Dimensions Property
[image]

Implements Series.Dimensions. Returns the number of X/Y/ZDataField properties set.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Dimensions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dimensions As Integer

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.InnerLabelsDataField Property

DataBoundSeries.InnerLabelsDataField Property
[image]

Gets or sets the name of inner labels data field in the data source.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string InnerLabelsDataField { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelsDataField As String

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.OuterLabelsDataField Property

DataBoundSeries.OuterLabelsDataField Property
[image]

Gets or sets the name of outer labels data field in the data source.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string OuterLabelsDataField { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelsDataField As String

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.Size Property

DataBoundSeries.Size Property
[image]

Implements Series.Size. Gets the number of data items in the data source.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Size { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Size As Integer

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.SupportedLabels Property

DataBoundSeries.SupportedLabels Property
[image]

Implements Series.SupportedLabels. Result depends on which *LabelsDataField properties are set.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public LabelKinds SupportedLabels { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SupportedLabels As LabelKinds

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.Title Property

DataBoundSeries.Title Property
[image]

Implements Series.Title. Gets or sets the title of this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.ToolTipsDataField Property

DataBoundSeries.ToolTipsDataField Property
[image]

Gets or sets the name of tooltips data field in the data source.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string ToolTipsDataField { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTipsDataField As String

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.XAxisLabelsDataField Property

DataBoundSeries.XAxisLabelsDataField Property
[image]

Gets or sets the name of X axis labels data field in the data source.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string XAxisLabelsDataField { get; set; }

Visual Basic [image] Copy Code

Public Property XAxisLabelsDataField As String

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.XDataField Property

DataBoundSeries.XDataField Property
[image]

Gets or sets the name of X data field in the data source.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string XDataField { get; set; }

Visual Basic [image] Copy Code

Public Property XDataField As String

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.YAxisLabelsDataField Property

DataBoundSeries.YAxisLabelsDataField Property
[image]

Gets or sets the name of Y axis labels data field in the data source.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string YAxisLabelsDataField { get; set; }

Visual Basic [image] Copy Code

Public Property YAxisLabelsDataField As String

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.YDataField Property

DataBoundSeries.YDataField Property
[image]

Gets or sets the name of Y data field in the data source.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string YDataField { get; set; }

Visual Basic [image] Copy Code

Public Property YDataField As String

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.ZAxisLabelsDataField Property

DataBoundSeries.ZAxisLabelsDataField Property
[image]

Gets or sets the name of Z axis labels data field in the data source.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string ZAxisLabelsDataField { get; set; }

Visual Basic [image] Copy Code

Public Property ZAxisLabelsDataField As String

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.ZDataField Property

DataBoundSeries.ZDataField Property
[image]

Gets or sets the name of Z data field in the data source.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string ZDataField { get; set; }

Visual Basic [image] Copy Code

Public Property ZDataField As String

Property Value

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries Events

DataBoundSeries Events
[image]

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DataBoundSeries.DataChanged Event

DataBoundSeries.DataChanged Event
[image]

Implements Series.DataChanged. Raised when the values in this series change.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

See Also

DataBoundSeries Members
DataBoundSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeFormat Enumeration

DateTimeFormat Enumeration
[image]

Specifies formats for DateTime values

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public enum DateTimeFormat

Visual Basic [image] Copy Code

Public Enum DateTimeFormat

Members

Member name | Description
CustomDateTime | Indicates that the number should be formatted as a DateTime value according to a custom set string.
FullDateTime | Indicates that the number should be formatted as a DateTime value with a full date pattern.
LongDate | Indicates that the number should be formatted as a DateTime value with a long date pattern.
LongTime | Indicates that the number should be formatted as a DateTime value with a long time pattern.
MonthDateTime | Indicates that the number should be formatted as a DateTime value with a month day pattern.
None | The DateTime value is not formatted
ShortDate | Indicates that the number should be formatted as a DateTime value with a short date pattern.
ShortTime | Indicates that the number should be formatted as a DateTime value with a short time pattern.
YearDateTime | Indicates that the number should be formatted as a DateTime value with a year month date pattern.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries Class

DateTimeSeries Class
[image]

Represents a series that contains DateTime values as X coordinates and double values as Y coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class DateTimeSeries : Series

Visual Basic [image] Copy Code

Public Class DateTimeSeries
Implements Series

Inheritance Hierarchy

System.Object
MindFusion.Charting.DateTimeSeries

See Also

DateTimeSeries Members
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries Members

DateTimeSeries Members
Constructors Properties Methods Events
[image]

Represents a series that contains DateTime values as X coordinates and double values as Y coordinates.

The following tables list the members exposed by the DateTimeSeries type.

Public Constructors

Name | Description
DateTimeSeries | Initializes a new instance of the DateTimeSeries class.

Public Properties

Name | Description
CustomDateTimeFormat | Gets or sets a custom format string for DateTime labels.
Dates | Gets or sets a list of DateTime values used as X coordinates of this series.
DateTimeFormat | Gets or sets a value indicating how to format DateTime values as labels.
Dimensions | Implements Series.Dimensions. Returns 2.
LabelPrefix | Gets or sets a prefix added in front of formatted DateTime labels.
LabelSuffix | Gets or sets a suffix appended to formatted DateTime labels.
MaxDate | Gets or sets the end of the time range.
MaxValue | Gets or sets the coordinate corresponding to MaxDate.
MinDate | Gets or sets the start of the time range.
MinValue | Gets or sets the coordinate corresponding to MinDate.
Size | Implements Series.Size. Returns the number of elements provided in DateTime list.
SupportedLabels | Implements Series.SupportedLabels. Returns LabelKinds.XAxisLabel.
Title | Implements Series.Title. Gets or sets the title of this series.

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns DateTime value at specified index as an XAxisLabel.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in this series.
IsEmphasized | Implements Series.IsEmphasized. DateTimeSeries always returns false.
IsSorted | Implements Series.IsSorted. DateTimeSeries always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries Constructor

DateTimeSeries Constructor
[image]

Initializes a new instance of the DateTimeSeries class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public DateTimeSeries (
IList<DateTime> dates,
IList<Double> values,
DateTime minDate,
DateTime maxDate
)

Visual Basic [image] Copy Code

Public New ( _
dates As IList(Of DateTime), _
values As IList(Of Double), _
minDate As DateTime, _
maxDate As DateTime _
)

Parameters

dates

A list of DateTime values.

values

A list of double values.

minDate

Identifies the start of the time range.

maxDate

Identifies the end of the time range.

See Also

DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries Methods

DateTimeSeries Methods
[image]

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns DateTime value at specified index as an XAxisLabel.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in this series.
IsEmphasized | Implements Series.IsEmphasized. DateTimeSeries always returns false.
IsSorted | Implements Series.IsSorted. DateTimeSeries always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

See Also

DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.GetLabel Method

DateTimeSeries.GetLabel Method
[image]

Implements Series.GetLabel. Returns DateTime value at specified index as an XAxisLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string GetLabel (
int index,
LabelKinds kind
)

Visual Basic [image] Copy Code

Public Function GetLabel( _
index As Integer, _
kind As LabelKinds _
) As String

Parameters

index

An integer value specifying the index of a data item.

kind

A member of the LabelKinds enumeration.

Return Value

A string containing the item's label.

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.GetValue Method

DateTimeSeries.GetValue Method
[image]

Implements Series.GetValue. Returns a value for the specified data item in this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GetValue (
int index,
int dimension
)

Visual Basic [image] Copy Code

Public Function GetValue( _
index As Integer, _
dimension As Integer _
) As Double

Parameters

index

An integer value specifying the index of a data item.

dimension

An integer value specifying the dimension whose coordinate to return.

Return Value

A double-precision number representing the value of a data item in the series.

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.IsEmphasized Method

DateTimeSeries.IsEmphasized Method
[image]

Implements Series.IsEmphasized. DateTimeSeries always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsEmphasized (
int index
)

Visual Basic [image] Copy Code

Public Function IsEmphasized( _
index As Integer _
) As Boolean

Parameters

index

An integer value specifying the index of a data item.

Return Value

true to emphasize the specified data item, or false otherwise.

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.IsSorted Method

DateTimeSeries.IsSorted Method
[image]

Implements Series.IsSorted. DateTimeSeries always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsSorted (
int dimension
)

Visual Basic [image] Copy Code

Public Function IsSorted( _
dimension As Integer _
) As Boolean

Parameters

dimension

An integer value identifying the dimension.

Return Value

true if the values are sorted in specified dimension, or false otherwise.

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.OnDataChanged Method

DateTimeSeries.OnDataChanged Method
[image]

Raises the DataChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void OnDataChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnDataChanged ()

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries Properties

DateTimeSeries Properties
[image]

Public Properties

Name | Description
CustomDateTimeFormat | Gets or sets a custom format string for DateTime labels.
Dates | Gets or sets a list of DateTime values used as X coordinates of this series.
DateTimeFormat | Gets or sets a value indicating how to format DateTime values as labels.
Dimensions | Implements Series.Dimensions. Returns 2.
LabelPrefix | Gets or sets a prefix added in front of formatted DateTime labels.
LabelSuffix | Gets or sets a suffix appended to formatted DateTime labels.
MaxDate | Gets or sets the end of the time range.
MaxValue | Gets or sets the coordinate corresponding to MaxDate.
MinDate | Gets or sets the start of the time range.
MinValue | Gets or sets the coordinate corresponding to MinDate.
Size | Implements Series.Size. Returns the number of elements provided in DateTime list.
SupportedLabels | Implements Series.SupportedLabels. Returns LabelKinds.XAxisLabel.
Title | Implements Series.Title. Gets or sets the title of this series.

See Also

DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.CustomDateTimeFormat Property

DateTimeSeries.CustomDateTimeFormat Property
[image]

Gets or sets a custom format string for DateTime labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string CustomDateTimeFormat { get; set; }

Visual Basic [image] Copy Code

Public Property CustomDateTimeFormat As String

Property Value

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.Dates Property

DateTimeSeries.Dates Property
[image]

Gets or sets a list of DateTime values used as X coordinates of this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<DateTime> Dates { get; set; }

Visual Basic [image] Copy Code

Public Property Dates As IList(Of DateTime)

Property Value

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.DateTimeFormat Property

DateTimeSeries.DateTimeFormat Property
[image]

Gets or sets a value indicating how to format DateTime values as labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public DateTimeFormat DateTimeFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DateTimeFormat As DateTimeFormat

Property Value

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.Dimensions Property

DateTimeSeries.Dimensions Property
[image]

Implements Series.Dimensions. Returns 2.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Dimensions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dimensions As Integer

Property Value

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.LabelPrefix Property

DateTimeSeries.LabelPrefix Property
[image]

Gets or sets a prefix added in front of formatted DateTime labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string LabelPrefix { get; set; }

Visual Basic [image] Copy Code

Public Property LabelPrefix As String

Property Value

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.LabelSuffix Property

DateTimeSeries.LabelSuffix Property
[image]

Gets or sets a suffix appended to formatted DateTime labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string LabelSuffix { get; set; }

Visual Basic [image] Copy Code

Public Property LabelSuffix As String

Property Value

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.MaxDate Property

DateTimeSeries.MaxDate Property
[image]

Gets or sets the end of the time range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public DateTime MaxDate { get; set; }

Visual Basic [image] Copy Code

Public Property MaxDate As DateTime

Property Value

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.MaxValue Property

DateTimeSeries.MaxValue Property
[image]

Gets or sets the coordinate corresponding to MaxDate.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double MaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property MaxValue As Double

Property Value

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.MinDate Property

DateTimeSeries.MinDate Property
[image]

Gets or sets the start of the time range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public DateTime MinDate { get; set; }

Visual Basic [image] Copy Code

Public Property MinDate As DateTime

Property Value

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.MinValue Property

DateTimeSeries.MinValue Property
[image]

Gets or sets the coordinate corresponding to MinDate.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double MinValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinValue As Double

Property Value

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.Size Property

DateTimeSeries.Size Property
[image]

Implements Series.Size. Returns the number of elements provided in DateTime list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Size { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Size As Integer

Property Value

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.SupportedLabels Property

DateTimeSeries.SupportedLabels Property
[image]

Implements Series.SupportedLabels. Returns LabelKinds.XAxisLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public LabelKinds SupportedLabels { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SupportedLabels As LabelKinds

Property Value

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.Title Property

DateTimeSeries.Title Property
[image]

Implements Series.Title. Gets or sets the title of this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries Events

DateTimeSeries Events
[image]

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.DateTimeSeries.DataChanged Event

DateTimeSeries.DataChanged Event
[image]

Implements Series.DataChanged. Raised when the values in this series change.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

See Also

DateTimeSeries Members
DateTimeSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries Class

FunctionSeries Class
[image]

Represents a series that calculates its values from provided formula.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class FunctionSeries : Series

Visual Basic [image] Copy Code

Public Class FunctionSeries
Implements Series

Inheritance Hierarchy

System.Object
MindFusion.Charting.FunctionSeries

See Also

FunctionSeries Members
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries Members

FunctionSeries Members
Constructors Properties Methods Events
[image]

Represents a series that calculates its values from provided formula.

The following tables list the members exposed by the FunctionSeries type.

Public Constructors

Name | Description
FunctionSeries | Initializes a new instance of the FunctionSeries class.

Public Properties

Name | Description
Dimensions | Implements Series.Dimensions. Returns 2.
EvaluateFunctionDelegate | Gets or sets a delegate called to evaluate unknown functions used in the expression.
Size | Implements Series.Size. Gets the number of data items in this series.
SupportedLabels | Implements Series.SupportedLabels.
Title | Implements Series.Title. Gets or sets the title of this series.

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel.
GetValue | Implements Series.GetValue. Evaluates the function expression for specified index.
IsEmphasized | Implements Series.IsEmphasized.
IsSorted | Implements Series.IsSorted.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries Constructor

FunctionSeries Constructor
[image]

Initializes a new instance of the FunctionSeries class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public FunctionSeries (
string fxExpression,
int size,
double maxX
)

Visual Basic [image] Copy Code

Public New ( _
fxExpression As String, _
size As Integer, _
maxX As Double _
)

Parameters

fxExpression

A string specifying a mathematical expression to evaluate.

size

An integer value specifying the number of values to calculate.

maxX

A double-precision number specifying the maximum value of function range.

See Also

FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries Methods

FunctionSeries Methods
[image]

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel.
GetValue | Implements Series.GetValue. Evaluates the function expression for specified index.
IsEmphasized | Implements Series.IsEmphasized.
IsSorted | Implements Series.IsSorted.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

See Also

FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries.GetLabel Method

FunctionSeries.GetLabel Method
[image]

Implements Series.GetLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string GetLabel (
int index,
LabelKinds kind
)

Visual Basic [image] Copy Code

Public Function GetLabel( _
index As Integer, _
kind As LabelKinds _
) As String

Parameters

index

An integer value specifying the index of a data item.

kind

A member of the LabelKinds enumeration.

Return Value

A string containing the item's label.

See Also

FunctionSeries Members
FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries.GetValue Method

FunctionSeries.GetValue Method
[image]

Implements Series.GetValue. Evaluates the function expression for specified index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GetValue (
int index,
int dimension
)

Visual Basic [image] Copy Code

Public Function GetValue( _
index As Integer, _
dimension As Integer _
) As Double

Parameters

index

An integer value specifying the index of a data item.

dimension

An integer value specifying the dimension whose coordinate to return.

Return Value

A double-precision number representing the value of a data item in the series.

See Also

FunctionSeries Members
FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries.IsEmphasized Method

FunctionSeries.IsEmphasized Method
[image]

Implements Series.IsEmphasized.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsEmphasized (
int index
)

Visual Basic [image] Copy Code

Public Function IsEmphasized( _
index As Integer _
) As Boolean

Parameters

index

An integer value specifying the index of a data item.

Return Value

true to emphasize the specified data item, or false otherwise.

See Also

FunctionSeries Members
FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries.IsSorted Method

FunctionSeries.IsSorted Method
[image]

Implements Series.IsSorted.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsSorted (
int dimension
)

Visual Basic [image] Copy Code

Public Function IsSorted( _
dimension As Integer _
) As Boolean

Parameters

dimension

An integer value identifying the dimension.

Return Value

true if the values are sorted in specified dimension, or false otherwise.

See Also

FunctionSeries Members
FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries.OnDataChanged Method

FunctionSeries.OnDataChanged Method
[image]

Raises the DataChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void OnDataChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnDataChanged ()

See Also

FunctionSeries Members
FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries Properties

FunctionSeries Properties
[image]

Public Properties

Name | Description
Dimensions | Implements Series.Dimensions. Returns 2.
EvaluateFunctionDelegate | Gets or sets a delegate called to evaluate unknown functions used in the expression.
Size | Implements Series.Size. Gets the number of data items in this series.
SupportedLabels | Implements Series.SupportedLabels.
Title | Implements Series.Title. Gets or sets the title of this series.

See Also

FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries.Dimensions Property

FunctionSeries.Dimensions Property
[image]

Implements Series.Dimensions. Returns 2.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Dimensions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dimensions As Integer

Property Value

See Also

FunctionSeries Members
FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries.EvaluateFunctionDelegate Property

FunctionSeries.EvaluateFunctionDelegate Property
[image]

Gets or sets a delegate called to evaluate unknown functions used in the expression.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public FunctionSeries.EvaluateFunction EvaluateFunctionDelegate { get; set; }

Visual Basic [image] Copy Code

Public Property EvaluateFunctionDelegate As FunctionSeries.EvaluateFunction

Property Value

See Also

FunctionSeries Members
FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries.Size Property

FunctionSeries.Size Property
[image]

Implements Series.Size. Gets the number of data items in this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Size { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Size As Integer

Property Value

See Also

FunctionSeries Members
FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries.SupportedLabels Property

FunctionSeries.SupportedLabels Property
[image]

Implements Series.SupportedLabels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public LabelKinds SupportedLabels { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SupportedLabels As LabelKinds

Property Value

See Also

FunctionSeries Members
FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries.Title Property

FunctionSeries.Title Property
[image]

Implements Series.Title. Gets or sets the title of this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

FunctionSeries Members
FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries Events

FunctionSeries Events
[image]

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries.DataChanged Event

FunctionSeries.DataChanged Event
[image]

Implements Series.DataChanged. Raised when the values in this series change.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

See Also

FunctionSeries Members
FunctionSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.FunctionSeries.EvaluateFunction Delegate

FunctionSeries.EvaluateFunction Delegate
[image]

Defines the signature of methods called to evaluate unknown functions used in the expression.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public delegate Object FunctionSeries.EvaluateFunction (
string name,
Object[] arguments
)

Visual Basic [image] Copy Code

Public Delegate Function FunctionSeries.EvaluateFunction( _
name As String, _
arguments() As Object _
) As Object

Parameters

name

A string value specifying function name.

arguments

A list of arguments passed to the function.

Return Value

The value of function for specified arguments.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.GridType Enumeration

GridType Enumeration
[image]

Indicates Plot2D grid type.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public enum GridType

Visual Basic [image] Copy Code

Public Enum GridType

Members

Member name | Description
Crossed | Draw crossed stripes.
Horizontal | Draw horizontal stripes.
None | Do not draw grid.
Vertical | Draw vertical stripes.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.HitResult Class

HitResult Class
[image]

Represents the result of a hit-test operation.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class HitResult : EventArgs

Visual Basic [image] Copy Code

Public Class HitResult
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Charting.HitResult

See Also

HitResult Members
MindFusion.Charting Namespace


MindFusion.Charting.HitResult Members

HitResult Members
Constructors Properties
[image]

Represents the result of a hit-test operation.

The following tables list the members exposed by the HitResult type.

Public Constructors

Name | Description
HitResult | Initializes a new instance of the HitResult class.

Public Properties

Name | Description
Index | Gets the data item index within its Series.
Plot | Gets the Plot that has been hit.
Renderer | Gets the SeriesRenderer that has been hit.
Series | Gets the Series that has been hit.
Value | Gets the data item value.

See Also

HitResult Class
MindFusion.Charting Namespace


MindFusion.Charting.HitResult Constructor

HitResult Constructor
[image]

Initializes a new instance of the HitResult class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public HitResult (
SeriesRenderer renderer,
int index,
double value,
Series series
)

Visual Basic [image] Copy Code

Public New ( _
renderer As SeriesRenderer, _
index As Integer, _
value As Double, _
series As Series _
)

Parameters

renderer

A SeriesRenderer whose data item has been hit.

index

An integer index of the data item.

value

The item's vaue.

series

The Series that contains the found item.

See Also

HitResult Class
MindFusion.Charting Namespace


MindFusion.Charting.HitResult Properties

HitResult Properties
[image]

Public Properties

Name | Description
Index | Gets the data item index within its Series.
Plot | Gets the Plot that has been hit.
Renderer | Gets the SeriesRenderer that has been hit.
Series | Gets the Series that has been hit.
Value | Gets the data item value.

See Also

HitResult Class
MindFusion.Charting Namespace


MindFusion.Charting.HitResult.Index Property

HitResult.Index Property
[image]

Gets the data item index within its Series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Index { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

See Also

HitResult Members
HitResult Class
MindFusion.Charting Namespace


MindFusion.Charting.HitResult.Plot Property

HitResult.Plot Property
[image]

Gets the Plot that has been hit.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Plot Plot { get; set; }

Visual Basic [image] Copy Code

Public Property Plot As Plot

Property Value

See Also

HitResult Members
HitResult Class
MindFusion.Charting Namespace


MindFusion.Charting.HitResult.Renderer Property

HitResult.Renderer Property
[image]

Gets the SeriesRenderer that has been hit.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public SeriesRenderer Renderer { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Renderer As SeriesRenderer

Property Value

See Also

HitResult Members
HitResult Class
MindFusion.Charting Namespace


MindFusion.Charting.HitResult.Series Property

HitResult.Series Property
[image]

Gets the Series that has been hit.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Series Series { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Series As Series

Property Value

See Also

HitResult Members
HitResult Class
MindFusion.Charting Namespace


MindFusion.Charting.HitResult.Value Property

HitResult.Value Property
[image]

Gets the data item value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Value { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Value As Double

Property Value

See Also

HitResult Members
HitResult Class
MindFusion.Charting Namespace


MindFusion.Charting.INotifyPropertyValueChanged Interface

INotifyPropertyValueChanged Interface
[image]

Provides notification for property changes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public interface INotifyPropertyValueChanged

Visual Basic [image] Copy Code

Public Interface INotifyPropertyValueChanged

See Also

INotifyPropertyValueChanged Members
MindFusion.Charting Namespace


MindFusion.Charting.INotifyPropertyValueChanged Members

INotifyPropertyValueChanged Members
Events
[image]

Provides notification for property changes.

The following tables list the members exposed by the INotifyPropertyValueChanged type.

Public Events

Name | Description
PropertyValueChanged | Occurs when a property value changes.

See Also

INotifyPropertyValueChanged Interface
MindFusion.Charting Namespace


MindFusion.Charting.INotifyPropertyValueChanged Events

INotifyPropertyValueChanged Events
[image]

Public Events

Name | Description
PropertyValueChanged | Occurs when a property value changes.

See Also

INotifyPropertyValueChanged Interface
MindFusion.Charting Namespace


MindFusion.Charting.INotifyPropertyValueChanged.PropertyValueChanged Event

INotifyPropertyValueChanged.PropertyValueChanged Event
[image]

Occurs when a property value changes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

event EventHandler<PropertyEventArgs> PropertyValueChanged

Visual Basic [image] Copy Code

Event PropertyValueChanged As EventHandler(Of PropertyEventArgs)

See Also

INotifyPropertyValueChanged Members
INotifyPropertyValueChanged Interface
MindFusion.Charting Namespace


MindFusion.Charting.LabelKinds Enumeration

LabelKinds Enumeration
[image]

Identifies the various kinds of labels that can be drawn for data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public enum LabelKinds

Visual Basic [image] Copy Code

Public Enum LabelKinds

Members

Member name | Description
All | Draw all labels supported by a series.
InnerLabel | Draw inner label in graphic representation of data item.
None | Do not draw labels.
OuterLabel | Draw outer label nearby graphic representation of data item.
ToolTip | Show label as a tooltip.
XAxisLabel | Draw data label at X axis.
YAxisLabel | Draw data label at Y axis.
ZAxisLabel | Draw data label at Z axis.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.LegendController Class

LegendController Class
[image]

Lets users move a legend within the boundaries of its parent Panel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class LegendController : PlotController

Visual Basic [image] Copy Code

Public Class LegendController
Inherits PlotController

Inheritance Hierarchy

System.Object
MindFusion.Charting.PlotController
MindFusion.Charting.LegendController

See Also

LegendController Members
MindFusion.Charting Namespace


MindFusion.Charting.LegendController Members

LegendController Members
Constructors Fields Properties Methods
[image]

Lets users move a legend within the boundaries of its parent Panel.

The following tables list the members exposed by the LegendController type.

Public Constructors

Name | Description
LegendController | Initializes a new instance of the LegendController class.

Protected Fields

Name | Description
renderContext | The current RenderContext. (Inherited from PlotController.)

Public Properties

Name | Description
Component | Gets the component controlled by this PlotController. (Inherited from PlotController.)

Public Methods

Name | Description
DrawInteraction | Implements ComponentController.DrawInteraction. Draws a representation of the current state of user interaction on specified IGraphics surface. (Inherited from PlotController.)
GetRunningAnimation | For internal use. (Inherited from PlotController.)
OnMouseDown | Implements ComponentController.OnMouseDown. Called when the user presses a mouse button.
OnMouseMove | Implements ComponentController.OnMouseMove. Called when the user moves the mouse.
OnMouseUp | Implements ComponentController.OnMouseUp. Called when the user releases a mouse button. (Inherited from PlotController.)

See Also

LegendController Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendController Constructor

LegendController Constructor
[image]

Initializes a new instance of the LegendController class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public LegendController (
RenderContext renderContext
)

Visual Basic [image] Copy Code

Public New ( _
renderContext As RenderContext _
)

Parameters

renderContext

A RenderContext instance.

See Also

LegendController Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendController Methods

LegendController Methods
[image]

Public Methods

Name | Description
DrawInteraction | Implements ComponentController.DrawInteraction. Draws a representation of the current state of user interaction on specified IGraphics surface. (Inherited from PlotController.)
GetRunningAnimation | For internal use. (Inherited from PlotController.)
OnMouseDown | Implements ComponentController.OnMouseDown. Called when the user presses a mouse button.
OnMouseMove | Implements ComponentController.OnMouseMove. Called when the user moves the mouse.
OnMouseUp | Implements ComponentController.OnMouseUp. Called when the user releases a mouse button. (Inherited from PlotController.)

See Also

LegendController Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendController.OnMouseDown Method

LegendController.OnMouseDown Method
[image]

Implements ComponentController.OnMouseDown. Called when the user presses a mouse button.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void OnMouseDown (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overrides Sub OnMouseDown( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

LegendController Members
LegendController Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendController.OnMouseMove Method

LegendController.OnMouseMove Method
[image]

Implements ComponentController.OnMouseMove. Called when the user moves the mouse.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void OnMouseMove (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overrides Sub OnMouseMove( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

LegendController Members
LegendController Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer Class

LegendRenderer Class
[image]

A component that renders chart legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class LegendRenderer : Component

Visual Basic [image] Copy Code

Public Class LegendRenderer
Inherits Component

Inheritance Hierarchy

System.Object
MindFusion.Charting.Components.Component
MindFusion.Charting.LegendRenderer

See Also

LegendRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer Members

LegendRenderer Members
Constructors Properties Methods
[image]

A component that renders chart legend.

The following tables list the members exposed by the LegendRenderer type.

Public Constructors

Name | Description
LegendRenderer | Initializes a new instance of the LegendRenderer class.

Public Properties

Name | Description
AllowMove | Gets or sets a value indicating whether users are allowed to move this legend.
Background | Gets or sets the Brush that should be used to fill the background of this legend.
BorderStroke | Gets or sets the Brush that should be used to stroke the borders of this legend.
BorderStrokeDashStyle | Gets or sets the stroke dash style of legend borders.
BorderStrokeThickness | Gets or sets the stroke thickness of legend borders.
Content | Gets or sets a list of SeriesRenderer objects whose Series should be displayed in this legend.
Padding | Gets or sets the padding space between content and borders of this legend.
ShowTitle | Gets or sets a value indicating whether to display the legend title.
Spacing | Gets or sets the distance between adjacent entries in the legend.
Title | Gets or sets the legend's title.
TitleBrush | Gets or sets the Brush that should be used to draw the legend's Title.
TitleFontName | Gets or sets the name of font that should be used to draw the legend's Title.
TitleFontSize | Gets or sets the size of font that should be used to draw the legend's Title.
TitleFontStyle | Gets or sets the style of font that should be used to draw the legend's Title.

Public Methods

Name | Description
CreateController | Component.CreateController override. Returns a ComponentController used to interact with this component.
Draw | Component.Draw override. Draws legend elements in specified RenderContext.
EffectiveBorderStroke | Gets the Brush that should be used to stroke the legend borders.
EffectiveFill | Gets the Brush that should be used to fill the legend background.
Measure | Component.Measure override. Measures the desired size of this component.

Protected Methods

Name | Description
EffectiveBorderPen | Gets the Pen that should be used to draw the legend borders.
EffectiveBorderStrokeThickness | Gets the thickness of border strokes.
EffectiveStrokeDashStyle | Gets the dash style of border strokes.
EffectiveTitleBrush | Gets the Brush that should be used to draw the legend's Title.
EffectiveTitleFont | Gets the Font that should be used to draw the legend's Title.

See Also

LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer Constructor

LegendRenderer Constructor
[image]

Initializes a new instance of the LegendRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public LegendRenderer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer Methods

LegendRenderer Methods
[image]

Public Methods

Name | Description
CreateController | Component.CreateController override. Returns a ComponentController used to interact with this component.
Draw | Component.Draw override. Draws legend elements in specified RenderContext.
EffectiveBorderStroke | Gets the Brush that should be used to stroke the legend borders.
EffectiveFill | Gets the Brush that should be used to fill the legend background.
Measure | Component.Measure override. Measures the desired size of this component.

Protected Methods

Name | Description
EffectiveBorderPen | Gets the Pen that should be used to draw the legend borders.
EffectiveBorderStrokeThickness | Gets the thickness of border strokes.
EffectiveStrokeDashStyle | Gets the dash style of border strokes.
EffectiveTitleBrush | Gets the Brush that should be used to draw the legend's Title.
EffectiveTitleFont | Gets the Font that should be used to draw the legend's Title.

See Also

LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.CreateController Method

LegendRenderer.CreateController Method
[image]

Component.CreateController override. Returns a ComponentController used to interact with this component.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override ComponentController CreateController (
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Function CreateController( _
context As RenderContext _
) As ComponentController

Parameters

context

A RenderContext instance.

Return Value

Instance of the LegendController class.

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.Draw Method

LegendRenderer.Draw Method
[image]

Component.Draw override. Draws legend elements in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.EffectiveBorderPen Method

LegendRenderer.EffectiveBorderPen Method
[image]

Gets the Pen that should be used to draw the legend borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Pen EffectiveBorderPen (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveBorderPen( _
context As RenderContext _
) As Pen

Parameters

context

A RenderContext instance.

Return Value

A Pen instance.

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.EffectiveBorderStroke Method

LegendRenderer.EffectiveBorderStroke Method
[image]

Gets the Brush that should be used to stroke the legend borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush EffectiveBorderStroke (
RenderContext context
)

Visual Basic [image] Copy Code

Public Function EffectiveBorderStroke( _
context As RenderContext _
) As Brush

Parameters

context

A RenderContext instance.

Return Value

A Brush instance.

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.EffectiveBorderStrokeThickness Method

LegendRenderer.EffectiveBorderStrokeThickness Method
[image]

Gets the thickness of border strokes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected double EffectiveBorderStrokeThickness (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveBorderStrokeThickness( _
context As RenderContext _
) As Double

Parameters

context

A RenderContext instance.

Return Value

A double value.

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.EffectiveFill Method

LegendRenderer.EffectiveFill Method
[image]

Gets the Brush that should be used to fill the legend background.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush EffectiveFill (
RenderContext context
)

Visual Basic [image] Copy Code

Public Function EffectiveFill( _
context As RenderContext _
) As Brush

Parameters

context

A RenderContext instance.

Return Value

A Brush instance.

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.EffectiveStrokeDashStyle Method

LegendRenderer.EffectiveStrokeDashStyle Method
[image]

Gets the dash style of border strokes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected DashStyle EffectiveStrokeDashStyle (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveStrokeDashStyle( _
context As RenderContext _
) As DashStyle

Parameters

context

A RenderContext instance.

Return Value

A member of the DashStyle enumeration.

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.EffectiveTitleBrush Method

LegendRenderer.EffectiveTitleBrush Method
[image]

Gets the Brush that should be used to draw the legend's Title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Brush EffectiveTitleBrush (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveTitleBrush( _
context As RenderContext _
) As Brush

Parameters

context

A RenderContext instance.

Return Value

A System.Drawing.Brush instance.

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.EffectiveTitleFont Method

LegendRenderer.EffectiveTitleFont Method
[image]

Gets the Font that should be used to draw the legend's Title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Font EffectiveTitleFont (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveTitleFont( _
context As RenderContext _
) As Font

Parameters

context

A RenderContext instance.

Return Value

A System.Drawing.Font instance.

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.Measure Method

LegendRenderer.Measure Method
[image]

Component.Measure override. Measures the desired size of this component.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void Measure (
double maxWidth,
double maxHeight,
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub Measure( _
maxWidth As Double, _
maxHeight As Double, _
context As RenderContext _
)

Parameters

maxWidth

The maximum width provided by parent component.

maxHeight

The maximum height provided by parent component.

context

A RenderContext instance.

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer Properties

LegendRenderer Properties
[image]

Public Properties

Name | Description
AllowMove | Gets or sets a value indicating whether users are allowed to move this legend.
Background | Gets or sets the Brush that should be used to fill the background of this legend.
BorderStroke | Gets or sets the Brush that should be used to stroke the borders of this legend.
BorderStrokeDashStyle | Gets or sets the stroke dash style of legend borders.
BorderStrokeThickness | Gets or sets the stroke thickness of legend borders.
Content | Gets or sets a list of SeriesRenderer objects whose Series should be displayed in this legend.
Padding | Gets or sets the padding space between content and borders of this legend.
ShowTitle | Gets or sets a value indicating whether to display the legend title.
Spacing | Gets or sets the distance between adjacent entries in the legend.
Title | Gets or sets the legend's title.
TitleBrush | Gets or sets the Brush that should be used to draw the legend's Title.
TitleFontName | Gets or sets the name of font that should be used to draw the legend's Title.
TitleFontSize | Gets or sets the size of font that should be used to draw the legend's Title.
TitleFontStyle | Gets or sets the style of font that should be used to draw the legend's Title.

See Also

LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.AllowMove Property

LegendRenderer.AllowMove Property
[image]

Gets or sets a value indicating whether users are allowed to move this legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool AllowMove { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMove As Boolean

Property Value

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.Background Property

LegendRenderer.Background Property
[image]

Gets or sets the Brush that should be used to fill the background of this legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush Background { get; set; }

Visual Basic [image] Copy Code

Public Property Background As Brush

Property Value

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.BorderStroke Property

LegendRenderer.BorderStroke Property
[image]

Gets or sets the Brush that should be used to stroke the borders of this legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush BorderStroke { get; set; }

Visual Basic [image] Copy Code

Public Property BorderStroke As Brush

Property Value

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.BorderStrokeDashStyle Property

LegendRenderer.BorderStrokeDashStyle Property
[image]

Gets or sets the stroke dash style of legend borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<DashStyle> BorderStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property BorderStrokeDashStyle As Nullable(Of DashStyle)

Property Value

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.BorderStrokeThickness Property

LegendRenderer.BorderStrokeThickness Property
[image]

Gets or sets the stroke thickness of legend borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> BorderStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property BorderStrokeThickness As Nullable(Of Double)

Property Value

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.Content Property

LegendRenderer.Content Property
[image]

Gets or sets a list of SeriesRenderer objects whose Series should be displayed in this legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public ObservableCollection<SeriesRenderer> Content { get; set; }

Visual Basic [image] Copy Code

Public Property Content As ObservableCollection(Of SeriesRenderer)

Property Value

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.Padding Property

LegendRenderer.Padding Property
[image]

Gets or sets the padding space between content and borders of this legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Double

Property Value

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.ShowTitle Property

LegendRenderer.ShowTitle Property
[image]

Gets or sets a value indicating whether to display the legend title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool ShowTitle { get; set; }

Visual Basic [image] Copy Code

Public Property ShowTitle As Boolean

Property Value

true to show the legend Title, or false otherwise. The default value is true.

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.Spacing Property

LegendRenderer.Spacing Property
[image]

Gets or sets the distance between adjacent entries in the legend.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Spacing { get; set; }

Visual Basic [image] Copy Code

Public Property Spacing As Double

Property Value

A double value specifying the distance between legend elements. The default value is 5.

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.Title Property

LegendRenderer.Title Property
[image]

Gets or sets the legend's title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.TitleBrush Property

LegendRenderer.TitleBrush Property
[image]

Gets or sets the Brush that should be used to draw the legend's Title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush TitleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TitleBrush As Brush

Property Value

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.TitleFontName Property

LegendRenderer.TitleFontName Property
[image]

Gets or sets the name of font that should be used to draw the legend's Title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string TitleFontName { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontName As String

Property Value

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.TitleFontSize Property

LegendRenderer.TitleFontSize Property
[image]

Gets or sets the size of font that should be used to draw the legend's Title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> TitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontSize As Nullable(Of Double)

Property Value

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LegendRenderer.TitleFontStyle Property

LegendRenderer.TitleFontStyle Property
[image]

Gets or sets the style of font that should be used to draw the legend's Title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<FontStyle> TitleFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontStyle As Nullable(Of FontStyle)

Property Value

See Also

LegendRenderer Members
LegendRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LineRenderer Class

LineRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws series as polylines.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class LineRenderer : Renderer2D

Visual Basic [image] Copy Code

Public Class LineRenderer
Inherits Renderer2D

Remarks

LineRenderer must be placed inside a Plot2D component. It draws the values of each series as a an open polyline. If the GetLabel method of Series object returns InnerLabel or OuterLabel strings, they are rendered near the polyline point corresponding to respective data item.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.LineRenderer
MindFusion.Charting.CurveRenderer

See Also

LineRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.LineRenderer Members

LineRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws series as polylines.

The following tables list the members exposed by the LineRenderer type.

Public Constructors

Name | Description
LineRenderer | Initializes a new instance of the LineRenderer class.

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

LineRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LineRenderer Constructor

LineRenderer Constructor
[image]

Initializes a new instance of the LineRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public LineRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as polylines.

See Also

LineRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LineRenderer Methods

LineRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

LineRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LineRenderer.Draw Method

LineRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

LineRenderer Members
LineRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.LineType Enumeration

LineType Enumeration
[image]

Identifies how to connect adjacent data points in line and area charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public enum LineType

Visual Basic [image] Copy Code

Public Enum LineType

Members

Member name | Description
Curve | Connect points using a cardinal spline.
Polyline | Connect points using straight line segments.
Step | Connect points using steps.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.Margins Class

Margins Class
[image]

Describes rectangular margins.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class Margins

Visual Basic [image] Copy Code

Public Class Margins

Inheritance Hierarchy

System.Object
MindFusion.Charting.Margins

See Also

Margins Members
MindFusion.Charting Namespace


MindFusion.Charting.Margins Members

Margins Members
Constructors Properties
[image]

Describes rectangular margins.

The following tables list the members exposed by the Margins type.

Public Constructors

Name | Description
Margins | Overloaded.

Public Properties

Name | Description
Bottom | Gets or sets the width of the bottom side of the frame.
Height | Returns the sum of Top and Bottom margins.
Left | Gets or sets the width of the left side of the frame.
Right | Gets or sets the width of the right side of the frame.
Top | Gets or sets the width of the top side of the frame.
Width | Returns the sum of Left and Right margins.

See Also

Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins Constructor

Margins Constructor
[image]

Overload List

Name | Description
Margins (Double) | Initializes a new instance of the Margins structure.
Margins (Double, Double, Double, Double) | Initializes a new instance of the Margins structure.

See Also

Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins Constructor (Double)

Margins Constructor (Double)
See Also
[image]

Initializes a new instance of the Margins structure.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Margins (
double uniformLength
)

Visual Basic [image] Copy Code

Public New ( _
uniformLength As Double _
)

Parameters

uniformLength

See Also

Margins Constructor Overload List
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins Constructor (Double, Double, Double, Double)

Margins Constructor (Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the Margins structure.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Margins (
double left,
double top,
double right,
double bottom
)

Visual Basic [image] Copy Code

Public New ( _
left As Double, _
top As Double, _
right As Double, _
bottom As Double _
)

Parameters

left

top

right

bottom

See Also

Margins Constructor Overload List
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins Properties

Margins Properties
[image]

Public Properties

Name | Description
Bottom | Gets or sets the width of the bottom side of the frame.
Height | Returns the sum of Top and Bottom margins.
Left | Gets or sets the width of the left side of the frame.
Right | Gets or sets the width of the right side of the frame.
Top | Gets or sets the width of the top side of the frame.
Width | Returns the sum of Left and Right margins.

See Also

Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins.Bottom Property

Margins.Bottom Property
[image]

Gets or sets the width of the bottom side of the frame.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Bottom { get; set; }

Visual Basic [image] Copy Code

Public Property Bottom As Double

Property Value

See Also

Margins Members
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins.Height Property

Margins.Height Property
[image]

Returns the sum of Top and Bottom margins.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Height { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Height As Double

Property Value

See Also

Margins Members
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins.Left Property

Margins.Left Property
[image]

Gets or sets the width of the left side of the frame.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Left { get; set; }

Visual Basic [image] Copy Code

Public Property Left As Double

Property Value

See Also

Margins Members
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins.Right Property

Margins.Right Property
[image]

Gets or sets the width of the right side of the frame.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Right { get; set; }

Visual Basic [image] Copy Code

Public Property Right As Double

Property Value

See Also

Margins Members
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins.Top Property

Margins.Top Property
[image]

Gets or sets the width of the top side of the frame.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Top { get; set; }

Visual Basic [image] Copy Code

Public Property Top As Double

Property Value

See Also

Margins Members
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.Margins.Width Property

Margins.Width Property
[image]

Returns the sum of Left and Right margins.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Width { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Width As Double

Property Value

See Also

Margins Members
Margins Class
MindFusion.Charting Namespace


MindFusion.Charting.MarginsConverter Class

MarginsConverter Class
[image]

The TypeConverter of the Margins structure.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class MarginsConverter : TypeConverter

Visual Basic [image] Copy Code

Public Class MarginsConverter
Inherits TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Charting.MarginsConverter

See Also

MarginsConverter Members
MindFusion.Charting Namespace


MindFusion.Charting.MarginsConverter Members

MarginsConverter Members
Constructors Methods
[image]

The TypeConverter of the Margins structure.

The following tables list the members exposed by the MarginsConverter type.

Public Constructors

Name | Description
MarginsConverter |

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

MarginsConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.MarginsConverter Constructor

MarginsConverter Constructor
[image]

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public MarginsConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MarginsConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.MarginsConverter Methods

MarginsConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

MarginsConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.MarginsConverter.CanConvertFrom Method

MarginsConverter.CanConvertFrom Method
[image]

TypeConverter.CanConvertFrom override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertFrom( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context

sourceType

Return Value

See Also

MarginsConverter Members
MarginsConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.MarginsConverter.CanConvertTo Method

MarginsConverter.CanConvertTo Method
[image]

TypeConverter.CanConvertTo override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertTo( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context

destinationType

Return Value

See Also

MarginsConverter Members
MarginsConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.MarginsConverter.ConvertFrom Method

MarginsConverter.ConvertFrom Method
[image]

TypeConverter.ConvertFrom override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertFrom( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context

culture

value

Return Value

See Also

MarginsConverter Members
MarginsConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.MarginsConverter.ConvertTo Method

MarginsConverter.ConvertTo Method
[image]

TypeConverter.ConvertTo override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertTo( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context

culture

value

destinationType

Return Value

See Also

MarginsConverter Members
MarginsConverter Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle Class

MixedSeriesStyle Class
[image]

Implements SeriesStyle using mixed per-element and uniform values for attributes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class MixedSeriesStyle : SeriesStyle

Visual Basic [image] Copy Code

Public Class MixedSeriesStyle
Implements SeriesStyle

Inheritance Hierarchy

System.Object
MindFusion.Charting.MixedSeriesStyle

See Also

MixedSeriesStyle Members
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle Members

MixedSeriesStyle Members
Constructors Properties Methods
[image]

Implements SeriesStyle using mixed per-element and uniform values for attributes.

The following tables list the members exposed by the MixedSeriesStyle type.

Public Constructors

Name | Description
MixedSeriesStyle | Overloaded.

Public Properties

Name | Description
CommonFills | Gets or sets a list of brushes, each Brush used to fill all elements of a series.
CommonStrokeDashStyles | Gets or sets a list of dash styles, each style applied to all elements of a series.
CommonStrokes | Gets or sets a list of brushes, each Brush used to stroke all elements of a series.
CommonStrokeThicknesses | Gets or sets a list of stroke thicknesses, each thickness applied to all elements of a series.
Fills | Gets or sets a list of Brush lists, each list used to draw a different series, and each Brush used to fill individual elements of a series.
StrokeDashStyles | Gets or sets a list of DashStyle lists, each list used to stroke a different series, and each DashStyle value specifying style of individual elements of a series.
Strokes | Gets or sets a list of Brush lists, each list used to stroke a different series, and each Brush used to stroke individual elements of a series.
StrokeThicknesses | Gets or sets a list of double lists, each list used to stroke a different series, and each double value specifying thickness of individual elements of a series.
UniformFill | Gets or sets a Brush used to fill all elements of all series uniformly.
UniformStroke | Gets or sets a Brush used to stroke all elements of all series uniformly.
UniformStrokeDashStyle | Gets or sets uniform stroke dash style for all elements of all series.
UniformStrokeThickness | Gets or sets uniform stroke thickness for all elements of all series.

Public Methods

Name | Description
Fill | Implements SeriesStyle.Stroke. Returns a Brush instance from Fills, CommonFills or UniformFill properties.
Stroke | Implements SeriesStyle.Stroke. Returns a Brush instance from Strokes, CommonStrokes or UniformStroke properties.
StrokeDashStyle | Implements SeriesStyle.StrokeDashStyle. Returns a value from StrokeDashStyles, CommonStrokeDashStyles or UniformStrokeDashStyle properties.
StrokeThickness | Implements SeriesStyle.StrokeThickness. Returns a value from StrokeThicknesses, CommonStrokeThicknesses or UniformStrokeThickness properties.

See Also

MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle Constructor

MixedSeriesStyle Constructor
[image]

Overload List

Name | Description
MixedSeriesStyle () | Initializes a new instance of the MixedSeriesStyle class.
MixedSeriesStyle (Brush, Brush, Double, DashStyle) | Initializes a new instance of the MixedSeriesStyle class.

See Also

MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle Constructor ()

MixedSeriesStyle Constructor ()
See Also
[image]

Initializes a new instance of the MixedSeriesStyle class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public MixedSeriesStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MixedSeriesStyle Constructor Overload List
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle Constructor (Brush, Brush, Double, DashStyle)

MixedSeriesStyle Constructor (Brush, Brush, Double, DashStyle)
See Also
[image]

Initializes a new instance of the MixedSeriesStyle class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public MixedSeriesStyle (
Brush fill,
Brush stroke,
double strokeThickness,
DashStyle strokeDashStyle
)

Visual Basic [image] Copy Code

Public New ( _
fill As Brush, _
stroke As Brush, _
strokeThickness As Double, _
strokeDashStyle As DashStyle _
)

Parameters

fill

A Brush used to fill all series elements.

stroke

A Brush used to stroke all series elements.

strokeThickness

Uniform thickness of series elements' strokes.

strokeDashStyle

Uniform dash style of series elements' strokes.

See Also

MixedSeriesStyle Constructor Overload List
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle Methods

MixedSeriesStyle Methods
[image]

Public Methods

Name | Description
Fill | Implements SeriesStyle.Stroke. Returns a Brush instance from Fills, CommonFills or UniformFill properties.
Stroke | Implements SeriesStyle.Stroke. Returns a Brush instance from Strokes, CommonStrokes or UniformStroke properties.
StrokeDashStyle | Implements SeriesStyle.StrokeDashStyle. Returns a value from StrokeDashStyles, CommonStrokeDashStyles or UniformStrokeDashStyle properties.
StrokeThickness | Implements SeriesStyle.StrokeThickness. Returns a value from StrokeThicknesses, CommonStrokeThicknesses or UniformStrokeThickness properties.

See Also

MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.Fill Method

MixedSeriesStyle.Fill Method
[image]

Implements SeriesStyle.Stroke. Returns a Brush instance from Fills, CommonFills or UniformFill properties.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush Fill (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function Fill( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Brush

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A Brush instance.

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.Stroke Method

MixedSeriesStyle.Stroke Method
[image]

Implements SeriesStyle.Stroke. Returns a Brush instance from Strokes, CommonStrokes or UniformStroke properties.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush Stroke (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function Stroke( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Brush

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A Brush instance.

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.StrokeDashStyle Method

MixedSeriesStyle.StrokeDashStyle Method
[image]

Implements SeriesStyle.StrokeDashStyle. Returns a value from StrokeDashStyles, CommonStrokeDashStyles or UniformStrokeDashStyle properties.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<DashStyle> StrokeDashStyle (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function StrokeDashStyle( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Nullable(Of DashStyle)

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A nullable DashStyle value specifying stroke dash style.

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.StrokeThickness Method

MixedSeriesStyle.StrokeThickness Method
[image]

Implements SeriesStyle.StrokeThickness. Returns a value from StrokeThicknesses, CommonStrokeThicknesses or UniformStrokeThickness properties.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> StrokeThickness (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function StrokeThickness( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Nullable(Of Double)

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A nullable double value specifying stroke thickness.

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle Properties

MixedSeriesStyle Properties
[image]

Public Properties

Name | Description
CommonFills | Gets or sets a list of brushes, each Brush used to fill all elements of a series.
CommonStrokeDashStyles | Gets or sets a list of dash styles, each style applied to all elements of a series.
CommonStrokes | Gets or sets a list of brushes, each Brush used to stroke all elements of a series.
CommonStrokeThicknesses | Gets or sets a list of stroke thicknesses, each thickness applied to all elements of a series.
Fills | Gets or sets a list of Brush lists, each list used to draw a different series, and each Brush used to fill individual elements of a series.
StrokeDashStyles | Gets or sets a list of DashStyle lists, each list used to stroke a different series, and each DashStyle value specifying style of individual elements of a series.
Strokes | Gets or sets a list of Brush lists, each list used to stroke a different series, and each Brush used to stroke individual elements of a series.
StrokeThicknesses | Gets or sets a list of double lists, each list used to stroke a different series, and each double value specifying thickness of individual elements of a series.
UniformFill | Gets or sets a Brush used to fill all elements of all series uniformly.
UniformStroke | Gets or sets a Brush used to stroke all elements of all series uniformly.
UniformStrokeDashStyle | Gets or sets uniform stroke dash style for all elements of all series.
UniformStrokeThickness | Gets or sets uniform stroke thickness for all elements of all series.

See Also

MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.CommonFills Property

MixedSeriesStyle.CommonFills Property
[image]

Gets or sets a list of brushes, each Brush used to fill all elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<Brush> CommonFills { get; set; }

Visual Basic [image] Copy Code

Public Property CommonFills As List(Of Brush)

Property Value

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.CommonStrokeDashStyles Property

MixedSeriesStyle.CommonStrokeDashStyles Property
[image]

Gets or sets a list of dash styles, each style applied to all elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<DashStyle> CommonStrokeDashStyles { get; set; }

Visual Basic [image] Copy Code

Public Property CommonStrokeDashStyles As List(Of DashStyle)

Property Value

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.CommonStrokes Property

MixedSeriesStyle.CommonStrokes Property
[image]

Gets or sets a list of brushes, each Brush used to stroke all elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<Brush> CommonStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property CommonStrokes As List(Of Brush)

Property Value

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.CommonStrokeThicknesses Property

MixedSeriesStyle.CommonStrokeThicknesses Property
[image]

Gets or sets a list of stroke thicknesses, each thickness applied to all elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<Double> CommonStrokeThicknesses { get; set; }

Visual Basic [image] Copy Code

Public Property CommonStrokeThicknesses As List(Of Double)

Property Value

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.Fills Property

MixedSeriesStyle.Fills Property
[image]

Gets or sets a list of Brush lists, each list used to draw a different series, and each Brush used to fill individual elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<List<Brush>> Fills { get; set; }

Visual Basic [image] Copy Code

Public Property Fills As List(Of List(Of Brush))

Property Value

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.StrokeDashStyles Property

MixedSeriesStyle.StrokeDashStyles Property
[image]

Gets or sets a list of DashStyle lists, each list used to stroke a different series, and each DashStyle value specifying style of individual elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<List<DashStyle>> StrokeDashStyles { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashStyles As List(Of List(Of DashStyle))

Property Value

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.Strokes Property

MixedSeriesStyle.Strokes Property
[image]

Gets or sets a list of Brush lists, each list used to stroke a different series, and each Brush used to stroke individual elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<List<Brush>> Strokes { get; set; }

Visual Basic [image] Copy Code

Public Property Strokes As List(Of List(Of Brush))

Property Value

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.StrokeThicknesses Property

MixedSeriesStyle.StrokeThicknesses Property
[image]

Gets or sets a list of double lists, each list used to stroke a different series, and each double value specifying thickness of individual elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<List<Double>> StrokeThicknesses { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThicknesses As List(Of List(Of Double))

Property Value

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.UniformFill Property

MixedSeriesStyle.UniformFill Property
[image]

Gets or sets a Brush used to fill all elements of all series uniformly.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush UniformFill { get; set; }

Visual Basic [image] Copy Code

Public Property UniformFill As Brush

Property Value

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.UniformStroke Property

MixedSeriesStyle.UniformStroke Property
[image]

Gets or sets a Brush used to stroke all elements of all series uniformly.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush UniformStroke { get; set; }

Visual Basic [image] Copy Code

Public Property UniformStroke As Brush

Property Value

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.UniformStrokeDashStyle Property

MixedSeriesStyle.UniformStrokeDashStyle Property
[image]

Gets or sets uniform stroke dash style for all elements of all series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<DashStyle> UniformStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property UniformStrokeDashStyle As Nullable(Of DashStyle)

Property Value

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.MixedSeriesStyle.UniformStrokeThickness Property

MixedSeriesStyle.UniformStrokeThickness Property
[image]

Gets or sets uniform stroke thickness for all elements of all series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> UniformStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property UniformStrokeThickness As Nullable(Of Double)

Property Value

See Also

MixedSeriesStyle Members
MixedSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.Pair(T1, T2) Class

Pair(T1, T2) Class
[image]

Contains two values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class Pair<T1, T2>

Visual Basic [image] Copy Code

Public Class Pair(Of T1, T2)

Inheritance Hierarchy

System.Object
MindFusion.Charting.Pair(T1, T2)

See Also

Pair(T1, T2) Members
MindFusion.Charting Namespace


MindFusion.Charting.Pair(T1, T2) Members

Pair(T1, T2) Members
Constructors Properties Methods
[image]

Contains two values.

The following tables list the members exposed by the Pair(T1, T2) type.

Public Constructors

Name | Description
Pair | Overloaded.

Public Properties

Name | Description
First | Gets or sets the first value.
Second | Gets or sets the second value.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Pair(T1, T2) Class
MindFusion.Charting Namespace


MindFusion.Charting.Pair(T1, T2) Constructor

Pair(T1, T2) Constructor
[image]

Overload List

Name | Description
Pair(T1, T2) () | Initializes a new instance of the Pair class.
Pair(T1, T2) (T1, T2) | Initializes a new instance of the Pair class.

See Also

Pair(T1, T2) Class
MindFusion.Charting Namespace


MindFusion.Charting.Pair(T1, T2) Constructor ()

Pair(T1, T2) Constructor ()
See Also
[image]

Initializes a new instance of the Pair class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Pair<T1, T2> ()

Visual Basic [image] Copy Code

Public Sub New(Of T1, T2) ()

See Also

Pair(T1, T2) Constructor Overload List
Pair(T1, T2) Class
MindFusion.Charting Namespace


MindFusion.Charting.Pair(T1, T2) Constructor (T1, T2)

Pair(T1, T2) Constructor (T1, T2)
See Also
[image]

Initializes a new instance of the Pair class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Pair<T1, T2> (
T1 first,
T2 second
)

Visual Basic [image] Copy Code

Public New (Of T1, T2) ( _
first As T1, _
second As T2 _
)

Parameters

first

The first value.

second

The second value.

See Also

Pair(T1, T2) Constructor Overload List
Pair(T1, T2) Class
MindFusion.Charting Namespace


MindFusion.Charting.Pair(T1, T2) Methods

Pair(T1, T2) Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Pair(T1, T2) Class
MindFusion.Charting Namespace


MindFusion.Charting.Pair(T1, T2).ToString Method

Pair(T1, T2).ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representation of the pair.

See Also

Pair(T1, T2) Members
Pair(T1, T2) Class
MindFusion.Charting Namespace


MindFusion.Charting.Pair(T1, T2) Properties

Pair(T1, T2) Properties
[image]

Public Properties

Name | Description
First | Gets or sets the first value.
Second | Gets or sets the second value.

See Also

Pair(T1, T2) Class
MindFusion.Charting Namespace


MindFusion.Charting.Pair(T1, T2).First Property

Pair(T1, T2).First Property
[image]

Gets or sets the first value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public T1 First { get; set; }

Visual Basic [image] Copy Code

Public Property First As T1

Property Value

See Also

Pair(T1, T2) Members
Pair(T1, T2) Class
MindFusion.Charting Namespace


MindFusion.Charting.Pair(T1, T2).Second Property

Pair(T1, T2).Second Property
[image]

Gets or sets the second value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public T2 Second { get; set; }

Visual Basic [image] Copy Code

Public Property Second As T2

Property Value

See Also

Pair(T1, T2) Members
Pair(T1, T2) Class
MindFusion.Charting Namespace


MindFusion.Charting.PanController Class

PanController Class
[image]

Represents a controller that pans its plot's data range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class PanController : Plot2DController

Visual Basic [image] Copy Code

Public Class PanController
Inherits Plot2DController

Inheritance Hierarchy

System.Object
MindFusion.Charting.PlotController
MindFusion.Charting.Plot2DController
MindFusion.Charting.PanController

See Also

PanController Members
MindFusion.Charting Namespace


MindFusion.Charting.PanController Members

PanController Members
Constructors Fields Properties Methods
[image]

Represents a controller that pans its plot's data range.

The following tables list the members exposed by the PanController type.

Public Constructors

Name | Description
PanController | Initializes a new instance of the PanController class.

Protected Fields

Name | Description
axisRanges | Contains information about Axis ranges processed by this controller. (Inherited from Plot2DController.)
renderContext | The current RenderContext. (Inherited from PlotController.)

Public Properties

Name | Description
Component | Gets the component controlled by this PlotController. (Inherited from PlotController.)
EnableAnimation | Gets or sets whether to enable pan inertia.
Vertical | Gets or sets a value indicating whether interaction is done along the X or Y axis. (Inherited from Plot2DController.)

Public Methods

Name | Description
DrawInteraction | Implements ComponentController.DrawInteraction. Draws a representation of the current state of user interaction on specified IGraphics surface. (Inherited from PlotController.)
GetRunningAnimation | For internal use.
OnMouseDown | Plot2DController.OnMouseDown override. Called when the user presses a mouse button.
OnMouseMove | PlotController.OnMouseMove override. Called when the user moves the mouse.
OnMouseUp | PlotController.OnMouseUp override. Called when the user releases a mouse button.

Protected Methods

Name | Description
PlotToAxisValue | Converts a plot pixel position to a logical value from specified axis' coordinate system. (Inherited from Plot2DController.)

See Also

PanController Class
MindFusion.Charting Namespace


MindFusion.Charting.PanController Constructor

PanController Constructor
[image]

Initializes a new instance of the PanController class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PanController (
RenderContext renderContext,
bool vertical
)

Visual Basic [image] Copy Code

Public New ( _
renderContext As RenderContext, _
vertical As Boolean _
)

Parameters

renderContext

A RenderContext instance.

vertical

true to implement interaction along the Y axis, or false for the X axis.

See Also

PanController Class
MindFusion.Charting Namespace


MindFusion.Charting.PanController Methods

PanController Methods
[image]

Public Methods

Name | Description
DrawInteraction | Implements ComponentController.DrawInteraction. Draws a representation of the current state of user interaction on specified IGraphics surface. (Inherited from PlotController.)
GetRunningAnimation | For internal use.
OnMouseDown | Plot2DController.OnMouseDown override. Called when the user presses a mouse button.
OnMouseMove | PlotController.OnMouseMove override. Called when the user moves the mouse.
OnMouseUp | PlotController.OnMouseUp override. Called when the user releases a mouse button.

Protected Methods

Name | Description
PlotToAxisValue | Converts a plot pixel position to a logical value from specified axis' coordinate system. (Inherited from Plot2DController.)

See Also

PanController Class
MindFusion.Charting Namespace


MindFusion.Charting.PanController.GetRunningAnimation Method

PanController.GetRunningAnimation Method
[image]

For internal use.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override ComponentAnimation GetRunningAnimation ()

Visual Basic [image] Copy Code

Public Overrides Function GetRunningAnimation () As ComponentAnimation

Return Value

An instance of a ComponentAnimation -derived class.

See Also

PanController Members
PanController Class
MindFusion.Charting Namespace


MindFusion.Charting.PanController.OnMouseDown Method

PanController.OnMouseDown Method
[image]

Plot2DController.OnMouseDown override. Called when the user presses a mouse button.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void OnMouseDown (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overrides Sub OnMouseDown( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

PanController Members
PanController Class
MindFusion.Charting Namespace


MindFusion.Charting.PanController.OnMouseMove Method

PanController.OnMouseMove Method
[image]

PlotController.OnMouseMove override. Called when the user moves the mouse.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void OnMouseMove (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overrides Sub OnMouseMove( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

PanController Members
PanController Class
MindFusion.Charting Namespace


MindFusion.Charting.PanController.OnMouseUp Method

PanController.OnMouseUp Method
[image]

PlotController.OnMouseUp override. Called when the user releases a mouse button.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void OnMouseUp (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overrides Sub OnMouseUp( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

PanController Members
PanController Class
MindFusion.Charting Namespace


MindFusion.Charting.PanController Properties

PanController Properties
[image]

Public Properties

Name | Description
Component | Gets the component controlled by this PlotController. (Inherited from PlotController.)
EnableAnimation | Gets or sets whether to enable pan inertia.
Vertical | Gets or sets a value indicating whether interaction is done along the X or Y axis. (Inherited from Plot2DController.)

See Also

PanController Class
MindFusion.Charting Namespace


MindFusion.Charting.PanController.EnableAnimation Property

PanController.EnableAnimation Property
[image]

Gets or sets whether to enable pan inertia.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool EnableAnimation { get; set; }

Visual Basic [image] Copy Code

Public Property EnableAnimation As Boolean

Property Value

See Also

PanController Members
PanController Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle Class

PerElementSeriesStyle Class
[image]

Implements SeriesStyle using different attributes for each data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class PerElementSeriesStyle : SeriesStyle

Visual Basic [image] Copy Code

Public Class PerElementSeriesStyle
Implements SeriesStyle

Inheritance Hierarchy

System.Object
MindFusion.Charting.PerElementSeriesStyle

See Also

PerElementSeriesStyle Members
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle Members

PerElementSeriesStyle Members
Constructors Properties Methods
[image]

Implements SeriesStyle using different attributes for each data item.

The following tables list the members exposed by the PerElementSeriesStyle type.

Public Constructors

Name | Description
PerElementSeriesStyle | Overloaded.

Public Properties

Name | Description
Fills | Gets or sets a list of Brush lists, each list used to draw a different series, and each Brush used to fill individual elements of a series.
StrokeDashStyles | Gets or sets a list of DashStyle lists, each list used to stroke a different series, and each DashStyle value specifying style of individual elements of a series.
Strokes | Gets or sets a list of Brush lists, each list used to stroke a different series, and each Brush used to stroke individual elements of a series.
StrokeThicknesses | Gets or sets a list of double lists, each list used to stroke a different series, and each double value specifying thickness of individual elements of a series.

Public Methods

Name | Description
Fill | Implements SeriesStyle.Fill. Returns a Brush from the Fills list that matches specified series and data indices.
Stroke | Implements SeriesStyle.Stroke. Returns a Brush from the Strokes list that matches specified series and data indices.
StrokeDashStyle | Implements SeriesStyle.StrokeDashStyle. Returns a value from the StrokeDashStyles list that matches specified series and data indices.
StrokeThickness | Implements SeriesStyle.StrokeThickness. Returns a value from the StrokeThicknesses list that matches specified series and data indices.

See Also

PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle Constructor

PerElementSeriesStyle Constructor
[image]

Overload List

Name | Description
PerElementSeriesStyle () | Initializes a new instance of PerElementSeriesStyle.
PerElementSeriesStyle (List(List(Brush)), List(List(Brush)), List(List(Double)), List(List(DashStyle))) | Initializes a new instance of PerElementSeriesStyle.

See Also

PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle Constructor ()

PerElementSeriesStyle Constructor ()
See Also
[image]

Initializes a new instance of PerElementSeriesStyle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PerElementSeriesStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PerElementSeriesStyle Constructor Overload List
PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle Constructor (List(List(Brush)), List(List(Brush)), List(List(Double)), List(List(DashStyle)))

PerElementSeriesStyle Constructor (List(List(Brush)), List(List(Brush)), List(List(Double)), List(List(DashStyle)))
See Also
[image]

Initializes a new instance of PerElementSeriesStyle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PerElementSeriesStyle (
List<List<Brush>> fills,
List<List<Brush>> strokes,
List<List<Double>> strokeThicknesses,
List<List<DashStyle>> strokeDashStyles
)

Visual Basic [image] Copy Code

Public New ( _
fills As List(Of List(Of Brush)), _
strokes As List(Of List(Of Brush)), _
strokeThicknesses As List(Of List(Of Double)), _
strokeDashStyles As List(Of List(Of DashStyle)) _
)

Parameters

fills

A list of Brush lists, each list used to draw a different series, and each Brush used to fill individual elements of a series.

strokes

A list of Brush lists, each list used to stroke a different series, and each Brush used to stroke individual elements of a series.

strokeThicknesses

A list of double lists, each list used to stroke a different series, and each double value specifying thickness of individual elements of a series.

strokeDashStyles

A list of DashStyle lists, each list used to stroke a different series, and each DashStyle value specifying style of individual elements of a series.

See Also

PerElementSeriesStyle Constructor Overload List
PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle Methods

PerElementSeriesStyle Methods
[image]

Public Methods

Name | Description
Fill | Implements SeriesStyle.Fill. Returns a Brush from the Fills list that matches specified series and data indices.
Stroke | Implements SeriesStyle.Stroke. Returns a Brush from the Strokes list that matches specified series and data indices.
StrokeDashStyle | Implements SeriesStyle.StrokeDashStyle. Returns a value from the StrokeDashStyles list that matches specified series and data indices.
StrokeThickness | Implements SeriesStyle.StrokeThickness. Returns a value from the StrokeThicknesses list that matches specified series and data indices.

See Also

PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle.Fill Method

PerElementSeriesStyle.Fill Method
[image]

Implements SeriesStyle.Fill. Returns a Brush from the Fills list that matches specified series and data indices.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush Fill (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function Fill( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Brush

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A Brush instance.

See Also

PerElementSeriesStyle Members
PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle.Stroke Method

PerElementSeriesStyle.Stroke Method
[image]

Implements SeriesStyle.Stroke. Returns a Brush from the Strokes list that matches specified series and data indices.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush Stroke (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function Stroke( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Brush

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A Brush instance.

See Also

PerElementSeriesStyle Members
PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle.StrokeDashStyle Method

PerElementSeriesStyle.StrokeDashStyle Method
[image]

Implements SeriesStyle.StrokeDashStyle. Returns a value from the StrokeDashStyles list that matches specified series and data indices.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<DashStyle> StrokeDashStyle (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function StrokeDashStyle( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Nullable(Of DashStyle)

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A nullable DashStyle value specifying stroke dash style.

See Also

PerElementSeriesStyle Members
PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle.StrokeThickness Method

PerElementSeriesStyle.StrokeThickness Method
[image]

Implements SeriesStyle.StrokeThickness. Returns a value from the StrokeThicknesses list that matches specified series and data indices.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> StrokeThickness (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function StrokeThickness( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Nullable(Of Double)

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A nullable double value specifying stroke thickness.

See Also

PerElementSeriesStyle Members
PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle Properties

PerElementSeriesStyle Properties
[image]

Public Properties

Name | Description
Fills | Gets or sets a list of Brush lists, each list used to draw a different series, and each Brush used to fill individual elements of a series.
StrokeDashStyles | Gets or sets a list of DashStyle lists, each list used to stroke a different series, and each DashStyle value specifying style of individual elements of a series.
Strokes | Gets or sets a list of Brush lists, each list used to stroke a different series, and each Brush used to stroke individual elements of a series.
StrokeThicknesses | Gets or sets a list of double lists, each list used to stroke a different series, and each double value specifying thickness of individual elements of a series.

See Also

PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle.Fills Property

PerElementSeriesStyle.Fills Property
[image]

Gets or sets a list of Brush lists, each list used to draw a different series, and each Brush used to fill individual elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<List<Brush>> Fills { get; set; }

Visual Basic [image] Copy Code

Public Property Fills As List(Of List(Of Brush))

Property Value

See Also

PerElementSeriesStyle Members
PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle.StrokeDashStyles Property

PerElementSeriesStyle.StrokeDashStyles Property
[image]

Gets or sets a list of DashStyle lists, each list used to stroke a different series, and each DashStyle value specifying style of individual elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<List<DashStyle>> StrokeDashStyles { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashStyles As List(Of List(Of DashStyle))

Property Value

See Also

PerElementSeriesStyle Members
PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle.Strokes Property

PerElementSeriesStyle.Strokes Property
[image]

Gets or sets a list of Brush lists, each list used to stroke a different series, and each Brush used to stroke individual elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<List<Brush>> Strokes { get; set; }

Visual Basic [image] Copy Code

Public Property Strokes As List(Of List(Of Brush))

Property Value

See Also

PerElementSeriesStyle Members
PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerElementSeriesStyle.StrokeThicknesses Property

PerElementSeriesStyle.StrokeThicknesses Property
[image]

Gets or sets a list of double lists, each list used to stroke a different series, and each double value specifying thickness of individual elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<List<Double>> StrokeThicknesses { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThicknesses As List(Of List(Of Double))

Property Value

See Also

PerElementSeriesStyle Members
PerElementSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle Class

PerSeriesStyle Class
[image]

Implements SeriesStyle using a different set of attributes for each series, where all elements in a single series have common appearance.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class PerSeriesStyle : SeriesStyle

Visual Basic [image] Copy Code

Public Class PerSeriesStyle
Implements SeriesStyle

Inheritance Hierarchy

System.Object
MindFusion.Charting.PerSeriesStyle

See Also

PerSeriesStyle Members
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle Members

PerSeriesStyle Members
Constructors Properties Methods
[image]

Implements SeriesStyle using a different set of attributes for each series, where all elements in a single series have common appearance.

The following tables list the members exposed by the PerSeriesStyle type.

Public Constructors

Name | Description
PerSeriesStyle | Overloaded.

Public Properties

Name | Description
Fills | Gets or sets a list of brushes, each Brush used to fill all elements of a series.
StrokeDashStyles | Gets or sets a list of dash styles, each style applied to all elements of a series.
Strokes | Gets or sets a list of brushes, each Brush used to stroke all elements of a series.
StrokeThicknesses | Gets or sets a list of stroke thicknesses, each thickness applied to all elements of a series.

Public Methods

Name | Description
Fill | Implements SeriesStyle.Fill. Returns a Brush from the Fills list that matches specified series index.
Stroke | Implements SeriesStyle.Stroke. Returns a Brush from the Strokes list that matches specified series index.
StrokeDashStyle | Implements SeriesStyle.StrokeDashStyle. Returns a value from the StrokeDashStyles list that matches specified series index.
StrokeThickness | Implements SeriesStyle.StrokeThickness. Returns a value from the StrokeThicknesses list that matches specified series index.

See Also

PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle Constructor

PerSeriesStyle Constructor
[image]

Overload List

Name | Description
PerSeriesStyle () | Initializes a new instance of the PerSeriesStyle class.
PerSeriesStyle (List(Brush), List(Brush), List(Double), List(DashStyle)) | Initializes a new instance of the PerSeriesStyle class.

See Also

PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle Constructor ()

PerSeriesStyle Constructor ()
See Also
[image]

Initializes a new instance of the PerSeriesStyle class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PerSeriesStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PerSeriesStyle Constructor Overload List
PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle Constructor (List(Brush), List(Brush), List(Double), List(DashStyle))

PerSeriesStyle Constructor (List(Brush), List(Brush), List(Double), List(DashStyle))
See Also
[image]

Initializes a new instance of the PerSeriesStyle class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PerSeriesStyle (
List<Brush> fills,
List<Brush> strokes,
List<Double> strokeThicknesses,
List<DashStyle> strokeDashStyles
)

Visual Basic [image] Copy Code

Public New ( _
fills As List(Of Brush), _
strokes As List(Of Brush), _
strokeThicknesses As List(Of Double), _
strokeDashStyles As List(Of DashStyle) _
)

Parameters

fills

A list of brushes, each Brush used to fill all elements of a series.

strokes

A list of brushes, each Brush used to stroke all elements of a series.

strokeThicknesses

A list of stroke thicknesses, each thickness applied to all elements of a series.

strokeDashStyles

A list of dash styles, each style applied to all elements of a series.

See Also

PerSeriesStyle Constructor Overload List
PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle Methods

PerSeriesStyle Methods
[image]

Public Methods

Name | Description
Fill | Implements SeriesStyle.Fill. Returns a Brush from the Fills list that matches specified series index.
Stroke | Implements SeriesStyle.Stroke. Returns a Brush from the Strokes list that matches specified series index.
StrokeDashStyle | Implements SeriesStyle.StrokeDashStyle. Returns a value from the StrokeDashStyles list that matches specified series index.
StrokeThickness | Implements SeriesStyle.StrokeThickness. Returns a value from the StrokeThicknesses list that matches specified series index.

See Also

PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle.Fill Method

PerSeriesStyle.Fill Method
[image]

Implements SeriesStyle.Fill. Returns a Brush from the Fills list that matches specified series index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush Fill (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function Fill( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Brush

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A Brush instance.

See Also

PerSeriesStyle Members
PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle.Stroke Method

PerSeriesStyle.Stroke Method
[image]

Implements SeriesStyle.Stroke. Returns a Brush from the Strokes list that matches specified series index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush Stroke (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function Stroke( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Brush

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A Brush instance.

See Also

PerSeriesStyle Members
PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle.StrokeDashStyle Method

PerSeriesStyle.StrokeDashStyle Method
[image]

Implements SeriesStyle.StrokeDashStyle. Returns a value from the StrokeDashStyles list that matches specified series index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<DashStyle> StrokeDashStyle (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function StrokeDashStyle( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Nullable(Of DashStyle)

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A nullable DashStyle value specifying stroke dash style.

See Also

PerSeriesStyle Members
PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle.StrokeThickness Method

PerSeriesStyle.StrokeThickness Method
[image]

Implements SeriesStyle.StrokeThickness. Returns a value from the StrokeThicknesses list that matches specified series index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> StrokeThickness (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function StrokeThickness( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Nullable(Of Double)

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A nullable double value specifying stroke thickness.

See Also

PerSeriesStyle Members
PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle Properties

PerSeriesStyle Properties
[image]

Public Properties

Name | Description
Fills | Gets or sets a list of brushes, each Brush used to fill all elements of a series.
StrokeDashStyles | Gets or sets a list of dash styles, each style applied to all elements of a series.
Strokes | Gets or sets a list of brushes, each Brush used to stroke all elements of a series.
StrokeThicknesses | Gets or sets a list of stroke thicknesses, each thickness applied to all elements of a series.

See Also

PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle.Fills Property

PerSeriesStyle.Fills Property
[image]

Gets or sets a list of brushes, each Brush used to fill all elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<Brush> Fills { get; set; }

Visual Basic [image] Copy Code

Public Property Fills As List(Of Brush)

Property Value

See Also

PerSeriesStyle Members
PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle.StrokeDashStyles Property

PerSeriesStyle.StrokeDashStyles Property
[image]

Gets or sets a list of dash styles, each style applied to all elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<DashStyle> StrokeDashStyles { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashStyles As List(Of DashStyle)

Property Value

See Also

PerSeriesStyle Members
PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle.Strokes Property

PerSeriesStyle.Strokes Property
[image]

Gets or sets a list of brushes, each Brush used to stroke all elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<Brush> Strokes { get; set; }

Visual Basic [image] Copy Code

Public Property Strokes As List(Of Brush)

Property Value

See Also

PerSeriesStyle Members
PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PerSeriesStyle.StrokeThicknesses Property

PerSeriesStyle.StrokeThicknesses Property
[image]

Gets or sets a list of stroke thicknesses, each thickness applied to all elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<Double> StrokeThicknesses { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThicknesses As List(Of Double)

Property Value

See Also

PerSeriesStyle Members
PerSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRadarRenderer Class

PieRadarRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws pie-radars, where data items are represented by circular sectors of equal central angles, and the sector corresponding to a data item has radius proportional to its value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class PieRadarRenderer : RadarRenderer

Visual Basic [image] Copy Code

Public Class PieRadarRenderer
Inherits RadarRenderer

Remarks

PieRadarRenderer must be placed inside a RadarPlot component. It draws each data item as a circular sector whose radius is proportional to the data value. If the GetLabel method of Series object returns InnerLabel string, the label is drawn inside its corresponding sector.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.RadarRenderer
MindFusion.Charting.PieRadarRenderer

See Also

PieRadarRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.PieRadarRenderer Members

PieRadarRenderer Members
Constructors Fields Properties Methods Events
[image]

A SeriesRenderer that draws pie-radars, where data items are represented by circular sectors of equal central angles, and the sector corresponding to a data item has radius proportional to its value.

The following tables list the members exposed by the PieRadarRenderer type.

Public Constructors

Name | Description
PieRadarRenderer | Initializes a new instance of the PieRadarRenderer class.

Protected Fields

Name | Description
series | A list of Series that should be rendered by this RadarRenderer. (Inherited from RadarRenderer.)

Public Properties

Name | Description
AlignToAxis | Gets or sets a value indicating whether sectors should be aligned to axes in the radar grid or centered around them.
AreaOpacity | Gets or sets the opacity of radar polygons. (Inherited from RadarRenderer.)
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this RadarRenderer. (Inherited from RadarRenderer.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implement SeriesContainer. (Inherited from RadarRenderer.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from RadarRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | Called to reset measure accumulators at the beginning of a measure pass. (Inherited from SeriesRenderer.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
Data | Returns the data value of specified series item. (Inherited from RadarRenderer.)
Draw | RadarRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | RadarRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSectors | Enumerates the pie-radar sectors corresponding to each series.
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from RadarRenderer.)
GetMaxValue | Gets the maximum value from all series located at specified index. (Inherited from RadarRenderer.)
GetMinValue | Gets the minimum value from all series located at specified index. (Inherited from RadarRenderer.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from RadarRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

PieRadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRadarRenderer Constructor

PieRadarRenderer Constructor
[image]

Initializes a new instance of the PieRadarRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PieRadarRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered by this object.

See Also

PieRadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRadarRenderer Methods

PieRadarRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implement SeriesContainer. (Inherited from RadarRenderer.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from RadarRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | Called to reset measure accumulators at the beginning of a measure pass. (Inherited from SeriesRenderer.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
Data | Returns the data value of specified series item. (Inherited from RadarRenderer.)
Draw | RadarRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | RadarRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSectors | Enumerates the pie-radar sectors corresponding to each series.
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from RadarRenderer.)
GetMaxValue | Gets the maximum value from all series located at specified index. (Inherited from RadarRenderer.)
GetMinValue | Gets the minimum value from all series located at specified index. (Inherited from RadarRenderer.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from RadarRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)

See Also

PieRadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRadarRenderer.Draw Method

PieRadarRenderer.Draw Method
[image]

RadarRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

PieRadarRenderer Members
PieRadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRadarRenderer.DrawHighlight Method

PieRadarRenderer.DrawHighlight Method
[image]

RadarRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void DrawHighlight (
RenderContext context,
HitResult hitResult
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawHighlight( _
context As RenderContext, _
hitResult As HitResult _
)

Parameters

context

A RenderContext instance.

hitResult

A HitResult instance identifying highlighted data item.

See Also

PieRadarRenderer Members
PieRadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRadarRenderer.EnumSectors Method

PieRadarRenderer.EnumSectors Method
[image]

Enumerates the pie-radar sectors corresponding to each series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void EnumSectors (
RenderContext context,
PieRadarRenderer.ProcessSectors process
)

Visual Basic [image] Copy Code

Protected Sub EnumSectors( _
context As RenderContext, _
process As PieRadarRenderer.ProcessSectors _
)

Parameters

context

A RenderContext instance.

process

A ProcessSectors callback.

See Also

PieRadarRenderer Members
PieRadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRadarRenderer Properties

PieRadarRenderer Properties
[image]

Public Properties

Name | Description
AlignToAxis | Gets or sets a value indicating whether sectors should be aligned to axes in the radar grid or centered around them.
AreaOpacity | Gets or sets the opacity of radar polygons. (Inherited from RadarRenderer.)
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this RadarRenderer. (Inherited from RadarRenderer.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)

See Also

PieRadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRadarRenderer.AlignToAxis Property

PieRadarRenderer.AlignToAxis Property
[image]

Gets or sets a value indicating whether sectors should be aligned to axes in the radar grid or centered around them.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool AlignToAxis { get; set; }

Visual Basic [image] Copy Code

Public Property AlignToAxis As Boolean

Property Value

See Also

PieRadarRenderer Members
PieRadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRadarRenderer.ProcessSectors Delegate

PieRadarRenderer.ProcessSectors Delegate
[image]

Defines the signature of delegates called to process sectors generated for a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected delegate void PieRadarRenderer.ProcessSectors (
int seriesIndex,
List<PointF> points,
List<GraphicsPath> paths
)

Visual Basic [image] Copy Code

Protected Delegate Sub PieRadarRenderer.ProcessSectors( _
seriesIndex As Integer, _
points As List(Of PointF), _
paths As List(Of GraphicsPath) _
)

Parameters

seriesIndex

An integer index of series in Series list.

points

A list of PointF values containing the plot coordinates corresponding to data items.

paths

A list of GraphicsPath objects representing pie-radar sectors.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer Class

PieRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws pies in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class PieRenderer : SeriesRenderer

Visual Basic [image] Copy Code

Public Class PieRenderer
Inherits SeriesRenderer

Remarks

PieRenderer must be placed inside a PolarPlot component. It draws each data item as a circular sector whose angle is proportional to the data value. If the GetLabel method of Series object returns InnerLabel or OuterLabel strings, they are drawn respectively inside or outside of their corresponding sector.

If series' IsEmphasized method returns true for a data item, its respective slice is drawn detached from the pie. If using PieSeries to specify data, you can assign indices of detached slices through the DetachedSlices property.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.PieRenderer

See Also

PieRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer Members

PieRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws pies in its containing plot.

The following tables list the members exposed by the PieRenderer type.

Public Constructors

Name | Description
PieRenderer | Overloaded.

Public Properties

Name | Description
DetachOffset | Gets or sets the percentage by which detached slices are offset from pie center.
Dimension | Gets or sets the dimension index that should be used to read data from the Series.
Doughnut | Gets or sets a value indicating whether the pie should be rendered as a doughnut.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets the Series drawn by this PieRenderer.
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface.
HitTest | SeriesRenderer.HitTest override. Hit-tests the pieces representing data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | Called to reset measure accumulators at the beginning of a measure pass. (Inherited from SeriesRenderer.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted piece in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSlices | Enumerates the slices of the pie.
MeasureDataRange | Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from SeriesRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer Constructor

PieRenderer Constructor
[image]

Overload List

Name | Description
PieRenderer (Series) | Initializes a new instance of the PieRenderer class.
PieRenderer (Series, Int32) | Initializes a new instance of the PieRenderer class.

See Also

PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer Constructor (Series)

PieRenderer Constructor (Series)
See Also
[image]

Initializes a new instance of the PieRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PieRenderer (
Series series
)

Visual Basic [image] Copy Code

Public New ( _
series As Series _
)

Parameters

series

The Series that should be rendered as a pie.

See Also

PieRenderer Constructor Overload List
PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer Constructor (Series, Int32)

PieRenderer Constructor (Series, Int32)
See Also
[image]

Initializes a new instance of the PieRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PieRenderer (
Series series,
int dimension
)

Visual Basic [image] Copy Code

Public New ( _
series As Series, _
dimension As Integer _
)

Parameters

series

The Series that should be rendered as a pie.

dimension

Specifies the Series dimension index that should be used to access data.

See Also

PieRenderer Constructor Overload List
PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer Methods

PieRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface.
HitTest | SeriesRenderer.HitTest override. Hit-tests the pieces representing data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | Called to reset measure accumulators at the beginning of a measure pass. (Inherited from SeriesRenderer.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted piece in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSlices | Enumerates the slices of the pie.
MeasureDataRange | Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from SeriesRenderer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)

See Also

PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer.Draw Method

PieRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

PieRenderer Members
PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer.DrawHighlight Method

PieRenderer.DrawHighlight Method
[image]

SeriesRenderer.DrawHighlight override. Draws highlighted piece in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void DrawHighlight (
RenderContext context,
HitResult hitResult
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawHighlight( _
context As RenderContext, _
hitResult As HitResult _
)

Parameters

context

A RenderContext instance.

hitResult

A HitResult instance identifying highlighted data item.

See Also

PieRenderer Members
PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer.EnumSeries Method

PieRenderer.EnumSeries Method
[image]

Implements the SeriesContainer interface.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override IEnumerable<Series> EnumSeries ()

Visual Basic [image] Copy Code

Public Overrides Function EnumSeries () As IEnumerable(Of Series)

Return Value

An instance of the IEnumerable<Series> class.

See Also

PieRenderer Members
PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer.EnumSlices Method

PieRenderer.EnumSlices Method
[image]

Enumerates the slices of the pie.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void EnumSlices (
RenderContext context,
PieRenderer.ProcessSlice process
)

Visual Basic [image] Copy Code

Protected Sub EnumSlices( _
context As RenderContext, _
process As PieRenderer.ProcessSlice _
)

Parameters

context

A RenderContext instance.

process

A ProcessSlice callback.

See Also

PieRenderer Members
PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer.HitTest Method

PieRenderer.HitTest Method
[image]

SeriesRenderer.HitTest override. Hit-tests the pieces representing data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override HitResult HitTest (
RenderContext context,
PointD location
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
context As RenderContext, _
location As PointD _
) As HitResult

Parameters

context

A RenderContext instance.

location

A PointD specifying where to look for a pie slice.

Return Value

A HitResult instance identifying the found data item.

See Also

PieRenderer Members
PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer Properties

PieRenderer Properties
[image]

Public Properties

Name | Description
DetachOffset | Gets or sets the percentage by which detached slices are offset from pie center.
Dimension | Gets or sets the dimension index that should be used to read data from the Series.
Doughnut | Gets or sets a value indicating whether the pie should be rendered as a doughnut.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets the Series drawn by this PieRenderer.
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)

See Also

PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer.DetachOffset Property

PieRenderer.DetachOffset Property
[image]

Gets or sets the percentage by which detached slices are offset from pie center.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public float DetachOffset { get; set; }

Visual Basic [image] Copy Code

Public Property DetachOffset As Single

Property Value

A float value specifying percentage.

See Also

PieRenderer Members
PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer.Dimension Property

PieRenderer.Dimension Property
[image]

Gets or sets the dimension index that should be used to read data from the Series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Dimension { get; set; }

Visual Basic [image] Copy Code

Public Property Dimension As Integer

Property Value

See Also

PieRenderer Members
PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer.Doughnut Property

PieRenderer.Doughnut Property
[image]

Gets or sets a value indicating whether the pie should be rendered as a doughnut.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool Doughnut { get; set; }

Visual Basic [image] Copy Code

Public Property Doughnut As Boolean

Property Value

See Also

PieRenderer Members
PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer.Series Property

PieRenderer.Series Property
[image]

Gets or sets the Series drawn by this PieRenderer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Series Series { get; set; }

Visual Basic [image] Copy Code

Public Property Series As Series

Property Value

See Also

PieRenderer Members
PieRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.PieRenderer.ProcessSlice Delegate

PieRenderer.ProcessSlice Delegate
[image]

Defines the signature of delegates called to process pie slices.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected delegate void PieRenderer.ProcessSlice (
int dataIndex,
RectangleF rect,
float diameter,
float startAngle,
float sweepAngle,
GraphicsPath path
)

Visual Basic [image] Copy Code

Protected Delegate Sub PieRenderer.ProcessSlice( _
dataIndex As Integer, _
rect As RectangleF, _
diameter As Single, _
startAngle As Single, _
sweepAngle As Single, _
path As GraphicsPath _
)

Parameters

dataIndex

An integer index of data item in Series.

rect

The bounding rectangle of the slice's circle.

diameter

The diameter of the pie.

startAngle

The start angle of the slice's sector.

sweepAngle

The sweep angle of the slice's sector.

path

A GraphicsPath representing the slice.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.PieSeries Class

PieSeries Class
[image]

Represents one-dimensional series defined by e list of data values and lists of inner and outer labels, convenient for providing data to PieRenderer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class PieSeries : SimpleSeries

Visual Basic [image] Copy Code

Public Class PieSeries
Inherits SimpleSeries

Inheritance Hierarchy

System.Object
MindFusion.Charting.SimpleSeries
MindFusion.Charting.PieSeries

See Also

PieSeries Members
MindFusion.Charting Namespace


MindFusion.Charting.PieSeries Members

PieSeries Members
Constructors Fields Properties Methods Events
[image]

Represents one-dimensional series defined by e list of data values and lists of inner and outer labels, convenient for providing data to PieRenderer.

The following tables list the members exposed by the PieSeries type.

Public Constructors

Name | Description
PieSeries | Initializes a new instance of the PieSeries class.

Protected Fields

Name | Description
emphasizedIndices | Contains the indices of emphasized data items. (Inherited from SimpleSeries.)
labels | Contains the labels of data items. (Inherited from SimpleSeries.)

Public Properties

Name | Description
Data | Gets or sets the data values contained in this series. (Inherited from SimpleSeries.)
DetachedSlices | Gets or sets indices of emphasized data items. PieRenderer draws their corresponding slices detached from the pie.
Dimensions | Implements Series.Dimensions. Returns 1. (Inherited from SimpleSeries.)
InnerLabels | Gets or sets the inner labels.
OuterLabels | Gets or sets the outer labels.
Size | Implements Series.Size. Returns the number of elements in Data list. (Inherited from SimpleSeries.)
SupportedLabels | Implements Series.SupportedLabels. Returns a combination of InnerLabel and OuterLabel.
Title | Implements Series.Title. Gets or sets the title of this series. (Inherited from SimpleSeries.)

Public Methods

Name | Description
GetLabel | SimpleSeries.GetLabel override. Returns an element of the inner or outer label lists.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in this series. (Inherited from SimpleSeries.)
IsEmphasized | Implements Series.IsEmphasized. Gets a value indicating whether the specified data item should be emphasized by the SeriesRenderer. (Inherited from SimpleSeries.)
IsSorted | Implements Series.IsSorted. SimpleSeries always returns false. (Inherited from SimpleSeries.)

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event. (Inherited from SimpleSeries.)

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change. (Inherited from SimpleSeries.)

See Also

PieSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PieSeries Constructor

PieSeries Constructor
[image]

Initializes a new instance of the PieSeries class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PieSeries (
IList<Double> values,
IList<string> innerLabels,
IList<string> outerLabels
)

Visual Basic [image] Copy Code

Public New ( _
values As IList(Of Double), _
innerLabels As IList(Of String), _
outerLabels As IList(Of String) _
)

Parameters

values

A list of data values.

innerLabels

A list of inner labels.

outerLabels

A list of outer labels.

See Also

PieSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PieSeries Methods

PieSeries Methods
[image]

Public Methods

Name | Description
GetLabel | SimpleSeries.GetLabel override. Returns an element of the inner or outer label lists.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in this series. (Inherited from SimpleSeries.)
IsEmphasized | Implements Series.IsEmphasized. Gets a value indicating whether the specified data item should be emphasized by the SeriesRenderer. (Inherited from SimpleSeries.)
IsSorted | Implements Series.IsSorted. SimpleSeries always returns false. (Inherited from SimpleSeries.)

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event. (Inherited from SimpleSeries.)

See Also

PieSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PieSeries.GetLabel Method

PieSeries.GetLabel Method
[image]

SimpleSeries.GetLabel override. Returns an element of the inner or outer label lists.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override string GetLabel (
int index,
LabelKinds kind
)

Visual Basic [image] Copy Code

Public Overrides Function GetLabel( _
index As Integer, _
kind As LabelKinds _
) As String

Parameters

index

An integer value specifying the index of a data item.

kind

A member of the LabelKinds enumeration.

Return Value

A string containing the item's label.

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PieSeries Properties

PieSeries Properties
[image]

Public Properties

Name | Description
Data | Gets or sets the data values contained in this series. (Inherited from SimpleSeries.)
DetachedSlices | Gets or sets indices of emphasized data items. PieRenderer draws their corresponding slices detached from the pie.
Dimensions | Implements Series.Dimensions. Returns 1. (Inherited from SimpleSeries.)
InnerLabels | Gets or sets the inner labels.
OuterLabels | Gets or sets the outer labels.
Size | Implements Series.Size. Returns the number of elements in Data list. (Inherited from SimpleSeries.)
SupportedLabels | Implements Series.SupportedLabels. Returns a combination of InnerLabel and OuterLabel.
Title | Implements Series.Title. Gets or sets the title of this series. (Inherited from SimpleSeries.)

See Also

PieSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PieSeries.DetachedSlices Property

PieSeries.DetachedSlices Property
[image]

Gets or sets indices of emphasized data items. PieRenderer draws their corresponding slices detached from the pie.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<Int32> DetachedSlices { get; set; }

Visual Basic [image] Copy Code

Public Property DetachedSlices As IList(Of Int32)

Property Value

A list of integer indices.

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PieSeries.InnerLabels Property

PieSeries.InnerLabels Property
[image]

Gets or sets the inner labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<string> InnerLabels { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabels As IList(Of String)

Property Value

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PieSeries.OuterLabels Property

PieSeries.OuterLabels Property
[image]

Gets or sets the outer labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<string> OuterLabels { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabels As IList(Of String)

Property Value

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PieSeries.SupportedLabels Property

PieSeries.SupportedLabels Property
[image]

Implements Series.SupportedLabels. Returns a combination of InnerLabel and OuterLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override LabelKinds SupportedLabels { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedLabels As LabelKinds

Property Value

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot Class

Plot Class
Remarks See Also
[image]

The base class for components used to draw chart graphics.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class Plot : Component, SeriesContainer

Visual Basic [image] Copy Code

Public Class Plot
Inherits Component
Implements SeriesContainer

Remarks

Plot is the base class for components that provide drawing surface to SeriesRenderer objects used to render series data. Use the derived Plot2D class to draw series in 2D Cartesian coordinate system, using renderers such as LineRenderer or BarRenderer. Use Plot3D to draw in 3D Cartesian coordinate system, using renderers such as BarRenderer3D. PolarPlot is the base class for drawing in polar coordinate system and can be used along with PieRenderer. RadarPlot can contain renderers for radar-chart graphics, such as RadarRenderer and PieRadarRenderer.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Components.Component
MindFusion.Charting.Plot
MindFusion.Charting.Plot2D
MindFusion.Charting.PolarPlot

See Also

Plot Members
MindFusion.Charting Namespace


MindFusion.Charting.Plot Members

Plot Members
Constructors Properties Methods
[image]

The base class for components used to draw chart graphics.

The following tables list the members exposed by the Plot type.

Public Constructors

Name | Description
Plot |

Public Properties

Name | Description
Background | Gets or sets the Brush that should be used to fill the background of this plot.
BorderStroke | Gets or sets the Brush that should be used to stroke the borders of this plot.
BorderStrokeDashStyle | Gets or sets the stroke dash style of plot borders.
BorderStrokeThickness | Gets or sets the stroke thickness of plot borders.
HighlightedItem | Gets or sets the data item that should be drawn highlighted.
HighlightStroke | Gets or sets the Brush used to stroke highlighted item.
HighlightStrokeDashStyle | Gets or sets the stroke dash style of highlighted item.
HighlightStrokeThickness | Gets or sets the stroke thickness of highlighted item.
SeriesRenderers | Gets or sets the SeriesRenderer objects that should draw inside this plot.
SeriesStyle | Gets or sets a SeriesStyle whose attributes should be used to draw series inside this plot, unless their own renderers have a local SeriesStyle value set for respetive attribute.

Public Methods

Name | Description
AdjustDataRanges | Called at the end of data measurement pass.
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function.
Draw | Component.Draw override. Draws a grid and all chart graphics represented by contained SeriesRenderer objects.
EffectiveBorderStroke | Gets the Brush that should be used to stroke the plot's borders.
EffectiveFill | Gets the Brush that should be used to fill the plot's background.
EnumSeries | Implements SeriesContainer.
Measure | Component.Measure override. Measures the desired size of this component.
MeasureDataRanges | Measures data of all SeriesRenderer objects drawn inside this plot.
StartMeasureData | Called in the beginning of data measurement pass.

Protected Methods

Name | Description
DrawGrid | Draws the plot's grid.
DrawPlot | Draws the plot's background and borders.
EffectiveBorder | Gets the Pen that should be used to draw the plot's borders.
EffectiveBorderStrokeThickness | Gets the thickness of border strokes.
EffectiveStrokeDashStyle | Gets the dash style of border strokes.
OnRendererDataChanged | Called when a Series raises its DataChanged event.

See Also

Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot Constructor

Plot Constructor
[image]

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Plot ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot Methods

Plot Methods
[image]

Public Methods

Name | Description
AdjustDataRanges | Called at the end of data measurement pass.
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function.
Draw | Component.Draw override. Draws a grid and all chart graphics represented by contained SeriesRenderer objects.
EffectiveBorderStroke | Gets the Brush that should be used to stroke the plot's borders.
EffectiveFill | Gets the Brush that should be used to fill the plot's background.
EnumSeries | Implements SeriesContainer.
Measure | Component.Measure override. Measures the desired size of this component.
MeasureDataRanges | Measures data of all SeriesRenderer objects drawn inside this plot.
StartMeasureData | Called in the beginning of data measurement pass.

Protected Methods

Name | Description
DrawGrid | Draws the plot's grid.
DrawPlot | Draws the plot's background and borders.
EffectiveBorder | Gets the Pen that should be used to draw the plot's borders.
EffectiveBorderStrokeThickness | Gets the thickness of border strokes.
EffectiveStrokeDashStyle | Gets the dash style of border strokes.
OnRendererDataChanged | Called when a Series raises its DataChanged event.

See Also

Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.AdjustDataRanges Method

Plot.AdjustDataRanges Method
[image]

Called at the end of data measurement pass.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void AdjustDataRanges (
RenderContext context
)

Visual Basic [image] Copy Code

Public Sub AdjustDataRanges( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.DomainDimension Method

Plot.DomainDimension Method
[image]

Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int DomainDimension (
Series series
)

Visual Basic [image] Copy Code

Public Function DomainDimension( _
series As Series _
) As Integer

Parameters

series

A Series in this container.

Return Value

The dimension index.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.Draw Method

Plot.Draw Method
[image]

Component.Draw override. Draws a grid and all chart graphics represented by contained SeriesRenderer objects.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.DrawGrid Method

Plot.DrawGrid Method
[image]

Draws the plot's grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void DrawGrid (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub DrawGrid( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.DrawPlot Method

Plot.DrawPlot Method
[image]

Draws the plot's background and borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void DrawPlot (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub DrawPlot( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.EffectiveBorder Method

Plot.EffectiveBorder Method
[image]

Gets the Pen that should be used to draw the plot's borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Pen EffectiveBorder (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveBorder( _
context As RenderContext _
) As Pen

Parameters

context

A RenderContext instance.

Return Value

A Pen instance.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.EffectiveBorderStroke Method

Plot.EffectiveBorderStroke Method
[image]

Gets the Brush that should be used to stroke the plot's borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush EffectiveBorderStroke (
RenderContext context
)

Visual Basic [image] Copy Code

Public Function EffectiveBorderStroke( _
context As RenderContext _
) As Brush

Parameters

context

A RenderContext instance.

Return Value

A Brush instance.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.EffectiveBorderStrokeThickness Method

Plot.EffectiveBorderStrokeThickness Method
[image]

Gets the thickness of border strokes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected double EffectiveBorderStrokeThickness (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveBorderStrokeThickness( _
context As RenderContext _
) As Double

Parameters

context

A RenderContext instance.

Return Value

A double value.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.EffectiveFill Method

Plot.EffectiveFill Method
[image]

Gets the Brush that should be used to fill the plot's background.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush EffectiveFill (
RenderContext context
)

Visual Basic [image] Copy Code

Public Function EffectiveFill( _
context As RenderContext _
) As Brush

Parameters

context

A RenderContext instance.

Return Value

A Brush instance.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.EffectiveStrokeDashStyle Method

Plot.EffectiveStrokeDashStyle Method
[image]

Gets the dash style of border strokes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected DashStyle EffectiveStrokeDashStyle (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveStrokeDashStyle( _
context As RenderContext _
) As DashStyle

Parameters

context

A RenderContext instance.

Return Value

A member of the DashStyle enumeration.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.EnumSeries Method

Plot.EnumSeries Method
[image]

Implements SeriesContainer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IEnumerable<Series> EnumSeries ()

Visual Basic [image] Copy Code

Public Function EnumSeries () As IEnumerable(Of Series)

Return Value

An instance of the IEnumerable<Series> class.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.Measure Method

Plot.Measure Method
[image]

Component.Measure override. Measures the desired size of this component.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void Measure (
double maxWidth,
double maxHeight,
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub Measure( _
maxWidth As Double, _
maxHeight As Double, _
context As RenderContext _
)

Parameters

maxWidth

The maximum width provided by parent component.

maxHeight

The maximum height provided by parent component.

context

A RenderContext instance.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.MeasureDataRanges Method

Plot.MeasureDataRanges Method
[image]

Measures data of all SeriesRenderer objects drawn inside this plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void MeasureDataRanges (
RenderContext context
)

Visual Basic [image] Copy Code

Public Sub MeasureDataRanges( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.OnRendererDataChanged Method

Plot.OnRendererDataChanged Method
[image]

Called when a Series raises its DataChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void OnRendererDataChanged (
Object sender,
EventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnRendererDataChanged( _
sender As Object, _
e As EventArgs _
)

Parameters

sender

The event sender.

e

An EventArgs instance.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.StartMeasureData Method

Plot.StartMeasureData Method
[image]

Called in the beginning of data measurement pass.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual void StartMeasureData (
RenderContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub StartMeasureData( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot Properties

Plot Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the Brush that should be used to fill the background of this plot.
BorderStroke | Gets or sets the Brush that should be used to stroke the borders of this plot.
BorderStrokeDashStyle | Gets or sets the stroke dash style of plot borders.
BorderStrokeThickness | Gets or sets the stroke thickness of plot borders.
HighlightedItem | Gets or sets the data item that should be drawn highlighted.
HighlightStroke | Gets or sets the Brush used to stroke highlighted item.
HighlightStrokeDashStyle | Gets or sets the stroke dash style of highlighted item.
HighlightStrokeThickness | Gets or sets the stroke thickness of highlighted item.
SeriesRenderers | Gets or sets the SeriesRenderer objects that should draw inside this plot.
SeriesStyle | Gets or sets a SeriesStyle whose attributes should be used to draw series inside this plot, unless their own renderers have a local SeriesStyle value set for respetive attribute.

See Also

Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.Background Property

Plot.Background Property
[image]

Gets or sets the Brush that should be used to fill the background of this plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush Background { get; set; }

Visual Basic [image] Copy Code

Public Property Background As Brush

Property Value

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.BorderStroke Property

Plot.BorderStroke Property
[image]

Gets or sets the Brush that should be used to stroke the borders of this plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush BorderStroke { get; set; }

Visual Basic [image] Copy Code

Public Property BorderStroke As Brush

Property Value

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.BorderStrokeDashStyle Property

Plot.BorderStrokeDashStyle Property
[image]

Gets or sets the stroke dash style of plot borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<DashStyle> BorderStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property BorderStrokeDashStyle As Nullable(Of DashStyle)

Property Value

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.BorderStrokeThickness Property

Plot.BorderStrokeThickness Property
[image]

Gets or sets the stroke thickness of plot borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> BorderStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property BorderStrokeThickness As Nullable(Of Double)

Property Value

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.HighlightedItem Property

Plot.HighlightedItem Property
[image]

Gets or sets the data item that should be drawn highlighted.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public HitResult HighlightedItem { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightedItem As HitResult

Property Value

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.HighlightStroke Property

Plot.HighlightStroke Property
[image]

Gets or sets the Brush used to stroke highlighted item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush HighlightStroke { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightStroke As Brush

Property Value

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.HighlightStrokeDashStyle Property

Plot.HighlightStrokeDashStyle Property
[image]

Gets or sets the stroke dash style of highlighted item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<DashStyle> HighlightStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightStrokeDashStyle As Nullable(Of DashStyle)

Property Value

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.HighlightStrokeThickness Property

Plot.HighlightStrokeThickness Property
[image]

Gets or sets the stroke thickness of highlighted item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> HighlightStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightStrokeThickness As Nullable(Of Double)

Property Value

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.SeriesRenderers Property

Plot.SeriesRenderers Property
[image]

Gets or sets the SeriesRenderer objects that should draw inside this plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public ObservableCollection<SeriesRenderer> SeriesRenderers { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesRenderers As ObservableCollection(Of SeriesRenderer)

Property Value

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot.SeriesStyle Property

Plot.SeriesStyle Property
[image]

Gets or sets a SeriesStyle whose attributes should be used to draw series inside this plot, unless their own renderers have a local SeriesStyle value set for respetive attribute.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public SeriesStyle SeriesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesStyle As SeriesStyle

Property Value

See Also

Plot Members
Plot Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D Class

Plot2D Class
Remarks See Also
[image]

A plot whose series are rendered relatively to a two-dimensional Cartesian coordinate system.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class Plot2D : Plot

Visual Basic [image] Copy Code

Public Class Plot2D
Inherits Plot

Remarks

This component implements drawing surface for renderers that work in 2D Cartesian coordinate system, such as AreaRenderer, StepRenderer, BarRenderer, LineRenderer. The plot can contain a combination of several renderers, each having their distinct appearance settings.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Components.Component
MindFusion.Charting.Plot
MindFusion.Charting.Plot2D
MindFusion.Charting.Plot3D

See Also

Plot2D Members
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D Members

Plot2D Members
Constructors Properties Methods Events
[image]

A plot whose series are rendered relatively to a two-dimensional Cartesian coordinate system.

The following tables list the members exposed by the Plot2D type.

Public Constructors

Name | Description
Plot2D | Initializes a new instance of the Plot2D class.

Public Properties

Name | Description
AllowPan | Gets or sets a value indicating whether users are allowed to pan this plot.
Background | Gets or sets the Brush that should be used to fill the background of this plot. (Inherited from Plot.)
BorderStroke | Gets or sets the Brush that should be used to stroke the borders of this plot. (Inherited from Plot.)
BorderStrokeDashStyle | Gets or sets the stroke dash style of plot borders. (Inherited from Plot.)
BorderStrokeThickness | Gets or sets the stroke thickness of plot borders. (Inherited from Plot.)
GridColor1 | Gets or sets the main color of the grid.
GridColor2 | Gets or sets the alternating color of the grid.
GridLineColor | Gets or sets the color of the grid lines.
GridLineStyle | Gets or sets the style of the grid lines.
GridLineThickness | Gets or sets the thickness of the grid lines.
GridType | Gets or sets the type of grid to draw in this plot.
HighlightedItem | Gets or sets the data item that should be drawn highlighted. (Inherited from Plot.)
HighlightStroke | Gets or sets the Brush used to stroke highlighted item. (Inherited from Plot.)
HighlightStrokeDashStyle | Gets or sets the stroke dash style of highlighted item. (Inherited from Plot.)
HighlightStrokeThickness | Gets or sets the stroke thickness of highlighted item. (Inherited from Plot.)
IsZoomed | Gets or sets a value indicating whether the user has zoomed into this plot.
PinGrid | Gets or sets a value indicating whether grid stripes should be pinned in place or scroll together with the plot when users pan it.
SeriesRenderers | Gets or sets the SeriesRenderer objects that should draw inside this plot. (Inherited from Plot.)
SeriesStyle | Gets or sets a SeriesStyle whose attributes should be used to draw series inside this plot, unless their own renderers have a local SeriesStyle value set for respetive attribute. (Inherited from Plot.)
VerticalScroll | Specifies whether the plot should scroll vertically when panned.
XAxis | Gets or sets default Axis instance used to map X data coordinates of series rendered inside this plot to the plot's pixels.
YAxis | Gets or sets default Axis instance used to map Y data coordinates of series rendered inside this plot to the plot's pixels.

Public Methods

Name | Description
AdjustDataRanges | Called at the end of data measurement pass. (Inherited from Plot.)
CreateController | Component.CreateController override. Returns a ComponentController used to interact with this component.
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from Plot.)
Draw | Component.Draw override. Draws a grid and all chart graphics represented by contained SeriesRenderer objects. (Inherited from Plot.)
EffectiveBorderStroke | Gets the Brush that should be used to stroke the plot's borders. (Inherited from Plot.)
EffectiveFill | Gets the Brush that should be used to fill the plot's background. (Inherited from Plot.)
EnumSeries | Implements SeriesContainer. (Inherited from Plot.)
Measure | Component.Measure override. Measures the desired size of this component. (Inherited from Plot.)
MeasureDataRanges | Measures data of all SeriesRenderer objects drawn inside this plot. (Inherited from Plot.)
ResetZoom | Resets the zoom level to original axis ranges.
StartMeasureData | Called in the beginning of data measurement pass. (Inherited from Plot.)
Visit | Component.Visit override. Calls visitor's VisitPlot method.
ZoomOut | Zooms out from current data range.

Protected Methods

Name | Description
DrawGrid | Plot.DrawGrid override. Draws the grid specified by GridType property.
DrawPlot | Draws the plot's background and borders. (Inherited from Plot.)
EffectiveBorder | Gets the Pen that should be used to draw the plot's borders. (Inherited from Plot.)
EffectiveBorderStrokeThickness | Gets the thickness of border strokes. (Inherited from Plot.)
EffectiveStrokeDashStyle | Gets the dash style of border strokes. (Inherited from Plot.)
OnRendererDataChanged | Called when a Series raises its DataChanged event. (Inherited from Plot.)

Public Events

Name | Description
ZoomChanged | Raised when the user zooms into this plot's data range.

See Also

Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D Constructor

Plot2D Constructor
[image]

Initializes a new instance of the Plot2D class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Plot2D ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D Methods

Plot2D Methods
[image]

Public Methods

Name | Description
AdjustDataRanges | Called at the end of data measurement pass. (Inherited from Plot.)
CreateController | Component.CreateController override. Returns a ComponentController used to interact with this component.
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from Plot.)
Draw | Component.Draw override. Draws a grid and all chart graphics represented by contained SeriesRenderer objects. (Inherited from Plot.)
EffectiveBorderStroke | Gets the Brush that should be used to stroke the plot's borders. (Inherited from Plot.)
EffectiveFill | Gets the Brush that should be used to fill the plot's background. (Inherited from Plot.)
EnumSeries | Implements SeriesContainer. (Inherited from Plot.)
Measure | Component.Measure override. Measures the desired size of this component. (Inherited from Plot.)
MeasureDataRanges | Measures data of all SeriesRenderer objects drawn inside this plot. (Inherited from Plot.)
ResetZoom | Resets the zoom level to original axis ranges.
StartMeasureData | Called in the beginning of data measurement pass. (Inherited from Plot.)
Visit | Component.Visit override. Calls visitor's VisitPlot method.
ZoomOut | Zooms out from current data range.

Protected Methods

Name | Description
DrawGrid | Plot.DrawGrid override. Draws the grid specified by GridType property.
DrawPlot | Draws the plot's background and borders. (Inherited from Plot.)
EffectiveBorder | Gets the Pen that should be used to draw the plot's borders. (Inherited from Plot.)
EffectiveBorderStrokeThickness | Gets the thickness of border strokes. (Inherited from Plot.)
EffectiveStrokeDashStyle | Gets the dash style of border strokes. (Inherited from Plot.)
OnRendererDataChanged | Called when a Series raises its DataChanged event. (Inherited from Plot.)

See Also

Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.CreateController Method

Plot2D.CreateController Method
[image]

Component.CreateController override. Returns a ComponentController used to interact with this component.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override ComponentController CreateController (
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Function CreateController( _
context As RenderContext _
) As ComponentController

Parameters

context

A RenderContext instance.

Return Value

An instance of the PanController class.

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.DrawGrid Method

Plot2D.DrawGrid Method
[image]

Plot.DrawGrid override. Draws the grid specified by GridType property.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void DrawGrid (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawGrid( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.ResetZoom Method

Plot2D.ResetZoom Method
[image]

Resets the zoom level to original axis ranges.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void ResetZoom ()

Visual Basic [image] Copy Code

Public Sub ResetZoom ()

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.Visit Method

Plot2D.Visit Method
[image]

Component.Visit override. Calls visitor's VisitPlot method.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void Visit (
ComponentVisitor visitor
)

Visual Basic [image] Copy Code

Public Overrides Sub Visit( _
visitor As ComponentVisitor _
)

Parameters

visitor

An instance of a ComponentVisitor -derived class.

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.ZoomOut Method

Plot2D.ZoomOut Method
[image]

Zooms out from current data range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void ZoomOut (
IEnumerable<Axis> axes
)

Visual Basic [image] Copy Code

Public Sub ZoomOut( _
axes As IEnumerable(Of Axis) _
)

Parameters

axes

The axes whose ranges should be scaled.

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D Properties

Plot2D Properties
[image]

Public Properties

Name | Description
AllowPan | Gets or sets a value indicating whether users are allowed to pan this plot.
Background | Gets or sets the Brush that should be used to fill the background of this plot. (Inherited from Plot.)
BorderStroke | Gets or sets the Brush that should be used to stroke the borders of this plot. (Inherited from Plot.)
BorderStrokeDashStyle | Gets or sets the stroke dash style of plot borders. (Inherited from Plot.)
BorderStrokeThickness | Gets or sets the stroke thickness of plot borders. (Inherited from Plot.)
GridColor1 | Gets or sets the main color of the grid.
GridColor2 | Gets or sets the alternating color of the grid.
GridLineColor | Gets or sets the color of the grid lines.
GridLineStyle | Gets or sets the style of the grid lines.
GridLineThickness | Gets or sets the thickness of the grid lines.
GridType | Gets or sets the type of grid to draw in this plot.
HighlightedItem | Gets or sets the data item that should be drawn highlighted. (Inherited from Plot.)
HighlightStroke | Gets or sets the Brush used to stroke highlighted item. (Inherited from Plot.)
HighlightStrokeDashStyle | Gets or sets the stroke dash style of highlighted item. (Inherited from Plot.)
HighlightStrokeThickness | Gets or sets the stroke thickness of highlighted item. (Inherited from Plot.)
IsZoomed | Gets or sets a value indicating whether the user has zoomed into this plot.
PinGrid | Gets or sets a value indicating whether grid stripes should be pinned in place or scroll together with the plot when users pan it.
SeriesRenderers | Gets or sets the SeriesRenderer objects that should draw inside this plot. (Inherited from Plot.)
SeriesStyle | Gets or sets a SeriesStyle whose attributes should be used to draw series inside this plot, unless their own renderers have a local SeriesStyle value set for respetive attribute. (Inherited from Plot.)
VerticalScroll | Specifies whether the plot should scroll vertically when panned.
XAxis | Gets or sets default Axis instance used to map X data coordinates of series rendered inside this plot to the plot's pixels.
YAxis | Gets or sets default Axis instance used to map Y data coordinates of series rendered inside this plot to the plot's pixels.

See Also

Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.AllowPan Property

Plot2D.AllowPan Property
[image]

Gets or sets a value indicating whether users are allowed to pan this plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool AllowPan { get; set; }

Visual Basic [image] Copy Code

Public Property AllowPan As Boolean

Property Value

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.GridColor1 Property

Plot2D.GridColor1 Property
[image]

Gets or sets the main color of the grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Color> GridColor1 { get; set; }

Visual Basic [image] Copy Code

Public Property GridColor1 As Nullable(Of Color)

Property Value

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.GridColor2 Property

Plot2D.GridColor2 Property
[image]

Gets or sets the alternating color of the grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Color> GridColor2 { get; set; }

Visual Basic [image] Copy Code

Public Property GridColor2 As Nullable(Of Color)

Property Value

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.GridLineColor Property

Plot2D.GridLineColor Property
[image]

Gets or sets the color of the grid lines.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Color> GridLineColor { get; set; }

Visual Basic [image] Copy Code

Public Property GridLineColor As Nullable(Of Color)

Property Value

An optional System.Drawing.Color value. The default value null indicates that grid lines should be drawn using theme's GridLineColor.

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.GridLineStyle Property

Plot2D.GridLineStyle Property
[image]

Gets or sets the style of the grid lines.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<DashStyle> GridLineStyle { get; set; }

Visual Basic [image] Copy Code

Public Property GridLineStyle As Nullable(Of DashStyle)

Property Value

An optional DashStyle value. The default value null indicates that grid lines should be drawn using theme's GridLineStyle.

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.GridLineThickness Property

Plot2D.GridLineThickness Property
[image]

Gets or sets the thickness of the grid lines.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> GridLineThickness { get; set; }

Visual Basic [image] Copy Code

Public Property GridLineThickness As Nullable(Of Double)

Property Value

An optional double value. The default value null indicates that grid lines should be drawn using theme's GridLineThickness.

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.GridType Property

Plot2D.GridType Property
[image]

Gets or sets the type of grid to draw in this plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public GridType GridType { get; set; }

Visual Basic [image] Copy Code

Public Property GridType As GridType

Property Value

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.IsZoomed Property

Plot2D.IsZoomed Property
[image]

Gets or sets a value indicating whether the user has zoomed into this plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsZoomed { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsZoomed As Boolean

Property Value

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.PinGrid Property

Plot2D.PinGrid Property
[image]

Gets or sets a value indicating whether grid stripes should be pinned in place or scroll together with the plot when users pan it.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool PinGrid { get; set; }

Visual Basic [image] Copy Code

Public Property PinGrid As Boolean

Property Value

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.VerticalScroll Property

Plot2D.VerticalScroll Property
[image]

Specifies whether the plot should scroll vertically when panned.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool VerticalScroll { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalScroll As Boolean

Property Value

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.XAxis Property

Plot2D.XAxis Property
[image]

Gets or sets default Axis instance used to map X data coordinates of series rendered inside this plot to the plot's pixels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Axis XAxis { get; set; }

Visual Basic [image] Copy Code

Public Property XAxis As Axis

Property Value

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.YAxis Property

Plot2D.YAxis Property
[image]

Gets or sets default Axis instance used to map Y data coordinates of series rendered inside this plot to the plot's pixels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Axis YAxis { get; set; }

Visual Basic [image] Copy Code

Public Property YAxis As Axis

Property Value

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D Events

Plot2D Events
[image]

Public Events

Name | Description
ZoomChanged | Raised when the user zooms into this plot's data range.

See Also

Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2D.ZoomChanged Event

Plot2D.ZoomChanged Event
[image]

Raised when the user zooms into this plot's data range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event EventHandler ZoomChanged

Visual Basic [image] Copy Code

Public Event ZoomChanged As EventHandler

See Also

Plot2D Members
Plot2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController Class

Plot2DController Class
[image]

A base class for controllers that let users interact with Plot2D objects.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class Plot2DController : PlotController

Visual Basic [image] Copy Code

Public Class Plot2DController
Inherits PlotController

Inheritance Hierarchy

System.Object
MindFusion.Charting.PlotController
MindFusion.Charting.Plot2DController
MindFusion.Charting.PanController
MindFusion.Charting.ZoomController

See Also

Plot2DController Members
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController Members

Plot2DController Members
Constructors Fields Properties Methods
[image]

A base class for controllers that let users interact with Plot2D objects.

The following tables list the members exposed by the Plot2DController type.

Public Constructors

Name | Description
Plot2DController | Initializes a new instance of the Plot2DController class.

Protected Fields

Name | Description
axisRanges | Contains information about Axis ranges processed by this controller.
renderContext | The current RenderContext. (Inherited from PlotController.)

Public Properties

Name | Description
Component | Gets the component controlled by this PlotController. (Inherited from PlotController.)
Vertical | Gets or sets a value indicating whether interaction is done along the X or Y axis.

Public Methods

Name | Description
DrawInteraction | Implements ComponentController.DrawInteraction. Draws a representation of the current state of user interaction on specified IGraphics surface. (Inherited from PlotController.)
GetRunningAnimation | For internal use. (Inherited from PlotController.)
OnMouseDown | PlotController.OnMouseDown override. Called when the user presses a mouse button.
OnMouseMove | Implements ComponentController.OnMouseMove. Called when the user moves the mouse. (Inherited from PlotController.)
OnMouseUp | Implements ComponentController.OnMouseUp. Called when the user releases a mouse button. (Inherited from PlotController.)

Protected Methods

Name | Description
PlotToAxisValue | Converts a plot pixel position to a logical value from specified axis' coordinate system.

See Also

Plot2DController Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController Fields

Plot2DController Fields
[image]

Protected Fields

Name | Description
axisRanges | Contains information about Axis ranges processed by this controller.
renderContext | The current RenderContext. (Inherited from PlotController.)

See Also

Plot2DController Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController.axisRanges Field

Plot2DController.axisRanges Field
[image]

Contains information about Axis ranges processed by this controller.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Dictionary<Axis, Plot2DController.AxisInfo> axisRanges

Visual Basic [image] Copy Code

Protected axisRanges As Dictionary(Of Axis, Plot2DController.AxisInfo)

See Also

Plot2DController Members
Plot2DController Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController Constructor

Plot2DController Constructor
[image]

Initializes a new instance of the Plot2DController class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Plot2DController (
RenderContext renderContext,
bool vertical
)

Visual Basic [image] Copy Code

Public New ( _
renderContext As RenderContext, _
vertical As Boolean _
)

Parameters

renderContext

A RenderContext instance.

vertical

true to implement interaction along the Y axis, or false for the X axis.

See Also

Plot2DController Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController Methods

Plot2DController Methods
[image]

Public Methods

Name | Description
DrawInteraction | Implements ComponentController.DrawInteraction. Draws a representation of the current state of user interaction on specified IGraphics surface. (Inherited from PlotController.)
GetRunningAnimation | For internal use. (Inherited from PlotController.)
OnMouseDown | PlotController.OnMouseDown override. Called when the user presses a mouse button.
OnMouseMove | Implements ComponentController.OnMouseMove. Called when the user moves the mouse. (Inherited from PlotController.)
OnMouseUp | Implements ComponentController.OnMouseUp. Called when the user releases a mouse button. (Inherited from PlotController.)

Protected Methods

Name | Description
PlotToAxisValue | Converts a plot pixel position to a logical value from specified axis' coordinate system.

See Also

Plot2DController Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController.OnMouseDown Method

Plot2DController.OnMouseDown Method
[image]

PlotController.OnMouseDown override. Called when the user presses a mouse button.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void OnMouseDown (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overrides Sub OnMouseDown( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

Plot2DController Members
Plot2DController Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController.PlotToAxisValue Method

Plot2DController.PlotToAxisValue Method
[image]

Converts a plot pixel position to a logical value from specified axis' coordinate system.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected double PlotToAxisValue (
Axis axis,
double value
)

Visual Basic [image] Copy Code

Protected Function PlotToAxisValue( _
axis As Axis, _
value As Double _
) As Double

Parameters

axis

The target Axis.

value

The value to convert.

Return Value

The converted value.

See Also

Plot2DController Members
Plot2DController Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController Properties

Plot2DController Properties
[image]

Public Properties

Name | Description
Component | Gets the component controlled by this PlotController. (Inherited from PlotController.)
Vertical | Gets or sets a value indicating whether interaction is done along the X or Y axis.

See Also

Plot2DController Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController.Vertical Property

Plot2DController.Vertical Property
[image]

Gets or sets a value indicating whether interaction is done along the X or Y axis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool Vertical { get; set; }

Visual Basic [image] Copy Code

Public Property Vertical As Boolean

Property Value

See Also

Plot2DController Members
Plot2DController Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController.AxisInfo Structure

Plot2DController.AxisInfo Structure
[image]

Stores information about Axis ranges processed by this controller.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected struct Plot2DController.AxisInfo

Visual Basic [image] Copy Code

Protected Structure Plot2DController.AxisInfo

See Also

Plot2DController.AxisInfo Members
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController.AxisInfo Members

Plot2DController.AxisInfo Members
Fields
[image]

Stores information about Axis ranges processed by this controller.

The following tables list the members exposed by the Plot2DController.AxisInfo type.

Public Fields

Name | Description
Origin | The axis origin.
Range | The axis range.
Resolution | The axis resolution.

See Also

Plot2DController.AxisInfo Structure
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController.AxisInfo Fields

Plot2DController.AxisInfo Fields
[image]

Public Fields

Name | Description
Origin | The axis origin.
Range | The axis range.
Resolution | The axis resolution.

See Also

Plot2DController.AxisInfo Structure
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController.AxisInfo.Origin Field

Plot2DController.AxisInfo.Origin Field
[image]

The axis origin.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Origin

Visual Basic [image] Copy Code

Public Origin As Double

See Also

Plot2DController.AxisInfo Members
Plot2DController.AxisInfo Structure
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController.AxisInfo.Range Field

Plot2DController.AxisInfo.Range Field
[image]

The axis range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Range

Visual Basic [image] Copy Code

Public Range As Double

See Also

Plot2DController.AxisInfo Members
Plot2DController.AxisInfo Structure
MindFusion.Charting Namespace


MindFusion.Charting.Plot2DController.AxisInfo.Resolution Field

Plot2DController.AxisInfo.Resolution Field
[image]

The axis resolution.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Resolution

Visual Basic [image] Copy Code

Public Resolution As Double

See Also

Plot2DController.AxisInfo Members
Plot2DController.AxisInfo Structure
MindFusion.Charting Namespace


MindFusion.Charting.Plot3D Class

Plot3D Class
Remarks See Also
[image]

A plot whose series are rendered relatively to a three-dimensional Cartesian coordinate system.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class Plot3D : Plot2D

Visual Basic [image] Copy Code

Public Class Plot3D
Inherits Plot2D

Remarks

This component implements drawing surface for renderers that work in 3D Cartesian coordinate system, such as BarRenderer3D, BarStackRenderer3D, BarOverlayRenderer3D.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Components.Component
MindFusion.Charting.Plot
MindFusion.Charting.Plot2D
MindFusion.Charting.Plot3D

See Also

Plot3D Members
MindFusion.Charting Namespace


MindFusion.Charting.Plot3D Members

Plot3D Members
Constructors Properties Methods Events
[image]

A plot whose series are rendered relatively to a three-dimensional Cartesian coordinate system.

The following tables list the members exposed by the Plot3D type.

Public Constructors

Name | Description
Plot3D |

Public Properties

Name | Description
AllowPan | Gets or sets a value indicating whether users are allowed to pan this plot. (Inherited from Plot2D.)
Background | Gets or sets the Brush that should be used to fill the background of this plot. (Inherited from Plot.)
BorderStroke | Gets or sets the Brush that should be used to stroke the borders of this plot. (Inherited from Plot.)
BorderStrokeDashStyle | Gets or sets the stroke dash style of plot borders. (Inherited from Plot.)
BorderStrokeThickness | Gets or sets the stroke thickness of plot borders. (Inherited from Plot.)
GridColor1 | Gets or sets the main color of the grid. (Inherited from Plot2D.)
GridColor2 | Gets or sets the alternating color of the grid. (Inherited from Plot2D.)
GridLineColor | Gets or sets the color of the grid lines. (Inherited from Plot2D.)
GridLineStyle | Gets or sets the style of the grid lines. (Inherited from Plot2D.)
GridLineThickness | Gets or sets the thickness of the grid lines. (Inherited from Plot2D.)
GridType | Gets or sets the type of grid to draw in this plot. (Inherited from Plot2D.)
HighlightedItem | Gets or sets the data item that should be drawn highlighted. (Inherited from Plot.)
HighlightStroke | Gets or sets the Brush used to stroke highlighted item. (Inherited from Plot.)
HighlightStrokeDashStyle | Gets or sets the stroke dash style of highlighted item. (Inherited from Plot.)
HighlightStrokeThickness | Gets or sets the stroke thickness of highlighted item. (Inherited from Plot.)
IsZoomed | Gets or sets a value indicating whether the user has zoomed into this plot. (Inherited from Plot2D.)
PinGrid | Gets or sets a value indicating whether grid stripes should be pinned in place or scroll together with the plot when users pan it. (Inherited from Plot2D.)
SeriesRenderers | Gets or sets the SeriesRenderer objects that should draw inside this plot. (Inherited from Plot.)
SeriesStyle | Gets or sets a SeriesStyle whose attributes should be used to draw series inside this plot, unless their own renderers have a local SeriesStyle value set for respetive attribute. (Inherited from Plot.)
VerticalScroll | Specifies whether the plot should scroll vertically when panned. (Inherited from Plot2D.)
XAxis | Gets or sets default Axis instance used to map X data coordinates of series rendered inside this plot to the plot's pixels. (Inherited from Plot2D.)
YAxis | Gets or sets default Axis instance used to map Y data coordinates of series rendered inside this plot to the plot's pixels. (Inherited from Plot2D.)
ZAxis | Gets or sets default Axis instance used to map Z data coordinates of series rendered inside this plot to the plot's pixels.

Public Methods

Name | Description
AdjustDataRanges | Called at the end of data measurement pass. (Inherited from Plot.)
CreateController | Component.CreateController override. Returns a ComponentController used to interact with this component. (Inherited from Plot2D.)
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from Plot.)
Draw | Plot.Draw override. Draws a projection of 3D models generated by contained Renderer3D objects.
EffectiveBorderStroke | Gets the Brush that should be used to stroke the plot's borders. (Inherited from Plot.)
EffectiveFill | Gets the Brush that should be used to fill the plot's background. (Inherited from Plot.)
EnumSeries | Implements SeriesContainer. (Inherited from Plot.)
Measure | Component.Measure override. Measures the desired size of this component. (Inherited from Plot.)
MeasureDataRanges | Measures data of all SeriesRenderer objects drawn inside this plot. (Inherited from Plot.)
ResetZoom | Resets the zoom level to original axis ranges. (Inherited from Plot2D.)
StartMeasureData | Called in the beginning of data measurement pass. (Inherited from Plot.)
Visit | Component.Visit override. Calls visitor's VisitPlot method. (Inherited from Plot2D.)
ZoomOut | Zooms out from current data range. (Inherited from Plot2D.)

Protected Methods

Name | Description
DrawGrid | Plot.DrawGrid override. Draws the grid specified by GridType property. (Inherited from Plot2D.)
DrawPlot | Draws the plot's background and borders. (Inherited from Plot.)
EffectiveBorder | Gets the Pen that should be used to draw the plot's borders. (Inherited from Plot.)
EffectiveBorderStrokeThickness | Gets the thickness of border strokes. (Inherited from Plot.)
EffectiveStrokeDashStyle | Gets the dash style of border strokes. (Inherited from Plot.)
OnRendererDataChanged | Called when a Series raises its DataChanged event. (Inherited from Plot.)

Public Events

Name | Description
ZoomChanged | Raised when the user zooms into this plot's data range. (Inherited from Plot2D.)

See Also

Plot3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot3D Constructor

Plot3D Constructor
[image]

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Plot3D ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Plot3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot3D Methods

Plot3D Methods
[image]

Public Methods

Name | Description
AdjustDataRanges | Called at the end of data measurement pass. (Inherited from Plot.)
CreateController | Component.CreateController override. Returns a ComponentController used to interact with this component. (Inherited from Plot2D.)
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from Plot.)
Draw | Plot.Draw override. Draws a projection of 3D models generated by contained Renderer3D objects.
EffectiveBorderStroke | Gets the Brush that should be used to stroke the plot's borders. (Inherited from Plot.)
EffectiveFill | Gets the Brush that should be used to fill the plot's background. (Inherited from Plot.)
EnumSeries | Implements SeriesContainer. (Inherited from Plot.)
Measure | Component.Measure override. Measures the desired size of this component. (Inherited from Plot.)
MeasureDataRanges | Measures data of all SeriesRenderer objects drawn inside this plot. (Inherited from Plot.)
ResetZoom | Resets the zoom level to original axis ranges. (Inherited from Plot2D.)
StartMeasureData | Called in the beginning of data measurement pass. (Inherited from Plot.)
Visit | Component.Visit override. Calls visitor's VisitPlot method. (Inherited from Plot2D.)
ZoomOut | Zooms out from current data range. (Inherited from Plot2D.)

Protected Methods

Name | Description
DrawGrid | Plot.DrawGrid override. Draws the grid specified by GridType property. (Inherited from Plot2D.)
DrawPlot | Draws the plot's background and borders. (Inherited from Plot.)
EffectiveBorder | Gets the Pen that should be used to draw the plot's borders. (Inherited from Plot.)
EffectiveBorderStrokeThickness | Gets the thickness of border strokes. (Inherited from Plot.)
EffectiveStrokeDashStyle | Gets the dash style of border strokes. (Inherited from Plot.)
OnRendererDataChanged | Called when a Series raises its DataChanged event. (Inherited from Plot.)

See Also

Plot3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot3D.Draw Method

Plot3D.Draw Method
[image]

Plot.Draw override. Draws a projection of 3D models generated by contained Renderer3D objects.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

Plot3D Members
Plot3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot3D Properties

Plot3D Properties
[image]

Public Properties

Name | Description
AllowPan | Gets or sets a value indicating whether users are allowed to pan this plot. (Inherited from Plot2D.)
Background | Gets or sets the Brush that should be used to fill the background of this plot. (Inherited from Plot.)
BorderStroke | Gets or sets the Brush that should be used to stroke the borders of this plot. (Inherited from Plot.)
BorderStrokeDashStyle | Gets or sets the stroke dash style of plot borders. (Inherited from Plot.)
BorderStrokeThickness | Gets or sets the stroke thickness of plot borders. (Inherited from Plot.)
GridColor1 | Gets or sets the main color of the grid. (Inherited from Plot2D.)
GridColor2 | Gets or sets the alternating color of the grid. (Inherited from Plot2D.)
GridLineColor | Gets or sets the color of the grid lines. (Inherited from Plot2D.)
GridLineStyle | Gets or sets the style of the grid lines. (Inherited from Plot2D.)
GridLineThickness | Gets or sets the thickness of the grid lines. (Inherited from Plot2D.)
GridType | Gets or sets the type of grid to draw in this plot. (Inherited from Plot2D.)
HighlightedItem | Gets or sets the data item that should be drawn highlighted. (Inherited from Plot.)
HighlightStroke | Gets or sets the Brush used to stroke highlighted item. (Inherited from Plot.)
HighlightStrokeDashStyle | Gets or sets the stroke dash style of highlighted item. (Inherited from Plot.)
HighlightStrokeThickness | Gets or sets the stroke thickness of highlighted item. (Inherited from Plot.)
IsZoomed | Gets or sets a value indicating whether the user has zoomed into this plot. (Inherited from Plot2D.)
PinGrid | Gets or sets a value indicating whether grid stripes should be pinned in place or scroll together with the plot when users pan it. (Inherited from Plot2D.)
SeriesRenderers | Gets or sets the SeriesRenderer objects that should draw inside this plot. (Inherited from Plot.)
SeriesStyle | Gets or sets a SeriesStyle whose attributes should be used to draw series inside this plot, unless their own renderers have a local SeriesStyle value set for respetive attribute. (Inherited from Plot.)
VerticalScroll | Specifies whether the plot should scroll vertically when panned. (Inherited from Plot2D.)
XAxis | Gets or sets default Axis instance used to map X data coordinates of series rendered inside this plot to the plot's pixels. (Inherited from Plot2D.)
YAxis | Gets or sets default Axis instance used to map Y data coordinates of series rendered inside this plot to the plot's pixels. (Inherited from Plot2D.)
ZAxis | Gets or sets default Axis instance used to map Z data coordinates of series rendered inside this plot to the plot's pixels.

See Also

Plot3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Plot3D.ZAxis Property

Plot3D.ZAxis Property
[image]

Gets or sets default Axis instance used to map Z data coordinates of series rendered inside this plot to the plot's pixels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Axis ZAxis { get; set; }

Visual Basic [image] Copy Code

Public Property ZAxis As Axis

Property Value

See Also

Plot3D Members
Plot3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PlotController Class

PlotController Class
[image]

A base class for controllers implementing user interaction with Plot components.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class PlotController : ComponentController

Visual Basic [image] Copy Code

Public Class PlotController
Implements ComponentController

Inheritance Hierarchy

System.Object
MindFusion.Charting.PlotController
MindFusion.Charting.LegendController
MindFusion.Charting.Plot2DController
MindFusion.Charting.RotationController

See Also

PlotController Members
MindFusion.Charting Namespace


MindFusion.Charting.PlotController Members

PlotController Members
Constructors Fields Properties Methods
[image]

A base class for controllers implementing user interaction with Plot components.

The following tables list the members exposed by the PlotController type.

Public Constructors

Name | Description
PlotController | Initializes a new instance of the PlotController class.

Protected Fields

Name | Description
renderContext | The current RenderContext.

Public Properties

Name | Description
Component | Gets the component controlled by this PlotController.

Public Methods

Name | Description
DrawInteraction | Implements ComponentController.DrawInteraction. Draws a representation of the current state of user interaction on specified IGraphics surface.
GetRunningAnimation | For internal use.
OnMouseDown | Implements ComponentController.OnMouseDown. Called when the user presses a mouse button.
OnMouseMove | Implements ComponentController.OnMouseMove. Called when the user moves the mouse.
OnMouseUp | Implements ComponentController.OnMouseUp. Called when the user releases a mouse button.

See Also

PlotController Class
MindFusion.Charting Namespace


MindFusion.Charting.PlotController Fields

PlotController Fields
[image]

Protected Fields

Name | Description
renderContext | The current RenderContext.

See Also

PlotController Class
MindFusion.Charting Namespace


MindFusion.Charting.PlotController.renderContext Field

PlotController.renderContext Field
[image]

The current RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected RenderContext renderContext

Visual Basic [image] Copy Code

Protected renderContext As RenderContext

See Also

PlotController Members
PlotController Class
MindFusion.Charting Namespace


MindFusion.Charting.PlotController Constructor

PlotController Constructor
[image]

Initializes a new instance of the PlotController class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PlotController (
RenderContext renderContext
)

Visual Basic [image] Copy Code

Public New ( _
renderContext As RenderContext _
)

Parameters

renderContext

A RenderContext instance.

See Also

PlotController Class
MindFusion.Charting Namespace


MindFusion.Charting.PlotController Methods

PlotController Methods
[image]

Public Methods

Name | Description
DrawInteraction | Implements ComponentController.DrawInteraction. Draws a representation of the current state of user interaction on specified IGraphics surface.
GetRunningAnimation | For internal use.
OnMouseDown | Implements ComponentController.OnMouseDown. Called when the user presses a mouse button.
OnMouseMove | Implements ComponentController.OnMouseMove. Called when the user moves the mouse.
OnMouseUp | Implements ComponentController.OnMouseUp. Called when the user releases a mouse button.

See Also

PlotController Class
MindFusion.Charting Namespace


MindFusion.Charting.PlotController.DrawInteraction Method

PlotController.DrawInteraction Method
[image]

Implements ComponentController.DrawInteraction. Draws a representation of the current state of user interaction on specified IGraphics surface.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual void DrawInteraction (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawInteraction( _
graphics As IGraphics _
)

Parameters

graphics

An IGraphics instance.

See Also

PlotController Members
PlotController Class
MindFusion.Charting Namespace


MindFusion.Charting.PlotController.GetRunningAnimation Method

PlotController.GetRunningAnimation Method
[image]

For internal use.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual ComponentAnimation GetRunningAnimation ()

Visual Basic [image] Copy Code

Public Overridable Function GetRunningAnimation () As ComponentAnimation

Return Value

An instance of a ComponentAnimation -derived class.

See Also

PlotController Members
PlotController Class
MindFusion.Charting Namespace


MindFusion.Charting.PlotController.OnMouseDown Method

PlotController.OnMouseDown Method
[image]

Implements ComponentController.OnMouseDown. Called when the user presses a mouse button.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual void OnMouseDown (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overridable Sub OnMouseDown( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

PlotController Members
PlotController Class
MindFusion.Charting Namespace


MindFusion.Charting.PlotController.OnMouseMove Method

PlotController.OnMouseMove Method
[image]

Implements ComponentController.OnMouseMove. Called when the user moves the mouse.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual void OnMouseMove (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overridable Sub OnMouseMove( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

PlotController Members
PlotController Class
MindFusion.Charting Namespace


MindFusion.Charting.PlotController.OnMouseUp Method

PlotController.OnMouseUp Method
[image]

Implements ComponentController.OnMouseUp. Called when the user releases a mouse button.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual void OnMouseUp (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overridable Sub OnMouseUp( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

PlotController Members
PlotController Class
MindFusion.Charting Namespace


MindFusion.Charting.PlotController Properties

PlotController Properties
[image]

Public Properties

Name | Description
Component | Gets the component controlled by this PlotController.

See Also

PlotController Class
MindFusion.Charting Namespace


MindFusion.Charting.PlotController.Component Property

PlotController.Component Property
[image]

Gets the component controlled by this PlotController.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Component Component { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Component As Component

Property Value

See Also

PlotController Members
PlotController Class
MindFusion.Charting Namespace


MindFusion.Charting.Point3D Structure

Point3D Structure
[image]

Represents a point in 3D space.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public struct Point3D

Visual Basic [image] Copy Code

Public Structure Point3D

See Also

Point3D Members
MindFusion.Charting Namespace


MindFusion.Charting.Point3D Members

Point3D Members
Constructors Properties Methods
[image]

Represents a point in 3D space.

The following tables list the members exposed by the Point3D type.

Public Constructors

Name | Description
Point3D | Initializes a new instance of the Point3D struct.

Public Properties

Name | Description
X | Gets or sets the X coordinate of this point.
Y | Gets or sets the Y coordinate of this point.
Z | Gets or sets the Z coordinate of this point.

Public Methods

Name | Description
Add | Sums two points' coordinates.
Distance | Gets the distance to specified point.
Scale | Scales the point's coordinates by specified scale factor.
ToString | Object.ToString override.

See Also

Point3D Structure
MindFusion.Charting Namespace


MindFusion.Charting.Point3D Constructor

Point3D Constructor
[image]

Initializes a new instance of the Point3D struct.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Point3D (
double x,
double y,
double z
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
z As Double _
)

Parameters

x

X coordinate of the point.

y

Y coordinate of the point.

z

Z coordinate of the point.

See Also

Point3D Structure
MindFusion.Charting Namespace


MindFusion.Charting.Point3D Methods

Point3D Methods
[image]

Public Methods

Name | Description
Add | Sums two points' coordinates.
Distance | Gets the distance to specified point.
Scale | Scales the point's coordinates by specified scale factor.
ToString | Object.ToString override.

See Also

Point3D Structure
MindFusion.Charting Namespace


MindFusion.Charting.Point3D.Add Method

Point3D.Add Method
[image]

Sums two points' coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static Point3D Add (
Point3D p1,
Point3D p2
)

Visual Basic [image] Copy Code

Public Shared Function Add( _
p1 As Point3D, _
p2 As Point3D _
) As Point3D

Parameters

p1

The first point.

p2

The second point.

Return Value

A Point3D containing sum of coordinates.

See Also

Point3D Members
Point3D Structure
MindFusion.Charting Namespace


MindFusion.Charting.Point3D.Distance Method

Point3D.Distance Method
[image]

Gets the distance to specified point.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Distance (
Point3D p
)

Visual Basic [image] Copy Code

Public Function Distance( _
p As Point3D _
) As Double

Parameters

p

A Point3D instance.

Return Value

A double value representing the distance.

See Also

Point3D Members
Point3D Structure
MindFusion.Charting Namespace


MindFusion.Charting.Point3D.Scale Method

Point3D.Scale Method
[image]

Scales the point's coordinates by specified scale factor.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Point3D Scale (
double scale
)

Visual Basic [image] Copy Code

Public Function Scale( _
scale As Double _
) As Point3D

Parameters

scale

A double value by which to multiply point's coordinates.

Return Value

A Point3D containing scaled coordinates.

See Also

Point3D Members
Point3D Structure
MindFusion.Charting Namespace


MindFusion.Charting.Point3D.ToString Method

Point3D.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representation of the points.

See Also

Point3D Members
Point3D Structure
MindFusion.Charting Namespace


MindFusion.Charting.Point3D Properties

Point3D Properties
[image]

Public Properties

Name | Description
X | Gets or sets the X coordinate of this point.
Y | Gets or sets the Y coordinate of this point.
Z | Gets or sets the Z coordinate of this point.

See Also

Point3D Structure
MindFusion.Charting Namespace


MindFusion.Charting.Point3D.X Property

Point3D.X Property
[image]

Gets or sets the X coordinate of this point.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

See Also

Point3D Members
Point3D Structure
MindFusion.Charting Namespace


MindFusion.Charting.Point3D.Y Property

Point3D.Y Property
[image]

Gets or sets the Y coordinate of this point.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

See Also

Point3D Members
Point3D Structure
MindFusion.Charting Namespace


MindFusion.Charting.Point3D.Z Property

Point3D.Z Property
[image]

Gets or sets the Z coordinate of this point.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Z { get; set; }

Visual Basic [image] Copy Code

Public Property Z As Double

Property Value

See Also

Point3D Members
Point3D Structure
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries Class

PointSeries Class
[image]

Represents a data series defined by a list of PointF objects.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class PointSeries : Series

Visual Basic [image] Copy Code

Public Class PointSeries
Implements Series

Inheritance Hierarchy

System.Object
MindFusion.Charting.PointSeries

See Also

PointSeries Members
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries Members

PointSeries Members
Constructors Properties Methods Events
[image]

Represents a data series defined by a list of PointF objects.

The following tables list the members exposed by the PointSeries type.

Public Constructors

Name | Description
PointSeries | Initializes a new instance of the PointSeries class.

Public Properties

Name | Description
Dimensions | Implements Series.Dimensions. Returns 2.
Labels | Gets or sets the data labels.
Points | Gets or sets the series' points.
Size | Implements Series.Size. Returns the number of elements in Points list.
SupportedLabels | Implements Series.SupportedLabels. Returns InnerLabel.
Title | Implements Series.Title. Gets or sets the title of this series.

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns an element of the Labels list.
GetValue | Implements Series.GetValue. Returns a coordinate of specified point in this series.
IsEmphasized | Implements Series.IsEmphasized. PointSeries always returns false.
IsSorted | Implements Series.IsSorted. PointSeries always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries Constructor

PointSeries Constructor
[image]

Initializes a new instance of the PointSeries class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PointSeries (
IList<PointF> points,
IList<string> labels
)

Visual Basic [image] Copy Code

Public New ( _
points As IList(Of PointF), _
labels As IList(Of String) _
)

Parameters

points

A list of points.

labels

A list of labels.

See Also

PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries Methods

PointSeries Methods
[image]

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns an element of the Labels list.
GetValue | Implements Series.GetValue. Returns a coordinate of specified point in this series.
IsEmphasized | Implements Series.IsEmphasized. PointSeries always returns false.
IsSorted | Implements Series.IsSorted. PointSeries always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

See Also

PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries.GetLabel Method

PointSeries.GetLabel Method
[image]

Implements Series.GetLabel. Returns an element of the Labels list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string GetLabel (
int index,
LabelKinds kind
)

Visual Basic [image] Copy Code

Public Function GetLabel( _
index As Integer, _
kind As LabelKinds _
) As String

Parameters

index

An integer value specifying the index of a data item.

kind

A member of the LabelKinds enumeration.

Return Value

A string containing the item's label.

See Also

PointSeries Members
PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries.GetValue Method

PointSeries.GetValue Method
[image]

Implements Series.GetValue. Returns a coordinate of specified point in this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GetValue (
int index,
int dimension
)

Visual Basic [image] Copy Code

Public Function GetValue( _
index As Integer, _
dimension As Integer _
) As Double

Parameters

index

An integer value specifying the index of a data item.

dimension

An integer value specifying the dimension whose coordinate to return.

Return Value

A double-precision number representing the value of a data item in the series.

See Also

PointSeries Members
PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries.IsEmphasized Method

PointSeries.IsEmphasized Method
[image]

Implements Series.IsEmphasized. PointSeries always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsEmphasized (
int index
)

Visual Basic [image] Copy Code

Public Function IsEmphasized( _
index As Integer _
) As Boolean

Parameters

index

An integer value specifying the index of a data item.

Return Value

true to emphasize the specified data item, or false otherwise.

See Also

PointSeries Members
PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries.IsSorted Method

PointSeries.IsSorted Method
[image]

Implements Series.IsSorted. PointSeries always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsSorted (
int dimension
)

Visual Basic [image] Copy Code

Public Function IsSorted( _
dimension As Integer _
) As Boolean

Parameters

dimension

An integer value identifying the dimension.

Return Value

true if the values are sorted in specified dimension, or false otherwise.

See Also

PointSeries Members
PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries.OnDataChanged Method

PointSeries.OnDataChanged Method
[image]

Raises the DataChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void OnDataChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnDataChanged ()

See Also

PointSeries Members
PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries Properties

PointSeries Properties
[image]

Public Properties

Name | Description
Dimensions | Implements Series.Dimensions. Returns 2.
Labels | Gets or sets the data labels.
Points | Gets or sets the series' points.
Size | Implements Series.Size. Returns the number of elements in Points list.
SupportedLabels | Implements Series.SupportedLabels. Returns InnerLabel.
Title | Implements Series.Title. Gets or sets the title of this series.

See Also

PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries.Dimensions Property

PointSeries.Dimensions Property
[image]

Implements Series.Dimensions. Returns 2.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Dimensions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dimensions As Integer

Property Value

See Also

PointSeries Members
PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries.Labels Property

PointSeries.Labels Property
[image]

Gets or sets the data labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<string> Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Labels As IList(Of String)

Property Value

See Also

PointSeries Members
PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries.Points Property

PointSeries.Points Property
[image]

Gets or sets the series' points.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<PointF> Points { get; set; }

Visual Basic [image] Copy Code

Public Property Points As IList(Of PointF)

Property Value

See Also

PointSeries Members
PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries.Size Property

PointSeries.Size Property
[image]

Implements Series.Size. Returns the number of elements in Points list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Size { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Size As Integer

Property Value

See Also

PointSeries Members
PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries.SupportedLabels Property

PointSeries.SupportedLabels Property
[image]

Implements Series.SupportedLabels. Returns InnerLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public LabelKinds SupportedLabels { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SupportedLabels As LabelKinds

Property Value

See Also

PointSeries Members
PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries.Title Property

PointSeries.Title Property
[image]

Implements Series.Title. Gets or sets the title of this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

PointSeries Members
PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries Events

PointSeries Events
[image]

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries.DataChanged Event

PointSeries.DataChanged Event
[image]

Implements Series.DataChanged. Raised when the values in this series change.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

See Also

PointSeries Members
PointSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D Class

PointSeries3D Class
[image]

Represents a data series defined by a list of Point3D objects.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class PointSeries3D : Series

Visual Basic [image] Copy Code

Public Class PointSeries3D
Implements Series

Inheritance Hierarchy

System.Object
MindFusion.Charting.PointSeries3D

See Also

PointSeries3D Members
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D Members

PointSeries3D Members
Constructors Properties Methods Events
[image]

Represents a data series defined by a list of Point3D objects.

The following tables list the members exposed by the PointSeries3D type.

Public Constructors

Name | Description
PointSeries3D | Initializes a new instance of the PointSeries3D class.

Public Properties

Name | Description
Dimensions | Implements Series.Dimensions. Returns 3.
Labels | Gets or sets the data labels.
Points | Gets or sets the series' points.
Size | Implements Series.Size. Returns the number of elements in Points list.
SupportedLabels | Implements Series.SupportedLabels. Returns InnerLabel.
Title | Implements Series.Title. Gets or sets the title of this series.

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns an element of the Labels list.
GetValue | Implements Series.GetValue. Returns a coordinate of specified point in this series.
IsEmphasized | Implements Series.IsEmphasized. PointSeries3D always returns false.
IsSorted | Implements Series.IsSorted. PointSeries3D always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D Constructor

PointSeries3D Constructor
[image]

Initializes a new instance of the PointSeries3D class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PointSeries3D (
IList<Point3D> points,
IList<string> labels
)

Visual Basic [image] Copy Code

Public New ( _
points As IList(Of Point3D), _
labels As IList(Of String) _
)

Parameters

points

A list of 3D points.

labels

A list of labels.

See Also

PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D Methods

PointSeries3D Methods
[image]

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns an element of the Labels list.
GetValue | Implements Series.GetValue. Returns a coordinate of specified point in this series.
IsEmphasized | Implements Series.IsEmphasized. PointSeries3D always returns false.
IsSorted | Implements Series.IsSorted. PointSeries3D always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

See Also

PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D.GetLabel Method

PointSeries3D.GetLabel Method
[image]

Implements Series.GetLabel. Returns an element of the Labels list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string GetLabel (
int index,
LabelKinds kind
)

Visual Basic [image] Copy Code

Public Function GetLabel( _
index As Integer, _
kind As LabelKinds _
) As String

Parameters

index

An integer value specifying the index of a data item.

kind

A member of the LabelKinds enumeration.

Return Value

A string containing the item's label.

See Also

PointSeries3D Members
PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D.GetValue Method

PointSeries3D.GetValue Method
[image]

Implements Series.GetValue. Returns a coordinate of specified point in this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GetValue (
int index,
int dimension
)

Visual Basic [image] Copy Code

Public Function GetValue( _
index As Integer, _
dimension As Integer _
) As Double

Parameters

index

An integer value specifying the index of a data item.

dimension

An integer value specifying the dimension whose coordinate to return.

Return Value

A double-precision number representing the value of a data item in the series.

See Also

PointSeries3D Members
PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D.IsEmphasized Method

PointSeries3D.IsEmphasized Method
[image]

Implements Series.IsEmphasized. PointSeries3D always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsEmphasized (
int index
)

Visual Basic [image] Copy Code

Public Function IsEmphasized( _
index As Integer _
) As Boolean

Parameters

index

An integer value specifying the index of a data item.

Return Value

true to emphasize the specified data item, or false otherwise.

See Also

PointSeries3D Members
PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D.IsSorted Method

PointSeries3D.IsSorted Method
[image]

Implements Series.IsSorted. PointSeries3D always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsSorted (
int dimension
)

Visual Basic [image] Copy Code

Public Function IsSorted( _
dimension As Integer _
) As Boolean

Parameters

dimension

An integer value identifying the dimension.

Return Value

true if the values are sorted in specified dimension, or false otherwise.

See Also

PointSeries3D Members
PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D.OnDataChanged Method

PointSeries3D.OnDataChanged Method
[image]

Raises the DataChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void OnDataChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnDataChanged ()

See Also

PointSeries3D Members
PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D Properties

PointSeries3D Properties
[image]

Public Properties

Name | Description
Dimensions | Implements Series.Dimensions. Returns 3.
Labels | Gets or sets the data labels.
Points | Gets or sets the series' points.
Size | Implements Series.Size. Returns the number of elements in Points list.
SupportedLabels | Implements Series.SupportedLabels. Returns InnerLabel.
Title | Implements Series.Title. Gets or sets the title of this series.

See Also

PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D.Dimensions Property

PointSeries3D.Dimensions Property
[image]

Implements Series.Dimensions. Returns 3.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Dimensions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dimensions As Integer

Property Value

See Also

PointSeries3D Members
PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D.Labels Property

PointSeries3D.Labels Property
[image]

Gets or sets the data labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<string> Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Labels As IList(Of String)

Property Value

See Also

PointSeries3D Members
PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D.Points Property

PointSeries3D.Points Property
[image]

Gets or sets the series' points.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<Point3D> Points { get; set; }

Visual Basic [image] Copy Code

Public Property Points As IList(Of Point3D)

Property Value

See Also

PointSeries3D Members
PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D.Size Property

PointSeries3D.Size Property
[image]

Implements Series.Size. Returns the number of elements in Points list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Size { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Size As Integer

Property Value

See Also

PointSeries3D Members
PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D.SupportedLabels Property

PointSeries3D.SupportedLabels Property
[image]

Implements Series.SupportedLabels. Returns InnerLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public LabelKinds SupportedLabels { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SupportedLabels As LabelKinds

Property Value

See Also

PointSeries3D Members
PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D.Title Property

PointSeries3D.Title Property
[image]

Implements Series.Title. Gets or sets the title of this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

PointSeries3D Members
PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D Events

PointSeries3D Events
[image]

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PointSeries3D.DataChanged Event

PointSeries3D.DataChanged Event
[image]

Implements Series.DataChanged. Raised when the values in this series change.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

See Also

PointSeries3D Members
PointSeries3D Class
MindFusion.Charting Namespace


MindFusion.Charting.PolarPlot Class

PolarPlot Class
Remarks See Also
[image]

A plot used to draw graphics in polar coordinate system.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class PolarPlot : Plot

Visual Basic [image] Copy Code

Public Class PolarPlot
Inherits Plot

Remarks

This component implements drawing surface for renderers that work in polar coordinate system, such as PieRenderer.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Components.Component
MindFusion.Charting.Plot
MindFusion.Charting.PolarPlot
MindFusion.Charting.RadarPlot

See Also

PolarPlot Members
MindFusion.Charting Namespace


MindFusion.Charting.PolarPlot Members

PolarPlot Members
Constructors Properties Methods
[image]

A plot used to draw graphics in polar coordinate system.

The following tables list the members exposed by the PolarPlot type.

Public Constructors

Name | Description
PolarPlot | Initializes a new instance of the PolarPlot class.

Public Properties

Name | Description
AllowRotate | Gets or sets a value indicating whether users are allowed to rotate this plot.
Background | Gets or sets the Brush that should be used to fill the background of this plot. (Inherited from Plot.)
BorderStroke | Gets or sets the Brush that should be used to stroke the borders of this plot. (Inherited from Plot.)
BorderStrokeDashStyle | Gets or sets the stroke dash style of plot borders. (Inherited from Plot.)
BorderStrokeThickness | Gets or sets the stroke thickness of plot borders. (Inherited from Plot.)
HighlightedItem | Gets or sets the data item that should be drawn highlighted. (Inherited from Plot.)
HighlightStroke | Gets or sets the Brush used to stroke highlighted item. (Inherited from Plot.)
HighlightStrokeDashStyle | Gets or sets the stroke dash style of highlighted item. (Inherited from Plot.)
HighlightStrokeThickness | Gets or sets the stroke thickness of highlighted item. (Inherited from Plot.)
Padding | Gets or set padding space between the plot's border and series graphics.
SeriesRenderers | Gets or sets the SeriesRenderer objects that should draw inside this plot. (Inherited from Plot.)
SeriesStyle | Gets or sets a SeriesStyle whose attributes should be used to draw series inside this plot, unless their own renderers have a local SeriesStyle value set for respetive attribute. (Inherited from Plot.)
StartAngle | Gets or set the angle where first data item of series should be drawn.

Public Methods

Name | Description
AdjustDataRanges | Called at the end of data measurement pass. (Inherited from Plot.)
CreateController | Component.CreateController override. Returns a ComponentController used to interact with this component.
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from Plot.)
Draw | Component.Draw override. Draws a grid and all chart graphics represented by contained SeriesRenderer objects. (Inherited from Plot.)
EffectiveBorderStroke | Gets the Brush that should be used to stroke the plot's borders. (Inherited from Plot.)
EffectiveFill | Gets the Brush that should be used to fill the plot's background. (Inherited from Plot.)
EnumSeries | Implements SeriesContainer. (Inherited from Plot.)
Measure | Component.Measure override. Measures the desired size of this component. (Inherited from Plot.)
MeasureDataRanges | Measures data of all SeriesRenderer objects drawn inside this plot. (Inherited from Plot.)
StartMeasureData | Called in the beginning of data measurement pass. (Inherited from Plot.)
Visit | Component.Visit override. Calls visitor's VisitPlot method.

Protected Methods

Name | Description
DrawGrid | Draws the plot's grid. (Inherited from Plot.)
DrawPlot | Draws the plot's background and borders. (Inherited from Plot.)
EffectiveBorder | Gets the Pen that should be used to draw the plot's borders. (Inherited from Plot.)
EffectiveBorderStrokeThickness | Gets the thickness of border strokes. (Inherited from Plot.)
EffectiveStrokeDashStyle | Gets the dash style of border strokes. (Inherited from Plot.)
OnRendererDataChanged | Called when a Series raises its DataChanged event. (Inherited from Plot.)
RotatePoint | Rotates point around specified rotation center at specified angle.

See Also

PolarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.PolarPlot Constructor

PolarPlot Constructor
[image]

Initializes a new instance of the PolarPlot class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PolarPlot ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PolarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.PolarPlot Methods

PolarPlot Methods
[image]

Public Methods

Name | Description
AdjustDataRanges | Called at the end of data measurement pass. (Inherited from Plot.)
CreateController | Component.CreateController override. Returns a ComponentController used to interact with this component.
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from Plot.)
Draw | Component.Draw override. Draws a grid and all chart graphics represented by contained SeriesRenderer objects. (Inherited from Plot.)
EffectiveBorderStroke | Gets the Brush that should be used to stroke the plot's borders. (Inherited from Plot.)
EffectiveFill | Gets the Brush that should be used to fill the plot's background. (Inherited from Plot.)
EnumSeries | Implements SeriesContainer. (Inherited from Plot.)
Measure | Component.Measure override. Measures the desired size of this component. (Inherited from Plot.)
MeasureDataRanges | Measures data of all SeriesRenderer objects drawn inside this plot. (Inherited from Plot.)
StartMeasureData | Called in the beginning of data measurement pass. (Inherited from Plot.)
Visit | Component.Visit override. Calls visitor's VisitPlot method.

Protected Methods

Name | Description
DrawGrid | Draws the plot's grid. (Inherited from Plot.)
DrawPlot | Draws the plot's background and borders. (Inherited from Plot.)
EffectiveBorder | Gets the Pen that should be used to draw the plot's borders. (Inherited from Plot.)
EffectiveBorderStrokeThickness | Gets the thickness of border strokes. (Inherited from Plot.)
EffectiveStrokeDashStyle | Gets the dash style of border strokes. (Inherited from Plot.)
OnRendererDataChanged | Called when a Series raises its DataChanged event. (Inherited from Plot.)
RotatePoint | Rotates point around specified rotation center at specified angle.

See Also

PolarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.PolarPlot.CreateController Method

PolarPlot.CreateController Method
[image]

Component.CreateController override. Returns a ComponentController used to interact with this component.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override ComponentController CreateController (
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Function CreateController( _
context As RenderContext _
) As ComponentController

Parameters

context

A RenderContext instance.

Return Value

An instance of the RotationController class.

See Also

PolarPlot Members
PolarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.PolarPlot.RotatePoint Method

PolarPlot.RotatePoint Method
[image]

Rotates point around specified rotation center at specified angle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected PointF RotatePoint (
PointF pointToRotate,
PointF centerPoint,
double angleInDegrees
)

Visual Basic [image] Copy Code

Protected Function RotatePoint( _
pointToRotate As PointF, _
centerPoint As PointF, _
angleInDegrees As Double _
) As PointF

Parameters

pointToRotate

The point to rotate.

centerPoint

The rotation center.

angleInDegrees

The rotation angle.

Return Value

See Also

PolarPlot Members
PolarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.PolarPlot.Visit Method

PolarPlot.Visit Method
[image]

Component.Visit override. Calls visitor's VisitPlot method.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void Visit (
ComponentVisitor visitor
)

Visual Basic [image] Copy Code

Public Overrides Sub Visit( _
visitor As ComponentVisitor _
)

Parameters

visitor

An instance of a ComponentVisitor -derived class.

See Also

PolarPlot Members
PolarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.PolarPlot Properties

PolarPlot Properties
[image]

Public Properties

Name | Description
AllowRotate | Gets or sets a value indicating whether users are allowed to rotate this plot.
Background | Gets or sets the Brush that should be used to fill the background of this plot. (Inherited from Plot.)
BorderStroke | Gets or sets the Brush that should be used to stroke the borders of this plot. (Inherited from Plot.)
BorderStrokeDashStyle | Gets or sets the stroke dash style of plot borders. (Inherited from Plot.)
BorderStrokeThickness | Gets or sets the stroke thickness of plot borders. (Inherited from Plot.)
HighlightedItem | Gets or sets the data item that should be drawn highlighted. (Inherited from Plot.)
HighlightStroke | Gets or sets the Brush used to stroke highlighted item. (Inherited from Plot.)
HighlightStrokeDashStyle | Gets or sets the stroke dash style of highlighted item. (Inherited from Plot.)
HighlightStrokeThickness | Gets or sets the stroke thickness of highlighted item. (Inherited from Plot.)
Padding | Gets or set padding space between the plot's border and series graphics.
SeriesRenderers | Gets or sets the SeriesRenderer objects that should draw inside this plot. (Inherited from Plot.)
SeriesStyle | Gets or sets a SeriesStyle whose attributes should be used to draw series inside this plot, unless their own renderers have a local SeriesStyle value set for respetive attribute. (Inherited from Plot.)
StartAngle | Gets or set the angle where first data item of series should be drawn.

See Also

PolarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.PolarPlot.AllowRotate Property

PolarPlot.AllowRotate Property
[image]

Gets or sets a value indicating whether users are allowed to rotate this plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool AllowRotate { get; set; }

Visual Basic [image] Copy Code

Public Property AllowRotate As Boolean

Property Value

See Also

PolarPlot Members
PolarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.PolarPlot.Padding Property

PolarPlot.Padding Property
[image]

Gets or set padding space between the plot's border and series graphics.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Integer

Property Value

See Also

PolarPlot Members
PolarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.PolarPlot.StartAngle Property

PolarPlot.StartAngle Property
[image]

Gets or set the angle where first data item of series should be drawn.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public float StartAngle { get; set; }

Visual Basic [image] Copy Code

Public Property StartAngle As Single

Property Value

See Also

PolarPlot Members
PolarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.PropertyEventArgs Class

PropertyEventArgs Class
[image]

Provides data for the PropertyValueChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class PropertyEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class PropertyEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Charting.PropertyEventArgs

See Also

PropertyEventArgs Members
MindFusion.Charting Namespace


MindFusion.Charting.PropertyEventArgs Members

PropertyEventArgs Members
Properties
[image]

Provides data for the PropertyValueChanged event.

The following tables list the members exposed by the PropertyEventArgs type.

Public Properties

Name | Description
NewValue | Gets the current value of the property.
OldValue | Gets the value of the property before the change.
PropertyName | Gets the name of the property that changed.

See Also

PropertyEventArgs Class
MindFusion.Charting Namespace


MindFusion.Charting.PropertyEventArgs Properties

PropertyEventArgs Properties
[image]

Public Properties

Name | Description
NewValue | Gets the current value of the property.
OldValue | Gets the value of the property before the change.
PropertyName | Gets the name of the property that changed.

See Also

PropertyEventArgs Class
MindFusion.Charting Namespace


MindFusion.Charting.PropertyEventArgs.NewValue Property

PropertyEventArgs.NewValue Property
[image]

Gets the current value of the property.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Object NewValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewValue As Object

Property Value

See Also

PropertyEventArgs Members
PropertyEventArgs Class
MindFusion.Charting Namespace


MindFusion.Charting.PropertyEventArgs.OldValue Property

PropertyEventArgs.OldValue Property
[image]

Gets the value of the property before the change.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Object OldValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldValue As Object

Property Value

See Also

PropertyEventArgs Members
PropertyEventArgs Class
MindFusion.Charting Namespace


MindFusion.Charting.PropertyEventArgs.PropertyName Property

PropertyEventArgs.PropertyName Property
[image]

Gets the name of the property that changed.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string PropertyName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PropertyName As String

Property Value

See Also

PropertyEventArgs Members
PropertyEventArgs Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarAxisOptions Class

RadarAxisOptions Class
[image]

Provides properties for customizing axis rendering in radar charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class RadarAxisOptions : AxisRenderer

Visual Basic [image] Copy Code

Public Class RadarAxisOptions
Inherits AxisRenderer

Inheritance Hierarchy

System.Object
MindFusion.Charting.Components.Component
MindFusion.Charting.AxisRenderer
MindFusion.Charting.RadarAxisOptions

See Also

RadarAxisOptions Members
MindFusion.Charting Namespace


MindFusion.Charting.RadarAxisOptions Members

RadarAxisOptions Members
Constructors Properties Methods
[image]

Provides properties for customizing axis rendering in radar charts.

The following tables list the members exposed by the RadarAxisOptions type.

Public Constructors

Name | Description
RadarAxisOptions | Initializes a new instance of the RadarAxisOptions class.

Public Properties

Name | Description
Axis | The Axis that will be drawn by this object. (Inherited from AxisRenderer.)
AxisStroke | Gets or sets the Brush that should be used to draw axis lines. (Inherited from AxisRenderer.)
AxisStrokeDashStyle | Gets or sets the dash style axis lines should be stroked with. (Inherited from AxisRenderer.)
AxisStrokeThickness | Gets or sets the thickness axis lines should be stroked with. (Inherited from AxisRenderer.)
LabelBrush | Gets or sets the Brush that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelPadding | Gets or sets the padding space between the axis line and coordinate labels. (Inherited from AxisRenderer.)
LabelsSource | Gets or sets the object whose Series labels should be rendered along this axis. (Inherited from AxisRenderer.)
PinLabels | Gets or sets a value indicating whether coordinate labels should be pinned in place or scroll together with the plot when users pan it. (Inherited from AxisRenderer.)
ShowCoordinates | Gets or sets a value indicating whether this AxisRenderer should draw axis coordinates. (Inherited from AxisRenderer.)
ShowSeriesLabels | Gets or sets a value indicating whether this AxisRenderer should draw data labels. (Inherited from AxisRenderer.)
ShowTicks | Gets or sets a value indicating whether this AxisRenderer should draw axis ticks. (Inherited from AxisRenderer.)
TickLength | Gets or sets the length of the axis ticks. (Inherited from AxisRenderer.)
TitleBrush | Gets or sets the Brush that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontName | Gets or sets the name of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontSize | Gets or sets the size of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontStyle | Gets or sets the style of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)

Public Methods

Name | Description
Draw | AxisRenderer.Draw override.
Measure | AxisRenderer.Measure override.

Protected Methods

Name | Description
EffectiveAxis | AxisRenderer.EffectiveAxis override.
EffectiveAxisDashStyle | Gets the dash style of axis line strokes. (Inherited from AxisRenderer.)
EffectiveAxisStroke | Gets the Brush that should be used to stroke axis lines. (Inherited from AxisRenderer.)
EffectiveAxisStrokeThickness | Gets the thickness of axis line strokes. (Inherited from AxisRenderer.)
EffectiveLabelBrush | Gets the Brush that should be used to draw axis labels. (Inherited from AxisRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw axis labels. (Inherited from AxisRenderer.)
EffectivePen | Gets the Pen that should be used to draw axis lines. (Inherited from AxisRenderer.)
EffectiveTitleBrush | Gets the Brush that should be used to draw the axis Title. (Inherited from AxisRenderer.)
EffectiveTitleFont | Gets the Font that should be used to draw the axis Title. (Inherited from AxisRenderer.)

See Also

RadarAxisOptions Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarAxisOptions Constructor

RadarAxisOptions Constructor
[image]

Initializes a new instance of the RadarAxisOptions class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public RadarAxisOptions (
Axis axis
)

Visual Basic [image] Copy Code

Public New ( _
axis As Axis _
)

Parameters

axis

See Also

RadarAxisOptions Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarAxisOptions Methods

RadarAxisOptions Methods
[image]

Public Methods

Name | Description
Draw | AxisRenderer.Draw override.
Measure | AxisRenderer.Measure override.

Protected Methods

Name | Description
EffectiveAxis | AxisRenderer.EffectiveAxis override.
EffectiveAxisDashStyle | Gets the dash style of axis line strokes. (Inherited from AxisRenderer.)
EffectiveAxisStroke | Gets the Brush that should be used to stroke axis lines. (Inherited from AxisRenderer.)
EffectiveAxisStrokeThickness | Gets the thickness of axis line strokes. (Inherited from AxisRenderer.)
EffectiveLabelBrush | Gets the Brush that should be used to draw axis labels. (Inherited from AxisRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw axis labels. (Inherited from AxisRenderer.)
EffectivePen | Gets the Pen that should be used to draw axis lines. (Inherited from AxisRenderer.)
EffectiveTitleBrush | Gets the Brush that should be used to draw the axis Title. (Inherited from AxisRenderer.)
EffectiveTitleFont | Gets the Font that should be used to draw the axis Title. (Inherited from AxisRenderer.)

See Also

RadarAxisOptions Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarAxisOptions.Draw Method

RadarAxisOptions.Draw Method
[image]

AxisRenderer.Draw override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

See Also

RadarAxisOptions Members
RadarAxisOptions Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarAxisOptions.EffectiveAxis Method

RadarAxisOptions.EffectiveAxis Method
[image]

AxisRenderer.EffectiveAxis override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override Axis EffectiveAxis (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function EffectiveAxis( _
context As RenderContext _
) As Axis

Parameters

context

Return Value

See Also

RadarAxisOptions Members
RadarAxisOptions Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarAxisOptions.Measure Method

RadarAxisOptions.Measure Method
[image]

AxisRenderer.Measure override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void Measure (
double maxWidth,
double maxHeight,
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub Measure( _
maxWidth As Double, _
maxHeight As Double, _
context As RenderContext _
)

Parameters

maxWidth

maxHeight

context

See Also

RadarAxisOptions Members
RadarAxisOptions Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarGridType Enumeration

RadarGridType Enumeration
[image]

Identifies the grid types supported by RadarPlot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public enum RadarGridType

Visual Basic [image] Copy Code

Public Enum RadarGridType

Members

Member name | Description
Radar | Identifies radar grid consisting as concentric circles.
Spiderweb | Identifies spider-web grid consisting as concentric regular polygons.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot Class

RadarPlot Class
Remarks See Also
[image]

A plot containing radar-chart graphics.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class RadarPlot : PolarPlot

Visual Basic [image] Copy Code

Public Class RadarPlot
Inherits PolarPlot

Remarks

This component implements drawing surface for radar-chart graphics renderers such as RadarRenderer, PieRadarRenderer, RadarScatterRenderer. The plot can contain a combination of such renderers, each having their distinct appearance settings.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Components.Component
MindFusion.Charting.Plot
MindFusion.Charting.PolarPlot
MindFusion.Charting.RadarPlot

See Also

RadarPlot Members
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot Members

RadarPlot Members
Constructors Properties Methods
[image]

A plot containing radar-chart graphics.

The following tables list the members exposed by the RadarPlot type.

Public Constructors

Name | Description
RadarPlot | Initializes a new instance of the RadarPlot class.

Public Properties

Name | Description
AllowRotate | Gets or sets a value indicating whether users are allowed to rotate this plot. (Inherited from PolarPlot.)
Axes | Gets the list of Axis objects representing ranges of variables represented in the radar chart.
AxisOptions | Gets a RadarAxisOptions object providing properties for customizing axis rendering in radar charts.
Background | Gets or sets the Brush that should be used to fill the background of this plot. (Inherited from Plot.)
BorderStroke | Gets or sets the Brush that should be used to stroke the borders of this plot. (Inherited from Plot.)
BorderStrokeDashStyle | Gets or sets the stroke dash style of plot borders. (Inherited from Plot.)
BorderStrokeThickness | Gets or sets the stroke thickness of plot borders. (Inherited from Plot.)
DefaultAxis | Gets a default Axis object used when data item index does not have corresponding element in the Axes collection.
GridColor1 | Gets or sets the main color of the grid.
GridColor2 | Gets or sets the alternating color of the grid.
GridDivisions | Gets the number of concentric shapes to draw in the grid.
GridType | Gets or sets the type of grid to draw in this plot.
HighlightedItem | Gets or sets the data item that should be drawn highlighted. (Inherited from Plot.)
HighlightStroke | Gets or sets the Brush used to stroke highlighted item. (Inherited from Plot.)
HighlightStrokeDashStyle | Gets or sets the stroke dash style of highlighted item. (Inherited from Plot.)
HighlightStrokeThickness | Gets or sets the stroke thickness of highlighted item. (Inherited from Plot.)
Padding | Gets or set padding space between the plot's border and series graphics. (Inherited from PolarPlot.)
SeriesRenderers | Gets or sets the SeriesRenderer objects that should draw inside this plot. (Inherited from Plot.)
SeriesStyle | Gets or sets a SeriesStyle whose attributes should be used to draw series inside this plot, unless their own renderers have a local SeriesStyle value set for respetive attribute. (Inherited from Plot.)
ShowCoordinates | Gets or sets a value indicating whether the grid should display axis coordinates.
StartAngle | Gets or set the angle where first data item of series should be drawn. (Inherited from PolarPlot.)
UniformScale | Gets or sets a value indicating whether all axes should display same data range.

Public Methods

Name | Description
AdjustDataRanges | Called at the end of data measurement pass. (Inherited from Plot.)
CreateController | Component.CreateController override. Returns a ComponentController used to interact with this component. (Inherited from PolarPlot.)
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from Plot.)
Draw | Component.Draw override. Draws a grid and all chart graphics represented by contained SeriesRenderer objects. (Inherited from Plot.)
EffectiveBorderStroke | Gets the Brush that should be used to stroke the plot's borders. (Inherited from Plot.)
EffectiveFill | Gets the Brush that should be used to fill the plot's background. (Inherited from Plot.)
EnumSeries | Implements SeriesContainer. (Inherited from Plot.)
GetEffectiveAxis | Gets the Axis representing the range for specified data variable index.
Measure | Component.Measure override. Measures the desired size of this component. (Inherited from Plot.)
MeasureDataRanges | Measures data of all SeriesRenderer objects drawn inside this plot. (Inherited from Plot.)
StartMeasureData | Plot.StartMeasureData override. Called in the beginning of data measurement pass.
Visit | Component.Visit override. Calls visitor's VisitPlot method. (Inherited from PolarPlot.)

Protected Methods

Name | Description
DrawGrid | Plot.DrawGrid override. Draws spiderweb ot radial grid.
DrawPlot | Draws the plot's background and borders. (Inherited from Plot.)
EffectiveBorder | Gets the Pen that should be used to draw the plot's borders. (Inherited from Plot.)
EffectiveBorderStrokeThickness | Gets the thickness of border strokes. (Inherited from Plot.)
EffectiveStrokeDashStyle | Gets the dash style of border strokes. (Inherited from Plot.)
OnRendererDataChanged | Called when a Series raises its DataChanged event. (Inherited from Plot.)
RotatePoint | Rotates point around specified rotation center at specified angle. (Inherited from PolarPlot.)

See Also

RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot Constructor

RadarPlot Constructor
[image]

Initializes a new instance of the RadarPlot class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public RadarPlot ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot Methods

RadarPlot Methods
[image]

Public Methods

Name | Description
AdjustDataRanges | Called at the end of data measurement pass. (Inherited from Plot.)
CreateController | Component.CreateController override. Returns a ComponentController used to interact with this component. (Inherited from PolarPlot.)
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from Plot.)
Draw | Component.Draw override. Draws a grid and all chart graphics represented by contained SeriesRenderer objects. (Inherited from Plot.)
EffectiveBorderStroke | Gets the Brush that should be used to stroke the plot's borders. (Inherited from Plot.)
EffectiveFill | Gets the Brush that should be used to fill the plot's background. (Inherited from Plot.)
EnumSeries | Implements SeriesContainer. (Inherited from Plot.)
GetEffectiveAxis | Gets the Axis representing the range for specified data variable index.
Measure | Component.Measure override. Measures the desired size of this component. (Inherited from Plot.)
MeasureDataRanges | Measures data of all SeriesRenderer objects drawn inside this plot. (Inherited from Plot.)
StartMeasureData | Plot.StartMeasureData override. Called in the beginning of data measurement pass.
Visit | Component.Visit override. Calls visitor's VisitPlot method. (Inherited from PolarPlot.)

Protected Methods

Name | Description
DrawGrid | Plot.DrawGrid override. Draws spiderweb ot radial grid.
DrawPlot | Draws the plot's background and borders. (Inherited from Plot.)
EffectiveBorder | Gets the Pen that should be used to draw the plot's borders. (Inherited from Plot.)
EffectiveBorderStrokeThickness | Gets the thickness of border strokes. (Inherited from Plot.)
EffectiveStrokeDashStyle | Gets the dash style of border strokes. (Inherited from Plot.)
OnRendererDataChanged | Called when a Series raises its DataChanged event. (Inherited from Plot.)
RotatePoint | Rotates point around specified rotation center at specified angle. (Inherited from PolarPlot.)

See Also

RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot.DrawGrid Method

RadarPlot.DrawGrid Method
[image]

Plot.DrawGrid override. Draws spiderweb ot radial grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void DrawGrid (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawGrid( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

RadarPlot Members
RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot.GetEffectiveAxis Method

RadarPlot.GetEffectiveAxis Method
[image]

Gets the Axis representing the range for specified data variable index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Axis GetEffectiveAxis (
int index
)

Visual Basic [image] Copy Code

Public Function GetEffectiveAxis( _
index As Integer _
) As Axis

Parameters

index

An integer index of data items in series.

Return Value

The associated Axis.

See Also

RadarPlot Members
RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot.StartMeasureData Method

RadarPlot.StartMeasureData Method
[image]

Plot.StartMeasureData override. Called in the beginning of data measurement pass.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void StartMeasureData (
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub StartMeasureData( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

RadarPlot Members
RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot Properties

RadarPlot Properties
[image]

Public Properties

Name | Description
AllowRotate | Gets or sets a value indicating whether users are allowed to rotate this plot. (Inherited from PolarPlot.)
Axes | Gets the list of Axis objects representing ranges of variables represented in the radar chart.
AxisOptions | Gets a RadarAxisOptions object providing properties for customizing axis rendering in radar charts.
Background | Gets or sets the Brush that should be used to fill the background of this plot. (Inherited from Plot.)
BorderStroke | Gets or sets the Brush that should be used to stroke the borders of this plot. (Inherited from Plot.)
BorderStrokeDashStyle | Gets or sets the stroke dash style of plot borders. (Inherited from Plot.)
BorderStrokeThickness | Gets or sets the stroke thickness of plot borders. (Inherited from Plot.)
DefaultAxis | Gets a default Axis object used when data item index does not have corresponding element in the Axes collection.
GridColor1 | Gets or sets the main color of the grid.
GridColor2 | Gets or sets the alternating color of the grid.
GridDivisions | Gets the number of concentric shapes to draw in the grid.
GridType | Gets or sets the type of grid to draw in this plot.
HighlightedItem | Gets or sets the data item that should be drawn highlighted. (Inherited from Plot.)
HighlightStroke | Gets or sets the Brush used to stroke highlighted item. (Inherited from Plot.)
HighlightStrokeDashStyle | Gets or sets the stroke dash style of highlighted item. (Inherited from Plot.)
HighlightStrokeThickness | Gets or sets the stroke thickness of highlighted item. (Inherited from Plot.)
Padding | Gets or set padding space between the plot's border and series graphics. (Inherited from PolarPlot.)
SeriesRenderers | Gets or sets the SeriesRenderer objects that should draw inside this plot. (Inherited from Plot.)
SeriesStyle | Gets or sets a SeriesStyle whose attributes should be used to draw series inside this plot, unless their own renderers have a local SeriesStyle value set for respetive attribute. (Inherited from Plot.)
ShowCoordinates | Gets or sets a value indicating whether the grid should display axis coordinates.
StartAngle | Gets or set the angle where first data item of series should be drawn. (Inherited from PolarPlot.)
UniformScale | Gets or sets a value indicating whether all axes should display same data range.

See Also

RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot.Axes Property

RadarPlot.Axes Property
[image]

Gets the list of Axis objects representing ranges of variables represented in the radar chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public ObservableCollection<Axis> Axes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Axes As ObservableCollection(Of Axis)

Property Value

See Also

RadarPlot Members
RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot.AxisOptions Property

RadarPlot.AxisOptions Property
[image]

Gets a RadarAxisOptions object providing properties for customizing axis rendering in radar charts.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public RadarAxisOptions AxisOptions { get; set; }

Visual Basic [image] Copy Code

Public Property AxisOptions As RadarAxisOptions

Property Value

See Also

RadarPlot Members
RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot.DefaultAxis Property

RadarPlot.DefaultAxis Property
[image]

Gets a default Axis object used when data item index does not have corresponding element in the Axes collection.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Axis DefaultAxis { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultAxis As Axis

Property Value

See Also

RadarPlot Members
RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot.GridColor1 Property

RadarPlot.GridColor1 Property
[image]

Gets or sets the main color of the grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Color> GridColor1 { get; set; }

Visual Basic [image] Copy Code

Public Property GridColor1 As Nullable(Of Color)

Property Value

See Also

RadarPlot Members
RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot.GridColor2 Property

RadarPlot.GridColor2 Property
[image]

Gets or sets the alternating color of the grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Color> GridColor2 { get; set; }

Visual Basic [image] Copy Code

Public Property GridColor2 As Nullable(Of Color)

Property Value

See Also

RadarPlot Members
RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot.GridDivisions Property

RadarPlot.GridDivisions Property
[image]

Gets the number of concentric shapes to draw in the grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int GridDivisions { get; set; }

Visual Basic [image] Copy Code

Public Property GridDivisions As Integer

Property Value

See Also

RadarPlot Members
RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot.GridType Property

RadarPlot.GridType Property
[image]

Gets or sets the type of grid to draw in this plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public RadarGridType GridType { get; set; }

Visual Basic [image] Copy Code

Public Property GridType As RadarGridType

Property Value

See Also

RadarPlot Members
RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot.ShowCoordinates Property

RadarPlot.ShowCoordinates Property
[image]

Gets or sets a value indicating whether the grid should display axis coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool ShowCoordinates { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCoordinates As Boolean

Property Value

See Also

RadarPlot Members
RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarPlot.UniformScale Property

RadarPlot.UniformScale Property
[image]

Gets or sets a value indicating whether all axes should display same data range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool UniformScale { get; set; }

Visual Basic [image] Copy Code

Public Property UniformScale As Boolean

Property Value

See Also

RadarPlot Members
RadarPlot Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer Class

RadarRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws series as polygons in polar coordinate system, where adjacent data points are at equal angular distances and radial coordinates correspond to magnitude of data item values.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class RadarRenderer : SeriesRenderer

Visual Basic [image] Copy Code

Public Class RadarRenderer
Inherits SeriesRenderer

Remarks

RadarRenderer must be placed inside a RadarPlot component. It draws each series as a polygon in polar coordinate system, where adjacent data points are at equal angular distances and radial coordinates correspond to magnitude of data item values. If the GetLabel method of Series object returns InnerLabel or OuterLabel strings, they are rendered near the polygon vertex corresponding to respective data item.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.RadarRenderer
MindFusion.Charting.PieRadarRenderer

See Also

RadarRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer Members

RadarRenderer Members
Constructors Fields Properties Methods Events
[image]

A SeriesRenderer that draws series as polygons in polar coordinate system, where adjacent data points are at equal angular distances and radial coordinates correspond to magnitude of data item values.

The following tables list the members exposed by the RadarRenderer type.

Public Constructors

Name | Description
RadarRenderer | Initializes a new instance of the RadarRenderer class.

Protected Fields

Name | Description
series | A list of Series that should be rendered by this RadarRenderer.

Public Properties

Name | Description
AreaOpacity | Gets or sets the opacity of radar polygons.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this RadarRenderer.
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implement SeriesContainer.
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | Called to reset measure accumulators at the beginning of a measure pass. (Inherited from SeriesRenderer.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
Data | Returns the data value of specified series item.
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration.
GetMaxValue | Gets the maximum value from all series located at specified index.
GetMinValue | Gets the minimum value from all series located at specified index.
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer Fields

RadarRenderer Fields
[image]

Protected Fields

Name | Description
series | A list of Series that should be rendered by this RadarRenderer.

See Also

RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer.series Field

RadarRenderer.series Field
[image]

A list of Series that should be rendered by this RadarRenderer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected ObservableCollection<Series> series

Visual Basic [image] Copy Code

Protected series As ObservableCollection(Of Series)

See Also

RadarRenderer Members
RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer Constructor

RadarRenderer Constructor
[image]

Initializes a new instance of the RadarRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public RadarRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered by this object.

See Also

RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer Methods

RadarRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implement SeriesContainer.
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | Called to reset measure accumulators at the beginning of a measure pass. (Inherited from SeriesRenderer.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
Data | Returns the data value of specified series item.
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration.
GetMaxValue | Gets the maximum value from all series located at specified index.
GetMinValue | Gets the minimum value from all series located at specified index.
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)

See Also

RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer.Data Method

RadarRenderer.Data Method
[image]

Returns the data value of specified series item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected double Data (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Protected Function Data( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Double

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this Renderer2D.

dataIndex

An integer index of the data item in specified series.

Return Value

A double value.

See Also

RadarRenderer Members
RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer.Draw Method

RadarRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

RadarRenderer Members
RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer.DrawHighlight Method

RadarRenderer.DrawHighlight Method
[image]

SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void DrawHighlight (
RenderContext context,
HitResult hitResult
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawHighlight( _
context As RenderContext, _
hitResult As HitResult _
)

Parameters

context

A RenderContext instance.

hitResult

A HitResult instance identifying highlighted data item.

See Also

RadarRenderer Members
RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer.EnumSeries Method

RadarRenderer.EnumSeries Method
[image]

Implement SeriesContainer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override IEnumerable<Series> EnumSeries ()

Visual Basic [image] Copy Code

Public Overrides Function EnumSeries () As IEnumerable(Of Series)

Return Value

An instance of the IEnumerable<Series> class.

See Also

RadarRenderer Members
RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer.EnumVisibleRanges Method

RadarRenderer.EnumVisibleRanges Method
[image]

Enumerates each series once providing a list of all visible points at each iteration.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void EnumVisibleRanges (
RenderContext context,
RadarRenderer.ProcessRange process
)

Visual Basic [image] Copy Code

Protected Sub EnumVisibleRanges( _
context As RenderContext, _
process As RadarRenderer.ProcessRange _
)

Parameters

context

A RenderContext instance.

process

A ProcessRange callback.

See Also

RadarRenderer Members
RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer.GetMaxValue Method

RadarRenderer.GetMaxValue Method
[image]

Gets the maximum value from all series located at specified index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected double GetMaxValue (
int index
)

Visual Basic [image] Copy Code

Protected Function GetMaxValue( _
index As Integer _
) As Double

Parameters

index

An integer index of data element in the series.

Return Value

A double value representing the largest data element.

See Also

RadarRenderer Members
RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer.GetMinValue Method

RadarRenderer.GetMinValue Method
[image]

Gets the minimum value from all series located at specified index.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected double GetMinValue (
int index
)

Visual Basic [image] Copy Code

Protected Function GetMinValue( _
index As Integer _
) As Double

Parameters

index

An integer index of data element in the series.

Return Value

A double value representing the smallest data element.

See Also

RadarRenderer Members
RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer.HitTest Method

RadarRenderer.HitTest Method
[image]

SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override HitResult HitTest (
RenderContext context,
PointD location
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
context As RenderContext, _
location As PointD _
) As HitResult

Parameters

context

A RenderContext instance.

location

A PointD specifying where to look for data items.

Return Value

A HitResult instance identifying the found data item.

See Also

RadarRenderer Members
RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer.MeasureDataRange Method

RadarRenderer.MeasureDataRange Method
[image]

SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void MeasureDataRange (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub MeasureDataRange( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

RadarRenderer Members
RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer Properties

RadarRenderer Properties
[image]

Public Properties

Name | Description
AreaOpacity | Gets or sets the opacity of radar polygons.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this RadarRenderer.
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)

See Also

RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer.AreaOpacity Property

RadarRenderer.AreaOpacity Property
[image]

Gets or sets the opacity of radar polygons.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double AreaOpacity { get; set; }

Visual Basic [image] Copy Code

Public Property AreaOpacity As Double

Property Value

See Also

RadarRenderer Members
RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer.Series Property

RadarRenderer.Series Property
[image]

Gets or sets a list of Series drawn by this RadarRenderer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public ObservableCollection<Series> Series { get; set; }

Visual Basic [image] Copy Code

Public Property Series As ObservableCollection(Of Series)

Property Value

See Also

RadarRenderer Members
RadarRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarRenderer.ProcessRange Delegate

RadarRenderer.ProcessRange Delegate
[image]

Defines the signature of delegates called to process all points from current data range at once.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected delegate void RadarRenderer.ProcessRange (
int seriesIndex,
List<PointF> points
)

Visual Basic [image] Copy Code

Protected Delegate Sub RadarRenderer.ProcessRange( _
seriesIndex As Integer, _
points As List(Of PointF) _
)

Parameters

seriesIndex

An integer index of series in Series list.

points

A list of PointF values containing the plot coordinates corresponding to data items in currently visible range.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.RadarScatterRenderer Class

RadarScatterRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws scatter in radar plots.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class RadarScatterRenderer : ScatterRenderer

Visual Basic [image] Copy Code

Public Class RadarScatterRenderer
Inherits ScatterRenderer

Remarks

RadarScatterRenderer must be placed inside a RadarPlot component. It draws each data item as a scatter Shape whose size is specified by ShapeSize. If the GetLabel method of Series object returns InnerLabel string, the label is drawn centered at its corresponding shape's location.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.ScatterRenderer
MindFusion.Charting.RadarScatterRenderer

See Also

RadarScatterRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.RadarScatterRenderer Members

RadarScatterRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws scatter in radar plots.

The following tables list the members exposed by the RadarScatterRenderer type.

Public Constructors

Name | Description
RadarScatterRenderer | Initializes a new instance of the RadarScatterRenderer class.

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
Shape | Gets or sets the type of scatter shapes. (Inherited from ScatterRenderer.)
ShapeSize | Gets or sets the size of scatter shapes. (Inherited from ScatterRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the scatter representations of data items. (Inherited from ScatterRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext. (Inherited from ScatterRenderer.)
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted shape in specified RenderContext. (Inherited from ScatterRenderer.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumPoints | ScatterRenderer.EnumPoints override. Enumerates the data values of rendered series mapped to plot's 2D coordinates.
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

RadarScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarScatterRenderer Constructor

RadarScatterRenderer Constructor
[image]

Initializes a new instance of the RadarScatterRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public RadarScatterRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as scatter.

See Also

RadarScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarScatterRenderer Methods

RadarScatterRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the scatter representations of data items. (Inherited from ScatterRenderer.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext. (Inherited from ScatterRenderer.)
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted shape in specified RenderContext. (Inherited from ScatterRenderer.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumPoints | ScatterRenderer.EnumPoints override. Enumerates the data values of rendered series mapped to plot's 2D coordinates.
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

RadarScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarScatterRenderer.EnumPoints Method

RadarScatterRenderer.EnumPoints Method
[image]

ScatterRenderer.EnumPoints override. Enumerates the data values of rendered series mapped to plot's 2D coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void EnumPoints (
RenderContext context,
Renderer2D.ProcessPoint process
)

Visual Basic [image] Copy Code

Protected Overrides Sub EnumPoints( _
context As RenderContext, _
process As Renderer2D.ProcessPoint _
)

Parameters

context

A RenderContext instance.

process

A ProcessPoint callback.

See Also

RadarScatterRenderer Members
RadarScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarScatterRenderer.MeasureDataRange Method

RadarScatterRenderer.MeasureDataRange Method
[image]

Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void MeasureDataRange (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub MeasureDataRange( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

RadarScatterRenderer Members
RadarScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.RadarType Enumeration

RadarType Enumeration
[image]

Identifies the type of radar-chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public enum RadarType

Visual Basic [image] Copy Code

Public Enum RadarType

Members

Member name | Description
Pie | Draw data items as circular sectors.
Polygon | Draw each series as a polygon.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.RectD Structure

RectD Structure
[image]

Represents a rectangle with double-precision coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public struct RectD

Visual Basic [image] Copy Code

Public Structure RectD

See Also

RectD Members
MindFusion.Charting Namespace


MindFusion.Charting.RectD Members

RectD Members
Constructors Properties Methods
[image]

Represents a rectangle with double-precision coordinates.

The following tables list the members exposed by the RectD type.

Public Constructors

Name | Description
RectD | Overloaded.

Public Properties

Name | Description
Bottom | Gets the rectangle's bottom side.
Height | Gets or sets the height of this rectangle.
Left | Gets the rectangle's left side.
Location | Gets the rectangle's location.
Right | Gets the rectangle's right side.
Top | Gets the rectangle's top side.
Width | Gets or sets the width of this rectangle.
X | Gets or sets X coordinate of this rectangle.
Y | Gets or sets Y coordinate of this rectangle.

Public Methods

Name | Description
Intersects | Checks whether this rectangle intersects with specified rectangle.
ToString | Object.ToString override.

See Also

RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD Constructor

RectD Constructor
[image]

Overload List

Name | Description
RectD (Double, Double, Double, Double) | Initializes a new instance of the RectD struct.
RectD (Rectangle) | Initializes a new instance of the RectD struct.

See Also

RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD Constructor (Double, Double, Double, Double)

RectD Constructor (Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the RectD struct.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public RectD (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
)

Parameters

x

X coordinate.

y

Y coordinate.

width

Rectangle's width.

height

Rectangle's height.

See Also

RectD Constructor Overload List
RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD Constructor (Rectangle)

RectD Constructor (Rectangle)
See Also
[image]

Initializes a new instance of the RectD struct.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public RectD (
Rectangle rect
)

Visual Basic [image] Copy Code

Public New ( _
rect As Rectangle _
)

Parameters

rect

A Rectangle whose location and size to copy.

See Also

RectD Constructor Overload List
RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD Methods

RectD Methods
[image]

Public Methods

Name | Description
Intersects | Checks whether this rectangle intersects with specified rectangle.
ToString | Object.ToString override.

See Also

RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD.Intersects Method

RectD.Intersects Method
[image]

Checks whether this rectangle intersects with specified rectangle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool Intersects (
RectD other
)

Visual Basic [image] Copy Code

Public Function Intersects( _
other As RectD _
) As Boolean

Parameters

other

A RectD instance.

Return Value

true if the rectangles intersect, or false otherwise.

See Also

RectD Members
RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD.ToString Method

RectD.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representation of this rectangle.

See Also

RectD Members
RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD Properties

RectD Properties
[image]

Public Properties

Name | Description
Bottom | Gets the rectangle's bottom side.
Height | Gets or sets the height of this rectangle.
Left | Gets the rectangle's left side.
Location | Gets the rectangle's location.
Right | Gets the rectangle's right side.
Top | Gets the rectangle's top side.
Width | Gets or sets the width of this rectangle.
X | Gets or sets X coordinate of this rectangle.
Y | Gets or sets Y coordinate of this rectangle.

See Also

RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD.Bottom Property

RectD.Bottom Property
[image]

Gets the rectangle's bottom side.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Bottom { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bottom As Double

Property Value

See Also

RectD Members
RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD.Height Property

RectD.Height Property
[image]

Gets or sets the height of this rectangle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

See Also

RectD Members
RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD.Left Property

RectD.Left Property
[image]

Gets the rectangle's left side.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Left { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Left As Double

Property Value

See Also

RectD Members
RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD.Location Property

RectD.Location Property
[image]

Gets the rectangle's location.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PointD Location { get; set; }

Visual Basic [image] Copy Code

Public Property Location As PointD

Property Value

See Also

RectD Members
RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD.Right Property

RectD.Right Property
[image]

Gets the rectangle's right side.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Right { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Right As Double

Property Value

See Also

RectD Members
RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD.Top Property

RectD.Top Property
[image]

Gets the rectangle's top side.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Top { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Top As Double

Property Value

See Also

RectD Members
RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD.Width Property

RectD.Width Property
[image]

Gets or sets the width of this rectangle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

See Also

RectD Members
RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD.X Property

RectD.X Property
[image]

Gets or sets X coordinate of this rectangle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

See Also

RectD Members
RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RectD.Y Property

RectD.Y Property
[image]

Gets or sets Y coordinate of this rectangle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

See Also

RectD Members
RectD Structure
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext Class

RenderContext Class
[image]

Provides contextual information about the dashboard to its child components when calling their draw, layout and user input methods.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class RenderContext

Visual Basic [image] Copy Code

Public Class RenderContext

Inheritance Hierarchy

System.Object
MindFusion.Charting.RenderContext

See Also

RenderContext Members
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext Members

RenderContext Members
Constructors Properties Methods
[image]

Provides contextual information about the dashboard to its child components when calling their draw, layout and user input methods.

The following tables list the members exposed by the RenderContext type.

Public Constructors

Name | Description
RenderContext | Initializes a new instance of the RenderContext clas.

Public Properties

Name | Description
Component | Gets or sets the component currently being painted.
Graphics | Gets or sets the current drawing surface.
Theme | Gets or sets the Theme used to resolve appearance attributes.
XAxis | Gets the chart's XAxis.
YAxis | Gets the chart's YAxis.

Public Methods

Name | Description
GetClipRect | Gets the clip rectangle relative to specified Component.
GetClipRectF | Gets the clip rectangle relative to specified Component.
GetXAxis | Overloaded.
GetYAxis | Overloaded.
TextStyle | Gets a TextStyle from current Theme.

See Also

RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext Constructor

RenderContext Constructor
[image]

Initializes a new instance of the RenderContext clas.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public RenderContext (
RectD clipRect,
Theme theme
)

Visual Basic [image] Copy Code

Public New ( _
clipRect As RectD, _
theme As Theme _
)

Parameters

clipRect

A RectD specifying the clip rectangle.

theme

A Theme instance where appearance attributes should be derived from.

See Also

RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext Methods

RenderContext Methods
[image]

Public Methods

Name | Description
GetClipRect | Gets the clip rectangle relative to specified Component.
GetClipRectF | Gets the clip rectangle relative to specified Component.
GetXAxis | Overloaded.
GetYAxis | Overloaded.
TextStyle | Gets a TextStyle from current Theme.

See Also

RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.GetClipRect Method

RenderContext.GetClipRect Method
[image]

Gets the clip rectangle relative to specified Component.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public RectD GetClipRect (
Component relativeTo
)

Visual Basic [image] Copy Code

Public Function GetClipRect( _
relativeTo As Component _
) As RectD

Parameters

relativeTo

A Component instance.

Return Value

A RectD instance.

See Also

RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.GetClipRectF Method

RenderContext.GetClipRectF Method
[image]

Gets the clip rectangle relative to specified Component.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public RectangleF GetClipRectF (
Component relativeTo
)

Visual Basic [image] Copy Code

Public Function GetClipRectF( _
relativeTo As Component _
) As RectangleF

Parameters

relativeTo

A Component instance.

Return Value

A RectangleF instance.

See Also

RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.GetXAxis Method

RenderContext.GetXAxis Method
[image]

Overload List

Name | Description
RenderContext.GetXAxis () | Gets the X axis associated with parent plot or chart.
RenderContext.GetXAxis (Renderer2D) | Gets the X axis assigned to a Renderer2D or returns one from parent plot or chart.

See Also

RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.GetXAxis Method ()

RenderContext.GetXAxis Method ()
See Also
[image]

Gets the X axis associated with parent plot or chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Axis GetXAxis ()

Visual Basic [image] Copy Code

Public Function GetXAxis () As Axis

Return Value

An Axis instance.

See Also

GetXAxis Method Overload List
RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.GetXAxis Method (Renderer2D)

RenderContext.GetXAxis Method (Renderer2D)
See Also
[image]

Gets the X axis assigned to a Renderer2D or returns one from parent plot or chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Axis GetXAxis (
Renderer2D series
)

Visual Basic [image] Copy Code

Public Function GetXAxis( _
series As Renderer2D _
) As Axis

Parameters

series

A Renderer2D instance.

Return Value

An Axis instance.

See Also

GetXAxis Method Overload List
RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.GetYAxis Method

RenderContext.GetYAxis Method
[image]

Overload List

Name | Description
RenderContext.GetYAxis () | Gets the Y axis associated with parent plot or chart.
RenderContext.GetYAxis (Renderer2D) | Gets the Y axis assigned to a Renderer2D or returns one from parent plot or chart.

See Also

RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.GetYAxis Method ()

RenderContext.GetYAxis Method ()
See Also
[image]

Gets the Y axis associated with parent plot or chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Axis GetYAxis ()

Visual Basic [image] Copy Code

Public Function GetYAxis () As Axis

Return Value

An Axis instance.

See Also

GetYAxis Method Overload List
RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.GetYAxis Method (Renderer2D)

RenderContext.GetYAxis Method (Renderer2D)
See Also
[image]

Gets the Y axis assigned to a Renderer2D or returns one from parent plot or chart.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Axis GetYAxis (
Renderer2D series
)

Visual Basic [image] Copy Code

Public Function GetYAxis( _
series As Renderer2D _
) As Axis

Parameters

series

A Renderer2D instance.

Return Value

An Axis instance.

See Also

GetYAxis Method Overload List
RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.TextStyle Method

RenderContext.TextStyle Method
[image]

Gets a TextStyle from current Theme.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual TextStyle TextStyle (
TextStyleHint hint
)

Visual Basic [image] Copy Code

Public Overridable Function TextStyle( _
hint As TextStyleHint _
) As TextStyle

Parameters

hint

A member of the TextStyleHint enumeration.

Return Value

A TextStyle instance.

See Also

RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext Properties

RenderContext Properties
[image]

Public Properties

Name | Description
Component | Gets or sets the component currently being painted.
Graphics | Gets or sets the current drawing surface.
Theme | Gets or sets the Theme used to resolve appearance attributes.
XAxis | Gets the chart's XAxis.
YAxis | Gets the chart's YAxis.

See Also

RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.Component Property

RenderContext.Component Property
[image]

Gets or sets the component currently being painted.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Component Component { get; set; }

Visual Basic [image] Copy Code

Public Property Component As Component

Property Value

See Also

RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.Graphics Property

RenderContext.Graphics Property
[image]

Gets or sets the current drawing surface.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; set; }

Visual Basic [image] Copy Code

Public Property Graphics As IGraphics

Property Value

See Also

RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.Theme Property

RenderContext.Theme Property
[image]

Gets or sets the Theme used to resolve appearance attributes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Theme Theme { get; set; }

Visual Basic [image] Copy Code

Public Property Theme As Theme

Property Value

See Also

RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.XAxis Property

RenderContext.XAxis Property
[image]

Gets the chart's XAxis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual Axis XAxis { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property XAxis As Axis

Property Value

See Also

RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.RenderContext.YAxis Property

RenderContext.YAxis Property
[image]

Gets the chart's YAxis.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual Axis YAxis { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property YAxis As Axis

Property Value

See Also

RenderContext Members
RenderContext Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D Class

Renderer2D Class
[image]

A base class for series renderers that draw in two dimensional Cartesian coordinate system.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class Renderer2D : SeriesRenderer

Visual Basic [image] Copy Code

Public Class Renderer2D
Inherits SeriesRenderer

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.AnnotationRenderer
MindFusion.Charting.AreaRenderer
MindFusion.Charting.BarOverlayRenderer
MindFusion.Charting.BarRenderer
MindFusion.Charting.BubbleRenderer
MindFusion.Charting.CandlestickRenderer
MindFusion.Charting.LineRenderer
MindFusion.Charting.ScatterRenderer
MindFusion.Charting.StackRenderer
MindFusion.Charting.StepAreaRenderer
MindFusion.Charting.StepRenderer

See Also

Renderer2D Members
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D Members

Renderer2D Members
Constructors Properties Methods Events
[image]

A base class for series renderers that draw in two dimensional Cartesian coordinate system.

The following tables list the members exposed by the Renderer2D type.

Public Constructors

Name | Description
Renderer2D | Initializes a new instance of the Renderer2D class.

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D.
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D.
YAxis | Gets the Y axis associated with this Renderer2D.

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface.
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass.

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item.
Draw | Draws the series data in specified RenderContext. (Inherited from SeriesRenderer.)
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates.
EnumVisiblePoints | Overloaded.
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration.
GetFirstInRange | Overloaded.
GetLastInRange | Overloaded.
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series.
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series.
GetPixel | Overloaded.
ImageData | Gets the image axis coordinate (output value) of specified data item.
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item.
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension.
YData | Gets the Y value of specified data item.
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension.

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D Constructor

Renderer2D Constructor
[image]

Initializes a new instance of the Renderer2D class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Renderer2D (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered by this object.

See Also

Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D Methods

Renderer2D Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface.
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass.

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item.
Draw | Draws the series data in specified RenderContext. (Inherited from SeriesRenderer.)
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates.
EnumVisiblePoints | Overloaded.
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration.
GetFirstInRange | Overloaded.
GetLastInRange | Overloaded.
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series.
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series.
GetPixel | Overloaded.
ImageData | Gets the image axis coordinate (output value) of specified data item.
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item.
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension.
YData | Gets the Y value of specified data item.
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension.

See Also

Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.DomainData Method

Renderer2D.DomainData Method
[image]

Gets the domain axis coordinate (input value) of specified data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected double DomainData (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Protected Function DomainData( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Double

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this Renderer2D.

dataIndex

An integer index of the data item in specified series.

Return Value

A double value.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.DrawHighlight Method

Renderer2D.DrawHighlight Method
[image]

SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void DrawHighlight (
RenderContext context,
HitResult hitResult
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawHighlight( _
context As RenderContext, _
hitResult As HitResult _
)

Parameters

context

A RenderContext instance.

hitResult

A HitResult instance identifying highlighted data item.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.EnumSeries Method

Renderer2D.EnumSeries Method
[image]

Implements the SeriesContainer interface.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override IEnumerable<Series> EnumSeries ()

Visual Basic [image] Copy Code

Public Overrides Function EnumSeries () As IEnumerable(Of Series)

Return Value

An instance of the IEnumerable<Series> class.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.EnumVisiblePointPairs Method

Renderer2D.EnumVisiblePointPairs Method
[image]

Enumerates the data values of rendered series mapped to plot 2D coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void EnumVisiblePointPairs (
RenderContext context,
Renderer2D.ProcessPoints process
)

Visual Basic [image] Copy Code

Protected Sub EnumVisiblePointPairs( _
context As RenderContext, _
process As Renderer2D.ProcessPoints _
)

Parameters

context

A RenderContext instance.

process

A ProcessPoints callback.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.EnumVisiblePoints Method

Renderer2D.EnumVisiblePoints Method
[image]

Overload List

Name | Description
Renderer2D.EnumVisiblePoints (RenderContext, Boolean, Renderer2D.ProcessPoint) | Enumerates the data values of rendered series mapped to plot 2D coordinates.
Renderer2D.EnumVisiblePoints (RenderContext, Renderer2D.ProcessPoint) | Enumerates the data values of rendered series mapped to plot 2D coordinates.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.EnumVisiblePoints Method (RenderContext, Boolean, Renderer2D.ProcessPoint)

Renderer2D.EnumVisiblePoints Method (RenderContext, Boolean, Renderer2D.ProcessPoint)
See Also
[image]

Enumerates the data values of rendered series mapped to plot 2D coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void EnumVisiblePoints (
RenderContext context,
bool frontToBack,
Renderer2D.ProcessPoint process
)

Visual Basic [image] Copy Code

Protected Sub EnumVisiblePoints( _
context As RenderContext, _
frontToBack As Boolean, _
process As Renderer2D.ProcessPoint _
)

Parameters

context

A RenderContext instance.

frontToBack

true if the series list should be enumerated from front to back, or false otherwise.

process

A ProcessPoint callback.

See Also

EnumVisiblePoints Method Overload List
Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.EnumVisiblePoints Method (RenderContext, Renderer2D.ProcessPoint)

Renderer2D.EnumVisiblePoints Method (RenderContext, Renderer2D.ProcessPoint)
See Also
[image]

Enumerates the data values of rendered series mapped to plot 2D coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void EnumVisiblePoints (
RenderContext context,
Renderer2D.ProcessPoint process
)

Visual Basic [image] Copy Code

Protected Sub EnumVisiblePoints( _
context As RenderContext, _
process As Renderer2D.ProcessPoint _
)

Parameters

context

A RenderContext instance.

process

A ProcessPoint callback.

See Also

EnumVisiblePoints Method Overload List
Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.EnumVisibleRanges Method

Renderer2D.EnumVisibleRanges Method
[image]

Enumerates each series once providing a list of all visible points at each iteration.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void EnumVisibleRanges (
RenderContext context,
Renderer2D.ProcessRange process
)

Visual Basic [image] Copy Code

Protected Sub EnumVisibleRanges( _
context As RenderContext, _
process As Renderer2D.ProcessRange _
)

Parameters

context

A RenderContext instance.

process

A ProcessRange callback.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.GetFirstInRange Method

Renderer2D.GetFirstInRange Method
[image]

Overload List

Name | Description
Renderer2D.GetFirstInRange (Int32, Axis) | Gets the index of first data item in specified range.
Renderer2D.GetFirstInRange (Int32, RenderContext) | Gets the index of first data item in currently visible plot range.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.GetFirstInRange Method (Int32, Axis)

Renderer2D.GetFirstInRange Method (Int32, Axis)
See Also
[image]

Gets the index of first data item in specified range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected int GetFirstInRange (
int s,
Axis axis
)

Visual Basic [image] Copy Code

Protected Function GetFirstInRange( _
s As Integer, _
axis As Axis _
) As Integer

Parameters

s

An integer value specifying index in Series list.

axis

An Axis instance identifying the data range.

Return Value

An integer index of first data item found in specified range.

See Also

GetFirstInRange Method Overload List
Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.GetFirstInRange Method (Int32, RenderContext)

Renderer2D.GetFirstInRange Method (Int32, RenderContext)
See Also
[image]

Gets the index of first data item in currently visible plot range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected int GetFirstInRange (
int s,
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function GetFirstInRange( _
s As Integer, _
context As RenderContext _
) As Integer

Parameters

s

An integer value specifying index in Series list.

context

A RenderContext instance.

Return Value

An integer index of first visible data item.

See Also

GetFirstInRange Method Overload List
Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.GetLastInRange Method

Renderer2D.GetLastInRange Method
[image]

Overload List

Name | Description
Renderer2D.GetLastInRange (Int32, Axis) | Gets the index of last data item in specified range.
Renderer2D.GetLastInRange (Int32, RenderContext) | Gets the index of last data item in currently visible plot range.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.GetLastInRange Method (Int32, Axis)

Renderer2D.GetLastInRange Method (Int32, Axis)
See Also
[image]

Gets the index of last data item in specified range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected int GetLastInRange (
int s,
Axis axis
)

Visual Basic [image] Copy Code

Protected Function GetLastInRange( _
s As Integer, _
axis As Axis _
) As Integer

Parameters

s

An integer value specifying index in Series list.

axis

An Axis instance identifying the data range.

Return Value

An integer index of last data item found in specified range.

See Also

GetLastInRange Method Overload List
Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.GetLastInRange Method (Int32, RenderContext)

Renderer2D.GetLastInRange Method (Int32, RenderContext)
See Also
[image]

Gets the index of last data item in currently visible plot range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected int GetLastInRange (
int s,
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function GetLastInRange( _
s As Integer, _
context As RenderContext _
) As Integer

Parameters

s

An integer value specifying index in Series list.

context

A RenderContext instance.

Return Value

An integer index of last visible data item.

See Also

GetLastInRange Method Overload List
Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.GetMaxXSum Method

Renderer2D.GetMaxXSum Method
[image]

Gets the maximum sum of X data values locates at same index in all series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected double GetMaxXSum ()

Visual Basic [image] Copy Code

Protected Function GetMaxXSum () As Double

Return Value

A double value containing the maximum sum.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.GetMaxYSum Method

Renderer2D.GetMaxYSum Method
[image]

Gets the maximum sum of Y data values locates at same index in all series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected double GetMaxYSum ()

Visual Basic [image] Copy Code

Protected Function GetMaxYSum () As Double

Return Value

A double value containing the maximum sum.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.GetPixel Method

Renderer2D.GetPixel Method
[image]

Overload List

Name | Description
Renderer2D.GetPixel (Double, Axis, Double, Axis, Component) | Gets the coordinates of specified data item when mapped to a Plot2D pixel.
Renderer2D.GetPixel (Int32, Int32, Axis, Axis, Component) | Gets the coordinates of specified data item when mapped to a Plot2D pixel.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.GetPixel Method (Double, Axis, Double, Axis, Component)

Renderer2D.GetPixel Method (Double, Axis, Double, Axis, Component)
See Also
[image]

Gets the coordinates of specified data item when mapped to a Plot2D pixel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected PointF GetPixel (
double valueX,
Axis xAxis,
double valueY,
Axis yAxis,
Component component
)

Visual Basic [image] Copy Code

Protected Function GetPixel( _
valueX As Double, _
xAxis As Axis, _
valueY As Double, _
yAxis As Axis, _
component As Component _
) As PointF

Parameters

valueX

The X value of data item in logical coordinate system.

xAxis

The X Axis from which logical value is mapped to plot's actual width.

valueY

The Y value of data item in logical coordinate system.

yAxis

The Y Axis from which logical value is mapped to plot's actual height.

component

An instance of Plot2D or derived class.

Return Value

See Also

GetPixel Method Overload List
Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.GetPixel Method (Int32, Int32, Axis, Axis, Component)

Renderer2D.GetPixel Method (Int32, Int32, Axis, Axis, Component)
See Also
[image]

Gets the coordinates of specified data item when mapped to a Plot2D pixel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected PointF GetPixel (
int seriesIndex,
int dataIndex,
Axis xAxis,
Axis yAxis,
Component component
)

Visual Basic [image] Copy Code

Protected Function GetPixel( _
seriesIndex As Integer, _
dataIndex As Integer, _
xAxis As Axis, _
yAxis As Axis, _
component As Component _
) As PointF

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this Renderer2D.

dataIndex

An integer index of the data item in specified series.

xAxis

An Axis reference specifying the X axis.

yAxis

An Axis reference specifying the Y axis.

component

An instance of Plot2D or derived class.

Return Value

A PointF containing Plot2D coordinates corresponding to specified data item.

See Also

GetPixel Method Overload List
Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.HitTest Method

Renderer2D.HitTest Method
[image]

SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override HitResult HitTest (
RenderContext context,
PointD location
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
context As RenderContext, _
location As PointD _
) As HitResult

Parameters

context

A RenderContext instance.

location

A PointD specifying where to look for data items.

Return Value

A HitResult instance identifying the found data item.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.ImageData Method

Renderer2D.ImageData Method
[image]

Gets the image axis coordinate (output value) of specified data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected double ImageData (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Protected Function ImageData( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Double

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this Renderer2D.

dataIndex

An integer index of the data item in specified series.

Return Value

A double value.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.MeasureDataRange Method

Renderer2D.MeasureDataRange Method
[image]

SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void MeasureDataRange (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub MeasureDataRange( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.StartMeasureData Method

Renderer2D.StartMeasureData Method
[image]

SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void StartMeasureData (
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub StartMeasureData( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.XData Method

Renderer2D.XData Method
[image]

Gets the X value of specified data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected double XData (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Protected Function XData( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Double

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this Renderer2D.

dataIndex

An integer index of the data item in specified series.

Return Value

A double value.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.XSorted Method

Renderer2D.XSorted Method
[image]

Gets a value indicating whether values of specified series increase monotonously in X dimension.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected bool XSorted (
int seriesIndex
)

Visual Basic [image] Copy Code

Protected Function XSorted( _
seriesIndex As Integer _
) As Boolean

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this Renderer2D.

Return Value

true if specified series is sorted, or false otherwise.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.YData Method

Renderer2D.YData Method
[image]

Gets the Y value of specified data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected double YData (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Protected Function YData( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Double

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this Renderer2D.

dataIndex

An integer index of the data item in specified series.

Return Value

A double value.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.YSorted Method

Renderer2D.YSorted Method
[image]

Gets a value indicating whether values of specified series increase monotonously in Y dimension.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected bool YSorted (
int seriesIndex
)

Visual Basic [image] Copy Code

Protected Function YSorted( _
seriesIndex As Integer _
) As Boolean

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this Renderer2D.

Return Value

true if specified series is sorted, or false otherwise.

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D Properties

Renderer2D Properties
[image]

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D.
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D.
YAxis | Gets the Y axis associated with this Renderer2D.

See Also

Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.Series Property

Renderer2D.Series Property
[image]

Gets or sets a list of Series drawn by this Renderer2D.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public ObservableCollection<Series> Series { get; set; }

Visual Basic [image] Copy Code

Public Property Series As ObservableCollection(Of Series)

Property Value

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.XAxis Property

Renderer2D.XAxis Property
[image]

Gets the X axis associated with this Renderer2D.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Axis XAxis { get; set; }

Visual Basic [image] Copy Code

Public Property XAxis As Axis

Property Value

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.YAxis Property

Renderer2D.YAxis Property
[image]

Gets the Y axis associated with this Renderer2D.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Axis YAxis { get; set; }

Visual Basic [image] Copy Code

Public Property YAxis As Axis

Property Value

See Also

Renderer2D Members
Renderer2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.ProcessPoint Delegate

Renderer2D.ProcessPoint Delegate
[image]

Defines the signature of delegates called to process a data point one element at a time.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected delegate void Renderer2D.ProcessPoint (
int seriesIndex,
int dataIndex,
PointF point
)

Visual Basic [image] Copy Code

Protected Delegate Sub Renderer2D.ProcessPoint( _
seriesIndex As Integer, _
dataIndex As Integer, _
point As PointF _
)

Parameters

seriesIndex

An integer index of series in Series list.

dataIndex

An integer index of data item in specified series.

point

A PointF instance containing the Plot2D coordinates corresponding to current data item.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.ProcessPoints Delegate

Renderer2D.ProcessPoints Delegate
[image]

Defines the signature of delegates called to process data points in pairs.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected delegate void Renderer2D.ProcessPoints (
int seriesIndex,
int dataIndex,
PointF point1,
PointF point2
)

Visual Basic [image] Copy Code

Protected Delegate Sub Renderer2D.ProcessPoints( _
seriesIndex As Integer, _
dataIndex As Integer, _
point1 As PointF, _
point2 As PointF _
)

Parameters

seriesIndex

An integer index of series in Series list.

dataIndex

An integer index of data item in specified series.

point1

A PointF instance containing the Plot2D coordinates corresponding to previous data item.

point2

A PointF instance containing the Plot2D coordinates corresponding to current data item.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.Renderer2D.ProcessRange Delegate

Renderer2D.ProcessRange Delegate
[image]

Defines the signature of delegates called to process all points from current data range at once.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected delegate void Renderer2D.ProcessRange (
int seriesIndex,
List<PointF> points
)

Visual Basic [image] Copy Code

Protected Delegate Sub Renderer2D.ProcessRange( _
seriesIndex As Integer, _
points As List(Of PointF) _
)

Parameters

seriesIndex

An integer index of series in Series list.

points

A list of PointF values containing the Plot2D coordinates corresponding to data items in currently visible range.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.Renderer3D Interface

Renderer3D Interface
[image]

Defines the interface called by Plot3D to build 3D models.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public interface Renderer3D

Visual Basic [image] Copy Code

Public Interface Renderer3D

Inheritors

MindFusion.Charting.BarOverlayRenderer3D
MindFusion.Charting.BarRenderer3D
MindFusion.Charting.BarStackRenderer3D

See Also

Renderer3D Members
MindFusion.Charting Namespace


MindFusion.Charting.Renderer3D Members

Renderer3D Members
Methods
[image]

Defines the interface called by Plot3D to build 3D models.

The following tables list the members exposed by the Renderer3D type.

Public Methods

Name | Description
BuildModels | Adds models for the series data to specified scene.

See Also

Renderer3D Interface
MindFusion.Charting Namespace


MindFusion.Charting.Renderer3D Methods

Renderer3D Methods
[image]

Public Methods

Name | Description
BuildModels | Adds models for the series data to specified scene.

See Also

Renderer3D Interface
MindFusion.Charting Namespace


MindFusion.Charting.Renderer3D.BuildModels Method

Renderer3D.BuildModels Method
[image]

Adds models for the series data to specified scene.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

void BuildModels (
Scene3D scene,
RenderContext context
)

Visual Basic [image] Copy Code

Sub BuildModels( _
scene As Scene3D, _
context As RenderContext _
)

Parameters

scene

A Scene3D instance.

context

A RenderContext instance.

See Also

Renderer3D Members
Renderer3D Interface
MindFusion.Charting Namespace


MindFusion.Charting.RotationController Class

RotationController Class
[image]

Represents a controller that rotates a polar plot by changing its StartAngle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class RotationController : PlotController

Visual Basic [image] Copy Code

Public Class RotationController
Inherits PlotController

Inheritance Hierarchy

System.Object
MindFusion.Charting.PlotController
MindFusion.Charting.RotationController

See Also

RotationController Members
MindFusion.Charting Namespace


MindFusion.Charting.RotationController Members

RotationController Members
Constructors Fields Properties Methods
[image]

Represents a controller that rotates a polar plot by changing its StartAngle.

The following tables list the members exposed by the RotationController type.

Public Constructors

Name | Description
RotationController | Initializes a new instance of the RotationController class.

Protected Fields

Name | Description
renderContext | The current RenderContext. (Inherited from PlotController.)

Public Properties

Name | Description
Component | Gets the component controlled by this PlotController. (Inherited from PlotController.)
EnableAnimation | Gets or sets whether to enable rotation inertia.

Public Methods

Name | Description
DrawInteraction | Implements ComponentController.DrawInteraction. Draws a representation of the current state of user interaction on specified IGraphics surface. (Inherited from PlotController.)
GetRunningAnimation | For internal use.
OnMouseDown | PlotController.OnMouseDown override. Called when the user presses a mouse button.
OnMouseMove | PlotController.OnMouseMove override. Called when the user moves the mouse.
OnMouseUp | PlotController.OnMouseUp override. Called when the user releases a mouse button.

See Also

RotationController Class
MindFusion.Charting Namespace


MindFusion.Charting.RotationController Constructor

RotationController Constructor
[image]

Initializes a new instance of the RotationController class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public RotationController (
RenderContext renderContext
)

Visual Basic [image] Copy Code

Public New ( _
renderContext As RenderContext _
)

Parameters

renderContext

A RenderContext instance.

See Also

RotationController Class
MindFusion.Charting Namespace


MindFusion.Charting.RotationController Methods

RotationController Methods
[image]

Public Methods

Name | Description
DrawInteraction | Implements ComponentController.DrawInteraction. Draws a representation of the current state of user interaction on specified IGraphics surface. (Inherited from PlotController.)
GetRunningAnimation | For internal use.
OnMouseDown | PlotController.OnMouseDown override. Called when the user presses a mouse button.
OnMouseMove | PlotController.OnMouseMove override. Called when the user moves the mouse.
OnMouseUp | PlotController.OnMouseUp override. Called when the user releases a mouse button.

See Also

RotationController Class
MindFusion.Charting Namespace


MindFusion.Charting.RotationController.GetRunningAnimation Method

RotationController.GetRunningAnimation Method
[image]

For internal use.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override ComponentAnimation GetRunningAnimation ()

Visual Basic [image] Copy Code

Public Overrides Function GetRunningAnimation () As ComponentAnimation

Return Value

An instance of a ComponentAnimation -derived class.

See Also

RotationController Members
RotationController Class
MindFusion.Charting Namespace


MindFusion.Charting.RotationController.OnMouseDown Method

RotationController.OnMouseDown Method
[image]

PlotController.OnMouseDown override. Called when the user presses a mouse button.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void OnMouseDown (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overrides Sub OnMouseDown( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

RotationController Members
RotationController Class
MindFusion.Charting Namespace


MindFusion.Charting.RotationController.OnMouseMove Method

RotationController.OnMouseMove Method
[image]

PlotController.OnMouseMove override. Called when the user moves the mouse.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void OnMouseMove (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overrides Sub OnMouseMove( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

RotationController Members
RotationController Class
MindFusion.Charting Namespace


MindFusion.Charting.RotationController.OnMouseUp Method

RotationController.OnMouseUp Method
[image]

PlotController.OnMouseUp override. Called when the user releases a mouse button.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void OnMouseUp (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overrides Sub OnMouseUp( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

RotationController Members
RotationController Class
MindFusion.Charting Namespace


MindFusion.Charting.RotationController Properties

RotationController Properties
[image]

Public Properties

Name | Description
Component | Gets the component controlled by this PlotController. (Inherited from PlotController.)
EnableAnimation | Gets or sets whether to enable rotation inertia.

See Also

RotationController Class
MindFusion.Charting Namespace


MindFusion.Charting.RotationController.EnableAnimation Property

RotationController.EnableAnimation Property
[image]

Gets or sets whether to enable rotation inertia.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool EnableAnimation { get; set; }

Visual Basic [image] Copy Code

Public Property EnableAnimation As Boolean

Property Value

See Also

RotationController Members
RotationController Class
MindFusion.Charting Namespace


MindFusion.Charting.ScatterRenderer Class

ScatterRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws scatter in its containing plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class ScatterRenderer : Renderer2D

Visual Basic [image] Copy Code

Public Class ScatterRenderer
Inherits Renderer2D

Remarks

ScatterRenderer must be placed inside a Plot2D component. It draws each data item as a scatter Shape whose size is specified by ShapeSize. If the GetLabel method of Series object returns InnerLabel string, the label is drawn centered at its corresponding shape's location.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.ScatterRenderer
MindFusion.Charting.RadarScatterRenderer

See Also

ScatterRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.ScatterRenderer Members

ScatterRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws scatter in its containing plot.

The following tables list the members exposed by the ScatterRenderer type.

Public Constructors

Name | Description
ScatterRenderer | Initializes a new instance of the ScatterRenderer class.

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
Shape | Gets or sets the type of scatter shapes.
ShapeSize | Gets or sets the size of scatter shapes.
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the scatter representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted shape in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumPoints | Enumerates the data values of rendered series mapped to plot 2D coordinates.
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

ScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.ScatterRenderer Constructor

ScatterRenderer Constructor
[image]

Initializes a new instance of the ScatterRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public ScatterRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered as scatter.

See Also

ScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.ScatterRenderer Methods

ScatterRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the scatter representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | Renderer2D.DrawHighlight override. Draws highlighted shape in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumPoints | Enumerates the data values of rendered series mapped to plot 2D coordinates.
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

ScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.ScatterRenderer.Draw Method

ScatterRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

ScatterRenderer Members
ScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.ScatterRenderer.DrawHighlight Method

ScatterRenderer.DrawHighlight Method
[image]

Renderer2D.DrawHighlight override. Draws highlighted shape in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void DrawHighlight (
RenderContext context,
HitResult hitResult
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawHighlight( _
context As RenderContext, _
hitResult As HitResult _
)

Parameters

context

A RenderContext instance.

hitResult

A HitResult instance identifying highlighted data item.

See Also

ScatterRenderer Members
ScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.ScatterRenderer.EnumPoints Method

ScatterRenderer.EnumPoints Method
[image]

Enumerates the data values of rendered series mapped to plot 2D coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void EnumPoints (
RenderContext context,
Renderer2D.ProcessPoint process
)

Visual Basic [image] Copy Code

Protected Overridable Sub EnumPoints( _
context As RenderContext, _
process As Renderer2D.ProcessPoint _
)

Parameters

context

A RenderContext instance.

process

A ProcessPoint callback.

See Also

ScatterRenderer Members
ScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.ScatterRenderer.HitTest Method

ScatterRenderer.HitTest Method
[image]

Renderer2D.HitTest override. Hit-tests the scatter representations of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override HitResult HitTest (
RenderContext context,
PointD location
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
context As RenderContext, _
location As PointD _
) As HitResult

Parameters

context

A RenderContext instance.

location

A PointD specifying where to look for data items.

Return Value

A HitResult instance identifying the found data item.

See Also

ScatterRenderer Members
ScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.ScatterRenderer Properties

ScatterRenderer Properties
[image]

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
Shape | Gets or sets the type of scatter shapes.
ShapeSize | Gets or sets the size of scatter shapes.
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

See Also

ScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.ScatterRenderer.Shape Property

ScatterRenderer.Shape Property
[image]

Gets or sets the type of scatter shapes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public ScatterType Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As ScatterType

Property Value

See Also

ScatterRenderer Members
ScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.ScatterRenderer.ShapeSize Property

ScatterRenderer.ShapeSize Property
[image]

Gets or sets the size of scatter shapes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double ShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeSize As Double

Property Value

See Also

ScatterRenderer Members
ScatterRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.ScatterType Enumeration

ScatterType Enumeration
[image]

Identifies the shapes rendered by a ScatterRenderer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public enum ScatterType

Visual Basic [image] Copy Code

Public Enum ScatterType

Members

Member name | Description
Circle | Draw circles.
Diamond | Draw diamonds.
None | Do not draw scatter.
Square | Draw squares.
Triangle | Draw triangles.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.Series Interface

Series Interface
Remarks See Also
[image]

Specifies the interface that data providers should implement in order to feed data to SeriesRenderer classes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public interface Series

Visual Basic [image] Copy Code

Public Interface Series

Remarks

You could implement this interface in your own model classes to avoid duplicating data. Alternatively, if a model class is sealed but provides API to access its data, you could implement the interface in an adapter class.

The library includes several pre-defined series classes that let you specify data via IList or array objects. For example, BarSeries lets you specify lists of values, inner labels and top labels, and PointSeries lets you specify data as a list of points.

The DataBoundSeries class can take a data-source object such as DataTable or a list of .NET CLR objects, and read their values using reflection on fields specified via properties such as XDataField and InnerLabelsDataField.

XmlSeries automatically loads data from an XmlDocument, where node or attribute values to read are specified via XPath expressions through properties such as XDataPath and InnerLabelsPath.

Inheritors

MindFusion.Charting.DataBoundSeries
MindFusion.Charting.DateTimeSeries
MindFusion.Charting.FunctionSeries
MindFusion.Charting.PointSeries
MindFusion.Charting.PointSeries3D
MindFusion.Charting.Series2D
MindFusion.Charting.Series3D
MindFusion.Charting.SimpleSeries
MindFusion.Charting.StockPriceSeries
MindFusion.Charting.XmlSeries

See Also

Series Members
MindFusion.Charting Namespace


MindFusion.Charting.Series Members

Series Members
Properties Methods Events
[image]

Specifies the interface that data providers should implement in order to feed data to SeriesRenderer classes.

The following tables list the members exposed by the Series type.

Public Properties

Name | Description
Dimensions | Gets the number of values (coordinates) that can be returned by each data item.
Size | Gets the number of data items in this series.
SupportedLabels | Gets the kind of labels supported by this series.
Title | Gets the title of this series.

Public Methods

Name | Description
GetLabel | Returns a label for the specified data item in this series.
GetValue | Returns a value for the specified data item in this series.
IsEmphasized | Gets a value indicating whether the specified data item should be emphasized by the SeriesRenderer.
IsSorted | Gets a value indicating whether the series values increase monotonously in specified dimension.

Public Events

Name | Description
DataChanged | Raised when the values in this series change.

See Also

Series Interface
MindFusion.Charting Namespace


MindFusion.Charting.Series Methods

Series Methods
[image]

Public Methods

Name | Description
GetLabel | Returns a label for the specified data item in this series.
GetValue | Returns a value for the specified data item in this series.
IsEmphasized | Gets a value indicating whether the specified data item should be emphasized by the SeriesRenderer.
IsSorted | Gets a value indicating whether the series values increase monotonously in specified dimension.

See Also

Series Interface
MindFusion.Charting Namespace


MindFusion.Charting.Series.GetLabel Method

Series.GetLabel Method
[image]

Returns a label for the specified data item in this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

string GetLabel (
int index,
LabelKinds kind
)

Visual Basic [image] Copy Code

Function GetLabel( _
index As Integer, _
kind As LabelKinds _
) As String

Parameters

index

An integer value specifying the index of a data item.

kind

A member of the LabelKinds enumeration.

Return Value

A string containing the item's label.

See Also

Series Members
Series Interface
MindFusion.Charting Namespace


MindFusion.Charting.Series.GetValue Method

Series.GetValue Method
[image]

Returns a value for the specified data item in this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

double GetValue (
int index,
int dimension
)

Visual Basic [image] Copy Code

Function GetValue( _
index As Integer, _
dimension As Integer _
) As Double

Parameters

index

An integer value specifying the index of a data item.

dimension

An integer value specifying the dimension whose coordinate to return.

Return Value

A double-precision number representing the value of a data item in the series.

See Also

Series Members
Series Interface
MindFusion.Charting Namespace


MindFusion.Charting.Series.IsEmphasized Method

Series.IsEmphasized Method
[image]

Gets a value indicating whether the specified data item should be emphasized by the SeriesRenderer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

bool IsEmphasized (
int index
)

Visual Basic [image] Copy Code

Function IsEmphasized( _
index As Integer _
) As Boolean

Parameters

index

An integer value specifying the index of a data item.

Return Value

true to emphasize the specified data item, or false otherwise.

Remarks

At this time emphasized data items are supported only by PieRenderer, where they are rendered as detached pieces.

See Also

Series Members
Series Interface
MindFusion.Charting Namespace


MindFusion.Charting.Series.IsSorted Method

Series.IsSorted Method
[image]

Gets a value indicating whether the series values increase monotonously in specified dimension.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

bool IsSorted (
int dimension
)

Visual Basic [image] Copy Code

Function IsSorted( _
dimension As Integer _
) As Boolean

Parameters

dimension

An integer value identifying the dimension.

Return Value

true if the values are sorted in specified dimension, or false otherwise.

See Also

Series Members
Series Interface
MindFusion.Charting Namespace


MindFusion.Charting.Series Properties

Series Properties
[image]

Public Properties

Name | Description
Dimensions | Gets the number of values (coordinates) that can be returned by each data item.
Size | Gets the number of data items in this series.
SupportedLabels | Gets the kind of labels supported by this series.
Title | Gets the title of this series.

See Also

Series Interface
MindFusion.Charting Namespace


MindFusion.Charting.Series.Dimensions Property

Series.Dimensions Property
[image]

Gets the number of values (coordinates) that can be returned by each data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

int Dimensions { get; }

Visual Basic [image] Copy Code

ReadOnly Property Dimensions As Integer

Property Value

An integer value specifying the number of values / coordinates per data item.

See Also

Series Members
Series Interface
MindFusion.Charting Namespace


MindFusion.Charting.Series.Size Property

Series.Size Property
[image]

Gets the number of data items in this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

int Size { get; }

Visual Basic [image] Copy Code

ReadOnly Property Size As Integer

Property Value

An integer value specifying the number of elements in the series.

See Also

Series Members
Series Interface
MindFusion.Charting Namespace


MindFusion.Charting.Series.SupportedLabels Property

Series.SupportedLabels Property
[image]

Gets the kind of labels supported by this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

LabelKinds SupportedLabels { get; }

Visual Basic [image] Copy Code

ReadOnly Property SupportedLabels As LabelKinds

Property Value

A combination of LabelKinds flags specifying what kinds of labels could be returned by GetLabel method.

See Also

Series Members
Series Interface
MindFusion.Charting Namespace


MindFusion.Charting.Series.Title Property

Series.Title Property
[image]

Gets the title of this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

string Title { get; }

Visual Basic [image] Copy Code

ReadOnly Property Title As String

Property Value

A string specifying the series' title.

Remarks

Series titles are displayed inside legends by LegendRenderer.

See Also

Series Members
Series Interface
MindFusion.Charting Namespace


MindFusion.Charting.Series Events

Series Events
[image]

Public Events

Name | Description
DataChanged | Raised when the values in this series change.

See Also

Series Interface
MindFusion.Charting Namespace


MindFusion.Charting.Series.DataChanged Event

Series.DataChanged Event
[image]

Raised when the values in this series change.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

event EventHandler DataChanged

Visual Basic [image] Copy Code

Event DataChanged As EventHandler

See Also

Series Members
Series Interface
MindFusion.Charting Namespace


MindFusion.Charting.Series2D Class

Series2D Class
[image]

Represents a data series defined by two lists of values containing respectively X and Y coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class Series2D : Series

Visual Basic [image] Copy Code

Public Class Series2D
Implements Series

Inheritance Hierarchy

System.Object
MindFusion.Charting.Series2D

See Also

Series2D Members
MindFusion.Charting Namespace


MindFusion.Charting.Series2D Members

Series2D Members
Constructors Properties Methods Events
[image]

Represents a data series defined by two lists of values containing respectively X and Y coordinates.

The following tables list the members exposed by the Series2D type.

Public Constructors

Name | Description
Series2D | Initializes a new instance of the Series2D class.

Public Properties

Name | Description
Dimensions | Implements Series.Dimensions. Returns 2.
Labels | Gets or sets the data labels.
Size | Implements Series.Size. Returns the number of elements in XData list.
SupportedLabels | Implements Series.SupportedLabels. Gets or sets the kind of labels reported as supported by this series.
Title | Implements Series.Title. Gets or sets the title of this series.
XData | Gets or sets the X coordinates of data items.
YData | Gets or sets the Y coordinates of data items.

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns an element of the Labels list.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in this series.
IsEmphasized | Implements Series.IsEmphasized. Series2D always returns false.
IsSorted | Implements Series.IsSorted. Series2D always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D Constructor

Series2D Constructor
[image]

Initializes a new instance of the Series2D class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Series2D (
IList<Double> xValues,
IList<Double> yValues,
IList<string> labels
)

Visual Basic [image] Copy Code

Public New ( _
xValues As IList(Of Double), _
yValues As IList(Of Double), _
labels As IList(Of String) _
)

Parameters

xValues

A list of X coordinates.

yValues

A list of Y coordinates.

labels

A list of labels.

See Also

Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D Methods

Series2D Methods
[image]

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns an element of the Labels list.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in this series.
IsEmphasized | Implements Series.IsEmphasized. Series2D always returns false.
IsSorted | Implements Series.IsSorted. Series2D always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

See Also

Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D.GetLabel Method

Series2D.GetLabel Method
[image]

Implements Series.GetLabel. Returns an element of the Labels list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string GetLabel (
int index,
LabelKinds kind
)

Visual Basic [image] Copy Code

Public Function GetLabel( _
index As Integer, _
kind As LabelKinds _
) As String

Parameters

index

An integer value specifying the index of a data item.

kind

A member of the LabelKinds enumeration.

Return Value

A string containing the item's label.

See Also

Series2D Members
Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D.GetValue Method

Series2D.GetValue Method
[image]

Implements Series.GetValue. Returns a value for the specified data item in this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual double GetValue (
int index,
int dimension
)

Visual Basic [image] Copy Code

Public Overridable Function GetValue( _
index As Integer, _
dimension As Integer _
) As Double

Parameters

index

An integer value specifying the index of a data item.

dimension

An integer value specifying the dimension whose coordinate to return.

Return Value

A double-precision number representing the value of a data item in the series.

See Also

Series2D Members
Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D.IsEmphasized Method

Series2D.IsEmphasized Method
[image]

Implements Series.IsEmphasized. Series2D always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsEmphasized (
int index
)

Visual Basic [image] Copy Code

Public Function IsEmphasized( _
index As Integer _
) As Boolean

Parameters

index

An integer value specifying the index of a data item.

Return Value

true to emphasize the specified data item, or false otherwise.

See Also

Series2D Members
Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D.IsSorted Method

Series2D.IsSorted Method
[image]

Implements Series.IsSorted. Series2D always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsSorted (
int dimension
)

Visual Basic [image] Copy Code

Public Function IsSorted( _
dimension As Integer _
) As Boolean

Parameters

dimension

An integer value identifying the dimension.

Return Value

true if the values are sorted in specified dimension, or false otherwise.

See Also

Series2D Members
Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D.OnDataChanged Method

Series2D.OnDataChanged Method
[image]

Raises the DataChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void OnDataChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnDataChanged ()

See Also

Series2D Members
Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D Properties

Series2D Properties
[image]

Public Properties

Name | Description
Dimensions | Implements Series.Dimensions. Returns 2.
Labels | Gets or sets the data labels.
Size | Implements Series.Size. Returns the number of elements in XData list.
SupportedLabels | Implements Series.SupportedLabels. Gets or sets the kind of labels reported as supported by this series.
Title | Implements Series.Title. Gets or sets the title of this series.
XData | Gets or sets the X coordinates of data items.
YData | Gets or sets the Y coordinates of data items.

See Also

Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D.Dimensions Property

Series2D.Dimensions Property
[image]

Implements Series.Dimensions. Returns 2.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Dimensions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dimensions As Integer

Property Value

See Also

Series2D Members
Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D.Labels Property

Series2D.Labels Property
[image]

Gets or sets the data labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<string> Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Labels As IList(Of String)

Property Value

See Also

Series2D Members
Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D.Size Property

Series2D.Size Property
[image]

Implements Series.Size. Returns the number of elements in XData list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual int Size { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property Size As Integer

Property Value

See Also

Series2D Members
Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D.SupportedLabels Property

Series2D.SupportedLabels Property
[image]

Implements Series.SupportedLabels. Gets or sets the kind of labels reported as supported by this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public LabelKinds SupportedLabels { get; set; }

Visual Basic [image] Copy Code

Public Property SupportedLabels As LabelKinds

Property Value

See Also

Series2D Members
Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D.Title Property

Series2D.Title Property
[image]

Implements Series.Title. Gets or sets the title of this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

Series2D Members
Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D.XData Property

Series2D.XData Property
[image]

Gets or sets the X coordinates of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<Double> XData { get; set; }

Visual Basic [image] Copy Code

Public Property XData As IList(Of Double)

Property Value

See Also

Series2D Members
Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D.YData Property

Series2D.YData Property
[image]

Gets or sets the Y coordinates of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<Double> YData { get; set; }

Visual Basic [image] Copy Code

Public Property YData As IList(Of Double)

Property Value

See Also

Series2D Members
Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D Events

Series2D Events
[image]

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series2D.DataChanged Event

Series2D.DataChanged Event
[image]

Implements Series.DataChanged. Raised when the values in this series change.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

See Also

Series2D Members
Series2D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D Class

Series3D Class
[image]

Represents a data series defined by three lists of values containing respectively X, Y and Z coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class Series3D : Series

Visual Basic [image] Copy Code

Public Class Series3D
Implements Series

Inheritance Hierarchy

System.Object
MindFusion.Charting.Series3D

See Also

Series3D Members
MindFusion.Charting Namespace


MindFusion.Charting.Series3D Members

Series3D Members
Constructors Properties Methods Events
[image]

Represents a data series defined by three lists of values containing respectively X, Y and Z coordinates.

The following tables list the members exposed by the Series3D type.

Public Constructors

Name | Description
Series3D | Initializes a new instance of the Series3D class.

Public Properties

Name | Description
Dimensions | Implements Series.Dimensions. Returns 3.
Labels | Gets or sets the data labels.
Size | Implements Series.Size. Returns the number of elements in XData list.
SupportedLabels | Implements Series.SupportedLabels. Returns InnerLabel.
Title | Implements Series.Title. Gets or sets the title of this series.
XData | Gets or sets the X coordinates of data items.
YData | Gets or sets the Y coordinates of data items.
ZData | Gets or sets the X coordinates of data items.

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns an element of the Labels list.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in this series.
IsEmphasized | Implements Series.IsEmphasized. Series3D always returns false.
IsSorted | Implements Series.IsSorted. Series3D always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D Constructor

Series3D Constructor
[image]

Initializes a new instance of the Series3D class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Series3D (
IList<Double> xValues,
IList<Double> yValues,
IList<Double> zValues,
IList<string> labels
)

Visual Basic [image] Copy Code

Public New ( _
xValues As IList(Of Double), _
yValues As IList(Of Double), _
zValues As IList(Of Double), _
labels As IList(Of String) _
)

Parameters

xValues

A list of X coordinates.

yValues

A list of Y coordinates.

zValues

A list of Z coordinates.

labels

A list of labels.

See Also

Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D Methods

Series3D Methods
[image]

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns an element of the Labels list.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in this series.
IsEmphasized | Implements Series.IsEmphasized. Series3D always returns false.
IsSorted | Implements Series.IsSorted. Series3D always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

See Also

Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.GetLabel Method

Series3D.GetLabel Method
[image]

Implements Series.GetLabel. Returns an element of the Labels list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string GetLabel (
int index,
LabelKinds kind
)

Visual Basic [image] Copy Code

Public Function GetLabel( _
index As Integer, _
kind As LabelKinds _
) As String

Parameters

index

An integer value specifying the index of a data item.

kind

A member of the LabelKinds enumeration.

Return Value

A string containing the item's label.

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.GetValue Method

Series3D.GetValue Method
[image]

Implements Series.GetValue. Returns a value for the specified data item in this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GetValue (
int index,
int dimension
)

Visual Basic [image] Copy Code

Public Function GetValue( _
index As Integer, _
dimension As Integer _
) As Double

Parameters

index

An integer value specifying the index of a data item.

dimension

An integer value specifying the dimension whose coordinate to return.

Return Value

A double-precision number representing the value of a data item in the series.

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.IsEmphasized Method

Series3D.IsEmphasized Method
[image]

Implements Series.IsEmphasized. Series3D always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsEmphasized (
int index
)

Visual Basic [image] Copy Code

Public Function IsEmphasized( _
index As Integer _
) As Boolean

Parameters

index

An integer value specifying the index of a data item.

Return Value

true to emphasize the specified data item, or false otherwise.

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.IsSorted Method

Series3D.IsSorted Method
[image]

Implements Series.IsSorted. Series3D always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsSorted (
int dimension
)

Visual Basic [image] Copy Code

Public Function IsSorted( _
dimension As Integer _
) As Boolean

Parameters

dimension

An integer value identifying the dimension.

Return Value

true if the values are sorted in specified dimension, or false otherwise.

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.OnDataChanged Method

Series3D.OnDataChanged Method
[image]

Raises the DataChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void OnDataChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnDataChanged ()

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D Properties

Series3D Properties
[image]

Public Properties

Name | Description
Dimensions | Implements Series.Dimensions. Returns 3.
Labels | Gets or sets the data labels.
Size | Implements Series.Size. Returns the number of elements in XData list.
SupportedLabels | Implements Series.SupportedLabels. Returns InnerLabel.
Title | Implements Series.Title. Gets or sets the title of this series.
XData | Gets or sets the X coordinates of data items.
YData | Gets or sets the Y coordinates of data items.
ZData | Gets or sets the X coordinates of data items.

See Also

Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.Dimensions Property

Series3D.Dimensions Property
[image]

Implements Series.Dimensions. Returns 3.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Dimensions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dimensions As Integer

Property Value

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.Labels Property

Series3D.Labels Property
[image]

Gets or sets the data labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<string> Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Labels As IList(Of String)

Property Value

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.Size Property

Series3D.Size Property
[image]

Implements Series.Size. Returns the number of elements in XData list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Size { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Size As Integer

Property Value

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.SupportedLabels Property

Series3D.SupportedLabels Property
[image]

Implements Series.SupportedLabels. Returns InnerLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public LabelKinds SupportedLabels { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SupportedLabels As LabelKinds

Property Value

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.Title Property

Series3D.Title Property
[image]

Implements Series.Title. Gets or sets the title of this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.XData Property

Series3D.XData Property
[image]

Gets or sets the X coordinates of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<Double> XData { get; set; }

Visual Basic [image] Copy Code

Public Property XData As IList(Of Double)

Property Value

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.YData Property

Series3D.YData Property
[image]

Gets or sets the Y coordinates of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<Double> YData { get; set; }

Visual Basic [image] Copy Code

Public Property YData As IList(Of Double)

Property Value

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.ZData Property

Series3D.ZData Property
[image]

Gets or sets the X coordinates of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<Double> ZData { get; set; }

Visual Basic [image] Copy Code

Public Property ZData As IList(Of Double)

Property Value

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D Events

Series3D Events
[image]

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.Series3D.DataChanged Event

Series3D.DataChanged Event
[image]

Implements Series.DataChanged. Raised when the values in this series change.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

See Also

Series3D Members
Series3D Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesContainer Interface

SeriesContainer Interface
[image]

Defines an interface for enumerating all series associated with a component of the dashboard.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public interface SeriesContainer

Visual Basic [image] Copy Code

Public Interface SeriesContainer

Inheritors

MindFusion.Charting.Plot
MindFusion.Charting.SeriesRenderer

See Also

SeriesContainer Members
MindFusion.Charting Namespace


MindFusion.Charting.SeriesContainer Members

SeriesContainer Members
Methods
[image]

Defines an interface for enumerating all series associated with a component of the dashboard.

The following tables list the members exposed by the SeriesContainer type.

Public Methods

Name | Description
DomainDimension | Gets the index of the dimension whose set of values should be treated as domain of plotted function.
EnumSeries | Enumerates the series associated with this component.

See Also

SeriesContainer Interface
MindFusion.Charting Namespace


MindFusion.Charting.SeriesContainer Methods

SeriesContainer Methods
[image]

Public Methods

Name | Description
DomainDimension | Gets the index of the dimension whose set of values should be treated as domain of plotted function.
EnumSeries | Enumerates the series associated with this component.

See Also

SeriesContainer Interface
MindFusion.Charting Namespace


MindFusion.Charting.SeriesContainer.DomainDimension Method

SeriesContainer.DomainDimension Method
[image]

Gets the index of the dimension whose set of values should be treated as domain of plotted function.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

int DomainDimension (
Series series
)

Visual Basic [image] Copy Code

Function DomainDimension( _
series As Series _
) As Integer

Parameters

series

A Series in this container.

Return Value

The dimension index.

See Also

SeriesContainer Members
SeriesContainer Interface
MindFusion.Charting Namespace


MindFusion.Charting.SeriesContainer.EnumSeries Method

SeriesContainer.EnumSeries Method
[image]

Enumerates the series associated with this component.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

IEnumerable<Series> EnumSeries ()

Visual Basic [image] Copy Code

Function EnumSeries () As IEnumerable(Of Series)

Return Value

An instance of the IEnumerable<Series> class.

See Also

SeriesContainer Members
SeriesContainer Interface
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer Class

SeriesRenderer Class
Remarks See Also
[image]

Base class for renderer objects that draw data series inside a Plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public abstract class SeriesRenderer : SeriesContainer, INotifyPropertyChanged

Visual Basic [image] Copy Code

Public MustInherit Class SeriesRenderer
Implements SeriesContainer, INotifyPropertyChanged

Remarks

This class defines how a series renderer interacts with its containing plot component and other renderers inside the plot. It also implements CSS-like style inheritance mechanism for visualization of data items that searches for appearance attributes in local SeriesStyle, plot's SeriesStyle or global dashboard's Theme.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.PieRenderer
MindFusion.Charting.RadarRenderer
MindFusion.Charting.Renderer2D

See Also

SeriesRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer Members

SeriesRenderer Members
Constructors Properties Methods Events
[image]

Base class for renderer objects that draw data series inside a Plot.

The following tables list the members exposed by the SeriesRenderer type.

Public Constructors

Name | Description
SeriesRenderer | Initializes a new instance of the SeriesRenderer class.

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items.
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items.
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items.
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items.
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer.
ShowDataLabels | Gets or sets the kind of data labels to draw.

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function.
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item.
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item.
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item.
EnumSeries | Implements the SeriesContainer interface.
HitTest | Hit-tests the visual representation of the series for a data item.
SearchStyle | Returns a SeriesStyle object that meets specified criteria.
StartMeasureData | Called to reset measure accumulators at the beginning of a measure pass.

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass.
Draw | Draws the series data in specified RenderContext.
DrawHighlight | Draws highlighted data item in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items.
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items.
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item.
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item.
MeasureDataRange | Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event.
OnSeriesDataChanged | Called when Series raise their DataChanged event.
SetToolTip | Sets tooltip text and lcoation.
Subscribe | Subscribes to the DataChanged event of specified Series.
Unsubscribe | Unsubscribes from the DataChanged event of specified Series.

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface.

See Also

SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer Constructor

SeriesRenderer Constructor
[image]

Initializes a new instance of the SeriesRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public SeriesRenderer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer Methods

SeriesRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function.
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item.
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item.
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item.
EnumSeries | Implements the SeriesContainer interface.
HitTest | Hit-tests the visual representation of the series for a data item.
SearchStyle | Returns a SeriesStyle object that meets specified criteria.
StartMeasureData | Called to reset measure accumulators at the beginning of a measure pass.

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass.
Draw | Draws the series data in specified RenderContext.
DrawHighlight | Draws highlighted data item in specified RenderContext.
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items.
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items.
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item.
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item.
MeasureDataRange | Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event.
OnSeriesDataChanged | Called when Series raise their DataChanged event.
SetToolTip | Sets tooltip text and lcoation.
Subscribe | Subscribes to the DataChanged event of specified Series.
Unsubscribe | Unsubscribes from the DataChanged event of specified Series.

See Also

SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.AdjustDataRange Method

SeriesRenderer.AdjustDataRange Method
[image]

Adjusts the data range of associated Axis objects after initial measure pass.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void AdjustDataRange (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub AdjustDataRange( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.DomainDimension Method

SeriesRenderer.DomainDimension Method
[image]

Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int DomainDimension (
Series series
)

Visual Basic [image] Copy Code

Public Function DomainDimension( _
series As Series _
) As Integer

Parameters

series

A Series in this container.

Return Value

The dimension index.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.Draw Method

SeriesRenderer.Draw Method
[image]

Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.DrawHighlight Method

SeriesRenderer.DrawHighlight Method
[image]

Draws highlighted data item in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void DrawHighlight (
RenderContext context,
HitResult hitResult
)

Visual Basic [image] Copy Code

Protected Overridable Sub DrawHighlight( _
context As RenderContext, _
hitResult As HitResult _
)

Parameters

context

A RenderContext instance.

hitResult

A HitResult instance identifying highlighted data item.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.EffectiveFill Method

SeriesRenderer.EffectiveFill Method
[image]

Gets the brush that should be used to fill the representation of specified data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush EffectiveFill (
int seriesIndex,
int dataIndex,
RenderContext context
)

Visual Basic [image] Copy Code

Public Function EffectiveFill( _
seriesIndex As Integer, _
dataIndex As Integer, _
context As RenderContext _
) As Brush

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this SeriesRenderer.

dataIndex

An integer index of the data item in specified series.

context

A RenderContext instance.

Return Value

A Brush instance.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.EffectiveLabelBrush Method

SeriesRenderer.EffectiveLabelBrush Method
[image]

Gets the System.Drawing.Brush that should be used to draw labels of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Brush EffectiveLabelBrush (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveLabelBrush( _
context As RenderContext _
) As Brush

Parameters

context

A RenderContext instance used to find styles and theme from dashboard hierarchy.

Return Value

A System.Drawing.Brush instance.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.EffectiveLabelFont Method

SeriesRenderer.EffectiveLabelFont Method
[image]

Gets the Font that should be used to draw labels of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Font EffectiveLabelFont (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveLabelFont( _
context As RenderContext _
) As Font

Parameters

context

A RenderContext instance used to find styles and theme from dashboard hierarchy.

Return Value

A Font instance.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.EffectiveStroke Method

SeriesRenderer.EffectiveStroke Method
[image]

Gets the brush that should be used to stroke the representation of specified data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush EffectiveStroke (
int seriesIndex,
int dataIndex,
RenderContext context
)

Visual Basic [image] Copy Code

Public Function EffectiveStroke( _
seriesIndex As Integer, _
dataIndex As Integer, _
context As RenderContext _
) As Brush

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this SeriesRenderer.

dataIndex

An integer index of the data item in specified series.

context

A RenderContext instance.

Return Value

A Brush instance.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.EffectiveStrokeDashStyle Method

SeriesRenderer.EffectiveStrokeDashStyle Method
[image]

Gets the dash style of the pen that should be used to stroke the representation of specified data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected DashStyle EffectiveStrokeDashStyle (
int seriesIndex,
int dataIndex,
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveStrokeDashStyle( _
seriesIndex As Integer, _
dataIndex As Integer, _
context As RenderContext _
) As DashStyle

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this SeriesRenderer.

dataIndex

An integer index of the data item in specified series.

context

A RenderContext instance.

Return Value

A member of the DashStyle enumeration.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.EffectiveStrokePen Method

SeriesRenderer.EffectiveStrokePen Method
[image]

Gets the Pen that should be used to stroke the representation of specified data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected Pen EffectiveStrokePen (
int seriesIndex,
int dataIndex,
RenderContext context
)

Visual Basic [image] Copy Code

Protected Function EffectiveStrokePen( _
seriesIndex As Integer, _
dataIndex As Integer, _
context As RenderContext _
) As Pen

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this SeriesRenderer.

dataIndex

An integer index of the data item in specified series.

context

A RenderContext instance.

Return Value

A Pen instance.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.EffectiveStrokeThickness Method

SeriesRenderer.EffectiveStrokeThickness Method
[image]

Gets the thickness of the pen that should be used to stroke the representation of specified data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double EffectiveStrokeThickness (
int seriesIndex,
int dataIndex,
RenderContext context
)

Visual Basic [image] Copy Code

Public Function EffectiveStrokeThickness( _
seriesIndex As Integer, _
dataIndex As Integer, _
context As RenderContext _
) As Double

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this SeriesRenderer.

dataIndex

An integer index of the data item in specified series.

context

A RenderContext instance.

Return Value

A double value.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.EnumSeries Method

SeriesRenderer.EnumSeries Method
[image]

Implements the SeriesContainer interface.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public abstract IEnumerable<Series> EnumSeries ()

Visual Basic [image] Copy Code

Public MustOverride Function EnumSeries () As IEnumerable(Of Series)

Return Value

An instance of the IEnumerable<Series> class.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.HitTest Method

SeriesRenderer.HitTest Method
[image]

Hit-tests the visual representation of the series for a data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual HitResult HitTest (
RenderContext context,
PointD location
)

Visual Basic [image] Copy Code

Public Overridable Function HitTest( _
context As RenderContext, _
location As PointD _
) As HitResult

Parameters

context

A RenderContext instance.

location

A PointD specifying where to look for data items.

Return Value

A HitResult instance identifying the found data item.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.MeasureDataRange Method

SeriesRenderer.MeasureDataRange Method
[image]

Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void MeasureDataRange (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub MeasureDataRange( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.OnPropertyChanged Method

SeriesRenderer.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
string propertyName
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
propertyName As String _
)

Parameters

propertyName

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.OnSeriesDataChanged Method

SeriesRenderer.OnSeriesDataChanged Method
[image]

Called when Series raise their DataChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void OnSeriesDataChanged (
Object sender,
EventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnSeriesDataChanged( _
sender As Object, _
e As EventArgs _
)

Parameters

sender

The Series raising the event.

e

An EventArgs instance.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.SearchStyle Method

SeriesRenderer.SearchStyle Method
[image]

Returns a SeriesStyle object that meets specified criteria.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public SeriesStyle SearchStyle (
SeriesRenderer.StyleCheck check,
RenderContext context
)

Visual Basic [image] Copy Code

Public Function SearchStyle( _
check As SeriesRenderer.StyleCheck, _
context As RenderContext _
) As SeriesStyle

Parameters

check

A StyleCheck delegate that tests SeriesStyle for some criteria.

context

A RenderContext instance used to access styles and theme from the dashboard hierarchy.

Return Value

A SeriesStyle instance, or null if none meets spcified criteria.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.SetToolTip Method

SeriesRenderer.SetToolTip Method
[image]

Sets tooltip text and lcoation.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void SetToolTip (
string text,
PointD location
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetToolTip( _
text As String, _
location As PointD _
)

Parameters

text

A string specifying tooltip text.

location

A PointD specifying tooltip location.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.StartMeasureData Method

SeriesRenderer.StartMeasureData Method
[image]

Called to reset measure accumulators at the beginning of a measure pass.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual void StartMeasureData (
RenderContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub StartMeasureData( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.Subscribe Method

SeriesRenderer.Subscribe Method
[image]

Subscribes to the DataChanged event of specified Series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void Subscribe (
Series series
)

Visual Basic [image] Copy Code

Protected Sub Subscribe( _
series As Series _
)

Parameters

series

A Series instance.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.Unsubscribe Method

SeriesRenderer.Unsubscribe Method
[image]

Unsubscribes from the DataChanged event of specified Series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void Unsubscribe (
Series series
)

Visual Basic [image] Copy Code

Protected Sub Unsubscribe( _
series As Series _
)

Parameters

series

A Series instance.

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer Properties

SeriesRenderer Properties
[image]

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items.
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items.
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items.
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items.
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer.
ShowDataLabels | Gets or sets the kind of data labels to draw.

See Also

SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.LabelBrush Property

SeriesRenderer.LabelBrush Property
[image]

Gets or sets the Brush that should be used to draw labels of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush LabelBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBrush As Brush

Property Value

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.LabelFontName Property

SeriesRenderer.LabelFontName Property
[image]

Gets or sets the name of font that should be used to draw labels of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string LabelFontName { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontName As String

Property Value

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.LabelFontSize Property

SeriesRenderer.LabelFontSize Property
[image]

Gets or sets the size of font that should be used to draw labels of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> LabelFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontSize As Nullable(Of Double)

Property Value

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.LabelFontStyle Property

SeriesRenderer.LabelFontStyle Property
[image]

Gets or sets the style of font that should be used to draw labels of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<FontStyle> LabelFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontStyle As Nullable(Of FontStyle)

Property Value

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.SeriesStyle Property

SeriesRenderer.SeriesStyle Property
[image]

A SeriesStyle instance specifying the appearance of series associated with this renderer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public SeriesStyle SeriesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesStyle As SeriesStyle

Property Value

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.ShowDataLabels Property

SeriesRenderer.ShowDataLabels Property
[image]

Gets or sets the kind of data labels to draw.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public LabelKinds ShowDataLabels { get; set; }

Visual Basic [image] Copy Code

Public Property ShowDataLabels As LabelKinds

Property Value

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer Events

SeriesRenderer Events
[image]

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface.

See Also

SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.PropertyChanged Event

SeriesRenderer.PropertyChanged Event
[image]

Implements the INotifyPropertyChanged interface.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

SeriesRenderer Members
SeriesRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.SeriesRenderer.StyleCheck Delegate

SeriesRenderer.StyleCheck Delegate
[image]

Defines the signature of filter methods used to find SeriesStyle objects that meet specified criteria.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public delegate bool SeriesRenderer.StyleCheck (
SeriesStyle style
)

Visual Basic [image] Copy Code

Public Delegate Function SeriesRenderer.StyleCheck( _
style As SeriesStyle _
) As Boolean

Parameters

style

A SeriesStyle to check.

Return Value

true if the style meets specified criteria, or false otherwise.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.SeriesStyle Interface

SeriesStyle Interface
Remarks See Also
[image]

Defines appearance attributes of series elements.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public interface SeriesStyle

Visual Basic [image] Copy Code

Public Interface SeriesStyle

Remarks

This interface defines how SeriesRenderer objects get appearance attributes for series elements, where each element of each series can generally be drawn in distinct style from others. You could implement this interface in your own class to calculate stroke and fill colors dynamically based on series and element indices.

There are several SeriesStyle classes provided out-of-the-box, that implement various levels of distinctness for graphical elements drawn for each data item. UniformSeriesStyle uses same attributes for all elements of all series. PerSeriesStyle contains different attributes for different series, where all elements in the series are drawn with same attributes. PerElementSeriesStyle allows customization of each element of each series. MixedSeriesStyle allows a mix of uniform, per-element and per-series attributes.

SeriesStyle attributes also participate in CSS-like style inheritance. There are SeriesStyle properties defined in SeriesRenderer and Plot classes, and if none of them contains a requested attribute, its value is ultimately inherited from the current Theme.

Inheritors

MindFusion.Charting.CandlestickSeriesStyle
MindFusion.Charting.MixedSeriesStyle
MindFusion.Charting.PerElementSeriesStyle
MindFusion.Charting.PerSeriesStyle
MindFusion.Charting.UniformSeriesStyle

See Also

SeriesStyle Members
MindFusion.Charting Namespace


MindFusion.Charting.SeriesStyle Members

SeriesStyle Members
Methods
[image]

Defines appearance attributes of series elements.

The following tables list the members exposed by the SeriesStyle type.

Public Methods

Name | Description
Fill | Returns a Brush that should be used to fill specified element of specified series.
Stroke | Returns a Brush that should be used to stroke specified element of specified series.
StrokeDashStyle | Returns the dash style of the stroke used to draw specified element of specified series.
StrokeThickness | Returns the thickness of the stroke used to draw specified element of specified series.

See Also

SeriesStyle Interface
MindFusion.Charting Namespace


MindFusion.Charting.SeriesStyle Methods

SeriesStyle Methods
[image]

Public Methods

Name | Description
Fill | Returns a Brush that should be used to fill specified element of specified series.
Stroke | Returns a Brush that should be used to stroke specified element of specified series.
StrokeDashStyle | Returns the dash style of the stroke used to draw specified element of specified series.
StrokeThickness | Returns the thickness of the stroke used to draw specified element of specified series.

See Also

SeriesStyle Interface
MindFusion.Charting Namespace


MindFusion.Charting.SeriesStyle.Fill Method

SeriesStyle.Fill Method
[image]

Returns a Brush that should be used to fill specified element of specified series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

Brush Fill (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Function Fill( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Brush

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A Brush instance.

See Also

SeriesStyle Members
SeriesStyle Interface
MindFusion.Charting Namespace


MindFusion.Charting.SeriesStyle.Stroke Method

SeriesStyle.Stroke Method
[image]

Returns a Brush that should be used to stroke specified element of specified series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

Brush Stroke (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Function Stroke( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Brush

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A Brush instance.

See Also

SeriesStyle Members
SeriesStyle Interface
MindFusion.Charting Namespace


MindFusion.Charting.SeriesStyle.StrokeDashStyle Method

SeriesStyle.StrokeDashStyle Method
[image]

Returns the dash style of the stroke used to draw specified element of specified series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

Nullable<DashStyle> StrokeDashStyle (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Function StrokeDashStyle( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Nullable(Of DashStyle)

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A nullable DashStyle value specifying stroke dash style.

See Also

SeriesStyle Members
SeriesStyle Interface
MindFusion.Charting Namespace


MindFusion.Charting.SeriesStyle.StrokeThickness Method

SeriesStyle.StrokeThickness Method
[image]

Returns the thickness of the stroke used to draw specified element of specified series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

Nullable<Double> StrokeThickness (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Function StrokeThickness( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Nullable(Of Double)

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A nullable double value specifying stroke thickness.

See Also

SeriesStyle Members
SeriesStyle Interface
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries Class

SimpleSeries Class
[image]

Represents one-dimensional series defined by e list of data values and a list of labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class SimpleSeries : Series

Visual Basic [image] Copy Code

Public Class SimpleSeries
Implements Series

Inheritance Hierarchy

System.Object
MindFusion.Charting.SimpleSeries
MindFusion.Charting.BarSeries
MindFusion.Charting.PieSeries

See Also

SimpleSeries Members
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries Members

SimpleSeries Members
Constructors Fields Properties Methods Events
[image]

Represents one-dimensional series defined by e list of data values and a list of labels.

The following tables list the members exposed by the SimpleSeries type.

Public Constructors

Name | Description
SimpleSeries | Initializes a new instance of the SimpleSeries class.

Protected Fields

Name | Description
emphasizedIndices | Contains the indices of emphasized data items.
labels | Contains the labels of data items.

Public Properties

Name | Description
Data | Gets or sets the data values contained in this series.
Dimensions | Implements Series.Dimensions. Returns 1.
Size | Implements Series.Size. Returns the number of elements in Data list.
SupportedLabels | Implements Series.SupportedLabels. Returns LabelKinds.InnerLabel.
Title | Implements Series.Title. Gets or sets the title of this series.

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns an element of the labels list.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in this series.
IsEmphasized | Implements Series.IsEmphasized. Gets a value indicating whether the specified data item should be emphasized by the SeriesRenderer.
IsSorted | Implements Series.IsSorted. SimpleSeries always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries Fields

SimpleSeries Fields
[image]

Protected Fields

Name | Description
emphasizedIndices | Contains the indices of emphasized data items.
labels | Contains the labels of data items.

See Also

SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries.emphasizedIndices Field

SimpleSeries.emphasizedIndices Field
[image]

Contains the indices of emphasized data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected IList<Int32> emphasizedIndices

Visual Basic [image] Copy Code

Protected emphasizedIndices As IList(Of Int32)

See Also

SimpleSeries Members
SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries.labels Field

SimpleSeries.labels Field
[image]

Contains the labels of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected IList<string> labels

Visual Basic [image] Copy Code

Protected labels As IList(Of String)

See Also

SimpleSeries Members
SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries Constructor

SimpleSeries Constructor
[image]

Initializes a new instance of the SimpleSeries class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public SimpleSeries (
IList<Double> values,
IList<string> labels
)

Visual Basic [image] Copy Code

Public New ( _
values As IList(Of Double), _
labels As IList(Of String) _
)

Parameters

values

A list of data values.

labels

A list of labels.

See Also

SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries Methods

SimpleSeries Methods
[image]

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns an element of the labels list.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in this series.
IsEmphasized | Implements Series.IsEmphasized. Gets a value indicating whether the specified data item should be emphasized by the SeriesRenderer.
IsSorted | Implements Series.IsSorted. SimpleSeries always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

See Also

SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries.GetLabel Method

SimpleSeries.GetLabel Method
[image]

Implements Series.GetLabel. Returns an element of the labels list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual string GetLabel (
int index,
LabelKinds kind
)

Visual Basic [image] Copy Code

Public Overridable Function GetLabel( _
index As Integer, _
kind As LabelKinds _
) As String

Parameters

index

An integer value specifying the index of a data item.

kind

A member of the LabelKinds enumeration.

Return Value

A string containing the item's label.

See Also

SimpleSeries Members
SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries.GetValue Method

SimpleSeries.GetValue Method
[image]

Implements Series.GetValue. Returns a value for the specified data item in this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GetValue (
int index,
int dimension
)

Visual Basic [image] Copy Code

Public Function GetValue( _
index As Integer, _
dimension As Integer _
) As Double

Parameters

index

An integer value specifying the index of a data item.

dimension

An integer value specifying the dimension whose coordinate to return.

Return Value

A double-precision number representing the value of a data item in the series.

See Also

SimpleSeries Members
SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries.IsEmphasized Method

SimpleSeries.IsEmphasized Method
[image]

Implements Series.IsEmphasized. Gets a value indicating whether the specified data item should be emphasized by the SeriesRenderer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsEmphasized (
int index
)

Visual Basic [image] Copy Code

Public Function IsEmphasized( _
index As Integer _
) As Boolean

Parameters

index

An integer value specifying the index of a data item.

Return Value

true to emphasize the specified data item, or false otherwise.

See Also

SimpleSeries Members
SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries.IsSorted Method

SimpleSeries.IsSorted Method
[image]

Implements Series.IsSorted. SimpleSeries always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsSorted (
int dimension
)

Visual Basic [image] Copy Code

Public Function IsSorted( _
dimension As Integer _
) As Boolean

Parameters

dimension

An integer value identifying the dimension.

Return Value

true if the values are sorted in specified dimension, or false otherwise.

See Also

SimpleSeries Members
SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries.OnDataChanged Method

SimpleSeries.OnDataChanged Method
[image]

Raises the DataChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void OnDataChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnDataChanged ()

See Also

SimpleSeries Members
SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries Properties

SimpleSeries Properties
[image]

Public Properties

Name | Description
Data | Gets or sets the data values contained in this series.
Dimensions | Implements Series.Dimensions. Returns 1.
Size | Implements Series.Size. Returns the number of elements in Data list.
SupportedLabels | Implements Series.SupportedLabels. Returns LabelKinds.InnerLabel.
Title | Implements Series.Title. Gets or sets the title of this series.

See Also

SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries.Data Property

SimpleSeries.Data Property
[image]

Gets or sets the data values contained in this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<Double> Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As IList(Of Double)

Property Value

See Also

SimpleSeries Members
SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries.Dimensions Property

SimpleSeries.Dimensions Property
[image]

Implements Series.Dimensions. Returns 1.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Dimensions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dimensions As Integer

Property Value

See Also

SimpleSeries Members
SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries.Size Property

SimpleSeries.Size Property
[image]

Implements Series.Size. Returns the number of elements in Data list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Size { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Size As Integer

Property Value

See Also

SimpleSeries Members
SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries.SupportedLabels Property

SimpleSeries.SupportedLabels Property
[image]

Implements Series.SupportedLabels. Returns LabelKinds.InnerLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public virtual LabelKinds SupportedLabels { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property SupportedLabels As LabelKinds

Property Value

See Also

SimpleSeries Members
SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries.Title Property

SimpleSeries.Title Property
[image]

Implements Series.Title. Gets or sets the title of this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

SimpleSeries Members
SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries Events

SimpleSeries Events
[image]

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.SimpleSeries.DataChanged Event

SimpleSeries.DataChanged Event
[image]

Implements Series.DataChanged. Raised when the values in this series change.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

See Also

SimpleSeries Members
SimpleSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StackRenderer Class

StackRenderer Class
[image]

A base SeriesRenderer for stacked graphics.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class StackRenderer : Renderer2D

Visual Basic [image] Copy Code

Public Class StackRenderer
Inherits Renderer2D

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.StackRenderer
MindFusion.Charting.AreaStackRenderer
MindFusion.Charting.BarStackRenderer
MindFusion.Charting.CurveAreaStackRenderer

See Also

StackRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.StackRenderer Members

StackRenderer Members
Constructors Properties Methods Events
[image]

A base SeriesRenderer for stacked graphics.

The following tables list the members exposed by the StackRenderer type.

Public Constructors

Name | Description
StackRenderer | Initializes a new instance of the StackRenderer class.

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the stack representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | Draws the series data in specified RenderContext. (Inherited from SeriesRenderer.)
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
EnumVisibleStackPoints | Enumerates the data values of rendered series mapped to plot 2D coordinates.
EnumVisibleStackRanges | Enumerates each series once providing a list of all visible points at each iteration.
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Gets the coordinates of specified data item when mapped to a Plot2D pixel.
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

StackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StackRenderer Constructor

StackRenderer Constructor
[image]

Initializes a new instance of the StackRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public StackRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

See Also

StackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StackRenderer Methods

StackRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | Renderer2D.HitTest override. Hit-tests the stack representations of data items.
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | Draws the series data in specified RenderContext. (Inherited from SeriesRenderer.)
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
EnumVisibleStackPoints | Enumerates the data values of rendered series mapped to plot 2D coordinates.
EnumVisibleStackRanges | Enumerates each series once providing a list of all visible points at each iteration.
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Gets the coordinates of specified data item when mapped to a Plot2D pixel.
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

StackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StackRenderer.EnumVisibleStackPoints Method

StackRenderer.EnumVisibleStackPoints Method
[image]

Enumerates the data values of rendered series mapped to plot 2D coordinates.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void EnumVisibleStackPoints (
RenderContext context,
StackRenderer.ProcessStackPoint process
)

Visual Basic [image] Copy Code

Protected Sub EnumVisibleStackPoints( _
context As RenderContext, _
process As StackRenderer.ProcessStackPoint _
)

Parameters

context

A RenderContext instance.

process

A ProcessStackPoint callback.

See Also

StackRenderer Members
StackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StackRenderer.EnumVisibleStackRanges Method

StackRenderer.EnumVisibleStackRanges Method
[image]

Enumerates each series once providing a list of all visible points at each iteration.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected void EnumVisibleStackRanges (
RenderContext context,
StackRenderer.ProcessStackRange process
)

Visual Basic [image] Copy Code

Protected Sub EnumVisibleStackRanges( _
context As RenderContext, _
process As StackRenderer.ProcessStackRange _
)

Parameters

context

A RenderContext instance.

process

A ProcessStackRange callback.

See Also

StackRenderer Members
StackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StackRenderer.GetPixel Method

StackRenderer.GetPixel Method
[image]

Gets the coordinates of specified data item when mapped to a Plot2D pixel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected new PointF GetPixel (
int seriesIndex,
int dataIndex,
Axis xAxis,
Axis yAxis,
Component component
)

Visual Basic [image] Copy Code

Protected Shadows Function GetPixel( _
seriesIndex As Integer, _
dataIndex As Integer, _
xAxis As Axis, _
yAxis As Axis, _
component As Component _
) As PointF

Parameters

seriesIndex

An integer index of a Series within the list of series rendered by this Renderer2D.

dataIndex

An integer index of the data item in specified series.

xAxis

An Axis reference specifying the X axis.

yAxis

An Axis reference specifying the Y axis.

component

An instance of Plot2D or derived class.

Return Value

A PointF containing Plot2D coordinates corresponding to specified data item.

See Also

StackRenderer Members
StackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StackRenderer.HitTest Method

StackRenderer.HitTest Method
[image]

Renderer2D.HitTest override. Hit-tests the stack representations of data items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override HitResult HitTest (
RenderContext context,
PointD location
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
context As RenderContext, _
location As PointD _
) As HitResult

Parameters

context

A RenderContext instance.

location

A PointD specifying where to look for a data point.

Return Value

A HitResult instance identifying the found data item.

See Also

StackRenderer Members
StackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StackRenderer.MeasureDataRange Method

StackRenderer.MeasureDataRange Method
[image]

Renderer2D.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void MeasureDataRange (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub MeasureDataRange( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

StackRenderer Members
StackRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StackRenderer.ProcessStackPoint Delegate

StackRenderer.ProcessStackPoint Delegate
[image]

Defines the signature of delegates called to process a data point one element at a time.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected delegate void StackRenderer.ProcessStackPoint (
int seriesIndex,
int dataIndex,
PointF stackPoint,
Nullable<PointF> prevPoint
)

Visual Basic [image] Copy Code

Protected Delegate Sub StackRenderer.ProcessStackPoint( _
seriesIndex As Integer, _
dataIndex As Integer, _
stackPoint As PointF, _
prevPoint As Nullable(Of PointF) _
)

Parameters

seriesIndex

An integer index of series in Series list.

dataIndex

An integer index of data item in specified series.

stackPoint

A PointF instance containing the Plot2D coordinates corresponding to current data item.

prevPoint

A PointF instance containing the Plot2D coordinates corresponding to previous data item.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.StackRenderer.ProcessStackRange Delegate

StackRenderer.ProcessStackRange Delegate
[image]

Defines the signature of delegates called to process all points from current data range at once.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected delegate void StackRenderer.ProcessStackRange (
int seriesIndex,
List<PointF> points,
List<PointF> prevPoints
)

Visual Basic [image] Copy Code

Protected Delegate Sub StackRenderer.ProcessStackRange( _
seriesIndex As Integer, _
points As List(Of PointF), _
prevPoints As List(Of PointF) _
)

Parameters

seriesIndex

An integer index of series in Series list.

points

A list of PointF values containing the Plot2D coordinates corresponding to data items in currently visible range.

prevPoints

A list of PointF values containing the Plot2D coordinates corresponding to previous series in currently visible range.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.StepAreaRenderer Class

StepAreaRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws series as filled steps between data points.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class StepAreaRenderer : Renderer2D

Visual Basic [image] Copy Code

Public Class StepAreaRenderer
Inherits Renderer2D

Remarks

StepAreaRenderer must be placed inside a Plot2D component. It draws the values of each series as a filled step polygon. If the GetLabel method of Series object returns InnerLabel or OuterLabel strings, they are rendered near the polygon vertex corresponding to respective data item.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.StepAreaRenderer

See Also

StepAreaRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.StepAreaRenderer Members

StepAreaRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws series as filled steps between data points.

The following tables list the members exposed by the StepAreaRenderer type.

Public Constructors

Name | Description
StepAreaRenderer | Initializes a new instance of the StepAreaRenderer class.

Public Properties

Name | Description
AreaOpacity | Gets or sets the opacity of radar polygons.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

StepAreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StepAreaRenderer Constructor

StepAreaRenderer Constructor
[image]

Initializes a new instance of the StepAreaRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public StepAreaRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered by this object.

See Also

StepAreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StepAreaRenderer Methods

StepAreaRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

StepAreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StepAreaRenderer.Draw Method

StepAreaRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

StepAreaRenderer Members
StepAreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StepAreaRenderer Properties

StepAreaRenderer Properties
[image]

Public Properties

Name | Description
AreaOpacity | Gets or sets the opacity of radar polygons.
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

See Also

StepAreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StepAreaRenderer.AreaOpacity Property

StepAreaRenderer.AreaOpacity Property
[image]

Gets or sets the opacity of radar polygons.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double AreaOpacity { get; set; }

Visual Basic [image] Copy Code

Public Property AreaOpacity As Double

Property Value

See Also

StepAreaRenderer Members
StepAreaRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StepRenderer Class

StepRenderer Class
Remarks See Also
[image]

A SeriesRenderer that draws series as steps between data points.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class StepRenderer : Renderer2D

Visual Basic [image] Copy Code

Public Class StepRenderer
Inherits Renderer2D

Remarks

StepRenderer must be placed inside a Plot2D component. It connects adjacent data points in series with step-like line segments. If the GetLabel method of Series object returns InnerLabel or OuterLabel strings, they are rendered near the polyline point corresponding to respective data item.

Inheritance Hierarchy

System.Object
MindFusion.Charting.SeriesRenderer
MindFusion.Charting.Renderer2D
MindFusion.Charting.StepRenderer

See Also

StepRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.StepRenderer Members

StepRenderer Members
Constructors Properties Methods Events
[image]

A SeriesRenderer that draws series as steps between data points.

The following tables list the members exposed by the StepRenderer type.

Public Constructors

Name | Description
StepRenderer | Initializes a new instance of the StepRenderer class.

Public Properties

Name | Description
LabelBrush | Gets or sets the Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
Series | Gets or sets a list of Series drawn by this Renderer2D. (Inherited from Renderer2D.)
SeriesStyle | A SeriesStyle instance specifying the appearance of series associated with this renderer. (Inherited from SeriesRenderer.)
ShowDataLabels | Gets or sets the kind of data labels to draw. (Inherited from SeriesRenderer.)
XAxis | Gets the X axis associated with this Renderer2D. (Inherited from Renderer2D.)
YAxis | Gets the Y axis associated with this Renderer2D. (Inherited from Renderer2D.)

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged interface. (Inherited from SeriesRenderer.)

See Also

StepRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StepRenderer Constructor

StepRenderer Constructor
[image]

Initializes a new instance of the StepRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public StepRenderer (
ObservableCollection<Series> series
)

Visual Basic [image] Copy Code

Public New ( _
series As ObservableCollection(Of Series) _
)

Parameters

series

A list of Series that should be rendered by this object.

See Also

StepRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StepRenderer Methods

StepRenderer Methods
[image]

Public Methods

Name | Description
DomainDimension | Implements the SeriesContainer interface. Gets the index of the dimension whose set of values should be treated as domain of plotted function. (Inherited from SeriesRenderer.)
EffectiveFill | Gets the brush that should be used to fill the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStroke | Gets the brush that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokeThickness | Gets the thickness of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumSeries | Implements the SeriesContainer interface. (Inherited from Renderer2D.)
HitTest | SeriesRenderer.HitTest override. Hit-tests the visual representation of the series for a data item. (Inherited from Renderer2D.)
SearchStyle | Returns a SeriesStyle object that meets specified criteria. (Inherited from SeriesRenderer.)
StartMeasureData | SeriesRenderer.StartMeasureData override. Called to reset measure accumulators at the beginning of a measure pass. (Inherited from Renderer2D.)

Protected Methods

Name | Description
AdjustDataRange | Adjusts the data range of associated Axis objects after initial measure pass. (Inherited from SeriesRenderer.)
DomainData | Gets the domain axis coordinate (input value) of specified data item. (Inherited from Renderer2D.)
Draw | SeriesRenderer.Draw override. Draws the series data in specified RenderContext.
DrawHighlight | SeriesRenderer.DrawHighlight override. Draws highlighted data item in specified RenderContext. (Inherited from Renderer2D.)
EffectiveLabelBrush | Gets the System.Drawing.Brush that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw labels of data items. (Inherited from SeriesRenderer.)
EffectiveStrokeDashStyle | Gets the dash style of the pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EffectiveStrokePen | Gets the Pen that should be used to stroke the representation of specified data item. (Inherited from SeriesRenderer.)
EnumVisiblePointPairs | Enumerates the data values of rendered series mapped to plot 2D coordinates. (Inherited from Renderer2D.)
EnumVisiblePoints | Overloaded. (Inherited from Renderer2D.)
EnumVisibleRanges | Enumerates each series once providing a list of all visible points at each iteration. (Inherited from Renderer2D.)
GetFirstInRange | Overloaded. (Inherited from Renderer2D.)
GetLastInRange | Overloaded. (Inherited from Renderer2D.)
GetMaxXSum | Gets the maximum sum of X data values locates at same index in all series. (Inherited from Renderer2D.)
GetMaxYSum | Gets the maximum sum of Y data values locates at same index in all series. (Inherited from Renderer2D.)
GetPixel | Overloaded. (Inherited from Renderer2D.)
ImageData | Gets the image axis coordinate (output value) of specified data item. (Inherited from Renderer2D.)
MeasureDataRange | SeriesRenderer.MeasureDataRange override. Measures the data range of rendered series and assigns it to the associated Axis objects if their MinValue and MaxValue are not set. (Inherited from Renderer2D.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from SeriesRenderer.)
OnSeriesDataChanged | Called when Series raise their DataChanged event. (Inherited from SeriesRenderer.)
SetToolTip | Sets tooltip text and lcoation. (Inherited from SeriesRenderer.)
Subscribe | Subscribes to the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
Unsubscribe | Unsubscribes from the DataChanged event of specified Series. (Inherited from SeriesRenderer.)
XData | Gets the X value of specified data item. (Inherited from Renderer2D.)
XSorted | Gets a value indicating whether values of specified series increase monotonously in X dimension. (Inherited from Renderer2D.)
YData | Gets the Y value of specified data item. (Inherited from Renderer2D.)
YSorted | Gets a value indicating whether values of specified series increase monotonously in Y dimension. (Inherited from Renderer2D.)

See Also

StepRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StepRenderer.Draw Method

StepRenderer.Draw Method
[image]

SeriesRenderer.Draw override. Draws the series data in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

StepRenderer Members
StepRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPrice Class

StockPrice Class
[image]

Represents a data object, containing open, close, low and high values for a certain date.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class StockPrice

Visual Basic [image] Copy Code

Public Class StockPrice

Inheritance Hierarchy

System.Object
MindFusion.Charting.StockPrice

See Also

StockPrice Members
MindFusion.Charting Namespace


MindFusion.Charting.StockPrice Members

StockPrice Members
Constructors Properties
[image]

Represents a data object, containing open, close, low and high values for a certain date.

The following tables list the members exposed by the StockPrice type.

Public Constructors

Name | Description
StockPrice | Overloaded.

Public Properties

Name | Description
Close | Gets or sets the close value.
Date | Gets or sets the date.
High | Gets or sets the high value.
Low | Gets or sets the low value.
Open | Gets or sets the open value.

See Also

StockPrice Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPrice Constructor

StockPrice Constructor
[image]

Overload List

Name | Description
StockPrice (Double, Double, Double, Double) | Initializes a new instance of the StockPrice class.
StockPrice (Double, Double, Double, Double, DateTime) | Initializes a new instance of the StockPrice class.

See Also

StockPrice Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPrice Constructor (Double, Double, Double, Double)

StockPrice Constructor (Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the StockPrice class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public StockPrice (
double open,
double close,
double low,
double high
)

Visual Basic [image] Copy Code

Public New ( _
open As Double, _
close As Double, _
low As Double, _
high As Double _
)

Parameters

open

The open value.

close

The close value.

low

The low value.

high

The high value.

See Also

StockPrice Constructor Overload List
StockPrice Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPrice Constructor (Double, Double, Double, Double, DateTime)

StockPrice Constructor (Double, Double, Double, Double, DateTime)
See Also
[image]

Initializes a new instance of the StockPrice class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public StockPrice (
double open,
double close,
double low,
double high,
DateTime date
)

Visual Basic [image] Copy Code

Public New ( _
open As Double, _
close As Double, _
low As Double, _
high As Double, _
date As DateTime _
)

Parameters

open

The open value.

close

The close value.

low

The low value.

high

The high value.

date

The corresponding date.

See Also

StockPrice Constructor Overload List
StockPrice Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPrice Properties

StockPrice Properties
[image]

Public Properties

Name | Description
Close | Gets or sets the close value.
Date | Gets or sets the date.
High | Gets or sets the high value.
Low | Gets or sets the low value.
Open | Gets or sets the open value.

See Also

StockPrice Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPrice.Close Property

StockPrice.Close Property
[image]

Gets or sets the close value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Close { get; set; }

Visual Basic [image] Copy Code

Public Property Close As Double

Property Value

See Also

StockPrice Members
StockPrice Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPrice.Date Property

StockPrice.Date Property
[image]

Gets or sets the date.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public DateTime Date { get; set; }

Visual Basic [image] Copy Code

Public Property Date As DateTime

Property Value

See Also

StockPrice Members
StockPrice Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPrice.High Property

StockPrice.High Property
[image]

Gets or sets the high value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double High { get; set; }

Visual Basic [image] Copy Code

Public Property High As Double

Property Value

See Also

StockPrice Members
StockPrice Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPrice.Low Property

StockPrice.Low Property
[image]

Gets or sets the low value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Low { get; set; }

Visual Basic [image] Copy Code

Public Property Low As Double

Property Value

See Also

StockPrice Members
StockPrice Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPrice.Open Property

StockPrice.Open Property
[image]

Gets or sets the open value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Open { get; set; }

Visual Basic [image] Copy Code

Public Property Open As Double

Property Value

See Also

StockPrice Members
StockPrice Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries Class

StockPriceSeries Class
Remarks See Also
[image]

Represents a data series defined by a list of StockPrice objects.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class StockPriceSeries : Series

Visual Basic [image] Copy Code

Public Class StockPriceSeries
Implements Series

Remarks

This is a convenience class that can be used to provide data to CandleStickRenderer and CandleStickChart objects.

Inheritance Hierarchy

System.Object
MindFusion.Charting.StockPriceSeries

See Also

StockPriceSeries Members
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries Members

StockPriceSeries Members
Constructors Properties Methods Events
[image]

Represents a data series defined by a list of StockPrice objects.

The following tables list the members exposed by the StockPriceSeries type.

Public Constructors

Name | Description
StockPriceSeries | Initializes a new instance of the StockPriceSeries class.

Public Properties

Name | Description
CustomDateTimeFormat | Gets or sets a custom format string for DateTime labels.
DateTimeFormat | Gets or sets a value indicating how to format DateTime values as labels.
Dimensions | Implements Series.Dimensions. Returns 5.
LabelPrefix | Gets or sets a prefix added in front of formatted DateTime labels.
LabelSuffix | Gets or sets a suffix appended to formatted DateTime labels.
Size | Implements Series.Size. Returns the number of elements in Values list.
SupportedLabels | Implements Series.SupportedLabels. Returns InnerLabel.
Title | Implements Series.Title. Gets or sets the title of this series.
Values | Gets or sets the series' points.

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns DateTime value at specified index as an XAxisLabel.
GetValue | Implements Series.GetValue. Returns a coordinate of specified point in this series.
IsEmphasized | Implements Series.IsEmphasized. StockPriceSeries always returns false.
IsSorted | Implements Series.IsSorted. StockPriceSeries always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries Constructor

StockPriceSeries Constructor
[image]

Initializes a new instance of the StockPriceSeries class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public StockPriceSeries (
IList<StockPrice> values
)

Visual Basic [image] Copy Code

Public New ( _
values As IList(Of StockPrice) _
)

Parameters

values

A list of StockPrice objects.

See Also

StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries Methods

StockPriceSeries Methods
[image]

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns DateTime value at specified index as an XAxisLabel.
GetValue | Implements Series.GetValue. Returns a coordinate of specified point in this series.
IsEmphasized | Implements Series.IsEmphasized. StockPriceSeries always returns false.
IsSorted | Implements Series.IsSorted. StockPriceSeries always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

See Also

StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.GetLabel Method

StockPriceSeries.GetLabel Method
[image]

Implements Series.GetLabel. Returns DateTime value at specified index as an XAxisLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string GetLabel (
int index,
LabelKinds kind
)

Visual Basic [image] Copy Code

Public Function GetLabel( _
index As Integer, _
kind As LabelKinds _
) As String

Parameters

index

An integer value specifying the index of a data item.

kind

A member of the LabelKinds enumeration.

Return Value

A string containing the item's label.

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.GetValue Method

StockPriceSeries.GetValue Method
[image]

Implements Series.GetValue. Returns a coordinate of specified point in this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GetValue (
int index,
int dimension
)

Visual Basic [image] Copy Code

Public Function GetValue( _
index As Integer, _
dimension As Integer _
) As Double

Parameters

index

An integer value specifying the index of a data item.

dimension

An integer value specifying the dimension whose coordinate to return.

Return Value

A double-precision number representing the value of a data item in the series.

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.IsEmphasized Method

StockPriceSeries.IsEmphasized Method
[image]

Implements Series.IsEmphasized. StockPriceSeries always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsEmphasized (
int index
)

Visual Basic [image] Copy Code

Public Function IsEmphasized( _
index As Integer _
) As Boolean

Parameters

index

An integer value specifying the index of a data item.

Return Value

true to emphasize the specified data item, or false otherwise.

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.IsSorted Method

StockPriceSeries.IsSorted Method
[image]

Implements Series.IsSorted. StockPriceSeries always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsSorted (
int dimension
)

Visual Basic [image] Copy Code

Public Function IsSorted( _
dimension As Integer _
) As Boolean

Parameters

dimension

An integer value identifying the dimension.

Return Value

true if the values are sorted in specified dimension, or false otherwise.

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.OnDataChanged Method

StockPriceSeries.OnDataChanged Method
[image]

Raises the DataChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void OnDataChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnDataChanged ()

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries Properties

StockPriceSeries Properties
[image]

Public Properties

Name | Description
CustomDateTimeFormat | Gets or sets a custom format string for DateTime labels.
DateTimeFormat | Gets or sets a value indicating how to format DateTime values as labels.
Dimensions | Implements Series.Dimensions. Returns 5.
LabelPrefix | Gets or sets a prefix added in front of formatted DateTime labels.
LabelSuffix | Gets or sets a suffix appended to formatted DateTime labels.
Size | Implements Series.Size. Returns the number of elements in Values list.
SupportedLabels | Implements Series.SupportedLabels. Returns InnerLabel.
Title | Implements Series.Title. Gets or sets the title of this series.
Values | Gets or sets the series' points.

See Also

StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.CustomDateTimeFormat Property

StockPriceSeries.CustomDateTimeFormat Property
[image]

Gets or sets a custom format string for DateTime labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string CustomDateTimeFormat { get; set; }

Visual Basic [image] Copy Code

Public Property CustomDateTimeFormat As String

Property Value

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.DateTimeFormat Property

StockPriceSeries.DateTimeFormat Property
[image]

Gets or sets a value indicating how to format DateTime values as labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public DateTimeFormat DateTimeFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DateTimeFormat As DateTimeFormat

Property Value

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.Dimensions Property

StockPriceSeries.Dimensions Property
[image]

Implements Series.Dimensions. Returns 5.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Dimensions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dimensions As Integer

Property Value

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.LabelPrefix Property

StockPriceSeries.LabelPrefix Property
[image]

Gets or sets a prefix added in front of formatted DateTime labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string LabelPrefix { get; set; }

Visual Basic [image] Copy Code

Public Property LabelPrefix As String

Property Value

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.LabelSuffix Property

StockPriceSeries.LabelSuffix Property
[image]

Gets or sets a suffix appended to formatted DateTime labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string LabelSuffix { get; set; }

Visual Basic [image] Copy Code

Public Property LabelSuffix As String

Property Value

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.Size Property

StockPriceSeries.Size Property
[image]

Implements Series.Size. Returns the number of elements in Values list.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Size { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Size As Integer

Property Value

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.SupportedLabels Property

StockPriceSeries.SupportedLabels Property
[image]

Implements Series.SupportedLabels. Returns InnerLabel.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public LabelKinds SupportedLabels { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SupportedLabels As LabelKinds

Property Value

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.Title Property

StockPriceSeries.Title Property
[image]

Implements Series.Title. Gets or sets the title of this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.Values Property

StockPriceSeries.Values Property
[image]

Gets or sets the series' points.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public IList<StockPrice> Values { get; set; }

Visual Basic [image] Copy Code

Public Property Values As IList(Of StockPrice)

Property Value

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries Events

StockPriceSeries Events
[image]

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.StockPriceSeries.DataChanged Event

StockPriceSeries.DataChanged Event
[image]

Implements Series.DataChanged. Raised when the values in this series change.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

See Also

StockPriceSeries Members
StockPriceSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer Class

TextRenderer Class
[image]

Draws text and labels inside chart components.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class TextRenderer : IDisposable

Visual Basic [image] Copy Code

Public Class TextRenderer
Implements IDisposable

Inheritance Hierarchy

System.Object
MindFusion.Charting.TextRenderer

See Also

TextRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer Members

TextRenderer Members
Constructors Properties Methods
[image]

Draws text and labels inside chart components.

The following tables list the members exposed by the TextRenderer type.

Public Constructors

Name | Description
TextRenderer | Initializes a new instance of the TextRenderer class.

Public Properties

Name | Description
LabelFont | Gets or sets the Font used to draw labels.
TextBrush | Gets or sets the System.Drawing.Brush used to draw labels.

Public Methods

Name | Description
Dispose | Disposes the font and brush associated with this object.
DrawLabelAtPoint | Draws the specified label centered at specified location.
DrawLabelInRect | Draws the specified label in specified layout rectangle.
DrawRightFromPoint | Draws the specified label on the right side of specified point.
DrawRotatedLabelInRect | Overloaded.

See Also

TextRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer Constructor

TextRenderer Constructor
[image]

Initializes a new instance of the TextRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public TextRenderer (
RenderContext context,
Font font,
Brush textBrush
)

Visual Basic [image] Copy Code

Public New ( _
context As RenderContext, _
font As Font, _
textBrush As Brush _
)

Parameters

context

A RenderContext instance.

font

A System.Drawing.Font instance.

textBrush

A System.Drawing.Brush instance.

See Also

TextRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer Methods

TextRenderer Methods
[image]

Public Methods

Name | Description
Dispose | Disposes the font and brush associated with this object.
DrawLabelAtPoint | Draws the specified label centered at specified location.
DrawLabelInRect | Draws the specified label in specified layout rectangle.
DrawRightFromPoint | Draws the specified label on the right side of specified point.
DrawRotatedLabelInRect | Overloaded.

See Also

TextRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer.Dispose Method

TextRenderer.Dispose Method
[image]

Disposes the font and brush associated with this object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void Dispose ()

Visual Basic [image] Copy Code

Public Sub Dispose ()

See Also

TextRenderer Members
TextRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer.DrawLabelAtPoint Method

TextRenderer.DrawLabelAtPoint Method
[image]

Draws the specified label centered at specified location.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void DrawLabelAtPoint (
Series series,
int index,
PointF point,
LabelKinds labelKind
)

Visual Basic [image] Copy Code

Public Sub DrawLabelAtPoint( _
series As Series, _
index As Integer, _
point As PointF, _
labelKind As LabelKinds _
)

Parameters

series

A Series whose label to draw.

index

An integer index of the label.

point

A PointF specifying the label's location.

labelKind

A member of the LabelKinds enumeration.

See Also

TextRenderer Members
TextRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer.DrawLabelInRect Method

TextRenderer.DrawLabelInRect Method
[image]

Draws the specified label in specified layout rectangle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void DrawLabelInRect (
Series series,
int index,
RectangleF bounds,
LabelKinds labelKind
)

Visual Basic [image] Copy Code

Public Sub DrawLabelInRect( _
series As Series, _
index As Integer, _
bounds As RectangleF, _
labelKind As LabelKinds _
)

Parameters

series

A Series whose label to draw.

index

An integer index of the label.

bounds

A RectangleF specifying the layout rectangle.

labelKind

A member of the LabelKinds enumeration.

See Also

TextRenderer Members
TextRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer.DrawRightFromPoint Method

TextRenderer.DrawRightFromPoint Method
[image]

Draws the specified label on the right side of specified point.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void DrawRightFromPoint (
Series series,
int index,
PointF point,
LabelKinds labelKind
)

Visual Basic [image] Copy Code

Public Sub DrawRightFromPoint( _
series As Series, _
index As Integer, _
point As PointF, _
labelKind As LabelKinds _
)

Parameters

series

A Series whose label to draw.

index

An integer index of the label.

point

A PointF specifying the label's location.

labelKind

A member of the LabelKinds enumeration.

See Also

TextRenderer Members
TextRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer.DrawRotatedLabelInRect Method

TextRenderer.DrawRotatedLabelInRect Method
[image]

Overload List

Name | Description
TextRenderer.DrawRotatedLabelInRect (Series, Int32, RectangleF, LabelKinds) | Draws the specified label rotated at 90 degrees in specified layout rectangle.
TextRenderer.DrawRotatedLabelInRect (String, RectangleF, Brush, StringAlignment) | Draws a 90-degree rotated text in specified layout rectangle.

See Also

TextRenderer Members
TextRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer.DrawRotatedLabelInRect Method (Series, Int32, RectangleF, LabelKinds)

TextRenderer.DrawRotatedLabelInRect Method (Series, Int32, RectangleF, LabelKinds)
See Also
[image]

Draws the specified label rotated at 90 degrees in specified layout rectangle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void DrawRotatedLabelInRect (
Series series,
int index,
RectangleF bounds,
LabelKinds labelKind
)

Visual Basic [image] Copy Code

Public Sub DrawRotatedLabelInRect( _
series As Series, _
index As Integer, _
bounds As RectangleF, _
labelKind As LabelKinds _
)

Parameters

series

A Series whose label to draw.

index

An integer index of the label.

bounds

A RectangleF specifying the layout rectangle.

labelKind

A member of the LabelKinds enumeration.

See Also

DrawRotatedLabelInRect Method Overload List
TextRenderer Members
TextRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer.DrawRotatedLabelInRect Method (String, RectangleF, Brush, StringAlignment)

TextRenderer.DrawRotatedLabelInRect Method (String, RectangleF, Brush, StringAlignment)
See Also
[image]

Draws a 90-degree rotated text in specified layout rectangle.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void DrawRotatedLabelInRect (
string text,
RectangleF bounds,
Brush textBrush,
StringAlignment alignment
)

Visual Basic [image] Copy Code

Public Sub DrawRotatedLabelInRect( _
text As String, _
bounds As RectangleF, _
textBrush As Brush, _
alignment As StringAlignment _
)

Parameters

text

A string containing the text to draw.

bounds

A RectangleF specifying the layout rectangle.

textBrush

A System.Drawing.Brush instance.

alignment

A member of the StringAlignment enumeration.

See Also

DrawRotatedLabelInRect Method Overload List
TextRenderer Members
TextRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer Properties

TextRenderer Properties
[image]

Public Properties

Name | Description
LabelFont | Gets or sets the Font used to draw labels.
TextBrush | Gets or sets the System.Drawing.Brush used to draw labels.

See Also

TextRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer.LabelFont Property

TextRenderer.LabelFont Property
[image]

Gets or sets the Font used to draw labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Font LabelFont { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFont As Font

Property Value

See Also

TextRenderer Members
TextRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.TextRenderer.TextBrush Property

TextRenderer.TextBrush Property
[image]

Gets or sets the System.Drawing.Brush used to draw labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

See Also

TextRenderer Members
TextRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.TextStyle Class

TextStyle Class
[image]

Defines text appearance attributes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class TextStyle

Visual Basic [image] Copy Code

Public Class TextStyle

Inheritance Hierarchy

System.Object
MindFusion.Charting.TextStyle

See Also

TextStyle Members
MindFusion.Charting Namespace


MindFusion.Charting.TextStyle Members

TextStyle Members
Constructors Properties
[image]

Defines text appearance attributes.

The following tables list the members exposed by the TextStyle type.

Public Constructors

Name | Description
TextStyle | Initializes a new instance of the TextStyle class.

Public Properties

Name | Description
FontName | Gets or sets font name.
FontSize | Gets or sets font size.
FontStyle | Gets or sets font style.
TextBrush | Gets or sets a Brush used to draw text.

See Also

TextStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.TextStyle Constructor

TextStyle Constructor
[image]

Initializes a new instance of the TextStyle class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public TextStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TextStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.TextStyle Properties

TextStyle Properties
[image]

Public Properties

Name | Description
FontName | Gets or sets font name.
FontSize | Gets or sets font size.
FontStyle | Gets or sets font style.
TextBrush | Gets or sets a Brush used to draw text.

See Also

TextStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.TextStyle.FontName Property

TextStyle.FontName Property
[image]

Gets or sets font name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string FontName { get; set; }

Visual Basic [image] Copy Code

Public Property FontName As String

Property Value

See Also

TextStyle Members
TextStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.TextStyle.FontSize Property

TextStyle.FontSize Property
[image]

Gets or sets font size.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Nullable(Of Double)

Property Value

See Also

TextStyle Members
TextStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.TextStyle.FontStyle Property

TextStyle.FontStyle Property
[image]

Gets or sets font style.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<FontStyle> FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As Nullable(Of FontStyle)

Property Value

See Also

TextStyle Members
TextStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.TextStyle.TextBrush Property

TextStyle.TextBrush Property
[image]

Gets or sets a Brush used to draw text.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

See Also

TextStyle Members
TextStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.TextStyleHint Enumeration

TextStyleHint Enumeration
[image]

Identifies text styles that can be accessed through RenderContent.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public enum TextStyleHint

Visual Basic [image] Copy Code

Public Enum TextStyleHint

Members

Member name | Description
AxisLabels | Identifies style used to draw axis labels.
AxisTitle | Identifies style used to draw axis title.
DataLabels | Identifies style used to draw data labels.
LegendTitle | Identifies style used to draw legend title.
Subtitle | Identifies style used to draw chart's sub-title.
Title | Identifies style used to draw chart's title.
Widget | Identifies style used to draw text in UI widgets.

See Also

MindFusion.Charting Namespace


MindFusion.Charting.Theme Class

Theme Class
[image]

Represents a dashboard's theme defining all appearance attributes of its elements.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class Theme : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class Theme
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.Charting.Theme

See Also

Theme Members
MindFusion.Charting Namespace


MindFusion.Charting.Theme Members

Theme Members
Constructors Properties Methods Events
[image]

Represents a dashboard's theme defining all appearance attributes of its elements.

The following tables list the members exposed by the Theme type.

Public Constructors

Name | Description
Theme | Overloaded.

Public Properties

Name | Description
AxisLabelsBrush | Gets or sets the Brush used to draw axis labels.
AxisLabelsFontName | Gets or sets the name of font used to draw axis labels.
AxisLabelsFontSize | Gets or sets the size of font used to draw axis labels.
AxisLabelsFontStyle | Gets or sets the style of font used to draw axis labels.
AxisStroke | Gets or sets a Brush used to stroke axis lines.
AxisStrokeDashStyle | Gets or sets the dash style of axis lines.
AxisStrokeThickness | Gets or sets the thickness of axis lines.
AxisTitleBrush | Gets or sets the Brush used to draw axis titles.
AxisTitleFontName | Gets or sets the name of font used to draw axis titles.
AxisTitleFontSize | Gets or sets the size of font used to draw axis titles.
AxisTitleFontStyle | Gets or sets the style of font used to draw axis titles.
CommonSeriesFills | Gets or sets a list of brushes, each Brush used to fill all elements of a series.
CommonSeriesStrokeDashStyles | Gets or sets a list of dash styles, each style applied to all elements of a series.
CommonSeriesStrokes | Gets or sets a list of brushes, each Brush used to stroke all elements of a series.
CommonSeriesStrokeThicknesses | Gets or sets a list of stroke thicknesses, each thickness applied to all elements of a series.
DataLabelsBrush | Gets or sets the Brush used to draw data labels.
DataLabelsFontName | Gets or sets the name of font used to draw data labels.
DataLabelsFontSize | Gets or sets the size of font used to draw data labels.
DataLabelsFontStyle | Gets or sets the style of font used to draw data labels.
GaugeBackground | Gets or sets a Brush used to draw gauge backgrounds.
GaugeFontName | Gets or sets the name of font used to draw text in gauges.
GaugeFontSize | Gets or sets the size of font used to draw text in gauges.
GaugeFontStyle | Gets or sets the style of font used to draw text in gauges.
GaugePointerBackground | Gets or sets a Brush used to draw gauge pointer backgrounds.
GaugePointerStroke | Gets or sets a Brush used to stroke gauge pointers.
GaugePointerStrokeThickness | Gets or sets the thickness of gauge pointer strokes.
GaugeScaleBackground | Gets or sets a Brush used to draw the background of gauge scales.
GaugeScaleStroke | Gets or sets a Brush used to stroke gauge scales.
GaugeScaleStrokeThickness | Gets or sets the thickness of gauge scale strokes.
GaugeStroke | Gets or sets a Brush used to stroke gauge borders.
GaugeStrokeThickness | Gets or sets the thickness of gauge borders.
GaugeTickBackground | Gets or sets a Brush used to draw gauge tick backgrounds.
GaugeTickStroke | Gets or sets a Brush used to stroke gauge ticks.
GaugeTickStrokeThickness | Gets or sets the thickness of gauge tick strokes.
GridColor1 | Gets or sets the main color of plot grid.
GridColor2 | Gets or sets the alternating color of plot grid.
GridLineColor | Gets or sets the line color of plot grid.
GridLineStyle | Gets or sets the style of plot grid lines.
GridLineThickness | Gets or sets the thickness of plot grid lines.
HighlightStroke | Gets or sets a Brush used to stroke highlighted items.
HighlightStrokeDashStyle | Gets or sets the dash style of highlight strokes.
HighlightStrokeThickness | Gets or sets the thickness of highlight strokes.
LegendBackground | Gets or sets a Brush used to draw legend background.
LegendBorderStroke | Gets or sets a Brush used to draw legend borders.
LegendBorderStrokeDashStyle | Gets or sets the dash style of legend borders.
LegendBorderStrokeThickness | Gets or sets the thickness of legend borders.
LegendTitleBrush | Gets or sets the Brush used to draw legend titles.
LegendTitleFontName | Gets or sets the name of font used to draw legend titles.
LegendTitleFontSize | Gets or sets the size of font used to draw legend titles.
LegendTitleFontStyle | Gets or sets the style of font used to draw legend titles.
PlotBackground | Gets or sets a Brush used to draw the background of plots.
PlotBorderStroke | Gets or sets a Brush used to stroke plot borders.
PlotBorderStrokeDashStyle | Gets or sets the dash style of plot borders.
PlotBorderStrokeThickness | Gets or sets the thickness of plot borders.
SeriesFills | Gets or sets a list of Brush lists, each list used to draw a different series, and each Brush used to fill individual elements of a series.
SeriesStrokeDashStyles | Gets or sets a list of DashStyle lists, each list used to stroke a different series, and each DashStyle value specifying style of individual elements of a series.
SeriesStrokes | Gets or sets a list of Brush lists, each list used to stroke a different series, and each Brush used to stroke individual elements of a series.
SeriesStrokeThicknesses | Gets or sets a list of double lists, each list used to stroke a different series, and each double value specifying thickness of individual elements of a series.
SubtitleBrush | Gets or sets the Brush used to draw the chart sub-title.
SubtitleFontName | Gets or sets the name of font used to draw the chart sub-title.
SubtitleFontSize | Gets or sets the size of font used to draw the chart sub-title.
SubtitleFontStyle | Gets or sets the style of font used to draw the chart sub-title.
TitleBrush | Gets or sets the Brush used to draw the chart title.
TitleFontName | Gets or sets the name of font used to draw the chart title.
TitleFontSize | Gets or sets the size of font used to draw the chart title.
TitleFontStyle | Gets or sets the style of font used to draw the chart title.
UniformSeriesFill | Gets or sets a Brush used to fill all elements of all series uniformly.
UniformSeriesStroke | Gets or sets a Brush used to stroke all elements of all series uniformly.
UniformSeriesStrokeDashStyle | Gets or sets uniform stroke dash style for all elements of all series.
UniformSeriesStrokeThickness | Gets or sets uniform stroke thickness for all elements of all series.
WidgetBrush | Gets or sets the Brush used to draw text in UI widgets.
WidgetFontName | Gets or sets the name of font used to draw text in UI widgets.
WidgetFontSize | Gets or sets the size of font used to draw text in UI widgets.
WidgetFontStyle | Gets or sets the style of font used to draw text in UI widgets.

Public Methods

Name | Description
LoadFrom | Overloaded.
SaveTo | Overloaded.

Public Events

Name | Description
PropertyChanged | Implements INotifyPropertyChanged.

See Also

Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme Constructor

Theme Constructor
[image]

Overload List

Name | Description
Theme () | Initializes a new instance of the Theme class.
Theme (Brush, Brush, Double, DashStyle) | Initializes a new instance of the Theme class.

See Also

Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme Constructor ()

Theme Constructor ()
See Also
[image]

Initializes a new instance of the Theme class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Theme ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Theme Constructor Overload List
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme Constructor (Brush, Brush, Double, DashStyle)

Theme Constructor (Brush, Brush, Double, DashStyle)
See Also
[image]

Initializes a new instance of the Theme class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Theme (
Brush fill,
Brush stroke,
double strokeThickness,
DashStyle strokeDashStyle
)

Visual Basic [image] Copy Code

Public New ( _
fill As Brush, _
stroke As Brush, _
strokeThickness As Double, _
strokeDashStyle As DashStyle _
)

Parameters

fill

A Brush used to fill all series elements.

stroke

A Brush used to stroke all series elements.

strokeThickness

Uniform thickness of series elements' strokes.

strokeDashStyle

Uniform dash style of series elements' strokes.

See Also

Theme Constructor Overload List
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme Methods

Theme Methods
[image]

Public Methods

Name | Description
LoadFrom | Overloaded.
SaveTo | Overloaded.

See Also

Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.LoadFrom Method

Theme.LoadFrom Method
[image]

Overload List

Name | Description
Theme.LoadFrom (String) | Loads the theme values from specified file.
Theme.LoadFrom (XElement) | Loads the theme values from specified XML element.

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.LoadFrom Method (String)

Theme.LoadFrom Method (String)
See Also
[image]

Loads the theme values from specified file.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void LoadFrom (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
fileName As String _
)

Parameters

fileName

A string specifying the file name or path.

See Also

LoadFrom Method Overload List
Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.LoadFrom Method (XElement)

Theme.LoadFrom Method (XElement)
See Also
[image]

Loads the theme values from specified XML element.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void LoadFrom (
XElement element
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
element As XElement _
)

Parameters

element

An XElement instance.

See Also

LoadFrom Method Overload List
Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.SaveTo Method

Theme.SaveTo Method
[image]

Overload List

Name | Description
Theme.SaveTo (String) | Saves the theme values to specified file.
Theme.SaveTo (XElement) | Saves the theme values to specified XML element.

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.SaveTo Method (String)

Theme.SaveTo Method (String)
See Also
[image]

Saves the theme values to specified file.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void SaveTo (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
fileName As String _
)

Parameters

fileName

A string specifying the file name or path.

See Also

SaveTo Method Overload List
Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.SaveTo Method (XElement)

Theme.SaveTo Method (XElement)
See Also
[image]

Saves the theme values to specified XML element.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void SaveTo (
XElement element
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
element As XElement _
)

Parameters

element

An XElement instance.

See Also

SaveTo Method Overload List
Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme Properties

Theme Properties
[image]

Public Properties

Name | Description
AxisLabelsBrush | Gets or sets the Brush used to draw axis labels.
AxisLabelsFontName | Gets or sets the name of font used to draw axis labels.
AxisLabelsFontSize | Gets or sets the size of font used to draw axis labels.
AxisLabelsFontStyle | Gets or sets the style of font used to draw axis labels.
AxisStroke | Gets or sets a Brush used to stroke axis lines.
AxisStrokeDashStyle | Gets or sets the dash style of axis lines.
AxisStrokeThickness | Gets or sets the thickness of axis lines.
AxisTitleBrush | Gets or sets the Brush used to draw axis titles.
AxisTitleFontName | Gets or sets the name of font used to draw axis titles.
AxisTitleFontSize | Gets or sets the size of font used to draw axis titles.
AxisTitleFontStyle | Gets or sets the style of font used to draw axis titles.
CommonSeriesFills | Gets or sets a list of brushes, each Brush used to fill all elements of a series.
CommonSeriesStrokeDashStyles | Gets or sets a list of dash styles, each style applied to all elements of a series.
CommonSeriesStrokes | Gets or sets a list of brushes, each Brush used to stroke all elements of a series.
CommonSeriesStrokeThicknesses | Gets or sets a list of stroke thicknesses, each thickness applied to all elements of a series.
DataLabelsBrush | Gets or sets the Brush used to draw data labels.
DataLabelsFontName | Gets or sets the name of font used to draw data labels.
DataLabelsFontSize | Gets or sets the size of font used to draw data labels.
DataLabelsFontStyle | Gets or sets the style of font used to draw data labels.
GaugeBackground | Gets or sets a Brush used to draw gauge backgrounds.
GaugeFontName | Gets or sets the name of font used to draw text in gauges.
GaugeFontSize | Gets or sets the size of font used to draw text in gauges.
GaugeFontStyle | Gets or sets the style of font used to draw text in gauges.
GaugePointerBackground | Gets or sets a Brush used to draw gauge pointer backgrounds.
GaugePointerStroke | Gets or sets a Brush used to stroke gauge pointers.
GaugePointerStrokeThickness | Gets or sets the thickness of gauge pointer strokes.
GaugeScaleBackground | Gets or sets a Brush used to draw the background of gauge scales.
GaugeScaleStroke | Gets or sets a Brush used to stroke gauge scales.
GaugeScaleStrokeThickness | Gets or sets the thickness of gauge scale strokes.
GaugeStroke | Gets or sets a Brush used to stroke gauge borders.
GaugeStrokeThickness | Gets or sets the thickness of gauge borders.
GaugeTickBackground | Gets or sets a Brush used to draw gauge tick backgrounds.
GaugeTickStroke | Gets or sets a Brush used to stroke gauge ticks.
GaugeTickStrokeThickness | Gets or sets the thickness of gauge tick strokes.
GridColor1 | Gets or sets the main color of plot grid.
GridColor2 | Gets or sets the alternating color of plot grid.
GridLineColor | Gets or sets the line color of plot grid.
GridLineStyle | Gets or sets the style of plot grid lines.
GridLineThickness | Gets or sets the thickness of plot grid lines.
HighlightStroke | Gets or sets a Brush used to stroke highlighted items.
HighlightStrokeDashStyle | Gets or sets the dash style of highlight strokes.
HighlightStrokeThickness | Gets or sets the thickness of highlight strokes.
LegendBackground | Gets or sets a Brush used to draw legend background.
LegendBorderStroke | Gets or sets a Brush used to draw legend borders.
LegendBorderStrokeDashStyle | Gets or sets the dash style of legend borders.
LegendBorderStrokeThickness | Gets or sets the thickness of legend borders.
LegendTitleBrush | Gets or sets the Brush used to draw legend titles.
LegendTitleFontName | Gets or sets the name of font used to draw legend titles.
LegendTitleFontSize | Gets or sets the size of font used to draw legend titles.
LegendTitleFontStyle | Gets or sets the style of font used to draw legend titles.
PlotBackground | Gets or sets a Brush used to draw the background of plots.
PlotBorderStroke | Gets or sets a Brush used to stroke plot borders.
PlotBorderStrokeDashStyle | Gets or sets the dash style of plot borders.
PlotBorderStrokeThickness | Gets or sets the thickness of plot borders.
SeriesFills | Gets or sets a list of Brush lists, each list used to draw a different series, and each Brush used to fill individual elements of a series.
SeriesStrokeDashStyles | Gets or sets a list of DashStyle lists, each list used to stroke a different series, and each DashStyle value specifying style of individual elements of a series.
SeriesStrokes | Gets or sets a list of Brush lists, each list used to stroke a different series, and each Brush used to stroke individual elements of a series.
SeriesStrokeThicknesses | Gets or sets a list of double lists, each list used to stroke a different series, and each double value specifying thickness of individual elements of a series.
SubtitleBrush | Gets or sets the Brush used to draw the chart sub-title.
SubtitleFontName | Gets or sets the name of font used to draw the chart sub-title.
SubtitleFontSize | Gets or sets the size of font used to draw the chart sub-title.
SubtitleFontStyle | Gets or sets the style of font used to draw the chart sub-title.
TitleBrush | Gets or sets the Brush used to draw the chart title.
TitleFontName | Gets or sets the name of font used to draw the chart title.
TitleFontSize | Gets or sets the size of font used to draw the chart title.
TitleFontStyle | Gets or sets the style of font used to draw the chart title.
UniformSeriesFill | Gets or sets a Brush used to fill all elements of all series uniformly.
UniformSeriesStroke | Gets or sets a Brush used to stroke all elements of all series uniformly.
UniformSeriesStrokeDashStyle | Gets or sets uniform stroke dash style for all elements of all series.
UniformSeriesStrokeThickness | Gets or sets uniform stroke thickness for all elements of all series.
WidgetBrush | Gets or sets the Brush used to draw text in UI widgets.
WidgetFontName | Gets or sets the name of font used to draw text in UI widgets.
WidgetFontSize | Gets or sets the size of font used to draw text in UI widgets.
WidgetFontStyle | Gets or sets the style of font used to draw text in UI widgets.

See Also

Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.AxisLabelsBrush Property

Theme.AxisLabelsBrush Property
[image]

Gets or sets the Brush used to draw axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush AxisLabelsBrush { get; set; }

Visual Basic [image] Copy Code

Public Property AxisLabelsBrush As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.AxisLabelsFontName Property

Theme.AxisLabelsFontName Property
[image]

Gets or sets the name of font used to draw axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string AxisLabelsFontName { get; set; }

Visual Basic [image] Copy Code

Public Property AxisLabelsFontName As String

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.AxisLabelsFontSize Property

Theme.AxisLabelsFontSize Property
[image]

Gets or sets the size of font used to draw axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double AxisLabelsFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property AxisLabelsFontSize As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.AxisLabelsFontStyle Property

Theme.AxisLabelsFontStyle Property
[image]

Gets or sets the style of font used to draw axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public FontStyle AxisLabelsFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property AxisLabelsFontStyle As FontStyle

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.AxisStroke Property

Theme.AxisStroke Property
[image]

Gets or sets a Brush used to stroke axis lines.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush AxisStroke { get; set; }

Visual Basic [image] Copy Code

Public Property AxisStroke As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.AxisStrokeDashStyle Property

Theme.AxisStrokeDashStyle Property
[image]

Gets or sets the dash style of axis lines.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public DashStyle AxisStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property AxisStrokeDashStyle As DashStyle

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.AxisStrokeThickness Property

Theme.AxisStrokeThickness Property
[image]

Gets or sets the thickness of axis lines.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double AxisStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property AxisStrokeThickness As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.AxisTitleBrush Property

Theme.AxisTitleBrush Property
[image]

Gets or sets the Brush used to draw axis titles.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush AxisTitleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property AxisTitleBrush As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.AxisTitleFontName Property

Theme.AxisTitleFontName Property
[image]

Gets or sets the name of font used to draw axis titles.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string AxisTitleFontName { get; set; }

Visual Basic [image] Copy Code

Public Property AxisTitleFontName As String

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.AxisTitleFontSize Property

Theme.AxisTitleFontSize Property
[image]

Gets or sets the size of font used to draw axis titles.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double AxisTitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property AxisTitleFontSize As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.AxisTitleFontStyle Property

Theme.AxisTitleFontStyle Property
[image]

Gets or sets the style of font used to draw axis titles.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public FontStyle AxisTitleFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property AxisTitleFontStyle As FontStyle

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.CommonSeriesFills Property

Theme.CommonSeriesFills Property
[image]

Gets or sets a list of brushes, each Brush used to fill all elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<Brush> CommonSeriesFills { get; set; }

Visual Basic [image] Copy Code

Public Property CommonSeriesFills As List(Of Brush)

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.CommonSeriesStrokeDashStyles Property

Theme.CommonSeriesStrokeDashStyles Property
[image]

Gets or sets a list of dash styles, each style applied to all elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<DashStyle> CommonSeriesStrokeDashStyles { get; set; }

Visual Basic [image] Copy Code

Public Property CommonSeriesStrokeDashStyles As List(Of DashStyle)

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.CommonSeriesStrokes Property

Theme.CommonSeriesStrokes Property
[image]

Gets or sets a list of brushes, each Brush used to stroke all elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<Brush> CommonSeriesStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property CommonSeriesStrokes As List(Of Brush)

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.CommonSeriesStrokeThicknesses Property

Theme.CommonSeriesStrokeThicknesses Property
[image]

Gets or sets a list of stroke thicknesses, each thickness applied to all elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<Double> CommonSeriesStrokeThicknesses { get; set; }

Visual Basic [image] Copy Code

Public Property CommonSeriesStrokeThicknesses As List(Of Double)

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.DataLabelsBrush Property

Theme.DataLabelsBrush Property
[image]

Gets or sets the Brush used to draw data labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush DataLabelsBrush { get; set; }

Visual Basic [image] Copy Code

Public Property DataLabelsBrush As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.DataLabelsFontName Property

Theme.DataLabelsFontName Property
[image]

Gets or sets the name of font used to draw data labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string DataLabelsFontName { get; set; }

Visual Basic [image] Copy Code

Public Property DataLabelsFontName As String

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.DataLabelsFontSize Property

Theme.DataLabelsFontSize Property
[image]

Gets or sets the size of font used to draw data labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double DataLabelsFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property DataLabelsFontSize As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.DataLabelsFontStyle Property

Theme.DataLabelsFontStyle Property
[image]

Gets or sets the style of font used to draw data labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public FontStyle DataLabelsFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DataLabelsFontStyle As FontStyle

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugeBackground Property

Theme.GaugeBackground Property
[image]

Gets or sets a Brush used to draw gauge backgrounds.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush GaugeBackground { get; set; }

Visual Basic [image] Copy Code

Public Property GaugeBackground As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugeFontName Property

Theme.GaugeFontName Property
[image]

Gets or sets the name of font used to draw text in gauges.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string GaugeFontName { get; set; }

Visual Basic [image] Copy Code

Public Property GaugeFontName As String

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugeFontSize Property

Theme.GaugeFontSize Property
[image]

Gets or sets the size of font used to draw text in gauges.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GaugeFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property GaugeFontSize As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugeFontStyle Property

Theme.GaugeFontStyle Property
[image]

Gets or sets the style of font used to draw text in gauges.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public FontStyle GaugeFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property GaugeFontStyle As FontStyle

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugePointerBackground Property

Theme.GaugePointerBackground Property
[image]

Gets or sets a Brush used to draw gauge pointer backgrounds.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush GaugePointerBackground { get; set; }

Visual Basic [image] Copy Code

Public Property GaugePointerBackground As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugePointerStroke Property

Theme.GaugePointerStroke Property
[image]

Gets or sets a Brush used to stroke gauge pointers.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush GaugePointerStroke { get; set; }

Visual Basic [image] Copy Code

Public Property GaugePointerStroke As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugePointerStrokeThickness Property

Theme.GaugePointerStrokeThickness Property
[image]

Gets or sets the thickness of gauge pointer strokes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GaugePointerStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property GaugePointerStrokeThickness As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugeScaleBackground Property

Theme.GaugeScaleBackground Property
[image]

Gets or sets a Brush used to draw the background of gauge scales.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush GaugeScaleBackground { get; set; }

Visual Basic [image] Copy Code

Public Property GaugeScaleBackground As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugeScaleStroke Property

Theme.GaugeScaleStroke Property
[image]

Gets or sets a Brush used to stroke gauge scales.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush GaugeScaleStroke { get; set; }

Visual Basic [image] Copy Code

Public Property GaugeScaleStroke As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugeScaleStrokeThickness Property

Theme.GaugeScaleStrokeThickness Property
[image]

Gets or sets the thickness of gauge scale strokes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GaugeScaleStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property GaugeScaleStrokeThickness As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugeStroke Property

Theme.GaugeStroke Property
[image]

Gets or sets a Brush used to stroke gauge borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush GaugeStroke { get; set; }

Visual Basic [image] Copy Code

Public Property GaugeStroke As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugeStrokeThickness Property

Theme.GaugeStrokeThickness Property
[image]

Gets or sets the thickness of gauge borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GaugeStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property GaugeStrokeThickness As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugeTickBackground Property

Theme.GaugeTickBackground Property
[image]

Gets or sets a Brush used to draw gauge tick backgrounds.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush GaugeTickBackground { get; set; }

Visual Basic [image] Copy Code

Public Property GaugeTickBackground As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugeTickStroke Property

Theme.GaugeTickStroke Property
[image]

Gets or sets a Brush used to stroke gauge ticks.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush GaugeTickStroke { get; set; }

Visual Basic [image] Copy Code

Public Property GaugeTickStroke As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GaugeTickStrokeThickness Property

Theme.GaugeTickStrokeThickness Property
[image]

Gets or sets the thickness of gauge tick strokes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GaugeTickStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property GaugeTickStrokeThickness As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GridColor1 Property

Theme.GridColor1 Property
[image]

Gets or sets the main color of plot grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Color GridColor1 { get; set; }

Visual Basic [image] Copy Code

Public Property GridColor1 As Color

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GridColor2 Property

Theme.GridColor2 Property
[image]

Gets or sets the alternating color of plot grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Color GridColor2 { get; set; }

Visual Basic [image] Copy Code

Public Property GridColor2 As Color

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GridLineColor Property

Theme.GridLineColor Property
[image]

Gets or sets the line color of plot grid.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Color GridLineColor { get; set; }

Visual Basic [image] Copy Code

Public Property GridLineColor As Color

Property Value

A System.Drawing.Color instance representing the color of grid lines. The default value is Gray.

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GridLineStyle Property

Theme.GridLineStyle Property
[image]

Gets or sets the style of plot grid lines.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public DashStyle GridLineStyle { get; set; }

Visual Basic [image] Copy Code

Public Property GridLineStyle As DashStyle

Property Value

A member of the DashStyle enumeration specifying the dash style of grid lines. The default value is Solid.

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.GridLineThickness Property

Theme.GridLineThickness Property
[image]

Gets or sets the thickness of plot grid lines.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GridLineThickness { get; set; }

Visual Basic [image] Copy Code

Public Property GridLineThickness As Double

Property Value

A double value specifying the thickness of grid lines. The default value is 1.

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.HighlightStroke Property

Theme.HighlightStroke Property
[image]

Gets or sets a Brush used to stroke highlighted items.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush HighlightStroke { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightStroke As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.HighlightStrokeDashStyle Property

Theme.HighlightStrokeDashStyle Property
[image]

Gets or sets the dash style of highlight strokes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public DashStyle HighlightStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightStrokeDashStyle As DashStyle

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.HighlightStrokeThickness Property

Theme.HighlightStrokeThickness Property
[image]

Gets or sets the thickness of highlight strokes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double HighlightStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightStrokeThickness As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.LegendBackground Property

Theme.LegendBackground Property
[image]

Gets or sets a Brush used to draw legend background.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush LegendBackground { get; set; }

Visual Basic [image] Copy Code

Public Property LegendBackground As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.LegendBorderStroke Property

Theme.LegendBorderStroke Property
[image]

Gets or sets a Brush used to draw legend borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush LegendBorderStroke { get; set; }

Visual Basic [image] Copy Code

Public Property LegendBorderStroke As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.LegendBorderStrokeDashStyle Property

Theme.LegendBorderStrokeDashStyle Property
[image]

Gets or sets the dash style of legend borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public DashStyle LegendBorderStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LegendBorderStrokeDashStyle As DashStyle

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.LegendBorderStrokeThickness Property

Theme.LegendBorderStrokeThickness Property
[image]

Gets or sets the thickness of legend borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double LegendBorderStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property LegendBorderStrokeThickness As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.LegendTitleBrush Property

Theme.LegendTitleBrush Property
[image]

Gets or sets the Brush used to draw legend titles.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush LegendTitleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LegendTitleBrush As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.LegendTitleFontName Property

Theme.LegendTitleFontName Property
[image]

Gets or sets the name of font used to draw legend titles.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string LegendTitleFontName { get; set; }

Visual Basic [image] Copy Code

Public Property LegendTitleFontName As String

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.LegendTitleFontSize Property

Theme.LegendTitleFontSize Property
[image]

Gets or sets the size of font used to draw legend titles.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double LegendTitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property LegendTitleFontSize As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.LegendTitleFontStyle Property

Theme.LegendTitleFontStyle Property
[image]

Gets or sets the style of font used to draw legend titles.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public FontStyle LegendTitleFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LegendTitleFontStyle As FontStyle

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.PlotBackground Property

Theme.PlotBackground Property
[image]

Gets or sets a Brush used to draw the background of plots.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush PlotBackground { get; set; }

Visual Basic [image] Copy Code

Public Property PlotBackground As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.PlotBorderStroke Property

Theme.PlotBorderStroke Property
[image]

Gets or sets a Brush used to stroke plot borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush PlotBorderStroke { get; set; }

Visual Basic [image] Copy Code

Public Property PlotBorderStroke As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.PlotBorderStrokeDashStyle Property

Theme.PlotBorderStrokeDashStyle Property
[image]

Gets or sets the dash style of plot borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public DashStyle PlotBorderStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property PlotBorderStrokeDashStyle As DashStyle

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.PlotBorderStrokeThickness Property

Theme.PlotBorderStrokeThickness Property
[image]

Gets or sets the thickness of plot borders.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double PlotBorderStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property PlotBorderStrokeThickness As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.SeriesFills Property

Theme.SeriesFills Property
[image]

Gets or sets a list of Brush lists, each list used to draw a different series, and each Brush used to fill individual elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<List<Brush>> SeriesFills { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesFills As List(Of List(Of Brush))

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.SeriesStrokeDashStyles Property

Theme.SeriesStrokeDashStyles Property
[image]

Gets or sets a list of DashStyle lists, each list used to stroke a different series, and each DashStyle value specifying style of individual elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<List<DashStyle>> SeriesStrokeDashStyles { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesStrokeDashStyles As List(Of List(Of DashStyle))

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.SeriesStrokes Property

Theme.SeriesStrokes Property
[image]

Gets or sets a list of Brush lists, each list used to stroke a different series, and each Brush used to stroke individual elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<List<Brush>> SeriesStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesStrokes As List(Of List(Of Brush))

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.SeriesStrokeThicknesses Property

Theme.SeriesStrokeThicknesses Property
[image]

Gets or sets a list of double lists, each list used to stroke a different series, and each double value specifying thickness of individual elements of a series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<List<Double>> SeriesStrokeThicknesses { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesStrokeThicknesses As List(Of List(Of Double))

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.SubtitleBrush Property

Theme.SubtitleBrush Property
[image]

Gets or sets the Brush used to draw the chart sub-title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush SubtitleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property SubtitleBrush As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.SubtitleFontName Property

Theme.SubtitleFontName Property
[image]

Gets or sets the name of font used to draw the chart sub-title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string SubtitleFontName { get; set; }

Visual Basic [image] Copy Code

Public Property SubtitleFontName As String

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.SubtitleFontSize Property

Theme.SubtitleFontSize Property
[image]

Gets or sets the size of font used to draw the chart sub-title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double SubtitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property SubtitleFontSize As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.SubtitleFontStyle Property

Theme.SubtitleFontStyle Property
[image]

Gets or sets the style of font used to draw the chart sub-title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public FontStyle SubtitleFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SubtitleFontStyle As FontStyle

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.TitleBrush Property

Theme.TitleBrush Property
[image]

Gets or sets the Brush used to draw the chart title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush TitleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TitleBrush As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.TitleFontName Property

Theme.TitleFontName Property
[image]

Gets or sets the name of font used to draw the chart title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string TitleFontName { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontName As String

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.TitleFontSize Property

Theme.TitleFontSize Property
[image]

Gets or sets the size of font used to draw the chart title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double TitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontSize As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.TitleFontStyle Property

Theme.TitleFontStyle Property
[image]

Gets or sets the style of font used to draw the chart title.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public FontStyle TitleFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontStyle As FontStyle

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.UniformSeriesFill Property

Theme.UniformSeriesFill Property
[image]

Gets or sets a Brush used to fill all elements of all series uniformly.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush UniformSeriesFill { get; set; }

Visual Basic [image] Copy Code

Public Property UniformSeriesFill As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.UniformSeriesStroke Property

Theme.UniformSeriesStroke Property
[image]

Gets or sets a Brush used to stroke all elements of all series uniformly.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush UniformSeriesStroke { get; set; }

Visual Basic [image] Copy Code

Public Property UniformSeriesStroke As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.UniformSeriesStrokeDashStyle Property

Theme.UniformSeriesStrokeDashStyle Property
[image]

Gets or sets uniform stroke dash style for all elements of all series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public DashStyle UniformSeriesStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property UniformSeriesStrokeDashStyle As DashStyle

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.UniformSeriesStrokeThickness Property

Theme.UniformSeriesStrokeThickness Property
[image]

Gets or sets uniform stroke thickness for all elements of all series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double UniformSeriesStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property UniformSeriesStrokeThickness As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.WidgetBrush Property

Theme.WidgetBrush Property
[image]

Gets or sets the Brush used to draw text in UI widgets.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush WidgetBrush { get; set; }

Visual Basic [image] Copy Code

Public Property WidgetBrush As Brush

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.WidgetFontName Property

Theme.WidgetFontName Property
[image]

Gets or sets the name of font used to draw text in UI widgets.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string WidgetFontName { get; set; }

Visual Basic [image] Copy Code

Public Property WidgetFontName As String

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.WidgetFontSize Property

Theme.WidgetFontSize Property
[image]

Gets or sets the size of font used to draw text in UI widgets.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double WidgetFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property WidgetFontSize As Double

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.WidgetFontStyle Property

Theme.WidgetFontStyle Property
[image]

Gets or sets the style of font used to draw text in UI widgets.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public FontStyle WidgetFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property WidgetFontStyle As FontStyle

Property Value

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme Events

Theme Events
[image]

Public Events

Name | Description
PropertyChanged | Implements INotifyPropertyChanged.

See Also

Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.Theme.PropertyChanged Event

Theme.PropertyChanged Event
[image]

Implements INotifyPropertyChanged.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

Theme Members
Theme Class
MindFusion.Charting Namespace


MindFusion.Charting.ToolTip Class

ToolTip Class
[image]

Represents current tooltip.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public sealed class ToolTip

Visual Basic [image] Copy Code

Public NotInheritable Class ToolTip

Inheritance Hierarchy

System.Object
MindFusion.Charting.ToolTip

See Also

ToolTip Members
MindFusion.Charting Namespace


MindFusion.Charting.ToolTip Members

ToolTip Members
Properties
[image]

Represents current tooltip.

The following tables list the members exposed by the ToolTip type.

Public Properties

Name | Description
Position | Gets or sets the tooltip position.
Text | Gets or sets the tooltip text.

See Also

ToolTip Class
MindFusion.Charting Namespace


MindFusion.Charting.ToolTip Properties

ToolTip Properties
[image]

Public Properties

Name | Description
Position | Gets or sets the tooltip position.
Text | Gets or sets the tooltip text.

See Also

ToolTip Class
MindFusion.Charting Namespace


MindFusion.Charting.ToolTip.Position Property

ToolTip.Position Property
[image]

Gets or sets the tooltip position.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static PointD Position { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Position As PointD

Property Value

See Also

ToolTip Members
ToolTip Class
MindFusion.Charting Namespace


MindFusion.Charting.ToolTip.Text Property

ToolTip.Text Property
[image]

Gets or sets the tooltip text.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static string Text { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Text As String

Property Value

See Also

ToolTip Members
ToolTip Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle Class

UniformSeriesStyle Class
[image]

Implements SeriesStyle using uniform attributes for all elements in all series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class UniformSeriesStyle : SeriesStyle

Visual Basic [image] Copy Code

Public Class UniformSeriesStyle
Implements SeriesStyle

Inheritance Hierarchy

System.Object
MindFusion.Charting.UniformSeriesStyle

See Also

UniformSeriesStyle Members
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle Members

UniformSeriesStyle Members
Constructors Properties Methods
[image]

Implements SeriesStyle using uniform attributes for all elements in all series.

The following tables list the members exposed by the UniformSeriesStyle type.

Public Constructors

Name | Description
UniformSeriesStyle | Overloaded.

Public Properties

Name | Description
UniformFill | Gets or sets a Brush used to fill all elements of all series uniformly.
UniformStroke | Gets or sets a Brush used to stroke all elements of all series uniformly.
UniformStrokeDashStyle | Gets or sets uniform stroke dash style for all elements of all series.
UniformStrokeThickness | Gets or sets uniform stroke thickness for all elements of all series.

Public Methods

Name | Description
Fill | Implements SeriesStyle.Fill. Returns UniformFill for any data item.
Stroke | Implements SeriesStyle.Stroke. Returns UniformStroke for any data item.
StrokeDashStyle | Implements SeriesStyle.StrokeDashStyle. Returns UniformStrokeDashStyle for any data item.
StrokeThickness | Implements SeriesStyle.StrokeThickness. Returns UniformStrokeThickness for any data item.

See Also

UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle Constructor

UniformSeriesStyle Constructor
[image]

Overload List

Name | Description
UniformSeriesStyle () | Initializes a new instance of the UniformSeriesStyle class.
UniformSeriesStyle (Brush, Brush, Double, DashStyle) | Initializes a new instance of the UniformSeriesStyle class.

See Also

UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle Constructor ()

UniformSeriesStyle Constructor ()
See Also
[image]

Initializes a new instance of the UniformSeriesStyle class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public UniformSeriesStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

UniformSeriesStyle Constructor Overload List
UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle Constructor (Brush, Brush, Double, DashStyle)

UniformSeriesStyle Constructor (Brush, Brush, Double, DashStyle)
See Also
[image]

Initializes a new instance of the UniformSeriesStyle class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public UniformSeriesStyle (
Brush fill,
Brush stroke,
double strokeThickness,
DashStyle strokeDashStyle
)

Visual Basic [image] Copy Code

Public New ( _
fill As Brush, _
stroke As Brush, _
strokeThickness As Double, _
strokeDashStyle As DashStyle _
)

Parameters

fill

A Brush used to fill all series elements.

stroke

A Brush used to stroke all series elements.

strokeThickness

Uniform thickness of series elements' strokes.

strokeDashStyle

Uniform dash style of series elements' strokes.

See Also

UniformSeriesStyle Constructor Overload List
UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle Methods

UniformSeriesStyle Methods
[image]

Public Methods

Name | Description
Fill | Implements SeriesStyle.Fill. Returns UniformFill for any data item.
Stroke | Implements SeriesStyle.Stroke. Returns UniformStroke for any data item.
StrokeDashStyle | Implements SeriesStyle.StrokeDashStyle. Returns UniformStrokeDashStyle for any data item.
StrokeThickness | Implements SeriesStyle.StrokeThickness. Returns UniformStrokeThickness for any data item.

See Also

UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle.Fill Method

UniformSeriesStyle.Fill Method
[image]

Implements SeriesStyle.Fill. Returns UniformFill for any data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush Fill (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function Fill( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Brush

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A Brush instance.

See Also

UniformSeriesStyle Members
UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle.Stroke Method

UniformSeriesStyle.Stroke Method
[image]

Implements SeriesStyle.Stroke. Returns UniformStroke for any data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush Stroke (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function Stroke( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Brush

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A Brush instance.

See Also

UniformSeriesStyle Members
UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle.StrokeDashStyle Method

UniformSeriesStyle.StrokeDashStyle Method
[image]

Implements SeriesStyle.StrokeDashStyle. Returns UniformStrokeDashStyle for any data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<DashStyle> StrokeDashStyle (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function StrokeDashStyle( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Nullable(Of DashStyle)

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A nullable DashStyle value specifying stroke dash style.

See Also

UniformSeriesStyle Members
UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle.StrokeThickness Method

UniformSeriesStyle.StrokeThickness Method
[image]

Implements SeriesStyle.StrokeThickness. Returns UniformStrokeThickness for any data item.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> StrokeThickness (
int seriesIndex,
int dataIndex
)

Visual Basic [image] Copy Code

Public Function StrokeThickness( _
seriesIndex As Integer, _
dataIndex As Integer _
) As Nullable(Of Double)

Parameters

seriesIndex

An integer index of a Series.

dataIndex

An integer index of a data item in specified series.

Return Value

A nullable double value specifying stroke thickness.

See Also

UniformSeriesStyle Members
UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle Properties

UniformSeriesStyle Properties
[image]

Public Properties

Name | Description
UniformFill | Gets or sets a Brush used to fill all elements of all series uniformly.
UniformStroke | Gets or sets a Brush used to stroke all elements of all series uniformly.
UniformStrokeDashStyle | Gets or sets uniform stroke dash style for all elements of all series.
UniformStrokeThickness | Gets or sets uniform stroke thickness for all elements of all series.

See Also

UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle.UniformFill Property

UniformSeriesStyle.UniformFill Property
[image]

Gets or sets a Brush used to fill all elements of all series uniformly.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush UniformFill { get; set; }

Visual Basic [image] Copy Code

Public Property UniformFill As Brush

Property Value

See Also

UniformSeriesStyle Members
UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle.UniformStroke Property

UniformSeriesStyle.UniformStroke Property
[image]

Gets or sets a Brush used to stroke all elements of all series uniformly.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush UniformStroke { get; set; }

Visual Basic [image] Copy Code

Public Property UniformStroke As Brush

Property Value

See Also

UniformSeriesStyle Members
UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle.UniformStrokeDashStyle Property

UniformSeriesStyle.UniformStrokeDashStyle Property
[image]

Gets or sets uniform stroke dash style for all elements of all series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<DashStyle> UniformStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property UniformStrokeDashStyle As Nullable(Of DashStyle)

Property Value

See Also

UniformSeriesStyle Members
UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.UniformSeriesStyle.UniformStrokeThickness Property

UniformSeriesStyle.UniformStrokeThickness Property
[image]

Gets or sets uniform stroke thickness for all elements of all series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> UniformStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property UniformStrokeThickness As Nullable(Of Double)

Property Value

See Also

UniformSeriesStyle Members
UniformSeriesStyle Class
MindFusion.Charting Namespace


MindFusion.Charting.Vector Structure

Vector Structure
[image]

Represents a two-dimensional vector.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public struct Vector

Visual Basic [image] Copy Code

Public Structure Vector

See Also

Vector Members
MindFusion.Charting Namespace


MindFusion.Charting.Vector Members

Vector Members
Constructors Properties Methods
[image]

Represents a two-dimensional vector.

The following tables list the members exposed by the Vector type.

Public Constructors

Name | Description
Vector | Initializes a new instance of the Vector struct.

Public Properties

Name | Description
Length | Gets the length of this vector.
LengthSquared | Gets the squared length of this vector.
X | Gets or sets the X component of this vector.
Y | Gets or sets the Y component of this vector.

Public Methods

Name | Description
Add | Overloaded.
AngleBetween | Determines the angle between two vectors.
CrossProduct | Returns the size of cross-product of two vectors.
Determinant | Finds the determinant of two vectors.
Divide | Divides a vector by a scalar.
Equals | Overloaded.
GetHashCode | Object.GetHashCode override.
Multiply | Overloaded.
Negate | Reverses the direction of this vector.
Normalize | Makes this vector a unit vector.
Subtract | Subtracts two vectors.
ToString | Overloaded.

See Also

Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector Constructor

Vector Constructor
[image]

Initializes a new instance of the Vector struct.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Vector (
double x,
double y
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double _
)

Parameters

x

X component of the vector.

y

Y component of the vector.

See Also

Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector Methods

Vector Methods
[image]

Public Methods

Name | Description
Add | Overloaded.
AngleBetween | Determines the angle between two vectors.
CrossProduct | Returns the size of cross-product of two vectors.
Determinant | Finds the determinant of two vectors.
Divide | Divides a vector by a scalar.
Equals | Overloaded.
GetHashCode | Object.GetHashCode override.
Multiply | Overloaded.
Negate | Reverses the direction of this vector.
Normalize | Makes this vector a unit vector.
Subtract | Subtracts two vectors.
ToString | Overloaded.

See Also

Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Add Method

Vector.Add Method
[image]

Overload List

Name | Description
Vector.Add (Vector, PointF) | Translates point by a vector.
Vector.Add (Vector, Vector) | Adds two vectors.

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Add Method (Vector, PointF)

Vector.Add Method (Vector, PointF)
See Also
[image]

Translates point by a vector.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static PointD Add (
Vector vector,
PointF point
)

Visual Basic [image] Copy Code

Public Shared Function Add( _
vector As Vector, _
point As PointF _
) As PointD

Parameters

vector

The vector to add.

point

The reference point.

Return Value

The translated point.

See Also

Add Method Overload List
Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Add Method (Vector, Vector)

Vector.Add Method (Vector, Vector)
See Also
[image]

Adds two vectors.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static Vector Add (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function Add( _
vector1 As Vector, _
vector2 As Vector _
) As Vector

Parameters

vector1

The first vector.

vector2

The second vector.

Return Value

A vector representing the sum of specified vectors.

See Also

Add Method Overload List
Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.AngleBetween Method

Vector.AngleBetween Method
[image]

Determines the angle between two vectors.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static double AngleBetween (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function AngleBetween( _
vector1 As Vector, _
vector2 As Vector _
) As Double

Parameters

vector1

The first vector.

vector2

The second vector.

Return Value

The angle between specified vectors.

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.CrossProduct Method

Vector.CrossProduct Method
[image]

Returns the size of cross-product of two vectors.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static double CrossProduct (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function CrossProduct( _
vector1 As Vector, _
vector2 As Vector _
) As Double

Parameters

vector1

The first vector.

vector2

The second vector.

Return Value

The size of cross-product.

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Determinant Method

Vector.Determinant Method
[image]

Finds the determinant of two vectors.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static double Determinant (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function Determinant( _
vector1 As Vector, _
vector2 As Vector _
) As Double

Parameters

vector1

The first vector.

vector2

The second vector.

Return Value

The determinant.

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Divide Method

Vector.Divide Method
[image]

Divides a vector by a scalar.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static Vector Divide (
Vector vector,
double scalar
)

Visual Basic [image] Copy Code

Public Shared Function Divide( _
vector As Vector, _
scalar As Double _
) As Vector

Parameters

vector

The vector to divide.

scalar

The scalar value.

Return Value

A vector containing the division result.

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Equals Method

Vector.Equals Method
[image]

Overload List

Name | Description
Vector.Equals (Object) | Object.Equals override.
Vector.Equals (Vector) | Determines if specified vector is equal to this one.
Vector.Equals (Vector, Vector) | Determines if two vectors are equal.

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Equals Method (Object)

Vector.Equals Method (Object)
See Also
[image]

Object.Equals override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override bool Equals (
Object o
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
o As Object _
) As Boolean

Parameters

o

An object to compare with this vector.

Return Value

true if vectors are equal, or false otherwise.

See Also

Equals Method Overload List
Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Equals Method (Vector)

Vector.Equals Method (Vector)
See Also
[image]

Determines if specified vector is equal to this one.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public new bool Equals (
Vector value
)

Visual Basic [image] Copy Code

Public Shadows Function Equals( _
value As Vector _
) As Boolean

Parameters

value

The vector to compare with this one.

Return Value

true if vectors are equal, or false otherwise.

See Also

Equals Method Overload List
Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Equals Method (Vector, Vector)

Vector.Equals Method (Vector, Vector)
See Also
[image]

Determines if two vectors are equal.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public new static bool Equals (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shadows Shared Function Equals( _
vector1 As Vector, _
vector2 As Vector _
) As Boolean

Parameters

vector1

The first vector to compare.

vector2

The second vector to compare.

Return Value

true if vectors are equal, or false otherwise.

See Also

Equals Method Overload List
Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.GetHashCode Method

Vector.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The hashcode.

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Multiply Method

Vector.Multiply Method
[image]

Overload List

Name | Description
Vector.Multiply (Double, Vector) | Multiplies vector by a scalar.
Vector.Multiply (Vector, Double) | Multiplies vector by a scalar.
Vector.Multiply (Vector, Vector) | Returns the dot product of two vectors.

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Multiply Method (Double, Vector)

Vector.Multiply Method (Double, Vector)
See Also
[image]

Multiplies vector by a scalar.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static Vector Multiply (
double scalar,
Vector vector
)

Visual Basic [image] Copy Code

Public Shared Function Multiply( _
scalar As Double, _
vector As Vector _
) As Vector

Parameters

scalar

The scalar value.

vector

The vector to multiply.

Return Value

A vector containing the multiplication result.

See Also

Multiply Method Overload List
Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Multiply Method (Vector, Double)

Vector.Multiply Method (Vector, Double)
See Also
[image]

Multiplies vector by a scalar.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static Vector Multiply (
Vector vector,
double scalar
)

Visual Basic [image] Copy Code

Public Shared Function Multiply( _
vector As Vector, _
scalar As Double _
) As Vector

Parameters

vector

The vector to multiply.

scalar

The scalar value.

Return Value

A vector containing the multiplication result.

See Also

Multiply Method Overload List
Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Multiply Method (Vector, Vector)

Vector.Multiply Method (Vector, Vector)
See Also
[image]

Returns the dot product of two vectors.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static double Multiply (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function Multiply( _
vector1 As Vector, _
vector2 As Vector _
) As Double

Parameters

vector1

The first vector.

vector2

The second vector.

Return Value

The dot product.

See Also

Multiply Method Overload List
Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Negate Method

Vector.Negate Method
[image]

Reverses the direction of this vector.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void Negate ()

Visual Basic [image] Copy Code

Public Sub Negate ()

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Normalize Method

Vector.Normalize Method
[image]

Makes this vector a unit vector.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public void Normalize ()

Visual Basic [image] Copy Code

Public Sub Normalize ()

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Subtract Method

Vector.Subtract Method
[image]

Subtracts two vectors.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static Vector Subtract (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function Subtract( _
vector1 As Vector, _
vector2 As Vector _
) As Vector

Parameters

vector1

The first vector.

vector2

The second vector.

Return Value

A vector representing the difference between specified vectors.

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.ToString Method

Vector.ToString Method
[image]

Overload List

Name | Description
Vector.ToString () | Object.ToString override.
Vector.ToString (IFormatProvider) | Gets a string representation of this vector.

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.ToString Method ()

Vector.ToString Method ()
See Also
[image]

Object.ToString override.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

ToString Method Overload List
Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.ToString Method (IFormatProvider)

Vector.ToString Method (IFormatProvider)
See Also
[image]

Gets a string representation of this vector.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string ToString (
IFormatProvider provider
)

Visual Basic [image] Copy Code

Public Function ToString( _
provider As IFormatProvider _
) As String

Parameters

provider

An IFormatProvider instance.

Return Value

The string representation of this vector.

See Also

ToString Method Overload List
Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector Properties

Vector Properties
[image]

Public Properties

Name | Description
Length | Gets the length of this vector.
LengthSquared | Gets the squared length of this vector.
X | Gets or sets the X component of this vector.
Y | Gets or sets the Y component of this vector.

See Also

Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Length Property

Vector.Length Property
[image]

Gets the length of this vector.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Double

Property Value

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.LengthSquared Property

Vector.LengthSquared Property
[image]

Gets the squared length of this vector.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double LengthSquared { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LengthSquared As Double

Property Value

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.X Property

Vector.X Property
[image]

Gets or sets the X component of this vector.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.Vector.Y Property

Vector.Y Property
[image]

Gets or sets the Y component of this vector.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

See Also

Vector Members
Vector Structure
MindFusion.Charting Namespace


MindFusion.Charting.XAxisRenderer Class

XAxisRenderer Class
Remarks See Also
[image]

A Component that renders horizontal Axis ranges.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class XAxisRenderer : AxisRenderer

Visual Basic [image] Copy Code

Public Class XAxisRenderer
Inherits AxisRenderer

Remarks

If the Axis property of this renderer is not set, it will search for Axis instances assigned to XAxis property of Plot2D or BiaxialChart in current RenderContext.

XAxisRenderer is not aware of the location of Plot components that display graphics on same Axis, and will not match series coordinates correctly if the plots are not horizontally aligned with the XAxisRenderer. You can ensure the axis renderer and plots are aligned by placing them in same vertical StackPanel, or in same column of a GridPanel.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Components.Component
MindFusion.Charting.AxisRenderer
MindFusion.Charting.XAxisRenderer

See Also

XAxisRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.XAxisRenderer Members

XAxisRenderer Members
Constructors Properties Methods
[image]

A Component that renders horizontal Axis ranges.

The following tables list the members exposed by the XAxisRenderer type.

Public Constructors

Name | Description
XAxisRenderer | Initializes a new instance of the XAxisRenderer class.

Public Properties

Name | Description
Axis | The Axis that will be drawn by this object. (Inherited from AxisRenderer.)
AxisStroke | Gets or sets the Brush that should be used to draw axis lines. (Inherited from AxisRenderer.)
AxisStrokeDashStyle | Gets or sets the dash style axis lines should be stroked with. (Inherited from AxisRenderer.)
AxisStrokeThickness | Gets or sets the thickness axis lines should be stroked with. (Inherited from AxisRenderer.)
LabelBrush | Gets or sets the Brush that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelPadding | Gets or sets the padding space between the axis line and coordinate labels. (Inherited from AxisRenderer.)
LabelsSource | Gets or sets the object whose Series labels should be rendered along this axis. (Inherited from AxisRenderer.)
PinLabels | Gets or sets a value indicating whether coordinate labels should be pinned in place or scroll together with the plot when users pan it. (Inherited from AxisRenderer.)
PlotBottomSide | Gets or sets whether this XAxisRenderer is shown at the bottom side of a plot.
ShowCoordinates | Gets or sets a value indicating whether this AxisRenderer should draw axis coordinates. (Inherited from AxisRenderer.)
ShowSeriesLabels | Gets or sets a value indicating whether this AxisRenderer should draw data labels. (Inherited from AxisRenderer.)
ShowTicks | Gets or sets a value indicating whether this AxisRenderer should draw axis ticks. (Inherited from AxisRenderer.)
TickLength | Gets or sets the length of the axis ticks. (Inherited from AxisRenderer.)
TitleBrush | Gets or sets the Brush that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontName | Gets or sets the name of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontSize | Gets or sets the size of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontStyle | Gets or sets the style of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)

Public Methods

Name | Description
Draw | Component.Draw override. Draws this component in specified RenderContext.
Measure | Component.Measure override. Measures the desired size of this component.

Protected Methods

Name | Description
EffectiveAxis | AxisRenderer.EffectiveAxis override. Gets the effective horizontal Axis in current context, getting one from Plot2D or chart control if there's no local Axis associated with this renderer.
EffectiveAxisDashStyle | Gets the dash style of axis line strokes. (Inherited from AxisRenderer.)
EffectiveAxisStroke | Gets the Brush that should be used to stroke axis lines. (Inherited from AxisRenderer.)
EffectiveAxisStrokeThickness | Gets the thickness of axis line strokes. (Inherited from AxisRenderer.)
EffectiveLabelBrush | Gets the Brush that should be used to draw axis labels. (Inherited from AxisRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw axis labels. (Inherited from AxisRenderer.)
EffectivePen | Gets the Pen that should be used to draw axis lines. (Inherited from AxisRenderer.)
EffectiveTitleBrush | Gets the Brush that should be used to draw the axis Title. (Inherited from AxisRenderer.)
EffectiveTitleFont | Gets the Font that should be used to draw the axis Title. (Inherited from AxisRenderer.)

See Also

XAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.XAxisRenderer Constructor

XAxisRenderer Constructor
[image]

Initializes a new instance of the XAxisRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XAxisRenderer (
Axis axis
)

Visual Basic [image] Copy Code

Public New ( _
axis As Axis _
)

Parameters

axis

The Axis that will be drawn by this object.

See Also

XAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.XAxisRenderer Methods

XAxisRenderer Methods
[image]

Public Methods

Name | Description
Draw | Component.Draw override. Draws this component in specified RenderContext.
Measure | Component.Measure override. Measures the desired size of this component.

Protected Methods

Name | Description
EffectiveAxis | AxisRenderer.EffectiveAxis override. Gets the effective horizontal Axis in current context, getting one from Plot2D or chart control if there's no local Axis associated with this renderer.
EffectiveAxisDashStyle | Gets the dash style of axis line strokes. (Inherited from AxisRenderer.)
EffectiveAxisStroke | Gets the Brush that should be used to stroke axis lines. (Inherited from AxisRenderer.)
EffectiveAxisStrokeThickness | Gets the thickness of axis line strokes. (Inherited from AxisRenderer.)
EffectiveLabelBrush | Gets the Brush that should be used to draw axis labels. (Inherited from AxisRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw axis labels. (Inherited from AxisRenderer.)
EffectivePen | Gets the Pen that should be used to draw axis lines. (Inherited from AxisRenderer.)
EffectiveTitleBrush | Gets the Brush that should be used to draw the axis Title. (Inherited from AxisRenderer.)
EffectiveTitleFont | Gets the Font that should be used to draw the axis Title. (Inherited from AxisRenderer.)

See Also

XAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.XAxisRenderer.Draw Method

XAxisRenderer.Draw Method
[image]

Component.Draw override. Draws this component in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

XAxisRenderer Members
XAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.XAxisRenderer.EffectiveAxis Method

XAxisRenderer.EffectiveAxis Method
[image]

AxisRenderer.EffectiveAxis override. Gets the effective horizontal Axis in current context, getting one from Plot2D or chart control if there's no local Axis associated with this renderer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override Axis EffectiveAxis (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function EffectiveAxis( _
context As RenderContext _
) As Axis

Parameters

context

A RenderContext instance.

Return Value

An Axis instance.

See Also

XAxisRenderer Members
XAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.XAxisRenderer.Measure Method

XAxisRenderer.Measure Method
[image]

Component.Measure override. Measures the desired size of this component.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void Measure (
double maxWidth,
double maxHeight,
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub Measure( _
maxWidth As Double, _
maxHeight As Double, _
context As RenderContext _
)

Parameters

maxWidth

The maximum width provided by parent component.

maxHeight

The maximum height provided by parent component.

context

A RenderContext instance.

See Also

XAxisRenderer Members
XAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.XAxisRenderer Properties

XAxisRenderer Properties
[image]

Public Properties

Name | Description
Axis | The Axis that will be drawn by this object. (Inherited from AxisRenderer.)
AxisStroke | Gets or sets the Brush that should be used to draw axis lines. (Inherited from AxisRenderer.)
AxisStrokeDashStyle | Gets or sets the dash style axis lines should be stroked with. (Inherited from AxisRenderer.)
AxisStrokeThickness | Gets or sets the thickness axis lines should be stroked with. (Inherited from AxisRenderer.)
LabelBrush | Gets or sets the Brush that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelPadding | Gets or sets the padding space between the axis line and coordinate labels. (Inherited from AxisRenderer.)
LabelsSource | Gets or sets the object whose Series labels should be rendered along this axis. (Inherited from AxisRenderer.)
PinLabels | Gets or sets a value indicating whether coordinate labels should be pinned in place or scroll together with the plot when users pan it. (Inherited from AxisRenderer.)
PlotBottomSide | Gets or sets whether this XAxisRenderer is shown at the bottom side of a plot.
ShowCoordinates | Gets or sets a value indicating whether this AxisRenderer should draw axis coordinates. (Inherited from AxisRenderer.)
ShowSeriesLabels | Gets or sets a value indicating whether this AxisRenderer should draw data labels. (Inherited from AxisRenderer.)
ShowTicks | Gets or sets a value indicating whether this AxisRenderer should draw axis ticks. (Inherited from AxisRenderer.)
TickLength | Gets or sets the length of the axis ticks. (Inherited from AxisRenderer.)
TitleBrush | Gets or sets the Brush that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontName | Gets or sets the name of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontSize | Gets or sets the size of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontStyle | Gets or sets the style of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)

See Also

XAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.XAxisRenderer.PlotBottomSide Property

XAxisRenderer.PlotBottomSide Property
[image]

Gets or sets whether this XAxisRenderer is shown at the bottom side of a plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool PlotBottomSide { get; set; }

Visual Basic [image] Copy Code

Public Property PlotBottomSide As Boolean

Property Value

See Also

XAxisRenderer Members
XAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext Class

XmlPersistContext Class
[image]

Contains methods that facilitate serializing and deserializing objects to and from XML documents.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class XmlPersistContext

Visual Basic [image] Copy Code

Public Class XmlPersistContext

Inheritance Hierarchy

System.Object
MindFusion.Charting.XmlPersistContext

See Also

XmlPersistContext Members
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext Members

XmlPersistContext Members
Constructors Fields Properties Methods
[image]

Contains methods that facilitate serializing and deserializing objects to and from XML documents.

The following tables list the members exposed by the XmlPersistContext type.

Public Constructors

Name | Description
XmlPersistContext | Initializes a new instance of the XmlPersistContext class.

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

Public Properties

Name | Description
FileVersion | Gets the format revision number for the file being currently serialized.
IncludeUnalteredProperties | Gets or sets a value specifies whether properties that have their default value should be serialized to XML.
XmlDocument | Gets the underlying XML document.

Public Methods

Name | Description
AddChildElement | Overloaded.
ReadBool | Overloaded.
ReadBrush | Overloaded.
ReadBrushList | Overloaded.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Overloaded.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadDoubleList | Overloaded.
ReadEnum | Overloaded.
ReadFloat | Overloaded.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Overloaded.
ReadHashtable | Reads a hashtable with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Overloaded.
ReadLong | Reads a long value with the specified name.
ReadNullableDouble | Reads a nullable double value with the specified name.
ReadNullableEnum | Reads a nullable enum value with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Overloaded.
ReadPointF | Overloaded.
ReadRectangleF | Reads a RectangleF object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShort | Overloaded.
ReadSizeF | Reads a SizeF object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded.
ReadStringFormat | Overloaded.
ReadThickness | Reads a Thickness object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteBrushList | Writes the specified brushes.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteDecimal | Write a decimal value with the specified name.
WriteDictionary | Writes the specified dictionary.
WriteDouble | Overloaded.
WriteDoubleList | Writes the specified list of doubles.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteLong | Writes a long value with the specified name.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePointF | Overloaded.
WriteRectangleF | Writes a RectangleF with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a SizeF with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteThickness | Writes a Thickness with the specified name.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext Fields

XmlPersistContext Fields
[image]

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

See Also

XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.LatestFormat Field

XmlPersistContext.LatestFormat Field
[image]

Specifies the latest file format revision number.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public static int LatestFormat

Visual Basic [image] Copy Code

Public Shared LatestFormat As Integer

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext Constructor

XmlPersistContext Constructor
[image]

Initializes a new instance of the XmlPersistContext class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XmlPersistContext (
XDocument document,
int fileVersion
)

Visual Basic [image] Copy Code

Public New ( _
document As XDocument, _
fileVersion As Integer _
)

Parameters

document

The associated XDocument.

fileVersion

Specifies the current file format number.

See Also

XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext Methods

XmlPersistContext Methods
[image]

Public Methods

Name | Description
AddChildElement | Overloaded.
ReadBool | Overloaded.
ReadBrush | Overloaded.
ReadBrushList | Overloaded.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Overloaded.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadDoubleList | Overloaded.
ReadEnum | Overloaded.
ReadFloat | Overloaded.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Overloaded.
ReadHashtable | Reads a hashtable with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Overloaded.
ReadLong | Reads a long value with the specified name.
ReadNullableDouble | Reads a nullable double value with the specified name.
ReadNullableEnum | Reads a nullable enum value with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Overloaded.
ReadPointF | Overloaded.
ReadRectangleF | Reads a RectangleF object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShort | Overloaded.
ReadSizeF | Reads a SizeF object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded.
ReadStringFormat | Overloaded.
ReadThickness | Reads a Thickness object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteBrushList | Writes the specified brushes.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteDecimal | Write a decimal value with the specified name.
WriteDictionary | Writes the specified dictionary.
WriteDouble | Overloaded.
WriteDoubleList | Writes the specified list of doubles.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteLong | Writes a long value with the specified name.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePointF | Overloaded.
WriteRectangleF | Writes a RectangleF with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a SizeF with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteThickness | Writes a Thickness with the specified name.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.AddChildElement Method

XmlPersistContext.AddChildElement Method
[image]

Overload List

Name | Description
XmlPersistContext.AddChildElement (String, XContainer) | Adds a new child node with the specified name to the specified parent node.
XmlPersistContext.AddChildElement (String, XContainer, String) | Adds a new child node with the specified name and value to the specified parent node.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.AddChildElement Method (String, XContainer)

XmlPersistContext.AddChildElement Method (String, XContainer)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement AddChildElement (
string elementName,
XContainer parentElement
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XContainer _
) As XElement

Parameters

elementName

parentElement

Return Value

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.AddChildElement Method (String, XContainer, String)

XmlPersistContext.AddChildElement Method (String, XContainer, String)
See Also
[image]

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement AddChildElement (
string elementName,
XContainer parentElement,
string innerText
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XContainer, _
innerText As String _
) As XElement

Parameters

elementName

parentElement

innerText

Return Value

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadBool Method

XmlPersistContext.ReadBool Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadBool (String, XElement) | Reads a boolean value with the specified name.
XmlPersistContext.ReadBool (String, XElement, Boolean) | Reads a boolean value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadBool Method (String, XElement)

XmlPersistContext.ReadBool Method (String, XElement)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XElement _
) As Boolean

Parameters

elementName

parentElement

Return Value

See Also

ReadBool Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadBool Method (String, XElement, Boolean)

XmlPersistContext.ReadBool Method (String, XElement, Boolean)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XElement parentElement,
bool defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadBool Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadBrush Method

XmlPersistContext.ReadBrush Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadBrush (String, XElement) | Reads a MindFusion.Drawing.Brush object with the specified name.
XmlPersistContext.ReadBrush (String, XElement, Brush) | Reads a MindFusion.Drawing.Brush object with the specified name.
XmlPersistContext.ReadBrush (XElement, Brush) | Reads a MindFusion.Drawing.Brush object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadBrush Method (String, XElement)

XmlPersistContext.ReadBrush Method (String, XElement)
See Also
[image]

Reads a MindFusion.Drawing.Brush object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush ReadBrush (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
elementName As String, _
parentElement As XElement _
) As Brush

Parameters

elementName

parentElement

Return Value

See Also

ReadBrush Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadBrush Method (String, XElement, Brush)

XmlPersistContext.ReadBrush Method (String, XElement, Brush)
See Also
[image]

Reads a MindFusion.Drawing.Brush object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush ReadBrush (
string elementName,
XElement parentElement,
Brush defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
elementName As String, _
parentElement As XElement, _
defaultValue As Brush _
) As Brush

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadBrush Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadBrush Method (XElement, Brush)

XmlPersistContext.ReadBrush Method (XElement, Brush)
See Also
[image]

Reads a MindFusion.Drawing.Brush object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Brush ReadBrush (
XElement element,
Brush defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
element As XElement, _
defaultValue As Brush _
) As Brush

Parameters

element

defaultValue

Return Value

See Also

ReadBrush Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadBrushList Method

XmlPersistContext.ReadBrushList Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadBrushList (String, String, XElement) | Reads a list of brushes.
XmlPersistContext.ReadBrushList (XElement, String) | Reads a list of brushes.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadBrushList Method (String, String, XElement)

XmlPersistContext.ReadBrushList Method (String, String, XElement)
See Also
[image]

Reads a list of brushes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<Brush> ReadBrushList (
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBrushList( _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As List(Of Brush)

Parameters

elementName

subElementName

parentElement

Return Value

See Also

ReadBrushList Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadBrushList Method (XElement, String)

XmlPersistContext.ReadBrushList Method (XElement, String)
See Also
[image]

Reads a list of brushes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<Brush> ReadBrushList (
XElement element,
string subElementName
)

Visual Basic [image] Copy Code

Public Function ReadBrushList( _
element As XElement, _
subElementName As String _
) As List(Of Brush)

Parameters

element

subElementName

Return Value

See Also

ReadBrushList Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadByte Method

XmlPersistContext.ReadByte Method
[image]

Reads a byte value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public byte ReadByte (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadByte( _
elementName As String, _
parentElement As XElement _
) As Byte

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadChar Method

XmlPersistContext.ReadChar Method
[image]

Reads a char value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public char ReadChar (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadChar( _
elementName As String, _
parentElement As XElement _
) As Char

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadColor Method

XmlPersistContext.ReadColor Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadColor (String, XElement) | Reads a color with the specified name.
XmlPersistContext.ReadColor (String, XElement, Color) | Reads a color with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadColor Method (String, XElement)

XmlPersistContext.ReadColor Method (String, XElement)
See Also
[image]

Reads a color with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As String, _
parentElement As XElement _
) As Color

Parameters

elementName

parentElement

Return Value

See Also

ReadColor Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadColor Method (String, XElement, Color)

XmlPersistContext.ReadColor Method (String, XElement, Color)
See Also
[image]

Reads a color with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XElement parentElement,
Color defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As String, _
parentElement As XElement, _
defaultValue As Color _
) As Color

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadColor Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadColorArray Method

XmlPersistContext.ReadColorArray Method
[image]

Reads a color array with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Color[] ReadColorArray (
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColorArray( _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As Color()

Parameters

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadDecimal Method

XmlPersistContext.ReadDecimal Method
[image]

Reads a decimal value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public decimal ReadDecimal (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDecimal( _
elementName As String, _
parentElement As XElement _
) As Decimal

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadDouble Method

XmlPersistContext.ReadDouble Method
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As String, _
parentElement As XElement _
) As Double

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadDoubleList Method

XmlPersistContext.ReadDoubleList Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadDoubleList (String, String, XElement) | Reads a list of doubles.
XmlPersistContext.ReadDoubleList (XElement, String) | Reads a list of doubles.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadDoubleList Method (String, String, XElement)

XmlPersistContext.ReadDoubleList Method (String, String, XElement)
See Also
[image]

Reads a list of doubles.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<Double> ReadDoubleList (
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDoubleList( _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As List(Of Double)

Parameters

elementName

subElementName

parentElement

Return Value

See Also

ReadDoubleList Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadDoubleList Method (XElement, String)

XmlPersistContext.ReadDoubleList Method (XElement, String)
See Also
[image]

Reads a list of doubles.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public List<Double> ReadDoubleList (
XElement element,
string subElementName
)

Visual Basic [image] Copy Code

Public Function ReadDoubleList( _
element As XElement, _
subElementName As String _
) As List(Of Double)

Parameters

element

subElementName

Return Value

See Also

ReadDoubleList Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadEnum Method

XmlPersistContext.ReadEnum Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadEnum (String, XElement) | Reads an enum value with the specified name.
XmlPersistContext.ReadEnum (String, XElement, Object) | Reads an enum value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadEnum Method (String, XElement)

XmlPersistContext.ReadEnum Method (String, XElement)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

ReadEnum Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadEnum Method (String, XElement, Object)

XmlPersistContext.ReadEnum Method (String, XElement, Object)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XElement parentElement,
Object defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XElement, _
defaultValue As Object _
) As Object

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadEnum Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadFloat Method

XmlPersistContext.ReadFloat Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadFloat (String, XElement) | Reads a float value with the specified name.
XmlPersistContext.ReadFloat (String, XElement, Single) | Reads a float value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadFloat Method (String, XElement)

XmlPersistContext.ReadFloat Method (String, XElement)
See Also
[image]

Reads a float value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public float ReadFloat (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XElement _
) As Single

Parameters

elementName

parentElement

Return Value

See Also

ReadFloat Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadFloat Method (String, XElement, Single)

XmlPersistContext.ReadFloat Method (String, XElement, Single)
See Also
[image]

Reads a float value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public float ReadFloat (
string elementName,
XElement parentElement,
float defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XElement, _
defaultValue As Single _
) As Single

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadFloat Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadFloatArray Method

XmlPersistContext.ReadFloatArray Method
[image]

Reads a float array with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public float[] ReadFloatArray (
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloatArray( _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As Single()

Parameters

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadFont Method

XmlPersistContext.ReadFont Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadFont (String, XElement) | Reads a Font object with the specified name.
XmlPersistContext.ReadFont (String, XElement, Font) | Reads a Font object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadFont Method (String, XElement)

XmlPersistContext.ReadFont Method (String, XElement)
See Also
[image]

Reads a Font object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Font ReadFont (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFont( _
elementName As String, _
parentElement As XElement _
) As Font

Parameters

elementName

parentElement

Return Value

See Also

ReadFont Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadFont Method (String, XElement, Font)

XmlPersistContext.ReadFont Method (String, XElement, Font)
See Also
[image]

Reads a Font object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Font ReadFont (
string elementName,
XElement parentElement,
Font defaultFont
)

Visual Basic [image] Copy Code

Public Function ReadFont( _
elementName As String, _
parentElement As XElement, _
defaultFont As Font _
) As Font

Parameters

elementName

parentElement

defaultFont

Return Value

See Also

ReadFont Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadHashtable Method

XmlPersistContext.ReadHashtable Method
[image]

Reads a hashtable with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Hashtable ReadHashtable (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadHashtable( _
elementName As String, _
parentElement As XElement _
) As Hashtable

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadImage Method

XmlPersistContext.ReadImage Method
[image]

Reads an Image object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Image ReadImage (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadImage( _
elementName As String, _
parentElement As XElement _
) As Image

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadInt Method

XmlPersistContext.ReadInt Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadInt (String, XElement) | Reads an integer value with the specified name.
XmlPersistContext.ReadInt (String, XElement, Int32) | Reads an integer value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadInt Method (String, XElement)

XmlPersistContext.ReadInt Method (String, XElement)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XElement _
) As Integer

Parameters

elementName

parentElement

Return Value

See Also

ReadInt Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadInt Method (String, XElement, Int32)

XmlPersistContext.ReadInt Method (String, XElement, Int32)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XElement parentElement,
int defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XElement, _
defaultValue As Integer _
) As Integer

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadInt Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadLong Method

XmlPersistContext.ReadLong Method
[image]

Reads a long value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public long ReadLong (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadLong( _
elementName As String, _
parentElement As XElement _
) As Long

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadNullableDouble Method

XmlPersistContext.ReadNullableDouble Method
[image]

Reads a nullable double value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Nullable<Double> ReadNullableDouble (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadNullableDouble( _
elementName As String, _
parentElement As XElement _
) As Nullable(Of Double)

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadNullableEnum Method

XmlPersistContext.ReadNullableEnum Method
[image]

Reads a nullable enum value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Object ReadNullableEnum (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadNullableEnum( _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadObject Method

XmlPersistContext.ReadObject Method
[image]

Reads an object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Object ReadObject (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadObject( _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadPen Method

XmlPersistContext.ReadPen Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadPen (String, XElement) | Reads a MindFusion.Drawing.Pen object with the specified name.
XmlPersistContext.ReadPen (String, XElement, Pen) | Reads a MindFusion.Drawing.Pen object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadPen Method (String, XElement)

XmlPersistContext.ReadPen Method (String, XElement)
See Also
[image]

Reads a MindFusion.Drawing.Pen object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Pen ReadPen (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPen( _
elementName As String, _
parentElement As XElement _
) As Pen

Parameters

elementName

parentElement

Return Value

See Also

ReadPen Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadPen Method (String, XElement, Pen)

XmlPersistContext.ReadPen Method (String, XElement, Pen)
See Also
[image]

Reads a MindFusion.Drawing.Pen object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Pen ReadPen (
string elementName,
XElement parentElement,
Pen defaultPen
)

Visual Basic [image] Copy Code

Public Function ReadPen( _
elementName As String, _
parentElement As XElement, _
defaultPen As Pen _
) As Pen

Parameters

elementName

parentElement

defaultPen

Return Value

See Also

ReadPen Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadPointF Method

XmlPersistContext.ReadPointF Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadPointF (String, XElement) | Reads a PointF object with the specified name.
XmlPersistContext.ReadPointF (XElement) | Reads a PointF object from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadPointF Method (String, XElement)

XmlPersistContext.ReadPointF Method (String, XElement)
See Also
[image]

Reads a PointF object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PointF ReadPointF (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointF( _
elementName As String, _
parentElement As XElement _
) As PointF

Parameters

elementName

parentElement

Return Value

See Also

ReadPointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadPointF Method (XElement)

XmlPersistContext.ReadPointF Method (XElement)
See Also
[image]

Reads a PointF object from the specified element.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public PointF ReadPointF (
XElement element
)

Visual Basic [image] Copy Code

Public Function ReadPointF( _
element As XElement _
) As PointF

Parameters

element

Return Value

See Also

ReadPointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadRectangleF Method

XmlPersistContext.ReadRectangleF Method
[image]

Reads a RectangleF object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public RectangleF ReadRectangleF (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadRectangleF( _
elementName As String, _
parentElement As XElement _
) As RectangleF

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadSByte Method

XmlPersistContext.ReadSByte Method
[image]

Reads a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public sbyte ReadSByte (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSByte( _
elementName As String, _
parentElement As XElement _
) As SByte

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadShort Method

XmlPersistContext.ReadShort Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadShort (String, XElement) | Reads a short value with the specified name.
XmlPersistContext.ReadShort (String, XElement, Int16) | Reads a short value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadShort Method (String, XElement)

XmlPersistContext.ReadShort Method (String, XElement)
See Also
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As String, _
parentElement As XElement _
) As Short

Parameters

elementName

parentElement

Return Value

See Also

ReadShort Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadShort Method (String, XElement, Int16)

XmlPersistContext.ReadShort Method (String, XElement, Int16)
See Also
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XElement parentElement,
short defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As String, _
parentElement As XElement, _
defaultValue As Short _
) As Short

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadShort Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadSizeF Method

XmlPersistContext.ReadSizeF Method
[image]

Reads a SizeF object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public SizeF ReadSizeF (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSizeF( _
elementName As String, _
parentElement As XElement _
) As SizeF

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadStream Method

XmlPersistContext.ReadStream Method
[image]

Reads a stream with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Stream ReadStream (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStream( _
elementName As String, _
parentElement As XElement _
) As Stream

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadString Method

XmlPersistContext.ReadString Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadString (String, XElement) | Reads a string value with the specified name.
XmlPersistContext.ReadString (String, XElement, String) | Reads a string value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadString Method (String, XElement)

XmlPersistContext.ReadString Method (String, XElement)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XElement _
) As String

Parameters

elementName

parentElement

Return Value

See Also

ReadString Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadString Method (String, XElement, String)

XmlPersistContext.ReadString Method (String, XElement, String)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XElement parentElement,
string defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XElement, _
defaultValue As String _
) As String

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadString Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadStringFormat Method

XmlPersistContext.ReadStringFormat Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadStringFormat (String, XElement) | Reads a StringFormat object with the specified name.
XmlPersistContext.ReadStringFormat (String, XElement, StringFormat) | Reads a StringFormat object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadStringFormat Method (String, XElement)

XmlPersistContext.ReadStringFormat Method (String, XElement)
See Also
[image]

Reads a StringFormat object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public StringFormat ReadStringFormat (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStringFormat( _
elementName As String, _
parentElement As XElement _
) As StringFormat

Parameters

elementName

parentElement

Return Value

See Also

ReadStringFormat Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadStringFormat Method (String, XElement, StringFormat)

XmlPersistContext.ReadStringFormat Method (String, XElement, StringFormat)
See Also
[image]

Reads a StringFormat object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public StringFormat ReadStringFormat (
string elementName,
XElement parentElement,
StringFormat defultFormat
)

Visual Basic [image] Copy Code

Public Function ReadStringFormat( _
elementName As String, _
parentElement As XElement, _
defultFormat As StringFormat _
) As StringFormat

Parameters

elementName

parentElement

defultFormat

Return Value

See Also

ReadStringFormat Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadThickness Method

XmlPersistContext.ReadThickness Method
[image]

Reads a Thickness object with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public Thickness ReadThickness (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadThickness( _
elementName As String, _
parentElement As XElement _
) As Thickness

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadUInt Method

XmlPersistContext.ReadUInt Method
[image]

Reads an unsigned integer value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public uint ReadUInt (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUInt( _
elementName As String, _
parentElement As XElement _
) As UInteger

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadULong Method

XmlPersistContext.ReadULong Method
[image]

Reads an unsigned long value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public ulong ReadULong (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadULong( _
elementName As String, _
parentElement As XElement _
) As ULong

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.ReadUShort Method

XmlPersistContext.ReadUShort Method
[image]

Reads an unsigned short value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public ushort ReadUShort (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUShort( _
elementName As String, _
parentElement As XElement _
) As UShort

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteBool Method

XmlPersistContext.WriteBool Method
[image]

Writes a boolean value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteBool (
bool boolValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBool( _
boolValue As Boolean, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

boolValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteBrush Method

XmlPersistContext.WriteBrush Method
[image]

Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteBrush (
Brush brush,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrush( _
brush As Brush, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

brush

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteBrushList Method

XmlPersistContext.WriteBrushList Method
[image]

Writes the specified brushes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteBrushList (
IList<Brush> list,
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrushList( _
list As IList(Of Brush), _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As XElement

Parameters

list

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteByte Method

XmlPersistContext.WriteByte Method
[image]

Write a byte value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteByte (
byte byteValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteByte( _
byteValue As Byte, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

byteValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteChar Method

XmlPersistContext.WriteChar Method
[image]

Write a char value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteChar (
char charValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteChar( _
charValue As Char, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

charValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteColor Method

XmlPersistContext.WriteColor Method
[image]

Writes the specified color.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteColor (
Color color,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColor( _
color As Color, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

color

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteColorArray Method

XmlPersistContext.WriteColorArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteColorArray (
Color[] array,
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColorArray( _
array() As Color, _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As XElement

Parameters

array

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteDecimal Method

XmlPersistContext.WriteDecimal Method
[image]

Write a decimal value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteDecimal (
decimal decimalValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDecimal( _
decimalValue As Decimal, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

decimalValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteDictionary Method

XmlPersistContext.WriteDictionary Method
[image]

Writes the specified dictionary.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteDictionary (
IDictionary dictionary,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDictionary( _
dictionary As IDictionary, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

dictionary

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteDouble Method

XmlPersistContext.WriteDouble Method
[image]

Overload List

Name | Description
XmlPersistContext.WriteDouble (Double, String, XElement) | Writes a double value with the specified name.
XmlPersistContext.WriteDouble (Nullable(Double), String, XElement) | Writes a nullable double value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteDouble Method (Double, String, XElement)

XmlPersistContext.WriteDouble Method (Double, String, XElement)
See Also
[image]

Writes a double value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteDouble (
double doubleValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDouble( _
doubleValue As Double, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

doubleValue

elementName

parentElement

Return Value

See Also

WriteDouble Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteDouble Method (Nullable(Double), String, XElement)

XmlPersistContext.WriteDouble Method (Nullable(Double), String, XElement)
See Also
[image]

Writes a nullable double value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteDouble (
Nullable<Double> doubleValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDouble( _
doubleValue As Nullable(Of Double), _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

doubleValue

elementName

parentElement

Return Value

See Also

WriteDouble Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteDoubleList Method

XmlPersistContext.WriteDoubleList Method
[image]

Writes the specified list of doubles.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteDoubleList (
IList<Double> list,
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDoubleList( _
list As IList(Of Double), _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As XElement

Parameters

list

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteEnum Method

XmlPersistContext.WriteEnum Method
[image]

Writes the specified enum value.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteEnum (
Object enumValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEnum( _
enumValue As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

enumValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteFloat Method

XmlPersistContext.WriteFloat Method
[image]

Writes a float value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteFloat (
float floatValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloat( _
floatValue As Single, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

floatValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteFloatArray Method

XmlPersistContext.WriteFloatArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteFloatArray (
float[] array,
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloatArray( _
array() As Single, _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As XElement

Parameters

array

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteFont Method

XmlPersistContext.WriteFont Method
[image]

Writes the specified font.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteFont (
Font font,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFont( _
font As Font, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

font

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteImage Method

XmlPersistContext.WriteImage Method
[image]

Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteImage (
Image image,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteImage( _
image As Image, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

image

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteInt Method

XmlPersistContext.WriteInt Method
[image]

Writes an integer value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteInt (
int intValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteInt( _
intValue As Integer, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

intValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteLong Method

XmlPersistContext.WriteLong Method
[image]

Writes a long value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteLong (
long longValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteLong( _
longValue As Long, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

longValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteObject Method

XmlPersistContext.WriteObject Method
[image]

Writes the specified object under the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteObject (
Object objectValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteObject( _
objectValue As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

objectValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WritePen Method

XmlPersistContext.WritePen Method
[image]

Writes the specified pen.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WritePen (
Pen pen,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePen( _
pen As Pen, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

pen

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WritePointF Method

XmlPersistContext.WritePointF Method
[image]

Overload List

Name | Description
XmlPersistContext.WritePointF (PointF, String, XElement) | Writes a PointF with the specified name.
XmlPersistContext.WritePointF (Single, Single, String, XElement) | Writes the specified PointF under the specified name. The x and y components of the point are written as attributes.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WritePointF Method (PointF, String, XElement)

XmlPersistContext.WritePointF Method (PointF, String, XElement)
See Also
[image]

Writes a PointF with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WritePointF (
PointF point,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointF( _
point As PointF, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

point

elementName

parentElement

Return Value

See Also

WritePointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WritePointF Method (Single, Single, String, XElement)

XmlPersistContext.WritePointF Method (Single, Single, String, XElement)
See Also
[image]

Writes the specified PointF under the specified name. The x and y components of the point are written as attributes.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WritePointF (
float x,
float y,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointF( _
x As Single, _
y As Single, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

x

y

elementName

parentElement

Return Value

See Also

WritePointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteRectangleF Method

XmlPersistContext.WriteRectangleF Method
[image]

Writes a RectangleF with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteRectangleF (
RectangleF rectangle,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteRectangleF( _
rectangle As RectangleF, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

rectangle

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteSByte Method

XmlPersistContext.WriteSByte Method
[image]

Write a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteSByte (
sbyte byteValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSByte( _
byteValue As SByte, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

byteValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteShort Method

XmlPersistContext.WriteShort Method
[image]

Writes a short value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteShort (
short shortValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShort( _
shortValue As Short, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

shortValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteSizeF Method

XmlPersistContext.WriteSizeF Method
[image]

Writes a SizeF with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteSizeF (
SizeF size,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSizeF( _
size As SizeF, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

size

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteStream Method

XmlPersistContext.WriteStream Method
[image]

Writes the specified stream.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteStream (
Stream stream,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStream( _
stream As Stream, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

stream

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteString Method

XmlPersistContext.WriteString Method
[image]

Writes a string value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteString (
string stringValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteString( _
stringValue As String, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

stringValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteStringFormat Method

XmlPersistContext.WriteStringFormat Method
[image]

Writes the specified StringFormat object.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteStringFormat (
StringFormat stringFormat,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStringFormat( _
stringFormat As StringFormat, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

stringFormat

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteThickness Method

XmlPersistContext.WriteThickness Method
[image]

Writes a Thickness with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteThickness (
Thickness thickness,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteThickness( _
thickness As Thickness, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

thickness

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteUInt Method

XmlPersistContext.WriteUInt Method
[image]

Writes an unsigned integer value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteUInt (
uint uintValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUInt( _
uintValue As UInteger, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

uintValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteULong Method

XmlPersistContext.WriteULong Method
[image]

Writes an unsigned long value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteULong (
ulong ulongValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteULong( _
ulongValue As ULong, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

ulongValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.WriteUShort Method

XmlPersistContext.WriteUShort Method
[image]

Writes an unsigned short value with the specified name.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XElement WriteUShort (
ushort ushortValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUShort( _
ushortValue As UShort, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

ushortValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext Properties

XmlPersistContext Properties
[image]

Public Properties

Name | Description
FileVersion | Gets the format revision number for the file being currently serialized.
IncludeUnalteredProperties | Gets or sets a value specifies whether properties that have their default value should be serialized to XML.
XmlDocument | Gets the underlying XML document.

See Also

XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.FileVersion Property

XmlPersistContext.FileVersion Property
[image]

Gets the format revision number for the file being currently serialized.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int FileVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FileVersion As Integer

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.IncludeUnalteredProperties Property

XmlPersistContext.IncludeUnalteredProperties Property
[image]

Gets or sets a value specifies whether properties that have their default value should be serialized to XML.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IncludeUnalteredProperties { get; set; }

Visual Basic [image] Copy Code

Public Property IncludeUnalteredProperties As Boolean

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlPersistContext.XmlDocument Property

XmlPersistContext.XmlDocument Property
[image]

Gets the underlying XML document.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XDocument XmlDocument { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XmlDocument As XDocument

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries Class

XmlSeries Class
[image]

Represents a series whose data items are retrieved from an XML document.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class XmlSeries : Series

Visual Basic [image] Copy Code

Public Class XmlSeries
Implements Series

Inheritance Hierarchy

System.Object
MindFusion.Charting.XmlSeries

See Also

XmlSeries Members
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries Members

XmlSeries Members
Constructors Properties Methods Events
[image]

Represents a series whose data items are retrieved from an XML document.

The following tables list the members exposed by the XmlSeries type.

Public Constructors

Name | Description
XmlSeries | Overloaded.

Public Properties

Name | Description
Dimensions | Implements Series.Dimensions. Returns the number of X/Y/ZDataPath properties set.
InnerLabelsPath | Gets or sets the XPath expression identifying inner data labels.
OuterLabelsPath | Gets or sets the XPath expression identifying outer data labels.
Size | Implements Series.Size. Gets the number of data items in the XML document.
SupportedLabels | Implements Series.SupportedLabels. Result depends on which *LabelsPath properties are set.
Title | Implements Series.Title. Gets or sets the title of this series.
ToolTipsPath | Gets or sets the XPath expression identifying tooltips.
XAxisLabelsPath | Gets or sets the XPath expression identifying X axis labels.
XDataPath | Gets or sets the XPath expression identifying data coordinates in first dimension.
YAxisLabelsPath | Gets or sets the XPath expression identifying Y axis labels.
YDataPath | Gets or sets the XPath expression identifying data coordinates in second dimension.
ZAxisLabelsPath | Gets or sets the XPath expression identifying Z axis labels.
ZDataPath | Gets or sets the XPath expression identifying data coordinates in third dimension.

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns a label for the specified data item in the XML document.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in the XML document.
IsEmphasized | Implements Series.IsEmphasized. XmlSeries always returns false.
IsSorted | Implements Series.IsSorted. XmlSeries always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries Constructor

XmlSeries Constructor
[image]

Overload List

Name | Description
XmlSeries (XmlDocument, String) | Initializes a new instance of the XmlSeries class.
XmlSeries (XmlDocument, String, String) | Initializes a new instance of the XmlSeries class.
XmlSeries (XmlDocument, String, String, String, String, String, String, String, String, String) | Initializes a new instance of the XmlSeries class.

See Also

XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries Constructor (XmlDocument, String)

XmlSeries Constructor (XmlDocument, String)
See Also
[image]

Initializes a new instance of the XmlSeries class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XmlSeries (
XmlDocument document,
string xDataXPath
)

Visual Basic [image] Copy Code

Public New ( _
document As XmlDocument, _
xDataXPath As String _
)

Parameters

document

An XmlDocument instance.

xDataXPath

An XPath string identifying data item coordinates in first dimension.

See Also

XmlSeries Constructor Overload List
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries Constructor (XmlDocument, String, String)

XmlSeries Constructor (XmlDocument, String, String)
See Also
[image]

Initializes a new instance of the XmlSeries class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XmlSeries (
XmlDocument document,
string xDataXPath,
string yDataXPath
)

Visual Basic [image] Copy Code

Public New ( _
document As XmlDocument, _
xDataXPath As String, _
yDataXPath As String _
)

Parameters

document

An XmlDocument instance.

xDataXPath

An XPath string identifying data item coordinates in first dimension.

yDataXPath

An XPath string identifying data item coordinates in second dimension.

See Also

XmlSeries Constructor Overload List
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries Constructor (XmlDocument, String, String, String, String, String, String, String, String, String)

XmlSeries Constructor (XmlDocument, String, String, String, String, String, String, String, String, String)
See Also
[image]

Initializes a new instance of the XmlSeries class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public XmlSeries (
XmlDocument document,
string xDataXPath,
string yDataXPath,
string zDataXPath,
string innerLabelsXPath,
string outerLabelsXPath,
string tooltipsXPath,
string xAxisLabelsXPath,
string yAxisLabelsXPath,
string zAxisLabelsXPath
)

Visual Basic [image] Copy Code

Public New ( _
document As XmlDocument, _
xDataXPath As String, _
yDataXPath As String, _
zDataXPath As String, _
innerLabelsXPath As String, _
outerLabelsXPath As String, _
tooltipsXPath As String, _
xAxisLabelsXPath As String, _
yAxisLabelsXPath As String, _
zAxisLabelsXPath As String _
)

Parameters

document

An XmlDocument instance.

xDataXPath

An XPath string identifying data item coordinates in first dimension.

yDataXPath

An XPath string identifying data item coordinates in second dimension.

zDataXPath

An XPath string identifying data item coordinates in third dimension.

innerLabelsXPath

An XPath string identifying inner data labels.

outerLabelsXPath

An XPath string identifying outer data labels.

tooltipsXPath

An XPath string identifying tooltips.

xAxisLabelsXPath

An XPath string identifying X axis labels.

yAxisLabelsXPath

An XPath string identifying Y axis labels.

zAxisLabelsXPath

An XPath string identifying Z axis labels.

See Also

XmlSeries Constructor Overload List
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries Methods

XmlSeries Methods
[image]

Public Methods

Name | Description
GetLabel | Implements Series.GetLabel. Returns a label for the specified data item in the XML document.
GetValue | Implements Series.GetValue. Returns a value for the specified data item in the XML document.
IsEmphasized | Implements Series.IsEmphasized. XmlSeries always returns false.
IsSorted | Implements Series.IsSorted. XmlSeries always returns false.

Protected Methods

Name | Description
OnDataChanged | Raises the DataChanged event.

See Also

XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.GetLabel Method

XmlSeries.GetLabel Method
[image]

Implements Series.GetLabel. Returns a label for the specified data item in the XML document.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string GetLabel (
int index,
LabelKinds kind
)

Visual Basic [image] Copy Code

Public Function GetLabel( _
index As Integer, _
kind As LabelKinds _
) As String

Parameters

index

An integer value specifying the index of a data item.

kind

A member of the LabelKinds enumeration.

Return Value

A string containing the item's label.

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.GetValue Method

XmlSeries.GetValue Method
[image]

Implements Series.GetValue. Returns a value for the specified data item in the XML document.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public double GetValue (
int index,
int dimension
)

Visual Basic [image] Copy Code

Public Function GetValue( _
index As Integer, _
dimension As Integer _
) As Double

Parameters

index

An integer value specifying the index of a data item.

dimension

An integer value specifying the dimension whose coordinate to return.

Return Value

A double-precision number representing the value of a data item in the XML document.

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.IsEmphasized Method

XmlSeries.IsEmphasized Method
[image]

Implements Series.IsEmphasized. XmlSeries always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsEmphasized (
int index
)

Visual Basic [image] Copy Code

Public Function IsEmphasized( _
index As Integer _
) As Boolean

Parameters

index

An integer value specifying the index of a data item.

Return Value

true to emphasize the specified data item, or false otherwise.

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.IsSorted Method

XmlSeries.IsSorted Method
[image]

Implements Series.IsSorted. XmlSeries always returns false.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool IsSorted (
int dimension
)

Visual Basic [image] Copy Code

Public Function IsSorted( _
dimension As Integer _
) As Boolean

Parameters

dimension

An integer value identifying the dimension.

Return Value

true if the values are sorted in specified dimension, or false otherwise.

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.OnDataChanged Method

XmlSeries.OnDataChanged Method
[image]

Raises the DataChanged event.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected virtual void OnDataChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnDataChanged ()

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries Properties

XmlSeries Properties
[image]

Public Properties

Name | Description
Dimensions | Implements Series.Dimensions. Returns the number of X/Y/ZDataPath properties set.
InnerLabelsPath | Gets or sets the XPath expression identifying inner data labels.
OuterLabelsPath | Gets or sets the XPath expression identifying outer data labels.
Size | Implements Series.Size. Gets the number of data items in the XML document.
SupportedLabels | Implements Series.SupportedLabels. Result depends on which *LabelsPath properties are set.
Title | Implements Series.Title. Gets or sets the title of this series.
ToolTipsPath | Gets or sets the XPath expression identifying tooltips.
XAxisLabelsPath | Gets or sets the XPath expression identifying X axis labels.
XDataPath | Gets or sets the XPath expression identifying data coordinates in first dimension.
YAxisLabelsPath | Gets or sets the XPath expression identifying Y axis labels.
YDataPath | Gets or sets the XPath expression identifying data coordinates in second dimension.
ZAxisLabelsPath | Gets or sets the XPath expression identifying Z axis labels.
ZDataPath | Gets or sets the XPath expression identifying data coordinates in third dimension.

See Also

XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.Dimensions Property

XmlSeries.Dimensions Property
[image]

Implements Series.Dimensions. Returns the number of X/Y/ZDataPath properties set.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Dimensions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dimensions As Integer

Property Value

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.InnerLabelsPath Property

XmlSeries.InnerLabelsPath Property
[image]

Gets or sets the XPath expression identifying inner data labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string InnerLabelsPath { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelsPath As String

Property Value

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.OuterLabelsPath Property

XmlSeries.OuterLabelsPath Property
[image]

Gets or sets the XPath expression identifying outer data labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string OuterLabelsPath { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelsPath As String

Property Value

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.Size Property

XmlSeries.Size Property
[image]

Implements Series.Size. Gets the number of data items in the XML document.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public int Size { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Size As Integer

Property Value

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.SupportedLabels Property

XmlSeries.SupportedLabels Property
[image]

Implements Series.SupportedLabels. Result depends on which *LabelsPath properties are set.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public LabelKinds SupportedLabels { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SupportedLabels As LabelKinds

Property Value

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.Title Property

XmlSeries.Title Property
[image]

Implements Series.Title. Gets or sets the title of this series.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.ToolTipsPath Property

XmlSeries.ToolTipsPath Property
[image]

Gets or sets the XPath expression identifying tooltips.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string ToolTipsPath { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTipsPath As String

Property Value

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.XAxisLabelsPath Property

XmlSeries.XAxisLabelsPath Property
[image]

Gets or sets the XPath expression identifying X axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string XAxisLabelsPath { get; set; }

Visual Basic [image] Copy Code

Public Property XAxisLabelsPath As String

Property Value

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.XDataPath Property

XmlSeries.XDataPath Property
[image]

Gets or sets the XPath expression identifying data coordinates in first dimension.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string XDataPath { get; set; }

Visual Basic [image] Copy Code

Public Property XDataPath As String

Property Value

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.YAxisLabelsPath Property

XmlSeries.YAxisLabelsPath Property
[image]

Gets or sets the XPath expression identifying Y axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string YAxisLabelsPath { get; set; }

Visual Basic [image] Copy Code

Public Property YAxisLabelsPath As String

Property Value

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.YDataPath Property

XmlSeries.YDataPath Property
[image]

Gets or sets the XPath expression identifying data coordinates in second dimension.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string YDataPath { get; set; }

Visual Basic [image] Copy Code

Public Property YDataPath As String

Property Value

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.ZAxisLabelsPath Property

XmlSeries.ZAxisLabelsPath Property
[image]

Gets or sets the XPath expression identifying Z axis labels.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string ZAxisLabelsPath { get; set; }

Visual Basic [image] Copy Code

Public Property ZAxisLabelsPath As String

Property Value

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.ZDataPath Property

XmlSeries.ZDataPath Property
[image]

Gets or sets the XPath expression identifying data coordinates in third dimension.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public string ZDataPath { get; set; }

Visual Basic [image] Copy Code

Public Property ZDataPath As String

Property Value

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries Events

XmlSeries Events
[image]

Public Events

Name | Description
DataChanged | Implements Series.DataChanged. Raised when the values in this series change.

See Also

XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.XmlSeries.DataChanged Event

XmlSeries.DataChanged Event
[image]

Implements Series.DataChanged. Raised when the values in this series change.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

See Also

XmlSeries Members
XmlSeries Class
MindFusion.Charting Namespace


MindFusion.Charting.YAxisRenderer Class

YAxisRenderer Class
Remarks See Also
[image]

A Component that renders vertical Axis ranges.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class YAxisRenderer : AxisRenderer

Visual Basic [image] Copy Code

Public Class YAxisRenderer
Inherits AxisRenderer

Remarks

If the Axis property of this renderer is not set, it will search for Axis instances assigned to YAxis property of Plot2D or BiaxialChart in current RenderContext.

YAxisRenderer is not aware of the location of Plot components that display graphics on same Axis, and will not match series coordinates correctly if the plots are not vertically aligned with the YAxisRenderer. You can ensure the axis renderer and plots are aligned by placing them in same horizontal StackPanel, or in same row of a GridPanel.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Components.Component
MindFusion.Charting.AxisRenderer
MindFusion.Charting.YAxisRenderer

See Also

YAxisRenderer Members
MindFusion.Charting Namespace


MindFusion.Charting.YAxisRenderer Members

YAxisRenderer Members
Constructors Properties Methods
[image]

A Component that renders vertical Axis ranges.

The following tables list the members exposed by the YAxisRenderer type.

Public Constructors

Name | Description
YAxisRenderer | Overloaded.

Public Properties

Name | Description
Axis | The Axis that will be drawn by this object. (Inherited from AxisRenderer.)
AxisStroke | Gets or sets the Brush that should be used to draw axis lines. (Inherited from AxisRenderer.)
AxisStrokeDashStyle | Gets or sets the dash style axis lines should be stroked with. (Inherited from AxisRenderer.)
AxisStrokeThickness | Gets or sets the thickness axis lines should be stroked with. (Inherited from AxisRenderer.)
LabelBrush | Gets or sets the Brush that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelPadding | Gets or sets the padding space between the axis line and coordinate labels. (Inherited from AxisRenderer.)
LabelsSource | Gets or sets the object whose Series labels should be rendered along this axis. (Inherited from AxisRenderer.)
PinLabels | Gets or sets a value indicating whether coordinate labels should be pinned in place or scroll together with the plot when users pan it. (Inherited from AxisRenderer.)
PlotLeftSide | Gets or sets whether this YAxisRenderer is shown at the left side of a plot.
ShowCoordinates | Gets or sets a value indicating whether this AxisRenderer should draw axis coordinates. (Inherited from AxisRenderer.)
ShowSeriesLabels | Gets or sets a value indicating whether this AxisRenderer should draw data labels. (Inherited from AxisRenderer.)
ShowTicks | Gets or sets a value indicating whether this AxisRenderer should draw axis ticks. (Inherited from AxisRenderer.)
TickLength | Gets or sets the length of the axis ticks. (Inherited from AxisRenderer.)
TitleBrush | Gets or sets the Brush that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontName | Gets or sets the name of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontSize | Gets or sets the size of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontStyle | Gets or sets the style of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)

Public Methods

Name | Description
Draw | Component.Draw override. Draws this component in specified RenderContext.
Measure | Component.Measure override. Measures the desired size of this component.

Protected Methods

Name | Description
EffectiveAxis | AxisRenderer.EffectiveAxis override. Gets the effective vertical Axis in current context, getting one from Plot2D or chart control if there's no local Axis associated with this renderer.
EffectiveAxisDashStyle | Gets the dash style of axis line strokes. (Inherited from AxisRenderer.)
EffectiveAxisStroke | Gets the Brush that should be used to stroke axis lines. (Inherited from AxisRenderer.)
EffectiveAxisStrokeThickness | Gets the thickness of axis line strokes. (Inherited from AxisRenderer.)
EffectiveLabelBrush | Gets the Brush that should be used to draw axis labels. (Inherited from AxisRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw axis labels. (Inherited from AxisRenderer.)
EffectivePen | Gets the Pen that should be used to draw axis lines. (Inherited from AxisRenderer.)
EffectiveTitleBrush | Gets the Brush that should be used to draw the axis Title. (Inherited from AxisRenderer.)
EffectiveTitleFont | Gets the Font that should be used to draw the axis Title. (Inherited from AxisRenderer.)

See Also

YAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.YAxisRenderer Constructor

YAxisRenderer Constructor
[image]

Overload List

Name | Description
YAxisRenderer (Axis) | Initializes a new instance of the YAxisRenderer class.
YAxisRenderer (Axis, Axis) | Initializes a new instance of the YAxisRenderer class.

See Also

YAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.YAxisRenderer Constructor (Axis)

YAxisRenderer Constructor (Axis)
See Also
[image]

Initializes a new instance of the YAxisRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public YAxisRenderer (
Axis axis
)

Visual Basic [image] Copy Code

Public New ( _
axis As Axis _
)

Parameters

axis

The Axis that will be drawn by this object.

See Also

YAxisRenderer Constructor Overload List
YAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.YAxisRenderer Constructor (Axis, Axis)

YAxisRenderer Constructor (Axis, Axis)
See Also
[image]

Initializes a new instance of the YAxisRenderer class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public YAxisRenderer (
Axis axis,
Axis xAxis
)

Visual Basic [image] Copy Code

Public New ( _
axis As Axis, _
xAxis As Axis _
)

Parameters

axis

The Axis that will be drawn by this object.

xAxis

The Axis used to check data item visibility.

See Also

YAxisRenderer Constructor Overload List
YAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.YAxisRenderer Methods

YAxisRenderer Methods
[image]

Public Methods

Name | Description
Draw | Component.Draw override. Draws this component in specified RenderContext.
Measure | Component.Measure override. Measures the desired size of this component.

Protected Methods

Name | Description
EffectiveAxis | AxisRenderer.EffectiveAxis override. Gets the effective vertical Axis in current context, getting one from Plot2D or chart control if there's no local Axis associated with this renderer.
EffectiveAxisDashStyle | Gets the dash style of axis line strokes. (Inherited from AxisRenderer.)
EffectiveAxisStroke | Gets the Brush that should be used to stroke axis lines. (Inherited from AxisRenderer.)
EffectiveAxisStrokeThickness | Gets the thickness of axis line strokes. (Inherited from AxisRenderer.)
EffectiveLabelBrush | Gets the Brush that should be used to draw axis labels. (Inherited from AxisRenderer.)
EffectiveLabelFont | Gets the Font that should be used to draw axis labels. (Inherited from AxisRenderer.)
EffectivePen | Gets the Pen that should be used to draw axis lines. (Inherited from AxisRenderer.)
EffectiveTitleBrush | Gets the Brush that should be used to draw the axis Title. (Inherited from AxisRenderer.)
EffectiveTitleFont | Gets the Font that should be used to draw the axis Title. (Inherited from AxisRenderer.)

See Also

YAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.YAxisRenderer.Draw Method

YAxisRenderer.Draw Method
[image]

Component.Draw override. Draws this component in specified RenderContext.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void Draw (
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
context As RenderContext _
)

Parameters

context

A RenderContext instance.

See Also

YAxisRenderer Members
YAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.YAxisRenderer.EffectiveAxis Method

YAxisRenderer.EffectiveAxis Method
[image]

AxisRenderer.EffectiveAxis override. Gets the effective vertical Axis in current context, getting one from Plot2D or chart control if there's no local Axis associated with this renderer.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

protected override Axis EffectiveAxis (
RenderContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function EffectiveAxis( _
context As RenderContext _
) As Axis

Parameters

context

A RenderContext instance.

Return Value

An Axis instance.

See Also

YAxisRenderer Members
YAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.YAxisRenderer.Measure Method

YAxisRenderer.Measure Method
[image]

Component.Measure override. Measures the desired size of this component.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void Measure (
double maxWidth,
double maxHeight,
RenderContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub Measure( _
maxWidth As Double, _
maxHeight As Double, _
context As RenderContext _
)

Parameters

maxWidth

The maximum width provided by parent component.

maxHeight

The maximum height provided by parent component.

context

A RenderContext instance.

See Also

YAxisRenderer Members
YAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.YAxisRenderer Properties

YAxisRenderer Properties
[image]

Public Properties

Name | Description
Axis | The Axis that will be drawn by this object. (Inherited from AxisRenderer.)
AxisStroke | Gets or sets the Brush that should be used to draw axis lines. (Inherited from AxisRenderer.)
AxisStrokeDashStyle | Gets or sets the dash style axis lines should be stroked with. (Inherited from AxisRenderer.)
AxisStrokeThickness | Gets or sets the thickness axis lines should be stroked with. (Inherited from AxisRenderer.)
LabelBrush | Gets or sets the Brush that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontName | Gets or sets the name of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontSize | Gets or sets the size of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelFontStyle | Gets or sets the style of font that should be used to draw axis labels. (Inherited from AxisRenderer.)
LabelPadding | Gets or sets the padding space between the axis line and coordinate labels. (Inherited from AxisRenderer.)
LabelsSource | Gets or sets the object whose Series labels should be rendered along this axis. (Inherited from AxisRenderer.)
PinLabels | Gets or sets a value indicating whether coordinate labels should be pinned in place or scroll together with the plot when users pan it. (Inherited from AxisRenderer.)
PlotLeftSide | Gets or sets whether this YAxisRenderer is shown at the left side of a plot.
ShowCoordinates | Gets or sets a value indicating whether this AxisRenderer should draw axis coordinates. (Inherited from AxisRenderer.)
ShowSeriesLabels | Gets or sets a value indicating whether this AxisRenderer should draw data labels. (Inherited from AxisRenderer.)
ShowTicks | Gets or sets a value indicating whether this AxisRenderer should draw axis ticks. (Inherited from AxisRenderer.)
TickLength | Gets or sets the length of the axis ticks. (Inherited from AxisRenderer.)
TitleBrush | Gets or sets the Brush that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontName | Gets or sets the name of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontSize | Gets or sets the size of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)
TitleFontStyle | Gets or sets the style of font that should be used to draw the axis Title. (Inherited from AxisRenderer.)

See Also

YAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.YAxisRenderer.PlotLeftSide Property

YAxisRenderer.PlotLeftSide Property
[image]

Gets or sets whether this YAxisRenderer is shown at the left side of a plot.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public bool PlotLeftSide { get; set; }

Visual Basic [image] Copy Code

Public Property PlotLeftSide As Boolean

Property Value

See Also

YAxisRenderer Members
YAxisRenderer Class
MindFusion.Charting Namespace


MindFusion.Charting.ZoomController Class

ZoomController Class
[image]

Represents a controller that zooms into plot's data range.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public class ZoomController : Plot2DController

Visual Basic [image] Copy Code

Public Class ZoomController
Inherits Plot2DController

Inheritance Hierarchy

System.Object
MindFusion.Charting.PlotController
MindFusion.Charting.Plot2DController
MindFusion.Charting.ZoomController

See Also

ZoomController Members
MindFusion.Charting Namespace


MindFusion.Charting.ZoomController Members

ZoomController Members
Constructors Fields Properties Methods
[image]

Represents a controller that zooms into plot's data range.

The following tables list the members exposed by the ZoomController type.

Public Constructors

Name | Description
ZoomController | Initializes a new instance of the ZoomController class.

Protected Fields

Name | Description
axisRanges | Contains information about Axis ranges processed by this controller. (Inherited from Plot2DController.)
renderContext | The current RenderContext. (Inherited from PlotController.)

Public Properties

Name | Description
Component | Gets the component controlled by this PlotController. (Inherited from PlotController.)
Vertical | Gets or sets a value indicating whether interaction is done along the X or Y axis. (Inherited from Plot2DController.)

Public Methods

Name | Description
DrawInteraction | PlotController.DrawInteraction override. Draws the currently selected data range that that controller will zoom into when the user releases the mouse button.
GetRunningAnimation | For internal use. (Inherited from PlotController.)
OnMouseDown | Plot2DController.OnMouseDown override. Called when the user presses a mouse button.
OnMouseMove | PlotController.OnMouseMove override. Called when the user moves the mouse.
OnMouseUp | PlotController.OnMouseUp override. Called when the user releases a mouse button.

Protected Methods

Name | Description
PlotToAxisValue | Converts a plot pixel position to a logical value from specified axis' coordinate system. (Inherited from Plot2DController.)

See Also

ZoomController Class
MindFusion.Charting Namespace


MindFusion.Charting.ZoomController Constructor

ZoomController Constructor
[image]

Initializes a new instance of the ZoomController class.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public ZoomController (
RenderContext renderContext,
bool vertical
)

Visual Basic [image] Copy Code

Public New ( _
renderContext As RenderContext, _
vertical As Boolean _
)

Parameters

renderContext

A RenderContext instance.

vertical

true to implement interaction along the Y axis, or false for the X axis.

See Also

ZoomController Class
MindFusion.Charting Namespace


MindFusion.Charting.ZoomController Methods

ZoomController Methods
[image]

Public Methods

Name | Description
DrawInteraction | PlotController.DrawInteraction override. Draws the currently selected data range that that controller will zoom into when the user releases the mouse button.
GetRunningAnimation | For internal use. (Inherited from PlotController.)
OnMouseDown | Plot2DController.OnMouseDown override. Called when the user presses a mouse button.
OnMouseMove | PlotController.OnMouseMove override. Called when the user moves the mouse.
OnMouseUp | PlotController.OnMouseUp override. Called when the user releases a mouse button.

Protected Methods

Name | Description
PlotToAxisValue | Converts a plot pixel position to a logical value from specified axis' coordinate system. (Inherited from Plot2DController.)

See Also

ZoomController Class
MindFusion.Charting Namespace


MindFusion.Charting.ZoomController.DrawInteraction Method

ZoomController.DrawInteraction Method
[image]

PlotController.DrawInteraction override. Draws the currently selected data range that that controller will zoom into when the user releases the mouse button.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void DrawInteraction (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawInteraction( _
graphics As IGraphics _
)

Parameters

graphics

An IGraphics instance.

See Also

ZoomController Members
ZoomController Class
MindFusion.Charting Namespace


MindFusion.Charting.ZoomController.OnMouseDown Method

ZoomController.OnMouseDown Method
[image]

Plot2DController.OnMouseDown override. Called when the user presses a mouse button.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void OnMouseDown (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overrides Sub OnMouseDown( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

ZoomController Members
ZoomController Class
MindFusion.Charting Namespace


MindFusion.Charting.ZoomController.OnMouseMove Method

ZoomController.OnMouseMove Method
[image]

PlotController.OnMouseMove override. Called when the user moves the mouse.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void OnMouseMove (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overrides Sub OnMouseMove( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

ZoomController Members
ZoomController Class
MindFusion.Charting Namespace


MindFusion.Charting.ZoomController.OnMouseUp Method

ZoomController.OnMouseUp Method
[image]

PlotController.OnMouseUp override. Called when the user releases a mouse button.

Namespace: MindFusion.Charting
Assembly: MindFusion.Charting

Syntax

C# [image] Copy Code

public override void OnMouseUp (
double x,
double y
)

Visual Basic [image] Copy Code

Public Overrides Sub OnMouseUp( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the horizontal position of mouse pointer.

y

A double value specifying the vertical position of mouse pointer.

See Also

ZoomController Members
ZoomController Class
MindFusion.Charting Namespace


MindFusion.DataBinding Namespace

MindFusion.DataBinding Namespace
Classes Interfaces Enumerations

Classes

Class | Description
BoundProperty | Represents a mapping between a property and a field in the data source.
BoundPropertyList | Defines a mapping between properties and data source fields.
DataBinder | Stores or retrieves structured data to and from arbitrary collections of objects.
DataSourceTracker | Determines and manages the properties of a data source.

Interfaces

Interface | Description
BindingTarget |
IItemFactory | Provides methods for creating, adding and removing items from a collection during data-binding.
IVirtualPropertyProvider | Provides virtual properties on an object which can be data-bound.

Enumerations

Enumeration | Description
PropertyType | Specifies the way the data bound properties are interpreted.


MindFusion.DataBinding.BindingTarget Interface

BindingTarget Interface
[image]

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public interface BindingTarget

Visual Basic [image] Copy Code

Public Interface BindingTarget

Inheritors

MindFusion.Reporting.AxesChart
MindFusion.Reporting.DataRange
MindFusion.Reporting.PieChart
MindFusion.Reporting.RadarChart

See Also

BindingTarget Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BindingTarget Members

BindingTarget Members
Methods
[image]

The following tables list the members exposed by the BindingTarget type.

Public Methods

Name | Description
CollectionLoaded |

See Also

BindingTarget Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BindingTarget Methods

BindingTarget Methods
[image]

Public Methods

Name | Description
CollectionLoaded |

See Also

BindingTarget Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BindingTarget.CollectionLoaded Method

BindingTarget.CollectionLoaded Method
[image]

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

void CollectionLoaded (
IList targetItems
)

Visual Basic [image] Copy Code

Sub CollectionLoaded( _
targetItems As IList _
)

Parameters

targetItems

See Also

BindingTarget Members
BindingTarget Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty Class

BoundProperty Class
[image]

Represents a mapping between a property and a field in the data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public class BoundProperty

Visual Basic [image] Copy Code

Public Class BoundProperty

Inheritance Hierarchy

System.Object
MindFusion.DataBinding.BoundProperty

See Also

BoundProperty Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty Members

BoundProperty Members
Constructors Properties
[image]

Represents a mapping between a property and a field in the data source.

The following tables list the members exposed by the BoundProperty type.

Public Constructors

Name | Description
BoundProperty | Overloaded.

Public Properties

Name | Description
ManyToManyTable | Gets or sets the name of the associated many-to-many table.
PropertyType | Gets or sets the type of the property.
SourceMember | Gets or sets the name of the corresponding field in the data source.
TargetMember | Gets or sets the name of the bound property.

See Also

BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty Constructor

BoundProperty Constructor
[image]

Overload List

Name | Description
BoundProperty (String, String, PropertyType) | Initializes a new instance of the BoundProperty class.
BoundProperty (String, String, PropertyType, String) | Initializes a new instance of the BoundProperty class.

See Also

BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty Constructor (String, String, PropertyType)

BoundProperty Constructor (String, String, PropertyType)
See Also
[image]

Initializes a new instance of the BoundProperty class.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public BoundProperty (
string sourceMember,
string targetMember,
PropertyType propertyType
)

Visual Basic [image] Copy Code

Public New ( _
sourceMember As String, _
targetMember As String, _
propertyType As PropertyType _
)

Parameters

sourceMember

The name of the field in the data source.

targetMember

The name of the property.

propertyType

The type of the property.

See Also

BoundProperty Constructor Overload List
BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty Constructor (String, String, PropertyType, String)

BoundProperty Constructor (String, String, PropertyType, String)
See Also
[image]

Initializes a new instance of the BoundProperty class.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public BoundProperty (
string sourceMember,
string targetMember,
PropertyType propertyType,
string manyToManyTable
)

Visual Basic [image] Copy Code

Public New ( _
sourceMember As String, _
targetMember As String, _
propertyType As PropertyType, _
manyToManyTable As String _
)

Parameters

sourceMember

The name of the field in the data source.

targetMember

The name of the property.

propertyType

The type of the property.

manyToManyTable
The name of the related table in the data source when the property type is ManyToMany.

See Also

BoundProperty Constructor Overload List
BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty Properties

BoundProperty Properties
[image]

Public Properties

Name | Description
ManyToManyTable | Gets or sets the name of the associated many-to-many table.
PropertyType | Gets or sets the type of the property.
SourceMember | Gets or sets the name of the corresponding field in the data source.
TargetMember | Gets or sets the name of the bound property.

See Also

BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty.ManyToManyTable Property

BoundProperty.ManyToManyTable Property
[image]

Gets or sets the name of the associated many-to-many table.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public string ManyToManyTable { get; set; }

Visual Basic [image] Copy Code

Public Property ManyToManyTable As String

Property Value

Remarks

Only valid if the property is of type ManyToMany.

See Also

BoundProperty Members
BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty.PropertyType Property

BoundProperty.PropertyType Property
[image]

Gets or sets the type of the property.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public PropertyType PropertyType { get; set; }

Visual Basic [image] Copy Code

Public Property PropertyType As PropertyType

Property Value

A member of the PropertyType Enumeration.

See Also

BoundProperty Members
BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty.SourceMember Property

BoundProperty.SourceMember Property
[image]

Gets or sets the name of the corresponding field in the data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public string SourceMember { get; set; }

Visual Basic [image] Copy Code

Public Property SourceMember As String

Property Value

See Also

BoundProperty Members
BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundProperty.TargetMember Property

BoundProperty.TargetMember Property
[image]

Gets or sets the name of the bound property.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public string TargetMember { get; set; }

Visual Basic [image] Copy Code

Public Property TargetMember As String

Property Value

See Also

BoundProperty Members
BoundProperty Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundPropertyList Class

BoundPropertyList Class
[image]

Defines a mapping between properties and data source fields.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public class BoundPropertyList : List<BoundProperty>

Visual Basic [image] Copy Code

Public Class BoundPropertyList
Inherits List(Of BoundProperty)

Inheritance Hierarchy

System.Object
System.Collections.Generic.List(BoundProperty)
MindFusion.DataBinding.BoundPropertyList

See Also

BoundPropertyList Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundPropertyList Members

BoundPropertyList Members
Properties
[image]

Defines a mapping between properties and data source fields.

The following tables list the members exposed by the BoundPropertyList type.

Public Properties

Name | Description
IdField | Gets or sets the unique identifier field of the corresponding data member in the associated data source.

See Also

BoundPropertyList Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundPropertyList Properties

BoundPropertyList Properties
[image]

Public Properties

Name | Description
IdField | Gets or sets the unique identifier field of the corresponding data member in the associated data source.

See Also

BoundPropertyList Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.BoundPropertyList.IdField Property

BoundPropertyList.IdField Property
[image]

Gets or sets the unique identifier field of the corresponding data member in the associated data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public string IdField { get; set; }

Visual Basic [image] Copy Code

Public Property IdField As String

Property Value

See Also

BoundPropertyList Members
BoundPropertyList Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder Class

DataBinder Class
[image]

Stores or retrieves structured data to and from arbitrary collections of objects.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public class DataBinder

Visual Basic [image] Copy Code

Public Class DataBinder

Inheritance Hierarchy

System.Object
MindFusion.DataBinding.DataBinder

See Also

DataBinder Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder Members

DataBinder Members
Constructors Methods
[image]

Stores or retrieves structured data to and from arbitrary collections of objects.

The following tables list the members exposed by the DataBinder type.

Public Constructors

Name | Description
DataBinder | Initializes a new instance of the DataBinder class.

Public Methods

Name | Description
AddDataSource | Overloaded.
DataBind |
LoadSourceData |
LoadTargetData |
WriteDelayedTables |

See Also

DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder Constructor

DataBinder Constructor
[image]

Initializes a new instance of the DataBinder class.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public DataBinder (
bool keepInSync
)

Visual Basic [image] Copy Code

Public New ( _
keepInSync As Boolean _
)

Parameters

keepInSync

Specifies whether the data source and the control's data collections should be kept synchronized.

See Also

DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder Methods

DataBinder Methods
[image]

Public Methods

Name | Description
AddDataSource | Overloaded.
DataBind |
LoadSourceData |
LoadTargetData |
WriteDelayedTables |

See Also

DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.AddDataSource Method

DataBinder.AddDataSource Method
[image]

Overload List

Name | Description
DataBinder.AddDataSource (Object, String) | Adds a new data source that will be managed by this DataBinder instance.
DataBinder.AddDataSource (Object, String, Boolean) | Adds a new data source that will be managed by this DataBinder instance.

See Also

DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.AddDataSource Method (Object, String)

DataBinder.AddDataSource Method (Object, String)
See Also
[image]

Adds a new data source that will be managed by this DataBinder instance.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public DataSourceTracker AddDataSource (
Object dataSource,
string dataMember
)

Visual Basic [image] Copy Code

Public Function AddDataSource ( _
dataSource As Object, _
dataMember As String _
) As DataSourceTracker

Parameters

dataSource
A data source to be managed by this DataBinder.
dataMember

The data source member that provides the data items.

Return Value

See Also

AddDataSource Method Overload List
DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.AddDataSource Method (Object, String, Boolean)

DataBinder.AddDataSource Method (Object, String, Boolean)
See Also
[image]

Adds a new data source that will be managed by this DataBinder instance.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public DataSourceTracker AddDataSource (
Object dataSource,
string dataMember,
bool append
)

Visual Basic [image] Copy Code

Public Function AddDataSource ( _
dataSource As Object, _
dataMember As String, _
append As Boolean _
) As DataSourceTracker

Parameters

dataSource
A data source to be managed by this DataBinder.
dataMember

The data source member that provides the data items.

append

Specifies whether the tracker should be added to the end of the list. When setting-up master-details binding, the master tracker should come after the details tracker.

Return Value

See Also

AddDataSource Method Overload List
DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.DataBind Method

DataBinder.DataBind Method
[image]

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public void DataBind ()

Visual Basic [image] Copy Code

Public Sub DataBind ()

See Also

DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.LoadSourceData Method

DataBinder.LoadSourceData Method
[image]

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public void LoadSourceData ()

Visual Basic [image] Copy Code

Public Sub LoadSourceData ()

See Also

DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.LoadTargetData Method

DataBinder.LoadTargetData Method
[image]

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public void LoadTargetData (
bool delayManyToMany
)

Visual Basic [image] Copy Code

Public Sub LoadTargetData( _
delayManyToMany As Boolean _
)

Parameters

delayManyToMany

See Also

DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataBinder.WriteDelayedTables Method

DataBinder.WriteDelayedTables Method
[image]

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public void WriteDelayedTables ()

Visual Basic [image] Copy Code

Public Sub WriteDelayedTables ()

See Also

DataBinder Members
DataBinder Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker Class

DataSourceTracker Class
[image]

Determines and manages the properties of a data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public class DataSourceTracker

Visual Basic [image] Copy Code

Public Class DataSourceTracker

Inheritance Hierarchy

System.Object
MindFusion.DataBinding.DataSourceTracker

See Also

DataSourceTracker Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker Members

DataSourceTracker Members
Properties Methods Events
[image]

Determines and manages the properties of a data source.

The following tables list the members exposed by the DataSourceTracker type.

Public Properties

Name | Description
DataBinder | Gets a DataBinder object that gives access to other DataSourceTracker objects, which are needed when handling references between items from different data source collections.
IdField | Gets or sets the primary key field in a data table.
Properties | Gets a Dictionary object that maps the data source item properties to the control's item properties.
SourceItems | Gets the list of source items.
TargetContext |
TargetItems | Gets or sets the list of target items.

Public Methods

Name | Description
AddProperties |
AddProperty | Overloaded.
CreateTracker | Overloaded.
ReadSourceItems | Fills the target list with items corresponding to the source items. Attaches event listeners so the items are kept synchronized.
ReadTargetItems | Fills the source list with items corresponding to the target items. Attaches event listeners so the items are kept synchronized.
SetSourceType | Specifies what type of items should be created in the source collection when an item is added to the target collection.
SetTargetFactory | Sets the factory used to create items in the target collection or remove existing items from there.
SetTargetType | Specifies what type of items should be created in the target collection when an item is added to the source collection.

Public Events

Name | Description
BindComplete | Raised when all target items have been loaded from the data source.

See Also

DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker Methods

DataSourceTracker Methods
[image]

Public Methods

Name | Description
AddProperties |
AddProperty | Overloaded.
CreateTracker | Overloaded.
ReadSourceItems | Fills the target list with items corresponding to the source items. Attaches event listeners so the items are kept synchronized.
ReadTargetItems | Fills the source list with items corresponding to the target items. Attaches event listeners so the items are kept synchronized.
SetSourceType | Specifies what type of items should be created in the source collection when an item is added to the target collection.
SetTargetFactory | Sets the factory used to create items in the target collection or remove existing items from there.
SetTargetType | Specifies what type of items should be created in the target collection when an item is added to the source collection.

See Also

DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.AddProperties Method

DataSourceTracker.AddProperties Method
[image]

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public void AddProperties (
List<BoundProperty> properties
)

Visual Basic [image] Copy Code

Public Sub AddProperties( _
properties As List(Of BoundProperty) _
)

Parameters

properties

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.AddProperty Method

DataSourceTracker.AddProperty Method
[image]

Overload List

Name | Description
DataSourceTracker.AddProperty (String, String) | Adds a new simple value binding between the data source and the target collection.
DataSourceTracker.AddProperty (String, String, PropertyType, DataSourceTracker) | Adds a new reference binding between the data source and the target collection.

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.AddProperty Method (String, String)

DataSourceTracker.AddProperty Method (String, String)
See Also
[image]

Adds a new simple value binding between the data source and the target collection.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public void AddProperty (
string sourceMember,
string targetMember
)

Visual Basic [image] Copy Code

Public Sub AddProperty( _
sourceMember As String, _
targetMember As String _
)

Parameters

sourceMember

A member field or property of the data source.

targetMember

A corresponding member field or property of the target items.

See Also

AddProperty Method Overload List
DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.AddProperty Method (String, String, PropertyType, DataSourceTracker)

DataSourceTracker.AddProperty Method (String, String, PropertyType, DataSourceTracker)
See Also
[image]

Adds a new reference binding between the data source and the target collection.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public void AddProperty (
string sourceMember,
string targetMember,
PropertyType propertyType,
DataSourceTracker tracker
)

Visual Basic [image] Copy Code

Public Sub AddProperty ( _
sourceMember As String, _
targetMember As String, _
propertyType As PropertyType, _
tracker As DataSourceTracker _
)

Parameters

sourceMember

A member field or property of the data source.

targetMember

A corresponding member field or property of the target items.

propertyType

Specifies the type of the property.

tracker

Tracks the collection that contains the object referred by this property.

See Also

AddProperty Method Overload List
DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.CreateTracker Method

DataSourceTracker.CreateTracker Method
[image]

Overload List

Name | Description
DataSourceTracker.CreateTracker (Object, DataBinder, Boolean) | Creates a new DataSourceTracker for the provided data source.
DataSourceTracker.CreateTracker (Object, String, DataBinder, Boolean) | Creates a new DataSourceTracker for the provided data source.

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.CreateTracker Method (Object, DataBinder, Boolean)

DataSourceTracker.CreateTracker Method (Object, DataBinder, Boolean)
See Also
[image]

Creates a new DataSourceTracker for the provided data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public static DataSourceTracker CreateTracker (
Object dataSource,
DataBinder dataBinder,
bool keepInSync
)

Visual Basic [image] Copy Code

Public Shared Function CreateTracker ( _
dataSource As Object, _
dataBinder As DataBinder, _
keepInSync As Boolean _
) As DataSourceTracker

Parameters

dataSource
The data source for which a DataSourceTracker should be created.
dataBinder
A DataBinder used to get access to other DataSourceTracker objects.
keepInSync

Specifies whether the data source and the control's data collections should be kept synchronized.

Return Value

A DataSourceTracker describing the specified data source.

See Also

CreateTracker Method Overload List
DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.CreateTracker Method (Object, String, DataBinder, Boolean)

DataSourceTracker.CreateTracker Method (Object, String, DataBinder, Boolean)
See Also
[image]

Creates a new DataSourceTracker for the provided data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public static DataSourceTracker CreateTracker (
Object dataSource,
string dataMember,
DataBinder dataBinder,
bool keepInSync
)

Visual Basic [image] Copy Code

Public Shared Function CreateTracker ( _
dataSource As Object, _
dataMember As String, _
dataBinder As DataBinder, _
keepInSync As Boolean _
) As DataSourceTracker

Parameters

dataSource
The data source for which a DataSourceTracker should be created.
dataMember

The data source member that provides the data items.

dataBinder
A DataBinder used to get access to other DataSourceTracker objects.
keepInSync

Specifies whether the data source and the control's data collections should be kept synchronized.

Return Value

A DataSourceTracker describing the specified data source.

See Also

CreateTracker Method Overload List
DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.ReadSourceItems Method

DataSourceTracker.ReadSourceItems Method
[image]

Fills the target list with items corresponding to the source items. Attaches event listeners so the items are kept synchronized.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public void ReadSourceItems ()

Visual Basic [image] Copy Code

Public Sub ReadSourceItems ()

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.ReadTargetItems Method

DataSourceTracker.ReadTargetItems Method
[image]

Fills the source list with items corresponding to the target items. Attaches event listeners so the items are kept synchronized.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public void ReadTargetItems (
bool delayManyToMany
)

Visual Basic [image] Copy Code

Public Sub ReadTargetItems( _
delayManyToMany As Boolean _
)

Parameters

delayManyToMany

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.SetSourceType Method

DataSourceTracker.SetSourceType Method
[image]

Specifies what type of items should be created in the source collection when an item is added to the target collection.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public void SetSourceType (
Type type
)

Visual Basic [image] Copy Code

Public Sub SetSourceType( _
type As Type _
)

Parameters

type

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.SetTargetFactory Method

DataSourceTracker.SetTargetFactory Method
[image]

Sets the factory used to create items in the target collection or remove existing items from there.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public void SetTargetFactory (
IItemFactory factory
)

Visual Basic [image] Copy Code

Public Sub SetTargetFactory ( _
factory As IItemFactory _
)

Parameters

factory
An object implementing the IItemFactory interface.

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.SetTargetType Method

DataSourceTracker.SetTargetType Method
[image]

Specifies what type of items should be created in the target collection when an item is added to the source collection.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public void SetTargetType (
Type type
)

Visual Basic [image] Copy Code

Public Sub SetTargetType( _
type As Type _
)

Parameters

type

The type of target items.

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker Properties

DataSourceTracker Properties
[image]

Public Properties

Name | Description
DataBinder | Gets a DataBinder object that gives access to other DataSourceTracker objects, which are needed when handling references between items from different data source collections.
IdField | Gets or sets the primary key field in a data table.
Properties | Gets a Dictionary object that maps the data source item properties to the control's item properties.
SourceItems | Gets the list of source items.
TargetContext |
TargetItems | Gets or sets the list of target items.

See Also

DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.DataBinder Property

DataSourceTracker.DataBinder Property
[image]

Gets a DataBinder object that gives access to other DataSourceTracker objects, which are needed when handling references between items from different data source collections.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public DataBinder DataBinder { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DataBinder As DataBinder

Property Value

A DataBinder object.

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.IdField Property

DataSourceTracker.IdField Property
[image]

Gets or sets the primary key field in a data table.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public string IdField { get; set; }

Visual Basic [image] Copy Code

Public Property IdField As String

Property Value

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.Properties Property

DataSourceTracker.Properties Property
[image]

Gets a Dictionary object that maps the data source item properties to the control's item properties.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public Dictionary<string, List<BoundProperty>> Properties { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Properties As Dictionary(Of String, List(Of BoundProperty))

Property Value

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.SourceItems Property

DataSourceTracker.SourceItems Property
[image]

Gets the list of source items.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public IList SourceItems { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SourceItems As IList

Property Value

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.TargetContext Property

DataSourceTracker.TargetContext Property
[image]

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public string TargetContext { get; set; }

Visual Basic [image] Copy Code

Public Property TargetContext As String

Property Value

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.TargetItems Property

DataSourceTracker.TargetItems Property
[image]

Gets or sets the list of target items.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public IList TargetItems { get; set; }

Visual Basic [image] Copy Code

Public Property TargetItems As IList

Property Value

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker Events

DataSourceTracker Events
[image]

Public Events

Name | Description
BindComplete | Raised when all target items have been loaded from the data source.

See Also

DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.DataSourceTracker.BindComplete Event

DataSourceTracker.BindComplete Event
[image]

Raised when all target items have been loaded from the data source.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public event EventHandler BindComplete

Visual Basic [image] Copy Code

Public Event BindComplete As EventHandler

See Also

DataSourceTracker Members
DataSourceTracker Class
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IItemFactory Interface

IItemFactory Interface
[image]

Provides methods for creating, adding and removing items from a collection during data-binding.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public interface IItemFactory

Visual Basic [image] Copy Code

Public Interface IItemFactory

Inheritors

MindFusion.Reporting.DataRange

See Also

IItemFactory Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IItemFactory Members

IItemFactory Members
Methods
[image]

Provides methods for creating, adding and removing items from a collection during data-binding.

The following tables list the members exposed by the IItemFactory type.

Public Methods

Name | Description
AddItem | Creates a new item and adds it to the specified collection.
RemoveItem | Removes an item from the specified collection.

See Also

IItemFactory Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IItemFactory Methods

IItemFactory Methods
[image]

Public Methods

Name | Description
AddItem | Creates a new item and adds it to the specified collection.
RemoveItem | Removes an item from the specified collection.

See Also

IItemFactory Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IItemFactory.AddItem Method

IItemFactory.AddItem Method
[image]

Creates a new item and adds it to the specified collection.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

Object AddItem (
IList items
)

Visual Basic [image] Copy Code

Function AddItem( _
items As IList _
) As Object

Parameters

items

The collection where the items should be added.

Return Value

The newly created item.

See Also

IItemFactory Members
IItemFactory Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IItemFactory.RemoveItem Method

IItemFactory.RemoveItem Method
[image]

Removes an item from the specified collection.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

void RemoveItem (
IList items,
Object item
)

Visual Basic [image] Copy Code

Sub RemoveItem( _
items As IList, _
item As Object _
)

Parameters

items

The collection from which the item should be removed.

item

The item that should be removed.

See Also

IItemFactory Members
IItemFactory Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IVirtualPropertyProvider Interface

IVirtualPropertyProvider Interface
Remarks See Also
[image]

Provides virtual properties on an object which can be data-bound.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public interface IVirtualPropertyProvider

Visual Basic [image] Copy Code

Public Interface IVirtualPropertyProvider

Remarks

Implement this interface when you want to perform data-binding of a property that do not exist. For example, when the name of the data-bound property is not be available at compile time.

Inheritors

MindFusion.Reporting.BarChart
MindFusion.Reporting.Label
MindFusion.Reporting.LineChart
MindFusion.Reporting.PieChart
MindFusion.Reporting.RadarChart

See Also

IVirtualPropertyProvider Members
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IVirtualPropertyProvider Members

IVirtualPropertyProvider Members
Methods
[image]

Provides virtual properties on an object which can be data-bound.

The following tables list the members exposed by the IVirtualPropertyProvider type.

Public Methods

Name | Description
GetValue | Gets the value of the virtual property with the specified name.
SetValue | Sets the value of the specified virtual property.

See Also

IVirtualPropertyProvider Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IVirtualPropertyProvider Methods

IVirtualPropertyProvider Methods
[image]

Public Methods

Name | Description
GetValue | Gets the value of the virtual property with the specified name.
SetValue | Sets the value of the specified virtual property.

See Also

IVirtualPropertyProvider Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IVirtualPropertyProvider.GetValue Method

IVirtualPropertyProvider.GetValue Method
[image]

Gets the value of the virtual property with the specified name.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

Object GetValue (
string propertyName
)

Visual Basic [image] Copy Code

Function GetValue( _
propertyName As String _
) As Object

Parameters

propertyName

The name of the virtual property.

Return Value

The value of the virtual property.

Remarks

This method is invoked during data-binding of a property that does not exist on an object.

See Also

IVirtualPropertyProvider Members
IVirtualPropertyProvider Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.IVirtualPropertyProvider.SetValue Method

IVirtualPropertyProvider.SetValue Method
[image]

Sets the value of the specified virtual property.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

void SetValue (
string propertyName,
Object value
)

Visual Basic [image] Copy Code

Sub SetValue( _
propertyName As String, _
value As Object _
)

Parameters

propertyName

The name of the virtual property.

value

The value of the virtual property.

Remarks

This method is invoked during data-binding of a property that does not exist on an object.

See Also

IVirtualPropertyProvider Members
IVirtualPropertyProvider Interface
MindFusion.DataBinding Namespace


MindFusion.DataBinding.PropertyType Enumeration

PropertyType Enumeration
[image]

Specifies the way the data bound properties are interpreted.

Namespace: MindFusion.DataBinding
Assembly: MindFusion.DataBinding

Syntax

C# [image] Copy Code

public enum PropertyType

Visual Basic [image] Copy Code

Public Enum PropertyType

Members

Member name | Description
Collection | A collection property contains references to objects in another data-bound collection.
ManyToMany | Specifies a collection of records that is retrieved through an intermediate table that defines a many-to-many relation.
ManyToOne | The property is a foreign key identifying a record in a related table.
Reference | A reference property is one that refers to an object in another data-bound collection.
Value | A simple value property.

See Also

MindFusion.DataBinding Namespace


MindFusion.Drawing Namespace

MindFusion.Drawing Namespace
Classes Interfaces Enumerations

Classes

Class | Description
Brush | Brush objects are used to fill the interiors of geometric shapes. Brush is abstract base class inherited by SolidBrush, HatchBrush, TextureBrush, PathGradientBrush and LinearGradientBrush.
BrushCollection | A collection of MindFusion.Drawing.Brush objects.
GdiGraphics | A wrapper of the System.Drawing.Graphics class that implements the IGraphics interface.
GraphicObject | The base class for graphical objects such as pens and brushes.
HatchBrush | HatchBrush objects represent rectangular brushes with a hatch style, a foreground color, and a background color that are used to fill the interiors of geometric shapes.
LinearGradientBrush | LinearGradientBrush objects represent brushes that fill the interiors of geometric shapes with a linear gradient.
PathGradientBrush | PathGradientBrush represents a brush that fills the interiors of geometric shapes with a gradient.
Pen | Pen instances are used to draw the outline of geometric shapes.
PenCollection | A collection of MindFusion.Drawing.Pen objects.
SolidBrush | SolidBrush objects represent brushes of a single color that are used to fill the interiors of geometric shapes.
TextureBrush | TextureBrush objects represent brushes that use images to fill the interiors of geometric shapes.

Interfaces

Interface | Description
IGraphics | This interface exposes the public interface of the .NET System.Drawing.Graphics class.

Enumerations

Enumeration | Description
ImageAlign | Specifies the position and alignment of a picture relative to its destination rectangle.


MindFusion.Drawing.Brush Class

Brush Class
Remarks See Also
[image]

Brush objects are used to fill the interiors of geometric shapes. Brush is abstract base class inherited by SolidBrush, HatchBrush, TextureBrush, PathGradientBrush and LinearGradientBrush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract class Brush : GraphicObject

Visual Basic [image] Copy Code

Public MustInherit Class Brush
Inherits GraphicObject

Remarks

The Brush-derived classes act as proxies for the .NET standard GDI+ System.Drawing.Brush-derived classes. There are two reasons to use proxy classes instead the original GDI classes:

  • First, the GDI resources are limited and would be exhausted by keeping a GDI brushes all the time; by using proxies GDI brushes can be created only at the time of drawing, and immediately disposed after that.
  • Second, the GDI Brush classes do not support serialization; the proxy-classes implement the required interfaces instead.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush

See Also

Brush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Members

Brush Members
Constructors Methods
[image]

Brush objects are used to fill the interiors of geometric shapes. Brush is abstract base class inherited by SolidBrush, HatchBrush, TextureBrush, PathGradientBrush and LinearGradientBrush.

The following tables list the members exposed by the Brush type.

Protected Constructors

Name | Description
Brush | Initializes a new instance of the Brush class.

Public Methods

Name | Description
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.
Deserialize | Creates and returns a new brush according to its string representation.
Serialize | Serializes the specified brush to a string.

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Constructor

Brush Constructor
[image]

Initializes a new instance of the Brush class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

protected Brush ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Methods

Brush Methods
[image]

Public Methods

Name | Description
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.
Deserialize | Creates and returns a new brush according to its string representation.
Serialize | Serializes the specified brush to a string.

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.CreateGdiBrush Method

Brush.CreateGdiBrush Method
[image]

Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.

Overload List

Name | Description
Brush.CreateGdiBrush (RectangleF) | Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object.
Brush.CreateGdiBrush (RectangleF, Single, Single) | Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object. The specified offset is used for texture or pattern brushes whose contents must scroll with the rest of the drawn image.

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.CreateGdiBrush Method (RectangleF)

Brush.CreateGdiBrush Method (RectangleF)
See Also
[image]

Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract Brush CreateGdiBrush (
RectangleF rc
)

Visual Basic [image] Copy Code

Public MustOverride Function CreateGdiBrush( _
rc As RectangleF _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.CreateGdiBrush Method (RectangleF, Single, Single)

Brush.CreateGdiBrush Method (RectangleF, Single, Single)
See Also
[image]

Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object. The specified offset is used for texture or pattern brushes whose contents must scroll with the rest of the drawn image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Brush CreateGdiBrush (
RectangleF rc,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Overridable Function CreateGdiBrush( _
rc As RectangleF, _
dx As Single, _
dy As Single _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

dx

Specifies a horizontal offset to apply to this brush.

dy

Specifies a vertical offset to apply to this brush.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.Deserialize Method

Brush.Deserialize Method
[image]

Creates and returns a new brush according to its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Brush Deserialize (
string image
)

Visual Basic [image] Copy Code

Public Shared Function Deserialize ( _
image As String _
) As Brush

Parameters

image

A string that represents the serialized bursh.

Return Value

An instance of a Brush-derived class.

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.Serialize Method

Brush.Serialize Method
[image]

Serializes the specified brush to a string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string Serialize (
Brush brush
)

Visual Basic [image] Copy Code

Public Shared Function Serialize ( _
brush As Brush _
) As String

Parameters

brush

The Brush object to serialize.

Return Value

A string that represents the specified brush.

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Class

BrushCollection Class
[image]

A collection of MindFusion.Drawing.Brush objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public sealed class BrushCollection : CollectionBase, ICloneable

Visual Basic [image] Copy Code

Public NotInheritable Class BrushCollection
Inherits CollectionBase
Implements ICloneable

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Drawing.BrushCollection

See Also

BrushCollection Members
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Members

BrushCollection Members
Constructors Properties Methods
[image]

A collection of MindFusion.Drawing.Brush objects.

The following tables list the members exposed by the BrushCollection type.

Public Constructors

Name | Description
BrushCollection | Overloaded. Initializes a new instance of the BrushCollection class.

Public Properties

Name | Description
DefaultBrush | Gets or sets the default brush added to a brush collection from within a design-time editor.
Item | Gets or sets the Brush, located at the specified position.

Public Methods

Name | Description
Add | Adds the specified Brush to the collection.
Clone | Returns a shallow copy of this BrushCollection object.
Contains | Checks whether the specified Brush is contained in the collection.
IndexOf | Returns the index of the first occurrence of the specified Brush.
Insert | Inserts the specified Brush at the specified position within the collection.
Remove | Removes the first occurrence of the specified Brush from the collection.
RemoveAt | Removes the Brush at the specified index.

See Also

BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Constructor

BrushCollection Constructor
[image]

Initializes a new instance of the BrushCollection class.

Overload List

Name | Description
BrushCollection () | Initializes a new empty instance of the BrushCollection class.
BrushCollection (String) | Initializes a new instance of the BrushCollection class using the specified string representation.

See Also

BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Constructor ()

BrushCollection Constructor ()
See Also
[image]

Initializes a new empty instance of the BrushCollection class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public BrushCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BrushCollection Constructor Overload List
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Constructor (String)

BrushCollection Constructor (String)
See Also
[image]

Initializes a new instance of the BrushCollection class using the specified string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public BrushCollection (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
The string that represents serialized contents of a BrushCollection.

See Also

BrushCollection Constructor Overload List
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Methods

BrushCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified Brush to the collection.
Clone | Returns a shallow copy of this BrushCollection object.
Contains | Checks whether the specified Brush is contained in the collection.
IndexOf | Returns the index of the first occurrence of the specified Brush.
Insert | Inserts the specified Brush at the specified position within the collection.
Remove | Removes the first occurrence of the specified Brush from the collection.
RemoveAt | Removes the Brush at the specified index.

See Also

BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Add Method

BrushCollection.Add Method
[image]

Adds the specified Brush to the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int Add (
Brush brush
)

Visual Basic [image] Copy Code

Public Function Add ( _
brush As Brush _
) As Integer

Parameters

brush

The Brush object to add to the end of the collection.

Return Value

The zero-based index within the collection of the newly added brush.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Clone Method

BrushCollection.Clone Method
[image]

Returns a shallow copy of this BrushCollection object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Object Clone ()

Visual Basic [image] Copy Code

Public Overridable Function Clone () As Object

Return Value

An instance of the BrushCollection class.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Contains Method

BrushCollection.Contains Method
[image]

Checks whether the specified Brush is contained in the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public bool Contains (
Brush brush
)

Visual Basic [image] Copy Code

Public Function Contains ( _
brush As Brush _
) As Boolean

Parameters

brush

The Brush object to search for in the collection.

Return Value

true if the specified brush is contained in the collection; otherwise, false.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.IndexOf Method

BrushCollection.IndexOf Method
[image]

Returns the index of the first occurrence of the specified Brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int IndexOf (
Brush brush
)

Visual Basic [image] Copy Code

Public Function IndexOf ( _
brush As Brush _
) As Integer

Parameters

brush

The Brush object to locate in the collection.

Return Value

The zero-based index of the first occurrence of brush within the entire collection, if found; otherwise, -1.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Insert Method

BrushCollection.Insert Method
[image]

Inserts the specified Brush at the specified position within the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void Insert (
int index,
Brush brush
)

Visual Basic [image] Copy Code

Public Sub Insert ( _
index As Integer, _
brush As Brush _
)

Parameters

index
The zero-based index at which to insert the brush.
brush
The Brush object to add to the collection.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Remove Method

BrushCollection.Remove Method
[image]

Removes the first occurrence of the specified Brush from the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void Remove (
Brush brush
)

Visual Basic [image] Copy Code

Public Sub Remove ( _
brush As Brush _
)

Parameters

brush

The Brush object to remove from the collection.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.RemoveAt Method

BrushCollection.RemoveAt Method
[image]

Removes the Brush at the specified index.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public new void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Shadows Sub RemoveAt( _
index As Integer _
)

Parameters

index

The index at which the Brush object should be removed.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection Properties

BrushCollection Properties
[image]

Public Properties

Name | Description
DefaultBrush | Gets or sets the default brush added to a brush collection from within a design-time editor.
Item | Gets or sets the Brush, located at the specified position.

See Also

BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.DefaultBrush Property

BrushCollection.DefaultBrush Property
[image]

Gets or sets the default brush added to a brush collection from within a design-time editor.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Brush DefaultBrush { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultBrush As Brush

Property Value

An instance of the Brush class.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.BrushCollection.Item Property

BrushCollection.Item Property
[image]

Gets or sets the Brush, located at the specified position.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Brush Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item ( _
index As Integer _
) As Brush

Parameters

index

The zero-based index of the brush to set or retrieve.

Property Value

An instance of the Brush class that represents the brush at the specified position.

See Also

BrushCollection Members
BrushCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Class

GdiGraphics Class
[image]

A wrapper of the System.Drawing.Graphics class that implements the IGraphics interface.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class GdiGraphics : IGraphics

Visual Basic [image] Copy Code

Public Class GdiGraphics
Implements IGraphics

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GdiGraphics

See Also

GdiGraphics Members
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Members

GdiGraphics Members
Constructors Properties Methods
[image]

A wrapper of the System.Drawing.Graphics class that implements the IGraphics interface.

The following tables list the members exposed by the GdiGraphics type.

Public Constructors

Name | Description
GdiGraphics | Initializes a new instance of the GdiGraphics class over the specified GDI+ Graphics object.

Public Properties

Name | Description
Clip | Gets or sets a .NET Region object that limits the drawing region of this GdiGraphics object.
ClipBounds | Gets a .NET RectangleF structure that bounds the clipping region of this GdiGraphics object.
CompositingMode | Gets or sets a value that specifies how composited images are drawn to this GdiGraphics object.
CompositingQuality | Gets or sets the rendering quality of composited images drawn to this GdiGraphics object.
DpiX | Gets the horizontal resolution of this GdiGraphics object.
DpiY | Gets the vertical resolution of this GdiGraphics object.
Graphics | Gets a reference to the underlying .NET Graphics object.
InterpolationMode | Gets or sets the interpolation mode associated with this GdiGraphics object.
IsClipEmpty | Gets a value indicating whether the clipping region of this GdiGraphics object is empty.
IsVisibleClipEmpty | Gets a value indicating whether the visible clipping region of this GdiGraphics object is empty.
PageScale | Gets or sets the scaling between world units and page units for this GdiGraphics object.
PageUnit | Gets or sets the unit of measure used for page coordinates in this GdiGraphics object.
PixelOffsetMode | Gets or set a value specifying how pixels are offset during rendering of this GdiGraphics object.
RenderingOrigin | Gets or sets the rendering origin of this GdiGraphics object for dithering and for hatch brushes.
SmoothingMode | Gets or sets the rendering quality for this GdiGraphics object.
TextContrast | Gets or sets the gamma correction value for rendering text.
TextRenderingHint | Gets or sets the rendering mode for text associated with this GdiGraphics object.
Transform | Gets or sets the world transformation for this GdiGraphics object.
VisibleClipBounds | Gets the bounding rectangle of the visible clipping region of this GdiGraphics object.

Public Methods

Name | Description
AddMetafileComment | Adds a comment to the current Metafile object.
BeginContainer | Overloaded. Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.
BeginHyperLink |
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Releases all resources used by this GdiGraphics object.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bézier spline defined by four .NET Point structures.
DrawBeziers | Overloaded. Draws a series of Bézier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of Point structures.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawIcon | Overloaded. Draws the image represented by the specified .NET Icon object at the specified coordinates.
DrawIconUnstretched | Draws the image represented by the specified .NET Icon object without scaling the image.
DrawImage | Overloaded. Draws the specified .NET Image object at the specified location and with the original size.
DrawImageUnscaled | Overloaded. Draws the specified image using its original physical size at the location specified by a coordinate pair.
DrawLine | Overloaded. Draws a line connecting the two points specified by coordinate pairs.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a .NET GraphicsPath object.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of Point or PointF structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangles | Overloaded. Draws a series of rectangles specified by Rectangle or RectangleF structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndContainer | Closes the current graphics container and restores the state of this GdiGraphics object to the state saved by a call to the BeginContainer method.
EndHyperLink |
EnumerateMetafile | Overloaded. Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
ExcludeClip | Overloaded. Updates the clip region of this GdiGraphics object to exclude the area specified by a .NET Rectangle structure.
FillClosedCurve | Overloaded. Fills the interior a closed cardinal spline curve defined by an array of Point structures.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillPath | Fills the interior of a .NET GraphicsPath object.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by Point structures.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a .NET Region object.
Flush | Overloaded. Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GetFontHeight |
GetHdc | Gets the handle to the device context associated with this GdiGraphics.
GetNearestColor | Gets the nearest color to the specified Color structure.
IntersectClip | Overloaded. Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IsVisible | Overloaded. Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.
MeasureCharacterRanges | Gets an array of Region objects, each of which bounds a range of character positions within the specified string.
MeasureString | Overloaded. Measures the specified string when drawn with the specified Font object.
MultiplyTransform | Overloaded. Multiplies the world transformation of this GdiGraphics object and specified the .NET Matrix object.
ReleaseHdc | Releases a device context handle obtained by a previous call to the GetHdc method of this GdiGraphics object.
ReleaseHdcInternal | Internal method. Do not use.
ResetClip | Resets the clip region of this GdiGraphics object to an infinite region.
ResetTransform | Resets the world transformation matrix of this GdiGraphics object to the identity matrix.
Restore | Restores the state of this GdiGraphics object to the state represented by a GraphicsState object.
RotateTransform | Overloaded. Applies the specified rotation to the transformation matrix of this GdiGraphics object.
Save | Saves the current state of this GdiGraphics object and identifies the saved state with a GraphicsState object.
ScaleTransform | Overloaded. Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.
SetClip | Overloaded. Sets the clipping region of this GdiGraphics object.
TransformPoints | Overloaded. Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.
TranslateClip | Overloaded. Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.
TranslateTransform | Overloaded. Prepends the specified translation to the transformation matrix of this GdiGraphics object.

See Also

GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Constructor

GdiGraphics Constructor
[image]

Initializes a new instance of the GdiGraphics class over the specified GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public GdiGraphics (
Graphics graphics
)

Visual Basic [image] Copy Code

Public New ( _
graphics As Graphics _
)

Parameters

graphics
The .NET Graphics object to wrap.

See Also

GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Methods

GdiGraphics Methods
[image]

Public Methods

Name | Description
AddMetafileComment | Adds a comment to the current Metafile object.
BeginContainer | Overloaded. Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.
BeginHyperLink |
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Releases all resources used by this GdiGraphics object.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bézier spline defined by four .NET Point structures.
DrawBeziers | Overloaded. Draws a series of Bézier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of Point structures.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawIcon | Overloaded. Draws the image represented by the specified .NET Icon object at the specified coordinates.
DrawIconUnstretched | Draws the image represented by the specified .NET Icon object without scaling the image.
DrawImage | Overloaded. Draws the specified .NET Image object at the specified location and with the original size.
DrawImageUnscaled | Overloaded. Draws the specified image using its original physical size at the location specified by a coordinate pair.
DrawLine | Overloaded. Draws a line connecting the two points specified by coordinate pairs.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a .NET GraphicsPath object.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of Point or PointF structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangles | Overloaded. Draws a series of rectangles specified by Rectangle or RectangleF structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndContainer | Closes the current graphics container and restores the state of this GdiGraphics object to the state saved by a call to the BeginContainer method.
EndHyperLink |
EnumerateMetafile | Overloaded. Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
ExcludeClip | Overloaded. Updates the clip region of this GdiGraphics object to exclude the area specified by a .NET Rectangle structure.
FillClosedCurve | Overloaded. Fills the interior a closed cardinal spline curve defined by an array of Point structures.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillPath | Fills the interior of a .NET GraphicsPath object.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by Point structures.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a .NET Region object.
Flush | Overloaded. Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GetFontHeight |
GetHdc | Gets the handle to the device context associated with this GdiGraphics.
GetNearestColor | Gets the nearest color to the specified Color structure.
IntersectClip | Overloaded. Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IsVisible | Overloaded. Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.
MeasureCharacterRanges | Gets an array of Region objects, each of which bounds a range of character positions within the specified string.
MeasureString | Overloaded. Measures the specified string when drawn with the specified Font object.
MultiplyTransform | Overloaded. Multiplies the world transformation of this GdiGraphics object and specified the .NET Matrix object.
ReleaseHdc | Releases a device context handle obtained by a previous call to the GetHdc method of this GdiGraphics object.
ReleaseHdcInternal | Internal method. Do not use.
ResetClip | Resets the clip region of this GdiGraphics object to an infinite region.
ResetTransform | Resets the world transformation matrix of this GdiGraphics object to the identity matrix.
Restore | Restores the state of this GdiGraphics object to the state represented by a GraphicsState object.
RotateTransform | Overloaded. Applies the specified rotation to the transformation matrix of this GdiGraphics object.
Save | Saves the current state of this GdiGraphics object and identifies the saved state with a GraphicsState object.
ScaleTransform | Overloaded. Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.
SetClip | Overloaded. Sets the clipping region of this GdiGraphics object.
TransformPoints | Overloaded. Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.
TranslateClip | Overloaded. Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.
TranslateTransform | Overloaded. Prepends the specified translation to the transformation matrix of this GdiGraphics object.

See Also

GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.AddMetafileComment Method

GdiGraphics.AddMetafileComment Method
[image]

Adds a comment to the current Metafile object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void AddMetafileComment (
byte[] data
)

Visual Basic [image] Copy Code

Public Overridable Sub AddMetafileComment( _
data() As Byte _
)

Parameters

data
Array of bytes that contains the comment.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginContainer Method

GdiGraphics.BeginContainer Method
[image]

Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.

Overload List

Name | Description
GdiGraphics.BeginContainer () | Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.
GdiGraphics.BeginContainer (Rectangle, Rectangle, GraphicsUnit) | Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container with the specified scale transformation.
GdiGraphics.BeginContainer (RectangleF, RectangleF, GraphicsUnit) | Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container with the specified scale transformation.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginContainer Method ()

GdiGraphics.BeginContainer Method ()
See Also
[image]

Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual GraphicsContainer BeginContainer ()

Visual Basic [image] Copy Code

Public Overridable Function BeginContainer () As GraphicsContainer

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this GdiGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginContainer Method (Rectangle, Rectangle, GraphicsUnit)

GdiGraphics.BeginContainer Method (Rectangle, Rectangle, GraphicsUnit)
See Also
[image]

Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container with the specified scale transformation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual GraphicsContainer BeginContainer (
Rectangle dstrect,
Rectangle srcrect,
GraphicsUnit unit
)

Visual Basic [image] Copy Code

Public Overridable Function BeginContainer( _
dstrect As Rectangle, _
srcrect As Rectangle, _
unit As GraphicsUnit _
) As GraphicsContainer

Parameters

dstrect
A .NET Rectangle structure that, together with the srcrect parameter, specifies a scale transformation for the container.
srcrect
A .NET Rectangle structure that, together with the dstrect parameter, specifies a scale transformation for the container.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure for the container.

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this GdiGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginContainer Method (RectangleF, RectangleF, GraphicsUnit)

GdiGraphics.BeginContainer Method (RectangleF, RectangleF, GraphicsUnit)
See Also
[image]

Saves a graphics container with the current state of this GdiGraphics object and opens and uses a new graphics container with the specified scale transformation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual GraphicsContainer BeginContainer (
RectangleF dstrect,
RectangleF srcrect,
GraphicsUnit unit
)

Visual Basic [image] Copy Code

Public Overridable Function BeginContainer( _
dstrect As RectangleF, _
srcrect As RectangleF, _
unit As GraphicsUnit _
) As GraphicsContainer

Parameters

dstrect
A .NET RectangleF structure that, together with the srcrect parameter, specifies a scale transformation for the new graphics container.
srcrect
A .NET RectangleF structure that, together with the dstrect parameter, specifies a scale transformation for the new graphics container.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure for the container.

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this GdiGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.BeginHyperLink Method

GdiGraphics.BeginHyperLink Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void BeginHyperLink (
string url,
string target
)

Visual Basic [image] Copy Code

Public Overridable Sub BeginHyperLink( _
url As String, _
target As String _
)

Parameters

url

target

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Clear Method

GdiGraphics.Clear Method
[image]

Clears the entire drawing surface and fills it with the specified background color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void Clear (
Color color
)

Visual Basic [image] Copy Code

Public Overridable Sub Clear( _
color As Color _
)

Parameters

color
A .NET Color structure that represents the background color of the drawing surface.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Dispose Method

GdiGraphics.Dispose Method
[image]

Releases all resources used by this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void Dispose ()

Visual Basic [image] Copy Code

Public Overridable Sub Dispose ()

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method

GdiGraphics.DrawArc Method
[image]

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
GdiGraphics.DrawArc (Pen, Int32, Int32, Int32, Int32, Int32, Int32) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
GdiGraphics.DrawArc (Pen, Rectangle, Single, Single) | Draws an arc representing a portion of an ellipse specified by a .NET Rectangle structure.
GdiGraphics.DrawArc (Pen, RectangleF, Single, Single) | Draws an arc representing a portion of an ellipse specified by a .NET RectangleF structure.
GdiGraphics.DrawArc (Pen, Single, Single, Single, Single, Single, Single) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

GdiGraphics.DrawArc Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawArc (
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawArc( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
The width of the rectangle that defines the ellipse.
height
The height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method (Pen, Rectangle, Single, Single)

GdiGraphics.DrawArc Method (Pen, Rectangle, Single, Single)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a .NET Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawArc (
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawArc( _
pen As Pen, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method (Pen, RectangleF, Single, Single)

GdiGraphics.DrawArc Method (Pen, RectangleF, Single, Single)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a .NET RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawArc (
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawArc( _
pen As Pen, _
rect As RectangleF, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawArc Method (Pen, Single, Single, Single, Single, Single, Single)

GdiGraphics.DrawArc Method (Pen, Single, Single, Single, Single, Single, Single)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawArc (
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawArc( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
The width of the rectangle that defines the ellipse.
height
The height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBezier Method

GdiGraphics.DrawBezier Method
[image]

Draws a Bézier spline defined by four .NET Point structures.

Overload List

Name | Description
GdiGraphics.DrawBezier (Pen, Point, Point, Point, Point) | Draws a Bézier spline defined by four Point structures.
GdiGraphics.DrawBezier (Pen, PointF, PointF, PointF, PointF) | Draws a Bézier spline defined by four PointF structures.
GdiGraphics.DrawBezier (Pen, Single, Single, Single, Single, Single, Single, Single, Single) | Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBezier Method (Pen, Point, Point, Point, Point)

GdiGraphics.DrawBezier Method (Pen, Point, Point, Point, Point)
See Also
[image]

Draws a Bézier spline defined by four Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawBezier (
Pen pen,
Point pt1,
Point pt2,
Point pt3,
Point pt4
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawBezier( _
pen As Pen, _
pt1 As Point, _
pt2 As Point, _
pt3 As Point, _
pt4 As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
pt1
A .NET Point structure that represents the starting point of the curve.
pt2
A .NET Point structure that represents the first control point for the curve.
pt3
A .NET Point structure that represents the second control point for the curve.
pt4
A .NET Point structure that represents the ending point of the curve.

See Also

DrawBezier Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBezier Method (Pen, PointF, PointF, PointF, PointF)

GdiGraphics.DrawBezier Method (Pen, PointF, PointF, PointF, PointF)
See Also
[image]

Draws a Bézier spline defined by four PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawBezier (
Pen pen,
PointF pt1,
PointF pt2,
PointF pt3,
PointF pt4
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawBezier( _
pen As Pen, _
pt1 As PointF, _
pt2 As PointF, _
pt3 As PointF, _
pt4 As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
pt1
A .NET PointF structure that represents the starting point of the curve.
pt2
A .NET PointF structure that represents the first control point for the curve.
pt3
A .NET PointF structure that represents the second control point for the curve.
pt4
A .NET PointF structure that represents the ending point of the curve.

See Also

DrawBezier Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBezier Method (Pen, Single, Single, Single, Single, Single, Single, Single, Single)

GdiGraphics.DrawBezier Method (Pen, Single, Single, Single, Single, Single, Single, Single, Single)
See Also
[image]

Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawBezier (
Pen pen,
float x1,
float y1,
float x2,
float y2,
float x3,
float y3,
float x4,
float y4
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawBezier( _
pen As Pen, _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single, _
x3 As Single, _
y3 As Single, _
x4 As Single, _
y4 As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
x1
The x-coordinate of the starting point of the curve.
y1
The y-coordinate of the starting point of the curve.
x2
The x-coordinate of the first control point of the curve.
y2
The y-coordinate of the first control point of the curve.
x3
The x-coordinate of the second control point of the curve.
y3
The y-coordinate of the second control point of the curve.
x4
The x-coordinate of the ending point of the curve.
y4
The y-coordinate of the ending point of the curve.

See Also

DrawBezier Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBeziers Method

GdiGraphics.DrawBeziers Method
[image]

Draws a series of Bézier splines from an array of Point structures.

Overload List

Name | Description
GdiGraphics.DrawBeziers (Pen, Point[]) | Draws a series of Bézier splines from an array of Point structures.
GdiGraphics.DrawBeziers (Pen, PointF[]) | Draws a series of Bézier splines from an array of PointF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBeziers Method (Pen, Point[])

GdiGraphics.DrawBeziers Method (Pen, Point[])
See Also
[image]

Draws a series of Bézier splines from an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawBeziers (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawBeziers( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
points
An array of .NET Point structures that represent the points that determine the curve.

See Also

DrawBeziers Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawBeziers Method (Pen, PointF[])

GdiGraphics.DrawBeziers Method (Pen, PointF[])
See Also
[image]

Draws a series of Bézier splines from an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawBeziers (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawBeziers( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
points
An array of .NET PointF structures that represent the points that determine the curve.

See Also

DrawBeziers Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method

GdiGraphics.DrawClosedCurve Method
[image]

Draws a closed cardinal spline defined by an array of Point structures.

Overload List

Name | Description
GdiGraphics.DrawClosedCurve (Pen, Point[]) | Draws a closed cardinal spline defined by an array of Point structures.
GdiGraphics.DrawClosedCurve (Pen, Point[], Single, FillMode) | Draws a closed cardinal spline defined by an array of Point structures using a specified tension.
GdiGraphics.DrawClosedCurve (Pen, PointF[]) | Draws a closed cardinal spline defined by an array of PointF structures.
GdiGraphics.DrawClosedCurve (Pen, PointF[], Single, FillMode) | Draws a closed cardinal spline defined by an array of PointF structures using a specified tension.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method (Pen, Point[])

GdiGraphics.DrawClosedCurve Method (Pen, Point[])
See Also
[image]

Draws a closed cardinal spline defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawClosedCurve (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawClosedCurve( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.

See Also

DrawClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method (Pen, Point[], Single, FillMode)

GdiGraphics.DrawClosedCurve Method (Pen, Point[], Single, FillMode)
See Also
[image]

Draws a closed cardinal spline defined by an array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawClosedCurve (
Pen pen,
Point[] points,
float tension,
FillMode fillmode
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawClosedCurve( _
pen As Pen, _
points() As Point, _
tension As Single, _
fillmode As FillMode _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled. This parameter is required but ignored.

See Also

DrawClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method (Pen, PointF[])

GdiGraphics.DrawClosedCurve Method (Pen, PointF[])
See Also
[image]

Draws a closed cardinal spline defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawClosedCurve (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawClosedCurve( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of PointF structures that define the spline.

See Also

DrawClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawClosedCurve Method (Pen, PointF[], Single, FillMode)

GdiGraphics.DrawClosedCurve Method (Pen, PointF[], Single, FillMode)
See Also
[image]

Draws a closed cardinal spline defined by an array of PointF structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawClosedCurve (
Pen pen,
PointF[] points,
float tension,
FillMode fillmode
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawClosedCurve( _
pen As Pen, _
points() As PointF, _
tension As Single, _
fillmode As FillMode _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of PointF structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.
fillmode
Member of the FillMode enumeration that determines how the curve is filled. This parameter is required but is ignored.

See Also

DrawClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method

GdiGraphics.DrawCurve Method
[image]

Draws a cardinal spline through a specified array of Point structures.

Overload List

Name | Description
GdiGraphics.DrawCurve (Pen, Point[]) | Draws a cardinal spline through a specified array of Point structures.
GdiGraphics.DrawCurve (Pen, Point[], Int32, Int32, Single) | Draws a cardinal spline through a specified array of Point structures using a specified tension.
GdiGraphics.DrawCurve (Pen, Point[], Single) | Draws a cardinal spline through a specified array of Point structures using a specified tension.
GdiGraphics.DrawCurve (Pen, PointF[]) | Draws a cardinal spline through a specified array of PointF structures.
GdiGraphics.DrawCurve (Pen, PointF[], Int32, Int32) | Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array.
GdiGraphics.DrawCurve (Pen, PointF[], Int32, Int32, Single) | Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.
GdiGraphics.DrawCurve (Pen, PointF[], Single) | Draws a cardinal spline through a specified array of PointF structures using a specified tension.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, Point[])

GdiGraphics.DrawCurve Method (Pen, Point[])
See Also
[image]

Draws a cardinal spline through a specified array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, Point[], Int32, Int32, Single)

GdiGraphics.DrawCurve Method (Pen, Point[], Int32, Int32, Single)
See Also
[image]

Draws a cardinal spline through a specified array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
Point[] points,
int offset,
int numberOfSegments,
float tension
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As Point, _
offset As Integer, _
numberOfSegments As Integer, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, Point[], Single)

GdiGraphics.DrawCurve Method (Pen, Point[], Single)
See Also
[image]

Draws a cardinal spline through a specified array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
Point[] points,
float tension
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As Point, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, PointF[])

GdiGraphics.DrawCurve Method (Pen, PointF[])
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32)

GdiGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32)
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
PointF[] points,
int offset,
int numberOfSegments
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As PointF, _
offset As Integer, _
numberOfSegments As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32, Single)

GdiGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32, Single)
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
PointF[] points,
int offset,
int numberOfSegments,
float tension
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As PointF, _
offset As Integer, _
numberOfSegments As Integer, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawCurve Method (Pen, PointF[], Single)

GdiGraphics.DrawCurve Method (Pen, PointF[], Single)
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawCurve (
Pen pen,
PointF[] points,
float tension
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawCurve( _
pen As Pen, _
points() As PointF, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that represent the points that define the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method

GdiGraphics.DrawEllipse Method
[image]

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Overload List

Name | Description
GdiGraphics.DrawEllipse (Pen, Int32, Int32, Int32, Int32) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
GdiGraphics.DrawEllipse (Pen, Rectangle) | Draws an ellipse specified by a bounding Rectangle structure.
GdiGraphics.DrawEllipse (Pen, RectangleF) | Draws an ellipse defined by a bounding RectangleF structure.
GdiGraphics.DrawEllipse (Pen, Single, Single, Single, Single) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method (Pen, Int32, Int32, Int32, Int32)

GdiGraphics.DrawEllipse Method (Pen, Int32, Int32, Int32, Int32)
See Also
[image]

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawEllipse (
Pen pen,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawEllipse( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
x

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

DrawEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method (Pen, Rectangle)

GdiGraphics.DrawEllipse Method (Pen, Rectangle)
See Also
[image]

Draws an ellipse specified by a bounding Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawEllipse (
Pen pen,
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawEllipse( _
pen As Pen, _
rect As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
rect
A .NET Rectangle structure that defines the boundaries of the ellipse.

See Also

DrawEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method (Pen, RectangleF)

GdiGraphics.DrawEllipse Method (Pen, RectangleF)
See Also
[image]

Draws an ellipse defined by a bounding RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawEllipse (
Pen pen,
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawEllipse( _
pen As Pen, _
rect As RectangleF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.

See Also

DrawEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawEllipse Method (Pen, Single, Single, Single, Single)

GdiGraphics.DrawEllipse Method (Pen, Single, Single, Single, Single)
See Also
[image]

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawEllipse (
Pen pen,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawEllipse( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
x

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

DrawEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawIcon Method

GdiGraphics.DrawIcon Method
[image]

Draws the image represented by the specified .NET Icon object at the specified coordinates.

Overload List

Name | Description
GdiGraphics.DrawIcon (Icon, Int32, Int32) | Draws the image represented by the specified .NET Icon object at the specified coordinates.
GdiGraphics.DrawIcon (Icon, Rectangle) | Draws the image represented by the specified .NET Icon object within the area specified by a Rectangle structure.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawIcon Method (Icon, Int32, Int32)

GdiGraphics.DrawIcon Method (Icon, Int32, Int32)
See Also
[image]

Draws the image represented by the specified .NET Icon object at the specified coordinates.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawIcon (
Icon icon,
int x,
int y
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawIcon( _
icon As Icon, _
x As Integer, _
y As Integer _
)

Parameters

icon
A .NET Icon object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawIcon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawIcon Method (Icon, Rectangle)

GdiGraphics.DrawIcon Method (Icon, Rectangle)
See Also
[image]

Draws the image represented by the specified .NET Icon object within the area specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawIcon (
Icon icon,
Rectangle targetRect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawIcon( _
icon As Icon, _
targetRect As Rectangle _
)

Parameters

icon
A .NET Icon object to draw.
targetRect
A .NET Rectangle structure that specifies the location and size of the resulting image on the display surface. The image contained in the icon parameter is scaled to the dimensions of this rectangular area.

See Also

DrawIcon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawIconUnstretched Method

GdiGraphics.DrawIconUnstretched Method
[image]

Draws the image represented by the specified .NET Icon object without scaling the image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawIconUnstretched (
Icon icon,
Rectangle targetRect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawIconUnstretched( _
icon As Icon, _
targetRect As Rectangle _
)

Parameters

icon
A .NET Icon object to draw.
targetRect
A .NET Rectangle structure that specifies the location and size of the resulting image. The image is not scaled to fit this rectangle, but retains its original size. If the image is larger than the rectangle, it is clipped to fit inside it.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method

GdiGraphics.DrawImage Method
[image]

Draws the specified .NET Image object at the specified location and with the original size.

Overload List

Name | Description
GdiGraphics.DrawImage (Image, Int32, Int32) | Draws the specified image, using its original physical size, at the location specified by a coordinate pair.
GdiGraphics.DrawImage (Image, Int32, Int32, Int32, Int32) | Draws the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Int32, Int32, Rectangle, GraphicsUnit) | Draws a portion of an image at a specified location.
GdiGraphics.DrawImage (Image, Point) | Draws the specified .NET Image object, using its original physical size, at the specified location.
GdiGraphics.DrawImage (Image, Point[]) | Draws the specified .NET Image object at the specified location and with the specified shape and size.
GdiGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location.
GdiGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, PointF) | Draws the specified .NET Image object, using its original physical size, at the specified location.
GdiGraphics.DrawImage (Image, PointF[]) | Draws the specified .NET Image object at the specified location and with the specified shape and size.
GdiGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle) | Draws the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Rectangle, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, RectangleF) | Draws the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, RectangleF, RectangleF, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
GdiGraphics.DrawImage (Image, Single, Single) | Draws the specified .NET Image object, using its original physical size, at the specified location.
GdiGraphics.DrawImage (Image, Single, Single, RectangleF, GraphicsUnit) | Draws a portion of an image at a specified location.
GdiGraphics.DrawImage (Image, Single, Single, Single, Single) | Draws the specified .NET Image object at the specified location and with the specified size.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Int32, Int32)

GdiGraphics.DrawImage Method (Image, Int32, Int32)
See Also
[image]

Draws the specified image, using its original physical size, at the location specified by a coordinate pair.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
int x,
int y
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
x As Integer, _
y As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Int32, Int32, Int32, Int32)

GdiGraphics.DrawImage Method (Image, Int32, Int32, Int32, Int32)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
The width of the drawn image.
height
The height of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Int32, Int32, Rectangle, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Int32, Int32, Rectangle, GraphicsUnit)
See Also
[image]

Draws a portion of an image at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
int x,
int y,
Rectangle srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
x As Integer, _
y As Integer, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point)

GdiGraphics.DrawImage Method (Image, Point)
See Also
[image]

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Point point
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
point As Point _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that represents the location of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[])

GdiGraphics.DrawImage Method (Image, Point[])
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified shape and size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Point[] destPoints
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destPoints() As Point _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)

GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)

GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32)

GdiGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback,
int callbackData
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort, _
callbackData As Integer _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.
callbackData

Value specifying additional data for the Graphics.DrawImageAbort delegate to use when checking whether to stop execution of the DrawImage method.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF)

GdiGraphics.DrawImage Method (Image, PointF)
See Also
[image]

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
PointF point
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
point As PointF _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that represents the location of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[])

GdiGraphics.DrawImage Method (Image, PointF[])
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified shape and size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
PointF[] destPoints
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destPoints() As PointF _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)

GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)

GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET Rectanglef structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32)

GdiGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, Int32)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback,
int callbackData
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort, _
callbackData As Integer _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.
callbackData
Value specifying additional data for the Graphics.DrawImageAbort delegate to use when checking whether to stop execution of the DrawImage method.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle)

GdiGraphics.DrawImage Method (Image, Rectangle)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
rect As Rectangle _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET Rectangle structure that specifies the location and size of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)

GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)

GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttr,
Graphics.DrawImageAbort callback
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes, _
callback As Graphics.DrawImageAbort _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr)

GdiGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs,
Graphics.DrawImageAbort callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes, _
callback As Graphics.DrawImageAbort, _
callbackData As IntPtr _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.
callbackData
Value specifying additional data for the DrawImageAbort delegate to use when checking whether to stop execution of the DrawImage method.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)

GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)

GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs,
Graphics.DrawImageAbort callback
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes, _
callback As Graphics.DrawImageAbort _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr)

GdiGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes, Graphics.DrawImageAbort, IntPtr)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs,
Graphics.DrawImageAbort callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes, _
callback As Graphics.DrawImageAbort, _
callbackData As IntPtr _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.
callback
A .NET Graphics.DrawImageAbort delegate that specifies a method to call during the drawing of the image. This method is called frequently to check whether to stop execution of the DrawImage method according to application-determined criteria.
callbackData
Value specifying additional data for the DrawImageAbort delegate to use when checking whether to stop execution of the DrawImage method.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, RectangleF)

GdiGraphics.DrawImage Method (Image, RectangleF)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
rect As RectangleF _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET RectangleF structure that specifies the location and size of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
destRect As RectangleF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET RectangleF structure.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Single, Single)

GdiGraphics.DrawImage Method (Image, Single, Single)
See Also
[image]

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
float x,
float y
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
x As Single, _
y As Single _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Single, Single, RectangleF, GraphicsUnit)

GdiGraphics.DrawImage Method (Image, Single, Single, RectangleF, GraphicsUnit)
See Also
[image]

Draws a portion of an image at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
float x,
float y,
RectangleF srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
x As Single, _
y As Single, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImage Method (Image, Single, Single, Single, Single)

GdiGraphics.DrawImage Method (Image, Single, Single, Single, Single)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImage (
Image image,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImage( _
image As Image, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
The width of the drawn image.
height
The height of the drawn image.

See Also

DrawImage Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method

GdiGraphics.DrawImageUnscaled Method
[image]

Draws the specified image using its original physical size at the location specified by a coordinate pair.

Overload List

Name | Description
GdiGraphics.DrawImageUnscaled (Image, Int32, Int32) | Draws the specified image using its original physical size at the location specified by a coordinate pair.
GdiGraphics.DrawImageUnscaled (Image, Int32, Int32, Int32, Int32) | Draws a specified image using its original physical size at a specified location.
GdiGraphics.DrawImageUnscaled (Image, Point) | Draws a specified image using its original physical size at a specified location.
GdiGraphics.DrawImageUnscaled (Image, Rectangle) | Draws a specified image using its original physical size at a specified location.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method (Image, Int32, Int32)

GdiGraphics.DrawImageUnscaled Method (Image, Int32, Int32)
See Also
[image]

Draws the specified image using its original physical size at the location specified by a coordinate pair.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImageUnscaled (
Image image,
int x,
int y
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImageUnscaled( _
image As Image, _
x As Integer, _
y As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImageUnscaled Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method (Image, Int32, Int32, Int32, Int32)

GdiGraphics.DrawImageUnscaled Method (Image, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImageUnscaled (
Image image,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImageUnscaled( _
image As Image, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
Not used.
height
Not used.

See Also

DrawImageUnscaled Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method (Image, Point)

GdiGraphics.DrawImageUnscaled Method (Image, Point)
See Also
[image]

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImageUnscaled (
Image image,
Point point
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImageUnscaled( _
image As Image, _
point As Point _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that specifies the upper-left corner of the drawn image.

See Also

DrawImageUnscaled Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawImageUnscaled Method (Image, Rectangle)

GdiGraphics.DrawImageUnscaled Method (Image, Rectangle)
See Also
[image]

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawImageUnscaled (
Image image,
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawImageUnscaled( _
image As Image, _
rect As Rectangle _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET Rectangle structure that specifies the drawn image.

See Also

DrawImageUnscaled Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method

GdiGraphics.DrawLine Method
[image]

Draws a line connecting the two points specified by coordinate pairs.

Overload List

Name | Description
GdiGraphics.DrawLine (Pen, Int32, Int32, Int32, Int32) | Draws a line connecting the two points specified by coordinate pairs.
GdiGraphics.DrawLine (Pen, Point, Point) | Draws a line connecting two Point structures.
GdiGraphics.DrawLine (Pen, PointF, PointF) | Draws a line connecting two PointF structures.
GdiGraphics.DrawLine (Pen, Single, Single, Single, Single) | Draws a line connecting the two points specified by coordinate pairs.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method (Pen, Int32, Int32, Int32, Int32)

GdiGraphics.DrawLine Method (Pen, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawLine (
Pen pen,
int x1,
int y1,
int x2,
int y2
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLine( _
pen As Pen, _
x1 As Integer, _
y1 As Integer, _
x2 As Integer, _
y2 As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

See Also

DrawLine Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method (Pen, Point, Point)

GdiGraphics.DrawLine Method (Pen, Point, Point)
See Also
[image]

Draws a line connecting two Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawLine (
Pen pen,
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLine( _
pen As Pen, _
pt1 As Point, _
pt2 As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
pt1
A .NET Point structure that represents the first point to connect.
pt2
A .NET Point structure that represents the second point to connect.

See Also

DrawLine Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method (Pen, PointF, PointF)

GdiGraphics.DrawLine Method (Pen, PointF, PointF)
See Also
[image]

Draws a line connecting two PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawLine (
Pen pen,
PointF pt1,
PointF pt2
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLine( _
pen As Pen, _
pt1 As PointF, _
pt2 As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
pt1
A .NET PointF structure that represents the first point to connect.
pt2
A .NET PointF structure that represents the second point to connect.

See Also

DrawLine Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLine Method (Pen, Single, Single, Single, Single)

GdiGraphics.DrawLine Method (Pen, Single, Single, Single, Single)
See Also
[image]

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawLine (
Pen pen,
float x1,
float y1,
float x2,
float y2
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLine( _
pen As Pen, _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

See Also

DrawLine Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLines Method

GdiGraphics.DrawLines Method
[image]

Draws a series of line segments that connect an array of Point structures.

Overload List

Name | Description
GdiGraphics.DrawLines (Pen, Point[]) | Draws a series of line segments that connect an array of Point structures.
GdiGraphics.DrawLines (Pen, PointF[]) | Draws a series of line segments that connect an array of PointF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLines Method (Pen, Point[])

GdiGraphics.DrawLines Method (Pen, Point[])
See Also
[image]

Draws a series of line segments that connect an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawLines (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLines( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line segments.
points
An array of .NET Point structures that represent the points to connect.

See Also

DrawLines Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawLines Method (Pen, PointF[])

GdiGraphics.DrawLines Method (Pen, PointF[])
See Also
[image]

Draws a series of line segments that connect an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawLines (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLines( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line segments.
points
An array of .NET PointF structures that represent the points to connect.

See Also

DrawLines Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPath Method

GdiGraphics.DrawPath Method
[image]

Draws a .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPath (
Pen pen,
GraphicsPath path
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPath( _
pen As Pen, _
path As GraphicsPath _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the path.
path
A .NET GraphicsPath object to draw.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method

GdiGraphics.DrawPie Method
[image]

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Overload List

Name | Description
GdiGraphics.DrawPie (Pen, Int32, Int32, Int32, Int32, Int32, Int32) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
GdiGraphics.DrawPie (Pen, Rectangle, Single, Single) | Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.
GdiGraphics.DrawPie (Pen, RectangleF, Single, Single) | Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.
GdiGraphics.DrawPie (Pen, Single, Single, Single, Single, Single, Single) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

GdiGraphics.DrawPie Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPie (
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPie( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method (Pen, Rectangle, Single, Single)

GdiGraphics.DrawPie Method (Pen, Rectangle, Single, Single)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPie (
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPie( _
pen As Pen, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method (Pen, RectangleF, Single, Single)

GdiGraphics.DrawPie Method (Pen, RectangleF, Single, Single)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPie (
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPie( _
pen As Pen, _
rect As RectangleF, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
rect
A .NET RectangleF structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPie Method (Pen, Single, Single, Single, Single, Single, Single)

GdiGraphics.DrawPie Method (Pen, Single, Single, Single, Single, Single, Single)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPie (
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPie( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPolygon Method

GdiGraphics.DrawPolygon Method
[image]

Draws a polygon defined by an array of Point or PointF structures.

Overload List

Name | Description
GdiGraphics.DrawPolygon (Pen, Point[]) | Draws a polygon defined by an array of Point structures.
GdiGraphics.DrawPolygon (Pen, PointF[]) | Draws a polygon defined by an array of PointF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPolygon Method (Pen, Point[])

GdiGraphics.DrawPolygon Method (Pen, Point[])
See Also
[image]

Draws a polygon defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPolygon (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPolygon( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the polygon.
points
An array of .NET Point structures that represent the vertices of the polygon.

See Also

DrawPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawPolygon Method (Pen, PointF[])

GdiGraphics.DrawPolygon Method (Pen, PointF[])
See Also
[image]

Draws a polygon defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawPolygon (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawPolygon( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the polygon.
points
An array of .NET PointF structures that represent the vertices of the polygon.

See Also

DrawPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangle Method

GdiGraphics.DrawRectangle Method
[image]

Draws a rectangle specified by a coordinate pair, a width, and a height.

Overload List

Name | Description
GdiGraphics.DrawRectangle (Pen, Int32, Int32, Int32, Int32) | Draws a rectangle specified by a coordinate pair, a width, and a height.
GdiGraphics.DrawRectangle (Pen, Rectangle) | Draws a rectangle specified by a Rectangle structure.
GdiGraphics.DrawRectangle (Pen, Single, Single, Single, Single) | Draws a rectangle specified by a coordinate pair, a width, and a height.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)

GdiGraphics.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawRectangle (
Pen pen,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawRectangle( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangle Method (Pen, Rectangle)

GdiGraphics.DrawRectangle Method (Pen, Rectangle)
See Also
[image]

Draws a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawRectangle (
Pen pen,
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawRectangle( _
pen As Pen, _
rect As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
rect
A .NET Rectangle structure that represents the rectangle to draw.

See Also

DrawRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangle Method (Pen, Single, Single, Single, Single)

GdiGraphics.DrawRectangle Method (Pen, Single, Single, Single, Single)
See Also
[image]

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawRectangle (
Pen pen,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawRectangle( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangles Method

GdiGraphics.DrawRectangles Method
[image]

Draws a series of rectangles specified by Rectangle or RectangleF structures.

Overload List

Name | Description
GdiGraphics.DrawRectangles (Pen, Rectangle[]) | Draws a series of rectangles specified by Rectangle structures.
GdiGraphics.DrawRectangles (Pen, RectangleF[]) | Draws a series of rectangles specified by RectangleF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangles Method (Pen, Rectangle[])

GdiGraphics.DrawRectangles Method (Pen, Rectangle[])
See Also
[image]

Draws a series of rectangles specified by Rectangle structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawRectangles (
Pen pen,
Rectangle[] rects
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawRectangles( _
pen As Pen, _
rects() As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the outlines of the rectangles.
rects
An array of .NET Rectangle structures that represent the rectangles to draw.

See Also

DrawRectangles Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawRectangles Method (Pen, RectangleF[])

GdiGraphics.DrawRectangles Method (Pen, RectangleF[])
See Also
[image]

Draws a series of rectangles specified by RectangleF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawRectangles (
Pen pen,
RectangleF[] rects
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawRectangles( _
pen As Pen, _
rects() As RectangleF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the outlines of the rectangles.
rects
An array of .NET RectangleF structures that represent the rectangles to draw.

See Also

DrawRectangles Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method

GdiGraphics.DrawString Method
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects.

Overload List

Name | Description
GdiGraphics.DrawString (String, Font, Brush, PointF) | Draws the specified text string at the specified location with the specified Brush and Font objects.
GdiGraphics.DrawString (String, Font, Brush, PointF, StringFormat) | Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.
GdiGraphics.DrawString (String, Font, Brush, RectangleF) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects.
GdiGraphics.DrawString (String, Font, Brush, RectangleF, StringFormat) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.
GdiGraphics.DrawString (String, Font, Brush, Single, Single) | Draws the specified text string at the specified location with the specified Brush and Font objects.
GdiGraphics.DrawString (String, Font, Brush, Single, Single, StringFormat) | Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, PointF)

GdiGraphics.DrawString Method (String, Font, Brush, PointF)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawString (
string s,
Font font,
Brush brush,
PointF point
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
point As PointF _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
point
A .NET PointF structure that specifies the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, PointF, StringFormat)

GdiGraphics.DrawString Method (String, Font, Brush, PointF, StringFormat)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawString (
string s,
Font font,
Brush brush,
PointF point,
StringFormat format
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
point As PointF, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
point
A .NET PointF structure that specifies the upper-left corner of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, RectangleF)

GdiGraphics.DrawString Method (String, Font, Brush, RectangleF)
See Also
[image]

Draws the specified text string in the specified rectangle with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawString (
string s,
Font font,
Brush brush,
RectangleF layoutRectangle
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
layoutRectangle As RectangleF _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
layoutRectangle
A .NET RectangleF structure that specifies the location of the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)

GdiGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)
See Also
[image]

Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawString (
string s,
Font font,
Brush brush,
RectangleF layoutRectangle,
StringFormat format
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
layoutRectangle As RectangleF, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
layoutRectangle
A .NET RectangleF structure that specifies the location of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, Single, Single)

GdiGraphics.DrawString Method (String, Font, Brush, Single, Single)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawString (
string s,
Font font,
Brush brush,
float x,
float y
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
x As Single, _
y As Single _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DrawString Method (String, Font, Brush, Single, Single, StringFormat)

GdiGraphics.DrawString Method (String, Font, Brush, Single, Single, StringFormat)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void DrawString (
string s,
Font font,
Brush brush,
float x,
float y,
StringFormat format
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
x As Single, _
y As Single, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EndContainer Method

GdiGraphics.EndContainer Method
[image]

Closes the current graphics container and restores the state of this GdiGraphics object to the state saved by a call to the BeginContainer method.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void EndContainer (
GraphicsContainer container
)

Visual Basic [image] Copy Code

Public Overridable Sub EndContainer( _
container As GraphicsContainer _
)

Parameters

container
A .NET GraphicsContainer object that represents the container this method restores.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EndHyperLink Method

GdiGraphics.EndHyperLink Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void EndHyperLink ()

Visual Basic [image] Copy Code

Public Overridable Sub EndHyperLink ()

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method

GdiGraphics.EnumerateMetafile Method
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Overload List

Name | Description
GdiGraphics.EnumerateMetafile (Metafile, Point, Graphics.EnumerateMetafileProc) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Graphics.EnumerateMetafileProc) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, PointF, Graphics.EnumerateMetafileProc) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.
GdiGraphics.EnumerateMetafile (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], Graphics.EnumerateMetafileProc) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.
GdiGraphics.EnumerateMetafile (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Graphics.EnumerateMetafileProc) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, Graphics.EnumerateMetafileProc) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.
GdiGraphics.EnumerateMetafile (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes) | Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As Point, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As Point, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As Point, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Point, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point destPoint,
Rectangle srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As Point, _
srcRect As Rectangle, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET Point structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As Point, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As Point, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As Point, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Point[], Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As Point, _
srcRect As Rectangle, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET Point structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As PointF, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As PointF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As PointF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display at a specified point using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF destPoint,
RectangleF srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoint As PointF, _
srcRect As RectangleF, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoint
A .NET PointF structure that specifies the location of the upper-left corner of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As PointF, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As PointF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in the specified Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As PointF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET RectangleF structures that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, PointF[], RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records in a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified parallelogram using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destPoints() As PointF, _
srcRect As RectangleF, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destPoints
An array of three .NET PointF structures that define a parallelogram that determines the size and location of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As Rectangle, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As Rectangle, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As Rectangle, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As Rectangle, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As Rectangle, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, Rectangle, Rectangle, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As Rectangle, _
srcRect As Rectangle, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn metafile.
srcRect
A .NET Rectangle structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As RectangleF, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As RectangleF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records of the specified Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As RectangleF, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc)
See Also
[image]

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As RectangleF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr)
See Also
[image]

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit srcUnit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As RectangleF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)

GdiGraphics.EnumerateMetafile Method (Metafile, RectangleF, RectangleF, GraphicsUnit, Graphics.EnumerateMetafileProc, IntPtr, ImageAttributes)
See Also
[image]

Sends the records of a selected rectangle from a Metafile object, one at a time, to a callback method for display in a specified rectangle using specified image attributes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void EnumerateMetafile (
Metafile metafile,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit unit,
Graphics.EnumerateMetafileProc callback,
IntPtr callbackData,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Public Sub EnumerateMetafile( _
metafile As Metafile, _
destRect As RectangleF, _
srcRect As RectangleF, _
unit As GraphicsUnit, _
callback As Graphics.EnumerateMetafileProc, _
callbackData As IntPtr, _
imageAttr As ImageAttributes _
)

Parameters

metafile
A .NET Metafile object to enumerate.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn metafile.
srcRect
A .NET RectangleF structure that specifies the portion of the metafile, relative to its upper-left corner, to draw.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure used to determine the portion of the metafile that the rectangle specified by the srcRect parameter contains.
callback
A .NET Graphics.EnumerateMetafileProc delegate that specifies the method to which the metafile records are sent.
callbackData
Internal pointer that is required, but ignored. You can pass IntPtr.Zero for this parameter.
imageAttr
A .NET ImageAttributes object that specifies image attribute information for the drawn image.

See Also

EnumerateMetafile Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ExcludeClip Method

GdiGraphics.ExcludeClip Method
[image]

Updates the clip region of this GdiGraphics object to exclude the area specified by a .NET Rectangle structure.

Overload List

Name | Description
GdiGraphics.ExcludeClip (Rectangle) | Updates the clip region of this GdiGraphics object to exclude the area specified by a Rectangle structure.
GdiGraphics.ExcludeClip (Region) | Updates the clip region of this GdiGraphics object to exclude the area specified by a Region object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ExcludeClip Method (Rectangle)

GdiGraphics.ExcludeClip Method (Rectangle)
See Also
[image]

Updates the clip region of this GdiGraphics object to exclude the area specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ExcludeClip (
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub ExcludeClip( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure that specifies the rectangle to exclude from the clip region.

See Also

ExcludeClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ExcludeClip Method (Region)

GdiGraphics.ExcludeClip Method (Region)
See Also
[image]

Updates the clip region of this GdiGraphics object to exclude the area specified by a Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ExcludeClip (
Region region
)

Visual Basic [image] Copy Code

Public Overridable Sub ExcludeClip( _
region As Region _
)

Parameters

region
A .NET Region object that specifies the region to exclude from the clip region.

See Also

ExcludeClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method

GdiGraphics.FillClosedCurve Method
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures.

Overload List

Name | Description
GdiGraphics.FillClosedCurve (Brush, Point[]) | Fills the interior a closed cardinal spline curve defined by an array of Point structures.
GdiGraphics.FillClosedCurve (Brush, Point[], FillMode) | Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode.
GdiGraphics.FillClosedCurve (Brush, Point[], FillMode, Single) | Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.
GdiGraphics.FillClosedCurve (Brush, PointF[]) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures.
GdiGraphics.FillClosedCurve (Brush, PointF[], FillMode) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode.
GdiGraphics.FillClosedCurve (Brush, PointF[], FillMode, Single) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, Point[])

GdiGraphics.FillClosedCurve Method (Brush, Point[])
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillClosedCurve (
Brush brush,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub FillClosedCurve( _
brush As Brush, _
points() As Point _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, Point[], FillMode)

GdiGraphics.FillClosedCurve Method (Brush, Point[], FillMode)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillClosedCurve (
Brush brush,
Point[] points,
FillMode fillmode
)

Visual Basic [image] Copy Code

Public Overridable Sub FillClosedCurve( _
brush As Brush, _
points() As Point, _
fillmode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, Point[], FillMode, Single)

GdiGraphics.FillClosedCurve Method (Brush, Point[], FillMode, Single)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillClosedCurve (
Brush brush,
Point[] points,
FillMode fillmode,
float tension
)

Visual Basic [image] Copy Code

Public Overridable Sub FillClosedCurve( _
brush As Brush, _
points() As Point, _
fillmode As FillMode, _
tension As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, PointF[])

GdiGraphics.FillClosedCurve Method (Brush, PointF[])
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillClosedCurve (
Brush brush,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub FillClosedCurve( _
brush As Brush, _
points() As PointF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, PointF[], FillMode)

GdiGraphics.FillClosedCurve Method (Brush, PointF[], FillMode)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillClosedCurve (
Brush brush,
PointF[] points,
FillMode fillmode
)

Visual Basic [image] Copy Code

Public Overridable Sub FillClosedCurve( _
brush As Brush, _
points() As PointF, _
fillmode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillClosedCurve Method (Brush, PointF[], FillMode, Single)

GdiGraphics.FillClosedCurve Method (Brush, PointF[], FillMode, Single)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillClosedCurve (
Brush brush,
PointF[] points,
FillMode fillmode,
float tension
)

Visual Basic [image] Copy Code

Public Overridable Sub FillClosedCurve( _
brush As Brush, _
points() As PointF, _
fillmode As FillMode, _
tension As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

FillClosedCurve Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method

GdiGraphics.FillEllipse Method
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
GdiGraphics.FillEllipse (Brush, Int32, Int32, Int32, Int32) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
GdiGraphics.FillEllipse (Brush, Rectangle) | Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.
GdiGraphics.FillEllipse (Brush, RectangleF) | Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.
GdiGraphics.FillEllipse (Brush, Single, Single, Single, Single) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method (Brush, Int32, Int32, Int32, Int32)

GdiGraphics.FillEllipse Method (Brush, Int32, Int32, Int32, Int32)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillEllipse (
Brush brush,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Sub FillEllipse( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method (Brush, Rectangle)

GdiGraphics.FillEllipse Method (Brush, Rectangle)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillEllipse (
Brush brush,
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub FillEllipse( _
brush As Brush, _
rect As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method (Brush, RectangleF)

GdiGraphics.FillEllipse Method (Brush, RectangleF)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillEllipse (
Brush brush,
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Sub FillEllipse( _
brush As Brush, _
rect As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET RectangleF structure that represents the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillEllipse Method (Brush, Single, Single, Single, Single)

GdiGraphics.FillEllipse Method (Brush, Single, Single, Single, Single)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillEllipse (
Brush brush,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Overridable Sub FillEllipse( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPath Method

GdiGraphics.FillPath Method
[image]

Fills the interior of a .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPath (
Brush brush,
GraphicsPath path
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPath( _
brush As Brush, _
path As GraphicsPath _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
path
A .NET GraphicsPath object that represents the path to fill.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPie Method

GdiGraphics.FillPie Method
[image]

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Overload List

Name | Description
GdiGraphics.FillPie (Brush, Int32, Int32, Int32, Int32, Int32, Int32) | Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
GdiGraphics.FillPie (Brush, Rectangle, Single, Single) | Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.
GdiGraphics.FillPie (Brush, Single, Single, Single, Single, Single, Single) | Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPie Method (Brush, Int32, Int32, Int32, Int32, Int32, Int32)

GdiGraphics.FillPie Method (Brush, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
[image]

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPie (
Brush brush,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPie( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPie Method (Brush, Rectangle, Single, Single)

GdiGraphics.FillPie Method (Brush, Rectangle, Single, Single)
See Also
[image]

Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPie (
Brush brush,
Rectangle rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPie( _
brush As Brush, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPie Method (Brush, Single, Single, Single, Single, Single, Single)

GdiGraphics.FillPie Method (Brush, Single, Single, Single, Single, Single, Single)
See Also
[image]

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPie (
Brush brush,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPie( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method

GdiGraphics.FillPolygon Method
[image]

Fills the interior of a polygon defined by an array of points specified by Point structures.

Overload List

Name | Description
GdiGraphics.FillPolygon (Brush, Point[]) | Fills the interior of a polygon defined by an array of points specified by Point structures.
GdiGraphics.FillPolygon (Brush, Point[], FillMode) | Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.
GdiGraphics.FillPolygon (Brush, PointF[]) | Fills the interior of a polygon defined by an array of points specified by PointF structures.
GdiGraphics.FillPolygon (Brush, PointF[], FillMode) | Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method (Brush, Point[])

GdiGraphics.FillPolygon Method (Brush, Point[])
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPolygon (
Brush brush,
Point[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPolygon( _
brush As Brush, _
points() As Point _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that represent the vertices of the polygon to fill.

See Also

FillPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method (Brush, Point[], FillMode)

GdiGraphics.FillPolygon Method (Brush, Point[], FillMode)
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPolygon (
Brush brush,
Point[] points,
FillMode fillMode
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPolygon( _
brush As Brush, _
points() As Point, _
fillMode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that represent the vertices of the polygon to fill.
fillMode
Member of the .NET FillMode enumeration that determines the style of the fill.

See Also

FillPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method (Brush, PointF[])

GdiGraphics.FillPolygon Method (Brush, PointF[])
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPolygon (
Brush brush,
PointF[] points
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPolygon( _
brush As Brush, _
points() As PointF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that represent the vertices of the polygon to fill.

See Also

FillPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillPolygon Method (Brush, PointF[], FillMode)

GdiGraphics.FillPolygon Method (Brush, PointF[], FillMode)
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillPolygon (
Brush brush,
PointF[] points,
FillMode fillMode
)

Visual Basic [image] Copy Code

Public Overridable Sub FillPolygon( _
brush As Brush, _
points() As PointF, _
fillMode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that represent the vertices of the polygon to fill.
fillMode
Member of the .NET FillMode enumeration that determines the style of the fill.

See Also

FillPolygon Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method

GdiGraphics.FillRectangle Method
[image]

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
GdiGraphics.FillRectangle (Brush, Int32, Int32, Int32, Int32) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
GdiGraphics.FillRectangle (Brush, Rectangle) | Fills the interior of a rectangle specified by a Rectangle structure.
GdiGraphics.FillRectangle (Brush, RectangleF) | Fills the interior of a rectangle specified by a RectangleF structure.
GdiGraphics.FillRectangle (Brush, Single, Single, Single, Single) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method (Brush, Int32, Int32, Int32, Int32)

GdiGraphics.FillRectangle Method (Brush, Int32, Int32, Int32, Int32)
See Also
[image]

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRectangle (
Brush brush,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRectangle( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
The width of the rectangle to fill.
height
The height of the rectangle to fill.

See Also

FillRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method (Brush, Rectangle)

GdiGraphics.FillRectangle Method (Brush, Rectangle)
See Also
[image]

Fills the interior of a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRectangle (
Brush brush,
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRectangle( _
brush As Brush, _
rect As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the rectangle to fill.

See Also

FillRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method (Brush, RectangleF)

GdiGraphics.FillRectangle Method (Brush, RectangleF)
See Also
[image]

Fills the interior of a rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRectangle (
Brush brush,
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRectangle( _
brush As Brush, _
rect As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET RectangleF structure that represents the rectangle to fill.

See Also

FillRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangle Method (Brush, Single, Single, Single, Single)

GdiGraphics.FillRectangle Method (Brush, Single, Single, Single, Single)
See Also
[image]

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRectangle (
Brush brush,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRectangle( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
The width of the rectangle to fill.
height
The height of the rectangle to fill.

See Also

FillRectangle Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangles Method

GdiGraphics.FillRectangles Method
[image]

Fills the interiors of a series of rectangles specified by Rectangle structures.

Overload List

Name | Description
GdiGraphics.FillRectangles (Brush, Rectangle[]) | Fills the interiors of a series of rectangles specified by Rectangle structures.
GdiGraphics.FillRectangles (Brush, RectangleF[]) | Fills the interiors of a series of rectangles specified by RectangleF structures.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangles Method (Brush, Rectangle[])

GdiGraphics.FillRectangles Method (Brush, Rectangle[])
See Also
[image]

Fills the interiors of a series of rectangles specified by Rectangle structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRectangles (
Brush brush,
Rectangle[] rects
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRectangles( _
brush As Brush, _
rects() As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rects
An array of .NET Rectangle structures that represent the rectangles to fill.

See Also

FillRectangles Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRectangles Method (Brush, RectangleF[])

GdiGraphics.FillRectangles Method (Brush, RectangleF[])
See Also
[image]

Fills the interiors of a series of rectangles specified by RectangleF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRectangles (
Brush brush,
RectangleF[] rects
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRectangles( _
brush As Brush, _
rects() As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rects
An array of .NET RectangleF structures that represent the rectangles to fill.

See Also

FillRectangles Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.FillRegion Method

GdiGraphics.FillRegion Method
[image]

Fills the interior of a .NET Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void FillRegion (
Brush brush,
Region region
)

Visual Basic [image] Copy Code

Public Overridable Sub FillRegion( _
brush As Brush, _
region As Region _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
region
A .NET Region object that represents the area to fill.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Flush Method

GdiGraphics.Flush Method
[image]

Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.

Overload List

Name | Description
GdiGraphics.Flush () | Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GdiGraphics.Flush (FlushIntention) | Forces execution of all pending graphics operations with the method waiting or not waiting, as specified, to return before the operations finish.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Flush Method ()

GdiGraphics.Flush Method ()
See Also
[image]

Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void Flush ()

Visual Basic [image] Copy Code

Public Overridable Sub Flush ()

See Also

Flush Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Flush Method (FlushIntention)

GdiGraphics.Flush Method (FlushIntention)
See Also
[image]

Forces execution of all pending graphics operations with the method waiting or not waiting, as specified, to return before the operations finish.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void Flush (
FlushIntention intention
)

Visual Basic [image] Copy Code

Public Overridable Sub Flush( _
intention As FlushIntention _
)

Parameters

intention
Member of the .NET FlushIntention enumeration that specifies whether the method returns immediately or waits for any existing operations to finish.

See Also

Flush Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.GetFontHeight Method

GdiGraphics.GetFontHeight Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual float GetFontHeight (
Font font
)

Visual Basic [image] Copy Code

Public Overridable Function GetFontHeight( _
font As Font _
) As Single

Parameters

font

Return Value

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.GetHdc Method

GdiGraphics.GetHdc Method
[image]

Gets the handle to the device context associated with this GdiGraphics.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual IntPtr GetHdc ()

Visual Basic [image] Copy Code

Public Overridable Function GetHdc () As IntPtr

Return Value

Handle to the device context associated with this GdiGraphics.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.GetNearestColor Method

GdiGraphics.GetNearestColor Method
[image]

Gets the nearest color to the specified Color structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Color GetNearestColor (
Color color
)

Visual Basic [image] Copy Code

Public Overridable Function GetNearestColor( _
color As Color _
) As Color

Parameters

color
A .NET Color structure for which to find a match.

Return Value

A .NET Color structure that represents the nearest color to the one specified with the color parameter.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IntersectClip Method

GdiGraphics.IntersectClip Method
[image]

Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.

Overload List

Name | Description
GdiGraphics.IntersectClip (Rectangle) | Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.
GdiGraphics.IntersectClip (RectangleF) | Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified RectangleF structure.
GdiGraphics.IntersectClip (Region) | Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Region object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IntersectClip Method (Rectangle)

GdiGraphics.IntersectClip Method (Rectangle)
See Also
[image]

Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void IntersectClip (
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub IntersectClip( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure to intersect with the current clip region.

See Also

IntersectClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IntersectClip Method (RectangleF)

GdiGraphics.IntersectClip Method (RectangleF)
See Also
[image]

Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void IntersectClip (
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Sub IntersectClip( _
rect As RectangleF _
)

Parameters

rect
A .NET RectangleF structure to intersect with the current clip region.

See Also

IntersectClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IntersectClip Method (Region)

GdiGraphics.IntersectClip Method (Region)
See Also
[image]

Updates the clip region of this GdiGraphics object to the intersection of the current clip region and the specified Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void IntersectClip (
Region region
)

Visual Basic [image] Copy Code

Public Overridable Sub IntersectClip( _
region As Region _
)

Parameters

region
A .NET Region object to intersect with the current region.

See Also

IntersectClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method

GdiGraphics.IsVisible Method
[image]

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.IsVisible (Int32, Int32) | Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Int32, Int32, Int32, Int32) | Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Point) | Indicates whether the specified Point structure is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (PointF) | Indicates whether the specified PointF structure is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Rectangle) | Indicates whether the rectangle specified by a Rectangle structure is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (RectangleF) | Indicates whether the rectangle specified by a RectangleF structure is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Single, Single) | Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.
GdiGraphics.IsVisible (Single, Single, Single, Single) | Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Int32, Int32)

GdiGraphics.IsVisible Method (Int32, Int32)
See Also
[image]

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
int x,
int y
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
x As Integer, _
y As Integer _
) As Boolean

Parameters

x
The x-coordinate of the point to test for visibility.
y
The y-coordinate of the point to test for visibility.

Return Value

This method returns true if the point defined by the x and y parameters is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Int32, Int32, Int32, Int32)

GdiGraphics.IsVisible Method (Int32, Int32, Int32, Int32)
See Also
[image]

Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
) As Boolean

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test for visibility.
y
The y-coordinate of the upper-left corner of the rectangle to test for visibility.
width
The width of the rectangle to test for visibility.
height
The height of the rectangle to test for visibility.

Return Value

This method returns true if the rectangle defined by the x, y, width, and height parameters is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Point)

GdiGraphics.IsVisible Method (Point)
See Also
[image]

Indicates whether the specified Point structure is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
Point point
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
point As Point _
) As Boolean

Parameters

point
A .NET Point structure to test for visibility.

Return Value

This method returns true if the point specified by the point parameter is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (PointF)

GdiGraphics.IsVisible Method (PointF)
See Also
[image]

Indicates whether the specified PointF structure is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
PointF point
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
point As PointF _
) As Boolean

Parameters

point
A .NET PointF structure to test for visibility.

Return Value

This method returns true if the point specified by the point parameter is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Rectangle)

GdiGraphics.IsVisible Method (Rectangle)
See Also
[image]

Indicates whether the rectangle specified by a Rectangle structure is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
rect As Rectangle _
) As Boolean

Parameters

rect
A .NET Rectangle structure to test for visibility.

Return Value

This method returns true if the rectangle specified by the rect parameter is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (RectangleF)

GdiGraphics.IsVisible Method (RectangleF)
See Also
[image]

Indicates whether the rectangle specified by a RectangleF structure is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
rect As RectangleF _
) As Boolean

Parameters

rect
A .NET RectangleF structure to test for visibility.

Return Value

This method returns true if the rectangle specified by the rect parameter is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Single, Single)

GdiGraphics.IsVisible Method (Single, Single)
See Also
[image]

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
float x,
float y
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
x As Single, _
y As Single _
) As Boolean

Parameters

x
The x-coordinate of the point to test for visibility.
y
The y-coordinate of the point to test for visibility.

Return Value

This method returns true if the point defined by the x and y parameters is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisible Method (Single, Single, Single, Single)

GdiGraphics.IsVisible Method (Single, Single, Single, Single)
See Also
[image]

Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisible (
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Public Overridable Function IsVisible( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As Boolean

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test for visibility.
y
The y-coordinate of the upper-left corner of the rectangle to test for visibility.
width
The width of the rectangle to test for visibility.
height
The height of the rectangle to test for visibility.

Return Value

This method returns true if the rectangle defined by the x, y, width, and height parameters is contained within the visible clip region of this GdiGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureCharacterRanges Method

GdiGraphics.MeasureCharacterRanges Method
[image]

Gets an array of Region objects, each of which bounds a range of character positions within the specified string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual RectangleF[] MeasureCharacterRanges (
string text,
Font font,
RectangleF layoutRect,
StringFormat stringFormat
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureCharacterRanges( _
text As String, _
font As Font, _
layoutRect As RectangleF, _
stringFormat As StringFormat _
) As RectangleF()

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
layoutRect
A .NET RectangleF structure that specifies the layout rectangle for the string.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns an array of .NET Region objects, each of which bounds a range of character positions within the specified string.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method

GdiGraphics.MeasureString Method
[image]

Measures the specified string when drawn with the specified Font object.

Overload List

Name | Description
GdiGraphics.MeasureString (String, Font) | Measures the specified string when drawn with the specified Font object.
GdiGraphics.MeasureString (String, Font, Int32) | Measures the specified string when drawn with the specified Font object.
GdiGraphics.MeasureString (String, Font, Int32, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
GdiGraphics.MeasureString (String, Font, PointF, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
GdiGraphics.MeasureString (String, Font, SizeF) | Measures the specified string when drawn with the specified Font object within the specified layout area.
GdiGraphics.MeasureString (String, Font, SizeF, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
GdiGraphics.MeasureString (String, Font, SizeF, StringFormat, Int32@, Int32@) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font)

GdiGraphics.MeasureString Method (String, Font)
See Also
[image]

Measures the specified string when drawn with the specified Font object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified by the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, Int32)

GdiGraphics.MeasureString Method (String, Font, Int32)
See Also
[image]

Measures the specified string when drawn with the specified Font object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font,
int width
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font, _
width As Integer _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the format of the string.
width
The maximum width of the string in pixels.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, Int32, StringFormat)

GdiGraphics.MeasureString Method (String, Font, Int32, StringFormat)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font,
int width,
StringFormat format
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font, _
width As Integer, _
format As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
width
The maximum width of the string.
format
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, PointF, StringFormat)

GdiGraphics.MeasureString Method (String, Font, PointF, StringFormat)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font,
PointF origin,
StringFormat stringFormat
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font, _
origin As PointF, _
stringFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
origin
A .NET PointF structure that represents the upper-left corner of the string.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size of the string, in pixels, of the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, SizeF)

GdiGraphics.MeasureString Method (String, Font, SizeF)
See Also
[image]

Measures the specified string when drawn with the specified Font object within the specified layout area.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font,
SizeF layoutArea
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font, _
layoutArea As SizeF _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, SizeF, StringFormat)

GdiGraphics.MeasureString Method (String, Font, SizeF, StringFormat)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font,
SizeF layoutArea,
StringFormat stringFormat
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font, _
layoutArea As SizeF, _
stringFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MeasureString Method (String, Font, SizeF, StringFormat, Int32@, Int32@)

GdiGraphics.MeasureString Method (String, Font, SizeF, StringFormat, Int32@, Int32@)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SizeF MeasureString (
string text,
Font font,
SizeF layoutArea,
StringFormat stringFormat,
ref int charactersFitted,
ref int linesFilled
)

Visual Basic [image] Copy Code

Public Overridable Function MeasureString( _
text As String, _
font As Font, _
layoutArea As SizeF, _
stringFormat As StringFormat, _
ByRef charactersFitted As Integer, _
ByRef linesFilled As Integer _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.
charactersFitted
Number of characters in the string.
linesFilled
Number of text lines in the string.

Return Value

This method returns a .NET SizeF structure that represents the size of the string, in pixels, of the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MultiplyTransform Method

GdiGraphics.MultiplyTransform Method
[image]

Multiplies the world transformation of this GdiGraphics object and specified the .NET Matrix object.

Overload List

Name | Description
GdiGraphics.MultiplyTransform (Matrix) | Multiplies the world transformation of this GdiGraphics object and specified the Matrix object.
GdiGraphics.MultiplyTransform (Matrix, MatrixOrder) | Multiplies the world transformation of this GdiGraphics object and specified the Matrix object in the specified order.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MultiplyTransform Method (Matrix)

GdiGraphics.MultiplyTransform Method (Matrix)
See Also
[image]

Multiplies the world transformation of this GdiGraphics object and specified the Matrix object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void MultiplyTransform (
Matrix matrix
)

Visual Basic [image] Copy Code

Public Overridable Sub MultiplyTransform( _
matrix As Matrix _
)

Parameters

matrix
A 4x4 .NET Matrix object that multiplies the world transformation.

See Also

MultiplyTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.MultiplyTransform Method (Matrix, MatrixOrder)

GdiGraphics.MultiplyTransform Method (Matrix, MatrixOrder)
See Also
[image]

Multiplies the world transformation of this GdiGraphics object and specified the Matrix object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void MultiplyTransform (
Matrix matrix,
MatrixOrder order
)

Visual Basic [image] Copy Code

Public Overridable Sub MultiplyTransform( _
matrix As Matrix, _
order As MatrixOrder _
)

Parameters

matrix
A 4x4 .NET Matrix object that multiplies the world transformation.
order
Member of the .NET MatrixOrder enumeration that determines the order of the multiplication.

See Also

MultiplyTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ReleaseHdc Method

GdiGraphics.ReleaseHdc Method
[image]

Releases a device context handle obtained by a previous call to the GetHdc method of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ReleaseHdc (
IntPtr hdc
)

Visual Basic [image] Copy Code

Public Overridable Sub ReleaseHdc( _
hdc As IntPtr _
)

Parameters

hdc
Handle to a device context obtained by a previous call to the GetHdc method of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ReleaseHdcInternal Method

GdiGraphics.ReleaseHdcInternal Method
[image]

Internal method. Do not use.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ReleaseHdcInternal (
IntPtr hdc
)

Visual Basic [image] Copy Code

Public Overridable Sub ReleaseHdcInternal( _
hdc As IntPtr _
)

Parameters

hdc
Handle to a device context.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ResetClip Method

GdiGraphics.ResetClip Method
[image]

Resets the clip region of this GdiGraphics object to an infinite region.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ResetClip ()

Visual Basic [image] Copy Code

Public Overridable Sub ResetClip ()

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ResetTransform Method

GdiGraphics.ResetTransform Method
[image]

Resets the world transformation matrix of this GdiGraphics object to the identity matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ResetTransform ()

Visual Basic [image] Copy Code

Public Overridable Sub ResetTransform ()

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Restore Method

GdiGraphics.Restore Method
[image]

Restores the state of this GdiGraphics object to the state represented by a GraphicsState object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void Restore (
GraphicsState gstate
)

Visual Basic [image] Copy Code

Public Overridable Sub Restore( _
gstate As GraphicsState _
)

Parameters

gstate
A .NET GraphicsState object that represents the state to which to restore this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.RotateTransform Method

GdiGraphics.RotateTransform Method
[image]

Applies the specified rotation to the transformation matrix of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.RotateTransform (Single) | Applies the specified rotation to the transformation matrix of this GdiGraphics object.
GdiGraphics.RotateTransform (Single, MatrixOrder) | Applies the specified rotation to the transformation matrix of this GdiGraphics object in the specified order.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.RotateTransform Method (Single)

GdiGraphics.RotateTransform Method (Single)
See Also
[image]

Applies the specified rotation to the transformation matrix of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void RotateTransform (
float angle
)

Visual Basic [image] Copy Code

Public Overridable Sub RotateTransform( _
angle As Single _
)

Parameters

angle
The angle of rotation in degrees.

See Also

RotateTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.RotateTransform Method (Single, MatrixOrder)

GdiGraphics.RotateTransform Method (Single, MatrixOrder)
See Also
[image]

Applies the specified rotation to the transformation matrix of this GdiGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void RotateTransform (
float angle,
MatrixOrder order
)

Visual Basic [image] Copy Code

Public Overridable Sub RotateTransform( _
angle As Single, _
order As MatrixOrder _
)

Parameters

angle
The angle of rotation in degrees.
order
Member of the .NET MatrixOrder enumeration that specifies whether the rotation is appended or prepended to the matrix transformation.

See Also

RotateTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Save Method

GdiGraphics.Save Method
[image]

Saves the current state of this GdiGraphics object and identifies the saved state with a GraphicsState object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual GraphicsState Save ()

Visual Basic [image] Copy Code

Public Overridable Function Save () As GraphicsState

Return Value

This method returns a .NET GraphicsState object that represents the saved state of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ScaleTransform Method

GdiGraphics.ScaleTransform Method
[image]

Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.

Overload List

Name | Description
GdiGraphics.ScaleTransform (Single, Single) | Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.
GdiGraphics.ScaleTransform (Single, Single, MatrixOrder) | Applies the specified scaling operation to the transformation matrix of this GdiGraphics object in the specified order.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ScaleTransform Method (Single, Single)

GdiGraphics.ScaleTransform Method (Single, Single)
See Also
[image]

Applies the specified scaling operation to the transformation matrix of this GdiGraphics object by prepending it to the object's transformation matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ScaleTransform (
float sx,
float sy
)

Visual Basic [image] Copy Code

Public Overridable Sub ScaleTransform( _
sx As Single, _
sy As Single _
)

Parameters

sx
The scale factor in the x direction.
sy
The scale factor in the y direction.

See Also

ScaleTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ScaleTransform Method (Single, Single, MatrixOrder)

GdiGraphics.ScaleTransform Method (Single, Single, MatrixOrder)
See Also
[image]

Applies the specified scaling operation to the transformation matrix of this GdiGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void ScaleTransform (
float sx,
float sy,
MatrixOrder order
)

Visual Basic [image] Copy Code

Public Overridable Sub ScaleTransform( _
sx As Single, _
sy As Single, _
order As MatrixOrder _
)

Parameters

sx
The scale factor in the x direction.
sy
The scale factor in the y direction.
order
Member of the .NET MatrixOrder enumeration that specifies whether the scaling operation is prepended or appended to the transformation matrix.

See Also

ScaleTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method

GdiGraphics.SetClip Method
[image]

Sets the clipping region of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.SetClip (GraphicsPath) | Sets the clipping region of this GdiGraphics object to the specified .NET GraphicsPath object.
GdiGraphics.SetClip (GraphicsPath, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the specified .NET GraphicsPath object.
GdiGraphics.SetClip (IGraphics) | Sets the clipping region of this GdiGraphics object to the Clip property of the specified IGraphics object.
GdiGraphics.SetClip (IGraphics, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified combining operation of the current clip region and the Clip property of the specified IGraphics object.
GdiGraphics.SetClip (Rectangle) | Sets the clipping region of this GdiGraphics object to the rectangle specified by a Rectangle structure.
GdiGraphics.SetClip (Rectangle, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a Rectangle structure.
GdiGraphics.SetClip (RectangleF) | Sets the clipping region of this GdiGraphics object to the rectangle specified by a RectangleF structure.
GdiGraphics.SetClip (RectangleF, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a RectangleF structure.
GdiGraphics.SetClip (Region, CombineMode) | Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the specified Region object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (GraphicsPath)

GdiGraphics.SetClip Method (GraphicsPath)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the specified .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
GraphicsPath path
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
path As GraphicsPath _
)

Parameters

path
A .NET GraphicsPath object that represents the new clip region.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (GraphicsPath, CombineMode)

GdiGraphics.SetClip Method (GraphicsPath, CombineMode)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the specified .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
GraphicsPath path,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
path As GraphicsPath, _
combineMode As CombineMode _
)

Parameters

path
A .NET GraphicsPath object to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (IGraphics)

GdiGraphics.SetClip Method (IGraphics)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the Clip property of the specified IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
IGraphics g
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
g As IGraphics _
)

Parameters

g
An IGraphics object from which to take the new clip region.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (IGraphics, CombineMode)

GdiGraphics.SetClip Method (IGraphics, CombineMode)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the result of the specified combining operation of the current clip region and the Clip property of the specified IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
IGraphics g,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
g As IGraphics, _
combineMode As CombineMode _
)

Parameters

g
An IGraphics object that specifies the clip region to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (Rectangle)

GdiGraphics.SetClip Method (Rectangle)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
Rectangle rect
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure that represents the new clip region.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (Rectangle, CombineMode)

GdiGraphics.SetClip Method (Rectangle, CombineMode)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
Rectangle rect,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
rect As Rectangle, _
combineMode As CombineMode _
)

Parameters

rect
A .NET Rectangle structure to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (RectangleF)

GdiGraphics.SetClip Method (RectangleF)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
RectangleF rect
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
rect As RectangleF _
)

Parameters

rect
A .NET RectangleF structure that represents the new clip region.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (RectangleF, CombineMode)

GdiGraphics.SetClip Method (RectangleF, CombineMode)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
RectangleF rect,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
rect As RectangleF, _
combineMode As CombineMode _
)

Parameters

rect
A .NET RectangleF structure to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SetClip Method (Region, CombineMode)

GdiGraphics.SetClip Method (Region, CombineMode)
See Also
[image]

Sets the clipping region of this GdiGraphics object to the result of the specified operation combining the current clip region and the specified Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void SetClip (
Region region,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Public Overridable Sub SetClip( _
region As Region, _
combineMode As CombineMode _
)

Parameters

region
A .NET Region object to combine.
combineMode
Member from the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TransformPoints Method

GdiGraphics.TransformPoints Method
[image]

Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.TransformPoints (CoordinateSpace, CoordinateSpace, Point[]) | Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.
GdiGraphics.TransformPoints (CoordinateSpace, CoordinateSpace, PointF[]) | Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, Point[])

GdiGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, Point[])
See Also
[image]

Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void TransformPoints (
CoordinateSpace destSpace,
CoordinateSpace srcSpace,
Point[] pts
)

Visual Basic [image] Copy Code

Public Overridable Sub TransformPoints( _
destSpace As CoordinateSpace, _
srcSpace As CoordinateSpace, _
pts() As Point _
)

Parameters

destSpace
Member of the .NET CoordinateSpace enumeration that specifies the destination coordinate space.
srcSpace
Member of the .NET CoordinateSpace enumeration that specifies the source coordinate space.
pts
An array of .NET Point structures that represents the points to transformation.

See Also

TransformPoints Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, PointF[])

GdiGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, PointF[])
See Also
[image]

Transforms an array of points from one coordinate space to another using the current world and page transformations of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void TransformPoints (
CoordinateSpace destSpace,
CoordinateSpace srcSpace,
PointF[] pts
)

Visual Basic [image] Copy Code

Public Overridable Sub TransformPoints( _
destSpace As CoordinateSpace, _
srcSpace As CoordinateSpace, _
pts() As PointF _
)

Parameters

destSpace
Member of the .NET CoordinateSpace enumeration that specifies the destination coordinate space.
srcSpace
Member of the .NET CoordinateSpace enumeration that specifies the source coordinate space.
pts
An array of .NET PointF structures that represent the points to transform.

See Also

TransformPoints Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateClip Method

GdiGraphics.TranslateClip Method
[image]

Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.

Overload List

Name | Description
GdiGraphics.TranslateClip (Int32, Int32) | Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.
GdiGraphics.TranslateClip (Single, Single) | Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateClip Method (Int32, Int32)

GdiGraphics.TranslateClip Method (Int32, Int32)
See Also
[image]

Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void TranslateClip (
int dx,
int dy
)

Visual Basic [image] Copy Code

Public Overridable Sub TranslateClip( _
dx As Integer, _
dy As Integer _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateClip Method (Single, Single)

GdiGraphics.TranslateClip Method (Single, Single)
See Also
[image]

Translates the clipping region of this GdiGraphics object by specified amounts in the horizontal and vertical directions.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void TranslateClip (
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Overridable Sub TranslateClip( _
dx As Single, _
dy As Single _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateClip Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateTransform Method

GdiGraphics.TranslateTransform Method
[image]

Prepends the specified translation to the transformation matrix of this GdiGraphics object.

Overload List

Name | Description
GdiGraphics.TranslateTransform (Single, Single) | Prepends the specified translation to the transformation matrix of this GdiGraphics object.
GdiGraphics.TranslateTransform (Single, Single, MatrixOrder) | Applies the specified translation to the transformation matrix of this GdiGraphics object in the specified order.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateTransform Method (Single, Single)

GdiGraphics.TranslateTransform Method (Single, Single)
See Also
[image]

Prepends the specified translation to the transformation matrix of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void TranslateTransform (
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Overridable Sub TranslateTransform( _
dx As Single, _
dy As Single _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TranslateTransform Method (Single, Single, MatrixOrder)

GdiGraphics.TranslateTransform Method (Single, Single, MatrixOrder)
See Also
[image]

Applies the specified translation to the transformation matrix of this GdiGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void TranslateTransform (
float dx,
float dy,
MatrixOrder order
)

Visual Basic [image] Copy Code

Public Overridable Sub TranslateTransform( _
dx As Single, _
dy As Single, _
order As MatrixOrder _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.
order
Member of the .NET MatrixOrder enumeration that specifies whether the translation is prepended or appended to the transformation matrix.

See Also

TranslateTransform Method Overload List
GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics Properties

GdiGraphics Properties
[image]

Public Properties

Name | Description
Clip | Gets or sets a .NET Region object that limits the drawing region of this GdiGraphics object.
ClipBounds | Gets a .NET RectangleF structure that bounds the clipping region of this GdiGraphics object.
CompositingMode | Gets or sets a value that specifies how composited images are drawn to this GdiGraphics object.
CompositingQuality | Gets or sets the rendering quality of composited images drawn to this GdiGraphics object.
DpiX | Gets the horizontal resolution of this GdiGraphics object.
DpiY | Gets the vertical resolution of this GdiGraphics object.
Graphics | Gets a reference to the underlying .NET Graphics object.
InterpolationMode | Gets or sets the interpolation mode associated with this GdiGraphics object.
IsClipEmpty | Gets a value indicating whether the clipping region of this GdiGraphics object is empty.
IsVisibleClipEmpty | Gets a value indicating whether the visible clipping region of this GdiGraphics object is empty.
PageScale | Gets or sets the scaling between world units and page units for this GdiGraphics object.
PageUnit | Gets or sets the unit of measure used for page coordinates in this GdiGraphics object.
PixelOffsetMode | Gets or set a value specifying how pixels are offset during rendering of this GdiGraphics object.
RenderingOrigin | Gets or sets the rendering origin of this GdiGraphics object for dithering and for hatch brushes.
SmoothingMode | Gets or sets the rendering quality for this GdiGraphics object.
TextContrast | Gets or sets the gamma correction value for rendering text.
TextRenderingHint | Gets or sets the rendering mode for text associated with this GdiGraphics object.
Transform | Gets or sets the world transformation for this GdiGraphics object.
VisibleClipBounds | Gets the bounding rectangle of the visible clipping region of this GdiGraphics object.

See Also

GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Clip Property

GdiGraphics.Clip Property
[image]

Gets or sets a .NET Region object that limits the drawing region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Region Clip { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Clip As Region

Property Value

This property specifies a .NET Region object that limits the portion of this GdiGraphics object that is currently available for drawing.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.ClipBounds Property

GdiGraphics.ClipBounds Property
[image]

Gets a .NET RectangleF structure that bounds the clipping region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual RectangleF ClipBounds { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property ClipBounds As RectangleF

Property Value

This property indicates a .NET RectangleF structure that represents a bounding rectangle for the clipping region of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.CompositingMode Property

GdiGraphics.CompositingMode Property
[image]

Gets or sets a value that specifies how composited images are drawn to this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual CompositingMode CompositingMode { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property CompositingMode As CompositingMode

Property Value

This property specifies a member of the .NET CompositingMode enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.CompositingQuality Property

GdiGraphics.CompositingQuality Property
[image]

Gets or sets the rendering quality of composited images drawn to this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual CompositingQuality CompositingQuality { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property CompositingQuality As CompositingQuality

Property Value

This property specifies a member of the .NET CompositingQuality enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DpiX Property

GdiGraphics.DpiX Property
[image]

Gets the horizontal resolution of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual float DpiX { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property DpiX As Single

Property Value

This property indicates a value, in dots per inch, for the horizontal resolution supported by this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.DpiY Property

GdiGraphics.DpiY Property
[image]

Gets the vertical resolution of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual float DpiY { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property DpiY As Single

Property Value

This property indicates a value, in dots per inch, for the vertical resolution supported by this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Graphics Property

GdiGraphics.Graphics Property
[image]

Gets a reference to the underlying .NET Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Graphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As Graphics

Property Value

An instance of the .NET System.Drawing.Graphics class.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.InterpolationMode Property

GdiGraphics.InterpolationMode Property
[image]

Gets or sets the interpolation mode associated with this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual InterpolationMode InterpolationMode { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property InterpolationMode As InterpolationMode

Property Value

This property specifies a member of the InterpolationMode enumeration associated with this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsClipEmpty Property

GdiGraphics.IsClipEmpty Property
[image]

Gets a value indicating whether the clipping region of this GdiGraphics object is empty.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsClipEmpty { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsClipEmpty As Boolean

Property Value

This property is true if the clipping region of this GdiGraphics object is empty; otherwise, false.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.IsVisibleClipEmpty Property

GdiGraphics.IsVisibleClipEmpty Property
[image]

Gets a value indicating whether the visible clipping region of this GdiGraphics object is empty.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual bool IsVisibleClipEmpty { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsVisibleClipEmpty As Boolean

Property Value

This property is true if the visible portion of the clipping region of this GdiGraphics object is empty; otherwise, false.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.PageScale Property

GdiGraphics.PageScale Property
[image]

Gets or sets the scaling between world units and page units for this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual float PageScale { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property PageScale As Single

Property Value

This property specifies a value for the scaling between world units and page units for this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.PageUnit Property

GdiGraphics.PageUnit Property
[image]

Gets or sets the unit of measure used for page coordinates in this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual GraphicsUnit PageUnit { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property PageUnit As GraphicsUnit

Property Value

This property specifies a member of the .NET GraphicsUnit enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.PixelOffsetMode Property

GdiGraphics.PixelOffsetMode Property
[image]

Gets or set a value specifying how pixels are offset during rendering of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual PixelOffsetMode PixelOffsetMode { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property PixelOffsetMode As PixelOffsetMode

Property Value

This property specifies a member of the .NET PixelOffsetMode enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.RenderingOrigin Property

GdiGraphics.RenderingOrigin Property
[image]

Gets or sets the rendering origin of this GdiGraphics object for dithering and for hatch brushes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Point RenderingOrigin { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property RenderingOrigin As Point

Property Value

This property specifies a .NET Point structure that represents the dither origin for 8-bits-per-pixel and 16-bits-per-pixel dithering and is also used to set the origin for hatch brushes.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.SmoothingMode Property

GdiGraphics.SmoothingMode Property
[image]

Gets or sets the rendering quality for this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual SmoothingMode SmoothingMode { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property SmoothingMode As SmoothingMode

Property Value

This property specifies a member of the .NET SmoothingMode enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TextContrast Property

GdiGraphics.TextContrast Property
[image]

Gets or sets the gamma correction value for rendering text.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual int TextContrast { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property TextContrast As Integer

Property Value

This property specifies a value of the gamma correction used for rendering antialiased and ClearType text.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.TextRenderingHint Property

GdiGraphics.TextRenderingHint Property
[image]

Gets or sets the rendering mode for text associated with this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual TextRenderingHint TextRenderingHint { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property TextRenderingHint As TextRenderingHint

Property Value

This property specifies a member of the .NET TextRenderingHint enumeration.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.Transform Property

GdiGraphics.Transform Property
[image]

Gets or sets the world transformation for this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Matrix Transform { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Transform As Matrix

Property Value

This property specifies a Matrix object that represents the world transformation for this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GdiGraphics.VisibleClipBounds Property

GdiGraphics.VisibleClipBounds Property
[image]

Gets the bounding rectangle of the visible clipping region of this GdiGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual RectangleF VisibleClipBounds { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property VisibleClipBounds As RectangleF

Property Value

A .NET RectangleF structure that represents a bounding rectangle for the visible clipping region of this GdiGraphics object.

See Also

GdiGraphics Members
GdiGraphics Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Class

GraphicObject Class
[image]

The base class for graphical objects such as pens and brushes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract class GraphicObject : ICloneable

Visual Basic [image] Copy Code

Public MustInherit Class GraphicObject
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject

See Also

GraphicObject Members
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Members

GraphicObject Members
Constructors Methods
[image]

The base class for graphical objects such as pens and brushes.

The following tables list the members exposed by the GraphicObject type.

Protected Constructors

Name | Description
GraphicObject | Initializes a new instance of the GraphicObject class.

Public Methods

Name | Description
Clone | Creates an exact copy of the graphic object.
Deserialize | Creates and returns a new graphics object according to its string representation.
Equals | Determines whether two GraphicObject instances are equal.
GetHashCode | Returns a hash code for this object.
Serialize | Serializes the specified object to a string.

See Also

GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Constructor

GraphicObject Constructor
[image]

Initializes a new instance of the GraphicObject class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

protected GraphicObject ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Methods

GraphicObject Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of the graphic object.
Deserialize | Creates and returns a new graphics object according to its string representation.
Equals | Determines whether two GraphicObject instances are equal.
GetHashCode | Returns a hash code for this object.
Serialize | Serializes the specified object to a string.

See Also

GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Clone Method

GraphicObject.Clone Method
[image]

Creates an exact copy of the graphic object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract Object Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Object

Return Value

An instance of the GraphicObject class.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Deserialize Method

GraphicObject.Deserialize Method
[image]

Creates and returns a new graphics object according to its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static GraphicObject Deserialize (
string image
)

Visual Basic [image] Copy Code

Public Shared Function Deserialize ( _
image As String _
) As GraphicObject

Parameters

image
A string that represents the serialized object.

Return Value

An instance of the GraphicObject class.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Equals Method

GraphicObject.Equals Method
[image]

Determines whether two GraphicObject instances are equal.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare to this one.

Return Value

true is the objects are equal; otherwise, false.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.GetHashCode Method

GraphicObject.GetHashCode Method
[image]

Returns a hash code for this object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for this object.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Serialize Method

GraphicObject.Serialize Method
[image]

Serializes the specified object to a string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string Serialize (
GraphicObject obj
)

Visual Basic [image] Copy Code

Public Shared Function Serialize ( _
obj As GraphicObject _
) As String

Parameters

obj
The graphic object to serialize.

Return Value

A string that represents the specified object.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Class

HatchBrush Class
Remarks See Also
[image]

HatchBrush objects represent rectangular brushes with a hatch style, a foreground color, and a background color that are used to fill the interiors of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class HatchBrush : Brush, ISerializable

Visual Basic [image] Copy Code

Public Class HatchBrush
Inherits Brush
Implements ISerializable

Remarks

The HatchBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.Drawing2D.HatchBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.HatchBrush

See Also

HatchBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Members

HatchBrush Members
Constructors Properties Methods
[image]

HatchBrush objects represent rectangular brushes with a hatch style, a foreground color, and a background color that are used to fill the interiors of geometric shapes.

The following tables list the members exposed by the HatchBrush type.

Public Constructors

Name | Description
HatchBrush | Overloaded. Initialize a new instance of the HatchBrush class with the specified attributes.

Public Properties

Name | Description
BackgroundColor | Gets or sets the color of spaces between the hatch lines drawn by this brush.
ForegroundColor | Gets or sets the color of hatch lines drawn by this brush.
HatchStyle | Gets or sets the hatch style of this brush.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.Drawing2D.HatchBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Hatch".

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Constructor

HatchBrush Constructor
[image]

Initialize a new instance of the HatchBrush class with the specified attributes.

Overload List

Name | Description
HatchBrush (HatchStyle, Color) | Initializes a new instance of the HatchBrush class with the specified hatch style and color.
HatchBrush (HatchStyle, Color, Color) | Initializes a new instance of the HatchBrush class with the specified style, foreground color and background color.
HatchBrush (String) | Initializes a new instance of the HatchBrush class according to its string representation.

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Constructor (HatchStyle, Color)

HatchBrush Constructor (HatchStyle, Color)
See Also
[image]

Initializes a new instance of the HatchBrush class with the specified hatch style and color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public HatchBrush (
HatchStyle hatchStyle,
Color foreColor
)

Visual Basic [image] Copy Code

Public New ( _
hatchStyle As HatchStyle, _
foreColor As Color _
)

Parameters

hatchStyle
A member of the .NET HatchStyle enumeration that represents the pattern drawn by this brush.
foreColor
A Color structure that specifies the color of lines drawn by this brush.

See Also

HatchBrush Constructor Overload List
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Constructor (HatchStyle, Color, Color)

HatchBrush Constructor (HatchStyle, Color, Color)
See Also
[image]

Initializes a new instance of the HatchBrush class with the specified style, foreground color and background color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public HatchBrush (
HatchStyle hatchStyle,
Color foreColor,
Color backColor
)

Visual Basic [image] Copy Code

Public New ( _
hatchStyle As HatchStyle, _
foreColor As Color, _
backColor As Color _
)

Parameters

hatchStyle
A member of the .NET HatchStyle enumeration that represents the pattern drawn by this brush.
foreColor
A Color structure that specifies the color of lines drawn by this brush.
backColor
A Color structure that specifies the color of spaces between the lines drawn by this brush.

See Also

HatchBrush Constructor Overload List
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Constructor (String)

HatchBrush Constructor (String)
See Also
[image]

Initializes a new instance of the HatchBrush class according to its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public HatchBrush (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized bursh.

See Also

HatchBrush Constructor Overload List
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Methods

HatchBrush Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.Drawing2D.HatchBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Hatch".

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.Clone Method

HatchBrush.Clone Method
[image]

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the HatchBrush class.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.CreateGdiBrush Method

HatchBrush.CreateGdiBrush Method
[image]

Returns an instance of the System.Drawing.Drawing2D.HatchBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush CreateGdiBrush (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Overrides Function CreateGdiBrush( _
rc As RectangleF _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.GetObjectData Method

HatchBrush.GetObjectData Method
[image]

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub GetObjectData( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info

The object that holds the serialized object data.

context

The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.ToString Method

HatchBrush.ToString Method
[image]

Returns "Hatch".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Properties

HatchBrush Properties
[image]

Public Properties

Name | Description
BackgroundColor | Gets or sets the color of spaces between the hatch lines drawn by this brush.
ForegroundColor | Gets or sets the color of hatch lines drawn by this brush.
HatchStyle | Gets or sets the hatch style of this brush.

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.BackgroundColor Property

HatchBrush.BackgroundColor Property
[image]

Gets or sets the color of spaces between the hatch lines drawn by this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color BackgroundColor { get; set; }

Visual Basic [image] Copy Code

Public Property BackgroundColor As Color

Property Value

An instance of the .NET Color structure that represents the background color of this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.ForegroundColor Property

HatchBrush.ForegroundColor Property
[image]

Gets or sets the color of hatch lines drawn by this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color ForegroundColor { get; set; }

Visual Basic [image] Copy Code

Public Property ForegroundColor As Color

Property Value

An instance of the .NET Color structure that represents the foreground color of this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.HatchStyle Property

HatchBrush.HatchStyle Property
[image]

Gets or sets the hatch style of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public HatchStyle HatchStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HatchStyle As HatchStyle

Property Value

A member of the .NET HatchStyle enumeration that represents the pattern of this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Interface

IGraphics Interface
[image]

This interface exposes the public interface of the .NET System.Drawing.Graphics class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public interface IGraphics

Visual Basic [image] Copy Code

Public Interface IGraphics

See Also

IGraphics Members
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Members

IGraphics Members
Properties Methods
[image]

This interface exposes the public interface of the .NET System.Drawing.Graphics class.

The following tables list the members exposed by the IGraphics type.

Public Properties

Name | Description
Clip | Gets or sets a .NET Region object that limits the drawing region of this IGraphics object.
ClipBounds | Gets a .NET RectangleF structure that bounds the clipping region of this IGraphics object.
CompositingMode | Gets or sets a value that specifies how composited images are drawn to this IGraphics object.
CompositingQuality | Gets or sets the rendering quality of composited images drawn to this IGraphics object.
DpiX | Gets the horizontal resolution of this IGraphics object.
DpiY | Gets the vertical resolution of this IGraphics object.
InterpolationMode | Gets or sets the interpolation mode associated with this IGraphics object.
IsClipEmpty | Gets a value indicating whether the clipping region of this IGraphics object is empty.
IsVisibleClipEmpty | Gets a value indicating whether the visible clipping region of this IGraphics object is empty.
PageScale | Gets or sets the scaling between world units and page units for this IGraphics object.
PageUnit | Gets or sets the unit of measure used for page coordinates in this IGraphics object.
PixelOffsetMode | Gets or set a value specifying how pixels are offset during rendering of this IGraphics object.
RenderingOrigin | Gets or sets the rendering origin of this IGraphics object for dithering and for hatch brushes.
SmoothingMode | Gets or sets the rendering quality for this IGraphics object.
TextContrast | Gets or sets the gamma correction value for rendering text.
TextRenderingHint | Gets or sets the rendering mode for text associated with this IGraphics object.
Transform | Gets or sets the world transformation for this IGraphics object.
VisibleClipBounds | Gets or sets the bounding rectangle of the visible clipping region of this IGraphics object.

Public Methods

Name | Description
AddMetafileComment | Adds a comment to the current Metafile object.
BeginContainer | Overloaded. Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.
BeginHyperLink |
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Releases all resources used by this IGraphics object.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bézier spline defined by four .NET Point structures.
DrawBeziers | Overloaded. Draws a series of Bézier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of Point structures.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawIcon | Overloaded. Draws the image represented by the specified .NET Icon object at the specified coordinates.
DrawIconUnstretched | Draws the image represented by the specified .NET Icon object without scaling the image.
DrawImage | Overloaded. Draws the specified .NET Image object at the specified location and with the original size.
DrawImageUnscaled | Overloaded. Draws the specified image using its original physical size at the location specified by a coordinate pair.
DrawLine | Overloaded. Draws a line connecting the two points specified by coordinate pairs.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a .NET GraphicsPath object.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of Point structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangles | Overloaded. Draws a series of rectangles specified by Rectangle structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndContainer | Closes the current graphics container and restores the state of this IGraphics object to the state saved by a call to the BeginContainer method.
EndHyperLink |
ExcludeClip | Overloaded. Updates the clip region of this IGraphics object to exclude the area specified by a .NET Rectangle structure.
FillClosedCurve | Overloaded. Fills the interior a closed cardinal spline curve defined by an array of Point structures.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillPath | Fills the interior of a .NET GraphicsPath object.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by Point structures.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a .NET Region object.
Flush | Overloaded. Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GetFontHeight |
GetHdc | Gets the handle to the device context associated with this IGraphics.
GetNearestColor | Gets the nearest color to the specified Color structure.
IntersectClip | Overloaded. Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IsVisible | Overloaded. Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.
MeasureCharacterRanges | Gets an array of Region objects, each of which bounds a range of character positions within the specified string.
MeasureString | Overloaded. Measures the specified string when drawn with the specified Font object.
MultiplyTransform | Overloaded. Multiplies the world transformation of this IGraphics object and specified the .NET Matrix object.
ReleaseHdc | Releases a device context handle obtained by a previous call to the GetHdc method of this IGraphics object.
ReleaseHdcInternal | Internal method. Do not use.
ResetClip | Resets the clip region of this IGraphics object to an infinite region.
ResetTransform | Resets the world transformation matrix of this IGraphics object to the identity matrix.
Restore | Restores the state of this IGraphics object to the state represented by a GraphicsState object.
RotateTransform | Overloaded. Applies the specified rotation to the transformation matrix of this IGraphics object.
Save | Saves the current state of this IGraphics object and identifies the saved state with a GraphicsState object.
ScaleTransform | Overloaded. Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.
SetClip | Overloaded. Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.
TransformPoints | Overloaded. Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.
TranslateClip | Overloaded. Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.
TranslateTransform | Overloaded. Prepends the specified translation to the transformation matrix of this IGraphics object.

See Also

IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Methods

IGraphics Methods
[image]

Public Methods

Name | Description
AddMetafileComment | Adds a comment to the current Metafile object.
BeginContainer | Overloaded. Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.
BeginHyperLink |
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Releases all resources used by this IGraphics object.
DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawBezier | Overloaded. Draws a Bézier spline defined by four .NET Point structures.
DrawBeziers | Overloaded. Draws a series of Bézier splines from an array of Point structures.
DrawClosedCurve | Overloaded. Draws a closed cardinal spline defined by an array of Point structures.
DrawCurve | Overloaded. Draws a cardinal spline through a specified array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawIcon | Overloaded. Draws the image represented by the specified .NET Icon object at the specified coordinates.
DrawIconUnstretched | Draws the image represented by the specified .NET Icon object without scaling the image.
DrawImage | Overloaded. Draws the specified .NET Image object at the specified location and with the original size.
DrawImageUnscaled | Overloaded. Draws the specified image using its original physical size at the location specified by a coordinate pair.
DrawLine | Overloaded. Draws a line connecting the two points specified by coordinate pairs.
DrawLines | Overloaded. Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws a .NET GraphicsPath object.
DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
DrawPolygon | Overloaded. Draws a polygon defined by an array of Point structures.
DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangles | Overloaded. Draws a series of rectangles specified by Rectangle structures.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
EndContainer | Closes the current graphics container and restores the state of this IGraphics object to the state saved by a call to the BeginContainer method.
EndHyperLink |
ExcludeClip | Overloaded. Updates the clip region of this IGraphics object to exclude the area specified by a .NET Rectangle structure.
FillClosedCurve | Overloaded. Fills the interior a closed cardinal spline curve defined by an array of Point structures.
FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillPath | Fills the interior of a .NET GraphicsPath object.
FillPie | Overloaded. Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
FillPolygon | Overloaded. Fills the interior of a polygon defined by an array of points specified by Point structures.
FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FillRectangles | Overloaded. Fills the interiors of a series of rectangles specified by Rectangle structures.
FillRegion | Fills the interior of a .NET Region object.
Flush | Overloaded. Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
GetFontHeight |
GetHdc | Gets the handle to the device context associated with this IGraphics.
GetNearestColor | Gets the nearest color to the specified Color structure.
IntersectClip | Overloaded. Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IsVisible | Overloaded. Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.
MeasureCharacterRanges | Gets an array of Region objects, each of which bounds a range of character positions within the specified string.
MeasureString | Overloaded. Measures the specified string when drawn with the specified Font object.
MultiplyTransform | Overloaded. Multiplies the world transformation of this IGraphics object and specified the .NET Matrix object.
ReleaseHdc | Releases a device context handle obtained by a previous call to the GetHdc method of this IGraphics object.
ReleaseHdcInternal | Internal method. Do not use.
ResetClip | Resets the clip region of this IGraphics object to an infinite region.
ResetTransform | Resets the world transformation matrix of this IGraphics object to the identity matrix.
Restore | Restores the state of this IGraphics object to the state represented by a GraphicsState object.
RotateTransform | Overloaded. Applies the specified rotation to the transformation matrix of this IGraphics object.
Save | Saves the current state of this IGraphics object and identifies the saved state with a GraphicsState object.
ScaleTransform | Overloaded. Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.
SetClip | Overloaded. Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.
TransformPoints | Overloaded. Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.
TranslateClip | Overloaded. Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.
TranslateTransform | Overloaded. Prepends the specified translation to the transformation matrix of this IGraphics object.

See Also

IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.AddMetafileComment Method

IGraphics.AddMetafileComment Method
[image]

Adds a comment to the current Metafile object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddMetafileComment (
byte[] data
)

Visual Basic [image] Copy Code

Sub AddMetafileComment( _
data() As Byte _
)

Parameters

data
Array of bytes that contains the comment.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginContainer Method

IGraphics.BeginContainer Method
[image]

Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.

Overload List

Name | Description
IGraphics.BeginContainer () | Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.
IGraphics.BeginContainer (Rectangle, Rectangle, GraphicsUnit) | Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container with the specified scale transformation.
IGraphics.BeginContainer (RectangleF, RectangleF, GraphicsUnit) | Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container with the specified scale transformation.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginContainer Method ()

IGraphics.BeginContainer Method ()
See Also
[image]

Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

GraphicsContainer BeginContainer ()

Visual Basic [image] Copy Code

Function BeginContainer () As GraphicsContainer

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this IGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginContainer Method (Rectangle, Rectangle, GraphicsUnit)

IGraphics.BeginContainer Method (Rectangle, Rectangle, GraphicsUnit)
See Also
[image]

Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container with the specified scale transformation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

GraphicsContainer BeginContainer (
Rectangle dstrect,
Rectangle srcrect,
GraphicsUnit unit
)

Visual Basic [image] Copy Code

Function BeginContainer( _
dstrect As Rectangle, _
srcrect As Rectangle, _
unit As GraphicsUnit _
) As GraphicsContainer

Parameters

dstrect
A .NET Rectangle structure that, together with the srcrect parameter, specifies a scale transformation for the container.
srcrect
A .NET Rectangle structure that, together with the dstrect parameter, specifies a scale transformation for the container.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure for the container.

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this IGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginContainer Method (RectangleF, RectangleF, GraphicsUnit)

IGraphics.BeginContainer Method (RectangleF, RectangleF, GraphicsUnit)
See Also
[image]

Saves a graphics container with the current state of this IGraphics object and opens and uses a new graphics container with the specified scale transformation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

GraphicsContainer BeginContainer (
RectangleF dstrect,
RectangleF srcrect,
GraphicsUnit unit
)

Visual Basic [image] Copy Code

Function BeginContainer( _
dstrect As RectangleF, _
srcrect As RectangleF, _
unit As GraphicsUnit _
) As GraphicsContainer

Parameters

dstrect
A .NET RectangleF structure that, together with the srcrect parameter, specifies a scale transformation for the new graphics container.
srcrect
A .NET RectangleF structure that, together with the dstrect parameter, specifies a scale transformation for the new graphics container.
unit
Member of the .NET GraphicsUnit enumeration that specifies the unit of measure for the container.

Return Value

This method returns a .NET GraphicsContainer object that represents the state of this IGraphics object at the time of the method call.

See Also

BeginContainer Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginHyperLink Method

IGraphics.BeginHyperLink Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void BeginHyperLink (
string url,
string target
)

Visual Basic [image] Copy Code

Sub BeginHyperLink( _
url As String, _
target As String _
)

Parameters

url

target

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Clear Method

IGraphics.Clear Method
[image]

Clears the entire drawing surface and fills it with the specified background color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Clear (
Color color
)

Visual Basic [image] Copy Code

Sub Clear( _
color As Color _
)

Parameters

color
A .NET Color structure that represents the background color of the drawing surface.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Dispose Method

IGraphics.Dispose Method
[image]

Releases all resources used by this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Dispose ()

Visual Basic [image] Copy Code

Sub Dispose ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method

IGraphics.DrawArc Method
[image]

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
IGraphics.DrawArc (Pen, Int32, Int32, Int32, Int32, Int32, Int32) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
IGraphics.DrawArc (Pen, Rectangle, Single, Single) | Draws an arc representing a portion of an ellipse specified by a .NET Rectangle structure.
IGraphics.DrawArc (Pen, RectangleF, Single, Single) | Draws an arc representing a portion of an ellipse specified by a .NET RectangleF structure.
IGraphics.DrawArc (Pen, Single, Single, Single, Single, Single, Single) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

IGraphics.DrawArc Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawArc (
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawArc( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
The width of the rectangle that defines the ellipse.
height
The height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, Rectangle, Single, Single)

IGraphics.DrawArc Method (Pen, Rectangle, Single, Single)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a .NET Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawArc (
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawArc( _
pen As Pen, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
rect
A .NET Rectangle structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, RectangleF, Single, Single)

IGraphics.DrawArc Method (Pen, RectangleF, Single, Single)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a .NET RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawArc (
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawArc( _
pen As Pen, _
rect As RectangleF, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, Single, Single, Single, Single, Single, Single)

IGraphics.DrawArc Method (Pen, Single, Single, Single, Single, Single, Single)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawArc (
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawArc( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
The width of the rectangle that defines the ellipse.
height
The height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBezier Method

IGraphics.DrawBezier Method
[image]

Draws a Bézier spline defined by four .NET Point structures.

Overload List

Name | Description
IGraphics.DrawBezier (Pen, Point, Point, Point, Point) | Draws a Bézier spline defined by four Point structures.
IGraphics.DrawBezier (Pen, PointF, PointF, PointF, PointF) | Draws a Bézier spline defined by four PointF structures.
IGraphics.DrawBezier (Pen, Single, Single, Single, Single, Single, Single, Single, Single) | Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBezier Method (Pen, Point, Point, Point, Point)

IGraphics.DrawBezier Method (Pen, Point, Point, Point, Point)
See Also
[image]

Draws a Bézier spline defined by four Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawBezier (
Pen pen,
Point pt1,
Point pt2,
Point pt3,
Point pt4
)

Visual Basic [image] Copy Code

Sub DrawBezier( _
pen As Pen, _
pt1 As Point, _
pt2 As Point, _
pt3 As Point, _
pt4 As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
pt1
A .NET Point structure that represents the starting point of the curve.
pt2
A .NET Point structure that represents the first control point for the curve.
pt3
A .NET Point structure that represents the second control point for the curve.
pt4
A .NET Point structure that represents the ending point of the curve.

See Also

DrawBezier Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBezier Method (Pen, PointF, PointF, PointF, PointF)

IGraphics.DrawBezier Method (Pen, PointF, PointF, PointF, PointF)
See Also
[image]

Draws a Bézier spline defined by four PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawBezier (
Pen pen,
PointF pt1,
PointF pt2,
PointF pt3,
PointF pt4
)

Visual Basic [image] Copy Code

Sub DrawBezier( _
pen As Pen, _
pt1 As PointF, _
pt2 As PointF, _
pt3 As PointF, _
pt4 As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
pt1
A .NET PointF structure that represents the starting point of the curve.
pt2
A .NET PointF structure that represents the first control point for the curve.
pt3
A .NET PointF structure that represents the second control point for the curve.
pt4
A .NET PointF structure that represents the ending point of the curve.

See Also

DrawBezier Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBezier Method (Pen, Single, Single, Single, Single, Single, Single, Single, Single)

IGraphics.DrawBezier Method (Pen, Single, Single, Single, Single, Single, Single, Single, Single)
See Also
[image]

Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawBezier (
Pen pen,
float x1,
float y1,
float x2,
float y2,
float x3,
float y3,
float x4,
float y4
)

Visual Basic [image] Copy Code

Sub DrawBezier( _
pen As Pen, _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single, _
x3 As Single, _
y3 As Single, _
x4 As Single, _
y4 As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
x1
The x-coordinate of the starting point of the curve.
y1
The y-coordinate of the starting point of the curve.
x2
The x-coordinate of the first control point of the curve.
y2
The y-coordinate of the first control point of the curve.
x3
The x-coordinate of the second control point of the curve.
y3
The y-coordinate of the second control point of the curve.
x4
The x-coordinate of the ending point of the curve.
y4
The y-coordinate of the ending point of the curve.

See Also

DrawBezier Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBeziers Method

IGraphics.DrawBeziers Method
[image]

Draws a series of Bézier splines from an array of Point structures.

Overload List

Name | Description
IGraphics.DrawBeziers (Pen, Point[]) | Draws a series of Bézier splines from an array of Point structures.
IGraphics.DrawBeziers (Pen, PointF[]) | Draws a series of Bézier splines from an array of PointF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBeziers Method (Pen, Point[])

IGraphics.DrawBeziers Method (Pen, Point[])
See Also
[image]

Draws a series of Bézier splines from an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawBeziers (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Sub DrawBeziers( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
points
An array of .NET Point structures that represent the points that determine the curve.

See Also

DrawBeziers Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBeziers Method (Pen, PointF[])

IGraphics.DrawBeziers Method (Pen, PointF[])
See Also
[image]

Draws a series of Bézier splines from an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawBeziers (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Sub DrawBeziers( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the curve.
points
An array of .NET PointF structures that represent the points that determine the curve.

See Also

DrawBeziers Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method

IGraphics.DrawClosedCurve Method
[image]

Draws a closed cardinal spline defined by an array of Point structures.

Overload List

Name | Description
IGraphics.DrawClosedCurve (Pen, Point[]) | Draws a closed cardinal spline defined by an array of Point structures.
IGraphics.DrawClosedCurve (Pen, Point[], Single, FillMode) | Draws a closed cardinal spline defined by an array of Point structures using a specified tension.
IGraphics.DrawClosedCurve (Pen, PointF[]) | Draws a closed cardinal spline defined by an array of PointF structures.
IGraphics.DrawClosedCurve (Pen, PointF[], Single, FillMode) | Draws a closed cardinal spline defined by an array of PointF structures using a specified tension.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method (Pen, Point[])

IGraphics.DrawClosedCurve Method (Pen, Point[])
See Also
[image]

Draws a closed cardinal spline defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawClosedCurve (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Sub DrawClosedCurve( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.

See Also

DrawClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method (Pen, Point[], Single, FillMode)

IGraphics.DrawClosedCurve Method (Pen, Point[], Single, FillMode)
See Also
[image]

Draws a closed cardinal spline defined by an array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawClosedCurve (
Pen pen,
Point[] points,
float tension,
FillMode fillmode
)

Visual Basic [image] Copy Code

Sub DrawClosedCurve( _
pen As Pen, _
points() As Point, _
tension As Single, _
fillmode As FillMode _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled. This parameter is required but ignored.

See Also

DrawClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method (Pen, PointF[])

IGraphics.DrawClosedCurve Method (Pen, PointF[])
See Also
[image]

Draws a closed cardinal spline defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawClosedCurve (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Sub DrawClosedCurve( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of PointF structures that define the spline.

See Also

DrawClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawClosedCurve Method (Pen, PointF[], Single, FillMode)

IGraphics.DrawClosedCurve Method (Pen, PointF[], Single, FillMode)
See Also
[image]

Draws a closed cardinal spline defined by an array of PointF structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawClosedCurve (
Pen pen,
PointF[] points,
float tension,
FillMode fillmode
)

Visual Basic [image] Copy Code

Sub DrawClosedCurve( _
pen As Pen, _
points() As PointF, _
tension As Single, _
fillmode As FillMode _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of PointF structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.
fillmode
Member of the FillMode enumeration that determines how the curve is filled. This parameter is required but is ignored.

See Also

DrawClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method

IGraphics.DrawCurve Method
[image]

Draws a cardinal spline through a specified array of Point structures.

Overload List

Name | Description
IGraphics.DrawCurve (Pen, Point[]) | Draws a cardinal spline through a specified array of Point structures.
IGraphics.DrawCurve (Pen, Point[], Int32, Int32, Single) | Draws a cardinal spline through a specified array of Point structures using a specified tension.
IGraphics.DrawCurve (Pen, Point[], Single) | Draws a cardinal spline through a specified array of Point structures using a specified tension.
IGraphics.DrawCurve (Pen, PointF[]) | Draws a cardinal spline through a specified array of PointF structures.
IGraphics.DrawCurve (Pen, PointF[], Int32, Int32) | Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array.
IGraphics.DrawCurve (Pen, PointF[], Int32, Int32, Single) | Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.
IGraphics.DrawCurve (Pen, PointF[], Single) | Draws a cardinal spline through a specified array of PointF structures using a specified tension.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, Point[])

IGraphics.DrawCurve Method (Pen, Point[])
See Also
[image]

Draws a cardinal spline through a specified array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, Point[], Int32, Int32, Single)

IGraphics.DrawCurve Method (Pen, Point[], Int32, Int32, Single)
See Also
[image]

Draws a cardinal spline through a specified array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
Point[] points,
int offset,
int numberOfSegments,
float tension
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As Point, _
offset As Integer, _
numberOfSegments As Integer, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, Point[], Single)

IGraphics.DrawCurve Method (Pen, Point[], Single)
See Also
[image]

Draws a cardinal spline through a specified array of Point structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
Point[] points,
float tension
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As Point, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET Point structures that define the spline.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, PointF[])

IGraphics.DrawCurve Method (Pen, PointF[])
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32)

IGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32)
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures. The drawing begins offset from the beginning of the array.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
PointF[] points,
int offset,
int numberOfSegments
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As PointF, _
offset As Integer, _
numberOfSegments As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32, Single)

IGraphics.DrawCurve Method (Pen, PointF[], Int32, Int32, Single)
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures using a specified tension. The drawing begins offset from the beginning of the array.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
PointF[] points,
int offset,
int numberOfSegments,
float tension
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As PointF, _
offset As Integer, _
numberOfSegments As Integer, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that define the spline.
offset
The offset from the first element in the array of the points parameter to the starting point in the curve.
numberOfSegments
The number of segments after the starting point to include in the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method (Pen, PointF[], Single)

IGraphics.DrawCurve Method (Pen, PointF[], Single)
See Also
[image]

Draws a cardinal spline through a specified array of PointF structures using a specified tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
PointF[] points,
float tension
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As PointF, _
tension As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and height of the curve.
points
An array of .NET PointF structures that represent the points that define the curve.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

DrawCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method

IGraphics.DrawEllipse Method
[image]

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Overload List

Name | Description
IGraphics.DrawEllipse (Pen, Int32, Int32, Int32, Int32) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
IGraphics.DrawEllipse (Pen, Rectangle) | Draws an ellipse specified by a bounding Rectangle structure.
IGraphics.DrawEllipse (Pen, RectangleF) | Draws an ellipse defined by a bounding RectangleF structure.
IGraphics.DrawEllipse (Pen, Single, Single, Single, Single) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, Int32, Int32, Int32, Int32)

IGraphics.DrawEllipse Method (Pen, Int32, Int32, Int32, Int32)
See Also
[image]

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawEllipse (
Pen pen,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Sub DrawEllipse( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
x

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, Rectangle)

IGraphics.DrawEllipse Method (Pen, Rectangle)
See Also
[image]

Draws an ellipse specified by a bounding Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawEllipse (
Pen pen,
Rectangle rect
)

Visual Basic [image] Copy Code

Sub DrawEllipse( _
pen As Pen, _
rect As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
rect
A .NET Rectangle structure that defines the boundaries of the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, RectangleF)

IGraphics.DrawEllipse Method (Pen, RectangleF)
See Also
[image]

Draws an ellipse defined by a bounding RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawEllipse (
Pen pen,
RectangleF rect
)

Visual Basic [image] Copy Code

Sub DrawEllipse( _
pen As Pen, _
rect As RectangleF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
rect
A .NET RectangleF structure that defines the boundaries of the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, Single, Single, Single, Single)

IGraphics.DrawEllipse Method (Pen, Single, Single, Single, Single)
See Also
[image]

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawEllipse (
Pen pen,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Sub DrawEllipse( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the ellipse.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawIcon Method

IGraphics.DrawIcon Method
[image]

Draws the image represented by the specified .NET Icon object at the specified coordinates.

Overload List

Name | Description
IGraphics.DrawIcon (Icon, Int32, Int32) | Draws the image represented by the specified .NET Icon object at the specified coordinates.
IGraphics.DrawIcon (Icon, Rectangle) | Draws the image represented by the specified .NET Icon object within the area specified by a Rectangle structure.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawIcon Method (Icon, Int32, Int32)

IGraphics.DrawIcon Method (Icon, Int32, Int32)
See Also
[image]

Draws the image represented by the specified .NET Icon object at the specified coordinates.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawIcon (
Icon icon,
int x,
int y
)

Visual Basic [image] Copy Code

Sub DrawIcon( _
icon As Icon, _
x As Integer, _
y As Integer _
)

Parameters

icon
A .NET Icon object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawIcon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawIcon Method (Icon, Rectangle)

IGraphics.DrawIcon Method (Icon, Rectangle)
See Also
[image]

Draws the image represented by the specified .NET Icon object within the area specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawIcon (
Icon icon,
Rectangle targetRect
)

Visual Basic [image] Copy Code

Sub DrawIcon( _
icon As Icon, _
targetRect As Rectangle _
)

Parameters

icon
A .NET Icon object to draw.
targetRect
A .NET Rectangle structure that specifies the location and size of the resulting image on the display surface. The image contained in the icon parameter is scaled to the dimensions of this rectangular area.

See Also

DrawIcon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawIconUnstretched Method

IGraphics.DrawIconUnstretched Method
[image]

Draws the image represented by the specified .NET Icon object without scaling the image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawIconUnstretched (
Icon icon,
Rectangle targetRect
)

Visual Basic [image] Copy Code

Sub DrawIconUnstretched( _
icon As Icon, _
targetRect As Rectangle _
)

Parameters

icon
A .NET Icon object to draw.
targetRect
A .NET Rectangle structure that specifies the location and size of the resulting image. The image is not scaled to fit this rectangle, but retains its original size. If the image is larger than the rectangle, it is clipped to fit inside it.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method

IGraphics.DrawImage Method
[image]

Draws the specified .NET Image object at the specified location and with the original size.

Overload List

Name | Description
IGraphics.DrawImage (Image, Int32, Int32) | Draws the specified image, using its original physical size, at the location specified by a coordinate pair.
IGraphics.DrawImage (Image, Int32, Int32, Int32, Int32) | Draws the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Int32, Int32, Rectangle, GraphicsUnit) | Draws a portion of an image at a specified location.
IGraphics.DrawImage (Image, Point) | Draws the specified .NET Image object, using its original physical size, at the specified location.
IGraphics.DrawImage (Image, Point[]) | Draws the specified .NET Image object at the specified location and with the specified shape and size.
IGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location.
IGraphics.DrawImage (Image, PointF) | Draws the specified .NET Image object, using its original physical size, at the specified location.
IGraphics.DrawImage (Image, PointF[]) | Draws the specified .NET Image object at the specified location and with the specified shape and size.
IGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle) | Draws the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Rectangle, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, RectangleF) | Draws the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, RectangleF, RectangleF, GraphicsUnit) | Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.
IGraphics.DrawImage (Image, Single, Single) | Draws the specified .NET Image object, using its original physical size, at the specified location.
IGraphics.DrawImage (Image, Single, Single, RectangleF, GraphicsUnit) | Draws a portion of an image at a specified location.
IGraphics.DrawImage (Image, Single, Single, Single, Single) | Draws the specified .NET Image object at the specified location and with the specified size.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Int32, Int32)

IGraphics.DrawImage Method (Image, Int32, Int32)
See Also
[image]

Draws the specified image, using its original physical size, at the location specified by a coordinate pair.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
int x,
int y
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
x As Integer, _
y As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Int32, Int32, Int32, Int32)

IGraphics.DrawImage Method (Image, Int32, Int32, Int32, Int32)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
The width of the drawn image.
height
The height of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Int32, Int32, Rectangle, GraphicsUnit)

IGraphics.DrawImage Method (Image, Int32, Int32, Rectangle, GraphicsUnit)
See Also
[image]

Draws a portion of an image at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
int x,
int y,
Rectangle srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
x As Integer, _
y As Integer, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Point)

IGraphics.DrawImage Method (Image, Point)
See Also
[image]

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Point point
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
point As Point _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that represents the location of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Point[])

IGraphics.DrawImage Method (Image, Point[])
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified shape and size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Point[] destPoints
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destPoints() As Point _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit)

IGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)

IGraphics.DrawImage Method (Image, Point[], Rectangle, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Point[] destPoints,
Rectangle srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destPoints() As Point, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET Point structures that define a parallelogram.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, PointF)

IGraphics.DrawImage Method (Image, PointF)
See Also
[image]

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
PointF point
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
point As PointF _
)

Parameters

image
A .NET Image object to draw.
point
A .NET PointF structure that represents the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, PointF[])

IGraphics.DrawImage Method (Image, PointF[])
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified shape and size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
PointF[] destPoints
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destPoints() As PointF _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit)

IGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)

IGraphics.DrawImage Method (Image, PointF[], RectangleF, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
PointF[] destPoints,
RectangleF srcRect,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destPoints() As PointF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destPoints
An array of three .NET PointF structures that define a parallelogram.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle)

IGraphics.DrawImage Method (Image, Rectangle)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Rectangle rect
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
rect As Rectangle _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET Rectangle structure that specifies the location and size of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit)

IGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)

IGraphics.DrawImage Method (Image, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Rectangle destRect,
int srcX,
int srcY,
int srcWidth,
int srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttr
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Integer, _
srcY As Integer, _
srcWidth As Integer, _
srcHeight As Integer, _
srcUnit As GraphicsUnit, _
imageAttr As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttr
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit)

IGraphics.DrawImage Method (Image, Rectangle, Rectangle, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Rectangle destRect,
Rectangle srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcRect As Rectangle, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcRect
A .NET Rectangle structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)

IGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)

IGraphics.DrawImage Method (Image, Rectangle, Single, Single, Single, Single, GraphicsUnit, ImageAttributes)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
Rectangle destRect,
float srcX,
float srcY,
float srcWidth,
float srcHeight,
GraphicsUnit srcUnit,
ImageAttributes imageAttrs
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destRect As Rectangle, _
srcX As Single, _
srcY As Single, _
srcWidth As Single, _
srcHeight As Single, _
srcUnit As GraphicsUnit, _
imageAttrs As ImageAttributes _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET Rectangle structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcX
The x-coordinate of the upper-left corner of the portion of the source image to draw.
srcY
The y-coordinate of the upper-left corner of the portion of the source image to draw.
srcWidth
The width of the portion of the source image to draw.
srcHeight
The height of the portion of the source image to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used to determine the source rectangle.
imageAttrs
A .NET ImageAttributes object that specifies recoloring and gamma information for the image object.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, RectangleF)

IGraphics.DrawImage Method (Image, RectangleF)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
RectangleF rect
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
rect As RectangleF _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET RectangleF structure that specifies the location and size of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit)

IGraphics.DrawImage Method (Image, RectangleF, RectangleF, GraphicsUnit)
See Also
[image]

Draws the specified portion of the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
RectangleF destRect,
RectangleF srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
destRect As RectangleF, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
destRect
A .NET RectangleF structure that specifies the location and size of the drawn image. The image is scaled to fit the rectangle.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Single, Single)

IGraphics.DrawImage Method (Image, Single, Single)
See Also
[image]

Draws the specified .NET Image object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
float x,
float y
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
x As Single, _
y As Single _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Single, Single, RectangleF, GraphicsUnit)

IGraphics.DrawImage Method (Image, Single, Single, RectangleF, GraphicsUnit)
See Also
[image]

Draws a portion of an image at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
float x,
float y,
RectangleF srcRect,
GraphicsUnit srcUnit
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
x As Single, _
y As Single, _
srcRect As RectangleF, _
srcUnit As GraphicsUnit _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
srcRect
A .NET RectangleF structure that specifies the portion of the image object to draw.
srcUnit
Member of the .NET GraphicsUnit enumeration that specifies the units of measure used by the srcRect parameter.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (Image, Single, Single, Single, Single)

IGraphics.DrawImage Method (Image, Single, Single, Single, Single)
See Also
[image]

Draws the specified .NET Image object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
Image image,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As Image, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
The width of the drawn image.
height
The height of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method

IGraphics.DrawImageUnscaled Method
[image]

Draws the specified image using its original physical size at the location specified by a coordinate pair.

Overload List

Name | Description
IGraphics.DrawImageUnscaled (Image, Int32, Int32) | Draws the specified image using its original physical size at the location specified by a coordinate pair.
IGraphics.DrawImageUnscaled (Image, Int32, Int32, Int32, Int32) | Draws a specified image using its original physical size at a specified location.
IGraphics.DrawImageUnscaled (Image, Point) | Draws a specified image using its original physical size at a specified location.
IGraphics.DrawImageUnscaled (Image, Rectangle) | Draws a specified image using its original physical size at a specified location.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method (Image, Int32, Int32)

IGraphics.DrawImageUnscaled Method (Image, Int32, Int32)
See Also
[image]

Draws the specified image using its original physical size at the location specified by a coordinate pair.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImageUnscaled (
Image image,
int x,
int y
)

Visual Basic [image] Copy Code

Sub DrawImageUnscaled( _
image As Image, _
x As Integer, _
y As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImageUnscaled Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method (Image, Int32, Int32, Int32, Int32)

IGraphics.DrawImageUnscaled Method (Image, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImageUnscaled (
Image image,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Sub DrawImageUnscaled( _
image As Image, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

image
A .NET Image object to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
Not used.
height
Not used.

See Also

DrawImageUnscaled Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method (Image, Point)

IGraphics.DrawImageUnscaled Method (Image, Point)
See Also
[image]

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImageUnscaled (
Image image,
Point point
)

Visual Basic [image] Copy Code

Sub DrawImageUnscaled( _
image As Image, _
point As Point _
)

Parameters

image
A .NET Image object to draw.
point
A .NET Point structure that specifies the upper-left corner of the drawn image.

See Also

DrawImageUnscaled Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImageUnscaled Method (Image, Rectangle)

IGraphics.DrawImageUnscaled Method (Image, Rectangle)
See Also
[image]

Draws a specified image using its original physical size at a specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImageUnscaled (
Image image,
Rectangle rect
)

Visual Basic [image] Copy Code

Sub DrawImageUnscaled( _
image As Image, _
rect As Rectangle _
)

Parameters

image
A .NET Image object to draw.
rect
A .NET Rectangle that specifies the upper-left corner of the drawn image. The X and Y properties of the rectangle specify the upper-left corner. The Width and Height properties are ignored.

See Also

DrawImageUnscaled Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method

IGraphics.DrawLine Method
[image]

Draws a line connecting the two points specified by coordinate pairs.

Overload List

Name | Description
IGraphics.DrawLine (Pen, Int32, Int32, Int32, Int32) | Draws a line connecting the two points specified by coordinate pairs.
IGraphics.DrawLine (Pen, Point, Point) | Draws a line connecting two Point structures.
IGraphics.DrawLine (Pen, PointF, PointF) | Draws a line connecting two PointF structures.
IGraphics.DrawLine (Pen, Single, Single, Single, Single) | Draws a line connecting the two points specified by coordinate pairs.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, Int32, Int32, Int32, Int32)

IGraphics.DrawLine Method (Pen, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLine (
Pen pen,
int x1,
int y1,
int x2,
int y2
)

Visual Basic [image] Copy Code

Sub DrawLine( _
pen As Pen, _
x1 As Integer, _
y1 As Integer, _
x2 As Integer, _
y2 As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, Point, Point)

IGraphics.DrawLine Method (Pen, Point, Point)
See Also
[image]

Draws a line connecting two Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLine (
Pen pen,
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Sub DrawLine( _
pen As Pen, _
pt1 As Point, _
pt2 As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
pt1
A .NET Point structure that represents the first point to connect.
pt2
A .NET Point structure that represents the second point to connect.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, PointF, PointF)

IGraphics.DrawLine Method (Pen, PointF, PointF)
See Also
[image]

Draws a line connecting two PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLine (
Pen pen,
PointF pt1,
PointF pt2
)

Visual Basic [image] Copy Code

Sub DrawLine( _
pen As Pen, _
pt1 As PointF, _
pt2 As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
pt1
A .NET PointF structure that represents the first point to connect.
pt2
A .NET PointF structure that represents the second point to connect.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, Single, Single, Single, Single)

IGraphics.DrawLine Method (Pen, Single, Single, Single, Single)
See Also
[image]

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLine (
Pen pen,
float x1,
float y1,
float x2,
float y2
)

Visual Basic [image] Copy Code

Sub DrawLine( _
pen As Pen, _
x1 As Single, _
y1 As Single, _
x2 As Single, _
y2 As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLines Method

IGraphics.DrawLines Method
[image]

Draws a series of line segments that connect an array of Point structures.

Overload List

Name | Description
IGraphics.DrawLines (Pen, Point[]) | Draws a series of line segments that connect an array of Point structures.
IGraphics.DrawLines (Pen, PointF[]) | Draws a series of line segments that connect an array of PointF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLines Method (Pen, Point[])

IGraphics.DrawLines Method (Pen, Point[])
See Also
[image]

Draws a series of line segments that connect an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLines (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Sub DrawLines( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line segments.
points
An array of .NET Point structures that represent the points to connect.

See Also

DrawLines Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLines Method (Pen, PointF[])

IGraphics.DrawLines Method (Pen, PointF[])
See Also
[image]

Draws a series of line segments that connect an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLines (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Sub DrawLines( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the line segments.
points
An array of .NET PointF structures that represent the points to connect.

See Also

DrawLines Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPath Method

IGraphics.DrawPath Method
[image]

Draws a .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPath (
Pen pen,
GraphicsPath path
)

Visual Basic [image] Copy Code

Sub DrawPath( _
pen As Pen, _
path As GraphicsPath _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the path.
path
A .NET GraphicsPath object to draw.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method

IGraphics.DrawPie Method
[image]

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Overload List

Name | Description
IGraphics.DrawPie (Pen, Int32, Int32, Int32, Int32, Int32, Int32) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.
IGraphics.DrawPie (Pen, Rectangle, Single, Single) | Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.
IGraphics.DrawPie (Pen, RectangleF, Single, Single) | Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.
IGraphics.DrawPie (Pen, Single, Single, Single, Single, Single, Single) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)

IGraphics.DrawPie Method (Pen, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPie (
Pen pen,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawPie( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method (Pen, Rectangle, Single, Single)

IGraphics.DrawPie Method (Pen, Rectangle, Single, Single)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a Rectangle structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPie (
Pen pen,
Rectangle rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawPie( _
pen As Pen, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method (Pen, RectangleF, Single, Single)

IGraphics.DrawPie Method (Pen, RectangleF, Single, Single)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a RectangleF structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPie (
Pen pen,
RectangleF rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawPie( _
pen As Pen, _
rect As RectangleF, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
rect
A .NET RectangleF structure that represents the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPie Method (Pen, Single, Single, Single, Single, Single, Single)

IGraphics.DrawPie Method (Pen, Single, Single, Single, Single, Single, Single)
See Also
[image]

Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPie (
Pen pen,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawPie( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

See Also

DrawPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPolygon Method

IGraphics.DrawPolygon Method
[image]

Draws a polygon defined by an array of Point structures.

Overload List

Name | Description
IGraphics.DrawPolygon (Pen, Point[]) | Draws a polygon defined by an array of Point structures.
IGraphics.DrawPolygon (Pen, PointF[]) | Draws a polygon defined by an array of PointF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPolygon Method (Pen, Point[])

IGraphics.DrawPolygon Method (Pen, Point[])
See Also
[image]

Draws a polygon defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPolygon (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Sub DrawPolygon( _
pen As Pen, _
points() As Point _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the polygon.
points
An array of .NET Point structures that represent the vertices of the polygon.

See Also

DrawPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPolygon Method (Pen, PointF[])

IGraphics.DrawPolygon Method (Pen, PointF[])
See Also
[image]

Draws a polygon defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPolygon (
Pen pen,
PointF[] points
)

Visual Basic [image] Copy Code

Sub DrawPolygon( _
pen As Pen, _
points() As PointF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the polygon.
points
An array of .NET PointF structures that represent the vertices of the polygon.

See Also

DrawPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method

IGraphics.DrawRectangle Method
[image]

Draws a rectangle specified by a coordinate pair, a width, and a height.

Overload List

Name | Description
IGraphics.DrawRectangle (Pen, Int32, Int32, Int32, Int32) | Draws a rectangle specified by a coordinate pair, a width, and a height.
IGraphics.DrawRectangle (Pen, Rectangle) | Draws a rectangle specified by a Rectangle structure.
IGraphics.DrawRectangle (Pen, Single, Single, Single, Single) | Draws a rectangle specified by a coordinate pair, a width, and a height.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)

IGraphics.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)
See Also
[image]

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawRectangle (
Pen pen,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Sub DrawRectangle( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method (Pen, Rectangle)

IGraphics.DrawRectangle Method (Pen, Rectangle)
See Also
[image]

Draws a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawRectangle (
Pen pen,
Rectangle rect
)

Visual Basic [image] Copy Code

Sub DrawRectangle( _
pen As Pen, _
rect As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
rect
A .NET Rectangle structure that represents the rectangle to draw.

See Also

DrawRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method (Pen, Single, Single, Single, Single)

IGraphics.DrawRectangle Method (Pen, Single, Single, Single, Single)
See Also
[image]

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawRectangle (
Pen pen,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Sub DrawRectangle( _
pen As Pen, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangles Method

IGraphics.DrawRectangles Method
[image]

Draws a series of rectangles specified by Rectangle structures.

Overload List

Name | Description
IGraphics.DrawRectangles (Pen, Rectangle[]) | Draws a series of rectangles specified by Rectangle structures.
IGraphics.DrawRectangles (Pen, RectangleF[]) | Draws a series of rectangles specified by RectangleF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangles Method (Pen, Rectangle[])

IGraphics.DrawRectangles Method (Pen, Rectangle[])
See Also
[image]

Draws a series of rectangles specified by Rectangle structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawRectangles (
Pen pen,
Rectangle[] rects
)

Visual Basic [image] Copy Code

Sub DrawRectangles( _
pen As Pen, _
rects() As Rectangle _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the outlines of the rectangles.
rects
An array of .NET Rectangle structures that represent the rectangles to draw.

See Also

DrawRectangles Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangles Method (Pen, RectangleF[])

IGraphics.DrawRectangles Method (Pen, RectangleF[])
See Also
[image]

Draws a series of rectangles specified by RectangleF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawRectangles (
Pen pen,
RectangleF[] rects
)

Visual Basic [image] Copy Code

Sub DrawRectangles( _
pen As Pen, _
rects() As RectangleF _
)

Parameters

pen
A .NET Pen object that determines the color, width, and style of the outlines of the rectangles.
rects
An array of .NET RectangleF structures that represent the rectangles to draw.

See Also

DrawRectangles Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method

IGraphics.DrawString Method
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects.

Overload List

Name | Description
IGraphics.DrawString (String, Font, Brush, PointF) | Draws the specified text string at the specified location with the specified Brush and Font objects.
IGraphics.DrawString (String, Font, Brush, PointF, StringFormat) | Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.
IGraphics.DrawString (String, Font, Brush, RectangleF) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects.
IGraphics.DrawString (String, Font, Brush, RectangleF, StringFormat) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.
IGraphics.DrawString (String, Font, Brush, Single, Single) | Draws the specified text string at the specified location with the specified Brush and Font objects.
IGraphics.DrawString (String, Font, Brush, Single, Single, StringFormat) | Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, PointF)

IGraphics.DrawString Method (String, Font, Brush, PointF)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string s,
Font font,
Brush brush,
PointF point
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
point As PointF _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
point
A .NET PointF structure that specifies the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, PointF, StringFormat)

IGraphics.DrawString Method (String, Font, Brush, PointF, StringFormat)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string s,
Font font,
Brush brush,
PointF point,
StringFormat format
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
point As PointF, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
point
A .NET PointF structure that specifies the upper-left corner of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, RectangleF)

IGraphics.DrawString Method (String, Font, Brush, RectangleF)
See Also
[image]

Draws the specified text string in the specified rectangle with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string s,
Font font,
Brush brush,
RectangleF layoutRectangle
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
layoutRectangle As RectangleF _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
layoutRectangle
A .NET RectangleF structure that specifies the location of the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)

IGraphics.DrawString Method (String, Font, Brush, RectangleF, StringFormat)
See Also
[image]

Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string s,
Font font,
Brush brush,
RectangleF layoutRectangle,
StringFormat format
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
layoutRectangle As RectangleF, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
layoutRectangle
A .NET RectangleF structure that specifies the location of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, Single, Single)

IGraphics.DrawString Method (String, Font, Brush, Single, Single)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string s,
Font font,
Brush brush,
float x,
float y
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
x As Single, _
y As Single _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, Single, Single, StringFormat)

IGraphics.DrawString Method (String, Font, Brush, Single, Single, StringFormat)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string s,
Font font,
Brush brush,
float x,
float y,
StringFormat format
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
font As Font, _
brush As Brush, _
x As Single, _
y As Single, _
format As StringFormat _
)

Parameters

s
The string to draw.
font
A .NET Font object that defines the text format of the string.
brush
A .NET Brush object that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.
format
A .NET StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.EndContainer Method

IGraphics.EndContainer Method
[image]

Closes the current graphics container and restores the state of this IGraphics object to the state saved by a call to the BeginContainer method.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void EndContainer (
GraphicsContainer container
)

Visual Basic [image] Copy Code

Sub EndContainer( _
container As GraphicsContainer _
)

Parameters

container
A .NET GraphicsContainer object that represents the container this method restores.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.EndHyperLink Method

IGraphics.EndHyperLink Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void EndHyperLink ()

Visual Basic [image] Copy Code

Sub EndHyperLink ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ExcludeClip Method

IGraphics.ExcludeClip Method
[image]

Updates the clip region of this IGraphics object to exclude the area specified by a .NET Rectangle structure.

Overload List

Name | Description
IGraphics.ExcludeClip (Rectangle) | Updates the clip region of this IGraphics object to exclude the area specified by a Rectangle structure.
IGraphics.ExcludeClip (Region) | Updates the clip region of this IGraphics object to exclude the area specified by a Region object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ExcludeClip Method (Rectangle)

IGraphics.ExcludeClip Method (Rectangle)
See Also
[image]

Updates the clip region of this IGraphics object to exclude the area specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ExcludeClip (
Rectangle rect
)

Visual Basic [image] Copy Code

Sub ExcludeClip( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure that specifies the rectangle to exclude from the clip region.

See Also

ExcludeClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ExcludeClip Method (Region)

IGraphics.ExcludeClip Method (Region)
See Also
[image]

Updates the clip region of this IGraphics object to exclude the area specified by a Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ExcludeClip (
Region region
)

Visual Basic [image] Copy Code

Sub ExcludeClip( _
region As Region _
)

Parameters

region
A .NET Region object that specifies the region to exclude from the clip region.

See Also

ExcludeClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method

IGraphics.FillClosedCurve Method
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures.

Overload List

Name | Description
IGraphics.FillClosedCurve (Brush, Point[]) | Fills the interior a closed cardinal spline curve defined by an array of Point structures.
IGraphics.FillClosedCurve (Brush, Point[], FillMode) | Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode.
IGraphics.FillClosedCurve (Brush, Point[], FillMode, Single) | Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.
IGraphics.FillClosedCurve (Brush, PointF[]) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures.
IGraphics.FillClosedCurve (Brush, PointF[], FillMode) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode.
IGraphics.FillClosedCurve (Brush, PointF[], FillMode, Single) | Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, Point[])

IGraphics.FillClosedCurve Method (Brush, Point[])
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillClosedCurve (
Brush brush,
Point[] points
)

Visual Basic [image] Copy Code

Sub FillClosedCurve( _
brush As Brush, _
points() As Point _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, Point[], FillMode)

IGraphics.FillClosedCurve Method (Brush, Point[], FillMode)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillClosedCurve (
Brush brush,
Point[] points,
FillMode fillmode
)

Visual Basic [image] Copy Code

Sub FillClosedCurve( _
brush As Brush, _
points() As Point, _
fillmode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, Point[], FillMode, Single)

IGraphics.FillClosedCurve Method (Brush, Point[], FillMode, Single)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of Point structures using the specified fill mode and tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillClosedCurve (
Brush brush,
Point[] points,
FillMode fillmode,
float tension
)

Visual Basic [image] Copy Code

Sub FillClosedCurve( _
brush As Brush, _
points() As Point, _
fillmode As FillMode, _
tension As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, PointF[])

IGraphics.FillClosedCurve Method (Brush, PointF[])
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillClosedCurve (
Brush brush,
PointF[] points
)

Visual Basic [image] Copy Code

Sub FillClosedCurve( _
brush As Brush, _
points() As PointF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, PointF[], FillMode)

IGraphics.FillClosedCurve Method (Brush, PointF[], FillMode)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillClosedCurve (
Brush brush,
PointF[] points,
FillMode fillmode
)

Visual Basic [image] Copy Code

Sub FillClosedCurve( _
brush As Brush, _
points() As PointF, _
fillmode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillClosedCurve Method (Brush, PointF[], FillMode, Single)

IGraphics.FillClosedCurve Method (Brush, PointF[], FillMode, Single)
See Also
[image]

Fills the interior a closed cardinal spline curve defined by an array of PointF structures using the specified fill mode and tension.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillClosedCurve (
Brush brush,
PointF[] points,
FillMode fillmode,
float tension
)

Visual Basic [image] Copy Code

Sub FillClosedCurve( _
brush As Brush, _
points() As PointF, _
fillmode As FillMode, _
tension As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that define the spline.
fillmode
Member of the .NET FillMode enumeration that determines how the curve is filled.
tension
A value greater than or equal to 0.0F that specifies the tension of the curve.

See Also

FillClosedCurve Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method

IGraphics.FillEllipse Method
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
IGraphics.FillEllipse (Brush, Int32, Int32, Int32, Int32) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
IGraphics.FillEllipse (Brush, Rectangle) | Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.
IGraphics.FillEllipse (Brush, RectangleF) | Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.
IGraphics.FillEllipse (Brush, Single, Single, Single, Single) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, Int32, Int32, Int32, Int32)

IGraphics.FillEllipse Method (Brush, Int32, Int32, Int32, Int32)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillEllipse (
Brush brush,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Sub FillEllipse( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, Rectangle)

IGraphics.FillEllipse Method (Brush, Rectangle)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillEllipse (
Brush brush,
Rectangle rect
)

Visual Basic [image] Copy Code

Sub FillEllipse( _
brush As Brush, _
rect As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, RectangleF)

IGraphics.FillEllipse Method (Brush, RectangleF)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillEllipse (
Brush brush,
RectangleF rect
)

Visual Basic [image] Copy Code

Sub FillEllipse( _
brush As Brush, _
rect As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET RectangleF structure that represents the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, Single, Single, Single, Single)

IGraphics.FillEllipse Method (Brush, Single, Single, Single, Single)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillEllipse (
Brush brush,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Sub FillEllipse( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
The width of the bounding rectangle that defines the ellipse.
height
The height of the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPath Method

IGraphics.FillPath Method
[image]

Fills the interior of a .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPath (
Brush brush,
GraphicsPath path
)

Visual Basic [image] Copy Code

Sub FillPath( _
brush As Brush, _
path As GraphicsPath _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
path
A .NET GraphicsPath object that represents the path to fill.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPie Method

IGraphics.FillPie Method
[image]

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Overload List

Name | Description
IGraphics.FillPie (Brush, Int32, Int32, Int32, Int32, Int32, Int32) | Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.
IGraphics.FillPie (Brush, Rectangle, Single, Single) | Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.
IGraphics.FillPie (Brush, Single, Single, Single, Single, Single, Single) | Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPie Method (Brush, Int32, Int32, Int32, Int32, Int32, Int32)

IGraphics.FillPie Method (Brush, Int32, Int32, Int32, Int32, Int32, Int32)
See Also
[image]

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPie (
Brush brush,
int x,
int y,
int width,
int height,
int startAngle,
int sweepAngle
)

Visual Basic [image] Copy Code

Sub FillPie( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer, _
startAngle As Integer, _
sweepAngle As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPie Method (Brush, Rectangle, Single, Single)

IGraphics.FillPie Method (Brush, Rectangle, Single, Single)
See Also
[image]

Fills the interior of a pie section defined by an ellipse specified by a RectangleF structure and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPie (
Brush brush,
Rectangle rect,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub FillPie( _
brush As Brush, _
rect As Rectangle, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPie Method (Brush, Single, Single, Single, Single, Single, Single)

IGraphics.FillPie Method (Brush, Single, Single, Single, Single, Single, Single)
See Also
[image]

Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, a width, and a height and two radial lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPie (
Brush brush,
float x,
float y,
float width,
float height,
float startAngle,
float sweepAngle
)

Visual Basic [image] Copy Code

Sub FillPie( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single, _
startAngle As Single, _
sweepAngle As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie section comes.
width
The width of the bounding rectangle that defines the ellipse from which the pie section comes.
height
The height of the bounding rectangle that defines the ellipse from which the pie section comes.
startAngle
The angle in degrees measured clockwise from the x-axis to the first side of the pie section.
sweepAngle
The angle in degrees measured clockwise from the startAngle parameter to the second side of the pie section.

See Also

FillPie Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method

IGraphics.FillPolygon Method
[image]

Fills the interior of a polygon defined by an array of points specified by Point structures.

Overload List

Name | Description
IGraphics.FillPolygon (Brush, Point[]) | Fills the interior of a polygon defined by an array of points specified by Point structures.
IGraphics.FillPolygon (Brush, Point[], FillMode) | Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.
IGraphics.FillPolygon (Brush, PointF[]) | Fills the interior of a polygon defined by an array of points specified by PointF structures.
IGraphics.FillPolygon (Brush, PointF[], FillMode) | Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method (Brush, Point[])

IGraphics.FillPolygon Method (Brush, Point[])
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPolygon (
Brush brush,
Point[] points
)

Visual Basic [image] Copy Code

Sub FillPolygon( _
brush As Brush, _
points() As Point _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that represent the vertices of the polygon to fill.

See Also

FillPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method (Brush, Point[], FillMode)

IGraphics.FillPolygon Method (Brush, Point[], FillMode)
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by Point structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPolygon (
Brush brush,
Point[] points,
FillMode fillMode
)

Visual Basic [image] Copy Code

Sub FillPolygon( _
brush As Brush, _
points() As Point, _
fillMode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET Point structures that represent the vertices of the polygon to fill.
fillMode
Member of the .NET FillMode enumeration that determines the style of the fill.

See Also

FillPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method (Brush, PointF[])

IGraphics.FillPolygon Method (Brush, PointF[])
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by PointF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPolygon (
Brush brush,
PointF[] points
)

Visual Basic [image] Copy Code

Sub FillPolygon( _
brush As Brush, _
points() As PointF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that represent the vertices of the polygon to fill.

See Also

FillPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method (Brush, PointF[], FillMode)

IGraphics.FillPolygon Method (Brush, PointF[], FillMode)
See Also
[image]

Fills the interior of a polygon defined by an array of points specified by PointF structures using the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPolygon (
Brush brush,
PointF[] points,
FillMode fillMode
)

Visual Basic [image] Copy Code

Sub FillPolygon( _
brush As Brush, _
points() As PointF, _
fillMode As FillMode _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
points
An array of .NET PointF structures that represent the vertices of the polygon to fill.
fillMode
Member of the .NET FillMode enumeration that determines the style of the fill.

See Also

FillPolygon Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method

IGraphics.FillRectangle Method
[image]

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Overload List

Name | Description
IGraphics.FillRectangle (Brush, Int32, Int32, Int32, Int32) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
IGraphics.FillRectangle (Brush, Rectangle) | Fills the interior of a rectangle specified by a Rectangle structure.
IGraphics.FillRectangle (Brush, RectangleF) | Fills the interior of a rectangle specified by a RectangleF structure.
IGraphics.FillRectangle (Brush, Single, Single, Single, Single) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, Int32, Int32, Int32, Int32)

IGraphics.FillRectangle Method (Brush, Int32, Int32, Int32, Int32)
See Also
[image]

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangle (
Brush brush,
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Sub FillRectangle( _
brush As Brush, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
The width of the rectangle to fill.
height
The height of the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, Rectangle)

IGraphics.FillRectangle Method (Brush, Rectangle)
See Also
[image]

Fills the interior of a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangle (
Brush brush,
Rectangle rect
)

Visual Basic [image] Copy Code

Sub FillRectangle( _
brush As Brush, _
rect As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET Rectangle structure that represents the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, RectangleF)

IGraphics.FillRectangle Method (Brush, RectangleF)
See Also
[image]

Fills the interior of a rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangle (
Brush brush,
RectangleF rect
)

Visual Basic [image] Copy Code

Sub FillRectangle( _
brush As Brush, _
rect As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rect
A .NET RectangleF structure that represents the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, Single, Single, Single, Single)

IGraphics.FillRectangle Method (Brush, Single, Single, Single, Single)
See Also
[image]

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangle (
Brush brush,
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Sub FillRectangle( _
brush As Brush, _
x As Single, _
y As Single, _
width As Single, _
height As Single _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to fill.
y
The y-coordinate of the upper-left corner of the rectangle to fill.
width
The width of the rectangle to fill.
height
The height of the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangles Method

IGraphics.FillRectangles Method
[image]

Fills the interiors of a series of rectangles specified by Rectangle structures.

Overload List

Name | Description
IGraphics.FillRectangles (Brush, Rectangle[]) | Fills the interiors of a series of rectangles specified by Rectangle structures.
IGraphics.FillRectangles (Brush, RectangleF[]) | Fills the interiors of a series of rectangles specified by RectangleF structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangles Method (Brush, Rectangle[])

IGraphics.FillRectangles Method (Brush, Rectangle[])
See Also
[image]

Fills the interiors of a series of rectangles specified by Rectangle structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangles (
Brush brush,
Rectangle[] rects
)

Visual Basic [image] Copy Code

Sub FillRectangles( _
brush As Brush, _
rects() As Rectangle _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rects
An array of .NET Rectangle structures that represent the rectangles to fill.

See Also

FillRectangles Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangles Method (Brush, RectangleF[])

IGraphics.FillRectangles Method (Brush, RectangleF[])
See Also
[image]

Fills the interiors of a series of rectangles specified by RectangleF structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangles (
Brush brush,
RectangleF[] rects
)

Visual Basic [image] Copy Code

Sub FillRectangles( _
brush As Brush, _
rects() As RectangleF _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
rects
An array of .NET RectangleF structures that represent the rectangles to fill.

See Also

FillRectangles Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRegion Method

IGraphics.FillRegion Method
[image]

Fills the interior of a .NET Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRegion (
Brush brush,
Region region
)

Visual Basic [image] Copy Code

Sub FillRegion( _
brush As Brush, _
region As Region _
)

Parameters

brush
A .NET Brush object that determines the characteristics of the fill.
region
A .NET Region object that represents the area to fill.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Flush Method

IGraphics.Flush Method
[image]

Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.

Overload List

Name | Description
IGraphics.Flush () | Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.
IGraphics.Flush (FlushIntention) | Forces execution of all pending graphics operations with the method waiting or not waiting, as specified, to return before the operations finish.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Flush Method ()

IGraphics.Flush Method ()
See Also
[image]

Forces execution of all pending graphics operations and returns immediately without waiting for the operations to finish.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Flush ()

Visual Basic [image] Copy Code

Sub Flush ()

See Also

Flush Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Flush Method (FlushIntention)

IGraphics.Flush Method (FlushIntention)
See Also
[image]

Forces execution of all pending graphics operations with the method waiting or not waiting, as specified, to return before the operations finish.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Flush (
FlushIntention intention
)

Visual Basic [image] Copy Code

Sub Flush( _
intention As FlushIntention _
)

Parameters

intention
Member of the .NET FlushIntention enumeration that specifies whether the method returns immediately or waits for any existing operations to finish.

See Also

Flush Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.GetFontHeight Method

IGraphics.GetFontHeight Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

float GetFontHeight (
Font font
)

Visual Basic [image] Copy Code

Function GetFontHeight( _
font As Font _
) As Single

Parameters

font

Return Value

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.GetHdc Method

IGraphics.GetHdc Method
[image]

Gets the handle to the device context associated with this IGraphics.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

IntPtr GetHdc ()

Visual Basic [image] Copy Code

Function GetHdc () As IntPtr

Return Value

Handle to the device context associated with this IGraphics.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.GetNearestColor Method

IGraphics.GetNearestColor Method
[image]

Gets the nearest color to the specified Color structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Color GetNearestColor (
Color color
)

Visual Basic [image] Copy Code

Function GetNearestColor( _
color As Color _
) As Color

Parameters

color
A .NET Color structure for which to find a match.

Return Value

A .NET Color structure that represents the nearest color to the one specified with the color parameter.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IntersectClip Method

IGraphics.IntersectClip Method
[image]

Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.

Overload List

Name | Description
IGraphics.IntersectClip (Rectangle) | Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.
IGraphics.IntersectClip (RectangleF) | Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified RectangleF structure.
IGraphics.IntersectClip (Region) | Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Region object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IntersectClip Method (Rectangle)

IGraphics.IntersectClip Method (Rectangle)
See Also
[image]

Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void IntersectClip (
Rectangle rect
)

Visual Basic [image] Copy Code

Sub IntersectClip( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure to intersect with the current clip region.

See Also

IntersectClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IntersectClip Method (RectangleF)

IGraphics.IntersectClip Method (RectangleF)
See Also
[image]

Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void IntersectClip (
RectangleF rect
)

Visual Basic [image] Copy Code

Sub IntersectClip( _
rect As RectangleF _
)

Parameters

rect
A .NET RectangleF structure to intersect with the current clip region.

See Also

IntersectClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IntersectClip Method (Region)

IGraphics.IntersectClip Method (Region)
See Also
[image]

Updates the clip region of this IGraphics object to the intersection of the current clip region and the specified Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void IntersectClip (
Region region
)

Visual Basic [image] Copy Code

Sub IntersectClip( _
region As Region _
)

Parameters

region
A .NET Region object to intersect with the current region.

See Also

IntersectClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method

IGraphics.IsVisible Method
[image]

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.

Overload List

Name | Description
IGraphics.IsVisible (Int32, Int32) | Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Int32, Int32, Int32, Int32) | Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Point) | Indicates whether the specified Point structure is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (PointF) | Indicates whether the specified PointF structure is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Rectangle) | Indicates whether the rectangle specified by a Rectangle structure is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (RectangleF) | Indicates whether the rectangle specified by a RectangleF structure is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Single, Single) | Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.
IGraphics.IsVisible (Single, Single, Single, Single) | Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Int32, Int32)

IGraphics.IsVisible Method (Int32, Int32)
See Also
[image]

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
int x,
int y
)

Visual Basic [image] Copy Code

Function IsVisible( _
x As Integer, _
y As Integer _
) As Boolean

Parameters

x
The x-coordinate of the point to test for visibility.
y
The y-coordinate of the point to test for visibility.

Return Value

This method returns true if the point defined by the x and y parameters is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Int32, Int32, Int32, Int32)

IGraphics.IsVisible Method (Int32, Int32, Int32, Int32)
See Also
[image]

Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Function IsVisible( _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
) As Boolean

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test for visibility.
y
The y-coordinate of the upper-left corner of the rectangle to test for visibility.
width
The width of the rectangle to test for visibility.
height
The height of the rectangle to test for visibility.

Return Value

This method returns true if the rectangle defined by the x, y, width, and height parameters is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Point)

IGraphics.IsVisible Method (Point)
See Also
[image]

Indicates whether the specified Point structure is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
Point point
)

Visual Basic [image] Copy Code

Function IsVisible( _
point As Point _
) As Boolean

Parameters

point
A .NET Point structure to test for visibility.

Return Value

This method returns true if the point specified by the point parameter is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (PointF)

IGraphics.IsVisible Method (PointF)
See Also
[image]

Indicates whether the specified PointF structure is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
PointF point
)

Visual Basic [image] Copy Code

Function IsVisible( _
point As PointF _
) As Boolean

Parameters

point
A .NET PointF structure to test for visibility.

Return Value

This method returns true if the point specified by the point parameter is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Rectangle)

IGraphics.IsVisible Method (Rectangle)
See Also
[image]

Indicates whether the rectangle specified by a Rectangle structure is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
Rectangle rect
)

Visual Basic [image] Copy Code

Function IsVisible( _
rect As Rectangle _
) As Boolean

Parameters

rect
A .NET Rectangle structure to test for visibility.

Return Value

This method returns true if the rectangle specified by the rect parameter is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (RectangleF)

IGraphics.IsVisible Method (RectangleF)
See Also
[image]

Indicates whether the rectangle specified by a RectangleF structure is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
RectangleF rect
)

Visual Basic [image] Copy Code

Function IsVisible( _
rect As RectangleF _
) As Boolean

Parameters

rect
A .NET RectangleF structure to test for visibility.

Return Value

This method returns true if the rectangle specified by the rect parameter is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Single, Single)

IGraphics.IsVisible Method (Single, Single)
See Also
[image]

Indicates whether the point specified by a pair of coordinates is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
float x,
float y
)

Visual Basic [image] Copy Code

Function IsVisible( _
x As Single, _
y As Single _
) As Boolean

Parameters

x
The x-coordinate of the point to test for visibility.
y
The y-coordinate of the point to test for visibility.

Return Value

This method returns true if the point defined by the x and y parameters is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisible Method (Single, Single, Single, Single)

IGraphics.IsVisible Method (Single, Single, Single, Single)
See Also
[image]

Indicates whether the rectangle specified by a pair of coordinates, a width, and a height is contained within the visible clip region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
float x,
float y,
float width,
float height
)

Visual Basic [image] Copy Code

Function IsVisible( _
x As Single, _
y As Single, _
width As Single, _
height As Single _
) As Boolean

Parameters

x
The x-coordinate of the upper-left corner of the rectangle to test for visibility.
y
The y-coordinate of the upper-left corner of the rectangle to test for visibility.
width
The width of the rectangle to test for visibility.
height
The height of the rectangle to test for visibility.

Return Value

This method returns true if the rectangle defined by the x, y, width, and height parameters is contained within the visible clip region of this IGraphics object; otherwise, false.

See Also

IsVisible Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureCharacterRanges Method

IGraphics.MeasureCharacterRanges Method
[image]

Gets an array of Region objects, each of which bounds a range of character positions within the specified string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

RectangleF[] MeasureCharacterRanges (
string text,
Font font,
RectangleF layoutRect,
StringFormat stringFormat
)

Visual Basic [image] Copy Code

Function MeasureCharacterRanges( _
text As String, _
font As Font, _
layoutRect As RectangleF, _
stringFormat As StringFormat _
) As RectangleF()

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
layoutRect
A .NET RectangleF structure that specifies the layout rectangle for the string.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns an array of .NET Region objects, each of which bounds a range of character positions within the specified string.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method

IGraphics.MeasureString Method
[image]

Measures the specified string when drawn with the specified Font object.

Overload List

Name | Description
IGraphics.MeasureString (String, Font) | Measures the specified string when drawn with the specified Font object.
IGraphics.MeasureString (String, Font, Int32) | Measures the specified string when drawn with the specified Font object.
IGraphics.MeasureString (String, Font, Int32, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
IGraphics.MeasureString (String, Font, PointF, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
IGraphics.MeasureString (String, Font, SizeF) | Measures the specified string when drawn with the specified Font object within the specified layout area.
IGraphics.MeasureString (String, Font, SizeF, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.
IGraphics.MeasureString (String, Font, SizeF, StringFormat, Int32@, Int32@) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font)

IGraphics.MeasureString Method (String, Font)
See Also
[image]

Measures the specified string when drawn with the specified Font object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified by the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, Int32)

IGraphics.MeasureString Method (String, Font, Int32)
See Also
[image]

Measures the specified string when drawn with the specified Font object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font,
int width
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font, _
width As Integer _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the format of the string.
width
The maximum width of the string in pixels.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, Int32, StringFormat)

IGraphics.MeasureString Method (String, Font, Int32, StringFormat)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font,
int width,
StringFormat format
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font, _
width As Integer, _
format As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
width
The maximum width of the string.
format
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, PointF, StringFormat)

IGraphics.MeasureString Method (String, Font, PointF, StringFormat)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font,
PointF origin,
StringFormat stringFormat
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font, _
origin As PointF, _
stringFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
origin
A .NET PointF structure that represents the upper-left corner of the string.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size of the string, in pixels, of the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, SizeF)

IGraphics.MeasureString Method (String, Font, SizeF)
See Also
[image]

Measures the specified string when drawn with the specified Font object within the specified layout area.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font,
SizeF layoutArea
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font, _
layoutArea As SizeF _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, SizeF, StringFormat)

IGraphics.MeasureString Method (String, Font, SizeF, StringFormat)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font,
SizeF layoutArea,
StringFormat stringFormat
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font, _
layoutArea As SizeF, _
stringFormat As StringFormat _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

This method returns a .NET SizeF structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, SizeF, StringFormat, Int32@, Int32@)

IGraphics.MeasureString Method (String, Font, SizeF, StringFormat, Int32@, Int32@)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SizeF MeasureString (
string text,
Font font,
SizeF layoutArea,
StringFormat stringFormat,
ref int charactersFitted,
ref int linesFilled
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font, _
layoutArea As SizeF, _
stringFormat As StringFormat, _
ByRef charactersFitted As Integer, _
ByRef linesFilled As Integer _
) As SizeF

Parameters

text
The string to measure.
font
A .NET Font object that defines the text format of the string.
layoutArea
A .NET SizeF structure that specifies the maximum layout area for the text.
stringFormat
A .NET StringFormat object that represents formatting information, such as line spacing, for the string.
charactersFitted
Number of characters in the string.
linesFilled
Number of text lines in the string.

Return Value

This method returns a .NET SizeF structure that represents the size of the string, in pixels, of the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MultiplyTransform Method

IGraphics.MultiplyTransform Method
[image]

Multiplies the world transformation of this IGraphics object and specified the .NET Matrix object.

Overload List

Name | Description
IGraphics.MultiplyTransform (Matrix) | Multiplies the world transformation of this IGraphics object and specified the Matrix object.
IGraphics.MultiplyTransform (Matrix, MatrixOrder) | Multiplies the world transformation of this IGraphics object and specified the Matrix object in the specified order.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MultiplyTransform Method (Matrix)

IGraphics.MultiplyTransform Method (Matrix)
See Also
[image]

Multiplies the world transformation of this IGraphics object and specified the Matrix object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void MultiplyTransform (
Matrix matrix
)

Visual Basic [image] Copy Code

Sub MultiplyTransform( _
matrix As Matrix _
)

Parameters

matrix
A 4x4 .NET Matrix object that multiplies the world transformation.

See Also

MultiplyTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MultiplyTransform Method (Matrix, MatrixOrder)

IGraphics.MultiplyTransform Method (Matrix, MatrixOrder)
See Also
[image]

Multiplies the world transformation of this IGraphics object and specified the Matrix object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void MultiplyTransform (
Matrix matrix,
MatrixOrder order
)

Visual Basic [image] Copy Code

Sub MultiplyTransform( _
matrix As Matrix, _
order As MatrixOrder _
)

Parameters

matrix
A 4x4 .NET Matrix object that multiplies the world transformation.
order
Member of the .NET MatrixOrder enumeration that determines the order of the multiplication.

See Also

MultiplyTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ReleaseHdc Method

IGraphics.ReleaseHdc Method
[image]

Releases a device context handle obtained by a previous call to the GetHdc method of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ReleaseHdc (
IntPtr hdc
)

Visual Basic [image] Copy Code

Sub ReleaseHdc( _
hdc As IntPtr _
)

Parameters

hdc
Handle to a device context obtained by a previous call to the GetHdc method of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ReleaseHdcInternal Method

IGraphics.ReleaseHdcInternal Method
[image]

Internal method. Do not use.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ReleaseHdcInternal (
IntPtr hdc
)

Visual Basic [image] Copy Code

Sub ReleaseHdcInternal( _
hdc As IntPtr _
)

Parameters

hdc
Handle to a device context.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ResetClip Method

IGraphics.ResetClip Method
[image]

Resets the clip region of this IGraphics object to an infinite region.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ResetClip ()

Visual Basic [image] Copy Code

Sub ResetClip ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ResetTransform Method

IGraphics.ResetTransform Method
[image]

Resets the world transformation matrix of this IGraphics object to the identity matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ResetTransform ()

Visual Basic [image] Copy Code

Sub ResetTransform ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Restore Method

IGraphics.Restore Method
[image]

Restores the state of this IGraphics object to the state represented by a GraphicsState object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Restore (
GraphicsState gstate
)

Visual Basic [image] Copy Code

Sub Restore( _
gstate As GraphicsState _
)

Parameters

gstate
A .NET GraphicsState object that represents the state to which to restore this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.RotateTransform Method

IGraphics.RotateTransform Method
[image]

Applies the specified rotation to the transformation matrix of this IGraphics object.

Overload List

Name | Description
IGraphics.RotateTransform (Single) | Applies the specified rotation to the transformation matrix of this IGraphics object.
IGraphics.RotateTransform (Single, MatrixOrder) | Applies the specified rotation to the transformation matrix of this IGraphics object in the specified order.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.RotateTransform Method (Single)

IGraphics.RotateTransform Method (Single)
See Also
[image]

Applies the specified rotation to the transformation matrix of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void RotateTransform (
float angle
)

Visual Basic [image] Copy Code

Sub RotateTransform( _
angle As Single _
)

Parameters

angle
The angle of rotation in degrees.

See Also

RotateTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.RotateTransform Method (Single, MatrixOrder)

IGraphics.RotateTransform Method (Single, MatrixOrder)
See Also
[image]

Applies the specified rotation to the transformation matrix of this IGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void RotateTransform (
float angle,
MatrixOrder order
)

Visual Basic [image] Copy Code

Sub RotateTransform( _
angle As Single, _
order As MatrixOrder _
)

Parameters

angle
The angle of rotation in degrees.
order
Member of the .NET MatrixOrder enumeration that specifies whether the rotation is appended or prepended to the matrix transformation.

See Also

RotateTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Save Method

IGraphics.Save Method
[image]

Saves the current state of this IGraphics object and identifies the saved state with a GraphicsState object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

GraphicsState Save ()

Visual Basic [image] Copy Code

Function Save () As GraphicsState

Return Value

This method returns a .NET GraphicsState object that represents the saved state of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ScaleTransform Method

IGraphics.ScaleTransform Method
[image]

Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.

Overload List

Name | Description
IGraphics.ScaleTransform (Single, Single) | Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.
IGraphics.ScaleTransform (Single, Single, MatrixOrder) | Applies the specified scaling operation to the transformation matrix of this IGraphics object in the specified order.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ScaleTransform Method (Single, Single)

IGraphics.ScaleTransform Method (Single, Single)
See Also
[image]

Applies the specified scaling operation to the transformation matrix of this IGraphics object by prepending it to the object's transformation matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ScaleTransform (
float sx,
float sy
)

Visual Basic [image] Copy Code

Sub ScaleTransform( _
sx As Single, _
sy As Single _
)

Parameters

sx
The scale factor in the x direction.
sy
The scale factor in the y direction.

See Also

ScaleTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ScaleTransform Method (Single, Single, MatrixOrder)

IGraphics.ScaleTransform Method (Single, Single, MatrixOrder)
See Also
[image]

Applies the specified scaling operation to the transformation matrix of this IGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ScaleTransform (
float sx,
float sy,
MatrixOrder order
)

Visual Basic [image] Copy Code

Sub ScaleTransform( _
sx As Single, _
sy As Single, _
order As MatrixOrder _
)

Parameters

sx
The scale factor in the x direction.
sy
The scale factor in the y direction.
order
Member of the .NET MatrixOrder enumeration that specifies whether the scaling operation is prepended or appended to the transformation matrix.

See Also

ScaleTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method

IGraphics.SetClip Method
[image]

Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.

Overload List

Name | Description
IGraphics.SetClip (GraphicsPath) | Sets the clipping region of this IGraphics object to the specified .NET GraphicsPath object.
IGraphics.SetClip (GraphicsPath, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified .NET GraphicsPath object.
IGraphics.SetClip (IGraphics) | Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.
IGraphics.SetClip (IGraphics, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified combining operation of the current clip region and the Clip property of the specified IGraphics object.
IGraphics.SetClip (Rectangle) | Sets the clipping region of this IGraphics object to the rectangle specified by a Rectangle structure.
IGraphics.SetClip (Rectangle, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a Rectangle structure.
IGraphics.SetClip (RectangleF) | Sets the clipping region of this IGraphics object to the rectangle specified by a RectangleF structure.
IGraphics.SetClip (RectangleF, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a RectangleF structure.
IGraphics.SetClip (Region, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified Region object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (GraphicsPath)

IGraphics.SetClip Method (GraphicsPath)
See Also
[image]

Sets the clipping region of this IGraphics object to the specified .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
GraphicsPath path
)

Visual Basic [image] Copy Code

Sub SetClip( _
path As GraphicsPath _
)

Parameters

path
A .NET GraphicsPath object that represents the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (GraphicsPath, CombineMode)

IGraphics.SetClip Method (GraphicsPath, CombineMode)
See Also
[image]

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified .NET GraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
GraphicsPath path,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Sub SetClip( _
path As GraphicsPath, _
combineMode As CombineMode _
)

Parameters

path
A .NET GraphicsPath object to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (IGraphics)

IGraphics.SetClip Method (IGraphics)
See Also
[image]

Sets the clipping region of this IGraphics object to the Clip property of the specified IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract void SetClip (
IGraphics g
)

Visual Basic [image] Copy Code

Public MustOverride Sub SetClip ( _
g As IGraphics _
)

Parameters

g
An IGraphics object from which to take the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (IGraphics, CombineMode)

IGraphics.SetClip Method (IGraphics, CombineMode)
See Also
[image]

Sets the clipping region of this IGraphics object to the result of the specified combining operation of the current clip region and the Clip property of the specified IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract void SetClip (
IGraphics g,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Public MustOverride Sub SetClip ( _
g As IGraphics, _
combineMode As CombineMode _
)

Parameters

g
An IGraphics object that specifies the clip region to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (Rectangle)

IGraphics.SetClip Method (Rectangle)
See Also
[image]

Sets the clipping region of this IGraphics object to the rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
Rectangle rect
)

Visual Basic [image] Copy Code

Sub SetClip( _
rect As Rectangle _
)

Parameters

rect
A .NET Rectangle structure that represents the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (Rectangle, CombineMode)

IGraphics.SetClip Method (Rectangle, CombineMode)
See Also
[image]

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
Rectangle rect,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Sub SetClip( _
rect As Rectangle, _
combineMode As CombineMode _
)

Parameters

rect
A .NET Rectangle structure to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (RectangleF)

IGraphics.SetClip Method (RectangleF)
See Also
[image]

Sets the clipping region of this IGraphics object to the rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
RectangleF rect
)

Visual Basic [image] Copy Code

Sub SetClip( _
rect As RectangleF _
)

Parameters

rect
A .NET RectangleF structure that represents the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (RectangleF, CombineMode)

IGraphics.SetClip Method (RectangleF, CombineMode)
See Also
[image]

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the rectangle specified by a RectangleF structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
RectangleF rect,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Sub SetClip( _
rect As RectangleF, _
combineMode As CombineMode _
)

Parameters

rect
A .NET RectangleF structure to combine.
combineMode
Member of the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (Region, CombineMode)

IGraphics.SetClip Method (Region, CombineMode)
See Also
[image]

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified Region object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
Region region,
CombineMode combineMode
)

Visual Basic [image] Copy Code

Sub SetClip( _
region As Region, _
combineMode As CombineMode _
)

Parameters

region
A .NET Region object to combine.
combineMode
Member from the .NET CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TransformPoints Method

IGraphics.TransformPoints Method
[image]

Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.

Overload List

Name | Description
IGraphics.TransformPoints (CoordinateSpace, CoordinateSpace, Point[]) | Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.
IGraphics.TransformPoints (CoordinateSpace, CoordinateSpace, PointF[]) | Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, Point[])

IGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, Point[])
See Also
[image]

Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TransformPoints (
CoordinateSpace destSpace,
CoordinateSpace srcSpace,
Point[] pts
)

Visual Basic [image] Copy Code

Sub TransformPoints( _
destSpace As CoordinateSpace, _
srcSpace As CoordinateSpace, _
pts() As Point _
)

Parameters

destSpace
Member of the .NET CoordinateSpace enumeration that specifies the destination coordinate space.
srcSpace
Member of the .NET CoordinateSpace enumeration that specifies the source coordinate space.
pts
An array of .NET Point structures that represents the points to transformation.

See Also

TransformPoints Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, PointF[])

IGraphics.TransformPoints Method (CoordinateSpace, CoordinateSpace, PointF[])
See Also
[image]

Transforms an array of points from one coordinate space to another using the current world and page transformations of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TransformPoints (
CoordinateSpace destSpace,
CoordinateSpace srcSpace,
PointF[] pts
)

Visual Basic [image] Copy Code

Sub TransformPoints( _
destSpace As CoordinateSpace, _
srcSpace As CoordinateSpace, _
pts() As PointF _
)

Parameters

destSpace
Member of the .NET CoordinateSpace enumeration that specifies the destination coordinate space.
srcSpace
Member of the .NET CoordinateSpace enumeration that specifies the source coordinate space.
pts
An array of .NET PointF structures that represent the points to transform.

See Also

TransformPoints Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateClip Method

IGraphics.TranslateClip Method
[image]

Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.

Overload List

Name | Description
IGraphics.TranslateClip (Int32, Int32) | Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.
IGraphics.TranslateClip (Single, Single) | Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateClip Method (Int32, Int32)

IGraphics.TranslateClip Method (Int32, Int32)
See Also
[image]

Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TranslateClip (
int dx,
int dy
)

Visual Basic [image] Copy Code

Sub TranslateClip( _
dx As Integer, _
dy As Integer _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateClip Method (Single, Single)

IGraphics.TranslateClip Method (Single, Single)
See Also
[image]

Translates the clipping region of this IGraphics object by specified amounts in the horizontal and vertical directions.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TranslateClip (
float dx,
float dy
)

Visual Basic [image] Copy Code

Sub TranslateClip( _
dx As Single, _
dy As Single _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateTransform Method

IGraphics.TranslateTransform Method
[image]

Prepends the specified translation to the transformation matrix of this IGraphics object.

Overload List

Name | Description
IGraphics.TranslateTransform (Single, Single) | Prepends the specified translation to the transformation matrix of this IGraphics object.
IGraphics.TranslateTransform (Single, Single, MatrixOrder) | Applies the specified translation to the transformation matrix of this IGraphics object in the specified order.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateTransform Method (Single, Single)

IGraphics.TranslateTransform Method (Single, Single)
See Also
[image]

Prepends the specified translation to the transformation matrix of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TranslateTransform (
float dx,
float dy
)

Visual Basic [image] Copy Code

Sub TranslateTransform( _
dx As Single, _
dy As Single _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.

See Also

TranslateTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateTransform Method (Single, Single, MatrixOrder)

IGraphics.TranslateTransform Method (Single, Single, MatrixOrder)
See Also
[image]

Applies the specified translation to the transformation matrix of this IGraphics object in the specified order.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TranslateTransform (
float dx,
float dy,
MatrixOrder order
)

Visual Basic [image] Copy Code

Sub TranslateTransform( _
dx As Single, _
dy As Single, _
order As MatrixOrder _
)

Parameters

dx
The x component of the translation.
dy
The y component of the translation.
order
Member of the .NET MatrixOrder enumeration that specifies whether the translation is prepended or appended to the transformation matrix.

See Also

TranslateTransform Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Properties

IGraphics Properties
[image]

Public Properties

Name | Description
Clip | Gets or sets a .NET Region object that limits the drawing region of this IGraphics object.
ClipBounds | Gets a .NET RectangleF structure that bounds the clipping region of this IGraphics object.
CompositingMode | Gets or sets a value that specifies how composited images are drawn to this IGraphics object.
CompositingQuality | Gets or sets the rendering quality of composited images drawn to this IGraphics object.
DpiX | Gets the horizontal resolution of this IGraphics object.
DpiY | Gets the vertical resolution of this IGraphics object.
InterpolationMode | Gets or sets the interpolation mode associated with this IGraphics object.
IsClipEmpty | Gets a value indicating whether the clipping region of this IGraphics object is empty.
IsVisibleClipEmpty | Gets a value indicating whether the visible clipping region of this IGraphics object is empty.
PageScale | Gets or sets the scaling between world units and page units for this IGraphics object.
PageUnit | Gets or sets the unit of measure used for page coordinates in this IGraphics object.
PixelOffsetMode | Gets or set a value specifying how pixels are offset during rendering of this IGraphics object.
RenderingOrigin | Gets or sets the rendering origin of this IGraphics object for dithering and for hatch brushes.
SmoothingMode | Gets or sets the rendering quality for this IGraphics object.
TextContrast | Gets or sets the gamma correction value for rendering text.
TextRenderingHint | Gets or sets the rendering mode for text associated with this IGraphics object.
Transform | Gets or sets the world transformation for this IGraphics object.
VisibleClipBounds | Gets or sets the bounding rectangle of the visible clipping region of this IGraphics object.

See Also

IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Clip Property

IGraphics.Clip Property
[image]

Gets or sets a .NET Region object that limits the drawing region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Region Clip { get; set; }

Visual Basic [image] Copy Code

Property Clip As Region

Property Value

This property specifies a .NET Region object that limits the portion of this IGraphics object that is currently available for drawing.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ClipBounds Property

IGraphics.ClipBounds Property
[image]

Gets a .NET RectangleF structure that bounds the clipping region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

RectangleF ClipBounds { get; }

Visual Basic [image] Copy Code

ReadOnly Property ClipBounds As RectangleF

Property Value

This property indicates a .NET RectangleF structure that represents a bounding rectangle for the clipping region of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.CompositingMode Property

IGraphics.CompositingMode Property
[image]

Gets or sets a value that specifies how composited images are drawn to this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

CompositingMode CompositingMode { get; set; }

Visual Basic [image] Copy Code

Property CompositingMode As CompositingMode

Property Value

This property specifies a member of the .NET CompositingMode enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.CompositingQuality Property

IGraphics.CompositingQuality Property
[image]

Gets or sets the rendering quality of composited images drawn to this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

CompositingQuality CompositingQuality { get; set; }

Visual Basic [image] Copy Code

Property CompositingQuality As CompositingQuality

Property Value

This property specifies a member of the .NET CompositingQuality enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DpiX Property

IGraphics.DpiX Property
[image]

Gets the horizontal resolution of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

float DpiX { get; }

Visual Basic [image] Copy Code

ReadOnly Property DpiX As Single

Property Value

This property indicates a value, in dots per inch, for the horizontal resolution supported by this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DpiY Property

IGraphics.DpiY Property
[image]

Gets the vertical resolution of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

float DpiY { get; }

Visual Basic [image] Copy Code

ReadOnly Property DpiY As Single

Property Value

This property indicates a value, in dots per inch, for the vertical resolution supported by this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.InterpolationMode Property

IGraphics.InterpolationMode Property
[image]

Gets or sets the interpolation mode associated with this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

InterpolationMode InterpolationMode { get; set; }

Visual Basic [image] Copy Code

Property InterpolationMode As InterpolationMode

Property Value

This property specifies a member of the InterpolationMode enumeration associated with this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsClipEmpty Property

IGraphics.IsClipEmpty Property
[image]

Gets a value indicating whether the clipping region of this IGraphics object is empty.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsClipEmpty { get; }

Visual Basic [image] Copy Code

ReadOnly Property IsClipEmpty As Boolean

Property Value

This property is true if the clipping region of this IGraphics object is empty; otherwise, false.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.IsVisibleClipEmpty Property

IGraphics.IsVisibleClipEmpty Property
[image]

Gets a value indicating whether the visible clipping region of this IGraphics object is empty.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisibleClipEmpty { get; }

Visual Basic [image] Copy Code

ReadOnly Property IsVisibleClipEmpty As Boolean

Property Value

This property is true if the visible portion of the clipping region of this IGraphics object is empty; otherwise, false.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.PageScale Property

IGraphics.PageScale Property
[image]

Gets or sets the scaling between world units and page units for this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

float PageScale { get; set; }

Visual Basic [image] Copy Code

Property PageScale As Single

Property Value

This property specifies a value for the scaling between world units and page units for this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.PageUnit Property

IGraphics.PageUnit Property
[image]

Gets or sets the unit of measure used for page coordinates in this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

GraphicsUnit PageUnit { get; set; }

Visual Basic [image] Copy Code

Property PageUnit As GraphicsUnit

Property Value

This property specifies a member of the .NET GraphicsUnit enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.PixelOffsetMode Property

IGraphics.PixelOffsetMode Property
[image]

Gets or set a value specifying how pixels are offset during rendering of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

PixelOffsetMode PixelOffsetMode { get; set; }

Visual Basic [image] Copy Code

Property PixelOffsetMode As PixelOffsetMode

Property Value

This property specifies a member of the .NET PixelOffsetMode enumeration

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.RenderingOrigin Property

IGraphics.RenderingOrigin Property
[image]

Gets or sets the rendering origin of this IGraphics object for dithering and for hatch brushes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Point RenderingOrigin { get; set; }

Visual Basic [image] Copy Code

Property RenderingOrigin As Point

Property Value

This property specifies a .NET Point structure that represents the dither origin for 8-bits-per-pixel and 16-bits-per-pixel dithering and is also used to set the origin for hatch brushes.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SmoothingMode Property

IGraphics.SmoothingMode Property
[image]

Gets or sets the rendering quality for this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

SmoothingMode SmoothingMode { get; set; }

Visual Basic [image] Copy Code

Property SmoothingMode As SmoothingMode

Property Value

This property specifies a member of the .NET SmoothingMode enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TextContrast Property

IGraphics.TextContrast Property
[image]

Gets or sets the gamma correction value for rendering text.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

int TextContrast { get; set; }

Visual Basic [image] Copy Code

Property TextContrast As Integer

Property Value

This property specifies a value of the gamma correction used for rendering antialiased and ClearType text.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TextRenderingHint Property

IGraphics.TextRenderingHint Property
[image]

Gets or sets the rendering mode for text associated with this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

TextRenderingHint TextRenderingHint { get; set; }

Visual Basic [image] Copy Code

Property TextRenderingHint As TextRenderingHint

Property Value

This property specifies a member of the .NET TextRenderingHint enumeration.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Transform Property

IGraphics.Transform Property
[image]

Gets or sets the world transformation for this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Matrix Transform { get; set; }

Visual Basic [image] Copy Code

Property Transform As Matrix

Property Value

This property specifies a Matrix object that represents the world transformation for this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.VisibleClipBounds Property

IGraphics.VisibleClipBounds Property
[image]

Gets or sets the bounding rectangle of the visible clipping region of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

RectangleF VisibleClipBounds { get; }

Visual Basic [image] Copy Code

ReadOnly Property VisibleClipBounds As RectangleF

Property Value

A .NET RectangleF structure that represents a bounding rectangle for the visible clipping region of this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.ImageAlign Enumeration

ImageAlign Enumeration
[image]

Specifies the position and alignment of a picture relative to its destination rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum ImageAlign

Visual Basic [image] Copy Code

Public Enum ImageAlign

Members

Member name | Description
BottomCenter | The image is centered horizontally and aligned to the bottom side.
BottomLeft | The image is aligned to the bottom left corner.
BottomRight | The image is aligned to the bottom right corner.
Center | The image is centered.
Fit | The image is resized to fit the size the destination rectangle.
MiddleLeft | The image is centered vertically and aligned to the left-hand side.
MiddleRight | The image is centered vertically and aligned to the right-hand side.
Stretch | The image is stretched to fill the destination rectangle.
Tile | The image is tiled across the destination rectangle.
TopCenter | The image is centered horizontally and aligned to the top side.
TopLeft | The image is aligned to the top left corner.
TopRight | The image is aligned o the top right corner.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Class

LinearGradientBrush Class
Remarks See Also
[image]

LinearGradientBrush objects represent brushes that fill the interiors of geometric shapes with a linear gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class LinearGradientBrush : Brush, ISerializable

Visual Basic [image] Copy Code

Public Class LinearGradientBrush
Inherits Brush
Implements ISerializable

Remarks

The LinearGradientBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.Drawing2D.LinearGradientBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.LinearGradientBrush

See Also

LinearGradientBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Members

LinearGradientBrush Members
Constructors Properties Methods
[image]

LinearGradientBrush objects represent brushes that fill the interiors of geometric shapes with a linear gradient.

The following tables list the members exposed by the LinearGradientBrush type.

Public Constructors

Name | Description
LinearGradientBrush | Overloaded. Initializes a new instance of the LinearGradientBrush class.

Public Properties

Name | Description
Angle | Gets or sets the angle of the gradient's orientation line.
Blend | Gets or sets a .NET Blend object that specifies positions and factors that define a custom falloff for the gradient.
InterpolationColors | Gets or sets a .NET ColorBlend object that defines a multicolor linear gradient.
LinearColors | Gets or sets the starting and ending colors of the gradient.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Creates an instance of the System.Drawing.Drawing2D.LinearGradientBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Gradient".

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor

LinearGradientBrush Constructor
[image]

Initializes a new instance of the LinearGradientBrush class.

Overload List

Name | Description
LinearGradientBrush (Color, Color) | Initializes a new instance of the LinearGradientBrush class with the specified start and end colors.
LinearGradientBrush (Color, Color, Single) | Initializes a new instance of the LinearGradientBrush class with the specified start and end colors and an orientation angle measured in degrees.
LinearGradientBrush (String) | Initializes a new instance of the LinearGradientBrush class given its string representation.

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor (Color, Color)

LinearGradientBrush Constructor (Color, Color)
See Also
[image]

Initializes a new instance of the LinearGradientBrush class with the specified start and end colors.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public LinearGradientBrush (
Color color1,
Color color2
)

Visual Basic [image] Copy Code

Public New ( _
color1 As Color, _
color2 As Color _
)

Parameters

color1

The first color of the gradient.

color2

The second color of the gradient.

See Also

LinearGradientBrush Constructor Overload List
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor (Color, Color, Single)

LinearGradientBrush Constructor (Color, Color, Single)
See Also
[image]

Initializes a new instance of the LinearGradientBrush class with the specified start and end colors and an orientation angle measured in degrees.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public LinearGradientBrush (
Color color1,
Color color2,
float angle
)

Visual Basic [image] Copy Code

Public New ( _
color1 As Color, _
color2 As Color, _
angle As Single _
)

Parameters

color1

The first color of the gradient.

color2

The second color of the gradient.

angle

The gradient direction angle.

See Also

LinearGradientBrush Constructor Overload List
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor (String)

LinearGradientBrush Constructor (String)
See Also
[image]

Initializes a new instance of the LinearGradientBrush class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public LinearGradientBrush (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized bursh.

See Also

LinearGradientBrush Constructor Overload List
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Methods

LinearGradientBrush Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Creates an instance of the System.Drawing.Drawing2D.LinearGradientBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Gradient".

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Clone Method

LinearGradientBrush.Clone Method
[image]

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the LinearGradientBrush class.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.CreateGdiBrush Method

LinearGradientBrush.CreateGdiBrush Method
[image]

Creates an instance of the System.Drawing.Drawing2D.LinearGradientBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush CreateGdiBrush (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Overrides Function CreateGdiBrush( _
rc As RectangleF _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.GetObjectData Method

LinearGradientBrush.GetObjectData Method
[image]

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub GetObjectData( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info

The object that holds the serialized object data.

context

The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.ToString Method

LinearGradientBrush.ToString Method
[image]

Returns "Gradient".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Properties

LinearGradientBrush Properties
[image]

Public Properties

Name | Description
Angle | Gets or sets the angle of the gradient's orientation line.
Blend | Gets or sets a .NET Blend object that specifies positions and factors that define a custom falloff for the gradient.
InterpolationColors | Gets or sets a .NET ColorBlend object that defines a multicolor linear gradient.
LinearColors | Gets or sets the starting and ending colors of the gradient.

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Angle Property

LinearGradientBrush.Angle Property
[image]

Gets or sets the angle of the gradient's orientation line.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float Angle { get; set; }

Visual Basic [image] Copy Code

Public Property Angle As Single

Property Value

A float value that represents he angle, measured in degrees clockwise from the x-axis, of the gradient's orientation line.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Blend Property

LinearGradientBrush.Blend Property
[image]

Gets or sets a .NET Blend object that specifies positions and factors that define a custom falloff for the gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Blend Blend { get; set; }

Visual Basic [image] Copy Code

Public Property Blend As Blend

Property Value

An instance of the .NET Blend class that represents a custom falloff for the gradient.

Remarks

A Blend object contains corresponding arrays of blend factors and positions. The blend factors specify the percentages of the starting color and ending color to use at the corresponding position. The positions are specified as a percentage of distance along the gradient line.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.InterpolationColors Property

LinearGradientBrush.InterpolationColors Property
[image]

Gets or sets a .NET ColorBlend object that defines a multicolor linear gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public ColorBlend InterpolationColors { get; set; }

Visual Basic [image] Copy Code

Public Property InterpolationColors As ColorBlend

Property Value

An instance of the .NET ColorBlend class that defines a multicolor linear gradient.

Remarks

A ColorBlend object contains corresponding arrays of colors and positions. The positions are values from 0 through 1 that specify the percentage of the distance along the gradient line where the corresponding color is located.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.LinearColors Property

LinearGradientBrush.LinearColors Property
[image]

Gets or sets the starting and ending colors of the gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color[] LinearColors { get; set; }

Visual Basic [image] Copy Code

Public Property LinearColors As Color()

Property Value

An array of two .NET Color objects that represents the starting and ending colors of the gradient.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Class

PathGradientBrush Class
Remarks See Also
[image]

PathGradientBrush represents a brush that fills the interiors of geometric shapes with a gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class PathGradientBrush : Brush, ISerializable

Visual Basic [image] Copy Code

Public Class PathGradientBrush
Inherits Brush
Implements ISerializable

Remarks

The PathGradientBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.Drawing2D.PathGradientBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.PathGradientBrush

See Also

PathGradientBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Members

PathGradientBrush Members
Constructors Properties Methods
[image]

PathGradientBrush represents a brush that fills the interiors of geometric shapes with a gradient.

The following tables list the members exposed by the PathGradientBrush type.

Public Constructors

Name | Description
PathGradientBrush | Overloaded. Initializes a new instance of the PathGradientBrush class.

Public Properties

Name | Description
CenterColor | Gets or sets the color at the center of the gradient path.
CenterPoint | Gets or sets the center of the gradient path.
InterpolationColors | Gets or sets a ColorBlend object that defines a multiple color gradient.
SurroundingColor | Gets or sets the color drawn at the borders of the gradient path.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.Drawing2D.PathGradientBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "PathGradient".

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Constructor

PathGradientBrush Constructor
[image]

Initializes a new instance of the PathGradientBrush class.

Overload List

Name | Description
PathGradientBrush (Color, Color) | Initializes a new instance of the PathGradientBrush class with the specified center and surrounding colors.
PathGradientBrush (String) | Initializes a new instance of the PathGradientBrush class given its string representation.

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Constructor (Color, Color)

PathGradientBrush Constructor (Color, Color)
See Also
[image]

Initializes a new instance of the PathGradientBrush class with the specified center and surrounding colors.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public PathGradientBrush (
Color centerColor,
Color surroundingColor
)

Visual Basic [image] Copy Code

Public New ( _
centerColor As Color, _
surroundingColor As Color _
)

Parameters

centerColor

Specifies an initial center color.

surroundingColor

Specifies an initial surrounding color.

See Also

PathGradientBrush Constructor Overload List
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Constructor (String)

PathGradientBrush Constructor (String)
See Also
[image]

Initializes a new instance of the PathGradientBrush class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public PathGradientBrush (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation

A string that represents the serialized bursh.

See Also

PathGradientBrush Constructor Overload List
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Methods

PathGradientBrush Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.Drawing2D.PathGradientBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "PathGradient".

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.Clone Method

PathGradientBrush.Clone Method
[image]

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the PathGradientBrush class.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.CreateGdiBrush Method

PathGradientBrush.CreateGdiBrush Method
[image]

Returns an instance of the System.Drawing.Drawing2D.PathGradientBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush CreateGdiBrush (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Overrides Function CreateGdiBrush( _
rc As RectangleF _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.GetObjectData Method

PathGradientBrush.GetObjectData Method
[image]

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub GetObjectData( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info

The object that holds the serialized object data.

context

The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.ToString Method

PathGradientBrush.ToString Method
[image]

Returns "PathGradient".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Properties

PathGradientBrush Properties
[image]

Public Properties

Name | Description
CenterColor | Gets or sets the color at the center of the gradient path.
CenterPoint | Gets or sets the center of the gradient path.
InterpolationColors | Gets or sets a ColorBlend object that defines a multiple color gradient.
SurroundingColor | Gets or sets the color drawn at the borders of the gradient path.

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.CenterColor Property

PathGradientBrush.CenterColor Property
[image]

Gets or sets the color at the center of the gradient path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color CenterColor { get; set; }

Visual Basic [image] Copy Code

Public Property CenterColor As Color

Property Value

Instance of the .NET Color structure that represents the color at the center of the path gradient.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.CenterPoint Property

PathGradientBrush.CenterPoint Property
[image]

Gets or sets the center of the gradient path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public PointF CenterPoint { get; set; }

Visual Basic [image] Copy Code

Public Property CenterPoint As PointF

Property Value

A .NET PointF structure that represents the center point of the path gradient.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.InterpolationColors Property

PathGradientBrush.InterpolationColors Property
[image]

Gets or sets a ColorBlend object that defines a multiple color gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public ColorBlend InterpolationColors { get; set; }

Visual Basic [image] Copy Code

Public Property InterpolationColors As ColorBlend

Property Value

Instance of the .NET ColorBlend object that defines a multicolor linear gradient.

Remarks

A ColorBlend object contains corresponding arrays of colors and positions. The positions are values from 0 through 1 that specify the percentage of the distance along the gradient path where the corresponding color is located.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.SurroundingColor Property

PathGradientBrush.SurroundingColor Property
[image]

Gets or sets the color drawn at the borders of the gradient path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color SurroundingColor { get; set; }

Visual Basic [image] Copy Code

Public Property SurroundingColor As Color

Property Value

Instance of .NET Color structure that represents the color at the border of the path gradient.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Class

Pen Class
Remarks See Also
[image]

Pen instances are used to draw the outline of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class Pen : GraphicObject, ISerializable

Visual Basic [image] Copy Code

Public Class Pen
Inherits GraphicObject
Implements ISerializable

Remarks

The Pen class acts as a proxy for the .NET standard GDI+ System.Drawing.Pen class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Pen

See Also

Pen Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Members

Pen Members
Constructors Properties Methods
[image]

Pen instances are used to draw the outline of geometric shapes.

The following tables list the members exposed by the Pen type.

Public Constructors

Name | Description
Pen | Overloaded. Initialize a new instance of the Pen class.

Public Properties

Name | Description
Brush | Gets or sets the Brush object that determines attributes of this pen.
Color | Gets or sets the color of this pen.
CompoundArray | Gets or sets an array values that specify a compound pen. A compound pen draws a compound line made up of parallel lines and spaces.
DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
DashPattern | Gets or sets an array of custom dashes and spaces.
DashStyle | Gets or sets the style used for dashed lines drawn with this pen.
LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this pen.
MiterLimit | Gets or sets the limit of the thickness of the join on a mitered corner.
Width | Gets or sets the width of the pen.

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.
CreateGdiPen | Overloaded. Returns an instance of the System.Drawing.Pen class corresponding to the current pen.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the pen.
Serialize | Serializes the specified pen to a string.
ToString | Returns the string representation of this Pen object.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor

Pen Constructor
[image]

Initialize a new instance of the Pen class.

Overload List

Name | Description
Pen (Brush) | Initializes a new instance of the Pen class with a specified Brush object.
Pen (Brush, Single) | Initializes a new instance of the Pen class with the specified Brush object and the specified width.
Pen (Color) | Initializes a new instance of the Pen class with the specified color.
Pen (Color, Single) | Initializes a new instance of the Pen class with the specified color and width.
Pen (String) | Initializes a new instance of the Pen class given its string representation.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Brush)

Pen Constructor (Brush)
See Also
[image]

Initializes a new instance of the Pen class with a specified Brush object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
Brush brush
)

Visual Basic [image] Copy Code

Public Sub Pen ( _
brush As Brush _
)

Parameters

brush
A Brush instance that determines the fill properties of the new pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Brush, Single)

Pen Constructor (Brush, Single)
See Also
[image]

Initializes a new instance of the Pen class with the specified Brush object and the specified width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
Brush brush,
float width
)

Visual Basic [image] Copy Code

Public Sub Pen ( _
brush As Brush, _
width As Single _
)

Parameters

brush
A Brush instance that determines the fill properties of the new pen.
width
The width of the new pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Color)

Pen Constructor (Color)
See Also
[image]

Initializes a new instance of the Pen class with the specified color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
Color color
)

Visual Basic [image] Copy Code

Public New ( _
color As Color _
)

Parameters

color
A Color structure that specifies the color of the new pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Color, Single)

Pen Constructor (Color, Single)
See Also
[image]

Initializes a new instance of the Pen class with the specified color and width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
Color color,
float width
)

Visual Basic [image] Copy Code

Public New ( _
color As Color, _
width As Single _
)

Parameters

color
A Color structure that specifies the color of the new pen.
width
The width of the new pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (String)

Pen Constructor (String)
See Also
[image]

Initializes a new instance of the Pen class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Methods

Pen Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.
CreateGdiPen | Overloaded. Returns an instance of the System.Drawing.Pen class corresponding to the current pen.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the pen.
Serialize | Serializes the specified pen to a string.
ToString | Returns the string representation of this Pen object.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Clone Method

Pen.Clone Method
[image]

Creates an exact copy of this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the Pen class.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CreateGdiPen Method

Pen.CreateGdiPen Method
[image]

Returns an instance of the System.Drawing.Pen class corresponding to the current pen.

Overload List

Name | Description
Pen.CreateGdiPen () | Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.
Pen.CreateGdiPen (RectangleF) | Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CreateGdiPen Method ()

Pen.CreateGdiPen Method ()
See Also
[image]

Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen CreateGdiPen ()

Visual Basic [image] Copy Code

Public Function CreateGdiPen () As Pen

Return Value

A System.Drawing.Pen instance corresponding to this pen.

See Also

CreateGdiPen Method Overload List
Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CreateGdiPen Method (RectangleF)

Pen.CreateGdiPen Method (RectangleF)
See Also
[image]

Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen CreateGdiPen (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Function CreateGdiPen( _
rc As RectangleF _
) As Pen

Parameters

rc

The rectangle in which painting will be performed.

Return Value

A System.Drawing.Pen instance corresponding to this pen.

See Also

CreateGdiPen Method Overload List
Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.GetObjectData Method

Pen.GetObjectData Method
[image]

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub GetObjectData( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info

The object that holds the serialized object data.

context

The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Serialize Method

Pen.Serialize Method
[image]

Serializes the specified pen to a string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string Serialize (
Pen pen
)

Visual Basic [image] Copy Code

Public Shared Function Serialize ( _
pen As Pen _
) As String

Parameters

pen

The Pen object to serialize.

Return Value

A string that represents the specified pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.ToString Method

Pen.ToString Method
[image]

Returns the string representation of this Pen object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing this pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Properties

Pen Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the Brush object that determines attributes of this pen.
Color | Gets or sets the color of this pen.
CompoundArray | Gets or sets an array values that specify a compound pen. A compound pen draws a compound line made up of parallel lines and spaces.
DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
DashPattern | Gets or sets an array of custom dashes and spaces.
DashStyle | Gets or sets the style used for dashed lines drawn with this pen.
LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this pen.
MiterLimit | Gets or sets the limit of the thickness of the join on a mitered corner.
Width | Gets or sets the width of the pen.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Brush Property

Pen.Brush Property
[image]

Gets or sets the Brush object that determines attributes of this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of the Brush class that determines attributes of this pen.

Remarks

Setting this property causes the pen to draw filled lines and curves. It overrides the Color property of the pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Color Property

Pen.Color Property
[image]

Gets or sets the color of this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

An instance of the .NET Color structure that represents the color of this pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CompoundArray Property

Pen.CompoundArray Property
[image]

Gets or sets an array values that specify a compound pen. A compound pen draws a compound line made up of parallel lines and spaces.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float[] CompoundArray { get; set; }

Visual Basic [image] Copy Code

Public Property CompoundArray As Single()

Property Value

An array of real numbers that specifies the compound array. The elements in the array must be in increasing order, not less than 0, and not greater than 1.

Remarks

A compound line is made up of alternating parallel lines and spaces of varying widths. The values in the array specify the starting points of each component of the compound line relative to the pen's width. The first value in the array specifies where the first component (a line) begins as a fraction of the distance across the width of the pen. The second value in the array specifies the beginning of the next component (a space) as a fraction of the distance across the width of the pen. The final value in the array specifies where the last component ends.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.DashOffset Property

Pen.DashOffset Property
[image]

Gets or sets the distance from the start of a line to the beginning of a dash pattern.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float DashOffset { get; set; }

Visual Basic [image] Copy Code

Public Property DashOffset As Single

Property Value

A float value representing the distance from the start of a line to the beginning of a dash pattern.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.DashPattern Property

Pen.DashPattern Property
[image]

Gets or sets an array of custom dashes and spaces.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float[] DashPattern { get; set; }

Visual Basic [image] Copy Code

Public Property DashPattern As Single()

Property Value

An array of real numbers that specify the lengths of alternating dashes and spaces in dashed lines.

Remarks

The elements in the array set the length of each dash and space in the dash pattern. The first element sets the length of a dash, the second element sets the length of a space, the third element sets the length of a dash, and so on.The length of each dash and space in the dash pattern is the product of the element value in the array and the width of the pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.DashStyle Property

Pen.DashStyle Property
[image]

Gets or sets the style used for dashed lines drawn with this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public DashStyle DashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration that represents the style used for dashed lines.

Remarks

A value of DashStyle.Custom for this property specifies that a custom pattern of dashes and spaces, defined by the DashPattern property, make up lines drawn with this pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.LineJoin Property

Pen.LineJoin Property
[image]

Gets or sets the join style for the ends of two consecutive lines drawn with this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public LineJoin LineJoin { get; set; }

Visual Basic [image] Copy Code

Public Property LineJoin As LineJoin

Property Value

A member of the .NET LineJoin enumeration that represents the join style for the ends of two consecutive lines.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.MiterLimit Property

Pen.MiterLimit Property
[image]

Gets or sets the limit of the thickness of the join on a mitered corner.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float MiterLimit { get; set; }

Visual Basic [image] Copy Code

Public Property MiterLimit As Single

Property Value

A floag value representing the limit of the thickness of the join on a mitered corner. The default is 10.0f.

Remarks

The miter length is the distance from the intersection of the line walls on the inside of the join to the intersection of the line walls outside of the join. The miter length can be large when the angle between two lines is small. The miter limit is the maximum allowed ratio of miter length to stroke width. If the miter length of the join of the intersection exceeds the limit of the join, then the join will be beveled to keep it within the limit of the join of the intersection.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Width Property

Pen.Width Property
[image]

Gets or sets the width of the pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Single

Property Value

A float value indicating the width of the pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Class

PenCollection Class
[image]

A collection of MindFusion.Drawing.Pen objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class PenCollection : CollectionBase, ICloneable

Visual Basic [image] Copy Code

Public Class PenCollection
Inherits CollectionBase
Implements ICloneable

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Drawing.PenCollection

See Also

PenCollection Members
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Members

PenCollection Members
Constructors Properties Methods
[image]

A collection of MindFusion.Drawing.Pen objects.

The following tables list the members exposed by the PenCollection type.

Public Constructors

Name | Description
PenCollection | Overloaded. Initializes a new instance of the PenCollection class.

Public Properties

Name | Description
Item | Gets or sets the Pen, located at the specified position.

Public Methods

Name | Description
Add | Adds the specified Pen to the collection.
Clone | Returns a shallow copy of this PenCollection object.
Contains | Checks whether the specified Pen is contained in the collection.
IndexOf | Returns the index of the first occurrence of the specified Pen.
Insert | Inserts the specified Pen at the specified position within the collection.
Remove | Removes the first occurrence of the specified Pen from the collection.
RemoveAt | Removes the Pen at the specified index.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Constructor

PenCollection Constructor
[image]

Initializes a new instance of the PenCollection class.

Overload List

Name | Description
PenCollection () | Initializes a new empty instance of the PenCollection class.
PenCollection (String) | Initializes a new instance of the PenCollection class using the specified string representation.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Constructor ()

PenCollection Constructor ()
See Also
[image]

Initializes a new empty instance of the PenCollection class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public PenCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Constructor (String)

PenCollection Constructor (String)
See Also
[image]

Initializes a new instance of the PenCollection class using the specified string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public PenCollection (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
The string that represents serialized contents of a PenCollection.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Methods

PenCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified Pen to the collection.
Clone | Returns a shallow copy of this PenCollection object.
Contains | Checks whether the specified Pen is contained in the collection.
IndexOf | Returns the index of the first occurrence of the specified Pen.
Insert | Inserts the specified Pen at the specified position within the collection.
Remove | Removes the first occurrence of the specified Pen from the collection.
RemoveAt | Removes the Pen at the specified index.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Add Method

PenCollection.Add Method
[image]

Adds the specified Pen to the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int Add (
Pen value
)

Visual Basic [image] Copy Code

Public Function Add ( _
value As Pen _
) As Integer

Parameters

value
The Pen object to add to the end of the collection.

Return Value

The zero-based index within the collection of the newly added pen.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Clone Method

PenCollection.Clone Method
[image]

Returns a shallow copy of this PenCollection object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Object Clone ()

Visual Basic [image] Copy Code

Public Overridable Function Clone () As Object

Return Value

An instance of the PenCollection class.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Contains Method

PenCollection.Contains Method
[image]

Checks whether the specified Pen is contained in the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public bool Contains (
Pen value
)

Visual Basic [image] Copy Code

Public Function Contains ( _
value As Pen _
) As Boolean

Parameters

value
The Pen object to search for in the collection.

Return Value

true if the specified pen is contained in the collection; otherwise, false.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.IndexOf Method

PenCollection.IndexOf Method
[image]

Returns the index of the first occurrence of the specified Pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int IndexOf (
Pen value
)

Visual Basic [image] Copy Code

Public Function IndexOf ( _
value As Pen _
) As Integer

Parameters

value
The Pen object to locate in the collection.

Return Value

The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Insert Method

PenCollection.Insert Method
[image]

Inserts the specified Pen at the specified position within the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void Insert (
int index,
Pen value
)

Visual Basic [image] Copy Code

Public Sub Insert ( _
index As Integer, _
value As Pen _
)

Parameters

index
The zero-based index at which to insert the pen.
value
The Pen object to add to the collection.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Remove Method

PenCollection.Remove Method
[image]

Removes the first occurrence of the specified Pen from the collection.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void Remove (
Pen value
)

Visual Basic [image] Copy Code

Public Sub Remove ( _
value As Pen _
)

Parameters

value
The Pen object to remove from the collection.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.RemoveAt Method

PenCollection.RemoveAt Method
[image]

Removes the Pen at the specified index.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public new void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Shadows Sub RemoveAt( _
index As Integer _
)

Parameters

index
The index at which the Pen object should be removed.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection Properties

PenCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the Pen, located at the specified position.

See Also

PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenCollection.Item Property

PenCollection.Item Property
[image]

Gets or sets the Pen, located at the specified position.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item ( _
index As Integer _
) As Pen

Parameters

index
The zero-based index of the element to get or set.

Property Value

The Pen element at the specified index.

Remarks

This property provides the ability to access a specific Pen element in the PenCollection.

See Also

PenCollection Members
PenCollection Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Class

SolidBrush Class
Remarks See Also
[image]

SolidBrush objects represent brushes of a single color that are used to fill the interiors of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class SolidBrush : Brush, ISerializable

Visual Basic [image] Copy Code

Public Class SolidBrush
Inherits Brush
Implements ISerializable

Remarks

The SolidBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.SolidBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.SolidBrush

See Also

SolidBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Members

SolidBrush Members
Constructors Properties Methods
[image]

SolidBrush objects represent brushes of a single color that are used to fill the interiors of geometric shapes.

The following tables list the members exposed by the SolidBrush type.

Public Constructors

Name | Description
SolidBrush | Overloaded. Initializes a new instance of the SolidBrush class.

Public Properties

Name | Description
Color | Gets or sets the color of this brush.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.SolidBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Solid".

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Constructor

SolidBrush Constructor
[image]

Initializes a new instance of the SolidBrush class.

Overload List

Name | Description
SolidBrush (Color) | Initializes a new instance of the SolidBrush class with the specified color.
SolidBrush (String) | Initializes a new instance of the SolidBrush class given its string representation.

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Constructor (Color)

SolidBrush Constructor (Color)
See Also
[image]

Initializes a new instance of the SolidBrush class with the specified color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public SolidBrush (
Color color
)

Visual Basic [image] Copy Code

Public New ( _
color As Color _
)

Parameters

color
A Color object that specifies the color of the new brush.

See Also

SolidBrush Constructor Overload List
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Constructor (String)

SolidBrush Constructor (String)
See Also
[image]

Initializes a new instance of the SolidBrush class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public SolidBrush (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized bursh.

See Also

SolidBrush Constructor Overload List
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Methods

SolidBrush Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.SolidBrush class that can be used to paint in a GDI+ Graphics object.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Solid".

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.Clone Method

SolidBrush.Clone Method
[image]

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the SolidBrush class.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.CreateGdiBrush Method

SolidBrush.CreateGdiBrush Method
[image]

Returns an instance of the System.Drawing.SolidBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush CreateGdiBrush (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Overrides Function CreateGdiBrush( _
rc As RectangleF _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.GetObjectData Method

SolidBrush.GetObjectData Method
[image]

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub GetObjectData( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info

The object that holds the serialized object data.

context

The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.ToString Method

SolidBrush.ToString Method
[image]

Returns "Solid".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Properties

SolidBrush Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the color of this brush.

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.Color Property

SolidBrush.Color Property
[image]

Gets or sets the color of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

Instance of the .NET Color structure that represents the color of this brush.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Class

TextureBrush Class
Remarks See Also
[image]

TextureBrush objects represent brushes that use images to fill the interiors of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class TextureBrush : Brush, ISerializable

Visual Basic [image] Copy Code

Public Class TextureBrush
Inherits Brush
Implements ISerializable

Remarks

The TextureBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.TextureBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.TextureBrush

See Also

TextureBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Members

TextureBrush Members
Constructors Properties Methods
[image]

TextureBrush objects represent brushes that use images to fill the interiors of geometric shapes.

The following tables list the members exposed by the TextureBrush type.

Public Constructors

Name | Description
TextureBrush | Overloaded. Initializes a new instance of the TextureBrush class.

Public Properties

Name | Description
Image | Gets or sets the Image instance associated with this brush.
ScaleFactor | Gets or sets the scale factor applied to all texture brushes.
WrapMode | Gets or sets a value that indicates the wrap mode for this brush.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.
Equals | Determines whether two TextureBrush instances are equal.
GetHashCode | Returns the hash code for this brush instance.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Texture".

See Also

TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Constructor

TextureBrush Constructor
[image]

Initializes a new instance of the TextureBrush class.

Overload List

Name | Description
TextureBrush (Image) | Initializes a new instance of the TextureBrush class with the specified image.
TextureBrush (Image, WrapMode) | Initializes a new instance of the TextureBrush class with the specified image and wrap mode.
TextureBrush (String) | Initializes a new instance of TextureBrush class given its string representation.

See Also

TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Constructor (Image)

TextureBrush Constructor (Image)
See Also
[image]

Initializes a new instance of the TextureBrush class with the specified image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public TextureBrush (
Image image
)

Visual Basic [image] Copy Code

Public New ( _
image As Image _
)

Parameters

image
The Image object with which this brush fills interiors.

See Also

TextureBrush Constructor Overload List
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Constructor (Image, WrapMode)

TextureBrush Constructor (Image, WrapMode)
See Also
[image]

Initializes a new instance of the TextureBrush class with the specified image and wrap mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public TextureBrush (
Image image,
WrapMode wrapMode
)

Visual Basic [image] Copy Code

Public New ( _
image As Image, _
wrapMode As WrapMode _
)

Parameters

image

Sets the texture image.

wrapMode

Sets the texture wrap mode.

See Also

TextureBrush Constructor Overload List
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Constructor (String)

TextureBrush Constructor (String)
See Also
[image]

Initializes a new instance of TextureBrush class given its string representation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public TextureBrush (
string representation
)

Visual Basic [image] Copy Code

Public New ( _
representation As String _
)

Parameters

representation
A string that represents the serialized bursh.

See Also

TextureBrush Constructor Overload List
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Methods

TextureBrush Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.
Equals | Determines whether two TextureBrush instances are equal.
GetHashCode | Returns the hash code for this brush instance.
GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.
ToString | Returns "Texture".

See Also

TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.Clone Method

TextureBrush.Clone Method
[image]

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the TextureBrush class.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.CreateGdiBrush Method

TextureBrush.CreateGdiBrush Method
[image]

Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.

Overload List

Name | Description
TextureBrush.CreateGdiBrush (RectangleF) | Creates an instance of the System.Drawing.TextureBrush class that can be used to paint in a GDI+ Graphics object.
TextureBrush.CreateGdiBrush (RectangleF, Single, Single) | Creates an instance of the System.Drawing.TextureBrush class that can be used to paint in a GDI+ Graphics object.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.CreateGdiBrush Method (RectangleF)

TextureBrush.CreateGdiBrush Method (RectangleF)
See Also
[image]

Creates an instance of the System.Drawing.TextureBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush CreateGdiBrush (
RectangleF rc
)

Visual Basic [image] Copy Code

Public Overrides Function CreateGdiBrush( _
rc As RectangleF _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.CreateGdiBrush Method (RectangleF, Single, Single)

TextureBrush.CreateGdiBrush Method (RectangleF, Single, Single)
See Also
[image]

Creates an instance of the System.Drawing.TextureBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush CreateGdiBrush (
RectangleF rc,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Overrides Function CreateGdiBrush( _
rc As RectangleF, _
dx As Single, _
dy As Single _
) As Brush

Parameters

rc

The rectangle in which painting will be performed.

dx

Specifies a horizontal offset to apply to this brush.

dy

Specifies a vertical offset to apply to this brush.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.Equals Method

TextureBrush.Equals Method
[image]

Determines whether two TextureBrush instances are equal.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj
The object to compare to this one.

Return Value

true is the brushes are equal; otherwise, false.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.GetHashCode Method

TextureBrush.GetHashCode Method
[image]

Returns the hash code for this brush instance.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for this object.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.GetObjectData Method

TextureBrush.GetObjectData Method
[image]

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual void GetObjectData (
SerializationInfo info,
StreamingContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub GetObjectData( _
info As SerializationInfo, _
context As StreamingContext _
)

Parameters

info

The object that holds the serialized object data.

context

The contextual information about the source or destination.

Remarks

This method is not intended to be used directly from your code.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.ToString Method

TextureBrush.ToString Method
[image]

Returns "Texture".

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush Properties

TextureBrush Properties
[image]

Public Properties

Name | Description
Image | Gets or sets the Image instance associated with this brush.
ScaleFactor | Gets or sets the scale factor applied to all texture brushes.
WrapMode | Gets or sets a value that indicates the wrap mode for this brush.

See Also

TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.Image Property

TextureBrush.Image Property
[image]

Gets or sets the Image instance associated with this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Image Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As Image

Property Value

Instance of the .NET Image class that represents the image with which this brush fills shapes.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.ScaleFactor Property

TextureBrush.ScaleFactor Property
[image]

Gets or sets the scale factor applied to all texture brushes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static float ScaleFactor { get; set; }

Visual Basic [image] Copy Code

Public Shared Property ScaleFactor As Single

Property Value

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextureBrush.WrapMode Property

TextureBrush.WrapMode Property
[image]

Gets or sets a value that indicates the wrap mode for this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public WrapMode WrapMode { get; set; }

Visual Basic [image] Copy Code

Public Property WrapMode As WrapMode

Property Value

A member of the .NET WrapMode enumeration that specifies how fills drawn with this brush are tiled.

See Also

TextureBrush Members
TextureBrush Class
MindFusion.Drawing Namespace


MindFusion.Reporting Namespace

MindFusion.Reporting Namespace
Classes Structures Enumerations

Classes

Class | Description
AxesChart | A base class for report items representing charts that use the rectangular coordinate system.
BarChart | Represents a report item that can display bar charts.
Barcode | Represents a report item that that can render barcodes.
Border | Defines a border around a report element.
Canvas | Represents a report item that provides a way to render custom contents within the report.
Chart | Base class for all charts in the report. Holds methods and properties common for all derived charts.
ControlWrapper | Represents a wrapper around a System.Windows.Forms.Control that can be added and rendered in a MindFusion.Reporting.Report.
DataRange | Represents a report item that provides master detail relation during data-binding.
DataRangeSection | Represents a data range header or footer.
DrawCanvasEventArgs | Contains the arguments passed to handlers of the RenderContents event of the Canvas class.
DrawContext | Provides contextual information when drawing report items.
DrawEventArgs | Provides data for various rendering events.
Ellipse | A report element that draws a simple ellipse.
ItemContainer | Represents a base class for report items that can serve as containers for other report items, such as DataRange.
Label | A report element that draws a static text.
Line | A report element that draws a simple line.
LineChart | Represents a report item that can display line charts.
Margins | Specifies the dimensions of the margins of a rectangle.
Page | Represents a page within a report.
PageBreak | Represents a single line across the whole width of a page, which indicates a page break at that location.
PageSection | Represents a page header or footer.
Picture | A report element that draws an image.
PieChart | Represents a report item that can display pie charts.
RadarChart | Represents a report item that can display radar charts.
Report | Serves as base class for all reports.
ReportItem | Represents an abstract base class for all report elements.
ReportLayout | Encapsulates the state of a laid out Report object. To create an instance of this class, call the Layout method of the Report class.
ReportParameter | Represents a parameter in a report.
SerializeDataSourceEventArgs | Provides data for the SerializeDataSource and DeserializeDataSource events.
SideBySideContainer | Represents a container that can hold side-by-side data ranges.
XmlSerializationContext | Contains methods that can help you serialize/deserialize MindFusion.Reporting reports to/from XML documents.

Structures

Structure | Description
Dimension | Stores an ordered pair of floating-point numbers, typically the width and height of an object.
Location | Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.

Enumerations

Enumeration | Description
BarType | Specifies the type of a bar chart.
LabelType | Specifies the type of labels drawn at chart elements.
LegendAlignment | Specifies the alignment of the chart legend.
LegendPosition | Specifies the position of the chart legend.
LineType | Specifies the type of a line chart.
MeasureUnit | Specifies units of measure.
PageOrientation | Specifies the orientation of a printed page.
PageSectionVisibility | Specifies the visibility of page headers and footers.
PieType | Specifies the type of a pie chart.
RadarStyle | Specifies the drawing styles for a radar chart.
RadarType | Specifies the different types of radar charts that can be drawn.
ReportParameterType | Specifies the type of a report parameter.


MindFusion.Reporting.AxesChart Class

AxesChart Class
Remarks See Also
[image]

A base class for report items representing charts that use the rectangular coordinate system.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public abstract class AxesChart : Chart

Visual Basic [image] Copy Code

Public MustInherit Class AxesChart
Inherits Chart

Remarks

AxesChart inherits properties and methods from its base class Chart.

Chart axes can be drawn with a shadow, which length is set with the Depth3D property. Use AxisShadowBrush to set the brush for the axis shadow. AxisPen specifies the pen for the chart axes.

Every axes chart can be drawn with a grid. You can choose among several grid types by using the GridType property. If the grid is Crossed, its density is set with GridWidth. The stripes of the grid are filled with GridBrush and AltGridBrush. The grid is drawn with the GridPen.

Custom grid points are set with HorGridPoints and VertGridPoints. They are drawn with HorGridPens and VertGridPens. Stripes in custom grids are filled with HorGridBrushes and VertGridBrushes.

Custom grids can have grid labels. They are set wtih XGridLabels, YGridLabels and Y2GridLabels. The orientation of the labels at the X-axis is set with XGridLabelsOrientation. If you want pointers to the grid labels, use GridLabelPointer.

The summary graphics or parts of graphics are drawn with SummaryBrushes and SummaryPens. Graphics, which data is bound to the Y2-axis are drawn with the Y2ChartBrushes and Y2ChartPens.

The AxisSettings class holds the settings for the chart axes - chart label, length, type of axis labels, label prefix and suffix, data formatting and so on. The properties for each chart axis are called XAxisSettings, YAxisSettings and Y2AxisSettings.

The chart data is set with XData and YData. Use Y2Data if you want to draw graphics for the second Y-axis, parallel to the first one. Data can be either numbers or DateTime values or any other format that can safely be converted to numbers / DateTime values using the standard .NET type converters.

Charts can be drawn with an Offset from the start of the coordinate system.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Chart
MindFusion.Reporting.AxesChart
MindFusion.Reporting.BarChart
MindFusion.Reporting.LineChart

See Also

AxesChart Members
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart Members

AxesChart Members
Constructors Properties
[image]

A base class for report items representing charts that use the rectangular coordinate system.

The following tables list the members exposed by the AxesChart type.

Protected Constructors

Name | Description
AxesChart | Initializes a new instance of the AxesChart class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
AltGridBrush | Gets or sets the brush used for filling even grid stripes.
AxisPen | Gets or sets the pen used for drawing the chart axis.
BackgroundBrush | Gets or sets the brush that fills the chart background. (Inherited from Chart.)
Border | Gets or sets the border of this chart. (Inherited from Chart.)
ChartBrushes | Gets or sets the brushes for the chart. (Inherited from Chart.)
ChartPens | Gets or sets the pens for the chart. (Inherited from Chart.)
DataMember | Gets or sets from which member in the data source data is read. (Inherited from Chart.)
DataSource | Gets or sets the object, from which chart data is retrieved. (Inherited from Chart.)
FontName | Gets or sets the name of the font for all chart labels. (Inherited from Chart.)
GridBrush | Gets or sets the brush used for filling odd grid stripes.
GridPen | Gets or sets the pen for drawing grid lines.
GridType | Gets or sets the type of the grid.
Horizontal | Gets or sets the orientation of the chart.
LabelBrush | Gets or sets the brush for the chart labels. (Inherited from Chart.)
LabelFont | Gets or sets the font for the chart labels. (Inherited from Chart.)
LegendAlignment | Gets or sets the alignment of the legend alongside the chart. (Inherited from Chart.)
LegendBackgroundBrush | Gets or sets the brush for the legend background. (Inherited from Chart.)
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels. (Inherited from Chart.)
LegendBrush | Gets or sets the brush for drawing the legend labels. (Inherited from Chart.)
LegendFont | Gets or sets the font for the legend labels. (Inherited from Chart.)
LegendLabels | Gets or sets the legend labels. (Inherited from Chart.)
LegendOffset | Gets or sets the offset of the legend to the axis labels. (Inherited from Chart.)
LegendPen | Gets or sets the pen for the legend outlining and grid. (Inherited from Chart.)
LegendPosition | Gets or sets the position of the legend. (Inherited from Chart.)
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
MasterDetailRelation | Gets or sets the master detail relation. (Inherited from Chart.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
PlotAreaBrush | Gets or sets the brush used for filling the plot area of the chart.
PlotAreaMargins | Gets or sets the margins of the chart plot area.
PlotAreaOutlinePen | Gets or sets the pen for outlining the plot area.
ShowLegend | Gets or sets a value indicating whether to display the chart legend. (Inherited from Chart.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
SubTitleBrush | Gets or sets the brush used for drawing the subtitle. (Inherited from Chart.)
SubTitleFont | Gets or sets the font for the subtitle. (Inherited from Chart.)
SubTitleText | Gets or sets the text for the subtitle. (Inherited from Chart.)
TitleBrush | Gets or sets the brush used for drawing the title. (Inherited from Chart.)
TitleFont | Gets or sets the font for the title. (Inherited from Chart.)
TitleText | Gets or sets the title text. (Inherited from Chart.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)
XAxisSettings | Gets or sets the appearance settings for the x-axis.
XLabels | Gets or sets custom labels for the x-axis.
XLabelsFields | Gets or sets the database columns from which custom labels for the x-axis are retrieved.
YAxisSettings | Gets or sets the appearance settings for the y-axis.
YLabels | Gets or sets custom labels for the y-axis.
YLabelsFields | Gets or sets the database columns, from which custom labels for the y-axis are retrieved.

See Also

AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart Constructor

AxesChart Constructor
[image]

Initializes a new instance of the AxesChart class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

protected AxesChart ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart Properties

AxesChart Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
AltGridBrush | Gets or sets the brush used for filling even grid stripes.
AxisPen | Gets or sets the pen used for drawing the chart axis.
BackgroundBrush | Gets or sets the brush that fills the chart background. (Inherited from Chart.)
Border | Gets or sets the border of this chart. (Inherited from Chart.)
ChartBrushes | Gets or sets the brushes for the chart. (Inherited from Chart.)
ChartPens | Gets or sets the pens for the chart. (Inherited from Chart.)
DataMember | Gets or sets from which member in the data source data is read. (Inherited from Chart.)
DataSource | Gets or sets the object, from which chart data is retrieved. (Inherited from Chart.)
FontName | Gets or sets the name of the font for all chart labels. (Inherited from Chart.)
GridBrush | Gets or sets the brush used for filling odd grid stripes.
GridPen | Gets or sets the pen for drawing grid lines.
GridType | Gets or sets the type of the grid.
Horizontal | Gets or sets the orientation of the chart.
LabelBrush | Gets or sets the brush for the chart labels. (Inherited from Chart.)
LabelFont | Gets or sets the font for the chart labels. (Inherited from Chart.)
LegendAlignment | Gets or sets the alignment of the legend alongside the chart. (Inherited from Chart.)
LegendBackgroundBrush | Gets or sets the brush for the legend background. (Inherited from Chart.)
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels. (Inherited from Chart.)
LegendBrush | Gets or sets the brush for drawing the legend labels. (Inherited from Chart.)
LegendFont | Gets or sets the font for the legend labels. (Inherited from Chart.)
LegendLabels | Gets or sets the legend labels. (Inherited from Chart.)
LegendOffset | Gets or sets the offset of the legend to the axis labels. (Inherited from Chart.)
LegendPen | Gets or sets the pen for the legend outlining and grid. (Inherited from Chart.)
LegendPosition | Gets or sets the position of the legend. (Inherited from Chart.)
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
MasterDetailRelation | Gets or sets the master detail relation. (Inherited from Chart.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
PlotAreaBrush | Gets or sets the brush used for filling the plot area of the chart.
PlotAreaMargins | Gets or sets the margins of the chart plot area.
PlotAreaOutlinePen | Gets or sets the pen for outlining the plot area.
ShowLegend | Gets or sets a value indicating whether to display the chart legend. (Inherited from Chart.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
SubTitleBrush | Gets or sets the brush used for drawing the subtitle. (Inherited from Chart.)
SubTitleFont | Gets or sets the font for the subtitle. (Inherited from Chart.)
SubTitleText | Gets or sets the text for the subtitle. (Inherited from Chart.)
TitleBrush | Gets or sets the brush used for drawing the title. (Inherited from Chart.)
TitleFont | Gets or sets the font for the title. (Inherited from Chart.)
TitleText | Gets or sets the title text. (Inherited from Chart.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)
XAxisSettings | Gets or sets the appearance settings for the x-axis.
XLabels | Gets or sets custom labels for the x-axis.
XLabelsFields | Gets or sets the database columns from which custom labels for the x-axis are retrieved.
YAxisSettings | Gets or sets the appearance settings for the y-axis.
YLabels | Gets or sets custom labels for the y-axis.
YLabelsFields | Gets or sets the database columns, from which custom labels for the y-axis are retrieved.

See Also

AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.AltGridBrush Property

AxesChart.AltGridBrush Property
[image]

Gets or sets the brush used for filling even grid stripes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush AltGridBrush { get; set; }

Visual Basic [image] Copy Code

Public Property AltGridBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

AltGridBrush is used for filling the even grid stripes when the GridType is not GridType.None or GridType.Custom. The odd grid stripes are filled with GridBrush. The grid stripes are drawn with the GridPen.

When the GridType is GridType.Custom the grid stripes are painted with HorGridBrushes and VertGridBrushes.

Default value for the AltGridBrush is null (no brush).

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.AxisPen Property

AxesChart.AxisPen Property
[image]

Gets or sets the pen used for drawing the chart axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Pen AxisPen { get; set; }

Visual Basic [image] Copy Code

Public Property AxisPen As Pen

Property Value

An instance of the Pen class.

Remarks

The property is used for drawing all chart axes. If the chart is of 3D type the axis shadow is drawn with AxisShadowBrush. If no AxisShadowBrush is specified, a shadow brush a little darker than the AxisPen is created.

Default value of the AxisPen property is black pen with width 1.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.GridBrush Property

AxesChart.GridBrush Property
[image]

Gets or sets the brush used for filling odd grid stripes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush GridBrush { get; set; }

Visual Basic [image] Copy Code

Public Property GridBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

GridBrush is used for filling the odd grid stripes when the GridType is not GridType.None or GridType.Custom. The even grid stripes are filled with AltGridBrush. The grid stripes are drawn with the GridPen.

Grid stripes in custom grids are painted with HorGridBrushes and VertGridBrushes.

Default value for the GridBrush is null (no brush).

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.GridPen Property

AxesChart.GridPen Property
[image]

Gets or sets the pen for drawing grid lines.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Pen GridPen { get; set; }

Visual Basic [image] Copy Code

Public Property GridPen As Pen

Property Value

An object of type MindFusion.Drawing.Pen.

Remarks

The GridPen is used for drawing the chart grid when the GridType is not GridType.None or GridType.Custom. The grid stripes are painted with GridBrush and AltGridBrush. You can have a grid that has only stripes and no lines are drawn. In this case, set GridPen to null.

The border of the grid is drawn with GridOutlinePen.

Default value for the GridPen is null, that is, no grid is drawn.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.GridType Property

AxesChart.GridType Property
[image]

Gets or sets the type of the grid.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public GridType GridType { get; set; }

Visual Basic [image] Copy Code

Public Property GridType As GridType

Property Value

One of the GridType Enumeration members.

Remarks

Grid can be drawn at all charts with axes. When the grid is of type GridType.Chess its width is set by GridWidth.

When the grid is custom, the positions of grid lines are specified with HorGridPoints and VertGridPoints. For all grid types, except GridType.None, the width is calculated automatically based on the scale of the axes.

Default value for the GridType property is GridType.None.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.Horizontal Property

AxesChart.Horizontal Property
[image]

Gets or sets the orientation of the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool Horizontal { get; set; }

Visual Basic [image] Copy Code

Public Property Horizontal As Boolean

Property Value

true if the chart is horizontal; otherwise false.

Remarks

In horizontal bar charts, the Data property specifies values for the X-axis. In vertical bar charts, the Data property specifies values for the Y-axis.

Line charts use data from both XData and YData lists, no matter their orientation. Summary operations are performed on XData for horizontal charts and YData for vertical ones. Bubble charts have no orientation.

Default value for the Horizontal property is false.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.PlotAreaBrush Property

AxesChart.PlotAreaBrush Property
[image]

Gets or sets the brush used for filling the plot area of the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush PlotAreaBrush { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaBrush As Brush

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.PlotAreaMargins Property

AxesChart.PlotAreaMargins Property
[image]

Gets or sets the margins of the chart plot area.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Margins PlotAreaMargins { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaMargins As Margins

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.PlotAreaOutlinePen Property

AxesChart.PlotAreaOutlinePen Property
[image]

Gets or sets the pen for outlining the plot area.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Pen PlotAreaOutlinePen { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaOutlinePen As Pen

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.XAxisSettings Property

AxesChart.XAxisSettings Property
[image]

Gets or sets the appearance settings for the x-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Axis XAxisSettings { get; set; }

Visual Basic [image] Copy Code

Public Property XAxisSettings As Axis

Property Value

An Axis object.

Remarks

The property specifies all appearance characteristics of the X-axis: minimum and maximum value as well the intervals among them.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.XLabels Property

AxesChart.XLabels Property
[image]

Gets or sets custom labels for the x-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList XLabels { get; set; }

Visual Basic [image] Copy Code

Public Property XLabels As IList

Property Value

An object of type .NET IList that holds other lists with the labels.

Remarks

The labels are drawn when XAxisSettings.LabelType is set to AxisLabelType.CustomText. If the labels are not set as strings, the control converts them automatically.

In multi-series charts, the labels are drawn in rows. The space among the rows depends on LabelSpan. LabelOffset specifies the offset of the labels to the chart axis.

The labels can be drawn rotated if RotationAngle is greater than zero. LabelBrush sets the brush for the labels. If MultiColoredLabels is true, the labels are drawn with the ChartBrushes.

If the labels are less than the data, the control adds empty strings. If they are more, the excess labels are omitted.

Default value for the XLabels property is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.XLabelsFields Property

AxesChart.XLabelsFields Property
[image]

Gets or sets the database columns from which custom labels for the x-axis are retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string XLabelsFields { get; set; }

Visual Basic [image] Copy Code

Public Property XLabelsFields As String

Property Value

A string that specifies the name of the data source field used as X-labels.

Remarks

The property enables you to bind the labels drawn at the X-axis to a field in a database. The data source object is specified with the DataSource property. If it is of type DataSet, you can use the DataMember property to specify a given table as source for the chart data. In this case, the fields of the table appear as items in the drop down combo box in the XLabelsFields property of the chart control.

The labels specified with the XLabelsFields are drawn only if the LabelType of the XAxisSettings property is set to AxisLabelType.CustomText.

The XLabelsFields property, when populated with data, is the same as the XLabels property.

Default value for the XLabelsFields property is an empty string ("").

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.YAxisSettings Property

AxesChart.YAxisSettings Property
[image]

Gets or sets the appearance settings for the y-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Axis YAxisSettings { get; set; }

Visual Basic [image] Copy Code

Public Property YAxisSettings As Axis

Property Value

An Axis object.

Remarks

The property specifies all appearance characteristics of the X-axis: minimum and maximum value as well the intervals among them.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.YLabels Property

AxesChart.YLabels Property
[image]

Gets or sets custom labels for the y-axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList YLabels { get; set; }

Visual Basic [image] Copy Code

Public Property YLabels As IList

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.AxesChart.YLabelsFields Property

AxesChart.YLabelsFields Property
[image]

Gets or sets the database columns, from which custom labels for the y-axis are retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string YLabelsFields { get; set; }

Visual Basic [image] Copy Code

Public Property YLabelsFields As String

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart Class

BarChart Class
[image]

Represents a report item that can display bar charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class BarChart : AxesChart, IVirtualPropertyProvider

Visual Basic [image] Copy Code

Public Class BarChart
Inherits AxesChart
Implements IVirtualPropertyProvider

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Chart
MindFusion.Reporting.AxesChart
MindFusion.Reporting.BarChart

See Also

BarChart Members
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart Members

BarChart Members
Constructors Properties
[image]

Represents a report item that can display bar charts.

The following tables list the members exposed by the BarChart type.

Public Constructors

Name | Description
BarChart | Initializes a new instance of the BarChart class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
AltGridBrush | Gets or sets the brush used for filling even grid stripes. (Inherited from AxesChart.)
AxisPen | Gets or sets the pen used for drawing the chart axis. (Inherited from AxesChart.)
BackgroundBrush | Gets or sets the brush that fills the chart background. (Inherited from Chart.)
BarSpacingRatio | Gets or sets the thickness of bars.
BarType | Gets or sets the type of bars.
Border | Gets or sets the border of this chart. (Inherited from Chart.)
ChartBrushes | Gets or sets the brushes for the chart. (Inherited from Chart.)
ChartPens | Gets or sets the pens for the chart. (Inherited from Chart.)
Data | Gets or sets the data for the chart, when not retrieved from a database.
DataFields | Gets or sets the names of database columns, from which data for the chart is retrieved.
DataMember | Gets or sets from which member in the data source data is read. (Inherited from Chart.)
DataSource | Gets or sets the object, from which chart data is retrieved. (Inherited from Chart.)
FontName | Gets or sets the name of the font for all chart labels. (Inherited from Chart.)
GridBrush | Gets or sets the brush used for filling odd grid stripes. (Inherited from AxesChart.)
GridPen | Gets or sets the pen for drawing grid lines. (Inherited from AxesChart.)
GridType | Gets or sets the type of the grid. (Inherited from AxesChart.)
Horizontal | Gets or sets the orientation of the chart. (Inherited from AxesChart.)
InnerLabels | Gets or sets custom text for the labels inside bars when not retrieved from a database.
InnerLabelsFields | Gets or sets the names of database columns, from which text for custom labels drawn inside bars is retrieved.
LabelBrush | Gets or sets the brush for the chart labels. (Inherited from Chart.)
LabelFont | Gets or sets the font for the chart labels. (Inherited from Chart.)
LegendAlignment | Gets or sets the alignment of the legend alongside the chart. (Inherited from Chart.)
LegendBackgroundBrush | Gets or sets the brush for the legend background. (Inherited from Chart.)
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels. (Inherited from Chart.)
LegendBrush | Gets or sets the brush for drawing the legend labels. (Inherited from Chart.)
LegendFont | Gets or sets the font for the legend labels. (Inherited from Chart.)
LegendLabels | Gets or sets the legend labels. (Inherited from Chart.)
LegendOffset | Gets or sets the offset of the legend to the axis labels. (Inherited from Chart.)
LegendPen | Gets or sets the pen for the legend outlining and grid. (Inherited from Chart.)
LegendPosition | Gets or sets the position of the legend. (Inherited from Chart.)
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
MasterDetailRelation | Gets or sets the master detail relation. (Inherited from Chart.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
PlotAreaBrush | Gets or sets the brush used for filling the plot area of the chart. (Inherited from AxesChart.)
PlotAreaMargins | Gets or sets the margins of the chart plot area. (Inherited from AxesChart.)
PlotAreaOutlinePen | Gets or sets the pen for outlining the plot area. (Inherited from AxesChart.)
ShowLegend | Gets or sets a value indicating whether to display the chart legend. (Inherited from Chart.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
SubTitleBrush | Gets or sets the brush used for drawing the subtitle. (Inherited from Chart.)
SubTitleFont | Gets or sets the font for the subtitle. (Inherited from Chart.)
SubTitleText | Gets or sets the text for the subtitle. (Inherited from Chart.)
TitleBrush | Gets or sets the brush used for drawing the title. (Inherited from Chart.)
TitleFont | Gets or sets the font for the title. (Inherited from Chart.)
TitleText | Gets or sets the title text. (Inherited from Chart.)
TopLabels | Gets or sets custom text as top labels when not retrieved from a database.
TopLabelsFields | Gets or sets the names of database columns, from which text for custom labels drawn at the top of bars is retrieved.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)
XAxisSettings | Gets or sets the appearance settings for the x-axis. (Inherited from AxesChart.)
XLabels | Gets or sets custom labels for the x-axis. (Inherited from AxesChart.)
XLabelsFields | Gets or sets the database columns from which custom labels for the x-axis are retrieved. (Inherited from AxesChart.)
YAxisSettings | Gets or sets the appearance settings for the y-axis. (Inherited from AxesChart.)
YLabels | Gets or sets custom labels for the y-axis. (Inherited from AxesChart.)
YLabelsFields | Gets or sets the database columns, from which custom labels for the y-axis are retrieved. (Inherited from AxesChart.)

See Also

BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart Constructor

BarChart Constructor
[image]

Initializes a new instance of the BarChart class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public BarChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart Properties

BarChart Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
AltGridBrush | Gets or sets the brush used for filling even grid stripes. (Inherited from AxesChart.)
AxisPen | Gets or sets the pen used for drawing the chart axis. (Inherited from AxesChart.)
BackgroundBrush | Gets or sets the brush that fills the chart background. (Inherited from Chart.)
BarSpacingRatio | Gets or sets the thickness of bars.
BarType | Gets or sets the type of bars.
Border | Gets or sets the border of this chart. (Inherited from Chart.)
ChartBrushes | Gets or sets the brushes for the chart. (Inherited from Chart.)
ChartPens | Gets or sets the pens for the chart. (Inherited from Chart.)
Data | Gets or sets the data for the chart, when not retrieved from a database.
DataFields | Gets or sets the names of database columns, from which data for the chart is retrieved.
DataMember | Gets or sets from which member in the data source data is read. (Inherited from Chart.)
DataSource | Gets or sets the object, from which chart data is retrieved. (Inherited from Chart.)
FontName | Gets or sets the name of the font for all chart labels. (Inherited from Chart.)
GridBrush | Gets or sets the brush used for filling odd grid stripes. (Inherited from AxesChart.)
GridPen | Gets or sets the pen for drawing grid lines. (Inherited from AxesChart.)
GridType | Gets or sets the type of the grid. (Inherited from AxesChart.)
Horizontal | Gets or sets the orientation of the chart. (Inherited from AxesChart.)
InnerLabels | Gets or sets custom text for the labels inside bars when not retrieved from a database.
InnerLabelsFields | Gets or sets the names of database columns, from which text for custom labels drawn inside bars is retrieved.
LabelBrush | Gets or sets the brush for the chart labels. (Inherited from Chart.)
LabelFont | Gets or sets the font for the chart labels. (Inherited from Chart.)
LegendAlignment | Gets or sets the alignment of the legend alongside the chart. (Inherited from Chart.)
LegendBackgroundBrush | Gets or sets the brush for the legend background. (Inherited from Chart.)
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels. (Inherited from Chart.)
LegendBrush | Gets or sets the brush for drawing the legend labels. (Inherited from Chart.)
LegendFont | Gets or sets the font for the legend labels. (Inherited from Chart.)
LegendLabels | Gets or sets the legend labels. (Inherited from Chart.)
LegendOffset | Gets or sets the offset of the legend to the axis labels. (Inherited from Chart.)
LegendPen | Gets or sets the pen for the legend outlining and grid. (Inherited from Chart.)
LegendPosition | Gets or sets the position of the legend. (Inherited from Chart.)
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
MasterDetailRelation | Gets or sets the master detail relation. (Inherited from Chart.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
PlotAreaBrush | Gets or sets the brush used for filling the plot area of the chart. (Inherited from AxesChart.)
PlotAreaMargins | Gets or sets the margins of the chart plot area. (Inherited from AxesChart.)
PlotAreaOutlinePen | Gets or sets the pen for outlining the plot area. (Inherited from AxesChart.)
ShowLegend | Gets or sets a value indicating whether to display the chart legend. (Inherited from Chart.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
SubTitleBrush | Gets or sets the brush used for drawing the subtitle. (Inherited from Chart.)
SubTitleFont | Gets or sets the font for the subtitle. (Inherited from Chart.)
SubTitleText | Gets or sets the text for the subtitle. (Inherited from Chart.)
TitleBrush | Gets or sets the brush used for drawing the title. (Inherited from Chart.)
TitleFont | Gets or sets the font for the title. (Inherited from Chart.)
TitleText | Gets or sets the title text. (Inherited from Chart.)
TopLabels | Gets or sets custom text as top labels when not retrieved from a database.
TopLabelsFields | Gets or sets the names of database columns, from which text for custom labels drawn at the top of bars is retrieved.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)
XAxisSettings | Gets or sets the appearance settings for the x-axis. (Inherited from AxesChart.)
XLabels | Gets or sets custom labels for the x-axis. (Inherited from AxesChart.)
XLabelsFields | Gets or sets the database columns from which custom labels for the x-axis are retrieved. (Inherited from AxesChart.)
YAxisSettings | Gets or sets the appearance settings for the y-axis. (Inherited from AxesChart.)
YLabels | Gets or sets custom labels for the y-axis. (Inherited from AxesChart.)
YLabelsFields | Gets or sets the database columns, from which custom labels for the y-axis are retrieved. (Inherited from AxesChart.)

See Also

BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.BarType Property

BarChart.BarType Property
[image]

Gets or sets the type of bars.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public BarType BarType { get; set; }

Visual Basic [image] Copy Code

Public Property BarType As BarType

Property Value

A member of the BarType enumeration.

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.Data Property

BarChart.Data Property
[image]

Gets or sets the data for the chart, when not retrieved from a database.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As IList

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.DataFields Property

BarChart.DataFields Property
[image]

Gets or sets the names of database columns, from which data for the chart is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string DataFields { get; set; }

Visual Basic [image] Copy Code

Public Property DataFields As String

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.InnerLabels Property

BarChart.InnerLabels Property
[image]

Gets or sets custom text for the labels inside bars when not retrieved from a database.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList InnerLabels { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabels As IList

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.InnerLabelsFields Property

BarChart.InnerLabelsFields Property
[image]

Gets or sets the names of database columns, from which text for custom labels drawn inside bars is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string InnerLabelsFields { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelsFields As String

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.TopLabels Property

BarChart.TopLabels Property
[image]

Gets or sets custom text as top labels when not retrieved from a database.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList TopLabels { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabels As IList

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.TopLabelsFields Property

BarChart.TopLabelsFields Property
[image]

Gets or sets the names of database columns, from which text for custom labels drawn at the top of bars is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string TopLabelsFields { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabelsFields As String

Property Value

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarChart.BarSpacingRatio Property

BarChart.BarSpacingRatio Property
[image]

Gets or sets the thickness of bars.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float BarSpacingRatio { get; set; }

Visual Basic [image] Copy Code

Public Property BarSpacingRatio As Single

Property Value

A float value.

See Also

BarChart Members
BarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode Class

Barcode Class
[image]

Represents a report item that that can render barcodes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class Barcode : ReportItem

Visual Basic [image] Copy Code

Public Class Barcode
Inherits ReportItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Barcode

See Also

Barcode Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode Members

Barcode Members
Constructors Properties
[image]

Represents a report item that that can render barcodes.

The following tables list the members exposed by the Barcode type.

Public Constructors

Name | Description
Barcode | Initializes a new instance of the Barcode class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
AutoSize | Gets or sets a value indicating whether the barcode will resize automatically.
Background | Gets or sets the brush that will be used to fill the barcode background.
Color | Gets or sets the color that will be used to draw the barcode.
Content | Gets or sets the barcode content.
DataField | Gets or sets the name of the data field to bind to.
Font | Gets or sets the barcode font.
FontName | Gets or sets the default font in the report.
FontSize | Gets or sets the font size of the label.
FontStyle | Gets or sets the font style of the label.
Format | Gets or sets the barcode format.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
QRCorrectionLevel | Gets or sets the correction level of QR barcodes.
RotationAngle | Gets or sets the rotation angle of the barcode.
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode Constructor

Barcode Constructor
[image]

Initializes a new instance of the Barcode class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Barcode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode Properties

Barcode Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
AutoSize | Gets or sets a value indicating whether the barcode will resize automatically.
Background | Gets or sets the brush that will be used to fill the barcode background.
Color | Gets or sets the color that will be used to draw the barcode.
Content | Gets or sets the barcode content.
DataField | Gets or sets the name of the data field to bind to.
Font | Gets or sets the barcode font.
FontName | Gets or sets the default font in the report.
FontSize | Gets or sets the font size of the label.
FontStyle | Gets or sets the font style of the label.
Format | Gets or sets the barcode format.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
QRCorrectionLevel | Gets or sets the correction level of QR barcodes.
RotationAngle | Gets or sets the rotation angle of the barcode.
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode.AutoSize Property

Barcode.AutoSize Property
[image]

Gets or sets a value indicating whether the barcode will resize automatically.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool AutoSize { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSize As Boolean

Property Value

true to automatically resize the barcode based on its content; otherwise, false.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode.Background Property

Barcode.Background Property
[image]

Gets or sets the brush that will be used to fill the barcode background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush Background { get; set; }

Visual Basic [image] Copy Code

Public Property Background As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic) indicating a transparent background.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode.Color Property

Barcode.Color Property
[image]

Gets or sets the color that will be used to draw the barcode.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

A .NET Color object specifying the color of the barcode. The default is Black.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode.Content Property

Barcode.Content Property
[image]

Gets or sets the barcode content.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string Content { get; set; }

Visual Basic [image] Copy Code

Public Property Content As String

Property Value

A string representing the barcode content.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode.DataField Property

Barcode.DataField Property
[image]

Gets or sets the name of the data field to bind to.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string DataField { get; set; }

Visual Basic [image] Copy Code

Public Property DataField As String

Property Value

A string specifying the data field this barcode is bound to. The default is an empty string indicating that the barcode is not data-bound.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode.Font Property

Barcode.Font Property
[image]

Gets or sets the barcode font.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Font Font { get; set; }

Visual Basic [image] Copy Code

Public Property Font As Font

Property Value

A .NET Font object specifying the font of the barcode. The default value is null (Nothing in Visual Basic).

Remarks

When this property is null (Nothing in Visual Basic) the font of the barcode is determined by the value of the Font property of the containing Report.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode.Format Property

Barcode.Format Property
[image]

Gets or sets the barcode format.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public BarcodeFormat Format { get; set; }

Visual Basic [image] Copy Code

Public Property Format As BarcodeFormat

Property Value

A member of the BarcodeFormat enumeration.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode.QRCorrectionLevel Property

Barcode.QRCorrectionLevel Property
[image]

Gets or sets the correction level of QR barcodes.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public CorrectionLevel QRCorrectionLevel { get; set; }

Visual Basic [image] Copy Code

Public Property QRCorrectionLevel As CorrectionLevel

Property Value

A member of the CorrectionLevel enumeration.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode.RotationAngle Property

Barcode.RotationAngle Property
[image]

Gets or sets the rotation angle of the barcode.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float RotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property RotationAngle As Single

Property Value

A float value specifying the rotation angle of the barcode, in degrees.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode.FontName Property

Barcode.FontName Property
[image]

Gets or sets the default font in the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string FontName { get; set; }

Visual Basic [image] Copy Code

Public Property FontName As String

Property Value

A string value or null (Nothing in Visual Basic) to use the report font.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode.FontSize Property

Barcode.FontSize Property
[image]

Gets or sets the font size of the label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Nullable<Single> FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Nullable(Of Single)

Property Value

A float value or null (Nothing in Visual Basic) to use the report font size.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Barcode.FontStyle Property

Barcode.FontStyle Property
[image]

Gets or sets the font style of the label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Nullable<FontStyle> FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As Nullable(Of FontStyle)

Property Value

A member of the FontStyle enumeration or null (Nothing in Visual Basic) to use the report font style.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting Namespace


MindFusion.Reporting.BarType Enumeration

BarType Enumeration
[image]

Specifies the type of a bar chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public enum BarType

Visual Basic [image] Copy Code

Public Enum BarType

Members

Member name | Description
ThreeD | Indicates a 3D bar chart.
TwoD | Indicates a 2D bar chart.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.Border Class

Border Class
Remarks See Also
[image]

Defines a border around a report element.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public sealed class Border : ICloneable

Visual Basic [image] Copy Code

Public NotInheritable Class Border
Implements ICloneable

Remarks

The border class lets you define a border around certain report elements - in particular those that provide a Border property. You need to create an instance of this class and assign it to the Border property of the report element.

It is not necessary to specify all the sides of a Border object. For example, you can create a border, which has only a left side, or whose sides have different colors or widths.

The following example creates a simple black border and assigns it to a Label element:

C# [image] Copy Code

label1.Border = new Border(Color.Black, 0);

Visual Basic [image] Copy Code

Label1.Border = New Border(Color.Black, 0)

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Border

See Also

Border Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Members

Border Members
Constructors Properties Methods
[image]

Defines a border around a report element.

The following tables list the members exposed by the Border type.

Public Constructors

Name | Description
Border | Overloaded. Initializes a new instance of the Border class.

Public Properties

Name | Description
BottomAlignment | Gets or sets the alignment of the bottom border.
BottomColor | Gets or sets the color of the bottom border.
BottomDashStyle | Gets or sets the style of the bottom border.
BottomVisible | Gets or sets a value indicating whether the bottom border is visible.
BottomWidth | Gets or sets the width of the bottom border.
IsEmpty | Gets a value indicating whether the border is empty.
LeftAlignment | Gets or sets the alignment of the left border.
LeftColor | Gets or sets the color of the left border.
LeftDashStyle | Gets or sets the style of the left border.
LeftVisible | Gets or sets a value indicating whether the left border is visible.
LeftWidth | Gets or sets the width of the left border.
RightAlignment | Gets or sets the alignment of the right border.
RightColor | Gets or sets the color of the left border.
RightDashStyle | Gets or sets the style of the right border.
RightVisible | Gets or sets a value indicating whether the right border is visible.
RightWidth | Gets or sets the width of the right border.
TopAlignment | Gets or sets the alignment of the top border.
TopColor | Gets or sets the color of the top border.
TopDashStyle | Gets or sets the style of the top border.
TopVisible | Gets or sets a value indicating whether the top border is visible.
TopWidth | Gets or sets the width of the top border.

Public Methods

Name | Description
Clone | Creates an exact clone of this Border object.
MakeEmpty | Resets the border to be invisible.
ToString | Object.ToString override.

See Also

Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Constructor

Border Constructor
[image]

Initializes a new instance of the Border class.

Overload List

Name | Description
Border () | Initializes a new instance of the Border class.
Border (Color, Single) | Initializes a new instance of the Border class.
Border (Color, Single, PenAlignment) | Initializes a new instance of the Border class.

See Also

Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Constructor ()

Border Constructor ()
See Also
[image]

Initializes a new instance of the Border class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Border ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Border Constructor Overload List
Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Constructor (Color, Single)

Border Constructor (Color, Single)
See Also
[image]

Initializes a new instance of the Border class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Border (
Color color,
float width
)

Visual Basic [image] Copy Code

Public New ( _
color As Color, _
width As Single _
)

Parameters

color
A .NET Color object that specifies the color of all four sides of the new border.
width
An integer value specifying the width of all four sides of the new border.

See Also

Border Constructor Overload List
Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Constructor (Color, Single, PenAlignment)

Border Constructor (Color, Single, PenAlignment)
See Also
[image]

Initializes a new instance of the Border class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Border (
Color color,
float width,
PenAlignment alignment
)

Visual Basic [image] Copy Code

Public New ( _
color As Color, _
width As Single, _
alignment As PenAlignment _
)

Parameters

color
A .NET Color object that specifies the color of all four sides of the new border.
width
An integer value specifying the width of all four sides of the new border.
alignment
A .NET PenAlignment value specifying the alignment of all four sides of the border.

See Also

Border Constructor Overload List
Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Methods

Border Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact clone of this Border object.
MakeEmpty | Resets the border to be invisible.
ToString | Object.ToString override.

See Also

Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border.Clone Method

Border.Clone Method
[image]

Creates an exact clone of this Border object.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An instance of the Border class.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border.MakeEmpty Method

Border.MakeEmpty Method
[image]

Resets the border to be invisible.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public void MakeEmpty ()

Visual Basic [image] Copy Code

Public Sub MakeEmpty ()

Remarks

Calling this method is equivalent to setting the visibility of each of the four border sides to false.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftVisible Property
TopVisible Property
RightVisible Property
BottomVisible Property


MindFusion.Reporting.Border.ToString Method

Border.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

Border Members
Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border Properties

Border Properties
[image]

Public Properties

Name | Description
BottomAlignment | Gets or sets the alignment of the bottom border.
BottomColor | Gets or sets the color of the bottom border.
BottomDashStyle | Gets or sets the style of the bottom border.
BottomVisible | Gets or sets a value indicating whether the bottom border is visible.
BottomWidth | Gets or sets the width of the bottom border.
IsEmpty | Gets a value indicating whether the border is empty.
LeftAlignment | Gets or sets the alignment of the left border.
LeftColor | Gets or sets the color of the left border.
LeftDashStyle | Gets or sets the style of the left border.
LeftVisible | Gets or sets a value indicating whether the left border is visible.
LeftWidth | Gets or sets the width of the left border.
RightAlignment | Gets or sets the alignment of the right border.
RightColor | Gets or sets the color of the left border.
RightDashStyle | Gets or sets the style of the right border.
RightVisible | Gets or sets a value indicating whether the right border is visible.
RightWidth | Gets or sets the width of the right border.
TopAlignment | Gets or sets the alignment of the top border.
TopColor | Gets or sets the color of the top border.
TopDashStyle | Gets or sets the style of the top border.
TopVisible | Gets or sets a value indicating whether the top border is visible.
TopWidth | Gets or sets the width of the top border.

See Also

Border Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Border.BottomAlignment Property

Border.BottomAlignment Property
[image]

Gets or sets the alignment of the bottom border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PenAlignment BottomAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property BottomAlignment As PenAlignment

Property Value

A member of the .NET PenAlignment enumeration that specifies the alignment of the bottom side of the border. The default is Center.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftAlignment Property
TopAlignment Property
RightAlignment Property


MindFusion.Reporting.Border.BottomColor Property

Border.BottomColor Property
[image]

Gets or sets the color of the bottom border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Color BottomColor { get; set; }

Visual Basic [image] Copy Code

Public Property BottomColor As Color

Property Value

A .NET Color object specifying the color of the bottom side of the border. The default is Color.Empty.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftColor Property
TopColor Property
RightColor Property


MindFusion.Reporting.Border.BottomDashStyle Property

Border.BottomDashStyle Property
[image]

Gets or sets the style of the bottom border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public DashStyle BottomDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property BottomDashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration that specifies the dash pattern of the bottom side of the border. The default is Solid.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftDashStyle Property
TopDashStyle Property
RightDashStyle Property


MindFusion.Reporting.Border.BottomVisible Property

Border.BottomVisible Property
[image]

Gets or sets a value indicating whether the bottom border is visible.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool BottomVisible { get; set; }

Visual Basic [image] Copy Code

Public Property BottomVisible As Boolean

Property Value

A boolean value specifying whether the bottom side of the border is visible. The default is false.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftVisible Property
TopVisible Property
RightVisible Property


MindFusion.Reporting.Border.BottomWidth Property

Border.BottomWidth Property
[image]

Gets or sets the width of the bottom border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float BottomWidth { get; set; }

Visual Basic [image] Copy Code

Public Property BottomWidth As Single

Property Value

An integer value specifying the width of the bottom side of the border. The default is 0.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftWidth Property
TopWidth Property
RightWidth Property


MindFusion.Reporting.Border.IsEmpty Property

Border.IsEmpty Property
[image]

Gets a value indicating whether the border is empty.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

A boolean value specifying whether the border is empty.

Remarks

This property returns true for borders all sides of which are invisible, that is, LeftVisible, TopVisible, RightVisible and BottomVisible are all set to false. This property will still return false for borders that are not rendered because their sides have transparent colors for example.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftVisible Property
TopVisible Property
RightVisible Property
BottomVisible Property


MindFusion.Reporting.Border.LeftAlignment Property

Border.LeftAlignment Property
[image]

Gets or sets the alignment of the left border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PenAlignment LeftAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property LeftAlignment As PenAlignment

Property Value

A member of the .NET PenAlignment enumeration that specifies the alignment of the left side of the border. The default is Center.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
TopAlignment Property
RightAlignment Property
BottomAlignment Property


MindFusion.Reporting.Border.LeftColor Property

Border.LeftColor Property
[image]

Gets or sets the color of the left border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Color LeftColor { get; set; }

Visual Basic [image] Copy Code

Public Property LeftColor As Color

Property Value

A .NET Color object specifying the color of the left side of the border. The default is Color.Empty.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
TopColor Property
RightColor Property
BottomColor Property


MindFusion.Reporting.Border.LeftDashStyle Property

Border.LeftDashStyle Property
[image]

Gets or sets the style of the left border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public DashStyle LeftDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LeftDashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration that specifies the dash pattern of the left side of the border. The default is Solid.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
TopDashStyle Property
RightDashStyle Property
BottomDashStyle Property


MindFusion.Reporting.Border.LeftVisible Property

Border.LeftVisible Property
[image]

Gets or sets a value indicating whether the left border is visible.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool LeftVisible { get; set; }

Visual Basic [image] Copy Code

Public Property LeftVisible As Boolean

Property Value

A boolean value specifying whether the left side of the border is visible. The default is false.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
TopVisible Property
RightVisible Property
BottomVisible Property


MindFusion.Reporting.Border.LeftWidth Property

Border.LeftWidth Property
[image]

Gets or sets the width of the left border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float LeftWidth { get; set; }

Visual Basic [image] Copy Code

Public Property LeftWidth As Single

Property Value

An integer value specifying the width of the left side of the border. The default is 0.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
TopWidth Property
RightWidth Property
BottomWidth Property


MindFusion.Reporting.Border.RightAlignment Property

Border.RightAlignment Property
[image]

Gets or sets the alignment of the right border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PenAlignment RightAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property RightAlignment As PenAlignment

Property Value

A member of the .NET PenAlignment enumeration that specifies the alignment of the right side of the border. The default is Center.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftAlignment Property
TopAlignment Property
BottomAlignment Property


MindFusion.Reporting.Border.RightColor Property

Border.RightColor Property
[image]

Gets or sets the color of the left border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Color RightColor { get; set; }

Visual Basic [image] Copy Code

Public Property RightColor As Color

Property Value

A .NET Color object specifying the color of the right side of the border. The default is Color.Empty.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftColor Property
TopColor Property
BottomColor Property


MindFusion.Reporting.Border.RightDashStyle Property

Border.RightDashStyle Property
[image]

Gets or sets the style of the right border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public DashStyle RightDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property RightDashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration that specifies the dash pattern of the right side of the border. The default is Solid.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftDashStyle Property
TopDashStyle Property
BottomDashStyle Property


MindFusion.Reporting.Border.RightVisible Property

Border.RightVisible Property
[image]

Gets or sets a value indicating whether the right border is visible.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool RightVisible { get; set; }

Visual Basic [image] Copy Code

Public Property RightVisible As Boolean

Property Value

A boolean value specifying whether the right side of the border is visible. The default is false.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftVisible Property
TopVisible Property
BottomVisible Property


MindFusion.Reporting.Border.RightWidth Property

Border.RightWidth Property
[image]

Gets or sets the width of the right border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float RightWidth { get; set; }

Visual Basic [image] Copy Code

Public Property RightWidth As Single

Property Value

An integer value specifying the width of the right side of the border. The default is 0.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftWidth Property
TopWidth Property
BottomWidth Property


MindFusion.Reporting.Border.TopAlignment Property

Border.TopAlignment Property
[image]

Gets or sets the alignment of the top border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PenAlignment TopAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TopAlignment As PenAlignment

Property Value

A member of the .NET PenAlignment enumeration that specifies the alignment of the top side of the border. The default is Center.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftAlignment Property
RightAlignment Property
BottomAlignment Property


MindFusion.Reporting.Border.TopColor Property

Border.TopColor Property
[image]

Gets or sets the color of the top border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Color TopColor { get; set; }

Visual Basic [image] Copy Code

Public Property TopColor As Color

Property Value

A .NET Color object specifying the color of the top side of the border. The default is Color.Empty.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftColor Property
RightColor Property
BottomColor Property


MindFusion.Reporting.Border.TopDashStyle Property

Border.TopDashStyle Property
[image]

Gets or sets the style of the top border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public DashStyle TopDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TopDashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration that specifies the dash pattern of the top side of the border. The default is Solid.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftDashStyle Property
RightDashStyle Property
BottomDashStyle Property


MindFusion.Reporting.Border.TopVisible Property

Border.TopVisible Property
[image]

Gets or sets a value indicating whether the top border is visible.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool TopVisible { get; set; }

Visual Basic [image] Copy Code

Public Property TopVisible As Boolean

Property Value

A boolean value specifying whether the top side of the border is visible. The default is false.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftVisible Property
RightVisible Property
BottomVisible Property


MindFusion.Reporting.Border.TopWidth Property

Border.TopWidth Property
[image]

Gets or sets the width of the top border.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float TopWidth { get; set; }

Visual Basic [image] Copy Code

Public Property TopWidth As Single

Property Value

An integer value specifying the width of the right side of the border. The default is 0.

See Also

Border Members
Border Class
MindFusion.Reporting Namespace
LeftWidth Property
RightWidth Property
BottomWidth Property


MindFusion.Reporting.Canvas Class

Canvas Class
Remarks See Also
[image]

Represents a report item that provides a way to render custom contents within the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class Canvas : ReportItem

Visual Basic [image] Copy Code

Public Class Canvas
Inherits ReportItem

Remarks

The Canvas element does not provide any visualization by default. In order to perform rendering through the Canvas, you need to handle its RenderContents event and place the custom drawing code in the event handler.

The following example illustrates how to render a rectangle using a Canvas object. The example assumes that canvas1 is a variable that references a valid Canvas instance.

C# [image] Copy Code

canvas1.RenderContents += new DrawCanvasEventHandler(this.OnDrawCanvas);

// ...

private void OnDrawCanvas(object sender, DrawCanvasEventArgs e)
{
// Render a black rectangle
e.Graphics.DrawRectangle(Pens.Black, e.Bounds);
}

Visual Basic [image] Copy Code

AddHandler(canvas1.RenderCanvas, AddressOf Me.OnDrawCanvas)

' ...

Private Sub OnDrawCanvas(ByRef sender As Object, ByRef e As DrawCanvasEventArgs)

' Render a black rectangle
e.Graphics.DrawRectangle(Pens.Black, e.Bounds)

End Sub

The Canvas element can be data-bound, similarly to a Label or a Picture. In this case, the value retrieved from the data source can be accessed through the DataValue property of the DrawCanvasEventArgs object passed to the RenderContents event handler. The type of this value depends on the type of the field the Canvas is data-bound to.

To learn more about data-binding, visit the Binding Reports to a Data Source.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Canvas

See Also

Canvas Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas Members

Canvas Members
Constructors Properties Methods Events
[image]

Represents a report item that provides a way to render custom contents within the report.

The following tables list the members exposed by the Canvas type.

Public Constructors

Name | Description
Canvas | Initializes a new instance of the Canvas class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
DataField | Gets or sets the name of the data field to bind to.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

Protected Methods

Name | Description
OnRenderContents | Fires the RenderContents event.

Public Events

Name | Description
RenderContents | Raised to enable you to perform custom rendering within the canvas.

See Also

Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas Constructor

Canvas Constructor
[image]

Initializes a new instance of the Canvas class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Canvas ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas Methods

Canvas Methods
[image]

Protected Methods

Name | Description
OnRenderContents | Fires the RenderContents event.

See Also

Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas.OnRenderContents Method

Canvas.OnRenderContents Method
[image]

Fires the RenderContents event.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

protected virtual void OnRenderContents (
DrawCanvasEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRenderContents ( _
e As DrawCanvasEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Canvas Members
Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas Properties

Canvas Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
DataField | Gets or sets the name of the data field to bind to.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas.DataField Property

Canvas.DataField Property
[image]

Gets or sets the name of the data field to bind to.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string DataField { get; set; }

Visual Basic [image] Copy Code

Public Property DataField As String

Property Value

A string containing the name of the database field to bind the Canvas to.

Remarks

This property is valid only when the Canvas object is placed in a data-bound DataRange container. Otherwise the value of the property is ignored since the Canvas cannot obtain a data source to bind to.

See Also

Canvas Members
Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas Events

Canvas Events
[image]

Public Events

Name | Description
RenderContents | Raised to enable you to perform custom rendering within the canvas.

See Also

Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Canvas.RenderContents Event

Canvas.RenderContents Event
[image]

Raised to enable you to perform custom rendering within the canvas.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public event EventHandler<DrawCanvasEventArgs> RenderContents

Visual Basic [image] Copy Code

Public Event RenderContents As EventHandler(Of DrawCanvasEventArgs)

Event Data

RenderContents event handlers receive an argument of type DrawCanvasEventArgs.

Example

The following example illustrates how to render a rectangle using a Canvas object. The example assumes that canvas1 is a variable that references a valid Canvas instance.

C# [image] Copy Code

canvas1.RenderContents += new DrawCanvasEventHandler(this.OnDrawCanvas);

// ...

private void OnDrawCanvas(object sender, DrawCanvasEventArgs e)
{
// Render a black rectangle
e.Graphics.DrawRectangle(Pens.Black, e.Bounds);
}

Visual Basic [image] Copy Code

AddHandler(canvas1.RenderCanvas, AddressOf Me.OnDrawCanvas)

' ...

Private Sub OnDrawCanvas(ByRef sender As Object, ByRef e As DrawCanvasEventArgs)

' Render a black rectangle
e.Graphics.DrawRectangle(Pens.Black, e.Bounds)

End Sub

See Also

Canvas Members
Canvas Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart Class

Chart Class
[image]

Base class for all charts in the report. Holds methods and properties common for all derived charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public abstract class Chart : ReportItem

Visual Basic [image] Copy Code

Public MustInherit Class Chart
Inherits ReportItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Chart
MindFusion.Reporting.AxesChart
MindFusion.Reporting.PieChart
MindFusion.Reporting.RadarChart

See Also

Chart Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart Members

Chart Members
Constructors Properties
[image]

Base class for all charts in the report. Holds methods and properties common for all derived charts.

The following tables list the members exposed by the Chart type.

Protected Constructors

Name | Description
Chart | Initializes a new instance of the Chart class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
BackgroundBrush | Gets or sets the brush that fills the chart background.
Border | Gets or sets the border of this chart.
ChartBrushes | Gets or sets the brushes for the chart.
ChartPens | Gets or sets the pens for the chart.
DataMember | Gets or sets from which member in the data source data is read.
DataSource | Gets or sets the object, from which chart data is retrieved.
FontName | Gets or sets the name of the font for all chart labels.
LabelBrush | Gets or sets the brush for the chart labels.
LabelFont | Gets or sets the font for the chart labels.
LegendAlignment | Gets or sets the alignment of the legend alongside the chart.
LegendBackgroundBrush | Gets or sets the brush for the legend background.
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels.
LegendBrush | Gets or sets the brush for drawing the legend labels.
LegendFont | Gets or sets the font for the legend labels.
LegendLabels | Gets or sets the legend labels.
LegendOffset | Gets or sets the offset of the legend to the axis labels.
LegendPen | Gets or sets the pen for the legend outlining and grid.
LegendPosition | Gets or sets the position of the legend.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
MasterDetailRelation | Gets or sets the master detail relation.
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
ShowLegend | Gets or sets a value indicating whether to display the chart legend.
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
SubTitleBrush | Gets or sets the brush used for drawing the subtitle.
SubTitleFont | Gets or sets the font for the subtitle.
SubTitleText | Gets or sets the text for the subtitle.
TitleBrush | Gets or sets the brush used for drawing the title.
TitleFont | Gets or sets the font for the title.
TitleText | Gets or sets the title text.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart Constructor

Chart Constructor
[image]

Initializes a new instance of the Chart class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

protected Chart ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart Properties

Chart Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
BackgroundBrush | Gets or sets the brush that fills the chart background.
Border | Gets or sets the border of this chart.
ChartBrushes | Gets or sets the brushes for the chart.
ChartPens | Gets or sets the pens for the chart.
DataMember | Gets or sets from which member in the data source data is read.
DataSource | Gets or sets the object, from which chart data is retrieved.
FontName | Gets or sets the name of the font for all chart labels.
LabelBrush | Gets or sets the brush for the chart labels.
LabelFont | Gets or sets the font for the chart labels.
LegendAlignment | Gets or sets the alignment of the legend alongside the chart.
LegendBackgroundBrush | Gets or sets the brush for the legend background.
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels.
LegendBrush | Gets or sets the brush for drawing the legend labels.
LegendFont | Gets or sets the font for the legend labels.
LegendLabels | Gets or sets the legend labels.
LegendOffset | Gets or sets the offset of the legend to the axis labels.
LegendPen | Gets or sets the pen for the legend outlining and grid.
LegendPosition | Gets or sets the position of the legend.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
MasterDetailRelation | Gets or sets the master detail relation.
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
ShowLegend | Gets or sets a value indicating whether to display the chart legend.
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
SubTitleBrush | Gets or sets the brush used for drawing the subtitle.
SubTitleFont | Gets or sets the font for the subtitle.
SubTitleText | Gets or sets the text for the subtitle.
TitleBrush | Gets or sets the brush used for drawing the title.
TitleFont | Gets or sets the font for the title.
TitleText | Gets or sets the title text.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.BackgroundBrush Property

Chart.BackgroundBrush Property
[image]

Gets or sets the brush that fills the chart background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush BackgroundBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BackgroundBrush As Brush

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.Border Property

Chart.Border Property
[image]

Gets or sets the border of this chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Border Border { get; set; }

Visual Basic [image] Copy Code

Public Property Border As Border

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.ChartBrushes Property

Chart.ChartBrushes Property
[image]

Gets or sets the brushes for the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public BrushCollection ChartBrushes { get; set; }

Visual Basic [image] Copy Code

Public Property ChartBrushes As BrushCollection

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.ChartPens Property

Chart.ChartPens Property
[image]

Gets or sets the pens for the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PenCollection ChartPens { get; set; }

Visual Basic [image] Copy Code

Public Property ChartPens As PenCollection

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.DataMember Property

Chart.DataMember Property
[image]

Gets or sets from which member in the data source data is read.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string DataMember { get; set; }

Visual Basic [image] Copy Code

Public Property DataMember As String

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.DataSource Property

Chart.DataSource Property
[image]

Gets or sets the object, from which chart data is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Object DataSource { get; set; }

Visual Basic [image] Copy Code

Public Property DataSource As Object

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.FontName Property

Chart.FontName Property
[image]

Gets or sets the name of the font for all chart labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string FontName { get; set; }

Visual Basic [image] Copy Code

Public Property FontName As String

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LabelBrush Property

Chart.LabelBrush Property
[image]

Gets or sets the brush for the chart labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush LabelBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBrush As Brush

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LabelFont Property

Chart.LabelFont Property
[image]

Gets or sets the font for the chart labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Font LabelFont { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFont As Font

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendAlignment Property

Chart.LegendAlignment Property
[image]

Gets or sets the alignment of the legend alongside the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public LegendAlignment LegendAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property LegendAlignment As LegendAlignment

Property Value

A member of the LegendAlignment enumeration.

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendBackgroundBrush Property

Chart.LegendBackgroundBrush Property
[image]

Gets or sets the brush for the legend background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush LegendBackgroundBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LegendBackgroundBrush As Brush

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendBorderMargin Property

Chart.LegendBorderMargin Property
[image]

Gets or sets the margin between the legend border and the legend labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float LegendBorderMargin { get; set; }

Visual Basic [image] Copy Code

Public Property LegendBorderMargin As Single

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendBrush Property

Chart.LegendBrush Property
[image]

Gets or sets the brush for drawing the legend labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush LegendBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LegendBrush As Brush

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendFont Property

Chart.LegendFont Property
[image]

Gets or sets the font for the legend labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Font LegendFont { get; set; }

Visual Basic [image] Copy Code

Public Property LegendFont As Font

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendLabels Property

Chart.LegendLabels Property
[image]

Gets or sets the legend labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList LegendLabels { get; set; }

Visual Basic [image] Copy Code

Public Property LegendLabels As IList

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendOffset Property

Chart.LegendOffset Property
[image]

Gets or sets the offset of the legend to the axis labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float LegendOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LegendOffset As Single

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendPen Property

Chart.LegendPen Property
[image]

Gets or sets the pen for the legend outlining and grid.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Pen LegendPen { get; set; }

Visual Basic [image] Copy Code

Public Property LegendPen As Pen

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.LegendPosition Property

Chart.LegendPosition Property
[image]

Gets or sets the position of the legend.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public LegendPosition LegendPosition { get; set; }

Visual Basic [image] Copy Code

Public Property LegendPosition As LegendPosition

Property Value

A member of the LegendPosition enumeration.

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.MasterDetailRelation Property

Chart.MasterDetailRelation Property
[image]

Gets or sets the master detail relation.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string MasterDetailRelation { get; set; }

Visual Basic [image] Copy Code

Public Property MasterDetailRelation As String

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.SubTitleBrush Property

Chart.SubTitleBrush Property
[image]

Gets or sets the brush used for drawing the subtitle.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush SubTitleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property SubTitleBrush As Brush

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.SubTitleFont Property

Chart.SubTitleFont Property
[image]

Gets or sets the font for the subtitle.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Font SubTitleFont { get; set; }

Visual Basic [image] Copy Code

Public Property SubTitleFont As Font

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.SubTitleText Property

Chart.SubTitleText Property
[image]

Gets or sets the text for the subtitle.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string SubTitleText { get; set; }

Visual Basic [image] Copy Code

Public Property SubTitleText As String

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.TitleBrush Property

Chart.TitleBrush Property
[image]

Gets or sets the brush used for drawing the title.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush TitleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TitleBrush As Brush

Property Value

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.TitleFont Property

Chart.TitleFont Property
[image]

Gets or sets the font for the title.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Font TitleFont { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFont As Font

Property Value

A value of type .NET Font class.

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.TitleText Property

Chart.TitleText Property
[image]

Gets or sets the title text.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string TitleText { get; set; }

Visual Basic [image] Copy Code

Public Property TitleText As String

Property Value

A string value.

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Chart.ShowLegend Property

Chart.ShowLegend Property
[image]

Gets or sets a value indicating whether to display the chart legend.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool ShowLegend { get; set; }

Visual Basic [image] Copy Code

Public Property ShowLegend As Boolean

Property Value

A boolean value.

See Also

Chart Members
Chart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper Class

ControlWrapper Class
Remarks See Also
[image]

Represents a wrapper around a System.Windows.Forms.Control that can be added and rendered in a MindFusion.Reporting.Report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class ControlWrapper : ReportItem

Visual Basic [image] Copy Code

Public Class ControlWrapper
Inherits ReportItem

Remarks

The ControlWrapper class provides means to render any System.Windows.Forms.Control in a MindFusion.Reporting report. Instances of this class are automatically created when the user drags a control from the Visual Studio Toolbox palette to the report surface.

The ControlWrapper class relies on the DrawBitmap method of the Control class in order to render the contents of the control to an image. If the underlying control fails to render itself through this method, the control wrapper will not display anything. Because the wrapper class creates an image of the control, rendering in higher resolution devices (such as printers) might suffer from a loss of quality.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.ControlWrapper

See Also

ControlWrapper Members
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper Members

ControlWrapper Members
Constructors Properties
[image]

Represents a wrapper around a System.Windows.Forms.Control that can be added and rendered in a MindFusion.Reporting.Report.

The following tables list the members exposed by the ControlWrapper type.

Public Constructors

Name | Description
ControlWrapper | Initializes a new instance of the ControlWrapper class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Border | Gets or sets the border of the wrapped control.
Control | Gets or sets the System.Windows.Forms.Control wrapped by this instance.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
ScaleDimensions | Gets or sets the design-time scale factor of the control.
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

ControlWrapper Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper Constructor

ControlWrapper Constructor
[image]

Initializes a new instance of the ControlWrapper class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public ControlWrapper ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ControlWrapper Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper Properties

ControlWrapper Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Border | Gets or sets the border of the wrapped control.
Control | Gets or sets the System.Windows.Forms.Control wrapped by this instance.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
ScaleDimensions | Gets or sets the design-time scale factor of the control.
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

ControlWrapper Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper.Border Property

ControlWrapper.Border Property
[image]

Gets or sets the border of the wrapped control.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Border Border { get; set; }

Visual Basic [image] Copy Code

Public Property Border As Border

Property Value

An instance of the Border class specifying the border around the object.

See Also

ControlWrapper Members
ControlWrapper Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper.Control Property

ControlWrapper.Control Property
[image]

Gets or sets the System.Windows.Forms.Control wrapped by this instance.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Control Control { get; set; }

Visual Basic [image] Copy Code

Public Property Control As Control

Property Value

A .NET System.Windows.Forms.Control instance representing the wrapped control.

See Also

ControlWrapper Members
ControlWrapper Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ControlWrapper.ScaleDimensions Property

ControlWrapper.ScaleDimensions Property
[image]

Gets or sets the design-time scale factor of the control.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public SizeF ScaleDimensions { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleDimensions As SizeF

Property Value

A .NET SizeF object specifying the ratio between the device dimensions of the wrapped control and the size of the control on the design surface.

Remarks

This property is not meant to be used directly.

See Also

ControlWrapper Members
ControlWrapper Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange Class

DataRange Class
Remarks See Also
[image]

Represents a report item that provides master detail relation during data-binding.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class DataRange : ReportItem, IItemFactory

Visual Basic [image] Copy Code

Public Class DataRange
Inherits ReportItem
Implements IItemFactory

Remarks

If you want to bind Label, Picture or Canvas objects to a data source, you need to create an object of the DataRange class first and set its DataSource and DataMember properties to the appropriate values. Once this is done, you can add Label, Picture and Canvas objects to this DataRange (as well as any other non-bound report elements) and set their DataField property to the name of the field in the associated data source you want to bind them to. When the report is being processed, a new instance of the DataRange is created for each record in the associated data source. Then the values of the data-bound report elements contained in this data range are obtained from the respective fields in that record.

For more information on data-binding, check the Binding Reports to a Data Source.

Example

The following example illustrates how to data-bind a Label report element through code. The example assumes that dataRange1 and label1 already reference DataRange and Label objects respectively, and that label1 is a child of dataRange1.

C# [image] Copy Code
dataRange1.DataSource = myDataSource;
dataRange1.DataMember = "MyDataMember";

label1.DataField = "MyDataField";
Visual Basic [image] Copy Code

dataRange1.DataSource = myDataSource
dataRange1.DataMember = "MyDataMember"

label1.DataField = "MyDataField"

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.DataRange
MindFusion.Reporting.SideBySideContainer

See Also

DataRange Members
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange Members

DataRange Members
Constructors Properties
[image]

Represents a report item that provides master detail relation during data-binding.

The following tables list the members exposed by the DataRange type.

Public Constructors

Name | Description
DataRange | Initializes a new instance of the DataRange class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
AllowSplit | Gets or sets a value indicating whether this data range contents are allowed to split across several pages.
AlternatingBackground | Gets or sets the brush that will be used to fill the background of the alternating instances of this data range.
AlternatingBorder | Gets or sets the alternating border of this data range.
ArrangeByX | Gets or sets a value indicating whether to attempt to arrange the instances of this data range by the x-axis first.
Background | Gets or sets the brush that will be used to fill the data range background.
Border | Gets or sets the border of this data range.
DataMember | Gets or sets the name of the data member this range is bound to.
DataSource | Gets or sets the data source this range is bound to.
Footer | Gets or sets the footer of this data range.
Header | Gets or sets the header of this data range.
Items | Gets or sets the items contained in the DataRange.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Margin | Gets or sets the margin of this data range, that is, the distance between the edge of this data range and the report elements adjacent to it.
MasterDetailRelation | Gets or sets the master detail relation.
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Repeat | Gets or sets the number of occurrences of this data range.
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange Constructor

DataRange Constructor
[image]

Initializes a new instance of the DataRange class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public DataRange ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange Properties

DataRange Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
AllowSplit | Gets or sets a value indicating whether this data range contents are allowed to split across several pages.
AlternatingBackground | Gets or sets the brush that will be used to fill the background of the alternating instances of this data range.
AlternatingBorder | Gets or sets the alternating border of this data range.
ArrangeByX | Gets or sets a value indicating whether to attempt to arrange the instances of this data range by the x-axis first.
Background | Gets or sets the brush that will be used to fill the data range background.
Border | Gets or sets the border of this data range.
DataMember | Gets or sets the name of the data member this range is bound to.
DataSource | Gets or sets the data source this range is bound to.
Footer | Gets or sets the footer of this data range.
Header | Gets or sets the header of this data range.
Items | Gets or sets the items contained in the DataRange.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Margin | Gets or sets the margin of this data range, that is, the distance between the edge of this data range and the report elements adjacent to it.
MasterDetailRelation | Gets or sets the master detail relation.
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Repeat | Gets or sets the number of occurrences of this data range.
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange.AllowSplit Property

DataRange.AllowSplit Property
[image]

Gets or sets a value indicating whether this data range contents are allowed to split across several pages.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool AllowSplit { get; set; }

Visual Basic [image] Copy Code

Public Property AllowSplit As Boolean

Property Value

true, to enable splitting of this DataRange across pages; false, to attempt to prevent this. The default is true.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange.AlternatingBackground Property

DataRange.AlternatingBackground Property
[image]

Gets or sets the brush that will be used to fill the background of the alternating instances of this data range.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush AlternatingBackground { get; set; }

Visual Basic [image] Copy Code

Public Property AlternatingBackground As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic).

Remarks

The value of this property determines the background of all even instances of this DataRange. If the property value is null (Nothing in Visual Basic), the background of even instances is determined by the Background property.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
Background Property
AlternatingBorder Property


MindFusion.Reporting.DataRange.AlternatingBorder Property

DataRange.AlternatingBorder Property
[image]

Gets or sets the alternating border of this data range.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Border AlternatingBorder { get; set; }

Visual Basic [image] Copy Code

Public Property AlternatingBorder As Border

Property Value

An instance of the Border class. The default is null (Nothing in Visual Basic).

Remarks

The value of this property determines the border of all even instances of this DataRange. If the property value is null (Nothing in Visual Basic), the border of even instances is determined by the Border property.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
Border Property
AlternatingBackground Property


MindFusion.Reporting.DataRange.ArrangeByX Property

DataRange.ArrangeByX Property
[image]

Gets or sets a value indicating whether to attempt to arrange the instances of this data range by the x-axis first.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool ArrangeByX { get; set; }

Visual Basic [image] Copy Code

Public Property ArrangeByX As Boolean

Property Value

true, to attempt to arrange the instances of this DataRange horizontally first; otherwise, false. The default is false.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange.Background Property

DataRange.Background Property
[image]

Gets or sets the brush that will be used to fill the data range background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush Background { get; set; }

Visual Basic [image] Copy Code

Public Property Background As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic), indicating a transparent background.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
AlternatingBackground Property


MindFusion.Reporting.DataRange.Border Property

DataRange.Border Property
[image]

Gets or sets the border of this data range.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Border Border { get; set; }

Visual Basic [image] Copy Code

Public Property Border As Border

Property Value

An instance of the Border class. The default is an empty border.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
AlternatingBorder Property


MindFusion.Reporting.DataRange.DataMember Property

DataRange.DataMember Property
[image]

Gets or sets the name of the data member this range is bound to.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string DataMember { get; set; }

Visual Basic [image] Copy Code

Public Property DataMember As String

Property Value

A string value specifying the name of the data member from the associated data source. The default is an empty string.

Remarks

This property is taken into consideration only when DataSource is specified.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
DataSource Property


MindFusion.Reporting.DataRange.DataSource Property

DataRange.DataSource Property
[image]

Gets or sets the data source this range is bound to.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Object DataSource { get; set; }

Visual Basic [image] Copy Code

Public Property DataSource As Object

Property Value

An object specifying the data source this DataRange is bound to. The default is null (Nothing in Visual Basic), indicating a disconnected data range.

Remarks

The member this data range binds to is specified through the DataMember property.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
DataMember Property


MindFusion.Reporting.DataRange.Footer Property

DataRange.Footer Property
[image]

Gets or sets the footer of this data range.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public DataRangeSection Footer { get; set; }

Visual Basic [image] Copy Code

Public Property Footer As DataRangeSection

Property Value

An instance of the DataRangeSection class representing the footer of this DataRange.

Remarks

You can add items to the footer through its Items property.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
Header Property


MindFusion.Reporting.DataRange.Header Property

DataRange.Header Property
[image]

Gets or sets the header of this data range.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public DataRangeSection Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As DataRangeSection

Property Value

An instance of the DataRangeSection class representing the header of this DataRange.

Remarks

You can add items to the header through its Items property.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace
Footer Property


MindFusion.Reporting.DataRange.Items Property

DataRange.Items Property
[image]

Gets or sets the items contained in the DataRange.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList<ReportItem> Items { get; set; }

Visual Basic [image] Copy Code

Public Property Items As IList(Of ReportItem)

Property Value

An instance of a IList(ReportItem) class with the report items contained in the DataRange.

Remarks

This collection does not include the items contained in the header or footer of the data range. To access these, use the Items property of the DataRangeSection object returned from the Header or Footer property of the data range respectively.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange.Margin Property

DataRange.Margin Property
[image]

Gets or sets the margin of this data range, that is, the distance between the edge of this data range and the report elements adjacent to it.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Margins Margin { get; set; }

Visual Basic [image] Copy Code

Public Property Margin As Margins

Property Value

An instance of the Margins class. The default is a Margins object with all sides set to 0.

Remarks

This property is particularly useful when you want to specify spacing between the adjacent instances of a DataRange.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange.MasterDetailRelation Property

DataRange.MasterDetailRelation Property
[image]

Gets or sets the master detail relation.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string MasterDetailRelation { get; set; }

Visual Basic [image] Copy Code

Public Property MasterDetailRelation As String

Property Value

A string value specifying the name of the master detail relationship. The default is an empty string.

Remarks

This property is used to establish a master detail relationship between embedded data ranges. For extensive information on how to perform data-binding and master detail relations in particular, visit Binding Reports to a Data Source.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRange.Repeat Property

DataRange.Repeat Property
[image]

Gets or sets the number of occurrences of this data range.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public int Repeat { get; set; }

Visual Basic [image] Copy Code

Public Property Repeat As Integer

Property Value

A positive integer value specifying the number of occurrences.

Remarks

This property is only valid for disconnected data ranges. It specifies the number of instances of this data range in the final layout of the containing report.

Note

The number of instances of data-bound data ranges depends on the data the data range is bound to.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRangeSection Class

DataRangeSection Class
Remarks See Also
[image]

Represents a data range header or footer.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class DataRangeSection : ItemContainer

Visual Basic [image] Copy Code

Public Class DataRangeSection
Inherits ItemContainer

Remarks

When working with the MindFusion.Reporting Designer you don't have to worry about creating instances of this class and assigning them to the appropriate DataRange properties.

If you want to create a header or footer for a DataRange object through code, you have to instantiate from this class and assign the instance to the Header or Footer property of the DataRange object respectively. You can add items to the header or footer through its Items property.

Example

The following example demonstrates how to create a header for an existing DataRange object:

C# [image] Copy Code

DataRangeSection header = new DataRangeSection();

Label headerLabel = new Label();
headerLabel.Text = "Header Text";

header.Items.Add(headerLabel);

dataRange1.Header = header;

Visual Basic [image] Copy Code

Dim header As New DataRangeSection()

Dim headerLabel As New Label()
headerLabel.Text = "Header Text"

header.Items.Add(headerLabel)

dataRange1.Header = header

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.ItemContainer
MindFusion.Reporting.DataRangeSection

See Also

DataRangeSection Members
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRangeSection Members

DataRangeSection Members
Constructors Properties
[image]

Represents a data range header or footer.

The following tables list the members exposed by the DataRangeSection type.

Public Constructors

Name | Description
DataRangeSection | Overloaded.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Background | Gets or sets the brush that will be used to fill the container's background. (Inherited from ItemContainer.)
Border | Gets or sets the border of this container. (Inherited from ItemContainer.)
Bounds | Gets the bounding rectangle of this container. (Inherited from ItemContainer.)
Items | Gets or sets the report items contained in this container. (Inherited from ItemContainer.)
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

DataRangeSection Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRangeSection Constructor

DataRangeSection Constructor
[image]

Overload List

Name | Description
DataRangeSection () | Initializes a new instance of the DataRangeSection class.
DataRangeSection (DataRangeSection) | Initializes a new instance of the DataRangeSection class with the specified DataRangeSection as a prototype.

See Also

DataRangeSection Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRangeSection Constructor ()

DataRangeSection Constructor ()
See Also
[image]

Initializes a new instance of the DataRangeSection class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public DataRangeSection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DataRangeSection Constructor Overload List
DataRangeSection Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DataRangeSection Constructor (DataRangeSection)

DataRangeSection Constructor (DataRangeSection)
See Also
[image]

Initializes a new instance of the DataRangeSection class with the specified DataRangeSection as a prototype.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public DataRangeSection (
DataRangeSection prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As DataRangeSection _
)

Parameters

prototype

See Also

DataRangeSection Constructor Overload List
DataRangeSection Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Structure

Dimension Structure
[image]

Stores an ordered pair of floating-point numbers, typically the width and height of an object.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public struct Dimension

Visual Basic [image] Copy Code

Public Structure Dimension

See Also

Dimension Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Members

Dimension Members
Constructors Fields Properties Methods
[image]

Stores an ordered pair of floating-point numbers, typically the width and height of an object.

The following tables list the members exposed by the Dimension type.

Public Constructors

Name | Description
Dimension | Overloaded. Initializes a new instance of the Dimension stucture.

Public Fields

Name | Description
Empty | An empty instance of the Dimension structure.

Public Properties

Name | Description
Height | Gets or sets the vertical component of this Dimension.
HeightUnit | Gets or sets the vertical units of measure of this Dimension.
IsEmpty | Gets a value indicating whether this Dimension has zero width and height.
Width | Gets or sets the horizontal component of this Dimension.
WidthUnit | Gets or sets the horizontal units of measure of this Dimension.

Public Methods

Name | Description
Add | Adds the width and height of one Dimension structure to the width and height of another Dimension structure.
Equals | Determines if two Dimension structures have the same height and width.
GetHashCode | Returns a hash code for this Dimension structure.
Subtract | Subtracts the width and height of one Dimension structure from the width and height of another Dimensions structure.
ToLocation | Converts this Dimension to a Location.
ToString | Creates a human-readable string that represents this Dimension.

See Also

Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Fields

Dimension Fields
[image]

Public Fields

Name | Description
Empty | An empty instance of the Dimension structure.

See Also

Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.Empty Field

Dimension.Empty Field
[image]

An empty instance of the Dimension structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public static readonly Dimension Empty

Visual Basic [image] Copy Code

Public Shared ReadOnly Empty As Dimension

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Constructor

Dimension Constructor
[image]

Initializes a new instance of the Dimension stucture.

Overload List

Name | Description
Dimension (Dimension) | Initializes a new instance of the Dimension structure from the specified Dimension.
Dimension (Location) | Initializes a new instance of the Dimension structure from the specified Location.
Dimension (Single, MeasureUnit, Single, MeasureUnit) | Initializes a new instance of the Dimension structure.
Dimension (Single, Single) | Initializes a new instance of the Dimension structure with the specified width and height.

See Also

Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Constructor (Dimension)

Dimension Constructor (Dimension)
See Also
[image]

Initializes a new instance of the Dimension structure from the specified Dimension.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Dimension (
Dimension size
)

Visual Basic [image] Copy Code

Public New ( _
size As Dimension _
)

Parameters

size

The Dimension from which to initialize the new object.

See Also

Dimension Constructor Overload List
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Constructor (Location)

Dimension Constructor (Location)
See Also
[image]

Initializes a new instance of the Dimension structure from the specified Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Dimension (
Location location
)

Visual Basic [image] Copy Code

Public New ( _
location As Location _
)

Parameters

location
The Location from which to initialize the new object.

See Also

Dimension Constructor Overload List
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Constructor (Single, MeasureUnit, Single, MeasureUnit)

Dimension Constructor (Single, MeasureUnit, Single, MeasureUnit)
See Also
[image]

Initializes a new instance of the Dimension structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Dimension (
float width,
MeasureUnit widthUnit,
float height,
MeasureUnit heightUnit
)

Visual Basic [image] Copy Code

Public New ( _
width As Single, _
widthUnit As MeasureUnit, _
height As Single, _
heightUnit As MeasureUnit _
)

Parameters

width
The width component of the new Dimension.
widthUnit
The width unit component of the new Dimension.
height
The height component of the new Dimension.
heightUnit
The height unit component of the new Dimension.

See Also

Dimension Constructor Overload List
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Constructor (Single, Single)

Dimension Constructor (Single, Single)
See Also
[image]

Initializes a new instance of the Dimension structure with the specified width and height.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Dimension (
float width,
float height
)

Visual Basic [image] Copy Code

Public New ( _
width As Single, _
height As Single _
)

Parameters

width
The width component of the new Dimension.
height
The height component of the new Dimension.

See Also

Dimension Constructor Overload List
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Methods

Dimension Methods
[image]

Public Methods

Name | Description
Add | Adds the width and height of one Dimension structure to the width and height of another Dimension structure.
Equals | Determines if two Dimension structures have the same height and width.
GetHashCode | Returns a hash code for this Dimension structure.
Subtract | Subtracts the width and height of one Dimension structure from the width and height of another Dimensions structure.
ToLocation | Converts this Dimension to a Location.
ToString | Creates a human-readable string that represents this Dimension.

See Also

Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.Add Method

Dimension.Add Method
[image]

Adds the width and height of one Dimension structure to the width and height of another Dimension structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public static Dimension Add (
Dimension dimension1,
Dimension dimension2
)

Visual Basic [image] Copy Code

Public Shared Function Add ( _
dimension1 As Dimension, _
dimension2 As Dimension _
) As Dimension

Parameters

dimension1
The first Dimension to add.
dimension2
The second Dimension to add.

Return Value

A Dimension structure that is the result of the addition operation. The WidthUnit and HeightUnit of the result are both set to Document.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.Equals Method

Dimension.Equals Method
[image]

Determines if two Dimension structures have the same height and width.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj
The System.Object to test.

Return Value

true if obj is a Dimension and has the same width, height and units as this Dimension; otherwise, false.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.GetHashCode Method

Dimension.GetHashCode Method
[image]

Returns a hash code for this Dimension structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

An integer value that specifies a hash value for this Dimension structure.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.Subtract Method

Dimension.Subtract Method
[image]

Subtracts the width and height of one Dimension structure from the width and height of another Dimensions structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public static Dimension Subtract (
Dimension dimension1,
Dimension dimension2
)

Visual Basic [image] Copy Code

Public Shared Function Subtract ( _
dimension1 As Dimension, _
dimension2 As Dimension _
) As Dimension

Parameters

dimension1
The Dimension structure on the left side of the subtraction operator.
dimension2
The Dimension structure on the right side of the subtraction operator.

Return Value

The Dimension that is a result of the subtraction operation. The WidthUnit and HeightUnit of the result are both set to Document.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.ToLocation Method

Dimension.ToLocation Method
[image]

Converts this Dimension to a Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Location ToLocation ()

Visual Basic [image] Copy Code

Public Function ToLocation () As Location

Return Value

An instance of the Location structure to which this Dimension converts.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.ToString Method

Dimension.ToString Method
[image]

Creates a human-readable string that represents this Dimension.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string that represents this Dimension.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension Properties

Dimension Properties
[image]

Public Properties

Name | Description
Height | Gets or sets the vertical component of this Dimension.
HeightUnit | Gets or sets the vertical units of measure of this Dimension.
IsEmpty | Gets a value indicating whether this Dimension has zero width and height.
Width | Gets or sets the horizontal component of this Dimension.
WidthUnit | Gets or sets the horizontal units of measure of this Dimension.

See Also

Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.Height Property

Dimension.Height Property
[image]

Gets or sets the vertical component of this Dimension.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Single

Property Value

A float number specifying the vertical component of the Dimension, in the units of measure specified by HeightUnit.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace
HeightUnit Property
Width Property


MindFusion.Reporting.Dimension.HeightUnit Property

Dimension.HeightUnit Property
[image]

Gets or sets the vertical units of measure of this Dimension.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public MeasureUnit HeightUnit { get; set; }

Visual Basic [image] Copy Code

Public Property HeightUnit As MeasureUnit

Property Value

A member of the MeasureUnit enumeration specifying the units of measure of the Height component of this Dimension.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace
WidthUnit Property
Height Property


MindFusion.Reporting.Dimension.IsEmpty Property

Dimension.IsEmpty Property
[image]

Gets a value indicating whether this Dimension has zero width and height.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

true if both Width and Height of the Dimension are 0; otherwise, false.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Dimension.Width Property

Dimension.Width Property
[image]

Gets or sets the horizontal component of this Dimension.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Single

Property Value

A float number specifying the horizontal component of the Dimension, in the units of measure specified by WidthUnit.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace
WidthUnit Property
Height Property


MindFusion.Reporting.Dimension.WidthUnit Property

Dimension.WidthUnit Property
[image]

Gets or sets the horizontal units of measure of this Dimension.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public MeasureUnit WidthUnit { get; set; }

Visual Basic [image] Copy Code

Public Property WidthUnit As MeasureUnit

Property Value

A member of the MeasureUnit enumeration specifying the units of measure of the Width component of this Dimension.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting Namespace
HeightUnit Property
Width Property


MindFusion.Reporting.DrawCanvasEventArgs Class

DrawCanvasEventArgs Class
Remarks See Also
[image]

Contains the arguments passed to handlers of the RenderContents event of the Canvas class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class DrawCanvasEventArgs : DrawEventArgs

Visual Basic [image] Copy Code

Public Class DrawCanvasEventArgs
Inherits DrawEventArgs

Remarks

The DrawCanvasEventArgs class exposes several properties, which provide contextual information when rendering Canvas objects, in addition to the Graphics property derived from the DrawEventArgs class. The DataValue property supplies the database value associated with the drawn Canvas, if the canvas is data-bound. PageIndex and PageCount specify the current index and total number of pages in the report. RangeIndex and RangeCount specify the current index and total number of data range instances, if the Canvas is contained in a DataRange.

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Reporting.DrawEventArgs
MindFusion.Reporting.DrawCanvasEventArgs

See Also

DrawCanvasEventArgs Members
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs Members

DrawCanvasEventArgs Members
Properties Methods
[image]

Contains the arguments passed to handlers of the RenderContents event of the Canvas class.

The following tables list the members exposed by the DrawCanvasEventArgs type.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the item being rendered. (Inherited from DrawEventArgs.)
DataValue | Gets the object assigned to the target data-bound canvas. If the canvas is not data-bound, this value is null (Nothing in Visual Basic).
Graphics | Gets the IGraphics object to use for rendering. (Inherited from DrawEventArgs.)
PageCount | Gets the total number of pages in the report.
PageIndex | Gets the index of the current page.
RangeCount | Gets the total number of instances of the data range, which contains the target Canvas (if any).
RangeIndex | Gets the index of the data range instance, which contains the target Canvas (if any).

Public Methods

Name | Description
DrawBorder | Renders the specified border around the specified rectangle in the underlying graphics. (Inherited from DrawEventArgs.)

See Also

DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs Properties

DrawCanvasEventArgs Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the item being rendered. (Inherited from DrawEventArgs.)
DataValue | Gets the object assigned to the target data-bound canvas. If the canvas is not data-bound, this value is null (Nothing in Visual Basic).
Graphics | Gets the IGraphics object to use for rendering. (Inherited from DrawEventArgs.)
PageCount | Gets the total number of pages in the report.
PageIndex | Gets the index of the current page.
RangeCount | Gets the total number of instances of the data range, which contains the target Canvas (if any).
RangeIndex | Gets the index of the data range instance, which contains the target Canvas (if any).

See Also

DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs.DataValue Property

DrawCanvasEventArgs.DataValue Property
[image]

Gets the object assigned to the target data-bound canvas. If the canvas is not data-bound, this value is null (Nothing in Visual Basic).

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Object DataValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DataValue As Object

Property Value

A System.Object representing the value obtained through data-binding.

See Also

DrawCanvasEventArgs Members
DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs.PageCount Property

DrawCanvasEventArgs.PageCount Property
[image]

Gets the total number of pages in the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public int PageCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PageCount As Integer

Property Value

An integer specifying the number of pages in the report.

See Also

DrawCanvasEventArgs Members
DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs.PageIndex Property

DrawCanvasEventArgs.PageIndex Property
[image]

Gets the index of the current page.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public int PageIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PageIndex As Integer

Property Value

An integer specifying the index of the page on which the target Canvas appears in the final report layout.

See Also

DrawCanvasEventArgs Members
DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs.RangeCount Property

DrawCanvasEventArgs.RangeCount Property
[image]

Gets the total number of instances of the data range, which contains the target Canvas (if any).

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public int RangeCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RangeCount As Integer

Property Value

An integer specifying the total number of instances in the final report layout of the DataRange, which contains the target Canvas. If the canvas is not contained in a DataRange, the value of this property is undefined.

See Also

DrawCanvasEventArgs Members
DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawCanvasEventArgs.RangeIndex Property

DrawCanvasEventArgs.RangeIndex Property
[image]

Gets the index of the data range instance, which contains the target Canvas (if any).

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public int RangeIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RangeIndex As Integer

Property Value

An integer specifying the index in the final report layout of the DataRange instance, which contains the target Canvas. If the canvas is not contained in a DataRange, the value of this property is undefined.

See Also

DrawCanvasEventArgs Members
DrawCanvasEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext Class

DrawContext Class
Remarks See Also
[image]

Provides contextual information when drawing report items.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class DrawContext

Visual Basic [image] Copy Code

Public Class DrawContext

Remarks

Instances of this class are passed as arguments to the DrawPage method of the ReportLayout.

Example

The following example layouts a report and draws its last page. The layout assumes that report1 is a variable identifying an existing report and that graphics identifies an instance of IGraphics.

C# [image] Copy Code

ReportLayout layout = report1.Layout(new SizeF(210, 297),
new Margins(20), PageOrientation.Portrait);
DrawContext context = new DrawContext(report1);

report1.DrawPage(graphics, layout.PageCount - 1, context);

Inheritance Hierarchy

System.Object
MindFusion.Reporting.DrawContext

See Also

DrawContext Members
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext Members

DrawContext Members
Constructors Properties
[image]

Provides contextual information when drawing report items.

The following tables list the members exposed by the DrawContext type.

Public Constructors

Name | Description
DrawContext | Initializes a new instance of the DrawContext class.

Public Properties

Name | Description
FontName | Gets the font name of the closest parent.
FontSize | Gets the font size of the closest parent.
FontStyle | Gets the font style of the closest parent.
Report | Gets the report being drawn.
Scale | Gets or sets the zoom factor of the drawing.

See Also

DrawContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext Constructor

DrawContext Constructor
[image]

Initializes a new instance of the DrawContext class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public DrawContext (
Report report
)

Visual Basic [image] Copy Code

Public New ( _
report As Report _
)

Parameters

report

The Report object whose items will be drawn using this DrawContext.

See Also

DrawContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext Properties

DrawContext Properties
[image]

Public Properties

Name | Description
FontName | Gets the font name of the closest parent.
FontSize | Gets the font size of the closest parent.
FontStyle | Gets the font style of the closest parent.
Report | Gets the report being drawn.
Scale | Gets or sets the zoom factor of the drawing.

See Also

DrawContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext.Report Property

DrawContext.Report Property
[image]

Gets the report being drawn.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Report Report { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Report As Report

Property Value

A reference to the Report that is being drawn.

See Also

DrawContext Members
DrawContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext.Scale Property

DrawContext.Scale Property
[image]

Gets or sets the zoom factor of the drawing.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Single

Property Value

A float value indicating a scale factor of the drawing. The default is 1.

Remarks

This value is used when rendering Picture elements in a Graphics with applied scale transformation.

See Also

DrawContext Members
DrawContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext.FontName Property

DrawContext.FontName Property
[image]

Gets the font name of the closest parent.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string FontName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FontName As String

Property Value

A string value.

See Also

DrawContext Members
DrawContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext.FontSize Property

DrawContext.FontSize Property
[image]

Gets the font size of the closest parent.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float FontSize { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FontSize As Single

Property Value

A float value.

See Also

DrawContext Members
DrawContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawContext.FontStyle Property

DrawContext.FontStyle Property
[image]

Gets the font style of the closest parent.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FontStyle As FontStyle

Property Value

A member of the FontStyle enumeration.

See Also

DrawContext Members
DrawContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs Class

DrawEventArgs Class
[image]

Provides data for various rendering events.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class DrawEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Reporting.DrawEventArgs
MindFusion.Reporting.DrawCanvasEventArgs

See Also

DrawEventArgs Members
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs Members

DrawEventArgs Members
Properties Methods
[image]

Provides data for various rendering events.

The following tables list the members exposed by the DrawEventArgs type.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the item being rendered.
Graphics | Gets the IGraphics object to use for rendering.

Public Methods

Name | Description
DrawBorder | Renders the specified border around the specified rectangle in the underlying graphics.

See Also

DrawEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs Methods

DrawEventArgs Methods
[image]

Public Methods

Name | Description
DrawBorder | Renders the specified border around the specified rectangle in the underlying graphics.

See Also

DrawEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs.DrawBorder Method

DrawEventArgs.DrawBorder Method
[image]

Renders the specified border around the specified rectangle in the underlying graphics.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public void DrawBorder (
Border border,
RectangleF bounds
)

Visual Basic [image] Copy Code

Public Sub DrawBorder ( _
border As Border, _
bounds As RectangleF _
)

Parameters

border
The Border object to render.
bounds
The RectangleF around which to render a border.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs Properties

DrawEventArgs Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the item being rendered.
Graphics | Gets the IGraphics object to use for rendering.

See Also

DrawEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs.Bounds Property

DrawEventArgs.Bounds Property
[image]

Gets the bounding rectangle of the item being rendered.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public RectangleF Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As RectangleF

Property Value

A .NET RectangleF specifying the bounding rectangle of the item being renderd.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.DrawEventArgs.Graphics Property

DrawEventArgs.Graphics Property
[image]

Gets the IGraphics object to use for rendering.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class, implementing the IGraphics interface.

Remarks

When the drawing is performed in a GDI+ graphics, the value of this property is of type GdiGraphics.

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse Class

Ellipse Class
[image]

A report element that draws a simple ellipse.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class Ellipse : ReportItem

Visual Basic [image] Copy Code

Public Class Ellipse
Inherits ReportItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Ellipse

See Also

Ellipse Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse Members

Ellipse Members
Constructors Properties
[image]

A report element that draws a simple ellipse.

The following tables list the members exposed by the Ellipse type.

Public Constructors

Name | Description
Ellipse | Initializes a new instance of the Ellipse class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Color | Gets or sets the color of the ellipse outline.
DashStyle | Gets or sets the dash style of the ellipse outline.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)
Width | Gets or sets the width of the ellipse outline.

See Also

Ellipse Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse Constructor

Ellipse Constructor
[image]

Initializes a new instance of the Ellipse class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Ellipse ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Ellipse Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse Properties

Ellipse Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Color | Gets or sets the color of the ellipse outline.
DashStyle | Gets or sets the dash style of the ellipse outline.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)
Width | Gets or sets the width of the ellipse outline.

See Also

Ellipse Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse.Color Property

Ellipse.Color Property
[image]

Gets or sets the color of the ellipse outline.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

A .NET Color object specifying the color of the ellipse outline. The default is the WindowText system color.

See Also

Ellipse Members
Ellipse Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse.DashStyle Property

Ellipse.DashStyle Property
[image]

Gets or sets the dash style of the ellipse outline.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public DashStyle DashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration specifying the style of the ellipse outline. The default is Solid.

See Also

Ellipse Members
Ellipse Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Ellipse.Width Property

Ellipse.Width Property
[image]

Gets or sets the width of the ellipse outline.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Single

Property Value

A float value indicating the thickness of the ellipse outline. The default is 1. Specify 0 for the value of this property to indicate a hairline thickness.

See Also

Ellipse Members
Ellipse Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer Class

ItemContainer Class
Remarks See Also
[image]

Represents a base class for report items that can serve as containers for other report items, such as DataRange.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class ItemContainer : ReportItem

Visual Basic [image] Copy Code

Public Class ItemContainer
Inherits ReportItem

Remarks

The items in an item container can be accessed through its Items property.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.ItemContainer
MindFusion.Reporting.DataRangeSection
MindFusion.Reporting.PageSection

See Also

ItemContainer Members
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer Members

ItemContainer Members
Constructors Properties
[image]

Represents a base class for report items that can serve as containers for other report items, such as DataRange.

The following tables list the members exposed by the ItemContainer type.

Public Constructors

Name | Description
ItemContainer | Initializes a new instance of the ItemContainer class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Background | Gets or sets the brush that will be used to fill the container's background.
Border | Gets or sets the border of this container.
Bounds | Gets the bounding rectangle of this container.
Items | Gets or sets the report items contained in this container.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer Constructor

ItemContainer Constructor
[image]

Initializes a new instance of the ItemContainer class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public ItemContainer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer Properties

ItemContainer Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Background | Gets or sets the brush that will be used to fill the container's background.
Border | Gets or sets the border of this container.
Bounds | Gets the bounding rectangle of this container.
Items | Gets or sets the report items contained in this container.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer.Background Property

ItemContainer.Background Property
[image]

Gets or sets the brush that will be used to fill the container's background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush Background { get; set; }

Visual Basic [image] Copy Code

Public Property Background As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic) indicating a transparent background.

See Also

ItemContainer Members
ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer.Border Property

ItemContainer.Border Property
[image]

Gets or sets the border of this container.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Border Border { get; set; }

Visual Basic [image] Copy Code

Public Property Border As Border

Property Value

An instance of the Border class. The default value is an empty Border object.

See Also

ItemContainer Members
ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer.Bounds Property

ItemContainer.Bounds Property
[image]

Gets the bounding rectangle of this container.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public RectangleF Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As RectangleF

Property Value

A .NET RectangleF object specifying the bounds of the container relative to its parent.

See Also

ItemContainer Members
ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ItemContainer.Items Property

ItemContainer.Items Property
[image]

Gets or sets the report items contained in this container.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList<ReportItem> Items { get; set; }

Visual Basic [image] Copy Code

Public Property Items As IList(Of ReportItem)

Property Value

An instance of an IList(ReportItem) class containing all items in the container.

See Also

ItemContainer Members
ItemContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label Class

Label Class
Remarks See Also
[image]

A report element that draws a static text.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class Label : ReportItem, IVirtualPropertyProvider

Visual Basic [image] Copy Code

Public Class Label
Inherits ReportItem
Implements IVirtualPropertyProvider

Remarks

Usually, labels display static text. In this case, simply assign the text to be displayed to their Text property.

Alternatively, the labels can be bound to fields in a data source. To do this, the label must be placed in a data-bound DataRange object and its DataField property must be set to the name of the respective data field. For more information regarding this, check the Report Items and Binding Reports to a Data Source topics.

Finally, the text of the label may contained the so-called expressions. The expressions within the label's text are evaluated when the report is run and the result of the evaluation is displayed by the label. Extensive information about how to integrate expressions in the text of labels can be found in the Using Expressions in Reports topic.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Label

See Also

Report Items
Label Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Label Members

Label Members
Constructors Properties
[image]

A report element that draws a static text.

The following tables list the members exposed by the Label type.

Public Constructors

Name | Description
Label | Initializes a new instance of the Label class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Alignment | Gets or sets the alignment of the text displayed in the label.
AutoSize | Gets or sets a value indicating whether the label automatically resizes to prevent its text from trimming.
Background | Gets or sets the brush that will be used to fill the label background.
Border | Gets or sets the border of this label.
Color | Gets or sets the color that will be used to draw the label.
DataField | Gets or sets the name of the data field to bind to.
Font | Gets or sets the label font.
FontName | Gets or sets the default font in the report.
FontSize | Gets or sets the font size of the label.
FontStyle | Gets or sets the font style of the label.
Format | Gets or sets the format of the text displayed in the label.
LineAlignment | Gets or sets the vertical alignment of the text displayed in the label.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
Padding | Gets or sets the padding of the label text.
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
RotationAngle | Gets or sets the rotation angle of the label text.
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
Text | Gets or sets the label text.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label Constructor

Label Constructor
[image]

Initializes a new instance of the Label class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Label ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label Properties

Label Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Alignment | Gets or sets the alignment of the text displayed in the label.
AutoSize | Gets or sets a value indicating whether the label automatically resizes to prevent its text from trimming.
Background | Gets or sets the brush that will be used to fill the label background.
Border | Gets or sets the border of this label.
Color | Gets or sets the color that will be used to draw the label.
DataField | Gets or sets the name of the data field to bind to.
Font | Gets or sets the label font.
FontName | Gets or sets the default font in the report.
FontSize | Gets or sets the font size of the label.
FontStyle | Gets or sets the font style of the label.
Format | Gets or sets the format of the text displayed in the label.
LineAlignment | Gets or sets the vertical alignment of the text displayed in the label.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
Padding | Gets or sets the padding of the label text.
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
RotationAngle | Gets or sets the rotation angle of the label text.
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
Text | Gets or sets the label text.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Alignment Property

Label.Alignment Property
[image]

Gets or sets the alignment of the text displayed in the label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public StringAlignment Alignment { get; set; }

Visual Basic [image] Copy Code

Public Property Alignment As StringAlignment

Property Value

A member of the .NET StringAlignment enumeration indicating the horizontal alignment of the text. The default is Near.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.AutoSize Property

Label.AutoSize Property
[image]

Gets or sets a value indicating whether the label automatically resizes to prevent its text from trimming.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool AutoSize { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSize As Boolean

Property Value

true to automatically resize the label based on its content; otherwise, false.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Background Property

Label.Background Property
[image]

Gets or sets the brush that will be used to fill the label background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush Background { get; set; }

Visual Basic [image] Copy Code

Public Property Background As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic) indicating a transparent background.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Border Property

Label.Border Property
[image]

Gets or sets the border of this label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Border Border { get; set; }

Visual Basic [image] Copy Code

Public Property Border As Border

Property Value

An instance of the Border class. The default value is an empty Border object.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Color Property

Label.Color Property
[image]

Gets or sets the color that will be used to draw the label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

A .NET Color object specifying the color of the label's text. The default is Black.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.DataField Property

Label.DataField Property
[image]

Gets or sets the name of the data field to bind to.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string DataField { get; set; }

Visual Basic [image] Copy Code

Public Property DataField As String

Property Value

A string specifying the data field this label is bound to. The default is an empty string indicating that the label is not data-bound.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Font Property

Label.Font Property
[image]

Gets or sets the label font.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Font Font { get; set; }

Visual Basic [image] Copy Code

Public Property Font As Font

Property Value

A .NET Font object specifying the font of the label's text. The default value is null (Nothing in Visual Basic).

Remarks

When this property is null (Nothing in Visual Basic) the font of the label's text is determined by the value of the Font property of the containing Report.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Format Property

Label.Format Property
[image]

Gets or sets the format of the text displayed in the label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public StringFormat Format { get; set; }

Visual Basic [image] Copy Code

Public Property Format As StringFormat

Property Value

A member of the .NET StringAlignment enumeration.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.LineAlignment Property

Label.LineAlignment Property
[image]

Gets or sets the vertical alignment of the text displayed in the label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public StringAlignment LineAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property LineAlignment As StringAlignment

Property Value

A member of the .NET StringAlignment enumeration indicating the vertical alignment of the text. The default is Center.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Padding Property

Label.Padding Property
[image]

Gets or sets the padding of the label text.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Margins Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Margins

Property Value

An instance of the Margins class specifying the distance between the label's outline and text. The default is a Margins object with all sides set to 0.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.RotationAngle Property

Label.RotationAngle Property
[image]

Gets or sets the rotation angle of the label text.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float RotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property RotationAngle As Single

Property Value

A float value specifying the rotation angle of the label text, in degrees.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.Text Property

Label.Text Property
[image]

Gets or sets the label text.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string representing the label's text.

Remarks

This property is ignored if the label is data-bound, that is, its DataField property is not empty. The text of the label in this case is obtained from the data source.

Expressions

The text of the label can contain expressions embedded in it. To embed an expression, simply encompass it in square brackets - '[' and ']'. The following example embeds the expression Now() in the text of a label. The example assumes that label1 is a variable identifying an existing label.

C# [image] Copy Code

label1.Text = "The time now is [Now()]";

Visual Basic [image] Copy Code

label1.Text = "The time now is [Now()]"

For more information about expressions in general, check Expressions. For more information on how to use expressions in label texts, check Using Expressions in Reports.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.FontName Property

Label.FontName Property
[image]

Gets or sets the default font in the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string FontName { get; set; }

Visual Basic [image] Copy Code

Public Property FontName As String

Property Value

A string value or null (Nothing in Visual Basic) to use the report font.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.FontSize Property

Label.FontSize Property
[image]

Gets or sets the font size of the label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Nullable<Single> FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Nullable(Of Single)

Property Value

A float value or null (Nothing in Visual Basic) to use the report font size.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Label.FontStyle Property

Label.FontStyle Property
[image]

Gets or sets the font style of the label.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Nullable<FontStyle> FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As Nullable(Of FontStyle)

Property Value

A member of the FontStyle enumeration or null (Nothing in Visual Basic) to use the report font style.

See Also

Label Members
Label Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LabelType Enumeration

LabelType Enumeration
[image]

Specifies the type of labels drawn at chart elements.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public enum LabelType

Visual Basic [image] Copy Code

Public Enum LabelType

Members

Member name | Description
Data | The labels represent the data values.
Percents | Percentage value for numerical data is drawn.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.LegendAlignment Enumeration

LegendAlignment Enumeration
[image]

Specifies the alignment of the chart legend.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public enum LegendAlignment

Visual Basic [image] Copy Code

Public Enum LegendAlignment

Members

Member name | Description
Begin | The legend is drawn at the beginning of the side.
Center | The legend is drawn at the center of the side.
End | The legend is drawn at the far end of the side.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.LegendPosition Enumeration

LegendPosition Enumeration
[image]

Specifies the position of the chart legend.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public enum LegendPosition

Visual Basic [image] Copy Code

Public Enum LegendPosition

Members

Member name | Description
Bottom | Indicates that the legend is positioned to the bottom.
Left | Indicates that the legend is positioned to the left.
Right | Indicates that the legend is positioned to the right.
Top | Indicates that the legend is positioned to the top.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.Line Class

Line Class
[image]

A report element that draws a simple line.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class Line : ReportItem

Visual Basic [image] Copy Code

Public Class Line
Inherits ReportItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Line

See Also

Line Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Line Members

Line Members
Constructors Properties
[image]

A report element that draws a simple line.

The following tables list the members exposed by the Line type.

Public Constructors

Name | Description
Line | Initializes a new instance of the Line class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Color | Gets or sets the color that will be used to draw the line.
DashStyle | Gets or sets the dash style of the line.
EndPoint | Gets or sets the end point of the line.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
StartPoint | The start point of the line.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)
Width | Gets or sets the width of the line.

See Also

Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line Constructor

Line Constructor
[image]

Initializes a new instance of the Line class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Line ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line Properties

Line Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Color | Gets or sets the color that will be used to draw the line.
DashStyle | Gets or sets the dash style of the line.
EndPoint | Gets or sets the end point of the line.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
StartPoint | The start point of the line.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)
Width | Gets or sets the width of the line.

See Also

Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line.Color Property

Line.Color Property
[image]

Gets or sets the color that will be used to draw the line.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

A .NET Color object specifying the color of the line. The default is the WindowText system color.

See Also

Line Members
Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line.DashStyle Property

Line.DashStyle Property
[image]

Gets or sets the dash style of the line.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public DashStyle DashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration specifying the style of the line. The default is Solid.

See Also

Line Members
Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line.EndPoint Property

Line.EndPoint Property
[image]

Gets or sets the end point of the line.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Location EndPoint { get; set; }

Visual Basic [image] Copy Code

Public Property EndPoint As Location

Property Value

A Location object specifying the end point of the line.

See Also

Line Members
Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line.StartPoint Property

Line.StartPoint Property
[image]

The start point of the line.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Location StartPoint { get; set; }

Visual Basic [image] Copy Code

Public Property StartPoint As Location

Property Value

A Location object specifying the start point of the line.

See Also

Line Members
Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Line.Width Property

Line.Width Property
[image]

Gets or sets the width of the line.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Single

Property Value

A float value indicating the thickness of the line. The default is 1. Specify 0 for the value of this property to indicate a hairline thickness.

See Also

Line Members
Line Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart Class

LineChart Class
[image]

Represents a report item that can display line charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class LineChart : AxesChart, IVirtualPropertyProvider

Visual Basic [image] Copy Code

Public Class LineChart
Inherits AxesChart
Implements IVirtualPropertyProvider

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Chart
MindFusion.Reporting.AxesChart
MindFusion.Reporting.LineChart

See Also

LineChart Members
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart Members

LineChart Members
Constructors Properties
[image]

Represents a report item that can display line charts.

The following tables list the members exposed by the LineChart type.

Public Constructors

Name | Description
LineChart | Initializes a new instance of the LineChart class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
AltGridBrush | Gets or sets the brush used for filling even grid stripes. (Inherited from AxesChart.)
AxisPen | Gets or sets the pen used for drawing the chart axis. (Inherited from AxesChart.)
BackgroundBrush | Gets or sets the brush that fills the chart background. (Inherited from Chart.)
Border | Gets or sets the border of this chart. (Inherited from Chart.)
ChartBrushes | Gets or sets the brushes for the chart. (Inherited from Chart.)
ChartPens | Gets or sets the pens for the chart. (Inherited from Chart.)
Curve | Gets or sets a value indicating whether lines are drawn as curves.
DataMember | Gets or sets from which member in the data source data is read. (Inherited from Chart.)
DataSource | Gets or sets the object, from which chart data is retrieved. (Inherited from Chart.)
FontName | Gets or sets the name of the font for all chart labels. (Inherited from Chart.)
GridBrush | Gets or sets the brush used for filling odd grid stripes. (Inherited from AxesChart.)
GridPen | Gets or sets the pen for drawing grid lines. (Inherited from AxesChart.)
GridType | Gets or sets the type of the grid. (Inherited from AxesChart.)
Horizontal | Gets or sets the orientation of the chart. (Inherited from AxesChart.)
LabelBrush | Gets or sets the brush for the chart labels. (Inherited from Chart.)
LabelFont | Gets or sets the font for the chart labels. (Inherited from Chart.)
Labels | Gets or sets custom labels drawn at chart data points.
LabelsFields | Gets or sets the database columns, from which custom text for data point labels is retrieved.
LegendAlignment | Gets or sets the alignment of the legend alongside the chart. (Inherited from Chart.)
LegendBackgroundBrush | Gets or sets the brush for the legend background. (Inherited from Chart.)
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels. (Inherited from Chart.)
LegendBrush | Gets or sets the brush for drawing the legend labels. (Inherited from Chart.)
LegendFont | Gets or sets the font for the legend labels. (Inherited from Chart.)
LegendLabels | Gets or sets the legend labels. (Inherited from Chart.)
LegendOffset | Gets or sets the offset of the legend to the axis labels. (Inherited from Chart.)
LegendPen | Gets or sets the pen for the legend outlining and grid. (Inherited from Chart.)
LegendPosition | Gets or sets the position of the legend. (Inherited from Chart.)
LineType | Gets or sets the type of the line chart.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
MasterDetailRelation | Gets or sets the master detail relation. (Inherited from Chart.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
PlotAreaBrush | Gets or sets the brush used for filling the plot area of the chart. (Inherited from AxesChart.)
PlotAreaMargins | Gets or sets the margins of the chart plot area. (Inherited from AxesChart.)
PlotAreaOutlinePen | Gets or sets the pen for outlining the plot area. (Inherited from AxesChart.)
ShowLegend | Gets or sets a value indicating whether to display the chart legend. (Inherited from Chart.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
Stacked | Gets or sets a value indicating whether multi-series 3D graphics are drawn stacked.
SubTitleBrush | Gets or sets the brush used for drawing the subtitle. (Inherited from Chart.)
SubTitleFont | Gets or sets the font for the subtitle. (Inherited from Chart.)
SubTitleText | Gets or sets the text for the subtitle. (Inherited from Chart.)
TitleBrush | Gets or sets the brush used for drawing the title. (Inherited from Chart.)
TitleFont | Gets or sets the font for the title. (Inherited from Chart.)
TitleText | Gets or sets the title text. (Inherited from Chart.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)
XAxisSettings | Gets or sets the appearance settings for the x-axis. (Inherited from AxesChart.)
XData | Gets or sets the data for calculating the X-coordinates of line charts.
XDataFields | Gets or sets the database columns, from which data for calculating the X-coordinates of charts is retrieved.
XLabels | Gets or sets custom labels for the x-axis. (Inherited from AxesChart.)
XLabelsFields | Gets or sets the database columns from which custom labels for the x-axis are retrieved. (Inherited from AxesChart.)
YAxisSettings | Gets or sets the appearance settings for the y-axis. (Inherited from AxesChart.)
YData | Gets or sets the data for calculating the Y-coordinates of charts.
YDataFields | Gets or sets the database columns, from which data for calculating the Y-coordinates of charts is retrieved.
YLabels | Gets or sets custom labels for the y-axis. (Inherited from AxesChart.)
YLabelsFields | Gets or sets the database columns, from which custom labels for the y-axis are retrieved. (Inherited from AxesChart.)

See Also

LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart Constructor

LineChart Constructor
[image]

Initializes a new instance of the LineChart class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public LineChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart Properties

LineChart Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
AltGridBrush | Gets or sets the brush used for filling even grid stripes. (Inherited from AxesChart.)
AxisPen | Gets or sets the pen used for drawing the chart axis. (Inherited from AxesChart.)
BackgroundBrush | Gets or sets the brush that fills the chart background. (Inherited from Chart.)
Border | Gets or sets the border of this chart. (Inherited from Chart.)
ChartBrushes | Gets or sets the brushes for the chart. (Inherited from Chart.)
ChartPens | Gets or sets the pens for the chart. (Inherited from Chart.)
Curve | Gets or sets a value indicating whether lines are drawn as curves.
DataMember | Gets or sets from which member in the data source data is read. (Inherited from Chart.)
DataSource | Gets or sets the object, from which chart data is retrieved. (Inherited from Chart.)
FontName | Gets or sets the name of the font for all chart labels. (Inherited from Chart.)
GridBrush | Gets or sets the brush used for filling odd grid stripes. (Inherited from AxesChart.)
GridPen | Gets or sets the pen for drawing grid lines. (Inherited from AxesChart.)
GridType | Gets or sets the type of the grid. (Inherited from AxesChart.)
Horizontal | Gets or sets the orientation of the chart. (Inherited from AxesChart.)
LabelBrush | Gets or sets the brush for the chart labels. (Inherited from Chart.)
LabelFont | Gets or sets the font for the chart labels. (Inherited from Chart.)
Labels | Gets or sets custom labels drawn at chart data points.
LabelsFields | Gets or sets the database columns, from which custom text for data point labels is retrieved.
LegendAlignment | Gets or sets the alignment of the legend alongside the chart. (Inherited from Chart.)
LegendBackgroundBrush | Gets or sets the brush for the legend background. (Inherited from Chart.)
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels. (Inherited from Chart.)
LegendBrush | Gets or sets the brush for drawing the legend labels. (Inherited from Chart.)
LegendFont | Gets or sets the font for the legend labels. (Inherited from Chart.)
LegendLabels | Gets or sets the legend labels. (Inherited from Chart.)
LegendOffset | Gets or sets the offset of the legend to the axis labels. (Inherited from Chart.)
LegendPen | Gets or sets the pen for the legend outlining and grid. (Inherited from Chart.)
LegendPosition | Gets or sets the position of the legend. (Inherited from Chart.)
LineType | Gets or sets the type of the line chart.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
MasterDetailRelation | Gets or sets the master detail relation. (Inherited from Chart.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
PlotAreaBrush | Gets or sets the brush used for filling the plot area of the chart. (Inherited from AxesChart.)
PlotAreaMargins | Gets or sets the margins of the chart plot area. (Inherited from AxesChart.)
PlotAreaOutlinePen | Gets or sets the pen for outlining the plot area. (Inherited from AxesChart.)
ShowLegend | Gets or sets a value indicating whether to display the chart legend. (Inherited from Chart.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
Stacked | Gets or sets a value indicating whether multi-series 3D graphics are drawn stacked.
SubTitleBrush | Gets or sets the brush used for drawing the subtitle. (Inherited from Chart.)
SubTitleFont | Gets or sets the font for the subtitle. (Inherited from Chart.)
SubTitleText | Gets or sets the text for the subtitle. (Inherited from Chart.)
TitleBrush | Gets or sets the brush used for drawing the title. (Inherited from Chart.)
TitleFont | Gets or sets the font for the title. (Inherited from Chart.)
TitleText | Gets or sets the title text. (Inherited from Chart.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)
XAxisSettings | Gets or sets the appearance settings for the x-axis. (Inherited from AxesChart.)
XData | Gets or sets the data for calculating the X-coordinates of line charts.
XDataFields | Gets or sets the database columns, from which data for calculating the X-coordinates of charts is retrieved.
XLabels | Gets or sets custom labels for the x-axis. (Inherited from AxesChart.)
XLabelsFields | Gets or sets the database columns from which custom labels for the x-axis are retrieved. (Inherited from AxesChart.)
YAxisSettings | Gets or sets the appearance settings for the y-axis. (Inherited from AxesChart.)
YData | Gets or sets the data for calculating the Y-coordinates of charts.
YDataFields | Gets or sets the database columns, from which data for calculating the Y-coordinates of charts is retrieved.
YLabels | Gets or sets custom labels for the y-axis. (Inherited from AxesChart.)
YLabelsFields | Gets or sets the database columns, from which custom labels for the y-axis are retrieved. (Inherited from AxesChart.)

See Also

LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.Curve Property

LineChart.Curve Property
[image]

Gets or sets a value indicating whether lines are drawn as curves.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool Curve { get; set; }

Visual Basic [image] Copy Code

Public Property Curve As Boolean

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.Labels Property

LineChart.Labels Property
[image]

Gets or sets custom labels drawn at chart data points.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Labels As IList

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.LabelsFields Property

LineChart.LabelsFields Property
[image]

Gets or sets the database columns, from which custom text for data point labels is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string LabelsFields { get; set; }

Visual Basic [image] Copy Code

Public Property LabelsFields As String

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.LineType Property

LineChart.LineType Property
[image]

Gets or sets the type of the line chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public LineType LineType { get; set; }

Visual Basic [image] Copy Code

Public Property LineType As LineType

Property Value

A member of the LineType enumeration.

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.Stacked Property

LineChart.Stacked Property
[image]

Gets or sets a value indicating whether multi-series 3D graphics are drawn stacked.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool Stacked { get; set; }

Visual Basic [image] Copy Code

Public Property Stacked As Boolean

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.XData Property

LineChart.XData Property
[image]

Gets or sets the data for calculating the X-coordinates of line charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList XData { get; set; }

Visual Basic [image] Copy Code

Public Property XData As IList

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.XDataFields Property

LineChart.XDataFields Property
[image]

Gets or sets the database columns, from which data for calculating the X-coordinates of charts is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string XDataFields { get; set; }

Visual Basic [image] Copy Code

Public Property XDataFields As String

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.YData Property

LineChart.YData Property
[image]

Gets or sets the data for calculating the Y-coordinates of charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList YData { get; set; }

Visual Basic [image] Copy Code

Public Property YData As IList

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineChart.YDataFields Property

LineChart.YDataFields Property
[image]

Gets or sets the database columns, from which data for calculating the Y-coordinates of charts is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string YDataFields { get; set; }

Visual Basic [image] Copy Code

Public Property YDataFields As String

Property Value

See Also

LineChart Members
LineChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.LineType Enumeration

LineType Enumeration
[image]

Specifies the type of a line chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public enum LineType

Visual Basic [image] Copy Code

Public Enum LineType

Members

Member name | Description
Area | Indicates an area chart.
Bubble | Indicates a bubble chart.
Line | Indicates a regular line chart.
Scatter | Indicates a scatter chart.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.Location Structure

Location Structure
[image]

Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public struct Location

Visual Basic [image] Copy Code

Public Structure Location

See Also

Location Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Members

Location Members
Constructors Fields Properties Methods
[image]

Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.

The following tables list the members exposed by the Location type.

Public Constructors

Name | Description
Location | Overloaded.

Public Fields

Name | Description
Empty | An empty instance of the Location structure.

Public Properties

Name | Description
IsEmpty | Gets a value indicating whether this Location is empty.
X | Gets or sets the x-coordinate of this location.
XUnit | Gets or sets the units of measure of the x-coordinate of this Location.
Y | Gets or sets the y-coordinate of this location.
YUnit | Gets or sets the units of measure of the y-coordinate of this Location.

Public Methods

Name | Description
Add | Adds the width and height of the specified Dimension to the specified Location.
Equals | Determines if two Location structures have the same coordinates.
GetHashCode | Returns a hash code for this Location structure.
Subtract | Returns the result of subtracting the specified Dimension from the specified Location.
ToString | Creates a human-readable string that represents this Location.

See Also

Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Fields

Location Fields
[image]

Public Fields

Name | Description
Empty | An empty instance of the Location structure.

See Also

Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.Empty Field

Location.Empty Field
[image]

An empty instance of the Location structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public static readonly Location Empty

Visual Basic [image] Copy Code

Public Shared ReadOnly Empty As Location

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Constructor

Location Constructor
[image]

Overload List

Name | Description
Location (Single, MeasureUnit, Single, MeasureUnit) | Initializes a new instance of the Location structure.
Location (Single, Single) | Initializes a new instance of the Location structure with the specified coordinates.

See Also

Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Constructor (Single, MeasureUnit, Single, MeasureUnit)

Location Constructor (Single, MeasureUnit, Single, MeasureUnit)
See Also
[image]

Initializes a new instance of the Location structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Location (
float x,
MeasureUnit xUnit,
float y,
MeasureUnit yUnit
)

Visual Basic [image] Copy Code

Public New ( _
x As Single, _
xUnit As MeasureUnit, _
y As Single, _
yUnit As MeasureUnit _
)

Parameters

x
The x component of the new Location.
xUnit
The x unit component of the new Location.
y
The y component of the new Location.
yUnit
The y unit component of the new Location.

See Also

Location Constructor Overload List
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Constructor (Single, Single)

Location Constructor (Single, Single)
See Also
[image]

Initializes a new instance of the Location structure with the specified coordinates.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Location (
float x,
float y
)

Visual Basic [image] Copy Code

Public New ( _
x As Single, _
y As Single _
)

Parameters

x
The x component of the new Location.
y
The y component of the new Location.

See Also

Location Constructor Overload List
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Methods

Location Methods
[image]

Public Methods

Name | Description
Add | Adds the width and height of the specified Dimension to the specified Location.
Equals | Determines if two Location structures have the same coordinates.
GetHashCode | Returns a hash code for this Location structure.
Subtract | Returns the result of subtracting the specified Dimension from the specified Location.
ToString | Creates a human-readable string that represents this Location.

See Also

Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.Add Method

Location.Add Method
[image]

Adds the width and height of the specified Dimension to the specified Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public static Location Add (
Location location,
Dimension dimension
)

Visual Basic [image] Copy Code

Public Shared Function Add ( _
location As Location, _
dimension As Dimension _
) As Location

Parameters

location
The Location to add to.
dimension
The Dimension to add.

Return Value

A Location structure that is the result of the addition operation. The XUnit and YUnit of the result are both set to Document.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.Equals Method

Location.Equals Method
[image]

Determines if two Location structures have the same coordinates.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj
The System.Object to test.

Return Value

true if obj is a Location and has the same coordinates and units as this Location; otherwise, false.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.GetHashCode Method

Location.GetHashCode Method
[image]

Returns a hash code for this Location structure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

An integer value that specifies a hash value for this Location structure.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.Subtract Method

Location.Subtract Method
[image]

Returns the result of subtracting the specified Dimension from the specified Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public static Location Subtract (
Location location,
Dimension dimension
)

Visual Basic [image] Copy Code

Public Shared Function Subtract ( _
location As Location, _
dimension As Dimension _
) As Location

Parameters

location
The Location structure to subtract from.
dimension
The Dimension structure to subtract.

Return Value

The Location that is a result of the subtraction operation. The XUnit and YUnit of the result are both set to Document.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.ToString Method

Location.ToString Method
[image]

Creates a human-readable string that represents this Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string that represents this Location.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location Properties

Location Properties
[image]

Public Properties

Name | Description
IsEmpty | Gets a value indicating whether this Location is empty.
X | Gets or sets the x-coordinate of this location.
XUnit | Gets or sets the units of measure of the x-coordinate of this Location.
Y | Gets or sets the y-coordinate of this location.
YUnit | Gets or sets the units of measure of the y-coordinate of this Location.

See Also

Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.IsEmpty Property

Location.IsEmpty Property
[image]

Gets a value indicating whether this Location is empty.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

true if both X and Y of the Location are 0; otherwise, false.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace


MindFusion.Reporting.Location.X Property

Location.X Property
[image]

Gets or sets the x-coordinate of this location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Single

Property Value

A float number specifying the x-axis component of the Location, in the units of measure specified by XUnit.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace
Y Property
XUnit Property


MindFusion.Reporting.Location.XUnit Property

Location.XUnit Property
[image]

Gets or sets the units of measure of the x-coordinate of this Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public MeasureUnit XUnit { get; set; }

Visual Basic [image] Copy Code

Public Property XUnit As MeasureUnit

Property Value

A member of the MeasureUnit enumeration specifying the units of measure of the X component of this Location.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace
YUnit Property
X Property


MindFusion.Reporting.Location.Y Property

Location.Y Property
[image]

Gets or sets the y-coordinate of this location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Single

Property Value

A float number specifying the y-axis component of the Location, in the units of measure specified by YUnit.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace
YUnit Property
X Property


MindFusion.Reporting.Location.YUnit Property

Location.YUnit Property
[image]

Gets or sets the units of measure of the y-coordinate of this Location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public MeasureUnit YUnit { get; set; }

Visual Basic [image] Copy Code

Public Property YUnit As MeasureUnit

Property Value

A member of the MeasureUnit enumeration specifying the units of measure of the Y component of this Location.

See Also

Location Members
Location Structure
MindFusion.Reporting Namespace
XUnit Property
Y Property


MindFusion.Reporting.Margins Class

Margins Class
[image]

Specifies the dimensions of the margins of a rectangle.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class Margins

Visual Basic [image] Copy Code

Public Class Margins

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Margins

See Also

Margins Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Members

Margins Members
Constructors Properties Methods
[image]

Specifies the dimensions of the margins of a rectangle.

The following tables list the members exposed by the Margins type.

Public Constructors

Name | Description
Margins | Overloaded.

Public Properties

Name | Description
Bottom | Gets or sets the bottom component of this margin.
Left | Gets or sets the left component of this margin.
Right | Gets or sets the right component of this margin.
Top | Gets or sets the top component of this margin.

Public Methods

Name | Description
Clone | Creates a copy of this Margins object.
Equals | Determines if two Margins objects are identicat, that is, have the same values for all four sides.
GetHashCode | Returns a hash code for this Margins instance.
ToString | Creates a human-readable string that represents this Margins.

See Also

Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Constructor

Margins Constructor
[image]

Overload List

Name | Description
Margins () | Initializes a new instance of the Margins class.
Margins (Single) | Initializes a new instance of the Margins class.
Margins (Single, Single, Single, Single) | Initializes a new instance of the Margins class.

See Also

Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Constructor ()

Margins Constructor ()
See Also
[image]

Initializes a new instance of the Margins class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Margins ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Margins Constructor Overload List
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Constructor (Single)

Margins Constructor (Single)
See Also
[image]

Initializes a new instance of the Margins class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Margins (
float value
)

Visual Basic [image] Copy Code

Public New ( _
value As Single _
)

Parameters

value
The initial value for all sides of the new Margins.

See Also

Margins Constructor Overload List
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Constructor (Single, Single, Single, Single)

Margins Constructor (Single, Single, Single, Single)
See Also
[image]

Initializes a new instance of the Margins class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Margins (
float left,
float top,
float right,
float bottom
)

Visual Basic [image] Copy Code

Public New ( _
left As Single, _
top As Single, _
right As Single, _
bottom As Single _
)

Parameters

left
The left component of the new Margins.
top
The top component of the new Margins.
right
The right component of the new Margins.
bottom
The bottom component of the new Margins.

See Also

Margins Constructor Overload List
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Methods

Margins Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this Margins object.
Equals | Determines if two Margins objects are identicat, that is, have the same values for all four sides.
GetHashCode | Returns a hash code for this Margins instance.
ToString | Creates a human-readable string that represents this Margins.

See Also

Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins.Clone Method

Margins.Clone Method
[image]

Creates a copy of this Margins object.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Margins Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Margins

Return Value

An instance of the Margins class identical to the current instance.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins.Equals Method

Margins.Equals Method
[image]

Determines if two Margins objects are identicat, that is, have the same values for all four sides.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj
The System.Object to test.

Return Value

true if obj is a Margins and has the same sides as this Margins; otherwise, false.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins.GetHashCode Method

Margins.GetHashCode Method
[image]

Returns a hash code for this Margins instance.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

An integer value that specifies a hash value for this Margins object.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins.ToString Method

Margins.ToString Method
[image]

Creates a human-readable string that represents this Margins.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string that represents this Margins.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins Properties

Margins Properties
[image]

Public Properties

Name | Description
Bottom | Gets or sets the bottom component of this margin.
Left | Gets or sets the left component of this margin.
Right | Gets or sets the right component of this margin.
Top | Gets or sets the top component of this margin.

See Also

Margins Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Margins.Bottom Property

Margins.Bottom Property
[image]

Gets or sets the bottom component of this margin.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float Bottom { get; set; }

Visual Basic [image] Copy Code

Public Property Bottom As Single

Property Value

A float number specifying the bottom component of the Margins.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace
Left Property
Right Property
Top Property


MindFusion.Reporting.Margins.Left Property

Margins.Left Property
[image]

Gets or sets the left component of this margin.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float Left { get; set; }

Visual Basic [image] Copy Code

Public Property Left As Single

Property Value

A float number specifying the left component of the Margins.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace
Bottom Property
Right Property
Top Property


MindFusion.Reporting.Margins.Right Property

Margins.Right Property
[image]

Gets or sets the right component of this margin.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float Right { get; set; }

Visual Basic [image] Copy Code

Public Property Right As Single

Property Value

A float number specifying the right component of the Margins.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace
Bottom Property
Left Property
Top Property


MindFusion.Reporting.Margins.Top Property

Margins.Top Property
[image]

Gets or sets the top component of this margin.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float Top { get; set; }

Visual Basic [image] Copy Code

Public Property Top As Single

Property Value

A float number specifying the top component of the Margins.

See Also

Margins Members
Margins Class
MindFusion.Reporting Namespace
Bottom Property
Left Property
Right Property


MindFusion.Reporting.MeasureUnit Enumeration

MeasureUnit Enumeration
[image]

Specifies units of measure.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public enum MeasureUnit

Visual Basic [image] Copy Code

Public Enum MeasureUnit

Members

Member name | Description
Document | Indicates a measure units identical to those of the current document.
Percent | Indicates percentage relative to the total size of the containing element.
PercentRemainder | Indicates percentage relative to the remaining size of the containing element.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.Page Class

Page Class
[image]

Represents a page within a report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class Page : Component

Visual Basic [image] Copy Code

Public Class Page
Inherits Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.Page

See Also

Page Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Page Members

Page Members
Constructors Properties
[image]

Represents a page within a report.

The following tables list the members exposed by the Page type.

Public Constructors

Name | Description
Page | Initializes a new instance of the Page class.

Public Properties

Name | Description
Background | Gets or sets the brush that will be used to fill the page background.
Border | Gets or sets the border of this page.
Footer | Gets or sets the page footer.
Header | Gets or sets the page header.
Items | Gets or sets the items contained in this page.
Name | Gets or sets the name of the report item.
PageOrientation | Gets or sets the orientation of the page.

See Also

Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page Constructor

Page Constructor
[image]

Initializes a new instance of the Page class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Page ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page Properties

Page Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush that will be used to fill the page background.
Border | Gets or sets the border of this page.
Footer | Gets or sets the page footer.
Header | Gets or sets the page header.
Items | Gets or sets the items contained in this page.
Name | Gets or sets the name of the report item.
PageOrientation | Gets or sets the orientation of the page.

See Also

Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page.Background Property

Page.Background Property
[image]

Gets or sets the brush that will be used to fill the page background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush Background { get; set; }

Visual Basic [image] Copy Code

Public Property Background As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic) indicating a transparent background.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page.Border Property

Page.Border Property
[image]

Gets or sets the border of this page.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Border Border { get; set; }

Visual Basic [image] Copy Code

Public Property Border As Border

Property Value

An instance of the Border class. The default value is an empty Border object.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page.Footer Property

Page.Footer Property
[image]

Gets or sets the page footer.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public ItemContainer Footer { get; set; }

Visual Basic [image] Copy Code

Public Property Footer As ItemContainer

Property Value

An instance of the PageSection class representing the footer of this Page.

Remarks

You can add items to the footer through its Items property.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace
Header Property


MindFusion.Reporting.Page.Header Property

Page.Header Property
[image]

Gets or sets the page header.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public ItemContainer Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As ItemContainer

Property Value

An instance of the PageSection class representing the header of this Page.

Remarks

You can add items to the footer through its Items property.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace
Footer Property


MindFusion.Reporting.Page.Items Property

Page.Items Property
[image]

Gets or sets the items contained in this page.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList<ReportItem> Items { get; set; }

Visual Basic [image] Copy Code

Public Property Items As IList(Of ReportItem)

Property Value

An instance of a IList(ReportItem) class with the report items contained on the Page.

Remarks

This collection does not include the items contained in the header or footer of the page. To access these, use the Items property of the PageSection object returned from the Header or Footer property of the page respectively.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page.Name Property

Page.Name Property
[image]

Gets or sets the name of the report item.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string Name { get; set; }

Visual Basic [image] Copy Code

Public Property Name As String

Property Value

A string specifying the name of the page.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Page.PageOrientation Property

Page.PageOrientation Property
[image]

Gets or sets the orientation of the page.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PageOrientation PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As PageOrientation

Property Value

A member of the PageOrientation enumeration specifying the orientation of the page. The default is Unspecified.

Remarks

When PageOrientation is set to Unspecified, the actual page orientation is determined by the value of the defaultPageOrientation argument passed to the Layout method of the Report class during report layouting.

See Also

Page Members
Page Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PageBreak Class

PageBreak Class
[image]

Represents a single line across the whole width of a page, which indicates a page break at that location.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class PageBreak : ReportItem

Visual Basic [image] Copy Code

Public Class PageBreak
Inherits ReportItem

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.PageBreak

See Also

Report Items
PageBreak Members
MindFusion.Reporting Namespace


MindFusion.Reporting.PageBreak Members

PageBreak Members
Constructors Properties
[image]

Represents a single line across the whole width of a page, which indicates a page break at that location.

The following tables list the members exposed by the PageBreak type.

Public Constructors

Name | Description
PageBreak | Initializes a new instance of the PageBreak class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Location | ReportItem.Location override.
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

PageBreak Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PageBreak Constructor

PageBreak Constructor
[image]

Initializes a new instance of the PageBreak class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PageBreak ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PageBreak Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PageBreak Properties

PageBreak Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Location | ReportItem.Location override.
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

PageBreak Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PageBreak.Location Property

PageBreak.Location Property
[image]

ReportItem.Location override.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public override Location Location { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Location As Location

Property Value

A Location object specifying the position of the PageBreak relative to its parent.

Remarks

The x component of this property is irrelevant and is always 0.

See Also

PageBreak Members
PageBreak Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PageOrientation Enumeration

PageOrientation Enumeration
[image]

Specifies the orientation of a printed page.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public enum PageOrientation

Visual Basic [image] Copy Code

Public Enum PageOrientation

Members

Member name | Description
Landscape | Indicates landscape orientation.
Portrait | Indicates portrait orientation.
Unspecified | Indicates that the page will get its orientation from the default printer settings at the time of printing or previewing.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.PageSection Class

PageSection Class
Remarks See Also
[image]

Represents a page header or footer.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class PageSection : ItemContainer

Visual Basic [image] Copy Code

Public Class PageSection
Inherits ItemContainer

Remarks

When working with the MindFusion.Reporting Designer you don't have to worry about creating instances of this class and assigning them to the appropriate Page properties.

If you want to create a header or footer for a Page object through code, you have to instantiate from this class and assign the instance to the Header or Footer property of the Page object respectively. You can add items to the header or footer through its Items property.

Example

The following example demonstrates how to create a header for an existing Page object:

C# [image] Copy Code

PageSection header = new PageSection();

Label headerLabel = new Label();
headerLabel.Text = "Header Text";

header.Items.Add(headerLabel);

page1.Header = header;

Visual Basic [image] Copy Code

Dim header As New PageSection()

Dim headerLabel As New Label()
headerLabel.Text = "Header Text"

header.Items.Add(headerLabel)

page1.Header = header

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.ItemContainer
MindFusion.Reporting.PageSection

See Also

PageSection Members
MindFusion.Reporting Namespace


MindFusion.Reporting.PageSection Members

PageSection Members
Constructors Properties
[image]

Represents a page header or footer.

The following tables list the members exposed by the PageSection type.

Public Constructors

Name | Description
PageSection | Initializes a new instance of the PageSection class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Background | Gets or sets the brush that will be used to fill the container's background. (Inherited from ItemContainer.)
Border | Gets or sets the border of this container. (Inherited from ItemContainer.)
Bounds | Gets the bounding rectangle of this container. (Inherited from ItemContainer.)
Items | Gets or sets the report items contained in this container. (Inherited from ItemContainer.)
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

PageSection Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PageSection Constructor

PageSection Constructor
[image]

Initializes a new instance of the PageSection class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PageSection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PageSection Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PageSectionVisibility Enumeration

PageSectionVisibility Enumeration
[image]

Specifies the visibility of page headers and footers.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public enum PageSectionVisibility

Visual Basic [image] Copy Code

Public Enum PageSectionVisibility

Members

Member name | Description
AllPages | Indicates that the section should appear only on all pages.
EvenPages | Indicates that the section should appear only on even pages.
FirstPage | Indicates that the section should appear only on the first page.
LastPage | Indicates that the section should appear only on the last page.
None | Indicates an invisible section.
OddPages | Indicates that the section should appear only on odd pages.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.Picture Class

Picture Class
Remarks See Also
[image]

A report element that draws an image.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class Picture : ReportItem

Visual Basic [image] Copy Code

Public Class Picture
Inherits ReportItem

Remarks

In order to associate an image with the Picture element, create a .NET System.Drawing.Image object and assign it to its Image property. The stretching and alignment of the displayed image can be specified through the ImageAlign property.

Alternatively, pictures can be bound to fields in a data source. To do this, the picture must be placed in a data-bound DataRange object and its DataField property must be set to the name of the respective data field. For more information regarding this, check the Report Items and Binding Reports to a Data Source topics.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Picture

See Also

Report Items
Picture Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture Members

Picture Members
Constructors Properties
[image]

A report element that draws an image.

The following tables list the members exposed by the Picture type.

Public Constructors

Name | Description
Picture | Initializes a new instance of the Picture class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Background | Gets or sets the brush that will be used to fill the picture background.
Border | Gets or sets the border of this picture.
DataField | Gets or sets the name of the data field to bind to.
Image | Gets or sets the System.Drawing.Image object displayed by this picture.
ImageAlign | Gets or sets the alignment of the displayed image.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
RotationAngle | Gets or sets the rotation angle of the picture.
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture Constructor

Picture Constructor
[image]

Initializes a new instance of the Picture class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Picture ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture Properties

Picture Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
Background | Gets or sets the brush that will be used to fill the picture background.
Border | Gets or sets the border of this picture.
DataField | Gets or sets the name of the data field to bind to.
Image | Gets or sets the System.Drawing.Image object displayed by this picture.
ImageAlign | Gets or sets the alignment of the displayed image.
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
RotationAngle | Gets or sets the rotation angle of the picture.
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture.Background Property

Picture.Background Property
[image]

Gets or sets the brush that will be used to fill the picture background.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush Background { get; set; }

Visual Basic [image] Copy Code

Public Property Background As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic) indicating a transparent background.

See Also

Picture Members
Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture.Border Property

Picture.Border Property
[image]

Gets or sets the border of this picture.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Border Border { get; set; }

Visual Basic [image] Copy Code

Public Property Border As Border

Property Value

An instance of the Border class. The default value is an empty Border object.

See Also

Picture Members
Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture.DataField Property

Picture.DataField Property
[image]

Gets or sets the name of the data field to bind to.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string DataField { get; set; }

Visual Basic [image] Copy Code

Public Property DataField As String

Property Value

A string specifying the data field this picture is bound to. The default is an empty string indicating that the picture is not data-bound.

See Also

Picture Members
Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture.Image Property

Picture.Image Property
[image]

Gets or sets the System.Drawing.Image object displayed by this picture.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Image Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As Image

Property Value

An instance of the .NET System.Drawing.Image class.

Remarks

This property is ignored if the picture is data-bound, that is, its DataField property is not empty. The image of the picture in this case is obtained from the data source.

See Also

Picture Members
Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture.ImageAlign Property

Picture.ImageAlign Property
[image]

Gets or sets the alignment of the displayed image.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public ImageAlign ImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property ImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration specifying the stretching and alignment of the displayed image. The default is Fit.

See Also

Picture Members
Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Picture.RotationAngle Property

Picture.RotationAngle Property
[image]

Gets or sets the rotation angle of the picture.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float RotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property RotationAngle As Single

Property Value

A float value specifying the rotation angle of the displayed image, in degrees.

See Also

Picture Members
Picture Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart Class

PieChart Class
[image]

Represents a report item that can display pie charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class PieChart : Chart

Visual Basic [image] Copy Code

Public Class PieChart
Inherits Chart

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Chart
MindFusion.Reporting.PieChart

See Also

PieChart Members
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart Members

PieChart Members
Constructors Properties
[image]

Represents a report item that can display pie charts.

The following tables list the members exposed by the PieChart type.

Public Constructors

Name | Description
PieChart | Initializes a new instance of the PieChart class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
BackgroundBrush | Gets or sets the brush that fills the chart background. (Inherited from Chart.)
Border | Gets or sets the border of this chart. (Inherited from Chart.)
ChartBrushes | Gets or sets the brushes for the chart. (Inherited from Chart.)
ChartPens | Gets or sets the pens for the chart. (Inherited from Chart.)
Data | Gets or sets the data for the chart.
DataField | Gets or sets the data for the chart.
DataMember | Gets or sets from which member in the data source data is read. (Inherited from Chart.)
DataSource | Gets or sets the object, from which chart data is retrieved. (Inherited from Chart.)
FontName | Gets or sets the name of the font for all chart labels. (Inherited from Chart.)
InnerLabels | Gets or sets custom text for the inner labels of the chart.
InnerLabelsField | Gets or sets the database column, from which custom text for the inner labels is retrieved.
InnerLabelType | Gets or sets the type of the inner labels.
LabelBrush | Gets or sets the brush for the chart labels. (Inherited from Chart.)
LabelFont | Gets or sets the font for the chart labels. (Inherited from Chart.)
LegendAlignment | Gets or sets the alignment of the legend alongside the chart. (Inherited from Chart.)
LegendBackgroundBrush | Gets or sets the brush for the legend background. (Inherited from Chart.)
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels. (Inherited from Chart.)
LegendBrush | Gets or sets the brush for drawing the legend labels. (Inherited from Chart.)
LegendFont | Gets or sets the font for the legend labels. (Inherited from Chart.)
LegendLabels | Gets or sets the legend labels. (Inherited from Chart.)
LegendOffset | Gets or sets the offset of the legend to the axis labels. (Inherited from Chart.)
LegendPen | Gets or sets the pen for the legend outlining and grid. (Inherited from Chart.)
LegendPosition | Gets or sets the position of the legend. (Inherited from Chart.)
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
MasterDetailRelation | Gets or sets the master detail relation. (Inherited from Chart.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
OuterLabels | Gets or sets custom text as outer labels.
OuterLabelsField | Gets or sets the database column, from which custom text for the outer labels is retrieved.
OuterLabelType | Gets or sets the type of the outer labels.
OutlinePen | Gets or sets the outline pen for the chart.
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
PieceOutIndex | Gets or sets the index of the detached chart piece.
PieType | Gets or sets the type of the chart.
ShowLegend | Gets or sets a value indicating whether to display the chart legend. (Inherited from Chart.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
StartAngle | Gets or sets the angle, at which drawing of pie pieces starts.
SubTitleBrush | Gets or sets the brush used for drawing the subtitle. (Inherited from Chart.)
SubTitleFont | Gets or sets the font for the subtitle. (Inherited from Chart.)
SubTitleText | Gets or sets the text for the subtitle. (Inherited from Chart.)
TitleBrush | Gets or sets the brush used for drawing the title. (Inherited from Chart.)
TitleFont | Gets or sets the font for the title. (Inherited from Chart.)
TitleText | Gets or sets the title text. (Inherited from Chart.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart Constructor

PieChart Constructor
[image]

Initializes a new instance of the PieChart class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PieChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart Properties

PieChart Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
BackgroundBrush | Gets or sets the brush that fills the chart background. (Inherited from Chart.)
Border | Gets or sets the border of this chart. (Inherited from Chart.)
ChartBrushes | Gets or sets the brushes for the chart. (Inherited from Chart.)
ChartPens | Gets or sets the pens for the chart. (Inherited from Chart.)
Data | Gets or sets the data for the chart.
DataField | Gets or sets the data for the chart.
DataMember | Gets or sets from which member in the data source data is read. (Inherited from Chart.)
DataSource | Gets or sets the object, from which chart data is retrieved. (Inherited from Chart.)
FontName | Gets or sets the name of the font for all chart labels. (Inherited from Chart.)
InnerLabels | Gets or sets custom text for the inner labels of the chart.
InnerLabelsField | Gets or sets the database column, from which custom text for the inner labels is retrieved.
InnerLabelType | Gets or sets the type of the inner labels.
LabelBrush | Gets or sets the brush for the chart labels. (Inherited from Chart.)
LabelFont | Gets or sets the font for the chart labels. (Inherited from Chart.)
LegendAlignment | Gets or sets the alignment of the legend alongside the chart. (Inherited from Chart.)
LegendBackgroundBrush | Gets or sets the brush for the legend background. (Inherited from Chart.)
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels. (Inherited from Chart.)
LegendBrush | Gets or sets the brush for drawing the legend labels. (Inherited from Chart.)
LegendFont | Gets or sets the font for the legend labels. (Inherited from Chart.)
LegendLabels | Gets or sets the legend labels. (Inherited from Chart.)
LegendOffset | Gets or sets the offset of the legend to the axis labels. (Inherited from Chart.)
LegendPen | Gets or sets the pen for the legend outlining and grid. (Inherited from Chart.)
LegendPosition | Gets or sets the position of the legend. (Inherited from Chart.)
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
MasterDetailRelation | Gets or sets the master detail relation. (Inherited from Chart.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
OuterLabels | Gets or sets custom text as outer labels.
OuterLabelsField | Gets or sets the database column, from which custom text for the outer labels is retrieved.
OuterLabelType | Gets or sets the type of the outer labels.
OutlinePen | Gets or sets the outline pen for the chart.
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
PieceOutIndex | Gets or sets the index of the detached chart piece.
PieType | Gets or sets the type of the chart.
ShowLegend | Gets or sets a value indicating whether to display the chart legend. (Inherited from Chart.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
StartAngle | Gets or sets the angle, at which drawing of pie pieces starts.
SubTitleBrush | Gets or sets the brush used for drawing the subtitle. (Inherited from Chart.)
SubTitleFont | Gets or sets the font for the subtitle. (Inherited from Chart.)
SubTitleText | Gets or sets the text for the subtitle. (Inherited from Chart.)
TitleBrush | Gets or sets the brush used for drawing the title. (Inherited from Chart.)
TitleFont | Gets or sets the font for the title. (Inherited from Chart.)
TitleText | Gets or sets the title text. (Inherited from Chart.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.Data Property

PieChart.Data Property
[image]

Gets or sets the data for the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As IList

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.DataField Property

PieChart.DataField Property
[image]

Gets or sets the data for the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string DataField { get; set; }

Visual Basic [image] Copy Code

Public Property DataField As String

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.InnerLabels Property

PieChart.InnerLabels Property
[image]

Gets or sets custom text for the inner labels of the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList InnerLabels { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabels As IList

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.InnerLabelsField Property

PieChart.InnerLabelsField Property
[image]

Gets or sets the database column, from which custom text for the inner labels is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string InnerLabelsField { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelsField As String

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.InnerLabelType Property

PieChart.InnerLabelType Property
[image]

Gets or sets the type of the inner labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public LabelType InnerLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelType As LabelType

Property Value

A member of the LabelType enumeration.

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.OuterLabels Property

PieChart.OuterLabels Property
[image]

Gets or sets custom text as outer labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList OuterLabels { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabels As IList

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.OuterLabelsField Property

PieChart.OuterLabelsField Property
[image]

Gets or sets the database column, from which custom text for the outer labels is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string OuterLabelsField { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelsField As String

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.OuterLabelType Property

PieChart.OuterLabelType Property
[image]

Gets or sets the type of the outer labels.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public LabelType OuterLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelType As LabelType

Property Value

A member of the LabelType enumeration.

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.OutlinePen Property

PieChart.OutlinePen Property
[image]

Gets or sets the outline pen for the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Pen OutlinePen { get; set; }

Visual Basic [image] Copy Code

Public Property OutlinePen As Pen

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.PieceOutIndex Property

PieChart.PieceOutIndex Property
[image]

Gets or sets the index of the detached chart piece.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public int PieceOutIndex { get; set; }

Visual Basic [image] Copy Code

Public Property PieceOutIndex As Integer

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.PieType Property

PieChart.PieType Property
[image]

Gets or sets the type of the chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PieType PieType { get; set; }

Visual Basic [image] Copy Code

Public Property PieType As PieType

Property Value

A member of the PieType enumeration.

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieChart.StartAngle Property

PieChart.StartAngle Property
[image]

Gets or sets the angle, at which drawing of pie pieces starts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float StartAngle { get; set; }

Visual Basic [image] Copy Code

Public Property StartAngle As Single

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.PieType Enumeration

PieType Enumeration
[image]

Specifies the type of a pie chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public enum PieType

Visual Basic [image] Copy Code

Public Enum PieType

Members

Member name | Description
Doughnut | Indicates a doughnut pie chart.
Pie | Indicates a regular pie chart.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart Class

RadarChart Class
[image]

Represents a report item that can display radar charts.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class RadarChart : Chart

Visual Basic [image] Copy Code

Public Class RadarChart
Inherits Chart

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Chart
MindFusion.Reporting.RadarChart

See Also

RadarChart Members
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart Members

RadarChart Members
Constructors Properties
[image]

Represents a report item that can display radar charts.

The following tables list the members exposed by the RadarChart type.

Public Constructors

Name | Description
RadarChart | Initializes a new instance of the RadarChart class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
BackgroundBrush | Gets or sets the brush that fills the chart background. (Inherited from Chart.)
Border | Gets or sets the border of this chart. (Inherited from Chart.)
ChartBrushes | Gets or sets the brushes for the chart. (Inherited from Chart.)
ChartPens | Gets or sets the pens for the chart. (Inherited from Chart.)
Data | Gets or sets the chart data.
DataFields | Gets or sets the database column, from which data for the chart is retrieved.
DataMember | Gets or sets from which member in the data source data is read. (Inherited from Chart.)
DataSource | Gets or sets the object, from which chart data is retrieved. (Inherited from Chart.)
FontName | Gets or sets the name of the font for all chart labels. (Inherited from Chart.)
InnerAxisLabels | Gets or sets custom labels for the inner axis.
InnerAxisLabelsField | Gets or sets the database column, from which labels for the inner axis are retrieved.
LabelBrush | Gets or sets the brush for the chart labels. (Inherited from Chart.)
LabelFont | Gets or sets the font for the chart labels. (Inherited from Chart.)
LegendAlignment | Gets or sets the alignment of the legend alongside the chart. (Inherited from Chart.)
LegendBackgroundBrush | Gets or sets the brush for the legend background. (Inherited from Chart.)
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels. (Inherited from Chart.)
LegendBrush | Gets or sets the brush for drawing the legend labels. (Inherited from Chart.)
LegendFont | Gets or sets the font for the legend labels. (Inherited from Chart.)
LegendLabels | Gets or sets the legend labels. (Inherited from Chart.)
LegendOffset | Gets or sets the offset of the legend to the axis labels. (Inherited from Chart.)
LegendPen | Gets or sets the pen for the legend outlining and grid. (Inherited from Chart.)
LegendPosition | Gets or sets the position of the legend. (Inherited from Chart.)
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
MasterDetailRelation | Gets or sets the master detail relation. (Inherited from Chart.)
MaxValue | Gets or sets the maximum number at the inner axis.
MinValue | Gets or sets the minimum number at the inner axis.
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
OuterAxisLabels | Gets or sets custom labels at the outer axis.
OuterAxisLabelsField | Gets or sets the database column, from which labels for the outer axis are retrieved.
OuterLabels | Gets or sets custom labels drawn in the middle of outer axis segments.
OuterLabelsField | Gets or sets the database column, from which labels at the chart segments are retrieved.
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
RadarStyle | Gets or sets the style of the radar chart.
RadarType | Gets or sets the type of the radar chart.
RadiusLength | Gets or sets the length of the radar radius.
ShowLegend | Gets or sets a value indicating whether to display the chart legend. (Inherited from Chart.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
SubTitleBrush | Gets or sets the brush used for drawing the subtitle. (Inherited from Chart.)
SubTitleFont | Gets or sets the font for the subtitle. (Inherited from Chart.)
SubTitleText | Gets or sets the text for the subtitle. (Inherited from Chart.)
TitleBrush | Gets or sets the brush used for drawing the title. (Inherited from Chart.)
TitleFont | Gets or sets the font for the title. (Inherited from Chart.)
TitleText | Gets or sets the title text. (Inherited from Chart.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart Constructor

RadarChart Constructor
[image]

Initializes a new instance of the RadarChart class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public RadarChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart Properties

RadarChart Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
BackgroundBrush | Gets or sets the brush that fills the chart background. (Inherited from Chart.)
Border | Gets or sets the border of this chart. (Inherited from Chart.)
ChartBrushes | Gets or sets the brushes for the chart. (Inherited from Chart.)
ChartPens | Gets or sets the pens for the chart. (Inherited from Chart.)
Data | Gets or sets the chart data.
DataFields | Gets or sets the database column, from which data for the chart is retrieved.
DataMember | Gets or sets from which member in the data source data is read. (Inherited from Chart.)
DataSource | Gets or sets the object, from which chart data is retrieved. (Inherited from Chart.)
FontName | Gets or sets the name of the font for all chart labels. (Inherited from Chart.)
InnerAxisLabels | Gets or sets custom labels for the inner axis.
InnerAxisLabelsField | Gets or sets the database column, from which labels for the inner axis are retrieved.
LabelBrush | Gets or sets the brush for the chart labels. (Inherited from Chart.)
LabelFont | Gets or sets the font for the chart labels. (Inherited from Chart.)
LegendAlignment | Gets or sets the alignment of the legend alongside the chart. (Inherited from Chart.)
LegendBackgroundBrush | Gets or sets the brush for the legend background. (Inherited from Chart.)
LegendBorderMargin | Gets or sets the margin between the legend border and the legend labels. (Inherited from Chart.)
LegendBrush | Gets or sets the brush for drawing the legend labels. (Inherited from Chart.)
LegendFont | Gets or sets the font for the legend labels. (Inherited from Chart.)
LegendLabels | Gets or sets the legend labels. (Inherited from Chart.)
LegendOffset | Gets or sets the offset of the legend to the axis labels. (Inherited from Chart.)
LegendPen | Gets or sets the pen for the legend outlining and grid. (Inherited from Chart.)
LegendPosition | Gets or sets the position of the legend. (Inherited from Chart.)
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
MasterDetailRelation | Gets or sets the master detail relation. (Inherited from Chart.)
MaxValue | Gets or sets the maximum number at the inner axis.
MinValue | Gets or sets the minimum number at the inner axis.
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
OuterAxisLabels | Gets or sets custom labels at the outer axis.
OuterAxisLabelsField | Gets or sets the database column, from which labels for the outer axis are retrieved.
OuterLabels | Gets or sets custom labels drawn in the middle of outer axis segments.
OuterLabelsField | Gets or sets the database column, from which labels at the chart segments are retrieved.
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
RadarStyle | Gets or sets the style of the radar chart.
RadarType | Gets or sets the type of the radar chart.
RadiusLength | Gets or sets the length of the radar radius.
ShowLegend | Gets or sets a value indicating whether to display the chart legend. (Inherited from Chart.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
SubTitleBrush | Gets or sets the brush used for drawing the subtitle. (Inherited from Chart.)
SubTitleFont | Gets or sets the font for the subtitle. (Inherited from Chart.)
SubTitleText | Gets or sets the text for the subtitle. (Inherited from Chart.)
TitleBrush | Gets or sets the brush used for drawing the title. (Inherited from Chart.)
TitleFont | Gets or sets the font for the title. (Inherited from Chart.)
TitleText | Gets or sets the title text. (Inherited from Chart.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.Data Property

RadarChart.Data Property
[image]

Gets or sets the chart data.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As IList

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.DataFields Property

RadarChart.DataFields Property
[image]

Gets or sets the database column, from which data for the chart is retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string DataFields { get; set; }

Visual Basic [image] Copy Code

Public Property DataFields As String

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.InnerAxisLabels Property

RadarChart.InnerAxisLabels Property
[image]

Gets or sets custom labels for the inner axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList InnerAxisLabels { get; set; }

Visual Basic [image] Copy Code

Public Property InnerAxisLabels As IList

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.InnerAxisLabelsField Property

RadarChart.InnerAxisLabelsField Property
[image]

Gets or sets the database column, from which labels for the inner axis are retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string InnerAxisLabelsField { get; set; }

Visual Basic [image] Copy Code

Public Property InnerAxisLabelsField As String

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.MaxValue Property

RadarChart.MaxValue Property
[image]

Gets or sets the maximum number at the inner axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public double MaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property MaxValue As Double

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.MinValue Property

RadarChart.MinValue Property
[image]

Gets or sets the minimum number at the inner axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public double MinValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinValue As Double

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.OuterAxisLabels Property

RadarChart.OuterAxisLabels Property
[image]

Gets or sets custom labels at the outer axis.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList OuterAxisLabels { get; set; }

Visual Basic [image] Copy Code

Public Property OuterAxisLabels As IList

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.OuterAxisLabelsField Property

RadarChart.OuterAxisLabelsField Property
[image]

Gets or sets the database column, from which labels for the outer axis are retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string OuterAxisLabelsField { get; set; }

Visual Basic [image] Copy Code

Public Property OuterAxisLabelsField As String

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.OuterLabels Property

RadarChart.OuterLabels Property
[image]

Gets or sets custom labels drawn in the middle of outer axis segments.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList OuterLabels { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabels As IList

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.OuterLabelsField Property

RadarChart.OuterLabelsField Property
[image]

Gets or sets the database column, from which labels at the chart segments are retrieved.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string OuterLabelsField { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelsField As String

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.RadarStyle Property

RadarChart.RadarStyle Property
[image]

Gets or sets the style of the radar chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public RadarStyle RadarStyle { get; set; }

Visual Basic [image] Copy Code

Public Property RadarStyle As RadarStyle

Property Value

A member of the RadarStyle enumeration.

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.RadarType Property

RadarChart.RadarType Property
[image]

Gets or sets the type of the radar chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public RadarType RadarType { get; set; }

Visual Basic [image] Copy Code

Public Property RadarType As RadarType

Property Value

A member of the RadarType enumeration.

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarChart.RadiusLength Property

RadarChart.RadiusLength Property
[image]

Gets or sets the length of the radar radius.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float RadiusLength { get; set; }

Visual Basic [image] Copy Code

Public Property RadiusLength As Single

Property Value

See Also

RadarChart Members
RadarChart Class
MindFusion.Reporting Namespace


MindFusion.Reporting.RadarStyle Enumeration

RadarStyle Enumeration
[image]

Specifies the drawing styles for a radar chart.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public enum RadarStyle

Visual Basic [image] Copy Code

Public Enum RadarStyle

Members

Member name | Description
Arcs | The chart is drawn with arcs that connect the data points.
Area | Chart segments are lines and the interior is filled.
AreaArcs | Chart segments are arcs and the interior is filled.
Lines | The chart is drawn with lines that connect the data points.
Points | The chart is drawn with points that mark the position of each chart value.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.RadarType Enumeration

RadarType Enumeration
[image]

Specifies the different types of radar charts that can be drawn.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public enum RadarType

Visual Basic [image] Copy Code

Public Enum RadarType

Members

Member name | Description
Polar | Indicates a 2D radar chart. The position of each data point is specified by a numerical value.
Radar | Indicates a 2D polar chart. The position of each data point is specified by an angle and a numerical value.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.Report Class

Report Class
Remarks See Also
[image]

Serves as base class for all reports.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class Report : Component

Visual Basic [image] Copy Code

Public Class Report
Inherits Component

Remarks

You can create new reports by instantiating from this class. New pages can be added to the report by creating Page objects and adding them to the collection returned by the report's Pages property. Report items are added to the Report indirectly by adding them to one of the pages contained in the report.

Creating reports in the Designer

An alternative (and much easier) way to create and design reports is to use the integrated MindFusion.Reporting Designer. In order to use the Designer, you need to create a custom class that derives from Report. A convenient way for creating custom report classes is by using the 'MindFusion Report' item template installed in Visual Studio with the MindFusion.Reporting package.

Note

If you create your custom report class manually, and you want this class to be designable, you need to ensure that the class provides a parameterless constructor and an InitializeComponent method, which should be called from the constructor.

Once the custom report class is created, double-click on it in the Solution Explorer in order to open the MindFusion.Reporting Designer and open the report.

For more information about the Designer and how to use it, check Report Designer.

Running the report

Once the report is initialized, you need to process it by calling its Run method. After the report has been processed it is ready to be used in various scenarios.

You can print the report by using a ReportPrinter object. You can open a preview of the report by using the PrintPreviewForm class. For details, check Printing and Print Previewing.

You can display the report on a Windows Form by using the ReportViewer control. For more information on how to do this, visit Displaying Reports on a Windows Form.

You can export the report to PDF or HTML by using the PdfExporter and HtmlExporter classes respectively. Check Exporting for more information.

Finally, you can manually layout the report and render its pages to any IGraphics object. To do this, call the Layout method of the Report class, then use the DrawPage method of the ReportLayout object returned as a result from the method.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.Report

See Also

Report Members
MindFusion.Reporting Namespace


MindFusion.Reporting.Report Members

Report Members
Constructors Properties Methods Events
[image]

Serves as base class for all reports.

The following tables list the members exposed by the Report type.

Public Constructors

Name | Description
Report | Initializes a new instance of the Report class.

Public Properties

Name | Description
Font | Gets or sets the default font in the report.
FontName | Gets or sets the default font in the report.
FontSize | Gets or sets the default font size in the report.
FontStyle | Gets or sets the default font style in the report.
MeasureUnit | Gets or sets the unit of the report measures.
Pages | Gets a collection with all report pages.
Parameters | Gets a list with the report parameters.

Public Methods

Name | Description
Layout | Layouts the report after it has been previously processed by a call to the Run method.
LoadFromXml | Overloaded. Loads the report from a file, stream, or XML node.
Run | Executes the report.
SaveToXml | Overloaded. Saves the report to a file, stream, or XML node.

Protected Methods

Name | Description
Load | Loads the report from the specified XML element.
OnDeserializeDataSource | Raises the DeserializeDataSource event.
OnReportRun | Raises the ReportRun event.
OnSerializeDataSource | Raises the SerializeDataSource event.
Save | Saves the report to the specified XML element.

Public Events

Name | Description
DeserializeDataSource | Raised during deserialization to resolve report data sources based on the string identifiers previously specified through the SerializeDataSource event.
ReportRun | Raised after the report has been processed.
SerializeDataSource | Raised during serialization to map the data sources referenced inside the report with string identifiers.

See Also

Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report Constructor

Report Constructor
[image]

Initializes a new instance of the Report class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Report ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report Methods

Report Methods
[image]

Public Methods

Name | Description
Layout | Layouts the report after it has been previously processed by a call to the Run method.
LoadFromXml | Overloaded. Loads the report from a file, stream, or XML node.
Run | Executes the report.
SaveToXml | Overloaded. Saves the report to a file, stream, or XML node.

Protected Methods

Name | Description
Load | Loads the report from the specified XML element.
OnDeserializeDataSource | Raises the DeserializeDataSource event.
OnReportRun | Raises the ReportRun event.
OnSerializeDataSource | Raises the SerializeDataSource event.
Save | Saves the report to the specified XML element.

See Also

Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.Layout Method

Report.Layout Method
[image]

Layouts the report after it has been previously processed by a call to the Run method.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public ReportLayout Layout (
SizeF paperSize,
Margins margin,
PageOrientation defaultPageOrientation
)

Visual Basic [image] Copy Code

Public Function Layout ( _
paperSize As SizeF, _
margin As Margins, _
defaultPageOrientation As PageOrientation _
) As ReportLayout

Parameters

paperSize
The size of the report pages.
margin
The margin of the report pages.
defaultPageOrientation
The orientation to use for all pages which do not have an explicitly specified orientation. This value is used for all pages who have their PageOrientation property set to Unspecified.

Return Value

An instance of the ReportLayout class.

Remarks

This ReportLayout object, returned by this method contains information about the total number of pages in the final layout. It also provides means for obtaining the physical size of individual pages as well as the ability to render individual pages to an IGraphics object.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.Load Method

Report.Load Method
[image]

Loads the report from the specified XML element.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

protected virtual void Load (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub Load( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

The parent element to load the report from.

context

An XmlSerializationContext object providing contextual information and helper methods.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace
Save Method


MindFusion.Reporting.Report.LoadFromXml Method

Report.LoadFromXml Method
[image]

Loads the report from a file, stream, or XML node.

Overload List

Name | Description
Report.LoadFromXml (Stream) | Loads the report from the specified stream.
Report.LoadFromXml (String) | Loads the report from the specified file.
Report.LoadFromXml (XmlNode) | Loads the report from the specified XML node.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.LoadFromXml Method (Stream)

Report.LoadFromXml Method (Stream)
See Also
[image]

Loads the report from the specified stream.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public void LoadFromXml (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
stream As Stream _
)

Parameters

stream

The stream to load from.

See Also

LoadFromXml Method Overload List
Report Members
Report Class
MindFusion.Reporting Namespace
SaveToXml Method


MindFusion.Reporting.Report.LoadFromXml Method (String)

Report.LoadFromXml Method (String)
See Also
[image]

Loads the report from the specified file.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the file to load from.

See Also

LoadFromXml Method Overload List
Report Members
Report Class
MindFusion.Reporting Namespace
SaveToXml Method


MindFusion.Reporting.Report.LoadFromXml Method (XmlNode)

Report.LoadFromXml Method (XmlNode)
See Also
[image]

Loads the report from the specified XML node.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlNode node
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
node As XmlNode _
)

Parameters

node

The node to load from.

See Also

LoadFromXml Method Overload List
Report Members
Report Class
MindFusion.Reporting Namespace
SaveToXml Method


MindFusion.Reporting.Report.OnDeserializeDataSource Method

Report.OnDeserializeDataSource Method
[image]

Raises the DeserializeDataSource event.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeDataSource (
SerializeDataSourceEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeDataSource( _
e As SerializeDataSourceEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.OnReportRun Method

Report.OnReportRun Method
[image]

Raises the ReportRun event.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

protected virtual void OnReportRun (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnReportRun( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.OnSerializeDataSource Method

Report.OnSerializeDataSource Method
[image]

Raises the SerializeDataSource event.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

protected virtual void OnSerializeDataSource (
SerializeDataSourceEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeDataSource( _
e As SerializeDataSourceEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.Run Method

Report.Run Method
[image]

Executes the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public void Run ()

Visual Basic [image] Copy Code

Public Sub Run ()

Remarks

It is imperative to invoke this method after the report design has been completed and before the report is actually used. This method performs all necessary operations such as data-binding of report items, expression evaluation, and so on.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.Save Method

Report.Save Method
[image]

Saves the report to the specified XML element.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

protected virtual void Save (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub Save( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

The parent element to save the report to.

context

An XmlSerializationContext object providing contextual information and helper methods.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace
Load Method


MindFusion.Reporting.Report.SaveToXml Method

Report.SaveToXml Method
[image]

Saves the report to a file, stream, or XML node.

Overload List

Name | Description
Report.SaveToXml (Stream) | Saves the report to the specified stream.
Report.SaveToXml (String) | Saves the report to the specified file.
Report.SaveToXml (XmlNode) | Saves the report to the specified XML node.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.SaveToXml Method (Stream)

Report.SaveToXml Method (Stream)
See Also
[image]

Saves the report to the specified stream.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public void SaveToXml (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
stream As Stream _
)

Parameters

stream

The stream to save to.

See Also

SaveToXml Method Overload List
Report Members
Report Class
MindFusion.Reporting Namespace
LoadFromXml Method


MindFusion.Reporting.Report.SaveToXml Method (String)

Report.SaveToXml Method (String)
See Also
[image]

Saves the report to the specified file.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The name of the file to save to.

See Also

SaveToXml Method Overload List
Report Members
Report Class
MindFusion.Reporting Namespace
LoadFromXml Method


MindFusion.Reporting.Report.SaveToXml Method (XmlNode)

Report.SaveToXml Method (XmlNode)
See Also
[image]

Saves the report to the specified XML node.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlNode node
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
node As XmlNode _
)

Parameters

node

The node to save to.

See Also

SaveToXml Method Overload List
Report Members
Report Class
MindFusion.Reporting Namespace
LoadFromXml Method


MindFusion.Reporting.Report Properties

Report Properties
[image]

Public Properties

Name | Description
Font | Gets or sets the default font in the report.
FontName | Gets or sets the default font in the report.
FontSize | Gets or sets the default font size in the report.
FontStyle | Gets or sets the default font style in the report.
MeasureUnit | Gets or sets the unit of the report measures.
Pages | Gets a collection with all report pages.
Parameters | Gets a list with the report parameters.

See Also

Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.Font Property

Report.Font Property
[image]

Gets or sets the default font in the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Font Font { get; set; }

Visual Basic [image] Copy Code

Public Property Font As Font

Property Value

A .NET Font object specifying the font for all report elements which have their Font property set to null (Nothing in Visual Basic). The defualt is a 10 point Arial font.

Remarks

This property is obsolete. Use the FontName, FontSize, and FontStyle properties of the report in order to specify the default font.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.MeasureUnit Property

Report.MeasureUnit Property
[image]

Gets or sets the unit of the report measures.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public GraphicsUnit MeasureUnit { get; set; }

Visual Basic [image] Copy Code

Public Property MeasureUnit As GraphicsUnit

Property Value

A member of the .NET GraphicsUnit enumeration specifying the units of measure in the report.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.Pages Property

Report.Pages Property
[image]

Gets a collection with all report pages.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public IList<Page> Pages { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Pages As IList(Of Page)

Property Value

An instance of an IList(Page) collection that contains all pages in the report.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.Parameters Property

Report.Parameters Property
[image]

Gets a list with the report parameters.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public List<ReportParameter> Parameters { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Parameters As List(Of ReportParameter)

Property Value

A list with the report parameters.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.FontName Property

Report.FontName Property
[image]

Gets or sets the default font in the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string FontName { get; set; }

Visual Basic [image] Copy Code

Public Property FontName As String

Property Value

A string value. The default is "Arial".

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.FontSize Property

Report.FontSize Property
[image]

Gets or sets the default font size in the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Single

Property Value

A float value. The default is 10.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.FontStyle Property

Report.FontStyle Property
[image]

Gets or sets the default font style in the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontStyle

Property Value

A member of the FontStyle enumeration. The default is Regular.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report Events

Report Events
[image]

Public Events

Name | Description
DeserializeDataSource | Raised during deserialization to resolve report data sources based on the string identifiers previously specified through the SerializeDataSource event.
ReportRun | Raised after the report has been processed.
SerializeDataSource | Raised during serialization to map the data sources referenced inside the report with string identifiers.

See Also

Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.DeserializeDataSource Event

Report.DeserializeDataSource Event
[image]

Raised during deserialization to resolve report data sources based on the string identifiers previously specified through the SerializeDataSource event.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public event EventHandler<SerializeDataSourceEventArgs> DeserializeDataSource

Visual Basic [image] Copy Code

Public Event DeserializeDataSource As EventHandler(Of SerializeDataSourceEventArgs)

Event Data

DeserializeDataSource event handlers receive an argument of type SerializeDataSourceEventArgs.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace
SerializeDataSource Event


MindFusion.Reporting.Report.ReportRun Event

Report.ReportRun Event
[image]

Raised after the report has been processed.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public event EventHandler ReportRun

Visual Basic [image] Copy Code

Public Event ReportRun As EventHandler

Event Data

ReportRun event handlers receive an argument of type EventArgs.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace


MindFusion.Reporting.Report.SerializeDataSource Event

Report.SerializeDataSource Event
[image]

Raised during serialization to map the data sources referenced inside the report with string identifiers.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public event EventHandler<SerializeDataSourceEventArgs> SerializeDataSource

Visual Basic [image] Copy Code

Public Event SerializeDataSource As EventHandler(Of SerializeDataSourceEventArgs)

Event Data

SerializeDataSource event handlers receive an argument of type SerializeDataSourceEventArgs.

See Also

Report Members
Report Class
MindFusion.Reporting Namespace
DeserializeDataSource Event


MindFusion.Reporting.ReportItem Class

ReportItem Class
[image]

Represents an abstract base class for all report elements.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public abstract class ReportItem : Component

Visual Basic [image] Copy Code

Public MustInherit Class ReportItem
Inherits Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.Barcode
MindFusion.Reporting.Canvas
MindFusion.Reporting.Chart
MindFusion.Reporting.ControlWrapper
MindFusion.Reporting.DataRange
MindFusion.Reporting.Ellipse
MindFusion.Reporting.ItemContainer
MindFusion.Reporting.Label
MindFusion.Reporting.Line
MindFusion.Reporting.PageBreak
MindFusion.Reporting.Picture

See Also

ReportItem Members
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem Members

ReportItem Members
Constructors Properties
[image]

Represents an abstract base class for all report elements.

The following tables list the members exposed by the ReportItem type.

Protected Constructors

Name | Description
ReportItem | Initialize a new instance of the ReportItem class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility.
Location | Gets or sets the position of the item.
Name | Gets or sets the name of the report item.
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections.
Size | Gets or sets the size of the item.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order.
Visible | Gets or sets a value indicating whether the item will be printed in the report.

See Also

ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem Constructor

ReportItem Constructor
[image]

Initialize a new instance of the ReportItem class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

protected ReportItem ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem Properties

ReportItem Properties
[image]

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility.
Location | Gets or sets the position of the item.
Name | Gets or sets the name of the report item.
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections.
Size | Gets or sets the size of the item.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order.
Visible | Gets or sets a value indicating whether the item will be printed in the report.

See Also

ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem.AffectsParentLayout Property

ReportItem.AffectsParentLayout Property
[image]

Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool AffectsParentLayout { get; set; }

Visual Basic [image] Copy Code

Public Property AffectsParentLayout As Boolean

Property Value

A boolean value.

Remarks

This poperty applies only to the top-level items in the page section.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem.Location Property

ReportItem.Location Property
[image]

Gets or sets the position of the item.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public virtual Location Location { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Location As Location

Property Value

A Location object specifyinf the position of the report item relative to its parent element.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting Namespace
Size Property


MindFusion.Reporting.ReportItem.Name Property

ReportItem.Name Property
[image]

Gets or sets the name of the report item.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string Name { get; set; }

Visual Basic [image] Copy Code

Public Property Name As String

Property Value

A string specifying the name of the item.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem.PageSectionVisibility Property

ReportItem.PageSectionVisibility Property
[image]

Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PageSectionVisibility PageSectionVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property PageSectionVisibility As PageSectionVisibility

Property Value

An member of the PageSectionVisibility enumeration.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem.Size Property

ReportItem.Size Property
[image]

Gets or sets the size of the item.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public virtual Nullable<Dimension> Size { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Size As Nullable(Of Dimension)

Property Value

A Dimension object or null (Nothing in Visual Basic) to indicate the default item size.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting Namespace
Location Property


MindFusion.Reporting.ReportItem.UseDesignOrder Property

ReportItem.UseDesignOrder Property
[image]

Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool UseDesignOrder { get; set; }

Visual Basic [image] Copy Code

Public Property UseDesignOrder As Boolean

Property Value

true to force the design-time order of the item to take precedence over the item's vertical position when determining the order in which the items are being laid out; otherwise, false. The default is false.

Remarks

When determining the order in which items are process during report layout, the following rules apply based on the value of this property:

Item1.UseDesignOrder | Item2.UseDesignOrder | Description
false | false | The vertical position of the items is considered when determining the layout order. The item with smaller y-coordinate is laid out first.
false | true | Item1 is laid out first.
true | false | Item2 is laid out first.
true | true | The design-time order of the items is considered when determining the items layout order. The item with smaller design-time order is laid out first.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportItem.Visible Property

ReportItem.Visible Property
[image]

Gets or sets a value indicating whether the item will be printed in the report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true to print this item; otherwise, false. The default is true.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout Class

ReportLayout Class
Remarks See Also
[image]

Encapsulates the state of a laid out Report object. To create an instance of this class, call the Layout method of the Report class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public sealed class ReportLayout

Visual Basic [image] Copy Code

Public NotInheritable Class ReportLayout

Remarks

You cannot instantiate from this class directly. Instead, invoke the Layout method of an existing Report object, which has been previously processed by a call to its Run method. The ReportLayout objects encapsulate the layout of the report, that is, the page split up and the position of individual report items.

Once you obtain a ReportLayout object you can perform several operations on it. The PageCount property returns the total number of pages in the layout. Individual pages can be rendered to an IGraphics object by calling the DrawPage method. The orientation and physical size of a page can be obtained through the GetPageOrientation and GetPageSize methods respectively.

Example

The following example creates a ReportLayout from an existing report and renders its 10th page to a GDI+ Graphics object. The example assumes that report1 is a variable identifying an existing Report, which has been previously processed through a call to its Run method and that graphics is a variable identifying existing GDI+ Graphics.

C# [image] Copy Code

// Layout the report
ReportLayout layout = report1.Layout(new SizeF(210, 297), new Margins(20), PageOrientation.Portrait);

// Create the drawing context and the target IGraphics
DrawContext context = new DrawContext(report1);
GdiGraphics target = new GdiGraphics(graphics);

// Draw the page
layout.DrawPage(target, 9, context);

Visual Basic [image] Copy Code

' Layout the report
Dim layout As New ReportLayout = report1.Layout(New SizeF(210, 297), New Margins(20), PageOrientation.Portrait)

' Create the drawing context and the target IGraphics
Dim context As New DrawContext(report1)
Dim target As New GdiGraphics(graphics)

' Draw the page
layout.DrawPage(target, 9, context)

Inheritance Hierarchy

System.Object
MindFusion.Reporting.ReportLayout

See Also

ReportLayout Members
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout Members

ReportLayout Members
Properties Methods
[image]

Encapsulates the state of a laid out Report object. To create an instance of this class, call the Layout method of the Report class.

The following tables list the members exposed by the ReportLayout type.

Public Properties

Name | Description
PageCount | Gets the number of pages within the layout.

Public Methods

Name | Description
DrawPage | Renders the page with the specified 0-based index to the specified IGraphics object.
GetPageOrientation | Returns the orientation of the page with the specified 0-based index.
GetPageSize | Returns the size of the page with the specified 0-based index. The returned value indicates the paper size of the page, including padding, margin and content.

See Also

ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout Methods

ReportLayout Methods
[image]

Public Methods

Name | Description
DrawPage | Renders the page with the specified 0-based index to the specified IGraphics object.
GetPageOrientation | Returns the orientation of the page with the specified 0-based index.
GetPageSize | Returns the size of the page with the specified 0-based index. The returned value indicates the paper size of the page, including padding, margin and content.

See Also

ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout.DrawPage Method

ReportLayout.DrawPage Method
[image]

Renders the page with the specified 0-based index to the specified IGraphics object.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public void DrawPage (
IGraphics graphics,
int pageIndex,
DrawContext context
)

Visual Basic [image] Copy Code

Public Sub DrawPage ( _
graphics As IGraphics, _
pageIndex As Integer, _
context As DrawContext _
)

Parameters

graphics
The IGraphics object to render to page to.
pageIndex
The 0-based index of the page to render. If the index is less than 0 or greater or equal to the number of available pages, an IndexOutOfRangeException is thrown.
context
A DrawContext object.

See Also

ReportLayout Members
ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout.GetPageOrientation Method

ReportLayout.GetPageOrientation Method
[image]

Returns the orientation of the page with the specified 0-based index.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PageOrientation GetPageOrientation (
int pageIndex
)

Visual Basic [image] Copy Code

Public Function GetPageOrientation ( _
pageIndex As Integer _
) As PageOrientation

Parameters

pageIndex
The 0-based index of the page. If the index is less than 0 or greater or equal to the number of available pages, an IndexOutOfRangeException is thrown.

Return Value

A member of the PageOrientation enumeration specifying the actual orientation of the page with the specified index.

See Also

ReportLayout Members
ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout.GetPageSize Method

ReportLayout.GetPageSize Method
[image]

Returns the size of the page with the specified 0-based index. The returned value indicates the paper size of the page, including padding, margin and content.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public SizeF GetPageSize (
int pageIndex
)

Visual Basic [image] Copy Code

Public Function GetPageSize( _
pageIndex As Integer _
) As SizeF

Parameters

pageIndex
The 0-based index of the page. If the index is less than 0 or greater or equal to the number of available pages, an IndexOutOfRangeException is thrown.

Return Value

A .NET SizeF object specifying the page size.

See Also

ReportLayout Members
ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout Properties

ReportLayout Properties
[image]

Public Properties

Name | Description
PageCount | Gets the number of pages within the layout.

See Also

ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportLayout.PageCount Property

ReportLayout.PageCount Property
[image]

Gets the number of pages within the layout.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public int PageCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PageCount As Integer

Property Value

An integer value specifying the number of pages in the layout.

See Also

ReportLayout Members
ReportLayout Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportParameter Class

ReportParameter Class
Remarks See Also
[image]

Represents a parameter in a report.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class ReportParameter

Visual Basic [image] Copy Code

Public Class ReportParameter

Remarks

For more information about report parameters, check Report Parameters.

Inheritance Hierarchy

System.Object
MindFusion.Reporting.ReportParameter

See Also

ReportParameter Members
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportParameter Members

ReportParameter Members
Constructors Properties
[image]

Represents a parameter in a report.

The following tables list the members exposed by the ReportParameter type.

Public Constructors

Name | Description
ReportParameter | Overloaded. Initializes a new instance of the ReportParameter class.

Public Properties

Name | Description
Description | Gets or sets the parameter description.
Name | Gets or sets the parameter name.
Type | Gets or sets the type of the parameter value.
Value | Gets or sets the parameter value.

See Also

ReportParameter Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportParameter Constructor

ReportParameter Constructor
[image]

Initializes a new instance of the ReportParameter class.

Overload List

Name | Description
ReportParameter () | Initializes a new instance of the ReportParameter class.
ReportParameter (String, Object) | Initializes a new instance of the ReportParameter class.

See Also

ReportParameter Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportParameter Constructor ()

ReportParameter Constructor ()
See Also
[image]

Initializes a new instance of the ReportParameter class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public ReportParameter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ReportParameter Constructor Overload List
ReportParameter Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportParameter Constructor (String, Object)

ReportParameter Constructor (String, Object)
See Also
[image]

Initializes a new instance of the ReportParameter class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public ReportParameter (
string name,
Object value
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
value As Object _
)

Parameters

name

The name of the new parameter.

value

The value of the new parameter.

See Also

ReportParameter Constructor Overload List
ReportParameter Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportParameter Properties

ReportParameter Properties
[image]

Public Properties

Name | Description
Description | Gets or sets the parameter description.
Name | Gets or sets the parameter name.
Type | Gets or sets the type of the parameter value.
Value | Gets or sets the parameter value.

See Also

ReportParameter Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportParameter.Description Property

ReportParameter.Description Property
[image]

Gets or sets the parameter description.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string Description { get; set; }

Visual Basic [image] Copy Code

Public Property Description As String

Property Value

A string value.

See Also

ReportParameter Members
ReportParameter Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportParameter.Name Property

ReportParameter.Name Property
[image]

Gets or sets the parameter name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string Name { get; set; }

Visual Basic [image] Copy Code

Public Property Name As String

Property Value

A string value.

Remarks

It is recommended to specify unique names for the parameters of a report. If two or more parameters share the same name, always the first parameter will be returned inside expressions.

See Also

ReportParameter Members
ReportParameter Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportParameter.Type Property

ReportParameter.Type Property
[image]

Gets or sets the type of the parameter value.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public ReportParameterType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As ReportParameterType

Property Value

A member of the ReportParameterType enumeration. The default is String.

See Also

ReportParameter Members
ReportParameter Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportParameter.Value Property

ReportParameter.Value Property
[image]

Gets or sets the parameter value.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Object Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Object

Property Value

An object representing the parameter value.

Remarks

Assigning this property automatically updates Type to reflect the type of the parameter. To create an expression parameter, the Type property needs to be assigned to Expression explicitly. Otherwise, the value will be interpreted as string.

Example

The following example creates a parameter with an expression value:

C# [image] Copy Code

ReportParameter parameter = new ReportParameter("DayOfMonth", "[Day(Now())]");
parameter.Type = ReportParameterType.Expression;
report.Parameters.Add(parameter);

Visual Basic [image] Copy Code

Dim parameter As New ReportParameter("DayOfMonth", "[Day(Now())]")
parameter.Type = ReportParameterType.Expression
report.Parameters.Add(parameter)

See Also

ReportParameter Members
ReportParameter Class
MindFusion.Reporting Namespace


MindFusion.Reporting.ReportParameterType Enumeration

ReportParameterType Enumeration
[image]

Specifies the type of a report parameter.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public enum ReportParameterType

Visual Basic [image] Copy Code

Public Enum ReportParameterType

Members

Member name | Description
Boolean | Indicates a boolean value.
Date | Indicates a date.
Double | Indicates a double value.
Expression | Indicates an expression.
Integer | Indicates an integer value.
Text | Indicates a text value.
Unknown | Indicates a type which is not one of the predefined parameter types.

See Also

MindFusion.Reporting Namespace


MindFusion.Reporting.SerializeDataSourceEventArgs Class

SerializeDataSourceEventArgs Class
[image]

Provides data for the SerializeDataSource and DeserializeDataSource events.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class SerializeDataSourceEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class SerializeDataSourceEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Reporting.SerializeDataSourceEventArgs

See Also

SerializeDataSourceEventArgs Members
MindFusion.Reporting Namespace


MindFusion.Reporting.SerializeDataSourceEventArgs Members

SerializeDataSourceEventArgs Members
Properties
[image]

Provides data for the SerializeDataSource and DeserializeDataSource events.

The following tables list the members exposed by the SerializeDataSourceEventArgs type.

Public Properties

Name | Description
DataSource | Gets or sets the data source that is being serialized or deserialized.
Name | Gets or sets a string used to identify the data source.

See Also

SerializeDataSourceEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.SerializeDataSourceEventArgs Properties

SerializeDataSourceEventArgs Properties
[image]

Public Properties

Name | Description
DataSource | Gets or sets the data source that is being serialized or deserialized.
Name | Gets or sets a string used to identify the data source.

See Also

SerializeDataSourceEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.SerializeDataSourceEventArgs.DataSource Property

SerializeDataSourceEventArgs.DataSource Property
[image]

Gets or sets the data source that is being serialized or deserialized.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Object DataSource { get; set; }

Visual Basic [image] Copy Code

Public Property DataSource As Object

Property Value

An object representing the data source.

Remarks

During serialization this property returns the data source that is being serialized. During deserialization this property should be set to the data source object corresponding to Name.

See Also

SerializeDataSourceEventArgs Members
SerializeDataSourceEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.SerializeDataSourceEventArgs.Name Property

SerializeDataSourceEventArgs.Name Property
[image]

Gets or sets a string used to identify the data source.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string Name { get; set; }

Visual Basic [image] Copy Code

Public Property Name As String

Property Value

A string value.

Remarks

During serialization this property is expected to be set to a value that can be used to identify the data source during subsequent deserializations.

See Also

SerializeDataSourceEventArgs Members
SerializeDataSourceEventArgs Class
MindFusion.Reporting Namespace


MindFusion.Reporting.SideBySideContainer Class

SideBySideContainer Class
[image]

Represents a container that can hold side-by-side data ranges.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class SideBySideContainer : DataRange

Visual Basic [image] Copy Code

Public Class SideBySideContainer
Inherits DataRange

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Reporting.ReportItem
MindFusion.Reporting.DataRange
MindFusion.Reporting.SideBySideContainer

See Also

SideBySideContainer Members
MindFusion.Reporting Namespace


MindFusion.Reporting.SideBySideContainer Members

SideBySideContainer Members
Constructors Properties
[image]

Represents a container that can hold side-by-side data ranges.

The following tables list the members exposed by the SideBySideContainer type.

Public Constructors

Name | Description
SideBySideContainer | Initializes a new instance of the SideBySideContainer class.

Public Properties

Name | Description
AffectsParentLayout | Gets or sets a value indicating whether the parent of this item will shrink when this item is hidden as a result of PageSectionVisibility. (Inherited from ReportItem.)
AllowSplit | Gets or sets a value indicating whether this data range contents are allowed to split across several pages. (Inherited from DataRange.)
AlternatingBackground | Gets or sets the brush that will be used to fill the background of the alternating instances of this data range. (Inherited from DataRange.)
AlternatingBorder | Gets or sets the alternating border of this data range. (Inherited from DataRange.)
ArrangeByX | Gets or sets a value indicating whether to attempt to arrange the instances of this data range by the x-axis first. (Inherited from DataRange.)
Background | Gets or sets the brush that will be used to fill the data range background. (Inherited from DataRange.)
Border | Gets or sets the border of this data range. (Inherited from DataRange.)
DataMember | Gets or sets the name of the data member this range is bound to. (Inherited from DataRange.)
DataSource | Gets or sets the data source this range is bound to. (Inherited from DataRange.)
Footer | Gets or sets the footer of this data range. (Inherited from DataRange.)
Header | Gets or sets the header of this data range. (Inherited from DataRange.)
Items | Gets or sets the items contained in the DataRange. (Inherited from DataRange.)
Location | Gets or sets the position of the item. (Inherited from ReportItem.)
Margin | Gets or sets the margin of this data range, that is, the distance between the edge of this data range and the report elements adjacent to it. (Inherited from DataRange.)
MasterDetailRelation | Gets or sets the master detail relation. (Inherited from DataRange.)
Name | Gets or sets the name of the report item. (Inherited from ReportItem.)
PageSectionVisibility | Gets or set a value indicating whether this item will be visible. This only applies to items placed in page sections. (Inherited from ReportItem.)
Repeat | Gets or sets the number of occurrences of this data range. (Inherited from DataRange.)
Size | Gets or sets the size of the item. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the item will be printed in the report. (Inherited from ReportItem.)

See Also

SideBySideContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.SideBySideContainer Constructor

SideBySideContainer Constructor
[image]

Initializes a new instance of the SideBySideContainer class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public SideBySideContainer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SideBySideContainer Class
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext Class

XmlSerializationContext Class
[image]

Contains methods that can help you serialize/deserialize MindFusion.Reporting reports to/from XML documents.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public sealed class XmlSerializationContext

Visual Basic [image] Copy Code

Public NotInheritable Class XmlSerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Reporting.XmlSerializationContext

See Also

XmlSerializationContext Members
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext Members

XmlSerializationContext Members
Constructors Properties Methods Events
[image]

Contains methods that can help you serialize/deserialize MindFusion.Reporting reports to/from XML documents.

The following tables list the members exposed by the XmlSerializationContext type.

Public Constructors

Name | Description
XmlSerializationContext | Overloaded. Initializes a new instance of the XmlSerializationContext class.

Public Properties

Name | Description
XmlDocument | Gets the underlying XML document.

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node to a specified parent node.
ReadBool | Overloaded.
ReadBorder | Reads a Border with the specified name.
ReadBrush | Reads a MindFusion.Drawing.Brush object with the specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a color with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadDataSource | Reads a data source with the specified name.
ReadDateTime | Reads a DateTime object with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDimension | Reads a Dimension value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEnum | Reads an enum value with the specified name.
ReadFloat | Reads a float value with the specified name.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Reads a Font object with the specified name.
ReadHashtable | Reads a hash table object with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Reads an integer value with the specified name.
ReadLocation | Reads a Location value with the specified name.
ReadLong | Reads a long value with the specified name.
ReadMargins | Reads a Margins value with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Reads a MindFusion.Drawing.Pen object with the specified name.
ReadPointF | Reads a PointF object with the specified name.
ReadRectangleF | Reads a RectangleF object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShort | Reads a short value with the specified name.
ReadSizeF | Reads a SizeF object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Reads a string value with the specified name.
ReadStringFormat | Reads a StringFormat object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
WriteBool | Writes a boolean value with the specified name.
WriteBorder | Writes a Border with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteDataSource | Writes the specified data source.
WriteDateTime | Writes the specified DateTime object.
WriteDecimal | Write a decimal value with the specified name.
WriteDimension | Writes a Dimension value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteLocation | Writes a Location value with the specified name.
WriteLong | Writes a long value with the specified name.
WriteMargins | Writes a Margins value with the specified name.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePointF | Writes a PointF with the specified name.
WriteRectangleF | Writes a RectangleF with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a SizeF with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

Public Events

Name | Description
DeserializeDataSource | Raised during deserialization to resolve report data sources based on the string identifiers previously specified through the SerializeDataSource event.
SerializeDataSource | Raised during serialization to map the data sources referenced inside the report with string identifiers.

See Also

XmlSerializationContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext Constructor

XmlSerializationContext Constructor
[image]

Initializes a new instance of the XmlSerializationContext class.

Overload List

Name | Description
XmlSerializationContext (Report, Int32, XmlDocument) | Initializes a new instance of the XmlSerializationContext class.
XmlSerializationContext (Report, XmlDocument) | Initializes a new instance of the XmlSerializationContext class.

See Also

XmlSerializationContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext Constructor (Report, Int32, XmlDocument)

XmlSerializationContext Constructor (Report, Int32, XmlDocument)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Report report,
int fileVersion,
XmlDocument document
)

Visual Basic [image] Copy Code

Public New ( _
report As Report, _
fileVersion As Integer, _
document As XmlDocument _
)

Parameters

report

The Report this class will operate on.

fileVersion

The file version of the report being deserialized.

document

The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext Constructor (Report, XmlDocument)

XmlSerializationContext Constructor (Report, XmlDocument)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Report report,
XmlDocument document
)

Visual Basic [image] Copy Code

Public New ( _
report As Report, _
document As XmlDocument _
)

Parameters

report

The Report this class will operate on.

document

The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext Methods

XmlSerializationContext Methods
[image]

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node to a specified parent node.
ReadBool | Overloaded.
ReadBorder | Reads a Border with the specified name.
ReadBrush | Reads a MindFusion.Drawing.Brush object with the specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a color with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadDataSource | Reads a data source with the specified name.
ReadDateTime | Reads a DateTime object with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDimension | Reads a Dimension value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEnum | Reads an enum value with the specified name.
ReadFloat | Reads a float value with the specified name.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Reads a Font object with the specified name.
ReadHashtable | Reads a hash table object with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Reads an integer value with the specified name.
ReadLocation | Reads a Location value with the specified name.
ReadLong | Reads a long value with the specified name.
ReadMargins | Reads a Margins value with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Reads a MindFusion.Drawing.Pen object with the specified name.
ReadPointF | Reads a PointF object with the specified name.
ReadRectangleF | Reads a RectangleF object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShort | Reads a short value with the specified name.
ReadSizeF | Reads a SizeF object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Reads a string value with the specified name.
ReadStringFormat | Reads a StringFormat object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
WriteBool | Writes a boolean value with the specified name.
WriteBorder | Writes a Border with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteDataSource | Writes the specified data source.
WriteDateTime | Writes the specified DateTime object.
WriteDecimal | Write a decimal value with the specified name.
WriteDimension | Writes a Dimension value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteLocation | Writes a Location value with the specified name.
WriteLong | Writes a long value with the specified name.
WriteMargins | Writes a Margins value with the specified name.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePointF | Writes a PointF with the specified name.
WriteRectangleF | Writes a RectangleF with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a SizeF with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlSerializationContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext.AddChildElement Method

XmlSerializationContext.AddChildElement Method
[image]

Adds a new child node to a specified parent node.

Overload List

Name | Description
XmlSerializationContext.AddChildElement (String, XmlNode) | Adds a new child node with the specified name to the specified parent node.
XmlSerializationContext.AddChildElement (String, XmlNode, String) | Adds a new child node with the specified name and value to the specified parent node.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext.AddChildElement Method (String, XmlNode)

XmlSerializationContext.AddChildElement Method (String, XmlNode)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement AddChildElement (
string elementName,
XmlNode parentNode
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentNode As XmlNode _
) As XmlElement

Parameters

elementName

The desired name of the new node.

parentNode

The parent element of the newly created node.

Return Value

A .NET XmlElement object representing the newly created element.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext.AddChildElement Method (String, XmlNode, String)

XmlSerializationContext.AddChildElement Method (String, XmlNode, String)
See Also
[image]

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement AddChildElement (
string elementName,
XmlNode parentNode,
string innerText
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentNode As XmlNode, _
innerText As String _
) As XmlElement

Parameters

elementName

The desired name of the new node.

parentNode

The parent element of the newly created node.

innerText

The desired value of the new node.

Return Value

A .NET XmlElement object representing the newly created element.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext.ReadBool Method

XmlSerializationContext.ReadBool Method
[image]

Overload List

Name | Description
XmlSerializationContext.ReadBool (String, XmlElement) | Reads a boolean value with the specified name.
XmlSerializationContext.ReadBool (String, XmlElement, Boolean) | Reads a boolean value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext.ReadBool Method (String, XmlElement)

XmlSerializationContext.ReadBool Method (String, XmlElement)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XmlElement _
) As Boolean

Parameters

elementName

The name of the element containing the bool value.

parentElement

The parent element of the node with the specified name.

Return Value

A bool value. Returns false if there is no element with the specified name under the specified parent.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteBool Method


MindFusion.Reporting.XmlSerializationContext.ReadBool Method (String, XmlElement, Boolean)

XmlSerializationContext.ReadBool Method (String, XmlElement, Boolean)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XmlElement parentElement,
bool defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName

The name of the element containing the bool value.

parentElement

The parent element of the node with the specified name.

defaultValue

The value that should be returned if there is no node with the specified name under the specified parent element.

Return Value

A bool value.

Remarks

If there is no element with the specified name, returns the specified default value.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteBool Method


MindFusion.Reporting.XmlSerializationContext.ReadBorder Method

XmlSerializationContext.ReadBorder Method
[image]

Reads a Border with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Border ReadBorder (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBorder( _
elementName As String, _
parentElement As XmlElement _
) As Border

Parameters

elementName

The name of the element containing the value.

parentElement

The parent element of the node with the specified name.

Return Value

A Border value. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteBorder Method


MindFusion.Reporting.XmlSerializationContext.ReadBrush Method

XmlSerializationContext.ReadBrush Method
[image]

Reads a MindFusion.Drawing.Brush object with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Brush ReadBrush (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
elementName As String, _
parentElement As XmlElement _
) As Brush

Parameters

elementName

The name of the element containing the Brush object.

parentElement

The parent element of the node with the specified name.

Return Value

An instance of the MindFusion.Drawing.Brush class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteBrush Method


MindFusion.Reporting.XmlSerializationContext.ReadByte Method

XmlSerializationContext.ReadByte Method
[image]

Reads a byte value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public byte ReadByte (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadByte( _
elementName As String, _
parentElement As XmlElement _
) As Byte

Parameters

elementName

The name of the element containing the byte value.

parentElement

The parent element of the node with the specified name.

Return Value

A byte value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteByte Method


MindFusion.Reporting.XmlSerializationContext.ReadChar Method

XmlSerializationContext.ReadChar Method
[image]

Reads a char value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public char ReadChar (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadChar( _
elementName As String, _
parentElement As XmlElement _
) As Char

Parameters

elementName

The name of the element containing the char value.

parentElement

The parent element of the node with the specified name.

Return Value

A char value. Returns 'a' if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteChar Method


MindFusion.Reporting.XmlSerializationContext.ReadColor Method

XmlSerializationContext.ReadColor Method
[image]

Reads a color with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As String, _
parentElement As XmlElement _
) As Color

Parameters

elementName

The name of the element containing the .NET Color object.

parentElement

The parent element of the node with the specified name.

Return Value

A .NET Color object. Returns Black if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteColor Method


MindFusion.Reporting.XmlSerializationContext.ReadColorArray Method

XmlSerializationContext.ReadColorArray Method
[image]

Reads a color array with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Color[] ReadColorArray (
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColorArray( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Color()

Parameters

elementName

The name of the element containing the array.

subElementName

The name of the elements containing the individual array values.

parentElement

The parent element of the node with the specified name.

Return Value

An array of .NET Color objects. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteColorArray Method


MindFusion.Reporting.XmlSerializationContext.ReadDataSource Method

XmlSerializationContext.ReadDataSource Method
[image]

Reads a data source with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Object ReadDataSource (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDataSource( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName

The name of the element containing the data source.

parentElement

The parent element of the node with the specified name.

Return Value

The read data source. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent or if the object cannot be deserialized.

Remarks

This method raises the DeserializeDataSource event to allow clients to specify the data source based on the string value of the specified XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteDataSource Method
DeserializeDataSource Event


MindFusion.Reporting.XmlSerializationContext.ReadDateTime Method

XmlSerializationContext.ReadDateTime Method
[image]

Reads a DateTime object with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public DateTime ReadDateTime (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDateTime( _
elementName As String, _
parentElement As XmlElement _
) As DateTime

Parameters

elementName

The name of the element containing the .NET DateTime object.

parentElement

The parent element of the node with the specified name.

Return Value

A .NET DateTime object. Returns DateTime.MinValue if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteDateTime Method


MindFusion.Reporting.XmlSerializationContext.ReadDecimal Method

XmlSerializationContext.ReadDecimal Method
[image]

Reads a decimal value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public decimal ReadDecimal (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDecimal( _
elementName As String, _
parentElement As XmlElement _
) As Decimal

Parameters

elementName

The name of the element containing the decimal value.

parentElement

The parent element of the node with the specified name.

Return Value

A decimal value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteDecimal Method


MindFusion.Reporting.XmlSerializationContext.ReadDimension Method

XmlSerializationContext.ReadDimension Method
[image]

Reads a Dimension value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Dimension ReadDimension (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDimension( _
elementName As String, _
parentElement As XmlElement _
) As Dimension

Parameters

elementName

The name of the element containing the value.

parentElement

The parent element of the node with the specified name.

Return Value

A Dimension value. Returns Dimension.Empty if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteDimension Method


MindFusion.Reporting.XmlSerializationContext.ReadDouble Method

XmlSerializationContext.ReadDouble Method
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As String, _
parentElement As XmlElement _
) As Double

Parameters

elementName

The name of the element containing the double value.

parentElement

The parent element of the node with the specified name.

Return Value

A double value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteDouble Method


MindFusion.Reporting.XmlSerializationContext.ReadEnum Method

XmlSerializationContext.ReadEnum Method
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName

The name of the element containing the enum value.

parentElement

The parent element of the node with the specified name.

Return Value

An enum value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteEnum Method


MindFusion.Reporting.XmlSerializationContext.ReadFloat Method

XmlSerializationContext.ReadFloat Method
[image]

Reads a float value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float ReadFloat (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XmlElement _
) As Single

Parameters

elementName

The name of the element containing the float value.

parentElement

The parent element of the node with the specified name.

Return Value

A float value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteFloat Method


MindFusion.Reporting.XmlSerializationContext.ReadFloatArray Method

XmlSerializationContext.ReadFloatArray Method
[image]

Reads a float array with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float[] ReadFloatArray (
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloatArray( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Single()

Parameters

elementName

The name of the element containing the array.

subElementName

The name of the elements containing the individual array values.

parentElement

The parent element of the node with the specified name.

Return Value

An array of float values. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteFloatArray Method


MindFusion.Reporting.XmlSerializationContext.ReadFont Method

XmlSerializationContext.ReadFont Method
[image]

Reads a Font object with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Font ReadFont (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFont( _
elementName As String, _
parentElement As XmlElement _
) As Font

Parameters

elementName

The name of the element containing the .NET Font object.

parentElement

The parent element of the node with the specified name.

Return Value

A .NET Font object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteFont Method


MindFusion.Reporting.XmlSerializationContext.ReadHashtable Method

XmlSerializationContext.ReadHashtable Method
[image]

Reads a hash table object with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Hashtable ReadHashtable (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadHashtable( _
elementName As String, _
parentElement As XmlElement _
) As Hashtable

Parameters

elementName

The name of the element containing the .NET Hashtable object.

parentElement

The parent element of the node with the specified name.

Return Value

A .NET Hashtable object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteHashtable Method


MindFusion.Reporting.XmlSerializationContext.ReadImage Method

XmlSerializationContext.ReadImage Method
[image]

Reads an Image object with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Image ReadImage (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadImage( _
elementName As String, _
parentElement As XmlElement _
) As Image

Parameters

elementName

The name of the element containing the .NET Image object.

parentElement

The parent element of the node with the specified name.

Return Value

A .NET Image object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteImage Method


MindFusion.Reporting.XmlSerializationContext.ReadInt Method

XmlSerializationContext.ReadInt Method
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XmlElement _
) As Integer

Parameters

elementName

The name of the element containing the integer value.

parentElement

The parent element of the node with the specified name.

Return Value

An integer value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteInt Method


MindFusion.Reporting.XmlSerializationContext.ReadLocation Method

XmlSerializationContext.ReadLocation Method
[image]

Reads a Location value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Location ReadLocation (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadLocation( _
elementName As String, _
parentElement As XmlElement _
) As Location

Parameters

elementName

The name of the element containing the value.

parentElement

The parent element of the node with the specified name.

Return Value

A Location value. Returns Location.Empty if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteLocation Method


MindFusion.Reporting.XmlSerializationContext.ReadLong Method

XmlSerializationContext.ReadLong Method
[image]

Reads a long value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public long ReadLong (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadLong( _
elementName As String, _
parentElement As XmlElement _
) As Long

Parameters

elementName

The name of the element containing the long value.

parentElement

The parent element of the node with the specified name.

Return Value

A long value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteLong Method


MindFusion.Reporting.XmlSerializationContext.ReadMargins Method

XmlSerializationContext.ReadMargins Method
[image]

Reads a Margins value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Margins ReadMargins (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadMargins( _
elementName As String, _
parentElement As XmlElement _
) As Margins

Parameters

elementName

The name of the element containing the value.

parentElement

The parent element of the node with the specified name.

Return Value

A Margins value. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteMargins Method


MindFusion.Reporting.XmlSerializationContext.ReadObject Method

XmlSerializationContext.ReadObject Method
[image]

Reads an object with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Object ReadObject (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadObject( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName

The name of the element containing the object.

parentElement

The parent element of the node with the specified name.

Return Value

An object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent or if the object cannot be deserialized.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteObject Method


MindFusion.Reporting.XmlSerializationContext.ReadPen Method

XmlSerializationContext.ReadPen Method
[image]

Reads a MindFusion.Drawing.Pen object with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Pen ReadPen (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPen( _
elementName As String, _
parentElement As XmlElement _
) As Pen

Parameters

elementName

The name of the element containing the Pen object.

parentElement

The parent element of the node with the specified name.

Return Value

An instance of the MindFusion.Drawing.Pen class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WritePen Method


MindFusion.Reporting.XmlSerializationContext.ReadPointF Method

XmlSerializationContext.ReadPointF Method
[image]

Reads a PointF object with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PointF ReadPointF (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointF( _
elementName As String, _
parentElement As XmlElement _
) As PointF

Parameters

elementName

The name of the element containing the .NET PointF object.

parentElement

The parent element of the node with the specified name.

Return Value

A .NET PointF object. Returns PointF.Empty if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WritePointF Method


MindFusion.Reporting.XmlSerializationContext.ReadRectangleF Method

XmlSerializationContext.ReadRectangleF Method
[image]

Reads a RectangleF object with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public RectangleF ReadRectangleF (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadRectangleF( _
elementName As String, _
parentElement As XmlElement _
) As RectangleF

Parameters

elementName

The name of the element containing the RectangleF object.

parentElement

The parent element of the node with the specified name.

Return Value

A .NET RectangleF object. Returns RectangleF.Empty if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteRectangleF Method


MindFusion.Reporting.XmlSerializationContext.ReadSByte Method

XmlSerializationContext.ReadSByte Method
[image]

Reads a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public sbyte ReadSByte (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSByte( _
elementName As String, _
parentElement As XmlElement _
) As SByte

Parameters

elementName

The name of the element containing the signed byte value.

parentElement

The parent element of the node with the specified name.

Return Value

A signed byte value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteSByte Method


MindFusion.Reporting.XmlSerializationContext.ReadShort Method

XmlSerializationContext.ReadShort Method
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As String, _
parentElement As XmlElement _
) As Short

Parameters

elementName

The name of the element containing the short value.

parentElement

The parent element of the node with the specified name.

Return Value

A short value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteShort Method


MindFusion.Reporting.XmlSerializationContext.ReadSizeF Method

XmlSerializationContext.ReadSizeF Method
[image]

Reads a SizeF object with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public SizeF ReadSizeF (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSizeF( _
elementName As String, _
parentElement As XmlElement _
) As SizeF

Parameters

elementName

The name of the element containing the .NET SizeF object.

parentElement

The parent element of the node with the specified name.

Return Value

A .NET SizeF object. Returns SizeF.Empty if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteSizeF Method


MindFusion.Reporting.XmlSerializationContext.ReadStream Method

XmlSerializationContext.ReadStream Method
[image]

Reads a stream with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Stream ReadStream (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStream( _
elementName As String, _
parentElement As XmlElement _
) As Stream

Parameters

elementName

The name of the element containing the .NET Stream object.

parentElement

The parent element of the node with the specified name.

Return Value

A .NET Stream object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteStream Method


MindFusion.Reporting.XmlSerializationContext.ReadString Method

XmlSerializationContext.ReadString Method
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XmlElement _
) As String

Parameters

elementName

The name of the element containing the string value.

parentElement

The parent element of the node with the specified name.

Return Value

A string value. Returns an empty string if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteString Method


MindFusion.Reporting.XmlSerializationContext.ReadStringFormat Method

XmlSerializationContext.ReadStringFormat Method
[image]

Reads a StringFormat object with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public StringFormat ReadStringFormat (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStringFormat( _
elementName As String, _
parentElement As XmlElement _
) As StringFormat

Parameters

elementName

The name of the element containing the .NET StringFormat object.

parentElement

The parent element of the node with the specified name.

Return Value

A .NET StringFormat object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteStringFormat Method


MindFusion.Reporting.XmlSerializationContext.ReadUInt Method

XmlSerializationContext.ReadUInt Method
[image]

Reads an unsigned integer value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public uint ReadUInt (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUInt( _
elementName As String, _
parentElement As XmlElement _
) As UInteger

Parameters

elementName

The name of the element containing the unsigned integer value.

parentElement

The parent element of the node with the specified name.

Return Value

An unsigned integer value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteUInt Method


MindFusion.Reporting.XmlSerializationContext.ReadULong Method

XmlSerializationContext.ReadULong Method
[image]

Reads an unsigned long value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public ulong ReadULong (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadULong( _
elementName As String, _
parentElement As XmlElement _
) As ULong

Parameters

elementName

The name of the element containing the unsigned long value.

parentElement

The parent element of the node with the specified name.

Return Value

An unsigned long value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteULong Method


MindFusion.Reporting.XmlSerializationContext.ReadUShort Method

XmlSerializationContext.ReadUShort Method
[image]

Reads an unsigned short value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public ushort ReadUShort (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUShort( _
elementName As String, _
parentElement As XmlElement _
) As UShort

Parameters

elementName

The name of the element containing the unsigned short value.

parentElement

The parent element of the node with the specified name.

Return Value

An unsigned short value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
WriteUShort Method


MindFusion.Reporting.XmlSerializationContext.WriteBool Method

XmlSerializationContext.WriteBool Method
[image]

Writes a boolean value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteBool (
bool value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBool( _
value As Boolean, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The bool value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadBool Method


MindFusion.Reporting.XmlSerializationContext.WriteBorder Method

XmlSerializationContext.WriteBorder Method
[image]

Writes a Border with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteBorder (
Border border,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBorder( _
border As Border, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

border

The border to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadBorder Method


MindFusion.Reporting.XmlSerializationContext.WriteBrush Method

XmlSerializationContext.WriteBrush Method
[image]

Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteBrush (
Brush brush,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrush( _
brush As Brush, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

brush

The Brush instance to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadBrush Method


MindFusion.Reporting.XmlSerializationContext.WriteByte Method

XmlSerializationContext.WriteByte Method
[image]

Write a byte value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteByte (
byte value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteByte( _
value As Byte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The byte value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadByte Method


MindFusion.Reporting.XmlSerializationContext.WriteChar Method

XmlSerializationContext.WriteChar Method
[image]

Write a char value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteChar (
char value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteChar( _
value As Char, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The char value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadChar Method


MindFusion.Reporting.XmlSerializationContext.WriteColor Method

XmlSerializationContext.WriteColor Method
[image]

Writes the specified color.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteColor (
Color color,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColor( _
color As Color, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

color

The .NET Color object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadColor Method


MindFusion.Reporting.XmlSerializationContext.WriteColorArray Method

XmlSerializationContext.WriteColorArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteColorArray (
Color[] array,
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColorArray( _
array() As Color, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array

The array to write.

elementName

The name of the element under which the array should be written.

subElementName

The name of the XML elements under which the individual array values will be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadColorArray Method


MindFusion.Reporting.XmlSerializationContext.WriteDataSource Method

XmlSerializationContext.WriteDataSource Method
[image]

Writes the specified data source.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteDataSource (
Object dataSource,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDataSource( _
dataSource As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

dataSource

The data source to write.

elementName

The name of the element under which the data source be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

Remarks

This method raises the SerializeDataSource event to allow clients to specify the name under which the data source should be written.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadDataSource Method
SerializeDataSource Event


MindFusion.Reporting.XmlSerializationContext.WriteDateTime Method

XmlSerializationContext.WriteDateTime Method
[image]

Writes the specified DateTime object.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteDateTime (
DateTime value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDateTime( _
value As DateTime, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The .NET DateTime object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadDateTime Method


MindFusion.Reporting.XmlSerializationContext.WriteDecimal Method

XmlSerializationContext.WriteDecimal Method
[image]

Write a decimal value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteDecimal (
decimal value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDecimal( _
value As Decimal, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The decimal value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadDecimal Method


MindFusion.Reporting.XmlSerializationContext.WriteDimension Method

XmlSerializationContext.WriteDimension Method
[image]

Writes a Dimension value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteDimension (
Dimension dimension,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDimension( _
dimension As Dimension, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

dimension

The dimension to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadDimension Method


MindFusion.Reporting.XmlSerializationContext.WriteDouble Method

XmlSerializationContext.WriteDouble Method
[image]

Writes a double value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteDouble (
double value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDouble( _
value As Double, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The double value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadDouble Method


MindFusion.Reporting.XmlSerializationContext.WriteEnum Method

XmlSerializationContext.WriteEnum Method
[image]

Writes the specified enum value.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteEnum (
Object value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEnum( _
value As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The enum value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadEnum Method


MindFusion.Reporting.XmlSerializationContext.WriteFloat Method

XmlSerializationContext.WriteFloat Method
[image]

Writes a float value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteFloat (
float value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloat( _
value As Single, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The float value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadFloat Method


MindFusion.Reporting.XmlSerializationContext.WriteFloatArray Method

XmlSerializationContext.WriteFloatArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteFloatArray (
float[] array,
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloatArray( _
array() As Single, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array

The array to write.

elementName

The name of the element under which the array should be written.

subElementName

The name of the XML elements under which the individual array values will be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadFloatArray Method


MindFusion.Reporting.XmlSerializationContext.WriteFont Method

XmlSerializationContext.WriteFont Method
[image]

Writes the specified font.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteFont (
Font font,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFont( _
font As Font, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

font

The .NET Font object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadFont Method


MindFusion.Reporting.XmlSerializationContext.WriteHashtable Method

XmlSerializationContext.WriteHashtable Method
[image]

Writes the specified hashtable.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteHashtable (
Hashtable hashtable,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteHashtable( _
hashtable As Hashtable, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

hashtable

The .NET Hashtable object to write.

elementName

The name of the element under which the hashtable should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadHashtable Method


MindFusion.Reporting.XmlSerializationContext.WriteImage Method

XmlSerializationContext.WriteImage Method
[image]

Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteImage (
Image image,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteImage( _
image As Image, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

image

The .NET Image object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadImage Method


MindFusion.Reporting.XmlSerializationContext.WriteInt Method

XmlSerializationContext.WriteInt Method
[image]

Writes an integer value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteInt (
int value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteInt( _
value As Integer, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The integer value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadInt Method


MindFusion.Reporting.XmlSerializationContext.WriteLocation Method

XmlSerializationContext.WriteLocation Method
[image]

Writes a Location value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteLocation (
Location location,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteLocation( _
location As Location, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

location

The location to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadLocation Method


MindFusion.Reporting.XmlSerializationContext.WriteLong Method

XmlSerializationContext.WriteLong Method
[image]

Writes a long value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteLong (
long value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteLong( _
value As Long, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The long value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadLong Method


MindFusion.Reporting.XmlSerializationContext.WriteMargins Method

XmlSerializationContext.WriteMargins Method
[image]

Writes a Margins value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteMargins (
Margins margins,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteMargins( _
margins As Margins, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

margins

The margins to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadMargins Method


MindFusion.Reporting.XmlSerializationContext.WriteObject Method

XmlSerializationContext.WriteObject Method
[image]

Writes the specified object under the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteObject (
Object value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteObject( _
value As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadObject Method


MindFusion.Reporting.XmlSerializationContext.WritePen Method

XmlSerializationContext.WritePen Method
[image]

Writes the specified pen.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WritePen (
Pen pen,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePen( _
pen As Pen, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

pen

The Pen instance to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadPen Method


MindFusion.Reporting.XmlSerializationContext.WritePointF Method

XmlSerializationContext.WritePointF Method
[image]

Writes a PointF with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WritePointF (
PointF value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointF( _
value As PointF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The .NET PointF object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadPointF Method


MindFusion.Reporting.XmlSerializationContext.WriteRectangleF Method

XmlSerializationContext.WriteRectangleF Method
[image]

Writes a RectangleF with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteRectangleF (
RectangleF value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteRectangleF( _
value As RectangleF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The .NET RectangleF object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadRectangleF Method


MindFusion.Reporting.XmlSerializationContext.WriteSByte Method

XmlSerializationContext.WriteSByte Method
[image]

Write a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteSByte (
sbyte value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSByte( _
value As SByte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The signed byte value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadSByte Method


MindFusion.Reporting.XmlSerializationContext.WriteShort Method

XmlSerializationContext.WriteShort Method
[image]

Writes a short value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteShort (
short value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShort( _
value As Short, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The short value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadShort Method


MindFusion.Reporting.XmlSerializationContext.WriteSizeF Method

XmlSerializationContext.WriteSizeF Method
[image]

Writes a SizeF with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteSizeF (
SizeF value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSizeF( _
value As SizeF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The .NET SizeF object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadSizeF Method


MindFusion.Reporting.XmlSerializationContext.WriteStream Method

XmlSerializationContext.WriteStream Method
[image]

Writes the specified stream.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteStream (
Stream stream,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStream( _
stream As Stream, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stream

The .NET Stream object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadStream Method


MindFusion.Reporting.XmlSerializationContext.WriteString Method

XmlSerializationContext.WriteString Method
[image]

Writes a string value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteString (
string value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteString( _
value As String, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The string value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadString Method


MindFusion.Reporting.XmlSerializationContext.WriteStringFormat Method

XmlSerializationContext.WriteStringFormat Method
[image]

Writes the specified StringFormat object.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteStringFormat (
StringFormat stringFormat,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStringFormat( _
stringFormat As StringFormat, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stringFormat

The .NET StringFormat object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadStringFormat Method


MindFusion.Reporting.XmlSerializationContext.WriteUInt Method

XmlSerializationContext.WriteUInt Method
[image]

Writes an unsigned integer value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteUInt (
uint value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUInt( _
value As UInteger, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The unsigned integer value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadUInt Method


MindFusion.Reporting.XmlSerializationContext.WriteULong Method

XmlSerializationContext.WriteULong Method
[image]

Writes an unsigned long value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteULong (
ulong value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteULong( _
value As ULong, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The unsigned long value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadULong Method


MindFusion.Reporting.XmlSerializationContext.WriteUShort Method

XmlSerializationContext.WriteUShort Method
[image]

Writes an unsigned short value with the specified name.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlElement WriteUShort (
ushort value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUShort( _
value As UShort, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The short value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
ReadUShort Method


MindFusion.Reporting.XmlSerializationContext Properties

XmlSerializationContext Properties
[image]

Public Properties

Name | Description
XmlDocument | Gets the underlying XML document.

See Also

XmlSerializationContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext.XmlDocument Property

XmlSerializationContext.XmlDocument Property
[image]

Gets the underlying XML document.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public XmlDocument XmlDocument { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XmlDocument As XmlDocument

Property Value

A .NET XmlDocument object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext Events

XmlSerializationContext Events
[image]

Public Events

Name | Description
DeserializeDataSource | Raised during deserialization to resolve report data sources based on the string identifiers previously specified through the SerializeDataSource event.
SerializeDataSource | Raised during serialization to map the data sources referenced inside the report with string identifiers.

See Also

XmlSerializationContext Class
MindFusion.Reporting Namespace


MindFusion.Reporting.XmlSerializationContext.DeserializeDataSource Event

XmlSerializationContext.DeserializeDataSource Event
[image]

Raised during deserialization to resolve report data sources based on the string identifiers previously specified through the SerializeDataSource event.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public event EventHandler<SerializeDataSourceEventArgs> DeserializeDataSource

Visual Basic [image] Copy Code

Public Event DeserializeDataSource As EventHandler(Of SerializeDataSourceEventArgs)

Event Data

DeserializeDataSource event handlers receive an argument of type SerializeDataSourceEventArgs.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
SerializeDataSource Event


MindFusion.Reporting.XmlSerializationContext.SerializeDataSource Event

XmlSerializationContext.SerializeDataSource Event
[image]

Raised during serialization to map the data sources referenced inside the report with string identifiers.

Namespace: MindFusion.Reporting
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public event EventHandler<SerializeDataSourceEventArgs> SerializeDataSource

Visual Basic [image] Copy Code

Public Event SerializeDataSource As EventHandler(Of SerializeDataSourceEventArgs)

Event Data

SerializeDataSource event handlers receive an argument of type SerializeDataSourceEventArgs.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Reporting Namespace
DeserializeDataSource Event


MindFusion.Reporting.Export Namespace

MindFusion.Reporting.Export Namespace
Classes

Classes

Class | Description
ExcelExporter | Exports MindFusion reports to Open Office XML files.
HtmlExporter | Exports MindFusion reports to HTML files.
HtmlExporterBase | The base class for HTML exporters.
ImageEventArgs | Provides information for image-related events during HTML rendering.
ImageExporter | Exports MindFusion reports as images.
MetaTagNames | Provides common HTML meta-tag names.
MhtmlExporter | Exports MindFusion reports to MHTML files.
PdfExporter | Exports MindFusion reports to Adobe Portable Document Format (PDF) files.
RenderHtmlEventArgs | Provides information to various rendering events of the HtmlExporter, such as BeginRenderHead, EndRenderHead, and so on.


MindFusion.Reporting.Export.ExcelExporter Class

ExcelExporter Class
Remarks See Also
[image]

Exports MindFusion reports to Open Office XML files.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Excel

Syntax

C# [image] Copy Code

public class ExcelExporter

Visual Basic [image] Copy Code

Public Class ExcelExporter

Remarks

For more information on how to use the ExcelExporter, check Exporting.

Note

The Excel export relies on the Ionic.Zip library, which is based on JZlib. The following copyright notice copyright notice ExcelExporter is used.

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Export.ExcelExporter

See Also

ExcelExporter Members
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ExcelExporter Members

ExcelExporter Members
Constructors Properties Methods
[image]

Exports MindFusion reports to Open Office XML files.

The following tables list the members exposed by the ExcelExporter type.

Public Constructors

Name | Description
ExcelExporter | Initializes a new instance of the ExcelExporter class.

Public Properties

Name | Description
Margins | Gets or sets the page margins.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the page size.

Public Methods

Name | Description
Export | Creates a XLSX file representing the specified report.

See Also

ExcelExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ExcelExporter Constructor

ExcelExporter Constructor
[image]

Initializes a new instance of the ExcelExporter class.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Excel

Syntax

C# [image] Copy Code

public ExcelExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ExcelExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ExcelExporter Methods

ExcelExporter Methods
[image]

Public Methods

Name | Description
Export | Creates a XLSX file representing the specified report.

See Also

ExcelExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ExcelExporter.Export Method

ExcelExporter.Export Method
[image]

Creates a XLSX file representing the specified report.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Excel

Syntax

C# [image] Copy Code

public void Export (
Report report,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export ( _
report As Report, _
filePath As String _
)

Parameters

report

A reference to the report that will be exported.

filePath

The full path to the XLSX file.

See Also

ExcelExporter Members
ExcelExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ExcelExporter Properties

ExcelExporter Properties
[image]

Public Properties

Name | Description
Margins | Gets or sets the page margins.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the page size.

See Also

ExcelExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ExcelExporter.Margins Property

ExcelExporter.Margins Property
[image]

Gets or sets the page margins.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Excel

Syntax

C# [image] Copy Code

public Margins Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Margins

Property Value

An instance of the Margins class.

See Also

ExcelExporter Members
ExcelExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ExcelExporter.PageOrientation Property

ExcelExporter.PageOrientation Property
[image]

Gets or sets the page orientation.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Excel

Syntax

C# [image] Copy Code

public PageOrientation PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As PageOrientation

Property Value

A member of the PageOrientation enumeration.

See Also

ExcelExporter Members
ExcelExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ExcelExporter.PageSize Property

ExcelExporter.PageSize Property
[image]

Gets or sets the page size.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Excel

Syntax

C# [image] Copy Code

public SizeF PageSize { get; set; }

Visual Basic [image] Copy Code

Public Property PageSize As SizeF

Property Value

A .NET SizeF object.

See Also

ExcelExporter Members
ExcelExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter Class

HtmlExporter Class
Remarks See Also
[image]

Exports MindFusion reports to HTML files.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public class HtmlExporter : HtmlExporterBase

Visual Basic [image] Copy Code

Public Class HtmlExporter
Inherits HtmlExporterBase

Remarks

For more information on how to use the HtmlExporter, check Exporting.

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Export.HtmlExporterBase
MindFusion.Reporting.Export.HtmlExporter

See Also

HtmlExporter Members
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter Members

HtmlExporter Members
Constructors Properties Methods Events
[image]

Exports MindFusion reports to HTML files.

The following tables list the members exposed by the HtmlExporter type.

Public Constructors

Name | Description
HtmlExporter | Initializes a new instance of the HtmlExporter class.

Public Properties

Name | Description
EmbedImages | Gets or sets a value indicating whether to embed images in the HTML or copy them in a specified directory.
ImageFolder | Gets or sets the directory where the images referenced in the HTML should be copied.
Margins | Gets or sets the page margins. (Inherited from HtmlExporterBase.)
MetaTags | Gets a list with the names and values of the meta-tags to be included in the resulting HTML. (Inherited from HtmlExporterBase.)
PageOrientation | Gets or sets the page orientation. (Inherited from HtmlExporterBase.)
PageSize | Gets or sets the page size. (Inherited from HtmlExporterBase.)
RootFolder | Gets or sets the folder of the target HTML.
Title | Gets or sets the title of the resulting HTML. (Inherited from HtmlExporterBase.)

Public Methods

Name | Description
Export | Creates an HTML file representing the specified report.

Protected Methods

Name | Description
OnBeginRenderHead | Fires the BeginRenderHead event. (Inherited from HtmlExporterBase.)
OnBeginRenderReport | Fires the BeginRenderReport event. (Inherited from HtmlExporterBase.)
OnEndRenderHead | Fires the EndRenderHead event. (Inherited from HtmlExporterBase.)
OnEndRenderReport | Fires the EndRenderReport event. (Inherited from HtmlExporterBase.)
OnProcessImage | HtmlExporterBase.OnProcessImage override.

Public Events

Name | Description
BeginRenderHead | Raised before the <head> tag contents are being rendered, but after the tag itself has been appended. (Inherited from HtmlExporterBase.)
BeginRenderReport | Raised within the <body> right before rendering the report. (Inherited from HtmlExporterBase.)
EndRenderHead | Raised after the <head> tag contents are being rendered, but before the closing tag has been appended. (Inherited from HtmlExporterBase.)
EndRenderReport | Raised within the <body> right after rendering the report. (Inherited from HtmlExporterBase.)
ProcessImage | Raised when the underlying HTML is rendered in order to process a referenced image. (Inherited from HtmlExporterBase.)

See Also

HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter Constructor

HtmlExporter Constructor
[image]

Initializes a new instance of the HtmlExporter class.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public HtmlExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter Methods

HtmlExporter Methods
[image]

Public Methods

Name | Description
Export | Creates an HTML file representing the specified report.

Protected Methods

Name | Description
OnBeginRenderHead | Fires the BeginRenderHead event. (Inherited from HtmlExporterBase.)
OnBeginRenderReport | Fires the BeginRenderReport event. (Inherited from HtmlExporterBase.)
OnEndRenderHead | Fires the EndRenderHead event. (Inherited from HtmlExporterBase.)
OnEndRenderReport | Fires the EndRenderReport event. (Inherited from HtmlExporterBase.)
OnProcessImage | HtmlExporterBase.OnProcessImage override.

See Also

HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter.Export Method

HtmlExporter.Export Method
[image]

Creates an HTML file representing the specified report.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public override void Export (
Report report,
string filePath
)

Visual Basic [image] Copy Code

Public Overrides Sub Export( _
report As Report, _
filePath As String _
)

Parameters

report

A reference to the report that will be exported.

filePath

The full path to the HTML file.

Example

The following example creates an instance of the HtmlExporter class and uses it to export an existing Report object. The Report is identified by the report1 variable.

C# [image] Copy Code

HtmlExporter exporter = new HtmlExporter();

exporter.Title = "My report";
exporter.EmbedImages = false;
exporter.ImageFolder = "Images";

exporter.Export(report1, @"c:\MyReport.htm");

Visual Basic [image] Copy Code

Dim Exporter As New HtmlExporter()

exporter.Title = "My report"
exporter.EmbedImages = False
exporter.ImageFolder = "Images"

exporter.Export(report1, "c:\MyReport.htm")

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter.OnProcessImage Method

HtmlExporter.OnProcessImage Method
[image]

HtmlExporterBase.OnProcessImage override.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

protected override void OnProcessImage (
ImageEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnProcessImage( _
e As ImageEventArgs _
)

Parameters

e

An object providing the event data.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter Properties

HtmlExporter Properties
[image]

Public Properties

Name | Description
EmbedImages | Gets or sets a value indicating whether to embed images in the HTML or copy them in a specified directory.
ImageFolder | Gets or sets the directory where the images referenced in the HTML should be copied.
Margins | Gets or sets the page margins. (Inherited from HtmlExporterBase.)
MetaTags | Gets a list with the names and values of the meta-tags to be included in the resulting HTML. (Inherited from HtmlExporterBase.)
PageOrientation | Gets or sets the page orientation. (Inherited from HtmlExporterBase.)
PageSize | Gets or sets the page size. (Inherited from HtmlExporterBase.)
RootFolder | Gets or sets the folder of the target HTML.
Title | Gets or sets the title of the resulting HTML. (Inherited from HtmlExporterBase.)

See Also

HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporter.EmbedImages Property

HtmlExporter.EmbedImages Property
[image]

Gets or sets a value indicating whether to embed images in the HTML or copy them in a specified directory.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public bool EmbedImages { get; set; }

Visual Basic [image] Copy Code

Public Property EmbedImages As Boolean

Property Value

true, to embed the report images in the resulting HTML file; false, to copy the images to the folder specified through the ImageFolder property. The default is true.

Remarks

This property is ignored when exporting directly to a StringBuilder. In this case, the images are always embedded in the resulting HTML.

Note

Not all browsers can handle embedded images. Make sure the target browser supports them when using the EmbedImages property.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace
ImageFolder Property


MindFusion.Reporting.Export.HtmlExporter.ImageFolder Property

HtmlExporter.ImageFolder Property
[image]

Gets or sets the directory where the images referenced in the HTML should be copied.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public string ImageFolder { get; set; }

Visual Basic [image] Copy Code

Public Property ImageFolder As String

Property Value

A string value specifying the directory where the report images should be copied. The default is an empty string.

Remarks

This property is ignored when exporting directly to a StringBuilder. This property is also ignored when EmbedImages is set to true, indicating that the images are embedded directly in the resulting HTML.

Note

This property can contain an incomplete path. In this case, the path is interpreted as relative to the directory containing the resulting HTML.

If the property value is an empty string, the images will be copied to the directory containing the resulting HTML.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace
EmbedImages Property


MindFusion.Reporting.Export.HtmlExporter.RootFolder Property

HtmlExporter.RootFolder Property
[image]

Gets or sets the folder of the target HTML.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public string RootFolder { get; set; }

Visual Basic [image] Copy Code

Public Property RootFolder As String

Property Value

Remarks

If images are not embedded and ImageFolder is a relative path, this parameter is used as a root.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase Class

HtmlExporterBase Class
[image]

The base class for HTML exporters.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public abstract class HtmlExporterBase

Visual Basic [image] Copy Code

Public MustInherit Class HtmlExporterBase

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Export.HtmlExporterBase
MindFusion.Reporting.Export.HtmlExporter
MindFusion.Reporting.Export.MhtmlExporter

See Also

HtmlExporterBase Members
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase Members

HtmlExporterBase Members
Constructors Properties Methods Events
[image]

The base class for HTML exporters.

The following tables list the members exposed by the HtmlExporterBase type.

Protected Constructors

Name | Description
HtmlExporterBase | Initializes a new instance of the HtmlExporterBase class.

Public Properties

Name | Description
Margins | Gets or sets the page margins.
MetaTags | Gets a list with the names and values of the meta-tags to be included in the resulting HTML.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the page size.
Title | Gets or sets the title of the resulting HTML.

Public Methods

Name | Description
Export | Overloaded. Exports a report as an HTML.

Protected Methods

Name | Description
OnBeginRenderHead | Fires the BeginRenderHead event.
OnBeginRenderReport | Fires the BeginRenderReport event.
OnEndRenderHead | Fires the EndRenderHead event.
OnEndRenderReport | Fires the EndRenderReport event.
OnProcessImage | Raises the ProcessImage event.

Public Events

Name | Description
BeginRenderHead | Raised before the <head> tag contents are being rendered, but after the tag itself has been appended.
BeginRenderReport | Raised within the <body> right before rendering the report.
EndRenderHead | Raised after the <head> tag contents are being rendered, but before the closing tag has been appended.
EndRenderReport | Raised within the <body> right after rendering the report.
ProcessImage | Raised when the underlying HTML is rendered in order to process a referenced image.

See Also

HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase Constructor

HtmlExporterBase Constructor
[image]

Initializes a new instance of the HtmlExporterBase class.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

protected HtmlExporterBase ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase Methods

HtmlExporterBase Methods
[image]

Public Methods

Name | Description
Export | Overloaded. Exports a report as an HTML.

Protected Methods

Name | Description
OnBeginRenderHead | Fires the BeginRenderHead event.
OnBeginRenderReport | Fires the BeginRenderReport event.
OnEndRenderHead | Fires the EndRenderHead event.
OnEndRenderReport | Fires the EndRenderReport event.
OnProcessImage | Raises the ProcessImage event.

See Also

HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.Export Method

HtmlExporterBase.Export Method
[image]

Exports a report as an HTML.

Overload List

Name | Description
HtmlExporterBase.Export (Report, String) | Creates an output file representing the specified report.
HtmlExporterBase.Export (Report, StringBuilder) | Exports the specified report as an HTML.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.Export Method (Report, String)

HtmlExporterBase.Export Method (Report, String)
See Also
[image]

Creates an output file representing the specified report.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public virtual void Export (
Report report,
string filePath
)

Visual Basic [image] Copy Code

Public Overridable Sub Export( _
report As Report, _
filePath As String _
)

Parameters

report

A reference to the report that will be exported.

filePath

The full path to the output file.

See Also

Export Method Overload List
HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.Export Method (Report, StringBuilder)

HtmlExporterBase.Export Method (Report, StringBuilder)
See Also
[image]

Exports the specified report as an HTML.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public void Export (
Report report,
StringBuilder target
)

Visual Basic [image] Copy Code

Public Sub Export( _
report As Report, _
target As StringBuilder _
)

Parameters

report

A reference to the report that will be exported.

target

The destination StringBuilder where the report contents will be rendered.

Remarks

This method does not raise any events nor does it use many of the HTML-related properties of the HtmlExporterBase class. Check the individual property remarks for details.

See Also

Export Method Overload List
HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.OnBeginRenderHead Method

HtmlExporterBase.OnBeginRenderHead Method
[image]

Fires the BeginRenderHead event.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

protected virtual void OnBeginRenderHead (
RenderHtmlEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnBeginRenderHead( _
e As RenderHtmlEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.OnBeginRenderReport Method

HtmlExporterBase.OnBeginRenderReport Method
[image]

Fires the BeginRenderReport event.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

protected virtual void OnBeginRenderReport (
RenderHtmlEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnBeginRenderReport( _
e As RenderHtmlEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.OnEndRenderHead Method

HtmlExporterBase.OnEndRenderHead Method
[image]

Fires the EndRenderHead event.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

protected virtual void OnEndRenderHead (
RenderHtmlEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnEndRenderHead( _
e As RenderHtmlEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.OnEndRenderReport Method

HtmlExporterBase.OnEndRenderReport Method
[image]

Fires the EndRenderReport event.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

protected virtual void OnEndRenderReport (
RenderHtmlEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnEndRenderReport( _
e As RenderHtmlEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.OnProcessImage Method

HtmlExporterBase.OnProcessImage Method
[image]

Raises the ProcessImage event.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

protected virtual void OnProcessImage (
ImageEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnProcessImage( _
e As ImageEventArgs _
)

Parameters

e

An object providing the event data.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase Properties

HtmlExporterBase Properties
[image]

Public Properties

Name | Description
Margins | Gets or sets the page margins.
MetaTags | Gets a list with the names and values of the meta-tags to be included in the resulting HTML.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the page size.
Title | Gets or sets the title of the resulting HTML.

See Also

HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.Margins Property

HtmlExporterBase.Margins Property
[image]

Gets or sets the page margins.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public Margins Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Margins

Property Value

An instance of the Margins class.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.MetaTags Property

HtmlExporterBase.MetaTags Property
[image]

Gets a list with the names and values of the meta-tags to be included in the resulting HTML.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public SortedList<string, string> MetaTags { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MetaTags As SortedList(Of String, String)

Property Value

An instance of a string-to-string map containing the names and values of the meta tags to be included in the <head> of the resulting HTML.

Remarks

This property is ignored when exporting directly to a StringBuilder.

For each entry in this map a meta tag with the following structure is generated in the resulting HTML:

Copy Code

<meta name="key" content="value">

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.PageOrientation Property

HtmlExporterBase.PageOrientation Property
[image]

Gets or sets the page orientation.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public PageOrientation PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As PageOrientation

Property Value

A member of the PageOrientation enumeration.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.PageSize Property

HtmlExporterBase.PageSize Property
[image]

Gets or sets the page size.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public SizeF PageSize { get; set; }

Visual Basic [image] Copy Code

Public Property PageSize As SizeF

Property Value

A .NET SizeF object.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.Title Property

HtmlExporterBase.Title Property
[image]

Gets or sets the title of the resulting HTML.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value specifying the HTML title. The default is an empty string.

Remarks

This property is ignored when exporting directly to a StringBuilder.

If the value of this property is an empty string, the name of the resulting HTML file is used as a title.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase Events

HtmlExporterBase Events
[image]

Public Events

Name | Description
BeginRenderHead | Raised before the <head> tag contents are being rendered, but after the tag itself has been appended.
BeginRenderReport | Raised within the <body> right before rendering the report.
EndRenderHead | Raised after the <head> tag contents are being rendered, but before the closing tag has been appended.
EndRenderReport | Raised within the <body> right after rendering the report.
ProcessImage | Raised when the underlying HTML is rendered in order to process a referenced image.

See Also

HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.BeginRenderHead Event

HtmlExporterBase.BeginRenderHead Event
[image]

Raised before the <head> tag contents are being rendered, but after the tag itself has been appended.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public event EventHandler<RenderHtmlEventArgs> BeginRenderHead

Visual Basic [image] Copy Code

Public Event BeginRenderHead As EventHandler(Of RenderHtmlEventArgs)

Event Data

BeginRenderHead event handlers receive an argument of type RenderHtmlEventArgs.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.BeginRenderReport Event

HtmlExporterBase.BeginRenderReport Event
[image]

Raised within the <body> right before rendering the report.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public event EventHandler<RenderHtmlEventArgs> BeginRenderReport

Visual Basic [image] Copy Code

Public Event BeginRenderReport As EventHandler(Of RenderHtmlEventArgs)

Event Data

BeginRenderReport event handlers receive an argument of type RenderHtmlEventArgs.

Remarks

This event is raised when exporting a report through the Export method. It enables clients to write custom contents in the beginning of the <body> section of the exported HTML file.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.EndRenderHead Event

HtmlExporterBase.EndRenderHead Event
[image]

Raised after the <head> tag contents are being rendered, but before the closing tag has been appended.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public event EventHandler<RenderHtmlEventArgs> EndRenderHead

Visual Basic [image] Copy Code

Public Event EndRenderHead As EventHandler(Of RenderHtmlEventArgs)

Event Data

EndRenderHead event handlers receive an argument of type RenderHtmlEventArgs.

Remarks

This event is raised when exporting a report through the Export method. It enables clients to write custom contents at the end of the <head> section of the exported HTML file.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.EndRenderReport Event

HtmlExporterBase.EndRenderReport Event
[image]

Raised within the <body> right after rendering the report.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public event EventHandler<RenderHtmlEventArgs> EndRenderReport

Visual Basic [image] Copy Code

Public Event EndRenderReport As EventHandler(Of RenderHtmlEventArgs)

Event Data

EndRenderReport event handlers receive an argument of type RenderHtmlEventArgs.

Remarks

This event is raised when exporting a report through the Export method. It enables clients to write custom contents at the end of the <body> section of the exported HTML file.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.HtmlExporterBase.ProcessImage Event

HtmlExporterBase.ProcessImage Event
[image]

Raised when the underlying HTML is rendered in order to process a referenced image.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public event EventHandler<ImageEventArgs> ProcessImage

Visual Basic [image] Copy Code

Public Event ProcessImage As EventHandler(Of ImageEventArgs)

Event Data

ProcessImage event handlers receive an argument of type RenderHtmlEventArgs.

See Also

HtmlExporterBase Members
HtmlExporterBase Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageEventArgs Class

ImageEventArgs Class
[image]

Provides information for image-related events during HTML rendering.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public class ImageEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ImageEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Reporting.Export.ImageEventArgs

See Also

ImageEventArgs Members
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageEventArgs Members

ImageEventArgs Members
Constructors Properties
[image]

Provides information for image-related events during HTML rendering.

The following tables list the members exposed by the ImageEventArgs type.

Public Constructors

Name | Description
ImageEventArgs | Initializes a new instance of the ImageEventArgs class.

Public Properties

Name | Description
Image | Gets the image related to the event.
IsProcessed | Gets or sets a value indicating whether the image has been processed.
Url | Gets or sets the desired URL of the image.

See Also

ImageEventArgs Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageEventArgs Constructor

ImageEventArgs Constructor
[image]

Initializes a new instance of the ImageEventArgs class.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public ImageEventArgs (
Image image
)

Visual Basic [image] Copy Code

Public New ( _
image As Image _
)

Parameters

image

The image related to the event.

See Also

ImageEventArgs Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageEventArgs Properties

ImageEventArgs Properties
[image]

Public Properties

Name | Description
Image | Gets the image related to the event.
IsProcessed | Gets or sets a value indicating whether the image has been processed.
Url | Gets or sets the desired URL of the image.

See Also

ImageEventArgs Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageEventArgs.Image Property

ImageEventArgs.Image Property
[image]

Gets the image related to the event.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public Image Image { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Image As Image

Property Value

An Image object.

See Also

ImageEventArgs Members
ImageEventArgs Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageEventArgs.IsProcessed Property

ImageEventArgs.IsProcessed Property
[image]

Gets or sets a value indicating whether the image has been processed.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public bool IsProcessed { get; set; }

Visual Basic [image] Copy Code

Public Property IsProcessed As Boolean

Property Value

true to write the image using an URL as a source, as specified by the Url property; false to write the image as base-64 encoded string.

See Also

ImageEventArgs Members
ImageEventArgs Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageEventArgs.Url Property

ImageEventArgs.Url Property
[image]

Gets or sets the desired URL of the image.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public string Url { get; set; }

Visual Basic [image] Copy Code

Public Property Url As String

Property Value

A string value identifying the processed image.

Remarks

This URL will be written in the output HTML file.

See Also

ImageEventArgs Members
ImageEventArgs Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageExporter Class

ImageExporter Class
Remarks See Also
[image]

Exports MindFusion reports as images.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public class ImageExporter

Visual Basic [image] Copy Code

Public Class ImageExporter

Remarks

For more information on how to use the ImageExporter, check Exporting.

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Export.ImageExporter

See Also

ImageExporter Members
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageExporter Members

ImageExporter Members
Constructors Properties Methods
[image]

Exports MindFusion reports as images.

The following tables list the members exposed by the ImageExporter type.

Public Constructors

Name | Description
ImageExporter | Initializes a new instance of the HtmlExporter class.

Public Properties

Name | Description
Margins | Gets or sets the page margins.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the page size.
Scale | Gets or sets a scale factor for the exported image.

Public Methods

Name | Description
Export | Creates an image from the specified report.

See Also

ImageExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageExporter Constructor

ImageExporter Constructor
[image]

Initializes a new instance of the HtmlExporter class.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public ImageExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ImageExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageExporter Methods

ImageExporter Methods
[image]

Public Methods

Name | Description
Export | Creates an image from the specified report.

See Also

ImageExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageExporter.Export Method

ImageExporter.Export Method
[image]

Creates an image from the specified report.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public void Export (
Report report,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export ( _
report As Report, _
filePath As String _
)

Parameters

report

A reference to the report that will be exported.

filePath

The full path to the image file.

See Also

ImageExporter Members
ImageExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageExporter Properties

ImageExporter Properties
[image]

Public Properties

Name | Description
Margins | Gets or sets the page margins.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the page size.
Scale | Gets or sets a scale factor for the exported image.

See Also

ImageExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageExporter.Margins Property

ImageExporter.Margins Property
[image]

Gets or sets the page margins.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public Margins Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Margins

Property Value

An instance of the Margins class.

See Also

ImageExporter Members
ImageExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageExporter.PageOrientation Property

ImageExporter.PageOrientation Property
[image]

Gets or sets the page orientation.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public PageOrientation PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As PageOrientation

Property Value

A member of the PageOrientation enumeration.

See Also

ImageExporter Members
ImageExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageExporter.PageSize Property

ImageExporter.PageSize Property
[image]

Gets or sets the page size.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public SizeF PageSize { get; set; }

Visual Basic [image] Copy Code

Public Property PageSize As SizeF

Property Value

A .NET SizeF object.

See Also

ImageExporter Members
ImageExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.ImageExporter.Scale Property

ImageExporter.Scale Property
[image]

Gets or sets a scale factor for the exported image.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting

Syntax

C# [image] Copy Code

public float Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Single

Property Value

A float value specifying the scale factor.

Remarks

A value of 1 indicates that the scale of the exported image will be unchanged.

See Also

ImageExporter Members
ImageExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames Class

MetaTagNames Class
[image]

Provides common HTML meta-tag names.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public sealed class MetaTagNames

Visual Basic [image] Copy Code

Public NotInheritable Class MetaTagNames

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Export.MetaTagNames

See Also

MetaTagNames Members
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames Members

MetaTagNames Members
Fields
[image]

Provides common HTML meta-tag names.

The following tables list the members exposed by the MetaTagNames type.

Public Fields

Name | Description
Abstract | The "abstract" tag. It defines a secondary description.
Author | The "author" tag. Records the name of the author of the document.
Classification | The "classification" tag. It classifies the site into the appropriate category.
Copyright | The "copyright" tag. Used to include copyright information in the document.
Description | The "description" tag. Some search engines pick up this description to show with the results of searches.
Distribution | The "distribution" tag. Declares whether a document is available to the web or on an intranet. Possible content values are "Global", "Local", "IU".
DocClass | The "doc-class" tag. Indicates completion status of a document. Possible values are "Completed", "Draft", "Living Document", "Published".
DocRights | The "doc-rights" tag. Indicates copyright status of document. Possible values are "Copywritten Work", "Private", "Public", "Public Domain".
DocType | The "doc-type" tag. Specifies type of document. Possible content values are "Confidential Company Papers", "eZine", "Government", "Journal", "Manuscript", "Paper", "Private", "Public", "Web Page", "White Paper".
Expires | The "expires" tag. Expiration date of the document.
Generator | The "generator" tag. The name of the program that created the document.
Googlebot | The "googlebot" tag. Define pages to be excluded from googlebot indexing. Possible content values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "nosnippet", "noarchive".
Keywords | The "keywords" tag. Informs search engines what your web site or page is about.
MSSmartTagsPreventParsing | The "MSSmartTagsPreventParsing" tag. Use this tag to prevent any Microsoft product from automatically generating smart tags. Possible content value is "TRUE".
Owner | The "owner" tag. Define the owner of the page or site.
ProgId | The "progid" tag.
Rating | The "rating" tag. A simple rating for a site.
Refresh | The "refresh" tag. Indicates that the document is displayed for a specified time before switching to a new URL. The content value should be in the format "n;url", where "n" is the number of seconds to wait before loading the URL specified by "url".
ReplyTo | The "reply-to" tag. Email address of contact for document.
ResourceType | The "resource-type" tag. Indicates the type of web resource. Possible content value is "document".
RevisitAfter | The "revisit-after" tag. Defines how often search engine spiders should revisit your site.
Robots | The "robots" tag. Defines pages to be excluded from robot indexing. Possible values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "noimageindex".

See Also

MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames Fields

MetaTagNames Fields
[image]

Public Fields

Name | Description
Abstract | The "abstract" tag. It defines a secondary description.
Author | The "author" tag. Records the name of the author of the document.
Classification | The "classification" tag. It classifies the site into the appropriate category.
Copyright | The "copyright" tag. Used to include copyright information in the document.
Description | The "description" tag. Some search engines pick up this description to show with the results of searches.
Distribution | The "distribution" tag. Declares whether a document is available to the web or on an intranet. Possible content values are "Global", "Local", "IU".
DocClass | The "doc-class" tag. Indicates completion status of a document. Possible values are "Completed", "Draft", "Living Document", "Published".
DocRights | The "doc-rights" tag. Indicates copyright status of document. Possible values are "Copywritten Work", "Private", "Public", "Public Domain".
DocType | The "doc-type" tag. Specifies type of document. Possible content values are "Confidential Company Papers", "eZine", "Government", "Journal", "Manuscript", "Paper", "Private", "Public", "Web Page", "White Paper".
Expires | The "expires" tag. Expiration date of the document.
Generator | The "generator" tag. The name of the program that created the document.
Googlebot | The "googlebot" tag. Define pages to be excluded from googlebot indexing. Possible content values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "nosnippet", "noarchive".
Keywords | The "keywords" tag. Informs search engines what your web site or page is about.
MSSmartTagsPreventParsing | The "MSSmartTagsPreventParsing" tag. Use this tag to prevent any Microsoft product from automatically generating smart tags. Possible content value is "TRUE".
Owner | The "owner" tag. Define the owner of the page or site.
ProgId | The "progid" tag.
Rating | The "rating" tag. A simple rating for a site.
Refresh | The "refresh" tag. Indicates that the document is displayed for a specified time before switching to a new URL. The content value should be in the format "n;url", where "n" is the number of seconds to wait before loading the URL specified by "url".
ReplyTo | The "reply-to" tag. Email address of contact for document.
ResourceType | The "resource-type" tag. Indicates the type of web resource. Possible content value is "document".
RevisitAfter | The "revisit-after" tag. Defines how often search engine spiders should revisit your site.
Robots | The "robots" tag. Defines pages to be excluded from robot indexing. Possible values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "noimageindex".

See Also

MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Abstract Field

MetaTagNames.Abstract Field
[image]

The "abstract" tag. It defines a secondary description.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Abstract

Visual Basic [image] Copy Code

Public Shared Abstract As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Author Field

MetaTagNames.Author Field
[image]

The "author" tag. Records the name of the author of the document.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Author

Visual Basic [image] Copy Code

Public Shared Author As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Classification Field

MetaTagNames.Classification Field
[image]

The "classification" tag. It classifies the site into the appropriate category.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Classification

Visual Basic [image] Copy Code

Public Shared Classification As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Copyright Field

MetaTagNames.Copyright Field
[image]

The "copyright" tag. Used to include copyright information in the document.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Copyright

Visual Basic [image] Copy Code

Public Shared Copyright As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Description Field

MetaTagNames.Description Field
[image]

The "description" tag. Some search engines pick up this description to show with the results of searches.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Description

Visual Basic [image] Copy Code

Public Shared Description As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Distribution Field

MetaTagNames.Distribution Field
[image]

The "distribution" tag. Declares whether a document is available to the web or on an intranet. Possible content values are "Global", "Local", "IU".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Distribution

Visual Basic [image] Copy Code

Public Shared Distribution As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.DocClass Field

MetaTagNames.DocClass Field
[image]

The "doc-class" tag. Indicates completion status of a document. Possible values are "Completed", "Draft", "Living Document", "Published".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string DocClass

Visual Basic [image] Copy Code

Public Shared DocClass As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.DocRights Field

MetaTagNames.DocRights Field
[image]

The "doc-rights" tag. Indicates copyright status of document. Possible values are "Copywritten Work", "Private", "Public", "Public Domain".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string DocRights

Visual Basic [image] Copy Code

Public Shared DocRights As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.DocType Field

MetaTagNames.DocType Field
[image]

The "doc-type" tag. Specifies type of document. Possible content values are "Confidential Company Papers", "eZine", "Government", "Journal", "Manuscript", "Paper", "Private", "Public", "Web Page", "White Paper".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string DocType

Visual Basic [image] Copy Code

Public Shared DocType As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Expires Field

MetaTagNames.Expires Field
[image]

The "expires" tag. Expiration date of the document.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Expires

Visual Basic [image] Copy Code

Public Shared Expires As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Generator Field

MetaTagNames.Generator Field
[image]

The "generator" tag. The name of the program that created the document.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Generator

Visual Basic [image] Copy Code

Public Shared Generator As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Googlebot Field

MetaTagNames.Googlebot Field
[image]

The "googlebot" tag. Define pages to be excluded from googlebot indexing. Possible content values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "nosnippet", "noarchive".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Googlebot

Visual Basic [image] Copy Code

Public Shared Googlebot As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Keywords Field

MetaTagNames.Keywords Field
[image]

The "keywords" tag. Informs search engines what your web site or page is about.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Keywords

Visual Basic [image] Copy Code

Public Shared Keywords As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.MSSmartTagsPreventParsing Field

MetaTagNames.MSSmartTagsPreventParsing Field
[image]

The "MSSmartTagsPreventParsing" tag. Use this tag to prevent any Microsoft product from automatically generating smart tags. Possible content value is "TRUE".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string MSSmartTagsPreventParsing

Visual Basic [image] Copy Code

Public Shared MSSmartTagsPreventParsing As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Owner Field

MetaTagNames.Owner Field
[image]

The "owner" tag. Define the owner of the page or site.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Owner

Visual Basic [image] Copy Code

Public Shared Owner As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.ProgId Field

MetaTagNames.ProgId Field
[image]

The "progid" tag.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string ProgId

Visual Basic [image] Copy Code

Public Shared ProgId As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Rating Field

MetaTagNames.Rating Field
[image]

The "rating" tag. A simple rating for a site.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Rating

Visual Basic [image] Copy Code

Public Shared Rating As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Refresh Field

MetaTagNames.Refresh Field
[image]

The "refresh" tag. Indicates that the document is displayed for a specified time before switching to a new URL. The content value should be in the format "n;url", where "n" is the number of seconds to wait before loading the URL specified by "url".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Refresh

Visual Basic [image] Copy Code

Public Shared Refresh As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.ReplyTo Field

MetaTagNames.ReplyTo Field
[image]

The "reply-to" tag. Email address of contact for document.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string ReplyTo

Visual Basic [image] Copy Code

Public Shared ReplyTo As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.ResourceType Field

MetaTagNames.ResourceType Field
[image]

The "resource-type" tag. Indicates the type of web resource. Possible content value is "document".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string ResourceType

Visual Basic [image] Copy Code

Public Shared ResourceType As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.RevisitAfter Field

MetaTagNames.RevisitAfter Field
[image]

The "revisit-after" tag. Defines how often search engine spiders should revisit your site.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string RevisitAfter

Visual Basic [image] Copy Code

Public Shared RevisitAfter As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MetaTagNames.Robots Field

MetaTagNames.Robots Field
[image]

The "robots" tag. Defines pages to be excluded from robot indexing. Possible values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "noimageindex".

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public static string Robots

Visual Basic [image] Copy Code

Public Shared Robots As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MhtmlExporter Class

MhtmlExporter Class
[image]

Exports MindFusion reports to MHTML files.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public class MhtmlExporter : HtmlExporterBase

Visual Basic [image] Copy Code

Public Class MhtmlExporter
Inherits HtmlExporterBase

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Export.HtmlExporterBase
MindFusion.Reporting.Export.MhtmlExporter

See Also

MhtmlExporter Members
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MhtmlExporter Members

MhtmlExporter Members
Constructors Properties Methods Events
[image]

Exports MindFusion reports to MHTML files.

The following tables list the members exposed by the MhtmlExporter type.

Public Constructors

Name | Description
MhtmlExporter | Initializes a new instance of the MhtmlExporter class.

Public Properties

Name | Description
Margins | Gets or sets the page margins. (Inherited from HtmlExporterBase.)
MetaTags | Gets a list with the names and values of the meta-tags to be included in the resulting HTML. (Inherited from HtmlExporterBase.)
PageOrientation | Gets or sets the page orientation. (Inherited from HtmlExporterBase.)
PageSize | Gets or sets the page size. (Inherited from HtmlExporterBase.)
Title | Gets or sets the title of the resulting HTML. (Inherited from HtmlExporterBase.)

Public Methods

Name | Description
Export | Overloaded. Exports a report as an HTML. (Inherited from HtmlExporterBase.)

Protected Methods

Name | Description
OnBeginRenderHead | Fires the BeginRenderHead event. (Inherited from HtmlExporterBase.)
OnBeginRenderReport | Fires the BeginRenderReport event. (Inherited from HtmlExporterBase.)
OnEndRenderHead | Fires the EndRenderHead event. (Inherited from HtmlExporterBase.)
OnEndRenderReport | Fires the EndRenderReport event. (Inherited from HtmlExporterBase.)
OnProcessImage | HtmlExporterBase.OnProcessImage override.

Public Events

Name | Description
BeginRenderHead | Raised before the <head> tag contents are being rendered, but after the tag itself has been appended. (Inherited from HtmlExporterBase.)
BeginRenderReport | Raised within the <body> right before rendering the report. (Inherited from HtmlExporterBase.)
EndRenderHead | Raised after the <head> tag contents are being rendered, but before the closing tag has been appended. (Inherited from HtmlExporterBase.)
EndRenderReport | Raised within the <body> right after rendering the report. (Inherited from HtmlExporterBase.)
ProcessImage | Raised when the underlying HTML is rendered in order to process a referenced image. (Inherited from HtmlExporterBase.)

See Also

MhtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MhtmlExporter Constructor

MhtmlExporter Constructor
[image]

Initializes a new instance of the MhtmlExporter class.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public MhtmlExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MhtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MhtmlExporter Methods

MhtmlExporter Methods
[image]

Public Methods

Name | Description
Export | Overloaded. Exports a report as an HTML. (Inherited from HtmlExporterBase.)

Protected Methods

Name | Description
OnBeginRenderHead | Fires the BeginRenderHead event. (Inherited from HtmlExporterBase.)
OnBeginRenderReport | Fires the BeginRenderReport event. (Inherited from HtmlExporterBase.)
OnEndRenderHead | Fires the EndRenderHead event. (Inherited from HtmlExporterBase.)
OnEndRenderReport | Fires the EndRenderReport event. (Inherited from HtmlExporterBase.)
OnProcessImage | HtmlExporterBase.OnProcessImage override.

See Also

MhtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.MhtmlExporter.OnProcessImage Method

MhtmlExporter.OnProcessImage Method
[image]

HtmlExporterBase.OnProcessImage override.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

protected override void OnProcessImage (
ImageEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnProcessImage( _
e As ImageEventArgs _
)

Parameters

e

An object providing the event data.

See Also

MhtmlExporter Members
MhtmlExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter Class

PdfExporter Class
Remarks See Also
[image]

Exports MindFusion reports to Adobe Portable Document Format (PDF) files.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Pdf

Syntax

C# [image] Copy Code

public class PdfExporter

Visual Basic [image] Copy Code

Public Class PdfExporter

Remarks

For more information on how to use the PdfExporter, check Exporting.

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Export.PdfExporter

See Also

PdfExporter Members
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter Members

PdfExporter Members
Constructors Properties Methods
[image]

Exports MindFusion reports to Adobe Portable Document Format (PDF) files.

The following tables list the members exposed by the PdfExporter type.

Public Constructors

Name | Description
PdfExporter | Initializes a new instance of the PdfExporter class.

Public Properties

Name | Description
Margins | Gets or sets the page margins.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the page size.

Public Methods

Name | Description
Export | Creates a PDF file representing the specified report.

See Also

PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter Constructor

PdfExporter Constructor
[image]

Initializes a new instance of the PdfExporter class.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Pdf

Syntax

C# [image] Copy Code

public PdfExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter Methods

PdfExporter Methods
[image]

Public Methods

Name | Description
Export | Creates a PDF file representing the specified report.

See Also

PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter.Export Method

PdfExporter.Export Method
[image]

Creates a PDF file representing the specified report.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Pdf

Syntax

C# [image] Copy Code

public void Export (
Report report,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export ( _
report As Report, _
filePath As String _
)

Parameters

report

A reference to the report that will be exported.

filePath

The full path to the PDF file.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter Properties

PdfExporter Properties
[image]

Public Properties

Name | Description
Margins | Gets or sets the page margins.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the page size.

See Also

PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter.Margins Property

PdfExporter.Margins Property
[image]

Gets or sets the page margins.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Pdf

Syntax

C# [image] Copy Code

public Margins Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Margins

Property Value

An instance of the Margins class.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter.PageOrientation Property

PdfExporter.PageOrientation Property
[image]

Gets or sets the page orientation.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Pdf

Syntax

C# [image] Copy Code

public PageOrientation PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As PageOrientation

Property Value

A member of the PageOrientation enumeration.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.PdfExporter.PageSize Property

PdfExporter.PageSize Property
[image]

Gets or sets the page size.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Pdf

Syntax

C# [image] Copy Code

public SizeF PageSize { get; set; }

Visual Basic [image] Copy Code

Public Property PageSize As SizeF

Property Value

A .NET SizeF object.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.RenderHtmlEventArgs Class

RenderHtmlEventArgs Class
[image]

Provides information to various rendering events of the HtmlExporter, such as BeginRenderHead, EndRenderHead, and so on.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public class RenderHtmlEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class RenderHtmlEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Reporting.Export.RenderHtmlEventArgs

See Also

RenderHtmlEventArgs Members
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.RenderHtmlEventArgs Members

RenderHtmlEventArgs Members
Properties
[image]

Provides information to various rendering events of the HtmlExporter, such as BeginRenderHead, EndRenderHead, and so on.

The following tables list the members exposed by the RenderHtmlEventArgs type.

Public Properties

Name | Description
Target | Gets the rendering target.

See Also

RenderHtmlEventArgs Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.RenderHtmlEventArgs Properties

RenderHtmlEventArgs Properties
[image]

Public Properties

Name | Description
Target | Gets the rendering target.

See Also

RenderHtmlEventArgs Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.Export.RenderHtmlEventArgs.Target Property

RenderHtmlEventArgs.Target Property
[image]

Gets the rendering target.

Namespace: MindFusion.Reporting.Export
Assembly: MindFusion.Reporting.Html

Syntax

C# [image] Copy Code

public StringBuilder Target { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Target As StringBuilder

Property Value

An instance of the .NET StringBuilder class. Use this object to render the custom HTML contents to.

See Also

RenderHtmlEventArgs Members
RenderHtmlEventArgs Class
MindFusion.Reporting.Export Namespace


MindFusion.Reporting.WinForms Namespace

MindFusion.Reporting.WinForms Namespace
Classes Interfaces Enumerations

Classes

Class | Description
MenuCommands | Provides additional menu commands for the ReportEditor control.
PreviewOptions | Provides properties that allow customization of various aspects of the extended print-preview window.
PrintPreviewForm | Implements an extended print preview form.
ReportCanvas | Represents a control that can display a MindFusion.Reporting.Report object.
ReportEditor | Represents a control that can create and edit MindFusion.Reporting reports.
ReportPrinter | Serves as a PrintDocument for MindFusion.Reporting.Report components.
ReportViewer | Represents a scrollable control that can display a MindFusion.Reporting.Report objects.
ScrollViewer | Represents a control that can host another control and provide scrolling capabilities if the hosted control is larger than the client area.

Interfaces

Interface | Description
ICommandListener | Represents an object that can listen to changes of a menu command.

Enumerations

Enumeration | Description
ReportEditorTabPage | Specifies one of the tab pages in the ReportEditor.


MindFusion.Reporting.WinForms.ICommandListener Interface

ICommandListener Interface
[image]

Represents an object that can listen to changes of a menu command.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public interface ICommandListener

Visual Basic [image] Copy Code

Public Interface ICommandListener

See Also

ICommandListener Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ICommandListener Members

ICommandListener Members
Methods
[image]

Represents an object that can listen to changes of a menu command.

The following tables list the members exposed by the ICommandListener type.

Public Methods

Name | Description
UpdateState | Called when the state of the command has changed.

See Also

ICommandListener Interface
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ICommandListener Methods

ICommandListener Methods
[image]

Public Methods

Name | Description
UpdateState | Called when the state of the command has changed.

See Also

ICommandListener Interface
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ICommandListener.UpdateState Method

ICommandListener.UpdateState Method
[image]

Called when the state of the command has changed.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

void UpdateState (
bool enabled,
bool visible
)

Visual Basic [image] Copy Code

Sub UpdateState( _
enabled As Boolean, _
visible As Boolean _
)

Parameters

enabled

A flag indicating whether the command is enabled.

visible

A flag indicating whether the command is visible.

See Also

ICommandListener Members
ICommandListener Interface
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.MenuCommands Class

MenuCommands Class
[image]

Provides additional menu commands for the ReportEditor control.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public sealed class MenuCommands

Visual Basic [image] Copy Code

Public NotInheritable Class MenuCommands

Inheritance Hierarchy

System.Object
MindFusion.Reporting.WinForms.MenuCommands

See Also

MenuCommands Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.MenuCommands Members

MenuCommands Members
Fields
[image]

Provides additional menu commands for the ReportEditor control.

The following tables list the members exposed by the MenuCommands type.

Public Fields

Name | Description
ToolboxWindow | Identifies the ToolboxWindow menu command.

See Also

MenuCommands Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.MenuCommands Fields

MenuCommands Fields
[image]

Public Fields

Name | Description
ToolboxWindow | Identifies the ToolboxWindow menu command.

See Also

MenuCommands Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.MenuCommands.ToolboxWindow Field

MenuCommands.ToolboxWindow Field
[image]

Identifies the ToolboxWindow menu command.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public static readonly CommandID ToolboxWindow

Visual Basic [image] Copy Code

Public Shared ReadOnly ToolboxWindow As CommandID

See Also

MenuCommands Members
MenuCommands Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions Class

PreviewOptions Class
[image]

Provides properties that allow customization of various aspects of the extended print-preview window.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public sealed class PreviewOptions

Visual Basic [image] Copy Code

Public NotInheritable Class PreviewOptions

Inheritance Hierarchy

System.Object
MindFusion.Reporting.WinForms.PreviewOptions

See Also

PreviewOptions Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions Members

PreviewOptions Members
Constructors Properties
[image]

Provides properties that allow customization of various aspects of the extended print-preview window.

The following tables list the members exposed by the PreviewOptions type.

Public Constructors

Name | Description
PreviewOptions | Initializes a new instance of the PreviewOptions class.

Public Properties

Name | Description
ButtonImages | Gets or sets the list of images to display in print preview toolbar buttons.
DisplayPrintDialog | Get or sets a value indicating whether a print setup dialog box is displayed when the print button of the preview form is clicked.
FirstPageToolTip | Gets or sets the ToolTip text displayed for the First Page button.
FitToPageToolTip | Gets or sets the ToolTip text displayed for the Fit to Page button.
FourPagesToolTip | Gets or sets the ToolTip text displayed for the Four Pages button.
LandscapeToolTip | Gets or sets the ToolTip text displayed for the Landscape button.
LastPageToolTip | Gets or sets the ToolTip text displayed for the Last Page button.
NextPageToolTip | Gets or sets the ToolTip text displayed for the Next Page button.
OnePageToolTip | Gets or sets the ToolTip text displayed for the One Page button.
PortraitToolTip | Gets or sets the ToolTip text displayed for the Portrait button.
PreviousPageToolTip | Gets or sets the ToolTip text displayed for the Previous Page button.
PrintToolTip | Gets or sets the ToolTip text displayed for the Print button.
SixPagesToolTip | Gets or sets the ToolTip text displayed for the Six Pages button.
ThreePagesToolTip | Gets or sets the ToolTip text displayed for the Three Pages button.
TitleBarIcon | Gets or sets the icon displayed in the titlebar of the preview window.
TwoPagesToolTip | Gets or sets the ToolTip text displayed for the Two Pages button.
ZoomAutoCmdText | Gets or sets the Label of the Zoom menu Auto item.
ZoomToolTip | Gets or sets the ToolTip text displayed for the Zoom button.

See Also

PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions Constructor

PreviewOptions Constructor
[image]

Initializes a new instance of the PreviewOptions class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public PreviewOptions ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions Properties

PreviewOptions Properties
[image]

Public Properties

Name | Description
ButtonImages | Gets or sets the list of images to display in print preview toolbar buttons.
DisplayPrintDialog | Get or sets a value indicating whether a print setup dialog box is displayed when the print button of the preview form is clicked.
FirstPageToolTip | Gets or sets the ToolTip text displayed for the First Page button.
FitToPageToolTip | Gets or sets the ToolTip text displayed for the Fit to Page button.
FourPagesToolTip | Gets or sets the ToolTip text displayed for the Four Pages button.
LandscapeToolTip | Gets or sets the ToolTip text displayed for the Landscape button.
LastPageToolTip | Gets or sets the ToolTip text displayed for the Last Page button.
NextPageToolTip | Gets or sets the ToolTip text displayed for the Next Page button.
OnePageToolTip | Gets or sets the ToolTip text displayed for the One Page button.
PortraitToolTip | Gets or sets the ToolTip text displayed for the Portrait button.
PreviousPageToolTip | Gets or sets the ToolTip text displayed for the Previous Page button.
PrintToolTip | Gets or sets the ToolTip text displayed for the Print button.
SixPagesToolTip | Gets or sets the ToolTip text displayed for the Six Pages button.
ThreePagesToolTip | Gets or sets the ToolTip text displayed for the Three Pages button.
TitleBarIcon | Gets or sets the icon displayed in the titlebar of the preview window.
TwoPagesToolTip | Gets or sets the ToolTip text displayed for the Two Pages button.
ZoomAutoCmdText | Gets or sets the Label of the Zoom menu Auto item.
ZoomToolTip | Gets or sets the ToolTip text displayed for the Zoom button.

See Also

PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.ButtonImages Property

PreviewOptions.ButtonImages Property
[image]

Gets or sets the list of images to display in print preview toolbar buttons.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public ImageList ButtonImages { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonImages As ImageList

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.DisplayPrintDialog Property

PreviewOptions.DisplayPrintDialog Property
[image]

Get or sets a value indicating whether a print setup dialog box is displayed when the print button of the preview form is clicked.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public bool DisplayPrintDialog { get; set; }

Visual Basic [image] Copy Code

Public Property DisplayPrintDialog As Boolean

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.FirstPageToolTip Property

PreviewOptions.FirstPageToolTip Property
[image]

Gets or sets the ToolTip text displayed for the First Page button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string FirstPageToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property FirstPageToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.FitToPageToolTip Property

PreviewOptions.FitToPageToolTip Property
[image]

Gets or sets the ToolTip text displayed for the Fit to Page button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string FitToPageToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property FitToPageToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.FourPagesToolTip Property

PreviewOptions.FourPagesToolTip Property
[image]

Gets or sets the ToolTip text displayed for the Four Pages button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string FourPagesToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property FourPagesToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.LandscapeToolTip Property

PreviewOptions.LandscapeToolTip Property
[image]

Gets or sets the ToolTip text displayed for the Landscape button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string LandscapeToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property LandscapeToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.LastPageToolTip Property

PreviewOptions.LastPageToolTip Property
[image]

Gets or sets the ToolTip text displayed for the Last Page button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string LastPageToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property LastPageToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.NextPageToolTip Property

PreviewOptions.NextPageToolTip Property
[image]

Gets or sets the ToolTip text displayed for the Next Page button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string NextPageToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property NextPageToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.OnePageToolTip Property

PreviewOptions.OnePageToolTip Property
[image]

Gets or sets the ToolTip text displayed for the One Page button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string OnePageToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property OnePageToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.PortraitToolTip Property

PreviewOptions.PortraitToolTip Property
[image]

Gets or sets the ToolTip text displayed for the Portrait button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string PortraitToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property PortraitToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.PreviousPageToolTip Property

PreviewOptions.PreviousPageToolTip Property
[image]

Gets or sets the ToolTip text displayed for the Previous Page button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string PreviousPageToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property PreviousPageToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.PrintToolTip Property

PreviewOptions.PrintToolTip Property
[image]

Gets or sets the ToolTip text displayed for the Print button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string PrintToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property PrintToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.SixPagesToolTip Property

PreviewOptions.SixPagesToolTip Property
[image]

Gets or sets the ToolTip text displayed for the Six Pages button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string SixPagesToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property SixPagesToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.ThreePagesToolTip Property

PreviewOptions.ThreePagesToolTip Property
[image]

Gets or sets the ToolTip text displayed for the Three Pages button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string ThreePagesToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property ThreePagesToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.TitleBarIcon Property

PreviewOptions.TitleBarIcon Property
[image]

Gets or sets the icon displayed in the titlebar of the preview window.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public Icon TitleBarIcon { get; set; }

Visual Basic [image] Copy Code

Public Property TitleBarIcon As Icon

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.TwoPagesToolTip Property

PreviewOptions.TwoPagesToolTip Property
[image]

Gets or sets the ToolTip text displayed for the Two Pages button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string TwoPagesToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property TwoPagesToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.ZoomAutoCmdText Property

PreviewOptions.ZoomAutoCmdText Property
[image]

Gets or sets the Label of the Zoom menu Auto item.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string ZoomAutoCmdText { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomAutoCmdText As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PreviewOptions.ZoomToolTip Property

PreviewOptions.ZoomToolTip Property
[image]

Gets or sets the ToolTip text displayed for the Zoom button.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string ZoomToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomToolTip As String

Property Value

See Also

PreviewOptions Members
PreviewOptions Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Class

PrintPreviewForm Class
[image]

Implements an extended print preview form.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public class PrintPreviewForm : Form

Visual Basic [image] Copy Code

Public Class PrintPreviewForm
Inherits Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
MindFusion.Reporting.WinForms.PrintPreviewForm

See Also

PrintPreviewForm Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Members

PrintPreviewForm Members
Constructors Properties Methods
[image]

Implements an extended print preview form.

The following tables list the members exposed by the PrintPreviewForm type.

Public Constructors

Name | Description
PrintPreviewForm | Overloaded. Initializes a new instance of the PrintPreviewForm class.

Public Properties

Name | Description
Document | Gets or sets the internal version of the document.
UseAntiAlias | Gets or sets the anti-alias flag on the preview control.

Protected Methods

Name | Description
Dispose | Form.Dispose override.
OnLoad | Form.OnLoad override.

See Also

PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Constructor

PrintPreviewForm Constructor
[image]

Initializes a new instance of the PrintPreviewForm class.

Overload List

Name | Description
PrintPreviewForm () | Initializes a new instance of the PrintPreviewForm class.
PrintPreviewForm (String, PreviewOptions) | Initializes a new instance of the PrintPreviewForm class.

See Also

PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Constructor ()

PrintPreviewForm Constructor ()
See Also
[image]

Initializes a new instance of the PrintPreviewForm class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public PrintPreviewForm ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PrintPreviewForm Constructor Overload List
PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Constructor (String, PreviewOptions)

PrintPreviewForm Constructor (String, PreviewOptions)
See Also
[image]

Initializes a new instance of the PrintPreviewForm class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public PrintPreviewForm (
string documentName,
PreviewOptions options
)

Visual Basic [image] Copy Code

Public New ( _
documentName As String, _
options As PreviewOptions _
)

Parameters

documentName

options

See Also

PrintPreviewForm Constructor Overload List
PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Methods

PrintPreviewForm Methods
[image]

Protected Methods

Name | Description
Dispose | Form.Dispose override.
OnLoad | Form.OnLoad override.

See Also

PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm.Dispose Method

PrintPreviewForm.Dispose Method
[image]

Form.Dispose override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

protected override void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overrides Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing

See Also

PrintPreviewForm Members
PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm.OnLoad Method

PrintPreviewForm.OnLoad Method
[image]

Form.OnLoad override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

protected override void OnLoad (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnLoad( _
e As EventArgs _
)

Parameters

e

See Also

PrintPreviewForm Members
PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm Properties

PrintPreviewForm Properties
[image]

Public Properties

Name | Description
Document | Gets or sets the internal version of the document.
UseAntiAlias | Gets or sets the anti-alias flag on the preview control.

See Also

PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm.Document Property

PrintPreviewForm.Document Property
[image]

Gets or sets the internal version of the document.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public PrintDocument Document { get; set; }

Visual Basic [image] Copy Code

Public Property Document As PrintDocument

Property Value

See Also

PrintPreviewForm Members
PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.PrintPreviewForm.UseAntiAlias Property

PrintPreviewForm.UseAntiAlias Property
[image]

Gets or sets the anti-alias flag on the preview control.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public bool UseAntiAlias { get; set; }

Visual Basic [image] Copy Code

Public Property UseAntiAlias As Boolean

Property Value

See Also

PrintPreviewForm Members
PrintPreviewForm Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas Class

ReportCanvas Class
[image]

Represents a control that can display a MindFusion.Reporting.Report object.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public class ReportCanvas : Control, IScrollable

Visual Basic [image] Copy Code

Public Class ReportCanvas
Inherits Control
Implements IScrollable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Reporting.WinForms.ReportCanvas

See Also

ReportCanvas Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas Members

ReportCanvas Members
Constructors Properties Methods Events
[image]

Represents a control that can display a MindFusion.Reporting.Report object.

The following tables list the members exposed by the ReportCanvas type.

Public Constructors

Name | Description
ReportCanvas | Initializes a new instance of the ReportCanvas class.

Public Properties

Name | Description
Margins | Gets or sets the margins of the displayed pages, expressed in millimeters.
PaperSize | Gets or sets the size of the pages displayed on the canvas, expressed in millimeters.
Report | Gets or sets a reference to the associated MindFusion.Reporting.Report object.
ScrollPosition | IScrollable.ScrollPosition implementation.
ScrollRange | IScrollable.ScrollRange implementation.

Public Methods

Name | Description
Recalc | Causes the control to recalculate all internals and repaint its client area.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnPaint | Control.OnPaint override.

Public Events

Name | Description
ScrollRangeChanged | IScrollable.ScrollRangeChanged implementation.

See Also

ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas Constructor

ReportCanvas Constructor
[image]

Initializes a new instance of the ReportCanvas class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public ReportCanvas ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas Methods

ReportCanvas Methods
[image]

Public Methods

Name | Description
Recalc | Causes the control to recalculate all internals and repaint its client area.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnPaint | Control.OnPaint override.

See Also

ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.Dispose Method

ReportCanvas.Dispose Method
[image]

Clean up any resources being used.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

protected override void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overrides Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.OnPaint Method

ReportCanvas.OnPaint Method
[image]

Control.OnPaint override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

protected override void OnPaint (
PaintEventArgs pe
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPaint( _
pe As PaintEventArgs _
)

Parameters

pe

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.Recalc Method

ReportCanvas.Recalc Method
[image]

Causes the control to recalculate all internals and repaint its client area.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public void Recalc (
int pageNum,
SizeF pageSize
)

Visual Basic [image] Copy Code

Public Sub Recalc( _
pageNum As Integer, _
pageSize As SizeF _
)

Parameters

pageNum

pageSize

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas Properties

ReportCanvas Properties
[image]

Public Properties

Name | Description
Margins | Gets or sets the margins of the displayed pages, expressed in millimeters.
PaperSize | Gets or sets the size of the pages displayed on the canvas, expressed in millimeters.
Report | Gets or sets a reference to the associated MindFusion.Reporting.Report object.
ScrollPosition | IScrollable.ScrollPosition implementation.
ScrollRange | IScrollable.ScrollRange implementation.

See Also

ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.Margins Property

ReportCanvas.Margins Property
[image]

Gets or sets the margins of the displayed pages, expressed in millimeters.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public Margins Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Margins

Property Value

An instance of the Margins class. The default is (20, 20, 20, 20).

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.PaperSize Property

ReportCanvas.PaperSize Property
[image]

Gets or sets the size of the pages displayed on the canvas, expressed in millimeters.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public SizeF PaperSize { get; set; }

Visual Basic [image] Copy Code

Public Property PaperSize As SizeF

Property Value

An instance of the SizeF structure. The default is (210, 297) – the A4 paper size.

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.Report Property

ReportCanvas.Report Property
[image]

Gets or sets a reference to the associated MindFusion.Reporting.Report object.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public Report Report { get; set; }

Visual Basic [image] Copy Code

Public Property Report As Report

Property Value

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.ScrollPosition Property

ReportCanvas.ScrollPosition Property
[image]

IScrollable.ScrollPosition implementation.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public Point ScrollPosition { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollPosition As Point

Property Value

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.ScrollRange Property

ReportCanvas.ScrollRange Property
[image]

IScrollable.ScrollRange implementation.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public Size ScrollRange { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScrollRange As Size

Property Value

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas Events

ReportCanvas Events
[image]

Public Events

Name | Description
ScrollRangeChanged | IScrollable.ScrollRangeChanged implementation.

See Also

ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportCanvas.ScrollRangeChanged Event

ReportCanvas.ScrollRangeChanged Event
[image]

IScrollable.ScrollRangeChanged implementation.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public event EventHandler ScrollRangeChanged

Visual Basic [image] Copy Code

Public Event ScrollRangeChanged As EventHandler

Event Data

EndRenderReport event handlers receive an argument of type EventArgs.

See Also

ReportCanvas Members
ReportCanvas Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor Class

ReportEditor Class
Remarks See Also
[image]

Represents a control that can create and edit MindFusion.Reporting reports.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public class ReportEditor : UserControl

Visual Basic [image] Copy Code

Public Class ReportEditor
Inherits UserControl

Remarks

For additional information about this class, refer to the ReportEditor Control topic.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
MindFusion.Reporting.WinForms.ReportEditor

See Also

ReportEditor Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor Members

ReportEditor Members
Constructors Properties Methods Events
[image]

Represents a control that can create and edit MindFusion.Reporting reports.

The following tables list the members exposed by the ReportEditor type.

Public Constructors

Name | Description
ReportEditor | Initializes a new instance of the ReportEditor class.

Public Properties

Name | Description
ActiveTabPage | Gets or sets the active tab page in the editor.
IsDesignerFocused | Gets a value indicating whether the report designer area inside the editor is focused.
IsReportDirty | Gets a value indicating whether the report is modified.
Report | Gets a Report instance representing the edited report.
ShowPreview | Gets or sets a value indicating whether the Preview tab page is visible.
ShowPropertiesWindow | Gets or sets a value indicating whether the Properties window is visible.
ShowPropertiesWindowContextMenu | Gets or sets a value indicating whether to dispay the context menu of the properties window.
ShowToolboxWindow | Gets or sets a value indicating whether the Toolbox window is visible.

Public Methods

Name | Description
AddDataSource | Overloaded. Adds an external data source to the editor.
CloseReport | Closes the currently edited report, if any.
GetService | Gets the service of the specified type, if it is available.
InvokeCommand | Invokes the command with the specified identifier.
NewReport | Creates a blank report inside the editor. The currently edited report is discarded.
OpenReport | Opens the report from the file with the specified name for editing.
Redo | Redoes the last undone action.
RegisterCommandListener | Establishes an association with the specified command.
RemoveDataSource | Removes the specified data source from the editor.
ResumePreviewUpdate | Resumes automatic updates on the report preview.
RunReport | Runs the underlying report if it is necessary.
SaveReport | Saves the currently edited report to a file with the specified name.
SuspendPreviewUpdate | Suspends automatic updates on the report preview.
Undo | Undoes the last action.
UnregisterCommandListener | Removes a previously associated listener with the specified command.
UpdatePreview | Updates the preview by running the report.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnPreviewUpdated | Raises the PreviewUpdated event.
OnPreviewUpdating | Raises the PreviewUpdating event.
OnReportDirtyChanged | Raises the ReportDirtyChanged event.
ProcessCmdKey | ContainerControl.ProcessCmdKey override.

Public Events

Name | Description
PreviewUpdated | Raised after the preview window has been updated.
PreviewUpdating | Raised when the preview window is about to be updated.
ReportDirtyChanged | Raised when the 'dirty' state of the report changes.

See Also

ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor Constructor

ReportEditor Constructor
[image]

Initializes a new instance of the ReportEditor class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public ReportEditor ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor Methods

ReportEditor Methods
[image]

Public Methods

Name | Description
AddDataSource | Overloaded. Adds an external data source to the editor.
CloseReport | Closes the currently edited report, if any.
GetService | Gets the service of the specified type, if it is available.
InvokeCommand | Invokes the command with the specified identifier.
NewReport | Creates a blank report inside the editor. The currently edited report is discarded.
OpenReport | Opens the report from the file with the specified name for editing.
Redo | Redoes the last undone action.
RegisterCommandListener | Establishes an association with the specified command.
RemoveDataSource | Removes the specified data source from the editor.
ResumePreviewUpdate | Resumes automatic updates on the report preview.
RunReport | Runs the underlying report if it is necessary.
SaveReport | Saves the currently edited report to a file with the specified name.
SuspendPreviewUpdate | Suspends automatic updates on the report preview.
Undo | Undoes the last action.
UnregisterCommandListener | Removes a previously associated listener with the specified command.
UpdatePreview | Updates the preview by running the report.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnPreviewUpdated | Raises the PreviewUpdated event.
OnPreviewUpdating | Raises the PreviewUpdating event.
OnReportDirtyChanged | Raises the ReportDirtyChanged event.
ProcessCmdKey | ContainerControl.ProcessCmdKey override.

See Also

ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.AddDataSource Method

ReportEditor.AddDataSource Method
[image]

Adds an external data source to the editor.

Overload List

Name | Description
ReportEditor.AddDataSource (Object) | Adds a new data source to the editor.
ReportEditor.AddDataSource (Object, String) | Adds a new data source with the specified name to the editor.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.AddDataSource Method (Object)

ReportEditor.AddDataSource Method (Object)
See Also
[image]

Adds a new data source to the editor.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public IComponent AddDataSource (
Object dataSource
)

Visual Basic [image] Copy Code

Public Function AddDataSource( _
dataSource As Object _
) As IComponent

Parameters

dataSource

The data source to add.

Return Value

The component representing the specified data source inside the editor.

Remarks

If the specified data source is a component (for example, DataSet), it is directly added to the editor. If the data source is not a component (for example an array of business objects), a BindingSource object is automatically created and added to the editor.

See Also

AddDataSource Method Overload List
ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace
RemoveDataSource Method


MindFusion.Reporting.WinForms.ReportEditor.AddDataSource Method (Object, String)

ReportEditor.AddDataSource Method (Object, String)
See Also
[image]

Adds a new data source with the specified name to the editor.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public IComponent AddDataSource (
Object dataSource,
string name
)

Visual Basic [image] Copy Code

Public Function AddDataSource( _
dataSource As Object, _
name As String _
) As IComponent

Parameters

dataSource

The data source to add.

name

The name of the data source in the designer. This name is also used to identify the data source when the report is saved to or loaded from a file.

Return Value

The component representing the specified data source inside the editor.

Remarks

If the specified data source is a component (for example, DataSet), it is directly added to the editor. If the data source is not a component (for example an array of business objects), a BindingSource object is automatically created and added to the editor.

Note

The specified name needs to be unique amongst all components in the editor (previously registered data sources included). Specifying an existing name will cause an ArgumentException to be raised.

When it is not possible to guarantee that the name of a data source is unique, use the other AddDataSource overload instead. This overload assigns a new unique name to the data source component. The name can be subsequently obtained through the Component.Site.Name of the returned IComponent.

See Also

AddDataSource Method Overload List
ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace
RemoveDataSource Method


MindFusion.Reporting.WinForms.ReportEditor.CloseReport Method

ReportEditor.CloseReport Method
[image]

Closes the currently edited report, if any.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public void CloseReport ()

Visual Basic [image] Copy Code

Public Sub CloseReport ()

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.Dispose Method

ReportEditor.Dispose Method
[image]

Clean up any resources being used.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

protected override void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overrides Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing

true if managed resources should be disposed; otherwise, false.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.GetService(T) Method

ReportEditor.GetService(T) Method
[image]

Gets the service of the specified type, if it is available.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public T GetService<T> ()

Visual Basic [image] Copy Code

Public Function GetService(Of T) () As T

Return Value

An object implementing the requested service, or null (Nothing in Visual Basic), if the service cannot be found.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.InvokeCommand Method

ReportEditor.InvokeCommand Method
[image]

Invokes the command with the specified identifier.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public bool InvokeCommand (
CommandID command
)

Visual Basic [image] Copy Code

Public Function InvokeCommand( _
command As CommandID _
) As Boolean

Parameters

command

The identifier of the command to invoke.

Return Value

true, if the command was found; otherwise, false.

Remarks

The report editor supports an array of standard menu commands, including the following:

CommandID | Description
AlignBottom | Aligns the bottom sides of the currently selected components.
AlignHorizontalCenters | Aligns the horizontal centers of the currently selected components.
AlignLeft | Aligns the left sides of the currently selected components.
AlignRight | Aligns the right sides of the currently selected components.
AlignTop | Aligns the top sides of the currently selected components.
AlignVerticalCenters | Aligns the vertical centers of the currently selected components.
BringToFront | Brings the currently selected components at the top of the z-order.
CenterHorizontally | Centers the currently selected components horizontally inside their respective parents.
CenterVertically | Centers the currently selected components vertically inside their respective parents.
Copy | Copies the selected components to the clipboard.
Cut | Cuts the selected components.
Delete | Deletes the selected components.
HorizSpaceConcatenate | Removes the horizontal spacing between the currently selected components. The primary selected component remains stationary.
HorizSpaceDecrease | Decreases the horizontal spacing between the currently selected components. The primary selected component remains stationary.
HorizSpaceIncrease | Increases the horizontal spacing between the currently selected components. The primary selected component remains stationary.
HorizSpaceMakeEqual | Makes the horizontal spacing between the currently selected components equal. The leftmost and rightmost components remain stationary.
Paste | Pastes the components in the clipboard.
PropertiesWindow | Displays and focuses the Properties window.
Redo | Redoes the last undone operation.
SendToBack | Sends the currently selected components at the bottom of the z-order.
SizeToControl | Makes the size of the currently selected components the same as the size of the primary selected component.
SizeToControlHeight | Makes the height of the currently selected components the same as the height of the primary selected component.
SizeToControlWidth | Makes the width of the currently selected components the same as the width of the primary selected component.
Undo | Undoes the most recent operation.
VertSpaceConcatenate | Removes the vertical spacing between the currently selected components. The primary selected component remains stationary.
VertSpaceDecrease | Decreases the vertical spacing between the currently selected components. The primary selected component remains stationary.
VertSpaceIncrease | Increases the vertical spacing between the currently selected components. The primary selected component remains stationary.
VertSpaceMakeEqual | Makes the vertical spacing between the currently selected components equal. The topmost and bottommost components remain stationary.

In addition, the editor supports the custom menu commands from the MenuCommands class.

To invoke a command, call the InvokeCommand method and pass the command identifier as an argument. For example, the following code invokes the standard BringToFront command.

C# [image] Copy Code

editor.InvokeCommand(StandardCommands.BringToFront);

Visual Basic [image] Copy Code

editor.InvokeCommand(StandardCommands.BringToFront)

Alternatively, the commands can be invoked through the MenuCommandService, which can be obtained from the editor through the GetService method.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.NewReport Method

ReportEditor.NewReport Method
[image]

Creates a blank report inside the editor. The currently edited report is discarded.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public void NewReport ()

Visual Basic [image] Copy Code

Public Sub NewReport ()

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.OnPreviewUpdated Method

ReportEditor.OnPreviewUpdated Method
[image]

Raises the PreviewUpdated event.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

protected virtual void OnPreviewUpdated (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPreviewUpdated( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.OnPreviewUpdating Method

ReportEditor.OnPreviewUpdating Method
[image]

Raises the PreviewUpdating event.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

protected virtual void OnPreviewUpdating (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPreviewUpdating( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.OnReportDirtyChanged Method

ReportEditor.OnReportDirtyChanged Method
[image]

Raises the ReportDirtyChanged event.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

protected virtual void OnReportDirtyChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnReportDirtyChanged( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.OpenReport Method

ReportEditor.OpenReport Method
[image]

Opens the report from the file with the specified name for editing.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public void OpenReport (
string fileName
)

Visual Basic [image] Copy Code

Public Sub OpenReport( _
fileName As String _
)

Parameters

fileName

The file containing the report to open.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.ProcessCmdKey Method

ReportEditor.ProcessCmdKey Method
[image]

ContainerControl.ProcessCmdKey override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

protected override bool ProcessCmdKey (
ref Message msg,
Keys keyData
)

Visual Basic [image] Copy Code

Protected Overrides Function ProcessCmdKey( _
ByRef msg As Message, _
keyData As Keys _
) As Boolean

Parameters

msg

A System.Windows.Forms.Message, passed by reference, that represents the window message to process.

keyData

true if the character was processed by the control; otherwise, false.

Return Value

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.Redo Method

ReportEditor.Redo Method
[image]

Redoes the last undone action.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public void Redo ()

Visual Basic [image] Copy Code

Public Sub Redo ()

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace
Undo Method


MindFusion.Reporting.WinForms.ReportEditor.RegisterCommandListener Method

ReportEditor.RegisterCommandListener Method
[image]

Establishes an association with the specified command.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public void RegisterCommandListener (
CommandID id,
ICommandListener listener
)

Visual Basic [image] Copy Code

Public Sub RegisterCommandListener( _
id As CommandID, _
listener As ICommandListener _
)

Parameters

id

The command to associate.

listener

The command listener to notify when the command with the specified id changes.

Remarks

This method is useful to synchronize the state of various UI elements in an application with their associated commands. When the state of a command changes, its registered listeners are notified. For more information, refer to the ReportEditor Control topic.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace
UnregisterCommandListener Method


MindFusion.Reporting.WinForms.ReportEditor.RemoveDataSource Method

ReportEditor.RemoveDataSource Method
[image]

Removes the specified data source from the editor.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public void RemoveDataSource (
Object dataSource
)

Visual Basic [image] Copy Code

Public Sub RemoveDataSource( _
dataSource As Object _
)

Parameters

dataSource

The data source to remove.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.ResumePreviewUpdate Method

ReportEditor.ResumePreviewUpdate Method
[image]

Resumes automatic updates on the report preview.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public void ResumePreviewUpdate ()

Visual Basic [image] Copy Code

Public Sub ResumePreviewUpdate ()

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace
SuspendPreviewUpdate Method


MindFusion.Reporting.WinForms.ReportEditor.RunReport Method

ReportEditor.RunReport Method
[image]

Runs the underlying report if it is necessary.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public void RunReport ()

Visual Basic [image] Copy Code

Public Sub RunReport ()

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.SaveReport Method

ReportEditor.SaveReport Method
[image]

Saves the currently edited report to a file with the specified name.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public void SaveReport (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveReport( _
fileName As String _
)

Parameters

fileName

The name of the file to save the report to.

Remarks

Saving the report automatically clears the IsReportDirty flag.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.SuspendPreviewUpdate Method

ReportEditor.SuspendPreviewUpdate Method
[image]

Suspends automatic updates on the report preview.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public void SuspendPreviewUpdate ()

Visual Basic [image] Copy Code

Public Sub SuspendPreviewUpdate ()

Remarks

The Preview is updated automatically when one of the following happens: the report is modified, a new report is created or an existing report is opened. However, the Preview is never updated if the Preview tab page is not active.

It is useful to suspend the preview during a block of programmatic changes to the report while the Preview tab page is active.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace
ResumePreviewUpdate Method


MindFusion.Reporting.WinForms.ReportEditor.Undo Method

ReportEditor.Undo Method
[image]

Undoes the last action.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public void Undo ()

Visual Basic [image] Copy Code

Public Sub Undo ()

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace
Redo Method


MindFusion.Reporting.WinForms.ReportEditor.UnregisterCommandListener Method

ReportEditor.UnregisterCommandListener Method
[image]

Removes a previously associated listener with the specified command.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public void UnregisterCommandListener (
CommandID id
)

Visual Basic [image] Copy Code

Public Sub UnregisterCommandListener( _
id As CommandID _
)

Parameters

id

The command to dissociate.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace
RegisterCommandListener Method


MindFusion.Reporting.WinForms.ReportEditor.UpdatePreview Method

ReportEditor.UpdatePreview Method
[image]

Updates the preview by running the report.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public bool UpdatePreview ()

Visual Basic [image] Copy Code

Public Function UpdatePreview () As Boolean

Return Value

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor Properties

ReportEditor Properties
[image]

Public Properties

Name | Description
ActiveTabPage | Gets or sets the active tab page in the editor.
IsDesignerFocused | Gets a value indicating whether the report designer area inside the editor is focused.
IsReportDirty | Gets a value indicating whether the report is modified.
Report | Gets a Report instance representing the edited report.
ShowPreview | Gets or sets a value indicating whether the Preview tab page is visible.
ShowPropertiesWindow | Gets or sets a value indicating whether the Properties window is visible.
ShowPropertiesWindowContextMenu | Gets or sets a value indicating whether to dispay the context menu of the properties window.
ShowToolboxWindow | Gets or sets a value indicating whether the Toolbox window is visible.

See Also

ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.ActiveTabPage Property

ReportEditor.ActiveTabPage Property
[image]

Gets or sets the active tab page in the editor.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public ReportEditorTabPage ActiveTabPage { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveTabPage As ReportEditorTabPage

Property Value

A member of the ReportEditorTabPage enumeration. The default is Design.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.IsDesignerFocused Property

ReportEditor.IsDesignerFocused Property
[image]

Gets a value indicating whether the report designer area inside the editor is focused.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public bool IsDesignerFocused { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsDesignerFocused As Boolean

Property Value

true if the designer area holds the input focus; otherwise, false.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.IsReportDirty Property

ReportEditor.IsReportDirty Property
[image]

Gets a value indicating whether the report is modified.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public bool IsReportDirty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsReportDirty As Boolean

Property Value

true if the report is modified after it was created, opened or saved; otherwise, false.

Remarks

This value of this property is automatically updated when the report is opened, saved or changed.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.Report Property

ReportEditor.Report Property
[image]

Gets a Report instance representing the edited report.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public Report Report { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Report As Report

Property Value

A reference to the underlying Report object.

Remarks

This property cannot be set and the returned instance is always the same object.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.ShowPreview Property

ReportEditor.ShowPreview Property
[image]

Gets or sets a value indicating whether the Preview tab page is visible.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public bool ShowPreview { get; set; }

Visual Basic [image] Copy Code

Public Property ShowPreview As Boolean

Property Value

true to show the Preview tab page inside the editor; otherwise, false. The default is true.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.ShowPropertiesWindow Property

ReportEditor.ShowPropertiesWindow Property
[image]

Gets or sets a value indicating whether the Properties window is visible.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public bool ShowPropertiesWindow { get; set; }

Visual Basic [image] Copy Code

Public Property ShowPropertiesWindow As Boolean

Property Value

true to show the Properties window inside the editor; otherwise, false. The default is true.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.ShowPropertiesWindowContextMenu Property

ReportEditor.ShowPropertiesWindowContextMenu Property
[image]

Gets or sets a value indicating whether to dispay the context menu of the properties window.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public bool ShowPropertiesWindowContextMenu { get; set; }

Visual Basic [image] Copy Code

Public Property ShowPropertiesWindowContextMenu As Boolean

Property Value

true to display the context menu when the user right-clicks inside the property window; otherwise, false. The default is true.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.ShowToolboxWindow Property

ReportEditor.ShowToolboxWindow Property
[image]

Gets or sets a value indicating whether the Toolbox window is visible.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public bool ShowToolboxWindow { get; set; }

Visual Basic [image] Copy Code

Public Property ShowToolboxWindow As Boolean

Property Value

true to display the Toolox window inside the editor; otherwise, false. The default is true.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor Events

ReportEditor Events
[image]

Public Events

Name | Description
PreviewUpdated | Raised after the preview window has been updated.
PreviewUpdating | Raised when the preview window is about to be updated.
ReportDirtyChanged | Raised when the 'dirty' state of the report changes.

See Also

ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditor.PreviewUpdated Event

ReportEditor.PreviewUpdated Event
[image]

Raised after the preview window has been updated.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public event EventHandler PreviewUpdated

Visual Basic [image] Copy Code

Public Event PreviewUpdated As EventHandler

Event Data

PreviewUpdated event handlers receive an argument of type EventArgs.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace
PreviewUpdating Event


MindFusion.Reporting.WinForms.ReportEditor.PreviewUpdating Event

ReportEditor.PreviewUpdating Event
[image]

Raised when the preview window is about to be updated.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public event EventHandler PreviewUpdating

Visual Basic [image] Copy Code

Public Event PreviewUpdating As EventHandler

Event Data

PreviewUpdating event handlers receive an argument of type EventArgs.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace
PreviewUpdated Event


MindFusion.Reporting.WinForms.ReportEditor.ReportDirtyChanged Event

ReportEditor.ReportDirtyChanged Event
[image]

Raised when the 'dirty' state of the report changes.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public event EventHandler ReportDirtyChanged

Visual Basic [image] Copy Code

Public Event ReportDirtyChanged As EventHandler

Event Data

ReportDirtyChanged event handlers receive an argument of type EventArgs.

See Also

ReportEditor Members
ReportEditor Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportEditorTabPage Enumeration

ReportEditorTabPage Enumeration
[image]

Specifies one of the tab pages in the ReportEditor.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.Editor

Syntax

C# [image] Copy Code

public enum ReportEditorTabPage

Visual Basic [image] Copy Code

Public Enum ReportEditorTabPage

Members

Member name | Description
Design | Indicates the Design tab page.
Preview | Indicates the Preview tab page.

See Also

MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Class

ReportPrinter Class
[image]

Serves as a PrintDocument for MindFusion.Reporting.Report components.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public class ReportPrinter : PrintDocument

Visual Basic [image] Copy Code

Public Class ReportPrinter
Inherits PrintDocument

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Drawing.Printing.PrintDocument
MindFusion.Reporting.WinForms.ReportPrinter

See Also

ReportPrinter Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Members

ReportPrinter Members
Constructors Properties Methods
[image]

Serves as a PrintDocument for MindFusion.Reporting.Report components.

The following tables list the members exposed by the ReportPrinter type.

Public Constructors

Name | Description
ReportPrinter | Overloaded.

Public Properties

Name | Description
Report | Gets or sets the Report associated with this print document.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnBeginPrint | PrintDocument.OnBeginPrint override.
OnPrintPage | PrintDocument.OnPrintPage override.
OnQueryPageSettings | PrintDocument.OnQueryPageSettings override.

See Also

ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Constructor

ReportPrinter Constructor
[image]

Overload List

Name | Description
ReportPrinter () | Initializes a new instance of the ReportPrinter class.
ReportPrinter (IContainer) | Initializes a new instance of the ReportPrinter class.

See Also

ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Constructor ()

ReportPrinter Constructor ()
See Also
[image]

Initializes a new instance of the ReportPrinter class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public ReportPrinter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ReportPrinter Constructor Overload List
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Constructor (IContainer)

ReportPrinter Constructor (IContainer)
See Also
[image]

Initializes a new instance of the ReportPrinter class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public ReportPrinter (
IContainer container
)

Visual Basic [image] Copy Code

Public New ( _
container As IContainer _
)

Parameters

container

See Also

ReportPrinter Constructor Overload List
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Methods

ReportPrinter Methods
[image]

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnBeginPrint | PrintDocument.OnBeginPrint override.
OnPrintPage | PrintDocument.OnPrintPage override.
OnQueryPageSettings | PrintDocument.OnQueryPageSettings override.

See Also

ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter.Dispose Method

ReportPrinter.Dispose Method
[image]

Clean up any resources being used.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

protected override void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overrides Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter.OnBeginPrint Method

ReportPrinter.OnBeginPrint Method
[image]

PrintDocument.OnBeginPrint override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

protected override void OnBeginPrint (
PrintEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnBeginPrint( _
e As PrintEventArgs _
)

Parameters

e

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter.OnPrintPage Method

ReportPrinter.OnPrintPage Method
[image]

PrintDocument.OnPrintPage override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

protected override void OnPrintPage (
PrintPageEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPrintPage( _
e As PrintPageEventArgs _
)

Parameters

e

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter.OnQueryPageSettings Method

ReportPrinter.OnQueryPageSettings Method
[image]

PrintDocument.OnQueryPageSettings override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

protected override void OnQueryPageSettings (
QueryPageSettingsEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnQueryPageSettings( _
e As QueryPageSettingsEventArgs _
)

Parameters

e

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter Properties

ReportPrinter Properties
[image]

Public Properties

Name | Description
Report | Gets or sets the Report associated with this print document.

See Also

ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportPrinter.Report Property

ReportPrinter.Report Property
[image]

Gets or sets the Report associated with this print document.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public Report Report { get; set; }

Visual Basic [image] Copy Code

Public Property Report As Report

Property Value

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer Class

ReportViewer Class
[image]

Represents a scrollable control that can display a MindFusion.Reporting.Report objects.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public class ReportViewer : UserControl

Visual Basic [image] Copy Code

Public Class ReportViewer
Inherits UserControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
MindFusion.Reporting.WinForms.ReportViewer

See Also

ReportViewer Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer Members

ReportViewer Members
Constructors Properties Methods
[image]

Represents a scrollable control that can display a MindFusion.Reporting.Report objects.

The following tables list the members exposed by the ReportViewer type.

Public Constructors

Name | Description
ReportViewer | Initializes a new instance of the ReportViewer class.

Public Properties

Name | Description
LicenseKey | Gets or sets the license key of the control.
Margins | Gets or sets the margins of the pages displayed in the viewer, expressed in millimeters.
PaperSize | Gets or sets the size of the pages displayed in the viewer, expressed in millimeters.
Report | Gets or sets a reference to the Report displayed in the viewer.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnInvalidated | Control.OnInvalidated override.

See Also

ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer Constructor

ReportViewer Constructor
[image]

Initializes a new instance of the ReportViewer class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public ReportViewer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer Methods

ReportViewer Methods
[image]

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnInvalidated | Control.OnInvalidated override.

See Also

ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer.Dispose Method

ReportViewer.Dispose Method
[image]

Clean up any resources being used.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

protected override void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overrides Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

ReportViewer Members
ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer.OnInvalidated Method

ReportViewer.OnInvalidated Method
[image]

Control.OnInvalidated override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

protected override void OnInvalidated (
InvalidateEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnInvalidated( _
e As InvalidateEventArgs _
)

Parameters

e

See Also

ReportViewer Members
ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer Properties

ReportViewer Properties
[image]

Public Properties

Name | Description
LicenseKey | Gets or sets the license key of the control.
Margins | Gets or sets the margins of the pages displayed in the viewer, expressed in millimeters.
PaperSize | Gets or sets the size of the pages displayed in the viewer, expressed in millimeters.
Report | Gets or sets a reference to the Report displayed in the viewer.

See Also

ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer.LicenseKey Property

ReportViewer.LicenseKey Property
[image]

Gets or sets the license key of the control.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public string LicenseKey { get; set; }

Visual Basic [image] Copy Code

Public Property LicenseKey As String

Property Value

See Also

ReportViewer Members
ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer.Margins Property

ReportViewer.Margins Property
[image]

Gets or sets the margins of the pages displayed in the viewer, expressed in millimeters.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public Margins Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Margins

Property Value

An instance of the Margins class.

See Also

ReportViewer Members
ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer.PaperSize Property

ReportViewer.PaperSize Property
[image]

Gets or sets the size of the pages displayed in the viewer, expressed in millimeters.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public SizeF PaperSize { get; set; }

Visual Basic [image] Copy Code

Public Property PaperSize As SizeF

Property Value

An instance of the SizeF structure.

See Also

ReportViewer Members
ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ReportViewer.Report Property

ReportViewer.Report Property
[image]

Gets or sets a reference to the Report displayed in the viewer.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public Report Report { get; set; }

Visual Basic [image] Copy Code

Public Property Report As Report

Property Value

An instance of the Report class.

See Also

ReportViewer Members
ReportViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer Class

ScrollViewer Class
[image]

Represents a control that can host another control and provide scrolling capabilities if the hosted control is larger than the client area.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public class ScrollViewer : UserControl

Visual Basic [image] Copy Code

Public Class ScrollViewer
Inherits UserControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
MindFusion.Reporting.WinForms.ScrollViewer

See Also

ScrollViewer Members
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer Members

ScrollViewer Members
Constructors Properties Methods
[image]

Represents a control that can host another control and provide scrolling capabilities if the hosted control is larger than the client area.

The following tables list the members exposed by the ScrollViewer type.

Public Constructors

Name | Description
ScrollViewer | Initializes a new instance of the ScrollViewer class.

Public Properties

Name | Description
ScrollableControl | Gets or sets a reference to the hosted control.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnLayout | ContainerControl.OnLayout override.

See Also

ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer Constructor

ScrollViewer Constructor
[image]

Initializes a new instance of the ScrollViewer class.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public ScrollViewer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer Methods

ScrollViewer Methods
[image]

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnLayout | ContainerControl.OnLayout override.

See Also

ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer.Dispose Method

ScrollViewer.Dispose Method
[image]

Clean up any resources being used.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

protected override void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overrides Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing

true if managed resources should be disposed; otherwise, false.

See Also

ScrollViewer Members
ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer.OnLayout Method

ScrollViewer.OnLayout Method
[image]

ContainerControl.OnLayout override.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

protected override void OnLayout (
LayoutEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnLayout( _
e As LayoutEventArgs _
)

Parameters

e

See Also

ScrollViewer Members
ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer Properties

ScrollViewer Properties
[image]

Public Properties

Name | Description
ScrollableControl | Gets or sets a reference to the hosted control.

See Also

ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Reporting.WinForms.ScrollViewer.ScrollableControl Property

ScrollViewer.ScrollableControl Property
[image]

Gets or sets a reference to the hosted control.

Namespace: MindFusion.Reporting.WinForms
Assembly: MindFusion.Reporting.WinForms

Syntax

C# [image] Copy Code

public Control ScrollableControl { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollableControl As Control

Property Value

See Also

ScrollViewer Members
ScrollViewer Class
MindFusion.Reporting.WinForms Namespace


MindFusion.Scripting Namespace

MindFusion.Scripting Namespace
Classes

Classes

Class | Description
ByteCode | Encapsulates the compiled result of a parsed tree and performs evaluations against that compiled result in various contexts.
CompileOptions | Contains options for the Compiler.Compile method.
Compiler | Provides methods for compiling expressions to byte code.
EvaluateFunctionEventArgs | Contains the arguments passed to DispatchFunctionCall event handlers.
EvaluationContext | Provides a context for evaluating a byte code.
ParseObjectEventArgs | Contains the arguments passed to ParseObject event handlers.


MindFusion.Scripting.ByteCode Class

ByteCode Class
Remarks See Also
[image]

Encapsulates the compiled result of a parsed tree and performs evaluations against that compiled result in various contexts.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public sealed class ByteCode

Visual Basic [image] Copy Code

Public NotInheritable Class ByteCode

Remarks

This class cannot be instantiated directly. To obtain an instance, call one of the Compile methods of the Compiler class.

Inheritance Hierarchy

System.Object
MindFusion.Scripting.ByteCode

See Also

ByteCode Members
MindFusion.Scripting Namespace


MindFusion.Scripting.ByteCode Members

ByteCode Members
Properties Methods
[image]

Encapsulates the compiled result of a parsed tree and performs evaluations against that compiled result in various contexts.

The following tables list the members exposed by the ByteCode type.

Public Properties

Name | Description
Identifiers | Gets the list with all identifiers within the code. There is no guarantee that this list will contain unique entries, thus, if an identifier is encountered several times in the initial sequence, it will appear several times in the returned list.

Public Methods

Name | Description
Empty | Creates and returns an empty byte code. Evaluating empty byte code will produce null (Nothing in Visual Basic) as a result.
Evaluate | Evaluates the byte code in the specified context.

See Also

ByteCode Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ByteCode Methods

ByteCode Methods
[image]

Public Methods

Name | Description
Empty | Creates and returns an empty byte code. Evaluating empty byte code will produce null (Nothing in Visual Basic) as a result.
Evaluate | Evaluates the byte code in the specified context.

See Also

ByteCode Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ByteCode.Empty Method

ByteCode.Empty Method
[image]

Creates and returns an empty byte code. Evaluating empty byte code will produce null (Nothing in Visual Basic) as a result.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public static ByteCode Empty ()

Visual Basic [image] Copy Code

Public Shared Function Empty () As ByteCode

Return Value

An empty instance of the ByteCode class.

Remarks

Calling this method multiple times will return different instances.

See Also

ByteCode Members
ByteCode Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ByteCode.Evaluate Method

ByteCode.Evaluate Method
[image]

Evaluates the byte code in the specified context.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Object Evaluate (
EvaluationContext context
)

Visual Basic [image] Copy Code

Public Function Evaluate ( _
context As EvaluationContext _
) As Object

Parameters

context
An instance of the EvaluationContext class providing evaluation context, such as culture, target object and parameters.

Return Value

The result of the evaluation, possibly null (Nothing in Visual Basic).

See Also

ByteCode Members
ByteCode Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ByteCode Properties

ByteCode Properties
[image]

Public Properties

Name | Description
Identifiers | Gets the list with all identifiers within the code. There is no guarantee that this list will contain unique entries, thus, if an identifier is encountered several times in the initial sequence, it will appear several times in the returned list.

See Also

ByteCode Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ByteCode.Identifiers Property

ByteCode.Identifiers Property
[image]

Gets the list with all identifiers within the code. There is no guarantee that this list will contain unique entries, thus, if an identifier is encountered several times in the initial sequence, it will appear several times in the returned list.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public string[] Identifiers { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Identifiers As String()

Property Value

A list with the identifiers in the code.

See Also

ByteCode Members
ByteCode Class
MindFusion.Scripting Namespace


MindFusion.Scripting.CompileOptions Class

CompileOptions Class
[image]

Contains options for the Compiler.Compile method.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public class CompileOptions

Visual Basic [image] Copy Code

Public Class CompileOptions

Inheritance Hierarchy

System.Object
MindFusion.Scripting.CompileOptions

See Also

CompileOptions Members
MindFusion.Scripting Namespace


MindFusion.Scripting.CompileOptions Members

CompileOptions Members
Constructors Properties
[image]

Contains options for the Compiler.Compile method.

The following tables list the members exposed by the CompileOptions type.

Public Constructors

Name | Description
CompileOptions | Initializes a new instance of the CompileOptions class.

Public Properties

Name | Description
InterpretCircumflexAsPower | Gets or sets a value indicating whether circumflex symbols (^) are interpreted as raising to power, rather than exclusive-OR. Raising to power also has different priority than XOR.
InterpretExclamationAsReference | Gets or sets a value indicating whether exclamation marks (!) are interpreted as references, rather than NOT.
Normalize | Gets or sets a value indicating whether to encase source in square brackets if it is not encased already.

See Also

CompileOptions Class
MindFusion.Scripting Namespace


MindFusion.Scripting.CompileOptions Constructor

CompileOptions Constructor
[image]

Initializes a new instance of the CompileOptions class.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public CompileOptions ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CompileOptions Class
MindFusion.Scripting Namespace


MindFusion.Scripting.CompileOptions Properties

CompileOptions Properties
[image]

Public Properties

Name | Description
InterpretCircumflexAsPower | Gets or sets a value indicating whether circumflex symbols (^) are interpreted as raising to power, rather than exclusive-OR. Raising to power also has different priority than XOR.
InterpretExclamationAsReference | Gets or sets a value indicating whether exclamation marks (!) are interpreted as references, rather than NOT.
Normalize | Gets or sets a value indicating whether to encase source in square brackets if it is not encased already.

See Also

CompileOptions Class
MindFusion.Scripting Namespace


MindFusion.Scripting.CompileOptions.InterpretCircumflexAsPower Property

CompileOptions.InterpretCircumflexAsPower Property
[image]

Gets or sets a value indicating whether circumflex symbols (^) are interpreted as raising to power, rather than exclusive-OR. Raising to power also has different priority than XOR.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public bool InterpretCircumflexAsPower { get; set; }

Visual Basic [image] Copy Code

Public Property InterpretCircumflexAsPower As Boolean

Property Value

A boolean value. The default is false.

See Also

CompileOptions Members
CompileOptions Class
MindFusion.Scripting Namespace


MindFusion.Scripting.CompileOptions.InterpretExclamationAsReference Property

CompileOptions.InterpretExclamationAsReference Property
[image]

Gets or sets a value indicating whether exclamation marks (!) are interpreted as references, rather than NOT.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public bool InterpretExclamationAsReference { get; set; }

Visual Basic [image] Copy Code

Public Property InterpretExclamationAsReference As Boolean

Property Value

A bolean value. The default is false.

See Also

CompileOptions Members
CompileOptions Class
MindFusion.Scripting Namespace


MindFusion.Scripting.CompileOptions.Normalize Property

CompileOptions.Normalize Property
[image]

Gets or sets a value indicating whether to encase source in square brackets if it is not encased already.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public bool Normalize { get; set; }

Visual Basic [image] Copy Code

Public Property Normalize As Boolean

Property Value

A boolean value. The default is true.

See Also

CompileOptions Members
CompileOptions Class
MindFusion.Scripting Namespace


MindFusion.Scripting.Compiler Class

Compiler Class
[image]

Provides methods for compiling expressions to byte code.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public sealed class Compiler

Visual Basic [image] Copy Code

Public NotInheritable Class Compiler

Inheritance Hierarchy

System.Object
MindFusion.Scripting.Compiler

See Also

Compiler Members
MindFusion.Scripting Namespace


MindFusion.Scripting.Compiler Members

Compiler Members
Methods
[image]

Provides methods for compiling expressions to byte code.

The following tables list the members exposed by the Compiler type.

Public Methods

Name | Description
Compile | Overloaded. Compiles a string expression into ByteCode.

See Also

Compiler Class
MindFusion.Scripting Namespace


MindFusion.Scripting.Compiler Methods

Compiler Methods
[image]

Public Methods

Name | Description
Compile | Overloaded. Compiles a string expression into ByteCode.

See Also

Compiler Class
MindFusion.Scripting Namespace


MindFusion.Scripting.Compiler.Compile Method

Compiler.Compile Method
[image]

Compiles a string expression into ByteCode.

Overload List

Name | Description
Compiler.Compile (String) | Returns a ByteCode object corresponding to the specified source code. The returned byte code can be subsequently evaluated by calling its Evaluate method.
Compiler.Compile (String, Boolean) | Returns a ByteCode object corresponding to the specified source code. The returned byte code can be subsequently evaluated by calling its Evaluate method.
Compiler.Compile (String, CompileOptions) | Returns a ByteCode object corresponding to the specified source code. The returned byte code can be subsequently evaluated by calling its Evaluate method.

See Also

Compiler Members
Compiler Class
MindFusion.Scripting Namespace


MindFusion.Scripting.Compiler.Compile Method (String)

Compiler.Compile Method (String)
See Also
[image]

Returns a ByteCode object corresponding to the specified source code. The returned byte code can be subsequently evaluated by calling its Evaluate method.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public static ByteCode Compile (
string source
)

Visual Basic [image] Copy Code

Public Shared Function Compile ( _
source As String _
) As ByteCode

Parameters

source

The script to compile.

Return Value

A ByteCode instance representing the compiled script.

See Also

Compile Method Overload List
Compiler Members
Compiler Class
MindFusion.Scripting Namespace


MindFusion.Scripting.Compiler.Compile Method (String, Boolean)

Compiler.Compile Method (String, Boolean)
See Also
[image]

Returns a ByteCode object corresponding to the specified source code. The returned byte code can be subsequently evaluated by calling its Evaluate method.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public static ByteCode Compile (
string source,
bool normalize
)

Visual Basic [image] Copy Code

Public Shared Function Compile ( _
source As String, _
normalize As Boolean _
) As ByteCode

Parameters

source

The script to compile.

normalize
true to encase source in square brackets if it is not encased already; otherwise, false.

Return Value

A ByteCode instance representing the compiled script.

See Also

Compile Method Overload List
Compiler Members
Compiler Class
MindFusion.Scripting Namespace


MindFusion.Scripting.Compiler.Compile Method (String, CompileOptions)

Compiler.Compile Method (String, CompileOptions)
See Also
[image]

Returns a ByteCode object corresponding to the specified source code. The returned byte code can be subsequently evaluated by calling its Evaluate method.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public static ByteCode Compile (
string source,
CompileOptions options
)

Visual Basic [image] Copy Code

Public Shared Function Compile( _
source As String, _
options As CompileOptions _
) As ByteCode

Parameters

source

The script to compile.

options

The compilation options.

Return Value

The compiled script.

See Also

Compile Method Overload List
Compiler Members
Compiler Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs Class

EvaluateFunctionEventArgs Class
[image]

Contains the arguments passed to DispatchFunctionCall event handlers.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public class EvaluateFunctionEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class EvaluateFunctionEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scripting.EvaluateFunctionEventArgs

See Also

EvaluateFunctionEventArgs Members
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs Members

EvaluateFunctionEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to DispatchFunctionCall event handlers.

The following tables list the members exposed by the EvaluateFunctionEventArgs type.

Public Constructors

Name | Description
EvaluateFunctionEventArgs | Initializes a new instance of the EvaluateFunctionEventArgs class.

Public Properties

Name | Description
Arguments | Gets the list of the function's arguments.
Name | Gets the name of the function to evaluate.
Param | Gets the user-defined object set to the EvaluationContext.DispatchFunctionParam.
Result | Gets or sets the result of the function evaluation. An attempt to get the value of this property before it was set results in an exception.

See Also

EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs Constructor

EvaluateFunctionEventArgs Constructor
[image]

Initializes a new instance of the EvaluateFunctionEventArgs class.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public EvaluateFunctionEventArgs (
string name,
Object[] arguments,
Object param
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
arguments() As Object, _
param As Object _
)

Parameters

name

The name of the function.

arguments

The list of arguments to pass to the function.

param

An object that should be passed as an argument to the function evaluation callback.

See Also

EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs Properties

EvaluateFunctionEventArgs Properties
[image]

Public Properties

Name | Description
Arguments | Gets the list of the function's arguments.
Name | Gets the name of the function to evaluate.
Param | Gets the user-defined object set to the EvaluationContext.DispatchFunctionParam.
Result | Gets or sets the result of the function evaluation. An attempt to get the value of this property before it was set results in an exception.

See Also

EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs.Arguments Property

EvaluateFunctionEventArgs.Arguments Property
[image]

Gets the list of the function's arguments.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Object[] Arguments { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Arguments As Object()

Property Value

The list of arguments of the function; or an empty list if the function does not accept arguments.

See Also

EvaluateFunctionEventArgs Members
EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs.Name Property

EvaluateFunctionEventArgs.Name Property
[image]

Gets the name of the function to evaluate.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

A string representing the function name, as it appears in the expression.

See Also

EvaluateFunctionEventArgs Members
EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs.Param Property

EvaluateFunctionEventArgs.Param Property
[image]

Gets the user-defined object set to the EvaluationContext.DispatchFunctionParam.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Object Param { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Param As Object

Property Value

An object representing an user-defined parameter.

See Also

EvaluateFunctionEventArgs Members
EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs.Result Property

EvaluateFunctionEventArgs.Result Property
[image]

Gets or sets the result of the function evaluation. An attempt to get the value of this property before it was set results in an exception.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Object Result { get; set; }

Visual Basic [image] Copy Code

Public Property Result As Object

Property Value

An object representing the function result.

Remarks

Functions always need to return values. If the event handler does not set Result, an exception will be thrown. null (Nothing in Visual Basic) is a valid return value.

See Also

EvaluateFunctionEventArgs Members
EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Class

EvaluationContext Class
[image]

Provides a context for evaluating a byte code.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public class EvaluationContext

Visual Basic [image] Copy Code

Public Class EvaluationContext

Inheritance Hierarchy

System.Object
MindFusion.Scripting.EvaluationContext

See Also

EvaluationContext Members
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Members

EvaluationContext Members
Constructors Properties Methods Events
[image]

Provides a context for evaluating a byte code.

The following tables list the members exposed by the EvaluationContext type.

Public Constructors

Name | Description
EvaluationContext | Overloaded. Initializes a new instance of the EvaluationContext class.

Public Properties

Name | Description
CultureInfo | Gets or sets the culture associated with the context.
DispatchFunctionParam | Gets or sets a user-defined object passed to the DispatchFunctionCall event.
LocalVars | Gets a collection with defined variables and their values.

Public Methods

Name | Description
EvaluateIdentifier | Evaluates the identifier with the specified name.
EvaluateMember | Evaluates the member with the specified name against the specified target.
EvaluateQuantity | Evaluates the specified quanitity in the specified unit.
InvokeFunction | Invokes the function with the specified name.
ResolveObject | Returns the object with the specified name.
ResolveReference | Returns the object representing the specified reference.

Protected Methods

Name | Description
OnDispatchFunctionCall | Raises the DispatchFunctionCall event.
OnParseObject | Raises the ParseObject event.

Public Events

Name | Description
DispatchFunctionCall | Raised by the EvaluationContext when a function name cannot be recognized as one of the built-in functions to allow clients to evaluate the function call.
ParseObject | Raised by the EvaluationContext when an object needs to be parsed from its string representation and the parser is either not able to parse it or not able to create an object of the respective type.

See Also

EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Constructor

EvaluationContext Constructor
[image]

Initializes a new instance of the EvaluationContext class.

Overload List

Name | Description
EvaluationContext (Object) | Initializes a new instance of the EvaluationContext class for the specified object.
EvaluationContext (Object, CultureInfo) | Initializes a new instance of the EvaluationContext class for the specified object and culture.

See Also

EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Constructor (Object)

EvaluationContext Constructor (Object)
See Also
[image]

Initializes a new instance of the EvaluationContext class for the specified object.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public EvaluationContext (
Object target
)

Visual Basic [image] Copy Code

Public New ( _
target As Object _
)

Parameters

target
The target object of the byte code evaluation.

Remarks

The target is used when evaluating identifiers within the expression. If an identifier is not recognized as local variable or a predefined keyword, the identifier is tested as a property against the target object. In addition the keyword this is also evaluated to the target object.

See Also

EvaluationContext Constructor Overload List
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Constructor (Object, CultureInfo)

EvaluationContext Constructor (Object, CultureInfo)
See Also
[image]

Initializes a new instance of the EvaluationContext class for the specified object and culture.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public EvaluationContext (
Object target,
CultureInfo cultureInfo
)

Visual Basic [image] Copy Code

Public New ( _
target As Object, _
cultureInfo As CultureInfo _
)

Parameters

target

The target object of the byte code evaluation.

cultureInfo
The culture associated with the context.

Remarks

The target is used when evaluating identifiers within the expression. If an identifier is not recognized as local variable or a predefined keyword, the identifier is tested as a property against the target object. In addition the keyword this is also evaluated to the target object.

See Also

EvaluationContext Constructor Overload List
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Methods

EvaluationContext Methods
[image]

Public Methods

Name | Description
EvaluateIdentifier | Evaluates the identifier with the specified name.
EvaluateMember | Evaluates the member with the specified name against the specified target.
EvaluateQuantity | Evaluates the specified quanitity in the specified unit.
InvokeFunction | Invokes the function with the specified name.
ResolveObject | Returns the object with the specified name.
ResolveReference | Returns the object representing the specified reference.

Protected Methods

Name | Description
OnDispatchFunctionCall | Raises the DispatchFunctionCall event.
OnParseObject | Raises the ParseObject event.

See Also

EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.EvaluateIdentifier Method

EvaluationContext.EvaluateIdentifier Method
[image]

Evaluates the identifier with the specified name.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public virtual Object EvaluateIdentifier (
string name
)

Visual Basic [image] Copy Code

Public Overridable Function EvaluateIdentifier( _
name As String _
) As Object

Parameters

name

The identifier to evaluate.

Return Value

The result of the evaluation.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.EvaluateMember Method

EvaluationContext.EvaluateMember Method
[image]

Evaluates the member with the specified name against the specified target.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public virtual Object EvaluateMember (
Object target,
string name,
bool last
)

Visual Basic [image] Copy Code

Public Overridable Function EvaluateMember( _
target As Object, _
name As String, _
last As Boolean _
) As Object

Parameters

target

The target object.

name

The name of the member.

last

Indicates whether the resolved member is the last in a sequence of member references. For example, in the following expression "A.B.C", when A.B is being resolved, last is set to false, and when R.C is being resolved (where R is the value of A.B), last is set to true.

Return Value

The value of the member.

Remarks

Member references are evaluated automatically. This method is called when a member references could not be resolved through reflection.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.EvaluateQuantity Method

EvaluationContext.EvaluateQuantity Method
[image]

Evaluates the specified quanitity in the specified unit.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public virtual double EvaluateQuantity (
double value,
string unit
)

Visual Basic [image] Copy Code

Public Overridable Function EvaluateQuantity( _
value As Double, _
unit As String _
) As Double

Parameters

value

The value to evaluate.

unit

The unit of the value.

Return Value

The evaluated quantity.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.InvokeFunction Method

EvaluationContext.InvokeFunction Method
[image]

Invokes the function with the specified name.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public virtual Object InvokeFunction (
string name,
Object[] p
)

Visual Basic [image] Copy Code

Public Overridable Function InvokeFunction( _
name As String, _
p() As Object _
) As Object

Parameters

name

The name of the function to invoke.

p

The list of arguments of the function.

Return Value

The result of the invocation.

Remarks

If the specified name does not match any of the built-in functions, the DispatchFunctionCall is raised.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.OnDispatchFunctionCall Method

EvaluationContext.OnDispatchFunctionCall Method
[image]

Raises the DispatchFunctionCall event.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

protected virtual void OnDispatchFunctionCall (
EvaluateFunctionEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDispatchFunctionCall ( _
e As EvaluateFunctionEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.OnParseObject Method

EvaluationContext.OnParseObject Method
[image]

Raises the ParseObject event.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

protected virtual void OnParseObject (
ParseObjectEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnParseObject ( _
e As ParseObjectEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.ResolveObject Method

EvaluationContext.ResolveObject Method
[image]

Returns the object with the specified name.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public virtual Object ResolveObject (
string name
)

Visual Basic [image] Copy Code

Public Overridable Function ResolveObject( _
name As String _
) As Object

Parameters

name

The name of the object.

Return Value

The found object.

Remarks

If this method returns null (Nothing in Visual Basic), the object is looked for in the underlying list with local variables.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.ResolveReference Method

EvaluationContext.ResolveReference Method
[image]

Returns the object representing the specified reference.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public virtual Object ResolveReference (
string target,
string[] fields
)

Visual Basic [image] Copy Code

Public Overridable Function ResolveReference( _
target As String, _
fields() As String _
) As Object

Parameters

target

The name of the object.

fields

A sequence of fields contained in the reference.

Return Value

The resolved object.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Properties

EvaluationContext Properties
[image]

Public Properties

Name | Description
CultureInfo | Gets or sets the culture associated with the context.
DispatchFunctionParam | Gets or sets a user-defined object passed to the DispatchFunctionCall event.
LocalVars | Gets a collection with defined variables and their values.

See Also

EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.CultureInfo Property

EvaluationContext.CultureInfo Property
[image]

Gets or sets the culture associated with the context.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public CultureInfo CultureInfo { get; set; }

Visual Basic [image] Copy Code

Public Property CultureInfo As CultureInfo

Property Value

An instance of the .NET CultureInfo class.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.DispatchFunctionParam Property

EvaluationContext.DispatchFunctionParam Property
[image]

Gets or sets a user-defined object passed to the DispatchFunctionCall event.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Object DispatchFunctionParam { get; set; }

Visual Basic [image] Copy Code

Public Property DispatchFunctionParam As Object

Property Value

Any System.Object.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.LocalVars Property

EvaluationContext.LocalVars Property
[image]

Gets a collection with defined variables and their values.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Dictionary<string, Object> LocalVars { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LocalVars As Dictionary(Of String, Object)

Property Value

A dictionary with variables and their values.

Remarks

After a byte code is evaluated within this context, LocalVars is updated with all variables declared in the code.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Events

EvaluationContext Events
[image]

Public Events

Name | Description
DispatchFunctionCall | Raised by the EvaluationContext when a function name cannot be recognized as one of the built-in functions to allow clients to evaluate the function call.
ParseObject | Raised by the EvaluationContext when an object needs to be parsed from its string representation and the parser is either not able to parse it or not able to create an object of the respective type.

See Also

EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.DispatchFunctionCall Event

EvaluationContext.DispatchFunctionCall Event
[image]

Raised by the EvaluationContext when a function name cannot be recognized as one of the built-in functions to allow clients to evaluate the function call.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public event EventHandler<EvaluateFunctionEventArgs> DispatchFunctionCall

Visual Basic [image] Copy Code

Public Event DispatchFunctionCall As EventHandler(Of EvaluateFunctionEventArgs)

Event Data

DispatchFunctionCall event handlers receive an argument of type EvaluateFunctionEventArgs.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.ParseObject Event

EvaluationContext.ParseObject Event
[image]

Raised by the EvaluationContext when an object needs to be parsed from its string representation and the parser is either not able to parse it or not able to create an object of the respective type.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public event EventHandler<ParseObjectEventArgs> ParseObject

Visual Basic [image] Copy Code

Public Event ParseObject As EventHandler(Of ParseObjectEventArgs)

Event Data

ParseObject event handlers receive an argument of type EvaluateFunctionEventArgs.

Remarks

A common case for this event to occur is when parsing a color object - where the actual platform-specific type is not known beforehand.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ParseObjectEventArgs Class

ParseObjectEventArgs Class
[image]

Contains the arguments passed to ParseObject event handlers.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public class ParseObjectEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ParseObjectEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scripting.ParseObjectEventArgs

See Also

ParseObjectEventArgs Members
MindFusion.Scripting Namespace


MindFusion.Scripting.ParseObjectEventArgs Members

ParseObjectEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to ParseObject event handlers.

The following tables list the members exposed by the ParseObjectEventArgs type.

Public Constructors

Name | Description
ParseObjectEventArgs | Initializes a new instance of the ParseObjectEventArgs class.

Public Properties

Name | Description
Result | Gets or sets the parsed object.
ValueAsString | Gets the string representation of the object to be parsed.

See Also

ParseObjectEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ParseObjectEventArgs Constructor

ParseObjectEventArgs Constructor
[image]

Initializes a new instance of the ParseObjectEventArgs class.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public ParseObjectEventArgs (
string valueAsString
)

Visual Basic [image] Copy Code

Public New ( _
valueAsString As String _
)

Parameters

valueAsString

The string representation of the object to parse.

See Also

ParseObjectEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ParseObjectEventArgs Properties

ParseObjectEventArgs Properties
[image]

Public Properties

Name | Description
Result | Gets or sets the parsed object.
ValueAsString | Gets the string representation of the object to be parsed.

See Also

ParseObjectEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ParseObjectEventArgs.Result Property

ParseObjectEventArgs.Result Property
[image]

Gets or sets the parsed object.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Object Result { get; set; }

Visual Basic [image] Copy Code

Public Property Result As Object

Property Value

A System.Object representing the parsed object.

See Also

ParseObjectEventArgs Members
ParseObjectEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ParseObjectEventArgs.ValueAsString Property

ParseObjectEventArgs.ValueAsString Property
[image]

Gets the string representation of the object to be parsed.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public string ValueAsString { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ValueAsString As String

Property Value

A string representing the object.

See Also

ParseObjectEventArgs Members
ParseObjectEventArgs Class
MindFusion.Scripting Namespace


Technical Support

Technical Support

Detailed information about everything connected with software products offered by MindFusion - online documentation, demos, information about forthcoming products can be found at http://www.mindfusion.eu [image] . The site is updated every day, so make sure you visit it regularly to catch up with the newest from us.

Apart from that, MindFusion employs a dedicated and technically proficient support team. This guarantees that all your questions and inquiries will be answered in quick and professional manner. They can be reached by e-mail at support@mindfusion.eu [image] or by phone at +359 889 199 729.

You can post a question on the MindFusion.Reporting discussion board here:

http://mindfusion.eu/Forum/YaBB.pl?board=reporting_winforms_disc

or visit our Help Desk site:

http://www.mindfusion.eu/HelpDesk/index.php

We will be happy to hear any suggestions and recommendations you might have regarding MindFusion.Reporting. We take in account the opinion of every single person who has shown interest in our products.


MindFusion Products

MindFusion Products

MindFusion offers various programming components for different platforms. Below is a list of our products with links to their sections on our website as well link to download a trial version. Clients that have already purchased a product use an increasing discount for each subsequent one.

Diagramming | Links
Diagramming for WPF | Product Information Download
Diagramming for Silverlight | Product Information Download
Diagramming for WinForms | Product Information Download
Diagramming for ASP.NET | Product Information Download
Diagramming for ActiveX | Product Information Download
Diagramming for .NET Compact | Product Information Download
Diagramming for Java Swing | Product Information Download
Diagramming for JavaScript | Product Information Download
DiagramViewer for iOS/Cocoa Touch | Product Information Download
DiagramViewer for Android | Product Information Download
Diagramming for Xamarin | Product Information

Charting | Links
Charting for WPF | Product Information Download
Charting for Silverlight | Product Information Download
Charting for WinForms | Product Information Download
Charting for ASP.NET | Product Information Download

Scheduling | Links
Scheduling for WinForms | Product Information Download
Scheduling for ASP.NET | Product Information Download
Scheduling for .NET Compact | Product Information Download
Scheduling for WPF | Product Information Download
Scheduling for Silverlight | Product Information Download
Scheduling for Java Swing | Product Information Download
Scheduling for Xamarin | Product Information

Spreadsheet | Links
Spreadsheet for WinForms | Product Information Download
Spreadsheet for WPF | Product Information Download

Reporting | Links
Reporting for WinForms | Product Information Download
Reporting for WPF | Product Information Download
Reporting for Silverlight | Product Information Download

Mapping | Links
Mapping for WinForms | Product Information Download
Mapping for WPF | Product Information Download
Mapping for Silverlight | Product Information Download

Suites | Links
Pack for WPF | Product Information Download
Pack for WinForms | Product Information Download
Pack for ASP.NET | Product Information Download
Pack for Java FX | Product Information Download
Pack for Scheduling | Product Information Download
Pack for Silverlight | Product Information Download


Acknowledgements

Acknowledgements

Copyright (c) 2000,2001,2002,2003 ymnk, JCraft,Inc. All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice,
this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in
the documentation and/or other materials provided with the distribution.

3. The names of the authors may not be used to endorse or promote products
derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL JCRAFT,
INC. OR ANY CONTRIBUTORS TO THIS SOFTWARE BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA,
OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.